DIHtmlGooglePlugin 1.00 Help: All Units

All Units

Name | Description
DIHtmlGooglePlugin | Contains TDIHtmlGooglePlugin plugin to extract properties of Google web search results.
DIHtmlGooglePlugin 1.00 Help
Copyright Ralf Junker 2003
http://www.zeitungsjunge.de/delphi/
HTML Help generated by DIPasDoc


DIHtmlGooglePlugin 1.00 Help: DIHtmlGooglePlugin

Unit DIHtmlGooglePlugin

Description

Contains TDIHtmlGooglePlugin plugin to extract properties of Google web search results.

The DIHtmlGooglePlugin unit is part of the DIHtmlParser Library.

Classes, Interfaces and Objects

Name | Description
Class TDIGoogleResult |
Class TDIHtmlGooglePlugin | TDIHtmlParser plugin to parse Google web search result pages.

Functions and Procedures

Overview

procedure Register;

Description

procedure Register;

Enumerations

TDIGoogleState
Various states of parsing a Google results page. Internal use only.
 | gsQuery
 | gsAfterQuery
 | gsInResults
 | gsTitle
 | gsAfterTitle
 | gsFileFormat
 | gsAbstract
 | gsAfterAbstract
 | gsDescription
 | gsCategory
 | gsProperties
 | gsAfterProperties
 | gsAfterResults

Author

Ralf Junker <delphi@zeitungsjunge.de>


DIHtmlGooglePlugin 1.00 Help: DIHtmlGooglePlugin: Class TDIGoogleResult

Class TDIGoogleResult

Unit

DIHtmlGooglePlugin

Declaration

type TDIGoogleResult = class(TObject)

Description

Stores the properties of a single Google search result.

Methods

Overview

Public procedure AssignFromPlugin(const Plugin: TDIHtmlGooglePlugin);

Description

Public procedure AssignFromPlugin(const Plugin: TDIHtmlGooglePlugin);

Fills an instance of AssignFromPlugin from a TDIHtmlGooglePlugin.

Properties

Overview

Public | property Abstract: WideString;
Public | property CacheUrl: WideString;
Public | property Category: WideString;
Public | property CategoryUrl: WideString;
Public | property Description: WideString;
Public | property FileFormat: WideString;
Public | property FileHtmlUrl: WideString;
Public | property LinkUrl: WideString;
Public | property Properties: WideString;
Public | property RelatedUrl: WideString;
Public | property Title: WideString;
Public | property TranslationUrl: WideString;

Description

Public property Abstract: WideString;

Public property CacheUrl: WideString;

Public property Category: WideString;

Public property CategoryUrl: WideString;

Public property Description: WideString;

Public property FileFormat: WideString;

Public property FileHtmlUrl: WideString;

Public property LinkUrl: WideString;

Public property Properties: WideString;

Public property RelatedUrl: WideString;

Public property Title: WideString;

Public property TranslationUrl: WideString;


DIHtmlGooglePlugin 1.00 Help: DIHtmlGooglePlugin: Class TDIHtmlGooglePlugin

Class TDIHtmlGooglePlugin

Unit

DIHtmlGooglePlugin

Declaration

type TDIHtmlGooglePlugin = class(TDIHtmlParserPlugin)

Description

TDIHtmlParser plugin to parse Google web search result pages.

TDIHtmlGooglePlugin extracts the individual results from a Google web search results page and fires an OnResult event for each result encounterd. The result's properties can then be read from the TDIHtmlGooglePlugin's properties like Title, LinkUrl, etc.

The intention of TDIHtmlGooglePlugin is to provide an advanced example of how to use DIHtmlParser plugins. While it was tested to work fine with many Google web search result pages, there is no guarantee that it will do so with all pages, especially not since Google might change its page layout sometime in the future.

Required tag and attribute registrations:

  • RegisterTag (TAG_A, TAG_A_ID);
  • RegisterTag (TAG_BR, TAG_BR_ID);
  • RegisterTag (TAG_FONT, TAG_FONT_ID);
  • RegisterTag (TAG_INPUT, TAG_INPUT_ID);
  • RegisterTag (TAG_SPAN, TAG_SPAN_ID);
  • RegisterATTRIB (ATTRIB_COLOR, ATTRIB_COLOR_ID);
  • RegisterATTRIB (ATTRIB_HREF, ATTRIB_HREF_ID);
  • RegisterATTRIB (ATTRIB_NAME, ATTRIB_NAME_ID);
  • RegisterATTRIB (ATTRIB_TYPE, ATTRIB_TYPE_ID);
  • RegisterATTRIB (ATTRIB_VALUE, ATTRIB_VALUE_ID);

Methods

Overview

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Protected | procedure ClearResult;
Protected | procedure HandleComment(var Show: Boolean); override;
Protected | procedure HandleHtmlTag(var Show: Boolean); override;
Protected | procedure HandleText(var Show: Boolean); override;
Public | procedure Reset; override;

Description

Public constructor Create(AOwner: TComponent); override;

Public destructor Destroy; override;

Protected procedure ClearResult;

Protected procedure HandleComment(var Show: Boolean); override;

Protected procedure HandleHtmlTag(var Show: Boolean); override;

Protected procedure HandleText(var Show: Boolean); override;

Public procedure Reset; override;

Properties

Overview

Public | property Abstract: WideString;
Public | property CacheUrl: WideString;
Public | property Category: WideString;
Public | property CategoryUrl: WideString;
Public | property Description: WideString;
Public | property FileFormat: WideString;
Public | property FileHtmlUrl: WideString;
Published | property HtmlParser;
Public | property LinkUrl: WideString;
Published | property OnResult: TDIHtmlParserPluginNotifyEvent;
Public | property Properties: WideString;
Public | property Query: WideString;
Public | property RelatedUrl: WideString;
Public | property Title: WideString;
Public | property TranslationUrl: WideString;

Description

Public property Abstract: WideString;

Public property CacheUrl: WideString;

Public property Category: WideString;

Public property CategoryUrl: WideString;

Public property Description: WideString;

Public property FileFormat: WideString;

Public property FileHtmlUrl: WideString;

Published property HtmlParser;

Public property LinkUrl: WideString;

Published property OnResult: TDIHtmlParserPluginNotifyEvent;

Public property Properties: WideString;

Public property Query: WideString;

Public property RelatedUrl: WideString;

Public property Title: WideString;

Public property TranslationUrl: WideString;


DIHtmlGooglePlugin 1.00 Help: Class Hierarchy

Class Hierarchy

  • TDIHtmlParserPlugin
    • TDIHtmlGooglePlugin
  • TObject
    • TDIGoogleResult


DIHtmlGooglePlugin 1.00 Help: All Classes, Interfaces and Objects

All Classes, Interfaces and Objects

Name | Unit | Description
TDIGoogleResult | DIHtmlGooglePlugin | Stores the properties of a single Google search result.
TDIHtmlGooglePlugin | DIHtmlGooglePlugin | TDIHtmlParser plugin to parse Google web search result pages.


DIHtmlGooglePlugin 1.00 Help: All Types

All Types

None


DIHtmlGooglePlugin 1.00 Help: All Enumerations

All Enumerations

Name | Unit | Description
TDIGoogleState | DIHtmlGooglePlugin | Various states of parsing a Google results page. Internal use only.


DIHtmlGooglePlugin 1.00 Help: All Variables

All Variables

None


DIHtmlGooglePlugin 1.00 Help: All Constants

All Constants

None


DIHtmlGooglePlugin 1.00 Help: All Functions and Procedures

All Functions and Procedures

Name Unit Description


DIHtmlGooglePlugin 1.00 Help: All Identifiers

All Identifiers

Name | Unit | Description
Register | DIHtmlGooglePlugin |
TDIGoogleResult | DIHtmlGooglePlugin | Stores the properties of a single Google search result.
TDIGoogleState | DIHtmlGooglePlugin | Various states of parsing a Google results page. Internal use only.
TDIHtmlGooglePlugin | DIHtmlGooglePlugin | TDIHtmlParser plugin to parse Google web search result pages.


DIHtmlGooglePlugin 1.00 Help: Legend

Legend

Private | Private
Protected | Protected
Public | Public
Published | Published