Windows Media SDK

There are six major components in the Microsoft® Windows Media™ Software Development Kit (SDK).

Microsoft® Windows Media™ Services SDK | Supports programmatically managing unicast and multicast streaming services.
Microsoft® Windows Media™ Encoder SDK | Supports the Automation interface for programmatically configuring and controlling Microsoft® Windows Media™ Encoder.
Microsoft® Windows Media™ Player SDK | Supports using the Microsoft® Windows Media™ Player ActiveX® control to add multimedia playback capabilities to COM-based documents and applications, as well as Web pages.
Microsoft® Windows Media™ Metafiles | Supports the creation of Windows Media metafile playlists, including ad insertion, banner graphics, and seamless stream switching.
Microsoft® Windows Media™ Format SDK | Supports the reading, writing, and editing of Windows Media™ files, along with downloading of files to portable devices.
Microsoft® Windows Media™ Rights Manager SDK | Supports protecting Windows Media files and issuing licenses for them to maintain copyrights.

Overview

Microsoft® Windows Media™ Technologies is a powerful solution for streaming multimedia content across corporate intranets and the Internet. The Windows Media™ platform supports development of Web sites or Web applications that stream audio, video, and script commands as a continuous flow of data. The ability to stream multimedia means the client can render content while that content is being received over the network without downloading it first. Streaming is superior to downloading multimedia files because it greatly reduces the wait time and storage requirements of the client computer. Streaming also opens the door to presentations of unlimited length, as well as live broadcasts. This SDK is designed for building applications on top of the Windows Media platform.

Windows Media Technologies supports data delivery over a wide variety of networks and protocols. Windows Media™ Format describes a transmission file format for arranging and organizing synchronized multimedia data. It is optimized for streaming the data over networks and rendering the data on a client computer. Windows Media Format specifies the format of live presentations that are being streamed across the network as well as prerecorded files.

One specialized use of Windows Media files is in streaming audio files compressed with the Windows Media™ Audio codec (compression/decompression system). This codec combines very high-quality audio output with significant improvements in file compression. Of great importance to many content providers is that these files can be made much more secure from piracy by using the digital rights management (DRM) encryption system.

Servers running Microsoft® Windows Media™ Services support unicasting (sending a stream to each client requesting it) and multicasting (broadcasting a single stream across the network so that it can be rendered by many clients at the same time). Unicasting enables the user to start, stop, pause, fast-forward, or rewind stored stream data at will (if the stream is indexed). However, sending a stream to each client can require a lot of bandwidth. Multicasting, on the other hand, makes better use of available bandwidth. Much like tuning into a TV or radio broadcast, multicasting restricts the user's ability to pause, rewind, or fast-forward the presentation.

Developing Applications

Windows Media Technologies tools and services, along with Windows Media Player, form an ideal platform for creating end-to-end Web- or Microsoft® Windows®-based multimedia streaming applications that are cost-effective. The Windows Media Player client can also be programmed for a variety of Web browsers.

The functionality exposed by Windows Media Technologies offers exciting opportunities to developers for creating compelling multimedia streaming applications. This SDK describes the programmable interfaces that interact with the various Windows Media component services and tools, and discusses techniques for using them.

Solutions Samples

The Windows Media Technologies Solutions Samples is a collection of samples that demonstrate the capabilities of the Windows Media technology. The samples range from server utilities and content tools to Web-based applications that can be used as a starting point for your Windows Media development. All the samples are documented and provide a starting point for building customized Windows Media™ applications.

Document Conventions

This SDK uses the following document conventions.

Convention | Description
Monospace
 Indicates syntax or code examples.
Bold | Indicates a function, structure, interface, method, event, property, or object name. Syntax elements shown in bold type must be typed exactly as shown.
Italic | Indicates placeholders, most often as attribute parameter names. Placeholders represent information that must be supplied by the developer.
[ ] Indicates optional syntax items. Type in only the information between the brackets, not the brackets themselves.

© 1996-1999 Microsoft Corporation. All rights reserved.


Legal Notice

Information in this document, including URL and other Internet Web site references, is subject to change without notice. Unless otherwise noted, the example companies, organizations, products, people and events depicted herein are fictitious and no association with any real company, organization, product, person or event is intended or should be inferred. Complying with all applicable copyright laws is the responsibility of the user. Without limiting the rights under copyright, no part of this document may be reproduced, stored in or introduced into a retrieval system, or transmitted in any form or by any means (electronic, mechanical, photocopying, recording, or otherwise), or for any purpose, without the express written permission of Microsoft Corporation.

Microsoft may have patents, patent applications, trademarks, copyrights, or other intellectual property rights covering subject matter in this document. Except as expressly provided in any written license agreement from Microsoft, the furnishing of this document does not give you any license to these patents, trademarks, copyrights, or other intellectual property.

© 1996-1999 Microsoft Corporation. All rights reserved.

Microsoft, MS-DOS, Windows, Windows Media, Windows NT, ActiveX, FrontPage, JScript, Microsoft Press, NetShow, PowerPoint, Visual Basic, Visual C++, Visual InterDev, Visual J++, Win32, and Win32s are either registered trademarks or trademarks of Microsoft Corporation in the U.S.A. and/or other countries.

Premiere is a registered trademark of Adobe Corporation.

The following statements apply only to the Python Language runtime:

Copyright © 1991-1995 by Stichting Mathematisch Centrum, Amsterdam, The Netherlands. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation for any purpose and without fee is hereby granted, provided that the above copyright notice appear in all copies and that both that copyright notice and this permission notice appear in supporting documentation, and that the names of Stichting Mathematisch Centrum or CWI not be used in advertising or publicity pertaining to distribution of the software without specific, written prior permission.

The names of actual companies and products mentioned herein may be the trademarks of their respective owners.