Windows Media Encoder Automation

Windows Media banner art

Windows Media Encoder SDK

Microsoft® Windows Media™ Encoder compresses live or stored audio and video content into Windows Media™ files or streams. It can be used to create multimedia productions from devices attached to your computer, translate audio and video files into Windows Media™ Format, and either save the Windows Media-based content to a file or broadcast it over the Internet. The Windows Media™ Encoder component of the Microsoft® Windows Media™ Software Development Kit (SDK) enables developers to create applications for Windows Media Encoder. The Automation-based API enables developers to create custom user interfaces for the encoder, manage batch process encoding, remotely administer the encoder, and schedule live broadcast events.

This SDK component has not been installed. You can install it from the following location:

Windows Media Encoder SDK

© 2000 Microsoft Corporation. All rights reserved.


Windows Media Services SDK

Microsoft® Windows Media™ Services is the premier platform for delivering high-quality digital media over the Internet or corporate networks. This set of services provides the most scalable, reliable, and manageable server for on-demand and broadcast audio and video. The Windows Media Services component of the Microsoft® Windows Media™ Software Development Kit (SDK) enables developers to create custom administration and monitoring applications, develop e-commerce solutions, and integrate Windows Media Services into other software products.

This SDK component has not been installed. You can install it from the following location:

Windows Media Services SDK

© 2000 Microsoft Corporation. All rights reserved.


Introducing Windows Media Format

Windows Media banner art

Windows Media Format SDK

The Windows Media™ Format component of the Microsoft® Windows Media™ Software Development Kit (SDK) enables developers to create applications for reading, writing, editing, and playing back Windows Media™ files and streams. This SDK component also enables development of applications that securely transfer Windows Media-based content to and from personal computers as well as portable devices.

This SDK component has not been installed. You can install it from the following location:

Windows Media Format SDK

© 2000 Microsoft Corporation. All rights reserved.


Windows Media Rights Manager SDK

The Microsoft® Windows Media™ Rights Manager component of the Microsoft® Windows Media™ Software Development Kit (SDK) is designed for anyone who wants to deliver digital media, such as music and videos, through the Internet in a protected and secure manner. This component provides tools that developers can use to protect digital files and issue licenses so those files can be distributed while maintaining copyright protection. The solutions provided with Windows Media Rights Manager SDK are flexible enough to be easily adapted to any current business model.

This SDK component has not been installed. You can install it from the following location:

Windows Media Rights Manager SDK

© 2000 Microsoft Corporation. All rights reserved.