Nápověda k programu WebGen

Co je WebGen

WebGen je aplikace pro generování HTML aplikace ve tvaru:

elektronického katalogu
e-obchodu
prezentačních stránek
redakčního systému

WebGen je vytvořen jako aplikace produktu firmy Software602 WinBase602 ver.6.1-7.0.
Jedná se o aplikaci pro uživatele, kteří potřebují vytvořit navzájem propojené stránky se stejným vzhledem, snadnou údržbou a aktualizací. Uživatel nemusí mít téměř žádné znalosti z tvorby HTML souboru. Je určena nejen pro obchodníky, kteří chtějí nabízet své zboží prostřednictvím Internetu nebo CD disku, ale i pro ostatní uživatele, kteří potřebují vytvořit vlastní e-katalog nebo www stránky.
Produkt pro svou fukci potřebuje na straně klienta internetový prohlížeč řady 4.0 vyšší. Je nezávislý na poskytovateli Internetu a na aktivní podpoře serveru. Po instalaci stačí nastavit základní parametry, naplnit data z vašeho informačního systému pomocí importu, připravit obrázky zboží a spustit generátor. Vzniklý HTML kód lze publikovat na Internet nebo nahrát na jiný datový nosič.


Jak funguje

Jedná se o databázovou aplikaci, která na základě nastavení vytvoří soubory typu HTML, které obsahují údaje z databází, vzájemné propojení, případně algoritmy na práci elektronického katalogu (e-obchodu). Soubory HTML (pouze e-obchod) obsahují program v jazyce JavaScript, ktrerý umožňuje vytvořit interaktivní stránky (tvorba objednávky).


Jak používat nápovědu

Tato nápověda slouží jednak jako nápověda při práci s programem WebGen a současně jako samostatná příručka k programu. S výhodou lze využít fulltextové vyhledávání.

Při práci s programem se kontextová nápověda se vyvolá klávesou F1.


WebGen.cz - antivirové programy

Zpomalení generování programu

Při současném použití antivirového programu se zapnutou rezidentní ochranou dojde k několikanásobnému prodloužení generování stránek. Příčinou je kontrola nově vznikajících souborů (*.HTM, *.js ...), které generuje program WebGen.cz.

Pro zrychlení práce je vhodné po dobu generování souborů zrušit rezidentní antivirovou kontrolu.


Instalace programu

Před vlastní instalaci programu doporučujeme uzavřít ostatní aplikace.
Po spuštění zkomprimovaného instalačního souboru webgen602xx.exe (xx je číslo verze programu) se objeví okno na rozbalení instalačního programu. Adresář na rozbalení instalace je přednabídnut jako pracovní (C:\WINDOWS\TEMP).
Pro instalaci na počítači s OS Windows2000 doporučujeme pracovní adresář přepsat na jakýkoliv jiný. Předejde se problémům s instalací, která se z 50% vyskytuje.

Po potvrzení tlačítka Start začne rozbalování instalačního programu do zvoleného adresáře a následně se spustí vlastní instalační program setup.exe

Pro pokračování v instalaci se potvrdí tlačítko další. Objeví se okno s přednastaveným adresářem pro vlastní instalaci.

Pokud není důvod jej měnit pokračuje se tlačítkem další.

Pokud se provádí instalace již podruhé (přeinstalace apod.) objeví se okno s touto informací. Doporučujeme potvrdit tlačítko Ano.
Pokud se instaluje poprvé okno se neobjevuje.

Dále následuje okno s výběrem složky.

Tlačítkem Další se objeví konečné nastavení parametrů instalace.

Tlačítkem Další se zahájí vlastní instalační proces.

Na závěr instalace se objeví okno potvrzující ukončení instalace

V záložce WebGen se vytvoří ikony pro spuštění programu WebGen

Popis ikon

  • Konfigurace Winbase602 - konfigurace Winbase602, za normální situace není důvod spouštět a cokoliv měnit
  • WebGen 602.10 - aplikace WebGen verze 602.10
  • WinBase602 Server - server Winbase602, spustí se automaticky spolu s aplikací. Samostatně se nespouští
  • Winbase602 - vývojové prostředí Winbase602. Standardně se neinstaluje a proto nejde samostatně spustit
  • WebGen 602.20A - aplikace WebGen verze 602.20A (v tomto případě jako druhá verze programu)

Spuštění programu - přihlášení

Při spuštění programu se objeví okno pro přihlášení. Uživatel je Anonymous (šipka dolů) a heslo se nevyplňuje.


Záloha dat

Záloda datových souborů do zvoleného adresáře v interním formátu Winbase602.

Nezálohují se obrázky!

Obnova dat


Parametry zálohy

Nastavení adresáře, do kterého se provádí záloha dat. Data jsou uložena do souborů ve vnitřím formátu Winbase602.

Záloha dat Obnova dat


Obnova dat

Obnova dat ze zálohy - vybraného adresáře.

Pozor původní data se přepíšou. Doporučujeme před obnovou dat provést zálohu do jiného adresáře.
Pomocí zálohy a obnovy dat se provádí přechod na jinou verzi programu.
Záloha dat


Import z DBF

Načtení dat (karty zboží, výrobků, služeb) z DBF souboru do aplikace.

Funkce umožňuje načíst data ze souboru DBF do tabulky Zboží podle nastaveného předpisu.
Nastavený přenos jde uložit pro další použití.

Spárování sloupců tabulek:
- v pravé části okna se myší vybere(levé tlačítko) sloupec z DBF souboru
- tlačítkem [image] se provede přiřazení k příslušnému sloupci tabulky zboží
- anebo se název sloupce přímo zapíše

Volby

Formát DBF souboru:
  • dBase 4
  • FoxPro 2
Kódování:
  • Windows EECS
  • Kamenických
  • Latin 2
Způsob importu:
  • Přidat vše
  • Přidat nové
  • Přepsat vše
  • Aktualizovat
Import - export


Přenosy dat mezi dvěma zdroji

WinBase602 obsahuje univerzální nástroj na přenášení dat mezi řadou datových formátů podle popisu zadaného uživatelem nebo automaticky odvozeného ze struktury dat.

Využití
  • přenos dat z prostředí WinBase602 ven (Export dat),
  • přenos dat z jiného prostředí do tabulky WinBase602 (Import dat),
  • přenos z tabulky WinBase602 do jiné tabulky s případnými změnami hodnot,
  • úpravu tabulek a záznamů v jedné tabulce WinBase602 (Modifikace dat):
  • zkušenějším uživatelům jsou k dispozici obecné přenosy z jednoho prostředí do prostředí jiného včetně přenosů z (do) zdroje dat připojeného přes rozhraní ODBC.
Návrhář přenosu dat
Návrhář přenosu dat dovoluje nejprve popsat způsob přenosu a poté data přenést. Po doběhnutí přenosu lze buď návrh přenosu zapomenout, anebo jej lze uložit do databáze pro pozdější použití. Navržený přenos je pak uložen mezi programy a lze jej opětovně provést vyvoláním akce Spustit.

Postup návrhu přenosu
Okno návrháře přenosu se skládá ze čtyř očíslovaných částí. Při návrhu se postupuje shora dolů podle následujícího popisu:

1. Stanovíte Odkud vzít data pro přenos. V levém combu nejprve vyberete druh zdroje dat a pak vpravo:
  • zvolíte buď jeden z nabízených objektů (tabulku z WinBase602 nebo z cizího zdroje dat, odpověď na dotaz),
  • nebo tlačítkem otevřete okno pro volbu vstupního souboru.
2. Stanovíte Kam zapisovat přenášená data. V levém combu nejprve vyberete druh cílového objektu a pak vpravo:
  • buď zvolíte některý nabízený objekt (existující tabulku ve WinBase602 nebo v cizím zdroji dat);
  • nebo zadáte jméno tabulky, která se má vytvořit;
  • anebo tlačítkem otevřete okno pro zadání výstupního souboru (vyberete-li exitující soubor, přenos dat jej - po dotazu - přepíše);
3. Doplníte Detailní popis přenosu jednotlivých hodnot. Tento popis se nevyplňuje, pokud přenášíte do nebo ze souboru ve vnitřním formátu WinBase602 (export / import dat ve vnitřním formátu). Automatický počáteční návrh přenosu lze vytvořit stiskem tlačítka Vytvořit popis. Obsah detailního popisu závisí na tom, odkud a kam přenášíte - viz dále.

4. Zadáte případnou podmínku, kterou musí splnit přenášené záznamy. Pomocí této podmínky lze filtrovat pouze záznamy exportované z tabulky ve WinBase602 nebo z odpovědi na dotaz. Není-li podmínka zadaná, přenesou se všechny záznamy.

Poté tlačítkem Kontrola popisu můžete provést hrubou syntaktickou kontrolu popisu a tlačítkem Přenést data zahájit vlastní přenos. Průběh přenosu lze sledovat na stavové řádce. Stiskem tlačítka Uložit popis se definice tohoto přenosu dat uloží jako speciální typ programu pro další použití.

Textový formát

Při přenosu ze souboru CSV vytvořeného např. v excelu je potřeba přenastavit oddělovač polí na ;. Po vytvoření souboru CSV se tento soubor nesmí v excelu otevřít protože již nejde pro přenos použít.

Podrobnosti přenosu dat jsou popsány v nápovědě dostupné v okně přenosu dat.
Import z DBF


Kontrola databáze

Kontrola a případná oprava databázového souboru. Doporučujeme spustit po nelegálním ukončení programu.


Velikost souboru

Zvětšení databázového souboru. Používá se po té, co se při spuštění serveru (aplikace) objeví hlášení o nedostatku volných clusterů. Program nabídne současnou velikost, která se upraví (směren nahoru).


Konec programu

Ukončení práce s programem WebGen. Současně se ukončí aplikace WebGen a WinBase602 server. Klávesa ALT+F4.
Horké klávesy


Karty

Pořízení, editace a mazání karet. Klávesa CTRL+K

Přehledové okno, které zobrazuje některé vybrané sloupce, umožňuje vybrat množinu záznamů pomocí filtru, setřídění podle zvoleného sloupce (poklepáním na název sloupce).

Popis tlačítek

  • Detail - zobrazí detailní informace o vybrané kartě (obdoba - poklepání na řádku)
  • Obrázek - zobrazí náhledový obrázek k vybrané kartě
  • Smazat kartu - smaže vybranou kartu
  • OK - uzavření okna s uložením změn
  • Odvolat změny - uzavření okna bez uložení změn
  • Zruš filtr - zruší nastavený filtr a zobrazí všechny karty
Klávesou Insert se dostaneme na pořízení nové karty.
Oblast okna nazvaná filtr slouží k výběru podmnožiny podle jednoho nebo více zadaných údajů. U textových údajů (kód, název, výrobce) stačí zadat začátek slova.U číselných údajů (SK, PSK, cena s DPH, Top) se zadává celý údaj.U označovacího čtverce (nové, tip, sleva, provedení, skrýt) mohou nastat tři stavy. Čtverec může být zaškrtnut nebo nezaškrtnut případně může mít nedefinovanou hodnotu.
POZOR pokud použijeme ve filtru označovací čtverec, pro ukončení filtru použijeme tlačítko Zruš filtr.

Detail karty

Popis sloupců

  • Kód - kódové označení karty
  • SK - číselný kód skupiny, v detailu se zobrazí název skupiny a pro zatřídění se použije tlačítko Zatřídění nebo jde použít hromadné zatřídění
  • Název - název karty (80 znaků)
  • Výrobce - název výrobce. Po prvním použití je v další kartě výrobce dostupný v combu. Otevření comba (nabídky) se provede myší nebo klávesou alt+šipka dolů
  • DPH - procento DPH *
  • Cena bez DPH - *
  • Cena s DPH - koncová prodejní cena
  • Stará cena - v případě, že koncová cena se změní, může se zde uvést pro srovnání původní cena
  • Malý obrázek -- jméno souboru. Pro nalistování souboru použijeme tlačítko Malý obr. nebo pravé tl. myši. Pravidla pro jména souboru
  • Velký obrázek -- jméno souboru. Pro nalistování souboru použijeme tlačítko Velký obr. nebo pravé tl. myši. Pravidla pro jména souboru
  • Toplist - pořadí v prodeji. Karty označené pořadovým číslem se jednak dostanou do skupiny nazvané Toplist a současně se podle nastavení mohou objevit na úvodní straně v pravém sloupku.
  • Novinka - příznak pro novou kartu. Karta se dostane do skupiny nazvané Novinky a současně se podle nastavení objeví text u karty.
  • Tip - příznak označující kartu jako tip. Karta se dostane do skupiny nazvané Tipy a současně se bude zobrazovat na úvodní straně. Pokud se označí více karet, tak na úvodní straně se zobrazí vždy náhodně pouze jedna karta.
  • Sleva - karta se do skupiny nazvané Sleva
  • Provedení - označená karta bude při objednání vyžadovat doplnění dalších údajů(např. barva, velikost podle nastavení)
  • Skrýt - karta se nezobrazí na stránkách aplikace
  • Výprodej - označená karta se objeví ve skupině nazvané Výprodej
  • Popis - popis karty. Může obsahovat HTML kód. Zobrazí se volitelně v přehledu nebo detailu.
  • Detailní popis - detailní popis karty. Může obsahovat HTML kód. Zobrazí se volitelně v detailu.

Popis tlačítek

  • EEa - externí editor pro editaci popisu
  • EEb - externí editor pro editaci detailního popisu
  • HTML ? - otevření okna se základními HTML tágy
* - platí pro plátce DPH viz. nastavení

Import z DBF Import - export Hromadné zatřídění


Nastavení pohledu

Volba zobrazených sloupců tabulky Zbozi.

Umožňuje libovolně zvolit sloupce, které se zobrazí v databázové mřížce. Sloupce se přesunují poklepáním na název sloupce.
Vlastní pohled Tabulky


Vlastní pohled

Zobrazení tabulky s vlastním pohledem. Klávesa CTRL+P (horké klávesy)

Obecně platné funkce pro data zobrazené v datové mřížce.
  • Změna pořadí sloupců - levým tlačítkem myši uchopit a přetáhnout název sloupce
  • Zrušení zobrazení sloupce- levým tlačítkem myši kliknout na název sloupce (sloupec se označí) a a klávesou delete se sloupec odstraní
  • Změna třídění - dvojklik ma název sloupce (opětovný dvojklik provede opačné třídění)


Přepočet cen s DPH

Přepočítá u všech karet ceny s DPH na základě ceny bez DPH. Pokud není vyplněna sazba DPH (u plátce) dosadí se implicitní hodnota DPH (viz. Sazby - hranice)

Přepočet cen bez DPH


Přepočet cen bez DPH

Přepočítá u všech karet ceny bez DPH na základě ceny s DPH. Pokud není vyplněna sazba DPH (u plátce) dosadí se implicitní hodnota DPH (viz. Sazby - hranice).

Přepočet cen s DPH


Kódy speciálních skupin

Přiřazení kódu skupin k vybraným položkám.

Do těchto skupin se přiřadí karty označené příslušným příznakem.

Karty Skupiny Zatřídění


Skupiny

Pořizování, editace, mazání skupin.

Počet úrovní skupin není omezen.

Popis údajů

  • Kód - jednoznačné označení skupiny. Nepoužívat české, speciální znaky a mezery v kódu. Pokud je rozpad této skupiny nejde měnit kód. Kódy speciálních skupin jsou dostupné zde.
  • Název - název skupiny. Text, který se zobrazí jako odkaz na skupinu (pokud není vyplněn obrázek).
  • Pořadí - pořadí zobrazení skupiny
  • Má rozpad - existuje/neexistuje podřízená skupina
  • Další - přechod do podřízené skupiny

Karty Skupiny - texty Skupiny - spec. kódy Zatřídění


Skupiny - texty

Pořizování, editace textu a dalších údajů spojených se skupinou.

Popis editovatelných údajů

  • Obrázek - soubor s obrázkem. Nalistování obrázku - pravé tl. myši. Pokud je obrázek vyplněn a je nastavené grafické zobrazování skupin, zobrazí namísto textového odkazu.
  • Titulek - bublina - popis skupiny. Při najetí myší na obrázek se zobrazí tento text.
  • Záhlaví 1. strany - text zobrazený v záhlaví hlavního okna této skupiny
  • Záhlaví další strany - text zobrazený v záhlaví hlavního okna této skupiny na 2. a další straně
  • Zápatí 1. strany - text zobrazený v zápatí hlavního okna této skupiny
  • Zápatí další strany - text zobrazený v zápatí hlavního okna této skupiny na 2. a další straně
  • Pravý sl. 1. strany - text zobrazený v pravém sloupci hlavního okna této skupiny
  • Pravý sl. další strany - text zobrazený v pravém sloupci hlavního okna této skupiny na 2. a další straně
  • Záhlaví oddělení - text zobrazený v záhlaví levého rámu této skupiny
  • Zápatí oddělení - text zobrazený v zápatí levého rámu této skupiny
  • Nahradit - nahrazení/přidání textu k standardnímu záhlaví/zápatí

Karty Skupiny - pořízení Zatřídění


Zatřídění

Okno zobrazuje položky, které nepatří do skupiny . Zatržené položky (sloupec označ) se hromadně dosadí do zvolené skupiny (podskupiny). Výběr dostupných skupin a podskupin se zobrazí po stisknutí tlačítka výběr skupin.

Tlačítkem Převzít se skupina dosadí do označených karet .

Skupiny Karty


 tabulky karty skupiny psk


Horní rám - odkazy

Pořízení, editace a mazání odkazů vrchního rámu.

Popis údajů

  • Text odkazu - textový odkaz (nezobrazí se pokud je použit obrázek)
  • Obrázek - jméno souboru s obrázkem. Pravé tl. myši nalistuje soubor. Nemusí se použít.
  • Alternativní text - popis obrázku po najetí myši na obr.
  • Soubor - jméno HTML souboru, na který ukazuje odkaz. Pokud je zatržený údaj existuje musí soubor fyzicky existovat. Pokud není zatrženo existuje - WebGen ho vytvoří. Soubor by měl být malým písmem, bez českých a specialní znaků, bez mezer a s příponou .htm, .html apod..
  • Existuje - příznak zda soubor fyzicky existuje nebo nikoliv.
  • Nové okno - odkaz se zobrazí do stávajícího hlavního okna, nebo se otevře nové (další) okno.
  • Skrýt - takto označený odkaz se nezahrne do HTML stránek.
  • Obsah - vlastní obsah HTML stránky (odkazu). Je přístupný pokud není údaj existuje zatržen. Může obsahovat libovolný html kód.
  • Odkaz na úvodní stranu - definice odkazu na úvodní stranu
  • Odkaz na nákupní košík - definice odkazu na nákupní košík a odeslání objednávky

Tlačítka

  • EEa - externí editor pro editaci textu odkazu
  • Nový - založí nový odkaz
  • Smazat - smaže odkaz
  • OK - zavře okno a uloží změny
  • Odvolat změny - zavře okno bez uložení změn
  • HTML ? - otevření okna se základními HTML tágy
Horní rám - parametry


Horní rám, obrázky nastavení

Definice velikosti a obrázků vrchního rámu.

Střední část horního rámu - střed rámu nad odkazy
Obrázek - jméno souboru s obrázkem. Nebude-li údaj vyplněn, zobrazí se textový údaj - jméno obchodu (viz. nastavení). Nalistování souboru - pravé tl. myši.
Alternativní popis - popis obrázku (po najetí myší). Má význam pouze s kombinací s obrázkem.

Logo - levá část horního rámu
Obrázek - jméno souboru s obrázkem. Nalistování souboru - pravé tl. myši.
Alternativní popis - popis obrázku (po najetí myší). Má význam pouze s kombinací s obrázkem.

Symbol objednáno - pravá část horního rámu
Obrázek - jméno souboru s obrázkem. Nebude-li údaj vyplněn, zobrazí se textový údaj - Objednáno za. Nalistování souboru - pravé tl. myši.
Alternativní popis - popis obrázku (po najetí myší). Má význam pouze s kombinací s obrázkem.

Výška vrchního rámu - výška rámu v bodech (např.150), nebo v procentech celkové výšky obrazovky (např. 25%)

Vlastní definice umožní vytvořit vlastní obsah horního rámu.
Funkce dostupná při nastavení programu v režimu e-shop, e-katalog.


Odkazy - levý rám

Pořízení, editace a mazání odkazů levého rámu.

Popis údajů

  • Text odkazu - textový odkaz (nezobrazí se pokud je použit obrázek)
  • Obrázek - jméno souboru s obrázkem. Pravé tl. myši nalistuje soubor. Nemusí se použít.
  • Alternativní text - popis obrázku po najetí myši na obr.
  • Soubor - jméno HTML souboru, na který ukazuje odkaz. Pokud je zatržený údaj Existuje musí soubor fyzicky existovat. Pokud není zatrženo Existuje - WebGen.cz ho vytvoří. Pravé tl. myši nalistuje soubor. Zásady pro vytváření jména souboru.
  • Pořadí - pořadí v jakém se odkazy zobrazí (shora dolů)
  • Existuje - příznak zda soubor fyzicky existuje nebo nikoliv.
  • Nové okno - odkaz se zobrazí do stávajícího okna, nebo se otevře nové (další) okno.
  • Skrýt - takto označený odkaz se nezahrne do HTML stránek.
  • Obsah - vlastní obsah HTML stránky (odkazu). Je přístupný pokud není údaj Existuje zatržen.Může obsahovat libovolný html kód.

Tlačítka

  • EEa - externí editor pro editaci textu odkazu
  • Nový - založí nový odkaz
  • Smazat - smaže odkaz
  • OK - zavře okno a uloží změny
  • Odvolat změny - zavře okno bez uložení změn
  • HTML ? - otevření okna se základními HTML tágy
Nastavení Texty


Levý rám - texty

Popis údajů

  • Vrchní text - text umístěný v horní části levého rámu. Může obsahovat libovolný HTML kód
  • Spodní text - text umístěný v dolní části levého rámu. Může obsahovat libovolný HTML kód

Popis tlačítek

  • Editovat vrchní text - otevře editor pro editaci vrchního textu
  • EE a - otevře externí editor pro editaci vrchního textu
  • Editovat spodní text - otevře editor pro editaci spodního textu
  • EE b - otevře externí editor pro editaci spodního textu
  • OK - zavře okno a uloží změny
  • Odvolat změny - zavře okno bez uložení změn
  • HTML ? - otevření okna se základními HTML tágy
Odkazy Parametry


Levý rám - nastavení

Nastavení vzhledu levého rámu.

Nadpis oddělení obchodu - textový údaj uvozující jednotlivá oddělení (skupiny a podskupiny).
Obrázek - jméno souboru s obrázkem. Pokud není údaj vyplněn zobrazí se nadpis viz. výše. Pravé tl. myši nalistování souboru.
Alternativní popis - popis obrázku po najetí myši na obrázek
Šířka levého rámu - šířka rámu v bodech (např.150), nebo v procentech celkové šířky obrazovky (např. 25%).
Odkazy před oddělením - zatržením budou odkazy zobrazeny nad oddělením (jinak naopak)
Textové odkazy + grafické symboly - definuje vzhled zobrazení skupin. Pokud je zatrženo jdou vidět grafické symboly + textové odkazy,

jinak buď textové nebo plně grafické odkazy.

Volba zarovnávání odkazů.
Odkazy Texty


Rubriky

Popis údajů

  • Jméno - jméno rubriky
  • Obrázek - soubor s obrázkem, objeví se místo Jména. Pravé tl. myši provede nalistování
  • Popis - popis obrázku v bublině
  • Soubor - jméno souboru, ve kterém bude rubrika uložena. Jméno se stanovuje podle pravidel.
  • Pořadí - pozice zobrazení rubriky na stránce
  • Nadřízená rubrika - jméno rubriky, která je nadřízenou pro tuto rubriku
  • Parametry tabulky - parametry tabulky zobrazující rubriky (orámování, šířka ...)
  • Zarovnání řádků - způsob zarovnání odkazů (vlevo, uprostřed, pravo)
  • Nadpis pro rubriky - textový údaj
  • Nebo obr. - soubor s obrázkem nahrazující textový nadpis
  • Odkaz na úvodní stranu - textový údaj
  • Nebo obr. - soubor s obrázkem nahrazující textový odkaz

Popis tlačítek

  • Nový - vložení nové rubriky
  • OK - uložení změn a zavření okna
  • Odvolat změny - odvolání změn a zavření okna
  • Nadřízené rubriky - otevření okna s nadřízenými rubrikami

Nadřízené rubriky

Popis údajů

  • Jméno - jméno nadřízené rubriky
  • Obrázek - soubor s obrázkem, objeví se místo Jména. Pravé tl. myši provede nalistování
  • Alternativní text - popis obrázku v bublině
  • Soubor HTML - jméno souboru, ve kterém bude nadřízená rubrika uložena. Jméno se stanovuje podle pravidel.
  • Pořadí - pozice zobrazení rubriky na stránce
  • Nadpis pro rubriky - textový údaj
  • Nebo obr. - soubor s obrázkem nahrazující textový nadpis


Levý sloupec Texty - nastavení

Popis údajů

  • Vrchní text - text umístěný v horní části levého sloupce. Může obsahovat libovolný HTML kód
  • Spodní text - text umístěný v dolní části levého sloupce. Může obsahovat libovolný HTML kód
  • Vkládat vrchní text do všech stránek - přepínač pro vkládání textu pouze do úvodní strany nebo do všech stránek
  • Vkládat spodní text do všech stránek - přepínač pro vkládání textu pouze do úvodní strany nebo do všech stránek
  • Šířka sloupce - nastavení šířky levého sloupce v bodech (např. 150), nebo v procentech celkové šířky obrazovky (např. 30%).

Popis tlačítek

  • Editovat vrchní text - otevře editor pro editaci vrchního textu
  • EE a - otevře externí editor pro editaci vrchního textu
  • Editovat spodní text - otevře editor pro editaci spodního textu
  • EE b - otevře externí editor pro editaci spodního textu
  • OK - zavře okno a uloží změny
  • Odvolat změny - zavře okno bez uložení změn
  • HTML ? - otevření okna se základními HTML tágy
Rubriky


Sloupek

Pořízení, editace, mazání článku ve sloupku. Klávesa CTRL+S (horké klávesy)

Sloupek je sloupec článků, které se zobrazují na úvodní straně na pravé části obrazovky. Pokud nepotřebujeme sloupek zobrazit, tak se pouze nevyplňuje žádný údaj.

Popis údajů

  • Nadpis článku - nadpis uvozující článek sloupku
  • Obsah - typ obsahu článku:
    • Dnešní datum - datum vygenerování (aktualizace) stránek. Používá se na zobrazení poslední úpravy stránek.
    • Toplist - seznam zboží (služeb), označených příznak toplist. Program vygeneruje seznam odkazů. Má význam pro nastavení v režimu e-shop
    • Text - libovolný text (program nic negeneruje)
  • Pořadí - pořadí v jekém budou články zobrazeny pod sebou.
  • Skrýt - zatržený článek se nezobrazí na stránce (lze později použít na rozdíl od smazání).
  • Šířka sloupku - šířka sloupku v bodech (např. 100), nebo v procentech šířky (30%)
  • Vlastní obsah článku sloupku - libovolný text včetně HTML kódu.

Tlačítka

  • EEa - externí editor pro editaci textu
  • Nový - založí nový článek
  • Smazat - smaže článek
  • OK - zavře okno a uloží změny
  • Odvolat změny - zavře okno bez uložení změn
  • HTML ? - otevření okna se základními HTML tágy

Články Záhlaví Střed Zápatí


Články

Pořízení, editace, mazání článku.

Klávesa CTRL+L (viz. Horké klávesy)

Údaje souboru

  • Datum - datum vytvoření článku (pokud se nevyplní na stránce se zobrazí bez údaje datum)
  • Autor - autor článku (není nutné vyplnit). Návaznost na číselník autorů.
  • Rubrika - jméno rubriky, do které článek spadá (nutno vyplnit při použití redakčního systému). Návaznost na číselník rubrik.
  • Nadpis - nadpis článku
  • Souvisí - jméno souboru, který navzájem prováže související články. Stejný název je potřeba napsat k těm článkům, které spolu souvisí. Jméno souboru bez českých znaků, malým písmem a bez mezer.
  • Pořadí - pořadí zobrazení článku nad sebou v rámci stejného datumu (není nutné vyplňovat).
  • Skrýt - zatržený článek se nezobrazí na stránkách (později lze použít)
  • Odkaz na soubor - soubor, na který odkazuje obrázek. Pravé tl. myši nalistování. Vyplňuje se pouze, pokud se tvoří odkaz z obrázku na jiný soubor než detail článku.
  • N. okno - příznak na otevření odkazu do nového okna.
  • Obrázek - soubor s obrázkem. Zobrazí se v horní části článku. Pravé tlačítko nalistování.
  • Alternativní text - popis obrázku po najetí kurzoru na obr..
  • Notace článku - úvodní část článku zobrazená v přehledu článků.

Tlačítka:

Zruš filtr - zruší zadaný filtr a zobrazí všechny údaje
Detail článku - celý obsah článku. Připojí se za notaci článku a zobrazí se spolu s obrázkem na samostatné stránce.
EEa - externí editor pro editaci notace článku
EEb - externí editor pro editaci detailu článku
Autor - číselník autorů
Rubriky - číselník rubrik
Nový - založení nového článku
Smazat článek - smaže vybraný článek
OK - uzavření okna a uložení změn
Odvolat změny - uzavření okna bez uložení změn
HTML ? - otevření okna se základními HTML tágy

Ostatní parametry

Počet článků na úvodní straně - definuje kolik nejnovějších článků se má zobrazit na úvodní straně
V rubrice - definuje kolik nejnovějších článků se má zobrazit v konkrétní rubrice, ostatní se objeví v archivu
V nadřízené rubrice - definuje kolik nejnovějších článků se má zobrazit na úvodní straně nadřízené rubriky


Záhlaví - zápatí úvodní strany

Hlavička a patička úvodní strany

Popis údajů

  • Záhlaví - text umístěný v horní části strany. Může obsahovat libovolný HTML kód
  • Střed - text umístěný ve střední části strany. Může obsahovat libovolný HTML kód
  • Zápatí - text umístěný v dolní části strany. Může obsahovat libovolný HTML kód

Popis tlačítek

  • Editovat záhlaví - otevře editor pro editaci záhlaví
  • EE a - otevře externí editor pro editaci záhlaví
  • Editovat střed - otevře editor pro editaci střední části
  • EE b - otevře externí editor pro editaci střední části
  • Editovat zápatí - otevře editor pro editaci zápatí
  • EE c - otevře externí editor pro editaci zápatí
  • OK - zavře okno a uloží změny
  • Odvolat změny - zavře okno bez uložení změn
  • HTML ? - otevření okna se základními HTML tágy

Články Sloupek


Nezávislé stránky

Stránky bez návaznosti na ostatní stránky.

Popis údajů

  • Popis souboru - titulek stránky
  • Jméno souboru - jméno vygenerovaného souboru, koncovka musí odpovídat koncovkám používaných v prohlížeči (htm, html ...)
  • Bez parametrů - stránka obsahuje/neobsahuje styl ostatních stránek vygenerovaných v programu. Pokud je zatrženo uživatel musí nadefinovat celou strukturu souboru.
  • Skrýt - soubor se nebude generovat
Odkaz na zobrazení takto vygenerované stránky musí uživatel vytvořit sám. Používá se např. na stránku, krerá se zobrazí odskokem z textu článku, popisu zboží, textu sloupku apod..
Tlačítka
  • Editovat obsah - otevře editor pro editaci textu stránky
  • EEa - externí editor pro editaci textu stránky
  • Nový - založí novou stránku
  • Smazat - smaže stránku
  • OK - zavře okno a uloží změny
  • Odvolat změny - zavře okno bez uložení změn
  • HTML ? - otevření okna se základními HTML tágy


Pravý sloupec

Parametry a vlastní obsah pravého sloupce

Režim e-shop, e-katalog

Popis údajů

  • Popis obsahu sloupce - poznámka k obsahu. Pro lepší orientaci, kde je definováno více textů.
  • Obsah - vlastní text. Může obsahovat libovolný HTML kód. Pro zobrazení obsahu sloupce z úvodní strany napište: <script src="pr_slrs.js" language="JavaScript"></script>
  • Pořadí - pořadí v jakém se bude text zobrazovat. Na každé straně se zobrazí vždy pouze jeden text.
  • Skrýt - údaj nebo generován
  • Použít pravý sloupec - přepínač pro aktivaci zobrazení pravého sloupce
  • Šířka sloupce - hodnota v bodech (100, 120, ...) nebo v procentech (30%, 35% ...)

Tlačítka

  • Editovat obsah - editor pro editaci textu sloupce
  • EEa - externí editor pro editaci textu
  • Nový - založí nový údaj
  • Smazat - smaže údaj
  • OK - zavře okno a uloží změny
  • Odvolat změny - zavře okno bez uložení změn
  • HTML ? - otevření okna se základními HTML tágy

Režim redakční systém

Popis odlišných údajů

  • Rubrika - jméno rubriky, kde se bude text zobrazovat. Pokud se neuvede zobrazí ve všech rubrikách. Pro text zobrazovaný pouze v nezávislých stránkách se píše do sloupce Rubrika slovo ns.
  • Pořadí - pořadí v jakém se bude text zobrazovat na jedné straně.
  • Zobrazovat v detailu článku - přepínač pro zobrazení v detailu článku
  • Zobrazovat v nezáv. stránkách - přepínač pro zobrazení v nezávislých stránkách


Dynamický sloupek

Představuje text, který je dynamicky vkládán do jedné nebo více stránek.

Obsah není uložen na stránce, na které se zobrazuje, ale v samostatném souboru. Tento soubor neobsahuje HTML kód ale JavaScript.
Dynamický sloupek slouží k vytvoření sloupku, který je graficky (barevně) shodný s pravým sloupkem na úvodní straně. Pro vložení takovéto tabulky do textu se použije syntaxe:
<script src="jmeno.js" language="JavaScript"></script>.
Konkrétní HTML kód se získá použitím tlačítka HTML kód.
Při změně obsahu dyn. sloupce není nutné generovat všechny stránky ale pouze dyn. sloupce.

Popis údajů

  • Sloupek - jméno sloupku, ke kterému text patří
  • Nadpis - nadpis textu
  • Pořadí - pořadí v zobrazování textu, který patří k jednomu sloupku
  • Skrýt - text nebude zobrazen
  • Text - vlastní text dynamického sloupku. Může obsahovat HTML kód

Tlačítka

  • Definice sloupku - volba parametrů sloupku

    • Sloupek - jméno sloupku. Bude součástí jména souboru, proto nesmí obsahovat české znaky a mezery.
    • Jméno souboru - jméno souboru tak jak je uloženo
    • Šířka sloupku - šířka v bodech, údaj je nutné zadat. Pro orientaci nejpoužívanější rozlišení je 800x600 tzn., že šířka celé obrazovky je 800 bodů.
    • Skrýt - sloupek se dočasně nebude generovat
    Počet sloupků je u volně šiřitelné verze a základní licence omezen na jeden.
  • HTML kód - zobrazí HTML kód, který je potřeba napsat do místa stránky, kde se bude sloupek zobrazovat
  • EEa - externí editor pro editaci textu sloupku
  • Nový - založí nový text pro sloupek
  • Smazat - smaže text sloupku
  • OK - zavře okno a uloží změny
  • Odvolat změny - zavře okno bez uložení změn
  • HTML ? - otevření okna se základními HTML tágy


Záhlaví - zápatí strany

Hlavička a patička strany mimo úvodní stranu.

Popis údajů

  • Záhlaví - text umístěný v horní části strany. Může obsahovat libovolný HTML kód
  • Zápatí - text umístěný v dolní části strany. Může obsahovat libovolný HTML kód

Popis tlačítek

  • Editovat záhlaví - otevře editor pro editaci záhlaví
  • EE a - otevře externí editor pro editaci záhlaví
  • Editovat zápatí - otevře editor pro editaci zápatí
  • EE b - otevře externí editor pro editaci zápatí
  • OK - zavře okno a uloží změny
  • Odvolat změny - zavře okno bez uložení změn
  • HTML ? - otevření okna se základními HTML tágy


 tabulky 2


Použití programu

Nastavení způsobu použití programu WebGen

Popis údajů

  • Režim programu - zatržením se program nastaví do příslušného módu
  • Zobrazovat okno s nápovědou - zatržením se aktivuje okno, které zobrazuje v průběhu běhu programu rady a tipy pro práci.


Iniciály

Základní informace o stránkách.

Popis údajů

  • Jméno stránek - titulek, který se objeví v hlavní (horní) liště prohlížeče.
  • Popis stránek - stručný popis tématiky, kterou se stránka zabývá. Je určeno především pro indexovací služby jako je Altavista a má velký význam. Text není viditelný na stránce. Např. "Snímky města Karlovy Vary".
  • Klíčové slova - opět určeno pro indexovací služby, tetokrát se však jedná přímo o klíčová slova.Text není viditelný na stránce. Např. "Karlovy Vary,fotografie,turistika".
  • Název, ulice, obec, DIČ, IČO - údaje pro objednávku *
  • Plátce DPH - nastaví se zda se počíta s DPH (důležité) *
  • E-mail - e-mail, na který se zasílají objednávky(důležité) *
  • Telefon, fax, účet, konst. symbol - údaje pro objednávku *
* - má význam pouze pro e-shop


Sazby - hranice

Popis údajů

  • Sleva
    • Sleva [%] - procento slevy
    • Hranice - hranice po jejíž dosažení se počítá sleva
    • Text slevy - text, který označuje slevu v objednávce
  • Distribuční náklady
    • Hranice pro placení - hranice, do které se platí distribuční náklady
    • Text - text, který označuje náklady s dodávkou objednávky
    • Text 2 - text, který označuje náklady s platbou (např. dobírkovné)
  • DPH
    • Základní sazba [%] - procento základní sazby DPH
    • Snížená sazba [%] - procento snížené sazby DPH
    • Implicitní sazba DPH [%] - hodnota DPH, která se dosadí do položek, kde není uvedena žádná sazba DPH, při přepočtu cen
  • Zaokrouhlení
    • Zaokrouhlení DPH
      • Setníky nahoru
      • Desetníky nahoru
    • Zaokrouhlení objednávky
      • Desetníky nahoru
      • Koruny nahoru
  • Počet položek zboží na stránce - počet současně zobrazených položek na stránce jedné skupiny a podskupiny.


Umístění stránek

Popis údajů

  • Soubory pro web - adresář, do kterého se budou generovat HTML stránky do počítače
  • Malé obrázky - adresář, do kterého je potřeba nakopírovat obrázky pro náhled karet. Stejně nazvaný adresář musí existovat na www serveru.
  • Velké obrázky - adresář, do kterého je potřeba nakopírovat obrázky pro detailní zobrazení karet. Stejně nazvaný adresář musí existovat na www serveru. Platí pro nastavení v režimu e-shop
  • Jméno hlavního souboru HTML - hlavní HTML soubor, kterým se budou stránky spouštět. Např. index.html, default.html apod. Platí pro nastavení v režimu e-shop
  • Jméno souboru levého rámu - soubor levého rámu (přednastaveno na oddeleni.htm). Doporučujeme měnit pouze v nutném případě. Platí pro nastavení v režimu e-shop

Při kopírování souborů na www server převeďte všechny jména souborů na malé písmena. Nepoužívejte ve jméně souborů mezery, interpukci, lomítka a uvozovky. Vyhnete se problémům se zobrazováním souborů na www.Co funguje ve Windows xx negunguje na www.


Pošta

Nastavení zprávy po odeslání objednávky.

Popis údajů

  • 2. e-mail obchodníka - druhá adresa, na kterou přijde objednávka. První adresa viz. iniciály
  • E-mail mobilního telefonu - adresa na kterou přijde informace o objednávce. Celková cena, odesílatel. (tvar adresy např. +420603123456@sms.paegas.cz)
  • Poslat zákazníkovi opis objednávky - e-mail pro zákazníka bude-nebude obsahovat opis objednávky
  • Předmět - předmět e-mailu, který dojde obchodníkovi a odběrateli
  • Text - obsah e-mailu, který dostane pouze odběratel (odezva, že objednávka byla odeslána obchodníkovi)

Odeslání objednávky


Odeslání objednávky

Nastavení textových informací zobrazených po odeslání objednávky.

Úspěšné odeslání objednávky - text, který se zobrazí odběrateli po úspěšném odeslání objednávky
Neúspěšné odeslání objednávky - text, který se zobrazí odběrateli po neúspěšném odeslání objednávky


Vzhled

Konfigurace vzhledu aplikace

Parametry pro nastavení programu v režimu e-shop, e-katalog

Popis údajů

  • Dotazovat se na množství - přepínač zda vyžadovat zadaní počtu při vhození zboží do košíku
  • Po vhození do košíku ukázat košík - přepínač na zobrazení košíku, které následuje okamžitě po vhození zboží do košíku
  • Levý rám
    • Odkazy na skupiny a podskupiny zarovnávat - volba zarovnání (nalevo, nastřed, napravo)
    • Uživatelské odkazy zarovnávat - volba zarovnání (nalevo, nastřed, napravo)
  • Šířka rámečku článku - šířka orámování v bodech (0 - bez orámování)
  • Zarovnání obrázku v článku - způsob zarovnání obrázku
    • Left - vlevo
    • Right - vpravo
    • Top - nahoru
    • Texttop - nahoru vůči textu
    • Middle - doprostřed vůči lince textu
    • Bottom - dolů vůči textu
    • Absbottom - dolů
  • Odkaz na celý článek - text odkazu na celý článek
  • Kód před odkazem na předchozí stranu - HTLM kód
  • Odkaz na předchozí stranu - text odkazu
  • Kód za odkazem na předchozí stranu - HTML kód
  • Použít vyhledávání - přepínač pro generování souboru pro vyhledávání v názvu karty
    • Hledaný řetězec - text
    • Tlačítko hledej - text
    • PHP soubor - volba souboru na vyhledávání. S podporou PHP (hledej.php3) nebo JavaScriptu (hledej.htm). Při volbě PHP vyhledávání funguje pouze při umístění stránek na www s podporou PHP jazyka.
    • Nalezené odkazy - text
    • Nic nenalezeno -
    • Počet znaků popisu zboží počet znaků, které budou zahrnuty do souboru pro vyhledávání

Definice rámů, script

Popis údajů

  • Rám
    • Horní rám - parametry horního rámu, změna rozměrů, rolování, odsazení
    • Levý rám -
    • Hlavní rám -
  • Script - www adresa scriptu pro zpracování objednávky (odeslání e-mailu zákazníkovi a obchodníkovi). Přednastavená adresa http://www.webgen.cz/php/posliobj.php3


Třídění

Definice zobrazení pořadí jednotlivých karet v oddělení.

Lze nastavit třídění podle 1-4 údajů.


Lokalizace - redakční systém

Nastavení kódové stránky + definice tagu META.

Definuje zda a kde se budou zobrazovat odkazy na články úvodní strany.
Příklad vygenerovaných odkazů:

Obdobně jde nastavit generování scriptu pro jiný server.

Definice šířky orámování tabulky s článkem a definice navigačních odkazů.

Doplňující parametry tabulky s článkem, kód oddělující dva články, zarovnání obrázku, popis odkazů zobrazovaných údajů

Způsob zobrazení datumu.

E-shop E-katalog


Lokalizace - e-shop

Definice znakové sady, textu v horním rámu, textu v informačních oknech

Definice textu tlačítek, navigačních odkazů a dialogových oken

Definice textu na první straně nákupního košíku

Definice textu na druhé straně nákupního košíku

Definice textu na třetí straně nákupního košíku

Definice zobrazení aktuálního datumu v horním rámu

Parametry článků na úvodní straně

Volba formátu zobrazovaného data

E-katalog Redakční systém


Lokalizace - e-katalog

Definice znakové sady, textu v horním rámu, textu v informačních oknech

Definice textu tlačítek, navigačních odkazů a dialogových oken

Parametry článků na úvodní straně

Volba formátu zobrazovaného data

E-shop Redakční systém


Reklamní odkazy

Nastavení scriptu pro zobrazování vybraných karet (karty, které mají jeden z příznaků např. novinka, sleva, výprodej, tip).

Ukázka zobrazených údajů. Obrázek slouží jako odkaz.

Popis údajů

  • Šířka tabulky -
  • Šířka obrázku -
  • Nadpis tabulky -
  • Zdrojový kód - zdrojový kód je možné libovolně umístit do stránek


Způsob dopravy

Nastavení způsobu dopravy pro doručení objednávky.

Sloupce souboru
  • Název - Popis způsobu dopravy
  • Cena - cena bez DPH
  • DPH - procento DPH


Způsob úhrady

Nastavení způsobu úhrady pro zaplacení objednávky.

Sloupce souboru
  • Název - Popis způsobu úhrady
  • Cena - cena bez DPH
  • DPH - procento DPH
  • Akce - umožní přesměrování na platební bránu I LIKE Q, eBanka, Monetka.


I LIKE Q

Nastavení parametrů platební brány.

Údaje se vyplní podle údajů obchodníka. Podmínkou je zřízení účtu na I LIKE Q
Způsob úhrady


eBanka

Nastavení parametrů platební brány.

Údaje se vyplní podle údajů obchodníka. Podmínkou je zřízení účtu v eBance
Způsob úhrady I LIKE Q Monetka


Monetka

Nastavení parametrů platební brány.

Údaje se vyplní podle údajů obchodníka. Podmínkou je zřízení účtu na Monetka.cz
Způsob úhrady I LIKE Q eBanka


Barvy

Nastavení barevné kombinace stránek.

Záložka Rám
Rám je horní a levá část obrazovky dle nastavení.
Nastavitelné parametry:
  • Barva textu - kód barvy
  • Nadpis oddělení - kód barvy
  • Podklad oddělení - kód barvy
  • Odkaz - kód barvy
  • Aktuální odkaz - kód barvy
  • Navštívený odkaz - kód barvy
  • Podklad rámu - kód barvy
  • Obrázek horní - soubor
  • Obrázek boční - soubor
Pravým tlačítkem myši v editačním poli se zobrazí paleta barev, respektive okno pro nalistování souboru s obrázkem. Do kódu barvy lze zapsat přímo název barvy (white, red ..)

Záložka okno
Okno je část obrazovky mimo rám.
Nastavitelné parametry:
  • Barva textu - kód barvy
  • Odkaz - kód barvy
  • Aktuální odkaz - kód barvy
  • Navštívený odkaz - kód barvy
  • Barva podkladu - kód barvy
  • Obrázek - soubor

Záložka články
Nastavitelné parametry:
  • Barva nadpisu - kód barvy
  • Podklad nadpisu - kód barvy
  • Podklad článku - kód barvy

Tlačítka

Uložit - uloží profil pod aktuálním názvem
Uložit jako - uloží profil pod novým názvem
Načíst - načte profil z databáze profilů

Spolu s profilem určuje vzhled (taky se nahrává a ukládá) styl CSS.


Rozmístění přehled

Definice rozmístění údajů v okně přehledu

Popis údajů

  • Hlavička - HTML kód uvozující skupinu údajů k jedné položce katalogu
  • Obrázek -
    • Pořadí - pořadí (0-11) zobrazení údaje obrázek, 0 - údaj se nezobrazí
    • Kód před - HTML kód vložený před údaj obrázek
    • Kód za - HTML kód vložený za údaj obrázek
    • Zarovnání - způsob zarovnání obrázku
      • Left - vlevo
      • Right - vpravo
      • Top - nahoru
      • Texttop - nahoru vůči textu
      • Middle - doprostřed vůči lince textu
      • Bottom - dolů vůči textu
      • Absbottom - dolů
  • Novinka -
    • Pořadí - pořadí (0-11) zobrazení údaje novinka, 0 - údaj se nezobrazí
    • Kód - kód, který se zobrazí u karty označené jako novinka
  • Kód -
    • Pořadí - pořadí (0-11) zobrazení údaje kód, 0 - údaj se nezobrazí
    • Kód před - HTML kód vložený před údaj kód
    • Kód za - HTML kód vložený za údaj kód
  • Název - nastavení viz. kód
  • Cena bez DPH - nastavení viz. kód
  • Koncová cena - nastavení viz. kód
  • Původní cena - nastavení viz. kód
  • DPH - nastavení viz. kód
  • Popis - nastavení viz. kód
  • Výrobce - nastavení viz. kód
  • Koupit - nastavení viz. kód
  • Měna - označení měny. Přidává se za údaj s cenou.
  • Detail -
    • Kód před - HTML kód vložený před odkaz detail
    • Text odkazu - text odkazu na zobrazení detailní informace o kartě
    • Kód za - HTML kód vložený za odkaz detail
  • Patička - HTML kód ukončující skupinu údajů k jedné položce katalogu
  • Oddělovač - kód oddělující následující položku katalogu (např. čára <HR>)

Rozmístění detail


Rozmístění detail

Definice rozmístění údajů v okně detailu

Popis údajů

  • Hlavička - HTML kód uvozující skupinu údajů k jedné položce katalogu
  • Obrázek -
    • Pořadí - pořadí (0-12) zobrazení údaje obrázek, 0 - údaj se nezobrazí
    • Kód před - HTML kód vložený před údaj obrázek
    • Kód za - HTML kód vložený za údaj obrázek
    • Zarovnání - způsob zarovnání obrázku
      • Left - vlevo
      • Right - vpravo
      • Top - nahoru
      • Texttop - nahoru vůči textu
      • Middle - doprostřed vůči lince textu
      • Bottom - dolů vůči textu
      • Absbottom - dolů
  • Novinka -
    • Pořadí - pořadí (0-12) zobrazení údaje novinka, 0 - údaj se nezobrazí
    • Kód - kód, který se zobrazí u karty označené jako novinka
  • Kód -
    • Pořadí - pořadí (0-12) zobrazení údaje kód, 0 - údaj se nezobrazí
    • Kód před - HTML kód vložený před údaj kód
    • Kód za - HTML kód vložený za údaj kód
  • Název - nastavení viz. kód
  • Cena bez DPH - nastavení viz. kód
  • Koncová cena - nastavení viz. kód
  • Původní cena - nastavení viz. kód
  • DPH - nastavení viz. kód
  • Popis - nastavení viz. kód
  • Detail popis - nastavení viz. kód
  • Výrobce - nastavení viz. kód
  • Koupit - nastavení viz. kód
  • Měna - označení měny. Přidává se za údaj s cenou.
  • Zpět -
    • Kód před - HTML kód vložený před odkaz zpět
    • Text odkazu - text odkazu na návrat na předchozí stranu
    • Kód za - HTML kód vložený za odkaz zpět
  • Patička - HTML kód ukončující skupinu údajů k jedné položce katalogu

Rozmístění přehled


Externí editor

Umožňuje využít externí editor pro editaci HTML kódu.

Jako externí editor se dosadí oblíbený HTML nebo jiný editor např. notepad.exe.
Volání externího editoru z programu se provádí tlačítkem [image] v editačním okně. Po ukončení editace v externím editoru se vyvolá dialogové okno na dotaz zda upravený text načíst.


Styl CSS

Definice kaskádových stylů - vzhledu písma, tabulek.

Předdefinovaný styl:
.n_clanek - nadpis článku
.clanek - obsah článku
.cldatum - datum vytvoření článku
.clautor - autor článku
.clrubrika - rubrika, do které patří článek
.clnadrubrika - nadřazená rubrika, do které patří článek
.levy_sl_v - vrchní text levého sloupce (rámu)
.levy_sl_s - spodní text levého sloupce (rámu)
.jmeno - jméno obchodu, nadpis v horním rámu
.odkaz - odkazy v horním rámu
.n_sloupek - nadpis článku ve sloupku
.sloupek - obsah sloupku
.n_oddeleni - nadpis oddělení
.n_skupina - nadpis skupina
.skupina - jméno skupiny
.skupina_roz - skupina rozbalená
.skupina_ner - skupina nerozbalená
.skupina_root - návrat na úvodní skupiny
.rubrikanadpis - nadpis pro rubriky
.rubrika - jednotlivé rubriky
.rubrika_akt - aktuálně zobrazená rubrika
input.tl_koupit - tlačítko koupit
input.tl_zpet - tlačítko zpět
input.tl_prep - tlačítko přepočítat
input.tl_dalsi - tlačítko další
input.tl_tisk - tlačítko tisk
input.vstup - vstupní jednořádkové pole
textarea.vstup - vstupní víceřádkové pole
input.cena - pole s celkovou cenou

Detail zboží
.s_d_kod - kód
.s_d_nove - nové
.s_d_cenab - cena bez DPH
.s_d_cena - prodejní cena
.s_d_dph - DPH
.s_d_starac - původní cena
.s_d_nazev - název
.s_d_popis - popis
.s_d_dpopis - detailní popis
.s_d_výrobce - výrobce
.s_d_zpet - zpět na přehled

Přehled zboží
.s_nove - nové
.s_kod - kód
.s_cenab - cena bez DPH
.s_cena - prodejní cena
.s_starac - původní cena
.s_dph - DPH
.s_nazev - název
.s_popis - popis
.s_výrobce - výrobce
.s_info - na detail

Barvy


Generuj

Spustí generování HTML stránek. Klávesa CTRL+F9 (viz. Horké klávesy)
Soubory se ukládají do adresáře nastaveného v parametrech.


Generuj dynamické sloupky

Spustí generování dynamických sloupků. Klávesa CTRL+F8 (Horké klávesy)
Soubory se ukládají do adresáře nastaveného v parametrech.


Ukaž

Zobrazí vygenerované HTML stránky. Klávesa F9 (horké klávesy)

Pokud je prohlížeč stránek již spuštěný a spustí se opětovné generování, je potřeba v prohlížeči aktualizovat obsah pomocí tlačítka obnovení (reload) stránek (klávesa F5).

Generuj Generuj dynamické sloupky


Změny HTML

Funkce provádí porovnání posledně vygenerovaných stránek (uloženy v kořenovém adresáři) a stránek, které se vytvořily při posledním použití funkce /Změny HTML/ (podadresář aktualni)

Rozdíl mezi obsahem těchto dvou adresářů je uložen do adresáře zmeny. Porovnává se obsah jednotlivých souborů.
Příklad:
Doposud se funkce /Změny HTML/ nepoužila.
1 - Spustíme generování stránek.
2 -Spustíme /Změny HTML/ a dáme si zobrazit změněné stránky. Měl by se zobrazit seznam všech souborů. Tyto soubory jsou uloženy v adresáři /zmeny/. Porovnal se podadresář /aktualni/, který byl prázdný, a kořenový adresář, který obsahuje všechny soubory. Na konci této operace se obsah kořenového adresáře přesune do podadresáře /aktualni/, který simuluje stav se soubory na www.
3 -Nyní je program připravem zaznamenat změny, které se provedou od této chvíle (spuštění funkce /Změny HTML/ nikoliv generování).
4 - V této chvíli můžeme provést zásah do obsahu databáze (doplnit nový článek, zboží apod.).
5 - Provedeme vygenerování stránek a zjistíme ještě chybu.
6 - Chybu opravíme a opět vygenerujeme stránky. (provádíme do té doby, než je vše OK)
7 -Spustíme funkci /Změny HTML/ a v adresáři /zmeny/ jsou modifikované soubory. Nejenom nové soubory, ale i staré, které mají vazbu na provedené změny.

Pozor spouští se vždy až po provedení všech změn, jinak se zobrazí nepřesné informace.


Okna

Volba rozmístění již otevřených oken na obrazovce. Mozaika nebo kaskáda.


Nápověda

Zobrazení této nápovědy.


Registrace

Zadání registračního čísla pro rozšíření free verze programu na plnou verzi. Více informací o získání registrace získáte na stránce www.webgen.cz


Informace

Zobrazení informací o verzi programu.


Asociace

Tabulka speciálních znaků, které je potřeba nahradit v textu HTML stránky, aby došlo ke správnému zobrazení.

Zobrazený znak | Zapsaný znak
< | &lt;
> | &gt;
& | &amp;
" | &guot;
§ | &sect;
© | &copy;
® | &reg;
™ | &#153;
mezera | &nbsp;


Horké klávesy

  • CTRL+K - okno s kartami zboží (Karty)
  • CTRL+P - vlastní pohled na karty (Vlastní pohled)
  • CTRL+L - okno s články (Články)
  • CTRL+S - okno sloupku (Sloupek)
  • CTRL+F9 - generování stránek (Generuj)
  • CTRL+F8 - generování dynamických sloupků (Generuj dynamické sloupky)
  • F8 - zobrazí změněné soubory od poslední použití této funkce(Změny HTML)
  • F9 - zobrazí HTML stránky ve www prohlížeči (Ukaž)
  • ALT+F4 - konec programu WebGen (Konec programu)


Pravidla pro jména souboru

Zásady pro vytváření jména souboru
  • používat pouze základní znaky a čísla
  • nepoužívat české znaky
  • nepoužívat speciální znaky (lomítko, středník ... )
  • používat pouze malá písmena
Použitím uvedených zásad se zmenší problémy při přesunu stránek z lokalního počítače na www, kde platí jiné pravidla pro soubory.


Obecná tlačítka na ovládací liště

Pracovní lišta při otevřeném pohledu má tyto podoby:

Základní sestava tlačítek je následující:

V režimu kladení dotazu se tlačítka změní na

Zobrazení výsledku dotazu

Je-li otevřen vázací pohled, na liště přibude ještě jedno tlačítko:

Význam tlačítek zleva doprava je:
vystřihnout text do clipboardu;
zkopírovat text do clipboardu;

vlepit text z clipboardu;
skok na první záznam pohledu;
skok o stránku dozadu;
skok o jeden záznam dozadu;
skok o jeden záznam dopředu;
skok o stránku dopředu;
skok na poslední záznam pohledu;
položení dotazu v jazyce QBE;
zadání uspořádání záznamů;
konec zadávání dotazu nebo uspořádání nebo zrušení dotazu a uspořádání;
zrušení běžného záznamu v pohledu;
zrušení všech záznamů v pohledu;
tisk obsahu pohledu;
otevření okna se složkami multiatributu;
otevření okna pro zamykání a aktualizaci pohledu;
otevření okna pro export záznamů z pohledu vč. odeslání elektronickou poštou.

Uživatelské pohledy mají často svá vlastní tlačítka, která jsou popsána pro konkrétní pohled.

Práce s pohledem


Podskupiny

Pořizování, editace, mazání podskupin produktu.

Popis údajů

  • Skupina - jméno skupiny, do které podskupina patří. Nalistování skupiny - ALT+šipka dolů
  • Kód PSK - kódové označení podskupiny
  • Název podskupiny - název podskupiny. Text, který se zobrazí jako odkaz na podskupinu (pokud není vyplněn obrázek).
  • Obrázek - soubor s obrázkem. Nalistování obrázku - pravé tl. myši. Obrázek pokud je vyplněn se zobrazí namísto textového odkazu.
  • Alternativní popis - popis obrázku. Při najetí myší na obrázek se zobrazí tento text.
Pozn. Použití podskupin není nutné. Postačí rozdělení na skupiny.
Karty Skupiny Zatřídění


 Pokud se Vám neotevřela nápověda pro určité okno přejděte na záložku Obsah a pod složkou Hlavní nabídka si nalistujte správnou nápovědu.

Práce s pohledem na obrazovce

Pro práci s pohledem na obrazovce jsou podstatné tyto informace:
složky pohledu ;
ovládací tlačítka;

Většinu akcí souvisejících s pohledem lze vyvolat buď stiskem klávesy, nebo myší, anebo ze systémového menu pohledu.

Okno pohledu má tyto hlavní částí:

Rám okna, který dovoluje měnit rozměry a polohu okna způsobem běžným v Windows. Na rámu jsou v pravém horním rohu tlačítka pro roztažení a ikonizaci pohledu, v levém horním rohu tlačítko systémového menu. Systémové menu můžete otevřít stiskem tohoto tlačítka myší nebo kombinací kláves Alt mezera a pak šipka doprava.

Táhlo u pravého rámu okna, které dovoluje se pohybovat mezi záznamy v pohledu nahoru a dolů. Pokud stisknete tlačítko myši pod nebo nad táhlem, posunete se o jednu stránku dopředu nebo dozadu. Pokud stisknete tlačítko myši na šipce pod nebo nad táhlem, posunete se o jeden záznam dopředu nebo dozadu. Táhlo není v těch pohledech, které vedou do proměnných projektu. POZOR: V některých pohledech poloha táhla nevyjadřuje poměr počtu záznamů před a za běžnou pozicí, protože WinBase dosud neví, kolik záznamů bude pohled obsahovat.

Řada ovládacích tlačítek, z nichž některá mohou být neviditelná. Tato tlačítka se objevují pouze tehdy, pokud to požaduje návrh pohledu, proto v některých pohledech nebudou.

Hlava okna, specifikovanou v návrhu pohledu.

Jeden nebo více záznamů, podle návrhu pohledu. V záznamech (případně i v hlavě okna) vidíte složky pohledu. Stiskem myši na tlačítkách, označovacích čtvercích a na některých hodnotových složkách vyvoláte akci zadanou návrhem pohledu.

POZOR: Při editaci údaje ve složce pohledu se Vámi pozměněný údaj zapíše do databáze v okamžiku, když po editaci stisknete klávesu Enter nebo když se pokusíte přejít na jinou složku pohledu. Pokud se Vámi zadaná hodnota nedá zapsat, pak je ohlášena chyba a složku nemůžete opustit. Musíte buď opravit hodnotu nebo upustit od zápisu tak, že stisknete klávesu ESC resp Shift+ESC.


Složky pohledu

Pohled obsahuje jeden nebo více záznamů (jsou pod sebou), každý záznam se skládá z jistého počtu složek (jsou libovolně rozmístěny v záznamu). Složky jsou různých druhů. Pro vstup a editaci dat se dají použít tyto složky:

Editační složky jsou orámovány a pokud některou z nich vyberete, objeví se v ní svislý kurzor. Obsah složky můžete přepsat, přitom zadávání obsahu ukončíte stiskem klávesy Enter nebo přechodem na jinou složku. Pokud jste zadali nepřípustnou hodnotu, budete na to akusticky upozorněni a WinBase Vám nedovolí tuto složku opustit, dokud hodnotu neopravíte!! Vrátit se k původní hodnotě složky můžete stiskem klávesy ESC.

Označovací čtverec (angl. Check-box) je čtvereček s nápisem vpravo. Čtverec může být zaškrtnut nebo nezaškrtnut případně může mít nedefinovanou hodnotu. Čtverec zaškrtnete nebo zaškrtnutí odstraníte tak, že na něm stisknete tlačítko myši nebo mezerník, je-li čtverec předem vybrán. Standardní použití je pro zápis do atributu typu Boolean. Vybraný čtverec poznáte tak, že má kolem svého nápisu tečkovaný rámeček.

Přepínač (angl. Radio-button) - dvoustavové přepínače kruhového tvaru, vyplněné nebo nevyplněné. Přepínají se myší nebo pouhým nastavením se na ně pomocí klávesy TAB.

Seznam (angl. List-box) slouží k zpřístupnění hodnoty multiatributu. Listuje se v něm pomocí šipek. Je-li počet hodnot větší než velikost seznamu, objeví se v jeho pravé části svislé táhlo a grafické šipky pro ovládání myší.

Combo pole (angl. Combo-box) slouží k výběru z několika předem známých hodnot. V této složce se listuje pomocí šipek dolů a nahoru. Combo pole se rozevře pomocí kombinace ALT+šipka dolů nebo kliknutím myši.

Tlačítka se dají stisknout buď myší, nebo mezerníkem, pokud je tlačítko předtím vybráno. Stisk tlačítka způsobí určitou akci definovanou v návrhu. Vybrané tlačítko poznáte tak, že má kolem svého nápisu tečkovaný rámeček.

Práce s pohledem


Vlastní definice

Vlastní definice horního rámu.

Při použití vlastního formuláře je nutné zachovat název formuláře vysledky a název proměnné celkem.