Xceed.FileSystem

Xceed Zip for .NET

Xceed.FileSystem Namespace

Namespace hierarchy

The Xceed.FileSystem namespace provides a generic implementation of methods for handling files and folders.

Classes

Class | Description
AbstractFile | Represents a generic file and exposes properties and methods that allow file-oriented operations to be performed.
AbstractFolder | Represents a generic folder, and exposes properties and methods that allow folder-oriented operations to be performed.
AndFilter | Performs a logical AND operation on a set of Filter objects.
AttributeFilter | Filters a FileSystemItem object based on its attributes.
AutoBatchUpdate | Class that verifies if the object implements the IBatchUpdateable interface.
ByteProgressionEventArgs | Argument class that provides byte progression information.
DateTimeFilter | Filters a FileSystemItem object based on its date and time.
DiskFile | Specialization of the AbstractFile class that implements access to a disk file.
DiskFolder | Specialization of the AbstractFolder class that implements access to a disk folder.
FileSystemEventArgs | The base class for argument classes used by all events.
FileSystemEvents | Class that dispatches events raised from methods called on FileSystemItem objects or objects that derive from the FileSystemItem class.
FileSystemEventsSession | Class which holds information about the session which is responsible for raising all events that occur during the process.
FileSystemException | Exception that is thrown when an error occurs in the Xceed.FileSystem namespace.
FileSystemInternalException | Exception that is thrown when something unexpected occurs in the Xceed.FileSystem namespace.
FileSystemIOException | Exception that is thrown when an IO error occurs while reading from or writing to an AbstractFile object.
FileSystemItem | Root class for all types of items that can exist in a generic (abstract) folder. For example, a file and a folder.
FileSystemNotSupportedException | Exception that is thrown when calling a method or accessing a property that is not supported by a FileSystemItem object.
Filter | The Filter class allows to filter a list of FileSystemItem objects.
ItemAlreadyExistsException | Exception that is thrown when performing an operation on a FileSystemItem object that already exists.
ItemDoesNotExistException | Exception that is thrown when performing an operation on a FileSystemItem object that does not yet exist.
ItemExceptionEventArgs | Argument class that provides information on the exception that was thrown during a process.
ItemIsReadOnlyException | Exception that is thrown when performing an operation on a FileSystemItem object that is read only.
ItemIsRootFolderException | Exception that is thrown when performing an illegal operation on a FileSystemItem object that is a root folder.
ItemPair | Represents a pair of FileSystemItem objects consisting of the item being processed and it's eventual target or destination item.
ItemProgressionEventArgs | Argument class that provides item progression information.
Licenser | Class which is used to register the classes located in the Xceed.FileSystem namespace as described in the Licensing topic of the Xceed Zip for .NET documentation.
NameFilter | Filters a FileSystemItem object based on its name.
NotFilter | Performs a logical NOT operation on a Filter object.
OrFilter | Performs a logical OR operation on a set of Filter objects.
ProgressionInfo | Class which provides progression information for progression events.
ScanningFolderEventArgs | Argument class that provides information on the folder being scanned or accessed.
SizeFilter | Filters a FileSystemItem object based on its size.

Interfaces

Interface | Description
IBatchUpdateable | Allows a AbstractFolder object to optimize its updates, by modifying its underlying physical store only once.

Delegates

Delegate | Description
ByteProgressionEventHandler | Represents the method that will handle the ByteProgression event.
ItemExceptionEventHandler | Represents the method that will handle the ItemException event.
ItemProgressionEventHandler | Represents the method that will handle the ItemProgression event.
ScanningFolderEventHandler | Represents the method that will handle the ScanningFolder event.

Enumerations

Enumeration | Description
DateTimeFilter.ApplicableDateTime | Specifies which type of date/time will be filtered by a DateTimeFilter class.
FilterScope | Specifies which type of FileSystemItem will be filtered by a Filter object.
ItemExceptionAction | Specifies the action taken when an exception is thrown during the processing of a FileSystemItem object.

Copyright 2000-2002 Xceed Software Inc.


AbstractFile Class

Represents a generic file and exposes properties and methods that allow file-oriented operations to be performed.

For a list of all members of this type, see AbstractFile Members.

System.Object
MarshalByRefObject
FileSystemItem
AbstractFile

[Visual Basic]
MustInherit Public Class AbstractFile
   Inherits FileSystemItem
[C#]
public abstract class AbstractFile : FileSystemItem

Requirements

Namespace: Xceed.FileSystem Namespace

Assembly: Xceed.FileSystem.dll

See Also

AbstractFile Members | Xceed.FileSystem Namespace

Based on v1.0.27.0 of the Xceed.FileSystem assembly.


AbstractFile Members

Public Instance Properties

Attributes (inherited from FileSystemItem) | Gets or sets the attributes of the item.
CreationDateTime (inherited from FileSystemItem) | Gets or sets the creation date and time of the item.
Exists (inherited from FileSystemItem) | Gets a boolean value indicating if the item physically exists.
FullName (inherited from FileSystemItem) | Gets the full name of the item.
LastAccessDateTime (inherited from FileSystemItem) | Gets or sets the last access date and time of the item.
LastWriteDateTime (inherited from FileSystemItem) | Gets or sets the modification date and time of the item.
Name (inherited from FileSystemItem) | Gets or sets the short name of the item.
ParentFolder (inherited from FileSystemItem) | Gets a reference to the parent folder of this item.
RootFolder (inherited from FileSystemItem) | Gets a reference to the root folder of this item.
Size | Gets the size of the file in bytes.

Public Instance Methods

ApplyPropertiesTo (inherited from FileSystemItem) | Overloaded. Copies the item's properties to another item.
CopyTo | Overloaded. Copies the file's data to another file.
Create (inherited from FileSystemItem) | Overloaded. Creates the physical item represented by the object.
CreateObjRef (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Delete (inherited from FileSystemItem) | Overloaded. Permanently deletes the physical item.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
InitializeLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
MoveTo | Overloaded. Moves the contents of the object to the target object.
OpenRead | Overloaded. Opens the file for reading.
OpenWrite | Overloaded. Opens the file for writing.
Refresh (inherited from FileSystemItem) | Overloaded. Re-reads the information from the physical item.
ToString (inherited from FileSystemItem) | Returns the full name of the item.

Protected Instance Constructors

AbstractFile Constructor

Protected Instance Properties

DoAttributes (inherited from FileSystemItem) | Gets or sets the attributes of the item. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoCreationDateTime (inherited from FileSystemItem) | Gets or sets the creation date and time of the item. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoExists (inherited from FileSystemItem) | Gets a boolean value indicating if the item physically exists. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoFullName (inherited from FileSystemItem) | Gets the full name of the item. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoLastAccessDateTime (inherited from FileSystemItem) | Gets or sets the last access date and time of the item. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoLastWriteDateTime (inherited from FileSystemItem) | Gets or sets the modification date and time of the item. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoName (inherited from FileSystemItem) | Gets or sets the short name of the item. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoParentFolder (inherited from FileSystemItem) | Gets a reference to the parent folder of this item. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoRootFolder (inherited from FileSystemItem) | Gets a reference to the root folder of this item. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoSize | Gets the size of the file in bytes. This property must be overridden when deriving from this class.
InvalidChars (inherited from FileSystemItem) | Gets the characters that are invalid in file and folder names.

Protected Instance Methods

BuildListForCreate (inherited from FileSystemItem) | Handles the special cases in regards to building the list of items to process when creating a FileSystemItem object.
DoApplyPropertiesTo (inherited from FileSystemItem) | Copies the item's properties to another item. This method must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoCopyTo | Copies the file into the destination.
DoOpenRead | Opens the file for reading. This method must be overridden when deriving from this class.
DoOpenWrite | Opens the file for writing. This method must be overridden when deriving from this class.
DoRefresh (inherited from FileSystemItem) | Re-reads the information from the physical item. This method must be overridden when deriving from the AbstractFolder or AbstractFile classes.
EnsureDateIsValid (inherited from FileSystemItem) | Ensures that the System.DateTime value is valid.
Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsPathRooted (inherited from FileSystemItem) | Returns a boolean value indicating if the path passed is rooted in the environment of the FileSystemItem object we are dealing with. This method must be overridden when deriving from the AbstractFolder or AbstractFile classes.
IsSameAs (inherited from FileSystemItem) | Gets a boolean value indicating if the source and target items are the same. This method must be overridden when deriving from the AbstractFolder or AbstractFile classes.
ListCopyTo (inherited from FileSystemItem) | Copies each item in the FileSystemEventsSession object's list to each item's destination.
ListCreate (inherited from FileSystemItem) | Creates each item in the FileSystemEventsSession object's list.
ListDelete (inherited from FileSystemItem) | Deletes each item in the FileSystemEventsSession object's list.
ListMoveTo (inherited from FileSystemItem) | Moves each item in the FileSystemEventsSession object's list to each item's destination.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Internal Instance Methods

BuildList | Builds a list of FileSystemItem objects to process.
DoCreate (inherited from FileSystemItem) | Creates the physical item represented by the FileSystemItem object. This method must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoDelete (inherited from FileSystemItem) | Permanently deletes the physical item. This method must be overridden when deriving from the AbstractFolder or AbstractFile classes.

See Also

AbstractFile Class | Xceed.FileSystem Namespace


AbstractFile Constructor

[Visual Basic]
Protected Sub New()
[C#]
protected AbstractFile();

See Also

AbstractFile Class | AbstractFile Members | Xceed.FileSystem Namespace


AbstractFile Properties

The properties of the AbstractFile class are listed below. For a complete list of AbstractFile class members, see the AbstractFile Members topic.

Public Instance Properties

Attributes (inherited from FileSystemItem) | Gets or sets the attributes of the item.
CreationDateTime (inherited from FileSystemItem) | Gets or sets the creation date and time of the item.
Exists (inherited from FileSystemItem) | Gets a boolean value indicating if the item physically exists.
FullName (inherited from FileSystemItem) | Gets the full name of the item.
LastAccessDateTime (inherited from FileSystemItem) | Gets or sets the last access date and time of the item.
LastWriteDateTime (inherited from FileSystemItem) | Gets or sets the modification date and time of the item.
Name (inherited from FileSystemItem) | Gets or sets the short name of the item.
ParentFolder (inherited from FileSystemItem) | Gets a reference to the parent folder of this item.
RootFolder (inherited from FileSystemItem) | Gets a reference to the root folder of this item.
Size | Gets the size of the file in bytes.

Protected Instance Properties

DoAttributes (inherited from FileSystemItem) | Gets or sets the attributes of the item. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoCreationDateTime (inherited from FileSystemItem) | Gets or sets the creation date and time of the item. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoExists (inherited from FileSystemItem) | Gets a boolean value indicating if the item physically exists. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoFullName (inherited from FileSystemItem) | Gets the full name of the item. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoLastAccessDateTime (inherited from FileSystemItem) | Gets or sets the last access date and time of the item. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoLastWriteDateTime (inherited from FileSystemItem) | Gets or sets the modification date and time of the item. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoName (inherited from FileSystemItem) | Gets or sets the short name of the item. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoParentFolder (inherited from FileSystemItem) | Gets a reference to the parent folder of this item. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoRootFolder (inherited from FileSystemItem) | Gets a reference to the root folder of this item. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoSize | Gets the size of the file in bytes. This property must be overridden when deriving from this class.
InvalidChars (inherited from FileSystemItem) | Gets the characters that are invalid in file and folder names.

See Also

AbstractFile Class | Xceed.FileSystem Namespace


AbstractFile.DoSize Property

Gets the size of the file in bytes. This property must be overridden when deriving from this class.

[Visual Basic]
MustOverride Protected ReadOnly Property DoSize As Long
[C#]
protected long DoSize {abstract get;}

Property Value

A value representing the file size in bytes.

Remarks

Some types of files may not have the size information available. In this case, -1 should be returned.

If the file does not physically exist, an exception should be thrown.

Note: Refresh should be called before accessing this property, or the information returned could be outdated.

See Also

AbstractFile Class | AbstractFile Members | Xceed.FileSystem Namespace


AbstractFile.Size Property

Gets the size of the file in bytes.

[Visual Basic]
Public ReadOnly Property Size As Long
[C#]
public long Size {get;}

Property Value

A value representing the file size in bytes.

Remarks

Some types of files may not have the size information available. In this case, -1 is returned.

If the file does not physically exist, an exception is thrown.

Note: Refresh should be called before accessing this property, or the information returned could be outdated.

Exceptions

Exception Type | Condition
Xceed.FileSystem.ItemDoesNotExistException | The file represented by this AbstractFile does not physically exist.

See Also

AbstractFile Class | AbstractFile Members | Xceed.FileSystem Namespace


AbstractFile Methods

The methods of the AbstractFile class are listed below. For a complete list of AbstractFile class members, see the AbstractFile Members topic.

Public Instance Methods

ApplyPropertiesTo (inherited from FileSystemItem) | Overloaded. Copies the item's properties to another item.
CopyTo | Overloaded.
Create (inherited from FileSystemItem) | Overloaded. Creates the physical item represented by the object.
CreateObjRef (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Delete (inherited from FileSystemItem) | Overloaded. Permanently deletes the physical item.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
InitializeLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
MoveTo | Overloaded.
OpenRead | Overloaded. Opens the file for reading.
OpenWrite | Overloaded. Opens the file for writing.
Refresh (inherited from FileSystemItem) | Overloaded. Re-reads the information from the physical item.
ToString (inherited from FileSystemItem) | Returns the full name of the item.

Protected Instance Methods

BuildListForCreate (inherited from FileSystemItem) | Handles the special cases in regards to building the list of items to process when creating a FileSystemItem object.
DoApplyPropertiesTo (inherited from FileSystemItem) | Copies the item's properties to another item. This method must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoCopyTo | Copies the file into the destination.
DoOpenRead | Opens the file for reading. This method must be overridden when deriving from this class.
DoOpenWrite | Opens the file for writing. This method must be overridden when deriving from this class.
DoRefresh (inherited from FileSystemItem) | Re-reads the information from the physical item. This method must be overridden when deriving from the AbstractFolder or AbstractFile classes.
EnsureDateIsValid (inherited from FileSystemItem) | Ensures that the System.DateTime value is valid.
Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsPathRooted (inherited from FileSystemItem) | Returns a boolean value indicating if the path passed is rooted in the environment of the FileSystemItem object we are dealing with. This method must be overridden when deriving from the AbstractFolder or AbstractFile classes.
IsSameAs (inherited from FileSystemItem) | Gets a boolean value indicating if the source and target items are the same. This method must be overridden when deriving from the AbstractFolder or AbstractFile classes.
ListCopyTo (inherited from FileSystemItem) | Copies each item in the FileSystemEventsSession object's list to each item's destination.
ListCreate (inherited from FileSystemItem) | Creates each item in the FileSystemEventsSession object's list.
ListDelete (inherited from FileSystemItem) | Deletes each item in the FileSystemEventsSession object's list.
ListMoveTo (inherited from FileSystemItem) | Moves each item in the FileSystemEventsSession object's list to each item's destination.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Internal Instance Methods

BuildList | Builds a list of FileSystemItem objects to process.
DoCreate (inherited from FileSystemItem) | Creates the physical item represented by the FileSystemItem object. This method must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoDelete (inherited from FileSystemItem) | Permanently deletes the physical item. This method must be overridden when deriving from the AbstractFolder or AbstractFile classes.

See Also

AbstractFile Class | Xceed.FileSystem Namespace


AbstractFile.BuildList Method

Builds a list of FileSystemItem objects to process.

[Visual Basic]
Overrides Protected Friend Sub BuildList( _
   ByVal session As Xceed.FileSystem.FileSystemEventsSession, _
   ByVal destination As Xceed.FileSystem.FileSystemItem, _
   ByVal forward As Boolean, _
   ByVal recursive As Boolean, _
   ByVal includeFolders As Boolean, _
   ByVal filters As Xceed.FileSystem.Filter() _
)
[C#]
protected internal override void BuildList(
   FileSystemEventsSession session,
   FileSystemItem destination,
   bool forward,
   bool recursive,
   bool includeFolders,
   Filter[] filters
);

Parameters

session

A reference to a FileSystemEventsSession object which is responsible for raising all events that occur during the process.

destination

The eventual target for the item that will be procesed. For example, the desination folder for a folder that will be copied.

forward

true if folders will be added to the list of FileSystemItem objects to process first; false if files will be added to the list first.

recursive

true if items in subfolders should be added to the list of items to process; false otherwise.

includeFolders

true if folders will be included in the list of items to process; false otherwise.

filters

An array of objects that can be used to filter the list of FileSystemItem objects to process.

See Also

AbstractFile Class | AbstractFile Members | Xceed.FileSystem Namespace


CopyTo Method

Xceed Zip for .NET

AbstractFile.CopyTo

Copies the file's data to another file.

Overload List

Copies the file's data to another file.

public FileSystemItem CopyTo(AbstractFile,bool);

Copies the file's data to another file, and raises events during the process.

public FileSystemItem CopyTo(FileSystemEvents,object,AbstractFile,bool);

Copies the item to another folder. Copies the item to another folder, and raises events during the process.

public FileSystemItem CopyTo(AbstractFolder,bool);

Copies the item to another folder. Copies the item to another folder, and raises events during the process.

public FileSystemItem CopyTo(FileSystemEvents,object,AbstractFolder,bool);

See Also

AbstractFile Class | AbstractFile Members | Xceed.FileSystem Namespace


AbstractFile.CopyTo Method (AbstractFile, Boolean)

Copies the file's data to another file.

[Visual Basic]
Overloads Public Function CopyTo( _
   ByVal destinationFile As Xceed.FileSystem.AbstractFile, _
   ByVal replaceIfExists As Boolean _
) As Xceed.FileSystem.FileSystemItem
[C#]
public FileSystemItem CopyTo(
   AbstractFile destinationFile,
   bool replaceIfExists
);

Parameters

destinationFile

An AbstractFile object that represents the file to which the current file's data must be copied. Cannot be a null reference (Nothing in Visual Basic).

replaceIfExists

true if the destination file should be replaced if it exists; false otherwise.

Return Value

A reference to a FileSystemItem object that represents the destination file.

Remarks

This method only copies the data of a file to another file.

If the file specified by destinationFile does not exist, it is created. If it does exist, an exception is thrown if replaceIfExists is false, or it is overwritten if replaceIfExists is true.

Exceptions

Exception Type | Condition
Xceed.FileSystem.ItemDoesNotExistException | The file represented by this AbstractFile does not physically exist.
Xceed.FileSystem.ItemAlreadyExistsException | The destination file already exists, and replaceIfExists is false.
Xceed.FileSystem.ItemIsReadOnlyException | The destination file already exists, replaceIfExists is true but the destination file has the ReadOnly attribute.
Xceed.FileSystem.FileSystemIOException | The source file could not be read from, or the destination file could not be written to.

See Also

AbstractFile Class | AbstractFile Members | Xceed.FileSystem Namespace | AbstractFile.CopyTo Overload List


AbstractFile.CopyTo Method (FileSystemEvents, Object, AbstractFile, Boolean)

Copies the file's data to another file, and raises events during the process.

[Visual Basic]
Overloads Public Function CopyTo( _
   ByVal events As Xceed.FileSystem.FileSystemEvents, _
   ByVal userData As Object, _
   ByVal destinationFile As Xceed.FileSystem.AbstractFile, _
   ByVal replaceIfExists As Boolean _
) As Xceed.FileSystem.FileSystemItem
[C#]
public FileSystemItem CopyTo(
   FileSystemEvents events,
   object userData,
   AbstractFile destinationFile,
   bool replaceIfExists
);

Parameters

events

A FileSystemEvents object that will be used to raise events. Cannot be a null reference (Nothing in Visual Basic).

userData

Opaque data that will be passed back to the event handler when an event is raised.

destinationFile

An AbstractFile object that represents the file to which the current file's data must be copied. Cannot be a null reference (Nothing in Visual Basic).

replaceIfExists

true if the destination file should be replaced if it exists; false otherwise.

Return Value

A reference to a FileSystemItem object that represents the destination file.

Remarks

This method only copies the data of a file to another file.

If the file specified by destinationFile does not exist, it is created. If it does exist, an exception is thrown if replaceIfExists is false, or it is overwritten if replaceIfExists is true.

Events

Event Type | Reason
Xceed.FileSystem.FileSystemEvents.ByteProgression | Every 32k, reports how many bytes have been and must be copied for the current file.
Xceed.FileSystem.FileSystemEvents.ItemException | When an exception occurs while copying the file, reports the exception and allows recovery from the exception and continues copying the file.

Exceptions

Exception Type | Condition
Xceed.FileSystem.ItemDoesNotExistException | The file represented by this AbstractFile does not physically exist.
Xceed.FileSystem.ItemAlreadyExistsException | The destination file already exists, and replaceIfExists is false.
Xceed.FileSystem.ItemIsReadOnlyException | The destination file already exists, replaceIfExists is true but the destination file has the ReadOnly attribute.
Xceed.FileSystem.FileSystemIOException | The source file could not be read from, or the destination file could not be written to.

See Also

AbstractFile Class | AbstractFile Members | Xceed.FileSystem Namespace | AbstractFile.CopyTo Overload List


AbstractFile.DoCopyTo Method

Copies the file into the destination.

[Visual Basic]
Overrides Protected Sub DoCopyTo( _
   ByVal session As Xceed.FileSystem.FileSystemEventsSession, _
   ByVal destination As Xceed.FileSystem.FileSystemItem, _
   ByVal replaceExistingFiles As Boolean _
)
[C#]
protected override void DoCopyTo(
   FileSystemEventsSession session,
   FileSystemItem destination,
   bool replaceExistingFiles
);

Parameters

session

A reference to a FileSystemEventsSession object which is responsible for raising all events that occur during the process.

destination

An FileSystemItem object into which the file will be copied. Cannot be a null reference (Nothing in Visual Basic).

replaceExistingFiles

true if existing items in the destination should be replaced; false otherwise.

Exceptions

Exception Type | Condition
Xceed.FileSystem.ItemDoesNotExistException | The physical file does not exist.
Xceed.FileSystem.FileSystemNotSupportedException | The source and target files are the same item.
Xceed.FileSystem.ItemAlreadyExistsException | The desination exists and replaceExistingFiles is set to false.
Xceed.FileSystem.ItemIsReadOnlyException | The destination already exists but is read-only.

See Also

AbstractFile Class | AbstractFile Members | Xceed.FileSystem Namespace


AbstractFile.DoOpenRead Method

Opens the file for reading. This method must be overridden when deriving from this class.

[Visual Basic]
MustOverride Protected Function DoOpenRead( _
   ByVal session As Xceed.FileSystem.FileSystemEventsSession, _
   ByVal share As System.IO.FileShare _
) As System.IO.Stream
[C#]
protected abstract Stream DoOpenRead(
   FileSystemEventsSession session,
   FileShare share
);

Parameters

session

A reference to a FileSystemEventsSession object which is responsible for raising all events that occur during the process.

share

A System.IO.FileShare constant that determines how the file will be shared by different processes.

Return Value

A System.IO.Stream object that can be used to read data from the file.

Remarks

The returned stream should be guaranteed to be readable, but does not have to be seekable.

The share parameter should allow control over how the file is shared by different processes. If the values defined in this enumeration are not supported, an exception should thrown.

See Also

AbstractFile Class | AbstractFile Members | Xceed.FileSystem Namespace


AbstractFile.DoOpenWrite Method

Opens the file for writing. This method must be overridden when deriving from this class.

[Visual Basic]
MustOverride Protected Function DoOpenWrite( _
   ByVal session As Xceed.FileSystem.FileSystemEventsSession, _
   ByVal overwrite As Boolean, _
   ByVal share As System.IO.FileShare _
) As System.IO.Stream
[C#]
protected abstract Stream DoOpenWrite(
   FileSystemEventsSession session,
   bool overwrite,
   FileShare share
);

Parameters

session

A reference to a FileSystemEventsSession object which is responsible for raising all events that occur during the process.

overwrite

true if existing data for the file should be replaced; false if existing data should be preserved, appending new data at the end.

share

A System.IO.FileShare constant that determines how the file will be shared by different processes.

Return Value

A System.IO.Stream object that can be used to write data to the file.

Remarks

The returned stream should be guaranteed to be writable, but does not have to be seekable.

The share parameter should allow control over how the file is shared by different processes. If the values defined in this enumeration are not supported, an exception should be thrown.

If the File implementation does not support appending or overwriting, an exception should be thrown.

If there is no existing data, the parameter overwrite should be ignored.

See Also

AbstractFile Class | AbstractFile Members | Xceed.FileSystem Namespace


MoveTo Method

Xceed Zip for .NET

AbstractFile.MoveTo

Moves the contents of the AbstractFile object to the target AbstractFile object.

Overload List

Moves the contents of the AbstractFile object to the target AbstractFile object.

public FileSystemItem MoveTo(AbstractFile,bool);

Moves the contents of the AbstractFile object to the target AbstractFile object and raises events during the process.

public FileSystemItem MoveTo(FileSystemEvents,object,AbstractFile,bool);

Moves the item to another folder. Moves the item to another folder, and raises events during the process.

public FileSystemItem MoveTo(AbstractFolder,bool);

Moves the item to another folder. Moves the item to another folder, and raises events during the process.

public FileSystemItem MoveTo(FileSystemEvents,object,AbstractFolder,bool);

See Also

AbstractFile Class | AbstractFile Members | Xceed.FileSystem Namespace


AbstractFile.MoveTo Method (AbstractFile, Boolean)

Moves the contents of the AbstractFile object to the target AbstractFile object.

[Visual Basic]
Overloads Public Function MoveTo( _
   ByVal destinationFile As Xceed.FileSystem.AbstractFile, _
   ByVal replaceIfExists As Boolean _
) As Xceed.FileSystem.FileSystemItem
[C#]
public FileSystemItem MoveTo(
   AbstractFile destinationFile,
   bool replaceIfExists
);

Parameters

destinationFile

An AbstractFile object into which the contents of the item will be moved. Cannot be a null reference (Nothing in Visual Basic).

replaceIfExists

true if existing items in the destination should be replaced; false otherwise.

Return Value

A FileSystemItem object that represents the newly moved item.

Remarks

If the physical file specified by destinationFile does not exist, it is created.

Exceptions

Exception Type | Condition
Xceed.FileSystem.ItemDoesNotExistException | The file represented by this AbstractFile object does not physically exist.
Xceed.FileSystem.ItemAlreadyExistsException | The destination file already exists, and replaceIfExistsis false.
Xceed.FileSystem.ItemIsReadOnlyException | The destination file already exists, replaceIfExists is true, but the destination file has the ReadOnly attribute. Or the source file has the ReadOnly attribute, and cannot be deleted.
Xceed.FileSystem.FileSystemIOException | The source file could not be read from, or the destination file could not be written to.

See Also

AbstractFile Class | AbstractFile Members | Xceed.FileSystem Namespace | AbstractFile.MoveTo Overload List


AbstractFile.MoveTo Method (FileSystemEvents, Object, AbstractFile, Boolean)

Moves the contents of the AbstractFile object to the target AbstractFile object and raises events during the process.

[Visual Basic]
Overloads Public Function MoveTo( _
   ByVal events As Xceed.FileSystem.FileSystemEvents, _
   ByVal userData As Object, _
   ByVal destinationFile As Xceed.FileSystem.AbstractFile, _
   ByVal replaceIfExists As Boolean _
) As Xceed.FileSystem.FileSystemItem
[C#]
public FileSystemItem MoveTo(
   FileSystemEvents events,
   object userData,
   AbstractFile destinationFile,
   bool replaceIfExists
);

Parameters

events

A FileSystemEvents object that will be used to raise events. Cannot be a null reference (Nothing in Visual Basic).

userData

Opaque data that will be passed back to the event handler when an event is raised.

destinationFile

An AbstractFile object into which the contents of the item will be moved. Cannot be a null reference (Nothing in Visual Basic).

replaceIfExists

true if existing items in the destination should be replaced; false otherwise.

Return Value

A FileSystemItem object that represents the newly moved item.

Remarks

If the physical file specified by destinationFile does not exist, it is created.

Events

Event Type | Reason
Xceed.FileSystem.FileSystemEvents.ItemProgression | Every time an item is about to be moved, reports how many items have been moved and the total number of items that must be moved.
Xceed.FileSystem.FileSystemEvents.ByteProgression | Every 32k, reports how many bytes have been and must be moved for the current item, as well as for the entire set of items that are being moved.
Xceed.FileSystem.FileSystemEvents.ItemException | When an exception occurs while moving an item, reports the exception and allows to recover from the exception and continue moving the items.

Exceptions

Exception Type | Condition
Xceed.FileSystem.ItemDoesNotExistException | The file represented by this AbstractFile object does not physically exist.
Xceed.FileSystem.ItemAlreadyExistsException | The destination file already exists, and replaceIfExistsis false.
Xceed.FileSystem.ItemIsReadOnlyException | The destination file already exists, replaceIfExists is true, but the destination file has the ReadOnly attribute. Or the source file has the ReadOnly attribute, and cannot be deleted.
Xceed.FileSystem.FileSystemIOException | The source file could not be read from, or the destination file could not be written to.

See Also

AbstractFile Class | AbstractFile Members | Xceed.FileSystem Namespace | AbstractFile.MoveTo Overload List


OpenRead Method

Xceed Zip for .NET

AbstractFile.OpenRead

Opens the file for reading.

Overload List

Opens the file for reading.

public Stream OpenRead();

Opens the file for reading with the specified file sharing mode.

public Stream OpenRead(FileShare);

Opens the file for reading and raises events during the process.

public Stream OpenRead(FileSystemEvents,object);

Opens the file for reading with the specified file sharing mode and raises events during the process.

public Stream OpenRead(FileSystemEvents,object,FileShare);

See Also

AbstractFile Class | AbstractFile Members | Xceed.FileSystem Namespace


AbstractFile.OpenRead Method ()

Opens the file for reading.

[Visual Basic]
Overloads Public Function OpenRead() As System.IO.Stream
[C#]
public Stream OpenRead();

Return Value

A System.IO.Stream object that can be used to read data from the file.

Remarks

The returned stream is guaranteed to be readable, but may or may not be seekable.

The file will be opened with System.IO.FileShare.Read shared access.

Exceptions

Exception Type | Condition
Xceed.FileSystem.ItemDoesNotExistException | The file represented by this AbstractFile object does not physically exist.
Xceed.FileSystem.FileSystemNotSupportedException | The file cannot be opened for reading.

See Also

AbstractFile Class | AbstractFile Members | Xceed.FileSystem Namespace | AbstractFile.OpenRead Overload List


AbstractFile.OpenRead Method (FileShare)

Opens the file for reading with the specified file sharing mode.

[Visual Basic]
Overloads Public Function OpenRead( _
   ByVal share As System.IO.FileShare _
) As System.IO.Stream
[C#]
public Stream OpenRead(
   FileShare share
);

Parameters

share

A System.IO.FileShare constant that determines how the file will be shared by different processes.

Return Value

A System.IO.Stream object that can be used to read data from the file.

Remarks

The returned stream is guaranteed to be readable, but may or may not be seekable.

The share parameter allows you to control how the file is shared by different processes. Some specializations of the AbstractFile class may not support any or all of the values defined in this enumeration. In this case, an exception is thrown.

Exceptions

Exception Type | Condition
Xceed.FileSystem.ItemDoesNotExistException | The file represented by this AbstractFile object does not physically exist.
Xceed.FileSystem.FileSystemNotSupportedException | The file cannot be opened for reading, or the provided share value is not supported by this file.

See Also

AbstractFile Class | AbstractFile Members | Xceed.FileSystem Namespace | AbstractFile.OpenRead Overload List


AbstractFile.OpenRead Method (FileSystemEvents, Object)

Opens the file for reading and raises events during the process.

[Visual Basic]
Overloads Public Function OpenRead( _
   ByVal events As Xceed.FileSystem.FileSystemEvents, _
   ByVal userData As Object _
) As System.IO.Stream
[C#]
public Stream OpenRead(
   FileSystemEvents events,
   object userData
);

Parameters

events

A FileSystemEvents object that will be used to raise events. Cannot be a null reference (Nothing in Visual Basic).

userData

Opaque data that will be passed back to the event handler when an event is raised.

Return Value

A System.IO.Stream object that can be used to read data from the file.

Remarks

The file will be opened with System.IO.FileShare.Read shared access.

The returned stream is guaranteed to be readable, but may or may not be seekable.

Exceptions

Exception Type | Condition
Xceed.FileSystem.ItemDoesNotExistException | The file represented by this AbstractFile object does not physically exist.
Xceed.FileSystem.FileSystemNotSupportedException | The file cannot be opened for reading.

See Also

AbstractFile Class | AbstractFile Members | Xceed.FileSystem Namespace | AbstractFile.OpenRead Overload List


AbstractFile.OpenRead Method (FileSystemEvents, Object, FileShare)

Opens the file for reading with the specified file sharing mode and raises events during the process.

[Visual Basic]
Overloads Public Function OpenRead( _
   ByVal events As Xceed.FileSystem.FileSystemEvents, _
   ByVal userData As Object, _
   ByVal share As System.IO.FileShare _
) As System.IO.Stream
[C#]
public Stream OpenRead(
   FileSystemEvents events,
   object userData,
   FileShare share
);

Parameters

events

A FileSystemEvents object that will be used to raise events. Cannot be a null reference (Nothing in Visual Basic).

userData

Opaque data that will be passed back to the event handler when an event is raised.

share

A System.IO.FileShare constant that determines how the file will be shared by different processes.

Return Value

A System.IO.Stream object that can be used to read data from the file.

Remarks

The returned stream is guaranteed to be readable, but may or may not be seekable.

The share parameter allows you to control how the file is shared by different processes. Some specializations of the AbstractFile class may not support any or all of the values defined in this enumeration. In this case, an exception is thrown.

Exceptions

Exception Type | Condition
Xceed.FileSystem.ItemDoesNotExistException | The file represented by this AbstractFile object does not physically exist.
Xceed.FileSystem.FileSystemNotSupportedException | The file cannot be opened for reading, or the provided share value is not supported by this file.

See Also

AbstractFile Class | AbstractFile Members | Xceed.FileSystem Namespace | AbstractFile.OpenRead Overload List


OpenWrite Method

Xceed Zip for .NET

AbstractFile.OpenWrite

Opens the file for writing.

Overload List

Opens the file for writing.

public Stream OpenWrite(bool);

Opens the file for writing with the specified file sharing mode.

public Stream OpenWrite(bool,FileShare);

Opens the file for writing and raises events during the process.

public Stream OpenWrite(FileSystemEvents,object,bool);

Opens the file for writing with the specified file sharing mode and raises events during the process.

public Stream OpenWrite(FileSystemEvents,object,bool,FileShare);

See Also

AbstractFile Class | AbstractFile Members | Xceed.FileSystem Namespace


AbstractFile.OpenWrite Method (Boolean)

Opens the file for writing.

[Visual Basic]
Overloads Public Function OpenWrite( _
   ByVal overwrite As Boolean _
) As System.IO.Stream
[C#]
public Stream OpenWrite(
   bool overwrite
);

Parameters

overwrite

true if existing data for the item should be replaced; false if existing data should be preserved, appending new data at the end.

Return Value

A System.IO.Stream object that can be used to write data to the file.

Remarks

The returned stream is guaranteed to be writable, but may or may not be seekable.

The file will be opened with System.IO.FileShare.None shared access.

Exceptions

Exception Type | Condition
Xceed.FileSystem.ItemDoesNotExistException | The file represented by this AbstractFile object does not physically exist.
Xceed.FileSystem.FileSystemNotSupportedException | The file cannot be opened for writing.

See Also

AbstractFile Class | AbstractFile Members | Xceed.FileSystem Namespace | AbstractFile.OpenWrite Overload List


AbstractFile.OpenWrite Method (Boolean, FileShare)

Opens the file for writing with the specified file sharing mode.

[Visual Basic]
Overloads Public Function OpenWrite( _
   ByVal overwrite As Boolean, _
   ByVal share As System.IO.FileShare _
) As System.IO.Stream
[C#]
public Stream OpenWrite(
   bool overwrite,
   FileShare share
);

Parameters

overwrite

true if existing data for the item should be replaced; false if existing data should be preserved, appending new data at the end.

share

A System.IO.FileShare constant that determines how the file will be shared by different processes.

Return Value

A System.IO.Stream object that can be used to write data to the file.

Remarks

The returned stream is guaranteed to be writable, but may or may not be seekable.

The share parameter allows you to control how the file is shared by different processes. Some specializations of the AbstractFile class may not support any or all of the values defined in this enumeration. In this case, an exception is thrown.

Some File implementations may not support appending or overwriting. In this case, an exception is thrown.

If there is no existing data, the parameter overwrite is ignored.

Exceptions

Exception Type | Condition
Xceed.FileSystem.ItemDoesNotExistException | The file represented by this AbstractFile object does not physically exist.
Xceed.FileSystem.FileSystemNotSupportedException | The file cannot be opened for writing, does not support appending or overwriting, or the provided share value is not supported by this file.

See Also

AbstractFile Class | AbstractFile Members | Xceed.FileSystem Namespace | AbstractFile.OpenWrite Overload List


AbstractFile.OpenWrite Method (FileSystemEvents, Object, Boolean)

Opens the file for writing and raises events during the process.

[Visual Basic]
Overloads Public Function OpenWrite( _
   ByVal events As Xceed.FileSystem.FileSystemEvents, _
   ByVal userData As Object, _
   ByVal overwrite As Boolean _
) As System.IO.Stream
[C#]
public Stream OpenWrite(
   FileSystemEvents events,
   object userData,
   bool overwrite
);

Parameters

events

A FileSystemEvents object that will be used to raise events. Cannot be a null reference (Nothing in Visual Basic).

userData

Opaque data that will be passed back to the event handler when an event is raised.

overwrite

true if existing data for the item should be replaced; false if existing data should be preserved, appending new data at the end.

Return Value

A System.IO.Stream object that can be used to write data to the file.

Remarks

The returned stream is guaranteed to be writable, but may or may not be seekable.

The file will be opened with System.IO.FileShare.None shared access.

Exceptions

Exception Type | Condition
Xceed.FileSystem.ItemDoesNotExistException | The file represented by this AbstractFile object does not physically exist.
Xceed.FileSystem.FileSystemNotSupportedException | The file cannot be opened for writing.

See Also

AbstractFile Class | AbstractFile Members | Xceed.FileSystem Namespace | AbstractFile.OpenWrite Overload List


AbstractFile.OpenWrite Method (FileSystemEvents, Object, Boolean, FileShare)

Opens the file for writing with the specified file sharing mode and raises events during the process.

[Visual Basic]
Overloads Public Function OpenWrite( _
   ByVal events As Xceed.FileSystem.FileSystemEvents, _
   ByVal userData As Object, _
   ByVal overwrite As Boolean, _
   ByVal share As System.IO.FileShare _
) As System.IO.Stream
[C#]
public Stream OpenWrite(
   FileSystemEvents events,
   object userData,
   bool overwrite,
   FileShare share
);

Parameters

events

A FileSystemEvents object that will be used to raise events. Cannot be a null reference (Nothing in Visual Basic).

userData

Opaque data that will be passed back to the event handler when an event is raised.

overwrite

true if existing data for the item should be replaced; false if existing data should be preserved, appending new data at the end.

share

A System.IO.FileShare constant that determines how the file will be shared by different processes.

Return Value

A System.IO.Stream object that can be used to write data to the file.

Remarks

The returned stream is guaranteed to be writable, but may or may not be seekable.

The share parameter allows you to control how the file is shared by different processes. Some specializations of the AbstractFile class may not support any or all of the values defined in this enumeration. In this case, an exception is thrown.

Some File implementations may not support appending or overwriting. In this case, an exception is thrown.

If there is no existing data, the parameter overwrite is ignored.

Exceptions

Exception Type | Condition
Xceed.FileSystem.ItemDoesNotExistException | The file represented by this AbstractFile object does not physically exist.
Xceed.FileSystem.FileSystemNotSupportedException | The file cannot be opened for writing, does not support appending or overwriting, or the provided share value is not supported by this file.

See Also

AbstractFile Class | AbstractFile Members | Xceed.FileSystem Namespace | AbstractFile.OpenWrite Overload List


AbstractFolder Class

Represents a generic folder, and exposes properties and methods that allow folder-oriented operations to be performed.

For a list of all members of this type, see AbstractFolder Members.

System.Object
MarshalByRefObject
FileSystemItem
AbstractFolder

[Visual Basic]
MustInherit Public Class AbstractFolder
   Inherits FileSystemItem
[C#]
public abstract class AbstractFolder : FileSystemItem

Requirements

Namespace: Xceed.FileSystem Namespace

Assembly: Xceed.FileSystem.dll

See Also

AbstractFolder Members | Xceed.FileSystem Namespace


AbstractFolder Members

Public Instance Properties

Attributes (inherited from FileSystemItem) | Gets or sets the attributes of the item.
CreationDateTime (inherited from FileSystemItem) | Gets or sets the creation date and time of the item.
Exists (inherited from FileSystemItem) | Gets a boolean value indicating if the item physically exists.
FullName (inherited from FileSystemItem) | Gets the full name of the item.
IsRoot | Gets a value indicating if the folder is a root folder.
LastAccessDateTime (inherited from FileSystemItem) | Gets or sets the last access date and time of the item.
LastWriteDateTime (inherited from FileSystemItem) | Gets or sets the modification date and time of the item.
Name (inherited from FileSystemItem) | Gets or sets the short name of the item.
ParentFolder (inherited from FileSystemItem) | Gets a reference to the parent folder of this item.
RootFolder (inherited from FileSystemItem) | Gets a reference to the root folder of this item.

Public Instance Methods

ApplyPropertiesTo (inherited from FileSystemItem) | Overloaded. Copies the item's properties to another item.
CopyFilesTo | Overloaded. Copies the folder's content to another folder.
CopyTo (inherited from FileSystemItem) | Overloaded. Copies the item, or it's content to the destination.
Create (inherited from FileSystemItem) | Overloaded. Creates the physical item represented by the object.
CreateFile | Overloaded. Creates a new file in the folder.
CreateFolder | Overloaded. Creates a new folder in the folder.
CreateObjRef (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Delete (inherited from FileSystemItem) | Overloaded. Permanently deletes the physical item.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetFile | Overloaded. Returns an object that represents a file contained in the folder.
GetFiles | Overloaded. Returns a filtered list of files contained in the folder.
GetFolder | Overloaded. Returns an object that represents a folder contained in the folder.
GetFolders | Overloaded. Returns a filtered list of folders contained in the folder.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetItems | Overloaded. Returns a list of items contained in the folder.
GetLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
InitializeLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
MoveFilesTo | Overloaded. Moves the folder's content to another folder.
MoveTo (inherited from FileSystemItem) | Overloaded. Moves the item, or it's content to the destination.
Refresh (inherited from FileSystemItem) | Overloaded. Re-reads the information from the physical item.
ToString (inherited from FileSystemItem) | Returns the full name of the item.

Protected Instance Constructors

AbstractFolder Constructor

Protected Instance Fields

m_isRoot Identifies if this folder is a root folder.

Protected Instance Properties

DoAttributes (inherited from FileSystemItem) | Gets or sets the attributes of the item. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoCreationDateTime (inherited from FileSystemItem) | Gets or sets the creation date and time of the item. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoExists (inherited from FileSystemItem) | Gets a boolean value indicating if the item physically exists. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoFullName (inherited from FileSystemItem) | Gets the full name of the item. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoIsRoot | Gets a boolean value indicating if the folder is a root folder.
DoLastAccessDateTime (inherited from FileSystemItem) | Gets or sets the last access date and time of the item. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoLastWriteDateTime (inherited from FileSystemItem) | Gets or sets the modification date and time of the item. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoName (inherited from FileSystemItem) | Gets or sets the short name of the item. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoParentFolder (inherited from FileSystemItem) | Gets a reference to the parent folder of this item. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoRootFolder (inherited from FileSystemItem) | Gets a reference to the root folder of this item. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.
InvalidChars (inherited from FileSystemItem) | Gets the characters that are invalid in file and folder names.

Protected Instance Methods

BuildListForCreate (inherited from FileSystemItem) | Handles the special cases in regards to building the list of items to process when creating a FileSystemItem object.
DoApplyPropertiesTo (inherited from FileSystemItem) | Copies the item's properties to another item. This method must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoCopyTo | Copies the folder to another folder.
DoGetChildItems | Retrieves an array of FileSystemItem objects. This method must be overridden when deriving from this class.
DoGetFile | Retrieves a reference to an AbstractFile object. This method must be overridden when deriving from this class.
DoGetFiles | Retrieves an array of AbstractFile objects.
DoGetFolder | Retrieves a reference to an AbstractFolder object. This method must be overridden when deriving from this class.
DoGetFolders | Retrieves an array of AbstractFolder objects.
DoGetItems | Retrieves an array of FileSystemItem objects.
DoRefresh (inherited from FileSystemItem) | Re-reads the information from the physical item. This method must be overridden when deriving from the AbstractFolder or AbstractFile classes.
EnsureDateIsValid (inherited from FileSystemItem) | Ensures that the System.DateTime value is valid.
Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsPathRooted (inherited from FileSystemItem) | Returns a boolean value indicating if the path passed is rooted in the environment of the FileSystemItem object we are dealing with. This method must be overridden when deriving from the AbstractFolder or AbstractFile classes.
IsSameAs (inherited from FileSystemItem) | Gets a boolean value indicating if the source and target items are the same. This method must be overridden when deriving from the AbstractFolder or AbstractFile classes.
ListCopyTo (inherited from FileSystemItem) | Copies each item in the FileSystemEventsSession object's list to each item's destination.
ListCreate (inherited from FileSystemItem) | Creates each item in the FileSystemEventsSession object's list.
ListDelete (inherited from FileSystemItem) | Deletes each item in the FileSystemEventsSession object's list.
ListMoveTo (inherited from FileSystemItem) | Moves each item in the FileSystemEventsSession object's list to each item's destination.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Internal Instance Methods

BuildList | Builds a list of FileSystemItem objects to process.
DoCreate (inherited from FileSystemItem) | Creates the physical item represented by the FileSystemItem object. This method must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoDelete (inherited from FileSystemItem) | Permanently deletes the physical item. This method must be overridden when deriving from the AbstractFolder or AbstractFile classes.

See Also

AbstractFolder Class | Xceed.FileSystem Namespace


AbstractFolder Constructor

[Visual Basic]
Protected Sub New()
[C#]
protected AbstractFolder();

See Also

AbstractFolder Class | AbstractFolder Members | Xceed.FileSystem Namespace


AbstractFolder Fields

The fields of the AbstractFolder class are listed below. For a complete list of AbstractFolder class members, see the AbstractFolder Members topic.

Protected Instance Fields

m_isRoot Identifies if this folder is a root folder.

See Also

AbstractFolder Class | Xceed.FileSystem Namespace


AbstractFolder.m_isRoot Field

Identifies if this folder is a root folder.

[Visual Basic]
Protected m_isRoot As Boolean
[C#]
protected bool m_isRoot;

Remarks

Notes to inheritors: The constructors of derived classes should set this field to true if they represent the root folder.

See Also

AbstractFolder Class | AbstractFolder Members | Xceed.FileSystem Namespace


AbstractFolder Properties

The properties of the AbstractFolder class are listed below. For a complete list of AbstractFolder class members, see the AbstractFolder Members topic.

Public Instance Properties

Attributes (inherited from FileSystemItem) | Gets or sets the attributes of the item.
CreationDateTime (inherited from FileSystemItem) | Gets or sets the creation date and time of the item.
Exists (inherited from FileSystemItem) | Gets a boolean value indicating if the item physically exists.
FullName (inherited from FileSystemItem) | Gets the full name of the item.
IsRoot | Gets a value indicating if the folder is a root folder.
LastAccessDateTime (inherited from FileSystemItem) | Gets or sets the last access date and time of the item.
LastWriteDateTime (inherited from FileSystemItem) | Gets or sets the modification date and time of the item.
Name (inherited from FileSystemItem) | Gets or sets the short name of the item.
ParentFolder (inherited from FileSystemItem) | Gets a reference to the parent folder of this item.
RootFolder (inherited from FileSystemItem) | Gets a reference to the root folder of this item.

Protected Instance Properties

DoAttributes (inherited from FileSystemItem) | Gets or sets the attributes of the item. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoCreationDateTime (inherited from FileSystemItem) | Gets or sets the creation date and time of the item. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoExists (inherited from FileSystemItem) | Gets a boolean value indicating if the item physically exists. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoFullName (inherited from FileSystemItem) | Gets the full name of the item. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoIsRoot | Gets a boolean value indicating if the folder is a root folder.
DoLastAccessDateTime (inherited from FileSystemItem) | Gets or sets the last access date and time of the item. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoLastWriteDateTime (inherited from FileSystemItem) | Gets or sets the modification date and time of the item. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoName (inherited from FileSystemItem) | Gets or sets the short name of the item. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoParentFolder (inherited from FileSystemItem) | Gets a reference to the parent folder of this item. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoRootFolder (inherited from FileSystemItem) | Gets a reference to the root folder of this item. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.
InvalidChars (inherited from FileSystemItem) | Gets the characters that are invalid in file and folder names.

See Also

AbstractFolder Class | Xceed.FileSystem Namespace


AbstractFolder.DoIsRoot Property

Gets a boolean value indicating if the folder is a root folder.

[Visual Basic]
Overridable Protected ReadOnly Property DoIsRoot As Boolean
[C#]
protected bool DoIsRoot {virtual get;}

Property Value

true if the folder represented by the AbstractFolder class is a root folder; false otherwise.

See Also

AbstractFolder Class | AbstractFolder Members | Xceed.FileSystem Namespace


AbstractFolder.IsRoot Property

Gets a value indicating if the folder is a root folder.

[Visual Basic]
Public ReadOnly Property IsRoot As Boolean
[C#]
public bool IsRoot {get;}

Property Value

true if the folder is a root folder; false otherwise.

Remarks

See RootFolder for more information about root folders.

See Also

AbstractFolder Class | AbstractFolder Members | Xceed.FileSystem Namespace


AbstractFolder Methods

The methods of the AbstractFolder class are listed below. For a complete list of AbstractFolder class members, see the AbstractFolder Members topic.

Public Instance Methods

ApplyPropertiesTo (inherited from FileSystemItem) | Overloaded. Copies the item's properties to another item.
CopyFilesTo | Overloaded.
CopyTo (inherited from FileSystemItem) | Overloaded. Copies the item, or it's content to the destination.
Create (inherited from FileSystemItem) | Overloaded. Creates the physical item represented by the object.
CreateFile | Overloaded.
CreateFolder | Overloaded.
CreateObjRef (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Delete (inherited from FileSystemItem) | Overloaded. Permanently deletes the physical item.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetFile | Overloaded.
GetFiles | Overloaded.
GetFolder | Overloaded.
GetFolders | Overloaded.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetItems | Overloaded.
GetLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
InitializeLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
MoveFilesTo | Overloaded.
MoveTo (inherited from FileSystemItem) | Overloaded. Moves the item, or it's content to the destination.
Refresh (inherited from FileSystemItem) | Overloaded. Re-reads the information from the physical item.
ToString (inherited from FileSystemItem) | Returns the full name of the item.

Protected Instance Methods

BuildListForCreate (inherited from FileSystemItem) | Handles the special cases in regards to building the list of items to process when creating a FileSystemItem object.
DoApplyPropertiesTo (inherited from FileSystemItem) | Copies the item's properties to another item. This method must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoCopyTo | Copies the folder to another folder.
DoGetChildItems | Retrieves an array of FileSystemItem objects. This method must be overridden when deriving from this class.
DoGetFile | Retrieves a reference to an AbstractFile object. This method must be overridden when deriving from this class.
DoGetFiles | Retrieves an array of AbstractFile objects.
DoGetFolder | Retrieves a reference to an AbstractFolder object. This method must be overridden when deriving from this class.
DoGetFolders | Retrieves an array of AbstractFolder objects.
DoGetItems | Retrieves an array of FileSystemItem objects.
DoRefresh (inherited from FileSystemItem) | Re-reads the information from the physical item. This method must be overridden when deriving from the AbstractFolder or AbstractFile classes.
EnsureDateIsValid (inherited from FileSystemItem) | Ensures that the System.DateTime value is valid.
Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsPathRooted (inherited from FileSystemItem) | Returns a boolean value indicating if the path passed is rooted in the environment of the FileSystemItem object we are dealing with. This method must be overridden when deriving from the AbstractFolder or AbstractFile classes.
IsSameAs (inherited from FileSystemItem) | Gets a boolean value indicating if the source and target items are the same. This method must be overridden when deriving from the AbstractFolder or AbstractFile classes.
ListCopyTo (inherited from FileSystemItem) | Copies each item in the FileSystemEventsSession object's list to each item's destination.
ListCreate (inherited from FileSystemItem) | Creates each item in the FileSystemEventsSession object's list.
ListDelete (inherited from FileSystemItem) | Deletes each item in the FileSystemEventsSession object's list.
ListMoveTo (inherited from FileSystemItem) | Moves each item in the FileSystemEventsSession object's list to each item's destination.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Internal Instance Methods

BuildList | Builds a list of FileSystemItem objects to process.
DoCreate (inherited from FileSystemItem) | Creates the physical item represented by the FileSystemItem object. This method must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoDelete (inherited from FileSystemItem) | Permanently deletes the physical item. This method must be overridden when deriving from the AbstractFolder or AbstractFile classes.

See Also

AbstractFolder Class | Xceed.FileSystem Namespace


AbstractFolder.BuildList Method

Builds a list of FileSystemItem objects to process.

[Visual Basic]
Overrides Protected Friend Sub BuildList( _
   ByVal session As Xceed.FileSystem.FileSystemEventsSession, _
   ByVal destination As Xceed.FileSystem.FileSystemItem, _
   ByVal forward As Boolean, _
   ByVal recursive As Boolean, _
   ByVal includeFolders As Boolean, _
   ByVal filters As Xceed.FileSystem.Filter() _
)
[C#]
protected internal override void BuildList(
   FileSystemEventsSession session,
   FileSystemItem destination,
   bool forward,
   bool recursive,
   bool includeFolders,
   Filter[] filters
);

Parameters

session

A reference to a FileSystemEventsSession object which is responsible for raising all events that occur during the process.

destination

The eventual target for the item that will be procesed. For example, the desination folder for a folder that will be copied.

forward

true if folders will be added to the list of FileSystemItem objects to process first; false if files will be added to the list first.

recursive

true if items in subfolders should be added to the list of items to process; false otherwise.

includeFolders

true if folders will be included in the list of items to process; false otherwise.

filters

An array of objects that can be used to filter the list of FileSystemItem objects to process.

See Also

AbstractFolder Class | AbstractFolder Members | Xceed.FileSystem Namespace


CopyFilesTo Method

Xceed Zip for .NET

AbstractFolder.CopyFilesTo

Copies the folder's content to another folder.

Overload List

Copies the folder's content to another folder.

public void CopyFilesTo(AbstractFolder,bool,bool,params object[]);

Copies the folder's content to another folder, and raises events during the process.

public void CopyFilesTo(FileSystemEvents,object,AbstractFolder,bool,bool,params object[]);

See Also

AbstractFolder Class | AbstractFolder Members | Xceed.FileSystem Namespace


AbstractFolder.CopyFilesTo Method (AbstractFolder, Boolean, Boolean, Object[])

Copies the folder's content to another folder.

[Visual Basic]
Overloads Public Sub CopyFilesTo( _
   ByVal destinationFolder As Xceed.FileSystem.AbstractFolder, _
   ByVal recursive As Boolean, _
   ByVal replaceExistingFiles As Boolean, _
   ByVal filters As Object() _
)
[C#]
public void CopyFilesTo(
   AbstractFolder destinationFolder,
   bool recursive,
   bool replaceExistingFiles,
   params object[] filters
);

Parameters

destinationFolder

An AbstractFolder object into which the folder's content must be copied. Cannot be a null reference (Nothing in Visual Basic).

recursive

true if the content of the folders contained in the subfolders should be copied; false if only the current folder's content should be copied.

replaceExistingFiles

true if existing files in the destination should be replaced; false otherwise.

filters

An array of objects that can be used to filter the items to be copied.

Remarks

If the physical folder specified by destinationFolder does not exist, it is created.

The folder's content (files and subfolders) that matches the provided filters is immediately copied to the destination.

When replacingExistingFiles is true, any file in the destination that has the same name as a file being copied is automatically replaced.

When replacingExistingFiles is false, an exception is thrown whenever the destination contains a file with the same name as a file being copied.

To filter a list of files or folders, you can pass a variable number of objects in the filters parameter. These objects may be of the following types:

Object type | Type of filter applied
System.String | The string is assumed to be a file mask, and a NameFilter object is automatically created for the passed string, with File as the default FilterScope.
System.IO.FileAttributes | A AttributeFilter object is automatically created for the provided attributes, with File as the default FilterScope.
Filter | The provided Filter object is used as-is.
Array of System.Object | Each object in the array may be of the types described in this table, and is used accordingly.
Other | If any other type is found, an exception is thrown.

Exceptions

Exception Type | Condition
Xceed.FileSystem.ItemDoesNotExistException | The folder represented by this AbstractFolder does not physically exist.
Xceed.FileSystem.ItemAlreadyExistsException | One of the destination files already exists, and replaceExistingFiles is false.
Xceed.FileSystem.ItemIsReadOnlyException | One of the destination files already exists, replaceExistingFiles is true, but the destination file has the ReadOnly attribute.
Xceed.FileSystem.FileSystemIOException | The source file could not be read from, or the destination file could not be written to.

See Also

AbstractFolder Class | AbstractFolder Members | Xceed.FileSystem Namespace | AbstractFolder.CopyFilesTo Overload List


AbstractFolder.CopyFilesTo Method (FileSystemEvents, Object, AbstractFolder, Boolean, Boolean, Object[])

Copies the folder's content to another folder, and raises events during the process.

[Visual Basic]
Overloads Public Sub CopyFilesTo( _
   ByVal events As Xceed.FileSystem.FileSystemEvents, _
   ByVal userData As Object, _
   ByVal destinationFolder As Xceed.FileSystem.AbstractFolder, _
   ByVal recursive As Boolean, _
   ByVal replaceExistingFiles As Boolean, _
   ByVal filters As Object() _
)
[C#]
public void CopyFilesTo(
   FileSystemEvents events,
   object userData,
   AbstractFolder destinationFolder,
   bool recursive,
   bool replaceExistingFiles,
   params object[] filters
);

Parameters

events

A FileSystemEvents object that will be used to raise events. Cannot be a null reference (Nothing in Visual Basic).

userData

Opaque data that will be passed back to the event handler when an event is raised.

destinationFolder

An AbstractFolder object into which the folder's content must be copied. Cannot be a null reference (Nothing in Visual Basic).

recursive

true if the content of the folders contained in the subfolders should be copied; false if only the current folder's content should be copied.

replaceExistingFiles

true if existing files in the destination should be replaced; false otherwise.

filters

An array of objects that can be used to filter the items to be copied.

Remarks

If the physical folder specified by destinationFolder does not exist, it is created.

The folder's content (files and subfolders) that matches the provided filters is immediately copied to the destination.

When replacingExistingFiles is true, any file in the destination that has the same name as a file being copied is automatically replaced.

When replacingExistingFiles is false, an exception is thrown whenever the destination contains a file with the same name as a file being copied.

To filter a list of files or folders, you can pass a variable number of objects in the filters parameter. These objects may be of the following types:

Object type | Type of filter applied
System.String | The string is assumed to be a file mask, and a NameFilter object is automatically created for the passed string, with File as the default FilterScope.
System.IO.FileAttributes | A AttributeFilter object is automatically created for the provided attributes, with File as the default FilterScope.
Filter | The provided Filter object is used as-is.
Array of System.Object | Each object in the array may be of the types described in this table, and is used accordingly.
Other | If any other type is found, an exception is thrown.

Events

Event Type | Reason
Xceed.FileSystem.FileSystemEvents.ScanningFolder | A folder is being scanned for files to be copied.
Xceed.FileSystem.FileSystemEvents.ItemProgression | Every time a file is about to be copied, reports how many files have been copied and the total number of files that must be copied.
Xceed.FileSystem.FileSystemEvents.ByteProgression | Every 32k, reports how many bytes have been and must be copied for the current file, as well as for the entire set of files that are being copied.
Xceed.FileSystem.FileSystemEvents.ItemException | When an exception occurs while copying a file, reports the exception and allows to recover from the exception and continue copying the files.

Exceptions

Exception Type | Condition
Xceed.FileSystem.ItemDoesNotExistException | The folder represented by this AbstractFolder does not physically exist.
Xceed.FileSystem.ItemAlreadyExistsException | One of the destination files already exists, and replaceExistingFiles is false.
Xceed.FileSystem.ItemIsReadOnlyException | One of the destination files already exists, replaceExistingFiles is true, but the destination file has the ReadOnly attribute.
Xceed.FileSystem.FileSystemIOException | The source file could not be read from, or the destination file could not be written to.

See Also

AbstractFolder Class | AbstractFolder Members | Xceed.FileSystem Namespace | AbstractFolder.CopyFilesTo Overload List


CreateFile Method

Xceed Zip for .NET

AbstractFolder.CreateFile

Creates a new file in the folder.

Overload List

Creates a new file in the folder.

public AbstractFile CreateFile(string,bool);

Creates a new file in the folder and raises events during the process.

public AbstractFile CreateFile(FileSystemEvents,object,string,bool);

See Also

AbstractFolder Class | AbstractFolder Members | Xceed.FileSystem Namespace


AbstractFolder.CreateFile Method (String, Boolean)

Creates a new file in the folder.

[Visual Basic]
Overloads Public Function CreateFile( _
   ByVal relativeName As String, _
   ByVal replaceIfExists As Boolean _
) As Xceed.FileSystem.AbstractFile
[C#]
public AbstractFile CreateFile(
   string relativeName,
   bool replaceIfExists
);

Parameters

relativeName

Relative name of the new file.

replaceIfExists

true if the new file should replace an existing file; false otherwise.

Return Value

An AbstractFile object representing the newly created file.

Remarks

The relativeName parameter can include relative path information, in which ".." means "previous folder". For example: "foo/bar.txt", "../bar.txt", etc.

If a file named relativeName already exist in the destination folder and replaceIfExists is false, an exception is thrown. If replaceIfExists is true, the existing file is replaced by the newly created one.

If the physical folder in which the new file is to be created does not exist, it is created.

The current property values (such as Attributes) are applied to the newly created file.

Exceptions

Exception Type | Condition
System.ArgumentException | The relativeName parameter is an empty string, contains only white space, or contains invalid characters as defined in InvalidChars.
Xceed.FileSystem.ItemAlreadyExistsException | The destination file already exists, and replaceIfExists is false.
Xceed.FileSystem.ItemIsReadOnlyException | The destination file already exists, replaceIfExists is true, but the destination file has the ReadOnly attribute.

See Also

AbstractFolder Class | AbstractFolder Members | Xceed.FileSystem Namespace | AbstractFolder.CreateFile Overload List


AbstractFolder.CreateFile Method (FileSystemEvents, Object, String, Boolean)

Creates a new file in the folder and raises events during the process.

[Visual Basic]
Overloads Public Function CreateFile( _
   ByVal events As Xceed.FileSystem.FileSystemEvents, _
   ByVal userData As Object, _
   ByVal relativeName As String, _
   ByVal replaceIfExists As Boolean _
) As Xceed.FileSystem.AbstractFile
[C#]
public AbstractFile CreateFile(
   FileSystemEvents events,
   object userData,
   string relativeName,
   bool replaceIfExists
);

Parameters

events

A FileSystemEvents object that will be used to raise events. Cannot be a null reference (Nothing in Visual Basic).

userData

Opaque data that will be passed back to the event handler when an event is raised.

relativeName

Relative name of the new file.

replaceIfExists

true if the new file should replace an existing file; false otherwise.

Return Value

An AbstractFile object representing the newly created file.

Remarks

The relativeName parameter can include relative path information, in which ".." means "previous folder". For example: "foo/bar.txt", "../bar.txt", etc.

If a file named relativeName already exist in the destination folder and replaceIfExists is false, an exception is thrown. If replaceIfExists is true, the existing file is replaced by the newly created one.

If the physical folder in which the new file is to be created does not exist, it is created.

The current property values (such as Attributes) are applied to the newly created file.

Exceptions

Exception Type | Condition
System.ArgumentException | The relativeName parameter is an empty string, contains only white space, or contains invalid characters as defined in InvalidChars.
Xceed.FileSystem.ItemAlreadyExistsException | The destination file already exists, and replaceIfExists is false.
Xceed.FileSystem.ItemIsReadOnlyException | The destination file already exists, replaceIfExists is true, but the destination file has the ReadOnly attribute.

See Also

AbstractFolder Class | AbstractFolder Members | Xceed.FileSystem Namespace | AbstractFolder.CreateFile Overload List


CreateFolder Method

Xceed Zip for .NET

AbstractFolder.CreateFolder

Creates a new folder in the folder.

Overload List

Creates a new folder in the folder.

public AbstractFolder CreateFolder(string);

Creates a new folder in the folder and raises events during the process.

public AbstractFolder CreateFolder(FileSystemEvents,object,string);

See Also

AbstractFolder Class | AbstractFolder Members | Xceed.FileSystem Namespace


AbstractFolder.CreateFolder Method (String)

Creates a new folder in the folder.

[Visual Basic]
Overloads Public Function CreateFolder( _
   ByVal relativeName As String _
) As Xceed.FileSystem.AbstractFolder
[C#]
public AbstractFolder CreateFolder(
   string relativeName
);

Parameters

relativeName

Relative name of the new folder.

Return Value

An AbstractFolder object representing the newly created folder.

Remarks

The relativeName parameter can include relative path information, in which ".." means "previous folder". For example: "foo/bar", "../bar", etc.

If a folder named relativeName already exist, this method does nothing.

If the physical folder in which the new folder is to be created does not exist, it is created.

The current property values (such as Attributes) are applied to the newly created folder.

Exceptions

Exception Type | Condition
System.ArgumentException | The relativeName parameter is an empty string, contains only white space, or contains invalid characters as defined in InvalidChars.

See Also

AbstractFolder Class | AbstractFolder Members | Xceed.FileSystem Namespace | AbstractFolder.CreateFolder Overload List


AbstractFolder.CreateFolder Method (FileSystemEvents, Object, String)

Creates a new folder in the folder and raises events during the process.

[Visual Basic]
Overloads Public Function CreateFolder( _
   ByVal events As Xceed.FileSystem.FileSystemEvents, _
   ByVal userData As Object, _
   ByVal relativeName As String _
) As Xceed.FileSystem.AbstractFolder
[C#]
public AbstractFolder CreateFolder(
   FileSystemEvents events,
   object userData,
   string relativeName
);

Parameters

events

A FileSystemEvents object that will be used to raise events. Cannot be a null reference (Nothing in Visual Basic).

userData

Opaque data that will be passed back to the event handler when an event is raised.

relativeName

Relative name of the new file.

Return Value

An AbstractFolder object representing the newly created folder.

Remarks

The relativeName parameter can include relative path information, in which ".." means "previous folder". For example: "foo/bar", "../bar", etc.

If a folder named relativeName already exist, this method does nothing.

If the physical folder in which the new folder is to be created does not exist, it is created.

The current property values (such as Attributes) are applied to the newly created folder.

Exceptions

Exception Type | Condition
System.ArgumentException | The relativeName parameter is an empty string, contains only white space, or contains invalid characters as defined in InvalidChars.

See Also

AbstractFolder Class | AbstractFolder Members | Xceed.FileSystem Namespace | AbstractFolder.CreateFolder Overload List


AbstractFolder.DoCopyTo Method

Copies the folder to another folder.

[Visual Basic]
Overrides Protected Sub DoCopyTo( _
   ByVal session As Xceed.FileSystem.FileSystemEventsSession, _
   ByVal destination As Xceed.FileSystem.FileSystemItem, _
   ByVal replaceExistingFiles As Boolean _
)
[C#]
protected override void DoCopyTo(
   FileSystemEventsSession session,
   FileSystemItem destination,
   bool replaceExistingFiles
);

Parameters

session

A reference to a FileSystemEventsSession object which is responsible for raising all events that occur during the process.

destination

An FileSystemItem object into which the folder will be copied. Cannot be a null reference (Nothing in Visual Basic).

replaceExistingFiles

true if existing items in the destination should be replaced; false otherwise.

Exceptions

Exception Type | Condition
Xceed.FileSystem.ItemDoesNotExistException | The physical item does not exist.
Xceed.FileSystem.FileSystemNotSupportedException | The source and target folders are the same item.

See Also

AbstractFolder Class | AbstractFolder Members | Xceed.FileSystem Namespace


AbstractFolder.DoGetChildItems Method

Retrieves an array of FileSystemItem objects. This method must be overridden when deriving from this class.

[Visual Basic]
MustOverride Protected Function DoGetChildItems( _
   ByVal session As Xceed.FileSystem.FileSystemEventsSession _
) As Xceed.FileSystem.FileSystemItem()
[C#]
protected abstract FileSystemItem[] DoGetChildItems(
   FileSystemEventsSession session
);

Parameters

session

A reference to a FileSystemEventsSession object which is responsible for raising all events that occur during the process.

Return Value

An array of FileSystemItem objects representing the items ( files and folders ) contained within the folder.

See Also

AbstractFolder Class | AbstractFolder Members | Xceed.FileSystem Namespace


AbstractFolder.DoGetFile Method

Retrieves a reference to an AbstractFile object. This method must be overridden when deriving from this class.

[Visual Basic]
MustOverride Protected Function DoGetFile( _
   ByVal session As Xceed.FileSystem.FileSystemEventsSession, _
   ByVal fileName As String _
) As Xceed.FileSystem.AbstractFile
[C#]
protected abstract AbstractFile DoGetFile(
   FileSystemEventsSession session,
   string fileName
);

Parameters

session

A reference to a FileSystemEventsSession object which is responsible for raising all events that occur during the process.

fileName

The name of the file to retrieve.

Return Value

Should return a reference to an AbstractFile object regardless if the file represented by the object exists or not.

Remarks

fileName should not end with a System.IO.Path.DirectorySeparatorChar.

See Also

AbstractFolder Class | AbstractFolder Members | Xceed.FileSystem Namespace


AbstractFolder.DoGetFiles Method

Retrieves an array of AbstractFile objects.

[Visual Basic]
Overridable Protected Function DoGetFiles( _
   ByVal session As Xceed.FileSystem.FileSystemEventsSession, _
   ByVal recursive As Boolean, _
   ByVal filters As Xceed.FileSystem.Filter() _
) As Xceed.FileSystem.AbstractFile()
[C#]
protected virtual AbstractFile[] DoGetFiles(
   FileSystemEventsSession session,
   bool recursive,
   Filter[] filters
);

Parameters

session

A reference to a FileSystemEventsSession object which is responsible for raising all events that occur during the process.

recursive

true if items in subfolders should be processed; false otherwise.

filters

An array of objects that can be used to filter the list of FileSystemItem objects to process.

Return Value

An array of AbstractFile objects representing the files contained within the folder.

See Also

AbstractFolder Class | AbstractFolder Members | Xceed.FileSystem Namespace


AbstractFolder.DoGetFolder Method

Retrieves a reference to an AbstractFolder object. This method must be overridden when deriving from this class.

[Visual Basic]
MustOverride Protected Function DoGetFolder( _
   ByVal session As Xceed.FileSystem.FileSystemEventsSession, _
   ByVal folderName As String _
) As Xceed.FileSystem.AbstractFolder
[C#]
protected abstract AbstractFolder DoGetFolder(
   FileSystemEventsSession session,
   string folderName
);

Parameters

session

A reference to a FileSystemEventsSession object which is responsible for raising all events that occur during the process.

folderName

The name of the folder to retrieve.

Return Value

Should return reference to an AbstractFolder object regardless if the folder represented by the object exists or not.

Remarks

folderName should not end with a System.IO.Path.DirectorySeparatorChar.

See Also

AbstractFolder Class | AbstractFolder Members | Xceed.FileSystem Namespace


AbstractFolder.DoGetFolders Method

Retrieves an array of AbstractFolder objects.

[Visual Basic]
Overridable Protected Function DoGetFolders( _
   ByVal session As Xceed.FileSystem.FileSystemEventsSession, _
   ByVal recursive As Boolean, _
   ByVal filters As Xceed.FileSystem.Filter() _
) As Xceed.FileSystem.AbstractFolder()
[C#]
protected virtual AbstractFolder[] DoGetFolders(
   FileSystemEventsSession session,
   bool recursive,
   Filter[] filters
);

Parameters

session

A reference to a FileSystemEventsSession object which is responsible for raising all events that occur during the process.

recursive

true if items in subfolders should be processed; false otherwise.

filters

An array of objects that can be used to filter the list of FileSystemItem objects to process.

Return Value

An array of AbstractFolder objects representing the folders contained within the folder.

See Also

AbstractFolder Class | AbstractFolder Members | Xceed.FileSystem Namespace


AbstractFolder.DoGetItems Method

Retrieves an array of FileSystemItem objects.

[Visual Basic]
Overridable Protected Function DoGetItems( _
   ByVal session As Xceed.FileSystem.FileSystemEventsSession, _
   ByVal recursive As Boolean _
) As Xceed.FileSystem.FileSystemItem()
[C#]
protected virtual FileSystemItem[] DoGetItems(
   FileSystemEventsSession session,
   bool recursive
);

Parameters

session

A reference to a FileSystemEventsSession object which is responsible for raising all events that occur during the process.

recursive

true if items in subfolders should be processed; false otherwise.

Return Value

An array of FileSystemItem objects representing the files and folders contained within the folder.

Exceptions

Exception Type | Condition
Xceed.FileSystem.ItemDoesNotExistException | The physical item does not exist.

See Also

AbstractFolder Class | AbstractFolder Members | Xceed.FileSystem Namespace


GetFile Method

Xceed Zip for .NET

AbstractFolder.GetFile

Returns an AbstractFile object that represents a file contained in the folder.

Overload List

Returns an AbstractFile object that represents a file contained in the folder.

public AbstractFile GetFile(string);

Returns an AbstractFile object that represents a file contained in the folder and raises events during the process.

public AbstractFile GetFile(FileSystemEvents,object,string);

See Also

AbstractFolder Class | AbstractFolder Members | Xceed.FileSystem Namespace


AbstractFolder.GetFile Method (String)

Returns an AbstractFile object that represents a file contained in the folder.

[Visual Basic]
Overloads Public Function GetFile( _
   ByVal relativeName As String _
) As Xceed.FileSystem.AbstractFile
[C#]
public AbstractFile GetFile(
   string relativeName
);

Parameters

relativeName

Relative name of the file to retrieve.

Return Value

An AbstractFile object representing the file named relativeName.

Remarks

The relativeName parameter can include relative path information, in which ".." means "previous folder". For example: "foo/bar.txt", "../bar.txt", etc.

This method allows to get a reference to an AbstractFile object for a file that exists, as well as for a file that does not exist. Further, the folder on which this method is called may not exist.

Exceptions

Exception Type | Condition
System.ArgumentException | The relativeName parameter is an empty string, contains only white space, or contains invalid characters as defined in InvalidChars.

See Also

AbstractFolder Class | AbstractFolder Members | Xceed.FileSystem Namespace | AbstractFolder.GetFile Overload List


AbstractFolder.GetFile Method (FileSystemEvents, Object, String)

Returns an AbstractFile object that represents a file contained in the folder and raises events during the process.

[Visual Basic]
Overloads Public Function GetFile( _
   ByVal events As Xceed.FileSystem.FileSystemEvents, _
   ByVal userData As Object, _
   ByVal relativeName As String _
) As Xceed.FileSystem.AbstractFile
[C#]
public AbstractFile GetFile(
   FileSystemEvents events,
   object userData,
   string relativeName
);

Parameters

events

A FileSystemEvents object that will be used to raise events. Cannot be a null reference (Nothing in Visual Basic).

userData

Opaque data that will be passed back to the event handler when an event is raised.

relativeName

Relative name of the file to retrieve.

Return Value

An AbstractFile object representing the file named relativeName.

Remarks

The relativeName parameter can include relative path information, in which ".." means "previous folder". For example: "foo/bar.txt", "../bar.txt", etc.

This method allows to get a reference to an AbstractFile object for a file that exists, as well as for a file that does not exist. Further, the folder on which this method is called may not exist.

Exceptions

Exception Type | Condition
System.ArgumentException | The relativeName parameter is an empty string, contains only white space, or contains invalid characters as defined in InvalidChars.

See Also

AbstractFolder Class | AbstractFolder Members | Xceed.FileSystem Namespace | AbstractFolder.GetFile Overload List


GetFiles Method

Xceed Zip for .NET

AbstractFolder.GetFiles

Returns a filtered list of files contained in the folder.

Overload List

Returns a filtered list of files contained in the folder.

public AbstractFile[] GetFiles(bool,params object[]);

Returns a filtered list of files contained in the folder, and raises events during the process.

public AbstractFile[] GetFiles(FileSystemEvents,object,bool,params object[]);

See Also

AbstractFolder Class | AbstractFolder Members | Xceed.FileSystem Namespace


AbstractFolder.GetFiles Method (Boolean, Object[])

Returns a filtered list of files contained in the folder.

[Visual Basic]
Overloads Public Function GetFiles( _
   ByVal recursive As Boolean, _
   ByVal filters As Object() _
) As Xceed.FileSystem.AbstractFile()
[C#]
public AbstractFile[] GetFiles(
   bool recursive,
   params object[] filters
);

Parameters

recursive

true if files contained in the subfolders should be returned; false if only files that are immediate children of the folder should be returned.

filters

An array of objects that can be used to filter the list of files returned.

Return Value

An array of AbstractFile objects representing the files that match the specified filters.

Remarks

To filter a list of files or folders, you can pass a variable number of objects in the filters parameter. These objects may be of the following types:

Object type | Type of filter applied
System.String | The string is assumed to be a file mask, and a NameFilter object is automatically created for the passed string, with File as the default FilterScope.
System.IO.FileAttributes | A AttributeFilter object is automatically created for the provided attributes, with File as the default FilterScope.
Filter | The provided Filter object is used as-is.
Array of System.Object | Each object in the array may be of the types described in this table, and is used accordingly.
Other | If any other type is found, an exception is thrown.

Exceptions

Exception Type | Condition
System.ArgumentException | An invalid type was passed in the filters parameter.
Xceed.FileSystem.ItemDoesNotExistException | The folder represented by this AbstractFolder does not physically exist.

See Also

AbstractFolder Class | AbstractFolder Members | Xceed.FileSystem Namespace | AbstractFolder.GetFiles Overload List


AbstractFolder.GetFiles Method (FileSystemEvents, Object, Boolean, Object[])

Returns a filtered list of files contained in the folder, and raises events during the process.

[Visual Basic]
Overloads Public Function GetFiles( _
   ByVal events As Xceed.FileSystem.FileSystemEvents, _
   ByVal userData As Object, _
   ByVal recursive As Boolean, _
   ByVal filters As Object() _
) As Xceed.FileSystem.AbstractFile()
[C#]
public AbstractFile[] GetFiles(
   FileSystemEvents events,
   object userData,
   bool recursive,
   params object[] filters
);

Parameters

events

A FileSystemEvents object that will be used to raise events. Cannot be a null reference (Nothing in Visual Basic).

userData

Opaque data that will be passed back to the event handler when an event is raised.

recursive

true if files contained in the subfolders should be returned; false if only files that are immediate children of the folder should be returned.

filters

An array of objects that can be used to filter the list of files returned.

Return Value

An array of AbstractFile objects representing the files that match the specified filters.

Remarks

To filter a list of files or folders, you can pass a variable number of objects in the filters parameter. These objects may be of the following types:

Object type | Type of filter applied
System.String | The string is assumed to be a file mask, and a NameFilter object is automatically created for the passed string, with File as the default FilterScope.
System.IO.FileAttributes | A AttributeFilter object is automatically created for the provided attributes, with File as the default FilterScope.
Filter | The provided Filter object is used as-is.
Array of System.Object | Each object in the array may be of the types described in this table, and is used accordingly.
Other | If any other type is found, an exception is thrown.

Events

Event Type | Reason
Xceed.FileSystem.FileSystemEvents.ScanningFolder | A folder is being scanned for files to be returned.
Xceed.FileSystem.FileSystemEvents.ItemException | When an exception occurs while scanning a folder, reports the exception and allows to recover from the exception and continue building the list of files.

Exceptions

Exception Type | Condition
System.ArgumentException | An invalid type was passed in the filters parameter.
Xceed.FileSystem.ItemDoesNotExistException | The folder represented by this AbstractFolder does not physically exist.

See Also

AbstractFolder Class | AbstractFolder Members | Xceed.FileSystem Namespace | AbstractFolder.GetFiles Overload List


GetFolder Method

Xceed Zip for .NET

AbstractFolder.GetFolder

Returns an AbstractFolder object that represents a folder contained in the folder.

Overload List

Returns an AbstractFolder object that represents a folder contained in the folder.

public AbstractFolder GetFolder(string);

Returns an AbstractFolder object that represents a folder contained in the folder and raises events during the process.

public AbstractFolder GetFolder(FileSystemEvents,object,string);

See Also

AbstractFolder Class | AbstractFolder Members | Xceed.FileSystem Namespace


AbstractFolder.GetFolder Method (String)

Returns an AbstractFolder object that represents a folder contained in the folder.

[Visual Basic]
Overloads Public Function GetFolder( _
   ByVal relativeName As String _
) As Xceed.FileSystem.AbstractFolder
[C#]
public AbstractFolder GetFolder(
   string relativeName
);

Parameters

relativeName

Relative name of the folder to retrieve.

Return Value

An AbstractFolder object representing the folder named relativeName.

Remarks

The relativeName parameter can include relative path information, in which ".." means "previous folder". For example: "foo/bar", "../bar", etc.

This method allows to get a reference to an AbstractFolder object for a folder that exists, as well as for a folder that does not exist. Further, the folder on which this method is called may not exist.

Exceptions

Exception Type | Condition
System.ArgumentException | The relativeName parameter is an empty string, contains only white space, or contains invalid characters as defined in InvalidChars.

See Also

AbstractFolder Class | AbstractFolder Members | Xceed.FileSystem Namespace | AbstractFolder.GetFolder Overload List


AbstractFolder.GetFolder Method (FileSystemEvents, Object, String)

Returns an AbstractFolder object that represents a folder contained in the folder and raises events during the process.

[Visual Basic]
Overloads Public Function GetFolder( _
   ByVal events As Xceed.FileSystem.FileSystemEvents, _
   ByVal userData As Object, _
   ByVal relativeName As String _
) As Xceed.FileSystem.AbstractFolder
[C#]
public AbstractFolder GetFolder(
   FileSystemEvents events,
   object userData,
   string relativeName
);

Parameters

events

A FileSystemEvents object that will be used to raise events. Cannot be a null reference (Nothing in Visual Basic).

userData

Opaque data that will be passed back to the event handler when an event is raised.

relativeName

Relative name of the folder to retrieve.

Return Value

An AbstractFolder object representing the folder named relativeName.

Remarks

The relativeName parameter can include relative path information, in which ".." means "previous folder". For example: "foo/bar", "../bar", etc.

This method allows to get a reference to an AbstractFolder object for a folder that exists, as well as for a folder that does not exist. Further, the folder on which this method is called may not exist.

Exceptions

Exception Type | Condition
System.ArgumentException | The relativeName parameter is an empty string, contains only white space, or contains invalid characters as defined in InvalidChars.

See Also

AbstractFolder Class | AbstractFolder Members | Xceed.FileSystem Namespace | AbstractFolder.GetFolder Overload List


GetFolders Method

Xceed Zip for .NET

AbstractFolder.GetFolders

Returns a filtered list of folders contained in the folder.

Overload List

Returns a filtered list of folders contained in the folder.

public AbstractFolder[] GetFolders(bool,params object[]);

Returns a filtered list of folders contained in the folder, and raises events during the process.

public AbstractFolder[] GetFolders(FileSystemEvents,object,bool,params object[]);

See Also

AbstractFolder Class | AbstractFolder Members | Xceed.FileSystem Namespace


AbstractFolder.GetFolders Method (Boolean, Object[])

Returns a filtered list of folders contained in the folder.

[Visual Basic]
Overloads Public Function GetFolders( _
   ByVal recursive As Boolean, _
   ByVal filters As Object() _
) As Xceed.FileSystem.AbstractFolder()
[C#]
public AbstractFolder[] GetFolders(
   bool recursive,
   params object[] filters
);

Parameters

recursive

true if folders contained in the subfolders should be returned; false if only folders that are immediate children of the folder should be returned.

filters

An array of objects that can be used to filter the list of folders returned.

Return Value

An array of AbstractFolder objects representing the folders that match the specified filters.

Remarks

To filter a list of files or folders, you can pass a variable number of objects in the filters parameter. These objects may be of the following types:

Object type | Type of filter applied
System.String | The string is assumed to be a file mask, and a NameFilter object is automatically created for the passed string, with File as the default FilterScope.
System.IO.FileAttributes | A AttributeFilter object is automatically created for the provided attributes, with File as the default FilterScope.
Filter | The provided Filter object is used as-is.
Array of System.Object | Each object in the array may be of the types described in this table, and is used accordingly.
Other | If any other type is found, an exception is thrown.

Note that when passing a string, for example "folder", as the folder to retrieve in the filters parameter, a NameFilter class will be created around the string. By default, the FilterScope of the NameFilter class is File. This means that only files will be filter and all folders will be returned.

In order to filter folders, a NameFilter class needs to be constructed around the string and the FilterScope must be set to Folder. For example:

            GetFolders( true, new NameFilter( "folder", FilterScope.Folder ) );

Exceptions

Exception Type | Condition
System.ArgumentException | An invalid type was passed in the filters parameter.
Xceed.FileSystem.ItemDoesNotExistException | The folder represented by this AbstractFolder does not physically exist.

See Also

AbstractFolder Class | AbstractFolder Members | Xceed.FileSystem Namespace | AbstractFolder.GetFolders Overload List


AbstractFolder.GetFolders Method (FileSystemEvents, Object, Boolean, Object[])

Returns a filtered list of folders contained in the folder, and raises events during the process.

[Visual Basic]
Overloads Public Function GetFolders( _
   ByVal events As Xceed.FileSystem.FileSystemEvents, _
   ByVal userData As Object, _
   ByVal recursive As Boolean, _
   ByVal filters As Object() _
) As Xceed.FileSystem.AbstractFolder()
[C#]
public AbstractFolder[] GetFolders(
   FileSystemEvents events,
   object userData,
   bool recursive,
   params object[] filters
);

Parameters

events

A FileSystemEvents object that will be used to raise events. Cannot be a null reference (Nothing in Visual Basic).

userData

Opaque data that will be passed back to the event handler when an event is raised.

recursive

true if folders contained in the subfolders should be returned; false if only folders that are immediate children of the folder should be returned.

filters

An array of objects that can be used to filter the list of folders returned.

Return Value

An array of AbstractFolder objects representing the folders that match the specified filters.

Remarks

To filter a list of files or folders, you can pass a variable number of objects in the filters parameter. These objects may be of the following types:

Object type | Type of filter applied
System.String | The string is assumed to be a file mask, and a NameFilter object is automatically created for the passed string, with File as the default FilterScope.
System.IO.FileAttributes | A AttributeFilter object is automatically created for the provided attributes, with File as the default FilterScope.
Filter | The provided Filter object is used as-is.
Array of System.Object | Each object in the array may be of the types described in this table, and is used accordingly.
Other | If any other type is found, an exception is thrown.

Note that when passing a string, for example "folder", as the folder to retrieve in the filters parameter, a NameFilter class will be created around the string. By default, the FilterScope of the NameFilter class is File. This means that only files will be filter and all folders will be returned.

In order to filter folders, a NameFilter class needs to be constructed around the string and the FilterScope must be set to Folder. For example:

            GetFolders( true, new NameFilter( "folder", FilterScope.Folder ) );

Events

Event Type | Reason
Xceed.FileSystem.FileSystemEvents.ScanningFolder | A folder is being scanned for folders to be returned.
Xceed.FileSystem.FileSystemEvents.ItemException | When an exception occurs while scanning a folder, reports the exception and allows to recover from the exception and continue building the list of folders.

Exceptions

Exception Type | Condition
System.ArgumentException | An invalid type was passed in the filters parameter.
Xceed.FileSystem.ItemDoesNotExistException | The folder represented by this AbstractFolder does not physically exist.

See Also

AbstractFolder Class | AbstractFolder Members | Xceed.FileSystem Namespace | AbstractFolder.GetFolders Overload List


GetItems Method

Xceed Zip for .NET

AbstractFolder.GetItems

Returns a list of items contained in the folder.

Overload List

Returns a list of items contained in the folder.

public FileSystemItem[] GetItems(bool);

Returns a list of items contained in the folder, and raises events during the process.

public FileSystemItem[] GetItems(FileSystemEvents,object,bool);

See Also

AbstractFolder Class | AbstractFolder Members | Xceed.FileSystem Namespace


AbstractFolder.GetItems Method (Boolean)

Returns a list of items contained in the folder.

[Visual Basic]
Overloads Public Function GetItems( _
   ByVal recursive As Boolean _
) As Xceed.FileSystem.FileSystemItem()
[C#]
public FileSystemItem[] GetItems(
   bool recursive
);

Parameters

recursive

true if items contained in the subfolders should be returned; false if only items that are immediate children of the folder should be returned.

Return Value

An array of FileSystemItem objects representing the items contained in the folder.

Remarks

Exceptions

Exception Type | Condition
Xceed.FileSystem.ItemDoesNotExistException | The folder represented by this AbstractFolder does not physically exist.

See Also

AbstractFolder Class | AbstractFolder Members | Xceed.FileSystem Namespace | AbstractFolder.GetItems Overload List


AbstractFolder.GetItems Method (FileSystemEvents, Object, Boolean)

Returns a list of items contained in the folder, and raises events during the process.

[Visual Basic]
Overloads Public Function GetItems( _
   ByVal events As Xceed.FileSystem.FileSystemEvents, _
   ByVal userData As Object, _
   ByVal recursive As Boolean _
) As Xceed.FileSystem.FileSystemItem()
[C#]
public FileSystemItem[] GetItems(
   FileSystemEvents events,
   object userData,
   bool recursive
);

Parameters

events

A FileSystemEvents object that will be used to raise events. Cannot be a null reference (Nothing in Visual Basic).

userData

Opaque data that will be passed back to the event handler when an event is raised.

recursive

true if items contained in the subfolders should be returned; false if only items that are immediate children of the folder should be returned.

Return Value

An array of FileSystemItem objects representing the items contained in the folder.

Remarks

Events

Event Type | Reason
Xceed.FileSystem.FileSystemEvents.ScanningFolder | A folder is being scanned for items to be returned.
Xceed.FileSystem.FileSystemEvents.ItemException | When an exception occurs while scanning a folder, reports the exception and allows to recover from the exception and continue building the list of items.

Exceptions

Exception Type | Condition
Xceed.FileSystem.ItemDoesNotExistException | The folder represented by this AbstractFolder does not physically exist.

See Also

AbstractFolder Class | AbstractFolder Members | Xceed.FileSystem Namespace | AbstractFolder.GetItems Overload List


MoveFilesTo Method

Xceed Zip for .NET

AbstractFolder.MoveFilesTo

Moves the folder's content to another folder.

Overload List

Moves the folder's content to another folder.

public void MoveFilesTo(AbstractFolder,bool,bool,params object[]);

Moves the folder's content to another folder, and raises events during the process.

public void MoveFilesTo(FileSystemEvents,object,AbstractFolder,bool,bool,params object[]);

See Also

AbstractFolder Class | AbstractFolder Members | Xceed.FileSystem Namespace


AbstractFolder.MoveFilesTo Method (AbstractFolder, Boolean, Boolean, Object[])

Moves the folder's content to another folder.

[Visual Basic]
Overloads Public Sub MoveFilesTo( _
   ByVal destinationFolder As Xceed.FileSystem.AbstractFolder, _
   ByVal recursive As Boolean, _
   ByVal replaceExistingFiles As Boolean, _
   ByVal filters As Object() _
)
[C#]
public void MoveFilesTo(
   AbstractFolder destinationFolder,
   bool recursive,
   bool replaceExistingFiles,
   params object[] filters
);

Parameters

destinationFolder

An AbstractFolder object into which the folder's content must be moved. Cannot be a null reference (Nothing in Visual Basic).

recursive

true if the content of the folders contained in the subfolders should be moved; false if only the current folder's content should be moved.

replaceExistingFiles

true if existing files in the destination should be replaced; false otherwise.

filters

An array of objects that can be used to filter the items to be moved.

Remarks

If the physical folder specified by destinationFolder does not exist, it is created.

The folder's content (files and subfolders) that matches the provided filters is immediately moved to the destination.

When replacingExistingFiles is true, any file in the destination that has the same name as a file being moved is automatically replaced.

When replacingExistingFiles is false, an exception is thrown whenever the destination contains a file with the same name as a file being moved.

To filter a list of files or folders, you can pass a variable number of objects in the filters parameter. These objects may be of the following types:

Object type | Type of filter applied
System.String | The string is assumed to be a file mask, and a NameFilter object is automatically created for the passed string, with File as the default FilterScope.
System.IO.FileAttributes | A AttributeFilter object is automatically created for the provided attributes, with File as the default FilterScope.
Filter | The provided Filter object is used as-is.
Array of System.Object | Each object in the array may be of the types described in this table, and is used accordingly.
Other | If any other type is found, an exception is thrown.

Exceptions

Exception Type | Condition
Xceed.FileSystem.ItemDoesNotExistException | The folder represented by this AbstractFolder does not physically exist.
Xceed.FileSystem.ItemAlreadyExistsException | One of the destination files already exists, and replaceExistingFiles is false.
Xceed.FileSystem.ItemIsReadOnlyException | One of the destination files already exists, replaceExistingFiles is true, but the destination file has the ReadOnly attribute.
Xceed.FileSystem.FileSystemIOException | The source file could not be read from, or the destination file could not be written to.

See Also

AbstractFolder Class | AbstractFolder Members | Xceed.FileSystem Namespace | AbstractFolder.MoveFilesTo Overload List


AbstractFolder.MoveFilesTo Method (FileSystemEvents, Object, AbstractFolder, Boolean, Boolean, Object[])

Moves the folder's content to another folder, and raises events during the process.

[Visual Basic]
Overloads Public Sub MoveFilesTo( _
   ByVal events As Xceed.FileSystem.FileSystemEvents, _
   ByVal userData As Object, _
   ByVal destinationFolder As Xceed.FileSystem.AbstractFolder, _
   ByVal recursive As Boolean, _
   ByVal replaceExistingFiles As Boolean, _
   ByVal filters As Object() _
)
[C#]
public void MoveFilesTo(
   FileSystemEvents events,
   object userData,
   AbstractFolder destinationFolder,
   bool recursive,
   bool replaceExistingFiles,
   params object[] filters
);

Parameters

events

A FileSystemEvents object that will be used to raise events. Cannot be a null reference (Nothing in Visual Basic).

userData

Opaque data that will be passed back to the event handler when an event is raised.

destinationFolder

An AbstractFolder object into which the folder's content must be moved. Cannot be a null reference (Nothing in Visual Basic).

recursive

true if the content of the folders contained in the subfolders should be moved; false if only the current folder's content should be moved.

replaceExistingFiles

true if existing files in the destination should be replaced; false otherwise.

filters

An array of objects that can be used to filter the items to be moved.

Remarks

If the physical folder specified by destinationFolder does not exist, it is created.

The folder's content (files and subfolders) that matches the provided filters is immediately moved to the destination.

When replacingExistingFiles is true, any file in the destination that has the same name as a file being moved is automatically replaced.

When replacingExistingFiles is false, an exception is thrown whenever the destination contains a file with the same name as a file being moved.

To filter a list of files or folders, you can pass a variable number of objects in the filters parameter. These objects may be of the following types:

Object type | Type of filter applied
System.String | The string is assumed to be a file mask, and a NameFilter object is automatically created for the passed string, with File as the default FilterScope.
System.IO.FileAttributes | A AttributeFilter object is automatically created for the provided attributes, with File as the default FilterScope.
Filter | The provided Filter object is used as-is.
Array of System.Object | Each object in the array may be of the types described in this table, and is used accordingly.
Other | If any other type is found, an exception is thrown.

Events

Event Type | Reason
Xceed.FileSystem.FileSystemEvents.ScanningFolder | A folder is being scanned for files to be moved.
Xceed.FileSystem.FileSystemEvents.ItemProgression | Every time an file is about to be moved, reports how many files have been moved and the total number of files that must be moved.
Xceed.FileSystem.FileSystemEvents.ByteProgression | Every 32k, reports how many bytes have been and must be moved for the current file, as well as for the entire set of files that are being moved.
Xceed.FileSystem.FileSystemEvents.ItemException | When an exception occurs while moving a file, reports the exception and allows to recover from the exception and continue moving the files.

Exceptions

Exception Type | Condition
Xceed.FileSystem.ItemDoesNotExistException | The folder represented by this AbstractFolder does not physically exist.
Xceed.FileSystem.ItemAlreadyExistsException | One of the destination files already exists, and replaceExistingFiles is false.
Xceed.FileSystem.ItemIsReadOnlyException | One of the destination files already exists, replaceExistingFiles is true, but the destination file has the ReadOnly attribute.
Xceed.FileSystem.FileSystemIOException | The source file could not be read from, or the destination file could not be written to.

See Also

AbstractFolder Class | AbstractFolder Members | Xceed.FileSystem Namespace | AbstractFolder.MoveFilesTo Overload List


AndFilter Class

Performs a logical AND operation on a set of Filter objects.

For a list of all members of this type, see AndFilter Members.

System.Object
Filter
AndFilter

[Visual Basic]
Public Class AndFilter
   Inherits Filter
[C#]
public class AndFilter : Filter

Requirements

Namespace: Xceed.FileSystem Namespace

Assembly: Xceed.FileSystem.dll

See Also

AndFilter Members | Xceed.FileSystem Namespace


AndFilter Members

Public Instance Constructors

AndFilter Constructor Initializes a new instance of the AndFilter class.

Public Instance Properties

Filters | Gets an array of Filter objects that are part of the logical AND operation.
Scope (inherited from Filter) | Gets or sets the scope of the filter.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsItemMatching | Gets a boolean value indicating if the item matches all of the filters.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsItemInScope (inherited from Filter) |
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

AndFilter Class | Xceed.FileSystem Namespace


AndFilter Constructor

Initializes a new instance of the AndFilter class.

[Visual Basic]
Public Sub New( _
   ByVal filters As Object() _
)
[C#]
public AndFilter(
   params object[] filters
);

Parameters

filters

Filters that are part of the logical AND operation.

See Also

AndFilter Class | AndFilter Members | Xceed.FileSystem Namespace


AndFilter Properties

The properties of the AndFilter class are listed below. For a complete list of AndFilter class members, see the AndFilter Members topic.

Public Instance Properties

Filters | Gets an array of Filter objects that are part of the logical AND operation.
Scope (inherited from Filter) | Gets or sets the scope of the filter.

See Also

AndFilter Class | Xceed.FileSystem Namespace


AndFilter.Filters Property

Gets an array of Filter objects that are part of the logical AND operation.

[Visual Basic]
Public ReadOnly Property Filters As System.Collections.IEnumerable
[C#]
public System.Collections.IEnumerable Filters {get;}

Property Value

An array of Filter objects.

See Also

AndFilter Class | AndFilter Members | Xceed.FileSystem Namespace


AndFilter Methods

The methods of the AndFilter class are listed below. For a complete list of AndFilter class members, see the AndFilter Members topic.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsItemMatching | Gets a boolean value indicating if the item matches all of the filters.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsItemInScope (inherited from Filter) |
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

AndFilter Class | Xceed.FileSystem Namespace


AndFilter.IsItemMatching Method

Gets a boolean value indicating if the item matches all of the filters.

[Visual Basic]
Overrides Public Function IsItemMatching( _
   ByVal item As Xceed.FileSystem.FileSystemItem _
) As Boolean
[C#]
public override bool IsItemMatching(
   FileSystemItem item
);

Parameters

item

The FileSystemItem object that will be verified.

Return Value

true if item matches all of the filters; false otherwise.

See Also

AndFilter Class | AndFilter Members | Xceed.FileSystem Namespace


AttributeFilter Class

Filters a FileSystemItem object based on its attributes.

For a list of all members of this type, see AttributeFilter Members.

System.Object
Filter
AttributeFilter

[Visual Basic]
Public Class AttributeFilter
   Inherits Filter
[C#]
public class AttributeFilter : Filter

Requirements

Namespace: Xceed.FileSystem Namespace

Assembly: Xceed.FileSystem.dll

See Also

AttributeFilter Members | Xceed.FileSystem Namespace


AttributeFilter Members

Public Instance Constructors

AttributeFilter Overloaded. Initialize a new instance of the AttributeFilter class.

Public Instance Properties

Attributes | Gets the file attributes used to filter files and folders.
Scope (inherited from Filter) | Gets or sets the scope of the filter.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsItemMatching | Gets a boolean value indicating if the item matches at least one of the file attributes.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsItemInScope (inherited from Filter) |
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

AttributeFilter Class | Xceed.FileSystem Namespace


AttributeFilter Constructor

Xceed Zip for .NET

AttributeFilter

Initializes a new instance of the AttributeFilter class.

Overload List

Initializes a new instance of the AttributeFilter class.

public AttributeFilter(FileAttributes);

Initializes a new instance of the AttributeFilter class.

public AttributeFilter(FileAttributes,FilterScope);

See Also

AttributeFilter Class | AttributeFilter Members | Xceed.FileSystem Namespace


AttributeFilter Constructor (FileAttributes)

Initializes a new instance of the AttributeFilter class.

[Visual Basic]
Overloads Public Sub New( _
   ByVal attributes As System.IO.FileAttributes _
)
[C#]
public AttributeFilter(
   FileAttributes attributes
);

Parameters

attributes

System.IO.FileAttributes fields that represent the attributes used to filter files and folders.

See Also

AttributeFilter Class | AttributeFilter Members | Xceed.FileSystem Namespace | AttributeFilter Constructor Overload List


AttributeFilter Constructor (FileAttributes, FilterScope)

Initializes a new instance of the AttributeFilter class.

[Visual Basic]
Overloads Public Sub New( _
   ByVal attributes As System.IO.FileAttributes, _
   ByVal scope As Xceed.FileSystem.FilterScope _
)
[C#]
public AttributeFilter(
   FileAttributes attributes,
   FilterScope scope
);

Parameters

attributes

System.IO.FileAttributes fields that represent the attributes used to filter files and folders.

scope

Determines whether the filter applies to files, folders or both.

See Also

AttributeFilter Class | AttributeFilter Members | Xceed.FileSystem Namespace | AttributeFilter Constructor Overload List


AttributeFilter Properties

The properties of the AttributeFilter class are listed below. For a complete list of AttributeFilter class members, see the AttributeFilter Members topic.

Public Instance Properties

Attributes | Gets the file attributes used to filter files and folders.
Scope (inherited from Filter) | Gets or sets the scope of the filter.

See Also

AttributeFilter Class | Xceed.FileSystem Namespace


AttributeFilter.Attributes Property

Gets the file attributes used to filter files and folders.

[Visual Basic]
Public ReadOnly Property Attributes As System.IO.FileAttributes
[C#]
public System.IO.FileAttributes Attributes {get;}

Property Value

A combination of System.IO.FileAttributes fields that represent the attributes used to filter files and folders.

See Also

AttributeFilter Class | AttributeFilter Members | Xceed.FileSystem Namespace


AttributeFilter Methods

The methods of the AttributeFilter class are listed below. For a complete list of AttributeFilter class members, see the AttributeFilter Members topic.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsItemMatching | Gets a boolean value indicating if the item matches at least one of the file attributes.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsItemInScope (inherited from Filter) |
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

AttributeFilter Class | Xceed.FileSystem Namespace


AttributeFilter.IsItemMatching Method

Gets a boolean value indicating if the item matches at least one of the file attributes.

[Visual Basic]
Overrides Public Function IsItemMatching( _
   ByVal item As Xceed.FileSystem.FileSystemItem _
) As Boolean
[C#]
public override bool IsItemMatching(
   FileSystemItem item
);

Parameters

item

The FileSystemItem object that will be verified.

Return Value

true if item matches at least one of the file attributes; false otherwise.

See Also

AttributeFilter Class | AttributeFilter Members | Xceed.FileSystem Namespace


AutoBatchUpdate Class

Class that verifies if the object implements the IBatchUpdateable interface.

For a list of all members of this type, see AutoBatchUpdate Members.

System.Object
MarshalByRefObject
AutoBatchUpdate

[Visual Basic]
Public Class AutoBatchUpdate
   Inherits MarshalByRefObject
   Implements IDisposable
[C#]
public class AutoBatchUpdate : MarshalByRefObject, IDisposable

Requirements

Namespace: Xceed.FileSystem Namespace

Assembly: Xceed.FileSystem.dll

See Also

AutoBatchUpdate Members | Xceed.FileSystem Namespace


AutoBatchUpdate Members

Public Instance Constructors

AutoBatchUpdate Overloaded. Initialize a new instance of the AutoBatchUpdate class.

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
InitializeLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

Explicit Interface Implementations

IDisposable.Dispose Calls the EndUpdate method on the object that was passed in the construction of the AutoBatchUpdateable class.

See Also

AutoBatchUpdate Class | Xceed.FileSystem Namespace


AutoBatchUpdate Constructor

Xceed Zip for .NET

AutoBatchUpdate

Verifies if the object implements the IBatchUpdateable interface.

Overload List

Verifies if the object implements the IBatchUpdateable interface.

public AutoBatchUpdate(object);

Verifies if the object implements the IBatchUpdateable interface and raises events during the process.

public AutoBatchUpdate(object,FileSystemEvents,object);

See Also

AutoBatchUpdate Class | AutoBatchUpdate Members | Xceed.FileSystem Namespace


AutoBatchUpdate Constructor (Object)

Verifies if the object implements the IBatchUpdateable interface.

[Visual Basic]
Overloads Public Sub New( _
   ByVal batchUpdateable As Object _
)
[C#]
public AutoBatchUpdate(
   object batchUpdateable
);

Parameters

batchUpdateable

object that may or may not implement the IBatchUpdateable interface.

Remarks

The AutoBatchUpdate class will verify if batchUpdateable implements the IBatchUpdateable interface and will automatically call the BeginUpdate and EndUpdate methods if it does. If batchUpdateable does not implement the IBatchUpdateable interface, the code will be executed normally.

See Also

AutoBatchUpdate Class | AutoBatchUpdate Members | Xceed.FileSystem Namespace | AutoBatchUpdate Constructor Overload List


AutoBatchUpdate Constructor (Object, FileSystemEvents, Object)

Verifies if the object implements the IBatchUpdateable interface and raises events during the process.

[Visual Basic]
Overloads Public Sub New( _
   ByVal batchUpdateable As Object, _
   ByVal events As Xceed.FileSystem.FileSystemEvents, _
   ByVal userData As Object _
)
[C#]
public AutoBatchUpdate(
   object batchUpdateable,
   FileSystemEvents events,
   object userData
);

Parameters

batchUpdateable

Object that may or may not implement the IBatchUpdateable interface.

events

A FileSystemEvents object that will be used to raise events. Cannot be a null reference (Nothing in Visual Basic).

userData

Opaque data that will be passed back to the event handler when an event is raised.

Remarks

The AutoBatchUpdate class will verify if batchUpdateable implements the IBatchUpdateable interface and will automatically call the BeginUpdate and EndUpdate methods if it does. If batchUpdateable does not implement the IBatchUpdateable interface, the code will be executed normally.

See Also

AutoBatchUpdate Class | AutoBatchUpdate Members | Xceed.FileSystem Namespace | AutoBatchUpdate Constructor Overload List


AutoBatchUpdate Methods

The methods of the AutoBatchUpdate class are listed below. For a complete list of AutoBatchUpdate class members, see the AutoBatchUpdate Members topic.

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
InitializeLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

Explicit Interface Implementations

IDisposable.Dispose Calls the EndUpdate method on the object that was passed in the construction of the AutoBatchUpdateable class.

See Also

AutoBatchUpdate Class | Xceed.FileSystem Namespace


AutoBatchUpdate.Dispose Method

Calls the EndUpdate method on the object that was passed in the construction of the AutoBatchUpdateable class.

[Visual Basic]
Sub Dispose() Implements IDisposable.Dispose
[C#]
void IDisposable.Dispose();

Remarks

The EndUpdate method will only be called if the objecy implemented the IBatchUpdateable interface.

See Also

AutoBatchUpdate Class | AutoBatchUpdate Members | Xceed.FileSystem Namespace


ByteProgressionEventArgs Class

Argument class that provides byte progression information.

For a list of all members of this type, see ByteProgressionEventArgs Members.

System.Object
EventArgs
FileSystemEventArgs
ByteProgressionEventArgs

[Visual Basic]
Public Class ByteProgressionEventArgs
   Inherits FileSystemEventArgs
[C#]
public class ByteProgressionEventArgs : FileSystemEventArgs

Requirements

Namespace: Xceed.FileSystem Namespace

Assembly: Xceed.FileSystem.dll

See Also

ByteProgressionEventArgs Members | Xceed.FileSystem Namespace


ByteProgressionEventArgs Members

Public Instance Constructors

ByteProgressionEventArgs Constructor Creates a new instance of the ByteProgressionEventArgs argument class.

Public Instance Properties

AllFilesBytes | Gets the total combined size, in bytes, of all files being processed.
CurrentFileBytes | Gets the size, in bytes, of the file currently being processed.
CurrentItem (inherited from FileSystemEventArgs) | Gets or sets the current FileSystemItem object being processed.
TargetItem (inherited from FileSystemEventArgs) | Gets or sets the destination FileSystemItem object.
UserData (inherited from FileSystemEventArgs) | Gets or sets the opaque data that will be sent back to the event handler whenever an event is raised.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Fields

m_allFilesBytes | An instance of the ProgressionInfo class representing the byte count information in regards to all the items to be processed.
m_currentFileBytes | An instance of the ProgressionInfo class representing the byte count information in regards to the current item being processed.
m_currentItem |
m_targetItem |
m_userData |

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

ByteProgressionEventArgs Class | Xceed.FileSystem Namespace


ByteProgressionEventArgs Constructor

Creates a new instance of the ByteProgressionEventArgs argument class.

[Visual Basic]
Public Sub New( _
   ByVal currentFileBytes As Xceed.FileSystem.ProgressionInfo, _
   ByVal allFilesBytes As Xceed.FileSystem.ProgressionInfo _
)
[C#]
public ByteProgressionEventArgs(
   ProgressionInfo currentFileBytes,
   ProgressionInfo allFilesBytes
);

Parameters

currentFileBytes

The size, in bytes, of the file currently being processed.

allFilesBytes

The total combined size, in bytes, of all files being processed.

See Also

ByteProgressionEventArgs Class | ByteProgressionEventArgs Members | Xceed.FileSystem Namespace


ByteProgressionEventArgs Fields

The fields of the ByteProgressionEventArgs class are listed below. For a complete list of ByteProgressionEventArgs class members, see the ByteProgressionEventArgs Members topic.

Protected Instance Fields

m_allFilesBytes | An instance of the ProgressionInfo class representing the byte count information in regards to all the items to be processed.
m_currentFileBytes | An instance of the ProgressionInfo class representing the byte count information in regards to the current item being processed.
m_currentItem |
m_targetItem |
m_userData |

See Also

ByteProgressionEventArgs Class | Xceed.FileSystem Namespace


ByteProgressionEventArgs.m_allFilesBytes Field

An instance of the ProgressionInfo class representing the byte count information in regards to all the items to be processed.

[Visual Basic]
Protected m_allFilesBytes As Xceed.FileSystem.ProgressionInfo
[C#]
protected ProgressionInfo m_allFilesBytes;

See Also

ByteProgressionEventArgs Class | ByteProgressionEventArgs Members | Xceed.FileSystem Namespace


ByteProgressionEventArgs.m_currentFileBytes Field

An instance of the ProgressionInfo class representing the byte count information in regards to the current item being processed.

[Visual Basic]
Protected m_currentFileBytes As Xceed.FileSystem.ProgressionInfo
[C#]
protected ProgressionInfo m_currentFileBytes;

See Also

ByteProgressionEventArgs Class | ByteProgressionEventArgs Members | Xceed.FileSystem Namespace


ByteProgressionEventArgs.m_currentItem Field

[Visual Basic]
Protected m_currentItem As Xceed.FileSystem.FileSystemItem
[C#]
protected FileSystemItem m_currentItem;

See Also

ByteProgressionEventArgs Class | ByteProgressionEventArgs Members | Xceed.FileSystem Namespace


ByteProgressionEventArgs.m_targetItem Field

[Visual Basic]
Protected m_targetItem As Xceed.FileSystem.FileSystemItem
[C#]
protected FileSystemItem m_targetItem;

See Also

ByteProgressionEventArgs Class | ByteProgressionEventArgs Members | Xceed.FileSystem Namespace


ByteProgressionEventArgs.m_userData Field

[Visual Basic]
Protected m_userData As Object
[C#]
protected object m_userData;

See Also

ByteProgressionEventArgs Class | ByteProgressionEventArgs Members | Xceed.FileSystem Namespace


ByteProgressionEventArgs Properties

The properties of the ByteProgressionEventArgs class are listed below. For a complete list of ByteProgressionEventArgs class members, see the ByteProgressionEventArgs Members topic.

Public Instance Properties

AllFilesBytes | Gets the total combined size, in bytes, of all files being processed.
CurrentFileBytes | Gets the size, in bytes, of the file currently being processed.
CurrentItem (inherited from FileSystemEventArgs) | Gets or sets the current FileSystemItem object being processed.
TargetItem (inherited from FileSystemEventArgs) | Gets or sets the destination FileSystemItem object.
UserData (inherited from FileSystemEventArgs) | Gets or sets the opaque data that will be sent back to the event handler whenever an event is raised.

See Also

ByteProgressionEventArgs Class | Xceed.FileSystem Namespace


ByteProgressionEventArgs.AllFilesBytes Property

Gets the total combined size, in bytes, of all files being processed.

[Visual Basic]
Public ReadOnly Property AllFilesBytes As Xceed.FileSystem.ProgressionInfo
[C#]
public ProgressionInfo AllFilesBytes {get;}

Property Value

A value indicating the size, in bytes, of all the files being processed.

See Also

ByteProgressionEventArgs Class | ByteProgressionEventArgs Members | Xceed.FileSystem Namespace


ByteProgressionEventArgs.CurrentFileBytes Property

Gets the size, in bytes, of the file currently being processed.

[Visual Basic]
Public ReadOnly Property CurrentFileBytes As Xceed.FileSystem.ProgressionInfo
[C#]
public ProgressionInfo CurrentFileBytes {get;}

Property Value

A value indicating the size, in bytes, of the file being processed.

See Also

ByteProgressionEventArgs Class | ByteProgressionEventArgs Members | Xceed.FileSystem Namespace


ByteProgressionEventHandler Delegate

Represents the method that will handle the ByteProgression event.

[Visual Basic]
Public Delegate Sub ByteProgressionEventHandler( _
   ByVal sender As Object, _
   ByVal e As Xceed.FileSystem.ByteProgressionEventArgs _
)
[C#]
public delegate void ByteProgressionEventHandler(
   object sender,
   ByteProgressionEventArgs e
);

Parameters

sender

The FileSystemItem on which the method was called.

e

An instance of the ByteProgressionEventArgs argument class that contains progression information.

Requirements

Namespace: Xceed.FileSystem Namespace

Assembly: Xceed.FileSystem.dll

See Also

Xceed.FileSystem Namespace

Copyright 2000-2002 Xceed Software Inc.


DateTimeFilter Class

Filters a FileSystemItem object based on its date and time.

For a list of all members of this type, see DateTimeFilter Members.

System.Object
Filter
DateTimeFilter

[Visual Basic]
Public Class DateTimeFilter
   Inherits Filter
[C#]
public class DateTimeFilter : Filter

Requirements

Namespace: Xceed.FileSystem Namespace

Assembly: Xceed.FileSystem.dll

See Also

DateTimeFilter Members | Xceed.FileSystem Namespace


DateTimeFilter Members

Public Instance Constructors

DateTimeFilter Overloaded. Initialize a new instance of the DateTimeFilter class.

Public Instance Properties

ApplicableDateTimes | Gets the dates and times used to filter files and folders.
MaxDateTime | Gets the maximum date and time value of the filter.
MinDateTime | Gets the minimum date and time value of the filter.
Scope (inherited from Filter) | Gets or sets the scope of the filter.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsItemMatching | Gets a boolean value indicating if the item matches the date/time filter.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsItemInScope (inherited from Filter) |
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

DateTimeFilter Class | Xceed.FileSystem Namespace


DateTimeFilter Constructor

Xceed Zip for .NET

DateTimeFilter

Initializes a new instance of the DateTimeFilter class.

Overload List

Initializes a new instance of the DateTimeFilter class.

public DateTimeFilter(DateTime,DateTime);

Initializes a new instance of the DateTimeFilter class, specifying to which type of date/time the filter applies.

public DateTimeFilter(DateTime,DateTime,ApplicableDateTime);

Initializes a new instance of the DateTimeFilter class, specifying to which type of FileSystemItem object the filter applies.

public DateTimeFilter(DateTime,DateTime,FilterScope);

Initializes a new instance of the DateTimeFilter class, specifying to which type of date/time and FileSystemItem object the filter applies.

public DateTimeFilter(DateTime,DateTime,ApplicableDateTime,FilterScope);

See Also

DateTimeFilter Class | DateTimeFilter Members | Xceed.FileSystem Namespace


DateTimeFilter Constructor (DateTime, DateTime)

Initializes a new instance of the DateTimeFilter class.

[Visual Basic]
Overloads Public Sub New( _
   ByVal minValue As Date, _
   ByVal maxValue As Date _
)
[C#]
public DateTimeFilter(
   DateTime minValue,
   DateTime maxValue
);

Parameters

minValue

A System.DateTime field that represents the minimum date and time of the filter.

maxValue

A System.DateTime field that represents the maximum date and time of the filter.

Remarks

The filter will apply only to files.

See Also

DateTimeFilter Class | DateTimeFilter Members | Xceed.FileSystem Namespace | DateTimeFilter Constructor Overload List


DateTimeFilter Constructor (DateTime, DateTime, ApplicableDateTime)

Initializes a new instance of the DateTimeFilter class, specifying to which type of date/time the filter applies.

[Visual Basic]
Overloads Public Sub New( _
   ByVal minValue As Date, _
   ByVal maxValue As Date, _
   ByVal applicableDateTimes As Xceed.FileSystem.DateTimeFilter.ApplicableDateTime _
)
[C#]
public DateTimeFilter(
   DateTime minValue,
   DateTime maxValue,
   ApplicableDateTime applicableDateTimes
);

Parameters

minValue

A System.DateTime field that represents the minimum date and time of the filter.

maxValue

A System.DateTime field that represents the maximum date and time of the filter.

applicableDateTimes

Determines to which type of date/time the filter applies.

Remarks

The filter will apply only to files.

See Also

DateTimeFilter Class | DateTimeFilter Members | Xceed.FileSystem Namespace | DateTimeFilter Constructor Overload List


DateTimeFilter Constructor (DateTime, DateTime, FilterScope)

Initializes a new instance of the DateTimeFilter class, specifying to which type of FileSystemItem object the filter applies.

[Visual Basic]
Overloads Public Sub New( _
   ByVal minValue As Date, _
   ByVal maxValue As Date, _
   ByVal scope As Xceed.FileSystem.FilterScope _
)
[C#]
public DateTimeFilter(
   DateTime minValue,
   DateTime maxValue,
   FilterScope scope
);

Parameters

minValue

A System.DateTime field that represents the minimum date and time of the filter.

maxValue

A System.DateTime field that represents the maximum date and time of the filter.

scope

Determines whether the filter applies to files, folders or both.

See Also

DateTimeFilter Class | DateTimeFilter Members | Xceed.FileSystem Namespace | DateTimeFilter Constructor Overload List


DateTimeFilter Constructor (DateTime, DateTime, ApplicableDateTime, FilterScope)

Initializes a new instance of the DateTimeFilter class, specifying to which type of date/time and FileSystemItem object the filter applies.

[Visual Basic]
Overloads Public Sub New( _
   ByVal minValue As Date, _
   ByVal maxValue As Date, _
   ByVal applicableDateTimes As Xceed.FileSystem.DateTimeFilter.ApplicableDateTime, _
   ByVal scope As Xceed.FileSystem.FilterScope _
)
[C#]
public DateTimeFilter(
   DateTime minValue,
   DateTime maxValue,
   ApplicableDateTime applicableDateTimes,
   FilterScope scope
);

Parameters

minValue

A System.DateTime field that represents the minimum date and time of the filter.

maxValue

A System.DateTime field that represents the maximum date and time of the filter.

applicableDateTimes

Determines to which type of date/time the filter applies.

scope

Determines whether the filter applies to files, folders or both.

See Also

DateTimeFilter Class | DateTimeFilter Members | Xceed.FileSystem Namespace | DateTimeFilter Constructor Overload List


DateTimeFilter Properties

The properties of the DateTimeFilter class are listed below. For a complete list of DateTimeFilter class members, see the DateTimeFilter Members topic.

Public Instance Properties

ApplicableDateTimes | Gets the dates and times used to filter files and folders.
MaxDateTime | Gets the maximum date and time value of the filter.
MinDateTime | Gets the minimum date and time value of the filter.
Scope (inherited from Filter) | Gets or sets the scope of the filter.

See Also

DateTimeFilter Class | Xceed.FileSystem Namespace


DateTimeFilter.ApplicableDateTimes Property

Gets the dates and times used to filter files and folders.

[Visual Basic]
Public ReadOnly Property ApplicableDateTimes As Xceed.FileSystem.DateTimeFilter.ApplicableDateTime
[C#]
public DateTimeFilter.ApplicableDateTime ApplicableDateTimes {get;}

Property Value

A combination of System.DateTime fields that represent the dates and times used to filter files and folders.

See Also

DateTimeFilter Class | DateTimeFilter Members | Xceed.FileSystem Namespace


DateTimeFilter.MaxDateTime Property

Gets the maximum date and time value of the filter.

[Visual Basic]
Public ReadOnly Property MaxDateTime As Date
[C#]
public System.DateTime MaxDateTime {get;}

Property Value

A System.DateTime that represents the maximum date and time of the filter.

See Also

DateTimeFilter Class | DateTimeFilter Members | Xceed.FileSystem Namespace


DateTimeFilter.MinDateTime Property

Gets the minimum date and time value of the filter.

[Visual Basic]
Public ReadOnly Property MinDateTime As Date
[C#]
public System.DateTime MinDateTime {get;}

Property Value

A System.DateTime that represents the minimum date and time of the filter.

See Also

DateTimeFilter Class | DateTimeFilter Members | Xceed.FileSystem Namespace


DateTimeFilter Methods

The methods of the DateTimeFilter class are listed below. For a complete list of DateTimeFilter class members, see the DateTimeFilter Members topic.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsItemMatching | Gets a boolean value indicating if the item matches the date/time filter.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsItemInScope (inherited from Filter) |
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

DateTimeFilter Class | Xceed.FileSystem Namespace


DateTimeFilter.IsItemMatching Method

Gets a boolean value indicating if the item matches the date/time filter.

[Visual Basic]
Overrides Public Function IsItemMatching( _
   ByVal item As Xceed.FileSystem.FileSystemItem _
) As Boolean
[C#]
public override bool IsItemMatching(
   FileSystemItem item
);

Parameters

item

The FileSystemItem object that will be verified.

Return Value

true if item matches the date/time filter; false otherwise.

See Also

DateTimeFilter Class | DateTimeFilter Members | Xceed.FileSystem Namespace


DateTimeFilter.ApplicableDateTime Enumeration

Specifies which type of date/time will be filtered by a DateTimeFilter class.

[Visual Basic]
Public Enum DateTimeFilter.ApplicableDateTime
[C#]
public enum DateTimeFilter.ApplicableDateTime

Members

Member Name | Description
Creation | The filter will apply only to the creation date/time.
LastWrite | The filter will apply only to the last modified date/time.
LastAccess | The filter will apply only to the last accessed date/time.
All | The filter will apply to all date/times.

Requirements

Namespace: Xceed.FileSystem Namespace

Assembly: Xceed.FileSystem.dll

See Also

Xceed.FileSystem Namespace

Copyright 2000-2002 Xceed Software Inc.


DiskFile Class

Specialization of the AbstractFile class that implements access to a disk file.

For a list of all members of this type, see DiskFile Members.

System.Object
MarshalByRefObject
FileSystemItem
AbstractFile
DiskFile

[Visual Basic]
Public Class DiskFile
   Inherits AbstractFile
[C#]
public class DiskFile : AbstractFile

Requirements

Namespace: Xceed.FileSystem Namespace

Assembly: Xceed.FileSystem.dll

See Also

DiskFile Members | Xceed.FileSystem Namespace


DiskFile Members

Public Instance Constructors

DiskFile Constructor Initializes a new instance of the DiskFile class with the fully qualified name of an underlying physical file.

Public Instance Properties

Attributes (inherited from FileSystemItem) | Gets or sets the attributes of the item.
CreationDateTime (inherited from FileSystemItem) | Gets or sets the creation date and time of the item.
Exists (inherited from FileSystemItem) | Gets a boolean value indicating if the item physically exists.
FullName (inherited from FileSystemItem) | Gets the full name of the item.
LastAccessDateTime (inherited from FileSystemItem) | Gets or sets the last access date and time of the item.
LastWriteDateTime (inherited from FileSystemItem) | Gets or sets the modification date and time of the item.
Name (inherited from FileSystemItem) | Gets or sets the short name of the item.
ParentFolder (inherited from FileSystemItem) | Gets a reference to the parent folder of this item.
RootFolder (inherited from FileSystemItem) | Gets a reference to the root folder of this item.
Size (inherited from AbstractFile) | Gets the size of the file in bytes.

Public Instance Methods

ApplyPropertiesTo (inherited from FileSystemItem) | Overloaded. Copies the item's properties to another item.
CopyTo (inherited from AbstractFile) | Overloaded. Copies the file's data to another file.
Create (inherited from FileSystemItem) | Overloaded. Creates the physical item represented by the object.
CreateObjRef (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Delete (inherited from FileSystemItem) | Overloaded. Permanently deletes the physical item.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
InitializeLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
MoveTo (inherited from AbstractFile) | Overloaded. Moves the contents of the object to the target object.
OpenRead (inherited from AbstractFile) | Overloaded. Opens the file for reading.
OpenWrite (inherited from AbstractFile) | Overloaded. Opens the file for writing.
Refresh (inherited from FileSystemItem) | Overloaded. Re-reads the information from the physical item.
ToString (inherited from FileSystemItem) | Returns the full name of the item.

Protected Instance Properties

DoAttributes | Gets or sets the attributes of the item.
DoCreationDateTime | Gets or sets the creation date and time of the item.
DoExists | Gets a boolean value indicating if the item physically exists.
DoFullName | Gets the full name of the item.
DoLastAccessDateTime | Gets or sets the last access date and time of the item.
DoLastWriteDateTime | Gets or sets the modification date and time of the item.
DoName | Gets or sets the short name of the item.
DoParentFolder | Gets a reference to the parent folder of this item.
DoRootFolder | Gets a reference to the root folder of this item.
DoSize | Gets the size of the file in bytes.
InvalidChars (inherited from FileSystemItem) | Gets the characters that are invalid in file and folder names.

Protected Instance Methods

BuildListForCreate (inherited from FileSystemItem) | Handles the special cases in regards to building the list of items to process when creating a FileSystemItem object.
DoApplyPropertiesTo (inherited from FileSystemItem) | Copies the item's properties to another item. This method must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoCopyTo (inherited from AbstractFile) | Copies the file into the destination.
DoOpenRead | Opens the file for reading.
DoOpenWrite | Opens the file for writing.
DoRefresh | Re-reads the information from the physical item.
EnsureDateIsValid (inherited from FileSystemItem) | Ensures that the System.DateTime value is valid.
Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsPathRooted | Returns a boolean value indicating if the path passed is rooted.
IsSameAs | Gets a boolean value indicating if the source and target file are the same.
ListCopyTo (inherited from FileSystemItem) | Copies each item in the FileSystemEventsSession object's list to each item's destination.
ListCreate (inherited from FileSystemItem) | Creates each item in the FileSystemEventsSession object's list.
ListDelete (inherited from FileSystemItem) | Deletes each item in the FileSystemEventsSession object's list.
ListMoveTo (inherited from FileSystemItem) | Moves each item in the FileSystemEventsSession object's list to each item's destination.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Internal Instance Methods

BuildList (inherited from AbstractFile) | Builds a list of FileSystemItem objects to process.
DoCreate | Creates the physical file.
DoDelete | Permanently deletes the physical item.

See Also

DiskFile Class | Xceed.FileSystem Namespace


DiskFile Constructor

Initializes a new instance of the DiskFile class with the fully qualified name of an underlying physical file.

[Visual Basic]
Public Sub New( _
   ByVal fileName As String _
)
[C#]
public DiskFile(
   string fileName
);

Parameters

fileName

Fully qualified name of the underlying physical file. This file may or may not physically exist.

Remarks

The fileName parameter can include relative path information, in which ".." means "previous folder". For example: "foo/bar.txt", "../bar.txt", etc.

In this context, a name is relative to the current working direcory of the application.

This method allows to initialize a DiskFile object for a file that exists, as well as for a file that does not exist.

Exceptions

Exception Type | Condition
System.ArgumentException | The fileName parameter is an empty string, contains only white space, represents a folder, or contains invalid characters as defined in InvalidChars.

See Also

DiskFile Class | DiskFile Members | Xceed.FileSystem Namespace


DiskFile Properties

The properties of the DiskFile class are listed below. For a complete list of DiskFile class members, see the DiskFile Members topic.

Public Instance Properties

Attributes (inherited from FileSystemItem) | Gets or sets the attributes of the item.
CreationDateTime (inherited from FileSystemItem) | Gets or sets the creation date and time of the item.
Exists (inherited from FileSystemItem) | Gets a boolean value indicating if the item physically exists.
FullName (inherited from FileSystemItem) | Gets the full name of the item.
LastAccessDateTime (inherited from FileSystemItem) | Gets or sets the last access date and time of the item.
LastWriteDateTime (inherited from FileSystemItem) | Gets or sets the modification date and time of the item.
Name (inherited from FileSystemItem) | Gets or sets the short name of the item.
ParentFolder (inherited from FileSystemItem) | Gets a reference to the parent folder of this item.
RootFolder (inherited from FileSystemItem) | Gets a reference to the root folder of this item.
Size (inherited from AbstractFile) | Gets the size of the file in bytes.

Protected Instance Properties

DoAttributes | Gets or sets the attributes of the item.
DoCreationDateTime | Gets or sets the creation date and time of the item.
DoExists | Gets a boolean value indicating if the item physically exists.
DoFullName | Gets the full name of the item.
DoLastAccessDateTime | Gets or sets the last access date and time of the item.
DoLastWriteDateTime | Gets or sets the modification date and time of the item.
DoName | Gets or sets the short name of the item.
DoParentFolder | Gets a reference to the parent folder of this item.
DoRootFolder | Gets a reference to the root folder of this item.
DoSize | Gets the size of the file in bytes.
InvalidChars (inherited from FileSystemItem) | Gets the characters that are invalid in file and folder names.

See Also

DiskFile Class | Xceed.FileSystem Namespace


DiskFile.DoAttributes Property

Gets or sets the attributes of the item.

[Visual Basic]
Overrides Protected Property DoAttributes As System.IO.FileAttributes
[C#]
protected System.IO.FileAttributes DoAttributes {override get; override set;}

Property Value

A combination of System.IO.FileAttributes values that represents the attributes of the item.

Remarks

When changing the item's attributes through this property, the physical item is immediately modified if it exists. If it does not exist, the attributes are cached and will be applied whenever this item is created.

Some types of items may not expose attributes. In this case, an exception is thrown when trying to read or modify the attributes.

Note: Refresh should be called before accessing this property, or the information returned could be outdated.

Exceptions

Exception Type | Condition
Xceed.FileSystem.FileSystemNotSupportedException | The item does not expose attributes, or does not support one of the assigned attributes.
Xceed.FileSystem.ItemIsRootFolderException | The physical item is a root folder.

See Also

DiskFile Class | DiskFile Members | Xceed.FileSystem Namespace


DiskFile.DoCreationDateTime Property

Gets or sets the creation date and time of the item.

[Visual Basic]
Overrides Protected Property DoCreationDateTime As Date
[C#]
protected System.DateTime DoCreationDateTime {override get; override set;}

Property Value

The date and time when the item was created.

Remarks

When changing the item's creation date through this property, the physical item is immediately modified if it exists. If it does not exist, the date is cached and will be applied whenever this item is created.

Some types of items may not expose a creation date and time. In this case, an exception is thrown when trying to read or modify the creation date.

Other types of items that do expose a creation date and time may not have the information available. In this case, System.DateTime.MinValue is returned.

Note: Refresh should be called before accessing this property, or the information returned could be outdated.

Exceptions

Exception Type | Condition
System.ArgumentException | The provided creation date is not valid for this item.
Xceed.FileSystem.FileSystemNotSupportedException | The item does not expose a creation date.
Xceed.FileSystem.ItemIsReadOnlyException | The item has the ReadOnly attribute, preventing it from being modified.
Xceed.FileSystem.ItemIsRootFolderException | The item is a root folder.

See Also

DiskFile Class | DiskFile Members | Xceed.FileSystem Namespace


DiskFile.DoExists Property

Gets a boolean value indicating if the item physically exists.

[Visual Basic]
Overrides Protected ReadOnly Property DoExists As Boolean
[C#]
protected bool DoExists {override get;}

Property Value

true if the item physically exists; false otherwise.

Remarks

This property should be evaluated before calling a method that needs to access the underlying physical item (For example, CopyTo), otherwise these methods will throw an exception.

Note: Refresh does not need to be called before accessing this property. The property will always reflect the physical item's existence.

See Also

DiskFile Class | DiskFile Members | Xceed.FileSystem Namespace


DiskFile.DoFullName Property

Gets the full name of the item.

[Visual Basic]
Overrides Protected ReadOnly Property DoFullName As String
[C#]
protected string DoFullName {override get;}

Property Value

A string that represents the full name of the item.

Remarks

The full name consists of the item's name fully-qualified with a path. For example: "c:\foo\bar.txt", "c:\foo\".

If the item represents a file, its name does not end with a path separator character.

If the item represents a folder, its name does end with a path separator character.

The separator character is defined in System.IO.Path.DirectorySeparatorChar and System.IO.Path.AltDirectorySeparatorChar.

See Also

DiskFile Class | DiskFile Members | Xceed.FileSystem Namespace


DiskFile.DoLastAccessDateTime Property

Gets or sets the last access date and time of the item.

[Visual Basic]
Overrides Protected Property DoLastAccessDateTime As Date
[C#]
protected System.DateTime DoLastAccessDateTime {override get; override set;}

Property Value

The date and time when the item was last accessed.

Remarks

When changing the item's access date through this property, the physical item is immediately modified if it exists. If it does not exist, the date is cached and will be applied whenever this item is created.

Some types of items may not expose a last access date and time. In this case, an exception is thrown when trying to read or modify the access date.

Other types of items that do expose a last access date and time may not have the information available. In this case, System.DateTime.MinValue is returned.

Note: Refresh should be called before accessing this property, or the information returned could be outdated.

Exceptions

Exception Type | Condition
System.ArgumentException | The provided last access date is not valid for this item.
Xceed.FileSystem.FileSystemNotSupportedException | The item does not expose a last access date.
Xceed.FileSystem.ItemIsReadOnlyException | The item has the ReadOnly attribute, preventing it from being modified.
Xceed.FileSystem.ItemIsRootFolderException | The physical item is a root folder.

See Also

DiskFile Class | DiskFile Members | Xceed.FileSystem Namespace


DiskFile.DoLastWriteDateTime Property

Gets or sets the modification date and time of the item.

[Visual Basic]
Overrides Protected Property DoLastWriteDateTime As Date
[C#]
protected System.DateTime DoLastWriteDateTime {override get; override set;}

Property Value

The date and time when the item was modified.

Remarks

When changing the item's modification date through this property, the physical item is immediately modified if it exists. If it does not exist, the date is cached and will be applied whenever this item is created.

Some types of items may not expose a modification date and time. In this case, an exception is thrown when trying to read or modify the modification date.

Other types of items that do expose a modification date and time may not have the information available. In this case, System.DateTime.MinValue is returned.

Note: Refresh should be called before accessing this property, or the information returned could be outdated.

Exceptions

Exception Type | Condition
System.ArgumentException | The provided modification date is not valid for this item.
Xceed.FileSystem.FileSystemNotSupportedException | The item does not expose a modification date.
Xceed.FileSystem.ItemIsReadOnlyException | The item has the ReadOnly attribute, preventing it from being modified.
Xceed.FileSystem.ItemIsRootFolderException | The item is a root folder.

See Also

DiskFile Class | DiskFile Members | Xceed.FileSystem Namespace


DiskFile.DoName Property

Gets or sets the short name of the item.

[Visual Basic]
Overrides Protected Property DoName As String
[C#]
protected string DoName {override get; override set;}

Property Value

A string that represents the short name of the item.

Remarks

The short name consists of the item's name without a path.

For example, the short name of a file named "c:\foo\bar.txt" is "bar.txt", and the short name of a folder named "c:\foo\" is "foo".

When assigning a new name to this property, the physical item is immediately renamed if it exists. If it does not exist, the new name is cached and will be applied whenever this item is created. In either cases, if a physical item with the same name already exists, an exception is thrown.

The short name of an item must not end with a path separator character regardless of whether it represents a file or a folder.

The separator character is defined in System.IO.Path.DirectorySeparatorChar and System.IO.Path.AltDirectorySeparatorChar.

Exceptions

Exception Type | Condition
System.ArgumentException | The new name assigned to the item is an empty string, contains only white space, contains a path, or contains invalid characters as defined in InvalidChars.
Xceed.FileSystem.ItemAlreadyExistsException | The new name corresponds to a physical item that already exists.
Xceed.FileSystem.ItemIsRootFolderException | The item is a root folder.

See Also

DiskFile Class | DiskFile Members | Xceed.FileSystem Namespace


DiskFile.DoParentFolder Property

Gets a reference to the parent folder of this item.

[Visual Basic]
Overrides Protected ReadOnly Property DoParentFolder As Xceed.FileSystem.AbstractFolder
[C#]
protected AbstractFolder DoParentFolder {override get;}

Property Value

An AbstractFolder object that represents the folder that contains the item, or a null reference (Nothing in Visual Basic) if the item does not have a parent.

Remarks

If the current item is the root of a folder hierarchy, it has no parent folder. In this case, the ParentFolder property returns a null reference (Nothing in Visual Basic).

See Also

DiskFile Class | DiskFile Members | Xceed.FileSystem Namespace


DiskFile.DoRootFolder Property

Gets a reference to the root folder of this item.

[Visual Basic]
Overrides Protected ReadOnly Property DoRootFolder As Xceed.FileSystem.AbstractFolder
[C#]
protected AbstractFolder DoRootFolder {override get;}

Property Value

An AbstractFolder object that represents the folder at the root of the path of this item, or a null reference (Nothing in Visual Basic) if a root folder is not available.

Remarks

A root folder represents the starting point of a folder hierarchy. On a physical disk, it is usually represented by a drive letter ("C:\") or UNC root ("\\server\share\").

Some specializations of the AbstractFolder class may define a specialized class that represents a root folder, exposing properties and methods that apply only to a root.

Therefore, the RootFolder property may return an AbstractFolder instance that is in fact a specialized class representing the root.

If the current item is the root of a folder hierarchy, the RootFolder property returns a reference to itself, or a reference to a specialized object that represents the root folder with more details.

If a root folder is not available, the RootFolder property returns a null reference (Nothing in Visual Basic).

See Also

DiskFile Class | DiskFile Members | Xceed.FileSystem Namespace


DiskFile.DoSize Property

Gets the size of the file in bytes.

[Visual Basic]
Overrides Protected ReadOnly Property DoSize As Long
[C#]
protected long DoSize {override get;}

Property Value

A value representing the file size in bytes.

Remarks

Some types of files may not have the size information available. In this case, -1 is returned.

If the file does not physically exist, an exception is thrown.

Note: Refresh should be called before accessing this property, or the information returned could be outdated.

Exceptions

Exception Type | Condition
Xceed.FileSystem.ItemDoesNotExistException | The file represented by this AbstractFile does not physically exist.

See Also

DiskFile Class | DiskFile Members | Xceed.FileSystem Namespace


DiskFile Methods

The methods of the DiskFile class are listed below. For a complete list of DiskFile class members, see the DiskFile Members topic.

Public Instance Methods

ApplyPropertiesTo (inherited from FileSystemItem) | Overloaded. Copies the item's properties to another item.
CopyTo (inherited from AbstractFile) | Overloaded.
Create (inherited from FileSystemItem) | Overloaded. Creates the physical item represented by the object.
CreateObjRef (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Delete (inherited from FileSystemItem) | Overloaded. Permanently deletes the physical item.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
InitializeLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
MoveTo (inherited from AbstractFile) | Overloaded.
OpenRead (inherited from AbstractFile) | Overloaded. Opens the file for reading.
OpenWrite (inherited from AbstractFile) | Overloaded. Opens the file for writing.
Refresh (inherited from FileSystemItem) | Overloaded. Re-reads the information from the physical item.
ToString (inherited from FileSystemItem) | Returns the full name of the item.

Protected Instance Methods

BuildListForCreate (inherited from FileSystemItem) | Handles the special cases in regards to building the list of items to process when creating a FileSystemItem object.
DoApplyPropertiesTo (inherited from FileSystemItem) | Copies the item's properties to another item. This method must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoCopyTo (inherited from AbstractFile) | Copies the file into the destination.
DoOpenRead | Opens the file for reading.
DoOpenWrite | Opens the file for writing.
DoRefresh | Re-reads the information from the physical item.
EnsureDateIsValid (inherited from FileSystemItem) | Ensures that the System.DateTime value is valid.
Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsPathRooted | Returns a boolean value indicating if the path passed is rooted.
IsSameAs | Gets a boolean value indicating if the source and target file are the same.
ListCopyTo (inherited from FileSystemItem) | Copies each item in the FileSystemEventsSession object's list to each item's destination.
ListCreate (inherited from FileSystemItem) | Creates each item in the FileSystemEventsSession object's list.
ListDelete (inherited from FileSystemItem) | Deletes each item in the FileSystemEventsSession object's list.
ListMoveTo (inherited from FileSystemItem) | Moves each item in the FileSystemEventsSession object's list to each item's destination.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Internal Instance Methods

BuildList (inherited from AbstractFile) | Builds a list of FileSystemItem objects to process.
DoCreate | Creates the physical file.
DoDelete | Permanently deletes the physical item.

See Also

DiskFile Class | Xceed.FileSystem Namespace


DiskFile.DoCreate Method

Creates the physical file.

[Visual Basic]
Overrides Protected Friend Sub DoCreate( _
   ByVal session As Xceed.FileSystem.FileSystemEventsSession _
)
[C#]
protected internal override void DoCreate(
   FileSystemEventsSession session
);

Parameters

session

A reference to a FileSystemEventsSession object which is responsible for raising all events that occur during the process.

Remarks

The file must be created in a folder that exists otherwise an exception will be thrown.

Exceptions

Exception Type | Condition
Xceed.FileSystem.ItemAlreadyExistsException | The physical file already exists.

See Also

DiskFile Class | DiskFile Members | Xceed.FileSystem Namespace


DiskFile.DoDelete Method

Permanently deletes the physical item.

[Visual Basic]
Overrides Protected Friend Sub DoDelete( _
   ByVal session As Xceed.FileSystem.FileSystemEventsSession _
)
[C#]
protected internal override void DoDelete(
   FileSystemEventsSession session
);

Parameters

session

A reference to a FileSystemEventsSession object which is responsible for raising all events that occur during the process.

Exceptions

Exception Type | Condition
Xceed.FileSystem.ItemDoesNotExistException | The file does not exist.
Xceed.FileSystem.ItemIsReadOnlyException | The file has the FileAttributes.ReadOnly attribute set.

See Also

DiskFile Class | DiskFile Members | Xceed.FileSystem Namespace


DiskFile.DoOpenRead Method

Opens the file for reading.

[Visual Basic]
Overrides Protected Function DoOpenRead( _
   ByVal session As Xceed.FileSystem.FileSystemEventsSession, _
   ByVal share As System.IO.FileShare _
) As System.IO.Stream
[C#]
protected override Stream DoOpenRead(
   FileSystemEventsSession session,
   FileShare share
);

Parameters

session

A reference to a FileSystemEventsSession object which is responsible for raising all events that occur during the process.

share

A System.IO.FileShare constant that determines how the file will be shared by different processes.

Return Value

A System.IO.Stream object that can be used to read data from the file.

Remarks

The returned stream is guaranteed to be readable, but may or may not be seekable.

The share parameter allows you to control how the file is shared by different processes.

Exceptions

Exception Type | Condition
Xceed.FileSystem.ItemDoesNotExistException | The file does not physically exist.
Xceed.FileSystem.FileSystemIOException | An error occured while attempting to open the file.

See Also

DiskFile Class | DiskFile Members | Xceed.FileSystem Namespace


DiskFile.DoOpenWrite Method

Opens the file for writing.

[Visual Basic]
Overrides Protected Function DoOpenWrite( _
   ByVal session As Xceed.FileSystem.FileSystemEventsSession, _
   ByVal overwrite As Boolean, _
   ByVal share As System.IO.FileShare _
) As System.IO.Stream
[C#]
protected override Stream DoOpenWrite(
   FileSystemEventsSession session,
   bool overwrite,
   FileShare share
);

Parameters

session

A reference to a FileSystemEventsSession object which is responsible for raising all events that occur during the process.

overwrite

true if existing data for the file should be replaced; false if existing data should be preserved, appending new data at the end.

share

A System.IO.FileShare constant that determines how the file will be shared by different processes.

Return Value

A System.IO.Stream object that can be used to write data to the file.

Remarks

The returned stream is guaranteed to be writable, but may or may not be seekable.

The share parameter allows you to control how the file is shared by different processes.

If there is no existing data, the parameter overwrite is ignored.

Exceptions

Exception Type | Condition
Xceed.FileSystem.ItemDoesNotExistException | The file does not physically exist.
Xceed.FileSystem.ItemIsReadOnlyException | The file has the FileAttributes.ReadOnly attribute set.
Xceed.FileSystem.FileSystemIOException | An error occured while attempting to open the file.

See Also

DiskFile Class | DiskFile Members | Xceed.FileSystem Namespace


DiskFile.DoRefresh Method

Re-reads the information from the physical item.

[Visual Basic]
Overrides Protected Sub DoRefresh( _
   ByVal session As Xceed.FileSystem.FileSystemEventsSession _
)
[C#]
protected override void DoRefresh(
   FileSystemEventsSession session
);

Parameters

session

A reference to a FileSystemEventsSession object which is responsible for raising all events that occur during the process.

Remarks

When a FileSystemItem object's properties, such as Attributes or CreationDateTime, are first accessed, a snapshot of the underlying physical item's properties is taken. This snapshot is not automatically updated whenever the physical item's properties change.

Refresh re-reads the information from the physical item and updates the snapshot.

Note: Refresh should be called before accessing a property, or the information returned could be outdated.

Exceptions

Exception Type | Condition
Xceed.FileSystem.ItemDoesNotExistException | The item represented by this FileSystemItem does not physically exist.

See Also

DiskFile Class | DiskFile Members | Xceed.FileSystem Namespace


DiskFile.IsPathRooted Method

Returns a boolean value indicating if the path passed is rooted.

[Visual Basic]
Overrides Protected Function IsPathRooted( _
   ByVal path As String _
) As Boolean
[C#]
protected override bool IsPathRooted(
   string path
);

Parameters

path

The path to verify.

Return Value

true if the path is rooted; false otherwise.

See Also

DiskFile Class | DiskFile Members | Xceed.FileSystem Namespace


DiskFile.IsSameAs Method

Gets a boolean value indicating if the source and target file are the same.

[Visual Basic]
Overrides Protected Function IsSameAs( _
   ByVal target As Xceed.FileSystem.FileSystemItem _
) As Boolean
[C#]
protected override bool IsSameAs(
   FileSystemItem target
);

Parameters

target

A FileSystemItem object representing the destination file.

Return Value

true if the source and target files are the same; false otherwise.

See Also

DiskFile Class | DiskFile Members | Xceed.FileSystem Namespace


DiskFolder Class

Specialization of the AbstractFolder class that implements access to a disk folder.

For a list of all members of this type, see DiskFolder Members.

System.Object
MarshalByRefObject
FileSystemItem
AbstractFolder
DiskFolder

[Visual Basic]
Public Class DiskFolder
   Inherits AbstractFolder
[C#]
public class DiskFolder : AbstractFolder

Requirements

Namespace: Xceed.FileSystem Namespace

Assembly: Xceed.FileSystem.dll

See Also

DiskFolder Members | Xceed.FileSystem Namespace


DiskFolder Members

Public Instance Constructors

DiskFolder Constructor Initializes a new instance of the DiskFolder class with the fully qualified name of an underlying physical folder.

Public Instance Properties

Attributes (inherited from FileSystemItem) | Gets or sets the attributes of the item.
CreationDateTime (inherited from FileSystemItem) | Gets or sets the creation date and time of the item.
Exists (inherited from FileSystemItem) | Gets a boolean value indicating if the item physically exists.
FullName (inherited from FileSystemItem) | Gets the full name of the item.
IsRoot (inherited from AbstractFolder) | Gets a value indicating if the folder is a root folder.
LastAccessDateTime (inherited from FileSystemItem) | Gets or sets the last access date and time of the item.
LastWriteDateTime (inherited from FileSystemItem) | Gets or sets the modification date and time of the item.
Name (inherited from FileSystemItem) | Gets or sets the short name of the item.
ParentFolder (inherited from FileSystemItem) | Gets a reference to the parent folder of this item.
RootFolder (inherited from FileSystemItem) | Gets a reference to the root folder of this item.

Public Instance Methods

ApplyPropertiesTo (inherited from FileSystemItem) | Overloaded. Copies the item's properties to another item.
CopyFilesTo (inherited from AbstractFolder) | Overloaded. Copies the folder's content to another folder.
CopyTo (inherited from FileSystemItem) | Overloaded. Copies the item, or it's content to the destination.
Create (inherited from FileSystemItem) | Overloaded. Creates the physical item represented by the object.
CreateFile (inherited from AbstractFolder) | Overloaded. Creates a new file in the folder.
CreateFolder (inherited from AbstractFolder) | Overloaded. Creates a new folder in the folder.
CreateObjRef (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Delete (inherited from FileSystemItem) | Overloaded. Permanently deletes the physical item.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetFile (inherited from AbstractFolder) | Overloaded. Returns an object that represents a file contained in the folder.
GetFiles (inherited from AbstractFolder) | Overloaded. Returns a filtered list of files contained in the folder.
GetFolder (inherited from AbstractFolder) | Overloaded. Returns an object that represents a folder contained in the folder.
GetFolders (inherited from AbstractFolder) | Overloaded. Returns a filtered list of folders contained in the folder.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetItems (inherited from AbstractFolder) | Overloaded. Returns a list of items contained in the folder.
GetLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
InitializeLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
MoveFilesTo (inherited from AbstractFolder) | Overloaded. Moves the folder's content to another folder.
MoveTo (inherited from FileSystemItem) | Overloaded. Moves the item, or it's content to the destination.
Refresh (inherited from FileSystemItem) | Overloaded. Re-reads the information from the physical item.
ToString (inherited from FileSystemItem) | Returns the full name of the item.

Protected Instance Fields

m_isRoot

Protected Instance Properties

DoAttributes | Gets or sets the attributes of the item.
DoCreationDateTime | Gets or sets the creation date and time of the item.
DoExists | Gets a boolean value indicating if the item physically exists.
DoFullName | Gets the full name of the item.
DoIsRoot (inherited from AbstractFolder) | Gets a boolean value indicating if the folder is a root folder.
DoLastAccessDateTime | Gets or sets the last access date and time of the item.
DoLastWriteDateTime | Gets or sets the modification date and time of the item.
DoName | Gets or sets the short name of the item.
DoParentFolder | Gets a reference to the parent folder of this item.
DoRootFolder | Gets a reference to the parent folder of this item.
InvalidChars (inherited from FileSystemItem) | Gets the characters that are invalid in file and folder names.

Protected Instance Methods

BuildListForCreate (inherited from FileSystemItem) | Handles the special cases in regards to building the list of items to process when creating a FileSystemItem object.
DoApplyPropertiesTo (inherited from FileSystemItem) | Copies the item's properties to another item. This method must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoCopyTo (inherited from AbstractFolder) | Copies the folder to another folder.
DoGetChildItems | Retrieves an array of FileSystemItem objects.
DoGetFile | Retrieves a reference to an AbstractFile object.
DoGetFiles (inherited from AbstractFolder) | Retrieves an array of AbstractFile objects.
DoGetFolder | Retrieves a reference to an AbstractFolder object.
DoGetFolders (inherited from AbstractFolder) | Retrieves an array of AbstractFolder objects.
DoGetItems (inherited from AbstractFolder) | Retrieves an array of FileSystemItem objects.
DoRefresh | Re-reads the information from the physical item.
EnsureDateIsValid (inherited from FileSystemItem) | Ensures that the System.DateTime value is valid.
Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsPathRooted | Returns a boolean value indicating if the path passed is rooted.
IsSameAs | Returns a boolean value indicating if the source and target items are the same.
ListCopyTo (inherited from FileSystemItem) | Copies each item in the FileSystemEventsSession object's list to each item's destination.
ListCreate (inherited from FileSystemItem) | Creates each item in the FileSystemEventsSession object's list.
ListDelete (inherited from FileSystemItem) | Deletes each item in the FileSystemEventsSession object's list.
ListMoveTo (inherited from FileSystemItem) | Moves each item in the FileSystemEventsSession object's list to each item's destination.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Internal Instance Methods

BuildList (inherited from AbstractFolder) | Builds a list of FileSystemItem objects to process.
DoCreate | Creates the physical folder.
DoDelete | Permanently deletes the physical folder.

See Also

DiskFolder Class | Xceed.FileSystem Namespace


DiskFolder Constructor

Initializes a new instance of the DiskFolder class with the fully qualified name of an underlying physical folder.

[Visual Basic]
Public Sub New( _
   ByVal folderName As String _
)
[C#]
public DiskFolder(
   string folderName
);

Parameters

folderName

Fully qualified name of the underlying physical folder. This folder may or may not physically exist.

Remarks

The folderName parameter can include relative path information, in which ".." means "previous folder". For example: "foo/bar", "../bar", etc.

In this context, a name is relative to the current working direcory of the application.

This method allows to initialize a DiskFolder object for a folder that exists, as well as for a folder that does not exist.

Exceptions

Exception Type | Condition
System.ArgumentException | The folderName parameter is an empty string, contains only white space, represents a file, or contains invalid characters as defined in InvalidChars.

See Also

DiskFolder Class | DiskFolder Members | Xceed.FileSystem Namespace


DiskFolder Fields

The fields of the DiskFolder class are listed below. For a complete list of DiskFolder class members, see the DiskFolder Members topic.

Protected Instance Fields

m_isRoot

See Also

DiskFolder Class | Xceed.FileSystem Namespace


DiskFolder.m_isRoot Field

[Visual Basic]
Protected m_isRoot As Boolean
[C#]
protected bool m_isRoot;

See Also

DiskFolder Class | DiskFolder Members | Xceed.FileSystem Namespace


DiskFolder Properties

The properties of the DiskFolder class are listed below. For a complete list of DiskFolder class members, see the DiskFolder Members topic.

Public Instance Properties

Attributes (inherited from FileSystemItem) | Gets or sets the attributes of the item.
CreationDateTime (inherited from FileSystemItem) | Gets or sets the creation date and time of the item.
Exists (inherited from FileSystemItem) | Gets a boolean value indicating if the item physically exists.
FullName (inherited from FileSystemItem) | Gets the full name of the item.
IsRoot (inherited from AbstractFolder) | Gets a value indicating if the folder is a root folder.
LastAccessDateTime (inherited from FileSystemItem) | Gets or sets the last access date and time of the item.
LastWriteDateTime (inherited from FileSystemItem) | Gets or sets the modification date and time of the item.
Name (inherited from FileSystemItem) | Gets or sets the short name of the item.
ParentFolder (inherited from FileSystemItem) | Gets a reference to the parent folder of this item.
RootFolder (inherited from FileSystemItem) | Gets a reference to the root folder of this item.

Protected Instance Properties

DoAttributes | Gets or sets the attributes of the item.
DoCreationDateTime | Gets or sets the creation date and time of the item.
DoExists | Gets a boolean value indicating if the item physically exists.
DoFullName | Gets the full name of the item.
DoIsRoot (inherited from AbstractFolder) | Gets a boolean value indicating if the folder is a root folder.
DoLastAccessDateTime | Gets or sets the last access date and time of the item.
DoLastWriteDateTime | Gets or sets the modification date and time of the item.
DoName | Gets or sets the short name of the item.
DoParentFolder | Gets a reference to the parent folder of this item.
DoRootFolder | Gets a reference to the parent folder of this item.
InvalidChars (inherited from FileSystemItem) | Gets the characters that are invalid in file and folder names.

See Also

DiskFolder Class | Xceed.FileSystem Namespace


DiskFolder.DoAttributes Property

Gets or sets the attributes of the item.

[Visual Basic]
Overrides Protected Property DoAttributes As System.IO.FileAttributes
[C#]
protected System.IO.FileAttributes DoAttributes {override get; override set;}

Property Value

A combination of System.IO.FileAttributes values that represents the attributes of the item.

Remarks

When changing the item's attributes through this property, the physical item is immediately modified if it exists. If it does not exist, the attributes are cached and will be applied whenever this item is created.

Some types of items may not expose attributes. In this case, an exception is thrown when trying to read or modify the attributes.

Note: Refresh should be called before accessing this property, or the information returned could be outdated.

Exceptions

Exception Type | Condition
Xceed.FileSystem.FileSystemNotSupportedException | The item does not expose attributes, or does not support one of the assigned attributes.
Xceed.FileSystem.ItemIsRootFolderException | The physical item is a root folder.

See Also

DiskFolder Class | DiskFolder Members | Xceed.FileSystem Namespace


DiskFolder.DoCreationDateTime Property

Gets or sets the creation date and time of the item.

[Visual Basic]
Overrides Protected Property DoCreationDateTime As Date
[C#]
protected System.DateTime DoCreationDateTime {override get; override set;}

Property Value

The date and time when the item was created.

Remarks

When changing the item's creation date through this property, the physical item is immediately modified if it exists. If it does not exist, the date is cached and will be applied whenever this item is created.

Some types of items may not expose a creation date and time. In this case, an exception is thrown when trying to read or modify the creation date.

Other types of items that do expose a creation date and time may not have the information available. In this case, System.DateTime.MinValue is returned.

Note: Refresh should be called before accessing this property, or the information returned could be outdated.

Exceptions

Exception Type | Condition
System.ArgumentException | The provided creation date is not valid for this item.
Xceed.FileSystem.FileSystemNotSupportedException | The item does not expose a creation date.
Xceed.FileSystem.ItemIsReadOnlyException | The item has the ReadOnly attribute, preventing it from being modified.
Xceed.FileSystem.ItemIsRootFolderException | The item is a root folder.

See Also

DiskFolder Class | DiskFolder Members | Xceed.FileSystem Namespace


DiskFolder.DoExists Property

Gets a boolean value indicating if the item physically exists.

[Visual Basic]
Overrides Protected ReadOnly Property DoExists As Boolean
[C#]
protected bool DoExists {override get;}

Property Value

true if the item physically exists; false otherwise.

Remarks

This property should be evaluated before calling a method that needs to access the underlying physical item (For example, CopyTo), otherwise these methods will throw an exception.

Note: Refresh does not need to be called before accessing this property. The property will always reflect the physical item's existence.

See Also

DiskFolder Class | DiskFolder Members | Xceed.FileSystem Namespace


DiskFolder.DoFullName Property

Gets the full name of the item.

[Visual Basic]
Overrides Protected ReadOnly Property DoFullName As String
[C#]
protected string DoFullName {override get;}

Property Value

A string that represents the full name of the item.

Remarks

The full name consists of the item's name fully-qualified with a path. For example: "c:\foo\bar.txt", "c:\foo\".

If the item represents a file, its name does not end with a path separator character.

If the item represents a folder, its name does end with a path separator character.

The separator character is defined in System.IO.Path.DirectorySeparatorChar and System.IO.Path.AltDirectorySeparatorChar.

See Also

DiskFolder Class | DiskFolder Members | Xceed.FileSystem Namespace


DiskFolder.DoLastAccessDateTime Property

Gets or sets the last access date and time of the item.

[Visual Basic]
Overrides Protected Property DoLastAccessDateTime As Date
[C#]
protected System.DateTime DoLastAccessDateTime {override get; override set;}

Property Value

The date and time when the item was last accessed.

Remarks

When changing the item's access date through this property, the physical item is immediately modified if it exists. If it does not exist, the date is cached and will be applied whenever this item is created.

Some types of items may not expose a last access date and time. In this case, an exception is thrown when trying to read or modify the access date.

Other types of items that do expose a last access date and time may not have the information available. In this case, System.DateTime.MinValue is returned.

Note: Refresh should be called before accessing this property, or the information returned could be outdated.

Exceptions

Exception Type | Condition
System.ArgumentException | The provided last access date is not valid for this item.
Xceed.FileSystem.FileSystemNotSupportedException | The item does not expose a last access date.
Xceed.FileSystem.ItemIsReadOnlyException | The item has the ReadOnly attribute, preventing it from being modified.
Xceed.FileSystem.ItemIsRootFolderException | The physical item is a root folder.

See Also

DiskFolder Class | DiskFolder Members | Xceed.FileSystem Namespace


DiskFolder.DoLastWriteDateTime Property

Gets or sets the modification date and time of the item.

[Visual Basic]
Overrides Protected Property DoLastWriteDateTime As Date
[C#]
protected System.DateTime DoLastWriteDateTime {override get; override set;}

Property Value

The date and time when the item was modified.

Remarks

When changing the item's modification date through this property, the physical item is immediately modified if it exists. If it does not exist, the date is cached and will be applied whenever this item is created.

Some types of items may not expose a modification date and time. In this case, an exception is thrown when trying to read or modify the modification date.

Other types of items that do expose a modification date and time may not have the information available. In this case, System.DateTime.MinValue is returned.

Note: Refresh should be called before accessing this property, or the information returned could be outdated.

Exceptions

Exception Type | Condition
System.ArgumentException | The provided modification date is not valid for this item.
Xceed.FileSystem.FileSystemNotSupportedException | The item does not expose a modification date.
Xceed.FileSystem.ItemIsReadOnlyException | The item has the ReadOnly attribute, preventing it from being modified.
Xceed.FileSystem.ItemIsRootFolderException | The item is a root folder.

See Also

DiskFolder Class | DiskFolder Members | Xceed.FileSystem Namespace


DiskFolder.DoName Property

Gets or sets the short name of the item.

[Visual Basic]
Overrides Protected Property DoName As String
[C#]
protected string DoName {override get; override set;}

Property Value

A string that represents the short name of the item.

Remarks

The short name consists of the item's name without a path.

For example, the short name of a file named "c:\foo\bar.txt" is "bar.txt", and the short name of a folder named "c:\foo\" is "foo".

When assigning a new name to this property, the physical item is immediately renamed if it exists. If it does not exist, the new name is cached and will be applied whenever this item is created. In either cases, if a physical item with the same name already exists, an exception is thrown.

The short name of an item must not end with a path separator character regardless of whether it represents a file or a folder.

The separator character is defined in System.IO.Path.DirectorySeparatorChar and System.IO.Path.AltDirectorySeparatorChar.

Exceptions

Exception Type | Condition
System.ArgumentException | The new name assigned to the item is an empty string, contains only white space, contains a path, or contains invalid characters as defined in InvalidChars.
Xceed.FileSystem.ItemAlreadyExistsException | The new name corresponds to a physical item that already exists.
Xceed.FileSystem.ItemIsRootFolderException | The item is a root folder.

See Also

DiskFolder Class | DiskFolder Members | Xceed.FileSystem Namespace


DiskFolder.DoParentFolder Property

Gets a reference to the parent folder of this item.

[Visual Basic]
Overrides Protected ReadOnly Property DoParentFolder As Xceed.FileSystem.AbstractFolder
[C#]
protected AbstractFolder DoParentFolder {override get;}

Property Value

An AbstractFolder object that represents the folder that contains the item, or a null reference (Nothing in Visual Basic) if the item does not have a parent.

Remarks

If the current item is the root of a folder hierarchy, it has no parent folder. In this case, the ParentFolder property returns a null reference (Nothing in Visual Basic).

See Also

DiskFolder Class | DiskFolder Members | Xceed.FileSystem Namespace


DiskFolder.DoRootFolder Property

Gets a reference to the parent folder of this item.

[Visual Basic]
Overrides Protected ReadOnly Property DoRootFolder As Xceed.FileSystem.AbstractFolder
[C#]
protected AbstractFolder DoRootFolder {override get;}

Property Value

An AbstractFolder object that represents the folder that contains the item, or a null reference (Nothing in Visual Basic) if the item does not have a parent.

Remarks

If the current item is the root of a folder hierarchy, it has no parent folder. In this case, the ParentFolder property returns a null reference (Nothing in Visual Basic).

See Also

DiskFolder Class | DiskFolder Members | Xceed.FileSystem Namespace


DiskFolder Methods

The methods of the DiskFolder class are listed below. For a complete list of DiskFolder class members, see the DiskFolder Members topic.

Public Instance Methods

ApplyPropertiesTo (inherited from FileSystemItem) | Overloaded. Copies the item's properties to another item.
CopyFilesTo (inherited from AbstractFolder) | Overloaded.
CopyTo (inherited from FileSystemItem) | Overloaded. Copies the item, or it's content to the destination.
Create (inherited from FileSystemItem) | Overloaded. Creates the physical item represented by the object.
CreateFile (inherited from AbstractFolder) | Overloaded.
CreateFolder (inherited from AbstractFolder) | Overloaded.
CreateObjRef (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Delete (inherited from FileSystemItem) | Overloaded. Permanently deletes the physical item.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetFile (inherited from AbstractFolder) | Overloaded.
GetFiles (inherited from AbstractFolder) | Overloaded.
GetFolder (inherited from AbstractFolder) | Overloaded.
GetFolders (inherited from AbstractFolder) | Overloaded.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetItems (inherited from AbstractFolder) | Overloaded.
GetLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
InitializeLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
MoveFilesTo (inherited from AbstractFolder) | Overloaded.
MoveTo (inherited from FileSystemItem) | Overloaded. Moves the item, or it's content to the destination.
Refresh (inherited from FileSystemItem) | Overloaded. Re-reads the information from the physical item.
ToString (inherited from FileSystemItem) | Returns the full name of the item.

Protected Instance Methods

BuildListForCreate (inherited from FileSystemItem) | Handles the special cases in regards to building the list of items to process when creating a FileSystemItem object.
DoApplyPropertiesTo (inherited from FileSystemItem) | Copies the item's properties to another item. This method must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoCopyTo (inherited from AbstractFolder) | Copies the folder to another folder.
DoGetChildItems | Retrieves an array of FileSystemItem objects.
DoGetFile | Retrieves a reference to an AbstractFile object.
DoGetFiles (inherited from AbstractFolder) | Retrieves an array of AbstractFile objects.
DoGetFolder | Retrieves a reference to an AbstractFolder object.
DoGetFolders (inherited from AbstractFolder) | Retrieves an array of AbstractFolder objects.
DoGetItems (inherited from AbstractFolder) | Retrieves an array of FileSystemItem objects.
DoRefresh | Re-reads the information from the physical item.
EnsureDateIsValid (inherited from FileSystemItem) | Ensures that the System.DateTime value is valid.
Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsPathRooted | Returns a boolean value indicating if the path passed is rooted.
IsSameAs | Returns a boolean value indicating if the source and target items are the same.
ListCopyTo (inherited from FileSystemItem) | Copies each item in the FileSystemEventsSession object's list to each item's destination.
ListCreate (inherited from FileSystemItem) | Creates each item in the FileSystemEventsSession object's list.
ListDelete (inherited from FileSystemItem) | Deletes each item in the FileSystemEventsSession object's list.
ListMoveTo (inherited from FileSystemItem) | Moves each item in the FileSystemEventsSession object's list to each item's destination.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Internal Instance Methods

BuildList (inherited from AbstractFolder) | Builds a list of FileSystemItem objects to process.
DoCreate | Creates the physical folder.
DoDelete | Permanently deletes the physical folder.

See Also

DiskFolder Class | Xceed.FileSystem Namespace


DiskFolder.DoCreate Method

Creates the physical folder.

[Visual Basic]
Overrides Protected Friend Sub DoCreate( _
   ByVal session As Xceed.FileSystem.FileSystemEventsSession _
)
[C#]
protected internal override void DoCreate(
   FileSystemEventsSession session
);

Parameters

session

A reference to a FileSystemEventsSession object which is responsible for raising all events that occur during the process.

Remarks

The folder must be created in a folder that exists otherwise an exception will be thrown.

Exceptions

Exception Type | Condition
Xceed.FileSystem.ItemAlreadyExistsException | The physical folder already exists.

See Also

DiskFolder Class | DiskFolder Members | Xceed.FileSystem Namespace


DiskFolder.DoDelete Method

Permanently deletes the physical folder.

[Visual Basic]
Overrides Protected Friend Sub DoDelete( _
   ByVal session As Xceed.FileSystem.FileSystemEventsSession _
)
[C#]
protected internal override void DoDelete(
   FileSystemEventsSession session
);

Parameters

session

A reference to a FileSystemEventsSession object which is responsible for raising all events that occur during the process.

Exceptions

Exception Type | Condition
Xceed.FileSystem.ItemDoesNotExistException | The physical folder does exist.
Xceed.FileSystem.ItemIsReadOnlyException | The physical folder is read-only.

See Also

DiskFolder Class | DiskFolder Members | Xceed.FileSystem Namespace


DiskFolder.DoGetChildItems Method

Retrieves an array of FileSystemItem objects.

[Visual Basic]
Overrides Protected Function DoGetChildItems( _
   ByVal session As Xceed.FileSystem.FileSystemEventsSession _
) As Xceed.FileSystem.FileSystemItem()
[C#]
protected override FileSystemItem[] DoGetChildItems(
   FileSystemEventsSession session
);

Parameters

session

A reference to a FileSystemEventsSession object which is responsible for raising all events that occur during the process.

Return Value

An array of FileSystemItem objects representing the items ( files and folders ) contained within the folder.

See Also

DiskFolder Class | DiskFolder Members | Xceed.FileSystem Namespace


DiskFolder.DoGetFile Method

Retrieves a reference to an AbstractFile object.

[Visual Basic]
Overrides Protected Function DoGetFile( _
   ByVal session As Xceed.FileSystem.FileSystemEventsSession, _
   ByVal fileName As String _
) As Xceed.FileSystem.AbstractFile
[C#]
protected override AbstractFile DoGetFile(
   FileSystemEventsSession session,
   string fileName
);

Parameters

session

A reference to a FileSystemEventsSession object which is responsible for raising all events that occur during the process.

fileName

The name of the file to retrieve.

Return Value

A reference to an AbstractFile object regardless of if the file represented by the object exists or not.

Remarks

fileName should not end with a System.IO.Path.DirectorySeparatorChar.

See Also

DiskFolder Class | DiskFolder Members | Xceed.FileSystem Namespace


DiskFolder.DoGetFolder Method

Retrieves a reference to an AbstractFolder object.

[Visual Basic]
Overrides Protected Function DoGetFolder( _
   ByVal session As Xceed.FileSystem.FileSystemEventsSession, _
   ByVal folderName As String _
) As Xceed.FileSystem.AbstractFolder
[C#]
protected override AbstractFolder DoGetFolder(
   FileSystemEventsSession session,
   string folderName
);

Parameters

session

A reference to a FileSystemEventsSession object which is responsible for raising all events that occur during the process.

folderName

The name of the folder to retrieve.

Return Value

A reference to an AbstractFolder object regardless of if the folder represented by the object exists or not.

Remarks

folderName should not end with a System.IO.Path.DirectorySeparatorChar.

See Also

DiskFolder Class | DiskFolder Members | Xceed.FileSystem Namespace


DiskFolder.DoRefresh Method

Re-reads the information from the physical item.

[Visual Basic]
Overrides Protected Sub DoRefresh( _
   ByVal session As Xceed.FileSystem.FileSystemEventsSession _
)
[C#]
protected override void DoRefresh(
   FileSystemEventsSession session
);

Parameters

session

A reference to a FileSystemEventsSession object which is responsible for raising all events that occur during the process.

Remarks

When a FileSystemItem object's properties, such as Attributes or CreationDateTime, are first accessed, a snapshot of the underlying physical item's properties is taken. This snapshot is not automatically updated whenever the physical item's properties change.

Refresh re-reads the information from the physical item and updates the snapshot.

Note: Refresh should be called before accessing a property, or the information returned could be outdated.

Exceptions

Exception Type | Condition
Xceed.FileSystem.ItemDoesNotExistException | The item represented by this FileSystemItem does not physically exist.

See Also

DiskFolder Class | DiskFolder Members | Xceed.FileSystem Namespace


DiskFolder.IsPathRooted Method

Returns a boolean value indicating if the path passed is rooted.

[Visual Basic]
Overrides Protected Function IsPathRooted( _
   ByVal path As String _
) As Boolean
[C#]
protected override bool IsPathRooted(
   string path
);

Parameters

path

The path to verify.

Return Value

true if the path is rooted; false otherwise.

See Also

DiskFolder Class | DiskFolder Members | Xceed.FileSystem Namespace


DiskFolder.IsSameAs Method

Returns a boolean value indicating if the source and target items are the same.

[Visual Basic]
Overrides Protected Function IsSameAs( _
   ByVal target As Xceed.FileSystem.FileSystemItem _
) As Boolean
[C#]
protected override bool IsSameAs(
   FileSystemItem target
);

Parameters

target

A FileSystemItem object representing the destination item.

Return Value

true if the source and target FileSystemItem objects are the same; false otherwise.

See Also

DiskFolder Class | DiskFolder Members | Xceed.FileSystem Namespace


FileSystemEventArgs Class

The base class for argument classes used by all events.

For a list of all members of this type, see FileSystemEventArgs Members.

System.Object
EventArgs
FileSystemEventArgs

[Visual Basic]
Public Class FileSystemEventArgs
   Inherits EventArgs
[C#]
public class FileSystemEventArgs : EventArgs

Requirements

Namespace: Xceed.FileSystem Namespace

Assembly: Xceed.FileSystem.dll

See Also

FileSystemEventArgs Members | Xceed.FileSystem Namespace


FileSystemEventArgs Members

Public Instance Constructors

FileSystemEventArgs Constructor Creates a new instance of the FileSystemEventArgs class.

Public Instance Properties

CurrentItem | Gets or sets the current FileSystemItem object being processed.
TargetItem | Gets or sets the destination FileSystemItem object.
UserData | Gets or sets the opaque data that will be sent back to the event handler whenever an event is raised.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Fields

m_currentItem | The current FileSystemItem object being processed.
m_targetItem | The current target FileSystemItem object of the process.
m_userData | Opaque data that is sent back to the event handler when an event is raised.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

FileSystemEventArgs Class | Xceed.FileSystem Namespace


FileSystemEventArgs Constructor

Creates a new instance of the FileSystemEventArgs class.

[Visual Basic]
Public Sub New()
[C#]
public FileSystemEventArgs();

See Also

FileSystemEventArgs Class | FileSystemEventArgs Members | Xceed.FileSystem Namespace


FileSystemEventArgs Fields

The fields of the FileSystemEventArgs class are listed below. For a complete list of FileSystemEventArgs class members, see the FileSystemEventArgs Members topic.

Protected Instance Fields

m_currentItem | The current FileSystemItem object being processed.
m_targetItem | The current target FileSystemItem object of the process.
m_userData | Opaque data that is sent back to the event handler when an event is raised.

See Also

FileSystemEventArgs Class | Xceed.FileSystem Namespace


FileSystemEventArgs.m_currentItem Field

The current FileSystemItem object being processed.

[Visual Basic]
Protected m_currentItem As Xceed.FileSystem.FileSystemItem
[C#]
protected FileSystemItem m_currentItem;

See Also

FileSystemEventArgs Class | FileSystemEventArgs Members | Xceed.FileSystem Namespace


FileSystemEventArgs.m_targetItem Field

The current target FileSystemItem object of the process.

[Visual Basic]
Protected m_targetItem As Xceed.FileSystem.FileSystemItem
[C#]
protected FileSystemItem m_targetItem;

See Also

FileSystemEventArgs Class | FileSystemEventArgs Members | Xceed.FileSystem Namespace


FileSystemEventArgs.m_userData Field

Opaque data that is sent back to the event handler when an event is raised.

[Visual Basic]
Protected m_userData As Object
[C#]
protected object m_userData;

See Also

FileSystemEventArgs Class | FileSystemEventArgs Members | Xceed.FileSystem Namespace


FileSystemEventArgs Properties

The properties of the FileSystemEventArgs class are listed below. For a complete list of FileSystemEventArgs class members, see the FileSystemEventArgs Members topic.

Public Instance Properties

CurrentItem | Gets or sets the current FileSystemItem object being processed.
TargetItem | Gets or sets the destination FileSystemItem object.
UserData | Gets or sets the opaque data that will be sent back to the event handler whenever an event is raised.

See Also

FileSystemEventArgs Class | Xceed.FileSystem Namespace


FileSystemEventArgs.CurrentItem Property

Gets or sets the current FileSystemItem object being processed.

[Visual Basic]
Public Property CurrentItem As Xceed.FileSystem.FileSystemItem
[C#]
public FileSystemItem CurrentItem {get; set;}

Property Value

A reference to a FileSystemItem object.

See Also

FileSystemEventArgs Class | FileSystemEventArgs Members | Xceed.FileSystem Namespace


FileSystemEventArgs.TargetItem Property

Gets or sets the destination FileSystemItem object.

[Visual Basic]
Public Property TargetItem As Xceed.FileSystem.FileSystemItem
[C#]
public FileSystemItem TargetItem {get; set;}

Property Value

A reference to the eventual target FileSystemItem object.

See Also

FileSystemEventArgs Class | FileSystemEventArgs Members | Xceed.FileSystem Namespace


FileSystemEventArgs.UserData Property

Gets or sets the opaque data that will be sent back to the event handler whenever an event is raised.

[Visual Basic]
Public Property UserData As Object
[C#]
public object UserData {get; set;}

Property Value

Opaque data that is sent back to the event handler.

See Also

FileSystemEventArgs Class | FileSystemEventArgs Members | Xceed.FileSystem Namespace


FileSystemEvents Class

Class that dispatches events raised from methods called on FileSystemItem objects or objects that derive from the FileSystemItem class.

For a list of all members of this type, see FileSystemEvents Members.

System.Object
FileSystemEvents

[Visual Basic]
Public Class FileSystemEvents
[C#]
public class FileSystemEvents

Remarks

This class serves as a central point of access to associate event handlers with method calls, for methods that need to raise events.

Requirements

Namespace: Xceed.FileSystem Namespace

Assembly: Xceed.FileSystem.dll

See Also

FileSystemEvents Members | Xceed.FileSystem Namespace


FileSystemEvents Members

Public Instance Constructors

FileSystemEvents Constructor

Public Instance Methods

BeginSubOperation | Called when a sub-operation is begun within a process.
CreateSession | Creates a new session from a FileSystemEvents object.
EndSubOperation | Called when a sub-operation is ended within a process.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Public Instance Events

ByteProgression | Raised for every 64k of bytes processed when a FileSystemItem object is being processed.
ItemException | Raised when an exception is caught during the processing of a FileSystemItem object, allowing the handler to decide the action to take.
ItemProgression | Raised every time a FileSystemItem object is about to be processed, providing progression information to the event handler.
ScanningFolder | Raised when an AbstractFolder object is accessed or is scanned for matching items while building a list of items to process.

Protected Instance Fields

m_subOperationCount Sub-operation counter which keeps a reference count on the amount of sub-operations within a process.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.
ValidateParams | Verifies the validity of the parameters sent to the event handlers.

Protected Internal Instance Properties

WantsByteProgression | Gets a boolean value indicating if the FileSystemEvents object has subscribed to the OnByteProgression event.
WantsItemException | Gets a boolean value indicating if the FileSystemEvents object has subscribed to the OnItemException event.
WantsItemProgression | Gets a boolean value indicating if the FileSystemEvents object has subscribed to the OnItemProgression event.
WantsScanningFolder | Gets a boolean value indicating if the FileSystemEvents object has subscribed to the OnScanningFolder event.

Protected Internal Instance Methods

OnByteProgression | Calls the delegated OnByteProgression event handler.
OnItemException | Calls the delegated OnItemException event handler.
OnItemProgression | Calls the delegated OnItemProgression event handler.
OnScanningFolder | Calls the delegated OnScanningFolder event handler.

See Also

FileSystemEvents Class | Xceed.FileSystem Namespace


FileSystemEvents Constructor

[Visual Basic]
Public Sub New()
[C#]
public FileSystemEvents();

See Also

FileSystemEvents Class | FileSystemEvents Members | Xceed.FileSystem Namespace


FileSystemEvents Fields

The fields of the FileSystemEvents class are listed below. For a complete list of FileSystemEvents class members, see the FileSystemEvents Members topic.

Protected Instance Fields

m_subOperationCount Sub-operation counter which keeps a reference count on the amount of sub-operations within a process.

See Also

FileSystemEvents Class | Xceed.FileSystem Namespace


FileSystemEvents.m_subOperationCount Field

Sub-operation counter which keeps a reference count on the amount of sub-operations within a process.

[Visual Basic]
Protected m_subOperationCount As Integer
[C#]
protected int m_subOperationCount;

See Also

FileSystemEvents Class | FileSystemEvents Members | Xceed.FileSystem Namespace


FileSystemEvents Properties

The properties of the FileSystemEvents class are listed below. For a complete list of FileSystemEvents class members, see the FileSystemEvents Members topic.

Protected Internal Instance Properties

WantsByteProgression | Gets a boolean value indicating if the FileSystemEvents object has subscribed to the OnByteProgression event.
WantsItemException | Gets a boolean value indicating if the FileSystemEvents object has subscribed to the OnItemException event.
WantsItemProgression | Gets a boolean value indicating if the FileSystemEvents object has subscribed to the OnItemProgression event.
WantsScanningFolder | Gets a boolean value indicating if the FileSystemEvents object has subscribed to the OnScanningFolder event.

See Also

FileSystemEvents Class | Xceed.FileSystem Namespace


FileSystemEvents.WantsByteProgression Property

Gets a boolean value indicating if the FileSystemEvents object has subscribed to the OnByteProgression event.

[Visual Basic]
Overridable Protected Friend ReadOnly Property WantsByteProgression As Boolean
[C#]
protected internal bool WantsByteProgression {virtual get;}

Property Value

true if the FileSystemEvents object has subscribed to the OnByteProgression event; false otherwise.

Remarks

It is not necessary to override this method.

See Also

FileSystemEvents Class | FileSystemEvents Members | Xceed.FileSystem Namespace


FileSystemEvents.WantsItemException Property

Gets a boolean value indicating if the FileSystemEvents object has subscribed to the OnItemException event.

[Visual Basic]
Overridable Protected Friend ReadOnly Property WantsItemException As Boolean
[C#]
protected internal bool WantsItemException {virtual get;}

Property Value

true if the FileSystemEvents object has subscribed to the OnItemException event; false otherwise.

Remarks

It is not necessary to override this method.

See Also

FileSystemEvents Class | FileSystemEvents Members | Xceed.FileSystem Namespace


FileSystemEvents.WantsItemProgression Property

Gets a boolean value indicating if the FileSystemEvents object has subscribed to the OnItemProgression event.

[Visual Basic]
Overridable Protected Friend ReadOnly Property WantsItemProgression As Boolean
[C#]
protected internal bool WantsItemProgression {virtual get;}

Property Value

true if the FileSystemEvents object has subscribed to the OnItemProgression event; false otherwise.

Remarks

It is not necessary to override this method.

See Also

FileSystemEvents Class | FileSystemEvents Members | Xceed.FileSystem Namespace


FileSystemEvents.WantsScanningFolder Property

Gets a boolean value indicating if the FileSystemEvents object has subscribed to the OnScanningFolder event.

[Visual Basic]
Overridable Protected Friend ReadOnly Property WantsScanningFolder As Boolean
[C#]
protected internal bool WantsScanningFolder {virtual get;}

Property Value

true if the FileSystemEvents object has subscribed to the OnScanningFolder event; false otherwise.

Remarks

It is not necessary to override this method.

See Also

FileSystemEvents Class | FileSystemEvents Members | Xceed.FileSystem Namespace


FileSystemEvents Methods

The methods of the FileSystemEvents class are listed below. For a complete list of FileSystemEvents class members, see the FileSystemEvents Members topic.

Public Instance Methods

BeginSubOperation | Called when a sub-operation is begun within a process.
CreateSession | Creates a new session from a FileSystemEvents object.
EndSubOperation | Called when a sub-operation is ended within a process.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.
ValidateParams | Verifies the validity of the parameters sent to the event handlers.

Protected Internal Instance Methods

OnByteProgression | Calls the delegated OnByteProgression event handler.
OnItemException | Calls the delegated OnItemException event handler.
OnItemProgression | Calls the delegated OnItemProgression event handler.
OnScanningFolder | Calls the delegated OnScanningFolder event handler.

See Also

FileSystemEvents Class | Xceed.FileSystem Namespace


FileSystemEvents.BeginSubOperation Method

Called when a sub-operation is begun within a process.

[Visual Basic]
Overridable Public Sub BeginSubOperation()
[C#]
public virtual void BeginSubOperation();

Remarks

Increments the sub-operation counter.

See Also

FileSystemEvents Class | FileSystemEvents Members | Xceed.FileSystem Namespace


FileSystemEvents.CreateSession Method

Creates a new session from a FileSystemEvents object.

[Visual Basic]
Overridable Public Function CreateSession( _
   ByVal sender As Object, _
   ByVal userData As Object _
) As Xceed.FileSystem.FileSystemEventsSession
[C#]
public virtual FileSystemEventsSession CreateSession(
   object sender,
   object userData
);

Parameters

sender

The FileSystemItem object from which the session is created.

userData

Opaque data that is sent back to the event handler when an event is raised.

Return Value

A reference to a FileSystemEventsSession object.

See Also

FileSystemEvents Class | FileSystemEvents Members | Xceed.FileSystem Namespace


FileSystemEvents.EndSubOperation Method

Called when a sub-operation is ended within a process.

[Visual Basic]
Overridable Public Sub EndSubOperation()
[C#]
public virtual void EndSubOperation();

Remarks

Decrements the sub-operation counter.

See Also

FileSystemEvents Class | FileSystemEvents Members | Xceed.FileSystem Namespace


FileSystemEvents.OnByteProgression Method

Calls the delegated OnByteProgression event handler.

[Visual Basic]
Overridable Protected Friend Sub OnByteProgression( _
   ByVal sender As Object, _
   ByVal e As Xceed.FileSystem.ByteProgressionEventArgs _
)
[C#]
protected internal virtual void OnByteProgression(
   object sender,
   ByteProgressionEventArgs e
);

Parameters

sender

The FileSystemItem on which the method was called.

e

An instance of the ByteProgressionEventArgs argument class that contains byte progression information.

Remarks

It is not necessary to override this method.

See Also

FileSystemEvents Class | FileSystemEvents Members | Xceed.FileSystem Namespace


FileSystemEvents.OnItemException Method

Calls the delegated OnItemException event handler.

[Visual Basic]
Overridable Protected Friend Sub OnItemException( _
   ByVal sender As Object, _
   ByVal e As Xceed.FileSystem.ItemExceptionEventArgs _
)
[C#]
protected internal virtual void OnItemException(
   object sender,
   ItemExceptionEventArgs e
);

Parameters

sender

The FileSystemItem on which the method was called.

e

An instance of the ItemExceptionEventArgs argument class that contains information on the exception that was raised.

Remarks

It is not necessary to override this method.

See Also

FileSystemEvents Class | FileSystemEvents Members | Xceed.FileSystem Namespace


FileSystemEvents.OnItemProgression Method

Calls the delegated OnItemProgression event handler.

[Visual Basic]
Overridable Protected Friend Sub OnItemProgression( _
   ByVal sender As Object, _
   ByVal e As Xceed.FileSystem.ItemProgressionEventArgs _
)
[C#]
protected internal virtual void OnItemProgression(
   object sender,
   ItemProgressionEventArgs e
);

Parameters

sender

The FileSystemItem on which the method was called.

e

An instance of the ItemProgressionEventArgs argument class that contains item progression information.

Remarks

It is not necessary to override this method.

See Also

FileSystemEvents Class | FileSystemEvents Members | Xceed.FileSystem Namespace


FileSystemEvents.OnScanningFolder Method

Calls the delegated OnScanningFolder event handler.

[Visual Basic]
Overridable Protected Friend Sub OnScanningFolder( _
   ByVal sender As Object, _
   ByVal e As Xceed.FileSystem.ScanningFolderEventArgs _
)
[C#]
protected internal virtual void OnScanningFolder(
   object sender,
   ScanningFolderEventArgs e
);

Parameters

sender

The FileSystemItem on which the method was called.

e

An instance of the ScanningFolderEventArgs argument class that contains information on the folder being scanned.

Remarks

It is not necessary to override this method.

See Also

FileSystemEvents Class | FileSystemEvents Members | Xceed.FileSystem Namespace


FileSystemEvents.ValidateParams Method

Verifies the validity of the parameters sent to the event handlers.

[Visual Basic]
Protected Sub ValidateParams( _
   ByVal sender As Object, _
   ByVal e As Xceed.FileSystem.FileSystemEventArgs _
)
[C#]
protected void ValidateParams(
   object sender,
   FileSystemEventArgs e
);

Parameters

sender

The FileSystemItem on which the method was called.

e

An instance of the FileSystemEventArgs argument class.

See Also

FileSystemEvents Class | FileSystemEvents Members | Xceed.FileSystem Namespace


FileSystemEvents Events

The events of the FileSystemEvents class are listed below. For a complete list of FileSystemEvents class members, see the FileSystemEvents Members topic.

Public Instance Events

ByteProgression | Raised for every 64k of bytes processed when a FileSystemItem object is being processed.
ItemException | Raised when an exception is caught during the processing of a FileSystemItem object, allowing the handler to decide the action to take.
ItemProgression | Raised every time a FileSystemItem object is about to be processed, providing progression information to the event handler.
ScanningFolder | Raised when an AbstractFolder object is accessed or is scanned for matching items while building a list of items to process.

See Also

FileSystemEvents Class | Xceed.FileSystem Namespace


FileSystemEvents.ByteProgression Event

Raised for every 64k of bytes processed when a FileSystemItem object is being processed.

[Visual Basic]
Public ByteProgression As Xceed.FileSystem.ByteProgressionEventHandler
[C#]
public ByteProgressionEventHandler ByteProgression;

Event Data

The event handler receives a ByteProgressionEventArgs containing data related to the ByteProgression event. The following ByteProgressionEventArgs properties provide information specific to this event.

Property | Description
AllFilesBytes | Gets the total combined size, in bytes, of all files being processed.
CurrentFileBytes | Gets the size, in bytes, of the file currently being processed.
CurrentItem |
TargetItem |
UserData |

See Also

FileSystemEvents Class | FileSystemEvents Members | Xceed.FileSystem Namespace


FileSystemEvents.ItemException Event

Raised when an exception is caught during the processing of a FileSystemItem object, allowing the handler to decide the action to take.

[Visual Basic]
Public ItemException As Xceed.FileSystem.ItemExceptionEventHandler
[C#]
public ItemExceptionEventHandler ItemException;

Event Data

The event handler receives a ItemExceptionEventArgs containing data related to the ItemException event. The following ItemExceptionEventArgs properties provide information specific to this event.

Property | Description
Action | Gets or sets the action taken when an exception is thrown during the processing of a FileSystemItem object.
CurrentItem |
Exception | Gets or sets the exception that was thrown.
TargetItem |
UserData |

See Also

FileSystemEvents Class | FileSystemEvents Members | Xceed.FileSystem Namespace


FileSystemEvents.ItemProgression Event

Raised every time a FileSystemItem object is about to be processed, providing progression information to the event handler.

[Visual Basic]
Public ItemProgression As Xceed.FileSystem.ItemProgressionEventHandler
[C#]
public ItemProgressionEventHandler ItemProgression;

Event Data

The event handler receives a ItemProgressionEventArgs containing data related to the ItemProgression event. The following ItemProgressionEventArgs properties provide information specific to this event.

Property | Description
AllItems | Gets the total number of items being processed.
CurrentItem |
TargetItem |
UserData |

See Also

FileSystemEvents Class | FileSystemEvents Members | Xceed.FileSystem Namespace


FileSystemEvents.ScanningFolder Event

Raised when an AbstractFolder object is accessed or is scanned for matching items while building a list of items to process.

[Visual Basic]
Public ScanningFolder As Xceed.FileSystem.ScanningFolderEventHandler
[C#]
public ScanningFolderEventHandler ScanningFolder;

Event Data

The event handler receives a ScanningFolderEventArgs containing data related to the ScanningFolder event. The following ScanningFolderEventArgs properties provide information specific to this event.

Property | Description
CurrentItem |
TargetItem |
UserData |

See Also

FileSystemEvents Class | FileSystemEvents Members | Xceed.FileSystem Namespace


FileSystemEventsSession Class

Class which holds information about the session which is responsible for raising all events that occur during the process.

For a list of all members of this type, see FileSystemEventsSession Members.

System.Object
FileSystemEventsSession

[Visual Basic]
Public Class FileSystemEventsSession
[C#]
public class FileSystemEventsSession

Requirements

Namespace: Xceed.FileSystem Namespace

Assembly: Xceed.FileSystem.dll

See Also

FileSystemEventsSession Members | Xceed.FileSystem Namespace


FileSystemEventsSession Members

Public Instance Properties

CurrentItem | Gets or sets the FileSystemItem object currently being processed.
Events | Gets the original FileSystemEvents object used to create the session.
IsEmpty | Gets a boolean value indicating if the session's list of FileSystemItem objects to process contains no items.
TargetItem | Gets or sets the eventual target FileSystemItem object for the process.
UserData | Gets the opaque data that is sent back to the event handler when an event is raised.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetNextItemPair | Retrieves the next pair of FileSystemItem objects to be processed.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
OnBytesCompleted | Forces the byte progression to 100% completion.
OnBytesProcessed | Raises the ByteProgression event for a FileSystemItem object being processed.
OnCompletion | Raises the last ItemProgression event when the process is completed.
OnException | Raises the ItemException event whenever an error occurs during the processing of a FileSystemItem object.
OnNewItemToProcess | Places the new item in the list of FileSystemItem objects to be processed.
OnProcessingNewItem | Raised when a new item is about to be processed.
OnScanningFolder | Raised when a folder is scanned or accessed during the processing of FileSystemItem objects.
OnUndoBytesProcessed | Removes the amount of bytes processed for an item if an error occured during the processing of that item.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Fields

m_allFilesBytes | An instance of the ProgressionInfo class representing the byte count information in regards to all the items to be processed for the current session.
m_allItems | An instance of the ProgressionInfo class representing the item count information for the current session.
m_byteProgressionArgs | An instance of the ByteProgressionEventArgs class that provides byte progression information for the current session.
m_currentFileBytes | An instance of the ProgressionInfo class representing the byte count information in regards to the current item being processed for the current session.
m_currentItem | The current FileSystemItem object being processed for the current session.
m_events | An instance of the FileSystemEvents class representing the original FileSystemEvents object from which we created the session.
m_itemExceptionArgs | An instance of the ItemExceptionEventArgs class that provides information on the exception that was thrown during a process for the current session.
m_itemPairQueue | Represents a first-in, first-out collection of the items to process for the current session.
m_itemProgressionArgs | An instance of the ItemProgressionEventArgs class that provides item progression information for the current session.
m_scanningFolderArgs | An instance of the ScanningFolderEventArgs class that provides information on the folder being scanned or accessed for the current session.
m_sender | The FileSystemItem object on which the process was called.
m_targetItem | The current target FileSystemItem object of the process for the current session.
m_userData | This is set at construction, and updated after each event. It is assigned to each argument structure before each event.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Internal Instance Constructors

FileSystemEventsSession Constructor Creates a new instance of the FileSystemEventsSession class.

See Also

FileSystemEventsSession Class | Xceed.FileSystem Namespace


FileSystemEventsSession Constructor

Creates a new instance of the FileSystemEventsSession class.

[Visual Basic]
Protected Friend Sub New( _
   ByVal events As Xceed.FileSystem.FileSystemEvents, _
   ByVal sender As Object, _
   ByVal userData As Object _
)
[C#]
protected internal FileSystemEventsSession(
   FileSystemEvents events,
   object sender,
   object userData
);

Parameters

events

The FileSystemEvents object from which we created the session.

sender

The FileSystemItem object on which the process was called.

userData

Opaque data that is sent back to the event handler when an event is raised.

Remarks

This constructor is called within the CreateSession method found in the FileSystemEvents class.

See Also

FileSystemEventsSession Class | FileSystemEventsSession Members | Xceed.FileSystem Namespace


FileSystemEventsSession Fields

The fields of the FileSystemEventsSession class are listed below. For a complete list of FileSystemEventsSession class members, see the FileSystemEventsSession Members topic.

Protected Instance Fields

m_allFilesBytes | An instance of the ProgressionInfo class representing the byte count information in regards to all the items to be processed for the current session.
m_allItems | An instance of the ProgressionInfo class representing the item count information for the current session.
m_byteProgressionArgs | An instance of the ByteProgressionEventArgs class that provides byte progression information for the current session.
m_currentFileBytes | An instance of the ProgressionInfo class representing the byte count information in regards to the current item being processed for the current session.
m_currentItem | The current FileSystemItem object being processed for the current session.
m_events | An instance of the FileSystemEvents class representing the original FileSystemEvents object from which we created the session.
m_itemExceptionArgs | An instance of the ItemExceptionEventArgs class that provides information on the exception that was thrown during a process for the current session.
m_itemPairQueue | Represents a first-in, first-out collection of the items to process for the current session.
m_itemProgressionArgs | An instance of the ItemProgressionEventArgs class that provides item progression information for the current session.
m_scanningFolderArgs | An instance of the ScanningFolderEventArgs class that provides information on the folder being scanned or accessed for the current session.
m_sender | The FileSystemItem object on which the process was called.
m_targetItem | The current target FileSystemItem object of the process for the current session.
m_userData | This is set at construction, and updated after each event. It is assigned to each argument structure before each event.

See Also

FileSystemEventsSession Class | Xceed.FileSystem Namespace


FileSystemEventsSession.m_allFilesBytes Field

An instance of the ProgressionInfo class representing the byte count information in regards to all the items to be processed for the current session.

[Visual Basic]
Protected m_allFilesBytes As Xceed.FileSystem.ProgressionInfo
[C#]
protected ProgressionInfo m_allFilesBytes;

See Also

FileSystemEventsSession Class | FileSystemEventsSession Members | Xceed.FileSystem Namespace


FileSystemEventsSession.m_allItems Field

An instance of the ProgressionInfo class representing the item count information for the current session.

[Visual Basic]
Protected m_allItems As Xceed.FileSystem.ProgressionInfo
[C#]
protected ProgressionInfo m_allItems;

See Also

FileSystemEventsSession Class | FileSystemEventsSession Members | Xceed.FileSystem Namespace


FileSystemEventsSession.m_byteProgressionArgs Field

An instance of the ByteProgressionEventArgs class that provides byte progression information for the current session.

[Visual Basic]
Protected m_byteProgressionArgs As Xceed.FileSystem.ByteProgressionEventArgs
[C#]
protected ByteProgressionEventArgs m_byteProgressionArgs;

See Also

FileSystemEventsSession Class | FileSystemEventsSession Members | Xceed.FileSystem Namespace


FileSystemEventsSession.m_currentFileBytes Field

An instance of the ProgressionInfo class representing the byte count information in regards to the current item being processed for the current session.

[Visual Basic]
Protected m_currentFileBytes As Xceed.FileSystem.ProgressionInfo
[C#]
protected ProgressionInfo m_currentFileBytes;

See Also

FileSystemEventsSession Class | FileSystemEventsSession Members | Xceed.FileSystem Namespace


FileSystemEventsSession.m_currentItem Field

The current FileSystemItem object being processed for the current session.

[Visual Basic]
Protected m_currentItem As Xceed.FileSystem.FileSystemItem
[C#]
protected FileSystemItem m_currentItem;

See Also

FileSystemEventsSession Class | FileSystemEventsSession Members | Xceed.FileSystem Namespace


FileSystemEventsSession.m_events Field

An instance of the FileSystemEvents class representing the original FileSystemEvents object from which we created the session.

[Visual Basic]
Protected m_events As Xceed.FileSystem.FileSystemEvents
[C#]
protected FileSystemEvents m_events;

See Also

FileSystemEventsSession Class | FileSystemEventsSession Members | Xceed.FileSystem Namespace


FileSystemEventsSession.m_itemExceptionArgs Field

An instance of the ItemExceptionEventArgs class that provides information on the exception that was thrown during a process for the current session.

[Visual Basic]
Protected m_itemExceptionArgs As Xceed.FileSystem.ItemExceptionEventArgs
[C#]
protected ItemExceptionEventArgs m_itemExceptionArgs;

See Also

FileSystemEventsSession Class | FileSystemEventsSession Members | Xceed.FileSystem Namespace


FileSystemEventsSession.m_itemPairQueue Field

Represents a first-in, first-out collection of the items to process for the current session.

[Visual Basic]
Protected m_itemPairQueue As System.Collections.Queue
[C#]
protected Queue m_itemPairQueue;

See Also

FileSystemEventsSession Class | FileSystemEventsSession Members | Xceed.FileSystem Namespace


FileSystemEventsSession.m_itemProgressionArgs Field

An instance of the ItemProgressionEventArgs class that provides item progression information for the current session.

[Visual Basic]
Protected m_itemProgressionArgs As Xceed.FileSystem.ItemProgressionEventArgs
[C#]
protected ItemProgressionEventArgs m_itemProgressionArgs;

See Also

FileSystemEventsSession Class | FileSystemEventsSession Members | Xceed.FileSystem Namespace


FileSystemEventsSession.m_scanningFolderArgs Field

An instance of the ScanningFolderEventArgs class that provides information on the folder being scanned or accessed for the current session.

[Visual Basic]
Protected m_scanningFolderArgs As Xceed.FileSystem.ScanningFolderEventArgs
[C#]
protected ScanningFolderEventArgs m_scanningFolderArgs;

See Also

FileSystemEventsSession Class | FileSystemEventsSession Members | Xceed.FileSystem Namespace


FileSystemEventsSession.m_sender Field

The FileSystemItem object on which the process was called.

[Visual Basic]
Protected m_sender As Object
[C#]
protected object m_sender;

See Also

FileSystemEventsSession Class | FileSystemEventsSession Members | Xceed.FileSystem Namespace


FileSystemEventsSession.m_targetItem Field

The current target FileSystemItem object of the process for the current session.

[Visual Basic]
Protected m_targetItem As Xceed.FileSystem.FileSystemItem
[C#]
protected FileSystemItem m_targetItem;

See Also

FileSystemEventsSession Class | FileSystemEventsSession Members | Xceed.FileSystem Namespace


FileSystemEventsSession.m_userData Field

This is set at construction, and updated after each event. It is assigned to each argument structure before each event.

[Visual Basic]
Protected m_userData As Object
[C#]
protected object m_userData;

See Also

FileSystemEventsSession Class | FileSystemEventsSession Members | Xceed.FileSystem Namespace


FileSystemEventsSession Properties

The properties of the FileSystemEventsSession class are listed below. For a complete list of FileSystemEventsSession class members, see the FileSystemEventsSession Members topic.

Public Instance Properties

CurrentItem | Gets or sets the FileSystemItem object currently being processed.
Events | Gets the original FileSystemEvents object used to create the session.
IsEmpty | Gets a boolean value indicating if the session's list of FileSystemItem objects to process contains no items.
TargetItem | Gets or sets the eventual target FileSystemItem object for the process.
UserData | Gets the opaque data that is sent back to the event handler when an event is raised.

See Also

FileSystemEventsSession Class | Xceed.FileSystem Namespace


FileSystemEventsSession.CurrentItem Property

Gets or sets the FileSystemItem object currently being processed.

[Visual Basic]
Public Property CurrentItem As Xceed.FileSystem.FileSystemItem
[C#]
public FileSystemItem CurrentItem {get; set;}

Property Value

A reference to a FileSystemItem object.

See Also

FileSystemEventsSession Class | FileSystemEventsSession Members | Xceed.FileSystem Namespace


FileSystemEventsSession.Events Property

Gets the original FileSystemEvents object used to create the session.

[Visual Basic]
Overridable Public ReadOnly Property Events As Xceed.FileSystem.FileSystemEvents
[C#]
public FileSystemEvents Events {virtual get;}

Property Value

A reference to FileSystemEvents object.

See Also

FileSystemEventsSession Class | FileSystemEventsSession Members | Xceed.FileSystem Namespace


FileSystemEventsSession.IsEmpty Property

Gets a boolean value indicating if the session's list of FileSystemItem objects to process contains no items.

[Visual Basic]
Public ReadOnly Property IsEmpty As Boolean
[C#]
public bool IsEmpty {get;}

Property Value

true if the list is empty; false otherwise.

See Also

FileSystemEventsSession Class | FileSystemEventsSession Members | Xceed.FileSystem Namespace


FileSystemEventsSession.TargetItem Property

Gets or sets the eventual target FileSystemItem object for the process.

[Visual Basic]
Public Property TargetItem As Xceed.FileSystem.FileSystemItem
[C#]
public FileSystemItem TargetItem {get; set;}

Property Value

A reference to the eventual target FileSystemItem object.

See Also

FileSystemEventsSession Class | FileSystemEventsSession Members | Xceed.FileSystem Namespace


FileSystemEventsSession.UserData Property

Gets the opaque data that is sent back to the event handler when an event is raised.

[Visual Basic]
Public ReadOnly Property UserData As Object
[C#]
public object UserData {get;}

Property Value

Opaque data that is sent back to the event handler.

See Also

FileSystemEventsSession Class | FileSystemEventsSession Members | Xceed.FileSystem Namespace


FileSystemEventsSession Methods

The methods of the FileSystemEventsSession class are listed below. For a complete list of FileSystemEventsSession class members, see the FileSystemEventsSession Members topic.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetNextItemPair | Retrieves the next pair of FileSystemItem objects to be processed.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
OnBytesCompleted | Forces the byte progression to 100% completion.
OnBytesProcessed | Raises the ByteProgression event for a FileSystemItem object being processed.
OnCompletion | Raises the last ItemProgression event when the process is completed.
OnException | Raises the ItemException event whenever an error occurs during the processing of a FileSystemItem object.
OnNewItemToProcess | Places the new item in the list of FileSystemItem objects to be processed.
OnProcessingNewItem | Raised when a new item is about to be processed.
OnScanningFolder | Raised when a folder is scanned or accessed during the processing of FileSystemItem objects.
OnUndoBytesProcessed | Removes the amount of bytes processed for an item if an error occured during the processing of that item.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

FileSystemEventsSession Class | Xceed.FileSystem Namespace


FileSystemEventsSession.GetNextItemPair Method

Retrieves the next pair of FileSystemItem objects to be processed.

[Visual Basic]
Public Function GetNextItemPair( _
   ByVal raiseBytesProgression As Boolean _
) As Xceed.FileSystem.ItemPair
[C#]
public ItemPair GetNextItemPair(
   bool raiseBytesProgression
);

Parameters

raiseBytesProgression

A boolean value indicating if the ByteProgression event should be raised.

Return Value

An ItemPair object.

Remarks

A pair of FileSystemItem objects consisting of the current item being processed and it's eventual target or destination item.

See Also

FileSystemEventsSession Class | FileSystemEventsSession Members | Xceed.FileSystem Namespace


FileSystemEventsSession.OnBytesCompleted Method

Forces the byte progression to 100% completion.

[Visual Basic]
Public Sub OnBytesCompleted()
[C#]
public void OnBytesCompleted();

See Also

FileSystemEventsSession Class | FileSystemEventsSession Members | Xceed.FileSystem Namespace


FileSystemEventsSession.OnBytesProcessed Method

Raises the ByteProgression event for a FileSystemItem object being processed.

[Visual Basic]
Public Sub OnBytesProcessed( _
   ByVal increment As Long _
)
[C#]
public void OnBytesProcessed(
   long increment
);

Parameters

increment

The amount of bytes to be added to the total amount of bytes processed so far.

See Also

FileSystemEventsSession Class | FileSystemEventsSession Members | Xceed.FileSystem Namespace


FileSystemEventsSession.OnCompletion Method

Raises the last ItemProgression event when the process is completed.

[Visual Basic]
Public Sub OnCompletion()
[C#]
public void OnCompletion();

See Also

FileSystemEventsSession Class | FileSystemEventsSession Members | Xceed.FileSystem Namespace


FileSystemEventsSession.OnException Method

Raises the ItemException event whenever an error occurs during the processing of a FileSystemItem object.

[Visual Basic]
Public Function OnException( _
   ByVal except As System.Exception _
) As Boolean
[C#]
public bool OnException(
   Exception except
);

Parameters

except

The error that occured.

Return Value

true if we want to retry processing the item; false if the item should be ignored or the process aborted.

See Also

FileSystemEventsSession Class | FileSystemEventsSession Members | Xceed.FileSystem Namespace


FileSystemEventsSession.OnNewItemToProcess Method

Places the new item in the list of FileSystemItem objects to be processed.

[Visual Basic]
Public Sub OnNewItemToProcess( _
   ByVal currentItem As Xceed.FileSystem.FileSystemItem, _
   ByVal targetItem As Xceed.FileSystem.FileSystemItem _
)
[C#]
public void OnNewItemToProcess(
   FileSystemItem currentItem,
   FileSystemItem targetItem
);

Parameters

currentItem

The FileSystemItem object being processed.

targetItem

The eventual target FileSystemItem object being added to the list of items.

See Also

FileSystemEventsSession Class | FileSystemEventsSession Members | Xceed.FileSystem Namespace


FileSystemEventsSession.OnProcessingNewItem Method

Raised when a new item is about to be processed.

[Visual Basic]
Public Sub OnProcessingNewItem( _
   ByVal current As Xceed.FileSystem.FileSystemItem, _
   ByVal target As Xceed.FileSystem.FileSystemItem, _
   ByVal raiseBytesProgression As Boolean _
)
[C#]
public void OnProcessingNewItem(
   FileSystemItem current,
   FileSystemItem target,
   bool raiseBytesProgression
);

Parameters

current

The current FileSystemItem object being processed.

target

The eventual target FileSystemItem object for the process.

raiseBytesProgression

A boolean value indicating if we want bytes progression events to be raised.

See Also

FileSystemEventsSession Class | FileSystemEventsSession Members | Xceed.FileSystem Namespace


FileSystemEventsSession.OnScanningFolder Method

Raised when a folder is scanned or accessed during the processing of FileSystemItem objects.

[Visual Basic]
Public Sub OnScanningFolder( _
   ByVal currentFolder As Xceed.FileSystem.AbstractFolder _
)
[C#]
public void OnScanningFolder(
   AbstractFolder currentFolder
);

Parameters

currentFolder

The AbstractFolder object being scanned.

See Also

FileSystemEventsSession Class | FileSystemEventsSession Members | Xceed.FileSystem Namespace


FileSystemEventsSession.OnUndoBytesProcessed Method

Removes the amount of bytes processed for an item if an error occured during the processing of that item.

[Visual Basic]
Public Sub OnUndoBytesProcessed()
[C#]
public void OnUndoBytesProcessed();

See Also

FileSystemEventsSession Class | FileSystemEventsSession Members | Xceed.FileSystem Namespace


FileSystemException Class

Exception that is thrown when an error occurs in the Xceed.FileSystem namespace.

For a list of all members of this type, see FileSystemException Members.

System.Object
Exception
ApplicationException
FileSystemException

[Visual Basic]
Public Class FileSystemException
   Inherits ApplicationException
   Implements ISerializable
[C#]
public class FileSystemException : ApplicationException, ISerializable

Remarks

This exception serves as the base class for all custom exceptions defined in the Xceed.FileSystem namespace.

Specializations of the FileSystem object model also throw exceptions that derives from FileSystemException.

Requirements

Namespace: Xceed.FileSystem Namespace

Assembly: Xceed.FileSystem.dll

See Also

FileSystemException Members | Xceed.FileSystem Namespace


FileSystemException Members

Public Instance Constructors

FileSystemException Overloaded. Initialize a new instance of the FileSystemException class.

Public Instance Properties

HelpLink (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
InnerException (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
Item | Gets or sets the FileSystemItem object that caused the current exception.
Message | Gets a message that describes the current exception.
Source (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
StackTrace (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
TargetSite (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetBaseException (inherited from Exception) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetObjectData (inherited from Exception) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Exception) | Select the method name to go to the Microsoft documentation.

Protected Instance Properties

HResult (inherited from System.Exception) Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

FileSystemException Class | Xceed.FileSystem Namespace


FileSystemException Constructor

Xceed Zip for .NET

FileSystemException

Initializes a new instance of the exception with the specified message text.

Overload List

Initializes a new instance of the exception with the specified message text.

public FileSystemException(string);

Initializes a new instance of the exception with the specified message text and inner exception.

public FileSystemException(string,Exception);

Initializes a new instance of the exception with the specified message text and FileSystemItem object.

public FileSystemException(string,FileSystemItem);

Initializes a new instance of the exception with the specified message text, FileSystemItem object and inner exception.

public FileSystemException(string,FileSystemItem,Exception);

See Also

FileSystemException Class | FileSystemException Members | Xceed.FileSystem Namespace


FileSystemException Constructor (String)

Initializes a new instance of the exception with the specified message text.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public FileSystemException(
   string message
);

Parameters

message

The error message that explains the reason for the exception.

See Also

FileSystemException Class | FileSystemException Members | Xceed.FileSystem Namespace | FileSystemException Constructor Overload List


FileSystemException Constructor (String, Exception)

Initializes a new instance of the exception with the specified message text and inner exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal inner As System.Exception _
)
[C#]
public FileSystemException(
   string message,
   Exception inner
);

Parameters

message

The error message that explains the reason for the exception.

inner

The exception that initially caused the current exception to be thrown.

See Also

FileSystemException Class | FileSystemException Members | Xceed.FileSystem Namespace | FileSystemException Constructor Overload List


FileSystemException Constructor (String, FileSystemItem)

Initializes a new instance of the exception with the specified message text and FileSystemItem object.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal item As Xceed.FileSystem.FileSystemItem _
)
[C#]
public FileSystemException(
   string message,
   FileSystemItem item
);

Parameters

message

The error message that explains the reason for the exception.

item

The FileSystemItem object that caused the current exception.

See Also

FileSystemException Class | FileSystemException Members | Xceed.FileSystem Namespace | FileSystemException Constructor Overload List


FileSystemException Constructor (String, FileSystemItem, Exception)

Initializes a new instance of the exception with the specified message text, FileSystemItem object and inner exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal item As Xceed.FileSystem.FileSystemItem, _
   ByVal inner As System.Exception _
)
[C#]
public FileSystemException(
   string message,
   FileSystemItem item,
   Exception inner
);

Parameters

message

The error message that explains the reason for the exception.

item

The FileSystemItem object that caused the current exception.

inner

The exception that initially caused the current exception to be thrown.

See Also

FileSystemException Class | FileSystemException Members | Xceed.FileSystem Namespace | FileSystemException Constructor Overload List


FileSystemException Properties

The properties of the FileSystemException class are listed below. For a complete list of FileSystemException class members, see the FileSystemException Members topic.

Public Instance Properties

HelpLink (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
InnerException (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
Item | Gets or sets the FileSystemItem object that caused the current exception.
Message | Gets a message that describes the current exception.
Source (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
StackTrace (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
TargetSite (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.

Protected Instance Properties

HResult (inherited from System.Exception) Select the method name to go to the Microsoft documentation.

See Also

FileSystemException Class | Xceed.FileSystem Namespace


FileSystemException.Item Property

Gets or sets the FileSystemItem object that caused the current exception.

[Visual Basic]
Public Default Property Item() As Xceed.FileSystem.FileSystemItem
[C#]
public FileSystemItem this[

] {get; set;}

Property Value

The FileSystemItem object that caused the exception to be thrown. Can be null.

See Also

FileSystemException Class | FileSystemException Members | Xceed.FileSystem Namespace


FileSystemException.Message Property

Gets a message that describes the current exception.

[Visual Basic]
Overrides Public ReadOnly Property Message As String
[C#]
public string Message {override get;}

Property Value

A message that describes the current exception, or an empty string.

See Also

FileSystemException Class | FileSystemException Members | Xceed.FileSystem Namespace


FileSystemInternalException Class

Exception that is thrown when something unexpected occurs in the Xceed.FileSystem namespace.

For a list of all members of this type, see FileSystemInternalException Members.

System.Object
Exception
ApplicationException
FileSystemException
FileSystemInternalException

[Visual Basic]
Public Class FileSystemInternalException
   Inherits FileSystemException
   Implements ISerializable
[C#]
public class FileSystemInternalException : FileSystemException, ISerializable

Remarks

This exception means that there was an internal failure in the library, and that nothing could be done to prevent it. Such failures should never occur.

To get more details about what went wrong, you can inspect the System.Exception.InnerException property. It is a reference to the exception that caused the internal failure.

If you ever catch this exception in your code, please contact Xceed Software Technical Support immediately.

Requirements

Namespace: Xceed.FileSystem Namespace

Assembly: Xceed.FileSystem.dll

See Also

FileSystemInternalException Members | Xceed.FileSystem Namespace


FileSystemInternalException Members

Public Instance Constructors

FileSystemInternalException Overloaded. Initialize a new instance of the FileSystemInternalException class.

Public Instance Properties

HelpLink (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
InnerException (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
Item (inherited from FileSystemException) | Gets or sets the FileSystemItem object that caused the current exception.
Message (inherited from FileSystemException) | Gets a message that describes the current exception.
Source (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
StackTrace (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
TargetSite (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetBaseException (inherited from Exception) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetObjectData (inherited from Exception) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Exception) | Select the method name to go to the Microsoft documentation.

Protected Instance Properties

HResult (inherited from System.Exception) Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

FileSystemInternalException Class | Xceed.FileSystem Namespace


FileSystemInternalException Constructor

Xceed Zip for .NET

FileSystemInternalException

Initializes a new instance of the exception.

Overload List

Initializes a new instance of the exception.

public FileSystemInternalException();

Initializes a new instance of the exception with the specified FileSystemItem object.

public FileSystemInternalException(FileSystemItem);

Initializes a new instance of the exception with the specified message text.

public FileSystemInternalException(string);

Initializes a new instance of the exception with the specified message text and FileSystemItem object.

public FileSystemInternalException(string,FileSystemItem);

Initializes a new instance of the exception with the specified inner exception.

public FileSystemInternalException(Exception);

Initializes a new instance of the exception with the specified FileSystemItem object and inner exception.

public FileSystemInternalException(FileSystemItem,Exception);

Initializes a new instance of the exception with the specified message text and inner exception.

public FileSystemInternalException(string,Exception);

Initializes a new instance of the exception with the specified message text, FileSystemItem object and inner exception.

public FileSystemInternalException(string,FileSystemItem,Exception);

See Also

FileSystemInternalException Class | FileSystemInternalException Members | Xceed.FileSystem Namespace


FileSystemInternalException Constructor ()

Initializes a new instance of the exception.

[Visual Basic]
Overloads Public Sub New()
[C#]
public FileSystemInternalException();

See Also

FileSystemInternalException Class | FileSystemInternalException Members | Xceed.FileSystem Namespace | FileSystemInternalException Constructor Overload List


FileSystemInternalException Constructor (FileSystemItem)

Initializes a new instance of the exception with the specified FileSystemItem object.

[Visual Basic]
Overloads Public Sub New( _
   ByVal item As Xceed.FileSystem.FileSystemItem _
)
[C#]
public FileSystemInternalException(
   FileSystemItem item
);

Parameters

item

The FileSystemItem object that caused the current exception.

See Also

FileSystemInternalException Class | FileSystemInternalException Members | Xceed.FileSystem Namespace | FileSystemInternalException Constructor Overload List


FileSystemInternalException Constructor (String)

Initializes a new instance of the exception with the specified message text.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public FileSystemInternalException(
   string message
);

Parameters

message

The error message that explains the reason for the exception.

See Also

FileSystemInternalException Class | FileSystemInternalException Members | Xceed.FileSystem Namespace | FileSystemInternalException Constructor Overload List


FileSystemInternalException Constructor (String, FileSystemItem)

Initializes a new instance of the exception with the specified message text and FileSystemItem object.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal item As Xceed.FileSystem.FileSystemItem _
)
[C#]
public FileSystemInternalException(
   string message,
   FileSystemItem item
);

Parameters

message

The error message that explains the reason for the exception.

item

The FileSystemItem object that caused the current exception.

See Also

FileSystemInternalException Class | FileSystemInternalException Members | Xceed.FileSystem Namespace | FileSystemInternalException Constructor Overload List


FileSystemInternalException Constructor (Exception)

Initializes a new instance of the exception with the specified inner exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal inner As System.Exception _
)
[C#]
public FileSystemInternalException(
   Exception inner
);

Parameters

inner

The exception that initially caused the current exception to be thrown.

See Also

FileSystemInternalException Class | FileSystemInternalException Members | Xceed.FileSystem Namespace | FileSystemInternalException Constructor Overload List


FileSystemInternalException Constructor (FileSystemItem, Exception)

Initializes a new instance of the exception with the specified FileSystemItem object and inner exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal item As Xceed.FileSystem.FileSystemItem, _
   ByVal inner As System.Exception _
)
[C#]
public FileSystemInternalException(
   FileSystemItem item,
   Exception inner
);

Parameters

item

The FileSystemItem object that caused the current exception.

inner

The exception that initially caused the current exception to be thrown.

See Also

FileSystemInternalException Class | FileSystemInternalException Members | Xceed.FileSystem Namespace | FileSystemInternalException Constructor Overload List


FileSystemInternalException Constructor (String, Exception)

Initializes a new instance of the exception with the specified message text and inner exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal inner As System.Exception _
)
[C#]
public FileSystemInternalException(
   string message,
   Exception inner
);

Parameters

message

The error message that explains the reason for the exception.

inner

The exception that initially caused the current exception to be thrown.

See Also

FileSystemInternalException Class | FileSystemInternalException Members | Xceed.FileSystem Namespace | FileSystemInternalException Constructor Overload List


FileSystemInternalException Constructor (String, FileSystemItem, Exception)

Initializes a new instance of the exception with the specified message text, FileSystemItem object and inner exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal item As Xceed.FileSystem.FileSystemItem, _
   ByVal inner As System.Exception _
)
[C#]
public FileSystemInternalException(
   string message,
   FileSystemItem item,
   Exception inner
);

Parameters

message

The error message that explains the reason for the exception.

item

The FileSystemItem object that caused the current exception.

inner

The exception that initially caused the current exception to be thrown.

See Also

FileSystemInternalException Class | FileSystemInternalException Members | Xceed.FileSystem Namespace | FileSystemInternalException Constructor Overload List


FileSystemIOException Class

Exception that is thrown when an IO error occurs while reading from or writing to an AbstractFile object.

For a list of all members of this type, see FileSystemIOException Members.

System.Object
Exception
ApplicationException
FileSystemException
FileSystemIOException

[Visual Basic]
Public Class FileSystemIOException
   Inherits FileSystemException
   Implements ISerializable
[C#]
public class FileSystemIOException : FileSystemException, ISerializable

Remarks

A System.IO.IOException will almost always be available in the System.Exception.InnerException property of this exception. This is the IO exception that caused the FileSystemIOException to be thrown.

Requirements

Namespace: Xceed.FileSystem Namespace

Assembly: Xceed.FileSystem.dll

See Also

FileSystemIOException Members | Xceed.FileSystem Namespace


FileSystemIOException Members

Public Instance Constructors

FileSystemIOException Overloaded. Initialize a new instance of the FileSystemIOException class.

Public Instance Properties

HelpLink (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
InnerException (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
Item (inherited from FileSystemException) | Gets or sets the FileSystemItem object that caused the current exception.
Message (inherited from FileSystemException) | Gets a message that describes the current exception.
Source (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
StackTrace (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
TargetSite (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetBaseException (inherited from Exception) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetObjectData (inherited from Exception) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Exception) | Select the method name to go to the Microsoft documentation.

Protected Instance Properties

HResult (inherited from System.Exception) Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

FileSystemIOException Class | Xceed.FileSystem Namespace


FileSystemIOException Constructor

Xceed Zip for .NET

FileSystemIOException

Initializes a new instance of the exception with the specified FileSystemItem object and inner exception.

Overload List

Initializes a new instance of the exception with the specified FileSystemItem object and inner exception.

public FileSystemIOException(FileSystemItem,Exception);

Initializes a new instance of the exception with the specified message text, FileSystemItem object and inner exception.

public FileSystemIOException(string,FileSystemItem,Exception);

See Also

FileSystemIOException Class | FileSystemIOException Members | Xceed.FileSystem Namespace


FileSystemIOException Constructor (FileSystemItem, Exception)

Initializes a new instance of the exception with the specified FileSystemItem object and inner exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal item As Xceed.FileSystem.FileSystemItem, _
   ByVal inner As System.Exception _
)
[C#]
public FileSystemIOException(
   FileSystemItem item,
   Exception inner
);

Parameters

item

The FileSystemItem object that caused the current exception.

inner

The exception that initially caused the current exception to be thrown.

See Also

FileSystemIOException Class | FileSystemIOException Members | Xceed.FileSystem Namespace | FileSystemIOException Constructor Overload List


FileSystemIOException Constructor (String, FileSystemItem, Exception)

Initializes a new instance of the exception with the specified message text, FileSystemItem object and inner exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal item As Xceed.FileSystem.FileSystemItem, _
   ByVal inner As System.Exception _
)
[C#]
public FileSystemIOException(
   string message,
   FileSystemItem item,
   Exception inner
);

Parameters

message

The error message that explains the reason for the exception.

item

The FileSystemItem object that caused the current exception.

inner

The exception that initially caused the current exception to be thrown.

See Also

FileSystemIOException Class | FileSystemIOException Members | Xceed.FileSystem Namespace | FileSystemIOException Constructor Overload List


FileSystemItem Class

Root class for all types of items that can exist in a generic (abstract) folder. For example, a file and a folder.

For a list of all members of this type, see FileSystemItem Members.

System.Object
MarshalByRefObject
FileSystemItem

[Visual Basic]
MustInherit Public Class FileSystemItem
   Inherits MarshalByRefObject
[C#]
public abstract class FileSystemItem : MarshalByRefObject

Requirements

Namespace: Xceed.FileSystem Namespace

Assembly: Xceed.FileSystem.dll

See Also

FileSystemItem Members | Xceed.FileSystem Namespace


FileSystemItem Members

Public Instance Constructors

FileSystemItem Constructor Initializes a new instance of the FileSystemItem class.

Public Instance Properties

Attributes | Gets or sets the attributes of the item.
CreationDateTime | Gets or sets the creation date and time of the item.
Exists | Gets a boolean value indicating if the item physically exists.
FullName | Gets the full name of the item.
LastAccessDateTime | Gets or sets the last access date and time of the item.
LastWriteDateTime | Gets or sets the modification date and time of the item.
Name | Gets or sets the short name of the item.
ParentFolder | Gets a reference to the parent folder of this item.
RootFolder | Gets a reference to the root folder of this item.

Public Instance Methods

ApplyPropertiesTo | Overloaded. Copies the item's properties to another item.
CopyTo | Overloaded. Copies the item, or it's content to the destination.
Create | Overloaded. Creates the physical item represented by the object.
CreateObjRef (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Delete | Overloaded. Permanently deletes the physical item.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
InitializeLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
MoveTo | Overloaded. Moves the item, or it's content to the destination.
Refresh | Overloaded. Re-reads the information from the physical item.
ToString | Returns the full name of the item.

Protected Instance Properties

DoAttributes | Gets or sets the attributes of the item. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoCreationDateTime | Gets or sets the creation date and time of the item. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoExists | Gets a boolean value indicating if the item physically exists. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoFullName | Gets the full name of the item. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoLastAccessDateTime | Gets or sets the last access date and time of the item. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoLastWriteDateTime | Gets or sets the modification date and time of the item. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoName | Gets or sets the short name of the item. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoParentFolder | Gets a reference to the parent folder of this item. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoRootFolder | Gets a reference to the root folder of this item. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.
InvalidChars | Gets the characters that are invalid in file and folder names.

Protected Instance Methods

BuildListForCreate | Handles the special cases in regards to building the list of items to process when creating a FileSystemItem object.
DoApplyPropertiesTo | Copies the item's properties to another item. This method must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoCopyTo | Copies the item to another folder. This method must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoRefresh | Re-reads the information from the physical item. This method must be overridden when deriving from the AbstractFolder or AbstractFile classes.
EnsureDateIsValid | Ensures that the System.DateTime value is valid.
Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsPathRooted | Returns a boolean value indicating if the path passed is rooted in the environment of the FileSystemItem object we are dealing with. This method must be overridden when deriving from the AbstractFolder or AbstractFile classes.
IsSameAs | Gets a boolean value indicating if the source and target items are the same. This method must be overridden when deriving from the AbstractFolder or AbstractFile classes.
ListCopyTo | Copies each item in the FileSystemEventsSession object's list to each item's destination.
ListCreate | Creates each item in the FileSystemEventsSession object's list.
ListDelete | Deletes each item in the FileSystemEventsSession object's list.
ListMoveTo | Moves each item in the FileSystemEventsSession object's list to each item's destination.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Internal Instance Methods

BuildList | Builds a list of FileSystemItem objects to process.
DoCreate | Creates the physical item represented by the FileSystemItem object. This method must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoDelete | Permanently deletes the physical item. This method must be overridden when deriving from the AbstractFolder or AbstractFile classes.

See Also

FileSystemItem Class | Xceed.FileSystem Namespace


FileSystemItem Constructor

Initializes a new instance of the FileSystemItem class.

[Visual Basic]
Public Sub New()
[C#]
public FileSystemItem();

See Also

FileSystemItem Class | FileSystemItem Members | Xceed.FileSystem Namespace


FileSystemItem Properties

The properties of the FileSystemItem class are listed below. For a complete list of FileSystemItem class members, see the FileSystemItem Members topic.

Public Instance Properties

Attributes | Gets or sets the attributes of the item.
CreationDateTime | Gets or sets the creation date and time of the item.
Exists | Gets a boolean value indicating if the item physically exists.
FullName | Gets the full name of the item.
LastAccessDateTime | Gets or sets the last access date and time of the item.
LastWriteDateTime | Gets or sets the modification date and time of the item.
Name | Gets or sets the short name of the item.
ParentFolder | Gets a reference to the parent folder of this item.
RootFolder | Gets a reference to the root folder of this item.

Protected Instance Properties

DoAttributes | Gets or sets the attributes of the item. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoCreationDateTime | Gets or sets the creation date and time of the item. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoExists | Gets a boolean value indicating if the item physically exists. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoFullName | Gets the full name of the item. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoLastAccessDateTime | Gets or sets the last access date and time of the item. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoLastWriteDateTime | Gets or sets the modification date and time of the item. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoName | Gets or sets the short name of the item. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoParentFolder | Gets a reference to the parent folder of this item. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoRootFolder | Gets a reference to the root folder of this item. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.
InvalidChars | Gets the characters that are invalid in file and folder names.

See Also

FileSystemItem Class | Xceed.FileSystem Namespace


FileSystemItem.Attributes Property

Gets or sets the attributes of the item.

[Visual Basic]
Public Property Attributes As System.IO.FileAttributes
[C#]
public System.IO.FileAttributes Attributes {get; set;}

Property Value

A combination of System.IO.FileAttributes values that represents the attributes of the item.

Remarks

When changing the item's attributes through this property, the physical item is immediately modified if it exists. If it does not exist, the attributes are cached and will be applied whenever this item is created.

Some types of items may not expose attributes. In this case, an exception is thrown when trying to read or modify the attributes.

Note: Refresh should be called before accessing this property, or the information returned could be outdated.

Exceptions

Exception Type | Condition
Xceed.FileSystem.FileSystemNotSupportedException | The item does not expose attributes, or does not support one of the assigned attributes.
Xceed.FileSystem.ItemIsRootFolderException | The physical item is a root folder.

See Also

FileSystemItem Class | FileSystemItem Members | Xceed.FileSystem Namespace


FileSystemItem.CreationDateTime Property

Gets or sets the creation date and time of the item.

[Visual Basic]
Public Property CreationDateTime As Date
[C#]
public System.DateTime CreationDateTime {get; set;}

Property Value

The date and time when the item was created.

Remarks

When changing the item's creation date through this property, the physical item is immediately modified if it exists. If it does not exist, the date is cached and will be applied whenever this item is created.

Some types of items may not expose a creation date and time. In this case, an exception is thrown when trying to read or modify the creation date.

Other types of items that do expose a creation date and time may not have the information available. In this case, System.DateTime.MinValue is returned.

Note: Refresh should be called before accessing this property, or the information returned could be outdated.

Exceptions

Exception Type | Condition
System.ArgumentException | The provided creation date is not valid for this item.
Xceed.FileSystem.FileSystemNotSupportedException | The item does not expose a creation date.
Xceed.FileSystem.ItemIsReadOnlyException | The item has the ReadOnly attribute, preventing it from being modified.
Xceed.FileSystem.ItemIsRootFolderException | The item is a root folder.

See Also

FileSystemItem Class | FileSystemItem Members | Xceed.FileSystem Namespace


FileSystemItem.DoAttributes Property

Gets or sets the attributes of the item. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.

[Visual Basic]
MustOverride Protected Property DoAttributes As System.IO.FileAttributes
[C#]
protected System.IO.FileAttributes DoAttributes {abstract get; abstract set;}

Property Value

A combination of System.IO.FileAttributes values that represents the attributes of the item.

Remarks

When changing the item's attributes through this property, the physical item should be immediately modified if it exists. If it does not exist, the attributes should be cached and applied whenever this item is created.

Some types of items may not expose attributes. In this case, an exception should be thrown when trying to read or modify the attributes.

Note: Refresh should be called before accessing this property, or the information returned could be outdated.

See Also

FileSystemItem Class | FileSystemItem Members | Xceed.FileSystem Namespace


FileSystemItem.DoCreationDateTime Property

Gets or sets the creation date and time of the item. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.

[Visual Basic]
MustOverride Protected Property DoCreationDateTime As Date
[C#]
protected System.DateTime DoCreationDateTime {abstract get; abstract set;}

Property Value

The date and time when the item was created.

Remarks

When changing the item's creation date through this property, the physical item should be immediately modified if it exists. If it does not exist, the date should be cached and applied whenever this item is created.

Some types of items may not expose a creation date and time. In this case, an exception should be thrown when trying to read or modify the creation date.

Other types of items that do expose a creation date and time may not have the information available. In this case, System.DateTime.MinValue should be returned.

Note: Refresh should be called before accessing this property, or the information returned could be outdated.

See Also

FileSystemItem Class | FileSystemItem Members | Xceed.FileSystem Namespace


FileSystemItem.DoExists Property

Gets a boolean value indicating if the item physically exists. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.

[Visual Basic]
MustOverride Protected ReadOnly Property DoExists As Boolean
[C#]
protected bool DoExists {abstract get;}

Property Value

true if the item physically exists; false otherwise.

Remarks

This property should be evaluated before calling a method that needs to access the underlying physical item, otherwise an exception should be raised from the method.

Note: Refresh does not need to be called before accessing this property. The property should always reflect the physical item's existence.

See Also

FileSystemItem Class | FileSystemItem Members | Xceed.FileSystem Namespace


FileSystemItem.DoFullName Property

Gets the full name of the item. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.

[Visual Basic]
MustOverride Protected ReadOnly Property DoFullName As String
[C#]
protected string DoFullName {abstract get;}

Property Value

A string that represents the full name of the item.

Remarks

The full name should consist of the item's name fully-qualified with a path. For example: "c:\foo\bar.txt", "c:\foo\".

If the item represents a file, its name should not end with a path separator character.

If the item represents a folder, its name should end with a path separator character.

See Also

FileSystemItem Class | FileSystemItem Members | Xceed.FileSystem Namespace


FileSystemItem.DoLastAccessDateTime Property

Gets or sets the last access date and time of the item. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.

[Visual Basic]
MustOverride Protected Property DoLastAccessDateTime As Date
[C#]
protected System.DateTime DoLastAccessDateTime {abstract get; abstract set;}

Property Value

The date and time when the item was last accessed.

Remarks

When changing the item's access date through this property, the physical item should be immediately modified if it exists. If it does not exist, the date should be cached and applied whenever this item is created.

Some types of items may not expose a last access date and time. In this case, an exception should be thrown when trying to read or modify the access date.

Other types of items that do expose a last access date and time may not have the information available. In this case, System.DateTime.MinValue should be returned.

Note: Refresh should be called before accessing this property, or the information returned could be outdated.

See Also

FileSystemItem Class | FileSystemItem Members | Xceed.FileSystem Namespace


FileSystemItem.DoLastWriteDateTime Property

Gets or sets the modification date and time of the item. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.

[Visual Basic]
MustOverride Protected Property DoLastWriteDateTime As Date
[C#]
protected System.DateTime DoLastWriteDateTime {abstract get; abstract set;}

Property Value

The date and time when the item was modified.

Remarks

When changing the item's modification date through this property, the physical item should be immediately modified if it exists. If it does not exist, the date should be cached and applied whenever this item is created.

Some types of items may not expose a modification date and time. In this case, an exception should be thrown when trying to read or modify the modification date.

Other types of items that do expose a modification date and time may not have the information available. In this case, System.DateTime.MinValue should be returned.

Note: Refresh should be called before accessing this property, or the information returned could be outdated.

See Also

FileSystemItem Class | FileSystemItem Members | Xceed.FileSystem Namespace


FileSystemItem.DoName Property

Gets or sets the short name of the item. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.

[Visual Basic]
MustOverride Protected Property DoName As String
[C#]
protected string DoName {abstract get; abstract set;}

Property Value

A string that represents the short name of the item.

Remarks

When assigning a new name to this property, the physical item should be immediately renamed if it exists. If it does not exist, the new name should be cached and applied whenever this item is created. In either cases, if a physical item with the same name already exists, an exception should be thrown.

The short name of an item should not end with a path separator character regardless of whether it represents a file or a folder.

See Also

FileSystemItem Class | FileSystemItem Members | Xceed.FileSystem Namespace


FileSystemItem.DoParentFolder Property

Gets a reference to the parent folder of this item. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.

[Visual Basic]
MustOverride Protected ReadOnly Property DoParentFolder As Xceed.FileSystem.AbstractFolder
[C#]
protected AbstractFolder DoParentFolder {abstract get;}

Property Value

An AbstractFolder object that represents the folder that contains the item, or a null reference (Nothing in Visual Basic) if the item does not have a parent.

Remarks

If the current item is the root of a folder hierarchy, it has no parent folder. In this case, the ParentFolder property should return a null reference (Nothing in Visual Basic).

See Also

FileSystemItem Class | FileSystemItem Members | Xceed.FileSystem Namespace


FileSystemItem.DoRootFolder Property

Gets a reference to the root folder of this item. This property must be overridden when deriving from the AbstractFolder or AbstractFile classes.

[Visual Basic]
MustOverride Protected ReadOnly Property DoRootFolder As Xceed.FileSystem.AbstractFolder
[C#]
protected AbstractFolder DoRootFolder {abstract get;}

Property Value

An AbstractFolder object that represents the folder at the root of the path of this item, or a null reference (Nothing in Visual Basic) if a root folder is not available.

Remarks

A root folder should represent the starting point of a folder hierarchy. On a physical disk, it is usually represented by a drive letter ("C:\") or UNC root ("\\server\share\").

If the current item is the root of a folder hierarchy, the RootFolder property should return a reference to itself.

If a root folder is not available, the RootFolder property should return a null reference (Nothing in Visual Basic).

See Also

FileSystemItem Class | FileSystemItem Members | Xceed.FileSystem Namespace


FileSystemItem.Exists Property

Gets a boolean value indicating if the item physically exists.

[Visual Basic]
Public ReadOnly Property Exists As Boolean
[C#]
public bool Exists {get;}

Property Value

true if the item physically exists; false otherwise.

Remarks

This property should be evaluated before calling a method that needs to access the underlying physical item (For example, CopyTo), otherwise these methods will throw an exception.

Note: Refresh does not need to be called before accessing this property. The property will always reflect the physical item's existence.

See Also

FileSystemItem Class | FileSystemItem Members | Xceed.FileSystem Namespace


FileSystemItem.FullName Property

Gets the full name of the item.

[Visual Basic]
Public ReadOnly Property FullName As String
[C#]
public string FullName {get;}

Property Value

A string that represents the full name of the item.

Remarks

The full name consists of the item's name fully-qualified with a path. For example: "c:\foo\bar.txt", "c:\foo\".

If the item represents a file, its name does not end with a path separator character.

If the item represents a folder, its name does end with a path separator character.

The separator character is defined in System.IO.Path.DirectorySeparatorChar and System.IO.Path.AltDirectorySeparatorChar.

See Also

FileSystemItem Class | FileSystemItem Members | Xceed.FileSystem Namespace


FileSystemItem.InvalidChars Property

Gets the characters that are invalid in file and folder names.

[Visual Basic]
Overridable Protected ReadOnly Property InvalidChars As Char()
[C#]
protected char[] InvalidChars {virtual get;}

Property Value

An array of characters containing the characters that are invalid in file and folder names.

See Also

FileSystemItem Class | FileSystemItem Members | Xceed.FileSystem Namespace


FileSystemItem.LastAccessDateTime Property

Gets or sets the last access date and time of the item.

[Visual Basic]
Public Property LastAccessDateTime As Date
[C#]
public System.DateTime LastAccessDateTime {get; set;}

Property Value

The date and time when the item was last accessed.

Remarks

When changing the item's access date through this property, the physical item is immediately modified if it exists. If it does not exist, the date is cached and will be applied whenever this item is created.

Some types of items may not expose a last access date and time. In this case, an exception is thrown when trying to read or modify the access date.

Other types of items that do expose a last access date and time may not have the information available. In this case, System.DateTime.MinValue is returned.

Note: Refresh should be called before accessing this property, or the information returned could be outdated.

Exceptions

Exception Type | Condition
System.ArgumentException | The provided last access date is not valid for this item.
Xceed.FileSystem.FileSystemNotSupportedException | The item does not expose a last access date.
Xceed.FileSystem.ItemIsReadOnlyException | The item has the ReadOnly attribute, preventing it from being modified.
Xceed.FileSystem.ItemIsRootFolderException | The physical item is a root folder.

See Also

FileSystemItem Class | FileSystemItem Members | Xceed.FileSystem Namespace


FileSystemItem.LastWriteDateTime Property

Gets or sets the modification date and time of the item.

[Visual Basic]
Public Property LastWriteDateTime As Date
[C#]
public System.DateTime LastWriteDateTime {get; set;}

Property Value

The date and time when the item was modified.

Remarks

When changing the item's modification date through this property, the physical item is immediately modified if it exists. If it does not exist, the date is cached and will be applied whenever this item is created.

Some types of items may not expose a modification date and time. In this case, an exception is thrown when trying to read or modify the modification date.

Other types of items that do expose a modification date and time may not have the information available. In this case, System.DateTime.MinValue is returned.

Note: Refresh should be called before accessing this property, or the information returned could be outdated.

Exceptions

Exception Type | Condition
System.ArgumentException | The provided modification date is not valid for this item.
Xceed.FileSystem.FileSystemNotSupportedException | The item does not expose a modification date.
Xceed.FileSystem.ItemIsReadOnlyException | The item has the ReadOnly attribute, preventing it from being modified.
Xceed.FileSystem.ItemIsRootFolderException | The item is a root folder.

See Also

FileSystemItem Class | FileSystemItem Members | Xceed.FileSystem Namespace


FileSystemItem.Name Property

Gets or sets the short name of the item.

[Visual Basic]
Public Property Name As String
[C#]
public string Name {get; set;}

Property Value

A string that represents the short name of the item.

Remarks

The short name consists of the item's name without a path.

For example, the short name of a file named "c:\foo\bar.txt" is "bar.txt", and the short name of a folder named "c:\foo\" is "foo".

When assigning a new name to this property, the physical item is immediately renamed if it exists. If it does not exist, the new name is cached and will be applied whenever this item is created. In either cases, if a physical item with the same name already exists, an exception is thrown.

The short name of an item must not end with a path separator character regardless of whether it represents a file or a folder.

The separator character is defined in System.IO.Path.DirectorySeparatorChar and System.IO.Path.AltDirectorySeparatorChar.

Exceptions

Exception Type | Condition
System.ArgumentException | The new name assigned to the item is an empty string, contains only white space, contains a path, or contains invalid characters as defined in InvalidChars.
Xceed.FileSystem.ItemAlreadyExistsException | The new name corresponds to a physical item that already exists.
Xceed.FileSystem.ItemIsRootFolderException | The item is a root folder.

See Also

FileSystemItem Class | FileSystemItem Members | Xceed.FileSystem Namespace


FileSystemItem.ParentFolder Property

Gets a reference to the parent folder of this item.

[Visual Basic]
Public ReadOnly Property ParentFolder As Xceed.FileSystem.AbstractFolder
[C#]
public AbstractFolder ParentFolder {get;}

Property Value

An AbstractFolder object that represents the folder that contains the item, or a null reference (Nothing in Visual Basic) if the item does not have a parent.

Remarks

If the current item is the root of a folder hierarchy, it has no parent folder. In this case, the ParentFolder property returns a null reference (Nothing in Visual Basic).

See Also

FileSystemItem Class | FileSystemItem Members | Xceed.FileSystem Namespace


FileSystemItem.RootFolder Property

Gets a reference to the root folder of this item.

[Visual Basic]
Public ReadOnly Property RootFolder As Xceed.FileSystem.AbstractFolder
[C#]
public AbstractFolder RootFolder {get;}

Property Value

An AbstractFolder object that represents the folder at the root of the path of this item, or a null reference (Nothing in Visual Basic) if a root folder is not available.

Remarks

A root folder represents the starting point of a folder hierarchy. On a physical disk, it is usually represented by a drive letter ("C:\") or UNC root ("\\server\share\").

Some specializations of the AbstractFolder class may define a specialized class that represents a root folder, exposing properties and methods that apply only to a root.

Therefore, the RootFolder property may return an AbstractFolder instance that is in fact a specialized class representing the root.

If the current item is the root of a folder hierarchy, the RootFolder property returns a reference to itself, or a reference to a specialized object that represents the root folder with more details.

If a root folder is not available, the RootFolder property returns a null reference (Nothing in Visual Basic).

See Also

FileSystemItem Class | FileSystemItem Members | Xceed.FileSystem Namespace


FileSystemItem Methods

The methods of the FileSystemItem class are listed below. For a complete list of FileSystemItem class members, see the FileSystemItem Members topic.

Public Instance Methods

ApplyPropertiesTo | Overloaded. Copies the item's properties to another item.
CopyTo | Overloaded. Copies the item, or it's content to the destination.
Create | Overloaded. Creates the physical item represented by the object.
CreateObjRef (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Delete | Overloaded. Permanently deletes the physical item.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
InitializeLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
MoveTo | Overloaded. Moves the item, or it's content to the destination.
Refresh | Overloaded. Re-reads the information from the physical item.
ToString | Returns the full name of the item.

Protected Instance Methods

BuildListForCreate | Handles the special cases in regards to building the list of items to process when creating a FileSystemItem object.
DoApplyPropertiesTo | Copies the item's properties to another item. This method must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoCopyTo | Copies the item to another folder. This method must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoRefresh | Re-reads the information from the physical item. This method must be overridden when deriving from the AbstractFolder or AbstractFile classes.
EnsureDateIsValid | Ensures that the System.DateTime value is valid.
Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsPathRooted | Returns a boolean value indicating if the path passed is rooted in the environment of the FileSystemItem object we are dealing with. This method must be overridden when deriving from the AbstractFolder or AbstractFile classes.
IsSameAs | Gets a boolean value indicating if the source and target items are the same. This method must be overridden when deriving from the AbstractFolder or AbstractFile classes.
ListCopyTo | Copies each item in the FileSystemEventsSession object's list to each item's destination.
ListCreate | Creates each item in the FileSystemEventsSession object's list.
ListDelete | Deletes each item in the FileSystemEventsSession object's list.
ListMoveTo | Moves each item in the FileSystemEventsSession object's list to each item's destination.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Internal Instance Methods

BuildList | Builds a list of FileSystemItem objects to process.
DoCreate | Creates the physical item represented by the FileSystemItem object. This method must be overridden when deriving from the AbstractFolder or AbstractFile classes.
DoDelete | Permanently deletes the physical item. This method must be overridden when deriving from the AbstractFolder or AbstractFile classes.

See Also

FileSystemItem Class | Xceed.FileSystem Namespace


ApplyPropertiesTo Method

Xceed Zip for .NET

FileSystemItem.ApplyPropertiesTo

Copies the item's properties to another item and raises events during the process.

Overload List

Copies the item's properties to another item.

public void ApplyPropertiesTo(FileSystemItem);

Copies the item's properties to another item and raises events during the process.

public void ApplyPropertiesTo(FileSystemEvents,object,FileSystemItem);

See Also

FileSystemItem Class | FileSystemItem Members | Xceed.FileSystem Namespace


FileSystemItem.ApplyPropertiesTo Method (FileSystemEvents, Object, FileSystemItem)

Copies the item's properties to another item and raises events during the process.

[Visual Basic]
Overloads Public Sub ApplyPropertiesTo( _
   ByVal events As Xceed.FileSystem.FileSystemEvents, _
   ByVal userData As Object, _
   ByVal targetItem As Xceed.FileSystem.FileSystemItem _
)
[C#]
public void ApplyPropertiesTo(
   FileSystemEvents events,
   object userData,
   FileSystemItem targetItem
);

Parameters

events

A FileSystemEvents object that will be used to raise events. Cannot be a null reference (Nothing in Visual Basic).

userData

Opaque data that will be passed back to the event handler when an event is raised.

targetItem

A FileSystemItem object to which the current item's properties must be copied. Cannot be a null reference (Nothing in Visual Basic).

Remarks

If the current item does not exist, its cached properties are copied to the destination. If it does exist, its physical properties are copied.

If the target item does not exist, it caches the values of the properties. If it does exist, its physical properties are changed immediately.

This method only copies the properties that are supported by the source and target items. No exception will be thrown if one of the items does not support one of the copied properties.

Note: Refresh does not need to be called before calling this method. This method will always copy the up-to-date property values to the target item.

See Also

FileSystemItem Class | FileSystemItem Members | Xceed.FileSystem Namespace | FileSystemItem.ApplyPropertiesTo Overload List


FileSystemItem.ApplyPropertiesTo Method (FileSystemItem)

Copies the item's properties to another item.

[Visual Basic]
Overloads Public Sub ApplyPropertiesTo( _
   ByVal targetItem As Xceed.FileSystem.FileSystemItem _
)
[C#]
public void ApplyPropertiesTo(
   FileSystemItem targetItem
);

Parameters

targetItem

A FileSystemItem object to which the current item's properties must be copied. Cannot be a null reference (Nothing in Visual Basic).

Remarks

If the current item does not exist, its cached properties are copied to the destination. If it does exist, its physical properties are copied.

If the target item does not exist, it caches the values of the properties. If it does exist, its physical properties are changed immediately.

This method only copies the properties that are supported by the source and target items. No exception will be thrown if one of the items does not support one of the copied properties.

Note: Refresh does not need to be called before calling this method. This method will always copy the up-to-date property values to the target item.

Exceptions

Exception Type | Condition
Xceed.FileSystem.ItemIsReadOnlyException | The target item has the ReadOnly attribute, preventing it from being modified.

See Also

FileSystemItem Class | FileSystemItem Members | Xceed.FileSystem Namespace | FileSystemItem.ApplyPropertiesTo Overload List


FileSystemItem.BuildList Method

Builds a list of FileSystemItem objects to process.

[Visual Basic]
MustOverride Protected Friend Sub BuildList( _
   ByVal session As Xceed.FileSystem.FileSystemEventsSession, _
   ByVal destination As Xceed.FileSystem.FileSystemItem, _
   ByVal forward As Boolean, _
   ByVal recursive As Boolean, _
   ByVal includeFolders As Boolean, _
   ByVal filters As Xceed.FileSystem.Filter() _
)
[C#]
protected internal abstract void BuildList(
   FileSystemEventsSession session,
   FileSystemItem destination,
   bool forward,
   bool recursive,
   bool includeFolders,
   Filter[] filters
);

Parameters

session

A reference to a FileSystemEventsSession object which is responsible for raising all events that occur during the process.

destination

The eventual target for the item that will be procesed. For example, the desination folder for a folder that will be copied.

forward

true if folders will be added to the list of FileSystemItem objects to process first; false if files will be added to the list first.

recursive

true if items in subfolders should be added to the list of items to process; false otherwise.

includeFolders

true if folders will be included in the list of items to process; false otherwise.

filters

An array of objects that can be used to filter the list of FileSystemItem objects to process.

Remarks

This method is overridden in both the AbstractFolder and AbstractFile classes and does not need to be overridden in more specific implementations.

See Also

FileSystemItem Class | FileSystemItem Members | Xceed.FileSystem Namespace


FileSystemItem.BuildListForCreate Method

Handles the special cases in regards to building the list of items to process when creating a FileSystemItem object.

[Visual Basic]
Overridable Protected Sub BuildListForCreate( _
   ByVal session As Xceed.FileSystem.FileSystemEventsSession _
)
[C#]
protected virtual void BuildListForCreate(
   FileSystemEventsSession session
);

Parameters

session

A reference to a FileSystemEventsSession object which is responsible for raising all events that occur during the process.

See Also

FileSystemItem Class | FileSystemItem Members | Xceed.FileSystem Namespace


CopyTo Method

Xceed Zip for .NET

FileSystemItem.CopyTo

Copies the item, or it's content to the destination.

Overload List

Copies the item to another folder.

public FileSystemItem CopyTo(AbstractFolder,bool);

Copies the item to another folder, and raises events during the process.

public FileSystemItem CopyTo(FileSystemEvents,object,AbstractFolder,bool);

See Also

FileSystemItem Class | FileSystemItem Members | Xceed.FileSystem Namespace


FileSystemItem.CopyTo Method (AbstractFolder, Boolean)

Copies the item to another folder.

[Visual Basic]
Overloads Public Function CopyTo( _
   ByVal destinationFolder As Xceed.FileSystem.AbstractFolder, _
   ByVal replaceExistingFiles As Boolean _
) As Xceed.FileSystem.FileSystemItem
[C#]
public FileSystemItem CopyTo(
   AbstractFolder destinationFolder,
   bool replaceExistingFiles
);

Parameters

destinationFolder

An AbstractFolder object into which the item will be copied. Cannot be a null reference (Nothing in Visual Basic).

replaceExistingFiles

true if existing items in the destination should be replaced; false otherwise.

Return Value

A FileSystemItem object that represents the newly copied item.

Remarks

If the physical folder specified by destinationFolder does not exist, it is created.

If this FileSystemItem object represents a file, the physical file is immediately copied to the destination folder.

If it represents a folder, the folder and all it's content (files and subfolders) is immediately copied to the destination.

When replaceExistingFiles is true, any item in the destination that has the same name as an item being copied is automatically replaced.

When replaceExistingFiles is false, an exception is thrown whenever the destination contains an item with the same name as an item being copied.

Exceptions

Exception Type | Condition
Xceed.FileSystem.ItemDoesNotExistException | The item represented by this FileSystemItem object does not physically exist.
Xceed.FileSystem.ItemAlreadyExistsException | The destination item already exists, and replaceExistingFiles is false.
Xceed.FileSystem.ItemIsReadOnlyException | The destination item already exists, replaceExistingFiles is true, but the destination item has the ReadOnly attribute.
Xceed.FileSystem.FileSystemIOException | The source item could not be read from, or the destination item could not be written to.
Xceed.FileSystem.ItemIsRootFolderException | The item is a root folder. You should consider using CopyFilesTo to copy the content of a root folder.

See Also

FileSystemItem Class | FileSystemItem Members | Xceed.FileSystem Namespace | FileSystemItem.CopyTo Overload List


FileSystemItem.CopyTo Method (FileSystemEvents, Object, AbstractFolder, Boolean)

Copies the item to another folder, and raises events during the process.

[Visual Basic]
Overloads Public Function CopyTo( _
   ByVal events As Xceed.FileSystem.FileSystemEvents, _
   ByVal userData As Object, _
   ByVal destinationFolder As Xceed.FileSystem.AbstractFolder, _
   ByVal replaceExistingFiles As Boolean _
) As Xceed.FileSystem.FileSystemItem
[C#]
public FileSystemItem CopyTo(
   FileSystemEvents events,
   object userData,
   AbstractFolder destinationFolder,
   bool replaceExistingFiles
);

Parameters

events

A FileSystemEvents object that will be used to raise events. Cannot be a null reference (Nothing in Visual Basic).

userData

Opaque data that will be passed back to the event handler when an event is raised.

destinationFolder

An AbstractFolder object into which the item will be copied. Cannot be a null reference (Nothing in Visual Basic).

replaceExistingFiles

true if existing items in the destination should be replaced; false otherwise.

Return Value

A FileSystemItem object that represents the newly copied item.

Remarks

If the physical folder specified by destinationFolder does not exist, it is created.

If this FileSystemItem object represents a file, the physical file is immediately copied to the destination folder.

If it represents a folder, the folder and all it's content (files and subfolders) is immediately copied to the destination.

When replaceExistingFiles is true, any item in the destination that has the same name as an item being copied is automatically replaced.

When replaceExistingFiles is false, an exception is thrown whenever the destination contains an item with the same name as an item being copied.

Events

Event Type | Reason
Xceed.FileSystem.FileSystemEvents.ScanningFolder | A folder is being scanned for items to be copied.
Xceed.FileSystem.FileSystemEvents.ItemProgression | Every time an item is about to be copied, reports how many items have been copied and the total number of items that must be copied.
Xceed.FileSystem.FileSystemEvents.ByteProgression | Every 32k, reports how many bytes have been and must be copied for the current item, as well as for the entire set of items that are being copied.
Xceed.FileSystem.FileSystemEvents.ItemException | When an exception occurs while copying an item, reports the exception and allows to recover from the exception and continue copying the items.

Exceptions

Exception Type | Condition
Xceed.FileSystem.ItemDoesNotExistException | The item represented by this FileSystemItem object does not physically exist.
Xceed.FileSystem.ItemAlreadyExistsException | The destination item already exists, and replaceExistingFiles is false.
Xceed.FileSystem.ItemIsReadOnlyException | The destination item already exists, replaceExistingFiles is true, but the destination item has the ReadOnly attribute.
Xceed.FileSystem.FileSystemIOException | The source item could not be read from, or the destination item could not be written to.
Xceed.FileSystem.ItemIsRootFolderException | The item is a root folder. You should consider using CopyFilesTo to copy the content of a root folder.

See Also

FileSystemItem Class | FileSystemItem Members | Xceed.FileSystem Namespace | FileSystemItem.CopyTo Overload List


Create Method

Xceed Zip for .NET

FileSystemItem.Create

Creates the physical item represented by the FileSystemItem object.

Overload List

Creates the physical item represented by this FileSystemItem object.

public void Create();

Creates the physical item represented by this FileSystemItem object and raises events during the process.

public void Create(FileSystemEvents,object);

See Also

FileSystemItem Class | FileSystemItem Members | Xceed.FileSystem Namespace


FileSystemItem.Create Method ()

Creates the physical item represented by this FileSystemItem object.

[Visual Basic]
Overloads Public Sub Create()
[C#]
public void Create();

Remarks

If this FileSystemItem object represents a file, an empty file is created. If it represents a folder, a folder is created.

If the physical item already exists, an exception is thrown.

If the physical folder in which the new item is to be created does not exist, it is created.

The current property values (such as Attributes) are applied to the newly created item.

Exceptions

Exception Type | Condition
Xceed.FileSystem.ItemAlreadyExistsException | The physical item already exists.
Xceed.FileSystem.ItemIsRootFolderException | The physical item is a root folder.

See Also

FileSystemItem Class | FileSystemItem Members | Xceed.FileSystem Namespace | FileSystemItem.Create Overload List


FileSystemItem.Create Method (FileSystemEvents, Object)

Creates the physical item represented by this FileSystemItem object and raises events during the process.

[Visual Basic]
Overloads Public Sub Create( _
   ByVal events As Xceed.FileSystem.FileSystemEvents, _
   ByVal userData As Object _
)
[C#]
public void Create(
   FileSystemEvents events,
   object userData
);

Parameters

events

A FileSystemEvents object that will be used to raise events. Cannot be a null reference (Nothing in Visual Basic).

userData

Opaque data that will be passed back to the event handler when an event is raised.

Remarks

If this FileSystemItem object represents a file, an empty file is created. If it represents a folder, a folder is created.

If the physical item already exists, an exception is thrown.

If the physical folder in which the new item is to be created does not exist, it is created.

The current property values (such as Attributes) are applied to the newly created item.

Exceptions

Exception Type | Condition
Xceed.FileSystem.ItemAlreadyExistsException | The physical item already exists.
Xceed.FileSystem.ItemIsRootFolderException | The physical item is a root folder.

See Also

FileSystemItem Class | FileSystemItem Members | Xceed.FileSystem Namespace | FileSystemItem.Create Overload List


Delete Method

Xceed Zip for .NET

FileSystemItem.Delete

Permanently deletes the physical item.

Overload List

Permanently deletes the physical item.

public void Delete();

Permanently deletes the physical item, and raises events during the process.

public void Delete(FileSystemEvents,object);

See Also

FileSystemItem Class | FileSystemItem Members | Xceed.FileSystem Namespace


FileSystemItem.Delete Method ()

Permanently deletes the physical item.

[Visual Basic]
Overloads Public Sub Delete()
[C#]
public void Delete();

Remarks

If this FileSystemItem object represents a file, the file is deleted. If it represents a folder, the folder and all it's content is deleted.

If the physical item does not exist, an exception is thrown.

Exceptions

Exception Type | Condition
Xceed.FileSystem.ItemDoesNotExistException | The item represented by this FileSystemItem object does not physically exist.
Xceed.FileSystem.ItemIsRootFolderException | The physical item is a root folder.

See Also

FileSystemItem Class | FileSystemItem Members | Xceed.FileSystem Namespace | FileSystemItem.Delete Overload List


FileSystemItem.Delete Method (FileSystemEvents, Object)

Permanently deletes the physical item, and raises events during the process.

[Visual Basic]
Overloads Public Sub Delete( _
   ByVal events As Xceed.FileSystem.FileSystemEvents, _
   ByVal userData As Object _
)
[C#]
public void Delete(
   FileSystemEvents events,
   object userData
);

Parameters

events

A FileSystemEvents object that will be used to raise events. Cannot be a null reference (Nothing in Visual Basic).

userData

Opaque data that will be passed back to the event handler when an event is raised.

Remarks

If this FileSystemItem object represents a file, the file is deleted. If it represents a folder, the folder and all it's content is deleted.

If the physical item does not exist, an exception is thrown.

Events

Event Type | Reason
Xceed.FileSystem.FileSystemEvents.ScanningFolder | A folder is being scanned for items to be deleted.
Xceed.FileSystem.FileSystemEvents.ItemProgression | Every time an item is about to be deleted, reports how many items have been deleted and the total number of items that must be deleted.
Xceed.FileSystem.FileSystemEvents.ItemException | When an exception occurs while deleting an item, reports the exception and allows to recover from the exception and continue deleting the items.

Exceptions

Exception Type | Condition
Xceed.FileSystem.ItemDoesNotExistException | The item represented by this FileSystemItem object does not physically exist.
Xceed.FileSystem.ItemIsRootFolderException | The physical item is a root folder.

See Also

FileSystemItem Class | FileSystemItem Members | Xceed.FileSystem Namespace | FileSystemItem.Delete Overload List


FileSystemItem.DoApplyPropertiesTo Method

Copies the item's properties to another item. This method must be overridden when deriving from the AbstractFolder or AbstractFile classes.

[Visual Basic]
Overridable Protected Sub DoApplyPropertiesTo( _
   ByVal session As Xceed.FileSystem.FileSystemEventsSession, _
   ByVal targetItem As Xceed.FileSystem.FileSystemItem _
)
[C#]
protected virtual void DoApplyPropertiesTo(
   FileSystemEventsSession session,
   FileSystemItem targetItem
);

Parameters

session

A reference to a FileSystemEventsSession object which is responsible for raising all events that occur during the process.

targetItem

A FileSystemItem object to which the current item's properties must be copied. Should not be a null reference (Nothing in Visual Basic).

Remarks

This method should be overridden only in the case where the physical item ( file or folder ) supports specific meta-data ( other than attributes, dates, size, etc... ). The overriding method should eventually call the base implementation found in the FileSystemItem class in order to address the regular FileSystemItem meta-data.

See Also

FileSystemItem Class | FileSystemItem Members | Xceed.FileSystem Namespace


FileSystemItem.DoCopyTo Method

Copies the item to another folder. This method must be overridden when deriving from the AbstractFolder or AbstractFile classes.

[Visual Basic]
MustOverride Protected Sub DoCopyTo( _
   ByVal session As Xceed.FileSystem.FileSystemEventsSession, _
   ByVal destination As Xceed.FileSystem.FileSystemItem, _
   ByVal replaceExistingFiles As Boolean _
)
[C#]
protected abstract void DoCopyTo(
   FileSystemEventsSession session,
   FileSystemItem destination,
   bool replaceExistingFiles
);

Parameters

session

A reference to a FileSystemEventsSession object which is responsible for raising all events that occur during the process.

destination

An FileSystemItem object into which the item will be copied. Should not be a null reference (Nothing in Visual Basic).

replaceExistingFiles

true if existing items in the destination should be replaced; false otherwise.

Remarks

If the destination does not exists, it should be created.

If an error occurs during the copying process of a file, the destination should not be automatically deleted.

If the destination is created during the process, the metadata of the source item should be applied to the destination by calling ApplyPropertiesTo.

See Also

FileSystemItem Class | FileSystemItem Members | Xceed.FileSystem Namespace


FileSystemItem.DoCreate Method

Creates the physical item represented by the FileSystemItem object. This method must be overridden when deriving from the AbstractFolder or AbstractFile classes.

[Visual Basic]
MustOverride Protected Friend Sub DoCreate( _
   ByVal session As Xceed.FileSystem.FileSystemEventsSession _
)
[C#]
protected internal abstract void DoCreate(
   FileSystemEventsSession session
);

Parameters

session

A reference to a FileSystemEventsSession object which is responsible for raising all events that occur during the process.

Remarks

If the parents of the FileSystemItem object do not exist upon creation of the item, an exception should be thrown.

If an exception is thrown during the creation of the item, the physical item should not be deleted automatically.

See Also

FileSystemItem Class | FileSystemItem Members | Xceed.FileSystem Namespace


FileSystemItem.DoDelete Method

Permanently deletes the physical item. This method must be overridden when deriving from the AbstractFolder or AbstractFile classes.

[Visual Basic]
MustOverride Protected Friend Sub DoDelete( _
   ByVal session As Xceed.FileSystem.FileSystemEventsSession _
)
[C#]
protected internal abstract void DoDelete(
   FileSystemEventsSession session
);

Parameters

session

A reference to a FileSystemEventsSession object which is responsible for raising all events that occur during the process.

Remarks

If this method is called for an AbstractFolder object, all children should have been previously deleted or the folder be empty or an exception should be thrown.

All metadata ( attributes, size, etc... ) associated with the FileSystemItem object should be reset to their default values after the item is deleted.

See Also

FileSystemItem Class | FileSystemItem Members | Xceed.FileSystem Namespace


FileSystemItem.DoRefresh Method

Re-reads the information from the physical item. This method must be overridden when deriving from the AbstractFolder or AbstractFile classes.

[Visual Basic]
MustOverride Protected Sub DoRefresh( _
   ByVal session As Xceed.FileSystem.FileSystemEventsSession _
)
[C#]
protected abstract void DoRefresh(
   FileSystemEventsSession session
);

Parameters

session

A reference to a FileSystemEventsSession object which is responsible for raising all events that occur during the process.

Remarks

When a FileSystemItem object's properties, such as Attributes or CreationDateTime, are first accessed, a snapshot of the underlying physical item's properties should be taken. This snapshot should not be automatically updated whenever the physical item's properties change.

Refresh should re-read the information from the physical item and updates the snapshot.

Note: Refresh should be called before accessing a property, or the information returned could be outdated.

See Also

FileSystemItem Class | FileSystemItem Members | Xceed.FileSystem Namespace


FileSystemItem.EnsureDateIsValid Method

Ensures that the System.DateTime value is valid.

[Visual Basic]
Overridable Protected Sub EnsureDateIsValid( _
   ByVal value As Date _
)
[C#]
protected virtual void EnsureDateIsValid(
   DateTime value
);

Parameters

value

The System.DateTime value to validate.

Remarks

This method should be overridden only in the case where the physical item ( file or folder ) supports a specific date/time interval for our System.DateTime values ( creation, modified, accessed ).

See Also

FileSystemItem Class | FileSystemItem Members | Xceed.FileSystem Namespace


FileSystemItem.IsPathRooted Method

Returns a boolean value indicating if the path passed is rooted in the environment of the FileSystemItem object we are dealing with. This method must be overridden when deriving from the AbstractFolder or AbstractFile classes.

[Visual Basic]
MustOverride Protected Function IsPathRooted( _
   ByVal path As String _
) As Boolean
[C#]
protected abstract bool IsPathRooted(
   string path
);

Parameters

path

The path to verify.

Return Value

true if the path is rooted; false otherwise.

See Also

FileSystemItem Class | FileSystemItem Members | Xceed.FileSystem Namespace


FileSystemItem.IsSameAs Method

Gets a boolean value indicating if the source and target items are the same. This method must be overridden when deriving from the AbstractFolder or AbstractFile classes.

[Visual Basic]
MustOverride Protected Function IsSameAs( _
   ByVal target As Xceed.FileSystem.FileSystemItem _
) As Boolean
[C#]
protected abstract bool IsSameAs(
   FileSystemItem target
);

Parameters

target

A FileSystemItem object representing the destination item.

Return Value

true if the source and target FileSystemItem objects are the same; false otherwise.

Remarks

If the target item is a null reference (Nothing in Visual Basic), this method should return false

See Also

FileSystemItem Class | FileSystemItem Members | Xceed.FileSystem Namespace


FileSystemItem.ListCopyTo Method

Copies each item in the FileSystemEventsSession object's list to each item's destination.

[Visual Basic]
Overridable Protected Function ListCopyTo( _
   ByVal session As Xceed.FileSystem.FileSystemEventsSession, _
   ByVal replaceExistingFiles As Boolean _
) As Xceed.FileSystem.FileSystemItem
[C#]
protected virtual FileSystemItem ListCopyTo(
   FileSystemEventsSession session,
   bool replaceExistingFiles
);

Parameters

session

A reference to a FileSystemEventsSession object which is responsible for raising all events that occur during the process.

replaceExistingFiles

true if existing items in the destination should be replaced; false otherwise.

Return Value

A reference to a FileSystemItem object representing the target item of the first ItemPair.

See Also

FileSystemItem Class | FileSystemItem Members | Xceed.FileSystem Namespace


FileSystemItem.ListCreate Method

Creates each item in the FileSystemEventsSession object's list.

[Visual Basic]
Overridable Protected Sub ListCreate( _
   ByVal session As Xceed.FileSystem.FileSystemEventsSession _
)
[C#]
protected virtual void ListCreate(
   FileSystemEventsSession session
);

Parameters

session

A reference to a FileSystemEventsSession object which is responsible for raising all events that occur during the process.

See Also

FileSystemItem Class | FileSystemItem Members | Xceed.FileSystem Namespace


FileSystemItem.ListDelete Method

Deletes each item in the FileSystemEventsSession object's list.

[Visual Basic]
Overridable Protected Sub ListDelete( _
   ByVal session As Xceed.FileSystem.FileSystemEventsSession _
)
[C#]
protected virtual void ListDelete(
   FileSystemEventsSession session
);

Parameters

session

A reference to a FileSystemEventsSession object which is responsible for raising all events that occur during the process.

See Also

FileSystemItem Class | FileSystemItem Members | Xceed.FileSystem Namespace


FileSystemItem.ListMoveTo Method

Moves each item in the FileSystemEventsSession object's list to each item's destination.

[Visual Basic]
Overridable Protected Function ListMoveTo( _
   ByVal session As Xceed.FileSystem.FileSystemEventsSession, _
   ByVal replaceExistingFiles As Boolean _
) As Xceed.FileSystem.FileSystemItem
[C#]
protected virtual FileSystemItem ListMoveTo(
   FileSystemEventsSession session,
   bool replaceExistingFiles
);

Parameters

session

A reference to a FileSystemEventsSession object which is responsible for raising all events that occur during the process.

replaceExistingFiles

true if existing items in the destination should be replaced; false otherwise.

Return Value

A reference to a FileSystemItem object representing the target item of the last ItemPair.

See Also

FileSystemItem Class | FileSystemItem Members | Xceed.FileSystem Namespace


MoveTo Method

Xceed Zip for .NET

FileSystemItem.MoveTo

Moves the item, or it's content to the destination.

Overload List

Moves the item to another folder.

public FileSystemItem MoveTo(AbstractFolder,bool);

Moves the item to another folder, and raises events during the process.

public FileSystemItem MoveTo(FileSystemEvents,object,AbstractFolder,bool);

See Also

FileSystemItem Class | FileSystemItem Members | Xceed.FileSystem Namespace


FileSystemItem.MoveTo Method (AbstractFolder, Boolean)

Moves the item to another folder.

[Visual Basic]
Overloads Public Function MoveTo( _
   ByVal destinationFolder As Xceed.FileSystem.AbstractFolder, _
   ByVal replaceExistingFiles As Boolean _
) As Xceed.FileSystem.FileSystemItem
[C#]
public FileSystemItem MoveTo(
   AbstractFolder destinationFolder,
   bool replaceExistingFiles
);

Parameters

destinationFolder

An AbstractFolder object into which the item will be moved. Cannot be a null reference (Nothing in Visual Basic).

replaceExistingFiles

true if existing items in the destination should be replaced; false otherwise.

Return Value

A FileSystemItem object that represents the newly moved item.

Remarks

If the physical folder specified by destinationFolder does not exist, it is created.

If this FileSystemItem object represents a file, the physical file is immediately moved to the destination folder.

If it represents a folder, the folder and all it's content (files and subfolders) is immediately moved to the destination.

When replaceExistingFiles is true, any item in the destination that has the same name as an item being moved is automatically replaced.

When replaceExistingFiles is false, an exception is thrown whenever the destination contains an item with the same name as an item being moved.

Exceptions

Exception Type | Condition
Xceed.FileSystem.ItemDoesNotExistException | The item represented by this FileSystemItem object does not physically exist.
Xceed.FileSystem.ItemAlreadyExistsException | The destination item already exists, and replaceExistingFiles is false.
Xceed.FileSystem.ItemIsReadOnlyException | The destination item already exists, replaceExistingFiles is true, but the destination item has the ReadOnly attribute. Or the source item has the ReadOnly attribute, and cannot be deleted.
Xceed.FileSystem.FileSystemIOException | The source item could not be read from, or the destination item could not be written to.
Xceed.FileSystem.ItemIsRootFolderException | The item is a root folder. You should consider using MoveFilesTo to move the content of a root folder.

See Also

FileSystemItem Class | FileSystemItem Members | Xceed.FileSystem Namespace | FileSystemItem.MoveTo Overload List


FileSystemItem.MoveTo Method (FileSystemEvents, Object, AbstractFolder, Boolean)

Moves the item to another folder, and raises events during the process.

[Visual Basic]
Overloads Public Function MoveTo( _
   ByVal events As Xceed.FileSystem.FileSystemEvents, _
   ByVal userData As Object, _
   ByVal destinationFolder As Xceed.FileSystem.AbstractFolder, _
   ByVal replaceExistingFiles As Boolean _
) As Xceed.FileSystem.FileSystemItem
[C#]
public FileSystemItem MoveTo(
   FileSystemEvents events,
   object userData,
   AbstractFolder destinationFolder,
   bool replaceExistingFiles
);

Parameters

events

A FileSystemEvents object that will be used to raise events. Cannot be a null reference (Nothing in Visual Basic).

userData

Opaque data that will be passed back to the event handler when an event is raised.

destinationFolder

An AbstractFolder object into which the item will be moved. Cannot be a null reference (Nothing in Visual Basic).

replaceExistingFiles

true if existing items in the destination should be replaced; false otherwise.

Return Value

A FileSystemItem object that represents the newly moved item.

Remarks

If the physical folder specified by destinationFolder does not exist, it is created.

If this FileSystemItem object represents a file, the physical file is immediately moved to the destination folder.

If it represents a folder, the folder and all it's content (files and subfolders) is immediately moved to the destination.

When replaceExistingFiles is true, any item in the destination that has the same name as an item being moved is automatically replaced.

When replaceExistingFiles is false, an exception is thrown whenever the destination contains an item with the same name as an item being moved.

Events

Event Type | Reason
Xceed.FileSystem.FileSystemEvents.ScanningFolder | A folder is being scanned for items to be moved.
Xceed.FileSystem.FileSystemEvents.ItemProgression | Every time an item is about to be moved, reports how many items have been moved and the total number of items that must be moved.
Xceed.FileSystem.FileSystemEvents.ByteProgression | Every 32k, reports how many bytes have been and must be moved for the current item, as well as for the entire set of items that are being moved.
Xceed.FileSystem.FileSystemEvents.ItemException | When an exception occurs while moving an item, reports the exception and allows to recover from the exception and continue moving the items.

Exceptions

Exception Type | Condition
Xceed.FileSystem.ItemDoesNotExistException | The item represented by this FileSystemItem object does not physically exist.
Xceed.FileSystem.ItemAlreadyExistsException | The destination item already exists, and replaceExistingFiles is false.
Xceed.FileSystem.ItemIsReadOnlyException | The destination item already exists, replaceExistingFiles is true, but the destination item has the ReadOnly attribute. Or the source item has the ReadOnly attribute, and cannot be deleted.
Xceed.FileSystem.FileSystemIOException | The source item could not be read from, or the destination item could not be written to.
Xceed.FileSystem.ItemIsRootFolderException | The item is a root folder. You should consider using MoveFilesTo to move the content of a root folder.

See Also

FileSystemItem Class | FileSystemItem Members | Xceed.FileSystem Namespace | FileSystemItem.MoveTo Overload List


Refresh Method

Xceed Zip for .NET

FileSystemItem.Refresh

Re-reads the information from the physical item.

Overload List

Re-reads the information from the physical item.

public void Refresh();

Re-reads the information from the physical item and raises events during the process.

public void Refresh(FileSystemEvents,object);

See Also

FileSystemItem Class | FileSystemItem Members | Xceed.FileSystem Namespace


FileSystemItem.Refresh Method ()

Re-reads the information from the physical item.

[Visual Basic]
Overloads Public Sub Refresh()
[C#]
public void Refresh();

Remarks

When a FileSystemItem object's properties, such as Attributes or CreationDateTime, are first accessed, a snapshot of the underlying physical item's properties is taken. This snapshot is not automatically updated whenever the physical item's properties change.

Refresh re-reads the information from the physical item and updates the snapshot.

Note: Refresh should be called before accessing a property, or the information returned could be outdated.

Exceptions

Exception Type | Condition
Xceed.FileSystem.ItemDoesNotExistException | The item represented by this FileSystemItem does not physically exist.

See Also

FileSystemItem Class | FileSystemItem Members | Xceed.FileSystem Namespace | FileSystemItem.Refresh Overload List


FileSystemItem.Refresh Method (FileSystemEvents, Object)

Re-reads the information from the physical item and raises events during the process.

[Visual Basic]
Overloads Public Sub Refresh( _
   ByVal events As Xceed.FileSystem.FileSystemEvents, _
   ByVal userData As Object _
)
[C#]
public void Refresh(
   FileSystemEvents events,
   object userData
);

Parameters

events

A FileSystemEvents object that will be used to raise events. Cannot be a null reference (Nothing in Visual Basic).

userData

Opaque data that will be passed back to the event handler when an event is raised.

Remarks

When a FileSystemItem object's properties, such as Attributes or CreationDateTime, are first accessed, a snapshot of the underlying physical item's properties is taken. This snapshot is not automatically updated whenever the physical item's properties change.

Refresh re-reads the information from the physical item and updates the snapshot.

Note: Refresh should be called before accessing a property, or the information returned could be outdated.

Exceptions

Exception Type | Condition
Xceed.FileSystem.ItemDoesNotExistException | The item represented by this FileSystemItem does not physically exist.

See Also

FileSystemItem Class | FileSystemItem Members | Xceed.FileSystem Namespace | FileSystemItem.Refresh Overload List


FileSystemItem.ToString Method

Returns the full name of the item.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

A string that represents the full name of the item.

See Also

FileSystemItem Class | FileSystemItem Members | Xceed.FileSystem Namespace | FullName


FileSystemNotSupportedException Class

Exception that is thrown when calling a method or accessing a property that is not supported by a FileSystemItem object.

For a list of all members of this type, see FileSystemNotSupportedException Members.

System.Object
Exception
ApplicationException
FileSystemException
FileSystemNotSupportedException

[Visual Basic]
Public Class FileSystemNotSupportedException
   Inherits FileSystemException
   Implements ISerializable
[C#]
public class FileSystemNotSupportedException : FileSystemException, ISerializable

Requirements

Namespace: Xceed.FileSystem Namespace

Assembly: Xceed.FileSystem.dll

See Also

FileSystemNotSupportedException Members | Xceed.FileSystem Namespace


FileSystemNotSupportedException Members

Public Instance Constructors

FileSystemNotSupportedException Overloaded. Initialize a new instance of the FileSystemNotSupportedException class.

Public Instance Properties

HelpLink (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
InnerException (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
Item (inherited from FileSystemException) | Gets or sets the FileSystemItem object that caused the current exception.
Message (inherited from FileSystemException) | Gets a message that describes the current exception.
Source (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
StackTrace (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
TargetSite (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetBaseException (inherited from Exception) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetObjectData (inherited from Exception) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Exception) | Select the method name to go to the Microsoft documentation.

Protected Instance Properties

HResult (inherited from System.Exception) Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

FileSystemNotSupportedException Class | Xceed.FileSystem Namespace


FileSystemNotSupportedException Constructor

Xceed Zip for .NET

FileSystemNotSupportedException

Initializes a new instance of the exception with the specified FileSystemItem object.

Overload List

Initializes a new instance of the exception with the specified FileSystemItem object.

public FileSystemNotSupportedException(FileSystemItem);

Initializes a new instance of the exception with the specified message text and FileSystemItem object.

public FileSystemNotSupportedException(string,FileSystemItem);

Initializes a new instance of the exception with the specified FileSystemItem object and inner exception.

public FileSystemNotSupportedException(FileSystemItem,Exception);

Initializes a new instance of the exception with the specified message text, FileSystemItem object and inner exception.

public FileSystemNotSupportedException(string,FileSystemItem,Exception);

See Also

FileSystemNotSupportedException Class | FileSystemNotSupportedException Members | Xceed.FileSystem Namespace


FileSystemNotSupportedException Constructor (FileSystemItem)

Initializes a new instance of the exception with the specified FileSystemItem object.

[Visual Basic]
Overloads Public Sub New( _
   ByVal item As Xceed.FileSystem.FileSystemItem _
)
[C#]
public FileSystemNotSupportedException(
   FileSystemItem item
);

Parameters

item

The FileSystemItem object that caused the current exception.

See Also

FileSystemNotSupportedException Class | FileSystemNotSupportedException Members | Xceed.FileSystem Namespace | FileSystemNotSupportedException Constructor Overload List


FileSystemNotSupportedException Constructor (String, FileSystemItem)

Initializes a new instance of the exception with the specified message text and FileSystemItem object.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal item As Xceed.FileSystem.FileSystemItem _
)
[C#]
public FileSystemNotSupportedException(
   string message,
   FileSystemItem item
);

Parameters

message

The error message that explains the reason for the exception.

item

The FileSystemItem object that caused the current exception.

See Also

FileSystemNotSupportedException Class | FileSystemNotSupportedException Members | Xceed.FileSystem Namespace | FileSystemNotSupportedException Constructor Overload List


FileSystemNotSupportedException Constructor (FileSystemItem, Exception)

Initializes a new instance of the exception with the specified FileSystemItem object and inner exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal item As Xceed.FileSystem.FileSystemItem, _
   ByVal inner As System.Exception _
)
[C#]
public FileSystemNotSupportedException(
   FileSystemItem item,
   Exception inner
);

Parameters

item

The FileSystemItem object that caused the current exception.

inner

The exception that initially caused the current exception to be thrown.

See Also

FileSystemNotSupportedException Class | FileSystemNotSupportedException Members | Xceed.FileSystem Namespace | FileSystemNotSupportedException Constructor Overload List


FileSystemNotSupportedException Constructor (String, FileSystemItem, Exception)

Initializes a new instance of the exception with the specified message text, FileSystemItem object and inner exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal item As Xceed.FileSystem.FileSystemItem, _
   ByVal inner As System.Exception _
)
[C#]
public FileSystemNotSupportedException(
   string message,
   FileSystemItem item,
   Exception inner
);

Parameters

message

The error message that explains the reason for the exception.

item

The FileSystemItem object that caused the current exception.

inner

The exception that initially caused the current exception to be thrown.

See Also

FileSystemNotSupportedException Class | FileSystemNotSupportedException Members | Xceed.FileSystem Namespace | FileSystemNotSupportedException Constructor Overload List


Filter Class

The Filter class allows to filter a list of FileSystemItem objects.

For a list of all members of this type, see Filter Members.

System.Object
Filter

[Visual Basic]
MustInherit Public Class Filter
[C#]
public abstract class Filter

Requirements

Namespace: Xceed.FileSystem Namespace

Assembly: Xceed.FileSystem.dll

See Also

Filter Members | Xceed.FileSystem Namespace


Filter Members

Public Static (Shared) Methods

GetFiltersFromParams | Converts a generic array of parameters to an array of Filter objects.
IsItemMatchingAll | Verifies if the FileSystemItem object matches all of the provided filters.
IsItemMatchingOne | Verifies if the FileSystemItem object matches at least one of the provided filters.

Public Instance Properties

Scope Gets or sets the scope of the filter.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsItemMatching | Gets a boolean value indicating if the item matches one or more of the filters.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Constructors

Filter Overloaded. Initialize a new instance of the Filter class.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsItemInScope |
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

Filter Class | Xceed.FileSystem Namespace


Filter Constructor

Xceed Zip for .NET

Filter

Default constructor

Overload List

Default constructor

protected Filter();

protected Filter(FilterScope);

See Also

Filter Class | Filter Members | Xceed.FileSystem Namespace


Filter Constructor ()

Default constructor

[Visual Basic]
Overloads Protected Sub New()
[C#]
protected Filter();

See Also

Filter Class | Filter Members | Xceed.FileSystem Namespace | Filter Constructor Overload List


Filter Constructor (FilterScope)

[Visual Basic]
Overloads Protected Sub New( _
   ByVal scope As Xceed.FileSystem.FilterScope _
)
[C#]
protected Filter(
   FilterScope scope
);

Parameters

scope

See Also

Filter Class | Filter Members | Xceed.FileSystem Namespace | Filter Constructor Overload List


Filter Properties

The properties of the Filter class are listed below. For a complete list of Filter class members, see the Filter Members topic.

Public Instance Properties

Scope Gets or sets the scope of the filter.

See Also

Filter Class | Xceed.FileSystem Namespace


FilterScope Enumeration

Specifies which type of FileSystemItem will be filtered by a Filter object.

[Visual Basic]
Public Enum FilterScope
[C#]
public enum FilterScope

Members

Member Name | Description
File | The filter will be applied to any AbstractFile object.
Folder | The filter will be applied to any AbstractFolder object.
All | The filter will be applied to all types of FileSystemItem objects.

Requirements

Namespace: Xceed.FileSystem Namespace

Assembly: Xceed.FileSystem.dll

See Also

Xceed.FileSystem Namespace

Copyright 2000-2002 Xceed Software Inc.


Filter Methods

The methods of the Filter class are listed below. For a complete list of Filter class members, see the Filter Members topic.

Public Static (Shared) Methods

GetFiltersFromParams | Converts a generic array of parameters to an array of Filter objects.
IsItemMatchingAll | Verifies if the FileSystemItem object matches all of the provided filters.
IsItemMatchingOne | Verifies if the FileSystemItem object matches at least one of the provided filters.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsItemMatching | Gets a boolean value indicating if the item matches one or more of the filters.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsItemInScope |
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

Filter Class | Xceed.FileSystem Namespace


Filter.GetFiltersFromParams Method

Converts a generic array of parameters to an array of Filter objects.

[Visual Basic]
Public Shared Function GetFiltersFromParams( _
   ByVal filters As Object() _
) As Xceed.FileSystem.Filter()
[C#]
public static Filter[] GetFiltersFromParams(
   params object[] filters
);

Parameters

filters

An array of objects that must be converted to an array of Filter objects.

Return Value

An array of Filter objects.

Remarks

To filter a list of files or folders, you can pass a variable number of objects in the filters parameter. These objects may be of the following types:

Object type | Type of filter applied
System.String | The string is assumed to be a file mask, and a NameFilter object is automatically created for the passed string, with File as the default FilterScope.
System.IO.FileAttributes | A AttributeFilter object is automatically created for the provided attributes, with File as the default FilterScope.
Filter | The provided Filter object is used as-is.
Array of System.Object | Each object in the array may be of the types described in this table, and is used accordingly.
Other | If any other type is found, an exception is thrown.

See Also

Filter Class | Filter Members | Xceed.FileSystem Namespace


Filter.IsItemInScope Method

[Visual Basic]
Protected Function IsItemInScope( _
   ByVal item As Xceed.FileSystem.FileSystemItem _
) As Boolean
[C#]
protected bool IsItemInScope(
   FileSystemItem item
);

Parameters

item

Return Value

See Also

Filter Class | Filter Members | Xceed.FileSystem Namespace


Filter.IsItemMatching Method

Gets a boolean value indicating if the item matches one or more of the filters.

[Visual Basic]
MustOverride Public Function IsItemMatching( _
   ByVal item As Xceed.FileSystem.FileSystemItem _
) As Boolean
[C#]
public abstract bool IsItemMatching(
   FileSystemItem item
);

Parameters

item

The FileSystemItem object that will being verified.

Return Value

true if item matches one or more of the filters; false otherwise.

See Also

Filter Class | Filter Members | Xceed.FileSystem Namespace


Filter.IsItemMatchingAll Method

Verifies if the FileSystemItem object matches all of the provided filters.

[Visual Basic]
Public Shared Function IsItemMatchingAll( _
   ByVal item As Xceed.FileSystem.FileSystemItem, _
   ByVal filters As Xceed.FileSystem.Filter() _
) As Boolean
[C#]
public static bool IsItemMatchingAll(
   FileSystemItem item,
   Filter[] filters
);

Parameters

item

The FileSystemItem object that will be verified.

filters

The array of Filter objects against which item will be verified.

Return Value

true if item matches all of the provided filters; false otherwise.

See Also

Filter Class | Filter Members | Xceed.FileSystem Namespace


Filter.IsItemMatchingOne Method

Verifies if the FileSystemItem object matches at least one of the provided filters.

[Visual Basic]
Public Shared Function IsItemMatchingOne( _
   ByVal item As Xceed.FileSystem.FileSystemItem, _
   ByVal filters As Xceed.FileSystem.Filter() _
) As Boolean
[C#]
public static bool IsItemMatchingOne(
   FileSystemItem item,
   Filter[] filters
);

Parameters

item

The FileSystemItem object that will be verified.

filters

The array of Filter objects against which item will be verified.

Return Value

true if item matches one of the provided filters; false otherwise.

See Also

Filter Class | Filter Members | Xceed.FileSystem Namespace


IBatchUpdateable Interface

Allows a AbstractFolder object to optimize its updates, by modifying its underlying physical store only once.

For a list of all members of this type, see IBatchUpdateable Members.

[Visual Basic]
Public Interface IBatchUpdateable
[C#]
public interface IBatchUpdateable

Remarks

This interface is usually implemented by a root folder.

Requirements

Namespace: Xceed.FileSystem Namespace

Assembly: Xceed.FileSystem.dll

See Also

IBatchUpdateable Members | Xceed.FileSystem Namespace


IBatchUpdateable Members

Public Instance Methods

BeginUpdate | Overloaded. Prevents a object from modifying its underlying physical store until the method is called and raises events during the process.
EndUpdate | Overloaded. Informs a object to apply to its underlying physical store all the modifications that have been made since the call to and raises events during the process.

See Also

IBatchUpdateable Interface | Xceed.FileSystem Namespace


IBatchUpdateable Methods

The methods of the IBatchUpdateable class are listed below. For a complete list of IBatchUpdateable class members, see the IBatchUpdateable Members topic.

Public Instance Methods

BeginUpdate | Overloaded.
EndUpdate | Overloaded.

See Also

IBatchUpdateable Interface | Xceed.FileSystem Namespace


BeginUpdate Method

Xceed Zip for .NET

IBatchUpdateable.BeginUpdate

Prevents a AbstractFolder object from modifying its underlying physical store until the EndUpdate method is called.

Overload List

Prevents a AbstractFolder object from modifying its underlying physical store until the EndUpdate method is called and raises events during the process.

void BeginUpdate(FileSystemEvents,object);

Prevents a AbstractFolder object from modifying its underlying physical store until the EndUpdate method is called.

void BeginUpdate();

See Also

IBatchUpdateable Interface | IBatchUpdateable Members | Xceed.FileSystem Namespace


IBatchUpdateable.BeginUpdate Method ()

Prevents a AbstractFolder object from modifying its underlying physical store until the EndUpdate method is called.

[Visual Basic]
Sub BeginUpdate()
[C#]
void BeginUpdate();

Remarks

A call to BeginUpdatemust be accompanied by a subsequent call to EndUpdate, or desynchronization can occur. One mean of making sure that both calls stay synchronized is to use a finally block:

            try
            {
              i.BeginUpdate();
              // Do some modifications to the folder
            }
            finally
            {
              i.EndUpdate();
            }

In C#, the preferred way is to use the AutoBatchUpdate class in a using statement.

See Also

IBatchUpdateable Interface | IBatchUpdateable Members | Xceed.FileSystem Namespace | IBatchUpdateable.BeginUpdate Overload List


IBatchUpdateable.BeginUpdate Method (FileSystemEvents, Object)

Prevents a AbstractFolder object from modifying its underlying physical store until the EndUpdate method is called and raises events during the process.

[Visual Basic]
Sub BeginUpdate( _
   ByVal events As Xceed.FileSystem.FileSystemEvents, _
   ByVal userData As Object _
)
[C#]
void BeginUpdate(
   FileSystemEvents events,
   object userData
);

Parameters

events

A FileSystemEvents object that will be used to raise events. Cannot be a null reference (Nothing in Visual Basic).

userData

Opaque data that will be passed back to the event handler when an event is raised.

Remarks

A call to BeginUpdatemust be accompanied by a subsequent call to EndUpdate, or desynchronization can occur. One mean of making sure that both calls stay synchronized is to use a finally block:

            try
            {
              i.BeginUpdate();
              // Do some modifications to the folder
            }
            finally
            {
              i.EndUpdate();
            }

In C#, the preferred way is to use the AutoBatchUpdate class in a using statement.

See Also

IBatchUpdateable Interface | IBatchUpdateable Members | Xceed.FileSystem Namespace | IBatchUpdateable.BeginUpdate Overload List


EndUpdate Method

Xceed Zip for .NET

IBatchUpdateable.EndUpdate

Informs a AbstractFolder object to apply to its underlying physical store all the modifications that have been made since the call to BeginUpdate.

Overload List

Informs a AbstractFolder object to apply to its underlying physical store all the modifications that have been made since the call to BeginUpdate and raises events during the process.

void EndUpdate(FileSystemEvents,object);

Informs a AbstractFolder object to apply to its underlying physical store all the modifications that have been made since the call to BeginUpdate.

void EndUpdate();

See Also

IBatchUpdateable Interface | IBatchUpdateable Members | Xceed.FileSystem Namespace


IBatchUpdateable.EndUpdate Method ()

Informs a AbstractFolder object to apply to its underlying physical store all the modifications that have been made since the call to BeginUpdate.

[Visual Basic]
Sub EndUpdate()
[C#]
void EndUpdate();

Remarks

A call to EndUpdatemust be preceded by a call to BeginUpdate, or desynchronization can occur. One mean of making sure that both calls stay synchronized is to use a finally block:

            try
            {
              i.BeginUpdate();
              // Do some modifications to the folder
            }
            finally
            {
              i.EndUpdate();
            }

In C#, the preferred way is to use the AutoBatchUpdate class in a using statement.

See Also

IBatchUpdateable Interface | IBatchUpdateable Members | Xceed.FileSystem Namespace | IBatchUpdateable.EndUpdate Overload List


IBatchUpdateable.EndUpdate Method (FileSystemEvents, Object)

Informs a AbstractFolder object to apply to its underlying physical store all the modifications that have been made since the call to BeginUpdate and raises events during the process.

[Visual Basic]
Sub EndUpdate( _
   ByVal events As Xceed.FileSystem.FileSystemEvents, _
   ByVal userData As Object _
)
[C#]
void EndUpdate(
   FileSystemEvents events,
   object userData
);

Parameters

events

A FileSystemEvents object that will be used to raise events. Cannot be a null reference (Nothing in Visual Basic).

userData

Opaque data that will be passed back to the event handler when an event is raised.

Remarks

A call to EndUpdatemust be preceded by a call to BeginUpdate, or desynchronization can occur. One mean of making sure that both calls stay synchronized is to use a finally block:

            try
            {
              i.BeginUpdate();
              // Do some modifications to the folder
            }
            finally
            {
              i.EndUpdate();
            }

In C#, the preferred way is to use the AutoBatchUpdate class in a using statement.

See Also

IBatchUpdateable Interface | IBatchUpdateable Members | Xceed.FileSystem Namespace | IBatchUpdateable.EndUpdate Overload List


ItemAlreadyExistsException Class

Exception that is thrown when performing an operation on a FileSystemItem object that already exists.

For a list of all members of this type, see ItemAlreadyExistsException Members.

System.Object
Exception
ApplicationException
FileSystemException
ItemAlreadyExistsException

[Visual Basic]
Public Class ItemAlreadyExistsException
   Inherits FileSystemException
   Implements ISerializable
[C#]
public class ItemAlreadyExistsException : FileSystemException, ISerializable

Requirements

Namespace: Xceed.FileSystem Namespace

Assembly: Xceed.FileSystem.dll

See Also

ItemAlreadyExistsException Members | Xceed.FileSystem Namespace


ItemAlreadyExistsException Members

Public Instance Constructors

ItemAlreadyExistsException Overloaded. Initialize a new instance of the ItemAlreadyExistsException class.

Public Instance Properties

HelpLink (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
InnerException (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
Item (inherited from FileSystemException) | Gets or sets the FileSystemItem object that caused the current exception.
Message (inherited from FileSystemException) | Gets a message that describes the current exception.
Source (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
StackTrace (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
TargetSite (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetBaseException (inherited from Exception) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetObjectData (inherited from Exception) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Exception) | Select the method name to go to the Microsoft documentation.

Protected Instance Properties

HResult (inherited from System.Exception) Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

ItemAlreadyExistsException Class | Xceed.FileSystem Namespace


ItemAlreadyExistsException Constructor

Xceed Zip for .NET

ItemAlreadyExistsException

Initializes a new instance of the exception with the specified FileSystemItem object.

Overload List

Initializes a new instance of the exception with the specified FileSystemItem object.

public ItemAlreadyExistsException(FileSystemItem);

Initializes a new instance of the exception with the specified message text and FileSystemItem object.

public ItemAlreadyExistsException(string,FileSystemItem);

Initializes a new instance of the exception with the specified FileSystemItem object and inner exception.

public ItemAlreadyExistsException(FileSystemItem,Exception);

Initializes a new instance of the exception with the specified message text, FileSystemItem object and inner exception.

public ItemAlreadyExistsException(string,FileSystemItem,Exception);

See Also

ItemAlreadyExistsException Class | ItemAlreadyExistsException Members | Xceed.FileSystem Namespace


ItemAlreadyExistsException Constructor (FileSystemItem)

Initializes a new instance of the exception with the specified FileSystemItem object.

[Visual Basic]
Overloads Public Sub New( _
   ByVal item As Xceed.FileSystem.FileSystemItem _
)
[C#]
public ItemAlreadyExistsException(
   FileSystemItem item
);

Parameters

item

The FileSystemItem object that caused the current exception.

See Also

ItemAlreadyExistsException Class | ItemAlreadyExistsException Members | Xceed.FileSystem Namespace | ItemAlreadyExistsException Constructor Overload List


ItemAlreadyExistsException Constructor (String, FileSystemItem)

Initializes a new instance of the exception with the specified message text and FileSystemItem object.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal item As Xceed.FileSystem.FileSystemItem _
)
[C#]
public ItemAlreadyExistsException(
   string message,
   FileSystemItem item
);

Parameters

message

The error message that explains the reason for the exception.

item

The FileSystemItem object that caused the current exception.

See Also

ItemAlreadyExistsException Class | ItemAlreadyExistsException Members | Xceed.FileSystem Namespace | ItemAlreadyExistsException Constructor Overload List


ItemAlreadyExistsException Constructor (FileSystemItem, Exception)

Initializes a new instance of the exception with the specified FileSystemItem object and inner exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal item As Xceed.FileSystem.FileSystemItem, _
   ByVal inner As System.Exception _
)
[C#]
public ItemAlreadyExistsException(
   FileSystemItem item,
   Exception inner
);

Parameters

item

The FileSystemItem object that caused the current exception.

inner

The exception that initially caused the current exception to be thrown.

See Also

ItemAlreadyExistsException Class | ItemAlreadyExistsException Members | Xceed.FileSystem Namespace | ItemAlreadyExistsException Constructor Overload List


ItemAlreadyExistsException Constructor (String, FileSystemItem, Exception)

Initializes a new instance of the exception with the specified message text, FileSystemItem object and inner exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal item As Xceed.FileSystem.FileSystemItem, _
   ByVal inner As System.Exception _
)
[C#]
public ItemAlreadyExistsException(
   string message,
   FileSystemItem item,
   Exception inner
);

Parameters

message

The error message that explains the reason for the exception.

item

The FileSystemItem object that caused the current exception.

inner

The exception that initially caused the current exception to be thrown.

See Also

ItemAlreadyExistsException Class | ItemAlreadyExistsException Members | Xceed.FileSystem Namespace | ItemAlreadyExistsException Constructor Overload List


ItemDoesNotExistException Class

Exception that is thrown when performing an operation on a FileSystemItem object that does not yet exist.

For a list of all members of this type, see ItemDoesNotExistException Members.

System.Object
Exception
ApplicationException
FileSystemException
ItemDoesNotExistException

[Visual Basic]
Public Class ItemDoesNotExistException
   Inherits FileSystemException
   Implements ISerializable
[C#]
public class ItemDoesNotExistException : FileSystemException, ISerializable

Requirements

Namespace: Xceed.FileSystem Namespace

Assembly: Xceed.FileSystem.dll

See Also

ItemDoesNotExistException Members | Xceed.FileSystem Namespace


ItemDoesNotExistException Members

Public Instance Constructors

ItemDoesNotExistException Overloaded. Initialize a new instance of the ItemDoesNotExistException class.

Public Instance Properties

HelpLink (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
InnerException (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
Item (inherited from FileSystemException) | Gets or sets the FileSystemItem object that caused the current exception.
Message (inherited from FileSystemException) | Gets a message that describes the current exception.
Source (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
StackTrace (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
TargetSite (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetBaseException (inherited from Exception) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetObjectData (inherited from Exception) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Exception) | Select the method name to go to the Microsoft documentation.

Protected Instance Properties

HResult (inherited from System.Exception) Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

ItemDoesNotExistException Class | Xceed.FileSystem Namespace


ItemDoesNotExistException Constructor

Xceed Zip for .NET

ItemDoesNotExistException

Initializes a new instance of the exception with the specified FileSystemItem object.

Overload List

Initializes a new instance of the exception with the specified FileSystemItem object.

public ItemDoesNotExistException(FileSystemItem);

Initializes a new instance of the exception with the specified message text and FileSystemItem object.

public ItemDoesNotExistException(string,FileSystemItem);

Initializes a new instance of the exception with the specified FileSystemItem object and inner exception.

public ItemDoesNotExistException(FileSystemItem,Exception);

Initializes a new instance of the exception with the specified message text, FileSystemItem object and inner exception.

public ItemDoesNotExistException(string,FileSystemItem,Exception);

See Also

ItemDoesNotExistException Class | ItemDoesNotExistException Members | Xceed.FileSystem Namespace


ItemDoesNotExistException Constructor (FileSystemItem)

Initializes a new instance of the exception with the specified FileSystemItem object.

[Visual Basic]
Overloads Public Sub New( _
   ByVal item As Xceed.FileSystem.FileSystemItem _
)
[C#]
public ItemDoesNotExistException(
   FileSystemItem item
);

Parameters

item

The FileSystemItem object that caused the current exception.

See Also

ItemDoesNotExistException Class | ItemDoesNotExistException Members | Xceed.FileSystem Namespace | ItemDoesNotExistException Constructor Overload List


ItemDoesNotExistException Constructor (String, FileSystemItem)

Initializes a new instance of the exception with the specified message text and FileSystemItem object.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal item As Xceed.FileSystem.FileSystemItem _
)
[C#]
public ItemDoesNotExistException(
   string message,
   FileSystemItem item
);

Parameters

message

The error message that explains the reason for the exception.

item

The FileSystemItem object that caused the current exception.

See Also

ItemDoesNotExistException Class | ItemDoesNotExistException Members | Xceed.FileSystem Namespace | ItemDoesNotExistException Constructor Overload List


ItemDoesNotExistException Constructor (FileSystemItem, Exception)

Initializes a new instance of the exception with the specified FileSystemItem object and inner exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal item As Xceed.FileSystem.FileSystemItem, _
   ByVal inner As System.Exception _
)
[C#]
public ItemDoesNotExistException(
   FileSystemItem item,
   Exception inner
);

Parameters

item

The FileSystemItem object that caused the current exception.

inner

The exception that initially caused the current exception to be thrown.

See Also

ItemDoesNotExistException Class | ItemDoesNotExistException Members | Xceed.FileSystem Namespace | ItemDoesNotExistException Constructor Overload List


ItemDoesNotExistException Constructor (String, FileSystemItem, Exception)

Initializes a new instance of the exception with the specified message text, FileSystemItem object and inner exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal item As Xceed.FileSystem.FileSystemItem, _
   ByVal inner As System.Exception _
)
[C#]
public ItemDoesNotExistException(
   string message,
   FileSystemItem item,
   Exception inner
);

Parameters

message

The error message that explains the reason for the exception.

item

The FileSystemItem object that caused the current exception.

inner

The exception that initially caused the current exception to be thrown.

See Also

ItemDoesNotExistException Class | ItemDoesNotExistException Members | Xceed.FileSystem Namespace | ItemDoesNotExistException Constructor Overload List


ItemExceptionAction Enumeration

Specifies the action taken when an exception is thrown during the processing of a FileSystemItem object.

[Visual Basic]
Public Enum ItemExceptionAction
[C#]
public enum ItemExceptionAction

Members

Member Name | Description
Abort | The entire process will be aborted and the exception will be thrown.
Retry | Retry processing the item. A corrective action must be taken otherwise the same exception will be rethrown.
Ignore | Ignore the item that caused the error and continue processing the other items.

Requirements

Namespace: Xceed.FileSystem Namespace

Assembly: Xceed.FileSystem.dll

See Also

Xceed.FileSystem Namespace

Copyright 2000-2002 Xceed Software Inc.


ItemExceptionEventArgs Class

Argument class that provides information on the exception that was thrown during a process.

For a list of all members of this type, see ItemExceptionEventArgs Members.

System.Object
EventArgs
FileSystemEventArgs
ItemExceptionEventArgs

[Visual Basic]
Public Class ItemExceptionEventArgs
   Inherits FileSystemEventArgs
[C#]
public class ItemExceptionEventArgs : FileSystemEventArgs

Requirements

Namespace: Xceed.FileSystem Namespace

Assembly: Xceed.FileSystem.dll

See Also

ItemExceptionEventArgs Members | Xceed.FileSystem Namespace


ItemExceptionEventArgs Members

Public Instance Constructors

ItemExceptionEventArgs Constructor Creates a new instance of the ItemExceptionEventArgs argument class.

Public Instance Properties

Action | Gets or sets the action taken when an exception is thrown during the processing of a FileSystemItem object.
CurrentItem (inherited from FileSystemEventArgs) | Gets or sets the current FileSystemItem object being processed.
Exception | Gets or sets the exception that was thrown.
TargetItem (inherited from FileSystemEventArgs) | Gets or sets the destination FileSystemItem object.
UserData (inherited from FileSystemEventArgs) | Gets or sets the opaque data that will be sent back to the event handler whenever an event is raised.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Fields

m_action | An instance of the ItemExceptionAction class representing the action that will be taken in the OnItemException event handler.
m_currentItem |
m_exception | An instance of the Exception class representing the exception that was thrown and caused the OnItemException event to be raised.
m_targetItem |
m_userData |

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

ItemExceptionEventArgs Class | Xceed.FileSystem Namespace


ItemExceptionEventArgs Constructor

Creates a new instance of the ItemExceptionEventArgs argument class.

[Visual Basic]
Public Sub New()
[C#]
public ItemExceptionEventArgs();

See Also

ItemExceptionEventArgs Class | ItemExceptionEventArgs Members | Xceed.FileSystem Namespace


ItemExceptionEventArgs Fields

The fields of the ItemExceptionEventArgs class are listed below. For a complete list of ItemExceptionEventArgs class members, see the ItemExceptionEventArgs Members topic.

Protected Instance Fields

m_action | An instance of the ItemExceptionAction class representing the action that will be taken in the OnItemException event handler.
m_currentItem |
m_exception | An instance of the Exception class representing the exception that was thrown and caused the OnItemException event to be raised.
m_targetItem |
m_userData |

See Also

ItemExceptionEventArgs Class | Xceed.FileSystem Namespace


ItemExceptionEventArgs.m_action Field

An instance of the ItemExceptionAction class representing the action that will be taken in the OnItemException event handler.

[Visual Basic]
Protected m_action As Xceed.FileSystem.ItemExceptionAction
[C#]
protected ItemExceptionAction m_action;

See Also

ItemExceptionEventArgs Class | ItemExceptionEventArgs Members | Xceed.FileSystem Namespace


ItemExceptionEventArgs.m_currentItem Field

[Visual Basic]
Protected m_currentItem As Xceed.FileSystem.FileSystemItem
[C#]
protected FileSystemItem m_currentItem;

See Also

ItemExceptionEventArgs Class | ItemExceptionEventArgs Members | Xceed.FileSystem Namespace


ItemExceptionEventArgs.m_exception Field

An instance of the Exception class representing the exception that was thrown and caused the OnItemException event to be raised.

[Visual Basic]
Protected m_exception As System.Exception
[C#]
protected Exception m_exception;

See Also

ItemExceptionEventArgs Class | ItemExceptionEventArgs Members | Xceed.FileSystem Namespace


ItemExceptionEventArgs.m_targetItem Field

[Visual Basic]
Protected m_targetItem As Xceed.FileSystem.FileSystemItem
[C#]
protected FileSystemItem m_targetItem;

See Also

ItemExceptionEventArgs Class | ItemExceptionEventArgs Members | Xceed.FileSystem Namespace


ItemExceptionEventArgs.m_userData Field

[Visual Basic]
Protected m_userData As Object
[C#]
protected object m_userData;

See Also

ItemExceptionEventArgs Class | ItemExceptionEventArgs Members | Xceed.FileSystem Namespace


ItemExceptionEventArgs Properties

The properties of the ItemExceptionEventArgs class are listed below. For a complete list of ItemExceptionEventArgs class members, see the ItemExceptionEventArgs Members topic.

Public Instance Properties

Action | Gets or sets the action taken when an exception is thrown during the processing of a FileSystemItem object.
CurrentItem (inherited from FileSystemEventArgs) | Gets or sets the current FileSystemItem object being processed.
Exception | Gets or sets the exception that was thrown.
TargetItem (inherited from FileSystemEventArgs) | Gets or sets the destination FileSystemItem object.
UserData (inherited from FileSystemEventArgs) | Gets or sets the opaque data that will be sent back to the event handler whenever an event is raised.

See Also

ItemExceptionEventArgs Class | Xceed.FileSystem Namespace


ItemExceptionEventArgs.Action Property

Gets or sets the action taken when an exception is thrown during the processing of a FileSystemItem object.

[Visual Basic]
Public Property Action As Xceed.FileSystem.ItemExceptionAction
[C#]
public ItemExceptionAction Action {get; set;}

Property Value

A value indicating the action taken when an exception is thrown

See Also

ItemExceptionEventArgs Class | ItemExceptionEventArgs Members | Xceed.FileSystem Namespace


ItemExceptionEventArgs.Exception Property

Gets or sets the exception that was thrown.

[Visual Basic]
Public Property Exception As System.Exception
[C#]
public System.Exception Exception {get; set;}

Property Value

A reference to a FileSystemException object.

See Also

ItemExceptionEventArgs Class | ItemExceptionEventArgs Members | Xceed.FileSystem Namespace


ItemExceptionEventHandler Delegate

Represents the method that will handle the ItemException event.

[Visual Basic]
Public Delegate Sub ItemExceptionEventHandler( _
   ByVal sender As Object, _
   ByVal e As Xceed.FileSystem.ItemExceptionEventArgs _
)
[C#]
public delegate void ItemExceptionEventHandler(
   object sender,
   ItemExceptionEventArgs e
);

Parameters

sender

The FileSystemItem on which the method was called.

e

An instance of the ItemExceptionEventArgs argument class that contains progression information.

Requirements

Namespace: Xceed.FileSystem Namespace

Assembly: Xceed.FileSystem.dll

See Also

Xceed.FileSystem Namespace

Copyright 2000-2002 Xceed Software Inc.


ItemIsReadOnlyException Class

Exception that is thrown when performing an operation on a FileSystemItem object that is read only.

For a list of all members of this type, see ItemIsReadOnlyException Members.

System.Object
Exception
ApplicationException
FileSystemException
ItemIsReadOnlyException

[Visual Basic]
Public Class ItemIsReadOnlyException
   Inherits FileSystemException
   Implements ISerializable
[C#]
public class ItemIsReadOnlyException : FileSystemException, ISerializable

Requirements

Namespace: Xceed.FileSystem Namespace

Assembly: Xceed.FileSystem.dll

See Also

ItemIsReadOnlyException Members | Xceed.FileSystem Namespace


ItemIsReadOnlyException Members

Public Instance Constructors

ItemIsReadOnlyException Overloaded. Initialize a new instance of the ItemIsReadOnlyException class.

Public Instance Properties

HelpLink (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
InnerException (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
Item (inherited from FileSystemException) | Gets or sets the FileSystemItem object that caused the current exception.
Message (inherited from FileSystemException) | Gets a message that describes the current exception.
Source (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
StackTrace (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
TargetSite (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetBaseException (inherited from Exception) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetObjectData (inherited from Exception) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Exception) | Select the method name to go to the Microsoft documentation.

Protected Instance Properties

HResult (inherited from System.Exception) Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

ItemIsReadOnlyException Class | Xceed.FileSystem Namespace


ItemIsReadOnlyException Constructor

Xceed Zip for .NET

ItemIsReadOnlyException

Initializes a new instance of the exception with the specified FileSystemItem object.

Overload List

Initializes a new instance of the exception with the specified FileSystemItem object.

public ItemIsReadOnlyException(FileSystemItem);

Initializes a new instance of the exception with the specified message text and FileSystemItem object.

public ItemIsReadOnlyException(string,FileSystemItem);

Initializes a new instance of the exception with the specified FileSystemItem object and inner exception.

public ItemIsReadOnlyException(FileSystemItem,Exception);

Initializes a new instance of the exception with the specified message text, FileSystemItem object and inner exception.

public ItemIsReadOnlyException(string,FileSystemItem,Exception);

See Also

ItemIsReadOnlyException Class | ItemIsReadOnlyException Members | Xceed.FileSystem Namespace


ItemIsReadOnlyException Constructor (FileSystemItem)

Initializes a new instance of the exception with the specified FileSystemItem object.

[Visual Basic]
Overloads Public Sub New( _
   ByVal item As Xceed.FileSystem.FileSystemItem _
)
[C#]
public ItemIsReadOnlyException(
   FileSystemItem item
);

Parameters

item

The FileSystemItem object that caused the current exception.

See Also

ItemIsReadOnlyException Class | ItemIsReadOnlyException Members | Xceed.FileSystem Namespace | ItemIsReadOnlyException Constructor Overload List


ItemIsReadOnlyException Constructor (String, FileSystemItem)

Initializes a new instance of the exception with the specified message text and FileSystemItem object.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal item As Xceed.FileSystem.FileSystemItem _
)
[C#]
public ItemIsReadOnlyException(
   string message,
   FileSystemItem item
);

Parameters

message

The error message that explains the reason for the exception.

item

The FileSystemItem object that caused the current exception.

See Also

ItemIsReadOnlyException Class | ItemIsReadOnlyException Members | Xceed.FileSystem Namespace | ItemIsReadOnlyException Constructor Overload List


ItemIsReadOnlyException Constructor (FileSystemItem, Exception)

Initializes a new instance of the exception with the specified FileSystemItem object and inner exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal item As Xceed.FileSystem.FileSystemItem, _
   ByVal inner As System.Exception _
)
[C#]
public ItemIsReadOnlyException(
   FileSystemItem item,
   Exception inner
);

Parameters

item

The FileSystemItem object that caused the current exception.

inner

The exception that initially caused the current exception to be thrown.

See Also

ItemIsReadOnlyException Class | ItemIsReadOnlyException Members | Xceed.FileSystem Namespace | ItemIsReadOnlyException Constructor Overload List


ItemIsReadOnlyException Constructor (String, FileSystemItem, Exception)

Initializes a new instance of the exception with the specified message text, FileSystemItem object and inner exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal item As Xceed.FileSystem.FileSystemItem, _
   ByVal inner As System.Exception _
)
[C#]
public ItemIsReadOnlyException(
   string message,
   FileSystemItem item,
   Exception inner
);

Parameters

message

The error message that explains the reason for the exception.

item

The FileSystemItem object that caused the current exception.

inner

The exception that initially caused the current exception to be thrown.

See Also

ItemIsReadOnlyException Class | ItemIsReadOnlyException Members | Xceed.FileSystem Namespace | ItemIsReadOnlyException Constructor Overload List


ItemIsRootFolderException Class

Exception that is thrown when performing an illegal operation on a FileSystemItem object that is a root folder.

For a list of all members of this type, see ItemIsRootFolderException Members.

System.Object
Exception
ApplicationException
FileSystemException
ItemIsRootFolderException

[Visual Basic]
Public Class ItemIsRootFolderException
   Inherits FileSystemException
   Implements ISerializable
[C#]
public class ItemIsRootFolderException : FileSystemException, ISerializable

Requirements

Namespace: Xceed.FileSystem Namespace

Assembly: Xceed.FileSystem.dll

See Also

ItemIsRootFolderException Members | Xceed.FileSystem Namespace


ItemIsRootFolderException Members

Public Instance Constructors

ItemIsRootFolderException Overloaded. Initialize a new instance of the ItemIsRootFolderException class.

Public Instance Properties

HelpLink (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
InnerException (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
Item (inherited from FileSystemException) | Gets or sets the FileSystemItem object that caused the current exception.
Message (inherited from FileSystemException) | Gets a message that describes the current exception.
Source (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
StackTrace (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
TargetSite (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetBaseException (inherited from Exception) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetObjectData (inherited from Exception) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Exception) | Select the method name to go to the Microsoft documentation.

Protected Instance Properties

HResult (inherited from System.Exception) Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

ItemIsRootFolderException Class | Xceed.FileSystem Namespace


ItemIsRootFolderException Constructor

Xceed Zip for .NET

ItemIsRootFolderException

Initializes a new instance of the exception with the specified FileSystemItem object.

Overload List

Initializes a new instance of the exception with the specified FileSystemItem object.

public ItemIsRootFolderException(FileSystemItem);

Initializes a new instance of the exception with the specified message text and FileSystemItem object.

public ItemIsRootFolderException(string,FileSystemItem);

Initializes a new instance of the exception with the specified FileSystemItem object and inner exception.

public ItemIsRootFolderException(FileSystemItem,Exception);

Initializes a new instance of the exception with the specified message text, FileSystemItem object and inner exception.

public ItemIsRootFolderException(string,FileSystemItem,Exception);

See Also

ItemIsRootFolderException Class | ItemIsRootFolderException Members | Xceed.FileSystem Namespace


ItemIsRootFolderException Constructor (FileSystemItem)

Initializes a new instance of the exception with the specified FileSystemItem object.

[Visual Basic]
Overloads Public Sub New( _
   ByVal item As Xceed.FileSystem.FileSystemItem _
)
[C#]
public ItemIsRootFolderException(
   FileSystemItem item
);

Parameters

item

The FileSystemItem object that caused the current exception.

See Also

ItemIsRootFolderException Class | ItemIsRootFolderException Members | Xceed.FileSystem Namespace | ItemIsRootFolderException Constructor Overload List


ItemIsRootFolderException Constructor (String, FileSystemItem)

Initializes a new instance of the exception with the specified message text and FileSystemItem object.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal item As Xceed.FileSystem.FileSystemItem _
)
[C#]
public ItemIsRootFolderException(
   string message,
   FileSystemItem item
);

Parameters

message

The error message that explains the reason for the exception.

item

The FileSystemItem object that caused the current exception.

See Also

ItemIsRootFolderException Class | ItemIsRootFolderException Members | Xceed.FileSystem Namespace | ItemIsRootFolderException Constructor Overload List


ItemIsRootFolderException Constructor (FileSystemItem, Exception)

Initializes a new instance of the exception with the specified FileSystemItem object and inner exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal item As Xceed.FileSystem.FileSystemItem, _
   ByVal inner As System.Exception _
)
[C#]
public ItemIsRootFolderException(
   FileSystemItem item,
   Exception inner
);

Parameters

item

The FileSystemItem object that caused the current exception.

inner

The exception that initially caused the current exception to be thrown.

See Also

ItemIsRootFolderException Class | ItemIsRootFolderException Members | Xceed.FileSystem Namespace | ItemIsRootFolderException Constructor Overload List


ItemIsRootFolderException Constructor (String, FileSystemItem, Exception)

Initializes a new instance of the exception with the specified message text, FileSystemItem object and inner exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal item As Xceed.FileSystem.FileSystemItem, _
   ByVal inner As System.Exception _
)
[C#]
public ItemIsRootFolderException(
   string message,
   FileSystemItem item,
   Exception inner
);

Parameters

message

The error message that explains the reason for the exception.

item

The FileSystemItem object that caused the current exception.

inner

The exception that initially caused the current exception to be thrown.

See Also

ItemIsRootFolderException Class | ItemIsRootFolderException Members | Xceed.FileSystem Namespace | ItemIsRootFolderException Constructor Overload List


ItemPair Class

Represents a pair of FileSystemItem objects consisting of the item being processed and it's eventual target or destination item.

For a list of all members of this type, see ItemPair Members.

System.Object
ItemPair

[Visual Basic]
Public Class ItemPair
[C#]
public class ItemPair

Requirements

Namespace: Xceed.FileSystem Namespace

Assembly: Xceed.FileSystem.dll

See Also

ItemPair Members | Xceed.FileSystem Namespace


ItemPair Members

Public Instance Constructors

ItemPair Constructor Initializes an instance of the ItemPair class specifying the current and target items.

Public Instance Fields

current | The FileSystemItem object being procesed.
target | The eventual target or destination FileSystemItem object.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

ItemPair Class | Xceed.FileSystem Namespace


ItemPair Constructor

Initializes an instance of the ItemPair class specifying the current and target items.

[Visual Basic]
Public Sub New( _
   ByVal currentItem As Xceed.FileSystem.FileSystemItem, _
   ByVal targetItem As Xceed.FileSystem.FileSystemItem _
)
[C#]
public ItemPair(
   FileSystemItem currentItem,
   FileSystemItem targetItem
);

Parameters

currentItem

The current FileSystemItem object being processed.

targetItem

The eventual target or destination FileSystemItem object.

See Also

ItemPair Class | ItemPair Members | Xceed.FileSystem Namespace


ItemPair Fields

The fields of the ItemPair class are listed below. For a complete list of ItemPair class members, see the ItemPair Members topic.

Public Instance Fields

current | The FileSystemItem object being procesed.
target | The eventual target or destination FileSystemItem object.

See Also

ItemPair Class | Xceed.FileSystem Namespace


ItemPair.current Field

The FileSystemItem object being procesed.

[Visual Basic]
Public current As Xceed.FileSystem.FileSystemItem
[C#]
public FileSystemItem current;

See Also

ItemPair Class | ItemPair Members | Xceed.FileSystem Namespace


ItemPair.target Field

The eventual target or destination FileSystemItem object.

[Visual Basic]
Public target As Xceed.FileSystem.FileSystemItem
[C#]
public FileSystemItem target;

Remarks

Can be a null reference (Nothing in Visual Basic) in cases where there is no target, for example when calling the method.

See Also

ItemPair Class | ItemPair Members | Xceed.FileSystem Namespace


ItemProgressionEventArgs Class

Argument class that provides item progression information.

For a list of all members of this type, see ItemProgressionEventArgs Members.

System.Object
EventArgs
FileSystemEventArgs
ItemProgressionEventArgs

[Visual Basic]
Public Class ItemProgressionEventArgs
   Inherits FileSystemEventArgs
[C#]
public class ItemProgressionEventArgs : FileSystemEventArgs

Requirements

Namespace: Xceed.FileSystem Namespace

Assembly: Xceed.FileSystem.dll

See Also

ItemProgressionEventArgs Members | Xceed.FileSystem Namespace


ItemProgressionEventArgs Members

Public Instance Constructors

ItemProgressionEventArgs Constructor Creates an new instance of the ItemProgressionEventArgs argument class.

Public Instance Properties

AllItems | Gets the total number of items being processed.
CurrentItem (inherited from FileSystemEventArgs) | Gets or sets the current FileSystemItem object being processed.
TargetItem (inherited from FileSystemEventArgs) | Gets or sets the destination FileSystemItem object.
UserData (inherited from FileSystemEventArgs) | Gets or sets the opaque data that will be sent back to the event handler whenever an event is raised.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Fields

m_allItems | An instance of the ProgressionInfo class representing the item count information.
m_currentItem |
m_targetItem |
m_userData |

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

ItemProgressionEventArgs Class | Xceed.FileSystem Namespace


ItemProgressionEventArgs Constructor

Creates an new instance of the ItemProgressionEventArgs argument class.

[Visual Basic]
Public Sub New( _
   ByVal allItems As Xceed.FileSystem.ProgressionInfo _
)
[C#]
public ItemProgressionEventArgs(
   ProgressionInfo allItems
);

Parameters

allItems

The total number of items being processed.

See Also

ItemProgressionEventArgs Class | ItemProgressionEventArgs Members | Xceed.FileSystem Namespace


ItemProgressionEventArgs Fields

The fields of the ItemProgressionEventArgs class are listed below. For a complete list of ItemProgressionEventArgs class members, see the ItemProgressionEventArgs Members topic.

Protected Instance Fields

m_allItems | An instance of the ProgressionInfo class representing the item count information.
m_currentItem |
m_targetItem |
m_userData |

See Also

ItemProgressionEventArgs Class | Xceed.FileSystem Namespace


ItemProgressionEventArgs.m_allItems Field

An instance of the ProgressionInfo class representing the item count information.

[Visual Basic]
Protected m_allItems As Xceed.FileSystem.ProgressionInfo
[C#]
protected ProgressionInfo m_allItems;

See Also

ItemProgressionEventArgs Class | ItemProgressionEventArgs Members | Xceed.FileSystem Namespace


ItemProgressionEventArgs.m_currentItem Field

[Visual Basic]
Protected m_currentItem As Xceed.FileSystem.FileSystemItem
[C#]
protected FileSystemItem m_currentItem;

See Also

ItemProgressionEventArgs Class | ItemProgressionEventArgs Members | Xceed.FileSystem Namespace


ItemProgressionEventArgs.m_targetItem Field

[Visual Basic]
Protected m_targetItem As Xceed.FileSystem.FileSystemItem
[C#]
protected FileSystemItem m_targetItem;

See Also

ItemProgressionEventArgs Class | ItemProgressionEventArgs Members | Xceed.FileSystem Namespace


ItemProgressionEventArgs.m_userData Field

[Visual Basic]
Protected m_userData As Object
[C#]
protected object m_userData;

See Also

ItemProgressionEventArgs Class | ItemProgressionEventArgs Members | Xceed.FileSystem Namespace


ItemProgressionEventArgs Properties

The properties of the ItemProgressionEventArgs class are listed below. For a complete list of ItemProgressionEventArgs class members, see the ItemProgressionEventArgs Members topic.

Public Instance Properties

AllItems | Gets the total number of items being processed.
CurrentItem (inherited from FileSystemEventArgs) | Gets or sets the current FileSystemItem object being processed.
TargetItem (inherited from FileSystemEventArgs) | Gets or sets the destination FileSystemItem object.
UserData (inherited from FileSystemEventArgs) | Gets or sets the opaque data that will be sent back to the event handler whenever an event is raised.

See Also

ItemProgressionEventArgs Class | Xceed.FileSystem Namespace


ItemProgressionEventArgs.AllItems Property

Gets the total number of items being processed.

[Visual Basic]
Public ReadOnly Property AllItems As Xceed.FileSystem.ProgressionInfo
[C#]
public ProgressionInfo AllItems {get;}

Property Value

A value indicating the number if items being processed.

See Also

ItemProgressionEventArgs Class | ItemProgressionEventArgs Members | Xceed.FileSystem Namespace


ItemProgressionEventHandler Delegate

Represents the method that will handle the ItemProgression event.

[Visual Basic]
Public Delegate Sub ItemProgressionEventHandler( _
   ByVal sender As Object, _
   ByVal e As Xceed.FileSystem.ItemProgressionEventArgs _
)
[C#]
public delegate void ItemProgressionEventHandler(
   object sender,
   ItemProgressionEventArgs e
);

Parameters

sender

The FileSystemItem on which the method was called.

e

An instance of the ItemProgressionEventArgs argument class that contains progression information.

Requirements

Namespace: Xceed.FileSystem Namespace

Assembly: Xceed.FileSystem.dll

See Also

Xceed.FileSystem Namespace

Copyright 2000-2002 Xceed Software Inc.


Licenser Class

Class which is used to register the classes located in the Xceed.FileSystem namespace as described in the Licensing topic of the Xceed Zip for .NET documentation.

For a list of all members of this type, see Licenser Members.

System.Object
Licenser

[Visual Basic]
Public Class Licenser
[C#]
public class Licenser

Requirements

Namespace: Xceed.FileSystem Namespace

Assembly: Xceed.FileSystem.dll

See Also

Licenser Members | Xceed.FileSystem Namespace


Licenser Members

Public Static (Shared) Properties

LicenseKey Gets or sets the license key used to license this product.

Public Instance Constructors

Licenser Constructor Initializes a new instance of the Licenser class.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

Licenser Class | Xceed.FileSystem Namespace


Licenser Constructor

Initializes a new instance of the Licenser class.

[Visual Basic]
Public Sub New()
[C#]
public Licenser();

See Also

Licenser Class | Licenser Members | Xceed.FileSystem Namespace


Licenser Properties

The properties of the Licenser class are listed below. For a complete list of Licenser class members, see the Licenser Members topic.

Public Static (Shared) Properties

LicenseKey Gets or sets the license key used to license this product.

See Also

Licenser Class | Xceed.FileSystem Namespace


Licenser.LicenseKey Property

Gets or sets the license key used to license this product.

[Visual Basic]
Public Shared Property LicenseKey As String
[C#]
public static string LicenseKey {get; set;}

Property Value

A string value representing the license key used to license this product.

See Also

Licenser Class | Licenser Members | Xceed.FileSystem Namespace


NameFilter Class

Filters a FileSystemItem object based on its name.

For a list of all members of this type, see NameFilter Members.

System.Object
Filter
NameFilter

[Visual Basic]
Public Class NameFilter
   Inherits Filter
[C#]
public class NameFilter : Filter

Requirements

Namespace: Xceed.FileSystem Namespace

Assembly: Xceed.FileSystem.dll

See Also

NameFilter Members | Xceed.FileSystem Namespace


NameFilter Members

Public Instance Constructors

NameFilter Overloaded. Initialize a new instance of the NameFilter class.

Public Instance Properties

CaseSensitive | Gets a value indicating whether the file or folder name matching is case-sensitive.
Masks | Gets an array of string masks that are used to filter the files and folders.
Scope (inherited from Filter) | Gets or sets the scope of the filter.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsItemMatching | Gets a boolean value indicating if the item matches at least one of the name filters.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsItemInScope (inherited from Filter) |
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

NameFilter Class | Xceed.FileSystem Namespace


NameFilter Constructor

Xceed Zip for .NET

NameFilter

Initializes a new instance of the NameFilter class.

Overload List

Initializes a new instance of the NameFilter class.

public NameFilter(string);

Initializes a new instance of the NameFilter class.

public NameFilter(string,FilterScope);

See Also

NameFilter Class | NameFilter Members | Xceed.FileSystem Namespace


NameFilter Constructor (String)

Initializes a new instance of the NameFilter class.

[Visual Basic]
Overloads Public Sub New( _
   ByVal mask As String _
)
[C#]
public NameFilter(
   string mask
);

Parameters

mask

Mask to use to filter file names (e.g. "*.txt", "a??.txt", etc.)

Remarks

By default, the mask is not case sensitive. To make it case sensitive, just prepend '>' to the mask parameter.

See Also

NameFilter Class | NameFilter Members | Xceed.FileSystem Namespace | NameFilter Constructor Overload List


NameFilter Constructor (String, FilterScope)

Initializes a new instance of the NameFilter class.

[Visual Basic]
Overloads Public Sub New( _
   ByVal mask As String, _
   ByVal scope As Xceed.FileSystem.FilterScope _
)
[C#]
public NameFilter(
   string mask,
   FilterScope scope
);

Parameters

mask

Mask to use to filter file names (e.g. "*.txt", "a??.txt", etc.)

scope

Determines whether the scope applies to files, folders or both.

Remarks

By default, the mask is not case sensitive. To make it case sensitive, just prepend '>' to the mask parameter.

See Also

NameFilter Class | NameFilter Members | Xceed.FileSystem Namespace | NameFilter Constructor Overload List


NameFilter Properties

The properties of the NameFilter class are listed below. For a complete list of NameFilter class members, see the NameFilter Members topic.

Public Instance Properties

CaseSensitive | Gets a value indicating whether the file or folder name matching is case-sensitive.
Masks | Gets an array of string masks that are used to filter the files and folders.
Scope (inherited from Filter) | Gets or sets the scope of the filter.

See Also

NameFilter Class | Xceed.FileSystem Namespace


NameFilter.CaseSensitive Property

Gets a value indicating whether the file or folder name matching is case-sensitive.

[Visual Basic]
Public ReadOnly Property CaseSensitive As Boolean
[C#]
public bool CaseSensitive {get;}

Property Value

true if the file or folder name is case-sesitive; false otherwise.

See Also

NameFilter Class | NameFilter Members | Xceed.FileSystem Namespace


NameFilter.Masks Property

Gets an array of string masks that are used to filter the files and folders.

[Visual Basic]
Public ReadOnly Property Masks As System.Collections.IEnumerable
[C#]
public System.Collections.IEnumerable Masks {get;}

Property Value

An array of string masks.

See Also

NameFilter Class | NameFilter Members | Xceed.FileSystem Namespace


NameFilter Methods

The methods of the NameFilter class are listed below. For a complete list of NameFilter class members, see the NameFilter Members topic.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsItemMatching | Gets a boolean value indicating if the item matches at least one of the name filters.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsItemInScope (inherited from Filter) |
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

NameFilter Class | Xceed.FileSystem Namespace


NameFilter.IsItemMatching Method

Gets a boolean value indicating if the item matches at least one of the name filters.

[Visual Basic]
Overrides Public Function IsItemMatching( _
   ByVal item As Xceed.FileSystem.FileSystemItem _
) As Boolean
[C#]
public override bool IsItemMatching(
   FileSystemItem item
);

Parameters

item

The FileSystemItem object that will be verified.

Return Value

true if item matches at least one of the name filters; false otherwise.

See Also

NameFilter Class | NameFilter Members | Xceed.FileSystem Namespace


NotFilter Class

Performs a logical NOT operation on a Filter object.

For a list of all members of this type, see NotFilter Members.

System.Object
Filter
NotFilter

[Visual Basic]
Public Class NotFilter
   Inherits Filter
[C#]
public class NotFilter : Filter

Requirements

Namespace: Xceed.FileSystem Namespace

Assembly: Xceed.FileSystem.dll

See Also

NotFilter Members | Xceed.FileSystem Namespace


NotFilter Members

Public Instance Constructors

NotFilter Overloaded. Initialize a new instance of the NotFilter class.

Public Instance Properties

Filter | Gets the Filter object that is used for the logical NOT operation.
Scope (inherited from Filter) | Gets or sets the scope of the filter.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsItemMatching | Gets a boolean value indicating if the item does not match the filter.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsItemInScope (inherited from Filter) |
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

NotFilter Class | Xceed.FileSystem Namespace


NotFilter Constructor

Xceed Zip for .NET

NotFilter

Initializes a new instance of the NotFilter class.

Overload List

Initializes a new instance of the NotFilter class.

public NotFilter(object);

Initializes a new instance of the NotFilter class.

public NotFilter(Filter);

See Also

NotFilter Class | NotFilter Members | Xceed.FileSystem Namespace


NotFilter Constructor (Object)

Initializes a new instance of the NotFilter class.

[Visual Basic]
Overloads Public Sub New( _
   ByVal filter As Object _
)
[C#]
public NotFilter(
   object filter
);

Parameters

filter

Filter who's result must be inverted.

See Also

NotFilter Class | NotFilter Members | Xceed.FileSystem Namespace | NotFilter Constructor Overload List


NotFilter Constructor (Filter)

Initializes a new instance of the NotFilter class.

[Visual Basic]
Overloads Public Sub New( _
   ByVal filter As Xceed.FileSystem.Filter _
)
[C#]
public NotFilter(
   Filter filter
);

Parameters

filter

Filter who's result must be inverted.

See Also

NotFilter Class | NotFilter Members | Xceed.FileSystem Namespace | NotFilter Constructor Overload List


NotFilter Properties

The properties of the NotFilter class are listed below. For a complete list of NotFilter class members, see the NotFilter Members topic.

Public Instance Properties

Filter | Gets the Filter object that is used for the logical NOT operation.
Scope (inherited from Filter) | Gets or sets the scope of the filter.

See Also

NotFilter Class | Xceed.FileSystem Namespace


NotFilter.Filter Property

Gets the Filter object that is used for the logical NOT operation.

[Visual Basic]
Public ReadOnly Property Filter As Xceed.FileSystem.Filter
[C#]
public Filter Filter {get;}

Property Value

A reference to a Filter object.

See Also

NotFilter Class | NotFilter Members | Xceed.FileSystem Namespace | NotFilter.Filter Overload List


NotFilter Methods

The methods of the NotFilter class are listed below. For a complete list of NotFilter class members, see the NotFilter Members topic.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsItemMatching | Gets a boolean value indicating if the item does not match the filter.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsItemInScope (inherited from Filter) |
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

NotFilter Class | Xceed.FileSystem Namespace


NotFilter.IsItemMatching Method

Gets a boolean value indicating if the item does not match the filter.

[Visual Basic]
Overrides Public Function IsItemMatching( _
   ByVal item As Xceed.FileSystem.FileSystemItem _
) As Boolean
[C#]
public override bool IsItemMatching(
   FileSystemItem item
);

Parameters

item

The FileSystemItem object that will be verified.

Return Value

true if item does not match the filter; false otherwise.

See Also

NotFilter Class | NotFilter Members | Xceed.FileSystem Namespace


OrFilter Class

Performs a logical OR operation on a set of Filter objects.

For a list of all members of this type, see OrFilter Members.

System.Object
Filter
OrFilter

[Visual Basic]
Public Class OrFilter
   Inherits Filter
[C#]
public class OrFilter : Filter

Requirements

Namespace: Xceed.FileSystem Namespace

Assembly: Xceed.FileSystem.dll

See Also

OrFilter Members | Xceed.FileSystem Namespace


OrFilter Members

Public Instance Constructors

OrFilter Constructor Initializes a new instance of the OrFilter class.

Public Instance Properties

Filters | Gets an array of Filter objects that are part of the logical OR operation.
Scope (inherited from Filter) | Gets or sets the scope of the filter.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsItemMatching | Gets a boolean value indicating if the item matches at least one of the filters.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsItemInScope (inherited from Filter) |
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

OrFilter Class | Xceed.FileSystem Namespace


OrFilter Constructor

Initializes a new instance of the OrFilter class.

[Visual Basic]
Public Sub New( _
   ByVal filters As Object() _
)
[C#]
public OrFilter(
   params object[] filters
);

Parameters

filters

Filters that are part of the logical OR operation.

See Also

OrFilter Class | OrFilter Members | Xceed.FileSystem Namespace


OrFilter Properties

The properties of the OrFilter class are listed below. For a complete list of OrFilter class members, see the OrFilter Members topic.

Public Instance Properties

Filters | Gets an array of Filter objects that are part of the logical OR operation.
Scope (inherited from Filter) | Gets or sets the scope of the filter.

See Also

OrFilter Class | Xceed.FileSystem Namespace


OrFilter.Filters Property

Gets an array of Filter objects that are part of the logical OR operation.

[Visual Basic]
Public ReadOnly Property Filters As System.Collections.IEnumerable
[C#]
public System.Collections.IEnumerable Filters {get;}

Property Value

A reference to a Filter object.

See Also

OrFilter Class | OrFilter Members | Xceed.FileSystem Namespace


OrFilter Methods

The methods of the OrFilter class are listed below. For a complete list of OrFilter class members, see the OrFilter Members topic.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsItemMatching | Gets a boolean value indicating if the item matches at least one of the filters.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsItemInScope (inherited from Filter) |
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

OrFilter Class | Xceed.FileSystem Namespace


OrFilter.IsItemMatching Method

Gets a boolean value indicating if the item matches at least one of the filters.

[Visual Basic]
Overrides Public Function IsItemMatching( _
   ByVal item As Xceed.FileSystem.FileSystemItem _
) As Boolean
[C#]
public override bool IsItemMatching(
   FileSystemItem item
);

Parameters

item

The FileSystemItem object that will be verified.

Return Value

true if item matches at least one of the filters; false otherwise.

See Also

OrFilter Class | OrFilter Members | Xceed.FileSystem Namespace


ProgressionInfo Class

Class which provides progression information for progression events.

For a list of all members of this type, see ProgressionInfo Members.

System.Object
ProgressionInfo

[Visual Basic]
Public Class ProgressionInfo
[C#]
public class ProgressionInfo

Requirements

Namespace: Xceed.FileSystem Namespace

Assembly: Xceed.FileSystem.dll

See Also

ProgressionInfo Members | Xceed.FileSystem Namespace


ProgressionInfo Members

Public Instance Constructors

ProgressionInfo Constructor Creates a new instance of the ProgressionInfo class.

Public Instance Properties

Percent | Gets the ratio (percentage) of bytes or FileSystemItem objects processed so far.
Processed | Gets or sets the number of bytes or FileSystemItem objects processed so far.
Total | Gets or sets the total number of bytes or FileSystemItem objects to be processed.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Fields

m_processed | The amount of bytes or items processed.
m_total | The total amount of bytes or items to process.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

ProgressionInfo Class | Xceed.FileSystem Namespace


ProgressionInfo Constructor

Creates a new instance of the ProgressionInfo class.

[Visual Basic]
Public Sub New()
[C#]
public ProgressionInfo();

See Also

ProgressionInfo Class | ProgressionInfo Members | Xceed.FileSystem Namespace


ProgressionInfo Fields

The fields of the ProgressionInfo class are listed below. For a complete list of ProgressionInfo class members, see the ProgressionInfo Members topic.

Protected Instance Fields

m_processed | The amount of bytes or items processed.
m_total | The total amount of bytes or items to process.

See Also

ProgressionInfo Class | Xceed.FileSystem Namespace


ProgressionInfo.m_processed Field

The amount of bytes or items processed.

[Visual Basic]
Protected m_processed As Long
[C#]
protected long m_processed;

See Also

ProgressionInfo Class | ProgressionInfo Members | Xceed.FileSystem Namespace


ProgressionInfo.m_total Field

The total amount of bytes or items to process.

[Visual Basic]
Protected m_total As Long
[C#]
protected long m_total;

See Also

ProgressionInfo Class | ProgressionInfo Members | Xceed.FileSystem Namespace


ProgressionInfo Properties

The properties of the ProgressionInfo class are listed below. For a complete list of ProgressionInfo class members, see the ProgressionInfo Members topic.

Public Instance Properties

Percent | Gets the ratio (percentage) of bytes or FileSystemItem objects processed so far.
Processed | Gets or sets the number of bytes or FileSystemItem objects processed so far.
Total | Gets or sets the total number of bytes or FileSystemItem objects to be processed.

See Also

ProgressionInfo Class | Xceed.FileSystem Namespace


ProgressionInfo.Percent Property

Gets the ratio (percentage) of bytes or FileSystemItem objects processed so far.

[Visual Basic]
Public ReadOnly Property Percent As Byte
[C#]
public byte Percent {get;}

Property Value

A value indicating the ratio of bytes or FileSystemItem objects processed so far.

See Also

ProgressionInfo Class | ProgressionInfo Members | Xceed.FileSystem Namespace


ProgressionInfo.Processed Property

Gets or sets the number of bytes or FileSystemItem objects processed so far.

[Visual Basic]
Public Property Processed As Long
[C#]
public long Processed {get; set;}

Property Value

A value indicating the number of bytes or FileSystemItem objects processed so far.

See Also

ProgressionInfo Class | ProgressionInfo Members | Xceed.FileSystem Namespace


ProgressionInfo.Total Property

Gets or sets the total number of bytes or FileSystemItem objects to be processed.

[Visual Basic]
Public Property Total As Long
[C#]
public long Total {get; set;}

Property Value

A value indicating the number of bytes or FileSystemItem objects to be processed.

See Also

ProgressionInfo Class | ProgressionInfo Members | Xceed.FileSystem Namespace


ScanningFolderEventArgs Class

Argument class that provides information on the folder being scanned or accessed.

For a list of all members of this type, see ScanningFolderEventArgs Members.

System.Object
EventArgs
FileSystemEventArgs
ScanningFolderEventArgs

[Visual Basic]
Public Class ScanningFolderEventArgs
   Inherits FileSystemEventArgs
[C#]
public class ScanningFolderEventArgs : FileSystemEventArgs

Requirements

Namespace: Xceed.FileSystem Namespace

Assembly: Xceed.FileSystem.dll

See Also

ScanningFolderEventArgs Members | Xceed.FileSystem Namespace


ScanningFolderEventArgs Members

Public Instance Constructors

ScanningFolderEventArgs Constructor Creates a new instance of the ScanningFolderEventArgs argument class.

Public Instance Properties

CurrentItem (inherited from FileSystemEventArgs) | Gets or sets the current FileSystemItem object being processed.
TargetItem (inherited from FileSystemEventArgs) | Gets or sets the destination FileSystemItem object.
UserData (inherited from FileSystemEventArgs) | Gets or sets the opaque data that will be sent back to the event handler whenever an event is raised.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Fields

m_currentItem
m_targetItem
m_userData

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

ScanningFolderEventArgs Class | Xceed.FileSystem Namespace


ScanningFolderEventArgs Constructor

Creates a new instance of the ScanningFolderEventArgs argument class.

[Visual Basic]
Public Sub New()
[C#]
public ScanningFolderEventArgs();

See Also

ScanningFolderEventArgs Class | ScanningFolderEventArgs Members | Xceed.FileSystem Namespace


ScanningFolderEventArgs Fields

The fields of the ScanningFolderEventArgs class are listed below. For a complete list of ScanningFolderEventArgs class members, see the ScanningFolderEventArgs Members topic.

Protected Instance Fields

m_currentItem
m_targetItem
m_userData

See Also

ScanningFolderEventArgs Class | Xceed.FileSystem Namespace


ScanningFolderEventArgs.m_currentItem Field

[Visual Basic]
Protected m_currentItem As Xceed.FileSystem.FileSystemItem
[C#]
protected FileSystemItem m_currentItem;

See Also

ScanningFolderEventArgs Class | ScanningFolderEventArgs Members | Xceed.FileSystem Namespace


ScanningFolderEventArgs.m_targetItem Field

[Visual Basic]
Protected m_targetItem As Xceed.FileSystem.FileSystemItem
[C#]
protected FileSystemItem m_targetItem;

See Also

ScanningFolderEventArgs Class | ScanningFolderEventArgs Members | Xceed.FileSystem Namespace


ScanningFolderEventArgs.m_userData Field

[Visual Basic]
Protected m_userData As Object
[C#]
protected object m_userData;

See Also

ScanningFolderEventArgs Class | ScanningFolderEventArgs Members | Xceed.FileSystem Namespace


ScanningFolderEventHandler Delegate

Represents the method that will handle the ScanningFolder event.

[Visual Basic]
Public Delegate Sub ScanningFolderEventHandler( _
   ByVal sender As Object, _
   ByVal e As Xceed.FileSystem.ScanningFolderEventArgs _
)
[C#]
public delegate void ScanningFolderEventHandler(
   object sender,
   ScanningFolderEventArgs e
);

Parameters

sender

The FileSystemItem on which the method was called.

e

An instance of the ScanningFolderEventArgs argument class that contains progression information.

Requirements

Namespace: Xceed.FileSystem Namespace

Assembly: Xceed.FileSystem.dll

See Also

Xceed.FileSystem Namespace

Copyright 2000-2002 Xceed Software Inc.


SizeFilter Class

Filters a FileSystemItem object based on its size.

For a list of all members of this type, see SizeFilter Members.

System.Object
Filter
SizeFilter

[Visual Basic]
Public Class SizeFilter
   Inherits Filter
[C#]
public class SizeFilter : Filter

Requirements

Namespace: Xceed.FileSystem Namespace

Assembly: Xceed.FileSystem.dll

See Also

SizeFilter Members | Xceed.FileSystem Namespace


SizeFilter Members

Public Instance Constructors

SizeFilter Constructor Initializes a new instance of the SizeFilter class.

Public Instance Properties

MaxSize | Gets the maximum size value of the filter.
MinSize | Gets the minimum size value of the filter.
Scope (inherited from Filter) | Gets or sets the scope of the filter.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsItemMatching | Gets a boolean value indicating if the item matches the size filter.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsItemInScope (inherited from Filter) |
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

SizeFilter Class | Xceed.FileSystem Namespace


SizeFilter Constructor

Initializes a new instance of the SizeFilter class.

[Visual Basic]
Public Sub New( _
   ByVal minSize As Long, _
   ByVal maxSize As Long _
)
[C#]
public SizeFilter(
   long minSize,
   long maxSize
);

Parameters

minSize

A value that represents the minimum size of the filter.

maxSize

A value that represents the maximum size of the filter.

See Also

SizeFilter Class | SizeFilter Members | Xceed.FileSystem Namespace


SizeFilter Properties

The properties of the SizeFilter class are listed below. For a complete list of SizeFilter class members, see the SizeFilter Members topic.

Public Instance Properties

MaxSize | Gets the maximum size value of the filter.
MinSize | Gets the minimum size value of the filter.
Scope (inherited from Filter) | Gets or sets the scope of the filter.

See Also

SizeFilter Class | Xceed.FileSystem Namespace


SizeFilter.MaxSize Property

Gets the maximum size value of the filter.

[Visual Basic]
Public ReadOnly Property MaxSize As Long
[C#]
public long MaxSize {get;}

Property Value

The maximum size value, in bytes, of the filter.

See Also

SizeFilter Class | SizeFilter Members | Xceed.FileSystem Namespace


SizeFilter.MinSize Property

Gets the minimum size value of the filter.

[Visual Basic]
Public ReadOnly Property MinSize As Long
[C#]
public long MinSize {get;}

Property Value

The minimum size value, in bytes, of the filter.

See Also

SizeFilter Class | SizeFilter Members | Xceed.FileSystem Namespace


SizeFilter Methods

The methods of the SizeFilter class are listed below. For a complete list of SizeFilter class members, see the SizeFilter Members topic.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsItemMatching | Gets a boolean value indicating if the item matches the size filter.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsItemInScope (inherited from Filter) |
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

SizeFilter Class | Xceed.FileSystem Namespace


SizeFilter.IsItemMatching Method

Gets a boolean value indicating if the item matches the size filter.

[Visual Basic]
Overrides Public Function IsItemMatching( _
   ByVal item As Xceed.FileSystem.FileSystemItem _
) As Boolean
[C#]
public override bool IsItemMatching(
   FileSystemItem item
);

Parameters

item

The FileSystemItem object that will be verified.

Return Value

true if item matches the size filter; false otherwise.

See Also

SizeFilter Class | SizeFilter Members | Xceed.FileSystem Namespace


Xceed.FileSystemHierarchy

Xceed Zip for .NET

Xceed.FileSystem Hierarchy

System.Object
-EventArgs
-FileSystemEventArgs
-EventArgs
-FileSystemEventArgs
-ByteProgressionEventArgs
-EventArgs
-FileSystemEventArgs
-ItemProgressionEventArgs
-EventArgs
-FileSystemEventArgs
-ScanningFolderEventArgs
-EventArgs
-FileSystemEventArgs
-ItemExceptionEventArgs
-Exception
-ApplicationException
-FileSystemException
-Exception
-ApplicationException
-FileSystemException
-FileSystemInternalException
-Exception
-ApplicationException
-FileSystemException
-FileSystemIOException
-Exception
-ApplicationException
-FileSystemException
-FileSystemNotSupportedException
-Exception
-ApplicationException
-FileSystemException
-ItemAlreadyExistsException
-Exception
-ApplicationException
-FileSystemException
-ItemDoesNotExistException
-Exception
-ApplicationException
-FileSystemException
-ItemIsReadOnlyException
-Exception
-ApplicationException
-FileSystemException
-ItemIsRootFolderException
-FileSystemEvents
-FileSystemEventsSession
-Filter
-Filter
-AndFilter
-Filter
-AttributeFilter
-Filter
-DateTimeFilter
-Filter
-NameFilter
-Filter
-NotFilter
-Filter
-OrFilter
-Filter
-SizeFilter
-ItemPair
-Licenser
-MarshalByRefObject
-FileSystemItem
-MarshalByRefObject
-FileSystemItem
-AbstractFile
-MarshalByRefObject
-FileSystemItem
-AbstractFolder
-MarshalByRefObject
-AutoBatchUpdate
-MarshalByRefObject
-FileSystemItem
-AbstractFile
-DiskFile
-MarshalByRefObject
-FileSystemItem
-AbstractFolder
-DiskFolder
-ProgressionInfo

Interfaces

IBatchUpdateable

Copyright 2000-2002 Xceed Software Inc.


Xceed.Zip

Xceed Zip for .NET

Xceed.Zip Namespace

Namespace hierarchy

The Xceed.Zip namespace provides a specialization of the Xceed.FileSystem model for handling files and folders contained within ZIP files.

Classes

Class | Description
InvalidDecryptionPasswordException | Exception that is thrown when the data could not be decrypted with the supplied decryption password.
InvalidZipStructureException | Exception that is thrown when the internal structure of a ZIP file is invalid.
Licenser | Class which is used to register the classes located in the Xceed.Zip namespace as described in the Licensing topic of the Xceed Zip for .NET documentation.
QuickZip | Exposes static methods that allow basic zip file operations.
QuickZipException | Exception that is thrown when an error occurs in a method of the QuickZip class.
QuickZipItem | Represents an item located within a zip file and exposes properties that get information in regards to the item.
ZipArchive | Specialization of the ZippedFolder class that represents the root folder in a ZIP file, i.e. the ZIP file itself.
ZipEvents | Class that dispatches events associated with zip operations performed on ZippedFile, ZippedFolder or ZipArchive objects.
ZipEventsSession | Class which derives from the FileSystemEventsSession class and holds information about the session which is responsible for raising all events that occur during the process.
ZipException | Exception that is thrown when an error occurs in the Xceed.Zip namespace.
ZipIOException | Exception that is thrown when an IO exception occurs while reading from or writing to the ZIP file.
ZippedFile | Specialization of the AbstractFile class that implements access to a file stored within a ZIP file.
ZippedFolder | Specialization of the AbstractFolder class that implements access to a folder stored in a ZIP file.

Delegates

Delegate | Description
BuildingZipByteProgressionEventHandler | Represents the method that will handle the BuildingZipByteProgression event.
BuildingZipItemProgressionEventHandler | Represents the method that will handle the BuildingZipItemProgression event.
CopyingZipByteProgressionEventHandler | Represents the method that will handle the CopyingZipByteProgression event.
ReadingZipItemProgressionEventHandler | Represents the method that will handle the ReadingZipItemProgression event.


BuildingZipByteProgressionEventHandler Delegate

Represents the method that will handle the BuildingZipByteProgression event.

[Visual Basic]
Public Delegate Sub BuildingZipByteProgressionEventHandler( _
   ByVal sender As Object, _
   ByVal e As Xceed.FileSystem.ByteProgressionEventArgs _
)
[C#]
public delegate void BuildingZipByteProgressionEventHandler(
   object sender,
   ByteProgressionEventArgs e
);

Parameters

sender

The FileSystemItem on which the method was called.

e

An instance of the ByteProgressionEventArgs argument class that contains progression information.

Requirements

Namespace: Xceed.Zip Namespace

Assembly: Xceed.Zip.dll

See Also

Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


BuildingZipItemProgressionEventHandler Delegate

Represents the method that will handle the BuildingZipItemProgression event.

[Visual Basic]
Public Delegate Sub BuildingZipItemProgressionEventHandler( _
   ByVal sender As Object, _
   ByVal e As Xceed.FileSystem.ItemProgressionEventArgs _
)
[C#]
public delegate void BuildingZipItemProgressionEventHandler(
   object sender,
   ItemProgressionEventArgs e
);

Parameters

sender

The FileSystemItem on which the method was called.

e

An instance of the ItemProgressionEventArgs argument class that contains progression information.

Requirements

Namespace: Xceed.Zip Namespace

Assembly: Xceed.Zip.dll

See Also

Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


CopyingZipByteProgressionEventHandler Delegate

Represents the method that will handle the CopyingZipByteProgression event.

[Visual Basic]
Public Delegate Sub CopyingZipByteProgressionEventHandler( _
   ByVal sender As Object, _
   ByVal e As Xceed.FileSystem.ByteProgressionEventArgs _
)
[C#]
public delegate void CopyingZipByteProgressionEventHandler(
   object sender,
   ByteProgressionEventArgs e
);

Parameters

sender

The FileSystemItem on which the method was called.

e

An instance of the ByteProgressionEventArgs argument class that contains progression information.

Requirements

Namespace: Xceed.Zip Namespace

Assembly: Xceed.Zip.dll

See Also

Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


Xceed.ZipHierarchy

Xceed Zip for .NET

Xceed.Zip Hierarchy

System.Object
-Exception
-ApplicationException
-FileSystemException
-ZipException
-Exception
-ApplicationException
-FileSystemException
-ZipException
-InvalidDecryptionPasswordException
-Exception
-ApplicationException
-FileSystemException
-ZipException
-InvalidZipStructureException
-Exception
-ApplicationException
-QuickZipException
-Exception
-ApplicationException
-FileSystemException
-ZipException
-ZipIOException
-FileSystemEvents
-ZipEvents
-FileSystemEventsSession
-ZipEventsSession
-Licenser
-MarshalByRefObject
-FileSystemItem
-AbstractFolder
-ZippedFolder
-MarshalByRefObject
-FileSystemItem
-AbstractFolder
-ZippedFolder
-ZipArchive
-MarshalByRefObject
-FileSystemItem
-AbstractFile
-ZippedFile
-QuickZip
-QuickZipItem

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


InvalidDecryptionPasswordException Class

Exception that is thrown when the data could not be decrypted with the supplied decryption password.

For a list of all members of this type, see InvalidDecryptionPasswordException Members.

System.Object
Exception
ApplicationException
FileSystemException
ZipException
InvalidDecryptionPasswordException

[Visual Basic]
Public Class InvalidDecryptionPasswordException
   Inherits ZipException
   Implements ISerializable
[C#]
public class InvalidDecryptionPasswordException : ZipException, ISerializable

Remarks

The supplied password does not match the one that was used to originally encrypt the data.

Requirements

Namespace: Xceed.Zip Namespace

Assembly: Xceed.Zip.dll

See Also

InvalidDecryptionPasswordException Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


InvalidDecryptionPasswordException Constructor

Xceed Zip for .NET

InvalidDecryptionPasswordException

Initializes a new instance of the InvalidDecryptionPasswordException class.

Overload List

Initializes a new instance of the InvalidDecryptionPasswordException class.

public InvalidDecryptionPasswordException();

Initializes a new instance of the InvalidDecryptionPasswordException class with the specified message text.

public InvalidDecryptionPasswordException(string);

Initializes a new instance of the InvalidDecryptionPasswordException class with the specified AbstractFile object.

public InvalidDecryptionPasswordException(AbstractFile);

Initializes a new instance of the InvalidDecryptionPasswordException class with the specified message text and AbstractFile object.

public InvalidDecryptionPasswordException(string,AbstractFile);

Initializes a new instance of the InvalidDecryptionPasswordException class with the specified AbstractFile object and inner exception.

public InvalidDecryptionPasswordException(AbstractFile,Exception);

Initializes a new instance of the InvalidDecryptionPasswordException class with the specified message text, AbstractFile object and inner exception.

public InvalidDecryptionPasswordException(string,AbstractFile,Exception);

See Also

InvalidDecryptionPasswordException Class | InvalidDecryptionPasswordException Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


InvalidDecryptionPasswordException Constructor ()

Initializes a new instance of the InvalidDecryptionPasswordException class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public InvalidDecryptionPasswordException();

See Also

InvalidDecryptionPasswordException Class | InvalidDecryptionPasswordException Members | Xceed.Zip Namespace | InvalidDecryptionPasswordException Constructor Overload List

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


InvalidDecryptionPasswordException Constructor (String)

Initializes a new instance of the InvalidDecryptionPasswordException class with the specified message text.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public InvalidDecryptionPasswordException(
   string message
);

Parameters

message

The error message that explains the reason for the exception.

See Also

InvalidDecryptionPasswordException Class | InvalidDecryptionPasswordException Members | Xceed.Zip Namespace | InvalidDecryptionPasswordException Constructor Overload List

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


InvalidDecryptionPasswordException Constructor (AbstractFile)

Initializes a new instance of the InvalidDecryptionPasswordException class with the specified AbstractFile object.

[Visual Basic]
Overloads Public Sub New( _
   ByVal zipFile As Xceed.FileSystem.AbstractFile _
)
[C#]
public InvalidDecryptionPasswordException(
   AbstractFile zipFile
);

Parameters

zipFile

The AbstractFile object that caused the current exception.

See Also

InvalidDecryptionPasswordException Class | InvalidDecryptionPasswordException Members | Xceed.Zip Namespace | InvalidDecryptionPasswordException Constructor Overload List

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


InvalidDecryptionPasswordException Constructor (String, AbstractFile)

Initializes a new instance of the InvalidDecryptionPasswordException class with the specified message text and AbstractFile object.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal zipFile As Xceed.FileSystem.AbstractFile _
)
[C#]
public InvalidDecryptionPasswordException(
   string message,
   AbstractFile zipFile
);

Parameters

message

The error message that explains the reason for the exception.

zipFile

The AbstractFile object that caused the current exception.

See Also

InvalidDecryptionPasswordException Class | InvalidDecryptionPasswordException Members | Xceed.Zip Namespace | InvalidDecryptionPasswordException Constructor Overload List

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


InvalidDecryptionPasswordException Constructor (AbstractFile, Exception)

Initializes a new instance of the InvalidDecryptionPasswordException class with the specified AbstractFile object and inner exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal zipFile As Xceed.FileSystem.AbstractFile, _
   ByVal inner As System.Exception _
)
[C#]
public InvalidDecryptionPasswordException(
   AbstractFile zipFile,
   Exception inner
);

Parameters

zipFile

The AbstractFile object that caused the current exception.

inner

The exception that initially caused the current exception to be thrown.

See Also

InvalidDecryptionPasswordException Class | InvalidDecryptionPasswordException Members | Xceed.Zip Namespace | InvalidDecryptionPasswordException Constructor Overload List

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


InvalidDecryptionPasswordException Constructor (String, AbstractFile, Exception)

Initializes a new instance of the InvalidDecryptionPasswordException class with the specified message text, AbstractFile object and inner exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal zipFile As Xceed.FileSystem.AbstractFile, _
   ByVal inner As System.Exception _
)
[C#]
public InvalidDecryptionPasswordException(
   string message,
   AbstractFile zipFile,
   Exception inner
);

Parameters

message

The error message that explains the reason for the exception.

zipFile

The AbstractFile object that caused the current exception.

inner

The exception that initially caused the current exception to be thrown.

See Also

InvalidDecryptionPasswordException Class | InvalidDecryptionPasswordException Members | Xceed.Zip Namespace | InvalidDecryptionPasswordException Constructor Overload List

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


InvalidDecryptionPasswordException Members

Public Instance Constructors

InvalidDecryptionPasswordException Overloaded. Initialize a new instance of the InvalidDecryptionPasswordException class.

Public Instance Properties

HelpLink (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
InnerException (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
Item (inherited from FileSystemException) | Gets or sets the FileSystemItem object that caused the current exception.
Message (inherited from ZipException) | Gets a message that describes the current exception.
Source (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
StackTrace (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
TargetSite (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
ZipFile (inherited from ZipException) | Gets or sets an AbstractFile object representing the zip file in which the current exception occured.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetBaseException (inherited from Exception) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetObjectData (inherited from Exception) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Exception) | Select the method name to go to the Microsoft documentation.

Protected Instance Properties

HResult (inherited from System.Exception) Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

InvalidDecryptionPasswordException Class | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


InvalidZipStructureException Class

Exception that is thrown when the internal structure of a ZIP file is invalid.

For a list of all members of this type, see InvalidZipStructureException Members.

System.Object
Exception
ApplicationException
FileSystemException
ZipException
InvalidZipStructureException

[Visual Basic]
Public Class InvalidZipStructureException
   Inherits ZipException
   Implements ISerializable
[C#]
public class InvalidZipStructureException : ZipException, ISerializable

Remarks

This exception means that the ZIP file may be corrupted, or it may not be a ZIP file.

Requirements

Namespace: Xceed.Zip Namespace

Assembly: Xceed.Zip.dll

See Also

InvalidZipStructureException Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


InvalidZipStructureException Constructor

Xceed Zip for .NET

InvalidZipStructureException

Initializes a new instance of the InvalidZipStructureException class.

Overload List

Initializes a new instance of the InvalidZipStructureException class.

public InvalidZipStructureException();

Initializes a new instance of the InvalidZipStructureException class with the specified message text.

public InvalidZipStructureException(string);

Initializes a new instance of the InvalidZipStructureException class with the specified AbstractFile object.

public InvalidZipStructureException(AbstractFile);

Initializes a new instance of the InvalidZipStructureException class with the specified message text and AbstractFile object.

public InvalidZipStructureException(string,AbstractFile);

Initializes a new instance of the InvalidZipStructureException class with the specified AbstractFile object and inner exception.

public InvalidZipStructureException(AbstractFile,Exception);

Initializes a new instance of the InvalidZipStructureException class with the specified message text, AbstractFile object and inner exception.

public InvalidZipStructureException(string,AbstractFile,Exception);

See Also

InvalidZipStructureException Class | InvalidZipStructureException Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


InvalidZipStructureException Constructor ()

Initializes a new instance of the InvalidZipStructureException class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public InvalidZipStructureException();

See Also

InvalidZipStructureException Class | InvalidZipStructureException Members | Xceed.Zip Namespace | InvalidZipStructureException Constructor Overload List

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


InvalidZipStructureException Constructor (String)

Initializes a new instance of the InvalidZipStructureException class with the specified message text.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public InvalidZipStructureException(
   string message
);

Parameters

message

The error message that explains the reason for the exception.

See Also

InvalidZipStructureException Class | InvalidZipStructureException Members | Xceed.Zip Namespace | InvalidZipStructureException Constructor Overload List

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


InvalidZipStructureException Constructor (AbstractFile)

Initializes a new instance of the InvalidZipStructureException class with the specified AbstractFile object.

[Visual Basic]
Overloads Public Sub New( _
   ByVal zipFile As Xceed.FileSystem.AbstractFile _
)
[C#]
public InvalidZipStructureException(
   AbstractFile zipFile
);

Parameters

zipFile

The AbstractFile object that caused the current exception.

See Also

InvalidZipStructureException Class | InvalidZipStructureException Members | Xceed.Zip Namespace | InvalidZipStructureException Constructor Overload List

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


InvalidZipStructureException Constructor (String, AbstractFile)

Initializes a new instance of the InvalidZipStructureException class with the specified message text and AbstractFile object.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal zipFile As Xceed.FileSystem.AbstractFile _
)
[C#]
public InvalidZipStructureException(
   string message,
   AbstractFile zipFile
);

Parameters

message

The error message that explains the reason for the exception.

zipFile

The AbstractFile object that caused the current exception.

See Also

InvalidZipStructureException Class | InvalidZipStructureException Members | Xceed.Zip Namespace | InvalidZipStructureException Constructor Overload List

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


InvalidZipStructureException Constructor (AbstractFile, Exception)

Initializes a new instance of the InvalidZipStructureException class with the specified AbstractFile object and inner exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal zipFile As Xceed.FileSystem.AbstractFile, _
   ByVal inner As System.Exception _
)
[C#]
public InvalidZipStructureException(
   AbstractFile zipFile,
   Exception inner
);

Parameters

zipFile

The AbstractFile object that caused the current exception.

inner

The exception that initially caused the current exception to be thrown.

See Also

InvalidZipStructureException Class | InvalidZipStructureException Members | Xceed.Zip Namespace | InvalidZipStructureException Constructor Overload List

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


InvalidZipStructureException Constructor (String, AbstractFile, Exception)

Initializes a new instance of the InvalidZipStructureException class with the specified message text, AbstractFile object and inner exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal zipFile As Xceed.FileSystem.AbstractFile, _
   ByVal inner As System.Exception _
)
[C#]
public InvalidZipStructureException(
   string message,
   AbstractFile zipFile,
   Exception inner
);

Parameters

message

The error message that explains the reason for the exception.

zipFile

The AbstractFile object that caused the current exception.

inner

The exception that initially caused the current exception to be thrown.

See Also

InvalidZipStructureException Class | InvalidZipStructureException Members | Xceed.Zip Namespace | InvalidZipStructureException Constructor Overload List

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


InvalidZipStructureException Members

Public Instance Constructors

InvalidZipStructureException Overloaded. Initialize a new instance of the InvalidZipStructureException class.

Public Instance Properties

HelpLink (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
InnerException (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
Item (inherited from FileSystemException) | Gets or sets the FileSystemItem object that caused the current exception.
Message (inherited from ZipException) | Gets a message that describes the current exception.
Source (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
StackTrace (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
TargetSite (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
ZipFile (inherited from ZipException) | Gets or sets an AbstractFile object representing the zip file in which the current exception occured.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetBaseException (inherited from Exception) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetObjectData (inherited from Exception) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Exception) | Select the method name to go to the Microsoft documentation.

Protected Instance Properties

HResult (inherited from System.Exception) Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

InvalidZipStructureException Class | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


Licenser Class

Class which is used to register the classes located in the Xceed.Zip namespace as described in the Licensing topic of the Xceed Zip for .NET documentation.

For a list of all members of this type, see Licenser Members.

System.Object
Licenser

[Visual Basic]
Public Class Licenser
[C#]
public class Licenser

Requirements

Namespace: Xceed.Zip Namespace

Assembly: Xceed.Zip.dll

See Also

Licenser Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


Licenser Constructor

Initializes a new instance of the Licenser class.

[Visual Basic]
Public Sub New()
[C#]
public Licenser();

See Also

Licenser Class | Licenser Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


Licenser.LicenseKey Property

Gets or sets the license key used to license this product.

[Visual Basic]
Public Shared Property LicenseKey As String
[C#]
public static string LicenseKey {get; set;}

Property Value

A string value representing the license key used to license this product.

See Also

Licenser Class | Licenser Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


Licenser Members

Public Static (Shared) Properties

LicenseKey Gets or sets the license key used to license this product.

Public Instance Constructors

Licenser Constructor Initializes a new instance of the Licenser class.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

Licenser Class | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


Licenser Properties

The properties of the Licenser class are listed below. For a complete list of Licenser class members, see the Licenser Members topic.

Public Static (Shared) Properties

LicenseKey Gets or sets the license key used to license this product.

See Also

Licenser Class | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


QuickZip Class

Exposes static methods that allow basic zip file operations.

For a list of all members of this type, see QuickZip Members.

System.Object
QuickZip

[Visual Basic]
Public Class QuickZip
[C#]
public class QuickZip

Requirements

Namespace: Xceed.Zip Namespace

Assembly: Xceed.Zip.dll

See Also

QuickZip Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


QuickZip Constructor

[Visual Basic]
Private Sub New()
[C#]
private QuickZip();

See Also

QuickZip Class | QuickZip Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


QuickZipException Class

Exception that is thrown when an error occurs in a method of the QuickZip class.

For a list of all members of this type, see QuickZipException Members.

System.Object
Exception
ApplicationException
QuickZipException

[Visual Basic]
Public Class QuickZipException
   Inherits ApplicationException
   Implements ISerializable
[C#]
public class QuickZipException : ApplicationException, ISerializable

Requirements

Namespace: Xceed.Zip Namespace

Assembly: Xceed.Zip.dll

See Also

QuickZipException Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


QuickZipException Constructor

Xceed Zip for .NET

QuickZipException

Initializes a new instance of the QuickZipException class with the specified message text.

Overload List

Initializes a new instance of the QuickZipException class with the specified message text.

public QuickZipException(string);

Initializes a new instance of the QuickZipException class with specified message text and inner exception.

public QuickZipException(string,Exception);

See Also

QuickZipException Class | QuickZipException Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


QuickZipException Constructor (String)

Initializes a new instance of the QuickZipException class with the specified message text.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public QuickZipException(
   string message
);

Parameters

message

The error message that explains the reason for the exception.

See Also

QuickZipException Class | QuickZipException Members | Xceed.Zip Namespace | QuickZipException Constructor Overload List

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


QuickZipException Constructor (String, Exception)

Initializes a new instance of the QuickZipException class with specified message text and inner exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal inner As System.Exception _
)
[C#]
public QuickZipException(
   string message,
   Exception inner
);

Parameters

message

The error message that explains the reason for the exception.

inner

The exception that initially caused the current exception to be thrown.

See Also

QuickZipException Class | QuickZipException Members | Xceed.Zip Namespace | QuickZipException Constructor Overload List

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


QuickZipException Members

Public Instance Constructors

QuickZipException Overloaded. Initialize a new instance of the QuickZipException class.

Public Instance Properties

HelpLink (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
InnerException (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
Message (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
Source (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
StackTrace (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
TargetSite (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetBaseException (inherited from Exception) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetObjectData (inherited from Exception) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Exception) | Select the method name to go to the Microsoft documentation.

Protected Instance Properties

HResult (inherited from System.Exception) Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

QuickZipException Class | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


QuickZip.GetZipContents Method

Gets the content of a zip file.

[Visual Basic]
Public Shared Function GetZipContents( _
   ByVal zipFileName As String, _
   ByVal fileMasks As String() _
) As Xceed.Zip.QuickZipItem()
[C#]
public static QuickZipItem[] GetZipContents(
   string zipFileName,
   params string[] fileMasks
);

Parameters

zipFileName

The fully-qualified path and name of the zip file.

fileMasks

The string masks that are used to filter the files.

Return Value

An array of QuickZipItem objects that contain information regarding each file retrieved.

Remarks

Zip files are case sensitive therefore the string passed in the fileMasks parameter, will be used "as-is".

For example, if a zip file contains a file named "FILE.TXT" and "file.txt" is passed to the fileMasks parameter, "FILE.TXT" will not be retrieved.

See Also

QuickZip Class | QuickZip Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


QuickZipItem Class

Represents an item located within a zip file and exposes properties that get information in regards to the item.

For a list of all members of this type, see QuickZipItem Members.

System.Object
QuickZipItem

[Visual Basic]
Public Class QuickZipItem
[C#]
public class QuickZipItem

Requirements

Namespace: Xceed.Zip Namespace

Assembly: Xceed.Zip.dll

See Also

QuickZipItem Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


QuickZipItem.Attributes Property

Gets the attributes of the file.

[Visual Basic]
Public ReadOnly Property Attributes As System.IO.FileAttributes
[C#]
public System.IO.FileAttributes Attributes {get;}

Property Value

A combination of System.IO.FileAttributes values that represent the attributes of the file.

See Also

QuickZipItem Class | QuickZipItem Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


QuickZipItem.Comment Property

Gets the comment of the file.

[Visual Basic]
Public ReadOnly Property Comment As String
[C#]
public string Comment {get;}

Property Value

A value that represents the comment of the file.

See Also

QuickZipItem Class | QuickZipItem Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


QuickZipItem.CompressedSize Property

Gets the compressed size of the file in bytes.

[Visual Basic]
Public ReadOnly Property CompressedSize As Long
[C#]
public long CompressedSize {get;}

Property Value

A value representing the compressed size of the file in bytes.

See Also

QuickZipItem Class | QuickZipItem Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


QuickZipItem.CompressionMethod Property

Gets the Xceed.Compression.CompressionMethod used to compress the file.

[Visual Basic]
Public ReadOnly Property CompressionMethod As Xceed.Compression.CompressionMethod
[C#]
public Xceed.Compression.CompressionMethod CompressionMethod {get;}

Property Value

A value representing the Xceed.Compression.CompressionMethod used to compress the file.

See Also

QuickZipItem Class | QuickZipItem Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


QuickZipItem.CompressionRatio Property

Gets the compression ratio of the file.

[Visual Basic]
Public ReadOnly Property CompressionRatio As Byte
[C#]
public byte CompressionRatio {get;}

Property Value

A value representing the compression ratio achieved for the file in percentage (%).

See Also

QuickZipItem Class | QuickZipItem Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


QuickZipItem Constructor

[Visual Basic]
Friend Sub New( _
   ByVal zippedFile As Xceed.Zip.ZippedFile _
)
[C#]
internal QuickZipItem(
   ZippedFile zippedFile
);

See Also

QuickZipItem Class | QuickZipItem Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


QuickZipItem.Crc32 Property

Gets the checksum of the file.

[Visual Basic]
Public ReadOnly Property Crc32 As Integer
[C#]
public int Crc32 {get;}

Property Value

A value representing the checksum of the file.

See Also

QuickZipItem Class | QuickZipItem Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


QuickZipItem.CreationDateTime Property

Gets the creation date and time of the file.

[Visual Basic]
Public ReadOnly Property CreationDateTime As Date
[C#]
public System.DateTime CreationDateTime {get;}

Property Value

A value representing the date and time when the file was created.

See Also

QuickZipItem Class | QuickZipItem Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


QuickZipItem.Encrypted Property

Gets a value indicating if the file is encrypted.

[Visual Basic]
Public ReadOnly Property Encrypted As Boolean
[C#]
public bool Encrypted {get;}

Property Value

A boolean value indicating if the file is encrypted.

Remarks

Returns true if the file is encrypted; false otherwise.

See Also

QuickZipItem Class | QuickZipItem Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


QuickZipItem.FullName Property

Gets the full name of the file.

[Visual Basic]
Public ReadOnly Property FullName As String
[C#]
public string FullName {get;}

Property Value

A string that represents the full name of the file.

Remarks

The full name consists of the file's name fully-qualified with a path. For example: "\foo\bar.txt".

See Also

QuickZipItem Class | QuickZipItem Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


QuickZipItem.LastAccessDateTime Property

Gets the last access date and time of the file.

[Visual Basic]
Public ReadOnly Property LastAccessDateTime As Date
[C#]
public System.DateTime LastAccessDateTime {get;}

Property Value

A value representing the date and time when the file was last accessed.

See Also

QuickZipItem Class | QuickZipItem Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


QuickZipItem.LastWriteDateTime Property

Gets the modification date and time of the file.

[Visual Basic]
Public ReadOnly Property LastWriteDateTime As Date
[C#]
public System.DateTime LastWriteDateTime {get;}

Property Value

A value representing the date and time when the file was modified.

See Also

QuickZipItem Class | QuickZipItem Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


QuickZipItem Members

Public Instance Properties

Attributes | Gets the attributes of the file.
Comment | Gets the comment of the file.
CompressedSize | Gets the compressed size of the file in bytes.
CompressionMethod | Gets the Xceed.Compression.CompressionMethod used to compress the file.
CompressionRatio | Gets the compression ratio of the file.
Crc32 | Gets the checksum of the file.
CreationDateTime | Gets the creation date and time of the file.
Encrypted | Gets a value indicating if the file is encrypted.
FullName | Gets the full name of the file.
LastAccessDateTime | Gets the last access date and time of the file.
LastWriteDateTime | Gets the modification date and time of the file.
Name | Gets the short name of the file.
Size | Gets the uncompressed size of the file in bytes.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

Internal Instance Constructors

QuickZipItem Constructor

See Also

QuickZipItem Class | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


QuickZipItem.Name Property

Gets the short name of the file.

[Visual Basic]
Public ReadOnly Property Name As String
[C#]
public string Name {get;}

Property Value

A string that represents the short name of the file.

Remarks

The short name consists of the file's name without a path.

For example, the short name of a file named "\foo\bar.txt" is "bar.txt".

See Also

QuickZipItem Class | QuickZipItem Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


QuickZipItem Properties

The properties of the QuickZipItem class are listed below. For a complete list of QuickZipItem class members, see the QuickZipItem Members topic.

Public Instance Properties

Attributes | Gets the attributes of the file.
Comment | Gets the comment of the file.
CompressedSize | Gets the compressed size of the file in bytes.
CompressionMethod | Gets the Xceed.Compression.CompressionMethod used to compress the file.
CompressionRatio | Gets the compression ratio of the file.
Crc32 | Gets the checksum of the file.
CreationDateTime | Gets the creation date and time of the file.
Encrypted | Gets a value indicating if the file is encrypted.
FullName | Gets the full name of the file.
LastAccessDateTime | Gets the last access date and time of the file.
LastWriteDateTime | Gets the modification date and time of the file.
Name | Gets the short name of the file.
Size | Gets the uncompressed size of the file in bytes.

See Also

QuickZipItem Class | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


QuickZipItem.Size Property

Gets the uncompressed size of the file in bytes.

[Visual Basic]
Public ReadOnly Property Size As Long
[C#]
public long Size {get;}

Property Value

A value representing the uncompressed size of the file in bytes.

See Also

QuickZipItem Class | QuickZipItem Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


QuickZip Members

Public Static (Shared) Methods

GetZipContents | Gets the content of a zip file.
Remove | Overloaded. Removes files from a zip file.
Unzip | Overloaded. Extracts files from a zip file overwriting existing files and restoring the directory structure.
Zip | Overloaded. Adds files to a zip file overwriting existing files and preserving the directory structure.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

Private Instance Constructors

QuickZip Constructor

See Also

QuickZip Class | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


QuickZip Methods

The methods of the QuickZip class are listed below. For a complete list of QuickZip class members, see the QuickZip Members topic.

Public Static (Shared) Methods

GetZipContents | Gets the content of a zip file.
Remove | Overloaded.
Unzip | Overloaded.
Zip | Overloaded.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

QuickZip Class | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


Remove Method

Xceed Zip for .NET

QuickZip.Remove

Removes files from a zip file specifying if files contained within sub-folders will also be removed.

Overload List

Removes files from a zip file.

public static void Remove(string,params string[]);

Removes files from a zip file specifying if files contained within sub-folders will also be removed.

public static void Remove(string,bool,params string[]);

See Also

QuickZip Class | QuickZip Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


QuickZip.Remove Method (String, String[])

Removes files from a zip file.

[Visual Basic]
Overloads Public Shared Sub Remove( _
   ByVal zipFileName As String, _
   ByVal filesToRemove As String() _
)
[C#]
public static void Remove(
   string zipFileName,
   params string[] filesToRemove
);

Parameters

zipFileName

The fully-qualified path and name of the zip file.

filesToRemove

The files to remove from zipFilename. Cannot be a null reference (Nothing in Visual Basic).

Remarks

Note that files contained within sub-folders will also be removed from the zip file.

Zip files are case sensitive therefore the string passed in the filesToRemove parameter, will be used "as-is".

For example, if a zip file contains a file named "FILE.TXT" and "file.txt" is passed to the filesToRemove parameter, "FILE.TXT" will not be removed.

See Also

QuickZip Class | QuickZip Members | Xceed.Zip Namespace | QuickZip.Remove Overload List

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


QuickZip.Remove Method (String, Boolean, String[])

Removes files from a zip file specifying if files contained within sub-folders will also be removed.

[Visual Basic]
Overloads Public Shared Sub Remove( _
   ByVal zipFileName As String, _
   ByVal recursive As Boolean, _
   ByVal filesToRemove As String() _
)
[C#]
public static void Remove(
   string zipFileName,
   bool recursive,
   params string[] filesToRemove
);

Parameters

zipFileName

The fully-qualified path and name of the zip file.

recursive

Boolean value indicating if files contained within sub-folders should be removed from the zip file.

filesToRemove

The files to remove from zipFilename. Cannot be a null reference (Nothing in Visual Basic).

Remarks

Zip files are case sensitive therefore the string passed in the filesToRemove parameter, will be used "as-is".

For example, if a zip file contains a file named "FILE.TXT" and "file.txt" is passed to the filesToRemove parameter, "FILE.TXT" will not be removed.

See Also

QuickZip Class | QuickZip Members | Xceed.Zip Namespace | QuickZip.Remove Overload List

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


Unzip Method

Xceed Zip for .NET

QuickZip.Unzip

Extracts files from a zip file specifying whether existing files will be overwritten and if the directory structure will be restored.

Overload List

Extracts files from a zip file overwriting existing files and restoring the directory structure.

public static void Unzip(string,string,params string[]);

Extracts files from a zip file specifying whether existing files will be overwritten and if the directory structure will be restored.

public static void Unzip(string,string,bool,bool,bool,params string[]);

Extracts files from a zip file providing a decryption password and specifying whether existing files will be overwritten and if the directory structure will be restored.

public static void Unzip(string,string,string,bool,bool,bool,params string[]);

See Also

QuickZip Class | QuickZip Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


QuickZip.Unzip Method (String, String, String[])

Extracts files from a zip file overwriting existing files and restoring the directory structure.

[Visual Basic]
Overloads Public Shared Sub Unzip( _
   ByVal zipFileName As String, _
   ByVal destinationFolder As String, _
   ByVal filesToUnzip As String() _
)
[C#]
public static void Unzip(
   string zipFileName,
   string destinationFolder,
   params string[] filesToUnzip
);

Parameters

zipFileName

The fully-qualified path and name of the zip file.

destinationFolder

The destination folder to where the files will be extracted.

filesToUnzip

The files to extract from zipFilename. Cannot be a null reference (Nothing in Visual Basic).

Remarks

Note that existing files will be overwritten, files contained within sub-folders will be extracted and the directory structure will be restored in the destination folder.

Zip files are case sensitive therefore the string passed in the filesToUnzip parameter, will be used "as-is".

For example, if a zip file contains a file named "FILE.TXT" and "file.txt" is passed to the filesToUnzip parameter, "FILE.TXT" will not be extracted.

See Also

QuickZip Class | QuickZip Members | Xceed.Zip Namespace | QuickZip.Unzip Overload List

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


QuickZip.Unzip Method (String, String, Boolean, Boolean, Boolean, String[])

Extracts files from a zip file specifying whether existing files will be overwritten and if the directory structure will be restored.

[Visual Basic]
Overloads Public Shared Sub Unzip( _
   ByVal zipFileName As String, _
   ByVal destinationFolder As String, _
   ByVal replaceExistingFiles As Boolean, _
   ByVal recursive As Boolean, _
   ByVal preservePaths As Boolean, _
   ByVal filesToUnzip As String() _
)
[C#]
public static void Unzip(
   string zipFileName,
   string destinationFolder,
   bool replaceExistingFiles,
   bool recursive,
   bool preservePaths,
   params string[] filesToUnzip
);

Parameters

zipFileName

The fully-qualified path and name of the zip file.

destinationFolder

The destination folder to where the files will be extracted.

replaceExistingFiles

Boolean value indicating if existing files should be overwritten.

recursive

Boolean value indicating if files contained within sub-folders should be extracted from the zip file.

preservePaths

Boolean value indicating if the directory structure should be preserved in the destination folder.

filesToUnzip

The files to extract from zipFilename. Cannot be a null reference (Nothing in Visual Basic).

Remarks

Zip files are case sensitive therefore the string passed in the filesToUnzip parameter, will be used "as-is".

For example, if a zip file contains a file named "FILE.TXT" and "file.txt" is passed to the filesToUnzip parameter, "FILE.TXT" will not be extracted.

See Also

QuickZip Class | QuickZip Members | Xceed.Zip Namespace | QuickZip.Unzip Overload List

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


QuickZip.Unzip Method (String, String, String, Boolean, Boolean, Boolean, String[])

Extracts files from a zip file providing a decryption password and specifying whether existing files will be overwritten and if the directory structure will be restored.

[Visual Basic]
Overloads Public Shared Sub Unzip( _
   ByVal zipFileName As String, _
   ByVal destinationFolder As String, _
   ByVal decryptionPassword As String, _
   ByVal replaceExistingFiles As Boolean, _
   ByVal recursive As Boolean, _
   ByVal preservePaths As Boolean, _
   ByVal filesToUnzip As String() _
)
[C#]
public static void Unzip(
   string zipFileName,
   string destinationFolder,
   string decryptionPassword,
   bool replaceExistingFiles,
   bool recursive,
   bool preservePaths,
   params string[] filesToUnzip
);

Parameters

zipFileName

The fully-qualified path and name of the zip file.

destinationFolder

The destination folder to where the files will be extracted.

decryptionPassword

The password that will be used to decrypt the files.

replaceExistingFiles

Boolean value indicating if existing files should be overwritten.

recursive

Boolean value indicating if files contained within sub-folders should be extracted from the zip file.

preservePaths

Boolean value indicating if the directory structure should be preserved in the destination folder.

filesToUnzip

The files to extract from zipFilename. Cannot be a null reference (Nothing in Visual Basic).

Remarks

Zip files are case sensitive therefore the string passed in the filesToUnzip parameter, will be used "as-is".

For example, if a zip file contains a file named "FILE.TXT" and "file.txt" is passed to the filesToUnzip parameter, "FILE.TXT" will not be extracted.

See Also

QuickZip Class | QuickZip Members | Xceed.Zip Namespace | QuickZip.Unzip Overload List

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


Zip Method

Xceed Zip for .NET

QuickZip.Zip

Adds files to a zip file specifying whether existing files will be overwritten and if the directory structure will be preserved.

Overload List

Adds files to a zip file overwriting existing files and preserving the directory structure.

public static void Zip(string,params string[]);

Adds files to a zip file specifying whether existing files will be overwritten and if the directory structure will be preserved.

public static void Zip(string,bool,bool,bool,params string[]);

Adds files to a zip file using an encryption password and specifying whether existing files will be overwritten and if the directory structure will be preserved.

public static void Zip(string,string,bool,bool,bool,params string[]);

See Also

QuickZip Class | QuickZip Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


QuickZip.Zip Method (String, String[])

Adds files to a zip file overwriting existing files and preserving the directory structure.

[Visual Basic]
Overloads Public Shared Sub Zip( _
   ByVal zipFileName As String, _
   ByVal filesToZip As String() _
)
[C#]
public static void Zip(
   string zipFileName,
   params string[] filesToZip
);

Parameters

zipFileName

The fully-qualified path and name of the zip file.

filesToZip

The files to add to zipFilename. Cannot be a null reference (Nothing in Visual Basic).

Remarks

If zipFilename does not exist, it will be created and then the files will be added.

Note that existing files will be overwritten, the directory structure will be preserved within the zip file and files contained within sub-folders will also be added to the zip file.

See Also

QuickZip Class | QuickZip Members | Xceed.Zip Namespace | QuickZip.Zip Overload List

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


QuickZip.Zip Method (String, Boolean, Boolean, Boolean, String[])

Adds files to a zip file specifying whether existing files will be overwritten and if the directory structure will be preserved.

[Visual Basic]
Overloads Public Shared Sub Zip( _
   ByVal zipFileName As String, _
   ByVal replaceExistingFiles As Boolean, _
   ByVal recursive As Boolean, _
   ByVal preservePaths As Boolean, _
   ByVal filesToZip As String() _
)
[C#]
public static void Zip(
   string zipFileName,
   bool replaceExistingFiles,
   bool recursive,
   bool preservePaths,
   params string[] filesToZip
);

Parameters

zipFileName

The fully-qualified path and name of the zip file.

replaceExistingFiles

Boolean value indicating if existing files should be overwritten.

recursive

Boolean value indicating if files contained within sub-folders should be added to the zip file.

preservePaths

Boolean value indicating if the directory structure should be preserved in the zip file.

filesToZip

The files to add to zipFilename. Cannot be a null reference (Nothing in Visual Basic).

Remarks

If zipFilename does not exist, it will be created and then the files will be added.

See Also

QuickZip Class | QuickZip Members | Xceed.Zip Namespace | QuickZip.Zip Overload List

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


QuickZip.Zip Method (String, String, Boolean, Boolean, Boolean, String[])

Adds files to a zip file using an encryption password and specifying whether existing files will be overwritten and if the directory structure will be preserved.

[Visual Basic]
Overloads Public Shared Sub Zip( _
   ByVal zipFileName As String, _
   ByVal encryptionPassword As String, _
   ByVal replaceExistingFiles As Boolean, _
   ByVal recursive As Boolean, _
   ByVal preservePaths As Boolean, _
   ByVal filesToZip As String() _
)
[C#]
public static void Zip(
   string zipFileName,
   string encryptionPassword,
   bool replaceExistingFiles,
   bool recursive,
   bool preservePaths,
   params string[] filesToZip
);

Parameters

zipFileName

The fully-qualified path and name of the zip file.

encryptionPassword

The password that will be used to encrypt the files.

replaceExistingFiles

Boolean value indicating if existing files should be overwritten.

recursive

Boolean value indicating if files contained within sub-folders should be added to the zip file.

preservePaths

Boolean value indicating if the directory structure should be preserved in the zip file.

filesToZip

The files to add to zipFilename. Cannot be a null reference (Nothing in Visual Basic).

Remarks

If zipFilename does not exist, it will be created and then the files will be added.

See Also

QuickZip Class | QuickZip Members | Xceed.Zip Namespace | QuickZip.Zip Overload List

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ReadingZipItemProgressionEventHandler Delegate

Represents the method that will handle the ReadingZipItemProgression event.

[Visual Basic]
Public Delegate Sub ReadingZipItemProgressionEventHandler( _
   ByVal sender As Object, _
   ByVal e As Xceed.FileSystem.ItemProgressionEventArgs _
)
[C#]
public delegate void ReadingZipItemProgressionEventHandler(
   object sender,
   ItemProgressionEventArgs e
);

Parameters

sender

The FileSystemItem on which the method was called.

e

An instance of the ItemProgressionEventArgs argument class that contains progression information.

Requirements

Namespace: Xceed.Zip Namespace

Assembly: Xceed.Zip.dll

See Also

Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipArchive Class

Specialization of the ZippedFolder class that represents the root folder in a ZIP file, i.e. the ZIP file itself.

For a list of all members of this type, see ZipArchive Members.

System.Object
MarshalByRefObject
FileSystemItem
AbstractFolder
ZippedFolder
ZipArchive

[Visual Basic]
Public Class ZipArchive
   Inherits ZippedFolder
   Implements IBatchUpdateable
[C#]
public class ZipArchive : ZippedFolder, IBatchUpdateable

Requirements

Namespace: Xceed.Zip Namespace

Assembly: Xceed.Zip.dll

See Also

ZipArchive Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


BeginUpdate Method

Xceed Zip for .NET

ZipArchive.BeginUpdate

Prevents a ZipArchive object from modifying its underlying physical store until the EndUpdate method is called.

Overload List

Prevents a ZipArchive object from modifying its underlying physical store until the EndUpdate method is called and raises events during the process.

public final void BeginUpdate(FileSystemEvents,object);

Prevents a ZipArchive object from modifying its underlying physical store until the EndUpdate method is called.

public final void BeginUpdate();

See Also

ZipArchive Class | ZipArchive Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipArchive.BeginUpdate Method (FileSystemEvents, Object)

Prevents a ZipArchive object from modifying its underlying physical store until the EndUpdate method is called and raises events during the process.

[Visual Basic]
NotOverridable Overloads Public Sub BeginUpdate( _
   ByVal events As Xceed.FileSystem.FileSystemEvents, _
   ByVal userData As Object _
)
[C#]
public final void BeginUpdate(
   FileSystemEvents events,
   object userData
);

Parameters

events

A FileSystemEvents object that will be used to raise events. Cannot be a null reference (Nothing in Visual Basic).

userData

Opaque data that will be passed back to the event handler when an event is raised.

Remarks

A call to BeginUpdatemust be accompanied by a subsequent call to EndUpdate, or desynchronization can occur. One way of making sure that both calls stay synchronized is to use a finally block:

            try
            {
              i.BeginUpdate();
              // Do some modifications to the zip file
            }
            finally
            {
              i.EndUpdate();
            }

In C#, the preferred way is to use the AutoBatchUpdate class within a using statement.

See Also

ZipArchive Class | ZipArchive Members | Xceed.Zip Namespace | ZipArchive.BeginUpdate Overload List

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipArchive.BeginUpdate Method ()

Prevents a ZipArchive object from modifying its underlying physical store until the EndUpdate method is called.

[Visual Basic]
NotOverridable Overloads Public Sub BeginUpdate()
[C#]
public final void BeginUpdate();

Remarks

A call to BeginUpdatemust be accompanied by a subsequent call to EndUpdate, or desynchronization can occur. One way of making sure that both calls stay synchronized is to use a finally block:

            try
            {
              i.BeginUpdate();
              // Do some modifications to the zip file
            }
            finally
            {
              i.EndUpdate();
            }

In C#, the preferred way is to use the AutoBatchUpdate class within a using statement.

See Also

ZipArchive Class | ZipArchive Members | Xceed.Zip Namespace | ZipArchive.BeginUpdate Overload List

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipArchive.Comment Property

Gets or sets the zip file's comment.

[Visual Basic]
Overrides Public Property Comment As String
[C#]
public string Comment {override get; override set;}

Property Value

A string containing the zip file's comment.

See Also

ZipArchive Class | ZipArchive Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipArchive Constructor

Xceed Zip for .NET

ZipArchive

Initializes a new instance of the ZipArchive class.

Overload List

Initializes a new instance of the ZipArchive class.

public ZipArchive(AbstractFile);

Initializes a new instance of the ZipArchive class enabling event notifications while the object is being created.

public ZipArchive(FileSystemEvents,object,AbstractFile);

internal ZipArchive(ZipItemHandler);

See Also

ZipArchive Class | ZipArchive Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipArchive Constructor (AbstractFile)

Initializes a new instance of the ZipArchive class.

[Visual Basic]
Overloads Public Sub New( _
   ByVal zipFile As Xceed.FileSystem.AbstractFile _
)
[C#]
public ZipArchive(
   AbstractFile zipFile
);

Parameters

zipFile

AbstractFile object that represents the ZIP file to access.

See Also

ZipArchive Class | ZipArchive Members | Xceed.Zip Namespace | ZipArchive Constructor Overload List

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipArchive Constructor (FileSystemEvents, Object, AbstractFile)

Initializes a new instance of the ZipArchive class enabling event notifications while the object is being created.

[Visual Basic]
Overloads Public Sub New( _
   ByVal events As Xceed.FileSystem.FileSystemEvents, _
   ByVal userData As Object, _
   ByVal zipFile As Xceed.FileSystem.AbstractFile _
)
[C#]
public ZipArchive(
   FileSystemEvents events,
   object userData,
   AbstractFile zipFile
);

Parameters

events

A FileSystemEvents object that will be used to raise events. Cannot be a null reference (Nothing in Visual Basic).

userData

Opaque data that will be passed back to the event handler when an event is raised.

zipFile

AbstractFile object that represents the ZIP file to access.

Remarks

Once the ZipArchive object is created, it does not keep a reference on the event object.

See Also

ZipArchive Class | ZipArchive Members | Xceed.Zip Namespace | ZipArchive Constructor Overload List

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipArchive Constructor (ZipItemHandler)

[Visual Basic]
Overloads Friend Sub New( _
   ByVal item As Xceed.Zip.ZipItemHandler _
)
[C#]
internal ZipArchive(
   ZipItemHandler item
);

See Also

ZipArchive Class | ZipArchive Members | Xceed.Zip Namespace | ZipArchive Constructor Overload List

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipArchive.DefaultCompressionLevel Property

Gets or sets the default Xceed.Compression.CompressionLevel that was applied or that will be applied to the file(s).

[Visual Basic]
Overridable Public Property DefaultCompressionLevel As Xceed.Compression.CompressionLevel
[C#]
public Xceed.Compression.CompressionLevel DefaultCompressionLevel {virtual get; virtual set;}

Property Value

The default Xceed.Compression.CompressionLevel that was applied or that will be applied to the file(s).

See Also

ZipArchive Class | ZipArchive Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipArchive.DefaultCompressionMethod Property

Gets or sets the default Xceed.Compression.CompressionMethod that was applied or that will be applied to the file(s).

[Visual Basic]
Overridable Public Property DefaultCompressionMethod As Xceed.Compression.CompressionMethod
[C#]
public Xceed.Compression.CompressionMethod DefaultCompressionMethod {virtual get; virtual set;}

Property Value

The default Xceed.Compression.CompressionMethod that was applied or that will be applied to the file(s).

See Also

ZipArchive Class | ZipArchive Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipArchive.DefaultDecryptionPassword Property

Gets or sets the default decryption password to use when decompressing files.

[Visual Basic]
Overridable Public Property DefaultDecryptionPassword As String
[C#]
public string DefaultDecryptionPassword {virtual get; virtual set;}

Property Value

A string containing the default decryption password to use when decompressing files.

Remarks

The length of the password must not be greater than 80 characters.

See Also

ZipArchive Class | ZipArchive Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipArchive.DefaultEncryptionPassword Property

Gets or sets the default encryption password to use when compressing files.

[Visual Basic]
Overridable Public Property DefaultEncryptionPassword As String
[C#]
public string DefaultEncryptionPassword {virtual get; virtual set;}

Property Value

A string containg the default encryption password to use when compressing files.

Remarks

The length of the password must not be greater than 80 characters.

See Also

ZipArchive Class | ZipArchive Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


EndUpdate Method

Xceed Zip for .NET

ZipArchive.EndUpdate

Informs a ZipArchive object to apply to its underlying physical store all the modifications that have been made since the call to BeginUpdate

Overload List

Informs a ZipArchive object to apply to its underlying physical store all the modifications that have been made since the call to BeginUpdate and raises events during the process.

public final void EndUpdate(FileSystemEvents,object);

Informs a ZipArchive object to apply to its underlying physical store all the modifications that have been made since the call to BeginUpdate

public final void EndUpdate();

See Also

ZipArchive Class | ZipArchive Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipArchive.EndUpdate Method (FileSystemEvents, Object)

Informs a ZipArchive object to apply to its underlying physical store all the modifications that have been made since the call to BeginUpdate and raises events during the process.

[Visual Basic]
NotOverridable Overloads Public Sub EndUpdate( _
   ByVal events As Xceed.FileSystem.FileSystemEvents, _
   ByVal userData As Object _
)
[C#]
public final void EndUpdate(
   FileSystemEvents events,
   object userData
);

Parameters

events

A FileSystemEvents object that will be used to raise events. Cannot be a null reference (Nothing in Visual Basic).

userData

Opaque data that will be passed back to the event handler when an event is raised.

Remarks

A call to EndUpdatemust be preceded by a call to BeginUpdate, or desynchronization can occur. One mean of making sure that both calls stay synchronized is to use a finally block:

            try
            {
              i.BeginUpdate();
              // Do some modifications to the zip file
            }
            finally
            {
              i.EndUpdate();
            }

In C#, the preferred way is to use the AutoBatchUpdate class in a using statement.

See Also

ZipArchive Class | ZipArchive Members | Xceed.Zip Namespace | ZipArchive.EndUpdate Overload List

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipArchive.EndUpdate Method ()

Informs a ZipArchive object to apply to its underlying physical store all the modifications that have been made since the call to BeginUpdate

[Visual Basic]
NotOverridable Overloads Public Sub EndUpdate()
[C#]
public final void EndUpdate();

Remarks

A call to EndUpdatemust be preceded by a call to BeginUpdate, or desynchronization can occur. One mean of making sure that both calls stay synchronized is to use a finally block:

            try
            {
              i.BeginUpdate();
              // Do some modifications to the zip file
            }
            finally
            {
              i.EndUpdate();
            }

In C#, the preferred way is to use the AutoBatchUpdate class in a using statement.

See Also

ZipArchive Class | ZipArchive Members | Xceed.Zip Namespace | ZipArchive.EndUpdate Overload List

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipArchive Fields

The fields of the ZipArchive class are listed below. For a complete list of ZipArchive class members, see the ZipArchive Members topic.

Protected Instance Fields

m_isRoot

See Also

ZipArchive Class | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipArchive.m_isRoot Field

[Visual Basic]
Protected m_isRoot As Boolean
[C#]
protected bool m_isRoot;

See Also

ZipArchive Class | ZipArchive Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipArchive Members

Public Instance Constructors

ZipArchive Overloaded. Initialize a new instance of the ZipArchive class.

Public Instance Properties

Attributes (inherited from FileSystemItem) | Gets or sets the attributes of the item.
Comment | Gets or sets the zip file's comment.
CreationDateTime (inherited from FileSystemItem) | Gets or sets the creation date and time of the item.
DefaultCompressionLevel | Gets or sets the default Xceed.Compression.CompressionLevel that was applied or that will be applied to the file(s).
DefaultCompressionMethod | Gets or sets the default Xceed.Compression.CompressionMethod that was applied or that will be applied to the file(s).
DefaultDecryptionPassword | Gets or sets the default decryption password to use when decompressing files.
DefaultEncryptionPassword | Gets or sets the default encryption password to use when compressing files.
Exists (inherited from FileSystemItem) | Gets a boolean value indicating if the item physically exists.
FullName (inherited from FileSystemItem) | Gets the full name of the item.
IsRoot (inherited from AbstractFolder) | Gets a value indicating if the folder is a root folder.
LastAccessDateTime (inherited from FileSystemItem) | Gets or sets the last access date and time of the item.
LastWriteDateTime (inherited from FileSystemItem) | Gets or sets the modification date and time of the item.
Name (inherited from FileSystemItem) | Gets or sets the short name of the item.
ParentFolder (inherited from FileSystemItem) | Gets a reference to the parent folder of this item.
RootFolder (inherited from FileSystemItem) | Gets a reference to the root folder of this item.
ZipFile | Gets a reference to the zip file around which the ZipArchive object is created.

Public Instance Methods

ApplyPropertiesTo (inherited from FileSystemItem) | Overloaded. Copies the item's properties to another item.
BeginUpdate | Overloaded. Prevents a object from modifying its underlying physical store until the method is called and raises events during the process.
CopyFilesTo (inherited from AbstractFolder) | Overloaded. Copies the folder's content to another folder.
CopyTo (inherited from FileSystemItem) | Overloaded. Copies the item, or it's content to the destination.
Create (inherited from FileSystemItem) | Overloaded. Creates the physical item represented by the object.
CreateFile (inherited from AbstractFolder) | Overloaded. Creates a new file in the folder.
CreateFolder (inherited from AbstractFolder) | Overloaded. Creates a new folder in the folder.
CreateObjRef (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Delete (inherited from FileSystemItem) | Overloaded. Permanently deletes the physical item.
EndUpdate | Overloaded. Informs a object to apply to its underlying physical store all the modifications that have been made since the call to and raises events during the process.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetFile (inherited from AbstractFolder) | Overloaded. Returns an object that represents a file contained in the folder.
GetFiles (inherited from AbstractFolder) | Overloaded. Returns a filtered list of files contained in the folder.
GetFolder (inherited from AbstractFolder) | Overloaded. Returns an object that represents a folder contained in the folder.
GetFolders (inherited from AbstractFolder) | Overloaded. Returns a filtered list of folders contained in the folder.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetItems (inherited from AbstractFolder) | Overloaded. Returns a list of items contained in the folder.
GetLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
InitializeLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
MoveFilesTo (inherited from AbstractFolder) | Overloaded. Moves the folder's content to another folder.
MoveTo (inherited from FileSystemItem) | Overloaded. Moves the item, or it's content to the destination.
Refresh (inherited from FileSystemItem) | Overloaded. Re-reads the information from the physical item.
ToString (inherited from FileSystemItem) | Returns the full name of the item.

Protected Instance Fields

m_isRoot

Protected Instance Properties

DoAttributes (inherited from ZippedFolder) | Gets or sets the attributes of the item.
DoCreationDateTime (inherited from ZippedFolder) | Gets or sets the creation date and time of the item.
DoExists (inherited from ZippedFolder) | Gets a boolean value indicating if the item physically exists.
DoFullName (inherited from ZippedFolder) | Gets the full name of the item.
DoIsRoot (inherited from AbstractFolder) | Gets a boolean value indicating if the folder is a root folder.
DoLastAccessDateTime (inherited from ZippedFolder) | Gets or sets the last access date and time of the item.
DoLastWriteDateTime (inherited from ZippedFolder) | Gets or sets the modification date and time of the item.
DoName (inherited from ZippedFolder) | Gets or sets the short name of the item.
DoParentFolder (inherited from ZippedFolder) | Gets a reference to the parent folder of this item.
DoRootFolder (inherited from ZippedFolder) | Gets a reference to the parent folder of this item.
InvalidChars (inherited from FileSystemItem) | Gets the characters that are invalid in file and folder names.

Protected Instance Methods

BuildListForCreate (inherited from FileSystemItem) | Handles the special cases in regards to building the list of items to process when creating a FileSystemItem object.
DoApplyPropertiesTo (inherited from ZippedFolder) | Copies the zipped folder's properties to another item.
DoCopyTo (inherited from AbstractFolder) | Copies the folder to another folder.
DoCreate (inherited from ZippedFolder) | Creates the physical zipped folder.
DoDelete (inherited from ZippedFolder) | Permanently deletes the physical zipped folder.
DoGetChildItems (inherited from ZippedFolder) | Retrieves an array of FileSystemItem objects contained within the zipped folder.
DoGetFile (inherited from ZippedFolder) | Retrieves a reference to an AbstractFile object contained within the zipped folder.
DoGetFiles (inherited from AbstractFolder) | Retrieves an array of AbstractFile objects.
DoGetFolder (inherited from ZippedFolder) | Retrieves a reference to an AbstractFolder object contained within the zipped folder.
DoGetFolders (inherited from AbstractFolder) | Retrieves an array of AbstractFolder objects.
DoGetItems (inherited from AbstractFolder) | Retrieves an array of FileSystemItem objects.
DoRefresh (inherited from ZippedFolder) | Re-reads the information from the physical item.
EnsureDateIsValid (inherited from ZippedFolder) | Ensures that the System.DateTime value is valid.
Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsPathRooted (inherited from ZippedFolder) | Returns a boolean value indicating if the path passed is rooted.
IsSameAs (inherited from ZippedFolder) | Returns a boolean value indicating if the source and target items are the same.
ListCopyTo (inherited from FileSystemItem) | Copies each item in the FileSystemEventsSession object's list to each item's destination.
ListCreate (inherited from FileSystemItem) | Creates each item in the FileSystemEventsSession object's list.
ListDelete (inherited from FileSystemItem) | Deletes each item in the FileSystemEventsSession object's list.
ListMoveTo (inherited from FileSystemItem) | Moves each item in the FileSystemEventsSession object's list to each item's destination.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Internal Instance Methods

BuildList (inherited from AbstractFolder) Builds a list of FileSystemItem objects to process.

Internal Instance Constructors

ZipArchive Overloaded. Initialize a new instance of the ZipArchive class.

See Also

ZipArchive Class | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipArchive Methods

The methods of the ZipArchive class are listed below. For a complete list of ZipArchive class members, see the ZipArchive Members topic.

Public Instance Methods

ApplyPropertiesTo (inherited from FileSystemItem) | Overloaded. Copies the item's properties to another item.
BeginUpdate | Overloaded.
CopyFilesTo (inherited from AbstractFolder) | Overloaded.
CopyTo (inherited from FileSystemItem) | Overloaded. Copies the item, or it's content to the destination.
Create (inherited from FileSystemItem) | Overloaded. Creates the physical item represented by the object.
CreateFile (inherited from AbstractFolder) | Overloaded.
CreateFolder (inherited from AbstractFolder) | Overloaded.
CreateObjRef (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Delete (inherited from FileSystemItem) | Overloaded. Permanently deletes the physical item.
EndUpdate | Overloaded.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetFile (inherited from AbstractFolder) | Overloaded.
GetFiles (inherited from AbstractFolder) | Overloaded.
GetFolder (inherited from AbstractFolder) | Overloaded.
GetFolders (inherited from AbstractFolder) | Overloaded.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetItems (inherited from AbstractFolder) | Overloaded.
GetLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
InitializeLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
MoveFilesTo (inherited from AbstractFolder) | Overloaded.
MoveTo (inherited from FileSystemItem) | Overloaded. Moves the item, or it's content to the destination.
Refresh (inherited from FileSystemItem) | Overloaded. Re-reads the information from the physical item.
ToString (inherited from FileSystemItem) | Returns the full name of the item.

Protected Instance Methods

BuildListForCreate (inherited from FileSystemItem) | Handles the special cases in regards to building the list of items to process when creating a FileSystemItem object.
DoApplyPropertiesTo (inherited from ZippedFolder) | Copies the zipped folder's properties to another item.
DoCopyTo (inherited from AbstractFolder) | Copies the folder to another folder.
DoCreate (inherited from ZippedFolder) | Creates the physical zipped folder.
DoDelete (inherited from ZippedFolder) | Permanently deletes the physical zipped folder.
DoGetChildItems (inherited from ZippedFolder) | Retrieves an array of FileSystemItem objects contained within the zipped folder.
DoGetFile (inherited from ZippedFolder) | Retrieves a reference to an AbstractFile object contained within the zipped folder.
DoGetFiles (inherited from AbstractFolder) | Retrieves an array of AbstractFile objects.
DoGetFolder (inherited from ZippedFolder) | Retrieves a reference to an AbstractFolder object contained within the zipped folder.
DoGetFolders (inherited from AbstractFolder) | Retrieves an array of AbstractFolder objects.
DoGetItems (inherited from AbstractFolder) | Retrieves an array of FileSystemItem objects.
DoRefresh (inherited from ZippedFolder) | Re-reads the information from the physical item.
EnsureDateIsValid (inherited from ZippedFolder) | Ensures that the System.DateTime value is valid.
Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsPathRooted (inherited from ZippedFolder) | Returns a boolean value indicating if the path passed is rooted.
IsSameAs (inherited from ZippedFolder) | Returns a boolean value indicating if the source and target items are the same.
ListCopyTo (inherited from FileSystemItem) | Copies each item in the FileSystemEventsSession object's list to each item's destination.
ListCreate (inherited from FileSystemItem) | Creates each item in the FileSystemEventsSession object's list.
ListDelete (inherited from FileSystemItem) | Deletes each item in the FileSystemEventsSession object's list.
ListMoveTo (inherited from FileSystemItem) | Moves each item in the FileSystemEventsSession object's list to each item's destination.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Internal Instance Methods

BuildList (inherited from AbstractFolder) Builds a list of FileSystemItem objects to process.

See Also

ZipArchive Class | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipArchive Properties

The properties of the ZipArchive class are listed below. For a complete list of ZipArchive class members, see the ZipArchive Members topic.

Public Instance Properties

Attributes (inherited from FileSystemItem) | Gets or sets the attributes of the item.
Comment | Gets or sets the zip file's comment.
CreationDateTime (inherited from FileSystemItem) | Gets or sets the creation date and time of the item.
DefaultCompressionLevel | Gets or sets the default Xceed.Compression.CompressionLevel that was applied or that will be applied to the file(s).
DefaultCompressionMethod | Gets or sets the default Xceed.Compression.CompressionMethod that was applied or that will be applied to the file(s).
DefaultDecryptionPassword | Gets or sets the default decryption password to use when decompressing files.
DefaultEncryptionPassword | Gets or sets the default encryption password to use when compressing files.
Exists (inherited from FileSystemItem) | Gets a boolean value indicating if the item physically exists.
FullName (inherited from FileSystemItem) | Gets the full name of the item.
IsRoot (inherited from AbstractFolder) | Gets a value indicating if the folder is a root folder.
LastAccessDateTime (inherited from FileSystemItem) | Gets or sets the last access date and time of the item.
LastWriteDateTime (inherited from FileSystemItem) | Gets or sets the modification date and time of the item.
Name (inherited from FileSystemItem) | Gets or sets the short name of the item.
ParentFolder (inherited from FileSystemItem) | Gets a reference to the parent folder of this item.
RootFolder (inherited from FileSystemItem) | Gets a reference to the root folder of this item.
ZipFile | Gets a reference to the zip file around which the ZipArchive object is created.

Protected Instance Properties

DoAttributes (inherited from ZippedFolder) | Gets or sets the attributes of the item.
DoCreationDateTime (inherited from ZippedFolder) | Gets or sets the creation date and time of the item.
DoExists (inherited from ZippedFolder) | Gets a boolean value indicating if the item physically exists.
DoFullName (inherited from ZippedFolder) | Gets the full name of the item.
DoIsRoot (inherited from AbstractFolder) | Gets a boolean value indicating if the folder is a root folder.
DoLastAccessDateTime (inherited from ZippedFolder) | Gets or sets the last access date and time of the item.
DoLastWriteDateTime (inherited from ZippedFolder) | Gets or sets the modification date and time of the item.
DoName (inherited from ZippedFolder) | Gets or sets the short name of the item.
DoParentFolder (inherited from ZippedFolder) | Gets a reference to the parent folder of this item.
DoRootFolder (inherited from ZippedFolder) | Gets a reference to the parent folder of this item.
InvalidChars (inherited from FileSystemItem) | Gets the characters that are invalid in file and folder names.

See Also

ZipArchive Class | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipArchive.ZipFile Property

Gets a reference to the zip file around which the ZipArchive object is created.

[Visual Basic]
Public ReadOnly Property ZipFile As Xceed.FileSystem.AbstractFile
[C#]
public Xceed.FileSystem.AbstractFile ZipFile {get;}

Property Value

A reference to a ZipArchive object.

See Also

ZipArchive Class | ZipArchive Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipEvents Class

Class that dispatches events associated with zip operations performed on ZippedFile, ZippedFolder or ZipArchive objects.

For a list of all members of this type, see ZipEvents Members.

System.Object
FileSystemEvents
ZipEvents

[Visual Basic]
Public Class ZipEvents
   Inherits FileSystemEvents
[C#]
public class ZipEvents : FileSystemEvents

Requirements

Namespace: Xceed.Zip Namespace

Assembly: Xceed.Zip.dll

See Also

ZipEvents Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipEvents.BuildingZipByteProgression Event

Raised every time a temporary zip file is being built, providing byte progression information to the event handler.

[Visual Basic]
Public BuildingZipByteProgression As Xceed.Zip.BuildingZipByteProgressionEventHandler
[C#]
public BuildingZipByteProgressionEventHandler BuildingZipByteProgression;

Event Data

The event handler receives a ByteProgressionEventArgs containing data related to the BuildingZipByteProgression event. The following ByteProgressionEventArgs properties provide information specific to this event.

Property | Description
AllFilesBytes | Gets the total combined size, in bytes, of all files being processed.
CurrentFileBytes | Gets the size, in bytes, of the file currently being processed.
CurrentItem |
TargetItem |
UserData |

See Also

ZipEvents Class | ZipEvents Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipEvents.BuildingZipItemProgression Event

Raised every time a temporary zip file is being built, providing item progression information to the event handler.

[Visual Basic]
Public BuildingZipItemProgression As Xceed.Zip.BuildingZipItemProgressionEventHandler
[C#]
public BuildingZipItemProgressionEventHandler BuildingZipItemProgression;

Event Data

The event handler receives a ItemProgressionEventArgs containing data related to the BuildingZipItemProgression event. The following ItemProgressionEventArgs properties provide information specific to this event.

Property | Description
AllItems | Gets the total number of items being processed.
CurrentItem |
TargetItem |
UserData |

See Also

ZipEvents Class | ZipEvents Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipEvents Constructor

[Visual Basic]
Public Sub New()
[C#]
public ZipEvents();

See Also

ZipEvents Class | ZipEvents Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipEvents.CopyingZipByteProgression Event

Raised every time the temporary zip file replaces the existing zip file, providing byte progression information to the event handler.

[Visual Basic]
Public CopyingZipByteProgression As Xceed.Zip.CopyingZipByteProgressionEventHandler
[C#]
public CopyingZipByteProgressionEventHandler CopyingZipByteProgression;

Event Data

The event handler receives a ByteProgressionEventArgs containing data related to the CopyingZipByteProgression event. The following ByteProgressionEventArgs properties provide information specific to this event.

Property | Description
AllFilesBytes | Gets the total combined size, in bytes, of all files being processed.
CurrentFileBytes | Gets the size, in bytes, of the file currently being processed.
CurrentItem |
TargetItem |
UserData |

See Also

ZipEvents Class | ZipEvents Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipEvents.CreateSession Method

Creates a new session from a ZipEvents object.

[Visual Basic]
Overrides Public Function CreateSession( _
   ByVal sender As Object, _
   ByVal userData As Object _
) As Xceed.FileSystem.FileSystemEventsSession
[C#]
public override FileSystemEventsSession CreateSession(
   object sender,
   object userData
);

Parameters

sender

The FileSystemItem object from which the session is created.

userData

Opaque data that is sent back to the event handler when an event is raised.

Return Value

A reference to a ZipEventsSession object.

See Also

ZipEvents Class | ZipEvents Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipEvents Events

The events of the ZipEvents class are listed below. For a complete list of ZipEvents class members, see the ZipEvents Members topic.

Public Instance Events

BuildingZipByteProgression | Raised every time a temporary zip file is being built, providing byte progression information to the event handler.
BuildingZipItemProgression | Raised every time a temporary zip file is being built, providing item progression information to the event handler.
CopyingZipByteProgression | Raised every time the temporary zip file replaces the existing zip file, providing byte progression information to the event handler.
ReadingZipItemProgression | Raised every time a zip file is being read for the first time or being refreshed, providing progression information to the event handler.

See Also

ZipEvents Class | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipEvents Fields

The fields of the ZipEvents class are listed below. For a complete list of ZipEvents class members, see the ZipEvents Members topic.

Protected Instance Fields

m_subOperationCount

See Also

ZipEvents Class | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipEvents.m_subOperationCount Field

[Visual Basic]
Protected m_subOperationCount As Integer
[C#]
protected int m_subOperationCount;

See Also

ZipEvents Class | ZipEvents Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipEvents Members

Public Instance Constructors

ZipEvents Constructor

Public Instance Methods

BeginSubOperation (inherited from FileSystemEvents) | Called when a sub-operation is begun within a process.
CreateSession | Creates a new session from a ZipEvents object.
EndSubOperation (inherited from FileSystemEvents) | Called when a sub-operation is ended within a process.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Public Instance Events

BuildingZipByteProgression | Raised every time a temporary zip file is being built, providing byte progression information to the event handler.
BuildingZipItemProgression | Raised every time a temporary zip file is being built, providing item progression information to the event handler.
CopyingZipByteProgression | Raised every time the temporary zip file replaces the existing zip file, providing byte progression information to the event handler.
ReadingZipItemProgression | Raised every time a zip file is being read for the first time or being refreshed, providing progression information to the event handler.

Protected Instance Fields

m_subOperationCount

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.
ValidateParams (inherited from FileSystemEvents) | Verifies the validity of the parameters sent to the event handlers.

Protected Internal Instance Properties

WantsBuildingZipByteProgression | Gets a boolean value indicating if the ZipEvents object has subscribed to the OnBuildingZipByteProgression event.
WantsBuildingZipItemProgression | Gets a boolean value indicating if the ZipEvents object has subscribed to the OnBuildingZipItemProgression event.
WantsByteProgression (inherited from FileSystemEvents) | Gets a boolean value indicating if the FileSystemEvents object has subscribed to the OnByteProgression event.
WantsCopyingZipByteProgression | Gets a boolean value indicating if the ZipEvents object has subscribed to the OnCopyingZipByteProgression event.
WantsItemException (inherited from FileSystemEvents) | Gets a boolean value indicating if the FileSystemEvents object has subscribed to the OnItemException event.
WantsItemProgression (inherited from FileSystemEvents) | Gets a boolean value indicating if the FileSystemEvents object has subscribed to the OnItemProgression event.
WantsReadingZipItemProgression | Gets a boolean value indicating if the ZipEvents object has subscribed to the OnReadingZipItemProgression event.
WantsScanningFolder (inherited from FileSystemEvents) | Gets a boolean value indicating if the FileSystemEvents object has subscribed to the OnScanningFolder event.

Protected Internal Instance Methods

OnBuildingZipByteProgression | Calls the delegated OnBuildingZipByteProgression event handler.
OnBuildingZipItemProgression | Calls the delegated OnBuildingZipItemProgression event handler.
OnByteProgression (inherited from FileSystemEvents) | Calls the delegated OnByteProgression event handler.
OnCopyingZipByteProgression | Calls the delegated OnCopyingZipByteProgression event handler.
OnItemException (inherited from FileSystemEvents) | Calls the delegated OnItemException event handler.
OnItemProgression (inherited from FileSystemEvents) | Calls the delegated OnItemProgression event handler.
OnReadingZipItemProgression | Calls the delegated OnReadingZipItemProgression event handler.
OnScanningFolder (inherited from FileSystemEvents) | Calls the delegated OnScanningFolder event handler.

See Also

ZipEvents Class | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipEvents Methods

The methods of the ZipEvents class are listed below. For a complete list of ZipEvents class members, see the ZipEvents Members topic.

Public Instance Methods

BeginSubOperation (inherited from FileSystemEvents) | Called when a sub-operation is begun within a process.
CreateSession | Creates a new session from a ZipEvents object.
EndSubOperation (inherited from FileSystemEvents) | Called when a sub-operation is ended within a process.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.
ValidateParams (inherited from FileSystemEvents) | Verifies the validity of the parameters sent to the event handlers.

Protected Internal Instance Methods

OnBuildingZipByteProgression | Calls the delegated OnBuildingZipByteProgression event handler.
OnBuildingZipItemProgression | Calls the delegated OnBuildingZipItemProgression event handler.
OnByteProgression (inherited from FileSystemEvents) | Calls the delegated OnByteProgression event handler.
OnCopyingZipByteProgression | Calls the delegated OnCopyingZipByteProgression event handler.
OnItemException (inherited from FileSystemEvents) | Calls the delegated OnItemException event handler.
OnItemProgression (inherited from FileSystemEvents) | Calls the delegated OnItemProgression event handler.
OnReadingZipItemProgression | Calls the delegated OnReadingZipItemProgression event handler.
OnScanningFolder (inherited from FileSystemEvents) | Calls the delegated OnScanningFolder event handler.

See Also

ZipEvents Class | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipEvents.OnBuildingZipByteProgression Method

Calls the delegated OnBuildingZipByteProgression event handler.

[Visual Basic]
Overridable Protected Friend Sub OnBuildingZipByteProgression( _
   ByVal sender As Object, _
   ByVal e As Xceed.FileSystem.ByteProgressionEventArgs _
)
[C#]
protected internal virtual void OnBuildingZipByteProgression(
   object sender,
   ByteProgressionEventArgs e
);

Parameters

sender

The FileSystemItem on which the method was called.

e

An instance of the ByteProgressionEventArgs argument class that contains byte progression information.

See Also

ZipEvents Class | ZipEvents Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipEvents.OnBuildingZipItemProgression Method

Calls the delegated OnBuildingZipItemProgression event handler.

[Visual Basic]
Overridable Protected Friend Sub OnBuildingZipItemProgression( _
   ByVal sender As Object, _
   ByVal e As Xceed.FileSystem.ItemProgressionEventArgs _
)
[C#]
protected internal virtual void OnBuildingZipItemProgression(
   object sender,
   ItemProgressionEventArgs e
);

Parameters

sender

The FileSystemItem on which the method was called.

e

An instance of the ItemProgressionEventArgs argument class that contains item progression information.

See Also

ZipEvents Class | ZipEvents Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipEvents.OnCopyingZipByteProgression Method

Calls the delegated OnCopyingZipByteProgression event handler.

[Visual Basic]
Overridable Protected Friend Sub OnCopyingZipByteProgression( _
   ByVal sender As Object, _
   ByVal e As Xceed.FileSystem.ByteProgressionEventArgs _
)
[C#]
protected internal virtual void OnCopyingZipByteProgression(
   object sender,
   ByteProgressionEventArgs e
);

Parameters

sender

The FileSystemItem on which the method was called.

e

An instance of the ByteProgressionEventArgs argument class that contains byte progression information.

See Also

ZipEvents Class | ZipEvents Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipEvents.OnReadingZipItemProgression Method

Calls the delegated OnReadingZipItemProgression event handler.

[Visual Basic]
Overridable Protected Friend Sub OnReadingZipItemProgression( _
   ByVal sender As Object, _
   ByVal e As Xceed.FileSystem.ItemProgressionEventArgs _
)
[C#]
protected internal virtual void OnReadingZipItemProgression(
   object sender,
   ItemProgressionEventArgs e
);

Parameters

sender

The FileSystemItem on which the method was called.

e

An instance of the ItemProgressionEventArgs argument class that contains item progression information.

See Also

ZipEvents Class | ZipEvents Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipEvents Properties

The properties of the ZipEvents class are listed below. For a complete list of ZipEvents class members, see the ZipEvents Members topic.

Protected Internal Instance Properties

WantsBuildingZipByteProgression | Gets a boolean value indicating if the ZipEvents object has subscribed to the OnBuildingZipByteProgression event.
WantsBuildingZipItemProgression | Gets a boolean value indicating if the ZipEvents object has subscribed to the OnBuildingZipItemProgression event.
WantsByteProgression (inherited from FileSystemEvents) | Gets a boolean value indicating if the FileSystemEvents object has subscribed to the OnByteProgression event.
WantsCopyingZipByteProgression | Gets a boolean value indicating if the ZipEvents object has subscribed to the OnCopyingZipByteProgression event.
WantsItemException (inherited from FileSystemEvents) | Gets a boolean value indicating if the FileSystemEvents object has subscribed to the OnItemException event.
WantsItemProgression (inherited from FileSystemEvents) | Gets a boolean value indicating if the FileSystemEvents object has subscribed to the OnItemProgression event.
WantsReadingZipItemProgression | Gets a boolean value indicating if the ZipEvents object has subscribed to the OnReadingZipItemProgression event.
WantsScanningFolder (inherited from FileSystemEvents) | Gets a boolean value indicating if the FileSystemEvents object has subscribed to the OnScanningFolder event.

See Also

ZipEvents Class | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipEvents.ReadingZipItemProgression Event

Raised every time a zip file is being read for the first time or being refreshed, providing progression information to the event handler.

[Visual Basic]
Public ReadingZipItemProgression As Xceed.Zip.ReadingZipItemProgressionEventHandler
[C#]
public ReadingZipItemProgressionEventHandler ReadingZipItemProgression;

Event Data

The event handler receives a ItemProgressionEventArgs containing data related to the ReadingZipItemProgression event. The following ItemProgressionEventArgs properties provide information specific to this event.

Property | Description
AllItems | Gets the total number of items being processed.
CurrentItem |
TargetItem |
UserData |

See Also

ZipEvents Class | ZipEvents Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipEventsSession Class

Class which derives from the FileSystemEventsSession class and holds information about the session which is responsible for raising all events that occur during the process.

For a list of all members of this type, see ZipEventsSession Members.

System.Object
FileSystemEventsSession
ZipEventsSession

[Visual Basic]
Public Class ZipEventsSession
   Inherits FileSystemEventsSession
[C#]
public class ZipEventsSession : FileSystemEventsSession

Requirements

Namespace: Xceed.Zip Namespace

Assembly: Xceed.Zip.dll

See Also

ZipEventsSession Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipEventsSession Constructor

Creates a new instance of the ZipEventsSession class.

[Visual Basic]
Protected Friend Sub New( _
   ByVal events As Xceed.Zip.ZipEvents, _
   ByVal sender As Object, _
   ByVal userData As Object _
)
[C#]
protected internal ZipEventsSession(
   ZipEvents events,
   object sender,
   object userData
);

Parameters

events

The ZipEvents object from which we created the session.

sender

The FileSystemItem object on which the process was called.

userData

Opaque data that is sent back to the event handler when an event is raised.

Remarks

This constructor is called within the CreateSession method found in the ZipEvents class.

See Also

ZipEventsSession Class | ZipEventsSession Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipEventsSession.Events Property

Gets the original FileSystemEvents object used to create the session.

[Visual Basic]
Overrides Public ReadOnly Property Events As Xceed.FileSystem.FileSystemEvents
[C#]
public Xceed.FileSystem.FileSystemEvents Events {override get;}

Property Value

A reference to the original FileSystemEvents object used to create the session.

See Also

ZipEventsSession Class | ZipEventsSession Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipEventsSession Fields

The fields of the ZipEventsSession class are listed below. For a complete list of ZipEventsSession class members, see the ZipEventsSession Members topic.

Protected Instance Fields

m_allFilesBytes |
m_allItems |
m_buildingZipByteProgressionArgs | An instance of the ByteProgressionEventArgs class that provides byte progression information for the current session.
m_buildingZipItemProgressionArgs | An instance of the ItemProgressionEventArgs class that provides item progression information for the current session.
m_byteProgressionArgs |
m_copyingZipByteProgressionArgs | An instance of the ByteProgressionEventArgs class that provides byte progression information for the current session.
m_currentFileBytes |
m_currentItem |
m_events |
m_itemExceptionArgs |
m_itemPairQueue |
m_itemProgressionArgs |
m_readingZipItemProgressionArgs | An instance of the ItemProgressionEventArgs class that provides item progression information for the current session.
m_scanningFolderArgs |
m_sender |
m_targetItem |
m_userData |
m_zipAllFilesBytes | An instance of the ProgressionInfo class representing the byte count information in regards to all the items to be processed for the current session.
m_zipAllItems | An instance of the ProgressionInfo class representing the item count information for the current session.
m_zipCurrentFileBytes | An instance of the ProgressionInfo class representing the byte count information in regards to the current item being processed for the current session.
m_zipEvents | An instance of the ZipEvents class representing the original ZipEvents object from which we created the session.

See Also

ZipEventsSession Class | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipEventsSession.InitializeCurrentTotalBytes Method

Initializes the total amount of bytes for the current zip item to be processed.

[Visual Basic]
Public Sub InitializeCurrentTotalBytes( _
   ByVal totalBytes As Long _
)
[C#]
public void InitializeCurrentTotalBytes(
   long totalBytes
);

Parameters

totalBytes

The total amount of bytes for the current zip item to be processed.

See Also

ZipEventsSession Class | ZipEventsSession Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipEventsSession.InitializeTotalBytes Method

Initializes the total amount of bytes for all zip items to be processed.

[Visual Basic]
Public Sub InitializeTotalBytes( _
   ByVal totalBytes As Long _
)
[C#]
public void InitializeTotalBytes(
   long totalBytes
);

Parameters

totalBytes

The total amount of bytes for all zip items to be processed.

See Also

ZipEventsSession Class | ZipEventsSession Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipEventsSession.InitializeTotalItems Method

Initializes the total amount of zip items to be processed.

[Visual Basic]
Public Sub InitializeTotalItems( _
   ByVal totalItems As Long _
)
[C#]
public void InitializeTotalItems(
   long totalItems
);

Parameters

totalItems

The total amount of zip items to be processed.

See Also

ZipEventsSession Class | ZipEventsSession Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipEventsSession.m_allFilesBytes Field

[Visual Basic]
Protected m_allFilesBytes As Xceed.FileSystem.ProgressionInfo
[C#]
protected ProgressionInfo m_allFilesBytes;

See Also

ZipEventsSession Class | ZipEventsSession Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipEventsSession.m_allItems Field

[Visual Basic]
Protected m_allItems As Xceed.FileSystem.ProgressionInfo
[C#]
protected ProgressionInfo m_allItems;

See Also

ZipEventsSession Class | ZipEventsSession Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipEventsSession.m_buildingZipByteProgressionArgs Field

An instance of the ByteProgressionEventArgs class that provides byte progression information for the current session.

[Visual Basic]
Protected m_buildingZipByteProgressionArgs As Xceed.FileSystem.ByteProgressionEventArgs
[C#]
protected ByteProgressionEventArgs m_buildingZipByteProgressionArgs;

See Also

ZipEventsSession Class | ZipEventsSession Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipEventsSession.m_buildingZipItemProgressionArgs Field

An instance of the ItemProgressionEventArgs class that provides item progression information for the current session.

[Visual Basic]
Protected m_buildingZipItemProgressionArgs As Xceed.FileSystem.ItemProgressionEventArgs
[C#]
protected ItemProgressionEventArgs m_buildingZipItemProgressionArgs;

See Also

ZipEventsSession Class | ZipEventsSession Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipEventsSession.m_byteProgressionArgs Field

[Visual Basic]
Protected m_byteProgressionArgs As Xceed.FileSystem.ByteProgressionEventArgs
[C#]
protected ByteProgressionEventArgs m_byteProgressionArgs;

See Also

ZipEventsSession Class | ZipEventsSession Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipEventsSession.m_copyingZipByteProgressionArgs Field

An instance of the ByteProgressionEventArgs class that provides byte progression information for the current session.

[Visual Basic]
Protected m_copyingZipByteProgressionArgs As Xceed.FileSystem.ByteProgressionEventArgs
[C#]
protected ByteProgressionEventArgs m_copyingZipByteProgressionArgs;

See Also

ZipEventsSession Class | ZipEventsSession Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipEventsSession.m_currentFileBytes Field

[Visual Basic]
Protected m_currentFileBytes As Xceed.FileSystem.ProgressionInfo
[C#]
protected ProgressionInfo m_currentFileBytes;

See Also

ZipEventsSession Class | ZipEventsSession Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipEventsSession.m_currentItem Field

[Visual Basic]
Protected m_currentItem As Xceed.FileSystem.FileSystemItem
[C#]
protected FileSystemItem m_currentItem;

See Also

ZipEventsSession Class | ZipEventsSession Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipEventsSession.m_events Field

[Visual Basic]
Protected m_events As Xceed.FileSystem.FileSystemEvents
[C#]
protected FileSystemEvents m_events;

See Also

ZipEventsSession Class | ZipEventsSession Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipEventsSession.m_itemExceptionArgs Field

[Visual Basic]
Protected m_itemExceptionArgs As Xceed.FileSystem.ItemExceptionEventArgs
[C#]
protected ItemExceptionEventArgs m_itemExceptionArgs;

See Also

ZipEventsSession Class | ZipEventsSession Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipEventsSession.m_itemPairQueue Field

[Visual Basic]
Protected m_itemPairQueue As System.Collections.Queue
[C#]
protected Queue m_itemPairQueue;

See Also

ZipEventsSession Class | ZipEventsSession Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipEventsSession.m_itemProgressionArgs Field

[Visual Basic]
Protected m_itemProgressionArgs As Xceed.FileSystem.ItemProgressionEventArgs
[C#]
protected ItemProgressionEventArgs m_itemProgressionArgs;

See Also

ZipEventsSession Class | ZipEventsSession Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipEventsSession.m_readingZipItemProgressionArgs Field

An instance of the ItemProgressionEventArgs class that provides item progression information for the current session.

[Visual Basic]
Protected m_readingZipItemProgressionArgs As Xceed.FileSystem.ItemProgressionEventArgs
[C#]
protected ItemProgressionEventArgs m_readingZipItemProgressionArgs;

See Also

ZipEventsSession Class | ZipEventsSession Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipEventsSession.m_scanningFolderArgs Field

[Visual Basic]
Protected m_scanningFolderArgs As Xceed.FileSystem.ScanningFolderEventArgs
[C#]
protected ScanningFolderEventArgs m_scanningFolderArgs;

See Also

ZipEventsSession Class | ZipEventsSession Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipEventsSession.m_sender Field

[Visual Basic]
Protected m_sender As Object
[C#]
protected object m_sender;

See Also

ZipEventsSession Class | ZipEventsSession Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipEventsSession.m_targetItem Field

[Visual Basic]
Protected m_targetItem As Xceed.FileSystem.FileSystemItem
[C#]
protected FileSystemItem m_targetItem;

See Also

ZipEventsSession Class | ZipEventsSession Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipEventsSession.m_userData Field

[Visual Basic]
Protected m_userData As Object
[C#]
protected object m_userData;

See Also

ZipEventsSession Class | ZipEventsSession Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipEventsSession.m_zipAllFilesBytes Field

An instance of the ProgressionInfo class representing the byte count information in regards to all the items to be processed for the current session.

[Visual Basic]
Protected m_zipAllFilesBytes As Xceed.FileSystem.ProgressionInfo
[C#]
protected ProgressionInfo m_zipAllFilesBytes;

See Also

ZipEventsSession Class | ZipEventsSession Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipEventsSession.m_zipAllItems Field

An instance of the ProgressionInfo class representing the item count information for the current session.

[Visual Basic]
Protected m_zipAllItems As Xceed.FileSystem.ProgressionInfo
[C#]
protected ProgressionInfo m_zipAllItems;

See Also

ZipEventsSession Class | ZipEventsSession Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipEventsSession.m_zipCurrentFileBytes Field

An instance of the ProgressionInfo class representing the byte count information in regards to the current item being processed for the current session.

[Visual Basic]
Protected m_zipCurrentFileBytes As Xceed.FileSystem.ProgressionInfo
[C#]
protected ProgressionInfo m_zipCurrentFileBytes;

See Also

ZipEventsSession Class | ZipEventsSession Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipEventsSession.m_zipEvents Field

An instance of the ZipEvents class representing the original ZipEvents object from which we created the session.

[Visual Basic]
Protected m_zipEvents As Xceed.Zip.ZipEvents
[C#]
protected ZipEvents m_zipEvents;

See Also

ZipEventsSession Class | ZipEventsSession Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipEventsSession Members

Public Instance Properties

CurrentItem (inherited from FileSystemEventsSession) | Gets or sets the FileSystemItem object currently being processed.
Events | Gets the original FileSystemEvents object used to create the session.
IsEmpty (inherited from FileSystemEventsSession) | Gets a boolean value indicating if the session's list of FileSystemItem objects to process contains no items.
TargetItem (inherited from FileSystemEventsSession) | Gets or sets the eventual target FileSystemItem object for the process.
UserData (inherited from FileSystemEventsSession) | Gets the opaque data that is sent back to the event handler when an event is raised.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetNextItemPair (inherited from FileSystemEventsSession) | Retrieves the next pair of FileSystemItem objects to be processed.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
InitializeCurrentTotalBytes | Initializes the total amount of bytes for the current zip item to be processed.
InitializeTotalBytes | Initializes the total amount of bytes for all zip items to be processed.
InitializeTotalItems | Initializes the total amount of zip items to be processed.
OnBuildingZipByteCompletion | The last BuildingZipByteProgression event raised once processing of a zip item is completed.
OnBuildingZipByteProgression | Raised every time a temporary zip file is being built.
OnBuildingZipItemCompletion | The last BuildingZipItemProgression event raised once processing is completed.
OnBuildingZipItemProgression | Raised every time a temporary zip file is being built.
OnBytesCompleted (inherited from FileSystemEventsSession) | Forces the byte progression to 100% completion.
OnBytesProcessed (inherited from FileSystemEventsSession) | Raises the ByteProgression event for a FileSystemItem object being processed.
OnCompletion (inherited from FileSystemEventsSession) | Raises the last ItemProgression event when the process is completed.
OnCopyingZipByteCompletion | The last CopyingZipByteProgression event raised once processing for a zip file is completed.
OnCopyingZipByteProgression | Raised every time the temporary zip file replaces the existing zip file.
OnException (inherited from FileSystemEventsSession) | Raises the ItemException event whenever an error occurs during the processing of a FileSystemItem object.
OnNewItemToProcess (inherited from FileSystemEventsSession) | Places the new item in the list of FileSystemItem objects to be processed.
OnProcessingNewItem (inherited from FileSystemEventsSession) | Raised when a new item is about to be processed.
OnReadingZipItemCompletion | The last ReadingZipItemProgression event raised once processing is completed.
OnReadingZipItemProgression | Raised every time a zip file is being read for the first time.
OnScanningFolder (inherited from FileSystemEventsSession) | Raised when a folder is scanned or accessed during the processing of FileSystemItem objects.
OnUndoBytesProcessed (inherited from FileSystemEventsSession) | Removes the amount of bytes processed for an item if an error occured during the processing of that item.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Fields

m_allFilesBytes |
m_allItems |
m_buildingZipByteProgressionArgs | An instance of the ByteProgressionEventArgs class that provides byte progression information for the current session.
m_buildingZipItemProgressionArgs | An instance of the ItemProgressionEventArgs class that provides item progression information for the current session.
m_byteProgressionArgs |
m_copyingZipByteProgressionArgs | An instance of the ByteProgressionEventArgs class that provides byte progression information for the current session.
m_currentFileBytes |
m_currentItem |
m_events |
m_itemExceptionArgs |
m_itemPairQueue |
m_itemProgressionArgs |
m_readingZipItemProgressionArgs | An instance of the ItemProgressionEventArgs class that provides item progression information for the current session.
m_scanningFolderArgs |
m_sender |
m_targetItem |
m_userData |
m_zipAllFilesBytes | An instance of the ProgressionInfo class representing the byte count information in regards to all the items to be processed for the current session.
m_zipAllItems | An instance of the ProgressionInfo class representing the item count information for the current session.
m_zipCurrentFileBytes | An instance of the ProgressionInfo class representing the byte count information in regards to the current item being processed for the current session.
m_zipEvents | An instance of the ZipEvents class representing the original ZipEvents object from which we created the session.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Internal Instance Constructors

ZipEventsSession Constructor Creates a new instance of the ZipEventsSession class.

See Also

ZipEventsSession Class | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipEventsSession Methods

The methods of the ZipEventsSession class are listed below. For a complete list of ZipEventsSession class members, see the ZipEventsSession Members topic.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetNextItemPair (inherited from FileSystemEventsSession) | Retrieves the next pair of FileSystemItem objects to be processed.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
InitializeCurrentTotalBytes | Initializes the total amount of bytes for the current zip item to be processed.
InitializeTotalBytes | Initializes the total amount of bytes for all zip items to be processed.
InitializeTotalItems | Initializes the total amount of zip items to be processed.
OnBuildingZipByteCompletion | The last BuildingZipByteProgression event raised once processing of a zip item is completed.
OnBuildingZipByteProgression | Raised every time a temporary zip file is being built.
OnBuildingZipItemCompletion | The last BuildingZipItemProgression event raised once processing is completed.
OnBuildingZipItemProgression | Raised every time a temporary zip file is being built.
OnBytesCompleted (inherited from FileSystemEventsSession) | Forces the byte progression to 100% completion.
OnBytesProcessed (inherited from FileSystemEventsSession) | Raises the ByteProgression event for a FileSystemItem object being processed.
OnCompletion (inherited from FileSystemEventsSession) | Raises the last ItemProgression event when the process is completed.
OnCopyingZipByteCompletion | The last CopyingZipByteProgression event raised once processing for a zip file is completed.
OnCopyingZipByteProgression | Raised every time the temporary zip file replaces the existing zip file.
OnException (inherited from FileSystemEventsSession) | Raises the ItemException event whenever an error occurs during the processing of a FileSystemItem object.
OnNewItemToProcess (inherited from FileSystemEventsSession) | Places the new item in the list of FileSystemItem objects to be processed.
OnProcessingNewItem (inherited from FileSystemEventsSession) | Raised when a new item is about to be processed.
OnReadingZipItemCompletion | The last ReadingZipItemProgression event raised once processing is completed.
OnReadingZipItemProgression | Raised every time a zip file is being read for the first time.
OnScanningFolder (inherited from FileSystemEventsSession) | Raised when a folder is scanned or accessed during the processing of FileSystemItem objects.
OnUndoBytesProcessed (inherited from FileSystemEventsSession) | Removes the amount of bytes processed for an item if an error occured during the processing of that item.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

ZipEventsSession Class | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipEventsSession.OnBuildingZipByteCompletion Method

The last BuildingZipByteProgression event raised once processing of a zip item is completed.

[Visual Basic]
Public Sub OnBuildingZipByteCompletion()
[C#]
public void OnBuildingZipByteCompletion();

See Also

ZipEventsSession Class | ZipEventsSession Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipEventsSession.OnBuildingZipByteProgression Method

Raised every time a temporary zip file is being built.

[Visual Basic]
Public Sub OnBuildingZipByteProgression( _
   ByVal increment As Long _
)
[C#]
public void OnBuildingZipByteProgression(
   long increment
);

Parameters

increment

The amount of bytes to be added to the total amount of bytes processed so far.

See Also

ZipEventsSession Class | ZipEventsSession Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipEventsSession.OnBuildingZipItemCompletion Method

The last BuildingZipItemProgression event raised once processing is completed.

[Visual Basic]
Public Sub OnBuildingZipItemCompletion()
[C#]
public void OnBuildingZipItemCompletion();

See Also

ZipEventsSession Class | ZipEventsSession Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipEventsSession.OnBuildingZipItemProgression Method

Raised every time a temporary zip file is being built.

[Visual Basic]
Public Sub OnBuildingZipItemProgression( _
   ByVal currentItem As Xceed.FileSystem.FileSystemItem _
)
[C#]
public void OnBuildingZipItemProgression(
   FileSystemItem currentItem
);

Parameters

currentItem

The current zip item object being processed.

See Also

ZipEventsSession Class | ZipEventsSession Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipEventsSession.OnCopyingZipByteCompletion Method

The last CopyingZipByteProgression event raised once processing for a zip file is completed.

[Visual Basic]
Public Sub OnCopyingZipByteCompletion()
[C#]
public void OnCopyingZipByteCompletion();

See Also

ZipEventsSession Class | ZipEventsSession Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipEventsSession.OnCopyingZipByteProgression Method

Raised every time the temporary zip file replaces the existing zip file.

[Visual Basic]
Public Sub OnCopyingZipByteProgression( _
   ByVal increment As Long _
)
[C#]
public void OnCopyingZipByteProgression(
   long increment
);

Parameters

increment

The amount of bytes to be added to the total amount of bytes processed so far.

See Also

ZipEventsSession Class | ZipEventsSession Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipEventsSession.OnReadingZipItemCompletion Method

The last ReadingZipItemProgression event raised once processing is completed.

[Visual Basic]
Public Sub OnReadingZipItemCompletion()
[C#]
public void OnReadingZipItemCompletion();

See Also

ZipEventsSession Class | ZipEventsSession Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipEventsSession.OnReadingZipItemProgression Method

Raised every time a zip file is being read for the first time.

[Visual Basic]
Public Sub OnReadingZipItemProgression( _
   ByVal currentItem As Xceed.FileSystem.FileSystemItem _
)
[C#]
public void OnReadingZipItemProgression(
   FileSystemItem currentItem
);

Parameters

currentItem

The current zip item object being processed.

See Also

ZipEventsSession Class | ZipEventsSession Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipEventsSession Properties

The properties of the ZipEventsSession class are listed below. For a complete list of ZipEventsSession class members, see the ZipEventsSession Members topic.

Public Instance Properties

CurrentItem (inherited from FileSystemEventsSession) | Gets or sets the FileSystemItem object currently being processed.
Events | Gets the original FileSystemEvents object used to create the session.
IsEmpty (inherited from FileSystemEventsSession) | Gets a boolean value indicating if the session's list of FileSystemItem objects to process contains no items.
TargetItem (inherited from FileSystemEventsSession) | Gets or sets the eventual target FileSystemItem object for the process.
UserData (inherited from FileSystemEventsSession) | Gets the opaque data that is sent back to the event handler when an event is raised.

See Also

ZipEventsSession Class | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipEvents.WantsBuildingZipByteProgression Property

Gets a boolean value indicating if the ZipEvents object has subscribed to the OnBuildingZipByteProgression event.

[Visual Basic]
Overridable Protected Friend ReadOnly Property WantsBuildingZipByteProgression As Boolean
[C#]
protected internal bool WantsBuildingZipByteProgression {virtual get;}

Property Value

true if the ZipEvents object has subscribed to the OnBuildingZipByteProgression event; false otherwise.

See Also

ZipEvents Class | ZipEvents Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipEvents.WantsBuildingZipItemProgression Property

Gets a boolean value indicating if the ZipEvents object has subscribed to the OnBuildingZipItemProgression event.

[Visual Basic]
Overridable Protected Friend ReadOnly Property WantsBuildingZipItemProgression As Boolean
[C#]
protected internal bool WantsBuildingZipItemProgression {virtual get;}

Property Value

true if the ZipEvents object has subscribed to the OnBuildingZipItemProgression event; false otherwise.

See Also

ZipEvents Class | ZipEvents Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipEvents.WantsCopyingZipByteProgression Property

Gets a boolean value indicating if the ZipEvents object has subscribed to the OnCopyingZipByteProgression event.

[Visual Basic]
Overridable Protected Friend ReadOnly Property WantsCopyingZipByteProgression As Boolean
[C#]
protected internal bool WantsCopyingZipByteProgression {virtual get;}

Property Value

true if the ZipEvents object has subscribed to the OnCopyingZipByteProgression event; false otherwise.

See Also

ZipEvents Class | ZipEvents Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipEvents.WantsReadingZipItemProgression Property

Gets a boolean value indicating if the ZipEvents object has subscribed to the OnReadingZipItemProgression event.

[Visual Basic]
Overridable Protected Friend ReadOnly Property WantsReadingZipItemProgression As Boolean
[C#]
protected internal bool WantsReadingZipItemProgression {virtual get;}

Property Value

true if the ZipEvents object has subscribed to the OnReadingZipItemProgression event; false otherwise.

See Also

ZipEvents Class | ZipEvents Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipException Class

Exception that is thrown when an error occurs in the Xceed.Zip namespace.

For a list of all members of this type, see ZipException Members.

System.Object
Exception
ApplicationException
FileSystemException
ZipException

[Visual Basic]
Public Class ZipException
   Inherits FileSystemException
   Implements ISerializable
[C#]
public class ZipException : FileSystemException, ISerializable

Remarks

This exception serves as the base class for all custom exceptions defined in the Xceed.Zip namespace.

Requirements

Namespace: Xceed.Zip Namespace

Assembly: Xceed.Zip.dll

See Also

ZipException Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipException Constructor

Xceed Zip for .NET

ZipException

Initializes a new instance of the ZipException class with the specified message text.

Overload List

Initializes a new instance of the ZipException class with the specified message text.

public ZipException(string);

Initializes a new instance of the ZipException class with the specified message text and AbstractFile object.

public ZipException(string,AbstractFile);

Initializes a new instance of the ZipException class with the specified message text, AbstractFile object and inner exception.

public ZipException(string,AbstractFile,Exception);

Initializes a new instance of the ZipException class with the specified message text, AbstractFile and FileSystemItem objects.

public ZipException(string,AbstractFile,FileSystemItem);

Initializes a new instance of the ZipException class with the specified message text, AbstractFile and FileSystemItem objects and inner exception.

public ZipException(string,AbstractFile,FileSystemItem,Exception);

See Also

ZipException Class | ZipException Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipException Constructor (String)

Initializes a new instance of the ZipException class with the specified message text.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public ZipException(
   string message
);

Parameters

message

The error message that explains the reason for the exception.

See Also

ZipException Class | ZipException Members | Xceed.Zip Namespace | ZipException Constructor Overload List

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipException Constructor (String, AbstractFile)

Initializes a new instance of the ZipException class with the specified message text and AbstractFile object.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal zipFile As Xceed.FileSystem.AbstractFile _
)
[C#]
public ZipException(
   string message,
   AbstractFile zipFile
);

Parameters

message

The error message that explains the reason for the exception.

zipFile

The AbstractFile object that caused the current exception.

See Also

ZipException Class | ZipException Members | Xceed.Zip Namespace | ZipException Constructor Overload List

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipException Constructor (String, AbstractFile, Exception)

Initializes a new instance of the ZipException class with the specified message text, AbstractFile object and inner exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal zipFile As Xceed.FileSystem.AbstractFile, _
   ByVal inner As System.Exception _
)
[C#]
public ZipException(
   string message,
   AbstractFile zipFile,
   Exception inner
);

Parameters

message

The error message that explains the reason for the exception.

zipFile

The AbstractFile object that caused the current exception.

inner

The exception that initially caused the current exception to be thrown.

See Also

ZipException Class | ZipException Members | Xceed.Zip Namespace | ZipException Constructor Overload List

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipException Constructor (String, AbstractFile, FileSystemItem)

Initializes a new instance of the ZipException class with the specified message text, AbstractFile and FileSystemItem objects.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal zipFile As Xceed.FileSystem.AbstractFile, _
   ByVal item As Xceed.FileSystem.FileSystemItem _
)
[C#]
public ZipException(
   string message,
   AbstractFile zipFile,
   FileSystemItem item
);

Parameters

message

The error message that explains the reason for the exception.

zipFile

The AbstractFile object that caused the current exception.

item

The Xceed.FileSystem object that caused the exception.

See Also

ZipException Class | ZipException Members | Xceed.Zip Namespace | ZipException Constructor Overload List

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipException Constructor (String, AbstractFile, FileSystemItem, Exception)

Initializes a new instance of the ZipException class with the specified message text, AbstractFile and FileSystemItem objects and inner exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal zipFile As Xceed.FileSystem.AbstractFile, _
   ByVal item As Xceed.FileSystem.FileSystemItem, _
   ByVal inner As System.Exception _
)
[C#]
public ZipException(
   string message,
   AbstractFile zipFile,
   FileSystemItem item,
   Exception inner
);

Parameters

message

The error message that explains the reason for the exception.

zipFile

The AbstractFile object that caused the current exception.

item

The Xceed.FileSystem object that caused the exception.

inner

The exception that initially caused the current exception to be thrown.

See Also

ZipException Class | ZipException Members | Xceed.Zip Namespace | ZipException Constructor Overload List

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipException Members

Public Instance Constructors

ZipException Overloaded. Initialize a new instance of the ZipException class.

Public Instance Properties

HelpLink (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
InnerException (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
Item (inherited from FileSystemException) | Gets or sets the FileSystemItem object that caused the current exception.
Message | Gets a message that describes the current exception.
Source (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
StackTrace (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
TargetSite (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
ZipFile | Gets or sets an AbstractFile object representing the zip file in which the current exception occured.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetBaseException (inherited from Exception) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetObjectData (inherited from Exception) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Exception) | Select the method name to go to the Microsoft documentation.

Protected Instance Properties

HResult (inherited from System.Exception) Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

ZipException Class | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipException.Message Property

Gets a message that describes the current exception.

[Visual Basic]
Overrides Public ReadOnly Property Message As String
[C#]
public string Message {override get;}

Property Value

A message that describes the current exception, or an empty string.

See Also

ZipException Class | ZipException Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipException Properties

The properties of the ZipException class are listed below. For a complete list of ZipException class members, see the ZipException Members topic.

Public Instance Properties

HelpLink (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
InnerException (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
Item (inherited from FileSystemException) | Gets or sets the FileSystemItem object that caused the current exception.
Message | Gets a message that describes the current exception.
Source (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
StackTrace (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
TargetSite (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
ZipFile | Gets or sets an AbstractFile object representing the zip file in which the current exception occured.

Protected Instance Properties

HResult (inherited from System.Exception) Select the method name to go to the Microsoft documentation.

See Also

ZipException Class | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipException.ZipFile Property

Gets or sets an AbstractFile object representing the zip file in which the current exception occured.

[Visual Basic]
Public Property ZipFile As Xceed.FileSystem.AbstractFile
[C#]
public Xceed.FileSystem.AbstractFile ZipFile {get; set;}

Property Value

An AbstractFile object representing the zip file in which the exception occured. Can be a null reference (Nothing in Visual Basic).

See Also

ZipException Class | ZipException Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipIOException Class

Exception that is thrown when an IO exception occurs while reading from or writing to the ZIP file.

For a list of all members of this type, see ZipIOException Members.

System.Object
Exception
ApplicationException
FileSystemException
ZipException
ZipIOException

[Visual Basic]
Public Class ZipIOException
   Inherits ZipException
   Implements ISerializable
[C#]
public class ZipIOException : ZipException, ISerializable

Requirements

Namespace: Xceed.Zip Namespace

Assembly: Xceed.Zip.dll

See Also

ZipIOException Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipIOException Constructor

Xceed Zip for .NET

ZipIOException

Initializes a new instance of the ZipIOException class.

Overload List

Initializes a new instance of the ZipIOException class.

public ZipIOException();

Initializes a new instance of the ZipIOException class with the specified message text.

public ZipIOException(string);

Initializes a new instance of the ZipIOException class with the specified AbstractFile object.

public ZipIOException(AbstractFile);

Initializes a new instance of the ZipIOException class with the specified message text and AbstractFile object.

public ZipIOException(string,AbstractFile);

Initializes a new instance of the ZipIOException class with the specified AbstractFile object and inner exception.

public ZipIOException(AbstractFile,Exception);

Initializes a new instance of the ZipIOException class with the specified message text, AbstractFile object and inner exception.

public ZipIOException(string,AbstractFile,Exception);

See Also

ZipIOException Class | ZipIOException Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipIOException Constructor ()

Initializes a new instance of the ZipIOException class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public ZipIOException();

See Also

ZipIOException Class | ZipIOException Members | Xceed.Zip Namespace | ZipIOException Constructor Overload List

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipIOException Constructor (String)

Initializes a new instance of the ZipIOException class with the specified message text.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public ZipIOException(
   string message
);

Parameters

message

The error message that explains the reason for the exception.

See Also

ZipIOException Class | ZipIOException Members | Xceed.Zip Namespace | ZipIOException Constructor Overload List

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipIOException Constructor (AbstractFile)

Initializes a new instance of the ZipIOException class with the specified AbstractFile object.

[Visual Basic]
Overloads Public Sub New( _
   ByVal zipFile As Xceed.FileSystem.AbstractFile _
)
[C#]
public ZipIOException(
   AbstractFile zipFile
);

Parameters

zipFile

The AbstractFile object that caused the current exception.

See Also

ZipIOException Class | ZipIOException Members | Xceed.Zip Namespace | ZipIOException Constructor Overload List

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipIOException Constructor (String, AbstractFile)

Initializes a new instance of the ZipIOException class with the specified message text and AbstractFile object.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal zipFile As Xceed.FileSystem.AbstractFile _
)
[C#]
public ZipIOException(
   string message,
   AbstractFile zipFile
);

Parameters

message

The error message that explains the reason for the exception.

zipFile

The AbstractFile object that caused the current exception.

See Also

ZipIOException Class | ZipIOException Members | Xceed.Zip Namespace | ZipIOException Constructor Overload List

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipIOException Constructor (AbstractFile, Exception)

Initializes a new instance of the ZipIOException class with the specified AbstractFile object and inner exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal zipFile As Xceed.FileSystem.AbstractFile, _
   ByVal inner As System.Exception _
)
[C#]
public ZipIOException(
   AbstractFile zipFile,
   Exception inner
);

Parameters

zipFile

The AbstractFile object that caused the current exception.

inner

The exception that initially caused the current exception to be thrown.

See Also

ZipIOException Class | ZipIOException Members | Xceed.Zip Namespace | ZipIOException Constructor Overload List

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipIOException Constructor (String, AbstractFile, Exception)

Initializes a new instance of the ZipIOException class with the specified message text, AbstractFile object and inner exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal zipFile As Xceed.FileSystem.AbstractFile, _
   ByVal inner As System.Exception _
)
[C#]
public ZipIOException(
   string message,
   AbstractFile zipFile,
   Exception inner
);

Parameters

message

The error message that explains the reason for the exception.

zipFile

The AbstractFile object that caused the current exception.

inner

The exception that initially caused the current exception to be thrown.

See Also

ZipIOException Class | ZipIOException Members | Xceed.Zip Namespace | ZipIOException Constructor Overload List

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZipIOException Members

Public Instance Constructors

ZipIOException Overloaded. Initialize a new instance of the ZipIOException class.

Public Instance Properties

HelpLink (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
InnerException (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
Item (inherited from FileSystemException) | Gets or sets the FileSystemItem object that caused the current exception.
Message (inherited from ZipException) | Gets a message that describes the current exception.
Source (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
StackTrace (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
TargetSite (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
ZipFile (inherited from ZipException) | Gets or sets an AbstractFile object representing the zip file in which the current exception occured.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetBaseException (inherited from Exception) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetObjectData (inherited from Exception) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Exception) | Select the method name to go to the Microsoft documentation.

Protected Instance Properties

HResult (inherited from System.Exception) Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

ZipIOException Class | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFile Class

Specialization of the AbstractFile class that implements access to a file stored within a ZIP file.

For a list of all members of this type, see ZippedFile Members.

System.Object
MarshalByRefObject
FileSystemItem
AbstractFile
ZippedFile

[Visual Basic]
Public Class ZippedFile
   Inherits AbstractFile
[C#]
public class ZippedFile : AbstractFile

Requirements

Namespace: Xceed.Zip Namespace

Assembly: Xceed.Zip.dll

See Also

ZippedFile Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFile.Comment Property

Gets or sets the file's comment.

[Visual Basic]
Overridable Public Property Comment As String
[C#]
public string Comment {virtual get; virtual set;}

Property Value

A string containing the file's comment.

See Also

ZippedFile Class | ZippedFile Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFile.CompressedSize Property

Gets the file's compressed size in bytes.

[Visual Basic]
Overridable Public ReadOnly Property CompressedSize As Long
[C#]
public long CompressedSize {virtual get;}

Property Value

A value indicating the file's compressed size in bytes.

See Also

ZippedFile Class | ZippedFile Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFile.CompressionLevel Property

Gets the Xceed.Compression.CompressionLevel level that was used to compress the file.

[Visual Basic]
Overridable Public ReadOnly Property CompressionLevel As Xceed.Compression.CompressionLevel
[C#]
public Xceed.Compression.CompressionLevel CompressionLevel {virtual get;}

Property Value

A value indicating the Xceed.Compression.CompressionLevel level that was used to compress the file.

See Also

ZippedFile Class | ZippedFile Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFile.CompressionMethod Property

Gets the Xceed.Compression.CompressionMethod that was used to compress the file.

[Visual Basic]
Overridable Public ReadOnly Property CompressionMethod As Xceed.Compression.CompressionMethod
[C#]
public Xceed.Compression.CompressionMethod CompressionMethod {virtual get;}

Property Value

A value indicating the Xceed.Compression.CompressionMethod that was used to compress the file.

See Also

ZippedFile Class | ZippedFile Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFile Constructor

Xceed Zip for .NET

ZippedFile

Initializes a new instance of the ZippedFile class.

Overload List

Initializes a new instance of the ZippedFile class.

public ZippedFile(AbstractFile,string);

Initializes a new instance of the ZippedFile class enabling event notifications while the object is being created.

public ZippedFile(FileSystemEvents,object,AbstractFile,string);

internal ZippedFile(ZipItemHandler);

See Also

ZippedFile Class | ZippedFile Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFile Constructor (AbstractFile, String)

Initializes a new instance of the ZippedFile class.

[Visual Basic]
Overloads Public Sub New( _
   ByVal zipFile As Xceed.FileSystem.AbstractFile, _
   ByVal fileName As String _
)
[C#]
public ZippedFile(
   AbstractFile zipFile,
   string fileName
);

Parameters

zipFile

AbstractFile object that represents the ZIP file to access.

fileName

Fully-qualified name of the file stored within the ZIP file. This file may or may not exist in the ZIP file.

See Also

ZippedFile Class | ZippedFile Members | Xceed.Zip Namespace | ZippedFile Constructor Overload List

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFile Constructor (FileSystemEvents, Object, AbstractFile, String)

Initializes a new instance of the ZippedFile class enabling event notifications while the object is being created.

[Visual Basic]
Overloads Public Sub New( _
   ByVal events As Xceed.FileSystem.FileSystemEvents, _
   ByVal userData As Object, _
   ByVal zipFile As Xceed.FileSystem.AbstractFile, _
   ByVal fileName As String _
)
[C#]
public ZippedFile(
   FileSystemEvents events,
   object userData,
   AbstractFile zipFile,
   string fileName
);

Parameters

events

A FileSystemEvents object that will be used to raise events. Cannot be a null reference (Nothing in Visual Basic).

userData

Opaque data that will be passed back to the event handler when an event is raised.

zipFile

AbstractFile object that represents the ZIP file to access.

fileName

Fully-qualified name of the file stored within the ZIP file. This file may or may not exist within the ZIP file.

Remarks

Once the ZippedFile object is created, it does not keep a reference on the event object.

See Also

ZippedFile Class | ZippedFile Members | Xceed.Zip Namespace | ZippedFile Constructor Overload List

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFile Constructor (ZipItemHandler)

[Visual Basic]
Overloads Friend Sub New( _
   ByVal handler As Xceed.Zip.ZipItemHandler _
)
[C#]
internal ZippedFile(
   ZipItemHandler handler
);

See Also

ZippedFile Class | ZippedFile Members | Xceed.Zip Namespace | ZippedFile Constructor Overload List

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFile.Crc32 Property

Gets the file's uncompressed data CRC checksum.

[Visual Basic]
Overridable Public ReadOnly Property Crc32 As Integer
[C#]
public int Crc32 {virtual get;}

Property Value

A value indicating the file's uncompressed data CRC checksum.

Remarks

The CRC (Cyclic Redundancy Check) is a 32-bit checksum system that is used to verify the integrity of data.

The zip file format contains the 32-bit CRC of each file's original uncompressed data. When a file is unzipped, the CRC is calculated on the file's newly unzipped data and compared with the stored CRC of the original file. If the CRCs are the same, then the unzipped file is very probably identical to the original file, because the 32-bit CRC is able to detect single bit variations even in the largest files.

See Also

ZippedFile Class | ZippedFile Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFile.DoApplyPropertiesTo Method

Copies the files properties to another item.

[Visual Basic]
Overrides Protected Sub DoApplyPropertiesTo( _
   ByVal session As Xceed.FileSystem.FileSystemEventsSession, _
   ByVal targetItem As Xceed.FileSystem.FileSystemItem _
)
[C#]
protected override void DoApplyPropertiesTo(
   FileSystemEventsSession session,
   FileSystemItem targetItem
);

Parameters

session

A reference to a FileSystemEventsSession object which is responsible for raising all events that occur during the process.

targetItem

A FileSystemItem object to which the current file's properties must be copied. Cannot not be a null reference (Nothing in Visual Basic).

See Also

ZippedFile Class | ZippedFile Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFile.DoAttributes Property

Gets or sets the attributes of the item.

[Visual Basic]
Overrides Protected Property DoAttributes As System.IO.FileAttributes
[C#]
protected System.IO.FileAttributes DoAttributes {override get; override set;}

Property Value

A combination of System.IO.FileAttributes values that represents the attributes of the item.

Remarks

When changing the item's attributes through this property, the physical item is immediately modified if it exists. If it does not exist, the attributes are cached and will be applied whenever this item is created.

Some types of items may not expose attributes. In this case, an exception is thrown when trying to read or modify the attributes.

Note: Refresh should be called before accessing this property, or the information returned could be outdated.

Exceptions

Exception Type | Condition
Xceed.FileSystem.FileSystemNotSupportedException | The item does not expose attributes, or does not support one of the assigned attributes.
Xceed.FileSystem.ItemIsRootFolderException | The physical item is a root folder.

See Also

ZippedFile Class | ZippedFile Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFile.DoCreate Method

Creates the physical file in the zip file.

[Visual Basic]
Overrides Protected Sub DoCreate( _
   ByVal session As Xceed.FileSystem.FileSystemEventsSession _
)
[C#]
protected override void DoCreate(
   FileSystemEventsSession session
);

Parameters

session

A reference to a FileSystemEventsSession object which is responsible for raising all events that occur during the process.

Remarks

The file must be created in a folder that exists otherwise an exception will be thrown.

Exceptions

Exception Type | Condition
Xceed.FileSystem.ItemAlreadyExistsException | The physical file already exists.

See Also

ZippedFile Class | ZippedFile Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFile.DoCreationDateTime Property

Gets or sets the creation date and time of the item.

[Visual Basic]
Overrides Protected Property DoCreationDateTime As Date
[C#]
protected System.DateTime DoCreationDateTime {override get; override set;}

Property Value

The date and time when the item was created.

Remarks

When changing the item's creation date through this property, the physical item is immediately modified if it exists. If it does not exist, the date is cached and will be applied whenever this item is created.

Some types of items may not expose a creation date and time. In this case, an exception is thrown when trying to read or modify the creation date.

Other types of items that do expose a creation date and time may not have the information available. In this case, System.DateTime.MinValue is returned.

Note: Refresh should be called before accessing this property, or the information returned could be outdated.

Exceptions

Exception Type | Condition
System.ArgumentException | The provided creation date is not valid for this item.
Xceed.FileSystem.FileSystemNotSupportedException | The item does not expose a creation date.
Xceed.FileSystem.ItemIsReadOnlyException | The item has the ReadOnly attribute, preventing it from being modified.
Xceed.FileSystem.ItemIsRootFolderException | The item is a root folder.

See Also

ZippedFile Class | ZippedFile Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFile.DoDelete Method

Permanently deletes the file within the zip file.

[Visual Basic]
Overrides Protected Sub DoDelete( _
   ByVal session As Xceed.FileSystem.FileSystemEventsSession _
)
[C#]
protected override void DoDelete(
   FileSystemEventsSession session
);

Parameters

session

A reference to a FileSystemEventsSession object which is responsible for raising all events that occur during the process.

Exceptions

Exception Type | Condition
Xceed.FileSystem.ItemDoesNotExistException | The file does not exist.
Xceed.FileSystem.ItemIsReadOnlyException | The file has the FileAttributes.ReadOnly attribute set.

See Also

ZippedFile Class | ZippedFile Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFile.DoExists Property

Gets a boolean value indicating if the item physically exists.

[Visual Basic]
Overrides Protected ReadOnly Property DoExists As Boolean
[C#]
protected bool DoExists {override get;}

Property Value

true if the item physically exists; false otherwise.

Remarks

This property should be evaluated before calling a method that needs to access the underlying physical item (For example, CopyTo), otherwise these methods will throw an exception.

Note: Refresh does not need to be called before accessing this property. The property will always reflect the physical item's existence.

See Also

ZippedFile Class | ZippedFile Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFile.DoFullName Property

Gets the full name of the item.

[Visual Basic]
Overrides Protected ReadOnly Property DoFullName As String
[C#]
protected string DoFullName {override get;}

Property Value

A string that represents the full name of the item.

Remarks

The full name consists of the item's name fully-qualified with a path. For example: "c:\foo\bar.txt", "c:\foo\".

If the item represents a file, its name does not end with a path separator character.

If the item represents a folder, its name does end with a path separator character.

The separator character is defined in System.IO.Path.DirectorySeparatorChar and System.IO.Path.AltDirectorySeparatorChar.

See Also

ZippedFile Class | ZippedFile Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFile.DoLastAccessDateTime Property

Gets or sets the last access date and time of the item.

[Visual Basic]
Overrides Protected Property DoLastAccessDateTime As Date
[C#]
protected System.DateTime DoLastAccessDateTime {override get; override set;}

Property Value

The date and time when the item was last accessed.

Remarks

When changing the item's access date through this property, the physical item is immediately modified if it exists. If it does not exist, the date is cached and will be applied whenever this item is created.

Some types of items may not expose a last access date and time. In this case, an exception is thrown when trying to read or modify the access date.

Other types of items that do expose a last access date and time may not have the information available. In this case, System.DateTime.MinValue is returned.

Note: Refresh should be called before accessing this property, or the information returned could be outdated.

Exceptions

Exception Type | Condition
System.ArgumentException | The provided last access date is not valid for this item.
Xceed.FileSystem.FileSystemNotSupportedException | The item does not expose a last access date.
Xceed.FileSystem.ItemIsReadOnlyException | The item has the ReadOnly attribute, preventing it from being modified.
Xceed.FileSystem.ItemIsRootFolderException | The physical item is a root folder.

See Also

ZippedFile Class | ZippedFile Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFile.DoLastWriteDateTime Property

Gets or sets the modification date and time of the item.

[Visual Basic]
Overrides Protected Property DoLastWriteDateTime As Date
[C#]
protected System.DateTime DoLastWriteDateTime {override get; override set;}

Property Value

The date and time when the item was modified.

Remarks

When changing the item's modification date through this property, the physical item is immediately modified if it exists. If it does not exist, the date is cached and will be applied whenever this item is created.

Some types of items may not expose a modification date and time. In this case, an exception is thrown when trying to read or modify the modification date.

Other types of items that do expose a modification date and time may not have the information available. In this case, System.DateTime.MinValue is returned.

Note: Refresh should be called before accessing this property, or the information returned could be outdated.

Exceptions

Exception Type | Condition
System.ArgumentException | The provided modification date is not valid for this item.
Xceed.FileSystem.FileSystemNotSupportedException | The item does not expose a modification date.
Xceed.FileSystem.ItemIsReadOnlyException | The item has the ReadOnly attribute, preventing it from being modified.
Xceed.FileSystem.ItemIsRootFolderException | The item is a root folder.

See Also

ZippedFile Class | ZippedFile Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFile.DoName Property

Gets or sets the short name of the item.

[Visual Basic]
Overrides Protected Property DoName As String
[C#]
protected string DoName {override get; override set;}

Property Value

A string that represents the short name of the item.

Remarks

The short name consists of the item's name without a path.

For example, the short name of a file named "c:\foo\bar.txt" is "bar.txt", and the short name of a folder named "c:\foo\" is "foo".

When assigning a new name to this property, the physical item is immediately renamed if it exists. If it does not exist, the new name is cached and will be applied whenever this item is created. In either cases, if a physical item with the same name already exists, an exception is thrown.

The short name of an item must not end with a path separator character regardless of whether it represents a file or a folder.

The separator character is defined in System.IO.Path.DirectorySeparatorChar and System.IO.Path.AltDirectorySeparatorChar.

Exceptions

Exception Type | Condition
System.ArgumentException | The new name assigned to the item is an empty string, contains only white space, contains a path, or contains invalid characters as defined in InvalidChars.
Xceed.FileSystem.ItemAlreadyExistsException | The new name corresponds to a physical item that already exists.
Xceed.FileSystem.ItemIsRootFolderException | The item is a root folder.

See Also

ZippedFile Class | ZippedFile Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


DoOpenRead Method

Xceed Zip for .NET

ZippedFile.DoOpenRead

Opens the file for reading with the specified System.IO.FileShare constant.

Overload List

Opens the file for reading with the specified System.IO.FileShare constant and password.

protected virtual Stream DoOpenRead(FileSystemEventsSession,FileShare,string);

Opens the file for reading with the specified System.IO.FileShare constant.

protected override Stream DoOpenRead(FileSystemEventsSession,FileShare);

See Also

ZippedFile Class | ZippedFile Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFile.DoOpenRead Method (FileSystemEventsSession, FileShare, String)

Opens the file for reading with the specified System.IO.FileShare constant and password.

[Visual Basic]
Overridable Overloads Protected Function DoOpenRead( _
   ByVal session As Xceed.FileSystem.FileSystemEventsSession, _
   ByVal share As System.IO.FileShare, _
   ByVal decryptionPassword As String _
) As System.IO.Stream
[C#]
protected virtual Stream DoOpenRead(
   FileSystemEventsSession session,
   FileShare share,
   string decryptionPassword
);

Parameters

session

A reference to a FileSystemEventsSession object which is responsible for raising all events that occur during the process.

share

A System.IO.FileShare constant that determines how the file will be shared by different processes.

decryptionPassword

The password to use to decrypt the file.

Return Value

A System.IO.Stream object that can be used to read data from the file.

Remarks

The returned stream is guaranteed to be readable, but may or may not be seekable.

See Also

ZippedFile Class | ZippedFile Members | Xceed.Zip Namespace | ZippedFile.DoOpenRead Overload List

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFile.DoOpenRead Method (FileSystemEventsSession, FileShare)

Opens the file for reading with the specified System.IO.FileShare constant.

[Visual Basic]
Overrides Overloads Protected Function DoOpenRead( _
   ByVal session As Xceed.FileSystem.FileSystemEventsSession, _
   ByVal share As System.IO.FileShare _
) As System.IO.Stream
[C#]
protected override Stream DoOpenRead(
   FileSystemEventsSession session,
   FileShare share
);

Parameters

session

A reference to a FileSystemEventsSession object which is responsible for raising all events that occur during the process.

share

A System.IO.FileShare constant that determines how the file will be shared by different processes.

Return Value

A System.IO.Stream object that can be used to read data from the file.

Remarks

The returned stream is guaranteed to be readable, but may or may not be seekable.

Exceptions

Exception Type | Condition
Xceed.FileSystem.ItemDoesNotExistException | The file does not physically exist.
Xceed.FileSystem.FileSystemNotSupportedException | The file cannot be opened for reading.

See Also

ZippedFile Class | ZippedFile Members | Xceed.Zip Namespace | ZippedFile.DoOpenRead Overload List

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


DoOpenWrite Method

Xceed Zip for .NET

ZippedFile.DoOpenWrite

Opens the file for writing with the specified System.IO.FileShare constant

Overload List

Opens the file for writing with the specified System.IO.FileShare constant and password.

protected virtual Stream DoOpenWrite(FileSystemEventsSession,bool,FileShare,CompressionMethod,CompressionLevel,string);

Opens the file for writing with the specified System.IO.FileShare constant

protected override Stream DoOpenWrite(FileSystemEventsSession,bool,FileShare);

See Also

ZippedFile Class | ZippedFile Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFile.DoOpenWrite Method (FileSystemEventsSession, Boolean, FileShare, CompressionMethod, CompressionLevel, String)

Opens the file for writing with the specified System.IO.FileShare constant and password.

[Visual Basic]
Overridable Overloads Protected Function DoOpenWrite( _
   ByVal session As Xceed.FileSystem.FileSystemEventsSession, _
   ByVal overwrite As Boolean, _
   ByVal share As System.IO.FileShare, _
   ByVal compressionMethod As Xceed.Compression.CompressionMethod, _
   ByVal compressionLevel As Xceed.Compression.CompressionLevel, _
   ByVal encryptionPassword As String _
) As System.IO.Stream
[C#]
protected virtual Stream DoOpenWrite(
   FileSystemEventsSession session,
   bool overwrite,
   FileShare share,
   CompressionMethod compressionMethod,
   CompressionLevel compressionLevel,
   string encryptionPassword
);

Parameters

session

A reference to a FileSystemEventsSession object which is responsible for raising all events that occur during the process.

overwrite

true if existing data for the file should be replaced; false if existing data should be preserved, appending new data at the end.

share

A System.IO.FileShare constant that determines how the file will be shared by different processes.

compressionMethod

The Xceed.Compression.CompressionMethod that will be used to compress the file.

compressionLevel

The Xceed.Compression.CompressionLevel that will be used when compressing the file.

encryptionPassword

The password that will be used to encrypt the file.

Return Value

A System.IO.Stream object that can be used to write data to the file.

Remarks

The returned stream is guaranteed to be writable, but may or may not be seekable.

If there is no existing data, the parameter overwrite is ignored.

See Also

ZippedFile Class | ZippedFile Members | Xceed.Zip Namespace | ZippedFile.DoOpenWrite Overload List

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFile.DoOpenWrite Method (FileSystemEventsSession, Boolean, FileShare)

Opens the file for writing with the specified System.IO.FileShare constant

[Visual Basic]
Overrides Overloads Protected Function DoOpenWrite( _
   ByVal session As Xceed.FileSystem.FileSystemEventsSession, _
   ByVal overwrite As Boolean, _
   ByVal share As System.IO.FileShare _
) As System.IO.Stream
[C#]
protected override Stream DoOpenWrite(
   FileSystemEventsSession session,
   bool overwrite,
   FileShare share
);

Parameters

session

A reference to a FileSystemEventsSession object which is responsible for raising all events that occur during the process.

overwrite

true if existing data for the file should be replaced; false if existing data should be preserved, appending new data at the end.

share

A System.IO.FileShare constant that determines how the file will be shared by different processes.

Return Value

A System.IO.Stream object that can be used to write data to the file.

Remarks

The returned stream is guaranteed to be writable, but may or may not be seekable.

If there is no existing data, the parameter overwrite is ignored.

Exceptions

Exception Type | Condition
Xceed.FileSystem.ItemDoesNotExistException | The file does not physically exist.
Xceed.FileSystem.ItemIsReadOnlyException | The file has the FileAttributes.ReadOnly attribute set.
Xceed.FileSystem.FileSystemNotSupportedException | The file cannot be opened for writing.

See Also

ZippedFile Class | ZippedFile Members | Xceed.Zip Namespace | ZippedFile.DoOpenWrite Overload List

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFile.DoParentFolder Property

Gets a reference to the parent folder of this item.

[Visual Basic]
Overrides Protected ReadOnly Property DoParentFolder As Xceed.FileSystem.AbstractFolder
[C#]
protected Xceed.FileSystem.AbstractFolder DoParentFolder {override get;}

Property Value

An AbstractFolder object that represents the folder that contains the item, or a null reference (Nothing in Visual Basic) if the item does not have a parent.

Remarks

If the current item is the root of a folder hierarchy, it has no parent folder. In this case, the ParentFolder property returns a null reference (Nothing in Visual Basic).

See Also

ZippedFile Class | ZippedFile Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFile.DoRefresh Method

Re-reads the information from the physical item.

[Visual Basic]
Overrides Protected Sub DoRefresh( _
   ByVal session As Xceed.FileSystem.FileSystemEventsSession _
)
[C#]
protected override void DoRefresh(
   FileSystemEventsSession session
);

Parameters

session

A reference to a FileSystemEventsSession object which is responsible for raising all events that occur during the process.

Remarks

When a FileSystemItem object's properties, such as Attributes or CreationDateTime, are first accessed, a snapshot of the underlying physical item's properties is taken. This snapshot is not automatically updated whenever the physical item's properties change.

Refresh re-reads the information from the physical item and updates the snapshot.

Note: Refresh should be called before accessing a property, or the information returned could be outdated.

Exceptions

Exception Type | Condition
Xceed.FileSystem.ItemDoesNotExistException | The item represented by this FileSystemItem does not physically exist.

See Also

ZippedFile Class | ZippedFile Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFile.DoRootFolder Property

Gets a reference to the root folder of this item.

[Visual Basic]
Overrides Protected ReadOnly Property DoRootFolder As Xceed.FileSystem.AbstractFolder
[C#]
protected Xceed.FileSystem.AbstractFolder DoRootFolder {override get;}

Property Value

An AbstractFolder object that represents the folder at the root of the path of this item, or a null reference (Nothing in Visual Basic) if a root folder is not available.

Remarks

A root folder represents the starting point of a folder hierarchy. On a physical disk, it is usually represented by a drive letter ("C:\") or UNC root ("\\server\share\").

Some specializations of the AbstractFolder class may define a specialized class that represents a root folder, exposing properties and methods that apply only to a root.

Therefore, the RootFolder property may return an AbstractFolder instance that is in fact a specialized class representing the root.

If the current item is the root of a folder hierarchy, the RootFolder property returns a reference to itself, or a reference to a specialized object that represents the root folder with more details.

If a root folder is not available, the RootFolder property returns a null reference (Nothing in Visual Basic).

See Also

ZippedFile Class | ZippedFile Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFile.DoSize Property

Gets the size of the file in bytes.

[Visual Basic]
Overrides Protected ReadOnly Property DoSize As Long
[C#]
protected long DoSize {override get;}

Property Value

A value representing the file size in bytes.

Remarks

Some types of files may not have the size information available. In this case, -1 is returned.

If the file does not physically exist, an exception is thrown.

Note: Refresh should be called before accessing this property, or the information returned could be outdated.

Exceptions

Exception Type | Condition
Xceed.FileSystem.ItemDoesNotExistException | The file represented by this AbstractFile does not physically exist.

See Also

ZippedFile Class | ZippedFile Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFile.Encrypted Property

Gets a boolean value indicating if the file has been encrypted.

[Visual Basic]
Overridable Public ReadOnly Property Encrypted As Boolean
[C#]
public bool Encrypted {virtual get;}

Property Value

A boolean value indicating if the file is encrypted.

Remarks

true if the file is encrypted; false otherwise.

See Also

ZippedFile Class | ZippedFile Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFile.EnsureDateIsValid Method

Ensures that the System.DateTime value is valid.

[Visual Basic]
Overrides Protected Sub EnsureDateIsValid( _
   ByVal value As Date _
)
[C#]
protected override void EnsureDateIsValid(
   DateTime value
);

Parameters

value

The System.DateTime value to validate.

See Also

ZippedFile Class | ZippedFile Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFile.IsPathRooted Method

Returns a boolean value indicating if the path passed is rooted.

[Visual Basic]
Overrides Protected Function IsPathRooted( _
   ByVal path As String _
) As Boolean
[C#]
protected override bool IsPathRooted(
   string path
);

Parameters

path

The path to verify.

Return Value

true if the path is rooted; false otherwise.

See Also

ZippedFile Class | ZippedFile Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFile.IsSameAs Method

Gets a boolean value indicating if the source and target file are the same.

[Visual Basic]
Overrides Protected Function IsSameAs( _
   ByVal target As Xceed.FileSystem.FileSystemItem _
) As Boolean
[C#]
protected override bool IsSameAs(
   FileSystemItem target
);

Parameters

target

A FileSystemItem object representing the destination file.

Return Value

true if the source and target files are the same; false otherwise.

See Also

ZippedFile Class | ZippedFile Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFile Members

Public Instance Constructors

ZippedFile Overloaded. Initializes a new instance of the class.

Public Instance Properties

Attributes (inherited from FileSystemItem) | Gets or sets the attributes of the item.
Comment | Gets or sets the file's comment.
CompressedSize | Gets the file's compressed size in bytes.
CompressionLevel | Gets the Xceed.Compression.CompressionLevel level that was used to compress the file.
CompressionMethod | Gets the Xceed.Compression.CompressionMethod that was used to compress the file.
Crc32 | Gets the file's uncompressed data CRC checksum.
CreationDateTime (inherited from FileSystemItem) | Gets or sets the creation date and time of the item.
Encrypted | Gets a boolean value indicating if the file has been encrypted.
Exists (inherited from FileSystemItem) | Gets a boolean value indicating if the item physically exists.
FullName (inherited from FileSystemItem) | Gets the full name of the item.
LastAccessDateTime (inherited from FileSystemItem) | Gets or sets the last access date and time of the item.
LastWriteDateTime (inherited from FileSystemItem) | Gets or sets the modification date and time of the item.
Name (inherited from FileSystemItem) | Gets or sets the short name of the item.
ParentFolder (inherited from FileSystemItem) | Gets a reference to the parent folder of this item.
RootFolder (inherited from FileSystemItem) | Gets a reference to the root folder of this item.
Size (inherited from AbstractFile) | Gets the size of the file in bytes.

Public Instance Methods

ApplyPropertiesTo (inherited from FileSystemItem) | Overloaded. Copies the item's properties to another item.
CopyTo (inherited from AbstractFile) | Overloaded. Copies the file's data to another file.
Create (inherited from FileSystemItem) | Overloaded. Creates the physical item represented by the object.
CreateObjRef (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Delete (inherited from FileSystemItem) | Overloaded. Permanently deletes the physical item.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
InitializeLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
MoveTo (inherited from AbstractFile) | Overloaded. Moves the contents of the object to the target object.
OpenRead | Overloaded. Opens the file for reading specifying a decryption password.
OpenWrite | Overloaded. Opens the file for writing providing an encryption password and specifying if existing data should be replaced.
Refresh (inherited from FileSystemItem) | Overloaded. Re-reads the information from the physical item.
ToString (inherited from FileSystemItem) | Returns the full name of the item.

Protected Instance Properties

DoAttributes | Gets or sets the attributes of the item.
DoCreationDateTime | Gets or sets the creation date and time of the item.
DoExists | Gets a boolean value indicating if the item physically exists.
DoFullName | Gets the full name of the item.
DoLastAccessDateTime | Gets or sets the last access date and time of the item.
DoLastWriteDateTime | Gets or sets the modification date and time of the item.
DoName | Gets or sets the short name of the item.
DoParentFolder | Gets a reference to the parent folder of this item.
DoRootFolder | Gets a reference to the root folder of this item.
DoSize | Gets the size of the file in bytes.
InvalidChars (inherited from FileSystemItem) | Gets the characters that are invalid in file and folder names.

Protected Instance Methods

BuildListForCreate (inherited from FileSystemItem) | Handles the special cases in regards to building the list of items to process when creating a FileSystemItem object.
DoApplyPropertiesTo | Copies the files properties to another item.
DoCopyTo (inherited from AbstractFile) | Copies the file into the destination.
DoCreate | Creates the physical file in the zip file.
DoDelete | Permanently deletes the file within the zip file.
DoOpenRead | Overloaded. Opens the file for reading with the specified constant and password.
DoOpenWrite | Overloaded. Opens the file for writing with the specified constant and password.
DoRefresh | Re-reads the information from the physical item.
EnsureDateIsValid | Ensures that the System.DateTime value is valid.
Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsPathRooted | Returns a boolean value indicating if the path passed is rooted.
IsSameAs | Gets a boolean value indicating if the source and target file are the same.
ListCopyTo (inherited from FileSystemItem) | Copies each item in the FileSystemEventsSession object's list to each item's destination.
ListCreate (inherited from FileSystemItem) | Creates each item in the FileSystemEventsSession object's list.
ListDelete (inherited from FileSystemItem) | Deletes each item in the FileSystemEventsSession object's list.
ListMoveTo (inherited from FileSystemItem) | Moves each item in the FileSystemEventsSession object's list to each item's destination.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Internal Instance Methods

BuildList (inherited from AbstractFile) Builds a list of FileSystemItem objects to process.

Internal Instance Constructors

ZippedFile Overloaded. Initializes a new instance of the class.

See Also

ZippedFile Class | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFile Methods

The methods of the ZippedFile class are listed below. For a complete list of ZippedFile class members, see the ZippedFile Members topic.

Public Instance Methods

ApplyPropertiesTo (inherited from FileSystemItem) | Overloaded. Copies the item's properties to another item.
CopyTo (inherited from AbstractFile) | Overloaded.
Create (inherited from FileSystemItem) | Overloaded. Creates the physical item represented by the object.
CreateObjRef (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Delete (inherited from FileSystemItem) | Overloaded. Permanently deletes the physical item.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
InitializeLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
MoveTo (inherited from AbstractFile) | Overloaded.
OpenRead | Overloaded.
OpenWrite | Overloaded.
Refresh (inherited from FileSystemItem) | Overloaded. Re-reads the information from the physical item.
ToString (inherited from FileSystemItem) | Returns the full name of the item.

Protected Instance Methods

BuildListForCreate (inherited from FileSystemItem) | Handles the special cases in regards to building the list of items to process when creating a FileSystemItem object.
DoApplyPropertiesTo | Copies the files properties to another item.
DoCopyTo (inherited from AbstractFile) | Copies the file into the destination.
DoCreate | Creates the physical file in the zip file.
DoDelete | Permanently deletes the file within the zip file.
DoOpenRead | Overloaded.
DoOpenWrite | Overloaded.
DoRefresh | Re-reads the information from the physical item.
EnsureDateIsValid | Ensures that the System.DateTime value is valid.
Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsPathRooted | Returns a boolean value indicating if the path passed is rooted.
IsSameAs | Gets a boolean value indicating if the source and target file are the same.
ListCopyTo (inherited from FileSystemItem) | Copies each item in the FileSystemEventsSession object's list to each item's destination.
ListCreate (inherited from FileSystemItem) | Creates each item in the FileSystemEventsSession object's list.
ListDelete (inherited from FileSystemItem) | Deletes each item in the FileSystemEventsSession object's list.
ListMoveTo (inherited from FileSystemItem) | Moves each item in the FileSystemEventsSession object's list to each item's destination.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Internal Instance Methods

BuildList (inherited from AbstractFile) Builds a list of FileSystemItem objects to process.

See Also

ZippedFile Class | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


OpenRead Method

Xceed Zip for .NET

ZippedFile.OpenRead

Opens the file for reading with the specified file sharing mode and decryption password.

Overload List

Opens the file for reading specifying a decryption password.

public Stream OpenRead(string);

Opens the file for reading with the specified file sharing mode and decryption password.

public Stream OpenRead(FileShare,string);

Opens the file for reading with the specified decryption password and raises events during the process.

public Stream OpenRead(FileSystemEvents,object,string);

Opens the file for reading with the specified file sharing mode and decryption password, and raises events during the process.

public Stream OpenRead(FileSystemEvents,object,FileShare,string);

Opens the file for reading. Opens the file for reading with the specified file sharing mode. Opens the file for reading and raises events during the process. Opens the file for reading with the specified file sharing mode and raises events during the process.

public Stream OpenRead();

Opens the file for reading. Opens the file for reading with the specified file sharing mode. Opens the file for reading and raises events during the process. Opens the file for reading with the specified file sharing mode and raises events during the process.

public Stream OpenRead(FileShare);

Opens the file for reading. Opens the file for reading with the specified file sharing mode. Opens the file for reading and raises events during the process. Opens the file for reading with the specified file sharing mode and raises events during the process.

public Stream OpenRead(FileSystemEvents,object);

Opens the file for reading. Opens the file for reading with the specified file sharing mode. Opens the file for reading and raises events during the process. Opens the file for reading with the specified file sharing mode and raises events during the process.

public Stream OpenRead(FileSystemEvents,object,FileShare);

See Also

ZippedFile Class | ZippedFile Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFile.OpenRead Method (String)

Opens the file for reading specifying a decryption password.

[Visual Basic]
Overloads Public Function OpenRead( _
   ByVal decryptionPassword As String _
) As System.IO.Stream
[C#]
public Stream OpenRead(
   string decryptionPassword
);

Parameters

decryptionPassword

The password that will be used to decrypt the file.

Return Value

A System.IO.Stream object that can be used to read data from the file.

Remarks

The file will be opened with System.IO.FileShare.Read shared access.

See Also

ZippedFile Class | ZippedFile Members | Xceed.Zip Namespace | ZippedFile.OpenRead Overload List

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFile.OpenRead Method (FileShare, String)

Opens the file for reading with the specified file sharing mode and decryption password.

[Visual Basic]
Overloads Public Function OpenRead( _
   ByVal share As System.IO.FileShare, _
   ByVal decryptionPassword As String _
) As System.IO.Stream
[C#]
public Stream OpenRead(
   FileShare share,
   string decryptionPassword
);

Parameters

share

A System.IO.FileShare constant that determines how the file will be shared by different processes.

decryptionPassword

The password that will be used to decrypt the file.

Return Value

A System.IO.Stream object that can be used to read data from the file.

See Also

ZippedFile Class | ZippedFile Members | Xceed.Zip Namespace | ZippedFile.OpenRead Overload List

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFile.OpenRead Method (FileSystemEvents, Object, String)

Opens the file for reading with the specified decryption password and raises events during the process.

[Visual Basic]
Overloads Public Function OpenRead( _
   ByVal events As Xceed.FileSystem.FileSystemEvents, _
   ByVal userData As Object, _
   ByVal decryptionPassword As String _
) As System.IO.Stream
[C#]
public Stream OpenRead(
   FileSystemEvents events,
   object userData,
   string decryptionPassword
);

Parameters

events

A FileSystemEvents object that will be used to raise events. Cannot be a null reference (Nothing in Visual Basic).

userData

Opaque data that will be passed back to the event handler when an event is raised.

decryptionPassword

The password that will be used to decrypt the file.

Return Value

A System.IO.Stream object that can be used to read data from the file.

Remarks

The file will be opened with System.IO.FileShare.Read shared access.

See Also

ZippedFile Class | ZippedFile Members | Xceed.Zip Namespace | ZippedFile.OpenRead Overload List

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFile.OpenRead Method (FileSystemEvents, Object, FileShare, String)

Opens the file for reading with the specified file sharing mode and decryption password, and raises events during the process.

[Visual Basic]
Overloads Public Function OpenRead( _
   ByVal events As Xceed.FileSystem.FileSystemEvents, _
   ByVal userData As Object, _
   ByVal share As System.IO.FileShare, _
   ByVal decryptionPassword As String _
) As System.IO.Stream
[C#]
public Stream OpenRead(
   FileSystemEvents events,
   object userData,
   FileShare share,
   string decryptionPassword
);

Parameters

events

A FileSystemEvents object that will be used to raise events. Cannot be a null reference (Nothing in Visual Basic).

userData

Opaque data that will be passed back to the event handler when an event is raised.

share

A System.IO.FileShare constant that determines how the file will be shared by different processes.

decryptionPassword

The password that will be used to decrypt the file.

Return Value

A System.IO.Stream object that can be used to read data from the file.

See Also

ZippedFile Class | ZippedFile Members | Xceed.Zip Namespace | ZippedFile.OpenRead Overload List

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


OpenWrite Method

Xceed Zip for .NET

ZippedFile.OpenWrite

Opens the file for writing providing an encryption password and file sharing mode as well as specifying if existing data should be replaced.

Overload List

Opens the file for writing providing an encryption password and specifying if existing data should be replaced.

public Stream OpenWrite(bool,CompressionMethod,CompressionLevel,string);

Opens the file for writing providing an encryption password and file sharing mode as well as specifying if existing data should be replaced.

public Stream OpenWrite(bool,FileShare,CompressionMethod,CompressionLevel,string);

Opens the file for writing providing an encryption password and specifying if existing data should be replaced. Events will be raised during the process.

public Stream OpenWrite(FileSystemEvents,object,bool,CompressionMethod,CompressionLevel,string);

Opens the file for writing providing an encryption password and file sharing mode as well as specifying if existing data should be replaced. Events will be raised during the process.

public Stream OpenWrite(FileSystemEvents,object,bool,FileShare,CompressionMethod,CompressionLevel,string);

Opens the file for writing. Opens the file for writing with the specified file sharing mode. Opens the file for writing and raises events during the process. Opens the file for writing with the specified file sharing mode and raises events during the process.

public Stream OpenWrite(bool);

Opens the file for writing. Opens the file for writing with the specified file sharing mode. Opens the file for writing and raises events during the process. Opens the file for writing with the specified file sharing mode and raises events during the process.

public Stream OpenWrite(bool,FileShare);

Opens the file for writing. Opens the file for writing with the specified file sharing mode. Opens the file for writing and raises events during the process. Opens the file for writing with the specified file sharing mode and raises events during the process.

public Stream OpenWrite(FileSystemEvents,object,bool);

Opens the file for writing. Opens the file for writing with the specified file sharing mode. Opens the file for writing and raises events during the process. Opens the file for writing with the specified file sharing mode and raises events during the process.

public Stream OpenWrite(FileSystemEvents,object,bool,FileShare);

See Also

ZippedFile Class | ZippedFile Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFile.OpenWrite Method (Boolean, CompressionMethod, CompressionLevel, String)

Opens the file for writing providing an encryption password and specifying if existing data should be replaced.

[Visual Basic]
Overloads Public Function OpenWrite( _
   ByVal overwrite As Boolean, _
   ByVal compressionMethod As Xceed.Compression.CompressionMethod, _
   ByVal compressionLevel As Xceed.Compression.CompressionLevel, _
   ByVal encryptionPassword As String _
) As System.IO.Stream
[C#]
public Stream OpenWrite(
   bool overwrite,
   CompressionMethod compressionMethod,
   CompressionLevel compressionLevel,
   string encryptionPassword
);

Parameters

overwrite

true if existing data for the item should be replaced; false if existing data should be preserved, appending new data at the end.

compressionMethod

The Xceed.Compression.CompressionMethod that will be used to compress the file.

compressionLevel

The Xceed.Compression.CompressionLevel that will be used when compressing the file.

encryptionPassword

The password that will be used to encrypt the file.

Return Value

A System.IO.Stream object that can be used to write data to the file.

Remarks

The returned stream is guaranteed to be writable, but may or may not be seekable.

The file will be opened with System.IO.FileShare.None shared access.

See Also

ZippedFile Class | ZippedFile Members | Xceed.Zip Namespace | ZippedFile.OpenWrite Overload List

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFile.OpenWrite Method (Boolean, FileShare, CompressionMethod, CompressionLevel, String)

Opens the file for writing providing an encryption password and file sharing mode as well as specifying if existing data should be replaced.

[Visual Basic]
Overloads Public Function OpenWrite( _
   ByVal overwrite As Boolean, _
   ByVal share As System.IO.FileShare, _
   ByVal compressionMethod As Xceed.Compression.CompressionMethod, _
   ByVal compressionLevel As Xceed.Compression.CompressionLevel, _
   ByVal encryptionPassword As String _
) As System.IO.Stream
[C#]
public Stream OpenWrite(
   bool overwrite,
   FileShare share,
   CompressionMethod compressionMethod,
   CompressionLevel compressionLevel,
   string encryptionPassword
);

Parameters

overwrite

true if existing data for the item should be replaced; false if existing data should be preserved, appending new data at the end.

share

A System.IO.FileShare constant that determines how the file will be shared by different processes.

compressionMethod

The Xceed.Compression.CompressionMethod that will be used to compress the file.

compressionLevel

The Xceed.Compression.CompressionLevel that will be used when compressing the file.

encryptionPassword

The password that will be used to encrypt the file.

Return Value

A System.IO.Stream object that can be used to write data to the file.

Remarks

The returned stream is guaranteed to be writable, but may or may not be seekable.

See Also

ZippedFile Class | ZippedFile Members | Xceed.Zip Namespace | ZippedFile.OpenWrite Overload List

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFile.OpenWrite Method (FileSystemEvents, Object, Boolean, CompressionMethod, CompressionLevel, String)

Opens the file for writing providing an encryption password and specifying if existing data should be replaced. Events will be raised during the process.

[Visual Basic]
Overloads Public Function OpenWrite( _
   ByVal events As Xceed.FileSystem.FileSystemEvents, _
   ByVal userData As Object, _
   ByVal overwrite As Boolean, _
   ByVal compressionMethod As Xceed.Compression.CompressionMethod, _
   ByVal compressionLevel As Xceed.Compression.CompressionLevel, _
   ByVal encryptionPassword As String _
) As System.IO.Stream
[C#]
public Stream OpenWrite(
   FileSystemEvents events,
   object userData,
   bool overwrite,
   CompressionMethod compressionMethod,
   CompressionLevel compressionLevel,
   string encryptionPassword
);

Parameters

events

A FileSystemEvents object that will be used to raise events. Cannot be a null reference (Nothing in Visual Basic).

userData

Opaque data that will be passed back to the event handler when an event is raised.

overwrite

true if existing data for the item should be replaced; false if existing data should be preserved, appending new data at the end.

compressionMethod

The Xceed.Compression.CompressionMethod that will be used to compress the file.

compressionLevel

The Xceed.Compression.CompressionLevel that will be used when compressing the file.

encryptionPassword

The password that will be used to encrypt the file.

Return Value

A System.IO.Stream object that can be used to write data to the file.

Remarks

The returned stream is guaranteed to be writable, but may or may not be seekable.

The file will be opened with System.IO.FileShare.None shared access.

See Also

ZippedFile Class | ZippedFile Members | Xceed.Zip Namespace | ZippedFile.OpenWrite Overload List

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFile.OpenWrite Method (FileSystemEvents, Object, Boolean, FileShare, CompressionMethod, CompressionLevel, String)

Opens the file for writing providing an encryption password and file sharing mode as well as specifying if existing data should be replaced. Events will be raised during the process.

[Visual Basic]
Overloads Public Function OpenWrite( _
   ByVal events As Xceed.FileSystem.FileSystemEvents, _
   ByVal userData As Object, _
   ByVal overwrite As Boolean, _
   ByVal share As System.IO.FileShare, _
   ByVal compressionMethod As Xceed.Compression.CompressionMethod, _
   ByVal compressionLevel As Xceed.Compression.CompressionLevel, _
   ByVal encryptionPassword As String _
) As System.IO.Stream
[C#]
public Stream OpenWrite(
   FileSystemEvents events,
   object userData,
   bool overwrite,
   FileShare share,
   CompressionMethod compressionMethod,
   CompressionLevel compressionLevel,
   string encryptionPassword
);

Parameters

events

A FileSystemEvents object that will be used to raise events. Cannot be a null reference (Nothing in Visual Basic).

userData

Opaque data that will be passed back to the event handler when an event is raised.

overwrite

true if existing data for the item should be replaced; false if existing data should be preserved, appending new data at the end.

share

A System.IO.FileShare constant that determines how the file will be shared by different processes.

compressionMethod

The Xceed.Compression.CompressionMethod that will be used to compress the file.

compressionLevel

The Xceed.Compression.CompressionLevel that will be used when compressing the file.

encryptionPassword

The password that will be used to encrypt the file.

Return Value

A System.IO.Stream object that can be used to write data to the file.

Remarks

The returned stream is guaranteed to be writable, but may or may not be seekable.

See Also

ZippedFile Class | ZippedFile Members | Xceed.Zip Namespace | ZippedFile.OpenWrite Overload List

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFile Properties

The properties of the ZippedFile class are listed below. For a complete list of ZippedFile class members, see the ZippedFile Members topic.

Public Instance Properties

Attributes (inherited from FileSystemItem) | Gets or sets the attributes of the item.
Comment | Gets or sets the file's comment.
CompressedSize | Gets the file's compressed size in bytes.
CompressionLevel | Gets the Xceed.Compression.CompressionLevel level that was used to compress the file.
CompressionMethod | Gets the Xceed.Compression.CompressionMethod that was used to compress the file.
Crc32 | Gets the file's uncompressed data CRC checksum.
CreationDateTime (inherited from FileSystemItem) | Gets or sets the creation date and time of the item.
Encrypted | Gets a boolean value indicating if the file has been encrypted.
Exists (inherited from FileSystemItem) | Gets a boolean value indicating if the item physically exists.
FullName (inherited from FileSystemItem) | Gets the full name of the item.
LastAccessDateTime (inherited from FileSystemItem) | Gets or sets the last access date and time of the item.
LastWriteDateTime (inherited from FileSystemItem) | Gets or sets the modification date and time of the item.
Name (inherited from FileSystemItem) | Gets or sets the short name of the item.
ParentFolder (inherited from FileSystemItem) | Gets a reference to the parent folder of this item.
RootFolder (inherited from FileSystemItem) | Gets a reference to the root folder of this item.
Size (inherited from AbstractFile) | Gets the size of the file in bytes.

Protected Instance Properties

DoAttributes | Gets or sets the attributes of the item.
DoCreationDateTime | Gets or sets the creation date and time of the item.
DoExists | Gets a boolean value indicating if the item physically exists.
DoFullName | Gets the full name of the item.
DoLastAccessDateTime | Gets or sets the last access date and time of the item.
DoLastWriteDateTime | Gets or sets the modification date and time of the item.
DoName | Gets or sets the short name of the item.
DoParentFolder | Gets a reference to the parent folder of this item.
DoRootFolder | Gets a reference to the root folder of this item.
DoSize | Gets the size of the file in bytes.
InvalidChars (inherited from FileSystemItem) | Gets the characters that are invalid in file and folder names.

See Also

ZippedFile Class | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFolder Class

Specialization of the AbstractFolder class that implements access to a folder stored in a ZIP file.

For a list of all members of this type, see ZippedFolder Members.

System.Object
MarshalByRefObject
FileSystemItem
AbstractFolder
ZippedFolder

[Visual Basic]
Public Class ZippedFolder
   Inherits AbstractFolder
[C#]
public class ZippedFolder : AbstractFolder

Requirements

Namespace: Xceed.Zip Namespace

Assembly: Xceed.Zip.dll

See Also

ZippedFolder Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFolder.Comment Property

Gets or sets the folder's comment.

[Visual Basic]
Overridable Public Property Comment As String
[C#]
public string Comment {virtual get; virtual set;}

Property Value

A string containing the folder's comment.

See Also

ZippedFolder Class | ZippedFolder Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFolder Constructor

Xceed Zip for .NET

ZippedFolder

Initializes a new instance of the ZippedFolder class.

Overload List

Initializes a new instance of the ZippedFolder class.

public ZippedFolder(AbstractFile,string);

Initializes a new instance of the ZippedFolder class enabling event notifications while the object is being created.

public ZippedFolder(FileSystemEvents,object,AbstractFile,string);

internal ZippedFolder(ZipItemHandler);

See Also

ZippedFolder Class | ZippedFolder Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFolder Constructor (AbstractFile, String)

Initializes a new instance of the ZippedFolder class.

[Visual Basic]
Overloads Public Sub New( _
   ByVal zipFile As Xceed.FileSystem.AbstractFile, _
   ByVal folderName As String _
)
[C#]
public ZippedFolder(
   AbstractFile zipFile,
   string folderName
);

Parameters

zipFile

AbstractFile object that represents the ZIP file to access.

folderName

Fully-qualified name of the folder stored in the ZIP file. This folder may or may not exist in the ZIP file.

See Also

ZippedFolder Class | ZippedFolder Members | Xceed.Zip Namespace | ZippedFolder Constructor Overload List

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFolder Constructor (FileSystemEvents, Object, AbstractFile, String)

Initializes a new instance of the ZippedFolder class enabling event notifications while the object is being created.

[Visual Basic]
Overloads Public Sub New( _
   ByVal events As Xceed.FileSystem.FileSystemEvents, _
   ByVal userData As Object, _
   ByVal zipFile As Xceed.FileSystem.AbstractFile, _
   ByVal folderName As String _
)
[C#]
public ZippedFolder(
   FileSystemEvents events,
   object userData,
   AbstractFile zipFile,
   string folderName
);

Parameters

events

A FileSystemEvents object that will be used to raise events. Cannot be a null reference (Nothing in Visual Basic).

userData

Opaque data that will be passed back to the event handler when an event is raised.

zipFile

AbstractFile object that represents the ZIP file to access.

folderName

Fully-qualified name of the folder stored in the ZIP file. This folder may or may not exist in the ZIP file.

Remarks

Once the ZippedFolder object is created, it does not keep a reference on the event object.

See Also

ZippedFolder Class | ZippedFolder Members | Xceed.Zip Namespace | ZippedFolder Constructor Overload List

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFolder Constructor (ZipItemHandler)

[Visual Basic]
Overloads Friend Sub New( _
   ByVal item As Xceed.Zip.ZipItemHandler _
)
[C#]
internal ZippedFolder(
   ZipItemHandler item
);

See Also

ZippedFolder Class | ZippedFolder Members | Xceed.Zip Namespace | ZippedFolder Constructor Overload List

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFolder.DoApplyPropertiesTo Method

Copies the zipped folder's properties to another item.

[Visual Basic]
Overrides Protected Sub DoApplyPropertiesTo( _
   ByVal session As Xceed.FileSystem.FileSystemEventsSession, _
   ByVal targetItem As Xceed.FileSystem.FileSystemItem _
)
[C#]
protected override void DoApplyPropertiesTo(
   FileSystemEventsSession session,
   FileSystemItem targetItem
);

Parameters

session

A reference to a FileSystemEventsSession object which is responsible for raising all events that occur during the process.

targetItem

A FileSystemItem object to which the current zipped folder's properties must be copied. Cannot be a null reference (Nothing in Visual Basic).

See Also

ZippedFolder Class | ZippedFolder Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFolder.DoAttributes Property

Gets or sets the attributes of the item.

[Visual Basic]
Overrides Protected Property DoAttributes As System.IO.FileAttributes
[C#]
protected System.IO.FileAttributes DoAttributes {override get; override set;}

Property Value

A combination of System.IO.FileAttributes values that represents the attributes of the item.

Remarks

When changing the item's attributes through this property, the physical item is immediately modified if it exists. If it does not exist, the attributes are cached and will be applied whenever this item is created.

Some types of items may not expose attributes. In this case, an exception is thrown when trying to read or modify the attributes.

Note: Refresh should be called before accessing this property, or the information returned could be outdated.

Exceptions

Exception Type | Condition
Xceed.FileSystem.FileSystemNotSupportedException | The item does not expose attributes, or does not support one of the assigned attributes.
Xceed.FileSystem.ItemIsRootFolderException | The physical item is a root folder.

See Also

ZippedFolder Class | ZippedFolder Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFolder.DoCreate Method

Creates the physical zipped folder.

[Visual Basic]
Overrides Protected Sub DoCreate( _
   ByVal session As Xceed.FileSystem.FileSystemEventsSession _
)
[C#]
protected override void DoCreate(
   FileSystemEventsSession session
);

Parameters

session

A reference to a FileSystemEventsSession object which is responsible for raising all events that occur during the process.

Remarks

The folder must be created in a folder that exists otherwise an exception will be thrown.

Exceptions

Exception Type | Condition
Xceed.FileSystem.ItemAlreadyExistsException | The physical folder already exists.

See Also

ZippedFolder Class | ZippedFolder Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFolder.DoCreationDateTime Property

Gets or sets the creation date and time of the item.

[Visual Basic]
Overrides Protected Property DoCreationDateTime As Date
[C#]
protected System.DateTime DoCreationDateTime {override get; override set;}

Property Value

The date and time when the item was created.

Remarks

When changing the item's creation date through this property, the physical item is immediately modified if it exists. If it does not exist, the date is cached and will be applied whenever this item is created.

Some types of items may not expose a creation date and time. In this case, an exception is thrown when trying to read or modify the creation date.

Other types of items that do expose a creation date and time may not have the information available. In this case, System.DateTime.MinValue is returned.

Note: Refresh should be called before accessing this property, or the information returned could be outdated.

Exceptions

Exception Type | Condition
System.ArgumentException | The provided creation date is not valid for this item.
Xceed.FileSystem.FileSystemNotSupportedException | The item does not expose a creation date.
Xceed.FileSystem.ItemIsReadOnlyException | The item has the ReadOnly attribute, preventing it from being modified.
Xceed.FileSystem.ItemIsRootFolderException | The item is a root folder.

See Also

ZippedFolder Class | ZippedFolder Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFolder.DoDelete Method

Permanently deletes the physical zipped folder.

[Visual Basic]
Overrides Protected Sub DoDelete( _
   ByVal session As Xceed.FileSystem.FileSystemEventsSession _
)
[C#]
protected override void DoDelete(
   FileSystemEventsSession session
);

Parameters

session

A reference to a FileSystemEventsSession object which is responsible for raising all events that occur during the process.

Exceptions

Exception Type | Condition
Xceed.FileSystem.ItemDoesNotExistException | The physical zipped folder does exist.
Xceed.FileSystem.ItemIsReadOnlyException | The physical zipped folder is read-only.

See Also

ZippedFolder Class | ZippedFolder Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFolder.DoExists Property

Gets a boolean value indicating if the item physically exists.

[Visual Basic]
Overrides Protected ReadOnly Property DoExists As Boolean
[C#]
protected bool DoExists {override get;}

Property Value

true if the item physically exists; false otherwise.

Remarks

This property should be evaluated before calling a method that needs to access the underlying physical item (For example, CopyTo), otherwise these methods will throw an exception.

Note: Refresh does not need to be called before accessing this property. The property will always reflect the physical item's existence.

See Also

ZippedFolder Class | ZippedFolder Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFolder.DoFullName Property

Gets the full name of the item.

[Visual Basic]
Overrides Protected ReadOnly Property DoFullName As String
[C#]
protected string DoFullName {override get;}

Property Value

A string that represents the full name of the item.

Remarks

The full name consists of the item's name fully-qualified with a path. For example: "c:\foo\bar.txt", "c:\foo\".

If the item represents a file, its name does not end with a path separator character.

If the item represents a folder, its name does end with a path separator character.

The separator character is defined in System.IO.Path.DirectorySeparatorChar and System.IO.Path.AltDirectorySeparatorChar.

See Also

ZippedFolder Class | ZippedFolder Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFolder.DoGetChildItems Method

Retrieves an array of FileSystemItem objects contained within the zipped folder.

[Visual Basic]
Overrides Protected Function DoGetChildItems( _
   ByVal session As Xceed.FileSystem.FileSystemEventsSession _
) As Xceed.FileSystem.FileSystemItem()
[C#]
protected override FileSystemItem[] DoGetChildItems(
   FileSystemEventsSession session
);

Parameters

session

A reference to a FileSystemEventsSession object which is responsible for raising all events that occur during the process.

Return Value

An array of FileSystemItem objects representing the items ( files and folders ) contained within the zipped folder.

See Also

ZippedFolder Class | ZippedFolder Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFolder.DoGetFile Method

Retrieves a reference to an AbstractFile object contained within the zipped folder.

[Visual Basic]
Overrides Protected Function DoGetFile( _
   ByVal session As Xceed.FileSystem.FileSystemEventsSession, _
   ByVal fileName As String _
) As Xceed.FileSystem.AbstractFile
[C#]
protected override AbstractFile DoGetFile(
   FileSystemEventsSession session,
   string fileName
);

Parameters

session

A reference to a FileSystemEventsSession object which is responsible for raising all events that occur during the process.

fileName

The name of the file to retrieve.

Return Value

A reference to an AbstractFile object regardless of if the file represented by the object exists or not.

Remarks

fileName should not end with a System.IO.Path.DirectorySeparatorChar.

See Also

ZippedFolder Class | ZippedFolder Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFolder.DoGetFolder Method

Retrieves a reference to an AbstractFolder object contained within the zipped folder.

[Visual Basic]
Overrides Protected Function DoGetFolder( _
   ByVal session As Xceed.FileSystem.FileSystemEventsSession, _
   ByVal folderName As String _
) As Xceed.FileSystem.AbstractFolder
[C#]
protected override AbstractFolder DoGetFolder(
   FileSystemEventsSession session,
   string folderName
);

Parameters

session

A reference to a FileSystemEventsSession object which is responsible for raising all events that occur during the process.

folderName

The name of the folder to retrieve.

Return Value

A reference to an AbstractFolder object regardless of if the folder represented by the object exists or not.

Remarks

folderName should not end with a System.IO.Path.DirectorySeparatorChar.

See Also

ZippedFolder Class | ZippedFolder Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFolder.DoLastAccessDateTime Property

Gets or sets the last access date and time of the item.

[Visual Basic]
Overrides Protected Property DoLastAccessDateTime As Date
[C#]
protected System.DateTime DoLastAccessDateTime {override get; override set;}

Property Value

The date and time when the item was last accessed.

Remarks

When changing the item's access date through this property, the physical item is immediately modified if it exists. If it does not exist, the date is cached and will be applied whenever this item is created.

Some types of items may not expose a last access date and time. In this case, an exception is thrown when trying to read or modify the access date.

Other types of items that do expose a last access date and time may not have the information available. In this case, System.DateTime.MinValue is returned.

Note: Refresh should be called before accessing this property, or the information returned could be outdated.

Exceptions

Exception Type | Condition
System.ArgumentException | The provided last access date is not valid for this item.
Xceed.FileSystem.FileSystemNotSupportedException | The item does not expose a last access date.
Xceed.FileSystem.ItemIsReadOnlyException | The item has the ReadOnly attribute, preventing it from being modified.
Xceed.FileSystem.ItemIsRootFolderException | The physical item is a root folder.

See Also

ZippedFolder Class | ZippedFolder Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFolder.DoLastWriteDateTime Property

Gets or sets the modification date and time of the item.

[Visual Basic]
Overrides Protected Property DoLastWriteDateTime As Date
[C#]
protected System.DateTime DoLastWriteDateTime {override get; override set;}

Property Value

The date and time when the item was modified.

Remarks

When changing the item's modification date through this property, the physical item is immediately modified if it exists. If it does not exist, the date is cached and will be applied whenever this item is created.

Some types of items may not expose a modification date and time. In this case, an exception is thrown when trying to read or modify the modification date.

Other types of items that do expose a modification date and time may not have the information available. In this case, System.DateTime.MinValue is returned.

Note: Refresh should be called before accessing this property, or the information returned could be outdated.

Exceptions

Exception Type | Condition
System.ArgumentException | The provided modification date is not valid for this item.
Xceed.FileSystem.FileSystemNotSupportedException | The item does not expose a modification date.
Xceed.FileSystem.ItemIsReadOnlyException | The item has the ReadOnly attribute, preventing it from being modified.
Xceed.FileSystem.ItemIsRootFolderException | The item is a root folder.

See Also

ZippedFolder Class | ZippedFolder Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFolder.DoName Property

Gets or sets the short name of the item.

[Visual Basic]
Overrides Protected Property DoName As String
[C#]
protected string DoName {override get; override set;}

Property Value

A string that represents the short name of the item.

Remarks

The short name consists of the item's name without a path.

For example, the short name of a file named "c:\foo\bar.txt" is "bar.txt", and the short name of a folder named "c:\foo\" is "foo".

When assigning a new name to this property, the physical item is immediately renamed if it exists. If it does not exist, the new name is cached and will be applied whenever this item is created. In either cases, if a physical item with the same name already exists, an exception is thrown.

The short name of an item must not end with a path separator character regardless of whether it represents a file or a folder.

The separator character is defined in System.IO.Path.DirectorySeparatorChar and System.IO.Path.AltDirectorySeparatorChar.

Exceptions

Exception Type | Condition
System.ArgumentException | The new name assigned to the item is an empty string, contains only white space, contains a path, or contains invalid characters as defined in InvalidChars.
Xceed.FileSystem.ItemAlreadyExistsException | The new name corresponds to a physical item that already exists.
Xceed.FileSystem.ItemIsRootFolderException | The item is a root folder.

See Also

ZippedFolder Class | ZippedFolder Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFolder.DoParentFolder Property

Gets a reference to the parent folder of this item.

[Visual Basic]
Overrides Protected ReadOnly Property DoParentFolder As Xceed.FileSystem.AbstractFolder
[C#]
protected Xceed.FileSystem.AbstractFolder DoParentFolder {override get;}

Property Value

An AbstractFolder object that represents the folder that contains the item, or a null reference (Nothing in Visual Basic) if the item does not have a parent.

Remarks

If the current item is the root of a folder hierarchy, it has no parent folder. In this case, the ParentFolder property returns a null reference (Nothing in Visual Basic).

See Also

ZippedFolder Class | ZippedFolder Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFolder.DoRefresh Method

Re-reads the information from the physical item.

[Visual Basic]
Overrides Protected Sub DoRefresh( _
   ByVal session As Xceed.FileSystem.FileSystemEventsSession _
)
[C#]
protected override void DoRefresh(
   FileSystemEventsSession session
);

Parameters

session

A reference to a FileSystemEventsSession object which is responsible for raising all events that occur during the process.

Remarks

When a FileSystemItem object's properties, such as Attributes or CreationDateTime, are first accessed, a snapshot of the underlying physical item's properties is taken. This snapshot is not automatically updated whenever the physical item's properties change.

Refresh re-reads the information from the physical item and updates the snapshot.

Note: Refresh should be called before accessing a property, or the information returned could be outdated.

Exceptions

Exception Type | Condition
Xceed.FileSystem.ItemDoesNotExistException | The item represented by this FileSystemItem does not physically exist.

See Also

ZippedFolder Class | ZippedFolder Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFolder.DoRootFolder Property

Gets a reference to the parent folder of this item.

[Visual Basic]
Overrides Protected ReadOnly Property DoRootFolder As Xceed.FileSystem.AbstractFolder
[C#]
protected Xceed.FileSystem.AbstractFolder DoRootFolder {override get;}

Property Value

An AbstractFolder object that represents the folder that contains the item, or a null reference (Nothing in Visual Basic) if the item does not have a parent.

Remarks

If the current item is the root of a folder hierarchy, it has no parent folder. In this case, the ParentFolder property returns a null reference (Nothing in Visual Basic).

See Also

ZippedFolder Class | ZippedFolder Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFolder.EnsureDateIsValid Method

Ensures that the System.DateTime value is valid.

[Visual Basic]
Overrides Protected Sub EnsureDateIsValid( _
   ByVal value As Date _
)
[C#]
protected override void EnsureDateIsValid(
   DateTime value
);

Parameters

value

The System.DateTime value to validate.

See Also

ZippedFolder Class | ZippedFolder Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFolder Fields

The fields of the ZippedFolder class are listed below. For a complete list of ZippedFolder class members, see the ZippedFolder Members topic.

Protected Instance Fields

m_isRoot

See Also

ZippedFolder Class | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFolder.IsPathRooted Method

Returns a boolean value indicating if the path passed is rooted.

[Visual Basic]
Overrides Protected Function IsPathRooted( _
   ByVal path As String _
) As Boolean
[C#]
protected override bool IsPathRooted(
   string path
);

Parameters

path

The path to verify.

Return Value

true if the path is rooted; false otherwise.

See Also

ZippedFolder Class | ZippedFolder Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFolder.IsSameAs Method

Returns a boolean value indicating if the source and target items are the same.

[Visual Basic]
Overrides Protected Function IsSameAs( _
   ByVal target As Xceed.FileSystem.FileSystemItem _
) As Boolean
[C#]
protected override bool IsSameAs(
   FileSystemItem target
);

Parameters

target

A FileSystemItem object representing the destination item.

Return Value

true if the source and target FileSystemItem objects are the same; false otherwise.

See Also

ZippedFolder Class | ZippedFolder Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFolder.m_isRoot Field

[Visual Basic]
Protected m_isRoot As Boolean
[C#]
protected bool m_isRoot;

See Also

ZippedFolder Class | ZippedFolder Members | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFolder Members

Public Instance Constructors

ZippedFolder Overloaded. Initializes a new instance of the class.

Public Instance Properties

Attributes (inherited from FileSystemItem) | Gets or sets the attributes of the item.
Comment | Gets or sets the folder's comment.
CreationDateTime (inherited from FileSystemItem) | Gets or sets the creation date and time of the item.
Exists (inherited from FileSystemItem) | Gets a boolean value indicating if the item physically exists.
FullName (inherited from FileSystemItem) | Gets the full name of the item.
IsRoot (inherited from AbstractFolder) | Gets a value indicating if the folder is a root folder.
LastAccessDateTime (inherited from FileSystemItem) | Gets or sets the last access date and time of the item.
LastWriteDateTime (inherited from FileSystemItem) | Gets or sets the modification date and time of the item.
Name (inherited from FileSystemItem) | Gets or sets the short name of the item.
ParentFolder (inherited from FileSystemItem) | Gets a reference to the parent folder of this item.
RootFolder (inherited from FileSystemItem) | Gets a reference to the root folder of this item.

Public Instance Methods

ApplyPropertiesTo (inherited from FileSystemItem) | Overloaded. Copies the item's properties to another item.
CopyFilesTo (inherited from AbstractFolder) | Overloaded. Copies the folder's content to another folder.
CopyTo (inherited from FileSystemItem) | Overloaded. Copies the item, or it's content to the destination.
Create (inherited from FileSystemItem) | Overloaded. Creates the physical item represented by the object.
CreateFile (inherited from AbstractFolder) | Overloaded. Creates a new file in the folder.
CreateFolder (inherited from AbstractFolder) | Overloaded. Creates a new folder in the folder.
CreateObjRef (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Delete (inherited from FileSystemItem) | Overloaded. Permanently deletes the physical item.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetFile (inherited from AbstractFolder) | Overloaded. Returns an object that represents a file contained in the folder.
GetFiles (inherited from AbstractFolder) | Overloaded. Returns a filtered list of files contained in the folder.
GetFolder (inherited from AbstractFolder) | Overloaded. Returns an object that represents a folder contained in the folder.
GetFolders (inherited from AbstractFolder) | Overloaded. Returns a filtered list of folders contained in the folder.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetItems (inherited from AbstractFolder) | Overloaded. Returns a list of items contained in the folder.
GetLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
InitializeLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
MoveFilesTo (inherited from AbstractFolder) | Overloaded. Moves the folder's content to another folder.
MoveTo (inherited from FileSystemItem) | Overloaded. Moves the item, or it's content to the destination.
Refresh (inherited from FileSystemItem) | Overloaded. Re-reads the information from the physical item.
ToString (inherited from FileSystemItem) | Returns the full name of the item.

Protected Instance Fields

m_isRoot

Protected Instance Properties

DoAttributes | Gets or sets the attributes of the item.
DoCreationDateTime | Gets or sets the creation date and time of the item.
DoExists | Gets a boolean value indicating if the item physically exists.
DoFullName | Gets the full name of the item.
DoIsRoot (inherited from AbstractFolder) | Gets a boolean value indicating if the folder is a root folder.
DoLastAccessDateTime | Gets or sets the last access date and time of the item.
DoLastWriteDateTime | Gets or sets the modification date and time of the item.
DoName | Gets or sets the short name of the item.
DoParentFolder | Gets a reference to the parent folder of this item.
DoRootFolder | Gets a reference to the parent folder of this item.
InvalidChars (inherited from FileSystemItem) | Gets the characters that are invalid in file and folder names.

Protected Instance Methods

BuildListForCreate (inherited from FileSystemItem) | Handles the special cases in regards to building the list of items to process when creating a FileSystemItem object.
DoApplyPropertiesTo | Copies the zipped folder's properties to another item.
DoCopyTo (inherited from AbstractFolder) | Copies the folder to another folder.
DoCreate | Creates the physical zipped folder.
DoDelete | Permanently deletes the physical zipped folder.
DoGetChildItems | Retrieves an array of FileSystemItem objects contained within the zipped folder.
DoGetFile | Retrieves a reference to an AbstractFile object contained within the zipped folder.
DoGetFiles (inherited from AbstractFolder) | Retrieves an array of AbstractFile objects.
DoGetFolder | Retrieves a reference to an AbstractFolder object contained within the zipped folder.
DoGetFolders (inherited from AbstractFolder) | Retrieves an array of AbstractFolder objects.
DoGetItems (inherited from AbstractFolder) | Retrieves an array of FileSystemItem objects.
DoRefresh | Re-reads the information from the physical item.
EnsureDateIsValid | Ensures that the System.DateTime value is valid.
Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsPathRooted | Returns a boolean value indicating if the path passed is rooted.
IsSameAs | Returns a boolean value indicating if the source and target items are the same.
ListCopyTo (inherited from FileSystemItem) | Copies each item in the FileSystemEventsSession object's list to each item's destination.
ListCreate (inherited from FileSystemItem) | Creates each item in the FileSystemEventsSession object's list.
ListDelete (inherited from FileSystemItem) | Deletes each item in the FileSystemEventsSession object's list.
ListMoveTo (inherited from FileSystemItem) | Moves each item in the FileSystemEventsSession object's list to each item's destination.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Internal Instance Methods

BuildList (inherited from AbstractFolder) Builds a list of FileSystemItem objects to process.

Internal Instance Constructors

ZippedFolder Overloaded. Initializes a new instance of the class.

See Also

ZippedFolder Class | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFolder Methods

The methods of the ZippedFolder class are listed below. For a complete list of ZippedFolder class members, see the ZippedFolder Members topic.

Public Instance Methods

ApplyPropertiesTo (inherited from FileSystemItem) | Overloaded. Copies the item's properties to another item.
CopyFilesTo (inherited from AbstractFolder) | Overloaded.
CopyTo (inherited from FileSystemItem) | Overloaded. Copies the item, or it's content to the destination.
Create (inherited from FileSystemItem) | Overloaded. Creates the physical item represented by the object.
CreateFile (inherited from AbstractFolder) | Overloaded.
CreateFolder (inherited from AbstractFolder) | Overloaded.
CreateObjRef (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Delete (inherited from FileSystemItem) | Overloaded. Permanently deletes the physical item.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetFile (inherited from AbstractFolder) | Overloaded.
GetFiles (inherited from AbstractFolder) | Overloaded.
GetFolder (inherited from AbstractFolder) | Overloaded.
GetFolders (inherited from AbstractFolder) | Overloaded.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetItems (inherited from AbstractFolder) | Overloaded.
GetLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
InitializeLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
MoveFilesTo (inherited from AbstractFolder) | Overloaded.
MoveTo (inherited from FileSystemItem) | Overloaded. Moves the item, or it's content to the destination.
Refresh (inherited from FileSystemItem) | Overloaded. Re-reads the information from the physical item.
ToString (inherited from FileSystemItem) | Returns the full name of the item.

Protected Instance Methods

BuildListForCreate (inherited from FileSystemItem) | Handles the special cases in regards to building the list of items to process when creating a FileSystemItem object.
DoApplyPropertiesTo | Copies the zipped folder's properties to another item.
DoCopyTo (inherited from AbstractFolder) | Copies the folder to another folder.
DoCreate | Creates the physical zipped folder.
DoDelete | Permanently deletes the physical zipped folder.
DoGetChildItems | Retrieves an array of FileSystemItem objects contained within the zipped folder.
DoGetFile | Retrieves a reference to an AbstractFile object contained within the zipped folder.
DoGetFiles (inherited from AbstractFolder) | Retrieves an array of AbstractFile objects.
DoGetFolder | Retrieves a reference to an AbstractFolder object contained within the zipped folder.
DoGetFolders (inherited from AbstractFolder) | Retrieves an array of AbstractFolder objects.
DoGetItems (inherited from AbstractFolder) | Retrieves an array of FileSystemItem objects.
DoRefresh | Re-reads the information from the physical item.
EnsureDateIsValid | Ensures that the System.DateTime value is valid.
Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsPathRooted | Returns a boolean value indicating if the path passed is rooted.
IsSameAs | Returns a boolean value indicating if the source and target items are the same.
ListCopyTo (inherited from FileSystemItem) | Copies each item in the FileSystemEventsSession object's list to each item's destination.
ListCreate (inherited from FileSystemItem) | Creates each item in the FileSystemEventsSession object's list.
ListDelete (inherited from FileSystemItem) | Deletes each item in the FileSystemEventsSession object's list.
ListMoveTo (inherited from FileSystemItem) | Moves each item in the FileSystemEventsSession object's list to each item's destination.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Internal Instance Methods

BuildList (inherited from AbstractFolder) Builds a list of FileSystemItem objects to process.

See Also

ZippedFolder Class | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.


ZippedFolder Properties

The properties of the ZippedFolder class are listed below. For a complete list of ZippedFolder class members, see the ZippedFolder Members topic.

Public Instance Properties

Attributes (inherited from FileSystemItem) | Gets or sets the attributes of the item.
Comment | Gets or sets the folder's comment.
CreationDateTime (inherited from FileSystemItem) | Gets or sets the creation date and time of the item.
Exists (inherited from FileSystemItem) | Gets a boolean value indicating if the item physically exists.
FullName (inherited from FileSystemItem) | Gets the full name of the item.
IsRoot (inherited from AbstractFolder) | Gets a value indicating if the folder is a root folder.
LastAccessDateTime (inherited from FileSystemItem) | Gets or sets the last access date and time of the item.
LastWriteDateTime (inherited from FileSystemItem) | Gets or sets the modification date and time of the item.
Name (inherited from FileSystemItem) | Gets or sets the short name of the item.
ParentFolder (inherited from FileSystemItem) | Gets a reference to the parent folder of this item.
RootFolder (inherited from FileSystemItem) | Gets a reference to the root folder of this item.

Protected Instance Properties

DoAttributes | Gets or sets the attributes of the item.
DoCreationDateTime | Gets or sets the creation date and time of the item.
DoExists | Gets a boolean value indicating if the item physically exists.
DoFullName | Gets the full name of the item.
DoIsRoot (inherited from AbstractFolder) | Gets a boolean value indicating if the folder is a root folder.
DoLastAccessDateTime | Gets or sets the last access date and time of the item.
DoLastWriteDateTime | Gets or sets the modification date and time of the item.
DoName | Gets or sets the short name of the item.
DoParentFolder | Gets a reference to the parent folder of this item.
DoRootFolder | Gets a reference to the parent folder of this item.
InvalidChars (inherited from FileSystemItem) | Gets the characters that are invalid in file and folder names.

See Also

ZippedFolder Class | Xceed.Zip Namespace

Copyright 2000-2002 Xceed Software Inc.

Based on v1.0.27.0 of the Xceed.Zip assembly.