Data Source Wizard Screen 1

Zašlete nám váš názor na tuto stránku. Nápověda k Průvodci zdrojem dat

Průvodce zdrojem dat - první obrazovka

Na první obrazovce tohoto průvodce je možné zadat název a popis zdroje dat a název serveru, na kterém je spuštěn Microsoft® SQL Server,™ ke kterému bude zdroj dat připojen.

Pole Název

Název zdroje dat, který používá aplikace ODBC při žádosti o připojení ke zdroji dat, například „Osoby“. Název zdroje dat se zobrazí v dialogovém okně Správce zdrojů dat ODBC.

Pole Popis

Volitelný popis zdroje dat, například „datum nástupu, platový vývoj a přehled o aktuálních zaměstnancích“.

Pole Server

Název serveru SQL Server v síti. Vyberete-li název serveru ze seznamu, není třeba dále zadávat konfiguraci. Pokud zadáte název serveru, který dosud není uveden v nástroji SQL Client Configuration, můžete na další obrazovce průvodce vytvořit pro nový název alias.

Používáte-li stejný počítač jako SQL Server, lze zadat do pole Server text „(local)“. Uživatel se pak může připojit k místní kopii serveru SQL Server, a to i v případě nesíťové verze serveru SQL Server. SQL Server 2000 podporuje spuštění více instancí serveru SQL Server ve stejném počítači. Chcete-li zadat pojmenovanou instanci serveru SQL Server, použijte název serveru ve tvaru NázevServeru\NázevInstance.

Další informace o názvech serverů pro různé typy sítí najdete v dokumentaci instalace serveru SQL Server v databázi informací SQL Server Books Online.

Pokud k připojení k serveru SQL Server postačí informace uvedené na této obrazovce, můžete klepnout na tlačítko Dokončit. Pro všechny atributy uvedené na zbývajících obrazovkách průvodce budou použity výchozí hodnoty.

©1988-2000 Microsoft Corporation. Všechna práva vyhrazena.


Data Source Wizard Screen 2

Průvodce zdrojem dat - druhá obrazovka

Na druhé obrazovce průvodce můžete stanovit metodu ověření a nastavit další parametry klienta aplikace Microsoft® SQL Server™ a přihlašovací identifikátor a heslo, které ovladač SQL Server ODBC použije k navázání spojení se serverem SQL Server při konfiguraci zdroje dat.

Přepínač Ověřením systémem Windows NT se síťovým přihlašovacím ID

Určí, že ovladač SQL Server ODBC požaduje zabezpečené (prověřené) spojení se serverem SQL Server spuštěným pod operačním systémem Microsoft Windows NT® nebo Windows® 2000. Je-li vybrána tato možnost, použije SQL Server integrované zabezpečení přihlášení pro vytvoření připojení pomocí tohoto zdroje dat bez ohledu na současný režim zabezpečení přihlášení na serveru. Všechna přihlašovací ID a hesla jsou ignorována. U správy systému SQL Server musí být k přihlašovacímu identifikátoru aplikace SQL Server přidružen přihlašovací identifikátor Microsoft Windows®.

Přepínač Ověřením serverem SQL s přihlašovacím ID a heslem

Určí, že ovladač SQL Server ODBC nepožaduje zabezpečené (prověřené) spojení se serverem SQL Server. Je-li vybrána tato možnost, server SQL Server při navazování spojení pomocí tohoto zdroje dat používá standardní zabezpečení přihlášení. Pro všechny žádosti o připojení musíte uvést přihlašovací identifikátor a heslo serveru SQL Server.

Tlačítko Konfigurace klienta

Otevře dialogové okno Add New Network Library Configuration (Přidat konfiguraci nové síťové knihovny) procedury SQL Client Configuration (Konfigurace klienta SQL).

Jestliže jste na první obrazovce průvodce zadali do pole Server nový název, bude pravděpodobně v tomto dialogovém okně nutné přidat konfigurační položku aliasu serveru, jehož název odpovídá názvu uvedenému v poli Server na první obrazovce průvodce ODBC. Název aliasu se musí shodovat s názvem zadaným v poli Server. Pro Microsoft SQL Server obvykle není třeba konfigurovat alias serveru. Ve většině případů může ovladač SQL Server ODBC použít při připojení výchozí síťovou knihovnu a název sítě uvedený v poli Server na první obrazovce průvodce.

Chcete-li, aby byla při připojení použita jiná síťová knihovna než výchozí knihovna klienta, klepněte na tlačítko Konfigurace klienta. Na tlačítko Konfigurace klienta klepněte i v případě nutnosti zadání skutečné síťové adresy serveru. Používáte-li například síťovou knihovnu TCP/IP, bude pravděpodobně nutné zadat port a adresu soketu serveru, respektive přijímá-li server SQL Server na jinak pojmenovaném kanále, bude nutné v dalších volbách zadat název kanálu.

Další informace o konfiguraci klientů najdete v databázi informací SQL Server Books Online.

Zaškrtávací políčko Připojit se k serveru SQL Server a získat výchozí nastavení pro další konfiguraci

Zaškrtnete-li toto políčko, ovladač SQL Server načte ze serveru SQL Server počáteční nastavení možností následujících obrazovek průvodce. Ovladač pro SQL Server se připojí k serveru SQL Server, jehož název je uveden v poli Server na první obrazovce.

Není-li políčko zaškrtnuto, použije ovladač jako počáteční nastavení voleb následujících obrazovek průvodce standardní výchozí hodnoty.

Pole Přihlašovací ID

Je-li vybrána možnost Ověřením serverem SQL s přihlašovacím ID a heslem, určuje toto pole přihlašovací identifikátor, který bude ovladač SQL Server používat při spojení se serverem SQL Server. Nastavená hodnota se týká pouze spojení, které slouží ke zjištění výchozích parametrů serveru, a netýká se dalších připojení pomocí zdroje dat po jeho vytvoření.

Pole Heslo

Je-li vybrána možnost Ověřením serverem SQL s přihlašovacím ID a heslem, určuje toto pole heslo, které při navazování spojení použije server SQL Server. Nastavená hodnota se týká pouze spojení, které slouží ke zjištění výchozích parametrů serveru, a netýká se dalších připojení pomocí zdroje dat po jeho vytvoření.

Obě pole Přihlašovací ID a Heslo jsou znepřístupněny, pokud je vybrána možnost Ověřením systémem Windows NT se síťovým přihlašovacím ID nebo pokud není zaškrtnuto políčko Připojit se k serveru Server SQL a získat výchozí nastavení pro další konfiguraci.


Data Source Wizard Screen 3

Průvodce zdrojem dat - třetí obrazovka

Na třetí obrazovce průvodce můžete určit výchozí databázi, způsob, jakým bude ovladač využívat uložené procedury při podpoře příkazu SQLPrepare, různé parametry ANSI pro ovladač a možnost, zda použít záložní server.

Pole Změnit výchozí databázi na

Určuje název výchozí databáze pro veškerá připojení s daným zdrojem dat. Pokud políčko nezaškrtnete, bude při připojení použita výchozí databáze definovaná pro přihlašovací identifikátor na serveru. Je-li políčko zaškrtnuto, název databáze uvedený v poli potlačí výchozí databázi definovanou pro přihlašovací identifikátor. Pokud je v poli Připojit název databázového souboru uveden název primárního souboru, bude databáze popsaná primárním souborem připojena jako databáze s použitím názvu databáze uvedeného v poli Změnit výchozí databázi na.

Použití výchozí databáze pro přihlašovací identifikátor je výhodnější než stanovení výchozí databáze ve zdroji dat ODBC.

Připojit název databázového souboru

Určuje název primárního souboru pro připojitelnou databázi. Tato databáze je připojena a používá se jako výchozí databáze pro zdroj dat. Zadejte úplnou cestu a název souboru pro primární soubor. Jako název připojené databáze se použije název databáze uvedený v poli Změnit výchozí databázi na.

Zaškrtávací políčko Vytvořit dočasně uložené procedury pro připravené příkazy SQL a smazat uložené procedury

Není-li toto políčko zaškrtnuto, ovladač pro Microsoft® SQL Server&trade nevytváří uložené procedury pro podporu funkce ODBC SQLPrepare. Je-li políčko zaškrtnuto, ovladač pro SQL Server vytváří dočasně uložené procedury pro podporu funkce ODBC SQLPrepare. Toto zaškrtávací políčko a s ním spojené možnosti se uplatní pouze při připojení ke starším verzím serveru SQL Server.

Přepínač Pouze při odpojení

Určuje, zda dočasně uložené procedury vytvořené pro příkaz SQLPrepare budou smazány až při volání funkce ODBC SQLDisconnect. Ovladač tak může uložené procedury znovu využívat, pokud se opakovaně připravuje stejný příkaz SQL, a současně se snižují dodatečné nároky spojené s mazáním uložených procedur při běhu aplikace. Výběr této možnosti pro aplikaci spuštěné po dlouhou dobu bez odpojení nebo pro aplikaci používající množství volání SQLPrepare může vést k hromadění dočasně uložených procedur.

Přepínač Při odpojení a je-li to vhodné, i během připojení

Určuje, zda se budou volat dočasně uložené procedury vytvořené pro příkaz SQLPrepare při volání funkce SQLDisconnect, při volání funkce SQLFreeHandle pro manipulátor příkazu, při volání příkazu SQLPrepare nebo SQLExecDirect ke zpracování nového příkazu SQL na stejném manipulátoru příkazu, popřípadě při volání funkcí katalogu. Vznikají přitom určité dodatečné nároky, neboť dočasně uložené procedury se mažou při běhu aplikace, nedochází však k hromadění dočasně uložených procedur v případě dlouho spuštěných aplikací.

Zaškrtávací políčko Použít identifikátory ve standardu ANSI s uvozovkami

Určuje, zda budou při navázání spojení ovladačem SQL Server ODBC) použity identifikátory s uvozovkami (QUOTED_IDENTIFIERS). Je-li políčko zaškrtnuto, server SQL Server si pro uvozovky vynutí pravidla standardu ANSI. Uvozovky lze používat pouze pro identifikátory, jako jsou názvy sloupců či tabulek. Znakové řetězce musejí být uvedeny v apostrofech:

SELECT "au_id"
FROM "authors"
WHERE "au_lname" = 'O''Brien'

Není-li políčko zaškrtnuto, aplikace využívající identifikátory v uvozovkách (například nástroj Microsoft Query dodávaný s aplikací Microsoft Excel) bude hlásit chyby u příkazů SQL obsahujících identifikátory v uvozovkách.

Zaškrtávací políčko Použít hodnoty Null, výplně a upozornění ve standardu ANSI

Určuje, zda budou při navázání spojení ovladačem SQL Server použity volby ANSI_NULLS, ANSI_WARNINGS a ANSI_PADDINGS .

Je-li nastavena volba ANSI_NULLS, bude server vynucovat pravidla standardu ANSI při porovnávání sloupců s hodnotou NULL. Pro veškerá porovnání s hodnotou NULL musí být použita syntaxe standardu ANSI "IS NULL" nebo "IS NOT NULL". Syntaxe typu "= NULL" jazyka Transact-SQL není podporována.

Je-li nastavena volba ANSI_WARNINGS, server SQL Server generuje varovné zprávy za podmínek, kdy dojde k porušení pravidel ANSI, ale nedojde k porušení pravidel jazyka Transact- SQL. Jako příklad tohoto typu chyb můžeme uvést zkrácení dat při provádění příkazu INSERT nebo UPDATE, popřípadě výskyt hodnoty Null během agregační funkce.

Je-li nastavena volba ANSI_PADDING, nedochází k automatickému vypuštění koncových mezer v hodnotách typu varchar a koncových nul v hodnotách typu varbinary.

Zaškrtávací políčko Použít záložní SQL Server, pokud primární SQL Server není k dispozici

Je-li toto políčko zaškrtnuto a pro server SQL Server uvedený ve zdroji dat je definován záložní server, ovladač SQL Server při připojení k příslušnému primárnímu serveru shromažďuje informace o připojení pro záložní server. Jestliže aplikace ztratí své připojení k primárnímu serveru SQL Server, ukončí aktuální transakci a pokusí se o nové připojení k primárnímu serveru SQL Server. Pokud ovladač zjistí, že primární server je nedostupný, automaticky se připojí k záložnímu serveru. Pokud server nepodporuje záložní funkce, není toto políčko dostupné.


Data Source Wizard Screen 4

Průvodce zdrojem dat - čtvrtá obrazovka

Na čtvrté obrazovce průvodce můžete určit jazyk zpráv serveru Microsoft® SQL Server™, převod znakové sady a případné použití místního nastavení v ovladači SQL Server. Můžete rovněž řídit protokolování dlouho probíhajících dotazů a nastavení statistiky ovladače.

Pole Změnit jazyk systémových zpráv serveru SQL Server na

Každý SQL Server může mít několik sad systémových zpráv, přičemž každá z nich je v jiném jazyce (angličtina, španělština, francouzština atd.). Je-li zdroj dat definován pro server, který podporuje více sad systémových zpráv, můžete stanovit jazyk, který chcete pro systémové zprávy použít. V seznamu klepněte na požadovaný jazyk. Pokud je na serveru SQL Server nastaven jediný jazyk, není tato možnost k dispozici.

Zaškrtávací políčko Převést znaková data

Je-li políčko zaškrtnuto, ovladač SQL Server ODBC převádí řetězce ANSI předávané mezi počítačem klienta a serverem SQL Server do znakové sady Unicode. Ovladač SQL Server ODBC v některých případech nechává dojít k převodu mezi kódovou stránkou serveru SQL Server a znakovou sadou Unicode na klientském počítači. Znaková stránka používaná na serveru SQL Server proto musí být současně i jednou z kódových stránek dostupných na klientském počítači.

Není-li políčko zaškrtnuto, nedochází při předávání znakových řetězců ANSI mezi klientskou aplikací a serverem k žádnému převodu znaků rozšířené sady. V případě, že klientský počítač používá kódovou stránku ANSI (ACP) odlišnou od kódové stránky serveru SQL Server, může ve znakových řetězcích ANSI dojít k chybné interpretaci rozšířených znaků. Používá-li klientský počítač stejnou kódovou stránku ANSI jako server SQL Server, rozšířené znaky budou interpretovány správně.

Zaškrtávací políčko Použít místní nastavení při výstupu ve formátu měny, čísel, data a času

Určuje, zda ovladač při formátování měny, čísel, kalendářního data a času do výstupních znakových řetězců používá místní nastavení klientského počítače. Pro uživatele, který navazuje spojení prostřednictvím zdroje dat, použije ovladač výchozí místní nastavení přihlašovací registrace operačního systému Microsoft Windows® 95 či 98, Microsoft Windows NT® nebo Microsoft Windows® 2000. Tuto možnost používejte pro aplikace, které data pouze zobrazují, nikoli pro aplikace určené ke zpracování dat.

Pole Uložit dlouho probíhající dotazy do souboru protokolu

Určuje, zda má ovladač protokolovat veškeré dotazy, které budou probíhat delší dobu než hodnota Dlouho probíhající dotaz. Dlouho probíhající dotazy jsou protokolovány v určeném souboru. Při určení souboru protokolu zadejte do pole buď úplnou cestu a název souboru, nebo klepněte na tlačítko Procházet a vyberte soubor protokolu procházením stávajících adresářů se soubory.

Pole Dlouho probíhající dotaz (milisekundy)

Určuje mezní hodnotu (v milisekundách) protokolování dlouho probíhajících dotazů. Veškeré dotazy, které budou probíhat déle než stanovený počet milisekund, budou zaznamenány do protokolu.

Pole Zaznamenat statistiku ovladače ODBC do souboru protokolu

Určuje, zda budou protokolovány statistické údaje. Tyto informace se ukládají do určeného souboru. Při určení souboru protokolu zadejte do pole buď úplnou cestu a název souboru, nebo klepněte na tlačítko Procházet a vyberte soubor protokolu procházením stávajících adresářů se soubory.

Protokol se statistickými údaji používá jako oddělovač znak tabelátor. Tento formát souborů lze analyzovat v programu Microsoft Excel nebo v libovolné jiné aplikaci, která podporuje soubory s tabulátorem jako oddělovačem.


SQL Server Login Dialog Box

Dialogové okno Přihlášení k serveru SQL Server

Pokusíte-li se vyvolat spojení bez uvedení dostatečných informací, které ovladač Microsoft® SQL Server™ ODBC potřebuje k navázání spojení se serverem SQL Server, zobrazí ovladač dialogové okno Přihlášení k serveru SQL Server.

Dialogové okno Přihlášení k serveru SQL Server se nejprve zobrazí pouze s těmito prvky:

pole Server nebo název zdroje dat,

zaškrtávací políčko Použít důvěryhodné připojení,

pole Přihlašovací ID,

pole Heslo,

tlačítka OK, Storno a Možnosti.

Klepnete-li na tlačítko Možnosti, dialogové okno se rozbalí a bude navíc obsahovat skupinový rámeček Možnosti:

pole Databáze,

pole Jazyk,

pole Název aplikace,

pole ID pracovní stanice.

Pole Server

Název serveru SQL Server v síti. Vyberete-li název serveru ze seznamu, není nutné dále zadávat konfiguraci. Pokud název serveru napíšete, musí se jednat o položku ve skupině Advanced v nástroji SQL Client Configuration nebo o síťový název serveru, na kterém je spuštěn SQL Server. Pokud jste pro spojení určili název zdroje dat (DSN – data source name), bude se na místě tohoto pole nacházet název zdroje dat.

Používáte-li stejný počítač jako SQL Server, lze zadat do pole Server text „(local)“. Uživatel se pak může připojit k místní kopii serveru SQL Server, a to i v případě nesíťové verze serveru SQL Server.

Další informace o názvech serverů pro různé typy sítí najdete v dokumentaci instalace serveru SQL Server v databázi informací SQL Server Books Online.

Zaškrtávací políčko Použít důvěryhodné připojení

Je–li toto políčko zaškrtnuto, požaduje ovladač SQL Server ODBC zabezpečené (prověřené) spojení se serverem SQL Server spuštěným pod operačním systémem Microsoft Windows NT®nebo Microsoft Windows® 2000. Je-li vybrána tato možnost, použije SQL Server integrované zabezpečení přihlášení pro vytvoření připojení pomocí tohoto zdroje dat bez ohledu na současný režim zabezpečení přihlášení na serveru. Všechna přihlašovací ID a hesla jsou ignorována. Správce systému serveru SQL Server musí mít přidružený identifikátor sítě Windows spolu s přihlašovacím identifikátorem serveru SQL Server.

Není-li toto políčko zaškrtnuto, použije server SQL Server při navazování spojení pomocí tohoto zdroje dat standardní zabezpečení přihlášení. U všech žádosti o připojení je nutné uvést přihlašovací identifikátor a heslo serveru SQL Server.

Pole Přihlašovací ID

Není-li zaškrtnuto políčko Použít důvěryhodné připojení, určuje toto textové pole přihlašovací identifikátor pro spojení se serverem SQL Server. Je-li políčko Použít důvěryhodné připojení zaškrtnuto, pole Přihlašovací ID není k dispozici.

Pole Heslo

Není-li zaškrtnuto políčko Použít důvěryhodné připojení, toto textové pole určuje heslo pro spojení se serverem SQL Server. Je-li políčko Použít důvěryhodné připojení zaškrtnuto, pole Heslo není k dispozici.

Pole Databáze

Určuje výchozí databázi, která bude použita při připojení. Tato možnost potlačí výchozí databázi nastavenou pro přihlášení k serveru. Není-li databáze zadána, bude při připojení použita výchozí databáze nastavená pro přihlášení na straně serveru.

Pole Jazyk

Určuje národní jazyk, který budou používat systémové zprávy serveru SQL Server. V aplikaci SQL Server musí být příslušný jazyk nainstalován. Tato možnost potlačuje výchozí jazyk nastavený pro přihlášení na straně serveru. Není-li jazyk zadán, při spojení se použije výchozí jazyk nastavený pro přihlášení k serveru.

Pole Název aplikace

Toto volitelné pole určuje název aplikace, který bude uložen do sloupce program_name v řádku daného připojení v tabulce master.dbo.sysprocesses.

Pole ID pracovní stanice

Toto volitelné pole určuje identifikátor pracovní stanice, který bude uložen do sloupce hostname v řádku daného připojení v tabulce master.dbo.sysprocesses.


Microsoft SQL Server 2000 Copyright and Disclaimer

Microsoft SQL Server 2000 – autorská práva a zřeknutí se práv

Tento dokument včetně obsažených vzorových aplikací je určen pouze k informačním účelům a společnost Microsoft v něm nevyjadřuje žádné záruky, výslovné ani předpokládané. Informace obsažené v tomto dokumentu, včetně vzorových příkladů, adres URL a dalších odkazů na stránky WWW v síti Internet se mohou změnit bez předchozího upozornění. Veškerá rizika spojená s používáním tohoto dokumentu nebo s následky tohoto používání nese uživatel.

Hlavním účelem vzorového příkladu je znázornění pojmu nebo vhodného použití konkrétního příkazu nebo klauzule. Většina vzorových příkladů nezahrnuje celý kód, který je normálně obsažen v plně funkčním systému, protože většina obvyklého ověřování dat a zpracování chyb byla odstraněna, aby mohl být vzorový příklad zaměřen na konkrétní pojem nebo příkaz. Odborná pomoc není u vzorových příkladů ani u uvedeného zdrojového kódu k dispozici.

Pokud není uvedeno jinak, jsou uvedené společnosti, organizace, produkty, osoby a události fiktivní a spojení s jakoukoli skutečnou společností, organizací, produktem, osobou nebo událostí není zamýšleno a nemělo by být vyvozováno. Zodpovědnost za dodržování příslušných autorských práv spočívá na uživateli. Bez omezení autorských práv nemůže být žádná část tohoto dokumentu kopírována, ukládána či zavedena do systému vyhledávání informací či jakýmkoli způsobem šířena (elektronicky, mechanicky, kopírováním, nahráváním nebo jinak) bez ohledu na účel, aniž k tomu společnost Microsoft vydá písemný souhlas.

Společnost Microsoft může vlastnit patenty, patentové přihlášky, ochranné známky, autorská práva či jiná práva týkající se duševního vlastnictví zahrnující předměty témat v tomto dokumentu. S výjimkou případů výslovně uvedených v písemných licenčních smlouvách společnosti Microsoft vám poskytnutím tohoto dokumentu nevznikají žádná oprávnění vůči těmto patentům, ochranným známkám, autorským právům či jinému duševnímu vlastnictví.

©1996-2000 Microsoft Corporation. Všechna práva vyhrazena.

Active Directory, ActiveX, BackOffice, CodeView, Developer Studio, FoxPro, JScript, Microsoft, Microsoft Press, Microsoft SQL Server, MSDN, MS-DOS, Outlook, PivotChart, PivotTable, PowerPoint, Visual Basic, Visual C++, Visual Studio, Win32, Windows 2000, Windows a Windows NT jsou registrované obchodní známky nebo obchodní známky společnosti Microsoft Corporation ve Spojených státech a jiných zemích.

Názvy společností či produktů zmíněné v tomto dokumentu mohou být ochrannými známkami příslušných vlastníků.

Verze: 8.00.000

©1988-2000 Microsoft Corporation. Všechna práva vyhrazena.