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SYMANTEC LICENSE AND WARRANTY

The software which accompanies this license (the "Software") is the property of Symantec or its licensors and is protected by copy-
right law. While Symantec continues to own the Software, you will have certain rights to use the Software after your acceptance of
this license. Except as may be modified by a license addendum which accompanies this license, your rights and obligations with
respect to the use of this Software are as follows:

* You may:
(i) use one copy of the Software on a single computer;

(if) make one copy of the Software for archival purposes, or copy the software onto the hard disk of your computer and retain
the original for archival purposes;

(iii) use the Software on a network, provided that you have a licensed copy of the Software for each computer that can access
the Software over that network;

(iv) after written notice to Symantec, transfer the Software on a permanent basis to another person or entity, provided that
you retain no copies of the Software and the transferee agrees to the terms of this agreement; and

(v) if a single person uses the computer on which the Software is installed at least 80% of the time, then after returning the
completed product registration card which accompanies the Software, that person may also use the Software on a single home com-
puter.

* You may not:
(i) copy the documentation which accompanies the Software;
(ii) sublicense, rent or lease any portion of the Software;

(iif) reverse engineer, decompile, disassemble, modify, translate, make any attempt to discover the source code of the Soft-
ware, or create derivative works from the Software; or

(iv) use a previous version or copy of the Software after you have received a disk replacement set or an upgraded version as
a replacement of the prior version, unless you donate a previous version of an upgraded version to a charity of your choice, and
such charity agrees in writing that it will be the sole end user of the product, and that it will abide by the terms of this agreement.
Unless you so donate a previous version of an upgraded version, upon upgrading the Software, all copies of the prior version must
be destroyed.

* Sixty Day Money Back Guarantee:

If you are the original licensee of this copy of the Software and are dissatisfied with it for any reason, you may return the complete
product, together with your receipt, to Symantec or an authorized dealer, postage prepaid, for a full refund at any time during the
sixty day period following the delivery to you of the Software.

* Limited Warranty:

Symantec warrants that the media on which the Software is distributed will be free from defects for a period of sixty (60) days from
the date of delivery of the Software to you. Your sole remedy in the event of a breach of this watranty will be that Symantec will,
at its option, replace any defective media returned to Symantec within the warranty period or refund the money you paid for the

Software. Symantec does not warrant that the Software will meet your requirements or that operation of the Software will be unin-
terrupted or that the Software will be error-free.

THE ABOVE WARRANTY IS EXCILUSIVE AND IN LIEU OF AILL OTHER WARRANTIES, WHETHER EXPRESS OR IMPLIED, INCLUD-
ING THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
THIS WARRANTY GIVES YOU SPECIFIC LEGAL RIGHTS. YOU MAY HAVE OTHER RIGHTS, WHICH VARY FROM STATE TO
STATE.

* Disclaimer of Damages:

REGARDLESS OF WHETHER ANY REMEDY SET FORTH HEREIN FAILS OF ITS ESSENTIAL PURPOSE, IN NO EVENT WILL SYMAN-
TEC BE LIABLE TO YOU FOR ANY SPECIAL, CONSEQUENTIAL, INDIRECT OR SIMILAR DAMAGES, INCLUDING ANY LOST PROF-
ITS OR LOST DATA ARISING OUT OF THE USE OR INABILITY TO USE THE SOFTWARE EVEN IF SYMANTEC HAS BEEN ADVISED
OF THE POSSIBILITY OF SUCH DAMAGES.

SOME STATES DO NOT ALLOW THE LIMITATION OR EXCLUSION OF IIABILITY FOR INCIDENTAL OR CONSEQUENTIAL DAM-
AGES SO THE ABOVE LIMITATION OR EXCILUSION MAY NOT APPLY TO YOU.

IN NO CASE SHAILLSYMANTEC’S ITABILITY EXCEED THE PURCHASE PRICE FOR THE SOFTWARE. The disclaimers and limitations
set forth above will apply regardless of whether you accept the Software.

¢ U.S. Government Restricted Rights:

RESTRICTED RIGHTS LEGEND. Use, duplication, or disclosure by the Government is subject to restrictions as set forth in subpara-
graph (c) (1) (ii) of the Rights in Technical Data and Computer Software clause at DFARS 252.227-7013 or subparagraphs (c) (1) and
(2) of the Commercial Computer Software-Restricted Rights clause at 48 CFR 52.227-19, as applicable, Symantec Corporation, 10201
Torre Avenue, Cupertino, CA 95014.

* General:

This Agreement will be governed by the laws of the State of California. This Agreement may only be modified by a license addendum
which accompanies this license or by a written document which has been signed by both you and Symantec. Should you have any
questions concerning this Agreement, or if you desire to contact Symantec for any reason, please write:



* Addendum for Development Ianguage Products

Because the Software is a Symantec development language product you have a royalty-free right to include object code derived
from the libraries in programs that you develop using the Software and you also have the right to use, distribute, and license such
programs to third parties without payment of any further fees, so long as a copyright notice sufficient to protect your copyright in
the program is included in the graphic display of your program and on the labels affixed to the media on which your program is
distributed.

* Copyright and License Information

JAVA(tm) web development products are owned and licensed exclusively by Sun Microsystems, Inc. Copyright (C) 1992-96 Sun

Microsystems, Inc. All rights reserved. Java and all Java-based names and logos, including the Coffee Cup and Duke, are trademarks
of Sun Microsystems, Inc. and refer to Sun's Java Technologies. Products bearing authotized "JAVA- Compatible" ILogo are based
upon Sun's JAVA and technology, and are compatible with the API's for such technology.

Sun grants to you ("Licensee") a non-exclusive, non-transferable license to use the Java binaty code version (hereafter, "Binary Soft-
ware") without fee. Iicensee may distribute the Binary Software to third parties provided that the copyright notice and this statement
appear on all copies. Licensee agrees that the copyright notice and this statement will appear on all copies of the software, pack-
aging, and documentation or portions thereof.

In the event Licensee creates additional classes or otherwise extends the Applet Application Programming Interface (AAPI), licensee
will publish the specifications for such extensions to the AAPI for use by third party developers of Java-based software, in connection
with licensee's commercial distribution of the Binary Software.

RESTRICTED RIGHTS: Use, duplication or disclosure by the government is subject to the restrictions as set forth in subparagraph
(c) (1) (ii) of the Rights in Technical Data and Computer Software Clause as DFARS 252.227-7013 and FAR 52.227-19.

SUN MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE BINARY SOFTWARE, EITHER EXPRESS
OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTIC-
ULAR PURPOSE, OR NON-INFRINGEMENT. SUN SHALL NOT BE ILIABLE FOR ANY DAMAGES SUFFERED BY LICENSEE AS A RE-
SULT OF USING, MODIFYING OR DISTRIBUTING THE BINARY SOFTWARE OR ITS DERIVATIVES.

By downloading, using or copying this Binary Software, Licensee agrees to abide by the intellectual property laws, and all other
applicable laws of the U.S., and the terms of this License. Ownership of the software shall remain solely in Sun Microsystems, Inc.

Sun shall have the right to terminate this license immediately by written notice upon Licensee's breach of, or non-compliance with,
any of its terms. Licensee shall be liable for any infringement or damages resulting from Licensee's failure to abide by the terms of
this Ticense.

The JDK 1.1.5 binary release is based in part on the work of the Independent JPEG Group.
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C HAPTER

Introducing Visual Cafe
Database Development
Edition

Symantec Visual Cafe Database Development Edition is the first Rapid
Application Development (RAD) environment for creating Web-hosted Java
applets and standalone Java applications that provide powerful database
connectivity. It offers a full suite of integrated tools for Java development,
including a project manager, form designer, component library, source
editor, class browser, interaction wizard, database wizards and navigator,
and an integrated graphical debugger coupled with a Java compiler and
applet viewer. For many tasks, you don’t have to work with raw source
code at all.

Whether you are a novice user who wants to quickly create animations for
a Web page without touching Java code or a high-powered Java
programmer who wants to create sophisticated standalone applications and
have control over every line of your code, Visual Cafe is for you.

What's included

The Visual Cafe Database Development Fdition package includes the
following software to meet a variety of your requirements:

*  Visual Cafe Database Development Edition — A RAD tool you use to
design Java applets and applications that can optionally contain
database functionality.
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Chapter 1: Introducing Visual Cafe Database Development Edition

* dbANYWHERE Server — This middleware gives Java applets and
applications running on clients access to a variety of databases. The
clients require no special database software.

* Database software — A relational DBMS solution that is ideal for
desktop, workgroup, and mobile users and provides multi-platform
suppott.

*  Netscape FastTrack Server — This easy-to-use, upgradable Web server
software lets you create and manage a Web site.

* Netscape browser software — This includes a powerful Web browser
that facilitates information creation, access, and sharing and includes
Web, News, and Mail applications.

Now let’s take a closer look at Java and its many advantages.

Java applets and Web browsers

If you’ve explored the World Wide Web (WWW) with a Java-enabled Web
browser, chances are you’ve run into Java applets such as steaming coffee
cups, fireworks, scrolling banners, hotel and airline reservation utilities, or
even adventure games. Integrating an applet into a Web page is as simple
as adding a graphic: you just add a line of Hypertext Markup Ianguage
(HTML) code. When you access a Web page with an applet, the applet
code is transferred to your computer and executed by the browser, which
reduces the load on the Web server and makes the applet run faster on the
local computer.

Java is becoming very popular on the Internet because it makes Web pages
much more appealing and adds more functionality than HTML alone can
provide, so most new browser versions support Java. What’s more, Java
applets are secure since they can’t access the file system on the local
computer, but they can still read from the Web server. This means that
applets are less likely to damage a user’s system or send private
information back to the Web server.

Java makes it possible for a Web site to include much richer capabilities,
such as sound, animation, and the ability to interact real-time with data on
the Web, than is currently possible with static text or graphics. You can
include new types of data and provide associated Java bytecode programs
that know how to process the data on the client computer. For example, if
you wanted your applet to display an image that is stored in a format not
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Java applets and Web browsers

supported by most browsers, you could incorporate the ability to handle
this graphics format in the applet.

With Visual Cafe, it’s easy to build Java applets that add dynamic,
interactive functionality to your Internet or intranet Web site. You simply
create a new project containing a “skeleton” applet, which you use as a
template. You can display the applet in the Form Designer, which enables
you to design the applet with graphical tools. To create your user interface,
you can drag onto the form a variety of components, such as a button, text
field, and even an animation or slide show, then position or resize the
components as needed. You assign the component properties in a separate
Property List window and add interactions between components with the
Interaction Wizard. Visual Cafe generates the Java code for you during this
design process. To test the applet, you can run it with Visual Cafe. The
following figure shows some elements of the Visual Cafe Database
Development Edition environment.
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After your applet is finished, you can optionally add an HTML file to the
project. You can create and view HTML files using Symantec Visual Page,
using the Source Editor in Visual Cafe, or you can create the files in
another environment and add it to a Visual Cafe project.
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Because of Visual Cafe’s extensive library of components, you can develop
many applets without manually creating or editing Java code. To program
other features, you can manually add Java code with Visual Cafe’s Source
Editor. For example, you can add more complex custom event handling
that can’t be created with the Interaction Wizard, add custom data
processing, and write your own components then add them to theVisual
Cafe Component Library.

Java standalone applications

Like applets, Java applications are cross-platform, which makes them
popular for intranets. A Java application can run on all computers that have
Java, so separate applications for each environment aren’t needed. Unlike
Java applets, Java applications usually have menu bars and can access files
on the local computer. This additional functionality lets you implement
features in applications that you can’t provide in an applet, but it also
makes applications less secure than applets. You should be aware of this if
you are going to write code to access local storage or any host other than a
Web server.

Like other applications, Java applications run standalone without a Web
browser. A Java application is like a C++application, but it’s cross-platform
and you need a standalone Java virtual machine and supporting files on
your computer to run it. For example, you could write a word processor
program in Java. Java is free: the Sun Java Developers Kit (JDK), for
instance, can be downloaded from the Sun Microsystems Web site,
http://java.sun.com . In the future, Java will be integrated into many
operating systems.

Developing a Java application with Visual Cafe is similar to developing an
applet. First, you create a project and add all of the elements of your
application to it. For your main application window, you can open an
application template in the Form Designer, which enables you to design
the Java frame with graphical tools. You can drag onto the form a variety of
components, then position or resize the components as needed. You assign
the component properties in a separate Property List window, including
the menu items (the frame can have a menu bar); you can specify
interactions between components with the Interaction Wizard. Visual Cafe
automatically creates the Java code for you during this design process. The
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following figure shows some of these elements of the Visual Cafe

environment.
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To test an application, you can run it with Visual Cafe.

What is Java?

Java, developed by Sun Microsystems, was designed for creating applets
and applications for Internets, intranets, and any other heterogeneous,
distributed network. This language offers the following powerful features,
as described in the Java white papers published by Sun:

* Simple — Java is similar to C and C++, which many programmers are
already familiar with. Some of the more difficult features of C++,
including operator overloading, pointers and pointer arithmetic,
multiple inheritance, and extensive automatic coercions, were omitted
to make programming with Java easier. The Java automatic garbage
collection feature reduces bugs by automatically freeing unused
memory.
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* Small — The Java virtual machine is relatively small in size, so it can
be downloaded over the Internet and run on computers with little
available memory. Many operating systems will include Java in the
future.

* Object-oriented — Java mimics the object orientation of C++ and
includes extensions from Objective C for dynamic method resolution.
Some advantages of object-oriented programming include the
following:

* Code is encapsulated in objects, which have a public interface
and a private implementation, so you can rapidly develop
prototypes and group code into manageable chunks — even
for very complex systems.

* Objects can inherit the characteristics of other objects and
override inherited characteristics, so you can easily reuse code,
make your code more compact, and fix or update code in one
place, which saves time and reduces bugs.

* Network-ready — Creating network connections is easier in Java than
for C ot C++because Java has built-in routines for dealing with TCP/IP,
including HTTP and FIP. These routines make it as easy to open and
access objects over the network through URLs as it is to access a local
file system.

* Robust — Java climinates problems early by requiring declarations,
using static typing, having the compiler perform type checks, and not
supporting pointers, which can result in overwriting memory or
corrupting data.

* Secure — Because there are no pointers, Java applications can’t access
data structures or private data that they don’t have access to. This
prevents most viruses from taking hold. Applets, when run within a
Web browser on a local computer, can’t read or write to the disk,
execute programs on this computer, or connect to any other computers
except the server from which they were downloaded.

* Architecture-neutral and portable — The Java compiler generates
an architecture-neutral object file format and bytecode instructions, so
Java code can run on any computer that has a Java runtime system.
Bytecodes are instructions that are similar to machine code, but are not
platform-specific. During execution, the Java virtual machine either
interprets the bytecodes or converts them to machine code. Creating
separate applications for different computer platforms is no longer an
issue.
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* High-performance — Java bytecodes can be translated on the fly to
native machine instructions — for example, by a Java-enabled browser.
Linking is faster than for C or C++. Once the Java bytecodes are
converted to machine code by a Just-In-Time compiler in a Java virtual
machine, the performance is comparable to that of C or C++.

* Multithreaded — Java code can deal with multiple things happening
at once with sophisticated synchronization primitives that are
integrated into the language, which makes them easier to use and
more robust. Multithreading improves interactive responsiveness and
real-time behaviot, so is critical to high-performance Java applets
because applet execution must continue while various image and
binary files are being retrieved from one or more Web servers. In
addition, the ability to control the execution of multiple concurrent
threads is crucial for deploying real-world Web applications.

* Dynamic — New module plug-ins can be added to a Java application
with minimal overhead. Java can look up a class definition at runtime
from its name.

What is JDBC?

The many advantages of Java make it an excellent choice for use with
databases. JDBC is an SQI-level API that provides Java developers with
database access that’s independent of the database and the connectivity
mechanism. Its generic SQL database access framework provides a uniform
interface to a variety of different database connectivity modules. Because
Visual Cafe is fully compliant with the JDBC API, you can use Visual Cafe
to create a single database interface that’s compatible with a variety of
connectivity solutions. The JDBC design is similar to the Open Database
Connectivity (ODBC) standard, so its interface is familiar to many
programmers.

What is the dbANYWHERE three-tier
architecture?

The three tiers are the client, the dbANYWHERE middleware, and the
database residing locally or remotely to dbANYWHERE. The client
communicates with dbANYWHERE over a network, such as the Internet,
an intranet, ot a local area network (LAN). This architecture distributes the
database software between the clients and dbANYWHERE. dbANYWHERE
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makes the database requests and passes the data back to clients; it caches
data from the database system and sends only the requested subset to a
client. The client needs no application or database software other than the
standard Java files or a Java-enabled Web browser.

The dbANYWHERE middle tier is easy to manage and secure because you
only have to maintain direct database connectivity at this tier. In addition,
three-tier systems are cost-effective because the middle tier requires fewer
connections than would be required for direct client connections.

The dbANYWHERE Server provides heterogeneous access to common
database engines. This allows applets and applications to maintain live
connections to multiple database engines, with the advantages of data
buffering, reduced network traffic, and decreased hits on the database
engines.

dbANYWHERE supports two interfaces for Java database connectivity: the
standard JDBC API and the dbANYWHERE API. The dbANYWHERE API
delivers robust functionality for Java applications while making common
database operations — including master/detail processing — easier to
implement.

Features of the Visual Cafe environment

Visual Cafe gives you the easy-to-use Java language in a development
environment designed to make you highly productive. It includes the
following features, which you’ll learn more about in the Tour:

*  Visual, form-based development
*  Quick creation of component connections with the Interaction Wizard

* Two-way development, which means the visual tools and Java code
always match

*  Database connectivity through a three-tier architecture and the JDBC
standard

*  Support for major database servers
* Database wizards for simplified form development

*  Hierarchical view of database cataloging information with the

dbNAVIGATOR
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Features of the Visual Cafe environment

Simplified Java database connectivity through smart dbAWARE
components that provide data binding

Support for JDK 1.1, portable JavaBeans components, and Java Archive
(JAR) files

Quick creation of component connections with the Interaction Wizard
Integration with the Visual Page HTML editor
Rapid turnaround with fast compilers

An advanced debugger that includes expression evaluation

1-9



Chapter 1: Introducing Visual Cafe Database Development Edition




C HAPTER

Installing Visual Cafe

This chapter outlines the installation process for Visual Cafe Database
Development Edition and other software on the Visual Cafe CD.

This chapter has the following sections:

*  “Installing the software needed for the tour”
*  “Planning your installation”

*  “Using the installer”

*  “Using Visual Cafe”

Installing the software needed for the tour

Before starting the tout, you need to perform the following tasks:
* Install Visual Cafe.

* Install the dbANYWHERE Server.

* Install the database software.

* Setup the database for use with the Tour.

Installing Visual Cafe, the dbANYWHERE Server, and the
database software

To use the Tour you need to install, at a minimum, the Visual Cafe program
files and the Tour files. To use the Visual Cafe database features provided
in the Tour, you must also have access to the Tour database through the

21
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dbANYWHERE Server and the database engine, which are included on the
CD for Visual Cafe Database Development FEdition for Java.

To install the software needed for the tour, follow these steps:

1 Insert the Visual Cafe CD into your CD-ROM drive.
Normally, this will start the install program.

2 Ifstep 1 didn’t start the install program, run Setup.exe
Install Visual Cafe.

Note: If you have a previous version of Visual Cafe, do #ot install
to the same directory where it resides. You need to install to a new
directory. See the Readme.txt file for details.

If you need more instructions on using the installer, see the section,
“Using the installer” on page 2-6.

4 Install the dbANYWHERE Server.

The dbANYWHERE Server can be installed on the local computer or
on a remote computer. If Visual Cafe and dbANYWHERE are on
different computers, the computers must be able to communicate
over the netwotk through TCP/IP.

For more information on installing dbANYWHERE, refer to the
Installing and Running dbANYWHERE Server manual.

5 Install the database software.

See the installation documentation provided with the database engine
for more information.

6 After installing these products, you must reboot the computer.

Note: The database section of the Tour, Chapter 6, is designed with the
assumption that all three tiers run locally. In other words, Visual Cafe, the
dbANYWHERE Server, and the database engine are running on one
computer. If you’re working through the Tour, you might want to install all
of this software on your development computer for the tour. If necessary,
you can uninstall this software later.

If you can’t run all of this software on one computer because of system
resource limitations, you can still work through the tour. However, in the
section, ‘“Looking at the Isle de Cafe Web pages” on page 3-2, you will
need to modify the applet to use a remote dbANYWHERE Server. See the
section, “Planning your installation” on page 2-4 for system requirements.
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Setting up the Tour database on a dbANYWHERE Server

;‘! dbANYWHERE @ 155.65.43.210:8889 [users: 0]
Log Options  Help

[ ad

After installing dbANYWHERE and the database engine, you must create
the database for the Tour and register it with the 32bit ODBC
Administrator. To create and register the database, complete the
procedutres provided in the file createdb.txt in the Tour subdirectory

of your Visual Cafe installation.

Once you have created and registered the database for the Tour, Launch
dbANYWHERE by clicking the Windows Start menu then Programs >
Symantec dbANYWHERE Server > Symantec dbANYWHERE Server. The
dbANYWHERE window opens.

Working dir <C:ADBANYWHERE > ;I

bl
-
g
X

Running.

o
E
=
e

-
1| 3

Running Shutdown |

Iook at the title bar and note the IP address (or host name) and the port
number configured for dbANYWHERE. You need this information when
you work through Chapter 6, “Creating Applets with Database
Functionality.” If dbANYWHERE is running locally, you can use localhost
in place of an IP address, as long as your hosts or Imhosts  file contains

an entry for it (and it typically does by default).

You can test the data source for the Tour using dbANYWHERE. For
information on how to do this, refer to the Installing and Running
dbANYWHERE Server manual.

The rest of this chapter contains more general-purpose installation
instructions. You can look through them now, or start the Tour by going
directly to Chapter 3.
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Planning your installation

If you are not developing Java programs with database features, you only
need to install Visual Cafe. However, to develop Java programs that have
database connectivity, you must have access to the rest of the three-tier
architecture described in Installing and Running db ANYWHERE Server.

We recommend that you set up your system so it uses dbANYWHERE with
the same database that you use when you deploy your applets or
applications.

During development, you install Visual Cafe on your local computer. You
also need to install the following software:

* The dbANYWHERE Setver

You can install dbANYWHERE on your local computer or on a
remote computer that can communicate with the local computer
through TCP/IP.

* The database engine

You can install the database engine locally (on the same computer as
dbANYWHERE) or on a remote computer that can communicate with
the local computet through TCP/IP. Remote database engines (and
some local engines) require client software that must be installed on
the same computer as dbANYWHERE.

System requirements

2-4

The requirements for your system vary with respect to how you decide to
install Visual Cafe and other software. The topics that follow describe the
requirements for some common scenarios.

*  “Running only Visual Cafe”
*  “Running Visual Cafe and dbANYWHERE”

*  “Running Visual Cafe, dbANYWHERE, and the database engine”

Running only Visual Cafe
To run only Visual Cafe you need:

* IBM personal computer or 100 percent compatible, Pentium
equivalent, 90 MHz minimum
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* 32 MB RAM; 48 MB recommended for larger projects
* Windows 95 or Windows NT 4.0 or greater
* CD-ROM drive

* 30 to 100 MB free hard disk space, depending on configuration and
data caching requirements

*  VGA monitor; Super VGA recommended

* TCP/IP network

Running Visual Cafe and dbANYWHERE

To run Visual Cafe and the dbANYWHERE Server (with client software to
interface with a remote database), you must satify the requirements listed
above for Visual Cafe, and you also need:

* an additional 16 MB RAM

* an additional 30 to 40 MB free hard disk space, depending on
configuration and data caching requirements

For a complete list of dbANYWHERE installation requirements, see the
Installing and Running dbANYWHERE Server manual.

Running Visual Cafe, dbANYWHERE, and the database
engine

To run Visual Cafe, the dbANYWHERE Server, and the database engine on
the same computer, you need to meet the requirements for running your
databases engine in addition to those listed for running Visual Cafe and
dbANYWHERE. Typically, this requires:

* an additional 16 MB RAM

* an additional 50 to 100 MB free hard disk space, depending on
configuration and data caching requirements

In some cases, additional RAM is not required. In other cases, more RAM
and disk space than is listed here is required. For details on the installation
requirements for your database engine and client software, refer to the
documentation that accompanies the database.
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Using the installer
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If Visual Cafe is already installed on your system, refer to the Readme.txt
file before you begin installation.

To install Visual Cafe, dbANYWHERE, and other products included
on the Visual Cafe CD:

1
2

Insert the CD into the CD-ROM drive on your system.

If the installer doesn’t automatically start, choose Run from the
Windows Start menu to display the Run dialog box. Then, type:
drive \setup.exe

where drive is the CD-ROM drive identifier, and click OK.
Click the name of the software you want to install.

The Install Wizard guides you through the installation process; you
can select where to install Visual Cafe and which elements to install.
Click Next to proceed through the steps.

You can install the following items separately, by clicking the
appropriate icon:

* Visual Cafe
* The dbANYWHERE Server
* Other software (if included on your CD)

After installing, you are prompted to register your copy of Visual
Cafe. The Registration program asks you for your location, method
of registration, name and address, and some questions about how
you use Visual Cafe. You can register over the Internet, or by
printing a form and mailing it to Symantec.

Upon registering, you’ll be able to access Technical Support. For
more information on obtaining Technical Support, see “Support and
More Information” on page 7-1.

After you register your copy of Visual Cafe, the installer returns
you to the main installation window, where you can install other
items.

Read the Readme.txt file (on the CD-ROM) before you use the
software. It contains important last-minute information.

Information on Visual Cafe is included in the User’s Guide and in the online
help. Information on the dbANYWHERE Server is included in Installing

and Running dbANYWHERE Server and in the online help. Information on
other software included with Visual Cafe is described in other publications.
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Using Visual Cafe

For information on starting, exiting, and uninstalling Visual Cafe, see the
following topics:

*  ‘Starting Visual Cafe”
*  “Exiting Visual Cafe”
*  “Uninstalling Visual Cafe”

*  “Updating Visual Cafe”

Starting Visual Cafe

You can use either of the following methods to launch Visual Cafe:

* TFrom the Windows Start menu, choose Programs > Symantec Visual
Cafe dbDE > Symantec Visual Cafe dbDE.

*  Run the application (vcafe.exe ) ora.vep file from the Run dialog
box or an Explorer window.

The Visual Cafe environment appears. After you use Visual Cafe, it
remembers what windows you had open when you last used the
application and opens those windows the next time you run the product.

To use database functionality within Visual Cafe, dbANYWHERE must be
installed and running, either locally or on a remote computet, and
accessible through TCP/IP. Your local computer must also be configured
with TCP/IP connectivity.

To locate dbANYWHERE, you must know the IP address (or host name) of
the PC it’s running on and the port number configured for dbANYWHERE
When dbANYWHERE is running, it displays its IP address and port
number. The default port number is 8889. If dbANYWHERE is running
locally, you can use localhost in place of an IP address, as long as your
hosts or Imhosts file contains an entry for it. The entry for localhost

in the hosts or Imhosts file should be 127.0.0.1.

Exiting Visual Cafe

To exit from Visual Cafe, choose Exit from the File menu. If you have
unsaved changes, you are prompted to save them.
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Uninstalling Visual Cafe

To uninstall Visual Cafe:

1 ILaunch the Add/Remove Programs utlity from the Windows
Control Panel.

2 C(lick the Install/Uninstall tab and click Visual Cafe.

Click Add/Remove and follow the instructions on the screen.

Note: Uninstall does not remove any files created in the
\VisualCafedbDE  directory tree after Visual Cafe is installed (for
example, any sample projects) or in the Visual Cafe program group. You
must manually remove these files.

Updating Visual Cafe

To get a newer version of Visual Cafe, choose LiveUpdate from the Help
menu and follow the instructions on your screen.
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Starting the Tour

Imagine that you work for a travel agency, called Amazing Adventures
Travel, that’s ready to take advantage of the money-making opportunities
that the Internet offers. You decide to add Java functionality to a series of
Web pages that advertise your upcoming package tours and your custom
tour services. To get started, you update the pages for your favorite
destination, Isle de Cafe.

In this chapter, you’ll look at the Isle de Cafe applets and application, some
of which you’ll create in the following chapters, plus learn some important
Visual Cafe terms and concepts.

Note: The Tour is designed to be used in SDI mode. Make sure the MDI
Development Environment checkbox is de-selected on the General tab of
the Environment Options dialog box.

What you need

To work through the tour, you need to install the Visual Cafe software, as
described in the section, “Installing the software needed for the tour” on
page 2-1. You also need to install the version of Visual Page thatis on your
Visual Cafe CD, because you will view applets in Visual Page. Be sure to
start the dbANYWHERE Server before working through the tour.

After you meet these requirements, you can start the tour with this chapter.
Then wortk through the following chapters in order:

Chapter 4, “Creating an Applet for the Web Page” shows you how to create
an island map applet including an animation and integrate it into a Web
page, without needing to program in Java code.

3-1



Chapter 3:  Starting the Tour

Chapter 5, “Creating the Application and Debugging Code” describes how
to create a simple application and how to perform advanced debugging
operations. This chapter builds on the previous chapter.

Chapter 6, “Creating Applets with Database Functionality” shows you how
to use many of the Visual Cafe database features.

Looking at the Isle de Cafe Web pages

Your main Isle de Cafe Web page is the most important page. On this page,
you need to grab the initial interest of prospective clients, so they
remember your company and want to spend some time at your Web site. A
Web page with only HTML could potentially be a little boring. You decide
to add Java applets so the page becomes dynamic and interactive.

Let’s look at the Web pages and identify the elements created with Visual
Cafe.

When you first start Visual Cafe, the last project you opened or an
unnamed project, based on the default project template, appears. By
default, the Project, Form Designer, and Property List windows appear.

2 Visual Cafe - Untitled1
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You’ll work with the Visual Cafe applet and application templates later in
this tour.
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Opening the project

The Visual Cafe full-featured project management system and flexible
editing and browsing tools let you develop and maintain even the most
complex Java applications.

All of the applets and HTML files that make up the Isle de Cafe Web pages
are contained within the IsleWeb.vep  project.

To look at the project:

1 Close any open projects by clicking the Project window, then
choosing Close Project from the File menu.

2 From the File menu, choose Open.
The Open dialog box appears.

3  Select the IsleWeb.vep  project in the \Tour\Applet folder,
then click Open.

The project appears.

5 Visual Cafe - Isleweb VEP
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Running the applets in the Web page

Visual Cafe lets you run the applet directly within the Web page by using
Visual Page or your default Web browser. The advantage of using Visual
Page is you can also modify your HIML files as needed.
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To open the Web page in Visual Page:

1 In the Objects tab of the Project window, double-click Homg
which is an HTML file.

If you have properly installed Visual Page from the Visual Cafe CD,
Visual Page starts and displays the Isle de Cafe home page.

%8 VisualPage - [Home. html]
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2 From the View menu, choose Preview.
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The applets run in Visual Page.
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The Web pages contain elements that were created with HIML using
Visual Page and with Java using Visual Cafe. The Visual Cafe applets
on this page are the plane animation created with the Visual Cafe
Animator component and the slide show created with the Visual Cafe
SlideShow component.

On the left of the page are links to the other pages.

You use the plane animation to attract the attention of your Web site
guests. You also want your potential customers to get an idea of what
Isle de Cafe offers them, so you include the slide show. The slide
show contains photos of Isle de Cafe that you’ve collected over the
years. Your customers can move back and forward between the
photos of the slide show. Next to each photo is a description of the
location so your customers know what they’re looking at.

3 Click the Forward button (the right triangle) until you’ve viewed
the entire slide show. Also try clicking the Previous button (the left
triangle).

4 Explore the other Web pages by clicking a link on the left of the
page.

While the main Isle de Cafe Web page is important to capture

people’s initial interest, once they’re interested they may want more
in-depth information about the island.
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You decide that the best way to present this detailed information is
through an island map. On the map, customers can click a location to
jump to information about it. This feature was implemented with the
ImageViewer and Invisible HTMILink components provided with
Visual Cafe. You also decide to add an animation, implemented with
the Animator component, that draws attention to a main attraction on
the island — the ability to safely view an active volcano.

Some additional features on the Web site include a list of your
upcoming package tours, information on the custom tours you can
design for clients, an e-mail request form (an applet created with
Visual Cafe) so clients can get additional information, and some
quotes from clients about how much they enjoyed your tours.

It’s time to look at these Web page elements in Visual Cafe directly. You

can exit Visual Page or keep it running so you can refer back to the
completed Web pages.

Looking at the applets in Visual Cafe

Now that you’ve seen how the applets look in your Web pages, let’s see
how they were created with Visual Cafe.

Looking at the project

The Visual Cafe full-featured project management system and flexible
editing and browsing tools let you develop and maintain even the most
complex Java applications.

The Objects view of the Project window shows the components of a
project:

Avisnal componentis a user interface element, such as a window,
menu, button, and so on, that is visible at runtime and appears in the
Visual Cafe Project window and Form Designer. It extends from the
Java Component class and has a screen position, a size, and a
foreground and background color. It is often called a control in C++.

A top-level component, also called a Visual Cafe form, can only appear
at the top level in the Objects view of the Project window. Applets,
Frames, Windows, and some dialog components are forms. A form has
an associated Java source file and can contain other components,
which are represented by code in the source file.
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The Objects view also shows HTML files, if present.

To look at the project:

1

Look at the items appearing in the Project window.

Project - Isleweb VEP [_ (O] x]

MHame

- [@] Custamtours
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----- I riguiry
..... Home

]-- Email

]-- lsleMap
]-- SlideShowlsle
-] Flare

- [3] Reserve

----- Reserve

i O o B e W e M

Gy Objects | [ Packages | Files I

You’ll notice the following HTML files in the Project window:

* Comments — page containing customer comments

* Customtours — page describing custom and package tours

* Isle — page with island map

* Inquiry — page with e-mail questionnaire

* Home — first page

* Reserve — page with online reservations utility

And the following applets:

* Fmail — e-mail information form

* IsleMap — Isle de Cafe map with volcano eruption

* SlideShowlIsle — slide show

* DPlane — plane animation

* Reserve — online reservations utility

In the Project window, click the + next to a form to view the

components contained by it.

From the View menu, choose Component Library.
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6

The Component Library appears.

7-[_1) Project Templates
77 Standard

- Utilty

727 Multimedia

#-[_] Foms

720 Menus & Menu ltems
(2] dhéwiaRE

-2 Swing

The Component Library is a repository of components that comply
with the JavaBeans standard. Visual Cafe provides an extensive
library of components, which you can supplement with third-party
JavaBeans components and your own components. In addition to
supporting the complete set of standard Java components, Visual
Cafe provides many additional components. For fast access, you can
configure the Component Palette, which is at the top of the main
window or floating, to contain your favorite components:

] 55 5 s o ) 5 =)

Standard | Utity | Mulimedia | dbéiw/aRE | dbaMywHERE | Additional | Panel | Shape | JOBE | Swing |

To add a component to a Visual Cafe form, drag a component from
the Component Library to the Project window or Form Designer, then
position and resize it as needed. Or, you can click a component on
the Component Palette and draw it on the form. In addition, the
Component library contains forms, so you can drag a form into a
Project window to add it to the project. To add a component to the
Component Palette so you can get to it more quickly, drag the
component from the Component Library to the Palette.

Close the Component Library window.
In the Project window, click the Packages tab.

The Packages view shows the source files in a project, grouped as
packages. A Java package is a group of related Java classes and
interfaces.

In the Project window, click the Files tab.
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The Files view lists the files in your projects. The Imports folder
contains the classes the Java programs need.

7 Click the Objects tab to teturn to the Objects view.

You can double-click a form or file in the Project window to open it. In the
following sections, you’ll look at the applets and an HTML file in the
project.

Looking at the applets

Once the Project is opened, you can look at the applets it contains.

To look at the applet:
1 Double-click the IsleMap applet in the Project window.
The Form Designer appears.

IzsleMap - Form Designer M=1 E3

VENDUCA

o~ Nl

I

Click a
location name
Jor more information

Muderna

The Form Designer is a true What-You-See-Is-What-You-Get
(WYSIWYG) form layout tool: it lets you edit all types of forms,
including applets, windows, message boxes, and dialog boxes. To
design the visual interface of your Java applications and applets, you
can drag and drop components from the Component Palette or
Library directly onto your forms. Visual Cafe automatically generates
the Java code and changes the code as you make modifications.
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Several layout managers are available, so you can pick the one that
best suits your form, or don’t use one at all.

The properties of the components are displayed in the Property List
window. To specify the properties of components on a form, you
simply fill in fields in the Property List. Visual Cafe updates the
component appearance on the form and the Java code for you.

To look at the properties for the Animator component, choose the
component (animatorErupt) from the pull-down menu at the top
of the Property List or click the component on the form.

The properties for the Animator component appear in the Property
List window.

To look at the underlying Java source code for the applet, double-
click the Form Designer. Or right-click over the IsleMap object in
the Project window, then choose Edit Source from the pop-up
menu.

The applet source code appears in the Source Editor.

B c\VisualCafe\Tour\AppletilsleMap.java =] E3
Obijectz |sletap j Eventz/Methods: I j
ke -
b4 hasic extension of the java.applet.ipplet class
w/

import java.awt.®;
import java.applet.¥;

import symantec.itools.multimedia. InageViewer:;
import symantec.itools.awt.InvisibleHTMLLink:
import symantec.itools.wultimedia. inimator:
public class IsleMap extends Applet

{

public woid inici)
{ -

4] | " 3

| | |Line 1 |CDI 1

Visual Cafe supports two-way development by translating Java code
into a visual representation and by translating the visual
representation in the Form Designer to Java code. Your code and
your visual model always match.

The Visual Cafe Source Editor simplifies development with full-color
Java syntax and keyword highlighting and an integrated macro
language for extending the editor. A single mouse click in a pull-
down menu navigates you to a declaration inside the Java project.
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The Form Designer ensures full synchronization between source
code and the visual tools. During debugging, you can use the Source
window to monitor program execution.

Close the Soutrce window.

5 You can also look at the plane animation by double-clicking Plane
in the Project window, the slide show by double-clicking
SlideShowIsle, the e-mail questionnaire applet by double-clicking
Email, and the online reservations utility by double-clicking the
Reserve applet.

Because these are detailed applets, you might want to close each

Form Designer window before opening another one.

To test your applet, you can run it in the Visual Cafe Applet Viewer. Visual
Cafe also lets you run your applets within a Web browser by launching the
browser for you.

Opening an HTML file

An applet runs from an HTML file. Although your project doesn’t have to
contain the HTML files that the applets run in, it’s convenient to include the
HTML files in the project.

To look at the HTML file:

1 Click the Files tab in the Project window, then double-click
Home.html .
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The Source window appears.

[ c:\WisualCafedbDEAT our\Applet\Home. html =1 3
Obijects: I j Ewents/Methods: I j Delete |
<!DOCTYPE HTHL PUBLIC "-//W3C//DTD HTML 3.z//EN"> ii
<HTML>
<HEAD>

<METAL HNAME="GENERATOR®™ Content="Visual Page 1.0 for Windows"™:>

<METL HTTP-EQUIV="Content-Type™ CONTENT="text/htwml;CHLRSET=is0-8859-1

<TITLE>Z3ymantec Visual Caf&sacute:; Tutorial - Isle de Caf&eacute: Tou
</HELD>

<BODY BACKGROUND="Images,GOALL.GIF™ TEXT="#000000" BGCOLOR="HFFFFFF" LINE

<F>
<TABLE BORDER="0" CELLSPACING="§" WIDTH="100%">
<TR>
<TD WIDTH="160" VALIGN="TOPF"><ING SRC="Images/GOALLZ.gif" WIDTH='jv
| >
[ Line15  [Call
The HTML file is displayed in this window. You can create and edit
HTML code here. If you’ve installed Visual Page from the Visual Cafe
CD, you can double-click an HTML file in the Project window to
launch Visual Page and edit the file there.
2 From the Search menu, choose Find.
The Find dialog box appears.
Find E
Fitnd what;
| i
Previous
™ Match case 4'
™ Match whole words only ﬂl
™ Begular expression
3 Type applet code, then click Next.
The words are highlighted in the HTML code. This is part of the
applet tag that causes the Visual Cafe applet to appear on the Web
page. An applet tag has the following basic format:
<APPLET code=" applet .class" width= pixw height=  pixh ></APPLET>

applet is the name of the applet, piXW is the number of pixels for
the width, and pixh is the number of pixels for the height.

4 From the Search menu, choose Find Again.
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Another applet tag is highlighted in the HTML file.
5 From the File menu, choose Close Home.html.

The Source window closes.

Now let’s look at the application. You can close your project by closing the
Project window.

Running the custom itinerary application

A large part of your business revenue is generated from designing custom,
escorted tours to Isle de Cafe. As you expand your operations onto the
web, you look at ways to take full advantage of the time-saving aspects of
electronic communications.

You decide that a cross-platform Java application would be ideal for
distributing custom itineraries to clients for approval. Instead of spending
time and money putting together an itinerary on paper — especially one
that looks good enough for people purchasing a premium tour — you can
put together a polished itinerary in the form of an application. This
itinerary is easily modified as changes are needed and includes photos of
the locations the clients will visit.

To run the itinerary application:

1 In a DOS window, navigate to the directory containing
AmazingTour.class

If you installed in the default location, it should be in the
\Tour\Application directory.

2 At the DOS prompt, enter the full path to java.exe followed by
the class. For example:

\'VisualCafedbDE"\java\bin \java AmazingTour

Note: Since Java is case sensitive, you must type in the class name
with appropriate upper/lowercase letters.
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The application appears.

E%Amazing Adventures Travel - Custom ltinerary Application

File Help

To start. choose Open from
the File menu and open
your data file. Your .dat file
and the graphics files must
be in the same directory.

3 From the application, open Tour.dat
Images directory.

, which is located in the




Looking at the application in Visual Cafe

The itinerary appears.

Eg_;gﬁmazing Adventures Travel - Custom ltinerary Application

File Help

Custom Itinerary for

Stan and Flora
Robinson

Ligy 7

Artiva this morning in lsle de Café, at
the tropical paradise of Bunghbusi.
Check into your deluxe seaside
tegat, then enjoy the pristine
heaches just outside your door. The
sand beaches and warm waters are
ideal for relaxing and for all kinds of
water sports, including surfing, water
skiing. and snorkeling, included at no
additional charge. The resont
gardens. three poals. gourmet
restaurants, open-air lounge with local
entertainers, and swim-up bar are at
wour disposal. Now is the time to let
the stresses fade atlsle de Cafe.

Previous MNext

4 Press the Next and Previous buttons to look through the itinerary.

5 To exit the application, choose Exit from the File menu. Then click
Yes in the dialog box.

Now let’s look at the application in Visual Cafe.

Looking at the application in Visual Cafe

Now that you’ve seen how the application works, let’s see how it was
created with Visual Cafe.

To look at the itinerary application in Visual Cafe:

1 If you don’t have Visual Cafe running, start it now.
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2 Close any open projects.
From the File menu, choose Open.
The Open dialog box appears.

4  Select the Itinerary.vep project in the \Tour\Application
folder, then click Open.

The project appears.

isual Cafe - Itinerary. YEP

File Edit Wiew Seach Project Inseit Tooks Window Help

Dz 22| 2] 282|| wokssce [ ~ || HEEEE ‘ [ = =[E
NEE R EEEE EEE = V= i e e i =
EI Standard [ Uity | Multimedia | dbawaRE | dbéNvwHERE | Additionsl | Panel | Shape | JDBC
For Help, press F1 [NUM |
H Pioject - ltinerary.VEP (O[] & Propety List - AmazingTour B[S EY
— | [F] AmazingT our -
[E] AmazingT our; Backgiound ] white
[E Aboiibidiog 5 Bounds
[E] QuitDialog vy 0
Y 0
Width 500
" Height 530
Class |ava. awt.Frame
Cursor DEFAULT_CURSOR
Enabled e
= Fant
Name Dialog
Size [H
=- Shle
~— Bold false
: italic false
Dbigcts | 1 Pack Fil
“n SheEh | B Ve = Foregiound W black
Inherit Background Igse
Inherit Font false
Inherit Foreground | false
None
Name AmazingT our
Riesizable [
Tille Amazing Adventures T
Wisible false
[ — 0|

You’ll notice the following components in the Project window:
* AmazingTour — main application window
* AboutDialog — About dialog box
* QuitDialog — Quit dialog box
5 In the Project window, double-click AmazingTour.
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sual Cale - Itinerary. VEP
Fie Edit Wiew Seach Project Inset Tooks Layout 0Object Window Help

The Form Designer appears.

M= EENER

A7

|| EE| A=

Workspace: |Edit - ||

EEEENE (V= = e T =

EI Standard ] Uity | Mulimedia | dbawiaRE | dbéNvwHERE | Addtionsl | Panel | Shape | JDBC

For Help, press F1 [ [NUM |
Project - Itinerary. VEP I8 [=1 [ || EEd AmazingT our - Form Designer =] S | masing T oun i =] EY
— T SRR RRRRALIRE o - =
To start, choose Open from the
[F] Bmazing our y [ white
Bl boudidiog File menu and open your data
=] QuitDidlag file. Your .dat file and the ]
. graphics files must be in the 1
" same directory. BED
530
java. awt Frame

Gy Objects | fy Packages | B Files [

DEFAULT_CURSOR
frue

Dialog
12

AmazingT oun
true

Amazing Adventures T
false

| 2]

The Project window lists the names of the components on the form.
To see the components within AmazingTour, you can click the + next

to AmazingTour.

6 Close your project by closing the Project window.

Visual Cafe lets you launch your application from within its environment so
you can test it. You’ll try this feature later in the tour.

Now you can continue with the next chapter to build and test one of the

applets.
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C HAPTER

Creating an Applet for the
Web Page

This chapter quickly acquaints you with the main features of Visual Cafe by
showing you how to create an applet for your Isle de Cafe Web site. This
portion of the tour doesn’t involve manually creating new Java code;

instead, you use the visual design capabilities of Visual Cafe to create your
complete applet. In the next chapter, you do work directly with Java code.

To learn how to add applets to your HIML page, you work through the
following sections in this chapter:

*  “Creating and naming the project”
*  ‘“Creating the island map applet”
* “Displaying the appletin a Web page”

Before working through this chapter, you should have completed the

3 55

previous chapter ““Starting the Tour”.

Note: When you first install Visual Cafe, you have the default environment
options. If you’ve changed your environment options since you’ve installed
the product, you might run into variations because of your settings. In
particular, make sure the keyboard is set to vcafe. Choose Environment
Options from the Tools menu to view your environment option settings.

Also, the Tour is designed to be used in SDI mode. Make sute the MDI
Development Environment checkbox is de-selected on the General tab of
the Environment Options dialog box.
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Creating and naming the project

4-2

The project contains the elements needed in a Web page, a group of
related Web pages, or an application, including applets, HTML files,
application windows, and so on. To get started quickly, you can use
project templates with skeleton applets and applications that you extend
with additional functionality. You can also create custom templates and
add them to the Component Library, and add your favorite templates to the
Component Palette.

To create the project:

1 Close any open projects by clicking the Project window, then
choosing Close Project from the File menu.

When you first start Visual Cafe, the last project you opened or an
unnamed project, based on the default project template, appears.
Here you’ll create a new project so you can see how to choose a
template.

2 From the File menu, choose New Project.

The New Project dialog box appears.

Mew Project E

Project Templates:

$ n § B

Emphy Project  JFC Applet Bazic Bazic Win32

Application  GUI Applic... J

* Basic Appletjs ARSI dbénARE
Templat..  Project Wizad

B asic Java applet with blank form.

Ok I Cancel | Set Default | ETE'

3 Select the Basic Applet project template. Then click OK




Creating and naming the project

The Project and Form Designer windows appear.

isual Cafe - Untitled1

Fie Edt View Seach Project Inseit Took Layout Object Window Help
O|=E] 2] 22| wekssce: [ ‘ === IIIEII| = G ‘
NEEREEEEEEEEEEE | 15 =i e R = ]E g I__H
EI Standard | Utiity | Mulimedia | dh/ARE | dhANYWHERE | Additional | Panel | Shape | JDBC
For Help, press F1 | [NOM |
2 Pioject - Untitled1 !EIB{ Appleﬂ Form Designer = B || Propenty List - Appletl (O]
m— Ciiiii. it ; et -
) e Background O whie
- Bounds
..... w [1]
Y 0
Width 485
..... Height 277
Class |ava.applet.Applet
Cursor DEFAULT_CURSOR
Enabled tiue
= Font
Mame Dialog
Size 12
= Style
G Objects [181 Packages [ B Fles | [C0 0o iooooroornnno Bod e
Italic false
Foreground M black
Inherit Backaround | true
Inerit Font | tue
Inhert Foreground | ue
None
Mame Applet]
Visible true

4 Click the Project window, then choose Save As from the File
menu.

The Save As dialog box appears.
Save As HE

Save Ia Projects j gl IE

File name: IUntitIed'I wEp Save I
Save as lype: IVisuaI Cafe Project [* vep] j Canzel |

5 Create a new directory structutre in the Visual Cafe directory, such

as \MyApps\Applet |, to hold your applet files.

The project and all of the files contained within it should be in the
same directory. For easier project management and to prevent
filename conflicts, you should save each project in its own directory.

6 Type MylslePg.vep in the File name field, then click Save.
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The new name appears in the titlebar of the Project window. Visual
Cafe Project files have a .vep extension.

The first ime you save a project, all of the files it contains are also
saved to the new directory. After you save it once, saving just the
project does not save other files, such as applets. Save All does save
all files.

Creating the island map applet

To create the applet, you work through the following tasks:

“Gathering the files you need”

“Setting the applet properties and adding the map”
“Adding the HTML links”

“Adding the volcano eruption animation”

“Running the applet”

Gathering the files you need

4-4

To construct your Web page, you need an HTML file that your applet will
run within and the graphics files that your applet uses. You will copy an
HTML file into your project directory. You will copy the graphics files into
an Images subditrectory.

Visual Cafe lets you specify URLs that are relative to the applet directory.

That way you can move your directory to another location and avoid the

problems associated with hardcoded file specifications.

To copy the files by using the Windows 95 or NT operating system
commands:

1

Copy lIsle.html from the \Toun\Applet directoty to your
project directory.

Create an Images directory in your project directory.

Copy these files from the \Tour\Applet\Images directory to
youtr new Images directory:

* Bungbusi.gif
=  Erupt0l.gif through Eruptl6.gif



Creating the island map applet

= Goall.gif

= Goall2.gif

= Map.gif

= Moderna.gif
= Photo_1.gif
= Simerili.gif

* Venduca.qgif

through Photo_8.gif

Setting the applet properties and adding the map

To start, you need to customize the properties of your form. Then you can

add a picture of the island to the form.

To customize the properties of the form:

1

2

In the Property List, for Appletl, set the Name property to Map
and the Inherit Background, Inherit Font, and Inherit Foreground

properties to false.

When you are finished, the Property List will look like this:

& Property List - Map

I Map vI

Background [ white
=~ Bounds
..... k4 N
..... N 0
----- ‘wiidth 394
----- Height 266
Clazs java.applet.Applet
Cursor DEFAULT_CURSOR
Enabled true
= Font
Dialog
12
falze
falze
Foreground W black
Inkent Background |falze
Inherit Font falze
Inhent Foreground | falee

La

Wizibla

Wone

In the Component Palette, click the Multimedia tab, then click

ImageViewer.

4.5



Chapter 4: Creating an Applet for the Web Page

ToolTips shows you which button is for the ImageViewer
component. Move the cursor over a button until a pop-up message
appears.

Draw a rectangle (about as latge as the island map) on the applet

form by clicking and dragging the cursor.

Map - Form Designer _ O] <]

You can make the Form Designer window bigger by dragging the
right side or bottom of the window. The components are
positioned on the window relative to the top and left sides, so this
spacing remains the same unless you move the components in the
window.

The component you just added to the applet appears in the Project
window.

i1 Project - MylslePg VEP =] E3
M ame |
=[] Map

[#] imageviewertd ap

Ty Objects I [y Packages I Files |

While the component is selected on the form, the Property List
displays the properties of this component.



Creating the island map applet

5 In the Property List, change the Name property to
imageViewerMap.

6 Double-click the Image URL property.
The Image URL dialog box appears.
Image URL

Image Files:

| -
ak. I Cancel |

7 Click the ... button.
The Add Image Files dialog box appears.

8 Navigate to your Images directory, select Map.gif , then click
Open.
The complete path appears in the Image URL dialog box.
9 Delete the first part of the URL so the only path remaining is
Images/Map.gif
Image URL

Image Files:

IImages!Map.gif J
(]9 I Cancel |

This creates the relative URL.
10 Click OK
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11

The map appears in the Form Designer.

Map - Form Designer =] &

...........................................

Click a
location name
Jor more information

Resize the form and the component as needed, so you can see the
entire image.

When a component is selected and you move the cursor over a
square (called a handle) on the edge of a component, the cursor
changes to a two-way arrow, which means you can click and drag to
resize the component.

+—

When a component is selected and you move the cursor over it, the
cursor changes to a four-way arrow, which means you can click and
drag the component to another location.

F S

AR

-

The Form Designer window size represents the applet size. So when
you run the applet, it will appear the same size as the window.

Click the Project or Form Designer window, then choose Save All
from the File menu.

The project and all included files are saved.

Adding the HTML links

Visual Cafe lets you specify clickable areas on the map by drawing
Invisible HTMILink components on it. These areas are associated with a

location in an HTML file, so when the applet runs clicking the area will
cause a jump to another location.



Creating the island map applet

To add the InvisibleHTMLLink components:

1 In the Component Palette, click Additional, then click
Invisible HTMI Link.

2 Draw the component over the image, by clicking and dragging, so
it contains the word Bungbusi and the location on the map.

Map - Form Designer =] &3

SIMERILIA

Click a
location name
Jor more information

3 In the Property List, change the Name property to
invisible HTMILinkB.

4 In the Property List, double-click the HTML Link URL property.
The HTML Link URL dialog box appears.
5 Type Isle.html#Bungbusi in the dialog box, then click OK.

6 Add InvisibleHTMILink components for the remaining three
locations. Use the following values for the Name and HTML Link
URL properties:

* Venduca — invisible HTMILinkV and Isle.html#Venduca
* Simerilia — invisible HTMILinkS and Isle.html#Simerilia
* Moderna — invisible HTMILinkM and Isle.html#Moderna

7 Click the Project or Form Designer window, then choose Save All
from the File menu.

Now you can add the final component to the applet: an eruption
animation.
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Adding the volcano eruption animation

The volcano eruption is an added feature of the island map that should
attract attention.

To create the volcano eruption animation:

1 Select the island map on the form, then choose Send to Back from
the Iayout menu.

This puts the InvisibleHTMILinks on top of the image. When you add
components to a form, they are added after other components in the
Project window. The order of components in the Project window
determines how components overlap. After you choose Send to
Back, the ImageViewer changes position in the Project window,
indicating that it is now underneath the other components on the
form.

2 Resize the form and move the components as needed so you can
put the animation above the map.

Shift-click the image and each of the links, then drag to move them.
El 3 On the Component Palette, click Multimedia, then click Animator.
Draw a rectangle (about as large as the eruption) on the applet

form by clicking and dragging the cursor.

Map - Form Designer H=] B3

Click a

location name
Jor more information

VENDUCA
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5 In the Property List, set the Name property to animatorErupt.

6 In the Property List, double-click the URL List property of the
Animator component.

The URL List dialog box appears.

URL List [x]

Image Files

7 Click Add, select the Erupt01.gif file in the File dialog box,
then click Open.

A dialog box, asking if you want to add the files Erupt*.gif
appears.

8 C(lick Yes to add the sequence of files.
The files appear in the URL List dialog box.

5

9 For each file specification, double-click the row then remove the
first part of each file specification up to the Images directory.

URL List <]

Image Files - | “HE I
Imagesferupt01.gif

Imageserupt02.gif Cancel |
Imageserupt03.qif

Imageserupt04.gif Add... |
Imageserupt05.gif

Images/erupt0E.gif Bemove |
Imageserupt(07.gif

Imageserupt08.qif EI il
Images/erupt03.gif L

Images/erupt10.gif
Images/erupt11.gif
Images/erupt] 2. gif
Images/erupt] 3. gif LI

10 Click OK to close the dialog box.



Chapter 4: Creating an Applet for the Web Page

An animation picture appears in the Form Designer.

Map - Form Designer

VENDUCA

SIMERILIA

Click a
location name
Jor more information

Set the Preview Component in the Property list to true to view the

animation.

11 Resize the Animator component as needed. Move the component
until it’s positioned where you want it in the applet.

12 Set the Preview Component to false.

13 Click the Project or Form Designer window, then choose Save All

from the File menu.

You have completed the animation and the applet, so you can close the
Form Designer.

Running the applet

The integrated Applet Viewer enables you to view and test your working
Java applets within the Visual Cafe environment. Now that you’ve created
your applet, you can compile it and look at it while it’s running.

To run the applet:

1 From the Project menu, choose Execute.
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The applet appears in the Applet Viewer. Visual Cafe saves your
source code and compiles your applet before displaying it.

E_%Applel Yiewer: Map_class M=l B3
Applet

VENDUCA

SIMERILIA

B s Bunglivsi

Click a
location name
Jor more information

M

When you choose Execute from the Project menu, the Visual Cafe
bytecode compiler creates machine-independent bytecode
instructions. Then the Symantec Just-In-Time (JIT) compiler translates
these instructions into native machine instructions, which Visual Cafe
runs for you. The machine instructions are stored temporarily in
memory — no native executable is generated.

Visual Cafe’s native bytecode compiler currently builds Java programs
several times faster than the standard Sun Java compiler. The
compiler also provides improved code optimizations and shows
detailed error information in the Messages window. You can double-
click an error message in this window to go to the line in the code
where the error was generated.

The enhanced JIT compiler has superior execution speed, too. To
start, it provides immediate applet and application execution by
converting bytecodes on-the-fly to native code as needed. When
compilation is complete, the JIT compiler seamlessly starts executing
the native code.

From the Applet menu, choose Quit.

The Applet Viewer window closes.
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Displaying the applet in a Web page

Adding the

4-14

To test your applet, you need to view itin a Web page. This is the only
way to try your HTML links. You will work through the following
procedures to do so:

* “Adding the HTML file to the project”
* “Adding the applet tag to the HTML file”

*  “Executing the applet within the Web page”

Note: To be able to run your applet in a Web browser, your default Web
browser must support JDK 1.1.5.

HTML file to the project

You can add HTML files to your project as an organizational tool, but it
isn’t required to run an applet in a Web page. Visual Cafe lets you create
HTML files in the Source window, or you can import existing HTML files
into a project. You already have your HIML file, so you can just add it.

To add the HTML file to the project:

1 From the Insert menu, choose Files into Project.



Displaying the applet in a Web page

2

The Project Files dialog box appears.

Project Files

Laak jn: IEADDH j gl &

] Images
(3] Isle.html

File: name: I jul I
Filez of type: INet Files [* html;®. htm;".gif;".ipg;".ipeg;*.au;*.[j Cancel
Filez in Project: Add |

CWWizualCafedbDEST ourb ap.java

Add all |
Hemoye |

4] J I

In the Project Files dialog box, select Isle.html in your project

directory, then click Add.

The file appears in the Files in Project list.
Click OK to add the file to the project.
The file appears in the Project window.

= Project - MylslePg VEP M=l E3

MHame |
Map

imagetiewertdap

invisibleHT MLLinkE
invizibleH T MLLinkV

invizibleHT MLLinkS

‘& invisibleHTMLLinkM

oL animatorE rupt

Eaf <l-

Gy Objects | 5 Packages | Files I
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Adding the applet tag to the HTML file

Now you’re ready to add the applet you created in Visual Cafe to the
HTML file.

To add the applet to the HTML file:

1 Iook atlIsle.html by clicking the Files tab in the Project
window, then double-clicking Isle.html

The Source Editor appearts. It contains the contents of Isle.html
You can edit the code in this window.

B c:\WisualCafe\MyApps\Applet\lsle htm M=l E3
Objects; I j Ewvents/Methods: I |-
|< 'DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2/ /EN"> ﬂ
<HTHML>
<HEAD=

<META HTTP-EQUIV="Content-Type” CONTENT="text/html;CHA
<TITLEr3vmantec Visual Café Tutorial - Island Map and
«</HEAD >

<BODT Background = "Images/GOALL.GIF™ TEXT="#000000" BGCOL

<Pr<IMG IRC="Images,/GOLLLZ .gif™ EORDER = 0 ALIGH="LEFT™ H
USEMAP="#GOLLLZ™ ISMAP:</F>

<UL>

T AT TEM=MCFRMTRD M s aDDT BT FOBT =M Tm 1 mWman 1 mme . ITHTH—F

| | 3

|M0d | | |Line1 |EOI'I

2 Find the following applet tag in the file:

<APPLET CODE="IsleMap.class" ARCHIVE="tour.jar”
WIDTH=594 HEIGHT=349 ALIGN=center>
<blockquote>

<hr>

If you were using a Java-enabled browser, you would
see an island map and volcano eruption instead of
this paragraph.
<hr>
</blockquote>

</APPLET>

This tag causes the applet to run within the Web page. If the browser
isn’t Java-enabled, the text displays instead.
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Whenever you create an HTML document and want to include an
applet, you need to add an applet tag.

3 Change the name IsleMap.class to Map.class . If the applet
tag contains the ARCHIVE="tour jar” variable and value, remove
it.

4 If different, change the width and height in the applet tag so it
matches the width and height in the Property List for your Map
applet.

5 Close the Source window, and save changes.

Executing the applet within the Web page

Visual Cafe lets you run the applet directly within the Web page by using
Visual Page or your default Web browser. The advantage of using Visual
Page is you can also modify your HIML files as needed.

To open your Web page in Visual Page:

1 In the Objects view of the Project window, double-click
Isle.html

If you have properly installed Visual Page from the Visual Cafe CD,
Visual Page starts and displays your Web page.

B VisualPage - [Isle_html] M=l 1
@Elle Edit Wiew |nset Stle Fomat Frame ‘window Help NETET

MEENa N E = =N
r— A =

1, Home Page
" and Slide
Show

Island Map b

and Information

Client @

Comments

Custom and
L~ Package
=l
Link te: I |
Far Help. press F1 [ [NumM] V

2 From the View menu, choose Preview.

The applet runs in Visual Page.
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3 Tty outyour applet.

Note: Some browsers use a different z-order when determining
how components overlap in an applet. When run in a browser, the
Invisible HTMI Link must be on top for users to be able to click it.
To ensure compatibility with different browsers, it is a good idea
to “sandwich” Invisible HTMILinks on top and beneath the image
they overlap. For now, if you are unable to use the
Invisible HTMI Links, close the Web page, select the island map on
the form, then choose Send to Back from the Layout menu and
view the Web page in Visual Page again.

Exit Visual Page.

The window closes.

If your applet works properly in Visual Page, you have completed the
applet. Continue with the next chapter to create the Custom Itinerary
application.



C HAPTER

Creating the Application
and Debugging Code

This chapter builds on the previous chapter. It introduces you to some
advanced features that you may want to use particularly if you have more
programming experience and want to take advantage of all the diverse
capabilities of Visual Cafe. In this chapter, you create the custom itinerary
application that your clients can use to view their custom tour itineraries.
You also try some of Visual Cafe’s debugging features.

Note: The Tour is designed to be used in SDI mode. Make sure the MDI
Development Environment checkbox is de-selected on the General tab of
the Environment Options dialog box.

Creating the itinerary application

To create the itinerary application, work through the following tasks:
*  “Opening and naming the new project”
*  “Gathering the files you need”

*  “Setting the properties of Framel and adding the SlideShow
component”

* “Adding the Button components to the frame”
*  “Adding the Amazing Adventures Travel logo”

*  “Adding the labels”
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. “Specifying component interactions”
g

* “Adding custom Java code”

*  “Customizing the menu bar”

*  “Customizing the About dialog box”

*  “Customizing the Quit dialog box”

*  “Running the application”

Opening and naming the new project

You should create a separate project for your application and save it in its

own directory.

To create the new project:

1 Close any open projects.

2 From the File menu, choose New Project.

The New Project dialog box appears.

3 Select the Basic Application project template, then click OK

The Project and Form Designer windows appear.

S Visual Cafe - Untitled1

File Edit “iew Sesrch Project Insert Tool Layout Object Window Help

MEENEEEER

Warkspace: |Edt e ‘ ][ |E| SIS

Bl

EEEEEREEEEEEE

5| Standard | Utiity | Mulimedia | ab&wARE | dbaNvWHERE | Additional | Parel | Shape | JDBC

El=mn ==z mEE ]

For Help, press F1

Project - Untitled] 1 =

Hame |
[ Framel

5 Shwiitislog

-5 QuitDizlog

rame1 - Form Designer

G Objects | [ Packages | B F\\Esl

| wum
] Framel =
Backaround [ white
=- Bounds
..... E ]
..... 5 0
“width 485
----- Height 305
Class java.awt Frame
Cursor DEFAULT_CURSOR
Enabled tue
=- Fant
----- MName Dialog
Size 12
= Style
- Bold falze
Italic false
Foreground I black
Inherit Background |tue

Inherit Fort

|tue

Narme

Inherit Foreground | true

None
Framel

Resizahle

true

Title

& Basic Application

Wisible

false
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A standard application project contains a Java frame (a special kind of
window) with a predefined menu bar, an About dialog box, and a
Quit dialog box. Two objects already included in Framel are
mainMenuBar and openFileDialog1, which are represented by icons
on the Form Designer. If you select an icon on the Form Designer, it
is identified in the Property List.

Double-click the Form Designer.
The Source Editor appears.
From the Search menu, choose Find.

The Find dialog box appears.

Find %]
| = = |
Previous
[ Match case
[ Match whole words only ﬂl

[~ Reqular expression

Type void main | then click Next.

The word is highlighted in the Java code. When you use the frame in
the application template, it’s already set to be the main application
window. If you do not use the frame in the template, you need to
add the main and show methods to your main application window.

Close the Source Editor.

Click the Project window, then choose Save As from the File
menu.

The Save As dialog box appears.

Create a new directory structure, such as
\MyApps\Application , to hold your application files.

The project and all of the files contained within it should be in the
same directory. For easier project management and to prevent
filename conflicts, you should save each project in its own directory.

Navigate to your project directory, type MylslePr.vep in the File
name field, then click Save.

The new name appears in the titlebar of the Project window, and all
the files in the project are saved to this directory.
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Gathering the files you need

To use relative URLs, you will store your graphics files in a directory
subordinate to the project directory.

To gather and store the graphics files:

1 Using Windows operating system commands, copy the
\Tour\Application\Images directory.

2 Paste the directory in your project directotry.
The Images directory contains the following files:
Logo.gif
Photo_1.gif through Photo_8.gif
Tour.dat

Setting the properties of Frame1 and adding the SlideShow
component

The user interface of your application can be put together quickly with the
SlideShow component, which associates a picture with text and allows you
to navigate through sequential photos with button clicks.

To add the SlideShow component to the frame and set its properties:

1 Set the Framel properties, including Name, Title, and Inherit
Background, Inherit Font, and Inherit Foreground, so it appears as

follows:
&' Property List - FrameM ain
I E Frametd ain - I
B ackground [ white
- Bounds [0, 0, 405, 305]
Clazz jawa. awt Frame
Cursar DEFAULT_CURSOR
Enabled true
- Font [Dialog, 12, Bold]
Foreground W black
Inhent Background | Falze
Inherit Font falze
Inhent Foreground | False
Layout Mone
MHame Frarmetd ain
Resizable true
N i 2 dventures Travel - Custom tinerary Application
Yizible true
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2 On the Component Palette, click Multimedia, then click SlideShow.
=]

ToolTips shows you which button is for the SlideShow component.
Move the cursor over a button until a pop-up message appears.

3 Draw a rectangle (about as large as the photos) on the form by

clicking and dragging the cursor.

FrameM ain - Form Designer =] &3

While the component is selected on the form, the Property List
displays the properties of this component. The Project window shows
the new component.

] Project - MylslePr.VEP [ [O]x]

Marne |

openFileDialogl
mainkd enub ar
zhideShow
+-[=) AboutDialog

- [=) QuitDialog

Gy Objects | 5 Packages | Files I

4 In the Property List, change the Name property to
slideShowItinerary.

5 Resize the slide show until it’s approximately 340 pixels in width
by 235 pixels in height by typing in the Property List.
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6 In the Property List, double-click the URL List property of the
SlideShow component.

The URL List dialog box appears. Normally, you would enter photo
names and text descriptions here, but for your application you will
read in a file that sets these properties at runtime.

URL List

Image Files [escription n}

Cancel

(i

Bemaove

7 Click Cancel.

8 Click the Project or Form Designer window, then choose Save All
from the File menu.

Adding the Button components to the frame

5-6

The slide show is controlled by button clicks. You need to add the buttons
and set their properties.

To add the button components:

1 Resize the Form Designer window so two buttons can fit under the
SlideShow component. Move the component until it’s positioned
where you want it in the frame.

You can make the Form Designer window bigger by dragging the
right side or bottom of the window. The components are positioned
on the window relative to the top and left sides, so this spacing
remains the same unless you move the components in the window.

The Form Designer window size represents the Java frame container
size. The frame size is the same as the window size. So when you run
the application, it will appear the same size as the window.

|:l 2 While the Form Designer is the active window, click the Standard
tab on the Component Palette, then click Button.
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3 Draw a button under the SlideShow component by clicking and
dragging.

FrameM ain - Form Designer Hi=] E3

4 To copy and paste this button, select the button and choose Copy
from the Edit menu, then choose Paste from the Edit menu. You
can also choose these menu items from the pop-up menu that
appears when you right-click.

A second button appears.

5 DPosition the buttons under the SlideShow component as follows:

FrameM ain - Form Designer =] B3

6 Seclect the button on the left, then set the following propetties:
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* Name — buttonPrevious
* Jabel — Previous

* Visible — false (because you don’t want the button to appear
until you load a data file)

7 Seclect the button on the right, then set the following properties:
* Name — buttonNext
* Iabel — Next
* Visible — false

The buttons now both have names.

FrameM ain - Form Dezigner O] x]

8 Click the Project or Form Designer window, then choose Save All
from the File menu.

Adding the Amazing Adventures Travel logo

5-8

Now you can add your company logo.

To add the Amazing Adventures Travel logo:

1 In the Property List, resize FrameMain to 600 pixels in width and
530 pixels in height.

The form size changes. If you have a small screen, you can make
FrameMain smaller.

2 Shift-click the SlideShow component, then each button, to select
them.
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3 Drag the components to the bottom tight cotner of the form.

4 In the Component Palette, click Multimedia, then click
ImageViewer.

5 On the form, draw a rectangle above the SlideShow component (a
little less wide than the slide show) by clicking and dragging the
cufrsot.

6 In the Property List, change the Name property to
imageViewerlogo.

7 Double-click the URL property.
The URL dialog box appears.
8 Click the ... button.
The Add Image Files dialog box appears.

9 Navigate to your Images directory, select L0go.gif | then click
Open.

10 To ctreate a relative URL delete the file specification so it displays
just Images/Logo.gif . Then click OKin the URL dialog box.

The logo appears in the Form Designer.

FrameMain - Form Designer Mi=] E3

11 Click the Project or Form Designer window, then choose Save All

from the File menu.

Adding the labels

Your application displays text, so you need to add text fields to the form.
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To add the text field components:

o 1 In the Component Palette, click the Additional tab, then click
- Wrappinglabel.

2 Draw a text box to the left of the SlideShow component.

The dimensions can be about 240 pixels in width by 265 pixels in
height.

You can choose Grid Options from the Iayout menu to turn Snap to
Grid on or off.

3 In the Property List, set the following properties:
* Name — wrappinglabelDesc
* Font Size — 14
* Font Style Bold — false
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tj| 4 To the left of the picture, draw two Wrappinglabel components
= and underneath a Iabel component (in the Standard tab of the
Component Palette) as shown.

FrameMain - Form Designer =] E3

5 In the Property List, set the properties of the top Wrappinglabel
component as follows:

(To display the properties in the Property List for this component,
either select the component on the form or choose it from the drop-
down list in the Property List window.)

Name — wrappinglabelTop

Font Size — 16

Font Style Bold — true

Text Alignment — ALIGN_CENTERED

Text — Custom Itinerary for

6 Set the properties of the middle Wrappinglabel component as

follows:

Name — wrappinglabelPeople

Font Size — 24

Font Style Bold — true

Text Alignment — ALIGN_CENTERED

7 Sect the properties of the Iabel component as follows:

Name — labelDay
Font Size — 16
Font Style Bold — false
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* Font Style Italic — true
* Alignment — CENTER
Also, delete the text in the Text field.
%l 8 Now draw a Wrappinglabel component over the top two labels as

follows:

FrameMain - Form Designer =] 3

Custom Itinerary for

9 Set the propertes of the new Wrappinglabel component as
follows:

* Name — wrappinglabelStart
* Font Size — 16
* Font Style Bold — true

* Text — To start, choose Open from the File menu and open
your data file. Your .dat file and the graphics files must be in
the same directory.

10 Select wrappinglabelStart on the Form Designer, then choose
Bring to Front from the Iayout menu.

This ensures that the label is on top of the other labels. Because the
labels overlap, an easy way to select wrappinglabelStart is to choose
it from the Property List drop-down menu.

11 Click the Project or Form Designer window, then choose Save All
from the File menu.

Specifying component interactions
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One of the most powerful features of Visual Cafe is the ability to create
interactions between components. The Interaction Wizard lets you
graphically build relationships between components, or between a
component and itself (for example, double-clicking an item in a list box
could remove the item from the list box and add it to another list box).
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These relationships specify the actions to take when an event is triggered
on a component. For example, in a slide show, a button click could cause
the next photo to be displayed. Visual Cafe automatically generates the
necessary Java code for the specified relationship.

In the following sections, you specify interactions between components on
the application form:

*  “Setting up the Previous button to display the previous image”

*  “Setting up the Next button to display the next image”

* ‘“Disabling the Next button at the end of the slide show”

* “Disabling the Previous button at the start of the slide show”

*  “Making the slide show descriptions appear in the wrapping labels”

*  “Setting the Day label”

Setting up the Previous button to display the previous image

Here you set up an interaction between the Previous button and the
SlideShow component so that a button click causes the previous image to

be displayed.

To set up the Previous button to display the previous image:

_.:l 1 Click the Interaction Wizard button, then click the Previous button
— . .
and drag a line to the SlideShow component.

Previous

5-13



Chapter 5: Creating the Application and Debugging Code

5-14

The Interaction Wizard appears.

Interaction Wizard

77 When

What

happens fo
what

Start an interaction for “buttonPrevious™. .

componentHidden
componentidoved
componentR esized ;l

Select the item pou want to interact with...

I slideShowltinerary j

Chooze what you want to happen...

Dizable the SlideShow “
Dizable the SlideShaw on condition....

Enable the SlideShaw

H deShow

Inwalidate the SlideShow

M ove focus to the nest component

Repaint the ShideShow

Fequest the focus LI

< Back I Finizh I Cancel | Help

2 Select the following items:

= Start an interaction for ‘buttonPrevious™ ActionPerformed

* Select the item you want to interact with: slideShowItinerary

* Choose what you want to happen: Go to the SlideShow’s

previous image

3 Click Finish.

Setting up the Next button to display the next image

Here you setup an interaction between the Next button and the SlideShow
component so a button click causes the next image to be displayed.

To set up the Next button to display the next image:

_..=| 1 Click the Interaction Wizard button, then click the Next button and
— . .
drag a line to the SlideShow component.

The Interaction Wizard appears.

2  Sclect the following items:

* Start an interaction for ‘buttonNext’> ActionPerformed

* Select the item you want to interact with: slideShowItinerary
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* Choose what you want to happen: Go to the SlideShow’s next
image

3 Click Finish.

Disabling the Next button at the end of the slide show

When you’re at the last picture, you want to indicate that by disabling the
Next button.

To disable the Next button at the end of the slide show:

—x 1 Click the Interaction Wizard button, then click the SlideShow
component and drag a line to the Next button.

The Interaction Wizard appears.

2 Sclect the following items:
* Start an interaction for “slideShowItinerary” SlideChanged
* Select the item you want to interact with: buttonNext

* Choose what you want to happen: Disable the Button on

condition
3 Click Next.

The second page wizard appears.

Interaction Wizard

Dizable the Button on condition uzing infarmation fran. ..

‘-" Hnw & Anather item
iE sn[mm shideShowltineran j

hl]l}BEIl By... _
| at the first image?
|z at the last image?
|s enabled?
|5 mot enabled?

|3 hiot showing?

|z hot walid? ;I

4 boolean constant or an expression

A variable or parameter
I fCarmpaonentzddjusted j

< Back I Finizh I Cancel Help |
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4 While Another item is selected, choose slideShowltinerary and

5

select Is at the last image?

Click Finish.

Disabling the Previous button at the start of the slide show

When you’re at the first picture, you want to indicate that by disabling the

Previous button.

To disable the Previous button at the start of the slide show:

1

Click the Interaction Wizard button, then click the SlideShow
component and drag a line to the Previous button.

The Interaction Wizard appears.

Select the following items:

* Start an interaction for “slideShowItinerary” SlideChanged
* Select the item you want to interact with: buttonPrevious

* Choose what you want to happen: Disable the Button on
condition

Click Next.
The second page of the wizard appears.

While Another item is selected, choose slideShowlItinerary and
select Is at the first image?

Click Finish.

Click the Project or Form Designer window, then choose Save All
from the File menu.

Making the slide show descriptions appear in the wrapping
labels

You need to set up an interaction between the SlideShow component and
a Wrappinglabel component so the descriptive text associated with a
picture displays in the text field.

To make the slide show descriptions appear in the wrapping labels:

El 1

Click the Interaction Wizard button, then click the SlideShow
component and drag a line to the wrappinglabelDesc component.

The Interaction Wizard appears.
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Select the following items:
* Start an interaction for “slideShowltinerary”: SlideChanged
* Select the item you want to interact with: wrappinglabelDesc

* Choose what you want to happen: Set the text for this
Wrappinglabel

Click Next.
The second page of the wizard appears.

While Another item is selected, choose slideShowItinerary and
select Get current description.

Click Finish.

Setting the Day label

Now you’ll set up the incrementing and decrementing Day field.

To set up the Day label:

1

Click the Interaction Wizard button, then click the Next button and
drag a line to the labelDay component.

The Interaction Wizard appears.

Select the following items:

* Start an interaction for “buttonNext™ ActionPerformed
* Select the item you want to interact with: labelDay

* Choose what you want to happen: Set the text for Iabel
Click Next.

The second page of the wizard appears.

Select A String constant or an expression.

Deselect Add quotes.

Type this expression (don’t forget the blank spaces):
"Day " + (++dayCount)

Click Finish.

Click the Interaction Wizard button, then click the Previous button
and drag a line to the labelDay component.

The Interaction Wizard appears.
Select the following items:

* Start an interaction for ‘buttonPrevious’ ActionPerformed
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10

11
12
13

14
15

* Select the item you want to interact with: labelDay

* Choose what you want to happen: Set the text for Iabel
Click Next.

The second page of the wizard appears.

Select A String constant or an expression.

Deselect Add quotes.

Type this expression:

"Day " + (--dayCount)

Click Finish.

Click the Project or Form Designer window, then choose Save All
from the File menu.

Now it’s time to add the custom code. You can close the Form Designer if

you want.

Adding custom Java code

5-18

You can add custom Java code to a project, including complete applets and
applications. If the code contains visual aspects, Visual Cafe translates the

code into a visual representation that’s displayed in the Form Designer.

Visual Cafe has many features to assist you with creating new Java code.

For example, the Source Editor can help you when you want to handle an
event for a component. From the Source Editor, you can select a

component from the Object drop-down list, then select the event you want
to handle from the Events/Methods drop-down list. When you do this,
Visual Cafe creates a method for that event and puts a call to that method
in the event handler. You fill in the body of the method.

Now that Visual Cafe has created the main portion of your program, you

can add custom code to read data from a file at runtime and to increment
the Day label.
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The data file is a text file in the following format:

client names
number_of pictures
picturel _filename
picturel _text
picture2_filename
picture2_text

Here's an easy way to add the code:

1 Choose Open from the File menu, and open
\TounApplication\AmazingTour.java
The file appears in the Source Editor. The custom code is identified
by comments directly in the code.

2 In the Project window, click FrameMain, then right-click. Choose
Edit Source from the pop-up menu.

FrameMain.java appears in another Source Editor.

3 Copy the custom code from AmazingTour.java into your
application.

You can search for the words “Custom code” in

AmazingTour.java  to find the code quickly. There are eight
places where you need to copy the code. Make sure you insert the
code into your application directly under the same line that appeared
above it in AmazingTour.java

4 When you’re finished, click the FrameMain Source Editor and
choose Save All. Then close the Source Editors.

Customizing the menu bar

When you use the Create Project wizard to create a Java application, Visual
Cafe adds a set of menus and menu items that are frequently used in
applications. For this application, you will use only a small subset of the
default menus.
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To modify the default menu bar in the application:

1 In the Project window, display the contents of mainMenuBar
(subordinate to FrameMain) by clicking the +.

5 Pioject - MylslePr.VEP M=l B3

Marne |

slideShowl
-[=] AboutDislog
-[=] QuitDialog

Gy Objects I [ Packages I Files |

2 In the Project window, select the Edit menu component and delete
it.

3 In the Project window, display the contents of the File menu, then
delete New, Save, and SaveAs.

4 Click the Project window, then choose Save All from the File
menu.

Customizing the About dialog box

The About dialog box is included as part of the application template.

To modify the About dialog box:
1 Double-click the AboutDialog object in your project.
The Form Designer appears.
2 Change the properties as follows:
* Inherit Font — false
* Inherit Background — false
* Inherit Foreground — false

3 Click the ILabel component in the Form Designer.
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4

7

In the Property List, click the Text property value to highlight it,
then type Amazing Adventures Travel - Custom Itinerary
Application.

The text appears in the Iabel.

Click the Form Designer, then resize and reposition the label,
button, and form as needed.

AboutDialog - Form Designer [_ (O] x|

Amazing Adventures Travel - Custom Itinerary Application
114 |

Click the Project or Form Designer window, then choose Save All
from the File menu.

The About dialog box is saved in the project.
Close the Form Designer for the About dialog box.

Customizing the Quit dialog box

The Quit dialog box is also included as part of the application project
template.

To modify the Quit dialog box:

1

Double-click the QuitDialog object in your project.
The Form Designer appears.

Change the properties as follows:

* Inherit Font — false

* Inherit Background — false

* Inherit Foreground — false

Click the Project or Form Designer window, then choose Save All
from the File menu.

The Quit dialog box is saved in the project.

Close the Form Designer for the Quit dialog box.

Running the application

Now that you’ve specified the user interface and other aspects of your
application, you’re ready to run it.
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To run the application from within Visual Cafe:
1 From the Window menu, choose Messages.
The Messages window appeats.

2 From the Project menu, choose Execute.

Visual Cafe compiles your application before displaying it. Any
warning or error messages appear in the Messages window.

Messages =
3 -make -cdb MulzlePr edb -g -classpath C:\WisualCafe'Mydppsidp

4] I i
| | |

You can double-click an error message in this window to go to the
line in the code where the error was generated.

Println statements and certain errors might be displayed in a java
(command prompt) window.

Then the application appears.

Egghmazing Adventures Travel - Custom ltinerary Application

File Help

To start, choose Open from
the File menu and open
your data file. Your .dat file
and the graphics files must
be in the same directory.
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3 Open the data file in the Images directory, and click the Next and
Previous buttons to verify your application works as planned.

E%%Amazing Adventurez Travel - Custom ltinerary Application
File Help

Custom Itinerary for

Stan and Flora
Robinson

Liay ¥

Arrive this morning in lsle de Café, at
the tropical paradise of Bungbusi.
Check in to your deluxe seaside
resot, then enjay the pristine
heaches just outside your door. The
sand beaches and warm waters are
ideal for relaxing and for all kinds of
water spons, including surfing, water
skiing, and snorkeling, included atno
additional charge. The reson
gardens, three pools, gourmet
restaurants. open-air lounge with local
entertainers, and swim-up bar are at
wour disposal. Now is the time to let
the stresses fade atlsle de Cafe.

Previous Next

4 Close the application.

5 Make adjustments in the Form Designer as needed. Then execute
the application again. Repeat until the application looks the way
you want it.

If the application works as planned, you have completed it.
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Looking at the application in the Hierarchy Editor

and Class Browser

Visual Cafe has special object programming tools that make it easy to
understand and manage Java classes. Let’s take a look at your application

in the Hierarchy Editor and Class Browser.

5.24

To look at the application in the Hierarchy Editor and Class Browser:

1

While your application project is open, choose Hierarchy Editor
from the View menu.

Your application appears in the Hierarchy Editor.

BB Hierarchy Editor HEE |
java st Compenent ——iava. swt Container —— java awt Window T [AboutDialon
AboutDialog Action
[ fvaourtevertdotivi i FrameMain.Action
QuitDialog Action
[ v st vom it it |AbouDialogwindon
java.awt event Windowddapter <| Frametain. Window
| QuitDialog Window
| 2

The Hierarchy Editor lets you visually learn, modify, and extend the
Java class hierarchy for an applet or application. Drag and drop to
instantly edit the hierarchy structure — both the visual model and the
source code.

2 Right-click, then choose View Imports from the pop-up menu.
The Hierarchy Editor now shows all Java classes.
3 In the Hierarchy Editot, double-click a class to navigate to a class

definition in the Class Browser. Then select a member in the upper
right list.
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The Class Browser shows the code associated with the class

member.
EH Class Browser M=l E3
Classes Members of Framekd ain
ﬂ -3 Methods ﬂ
~[uitlialog - i About_Action
{58 java.applet & Exit_action
¢ -Applet & Framebain
-ippletContest S ok ain
-AppletStub hd - iy Open_sction ;l
Y
public FrameMaini(String titcle) {
this|():
setTitle (title) ; al
4 3
FrameMain FrameMain [FrameM | [ Line 1 Col 1

The three-pane Class Browser lists the classes in your project, and
shows each method and data member contained within a class, all of
which are individually editable to make you more productive. For
example, when you click a class in the upper left pane, its methods
and data members appear in the upper right pane. When you click a
method, that implementation of the method is extracted from the
source file and displayed in the lower pane where you can edit it.
This makes it easy to navigate to the areas you want to edit — no
matter how large the source file — and reduces the possibility of
accidentally editing code outside the scope of the selected object.

Color syntax highlighting makes your Java source more readable. The
Class Browser also has an incremental search feature when you have
a class selected: as you type the name of a class, the list of matching
objects is refined until you have automatically selected the class you
want.

Visual Cafe reads your Java source code so the Hierarchy Editor and
Class Browser always contain the most up-to-date information.

4 Close the Class Browser and Hierarchy Editor.

Debugging

The integrated graphical debugger provides source-level debugging and
lets you browse data and manipulate calls and threads. You can modify a
variable value and continue debugging without reloading. The Source
Editor shows ValueTips so you can quickly view variable values.
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While debugging, you can either step through each line of source code

one at a time (including sublevel method code, when available) or step

over the execution of method calls, which causes the debugger to execute
all method code then pause on the line following the method call.

The debugger includes the following windows:

Breakpoints window — The breakpoints for the entire project appear
in this window. You can set simple breakpoints that stop execution at
a certain line or method, or conditional breakpoints based on an
expression.

Threads window — You can pause individual threads, which causes
their execution to cease temporarily while all other threads continue to
execute, and resume them. This helps you check for and resolve
thread synchronization errors, where more than one thread is in
contention for the execution of a method. Double-clicking a thread in
this window updates the Calls window, so it reflects the chain of
execution for the thread, and the Variables window, so it reflects the
scoping level of the thread.

Calls window — All code modules and methods executed by a thread,
and the current execution point and return points for each called
method, appear in this window. This view is useful for following the
flow of the code, for example.

Watch window — In this window, you can specify variables and
expressions that you want to watch continuously while debugging
your program. The values update when you pause execution or step
through code. You can also examine the contents of a class member or
variable. To watch all the variables accessible to a method, drag the
variable from the Variables window to the Watch window. To modify a
variable value, you can enter it and continue debugging without
having to stop and restart the debug session.

Variables window — This window incorporates a tree view so you can
collapse and expand the various scopes and makes it easy to examine
the values of both simple and complex data types, such as arrays. It
automatically displays the local and global variables and objects that
are local to the current method, and the variables that are members of
the current object. You can edit variable values.

All of the debugger windows have resizable columns so you can create the
most readable display.
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Visual Cafe also lets you debug an applet or application that’s running on
another computer. One computer displays the debug windows while an
applet or application runs on a remote computer.

Working with the debugger is divided into the following sections:
*  “Debugging the About dialog box”

*  “Debugging the Day label”

Debugging the About dialog box

Although the About dialog box works properly in your application, here
you can explore some debugging features by working with the About
dialog box code.

To debug the About dialog box:

1 While your application project is open, choose Run in Debugger
from the Project menu.

Visual Cafe compiles your program and displays several debugger
windows. Then it displays your application.

5 Visual Cafe - MylslePr_vpj - [Executing]

Ele Edt E‘,;Amazing Adventures Travel - Custom Itinerary Application
D)l Fie Help dDEFEEE

E

% = To start. choose Open
EI _Sta from the File menu and
Buld Suscz. OpeN your data file. Your
- _dat file and the graphics
=

el files must be in the same

Eli directory.

[T

G Obie M=

PR

E
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Note: When your application is running, “Executing” appears in
the titlebar of the Visual Cafe main window. Note that when your
application is paused, it cannot redraw its window, so the
application may pick up the contents of other windows when you
move them.

The Variables, Calls, and Breakpoints windows should be displayed.
If they aren’t, open the window by choosing them from the View
menu.

If it’s not already open, open FrameMain in the Source Editor.
From the View menu, choose Watch.

The Watch window appears. You use the Watch window to display
the value of selected variables.

E Watch =] B3

From the View menu, choose Threads.

The Threads window appears.

ik Threads
I

Ii[=] E3

B U[java.a . b 3l
Al T Wfindows [java lang. Thread)OxeS6dal TRRing
Sereen Updater [sun.awt. Screen pdaler]ﬂxeﬂﬂq cond. waiting

The window shows the standard Java AWT threads and other threads,
including the debugger threads.

In the Source Editor, choose FrameMain in the Objects pull-down
list, then choose miAbout_Action from the Events/Methods pull-
down list.

The miAbout_Action method appears in the window.

Click the line with the show method, right-click, then choose Set
Breakpoint from the pop-up menu.
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10

11

12
13
14

15
16
17

A red diamond indicates a breakpoint was set.

E c:WizualCafe\MyApps'\Application\FrameM ain.java

Ohjects: IE Framehd ain j Events/tethods: | About_Action -

} .
A4 ...up to here.

void About_Action(Event ewvent) {
FAU{CONNECTICH
/¢ Aetion from About Create and show as modsal
- (new AboutDialogi(this, true)).show();

ey =
|

Mod | | | |Line'| 1

Notice the breakpoint in the Breakpoints window.

¥

In your running application, choose About from the Help menu.

The breakpoint is triggered. The Source Editor appears and the
breakpoint line is highlighted. Variables and their values at this point
in the code appear in the Variables window; the current call stack
appears in the Calls window. The titlebar of the Visual Cafe main
window displays [Paused].

From the Debug menu, choose Step Into.

Another Source Editor appears. It displays AboutDialog.java.
From the Debug menu, choose Step Over.

The next call is highlighted.

From the Debug menu, choose Step Out.

You return to the FrameMain.java file.

Right-click the highlighted line and choose Clear Breakpoint from
the pop-up menu.

The breakpoint is removed.

From the Debug menu, choose Continue.

Now you can click OK in the About dialog box.

From the File menu, choose Open, then open Tour.dat
The data appears in the application.

Click the FrameMain Source Editor.

Choose main from the Events/Methods drop-down list.

From the Search menu, choose Find, then search for class

SymAction .
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18

19

20

21

The class appears. Actionlistener receives events such as mouse
clicks and determines which event handler each event goes to.

Set a breakpoint at Object object.

The breakpoint appears.

Click a button in the application window.
The breakpoint is triggered.

The Visual Cafe debugger lets you dynamically set breakpoints while
the program runs for more powerful debugging. A listener or adapter
is a useful place to put a breakpoint, because in the Breakpoints
window you can disable the breakpoint by de-selecting the checkbox
and enable it with a condition for particular types of events.

Clear the breakpoint, then choose Continue from the Debug
menu.

The application appears.
Close the Source Editor displaying AboutDialog.java.

Debugging the Day label

5-30

Continue exploring the debugger with these steps that examine the Day
label code.

To examine the Day label code in the Debugger:

1

If not already open, open the Source Editor for your FrameMain
application.

While the Objects field shows FrameMain, choose
buttonNext_ActionPerformed from the Events/Methods menu.

Under buttonNext_ActionPerformed, you’ll see this method:
slideShowlItinerary.nextlmage. The method is activated when the
Next button is clicked.

Set a breakpoint at nextlmage.
A breakpoint symbol appears next to the code.
In your application window, click the Next button.

The breakpoint is activated. The Source Editor appears with the
breakpoint highlighted.

Took at the variables in the Variables window.

The Variables window shows the variables and their values at this
breakpoint.
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1

12
13

14

15

16

17

18

Click the +next to this.
The variables associated with the object appear.
Type this.day.

The dayCount variable row is highlighted. This is the variable that
sets the Day value.

Drag dayCount from the Variables window to the Watch window.
(Or right-click and choose Evaluate Expression; in the Evaluate
Expression dialog box, click Add Watch.)

dayCount appears in the Watch window. You can drag the variables
you want to watch closely, no matter where they are in the Variables
window hierarchy, to this window.

Drag fileName (under dayCount) to the Watch window.
fileName appears in the Watch window.

Scroll down in the Variables window, and click the + next to
wrappinglabelDesc.

The variables associated with this component appear. You can resize
columns for a mote readable display.

Drag one of the wrappinglabelDesc variables, text, to the Watch
window.

The variable appears in the Watch window.
From the Debug menu, choose Continue.
Click the Next button in the application.

The breakpoint is triggered. The Day and text values change in the
Watch window.

In the Calls window, double-click actionPerformed.

The portion of code called in the action listener appears in the Source

Fditor.
In the Calls window, double-click buttonNext_ActionPerformed.
You return to the original breakpoint position.

De-select the checkbox in the Breakpoints window to deactivate
the breakpoint.

In the Watch window, click the dayCount row, then click the Value
field and change the value to 2 less than its current value.

In the Source Editor, highlight the dayCount variable under the
breakpoint, and leave the cursor there.

ValueTips show that the value has changed.
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19 From the Debug menu, choose Continue.
20 Press the Previous and Next buttons.
Notice what has happened to the Day value in your application.

21 In the Breakpoints window, select the breakpoint checkbox, then
click the Next button in the application.

The breakpoint is triggered.

22 In the Breakpoints window, enter the following in the Condition
field:

dayCount ==
Now the breakpoint triggers only when dayCount is zero.
23 Choose Continue from the Debug menu.

24 Press the Previous and Next buttons until the breakpoint is
triggered.

25 Clear the breakpoint, then choose Stop from the Debug menu.
The debugger windows close.

You have now completed the Visual Cafe tour and learned about many

important Visual Cafe features. Now you’re ready to build your own

applets and applications. For more in-depth information, explore the User’s
Guide and the online help provided with Visual Cafe.
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C HAPTER

Creating Applets with
Database Functionality

This chapter showcases some Visual Cafe database features. Here you
create an online reservation applet that your clients can use to sign up for
your package tours and an administrative applet to keep track of your
reservations. To create your applets, you work through the following tasks:

*  “Creating the online reservations applet”
* ‘“Displaying the applet in a Web page”
*  “Creating an administrative applet for online reservations”

Before beginning, make sure you have installed and started the
dbANYWHERE Server and the database engine as described in “Installing
the software needed for the tour” on page 2-1.

Note: The Tour is designed to be used in SDI mode. Make sure the MDI
Development Environment checkbox is de-selected on the General tab of
the Environment Options dialog box.

The database functionality described in this chapter utilizes the JDBC APL
Make sure the Code generation setting is set to JDBC API on the Database
tab of the Environment Options dialog box.

Creating the online reservations applet

Now you’ll create an online reservations applet that your clients can use to
browse through package tours and reserve a spotin a tour. The packages
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are kept in one database table, and the reservations in another table. You
work through the following tasks to create the applet:

*  “Using the dbAWARE Project Wizard to create a new project”
= “Assigning applet properties”

*  “Gathering the files you need”

*  “Designing the package portion of the applet”

*  “Designing the reservation portion of the applet”

*  ‘“Tooking at dbNAVIGATOR”

*  “Setting initial record positions”

*  “Making fields uneditable”

*  “Adding component interactions”

*  ‘“Running the applet”

Using the dbAWARE Project Wizard to create a new project

Visual Cafe has several wizards that help you set up applets and
applications that are database-aware. The wizards step you through
complicated processes and let you create new forms over existing database
tables, add database connectivity to existing forms, define master/detail
joins, and create tables and forms from predefined templates.

You use the Project Wizard to create a new project for an applet.

To create a new project for an applet:
1 Make sure the dbANYWHERE Server is running.

Note: If you don’t set up your system as described in the
section,“Installing the software needed for the tour” on page 2-1,
you might not be able to successfully complete this chapter.

2 Close any open projects.

From the File menu, choose New Project.
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A New Project dialog box appears.

Froject Templates:

Empty Project

Basic Java
Bean

v B B & 7

A A 4

Annliation Gl =

Basic Wind2  Basic Win32
i [ ynamic Link Conszale
Library Application

Basic Basic Win32  * Basic Applet

[ o ]

dbit A ARE Project ‘izard

Cancel | SetDefauItl l:,, E:n_

4 Sclect the dbAWARE Project Wizard template and click OK.
The dbAWARE Project Wizard appears.

dbAWARE Project Wizard

Create a dbAWARE Project

This wizard helpz you create a db&WARE project. [t will azsist you
in performing the following steps:

* Chooze a project tppe,

* Choose the deaM™WHERE server, data source, database
table, and databaze columns to access.

* Chooze the components and labels to dizplay on the forr.

* Choose which databaze operations to have autarnatically
added to the form.

Upon completion of the wizard, you will have the opportunity to
review your selections and alter them iIf necessany.

Mote: The &P selected for code generation is JDBC AP To
change the setting to dbANYWHERE AP, uze the Database page
of the Environment Optiohs dislog under Tools Menu.

< Back I Mest » I Cancel Help

5 Click Next.

The Project Type page appears. Here is where you choose whether
you want to create an applet or application.

Select Applet, then click Next.
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The dbANYWHERE Server page appearts.

7 In the dbANYWHERE Server Name field, type the name you want
to give your dbANYWHERE Server.

The screens in this tour will show the server name dba. Normally,
you can use any name you want, provided it is a unique name.

8 If dbANYWHEREis on a local computet, you can use the default
host name and port number. If dbANYWHERE is on a remote
computer, type the host name or IP address, and the port number,
in the fields.

When dbANYWHERE is running, it displays its IP address and port
number in its window; the default port number is 8889. (Remember,
if you use localhost for the host name, you must change the URL
property for the JdbcConnection object before deploying an applet or
application.)

9 Click Next.

The Data Source page appearts.

Note: If a “Server not responding” message appears,
dbANYWHERE is not running. You need to start it.

10 TFor the Data Soutce Name, choose Tutotial from the pull-down
menu. Then click Next.

You’re asked for a user name and password.

11 Type dba for the user name then type sql for the password, and
click OK.

The Database Table page appears.

Note: If the system seems to be waiting for a response, you could
have a problem with low system resources. The dbANYWHERE
Server has issued a request for the database engine to start, but the
engine has not fully started. Eventually, you receive a “Timed out”
message. If you do, press the Next button again to retry the
connection to the database engine, because the extra time may
have allowed the database engine to start. Otherwise, you
probably need to increase your memory resoutces.

12 Select DBA.packages. Then click Next.

This lets you build a form that contains information on travel
packages.

The Database Columns page appears.
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13 Make sure the checkboxes for all columns are selected. Then click

Next.

The Components and ILabels page appears.
Components and Labels

{*' Components

iz required.

Choosze Components/Gnd and Labels

r'ou can represent the selected columng either by individual
components o a single grid by clicking the radiobutton.

¢ Grid

Y'ou can change the component used for each column by
zelecting from the list of available components. Y'ou can change
the label by byping new text. You can clear the label field if na label

Columnn

| Component | Label |

Package_|D
Package_Mame
Start_Date
Humber_of_Days
Frice_Per_Person
Image

Description

FormattedT extField [syn Package D
TestField [zpmantec.itor Package Mame
DET stamp [symantec.it Start Duate
FormattedT extField [syn Mumber of Daps
TestField [symantec.itor Price Per Person
ImageXiewer [spmantec

| Testirea [symantec.itod D escription

s

o

{ Back I MNest > I Cancel | Help |

14 Perform these operations in the Components and Iabels page:

a In the Iabel fields, replace each underscore (_) with a blank
space to create a more readable form.

b Clear the Label field for the Image column, because you
don’t need an identifier for the image.

¢ Make sure each column has the correct component as

follows:

Package_ID and Number_of Days — FormattedTextField

Package_Name and Price_Per_Person — TextlHeld

Start_Date — DBTstamp
Image — ImageViewer

Description — TextArea
d Then click Next.

The Database Operations page appears.
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15

16

isual Cafe - Untitled1

File Edit Miew Seach Project |nseit Jools Layout QObject Window Help

De-select all operations except Move to the next record and Move
to the previous record. Then click Next.

A summary of your selections appears.

Look over your selections. If they look correct, click Finish. If you
need to change something, click Back and change what you need
to, then return to this window and click Finish.

The new project appears. It contains an automatically generated form
with the fields you selected. (You have to click the ImageViewer
component to see where it is.)

D@ *[me| =7
EEE e EEEEEEE =

| [=F=

Workspace: [Edt - | mlEE FlEEEEE

gl Standard | Utity | Mulimedia | dbéwaRE | dbaNvwHERE | Addiional | Panel | Shape | JDBE |

For Help. press F1 [ [HUM |
Project - Untitled1 =] E Applet - Form Designer [_[O[x] &5 Property List - Applet1 I [=]
e ] [% s ||
b s Background [ white
[ — oo FackagelD L 5 Bounds
= DBA_packagesRecord Packags Name I Ll = 158
o Y 160
Start Date - didth 100
.. Height 100
Mumber of Days sl Class symantec.itooks. db. awt
sl Cursor DEFAULT_CURSOR
Price Per Persan T Diata Binding DBA_packages_Apple
Enabled true
= Font
- L - Mame Dialog
- [ - i Size 12
T Objects | (3 Packages Files - C £ Style
- Bold false
s Italic false
Foreground W black
Description = Trherit Background [tue
s Inherit Font | true
_'ﬂ A Inherit Foreground | true
il ' mage
Wigible true
Mext Previous _|
| D

17

18

Click the Project window, then choose Save As from the File
menu.

The Save As dialog box appears.

Create a new directory structure, such as \VisualCafedbDE
\MyApps\AppletDb , to hold your applet files.

Note: The project and all of the files contained within it should be
in the same directory. For easier project management and to
prevent filename conflicts, you should save each project in its own
directory.
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19 Navigate to the new project directory, type Reserve.vep in the

File Name field, then click Save.

The new name appears in the title bar of the Project window.

Assigning applet properties

Follow these steps:

1

Select Appletl in the Project window.
The properties of Appletl appear in the Property List.
In the Property List, set the Name property to Reserve.

Set the Inherit Background, Inherit Font, and Inherit Foreground
properties to False.

Click the Project or Form Designer window, then choose Save All
from the File menu.

The project and all included files are saved.

Gathering the files you need

To construct your Web page, you need an HTML file that your applet will

run within and the graphics files that your applet uses. You need to copy

an HTML file into your project directory. Then copy the graphics files into
an Images directory subordinate to the project directory.

Using the Windows 95 or NT operating system commands, copy the
files as follows:

1

Copy Reserve.html  from the \VisualCafedbDE
\Toun\Applet directoty to your project directory.

Create a new Images directory in your project foldert.

Copy the following files from the \VisualCafedbDE\Tour
\Applet\images directory to the Images directory in your
project directory:

= reserv.gif

= register.gif
= goall.gif

= goall2.gif

Now you’re ready to design your form.
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Designing the package portion of the applet

6-8

Visual Cafe has put the fields you need on the form, so you can arrange
them.

Follow these steps:

1 TIook at the objects in the Project window (click all the +icons to

expand the container objects).

Project - Reserve YEP Hi=] 3

I ame

AMDBA_packagesM avigatar
dbControlsPanel
== dbButtonzPanel
[ DBA_packagesM avigator_next
3 DBa&_packagesMavigator_previous

-.asb| Package_|DLabel
-isb| Package_Mamelabel
-dsb| Start_[ atel abel

~-dob| Murmber_of_D aysLabel
~-dub| Price_Per_PersonLabel
- dub| DescriptionLabel
-t Package_ID

-.tjz8 Package_Mame
Start_D ate

-2 Nurmber_of_Days
t[= Price_Per_Person

- [#d Image

[z Description

E Connectiontdanager
& jdbeConnection
..... = DBA_packagesRecard

Cy Objects | =y Packages I Files |

The objects that are not listed under dbControlsPanel are invisible
objects:

DBA_packagesNavigator

The QueryNavigator object manages the interaction between the
set of data and the user interface. It provides methods for
navigating (next, previous) and manipulating (insert, delete) the
set of data. The QueryNavigator object also defines the master-

detail relationship, if any.

ConnectionManagerl and jdbcConnectionl

The jdbConnection object provides access to a data source. It
stores the URL of the data source and optionally a user name and
password for connecting to the data source. You can have
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3

multiple jdbcConnection objects in an applet. The
ConnectionManager object manages the jdbcConnection objects
for the applet.

* DBA_packagesRecord

The RecordDefinition object stores the name of the table and
defines the set of data that is retrieved from the database.

The dbControlsPanel object contains all of the visual components that
have been added to the form. The Iabel components are the labels
for the fields of the same name (minus the word Iabel). New visual
components go into the same container.

The fields are database-aware. Java forms built with these
components communicate with databases through the JDBC APL The
tab order of the fields is determined by the order of the components
in the list.

Click on the Form Designer, then de-select Invisibles from the
ILayout menu. This is so you can lay out your applets without the
invisible object icons getting in the way.

The icon in the upper corner, corresponding to the
DBA_packagesNavigator object disappears.

Move the items on the form so they appear like this:

Reserve - Form Designer =] 3

Package Mame

Package ID I

Start Date I
Mumber of Days I
Price Per Person I

Description

" of

Next Previous ”

You need to leave room at the top for a banner. You can click then
Shift-click to select more than one item to move. You can tresize the
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6-10

5

window and the Panel by dragging the right or bottom sides. The
fields must appear on the Panel.

In the Property List, change the Font Bold property to True for all
label and button components.

This action might cause a button to “disappear” from the
dbButtonsPanel. If so, resize the dbButtonsPanel to allow room for all
the buttons.

In the Component Palette, click the Multimedia tab, then click
ImageViewer.

ToolTips shows you which button is for the ImageViewer
component. Move the cursor over a button until a pop-up message

appears.
6 Draw a rectangle actross the top of the applet form by clicking and
dragging the cursor.
Reserve - Form Designer [_ (O]

Package Name

10

1

12

| Package ID I

In the Property List, change the following:
* Name property — imageViewerPackage
IMAGE_NORMAL

Double-click the Image URL property to specify an image for the
component.

* Image Style property

The Image URL dialog box appears.
Click the ... button.
An Add Image Files dialog box appears.

Navigate to your Images directory, select Reserv.gif , then click
Open.

The complete path appears in the dialog box.

Delete the first part of the URL, so the only path remaining is
Images/Reserv.gif

This creates the relative URL
Click OK.
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The banner appears in the Form Designer. Reposition and resize it as
needed.

Reserve - Form Designer Mi=] B2

online reservations for Ilede Café package tours

Package Name | Package ID I—
Start Date I—
Mumber of Days I—
Price Per Perzon I—

Description

¥
4 »

Hext Previous |

13 In the Project window, select Start_Date.

14 In the Property List, change the Format on Display property to:
M+ D%, Y*
This makes the date display in the format of Apr. 7, 1998.

15 Click the Project or Form Designer window, then choose Save All
from the File menu.

The project and all included files are saved.
16 Close your project so you can copy it.

17 Make a copy the entire project directory. You could name the new

directory \VisualCafedbDE\MyApps\AppAdmin

You’ll use these files later when you create an administrative page for
your database.

18 Reopen your project by choosing Reserve.vep  from the File
menu. Open the Form Designer window by double-clicking on
Reserve in the Objects view of the Project Window.

Now you can create the lower half of your applet form.
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Designing the reservation portion of the applet

The lower portion of the applet lets users make reservations.

To design the reservation portion, follow these steps:

1 With the Form Designer window active, deselect Invisibles from
the Iayout menu. This is so that you can lay out your applets
without the invisible object icons getting in the way.

2 In the Project window, click dbControlsPanel.

This ensures that new components are added to this panel.
3 Choose Add Table Wizard from the Insert menu.

The dbAWARE Project Wizard appears.
4 Click Next.

The dbANYWHERE Server page appears.

5 Type dba in the dbANYWHERE Server Name field or choose it
from the pull-down menu.

6 The correct host name and port number should appear. If not,
type the host name or IP address, and the port number, in the
fields.

When dbANYWHERE is running, it displays its IP address and port
number in its window; the default port number is 8889.

7 Click Next.
The Data Source page appears.
8 Choose Tutorial for the Data Source Name. Then click Next.

You are asked for a user name and password only if you’re not still
logged in. Type dba for the user name, then type sql for the
password, then click OK

The Database Table page appears.
9 Select DBA registratdon. Then click Next.
The Database Columns page appears.

10 Make sure the checkboxes for all columns are selected, except for
Registration_ID. Then click Next.
The Components and Iabels page appears. Perform these operations
in the Components and Iabels page:

b3

a In the Iabel fields, delete each occurence of “Customer_
and replace each underscore (_) with a blank space.
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1
12
13

14

15
16

b Make sure each column has the correct component as
follows:

* Package_ID and Customer_Phone — FormattedTextField
* all others — TextField

The components and labels should be set up as follows:
Components and Labels

Choosze Components/Gnd and Labels

'ou can represent the zelected columng either by individual
components o & single gid by clicking the radiobutton,

¢ Comporents ¢ Grd

“r'ou can change the component used for each column by

zelecting from the list of available components. Y'ou can change

the label by bwping new text. You can clear the label field if no label

iz required.

Column | Component | Label |
Package_|D FormattedT extField [syn Package D
Cuztomer_First_Mame | TestField [spmantec.itor First Mame
Customer_Last_Mame | TestField [symantec.itor Last Mame

Customer_Email TextField [zpmantec.itor Email
Customer_Phone FormattedT extField [spn Phone
MHumber_in_Party TestField [symantec.itol Mumber in Party
Total_Cost TestField [symantec.itor Total Cost

{ Back I Mest > I Cancel Help |

¢ Then click Next.

The Database Operations page appears.

De-select all operations except Save changes and Undo changes.
Change the text of the Undo changes operation to Clear.

Change the text of the Save changes operation to Send
Registration.

Then click Next.
The Master View page appears.
You don’t need to make any changes on this page, so click Next.

Look over your selections. If they look correct, click Finish. If you
need to change something, click Back and change what you need
to, then move to this window and click Finish.
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17

18

19
20

21

22
23

24

The new fields appear on the same form in the lower half of the

Form Designer.

Arrange the fields as follows:

¥
q ¥
Next Previous
Package ID Phone
First Name | Number in Party
Last Name | Total Cost
E-mail |
Send Registration | Clear

You may need to resize some elements so they fit onto the

dbControlsPanel correctly.

In the Property List, change the Font Bold property to True for all

label and button components.

In the Component Palette, click the Multimedia tab, then click

ImageViewer.

Draw a rectangle underneath the Previous and Next buttons by

clicking and dragging the cursor.

Ly o

Next Previous
Package ID Phone
First Name | Number in Party
Last Name | Total Cost

E-mail |

Send Registration | Clear

In the Property List, change the following:
* Name property
* Image Style property — IMAGE_NORMAL
Double-click the Image URL property.

imageViewerReg

The Image URL dialog box appears.
Click the ... button.
An Add Image Files dialog box appears.

Navigate to your Images directory, select Register.gif
click Open.

, then
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25

26

27

28

29

30

The complete path appears in the dialog box.

Delete the first part of the URL so the only path remaining is
Images/Register.qgif

This creates the relative URL
Click OK
The banner appears in the Form Designer. Reposition and resize it as

needed.

register for this tour here

—

First Mame |

Package ID Phone
Number in Party

Total Cost

Last Name [

E-mail [

Send Registration | Clear

Click the Package ID field on the second part of your form
(Package_ID2).

In the Property List, change the Text property to 780.

This initializes the field to display the first Tutorial package ID.
Alternatively, you could write Java code that took the first Package ID
number from the database and placed it in the registration Package
ID field on initialization.

For the Number in Party and Total Cost fields, change the Text
property for each to 0 (zero).

This initializes these fields to display zero at first. This is important
because later these fields will dynamically update numbered data.

Click the Project or Form Designer window, then choose Save All
from the File menu.

The project and all included files are saved.

Looking at dbNAVIGATOR

The dbNAVIGATOR provides a hierarchical view of database cataloging
information (known as meta-data). This view shows you dbANYWHERE
Servers and available databases, as well as the tables and columns in each
database. You can use dbNAVIGATOR to drop fields on a form and add
fields after you’ve run the Project Wizard.
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To view the dbNAVIGATOR display for the Tutorial database, follow
these steps:

1 From the View menu, choose dbNAVIGATOR.
The dbNAVIGATOR window opens.

2 C(lick the +to open dba, then the Tutorial database, then the
DBA.registration table in the Tutorial database.

= dbNAVIGATOR M=l B3

=2 Tutarial ;I

@ DB, packages

E@ DB regiztration
{E] Registration_|D
{E] Package_ ID
{E] Customer_First_Mame
{E] Customer_Last_Mame
{E] Customer_E mail
-] Customer_Phane
- IH] Mumber_in_Party
“[H] Total_Cost

-

You can drag fields from the dbNAVIGATOR to the dbControlsPanel
object in the Project window to add them to a form. Both a field and
a label are added. Because you’ve alteady added all of the fields you
need, you don’t need to drag a field.

3 Close the dbNAVIGATOR window.

Setting initial record positions
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The packages information should start at the first record, while the
registration information should start at a new record.

To set the initial record position:
1 Select DBA_packagesNavigator in the Project window.

2 In the Properties window, make sure the AutoStart property is set
to true.

3 Now select DBA_registrationNavigator in the Project window.

4 In the Properties window, set the AutoStart property to false.

Now you need to type in a line of Java code to start a new record for the
registration information.

5 Right-click on the Reserve applet in the Project window and
choose Edit Source from the pop-up menu.
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The Source Editor appears.

Choose Find from the Search menu to display the Find dialog box.
Search for REGISTER_LISTENERS

Immediately above the REGISTER_LISTENERS line, enter the

following:
DBA_registrationNavigator.insert();
Close the Source Editor.

Click on the Project window and choose Save All from the File
menu.

Making fields uneditable

All of the DBA.packages fields (except for the label fields and the image
field) and the following registration fields should not be editable by a user:

Package_ID2

Total_Cost

To make the fields uneditable:

1

In the Form Designer, select all of the fields listed above.
As before, click then Shift-click to select multiple fields.
In the Property List, set the Editable property to False.

The field is now uneditable. To indicate this, you’ll change the
background to gray.

For the Background property, choose gray.

The gray color appears as the background color.

& Property List - Reserve

IEI% Package_Mame vl
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When you finish with the fields, your form should look like this:

Reserve - Form Designer [_[O]

online reservations “Jur ke de Caft package tatrs

Package Hame | Package ID ]
Start Date I
Numberof Days [
Price Per Person [

Description

q »
HNext Previous

register for this tonr here

Package ID Phone
First Name | Number in Party
Last Name | Total Cost
E-mail |

Send Registration | Clear

Save your project by clicking the Project or Form Designer window, and
then choosing Save All from the File menu.

Adding component interactions

6-18

You need to add the following component interactions to your applet:

*  “Setting up the Send Registration button”
*  ‘Setting the Package ID field”

*  “Calculating the total cost”

Setting up the Send Registration button

Whenever a record is saved, you want to get a new record so a user can
register again.
To set up the Send Registration button:
1 Select the Send Registration button and right-click.
A pop-up menu appears.
2 Choose Add Interaction.



Creating the online reservations applet

The Interaction Wizard appears.
3 Select the following items:

* Start an interaction for “DBA_registrationNavigator_save™
ActionPerformed

* Select the item you want to interact with:
DBA_registrationNavigator

* Choose what you want to happen: insert
4 Click Finish.

5 Click the Project or Form Designer window, then choose Save All
from the File menu.

Setting the Package ID field

You need to set the Package ID field when the following buttons are
clicked:

*  C(Clear
*  Send Registration
*  Previous

*  Next

To create the interaction for each button:

_¢| 1 Click the Interaction Wizard button, then click the button and drag
a a line to the Package ID field on the registration form.

register for this tour here
Package ID ” Phone I
First Name [ \ Number in Party |
Last Name T N Total Cast T
E-mail [
Send Registratio

The Interaction Wizard appears.
2 Select the following items:
* Start an interaction for “button” ActionPerformed
* Select the item you want to interact with: Package_ID2

* Choose what you want to happen: Set the text for
Formatted TextField
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4

5

Click Next.
The second page in the wizard appears.

While Another item is selected, choose Package_ID and select Get
the contents of the FormattedTextField.

Click Finish.

Save your project by clicking the Project or Form Designer window, then

choosing Save All from the File menu.

Setting up the Number in Party and Total Cost fields

The Number in Party and Total Cost fields need to be reset to zero when
the Clear or Send Registration buttons are clicked.

To set up the Number in Party field:

1

4

5

Click the Interaction Wizard button, then click the button and drag
a line to the Number in Party field on the registration form.

The Interaction Wizard appears.

Select the following items:

* Start an interaction for “button”: ActionPerformed

* Select the item you want to interact with: Number_in_party
* Choose what you want to happen: Set the text for TextField
Click Next.

The second page of the wizard appears.

While A String constant or an expression is selected, select Add
quotes and type 0 (zero).

Click Finish.

To set up the Total Cost field:

1

Click the Interaction Wizard button, then click the button and drag
a line to the Total Cost field on the registration form.

The Interaction Wizard appears.

Select the following items:

* Start an interaction for “button’ ActionPerformed

* Select the item you want to interact with: Total_Cost

* Choose what you want to happen: Set the text for TextField
Click Next.
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The second page of the wizard appears.

4 While A String constant or an expression is selected, select Add
quotes and type 0 (zero).

5 Click Finish.

Save your project by clicking the Project or Form Designer window, then
choosing Save All from the File menu.

Calculating the total cost

The total cost should be calculated after a user enters the number of
people. It should be updated when Previous or Next is clicked, because
the price might change.

To calculate the cost when the Number in Party field changes:

1 Click the Interaction Wizard button, then click the Number in Party
field and drag a line to the Total Cost field on the registration form.

register for this tour here

Package ID l— Phone l—
First Name | Number in Pa
Last Name [ Total Cost
E-mail [
Send Registration | Clear |

The Interaction Wizard appears.
2 Select the following items:

* Start an interaction for “Number_in_Party™ focusLost

* Select the item you want to interact with: Total_Cost

* Choose what you want to happen: Set the text for TextField
3 Click Next.

The second page of the wizard appears.

4 While A String constant or an expression is selected, deselect Add
quotes and type the following line:

String.valueOf(Float.valueOf(
Price_Per_Person.getText()).floatValue()
*  Float.valueOf{(
Number_in_Party.getText()).floatValue())

5 Once you've typed it in, copy the entire line.
You'll paste it later.
6 Click Finish.
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7 Click the Project or Form Designer window, then choose Save All
from the File menu.

To set up the cost calculation for the Previous and Next buttons:

—+| 1 Click the Interaction Wizard button, then click the button and drag
a line to the Total Cost field on the registration form.

The Interaction Wizard appears.
2 Select the following items:

* Start an interaction for “button” ActionPerformed

* Select the item you want to interact with: Total_Cost

* Choose what you want to happen: Set the text for TextField
3 Click Next.

The second page of the wizard appears.

4 While A String constant or an expression is selected, deselect Add
quotes and paste the following line:

String.valueOf(Float.value Of(
Price_Per_Person.getText()).floatValue()
*  Float.valueOf(
Number_in_Party.getText()).floatValue())

5 Click Finish.

Save your project by clicking the Project or Form Designer window, then
choosing Save All from the File menu.

Now you’re ready to run the applet.

Running the applet

You can compile your applet and look at it while it’s running in the Applet
Viewer.

To run the applet:

1 From the Project menu, choose Execute.
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The applet appears in the Applet Viewer. Visual Cafe compiles your

applet before displaying it.

23 Applet Viewer: Reserve.class

[_ O[]
Applet
online reservations for Isle de Café package tours
Package Name  [AIGESUONOMICAGVERENIIINN ~ Package ID |2 —
Start Date [997-0401
Number of Days  [T20NN
Price Per Person  [HG0DI00000
Description
Next Previous:
register for this tour here
Package ID  [FEORN Phone
First Name | Number in Party [0
Last Name | Total Cost o
E-mail |
Send Registration | Clear
2 Try outyour applet to make sure it works.
3 From the Applet menu, choose Quit.
The Applet Viewer window closes.
4

from the File menu.

Click the Project or Form Designer window, then choose Save All

Displaying the applet in a Web page

Now you can test your appletin a Web page.

Note: To be able to run your applet in a Web browser, the browser must

support JDK 1.1.5.

Adding the HTML file to the project

To add the file to the project:
1

The Project Files dialog box appears.

From the Insert menu, choose Files into Project.
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2 In the Project Hiles dialog box, select Reserve.html  in your
project directory, then click Add.

The file appears in the Files in Project list.
3 Click OK to add the file to the project.

The file appears in the Project window.

Project - Reserve YEP M= E3

M ame |

[#-[5] Reserve

. Connectionk anager
@ [BA_packagesRecord
=3 DBA_registrationRecard

B

G Objects | = Packages I Files |

Modifying the applet tag in the HTML file

Now you’re ready to add the applet you created in Visual Cafe to the
HTML file.

To add the applet to the HTML file:

1 'To look at Reserve.html | right-click on the file in the Objects
view of the Project window and choose Edit Source from the pop-
up menu.

The file opens in Edit Mode in Visual Page.
2 From the View menu, choose Source.

The HTML source window opens.
3 Find the applet tag in the file:

<APPLET CODE="Reserve.class" WIDTH=634 HEIGHT=540>

4 If different, change the width and height in the applet tag so it
matches the width and height in the Property List for your Reserve

applet.

5 From the File menu, choose Save.

6 Close or minimize Visual Page.
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Executing the applet within the Web page

Visual Cafe lets you run the applet directly within the Web page by using
Visual Page or your default Web browser. The advantage of using Visual
Page is you can also modify your HTML files as needed.

To open your Web page in Visual Page:

1 In the Objects view of the Project window, double-click
Reserve.html

If you have properly installed Visual Page from the Visual Cafe CD,
Visual Page starts and displays your Web page.

BE VisualPage - [Reserve_htmi] [_[O] <]
[3] Ele Edt Yiew Inset Stle Fomat Frame Window Help _12] %
DleE| @ e EEE EE | wl =] @2l

[Home H Bz |E| a|&] 28 [E

L s = e Page
and Slide

Show

and Information

& 99
Client
Comments
Custom and
Package
Tours

@
—
. =

==
E mail
Request Form
e
Online 255
Reservations
Reserve.class =l
Link to: | ‘
For Help, press F1 NUM 7

2 TFrom the View menu, choose Preview.
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The applet runs in Visual Page.

B8 VisualPage - [Reserve_html]

@ File Edit Miew |nset Stle Fomat Frame MWindow Help =& x|

Shaw

Package ID cTen
Start Date [Apr1 188
Number of Days  [FZIN
Price Per Person  [JESO000000N

Description

Island Map ——
and Information

&6 99,
Clicnt
Comments

Custom and
Package
Tours
=
’ =
E mail
Request Form
Hext Previous
iras q .
Online ¥ register for this tour here
Reservations
Package ID _ Phone
First Name [ MumberinParty [ 0
Losttiame | Taicost [
Email |
Send Registration | Clear |
I
Lirkte: [ ‘
For Help, press F1 NLIM 4

Try out your applet.
3 Exit Visual Page.

The window closes.

If your applet works properly in Visual Page, you have completed the
applet. Continue with the next section to create the administrative applet.

Creating an administrative applet for online
reservations

You can quickly create an administrative applet so you can manage and
view the reservations in DBA.registration. The applet should require a
password for security.
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To create an administrative applet:
1 Close any open projects.

2 Open the project you saved in your AppAdmIn project directoty.

The project appears.

& Visual Cale - Reserve VEP
File Edit Miew Search Project Insert Tools Layout Object Window Help
DR see|52KR |wea - |FOEBDEEEEE >0 = |8E6¢
DN [ = e =g )
=% | "Standad [ Uiy | Mubimedia [ doéiwiaRE | dbaNYWHERE [ Addiional | Fanel [ Shape | JDBC]
For Help, press F1 [MUM |
Project - Reseive. Reserve - Form Designer =] K [Reserve = [=] B3
Name -
e . A e
ervel - online reservations Jfor Isle de Café package tours [ white
onnectionian |
DB4_packages | 3
Package Name Package ID a0
324
Start Date 513
WumberofDays | | symantes itocls db swt Imag
DEFAULT_CURSOR
Price Per Person DB&_packages@Image
Description e
| = Dialog
| _I 12
P [Plain]
G Objects | (5 Pack W black
- ind [true
tue
d | tue
Image
B
_I_I trug
q 3
Next Previous ﬂ

3 In the Project window, select dbControlsPanel.
4 Choose Add Table Wizard from the Insert menu.
The dbAWARE Project Wizard appears.
5 Click Next.
On the dbANYWHERE Server page, choose dba.

7 Make sure the Host Name and Port Number are correct and click
Next.

8 On the Data Source page, choose Tutorial and click Next.

9 Ifyou’te notalready logged in, do so using dba for the User Name
and sql for the password.

10  On the Database Table page, choose DBA.registration and click
Next.

11 On the Database Columns page, make sure all columns are
selected and click Next.

The Components and Iabels page appears.
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12 Click Grid, then clear the Grid Iabel field.

Components and Labels

Chooze Compaonents/Grid and Labels

'ou can represent the zelected columng either by individual
components of & single gnd by clicking the radiobutton,

" Components %

“r'ou can change the label that iz used for the Gnd by tping new
text. You can clear the label field if no label is required.

Grid Label:

< Back I Ment » I Cancel | Help

13 Click Next.

14  On the Database Operations page, de-select all operations and
click Next.

15 On the Master View page, choose the alias of the packages view
and click Next.

The Join Definition page appears.
16 Specify the master-detail relationship as follows:
* Master Column -- Package_ID
* Operator -- =
* Detail Column -- Package_ID
17 Click Next.
A summary of your selections appearts.

18 1If the information appeats to be correct, click Finish to create the

grid.
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19  Resize the grid so it fits on the bottom of the form like this:

Reserve - Form Designer M=l B3

online reservations for Isle de Café package tours

Package Name [ Package ID |

Start Date |
Humber of Days |
Price Per Person |

Description

Hext Previous ‘

20 Click the Project or Form Designer window, then choose Save All
from the File menu.

Now let’s see if the applet runs.
21 From the Project menu, choose Execute.
The applet appears in the Applet Viewer.

22 Try out the applet to make sure it works. Then close the Applet
Viewer.

When you click Next or Previous, the list in the grid updates. You can
resize the columns in the grid for the best display.

23 In the Project window, select the jdbcConnectionl object.

The properties for this object are displayed.

6-29



Chapter 6: Creating Applets with Database Functionality

24 In the Properties List, delete the values for the User Name and
User Password properties.

Now you’ll have to enter them at runtime to access the data source.
Let’s try the applet again.

25 From the Project menu, choose Execute.
A User Authentication dialog box appears.

[3 Untitled ]

URL: idbc:dbawiflocalhost: 3889 utarial

User Marme: | dba
Password: | e
614 | Cancel

26 Type dba in the User Name field and sql in the Password field.
Then click OK.

The applet appears in the Applet Viewer.
27 Close the Applet Viewer.

You can also test the applet in a browser.
If your applet works, you have completed the Visual Cafe tour and learned
about many important Visual Cafe features. Now you’re ready to build your
own applets and applications. For more in-depth information, explore the

online help and the Visual Cafe for Java User’s Guide provided with Visual
Cafe.
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C HAPTER

Support and More
Information

This chapter describes where to get more information on Java and the
Database Development Edition of Visual Cafe. It has the following sections:

*  “Where to get information”

*  ‘“Registering your Symantec product”

*  “Product updates”

* ‘“Symantec service and support solutions”

*  “Technical support”

- “Electronic support”
- “Customer service”
*  “Service and support headquarters”

*  “Worldwide service and support”

Note: The information in this chapter is accurate at the time of publication.
However all information, including URLs, is subject to change.
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Where to get information

Visual Cafe includes the following documentation:

Title To find it ...

Visual Cafe help Choose Help Topics from the Help menu.

Choose a menu command, then press F1 to
see a description.

Press F1 in any dialog box or window to
display help for that option.

Press Shift+F1, then choose the item for
which you need help.

Visual Cafe Samples  Go to the Samples subdirectory of your
Visual Cafe installation. You need to use the
custom install to install these samples.

Sun Microsystems Java Choose Java API Reference from the Help
API Specifications menu.

Highlight a keyword in an Editor window
and press Fl for a description.

Sun Microsystems Java Choose Java Language Reference from the
Ianguage Help menu.

Specifications
Highlight a keyword in an Editor window

and press Il for a description.

Visual Cafe Macro Choose Macro Reference from the Help
Reference menu.
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Registering your Symantec product

To find the most up-to-date information about Sun Java and Visual Cafe:

For information about... See...
Sun Microsystem’s Java http://www.javasoft.com
Symantec Internet Tools http://cafe.symantec.com

Symantec Technical Support http://service.symantec.com
See the section “Symantec service
and support solutions” in this
chapter.

For technical support telephone
numbers, see the section “Service
and support headquarters” in this
chapter.

You can also purchase books on Java. Some books for Java and HIMIL, are
listed at http://service.symantec.com/amazon/index.html

Registering your Symantec product

If you have ordered the product online, you are automatically registered
through Customer Service. In addition, you can use the toll-free fax
number listed below to register your product, or register on the Customer
Service Home Page under Service and Support at www.symantec.com.

If your address changes, you can mail or fax your new address to Customer
Service. Please send it to the attention of the Registration Department.

Symantec Corporation
Attn: Registration Dept.
175 W. Broadway
Eugene, OR 97401

(800) 800-1438 Fax

You can also change your address on the Customer Service Home Page
under Service and Support at www.symantec.com.
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Product updates

Check the Symantec Web site (http://cafe.symantec.com ) for
updates to Visual Cafe. After you have registered your copy of Visual Cafe,
you can use your login name and password to download patches and
minor updates to your current version. If you bought your productin a
box, the user ID and password are included with your package. If you
bought your product online, the user ID and password were displayed to
you on the screen.

Symantec service and support solutions

Symantec is committed to excellent service worldwide. Our goal is to
provide you with professional assistance in the use of our software,
wherever you are located.

Technical Support and Customer Service solutions vary by country. If you
are outside the United States or Canada, please refer to the Worldwide
Service and Support section at the end of this chapter.

Technical support
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Symantec’s Technical Support department offers expanded support options
designed for your individual needs and to help you get the most out of
your software investment.

The phone numbers listed “Service and support headquarters” on

page 7-11 are for support in North America. If you are outside the United
States or Canada, please call the local Symantec office or distributor in your
area, or refer to the information provided at the end of this chapter.

Symantec now offers different types of technical support services for you
to choose from, which are described below. You are given StandardCare
Support by purchasing the product and then can choose from Symantec’s
PriorityCare and PremiumCare services to extend your level of support.

For the most current information on Symantec Support Solutions, please
call our automated fax retrieval service, located in the United States, at
(800) 554-4403 or (541) 984-2490, and request document 070. Alternatively,
visit Symantec on the World Wide Web at www.symantec.com.



Technical support

StandardCare support

All registered users of Symantec products are entitled to these services at

no charge:

Unlimited calls for 90 days (from the date of the first call) for
installation assistance, configuration, and general usage questions. The
phone number is (541) 465-8470.

Unlimited technical assistance through CompuServe and America
Online. These forums offer electronic access to our technical support
staff, libraries of sample files, technical notes, and bulletins. You will
also find a rich interaction and information exchange with other users
of Symantec software.

Unlimited use of the Symantec Discussion Groups available from the
Service and Support section on www.symantec.com. These forums
offer electronic access to our professional technical support staff, the
Symantec knowledge base, FAQs, and announcements. The news
server is at service.symantec.com.

Unlimited access to company information through the Internet. With a
Web browser such as Netscape, you get the latest company news by
entering the URL for Symantec’s home page: www.symantec.com.

The Web site include links to our anonymous FIP site, where you
can download the latest software patches and drivers for Symantec
products. You can also FIP directly to the site by entering:
ftp.symantec.com.

Unlimited use of Symantec’s automated fax retrieval system for instant
printouts of technical notes, bulletins, product literature, and general
information by fax.

StandardCare Support is available Monday through Friday, 7:00 a.m. to
4:00 p.m. Pacific Time.

For your first 90 days of free technical support, please refer to the
StandardCare Support (541) phone number in the “Service and support
headquarters” section.

PriorityCare support

All registered users of Symantec products are entitled to these services on a

“pay-as-you-go” basis:
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The PriorityCare 800-number is charged to your VISA, MasterCard, or
American Express on a per incident basis.

The PriorityCare 900-number is charged to your telephone bill on a per
minute basis. (As of this writing, the charge is $2 per minute, and an
equivalent 900-number service is not available outside the United
States.)

Average hold time will be kept to a minimum.

PriorityCare Support is available Monday through Friday, 6:00 a.m. to
5:00 p.m. Pacific Time.

To use the PriorityCare 800- and 900-number services, please refer to those

numbers in the “Service and support headquarters” section.

PremiumCare support
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All registered users of Symantec products are entitled to these services on

an annual subscription basis:

PremiumCare Gold support

Supportt for one year for a set number of incidents, with an option to
add more incidents.

Priority support on a a toll-free 800 line.
Average hold time will be kept to a minimum.

Hlectronic mail support is provided with a 24-hour response time on

working days. The PremiumCare Gold Supportt is available for Visual
Cafe for Windows ownerts at support_javawin@ ymantec.com and for
Visual Cafe for Macintosh owners at support@levtools.symantec.com.
Please include your subscription ID with any e-mail.

PremiumCare Gold Support is available Monday through Friday, 6:00
a.m. to 5:00 p.m. Pacific Time.

PremiumCare Platinum support

Unlimited calls on a toll-free 800 line.

Average hold time will be kept to a minimum.



Electronic support

* A Support Center Manual with troubleshooting, installation,
configuration, and usage information.

*  Quarterly updates of technical notes and bulletins.
* Instant access to senior support staff.

* Automatic updates of inline software revisions. (Inline software
revisions do not include version upgrades.)

*  After hours and weekend support is also available to PremiumCare
Platinum customers for an additional fee.

*  PremiumCare Platinum Support is charged on an annual subscription
basis per product family. The annual fee is for two subscribers; other
subscribers can be added on a per person basis.

* PremiumCare Platinum Supportt is available Monday through Friday,
6:00 a.m. to 5:00 p.m. Pacific Time.

*  Hlectronic support for Visual Cafe for Windows owners at
support_javawin@symantec.com and for Visual Cafe for
Macintosh owners at support@devtools.symantec.com

To order PremiumCare Gold or Platinum support, please contact Customer
Service or your Symantec sales representative.

Electronic support

Technical information is available electronically 24 hours a day. Symantec
maintains the Symantec forums on CompuServe and America Online.
CompuServe

You can exchange information and ideas with Symantec representatives
and with other users of Symantec products on the CompuServe bulletin
board.

To access the Symantec forums on CompuServe, type:

GO SYMANTEGt any ! prompt or
GO SYMDEVTOOL

For additional information, ot to subscribe in the United States and Canada,
please call CompuServe at (800) 848-8199. Outside the United States and
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Canada, please call (1) (614) 718-2800. Check with CompuServe for data
communications settings.

America Online

To access the Symantec bulletin board on America Online, type keyword:
SYMANTEC

For additional information, or to subscribe in the United States and Canada,
please call America Online at (800) 227-6364. Check with America Online
for data communications settings.

Symantec discussion groups

Use your Web browser to go to http://www.symantec.com and go to
the Service and Support section. Here you can review the Frequently
Asked Questions, search the Symantec Knowledge Base for known
solutions to problems previously encountered, or post your own quety to a
support newsgroup.

Symantec representatives are ready to answer your questions via our
support discussion groups. All messages posted will receive a response
from a Symantec representative within 48 hours. The discussion groups are
similar to electronic bulletin boards where you post a message and then
return later to find an answer. These support forums are in Usenet
newsgroup (Internet news) format and require that you have a newsreader
available.

You can FIP directly to this site to download technical notes and software
patches at: ftp.symantec.com. You can also use the news server,
service.symantec.com.

Automated fax retrieval system
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Symantec’s automated fax retrieval system can be used 24 hours a day to
receive product information on your fax machine. You can call from any
touch tone phone to receive an index listing of both Technical Support and
Customer Setrvice documents available, then have any of these specific
documents faxed to you.

To receive technical application notes and samples of “how tos,” please
call our Technical Support fax retrieval number, and choose Option 2.



Customer service

You can receive general product information, data sheets, and product
upgrade order forms from our Customer Service fax retrieval number.

*  Technical Support: (541) 984-2490
*  Customer Service: (800) 554-4403

In addition, you can receive a listing of Symantec offices and worldwide
service and support partners by calling the Technical Support fax retrieval
number, choosing Option 2, and requesting Document 1400.

Customer service

Symantec’s Customer Service department builds and maintains long-lasting
customer relations through consistent, expert service. Our Customer
Service department is available to help you:

*  Otrder an upgrade.

*  Subscribe to the technical support solution of your choice.

*  Fulfill your request for product literature or demonstration disks.
* Find out about dealers and consultants in your area.

*  Replace missing or defective pieces (disks, manuals, and so on) from
your package.

* Getstatus on an order or a return.
* Update your product registration with address or name changes.
*  Replace lost passwords or user IDs.

You can reach Customer Service at (800) 441-7234 or under the Service and
Support section at www.symantec.com. For specific questions about how
to use your Symantec software, please contact Technical Support.

Replacing a CD-ROM

If the Visual Cafe CD-ROM is damaged or unusable, you can obtain a
replacement.
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To receive a replacement or refund for a product purchased through a
reseller, please visit or contact the authorized dealer from whom you
purchased the product.

If you ordered the product or upgrade directly from Symantec and wish to
receive an replacement or refund in accordance with our 60-day money
back guarantee, please return your CD-ROM and a letter including a brief
explanation for the return. Please send by traceable means, such as UPS or
FEDEX, to:

Symantec Corporation
ATTN: RMA Dept.

175 West Broadway
Eugene, OR 97401

Recovering user IDs and passwords

If your user ID and password become inoperative, send a message to
Customer Setvice at custserv@symantec.com  with your name,
address, daytime phone number, ID, and password and we will resolve the
situation for you within 24 to 48 hours. Type Cafe 1.5 DL Reset in the
subject field of the message.

If you have lost your Visual Cafe ID, send a message to Customer Service
at custserv@symantec.com . If your information does not appeat in
our registration database, we will provide additional avenues so you can
verify ownership of the product.

Old version support

When a new version of this software is released, registered users may
receive upgrade information through electronic mail or the postal service.
After the release of the new version, telephone support will be provided
for the previous version for 6 months. Technical information for the older
versions may still be available on the electronic services and automated fax
retrieval system.

Discontinued product support
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When Symantec announces that a product will no longer be marketed or
sold, telephone support will be discontinued 60 days later. Support will
only be available for discontinued products through services such as our



Service and support headquarters

automated fax retrieval system or through documentation posted on
electronic services such as the World Wide Web, Symantec BBS,
CompuServe or America Online.

Service and support headquarters

Symantec’s service and support headquarters for North America is at the
following location.

Symantec (800) 441-7234 (USA & Canada Customer
Corporation Service)

175 W. Broadway [(541) 334-6054 (all other locations)
Eugene, OR 97401 |Fax (541) 984-8020

For Visual Cafe technical support, please call
the following numbers:

StandardCare Support (541) 465-8470
PriorityCare 800 Support (800) 927-4014
PriorityCare 900 Support (900) 646-0004

or post a message in the Visual Cafe Discussion
Group at http://www.symantec.com/
techsupp/index.html

Worldwide service and support

Symantec provides technical support and customer service worldwide.
Services vary by country and include International Partners (IPs) who
represent Symantec in regions where there is no Symantec office. Most IPs
provide customer service and technical support for Symantec products in
your local language, as close to your home or office as possible.

If your country is not listed in the International Locations section below,
please call our Technical Supportautomated fax retrieval service, located in
the United States, at (541) 984-2490, choose Option 2, and request
Document 1400.

International locations

European headquarters
Symantec Europe Itd. Tel. (31) (71) 535 3111
Kanaalpark 145 Fax (31) (71) 535 3150
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2321 JV Leiden
The Netherlands

Customer Service

Technical Support -  Dutch
French PC/Mac
French Mac
German
English
Other Countries

International BBS (up to 14.4 baud)
Automated fax retrieval (24 hrs.)

Asia/Pacific Rim region
Symantec Australia Pty. Itd.
408 Victoria Road
Gladesville, NSW 2111
Australia

Technical Support

BBS
Automated fax retrieval (24 hrs.)

Mexico

Tel. (31) (71) 535 3294

Tel. (31) (71) 579 4407
Tel. (33) (1) 41 38 69 80
Tel. (33) (1) 41 38 69 81
Tel. (49) (211) 9917 110
Tel. (44) (1628) 788 580
Tel. (31) (71) 579 4425

Fax (31) (71) 535 3153

—

<

Tel. (31) (71) 535 3169
Tel. (31) (71) 535 3255

—

—

Tel. (61) (2) 9850 1000
Fax (61) (2) 9850 1001

Tel. (61) (2) 9879 6577
Fax (61) (2) 9879 6594
Tel. (61) (2) 9879 6322
Tel. (61) (2) 9817 4550

Symantec Mexico Tel. (52) (5) 545 1234
Rubén Dario No. 36, Piso 2, OFNA 6Fax (52) (5) 531 2252

Colonia Chapultapec Polanco
11560 México, D.E

Technical Support

Japan

Symantec Japan, Inc.

Pine Bldg. 6F

3-1-2, Shibuya, Shibuya-ku
Tokyo 150 JAPAN

Phone: (81)03-3498-1118
Fax: (81)03-3498-1124

For Technical Support call the
automated fax retrieval service,
located in the United States, at
(541) 984-2490, and request
Document 1400.



Worldwide service and support

Every effort has been made to ensure the accuracy of this information.
However, the information contained herein is subject to change without
notice. Symantec Corporation reserves the right for such change without
prior notice.
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Glossary

adapter

Classes that implement an interface. The java.awt.event package provides, as a
convenience, a series of listener classes that can be implemented by classes

applet

A program that can be added to a Web page and run by Java-enabled Web browsers
(or the Applet Viewer). Java applets are secure because they can’t access the file
system on the local computer, but they can still read from the Web server. This
means that applets are less likely to damage a user’s system or send private
information back to the Web server. (While an applet usually doesn’t have a menu
bar, it can create a Java frame that has a menu bar.)

applet tag

HTML code that causes an applet to appear in a Web page. It has the following basic
format:

<APPLET code="applet.class" width=pixw height=pixh></APPLET>
applet is the name of the applet.

pixw is the number of pixels for the width.

pixh is the number of pixels for the height.

Consult an HTML book for more information on the applet tag.

application

A Java application is standalone and cross-platform: it can run on all computers with
a standalone Java virtual machine and supporting files (which, for instance, you can
obtain from the Sun JDK at http://java.sun.com ), so separate applications for
each environment aren’t needed. Java applications can have menu bars and access
files on the local computer. A Java application is like a C++ application, but it’s cross-
platform and you need a Java virtual machine to run it. For example, you could write
a word processor program in Java. A Java frame is a good base class for a main
application window: it can exist by itself, contain components and menus, and can
show dialogs and windows.

bean
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A component complying with the JavaBeans standard. Also called a JavaBean or a
JavaBeans component. A bean is a reusable component that can be visually
manipulated in a builder tool. The minimum requirements are that it can be
instantiated (it is not an abstract class or interface) and has a class constructor method
that takes zero parameters (it has a null constructor). It can also have properties and
events, implement the serializable or externalizable interface, and follow method
signature rules so it can be introspected.

bytecodes

Instructions that are similar to machine code, but are machine-independent. During
execution, the Java virtual machine either interprets the bytecodes with a Java
interpreter or converts them to machine code (stored temporarily in memory) with a
Just-In-Time compiler.

class

A collection of attributes and methods that defines the implementation of a particular
kind of object. A class definition defines instance variables and methods, and
specifies the interfaces the class implements and the immediate superclass of the
class. See also inner ¢class.

component

A JavaBeans component.

- Avisualcomponentis a user interface element, such as a window, menu,
button, and so on, that is visible at run time and appears in the Visual Cafe
Project window and Form Designer. It extends from the Java Component
class and has a screen position, a size, and a foreground and background
colot.

- An invisible componentis not visible at run time, such as a Timer, or displays
in a different way in the Form Designer and at run time, such as a MenuBar. It
does not extend from the Java Component class. In the Form Designer, an
invisible component is represented by an icon that does not effect the form
layout.

- Some components can contain other components, such as an application
window containing a button; these components are called containers. In the
Objects view of the Project window, the components in a container appear
subordinate to the container, like a file system display. The containers at the
top level are separate Java files in your project (called Visual Cafe forms),
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while the components in the containers are Java code within the container
Java file.

To create youruser interface, you can displaya form in the Form Designer, then drag
onto the form a variety of components from the Component Library or Palette; you
assign the component properties in a separate Property List window, and add
interactions between components with the Interaction Wizard. Visual Cafe Pro
automatically creates the Java code for you during this design process.

. Components are like controls in C++.

container

A component that can contain other components. There are two general categories of
Java containers: windows and panels. Some types of windows are a frame (which can
have a menu bar) and a dialog. A panel is a defined area that can appearin a
window, such as an applet that appears in a browser. A top-level container, also
called a Visual Cafe form, is at the top level in the Objects view of the Project
window. It has a corresponding Java file that appears in the Packages and Files
views.

dialog

A Java Dialog component is a simple window with a title bar that can receive and
process input from a user. Dialogs cannot be used by applets, and are not suitable for
use as a main window for an application. Dialogs can contain components, but not
menus. Use dialogs for temporary windows. See also componentand container.

data source

A data source is a source of data, usually a database.

database template

A database template is an empty database table with predefined columns. Fach
template is designed for a specific type of information.

event

An action, initiated by a user or a program, to which an object can respond. Events
are typically user actions that the program can capture and respond to. Examples of
events include mouse clicks, key presses, and mouse movements.

event handler

A method that is called when a certain type of event is triggered. Visual Cafe
automatically generates the code needed to bind the occurrence of an event to an
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event handler when you create an interaction with the Interaction Wizard or from the
Events/Methods pull-down menu of the Soutce window. An event binding is made of
three parts: the event handler, the listener or adapter implementation, and the code to
register the listener or adapter to the object triggering the event. The default name of
an event handler is the object name, followed by an underscore then the name of the
action that triggers the event.

form

A component that can only appear at the top level in the Objects view of the Project
window. Applet, Frame, Window, and some dialog components are forms. In the
Component Library, the Visual Cafe forms are all in the Forms group. When you open
a form in the Form Designer, the form boundaries are the bounds of the window.
You can position other components, such as text, buttons, and graphics, on the form;
these components are contained by the form.

frame

A Java Frame component is a general-purpose application window to which you can
add components and menus. See also component and container.

inner class

A class that is included within the body of another class, even within a method
(called a local class). An inner class is also called a nested class. This feature is new
for JDK 1.1 and is useful for creating adapter classes. After compilation, the inner
class ends up in its own class file, which has a dollar sign ($) in its name.

interaction

A relationship that you define between components, or a component and itself,
resulting in Visual Cafe—generated code. You can create an interaction between
components on one form, or between a component on one form and a top-level
component (such as having a button click open another form). An interaction
consists of one or more components, a trigger event, and an action. For example, you
can connect a button (the trigger component) to a text box (the action component)
so that when the user clicks on the button (the trigger event), the associated text box
is enabled for user input (the action).

interface

A set of methods and constants to be implemented by another object. It defines the
behavior, or certain characteristics, that another object implements. An interface can
define abstract methods and final fields, but not the implementation of them.
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introspection

The ability to read JavaBeans classes directly with the Core Reflection API using the
Introspector class. This information is stored in a BeanInfo object and includes data
such as properties, events, and all the accessible methods.

invisible component

See component.

Java Archive (JAR) file

Compressed archive file that complies with the JavaBeans standard. It is the primary
method for delivering JavaBeans components. For example, a JAR file can contain
one or more related beans, and any support files, including classes, icons, graphics,
sounds, HTML documentation, serialization files, and internationalization files. You
can deploy applets and applications from a JAR file. A JAR tool, called jar.exe on
Windows computers, archives and extracts JAR files and is provided with JDK 1.1. In
Visual Cafe, to use the JavaBeans components in a JAR file, you must first add the file
to the Component Library.

JavaBeans

A standard for creating portable, cross-platform components.

JavaBeans component

A component complying with the JavaBeans standard. Also called a bean or
JavaBean. A bean is a reusable component that can be visually manipulated in a
builder tool. The minimum requirements are that it can be instantiated (it is not an
abstract class or interface) and has a class constructor method that takes zero
parameters (it has a null constructor). It can also have properties and events,
implement the serializable or externalizable interface, and follow method signature
rules so it can be introspected.

Java Virtual Machine

The Java Virtual Machine (Java VM) contains a bytecode translator that converts the

downloaded binary Java files into instructions to be executed by the client machine.
The Java VM also contains the library routines that are called by a Java applet.

join

Ajoin is a definition of a master/detail relatonship. Only detail views have joins. The

Join properties for a detail RelationView define a join.

layout manager
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The layout is a property of container components that automatically arranges
components within the container so that they display well on different platforms and
screens, and at different resolutions.

listener

An event listener is an object that has defined the listener interface for a specific
event. After this interface has been implemented in a class, an instance of this class
may be registered as an event listener. When an event is generated, the event is sent
to the object, as well as all other registered listeners.

master/detail relationship

This is a relationship between a master view and a detail view. The join of the detail
view defines the relationship.

method

A procedure thatis defined as part of an object and acts on an object that is based on
that object. It is a collection of statements that perform a complex operation. When a
method is called, the instructions in the method are performed and the result is
returned to the statement that made the call.

nested class

See inner class.

package

A Java package is a group of related Java classes and interfaces. It is both a way of
organizing code and a library of code. You can view the source files and packages of
a project in the Package view of the Project window.

panel

A Java Panel componentis a general-purpose container that can be added to another
container. A panel has no visible border and can be used to break up windows into
logical regions. See also component and container.

project

For an application, a Visual Cafe projectis a collection of components and code that
make up the application. For applets, a Visual Cafe projectis a collection of
components and code that make up an applet or a group of related applets; it
optionally contains one or more HTML files that the applets run in.

property
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A named attribute of a component. Properties define component characteristics such
as the size, color, label, and state — for example, enabled or disabled.

RelationView

A Visual Cafe component that represents a view of data that’s defined by an SQL
statement.

top-level component

A component that can only appear at the top level in the Objects view of the Project
window. Also called a form. Applet, Frame, Window, and some dialog components
are top-level components. In the Component Library, the Visual Cafe top-level
components are all in the Forms group. When you open a top-level component in
the Form Designer, the component boundaries are the bounds of the window. You
can position other components, such as text, buttons, and graphics, on the top-level
component in the Form Designer; these components are contained by the top-level
component.

visual component

See component.

view

A view is a virtual database table that exists only in memory.

window

A Java Window component, which is based on the Window class, is an area that has
no borders and no menu bar. See also component and container.
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