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Block Breaker is an exciting action game.

To learn how to use Help, press F1.
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How to Play Block Breaker

Object
Object of this game is to break all the blocks (except Gold blocks) by hitting the ball with the paddle. 

Open Block Patterns
First, Use Open command to open a block pattern file to play.
 
Mouse 
By default, you can use mouse to control the paddle.    Press the left mouse button to start the ball 
moving, and the right mouse button to pause.

Keyboard
If you would like to control the paddle by keyboard, you can do so by selecting "Keyboard" from Control 
command.    Press the left or right arrow key to move the paddle.    By pressing the Shift key with an arrow
key, you can move the paddle faster.    Press the space bar to start the ball moving, and the Esc key to 
pause. 

Block Types 

Gold blocks    These blocks can not be broken. 
Silver blocks    These blocks will break after being hit three times. 
Colored blocks    These blocks will break after a single hit. 

Game Mode
There are three modes in this game: Play, Demo and Editor.    The paddle will move automatically in the 
Demo mode.    In the Editor mode, you can create your own Block pattern files.



How to Use Block Breaker Editor

The Block Breaker Editor will allow you to create your own patterns.    

Mouse
Click the left mouse button on the pallet to choose a block color. Then click the left mouse button in the 
grid to add a block to the pattern. You can remove blocks by clicking the right mouse button.



File menu commands

The File menu offers the following commands:

New Creates a new Block pattern.
Open Opens an existing Block pattern.
Save Saves an opened Block pattern using the same file name.
Save As Saves an opened Block pattern to a specified file name.
Exit Exits Block Breaker.



Edit menu commands

The Edit menu offers the following commands:

Add Bonus Ball when This Stage 
Cleared

Checking this menu will cause an extra ball 
to be added after completing the current 
stage when playing the game.

Message when All Stages 
Cleared

Allows you to edit the message 
displayed when all stages are cleared. 

Delete This Stage Deletes the contents of the current 
editing stage. 



Game menu commands

The Game menu offers the following commands:

Play Switches to the play game mode.
Demonstra
tion

Switches to the demonstration game mode.

Edit Switches to the Block Breaker Editor mode.
Pause Pauses or resumes the moving ball.

View menu commands

The View menu offers the following commands:

Stage 
Forward

Advances to the next stage of the game.

Stage 
Backward

Returns to the previous stage of the game.

Zoom Allows you to change the zooming.

Toolbar Shows or hides the toolbar.
Status Bar Shows or hides the status bar.

Option menu commands

The Option menu offers the following commands:

Speed Allows you to change the ball moving speed.
Control Allows you to change mouse or keyboard to control the 

ball, and shows or hides mouse cursor.
Sound Allows you to control sound settings.



Help menu commands

The Help menu offers the following commands: 

Contents Offers you the Help contents.
Search 
for Help 
on

Offers you the Help Index where you can find the Help 
topics.

Using 
Help

Provides general instructions on using help.

About Displays the version number of Block Breaker.



New command (File menu)

Use this command to create a new Block pattern in Block Breaker.

You can open an existing Block pattern with the Open command.

Shortcuts

Toolbar:
Keys: CTRL+N



Open command (File menu)

Use this command to open an existing Block pattern in a new window.    File Open dialog box 
will appear.

You can create new Block patterns with the New command.

Shortcuts

Toolbar:
Keys: CTRL+O



File Open dialog box

The following options allow you to specify which file to open:
File Name

Type or select the filename you want to open.    This box lists files with the extension you 
select in the List Files of Type box. 

List Files of Type
Select the type of file you want to open:
Only Block pattern files with .blc extension can be opened.

Drives
Select the drive in which Block Breaker stores the file that you want to open. 

Directories
Select the directory in which Block Breaker stores the file that you want to open.



Save command (File menu)

Use this command to save the active Block pattern to its current name and directory.    When
you save a Block pattern for the first time, Block Breaker displays the Save As dialog box so 
you can name your Block pattern.    If you want to change the name and directory of an 
existing Block pattern before you save it, choose the Save As command.

Shortcuts

Toolbar:
Keys: CTRL+S



Save As command (File menu)

Use this command to save and name the active Block pattern.    Block Breaker displays the 
Save As dialog box so you can name your Block pattern.    

To save a Block pattern with its existing name and directory, use the Save command.



File Save As dialog box

The following options allow you to specify the name and location of the file you're about to 
save:
File Name

Type a new filename to save a Block pattern with a different name.    A filename can 
contain up to eight characters and an extension of up to three characters.    Block 
Breaker adds the extension you specify in the Save File As Type box.

Drives
Select the drive in which you want to store the Block pattern.

Directories
Select the directory in which you want to store the Block pattern.

Network...
Choose this button to connect to a network location, assigning it a new drive letter. 



Exit command (File menu)

Use this command to end your Block Breaker session.    You can also use the Close command
on the application Control menu.    Block Breaker prompts you to save Block patterns with 
unsaved changes.

Shortcuts
Mouse: Double-click the application's Control menu button.

Keys: ALT+F4



Play command (Game menu)

Switches the game mode to Play mode.    This is where you play the game.

Shortcuts

Toolbar:
Keys: CTRL+P



Demonstration command (Game menu)

Switches the game mode to Demonstration mode.    The demonstration will not advance to 
the next stage automatically.

Shortcuts

Toolbar:
Keys: CTRL+D



Edit command (Game menu)

Switches the game mode to Block Breaker Editor mode.    You can edit your original Block 
patterns.    This command is enable only for registered users.

Shortcuts

Toolbar:
Keys: CTRL+E



Pause command (Game menu)

Pauses or resumes the moving ball.    To resume the ball, repeat the command, or use one of 
the following short cuts.

Shortcuts
Mouse Right click to pause, Left click to resume

Toolbar:
Keys: Esc to resume and pause, Space bar to resume



Add Bonus Ball when This Stage Cleared command (Edit menu)

Checking this command will cause an extra ball to be added after completing the current 
stage when playing the game. 

Shortcuts

Toolbar:



Message when All Stages Cleared command (Edit menu)

Allows you to edit the message displayed when all stages are cleared.

Shortcuts

Toolbar:



Message when All Stages Cleared Dialog box

Edit the final message when all stages are cleared.    You can enter multiple lines of the 
message, and the message can contains up to 255 characters.    



Delete This Stage command (Edit menu)

Deletes the contents of the current editing stage.



Stage Forward command (View menu)

Advances to the next stage of the game.

Shortcuts

Toolbar:
Keys: CTRL+F



Stage Backward command (View menu)

Returns to the previous stage of the game.

Shortcuts

Toolbar:
Keys: CTRL+P



Zoom command (View menu)

Use this command to zoom the view.    Block Breaker displays the Zoom dialog box so you 
can change the zoom settings.    



Zoom Dialog box

Specify the zooming value.    The Block Breaker Window will be resized automatically 
according to the zooming value.    To select 75% or 100%, you need higher graphic resolution
to display.    With VGA which is a general graphic resolution, only 50% can be selected. 



Toolbar command (View menu)

Use this command to display and hide the Toolbar, which includes buttons for some of the 
most common commands in Block Breaker.    A check mark appears next to the command 
name when the Toolbar is displayed.

See Toolbar for help on using the toolbar.



Toolbar

The toolbar is displayed across the top of the application window, below the menu bar.    The 
toolbar provides quick mouse access to many tools used in Block Breaker,

To hide or display the Toolbar, choose Toolbar from the View menu.

Click To

Open a new Block pattern.    (In an Edit mode only)

Open an existing Block pattern.    Block Breaker displays the Open dialog box, in 
which you can locate and open the desired file.

Save the active Block pattern.    If you have not named the document, Block Breaker 
displays the Save As dialog box.    (In an Edit mode only)

Enable or disable a bonus ball to be added when the current stage is cleared when 
you play.    (In an Edit mode only)

Edit an message displayed when all stages are cleared.    (In an Edit mode only)

Switch to the play mode.

Switch to the demonstration mode.

Switch to the editor mode.

Return to the previous stage

Advance to the next stage

Pause or resumes the moving ball.

Set the ball speed slow.

Set the ball speed normal.



Set the ball speed fast.

Set the ball speed very fast.

Enable or disable the music.

Enable or disable the sound effect.

Activate the context-sensitive Help.



Status Bar command (View menu)

Use this command to display and hide the Status Bar, which describes the action to be 
executed by the selected menu item or depressed toolbar button, and keyboard latch state. 
A check mark appears next to the command name when the Status Bar is displayed.

See Status Bar for help on using the status bar.



Status Bar

The status bar is displayed at the bottom of the Block Breaker window.    To display or hide 
the status bar, use the Status Bar command in the View menu.

The status bar indicates the following game status:

Indicator Description
Stage The order number of the current stage.
High Score The highest score achieved in past for the current Block pattern.
Score The current score of the current Block pattern in a Play mode.
Ball Left The number of remaining balls.



Speed command (Option menu)

Allows you to set the ball speed.    Block Breaker displays the Speed dialog box so you can 
change the ball speed.

Shortcuts

Toolbar:



Speed Dialog box

Select the ball speed.    Slow will slow ball most, and Turbo will make the ball fastest.



Speed - Slow command (Toolbar)

Allows you to slow the ball most.    This command is enable only when the Play or 
Demonstration command is checked in the Game menu.

Shortcuts

Toolbar:
 



Speed - Normal command (Toolbar)

Allows you to make the ball speed normal.    This command is enable only when the Play or 
Demonstration command is checked in the Game menu.

Shortcuts

Toolbar:
 



Speed - Fast command (Toolbar)

Allows you to make the ball speed fast.    This command is enable only when the Play or 
Demonstration command is checked in the Game menu.

Shortcuts

Toolbar:
 



Speed - Turbo command (Toolbar)

Allows you to make the ball speed fastest.    This command is enable only when the Play or 
Demonstration command is checked in the Game menu.

Shortcuts

Toolbar:
 



Control command (Option menu)

Allows you to change mouse or keyboard to control the ball, and shows or hides mouse 
cursor.    Block Breaker displays the Control dialog box so you can set these control settings.   
This command is enable only when the Play command is checked in the Game menu.



Control Dialog box

Allows you to change mouse or keyboard to control the ball, and shows or hides mouse 
cursor. 

Control
If you choose Mouse, the paddle will follow the same horizontal position as the mouse 
cursor.    If you choose Keyboard, you can control the paddle with the right or left arrow keys 
on your keyboard.    To move the paddle faster on the keyboard, press the Shift key as you 
press the arrow keys.

Hide Mouse Cursor
Checking this box will hide the mouse cursor when you play.    Check this if the mouse cursor 
annoys you.



Sound command (Option menu)

Allows you to change the sound settings.    Block Breaker displays the Sound dialog box so 
you can set these control settings.

Shortcuts

Toolbar:

 



Sound - Music command (Toolbar)

Enable or disable the music.

Shortcuts

Toolbar:  



Sound - Effect command (Toolbar)

Enable or disable the sound effect.

Shortcuts

Toolbar:  



Sound Dialog box

Allows you to set the sound settings.    To play the music or sound effect, you need to have a 
PC equipped with a Microsoft Windows compatible sound card or a Multimedia PC.

Music
If this checkbox is selected, the music will be play when the game begins.

Music Settings
Click this button to display Music Settings Dialog box so you can select the music files,

Effect
If this checkbox is selected, the sound effect will be played when a ball hits the paddle or 
bricks.

Effect Settings
Click this button to display Sound Dialog box in Control Panel so you can assign your favorite
sound files to various events.



Music Settings Dialog box

You can have your favorite music playing during the various events.    The music files must 
be Windows standard MIDI files.

Demonstration
Enter a music file path to be played during the demonstration.

Play
Enter a music file path to be played during the play.

Game Over
Enter a music file path to be played during the game is over.

Browse
Press this button to find music file location.



Sound Settings Dialog box

You can assign sound files to various events.    The sound files must be Windows WAVE 
format files.

Event
Choose an event where you want to assign sound a file.

Sound File
Choose a sound file for the event selected.

Test
Press this button if you want to test the selected sound file.



Copyright

Bloock Breaker is now Freeware.    You can freely use, copy and distribute this software.    You have no 
obligation to send moeny.    The 9 new patterns (easy.blc, geom.blc, hi.blc, mosaic.blc, paths.blc, 
quikeze.blc, wall2.blc, walls.blc and zee.blc) were created by Jay Gerard (CIS: 76500,3504).

CompuServe      73560,2250
Internet        QFG02250@niftyserve.or.jp
Yutaka Emura



Contents command (Help menu)

Use this command to display the opening screen of Help.    From the opening screen, you can
jump to step-by-step instructions for using Block Breaker and various types of reference 
information.    

Once you open Help, you can click the first button on the left in the Help window whenever 
you want to return to the opening screen.



Search for Help on command (Help menu)

Use this command to display the Help index.    



How to Use Help command (Help menu)

Use this command for instructions about using Help.



About command (Help menu)

Use this command to display the copyright notice and version number of your copy of Block 
Breaker.



Context Help command 

Use the Context Help command to obtain help on some portion of Block Breaker.    When you 
choose the Toolbar's Context Help button, the mouse pointer will change to an arrow and 
question mark.    Then click somewhere in the Block Breaker window, such as another Toolbar
button.    The Help topic will be shown for the item you clicked.

Shortcut
Keys: SHIFT+F1



Title Bar

The title bar is located along the top of a window.    It contains the name of the application 
and Block pattern.

To move the window, drag the title bar.    Note: You can also move dialog boxes by dragging 
their title bars.

A title bar may contain the following elements:
Application Control-menu button

Block pattern Control-menu button

Minimize button

Name of the application

Name of the Block pattern



Size command (System menu)

This command cannot be used in Block Breaker.



Move command (Control menu)

Use this command to display a four-headed arrow so you can move the active window or 
dialog box with the arrow keys.

Note:    This command is unavailable if you maximize the window.

Shortcut
Keys: CTRL+F7



Minimize command (application Control menu)

Use this command to reduce the Block Breaker window to an icon.

Shortcut

Keys: ALT+F9



Maximize command (System menu)

This command cannot be used in Block Breaker



Next Window command (Block pattern Control menu)

Use this command to switch to the next open Block pattern window.    Block Breaker 
determines which window is next according to the order in which you opened the windows.

Shortcut
Keys: CTRL+F6



Previous Window command (Block pattern Control menu)

Use this command to switch to the previous open Block pattern window.    Block Breaker 
determines which window is previous according to the order in which you opened the 
windows.

Shortcut
Keys: SHIFT+CTRL+F6



Close command (Control menus)

Use this command to close the active window or dialog box.

Double-clicking a Control-menu box is the same as choosing the Close command.

Note:    If you have multiple windows open for a single Block pattern, the Close command on 
the Block pattern Control menu closes only one window at a time.    You can close all 
windows at once with the Close command on the File menu.

Shortcuts
Keys: ALT+F4 closes the Block Breaker window or dialog box



Restore command (Control menu)

Use this command to return the active window to its size and position before you chose the 
Minimize command.



Switch to command (application Control menu)

Use this command to display a list of all open applications.    Use this "Task List" to switch to 
or close an application on the list.

Shortcut
Keys: CTRL+ESC

Dialog Box Options
When you choose the Switch To command, you will be presented with a dialog box with the 
following options:
Task List

Select the application you want to switch to or close.
Switch To

Makes the selected application active.
End Task

Closes the selected application.
Cancel

Closes the Task List box.
Cascade

Arranges open applications so they overlap and you can see each title bar.    This option 
does not affect applications reduced to icons.

Tile
Arranges open applications into windows that do not overlap.    This option does not 
affect applications reduced to icons.

Arrange Icons
Arranges the icons of all minimized applications across the bottom of the screen.



No Help Available

No help is available for this area of the window.



No Help Available

No help is available for this message box.




