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File menu commands

The File menu offers the following commands:

New Creates a new document.
Open Opens an existing document.
Close Closes an opened document.
Save Saves an opened document using the same file name.
Save As Saves an opened document to a specified file name.
Print Prints a document.
Print Preview Displays the document on the screen as it would appear printed.
Print Setup Selects a printer and printer connection.
Page Layout Set a page layout for printing.
Exit Exits PEM EdTex.



Edit menu commands

The Edit menu offers the following commands:

Undo Reverse previous editing operation.
Redo Redo the previous Undo command.
Cut Deletes data from the document and moves it to the clipboard.
Copy Copies data from the document to the clipboard.
Add Cut Deletes data from the document and adds it to the clipboard.
Add Copy Copies data from the document and adds it to the clipboard.
Paste Pastes data from the clipboard into the document.
Find Find the specified text.
Replace Replace specified text with different text.
Global Find Find the specfied text in the specified files.
Move:Right Move the selected text to the right edge.
Move:Center Move the selected text to the center.
Convert:Tab->Space Convert tabs in the specified area to spaces.
Convert:Space->Tab Convert spaces in the specified area to tabs.
Select All Select the entire document
Read Only Toggle the active file read-only status.



View menu commands

The View menu offers the following commands:

Go To Line Go to the specified line number.
Bookmark Set or reset bookmarks and move to the specified position.
Text Mark Set or reset text marks and move to the specified position.
Tag Move to the specified tag position.
Ruler/Bar:Column 
Ruler

Shows or hides the column ruler.

Ruler/Bar:Line Ruler Shows or hides the line ruler.
Ruler/Bar:Toolbar Shows or hides the toolbar.
Ruler/Bar:Status Bar Shows or hides the status bar.



Window menu commands

The Window menu offers the following commands, which enable you to arrange multiple views of multiple
documents in the application window:

New Window Creates a new window that views the same document.
Cascade Arranges windows in an overlapped fashion.
Tile Arranges windows in non-overlapped tiles.
Arrange Icons Arranges icons of closed windows.
Window Mark Set or reset window marks and move to the specified window.
Window 1, 2, ... Goes to specified window.



Help menu commands

The Help menu offers the following commands, which provide you assistance with this application: 

Index Offers you an index to topics on which you can get help.
Using Help Provides general instructions on using help.
About 
Registration

Displays the description about the registration.

About Displays the version number of this application.



New command (File menu)

Use this command to create a new document in PEM EdTex.
You can open an existing document with the Open command.



Open command (File menu)

Use this command to open an existing document in a new window.    You can open multiple documents at 
once.    Use the Window menu to switch among the multiple open documents.    See Window 1, 2, ... 
command.

You can create new documents with the New command.



File Open dialog box

The following options allow you to specify which file to open:
File Name

Type or select the filename you want to open.    This box lists files with the extension you select in the 
List Files of Type box. 

List Files of Type
Select the type of file you want to open:

Drives
Select the drive in which PEM EdTex stores the file that you want to open. 

Directories
Select the directory in which PEM EdTex stores the file that you want to open.

Network...
Choose this button to connect to a network location, assigning it a new drive letter. 



Close command (File menu)

Use this command to close all windows containing the active document.    PEM EdTex suggests that you 
save changes to your document before you close it.    If you close a document without saving, you lose all 
changes made since the last time you saved it.    Before closing an untitled document, PEM EdTex 
displays the Save As dialog box and suggests that you name and save the document.



Save command (File menu)

Use this command to save the active document to its current name and directory.    When you save a 
document for the first time, PEM EdTex displays the Save As dialog box so you can name your document.
If you want to change the name and directory of an existing document before you save it, choose the 
Save As command.



Save As command (File menu)

Use this command to save and name the active document.    PEM EdTex displays the Save As dialog box 
so you can name your document.    

To save a document with its existing name and directory, use the Save command.



File Save As dialog box

The following options allow you to specify the name and location of the file you're about to save:
File Name

Type a new filename to save a document with a different name.    A filename can contain up to eight 
characters and an extension of up to three characters.    PEM EdTex adds the extension you specify 
in the Save File As Type box.

Drives
Select the drive in which you want to store the document.

Directories
Select the directory in which you want to store the document.

Network...
Choose this button to connect to a network location, assigning it a new drive letter. 



1, 2, 3, 4 command (File menu)

Use the numbers and filenames listed at the bottom of the File menu to open the last four documents you 
closed.    Choose the number that corresponds with the document you want to open.



Exit command (File menu)

Use this command to end your PEM EdTex session.    You can also use the Close command on the 
application Control menu.    PEM EdTex prompts you to save documents with unsaved changes.



Undo command (Edit menu)

Use this command to reverse the last editing action, if possible. Now available only for editing text .



Redo command (Edit menu)

Redo the previously undone action.



Cut command (Edit menu)

Use this command to remove the currently selected data from the document and put it on the clipboard.    
This command is unavailable if there is no data currently selected.

Cutting data to the clipboard replaces the contents previously stored there.



Copy command (Edit menu)

Use this command to copy selected data onto the clipboard.    This command is unavailable if there is no 
data currently selected.

Copying data to the clipboard replaces the contents previously stored there.



Paste command (Edit menu)

Use this command to insert a copy of the clipboard contents at the insertion point.    This command is 
unavailable if the clipboard is empty.



Ruler/Bar:Toolbar command (View menu)

Use this command to display and hide the Toolbar, which includes buttons for some of the most common 
commands in PEM EdTex, such as File Open.    A check mark appears next to the menu item when the 
Toolbar is displayed.



Toolbar

The toolbar is displayed across the top of the application window, below the menu bar.    The toolbar 
provides quick mouse access to many tools used in PEM EdTex,

To hide or display the Toolbar, choose Toolbar from the View menu .

Click To

Open a new document.

Open an existing document.    PEM EdTex displays the Open dialog box, in which you can locate 
and open the desired file.

Save the active document or template with its current name.    If you have not named the 
document, PEM EdTex displays the Save As dialog box.

Print the active document.

Remove selected data from the document and stores it on the clipboard.

Copy the selection to the clipboard.

Insert the contents of the clipboard at the insertion point.



Status Bar command (View menu)

Use this command to display and hide the Status Bar, which describes the action to be executed by the 
selected menu item or depressed toolbar button, and keyboard latch state. A check mark appears next to 
the menu item when the Status Bar is displayed.

See Status Bar for help on using the status bar.



Status Bar
The status bar is displayed at the bottom of the PEM EdTex window.    To display or hide the status bar, 
use the Status Bar command in the View menu.

The left area of the status bar describes actions of menu items as you use the arrow keys to navigate 
through menus.    This area similarly shows messages that describe the actions of toolbar buttons as you 
depress them, before releasing them.    If after viewing the description of the toolbar button command you 
wish not to execute the command, then release the mouse button while the pointer is off the toolbar 
button.



New command (Window menu)

Use this command to open a new window with the same contents as the active window.    You can open 
multiple document windows to display different parts or views of a document at the same time.    If you 
change the contents in one window, all other windows containing the same document reflect those 
changes.    When you open a new window, it becomes the active window and is displayed on top of all 
other open windows.



Cascade command (Window menu)

Use this command to arrange multiple opened windows in an overlapped fashion. 



Tile command (Window menu)

Use this command to arrange multiple opened windows in a non-overlapped fashion.



Window Arrange Icons Command

Use this command to arrange the icons for minimized windows at the bottom of the main window.    If 
there is an open document window at the bottom of the main window, then some or all of the icons may 
not be visible because they will be underneath this document window.



1, 2, ... command (Window menu)

PEM EdTex displays a list of currently open document windows at the bottom of the Window menu.    A 
check mark appears in front of the document name of the active window.    Choose a document from this 
list to make its window active.    



Index command (Help menu)

Use this command to display the opening screen of Help.    From the opening screen, you can jump to 
step-by-step instructions for using PEM EdTex and various types of reference information.    

Once you open Help, you can click the Contents button whenever you want to return to the opening 
screen.



Using Help command (Help menu)

Use this command for instructions about using Help.



About command (Help menu)

Use this command to display the copyright notice and version number of your copy of PEM EdTex.



Context Help command 

Use the Context Help command to obtain help on some portion of PEM EdTex.    When you choose the 
Toolbar's Context Help button, the mouse pointer will change to an arrow and question mark.    Then click 
somewhere in the PEM EdTex window, such as another Toolbar button.    The Help topic will be shown for 
the item you clicked.

Shortcut
Keys: SHIFT+F1



No Help Available

No help is available for this area of the window.



No Help Available

No help is available for this message box.



Page Layout

Margins
Set the paper margins. Necessary at least 5mm. To add a header and footer, about 10mm margins 
are necessary at theTop and Bottom.

Header,Footer
Texts typed in the boxes are printed as a header and footer to each printed page. The following 
characters are replaced with corresponded ones.
                  Replaced with
 &p : Page number
 &f : File name
 &d : Date(MM/DD/YY)
 &t : Time(HH:MM:SS)

Line Spaces, Column Spaces
To extend line spaces and column spaces, select the proper value except 0.

Initial Page Number
This number will be printed on the header or footer of the first page. It is increased for the next 
pages. Note that if you don't specify "&p" in the header or footer, none of page numbers are printed.

Initial Line Number
This number will be printed on the left edge of the first line. It is increased for the next lines. Note 
that if you don't check "Print Line Number", none of line numbers are printed.

Printing Font
Select a proper font for printing.

Print Line Number
If checked, a line number is printed on the left edge of each lines.



Add Cut command (Edit menu)

Use this command to remove the currently selected data from the document and add it on the clipboard.   
This command is unavailable if there is no data currently selected.



Add Copy command (Edit menu)

Use this command to add selected data onto the clipboard.    This command is unavailable if there is no 
data currently selected.



Find command (Edit menu)

Use this command to specify a search string and to search it. You can also use Find By ComboBox for 
searching.



Find By ComboBox

Use the combobox on the toolbar to specify a search string and to search it. Focus will be moved to the 
combobox by mouse clicking it or shortcut (Ctrl+F in default). Searching will be started by clicking the 
Find Execute Button right side of the combobox or enter key. To return to a document window, click the 
window by mouse or enter Esc key.



Replace command (Edit menu)

Use this command to specify search and replace strings.



Find In Files

You can search for strings in text files. Matching strings are listed with tag informations in a new Untitled 
window(tag window). You can use it to move to the searched strings. By double clicking the line in the tag 
window, the specified text window will be opend and the searched string will be displayed. You can also 
use the following shortcuts.

    Ctrl+F5 : Display the searched string with the current tag.
    F5                    : Display the searched string with the next tag.
    Shift+F5    : Display the searched string with the previous tag.

If you set a mark for the tag window by Ctrl+F6, you can return to the tag window immediately by F6.

Above shortcuts are default ones. If you have defined another assignments by Customize Key 
Assignment, operate according to them.



Move:Right

Move the text between the current caret and enter mark to the right edge on a line.



Move:Center

Move the text between the current caret and enter mark to the center of the caret and the right edge.



Convert:Tab->Space

Convert tabs in the current selected data to spaces. It takes more time for converting large data.



Convert:Space->Tab

Convert spaces in the current selected data to tabs. It takes more time for converting large data.



Select All

Select all text in the active document. At the top of document you can also select all text by 
Ctrl+Shift+End.



Read Only

Toggle the active document read-only status. This item will be saved in the cabinet file.



Bookmark

Maximum 100 bookmarks can be setted in a document. The line with bookmark will be colored with the 
specified color in the Cabinet:Color.If the previous line has no enter mark, you can't set bookmark to the 
current line. Bookmarks information will be saved in the attribute file(*.ATR). Note that if "Save Bookmark"
in Cabinet:Form does not checked, bookmarks information will not be saved.



Text Mark

Maximum 100 text marks can be setted in a document. Marked text will be colored with the specified color
in the Cabinet:Color. Maximum length allowed for a text mark is 40 characters. Text marks information will
be saved in the attribute file(*.ATR). Note that if "Save Text Mark" in Cabinet:Form does not checked, text 
marks information will not be saved.



Tag

Refer to Find In Files.



Ruler/Bar:Column Ruler

Show or hide the column ruler. Cursor and background colors can be customized by changing the 
following items in the .INI file.

    RulerCursorColor=4 : Column ruler cursor color(green in default).
    RulerBackColor=16 : Column ruler background color(silver in default).

The number on the righ side of "=" means the sequence appeared in the color combobox of 
Cabinet:Color dialog box.



Ruler/Bar:Line Ruler

Show or hide the line ruler. Cursor and background colors can be customized by changing the following 
items in the .INI file.

    LineCursorColor=4 : Line ruler cursor color(green in default).
    LineBackColor=16 :Line ruler background color(silver in default).

The number on the righ side of "=" means the sequence appeared in the color combobox of 
Cabinet:Color dialog box.



Go To Line

Move to the specified line number.



Cabinet menu commands

The Cabinet menu offers the following commands:

New Create a new cabinet.
Change Close the active cabinet and open an existing one.
Form Set a form for the active cabinet.
Color Set colors for the active cabinet.
Font Set font for the active cabinet.
Keyword Set keywords for the active cabinet.



Cabinet:New

Cabinet Name
Enter a cabinet file name to be created. ".CAB" will be added automatically.

Document Type
Select the type of documents maked in this cabinet.
The items different by the types are as follows.
 Columns per Line , Color C/C++ keywords or not , auto indent or not , How to calculate the line 
number 

The items can be changed after. For details refer to Cabinet:Form.



Cabinet:Change

Close the active cabinet and open the specified cabinet.



Cabinet:Form

Document Type
Normal document: C/C++ keywords are not colored.
C :Color C keywords.
C++ :Color C and C++ keywords.

Columns Per Line
Specify column counts per one line. From 20 to 250 available.

Tab Stops
Specify tab stops . From 2 to 20 available.

Free Cursor
ON    :Caret can be moved freely on available lines.
OFF:Caret can be moved only on available columns.

Auto Indent
ON :Indent automatically according to the previous line.
OFF:Don't indent.

Display Enter Mark
ON    :Display enter mark.
OFF:Don't display it.

Display Tab Mark
ON    :Display tab mark.
OFF:Don't display it.

Save Bookmark
ON    :Bookmarks information will be saved into the attribute file.
OFF:Not be saved.

Save Text Mark
ON    :Text marks information will be saved into the attribute file.
OFF:Not be saved.

Word Wrap
ON    :Available.
OFF:Unavailable

Line Number
This item means that how to calculate the line number.
As Screen :According to the line counts displayed on the screen.
As Enter Mark :According to the enter mark counts. 



Cabinet:Color

You can select your favorite colors.



Cabinet:Font

Select font used on the screen.



Cabinet:Keyword

Specify keywords for your using. Keywords will be colored. Maximum count is 300. Maximum keyword 
length is 30 characters.



Option menu commands

The Option menu offers the following commands:

Common Settings Set options for all cabinets.
Customize Key 
Assignment

Customize key assignments.

Start/Stop Recording Start recording of operations or stop it.
Play Play the recoded or loaded operation.
Save Save the recorded operations.
Load Load the saved operations.



Option:Common Settings

Save cabinet attributes
ON    :Save cabinet attributes( form, color, font, and keyword) to the cabinet file.
OFF:Don't save.

Start with the default cabinet
ON    :Start PEM EdTex with opening the default cabinet(EDTEX.CAB).
OFF:Start PEM EdTex with opening the previous cabinet.

Start without files in cabinet
ON    :Start PEM EdTex without opening files in cabinet. Available only cabinet attributes.
OFF:Start PEM EdTex with opening files in cabinet. Available cabinet attributes too.

Color "/* */" area
ON    :Color "/* */" area with the comment color. Available only when Document Type is C or C++. To
large document editting performance will be reduced if ON.
OFF:Don't color. 



Option:Customize Key Assignment

You can customize key assignments of menu/operation(playing)/others commands.

Type
Select command type to be customized.

Command, Key
If you click a command in the Command ListBox, it's current key assignment will be displayed in the
Key ListBox. If the Key ListBox is empty, it means that key assignment of the command is 
undefined.

Add
To add a new key assignment:
    -Select a command in the Command ListBox.
    -Set short cut key in the Shortcut.
    -Push the Add button.
    -Repeat the above operation for all commands to be customized.
    -Push OK button.

Delete
To delete an existing key assignment:
    -Select a command in the Command ListBox.
    -Select an existing key assignment to be deleted in the Key ListBox.
    -Push the Delete button.
    -Repeat the above operation for all key assignments to be deleted.
    -Push OK button.

List
To list current key assignments, push this button.



Option:Start/Stop Recording

You can record your operations and play it later. Recorded operations can be saved to a file and you can 
load and play them later. You can also use shortcuts to play them. Shortcuts can be assigned or changed 
in the Customizing Key Assignment too.

Note that the following operations can't be recorded.
    -Mouse operations for text.
    -System bar.
    -File:Exit/Print Setup command
    -View:Ruler/Bar command
    -Cabinet:Keyword command
    -Option command(except Common Settings )
    -Window command
    -Help command
    -Others



Option:Play

Play the recorded or loaded operations.



Option:Save

File Name
Specify a file name to be saved recorded or loaded operations.
".MAC" will be added to the end of the file name if not exist.

Shortcut
Specify a short cut key to load and play the operation if necessary. This shortcut can be changed 
later by Customizing Key Assignment.

Comment
Specify a comment to the operation if necessary.



Option:Load

File Name
Select the file to be loaded.

Play
Load the file and play it.

Delete
Delete the selected file.



Window:Window Mark

Maximum 10 windows can be marked. "*" will be added to the title of the marked window. 



Keyboard Operation

You can customize key assignments for menu commands, recorded operations and others by 
Customizing Key Assignment. Another key assignments are described here.

Caret Control
"arrows" :Up, down,left and right
Home :To top of the line.
End :To end of the line.
Ctrl+Home :To top of the document.
Ctrl+End :To end of the document.
PageUp :To previous page(screen).
PageDown :To next page(screen)

Selection
Shift+"arrows" :Up, down,left and right
Shift+Home :To top of the line.
Shift+End:To end of the line.
Shift+PageUp :To previous page(screen).
Shift+PageDown :To next page(screen)
Ctrl+Shift+Home :To top of the document.
Ctrl+Shift+End :To end of the document.

Note:Refer to Mouse Operation for block selection

Others
Insert :Switch to insert mode or overwrite mode.



Mouse Operation

Use only left button.
    Click :Move caret
    Drag :Select characters
    Ctrl+drag :Select block area
    Double click :Open the tag information. Refer to Find In Files.



About Registration

Displays the description about the registration.





Print command (File menu)

Use this command to print a document.      This command presents a Print dialog box, where 
you may specify the range of pages to be printed, the number of copies, the destination 
printer, and other printer setup options.

Shortcuts

Toolbar:
Keys: CTRL+P



Print dialog box

The following options allow you to specify how the document should be printed:
Printer

This is the active printer and printer connection.    Choose the Setup option to change the
printer and printer connection.

Setup
Displays a Print Setup dialog box, so    you can select a printer and printer connection.

Print Range
Specify the pages you want to print:
All Prints the entire document.
Selectio
n

Prints the currently selected text.

Pages Prints the range of pages you specify in the From and To boxes.
Copies

Specify the number of copies you want to print for the above page range.
Collate Copies

Prints copies in page number order, instead of separated multiple copies of each page.
Print Quality

Select the quality of the printing.    Generally, lower quality printing takes less time to 
produce.



Print Progress Dialog

The Printing dialog box is shown during the time that <<YourApp>> is sending output to the
printer.    The page number indicates the progress of the printing.

To abort printing, choose Cancel.



Print Preview command (File menu)

Use this command to display the active document as it would appear when printed.    When 
you choose this command, the main window will be replaced with a print preview window in 
which one or two pages will be displayed in their printed format.    The print preview toolbar 
offers you options to view either one or two pages at a time; move back and forth through 
the document; zoom in and out of pages; and initiate a print job.



Print Preview toolbar

The print preview toolbar offers you the following options:
Print

Bring up the print dialog box, to start a print job.
Next Page

Preview the next printed page.
Prev Page

Preview the previous printed page.
One Page / Two Page

Preview one or two printed pages at a time.
Zoom In

Take a closer look at the printed page.
Zoom Out

Take a larger look at the printed page.
Close

Return from print preview to the editing window.



Print Setup command (File menu)

Use this command to select a printer and a printer connection.    This command presents a 
Print Setup dialog box, where you specify the printer and its connection.



Print Setup dialog box

The following options allow you to select the destination printer and its connection.
Printer

Select the printer you want to use.    Choose the Default Printer; or choose the Specific 
Printer option and select one of the current installed printers shown in the box.    You 
install printers and configure ports using the Windows Control Panel. 

Orientation
Choose Portrait or Landscape.

Paper Size
Select the size of paper that the document is to be printed on.

Paper Source
Some printers offer multiple trays for different paper sources.    Specify the tray here.

Options
Displays a dialog box where you can make additional choices about printing, specific to 
the type of printer you have selected.

Network...
Choose this button to connect to a network location, assigning it a new drive letter.



Page Setup command (File menu)

<< Write application-specific help here. >>

    




