NETXP.Components

NetXP 3.0 Reference

NETXP.Components Namespace

Classes

Class | Description
CompBrowser | CompBrowser is a form that provides built-in capability to list the computers on a network.
FlagsEditor | Implements a custom type editor.
ImageStore | This component stores an image into the resources for use at runtime, such as adding it to an ImageList and preserving transparency.
NotifyIconEx | This component provides extended notify icon functionality.
TaskbarNotifier | TaskbarNotifier allows you to display MSN style/Skinned instant messaging popups.
XTimer | XTimer is an enhanced high-precision timer using Win32 performance counters.

Enumerations

Enumeration | Description
NotifyInfoFlags | Flags for balloon tip's icon.
TaskbarNotifier.TaskbarStates | List of the different popup animation status

Copyright © 2004 Dacris Software Inc. All Rights Reserved.


CompBrowser Class

CompBrowser is a form that provides built-in capability to list the computers on a network.

For a list of all members of this type, see CompBrowser Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
CompBrowser

[Visual Basic]
Public Class CompBrowser
Inherits Form
[C#]
public class CompBrowser : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Components

Assembly: NETXP.Components (in NETXP.Components.dll)

See Also

CompBrowser Members | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


CompBrowser Members

CompBrowser overview

Public Instance Constructors

CompBrowser Constructor Constructs a new CompBrowser form.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) |
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScale (inherited from Form) | Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | [To be supplied.]
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsRestrictedWindow (inherited from Form) |
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
SelectedComputer | The name of the selected computer.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) |
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as the top-most form of your application.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PopulateTree | Populates the main tree view.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Control) | Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with no owner window.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is not the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) |
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

CompBrowser Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


CompBrowser Constructor

Constructs a new CompBrowser form.

[Visual Basic]
Public Sub New()
[C#]
public CompBrowser();

See Also

CompBrowser Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


CompBrowser Properties

The properties of the CompBrowser class are listed below. For a complete list of CompBrowser class members, see the CompBrowser Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) |
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScale (inherited from Form) | Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | [To be supplied.]
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsRestrictedWindow (inherited from Form) |
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
SelectedComputer | The name of the selected computer.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) |
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as the top-most form of your application.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

CompBrowser Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


CompBrowser.SelectedComputer Property

The name of the selected computer.

[Visual Basic]
Public Property SelectedComputer As String
[C#]
public string SelectedComputer {get; set;}

See Also

CompBrowser Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


CompBrowser Methods

The methods of the CompBrowser class are listed below. For a complete list of CompBrowser class members, see the CompBrowser Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PopulateTree | Populates the main tree view.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Control) | Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with no owner window.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

CompBrowser Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


CompBrowser.PopulateTree Method

Populates the main tree view.

[Visual Basic]
Public Sub PopulateTree()
[C#]
public void PopulateTree();

See Also

CompBrowser Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


FlagsEditor Class

Implements a custom type editor.

For a list of all members of this type, see FlagsEditor Members.

System.Object
UITypeEditor
FlagsEditor

[Visual Basic]
Public Class FlagsEditor
Inherits UITypeEditor
[C#]
public class FlagsEditor : UITypeEditor

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Components

Assembly: NETXP.Components (in NETXP.Components.dll)

See Also

FlagsEditor Members | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


FlagsEditor Members

FlagsEditor overview

Public Instance Constructors

FlagsEditor Constructor Initializes a new instance of the FlagsEditor class.

Public Instance Methods

EditValue | Overloaded. Overrides the method used to provide basic behavior for selecting editor. Shows our custom control for editing the value.
EditValue (inherited from UITypeEditor) | Overloaded. Edits the value of the specified object using the editor style indicated by GetEditStyle.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEditStyle | Overloaded. Shows a dropdown icon in the property editor.
GetEditStyle (inherited from UITypeEditor) | Overloaded. Gets the editor style used by the EditValue method.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPaintValueSupported (inherited from UITypeEditor) | Overloaded. Indicates whether the specified context supports painting a representation of an object's value within the specified context.
GetType (inherited from Object) | Gets the Type of the current instance.
PaintValue (inherited from UITypeEditor) | Overloaded. Paints a representation of the value of an object using the specified PaintValueEventArgs.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FlagsEditor Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


FlagsEditor Constructor

Initializes a new instance of the FlagsEditor class.

[Visual Basic]
Public Sub New()
[C#]
public FlagsEditor();

See Also

FlagsEditor Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


FlagsEditor Methods

The methods of the FlagsEditor class are listed below. For a complete list of FlagsEditor class members, see the FlagsEditor Members topic.

Public Instance Methods

EditValue | Overloaded. Overrides the method used to provide basic behavior for selecting editor. Shows our custom control for editing the value.
EditValue (inherited from UITypeEditor) | Overloaded. Edits the value of the specified object using the editor style indicated by GetEditStyle.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEditStyle | Overloaded. Shows a dropdown icon in the property editor.
GetEditStyle (inherited from UITypeEditor) | Overloaded. Gets the editor style used by the EditValue method.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPaintValueSupported (inherited from UITypeEditor) | Overloaded. Indicates whether the specified context supports painting a representation of an object's value within the specified context.
GetType (inherited from Object) | Gets the Type of the current instance.
PaintValue (inherited from UITypeEditor) | Overloaded. Paints a representation of the value of an object using the specified PaintValueEventArgs.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FlagsEditor Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


EditValue Method

NetXP 3.0 Reference

FlagsEditor.EditValue Method

Overrides the method used to provide basic behavior for selecting editor. Shows our custom control for editing the value.

Overload List

Overrides the method used to provide basic behavior for selecting editor. Shows our custom control for editing the value.

public override object EditValue(ITypeDescriptorContext,IServiceProvider,object);

Inherited from UITypeEditor.

public object EditValue(IServiceProvider,object);

See Also

FlagsEditor Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


FlagsEditor.EditValue Method (ITypeDescriptorContext, IServiceProvider, Object)

Overrides the method used to provide basic behavior for selecting editor. Shows our custom control for editing the value.

[Visual Basic]
Overrides Overloads Public Function EditValue( _
ByVal context As ITypeDescriptorContext, _
ByVal provider As IServiceProvider, _
ByVal value As Object _
) As Object
[C#]
public override object EditValue(
ITypeDescriptorContext context,
IServiceProvider provider,
object value
);

Parameters

context
The context of the editing control
provider
A valid service provider
value
The current value of the object to edit

Return Value

The new value of the object

See Also

FlagsEditor Class | NETXP.Components Namespace | FlagsEditor.EditValue Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


GetEditStyle Method

NetXP 3.0 Reference

FlagsEditor.GetEditStyle Method

Shows a dropdown icon in the property editor.

Overload List

Inherited from UITypeEditor.

public UITypeEditorEditStyle GetEditStyle();

Shows a dropdown icon in the property editor.

public override UITypeEditorEditStyle GetEditStyle(ITypeDescriptorContext);

See Also

FlagsEditor Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


FlagsEditor.GetEditStyle Method (ITypeDescriptorContext)

Shows a dropdown icon in the property editor.

[Visual Basic]
Overrides Overloads Public Function GetEditStyle( _
ByVal context As ITypeDescriptorContext _
) As UITypeEditorEditStyle
[C#]
public override UITypeEditorEditStyle GetEditStyle(
ITypeDescriptorContext context
);

Parameters

context
The context of the editing control

Return Value

Returns UITypeEditorEditStyle.DropDown

See Also

FlagsEditor Class | NETXP.Components Namespace | FlagsEditor.GetEditStyle Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


ImageStore Class

This component stores an image into the resources for use at runtime, such as adding it to an ImageList and preserving transparency.

For a list of all members of this type, see ImageStore Members.

System.Object
MarshalByRefObject
Component
ImageStore

[Visual Basic]
Public Class ImageStore
Inherits Component
[C#]
public class ImageStore : Component

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Components

Assembly: NETXP.Components (in NETXP.Components.dll)

See Also

ImageStore Members | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


ImageStore Members

ImageStore overview

Public Instance Constructors

ImageStore Overloaded. Initializes a new instance of the ImageStore class.

Public Instance Properties

Container (inherited from Component) | Gets the IContainer that contains the Component.
Image | The image to store in resources.
Site (inherited from Component) | Gets or sets the ISite of the Component.

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
ToString (inherited from Component) |

Public Instance Events

Disposed (inherited from Component) Adds an event handler to listen to the Disposed event on the component.

See Also

ImageStore Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


ImageStore Constructor

Constructs a new ImageStore component and assigns it to a container.

Overload List

Constructs a new ImageStore component.

public ImageStore();

Constructs a new ImageStore component and assigns it to a container.

public ImageStore(IContainer);

See Also

ImageStore Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


ImageStore Constructor (IContainer)

Constructs a new ImageStore component and assigns it to a container.

[Visual Basic]
Overloads Public Sub New( _
ByVal container As IContainer _
)
[C#]
public ImageStore(
IContainer container
);

Parameters

container
The container to which to assign this component.

See Also

ImageStore Class | NETXP.Components Namespace | ImageStore Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


ImageStore Constructor ()

Constructs a new ImageStore component.

[Visual Basic]
Overloads Public Sub New()
[C#]
public ImageStore();

See Also

ImageStore Class | NETXP.Components Namespace | ImageStore Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


ImageStore Properties

The properties of the ImageStore class are listed below. For a complete list of ImageStore class members, see the ImageStore Members topic.

Public Instance Properties

Container (inherited from Component) | Gets the IContainer that contains the Component.
Image | The image to store in resources.
Site (inherited from Component) | Gets or sets the ISite of the Component.

See Also

ImageStore Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


ImageStore.Image Property

The image to store in resources.

[Visual Basic]
Public Property Image As Image
[C#]
public System.Drawing.Image Image {get; set;}

See Also

ImageStore Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


NotifyIconEx Class

This component provides extended notify icon functionality.

For a list of all members of this type, see NotifyIconEx Members.

System.Object
MarshalByRefObject
Component
NotifyIconEx

[Visual Basic]
Public Class NotifyIconEx
Inherits Component
[C#]
public class NotifyIconEx : Component

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Components

Assembly: NETXP.Components (in NETXP.Components.dll)

See Also

NotifyIconEx Members | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


NotifyIconEx Members

NotifyIconEx overview

Public Instance Constructors

NotifyIconEx Constructor Constructs a new NotifyIconEx.

Public Instance Properties

Container (inherited from Component) | Gets the IContainer that contains the Component.
ContextMenu | The context menu to be shown if item is right-clicked.
Icon | Icon for this item.
Site (inherited from Component) | Gets or sets the ISite of the Component.
Text | Text for this item.
Visible | Configures visibility.

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Remove | Removes the icon from the tray.
ShowBalloon | Shows a balloon for the icon.
ToString (inherited from Component) |

Public Instance Events

BalloonClick | Balloon was clicked.
Click | Item was clicked.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DoubleClick | Item was double-clicked.
RightClick | Item was right-clicked.

See Also

NotifyIconEx Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


NotifyIconEx Constructor

Constructs a new NotifyIconEx.

[Visual Basic]
Public Sub New()
[C#]
public NotifyIconEx();

See Also

NotifyIconEx Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


NotifyIconEx Properties

The properties of the NotifyIconEx class are listed below. For a complete list of NotifyIconEx class members, see the NotifyIconEx Members topic.

Public Instance Properties

Container (inherited from Component) | Gets the IContainer that contains the Component.
ContextMenu | The context menu to be shown if item is right-clicked.
Icon | Icon for this item.
Site (inherited from Component) | Gets or sets the ISite of the Component.
Text | Text for this item.
Visible | Configures visibility.

See Also

NotifyIconEx Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


NotifyIconEx.ContextMenu Property

The context menu to be shown if item is right-clicked.

[Visual Basic]
Public Property ContextMenu As ContextMenu
[C#]
public System.Windows.Forms.ContextMenu ContextMenu {get; set;}

See Also

NotifyIconEx Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


NotifyIconEx.Icon Property

Icon for this item.

[Visual Basic]
Public Property Icon As Icon
[C#]
public System.Drawing.Icon Icon {get; set;}

See Also

NotifyIconEx Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


NotifyIconEx.Text Property

Text for this item.

[Visual Basic]
Public Property Text As String
[C#]
public string Text {get; set;}

See Also

NotifyIconEx Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


NotifyIconEx.Visible Property

Configures visibility.

[Visual Basic]
Public Property Visible As Boolean
[C#]
public bool Visible {get; set;}

See Also

NotifyIconEx Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


NotifyIconEx Methods

The methods of the NotifyIconEx class are listed below. For a complete list of NotifyIconEx class members, see the NotifyIconEx Members topic.

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Remove | Removes the icon from the tray.
ShowBalloon | Shows a balloon for the icon.
ToString (inherited from Component) |

See Also

NotifyIconEx Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


NotifyIconEx.Remove Method

Removes the icon from the tray.

[Visual Basic]
Public Sub Remove()
[C#]
public void Remove();

See Also

NotifyIconEx Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


NotifyIconEx.ShowBalloon Method

Shows a balloon for the icon.

[Visual Basic]
Public Sub ShowBalloon( _
ByVal title As String, _
ByVal text As String, _
ByVal type As NotifyInfoFlags, _
ByVal timeoutInMilliSeconds As Integer _
)
[C#]
public void ShowBalloon(
string title,
string text,
NotifyInfoFlags type,
int timeoutInMilliSeconds
);

Parameters

title
The title of the balloon, up to 64 chars in length.
text
The contents of the balloon, up to 256 chars in length.
type
The type of the balloon.
timeoutInMilliSeconds
The timeout of the balloon, in milliseconds.

See Also

NotifyIconEx Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


NotifyIconEx Events

The events of the NotifyIconEx class are listed below. For a complete list of NotifyIconEx class members, see the NotifyIconEx Members topic.

Public Instance Events

BalloonClick | Balloon was clicked.
Click | Item was clicked.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DoubleClick | Item was double-clicked.
RightClick | Item was right-clicked.

See Also

NotifyIconEx Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


NotifyIconEx.BalloonClick Event

Balloon was clicked.

[Visual Basic]
Public Event BalloonClick As EventHandler
[C#]
public event EventHandler BalloonClick;

See Also

NotifyIconEx Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


NotifyIconEx.Click Event

Item was clicked.

[Visual Basic]
Public Event Click As EventHandler
[C#]
public event EventHandler Click;

See Also

NotifyIconEx Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


NotifyIconEx.DoubleClick Event

Item was double-clicked.

[Visual Basic]
Public Event DoubleClick As EventHandler
[C#]
public event EventHandler DoubleClick;

See Also

NotifyIconEx Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


NotifyIconEx.RightClick Event

Item was right-clicked.

[Visual Basic]
Public Event RightClick As EventHandler
[C#]
public event EventHandler RightClick;

See Also

NotifyIconEx Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


NotifyInfoFlags Enumeration

Flags for balloon tip's icon.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

[Visual Basic]
Public Enum NotifyInfoFlags
[C#]
public enum NotifyInfoFlags

Members

Member Name | Description | Value
Error | Shows an error icon. | 3
Info | Shows an info icon. | 1
None | Shows no icon. | 0
Warning | Shows a warning icon. | 2

Requirements

Namespace: NETXP.Components

Assembly: NETXP.Components (in NETXP.Components.dll)

See Also

NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


TaskbarNotifier Class

TaskbarNotifier allows you to display MSN style/Skinned instant messaging popups.

For a list of all members of this type, see TaskbarNotifier Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
TaskbarNotifier

[Visual Basic]
NotInheritable Public Class TaskbarNotifier
Inherits Form
[C#]
public sealed class TaskbarNotifier : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Components

Assembly: NETXP.Components (in NETXP.Components.dll)

See Also

TaskbarNotifier Members | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


TaskbarNotifier Members

TaskbarNotifier overview

Public Instance Constructors

TaskbarNotifier Constructor The Constructor for TaskbarNotifier

Public Instance Fields

CloseClickable | Configures TaskbarNotifier.
ContentClickable | Configures TaskbarNotifier.
ContentRectangle | Configures TaskbarNotifier.
EnableSelectionRectangle | Configures TaskbarNotifier.
TitleClickable | Configures TaskbarNotifier.
TitleRectangle | Configures TaskbarNotifier.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) |
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScale (inherited from Form) | Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContentText | Get/Set the popup Content Text
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | [To be supplied.]
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HoverContentColor | Get/Set the Hover Content Color
HoverContentFont | Get/Set the Hover Content Font
HoverTitleColor | Get/Set the Hover Title Color
HoverTitleFont | Get/Set the Hover Title Font
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsRestrictedWindow (inherited from Form) |
KeepVisibleOnMousOver | Indicates if the popup should remain visible when the mouse pointer is over it. Added Rev 002
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
NormalContentColor | Get/Set the Normal Content Color
NormalContentFont | Get/Set the Normal Content Font
NormalTitleColor | Get/Set the Normal Title Color
NormalTitleFont | Get/Set the Normal Title Font
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
ReShowOnMouseOver | Indicates if the popup should appear again when mouse moves over it while it's disappearing. Added Rev 002
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) |
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
TaskbarState | Get the current TaskbarState (hidden, showing, visible, hiding)
Text (inherited from Control) | Gets or sets the text associated with this control.
TitleText | Get/Set the popup Title Text
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as the top-most form of your application.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide | Hides the popup
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBackgroundBitmap | Overloaded. Sets the background bitmap and its transparency color
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetCloseBitmap | Overloaded. Sets the 3-State Close Button bitmap, its transparency color and its coordinates
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show | Overloaded. Displays the popup for a certain amount of time
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with no owner window.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
CloseClick | Handle CloseClick event.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContentClick | Handle ContentClick event.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is not the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) |
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
TitleClick | Handle TitleClick event.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

TaskbarNotifier Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


TaskbarNotifier Constructor

The Constructor for TaskbarNotifier

[Visual Basic]
Public Sub New()
[C#]
public TaskbarNotifier();

See Also

TaskbarNotifier Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


TaskbarNotifier Fields

The fields of the TaskbarNotifier class are listed below. For a complete list of TaskbarNotifier class members, see the TaskbarNotifier Members topic.

Public Instance Fields

CloseClickable | Configures TaskbarNotifier.
ContentClickable | Configures TaskbarNotifier.
ContentRectangle | Configures TaskbarNotifier.
EnableSelectionRectangle | Configures TaskbarNotifier.
TitleClickable | Configures TaskbarNotifier.
TitleRectangle | Configures TaskbarNotifier.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

TaskbarNotifier Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


TaskbarNotifier.CloseClickable Field

Configures TaskbarNotifier.

[Visual Basic]
Public CloseClickable As Boolean
[C#]
public bool CloseClickable;

See Also

TaskbarNotifier Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


TaskbarNotifier.ContentClickable Field

Configures TaskbarNotifier.

[Visual Basic]
Public ContentClickable As Boolean
[C#]
public bool ContentClickable;

See Also

TaskbarNotifier Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


TaskbarNotifier.ContentRectangle Field

Configures TaskbarNotifier.

[Visual Basic]
Public ContentRectangle As Rectangle
[C#]
public Rectangle ContentRectangle;

See Also

TaskbarNotifier Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


TaskbarNotifier.EnableSelectionRectangle Field

Configures TaskbarNotifier.

[Visual Basic]
Public EnableSelectionRectangle As Boolean
[C#]
public bool EnableSelectionRectangle;

See Also

TaskbarNotifier Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


TaskbarNotifier.TitleClickable Field

Configures TaskbarNotifier.

[Visual Basic]
Public TitleClickable As Boolean
[C#]
public bool TitleClickable;

See Also

TaskbarNotifier Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


TaskbarNotifier.TitleRectangle Field

Configures TaskbarNotifier.

[Visual Basic]
Public TitleRectangle As Rectangle
[C#]
public Rectangle TitleRectangle;

See Also

TaskbarNotifier Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


TaskbarNotifier Properties

The properties of the TaskbarNotifier class are listed below. For a complete list of TaskbarNotifier class members, see the TaskbarNotifier Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) |
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScale (inherited from Form) | Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContentText | Get/Set the popup Content Text
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | [To be supplied.]
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HoverContentColor | Get/Set the Hover Content Color
HoverContentFont | Get/Set the Hover Content Font
HoverTitleColor | Get/Set the Hover Title Color
HoverTitleFont | Get/Set the Hover Title Font
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsRestrictedWindow (inherited from Form) |
KeepVisibleOnMousOver | Indicates if the popup should remain visible when the mouse pointer is over it. Added Rev 002
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
NormalContentColor | Get/Set the Normal Content Color
NormalContentFont | Get/Set the Normal Content Font
NormalTitleColor | Get/Set the Normal Title Color
NormalTitleFont | Get/Set the Normal Title Font
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
ReShowOnMouseOver | Indicates if the popup should appear again when mouse moves over it while it's disappearing. Added Rev 002
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) |
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
TaskbarState | Get the current TaskbarState (hidden, showing, visible, hiding)
Text (inherited from Control) | Gets or sets the text associated with this control.
TitleText | Get/Set the popup Title Text
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as the top-most form of your application.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

TaskbarNotifier Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


TaskbarNotifier.ContentText Property

Get/Set the popup Content Text

[Visual Basic]
Public Property ContentText As String
[C#]
public string ContentText {get; set;}

See Also

TaskbarNotifier Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


TaskbarNotifier.HoverContentColor Property

Get/Set the Hover Content Color

[Visual Basic]
Public Property HoverContentColor As Color
[C#]
public System.Drawing.Color HoverContentColor {get; set;}

See Also

TaskbarNotifier Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


TaskbarNotifier.HoverContentFont Property

Get/Set the Hover Content Font

[Visual Basic]
Public Property HoverContentFont As Font
[C#]
public System.Drawing.Font HoverContentFont {get; set;}

See Also

TaskbarNotifier Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


TaskbarNotifier.HoverTitleColor Property

Get/Set the Hover Title Color

[Visual Basic]
Public Property HoverTitleColor As Color
[C#]
public System.Drawing.Color HoverTitleColor {get; set;}

See Also

TaskbarNotifier Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


TaskbarNotifier.HoverTitleFont Property

Get/Set the Hover Title Font

[Visual Basic]
Public Property HoverTitleFont As Font
[C#]
public System.Drawing.Font HoverTitleFont {get; set;}

See Also

TaskbarNotifier Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


TaskbarNotifier.KeepVisibleOnMousOver Property

Indicates if the popup should remain visible when the mouse pointer is over it. Added Rev 002

[Visual Basic]
Public Property KeepVisibleOnMousOver As Boolean
[C#]
public bool KeepVisibleOnMousOver {get; set;}

See Also

TaskbarNotifier Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


TaskbarNotifier.NormalContentColor Property

Get/Set the Normal Content Color

[Visual Basic]
Public Property NormalContentColor As Color
[C#]
public System.Drawing.Color NormalContentColor {get; set;}

See Also

TaskbarNotifier Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


TaskbarNotifier.NormalContentFont Property

Get/Set the Normal Content Font

[Visual Basic]
Public Property NormalContentFont As Font
[C#]
public System.Drawing.Font NormalContentFont {get; set;}

See Also

TaskbarNotifier Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


TaskbarNotifier.NormalTitleColor Property

Get/Set the Normal Title Color

[Visual Basic]
Public Property NormalTitleColor As Color
[C#]
public System.Drawing.Color NormalTitleColor {get; set;}

See Also

TaskbarNotifier Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


TaskbarNotifier.NormalTitleFont Property

Get/Set the Normal Title Font

[Visual Basic]
Public Property NormalTitleFont As Font
[C#]
public System.Drawing.Font NormalTitleFont {get; set;}

See Also

TaskbarNotifier Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


TaskbarNotifier.ReShowOnMouseOver Property

Indicates if the popup should appear again when mouse moves over it while it's disappearing. Added Rev 002

[Visual Basic]
Public Property ReShowOnMouseOver As Boolean
[C#]
public bool ReShowOnMouseOver {get; set;}

See Also

TaskbarNotifier Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


TaskbarNotifier.TaskbarState Property

Get the current TaskbarState (hidden, showing, visible, hiding)

[Visual Basic]
Public ReadOnly Property TaskbarState As TaskbarStates
[C#]
public TaskbarNotifier.TaskbarStates TaskbarState {get;}

See Also

TaskbarNotifier Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


TaskbarNotifier.TitleText Property

Get/Set the popup Title Text

[Visual Basic]
Public Property TitleText As String
[C#]
public string TitleText {get; set;}

See Also

TaskbarNotifier Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


TaskbarNotifier Methods

The methods of the TaskbarNotifier class are listed below. For a complete list of TaskbarNotifier class members, see the TaskbarNotifier Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide | Hides the popup
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBackgroundBitmap | Overloaded. Sets the background bitmap and its transparency color
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetCloseBitmap | Overloaded. Sets the 3-State Close Button bitmap, its transparency color and its coordinates
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show | Overloaded. Displays the popup for a certain amount of time
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with no owner window.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

TaskbarNotifier Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


TaskbarNotifier.Hide Method

Hides the popup

[Visual Basic]
Public Sub Hide()
[C#]
new public void Hide();

Return Value

Nothing

See Also

TaskbarNotifier Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


SetBackgroundBitmap Method

NetXP 3.0 Reference

TaskbarNotifier.SetBackgroundBitmap Method

Sets the background bitmap and its transparency color

Overload List

Sets the background bitmap and its transparency color

public void SetBackgroundBitmap(Image,Color);

Sets the background bitmap and its transparency color

public void SetBackgroundBitmap(string,Color);

See Also

TaskbarNotifier Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


TaskbarNotifier.SetBackgroundBitmap Method (Image, Color)

Sets the background bitmap and its transparency color

[Visual Basic]
Overloads Public Sub SetBackgroundBitmap( _
ByVal image As Image, _
ByVal transparencyColor As Color _
)
[C#]
public void SetBackgroundBitmap(
Image image,
Color transparencyColor
);

Parameters

image
Image/Bitmap object which represents the Background Bitmap
transparencyColor
Color of the Bitmap which won't be visible

Return Value

Nothing

See Also

TaskbarNotifier Class | NETXP.Components Namespace | TaskbarNotifier.SetBackgroundBitmap Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


TaskbarNotifier.SetBackgroundBitmap Method (String, Color)

Sets the background bitmap and its transparency color

[Visual Basic]
Overloads Public Sub SetBackgroundBitmap( _
ByVal strFilename As String, _
ByVal transparencyColor As Color _
)
[C#]
public void SetBackgroundBitmap(
string strFilename,
Color transparencyColor
);

Parameters

strFilename
Path of the Background Bitmap on the disk
transparencyColor
Color of the Bitmap which won't be visible

Return Value

Nothing

See Also

TaskbarNotifier Class | NETXP.Components Namespace | TaskbarNotifier.SetBackgroundBitmap Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


SetCloseBitmap Method

NetXP 3.0 Reference

TaskbarNotifier.SetCloseBitmap Method

Sets the 3-State Close Button bitmap, its transparency color and its coordinates

Overload List

Sets the 3-State Close Button bitmap, its transparency color and its coordinates

public void SetCloseBitmap(Image,Color,Point);

Sets the 3-State Close Button bitmap, its transparency color and its coordinates

public void SetCloseBitmap(string,Color,Point);

See Also

TaskbarNotifier Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


TaskbarNotifier.SetCloseBitmap Method (Image, Color, Point)

Sets the 3-State Close Button bitmap, its transparency color and its coordinates

[Visual Basic]
Overloads Public Sub SetCloseBitmap( _
ByVal image As Image, _
ByVal transparencyColor As Color, _
ByVal position As Point _
)
[C#]
public void SetCloseBitmap(
Image image,
Color transparencyColor,
Point position
);

Parameters

image
Image/Bitmap object which represents the 3-state Close button Bitmap (width must be a multiple of 3)
transparencyColor
Color of the Bitmap which won't be visible
position
Location of the close button on the popup

Return Value

Nothing

See Also

TaskbarNotifier Class | NETXP.Components Namespace | TaskbarNotifier.SetCloseBitmap Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


TaskbarNotifier.SetCloseBitmap Method (String, Color, Point)

Sets the 3-State Close Button bitmap, its transparency color and its coordinates

[Visual Basic]
Overloads Public Sub SetCloseBitmap( _
ByVal strFilename As String, _
ByVal transparencyColor As Color, _
ByVal position As Point _
)
[C#]
public void SetCloseBitmap(
string strFilename,
Color transparencyColor,
Point position
);

Parameters

strFilename
Path of the 3-state Close button Bitmap on the disk (width must a multiple of 3)
transparencyColor
Color of the Bitmap which won't be visible
position
Location of the close button on the popup

Return Value

Nothing

See Also

TaskbarNotifier Class | NETXP.Components Namespace | TaskbarNotifier.SetCloseBitmap Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


Show Method

NetXP 3.0 Reference

TaskbarNotifier.Show Method

Displays the popup for a certain amount of time

Overload List

Inherited from Control.

public void Show();

Displays the popup for a certain amount of time

public void Show(string,string,int,int,int);

See Also

TaskbarNotifier Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


TaskbarNotifier.Show Method (String, String, Int32, Int32, Int32)

Displays the popup for a certain amount of time

[Visual Basic]
Overloads Public Sub Show( _
ByVal strTitle As String, _
ByVal strContent As String, _
ByVal nTimeToShow As Integer, _
ByVal nTimeToStay As Integer, _
ByVal nTimeToHide As Integer _
)
[C#]
public void Show(
string strTitle,
string strContent,
int nTimeToShow,
int nTimeToStay,
int nTimeToHide
);

Parameters

strTitle
The string which will be shown as the title of the popup
strContent
The string which will be shown as the content of the popup
nTimeToShow
Duration of the showing animation (in milliseconds)
nTimeToStay
Duration of the visible state before collapsing (in milliseconds)
nTimeToHide
Duration of the hiding animation (in milliseconds)

Return Value

Nothing

See Also

TaskbarNotifier Class | NETXP.Components Namespace | TaskbarNotifier.Show Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


TaskbarNotifier Events

The events of the TaskbarNotifier class are listed below. For a complete list of TaskbarNotifier class members, see the TaskbarNotifier Members topic.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
CloseClick | Handle CloseClick event.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContentClick | Handle ContentClick event.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is not the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) |
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
TitleClick | Handle TitleClick event.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

TaskbarNotifier Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


TaskbarNotifier.CloseClick Event

Handle CloseClick event.

[Visual Basic]
Public Event CloseClick As EventHandler
[C#]
public event EventHandler CloseClick;

See Also

TaskbarNotifier Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


TaskbarNotifier.ContentClick Event

Handle ContentClick event.

[Visual Basic]
Public Event ContentClick As EventHandler
[C#]
public event EventHandler ContentClick;

See Also

TaskbarNotifier Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


TaskbarNotifier.TitleClick Event

Handle TitleClick event.

[Visual Basic]
Public Event TitleClick As EventHandler
[C#]
public event EventHandler TitleClick;

See Also

TaskbarNotifier Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


TaskbarNotifier.TaskbarStates Enumeration

List of the different popup animation status

[Visual Basic]
Public Enum TaskbarNotifier.TaskbarStates
[C#]
public enum TaskbarNotifier.TaskbarStates

Members

Member Name | Description
hidden | Taskbar notifier is hidden.
appearing | Taskbar notification window is appearing.
visible | Window is visible.
disappearing | Window is disappearing.

Requirements

Namespace: NETXP.Components

Assembly: NETXP.Components (in NETXP.Components.dll)

See Also

NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


XTimer Class

XTimer is an enhanced high-precision timer using Win32 performance counters.

For a list of all members of this type, see XTimer Members.

System.Object
XTimer

[Visual Basic]
Public Class XTimer
[C#]
public class XTimer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Components

Assembly: NETXP.Components (in NETXP.Components.dll)

See Also

XTimer Members | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


XTimer Members

XTimer overview

Public Static (Shared) Properties

BeginTime | Gets the time when the timing operation was started.
Frequency | Gets the maximum frequency of this high-res timer.
Initialized | Gets whether or not the timer was initialized.

Public Static (Shared) Methods

Begin | Begins timing.
End | Ends timing operation and gets the elapsed time in microseconds.
Init | Initializes the high-res timer, getting its frequency.

Public Instance Constructors

XTimer Constructor Initializes a new instance of the XTimer class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

XTimer Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


XTimer Constructor

Initializes a new instance of the XTimer class.

[Visual Basic]
Public Sub New()
[C#]
public XTimer();

See Also

XTimer Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


XTimer Properties

The properties of the XTimer class are listed below. For a complete list of XTimer class members, see the XTimer Members topic.

Public Static (Shared) Properties

BeginTime | Gets the time when the timing operation was started.
Frequency | Gets the maximum frequency of this high-res timer.
Initialized | Gets whether or not the timer was initialized.

See Also

XTimer Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


XTimer.BeginTime Property

Gets the time when the timing operation was started.

[Visual Basic]
Public Shared ReadOnly Property BeginTime As Long
[C#]
public static long BeginTime {get;}

See Also

XTimer Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


XTimer.Frequency Property

Gets the maximum frequency of this high-res timer.

[Visual Basic]
Public Shared ReadOnly Property Frequency As Long
[C#]
public static long Frequency {get;}

See Also

XTimer Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


XTimer.Initialized Property

Gets whether or not the timer was initialized.

[Visual Basic]
Public Shared ReadOnly Property Initialized As Boolean
[C#]
public static bool Initialized {get;}

See Also

XTimer Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


XTimer Methods

The methods of the XTimer class are listed below. For a complete list of XTimer class members, see the XTimer Members topic.

Public Static (Shared) Methods

Begin | Begins timing.
End | Ends timing operation and gets the elapsed time in microseconds.
Init | Initializes the high-res timer, getting its frequency.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

XTimer Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


XTimer.Begin Method

Begins timing.

[Visual Basic]
Public Shared Function Begin() As Boolean
[C#]
public static bool Begin();

Return Value

True if it succeeded.

See Also

XTimer Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


XTimer.End Method

Ends timing operation and gets the elapsed time in microseconds.

[Visual Basic]
Public Shared Function End() As Double
[C#]
public static double End();

Return Value

A double value indicating the elapsed time in microseconds, or 0.0 if failed.

See Also

XTimer Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


XTimer.Init Method

Initializes the high-res timer, getting its frequency.

[Visual Basic]
Public Shared Sub Init()
[C#]
public static void Init();

See Also

XTimer Class | NETXP.Components Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components [3.0.5600.2205]


NETXP.Components.Extenders

NetXP 3.0 Reference

NETXP.Components.Extenders Namespace

Classes

Class | Description
MenuImageExtender | A custom extender class that adds an Image attribute to MenuItem objects, and custom draws the menu.
StatusMessages | Implements an extender for menu item status messages (typically for CommandBar items)


MenuImageExtender Class

A custom extender class that adds an Image attribute to MenuItem objects, and custom draws the menu.

For a list of all members of this type, see MenuImageExtender Members.

System.Object
MarshalByRefObject
Component
MenuImageExtender

[Visual Basic]
NotInheritable Public Class MenuImageExtender
Inherits Component
Implements System.ComponentModel.IExtenderProvider
[C#]
public sealed class MenuImageExtender : Component, IExtenderProvider

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

This extension was written to provide an simple way to link icons with a menu, and owner draw the menu. By using an extender, no custom coding is required.

Requirements

Namespace: NETXP.Components.Extenders

Assembly: NETXP.Components.Extenders (in NETXP.Components.Extenders.dll)

See Also

MenuImageExtender Members | NETXP.Components.Extenders Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components.Extenders [3.0.5600.2205]


MenuImageExtender Members

MenuImageExtender overview

Public Instance Constructors

MenuImageExtender Overloaded. Initializes a new instance of the MenuImageExtender class.

Public Instance Properties

Container (inherited from Component) | Gets the IContainer that contains the Component.
Site (inherited from Component) | Gets or sets the ISite of the Component.

Public Instance Methods

CanExtend | Used to determine if the given component is supported by the extender.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetImage | Used to retrieve the Image extender property value for a given MenuItem component instance.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
SetImage | Used to set a Image property value for a specific MenuItem component instance.
ToString (inherited from Component) |

Public Instance Events

Disposed (inherited from Component) Adds an event handler to listen to the Disposed event on the component.

See Also

MenuImageExtender Class | NETXP.Components.Extenders Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components.Extenders [3.0.5600.2205]


MenuImageExtender Constructor

Constructor for instance that supports Class Composition designer.

Overload List

Creates the extender.

public MenuImageExtender();

Constructor for instance that supports Class Composition designer.

public MenuImageExtender(IContainer);

See Also

MenuImageExtender Class | NETXP.Components.Extenders Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components.Extenders [3.0.5600.2205]


MenuImageExtender Constructor (IContainer)

Constructor for instance that supports Class Composition designer.

[Visual Basic]
Overloads Public Sub New( _
ByVal container As IContainer _
)
[C#]
public MenuImageExtender(
IContainer container
);

Parameters

container
Reference to container hosting this instance.

See Also

MenuImageExtender Class | NETXP.Components.Extenders Namespace | MenuImageExtender Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components.Extenders [3.0.5600.2205]


MenuImageExtender Constructor ()

Creates the extender.

[Visual Basic]
Overloads Public Sub New()
[C#]
public MenuImageExtender();

See Also

MenuImageExtender Class | NETXP.Components.Extenders Namespace | MenuImageExtender Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components.Extenders [3.0.5600.2205]


MenuImageExtender Methods

The methods of the MenuImageExtender class are listed below. For a complete list of MenuImageExtender class members, see the MenuImageExtender Members topic.

Public Instance Methods

CanExtend | Used to determine if the given component is supported by the extender.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetImage | Used to retrieve the Image extender property value for a given MenuItem component instance.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
SetImage | Used to set a Image property value for a specific MenuItem component instance.
ToString (inherited from Component) |

See Also

MenuImageExtender Class | NETXP.Components.Extenders Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components.Extenders [3.0.5600.2205]


MenuImageExtender.CanExtend Method

Used to determine if the given component is supported by the extender.

[Visual Basic]
NotOverridable Public Function CanExtend( _
ByVal component As Object _
) As Boolean Implements _
IExtenderProvider.CanExtend
[C#]
public bool CanExtend(
object component
);

Parameters

component
component to evaluate for compatability

Return Value

Returns True/False if the component supports the extender.

Implements

IExtenderProvider.CanExtend

See Also

MenuImageExtender Class | NETXP.Components.Extenders Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components.Extenders [3.0.5600.2205]


MenuImageExtender.GetImage Method

Used to retrieve the Image extender property value for a given MenuItem component instance.

[Visual Basic]
Public Function GetImage( _
ByVal component As Component _
) As Image
[C#]
public Image GetImage(
Component component
);

Parameters

component
The menu item instance associated with the value

Return Value

Returns the Image property value for the specified MenuItem component instance.

See Also

MenuImageExtender Class | NETXP.Components.Extenders Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components.Extenders [3.0.5600.2205]


MenuImageExtender.SetImage Method

Used to set a Image property value for a specific MenuItem component instance.

[Visual Basic]
Public Sub SetImage( _
ByVal component As Component, _
ByVal imageValue As Image _
)
[C#]
public void SetImage(
Component component,
Image imageValue
);

Parameters

component
The MenuItem object to store
imageValue
The value to associate with the menu item

See Also

MenuImageExtender Class | NETXP.Components.Extenders Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components.Extenders [3.0.5600.2205]


StatusMessages Class

Implements an extender for menu item status messages (typically for CommandBar items)

For a list of all members of this type, see StatusMessages Members.

System.Object
MarshalByRefObject
Component
StatusMessages

[Visual Basic]
NotInheritable Public Class StatusMessages
Inherits Component
Implements System.ComponentModel.IExtenderProvider
[C#]
public sealed class StatusMessages : Component, IExtenderProvider

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Components.Extenders

Assembly: NETXP.Components.Extenders (in NETXP.Components.Extenders.dll)

See Also

StatusMessages Members | NETXP.Components.Extenders Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components.Extenders [3.0.5600.2205]


StatusMessages Members

StatusMessages overview

Public Instance Constructors

StatusMessages Overloaded. Initializes a new instance of the StatusMessages class.

Public Instance Properties

Container (inherited from Component) | Gets the IContainer that contains the Component.
Site (inherited from Component) | Gets or sets the ISite of the Component.
StatusBar | The status bar displaying the status messages.

Public Instance Methods

CanExtend | Can the component be extended?
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetStatusBar | Retrieves the status bar that displays the status messages.
GetStatusMessage | Retrieves the status message.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
SetStatusMessage | Sets the status message.
ToString (inherited from Component) |

Public Instance Events

Disposed (inherited from Component) Adds an event handler to listen to the Disposed event on the component.

See Also

StatusMessages Class | NETXP.Components.Extenders Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components.Extenders [3.0.5600.2205]


StatusMessages Constructor

Creates a new StatusMessages extender for the specified container.

Overload List

Creates a new StatusMessages extender.

public StatusMessages();

Creates a new StatusMessages extender for the specified container.

public StatusMessages(IContainer);

See Also

StatusMessages Class | NETXP.Components.Extenders Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components.Extenders [3.0.5600.2205]


StatusMessages Constructor (IContainer)

Creates a new StatusMessages extender for the specified container.

[Visual Basic]
Overloads Public Sub New( _
ByVal container As IContainer _
)
[C#]
public StatusMessages(
IContainer container
);

Parameters

container
The container

See Also

StatusMessages Class | NETXP.Components.Extenders Namespace | StatusMessages Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components.Extenders [3.0.5600.2205]


StatusMessages Constructor ()

Creates a new StatusMessages extender.

[Visual Basic]
Overloads Public Sub New()
[C#]
public StatusMessages();

See Also

StatusMessages Class | NETXP.Components.Extenders Namespace | StatusMessages Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components.Extenders [3.0.5600.2205]


StatusMessages Properties

The properties of the StatusMessages class are listed below. For a complete list of StatusMessages class members, see the StatusMessages Members topic.

Public Instance Properties

Container (inherited from Component) | Gets the IContainer that contains the Component.
Site (inherited from Component) | Gets or sets the ISite of the Component.
StatusBar | The status bar displaying the status messages.

See Also

StatusMessages Class | NETXP.Components.Extenders Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components.Extenders [3.0.5600.2205]


StatusMessages.StatusBar Property

The status bar displaying the status messages.

[Visual Basic]
Public Property StatusBar As Control
[C#]
public System.Windows.Forms.Control StatusBar {get; set;}

See Also

StatusMessages Class | NETXP.Components.Extenders Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components.Extenders [3.0.5600.2205]


StatusMessages Methods

The methods of the StatusMessages class are listed below. For a complete list of StatusMessages class members, see the StatusMessages Members topic.

Public Instance Methods

CanExtend | Can the component be extended?
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetStatusBar | Retrieves the status bar that displays the status messages.
GetStatusMessage | Retrieves the status message.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
SetStatusMessage | Sets the status message.
ToString (inherited from Component) |

See Also

StatusMessages Class | NETXP.Components.Extenders Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components.Extenders [3.0.5600.2205]


StatusMessages.CanExtend Method

Can the component be extended?

[Visual Basic]
NotOverridable Public Function CanExtend( _
ByVal component As Object _
) As Boolean Implements _
IExtenderProvider.CanExtend
[C#]
public bool CanExtend(
object component
);

Parameters

component
The component to check.

Return Value

True if it can be extended.

Implements

IExtenderProvider.CanExtend

See Also

StatusMessages Class | NETXP.Components.Extenders Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components.Extenders [3.0.5600.2205]


StatusMessages.GetStatusBar Method

Retrieves the status bar that displays the status messages.

[Visual Basic]
Public Function GetStatusBar() As IStatusMessageAcceptor
[C#]
public IStatusMessageAcceptor GetStatusBar();

Return Value

The status bar.

See Also

StatusMessages Class | NETXP.Components.Extenders Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components.Extenders [3.0.5600.2205]


StatusMessages.GetStatusMessage Method

Retrieves the status message.

[Visual Basic]
Public Function GetStatusMessage( _
ByVal component As Component _
) As String
[C#]
public string GetStatusMessage(
Component component
);

Parameters

component
The component to associate with the value.

Return Value

The string value pertaining to the status message.

See Also

StatusMessages Class | NETXP.Components.Extenders Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components.Extenders [3.0.5600.2205]


StatusMessages.SetStatusMessage Method

Sets the status message.

[Visual Basic]
Public Sub SetStatusMessage( _
ByVal component As Component, _
ByVal value As String _
)
[C#]
public void SetStatusMessage(
Component component,
string value
);

Parameters

component
The component to associate with the value.
value
The string value pertaining to the status message.

See Also

StatusMessages Class | NETXP.Components.Extenders Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Components.Extenders [3.0.5600.2205]


NETXP.Controls

NetXP 3.0 Reference

NETXP.Controls Namespace

Classes

Class | Description
AutoTextBox | AutoTextBox is a text box that saves all the strings the user types to an XML file.
BalloonHelp | Encapsulates the functionality of a balloon-shaped window.
BalloonWindow | BalloonWindow is a special form in the shape of a balloon.
ColorButton | Provides a button which invokes a color picker control when clicked.
ColorForm | This form implements a color picker.
ComboBoxEx | ComboBoxEx allows specifically the retrieval of recently typed URLs and file paths, as well as items with icons.
ComboBoxExItem | ComboBoxExItem describes a ComboBoxEx item.
ComboBoxExItemCollection | Internal. Do not use.
DesktopAlert | Summary description for DesktopAlert.
DropDownTreeView | A drop-down tree view control.
Graph | This class implements a graph control.
GraphItem | GraphItem
GraphItemCollection | Collection
MaskedTextBox | A textbox that automatically provides a mask based on required input.
MultiPage | The MultiPage control is a tab control that does not show its tabs. It is used for the wizard form.
RealPanel | A panel control that ACTUALLY inherits ContainerControl, unlike its Windows Forms cousin.
SkinnedPanel | SkinnedPanel is a panel that uses the XP tab page background.
TreeViewEx | TreeViewEx is an extension to TreeView which automatically checks and unchecks child items.
XPButton | XPButton extends the Button control by providing an Office-XP look or a Windows XP skinned look PLUS an icon.
XPCheckBox | XPCheckBox is a check box that draws itself using XP visual styles. It is meant to be used on SkinnedPanel controls where the normal .NET checkbox would not draw itself properly.
XPGroupBox | The XPGroupBox control draws itself using XP visual styles. It is meant to be used with the SkinnedPanel control where the regular .NET GroupBox control would not draw itself properly.
XPictureBox | XPictureBox is an extended PictureBox control for faster display of pictures.

Enumerations

Enumeration | Description
AutoCompleteFlags | A simple enumeration that wraps various auto complete flags of SHAutoComplete. See documenation of SHAutoComplete for details
BalloonWindow.BallonQuadrant | Describes the locations in the balloon.
GraphType | The type of graph.
Mask | Type of mask.
MRUKeyHive | Enumeration for possible types of registry base keys for storing most recntly typed URLs


AutoCompleteFlags Enumeration

A simple enumeration that wraps various auto complete flags of SHAutoComplete. See documenation of SHAutoComplete for details

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

[Visual Basic]
Public Enum AutoCompleteFlags
[C#]
public enum AutoCompleteFlags

Members

Member Name | Description | Value
None | No flags. | 0
FileSystem | This includes the File System as well as the rest of the shell (Desktop\My Computer\Control Panel\) | 1
URLHistory | URLs in the User's History | 2
URLMRU | URLs in the User's Recently Used list. | 4
UseTab | Use the tab to move thru the autocomplete possibilities instead of to the next dialog/window control. | 8
FileSystemOnly | This includes the File System | 16
FileSystemDirs | Same as FileSystemOnly except it only includes directories, UNC servers, and UNC server shares. | 32
AutoSuggestForceOn | Ignore the registry default and force the auto suggest feature on. | 268435456
AutoSuggestForceOff | Ignore the registry default and force the auto suggest feature off | 536870912
AutoAppendForceOn | Ignore the registry default and force the auto append on. | 1073741824

Requirements

Namespace: NETXP.Controls

Assembly: NETXP.Controls (in NETXP.Controls.dll)

See Also

NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


AutoTextBox Class

AutoTextBox is a text box that saves all the strings the user types to an XML file.

For a list of all members of this type, see AutoTextBox Members.

System.Object
MarshalByRefObject
Component
Control
ListControl
ComboBox
AutoTextBox

[Visual Basic]
Public Class AutoTextBox
Inherits ComboBox
[C#]
public class AutoTextBox : ComboBox

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls

Assembly: NETXP.Controls (in NETXP.Controls.dll)

See Also

AutoTextBox Members | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


AutoTextBox Members

AutoTextBox overview

Public Instance Constructors

AutoTextBox Constructor Creates an auto-textbox.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoCompleteHeader | The XML file name to use, without the extension.
BackColor (inherited from ComboBox) |
BackgroundImage (inherited from ComboBox) |
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataSource (inherited from ListControl) | Gets or sets the data source for this ListControl .
DisplayMember (inherited from ListControl) | Gets or sets a string that specifies the property of the data source whose contents you want to display.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DrawMode (inherited from ComboBox) | Gets or sets a value indicating whether your code or the operating system will handle drawing of elements in the list.
DropDownWidth (inherited from ComboBox) | Gets or sets the width of the of the drop-down portion of a combo box.
DroppedDown (inherited from ComboBox) | Gets or sets a value indicating whether the combo box is displaying its drop-down portion.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from ComboBox) |
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from ComboBox) |
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
IntegralHeight (inherited from ComboBox) | Gets or sets a value indicating whether the control should resize to avoid showing partial items.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
ItemHeight (inherited from ComboBox) | Gets or sets the height of an item in the combo box.
Items (inherited from ComboBox) | Gets an object representing the collection of the items contained in this ComboBox .
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaxDropDownItems (inherited from ComboBox) | Gets or sets the maximum number of items to be shown in the drop-down portion of the ComboBox .
MaxLength (inherited from ComboBox) | Gets or sets the maximum number of characters allowed in the editable portion of a combo box.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PreferredHeight (inherited from ComboBox) | Gets the preferred height of the ComboBox.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
SelectedIndex (inherited from ComboBox) | Gets or sets the index specifying the currently selected item.
SelectedItem (inherited from ComboBox) | Gets or sets currently selected item in the ComboBox .
SelectedText (inherited from ComboBox) | Gets or sets the text that is selected in the editable portion of a ComboBox .
SelectedValue (inherited from ListControl) | Gets or sets the value of the member property specified by the ValueMember property.
SelectionLength (inherited from ComboBox) | Gets or sets the number of characters selected in the editable portion of the combo box.
SelectionStart (inherited from ComboBox) | Gets or sets the starting index of text selected in the combo box.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
Sorted (inherited from ComboBox) | Gets or sets a value indicating whether the items in the combo box are sorted.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from ComboBox) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
ValueMember (inherited from ListControl) | Gets or sets a string that specifies the property of the data source from which to draw the value.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BeginUpdate (inherited from ComboBox) | Maintains performance when items are added to the ComboBox one at a time.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
EndUpdate (inherited from ComboBox) | Resumes painting the ComboBox control after painting is suspended by the BeginUpdate method.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
FindString (inherited from ComboBox) | Overloaded. Finds the first item in the combo box that starts with the specified string.
FindStringExact (inherited from ComboBox) | Overloaded. Finds the first item in the combo box that matches the specified string.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetItemHeight (inherited from ComboBox) | Returns the height of an item in the ComboBox.
GetItemText (inherited from ListControl) | Returns the text representation of the specified item.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from ComboBox) | Overloaded. Selects a range of text in the editable portion of the ComboBox.
Select (inherited from Control) | Overloaded. Activates the control.
SelectAll (inherited from ComboBox) | Selects all the text in the editable portion of the ComboBox .
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from ComboBox) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from ComboBox) |
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
DataSourceChanged (inherited from ListControl) | Occurs when the DataSource changes.
DisplayMemberChanged (inherited from ListControl) | Occurs when the DisplayMember property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
DrawItem (inherited from ComboBox) | Occurs when a visual aspect of an owner-drawn ComboBox changes.
DropDown (inherited from ComboBox) | Occurs when the drop-down portion of a ComboBox is shown.
DropDownStyleChanged (inherited from ComboBox) | Occurs when the DropDownStyle property has changed.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MeasureItem (inherited from ComboBox) | Occurs each time an owner-drawn ComboBox item needs to be drawn and when the sizes of the list items are determined.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from ComboBox) |
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SelectedIndexChanged (inherited from ComboBox) | Occurs when the SelectedIndex property has changed.
SelectedValueChanged (inherited from ListControl) | Occurs when the SelectedValue property changes.
SelectionChangeCommitted (inherited from ComboBox) | Occurs when the selected item has changed and that change is committed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueMemberChanged (inherited from ListControl) | Occurs when the ValueMember property changes.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

AutoTextBox Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


AutoTextBox Constructor

Creates an auto-textbox.

[Visual Basic]
Public Sub New()
[C#]
public AutoTextBox();

See Also

AutoTextBox Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


AutoTextBox Properties

The properties of the AutoTextBox class are listed below. For a complete list of AutoTextBox class members, see the AutoTextBox Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoCompleteHeader | The XML file name to use, without the extension.
BackColor (inherited from ComboBox) |
BackgroundImage (inherited from ComboBox) |
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataSource (inherited from ListControl) | Gets or sets the data source for this ListControl .
DisplayMember (inherited from ListControl) | Gets or sets a string that specifies the property of the data source whose contents you want to display.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DrawMode (inherited from ComboBox) | Gets or sets a value indicating whether your code or the operating system will handle drawing of elements in the list.
DropDownWidth (inherited from ComboBox) | Gets or sets the width of the of the drop-down portion of a combo box.
DroppedDown (inherited from ComboBox) | Gets or sets a value indicating whether the combo box is displaying its drop-down portion.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from ComboBox) |
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from ComboBox) |
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
IntegralHeight (inherited from ComboBox) | Gets or sets a value indicating whether the control should resize to avoid showing partial items.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
ItemHeight (inherited from ComboBox) | Gets or sets the height of an item in the combo box.
Items (inherited from ComboBox) | Gets an object representing the collection of the items contained in this ComboBox .
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaxDropDownItems (inherited from ComboBox) | Gets or sets the maximum number of items to be shown in the drop-down portion of the ComboBox .
MaxLength (inherited from ComboBox) | Gets or sets the maximum number of characters allowed in the editable portion of a combo box.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PreferredHeight (inherited from ComboBox) | Gets the preferred height of the ComboBox.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
SelectedIndex (inherited from ComboBox) | Gets or sets the index specifying the currently selected item.
SelectedItem (inherited from ComboBox) | Gets or sets currently selected item in the ComboBox .
SelectedText (inherited from ComboBox) | Gets or sets the text that is selected in the editable portion of a ComboBox .
SelectedValue (inherited from ListControl) | Gets or sets the value of the member property specified by the ValueMember property.
SelectionLength (inherited from ComboBox) | Gets or sets the number of characters selected in the editable portion of the combo box.
SelectionStart (inherited from ComboBox) | Gets or sets the starting index of text selected in the combo box.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
Sorted (inherited from ComboBox) | Gets or sets a value indicating whether the items in the combo box are sorted.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from ComboBox) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
ValueMember (inherited from ListControl) | Gets or sets a string that specifies the property of the data source from which to draw the value.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

See Also

AutoTextBox Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


AutoTextBox.AutoCompleteHeader Property

The XML file name to use, without the extension.

[Visual Basic]
Public Property AutoCompleteHeader As String
[C#]
public string AutoCompleteHeader {get; set;}

See Also

AutoTextBox Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


BalloonHelp Class

Encapsulates the functionality of a balloon-shaped window.

For a list of all members of this type, see BalloonHelp Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
BalloonWindow
BalloonHelp

[Visual Basic]
Public Class BalloonHelp
Inherits BalloonWindow
Implements System.Windows.Forms.IMessageFilter
[C#]
public class BalloonHelp : BalloonWindow, IMessageFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls

Assembly: NETXP.Controls (in NETXP.Controls.dll)

See Also

BalloonHelp Members | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


BalloonHelp Members

BalloonHelp overview

Public Instance Constructors

BalloonHelp Constructor Constructor for BalloonHelp window.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) |
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AnchorPoint (inherited from BalloonWindow) | The point to which this window is anchored.
AutoScale (inherited from Form) | Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Caption | The caption shown next to the icon.
CaptionFont | The font of the caption.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CloseOnDeactivate | Close this window when it is deactivated.
CloseOnKeyPress | Close this window when a key is pressed.
CloseOnMouseClick | Allow this window to close when clicked.
CloseOnMouseMove | Close this window when mouse is moved.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
Content | The text shown on the balloon window.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
EnableTimeout | Enable automatic closing of this window after a certain interval.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | [To be supplied.]
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsRestrictedWindow (inherited from Form) |
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Quadrant (inherited from BalloonWindow) | Internal.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShowCloseButton | Show close button or not?
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) |
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text | The window's title.
Timeout | The amount of time until the window disappears.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as the top-most form of your application.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreFilterMessage | Internal
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Control) | Displays the control to the user.
ShowBalloon (inherited from BalloonWindow) | Shows this window anchored to a control.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with no owner window.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is not the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) |
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

BalloonHelp Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


BalloonHelp Constructor

Constructor for BalloonHelp window.

[Visual Basic]
Public Sub New()
[C#]
public BalloonHelp();

See Also

BalloonHelp Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


BalloonHelp Properties

The properties of the BalloonHelp class are listed below. For a complete list of BalloonHelp class members, see the BalloonHelp Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) |
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AnchorPoint (inherited from BalloonWindow) | The point to which this window is anchored.
AutoScale (inherited from Form) | Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Caption | The caption shown next to the icon.
CaptionFont | The font of the caption.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CloseOnDeactivate | Close this window when it is deactivated.
CloseOnKeyPress | Close this window when a key is pressed.
CloseOnMouseClick | Allow this window to close when clicked.
CloseOnMouseMove | Close this window when mouse is moved.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
Content | The text shown on the balloon window.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
EnableTimeout | Enable automatic closing of this window after a certain interval.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | [To be supplied.]
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsRestrictedWindow (inherited from Form) |
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Quadrant (inherited from BalloonWindow) | Internal.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShowCloseButton | Show close button or not?
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) |
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text | The window's title.
Timeout | The amount of time until the window disappears.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as the top-most form of your application.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

BalloonHelp Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


BalloonHelp.Caption Property

The caption shown next to the icon.

[Visual Basic]
Public Property Caption As String
[C#]
public string Caption {get; set;}

See Also

BalloonHelp Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


BalloonHelp.CaptionFont Property

The font of the caption.

[Visual Basic]
Public Property CaptionFont As Font
[C#]
public System.Drawing.Font CaptionFont {get; set;}

See Also

BalloonHelp Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


BalloonHelp.CloseOnDeactivate Property

Close this window when it is deactivated.

[Visual Basic]
Public Property CloseOnDeactivate As Boolean
[C#]
public bool CloseOnDeactivate {get; set;}

See Also

BalloonHelp Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


BalloonHelp.CloseOnKeyPress Property

Close this window when a key is pressed.

[Visual Basic]
Public Property CloseOnKeyPress As Boolean
[C#]
public bool CloseOnKeyPress {get; set;}

See Also

BalloonHelp Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


BalloonHelp.CloseOnMouseClick Property

Allow this window to close when clicked.

[Visual Basic]
Public Property CloseOnMouseClick As Boolean
[C#]
public bool CloseOnMouseClick {get; set;}

See Also

BalloonHelp Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


BalloonHelp.CloseOnMouseMove Property

Close this window when mouse is moved.

[Visual Basic]
Public Property CloseOnMouseMove As Boolean
[C#]
public bool CloseOnMouseMove {get; set;}

See Also

BalloonHelp Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


BalloonHelp.Content Property

The text shown on the balloon window.

[Visual Basic]
Public Property Content As String
[C#]
public string Content {get; set;}

See Also

BalloonHelp Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


BalloonHelp.EnableTimeout Property

Enable automatic closing of this window after a certain interval.

[Visual Basic]
Public Property EnableTimeout As Boolean
[C#]
public bool EnableTimeout {get; set;}

See Also

BalloonHelp Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


BalloonHelp.ShowCloseButton Property

Show close button or not?

[Visual Basic]
Public Property ShowCloseButton As Boolean
[C#]
public bool ShowCloseButton {get; set;}

See Also

BalloonHelp Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


BalloonHelp.Text Property

The window's title.

[Visual Basic]
Public Property Text As String
[C#]
new public string Text {get; set;}

See Also

BalloonHelp Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


BalloonHelp.Timeout Property

The amount of time until the window disappears.

[Visual Basic]
Public Property Timeout As Integer
[C#]
public int Timeout {get; set;}

See Also

BalloonHelp Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


BalloonHelp Methods

The methods of the BalloonHelp class are listed below. For a complete list of BalloonHelp class members, see the BalloonHelp Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreFilterMessage | Internal
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Control) | Displays the control to the user.
ShowBalloon (inherited from BalloonWindow) | Shows this window anchored to a control.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with no owner window.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

BalloonHelp Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


BalloonHelp.PreFilterMessage Method

Internal

[Visual Basic]
NotOverridable Public Function PreFilterMessage( _
ByRef m As Message _
) As Boolean Implements _
IMessageFilter.PreFilterMessage
[C#]
public bool PreFilterMessage(
ref Message m
);

Parameters

m

Return Value

Implements

IMessageFilter.PreFilterMessage

See Also

BalloonHelp Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


BalloonWindow Class

BalloonWindow is a special form in the shape of a balloon.

For a list of all members of this type, see BalloonWindow Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
BalloonWindow

[Visual Basic]
Public Class BalloonWindow
Inherits Form
[C#]
public class BalloonWindow : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls

Assembly: NETXP.Controls (in NETXP.Controls.dll)

See Also

BalloonWindow Members | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


BalloonWindow Members

BalloonWindow overview

Public Static (Shared) Methods

AnchorPointFromControl Creates an anchor point from a control.

Public Instance Constructors

BalloonWindow Constructor Constructs a BalloonWindow object.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) |
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AnchorPoint | The point to which this window is anchored.
AutoScale (inherited from Form) | Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | [To be supplied.]
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsRestrictedWindow (inherited from Form) |
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Quadrant | Internal.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) |
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as the top-most form of your application.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Control) | Displays the control to the user.
ShowBalloon | Shows this window anchored to a control.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with no owner window.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is not the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) |
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

BalloonWindow Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


BalloonWindow Constructor

Constructs a BalloonWindow object.

[Visual Basic]
Public Sub New()
[C#]
public BalloonWindow();

See Also

BalloonWindow Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


BalloonWindow Properties

The properties of the BalloonWindow class are listed below. For a complete list of BalloonWindow class members, see the BalloonWindow Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) |
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AnchorPoint | The point to which this window is anchored.
AutoScale (inherited from Form) | Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | [To be supplied.]
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsRestrictedWindow (inherited from Form) |
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Quadrant | Internal.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) |
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as the top-most form of your application.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

BalloonWindow Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


BalloonWindow.AnchorPoint Property

The point to which this window is anchored.

[Visual Basic]
Public Property AnchorPoint As Point
[C#]
public System.Drawing.Point AnchorPoint {get; set;}

See Also

BalloonWindow Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


BalloonWindow.Quadrant Property

Internal.

[Visual Basic]
Public ReadOnly Property Quadrant As BallonQuadrant
[C#]
public BalloonWindow.BallonQuadrant Quadrant {get;}

See Also

BalloonWindow Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


BalloonWindow Methods

The methods of the BalloonWindow class are listed below. For a complete list of BalloonWindow class members, see the BalloonWindow Members topic.

Public Static (Shared) Methods

AnchorPointFromControl Creates an anchor point from a control.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Control) | Displays the control to the user.
ShowBalloon | Shows this window anchored to a control.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with no owner window.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

BalloonWindow Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


BalloonWindow.AnchorPointFromControl Method

Creates an anchor point from a control.

[Visual Basic]
Public Shared Function AnchorPointFromControl( _
ByVal anchorControl As Control _
) As Point
[C#]
public static Point AnchorPointFromControl(
Control anchorControl
);

Parameters

anchorControl
The control whose location to use.

Return Value

A Point.

See Also

BalloonWindow Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


BalloonWindow.ShowBalloon Method

Shows this window anchored to a control.

[Visual Basic]
Public Sub ShowBalloon( _
ByVal anchorControl As Control _
)
[C#]
public void ShowBalloon(
Control anchorControl
);

Parameters

anchorControl
The control to anchor to.

See Also

BalloonWindow Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


BalloonWindow.BallonQuadrant Enumeration

Describes the locations in the balloon.

[Visual Basic]
Public Enum BalloonWindow.BallonQuadrant
[C#]
public enum BalloonWindow.BallonQuadrant

Members

Member Name | Description
TopLeft | Top left corner.
TopRight | Top right corner.
BottomLeft | Bottom left corner.
BottomRight | Bottom right corner.

Requirements

Namespace: NETXP.Controls

Assembly: NETXP.Controls (in NETXP.Controls.dll)

See Also

NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ColorButton Class

Provides a button which invokes a color picker control when clicked.

For a list of all members of this type, see ColorButton Members.

System.Object
MarshalByRefObject
Component
Control
ButtonBase
Button
XPButton
ColorButton

[Visual Basic]
Public Class ColorButton
Inherits XPButton
[C#]
public class ColorButton : XPButton

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls

Assembly: NETXP.Controls (in NETXP.Controls.dll)

See Also

ColorButton Members | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ColorButton Members

ColorButton overview

Public Instance Constructors

ColorButton Constructor Creates a ColorButton.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
CenterColor | The color displayed on the button.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DescriptionText | Gets or sets the text to be shown on the description label.
DialogResult (inherited from Button) | Gets or sets a value that is returned to the parent form when the button is clicked.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
EnableFade (inherited from XPButton) | Allow gradual rollover fade?
FlatStyle (inherited from ButtonBase) | Gets or sets the flat style appearance of the button control.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
Image (inherited from ButtonBase) | Gets or sets the image that is displayed on a button control.
ImageAlign (inherited from ButtonBase) | Gets or sets the alignment of the image on the button control.
ImageIndex (inherited from ButtonBase) | Gets or sets the image list index value of the image displayed on the button control.
ImageList (inherited from ButtonBase) | Gets or sets the ImageList that contains the Image displayed on a button control.
ImeMode (inherited from ButtonBase) | Gets or sets the Input Method Editor (IME) mode supported by this control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MoreColorsButtonText | Gets or sets the text to be shown on the More Colors button.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text | Hides an inherited property.
TextAlign (inherited from ButtonBase) | Gets or sets the alignment of the text on the button control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseXPThemes (inherited from XPButton) | Indicates whether or not to use Windows XP visual styles. Enabling this does not allow setting custom colors for the button.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
NotifyDefault (inherited from Button) | Notifies the Button whether it is the default button so that it can adjust its appearance accordingly.
PerformClick (inherited from Button) | Generates a Click event for a button.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Button) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
CenterColorChanged | Raised when the center color has changed either programmatically or due to user selection.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Button) |
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from ButtonBase) |
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
ShowPopup | Raised when the popup form is shown.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

ColorButton Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ColorButton Constructor

Creates a ColorButton.

[Visual Basic]
Public Sub New()
[C#]
public ColorButton();

See Also

ColorButton Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ColorButton Properties

The properties of the ColorButton class are listed below. For a complete list of ColorButton class members, see the ColorButton Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
CenterColor | The color displayed on the button.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DescriptionText | Gets or sets the text to be shown on the description label.
DialogResult (inherited from Button) | Gets or sets a value that is returned to the parent form when the button is clicked.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
EnableFade (inherited from XPButton) | Allow gradual rollover fade?
FlatStyle (inherited from ButtonBase) | Gets or sets the flat style appearance of the button control.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
Image (inherited from ButtonBase) | Gets or sets the image that is displayed on a button control.
ImageAlign (inherited from ButtonBase) | Gets or sets the alignment of the image on the button control.
ImageIndex (inherited from ButtonBase) | Gets or sets the image list index value of the image displayed on the button control.
ImageList (inherited from ButtonBase) | Gets or sets the ImageList that contains the Image displayed on a button control.
ImeMode (inherited from ButtonBase) | Gets or sets the Input Method Editor (IME) mode supported by this control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MoreColorsButtonText | Gets or sets the text to be shown on the More Colors button.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text | Hides an inherited property.
TextAlign (inherited from ButtonBase) | Gets or sets the alignment of the text on the button control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseXPThemes (inherited from XPButton) | Indicates whether or not to use Windows XP visual styles. Enabling this does not allow setting custom colors for the button.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

See Also

ColorButton Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ColorButton.CenterColor Property

The color displayed on the button.

[Visual Basic]
Public Property CenterColor As Color
[C#]
public System.Drawing.Color CenterColor {get; set;}

See Also

ColorButton Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ColorButton.DescriptionText Property

Gets or sets the text to be shown on the description label.

[Visual Basic]
Public Property DescriptionText As String
[C#]
public string DescriptionText {get; set;}

See Also

ColorButton Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ColorButton.MoreColorsButtonText Property

Gets or sets the text to be shown on the More Colors button.

[Visual Basic]
Public Property MoreColorsButtonText As String
[C#]
public string MoreColorsButtonText {get; set;}

See Also

ColorButton Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ColorButton.Text Property

Hides an inherited property.

[Visual Basic]
Overrides Public Property Text As String
[C#]
public override string Text {get; set;}

See Also

ColorButton Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ColorButton Events

The events of the ColorButton class are listed below. For a complete list of ColorButton class members, see the ColorButton Members topic.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
CenterColorChanged | Raised when the center color has changed either programmatically or due to user selection.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Button) |
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from ButtonBase) |
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
ShowPopup | Raised when the popup form is shown.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

ColorButton Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ColorButton.CenterColorChanged Event

Raised when the center color has changed either programmatically or due to user selection.

[Visual Basic]
Public Event CenterColorChanged As EventHandler
[C#]
public event EventHandler CenterColorChanged;

See Also

ColorButton Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ColorButton.ShowPopup Event

Raised when the popup form is shown.

[Visual Basic]
Public Event ShowPopup As CancelEventHandler
[C#]
public event CancelEventHandler ShowPopup;

See Also

ColorButton Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ColorForm Class

This form implements a color picker.

For a list of all members of this type, see ColorForm Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
PopupForm
ColorForm

[Visual Basic]
Public Class ColorForm
Inherits PopupForm
[C#]
public class ColorForm : PopupForm

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls

Assembly: NETXP.Controls (in NETXP.Controls.dll)

See Also

ColorForm Members | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ColorForm Members

ColorForm overview

Public Instance Constructors

ColorForm Constructor Creates a ColorForm.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) |
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScale (inherited from Form) | Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
BottomShadow (inherited from PopupForm) | Gets the bottom shadow window.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
Color | Gets the selected color.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DescriptionText | Gets or sets the text to be shown on the description label.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Filter (inherited from PopupForm) | Gets the message filter.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | [To be supplied.]
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
HasShadow (inherited from PopupForm) | Does this form have a shadow?
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsRestrictedWindow (inherited from Form) |
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
MoreColorsButtonText | Gets or sets the text to be shown on the More Colors button.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightShadow (inherited from PopupForm) | Gets the right-side shadow window.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShadowSize (inherited from PopupForm) | Gets or sets the shadow size.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) |
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as the top-most form of your application.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreFilterMessage (inherited from PopupForm) | Internal
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Control) | Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with no owner window.
ShowPopup | Shows the color form.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is not the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
ShadowCreated (inherited from PopupForm) | Raised when the shadow of the form has been created.
Showing (inherited from PopupForm) | Raised when showing the form. Provides an opportunity to animate the form.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) |
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

ColorForm Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ColorForm Constructor

Creates a ColorForm.

[Visual Basic]
Public Sub New()
[C#]
public ColorForm();

See Also

ColorForm Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ColorForm Properties

The properties of the ColorForm class are listed below. For a complete list of ColorForm class members, see the ColorForm Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) |
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScale (inherited from Form) | Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
BottomShadow (inherited from PopupForm) | Gets the bottom shadow window.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
Color | Gets the selected color.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DescriptionText | Gets or sets the text to be shown on the description label.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Filter (inherited from PopupForm) | Gets the message filter.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | [To be supplied.]
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
HasShadow (inherited from PopupForm) | Does this form have a shadow?
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsRestrictedWindow (inherited from Form) |
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
MoreColorsButtonText | Gets or sets the text to be shown on the More Colors button.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightShadow (inherited from PopupForm) | Gets the right-side shadow window.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShadowSize (inherited from PopupForm) | Gets or sets the shadow size.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) |
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as the top-most form of your application.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

ColorForm Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ColorForm.Color Property

Gets the selected color.

[Visual Basic]
Public Property Color As Color
[C#]
public System.Drawing.Color Color {get; set;}

See Also

ColorForm Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ColorForm.DescriptionText Property

Gets or sets the text to be shown on the description label.

[Visual Basic]
Public Property DescriptionText As String
[C#]
public string DescriptionText {get; set;}

See Also

ColorForm Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ColorForm.MoreColorsButtonText Property

Gets or sets the text to be shown on the More Colors button.

[Visual Basic]
Public Property MoreColorsButtonText As String
[C#]
public string MoreColorsButtonText {get; set;}

See Also

ColorForm Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ColorForm Methods

The methods of the ColorForm class are listed below. For a complete list of ColorForm class members, see the ColorForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreFilterMessage (inherited from PopupForm) | Internal
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Control) | Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with no owner window.
ShowPopup | Shows the color form.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

ColorForm Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ColorForm.ShowPopup Method

Shows the color form.

[Visual Basic]
Overrides Public Sub ShowPopup( _
ByVal owner As Form, _
ByVal location As Point, _
ByVal modal As Boolean _
)
[C#]
public override void ShowPopup(
Form owner,
Point location,
bool modal
);

Parameters

owner
The owner form.
location
The location where the form is shown.
modal
Is this a modal form?

See Also

ColorForm Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ComboBoxEx Class

ComboBoxEx allows specifically the retrieval of recently typed URLs and file paths, as well as items with icons.

For a list of all members of this type, see ComboBoxEx Members.

System.Object
MarshalByRefObject
Component
Control
ListControl
ComboBox
ComboBoxEx

[Visual Basic]
NotInheritable Public Class ComboBoxEx
Inherits ComboBox
[C#]
public sealed class ComboBoxEx : ComboBox

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls

Assembly: NETXP.Controls (in NETXP.Controls.dll)

See Also

ComboBoxEx Members | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ComboBoxEx Members

ComboBoxEx overview

Public Instance Constructors

ComboBoxEx Constructor Constructs a ComboBoxEx.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from ComboBox) |
BackgroundImage (inherited from ComboBox) |
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataSource (inherited from ListControl) | Gets or sets the data source for this ListControl .
DisplayMember (inherited from ListControl) | Gets or sets a string that specifies the property of the data source whose contents you want to display.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DrawMode (inherited from ComboBox) | Gets or sets a value indicating whether your code or the operating system will handle drawing of elements in the list.
DropDownStyle (inherited from ComboBox) | Gets or sets a value specifying the style of the combo box.
DropDownWidth (inherited from ComboBox) | Gets or sets the width of the of the drop-down portion of a combo box.
DroppedDown (inherited from ComboBox) | Gets or sets a value indicating whether the combo box is displaying its drop-down portion.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
EnableMRU | Should enable MRU features?
Flags | Gets or sets the auto complete flags
Focused (inherited from ComboBox) |
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from ComboBox) |
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImageIndex | The default image index.
ImageList | The image list used by the items.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
IntegralHeight (inherited from ComboBox) | Gets or sets a value indicating whether the control should resize to avoid showing partial items.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
ItemHeight (inherited from ComboBox) | Gets or sets the height of an item in the combo box.
Items | Overloaded. A collection of items.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaxDropDownItems (inherited from ComboBox) | Gets or sets the maximum number of items to be shown in the drop-down portion of the ComboBox .
MaxLength (inherited from ComboBox) | Gets or sets the maximum number of characters allowed in the editable portion of a combo box.
MRUHive | Gets or sets the registry key hive for the MRUKey property.
MRUKey | Gets or sets the registry key name where the combo box maintains MRU list.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PreferredHeight (inherited from ComboBox) | Gets the preferred height of the ComboBox.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
SelectedIndex (inherited from ComboBox) | Gets or sets the index specifying the currently selected item.
SelectedItem (inherited from ComboBox) | Gets or sets currently selected item in the ComboBox .
SelectedText (inherited from ComboBox) | Gets or sets the text that is selected in the editable portion of a ComboBox .
SelectedValue (inherited from ListControl) | Gets or sets the value of the member property specified by the ValueMember property.
SelectionLength (inherited from ComboBox) | Gets or sets the number of characters selected in the editable portion of the combo box.
SelectionStart (inherited from ComboBox) | Gets or sets the starting index of text selected in the combo box.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
Sorted (inherited from ComboBox) | Gets or sets a value indicating whether the items in the combo box are sorted.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from ComboBox) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
ValueMember (inherited from ListControl) | Gets or sets a string that specifies the property of the data source from which to draw the value.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BeginUpdate (inherited from ComboBox) | Maintains performance when items are added to the ComboBox one at a time.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
EndUpdate (inherited from ComboBox) | Resumes painting the ComboBox control after painting is suspended by the BeginUpdate method.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
FindString (inherited from ComboBox) | Overloaded. Finds the first item in the combo box that starts with the specified string.
FindStringExact (inherited from ComboBox) | Overloaded. Finds the first item in the combo box that matches the specified string.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetItemHeight (inherited from ComboBox) | Returns the height of an item in the ComboBox.
GetItemText (inherited from ListControl) | Returns the text representation of the specified item.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from ComboBox) | Overloaded. Selects a range of text in the editable portion of the ComboBox.
Select (inherited from Control) | Overloaded. Activates the control.
SelectAll (inherited from ComboBox) | Selects all the text in the editable portion of the ComboBox .
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from ComboBox) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from ComboBox) |
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
DataSourceChanged (inherited from ListControl) | Occurs when the DataSource changes.
DisplayMemberChanged (inherited from ListControl) | Occurs when the DisplayMember property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
DrawItem (inherited from ComboBox) | Occurs when a visual aspect of an owner-drawn ComboBox changes.
DropDown (inherited from ComboBox) | Occurs when the drop-down portion of a ComboBox is shown.
DropDownStyleChanged (inherited from ComboBox) | Occurs when the DropDownStyle property has changed.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MeasureItem (inherited from ComboBox) | Occurs each time an owner-drawn ComboBox item needs to be drawn and when the sizes of the list items are determined.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from ComboBox) |
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SelectedIndexChanged (inherited from ComboBox) | Occurs when the SelectedIndex property has changed.
SelectedValueChanged (inherited from ListControl) | Occurs when the SelectedValue property changes.
SelectionChangeCommitted (inherited from ComboBox) | Occurs when the selected item has changed and that change is committed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueMemberChanged (inherited from ListControl) | Occurs when the ValueMember property changes.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

ComboBoxEx Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ComboBoxEx Constructor

Constructs a ComboBoxEx.

[Visual Basic]
Public Sub New()
[C#]
public ComboBoxEx();

See Also

ComboBoxEx Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ComboBoxEx Properties

The properties of the ComboBoxEx class are listed below. For a complete list of ComboBoxEx class members, see the ComboBoxEx Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from ComboBox) |
BackgroundImage (inherited from ComboBox) |
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataSource (inherited from ListControl) | Gets or sets the data source for this ListControl .
DisplayMember (inherited from ListControl) | Gets or sets a string that specifies the property of the data source whose contents you want to display.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DrawMode (inherited from ComboBox) | Gets or sets a value indicating whether your code or the operating system will handle drawing of elements in the list.
DropDownStyle (inherited from ComboBox) | Gets or sets a value specifying the style of the combo box.
DropDownWidth (inherited from ComboBox) | Gets or sets the width of the of the drop-down portion of a combo box.
DroppedDown (inherited from ComboBox) | Gets or sets a value indicating whether the combo box is displaying its drop-down portion.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
EnableMRU | Should enable MRU features?
Flags | Gets or sets the auto complete flags
Focused (inherited from ComboBox) |
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from ComboBox) |
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImageIndex | The default image index.
ImageList | The image list used by the items.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
IntegralHeight (inherited from ComboBox) | Gets or sets a value indicating whether the control should resize to avoid showing partial items.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
ItemHeight (inherited from ComboBox) | Gets or sets the height of an item in the combo box.
Items | Overloaded. A collection of items.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaxDropDownItems (inherited from ComboBox) | Gets or sets the maximum number of items to be shown in the drop-down portion of the ComboBox .
MaxLength (inherited from ComboBox) | Gets or sets the maximum number of characters allowed in the editable portion of a combo box.
MRUHive | Gets or sets the registry key hive for the MRUKey property.
MRUKey | Gets or sets the registry key name where the combo box maintains MRU list.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PreferredHeight (inherited from ComboBox) | Gets the preferred height of the ComboBox.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
SelectedIndex (inherited from ComboBox) | Gets or sets the index specifying the currently selected item.
SelectedItem (inherited from ComboBox) | Gets or sets currently selected item in the ComboBox .
SelectedText (inherited from ComboBox) | Gets or sets the text that is selected in the editable portion of a ComboBox .
SelectedValue (inherited from ListControl) | Gets or sets the value of the member property specified by the ValueMember property.
SelectionLength (inherited from ComboBox) | Gets or sets the number of characters selected in the editable portion of the combo box.
SelectionStart (inherited from ComboBox) | Gets or sets the starting index of text selected in the combo box.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
Sorted (inherited from ComboBox) | Gets or sets a value indicating whether the items in the combo box are sorted.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from ComboBox) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
ValueMember (inherited from ListControl) | Gets or sets a string that specifies the property of the data source from which to draw the value.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

See Also

ComboBoxEx Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ComboBoxEx.EnableMRU Property

Should enable MRU features?

[Visual Basic]
Public Property EnableMRU As Boolean
[C#]
public bool EnableMRU {get; set;}

See Also

ComboBoxEx Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ComboBoxEx.Flags Property

Gets or sets the auto complete flags

[Visual Basic]
Public Property Flags As AutoCompleteFlags
[C#]
public AutoCompleteFlags Flags {get; set;}

See Also

ComboBoxEx Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ComboBoxEx.ImageIndex Property

The default image index.

[Visual Basic]
Public Property ImageIndex As Integer
[C#]
public int ImageIndex {get; set;}

See Also

ComboBoxEx Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ComboBoxEx.ImageList Property

The image list used by the items.

[Visual Basic]
Public Property ImageList As ImageList
[C#]
public System.Windows.Forms.ImageList ImageList {get; set;}

See Also

ComboBoxEx Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ComboBoxEx.Items Property

A collection of items.

[Visual Basic]
Overloads Public ReadOnly Property Items As ComboBoxExItemCollection
[C#]
new public ComboBoxExItemCollection Items {get;}

See Also

ComboBoxEx Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ComboBoxEx.MRUHive Property

Gets or sets the registry key hive for the MRUKey property.

[Visual Basic]
Public Property MRUHive As MRUKeyHive
[C#]
public MRUKeyHive MRUHive {get; set;}

See Also

ComboBoxEx Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ComboBoxEx.MRUKey Property

Gets or sets the registry key name where the combo box maintains MRU list.

[Visual Basic]
Public Property MRUKey As String
[C#]
public string MRUKey {get; set;}

See Also

ComboBoxEx Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ComboBoxExItem Class

ComboBoxExItem describes a ComboBoxEx item.

For a list of all members of this type, see ComboBoxExItem Members.

System.Object
ComboBoxExItem

[Visual Basic]
NotInheritable Public Class ComboBoxExItem
[C#]
public sealed class ComboBoxExItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls

Assembly: NETXP.Controls (in NETXP.Controls.dll)

See Also

ComboBoxExItem Members | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ComboBoxExItem Members

ComboBoxExItem overview

Public Instance Constructors

ComboBoxExItem Overloaded. Initializes a new instance of the ComboBoxExItem class.

Public Instance Properties

ImageIndex | The item's image index.
ImageList | The item's image list.
Level | The item's indentation level (to simulate tree view)
Text | The item's text.

Public Instance Methods

Empty | Empties the item.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Provides a string representation of the item using the item's text.

Public Instance Events

Changed Occurs when the item has changed.

See Also

ComboBoxExItem Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ComboBoxExItem Constructor

Creates a new, blank ComboBoxEx item.

Overload List

Creates a new, blank ComboBoxEx item.

public ComboBoxExItem();

Creates a new ComboBoxEx item from these parameters.

public ComboBoxExItem(int,string,int);

See Also

ComboBoxExItem Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ComboBoxExItem Constructor ()

Creates a new, blank ComboBoxEx item.

[Visual Basic]
Overloads Public Sub New()
[C#]
public ComboBoxExItem();

See Also

ComboBoxExItem Class | NETXP.Controls Namespace | ComboBoxExItem Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ComboBoxExItem Constructor (Int32, String, Int32)

Creates a new ComboBoxEx item from these parameters.

[Visual Basic]
Overloads Public Sub New( _
ByVal imageIndex As Integer, _
ByVal text As String, _
ByVal level As Integer _
)
[C#]
public ComboBoxExItem(
int imageIndex,
string text,
int level
);

Parameters

imageIndex
The image index of the item.
text
The item's text.
level
The item's level (as in a tree view, indentation level)

See Also

ComboBoxExItem Class | NETXP.Controls Namespace | ComboBoxExItem Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ComboBoxExItem Properties

The properties of the ComboBoxExItem class are listed below. For a complete list of ComboBoxExItem class members, see the ComboBoxExItem Members topic.

Public Instance Properties

ImageIndex | The item's image index.
ImageList | The item's image list.
Level | The item's indentation level (to simulate tree view)
Text | The item's text.

See Also

ComboBoxExItem Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ComboBoxExItem.ImageIndex Property

The item's image index.

[Visual Basic]
Public Property ImageIndex As Integer
[C#]
public int ImageIndex {get; set;}

See Also

ComboBoxExItem Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ComboBoxExItem.ImageList Property

The item's image list.

[Visual Basic]
Public Property ImageList As ImageList
[C#]
public System.Windows.Forms.ImageList ImageList {get; set;}

See Also

ComboBoxExItem Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ComboBoxExItem.Level Property

The item's indentation level (to simulate tree view)

[Visual Basic]
Public Property Level As Integer
[C#]
public int Level {get; set;}

See Also

ComboBoxExItem Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ComboBoxExItem.Text Property

The item's text.

[Visual Basic]
Public Property Text As String
[C#]
public string Text {get; set;}

See Also

ComboBoxExItem Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ComboBoxExItem Methods

The methods of the ComboBoxExItem class are listed below. For a complete list of ComboBoxExItem class members, see the ComboBoxExItem Members topic.

Public Instance Methods

Empty | Empties the item.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Provides a string representation of the item using the item's text.

See Also

ComboBoxExItem Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ComboBoxExItem.Empty Method

Empties the item.

[Visual Basic]
Public Sub Empty()
[C#]
public void Empty();

See Also

ComboBoxExItem Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ComboBoxExItem.ToString Method

Provides a string representation of the item using the item's text.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

The item's text.

See Also

ComboBoxExItem Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ComboBoxExItem Events

The events of the ComboBoxExItem class are listed below. For a complete list of ComboBoxExItem class members, see the ComboBoxExItem Members topic.

Public Instance Events

Changed Occurs when the item has changed.

See Also

ComboBoxExItem Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ComboBoxExItem.Changed Event

Occurs when the item has changed.

[Visual Basic]
Public Event Changed As EventHandler
[C#]
public event EventHandler Changed;

See Also

ComboBoxExItem Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ComboBoxExItemCollection Class

Internal. Do not use.

For a list of all members of this type, see ComboBoxExItemCollection Members.

System.Object
CollectionBase
ComboBoxExItemCollection

[Visual Basic]
NotInheritable Public Class ComboBoxExItemCollection
Inherits CollectionBase
[C#]
public sealed class ComboBoxExItemCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls

Assembly: NETXP.Controls (in NETXP.Controls.dll)

See Also

ComboBoxExItemCollection Members | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ComboBoxExItemCollection Members

ComboBoxExItemCollection overview

Public Instance Constructors

ComboBoxExItemCollection Constructor Creates a new collection.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
ImageList | Internal.
Item | Internal

Public Instance Methods

Add | Internal
AddRange | Internal
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Contains | Internal
CopyTo | Internal
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Internal
Insert | Internal
RaiseChanged | Internal
Remove | Internal
RemoveAt | Internal
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

Changed Internal

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

ComboBoxExItemCollection Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ComboBoxExItemCollection Constructor

Creates a new collection.

[Visual Basic]
Public Sub New( _
ByVal imgList As ImageList, _
ByVal owner As ComboBox _
)
[C#]
public ComboBoxExItemCollection(
ImageList imgList,
ComboBox owner
);

Parameters

imgList
owner

See Also

ComboBoxExItemCollection Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ComboBoxExItemCollection Properties

The properties of the ComboBoxExItemCollection class are listed below. For a complete list of ComboBoxExItemCollection class members, see the ComboBoxExItemCollection Members topic.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
ImageList | Internal.
Item | Internal

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

ComboBoxExItemCollection Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ComboBoxExItemCollection.ImageList Property

Internal.

[Visual Basic]
Public Property ImageList As ImageList
[C#]
public System.Windows.Forms.ImageList ImageList {get; set;}

See Also

ComboBoxExItemCollection Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ComboBoxExItemCollection.Item Property

Internal

[Visual Basic]
Public Default Property Item( _
ByVal index As Integer _
) As ComboBoxExItem
[C#]
public ComboBoxExItem this[
int index
] {get; set;}

See Also

ComboBoxExItemCollection Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ComboBoxExItemCollection Methods

The methods of the ComboBoxExItemCollection class are listed below. For a complete list of ComboBoxExItemCollection class members, see the ComboBoxExItemCollection Members topic.

Public Instance Methods

Add | Internal
AddRange | Internal
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Contains | Internal
CopyTo | Internal
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Internal
Insert | Internal
RaiseChanged | Internal
Remove | Internal
RemoveAt | Internal
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

ComboBoxExItemCollection Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ComboBoxExItemCollection.Add Method

Internal

[Visual Basic]
Public Function Add( _
ByVal item As ComboBoxExItem _
) As Integer
[C#]
public int Add(
ComboBoxExItem item
);

Parameters

item

Return Value

See Also

ComboBoxExItemCollection Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ComboBoxExItemCollection.AddRange Method

Internal

[Visual Basic]
Public Sub AddRange( _
ByVal items As ComboBoxExItem() _
)
[C#]
public void AddRange(
ComboBoxExItem[] items
);

Parameters

items

See Also

ComboBoxExItemCollection Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ComboBoxExItemCollection.Contains Method

Internal

[Visual Basic]
Public Function Contains( _
ByVal item As ComboBoxExItem _
) As Boolean
[C#]
public bool Contains(
ComboBoxExItem item
);

Parameters

item

Return Value

See Also

ComboBoxExItemCollection Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ComboBoxExItemCollection.CopyTo Method

Internal

[Visual Basic]
Public Sub CopyTo( _
ByVal array As Array, _
ByVal index As Integer _
)
[C#]
public void CopyTo(
Array array,
int index
);

Parameters

array
index

See Also

ComboBoxExItemCollection Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ComboBoxExItemCollection.IndexOf Method

Internal

[Visual Basic]
Public Function IndexOf( _
ByVal item As ComboBoxExItem _
) As Integer
[C#]
public int IndexOf(
ComboBoxExItem item
);

Parameters

item

Return Value

See Also

ComboBoxExItemCollection Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ComboBoxExItemCollection.Insert Method

Internal

[Visual Basic]
Public Sub Insert( _
ByVal index As Integer, _
ByVal item As ComboBoxExItem _
)
[C#]
public void Insert(
int index,
ComboBoxExItem item
);

Parameters

index
item

See Also

ComboBoxExItemCollection Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ComboBoxExItemCollection.RaiseChanged Method

Internal

[Visual Basic]
Public Sub RaiseChanged()
[C#]
public void RaiseChanged();

See Also

ComboBoxExItemCollection Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ComboBoxExItemCollection.Remove Method

Internal

[Visual Basic]
Public Sub Remove( _
ByVal item As ComboBoxExItem _
)
[C#]
public void Remove(
ComboBoxExItem item
);

Parameters

item

See Also

ComboBoxExItemCollection Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ComboBoxExItemCollection.RemoveAt Method

Internal

[Visual Basic]
Public Sub RemoveAt( _
ByVal index As Integer _
) Implements _
IList.RemoveAt
[C#]
new public void RemoveAt(
int index
);

Parameters

index

Implements

IList.RemoveAt

See Also

ComboBoxExItemCollection Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ComboBoxExItemCollection Events

The events of the ComboBoxExItemCollection class are listed below. For a complete list of ComboBoxExItemCollection class members, see the ComboBoxExItemCollection Members topic.

Public Instance Events

Changed Internal

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

ComboBoxExItemCollection Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


ComboBoxExItemCollection.Changed Event

Internal

[Visual Basic]
Public Event Changed As EventHandler
[C#]
public event EventHandler Changed;

See Also

ComboBoxExItemCollection Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


DesktopAlert Class

Summary description for DesktopAlert.

For a list of all members of this type, see DesktopAlert Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
DesktopAlert

[Visual Basic]
Public Class DesktopAlert
Inherits Form
[C#]
public class DesktopAlert : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls

Assembly: NETXP.Controls (in NETXP.Controls.dll)

See Also

DesktopAlert Members | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


DesktopAlert Members

DesktopAlert overview

Public Instance Constructors

DesktopAlert Constructor Constructs a new DesktopAlert form.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) |
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScale (inherited from Form) | Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | [To be supplied.]
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsRestrictedWindow (inherited from Form) |
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) |
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TimeoutTicks | Gets or sets the number of timer ticks to wait for before starting the fade-out.
TimerDelay | Gets or sets the period of the timers. This affects how quickly the desktop alert fades in/out.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as the top-most form of your application.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Control) | Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with no owner window.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
CloseClicked | Raised when the close button is clicked.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is not the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LinkClicked | Raised when the link is clicked.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) |
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
TimedOut | Raised when the desktop alert has timed out.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

DesktopAlert Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


DesktopAlert Constructor

Constructs a new DesktopAlert form.

[Visual Basic]
Public Sub New( _
ByVal from As String, _
ByVal subject As String, _
ByVal message As String _
)
[C#]
public DesktopAlert(
string from,
string subject,
string message
);

Parameters

from
The sender of the email message.
subject
The subject of the email message.
message
The message.

See Also

DesktopAlert Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


DesktopAlert Properties

The properties of the DesktopAlert class are listed below. For a complete list of DesktopAlert class members, see the DesktopAlert Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) |
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScale (inherited from Form) | Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | [To be supplied.]
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsRestrictedWindow (inherited from Form) |
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) |
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TimeoutTicks | Gets or sets the number of timer ticks to wait for before starting the fade-out.
TimerDelay | Gets or sets the period of the timers. This affects how quickly the desktop alert fades in/out.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as the top-most form of your application.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

DesktopAlert Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


DesktopAlert.TimeoutTicks Property

Gets or sets the number of timer ticks to wait for before starting the fade-out.

[Visual Basic]
Public Property TimeoutTicks As Integer
[C#]
public int TimeoutTicks {get; set;}

See Also

DesktopAlert Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


DesktopAlert.TimerDelay Property

Gets or sets the period of the timers. This affects how quickly the desktop alert fades in/out.

[Visual Basic]
Public Property TimerDelay As Integer
[C#]
public int TimerDelay {get; set;}

See Also

DesktopAlert Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


DesktopAlert Events

The events of the DesktopAlert class are listed below. For a complete list of DesktopAlert class members, see the DesktopAlert Members topic.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
CloseClicked | Raised when the close button is clicked.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is not the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LinkClicked | Raised when the link is clicked.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) |
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
TimedOut | Raised when the desktop alert has timed out.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

DesktopAlert Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


DesktopAlert.CloseClicked Event

Raised when the close button is clicked.

[Visual Basic]
Public Event CloseClicked As EventHandler
[C#]
public event EventHandler CloseClicked;

See Also

DesktopAlert Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


DesktopAlert.LinkClicked Event

Raised when the link is clicked.

[Visual Basic]
Public Event LinkClicked As EventHandler
[C#]
public event EventHandler LinkClicked;

See Also

DesktopAlert Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


DesktopAlert.TimedOut Event

Raised when the desktop alert has timed out.

[Visual Basic]
Public Event TimedOut As EventHandler
[C#]
public event EventHandler TimedOut;

See Also

DesktopAlert Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


DropDownTreeView Class

A drop-down tree view control.

For a list of all members of this type, see DropDownTreeView Members.

System.Object
MarshalByRefObject
Component
Control
DropDownTreeView

[Visual Basic]
Public Class DropDownTreeView
Inherits Control
[C#]
public class DropDownTreeView : Control

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls

Assembly: NETXP.Controls (in NETXP.Controls.dll)

See Also

DropDownTreeView Members | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


DropDownTreeView Members

DropDownTreeView overview

Public Instance Constructors

DropDownTreeView Constructor Creates a new drop-down tree view.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
IdealTreeViewHeight | The ideal height of the tree view.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextBox | Gets the text box associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TreeView | Gets the tree view associated with this control.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
HideTreeView | Closes the tree view.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
ShowTreeView | Drops down the tree view.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

DropDownTreeView Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


DropDownTreeView Constructor

Creates a new drop-down tree view.

[Visual Basic]
Public Sub New()
[C#]
public DropDownTreeView();

See Also

DropDownTreeView Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


DropDownTreeView Properties

The properties of the DropDownTreeView class are listed below. For a complete list of DropDownTreeView class members, see the DropDownTreeView Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
IdealTreeViewHeight | The ideal height of the tree view.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextBox | Gets the text box associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TreeView | Gets the tree view associated with this control.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

See Also

DropDownTreeView Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


DropDownTreeView.IdealTreeViewHeight Property

The ideal height of the tree view.

[Visual Basic]
Public Property IdealTreeViewHeight As Integer
[C#]
public int IdealTreeViewHeight {get; set;}

See Also

DropDownTreeView Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


DropDownTreeView.TextBox Property

Gets the text box associated with this control.

[Visual Basic]
Public ReadOnly Property TextBox As TextBox
[C#]
public System.Windows.Forms.TextBox TextBox {get;}

See Also

DropDownTreeView Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


DropDownTreeView.TreeView Property

Gets the tree view associated with this control.

[Visual Basic]
Public ReadOnly Property TreeView As TreeViewEx
[C#]
public TreeViewEx TreeView {get;}

See Also

DropDownTreeView Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


DropDownTreeView Methods

The methods of the DropDownTreeView class are listed below. For a complete list of DropDownTreeView class members, see the DropDownTreeView Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
HideTreeView | Closes the tree view.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
ShowTreeView | Drops down the tree view.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

See Also

DropDownTreeView Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


DropDownTreeView.HideTreeView Method

Closes the tree view.

[Visual Basic]
Public Sub HideTreeView()
[C#]
public void HideTreeView();

See Also

DropDownTreeView Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


DropDownTreeView.ShowTreeView Method

Drops down the tree view.

[Visual Basic]
Public Sub ShowTreeView()
[C#]
public void ShowTreeView();

See Also

DropDownTreeView Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


Graph Class

This class implements a graph control.

For a list of all members of this type, see Graph Members.

System.Object
MarshalByRefObject
Component
Control
Graph

[Visual Basic]
Public Class Graph
Inherits Control
[C#]
public class Graph : Control

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls

Assembly: NETXP.Controls (in NETXP.Controls.dll)

See Also

Graph Members | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


Graph Members

Graph overview

Public Instance Constructors

Graph Constructor Constructs a graph with default options.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AxisLabelFont | The font of the labels of the axes.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
fMaxX | For a line graph, the maximum value of the X axis.
fMaxY | For a line graph, the maximum value of the Y axis.
fMinX | For a line graph, the minimum value of the X axis.
fMinY | For a line graph, the minimum value of the Y axis.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
GraphItems | A collection of bars, points, or pie slices.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
HeaderColor | The color of header texts (for axes)
HeaderFont | The font of the header text (graph title)
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
Is3D | If the graph is a bar or pie chart, is the chart drawn in 3D semantics?
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
LineColor | The color of the line (in a line graph) connecting the points.
LineThickness | The thickness of the line (on a line graph)
LOBF | If the graph is a line graph, should it show the line of best fit?
LOBFColor | The color of the line of best fit, in a line graph.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text | The graph's title.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type | The type of graph.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |
XAxisColor | The color of the actual X axis line.
XAxisLabel | The label of the X axis.
YAxisColor | The color of the actual Y axis line.
YAxisLabel | The label of the Y axis.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BeginUpdate | Suspends all repainting until EndUpdate is called.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Clear | Clears the collection of graph items.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
EndUpdate | Refreshes the control and ends the update state.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PlotPoint | Plots a point on a line graph.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
SaveBitmap | Exports the graph as a bitmap image. The file extension specifies the format.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

Graph Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


Graph Constructor

Constructs a graph with default options.

[Visual Basic]
Public Sub New()
[C#]
public Graph();

See Also

Graph Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


Graph Properties

The properties of the Graph class are listed below. For a complete list of Graph class members, see the Graph Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AxisLabelFont | The font of the labels of the axes.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
fMaxX | For a line graph, the maximum value of the X axis.
fMaxY | For a line graph, the maximum value of the Y axis.
fMinX | For a line graph, the minimum value of the X axis.
fMinY | For a line graph, the minimum value of the Y axis.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
GraphItems | A collection of bars, points, or pie slices.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
HeaderColor | The color of header texts (for axes)
HeaderFont | The font of the header text (graph title)
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
Is3D | If the graph is a bar or pie chart, is the chart drawn in 3D semantics?
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
LineColor | The color of the line (in a line graph) connecting the points.
LineThickness | The thickness of the line (on a line graph)
LOBF | If the graph is a line graph, should it show the line of best fit?
LOBFColor | The color of the line of best fit, in a line graph.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text | The graph's title.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type | The type of graph.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |
XAxisColor | The color of the actual X axis line.
XAxisLabel | The label of the X axis.
YAxisColor | The color of the actual Y axis line.
YAxisLabel | The label of the Y axis.

See Also

Graph Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


Graph.AxisLabelFont Property

The font of the labels of the axes.

[Visual Basic]
Public Property AxisLabelFont As Font
[C#]
public System.Drawing.Font AxisLabelFont {get; set;}

See Also

Graph Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


Graph.fMaxX Property

For a line graph, the maximum value of the X axis.

[Visual Basic]
Public Property fMaxX As Double
[C#]
public double fMaxX {get; set;}

See Also

Graph Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


Graph.fMaxY Property

For a line graph, the maximum value of the Y axis.

[Visual Basic]
Public Property fMaxY As Double
[C#]
public double fMaxY {get; set;}

See Also

Graph Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


Graph.fMinX Property

For a line graph, the minimum value of the X axis.

[Visual Basic]
Public Property fMinX As Double
[C#]
public double fMinX {get; set;}

See Also

Graph Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


Graph.fMinY Property

For a line graph, the minimum value of the Y axis.

[Visual Basic]
Public Property fMinY As Double
[C#]
public double fMinY {get; set;}

See Also

Graph Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


Graph.GraphItems Property

A collection of bars, points, or pie slices.

[Visual Basic]
Public ReadOnly Property GraphItems As GraphItemCollection
[C#]
public GraphItemCollection GraphItems {get;}

See Also

Graph Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


Graph.HeaderColor Property

The color of header texts (for axes)

[Visual Basic]
Public Property HeaderColor As Color
[C#]
public System.Drawing.Color HeaderColor {get; set;}

See Also

Graph Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


Graph.HeaderFont Property

The font of the header text (graph title)

[Visual Basic]
Public Property HeaderFont As Font
[C#]
public System.Drawing.Font HeaderFont {get; set;}

See Also

Graph Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


Graph.Is3D Property

If the graph is a bar or pie chart, is the chart drawn in 3D semantics?

[Visual Basic]
Public Property Is3D As Boolean
[C#]
public bool Is3D {get; set;}

See Also

Graph Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


Graph.LineColor Property

The color of the line (in a line graph) connecting the points.

[Visual Basic]
Public Property LineColor As Color
[C#]
public System.Drawing.Color LineColor {get; set;}

See Also

Graph Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


Graph.LineThickness Property

The thickness of the line (on a line graph)

[Visual Basic]
Public Property LineThickness As Integer
[C#]
public int LineThickness {get; set;}

See Also

Graph Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


Graph.LOBF Property

If the graph is a line graph, should it show the line of best fit?

[Visual Basic]
Public Property LOBF As Boolean
[C#]
public bool LOBF {get; set;}

See Also

Graph Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


Graph.LOBFColor Property

The color of the line of best fit, in a line graph.

[Visual Basic]
Public Property LOBFColor As Color
[C#]
public System.Drawing.Color LOBFColor {get; set;}

See Also

Graph Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


Graph.Text Property

The graph's title.

[Visual Basic]
Overrides Public Property Text As String
[C#]
public override string Text {get; set;}

See Also

Graph Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


Graph.Type Property

The type of graph.

[Visual Basic]
Public Property Type As GraphType
[C#]
public GraphType Type {get; set;}

See Also

Graph Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


Graph.XAxisColor Property

The color of the actual X axis line.

[Visual Basic]
Public Property XAxisColor As Color
[C#]
public System.Drawing.Color XAxisColor {get; set;}

See Also

Graph Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


Graph.XAxisLabel Property

The label of the X axis.

[Visual Basic]
Public Property XAxisLabel As String
[C#]
public string XAxisLabel {get; set;}

See Also

Graph Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


Graph.YAxisColor Property

The color of the actual Y axis line.

[Visual Basic]
Public Property YAxisColor As Color
[C#]
public System.Drawing.Color YAxisColor {get; set;}

See Also

Graph Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


Graph.YAxisLabel Property

The label of the Y axis.

[Visual Basic]
Public Property YAxisLabel As String
[C#]
public string YAxisLabel {get; set;}

See Also

Graph Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


Graph Methods

The methods of the Graph class are listed below. For a complete list of Graph class members, see the Graph Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BeginUpdate | Suspends all repainting until EndUpdate is called.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Clear | Clears the collection of graph items.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
EndUpdate | Refreshes the control and ends the update state.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PlotPoint | Plots a point on a line graph.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
SaveBitmap | Exports the graph as a bitmap image. The file extension specifies the format.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

See Also

Graph Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


Graph.BeginUpdate Method

Suspends all repainting until EndUpdate is called.

[Visual Basic]
Public Sub BeginUpdate()
[C#]
public void BeginUpdate();

See Also

Graph Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


Graph.Clear Method

Clears the collection of graph items.

[Visual Basic]
Public Sub Clear()
[C#]
public void Clear();

See Also

Graph Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


Graph.EndUpdate Method

Refreshes the control and ends the update state.

[Visual Basic]
Public Sub EndUpdate()
[C#]
public void EndUpdate();

See Also

Graph Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


Graph.PlotPoint Method

Plots a point on a line graph.

[Visual Basic]
Public Sub PlotPoint( _
ByVal x As Double, _
ByVal y As Double _
)
[C#]
public void PlotPoint(
double x,
double y
);

Parameters

x
The x value of the point.
y
The y value of the point.

See Also

Graph Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


Graph.SaveBitmap Method

Exports the graph as a bitmap image. The file extension specifies the format.

[Visual Basic]
Public Sub SaveBitmap( _
ByVal filename As String, _
ByVal width As Integer, _
ByVal height As Integer _
)
[C#]
public void SaveBitmap(
string filename,
int width,
int height
);

Parameters

filename
The file name.

Formats supported include:
  • GIF - GIF format (256 colors)
  • JPG - JPEG format (Standard compression)
  • PNG - PNG format (Lossless compression)
  • BMP - Bitmap Image for Windows (Standard)
  • EMF - Enhanced MetaFile format
  • ICO - Icon (Not sure what it'll look like though)
  • TIF - TIFF format with standard compression
  • WMF - Windows MetaFile format
  • Any other extension default to Bitmap (BMP) format.
width
The width of the image.
height
The height of the image.

See Also

Graph Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


GraphItem Class

GraphItem

For a list of all members of this type, see GraphItem Members.

System.Object
MarshalByRefObject
Component
GraphItem

[Visual Basic]
Public Class GraphItem
Inherits Component
[C#]
public class GraphItem : Component

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls

Assembly: NETXP.Controls (in NETXP.Controls.dll)

See Also

GraphItem Members | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


GraphItem Members

GraphItem overview

Public Instance Constructors

GraphItem Overloaded. Initializes a new instance of the GraphItem class.

Public Instance Properties

AxisLabel | Label under the bar, or on the pie slice.
BarColor | Bar and pie graph only
Container (inherited from Component) | Gets the IContainer that contains the Component.
GradientBottom | Bar and pie graph only
GradientTop | Bar and pie graph only
ShowValueOnTop | For Bar and Pie charts, show actual value on the bar or pie.
Site (inherited from Component) | Gets or sets the ISite of the Component.
Tag | An object associated with this item.
Value | Value (Bar) or degree (Pie)
X | Line graph only: X value of point.
Y | Line graph only: Y value of point.

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
ToString (inherited from Component) |

Public Instance Events

Changed | Raised when one or more of the item's properties changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.

See Also

GraphItem Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


GraphItem Constructor

Creates a graph item to store in the specified container.

Overload List

Creates a graph item with the default options.

public GraphItem();

Creates a graph item to store in the specified container.

public GraphItem(IContainer);

See Also

GraphItem Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


GraphItem Constructor (IContainer)

Creates a graph item to store in the specified container.

[Visual Basic]
Overloads Public Sub New( _
ByVal container As IContainer _
)
[C#]
public GraphItem(
IContainer container
);

Parameters

container
For designer support.

See Also

GraphItem Class | NETXP.Controls Namespace | GraphItem Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


GraphItem Constructor ()

Creates a graph item with the default options.

[Visual Basic]
Overloads Public Sub New()
[C#]
public GraphItem();

See Also

GraphItem Class | NETXP.Controls Namespace | GraphItem Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


GraphItem Properties

The properties of the GraphItem class are listed below. For a complete list of GraphItem class members, see the GraphItem Members topic.

Public Instance Properties

AxisLabel | Label under the bar, or on the pie slice.
BarColor | Bar and pie graph only
Container (inherited from Component) | Gets the IContainer that contains the Component.
GradientBottom | Bar and pie graph only
GradientTop | Bar and pie graph only
ShowValueOnTop | For Bar and Pie charts, show actual value on the bar or pie.
Site (inherited from Component) | Gets or sets the ISite of the Component.
Tag | An object associated with this item.
Value | Value (Bar) or degree (Pie)
X | Line graph only: X value of point.
Y | Line graph only: Y value of point.

See Also

GraphItem Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


GraphItem.AxisLabel Property

Label under the bar, or on the pie slice.

[Visual Basic]
Public Property AxisLabel As String
[C#]
public string AxisLabel {get; set;}

See Also

GraphItem Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


GraphItem.BarColor Property

Bar and pie graph only

[Visual Basic]
Public Property BarColor As Color
[C#]
public System.Drawing.Color BarColor {get; set;}

See Also

GraphItem Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


GraphItem.GradientBottom Property

Bar and pie graph only

[Visual Basic]
Public Property GradientBottom As Color
[C#]
public System.Drawing.Color GradientBottom {get; set;}

See Also

GraphItem Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


GraphItem.GradientTop Property

Bar and pie graph only

[Visual Basic]
Public Property GradientTop As Color
[C#]
public System.Drawing.Color GradientTop {get; set;}

See Also

GraphItem Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


GraphItem.ShowValueOnTop Property

For Bar and Pie charts, show actual value on the bar or pie.

[Visual Basic]
Public Property ShowValueOnTop As Boolean
[C#]
public bool ShowValueOnTop {get; set;}

See Also

GraphItem Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


GraphItem.Tag Property

An object associated with this item.

[Visual Basic]
Public Property Tag As Object
[C#]
public object Tag {get; set;}

See Also

GraphItem Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


GraphItem.Value Property

Value (Bar) or degree (Pie)

[Visual Basic]
Public Property Value As Double
[C#]
public double Value {get; set;}

See Also

GraphItem Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


GraphItem.X Property

Line graph only: X value of point.

[Visual Basic]
Public Property X As Double
[C#]
public double X {get; set;}

See Also

GraphItem Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


GraphItem.Y Property

Line graph only: Y value of point.

[Visual Basic]
Public Property Y As Double
[C#]
public double Y {get; set;}

See Also

GraphItem Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


GraphItem Events

The events of the GraphItem class are listed below. For a complete list of GraphItem class members, see the GraphItem Members topic.

Public Instance Events

Changed | Raised when one or more of the item's properties changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.

See Also

GraphItem Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


GraphItem.Changed Event

Raised when one or more of the item's properties changes.

[Visual Basic]
Public Event Changed As EventHandler
[C#]
public event EventHandler Changed;

See Also

GraphItem Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


GraphItemCollection Class

Collection

For a list of all members of this type, see GraphItemCollection Members.

System.Object
CollectionBase
GraphItemCollection

[Visual Basic]
Public Class GraphItemCollection
Inherits CollectionBase
[C#]
public class GraphItemCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls

Assembly: NETXP.Controls (in NETXP.Controls.dll)

See Also

GraphItemCollection Members | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


GraphItemCollection Members

GraphItemCollection overview

Public Instance Constructors

GraphItemCollection Constructor Not for public use.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Item | Not for public use.

Public Instance Methods

Add | Not for public use.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

Changed Not for public use.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

GraphItemCollection Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


GraphItemCollection Constructor

Not for public use.

[Visual Basic]
Public Sub New()
[C#]
public GraphItemCollection();

See Also

GraphItemCollection Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


GraphItemCollection Properties

The properties of the GraphItemCollection class are listed below. For a complete list of GraphItemCollection class members, see the GraphItemCollection Members topic.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Item | Not for public use.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

GraphItemCollection Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


GraphItemCollection.Item Property

Not for public use.

[Visual Basic]
Public Default Property Item( _
ByVal index As Integer _
) As GraphItem
[C#]
public GraphItem this[
int index
] {get; set;}

See Also

GraphItemCollection Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


GraphItemCollection Methods

The methods of the GraphItemCollection class are listed below. For a complete list of GraphItemCollection class members, see the GraphItemCollection Members topic.

Public Instance Methods

Add | Not for public use.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

GraphItemCollection Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


GraphItemCollection.Add Method

Not for public use.

[Visual Basic]
Public Function Add( _
ByVal item As GraphItem _
) As Integer
[C#]
public int Add(
GraphItem item
);

Parameters

item

Return Value

See Also

GraphItemCollection Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


GraphItemCollection Events

The events of the GraphItemCollection class are listed below. For a complete list of GraphItemCollection class members, see the GraphItemCollection Members topic.

Public Instance Events

Changed Not for public use.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

GraphItemCollection Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


GraphItemCollection.Changed Event

Not for public use.

[Visual Basic]
Public Event Changed As EventHandler
[C#]
public event EventHandler Changed;

See Also

GraphItemCollection Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


GraphType Enumeration

The type of graph.

[Visual Basic]
Public Enum GraphType
[C#]
public enum GraphType

Members

Member Name | Description
Bar | Graph is a bar graph.
Line | Graph is a line graph.
Pie | Graph is a pie chart.

Requirements

Namespace: NETXP.Controls

Assembly: NETXP.Controls (in NETXP.Controls.dll)

See Also

NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


Mask Enumeration

Type of mask.

[Visual Basic]
Public Enum Mask
[C#]
public enum Mask

Members

Member Name | Description
None | No mask.
DateOnly | Only allow dates.
PhoneWithArea | Mask for phone number and area code.
IpAddress | Mask for IP address.
SSN | Mask for social security number.
Decimal | Mask for a decimal number.
Digit | Mask for any digit.

Requirements

Namespace: NETXP.Controls

Assembly: NETXP.Controls (in NETXP.Controls.dll)

See Also

NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


MaskedTextBox Class

A textbox that automatically provides a mask based on required input.

For a list of all members of this type, see MaskedTextBox Members.

System.Object
MarshalByRefObject
Component
Control
TextBoxBase
TextBox
MaskedTextBox

[Visual Basic]
Public Class MaskedTextBox
Inherits TextBox
[C#]
public class MaskedTextBox : TextBox

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls

Assembly: NETXP.Controls (in NETXP.Controls.dll)

See Also

MaskedTextBox Members | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


MaskedTextBox Members

MaskedTextBox overview

Public Instance Constructors

MaskedTextBox Constructor Creates a masked textbox.

Public Instance Properties

AcceptsReturn (inherited from TextBox) | Gets or sets a value indicating whether pressing ENTER in a multiline TextBox control creates a new line of text in the control or activates the default button for the form.
AcceptsTab (inherited from TextBoxBase) | Gets or sets a value indicating whether pressing the TAB key in a multiline text box control types a TAB character in the control instead of moving the focus to the next control in the tab order.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoSize (inherited from TextBoxBase) | Gets or sets a value indicating whether the height of the control automatically adjusts when the font assigned to the control is changed.
BackColor (inherited from TextBoxBase) | Gets or sets the background color of the control.
BackgroundImage (inherited from TextBoxBase) |
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BorderStyle (inherited from TextBoxBase) | Gets or sets the border type of the text box control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
CanUndo (inherited from TextBoxBase) | Gets a value indicating whether the user can undo the previous operation in a text box control.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
CharacterCasing (inherited from TextBox) | Gets or sets whether the TextBox control modifies the case of characters as they are typed.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from TextBoxBase) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HideSelection (inherited from TextBoxBase) | Gets or sets a value indicating whether the selected text in the text box control remains highlighted when the control loses focus.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Lines (inherited from TextBoxBase) | Gets or sets the lines of text in a text box control.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Masked | Gets or sets the current mask.
MaxLength (inherited from TextBoxBase) | Gets or sets the maximum number of characters the user can type or paste into the text box control.
Modified (inherited from TextBoxBase) | Gets or sets a value that indicates that the text box control has been modified by the user since the control was created or its contents were last set.
Multiline (inherited from TextBoxBase) | Gets or sets a value indicating whether this is a multiline text box control.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PasswordChar (inherited from TextBox) | Gets or sets the character used to mask characters of a password in a single-line TextBox control.
PreferredHeight (inherited from TextBoxBase) | Gets the preferred height for a single-line text box.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
ReadOnly (inherited from TextBoxBase) | Gets or sets a value indicating whether text in the text box is read-only.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ScrollBars (inherited from TextBox) | Gets or sets which scroll bars should appear in a multiline TextBox control.
SelectedText (inherited from TextBoxBase) | Gets or sets a value indicating the currently selected text in the control.
SelectionLength (inherited from TextBox) |
SelectionStart (inherited from TextBoxBase) | Gets or sets the starting point of text selected in the text box.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from TextBox) |
TextAlign (inherited from TextBox) | Gets or sets how text is aligned in a TextBox control.
TextLength (inherited from TextBoxBase) | Gets the length of text in the control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |
WordWrap (inherited from TextBoxBase) | Indicates whether a multiline text box control automatically wraps words to the beginning of the next line when necessary.

Public Instance Methods

AppendText (inherited from TextBoxBase) | Appends text to the current text of text box.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Clear (inherited from TextBoxBase) | Clears all text from the text box control.
ClearUndo (inherited from TextBoxBase) | Clears information about the most recent operation from the undo buffer of the text box.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
Copy (inherited from TextBoxBase) | Copies the current selection in the text box to the Clipboard.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Cut (inherited from TextBoxBase) | Moves the current selection in the text box to the Clipboard.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
Paste (inherited from TextBoxBase) | Replaces the current selection in the text box with the contents of the Clipboard.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollToCaret (inherited from TextBoxBase) | Scrolls the contents of the control to the current caret position.
Select (inherited from TextBoxBase) | Overloaded. Selects a range of text in the text box.
Select (inherited from Control) | Overloaded. Activates the control.
SelectAll (inherited from TextBoxBase) | Selects all text in the text box.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from TextBoxBase) |
Undo (inherited from TextBoxBase) | Undoes the last edit operation in the text box.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

AcceptsTabChanged (inherited from TextBoxBase) | Occurs when the value of the AcceptsTab property has changed.
AutoSizeChanged (inherited from TextBoxBase) | Occurs when the value of the AutoSize property has changed.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from TextBoxBase) |
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
BorderStyleChanged (inherited from TextBoxBase) | Occurs when the value of the BorderStyle property has changed.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from TextBoxBase) | Occurs when the text box is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
HideSelectionChanged (inherited from TextBoxBase) | Occurs when the value of the HideSelection property has changed.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
ModifiedChanged (inherited from TextBoxBase) | Occurs when the value of the Modified property has changed.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
MultilineChanged (inherited from TextBoxBase) | Occurs when the value of the Multiline property has changed.
Paint (inherited from TextBoxBase) |
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
ReadOnlyChanged (inherited from TextBoxBase) | Occurs when the value of the ReadOnly property has changed.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextAlignChanged (inherited from TextBox) | Occurs when the value of the TextAlign property has changed.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

MaskedTextBox Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


MaskedTextBox Constructor

Creates a masked textbox.

[Visual Basic]
Public Sub New()
[C#]
public MaskedTextBox();

See Also

MaskedTextBox Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


MaskedTextBox Properties

The properties of the MaskedTextBox class are listed below. For a complete list of MaskedTextBox class members, see the MaskedTextBox Members topic.

Public Instance Properties

AcceptsReturn (inherited from TextBox) | Gets or sets a value indicating whether pressing ENTER in a multiline TextBox control creates a new line of text in the control or activates the default button for the form.
AcceptsTab (inherited from TextBoxBase) | Gets or sets a value indicating whether pressing the TAB key in a multiline text box control types a TAB character in the control instead of moving the focus to the next control in the tab order.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoSize (inherited from TextBoxBase) | Gets or sets a value indicating whether the height of the control automatically adjusts when the font assigned to the control is changed.
BackColor (inherited from TextBoxBase) | Gets or sets the background color of the control.
BackgroundImage (inherited from TextBoxBase) |
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BorderStyle (inherited from TextBoxBase) | Gets or sets the border type of the text box control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
CanUndo (inherited from TextBoxBase) | Gets a value indicating whether the user can undo the previous operation in a text box control.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
CharacterCasing (inherited from TextBox) | Gets or sets whether the TextBox control modifies the case of characters as they are typed.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from TextBoxBase) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HideSelection (inherited from TextBoxBase) | Gets or sets a value indicating whether the selected text in the text box control remains highlighted when the control loses focus.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Lines (inherited from TextBoxBase) | Gets or sets the lines of text in a text box control.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Masked | Gets or sets the current mask.
MaxLength (inherited from TextBoxBase) | Gets or sets the maximum number of characters the user can type or paste into the text box control.
Modified (inherited from TextBoxBase) | Gets or sets a value that indicates that the text box control has been modified by the user since the control was created or its contents were last set.
Multiline (inherited from TextBoxBase) | Gets or sets a value indicating whether this is a multiline text box control.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PasswordChar (inherited from TextBox) | Gets or sets the character used to mask characters of a password in a single-line TextBox control.
PreferredHeight (inherited from TextBoxBase) | Gets the preferred height for a single-line text box.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
ReadOnly (inherited from TextBoxBase) | Gets or sets a value indicating whether text in the text box is read-only.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ScrollBars (inherited from TextBox) | Gets or sets which scroll bars should appear in a multiline TextBox control.
SelectedText (inherited from TextBoxBase) | Gets or sets a value indicating the currently selected text in the control.
SelectionLength (inherited from TextBox) |
SelectionStart (inherited from TextBoxBase) | Gets or sets the starting point of text selected in the text box.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from TextBox) |
TextAlign (inherited from TextBox) | Gets or sets how text is aligned in a TextBox control.
TextLength (inherited from TextBoxBase) | Gets the length of text in the control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |
WordWrap (inherited from TextBoxBase) | Indicates whether a multiline text box control automatically wraps words to the beginning of the next line when necessary.

See Also

MaskedTextBox Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


MaskedTextBox.Masked Property

Gets or sets the current mask.

[Visual Basic]
Public Property Masked As Mask
[C#]
public Mask Masked {get; set;}

See Also

MaskedTextBox Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


MRUKeyHive Enumeration

Enumeration for possible types of registry base keys for storing most recntly typed URLs

[Visual Basic]
Public Enum MRUKeyHive
[C#]
public enum MRUKeyHive

Members

Member Name | Description
CurrentUser | Value that indicates HKEY_CURRENT_USER should be used for MRUKey property
LocalMachine | Value that indicates HKEY_LOCAL_MACHINE should be used for MRUKey property

Requirements

Namespace: NETXP.Controls

Assembly: NETXP.Controls (in NETXP.Controls.dll)

See Also

NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


MultiPage Class

The MultiPage control is a tab control that does not show its tabs. It is used for the wizard form.

For a list of all members of this type, see MultiPage Members.

System.Object
MarshalByRefObject
Component
Control
TabControl
MultiPage

[Visual Basic]
NotInheritable Public Class MultiPage
Inherits TabControl
[C#]
public sealed class MultiPage : TabControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls

Assembly: NETXP.Controls (in NETXP.Controls.dll)

See Also

MultiPage Members | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


MultiPage Members

MultiPage overview

Public Instance Constructors

MultiPage Constructor Creates a MultiPage control.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
Alignment (inherited from TabControl) | Gets or sets the area of the control (for example, along the top) where the tabs are aligned.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
Appearance (inherited from TabControl) | Gets or sets the visual appearance of the control's tabs.
BackColor (inherited from TabControl) |
BackgroundImage (inherited from TabControl) |
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from TabControl) | Gets the display area of the control's tab pages.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DrawMode (inherited from TabControl) | Gets or sets the way that the control's tab pages are drawn.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from TabControl) |
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HotTrack (inherited from TabControl) | Gets or sets a value indicating whether the control's tabs change in appearance when the mouse passes over them.
ImageList (inherited from TabControl) | Gets or sets the images to display on the control's tabs.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
ItemSize (inherited from TabControl) | Gets or sets the size of the control's tabs.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Multiline (inherited from TabControl) | Gets or sets a value indicating whether more than one row of tabs can be displayed.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from TabControl) | Gets or sets the amount of space around each item on the control's tab pages.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RowCount (inherited from TabControl) | Gets the number of rows that are currently being displayed in the control's tab strip.
SelectedIndex (inherited from TabControl) | Gets or sets the index of the currently-selected tab page.
SelectedTab (inherited from TabControl) | Gets or sets the currently-selected tab page.
ShowTabs | Show tabs?
ShowToolTips (inherited from TabControl) | Gets or sets a value indicating whether a tab's ToolTip is shown when the mouse passes over the tab.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeMode (inherited from TabControl) | Gets or sets the way that the control's tabs are sized.
TabCount (inherited from TabControl) | Gets the number of tabs in the tab strip.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabPages (inherited from TabControl) | Gets the collection of tab pages in this tab control.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from TabControl) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetControl (inherited from TabControl) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetTabRect (inherited from TabControl) | Returns the bounding rectangle for a specified tab in this tab control.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from TabControl) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

BackColorChanged (inherited from TabControl) |
BackgroundImageChanged (inherited from TabControl) |
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
DrawItem (inherited from TabControl) | Occurs when the tabs are drawn, if the DrawMode property is set to OwnerDrawFixed.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from TabControl) |
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from TabControl) |
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SelectedIndexChanged (inherited from TabControl) | Occurs when the SelectedIndex property is changed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from TabControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

MultiPage Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


MultiPage Constructor

Creates a MultiPage control.

[Visual Basic]
Public Sub New()
[C#]
public MultiPage();

See Also

MultiPage Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


MultiPage Properties

The properties of the MultiPage class are listed below. For a complete list of MultiPage class members, see the MultiPage Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
Alignment (inherited from TabControl) | Gets or sets the area of the control (for example, along the top) where the tabs are aligned.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
Appearance (inherited from TabControl) | Gets or sets the visual appearance of the control's tabs.
BackColor (inherited from TabControl) |
BackgroundImage (inherited from TabControl) |
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from TabControl) | Gets the display area of the control's tab pages.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DrawMode (inherited from TabControl) | Gets or sets the way that the control's tab pages are drawn.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from TabControl) |
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HotTrack (inherited from TabControl) | Gets or sets a value indicating whether the control's tabs change in appearance when the mouse passes over them.
ImageList (inherited from TabControl) | Gets or sets the images to display on the control's tabs.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
ItemSize (inherited from TabControl) | Gets or sets the size of the control's tabs.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Multiline (inherited from TabControl) | Gets or sets a value indicating whether more than one row of tabs can be displayed.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from TabControl) | Gets or sets the amount of space around each item on the control's tab pages.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RowCount (inherited from TabControl) | Gets the number of rows that are currently being displayed in the control's tab strip.
SelectedIndex (inherited from TabControl) | Gets or sets the index of the currently-selected tab page.
SelectedTab (inherited from TabControl) | Gets or sets the currently-selected tab page.
ShowTabs | Show tabs?
ShowToolTips (inherited from TabControl) | Gets or sets a value indicating whether a tab's ToolTip is shown when the mouse passes over the tab.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeMode (inherited from TabControl) | Gets or sets the way that the control's tabs are sized.
TabCount (inherited from TabControl) | Gets the number of tabs in the tab strip.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabPages (inherited from TabControl) | Gets the collection of tab pages in this tab control.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from TabControl) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

See Also

MultiPage Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


MultiPage.ShowTabs Property

Show tabs?

[Visual Basic]
Public Property ShowTabs As Boolean
[C#]
public bool ShowTabs {get; set;}

See Also

MultiPage Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


RealPanel Class

A panel control that ACTUALLY inherits ContainerControl, unlike its Windows Forms cousin.

For a list of all members of this type, see RealPanel Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
RealPanel

[Visual Basic]
Public Class RealPanel
Inherits ContainerControl
[C#]
public class RealPanel : ContainerControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls

Assembly: NETXP.Controls (in NETXP.Controls.dll)

See Also

RealPanel Members | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


RealPanel Members

RealPanel overview

Public Instance Constructors

RealPanel Constructor Empty constructor.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

RealPanel Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


RealPanel Constructor

Empty constructor.

[Visual Basic]
Public Sub New()
[C#]
public RealPanel();

See Also

RealPanel Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


SkinnedPanel Class

SkinnedPanel is a panel that uses the XP tab page background.

For a list of all members of this type, see SkinnedPanel Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
RealPanel
SkinnedPanel

[Visual Basic]
Public Class SkinnedPanel
Inherits RealPanel
[C#]
public class SkinnedPanel : RealPanel

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls

Assembly: NETXP.Controls (in NETXP.Controls.dll)

See Also

SkinnedPanel Members | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


SkinnedPanel Members

SkinnedPanel overview

Public Instance Constructors

SkinnedPanel Constructor Constructs a new SkinnedPanel.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor | Hides an inherited property.
BackgroundImage | Hides the inherited property.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseTheme | Determines whether or not the application is using XP themes.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

SkinnedPanel Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


SkinnedPanel Constructor

Constructs a new SkinnedPanel.

[Visual Basic]
Public Sub New()
[C#]
public SkinnedPanel();

See Also

SkinnedPanel Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


SkinnedPanel Properties

The properties of the SkinnedPanel class are listed below. For a complete list of SkinnedPanel class members, see the SkinnedPanel Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor | Hides an inherited property.
BackgroundImage | Hides the inherited property.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseTheme | Determines whether or not the application is using XP themes.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

SkinnedPanel Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


SkinnedPanel.BackColor Property

Hides an inherited property.

[Visual Basic]
Public Property BackColor As Color
[C#]
new public System.Drawing.Color BackColor {get; set;}

See Also

SkinnedPanel Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


SkinnedPanel.BackgroundImage Property

Hides the inherited property.

[Visual Basic]
Public ReadOnly Property BackgroundImage As Image
[C#]
new public System.Drawing.Image BackgroundImage {get;}

See Also

SkinnedPanel Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


SkinnedPanel.UseTheme Property

Determines whether or not the application is using XP themes.

[Visual Basic]
Public ReadOnly Property UseTheme As Boolean
[C#]
public bool UseTheme {get;}

See Also

SkinnedPanel Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


TreeViewEx Class

TreeViewEx is an extension to TreeView which automatically checks and unchecks child items.

For a list of all members of this type, see TreeViewEx Members.

System.Object
MarshalByRefObject
Component
Control
TreeView
TreeViewEx

[Visual Basic]
Public Class TreeViewEx
Inherits TreeView
[C#]
public class TreeViewEx : TreeView

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls

Assembly: NETXP.Controls (in NETXP.Controls.dll)

See Also

TreeViewEx Members | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


TreeViewEx Members

TreeViewEx overview

Public Instance Constructors

TreeViewEx Constructor Creates a new TreeViewEx control.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from TreeView) |
BackgroundImage (inherited from TreeView) |
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BorderStyle (inherited from TreeView) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
CheckBoxes (inherited from TreeView) | Gets or sets a value indicating whether check boxes are displayed next to the tree nodes in the tree view control.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from TreeView) |
FullRowSelect (inherited from TreeView) | Gets or sets a value indicating whether the selection highlight spans the width of the tree view control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HideSelection (inherited from TreeView) | Gets or sets a value indicating whether the selected tree node remains highlighted even when the tree view has lost the focus.
HotTracking (inherited from TreeView) | Gets or sets a value indicating whether a tree node label takes on the appearance of a hyperlink as the mouse pointer passes over it.
ImageIndex (inherited from TreeView) | Gets or sets the image-list index value of the default image that is displayed by the tree nodes.
ImageList (inherited from TreeView) | Gets or sets the ImageList that contains the Image objects used by the tree nodes.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
Indent (inherited from TreeView) | Gets or sets the distance to indent each of the child tree node levels.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
ItemHeight (inherited from TreeView) | Gets or sets the height of each tree node in the tree view control.
LabelEdit (inherited from TreeView) | Gets or sets a value indicating whether the label text of the tree nodes can be edited.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Nodes (inherited from TreeView) | Gets the collection of tree nodes that are assigned to the tree view control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PathSeparator (inherited from TreeView) | Gets or sets the delimiter string that the tree node path uses.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Scrollable (inherited from TreeView) | Gets or sets a value indicating whether the tree view control displays scroll bars when they are needed.
SelectedImageIndex (inherited from TreeView) | Gets or sets the image list index value of the image that is displayed when a tree node is selected.
SelectedNode (inherited from TreeView) | Gets or sets the tree node that is currently selected in the tree view control.
ShowLines (inherited from TreeView) | Gets or sets a value indicating whether lines are drawn between tree nodes in the tree view control.
ShowPlusMinus (inherited from TreeView) | Gets or sets a value indicating whether plus-sign (+) and minus-sign (-) buttons are displayed next to tree nodes that contain child tree nodes.
ShowRootLines (inherited from TreeView) | Gets or sets a value indicating whether lines are drawn between the tree nodes that are at the root of the tree view.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
Sorted (inherited from TreeView) | Gets or sets a value indicating whether the tree nodes in the tree view are sorted.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from TreeView) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopNode (inherited from TreeView) | Gets the first fully-visible tree node in the tree view control.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
VisibleCount (inherited from TreeView) | Gets the number of tree nodes that can be fully visible in the tree view control.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BeginUpdate (inherited from TreeView) | Disables any redrawing of the tree view.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
CollapseAll (inherited from TreeView) | Collapses all the tree nodes.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
EndUpdate (inherited from TreeView) | Enables the redrawing of the tree view.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExpandAll (inherited from TreeView) | Expands all the tree nodes.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetNodeAt (inherited from TreeView) | Overloaded. Retrieves the tree node that is at the specified point.
GetNodeCount (inherited from TreeView) | Retrieves the number of tree nodes, optionally including those in all subtrees, assigned to the tree view control.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from TreeView) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

AfterCheck (inherited from TreeView) | Occurs after the tree node check box is checked.
AfterCollapse (inherited from TreeView) | Occurs after the tree node is collapsed.
AfterExpand (inherited from TreeView) | Occurs after the tree node is expanded.
AfterLabelEdit (inherited from TreeView) | Occurs after the tree node label text is edited.
AfterSelect (inherited from TreeView) | Occurs after the tree node is selected.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from TreeView) |
BeforeCheck (inherited from TreeView) | Occurs before the tree node check box is checked.
BeforeCollapse (inherited from TreeView) | Occurs before the tree node is collapsed.
BeforeExpand (inherited from TreeView) | Occurs before the tree node is expanded.
BeforeLabelEdit (inherited from TreeView) | Occurs before the tree node label text is edited.
BeforeSelect (inherited from TreeView) | Occurs before the tree node is selected.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
ItemDrag (inherited from TreeView) | Occurs when an item is dragged into the tree view control.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from TreeView) |
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from TreeView) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

TreeViewEx Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


TreeViewEx Constructor

Creates a new TreeViewEx control.

[Visual Basic]
Public Sub New()
[C#]
public TreeViewEx();

See Also

TreeViewEx Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


XPButton Class

XPButton extends the Button control by providing an Office-XP look or a Windows XP skinned look PLUS an icon.

For a list of all members of this type, see XPButton Members.

System.Object
MarshalByRefObject
Component
Control
ButtonBase
Button
XPButton

[Visual Basic]
Public Class XPButton
Inherits Button
[C#]
public class XPButton : Button

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls

Assembly: NETXP.Controls (in NETXP.Controls.dll)

See Also

XPButton Members | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


XPButton Members

XPButton overview

Public Instance Constructors

XPButton Constructor Creates a new XPButton.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DialogResult (inherited from Button) | Gets or sets a value that is returned to the parent form when the button is clicked.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
EnableFade | Allow gradual rollover fade?
FlatStyle (inherited from ButtonBase) | Gets or sets the flat style appearance of the button control.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
Image (inherited from ButtonBase) | Gets or sets the image that is displayed on a button control.
ImageAlign (inherited from ButtonBase) | Gets or sets the alignment of the image on the button control.
ImageIndex (inherited from ButtonBase) | Gets or sets the image list index value of the image displayed on the button control.
ImageList (inherited from ButtonBase) | Gets or sets the ImageList that contains the Image displayed on a button control.
ImeMode (inherited from ButtonBase) | Gets or sets the Input Method Editor (IME) mode supported by this control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextAlign (inherited from ButtonBase) | Gets or sets the alignment of the text on the button control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseXPThemes | Indicates whether or not to use Windows XP visual styles. Enabling this does not allow setting custom colors for the button.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
NotifyDefault (inherited from Button) | Notifies the Button whether it is the default button so that it can adjust its appearance accordingly.
PerformClick (inherited from Button) | Generates a Click event for a button.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Button) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Button) |
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from ButtonBase) |
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

XPButton Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


XPButton Constructor

Creates a new XPButton.

[Visual Basic]
Public Sub New()
[C#]
public XPButton();

See Also

XPButton Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


XPButton Properties

The properties of the XPButton class are listed below. For a complete list of XPButton class members, see the XPButton Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DialogResult (inherited from Button) | Gets or sets a value that is returned to the parent form when the button is clicked.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
EnableFade | Allow gradual rollover fade?
FlatStyle (inherited from ButtonBase) | Gets or sets the flat style appearance of the button control.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
Image (inherited from ButtonBase) | Gets or sets the image that is displayed on a button control.
ImageAlign (inherited from ButtonBase) | Gets or sets the alignment of the image on the button control.
ImageIndex (inherited from ButtonBase) | Gets or sets the image list index value of the image displayed on the button control.
ImageList (inherited from ButtonBase) | Gets or sets the ImageList that contains the Image displayed on a button control.
ImeMode (inherited from ButtonBase) | Gets or sets the Input Method Editor (IME) mode supported by this control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextAlign (inherited from ButtonBase) | Gets or sets the alignment of the text on the button control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseXPThemes | Indicates whether or not to use Windows XP visual styles. Enabling this does not allow setting custom colors for the button.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

See Also

XPButton Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


XPButton.EnableFade Property

Allow gradual rollover fade?

[Visual Basic]
Public Property EnableFade As Boolean
[C#]
public bool EnableFade {get; set;}

See Also

XPButton Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


XPButton.UseXPThemes Property

Indicates whether or not to use Windows XP visual styles. Enabling this does not allow setting custom colors for the button.

[Visual Basic]
Public Property UseXPThemes As Boolean
[C#]
public bool UseXPThemes {get; set;}

See Also

XPButton Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


XPCheckBox Class

XPCheckBox is a check box that draws itself using XP visual styles. It is meant to be used on SkinnedPanel controls where the normal .NET checkbox would not draw itself properly.

For a list of all members of this type, see XPCheckBox Members.

System.Object
MarshalByRefObject
Component
Control
ButtonBase
CheckBox
XPCheckBox

[Visual Basic]
Public Class XPCheckBox
Inherits CheckBox
[C#]
public class XPCheckBox : CheckBox

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls

Assembly: NETXP.Controls (in NETXP.Controls.dll)

See Also

XPCheckBox Members | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


XPCheckBox Members

XPCheckBox overview

Public Instance Constructors

XPCheckBox Constructor Constructs a new XPCheckBox.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
Appearance (inherited from CheckBox) | Gets or sets the value that determines the appearance of a check box control.
AutoCheck (inherited from CheckBox) | Gets or set a value indicating whether the Checked or CheckState values and the check box's appearance are automatically changed when the check box is clicked.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage | Hides the inherited property.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
CheckAlign | Hides the inherited property.
Checked (inherited from CheckBox) | Gets or set a value indicating whether the check box is in the checked state.
CheckState (inherited from CheckBox) | Gets or sets the state of the check box.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
FlatStyle | Hides the inherited property.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
Image | Hides the inherited property.
ImageAlign | Hides the inherited property.
ImageIndex | Hides the inherited property.
ImageList | Hides the inherited property.
ImeMode (inherited from ButtonBase) | Gets or sets the Input Method Editor (IME) mode supported by this control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextAlign | Hides the inherited property.
TextColor | The color of the checkbox text.
ThreeState (inherited from CheckBox) | Gets or sets a value indicating whether the check box will allow three check states rather than two.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseTheme | Determines whether or not the application is using XP themes.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from CheckBox) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

AppearanceChanged (inherited from CheckBox) | Occurs when the value of the Appearance property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
CheckedChanged (inherited from CheckBox) | Occurs when the value of the Checked property changes.
CheckStateChanged (inherited from CheckBox) | Occurs when the value of the CheckState property changes.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from CheckBox) |
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from ButtonBase) |
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

XPCheckBox Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


XPCheckBox Constructor

Constructs a new XPCheckBox.

[Visual Basic]
Public Sub New()
[C#]
public XPCheckBox();

See Also

XPCheckBox Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


XPCheckBox Properties

The properties of the XPCheckBox class are listed below. For a complete list of XPCheckBox class members, see the XPCheckBox Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
Appearance (inherited from CheckBox) | Gets or sets the value that determines the appearance of a check box control.
AutoCheck (inherited from CheckBox) | Gets or set a value indicating whether the Checked or CheckState values and the check box's appearance are automatically changed when the check box is clicked.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage | Hides the inherited property.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
CheckAlign | Hides the inherited property.
Checked (inherited from CheckBox) | Gets or set a value indicating whether the check box is in the checked state.
CheckState (inherited from CheckBox) | Gets or sets the state of the check box.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
FlatStyle | Hides the inherited property.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
Image | Hides the inherited property.
ImageAlign | Hides the inherited property.
ImageIndex | Hides the inherited property.
ImageList | Hides the inherited property.
ImeMode (inherited from ButtonBase) | Gets or sets the Input Method Editor (IME) mode supported by this control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextAlign | Hides the inherited property.
TextColor | The color of the checkbox text.
ThreeState (inherited from CheckBox) | Gets or sets a value indicating whether the check box will allow three check states rather than two.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseTheme | Determines whether or not the application is using XP themes.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

See Also

XPCheckBox Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


XPCheckBox.BackgroundImage Property

Hides the inherited property.

[Visual Basic]
Public ReadOnly Property BackgroundImage As Image
[C#]
new public System.Drawing.Image BackgroundImage {get;}

See Also

XPCheckBox Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


XPCheckBox.CheckAlign Property

Hides the inherited property.

[Visual Basic]
Public ReadOnly Property CheckAlign As ContentAlignment
[C#]
new public System.Drawing.ContentAlignment CheckAlign {get;}

See Also

XPCheckBox Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


XPCheckBox.FlatStyle Property

Hides the inherited property.

[Visual Basic]
Public ReadOnly Property FlatStyle As FlatStyle
[C#]
new public System.Windows.Forms.FlatStyle FlatStyle {get;}

See Also

XPCheckBox Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


XPCheckBox.Image Property

Hides the inherited property.

[Visual Basic]
Public ReadOnly Property Image As Image
[C#]
new public System.Drawing.Image Image {get;}

See Also

XPCheckBox Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


XPCheckBox.ImageAlign Property

Hides the inherited property.

[Visual Basic]
Public ReadOnly Property ImageAlign As ContentAlignment
[C#]
new public System.Drawing.ContentAlignment ImageAlign {get;}

See Also

XPCheckBox Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


XPCheckBox.ImageIndex Property

Hides the inherited property.

[Visual Basic]
Public ReadOnly Property ImageIndex As Integer
[C#]
new public int ImageIndex {get;}

See Also

XPCheckBox Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


XPCheckBox.ImageList Property

Hides the inherited property.

[Visual Basic]
Public ReadOnly Property ImageList As ImageList
[C#]
new public System.Windows.Forms.ImageList ImageList {get;}

See Also

XPCheckBox Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


XPCheckBox.TextAlign Property

Hides the inherited property.

[Visual Basic]
Public ReadOnly Property TextAlign As ContentAlignment
[C#]
new public System.Drawing.ContentAlignment TextAlign {get;}

See Also

XPCheckBox Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


XPCheckBox.TextColor Property

The color of the checkbox text.

[Visual Basic]
Public ReadOnly Property TextColor As Color
[C#]
public System.Drawing.Color TextColor {get;}

See Also

XPCheckBox Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


XPCheckBox.UseTheme Property

Determines whether or not the application is using XP themes.

[Visual Basic]
Public ReadOnly Property UseTheme As Boolean
[C#]
public bool UseTheme {get;}

See Also

XPCheckBox Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


XPGroupBox Class

The XPGroupBox control draws itself using XP visual styles. It is meant to be used with the SkinnedPanel control where the regular .NET GroupBox control would not draw itself properly.

For a list of all members of this type, see XPGroupBox Members.

System.Object
MarshalByRefObject
Component
Control
GroupBox
XPGroupBox

[Visual Basic]
Public Class XPGroupBox
Inherits GroupBox
[C#]
public class XPGroupBox : GroupBox

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls

Assembly: NETXP.Controls (in NETXP.Controls.dll)

See Also

XPGroupBox Members | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


XPGroupBox Members

XPGroupBox overview

Public Instance Constructors

XPGroupBox Constructor Constructs a new XPGroupBox.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from GroupBox) |
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor | Hides an inherited property.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from GroupBox) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
FlatStyle | Hides an inherited property.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from GroupBox) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from GroupBox) |
TextColor | The text color used for the header.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseTheme | Determines whether or not the application is using XP themes.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from GroupBox) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from GroupBox) |
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from GroupBox) |
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from GroupBox) |
KeyPress (inherited from GroupBox) |
KeyUp (inherited from GroupBox) |
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from GroupBox) |
MouseEnter (inherited from GroupBox) |
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from GroupBox) |
MouseMove (inherited from GroupBox) |
MouseUp (inherited from GroupBox) |
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from GroupBox) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

XPGroupBox Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


XPGroupBox Constructor

Constructs a new XPGroupBox.

[Visual Basic]
Public Sub New()
[C#]
public XPGroupBox();

See Also

XPGroupBox Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


XPGroupBox Properties

The properties of the XPGroupBox class are listed below. For a complete list of XPGroupBox class members, see the XPGroupBox Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from GroupBox) |
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor | Hides an inherited property.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from GroupBox) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
FlatStyle | Hides an inherited property.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from GroupBox) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from GroupBox) |
TextColor | The text color used for the header.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseTheme | Determines whether or not the application is using XP themes.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

See Also

XPGroupBox Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


XPGroupBox.BackColor Property

Hides an inherited property.

[Visual Basic]
Public Property BackColor As Color
[C#]
new public System.Drawing.Color BackColor {get; set;}

See Also

XPGroupBox Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


XPGroupBox.FlatStyle Property

Hides an inherited property.

[Visual Basic]
Public Property FlatStyle As FlatStyle
[C#]
new public System.Windows.Forms.FlatStyle FlatStyle {get; set;}

See Also

XPGroupBox Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


XPGroupBox.TextColor Property

The text color used for the header.

[Visual Basic]
Public ReadOnly Property TextColor As Color
[C#]
public System.Drawing.Color TextColor {get;}

See Also

XPGroupBox Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


XPGroupBox.UseTheme Property

Determines whether or not the application is using XP themes.

[Visual Basic]
Public ReadOnly Property UseTheme As Boolean
[C#]
public bool UseTheme {get;}

See Also

XPGroupBox Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


XPictureBox Class

XPictureBox is an extended PictureBox control for faster display of pictures.

For a list of all members of this type, see XPictureBox Members.

System.Object
MarshalByRefObject
Component
Control
XPictureBox

[Visual Basic]
NotInheritable Public Class XPictureBox
Inherits Control
[C#]
public sealed class XPictureBox : Control

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls

Assembly: NETXP.Controls (in NETXP.Controls.dll)

See Also

XPictureBox Members | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


XPictureBox Members

XPictureBox overview

Public Instance Constructors

XPictureBox Constructor Creates a new XPictureBox.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoStretch | Stretch the image automatically based on DPI?
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
Image | The image to be displayed.
ImageIndex | Image index to use instead of Image.
ImageList | Image list for Image.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

XPictureBox Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


XPictureBox Constructor

Creates a new XPictureBox.

[Visual Basic]
Public Sub New()
[C#]
public XPictureBox();

See Also

XPictureBox Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


XPictureBox Properties

The properties of the XPictureBox class are listed below. For a complete list of XPictureBox class members, see the XPictureBox Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoStretch | Stretch the image automatically based on DPI?
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
Image | The image to be displayed.
ImageIndex | Image index to use instead of Image.
ImageList | Image list for Image.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

See Also

XPictureBox Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


XPictureBox.AutoStretch Property

Stretch the image automatically based on DPI?

[Visual Basic]
Public Property AutoStretch As Boolean
[C#]
public bool AutoStretch {get; set;}

See Also

XPictureBox Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


XPictureBox.Image Property

The image to be displayed.

[Visual Basic]
Public Property Image As Bitmap
[C#]
public System.Drawing.Bitmap Image {get; set;}

See Also

XPictureBox Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


XPictureBox.ImageIndex Property

Image index to use instead of Image.

[Visual Basic]
Public Property ImageIndex As Integer
[C#]
public int ImageIndex {get; set;}

See Also

XPictureBox Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


XPictureBox.ImageList Property

Image list for Image.

[Visual Basic]
Public Property ImageList As ImageList
[C#]
public System.Windows.Forms.ImageList ImageList {get; set;}

See Also

XPictureBox Class | NETXP.Controls Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls [3.0.5600.2205]


NETXP.Controls.Bars

NetXP 3.0 Reference

NETXP.Controls.Bars Namespace

Classes

Class | Description
BarSerializeInfo | Internal serialization class.
BeforeGroupChangedEventArgs | Provides event arguments for the BeforeSelectedGroupChanged event raised by the control. This object contains the group that would be selected and provides the opportunity to cancel the group selection.
BeforeItemClickedEventArgs | This class is used with the BeforeItemClicked event and provides the item which is about to be clicked and the option to prevent the item being clicked by setting the Cancel property.
CommandBar | The command bar control. You can add this to a form or a container control.
CommandBarButtonItem | The command bar button item.
CommandBarComboBox | A special combo box.
CommandBarComboItem | Combo box item.
CommandBarControlItem | A command bar item that contains a control.
CommandBarDock | A command bar container control which manages multiple command bars. This should not be added at design time.
CommandBarExpansionItem | Internal
CommandBarItem | This class describes one item on the command bar.
CommandBarItemChangedEventArgs | Defines event arguments for the ItemChanged event.
CommandBarItemCollection | A collection of CommandBarItem objects.
CommandBarLabelItem | A label item.
CommandBarManager | This component manages the command bars on your form. This includes saving and loading layouts, providing tear-off functionality, and allowing the bars to dock to any side of the form.
CommandBarSeparatorItem | A separator item.
CommandContextMenu | A context menu with fully customizable look and feel.
ExpandedEventArgs | Event arguments for the Expanded event.
FloatingForm | Internal
GroupClickedEventArgs | This class is provides details of which item has been clicked and the mouse details of the click when the GroupClicked event is raised from a ListBar control.
ItemClickedEventArgs | This class is provides details of which item has been clicked and the mouse details of the click when the ItemClicked event is raised from a ListBar.
ListBar | The ListBar control is an implementation of the Microsoft outlook bar control. This control provides both the functionality of a standard outlook bar control as well as the functionality of the VS.NET toolbox control. The ListBar control supports drag and drop, as well as custom rendering. The bars are configured using ListBarGroup objects which are collected in the ListBarGroupCollection object accessible through the control's Groups property. Each ListBarGroup in turn contains a ListBarItemCollection of ListBarItem objects which represent the buttons within each group.
ListBarGroup | A ListBarGroup is a bar within a ListBar control.
ListBarGroupCollection | A class to hold the collection of groups in the ListBar control.
ListBarInsertPoint | An internal class to manage the drag-drop insert point within the control.
ListBarItem | A class containing the information describing an Item in the ListBar control.
ListBarItemCollection | This class manages a collection of items within a ListBarGroup.
ListBarLabelEditEventArgs | Provides details about an item which will undergo an edit operation.
ListBarScrollButton | A class which manages the behaviour and data associated with a scrolling button in the ListBar control.
Margins | Provides a way to set up margins or padding.
ObjectClickedEventArgs | An abstract class used as the bases for the ItemClicked and GroupClicked events of the ListBar control. This class stores details of the mouse location and button.
ProgressPanel | Provides a progress bar panel for the NetXP status bar.
SetupChevronMenuEventArgs | Event arguments for the SetupChevronMenu event.
StatusBar | The extended status bar control supporting custom renderers and progress bars.
TornOffEventArgs | Event arguments for the TornOff event.

Interfaces

Interface | Description
ICommandBarRenderer | Defines a renderer for command bars. This allows full control over how the command bar is drawn.
IListBarRenderer | Defines a renderer for list bars. This allows full control over how list bars are drawn.
IMouseHandler | An internal interface specifying the properties and methods which must be supported by an object in the control which handles mouse events.
IStatusBarRenderer | Defines a status bar renderer. This allows full control over how status bars are drawn.

Delegates

Delegate | Description
BeforeGroupChangedEventHandler | Represents the method that handles the BeforeSelectedGroupChanged event of a ListBar control.
BeforeItemClickedEventHandler | Represents the method that handles the BeforeItemClicked event of a ListBar control.
CommandBarItemChangedEventHandler | Handles the Item.Changed event.
ExpandedEventHandler | Defines the signature for the expanded event.
GroupClickedEventHandler | Represents the method that handles the GroupClicked event of a ListBar control.
ItemClickedEventHandler | Represents the method that handles the ItemClicked event of a ListBar control.
ListBarLabelEditEventHandler | Represents the method that handles the BeforeLabelEdit and AfterLabelEdit events of a ListBar control.
SetupChevronMenuEventHandler | Event handler for the SetupChevronMenu event.
TornOffEventHandler | Event handler for the TornOff event.

Enumerations

Enumeration | Description
ButtonItemCheckType | The command bar button item checkmark style.
ButtonItemStyle | The command bar button item behavior style.
CommandBarState | Command bar states.
CommandBarStyle | Command bar display style.
DockLocation | Internal serialization class.
DrawStyle | Defines how to draw the combo box.
ListBarGroupView | Specifies the view to use for the items within a ListBarGroup.
ListBarScrollButton.ListBarScrollButtonType | Enumeration of available scroll button types for this control.


BarSerializeInfo Class

Internal serialization class.

For a list of all members of this type, see BarSerializeInfo Members.

System.Object
BarSerializeInfo

[Visual Basic]
Public Class BarSerializeInfo
[C#]
public class BarSerializeInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Bars

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

BarSerializeInfo Members | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


BarSerializeInfo Members

BarSerializeInfo overview

Public Instance Constructors

BarSerializeInfo Constructor Internal

Public Instance Fields

Dock | Internal
FloatingLocation | Internal
ID | Internal
IsFloating | Internal
RowNumber | Internal
RowPosition | Internal
ShowGripper | Internal
Visible | Internal

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

BarSerializeInfo Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


BarSerializeInfo Constructor

Internal

[Visual Basic]
Public Sub New()
[C#]
public BarSerializeInfo();

See Also

BarSerializeInfo Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


BarSerializeInfo Fields

The fields of the BarSerializeInfo class are listed below. For a complete list of BarSerializeInfo class members, see the BarSerializeInfo Members topic.

Public Instance Fields

Dock | Internal
FloatingLocation | Internal
ID | Internal
IsFloating | Internal
RowNumber | Internal
RowPosition | Internal
ShowGripper | Internal
Visible | Internal

See Also

BarSerializeInfo Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


BarSerializeInfo.Dock Field

Internal

[Visual Basic]
Public Dock As DockLocation
[C#]
public DockLocation Dock;

See Also

BarSerializeInfo Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


BarSerializeInfo.FloatingLocation Field

Internal

[Visual Basic]
Public FloatingLocation As Point
[C#]
public Point FloatingLocation;

See Also

BarSerializeInfo Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


BarSerializeInfo.ID Field

Internal

[Visual Basic]
Public ID As Integer
[C#]
public int ID;

See Also

BarSerializeInfo Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


BarSerializeInfo.IsFloating Field

Internal

[Visual Basic]
Public IsFloating As Boolean
[C#]
public bool IsFloating;

See Also

BarSerializeInfo Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


BarSerializeInfo.RowNumber Field

Internal

[Visual Basic]
Public RowNumber As Integer
[C#]
public int RowNumber;

See Also

BarSerializeInfo Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


BarSerializeInfo.RowPosition Field

Internal

[Visual Basic]
Public RowPosition As Integer
[C#]
public int RowPosition;

See Also

BarSerializeInfo Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


BarSerializeInfo.ShowGripper Field

Internal

[Visual Basic]
Public ShowGripper As Boolean
[C#]
public bool ShowGripper;

See Also

BarSerializeInfo Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


BarSerializeInfo.Visible Field

Internal

[Visual Basic]
Public Visible As Boolean
[C#]
public bool Visible;

See Also

BarSerializeInfo Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


BeforeGroupChangedEventArgs Class

Provides event arguments for the BeforeSelectedGroupChanged event raised by the control. This object contains the group that would be selected and provides the opportunity to cancel the group selection.

For a list of all members of this type, see BeforeGroupChangedEventArgs Members.

System.Object
EventArgs
BeforeGroupChangedEventArgs

[Visual Basic]
Public Class BeforeGroupChangedEventArgs
Inherits EventArgs
[C#]
public class BeforeGroupChangedEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Bars

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

BeforeGroupChangedEventArgs Members | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


BeforeGroupChangedEventArgs Members

BeforeGroupChangedEventArgs overview

Public Instance Constructors

BeforeGroupChangedEventArgs Constructor Constructs a new instance of this object. Called by the ListBar control before firing a BeforeSelectedGroupChanged event.

Public Instance Properties

Cancel | Gets/sets whether the group selection should be cancelled or not. By default the group selection is not cancelled.
Group | Gets the group that will be selected.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

BeforeGroupChangedEventArgs Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


BeforeGroupChangedEventArgs Constructor

Constructs a new instance of this object. Called by the ListBar control before firing a BeforeSelectedGroupChanged event.

[Visual Basic]
Public Sub New( _
ByVal group As ListBarGroup _
)
[C#]
public BeforeGroupChangedEventArgs(
ListBarGroup group
);

Parameters

group
The group that will be selected

See Also

BeforeGroupChangedEventArgs Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


BeforeGroupChangedEventArgs Properties

The properties of the BeforeGroupChangedEventArgs class are listed below. For a complete list of BeforeGroupChangedEventArgs class members, see the BeforeGroupChangedEventArgs Members topic.

Public Instance Properties

Cancel | Gets/sets whether the group selection should be cancelled or not. By default the group selection is not cancelled.
Group | Gets the group that will be selected.

See Also

BeforeGroupChangedEventArgs Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


BeforeGroupChangedEventArgs.Cancel Property

Gets/sets whether the group selection should be cancelled or not. By default the group selection is not cancelled.

[Visual Basic]
Public Property Cancel As Boolean
[C#]
public bool Cancel {get; set;}

See Also

BeforeGroupChangedEventArgs Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


BeforeGroupChangedEventArgs.Group Property

Gets the group that will be selected.

[Visual Basic]
Public ReadOnly Property Group As ListBarGroup
[C#]
public ListBarGroup Group {get;}

See Also

BeforeGroupChangedEventArgs Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


BeforeGroupChangedEventHandler Delegate

Represents the method that handles the BeforeSelectedGroupChanged event of a ListBar control.

[Visual Basic]
Public Delegate Sub BeforeGroupChangedEventHandler( _
ByVal sender As Object, _
ByVal e As BeforeGroupChangedEventArgs _
)
[C#]
public delegate void BeforeGroupChangedEventHandler(
object sender,
BeforeGroupChangedEventArgs e
);

Requirements

Namespace: NETXP.Controls.Bars

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


BeforeItemClickedEventArgs Class

This class is used with the BeforeItemClicked event and provides the item which is about to be clicked and the option to prevent the item being clicked by setting the Cancel property.

For a list of all members of this type, see BeforeItemClickedEventArgs Members.

System.Object
EventArgs
BeforeItemClickedEventArgs

[Visual Basic]
Public Class BeforeItemClickedEventArgs
Inherits EventArgs
[C#]
public class BeforeItemClickedEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Bars

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

BeforeItemClickedEventArgs Members | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


BeforeItemClickedEventArgs Members

BeforeItemClickedEventArgs overview

Public Instance Constructors

BeforeItemClickedEventArgs Constructor Constructor for this object. Called by the ListBar control before firing a BeforeItemClickedEventHandler event.

Public Instance Properties

Cancel | Gets/sets whether the click should be cancelled or not.
Item | Gets the ListBarItem that is about to be clicked.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

BeforeItemClickedEventArgs Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


BeforeItemClickedEventArgs Constructor

Constructor for this object. Called by the ListBar control before firing a BeforeItemClickedEventHandler event.

[Visual Basic]
Public Sub New( _
ByVal item As ListBarItem _
)
[C#]
public BeforeItemClickedEventArgs(
ListBarItem item
);

Parameters

item
The item that's about to be clicked.

See Also

BeforeItemClickedEventArgs Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


BeforeItemClickedEventArgs Properties

The properties of the BeforeItemClickedEventArgs class are listed below. For a complete list of BeforeItemClickedEventArgs class members, see the BeforeItemClickedEventArgs Members topic.

Public Instance Properties

Cancel | Gets/sets whether the click should be cancelled or not.
Item | Gets the ListBarItem that is about to be clicked.

See Also

BeforeItemClickedEventArgs Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


BeforeItemClickedEventArgs.Cancel Property

Gets/sets whether the click should be cancelled or not.

[Visual Basic]
Public Property Cancel As Boolean
[C#]
public bool Cancel {get; set;}

See Also

BeforeItemClickedEventArgs Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


BeforeItemClickedEventArgs.Item Property

Gets the ListBarItem that is about to be clicked.

[Visual Basic]
Public ReadOnly Property Item As ListBarItem
[C#]
public ListBarItem Item {get;}

See Also

BeforeItemClickedEventArgs Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


BeforeItemClickedEventHandler Delegate

Represents the method that handles the BeforeItemClicked event of a ListBar control.

[Visual Basic]
Public Delegate Sub BeforeItemClickedEventHandler( _
ByVal sender As Object, _
ByVal e As BeforeItemClickedEventArgs _
)
[C#]
public delegate void BeforeItemClickedEventHandler(
object sender,
BeforeItemClickedEventArgs e
);

Requirements

Namespace: NETXP.Controls.Bars

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ButtonItemCheckType Enumeration

The command bar button item checkmark style.

[Visual Basic]
Public Enum ButtonItemCheckType
[C#]
public enum ButtonItemCheckType

Members

Member Name | Description
Checkmark | Item uses checkmark.
Radio | Item uses radio dot.

Requirements

Namespace: NETXP.Controls.Bars

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ButtonItemStyle Enumeration

The command bar button item behavior style.

[Visual Basic]
Public Enum ButtonItemStyle
[C#]
public enum ButtonItemStyle

Members

Member Name | Description
Command | Item behaves like a command button.
DropDown | Item has a dropdown menu.

Requirements

Namespace: NETXP.Controls.Bars

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBar Class

The command bar control. You can add this to a form or a container control.

For a list of all members of this type, see CommandBar Members.

System.Object
MarshalByRefObject
Component
Control
CommandBar

[Visual Basic]
NotInheritable Public Class CommandBar
Inherits Control
Implements System.ComponentModel.ISupportInitialize, System.Windows.Forms.IMessageFilter
[C#]
public sealed class CommandBar : Control, ISupportInitialize, IMessageFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Bars

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

CommandBar Members | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBar Members

CommandBar overview

Public Instance Constructors

CommandBar Constructor Creates a command bar.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowClose | Gets or sets if the bar's floating window can be closed by the user.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTearOff | Gets or sets if the bar can be torn off by the user.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoFocus | Gets or sets if the bar can be automatically focused if the user clicks on it.
BackColor | Gets or sets the background color of this command bar.
BackgroundImage | Gets or sets the background image for this command bar.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClickedArrow | Gets or sets if the user clicked a drop down arrow.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
CustomBackground | If true, the command bar will not draw its default background. Only available for bars outside of dock containers.
CustomizeText | Gets or setst the text of the Customize command.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Dropped | Gets or sets if the command bar's state is Dropped.
EnableCustomize | Is the Customize option enabled?
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
FloatingForm | Gets or sets this bar's floating form.
FloatingLocation | Gets the location of the floating form.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FullRow | Gets or sets if this bar takes up the whole row.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ID | Gets or sets a unique ID for this command bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsFloating | Gets if this bar is floating.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Items | The collection of toolbar items on the toolbar or menu.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margins | Gets the margins (padding) between the command bar's edges and its items.
MdiContainer | Gets or sets the MDI container associated with this menu bar.
MenuEnabled | If false, the menu will become grayed out (i.e. when the window is deactivated)
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentDock | Gets or sets the command bar's parent dock when floating.
Position | Gets or sets the position of this bar within a row.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Pushed | Gets or sets if the command bar's state is Pushed.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Renderer | Gets or sets the command bar's renderer.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightAlignChevronMenu | Gets or sets if the chevron menu is right-aligned.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RowNumber | Gets or sets the row number where this command bar is placed.
ShowCues | Gets if the command bar should show keyboard underlines.
ShowGripper | If true, a gripper will be shown, allowing the user to move the command bar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
State | Gets this command bar's hot tracking state.
Style | The style (can be Menu or Toolbar)
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text | Gets or sets the text of the command bar shown in the title bar of the floating form.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Vertical | Gets if this bar is vertical.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInit | Begins initialization. Suspends all redraw operations.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInit | Ends initialization. Redraws the control.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Float | Undocks the command bar from the parent.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetHotItem | Gets the current hot item.
GetItemRect | Gets the bounds of an item.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetNumRects | Gets the number of item rectangles.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
HideBar | Hides this command bar. Use this method instead of just setting the Visible property.
HitTest | Performs a hit test for an item.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreFilterMessage | Internal
PreProcessMessage | Processes messages received from Windows.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetHotItem | Assigns a new hot item.
Show (inherited from Control) | Displays the control to the user.
ShowBar | Shows this command bar. Use this method instead of just setting the Visible property.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
UpdateItems | Redraws items and resizes the control.
UpdateSize | Updates the size of the command bar control. This causes the control to have the most compact size possible, depending on the items it is displaying.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Customize | Raised when the Cutomize Toolbar menu item has been clicked.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SetupChevronMenu | Handle this event if you wish to customize the expansion item menu.
ShowGripperChanged | Raised when the command bar has been locked or unlocked.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
SnappedOn | Raised when the command bar has been snapped back on (redocked).
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
TornOff | Raised when the command bar has been torn off (undocked).
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

CommandBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBar Constructor

Creates a command bar.

[Visual Basic]
Public Sub New()
[C#]
public CommandBar();

See Also

CommandBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBar Properties

The properties of the CommandBar class are listed below. For a complete list of CommandBar class members, see the CommandBar Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowClose | Gets or sets if the bar's floating window can be closed by the user.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTearOff | Gets or sets if the bar can be torn off by the user.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoFocus | Gets or sets if the bar can be automatically focused if the user clicks on it.
BackColor | Gets or sets the background color of this command bar.
BackgroundImage | Gets or sets the background image for this command bar.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClickedArrow | Gets or sets if the user clicked a drop down arrow.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
CustomBackground | If true, the command bar will not draw its default background. Only available for bars outside of dock containers.
CustomizeText | Gets or setst the text of the Customize command.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Dropped | Gets or sets if the command bar's state is Dropped.
EnableCustomize | Is the Customize option enabled?
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
FloatingForm | Gets or sets this bar's floating form.
FloatingLocation | Gets the location of the floating form.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FullRow | Gets or sets if this bar takes up the whole row.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ID | Gets or sets a unique ID for this command bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsFloating | Gets if this bar is floating.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Items | The collection of toolbar items on the toolbar or menu.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margins | Gets the margins (padding) between the command bar's edges and its items.
MdiContainer | Gets or sets the MDI container associated with this menu bar.
MenuEnabled | If false, the menu will become grayed out (i.e. when the window is deactivated)
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentDock | Gets or sets the command bar's parent dock when floating.
Position | Gets or sets the position of this bar within a row.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Pushed | Gets or sets if the command bar's state is Pushed.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Renderer | Gets or sets the command bar's renderer.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightAlignChevronMenu | Gets or sets if the chevron menu is right-aligned.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RowNumber | Gets or sets the row number where this command bar is placed.
ShowCues | Gets if the command bar should show keyboard underlines.
ShowGripper | If true, a gripper will be shown, allowing the user to move the command bar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
State | Gets this command bar's hot tracking state.
Style | The style (can be Menu or Toolbar)
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text | Gets or sets the text of the command bar shown in the title bar of the floating form.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Vertical | Gets if this bar is vertical.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

See Also

CommandBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBar.AllowClose Property

Gets or sets if the bar's floating window can be closed by the user.

[Visual Basic]
Public Property AllowClose As Boolean
[C#]
public bool AllowClose {get; set;}

See Also

CommandBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBar.AllowTearOff Property

Gets or sets if the bar can be torn off by the user.

[Visual Basic]
Public Property AllowTearOff As Boolean
[C#]
public bool AllowTearOff {get; set;}

See Also

CommandBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBar.AutoFocus Property

Gets or sets if the bar can be automatically focused if the user clicks on it.

[Visual Basic]
Public Property AutoFocus As Boolean
[C#]
public bool AutoFocus {get; set;}

See Also

CommandBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBar.BackColor Property

Gets or sets the background color of this command bar.

[Visual Basic]
Overrides Public Property BackColor As Color
[C#]
public override System.Drawing.Color BackColor {get; set;}

See Also

CommandBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBar.BackgroundImage Property

Gets or sets the background image for this command bar.

[Visual Basic]
Overrides Public Property BackgroundImage As Image
[C#]
public override System.Drawing.Image BackgroundImage {get; set;}

See Also

CommandBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBar.ClickedArrow Property

Gets or sets if the user clicked a drop down arrow.

[Visual Basic]
Public Property ClickedArrow As Boolean
[C#]
public bool ClickedArrow {get; set;}

See Also

CommandBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBar.CustomBackground Property

If true, the command bar will not draw its default background. Only available for bars outside of dock containers.

[Visual Basic]
Public Property CustomBackground As Boolean
[C#]
public bool CustomBackground {get; set;}

See Also

CommandBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBar.CustomizeText Property

Gets or setst the text of the Customize command.

[Visual Basic]
Public Property CustomizeText As String
[C#]
public string CustomizeText {get; set;}

See Also

CommandBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBar.Dropped Property

Gets or sets if the command bar's state is Dropped.

[Visual Basic]
Public Property Dropped As Boolean
[C#]
public bool Dropped {get; set;}

See Also

CommandBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBar.EnableCustomize Property

Is the Customize option enabled?

[Visual Basic]
Public Property EnableCustomize As Boolean
[C#]
public bool EnableCustomize {get; set;}

See Also

CommandBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBar.FloatingForm Property

Gets or sets this bar's floating form.

[Visual Basic]
Public Property FloatingForm As FloatingForm
[C#]
public FloatingForm FloatingForm {get; set;}

See Also

CommandBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBar.FloatingLocation Property

Gets the location of the floating form.

[Visual Basic]
Public ReadOnly Property FloatingLocation As Point
[C#]
public System.Drawing.Point FloatingLocation {get;}

See Also

CommandBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBar.FullRow Property

Gets or sets if this bar takes up the whole row.

[Visual Basic]
Public Property FullRow As Boolean
[C#]
public bool FullRow {get; set;}

See Also

CommandBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBar.ID Property

Gets or sets a unique ID for this command bar.

[Visual Basic]
Public Property ID As Integer
[C#]
public int ID {get; set;}

See Also

CommandBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBar.IsFloating Property

Gets if this bar is floating.

[Visual Basic]
Public ReadOnly Property IsFloating As Boolean
[C#]
public bool IsFloating {get;}

See Also

CommandBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBar.Items Property

The collection of toolbar items on the toolbar or menu.

[Visual Basic]
Public ReadOnly Property Items As CommandBarItemCollection
[C#]
public CommandBarItemCollection Items {get;}

See Also

CommandBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBar.Margins Property

Gets the margins (padding) between the command bar's edges and its items.

[Visual Basic]
Public ReadOnly Property Margins As Margins
[C#]
public Margins Margins {get;}

See Also

CommandBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBar.MdiContainer Property

Gets or sets the MDI container associated with this menu bar.

[Visual Basic]
Public Property MdiContainer As Form
[C#]
public System.Windows.Forms.Form MdiContainer {get; set;}

See Also

CommandBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBar.MenuEnabled Property

If false, the menu will become grayed out (i.e. when the window is deactivated)

[Visual Basic]
Public Property MenuEnabled As Boolean
[C#]
public bool MenuEnabled {get; set;}

See Also

CommandBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBar.ParentDock Property

Gets or sets the command bar's parent dock when floating.

[Visual Basic]
Public Property ParentDock As CommandBarDock
[C#]
public CommandBarDock ParentDock {get; set;}

See Also

CommandBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBar.Position Property

Gets or sets the position of this bar within a row.

[Visual Basic]
Public Property Position As Integer
[C#]
public int Position {get; set;}

See Also

CommandBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBar.Pushed Property

Gets or sets if the command bar's state is Pushed.

[Visual Basic]
Public Property Pushed As Boolean
[C#]
public bool Pushed {get; set;}

See Also

CommandBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBar.Renderer Property

Gets or sets the command bar's renderer.

[Visual Basic]
Public Property Renderer As ICommandBarRenderer
[C#]
public ICommandBarRenderer Renderer {get; set;}

See Also

CommandBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBar.RightAlignChevronMenu Property

Gets or sets if the chevron menu is right-aligned.

[Visual Basic]
Public Property RightAlignChevronMenu As Boolean
[C#]
public bool RightAlignChevronMenu {get; set;}

See Also

CommandBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBar.RowNumber Property

Gets or sets the row number where this command bar is placed.

[Visual Basic]
Public Property RowNumber As Integer
[C#]
public int RowNumber {get; set;}

See Also

CommandBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBar.ShowCues Property

Gets if the command bar should show keyboard underlines.

[Visual Basic]
Public ReadOnly Property ShowCues As Boolean
[C#]
public bool ShowCues {get;}

See Also

CommandBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBar.ShowGripper Property

If true, a gripper will be shown, allowing the user to move the command bar.

[Visual Basic]
Public Property ShowGripper As Boolean
[C#]
public bool ShowGripper {get; set;}

See Also

CommandBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBar.State Property

Gets this command bar's hot tracking state.

[Visual Basic]
Public ReadOnly Property State As CommandBarState
[C#]
public CommandBarState State {get;}

See Also

CommandBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBar.Style Property

The style (can be Menu or Toolbar)

[Visual Basic]
Public Property Style As CommandBarStyle
[C#]
public CommandBarStyle Style {get; set;}

See Also

CommandBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBar.Text Property

Gets or sets the text of the command bar shown in the title bar of the floating form.

[Visual Basic]
Public Property Text As String
[C#]
new public string Text {get; set;}

See Also

CommandBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBar.Vertical Property

Gets if this bar is vertical.

[Visual Basic]
Public ReadOnly Property Vertical As Boolean
[C#]
public bool Vertical {get;}

See Also

CommandBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBar Methods

The methods of the CommandBar class are listed below. For a complete list of CommandBar class members, see the CommandBar Members topic.

Public Instance Methods

BeginInit | Begins initialization. Suspends all redraw operations.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInit | Ends initialization. Redraws the control.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Float | Undocks the command bar from the parent.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetHotItem | Gets the current hot item.
GetItemRect | Gets the bounds of an item.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetNumRects | Gets the number of item rectangles.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
HideBar | Hides this command bar. Use this method instead of just setting the Visible property.
HitTest | Performs a hit test for an item.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreFilterMessage | Internal
PreProcessMessage | Processes messages received from Windows.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetHotItem | Assigns a new hot item.
Show (inherited from Control) | Displays the control to the user.
ShowBar | Shows this command bar. Use this method instead of just setting the Visible property.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
UpdateItems | Redraws items and resizes the control.
UpdateSize | Updates the size of the command bar control. This causes the control to have the most compact size possible, depending on the items it is displaying.

See Also

CommandBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBar.BeginInit Method

Begins initialization. Suspends all redraw operations.

[Visual Basic]
NotOverridable Public Sub BeginInit() Implements _
ISupportInitialize.BeginInit
[C#]
public void BeginInit();

Implements

ISupportInitialize.BeginInit

See Also

CommandBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBar.EndInit Method

Ends initialization. Redraws the control.

[Visual Basic]
NotOverridable Public Sub EndInit() Implements _
ISupportInitialize.EndInit
[C#]
public void EndInit();

Implements

ISupportInitialize.EndInit

See Also

CommandBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBar.Float Method

Undocks the command bar from the parent.

[Visual Basic]
Public Sub Float( _
ByVal pt As Point, _
ByVal parent As CommandBarDock _
)
[C#]
public void Float(
Point pt,
CommandBarDock parent
);

Parameters

pt
The point where the floating form will be shown.
parent
The parent of the command bar.

See Also

CommandBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBar.GetHotItem Method

Gets the current hot item.

[Visual Basic]
Public Function GetHotItem() As Integer
[C#]
public int GetHotItem();

Return Value

The hot item.

See Also

CommandBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBar.GetItemRect Method

Gets the bounds of an item.

[Visual Basic]
Public Function GetItemRect( _
ByVal item As CommandBarItem _
) As Rectangle
[C#]
public Rectangle GetItemRect(
CommandBarItem item
);

Parameters

item
The item.

Return Value

The item's bounds.

See Also

CommandBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBar.GetNumRects Method

Gets the number of item rectangles.

[Visual Basic]
Public Function GetNumRects() As Integer
[C#]
public int GetNumRects();

Return Value

The number of item rectangles.

See Also

CommandBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBar.HideBar Method

Hides this command bar. Use this method instead of just setting the Visible property.

[Visual Basic]
Public Sub HideBar()
[C#]
public void HideBar();

See Also

CommandBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBar.HitTest Method

Performs a hit test for an item.

[Visual Basic]
Public Function HitTest( _
ByVal point As Point, _
ByVal includeDisabled As Boolean _
) As Integer
[C#]
public int HitTest(
Point point,
bool includeDisabled
);

Parameters

point
Point where user clicked.
includeDisabled
Hit test disabled items as well?

Return Value

Item index at that location. -1 if no items were hit.

See Also

CommandBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBar.PreFilterMessage Method

Internal

[Visual Basic]
NotOverridable Public Function PreFilterMessage( _
ByRef m As Message _
) As Boolean Implements _
IMessageFilter.PreFilterMessage
[C#]
public bool PreFilterMessage(
ref Message m
);

Parameters

m

Return Value

Implements

IMessageFilter.PreFilterMessage

See Also

CommandBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBar.PreProcessMessage Method

Processes messages received from Windows.

[Visual Basic]
Overrides Public Function PreProcessMessage( _
ByRef message As Message _
) As Boolean
[C#]
public override bool PreProcessMessage(
ref Message message
);

Parameters

message
The message.

Return Value

Internal. Do not use.

See Also

CommandBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBar.SetHotItem Method

Assigns a new hot item.

[Visual Basic]
Public Sub SetHotItem( _
ByVal item As CommandBarItem _
)
[C#]
public void SetHotItem(
CommandBarItem item
);

Parameters

item
The new hot item.

See Also

CommandBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBar.ShowBar Method

Shows this command bar. Use this method instead of just setting the Visible property.

[Visual Basic]
Public Sub ShowBar()
[C#]
public void ShowBar();

See Also

CommandBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBar.UpdateItems Method

Redraws items and resizes the control.

[Visual Basic]
Public Sub UpdateItems()
[C#]
public void UpdateItems();

See Also

CommandBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBar.UpdateSize Method

Updates the size of the command bar control. This causes the control to have the most compact size possible, depending on the items it is displaying.

[Visual Basic]
Public Sub UpdateSize()
[C#]
public void UpdateSize();

See Also

CommandBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBar Events

The events of the CommandBar class are listed below. For a complete list of CommandBar class members, see the CommandBar Members topic.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Customize | Raised when the Cutomize Toolbar menu item has been clicked.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SetupChevronMenu | Handle this event if you wish to customize the expansion item menu.
ShowGripperChanged | Raised when the command bar has been locked or unlocked.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
SnappedOn | Raised when the command bar has been snapped back on (redocked).
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
TornOff | Raised when the command bar has been torn off (undocked).
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

CommandBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBar.Customize Event

Raised when the Cutomize Toolbar menu item has been clicked.

[Visual Basic]
Public Event Customize As EventHandler
[C#]
public event EventHandler Customize;

See Also

CommandBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBar.SetupChevronMenu Event

Handle this event if you wish to customize the expansion item menu.

[Visual Basic]
Public Event SetupChevronMenu As SetupChevronMenuEventHandler
[C#]
public event SetupChevronMenuEventHandler SetupChevronMenu;

Event Data

The event handler receives an argument of type SetupChevronMenuEventArgs containing data related to this event. The following SetupChevronMenuEventArgs property provides information specific to this event.

Property | Description
Items | The items shown in the chevron menu.

See Also

CommandBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBar.ShowGripperChanged Event

Raised when the command bar has been locked or unlocked.

[Visual Basic]
Public Event ShowGripperChanged As EventHandler
[C#]
public event EventHandler ShowGripperChanged;

See Also

CommandBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBar.SnappedOn Event

Raised when the command bar has been snapped back on (redocked).

[Visual Basic]
Public Event SnappedOn As EventHandler
[C#]
public event EventHandler SnappedOn;

See Also

CommandBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBar.TornOff Event

Raised when the command bar has been torn off (undocked).

[Visual Basic]
Public Event TornOff As TornOffEventHandler
[C#]
public event TornOffEventHandler TornOff;

Event Data

The event handler receives an argument of type TornOffEventArgs containing data related to this event. The following TornOffEventArgs property provides information specific to this event.

Property | Description
DockForm | The floating form.

See Also

CommandBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarButtonItem Class

The command bar button item.

For a list of all members of this type, see CommandBarButtonItem Members.

System.Object
MarshalByRefObject
Component
CommandBarItem
CommandBarButtonItem

[Visual Basic]
Public Class CommandBarButtonItem
Inherits CommandBarItem
Implements NETXP.Library.IStatusMessageProvider
[C#]
public class CommandBarButtonItem : CommandBarItem, IStatusMessageProvider

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Bars

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

CommandBarButtonItem Members | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarButtonItem Members

CommandBarButtonItem overview

Public Instance Constructors

CommandBarButtonItem Overloaded. Initializes a new instance of the CommandBarButtonItem class.

Public Instance Properties

Checked | Is this item checked (depressed)?
CheckType | How the item displays checkmarks.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerControl (inherited from CommandBarItem) | The item's container control.
DefaultItem | Does this item show its text bold when shown on a menu?
DropUp | Gets or sets if this item is dropped up instead of down.
Enabled (inherited from CommandBarItem) | Is this item enabled?
HotImage | The item's hot image.
Image | The item's image.
Infrequent (inherited from CommandBarItem) | Is this item infrequent?
Items | A collection of CommandBarItem objects shown in the submenu of this item.
MenuSelectable (inherited from CommandBarItem) | Can this item be selected in a menu?
PadHorizontal (inherited from CommandBarItem) | The item's horizontal padding.
PadVertical (inherited from CommandBarItem) | The item's vertical padding.
Shortcut | The item's shortcut key (if a menu item).
ShowText | Does this item show its text?
Site (inherited from Component) | Gets or sets the ISite of the Component.
Style | The item's display style.
Tag (inherited from CommandBarItem) | An object associated with this item.
Text (inherited from CommandBarItem) | The item's text.
Visible (inherited from CommandBarItem) | Is this item visible?

Public Instance Methods

CalculateSize | See CommandBarItem
CalculateSizeMenu | See CommandBarItem
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
Draw | See CommandBarItem
DrawMenu | See CommandBarItem
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize | Resets the item to default properties.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
OnBoundsChanged | See CommandBarItem
OnContainerChanged | See CommandBarItem
ProcessMouseDown | See CommandBarItem
ProcessMouseMove | See CommandBarItem
ProcessMouseUp | See CommandBarItem
ResumeEvents (inherited from CommandBarItem) | Resumes events.
SuspendEvents (inherited from CommandBarItem) | Suspends events.
ToString (inherited from CommandBarItem) | Gives a string representation of this item.

Public Instance Events

Changed (inherited from CommandBarItem) | Called when the item's properties are changed.
Click (inherited from CommandBarItem) | Called when the item is clicked.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DropDown | Called when a dropdown menu is shown. Cancel the event in order to avoid showing the default popup menu.
Enter | See IStatusMessageProvider.
Hover (inherited from CommandBarItem) | Called when the mouse moves over the item.
Leave (inherited from CommandBarItem) | Called when the mouse has left the item.

See Also

CommandBarButtonItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarButtonItem Constructor

Constructs a new command bar button item with the given text and event handler.

Overload List

Constructs an empty command bar button item.

public CommandBarButtonItem();

Constructs a new command bar button item with the given text.

public CommandBarButtonItem(string);

Constructs a new command bar button item with the given text and event handler.

public CommandBarButtonItem(string,EventHandler);

See Also

CommandBarButtonItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarButtonItem Constructor (String, EventHandler)

Constructs a new command bar button item with the given text and event handler.

[Visual Basic]
Overloads Public Sub New( _
ByVal text As String, _
ByVal onClick As EventHandler _
)
[C#]
public CommandBarButtonItem(
string text,
EventHandler onClick
);

Parameters

text
The text of the item.
onClick
The Click event handler.

See Also

CommandBarButtonItem Class | NETXP.Controls.Bars Namespace | CommandBarButtonItem Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarButtonItem Constructor (String)

Constructs a new command bar button item with the given text.

[Visual Basic]
Overloads Public Sub New( _
ByVal text As String _
)
[C#]
public CommandBarButtonItem(
string text
);

Parameters

text
The text of the item.

See Also

CommandBarButtonItem Class | NETXP.Controls.Bars Namespace | CommandBarButtonItem Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarButtonItem Constructor ()

Constructs an empty command bar button item.

[Visual Basic]
Overloads Public Sub New()
[C#]
public CommandBarButtonItem();

See Also

CommandBarButtonItem Class | NETXP.Controls.Bars Namespace | CommandBarButtonItem Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarButtonItem Properties

The properties of the CommandBarButtonItem class are listed below. For a complete list of CommandBarButtonItem class members, see the CommandBarButtonItem Members topic.

Public Instance Properties

Checked | Is this item checked (depressed)?
CheckType | How the item displays checkmarks.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerControl (inherited from CommandBarItem) | The item's container control.
DefaultItem | Does this item show its text bold when shown on a menu?
DropUp | Gets or sets if this item is dropped up instead of down.
Enabled (inherited from CommandBarItem) | Is this item enabled?
HotImage | The item's hot image.
Image | The item's image.
Infrequent (inherited from CommandBarItem) | Is this item infrequent?
Items | A collection of CommandBarItem objects shown in the submenu of this item.
MenuSelectable (inherited from CommandBarItem) | Can this item be selected in a menu?
PadHorizontal (inherited from CommandBarItem) | The item's horizontal padding.
PadVertical (inherited from CommandBarItem) | The item's vertical padding.
Shortcut | The item's shortcut key (if a menu item).
ShowText | Does this item show its text?
Site (inherited from Component) | Gets or sets the ISite of the Component.
Style | The item's display style.
Tag (inherited from CommandBarItem) | An object associated with this item.
Text (inherited from CommandBarItem) | The item's text.
Visible (inherited from CommandBarItem) | Is this item visible?

See Also

CommandBarButtonItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarButtonItem.Checked Property

Is this item checked (depressed)?

[Visual Basic]
Overridable Public Property Checked As Boolean
[C#]
public virtual bool Checked {get; set;}

See Also

CommandBarButtonItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarButtonItem.CheckType Property

How the item displays checkmarks.

[Visual Basic]
Overridable Public Property CheckType As ButtonItemCheckType
[C#]
public virtual ButtonItemCheckType CheckType {get; set;}

See Also

CommandBarButtonItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarButtonItem.DefaultItem Property

Does this item show its text bold when shown on a menu?

[Visual Basic]
Overridable Public Property DefaultItem As Boolean
[C#]
public virtual bool DefaultItem {get; set;}

See Also

CommandBarButtonItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarButtonItem.DropUp Property

Gets or sets if this item is dropped up instead of down.

[Visual Basic]
Overridable Public Property DropUp As Boolean
[C#]
public virtual bool DropUp {get; set;}

See Also

CommandBarButtonItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarButtonItem.HotImage Property

The item's hot image.

[Visual Basic]
Overridable Public Property HotImage As Image
[C#]
public virtual System.Drawing.Image HotImage {get; set;}

See Also

CommandBarButtonItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarButtonItem.Image Property

The item's image.

[Visual Basic]
Overridable Public Property Image As Image
[C#]
public virtual System.Drawing.Image Image {get; set;}

See Also

CommandBarButtonItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarButtonItem.Items Property

A collection of CommandBarItem objects shown in the submenu of this item.

[Visual Basic]
Overridable Public ReadOnly Property Items As CommandBarItemCollection
[C#]
public virtual CommandBarItemCollection Items {get;}

See Also

CommandBarButtonItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarButtonItem.Shortcut Property

The item's shortcut key (if a menu item).

[Visual Basic]
Overridable Public Property Shortcut As Shortcut
[C#]
public virtual System.Windows.Forms.Shortcut Shortcut {get; set;}

See Also

CommandBarButtonItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarButtonItem.ShowText Property

Does this item show its text?

[Visual Basic]
Overridable Public Property ShowText As Boolean
[C#]
public virtual bool ShowText {get; set;}

See Also

CommandBarButtonItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarButtonItem.Style Property

The item's display style.

[Visual Basic]
Overridable Public Property Style As ButtonItemStyle
[C#]
public virtual ButtonItemStyle Style {get; set;}

See Also

CommandBarButtonItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarButtonItem Methods

The methods of the CommandBarButtonItem class are listed below. For a complete list of CommandBarButtonItem class members, see the CommandBarButtonItem Members topic.

Public Instance Methods

CalculateSize | See CommandBarItem
CalculateSizeMenu | See CommandBarItem
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
Draw | See CommandBarItem
DrawMenu | See CommandBarItem
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize | Resets the item to default properties.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
OnBoundsChanged | See CommandBarItem
OnContainerChanged | See CommandBarItem
ProcessMouseDown | See CommandBarItem
ProcessMouseMove | See CommandBarItem
ProcessMouseUp | See CommandBarItem
ResumeEvents (inherited from CommandBarItem) | Resumes events.
SuspendEvents (inherited from CommandBarItem) | Suspends events.
ToString (inherited from CommandBarItem) | Gives a string representation of this item.

See Also

CommandBarButtonItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarButtonItem.CalculateSize Method

See CommandBarItem

[Visual Basic]
Overrides Public Function CalculateSize( _
ByVal parent As CommandBar, _
ByVal g As Graphics _
) As Size
[C#]
public override Size CalculateSize(
CommandBar parent,
Graphics g
);

Parameters

parent
g

Return Value

See Also

CommandBarButtonItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarButtonItem.CalculateSizeMenu Method

See CommandBarItem

[Visual Basic]
Overrides Public Function CalculateSizeMenu( _
ByVal parent As CommandContextMenu, _
ByVal g As Graphics _
) As Size
[C#]
public override Size CalculateSizeMenu(
CommandContextMenu parent,
Graphics g
);

Parameters

parent
g

Return Value

See Also

CommandBarButtonItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarButtonItem.Draw Method

See CommandBarItem

[Visual Basic]
Overrides Public Sub Draw( _
ByVal parent As CommandBar, _
ByVal g As Graphics, _
ByVal state As DrawItemState, _
ByVal rect As Rectangle _
)
[C#]
public override void Draw(
CommandBar parent,
Graphics g,
DrawItemState state,
Rectangle rect
);

Parameters

parent
g
state
rect

See Also

CommandBarButtonItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarButtonItem.DrawMenu Method

See CommandBarItem

[Visual Basic]
Overrides Public Sub DrawMenu( _
ByVal parent As CommandContextMenu, _
ByVal g As Graphics, _
ByVal state As DrawItemState, _
ByVal rect As Rectangle _
)
[C#]
public override void DrawMenu(
CommandContextMenu parent,
Graphics g,
DrawItemState state,
Rectangle rect
);

Parameters

parent
g
state
rect

See Also

CommandBarButtonItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarButtonItem.Initialize Method

Resets the item to default properties.

[Visual Basic]
Overrides Public Sub Initialize()
[C#]
public override void Initialize();

See Also

CommandBarButtonItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarButtonItem.OnBoundsChanged Method

See CommandBarItem

[Visual Basic]
Overrides Public Sub OnBoundsChanged()
[C#]
public override void OnBoundsChanged();

See Also

CommandBarButtonItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarButtonItem.OnContainerChanged Method

See CommandBarItem

[Visual Basic]
Overrides Public Sub OnContainerChanged()
[C#]
public override void OnContainerChanged();

See Also

CommandBarButtonItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarButtonItem.ProcessMouseDown Method

See CommandBarItem

[Visual Basic]
Overrides Public Sub ProcessMouseDown( _
ByVal parent As CommandBar, _
ByVal e As MouseEventArgs _
)
[C#]
public override void ProcessMouseDown(
CommandBar parent,
MouseEventArgs e
);

Parameters

parent
e

See Also

CommandBarButtonItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarButtonItem.ProcessMouseMove Method

See CommandBarItem

[Visual Basic]
Overrides Public Sub ProcessMouseMove( _
ByVal parent As CommandBar, _
ByVal e As MouseEventArgs _
)
[C#]
public override void ProcessMouseMove(
CommandBar parent,
MouseEventArgs e
);

Parameters

parent
e

See Also

CommandBarButtonItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarButtonItem.ProcessMouseUp Method

See CommandBarItem

[Visual Basic]
Overrides Public Sub ProcessMouseUp( _
ByVal parent As CommandBar, _
ByVal e As MouseEventArgs _
)
[C#]
public override void ProcessMouseUp(
CommandBar parent,
MouseEventArgs e
);

Parameters

parent
e

See Also

CommandBarButtonItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarButtonItem Events

The events of the CommandBarButtonItem class are listed below. For a complete list of CommandBarButtonItem class members, see the CommandBarButtonItem Members topic.

Public Instance Events

Changed (inherited from CommandBarItem) | Called when the item's properties are changed.
Click (inherited from CommandBarItem) | Called when the item is clicked.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DropDown | Called when a dropdown menu is shown. Cancel the event in order to avoid showing the default popup menu.
Enter | See IStatusMessageProvider.
Hover (inherited from CommandBarItem) | Called when the mouse moves over the item.
Leave (inherited from CommandBarItem) | Called when the mouse has left the item.

See Also

CommandBarButtonItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarButtonItem.DropDown Event

Called when a dropdown menu is shown. Cancel the event in order to avoid showing the default popup menu.

[Visual Basic]
Public Event DropDown As CancelEventHandler
[C#]
public event CancelEventHandler DropDown;

See Also

CommandBarButtonItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarButtonItem.Enter Event

See IStatusMessageProvider.

[Visual Basic]
Public Event Enter As EventHandler
[C#]
public event EventHandler Enter;

Implements

IStatusMessageProvider.Enter

See Also

CommandBarButtonItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarComboBox Class

A special combo box.

For a list of all members of this type, see CommandBarComboBox Members.

System.Object
MarshalByRefObject
Component
Control
ListControl
ComboBox
CommandBarComboBox

[Visual Basic]
Public Class CommandBarComboBox
Inherits ComboBox
[C#]
public class CommandBarComboBox : ComboBox

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Bars

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

CommandBarComboBox Members | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarComboBox Members

CommandBarComboBox overview

Public Instance Constructors

CommandBarComboBox Constructor Constructs a new combo box item.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from ComboBox) |
BackgroundImage (inherited from ComboBox) |
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataSource (inherited from ListControl) | Gets or sets the data source for this ListControl .
DesignMode | Internal
DisplayMember (inherited from ListControl) | Gets or sets a string that specifies the property of the data source whose contents you want to display.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DrawMode (inherited from ComboBox) | Gets or sets a value indicating whether your code or the operating system will handle drawing of elements in the list.
DropDownStyle (inherited from ComboBox) | Gets or sets a value specifying the style of the combo box.
DropDownWidth (inherited from ComboBox) | Gets or sets the width of the of the drop-down portion of a combo box.
DroppedDown (inherited from ComboBox) | Gets or sets a value indicating whether the combo box is displaying its drop-down portion.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from ComboBox) |
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from ComboBox) |
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
IntegralHeight (inherited from ComboBox) | Gets or sets a value indicating whether the control should resize to avoid showing partial items.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
ItemHeight (inherited from ComboBox) | Gets or sets the height of an item in the combo box.
Items (inherited from ComboBox) | Gets an object representing the collection of the items contained in this ComboBox .
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaxDropDownItems (inherited from ComboBox) | Gets or sets the maximum number of items to be shown in the drop-down portion of the ComboBox .
MaxLength (inherited from ComboBox) | Gets or sets the maximum number of characters allowed in the editable portion of a combo box.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PreferredHeight (inherited from ComboBox) | Gets the preferred height of the ComboBox.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Renderer | Gets or sets the renderer for the combo box.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
SelectedIndex (inherited from ComboBox) | Gets or sets the index specifying the currently selected item.
SelectedItem (inherited from ComboBox) | Gets or sets currently selected item in the ComboBox .
SelectedText (inherited from ComboBox) | Gets or sets the text that is selected in the editable portion of a ComboBox .
SelectedValue (inherited from ListControl) | Gets or sets the value of the member property specified by the ValueMember property.
SelectionLength (inherited from ComboBox) | Gets or sets the number of characters selected in the editable portion of the combo box.
SelectionStart (inherited from ComboBox) | Gets or sets the starting index of text selected in the combo box.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
Sorted (inherited from ComboBox) | Gets or sets a value indicating whether the items in the combo box are sorted.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from ComboBox) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
ValueMember (inherited from ListControl) | Gets or sets a string that specifies the property of the data source from which to draw the value.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BeginUpdate (inherited from ComboBox) | Maintains performance when items are added to the ComboBox one at a time.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
EndUpdate (inherited from ComboBox) | Resumes painting the ComboBox control after painting is suspended by the BeginUpdate method.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
FindString (inherited from ComboBox) | Overloaded. Finds the first item in the combo box that starts with the specified string.
FindStringExact (inherited from ComboBox) | Overloaded. Finds the first item in the combo box that matches the specified string.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetItemHeight (inherited from ComboBox) | Returns the height of an item in the ComboBox.
GetItemText (inherited from ListControl) | Returns the text representation of the specified item.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from ComboBox) | Overloaded. Selects a range of text in the editable portion of the ComboBox.
Select (inherited from Control) | Overloaded. Activates the control.
SelectAll (inherited from ComboBox) | Selects all the text in the editable portion of the ComboBox .
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from ComboBox) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from ComboBox) |
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
DataSourceChanged (inherited from ListControl) | Occurs when the DataSource changes.
DisplayMemberChanged (inherited from ListControl) | Occurs when the DisplayMember property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
DrawItem (inherited from ComboBox) | Occurs when a visual aspect of an owner-drawn ComboBox changes.
DropDown (inherited from ComboBox) | Occurs when the drop-down portion of a ComboBox is shown.
DropDownStyleChanged (inherited from ComboBox) | Occurs when the DropDownStyle property has changed.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MeasureItem (inherited from ComboBox) | Occurs each time an owner-drawn ComboBox item needs to be drawn and when the sizes of the list items are determined.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from ComboBox) |
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SelectedIndexChanged (inherited from ComboBox) | Occurs when the SelectedIndex property has changed.
SelectedValueChanged (inherited from ListControl) | Occurs when the SelectedValue property changes.
SelectionChangeCommitted (inherited from ComboBox) | Occurs when the selected item has changed and that change is committed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueMemberChanged (inherited from ListControl) | Occurs when the ValueMember property changes.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

CommandBarComboBox Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarComboBox Constructor

Constructs a new combo box item.

[Visual Basic]
Public Sub New()
[C#]
public CommandBarComboBox();

See Also

CommandBarComboBox Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarComboBox Properties

The properties of the CommandBarComboBox class are listed below. For a complete list of CommandBarComboBox class members, see the CommandBarComboBox Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from ComboBox) |
BackgroundImage (inherited from ComboBox) |
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataSource (inherited from ListControl) | Gets or sets the data source for this ListControl .
DesignMode | Internal
DisplayMember (inherited from ListControl) | Gets or sets a string that specifies the property of the data source whose contents you want to display.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DrawMode (inherited from ComboBox) | Gets or sets a value indicating whether your code or the operating system will handle drawing of elements in the list.
DropDownStyle (inherited from ComboBox) | Gets or sets a value specifying the style of the combo box.
DropDownWidth (inherited from ComboBox) | Gets or sets the width of the of the drop-down portion of a combo box.
DroppedDown (inherited from ComboBox) | Gets or sets a value indicating whether the combo box is displaying its drop-down portion.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from ComboBox) |
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from ComboBox) |
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
IntegralHeight (inherited from ComboBox) | Gets or sets a value indicating whether the control should resize to avoid showing partial items.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
ItemHeight (inherited from ComboBox) | Gets or sets the height of an item in the combo box.
Items (inherited from ComboBox) | Gets an object representing the collection of the items contained in this ComboBox .
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaxDropDownItems (inherited from ComboBox) | Gets or sets the maximum number of items to be shown in the drop-down portion of the ComboBox .
MaxLength (inherited from ComboBox) | Gets or sets the maximum number of characters allowed in the editable portion of a combo box.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PreferredHeight (inherited from ComboBox) | Gets the preferred height of the ComboBox.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Renderer | Gets or sets the renderer for the combo box.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
SelectedIndex (inherited from ComboBox) | Gets or sets the index specifying the currently selected item.
SelectedItem (inherited from ComboBox) | Gets or sets currently selected item in the ComboBox .
SelectedText (inherited from ComboBox) | Gets or sets the text that is selected in the editable portion of a ComboBox .
SelectedValue (inherited from ListControl) | Gets or sets the value of the member property specified by the ValueMember property.
SelectionLength (inherited from ComboBox) | Gets or sets the number of characters selected in the editable portion of the combo box.
SelectionStart (inherited from ComboBox) | Gets or sets the starting index of text selected in the combo box.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
Sorted (inherited from ComboBox) | Gets or sets a value indicating whether the items in the combo box are sorted.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from ComboBox) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
ValueMember (inherited from ListControl) | Gets or sets a string that specifies the property of the data source from which to draw the value.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

See Also

CommandBarComboBox Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarComboBox.DesignMode Property

Internal

[Visual Basic]
Public Property DesignMode As Boolean
[C#]
new public bool DesignMode {get; set;}

See Also

CommandBarComboBox Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarComboBox.Renderer Property

Gets or sets the renderer for the combo box.

[Visual Basic]
Public Property Renderer As ICommandBarRenderer
[C#]
public ICommandBarRenderer Renderer {get; set;}

See Also

CommandBarComboBox Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarComboItem Class

Combo box item.

For a list of all members of this type, see CommandBarComboItem Members.

System.Object
MarshalByRefObject
Component
CommandBarItem
CommandBarComboItem

[Visual Basic]
Public Class CommandBarComboItem
Inherits CommandBarItem
[C#]
public class CommandBarComboItem : CommandBarItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Bars

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

CommandBarComboItem Members | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarComboItem Members

CommandBarComboItem overview

Public Instance Constructors

CommandBarComboItem Overloaded. Initializes a new instance of the CommandBarComboItem class.

Public Instance Properties

Combo | Gets the combo box within this item.
ComboText | Gets or sets the combo box text.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerControl (inherited from CommandBarItem) | The item's container control.
Enabled (inherited from CommandBarItem) | Is this item enabled?
Infrequent (inherited from CommandBarItem) | Is this item infrequent?
Items | Gets the items in the combo box.
MenuSelectable | See CommandBarItem
PadHorizontal (inherited from CommandBarItem) | The item's horizontal padding.
PadVertical (inherited from CommandBarItem) | The item's vertical padding.
Site | Internal
Style | Gets or sets the combo box style.
Tag (inherited from CommandBarItem) | An object associated with this item.
Text (inherited from CommandBarItem) | The item's text.
Visible (inherited from CommandBarItem) | Is this item visible?
Width | Gets or sets the combo box width.

Public Instance Methods

CalculateSize | See CommandBarItem
CalculateSizeMenu | See CommandBarItem
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
Draw | See CommandBarItem
DrawMenu | See CommandBarItem
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize | Resets the item to default properties.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
OnBoundsChanged | See CommandBarItem
OnContainerChanged | See CommandBarItem
ProcessMouseDown | See CommandBarItem
ProcessMouseMove | See CommandBarItem
ProcessMouseUp | See CommandBarItem
ResumeEvents (inherited from CommandBarItem) | Resumes events.
SuspendEvents (inherited from CommandBarItem) | Suspends events.
ToString (inherited from CommandBarItem) | Gives a string representation of this item.

Public Instance Events

Changed (inherited from CommandBarItem) | Called when the item's properties are changed.
Click (inherited from CommandBarItem) | Called when the item is clicked.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
Hover (inherited from CommandBarItem) | Called when the mouse moves over the item.
Leave (inherited from CommandBarItem) | Called when the mouse has left the item.

See Also

CommandBarComboItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarComboItem Constructor

Constructs a combo box item with specified text and Click event handler.

Overload List

Creates a combo box item with default options.

public CommandBarComboItem();

Constructs a combo box item with specified text.

public CommandBarComboItem(string);

Constructs a combo box item with specified text and Click event handler.

public CommandBarComboItem(string,EventHandler);

See Also

CommandBarComboItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarComboItem Constructor (String, EventHandler)

Constructs a combo box item with specified text and Click event handler.

[Visual Basic]
Overloads Public Sub New( _
ByVal text As String, _
ByVal onClick As EventHandler _
)
[C#]
public CommandBarComboItem(
string text,
EventHandler onClick
);

Parameters

text
Text to display.
onClick
Click event handler.

See Also

CommandBarComboItem Class | NETXP.Controls.Bars Namespace | CommandBarComboItem Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarComboItem Constructor (String)

Constructs a combo box item with specified text.

[Visual Basic]
Overloads Public Sub New( _
ByVal text As String _
)
[C#]
public CommandBarComboItem(
string text
);

Parameters

text
Text to display.

See Also

CommandBarComboItem Class | NETXP.Controls.Bars Namespace | CommandBarComboItem Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarComboItem Constructor ()

Creates a combo box item with default options.

[Visual Basic]
Overloads Public Sub New()
[C#]
public CommandBarComboItem();

See Also

CommandBarComboItem Class | NETXP.Controls.Bars Namespace | CommandBarComboItem Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarComboItem Properties

The properties of the CommandBarComboItem class are listed below. For a complete list of CommandBarComboItem class members, see the CommandBarComboItem Members topic.

Public Instance Properties

Combo | Gets the combo box within this item.
ComboText | Gets or sets the combo box text.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerControl (inherited from CommandBarItem) | The item's container control.
Enabled (inherited from CommandBarItem) | Is this item enabled?
Infrequent (inherited from CommandBarItem) | Is this item infrequent?
Items | Gets the items in the combo box.
MenuSelectable | See CommandBarItem
PadHorizontal (inherited from CommandBarItem) | The item's horizontal padding.
PadVertical (inherited from CommandBarItem) | The item's vertical padding.
Site | Internal
Style | Gets or sets the combo box style.
Tag (inherited from CommandBarItem) | An object associated with this item.
Text (inherited from CommandBarItem) | The item's text.
Visible (inherited from CommandBarItem) | Is this item visible?
Width | Gets or sets the combo box width.

See Also

CommandBarComboItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarComboItem.Combo Property

Gets the combo box within this item.

[Visual Basic]
Public ReadOnly Property Combo As ComboBox
[C#]
public System.Windows.Forms.ComboBox Combo {get;}

See Also

CommandBarComboItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarComboItem.ComboText Property

Gets or sets the combo box text.

[Visual Basic]
Public Property ComboText As String
[C#]
public string ComboText {get; set;}

See Also

CommandBarComboItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarComboItem.Items Property

Gets the items in the combo box.

[Visual Basic]
Public ReadOnly Property Items As ObjectCollection
[C#]
public System.Windows.Forms.ComboBox.ObjectCollection Items {get;}

See Also

CommandBarComboItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarComboItem.MenuSelectable Property

See CommandBarItem

[Visual Basic]
Overrides Public ReadOnly Property MenuSelectable As Boolean
[C#]
public override bool MenuSelectable {get;}

See Also

CommandBarComboItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarComboItem.Site Property

Internal

[Visual Basic]
Overrides Public Property Site As ISite Implements _
IComponent.Site
[C#]
public override System.ComponentModel.ISite Site {get; set;}

Implements

IComponent.Site

See Also

CommandBarComboItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarComboItem.Style Property

Gets or sets the combo box style.

[Visual Basic]
Public Property Style As ComboBoxStyle
[C#]
public System.Windows.Forms.ComboBoxStyle Style {get; set;}

See Also

CommandBarComboItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarComboItem.Width Property

Gets or sets the combo box width.

[Visual Basic]
Public Property Width As Integer
[C#]
public int Width {get; set;}

See Also

CommandBarComboItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarComboItem Methods

The methods of the CommandBarComboItem class are listed below. For a complete list of CommandBarComboItem class members, see the CommandBarComboItem Members topic.

Public Instance Methods

CalculateSize | See CommandBarItem
CalculateSizeMenu | See CommandBarItem
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
Draw | See CommandBarItem
DrawMenu | See CommandBarItem
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize | Resets the item to default properties.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
OnBoundsChanged | See CommandBarItem
OnContainerChanged | See CommandBarItem
ProcessMouseDown | See CommandBarItem
ProcessMouseMove | See CommandBarItem
ProcessMouseUp | See CommandBarItem
ResumeEvents (inherited from CommandBarItem) | Resumes events.
SuspendEvents (inherited from CommandBarItem) | Suspends events.
ToString (inherited from CommandBarItem) | Gives a string representation of this item.

See Also

CommandBarComboItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarComboItem.CalculateSize Method

See CommandBarItem

[Visual Basic]
Overrides Public Function CalculateSize( _
ByVal parent As CommandBar, _
ByVal g As Graphics _
) As Size
[C#]
public override Size CalculateSize(
CommandBar parent,
Graphics g
);

Parameters

parent
g

Return Value

See Also

CommandBarComboItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarComboItem.CalculateSizeMenu Method

See CommandBarItem

[Visual Basic]
Overrides Public Function CalculateSizeMenu( _
ByVal parent As CommandContextMenu, _
ByVal g As Graphics _
) As Size
[C#]
public override Size CalculateSizeMenu(
CommandContextMenu parent,
Graphics g
);

Parameters

parent
g

Return Value

See Also

CommandBarComboItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarComboItem.Draw Method

See CommandBarItem

[Visual Basic]
Overrides Public Sub Draw( _
ByVal parent As CommandBar, _
ByVal g As Graphics, _
ByVal state As DrawItemState, _
ByVal rect As Rectangle _
)
[C#]
public override void Draw(
CommandBar parent,
Graphics g,
DrawItemState state,
Rectangle rect
);

Parameters

parent
g
state
rect

See Also

CommandBarComboItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarComboItem.DrawMenu Method

See CommandBarItem

[Visual Basic]
Overrides Public Sub DrawMenu( _
ByVal parent As CommandContextMenu, _
ByVal g As Graphics, _
ByVal state As DrawItemState, _
ByVal rect As Rectangle _
)
[C#]
public override void DrawMenu(
CommandContextMenu parent,
Graphics g,
DrawItemState state,
Rectangle rect
);

Parameters

parent
g
state
rect

See Also

CommandBarComboItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarComboItem.Initialize Method

Resets the item to default properties.

[Visual Basic]
Overrides Public Sub Initialize()
[C#]
public override void Initialize();

See Also

CommandBarComboItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarComboItem.OnBoundsChanged Method

See CommandBarItem

[Visual Basic]
Overrides Public Sub OnBoundsChanged()
[C#]
public override void OnBoundsChanged();

See Also

CommandBarComboItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarComboItem.OnContainerChanged Method

See CommandBarItem

[Visual Basic]
Overrides Public Sub OnContainerChanged()
[C#]
public override void OnContainerChanged();

See Also

CommandBarComboItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarComboItem.ProcessMouseDown Method

See CommandBarItem

[Visual Basic]
Overrides Public Sub ProcessMouseDown( _
ByVal parent As CommandBar, _
ByVal e As MouseEventArgs _
)
[C#]
public override void ProcessMouseDown(
CommandBar parent,
MouseEventArgs e
);

Parameters

parent
e

See Also

CommandBarComboItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarComboItem.ProcessMouseMove Method

See CommandBarItem

[Visual Basic]
Overrides Public Sub ProcessMouseMove( _
ByVal parent As CommandBar, _
ByVal e As MouseEventArgs _
)
[C#]
public override void ProcessMouseMove(
CommandBar parent,
MouseEventArgs e
);

Parameters

parent
e

See Also

CommandBarComboItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarComboItem.ProcessMouseUp Method

See CommandBarItem

[Visual Basic]
Overrides Public Sub ProcessMouseUp( _
ByVal parent As CommandBar, _
ByVal e As MouseEventArgs _
)
[C#]
public override void ProcessMouseUp(
CommandBar parent,
MouseEventArgs e
);

Parameters

parent
e

See Also

CommandBarComboItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarControlItem Class

A command bar item that contains a control.

For a list of all members of this type, see CommandBarControlItem Members.

System.Object
MarshalByRefObject
Component
CommandBarItem
CommandBarControlItem

[Visual Basic]
Public Class CommandBarControlItem
Inherits CommandBarItem
[C#]
public class CommandBarControlItem : CommandBarItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Bars

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

CommandBarControlItem Members | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarControlItem Members

CommandBarControlItem overview

Public Instance Constructors

CommandBarControlItem Overloaded. Initializes a new instance of the CommandBarControlItem class.

Public Instance Properties

Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerControl (inherited from CommandBarItem) | The item's container control.
Control | Gets or sets the control associated with this item.
Enabled (inherited from CommandBarItem) | Is this item enabled?
Height | Gets or sets the height of this item's control.
Infrequent (inherited from CommandBarItem) | Is this item infrequent?
MenuSelectable | See CommandBarItem
PadHorizontal (inherited from CommandBarItem) | The item's horizontal padding.
PadVertical (inherited from CommandBarItem) | The item's vertical padding.
Site (inherited from Component) | Gets or sets the ISite of the Component.
Tag (inherited from CommandBarItem) | An object associated with this item.
Text (inherited from CommandBarItem) | The item's text.
Visible (inherited from CommandBarItem) | Is this item visible?
Width | Gets or sets the width of this item's control.

Public Instance Methods

CalculateSize | See CommandBarItem
CalculateSizeMenu | See CommandBarItem
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
Draw | See CommandBarItem
DrawMenu | See CommandBarItem
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize | Resets the item to default properties.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
OnBoundsChanged | See CommandBarItem
OnContainerChanged | See CommandBarItem
ProcessMouseDown | See CommandBarItem
ProcessMouseMove | See CommandBarItem
ProcessMouseUp | See CommandBarItem
ResumeEvents (inherited from CommandBarItem) | Resumes events.
SuspendEvents (inherited from CommandBarItem) | Suspends events.
ToString (inherited from CommandBarItem) | Gives a string representation of this item.

Public Instance Events

Changed (inherited from CommandBarItem) | Called when the item's properties are changed.
Click (inherited from CommandBarItem) | Called when the item is clicked.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
Hover (inherited from CommandBarItem) | Called when the mouse moves over the item.
Leave (inherited from CommandBarItem) | Called when the mouse has left the item.

See Also

CommandBarControlItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarControlItem Constructor

Constructs a control item with specified text and Click event handler.

Overload List

Creates a control box item with default options.

public CommandBarControlItem();

Constructs a control item with specified text.

public CommandBarControlItem(string);

Constructs a control item with specified text and Click event handler.

public CommandBarControlItem(string,EventHandler);

See Also

CommandBarControlItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarControlItem Constructor (String, EventHandler)

Constructs a control item with specified text and Click event handler.

[Visual Basic]
Overloads Public Sub New( _
ByVal text As String, _
ByVal onClick As EventHandler _
)
[C#]
public CommandBarControlItem(
string text,
EventHandler onClick
);

Parameters

text
Text to display.
onClick
Click event handler.

See Also

CommandBarControlItem Class | NETXP.Controls.Bars Namespace | CommandBarControlItem Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarControlItem Constructor (String)

Constructs a control item with specified text.

[Visual Basic]
Overloads Public Sub New( _
ByVal text As String _
)
[C#]
public CommandBarControlItem(
string text
);

Parameters

text
Text to display.

See Also

CommandBarControlItem Class | NETXP.Controls.Bars Namespace | CommandBarControlItem Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarControlItem Constructor ()

Creates a control box item with default options.

[Visual Basic]
Overloads Public Sub New()
[C#]
public CommandBarControlItem();

See Also

CommandBarControlItem Class | NETXP.Controls.Bars Namespace | CommandBarControlItem Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarControlItem Properties

The properties of the CommandBarControlItem class are listed below. For a complete list of CommandBarControlItem class members, see the CommandBarControlItem Members topic.

Public Instance Properties

Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerControl (inherited from CommandBarItem) | The item's container control.
Control | Gets or sets the control associated with this item.
Enabled (inherited from CommandBarItem) | Is this item enabled?
Height | Gets or sets the height of this item's control.
Infrequent (inherited from CommandBarItem) | Is this item infrequent?
MenuSelectable | See CommandBarItem
PadHorizontal (inherited from CommandBarItem) | The item's horizontal padding.
PadVertical (inherited from CommandBarItem) | The item's vertical padding.
Site (inherited from Component) | Gets or sets the ISite of the Component.
Tag (inherited from CommandBarItem) | An object associated with this item.
Text (inherited from CommandBarItem) | The item's text.
Visible (inherited from CommandBarItem) | Is this item visible?
Width | Gets or sets the width of this item's control.

See Also

CommandBarControlItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarControlItem.Control Property

Gets or sets the control associated with this item.

[Visual Basic]
Public Property Control As Control
[C#]
public System.Windows.Forms.Control Control {get; set;}

See Also

CommandBarControlItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarControlItem.Height Property

Gets or sets the height of this item's control.

[Visual Basic]
Public Property Height As Integer
[C#]
public int Height {get; set;}

See Also

CommandBarControlItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarControlItem.MenuSelectable Property

See CommandBarItem

[Visual Basic]
Overrides Public ReadOnly Property MenuSelectable As Boolean
[C#]
public override bool MenuSelectable {get;}

See Also

CommandBarControlItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarControlItem.Width Property

Gets or sets the width of this item's control.

[Visual Basic]
Public Property Width As Integer
[C#]
public int Width {get; set;}

See Also

CommandBarControlItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarControlItem Methods

The methods of the CommandBarControlItem class are listed below. For a complete list of CommandBarControlItem class members, see the CommandBarControlItem Members topic.

Public Instance Methods

CalculateSize | See CommandBarItem
CalculateSizeMenu | See CommandBarItem
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
Draw | See CommandBarItem
DrawMenu | See CommandBarItem
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize | Resets the item to default properties.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
OnBoundsChanged | See CommandBarItem
OnContainerChanged | See CommandBarItem
ProcessMouseDown | See CommandBarItem
ProcessMouseMove | See CommandBarItem
ProcessMouseUp | See CommandBarItem
ResumeEvents (inherited from CommandBarItem) | Resumes events.
SuspendEvents (inherited from CommandBarItem) | Suspends events.
ToString (inherited from CommandBarItem) | Gives a string representation of this item.

See Also

CommandBarControlItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarControlItem.CalculateSize Method

See CommandBarItem

[Visual Basic]
Overrides Public Function CalculateSize( _
ByVal parent As CommandBar, _
ByVal g As Graphics _
) As Size
[C#]
public override Size CalculateSize(
CommandBar parent,
Graphics g
);

Parameters

parent
g

Return Value

See Also

CommandBarControlItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarControlItem.CalculateSizeMenu Method

See CommandBarItem

[Visual Basic]
Overrides Public Function CalculateSizeMenu( _
ByVal parent As CommandContextMenu, _
ByVal g As Graphics _
) As Size
[C#]
public override Size CalculateSizeMenu(
CommandContextMenu parent,
Graphics g
);

Parameters

parent
g

Return Value

See Also

CommandBarControlItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarControlItem.Draw Method

See CommandBarItem

[Visual Basic]
Overrides Public Sub Draw( _
ByVal parent As CommandBar, _
ByVal g As Graphics, _
ByVal state As DrawItemState, _
ByVal rect As Rectangle _
)
[C#]
public override void Draw(
CommandBar parent,
Graphics g,
DrawItemState state,
Rectangle rect
);

Parameters

parent
g
state
rect

See Also

CommandBarControlItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarControlItem.DrawMenu Method

See CommandBarItem

[Visual Basic]
Overrides Public Sub DrawMenu( _
ByVal parent As CommandContextMenu, _
ByVal g As Graphics, _
ByVal state As DrawItemState, _
ByVal rect As Rectangle _
)
[C#]
public override void DrawMenu(
CommandContextMenu parent,
Graphics g,
DrawItemState state,
Rectangle rect
);

Parameters

parent
g
state
rect

See Also

CommandBarControlItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarControlItem.Initialize Method

Resets the item to default properties.

[Visual Basic]
Overrides Public Sub Initialize()
[C#]
public override void Initialize();

See Also

CommandBarControlItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarControlItem.OnBoundsChanged Method

See CommandBarItem

[Visual Basic]
Overrides Public Sub OnBoundsChanged()
[C#]
public override void OnBoundsChanged();

See Also

CommandBarControlItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarControlItem.OnContainerChanged Method

See CommandBarItem

[Visual Basic]
Overrides Public Sub OnContainerChanged()
[C#]
public override void OnContainerChanged();

See Also

CommandBarControlItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarControlItem.ProcessMouseDown Method

See CommandBarItem

[Visual Basic]
Overrides Public Sub ProcessMouseDown( _
ByVal parent As CommandBar, _
ByVal e As MouseEventArgs _
)
[C#]
public override void ProcessMouseDown(
CommandBar parent,
MouseEventArgs e
);

Parameters

parent
e

See Also

CommandBarControlItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarControlItem.ProcessMouseMove Method

See CommandBarItem

[Visual Basic]
Overrides Public Sub ProcessMouseMove( _
ByVal parent As CommandBar, _
ByVal e As MouseEventArgs _
)
[C#]
public override void ProcessMouseMove(
CommandBar parent,
MouseEventArgs e
);

Parameters

parent
e

See Also

CommandBarControlItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarControlItem.ProcessMouseUp Method

See CommandBarItem

[Visual Basic]
Overrides Public Sub ProcessMouseUp( _
ByVal parent As CommandBar, _
ByVal e As MouseEventArgs _
)
[C#]
public override void ProcessMouseUp(
CommandBar parent,
MouseEventArgs e
);

Parameters

parent
e

See Also

CommandBarControlItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarDock Class

A command bar container control which manages multiple command bars. This should not be added at design time.

For a list of all members of this type, see CommandBarDock Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
CommandBarDock

[Visual Basic]
NotInheritable Public Class CommandBarDock
Inherits ContainerControl
[C#]
public sealed class CommandBarDock : ContainerControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Bars

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

CommandBarDock Members | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarDock Members

CommandBarDock overview

Public Instance Constructors

CommandBarDock Constructor Constructs a new control bar with default parameters.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor | Hides an inherited property.
BackgroundImage | Hides an inherited property.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock | Gets or sets the dock style for the command bar dock.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor | Hides an inherited property.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDesignMode | Is this control in design mode?
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsRTL | Is this control right-to-left?
IsVertical | Is this control vertical?
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Manager | Gets or sets the command bar manager associated with this command bar dock.
Name (inherited from Control) | Gets or sets the name of the control.
Orientation | Gets the orientation for this control based on the dock style.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetFreeRow | Gets the next free row.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
UpdateLayout | Lays out the bars.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

CommandBarDock Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarDock Constructor

Constructs a new control bar with default parameters.

[Visual Basic]
Public Sub New()
[C#]
public CommandBarDock();

See Also

CommandBarDock Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarDock Properties

The properties of the CommandBarDock class are listed below. For a complete list of CommandBarDock class members, see the CommandBarDock Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor | Hides an inherited property.
BackgroundImage | Hides an inherited property.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock | Gets or sets the dock style for the command bar dock.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor | Hides an inherited property.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDesignMode | Is this control in design mode?
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsRTL | Is this control right-to-left?
IsVertical | Is this control vertical?
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Manager | Gets or sets the command bar manager associated with this command bar dock.
Name (inherited from Control) | Gets or sets the name of the control.
Orientation | Gets the orientation for this control based on the dock style.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

CommandBarDock Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarDock.BackColor Property

Hides an inherited property.

[Visual Basic]
Overrides Public Property BackColor As Color
[C#]
public override System.Drawing.Color BackColor {get; set;}

See Also

CommandBarDock Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarDock.BackgroundImage Property

Hides an inherited property.

[Visual Basic]
Overrides Public Property BackgroundImage As Image
[C#]
public override System.Drawing.Image BackgroundImage {get; set;}

See Also

CommandBarDock Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarDock.Dock Property

Gets or sets the dock style for the command bar dock.

[Visual Basic]
Overrides Public Property Dock As DockStyle
[C#]
public override System.Windows.Forms.DockStyle Dock {get; set;}

See Also

CommandBarDock Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarDock.ForeColor Property

Hides an inherited property.

[Visual Basic]
Overrides Public Property ForeColor As Color
[C#]
public override System.Drawing.Color ForeColor {get; set;}

See Also

CommandBarDock Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarDock.IsDesignMode Property

Is this control in design mode?

[Visual Basic]
Public ReadOnly Property IsDesignMode As Boolean
[C#]
public bool IsDesignMode {get;}

See Also

CommandBarDock Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarDock.IsRTL Property

Is this control right-to-left?

[Visual Basic]
Public ReadOnly Property IsRTL As Boolean
[C#]
public bool IsRTL {get;}

See Also

CommandBarDock Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarDock.IsVertical Property

Is this control vertical?

[Visual Basic]
Public ReadOnly Property IsVertical As Boolean
[C#]
public bool IsVertical {get;}

See Also

CommandBarDock Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarDock.Manager Property

Gets or sets the command bar manager associated with this command bar dock.

[Visual Basic]
Public Property Manager As CommandBarManager
[C#]
public CommandBarManager Manager {get; set;}

See Also

CommandBarDock Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarDock.Orientation Property

Gets the orientation for this control based on the dock style.

[Visual Basic]
Public ReadOnly Property Orientation As Orientation
[C#]
public System.Windows.Forms.Orientation Orientation {get;}

See Also

CommandBarDock Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarDock Methods

The methods of the CommandBarDock class are listed below. For a complete list of CommandBarDock class members, see the CommandBarDock Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetFreeRow | Gets the next free row.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
UpdateLayout | Lays out the bars.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

CommandBarDock Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarDock.GetFreeRow Method

Gets the next free row.

[Visual Basic]
Public Function GetFreeRow() As Integer
[C#]
public int GetFreeRow();

Return Value

A row number.

See Also

CommandBarDock Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarDock.UpdateLayout Method

Lays out the bars.

[Visual Basic]
Public Sub UpdateLayout( _
ByVal lastBar As CommandBar _
)
[C#]
public void UpdateLayout(
CommandBar lastBar
);

Parameters

lastBar
Optional. The last bar to lay out.

See Also

CommandBarDock Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarExpansionItem Class

Internal

For a list of all members of this type, see CommandBarExpansionItem Members.

System.Object
MarshalByRefObject
Component
CommandBarItem
CommandBarButtonItem
CommandBarExpansionItem

[Visual Basic]
NotInheritable Public Class CommandBarExpansionItem
Inherits CommandBarButtonItem
[C#]
public sealed class CommandBarExpansionItem : CommandBarButtonItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Bars

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

CommandBarExpansionItem Members | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarExpansionItem Members

CommandBarExpansionItem overview

Public Instance Constructors

CommandBarExpansionItem Constructor Initializes a new instance of the CommandBarExpansionItem class.

Public Instance Properties

Checked (inherited from CommandBarButtonItem) | Is this item checked (depressed)?
CheckType (inherited from CommandBarButtonItem) | How the item displays checkmarks.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerControl (inherited from CommandBarItem) | The item's container control.
DefaultItem (inherited from CommandBarButtonItem) | Does this item show its text bold when shown on a menu?
DropUp (inherited from CommandBarButtonItem) | Gets or sets if this item is dropped up instead of down.
Enabled (inherited from CommandBarItem) | Is this item enabled?
HotImage (inherited from CommandBarButtonItem) | The item's hot image.
Image (inherited from CommandBarButtonItem) | The item's image.
Infrequent (inherited from CommandBarItem) | Is this item infrequent?
Items (inherited from CommandBarButtonItem) | A collection of CommandBarItem objects shown in the submenu of this item.
MenuSelectable (inherited from CommandBarItem) | Can this item be selected in a menu?
PadHorizontal (inherited from CommandBarItem) | The item's horizontal padding.
PadVertical (inherited from CommandBarItem) | The item's vertical padding.
Shortcut (inherited from CommandBarButtonItem) | The item's shortcut key (if a menu item).
ShowText (inherited from CommandBarButtonItem) | Does this item show its text?
Site (inherited from Component) | Gets or sets the ISite of the Component.
Style (inherited from CommandBarButtonItem) | The item's display style.
Tag (inherited from CommandBarItem) | An object associated with this item.
Text (inherited from CommandBarItem) | The item's text.
Visible (inherited from CommandBarItem) | Is this item visible?

Public Instance Methods

CalculateSize | See CommandBarItem
CalculateSizeMenu | See CommandBarItem
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
Draw | See CommandBarItem
DrawMenu | See CommandBarItem
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from CommandBarButtonItem) | Resets the item to default properties.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
OnBoundsChanged (inherited from CommandBarButtonItem) | See CommandBarItem
OnContainerChanged (inherited from CommandBarButtonItem) | See CommandBarItem
ProcessMouseDown (inherited from CommandBarButtonItem) | See CommandBarItem
ProcessMouseMove (inherited from CommandBarButtonItem) | See CommandBarItem
ProcessMouseUp (inherited from CommandBarButtonItem) | See CommandBarItem
ResumeEvents (inherited from CommandBarItem) | Resumes events.
SuspendEvents (inherited from CommandBarItem) | Suspends events.
ToString (inherited from CommandBarItem) | Gives a string representation of this item.

Public Instance Events

Changed (inherited from CommandBarItem) | Called when the item's properties are changed.
Click (inherited from CommandBarItem) | Called when the item is clicked.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DropDown (inherited from CommandBarButtonItem) | Called when a dropdown menu is shown. Cancel the event in order to avoid showing the default popup menu.
Enter (inherited from CommandBarButtonItem) | See IStatusMessageProvider.
Hover (inherited from CommandBarItem) | Called when the mouse moves over the item.
Leave (inherited from CommandBarItem) | Called when the mouse has left the item.

See Also

CommandBarExpansionItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarExpansionItem Constructor

Initializes a new instance of the CommandBarExpansionItem class.

[Visual Basic]
Public Sub New()
[C#]
public CommandBarExpansionItem();

See Also

CommandBarExpansionItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarExpansionItem Methods

The methods of the CommandBarExpansionItem class are listed below. For a complete list of CommandBarExpansionItem class members, see the CommandBarExpansionItem Members topic.

Public Instance Methods

CalculateSize | See CommandBarItem
CalculateSizeMenu | See CommandBarItem
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
Draw | See CommandBarItem
DrawMenu | See CommandBarItem
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from CommandBarButtonItem) | Resets the item to default properties.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
OnBoundsChanged (inherited from CommandBarButtonItem) | See CommandBarItem
OnContainerChanged (inherited from CommandBarButtonItem) | See CommandBarItem
ProcessMouseDown (inherited from CommandBarButtonItem) | See CommandBarItem
ProcessMouseMove (inherited from CommandBarButtonItem) | See CommandBarItem
ProcessMouseUp (inherited from CommandBarButtonItem) | See CommandBarItem
ResumeEvents (inherited from CommandBarItem) | Resumes events.
SuspendEvents (inherited from CommandBarItem) | Suspends events.
ToString (inherited from CommandBarItem) | Gives a string representation of this item.

See Also

CommandBarExpansionItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarExpansionItem.CalculateSize Method

See CommandBarItem

[Visual Basic]
Overrides Public Function CalculateSize( _
ByVal parent As CommandBar, _
ByVal g As Graphics _
) As Size
[C#]
public override Size CalculateSize(
CommandBar parent,
Graphics g
);

Parameters

parent
g

Return Value

See Also

CommandBarExpansionItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarExpansionItem.CalculateSizeMenu Method

See CommandBarItem

[Visual Basic]
Overrides Public Function CalculateSizeMenu( _
ByVal parent As CommandContextMenu, _
ByVal g As Graphics _
) As Size
[C#]
public override Size CalculateSizeMenu(
CommandContextMenu parent,
Graphics g
);

Parameters

parent
g

Return Value

See Also

CommandBarExpansionItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarExpansionItem.Draw Method

See CommandBarItem

[Visual Basic]
Overrides Public Sub Draw( _
ByVal parent As CommandBar, _
ByVal g As Graphics, _
ByVal state As DrawItemState, _
ByVal rect As Rectangle _
)
[C#]
public override void Draw(
CommandBar parent,
Graphics g,
DrawItemState state,
Rectangle rect
);

Parameters

parent
g
state
rect

See Also

CommandBarExpansionItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarExpansionItem.DrawMenu Method

See CommandBarItem

[Visual Basic]
Overrides Public Sub DrawMenu( _
ByVal parent As CommandContextMenu, _
ByVal g As Graphics, _
ByVal state As DrawItemState, _
ByVal rect As Rectangle _
)
[C#]
public override void DrawMenu(
CommandContextMenu parent,
Graphics g,
DrawItemState state,
Rectangle rect
);

Parameters

parent
g
state
rect

See Also

CommandBarExpansionItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItem Class

This class describes one item on the command bar.

For a list of all members of this type, see CommandBarItem Members.

System.Object
MarshalByRefObject
Component
CommandBarItem

[Visual Basic]
MustInherit Public Class CommandBarItem
Inherits Component
[C#]
public abstract class CommandBarItem : Component

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Bars

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

CommandBarItem Members | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItem Members

CommandBarItem overview

Public Instance Constructors

CommandBarItem Overloaded. Initializes a new instance of the CommandBarItem class.

Public Instance Properties

Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerControl | The item's container control.
Enabled | Is this item enabled?
Infrequent | Is this item infrequent?
MenuSelectable | Can this item be selected in a menu?
PadHorizontal | The item's horizontal padding.
PadVertical | The item's vertical padding.
Site (inherited from Component) | Gets or sets the ISite of the Component.
Tag | An object associated with this item.
Text | The item's text.
Visible | Is this item visible?

Public Instance Methods

CalculateSize | Calculates the size of this command bar item on a command bar.
CalculateSizeMenu | Calculates the size of this command bar item on a popup menu.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
Draw | Draws the command bar item on a command bar.
DrawMenu | Draws the command bar item on a popup menu.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize | Resets the item to default properties.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
OnBoundsChanged | Called when the item's bounds rectangle changed.
OnContainerChanged | Called when the container control changed.
ProcessMouseDown | Processes a MouseDown event.
ProcessMouseMove | Processes a MouseMove event.
ProcessMouseUp | Processes a MouseUp event.
ResumeEvents | Resumes events.
SuspendEvents | Suspends events.
ToString | Gives a string representation of this item.

Public Instance Events

Changed | Called when the item's properties are changed.
Click | Called when the item is clicked.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
Hover | Called when the mouse moves over the item.
Leave | Called when the mouse has left the item.

See Also

CommandBarItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItem Constructor

Creates a command bar item for use inside a designer.

Overload List

Creates a command bar item with default options.

public CommandBarItem();

Creates a command bar item for use inside a designer.

public CommandBarItem(IContainer);

Constructs a command bar item with specified text.

public CommandBarItem(string);

Constructs a command bar item with specified text and Click event handler.

public CommandBarItem(string,EventHandler);

See Also

CommandBarItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItem Constructor (IContainer)

Creates a command bar item for use inside a designer.

[Visual Basic]
Overloads Public Sub New( _
ByVal container As IContainer _
)
[C#]
public CommandBarItem(
IContainer container
);

Parameters

container
The container for this item.

See Also

CommandBarItem Class | NETXP.Controls.Bars Namespace | CommandBarItem Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItem Constructor ()

Creates a command bar item with default options.

[Visual Basic]
Overloads Public Sub New()
[C#]
public CommandBarItem();

See Also

CommandBarItem Class | NETXP.Controls.Bars Namespace | CommandBarItem Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItem Constructor (String, EventHandler)

Constructs a command bar item with specified text and Click event handler.

[Visual Basic]
Overloads Public Sub New( _
ByVal text As String, _
ByVal onClick As EventHandler _
)
[C#]
public CommandBarItem(
string text,
EventHandler onClick
);

Parameters

text
Text to display.
onClick
Click event handler.

See Also

CommandBarItem Class | NETXP.Controls.Bars Namespace | CommandBarItem Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItem Constructor (String)

Constructs a command bar item with specified text.

[Visual Basic]
Overloads Public Sub New( _
ByVal text As String _
)
[C#]
public CommandBarItem(
string text
);

Parameters

text
Text to display.

See Also

CommandBarItem Class | NETXP.Controls.Bars Namespace | CommandBarItem Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItem Properties

The properties of the CommandBarItem class are listed below. For a complete list of CommandBarItem class members, see the CommandBarItem Members topic.

Public Instance Properties

Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerControl | The item's container control.
Enabled | Is this item enabled?
Infrequent | Is this item infrequent?
MenuSelectable | Can this item be selected in a menu?
PadHorizontal | The item's horizontal padding.
PadVertical | The item's vertical padding.
Site (inherited from Component) | Gets or sets the ISite of the Component.
Tag | An object associated with this item.
Text | The item's text.
Visible | Is this item visible?

See Also

CommandBarItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItem.ContainerControl Property

The item's container control.

[Visual Basic]
Overridable Public Property ContainerControl As Control
[C#]
public virtual System.Windows.Forms.Control ContainerControl {get; set;}

See Also

CommandBarItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItem.Enabled Property

Is this item enabled?

[Visual Basic]
Overridable Public Property Enabled As Boolean
[C#]
public virtual bool Enabled {get; set;}

See Also

CommandBarItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItem.Infrequent Property

Is this item infrequent?

[Visual Basic]
Overridable Public Property Infrequent As Boolean
[C#]
public virtual bool Infrequent {get; set;}

See Also

CommandBarItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItem.MenuSelectable Property

Can this item be selected in a menu?

[Visual Basic]
Overridable Public ReadOnly Property MenuSelectable As Boolean
[C#]
public virtual bool MenuSelectable {get;}

See Also

CommandBarItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItem.PadHorizontal Property

The item's horizontal padding.

[Visual Basic]
Overridable Public Property PadHorizontal As Integer
[C#]
public virtual int PadHorizontal {get; set;}

See Also

CommandBarItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItem.PadVertical Property

The item's vertical padding.

[Visual Basic]
Overridable Public Property PadVertical As Integer
[C#]
public virtual int PadVertical {get; set;}

See Also

CommandBarItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItem.Tag Property

An object associated with this item.

[Visual Basic]
Overridable Public Property Tag As Object
[C#]
public virtual object Tag {get; set;}

See Also

CommandBarItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItem.Text Property

The item's text.

[Visual Basic]
Overridable Public Property Text As String
[C#]
public virtual string Text {get; set;}

See Also

CommandBarItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItem.Visible Property

Is this item visible?

[Visual Basic]
Overridable Public Property Visible As Boolean
[C#]
public virtual bool Visible {get; set;}

See Also

CommandBarItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItem Methods

The methods of the CommandBarItem class are listed below. For a complete list of CommandBarItem class members, see the CommandBarItem Members topic.

Public Instance Methods

CalculateSize | Calculates the size of this command bar item on a command bar.
CalculateSizeMenu | Calculates the size of this command bar item on a popup menu.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
Draw | Draws the command bar item on a command bar.
DrawMenu | Draws the command bar item on a popup menu.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize | Resets the item to default properties.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
OnBoundsChanged | Called when the item's bounds rectangle changed.
OnContainerChanged | Called when the container control changed.
ProcessMouseDown | Processes a MouseDown event.
ProcessMouseMove | Processes a MouseMove event.
ProcessMouseUp | Processes a MouseUp event.
ResumeEvents | Resumes events.
SuspendEvents | Suspends events.
ToString | Gives a string representation of this item.

See Also

CommandBarItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItem.CalculateSize Method

Calculates the size of this command bar item on a command bar.

[Visual Basic]
MustOverride Public Function CalculateSize( _
ByVal parent As CommandBar, _
ByVal g As Graphics _
) As Size
[C#]
public abstract Size CalculateSize(
CommandBar parent,
Graphics g
);

Parameters

parent
The command bar.
g
The graphics object.

Return Value

The size of the item.

See Also

CommandBarItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItem.CalculateSizeMenu Method

Calculates the size of this command bar item on a popup menu.

[Visual Basic]
MustOverride Public Function CalculateSizeMenu( _
ByVal parent As CommandContextMenu, _
ByVal g As Graphics _
) As Size
[C#]
public abstract Size CalculateSizeMenu(
CommandContextMenu parent,
Graphics g
);

Parameters

parent
The popup menu.
g
The graphics object.

Return Value

The size of the item.

See Also

CommandBarItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItem.Draw Method

Draws the command bar item on a command bar.

[Visual Basic]
MustOverride Public Sub Draw( _
ByVal parent As CommandBar, _
ByVal g As Graphics, _
ByVal state As DrawItemState, _
ByVal rect As Rectangle _
)
[C#]
public abstract void Draw(
CommandBar parent,
Graphics g,
DrawItemState state,
Rectangle rect
);

Parameters

parent
The command bar.
g
The graphics object.
state
The item's draw state.
rect
The item's bounds rectangle.

See Also

CommandBarItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItem.DrawMenu Method

Draws the command bar item on a popup menu.

[Visual Basic]
MustOverride Public Sub DrawMenu( _
ByVal parent As CommandContextMenu, _
ByVal g As Graphics, _
ByVal state As DrawItemState, _
ByVal rect As Rectangle _
)
[C#]
public abstract void DrawMenu(
CommandContextMenu parent,
Graphics g,
DrawItemState state,
Rectangle rect
);

Parameters

parent
The popup menu.
g
The graphics object.
state
The item's draw state.
rect
The item's bounds rectangle.

See Also

CommandBarItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItem.Initialize Method

Resets the item to default properties.

[Visual Basic]
Overridable Public Sub Initialize()
[C#]
public virtual void Initialize();

See Also

CommandBarItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItem.OnBoundsChanged Method

Called when the item's bounds rectangle changed.

[Visual Basic]
MustOverride Public Sub OnBoundsChanged()
[C#]
public abstract void OnBoundsChanged();

See Also

CommandBarItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItem.OnContainerChanged Method

Called when the container control changed.

[Visual Basic]
MustOverride Public Sub OnContainerChanged()
[C#]
public abstract void OnContainerChanged();

See Also

CommandBarItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItem.ProcessMouseDown Method

Processes a MouseDown event.

[Visual Basic]
MustOverride Public Sub ProcessMouseDown( _
ByVal parent As CommandBar, _
ByVal e As MouseEventArgs _
)
[C#]
public abstract void ProcessMouseDown(
CommandBar parent,
MouseEventArgs e
);

Parameters

parent
The command bar.
e
The mouse event args.

See Also

CommandBarItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItem.ProcessMouseMove Method

Processes a MouseMove event.

[Visual Basic]
MustOverride Public Sub ProcessMouseMove( _
ByVal parent As CommandBar, _
ByVal e As MouseEventArgs _
)
[C#]
public abstract void ProcessMouseMove(
CommandBar parent,
MouseEventArgs e
);

Parameters

parent
The command bar.
e
The mouse event args.

See Also

CommandBarItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItem.ProcessMouseUp Method

Processes a MouseUp event.

[Visual Basic]
MustOverride Public Sub ProcessMouseUp( _
ByVal parent As CommandBar, _
ByVal e As MouseEventArgs _
)
[C#]
public abstract void ProcessMouseUp(
CommandBar parent,
MouseEventArgs e
);

Parameters

parent
The command bar.
e
The mouse event args.

See Also

CommandBarItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItem.ResumeEvents Method

Resumes events.

[Visual Basic]
Public Sub ResumeEvents()
[C#]
public void ResumeEvents();

See Also

CommandBarItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItem.SuspendEvents Method

Suspends events.

[Visual Basic]
Public Sub SuspendEvents()
[C#]
public void SuspendEvents();

See Also

CommandBarItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItem.ToString Method

Gives a string representation of this item.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

The string

See Also

CommandBarItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItem Events

The events of the CommandBarItem class are listed below. For a complete list of CommandBarItem class members, see the CommandBarItem Members topic.

Public Instance Events

Changed | Called when the item's properties are changed.
Click | Called when the item is clicked.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
Hover | Called when the mouse moves over the item.
Leave | Called when the mouse has left the item.

See Also

CommandBarItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItem.Changed Event

Called when the item's properties are changed.

[Visual Basic]
Public Event Changed As CommandBarItemChangedEventHandler
[C#]
public event CommandBarItemChangedEventHandler Changed;

Event Data

The event handler receives an argument of type CommandBarItemChangedEventArgs containing data related to this event. The following CommandBarItemChangedEventArgs property provides information specific to this event.

Property | Description
SizeChanged | Has the item's size changed?

See Also

CommandBarItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItem.Click Event

Called when the item is clicked.

[Visual Basic]
Public Event Click As EventHandler
[C#]
public event EventHandler Click;

See Also

CommandBarItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItem.Hover Event

Called when the mouse moves over the item.

[Visual Basic]
Public Event Hover As EventHandler
[C#]
public event EventHandler Hover;

See Also

CommandBarItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItem.Leave Event

Called when the mouse has left the item.

[Visual Basic]
Public Event Leave As EventHandler
[C#]
public event EventHandler Leave;

See Also

CommandBarItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItemChangedEventArgs Class

Defines event arguments for the ItemChanged event.

For a list of all members of this type, see CommandBarItemChangedEventArgs Members.

System.Object
EventArgs
CommandBarItemChangedEventArgs

[Visual Basic]
Public Class CommandBarItemChangedEventArgs
Inherits EventArgs
[C#]
public class CommandBarItemChangedEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Bars

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

CommandBarItemChangedEventArgs Members | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItemChangedEventArgs Members

CommandBarItemChangedEventArgs overview

Public Instance Constructors

CommandBarItemChangedEventArgs Constructor Initializes the event arguments.

Public Instance Properties

SizeChanged Has the item's size changed?

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

CommandBarItemChangedEventArgs Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItemChangedEventArgs Constructor

Initializes the event arguments.

[Visual Basic]
Public Sub New( _
ByVal sizeChanged As Boolean _
)
[C#]
public CommandBarItemChangedEventArgs(
bool sizeChanged
);

Parameters

sizeChanged
Has the item's size changed?

See Also

CommandBarItemChangedEventArgs Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItemChangedEventArgs Properties

The properties of the CommandBarItemChangedEventArgs class are listed below. For a complete list of CommandBarItemChangedEventArgs class members, see the CommandBarItemChangedEventArgs Members topic.

Public Instance Properties

SizeChanged Has the item's size changed?

See Also

CommandBarItemChangedEventArgs Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItemChangedEventArgs.SizeChanged Property

Has the item's size changed?

[Visual Basic]
Public Property SizeChanged As Boolean
[C#]
public bool SizeChanged {get; set;}

See Also

CommandBarItemChangedEventArgs Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItemChangedEventHandler Delegate

Handles the Item.Changed event.

[Visual Basic]
Public Delegate Sub CommandBarItemChangedEventHandler( _
ByVal sender As Object, _
ByVal e As CommandBarItemChangedEventArgs _
)
[C#]
public delegate void CommandBarItemChangedEventHandler(
object sender,
CommandBarItemChangedEventArgs e
);

Requirements

Namespace: NETXP.Controls.Bars

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItemCollection Class

A collection of CommandBarItem objects.

For a list of all members of this type, see CommandBarItemCollection Members.

System.Object
CollectionBase
CommandBarItemCollection

[Visual Basic]
NotInheritable Public Class CommandBarItemCollection
Inherits CollectionBase
[C#]
public sealed class CommandBarItemCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Bars

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

CommandBarItemCollection Members | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItemCollection Members

CommandBarItemCollection overview

Public Instance Constructors

CommandBarItemCollection Constructor Creates a new collection.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Item | Overloaded. Retrieves an item at an index.
SuppressEvents | Should events be suppressed?

Public Instance Methods

Add | Adds an item to the collection.
AddRange | Adds a set of items to the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Contains | Checks if the collection contains a certain item.
CopyTo | Copies this collection's items into an array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Gets the index of an item.
Insert | Inserts an item at a specified index.
MoveDown | Moves an item down the list.
MoveUp | Moves an item up the list.
RaiseChanged | Raises a Changed event.
Remove | Removes an item.
RemoveAt | Removes an item at a specified index.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

Changed Called when the collection has changed.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

CommandBarItemCollection Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItemCollection Constructor

Creates a new collection.

[Visual Basic]
Public Sub New()
[C#]
public CommandBarItemCollection();

See Also

CommandBarItemCollection Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItemCollection Properties

The properties of the CommandBarItemCollection class are listed below. For a complete list of CommandBarItemCollection class members, see the CommandBarItemCollection Members topic.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Item | Overloaded. Retrieves an item at an index.
SuppressEvents | Should events be suppressed?

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

CommandBarItemCollection Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItemCollection.Item Property

Retrieves an item at an index.

[Visual Basic]
Overloads Public Default Property Item( _
ByVal index As Integer _
) As CommandBarItem
[C#]
public CommandBarItem this[
int index
] {get; set;}

See Also

CommandBarItemCollection Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItemCollection.SuppressEvents Property

Should events be suppressed?

[Visual Basic]
Public Property SuppressEvents As Boolean
[C#]
public bool SuppressEvents {get; set;}

See Also

CommandBarItemCollection Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItemCollection Methods

The methods of the CommandBarItemCollection class are listed below. For a complete list of CommandBarItemCollection class members, see the CommandBarItemCollection Members topic.

Public Instance Methods

Add | Adds an item to the collection.
AddRange | Adds a set of items to the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Contains | Checks if the collection contains a certain item.
CopyTo | Copies this collection's items into an array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Gets the index of an item.
Insert | Inserts an item at a specified index.
MoveDown | Moves an item down the list.
MoveUp | Moves an item up the list.
RaiseChanged | Raises a Changed event.
Remove | Removes an item.
RemoveAt | Removes an item at a specified index.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

CommandBarItemCollection Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItemCollection.Add Method

Adds an item to the collection.

[Visual Basic]
Public Function Add( _
ByVal item As CommandBarItem _
) As Integer
[C#]
public int Add(
CommandBarItem item
);

Parameters

item
The item to add.

Return Value

The index where the item was added.

See Also

CommandBarItemCollection Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItemCollection.AddRange Method

Adds a set of items to the collection.

[Visual Basic]
Public Sub AddRange( _
ByVal items As CommandBarItem() _
)
[C#]
public void AddRange(
CommandBarItem[] items
);

Parameters

items
The array of items to add.

See Also

CommandBarItemCollection Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItemCollection.Contains Method

Checks if the collection contains a certain item.

[Visual Basic]
Public Function Contains( _
ByVal item As CommandBarItem _
) As Boolean
[C#]
public bool Contains(
CommandBarItem item
);

Parameters

item
The item

Return Value

True if the collection contains this item.

See Also

CommandBarItemCollection Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItemCollection.CopyTo Method

Copies this collection's items into an array.

[Visual Basic]
Public Sub CopyTo( _
ByVal array As Array, _
ByVal index As Integer _
)
[C#]
public void CopyTo(
Array array,
int index
);

Parameters

array
The array.
index
The index at which to start copying.

See Also

CommandBarItemCollection Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItemCollection.IndexOf Method

Gets the index of an item.

[Visual Basic]
Public Function IndexOf( _
ByVal item As CommandBarItem _
) As Integer
[C#]
public int IndexOf(
CommandBarItem item
);

Parameters

item
The item.

Return Value

The index of the item.

See Also

CommandBarItemCollection Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItemCollection.Insert Method

Inserts an item at a specified index.

[Visual Basic]
Public Sub Insert( _
ByVal index As Integer, _
ByVal item As CommandBarItem _
)
[C#]
public void Insert(
int index,
CommandBarItem item
);

Parameters

index
The index.
item
The item.

See Also

CommandBarItemCollection Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItemCollection.MoveDown Method

Moves an item down the list.

[Visual Basic]
Public Sub MoveDown( _
ByVal item As CommandBarItem _
)
[C#]
public void MoveDown(
CommandBarItem item
);

Parameters

item
The item.

See Also

CommandBarItemCollection Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItemCollection.MoveUp Method

Moves an item up the list.

[Visual Basic]
Public Sub MoveUp( _
ByVal item As CommandBarItem _
)
[C#]
public void MoveUp(
CommandBarItem item
);

Parameters

item
The item.

See Also

CommandBarItemCollection Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItemCollection.RaiseChanged Method

Raises a Changed event.

[Visual Basic]
Public Sub RaiseChanged()
[C#]
public void RaiseChanged();

See Also

CommandBarItemCollection Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItemCollection.Remove Method

Removes an item.

[Visual Basic]
Public Sub Remove( _
ByVal item As CommandBarItem _
)
[C#]
public void Remove(
CommandBarItem item
);

Parameters

item
The item to remove.

See Also

CommandBarItemCollection Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItemCollection.RemoveAt Method

Removes an item at a specified index.

[Visual Basic]
Public Sub RemoveAt( _
ByVal index As Integer _
) Implements _
IList.RemoveAt
[C#]
new public void RemoveAt(
int index
);

Parameters

index
The index to remove at.

Implements

IList.RemoveAt

See Also

CommandBarItemCollection Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItemCollection Events

The events of the CommandBarItemCollection class are listed below. For a complete list of CommandBarItemCollection class members, see the CommandBarItemCollection Members topic.

Public Instance Events

Changed Called when the collection has changed.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

CommandBarItemCollection Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarItemCollection.Changed Event

Called when the collection has changed.

[Visual Basic]
Public Event Changed As EventHandler
[C#]
public event EventHandler Changed;

See Also

CommandBarItemCollection Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarLabelItem Class

A label item.

For a list of all members of this type, see CommandBarLabelItem Members.

System.Object
MarshalByRefObject
Component
CommandBarItem
CommandBarLabelItem

[Visual Basic]
Public Class CommandBarLabelItem
Inherits CommandBarItem
[C#]
public class CommandBarLabelItem : CommandBarItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Bars

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

CommandBarLabelItem Members | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarLabelItem Members

CommandBarLabelItem overview

Public Instance Constructors

CommandBarLabelItem Overloaded. Initializes a new instance of the CommandBarLabelItem class.

Public Instance Properties

Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerControl (inherited from CommandBarItem) | The item's container control.
Enabled | See CommandBarItem
Infrequent (inherited from CommandBarItem) | Is this item infrequent?
MenuSelectable | See CommandBarItem
PadHorizontal (inherited from CommandBarItem) | The item's horizontal padding.
PadVertical (inherited from CommandBarItem) | The item's vertical padding.
Site (inherited from Component) | Gets or sets the ISite of the Component.
Tag (inherited from CommandBarItem) | An object associated with this item.
Text (inherited from CommandBarItem) | The item's text.
Visible (inherited from CommandBarItem) | Is this item visible?

Public Instance Methods

CalculateSize | See CommandBarItem
CalculateSizeMenu | See CommandBarItem
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
Draw | See CommandBarItem
DrawMenu | See CommandBarItem
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize | Resets to default options.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
OnBoundsChanged | See CommandBarItem
OnContainerChanged | See CommandBarItem
ProcessMouseDown | See CommandBarItem
ProcessMouseMove | See CommandBarItem
ProcessMouseUp | See CommandBarItem
ResumeEvents (inherited from CommandBarItem) | Resumes events.
SuspendEvents (inherited from CommandBarItem) | Suspends events.
ToString (inherited from CommandBarItem) | Gives a string representation of this item.

Public Instance Events

Changed (inherited from CommandBarItem) | Called when the item's properties are changed.
Click (inherited from CommandBarItem) | Called when the item is clicked.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
Hover (inherited from CommandBarItem) | Called when the mouse moves over the item.
Leave (inherited from CommandBarItem) | Called when the mouse has left the item.

See Also

CommandBarLabelItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarLabelItem Constructor

Constructs a new label item with the given text.

Overload List

Constructs a new label item with default options.

public CommandBarLabelItem();

Constructs a new label item with the given text.

public CommandBarLabelItem(string);

See Also

CommandBarLabelItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarLabelItem Constructor (String)

Constructs a new label item with the given text.

[Visual Basic]
Overloads Public Sub New( _
ByVal text As String _
)
[C#]
public CommandBarLabelItem(
string text
);

Parameters

text
The text.

See Also

CommandBarLabelItem Class | NETXP.Controls.Bars Namespace | CommandBarLabelItem Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarLabelItem Constructor ()

Constructs a new label item with default options.

[Visual Basic]
Overloads Public Sub New()
[C#]
public CommandBarLabelItem();

See Also

CommandBarLabelItem Class | NETXP.Controls.Bars Namespace | CommandBarLabelItem Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarLabelItem Properties

The properties of the CommandBarLabelItem class are listed below. For a complete list of CommandBarLabelItem class members, see the CommandBarLabelItem Members topic.

Public Instance Properties

Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerControl (inherited from CommandBarItem) | The item's container control.
Enabled | See CommandBarItem
Infrequent (inherited from CommandBarItem) | Is this item infrequent?
MenuSelectable | See CommandBarItem
PadHorizontal (inherited from CommandBarItem) | The item's horizontal padding.
PadVertical (inherited from CommandBarItem) | The item's vertical padding.
Site (inherited from Component) | Gets or sets the ISite of the Component.
Tag (inherited from CommandBarItem) | An object associated with this item.
Text (inherited from CommandBarItem) | The item's text.
Visible (inherited from CommandBarItem) | Is this item visible?

See Also

CommandBarLabelItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarLabelItem.Enabled Property

See CommandBarItem

[Visual Basic]
Overrides Public Property Enabled As Boolean
[C#]
public override bool Enabled {get; set;}

See Also

CommandBarLabelItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarLabelItem.MenuSelectable Property

See CommandBarItem

[Visual Basic]
Overrides Public ReadOnly Property MenuSelectable As Boolean
[C#]
public override bool MenuSelectable {get;}

See Also

CommandBarLabelItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarLabelItem Methods

The methods of the CommandBarLabelItem class are listed below. For a complete list of CommandBarLabelItem class members, see the CommandBarLabelItem Members topic.

Public Instance Methods

CalculateSize | See CommandBarItem
CalculateSizeMenu | See CommandBarItem
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
Draw | See CommandBarItem
DrawMenu | See CommandBarItem
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize | Resets to default options.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
OnBoundsChanged | See CommandBarItem
OnContainerChanged | See CommandBarItem
ProcessMouseDown | See CommandBarItem
ProcessMouseMove | See CommandBarItem
ProcessMouseUp | See CommandBarItem
ResumeEvents (inherited from CommandBarItem) | Resumes events.
SuspendEvents (inherited from CommandBarItem) | Suspends events.
ToString (inherited from CommandBarItem) | Gives a string representation of this item.

See Also

CommandBarLabelItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarLabelItem.CalculateSize Method

See CommandBarItem

[Visual Basic]
Overrides Public Function CalculateSize( _
ByVal parent As CommandBar, _
ByVal g As Graphics _
) As Size
[C#]
public override Size CalculateSize(
CommandBar parent,
Graphics g
);

Parameters

parent
g

Return Value

See Also

CommandBarLabelItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarLabelItem.CalculateSizeMenu Method

See CommandBarItem

[Visual Basic]
Overrides Public Function CalculateSizeMenu( _
ByVal parent As CommandContextMenu, _
ByVal g As Graphics _
) As Size
[C#]
public override Size CalculateSizeMenu(
CommandContextMenu parent,
Graphics g
);

Parameters

parent
g

Return Value

See Also

CommandBarLabelItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarLabelItem.Draw Method

See CommandBarItem

[Visual Basic]
Overrides Public Sub Draw( _
ByVal parent As CommandBar, _
ByVal g As Graphics, _
ByVal state As DrawItemState, _
ByVal rect As Rectangle _
)
[C#]
public override void Draw(
CommandBar parent,
Graphics g,
DrawItemState state,
Rectangle rect
);

Parameters

parent
g
state
rect

See Also

CommandBarLabelItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarLabelItem.DrawMenu Method

See CommandBarItem

[Visual Basic]
Overrides Public Sub DrawMenu( _
ByVal parent As CommandContextMenu, _
ByVal g As Graphics, _
ByVal state As DrawItemState, _
ByVal rect As Rectangle _
)
[C#]
public override void DrawMenu(
CommandContextMenu parent,
Graphics g,
DrawItemState state,
Rectangle rect
);

Parameters

parent
g
state
rect

See Also

CommandBarLabelItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarLabelItem.Initialize Method

Resets to default options.

[Visual Basic]
Overrides Public Sub Initialize()
[C#]
public override void Initialize();

See Also

CommandBarLabelItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarLabelItem.OnBoundsChanged Method

See CommandBarItem

[Visual Basic]
Overrides Public Sub OnBoundsChanged()
[C#]
public override void OnBoundsChanged();

See Also

CommandBarLabelItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarLabelItem.OnContainerChanged Method

See CommandBarItem

[Visual Basic]
Overrides Public Sub OnContainerChanged()
[C#]
public override void OnContainerChanged();

See Also

CommandBarLabelItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarLabelItem.ProcessMouseDown Method

See CommandBarItem

[Visual Basic]
Overrides Public Sub ProcessMouseDown( _
ByVal parent As CommandBar, _
ByVal e As MouseEventArgs _
)
[C#]
public override void ProcessMouseDown(
CommandBar parent,
MouseEventArgs e
);

Parameters

parent
e

See Also

CommandBarLabelItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarLabelItem.ProcessMouseMove Method

See CommandBarItem

[Visual Basic]
Overrides Public Sub ProcessMouseMove( _
ByVal parent As CommandBar, _
ByVal e As MouseEventArgs _
)
[C#]
public override void ProcessMouseMove(
CommandBar parent,
MouseEventArgs e
);

Parameters

parent
e

See Also

CommandBarLabelItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarLabelItem.ProcessMouseUp Method

See CommandBarItem

[Visual Basic]
Overrides Public Sub ProcessMouseUp( _
ByVal parent As CommandBar, _
ByVal e As MouseEventArgs _
)
[C#]
public override void ProcessMouseUp(
CommandBar parent,
MouseEventArgs e
);

Parameters

parent
e

See Also

CommandBarLabelItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarManager Class

This component manages the command bars on your form. This includes saving and loading layouts, providing tear-off functionality, and allowing the bars to dock to any side of the form.

For a list of all members of this type, see CommandBarManager Members.

System.Object
MarshalByRefObject
Component
CommandBarManager

[Visual Basic]
NotInheritable Public Class CommandBarManager
Inherits Component
[C#]
public sealed class CommandBarManager : Component

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

This is the component you should add to your form in order to obtain command bar functionality. You may also add a single command bar, but it will be locked.

Requirements

Namespace: NETXP.Controls.Bars

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

CommandBarManager Members | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarManager Members

CommandBarManager overview

Public Instance Constructors

CommandBarManager Constructor Creates a new command bar manager.

Public Instance Properties

AutomaticStatePersistence | Enable or disable the Automatic State Persistence feature. If enabled the customized layout made by the user is persisted into isolated storage.
BottomDock | Gets or sets the bottom command bar dock on this form.
Container (inherited from Component) | Gets the IContainer that contains the Component.
Form | Gets or sets the form associated with this command bar manager. This must not be null.
LeftDock | Gets or sets the left-side command bar dock on this form.
Renderer | Gets or sets the renderer used to draw the command bars.
RightDock | Gets or sets the right-side command bar dock on this form.
Site | Internal. For designer support.
TopDock | Gets or sets the top command bar dock on this form.

Public Instance Methods

AttachCommandBar | Use this method to explicitly add a command bar to the manager without necessarily adding it to a dock.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DetachCommandBar | Use this method to explicitly remove a command bar from the manager without necessarily removing it from a dock.
Dispose (inherited from Component) | Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCommandBar | Gets a command bar with the given ID.
GetCommandBars | Returns the collection of command bars managed by the command bar manager.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
LoadLayout | Overloaded. Loads the current layout from a stream. Can be read as binary or as XML.
ResetAutoPersistent | Reset Automatic State Persistence
SaveLayout | Overloaded. Saves the current layout to a stream. Can be written as binary or as XML.
ToString (inherited from Component) |

Public Instance Events

Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
LoadedLayout | Occurs when auto-persisted layout has been loaded.
LoadingLayout | Occurs when auto-persisted layout is being loaded.
SavedLayout | Occurs when auto-persisted layout has been saved.
SavingLayout | Occurs when auto-persisted layout is being saved.

See Also

CommandBarManager Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarManager Constructor

Creates a new command bar manager.

[Visual Basic]
Public Sub New()
[C#]
public CommandBarManager();

See Also

CommandBarManager Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarManager Properties

The properties of the CommandBarManager class are listed below. For a complete list of CommandBarManager class members, see the CommandBarManager Members topic.

Public Instance Properties

AutomaticStatePersistence | Enable or disable the Automatic State Persistence feature. If enabled the customized layout made by the user is persisted into isolated storage.
BottomDock | Gets or sets the bottom command bar dock on this form.
Container (inherited from Component) | Gets the IContainer that contains the Component.
Form | Gets or sets the form associated with this command bar manager. This must not be null.
LeftDock | Gets or sets the left-side command bar dock on this form.
Renderer | Gets or sets the renderer used to draw the command bars.
RightDock | Gets or sets the right-side command bar dock on this form.
Site | Internal. For designer support.
TopDock | Gets or sets the top command bar dock on this form.

See Also

CommandBarManager Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarManager.AutomaticStatePersistence Property

Enable or disable the Automatic State Persistence feature. If enabled the customized layout made by the user is persisted into isolated storage.

[Visual Basic]
Public Property AutomaticStatePersistence As Boolean
[C#]
public bool AutomaticStatePersistence {get; set;}

See Also

CommandBarManager Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarManager.BottomDock Property

Gets or sets the bottom command bar dock on this form.

[Visual Basic]
Public Property BottomDock As CommandBarDock
[C#]
public CommandBarDock BottomDock {get; set;}

See Also

CommandBarManager Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarManager.Form Property

Gets or sets the form associated with this command bar manager. This must not be null.

[Visual Basic]
Public Property Form As Form
[C#]
public System.Windows.Forms.Form Form {get; set;}

See Also

CommandBarManager Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarManager.LeftDock Property

Gets or sets the left-side command bar dock on this form.

[Visual Basic]
Public Property LeftDock As CommandBarDock
[C#]
public CommandBarDock LeftDock {get; set;}

See Also

CommandBarManager Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarManager.Renderer Property

Gets or sets the renderer used to draw the command bars.

[Visual Basic]
Public Property Renderer As ICommandBarRenderer
[C#]
public ICommandBarRenderer Renderer {get; set;}

See Also

CommandBarManager Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarManager.RightDock Property

Gets or sets the right-side command bar dock on this form.

[Visual Basic]
Public Property RightDock As CommandBarDock
[C#]
public CommandBarDock RightDock {get; set;}

See Also

CommandBarManager Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarManager.Site Property

Internal. For designer support.

[Visual Basic]
Overrides Public Property Site As ISite Implements _
IComponent.Site
[C#]
public override System.ComponentModel.ISite Site {get; set;}

Implements

IComponent.Site

See Also

CommandBarManager Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarManager.TopDock Property

Gets or sets the top command bar dock on this form.

[Visual Basic]
Public Property TopDock As CommandBarDock
[C#]
public CommandBarDock TopDock {get; set;}

See Also

CommandBarManager Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarManager Methods

The methods of the CommandBarManager class are listed below. For a complete list of CommandBarManager class members, see the CommandBarManager Members topic.

Public Instance Methods

AttachCommandBar | Use this method to explicitly add a command bar to the manager without necessarily adding it to a dock.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DetachCommandBar | Use this method to explicitly remove a command bar from the manager without necessarily removing it from a dock.
Dispose (inherited from Component) | Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCommandBar | Gets a command bar with the given ID.
GetCommandBars | Returns the collection of command bars managed by the command bar manager.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
LoadLayout | Overloaded. Loads the current layout from a stream. Can be read as binary or as XML.
ResetAutoPersistent | Reset Automatic State Persistence
SaveLayout | Overloaded. Saves the current layout to a stream. Can be written as binary or as XML.
ToString (inherited from Component) |

See Also

CommandBarManager Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarManager.AttachCommandBar Method

Use this method to explicitly add a command bar to the manager without necessarily adding it to a dock.

[Visual Basic]
Public Sub AttachCommandBar( _
ByVal bar As CommandBar _
)
[C#]
public void AttachCommandBar(
CommandBar bar
);

Parameters

bar
The command bar to add.

See Also

CommandBarManager Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarManager.DetachCommandBar Method

Use this method to explicitly remove a command bar from the manager without necessarily removing it from a dock.

[Visual Basic]
Public Sub DetachCommandBar( _
ByVal bar As CommandBar _
)
[C#]
public void DetachCommandBar(
CommandBar bar
);

Parameters

bar
The command bar to remove.

See Also

CommandBarManager Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarManager.GetCommandBar Method

Gets a command bar with the given ID.

[Visual Basic]
Public Function GetCommandBar( _
ByVal id As Integer _
) As CommandBar
[C#]
public CommandBar GetCommandBar(
int id
);

Parameters

id
The ID of the command bar.

Return Value

The command bar, if any. Null if no command bar is found.

See Also

CommandBarManager Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarManager.GetCommandBars Method

Returns the collection of command bars managed by the command bar manager.

[Visual Basic]
Public Function GetCommandBars() As ArrayList
[C#]
public ArrayList GetCommandBars();

Return Value

The collection.

See Also

CommandBarManager Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


LoadLayout Method

NetXP 3.0 Reference

CommandBarManager.LoadLayout Method

Loads the layout from a registry key.

Overload List

Loads the layout from a registry key.

public void LoadLayout(RegistryKey);

Loads the layout from a binary stream.

public void LoadLayout(BinaryReader);

Loads the current layout from a stream. Can be read as binary or as XML.

public void LoadLayout(Stream,bool);

Loads the layout from an XML stream.

public void LoadLayout(XmlReader);

See Also

CommandBarManager Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarManager.LoadLayout Method (RegistryKey)

Loads the layout from a registry key.

[Visual Basic]
Overloads Public Sub LoadLayout( _
ByVal key As RegistryKey _
)
[C#]
public void LoadLayout(
RegistryKey key
);

Parameters

key
The root key.

Remarks

Each command bar's layout is loaded from a different subkey, whose name is based on the command bar's ID.

See Also

CommandBarManager Class | NETXP.Controls.Bars Namespace | CommandBarManager.LoadLayout Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarManager.LoadLayout Method (BinaryReader)

Loads the layout from a binary stream.

[Visual Basic]
Overloads Public Sub LoadLayout( _
ByVal inStream As BinaryReader _
)
[C#]
public void LoadLayout(
BinaryReader inStream
);

Parameters

inStream
The stream.

See Also

CommandBarManager Class | NETXP.Controls.Bars Namespace | CommandBarManager.LoadLayout Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarManager.LoadLayout Method (Stream, Boolean)

Loads the current layout from a stream. Can be read as binary or as XML.

[Visual Basic]
Overloads Public Sub LoadLayout( _
ByVal file As Stream, _
ByVal binary As Boolean _
)
[C#]
public void LoadLayout(
Stream file,
bool binary
);

Parameters

file
The stream. Not necessarily a file.
binary
Is this a binary stream? If not, read as XML.

See Also

CommandBarManager Class | NETXP.Controls.Bars Namespace | CommandBarManager.LoadLayout Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarManager.LoadLayout Method (XmlReader)

Loads the layout from an XML stream.

[Visual Basic]
Overloads Public Sub LoadLayout( _
ByVal inStream As XmlReader _
)
[C#]
public void LoadLayout(
XmlReader inStream
);

Parameters

inStream
The XML stream.

See Also

CommandBarManager Class | NETXP.Controls.Bars Namespace | CommandBarManager.LoadLayout Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarManager.ResetAutoPersistent Method

Reset Automatic State Persistence

[Visual Basic]
Public Sub ResetAutoPersistent( _
ByVal currentWorkingArea As Boolean _
)
[C#]
public void ResetAutoPersistent(
bool currentWorkingArea
);

See Also

CommandBarManager Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


SaveLayout Method

NetXP 3.0 Reference

CommandBarManager.SaveLayout Method

Saves the layout to a registry key.

Overload List

Saves the layout to a registry key.

public void SaveLayout(RegistryKey);

Saves the layout to a binary stream.

public void SaveLayout(BinaryWriter);

Saves the current layout to a stream. Can be written as binary or as XML.

public void SaveLayout(Stream,bool);

Saves the layout to an XML stream.

public void SaveLayout(XmlWriter);

See Also

CommandBarManager Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarManager.SaveLayout Method (RegistryKey)

Saves the layout to a registry key.

[Visual Basic]
Overloads Public Sub SaveLayout( _
ByVal key As RegistryKey _
)
[C#]
public void SaveLayout(
RegistryKey key
);

Parameters

key
The root key.

Remarks

Each command bar's layout is saved under a different subkey, whose name is based on the command bar's ID.

See Also

CommandBarManager Class | NETXP.Controls.Bars Namespace | CommandBarManager.SaveLayout Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarManager.SaveLayout Method (BinaryWriter)

Saves the layout to a binary stream.

[Visual Basic]
Overloads Public Sub SaveLayout( _
ByVal outStream As BinaryWriter _
)
[C#]
public void SaveLayout(
BinaryWriter outStream
);

Parameters

outStream
The stream.

See Also

CommandBarManager Class | NETXP.Controls.Bars Namespace | CommandBarManager.SaveLayout Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarManager.SaveLayout Method (Stream, Boolean)

Saves the current layout to a stream. Can be written as binary or as XML.

[Visual Basic]
Overloads Public Sub SaveLayout( _
ByVal file As Stream, _
ByVal binary As Boolean _
)
[C#]
public void SaveLayout(
Stream file,
bool binary
);

Parameters

file
The stream. Not necessarily a file.
binary
Is this a binary stream? If not, write as XML.

See Also

CommandBarManager Class | NETXP.Controls.Bars Namespace | CommandBarManager.SaveLayout Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarManager.SaveLayout Method (XmlWriter)

Saves the layout to an XML stream.

[Visual Basic]
Overloads Public Sub SaveLayout( _
ByVal outStream As XmlWriter _
)
[C#]
public void SaveLayout(
XmlWriter outStream
);

Parameters

outStream
The XML stream.

See Also

CommandBarManager Class | NETXP.Controls.Bars Namespace | CommandBarManager.SaveLayout Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarManager Events

The events of the CommandBarManager class are listed below. For a complete list of CommandBarManager class members, see the CommandBarManager Members topic.

Public Instance Events

Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
LoadedLayout | Occurs when auto-persisted layout has been loaded.
LoadingLayout | Occurs when auto-persisted layout is being loaded.
SavedLayout | Occurs when auto-persisted layout has been saved.
SavingLayout | Occurs when auto-persisted layout is being saved.

See Also

CommandBarManager Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarManager.LoadedLayout Event

Occurs when auto-persisted layout has been loaded.

[Visual Basic]
Public Event LoadedLayout As EventHandler
[C#]
public event EventHandler LoadedLayout;

See Also

CommandBarManager Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarManager.LoadingLayout Event

Occurs when auto-persisted layout is being loaded.

[Visual Basic]
Public Event LoadingLayout As EventHandler
[C#]
public event EventHandler LoadingLayout;

See Also

CommandBarManager Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarManager.SavedLayout Event

Occurs when auto-persisted layout has been saved.

[Visual Basic]
Public Event SavedLayout As EventHandler
[C#]
public event EventHandler SavedLayout;

See Also

CommandBarManager Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarManager.SavingLayout Event

Occurs when auto-persisted layout is being saved.

[Visual Basic]
Public Event SavingLayout As EventHandler
[C#]
public event EventHandler SavingLayout;

See Also

CommandBarManager Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarSeparatorItem Class

A separator item.

For a list of all members of this type, see CommandBarSeparatorItem Members.

System.Object
MarshalByRefObject
Component
CommandBarItem
CommandBarSeparatorItem

[Visual Basic]
Public Class CommandBarSeparatorItem
Inherits CommandBarItem
[C#]
public class CommandBarSeparatorItem : CommandBarItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Bars

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

CommandBarSeparatorItem Members | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarSeparatorItem Members

CommandBarSeparatorItem overview

Public Instance Constructors

CommandBarSeparatorItem Constructor Constructs a new separator item.

Public Instance Properties

Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerControl (inherited from CommandBarItem) | The item's container control.
Enabled | See CommandBarItem
Infrequent (inherited from CommandBarItem) | Is this item infrequent?
MenuSelectable | See CommandBarItem
PadHorizontal | See CommandBarItem
PadVertical | See CommandBarItem
Site (inherited from Component) | Gets or sets the ISite of the Component.
Tag (inherited from CommandBarItem) | An object associated with this item.
Text | See CommandBarItem
Visible (inherited from CommandBarItem) | Is this item visible?

Public Instance Methods

CalculateSize | See CommandBarItem
CalculateSizeMenu | See CommandBarItem
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
Draw | See CommandBarItem
DrawMenu | See CommandBarItem
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize | Resets the item to default options.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
OnBoundsChanged | See CommandBarItem
OnContainerChanged | See CommandBarItem
ProcessMouseDown | See CommandBarItem
ProcessMouseMove | See CommandBarItem
ProcessMouseUp | See CommandBarItem
ResumeEvents (inherited from CommandBarItem) | Resumes events.
SuspendEvents (inherited from CommandBarItem) | Suspends events.
ToString (inherited from CommandBarItem) | Gives a string representation of this item.

Public Instance Events

Changed (inherited from CommandBarItem) | Called when the item's properties are changed.
Click (inherited from CommandBarItem) | Called when the item is clicked.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
Hover (inherited from CommandBarItem) | Called when the mouse moves over the item.
Leave (inherited from CommandBarItem) | Called when the mouse has left the item.

See Also

CommandBarSeparatorItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarSeparatorItem Constructor

Constructs a new separator item.

[Visual Basic]
Public Sub New()
[C#]
public CommandBarSeparatorItem();

See Also

CommandBarSeparatorItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarSeparatorItem Properties

The properties of the CommandBarSeparatorItem class are listed below. For a complete list of CommandBarSeparatorItem class members, see the CommandBarSeparatorItem Members topic.

Public Instance Properties

Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerControl (inherited from CommandBarItem) | The item's container control.
Enabled | See CommandBarItem
Infrequent (inherited from CommandBarItem) | Is this item infrequent?
MenuSelectable | See CommandBarItem
PadHorizontal | See CommandBarItem
PadVertical | See CommandBarItem
Site (inherited from Component) | Gets or sets the ISite of the Component.
Tag (inherited from CommandBarItem) | An object associated with this item.
Text | See CommandBarItem
Visible (inherited from CommandBarItem) | Is this item visible?

See Also

CommandBarSeparatorItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarSeparatorItem.Enabled Property

See CommandBarItem

[Visual Basic]
Overrides Public Property Enabled As Boolean
[C#]
public override bool Enabled {get; set;}

See Also

CommandBarSeparatorItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarSeparatorItem.MenuSelectable Property

See CommandBarItem

[Visual Basic]
Overrides Public ReadOnly Property MenuSelectable As Boolean
[C#]
public override bool MenuSelectable {get;}

See Also

CommandBarSeparatorItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarSeparatorItem.PadHorizontal Property

See CommandBarItem

[Visual Basic]
Overrides Public ReadOnly Property PadHorizontal As Integer
[C#]
public override int PadHorizontal {get;}

See Also

CommandBarSeparatorItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarSeparatorItem.PadVertical Property

See CommandBarItem

[Visual Basic]
Overrides Public ReadOnly Property PadVertical As Integer
[C#]
public override int PadVertical {get;}

See Also

CommandBarSeparatorItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarSeparatorItem.Text Property

See CommandBarItem

[Visual Basic]
Overrides Public Property Text As String
[C#]
public override string Text {get; set;}

See Also

CommandBarSeparatorItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarSeparatorItem Methods

The methods of the CommandBarSeparatorItem class are listed below. For a complete list of CommandBarSeparatorItem class members, see the CommandBarSeparatorItem Members topic.

Public Instance Methods

CalculateSize | See CommandBarItem
CalculateSizeMenu | See CommandBarItem
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
Draw | See CommandBarItem
DrawMenu | See CommandBarItem
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize | Resets the item to default options.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
OnBoundsChanged | See CommandBarItem
OnContainerChanged | See CommandBarItem
ProcessMouseDown | See CommandBarItem
ProcessMouseMove | See CommandBarItem
ProcessMouseUp | See CommandBarItem
ResumeEvents (inherited from CommandBarItem) | Resumes events.
SuspendEvents (inherited from CommandBarItem) | Suspends events.
ToString (inherited from CommandBarItem) | Gives a string representation of this item.

See Also

CommandBarSeparatorItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarSeparatorItem.CalculateSize Method

See CommandBarItem

[Visual Basic]
Overrides Public Function CalculateSize( _
ByVal parent As CommandBar, _
ByVal g As Graphics _
) As Size
[C#]
public override Size CalculateSize(
CommandBar parent,
Graphics g
);

Parameters

parent
g

Return Value

See Also

CommandBarSeparatorItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarSeparatorItem.CalculateSizeMenu Method

See CommandBarItem

[Visual Basic]
Overrides Public Function CalculateSizeMenu( _
ByVal parent As CommandContextMenu, _
ByVal g As Graphics _
) As Size
[C#]
public override Size CalculateSizeMenu(
CommandContextMenu parent,
Graphics g
);

Parameters

parent
g

Return Value

See Also

CommandBarSeparatorItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarSeparatorItem.Draw Method

See CommandBarItem

[Visual Basic]
Overrides Public Sub Draw( _
ByVal parent As CommandBar, _
ByVal g As Graphics, _
ByVal state As DrawItemState, _
ByVal rect As Rectangle _
)
[C#]
public override void Draw(
CommandBar parent,
Graphics g,
DrawItemState state,
Rectangle rect
);

Parameters

parent
g
state
rect

See Also

CommandBarSeparatorItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarSeparatorItem.DrawMenu Method

See CommandBarItem

[Visual Basic]
Overrides Public Sub DrawMenu( _
ByVal parent As CommandContextMenu, _
ByVal g As Graphics, _
ByVal state As DrawItemState, _
ByVal rect As Rectangle _
)
[C#]
public override void DrawMenu(
CommandContextMenu parent,
Graphics g,
DrawItemState state,
Rectangle rect
);

Parameters

parent
g
state
rect

See Also

CommandBarSeparatorItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarSeparatorItem.Initialize Method

Resets the item to default options.

[Visual Basic]
Overrides Public Sub Initialize()
[C#]
public override void Initialize();

See Also

CommandBarSeparatorItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarSeparatorItem.OnBoundsChanged Method

See CommandBarItem

[Visual Basic]
Overrides Public Sub OnBoundsChanged()
[C#]
public override void OnBoundsChanged();

See Also

CommandBarSeparatorItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarSeparatorItem.OnContainerChanged Method

See CommandBarItem

[Visual Basic]
Overrides Public Sub OnContainerChanged()
[C#]
public override void OnContainerChanged();

See Also

CommandBarSeparatorItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarSeparatorItem.ProcessMouseDown Method

See CommandBarItem

[Visual Basic]
Overrides Public Sub ProcessMouseDown( _
ByVal parent As CommandBar, _
ByVal e As MouseEventArgs _
)
[C#]
public override void ProcessMouseDown(
CommandBar parent,
MouseEventArgs e
);

Parameters

parent
e

See Also

CommandBarSeparatorItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarSeparatorItem.ProcessMouseMove Method

See CommandBarItem

[Visual Basic]
Overrides Public Sub ProcessMouseMove( _
ByVal parent As CommandBar, _
ByVal e As MouseEventArgs _
)
[C#]
public override void ProcessMouseMove(
CommandBar parent,
MouseEventArgs e
);

Parameters

parent
e

See Also

CommandBarSeparatorItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarSeparatorItem.ProcessMouseUp Method

See CommandBarItem

[Visual Basic]
Overrides Public Sub ProcessMouseUp( _
ByVal parent As CommandBar, _
ByVal e As MouseEventArgs _
)
[C#]
public override void ProcessMouseUp(
CommandBar parent,
MouseEventArgs e
);

Parameters

parent
e

See Also

CommandBarSeparatorItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarState Enumeration

Command bar states.

[Visual Basic]
Public Enum CommandBarState
[C#]
public enum CommandBarState

Members

Member Name | Description
None | Internal.
Hot | Internal.
HotTracking | Internal.

Requirements

Namespace: NETXP.Controls.Bars

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandBarStyle Enumeration

Command bar display style.

[Visual Basic]
Public Enum CommandBarStyle
[C#]
public enum CommandBarStyle

Members

Member Name | Description
Menu | Shows the command bar as a menu. (No button images and asynchronous drop-down menus)
ToolBar | Shows the command bar as a toolbar.

Requirements

Namespace: NETXP.Controls.Bars

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandContextMenu Class

A context menu with fully customizable look and feel.

For a list of all members of this type, see CommandContextMenu Members.

System.Object
MarshalByRefObject
NativeWindow
CommandContextMenu

[Visual Basic]
NotInheritable Public Class CommandContextMenu
Inherits NativeWindow
Implements System.ComponentModel.IComponent, System.IDisposable
[C#]
public sealed class CommandContextMenu : NativeWindow, IComponent, IDisposable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

This menu should not be used with system tray icons.

Requirements

Namespace: NETXP.Controls.Bars

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

CommandContextMenu Members | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandContextMenu Members

CommandContextMenu overview

Public Instance Constructors

CommandContextMenu Constructor Constructs a new CommandContextMenu.

Public Instance Properties

Animate | Specifies whether or not to animate the menu when shown.
EatFinalClick | Should the final click message (WM_LBUTTONDOWN) be eaten? Set this to True for left-button handled context menus.
Handle | Gets the handle of this menu window.
IsPersonalized | Indicates whether or not the menu has infrequent items.
Items | A collection of CommandBarItem objects that defines the items in the menu.
Parent | The parent context menu of this menu (if this is a submenu).
Renderer | The renderer that defines the look and feel of the menu.
ReturnCommand | Gets the item that was clicked by the user when the menu was closed.
SelectedMenuItem | The initially selected menu item, set before the menu is shown.
ShowInfrequent | Specifies whether or not to show the personalized menu initially expanded.
Site | The container of this component.
SourceControl | The control responsible for handling messages.
SuppressClickEvents | Specifies whether or not to raise the Click event for the selected menu item. If you set this to True, no Click events will be generated for menu items.

Public Instance Methods

AssignHandle (inherited from NativeWindow) | Assigns a handle to this window.
CalculateWindowSize | Calculates the menu window's size.
CreateHandle (inherited from NativeWindow) | Creates a window and its handle with the specified creation parameters.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DefWndProc (inherited from NativeWindow) | Invokes the default window procedure associated with this window. It is an error to call this method when the Handle property is 0.
DestroyHandle (inherited from NativeWindow) | Destroys the window and its handle.
Dismiss | Dismisses (closes) the menu.
Dispose | Called when the menu must be disposed. NEVER call this function manually if you've set the command bar item collection such that it's no longer owned by this menu.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetItemRect | Gets the rectangle (bounds) of an item.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
ReleaseHandle (inherited from NativeWindow) | Releases the handle associated with this window.
Show | Overloaded. Shows the popup menu at the specified location. No source control is provided.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdatePosition | Requests a repositioning of the menu.

Public Instance Events

Disposed | Occurs when the object has been disposed.
Expanded | Raised when a collapsed personalized menu is expanded.
MenuQuit | Raised when the menu has been dismissed.
Shown | Raised after the menu has been shown.

See Also

CommandContextMenu Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandContextMenu Constructor

Constructs a new CommandContextMenu.

[Visual Basic]
Public Sub New()
[C#]
public CommandContextMenu();

See Also

CommandContextMenu Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandContextMenu Properties

The properties of the CommandContextMenu class are listed below. For a complete list of CommandContextMenu class members, see the CommandContextMenu Members topic.

Public Instance Properties

Animate | Specifies whether or not to animate the menu when shown.
EatFinalClick | Should the final click message (WM_LBUTTONDOWN) be eaten? Set this to True for left-button handled context menus.
Handle | Gets the handle of this menu window.
IsPersonalized | Indicates whether or not the menu has infrequent items.
Items | A collection of CommandBarItem objects that defines the items in the menu.
Parent | The parent context menu of this menu (if this is a submenu).
Renderer | The renderer that defines the look and feel of the menu.
ReturnCommand | Gets the item that was clicked by the user when the menu was closed.
SelectedMenuItem | The initially selected menu item, set before the menu is shown.
ShowInfrequent | Specifies whether or not to show the personalized menu initially expanded.
Site | The container of this component.
SourceControl | The control responsible for handling messages.
SuppressClickEvents | Specifies whether or not to raise the Click event for the selected menu item. If you set this to True, no Click events will be generated for menu items.

See Also

CommandContextMenu Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandContextMenu.Animate Property

Specifies whether or not to animate the menu when shown.

[Visual Basic]
Public Property Animate As Boolean
[C#]
public bool Animate {get; set;}

See Also

CommandContextMenu Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandContextMenu.EatFinalClick Property

Should the final click message (WM_LBUTTONDOWN) be eaten? Set this to True for left-button handled context menus.

[Visual Basic]
Public Property EatFinalClick As Boolean
[C#]
public bool EatFinalClick {get; set;}

See Also

CommandContextMenu Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandContextMenu.Handle Property

Gets the handle of this menu window.

[Visual Basic]
Public ReadOnly Property Handle As IntPtr
[C#]
new public System.IntPtr Handle {get;}

See Also

CommandContextMenu Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandContextMenu.IsPersonalized Property

Indicates whether or not the menu has infrequent items.

[Visual Basic]
Public ReadOnly Property IsPersonalized As Boolean
[C#]
public bool IsPersonalized {get;}

See Also

CommandContextMenu Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandContextMenu.Items Property

A collection of CommandBarItem objects that defines the items in the menu.

[Visual Basic]
Public Property Items As CommandBarItemCollection
[C#]
public CommandBarItemCollection Items {get; set;}

See Also

CommandContextMenu Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandContextMenu.Parent Property

The parent context menu of this menu (if this is a submenu).

[Visual Basic]
Public ReadOnly Property Parent As CommandContextMenu
[C#]
public CommandContextMenu Parent {get;}

See Also

CommandContextMenu Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandContextMenu.Renderer Property

The renderer that defines the look and feel of the menu.

[Visual Basic]
Public Property Renderer As ICommandBarRenderer
[C#]
public ICommandBarRenderer Renderer {get; set;}

See Also

CommandContextMenu Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandContextMenu.ReturnCommand Property

Gets the item that was clicked by the user when the menu was closed.

[Visual Basic]
Public ReadOnly Property ReturnCommand As CommandBarItem
[C#]
public CommandBarItem ReturnCommand {get;}

See Also

CommandContextMenu Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandContextMenu.SelectedMenuItem Property

The initially selected menu item, set before the menu is shown.

[Visual Basic]
Public Property SelectedMenuItem As CommandBarItem
[C#]
public CommandBarItem SelectedMenuItem {get; set;}

See Also

CommandContextMenu Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandContextMenu.ShowInfrequent Property

Specifies whether or not to show the personalized menu initially expanded.

[Visual Basic]
Public Property ShowInfrequent As Boolean
[C#]
public bool ShowInfrequent {get; set;}

See Also

CommandContextMenu Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandContextMenu.Site Property

The container of this component.

[Visual Basic]
NotOverridable Public Property Site As ISite Implements _
IComponent.Site
[C#]
public System.ComponentModel.ISite Site {get; set;}

Implements

IComponent.Site

See Also

CommandContextMenu Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandContextMenu.SourceControl Property

The control responsible for handling messages.

[Visual Basic]
Public ReadOnly Property SourceControl As Control
[C#]
public System.Windows.Forms.Control SourceControl {get;}

See Also

CommandContextMenu Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandContextMenu.SuppressClickEvents Property

Specifies whether or not to raise the Click event for the selected menu item. If you set this to True, no Click events will be generated for menu items.

[Visual Basic]
Public Property SuppressClickEvents As Boolean
[C#]
public bool SuppressClickEvents {get; set;}

See Also

CommandContextMenu Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandContextMenu Methods

The methods of the CommandContextMenu class are listed below. For a complete list of CommandContextMenu class members, see the CommandContextMenu Members topic.

Public Instance Methods

AssignHandle (inherited from NativeWindow) | Assigns a handle to this window.
CalculateWindowSize | Calculates the menu window's size.
CreateHandle (inherited from NativeWindow) | Creates a window and its handle with the specified creation parameters.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DefWndProc (inherited from NativeWindow) | Invokes the default window procedure associated with this window. It is an error to call this method when the Handle property is 0.
DestroyHandle (inherited from NativeWindow) | Destroys the window and its handle.
Dismiss | Dismisses (closes) the menu.
Dispose | Called when the menu must be disposed. NEVER call this function manually if you've set the command bar item collection such that it's no longer owned by this menu.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetItemRect | Gets the rectangle (bounds) of an item.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
ReleaseHandle (inherited from NativeWindow) | Releases the handle associated with this window.
Show | Overloaded. Shows the popup menu at the specified location. No source control is provided.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdatePosition | Requests a repositioning of the menu.

See Also

CommandContextMenu Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandContextMenu.CalculateWindowSize Method

Calculates the menu window's size.

[Visual Basic]
Public Function CalculateWindowSize() As Size
[C#]
public Size CalculateWindowSize();

Return Value

The menu window's size.

See Also

CommandContextMenu Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandContextMenu.Dismiss Method

Dismisses (closes) the menu.

[Visual Basic]
Public Sub Dismiss()
[C#]
public void Dismiss();

See Also

CommandContextMenu Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandContextMenu.Dispose Method

Called when the menu must be disposed. NEVER call this function manually if you've set the command bar item collection such that it's no longer owned by this menu.

[Visual Basic]
NotOverridable Public Sub Dispose() Implements _
IDisposable.Dispose
[C#]
public void Dispose();

Implements

IDisposable.Dispose

See Also

CommandContextMenu Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandContextMenu.GetItemRect Method

Gets the rectangle (bounds) of an item.

[Visual Basic]
Public Function GetItemRect( _
ByVal item As CommandBarItem _
) As Rectangle
[C#]
public Rectangle GetItemRect(
CommandBarItem item
);

Parameters

item
The item (must be visible).

Return Value

The bounds rectangle of the item.

See Also

CommandContextMenu Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Show Method

NetXP 3.0 Reference

CommandContextMenu.Show Method

Shows the popup menu at the specified location. No source control is provided.

Overload List

Shows the popup menu at the specified location. No source control is provided.

public CommandBarItem Show(Point);

Shows the popup menu with four preferred locations.

public CommandBarItem Show(Point,Point,Point,Point);

Shows the popup menu at the specified location, using the specified source control.

public CommandBarItem Show(Control,Point);

Shows the popup menu with four preferred locations for the specified source control.

public CommandBarItem Show(Control,Point,Point,Point,Point);

See Also

CommandContextMenu Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandContextMenu.Show Method (Point)

Shows the popup menu at the specified location. No source control is provided.

[Visual Basic]
Overloads Public Function Show( _
ByVal pt As Point _
) As CommandBarItem
[C#]
public CommandBarItem Show(
Point pt
);

Parameters

pt
Location (in screen coordinates) of the top-left corner of the menu.

Return Value

The command bar item (if any) that the user clicked.

See Also

CommandContextMenu Class | NETXP.Controls.Bars Namespace | CommandContextMenu.Show Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandContextMenu.Show Method (Point, Point, Point, Point)

Shows the popup menu with four preferred locations.

[Visual Basic]
Overloads Public Function Show( _
ByVal topLeft As Point, _
ByVal topRight As Point, _
ByVal bottomLeft As Point, _
ByVal bottomRight As Point _
) As CommandBarItem
[C#]
public CommandBarItem Show(
Point topLeft,
Point topRight,
Point bottomLeft,
Point bottomRight
);

Parameters

topLeft
The preferred top-left location, in screen coordinates.
topRight
The preferred top-right location, in screen coordinates.
bottomLeft
The preferred bottom-left location, in screen coordinates.
bottomRight
The perferred bottom-right location, in screen coordinates.

Return Value

See Also

CommandContextMenu Class | NETXP.Controls.Bars Namespace | CommandContextMenu.Show Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandContextMenu.Show Method (Control, Point)

Shows the popup menu at the specified location, using the specified source control.

[Visual Basic]
Overloads Public Function Show( _
ByVal sourceControl As Control, _
ByVal pt As Point _
) As CommandBarItem
[C#]
public CommandBarItem Show(
Control sourceControl,
Point pt
);

Parameters

sourceControl
The control responsible for handling menu messages.
pt
The location (in sourceControl client coordinates) of the top-left corner of the menu.

Return Value

The command bar item (if any) that the user clicked.

See Also

CommandContextMenu Class | NETXP.Controls.Bars Namespace | CommandContextMenu.Show Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandContextMenu.Show Method (Control, Point, Point, Point, Point)

Shows the popup menu with four preferred locations for the specified source control.

[Visual Basic]
Overloads Public Function Show( _
ByVal sourceControl As Control, _
ByVal topLeft As Point, _
ByVal topRight As Point, _
ByVal bottomLeft As Point, _
ByVal bottomRight As Point _
) As CommandBarItem
[C#]
public CommandBarItem Show(
Control sourceControl,
Point topLeft,
Point topRight,
Point bottomLeft,
Point bottomRight
);

Parameters

sourceControl
The control responsible for handling menu messages.
topLeft
The preferred top-left location, in sourceControl client coordinates.
topRight
The preferred top-right location, in sourceControl client coordinates.
bottomLeft
The preferred bottom-left location, in sourceControl client coordinates.
bottomRight
The perferred bottom-right location, in sourceControl client coordinates.

Return Value

See Also

CommandContextMenu Class | NETXP.Controls.Bars Namespace | CommandContextMenu.Show Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandContextMenu.UpdatePosition Method

Requests a repositioning of the menu.

[Visual Basic]
Public Sub UpdatePosition( _
ByVal newPos As Point _
)
[C#]
public void UpdatePosition(
Point newPos
);

Parameters

newPos
New position of the menu.

See Also

CommandContextMenu Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandContextMenu Events

The events of the CommandContextMenu class are listed below. For a complete list of CommandContextMenu class members, see the CommandContextMenu Members topic.

Public Instance Events

Disposed | Occurs when the object has been disposed.
Expanded | Raised when a collapsed personalized menu is expanded.
MenuQuit | Raised when the menu has been dismissed.
Shown | Raised after the menu has been shown.

See Also

CommandContextMenu Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandContextMenu.Disposed Event

Occurs when the object has been disposed.

[Visual Basic]
Public Event Disposed As EventHandler
[C#]
public event EventHandler Disposed;

Implements

IComponent.Disposed

See Also

CommandContextMenu Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandContextMenu.Expanded Event

Raised when a collapsed personalized menu is expanded.

[Visual Basic]
Public Event Expanded As ExpandedEventHandler
[C#]
public event ExpandedEventHandler Expanded;

Event Data

The event handler receives an argument of type ExpandedEventArgs containing data related to this event. The following ExpandedEventArgs property provides information specific to this event.

Property | Description
DoNotUpdate | Instructs the menu NOT to update its position and size as a result of the expansion.

See Also

CommandContextMenu Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandContextMenu.MenuQuit Event

Raised when the menu has been dismissed.

[Visual Basic]
Public Event MenuQuit As EventHandler
[C#]
public event EventHandler MenuQuit;

See Also

CommandContextMenu Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


CommandContextMenu.Shown Event

Raised after the menu has been shown.

[Visual Basic]
Public Event Shown As EventHandler
[C#]
public event EventHandler Shown;

See Also

CommandContextMenu Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


DockLocation Enumeration

Internal serialization class.

[Visual Basic]
Public Enum DockLocation
[C#]
public enum DockLocation

Members

Member Name | Description
Top | Internal
Left | Internal
Bottom | Internal
Right | Internal

Requirements

Namespace: NETXP.Controls.Bars

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


DrawStyle Enumeration

Defines how to draw the combo box.

[Visual Basic]
Public Enum DrawStyle
[C#]
public enum DrawStyle

Members

Member Name | Description
Normal | Normal combo box.
Raised | Mouse over.
Pressed | Pushed.

Requirements

Namespace: NETXP.Controls.Bars

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ExpandedEventArgs Class

Event arguments for the Expanded event.

For a list of all members of this type, see ExpandedEventArgs Members.

System.Object
EventArgs
ExpandedEventArgs

[Visual Basic]
Public Class ExpandedEventArgs
Inherits EventArgs
[C#]
public class ExpandedEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Bars

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

ExpandedEventArgs Members | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ExpandedEventArgs Members

ExpandedEventArgs overview

Public Instance Constructors

ExpandedEventArgs Constructor Constructs a new object.

Public Instance Properties

DoNotUpdate Instructs the menu NOT to update its position and size as a result of the expansion.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ExpandedEventArgs Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ExpandedEventArgs Constructor

Constructs a new object.

[Visual Basic]
Public Sub New()
[C#]
public ExpandedEventArgs();

See Also

ExpandedEventArgs Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ExpandedEventArgs Properties

The properties of the ExpandedEventArgs class are listed below. For a complete list of ExpandedEventArgs class members, see the ExpandedEventArgs Members topic.

Public Instance Properties

DoNotUpdate Instructs the menu NOT to update its position and size as a result of the expansion.

See Also

ExpandedEventArgs Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ExpandedEventArgs.DoNotUpdate Property

Instructs the menu NOT to update its position and size as a result of the expansion.

[Visual Basic]
Public Property DoNotUpdate As Boolean
[C#]
public bool DoNotUpdate {get; set;}

See Also

ExpandedEventArgs Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ExpandedEventHandler Delegate

Defines the signature for the expanded event.

[Visual Basic]
Public Delegate Sub ExpandedEventHandler( _
ByVal sender As Object, _
ByVal e As ExpandedEventArgs _
)
[C#]
public delegate void ExpandedEventHandler(
object sender,
ExpandedEventArgs e
);

Requirements

Namespace: NETXP.Controls.Bars

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


FloatingForm Class

Internal

For a list of all members of this type, see FloatingForm Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
FloatingForm

[Visual Basic]
NotInheritable Public Class FloatingForm
Inherits Form
Implements System.Windows.Forms.IMessageFilter
[C#]
public sealed class FloatingForm : Form, IMessageFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Bars

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

FloatingForm Members | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


FloatingForm Members

FloatingForm overview

Public Static (Shared) Fields

BorderHeight | Gets the total border height (top, bottom, and caption bar) of a floating form.
BorderSize | Gets the typical border thickness of a floating form.
BorderWidth | Gets the total border width (left and right) of a floating form.
CaptionHeight | Gets the height of a floating form's caption.

Public Instance Constructors

FloatingForm Constructor Constructs a new FloatingForm.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) |
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScale (inherited from Form) | Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | [To be supplied.]
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsRestrictedWindow (inherited from Form) |
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) |
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text | Internal
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as the top-most form of your application.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreFilterMessage | Internal
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Control) | Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with no owner window.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is not the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) |
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

FloatingForm Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


FloatingForm Constructor

Constructs a new FloatingForm.

[Visual Basic]
Public Sub New()
[C#]
public FloatingForm();

See Also

FloatingForm Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


FloatingForm Fields

The fields of the FloatingForm class are listed below. For a complete list of FloatingForm class members, see the FloatingForm Members topic.

Public Static (Shared) Fields

BorderHeight | Gets the total border height (top, bottom, and caption bar) of a floating form.
BorderSize | Gets the typical border thickness of a floating form.
BorderWidth | Gets the total border width (left and right) of a floating form.
CaptionHeight | Gets the height of a floating form's caption.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

FloatingForm Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


FloatingForm.BorderHeight Field

Gets the total border height (top, bottom, and caption bar) of a floating form.

[Visual Basic]
Public Const BorderHeight As Integer
[C#]
public const int BorderHeight;

See Also

FloatingForm Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


FloatingForm.BorderSize Field

Gets the typical border thickness of a floating form.

[Visual Basic]
Public Const BorderSize As Integer
[C#]
public const int BorderSize;

See Also

FloatingForm Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


FloatingForm.BorderWidth Field

Gets the total border width (left and right) of a floating form.

[Visual Basic]
Public Const BorderWidth As Integer
[C#]
public const int BorderWidth;

See Also

FloatingForm Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


FloatingForm.CaptionHeight Field

Gets the height of a floating form's caption.

[Visual Basic]
Public Const CaptionHeight As Integer
[C#]
public const int CaptionHeight;

See Also

FloatingForm Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


FloatingForm Properties

The properties of the FloatingForm class are listed below. For a complete list of FloatingForm class members, see the FloatingForm Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) |
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScale (inherited from Form) | Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | [To be supplied.]
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsRestrictedWindow (inherited from Form) |
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) |
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text | Internal
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as the top-most form of your application.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

FloatingForm Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


FloatingForm.Text Property

Internal

[Visual Basic]
Public Property Text As String
[C#]
new public string Text {get; set;}

See Also

FloatingForm Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


FloatingForm Methods

The methods of the FloatingForm class are listed below. For a complete list of FloatingForm class members, see the FloatingForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreFilterMessage | Internal
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Control) | Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with no owner window.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

FloatingForm Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


FloatingForm.PreFilterMessage Method

Internal

[Visual Basic]
NotOverridable Public Function PreFilterMessage( _
ByRef m As Message _
) As Boolean Implements _
IMessageFilter.PreFilterMessage
[C#]
public bool PreFilterMessage(
ref Message m
);

Parameters

m

Return Value

Implements

IMessageFilter.PreFilterMessage

See Also

FloatingForm Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


GroupClickedEventArgs Class

This class is provides details of which item has been clicked and the mouse details of the click when the GroupClicked event is raised from a ListBar control.

For a list of all members of this type, see GroupClickedEventArgs Members.

System.Object
EventArgs
ObjectClickedEventArgs
GroupClickedEventArgs

[Visual Basic]
Public Class GroupClickedEventArgs
Inherits ObjectClickedEventArgs
[C#]
public class GroupClickedEventArgs : ObjectClickedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Bars

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

GroupClickedEventArgs Members | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


GroupClickedEventArgs Members

GroupClickedEventArgs overview

Public Instance Constructors

GroupClickedEventArgs Constructor Constructs a new instance of this object. Called by the ListBar control when firing a GroupClicked event.

Public Instance Properties

Group | Gets the ListBarGroup that has been clicked.
Location (inherited from ObjectClickedEventArgs) | The Location of the mouse, relative to the control, when the item was clicked.
MouseButton (inherited from ObjectClickedEventArgs) | The MouseButton used to click the item.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

GroupClickedEventArgs Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


GroupClickedEventArgs Constructor

Constructs a new instance of this object. Called by the ListBar control when firing a GroupClicked event.

[Visual Basic]
Public Sub New( _
ByVal group As ListBarGroup, _
ByVal location As Point, _
ByVal mouseButton As MouseButtons _
)
[C#]
public GroupClickedEventArgs(
ListBarGroup group,
Point location,
MouseButtons mouseButton
);

Parameters

group
The ListBarGroup that has been clicked
location
The mouse location relative to the control for the click.
mouseButton
The mouse button used to click the item.

See Also

GroupClickedEventArgs Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


GroupClickedEventArgs Properties

The properties of the GroupClickedEventArgs class are listed below. For a complete list of GroupClickedEventArgs class members, see the GroupClickedEventArgs Members topic.

Public Instance Properties

Group | Gets the ListBarGroup that has been clicked.
Location (inherited from ObjectClickedEventArgs) | The Location of the mouse, relative to the control, when the item was clicked.
MouseButton (inherited from ObjectClickedEventArgs) | The MouseButton used to click the item.

See Also

GroupClickedEventArgs Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


GroupClickedEventArgs.Group Property

Gets the ListBarGroup that has been clicked.

[Visual Basic]
Public ReadOnly Property Group As ListBarGroup
[C#]
public ListBarGroup Group {get;}

See Also

GroupClickedEventArgs Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


GroupClickedEventHandler Delegate

Represents the method that handles the GroupClicked event of a ListBar control.

[Visual Basic]
Public Delegate Sub GroupClickedEventHandler( _
ByVal sender As Object, _
ByVal e As GroupClickedEventArgs _
)
[C#]
public delegate void GroupClickedEventHandler(
object sender,
GroupClickedEventArgs e
);

Requirements

Namespace: NETXP.Controls.Bars

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ICommandBarRenderer Interface

Defines a renderer for command bars. This allows full control over how the command bar is drawn.

For a list of all members of this type, see ICommandBarRenderer Members.

[Visual Basic]
Public Interface ICommandBarRenderer
[C#]
public interface ICommandBarRenderer

Requirements

Namespace: NETXP.Controls.Bars

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

ICommandBarRenderer Members | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ICommandBarRenderer Members

ICommandBarRenderer overview

Public Instance Methods

DrawButtonItem | Draws a button item.
DrawComboBox | Draws a flat combo box.
DrawCommandBarBackground | Draws the command bar background.
DrawContainerBackground | Draws the background of the command bar dock.
DrawExpansionItem | Draws an expansion item.
DrawFloatingWindowBackground | Draws the background of a floating form.
DrawFloatingWindowButton | Draws the close button for a floating form.
DrawGripper | Draws the gripper for a command bar.
DrawLabelItem | Draws a label item.
DrawMenuBackground | Draws the background of a popup menu.
DrawMenuButtonItem | Draws a button item on a popup menu.
DrawMenuExpansionItem | Draws an expansion (chevron) item on a personalized menu.
DrawMenuLabelItem | Draws a label on a popup menu.
DrawMenuScrollArrow | Draws a scroll bar arrow on a scrollable popup menu.
DrawMenuSeparatorItem | Draws a separator item on a popup menu.
DrawMenuShadowHorizontal | Draws a horizontal popup menu shadow.
DrawMenuShadowVertical | Draws a vertical popup menu shadow.
DrawSeparatorItem | Draws a separator item.
UpdateColorTable | Called at the beginning of every draw operation to ensure that the color tables are up to date.

See Also

ICommandBarRenderer Interface | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ICommandBarRenderer Methods

The methods of the ICommandBarRenderer interface are listed below. For a complete list of ICommandBarRenderer interface members, see the ICommandBarRenderer Members topic.

Public Instance Methods

DrawButtonItem | Draws a button item.
DrawComboBox | Draws a flat combo box.
DrawCommandBarBackground | Draws the command bar background.
DrawContainerBackground | Draws the background of the command bar dock.
DrawExpansionItem | Draws an expansion item.
DrawFloatingWindowBackground | Draws the background of a floating form.
DrawFloatingWindowButton | Draws the close button for a floating form.
DrawGripper | Draws the gripper for a command bar.
DrawLabelItem | Draws a label item.
DrawMenuBackground | Draws the background of a popup menu.
DrawMenuButtonItem | Draws a button item on a popup menu.
DrawMenuExpansionItem | Draws an expansion (chevron) item on a personalized menu.
DrawMenuLabelItem | Draws a label on a popup menu.
DrawMenuScrollArrow | Draws a scroll bar arrow on a scrollable popup menu.
DrawMenuSeparatorItem | Draws a separator item on a popup menu.
DrawMenuShadowHorizontal | Draws a horizontal popup menu shadow.
DrawMenuShadowVertical | Draws a vertical popup menu shadow.
DrawSeparatorItem | Draws a separator item.
UpdateColorTable | Called at the beginning of every draw operation to ensure that the color tables are up to date.

See Also

ICommandBarRenderer Interface | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ICommandBarRenderer.DrawButtonItem Method

Draws a button item.

[Visual Basic]
Sub DrawButtonItem( _
ByVal item As CommandBarButtonItem, _
ByVal bar As CommandBar, _
ByVal g As Graphics, _
ByVal state As DrawItemState, _
ByVal rect As Rectangle, _
ByVal dropDown As Boolean _
)
[C#]
void DrawButtonItem(
CommandBarButtonItem item,
CommandBar bar,
Graphics g,
DrawItemState state,
Rectangle rect,
bool dropDown
);

Parameters

item
The item.
bar
The command bar.
g
The graphics object.
state
The item's state.
rect
The item's bounds.
dropDown
Is the item dropped down?

See Also

ICommandBarRenderer Interface | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ICommandBarRenderer.DrawComboBox Method

Draws a flat combo box.

[Visual Basic]
Function DrawComboBox( _
ByVal box As ComboBox, _
ByVal g As Graphics, _
ByVal rect As Rectangle, _
ByVal enabled As Boolean, _
ByVal rightToLeft As Boolean, _
ByVal drawStyle As DrawStyle _
) As Boolean
[C#]
bool DrawComboBox(
ComboBox box,
Graphics g,
Rectangle rect,
bool enabled,
bool rightToLeft,
DrawStyle drawStyle
);

Parameters

box
The combo box.
g
The graphics object.
rect
The item's bounds.
enabled
Is the combo box enabled?
rightToLeft
Is the combo box right-to-left?
drawStyle
The combo box state.

Return Value

True if custom drawn.

See Also

ICommandBarRenderer Interface | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ICommandBarRenderer.DrawCommandBarBackground Method

Draws the command bar background.

[Visual Basic]
Sub DrawCommandBarBackground( _
ByVal bar As CommandBar, _
ByVal g As Graphics, _
ByVal rect As Rectangle, _
ByVal vertical As Boolean _
)
[C#]
void DrawCommandBarBackground(
CommandBar bar,
Graphics g,
Rectangle rect,
bool vertical
);

Parameters

bar
The command bar.
g
The graphics object.
rect
The command bar bounds.
vertical
Is the bar vertical?

See Also

ICommandBarRenderer Interface | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ICommandBarRenderer.DrawContainerBackground Method

Draws the background of the command bar dock.

[Visual Basic]
Sub DrawContainerBackground( _
ByVal dock As CommandBarDock, _
ByVal g As Graphics, _
ByVal clip As Rectangle _
)
[C#]
void DrawContainerBackground(
CommandBarDock dock,
Graphics g,
Rectangle clip
);

Parameters

dock
The dock.
g
The graphics object.
clip
The clipping rectangle.

See Also

ICommandBarRenderer Interface | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ICommandBarRenderer.DrawExpansionItem Method

Draws an expansion item.

[Visual Basic]
Sub DrawExpansionItem( _
ByVal item As CommandBarExpansionItem, _
ByVal bar As CommandBar, _
ByVal g As Graphics, _
ByVal state As DrawItemState, _
ByVal rect As Rectangle, _
ByVal dropDown As Boolean, _
ByVal chevron As Boolean _
)
[C#]
void DrawExpansionItem(
CommandBarExpansionItem item,
CommandBar bar,
Graphics g,
DrawItemState state,
Rectangle rect,
bool dropDown,
bool chevron
);

Parameters

item
The item.
bar
The command bar.
g
The graphics object.
state
The item's state.
rect
The item's bounds.
dropDown
Is the item dropped down?
chevron
Show a chevron?

See Also

ICommandBarRenderer Interface | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ICommandBarRenderer.DrawFloatingWindowBackground Method

Draws the background of a floating form.

[Visual Basic]
Sub DrawFloatingWindowBackground( _
ByVal form As FloatingForm, _
ByVal bar As CommandBar, _
ByVal g As Graphics _
)
[C#]
void DrawFloatingWindowBackground(
FloatingForm form,
CommandBar bar,
Graphics g
);

Parameters

form
The floating form.
bar
The command bar inside the form.
g
The graphics object.

See Also

ICommandBarRenderer Interface | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ICommandBarRenderer.DrawFloatingWindowButton Method

Draws the close button for a floating form.

[Visual Basic]
Sub DrawFloatingWindowButton( _
ByVal form As FloatingForm, _
ByVal bar As CommandBar, _
ByVal g As Graphics, _
ByVal rect As Rectangle, _
ByVal state As DrawItemState _
)
[C#]
void DrawFloatingWindowButton(
FloatingForm form,
CommandBar bar,
Graphics g,
Rectangle rect,
DrawItemState state
);

Parameters

form
The floating form.
bar
The command bar inside the form.
g
The graphics object.
rect
The button's bounds rectangle.
state
The button's state.

See Also

ICommandBarRenderer Interface | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ICommandBarRenderer.DrawGripper Method

Draws the gripper for a command bar.

[Visual Basic]
Sub DrawGripper( _
ByVal bar As CommandBar, _
ByVal g As Graphics, _
ByVal gripRect As Rectangle, _
ByVal vertical As Boolean _
)
[C#]
void DrawGripper(
CommandBar bar,
Graphics g,
Rectangle gripRect,
bool vertical
);

Parameters

bar
The command bar.
g
The graphics object.
gripRect
The gripper bounds.
vertical
Is the bar vertical?

See Also

ICommandBarRenderer Interface | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ICommandBarRenderer.DrawLabelItem Method

Draws a label item.

[Visual Basic]
Sub DrawLabelItem( _
ByVal item As CommandBarLabelItem, _
ByVal bar As CommandBar, _
ByVal g As Graphics, _
ByVal rect As Rectangle _
)
[C#]
void DrawLabelItem(
CommandBarLabelItem item,
CommandBar bar,
Graphics g,
Rectangle rect
);

Parameters

item
The item.
bar
The command bar.
g
The graphics object.
rect
The item's bounds.

See Also

ICommandBarRenderer Interface | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ICommandBarRenderer.DrawMenuBackground Method

Draws the background of a popup menu.

[Visual Basic]
Sub DrawMenuBackground( _
ByVal g As Graphics, _
ByVal rect As Rectangle, _
ByVal menuGapLocation As Point, _
ByVal menuGapSize As Integer _
)
[C#]
void DrawMenuBackground(
Graphics g,
Rectangle rect,
Point menuGapLocation,
int menuGapSize
);

Parameters

g
The graphics object.
rect
The menu's bounds.
menuGapLocation
The location of the menu gap (for menus shown by command bar items).
menuGapSize
The horizontal size of the menu gap.

See Also

ICommandBarRenderer Interface | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ICommandBarRenderer.DrawMenuButtonItem Method

Draws a button item on a popup menu.

[Visual Basic]
Sub DrawMenuButtonItem( _
ByVal item As CommandBarButtonItem, _
ByVal menu As CommandContextMenu, _
ByVal g As Graphics, _
ByVal state As DrawItemState, _
ByVal rect As Rectangle _
)
[C#]
void DrawMenuButtonItem(
CommandBarButtonItem item,
CommandContextMenu menu,
Graphics g,
DrawItemState state,
Rectangle rect
);

Parameters

item
The item.
menu
The menu.
g
The graphics object.
state
The item's state.
rect
The item's bounds.

See Also

ICommandBarRenderer Interface | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ICommandBarRenderer.DrawMenuExpansionItem Method

Draws an expansion (chevron) item on a personalized menu.

[Visual Basic]
Sub DrawMenuExpansionItem( _
ByVal item As CommandBarExpansionItem, _
ByVal menu As CommandContextMenu, _
ByVal g As Graphics, _
ByVal state As DrawItemState, _
ByVal rect As Rectangle _
)
[C#]
void DrawMenuExpansionItem(
CommandBarExpansionItem item,
CommandContextMenu menu,
Graphics g,
DrawItemState state,
Rectangle rect
);

Parameters

item
The item.
menu
The menu.
g
The graphics object.
state
The item's state.
rect
The item's bounds.

See Also

ICommandBarRenderer Interface | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ICommandBarRenderer.DrawMenuLabelItem Method

Draws a label on a popup menu.

[Visual Basic]
Sub DrawMenuLabelItem( _
ByVal item As CommandBarLabelItem, _
ByVal menu As CommandContextMenu, _
ByVal g As Graphics, _
ByVal rect As Rectangle _
)
[C#]
void DrawMenuLabelItem(
CommandBarLabelItem item,
CommandContextMenu menu,
Graphics g,
Rectangle rect
);

Parameters

item
The item.
menu
The menu.
g
The graphics object.
rect
The item's bounds.

See Also

ICommandBarRenderer Interface | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ICommandBarRenderer.DrawMenuScrollArrow Method

Draws a scroll bar arrow on a scrollable popup menu.

[Visual Basic]
Sub DrawMenuScrollArrow( _
ByVal bounds As Rectangle, _
ByVal g As Graphics, _
ByVal up As Boolean _
)
[C#]
void DrawMenuScrollArrow(
Rectangle bounds,
Graphics g,
bool up
);

Parameters

bounds
The arrow's bounds.
g
The graphics object.
up
Is this an up arrow?

See Also

ICommandBarRenderer Interface | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ICommandBarRenderer.DrawMenuSeparatorItem Method

Draws a separator item on a popup menu.

[Visual Basic]
Sub DrawMenuSeparatorItem( _
ByVal item As CommandBarSeparatorItem, _
ByVal menu As CommandContextMenu, _
ByVal g As Graphics, _
ByVal rect As Rectangle _
)
[C#]
void DrawMenuSeparatorItem(
CommandBarSeparatorItem item,
CommandContextMenu menu,
Graphics g,
Rectangle rect
);

Parameters

item
The item.
menu
The menu.
g
The graphics object.
rect
The item's bounds.

See Also

ICommandBarRenderer Interface | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ICommandBarRenderer.DrawMenuShadowHorizontal Method

Draws a horizontal popup menu shadow.

[Visual Basic]
Sub DrawMenuShadowHorizontal( _
ByVal g As Graphics, _
ByVal rect As Rectangle, _
ByVal menuGapLocation As Point, _
ByVal menuGapSize As Integer _
)
[C#]
void DrawMenuShadowHorizontal(
Graphics g,
Rectangle rect,
Point menuGapLocation,
int menuGapSize
);

Parameters

g
The graphics object.
rect
The shadow's bounding rectangle.
menuGapLocation
The location of the menu gap (for menus shown by command bar items).
menuGapSize
The horizontal size of the menu gap.

See Also

ICommandBarRenderer Interface | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ICommandBarRenderer.DrawMenuShadowVertical Method

Draws a vertical popup menu shadow.

[Visual Basic]
Sub DrawMenuShadowVertical( _
ByVal g As Graphics, _
ByVal rect As Rectangle _
)
[C#]
void DrawMenuShadowVertical(
Graphics g,
Rectangle rect
);

Parameters

g
The graphics object.
rect
The shadow's bounding rectangle.

See Also

ICommandBarRenderer Interface | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ICommandBarRenderer.DrawSeparatorItem Method

Draws a separator item.

[Visual Basic]
Sub DrawSeparatorItem( _
ByVal item As CommandBarSeparatorItem, _
ByVal bar As CommandBar, _
ByVal g As Graphics, _
ByVal rect As Rectangle _
)
[C#]
void DrawSeparatorItem(
CommandBarSeparatorItem item,
CommandBar bar,
Graphics g,
Rectangle rect
);

Parameters

item
The item.
bar
The command bar.
g
The graphics object.
rect
The item's bounds.

See Also

ICommandBarRenderer Interface | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ICommandBarRenderer.UpdateColorTable Method

Called at the beginning of every draw operation to ensure that the color tables are up to date.

[Visual Basic]
Sub UpdateColorTable()
[C#]
void UpdateColorTable();

See Also

ICommandBarRenderer Interface | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


IListBarRenderer Interface

Defines a renderer for list bars. This allows full control over how list bars are drawn.

For a list of all members of this type, see IListBarRenderer Members.

[Visual Basic]
Public Interface IListBarRenderer
[C#]
public interface IListBarRenderer

Requirements

Namespace: NETXP.Controls.Bars

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

IListBarRenderer Members | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


IListBarRenderer Members

IListBarRenderer overview

Public Instance Methods

DrawBackground | Draws a list bar's background.
DrawBar | Draws a list bar group's background and contents (items).
DrawButton | Draws a list bar group's button.
DrawControlBorder | Draws the border of a list bar.
DrawInsertPoint | Draws the insertion point when dragging an item.
DrawScrollButton | Draws a scroll button.

See Also

IListBarRenderer Interface | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


IListBarRenderer Methods

The methods of the IListBarRenderer interface are listed below. For a complete list of IListBarRenderer interface members, see the IListBarRenderer Members topic.

Public Instance Methods

DrawBackground | Draws a list bar's background.
DrawBar | Draws a list bar group's background and contents (items).
DrawButton | Draws a list bar group's button.
DrawControlBorder | Draws the border of a list bar.
DrawInsertPoint | Draws the insertion point when dragging an item.
DrawScrollButton | Draws a scroll button.

See Also

IListBarRenderer Interface | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


IListBarRenderer.DrawBackground Method

Draws a list bar's background.

[Visual Basic]
Sub DrawBackground( _
ByVal bar As ListBar, _
ByVal g As Graphics _
)
[C#]
void DrawBackground(
ListBar bar,
Graphics g
);

Parameters

bar
The list bar.
g
The graphics object.

See Also

IListBarRenderer Interface | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


IListBarRenderer.DrawBar Method

Draws a list bar group's background and contents (items).

[Visual Basic]
Sub DrawBar( _
ByVal bar As ListBar, _
ByVal group As ListBarGroup, _
ByVal g As Graphics, _
ByVal bounds As Rectangle _
)
[C#]
void DrawBar(
ListBar bar,
ListBarGroup group,
Graphics g,
Rectangle bounds
);

Parameters

bar
The list bar.
group
The list bar group.
g
The graphics object.
bounds
The group's bounding rectangle.

See Also

IListBarRenderer Interface | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


IListBarRenderer.DrawButton Method

Draws a list bar group's button.

[Visual Basic]
Sub DrawButton( _
ByVal bar As ListBar, _
ByVal group As ListBarGroup, _
ByVal g As Graphics _
)
[C#]
void DrawButton(
ListBar bar,
ListBarGroup group,
Graphics g
);

Parameters

bar
The list bar.
group
The list bar group.
g
The graphics object.

See Also

IListBarRenderer Interface | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


IListBarRenderer.DrawControlBorder Method

Draws the border of a list bar.

[Visual Basic]
Sub DrawControlBorder( _
ByVal bar As ListBar, _
ByVal g As Graphics _
)
[C#]
void DrawControlBorder(
ListBar bar,
Graphics g
);

Parameters

bar
The list bar.
g
The graphics object.

See Also

IListBarRenderer Interface | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


IListBarRenderer.DrawInsertPoint Method

Draws the insertion point when dragging an item.

[Visual Basic]
Sub DrawInsertPoint( _
ByVal bar As ListBar, _
ByVal g As Graphics, _
ByVal group As ListBarGroup, _
ByVal dragInsertPoint As ListBarInsertPoint _
)
[C#]
void DrawInsertPoint(
ListBar bar,
Graphics g,
ListBarGroup group,
ListBarInsertPoint dragInsertPoint
);

Parameters

bar
The list bar.
g
The graphics object.
group
The current list bar group.
dragInsertPoint
The insertion point.

See Also

IListBarRenderer Interface | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


IListBarRenderer.DrawScrollButton Method

Draws a scroll button.

[Visual Basic]
Sub DrawScrollButton( _
ByVal bar As ListBar, _
ByVal sb As ListBarScrollButton, _
ByVal g As Graphics _
)
[C#]
void DrawScrollButton(
ListBar bar,
ListBarScrollButton sb,
Graphics g
);

Parameters

bar
The list bar.
sb
The scroll button.
g
The graphics object.

See Also

IListBarRenderer Interface | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


IMouseHandler Interface

An internal interface specifying the properties and methods which must be supported by an object in the control which handles mouse events.

For a list of all members of this type, see IMouseHandler Members.

[Visual Basic]
Public Interface IMouseHandler
[C#]
public interface IMouseHandler

Requirements

Namespace: NETXP.Controls.Bars

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

IMouseHandler Members | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


IMouseHandler Members

IMouseHandler overview

Public Instance Properties

MouseDown | Gets/sets whether the mouse was pressed on the object or not.
MouseDownPoint | Gets/sets the point at which the mouse button was pressed.
MouseOver | Gets/sets whether the mouse is over the object or not.
ToolTipText | Gets/sets the tooltip text for this object.

See Also

IMouseHandler Interface | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


IMouseHandler Properties

The properties of the IMouseHandler interface are listed below. For a complete list of IMouseHandler interface members, see the IMouseHandler Members topic.

Public Instance Properties

MouseDown | Gets/sets whether the mouse was pressed on the object or not.
MouseDownPoint | Gets/sets the point at which the mouse button was pressed.
MouseOver | Gets/sets whether the mouse is over the object or not.
ToolTipText | Gets/sets the tooltip text for this object.

See Also

IMouseHandler Interface | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


IMouseHandler.MouseDown Property

Gets/sets whether the mouse was pressed on the object or not.

[Visual Basic]
Property MouseDown As Boolean
[C#]
bool MouseDown {get; set;}

See Also

IMouseHandler Interface | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


IMouseHandler.MouseDownPoint Property

Gets/sets the point at which the mouse button was pressed.

[Visual Basic]
Property MouseDownPoint As Point
[C#]
System.Drawing.Point MouseDownPoint {get; set;}

See Also

IMouseHandler Interface | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


IMouseHandler.MouseOver Property

Gets/sets whether the mouse is over the object or not.

[Visual Basic]
Property MouseOver As Boolean
[C#]
bool MouseOver {get; set;}

See Also

IMouseHandler Interface | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


IMouseHandler.ToolTipText Property

Gets/sets the tooltip text for this object.

[Visual Basic]
Property ToolTipText As String
[C#]
string ToolTipText {get; set;}

See Also

IMouseHandler Interface | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


IStatusBarRenderer Interface

Defines a status bar renderer. This allows full control over how status bars are drawn.

For a list of all members of this type, see IStatusBarRenderer Members.

[Visual Basic]
Public Interface IStatusBarRenderer
[C#]
public interface IStatusBarRenderer

Requirements

Namespace: NETXP.Controls.Bars

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

IStatusBarRenderer Members | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


IStatusBarRenderer Members

IStatusBarRenderer overview

Public Instance Methods

DrawBackground | Draws the status bar background.
DrawItem | Draws an owner-drawn status bar panel.
DrawProgressBar | Draws the progress bar panel.
DrawSizeGrip | Draws the sizing grip.

See Also

IStatusBarRenderer Interface | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


IStatusBarRenderer Methods

The methods of the IStatusBarRenderer interface are listed below. For a complete list of IStatusBarRenderer interface members, see the IStatusBarRenderer Members topic.

Public Instance Methods

DrawBackground | Draws the status bar background.
DrawItem | Draws an owner-drawn status bar panel.
DrawProgressBar | Draws the progress bar panel.
DrawSizeGrip | Draws the sizing grip.

See Also

IStatusBarRenderer Interface | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


IStatusBarRenderer.DrawBackground Method

Draws the status bar background.

[Visual Basic]
Sub DrawBackground( _
ByVal bar As StatusBar, _
ByVal g As Graphics _
)
[C#]
void DrawBackground(
StatusBar bar,
Graphics g
);

Parameters

bar
The status bar.
g
The graphics object.

See Also

IStatusBarRenderer Interface | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


IStatusBarRenderer.DrawItem Method

Draws an owner-drawn status bar panel.

[Visual Basic]
Sub DrawItem( _
ByVal bar As StatusBar, _
ByVal sbdevent As StatusBarDrawItemEventArgs _
)
[C#]
void DrawItem(
StatusBar bar,
StatusBarDrawItemEventArgs sbdevent
);

Parameters

bar
The status bar.
sbdevent
The event args specifying the panel.

See Also

IStatusBarRenderer Interface | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


IStatusBarRenderer.DrawProgressBar Method

Draws the progress bar panel.

[Visual Basic]
Sub DrawProgressBar( _
ByVal bar As StatusBar, _
ByVal sbdevent As StatusBarDrawItemEventArgs, _
ByVal panel As ProgressPanel _
)
[C#]
void DrawProgressBar(
StatusBar bar,
StatusBarDrawItemEventArgs sbdevent,
ProgressPanel panel
);

Parameters

bar
The status bar.
sbdevent
The event args specifying the panel.
panel
The progress bar panel.

See Also

IStatusBarRenderer Interface | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


IStatusBarRenderer.DrawSizeGrip Method

Draws the sizing grip.

[Visual Basic]
Sub DrawSizeGrip( _
ByVal bar As StatusBar, _
ByVal g As Graphics, _
ByVal bounds As Rectangle _
)
[C#]
void DrawSizeGrip(
StatusBar bar,
Graphics g,
Rectangle bounds
);

Parameters

bar
The status bar.
g
The graphics object.
bounds
The bounds of the size grip.

See Also

IStatusBarRenderer Interface | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ItemClickedEventArgs Class

This class is provides details of which item has been clicked and the mouse details of the click when the ItemClicked event is raised from a ListBar.

For a list of all members of this type, see ItemClickedEventArgs Members.

System.Object
EventArgs
ObjectClickedEventArgs
ItemClickedEventArgs

[Visual Basic]
Public Class ItemClickedEventArgs
Inherits ObjectClickedEventArgs
[C#]
public class ItemClickedEventArgs : ObjectClickedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Bars

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

ItemClickedEventArgs Members | NETXP.Controls.Bars Namespace | ItemClicked

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ItemClickedEventArgs Members

ItemClickedEventArgs overview

Public Instance Constructors

ItemClickedEventArgs Constructor Constructs a new instance of this object. Called by the ListBar control when firing an ItemClicked event.

Public Instance Properties

Item | Gets the ListBarItem that has been clicked.
Location (inherited from ObjectClickedEventArgs) | The Location of the mouse, relative to the control, when the item was clicked.
MouseButton (inherited from ObjectClickedEventArgs) | The MouseButton used to click the item.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ItemClickedEventArgs Class | NETXP.Controls.Bars Namespace | ItemClicked

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ItemClickedEventArgs Constructor

Constructs a new instance of this object. Called by the ListBar control when firing an ItemClicked event.

[Visual Basic]
Public Sub New( _
ByVal item As ListBarItem, _
ByVal location As Point, _
ByVal mouseButton As MouseButtons _
)
[C#]
public ItemClickedEventArgs(
ListBarItem item,
Point location,
MouseButtons mouseButton
);

Parameters

item
The item that has been clicked
location
The mouse location relative to the control for the click.
mouseButton
The mouse button used to click the item.

See Also

ItemClickedEventArgs Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ItemClickedEventArgs Properties

The properties of the ItemClickedEventArgs class are listed below. For a complete list of ItemClickedEventArgs class members, see the ItemClickedEventArgs Members topic.

Public Instance Properties

Item | Gets the ListBarItem that has been clicked.
Location (inherited from ObjectClickedEventArgs) | The Location of the mouse, relative to the control, when the item was clicked.
MouseButton (inherited from ObjectClickedEventArgs) | The MouseButton used to click the item.

See Also

ItemClickedEventArgs Class | NETXP.Controls.Bars Namespace | ItemClicked

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ItemClickedEventArgs.Item Property

Gets the ListBarItem that has been clicked.

[Visual Basic]
Public ReadOnly Property Item As ListBarItem
[C#]
public ListBarItem Item {get;}

See Also

ItemClickedEventArgs Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ItemClickedEventHandler Delegate

Represents the method that handles the ItemClicked event of a ListBar control.

[Visual Basic]
Public Delegate Sub ItemClickedEventHandler( _
ByVal sender As Object, _
ByVal e As ItemClickedEventArgs _
)
[C#]
public delegate void ItemClickedEventHandler(
object sender,
ItemClickedEventArgs e
);

Requirements

Namespace: NETXP.Controls.Bars

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBar Class

The ListBar control is an implementation of the Microsoft outlook bar control. This control provides both the functionality of a standard outlook bar control as well as the functionality of the VS.NET toolbox control. The ListBar control supports drag and drop, as well as custom rendering. The bars are configured using ListBarGroup objects which are collected in the ListBarGroupCollection object accessible through the control's Groups property. Each ListBarGroup in turn contains a ListBarItemCollection of ListBarItem objects which represent the buttons within each group.

For a list of all members of this type, see ListBar Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
ListBar

[Visual Basic]
NotInheritable Public Class ListBar
Inherits UserControl
Implements System.ComponentModel.ISupportInitialize
[C#]
public sealed class ListBar : UserControl, ISupportInitialize

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Bars

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

ListBar Members | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBar Members

ListBar overview

Public Instance Constructors

ListBar Constructor Creates a new instance of a ListBar control.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDragGroups | Gets/sets whether groups will be dragged in the control automatically. The default is True. (Note in MS Outlook Groups cannot be reordered by dragging, but they can in VS.NET).
AllowDragItems | Gets/sets whether items will be dragged in the control automatically. The default is True.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
EditItem | Gets the item which is currently being edited, if any, otherwise returns null.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font | Gets/sets the default Font used to render text in the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Groups | Gets the collection of groups in the ListBar.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Renderer | Gets or sets the renderer associated with this list bar.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
SelectedGroup | Returns the currently selected group in the ListBar control, if any.
SelectOnMouseDown | Gets/sets whether items are selected on MouseDown, rather than on MouseUp, which is the default.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
ToolTip | Gets/sets the tooltip object associated with this control. The control does not generate its own internal Tooltips and instead relies on an external ToolTip object to display tooltips.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInit | ISupportInitialize method.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BeginUpdate | Prevents the control from drawing until the EndUpdate method is called.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInit | ISupportInitialize method.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
EndUpdate | Resumes drawing of the control after drawing was suspended by the BeginUpdate method.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
HitTest | Overloaded. Checks if there is an object which interacts with the mouse in the control under the specified point.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetGroups | Sets the groups object associated with this control to a new group collection.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

AfterLabelEdit | Raised after an item's label has been edited in the ListBar control. Allows the new caption to be checked and the edit cancelled.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BeforeItemClicked | Raised before an item in a ListBar control is clicked. Allows the item selection to be cancelled.
BeforeLabelEdit | Raised before an item's label is about to be edited in the ListBar control. Allows the label edit to be cancelled.
BeforeSelectedGroupChanged | Raised before the selected group in the ListBar control is changed. Allows the group selection to be cancelled.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
GroupClicked | Raised when a group has been clicked in the ListBar control.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
ItemClicked | Raised when an item has been clicked in the ListBar control.
ItemDoubleClicked | Raised when an item has been double clicked in the ListBar control.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SelectedGroupChanged | Raised when the selected group in a ListBar control has been changed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

ListBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBar Constructor

Creates a new instance of a ListBar control.

[Visual Basic]
Public Sub New()
[C#]
public ListBar();

See Also

ListBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBar Properties

The properties of the ListBar class are listed below. For a complete list of ListBar class members, see the ListBar Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDragGroups | Gets/sets whether groups will be dragged in the control automatically. The default is True. (Note in MS Outlook Groups cannot be reordered by dragging, but they can in VS.NET).
AllowDragItems | Gets/sets whether items will be dragged in the control automatically. The default is True.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
EditItem | Gets the item which is currently being edited, if any, otherwise returns null.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font | Gets/sets the default Font used to render text in the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Groups | Gets the collection of groups in the ListBar.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Renderer | Gets or sets the renderer associated with this list bar.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
SelectedGroup | Returns the currently selected group in the ListBar control, if any.
SelectOnMouseDown | Gets/sets whether items are selected on MouseDown, rather than on MouseUp, which is the default.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
ToolTip | Gets/sets the tooltip object associated with this control. The control does not generate its own internal Tooltips and instead relies on an external ToolTip object to display tooltips.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

ListBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBar.AllowDragGroups Property

Gets/sets whether groups will be dragged in the control automatically. The default is True. (Note in MS Outlook Groups cannot be reordered by dragging, but they can in VS.NET).

[Visual Basic]
Public Property AllowDragGroups As Boolean
[C#]
public bool AllowDragGroups {get; set;}

See Also

ListBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBar.AllowDragItems Property

Gets/sets whether items will be dragged in the control automatically. The default is True.

[Visual Basic]
Public Property AllowDragItems As Boolean
[C#]
public bool AllowDragItems {get; set;}

See Also

ListBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBar.EditItem Property

Gets the item which is currently being edited, if any, otherwise returns null.

[Visual Basic]
Public ReadOnly Property EditItem As ListBarItem
[C#]
public ListBarItem EditItem {get;}

See Also

ListBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBar.Font Property

Gets/sets the default Font used to render text in the control.

[Visual Basic]
Overrides Public Property Font As Font
[C#]
public override System.Drawing.Font Font {get; set;}

See Also

ListBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBar.Groups Property

Gets the collection of groups in the ListBar.

[Visual Basic]
Public ReadOnly Property Groups As ListBarGroupCollection
[C#]
public ListBarGroupCollection Groups {get;}

See Also

ListBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBar.Renderer Property

Gets or sets the renderer associated with this list bar.

[Visual Basic]
Public Property Renderer As IListBarRenderer
[C#]
public IListBarRenderer Renderer {get; set;}

See Also

ListBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBar.SelectedGroup Property

Returns the currently selected group in the ListBar control, if any.

[Visual Basic]
Public ReadOnly Property SelectedGroup As ListBarGroup
[C#]
public ListBarGroup SelectedGroup {get;}

See Also

ListBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBar.SelectOnMouseDown Property

Gets/sets whether items are selected on MouseDown, rather than on MouseUp, which is the default.

[Visual Basic]
Public Property SelectOnMouseDown As Boolean
[C#]
public bool SelectOnMouseDown {get; set;}

See Also

ListBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBar.ToolTip Property

Gets/sets the tooltip object associated with this control. The control does not generate its own internal Tooltips and instead relies on an external ToolTip object to display tooltips.

[Visual Basic]
Public Property ToolTip As ToolTip
[C#]
public System.Windows.Forms.ToolTip ToolTip {get; set;}

See Also

ListBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBar Methods

The methods of the ListBar class are listed below. For a complete list of ListBar class members, see the ListBar Members topic.

Public Instance Methods

BeginInit | ISupportInitialize method.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BeginUpdate | Prevents the control from drawing until the EndUpdate method is called.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInit | ISupportInitialize method.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
EndUpdate | Resumes drawing of the control after drawing was suspended by the BeginUpdate method.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
HitTest | Overloaded. Checks if there is an object which interacts with the mouse in the control under the specified point.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetGroups | Sets the groups object associated with this control to a new group collection.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

ListBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBar.BeginInit Method

ISupportInitialize method.

[Visual Basic]
NotOverridable Public Sub BeginInit() Implements _
ISupportInitialize.BeginInit
[C#]
public void BeginInit();

Implements

ISupportInitialize.BeginInit

See Also

ListBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBar.BeginUpdate Method

Prevents the control from drawing until the EndUpdate method is called.

[Visual Basic]
Public Sub BeginUpdate()
[C#]
public void BeginUpdate();

See Also

ListBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBar.EndInit Method

ISupportInitialize method.

[Visual Basic]
NotOverridable Public Sub EndInit() Implements _
ISupportInitialize.EndInit
[C#]
public void EndInit();

Implements

ISupportInitialize.EndInit

See Also

ListBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBar.EndUpdate Method

Resumes drawing of the control after drawing was suspended by the BeginUpdate method.

[Visual Basic]
Public Sub EndUpdate()
[C#]
public void EndUpdate();

See Also

ListBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


HitTest Method

NetXP 3.0 Reference

ListBar.HitTest Method

Checks if there is an object which interacts with the mouse in the control under the specified point.

Overload List

Checks if there is an object which interacts with the mouse in the control under the specified point.

public IMouseHandler HitTest(Point);

Checks if there is an object which interacts with the mouse in the control under the specified point.

public IMouseHandler HitTest(Point,bool);

See Also

ListBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBar.HitTest Method (Point)

Checks if there is an object which interacts with the mouse in the control under the specified point.

[Visual Basic]
Overloads Public Function HitTest( _
ByVal pt As Point _
) As IMouseHandler
[C#]
public IMouseHandler HitTest(
Point pt
);

Parameters

pt
The point to test.

Return Value

If there is a mouse object under the point then its IMouseHandler interface, otherwise null.

See Also

ListBar Class | NETXP.Controls.Bars Namespace | ListBar.HitTest Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBar.HitTest Method (Point, Boolean)

Checks if there is an object which interacts with the mouse in the control under the specified point.

[Visual Basic]
Overloads Public Function HitTest( _
ByVal pt As Point, _
ByVal forDragDrop As Boolean _
) As IMouseHandler
[C#]
public IMouseHandler HitTest(
Point pt,
bool forDragDrop
);

Parameters

pt
The point to test.
forDragDrop
Whether the hit testing is being performed for a drag-drop operation or not. During drag-drop, the hittest rectangle is relaxed so it includes the entire rectangle and not just the icon and text.

Return Value

If there is a mouse object under the point then its IMouseHandler interface, otherwise null.

See Also

ListBar Class | NETXP.Controls.Bars Namespace | ListBar.HitTest Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBar.SetGroups Method

Sets the groups object associated with this control to a new group collection.

[Visual Basic]
Public Sub SetGroups( _
ByVal groups As ListBarGroupCollection _
)
[C#]
public void SetGroups(
ListBarGroupCollection groups
);

Parameters

groups
The ListBarGroupCollection object holding the new collection of groups to associate with this control.

See Also

ListBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBar Events

The events of the ListBar class are listed below. For a complete list of ListBar class members, see the ListBar Members topic.

Public Instance Events

AfterLabelEdit | Raised after an item's label has been edited in the ListBar control. Allows the new caption to be checked and the edit cancelled.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BeforeItemClicked | Raised before an item in a ListBar control is clicked. Allows the item selection to be cancelled.
BeforeLabelEdit | Raised before an item's label is about to be edited in the ListBar control. Allows the label edit to be cancelled.
BeforeSelectedGroupChanged | Raised before the selected group in the ListBar control is changed. Allows the group selection to be cancelled.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
GroupClicked | Raised when a group has been clicked in the ListBar control.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
ItemClicked | Raised when an item has been clicked in the ListBar control.
ItemDoubleClicked | Raised when an item has been double clicked in the ListBar control.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SelectedGroupChanged | Raised when the selected group in a ListBar control has been changed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

ListBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBar.AfterLabelEdit Event

Raised after an item's label has been edited in the ListBar control. Allows the new caption to be checked and the edit cancelled.

[Visual Basic]
Public Event AfterLabelEdit As ListBarLabelEditEventHandler
[C#]
public event ListBarLabelEditEventHandler AfterLabelEdit;

Event Data

The event handler receives an argument of type ListBarLabelEditEventArgs containing data related to this event. The following ListBarLabelEditEventArgs properties provide information specific to this event.

Property | Description
CancelEdit | Gets or sets a value indicating whether changes made to the label of the should be canceled.
Item | Gets the zero-based index of the containing the label to edit.
Label | Gets the new text assigned to the label of the .
LabelEditObject | Returns the object for which label editing has been requested. Can either be a or a (or a subclass of either).

See Also

ListBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBar.BeforeItemClicked Event

Raised before an item in a ListBar control is clicked. Allows the item selection to be cancelled.

[Visual Basic]
Public Event BeforeItemClicked As BeforeItemClickedEventHandler
[C#]
public event BeforeItemClickedEventHandler BeforeItemClicked;

Event Data

The event handler receives an argument of type BeforeItemClickedEventArgs containing data related to this event. The following BeforeItemClickedEventArgs properties provide information specific to this event.

Property | Description
Cancel | Gets/sets whether the click should be cancelled or not.
Item | Gets the ListBarItem that is about to be clicked.

See Also

ListBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBar.BeforeLabelEdit Event

Raised before an item's label is about to be edited in the ListBar control. Allows the label edit to be cancelled.

[Visual Basic]
Public Event BeforeLabelEdit As ListBarLabelEditEventHandler
[C#]
public event ListBarLabelEditEventHandler BeforeLabelEdit;

Event Data

The event handler receives an argument of type ListBarLabelEditEventArgs containing data related to this event. The following ListBarLabelEditEventArgs properties provide information specific to this event.

Property | Description
CancelEdit | Gets or sets a value indicating whether changes made to the label of the should be canceled.
Item | Gets the zero-based index of the containing the label to edit.
Label | Gets the new text assigned to the label of the .
LabelEditObject | Returns the object for which label editing has been requested. Can either be a or a (or a subclass of either).

See Also

ListBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBar.BeforeSelectedGroupChanged Event

Raised before the selected group in the ListBar control is changed. Allows the group selection to be cancelled.

[Visual Basic]
Public Event BeforeSelectedGroupChanged As BeforeGroupChangedEventHandler
[C#]
public event BeforeGroupChangedEventHandler BeforeSelectedGroupChanged;

Event Data

The event handler receives an argument of type BeforeGroupChangedEventArgs containing data related to this event. The following BeforeGroupChangedEventArgs properties provide information specific to this event.

Property | Description
Cancel | Gets/sets whether the group selection should be cancelled or not. By default the group selection is not cancelled.
Group | Gets the group that will be selected.

See Also

ListBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBar.GroupClicked Event

Raised when a group has been clicked in the ListBar control.

[Visual Basic]
Public Event GroupClicked As GroupClickedEventHandler
[C#]
public event GroupClickedEventHandler GroupClicked;

Event Data

The event handler receives an argument of type GroupClickedEventArgs containing data related to this event. The following GroupClickedEventArgs properties provide information specific to this event.

Property | Description
Group | Gets the that has been clicked.
Location | The Location of the mouse, relative to the control, when the item was clicked.
MouseButton | The MouseButton used to click the item.

See Also

ListBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBar.ItemClicked Event

Raised when an item has been clicked in the ListBar control.

[Visual Basic]
Public Event ItemClicked As ItemClickedEventHandler
[C#]
public event ItemClickedEventHandler ItemClicked;

Event Data

The event handler receives an argument of type ItemClickedEventArgs containing data related to this event. The following ItemClickedEventArgs properties provide information specific to this event.

Property | Description
Item | Gets the that has been clicked.
Location | The Location of the mouse, relative to the control, when the item was clicked.
MouseButton | The MouseButton used to click the item.

See Also

ListBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBar.ItemDoubleClicked Event

Raised when an item has been double clicked in the ListBar control.

[Visual Basic]
Public Event ItemDoubleClicked As ItemClickedEventHandler
[C#]
public event ItemClickedEventHandler ItemDoubleClicked;

Event Data

The event handler receives an argument of type ItemClickedEventArgs containing data related to this event. The following ItemClickedEventArgs properties provide information specific to this event.

Property | Description
Item | Gets the that has been clicked.
Location | The Location of the mouse, relative to the control, when the item was clicked.
MouseButton | The MouseButton used to click the item.

See Also

ListBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBar.SelectedGroupChanged Event

Raised when the selected group in a ListBar control has been changed.

[Visual Basic]
Public Event SelectedGroupChanged As EventHandler
[C#]
public event EventHandler SelectedGroupChanged;

See Also

ListBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarGroup Class

A ListBarGroup is a bar within a ListBar control.

For a list of all members of this type, see ListBarGroup Members.

System.Object
MarshalByRefObject
Component
ListBarGroup

[Visual Basic]
NotInheritable Public Class ListBarGroup
Inherits Component
Implements NETXP.Controls.Bars.IMouseHandler
[C#]
public sealed class ListBarGroup : Component, IMouseHandler

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Bars

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

ListBarGroup Members | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarGroup Members

ListBarGroup overview

Public Instance Constructors

ListBarGroup Overloaded. Initializes a new instance of the ListBarGroup class.

Public Instance Properties

ButtonHeight | Returns the height of the button which activates this group.
ButtonLocation | Returns the location of the button which activates this group relative to the owning control.
ButtonWidth | Returns the width of the button which activates this group.
Caption | Gets/sets the caption displayed for this group.
Container (inherited from Component) | Gets the IContainer that contains the Component.
Items | Returns the collection of items belonging to this ListBarGroup. group.
Key | Gets/sets the string key associated with this group.
MouseDown | Gets/sets whether the mouse is down over the group button.
MouseDownPoint | Gets/sets the point at which the mouse was clicked on the group button.
MouseOver | Gets/sets whether the mouse is over the group button.
ScrollOffset | Internal member holding the negative scrolled offset of this bar from the top of the client area
Selected | Gets/sets whether this group is selected or not.
SelectedItem | Returns the selected ListBarItem in this Group, if any, otherwise null.
Site (inherited from Component) | Gets or sets the ISite of the Component.
Tag | Gets/sets a user-defined object associated with this group.
ToolTipText | Gets/sets the tooltip that will be displayed when the user hovers over this group's button.
View | Gets/sets the which view to show the items within this bar.
Visible | Gets/sets whether this group is visible in the control or not.

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
SetButtonHeight | Called to set the height of this group's button by the owning control.
SetLocationAndWidth | Sets the location and width of the button which activates this ListBarGroup. This method is called by internally by the ListBar which owns this item.
StartEdit | Starts editing this item. The BeforeLabelEdit event will be fired prior to the text box being made visible.
ToString (inherited from Component) |

Public Instance Events

Disposed (inherited from Component) Adds an event handler to listen to the Disposed event on the component.

See Also

ListBarGroup Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarGroup Constructor

Constructs a new, blank instance of a ListBarGroup.

Overload List

Constructs a new, blank instance of a ListBarGroup.

public ListBarGroup();

Constructs a new instance of a ListBarGroup with the specified caption.

public ListBarGroup(string);

Constructs a new instance of a ListBarGroup with the specified caption and items.

public ListBarGroup(string,ListBarItem[]);

Constructs a new instance of a ListBarGroup with the specified caption and tooltip text.

public ListBarGroup(string,string);

Constructs a new instance of a ListBarGroup with the specified caption, tooltip text and user-defined data.

public ListBarGroup(string,string,object);

See Also

ListBarGroup Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarGroup Constructor ()

Constructs a new, blank instance of a ListBarGroup.

[Visual Basic]
Overloads Public Sub New()
[C#]
public ListBarGroup();

See Also

ListBarGroup Class | NETXP.Controls.Bars Namespace | ListBarGroup Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarGroup Constructor (String)

Constructs a new instance of a ListBarGroup with the specified caption.

[Visual Basic]
Overloads Public Sub New( _
ByVal caption As String _
)
[C#]
public ListBarGroup(
string caption
);

Parameters

caption
Caption for the group's control button.

See Also

ListBarGroup Class | NETXP.Controls.Bars Namespace | ListBarGroup Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarGroup Constructor (String, ListBarItem[])

Constructs a new instance of a ListBarGroup with the specified caption and items.

[Visual Basic]
Overloads Public Sub New( _
ByVal caption As String, _
ByVal subItems As ListBarItem() _
)
[C#]
public ListBarGroup(
string caption,
ListBarItem[] subItems
);

Parameters

caption
Caption for the group's control button.
subItems
The array of items to add to the group's collection of items.

See Also

ListBarGroup Class | NETXP.Controls.Bars Namespace | ListBarGroup Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarGroup Constructor (String, String)

Constructs a new instance of a ListBarGroup with the specified caption and tooltip text.

[Visual Basic]
Overloads Public Sub New( _
ByVal caption As String, _
ByVal toolTipText As String _
)
[C#]
public ListBarGroup(
string caption,
string toolTipText
);

Parameters

caption
Caption for the group's control button.
toolTipText
ToolTip text to show when hovering over the group.

See Also

ListBarGroup Class | NETXP.Controls.Bars Namespace | ListBarGroup Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarGroup Constructor (String, String, Object)

Constructs a new instance of a ListBarGroup with the specified caption, tooltip text and user-defined data.

[Visual Basic]
Overloads Public Sub New( _
ByVal caption As String, _
ByVal toolTipText As String, _
ByVal tag As Object _
)
[C#]
public ListBarGroup(
string caption,
string toolTipText,
object tag
);

Parameters

caption
Caption for the group's control button.
toolTipText
ToolTip text to show when hovering over the group.
tag
User-defined object data which is associated with the group.

See Also

ListBarGroup Class | NETXP.Controls.Bars Namespace | ListBarGroup Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarGroup Properties

The properties of the ListBarGroup class are listed below. For a complete list of ListBarGroup class members, see the ListBarGroup Members topic.

Public Instance Properties

ButtonHeight | Returns the height of the button which activates this group.
ButtonLocation | Returns the location of the button which activates this group relative to the owning control.
ButtonWidth | Returns the width of the button which activates this group.
Caption | Gets/sets the caption displayed for this group.
Container (inherited from Component) | Gets the IContainer that contains the Component.
Items | Returns the collection of items belonging to this ListBarGroup. group.
Key | Gets/sets the string key associated with this group.
MouseDown | Gets/sets whether the mouse is down over the group button.
MouseDownPoint | Gets/sets the point at which the mouse was clicked on the group button.
MouseOver | Gets/sets whether the mouse is over the group button.
ScrollOffset | Internal member holding the negative scrolled offset of this bar from the top of the client area
Selected | Gets/sets whether this group is selected or not.
SelectedItem | Returns the selected ListBarItem in this Group, if any, otherwise null.
Site (inherited from Component) | Gets or sets the ISite of the Component.
Tag | Gets/sets a user-defined object associated with this group.
ToolTipText | Gets/sets the tooltip that will be displayed when the user hovers over this group's button.
View | Gets/sets the which view to show the items within this bar.
Visible | Gets/sets whether this group is visible in the control or not.

See Also

ListBarGroup Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarGroup.ButtonHeight Property

Returns the height of the button which activates this group.

[Visual Basic]
Public ReadOnly Property ButtonHeight As Integer
[C#]
public int ButtonHeight {get;}

See Also

ListBarGroup Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarGroup.ButtonLocation Property

Returns the location of the button which activates this group relative to the owning control.

[Visual Basic]
Public ReadOnly Property ButtonLocation As Point
[C#]
public System.Drawing.Point ButtonLocation {get;}

See Also

ListBarGroup Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarGroup.ButtonWidth Property

Returns the width of the button which activates this group.

[Visual Basic]
Public ReadOnly Property ButtonWidth As Integer
[C#]
public int ButtonWidth {get;}

See Also

ListBarGroup Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarGroup.Caption Property

Gets/sets the caption displayed for this group.

[Visual Basic]
Public Property Caption As String
[C#]
public string Caption {get; set;}

See Also

ListBarGroup Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarGroup.Items Property

Returns the collection of items belonging to this ListBarGroup. group.

[Visual Basic]
Public ReadOnly Property Items As ListBarItemCollection
[C#]
public ListBarItemCollection Items {get;}

See Also

ListBarGroup Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarGroup.Key Property

Gets/sets the string key associated with this group.

[Visual Basic]
Public Property Key As String
[C#]
public string Key {get; set;}

See Also

ListBarGroup Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarGroup.MouseDown Property

Gets/sets whether the mouse is down over the group button.

[Visual Basic]
NotOverridable Public Property MouseDown As Boolean Implements _
IMouseHandler.MouseDown
[C#]
public bool MouseDown {get; set;}

Implements

IMouseHandler.MouseDown

See Also

ListBarGroup Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarGroup.MouseDownPoint Property

Gets/sets the point at which the mouse was clicked on the group button.

[Visual Basic]
NotOverridable Public Property MouseDownPoint As Point Implements _
IMouseHandler.MouseDownPoint
[C#]
public System.Drawing.Point MouseDownPoint {get; set;}

Implements

IMouseHandler.MouseDownPoint

See Also

ListBarGroup Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarGroup.MouseOver Property

Gets/sets whether the mouse is over the group button.

[Visual Basic]
NotOverridable Public Property MouseOver As Boolean Implements _
IMouseHandler.MouseOver
[C#]
public bool MouseOver {get; set;}

Implements

IMouseHandler.MouseOver

See Also

ListBarGroup Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarGroup.ScrollOffset Property

Internal member holding the negative scrolled offset of this bar from the top of the client area

[Visual Basic]
Public Property ScrollOffset As Integer
[C#]
public int ScrollOffset {get; set;}

See Also

ListBarGroup Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarGroup.Selected Property

Gets/sets whether this group is selected or not.

[Visual Basic]
Public Property Selected As Boolean
[C#]
public bool Selected {get; set;}

See Also

ListBarGroup Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarGroup.SelectedItem Property

Returns the selected ListBarItem in this Group, if any, otherwise null.

[Visual Basic]
Public ReadOnly Property SelectedItem As ListBarItem
[C#]
public ListBarItem SelectedItem {get;}

See Also

ListBarGroup Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarGroup.Tag Property

Gets/sets a user-defined object associated with this group.

[Visual Basic]
Public Property Tag As Object
[C#]
public object Tag {get; set;}

See Also

ListBarGroup Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarGroup.ToolTipText Property

Gets/sets the tooltip that will be displayed when the user hovers over this group's button.

[Visual Basic]
NotOverridable Public Property ToolTipText As String Implements _
IMouseHandler.ToolTipText
[C#]
public string ToolTipText {get; set;}

Implements

IMouseHandler.ToolTipText

See Also

ListBarGroup Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarGroup.View Property

Gets/sets the which view to show the items within this bar.

[Visual Basic]
Public Property View As ListBarGroupView
[C#]
public ListBarGroupView View {get; set;}

See Also

ListBarGroup Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarGroup.Visible Property

Gets/sets whether this group is visible in the control or not.

[Visual Basic]
Public Property Visible As Boolean
[C#]
public bool Visible {get; set;}

See Also

ListBarGroup Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarGroup Methods

The methods of the ListBarGroup class are listed below. For a complete list of ListBarGroup class members, see the ListBarGroup Members topic.

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
SetButtonHeight | Called to set the height of this group's button by the owning control.
SetLocationAndWidth | Sets the location and width of the button which activates this ListBarGroup. This method is called by internally by the ListBar which owns this item.
StartEdit | Starts editing this item. The BeforeLabelEdit event will be fired prior to the text box being made visible.
ToString (inherited from Component) |

See Also

ListBarGroup Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarGroup.SetButtonHeight Method

Called to set the height of this group's button by the owning control.

[Visual Basic]
Public Sub SetButtonHeight( _
ByVal defaultFont As Font _
)
[C#]
public void SetButtonHeight(
Font defaultFont
);

Parameters

defaultFont
The default Font to use when this item does not have a specific font set.

See Also

ListBarGroup Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarGroup.SetLocationAndWidth Method

Sets the location and width of the button which activates this ListBarGroup. This method is called by internally by the ListBar which owns this item.

[Visual Basic]
Public Sub SetLocationAndWidth( _
ByVal location As Point, _
ByVal width As Integer _
)
[C#]
public void SetLocationAndWidth(
Point location,
int width
);

Parameters

location
The new location for the item.
width
The new width of the item.

Remarks

This member is not intended to be called from client code. If you do use it, it is likely that a subsequent operation on the control or group will replace the values. If you need more control over placement, override this class and build the logic into the override for this method instead.

See Also

ListBarGroup Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarGroup.StartEdit Method

Starts editing this item. The BeforeLabelEdit event will be fired prior to the text box being made visible.

[Visual Basic]
Public Sub StartEdit()
[C#]
public void StartEdit();

Exceptions

Exception Type | Condition
InvalidOperationException | If the item is not part of a ListBar control.

See Also

ListBarGroup Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarGroupCollection Class

A class to hold the collection of groups in the ListBar control.

For a list of all members of this type, see ListBarGroupCollection Members.

System.Object
CollectionBase
ListBarGroupCollection

[Visual Basic]
NotInheritable Public Class ListBarGroupCollection
Inherits CollectionBase
Implements System.Runtime.Serialization.ISerializable
[C#]
public sealed class ListBarGroupCollection : CollectionBase, ISerializable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Bars

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

ListBarGroupCollection Members | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarGroupCollection Members

ListBarGroupCollection overview

Public Instance Constructors

ListBarGroupCollection Constructor Creates a new instance of the ListBarGroup collection and associates it with the control which owns it.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Item | Overloaded. Gets the ListBarGroup at the specified 0-based index.

Public Instance Methods

Add | Adds a new ListBarGroup to the control.
AddRange | Adds a range of previously defined ListBarGroup objects.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Contains | Determines whether a ListBarGroup element is contained within the control's collection of groups.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData | Not implemented.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Gets the 0-based index of the specified ListBarGroup within this collection.
Insert | Inserts a group at the specified 0-based index in the collection of groups.
InsertAfter | Inserts a ListBarGroup immediately after the specified ListBarGroup.
InsertBefore | Inserts a group immediately before the specified ListBarGroup.
Remove | Removes the specified ListBarGroup.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
SetOwner | Enables a deserialized object graph to be associated with a ListBar control.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

ListBarGroupCollection Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarGroupCollection Constructor

Creates a new instance of the ListBarGroup collection and associates it with the control which owns it.

[Visual Basic]
Public Sub New( _
ByVal owner As ListBar _
)
[C#]
public ListBarGroupCollection(
ListBar owner
);

Parameters

owner
The owning ListBar control.

See Also

ListBarGroupCollection Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarGroupCollection Properties

The properties of the ListBarGroupCollection class are listed below. For a complete list of ListBarGroupCollection class members, see the ListBarGroupCollection Members topic.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Item | Overloaded. Gets the ListBarGroup at the specified 0-based index.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

ListBarGroupCollection Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Item Property

NetXP 3.0 Reference

ListBarGroupCollection.Item Property

Gets the ListBarGroup at the specified 0-based index.

Overload List

Gets the ListBarGroup at the specified 0-based index.

public ListBarGroup this[int] {get;}

Gets the ListBarGroup with the specified string key.

public ListBarGroup this[string] {get;}

See Also

ListBarGroupCollection Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarGroupCollection.Item Property

Gets the ListBarGroup at the specified 0-based index.

[Visual Basic]
Overloads Public Default ReadOnly Property Item( _
ByVal index As Integer _
) As ListBarGroup
[C#]
public ListBarGroup this[
int index
] {get;}

See Also

ListBarGroupCollection Class | NETXP.Controls.Bars Namespace | ListBarGroupCollection.Item Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarGroupCollection.Item Property

Gets the ListBarGroup with the specified string key.

[Visual Basic]
Overloads Public Default ReadOnly Property Item( _
ByVal key As String _
) As ListBarGroup
[C#]
public ListBarGroup this[
string key
] {get;}

See Also

ListBarGroupCollection Class | NETXP.Controls.Bars Namespace | ListBarGroupCollection.Item Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarGroupCollection Methods

The methods of the ListBarGroupCollection class are listed below. For a complete list of ListBarGroupCollection class members, see the ListBarGroupCollection Members topic.

Public Instance Methods

Add | Adds a new ListBarGroup to the control.
AddRange | Adds a range of previously defined ListBarGroup objects.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Contains | Determines whether a ListBarGroup element is contained within the control's collection of groups.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData | Not implemented.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Gets the 0-based index of the specified ListBarGroup within this collection.
Insert | Inserts a group at the specified 0-based index in the collection of groups.
InsertAfter | Inserts a ListBarGroup immediately after the specified ListBarGroup.
InsertBefore | Inserts a group immediately before the specified ListBarGroup.
Remove | Removes the specified ListBarGroup.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
SetOwner | Enables a deserialized object graph to be associated with a ListBar control.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

ListBarGroupCollection Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarGroupCollection.Add Method

Adds a new ListBarGroup to the control.

[Visual Basic]
Public Function Add( _
ByVal group As ListBarGroup _
) As Integer
[C#]
public int Add(
ListBarGroup group
);

Parameters

group
The group to add to the control

Return Value

The index at which the group was added.

See Also

ListBarGroupCollection Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarGroupCollection.AddRange Method

Adds a range of previously defined ListBarGroup objects.

[Visual Basic]
Public Sub AddRange( _
ByVal values As ListBarGroup() _
)
[C#]
public void AddRange(
ListBarGroup[] values
);

Parameters

values
The array of ListBarGroups to add to the control.

See Also

ListBarGroupCollection Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarGroupCollection.Contains Method

Determines whether a ListBarGroup element is contained within the control's collection of groups.

[Visual Basic]
Public Function Contains( _
ByVal group As ListBarGroup _
) As Boolean
[C#]
public bool Contains(
ListBarGroup group
);

Parameters

group
The ListBarGroup to check if present.

Return Value

True if the ListBarGroup is contained within the control's collection, False otherwise.

See Also

ListBarGroupCollection Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarGroupCollection.GetObjectData Method

Not implemented.

[Visual Basic]
NotOverridable Public Sub GetObjectData( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
) Implements _
ISerializable.GetObjectData
[C#]
public void GetObjectData(
SerializationInfo info,
StreamingContext context
);

Parameters

info
context

Implements

ISerializable.GetObjectData

See Also

ListBarGroupCollection Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarGroupCollection.IndexOf Method

Gets the 0-based index of the specified ListBarGroup within this collection.

[Visual Basic]
Public Function IndexOf( _
ByVal group As ListBarGroup _
) As Integer
[C#]
public int IndexOf(
ListBarGroup group
);

Parameters

group
The group to find the index for.

Return Value

The 0-based index of the group, if found, otherwise - 1.

See Also

ListBarGroupCollection Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarGroupCollection.Insert Method

Inserts a group at the specified 0-based index in the collection of groups.

[Visual Basic]
Public Sub Insert( _
ByVal index As Integer, _
ByVal group As ListBarGroup _
)
[C#]
public void Insert(
int index,
ListBarGroup group
);

Parameters

index
The 0-based index to insert the group at.
group
The ListBarGroup to add.

See Also

ListBarGroupCollection Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarGroupCollection.InsertAfter Method

Inserts a ListBarGroup immediately after the specified ListBarGroup.

[Visual Basic]
Public Sub InsertAfter( _
ByVal groupAfter As ListBarGroup, _
ByVal group As ListBarGroup _
)
[C#]
public void InsertAfter(
ListBarGroup groupAfter,
ListBarGroup group
);

Parameters

groupAfter
ListBarGroup to insert after.
group
Group to insert.

See Also

ListBarGroupCollection Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarGroupCollection.InsertBefore Method

Inserts a group immediately before the specified ListBarGroup.

[Visual Basic]
Public Sub InsertBefore( _
ByVal groupBefore As ListBarGroup, _
ByVal group As ListBarGroup _
)
[C#]
public void InsertBefore(
ListBarGroup groupBefore,
ListBarGroup group
);

Parameters

groupBefore
ListBarGroup to insert before.
group
Group to insert.

See Also

ListBarGroupCollection Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarGroupCollection.Remove Method

Removes the specified ListBarGroup.

[Visual Basic]
Public Sub Remove( _
ByVal group As ListBarGroup _
)
[C#]
public void Remove(
ListBarGroup group
);

Parameters

group
The group to remove.

See Also

ListBarGroupCollection Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarGroupCollection.SetOwner Method

Enables a deserialized object graph to be associated with a ListBar control.

[Visual Basic]
Public Sub SetOwner( _
ByVal owner As ListBar _
)
[C#]
public void SetOwner(
ListBar owner
);

Parameters

owner
The ListBar control which will own this collection of items.

See Also

ListBarGroupCollection Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarGroupView Enumeration

Specifies the view to use for the items within a ListBarGroup.

[Visual Basic]
Public Enum ListBarGroupView
[C#]
public enum ListBarGroupView

Members

Member Name | Description
TextUnderneath | The ListBar will display using large icons, with the text underneath.
TextRight | The ListBar will display using small icons, with text to the right.
NoText | The ListBar will display using small or large icons, with no text.

Requirements

Namespace: NETXP.Controls.Bars

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarInsertPoint Class

An internal class to manage the drag-drop insert point within the control.

For a list of all members of this type, see ListBarInsertPoint Members.

System.Object
ListBarInsertPoint

[Visual Basic]
NotInheritable Public Class ListBarInsertPoint
Implements System.IComparable
[C#]
public sealed class ListBarInsertPoint : IComparable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Bars

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

ListBarInsertPoint Members | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarInsertPoint Members

ListBarInsertPoint overview

Public Instance Constructors

ListBarInsertPoint Constructor Constructs a new instance of this class, setting the items before and after the drag-drop insertion point.

Public Instance Properties

ItemAfter | Returns the item after the drag-drop point, if any. At least one of the properties ItemBefore or ItemAfter will return an item.
ItemBefore | Returns the item before the drag-drop point, if any. At least one of the properties ItemBefore or ItemAfter will return an item.
OverEmptyBar | Returns whether the drag point is over an empty bar or not.

Public Instance Methods

CompareTo | Compares this object with another object of the same type. This implementation is only really useful for testing equality
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ListBarInsertPoint Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarInsertPoint Constructor

Constructs a new instance of this class, setting the items before and after the drag-drop insertion point.

[Visual Basic]
Public Sub New( _
ByVal itemBefore As ListBarItem, _
ByVal itemAfter As ListBarItem, _
ByVal overEmptyBar As Boolean _
)
[C#]
public ListBarInsertPoint(
ListBarItem itemBefore,
ListBarItem itemAfter,
bool overEmptyBar
);

Parameters

itemBefore
Item before the drag-drop insertion point, or null if no item before.
itemAfter
Item after the drag-drop insertion point, or null if no item after.
overEmptyBar
Whether the drag-drop insertion point should be displayed in an empty bar.

See Also

ListBarInsertPoint Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarInsertPoint Properties

The properties of the ListBarInsertPoint class are listed below. For a complete list of ListBarInsertPoint class members, see the ListBarInsertPoint Members topic.

Public Instance Properties

ItemAfter | Returns the item after the drag-drop point, if any. At least one of the properties ItemBefore or ItemAfter will return an item.
ItemBefore | Returns the item before the drag-drop point, if any. At least one of the properties ItemBefore or ItemAfter will return an item.
OverEmptyBar | Returns whether the drag point is over an empty bar or not.

See Also

ListBarInsertPoint Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarInsertPoint.ItemAfter Property

Returns the item after the drag-drop point, if any. At least one of the properties ItemBefore or ItemAfter will return an item.

[Visual Basic]
Public ReadOnly Property ItemAfter As ListBarItem
[C#]
public ListBarItem ItemAfter {get;}

See Also

ListBarInsertPoint Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarInsertPoint.ItemBefore Property

Returns the item before the drag-drop point, if any. At least one of the properties ItemBefore or ItemAfter will return an item.

[Visual Basic]
Public ReadOnly Property ItemBefore As ListBarItem
[C#]
public ListBarItem ItemBefore {get;}

See Also

ListBarInsertPoint Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarInsertPoint.OverEmptyBar Property

Returns whether the drag point is over an empty bar or not.

[Visual Basic]
Public ReadOnly Property OverEmptyBar As Boolean
[C#]
public bool OverEmptyBar {get;}

See Also

ListBarInsertPoint Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarInsertPoint Methods

The methods of the ListBarInsertPoint class are listed below. For a complete list of ListBarInsertPoint class members, see the ListBarInsertPoint Members topic.

Public Instance Methods

CompareTo | Compares this object with another object of the same type. This implementation is only really useful for testing equality
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ListBarInsertPoint Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarInsertPoint.CompareTo Method

Compares this object with another object of the same type. This implementation is only really useful for testing equality

[Visual Basic]
NotOverridable Public Function CompareTo( _
ByVal obj As Object _
) As Integer Implements _
IComparable.CompareTo
[C#]
public int CompareTo(
object obj
);

Parameters

obj
Another ListBarInsertPoint object

Return Value

A 32-bit signed integer that indicates the relative order of the comparands. The return value has these meanings: < 0: This instance is less than obj. 0: This instance is equal to obj. > 0: This instance is greater than obj.

Implements

IComparable.CompareTo

See Also

ListBarInsertPoint Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarItem Class

A class containing the information describing an Item in the ListBar control.

For a list of all members of this type, see ListBarItem Members.

System.Object
MarshalByRefObject
Component
ListBarItem

[Visual Basic]
NotInheritable Public Class ListBarItem
Inherits Component
Implements System.IComparable, NETXP.Controls.Bars.IMouseHandler
[C#]
public sealed class ListBarItem : Component, IComparable, IMouseHandler

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Bars

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

ListBarItem Members | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarItem Members

ListBarItem overview

Public Instance Constructors

ListBarItem Overloaded. Initializes a new instance of the ListBarItem class.

Public Instance Properties

Caption | Gets/sets the caption displayed for this item.
Container (inherited from Component) | Gets the IContainer that contains the Component.
Enabled | Gets/sets whether this item is enabled.
Height | Gets the height of this item.
IconRectangle | Gets or sets the bounds of the image.
Image | Gets or sets the image associated with this item.
Key | Gets/sets a user-defined string value which can be used to look up the item in the collection which owns it.
Location | Gets the location for this item in the control.
MouseDown | Gets/sets whether the mouse is down on this item.
MouseDownPoint | Gets/sets the point at which the mouse was pressed on this object.
MouseOver | Gets/sets whether the mouse is over this item.
Rectangle | Gets or sets the bounds of the item.
Selected | Gets/sets whether this item is "selected" or not. Only one item in the ListBar control can be selected at a time.
Site (inherited from Component) | Gets or sets the ISite of the Component.
Tag | Gets/sets an object which can be used to associate user-defined data with this item.
TextRectangle | Gets or sets the bounds of the text.
ToolTipText | Gets/sets the tooltip text that will be displayed when the user hovers over this item.
Width | Gets the width of this item.

Public Instance Methods

CompareTo | Compares this object with another object of the same type. The implementation compares the captions of the items to allow items to be sorted alphabetically.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
EnsureVisible | Ensures that this item can be seen in the owner control.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
SetLocationAndWidth | Sets the location and width of this item. This method is called by internally by the ListBar or the ListBarGroup which owns this item.
SetSize | Called to set the height of the item by the owning control.
StartEdit | Starts editing this item. The BeforeLabelEdit event will be fired prior to the text box being made visible.
ToString (inherited from Component) |

Public Instance Events

Disposed (inherited from Component) Adds an event handler to listen to the Disposed event on the component.

See Also

ListBarItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarItem Constructor

Constructs a new, empty instance of a ListBarItem.

Overload List

Constructs a new, empty instance of a ListBarItem.

public ListBarItem();

Constructs a new instance of a ListBarItem, specifying the caption to display.

public ListBarItem(string);

See Also

ListBarItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarItem Constructor ()

Constructs a new, empty instance of a ListBarItem.

[Visual Basic]
Overloads Public Sub New()
[C#]
public ListBarItem();

See Also

ListBarItem Class | NETXP.Controls.Bars Namespace | ListBarItem Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarItem Constructor (String)

Constructs a new instance of a ListBarItem, specifying the caption to display.

[Visual Basic]
Overloads Public Sub New( _
ByVal caption As String _
)
[C#]
public ListBarItem(
string caption
);

Parameters

caption
The caption for this item.

See Also

ListBarItem Class | NETXP.Controls.Bars Namespace | ListBarItem Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarItem Properties

The properties of the ListBarItem class are listed below. For a complete list of ListBarItem class members, see the ListBarItem Members topic.

Public Instance Properties

Caption | Gets/sets the caption displayed for this item.
Container (inherited from Component) | Gets the IContainer that contains the Component.
Enabled | Gets/sets whether this item is enabled.
Height | Gets the height of this item.
IconRectangle | Gets or sets the bounds of the image.
Image | Gets or sets the image associated with this item.
Key | Gets/sets a user-defined string value which can be used to look up the item in the collection which owns it.
Location | Gets the location for this item in the control.
MouseDown | Gets/sets whether the mouse is down on this item.
MouseDownPoint | Gets/sets the point at which the mouse was pressed on this object.
MouseOver | Gets/sets whether the mouse is over this item.
Rectangle | Gets or sets the bounds of the item.
Selected | Gets/sets whether this item is "selected" or not. Only one item in the ListBar control can be selected at a time.
Site (inherited from Component) | Gets or sets the ISite of the Component.
Tag | Gets/sets an object which can be used to associate user-defined data with this item.
TextRectangle | Gets or sets the bounds of the text.
ToolTipText | Gets/sets the tooltip text that will be displayed when the user hovers over this item.
Width | Gets the width of this item.

See Also

ListBarItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarItem.Caption Property

Gets/sets the caption displayed for this item.

[Visual Basic]
Public Property Caption As String
[C#]
public string Caption {get; set;}

See Also

ListBarItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarItem.Enabled Property

Gets/sets whether this item is enabled.

[Visual Basic]
Public Property Enabled As Boolean
[C#]
public bool Enabled {get; set;}

See Also

ListBarItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarItem.Height Property

Gets the height of this item.

[Visual Basic]
Public ReadOnly Property Height As Integer
[C#]
public int Height {get;}

See Also

ListBarItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarItem.IconRectangle Property

Gets or sets the bounds of the image.

[Visual Basic]
Public Property IconRectangle As Rectangle
[C#]
public System.Drawing.Rectangle IconRectangle {get; set;}

See Also

ListBarItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarItem.Image Property

Gets or sets the image associated with this item.

[Visual Basic]
Public Property Image As Image
[C#]
public System.Drawing.Image Image {get; set;}

See Also

ListBarItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarItem.Key Property

Gets/sets a user-defined string value which can be used to look up the item in the collection which owns it.

[Visual Basic]
Public Property Key As String
[C#]
public string Key {get; set;}

See Also

ListBarItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarItem.Location Property

Gets the location for this item in the control.

[Visual Basic]
Public ReadOnly Property Location As Point
[C#]
public System.Drawing.Point Location {get;}

Remarks

The location is relative to the group the item belongs to. Therefore to find the position relative to the control you need to add the bottom position of the button rectangle for the group and the scroll offset of the item.

See Also

ListBarItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarItem.MouseDown Property

Gets/sets whether the mouse is down on this item.

[Visual Basic]
NotOverridable Public Property MouseDown As Boolean Implements _
IMouseHandler.MouseDown
[C#]
public bool MouseDown {get; set;}

Implements

IMouseHandler.MouseDown

See Also

ListBarItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarItem.MouseDownPoint Property

Gets/sets the point at which the mouse was pressed on this object.

[Visual Basic]
NotOverridable Public Property MouseDownPoint As Point Implements _
IMouseHandler.MouseDownPoint
[C#]
public System.Drawing.Point MouseDownPoint {get; set;}

Implements

IMouseHandler.MouseDownPoint

See Also

ListBarItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarItem.MouseOver Property

Gets/sets whether the mouse is over this item.

[Visual Basic]
NotOverridable Public Property MouseOver As Boolean Implements _
IMouseHandler.MouseOver
[C#]
public bool MouseOver {get; set;}

Implements

IMouseHandler.MouseOver

See Also

ListBarItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarItem.Rectangle Property

Gets or sets the bounds of the item.

[Visual Basic]
Public Property Rectangle As Rectangle
[C#]
public System.Drawing.Rectangle Rectangle {get; set;}

See Also

ListBarItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarItem.Selected Property

Gets/sets whether this item is "selected" or not. Only one item in the ListBar control can be selected at a time.

[Visual Basic]
Public Property Selected As Boolean
[C#]
public bool Selected {get; set;}

See Also

ListBarItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarItem.Tag Property

Gets/sets an object which can be used to associate user-defined data with this item.

[Visual Basic]
Public Property Tag As Object
[C#]
public object Tag {get; set;}

See Also

ListBarItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarItem.TextRectangle Property

Gets or sets the bounds of the text.

[Visual Basic]
Public Property TextRectangle As Rectangle
[C#]
public System.Drawing.Rectangle TextRectangle {get; set;}

See Also

ListBarItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarItem.ToolTipText Property

Gets/sets the tooltip text that will be displayed when the user hovers over this item.

[Visual Basic]
NotOverridable Public Property ToolTipText As String Implements _
IMouseHandler.ToolTipText
[C#]
public string ToolTipText {get; set;}

Implements

IMouseHandler.ToolTipText

See Also

ListBarItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarItem.Width Property

Gets the width of this item.

[Visual Basic]
Public ReadOnly Property Width As Integer
[C#]
public int Width {get;}

See Also

ListBarItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarItem Methods

The methods of the ListBarItem class are listed below. For a complete list of ListBarItem class members, see the ListBarItem Members topic.

Public Instance Methods

CompareTo | Compares this object with another object of the same type. The implementation compares the captions of the items to allow items to be sorted alphabetically.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
EnsureVisible | Ensures that this item can be seen in the owner control.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
SetLocationAndWidth | Sets the location and width of this item. This method is called by internally by the ListBar or the ListBarGroup which owns this item.
SetSize | Called to set the height of the item by the owning control.
StartEdit | Starts editing this item. The BeforeLabelEdit event will be fired prior to the text box being made visible.
ToString (inherited from Component) |

See Also

ListBarItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarItem.CompareTo Method

Compares this object with another object of the same type. The implementation compares the captions of the items to allow items to be sorted alphabetically.

[Visual Basic]
NotOverridable Public Function CompareTo( _
ByVal obj As Object _
) As Integer Implements _
IComparable.CompareTo
[C#]
public int CompareTo(
object obj
);

Parameters

obj
Another ListBarItem object

Return Value

A 32-bit signed integer that indicates the relative order of the comparands. The return value has these meanings: < 0: This instance is less than obj. 0: This instance is equal to obj. > 0: This instance is greater than obj.

Implements

IComparable.CompareTo

See Also

ListBarItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarItem.EnsureVisible Method

Ensures that this item can be seen in the owner control.

[Visual Basic]
Public Sub EnsureVisible()
[C#]
public void EnsureVisible();

Exceptions

Exception Type | Condition
InvalidOperationException | If the item is not part of a ListBarGroup.

See Also

ListBarItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarItem.SetLocationAndWidth Method

Sets the location and width of this item. This method is called by internally by the ListBar or the ListBarGroup which owns this item.

[Visual Basic]
Public Sub SetLocationAndWidth( _
ByVal location As Point, _
ByVal width As Integer _
)
[C#]
public void SetLocationAndWidth(
Point location,
int width
);

Parameters

location
The new location for the item.
width
The new width of the item.

Remarks

This member is not intended to be called from client code. If you do use it, it is likely that a subsequent operation on the control or group will replace the values. If you need more control over placement, override this class and build the logic into the override for this method instead.

See Also

ListBarItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarItem.SetSize Method

Called to set the height of the item by the owning control.

[Visual Basic]
Public Sub SetSize( _
ByVal view As ListBarGroupView, _
ByVal defaultFont As Font, _
ByVal imageSize As Size _
)
[C#]
public void SetSize(
ListBarGroupView view,
Font defaultFont,
Size imageSize
);

Parameters

view
The ListBarGroupView in which this item is being shown.
defaultFont
The default Font to use when this item does not have a specific font set.
imageSize
The size of the image for this item.

See Also

ListBarItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarItem.StartEdit Method

Starts editing this item. The BeforeLabelEdit event will be fired prior to the text box being made visible.

[Visual Basic]
Public Sub StartEdit()
[C#]
public void StartEdit();

Exceptions

Exception Type | Condition
InvalidOperationException | If the item is not part of a ListBarGroup or not part of the selected group in the control.

See Also

ListBarItem Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarItemCollection Class

This class manages a collection of items within a ListBarGroup.

For a list of all members of this type, see ListBarItemCollection Members.

System.Object
CollectionBase
ListBarItemCollection

[Visual Basic]
NotInheritable Public Class ListBarItemCollection
Inherits CollectionBase
Implements System.Runtime.Serialization.ISerializable
[C#]
public sealed class ListBarItemCollection : CollectionBase, ISerializable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Bars

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

ListBarItemCollection Members | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarItemCollection Members

ListBarItemCollection overview

Public Instance Constructors

ListBarItemCollection Overloaded. Initializes a new instance of the ListBarItemCollection class.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Height | Gets the height of all the items within this collection.
Item | Overloaded. Gets the ListBarItem at the specified 0-based index.

Public Instance Methods

Add | Adds a ListBarItem object to the group.
AddRange | Adds a range of ListBarItem objects to the bar from an array.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Contains | Returns true if the specified ListBarItem is contained within this collection, otherwise false.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData | Not implemented.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Returns the 0-based index of the specified item in the collection if present, -1 otherwise.
Insert | Inserts a ListBarItem at the specified index in the bar.
InsertAfter | Inserts a ListBarItem immediately after the specified ListBarItem.
InsertBefore | Inserts a ListBarItem immediately before the specified ListBarItem.
Remove | Removes the specified ListBarItem from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
SetOwner | Enables a deserialized object graph to be associated with a ListBar control.
Sort | Overloaded. Sorts the items in this collection using the specified comparer.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

ListBarItemCollection Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarItemCollection Constructor

Not implemented.

Overload List

Constructs a new instance of this collection and sets the owner. Typically this is performed by the owning ListBar control.

public ListBarItemCollection(ListBar);

Not implemented.

public ListBarItemCollection(SerializationInfo,StreamingContext);

See Also

ListBarItemCollection Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarItemCollection Constructor (SerializationInfo, StreamingContext)

Not implemented.

[Visual Basic]
Overloads Public Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
[C#]
public ListBarItemCollection(
SerializationInfo info,
StreamingContext context
);

Parameters

info
context

See Also

ListBarItemCollection Class | NETXP.Controls.Bars Namespace | ListBarItemCollection Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarItemCollection Constructor (ListBar)

Constructs a new instance of this collection and sets the owner. Typically this is performed by the owning ListBar control.

[Visual Basic]
Overloads Public Sub New( _
ByVal owner As ListBar _
)
[C#]
public ListBarItemCollection(
ListBar owner
);

Parameters

owner
The ListBar which owns this collection

See Also

ListBarItemCollection Class | NETXP.Controls.Bars Namespace | ListBarItemCollection Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarItemCollection Properties

The properties of the ListBarItemCollection class are listed below. For a complete list of ListBarItemCollection class members, see the ListBarItemCollection Members topic.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Height | Gets the height of all the items within this collection.
Item | Overloaded. Gets the ListBarItem at the specified 0-based index.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

ListBarItemCollection Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarItemCollection.Height Property

Gets the height of all the items within this collection.

[Visual Basic]
Public ReadOnly Property Height As Integer
[C#]
public int Height {get;}

See Also

ListBarItemCollection Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Item Property

NetXP 3.0 Reference

ListBarItemCollection.Item Property

Gets the ListBarItem at the specified 0-based index.

Overload List

Gets the ListBarItem at the specified 0-based index.

public ListBarItem this[int] {get;}

Gets the ListBarItem with the specified key.

public ListBarItem this[string] {get;}

See Also

ListBarItemCollection Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarItemCollection.Item Property

Gets the ListBarItem at the specified 0-based index.

[Visual Basic]
Overloads Public Default ReadOnly Property Item( _
ByVal index As Integer _
) As ListBarItem
[C#]
public ListBarItem this[
int index
] {get;}

See Also

ListBarItemCollection Class | NETXP.Controls.Bars Namespace | ListBarItemCollection.Item Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarItemCollection.Item Property

Gets the ListBarItem with the specified key.

[Visual Basic]
Overloads Public Default ReadOnly Property Item( _
ByVal key As String _
) As ListBarItem
[C#]
public ListBarItem this[
string key
] {get;}

See Also

ListBarItemCollection Class | NETXP.Controls.Bars Namespace | ListBarItemCollection.Item Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarItemCollection Methods

The methods of the ListBarItemCollection class are listed below. For a complete list of ListBarItemCollection class members, see the ListBarItemCollection Members topic.

Public Instance Methods

Add | Adds a ListBarItem object to the group.
AddRange | Adds a range of ListBarItem objects to the bar from an array.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Contains | Returns true if the specified ListBarItem is contained within this collection, otherwise false.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData | Not implemented.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Returns the 0-based index of the specified item in the collection if present, -1 otherwise.
Insert | Inserts a ListBarItem at the specified index in the bar.
InsertAfter | Inserts a ListBarItem immediately after the specified ListBarItem.
InsertBefore | Inserts a ListBarItem immediately before the specified ListBarItem.
Remove | Removes the specified ListBarItem from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
SetOwner | Enables a deserialized object graph to be associated with a ListBar control.
Sort | Overloaded. Sorts the items in this collection using the specified comparer.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

ListBarItemCollection Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarItemCollection.Add Method

Adds a ListBarItem object to the group.

[Visual Basic]
Public Sub Add( _
ByVal item As ListBarItem _
)
[C#]
public void Add(
ListBarItem item
);

Parameters

item
The ListBarItem to add.

See Also

ListBarItemCollection Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarItemCollection.AddRange Method

Adds a range of ListBarItem objects to the bar from an array.

[Visual Basic]
Public Sub AddRange( _
ByVal values As ListBarItem() _
)
[C#]
public void AddRange(
ListBarItem[] values
);

Parameters

values
The array of ListBarItem objects to add.

See Also

ListBarItemCollection Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarItemCollection.Contains Method

Returns true if the specified ListBarItem is contained within this collection, otherwise false.

[Visual Basic]
Public Function Contains( _
ByVal item As ListBarItem _
) As Boolean
[C#]
public bool Contains(
ListBarItem item
);

Parameters

item
The ListBarItem to check.

Return Value

True if the specified ListBarItem is contained within this collection, False otherwise.

See Also

ListBarItemCollection Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarItemCollection.GetObjectData Method

Not implemented.

[Visual Basic]
NotOverridable Public Sub GetObjectData( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
) Implements _
ISerializable.GetObjectData
[C#]
public void GetObjectData(
SerializationInfo info,
StreamingContext context
);

Parameters

info
context

Implements

ISerializable.GetObjectData

See Also

ListBarItemCollection Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarItemCollection.IndexOf Method

Returns the 0-based index of the specified item in the collection if present, -1 otherwise.

[Visual Basic]
Public Function IndexOf( _
ByVal item As ListBarItem _
) As Integer
[C#]
public int IndexOf(
ListBarItem item
);

Parameters

item
The ListBarItem to check.

Return Value

The 0-based index of the specified item in the collection if present, -1 otherwise.

See Also

ListBarItemCollection Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarItemCollection.Insert Method

Inserts a ListBarItem at the specified index in the bar.

[Visual Basic]
Public Sub Insert( _
ByVal index As Integer, _
ByVal item As ListBarItem _
)
[C#]
public void Insert(
int index,
ListBarItem item
);

Parameters

index
The index to insert at.
item
The ListBarItem to insert.

See Also

ListBarItemCollection Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarItemCollection.InsertAfter Method

Inserts a ListBarItem immediately after the specified ListBarItem.

[Visual Basic]
Public Sub InsertAfter( _
ByVal itemAfter As ListBarItem, _
ByVal item As ListBarItem _
)
[C#]
public void InsertAfter(
ListBarItem itemAfter,
ListBarItem item
);

Parameters

itemAfter
ListBarItem to insert after.
item
Item to insert.

See Also

ListBarItemCollection Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarItemCollection.InsertBefore Method

Inserts a ListBarItem immediately before the specified ListBarItem.

[Visual Basic]
Public Sub InsertBefore( _
ByVal itemBefore As ListBarItem, _
ByVal item As ListBarItem _
)
[C#]
public void InsertBefore(
ListBarItem itemBefore,
ListBarItem item
);

Parameters

itemBefore
ListBarItem to insert before.
item
Item to insert.

See Also

ListBarItemCollection Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarItemCollection.Remove Method

Removes the specified ListBarItem from the collection.

[Visual Basic]
Public Sub Remove( _
ByVal item As ListBarItem _
)
[C#]
public void Remove(
ListBarItem item
);

Parameters

item
Item to remove.

See Also

ListBarItemCollection Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarItemCollection.SetOwner Method

Enables a deserialized object graph to be associated with a ListBar control.

[Visual Basic]
Public Sub SetOwner( _
ByVal owner As ListBar _
)
[C#]
public void SetOwner(
ListBar owner
);

Parameters

owner
The ListBar control which will own this collection of items.

See Also

ListBarItemCollection Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Sort Method

NetXP 3.0 Reference

ListBarItemCollection.Sort Method

Sorts the items in this collection using the default comparison operation (alphabetic).

Overload List

Sorts the items in this collection using the default comparison operation (alphabetic).

public void Sort();

Sorts the items in this collection using the specified comparer.

public void Sort(IComparer);

See Also

ListBarItemCollection Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarItemCollection.Sort Method ()

Sorts the items in this collection using the default comparison operation (alphabetic).

[Visual Basic]
Overloads Public Sub Sort()
[C#]
public void Sort();

See Also

ListBarItemCollection Class | NETXP.Controls.Bars Namespace | ListBarItemCollection.Sort Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarItemCollection.Sort Method (IComparer)

Sorts the items in this collection using the specified comparer.

[Visual Basic]
Overloads Public Sub Sort( _
ByVal comparer As IComparer _
)
[C#]
public void Sort(
IComparer comparer
);

Parameters

comparer
IComparer implementation specifying how to sort the objects.

See Also

ListBarItemCollection Class | NETXP.Controls.Bars Namespace | ListBarItemCollection.Sort Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarLabelEditEventArgs Class

Provides details about an item which will undergo an edit operation.

For a list of all members of this type, see ListBarLabelEditEventArgs Members.

System.Object
EventArgs
LabelEditEventArgs
ListBarLabelEditEventArgs

[Visual Basic]
Public Class ListBarLabelEditEventArgs
Inherits LabelEditEventArgs
[C#]
public class ListBarLabelEditEventArgs : LabelEditEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Bars

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

ListBarLabelEditEventArgs Members | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarLabelEditEventArgs Members

ListBarLabelEditEventArgs overview

Public Instance Constructors

ListBarLabelEditEventArgs Constructor Constructs a new instance of this object given the item, label and object.

Public Instance Properties

CancelEdit (inherited from LabelEditEventArgs) | Gets or sets a value indicating whether changes made to the label of the ListViewItem should be canceled.
Item (inherited from LabelEditEventArgs) | Gets the zero-based index of the ListViewItem containing the label to edit.
Label (inherited from LabelEditEventArgs) | Gets the new text assigned to the label of the ListViewItem.
LabelEditObject | Returns the object for which label editing has been requested. Can either be a ListBarItem or a ListBarGroup (or a subclass of either).

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ListBarLabelEditEventArgs Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarLabelEditEventArgs Constructor

Constructs a new instance of this object given the item, label and object.

[Visual Basic]
Public Sub New( _
ByVal item As Integer, _
ByVal label As String, _
ByVal labelEditObject As Object _
)
[C#]
public ListBarLabelEditEventArgs(
int item,
string label,
object labelEditObject
);

Parameters

item
The index of the item being edited.
label
The label of the item being edited.
labelEditObject
The object being edited.

See Also

ListBarLabelEditEventArgs Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarLabelEditEventArgs Properties

The properties of the ListBarLabelEditEventArgs class are listed below. For a complete list of ListBarLabelEditEventArgs class members, see the ListBarLabelEditEventArgs Members topic.

Public Instance Properties

CancelEdit (inherited from LabelEditEventArgs) | Gets or sets a value indicating whether changes made to the label of the ListViewItem should be canceled.
Item (inherited from LabelEditEventArgs) | Gets the zero-based index of the ListViewItem containing the label to edit.
Label (inherited from LabelEditEventArgs) | Gets the new text assigned to the label of the ListViewItem.
LabelEditObject | Returns the object for which label editing has been requested. Can either be a ListBarItem or a ListBarGroup (or a subclass of either).

See Also

ListBarLabelEditEventArgs Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarLabelEditEventArgs.LabelEditObject Property

Returns the object for which label editing has been requested. Can either be a ListBarItem or a ListBarGroup (or a subclass of either).

[Visual Basic]
Public ReadOnly Property LabelEditObject As Object
[C#]
public object LabelEditObject {get;}

See Also

ListBarLabelEditEventArgs Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarLabelEditEventHandler Delegate

Represents the method that handles the BeforeLabelEdit and AfterLabelEdit events of a ListBar control.

[Visual Basic]
Public Delegate Sub ListBarLabelEditEventHandler( _
ByVal sender As Object, _
ByVal e As ListBarLabelEditEventArgs _
)
[C#]
public delegate void ListBarLabelEditEventHandler(
object sender,
ListBarLabelEditEventArgs e
);

Requirements

Namespace: NETXP.Controls.Bars

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarScrollButton Class

A class which manages the behaviour and data associated with a scrolling button in the ListBar control.

For a list of all members of this type, see ListBarScrollButton Members.

System.Object
ListBarScrollButton

[Visual Basic]
NotInheritable Public Class ListBarScrollButton
Implements NETXP.Controls.Bars.IMouseHandler
[C#]
public sealed class ListBarScrollButton : IMouseHandler

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Bars

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

ListBarScrollButton Members | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarScrollButton Members

ListBarScrollButton overview

Public Instance Constructors

ListBarScrollButton Constructor Creates a new instance of this class with the specified button type (Up or Down)

Public Instance Properties

ButtonType | Gets which type of scroll button this is (Up or Down)
MouseDown | Gets/sets whether the mouse is down on this object or not.
MouseDownPoint | Gets/sets the point at which the mouse was pressed on this object.
MouseOver | Gets/sets whether the mouse is over this object or not.
Rectangle | Gets the bounding rectangle for this button.
ToolTipText | Gets/sets the tooltip text to display for this button.
Visible | Gets/sets whether this object is visible or not.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HitTest | Determines whether the specified point is within the control.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ListBarScrollButton Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarScrollButton Constructor

Creates a new instance of this class with the specified button type (Up or Down)

[Visual Basic]
Public Sub New( _
ByVal buttonType As ListBarScrollButtonType _
)
[C#]
public ListBarScrollButton(
ListBarScrollButtonType buttonType
);

Parameters

buttonType
The scroll button type to create.

See Also

ListBarScrollButton Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarScrollButton Properties

The properties of the ListBarScrollButton class are listed below. For a complete list of ListBarScrollButton class members, see the ListBarScrollButton Members topic.

Public Instance Properties

ButtonType | Gets which type of scroll button this is (Up or Down)
MouseDown | Gets/sets whether the mouse is down on this object or not.
MouseDownPoint | Gets/sets the point at which the mouse was pressed on this object.
MouseOver | Gets/sets whether the mouse is over this object or not.
Rectangle | Gets the bounding rectangle for this button.
ToolTipText | Gets/sets the tooltip text to display for this button.
Visible | Gets/sets whether this object is visible or not.

See Also

ListBarScrollButton Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarScrollButton.ButtonType Property

Gets which type of scroll button this is (Up or Down)

[Visual Basic]
Public ReadOnly Property ButtonType As ListBarScrollButtonType
[C#]
public ListBarScrollButton.ListBarScrollButtonType ButtonType {get;}

See Also

ListBarScrollButton Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarScrollButton.MouseDown Property

Gets/sets whether the mouse is down on this object or not.

[Visual Basic]
NotOverridable Public Property MouseDown As Boolean Implements _
IMouseHandler.MouseDown
[C#]
public bool MouseDown {get; set;}

Implements

IMouseHandler.MouseDown

See Also

ListBarScrollButton Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarScrollButton.MouseDownPoint Property

Gets/sets the point at which the mouse was pressed on this object.

[Visual Basic]
NotOverridable Public Property MouseDownPoint As Point Implements _
IMouseHandler.MouseDownPoint
[C#]
public System.Drawing.Point MouseDownPoint {get; set;}

Implements

IMouseHandler.MouseDownPoint

See Also

ListBarScrollButton Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarScrollButton.MouseOver Property

Gets/sets whether the mouse is over this object or not.

[Visual Basic]
NotOverridable Public Property MouseOver As Boolean Implements _
IMouseHandler.MouseOver
[C#]
public bool MouseOver {get; set;}

Implements

IMouseHandler.MouseOver

See Also

ListBarScrollButton Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarScrollButton.Rectangle Property

Gets the bounding rectangle for this button.

[Visual Basic]
Public ReadOnly Property Rectangle As Rectangle
[C#]
public System.Drawing.Rectangle Rectangle {get;}

See Also

ListBarScrollButton Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarScrollButton.ToolTipText Property

Gets/sets the tooltip text to display for this button.

[Visual Basic]
NotOverridable Public Property ToolTipText As String Implements _
IMouseHandler.ToolTipText
[C#]
public string ToolTipText {get; set;}

Implements

IMouseHandler.ToolTipText

See Also

ListBarScrollButton Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarScrollButton.Visible Property

Gets/sets whether this object is visible or not.

[Visual Basic]
Public Property Visible As Boolean
[C#]
public bool Visible {get; set;}

See Also

ListBarScrollButton Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarScrollButton Methods

The methods of the ListBarScrollButton class are listed below. For a complete list of ListBarScrollButton class members, see the ListBarScrollButton Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HitTest | Determines whether the specified point is within the control.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ListBarScrollButton Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarScrollButton.HitTest Method

Determines whether the specified point is within the control.

[Visual Basic]
Public Function HitTest( _
ByVal pt As Point _
) As Boolean
[C#]
public bool HitTest(
Point pt
);

Parameters

pt
The point to test.

Return Value

True if the point is over the button and the button is visible, false otherwise.

See Also

ListBarScrollButton Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ListBarScrollButton.ListBarScrollButtonType Enumeration

Enumeration of available scroll button types for this control.

[Visual Basic]
Public Enum ListBarScrollButton.ListBarScrollButtonType
[C#]
public enum ListBarScrollButton.ListBarScrollButtonType

Members

Member Name | Description
Up | The scroll button is an up button.
Down | The scroll button is a down button.

Requirements

Namespace: NETXP.Controls.Bars

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Margins Class

Provides a way to set up margins or padding.

For a list of all members of this type, see Margins Members.

System.Object
Margins

[Visual Basic]
Public Class Margins
[C#]
public class Margins

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Bars

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

Margins Members | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Margins Members

Margins overview

Public Instance Constructors

Margins Overloaded. Initializes a new instance of the Margins class.

Public Instance Properties

Bottom | Gets or sets the value of the bottom margin.
Left | Gets or sets the value of the left margin.
Right | Gets or sets the value of the right margin.
Top | Gets or sets the value of the top margin.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Gets a string representation of this Margins object.

Public Instance Events

Changed Called when the Margins object has changed.

See Also

Margins Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Margins Constructor

Creates a new Margins object with default values.

Overload List

Creates a new Margins object with default values.

public Margins();

Creates a new Margins object with the given values.

public Margins(int,int,int,int);

See Also

Margins Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Margins Constructor ()

Creates a new Margins object with default values.

[Visual Basic]
Overloads Public Sub New()
[C#]
public Margins();

See Also

Margins Class | NETXP.Controls.Bars Namespace | Margins Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Margins Constructor (Int32, Int32, Int32, Int32)

Creates a new Margins object with the given values.

[Visual Basic]
Overloads Public Sub New( _
ByVal left As Integer, _
ByVal top As Integer, _
ByVal right As Integer, _
ByVal bottom As Integer _
)
[C#]
public Margins(
int left,
int top,
int right,
int bottom
);

Parameters

left
The left margin.
top
The top margin.
right
The right margin.
bottom
The bottom margin.

See Also

Margins Class | NETXP.Controls.Bars Namespace | Margins Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Margins Properties

The properties of the Margins class are listed below. For a complete list of Margins class members, see the Margins Members topic.

Public Instance Properties

Bottom | Gets or sets the value of the bottom margin.
Left | Gets or sets the value of the left margin.
Right | Gets or sets the value of the right margin.
Top | Gets or sets the value of the top margin.

See Also

Margins Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Margins.Bottom Property

Gets or sets the value of the bottom margin.

[Visual Basic]
Public Property Bottom As Integer
[C#]
public int Bottom {get; set;}

See Also

Margins Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Margins.Left Property

Gets or sets the value of the left margin.

[Visual Basic]
Public Property Left As Integer
[C#]
public int Left {get; set;}

See Also

Margins Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Margins.Right Property

Gets or sets the value of the right margin.

[Visual Basic]
Public Property Right As Integer
[C#]
public int Right {get; set;}

See Also

Margins Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Margins.Top Property

Gets or sets the value of the top margin.

[Visual Basic]
Public Property Top As Integer
[C#]
public int Top {get; set;}

See Also

Margins Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Margins Methods

The methods of the Margins class are listed below. For a complete list of Margins class members, see the Margins Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Gets a string representation of this Margins object.

See Also

Margins Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Margins.ToString Method

Gets a string representation of this Margins object.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

A string representation of this Margins object.

See Also

Margins Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Margins Events

The events of the Margins class are listed below. For a complete list of Margins class members, see the Margins Members topic.

Public Instance Events

Changed Called when the Margins object has changed.

See Also

Margins Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Margins.Changed Event

Called when the Margins object has changed.

[Visual Basic]
Public Event Changed As EventHandler
[C#]
public event EventHandler Changed;

See Also

Margins Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ObjectClickedEventArgs Class

An abstract class used as the bases for the ItemClicked and GroupClicked events of the ListBar control. This class stores details of the mouse location and button.

For a list of all members of this type, see ObjectClickedEventArgs Members.

System.Object
EventArgs
ObjectClickedEventArgs

[Visual Basic]
MustInherit Public Class ObjectClickedEventArgs
Inherits EventArgs
[C#]
public abstract class ObjectClickedEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Bars

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

ObjectClickedEventArgs Members | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ObjectClickedEventArgs Members

ObjectClickedEventArgs overview

Public Instance Constructors

ObjectClickedEventArgs Constructor When used in a subclass, constructs a new instance of the class with the specified mouse location and button.

Public Instance Properties

Location | The Location of the mouse, relative to the control, when the item was clicked.
MouseButton | The MouseButton used to click the item.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ObjectClickedEventArgs Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ObjectClickedEventArgs Constructor

When used in a subclass, constructs a new instance of the class with the specified mouse location and button.

[Visual Basic]
Public Sub New( _
ByVal location As Point, _
ByVal mouseButton As MouseButtons _
)
[C#]
public ObjectClickedEventArgs(
Point location,
MouseButtons mouseButton
);

Parameters

location
The location of the mouse.
mouseButton
The button which was pressed.

See Also

ObjectClickedEventArgs Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ObjectClickedEventArgs Properties

The properties of the ObjectClickedEventArgs class are listed below. For a complete list of ObjectClickedEventArgs class members, see the ObjectClickedEventArgs Members topic.

Public Instance Properties

Location | The Location of the mouse, relative to the control, when the item was clicked.
MouseButton | The MouseButton used to click the item.

See Also

ObjectClickedEventArgs Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ObjectClickedEventArgs.Location Property

The Location of the mouse, relative to the control, when the item was clicked.

[Visual Basic]
Public ReadOnly Property Location As Point
[C#]
public System.Drawing.Point Location {get;}

See Also

ObjectClickedEventArgs Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ObjectClickedEventArgs.MouseButton Property

The MouseButton used to click the item.

[Visual Basic]
Public ReadOnly Property MouseButton As MouseButtons
[C#]
public System.Windows.Forms.MouseButtons MouseButton {get;}

See Also

ObjectClickedEventArgs Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ProgressPanel Class

Provides a progress bar panel for the NetXP status bar.

For a list of all members of this type, see ProgressPanel Members.

System.Object
MarshalByRefObject
Component
StatusBarPanel
ProgressPanel

[Visual Basic]
NotInheritable Public Class ProgressPanel
Inherits StatusBarPanel
[C#]
public sealed class ProgressPanel : StatusBarPanel

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Bars

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

ProgressPanel Members | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ProgressPanel Members

ProgressPanel overview

Public Instance Constructors

ProgressPanel Constructor Constructs a new ProgressPanel.

Public Instance Properties

Alignment (inherited from StatusBarPanel) | Gets or sets the alignment of text and icons within the status bar panel.
AutoSize (inherited from StatusBarPanel) | Gets or sets a value indicating whether the status bar panel is autosized.
BorderStyle (inherited from StatusBarPanel) | Gets or sets the border style of the status bar panel.
Container (inherited from Component) | Gets the IContainer that contains the Component.
Icon (inherited from StatusBarPanel) | Gets or sets the icon to display within the status bar panel.
Maximum | Gets or sets the maximum value for the progress bar.
Minimum | Gets or sets the minimum value for the progress bar.
MinWidth (inherited from StatusBarPanel) | Gets or sets the minimum allowed width of the status bar panel within the StatusBar control.
Parent (inherited from StatusBarPanel) | Gets the StatusBar control that hosts the status bar panel.
Site (inherited from Component) | Gets or sets the ISite of the Component.
Style (inherited from StatusBarPanel) | Gets or sets the style of the status bar panel.
Text (inherited from StatusBarPanel) | Gets or sets the text of the status bar panel.
ToolTipText (inherited from StatusBarPanel) | Gets or sets ToolTip text associated with the status bar panel.
Value | Gets or sets the actual value of the progress bar.
Width (inherited from StatusBarPanel) | Gets or sets the width of the status bar panel within the StatusBar control.

Public Instance Methods

BeginInit (inherited from StatusBarPanel) |
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
EndInit (inherited from StatusBarPanel) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
ToString (inherited from StatusBarPanel) |

Public Instance Events

Disposed (inherited from Component) Adds an event handler to listen to the Disposed event on the component.

See Also

ProgressPanel Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ProgressPanel Constructor

Constructs a new ProgressPanel.

[Visual Basic]
Public Sub New()
[C#]
public ProgressPanel();

See Also

ProgressPanel Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ProgressPanel Properties

The properties of the ProgressPanel class are listed below. For a complete list of ProgressPanel class members, see the ProgressPanel Members topic.

Public Instance Properties

Alignment (inherited from StatusBarPanel) | Gets or sets the alignment of text and icons within the status bar panel.
AutoSize (inherited from StatusBarPanel) | Gets or sets a value indicating whether the status bar panel is autosized.
BorderStyle (inherited from StatusBarPanel) | Gets or sets the border style of the status bar panel.
Container (inherited from Component) | Gets the IContainer that contains the Component.
Icon (inherited from StatusBarPanel) | Gets or sets the icon to display within the status bar panel.
Maximum | Gets or sets the maximum value for the progress bar.
Minimum | Gets or sets the minimum value for the progress bar.
MinWidth (inherited from StatusBarPanel) | Gets or sets the minimum allowed width of the status bar panel within the StatusBar control.
Parent (inherited from StatusBarPanel) | Gets the StatusBar control that hosts the status bar panel.
Site (inherited from Component) | Gets or sets the ISite of the Component.
Style (inherited from StatusBarPanel) | Gets or sets the style of the status bar panel.
Text (inherited from StatusBarPanel) | Gets or sets the text of the status bar panel.
ToolTipText (inherited from StatusBarPanel) | Gets or sets ToolTip text associated with the status bar panel.
Value | Gets or sets the actual value of the progress bar.
Width (inherited from StatusBarPanel) | Gets or sets the width of the status bar panel within the StatusBar control.

See Also

ProgressPanel Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ProgressPanel.Maximum Property

Gets or sets the maximum value for the progress bar.

[Visual Basic]
Public Property Maximum As Integer
[C#]
public int Maximum {get; set;}

See Also

ProgressPanel Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ProgressPanel.Minimum Property

Gets or sets the minimum value for the progress bar.

[Visual Basic]
Public Property Minimum As Integer
[C#]
public int Minimum {get; set;}

See Also

ProgressPanel Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


ProgressPanel.Value Property

Gets or sets the actual value of the progress bar.

[Visual Basic]
Public Property Value As Integer
[C#]
public int Value {get; set;}

See Also

ProgressPanel Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


SetupChevronMenuEventArgs Class

Event arguments for the SetupChevronMenu event.

For a list of all members of this type, see SetupChevronMenuEventArgs Members.

System.Object
EventArgs
SetupChevronMenuEventArgs

[Visual Basic]
Public Class SetupChevronMenuEventArgs
Inherits EventArgs
[C#]
public class SetupChevronMenuEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Bars

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

SetupChevronMenuEventArgs Members | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


SetupChevronMenuEventArgs Members

SetupChevronMenuEventArgs overview

Public Instance Constructors

SetupChevronMenuEventArgs Constructor Constructs a SetupChevronMenuEventArgs object.

Public Instance Properties

Items The items shown in the chevron menu.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

SetupChevronMenuEventArgs Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


SetupChevronMenuEventArgs Constructor

Constructs a SetupChevronMenuEventArgs object.

[Visual Basic]
Public Sub New( _
ByVal items As CommandBarItemCollection _
)
[C#]
public SetupChevronMenuEventArgs(
CommandBarItemCollection items
);

Parameters

items
The items shown in the chevron menu. The last two items can be removed if desired.

See Also

SetupChevronMenuEventArgs Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


SetupChevronMenuEventArgs Properties

The properties of the SetupChevronMenuEventArgs class are listed below. For a complete list of SetupChevronMenuEventArgs class members, see the SetupChevronMenuEventArgs Members topic.

Public Instance Properties

Items The items shown in the chevron menu.

See Also

SetupChevronMenuEventArgs Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


SetupChevronMenuEventArgs.Items Property

The items shown in the chevron menu.

[Visual Basic]
Public ReadOnly Property Items As CommandBarItemCollection
[C#]
public CommandBarItemCollection Items {get;}

See Also

SetupChevronMenuEventArgs Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


SetupChevronMenuEventHandler Delegate

Event handler for the SetupChevronMenu event.

[Visual Basic]
Public Delegate Sub SetupChevronMenuEventHandler( _
ByVal sender As Object, _
ByVal args As SetupChevronMenuEventArgs _
)
[C#]
public delegate void SetupChevronMenuEventHandler(
object sender,
SetupChevronMenuEventArgs args
);

Requirements

Namespace: NETXP.Controls.Bars

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


StatusBar Class

The extended status bar control supporting custom renderers and progress bars.

For a list of all members of this type, see StatusBar Members.

System.Object
MarshalByRefObject
Component
Control
StatusBar
StatusBar

[Visual Basic]
NotInheritable Public Class StatusBar
Inherits StatusBar
Implements NETXP.Library.IStatusMessageAcceptor
[C#]
public sealed class StatusBar : StatusBar, IStatusMessageAcceptor

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Bars

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

StatusBar Members | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


StatusBar Members

StatusBar overview

Public Instance Constructors

StatusBar Constructor Constructs a new StatusBar.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from StatusBar) |
BackgroundImage (inherited from StatusBar) |
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock | Gets or sets the position and manner in which the status bar is docked.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from StatusBar) |
ForeColor (inherited from StatusBar) |
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from StatusBar) |
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Panels (inherited from StatusBar) | Gets the collection of StatusBar panels contained within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Renderer | Gets or sets the renderer associated with this status bar.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShowPanels (inherited from StatusBar) | Gets or sets a value indicating whether any panels that have been added to the control are displayed.
ShowSizeGrip | Show the sizing grip to the right of the status bar?
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizingGrip (inherited from StatusBar) | Gets or sets a value indicating whether a sizing grip is displayed in the lower-right corner of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from StatusBar) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from StatusBar) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ClearStatusText | IStatusMessageAcceptor method.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetStatusText | IStatusMessageAcceptor method.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from StatusBar) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

BackColorChanged (inherited from StatusBar) |
BackgroundImageChanged (inherited from StatusBar) |
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
DrawItem (inherited from StatusBar) | Occurs when a visual aspect of an owner-drawn status bar control changes.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from StatusBar) |
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from StatusBar) |
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from StatusBar) |
PanelClick (inherited from StatusBar) | Occurs when a StatusBarPanel object on a StatusBar control is clicked.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

StatusBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


StatusBar Constructor

Constructs a new StatusBar.

[Visual Basic]
Public Sub New()
[C#]
public StatusBar();

See Also

StatusBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


StatusBar Properties

The properties of the StatusBar class are listed below. For a complete list of StatusBar class members, see the StatusBar Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from StatusBar) |
BackgroundImage (inherited from StatusBar) |
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock | Gets or sets the position and manner in which the status bar is docked.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from StatusBar) |
ForeColor (inherited from StatusBar) |
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from StatusBar) |
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Panels (inherited from StatusBar) | Gets the collection of StatusBar panels contained within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Renderer | Gets or sets the renderer associated with this status bar.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShowPanels (inherited from StatusBar) | Gets or sets a value indicating whether any panels that have been added to the control are displayed.
ShowSizeGrip | Show the sizing grip to the right of the status bar?
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizingGrip (inherited from StatusBar) | Gets or sets a value indicating whether a sizing grip is displayed in the lower-right corner of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from StatusBar) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from StatusBar) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

See Also

StatusBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


StatusBar.Dock Property

Gets or sets the position and manner in which the status bar is docked.

[Visual Basic]
Overrides Public Property Dock As DockStyle
[C#]
public override System.Windows.Forms.DockStyle Dock {get; set;}

See Also

StatusBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


StatusBar.Renderer Property

Gets or sets the renderer associated with this status bar.

[Visual Basic]
Public Property Renderer As IStatusBarRenderer
[C#]
public IStatusBarRenderer Renderer {get; set;}

See Also

StatusBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


StatusBar.ShowSizeGrip Property

Show the sizing grip to the right of the status bar?

[Visual Basic]
Public Property ShowSizeGrip As Boolean
[C#]
public bool ShowSizeGrip {get; set;}

See Also

StatusBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


StatusBar Methods

The methods of the StatusBar class are listed below. For a complete list of StatusBar class members, see the StatusBar Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ClearStatusText | IStatusMessageAcceptor method.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetStatusText | IStatusMessageAcceptor method.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from StatusBar) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

See Also

StatusBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


StatusBar.ClearStatusText Method

IStatusMessageAcceptor method.

[Visual Basic]
NotOverridable Public Sub ClearStatusText() Implements _
IStatusMessageAcceptor.ClearStatusText
[C#]
public void ClearStatusText();

Implements

IStatusMessageAcceptor.ClearStatusText

See Also

StatusBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


StatusBar.SetStatusText Method

IStatusMessageAcceptor method.

[Visual Basic]
NotOverridable Public Sub SetStatusText( _
ByVal text As String _
) Implements _
IStatusMessageAcceptor.SetStatusText
[C#]
public void SetStatusText(
string text
);

Parameters

text

Implements

IStatusMessageAcceptor.SetStatusText

See Also

StatusBar Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


TornOffEventArgs Class

Event arguments for the TornOff event.

For a list of all members of this type, see TornOffEventArgs Members.

System.Object
EventArgs
TornOffEventArgs

[Visual Basic]
Public Class TornOffEventArgs
Inherits EventArgs
[C#]
public class TornOffEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Bars

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

TornOffEventArgs Members | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


TornOffEventArgs Members

TornOffEventArgs overview

Public Instance Constructors

TornOffEventArgs Constructor Constructs a TornOffEventArgs object.

Public Instance Properties

DockForm The floating form.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

TornOffEventArgs Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


TornOffEventArgs Constructor

Constructs a TornOffEventArgs object.

[Visual Basic]
Public Sub New( _
ByVal dockForm As FloatingForm _
)
[C#]
public TornOffEventArgs(
FloatingForm dockForm
);

Parameters

dockForm
The floating form.

See Also

TornOffEventArgs Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


TornOffEventArgs Properties

The properties of the TornOffEventArgs class are listed below. For a complete list of TornOffEventArgs class members, see the TornOffEventArgs Members topic.

Public Instance Properties

DockForm The floating form.

See Also

TornOffEventArgs Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


TornOffEventArgs.DockForm Property

The floating form.

[Visual Basic]
Public ReadOnly Property DockForm As FloatingForm
[C#]
public FloatingForm DockForm {get;}

See Also

TornOffEventArgs Class | NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


TornOffEventHandler Delegate

Event handler for the TornOff event.

[Visual Basic]
Public Delegate Sub TornOffEventHandler( _
ByVal sender As Object, _
ByVal args As TornOffEventArgs _
)
[C#]
public delegate void TornOffEventHandler(
object sender,
TornOffEventArgs args
);

Requirements

Namespace: NETXP.Controls.Bars

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

NETXP.Controls.Bars Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


NETXP.Controls.Bars.CommandBarRenderers

NetXP 3.0 Reference

NETXP.Controls.Bars.CommandBarRenderers Namespace

Classes

Class | Description
Office2003 | Provides the Office 2003 look and feel.
OfficeXP | Provides the Office XP look and feel.
WindowsDefault | Provides the Windows Default look and feel.


Office2003 Class

Provides the Office 2003 look and feel.

For a list of all members of this type, see Office2003 Members.

System.Object
Office2003

[Visual Basic]
NotInheritable Public Class Office2003
Implements NETXP.Controls.Bars.ICommandBarRenderer
[C#]
public sealed class Office2003 : ICommandBarRenderer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Bars.CommandBarRenderers

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

Office2003 Members | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Office2003 Members

Office2003 overview

Public Instance Constructors

Office2003 Overloaded. Initializes a new instance of the Office2003 class.

Public Instance Properties

ColorTable Internal. See ICommandBarRenderer

Public Instance Methods

DrawButtonItem | Internal. See ICommandBarRenderer
DrawComboBox | Internal. See ICommandBarRenderer
DrawCommandBarBackground | Internal. See ICommandBarRenderer
DrawContainerBackground | Internal. See ICommandBarRenderer
DrawExpansionItem | Internal. See ICommandBarRenderer
DrawFloatingWindowBackground | Internal. See ICommandBarRenderer
DrawFloatingWindowButton | Internal. See ICommandBarRenderer
DrawGripper | Internal. See ICommandBarRenderer
DrawLabelItem | Internal. See ICommandBarRenderer
DrawMenuBackground | Internal. See ICommandBarRenderer
DrawMenuButtonItem | Internal. See ICommandBarRenderer
DrawMenuExpansionItem | Internal. See ICommandBarRenderer
DrawMenuLabelItem | Internal. See ICommandBarRenderer
DrawMenuScrollArrow | Internal. See ICommandBarRenderer
DrawMenuSeparatorItem | Internal. See ICommandBarRenderer
DrawMenuShadowHorizontal | Internal. See ICommandBarRenderer
DrawMenuShadowVertical | Internal. See ICommandBarRenderer
DrawSeparatorItem | Internal. See ICommandBarRenderer
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateColorTable | Internal. See ICommandBarRenderer

See Also

Office2003 Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Office2003 Constructor

Internal. See ICommandBarRenderer

Overload List

Internal. See ICommandBarRenderer

public Office2003();

Internal. See ICommandBarRenderer

public Office2003(IColorTable);

See Also

Office2003 Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Office2003 Constructor ()

Internal. See ICommandBarRenderer

[Visual Basic]
Overloads Public Sub New()
[C#]
public Office2003();

See Also

Office2003 Class | NETXP.Controls.Bars.CommandBarRenderers Namespace | Office2003 Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Office2003 Constructor (IColorTable)

Internal. See ICommandBarRenderer

[Visual Basic]
Overloads Public Sub New( _
ByVal colorTable As IColorTable _
)
[C#]
public Office2003(
IColorTable colorTable
);

Parameters

colorTable

See Also

Office2003 Class | NETXP.Controls.Bars.CommandBarRenderers Namespace | Office2003 Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Office2003 Properties

The properties of the Office2003 class are listed below. For a complete list of Office2003 class members, see the Office2003 Members topic.

Public Instance Properties

ColorTable Internal. See ICommandBarRenderer

See Also

Office2003 Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Office2003.ColorTable Property

Internal. See ICommandBarRenderer

[Visual Basic]
Public Property ColorTable As IColorTable
[C#]
public NETXP.Library.IColorTable ColorTable {get; set;}

See Also

Office2003 Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Office2003 Methods

The methods of the Office2003 class are listed below. For a complete list of Office2003 class members, see the Office2003 Members topic.

Public Instance Methods

DrawButtonItem | Internal. See ICommandBarRenderer
DrawComboBox | Internal. See ICommandBarRenderer
DrawCommandBarBackground | Internal. See ICommandBarRenderer
DrawContainerBackground | Internal. See ICommandBarRenderer
DrawExpansionItem | Internal. See ICommandBarRenderer
DrawFloatingWindowBackground | Internal. See ICommandBarRenderer
DrawFloatingWindowButton | Internal. See ICommandBarRenderer
DrawGripper | Internal. See ICommandBarRenderer
DrawLabelItem | Internal. See ICommandBarRenderer
DrawMenuBackground | Internal. See ICommandBarRenderer
DrawMenuButtonItem | Internal. See ICommandBarRenderer
DrawMenuExpansionItem | Internal. See ICommandBarRenderer
DrawMenuLabelItem | Internal. See ICommandBarRenderer
DrawMenuScrollArrow | Internal. See ICommandBarRenderer
DrawMenuSeparatorItem | Internal. See ICommandBarRenderer
DrawMenuShadowHorizontal | Internal. See ICommandBarRenderer
DrawMenuShadowVertical | Internal. See ICommandBarRenderer
DrawSeparatorItem | Internal. See ICommandBarRenderer
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateColorTable | Internal. See ICommandBarRenderer

See Also

Office2003 Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Office2003.DrawButtonItem Method

Internal. See ICommandBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawButtonItem( _
ByVal item As CommandBarButtonItem, _
ByVal bar As CommandBar, _
ByVal g As Graphics, _
ByVal state As DrawItemState, _
ByVal rc As Rectangle, _
ByVal dropDown As Boolean _
) Implements _
ICommandBarRenderer.DrawButtonItem
[C#]
public void DrawButtonItem(
CommandBarButtonItem item,
CommandBar bar,
Graphics g,
DrawItemState state,
Rectangle rc,
bool dropDown
);

Parameters

item
bar
g
state
rc
dropDown

Implements

ICommandBarRenderer.DrawButtonItem

See Also

Office2003 Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Office2003.DrawComboBox Method

Internal. See ICommandBarRenderer

[Visual Basic]
NotOverridable Public Function DrawComboBox( _
ByVal box As ComboBox, _
ByVal gi As Graphics, _
ByVal rect As Rectangle, _
ByVal enabled As Boolean, _
ByVal rightToLeft As Boolean, _
ByVal drawStyle As DrawStyle _
) As Boolean Implements _
ICommandBarRenderer.DrawComboBox
[C#]
public bool DrawComboBox(
ComboBox box,
Graphics gi,
Rectangle rect,
bool enabled,
bool rightToLeft,
DrawStyle drawStyle
);

Parameters

box
gi
rect
enabled
rightToLeft
drawStyle

Return Value

Implements

ICommandBarRenderer.DrawComboBox

See Also

Office2003 Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Office2003.DrawCommandBarBackground Method

Internal. See ICommandBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawCommandBarBackground( _
ByVal bar As CommandBar, _
ByVal g As Graphics, _
ByVal rect As Rectangle, _
ByVal vertical As Boolean _
) Implements _
ICommandBarRenderer.DrawCommandBarBackground
[C#]
public void DrawCommandBarBackground(
CommandBar bar,
Graphics g,
Rectangle rect,
bool vertical
);

Parameters

bar
g
rect
vertical

Implements

ICommandBarRenderer.DrawCommandBarBackground

See Also

Office2003 Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Office2003.DrawContainerBackground Method

Internal. See ICommandBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawContainerBackground( _
ByVal dock As CommandBarDock, _
ByVal g As Graphics, _
ByVal clip As Rectangle _
) Implements _
ICommandBarRenderer.DrawContainerBackground
[C#]
public void DrawContainerBackground(
CommandBarDock dock,
Graphics g,
Rectangle clip
);

Parameters

dock
g
clip

Implements

ICommandBarRenderer.DrawContainerBackground

See Also

Office2003 Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Office2003.DrawExpansionItem Method

Internal. See ICommandBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawExpansionItem( _
ByVal item As CommandBarExpansionItem, _
ByVal bar As CommandBar, _
ByVal g As Graphics, _
ByVal state As DrawItemState, _
ByVal rect As Rectangle, _
ByVal dropDown As Boolean, _
ByVal chevron As Boolean _
) Implements _
ICommandBarRenderer.DrawExpansionItem
[C#]
public void DrawExpansionItem(
CommandBarExpansionItem item,
CommandBar bar,
Graphics g,
DrawItemState state,
Rectangle rect,
bool dropDown,
bool chevron
);

Parameters

item
bar
g
state
rect
dropDown
chevron

Implements

ICommandBarRenderer.DrawExpansionItem

See Also

Office2003 Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Office2003.DrawFloatingWindowBackground Method

Internal. See ICommandBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawFloatingWindowBackground( _
ByVal form As FloatingForm, _
ByVal bar As CommandBar, _
ByVal g As Graphics _
) Implements _
ICommandBarRenderer.DrawFloatingWindowBackground
[C#]
public void DrawFloatingWindowBackground(
FloatingForm form,
CommandBar bar,
Graphics g
);

Parameters

form
bar
g

Implements

ICommandBarRenderer.DrawFloatingWindowBackground

See Also

Office2003 Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Office2003.DrawFloatingWindowButton Method

Internal. See ICommandBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawFloatingWindowButton( _
ByVal form As FloatingForm, _
ByVal bar As CommandBar, _
ByVal g As Graphics, _
ByVal rect As Rectangle, _
ByVal state As DrawItemState _
) Implements _
ICommandBarRenderer.DrawFloatingWindowButton
[C#]
public void DrawFloatingWindowButton(
FloatingForm form,
CommandBar bar,
Graphics g,
Rectangle rect,
DrawItemState state
);

Parameters

form
bar
g
rect
state

Implements

ICommandBarRenderer.DrawFloatingWindowButton

See Also

Office2003 Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Office2003.DrawGripper Method

Internal. See ICommandBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawGripper( _
ByVal bar As CommandBar, _
ByVal g As Graphics, _
ByVal gripRect As Rectangle, _
ByVal vertical As Boolean _
) Implements _
ICommandBarRenderer.DrawGripper
[C#]
public void DrawGripper(
CommandBar bar,
Graphics g,
Rectangle gripRect,
bool vertical
);

Parameters

bar
g
gripRect
vertical

Implements

ICommandBarRenderer.DrawGripper

See Also

Office2003 Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Office2003.DrawLabelItem Method

Internal. See ICommandBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawLabelItem( _
ByVal item As CommandBarLabelItem, _
ByVal bar As CommandBar, _
ByVal g As Graphics, _
ByVal rc As Rectangle _
) Implements _
ICommandBarRenderer.DrawLabelItem
[C#]
public void DrawLabelItem(
CommandBarLabelItem item,
CommandBar bar,
Graphics g,
Rectangle rc
);

Parameters

item
bar
g
rc

Implements

ICommandBarRenderer.DrawLabelItem

See Also

Office2003 Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Office2003.DrawMenuBackground Method

Internal. See ICommandBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawMenuBackground( _
ByVal g As Graphics, _
ByVal rect As Rectangle, _
ByVal menuGapLocation As Point, _
ByVal menuGapSize As Integer _
) Implements _
ICommandBarRenderer.DrawMenuBackground
[C#]
public void DrawMenuBackground(
Graphics g,
Rectangle rect,
Point menuGapLocation,
int menuGapSize
);

Parameters

g
rect
menuGapLocation
menuGapSize

Implements

ICommandBarRenderer.DrawMenuBackground

See Also

Office2003 Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Office2003.DrawMenuButtonItem Method

Internal. See ICommandBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawMenuButtonItem( _
ByVal item As CommandBarButtonItem, _
ByVal menu As CommandContextMenu, _
ByVal g As Graphics, _
ByVal state As DrawItemState, _
ByVal bounds As Rectangle _
) Implements _
ICommandBarRenderer.DrawMenuButtonItem
[C#]
public void DrawMenuButtonItem(
CommandBarButtonItem item,
CommandContextMenu menu,
Graphics g,
DrawItemState state,
Rectangle bounds
);

Parameters

item
menu
g
state
bounds

Implements

ICommandBarRenderer.DrawMenuButtonItem

See Also

Office2003 Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Office2003.DrawMenuExpansionItem Method

Internal. See ICommandBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawMenuExpansionItem( _
ByVal item As CommandBarExpansionItem, _
ByVal menu As CommandContextMenu, _
ByVal g As Graphics, _
ByVal state As DrawItemState, _
ByVal bounds As Rectangle _
) Implements _
ICommandBarRenderer.DrawMenuExpansionItem
[C#]
public void DrawMenuExpansionItem(
CommandBarExpansionItem item,
CommandContextMenu menu,
Graphics g,
DrawItemState state,
Rectangle bounds
);

Parameters

item
menu
g
state
bounds

Implements

ICommandBarRenderer.DrawMenuExpansionItem

See Also

Office2003 Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Office2003.DrawMenuLabelItem Method

Internal. See ICommandBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawMenuLabelItem( _
ByVal item As CommandBarLabelItem, _
ByVal menu As CommandContextMenu, _
ByVal g As Graphics, _
ByVal bounds As Rectangle _
) Implements _
ICommandBarRenderer.DrawMenuLabelItem
[C#]
public void DrawMenuLabelItem(
CommandBarLabelItem item,
CommandContextMenu menu,
Graphics g,
Rectangle bounds
);

Parameters

item
menu
g
bounds

Implements

ICommandBarRenderer.DrawMenuLabelItem

See Also

Office2003 Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Office2003.DrawMenuScrollArrow Method

Internal. See ICommandBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawMenuScrollArrow( _
ByVal bounds As Rectangle, _
ByVal g As Graphics, _
ByVal up As Boolean _
) Implements _
ICommandBarRenderer.DrawMenuScrollArrow
[C#]
public void DrawMenuScrollArrow(
Rectangle bounds,
Graphics g,
bool up
);

Parameters

bounds
g
up

Implements

ICommandBarRenderer.DrawMenuScrollArrow

See Also

Office2003 Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Office2003.DrawMenuSeparatorItem Method

Internal. See ICommandBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawMenuSeparatorItem( _
ByVal item As CommandBarSeparatorItem, _
ByVal menu As CommandContextMenu, _
ByVal g As Graphics, _
ByVal bounds As Rectangle _
) Implements _
ICommandBarRenderer.DrawMenuSeparatorItem
[C#]
public void DrawMenuSeparatorItem(
CommandBarSeparatorItem item,
CommandContextMenu menu,
Graphics g,
Rectangle bounds
);

Parameters

item
menu
g
bounds

Implements

ICommandBarRenderer.DrawMenuSeparatorItem

See Also

Office2003 Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Office2003.DrawMenuShadowHorizontal Method

Internal. See ICommandBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawMenuShadowHorizontal( _
ByVal gr As Graphics, _
ByVal rect As Rectangle, _
ByVal menuGapLocation As Point, _
ByVal menuGapSize As Integer _
) Implements _
ICommandBarRenderer.DrawMenuShadowHorizontal
[C#]
public void DrawMenuShadowHorizontal(
Graphics gr,
Rectangle rect,
Point menuGapLocation,
int menuGapSize
);

Parameters

gr
rect
menuGapLocation
menuGapSize

Implements

ICommandBarRenderer.DrawMenuShadowHorizontal

See Also

Office2003 Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Office2003.DrawMenuShadowVertical Method

Internal. See ICommandBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawMenuShadowVertical( _
ByVal gr As Graphics, _
ByVal rect As Rectangle _
) Implements _
ICommandBarRenderer.DrawMenuShadowVertical
[C#]
public void DrawMenuShadowVertical(
Graphics gr,
Rectangle rect
);

Parameters

gr
rect

Implements

ICommandBarRenderer.DrawMenuShadowVertical

See Also

Office2003 Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Office2003.DrawSeparatorItem Method

Internal. See ICommandBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawSeparatorItem( _
ByVal item As CommandBarSeparatorItem, _
ByVal bar As CommandBar, _
ByVal g As Graphics, _
ByVal rect As Rectangle _
) Implements _
ICommandBarRenderer.DrawSeparatorItem
[C#]
public void DrawSeparatorItem(
CommandBarSeparatorItem item,
CommandBar bar,
Graphics g,
Rectangle rect
);

Parameters

item
bar
g
rect

Implements

ICommandBarRenderer.DrawSeparatorItem

See Also

Office2003 Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Office2003.UpdateColorTable Method

Internal. See ICommandBarRenderer

[Visual Basic]
NotOverridable Public Sub UpdateColorTable() Implements _
ICommandBarRenderer.UpdateColorTable
[C#]
public void UpdateColorTable();

Implements

ICommandBarRenderer.UpdateColorTable

See Also

Office2003 Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


OfficeXP Class

Provides the Office XP look and feel.

For a list of all members of this type, see OfficeXP Members.

System.Object
OfficeXP

[Visual Basic]
NotInheritable Public Class OfficeXP
Implements NETXP.Controls.Bars.ICommandBarRenderer
[C#]
public sealed class OfficeXP : ICommandBarRenderer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Bars.CommandBarRenderers

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

OfficeXP Members | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


OfficeXP Members

OfficeXP overview

Public Instance Constructors

OfficeXP Overloaded. Initializes a new instance of the OfficeXP class.

Public Instance Properties

ColorTable Internal. See ICommandBarRenderer

Public Instance Methods

DrawButtonItem | Internal. See ICommandBarRenderer
DrawComboBox | Internal. See ICommandBarRenderer
DrawCommandBarBackground | Internal. See ICommandBarRenderer
DrawContainerBackground | Internal. See ICommandBarRenderer
DrawExpansionItem | Internal. See ICommandBarRenderer
DrawFloatingWindowBackground | Internal. See ICommandBarRenderer
DrawFloatingWindowButton | Internal. See ICommandBarRenderer
DrawGripper | Internal. See ICommandBarRenderer
DrawLabelItem | Internal. See ICommandBarRenderer
DrawMenuBackground | Internal. See ICommandBarRenderer
DrawMenuButtonItem | Internal. See ICommandBarRenderer
DrawMenuExpansionItem | Internal. See ICommandBarRenderer
DrawMenuLabelItem | Internal. See ICommandBarRenderer
DrawMenuScrollArrow | Internal. See ICommandBarRenderer
DrawMenuSeparatorItem | Internal. See ICommandBarRenderer
DrawMenuShadowHorizontal | Internal. See ICommandBarRenderer
DrawMenuShadowVertical | Internal. See ICommandBarRenderer
DrawSeparatorItem | Internal. See ICommandBarRenderer
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateColorTable | Internal. See ICommandBarRenderer

See Also

OfficeXP Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


OfficeXP Constructor

Internal. See ICommandBarRenderer

Overload List

Internal. See ICommandBarRenderer

public OfficeXP();

Internal. See ICommandBarRenderer

public OfficeXP(IColorTable);

See Also

OfficeXP Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


OfficeXP Constructor ()

Internal. See ICommandBarRenderer

[Visual Basic]
Overloads Public Sub New()
[C#]
public OfficeXP();

See Also

OfficeXP Class | NETXP.Controls.Bars.CommandBarRenderers Namespace | OfficeXP Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


OfficeXP Constructor (IColorTable)

Internal. See ICommandBarRenderer

[Visual Basic]
Overloads Public Sub New( _
ByVal colorTable As IColorTable _
)
[C#]
public OfficeXP(
IColorTable colorTable
);

Parameters

colorTable

See Also

OfficeXP Class | NETXP.Controls.Bars.CommandBarRenderers Namespace | OfficeXP Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


OfficeXP Properties

The properties of the OfficeXP class are listed below. For a complete list of OfficeXP class members, see the OfficeXP Members topic.

Public Instance Properties

ColorTable Internal. See ICommandBarRenderer

See Also

OfficeXP Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


OfficeXP.ColorTable Property

Internal. See ICommandBarRenderer

[Visual Basic]
Public Property ColorTable As IColorTable
[C#]
public NETXP.Library.IColorTable ColorTable {get; set;}

See Also

OfficeXP Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


OfficeXP Methods

The methods of the OfficeXP class are listed below. For a complete list of OfficeXP class members, see the OfficeXP Members topic.

Public Instance Methods

DrawButtonItem | Internal. See ICommandBarRenderer
DrawComboBox | Internal. See ICommandBarRenderer
DrawCommandBarBackground | Internal. See ICommandBarRenderer
DrawContainerBackground | Internal. See ICommandBarRenderer
DrawExpansionItem | Internal. See ICommandBarRenderer
DrawFloatingWindowBackground | Internal. See ICommandBarRenderer
DrawFloatingWindowButton | Internal. See ICommandBarRenderer
DrawGripper | Internal. See ICommandBarRenderer
DrawLabelItem | Internal. See ICommandBarRenderer
DrawMenuBackground | Internal. See ICommandBarRenderer
DrawMenuButtonItem | Internal. See ICommandBarRenderer
DrawMenuExpansionItem | Internal. See ICommandBarRenderer
DrawMenuLabelItem | Internal. See ICommandBarRenderer
DrawMenuScrollArrow | Internal. See ICommandBarRenderer
DrawMenuSeparatorItem | Internal. See ICommandBarRenderer
DrawMenuShadowHorizontal | Internal. See ICommandBarRenderer
DrawMenuShadowVertical | Internal. See ICommandBarRenderer
DrawSeparatorItem | Internal. See ICommandBarRenderer
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateColorTable | Internal. See ICommandBarRenderer

See Also

OfficeXP Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


OfficeXP.DrawButtonItem Method

Internal. See ICommandBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawButtonItem( _
ByVal item As CommandBarButtonItem, _
ByVal bar As CommandBar, _
ByVal g As Graphics, _
ByVal state As DrawItemState, _
ByVal rc As Rectangle, _
ByVal dropDown As Boolean _
) Implements _
ICommandBarRenderer.DrawButtonItem
[C#]
public void DrawButtonItem(
CommandBarButtonItem item,
CommandBar bar,
Graphics g,
DrawItemState state,
Rectangle rc,
bool dropDown
);

Parameters

item
bar
g
state
rc
dropDown

Implements

ICommandBarRenderer.DrawButtonItem

See Also

OfficeXP Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


OfficeXP.DrawComboBox Method

Internal. See ICommandBarRenderer

[Visual Basic]
NotOverridable Public Function DrawComboBox( _
ByVal box As ComboBox, _
ByVal gi As Graphics, _
ByVal rect As Rectangle, _
ByVal enabled As Boolean, _
ByVal rightToLeft As Boolean, _
ByVal drawStyle As DrawStyle _
) As Boolean Implements _
ICommandBarRenderer.DrawComboBox
[C#]
public bool DrawComboBox(
ComboBox box,
Graphics gi,
Rectangle rect,
bool enabled,
bool rightToLeft,
DrawStyle drawStyle
);

Parameters

box
gi
rect
enabled
rightToLeft
drawStyle

Return Value

Implements

ICommandBarRenderer.DrawComboBox

See Also

OfficeXP Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


OfficeXP.DrawCommandBarBackground Method

Internal. See ICommandBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawCommandBarBackground( _
ByVal bar As CommandBar, _
ByVal g As Graphics, _
ByVal rect As Rectangle, _
ByVal vertical As Boolean _
) Implements _
ICommandBarRenderer.DrawCommandBarBackground
[C#]
public void DrawCommandBarBackground(
CommandBar bar,
Graphics g,
Rectangle rect,
bool vertical
);

Parameters

bar
g
rect
vertical

Implements

ICommandBarRenderer.DrawCommandBarBackground

See Also

OfficeXP Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


OfficeXP.DrawContainerBackground Method

Internal. See ICommandBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawContainerBackground( _
ByVal dock As CommandBarDock, _
ByVal g As Graphics, _
ByVal clip As Rectangle _
) Implements _
ICommandBarRenderer.DrawContainerBackground
[C#]
public void DrawContainerBackground(
CommandBarDock dock,
Graphics g,
Rectangle clip
);

Parameters

dock
g
clip

Implements

ICommandBarRenderer.DrawContainerBackground

See Also

OfficeXP Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


OfficeXP.DrawExpansionItem Method

Internal. See ICommandBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawExpansionItem( _
ByVal item As CommandBarExpansionItem, _
ByVal bar As CommandBar, _
ByVal g As Graphics, _
ByVal state As DrawItemState, _
ByVal rect As Rectangle, _
ByVal dropDown As Boolean, _
ByVal chevron As Boolean _
) Implements _
ICommandBarRenderer.DrawExpansionItem
[C#]
public void DrawExpansionItem(
CommandBarExpansionItem item,
CommandBar bar,
Graphics g,
DrawItemState state,
Rectangle rect,
bool dropDown,
bool chevron
);

Parameters

item
bar
g
state
rect
dropDown
chevron

Implements

ICommandBarRenderer.DrawExpansionItem

See Also

OfficeXP Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


OfficeXP.DrawFloatingWindowBackground Method

Internal. See ICommandBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawFloatingWindowBackground( _
ByVal form As FloatingForm, _
ByVal bar As CommandBar, _
ByVal g As Graphics _
) Implements _
ICommandBarRenderer.DrawFloatingWindowBackground
[C#]
public void DrawFloatingWindowBackground(
FloatingForm form,
CommandBar bar,
Graphics g
);

Parameters

form
bar
g

Implements

ICommandBarRenderer.DrawFloatingWindowBackground

See Also

OfficeXP Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


OfficeXP.DrawFloatingWindowButton Method

Internal. See ICommandBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawFloatingWindowButton( _
ByVal form As FloatingForm, _
ByVal bar As CommandBar, _
ByVal g As Graphics, _
ByVal rect As Rectangle, _
ByVal state As DrawItemState _
) Implements _
ICommandBarRenderer.DrawFloatingWindowButton
[C#]
public void DrawFloatingWindowButton(
FloatingForm form,
CommandBar bar,
Graphics g,
Rectangle rect,
DrawItemState state
);

Parameters

form
bar
g
rect
state

Implements

ICommandBarRenderer.DrawFloatingWindowButton

See Also

OfficeXP Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


OfficeXP.DrawGripper Method

Internal. See ICommandBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawGripper( _
ByVal bar As CommandBar, _
ByVal g As Graphics, _
ByVal gripRect As Rectangle, _
ByVal vertical As Boolean _
) Implements _
ICommandBarRenderer.DrawGripper
[C#]
public void DrawGripper(
CommandBar bar,
Graphics g,
Rectangle gripRect,
bool vertical
);

Parameters

bar
g
gripRect
vertical

Implements

ICommandBarRenderer.DrawGripper

See Also

OfficeXP Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


OfficeXP.DrawLabelItem Method

Internal. See ICommandBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawLabelItem( _
ByVal item As CommandBarLabelItem, _
ByVal bar As CommandBar, _
ByVal g As Graphics, _
ByVal rc As Rectangle _
) Implements _
ICommandBarRenderer.DrawLabelItem
[C#]
public void DrawLabelItem(
CommandBarLabelItem item,
CommandBar bar,
Graphics g,
Rectangle rc
);

Parameters

item
bar
g
rc

Implements

ICommandBarRenderer.DrawLabelItem

See Also

OfficeXP Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


OfficeXP.DrawMenuBackground Method

Internal. See ICommandBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawMenuBackground( _
ByVal g As Graphics, _
ByVal rect As Rectangle, _
ByVal menuGapLocation As Point, _
ByVal menuGapSize As Integer _
) Implements _
ICommandBarRenderer.DrawMenuBackground
[C#]
public void DrawMenuBackground(
Graphics g,
Rectangle rect,
Point menuGapLocation,
int menuGapSize
);

Parameters

g
rect
menuGapLocation
menuGapSize

Implements

ICommandBarRenderer.DrawMenuBackground

See Also

OfficeXP Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


OfficeXP.DrawMenuButtonItem Method

Internal. See ICommandBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawMenuButtonItem( _
ByVal item As CommandBarButtonItem, _
ByVal menu As CommandContextMenu, _
ByVal g As Graphics, _
ByVal state As DrawItemState, _
ByVal bounds As Rectangle _
) Implements _
ICommandBarRenderer.DrawMenuButtonItem
[C#]
public void DrawMenuButtonItem(
CommandBarButtonItem item,
CommandContextMenu menu,
Graphics g,
DrawItemState state,
Rectangle bounds
);

Parameters

item
menu
g
state
bounds

Implements

ICommandBarRenderer.DrawMenuButtonItem

See Also

OfficeXP Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


OfficeXP.DrawMenuExpansionItem Method

Internal. See ICommandBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawMenuExpansionItem( _
ByVal item As CommandBarExpansionItem, _
ByVal menu As CommandContextMenu, _
ByVal g As Graphics, _
ByVal state As DrawItemState, _
ByVal bounds As Rectangle _
) Implements _
ICommandBarRenderer.DrawMenuExpansionItem
[C#]
public void DrawMenuExpansionItem(
CommandBarExpansionItem item,
CommandContextMenu menu,
Graphics g,
DrawItemState state,
Rectangle bounds
);

Parameters

item
menu
g
state
bounds

Implements

ICommandBarRenderer.DrawMenuExpansionItem

See Also

OfficeXP Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


OfficeXP.DrawMenuLabelItem Method

Internal. See ICommandBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawMenuLabelItem( _
ByVal item As CommandBarLabelItem, _
ByVal menu As CommandContextMenu, _
ByVal g As Graphics, _
ByVal bounds As Rectangle _
) Implements _
ICommandBarRenderer.DrawMenuLabelItem
[C#]
public void DrawMenuLabelItem(
CommandBarLabelItem item,
CommandContextMenu menu,
Graphics g,
Rectangle bounds
);

Parameters

item
menu
g
bounds

Implements

ICommandBarRenderer.DrawMenuLabelItem

See Also

OfficeXP Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


OfficeXP.DrawMenuScrollArrow Method

Internal. See ICommandBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawMenuScrollArrow( _
ByVal bounds As Rectangle, _
ByVal g As Graphics, _
ByVal up As Boolean _
) Implements _
ICommandBarRenderer.DrawMenuScrollArrow
[C#]
public void DrawMenuScrollArrow(
Rectangle bounds,
Graphics g,
bool up
);

Parameters

bounds
g
up

Implements

ICommandBarRenderer.DrawMenuScrollArrow

See Also

OfficeXP Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


OfficeXP.DrawMenuSeparatorItem Method

Internal. See ICommandBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawMenuSeparatorItem( _
ByVal item As CommandBarSeparatorItem, _
ByVal menu As CommandContextMenu, _
ByVal g As Graphics, _
ByVal bounds As Rectangle _
) Implements _
ICommandBarRenderer.DrawMenuSeparatorItem
[C#]
public void DrawMenuSeparatorItem(
CommandBarSeparatorItem item,
CommandContextMenu menu,
Graphics g,
Rectangle bounds
);

Parameters

item
menu
g
bounds

Implements

ICommandBarRenderer.DrawMenuSeparatorItem

See Also

OfficeXP Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


OfficeXP.DrawMenuShadowHorizontal Method

Internal. See ICommandBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawMenuShadowHorizontal( _
ByVal gr As Graphics, _
ByVal rect As Rectangle, _
ByVal menuGapLocation As Point, _
ByVal menuGapSize As Integer _
) Implements _
ICommandBarRenderer.DrawMenuShadowHorizontal
[C#]
public void DrawMenuShadowHorizontal(
Graphics gr,
Rectangle rect,
Point menuGapLocation,
int menuGapSize
);

Parameters

gr
rect
menuGapLocation
menuGapSize

Implements

ICommandBarRenderer.DrawMenuShadowHorizontal

See Also

OfficeXP Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


OfficeXP.DrawMenuShadowVertical Method

Internal. See ICommandBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawMenuShadowVertical( _
ByVal gr As Graphics, _
ByVal rect As Rectangle _
) Implements _
ICommandBarRenderer.DrawMenuShadowVertical
[C#]
public void DrawMenuShadowVertical(
Graphics gr,
Rectangle rect
);

Parameters

gr
rect

Implements

ICommandBarRenderer.DrawMenuShadowVertical

See Also

OfficeXP Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


OfficeXP.DrawSeparatorItem Method

Internal. See ICommandBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawSeparatorItem( _
ByVal item As CommandBarSeparatorItem, _
ByVal bar As CommandBar, _
ByVal g As Graphics, _
ByVal rect As Rectangle _
) Implements _
ICommandBarRenderer.DrawSeparatorItem
[C#]
public void DrawSeparatorItem(
CommandBarSeparatorItem item,
CommandBar bar,
Graphics g,
Rectangle rect
);

Parameters

item
bar
g
rect

Implements

ICommandBarRenderer.DrawSeparatorItem

See Also

OfficeXP Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


OfficeXP.UpdateColorTable Method

Internal. See ICommandBarRenderer

[Visual Basic]
NotOverridable Public Sub UpdateColorTable() Implements _
ICommandBarRenderer.UpdateColorTable
[C#]
public void UpdateColorTable();

Implements

ICommandBarRenderer.UpdateColorTable

See Also

OfficeXP Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


WindowsDefault Class

Provides the Windows Default look and feel.

For a list of all members of this type, see WindowsDefault Members.

System.Object
WindowsDefault

[Visual Basic]
NotInheritable Public Class WindowsDefault
Implements NETXP.Controls.Bars.ICommandBarRenderer
[C#]
public sealed class WindowsDefault : ICommandBarRenderer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Bars.CommandBarRenderers

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

WindowsDefault Members | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


WindowsDefault Members

WindowsDefault overview

Public Instance Constructors

WindowsDefault Constructor Internal. See ICommandBarRenderer

Public Instance Methods

DrawButtonItem | Internal. See ICommandBarRenderer
DrawComboBox | Internal. See ICommandBarRenderer
DrawCommandBarBackground | Internal. See ICommandBarRenderer
DrawContainerBackground | Internal. See ICommandBarRenderer
DrawExpansionItem | Internal. See ICommandBarRenderer
DrawFloatingWindowBackground | Internal. See ICommandBarRenderer
DrawFloatingWindowButton | Internal. See ICommandBarRenderer
DrawGripper | Internal. See ICommandBarRenderer
DrawLabelItem | Internal. See ICommandBarRenderer
DrawMenuBackground | Internal. See ICommandBarRenderer
DrawMenuButtonItem | Internal. See ICommandBarRenderer
DrawMenuExpansionItem | Internal. See ICommandBarRenderer
DrawMenuLabelItem | Internal. See ICommandBarRenderer
DrawMenuScrollArrow | Internal. See ICommandBarRenderer
DrawMenuSeparatorItem | Internal. See ICommandBarRenderer
DrawMenuShadowHorizontal | Internal. See ICommandBarRenderer
DrawMenuShadowVertical | Internal. See ICommandBarRenderer
DrawSeparatorItem | Internal. See ICommandBarRenderer
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateColorTable | Internal. See ICommandBarRenderer

See Also

WindowsDefault Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


WindowsDefault Constructor

Internal. See ICommandBarRenderer

[Visual Basic]
Public Sub New()
[C#]
public WindowsDefault();

See Also

WindowsDefault Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


WindowsDefault Methods

The methods of the WindowsDefault class are listed below. For a complete list of WindowsDefault class members, see the WindowsDefault Members topic.

Public Instance Methods

DrawButtonItem | Internal. See ICommandBarRenderer
DrawComboBox | Internal. See ICommandBarRenderer
DrawCommandBarBackground | Internal. See ICommandBarRenderer
DrawContainerBackground | Internal. See ICommandBarRenderer
DrawExpansionItem | Internal. See ICommandBarRenderer
DrawFloatingWindowBackground | Internal. See ICommandBarRenderer
DrawFloatingWindowButton | Internal. See ICommandBarRenderer
DrawGripper | Internal. See ICommandBarRenderer
DrawLabelItem | Internal. See ICommandBarRenderer
DrawMenuBackground | Internal. See ICommandBarRenderer
DrawMenuButtonItem | Internal. See ICommandBarRenderer
DrawMenuExpansionItem | Internal. See ICommandBarRenderer
DrawMenuLabelItem | Internal. See ICommandBarRenderer
DrawMenuScrollArrow | Internal. See ICommandBarRenderer
DrawMenuSeparatorItem | Internal. See ICommandBarRenderer
DrawMenuShadowHorizontal | Internal. See ICommandBarRenderer
DrawMenuShadowVertical | Internal. See ICommandBarRenderer
DrawSeparatorItem | Internal. See ICommandBarRenderer
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateColorTable | Internal. See ICommandBarRenderer

See Also

WindowsDefault Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


WindowsDefault.DrawButtonItem Method

Internal. See ICommandBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawButtonItem( _
ByVal item As CommandBarButtonItem, _
ByVal bar As CommandBar, _
ByVal g As Graphics, _
ByVal state As DrawItemState, _
ByVal rc As Rectangle, _
ByVal dropDown As Boolean _
) Implements _
ICommandBarRenderer.DrawButtonItem
[C#]
public void DrawButtonItem(
CommandBarButtonItem item,
CommandBar bar,
Graphics g,
DrawItemState state,
Rectangle rc,
bool dropDown
);

Parameters

item
bar
g
state
rc
dropDown

Implements

ICommandBarRenderer.DrawButtonItem

See Also

WindowsDefault Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


WindowsDefault.DrawComboBox Method

Internal. See ICommandBarRenderer

[Visual Basic]
NotOverridable Public Function DrawComboBox( _
ByVal box As ComboBox, _
ByVal gi As Graphics, _
ByVal rect As Rectangle, _
ByVal enabled As Boolean, _
ByVal rightToLeft As Boolean, _
ByVal drawStyle As DrawStyle _
) As Boolean Implements _
ICommandBarRenderer.DrawComboBox
[C#]
public bool DrawComboBox(
ComboBox box,
Graphics gi,
Rectangle rect,
bool enabled,
bool rightToLeft,
DrawStyle drawStyle
);

Parameters

box
gi
rect
enabled
rightToLeft
drawStyle

Return Value

Implements

ICommandBarRenderer.DrawComboBox

See Also

WindowsDefault Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


WindowsDefault.DrawCommandBarBackground Method

Internal. See ICommandBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawCommandBarBackground( _
ByVal bar As CommandBar, _
ByVal g As Graphics, _
ByVal rect As Rectangle, _
ByVal vertical As Boolean _
) Implements _
ICommandBarRenderer.DrawCommandBarBackground
[C#]
public void DrawCommandBarBackground(
CommandBar bar,
Graphics g,
Rectangle rect,
bool vertical
);

Parameters

bar
g
rect
vertical

Implements

ICommandBarRenderer.DrawCommandBarBackground

See Also

WindowsDefault Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


WindowsDefault.DrawContainerBackground Method

Internal. See ICommandBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawContainerBackground( _
ByVal dock As CommandBarDock, _
ByVal g As Graphics, _
ByVal clip As Rectangle _
) Implements _
ICommandBarRenderer.DrawContainerBackground
[C#]
public void DrawContainerBackground(
CommandBarDock dock,
Graphics g,
Rectangle clip
);

Parameters

dock
g
clip

Implements

ICommandBarRenderer.DrawContainerBackground

See Also

WindowsDefault Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


WindowsDefault.DrawExpansionItem Method

Internal. See ICommandBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawExpansionItem( _
ByVal item As CommandBarExpansionItem, _
ByVal bar As CommandBar, _
ByVal g As Graphics, _
ByVal state As DrawItemState, _
ByVal rect As Rectangle, _
ByVal dropDown As Boolean, _
ByVal chevron As Boolean _
) Implements _
ICommandBarRenderer.DrawExpansionItem
[C#]
public void DrawExpansionItem(
CommandBarExpansionItem item,
CommandBar bar,
Graphics g,
DrawItemState state,
Rectangle rect,
bool dropDown,
bool chevron
);

Parameters

item
bar
g
state
rect
dropDown
chevron

Implements

ICommandBarRenderer.DrawExpansionItem

See Also

WindowsDefault Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


WindowsDefault.DrawFloatingWindowBackground Method

Internal. See ICommandBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawFloatingWindowBackground( _
ByVal form As FloatingForm, _
ByVal bar As CommandBar, _
ByVal g As Graphics _
) Implements _
ICommandBarRenderer.DrawFloatingWindowBackground
[C#]
public void DrawFloatingWindowBackground(
FloatingForm form,
CommandBar bar,
Graphics g
);

Parameters

form
bar
g

Implements

ICommandBarRenderer.DrawFloatingWindowBackground

See Also

WindowsDefault Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


WindowsDefault.DrawFloatingWindowButton Method

Internal. See ICommandBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawFloatingWindowButton( _
ByVal form As FloatingForm, _
ByVal bar As CommandBar, _
ByVal g As Graphics, _
ByVal rect As Rectangle, _
ByVal state As DrawItemState _
) Implements _
ICommandBarRenderer.DrawFloatingWindowButton
[C#]
public void DrawFloatingWindowButton(
FloatingForm form,
CommandBar bar,
Graphics g,
Rectangle rect,
DrawItemState state
);

Parameters

form
bar
g
rect
state

Implements

ICommandBarRenderer.DrawFloatingWindowButton

See Also

WindowsDefault Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


WindowsDefault.DrawGripper Method

Internal. See ICommandBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawGripper( _
ByVal bar As CommandBar, _
ByVal g As Graphics, _
ByVal gripRect As Rectangle, _
ByVal vertical As Boolean _
) Implements _
ICommandBarRenderer.DrawGripper
[C#]
public void DrawGripper(
CommandBar bar,
Graphics g,
Rectangle gripRect,
bool vertical
);

Parameters

bar
g
gripRect
vertical

Implements

ICommandBarRenderer.DrawGripper

See Also

WindowsDefault Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


WindowsDefault.DrawLabelItem Method

Internal. See ICommandBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawLabelItem( _
ByVal item As CommandBarLabelItem, _
ByVal bar As CommandBar, _
ByVal g As Graphics, _
ByVal rc As Rectangle _
) Implements _
ICommandBarRenderer.DrawLabelItem
[C#]
public void DrawLabelItem(
CommandBarLabelItem item,
CommandBar bar,
Graphics g,
Rectangle rc
);

Parameters

item
bar
g
rc

Implements

ICommandBarRenderer.DrawLabelItem

See Also

WindowsDefault Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


WindowsDefault.DrawMenuBackground Method

Internal. See ICommandBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawMenuBackground( _
ByVal g As Graphics, _
ByVal rect As Rectangle, _
ByVal menuGapLocation As Point, _
ByVal menuGapSize As Integer _
) Implements _
ICommandBarRenderer.DrawMenuBackground
[C#]
public void DrawMenuBackground(
Graphics g,
Rectangle rect,
Point menuGapLocation,
int menuGapSize
);

Parameters

g
rect
menuGapLocation
menuGapSize

Implements

ICommandBarRenderer.DrawMenuBackground

See Also

WindowsDefault Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


WindowsDefault.DrawMenuButtonItem Method

Internal. See ICommandBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawMenuButtonItem( _
ByVal item As CommandBarButtonItem, _
ByVal menu As CommandContextMenu, _
ByVal g As Graphics, _
ByVal state As DrawItemState, _
ByVal bounds As Rectangle _
) Implements _
ICommandBarRenderer.DrawMenuButtonItem
[C#]
public void DrawMenuButtonItem(
CommandBarButtonItem item,
CommandContextMenu menu,
Graphics g,
DrawItemState state,
Rectangle bounds
);

Parameters

item
menu
g
state
bounds

Implements

ICommandBarRenderer.DrawMenuButtonItem

See Also

WindowsDefault Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


WindowsDefault.DrawMenuExpansionItem Method

Internal. See ICommandBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawMenuExpansionItem( _
ByVal item As CommandBarExpansionItem, _
ByVal menu As CommandContextMenu, _
ByVal g As Graphics, _
ByVal state As DrawItemState, _
ByVal bounds As Rectangle _
) Implements _
ICommandBarRenderer.DrawMenuExpansionItem
[C#]
public void DrawMenuExpansionItem(
CommandBarExpansionItem item,
CommandContextMenu menu,
Graphics g,
DrawItemState state,
Rectangle bounds
);

Parameters

item
menu
g
state
bounds

Implements

ICommandBarRenderer.DrawMenuExpansionItem

See Also

WindowsDefault Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


WindowsDefault.DrawMenuLabelItem Method

Internal. See ICommandBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawMenuLabelItem( _
ByVal item As CommandBarLabelItem, _
ByVal menu As CommandContextMenu, _
ByVal g As Graphics, _
ByVal bounds As Rectangle _
) Implements _
ICommandBarRenderer.DrawMenuLabelItem
[C#]
public void DrawMenuLabelItem(
CommandBarLabelItem item,
CommandContextMenu menu,
Graphics g,
Rectangle bounds
);

Parameters

item
menu
g
bounds

Implements

ICommandBarRenderer.DrawMenuLabelItem

See Also

WindowsDefault Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


WindowsDefault.DrawMenuScrollArrow Method

Internal. See ICommandBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawMenuScrollArrow( _
ByVal bounds As Rectangle, _
ByVal g As Graphics, _
ByVal up As Boolean _
) Implements _
ICommandBarRenderer.DrawMenuScrollArrow
[C#]
public void DrawMenuScrollArrow(
Rectangle bounds,
Graphics g,
bool up
);

Parameters

bounds
g
up

Implements

ICommandBarRenderer.DrawMenuScrollArrow

See Also

WindowsDefault Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


WindowsDefault.DrawMenuSeparatorItem Method

Internal. See ICommandBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawMenuSeparatorItem( _
ByVal item As CommandBarSeparatorItem, _
ByVal menu As CommandContextMenu, _
ByVal g As Graphics, _
ByVal bounds As Rectangle _
) Implements _
ICommandBarRenderer.DrawMenuSeparatorItem
[C#]
public void DrawMenuSeparatorItem(
CommandBarSeparatorItem item,
CommandContextMenu menu,
Graphics g,
Rectangle bounds
);

Parameters

item
menu
g
bounds

Implements

ICommandBarRenderer.DrawMenuSeparatorItem

See Also

WindowsDefault Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


WindowsDefault.DrawMenuShadowHorizontal Method

Internal. See ICommandBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawMenuShadowHorizontal( _
ByVal gr As Graphics, _
ByVal rect As Rectangle, _
ByVal menuGapLocation As Point, _
ByVal menuGapSize As Integer _
) Implements _
ICommandBarRenderer.DrawMenuShadowHorizontal
[C#]
public void DrawMenuShadowHorizontal(
Graphics gr,
Rectangle rect,
Point menuGapLocation,
int menuGapSize
);

Parameters

gr
rect
menuGapLocation
menuGapSize

Implements

ICommandBarRenderer.DrawMenuShadowHorizontal

See Also

WindowsDefault Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


WindowsDefault.DrawMenuShadowVertical Method

Internal. See ICommandBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawMenuShadowVertical( _
ByVal gr As Graphics, _
ByVal rect As Rectangle _
) Implements _
ICommandBarRenderer.DrawMenuShadowVertical
[C#]
public void DrawMenuShadowVertical(
Graphics gr,
Rectangle rect
);

Parameters

gr
rect

Implements

ICommandBarRenderer.DrawMenuShadowVertical

See Also

WindowsDefault Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


WindowsDefault.DrawSeparatorItem Method

Internal. See ICommandBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawSeparatorItem( _
ByVal item As CommandBarSeparatorItem, _
ByVal bar As CommandBar, _
ByVal g As Graphics, _
ByVal rect As Rectangle _
) Implements _
ICommandBarRenderer.DrawSeparatorItem
[C#]
public void DrawSeparatorItem(
CommandBarSeparatorItem item,
CommandBar bar,
Graphics g,
Rectangle rect
);

Parameters

item
bar
g
rect

Implements

ICommandBarRenderer.DrawSeparatorItem

See Also

WindowsDefault Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


WindowsDefault.UpdateColorTable Method

Internal. See ICommandBarRenderer

[Visual Basic]
NotOverridable Public Sub UpdateColorTable() Implements _
ICommandBarRenderer.UpdateColorTable
[C#]
public void UpdateColorTable();

Implements

ICommandBarRenderer.UpdateColorTable

See Also

WindowsDefault Class | NETXP.Controls.Bars.CommandBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


NETXP.Controls.Bars.ListBarRenderers

NetXP 3.0 Reference

NETXP.Controls.Bars.ListBarRenderers Namespace

Classes

Class | Description
Office2003 | Provides the Office 2003 look and feel.
OfficeXP | Provides the Office XP look and feel.
WindowsDefault | Provides the Windows Default look and feel.


Office2003 Class

Provides the Office 2003 look and feel.

For a list of all members of this type, see Office2003 Members.

System.Object
Office2003

[Visual Basic]
NotInheritable Public Class Office2003
Implements NETXP.Controls.Bars.IListBarRenderer
[C#]
public sealed class Office2003 : IListBarRenderer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Bars.ListBarRenderers

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

Office2003 Members | NETXP.Controls.Bars.ListBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Office2003 Members

Office2003 overview

Public Instance Constructors

Office2003 Overloaded. Initializes a new instance of the Office2003 class.

Public Instance Properties

ColorTable Internal. See IListBarRenderer

Public Instance Methods

DrawBackground | Internal. See IListBarRenderer
DrawBar | Internal. See IListBarRenderer
DrawButton | Internal. See IListBarRenderer
DrawControlBorder | Internal. See IListBarRenderer
DrawInsertPoint | Internal. See IListBarRenderer
DrawScrollButton | Internal. See IListBarRenderer
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Office2003 Class | NETXP.Controls.Bars.ListBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Office2003 Constructor

Internal. See IListBarRenderer

Overload List

Internal. See IListBarRenderer

public Office2003();

Internal. See IListBarRenderer

public Office2003(IColorTable);

See Also

Office2003 Class | NETXP.Controls.Bars.ListBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Office2003 Constructor ()

Internal. See IListBarRenderer

[Visual Basic]
Overloads Public Sub New()
[C#]
public Office2003();

See Also

Office2003 Class | NETXP.Controls.Bars.ListBarRenderers Namespace | Office2003 Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Office2003 Constructor (IColorTable)

Internal. See IListBarRenderer

[Visual Basic]
Overloads Public Sub New( _
ByVal colorTable As IColorTable _
)
[C#]
public Office2003(
IColorTable colorTable
);

Parameters

colorTable

See Also

Office2003 Class | NETXP.Controls.Bars.ListBarRenderers Namespace | Office2003 Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Office2003 Properties

The properties of the Office2003 class are listed below. For a complete list of Office2003 class members, see the Office2003 Members topic.

Public Instance Properties

ColorTable Internal. See IListBarRenderer

See Also

Office2003 Class | NETXP.Controls.Bars.ListBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Office2003.ColorTable Property

Internal. See IListBarRenderer

[Visual Basic]
Public Property ColorTable As IColorTable
[C#]
public NETXP.Library.IColorTable ColorTable {get; set;}

See Also

Office2003 Class | NETXP.Controls.Bars.ListBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Office2003 Methods

The methods of the Office2003 class are listed below. For a complete list of Office2003 class members, see the Office2003 Members topic.

Public Instance Methods

DrawBackground | Internal. See IListBarRenderer
DrawBar | Internal. See IListBarRenderer
DrawButton | Internal. See IListBarRenderer
DrawControlBorder | Internal. See IListBarRenderer
DrawInsertPoint | Internal. See IListBarRenderer
DrawScrollButton | Internal. See IListBarRenderer
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Office2003 Class | NETXP.Controls.Bars.ListBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Office2003.DrawBackground Method

Internal. See IListBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawBackground( _
ByVal bar As ListBar, _
ByVal g As Graphics _
) Implements _
IListBarRenderer.DrawBackground
[C#]
public void DrawBackground(
ListBar bar,
Graphics g
);

Parameters

bar
g

Implements

IListBarRenderer.DrawBackground

See Also

Office2003 Class | NETXP.Controls.Bars.ListBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Office2003.DrawBar Method

Internal. See IListBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawBar( _
ByVal bar As ListBar, _
ByVal group As ListBarGroup, _
ByVal g As Graphics, _
ByVal bounds As Rectangle _
) Implements _
IListBarRenderer.DrawBar
[C#]
public void DrawBar(
ListBar bar,
ListBarGroup group,
Graphics g,
Rectangle bounds
);

Parameters

bar
group
g
bounds

Implements

IListBarRenderer.DrawBar

See Also

Office2003 Class | NETXP.Controls.Bars.ListBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Office2003.DrawButton Method

Internal. See IListBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawButton( _
ByVal bar As ListBar, _
ByVal group As ListBarGroup, _
ByVal g As Graphics _
) Implements _
IListBarRenderer.DrawButton
[C#]
public void DrawButton(
ListBar bar,
ListBarGroup group,
Graphics g
);

Parameters

bar
group
g

Implements

IListBarRenderer.DrawButton

See Also

Office2003 Class | NETXP.Controls.Bars.ListBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Office2003.DrawControlBorder Method

Internal. See IListBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawControlBorder( _
ByVal bar As ListBar, _
ByVal g As Graphics _
) Implements _
IListBarRenderer.DrawControlBorder
[C#]
public void DrawControlBorder(
ListBar bar,
Graphics g
);

Parameters

bar
g

Implements

IListBarRenderer.DrawControlBorder

See Also

Office2003 Class | NETXP.Controls.Bars.ListBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Office2003.DrawInsertPoint Method

Internal. See IListBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawInsertPoint( _
ByVal bar As ListBar, _
ByVal g As Graphics, _
ByVal selectedGroup As ListBarGroup, _
ByVal dragInsertPoint As ListBarInsertPoint _
) Implements _
IListBarRenderer.DrawInsertPoint
[C#]
public void DrawInsertPoint(
ListBar bar,
Graphics g,
ListBarGroup selectedGroup,
ListBarInsertPoint dragInsertPoint
);

Parameters

bar
g
selectedGroup
dragInsertPoint

Implements

IListBarRenderer.DrawInsertPoint

See Also

Office2003 Class | NETXP.Controls.Bars.ListBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Office2003.DrawScrollButton Method

Internal. See IListBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawScrollButton( _
ByVal bar As ListBar, _
ByVal sb As ListBarScrollButton, _
ByVal g As Graphics _
) Implements _
IListBarRenderer.DrawScrollButton
[C#]
public void DrawScrollButton(
ListBar bar,
ListBarScrollButton sb,
Graphics g
);

Parameters

bar
sb
g

Implements

IListBarRenderer.DrawScrollButton

See Also

Office2003 Class | NETXP.Controls.Bars.ListBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


OfficeXP Class

Provides the Office XP look and feel.

For a list of all members of this type, see OfficeXP Members.

System.Object
OfficeXP

[Visual Basic]
NotInheritable Public Class OfficeXP
Implements NETXP.Controls.Bars.IListBarRenderer
[C#]
public sealed class OfficeXP : IListBarRenderer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Bars.ListBarRenderers

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

OfficeXP Members | NETXP.Controls.Bars.ListBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


OfficeXP Members

OfficeXP overview

Public Instance Constructors

OfficeXP Overloaded. Initializes a new instance of the OfficeXP class.

Public Instance Properties

ColorTable Internal. See IListBarRenderer

Public Instance Methods

DrawBackground | Internal. See IListBarRenderer
DrawBar | Internal. See IListBarRenderer
DrawButton | Internal. See IListBarRenderer
DrawControlBorder | Internal. See IListBarRenderer
DrawInsertPoint | Internal. See IListBarRenderer
DrawScrollButton | Internal. See IListBarRenderer
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

OfficeXP Class | NETXP.Controls.Bars.ListBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


OfficeXP Constructor

Internal. See IListBarRenderer

Overload List

Internal. See IListBarRenderer

public OfficeXP();

Internal. See IListBarRenderer

public OfficeXP(IColorTable);

See Also

OfficeXP Class | NETXP.Controls.Bars.ListBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


OfficeXP Constructor ()

Internal. See IListBarRenderer

[Visual Basic]
Overloads Public Sub New()
[C#]
public OfficeXP();

See Also

OfficeXP Class | NETXP.Controls.Bars.ListBarRenderers Namespace | OfficeXP Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


OfficeXP Constructor (IColorTable)

Internal. See IListBarRenderer

[Visual Basic]
Overloads Public Sub New( _
ByVal colorTable As IColorTable _
)
[C#]
public OfficeXP(
IColorTable colorTable
);

Parameters

colorTable

See Also

OfficeXP Class | NETXP.Controls.Bars.ListBarRenderers Namespace | OfficeXP Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


OfficeXP Properties

The properties of the OfficeXP class are listed below. For a complete list of OfficeXP class members, see the OfficeXP Members topic.

Public Instance Properties

ColorTable Internal. See IListBarRenderer

See Also

OfficeXP Class | NETXP.Controls.Bars.ListBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


OfficeXP.ColorTable Property

Internal. See IListBarRenderer

[Visual Basic]
Public Property ColorTable As IColorTable
[C#]
public NETXP.Library.IColorTable ColorTable {get; set;}

See Also

OfficeXP Class | NETXP.Controls.Bars.ListBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


OfficeXP Methods

The methods of the OfficeXP class are listed below. For a complete list of OfficeXP class members, see the OfficeXP Members topic.

Public Instance Methods

DrawBackground | Internal. See IListBarRenderer
DrawBar | Internal. See IListBarRenderer
DrawButton | Internal. See IListBarRenderer
DrawControlBorder | Internal. See IListBarRenderer
DrawInsertPoint | Internal. See IListBarRenderer
DrawScrollButton | Internal. See IListBarRenderer
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

OfficeXP Class | NETXP.Controls.Bars.ListBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


OfficeXP.DrawBackground Method

Internal. See IListBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawBackground( _
ByVal bar As ListBar, _
ByVal g As Graphics _
) Implements _
IListBarRenderer.DrawBackground
[C#]
public void DrawBackground(
ListBar bar,
Graphics g
);

Parameters

bar
g

Implements

IListBarRenderer.DrawBackground

See Also

OfficeXP Class | NETXP.Controls.Bars.ListBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


OfficeXP.DrawBar Method

Internal. See IListBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawBar( _
ByVal bar As ListBar, _
ByVal group As ListBarGroup, _
ByVal g As Graphics, _
ByVal bounds As Rectangle _
) Implements _
IListBarRenderer.DrawBar
[C#]
public void DrawBar(
ListBar bar,
ListBarGroup group,
Graphics g,
Rectangle bounds
);

Parameters

bar
group
g
bounds

Implements

IListBarRenderer.DrawBar

See Also

OfficeXP Class | NETXP.Controls.Bars.ListBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


OfficeXP.DrawButton Method

Internal. See IListBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawButton( _
ByVal bar As ListBar, _
ByVal group As ListBarGroup, _
ByVal g As Graphics _
) Implements _
IListBarRenderer.DrawButton
[C#]
public void DrawButton(
ListBar bar,
ListBarGroup group,
Graphics g
);

Parameters

bar
group
g

Implements

IListBarRenderer.DrawButton

See Also

OfficeXP Class | NETXP.Controls.Bars.ListBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


OfficeXP.DrawControlBorder Method

Internal. See IListBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawControlBorder( _
ByVal bar As ListBar, _
ByVal g As Graphics _
) Implements _
IListBarRenderer.DrawControlBorder
[C#]
public void DrawControlBorder(
ListBar bar,
Graphics g
);

Parameters

bar
g

Implements

IListBarRenderer.DrawControlBorder

See Also

OfficeXP Class | NETXP.Controls.Bars.ListBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


OfficeXP.DrawInsertPoint Method

Internal. See IListBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawInsertPoint( _
ByVal bar As ListBar, _
ByVal g As Graphics, _
ByVal selectedGroup As ListBarGroup, _
ByVal dragInsertPoint As ListBarInsertPoint _
) Implements _
IListBarRenderer.DrawInsertPoint
[C#]
public void DrawInsertPoint(
ListBar bar,
Graphics g,
ListBarGroup selectedGroup,
ListBarInsertPoint dragInsertPoint
);

Parameters

bar
g
selectedGroup
dragInsertPoint

Implements

IListBarRenderer.DrawInsertPoint

See Also

OfficeXP Class | NETXP.Controls.Bars.ListBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


OfficeXP.DrawScrollButton Method

Internal. See IListBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawScrollButton( _
ByVal bar As ListBar, _
ByVal sb As ListBarScrollButton, _
ByVal g As Graphics _
) Implements _
IListBarRenderer.DrawScrollButton
[C#]
public void DrawScrollButton(
ListBar bar,
ListBarScrollButton sb,
Graphics g
);

Parameters

bar
sb
g

Implements

IListBarRenderer.DrawScrollButton

See Also

OfficeXP Class | NETXP.Controls.Bars.ListBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


WindowsDefault Class

Provides the Windows Default look and feel.

For a list of all members of this type, see WindowsDefault Members.

System.Object
WindowsDefault

[Visual Basic]
NotInheritable Public Class WindowsDefault
Implements NETXP.Controls.Bars.IListBarRenderer
[C#]
public sealed class WindowsDefault : IListBarRenderer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Bars.ListBarRenderers

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

WindowsDefault Members | NETXP.Controls.Bars.ListBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


WindowsDefault Members

WindowsDefault overview

Public Instance Constructors

WindowsDefault Constructor Internal. See IListBarRenderer

Public Instance Methods

DrawBackground | Internal. See IListBarRenderer
DrawBar | Internal. See IListBarRenderer
DrawButton | Internal. See IListBarRenderer
DrawControlBorder | Internal. See IListBarRenderer
DrawInsertPoint | Internal. See IListBarRenderer
DrawScrollButton | Internal. See IListBarRenderer
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

WindowsDefault Class | NETXP.Controls.Bars.ListBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


WindowsDefault Constructor

Internal. See IListBarRenderer

[Visual Basic]
Public Sub New()
[C#]
public WindowsDefault();

See Also

WindowsDefault Class | NETXP.Controls.Bars.ListBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


WindowsDefault Methods

The methods of the WindowsDefault class are listed below. For a complete list of WindowsDefault class members, see the WindowsDefault Members topic.

Public Instance Methods

DrawBackground | Internal. See IListBarRenderer
DrawBar | Internal. See IListBarRenderer
DrawButton | Internal. See IListBarRenderer
DrawControlBorder | Internal. See IListBarRenderer
DrawInsertPoint | Internal. See IListBarRenderer
DrawScrollButton | Internal. See IListBarRenderer
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

WindowsDefault Class | NETXP.Controls.Bars.ListBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


WindowsDefault.DrawBackground Method

Internal. See IListBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawBackground( _
ByVal bar As ListBar, _
ByVal g As Graphics _
) Implements _
IListBarRenderer.DrawBackground
[C#]
public void DrawBackground(
ListBar bar,
Graphics g
);

Parameters

bar
g

Implements

IListBarRenderer.DrawBackground

See Also

WindowsDefault Class | NETXP.Controls.Bars.ListBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


WindowsDefault.DrawBar Method

Internal. See IListBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawBar( _
ByVal bar As ListBar, _
ByVal group As ListBarGroup, _
ByVal g As Graphics, _
ByVal bounds As Rectangle _
) Implements _
IListBarRenderer.DrawBar
[C#]
public void DrawBar(
ListBar bar,
ListBarGroup group,
Graphics g,
Rectangle bounds
);

Parameters

bar
group
g
bounds

Implements

IListBarRenderer.DrawBar

See Also

WindowsDefault Class | NETXP.Controls.Bars.ListBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


WindowsDefault.DrawButton Method

Internal. See IListBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawButton( _
ByVal bar As ListBar, _
ByVal group As ListBarGroup, _
ByVal g As Graphics _
) Implements _
IListBarRenderer.DrawButton
[C#]
public void DrawButton(
ListBar bar,
ListBarGroup group,
Graphics g
);

Parameters

bar
group
g

Implements

IListBarRenderer.DrawButton

See Also

WindowsDefault Class | NETXP.Controls.Bars.ListBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


WindowsDefault.DrawControlBorder Method

Internal. See IListBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawControlBorder( _
ByVal bar As ListBar, _
ByVal g As Graphics _
) Implements _
IListBarRenderer.DrawControlBorder
[C#]
public void DrawControlBorder(
ListBar bar,
Graphics g
);

Parameters

bar
g

Implements

IListBarRenderer.DrawControlBorder

See Also

WindowsDefault Class | NETXP.Controls.Bars.ListBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


WindowsDefault.DrawInsertPoint Method

Internal. See IListBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawInsertPoint( _
ByVal bar As ListBar, _
ByVal g As Graphics, _
ByVal selectedGroup As ListBarGroup, _
ByVal dragInsertPoint As ListBarInsertPoint _
) Implements _
IListBarRenderer.DrawInsertPoint
[C#]
public void DrawInsertPoint(
ListBar bar,
Graphics g,
ListBarGroup selectedGroup,
ListBarInsertPoint dragInsertPoint
);

Parameters

bar
g
selectedGroup
dragInsertPoint

Implements

IListBarRenderer.DrawInsertPoint

See Also

WindowsDefault Class | NETXP.Controls.Bars.ListBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


WindowsDefault.DrawScrollButton Method

Internal. See IListBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawScrollButton( _
ByVal bar As ListBar, _
ByVal sb As ListBarScrollButton, _
ByVal g As Graphics _
) Implements _
IListBarRenderer.DrawScrollButton
[C#]
public void DrawScrollButton(
ListBar bar,
ListBarScrollButton sb,
Graphics g
);

Parameters

bar
sb
g

Implements

IListBarRenderer.DrawScrollButton

See Also

WindowsDefault Class | NETXP.Controls.Bars.ListBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


NETXP.Controls.Bars.StatusBarRenderers

NetXP 3.0 Reference

NETXP.Controls.Bars.StatusBarRenderers Namespace

Classes

Class | Description
Office2003 | Provides the Office 2003 look and feel.
OfficeXP | Provides the Office XP look and feel.
WindowsDefault | Provides the Windows default look and feel.


Office2003 Class

Provides the Office 2003 look and feel.

For a list of all members of this type, see Office2003 Members.

System.Object
Office2003

[Visual Basic]
NotInheritable Public Class Office2003
Implements NETXP.Controls.Bars.IStatusBarRenderer
[C#]
public sealed class Office2003 : IStatusBarRenderer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Bars.StatusBarRenderers

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

Office2003 Members | NETXP.Controls.Bars.StatusBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Office2003 Members

Office2003 overview

Public Instance Constructors

Office2003 Overloaded. Initializes a new instance of the Office2003 class.

Public Instance Properties

ColorTable Internal. See IStatusBarRenderer

Public Instance Methods

DrawBackground | Internal. See IStatusBarRenderer
DrawItem | Internal. See IStatusBarRenderer
DrawProgressBar | Internal. See IStatusBarRenderer
DrawSizeGrip | Internal. See IStatusBarRenderer
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Office2003 Class | NETXP.Controls.Bars.StatusBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Office2003 Constructor

Internal. See IStatusBarRenderer

Overload List

Internal. See IStatusBarRenderer

public Office2003();

Internal. See IStatusBarRenderer

public Office2003(IColorTable);

See Also

Office2003 Class | NETXP.Controls.Bars.StatusBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Office2003 Constructor ()

Internal. See IStatusBarRenderer

[Visual Basic]
Overloads Public Sub New()
[C#]
public Office2003();

See Also

Office2003 Class | NETXP.Controls.Bars.StatusBarRenderers Namespace | Office2003 Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Office2003 Constructor (IColorTable)

Internal. See IStatusBarRenderer

[Visual Basic]
Overloads Public Sub New( _
ByVal colorTable As IColorTable _
)
[C#]
public Office2003(
IColorTable colorTable
);

Parameters

colorTable

See Also

Office2003 Class | NETXP.Controls.Bars.StatusBarRenderers Namespace | Office2003 Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Office2003 Properties

The properties of the Office2003 class are listed below. For a complete list of Office2003 class members, see the Office2003 Members topic.

Public Instance Properties

ColorTable Internal. See IStatusBarRenderer

See Also

Office2003 Class | NETXP.Controls.Bars.StatusBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Office2003.ColorTable Property

Internal. See IStatusBarRenderer

[Visual Basic]
Public Property ColorTable As IColorTable
[C#]
public NETXP.Library.IColorTable ColorTable {get; set;}

See Also

Office2003 Class | NETXP.Controls.Bars.StatusBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Office2003 Methods

The methods of the Office2003 class are listed below. For a complete list of Office2003 class members, see the Office2003 Members topic.

Public Instance Methods

DrawBackground | Internal. See IStatusBarRenderer
DrawItem | Internal. See IStatusBarRenderer
DrawProgressBar | Internal. See IStatusBarRenderer
DrawSizeGrip | Internal. See IStatusBarRenderer
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Office2003 Class | NETXP.Controls.Bars.StatusBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Office2003.DrawBackground Method

Internal. See IStatusBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawBackground( _
ByVal bar As StatusBar, _
ByVal g As Graphics _
) Implements _
IStatusBarRenderer.DrawBackground
[C#]
public void DrawBackground(
StatusBar bar,
Graphics g
);

Parameters

bar
g

Implements

IStatusBarRenderer.DrawBackground

See Also

Office2003 Class | NETXP.Controls.Bars.StatusBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Office2003.DrawItem Method

Internal. See IStatusBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawItem( _
ByVal bar As StatusBar, _
ByVal sbdevent As StatusBarDrawItemEventArgs _
) Implements _
IStatusBarRenderer.DrawItem
[C#]
public void DrawItem(
StatusBar bar,
StatusBarDrawItemEventArgs sbdevent
);

Parameters

bar
sbdevent

Implements

IStatusBarRenderer.DrawItem

See Also

Office2003 Class | NETXP.Controls.Bars.StatusBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Office2003.DrawProgressBar Method

Internal. See IStatusBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawProgressBar( _
ByVal bar As StatusBar, _
ByVal sbdevent As StatusBarDrawItemEventArgs, _
ByVal ProgressPanel As ProgressPanel _
) Implements _
IStatusBarRenderer.DrawProgressBar
[C#]
public void DrawProgressBar(
StatusBar bar,
StatusBarDrawItemEventArgs sbdevent,
ProgressPanel ProgressPanel
);

Parameters

bar
sbdevent
ProgressPanel

Implements

IStatusBarRenderer.DrawProgressBar

See Also

Office2003 Class | NETXP.Controls.Bars.StatusBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


Office2003.DrawSizeGrip Method

Internal. See IStatusBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawSizeGrip( _
ByVal bar As StatusBar, _
ByVal g As Graphics, _
ByVal gripRect As Rectangle _
) Implements _
IStatusBarRenderer.DrawSizeGrip
[C#]
public void DrawSizeGrip(
StatusBar bar,
Graphics g,
Rectangle gripRect
);

Parameters

bar
g
gripRect

Implements

IStatusBarRenderer.DrawSizeGrip

See Also

Office2003 Class | NETXP.Controls.Bars.StatusBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


OfficeXP Class

Provides the Office XP look and feel.

For a list of all members of this type, see OfficeXP Members.

System.Object
OfficeXP

[Visual Basic]
NotInheritable Public Class OfficeXP
Implements NETXP.Controls.Bars.IStatusBarRenderer
[C#]
public sealed class OfficeXP : IStatusBarRenderer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Bars.StatusBarRenderers

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

OfficeXP Members | NETXP.Controls.Bars.StatusBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


OfficeXP Members

OfficeXP overview

Public Instance Constructors

OfficeXP Overloaded. Initializes a new instance of the OfficeXP class.

Public Instance Properties

ColorTable Internal. See IStatusBarRenderer

Public Instance Methods

DrawBackground | Internal. See IStatusBarRenderer
DrawItem | Internal. See IStatusBarRenderer
DrawProgressBar | Internal. See IStatusBarRenderer
DrawSizeGrip | Internal. See IStatusBarRenderer
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

OfficeXP Class | NETXP.Controls.Bars.StatusBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


OfficeXP Constructor

Internal. See IStatusBarRenderer

Overload List

Internal. See IStatusBarRenderer

public OfficeXP();

Internal. See IStatusBarRenderer

public OfficeXP(IColorTable);

See Also

OfficeXP Class | NETXP.Controls.Bars.StatusBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


OfficeXP Constructor ()

Internal. See IStatusBarRenderer

[Visual Basic]
Overloads Public Sub New()
[C#]
public OfficeXP();

See Also

OfficeXP Class | NETXP.Controls.Bars.StatusBarRenderers Namespace | OfficeXP Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


OfficeXP Constructor (IColorTable)

Internal. See IStatusBarRenderer

[Visual Basic]
Overloads Public Sub New( _
ByVal colorTable As IColorTable _
)
[C#]
public OfficeXP(
IColorTable colorTable
);

Parameters

colorTable

See Also

OfficeXP Class | NETXP.Controls.Bars.StatusBarRenderers Namespace | OfficeXP Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


OfficeXP Properties

The properties of the OfficeXP class are listed below. For a complete list of OfficeXP class members, see the OfficeXP Members topic.

Public Instance Properties

ColorTable Internal. See IStatusBarRenderer

See Also

OfficeXP Class | NETXP.Controls.Bars.StatusBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


OfficeXP.ColorTable Property

Internal. See IStatusBarRenderer

[Visual Basic]
Public Property ColorTable As IColorTable
[C#]
public NETXP.Library.IColorTable ColorTable {get; set;}

See Also

OfficeXP Class | NETXP.Controls.Bars.StatusBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


OfficeXP Methods

The methods of the OfficeXP class are listed below. For a complete list of OfficeXP class members, see the OfficeXP Members topic.

Public Instance Methods

DrawBackground | Internal. See IStatusBarRenderer
DrawItem | Internal. See IStatusBarRenderer
DrawProgressBar | Internal. See IStatusBarRenderer
DrawSizeGrip | Internal. See IStatusBarRenderer
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

OfficeXP Class | NETXP.Controls.Bars.StatusBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


OfficeXP.DrawBackground Method

Internal. See IStatusBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawBackground( _
ByVal bar As StatusBar, _
ByVal g As Graphics _
) Implements _
IStatusBarRenderer.DrawBackground
[C#]
public void DrawBackground(
StatusBar bar,
Graphics g
);

Parameters

bar
g

Implements

IStatusBarRenderer.DrawBackground

See Also

OfficeXP Class | NETXP.Controls.Bars.StatusBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


OfficeXP.DrawItem Method

Internal. See IStatusBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawItem( _
ByVal bar As StatusBar, _
ByVal sbdevent As StatusBarDrawItemEventArgs _
) Implements _
IStatusBarRenderer.DrawItem
[C#]
public void DrawItem(
StatusBar bar,
StatusBarDrawItemEventArgs sbdevent
);

Parameters

bar
sbdevent

Implements

IStatusBarRenderer.DrawItem

See Also

OfficeXP Class | NETXP.Controls.Bars.StatusBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


OfficeXP.DrawProgressBar Method

Internal. See IStatusBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawProgressBar( _
ByVal bar As StatusBar, _
ByVal sbdevent As StatusBarDrawItemEventArgs, _
ByVal ProgressPanel As ProgressPanel _
) Implements _
IStatusBarRenderer.DrawProgressBar
[C#]
public void DrawProgressBar(
StatusBar bar,
StatusBarDrawItemEventArgs sbdevent,
ProgressPanel ProgressPanel
);

Parameters

bar
sbdevent
ProgressPanel

Implements

IStatusBarRenderer.DrawProgressBar

See Also

OfficeXP Class | NETXP.Controls.Bars.StatusBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


OfficeXP.DrawSizeGrip Method

Internal. See IStatusBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawSizeGrip( _
ByVal bar As StatusBar, _
ByVal g As Graphics, _
ByVal gripRect As Rectangle _
) Implements _
IStatusBarRenderer.DrawSizeGrip
[C#]
public void DrawSizeGrip(
StatusBar bar,
Graphics g,
Rectangle gripRect
);

Parameters

bar
g
gripRect

Implements

IStatusBarRenderer.DrawSizeGrip

See Also

OfficeXP Class | NETXP.Controls.Bars.StatusBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


WindowsDefault Class

Provides the Windows default look and feel.

For a list of all members of this type, see WindowsDefault Members.

System.Object
WindowsDefault

[Visual Basic]
NotInheritable Public Class WindowsDefault
Implements NETXP.Controls.Bars.IStatusBarRenderer
[C#]
public sealed class WindowsDefault : IStatusBarRenderer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Bars.StatusBarRenderers

Assembly: NETXP.Controls.Bars (in NETXP.Controls.Bars.dll)

See Also

WindowsDefault Members | NETXP.Controls.Bars.StatusBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


WindowsDefault Members

WindowsDefault overview

Public Instance Constructors

WindowsDefault Constructor Internal. See IStatusBarRenderer

Public Instance Methods

DrawBackground | Internal. See IStatusBarRenderer
DrawItem | Internal. See IStatusBarRenderer
DrawProgressBar | Internal. See IStatusBarRenderer
DrawSizeGrip | Internal. See IStatusBarRenderer
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

WindowsDefault Class | NETXP.Controls.Bars.StatusBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


WindowsDefault Constructor

Internal. See IStatusBarRenderer

[Visual Basic]
Public Sub New()
[C#]
public WindowsDefault();

See Also

WindowsDefault Class | NETXP.Controls.Bars.StatusBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


WindowsDefault Methods

The methods of the WindowsDefault class are listed below. For a complete list of WindowsDefault class members, see the WindowsDefault Members topic.

Public Instance Methods

DrawBackground | Internal. See IStatusBarRenderer
DrawItem | Internal. See IStatusBarRenderer
DrawProgressBar | Internal. See IStatusBarRenderer
DrawSizeGrip | Internal. See IStatusBarRenderer
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

WindowsDefault Class | NETXP.Controls.Bars.StatusBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


WindowsDefault.DrawBackground Method

Internal. See IStatusBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawBackground( _
ByVal bar As StatusBar, _
ByVal g As Graphics _
) Implements _
IStatusBarRenderer.DrawBackground
[C#]
public void DrawBackground(
StatusBar bar,
Graphics g
);

Parameters

bar
g

Implements

IStatusBarRenderer.DrawBackground

See Also

WindowsDefault Class | NETXP.Controls.Bars.StatusBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


WindowsDefault.DrawItem Method

Internal. See IStatusBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawItem( _
ByVal bar As StatusBar, _
ByVal sbdevent As StatusBarDrawItemEventArgs _
) Implements _
IStatusBarRenderer.DrawItem
[C#]
public void DrawItem(
StatusBar bar,
StatusBarDrawItemEventArgs sbdevent
);

Parameters

bar
sbdevent

Implements

IStatusBarRenderer.DrawItem

See Also

WindowsDefault Class | NETXP.Controls.Bars.StatusBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


WindowsDefault.DrawProgressBar Method

Internal. See IStatusBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawProgressBar( _
ByVal bar As StatusBar, _
ByVal sbdevent As StatusBarDrawItemEventArgs, _
ByVal ProgressPanel As ProgressPanel _
) Implements _
IStatusBarRenderer.DrawProgressBar
[C#]
public void DrawProgressBar(
StatusBar bar,
StatusBarDrawItemEventArgs sbdevent,
ProgressPanel ProgressPanel
);

Parameters

bar
sbdevent
ProgressPanel

Implements

IStatusBarRenderer.DrawProgressBar

See Also

WindowsDefault Class | NETXP.Controls.Bars.StatusBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


WindowsDefault.DrawSizeGrip Method

Internal. See IStatusBarRenderer

[Visual Basic]
NotOverridable Public Sub DrawSizeGrip( _
ByVal bar As StatusBar, _
ByVal g As Graphics, _
ByVal gripRect As Rectangle _
) Implements _
IStatusBarRenderer.DrawSizeGrip
[C#]
public void DrawSizeGrip(
StatusBar bar,
Graphics g,
Rectangle gripRect
);

Parameters

bar
g
gripRect

Implements

IStatusBarRenderer.DrawSizeGrip

See Also

WindowsDefault Class | NETXP.Controls.Bars.StatusBarRenderers Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Bars [3.0.5600.2205]


NETXP.Controls.Docking

NetXP 3.0 Reference

NETXP.Controls.Docking Namespace

Classes

Class | Description
AutoHidePanel | Internal.
CaptionButton | This control is a button used in the captions of docked objects. Used internally.
CloseRequestEventArgs | Defines event arguments for the tabbed group close request events.
ContextMenuEventArgs | Defines the context menu event arguments.
DockFrame | Internal.
DockFrameCaption | Internal.
DockFrameCollection | Internal.
DockingManager | A full-featured VS.NET-style docking manager. An instance of the DockingManager class needs to be created and associated with each ContainerControl-derived object you want to have a docking capability. Most of the time this will be your application's top-level Form.
DockingManagerExtender | DockingManagerExtender enhances the DockingManager for design time. It extends the controls on your form with properties, which defines the docking behaviour at run time.
DockObject | A docking object.
DockObjectCollection | A collection of DockObject objects.
DockRegion | Internal.
DockRegionCollection | Internal.
ExDockObject | Wraps DockObject and extend it with needed properties.
FloatingForm | A generic floating form.
HotDockRegion | Internal.
HotDockRegionCollection | Internal.
ManagerDockObjectCollection | Internal.
PageLoadingEventArgs | Defines the loading event arguments.
PageSavingEventArgs | Defines the saving event arguments.
Redocker | Internal.
Renderers | Provides renderers for Windows Default, Office XP, and Office 2003 styles.
Renderers.Office2003 | Office 2003 style.
Renderers.OfficeXP | Office XP / VS.NET IDE style.
Renderers.WindowsDefault | Windows Default style.
Restore | Internal.
SizeBar | Internal control.
TabbedGroups | The TabbedGroups control offers automated support for tabbed MDI, similar to Visual Studio .NET.
TabbedGroups.DragProvider | Defines a drag provider.
TabControl | A tab control with extended features.
TabControl.MultiRect | Util class for handling multiline calculations.
TabGroupBase | The base class for tabbed groups.
TabGroupBaseCollection | Provides a collection of TabGroupBase objects.
TabGroupNode | Defines a tab group node.
TabGroupSequence | A container for multiple tabbed group nodes.
TabPage | A tab page for NETXP.Controls.Docking.TabControl
TabPageCollection | A collection of tab pages.
VerticalTab | Internal.
Window | Internal.
WindowCollection | Internal.
WindowObjects | Internal.

Interfaces

Interface | Description
IDockingRenderer | Defines a renderer for the docking subsystem.
IDockRegionMaximizeWindow | Internal.
IHotDockRegionSource | Internal.
IResizeSource | Used by the docking manager internally.

Delegates

Delegate | Description
ContextHandler | Signature of a delegate.
ContextMenuHandler | Context menu is about to be shown.
DockObject.PropChangeHandler | The property change event signature.
DockObjectHandler | Handles events for an object.
DockObjectHidingHandler | Handles events for an object when hiding.
LoadCustomConfigHandler | Custom configuration about to be loaded.
SaveCustomConfigHandler | Custom configuration about to be saved.
TabbedGroups.ExternalDropHandler | Defines an event handler.
TabbedGroups.GlobalLoadingHandler | Defines an event handler.
TabbedGroups.GlobalSavingHandler | Defines an event handler.
TabbedGroups.PageCloseRequestHandler | Defines an event handler.
TabbedGroups.PageContextMenuHandler | Defines an event handler.
TabbedGroups.PageLoadingHandler | Defines an event handler.
TabbedGroups.PageSavingHandler | Defines an event handler.
TabbedGroups.TabControlCreatedHandler | Defines an event handler.
TabControl.DoubleClickTabHandler | Event handler for when tab is double-clicked.
TabControl.PopupMenuHandler | Event handler for when a popup menu is about to be shown.
TabControlCreatedHandler | A tab control has been created.
TabPage.PropChangeHandler | The property change event signature.
VerticalTab.VerticalTabHandler | Internal.
VerticalTab.VerticalTabIndexHandler | Internal.

Enumerations

Enumeration | Description
ButtonFunction | Describes the predefined function that the caption button performs. This determines the images that the caption button will use.
DockObject.Property | Enumeration of property change events.
HideTabsModes | Enumeration of modes that control the display of the tabs area.
State | The state of docked objects.
TabbedGroups.CompactFlags | Flags for compacting tabbed groups.
TabbedGroups.DisplayTabModes | Specifies modes for showing/hiding tabbed groups.
TabGroupBase.NotifyCode | Notification code.
TabPage.Property | Enumeration of property change events.
TabPosition | Enumeration of tab positions.
UpdateName | Properties to propagate.


AutoHidePanel Class

Internal.

For a list of all members of this type, see AutoHidePanel Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
Panel
AutoHidePanel

[Visual Basic]
Public Class AutoHidePanel
Inherits Panel
Implements System.Windows.Forms.IMessageFilter
[C#]
public class AutoHidePanel : Panel, IMessageFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

AutoHidePanel Members | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


AutoHidePanel Members

AutoHidePanel overview

Public Instance Constructors

AutoHidePanel Constructor Internal.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor | Internal.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BorderStyle (inherited from Panel) | Indicates the border style for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Panel) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Panel) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

AddDockObject | Internal.
AddDockObjectIntoVerticalTab | Internal.
AddDockObjectsAsGroup | Overloaded. Internal.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringDockObjectIntoView | Internal.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
ContainsDockObject | Internal.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreFilterMessage | Internal.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveDockObject | Internal.
RemoveShowingWindow | Internal.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
RestoreObjectForDockObject | Internal.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Panel) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
UpdateNameValue | Internal.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Panel) |
KeyPress (inherited from Panel) |
KeyUp (inherited from Panel) |
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Panel) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

AutoHidePanel Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


AutoHidePanel Constructor

Internal.

[Visual Basic]
Public Sub New( _
ByVal manager As DockingManager, _
ByVal dockEdge As DockStyle _
)
[C#]
public AutoHidePanel(
DockingManager manager,
DockStyle dockEdge
);

Parameters

manager
dockEdge

See Also

AutoHidePanel Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


AutoHidePanel Properties

The properties of the AutoHidePanel class are listed below. For a complete list of AutoHidePanel class members, see the AutoHidePanel Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor | Internal.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BorderStyle (inherited from Panel) | Indicates the border style for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Panel) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Panel) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

See Also

AutoHidePanel Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


AutoHidePanel.BackColor Property

Internal.

[Visual Basic]
Overrides Public Property BackColor As Color
[C#]
public override System.Drawing.Color BackColor {get; set;}

See Also

AutoHidePanel Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


AutoHidePanel Methods

The methods of the AutoHidePanel class are listed below. For a complete list of AutoHidePanel class members, see the AutoHidePanel Members topic.

Public Instance Methods

AddDockObject | Internal.
AddDockObjectIntoVerticalTab | Internal.
AddDockObjectsAsGroup | Overloaded. Internal.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringDockObjectIntoView | Internal.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
ContainsDockObject | Internal.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreFilterMessage | Internal.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveDockObject | Internal.
RemoveShowingWindow | Internal.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
RestoreObjectForDockObject | Internal.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Panel) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
UpdateNameValue | Internal.

See Also

AutoHidePanel Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


AutoHidePanel.AddDockObject Method

Internal.

[Visual Basic]
Public Sub AddDockObject( _
ByVal obj As DockObject, _
ByVal next As StringCollection, _
ByVal previous As StringCollection, _
ByVal nextAll As StringCollection, _
ByVal previousAll As StringCollection _
)
[C#]
public void AddDockObject(
DockObject obj,
StringCollection next,
StringCollection previous,
StringCollection nextAll,
StringCollection previousAll
);

Parameters

obj
next
previous
nextAll
previousAll

See Also

AutoHidePanel Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


AutoHidePanel.AddDockObjectIntoVerticalTab Method

Internal.

[Visual Basic]
Public Sub AddDockObjectIntoVerticalTab( _
ByVal obj As DockObject, _
ByVal ts As VerticalTab, _
ByVal index As Integer _
)
[C#]
public void AddDockObjectIntoVerticalTab(
DockObject obj,
VerticalTab ts,
int index
);

Parameters

obj
ts
index

See Also

AutoHidePanel Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


AddDockObjectsAsGroup Method

NetXP 3.0 Reference

AutoHidePanel.AddDockObjectsAsGroup Method

Internal.

Overload List

Internal.

public void AddDockObjectsAsGroup(DockObjectCollection);

Internal.

public void AddDockObjectsAsGroup(DockObjectCollection,int);

See Also

AutoHidePanel Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


AutoHidePanel.AddDockObjectsAsGroup Method (DockObjectCollection)

Internal.

[Visual Basic]
Overloads Public Sub AddDockObjectsAsGroup( _
ByVal objects As DockObjectCollection _
)
[C#]
public void AddDockObjectsAsGroup(
DockObjectCollection objects
);

Parameters

objects

See Also

AutoHidePanel Class | NETXP.Controls.Docking Namespace | AutoHidePanel.AddDockObjectsAsGroup Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


AutoHidePanel.AddDockObjectsAsGroup Method (DockObjectCollection, Int32)

Internal.

[Visual Basic]
Overloads Public Sub AddDockObjectsAsGroup( _
ByVal objects As DockObjectCollection, _
ByVal index As Integer _
)
[C#]
public void AddDockObjectsAsGroup(
DockObjectCollection objects,
int index
);

Parameters

objects
index

See Also

AutoHidePanel Class | NETXP.Controls.Docking Namespace | AutoHidePanel.AddDockObjectsAsGroup Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


AutoHidePanel.BringDockObjectIntoView Method

Internal.

[Visual Basic]
Public Sub BringDockObjectIntoView( _
ByVal c As DockObject _
)
[C#]
public void BringDockObjectIntoView(
DockObject c
);

Parameters

c

See Also

AutoHidePanel Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


AutoHidePanel.ContainsDockObject Method

Internal.

[Visual Basic]
Public Function ContainsDockObject( _
ByVal c As DockObject _
) As Boolean
[C#]
public bool ContainsDockObject(
DockObject c
);

Parameters

c

Return Value

See Also

AutoHidePanel Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


AutoHidePanel.PreFilterMessage Method

Internal.

[Visual Basic]
NotOverridable Public Function PreFilterMessage( _
ByRef msg As Message _
) As Boolean Implements _
IMessageFilter.PreFilterMessage
[C#]
public bool PreFilterMessage(
ref Message msg
);

Parameters

msg

Return Value

Implements

IMessageFilter.PreFilterMessage

See Also

AutoHidePanel Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


AutoHidePanel.RemoveDockObject Method

Internal.

[Visual Basic]
Public Sub RemoveDockObject( _
ByVal c As DockObject _
)
[C#]
public void RemoveDockObject(
DockObject c
);

Parameters

c

See Also

AutoHidePanel Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


AutoHidePanel.RemoveShowingWindow Method

Internal.

[Visual Basic]
Public Sub RemoveShowingWindow()
[C#]
public void RemoveShowingWindow();

See Also

AutoHidePanel Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


AutoHidePanel.RestoreObjectForDockObject Method

Internal.

[Visual Basic]
Public Function RestoreObjectForDockObject( _
ByVal c As DockObject _
) As Restore
[C#]
public Restore RestoreObjectForDockObject(
DockObject c
);

Parameters

c

Return Value

See Also

AutoHidePanel Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


AutoHidePanel.UpdateNameValue Method

Internal.

[Visual Basic]
Public Sub UpdateNameValue( _
ByVal name As UpdateName, _
ByVal value As Object _
)
[C#]
public void UpdateNameValue(
UpdateName name,
object value
);

Parameters

name
value

See Also

AutoHidePanel Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


ButtonFunction Enumeration

Describes the predefined function that the caption button performs. This determines the images that the caption button will use.

[Visual Basic]
Public Enum ButtonFunction
[C#]
public enum ButtonFunction

Members

Member Name | Description
Close | Uses a Close (X) image.
Maximize | Uses a Maximize (square) image.
Restore | Uses a Restore (two squares) image.
AutoHide | Uses an auto-hide image (a vertical pin).
Pin | Uses a horizontal pin image.
LeftArrow | Uses a left arrow image.
RightArrow | Uses a right arrow image.
Minimize | Uses a minimize ( _ ) image.

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


CaptionButton Class

This control is a button used in the captions of docked objects. Used internally.

For a list of all members of this type, see CaptionButton Members.

System.Object
MarshalByRefObject
Component
Control
CaptionButton

[Visual Basic]
NotInheritable Public Class CaptionButton
Inherits Control
[C#]
public sealed class CaptionButton : Control

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

CaptionButton Members | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


CaptionButton Members

CaptionButton overview

Public Instance Constructors

CaptionButton Constructor Constructs a new CaptionButton.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
Active | Is the button active?
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Function | Gets or sets the function that this button will perform. This affects the image that the button will display.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PopupStyle | Should the button "pop up" when the mouse is over it?
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Renderer | The renderer used by this control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeComponent | Constructs a new CaptionButton.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

CaptionButton Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


CaptionButton Constructor

Constructs a new CaptionButton.

[Visual Basic]
Public Sub New()
[C#]
public CaptionButton();

See Also

CaptionButton Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


CaptionButton Properties

The properties of the CaptionButton class are listed below. For a complete list of CaptionButton class members, see the CaptionButton Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
Active | Is the button active?
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Function | Gets or sets the function that this button will perform. This affects the image that the button will display.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PopupStyle | Should the button "pop up" when the mouse is over it?
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Renderer | The renderer used by this control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

See Also

CaptionButton Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


CaptionButton.Active Property

Is the button active?

[Visual Basic]
Public Property Active As Boolean
[C#]
public bool Active {get; set;}

See Also

CaptionButton Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


CaptionButton.Function Property

Gets or sets the function that this button will perform. This affects the image that the button will display.

[Visual Basic]
Public Property Function As ButtonFunction
[C#]
public ButtonFunction Function {get; set;}

See Also

CaptionButton Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


CaptionButton.PopupStyle Property

Should the button "pop up" when the mouse is over it?

[Visual Basic]
Public Property PopupStyle As Boolean
[C#]
public bool PopupStyle {get; set;}

See Also

CaptionButton Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


CaptionButton.Renderer Property

The renderer used by this control.

[Visual Basic]
Public Property Renderer As IDockingRenderer
[C#]
public IDockingRenderer Renderer {get; set;}

See Also

CaptionButton Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


CaptionButton Methods

The methods of the CaptionButton class are listed below. For a complete list of CaptionButton class members, see the CaptionButton Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeComponent | Constructs a new CaptionButton.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

See Also

CaptionButton Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


CaptionButton.InitializeComponent Method

Constructs a new CaptionButton.

[Visual Basic]
Public Sub InitializeComponent()
[C#]
public void InitializeComponent();

See Also

CaptionButton Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


CloseRequestEventArgs Class

Defines event arguments for the tabbed group close request events.

For a list of all members of this type, see CloseRequestEventArgs Members.

System.Object
CloseRequestEventArgs

[Visual Basic]
Public Class CloseRequestEventArgs
[C#]
public class CloseRequestEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

CloseRequestEventArgs Members | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


CloseRequestEventArgs Members

CloseRequestEventArgs overview

Public Instance Constructors

CloseRequestEventArgs Constructor Constructs a new CloseRequestEventArgs object.

Public Instance Properties

Cancel | Cancel this event?
Node | Retrieves the node.
TabControl | Retrieves the tab control.
TabPage | Retrieves the tab page.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

CloseRequestEventArgs Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


CloseRequestEventArgs Constructor

Constructs a new CloseRequestEventArgs object.

[Visual Basic]
Public Sub New( _
ByVal tgn As TabGroupNode, _
ByVal tc As TabControl, _
ByVal tp As TabPage _
)
[C#]
public CloseRequestEventArgs(
TabGroupNode tgn,
TabControl tc,
TabPage tp
);

Parameters

tgn
The tab group node.
tc
The tab control.
tp
The tab page.

See Also

CloseRequestEventArgs Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


CloseRequestEventArgs Properties

The properties of the CloseRequestEventArgs class are listed below. For a complete list of CloseRequestEventArgs class members, see the CloseRequestEventArgs Members topic.

Public Instance Properties

Cancel | Cancel this event?
Node | Retrieves the node.
TabControl | Retrieves the tab control.
TabPage | Retrieves the tab page.

See Also

CloseRequestEventArgs Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


CloseRequestEventArgs.Cancel Property

Cancel this event?

[Visual Basic]
Public Property Cancel As Boolean
[C#]
public bool Cancel {get; set;}

See Also

CloseRequestEventArgs Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


CloseRequestEventArgs.Node Property

Retrieves the node.

[Visual Basic]
Public ReadOnly Property Node As TabGroupNode
[C#]
public TabGroupNode Node {get;}

See Also

CloseRequestEventArgs Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


CloseRequestEventArgs.TabControl Property

Retrieves the tab control.

[Visual Basic]
Public ReadOnly Property TabControl As TabControl
[C#]
public TabControl TabControl {get;}

See Also

CloseRequestEventArgs Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


CloseRequestEventArgs.TabPage Property

Retrieves the tab page.

[Visual Basic]
Public ReadOnly Property TabPage As TabPage
[C#]
public TabPage TabPage {get;}

See Also

CloseRequestEventArgs Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


ContextHandler Delegate

Signature of a delegate.

[Visual Basic]
Public Delegate Sub ContextHandler( _
ByVal screenPos As Point _
)
[C#]
public delegate void ContextHandler(
Point screenPos
);

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


ContextMenuEventArgs Class

Defines the context menu event arguments.

For a list of all members of this type, see ContextMenuEventArgs Members.

System.Object
CloseRequestEventArgs
ContextMenuEventArgs

[Visual Basic]
Public Class ContextMenuEventArgs
Inherits CloseRequestEventArgs
[C#]
public class ContextMenuEventArgs : CloseRequestEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

ContextMenuEventArgs Members | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


ContextMenuEventArgs Members

ContextMenuEventArgs overview

Public Instance Constructors

ContextMenuEventArgs Constructor Constructs a new ContextMenuEventArgs object.

Public Instance Properties

Cancel (inherited from CloseRequestEventArgs) | Cancel this event?
ContextMenu | Gets the context menu.
Node (inherited from CloseRequestEventArgs) | Retrieves the node.
TabControl (inherited from CloseRequestEventArgs) | Retrieves the tab control.
TabPage (inherited from CloseRequestEventArgs) | Retrieves the tab page.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ContextMenuEventArgs Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


ContextMenuEventArgs Constructor

Constructs a new ContextMenuEventArgs object.

[Visual Basic]
Public Sub New( _
ByVal tgn As TabGroupNode, _
ByVal tc As TabControl, _
ByVal tp As TabPage, _
ByVal contextMenu As ContextMenu _
)
[C#]
public ContextMenuEventArgs(
TabGroupNode tgn,
TabControl tc,
TabPage tp,
ContextMenu contextMenu
);

Parameters

tgn
The tab group node.
tc
The tab control.
tp
The tab page.
contextMenu
The context menu.

See Also

ContextMenuEventArgs Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


ContextMenuEventArgs Properties

The properties of the ContextMenuEventArgs class are listed below. For a complete list of ContextMenuEventArgs class members, see the ContextMenuEventArgs Members topic.

Public Instance Properties

Cancel (inherited from CloseRequestEventArgs) | Cancel this event?
ContextMenu | Gets the context menu.
Node (inherited from CloseRequestEventArgs) | Retrieves the node.
TabControl (inherited from CloseRequestEventArgs) | Retrieves the tab control.
TabPage (inherited from CloseRequestEventArgs) | Retrieves the tab page.

See Also

ContextMenuEventArgs Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


ContextMenuEventArgs.ContextMenu Property

Gets the context menu.

[Visual Basic]
Public ReadOnly Property ContextMenu As ContextMenu
[C#]
public System.Windows.Forms.ContextMenu ContextMenu {get;}

See Also

ContextMenuEventArgs Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


ContextMenuHandler Delegate

Context menu is about to be shown.

[Visual Basic]
Public Delegate Sub ContextMenuHandler( _
ByVal sender As DockingManager, _
ByVal sourceControl As Control, _
ByVal pt As Point, _
ByVal e As EventArgs _
)
[C#]
public delegate void ContextMenuHandler(
DockingManager sender,
Control sourceControl,
Point pt,
EventArgs e
);

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrame Class

Internal.

For a list of all members of this type, see DockFrame Members.

System.Object
MarshalByRefObject
Component
Control
DockFrame

[Visual Basic]
Public Class DockFrame
Inherits Control
[C#]
public class DockFrame : Control

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

DockFrame Members | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrame Members

DockFrame overview

Public Instance Constructors

DockFrame Constructor Internal.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Manager | Internal.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentDockRegion | Internal.
ParentWindow | Internal.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

AddedToParent | Internal.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
NotifyAutoHideImage | Internal.
NotifyCloseButton | Internal.
NotifyFullTitleText | Internal.
NotifyHideButton | Internal.
NotifyRedockAllowed | Internal.
NotifyShowCaptionBar | Internal.
ParentStateChanged | Internal.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemovedFromParent | Internal.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
UpdateNameValue | Internal.
WindowGotFocus | Internal.
WindowLostFocus | Internal.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

DockFrame Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrame Constructor

Internal.

[Visual Basic]
Public Sub New( _
ByVal manager As DockingManager _
)
[C#]
public DockFrame(
DockingManager manager
);

Parameters

manager

See Also

DockFrame Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrame Properties

The properties of the DockFrame class are listed below. For a complete list of DockFrame class members, see the DockFrame Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Manager | Internal.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentDockRegion | Internal.
ParentWindow | Internal.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

See Also

DockFrame Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrame.Manager Property

Internal.

[Visual Basic]
Public Property Manager As DockingManager
[C#]
public DockingManager Manager {get; set;}

See Also

DockFrame Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrame.ParentDockRegion Property

Internal.

[Visual Basic]
Overridable Public Property ParentDockRegion As DockRegion
[C#]
public virtual DockRegion ParentDockRegion {get; set;}

See Also

DockFrame Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrame.ParentWindow Property

Internal.

[Visual Basic]
Public Property ParentWindow As Window
[C#]
public Window ParentWindow {get; set;}

See Also

DockFrame Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrame Methods

The methods of the DockFrame class are listed below. For a complete list of DockFrame class members, see the DockFrame Members topic.

Public Instance Methods

AddedToParent | Internal.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
NotifyAutoHideImage | Internal.
NotifyCloseButton | Internal.
NotifyFullTitleText | Internal.
NotifyHideButton | Internal.
NotifyRedockAllowed | Internal.
NotifyShowCaptionBar | Internal.
ParentStateChanged | Internal.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemovedFromParent | Internal.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
UpdateNameValue | Internal.
WindowGotFocus | Internal.
WindowLostFocus | Internal.

See Also

DockFrame Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrame.AddedToParent Method

Internal.

[Visual Basic]
Overridable Public Sub AddedToParent( _
ByVal parent As Window _
)
[C#]
public virtual void AddedToParent(
Window parent
);

Parameters

parent

See Also

DockFrame Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrame.NotifyAutoHideImage Method

Internal.

[Visual Basic]
Overridable Public Sub NotifyAutoHideImage( _
ByVal autoHidden As Boolean _
)
[C#]
public virtual void NotifyAutoHideImage(
bool autoHidden
);

Parameters

autoHidden

See Also

DockFrame Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrame.NotifyCloseButton Method

Internal.

[Visual Basic]
Overridable Public Sub NotifyCloseButton( _
ByVal show As Boolean _
)
[C#]
public virtual void NotifyCloseButton(
bool show
);

Parameters

show

See Also

DockFrame Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrame.NotifyFullTitleText Method

Internal.

[Visual Basic]
Overridable Public Sub NotifyFullTitleText( _
ByVal title As String _
)
[C#]
public virtual void NotifyFullTitleText(
string title
);

Parameters

title

See Also

DockFrame Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrame.NotifyHideButton Method

Internal.

[Visual Basic]
Overridable Public Sub NotifyHideButton( _
ByVal show As Boolean _
)
[C#]
public virtual void NotifyHideButton(
bool show
);

Parameters

show

See Also

DockFrame Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrame.NotifyRedockAllowed Method

Internal.

[Visual Basic]
Overridable Public Sub NotifyRedockAllowed( _
ByVal redockAllowed As Boolean _
)
[C#]
public virtual void NotifyRedockAllowed(
bool redockAllowed
);

Parameters

redockAllowed

See Also

DockFrame Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrame.NotifyShowCaptionBar Method

Internal.

[Visual Basic]
Overridable Public Sub NotifyShowCaptionBar( _
ByVal show As Boolean _
)
[C#]
public virtual void NotifyShowCaptionBar(
bool show
);

Parameters

show

See Also

DockFrame Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrame.ParentStateChanged Method

Internal.

[Visual Basic]
Overridable Public Sub ParentStateChanged( _
ByVal newState As State _
)
[C#]
public virtual void ParentStateChanged(
State newState
);

Parameters

newState

See Also

DockFrame Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrame.RemovedFromParent Method

Internal.

[Visual Basic]
Overridable Public Sub RemovedFromParent( _
ByVal parent As Window _
)
[C#]
public virtual void RemovedFromParent(
Window parent
);

Parameters

parent

See Also

DockFrame Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrame.UpdateNameValue Method

Internal.

[Visual Basic]
Overridable Public Sub UpdateNameValue( _
ByVal name As UpdateName, _
ByVal value As Object _
)
[C#]
public virtual void UpdateNameValue(
UpdateName name,
object value
);

Parameters

name
value

See Also

DockFrame Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrame.WindowGotFocus Method

Internal.

[Visual Basic]
Overridable Public Sub WindowGotFocus()
[C#]
public virtual void WindowGotFocus();

See Also

DockFrame Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrame.WindowLostFocus Method

Internal.

[Visual Basic]
Overridable Public Sub WindowLostFocus()
[C#]
public virtual void WindowLostFocus();

See Also

DockFrame Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrameCaption Class

Internal.

For a list of all members of this type, see DockFrameCaption Members.

System.Object
MarshalByRefObject
Component
Control
DockFrame
DockFrameCaption

[Visual Basic]
Public Class DockFrameCaption
Inherits DockFrame
Implements System.Windows.Forms.IMessageFilter
[C#]
public class DockFrameCaption : DockFrame, IMessageFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

DockFrameCaption Members | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrameCaption Members

DockFrameCaption overview

Public Instance Constructors

DockFrameCaption Constructor Internal.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CloseButton | Internal.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HideButton | Internal.
IgnoreHideButton | Internal.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Manager (inherited from DockFrame) | Internal.
MaxButton | Internal.
MaxInterface | Internal.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentDockRegion | Internal.
ParentWindow (inherited from DockFrame) | Internal.
PinnedImage | Internal.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Redocker | Internal.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShowCloseButton | Internal.
ShowHideButton | Internal.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

AddedToParent (inherited from DockFrame) | Internal.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
NotifyAutoHideImage | Internal.
NotifyCloseButton | Internal.
NotifyFullTitleText (inherited from DockFrame) | Internal.
NotifyHideButton | Internal.
NotifyRedockAllowed (inherited from DockFrame) | Internal.
NotifyShowCaptionBar | Internal.
OnClose | Internal.
OnContext | Internal.
OnInvertAutoHide | Internal.
OnRestore | Internal.
ParentStateChanged (inherited from DockFrame) | Internal.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreFilterMessage | Internal.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemovedFromParent (inherited from DockFrame) | Internal.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
UpdateNameValue (inherited from DockFrame) | Internal.
WindowGotFocus (inherited from DockFrame) | Internal.
WindowLostFocus (inherited from DockFrame) | Internal.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
Close | Internal.
Context | Internal.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
InvertAutoHide | Internal.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
Restore | Internal.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

DockFrameCaption Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrameCaption Constructor

Internal.

[Visual Basic]
Public Sub New( _
ByVal manager As DockingManager, _
ByVal fixedSize As Size, _
ByVal closeHandler As EventHandler, _
ByVal restoreHandler As EventHandler, _
ByVal invertAutoHideHandler As EventHandler, _
ByVal contextHandler As ContextHandler _
)
[C#]
public DockFrameCaption(
DockingManager manager,
Size fixedSize,
EventHandler closeHandler,
EventHandler restoreHandler,
EventHandler invertAutoHideHandler,
ContextHandler contextHandler
);

Parameters

manager
fixedSize
closeHandler
restoreHandler
invertAutoHideHandler
contextHandler

See Also

DockFrameCaption Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrameCaption Properties

The properties of the DockFrameCaption class are listed below. For a complete list of DockFrameCaption class members, see the DockFrameCaption Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CloseButton | Internal.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HideButton | Internal.
IgnoreHideButton | Internal.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Manager (inherited from DockFrame) | Internal.
MaxButton | Internal.
MaxInterface | Internal.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentDockRegion | Internal.
ParentWindow (inherited from DockFrame) | Internal.
PinnedImage | Internal.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Redocker | Internal.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShowCloseButton | Internal.
ShowHideButton | Internal.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

See Also

DockFrameCaption Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrameCaption.CloseButton Property

Internal.

[Visual Basic]
Public Property CloseButton As CaptionButton
[C#]
public CaptionButton CloseButton {get; set;}

See Also

DockFrameCaption Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrameCaption.HideButton Property

Internal.

[Visual Basic]
Public Property HideButton As CaptionButton
[C#]
public CaptionButton HideButton {get; set;}

See Also

DockFrameCaption Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrameCaption.IgnoreHideButton Property

Internal.

[Visual Basic]
Public Property IgnoreHideButton As Boolean
[C#]
public bool IgnoreHideButton {get; set;}

See Also

DockFrameCaption Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrameCaption.MaxButton Property

Internal.

[Visual Basic]
Public Property MaxButton As CaptionButton
[C#]
public CaptionButton MaxButton {get; set;}

See Also

DockFrameCaption Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrameCaption.MaxInterface Property

Internal.

[Visual Basic]
Public ReadOnly Property MaxInterface As IDockRegionMaximizeWindow
[C#]
public IDockRegionMaximizeWindow MaxInterface {get;}

See Also

DockFrameCaption Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrameCaption.ParentDockRegion Property

Internal.

[Visual Basic]
Overrides Public Property ParentDockRegion As DockRegion
[C#]
public override DockRegion ParentDockRegion {set;}

See Also

DockFrameCaption Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrameCaption.PinnedImage Property

Internal.

[Visual Basic]
Public ReadOnly Property PinnedImage As Boolean
[C#]
public bool PinnedImage {get;}

See Also

DockFrameCaption Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrameCaption.Redocker Property

Internal.

[Visual Basic]
Public ReadOnly Property Redocker As Redocker
[C#]
public Redocker Redocker {get;}

See Also

DockFrameCaption Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrameCaption.ShowCloseButton Property

Internal.

[Visual Basic]
Public ReadOnly Property ShowCloseButton As Boolean
[C#]
public bool ShowCloseButton {get;}

See Also

DockFrameCaption Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrameCaption.ShowHideButton Property

Internal.

[Visual Basic]
Public ReadOnly Property ShowHideButton As Boolean
[C#]
public bool ShowHideButton {get;}

See Also

DockFrameCaption Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrameCaption Methods

The methods of the DockFrameCaption class are listed below. For a complete list of DockFrameCaption class members, see the DockFrameCaption Members topic.

Public Instance Methods

AddedToParent (inherited from DockFrame) | Internal.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
NotifyAutoHideImage | Internal.
NotifyCloseButton | Internal.
NotifyFullTitleText (inherited from DockFrame) | Internal.
NotifyHideButton | Internal.
NotifyRedockAllowed (inherited from DockFrame) | Internal.
NotifyShowCaptionBar | Internal.
OnClose | Internal.
OnContext | Internal.
OnInvertAutoHide | Internal.
OnRestore | Internal.
ParentStateChanged (inherited from DockFrame) | Internal.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreFilterMessage | Internal.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemovedFromParent (inherited from DockFrame) | Internal.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
UpdateNameValue (inherited from DockFrame) | Internal.
WindowGotFocus (inherited from DockFrame) | Internal.
WindowLostFocus (inherited from DockFrame) | Internal.

See Also

DockFrameCaption Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrameCaption.NotifyAutoHideImage Method

Internal.

[Visual Basic]
Overrides Public Sub NotifyAutoHideImage( _
ByVal autoHidden As Boolean _
)
[C#]
public override void NotifyAutoHideImage(
bool autoHidden
);

Parameters

autoHidden

See Also

DockFrameCaption Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrameCaption.NotifyCloseButton Method

Internal.

[Visual Basic]
Overrides Public Sub NotifyCloseButton( _
ByVal show As Boolean _
)
[C#]
public override void NotifyCloseButton(
bool show
);

Parameters

show

See Also

DockFrameCaption Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrameCaption.NotifyHideButton Method

Internal.

[Visual Basic]
Overrides Public Sub NotifyHideButton( _
ByVal show As Boolean _
)
[C#]
public override void NotifyHideButton(
bool show
);

Parameters

show

See Also

DockFrameCaption Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrameCaption.NotifyShowCaptionBar Method

Internal.

[Visual Basic]
Overrides Public Sub NotifyShowCaptionBar( _
ByVal show As Boolean _
)
[C#]
public override void NotifyShowCaptionBar(
bool show
);

Parameters

show

See Also

DockFrameCaption Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrameCaption.OnClose Method

Internal.

[Visual Basic]
Overridable Public Sub OnClose()
[C#]
public virtual void OnClose();

See Also

DockFrameCaption Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrameCaption.OnContext Method

Internal.

[Visual Basic]
Overridable Public Sub OnContext( _
ByVal screenPos As Point _
)
[C#]
public virtual void OnContext(
Point screenPos
);

Parameters

screenPos

See Also

DockFrameCaption Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrameCaption.OnInvertAutoHide Method

Internal.

[Visual Basic]
Overridable Public Sub OnInvertAutoHide()
[C#]
public virtual void OnInvertAutoHide();

See Also

DockFrameCaption Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrameCaption.OnRestore Method

Internal.

[Visual Basic]
Overridable Public Sub OnRestore()
[C#]
public virtual void OnRestore();

See Also

DockFrameCaption Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrameCaption.PreFilterMessage Method

Internal.

[Visual Basic]
NotOverridable Public Function PreFilterMessage( _
ByRef m As Message _
) As Boolean Implements _
IMessageFilter.PreFilterMessage
[C#]
public bool PreFilterMessage(
ref Message m
);

Parameters

m

Return Value

Implements

IMessageFilter.PreFilterMessage

See Also

DockFrameCaption Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrameCaption Events

The events of the DockFrameCaption class are listed below. For a complete list of DockFrameCaption class members, see the DockFrameCaption Members topic.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
Close | Internal.
Context | Internal.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
InvertAutoHide | Internal.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
Restore | Internal.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

DockFrameCaption Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrameCaption.Close Event

Internal.

[Visual Basic]
Public Event Close As EventHandler
[C#]
public event EventHandler Close;

See Also

DockFrameCaption Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrameCaption.Context Event

Internal.

[Visual Basic]
Public Event Context As ContextHandler
[C#]
public event ContextHandler Context;

See Also

DockFrameCaption Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrameCaption.InvertAutoHide Event

Internal.

[Visual Basic]
Public Event InvertAutoHide As EventHandler
[C#]
public event EventHandler InvertAutoHide;

See Also

DockFrameCaption Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrameCaption.Restore Event

Internal.

[Visual Basic]
Public Event Restore As EventHandler
[C#]
public event EventHandler Restore;

See Also

DockFrameCaption Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrameCollection Class

Internal.

For a list of all members of this type, see DockFrameCollection Members.

System.Object
CollectionBase
CollectionEx
DockFrameCollection

[Visual Basic]
NotInheritable Public Class DockFrameCollection
Inherits CollectionEx
[C#]
public sealed class DockFrameCollection : CollectionEx

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

DockFrameCollection Members | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrameCollection Members

DockFrameCollection overview

Public Instance Constructors

DockFrameCollection Constructor Initializes a new instance of the DockFrameCollection class.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
IsSuspended (inherited from CollectionEx) | Is event generation already suspended?
Item | Internal.

Public Instance Methods

Add | Internal.
AddRange | Internal.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Contains | Internal.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Internal.
Insert | Internal.
RaiseChanged (inherited from CollectionEx) | Raises the Changed event.
Remove | Internal.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
ResumeEvents (inherited from CollectionEx) | Resume event generation.
SuspendEvents (inherited from CollectionEx) | Suspend event generation.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

Changed (inherited from CollectionEx) | Event raised when the collection has changed.
Cleared (inherited from CollectionEx) | Event raised when collection has been cleared.
Clearing (inherited from CollectionEx) | Event raised when collection is being cleared.
Inserted (inherited from CollectionEx) | Event raised when an item has been inserted.
Inserting (inherited from CollectionEx) | Event raised when an item is being inserted.
Removed (inherited from CollectionEx) | Event raised when an item has been removed.
Removing (inherited from CollectionEx) | Event raised when an item is being removed.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

DockFrameCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrameCollection Constructor

Initializes a new instance of the DockFrameCollection class.

[Visual Basic]
Public Sub New()
[C#]
public DockFrameCollection();

See Also

DockFrameCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrameCollection Properties

The properties of the DockFrameCollection class are listed below. For a complete list of DockFrameCollection class members, see the DockFrameCollection Members topic.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
IsSuspended (inherited from CollectionEx) | Is event generation already suspended?
Item | Internal.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

DockFrameCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrameCollection.Item Property

Internal.

[Visual Basic]
Public Default ReadOnly Property Item( _
ByVal index As Integer _
) As DockFrame
[C#]
public DockFrame this[
int index
] {get;}

See Also

DockFrameCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrameCollection Methods

The methods of the DockFrameCollection class are listed below. For a complete list of DockFrameCollection class members, see the DockFrameCollection Members topic.

Public Instance Methods

Add | Internal.
AddRange | Internal.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Contains | Internal.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Internal.
Insert | Internal.
RaiseChanged (inherited from CollectionEx) | Raises the Changed event.
Remove | Internal.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
ResumeEvents (inherited from CollectionEx) | Resume event generation.
SuspendEvents (inherited from CollectionEx) | Suspend event generation.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

DockFrameCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrameCollection.Add Method

Internal.

[Visual Basic]
Public Function Add( _
ByVal value As DockFrame _
) As DockFrame
[C#]
public DockFrame Add(
DockFrame value
);

Parameters

value

Return Value

See Also

DockFrameCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrameCollection.AddRange Method

Internal.

[Visual Basic]
Public Sub AddRange( _
ByVal values As DockFrame() _
)
[C#]
public void AddRange(
DockFrame[] values
);

Parameters

values

See Also

DockFrameCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrameCollection.Contains Method

Internal.

[Visual Basic]
Public Function Contains( _
ByVal value As DockFrame _
) As Boolean
[C#]
public bool Contains(
DockFrame value
);

Parameters

value

Return Value

See Also

DockFrameCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrameCollection.IndexOf Method

Internal.

[Visual Basic]
Public Function IndexOf( _
ByVal value As DockFrame _
) As Integer
[C#]
public int IndexOf(
DockFrame value
);

Parameters

value

Return Value

See Also

DockFrameCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrameCollection.Insert Method

Internal.

[Visual Basic]
Public Sub Insert( _
ByVal index As Integer, _
ByVal value As DockFrame _
)
[C#]
public void Insert(
int index,
DockFrame value
);

Parameters

index
value

See Also

DockFrameCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockFrameCollection.Remove Method

Internal.

[Visual Basic]
Public Sub Remove( _
ByVal value As DockFrame _
)
[C#]
public void Remove(
DockFrame value
);

Parameters

value

See Also

DockFrameCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManager Class

A full-featured VS.NET-style docking manager. An instance of the DockingManager class needs to be created and associated with each ContainerControl-derived object you want to have a docking capability. Most of the time this will be your application's top-level Form.

For a list of all members of this type, see DockingManager Members.

System.Object
MarshalByRefObject
Component
DockingManager

[Visual Basic]
NotInheritable Public Class DockingManager
Inherits Component
[C#]
public sealed class DockingManager : Component

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

DockingManager Members | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManager Members

DockingManager overview

Public Instance Constructors

DockingManager Constructor Creates a docking manager with a container and renderer.

Public Instance Properties

AutoResize | When set to True, a resizing of the control will cause the docking windows to be resized smaller if they would start overlapping. Note that the windows will not be sized bigger again when the control is increased in size.
Container (inherited from Component) | Gets the IContainer that contains the Component.
DockContainer | The container.
DockObjects | A collection of objects associated with this dock manager.
DockRegionMinMax | If more than one Window is docked in the same column/row, should they have a maximize capability?
InnerControl | The inner-most control. The InnerControl property needs to be set to the last control in the Forms.Control collection that represents the group of controls that the manager must not dock after.
InnerFill | When set to True, the innermost docking window will assume the Fill docking style so that you can create applications whose client area consists only of docking windows.
InnerMinimum | Defines the minimum size of the inner control, if resizing the application would cause the inner control to become smaller than this then the docking windows are resized smaller instead.
Locked | Is this docking manager locked?
OuterControl | The outer-most control. The OuterControl property needs to be set to the first control in the Forms.Control collection that represents the group of controls that the manager must not dock between.
Renderer | The renderer used to draw the docked objects.
Site (inherited from Component) | Gets or sets the ISite of the Component.
SizeBarWidth | Defines the width/height of resize bars used between docking windows. A value of -1 will cause the appropriate default value for the visual style to be used instead.

Public Instance Methods

AddDockObjectToDockRegion | If you already have a reference to a DockRegion object then this will create a new Window to host the provided DockObject and then add the Window to the given relative position inside the DockRegion.
AddDockObjectToWindowObjects | If you already have a reference to a WindowObjects object then this method will add the provided DockObject into that object.
AddDockObjectWithState | Will create an appropriate Window for hosting the provided DockObject and place inside a new DockRegion which is placed according to the State given.
BringAutoHideIntoView | If the given object instance is in the AutoHide mode then it will be selected and slide out into view.
CreateDockRegionForDockObject | Creates an appropriate DockRegion object and adds it to the managed control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
CreateWindowForDockObject | Overloaded. Used to create an appropriately configured Window object for the given DockObject object. Currently this ensures the caption bar matches the requested style specified in the constructor.
Dispose (inherited from Component) | Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
HideAllDockObjects | Hides all objects.
HideDockObject | Overloaded. If the provided object is visible then it will become hidden.
InitializeControl | Initializes the control.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
InnerResizeRectangle | Internal.
LoadConfigFromArray | Loads layout information from given array of bytes.
LoadConfigFromFile | Loads layout information from given file.
LoadConfigFromStream | Loads layout information from given stream object.
OnDockObjectHiding | Internal.
OuterControlIndex | Internal.
RemoveShowingAutoHideWindows | If any of the AutoHide windows is currently being shown, this will remove it from display immediately.
ReorderDockRegionToInnerMost | Repositions the given reference within the list of Form controls to the innermost valid point.
ReorderDockRegionToOuterMost | Repositions the given reference within the list of Form controls to the outermost valid point.
SaveConfigToArray | Overloaded. Saves layout information into an array of bytes using Encoding.Unicode.
SaveConfigToFile | Overloaded. Saves layout information into a named file using Encoding.Unicode.
SaveConfigToStream | Saves layout information into a stream object using specified encoding.
ShowAllDockObjects | Show all objects.
ShowDockObject | If the provided object is hidden then it will be restored to become visible.
ToggleDockObjectAutoHide | Toggles the auto-hide state of an object.
ToString (inherited from Component) |
UpdateInnerFill | Internal.
UpdateNameValue | Internal.
ValuesFromState | Internal.

Public Instance Events

ContextMenu | Context menu about to be shown.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockObjectHidden | DockObject hidden.
DockObjectHiding | DockObject hiding.
DockObjectShown | DockObject shown.
LoadCustomConfig | Custom configuration about to be loaded.
SaveCustomConfig | Custom configuration about to be saved.
TabControlCreated | A tab control was created.

See Also

DockingManager Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManager Constructor

Creates a docking manager with a container and renderer.

[Visual Basic]
Public Sub New( _
ByVal container As ContainerControl, _
ByVal renderer As IDockingRenderer _
)
[C#]
public DockingManager(
ContainerControl container,
IDockingRenderer renderer
);

Parameters

container
The container to use.
renderer
The renderer to use to draw the docked objects.

See Also

DockingManager Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManager Properties

The properties of the DockingManager class are listed below. For a complete list of DockingManager class members, see the DockingManager Members topic.

Public Instance Properties

AutoResize | When set to True, a resizing of the control will cause the docking windows to be resized smaller if they would start overlapping. Note that the windows will not be sized bigger again when the control is increased in size.
Container (inherited from Component) | Gets the IContainer that contains the Component.
DockContainer | The container.
DockObjects | A collection of objects associated with this dock manager.
DockRegionMinMax | If more than one Window is docked in the same column/row, should they have a maximize capability?
InnerControl | The inner-most control. The InnerControl property needs to be set to the last control in the Forms.Control collection that represents the group of controls that the manager must not dock after.
InnerFill | When set to True, the innermost docking window will assume the Fill docking style so that you can create applications whose client area consists only of docking windows.
InnerMinimum | Defines the minimum size of the inner control, if resizing the application would cause the inner control to become smaller than this then the docking windows are resized smaller instead.
Locked | Is this docking manager locked?
OuterControl | The outer-most control. The OuterControl property needs to be set to the first control in the Forms.Control collection that represents the group of controls that the manager must not dock between.
Renderer | The renderer used to draw the docked objects.
Site (inherited from Component) | Gets or sets the ISite of the Component.
SizeBarWidth | Defines the width/height of resize bars used between docking windows. A value of -1 will cause the appropriate default value for the visual style to be used instead.

See Also

DockingManager Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManager.AutoResize Property

When set to True, a resizing of the control will cause the docking windows to be resized smaller if they would start overlapping. Note that the windows will not be sized bigger again when the control is increased in size.

[Visual Basic]
Public Property AutoResize As Boolean
[C#]
public bool AutoResize {get; set;}

See Also

DockingManager Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManager.DockContainer Property

The container.

[Visual Basic]
Public ReadOnly Property DockContainer As ContainerControl
[C#]
public System.Windows.Forms.ContainerControl DockContainer {get;}

See Also

DockingManager Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManager.DockObjects Property

A collection of objects associated with this dock manager.

[Visual Basic]
Public Property DockObjects As ManagerDockObjectCollection
[C#]
public ManagerDockObjectCollection DockObjects {get; set;}

See Also

DockingManager Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManager.DockRegionMinMax Property

If more than one Window is docked in the same column/row, should they have a maximize capability?

[Visual Basic]
Public Property DockRegionMinMax As Boolean
[C#]
public bool DockRegionMinMax {get; set;}

See Also

DockingManager Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManager.InnerControl Property

The inner-most control. The InnerControl property needs to be set to the last control in the Forms.Control collection that represents the group of controls that the manager must not dock after.

[Visual Basic]
Public Property InnerControl As Control
[C#]
public System.Windows.Forms.Control InnerControl {get; set;}

See Also

DockingManager Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManager.InnerFill Property

When set to True, the innermost docking window will assume the Fill docking style so that you can create applications whose client area consists only of docking windows.

[Visual Basic]
Public Property InnerFill As Boolean
[C#]
public bool InnerFill {get; set;}

See Also

DockingManager Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManager.InnerMinimum Property

Defines the minimum size of the inner control, if resizing the application would cause the inner control to become smaller than this then the docking windows are resized smaller instead.

[Visual Basic]
Public Property InnerMinimum As Size
[C#]
public System.Drawing.Size InnerMinimum {get; set;}

See Also

DockingManager Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManager.Locked Property

Is this docking manager locked?

[Visual Basic]
Public Property Locked As Boolean
[C#]
public bool Locked {get; set;}

See Also

DockingManager Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManager.OuterControl Property

The outer-most control. The OuterControl property needs to be set to the first control in the Forms.Control collection that represents the group of controls that the manager must not dock between.

[Visual Basic]
Public Property OuterControl As Control
[C#]
public System.Windows.Forms.Control OuterControl {get; set;}

See Also

DockingManager Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManager.Renderer Property

The renderer used to draw the docked objects.

[Visual Basic]
Public Property Renderer As IDockingRenderer
[C#]
public IDockingRenderer Renderer {get; set;}

See Also

DockingManager Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManager.SizeBarWidth Property

Defines the width/height of resize bars used between docking windows. A value of -1 will cause the appropriate default value for the visual style to be used instead.

[Visual Basic]
Public Property SizeBarWidth As Integer
[C#]
public int SizeBarWidth {get; set;}

See Also

DockingManager Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManager Methods

The methods of the DockingManager class are listed below. For a complete list of DockingManager class members, see the DockingManager Members topic.

Public Instance Methods

AddDockObjectToDockRegion | If you already have a reference to a DockRegion object then this will create a new Window to host the provided DockObject and then add the Window to the given relative position inside the DockRegion.
AddDockObjectToWindowObjects | If you already have a reference to a WindowObjects object then this method will add the provided DockObject into that object.
AddDockObjectWithState | Will create an appropriate Window for hosting the provided DockObject and place inside a new DockRegion which is placed according to the State given.
BringAutoHideIntoView | If the given object instance is in the AutoHide mode then it will be selected and slide out into view.
CreateDockRegionForDockObject | Creates an appropriate DockRegion object and adds it to the managed control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
CreateWindowForDockObject | Overloaded. Used to create an appropriately configured Window object for the given DockObject object. Currently this ensures the caption bar matches the requested style specified in the constructor.
Dispose (inherited from Component) | Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
HideAllDockObjects | Hides all objects.
HideDockObject | Overloaded. If the provided object is visible then it will become hidden.
InitializeControl | Initializes the control.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
InnerResizeRectangle | Internal.
LoadConfigFromArray | Loads layout information from given array of bytes.
LoadConfigFromFile | Loads layout information from given file.
LoadConfigFromStream | Loads layout information from given stream object.
OnDockObjectHiding | Internal.
OuterControlIndex | Internal.
RemoveShowingAutoHideWindows | If any of the AutoHide windows is currently being shown, this will remove it from display immediately.
ReorderDockRegionToInnerMost | Repositions the given reference within the list of Form controls to the innermost valid point.
ReorderDockRegionToOuterMost | Repositions the given reference within the list of Form controls to the outermost valid point.
SaveConfigToArray | Overloaded. Saves layout information into an array of bytes using Encoding.Unicode.
SaveConfigToFile | Overloaded. Saves layout information into a named file using Encoding.Unicode.
SaveConfigToStream | Saves layout information into a stream object using specified encoding.
ShowAllDockObjects | Show all objects.
ShowDockObject | If the provided object is hidden then it will be restored to become visible.
ToggleDockObjectAutoHide | Toggles the auto-hide state of an object.
ToString (inherited from Component) |
UpdateInnerFill | Internal.
UpdateNameValue | Internal.
ValuesFromState | Internal.

See Also

DockingManager Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManager.AddDockObjectToDockRegion Method

If you already have a reference to a DockRegion object then this will create a new Window to host the provided DockObject and then add the Window to the given relative position inside the DockRegion.

[Visual Basic]
Public Function AddDockObjectToDockRegion( _
ByVal c As DockObject, _
ByVal z As DockRegion, _
ByVal index As Integer _
) As Window
[C#]
public Window AddDockObjectToDockRegion(
DockObject c,
DockRegion z,
int index
);

Parameters

c
The object.
z
The region.
index
The index.

Return Value

The window.

See Also

DockingManager Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManager.AddDockObjectToWindowObjects Method

If you already have a reference to a WindowObjects object then this method will add the provided DockObject into that object.

[Visual Basic]
Public Function AddDockObjectToWindowObjects( _
ByVal c As DockObject, _
ByVal wc As WindowObjects _
) As WindowObjects
[C#]
public WindowObjects AddDockObjectToWindowObjects(
DockObject c,
WindowObjects wc
);

Parameters

c
The object.
wc
The WindowObjects object.

Return Value

The WindowObjects object.

See Also

DockingManager Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManager.AddDockObjectWithState Method

Will create an appropriate Window for hosting the provided DockObject and place inside a new DockRegion which is placed according to the State given.

[Visual Basic]
Public Function AddDockObjectWithState( _
ByVal c As DockObject, _
ByVal newState As State _
) As WindowObjects
[C#]
public WindowObjects AddDockObjectWithState(
DockObject c,
State newState
);

Parameters

c
The object.
newState
The state.

Return Value

The window.

See Also

DockingManager Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManager.BringAutoHideIntoView Method

If the given object instance is in the AutoHide mode then it will be selected and slide out into view.

[Visual Basic]
Public Sub BringAutoHideIntoView( _
ByVal c As DockObject _
)
[C#]
public void BringAutoHideIntoView(
DockObject c
);

Parameters

c
The object.

See Also

DockingManager Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManager.CreateDockRegionForDockObject Method

Creates an appropriate DockRegion object and adds it to the managed control.

[Visual Basic]
Public Function CreateDockRegionForDockObject( _
ByVal regionState As State _
) As DockRegion
[C#]
public DockRegion CreateDockRegionForDockObject(
State regionState
);

Parameters

regionState
The state of the region.

Return Value

The region.

See Also

DockingManager Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


CreateWindowForDockObject Method

NetXP 3.0 Reference

DockingManager.CreateWindowForDockObject Method

Used to create an appropriately configured Window object for the given DockObject object. Currently this ensures the caption bar matches the requested style specified in the constructor.

Overload List

Used to create an appropriately configured Window object for the given DockObject object. Currently this ensures the caption bar matches the requested style specified in the constructor.

public Window CreateWindowForDockObject(DockObject);

Internal.

public Window CreateWindowForDockObject(DockObject,EventHandler,EventHandler,EventHandler,ContextHandler);

See Also

DockingManager Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManager.CreateWindowForDockObject Method (DockObject)

Used to create an appropriately configured Window object for the given DockObject object. Currently this ensures the caption bar matches the requested style specified in the constructor.

[Visual Basic]
Overloads Public Function CreateWindowForDockObject( _
ByVal c As DockObject _
) As Window
[C#]
public Window CreateWindowForDockObject(
DockObject c
);

Parameters

c
The object.

Return Value

The window to use for the object.

See Also

DockingManager Class | NETXP.Controls.Docking Namespace | DockingManager.CreateWindowForDockObject Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManager.CreateWindowForDockObject Method (DockObject, EventHandler, EventHandler, EventHandler, ContextHandler)

Internal.

[Visual Basic]
Overloads Public Function CreateWindowForDockObject( _
ByVal c As DockObject, _
ByVal objClose As EventHandler, _
ByVal restore As EventHandler, _
ByVal invertAutoHide As EventHandler, _
ByVal showContextMenu As ContextHandler _
) As Window
[C#]
public Window CreateWindowForDockObject(
DockObject c,
EventHandler objClose,
EventHandler restore,
EventHandler invertAutoHide,
ContextHandler showContextMenu
);

Parameters

c
objClose
restore
invertAutoHide
showContextMenu

Return Value

See Also

DockingManager Class | NETXP.Controls.Docking Namespace | DockingManager.CreateWindowForDockObject Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManager.HideAllDockObjects Method

Hides all objects.

[Visual Basic]
Public Sub HideAllDockObjects()
[C#]
public void HideAllDockObjects();

See Also

DockingManager Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


HideDockObject Method

NetXP 3.0 Reference

DockingManager.HideDockObject Method

If the provided object is visible then it will become hidden.

Overload List

If the provided object is visible then it will become hidden.

public void HideDockObject(DockObject);

Provides greater control over actions taken when a DockObject becomes hidden. This is provided for internal use by the docking windows framework code.

public void HideDockObject(DockObject,bool,bool);

See Also

DockingManager Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManager.HideDockObject Method (DockObject)

If the provided object is visible then it will become hidden.

[Visual Basic]
Overloads Public Sub HideDockObject( _
ByVal c As DockObject _
)
[C#]
public void HideDockObject(
DockObject c
);

Parameters

c
The object.

See Also

DockingManager Class | NETXP.Controls.Docking Namespace | DockingManager.HideDockObject Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManager.HideDockObject Method (DockObject, Boolean, Boolean)

Provides greater control over actions taken when a DockObject becomes hidden. This is provided for internal use by the docking windows framework code.

[Visual Basic]
Overloads Public Sub HideDockObject( _
ByVal c As DockObject, _
ByVal record As Boolean, _
ByVal reorder As Boolean _
)
[C#]
public void HideDockObject(
DockObject c,
bool record,
bool reorder
);

Parameters

c
The object.
record
If record is set then it will record the current DockObject position before hiding window.
reorder
If reorder is set then it will move the DockObject to the end of the DockObjects collection.

See Also

DockingManager Class | NETXP.Controls.Docking Namespace | DockingManager.HideDockObject Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManager.InitializeControl Method

Initializes the control.

[Visual Basic]
Public Sub InitializeControl()
[C#]
public void InitializeControl();

See Also

DockingManager Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManager.InnerResizeRectangle Method

Internal.

[Visual Basic]
Public Function InnerResizeRectangle( _
ByVal source As Control _
) As Rectangle
[C#]
public Rectangle InnerResizeRectangle(
Control source
);

Parameters

source

Return Value

See Also

DockingManager Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManager.LoadConfigFromArray Method

Loads layout information from given array of bytes.

[Visual Basic]
Public Sub LoadConfigFromArray( _
ByVal buffer As Byte() _
)
[C#]
public void LoadConfigFromArray(
byte[] buffer
);

Parameters

buffer
The byte array.

See Also

DockingManager Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManager.LoadConfigFromFile Method

Loads layout information from given file.

[Visual Basic]
Public Sub LoadConfigFromFile( _
ByVal filename As String _
)
[C#]
public void LoadConfigFromFile(
string filename
);

Parameters

filename
The file.

See Also

DockingManager Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManager.LoadConfigFromStream Method

Loads layout information from given stream object.

[Visual Basic]
Public Sub LoadConfigFromStream( _
ByVal stream As Stream _
)
[C#]
public void LoadConfigFromStream(
Stream stream
);

Parameters

stream
The stream.

See Also

DockingManager Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManager.OnDockObjectHiding Method

Internal.

[Visual Basic]
Public Function OnDockObjectHiding( _
ByVal c As DockObject _
) As Boolean
[C#]
public bool OnDockObjectHiding(
DockObject c
);

Parameters

c

Return Value

See Also

DockingManager Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManager.OuterControlIndex Method

Internal.

[Visual Basic]
Public Function OuterControlIndex() As Integer
[C#]
public int OuterControlIndex();

Return Value

See Also

DockingManager Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManager.RemoveShowingAutoHideWindows Method

If any of the AutoHide windows is currently being shown, this will remove it from display immediately.

[Visual Basic]
Public Sub RemoveShowingAutoHideWindows()
[C#]
public void RemoveShowingAutoHideWindows();

See Also

DockingManager Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManager.ReorderDockRegionToInnerMost Method

Repositions the given reference within the list of Form controls to the innermost valid point.

[Visual Basic]
Public Sub ReorderDockRegionToInnerMost( _
ByVal region As DockRegion _
)
[C#]
public void ReorderDockRegionToInnerMost(
DockRegion region
);

Parameters

region
The region.

See Also

DockingManager Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManager.ReorderDockRegionToOuterMost Method

Repositions the given reference within the list of Form controls to the outermost valid point.

[Visual Basic]
Public Sub ReorderDockRegionToOuterMost( _
ByVal region As DockRegion _
)
[C#]
public void ReorderDockRegionToOuterMost(
DockRegion region
);

Parameters

region
The region.

See Also

DockingManager Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


SaveConfigToArray Method

NetXP 3.0 Reference

DockingManager.SaveConfigToArray Method

Saves layout information into an array of bytes using Encoding.Unicode.

Overload List

Saves layout information into an array of bytes using Encoding.Unicode.

public byte[] SaveConfigToArray();

Saves layout information into an array of bytes using specified encoding.

public byte[] SaveConfigToArray(Encoding);

See Also

DockingManager Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManager.SaveConfigToArray Method ()

Saves layout information into an array of bytes using Encoding.Unicode.

[Visual Basic]
Overloads Public Function SaveConfigToArray() As Byte()
[C#]
public byte[] SaveConfigToArray();

Return Value

An array of bytes.

See Also

DockingManager Class | NETXP.Controls.Docking Namespace | DockingManager.SaveConfigToArray Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManager.SaveConfigToArray Method (Encoding)

Saves layout information into an array of bytes using specified encoding.

[Visual Basic]
Overloads Public Function SaveConfigToArray( _
ByVal encoding As Encoding _
) As Byte()
[C#]
public byte[] SaveConfigToArray(
Encoding encoding
);

Parameters

encoding
The encoding.

Return Value

An array of bytes.

See Also

DockingManager Class | NETXP.Controls.Docking Namespace | DockingManager.SaveConfigToArray Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


SaveConfigToFile Method

NetXP 3.0 Reference

DockingManager.SaveConfigToFile Method

Saves layout information into a named file using Encoding.Unicode.

Overload List

Saves layout information into a named file using Encoding.Unicode.

public void SaveConfigToFile(string);

Saves layout information into a named file using specified encoding.

public void SaveConfigToFile(string,Encoding);

See Also

DockingManager Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManager.SaveConfigToFile Method (String)

Saves layout information into a named file using Encoding.Unicode.

[Visual Basic]
Overloads Public Sub SaveConfigToFile( _
ByVal filename As String _
)
[C#]
public void SaveConfigToFile(
string filename
);

Parameters

filename
The file.

See Also

DockingManager Class | NETXP.Controls.Docking Namespace | DockingManager.SaveConfigToFile Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManager.SaveConfigToFile Method (String, Encoding)

Saves layout information into a named file using specified encoding.

[Visual Basic]
Overloads Public Sub SaveConfigToFile( _
ByVal filename As String, _
ByVal encoding As Encoding _
)
[C#]
public void SaveConfigToFile(
string filename,
Encoding encoding
);

Parameters

filename
The file.
encoding
The encoding.

See Also

DockingManager Class | NETXP.Controls.Docking Namespace | DockingManager.SaveConfigToFile Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManager.SaveConfigToStream Method

Saves layout information into a stream object using specified encoding.

[Visual Basic]
Public Sub SaveConfigToStream( _
ByVal stream As Stream, _
ByVal encoding As Encoding _
)
[C#]
public void SaveConfigToStream(
Stream stream,
Encoding encoding
);

Parameters

stream
The stream.
encoding
The encoding.

See Also

DockingManager Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManager.ShowAllDockObjects Method

Show all objects.

[Visual Basic]
Public Sub ShowAllDockObjects()
[C#]
public void ShowAllDockObjects();

See Also

DockingManager Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManager.ShowDockObject Method

If the provided object is hidden then it will be restored to become visible.

[Visual Basic]
Public Function ShowDockObject( _
ByVal c As DockObject _
) As Boolean
[C#]
public bool ShowDockObject(
DockObject c
);

Parameters

c
DockObject to be shown.

Return Value

True if successful. False if failed.

See Also

DockingManager Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManager.ToggleDockObjectAutoHide Method

Toggles the auto-hide state of an object.

[Visual Basic]
Public Function ToggleDockObjectAutoHide( _
ByVal c As DockObject _
) As Boolean
[C#]
public bool ToggleDockObjectAutoHide(
DockObject c
);

Parameters

c
The object.

Return Value

True if successful. False if failed.

See Also

DockingManager Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManager.UpdateInnerFill Method

Internal.

[Visual Basic]
Public Sub UpdateInnerFill()
[C#]
public void UpdateInnerFill();

See Also

DockingManager Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManager.UpdateNameValue Method

Internal.

[Visual Basic]
Public Sub UpdateNameValue( _
ByVal name As UpdateName, _
ByVal value As Object _
)
[C#]
public void UpdateNameValue(
UpdateName name,
object value
);

Parameters

name
value

See Also

DockingManager Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManager.ValuesFromState Method

Internal.

[Visual Basic]
Public Sub ValuesFromState( _
ByVal newState As State, _
ByRef dockState As DockStyle, _
ByRef direction As Direction _
)
[C#]
public void ValuesFromState(
State newState,
out DockStyle dockState,
out Direction direction
);

Parameters

newState
dockState
direction

See Also

DockingManager Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManager Events

The events of the DockingManager class are listed below. For a complete list of DockingManager class members, see the DockingManager Members topic.

Public Instance Events

ContextMenu | Context menu about to be shown.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockObjectHidden | DockObject hidden.
DockObjectHiding | DockObject hiding.
DockObjectShown | DockObject shown.
LoadCustomConfig | Custom configuration about to be loaded.
SaveCustomConfig | Custom configuration about to be saved.
TabControlCreated | A tab control was created.

See Also

DockingManager Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManager.ContextMenu Event

Context menu about to be shown.

[Visual Basic]
Public Event ContextMenu As ContextMenuHandler
[C#]
public event ContextMenuHandler ContextMenu;

See Also

DockingManager Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManager.DockObjectHidden Event

DockObject hidden.

[Visual Basic]
Public Event DockObjectHidden As DockObjectHandler
[C#]
public event DockObjectHandler DockObjectHidden;

See Also

DockingManager Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManager.DockObjectHiding Event

DockObject hiding.

[Visual Basic]
Public Event DockObjectHiding As DockObjectHidingHandler
[C#]
public event DockObjectHidingHandler DockObjectHiding;

See Also

DockingManager Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManager.DockObjectShown Event

DockObject shown.

[Visual Basic]
Public Event DockObjectShown As DockObjectHandler
[C#]
public event DockObjectHandler DockObjectShown;

See Also

DockingManager Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManager.LoadCustomConfig Event

Custom configuration about to be loaded.

[Visual Basic]
Public Event LoadCustomConfig As LoadCustomConfigHandler
[C#]
public event LoadCustomConfigHandler LoadCustomConfig;

See Also

DockingManager Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManager.SaveCustomConfig Event

Custom configuration about to be saved.

[Visual Basic]
Public Event SaveCustomConfig As SaveCustomConfigHandler
[C#]
public event SaveCustomConfigHandler SaveCustomConfig;

See Also

DockingManager Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManager.TabControlCreated Event

A tab control was created.

[Visual Basic]
Public Event TabControlCreated As TabControlCreatedHandler
[C#]
public event TabControlCreatedHandler TabControlCreated;

See Also

DockingManager Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManagerExtender Class

DockingManagerExtender enhances the DockingManager for design time. It extends the controls on your form with properties, which defines the docking behaviour at run time.

For a list of all members of this type, see DockingManagerExtender Members.

System.Object
MarshalByRefObject
Component
DockingManagerExtender

[Visual Basic]
Public Class DockingManagerExtender
Inherits Component
Implements System.ComponentModel.IExtenderProvider
[C#]
public class DockingManagerExtender : Component, IExtenderProvider

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

DockingManagerExtender Members | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManagerExtender Members

DockingManagerExtender overview

Public Instance Constructors

DockingManagerExtender Overloaded. Initializes a new instance of the DockingManagerExtender class.

Public Instance Properties

AutomaticStatePersistence | Enable or disable the Automatic State Persistence feature. If enabled the customized docking settings made by the user are persistent by User/Domain/WorkingArea
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerControl | Gets or sets the object to which the docking manager instance is attached
DockingManager | The wrapped DockingManager. Direct access to all properties.
InnerControl | Sets or gets the Control for which the docking windows will not be allowed to dock inside of the specified control.
OuterControl | Sets or gets the Control for which docking windows will not be allowed to dock outside of the specified control.
Site (inherited from Component) | Gets or sets the ISite of the Component.

Public Instance Methods

CanExtend | Internal.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAllowDocking | Gets if control is in dock mode.
GetCaptionBar | Gets the caption bar property.
GetCloseButton | Gets the enable and disable state of the close button for this docking window.
GetCloseOnHide | Gets the close-on-hide property.
GetDockingStyle | Gets the dock style for the control.
GetFullTitle | Gets the text displayed in docking control title.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetHideButton | Gets the hide button property.
GetIcon | Gets the icon displayed in tabbed/hide mode.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetMinimumSize | Gets the minimum size property.
GetTabbedMode | Gets the mode for tabbed docking.
GetTitle | Gets the text displayed in tabbed/hide mode.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
LoadConfigFromStream | Restores the docking configuration.
ResetAutoPersistent | Reset Automatic State Persistence
SaveConfigToStream | Stores the docking configuration.
SetAllowDocking | Enables and disabled the docking for the control.
SetCaptionBar | Sets the caption bar property.
SetCloseButton | Enable and disables the close button of the docking window.
SetCloseOnHide | Sets the close-on-hide property.
SetDockingStyle | Sets the dock style for the control.
SetFullTitle | Sets the text displayed in docking control title.
SetHideButton | Sets the hide button property.
SetIcon | Sets the icon displayed in tabbed/hide mode.
SetMinimumSize | Sets the minimum size property.
SetTabbedMode | Sets the mode for tabbed docking.
SetTitle | Sets the text displayed in tabbed/hide mode.
ToString (inherited from Component) |

Public Instance Events

Closed | The docking manager extender has finished closing.
Closing | The docking manager extender is closing.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
Loaded | The docking manager extender has finished loading.
Loading | The docking manager extender is loading.

See Also

DockingManagerExtender Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManagerExtender Constructor

Internal.

Overload List

Internal.

public DockingManagerExtender();

Internal.

public DockingManagerExtender(IContainer);

See Also

DockingManagerExtender Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManagerExtender Constructor (IContainer)

Internal.

[Visual Basic]
Overloads Public Sub New( _
ByVal container As IContainer _
)
[C#]
public DockingManagerExtender(
IContainer container
);

Parameters

container

See Also

DockingManagerExtender Class | NETXP.Controls.Docking Namespace | DockingManagerExtender Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManagerExtender Constructor ()

Internal.

[Visual Basic]
Overloads Public Sub New()
[C#]
public DockingManagerExtender();

See Also

DockingManagerExtender Class | NETXP.Controls.Docking Namespace | DockingManagerExtender Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManagerExtender Properties

The properties of the DockingManagerExtender class are listed below. For a complete list of DockingManagerExtender class members, see the DockingManagerExtender Members topic.

Public Instance Properties

AutomaticStatePersistence | Enable or disable the Automatic State Persistence feature. If enabled the customized docking settings made by the user are persistent by User/Domain/WorkingArea
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerControl | Gets or sets the object to which the docking manager instance is attached
DockingManager | The wrapped DockingManager. Direct access to all properties.
InnerControl | Sets or gets the Control for which the docking windows will not be allowed to dock inside of the specified control.
OuterControl | Sets or gets the Control for which docking windows will not be allowed to dock outside of the specified control.
Site (inherited from Component) | Gets or sets the ISite of the Component.

See Also

DockingManagerExtender Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManagerExtender.AutomaticStatePersistence Property

Enable or disable the Automatic State Persistence feature. If enabled the customized docking settings made by the user are persistent by User/Domain/WorkingArea

[Visual Basic]
Public Property AutomaticStatePersistence As Boolean
[C#]
public bool AutomaticStatePersistence {get; set;}

See Also

DockingManagerExtender Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManagerExtender.ContainerControl Property

Gets or sets the object to which the docking manager instance is attached

[Visual Basic]
Public Property ContainerControl As ContainerControl
[C#]
public System.Windows.Forms.ContainerControl ContainerControl {get; set;}

See Also

DockingManagerExtender Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManagerExtender.DockingManager Property

The wrapped DockingManager. Direct access to all properties.

[Visual Basic]
Public ReadOnly Property DockingManager As DockingManager
[C#]
public DockingManager DockingManager {get;}

See Also

DockingManagerExtender Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManagerExtender.InnerControl Property

Sets or gets the Control for which the docking windows will not be allowed to dock inside of the specified control.

[Visual Basic]
Public Property InnerControl As Control
[C#]
public System.Windows.Forms.Control InnerControl {get; set;}

See Also

DockingManagerExtender Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManagerExtender.OuterControl Property

Sets or gets the Control for which docking windows will not be allowed to dock outside of the specified control.

[Visual Basic]
Public Property OuterControl As Control
[C#]
public System.Windows.Forms.Control OuterControl {get; set;}

See Also

DockingManagerExtender Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManagerExtender Methods

The methods of the DockingManagerExtender class are listed below. For a complete list of DockingManagerExtender class members, see the DockingManagerExtender Members topic.

Public Instance Methods

CanExtend | Internal.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAllowDocking | Gets if control is in dock mode.
GetCaptionBar | Gets the caption bar property.
GetCloseButton | Gets the enable and disable state of the close button for this docking window.
GetCloseOnHide | Gets the close-on-hide property.
GetDockingStyle | Gets the dock style for the control.
GetFullTitle | Gets the text displayed in docking control title.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetHideButton | Gets the hide button property.
GetIcon | Gets the icon displayed in tabbed/hide mode.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetMinimumSize | Gets the minimum size property.
GetTabbedMode | Gets the mode for tabbed docking.
GetTitle | Gets the text displayed in tabbed/hide mode.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
LoadConfigFromStream | Restores the docking configuration.
ResetAutoPersistent | Reset Automatic State Persistence
SaveConfigToStream | Stores the docking configuration.
SetAllowDocking | Enables and disabled the docking for the control.
SetCaptionBar | Sets the caption bar property.
SetCloseButton | Enable and disables the close button of the docking window.
SetCloseOnHide | Sets the close-on-hide property.
SetDockingStyle | Sets the dock style for the control.
SetFullTitle | Sets the text displayed in docking control title.
SetHideButton | Sets the hide button property.
SetIcon | Sets the icon displayed in tabbed/hide mode.
SetMinimumSize | Sets the minimum size property.
SetTabbedMode | Sets the mode for tabbed docking.
SetTitle | Sets the text displayed in tabbed/hide mode.
ToString (inherited from Component) |

See Also

DockingManagerExtender Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManagerExtender.CanExtend Method

Internal.

[Visual Basic]
NotOverridable Public Function CanExtend( _
ByVal extendee As Object _
) As Boolean Implements _
IExtenderProvider.CanExtend
[C#]
public bool CanExtend(
object extendee
);

Parameters

extendee

Return Value

Implements

IExtenderProvider.CanExtend

See Also

DockingManagerExtender Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManagerExtender.GetAllowDocking Method

Gets if control is in dock mode.

[Visual Basic]
Public Function GetAllowDocking( _
ByVal control As Control _
) As Boolean
[C#]
public bool GetAllowDocking(
Control control
);

Parameters

control

Return Value

See Also

DockingManagerExtender Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManagerExtender.GetCaptionBar Method

Gets the caption bar property.

[Visual Basic]
Public Function GetCaptionBar( _
ByVal control As Control _
) As Boolean
[C#]
public bool GetCaptionBar(
Control control
);

Parameters

control

Return Value

See Also

DockingManagerExtender Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManagerExtender.GetCloseButton Method

Gets the enable and disable state of the close button for this docking window.

[Visual Basic]
Public Function GetCloseButton( _
ByVal control As Control _
) As Boolean
[C#]
public bool GetCloseButton(
Control control
);

Parameters

control

Return Value

See Also

DockingManagerExtender Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManagerExtender.GetCloseOnHide Method

Gets the close-on-hide property.

[Visual Basic]
Public Function GetCloseOnHide( _
ByVal control As Control _
) As Boolean
[C#]
public bool GetCloseOnHide(
Control control
);

Parameters

control

Return Value

See Also

DockingManagerExtender Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManagerExtender.GetDockingStyle Method

Gets the dock style for the control.

[Visual Basic]
Public Function GetDockingStyle( _
ByVal control As Control _
) As DockStyle
[C#]
public DockStyle GetDockingStyle(
Control control
);

Parameters

control

Return Value

See Also

DockingManagerExtender Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManagerExtender.GetFullTitle Method

Gets the text displayed in docking control title.

[Visual Basic]
Public Function GetFullTitle( _
ByVal control As Control _
) As String
[C#]
public string GetFullTitle(
Control control
);

Parameters

control

Return Value

See Also

DockingManagerExtender Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManagerExtender.GetHideButton Method

Gets the hide button property.

[Visual Basic]
Public Function GetHideButton( _
ByVal control As Control _
) As Boolean
[C#]
public bool GetHideButton(
Control control
);

Parameters

control

Return Value

See Also

DockingManagerExtender Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManagerExtender.GetIcon Method

Gets the icon displayed in tabbed/hide mode.

[Visual Basic]
Public Function GetIcon( _
ByVal control As Control _
) As Image
[C#]
public Image GetIcon(
Control control
);

Parameters

control

Return Value

See Also

DockingManagerExtender Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManagerExtender.GetMinimumSize Method

Gets the minimum size property.

[Visual Basic]
Public Function GetMinimumSize( _
ByVal control As Control _
) As Integer
[C#]
public int GetMinimumSize(
Control control
);

Parameters

control

Return Value

See Also

DockingManagerExtender Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManagerExtender.GetTabbedMode Method

Gets the mode for tabbed docking.

[Visual Basic]
Public Function GetTabbedMode( _
ByVal control As Control _
) As Boolean
[C#]
public bool GetTabbedMode(
Control control
);

Parameters

control

Return Value

See Also

DockingManagerExtender Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManagerExtender.GetTitle Method

Gets the text displayed in tabbed/hide mode.

[Visual Basic]
Public Function GetTitle( _
ByVal control As Control _
) As String
[C#]
public string GetTitle(
Control control
);

Parameters

control

Return Value

See Also

DockingManagerExtender Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManagerExtender.LoadConfigFromStream Method

Restores the docking configuration.

[Visual Basic]
Public Sub LoadConfigFromStream( _
ByVal stream As Stream _
)
[C#]
public void LoadConfigFromStream(
Stream stream
);

Parameters

stream
Valid stream

See Also

DockingManagerExtender Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManagerExtender.ResetAutoPersistent Method

Reset Automatic State Persistence

[Visual Basic]
Public Sub ResetAutoPersistent( _
ByVal currentWorkingArea As Boolean _
)
[C#]
public void ResetAutoPersistent(
bool currentWorkingArea
);

See Also

DockingManagerExtender Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManagerExtender.SaveConfigToStream Method

Stores the docking configuration.

[Visual Basic]
Public Sub SaveConfigToStream( _
ByVal stream As Stream _
)
[C#]
public void SaveConfigToStream(
Stream stream
);

Parameters

stream
Valid stream

See Also

DockingManagerExtender Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManagerExtender.SetAllowDocking Method

Enables and disabled the docking for the control.

[Visual Basic]
Public Sub SetAllowDocking( _
ByVal control As Control, _
ByVal enable As Boolean _
)
[C#]
public void SetAllowDocking(
Control control,
bool enable
);

Parameters

control
enable

See Also

DockingManagerExtender Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManagerExtender.SetCaptionBar Method

Sets the caption bar property.

[Visual Basic]
Public Sub SetCaptionBar( _
ByVal control As Control, _
ByVal enable As Boolean _
)
[C#]
public void SetCaptionBar(
Control control,
bool enable
);

Parameters

control
enable

See Also

DockingManagerExtender Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManagerExtender.SetCloseButton Method

Enable and disables the close button of the docking window.

[Visual Basic]
Public Sub SetCloseButton( _
ByVal control As Control, _
ByVal enable As Boolean _
)
[C#]
public void SetCloseButton(
Control control,
bool enable
);

Parameters

control
enable

See Also

DockingManagerExtender Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManagerExtender.SetCloseOnHide Method

Sets the close-on-hide property.

[Visual Basic]
Public Sub SetCloseOnHide( _
ByVal control As Control, _
ByVal enable As Boolean _
)
[C#]
public void SetCloseOnHide(
Control control,
bool enable
);

Parameters

control
enable

See Also

DockingManagerExtender Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManagerExtender.SetDockingStyle Method

Sets the dock style for the control.

[Visual Basic]
Public Sub SetDockingStyle( _
ByVal control As Control, _
ByVal dockState As DockStyle _
)
[C#]
public void SetDockingStyle(
Control control,
DockStyle dockState
);

Parameters

control
dockState

See Also

DockingManagerExtender Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManagerExtender.SetFullTitle Method

Sets the text displayed in docking control title.

[Visual Basic]
Public Sub SetFullTitle( _
ByVal control As Control, _
ByVal title As String _
)
[C#]
public void SetFullTitle(
Control control,
string title
);

Parameters

control
title

See Also

DockingManagerExtender Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManagerExtender.SetHideButton Method

Sets the hide button property.

[Visual Basic]
Public Sub SetHideButton( _
ByVal control As Control, _
ByVal enable As Boolean _
)
[C#]
public void SetHideButton(
Control control,
bool enable
);

Parameters

control
enable

See Also

DockingManagerExtender Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManagerExtender.SetIcon Method

Sets the icon displayed in tabbed/hide mode.

[Visual Basic]
Public Sub SetIcon( _
ByVal control As Control, _
ByVal icon As Image _
)
[C#]
public void SetIcon(
Control control,
Image icon
);

Parameters

control
icon

See Also

DockingManagerExtender Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManagerExtender.SetMinimumSize Method

Sets the minimum size property.

[Visual Basic]
Public Sub SetMinimumSize( _
ByVal control As Control, _
ByVal size As Integer _
)
[C#]
public void SetMinimumSize(
Control control,
int size
);

Parameters

control
size

See Also

DockingManagerExtender Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManagerExtender.SetTabbedMode Method

Sets the mode for tabbed docking.

[Visual Basic]
Public Sub SetTabbedMode( _
ByVal control As Control, _
ByVal value As Boolean _
)
[C#]
public void SetTabbedMode(
Control control,
bool value
);

Parameters

control
value

See Also

DockingManagerExtender Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManagerExtender.SetTitle Method

Sets the text displayed in tabbed/hide mode.

[Visual Basic]
Public Sub SetTitle( _
ByVal control As Control, _
ByVal title As String _
)
[C#]
public void SetTitle(
Control control,
string title
);

Parameters

control
title

See Also

DockingManagerExtender Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManagerExtender Events

The events of the DockingManagerExtender class are listed below. For a complete list of DockingManagerExtender class members, see the DockingManagerExtender Members topic.

Public Instance Events

Closed | The docking manager extender has finished closing.
Closing | The docking manager extender is closing.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
Loaded | The docking manager extender has finished loading.
Loading | The docking manager extender is loading.

See Also

DockingManagerExtender Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManagerExtender.Closed Event

The docking manager extender has finished closing.

[Visual Basic]
Public Event Closed As EventHandler
[C#]
public event EventHandler Closed;

See Also

DockingManagerExtender Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManagerExtender.Closing Event

The docking manager extender is closing.

[Visual Basic]
Public Event Closing As EventHandler
[C#]
public event EventHandler Closing;

See Also

DockingManagerExtender Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManagerExtender.Loaded Event

The docking manager extender has finished loading.

[Visual Basic]
Public Event Loaded As EventHandler
[C#]
public event EventHandler Loaded;

See Also

DockingManagerExtender Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockingManagerExtender.Loading Event

The docking manager extender is loading.

[Visual Basic]
Public Event Loading As EventHandler
[C#]
public event EventHandler Loading;

See Also

DockingManagerExtender Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObject Class

A docking object.

For a list of all members of this type, see DockObject Members.

System.Object
DockObject

[Visual Basic]
Public Class DockObject
[C#]
public class DockObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

DockObject Members | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObject Members

DockObject overview

Public Static (Shared) Properties

DefaultAutoHideSize | The default size for auto-hidden objects.
DefaultDisplayLocation | The default location for floating objects.
DefaultDisplaySize | The default size for docked objects.
DefaultFloatingSize | The default size for floating objects.

Public Instance Constructors

DockObject Overloaded. Initializes a new instance of the DockObject class.

Public Instance Properties

AutoHidden | Gets/sets if the object is auto-hidden.
AutoHidePanel | Gets/sets the auto-hide panel, if any.
AutoHideRestore | The auto-hide restore object for this object.
AutoHideSize | Gets/sets the auto hide size of the object.
CaptionBar | Should the object have a caption bar?
CloseButton | Should the object have a close button?
CloseOnHide | Should the object be closed when auto-hidden?
Control | Gets/sets the control assigned to this object.
DefaultRestore | The default restore object for this object.
DisplayLocation | Gets/sets the location of the object.
DisplaySize | Gets/sets the display size of the object.
Docked | Gets/sets if the object is docked.
DockingManager | Gets/sets the docking manager used by this object.
DockingRestore | The docking restore object for this object.
FloatingRestore | The floating restore object for this object.
FloatingSize | Gets/sets the floating size of the object.
FullTitle | Gets/sets the full title assigned to this object.
HideButton | Should the object have an auto-hide button?
Icon | Gets/sets the icon assigned to this object.
MinimumSize | The minimum size of this object.
Order | Gets the order of the object.
ParentWindowObjects | Gets/sets the parent window object.
Tag | An object associated with this object.
Title | Gets/sets the title assigned to this object.
Visible | Is this object visible?

Public Instance Methods

BringToFront | Brings the object to front.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
OnPropertyChanged | Internal.
OnPropertyChanging | Internal.
RecordAutoHideRestore | Records a restore object.
RecordDockingRestore | Records a restore object.
RecordFloatingRestore | Records a restore object.
RecordRestore | Records a restore object.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateVisibility | Updates the object's visibility.

Public Instance Events

PropertyChanged | A property has changed.
PropertyChanging | A property is changing.

See Also

DockObject Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObject Constructor

Constructs a new docking object. Internal.

Overload List

Constructs a new object for the specified dock manager.

public DockObject(DockingManager);

Constructs a new object for the specified dock manager and assigns it the specified control.

public DockObject(DockingManager,Control);

Constructs a new object for the specified dock manager, assigns it the specified control, and gives it the specified title.

public DockObject(DockingManager,Control,string);

Constructs a new object for the specified dock manager, assigns it the specified control and title, and gives it the specified icon.

public DockObject(DockingManager,Control,string,Image);

Constructs a new docking object. Internal.

public DockObject(XmlTextReader,int);

See Also

DockObject Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObject Constructor (XmlTextReader, Int32)

Constructs a new docking object. Internal.

[Visual Basic]
Overloads Public Sub New( _
ByVal xmlIn As XmlTextReader, _
ByVal formatVersion As Integer _
)
[C#]
public DockObject(
XmlTextReader xmlIn,
int formatVersion
);

Parameters

xmlIn
formatVersion

See Also

DockObject Class | NETXP.Controls.Docking Namespace | DockObject Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObject Constructor (DockingManager)

Constructs a new object for the specified dock manager.

[Visual Basic]
Overloads Public Sub New( _
ByVal manager As DockingManager _
)
[C#]
public DockObject(
DockingManager manager
);

Parameters

manager
The dock manager.

See Also

DockObject Class | NETXP.Controls.Docking Namespace | DockObject Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObject Constructor (DockingManager, Control)

Constructs a new object for the specified dock manager and assigns it the specified control.

[Visual Basic]
Overloads Public Sub New( _
ByVal manager As DockingManager, _
ByVal control As Control _
)
[C#]
public DockObject(
DockingManager manager,
Control control
);

Parameters

manager
The dock manager.
control
The control.

See Also

DockObject Class | NETXP.Controls.Docking Namespace | DockObject Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObject Constructor (DockingManager, Control, String)

Constructs a new object for the specified dock manager, assigns it the specified control, and gives it the specified title.

[Visual Basic]
Overloads Public Sub New( _
ByVal manager As DockingManager, _
ByVal control As Control, _
ByVal title As String _
)
[C#]
public DockObject(
DockingManager manager,
Control control,
string title
);

Parameters

manager
The cock manager.
control
The control.
title
The title.

See Also

DockObject Class | NETXP.Controls.Docking Namespace | DockObject Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObject Constructor (DockingManager, Control, String, Image)

Constructs a new object for the specified dock manager, assigns it the specified control and title, and gives it the specified icon.

[Visual Basic]
Overloads Public Sub New( _
ByVal manager As DockingManager, _
ByVal control As Control, _
ByVal title As String, _
ByVal icon As Image _
)
[C#]
public DockObject(
DockingManager manager,
Control control,
string title,
Image icon
);

Parameters

manager
The dock manager.
control
The control.
title
The title.
icon
The icon.

See Also

DockObject Class | NETXP.Controls.Docking Namespace | DockObject Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObject Properties

The properties of the DockObject class are listed below. For a complete list of DockObject class members, see the DockObject Members topic.

Public Static (Shared) Properties

DefaultAutoHideSize | The default size for auto-hidden objects.
DefaultDisplayLocation | The default location for floating objects.
DefaultDisplaySize | The default size for docked objects.
DefaultFloatingSize | The default size for floating objects.

Public Instance Properties

AutoHidden | Gets/sets if the object is auto-hidden.
AutoHidePanel | Gets/sets the auto-hide panel, if any.
AutoHideRestore | The auto-hide restore object for this object.
AutoHideSize | Gets/sets the auto hide size of the object.
CaptionBar | Should the object have a caption bar?
CloseButton | Should the object have a close button?
CloseOnHide | Should the object be closed when auto-hidden?
Control | Gets/sets the control assigned to this object.
DefaultRestore | The default restore object for this object.
DisplayLocation | Gets/sets the location of the object.
DisplaySize | Gets/sets the display size of the object.
Docked | Gets/sets if the object is docked.
DockingManager | Gets/sets the docking manager used by this object.
DockingRestore | The docking restore object for this object.
FloatingRestore | The floating restore object for this object.
FloatingSize | Gets/sets the floating size of the object.
FullTitle | Gets/sets the full title assigned to this object.
HideButton | Should the object have an auto-hide button?
Icon | Gets/sets the icon assigned to this object.
MinimumSize | The minimum size of this object.
Order | Gets the order of the object.
ParentWindowObjects | Gets/sets the parent window object.
Tag | An object associated with this object.
Title | Gets/sets the title assigned to this object.
Visible | Is this object visible?

See Also

DockObject Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObject.AutoHidden Property

Gets/sets if the object is auto-hidden.

[Visual Basic]
Public Property AutoHidden As Boolean
[C#]
public bool AutoHidden {get; set;}

See Also

DockObject Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObject.AutoHidePanel Property

Gets/sets the auto-hide panel, if any.

[Visual Basic]
Public Property AutoHidePanel As AutoHidePanel
[C#]
public AutoHidePanel AutoHidePanel {get; set;}

See Also

DockObject Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObject.AutoHideRestore Property

The auto-hide restore object for this object.

[Visual Basic]
Public Property AutoHideRestore As Restore
[C#]
public Restore AutoHideRestore {get; set;}

See Also

DockObject Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObject.AutoHideSize Property

Gets/sets the auto hide size of the object.

[Visual Basic]
Public Property AutoHideSize As Size
[C#]
public System.Drawing.Size AutoHideSize {get; set;}

See Also

DockObject Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObject.CaptionBar Property

Should the object have a caption bar?

[Visual Basic]
Public Property CaptionBar As Boolean
[C#]
public bool CaptionBar {get; set;}

See Also

DockObject Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObject.CloseButton Property

Should the object have a close button?

[Visual Basic]
Public Property CloseButton As Boolean
[C#]
public bool CloseButton {get; set;}

See Also

DockObject Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObject.CloseOnHide Property

Should the object be closed when auto-hidden?

[Visual Basic]
Public Property CloseOnHide As Boolean
[C#]
public bool CloseOnHide {get; set;}

See Also

DockObject Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObject.Control Property

Gets/sets the control assigned to this object.

[Visual Basic]
Public Property Control As Control
[C#]
public System.Windows.Forms.Control Control {get; set;}

See Also

DockObject Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObject.DefaultAutoHideSize Property

The default size for auto-hidden objects.

[Visual Basic]
Public Shared ReadOnly Property DefaultAutoHideSize As Size
[C#]
public static System.Drawing.Size DefaultAutoHideSize {get;}

See Also

DockObject Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObject.DefaultDisplayLocation Property

The default location for floating objects.

[Visual Basic]
Public Shared ReadOnly Property DefaultDisplayLocation As Point
[C#]
public static System.Drawing.Point DefaultDisplayLocation {get;}

See Also

DockObject Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObject.DefaultDisplaySize Property

The default size for docked objects.

[Visual Basic]
Public Shared ReadOnly Property DefaultDisplaySize As Size
[C#]
public static System.Drawing.Size DefaultDisplaySize {get;}

See Also

DockObject Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObject.DefaultFloatingSize Property

The default size for floating objects.

[Visual Basic]
Public Shared ReadOnly Property DefaultFloatingSize As Size
[C#]
public static System.Drawing.Size DefaultFloatingSize {get;}

See Also

DockObject Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObject.DefaultRestore Property

The default restore object for this object.

[Visual Basic]
Public Property DefaultRestore As Restore
[C#]
public Restore DefaultRestore {get; set;}

See Also

DockObject Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObject.DisplayLocation Property

Gets/sets the location of the object.

[Visual Basic]
Public Property DisplayLocation As Point
[C#]
public System.Drawing.Point DisplayLocation {get; set;}

See Also

DockObject Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObject.DisplaySize Property

Gets/sets the display size of the object.

[Visual Basic]
Public Property DisplaySize As Size
[C#]
public System.Drawing.Size DisplaySize {get; set;}

See Also

DockObject Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObject.Docked Property

Gets/sets if the object is docked.

[Visual Basic]
Public Property Docked As Boolean
[C#]
public bool Docked {get; set;}

See Also

DockObject Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObject.DockingManager Property

Gets/sets the docking manager used by this object.

[Visual Basic]
Public Property DockingManager As DockingManager
[C#]
public DockingManager DockingManager {get; set;}

See Also

DockObject Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObject.DockingRestore Property

The docking restore object for this object.

[Visual Basic]
Public Property DockingRestore As Restore
[C#]
public Restore DockingRestore {get; set;}

See Also

DockObject Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObject.FloatingRestore Property

The floating restore object for this object.

[Visual Basic]
Public Property FloatingRestore As Restore
[C#]
public Restore FloatingRestore {get; set;}

See Also

DockObject Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObject.FloatingSize Property

Gets/sets the floating size of the object.

[Visual Basic]
Public Property FloatingSize As Size
[C#]
public System.Drawing.Size FloatingSize {get; set;}

See Also

DockObject Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObject.FullTitle Property

Gets/sets the full title assigned to this object.

[Visual Basic]
Public Property FullTitle As String
[C#]
public string FullTitle {get; set;}

See Also

DockObject Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObject.HideButton Property

Should the object have an auto-hide button?

[Visual Basic]
Public Property HideButton As Boolean
[C#]
public bool HideButton {get; set;}

See Also

DockObject Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObject.Icon Property

Gets/sets the icon assigned to this object.

[Visual Basic]
Public Property Icon As Image
[C#]
public System.Drawing.Image Icon {get; set;}

See Also

DockObject Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObject.MinimumSize Property

The minimum size of this object.

[Visual Basic]
Public Property MinimumSize As Integer
[C#]
public int MinimumSize {get; set;}

See Also

DockObject Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObject.Order Property

Gets the order of the object.

[Visual Basic]
Public ReadOnly Property Order As Integer
[C#]
public int Order {get;}

See Also

DockObject Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObject.ParentWindowObjects Property

Gets/sets the parent window object.

[Visual Basic]
Public Property ParentWindowObjects As WindowObjects
[C#]
public WindowObjects ParentWindowObjects {get; set;}

See Also

DockObject Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObject.Tag Property

An object associated with this object.

[Visual Basic]
Public Property Tag As Object
[C#]
public object Tag {get; set;}

See Also

DockObject Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObject.Title Property

Gets/sets the title assigned to this object.

[Visual Basic]
Public Property Title As String
[C#]
public string Title {get; set;}

See Also

DockObject Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObject.Visible Property

Is this object visible?

[Visual Basic]
Public ReadOnly Property Visible As Boolean
[C#]
public bool Visible {get;}

See Also

DockObject Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObject Methods

The methods of the DockObject class are listed below. For a complete list of DockObject class members, see the DockObject Members topic.

Public Instance Methods

BringToFront | Brings the object to front.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
OnPropertyChanged | Internal.
OnPropertyChanging | Internal.
RecordAutoHideRestore | Records a restore object.
RecordDockingRestore | Records a restore object.
RecordFloatingRestore | Records a restore object.
RecordRestore | Records a restore object.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateVisibility | Updates the object's visibility.

See Also

DockObject Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObject.BringToFront Method

Brings the object to front.

[Visual Basic]
Public Sub BringToFront()
[C#]
public void BringToFront();

See Also

DockObject Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObject.OnPropertyChanged Method

Internal.

[Visual Basic]
Overridable Public Sub OnPropertyChanged( _
ByVal prop As Property _
)
[C#]
public virtual void OnPropertyChanged(
Property prop
);

Parameters

prop

See Also

DockObject Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObject.OnPropertyChanging Method

Internal.

[Visual Basic]
Overridable Public Sub OnPropertyChanging( _
ByVal prop As Property _
)
[C#]
public virtual void OnPropertyChanging(
Property prop
);

Parameters

prop

See Also

DockObject Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObject.RecordAutoHideRestore Method

Records a restore object.

[Visual Basic]
Public Function RecordAutoHideRestore() As Restore
[C#]
public Restore RecordAutoHideRestore();

Return Value

The restore object.

See Also

DockObject Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObject.RecordDockingRestore Method

Records a restore object.

[Visual Basic]
Public Function RecordDockingRestore() As Restore
[C#]
public Restore RecordDockingRestore();

Return Value

The restore object.

See Also

DockObject Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObject.RecordFloatingRestore Method

Records a restore object.

[Visual Basic]
Public Function RecordFloatingRestore() As Restore
[C#]
public Restore RecordFloatingRestore();

Return Value

The restore object.

See Also

DockObject Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObject.RecordRestore Method

Records a restore object.

[Visual Basic]
Public Function RecordRestore() As Restore
[C#]
public Restore RecordRestore();

Return Value

The restore object.

See Also

DockObject Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObject.UpdateVisibility Method

Updates the object's visibility.

[Visual Basic]
Public Sub UpdateVisibility()
[C#]
public void UpdateVisibility();

See Also

DockObject Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObject Events

The events of the DockObject class are listed below. For a complete list of DockObject class members, see the DockObject Members topic.

Public Instance Events

PropertyChanged | A property has changed.
PropertyChanging | A property is changing.

See Also

DockObject Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObject.PropertyChanged Event

A property has changed.

[Visual Basic]
Public Event PropertyChanged As PropChangeHandler
[C#]
public event PropChangeHandler PropertyChanged;

See Also

DockObject Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObject.PropertyChanging Event

A property is changing.

[Visual Basic]
Public Event PropertyChanging As PropChangeHandler
[C#]
public event PropChangeHandler PropertyChanging;

See Also

DockObject Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObject.PropChangeHandler Delegate

The property change event signature.

[Visual Basic]
Public Delegate Sub DockObject.PropChangeHandler( _
ByVal obj As DockObject, _
ByVal prop As Property _
)
[C#]
public delegate void DockObject.PropChangeHandler(
DockObject obj,
Property prop
);

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObject.Property Enumeration

Enumeration of property change events.

[Visual Basic]
Public Enum DockObject.Property
[C#]
public enum DockObject.Property

Members

Member Name | Description
Control | The Control property of the object.
Title | The Title property of the object.
FullTitle | The FullTitle property of the object.
Icon | The Icon property of the object.
CaptionBar | The CaptionBar property of the object.
CloseButton | The CloseButton property of the object.
HideButton | The HideButton property of the object.
DisplaySize | The DisplaySize property of the object.
AutoHideSize | The AutoHideSize property of the object.
FloatingSize | The FloatingSize property of the object.
DisplayLocation | The DisplayLocation property of the object.
AutoHidden | The AutoHidden property of the object.

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObjectCollection Class

A collection of DockObject objects.

For a list of all members of this type, see DockObjectCollection Members.

System.Object
CollectionBase
CollectionEx
DockObjectCollection

[Visual Basic]
NotInheritable Public Class DockObjectCollection
Inherits CollectionEx
[C#]
public sealed class DockObjectCollection : CollectionEx

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

DockObjectCollection Members | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObjectCollection Members

DockObjectCollection overview

Public Instance Constructors

DockObjectCollection Constructor Initializes a new instance of the DockObjectCollection class.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
IsSuspended (inherited from CollectionEx) | Is event generation already suspended?
Item | Overloaded. Gets a object at the specified index.

Public Instance Methods

Add | Adds an object to the collection.
AddRange | Adds a bunch of objects.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Contains | Overloaded. Does the list contain the specified object?
Copy | Creates a copy of this collection.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Gets the index of a object.
Insert | Inserts a object at specified index.
RaiseChanged (inherited from CollectionEx) | Raises the Changed event.
Remove | Removes a object.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
ResumeEvents (inherited from CollectionEx) | Resume event generation.
SuspendEvents (inherited from CollectionEx) | Suspend event generation.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

Changed (inherited from CollectionEx) | Event raised when the collection has changed.
Cleared (inherited from CollectionEx) | Event raised when collection has been cleared.
Clearing (inherited from CollectionEx) | Event raised when collection is being cleared.
Inserted (inherited from CollectionEx) | Event raised when an item has been inserted.
Inserting (inherited from CollectionEx) | Event raised when an item is being inserted.
Removed (inherited from CollectionEx) | Event raised when an item has been removed.
Removing (inherited from CollectionEx) | Event raised when an item is being removed.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

DockObjectCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObjectCollection Constructor

Initializes a new instance of the DockObjectCollection class.

[Visual Basic]
Public Sub New()
[C#]
public DockObjectCollection();

See Also

DockObjectCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObjectCollection Properties

The properties of the DockObjectCollection class are listed below. For a complete list of DockObjectCollection class members, see the DockObjectCollection Members topic.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
IsSuspended (inherited from CollectionEx) | Is event generation already suspended?
Item | Overloaded. Gets a object at the specified index.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

DockObjectCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Item Property

NetXP 3.0 Reference

DockObjectCollection.Item Property

Gets a object at the specified index.

Overload List

Gets a object at the specified index.

public DockObject this[int] {get;}

Gets a object with the specified title.

public DockObject this[string] {get;}

See Also

DockObjectCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObjectCollection.Item Property

Gets a object at the specified index.

[Visual Basic]
Overloads Public Default ReadOnly Property Item( _
ByVal index As Integer _
) As DockObject
[C#]
public DockObject this[
int index
] {get;}

See Also

DockObjectCollection Class | NETXP.Controls.Docking Namespace | DockObjectCollection.Item Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObjectCollection.Item Property

Gets a object with the specified title.

[Visual Basic]
Overloads Public Default ReadOnly Property Item( _
ByVal title As String _
) As DockObject
[C#]
public DockObject this[
string title
] {get;}

See Also

DockObjectCollection Class | NETXP.Controls.Docking Namespace | DockObjectCollection.Item Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObjectCollection Methods

The methods of the DockObjectCollection class are listed below. For a complete list of DockObjectCollection class members, see the DockObjectCollection Members topic.

Public Instance Methods

Add | Adds an object to the collection.
AddRange | Adds a bunch of objects.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Contains | Overloaded. Does the list contain the specified object?
Copy | Creates a copy of this collection.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Gets the index of a object.
Insert | Inserts a object at specified index.
RaiseChanged (inherited from CollectionEx) | Raises the Changed event.
Remove | Removes a object.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
ResumeEvents (inherited from CollectionEx) | Resume event generation.
SuspendEvents (inherited from CollectionEx) | Suspend event generation.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

DockObjectCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObjectCollection.Add Method

Adds an object to the collection.

[Visual Basic]
Public Function Add( _
ByVal value As DockObject _
) As Integer
[C#]
public int Add(
DockObject value
);

Parameters

value
The object to add.

Return Value

The index of the object.

See Also

DockObjectCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObjectCollection.AddRange Method

Adds a bunch of objects.

[Visual Basic]
Public Sub AddRange( _
ByVal values As DockObject() _
)
[C#]
public void AddRange(
DockObject[] values
);

Parameters

values
The objects.

See Also

DockObjectCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Contains Method

NetXP 3.0 Reference

DockObjectCollection.Contains Method

Does the list contain the specified object?

Overload List

Does the list contain the specified object?

public bool Contains(DockObject);

Does the list contain any of a bunch of objects?

public bool Contains(DockObjectCollection);

Does the list contain a object whose title matches any of the specified titles?

public bool Contains(StringCollection);

Does the list contain a object whose title matches the specified title?

public bool Contains(string);

See Also

DockObjectCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObjectCollection.Contains Method (DockObject)

Does the list contain the specified object?

[Visual Basic]
Overloads Public Function Contains( _
ByVal value As DockObject _
) As Boolean
[C#]
public bool Contains(
DockObject value
);

Parameters

value
The object.

Return Value

True if the list contains the object.

See Also

DockObjectCollection Class | NETXP.Controls.Docking Namespace | DockObjectCollection.Contains Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObjectCollection.Contains Method (DockObjectCollection)

Does the list contain any of a bunch of objects?

[Visual Basic]
Overloads Public Function Contains( _
ByVal values As DockObjectCollection _
) As Boolean
[C#]
public bool Contains(
DockObjectCollection values
);

Parameters

values
The objects.

Return Value

True if at least one of the objects in the values collection is contained in this collection.

See Also

DockObjectCollection Class | NETXP.Controls.Docking Namespace | DockObjectCollection.Contains Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObjectCollection.Contains Method (StringCollection)

Does the list contain a object whose title matches any of the specified titles?

[Visual Basic]
Overloads Public Function Contains( _
ByVal values As StringCollection _
) As Boolean
[C#]
public bool Contains(
StringCollection values
);

Parameters

values
The titles to look for.

Return Value

True if at least one of the titles was matched.

See Also

DockObjectCollection Class | NETXP.Controls.Docking Namespace | DockObjectCollection.Contains Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObjectCollection.Contains Method (String)

Does the list contain a object whose title matches the specified title?

[Visual Basic]
Overloads Public Function Contains( _
ByVal value As String _
) As Boolean
[C#]
public bool Contains(
string value
);

Parameters

value
The title to match.

Return Value

True if the list contains a object whose title matches the specified title.

See Also

DockObjectCollection Class | NETXP.Controls.Docking Namespace | DockObjectCollection.Contains Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObjectCollection.Copy Method

Creates a copy of this collection.

[Visual Basic]
Public Function Copy() As DockObjectCollection
[C#]
public DockObjectCollection Copy();

Return Value

A clone of this collection.

See Also

DockObjectCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObjectCollection.IndexOf Method

Gets the index of a object.

[Visual Basic]
Public Function IndexOf( _
ByVal value As DockObject _
) As Integer
[C#]
public int IndexOf(
DockObject value
);

Parameters

value
The object.

Return Value

The index.

See Also

DockObjectCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObjectCollection.Insert Method

Inserts a object at specified index.

[Visual Basic]
Public Sub Insert( _
ByVal index As Integer, _
ByVal value As DockObject _
)
[C#]
public void Insert(
int index,
DockObject value
);

Parameters

index
Index.
value
DockObject.

See Also

DockObjectCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObjectCollection.Remove Method

Removes a object.

[Visual Basic]
Public Sub Remove( _
ByVal value As DockObject _
)
[C#]
public void Remove(
DockObject value
);

Parameters

value
The object.

See Also

DockObjectCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObjectHandler Delegate

Handles events for an object.

[Visual Basic]
Public Delegate Sub DockObjectHandler( _
ByVal c As DockObject, _
ByVal cea As EventArgs _
)
[C#]
public delegate void DockObjectHandler(
DockObject c,
EventArgs cea
);

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockObjectHidingHandler Delegate

Handles events for an object when hiding.

[Visual Basic]
Public Delegate Sub DockObjectHidingHandler( _
ByVal c As DockObject, _
ByVal cea As CancelEventArgs _
)
[C#]
public delegate void DockObjectHidingHandler(
DockObject c,
CancelEventArgs cea
);

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockRegion Class

Internal.

For a list of all members of this type, see DockRegion Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
Panel
DockRegion

[Visual Basic]
Public Class DockRegion
Inherits Panel
[C#]
public class DockRegion : Panel

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

DockRegion Members | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockRegion Members

DockRegion overview

Public Instance Constructors

DockRegion Overloaded. Initializes a new instance of the DockRegion class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoDispose | Internal.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BorderStyle (inherited from Panel) | Indicates the border style for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockingManager | Internal.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MinimumHeight | Internal.
MinimumWidth | Internal.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
State | Internal.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Panel) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Panel) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
Windows | Internal.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RecordRestore | Internal.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Panel) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
UpdateNameValue | Internal.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Panel) |
KeyPress (inherited from Panel) |
KeyUp (inherited from Panel) |
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Panel) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

DockRegion Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockRegion Constructor

Internal.

Overload List

Internal.

public DockRegion(DockingManager);

Internal.

public DockRegion(DockingManager,State);

See Also

DockRegion Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockRegion Constructor (DockingManager)

Internal.

[Visual Basic]
Overloads Public Sub New( _
ByVal manager As DockingManager _
)
[C#]
public DockRegion(
DockingManager manager
);

Parameters

manager

See Also

DockRegion Class | NETXP.Controls.Docking Namespace | DockRegion Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockRegion Constructor (DockingManager, State)

Internal.

[Visual Basic]
Overloads Public Sub New( _
ByVal manager As DockingManager, _
ByVal state As State _
)
[C#]
public DockRegion(
DockingManager manager,
State state
);

Parameters

manager
state

See Also

DockRegion Class | NETXP.Controls.Docking Namespace | DockRegion Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockRegion Properties

The properties of the DockRegion class are listed below. For a complete list of DockRegion class members, see the DockRegion Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoDispose | Internal.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BorderStyle (inherited from Panel) | Indicates the border style for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockingManager | Internal.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MinimumHeight | Internal.
MinimumWidth | Internal.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
State | Internal.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Panel) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Panel) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
Windows | Internal.
WindowTarget (inherited from Control) |

See Also

DockRegion Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockRegion.AutoDispose Property

Internal.

[Visual Basic]
Public Property AutoDispose As Boolean
[C#]
public bool AutoDispose {get; set;}

See Also

DockRegion Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockRegion.DockingManager Property

Internal.

[Visual Basic]
Public ReadOnly Property DockingManager As DockingManager
[C#]
public DockingManager DockingManager {get;}

See Also

DockRegion Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockRegion.MinimumHeight Property

Internal.

[Visual Basic]
Overridable Public ReadOnly Property MinimumHeight As Integer
[C#]
public virtual int MinimumHeight {get;}

See Also

DockRegion Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockRegion.MinimumWidth Property

Internal.

[Visual Basic]
Overridable Public ReadOnly Property MinimumWidth As Integer
[C#]
public virtual int MinimumWidth {get;}

See Also

DockRegion Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockRegion.State Property

Internal.

[Visual Basic]
Overridable Public Property State As State
[C#]
public virtual State State {get; set;}

See Also

DockRegion Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockRegion.Windows Property

Internal.

[Visual Basic]
Public Property Windows As WindowCollection
[C#]
public WindowCollection Windows {get; set;}

See Also

DockRegion Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockRegion Methods

The methods of the DockRegion class are listed below. For a complete list of DockRegion class members, see the DockRegion Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RecordRestore | Internal.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Panel) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
UpdateNameValue | Internal.

See Also

DockRegion Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockRegion.RecordRestore Method

Internal.

[Visual Basic]
Overridable Public Function RecordRestore( _
ByVal w As Window, _
ByVal child As Object, _
ByVal childRestore As Restore _
) As Restore
[C#]
public virtual Restore RecordRestore(
Window w,
object child,
Restore childRestore
);

Parameters

w
child
childRestore

Return Value

See Also

DockRegion Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockRegion.UpdateNameValue Method

Internal.

[Visual Basic]
Overridable Public Sub UpdateNameValue( _
ByVal name As UpdateName, _
ByVal value As Object _
)
[C#]
public virtual void UpdateNameValue(
UpdateName name,
object value
);

Parameters

name
value

See Also

DockRegion Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockRegionCollection Class

Internal.

For a list of all members of this type, see DockRegionCollection Members.

System.Object
CollectionBase
CollectionEx
DockRegionCollection

[Visual Basic]
NotInheritable Public Class DockRegionCollection
Inherits CollectionEx
[C#]
public sealed class DockRegionCollection : CollectionEx

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

DockRegionCollection Members | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockRegionCollection Members

DockRegionCollection overview

Public Instance Constructors

DockRegionCollection Constructor Initializes a new instance of the DockRegionCollection class.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
IsSuspended (inherited from CollectionEx) | Is event generation already suspended?
Item | Internal.

Public Instance Methods

Add | Internal.
AddRange | Internal.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Contains | Internal.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Internal.
Insert | Internal.
RaiseChanged (inherited from CollectionEx) | Raises the Changed event.
Remove | Internal.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
ResumeEvents (inherited from CollectionEx) | Resume event generation.
SuspendEvents (inherited from CollectionEx) | Suspend event generation.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

Changed (inherited from CollectionEx) | Event raised when the collection has changed.
Cleared (inherited from CollectionEx) | Event raised when collection has been cleared.
Clearing (inherited from CollectionEx) | Event raised when collection is being cleared.
Inserted (inherited from CollectionEx) | Event raised when an item has been inserted.
Inserting (inherited from CollectionEx) | Event raised when an item is being inserted.
Removed (inherited from CollectionEx) | Event raised when an item has been removed.
Removing (inherited from CollectionEx) | Event raised when an item is being removed.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

DockRegionCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockRegionCollection Constructor

Initializes a new instance of the DockRegionCollection class.

[Visual Basic]
Public Sub New()
[C#]
public DockRegionCollection();

See Also

DockRegionCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockRegionCollection Properties

The properties of the DockRegionCollection class are listed below. For a complete list of DockRegionCollection class members, see the DockRegionCollection Members topic.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
IsSuspended (inherited from CollectionEx) | Is event generation already suspended?
Item | Internal.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

DockRegionCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockRegionCollection.Item Property

Internal.

[Visual Basic]
Public Default ReadOnly Property Item( _
ByVal index As Integer _
) As DockRegion
[C#]
public DockRegion this[
int index
] {get;}

See Also

DockRegionCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockRegionCollection Methods

The methods of the DockRegionCollection class are listed below. For a complete list of DockRegionCollection class members, see the DockRegionCollection Members topic.

Public Instance Methods

Add | Internal.
AddRange | Internal.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Contains | Internal.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Internal.
Insert | Internal.
RaiseChanged (inherited from CollectionEx) | Raises the Changed event.
Remove | Internal.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
ResumeEvents (inherited from CollectionEx) | Resume event generation.
SuspendEvents (inherited from CollectionEx) | Suspend event generation.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

DockRegionCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockRegionCollection.Add Method

Internal.

[Visual Basic]
Public Function Add( _
ByVal value As DockRegion _
) As DockRegion
[C#]
public DockRegion Add(
DockRegion value
);

Parameters

value

Return Value

See Also

DockRegionCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockRegionCollection.AddRange Method

Internal.

[Visual Basic]
Public Sub AddRange( _
ByVal values As DockRegion() _
)
[C#]
public void AddRange(
DockRegion[] values
);

Parameters

values

See Also

DockRegionCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockRegionCollection.Contains Method

Internal.

[Visual Basic]
Public Function Contains( _
ByVal value As DockRegion _
) As Boolean
[C#]
public bool Contains(
DockRegion value
);

Parameters

value

Return Value

See Also

DockRegionCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockRegionCollection.IndexOf Method

Internal.

[Visual Basic]
Public Function IndexOf( _
ByVal value As DockRegion _
) As Integer
[C#]
public int IndexOf(
DockRegion value
);

Parameters

value

Return Value

See Also

DockRegionCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockRegionCollection.Insert Method

Internal.

[Visual Basic]
Public Sub Insert( _
ByVal index As Integer, _
ByVal value As DockRegion _
)
[C#]
public void Insert(
int index,
DockRegion value
);

Parameters

index
value

See Also

DockRegionCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


DockRegionCollection.Remove Method

Internal.

[Visual Basic]
Public Sub Remove( _
ByVal value As DockRegion _
)
[C#]
public void Remove(
DockRegion value
);

Parameters

value

See Also

DockRegionCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


ExDockObject Class

Wraps DockObject and extend it with needed properties.

For a list of all members of this type, see ExDockObject Members.

System.Object
DockObject
ExDockObject

[Visual Basic]
Public Class ExDockObject
Inherits DockObject
[C#]
public class ExDockObject : DockObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

ExDockObject Members | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


ExDockObject Members

ExDockObject overview

Public Instance Constructors

ExDockObject Overloaded. Initializes a new instance of the ExDockObject class.

Public Instance Properties

AutoHidden (inherited from DockObject) | Gets/sets if the object is auto-hidden.
AutoHidePanel (inherited from DockObject) | Gets/sets the auto-hide panel, if any.
AutoHideRestore (inherited from DockObject) | The auto-hide restore object for this object.
AutoHideSize (inherited from DockObject) | Gets/sets the auto hide size of the object.
CaptionBar (inherited from DockObject) | Should the object have a caption bar?
CloseButton (inherited from DockObject) | Should the object have a close button?
CloseOnHide (inherited from DockObject) | Should the object be closed when auto-hidden?
Control (inherited from DockObject) | Gets/sets the control assigned to this object.
DefaultRestore (inherited from DockObject) | The default restore object for this object.
DisplayLocation (inherited from DockObject) | Gets/sets the location of the object.
DisplaySize (inherited from DockObject) | Gets/sets the display size of the object.
Docked (inherited from DockObject) | Gets/sets if the object is docked.
DockingManager (inherited from DockObject) | Gets/sets the docking manager used by this object.
DockingRestore (inherited from DockObject) | The docking restore object for this object.
DockStyle | Gets or sets the DockStyle.
FloatingRestore (inherited from DockObject) | The floating restore object for this object.
FloatingSize (inherited from DockObject) | Gets/sets the floating size of the object.
FullTitle (inherited from DockObject) | Gets/sets the full title assigned to this object.
HideButton (inherited from DockObject) | Should the object have an auto-hide button?
Icon (inherited from DockObject) | Gets/sets the icon assigned to this object.
MinimumSize (inherited from DockObject) | The minimum size of this object.
Order (inherited from DockObject) | Gets the order of the object.
ParentWindowObjects (inherited from DockObject) | Gets/sets the parent window object.
TabbedMode | Enable or disable the tabbed docking mode.
Tag (inherited from DockObject) | An object associated with this object.
Title (inherited from DockObject) | Gets/sets the title assigned to this object.
Visible (inherited from DockObject) | Is this object visible?

Public Instance Methods

BringToFront (inherited from DockObject) | Brings the object to front.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
OnPropertyChanged (inherited from DockObject) | Internal.
OnPropertyChanging (inherited from DockObject) | Internal.
RecordAutoHideRestore (inherited from DockObject) | Records a restore object.
RecordDockingRestore (inherited from DockObject) | Records a restore object.
RecordFloatingRestore (inherited from DockObject) | Records a restore object.
RecordRestore (inherited from DockObject) | Records a restore object.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateVisibility (inherited from DockObject) | Updates the object's visibility.

Public Instance Events

PropertyChanged (inherited from DockObject) | A property has changed.
PropertyChanging (inherited from DockObject) | A property is changing.

See Also

ExDockObject Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


ExDockObject Constructor

Constructs a new docking object.

Overload List

Constructs a new docking object.

public ExDockObject(DockingManager);

Constructs a new docking object.

public ExDockObject(DockingManager,Control);

See Also

ExDockObject Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


ExDockObject Constructor (DockingManager)

Constructs a new docking object.

[Visual Basic]
Overloads Public Sub New( _
ByVal dockingManager As DockingManager _
)
[C#]
public ExDockObject(
DockingManager dockingManager
);

Parameters

dockingManager
The docking manager.

See Also

ExDockObject Class | NETXP.Controls.Docking Namespace | ExDockObject Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


ExDockObject Constructor (DockingManager, Control)

Constructs a new docking object.

[Visual Basic]
Overloads Public Sub New( _
ByVal dockingManager As DockingManager, _
ByVal control As Control _
)
[C#]
public ExDockObject(
DockingManager dockingManager,
Control control
);

Parameters

dockingManager
The docking manager.
control
The control.

See Also

ExDockObject Class | NETXP.Controls.Docking Namespace | ExDockObject Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


ExDockObject Properties

The properties of the ExDockObject class are listed below. For a complete list of ExDockObject class members, see the ExDockObject Members topic.

Public Instance Properties

AutoHidden (inherited from DockObject) | Gets/sets if the object is auto-hidden.
AutoHidePanel (inherited from DockObject) | Gets/sets the auto-hide panel, if any.
AutoHideRestore (inherited from DockObject) | The auto-hide restore object for this object.
AutoHideSize (inherited from DockObject) | Gets/sets the auto hide size of the object.
CaptionBar (inherited from DockObject) | Should the object have a caption bar?
CloseButton (inherited from DockObject) | Should the object have a close button?
CloseOnHide (inherited from DockObject) | Should the object be closed when auto-hidden?
Control (inherited from DockObject) | Gets/sets the control assigned to this object.
DefaultRestore (inherited from DockObject) | The default restore object for this object.
DisplayLocation (inherited from DockObject) | Gets/sets the location of the object.
DisplaySize (inherited from DockObject) | Gets/sets the display size of the object.
Docked (inherited from DockObject) | Gets/sets if the object is docked.
DockingManager (inherited from DockObject) | Gets/sets the docking manager used by this object.
DockingRestore (inherited from DockObject) | The docking restore object for this object.
DockStyle | Gets or sets the DockStyle.
FloatingRestore (inherited from DockObject) | The floating restore object for this object.
FloatingSize (inherited from DockObject) | Gets/sets the floating size of the object.
FullTitle (inherited from DockObject) | Gets/sets the full title assigned to this object.
HideButton (inherited from DockObject) | Should the object have an auto-hide button?
Icon (inherited from DockObject) | Gets/sets the icon assigned to this object.
MinimumSize (inherited from DockObject) | The minimum size of this object.
Order (inherited from DockObject) | Gets the order of the object.
ParentWindowObjects (inherited from DockObject) | Gets/sets the parent window object.
TabbedMode | Enable or disable the tabbed docking mode.
Tag (inherited from DockObject) | An object associated with this object.
Title (inherited from DockObject) | Gets/sets the title assigned to this object.
Visible (inherited from DockObject) | Is this object visible?

See Also

ExDockObject Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


ExDockObject.DockStyle Property

Gets or sets the DockStyle.

[Visual Basic]
Public Property DockStyle As DockStyle
[C#]
public System.Windows.Forms.DockStyle DockStyle {get; set;}

See Also

ExDockObject Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


ExDockObject.TabbedMode Property

Enable or disable the tabbed docking mode.

[Visual Basic]
Public Property TabbedMode As Boolean
[C#]
public bool TabbedMode {get; set;}

See Also

ExDockObject Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


FloatingForm Class

A generic floating form.

For a list of all members of this type, see FloatingForm Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
FloatingForm

[Visual Basic]
NotInheritable Public Class FloatingForm
Inherits Form
Implements NETXP.Controls.Docking.IHotDockRegionSource, System.Windows.Forms.IMessageFilter
[C#]
public sealed class FloatingForm : Form, IHotDockRegionSource, IMessageFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

FloatingForm Members | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


FloatingForm Members

FloatingForm overview

Public Instance Constructors

FloatingForm Constructor Internal.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) |
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScale (inherited from Form) | Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockingManager | The docking manager responsible for this form.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
DockRegion | The region.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | [To be supplied.]
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsRestrictedWindow (inherited from Form) |
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) |
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as the top-most form of your application.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddHotDockRegions | Internal.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExitFloating | Internal.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreFilterMessage | Internal.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Control) | Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with no owner window.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
UpdateNameValue | Internal.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
Context | Context menu is being shown.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is not the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) |
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

FloatingForm Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


FloatingForm Constructor

Internal.

[Visual Basic]
Public Sub New( _
ByVal dockingManager As DockingManager, _
ByVal region As DockRegion, _
ByVal contextHandler As ContextHandler _
)
[C#]
public FloatingForm(
DockingManager dockingManager,
DockRegion region,
ContextHandler contextHandler
);

Parameters

dockingManager
region
contextHandler

See Also

FloatingForm Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


FloatingForm Properties

The properties of the FloatingForm class are listed below. For a complete list of FloatingForm class members, see the FloatingForm Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) |
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScale (inherited from Form) | Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockingManager | The docking manager responsible for this form.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
DockRegion | The region.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | [To be supplied.]
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsRestrictedWindow (inherited from Form) |
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) |
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as the top-most form of your application.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

FloatingForm Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


FloatingForm.DockingManager Property

The docking manager responsible for this form.

[Visual Basic]
Public ReadOnly Property DockingManager As DockingManager
[C#]
public DockingManager DockingManager {get;}

See Also

FloatingForm Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


FloatingForm.DockRegion Property

The region.

[Visual Basic]
Public ReadOnly Property DockRegion As DockRegion
[C#]
public DockRegion DockRegion {get;}

See Also

FloatingForm Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


FloatingForm Methods

The methods of the FloatingForm class are listed below. For a complete list of FloatingForm class members, see the FloatingForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddHotDockRegions | Internal.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExitFloating | Internal.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreFilterMessage | Internal.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Control) | Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with no owner window.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
UpdateNameValue | Internal.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

FloatingForm Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


FloatingForm.AddHotDockRegions Method

Internal.

[Visual Basic]
NotOverridable Public Sub AddHotDockRegions( _
ByVal redock As Redocker, _
ByVal collection As HotDockRegionCollection _
) Implements _
IHotDockRegionSource.AddHotDockRegions
[C#]
public void AddHotDockRegions(
Redocker redock,
HotDockRegionCollection collection
);

Parameters

redock
collection

Implements

IHotDockRegionSource.AddHotDockRegions

See Also

FloatingForm Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


FloatingForm.ExitFloating Method

Internal.

[Visual Basic]
Public Sub ExitFloating()
[C#]
public void ExitFloating();

See Also

FloatingForm Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


FloatingForm.PreFilterMessage Method

Internal.

[Visual Basic]
NotOverridable Public Function PreFilterMessage( _
ByRef m As Message _
) As Boolean Implements _
IMessageFilter.PreFilterMessage
[C#]
public bool PreFilterMessage(
ref Message m
);

Parameters

m

Return Value

Implements

IMessageFilter.PreFilterMessage

See Also

FloatingForm Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


FloatingForm.UpdateNameValue Method

Internal.

[Visual Basic]
Public Sub UpdateNameValue( _
ByVal name As UpdateName, _
ByVal value As Object _
)
[C#]
public void UpdateNameValue(
UpdateName name,
object value
);

Parameters

name
value

See Also

FloatingForm Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


FloatingForm Events

The events of the FloatingForm class are listed below. For a complete list of FloatingForm class members, see the FloatingForm Members topic.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
Context | Context menu is being shown.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is not the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) |
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

FloatingForm Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


FloatingForm.Context Event

Context menu is being shown.

[Visual Basic]
Public Event Context As ContextHandler
[C#]
public event ContextHandler Context;

See Also

FloatingForm Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


HideTabsModes Enumeration

Enumeration of modes that control the display of the tabs area.

[Visual Basic]
Public Enum HideTabsModes
[C#]
public enum HideTabsModes

Members

Member Name | Description
ShowAlways | Always show tabs.
HideAlways | Always hide tabs.
HideUsingLogic | Use logic to hide tabs.
HideWithoutMouse | Hide without mouse.

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


HotDockRegion Class

Internal.

For a list of all members of this type, see HotDockRegion Members.

System.Object
HotDockRegion

[Visual Basic]
Public Class HotDockRegion
[C#]
public class HotDockRegion

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

HotDockRegion Members | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


HotDockRegion Members

HotDockRegion overview

Public Static (Shared) Properties

DragWidth Internal.

Public Instance Constructors

HotDockRegion Constructor Internal.

Public Instance Properties

HotArea | Internal.
NewSize | Internal.

Public Instance Methods

ApplyChange | Internal.
DrawIndicator | Internal.
DrawReversible | Internal.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RemoveIndicator | Internal.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateForMousePosition | Internal.

See Also

HotDockRegion Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


HotDockRegion Constructor

Internal.

[Visual Basic]
Public Sub New( _
ByVal hotArea As Rectangle, _
ByVal newSize As Rectangle _
)
[C#]
public HotDockRegion(
Rectangle hotArea,
Rectangle newSize
);

Parameters

hotArea
newSize

See Also

HotDockRegion Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


HotDockRegion Properties

The properties of the HotDockRegion class are listed below. For a complete list of HotDockRegion class members, see the HotDockRegion Members topic.

Public Static (Shared) Properties

DragWidth Internal.

Public Instance Properties

HotArea | Internal.
NewSize | Internal.

See Also

HotDockRegion Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


HotDockRegion.DragWidth Property

Internal.

[Visual Basic]
Public Shared ReadOnly Property DragWidth As Integer
[C#]
public static int DragWidth {get;}

See Also

HotDockRegion Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


HotDockRegion.HotArea Property

Internal.

[Visual Basic]
Public ReadOnly Property HotArea As Rectangle
[C#]
public System.Drawing.Rectangle HotArea {get;}

See Also

HotDockRegion Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


HotDockRegion.NewSize Property

Internal.

[Visual Basic]
Public Property NewSize As Rectangle
[C#]
public System.Drawing.Rectangle NewSize {get; set;}

See Also

HotDockRegion Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


HotDockRegion Methods

The methods of the HotDockRegion class are listed below. For a complete list of HotDockRegion class members, see the HotDockRegion Members topic.

Public Instance Methods

ApplyChange | Internal.
DrawIndicator | Internal.
DrawReversible | Internal.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RemoveIndicator | Internal.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateForMousePosition | Internal.

See Also

HotDockRegion Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


HotDockRegion.ApplyChange Method

Internal.

[Visual Basic]
Overridable Public Function ApplyChange( _
ByVal screenPos As Point, _
ByVal parent As Redocker _
) As Boolean
[C#]
public virtual bool ApplyChange(
Point screenPos,
Redocker parent
);

Parameters

screenPos
parent

Return Value

See Also

HotDockRegion Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


HotDockRegion.DrawIndicator Method

Internal.

[Visual Basic]
Overridable Public Sub DrawIndicator( _
ByVal mousePos As Point _
)
[C#]
public virtual void DrawIndicator(
Point mousePos
);

Parameters

mousePos

See Also

HotDockRegion Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


HotDockRegion.DrawReversible Method

Internal.

[Visual Basic]
Overridable Public Sub DrawReversible( _
ByVal rect As Rectangle _
)
[C#]
public virtual void DrawReversible(
Rectangle rect
);

Parameters

rect

See Also

HotDockRegion Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


HotDockRegion.RemoveIndicator Method

Internal.

[Visual Basic]
Overridable Public Sub RemoveIndicator( _
ByVal mousePos As Point _
)
[C#]
public virtual void RemoveIndicator(
Point mousePos
);

Parameters

mousePos

See Also

HotDockRegion Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


HotDockRegion.UpdateForMousePosition Method

Internal.

[Visual Basic]
Overridable Public Sub UpdateForMousePosition( _
ByVal screenPos As Point, _
ByVal parent As Redocker _
)
[C#]
public virtual void UpdateForMousePosition(
Point screenPos,
Redocker parent
);

Parameters

screenPos
parent

See Also

HotDockRegion Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


HotDockRegionCollection Class

Internal.

For a list of all members of this type, see HotDockRegionCollection Members.

System.Object
CollectionBase
CollectionEx
HotDockRegionCollection

[Visual Basic]
NotInheritable Public Class HotDockRegionCollection
Inherits CollectionEx
[C#]
public sealed class HotDockRegionCollection : CollectionEx

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

HotDockRegionCollection Members | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


HotDockRegionCollection Members

HotDockRegionCollection overview

Public Instance Constructors

HotDockRegionCollection Constructor Initializes a new instance of the HotDockRegionCollection class.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
IsSuspended (inherited from CollectionEx) | Is event generation already suspended?
Item | Internal.

Public Instance Methods

Add | Internal.
AddRange | Internal.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Contains | Overloaded. Internal.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Internal.
Insert | Internal.
RaiseChanged (inherited from CollectionEx) | Raises the Changed event.
Remove | Internal.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
ResumeEvents (inherited from CollectionEx) | Resume event generation.
SuspendEvents (inherited from CollectionEx) | Suspend event generation.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

Changed (inherited from CollectionEx) | Event raised when the collection has changed.
Cleared (inherited from CollectionEx) | Event raised when collection has been cleared.
Clearing (inherited from CollectionEx) | Event raised when collection is being cleared.
Inserted (inherited from CollectionEx) | Event raised when an item has been inserted.
Inserting (inherited from CollectionEx) | Event raised when an item is being inserted.
Removed (inherited from CollectionEx) | Event raised when an item has been removed.
Removing (inherited from CollectionEx) | Event raised when an item is being removed.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

HotDockRegionCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


HotDockRegionCollection Constructor

Initializes a new instance of the HotDockRegionCollection class.

[Visual Basic]
Public Sub New()
[C#]
public HotDockRegionCollection();

See Also

HotDockRegionCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


HotDockRegionCollection Properties

The properties of the HotDockRegionCollection class are listed below. For a complete list of HotDockRegionCollection class members, see the HotDockRegionCollection Members topic.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
IsSuspended (inherited from CollectionEx) | Is event generation already suspended?
Item | Internal.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

HotDockRegionCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


HotDockRegionCollection.Item Property

Internal.

[Visual Basic]
Public Default ReadOnly Property Item( _
ByVal index As Integer _
) As HotDockRegion
[C#]
public HotDockRegion this[
int index
] {get;}

See Also

HotDockRegionCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


HotDockRegionCollection Methods

The methods of the HotDockRegionCollection class are listed below. For a complete list of HotDockRegionCollection class members, see the HotDockRegionCollection Members topic.

Public Instance Methods

Add | Internal.
AddRange | Internal.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Contains | Overloaded. Internal.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Internal.
Insert | Internal.
RaiseChanged (inherited from CollectionEx) | Raises the Changed event.
Remove | Internal.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
ResumeEvents (inherited from CollectionEx) | Resume event generation.
SuspendEvents (inherited from CollectionEx) | Suspend event generation.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

HotDockRegionCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


HotDockRegionCollection.Add Method

Internal.

[Visual Basic]
Public Function Add( _
ByVal value As HotDockRegion _
) As HotDockRegion
[C#]
public HotDockRegion Add(
HotDockRegion value
);

Parameters

value

Return Value

See Also

HotDockRegionCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


HotDockRegionCollection.AddRange Method

Internal.

[Visual Basic]
Public Sub AddRange( _
ByVal values As HotDockRegion() _
)
[C#]
public void AddRange(
HotDockRegion[] values
);

Parameters

values

See Also

HotDockRegionCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Contains Method

NetXP 3.0 Reference

HotDockRegionCollection.Contains Method

Internal.

Overload List

Internal.

public bool Contains(HotDockRegion);

Internal.

public HotDockRegion Contains(Point);

See Also

HotDockRegionCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


HotDockRegionCollection.Contains Method (HotDockRegion)

Internal.

[Visual Basic]
Overloads Public Function Contains( _
ByVal value As HotDockRegion _
) As Boolean
[C#]
public bool Contains(
HotDockRegion value
);

Parameters

value

Return Value

See Also

HotDockRegionCollection Class | NETXP.Controls.Docking Namespace | HotDockRegionCollection.Contains Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


HotDockRegionCollection.Contains Method (Point)

Internal.

[Visual Basic]
Overloads Public Function Contains( _
ByVal pt As Point _
) As HotDockRegion
[C#]
public HotDockRegion Contains(
Point pt
);

Parameters

pt

Return Value

See Also

HotDockRegionCollection Class | NETXP.Controls.Docking Namespace | HotDockRegionCollection.Contains Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


HotDockRegionCollection.IndexOf Method

Internal.

[Visual Basic]
Public Function IndexOf( _
ByVal value As HotDockRegion _
) As Integer
[C#]
public int IndexOf(
HotDockRegion value
);

Parameters

value

Return Value

See Also

HotDockRegionCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


HotDockRegionCollection.Insert Method

Internal.

[Visual Basic]
Public Sub Insert( _
ByVal index As Integer, _
ByVal value As HotDockRegion _
)
[C#]
public void Insert(
int index,
HotDockRegion value
);

Parameters

index
value

See Also

HotDockRegionCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


HotDockRegionCollection.Remove Method

Internal.

[Visual Basic]
Public Sub Remove( _
ByVal value As HotDockRegion _
)
[C#]
public void Remove(
HotDockRegion value
);

Parameters

value

See Also

HotDockRegionCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


IDockingRenderer Interface

Defines a renderer for the docking subsystem.

For a list of all members of this type, see IDockingRenderer Members.

[Visual Basic]
Public Interface IDockingRenderer
[C#]
public interface IDockingRenderer

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

IDockingRenderer Members | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


IDockingRenderer Members

IDockingRenderer overview

Public Instance Methods

DrawAutoHidePanel | Draws an auto-hide panel.
DrawTab | Draws a tab.
DrawTabBorders | Draws tab borders.
DrawVerticalTabBorder | Draws the border for a tab stub.
DrawVerticalTabOutline | Draws a tab stub outline.
FillTabBackgrounds | Fills tab backgrounds.
FillVerticalTabBackground | Fills a tab stub background.
GetTabPageSpace | Gets tab page space.
PaintCaption | Paints a window detail caption.
PaintCaptionButton | Paints a caption button.
PaintSizeBar | Paints a resize bar.
RecalculateMultilineTabs | Recalculates multiline tabs.
RecalculateSinglelineTabs | Recalculates single line tabs.

See Also

IDockingRenderer Interface | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


IDockingRenderer Methods

The methods of the IDockingRenderer interface are listed below. For a complete list of IDockingRenderer interface members, see the IDockingRenderer Members topic.

Public Instance Methods

DrawAutoHidePanel | Draws an auto-hide panel.
DrawTab | Draws a tab.
DrawTabBorders | Draws tab borders.
DrawVerticalTabBorder | Draws the border for a tab stub.
DrawVerticalTabOutline | Draws a tab stub outline.
FillTabBackgrounds | Fills tab backgrounds.
FillVerticalTabBackground | Fills a tab stub background.
GetTabPageSpace | Gets tab page space.
PaintCaption | Paints a window detail caption.
PaintCaptionButton | Paints a caption button.
PaintSizeBar | Paints a resize bar.
RecalculateMultilineTabs | Recalculates multiline tabs.
RecalculateSinglelineTabs | Recalculates single line tabs.

See Also

IDockingRenderer Interface | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


IDockingRenderer.DrawAutoHidePanel Method

Draws an auto-hide panel.

[Visual Basic]
Sub DrawAutoHidePanel( _
ByVal item As AutoHidePanel, _
ByVal g As Graphics _
)
[C#]
void DrawAutoHidePanel(
AutoHidePanel item,
Graphics g
);

Parameters

item
The panel.
g
The graphics object.

See Also

IDockingRenderer Interface | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


IDockingRenderer.DrawTab Method

Draws a tab.

[Visual Basic]
Sub DrawTab( _
ByVal ctl As TabControl, _
ByVal page As TabPage, _
ByVal g As Graphics, _
ByVal highlightText As Boolean, _
ByVal tabRects As ArrayList, _
ByVal imageGapTopExtra As Integer, _
ByVal selectedTextOnly As Boolean, _
ByVal dimUnselected As Boolean, _
ByVal boldSelected As Boolean, _
ByVal appearance As TabPosition, _
ByVal multiline As Boolean, _
ByVal positionAtTop As Boolean _
)
[C#]
void DrawTab(
TabControl ctl,
TabPage page,
Graphics g,
bool highlightText,
ArrayList tabRects,
int imageGapTopExtra,
bool selectedTextOnly,
bool dimUnselected,
bool boldSelected,
TabPosition appearance,
bool multiline,
bool positionAtTop
);

Parameters

ctl
page
g
highlightText
tabRects
imageGapTopExtra
selectedTextOnly
dimUnselected
boldSelected
appearance
multiline
positionAtTop

See Also

IDockingRenderer Interface | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


IDockingRenderer.DrawTabBorders Method

Draws tab borders.

[Visual Basic]
Sub DrawTabBorders( _
ByVal ctl As TabControl, _
ByVal g As Graphics, _
ByVal positionAtTop As Boolean, _
ByVal tabsAreaRect As Rectangle, _
ByVal pixelBorder As Boolean, _
ByVal pixelArea As Boolean, _
ByVal hiddenPages As Boolean _
)
[C#]
void DrawTabBorders(
TabControl ctl,
Graphics g,
bool positionAtTop,
Rectangle tabsAreaRect,
bool pixelBorder,
bool pixelArea,
bool hiddenPages
);

Parameters

ctl
g
positionAtTop
tabsAreaRect
pixelBorder
pixelArea
hiddenPages

See Also

IDockingRenderer Interface | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


IDockingRenderer.DrawVerticalTabBorder Method

Draws the border for a tab stub.

[Visual Basic]
Sub DrawVerticalTabBorder( _
ByVal item As VerticalTab, _
ByVal g As Graphics, _
ByVal edge As Edge, _
ByVal drawTabs As ArrayList, _
ByVal selectedIndex As Integer _
)
[C#]
void DrawVerticalTabBorder(
VerticalTab item,
Graphics g,
Edge edge,
ArrayList drawTabs,
int selectedIndex
);

Parameters

item
The tab stub.
g
The graphics object.
edge
The edge.
drawTabs
Array of DrawTab objects.
selectedIndex
The selected tab index.

See Also

IDockingRenderer Interface | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


IDockingRenderer.DrawVerticalTabOutline Method

Draws a tab stub outline.

[Visual Basic]
Sub DrawVerticalTabOutline( _
ByVal item As VerticalTab, _
ByVal g As Graphics, _
ByVal pre As Boolean, _
ByVal edge As Edge _
)
[C#]
void DrawVerticalTabOutline(
VerticalTab item,
Graphics g,
bool pre,
Edge edge
);

Parameters

item
The tab stub.
g
The graphics object.
pre
edge
The edge.

See Also

IDockingRenderer Interface | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


IDockingRenderer.FillTabBackgrounds Method

Fills tab backgrounds.

[Visual Basic]
Sub FillTabBackgrounds( _
ByVal ctl As TabControl, _
ByVal g As Graphics, _
ByVal pageAreaRect As Rectangle, _
ByVal tabsAreaRect As Rectangle, _
ByVal appearance As TabPosition _
)
[C#]
void FillTabBackgrounds(
TabControl ctl,
Graphics g,
Rectangle pageAreaRect,
Rectangle tabsAreaRect,
TabPosition appearance
);

Parameters

ctl
g
pageAreaRect
tabsAreaRect
appearance

See Also

IDockingRenderer Interface | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


IDockingRenderer.FillVerticalTabBackground Method

Fills a tab stub background.

[Visual Basic]
Sub FillVerticalTabBackground( _
ByVal item As VerticalTab, _
ByVal g As Graphics _
)
[C#]
void FillVerticalTabBackground(
VerticalTab item,
Graphics g
);

Parameters

item
The tab stub.
g
The graphics object.

See Also

IDockingRenderer Interface | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


IDockingRenderer.GetTabPageSpace Method

Gets tab page space.

[Visual Basic]
Function GetTabPageSpace( _
ByVal g As Graphics, _
ByVal page As TabPage, _
ByVal selectedTextOnly As Boolean, _
ByVal pageSelected As Integer, _
ByVal ctl As TabControl, _
ByVal boldSelected As Boolean _
) As Integer
[C#]
int GetTabPageSpace(
Graphics g,
TabPage page,
bool selectedTextOnly,
int pageSelected,
TabControl ctl,
bool boldSelected
);

Parameters

g
page
selectedTextOnly
pageSelected
ctl
boldSelected

Return Value

See Also

IDockingRenderer Interface | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


IDockingRenderer.PaintCaption Method

Paints a window detail caption.

[Visual Basic]
Sub PaintCaption( _
ByVal g As Graphics, _
ByVal item As DockFrameCaption, _
ByVal rectCaption As Rectangle, _
ByVal focused As Boolean _
)
[C#]
void PaintCaption(
Graphics g,
DockFrameCaption item,
Rectangle rectCaption,
bool focused
);

Parameters

g
The graphics object.
item
The caption.
rectCaption
The bounds rectangle.
focused
Is the caption active?

See Also

IDockingRenderer Interface | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


IDockingRenderer.PaintCaptionButton Method

Paints a caption button.

[Visual Basic]
Sub PaintCaptionButton( _
ByVal g As Graphics, _
ByVal item As CaptionButton, _
ByVal active As Boolean, _
ByVal function As ButtonFunction, _
ByVal mouseOver As Boolean, _
ByVal mouseCapture As Boolean, _
ByVal popupStyle As Boolean _
)
[C#]
void PaintCaptionButton(
Graphics g,
CaptionButton item,
bool active,
ButtonFunction function,
bool mouseOver,
bool mouseCapture,
bool popupStyle
);

Parameters

g
The graphics object.
item
The caption button.
active
Is the caption active?
function
The button's designation.
mouseOver
Is the button hovering?
mouseCapture
Is the button pressed?
popupStyle
Is it a popup-style button?

See Also

IDockingRenderer Interface | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


IDockingRenderer.PaintSizeBar Method

Paints a resize bar.

[Visual Basic]
Sub PaintSizeBar( _
ByVal g As Graphics, _
ByVal item As SizeBar, _
ByVal dock As DockStyle _
)
[C#]
void PaintSizeBar(
Graphics g,
SizeBar item,
DockStyle dock
);

Parameters

g
The graphics object.
item
The resize bar.
dock
The dock style.

See Also

IDockingRenderer Interface | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


IDockingRenderer.RecalculateMultilineTabs Method

Recalculates multiline tabs.

[Visual Basic]
Sub RecalculateMultilineTabs( _
ByVal ctl As TabControl, _
ByVal xStartPos As Integer, _
ByVal xEndPos As Integer, _
ByVal tabPosition As Rectangle, _
ByVal tabButtonHeight As Integer, _
ByVal appearance As TabPosition, _
ByRef topYPos As Integer, _
ByRef bottomYPos As Integer, _
ByRef tabsAreaRect As Rectangle, _
ByRef pageAreaRect As Rectangle, _
ByVal positionAtTop As Boolean, _
ByVal pageSelected As Integer, _
ByVal multilineFullWidth As Boolean, _
ByRef tabRects As ArrayList, _
ByVal selectedTextOnly As Boolean, _
ByVal boldSelected As Boolean _
)
[C#]
void RecalculateMultilineTabs(
TabControl ctl,
int xStartPos,
int xEndPos,
Rectangle tabPosition,
int tabButtonHeight,
TabPosition appearance,
ref int topYPos,
ref int bottomYPos,
ref Rectangle tabsAreaRect,
ref Rectangle pageAreaRect,
bool positionAtTop,
int pageSelected,
bool multilineFullWidth,
ref ArrayList tabRects,
bool selectedTextOnly,
bool boldSelected
);

Parameters

ctl
xStartPos
xEndPos
tabPosition
tabButtonHeight
appearance
topYPos
bottomYPos
tabsAreaRect
pageAreaRect
positionAtTop
pageSelected
multilineFullWidth
tabRects
selectedTextOnly
boldSelected

See Also

IDockingRenderer Interface | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


IDockingRenderer.RecalculateSinglelineTabs Method

Recalculates single line tabs.

[Visual Basic]
Sub RecalculateSinglelineTabs( _
ByVal ctl As TabControl, _
ByVal xStartPos As Integer, _
ByVal xWidth As Integer, _
ByVal tabPosition As Rectangle, _
ByRef topYPos As Integer, _
ByRef bottomYPos As Integer, _
ByVal positionAtTop As Boolean, _
ByVal pageSelected As Integer, _
ByRef tabRects As ArrayList, _
ByVal selectedTextOnly As Boolean, _
ByVal boldSelected As Boolean, _
ByVal startPage As Integer, _
ByVal shrinkPagesToFit As Boolean _
)
[C#]
void RecalculateSinglelineTabs(
TabControl ctl,
int xStartPos,
int xWidth,
Rectangle tabPosition,
ref int topYPos,
ref int bottomYPos,
bool positionAtTop,
int pageSelected,
ref ArrayList tabRects,
bool selectedTextOnly,
bool boldSelected,
int startPage,
bool shrinkPagesToFit
);

Parameters

ctl
xStartPos
xWidth
tabPosition
topYPos
bottomYPos
positionAtTop
pageSelected
tabRects
selectedTextOnly
boldSelected
startPage
shrinkPagesToFit

See Also

IDockingRenderer Interface | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


IDockRegionMaximizeWindow Interface

Internal.

For a list of all members of this type, see IDockRegionMaximizeWindow Members.

[Visual Basic]
Public Interface IDockRegionMaximizeWindow
[C#]
public interface IDockRegionMaximizeWindow

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

IDockRegionMaximizeWindow Members | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


IDockRegionMaximizeWindow Members

IDockRegionMaximizeWindow overview

Public Instance Properties

Direction Internal.

Public Instance Methods

IsMaximizeAvailable | Internal.
IsWindowMaximized | Internal.
MaximizeWindow | Internal.
RestoreWindow | Internal.

Public Instance Events

RefreshMaximize Internal.

See Also

IDockRegionMaximizeWindow Interface | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


IDockRegionMaximizeWindow Properties

The properties of the IDockRegionMaximizeWindow interface are listed below. For a complete list of IDockRegionMaximizeWindow interface members, see the IDockRegionMaximizeWindow Members topic.

Public Instance Properties

Direction Internal.

See Also

IDockRegionMaximizeWindow Interface | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


IDockRegionMaximizeWindow.Direction Property

Internal.

[Visual Basic]
Property Direction As Direction
[C#]
NETXP.Library.Direction Direction {get;}

See Also

IDockRegionMaximizeWindow Interface | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


IDockRegionMaximizeWindow Methods

The methods of the IDockRegionMaximizeWindow interface are listed below. For a complete list of IDockRegionMaximizeWindow interface members, see the IDockRegionMaximizeWindow Members topic.

Public Instance Methods

IsMaximizeAvailable | Internal.
IsWindowMaximized | Internal.
MaximizeWindow | Internal.
RestoreWindow | Internal.

See Also

IDockRegionMaximizeWindow Interface | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


IDockRegionMaximizeWindow.IsMaximizeAvailable Method

Internal.

[Visual Basic]
Function IsMaximizeAvailable() As Boolean
[C#]
bool IsMaximizeAvailable();

Return Value

See Also

IDockRegionMaximizeWindow Interface | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


IDockRegionMaximizeWindow.IsWindowMaximized Method

Internal.

[Visual Basic]
Function IsWindowMaximized( _
ByVal w As Window _
) As Boolean
[C#]
bool IsWindowMaximized(
Window w
);

Parameters

w

Return Value

See Also

IDockRegionMaximizeWindow Interface | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


IDockRegionMaximizeWindow.MaximizeWindow Method

Internal.

[Visual Basic]
Sub MaximizeWindow( _
ByVal w As Window _
)
[C#]
void MaximizeWindow(
Window w
);

Parameters

w

See Also

IDockRegionMaximizeWindow Interface | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


IDockRegionMaximizeWindow.RestoreWindow Method

Internal.

[Visual Basic]
Sub RestoreWindow()
[C#]
void RestoreWindow();

See Also

IDockRegionMaximizeWindow Interface | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


IDockRegionMaximizeWindow Events

The events of the IDockRegionMaximizeWindow interface are listed below. For a complete list of IDockRegionMaximizeWindow interface members, see the IDockRegionMaximizeWindow Members topic.

Public Instance Events

RefreshMaximize Internal.

See Also

IDockRegionMaximizeWindow Interface | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


IDockRegionMaximizeWindow.RefreshMaximize Event

Internal.

[Visual Basic]
Event RefreshMaximize As EventHandler
[C#]
event EventHandler RefreshMaximize;

See Also

IDockRegionMaximizeWindow Interface | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


IHotDockRegionSource Interface

Internal.

For a list of all members of this type, see IHotDockRegionSource Members.

[Visual Basic]
Public Interface IHotDockRegionSource
[C#]
public interface IHotDockRegionSource

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

IHotDockRegionSource Members | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


IHotDockRegionSource Members

IHotDockRegionSource overview

Public Instance Methods

AddHotDockRegions Internal.

See Also

IHotDockRegionSource Interface | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


IHotDockRegionSource Methods

The methods of the IHotDockRegionSource interface are listed below. For a complete list of IHotDockRegionSource interface members, see the IHotDockRegionSource Members topic.

Public Instance Methods

AddHotDockRegions Internal.

See Also

IHotDockRegionSource Interface | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


IHotDockRegionSource.AddHotDockRegions Method

Internal.

[Visual Basic]
Sub AddHotDockRegions( _
ByVal redock As Redocker, _
ByVal collection As HotDockRegionCollection _
)
[C#]
void AddHotDockRegions(
Redocker redock,
HotDockRegionCollection collection
);

Parameters

redock
collection

See Also

IHotDockRegionSource Interface | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


IResizeSource Interface

Used by the docking manager internally.

For a list of all members of this type, see IResizeSource Members.

[Visual Basic]
Public Interface IResizeSource
[C#]
public interface IResizeSource

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

IResizeSource Members | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


IResizeSource Members

IResizeSource overview

Public Instance Properties

Renderer | Internal.
SizeBarWidth | Internal.

Public Instance Methods

CanResize | Internal.
EndResizeOperation | Internal.
StartResizeOperation | Internal.

See Also

IResizeSource Interface | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


IResizeSource Properties

The properties of the IResizeSource interface are listed below. For a complete list of IResizeSource interface members, see the IResizeSource Members topic.

Public Instance Properties

Renderer | Internal.
SizeBarWidth | Internal.

See Also

IResizeSource Interface | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


IResizeSource.Renderer Property

Internal.

[Visual Basic]
Property Renderer As IDockingRenderer
[C#]
IDockingRenderer Renderer {get;}

See Also

IResizeSource Interface | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


IResizeSource.SizeBarWidth Property

Internal.

[Visual Basic]
Property SizeBarWidth As Integer
[C#]
int SizeBarWidth {get;}

See Also

IResizeSource Interface | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


IResizeSource Methods

The methods of the IResizeSource interface are listed below. For a complete list of IResizeSource interface members, see the IResizeSource Members topic.

Public Instance Methods

CanResize | Internal.
EndResizeOperation | Internal.
StartResizeOperation | Internal.

See Also

IResizeSource Interface | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


IResizeSource.CanResize Method

Internal.

[Visual Basic]
Function CanResize( _
ByVal bar As SizeBar _
) As Boolean
[C#]
bool CanResize(
SizeBar bar
);

Parameters

bar

Return Value

See Also

IResizeSource Interface | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


IResizeSource.EndResizeOperation Method

Internal.

[Visual Basic]
Sub EndResizeOperation( _
ByVal bar As SizeBar, _
ByVal delta As Integer _
)
[C#]
void EndResizeOperation(
SizeBar bar,
int delta
);

Parameters

bar
delta

See Also

IResizeSource Interface | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


IResizeSource.StartResizeOperation Method

Internal.

[Visual Basic]
Function StartResizeOperation( _
ByVal bar As SizeBar, _
ByRef screenBoundary As Rectangle _
) As Boolean
[C#]
bool StartResizeOperation(
SizeBar bar,
ref Rectangle screenBoundary
);

Parameters

bar
screenBoundary

Return Value

See Also

IResizeSource Interface | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


LoadCustomConfigHandler Delegate

Custom configuration about to be loaded.

[Visual Basic]
Public Delegate Sub LoadCustomConfigHandler( _
ByVal xmlIn As XmlTextReader _
)
[C#]
public delegate void LoadCustomConfigHandler(
XmlTextReader xmlIn
);

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


ManagerDockObjectCollection Class

Internal.

For a list of all members of this type, see ManagerDockObjectCollection Members.

System.Object
CollectionBase
CollectionEx
ManagerDockObjectCollection

[Visual Basic]
NotInheritable Public Class ManagerDockObjectCollection
Inherits CollectionEx
[C#]
public sealed class ManagerDockObjectCollection : CollectionEx

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

ManagerDockObjectCollection Members | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


ManagerDockObjectCollection Members

ManagerDockObjectCollection overview

Public Instance Constructors

ManagerDockObjectCollection Constructor Internal.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
IsSuspended (inherited from CollectionEx) | Is event generation already suspended?
Item | Overloaded. Internal.

Public Instance Methods

Add | Overloaded. Internal.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Contains | Internal.
Copy | Internal.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Internal.
RaiseChanged (inherited from CollectionEx) | Raises the Changed event.
Remove | Internal.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
ResumeEvents (inherited from CollectionEx) | Resume event generation.
SetIndex | Internal.
SuspendEvents (inherited from CollectionEx) | Suspend event generation.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

Changed (inherited from CollectionEx) | Event raised when the collection has changed.
Cleared (inherited from CollectionEx) | Event raised when collection has been cleared.
Clearing (inherited from CollectionEx) | Event raised when collection is being cleared.
Inserted (inherited from CollectionEx) | Event raised when an item has been inserted.
Inserting (inherited from CollectionEx) | Event raised when an item is being inserted.
Removed (inherited from CollectionEx) | Event raised when an item has been removed.
Removing (inherited from CollectionEx) | Event raised when an item is being removed.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

ManagerDockObjectCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


ManagerDockObjectCollection Constructor

Internal.

[Visual Basic]
Public Sub New( _
ByVal manager As DockingManager _
)
[C#]
public ManagerDockObjectCollection(
DockingManager manager
);

Parameters

manager

See Also

ManagerDockObjectCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


ManagerDockObjectCollection Properties

The properties of the ManagerDockObjectCollection class are listed below. For a complete list of ManagerDockObjectCollection class members, see the ManagerDockObjectCollection Members topic.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
IsSuspended (inherited from CollectionEx) | Is event generation already suspended?
Item | Overloaded. Internal.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

ManagerDockObjectCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Item Property

NetXP 3.0 Reference

ManagerDockObjectCollection.Item Property

Internal.

Overload List

Internal.

public DockObject this[int] {get;}

Internal.

public DockObject this[string] {get;}

See Also

ManagerDockObjectCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


ManagerDockObjectCollection.Item Property

Internal.

[Visual Basic]
Overloads Public Default ReadOnly Property Item( _
ByVal index As Integer _
) As DockObject
[C#]
public DockObject this[
int index
] {get;}

See Also

ManagerDockObjectCollection Class | NETXP.Controls.Docking Namespace | ManagerDockObjectCollection.Item Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


ManagerDockObjectCollection.Item Property

Internal.

[Visual Basic]
Overloads Public Default ReadOnly Property Item( _
ByVal title As String _
) As DockObject
[C#]
public DockObject this[
string title
] {get;}

See Also

ManagerDockObjectCollection Class | NETXP.Controls.Docking Namespace | ManagerDockObjectCollection.Item Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


ManagerDockObjectCollection Methods

The methods of the ManagerDockObjectCollection class are listed below. For a complete list of ManagerDockObjectCollection class members, see the ManagerDockObjectCollection Members topic.

Public Instance Methods

Add | Overloaded. Internal.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Contains | Internal.
Copy | Internal.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Internal.
RaiseChanged (inherited from CollectionEx) | Raises the Changed event.
Remove | Internal.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
ResumeEvents (inherited from CollectionEx) | Resume event generation.
SetIndex | Internal.
SuspendEvents (inherited from CollectionEx) | Suspend event generation.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

ManagerDockObjectCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Add Method

NetXP 3.0 Reference

ManagerDockObjectCollection.Add Method

Internal.

Overload List

Internal.

public DockObject Add();

Internal.

public DockObject Add(DockObject);

Internal.

public DockObject Add(Control);

Internal.

public DockObject Add(Control,string);

Internal.

public DockObject Add(Control,string,Image);

See Also

ManagerDockObjectCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


ManagerDockObjectCollection.Add Method ()

Internal.

[Visual Basic]
Overloads Public Function Add() As DockObject
[C#]
public DockObject Add();

Return Value

See Also

ManagerDockObjectCollection Class | NETXP.Controls.Docking Namespace | ManagerDockObjectCollection.Add Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


ManagerDockObjectCollection.Add Method (DockObject)

Internal.

[Visual Basic]
Overloads Public Function Add( _
ByVal c As DockObject _
) As DockObject
[C#]
public DockObject Add(
DockObject c
);

Parameters

c

Return Value

See Also

ManagerDockObjectCollection Class | NETXP.Controls.Docking Namespace | ManagerDockObjectCollection.Add Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


ManagerDockObjectCollection.Add Method (Control)

Internal.

[Visual Basic]
Overloads Public Function Add( _
ByVal control As Control _
) As DockObject
[C#]
public DockObject Add(
Control control
);

Parameters

control

Return Value

See Also

ManagerDockObjectCollection Class | NETXP.Controls.Docking Namespace | ManagerDockObjectCollection.Add Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


ManagerDockObjectCollection.Add Method (Control, String)

Internal.

[Visual Basic]
Overloads Public Function Add( _
ByVal control As Control, _
ByVal title As String _
) As DockObject
[C#]
public DockObject Add(
Control control,
string title
);

Parameters

control
title

Return Value

See Also

ManagerDockObjectCollection Class | NETXP.Controls.Docking Namespace | ManagerDockObjectCollection.Add Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


ManagerDockObjectCollection.Add Method (Control, String, Image)

Internal.

[Visual Basic]
Overloads Public Function Add( _
ByVal control As Control, _
ByVal title As String, _
ByVal icon As Image _
) As DockObject
[C#]
public DockObject Add(
Control control,
string title,
Image icon
);

Parameters

control
title
icon

Return Value

See Also

ManagerDockObjectCollection Class | NETXP.Controls.Docking Namespace | ManagerDockObjectCollection.Add Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


ManagerDockObjectCollection.Contains Method

Internal.

[Visual Basic]
Public Function Contains( _
ByVal value As DockObject _
) As Boolean
[C#]
public bool Contains(
DockObject value
);

Parameters

value

Return Value

See Also

ManagerDockObjectCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


ManagerDockObjectCollection.Copy Method

Internal.

[Visual Basic]
Public Function Copy() As DockObjectCollection
[C#]
public DockObjectCollection Copy();

Return Value

See Also

ManagerDockObjectCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


ManagerDockObjectCollection.IndexOf Method

Internal.

[Visual Basic]
Public Function IndexOf( _
ByVal value As DockObject _
) As Integer
[C#]
public int IndexOf(
DockObject value
);

Parameters

value

Return Value

See Also

ManagerDockObjectCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


ManagerDockObjectCollection.Remove Method

Internal.

[Visual Basic]
Public Sub Remove( _
ByVal value As DockObject _
)
[C#]
public void Remove(
DockObject value
);

Parameters

value

See Also

ManagerDockObjectCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


ManagerDockObjectCollection.SetIndex Method

Internal.

[Visual Basic]
Public Function SetIndex( _
ByVal newIndex As Integer, _
ByVal value As DockObject _
) As Integer
[C#]
public int SetIndex(
int newIndex,
DockObject value
);

Parameters

newIndex
value

Return Value

See Also

ManagerDockObjectCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


PageLoadingEventArgs Class

Defines the loading event arguments.

For a list of all members of this type, see PageLoadingEventArgs Members.

System.Object
PageLoadingEventArgs

[Visual Basic]
Public Class PageLoadingEventArgs
[C#]
public class PageLoadingEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

PageLoadingEventArgs Members | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


PageLoadingEventArgs Members

PageLoadingEventArgs overview

Public Instance Constructors

PageLoadingEventArgs Constructor Constructs a new PageLoadingEventArgs object.

Public Instance Properties

Cancel | Cancel this event?
TabPage | Gets the tab page.
XmlIn | Gets the XML reader.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

PageLoadingEventArgs Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


PageLoadingEventArgs Constructor

Constructs a new PageLoadingEventArgs object.

[Visual Basic]
Public Sub New( _
ByVal tp As TabPage, _
ByVal xmlIn As XmlTextReader _
)
[C#]
public PageLoadingEventArgs(
TabPage tp,
XmlTextReader xmlIn
);

Parameters

tp
The tab page.
xmlIn
The XML layout data.

See Also

PageLoadingEventArgs Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


PageLoadingEventArgs Properties

The properties of the PageLoadingEventArgs class are listed below. For a complete list of PageLoadingEventArgs class members, see the PageLoadingEventArgs Members topic.

Public Instance Properties

Cancel | Cancel this event?
TabPage | Gets the tab page.
XmlIn | Gets the XML reader.

See Also

PageLoadingEventArgs Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


PageLoadingEventArgs.Cancel Property

Cancel this event?

[Visual Basic]
Public Property Cancel As Boolean
[C#]
public bool Cancel {get; set;}

See Also

PageLoadingEventArgs Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


PageLoadingEventArgs.TabPage Property

Gets the tab page.

[Visual Basic]
Public ReadOnly Property TabPage As TabPage
[C#]
public TabPage TabPage {get;}

See Also

PageLoadingEventArgs Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


PageLoadingEventArgs.XmlIn Property

Gets the XML reader.

[Visual Basic]
Public ReadOnly Property XmlIn As XmlTextReader
[C#]
public System.Xml.XmlTextReader XmlIn {get;}

See Also

PageLoadingEventArgs Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


PageSavingEventArgs Class

Defines the saving event arguments.

For a list of all members of this type, see PageSavingEventArgs Members.

System.Object
PageSavingEventArgs

[Visual Basic]
Public Class PageSavingEventArgs
[C#]
public class PageSavingEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

PageSavingEventArgs Members | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


PageSavingEventArgs Members

PageSavingEventArgs overview

Public Instance Constructors

PageSavingEventArgs Constructor Constructs a new PageSavingEventArgs object.

Public Instance Properties

TabPage | Gets the tab page.
XmlOut | Gets the XML writer.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

PageSavingEventArgs Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


PageSavingEventArgs Constructor

Constructs a new PageSavingEventArgs object.

[Visual Basic]
Public Sub New( _
ByVal tp As TabPage, _
ByVal xmlOut As XmlTextWriter _
)
[C#]
public PageSavingEventArgs(
TabPage tp,
XmlTextWriter xmlOut
);

Parameters

tp
The tab page.
xmlOut
The XML layout data.

See Also

PageSavingEventArgs Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


PageSavingEventArgs Properties

The properties of the PageSavingEventArgs class are listed below. For a complete list of PageSavingEventArgs class members, see the PageSavingEventArgs Members topic.

Public Instance Properties

TabPage | Gets the tab page.
XmlOut | Gets the XML writer.

See Also

PageSavingEventArgs Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


PageSavingEventArgs.TabPage Property

Gets the tab page.

[Visual Basic]
Public ReadOnly Property TabPage As TabPage
[C#]
public TabPage TabPage {get;}

See Also

PageSavingEventArgs Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


PageSavingEventArgs.XmlOut Property

Gets the XML writer.

[Visual Basic]
Public ReadOnly Property XmlOut As XmlTextWriter
[C#]
public System.Xml.XmlTextWriter XmlOut {get;}

See Also

PageSavingEventArgs Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Redocker Class

Internal.

For a list of all members of this type, see Redocker Members.

System.Object
Redocker

[Visual Basic]
Public Class Redocker
[C#]
public class Redocker

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

Redocker Members | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Redocker Members

Redocker overview

Public Instance Constructors

Redocker Constructor Internal.

Public Instance Properties

Tracking Internal.

Public Instance Methods

EnterTrackingMode | Internal.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExitTrackingMode | Internal.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
OnMouseMove | Internal.
OnMouseUp | Internal.
QuitTrackingMode | Internal.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Redocker Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Redocker Constructor

Internal.

[Visual Basic]
Public Sub New()
[C#]
public Redocker();

See Also

Redocker Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Redocker Properties

The properties of the Redocker class are listed below. For a complete list of Redocker class members, see the Redocker Members topic.

Public Instance Properties

Tracking Internal.

See Also

Redocker Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Redocker.Tracking Property

Internal.

[Visual Basic]
Public ReadOnly Property Tracking As Boolean
[C#]
public bool Tracking {get;}

See Also

Redocker Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Redocker Methods

The methods of the Redocker class are listed below. For a complete list of Redocker class members, see the Redocker Members topic.

Public Instance Methods

EnterTrackingMode | Internal.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExitTrackingMode | Internal.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
OnMouseMove | Internal.
OnMouseUp | Internal.
QuitTrackingMode | Internal.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Redocker Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Redocker.EnterTrackingMode Method

Internal.

[Visual Basic]
Overridable Public Sub EnterTrackingMode()
[C#]
public virtual void EnterTrackingMode();

See Also

Redocker Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Redocker.ExitTrackingMode Method

Internal.

[Visual Basic]
Overridable Public Function ExitTrackingMode( _
ByVal e As MouseEventArgs _
) As Boolean
[C#]
public virtual bool ExitTrackingMode(
MouseEventArgs e
);

Parameters

e

Return Value

See Also

Redocker Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Redocker.OnMouseMove Method

Internal.

[Visual Basic]
Overridable Public Sub OnMouseMove( _
ByVal e As MouseEventArgs _
)
[C#]
public virtual void OnMouseMove(
MouseEventArgs e
);

Parameters

e

See Also

Redocker Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Redocker.OnMouseUp Method

Internal.

[Visual Basic]
Overridable Public Function OnMouseUp( _
ByVal e As MouseEventArgs _
) As Boolean
[C#]
public virtual bool OnMouseUp(
MouseEventArgs e
);

Parameters

e

Return Value

See Also

Redocker Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Redocker.QuitTrackingMode Method

Internal.

[Visual Basic]
Overridable Public Sub QuitTrackingMode( _
ByVal e As MouseEventArgs _
)
[C#]
public virtual void QuitTrackingMode(
MouseEventArgs e
);

Parameters

e

See Also

Redocker Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers Class

Provides renderers for Windows Default, Office XP, and Office 2003 styles.

For a list of all members of this type, see Renderers Members.

System.Object
Renderers

[Visual Basic]
Public Class Renderers
[C#]
public class Renderers

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

Renderers Members | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers Members

Renderers overview

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Renderers Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers.Office2003 Class

Office 2003 style.

For a list of all members of this type, see Renderers.Office2003 Members.

System.Object
Renderers.Office2003

[Visual Basic]
Public Class Renderers.Office2003
Implements NETXP.Controls.Docking.IDockingRenderer
[C#]
public class Renderers.Office2003 : IDockingRenderer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

Renderers.Office2003 Members | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers.Office2003 Members

Renderers.Office2003 overview

Public Instance Constructors

Renderers.Office2003 Overloaded. Initializes a new instance of the Renderers.Office2003 class.

Public Instance Properties

ColorTable Internal

Public Instance Methods

DrawAutoHidePanel | Internal. See IDockingRenderer
DrawTab | Internal. See IDockingRenderer
DrawTabBorders | Internal. See IDockingRenderer
DrawVerticalTabBorder | Internal. See IDockingRenderer
DrawVerticalTabOutline | Internal. See IDockingRenderer
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FillTabBackgrounds | Internal. See IDockingRenderer
FillVerticalTabBackground | Internal. See IDockingRenderer
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetTabPageSpace | Internal. See IDockingRenderer
GetType (inherited from Object) | Gets the Type of the current instance.
PaintCaption | Internal. See IDockingRenderer
PaintCaptionButton | Internal. See IDockingRenderer
PaintSizeBar | Internal. See IDockingRenderer
RecalculateMultilineTabs | Internal. See IDockingRenderer
RecalculateSinglelineTabs | Internal. See IDockingRenderer
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Renderers.Office2003 Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers.Office2003 Constructor

Internal

Overload List

Internal

public Renderers.Office2003();

Internal

public Renderers.Office2003(IColorTable);

See Also

Renderers.Office2003 Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers.Office2003 Constructor ()

Internal

[Visual Basic]
Overloads Public Sub New()
[C#]
public Renderers.Office2003();

See Also

Renderers.Office2003 Class | NETXP.Controls.Docking Namespace | Renderers.Office2003 Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers.Office2003 Constructor (IColorTable)

Internal

[Visual Basic]
Overloads Public Sub New( _
ByVal colorTable As IColorTable _
)
[C#]
public Renderers.Office2003(
IColorTable colorTable
);

Parameters

colorTable

See Also

Renderers.Office2003 Class | NETXP.Controls.Docking Namespace | Renderers.Office2003 Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers.Office2003 Properties

The properties of the Renderers.Office2003 class are listed below. For a complete list of Renderers.Office2003 class members, see the Renderers.Office2003 Members topic.

Public Instance Properties

ColorTable Internal

See Also

Renderers.Office2003 Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers.Office2003.ColorTable Property

Internal

[Visual Basic]
Public Property ColorTable As IColorTable
[C#]
public NETXP.Library.IColorTable ColorTable {get; set;}

See Also

Renderers.Office2003 Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers.Office2003 Methods

The methods of the Renderers.Office2003 class are listed below. For a complete list of Renderers.Office2003 class members, see the Renderers.Office2003 Members topic.

Public Instance Methods

DrawAutoHidePanel | Internal. See IDockingRenderer
DrawTab | Internal. See IDockingRenderer
DrawTabBorders | Internal. See IDockingRenderer
DrawVerticalTabBorder | Internal. See IDockingRenderer
DrawVerticalTabOutline | Internal. See IDockingRenderer
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FillTabBackgrounds | Internal. See IDockingRenderer
FillVerticalTabBackground | Internal. See IDockingRenderer
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetTabPageSpace | Internal. See IDockingRenderer
GetType (inherited from Object) | Gets the Type of the current instance.
PaintCaption | Internal. See IDockingRenderer
PaintCaptionButton | Internal. See IDockingRenderer
PaintSizeBar | Internal. See IDockingRenderer
RecalculateMultilineTabs | Internal. See IDockingRenderer
RecalculateSinglelineTabs | Internal. See IDockingRenderer
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Renderers.Office2003 Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers.Office2003.DrawAutoHidePanel Method

Internal. See IDockingRenderer

[Visual Basic]
NotOverridable Public Sub DrawAutoHidePanel( _
ByVal item As AutoHidePanel, _
ByVal g As Graphics _
) Implements _
IDockingRenderer.DrawAutoHidePanel
[C#]
public void DrawAutoHidePanel(
AutoHidePanel item,
Graphics g
);

Parameters

item
g

Implements

IDockingRenderer.DrawAutoHidePanel

See Also

Renderers.Office2003 Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers.Office2003.DrawTab Method

Internal. See IDockingRenderer

[Visual Basic]
NotOverridable Public Sub DrawTab( _
ByVal ctl As TabControl, _
ByVal page As TabPage, _
ByVal g As Graphics, _
ByVal highlightText As Boolean, _
ByVal tabRects As ArrayList, _
ByVal imageGapTopExtra As Integer, _
ByVal selectedTextOnly As Boolean, _
ByVal dimUnselected As Boolean, _
ByVal boldSelected As Boolean, _
ByVal appearance As TabPosition, _
ByVal multiline As Boolean, _
ByVal positionAtTop As Boolean _
) Implements _
IDockingRenderer.DrawTab
[C#]
public void DrawTab(
TabControl ctl,
TabPage page,
Graphics g,
bool highlightText,
ArrayList tabRects,
int imageGapTopExtra,
bool selectedTextOnly,
bool dimUnselected,
bool boldSelected,
TabPosition appearance,
bool multiline,
bool positionAtTop
);

Parameters

ctl
page
g
highlightText
tabRects
imageGapTopExtra
selectedTextOnly
dimUnselected
boldSelected
appearance
multiline
positionAtTop

Implements

IDockingRenderer.DrawTab

See Also

Renderers.Office2003 Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers.Office2003.DrawTabBorders Method

Internal. See IDockingRenderer

[Visual Basic]
NotOverridable Public Sub DrawTabBorders( _
ByVal ctl As TabControl, _
ByVal g As Graphics, _
ByVal positionAtTop As Boolean, _
ByVal tabsAreaRect As Rectangle, _
ByVal pixelBorder As Boolean, _
ByVal pixelArea As Boolean, _
ByVal hiddenPages As Boolean _
) Implements _
IDockingRenderer.DrawTabBorders
[C#]
public void DrawTabBorders(
TabControl ctl,
Graphics g,
bool positionAtTop,
Rectangle tabsAreaRect,
bool pixelBorder,
bool pixelArea,
bool hiddenPages
);

Parameters

ctl
g
positionAtTop
tabsAreaRect
pixelBorder
pixelArea
hiddenPages

Implements

IDockingRenderer.DrawTabBorders

See Also

Renderers.Office2003 Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers.Office2003.DrawVerticalTabBorder Method

Internal. See IDockingRenderer

[Visual Basic]
NotOverridable Public Sub DrawVerticalTabBorder( _
ByVal item As VerticalTab, _
ByVal g As Graphics, _
ByVal edge As Edge, _
ByVal drawTabs As ArrayList, _
ByVal selectedIndex As Integer _
) Implements _
IDockingRenderer.DrawVerticalTabBorder
[C#]
public void DrawVerticalTabBorder(
VerticalTab item,
Graphics g,
Edge edge,
ArrayList drawTabs,
int selectedIndex
);

Parameters

item
g
edge
drawTabs
selectedIndex

Implements

IDockingRenderer.DrawVerticalTabBorder

See Also

Renderers.Office2003 Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers.Office2003.DrawVerticalTabOutline Method

Internal. See IDockingRenderer

[Visual Basic]
NotOverridable Public Sub DrawVerticalTabOutline( _
ByVal item As VerticalTab, _
ByVal g As Graphics, _
ByVal pre As Boolean, _
ByVal edge As Edge _
) Implements _
IDockingRenderer.DrawVerticalTabOutline
[C#]
public void DrawVerticalTabOutline(
VerticalTab item,
Graphics g,
bool pre,
Edge edge
);

Parameters

item
g
pre
edge

Implements

IDockingRenderer.DrawVerticalTabOutline

See Also

Renderers.Office2003 Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers.Office2003.FillTabBackgrounds Method

Internal. See IDockingRenderer

[Visual Basic]
NotOverridable Public Sub FillTabBackgrounds( _
ByVal ctl As TabControl, _
ByVal g As Graphics, _
ByVal pageAreaRect As Rectangle, _
ByVal tabsAreaRect As Rectangle, _
ByVal appearance As TabPosition _
) Implements _
IDockingRenderer.FillTabBackgrounds
[C#]
public void FillTabBackgrounds(
TabControl ctl,
Graphics g,
Rectangle pageAreaRect,
Rectangle tabsAreaRect,
TabPosition appearance
);

Parameters

ctl
g
pageAreaRect
tabsAreaRect
appearance

Implements

IDockingRenderer.FillTabBackgrounds

See Also

Renderers.Office2003 Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers.Office2003.FillVerticalTabBackground Method

Internal. See IDockingRenderer

[Visual Basic]
NotOverridable Public Sub FillVerticalTabBackground( _
ByVal item As VerticalTab, _
ByVal g As Graphics _
) Implements _
IDockingRenderer.FillVerticalTabBackground
[C#]
public void FillVerticalTabBackground(
VerticalTab item,
Graphics g
);

Parameters

item
g

Implements

IDockingRenderer.FillVerticalTabBackground

See Also

Renderers.Office2003 Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers.Office2003.GetTabPageSpace Method

Internal. See IDockingRenderer

[Visual Basic]
NotOverridable Public Function GetTabPageSpace( _
ByVal g As Graphics, _
ByVal page As TabPage, _
ByVal selectedTextOnly As Boolean, _
ByVal pageSelected As Integer, _
ByVal ctl As TabControl, _
ByVal boldSelected As Boolean _
) As Integer Implements _
IDockingRenderer.GetTabPageSpace
[C#]
public int GetTabPageSpace(
Graphics g,
TabPage page,
bool selectedTextOnly,
int pageSelected,
TabControl ctl,
bool boldSelected
);

Parameters

g
page
selectedTextOnly
pageSelected
ctl
boldSelected

Return Value

Implements

IDockingRenderer.GetTabPageSpace

See Also

Renderers.Office2003 Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers.Office2003.PaintCaption Method

Internal. See IDockingRenderer

[Visual Basic]
NotOverridable Public Sub PaintCaption( _
ByVal g As Graphics, _
ByVal item As DockFrameCaption, _
ByVal rectCaption As Rectangle, _
ByVal focused As Boolean _
) Implements _
IDockingRenderer.PaintCaption
[C#]
public void PaintCaption(
Graphics g,
DockFrameCaption item,
Rectangle rectCaption,
bool focused
);

Parameters

g
item
rectCaption
focused

Implements

IDockingRenderer.PaintCaption

See Also

Renderers.Office2003 Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers.Office2003.PaintCaptionButton Method

Internal. See IDockingRenderer

[Visual Basic]
NotOverridable Public Sub PaintCaptionButton( _
ByVal g As Graphics, _
ByVal item As CaptionButton, _
ByVal active As Boolean, _
ByVal function As ButtonFunction, _
ByVal mouseOver As Boolean, _
ByVal mouseCapture As Boolean, _
ByVal popupStyle As Boolean _
) Implements _
IDockingRenderer.PaintCaptionButton
[C#]
public void PaintCaptionButton(
Graphics g,
CaptionButton item,
bool active,
ButtonFunction function,
bool mouseOver,
bool mouseCapture,
bool popupStyle
);

Parameters

g
item
active
function
mouseOver
mouseCapture
popupStyle

Implements

IDockingRenderer.PaintCaptionButton

See Also

Renderers.Office2003 Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers.Office2003.PaintSizeBar Method

Internal. See IDockingRenderer

[Visual Basic]
NotOverridable Public Sub PaintSizeBar( _
ByVal g As Graphics, _
ByVal item As SizeBar, _
ByVal dock As DockStyle _
) Implements _
IDockingRenderer.PaintSizeBar
[C#]
public void PaintSizeBar(
Graphics g,
SizeBar item,
DockStyle dock
);

Parameters

g
item
dock

Implements

IDockingRenderer.PaintSizeBar

See Also

Renderers.Office2003 Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers.Office2003.RecalculateMultilineTabs Method

Internal. See IDockingRenderer

[Visual Basic]
NotOverridable Public Sub RecalculateMultilineTabs( _
ByVal ctl As TabControl, _
ByVal xStartPos As Integer, _
ByVal xEndPos As Integer, _
ByVal tabPosition As Rectangle, _
ByVal tabButtonHeight As Integer, _
ByVal appearance As TabPosition, _
ByRef topYPos As Integer, _
ByRef bottomYPos As Integer, _
ByRef tabsAreaRect As Rectangle, _
ByRef pageAreaRect As Rectangle, _
ByVal positionAtTop As Boolean, _
ByVal pageSelected As Integer, _
ByVal multilineFullWidth As Boolean, _
ByRef tabRects As ArrayList, _
ByVal selectedTextOnly As Boolean, _
ByVal boldSelected As Boolean _
) Implements _
IDockingRenderer.RecalculateMultilineTabs
[C#]
public void RecalculateMultilineTabs(
TabControl ctl,
int xStartPos,
int xEndPos,
Rectangle tabPosition,
int tabButtonHeight,
TabPosition appearance,
ref int topYPos,
ref int bottomYPos,
ref Rectangle tabsAreaRect,
ref Rectangle pageAreaRect,
bool positionAtTop,
int pageSelected,
bool multilineFullWidth,
ref ArrayList tabRects,
bool selectedTextOnly,
bool boldSelected
);

Parameters

ctl
xStartPos
xEndPos
tabPosition
tabButtonHeight
appearance
topYPos
bottomYPos
tabsAreaRect
pageAreaRect
positionAtTop
pageSelected
multilineFullWidth
tabRects
selectedTextOnly
boldSelected

Implements

IDockingRenderer.RecalculateMultilineTabs

See Also

Renderers.Office2003 Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers.Office2003.RecalculateSinglelineTabs Method

Internal. See IDockingRenderer

[Visual Basic]
NotOverridable Public Sub RecalculateSinglelineTabs( _
ByVal ctl As TabControl, _
ByVal xStartPos As Integer, _
ByVal xWidth As Integer, _
ByVal tabPosition As Rectangle, _
ByRef topYPos As Integer, _
ByRef bottomYPos As Integer, _
ByVal positionAtTop As Boolean, _
ByVal pageSelected As Integer, _
ByRef tabRects As ArrayList, _
ByVal selectedTextOnly As Boolean, _
ByVal boldSelected As Boolean, _
ByVal startPage As Integer, _
ByVal shrinkPagesToFit As Boolean _
) Implements _
IDockingRenderer.RecalculateSinglelineTabs
[C#]
public void RecalculateSinglelineTabs(
TabControl ctl,
int xStartPos,
int xWidth,
Rectangle tabPosition,
ref int topYPos,
ref int bottomYPos,
bool positionAtTop,
int pageSelected,
ref ArrayList tabRects,
bool selectedTextOnly,
bool boldSelected,
int startPage,
bool shrinkPagesToFit
);

Parameters

ctl
xStartPos
xWidth
tabPosition
topYPos
bottomYPos
positionAtTop
pageSelected
tabRects
selectedTextOnly
boldSelected
startPage
shrinkPagesToFit

Implements

IDockingRenderer.RecalculateSinglelineTabs

See Also

Renderers.Office2003 Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers.OfficeXP Class

Office XP / VS.NET IDE style.

For a list of all members of this type, see Renderers.OfficeXP Members.

System.Object
Renderers.OfficeXP

[Visual Basic]
Public Class Renderers.OfficeXP
Implements NETXP.Controls.Docking.IDockingRenderer
[C#]
public class Renderers.OfficeXP : IDockingRenderer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

Renderers.OfficeXP Members | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers.OfficeXP Members

Renderers.OfficeXP overview

Public Instance Constructors

Renderers.OfficeXP Overloaded. Initializes a new instance of the Renderers.OfficeXP class.

Public Instance Properties

ColorTable Internal

Public Instance Methods

DrawAutoHidePanel | Internal. See IDockingRenderer
DrawTab | Internal. See IDockingRenderer
DrawTabBorders | Internal. See IDockingRenderer
DrawVerticalTabBorder | Internal. See IDockingRenderer
DrawVerticalTabOutline | Internal. See IDockingRenderer
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FillTabBackgrounds | Internal. See IDockingRenderer
FillVerticalTabBackground | Internal. See IDockingRenderer
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetTabPageSpace | Internal. See IDockingRenderer
GetType (inherited from Object) | Gets the Type of the current instance.
PaintCaption | Internal. See IDockingRenderer
PaintCaptionButton | Internal. See IDockingRenderer
PaintSizeBar | Internal. See IDockingRenderer
RecalculateMultilineTabs | Internal. See IDockingRenderer
RecalculateSinglelineTabs | Internal. See IDockingRenderer
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Renderers.OfficeXP Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers.OfficeXP Constructor

Internal

Overload List

Internal

public Renderers.OfficeXP();

Internal

public Renderers.OfficeXP(IColorTable);

See Also

Renderers.OfficeXP Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers.OfficeXP Constructor ()

Internal

[Visual Basic]
Overloads Public Sub New()
[C#]
public Renderers.OfficeXP();

See Also

Renderers.OfficeXP Class | NETXP.Controls.Docking Namespace | Renderers.OfficeXP Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers.OfficeXP Constructor (IColorTable)

Internal

[Visual Basic]
Overloads Public Sub New( _
ByVal colorTable As IColorTable _
)
[C#]
public Renderers.OfficeXP(
IColorTable colorTable
);

Parameters

colorTable

See Also

Renderers.OfficeXP Class | NETXP.Controls.Docking Namespace | Renderers.OfficeXP Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers.OfficeXP Properties

The properties of the Renderers.OfficeXP class are listed below. For a complete list of Renderers.OfficeXP class members, see the Renderers.OfficeXP Members topic.

Public Instance Properties

ColorTable Internal

See Also

Renderers.OfficeXP Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers.OfficeXP.ColorTable Property

Internal

[Visual Basic]
Public Property ColorTable As IColorTable
[C#]
public NETXP.Library.IColorTable ColorTable {get; set;}

See Also

Renderers.OfficeXP Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers.OfficeXP Methods

The methods of the Renderers.OfficeXP class are listed below. For a complete list of Renderers.OfficeXP class members, see the Renderers.OfficeXP Members topic.

Public Instance Methods

DrawAutoHidePanel | Internal. See IDockingRenderer
DrawTab | Internal. See IDockingRenderer
DrawTabBorders | Internal. See IDockingRenderer
DrawVerticalTabBorder | Internal. See IDockingRenderer
DrawVerticalTabOutline | Internal. See IDockingRenderer
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FillTabBackgrounds | Internal. See IDockingRenderer
FillVerticalTabBackground | Internal. See IDockingRenderer
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetTabPageSpace | Internal. See IDockingRenderer
GetType (inherited from Object) | Gets the Type of the current instance.
PaintCaption | Internal. See IDockingRenderer
PaintCaptionButton | Internal. See IDockingRenderer
PaintSizeBar | Internal. See IDockingRenderer
RecalculateMultilineTabs | Internal. See IDockingRenderer
RecalculateSinglelineTabs | Internal. See IDockingRenderer
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Renderers.OfficeXP Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers.OfficeXP.DrawAutoHidePanel Method

Internal. See IDockingRenderer

[Visual Basic]
NotOverridable Public Sub DrawAutoHidePanel( _
ByVal item As AutoHidePanel, _
ByVal g As Graphics _
) Implements _
IDockingRenderer.DrawAutoHidePanel
[C#]
public void DrawAutoHidePanel(
AutoHidePanel item,
Graphics g
);

Parameters

item
g

Implements

IDockingRenderer.DrawAutoHidePanel

See Also

Renderers.OfficeXP Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers.OfficeXP.DrawTab Method

Internal. See IDockingRenderer

[Visual Basic]
NotOverridable Public Sub DrawTab( _
ByVal ctl As TabControl, _
ByVal page As TabPage, _
ByVal g As Graphics, _
ByVal highlightText As Boolean, _
ByVal tabRects As ArrayList, _
ByVal imageGapTopExtra As Integer, _
ByVal selectedTextOnly As Boolean, _
ByVal dimUnselected As Boolean, _
ByVal boldSelected As Boolean, _
ByVal appearance As TabPosition, _
ByVal multiline As Boolean, _
ByVal positionAtTop As Boolean _
) Implements _
IDockingRenderer.DrawTab
[C#]
public void DrawTab(
TabControl ctl,
TabPage page,
Graphics g,
bool highlightText,
ArrayList tabRects,
int imageGapTopExtra,
bool selectedTextOnly,
bool dimUnselected,
bool boldSelected,
TabPosition appearance,
bool multiline,
bool positionAtTop
);

Parameters

ctl
page
g
highlightText
tabRects
imageGapTopExtra
selectedTextOnly
dimUnselected
boldSelected
appearance
multiline
positionAtTop

Implements

IDockingRenderer.DrawTab

See Also

Renderers.OfficeXP Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers.OfficeXP.DrawTabBorders Method

Internal. See IDockingRenderer

[Visual Basic]
NotOverridable Public Sub DrawTabBorders( _
ByVal ctl As TabControl, _
ByVal g As Graphics, _
ByVal positionAtTop As Boolean, _
ByVal tabsAreaRect As Rectangle, _
ByVal pixelBorder As Boolean, _
ByVal pixelArea As Boolean, _
ByVal hiddenPages As Boolean _
) Implements _
IDockingRenderer.DrawTabBorders
[C#]
public void DrawTabBorders(
TabControl ctl,
Graphics g,
bool positionAtTop,
Rectangle tabsAreaRect,
bool pixelBorder,
bool pixelArea,
bool hiddenPages
);

Parameters

ctl
g
positionAtTop
tabsAreaRect
pixelBorder
pixelArea
hiddenPages

Implements

IDockingRenderer.DrawTabBorders

See Also

Renderers.OfficeXP Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers.OfficeXP.DrawVerticalTabBorder Method

Internal. See IDockingRenderer

[Visual Basic]
NotOverridable Public Sub DrawVerticalTabBorder( _
ByVal item As VerticalTab, _
ByVal g As Graphics, _
ByVal edge As Edge, _
ByVal drawTabs As ArrayList, _
ByVal selectedIndex As Integer _
) Implements _
IDockingRenderer.DrawVerticalTabBorder
[C#]
public void DrawVerticalTabBorder(
VerticalTab item,
Graphics g,
Edge edge,
ArrayList drawTabs,
int selectedIndex
);

Parameters

item
g
edge
drawTabs
selectedIndex

Implements

IDockingRenderer.DrawVerticalTabBorder

See Also

Renderers.OfficeXP Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers.OfficeXP.DrawVerticalTabOutline Method

Internal. See IDockingRenderer

[Visual Basic]
NotOverridable Public Sub DrawVerticalTabOutline( _
ByVal item As VerticalTab, _
ByVal g As Graphics, _
ByVal pre As Boolean, _
ByVal edge As Edge _
) Implements _
IDockingRenderer.DrawVerticalTabOutline
[C#]
public void DrawVerticalTabOutline(
VerticalTab item,
Graphics g,
bool pre,
Edge edge
);

Parameters

item
g
pre
edge

Implements

IDockingRenderer.DrawVerticalTabOutline

See Also

Renderers.OfficeXP Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers.OfficeXP.FillTabBackgrounds Method

Internal. See IDockingRenderer

[Visual Basic]
NotOverridable Public Sub FillTabBackgrounds( _
ByVal ctl As TabControl, _
ByVal g As Graphics, _
ByVal pageAreaRect As Rectangle, _
ByVal tabsAreaRect As Rectangle, _
ByVal appearance As TabPosition _
) Implements _
IDockingRenderer.FillTabBackgrounds
[C#]
public void FillTabBackgrounds(
TabControl ctl,
Graphics g,
Rectangle pageAreaRect,
Rectangle tabsAreaRect,
TabPosition appearance
);

Parameters

ctl
g
pageAreaRect
tabsAreaRect
appearance

Implements

IDockingRenderer.FillTabBackgrounds

See Also

Renderers.OfficeXP Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers.OfficeXP.FillVerticalTabBackground Method

Internal. See IDockingRenderer

[Visual Basic]
NotOverridable Public Sub FillVerticalTabBackground( _
ByVal item As VerticalTab, _
ByVal g As Graphics _
) Implements _
IDockingRenderer.FillVerticalTabBackground
[C#]
public void FillVerticalTabBackground(
VerticalTab item,
Graphics g
);

Parameters

item
g

Implements

IDockingRenderer.FillVerticalTabBackground

See Also

Renderers.OfficeXP Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers.OfficeXP.GetTabPageSpace Method

Internal. See IDockingRenderer

[Visual Basic]
NotOverridable Public Function GetTabPageSpace( _
ByVal g As Graphics, _
ByVal page As TabPage, _
ByVal selectedTextOnly As Boolean, _
ByVal pageSelected As Integer, _
ByVal ctl As TabControl, _
ByVal boldSelected As Boolean _
) As Integer Implements _
IDockingRenderer.GetTabPageSpace
[C#]
public int GetTabPageSpace(
Graphics g,
TabPage page,
bool selectedTextOnly,
int pageSelected,
TabControl ctl,
bool boldSelected
);

Parameters

g
page
selectedTextOnly
pageSelected
ctl
boldSelected

Return Value

Implements

IDockingRenderer.GetTabPageSpace

See Also

Renderers.OfficeXP Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers.OfficeXP.PaintCaption Method

Internal. See IDockingRenderer

[Visual Basic]
NotOverridable Public Sub PaintCaption( _
ByVal g As Graphics, _
ByVal item As DockFrameCaption, _
ByVal rectCaption As Rectangle, _
ByVal focused As Boolean _
) Implements _
IDockingRenderer.PaintCaption
[C#]
public void PaintCaption(
Graphics g,
DockFrameCaption item,
Rectangle rectCaption,
bool focused
);

Parameters

g
item
rectCaption
focused

Implements

IDockingRenderer.PaintCaption

See Also

Renderers.OfficeXP Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers.OfficeXP.PaintCaptionButton Method

Internal. See IDockingRenderer

[Visual Basic]
NotOverridable Public Sub PaintCaptionButton( _
ByVal g As Graphics, _
ByVal item As CaptionButton, _
ByVal active As Boolean, _
ByVal function As ButtonFunction, _
ByVal mouseOver As Boolean, _
ByVal mouseCapture As Boolean, _
ByVal popupStyle As Boolean _
) Implements _
IDockingRenderer.PaintCaptionButton
[C#]
public void PaintCaptionButton(
Graphics g,
CaptionButton item,
bool active,
ButtonFunction function,
bool mouseOver,
bool mouseCapture,
bool popupStyle
);

Parameters

g
item
active
function
mouseOver
mouseCapture
popupStyle

Implements

IDockingRenderer.PaintCaptionButton

See Also

Renderers.OfficeXP Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers.OfficeXP.PaintSizeBar Method

Internal. See IDockingRenderer

[Visual Basic]
NotOverridable Public Sub PaintSizeBar( _
ByVal g As Graphics, _
ByVal item As SizeBar, _
ByVal dock As DockStyle _
) Implements _
IDockingRenderer.PaintSizeBar
[C#]
public void PaintSizeBar(
Graphics g,
SizeBar item,
DockStyle dock
);

Parameters

g
item
dock

Implements

IDockingRenderer.PaintSizeBar

See Also

Renderers.OfficeXP Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers.OfficeXP.RecalculateMultilineTabs Method

Internal. See IDockingRenderer

[Visual Basic]
NotOverridable Public Sub RecalculateMultilineTabs( _
ByVal ctl As TabControl, _
ByVal xStartPos As Integer, _
ByVal xEndPos As Integer, _
ByVal tabPosition As Rectangle, _
ByVal tabButtonHeight As Integer, _
ByVal appearance As TabPosition, _
ByRef topYPos As Integer, _
ByRef bottomYPos As Integer, _
ByRef tabsAreaRect As Rectangle, _
ByRef pageAreaRect As Rectangle, _
ByVal positionAtTop As Boolean, _
ByVal pageSelected As Integer, _
ByVal multilineFullWidth As Boolean, _
ByRef tabRects As ArrayList, _
ByVal selectedTextOnly As Boolean, _
ByVal boldSelected As Boolean _
) Implements _
IDockingRenderer.RecalculateMultilineTabs
[C#]
public void RecalculateMultilineTabs(
TabControl ctl,
int xStartPos,
int xEndPos,
Rectangle tabPosition,
int tabButtonHeight,
TabPosition appearance,
ref int topYPos,
ref int bottomYPos,
ref Rectangle tabsAreaRect,
ref Rectangle pageAreaRect,
bool positionAtTop,
int pageSelected,
bool multilineFullWidth,
ref ArrayList tabRects,
bool selectedTextOnly,
bool boldSelected
);

Parameters

ctl
xStartPos
xEndPos
tabPosition
tabButtonHeight
appearance
topYPos
bottomYPos
tabsAreaRect
pageAreaRect
positionAtTop
pageSelected
multilineFullWidth
tabRects
selectedTextOnly
boldSelected

Implements

IDockingRenderer.RecalculateMultilineTabs

See Also

Renderers.OfficeXP Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers.OfficeXP.RecalculateSinglelineTabs Method

Internal. See IDockingRenderer

[Visual Basic]
NotOverridable Public Sub RecalculateSinglelineTabs( _
ByVal ctl As TabControl, _
ByVal xStartPos As Integer, _
ByVal xWidth As Integer, _
ByVal tabPosition As Rectangle, _
ByRef topYPos As Integer, _
ByRef bottomYPos As Integer, _
ByVal positionAtTop As Boolean, _
ByVal pageSelected As Integer, _
ByRef tabRects As ArrayList, _
ByVal selectedTextOnly As Boolean, _
ByVal boldSelected As Boolean, _
ByVal startPage As Integer, _
ByVal shrinkPagesToFit As Boolean _
) Implements _
IDockingRenderer.RecalculateSinglelineTabs
[C#]
public void RecalculateSinglelineTabs(
TabControl ctl,
int xStartPos,
int xWidth,
Rectangle tabPosition,
ref int topYPos,
ref int bottomYPos,
bool positionAtTop,
int pageSelected,
ref ArrayList tabRects,
bool selectedTextOnly,
bool boldSelected,
int startPage,
bool shrinkPagesToFit
);

Parameters

ctl
xStartPos
xWidth
tabPosition
topYPos
bottomYPos
positionAtTop
pageSelected
tabRects
selectedTextOnly
boldSelected
startPage
shrinkPagesToFit

Implements

IDockingRenderer.RecalculateSinglelineTabs

See Also

Renderers.OfficeXP Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers.WindowsDefault Class

Windows Default style.

For a list of all members of this type, see Renderers.WindowsDefault Members.

System.Object
Renderers.WindowsDefault

[Visual Basic]
Public Class Renderers.WindowsDefault
Implements NETXP.Controls.Docking.IDockingRenderer
[C#]
public class Renderers.WindowsDefault : IDockingRenderer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

Renderers.WindowsDefault Members | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers.WindowsDefault Members

Renderers.WindowsDefault overview

Public Instance Constructors

Renderers.WindowsDefault Constructor Initializes a new instance of the WindowsDefault class.

Public Instance Methods

DrawAutoHidePanel | Internal. See IDockingRenderer
DrawTab | Internal. See IDockingRenderer
DrawTabBorders | Internal. See IDockingRenderer
DrawVerticalTabBorder | Internal. See IDockingRenderer
DrawVerticalTabOutline | Internal. See IDockingRenderer
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FillTabBackgrounds | Internal. See IDockingRenderer
FillVerticalTabBackground | Internal. See IDockingRenderer
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetTabPageSpace | Internal. See IDockingRenderer
GetType (inherited from Object) | Gets the Type of the current instance.
PaintCaption | Internal. See IDockingRenderer
PaintCaptionButton | Internal. See IDockingRenderer
PaintSizeBar | Internal. See IDockingRenderer
RecalculateMultilineTabs | Internal. See IDockingRenderer
RecalculateSinglelineTabs | Internal. See IDockingRenderer
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Renderers.WindowsDefault Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers.WindowsDefault Constructor

Initializes a new instance of the WindowsDefault class.

[Visual Basic]
Public Sub New()
[C#]
public Renderers.WindowsDefault();

See Also

Renderers.WindowsDefault Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers.WindowsDefault Methods

The methods of the Renderers.WindowsDefault class are listed below. For a complete list of Renderers.WindowsDefault class members, see the Renderers.WindowsDefault Members topic.

Public Instance Methods

DrawAutoHidePanel | Internal. See IDockingRenderer
DrawTab | Internal. See IDockingRenderer
DrawTabBorders | Internal. See IDockingRenderer
DrawVerticalTabBorder | Internal. See IDockingRenderer
DrawVerticalTabOutline | Internal. See IDockingRenderer
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FillTabBackgrounds | Internal. See IDockingRenderer
FillVerticalTabBackground | Internal. See IDockingRenderer
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetTabPageSpace | Internal. See IDockingRenderer
GetType (inherited from Object) | Gets the Type of the current instance.
PaintCaption | Internal. See IDockingRenderer
PaintCaptionButton | Internal. See IDockingRenderer
PaintSizeBar | Internal. See IDockingRenderer
RecalculateMultilineTabs | Internal. See IDockingRenderer
RecalculateSinglelineTabs | Internal. See IDockingRenderer
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Renderers.WindowsDefault Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers.WindowsDefault.DrawAutoHidePanel Method

Internal. See IDockingRenderer

[Visual Basic]
NotOverridable Public Sub DrawAutoHidePanel( _
ByVal item As AutoHidePanel, _
ByVal g As Graphics _
) Implements _
IDockingRenderer.DrawAutoHidePanel
[C#]
public void DrawAutoHidePanel(
AutoHidePanel item,
Graphics g
);

Parameters

item
g

Implements

IDockingRenderer.DrawAutoHidePanel

See Also

Renderers.WindowsDefault Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers.WindowsDefault.DrawTab Method

Internal. See IDockingRenderer

[Visual Basic]
NotOverridable Public Sub DrawTab( _
ByVal ctl As TabControl, _
ByVal page As TabPage, _
ByVal g As Graphics, _
ByVal highlightText As Boolean, _
ByVal tabRects As ArrayList, _
ByVal imageGapTopExtra As Integer, _
ByVal selectedTextOnly As Boolean, _
ByVal dimUnselected As Boolean, _
ByVal boldSelected As Boolean, _
ByVal appearance As TabPosition, _
ByVal multiline As Boolean, _
ByVal positionAtTop As Boolean _
) Implements _
IDockingRenderer.DrawTab
[C#]
public void DrawTab(
TabControl ctl,
TabPage page,
Graphics g,
bool highlightText,
ArrayList tabRects,
int imageGapTopExtra,
bool selectedTextOnly,
bool dimUnselected,
bool boldSelected,
TabPosition appearance,
bool multiline,
bool positionAtTop
);

Parameters

ctl
page
g
highlightText
tabRects
imageGapTopExtra
selectedTextOnly
dimUnselected
boldSelected
appearance
multiline
positionAtTop

Implements

IDockingRenderer.DrawTab

See Also

Renderers.WindowsDefault Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers.WindowsDefault.DrawTabBorders Method

Internal. See IDockingRenderer

[Visual Basic]
NotOverridable Public Sub DrawTabBorders( _
ByVal ctl As TabControl, _
ByVal g As Graphics, _
ByVal positionAtTop As Boolean, _
ByVal tabsAreaRect As Rectangle, _
ByVal pixelBorder As Boolean, _
ByVal pixelArea As Boolean, _
ByVal hiddenPages As Boolean _
) Implements _
IDockingRenderer.DrawTabBorders
[C#]
public void DrawTabBorders(
TabControl ctl,
Graphics g,
bool positionAtTop,
Rectangle tabsAreaRect,
bool pixelBorder,
bool pixelArea,
bool hiddenPages
);

Parameters

ctl
g
positionAtTop
tabsAreaRect
pixelBorder
pixelArea
hiddenPages

Implements

IDockingRenderer.DrawTabBorders

See Also

Renderers.WindowsDefault Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers.WindowsDefault.DrawVerticalTabBorder Method

Internal. See IDockingRenderer

[Visual Basic]
NotOverridable Public Sub DrawVerticalTabBorder( _
ByVal item As VerticalTab, _
ByVal g As Graphics, _
ByVal edge As Edge, _
ByVal drawTabs As ArrayList, _
ByVal selectedIndex As Integer _
) Implements _
IDockingRenderer.DrawVerticalTabBorder
[C#]
public void DrawVerticalTabBorder(
VerticalTab item,
Graphics g,
Edge edge,
ArrayList drawTabs,
int selectedIndex
);

Parameters

item
g
edge
drawTabs
selectedIndex

Implements

IDockingRenderer.DrawVerticalTabBorder

See Also

Renderers.WindowsDefault Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers.WindowsDefault.DrawVerticalTabOutline Method

Internal. See IDockingRenderer

[Visual Basic]
NotOverridable Public Sub DrawVerticalTabOutline( _
ByVal item As VerticalTab, _
ByVal g As Graphics, _
ByVal pre As Boolean, _
ByVal edge As Edge _
) Implements _
IDockingRenderer.DrawVerticalTabOutline
[C#]
public void DrawVerticalTabOutline(
VerticalTab item,
Graphics g,
bool pre,
Edge edge
);

Parameters

item
g
pre
edge

Implements

IDockingRenderer.DrawVerticalTabOutline

See Also

Renderers.WindowsDefault Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers.WindowsDefault.FillTabBackgrounds Method

Internal. See IDockingRenderer

[Visual Basic]
NotOverridable Public Sub FillTabBackgrounds( _
ByVal ctl As TabControl, _
ByVal g As Graphics, _
ByVal pageAreaRect As Rectangle, _
ByVal tabsAreaRect As Rectangle, _
ByVal appearance As TabPosition _
) Implements _
IDockingRenderer.FillTabBackgrounds
[C#]
public void FillTabBackgrounds(
TabControl ctl,
Graphics g,
Rectangle pageAreaRect,
Rectangle tabsAreaRect,
TabPosition appearance
);

Parameters

ctl
g
pageAreaRect
tabsAreaRect
appearance

Implements

IDockingRenderer.FillTabBackgrounds

See Also

Renderers.WindowsDefault Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers.WindowsDefault.FillVerticalTabBackground Method

Internal. See IDockingRenderer

[Visual Basic]
NotOverridable Public Sub FillVerticalTabBackground( _
ByVal item As VerticalTab, _
ByVal g As Graphics _
) Implements _
IDockingRenderer.FillVerticalTabBackground
[C#]
public void FillVerticalTabBackground(
VerticalTab item,
Graphics g
);

Parameters

item
g

Implements

IDockingRenderer.FillVerticalTabBackground

See Also

Renderers.WindowsDefault Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers.WindowsDefault.GetTabPageSpace Method

Internal. See IDockingRenderer

[Visual Basic]
NotOverridable Public Function GetTabPageSpace( _
ByVal g As Graphics, _
ByVal page As TabPage, _
ByVal selectedTextOnly As Boolean, _
ByVal pageSelected As Integer, _
ByVal ctl As TabControl, _
ByVal boldSelected As Boolean _
) As Integer Implements _
IDockingRenderer.GetTabPageSpace
[C#]
public int GetTabPageSpace(
Graphics g,
TabPage page,
bool selectedTextOnly,
int pageSelected,
TabControl ctl,
bool boldSelected
);

Parameters

g
page
selectedTextOnly
pageSelected
ctl
boldSelected

Return Value

Implements

IDockingRenderer.GetTabPageSpace

See Also

Renderers.WindowsDefault Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers.WindowsDefault.PaintCaption Method

Internal. See IDockingRenderer

[Visual Basic]
NotOverridable Public Sub PaintCaption( _
ByVal g As Graphics, _
ByVal item As DockFrameCaption, _
ByVal rectCaption As Rectangle, _
ByVal focused As Boolean _
) Implements _
IDockingRenderer.PaintCaption
[C#]
public void PaintCaption(
Graphics g,
DockFrameCaption item,
Rectangle rectCaption,
bool focused
);

Parameters

g
item
rectCaption
focused

Implements

IDockingRenderer.PaintCaption

See Also

Renderers.WindowsDefault Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers.WindowsDefault.PaintCaptionButton Method

Internal. See IDockingRenderer

[Visual Basic]
NotOverridable Public Sub PaintCaptionButton( _
ByVal g As Graphics, _
ByVal item As CaptionButton, _
ByVal active As Boolean, _
ByVal function As ButtonFunction, _
ByVal mouseOver As Boolean, _
ByVal mouseCapture As Boolean, _
ByVal popupStyle As Boolean _
) Implements _
IDockingRenderer.PaintCaptionButton
[C#]
public void PaintCaptionButton(
Graphics g,
CaptionButton item,
bool active,
ButtonFunction function,
bool mouseOver,
bool mouseCapture,
bool popupStyle
);

Parameters

g
item
active
function
mouseOver
mouseCapture
popupStyle

Implements

IDockingRenderer.PaintCaptionButton

See Also

Renderers.WindowsDefault Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers.WindowsDefault.PaintSizeBar Method

Internal. See IDockingRenderer

[Visual Basic]
NotOverridable Public Sub PaintSizeBar( _
ByVal g As Graphics, _
ByVal item As SizeBar, _
ByVal dock As DockStyle _
) Implements _
IDockingRenderer.PaintSizeBar
[C#]
public void PaintSizeBar(
Graphics g,
SizeBar item,
DockStyle dock
);

Parameters

g
item
dock

Implements

IDockingRenderer.PaintSizeBar

See Also

Renderers.WindowsDefault Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers.WindowsDefault.RecalculateMultilineTabs Method

Internal. See IDockingRenderer

[Visual Basic]
NotOverridable Public Sub RecalculateMultilineTabs( _
ByVal ctl As TabControl, _
ByVal xStartPos As Integer, _
ByVal xEndPos As Integer, _
ByVal tabPosition As Rectangle, _
ByVal tabButtonHeight As Integer, _
ByVal appearance As TabPosition, _
ByRef topYPos As Integer, _
ByRef bottomYPos As Integer, _
ByRef tabsAreaRect As Rectangle, _
ByRef pageAreaRect As Rectangle, _
ByVal positionAtTop As Boolean, _
ByVal pageSelected As Integer, _
ByVal multilineFullWidth As Boolean, _
ByRef tabRects As ArrayList, _
ByVal selectedTextOnly As Boolean, _
ByVal boldSelected As Boolean _
) Implements _
IDockingRenderer.RecalculateMultilineTabs
[C#]
public void RecalculateMultilineTabs(
TabControl ctl,
int xStartPos,
int xEndPos,
Rectangle tabPosition,
int tabButtonHeight,
TabPosition appearance,
ref int topYPos,
ref int bottomYPos,
ref Rectangle tabsAreaRect,
ref Rectangle pageAreaRect,
bool positionAtTop,
int pageSelected,
bool multilineFullWidth,
ref ArrayList tabRects,
bool selectedTextOnly,
bool boldSelected
);

Parameters

ctl
xStartPos
xEndPos
tabPosition
tabButtonHeight
appearance
topYPos
bottomYPos
tabsAreaRect
pageAreaRect
positionAtTop
pageSelected
multilineFullWidth
tabRects
selectedTextOnly
boldSelected

Implements

IDockingRenderer.RecalculateMultilineTabs

See Also

Renderers.WindowsDefault Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Renderers.WindowsDefault.RecalculateSinglelineTabs Method

Internal. See IDockingRenderer

[Visual Basic]
NotOverridable Public Sub RecalculateSinglelineTabs( _
ByVal ctl As TabControl, _
ByVal xStartPos As Integer, _
ByVal xWidth As Integer, _
ByVal tabPosition As Rectangle, _
ByRef topYPos As Integer, _
ByRef bottomYPos As Integer, _
ByVal positionAtTop As Boolean, _
ByVal pageSelected As Integer, _
ByRef tabRects As ArrayList, _
ByVal selectedTextOnly As Boolean, _
ByVal boldSelected As Boolean, _
ByVal startPage As Integer, _
ByVal shrinkPagesToFit As Boolean _
) Implements _
IDockingRenderer.RecalculateSinglelineTabs
[C#]
public void RecalculateSinglelineTabs(
TabControl ctl,
int xStartPos,
int xWidth,
Rectangle tabPosition,
ref int topYPos,
ref int bottomYPos,
bool positionAtTop,
int pageSelected,
ref ArrayList tabRects,
bool selectedTextOnly,
bool boldSelected,
int startPage,
bool shrinkPagesToFit
);

Parameters

ctl
xStartPos
xWidth
tabPosition
topYPos
bottomYPos
positionAtTop
pageSelected
tabRects
selectedTextOnly
boldSelected
startPage
shrinkPagesToFit

Implements

IDockingRenderer.RecalculateSinglelineTabs

See Also

Renderers.WindowsDefault Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Restore Class

Internal.

For a list of all members of this type, see Restore Members.

System.Object
Restore

[Visual Basic]
Public Class Restore
[C#]
public class Restore

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

Restore Members | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Restore Members

Restore overview

Public Static (Shared) Methods

CreateFromXml Internal.

Public Instance Constructors

Restore Overloaded. Initializes a new instance of the Restore class.

Public Instance Properties

Child Internal.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadFromXml | Internal.
LoadInternalFromXml | Internal.
PerformRestore | Overloaded. Internal.
Reconnect | Internal.
SaveInternalToXml | Internal.
SaveToXml | Internal.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Restore Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Restore Constructor

Internal.

Overload List

Internal.

public Restore();

Internal.

public Restore(Restore);

See Also

Restore Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Restore Constructor ()

Internal.

[Visual Basic]
Overloads Public Sub New()
[C#]
public Restore();

See Also

Restore Class | NETXP.Controls.Docking Namespace | Restore Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Restore Constructor (Restore)

Internal.

[Visual Basic]
Overloads Public Sub New( _
ByVal child As Restore _
)
[C#]
public Restore(
Restore child
);

Parameters

child

See Also

Restore Class | NETXP.Controls.Docking Namespace | Restore Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Restore Properties

The properties of the Restore class are listed below. For a complete list of Restore class members, see the Restore Members topic.

Public Instance Properties

Child Internal.

See Also

Restore Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Restore.Child Property

Internal.

[Visual Basic]
Public Property Child As Restore
[C#]
public Restore Child {get; set;}

See Also

Restore Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Restore Methods

The methods of the Restore class are listed below. For a complete list of Restore class members, see the Restore Members topic.

Public Static (Shared) Methods

CreateFromXml Internal.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadFromXml | Internal.
LoadInternalFromXml | Internal.
PerformRestore | Overloaded. Internal.
Reconnect | Internal.
SaveInternalToXml | Internal.
SaveToXml | Internal.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Restore Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Restore.CreateFromXml Method

Internal.

[Visual Basic]
Public Shared Function CreateFromXml( _
ByVal xmlIn As XmlTextReader, _
ByVal readIn As Boolean, _
ByVal formatVersion As Integer _
) As Restore
[C#]
public static Restore CreateFromXml(
XmlTextReader xmlIn,
bool readIn,
int formatVersion
);

Parameters

xmlIn
readIn
formatVersion

Return Value

See Also

Restore Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Restore.LoadFromXml Method

Internal.

[Visual Basic]
Overridable Public Sub LoadFromXml( _
ByVal xmlIn As XmlTextReader, _
ByVal formatVersion As Integer _
)
[C#]
public virtual void LoadFromXml(
XmlTextReader xmlIn,
int formatVersion
);

Parameters

xmlIn
formatVersion

See Also

Restore Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Restore.LoadInternalFromXml Method

Internal.

[Visual Basic]
Overridable Public Sub LoadInternalFromXml( _
ByVal xmlIn As XmlTextReader, _
ByVal formatVersion As Integer _
)
[C#]
public virtual void LoadInternalFromXml(
XmlTextReader xmlIn,
int formatVersion
);

Parameters

xmlIn
formatVersion

See Also

Restore Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


PerformRestore Method

NetXP 3.0 Reference

Restore.PerformRestore Method

Internal.

Overload List

Internal.

public virtual void PerformRestore();

Internal.

public virtual void PerformRestore(DockingManager);

Internal.

public virtual void PerformRestore(DockRegion);

Internal.

public virtual void PerformRestore(Window);

See Also

Restore Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Restore.PerformRestore Method ()

Internal.

[Visual Basic]
Overridable Overloads Public Sub PerformRestore()
[C#]
public virtual void PerformRestore();

See Also

Restore Class | NETXP.Controls.Docking Namespace | Restore.PerformRestore Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Restore.PerformRestore Method (DockingManager)

Internal.

[Visual Basic]
Overridable Overloads Public Sub PerformRestore( _
ByVal dm As DockingManager _
)
[C#]
public virtual void PerformRestore(
DockingManager dm
);

Parameters

dm

See Also

Restore Class | NETXP.Controls.Docking Namespace | Restore.PerformRestore Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Restore.PerformRestore Method (DockRegion)

Internal.

[Visual Basic]
Overridable Overloads Public Sub PerformRestore( _
ByVal z As DockRegion _
)
[C#]
public virtual void PerformRestore(
DockRegion z
);

Parameters

z

See Also

Restore Class | NETXP.Controls.Docking Namespace | Restore.PerformRestore Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Restore.PerformRestore Method (Window)

Internal.

[Visual Basic]
Overridable Overloads Public Sub PerformRestore( _
ByVal w As Window _
)
[C#]
public virtual void PerformRestore(
Window w
);

Parameters

w

See Also

Restore Class | NETXP.Controls.Docking Namespace | Restore.PerformRestore Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Restore.Reconnect Method

Internal.

[Visual Basic]
Overridable Public Sub Reconnect( _
ByVal dm As DockingManager _
)
[C#]
public virtual void Reconnect(
DockingManager dm
);

Parameters

dm

See Also

Restore Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Restore.SaveInternalToXml Method

Internal.

[Visual Basic]
Overridable Public Sub SaveInternalToXml( _
ByVal xmlOut As XmlTextWriter _
)
[C#]
public virtual void SaveInternalToXml(
XmlTextWriter xmlOut
);

Parameters

xmlOut

See Also

Restore Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Restore.SaveToXml Method

Internal.

[Visual Basic]
Overridable Public Sub SaveToXml( _
ByVal xmlOut As XmlTextWriter _
)
[C#]
public virtual void SaveToXml(
XmlTextWriter xmlOut
);

Parameters

xmlOut

See Also

Restore Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


SaveCustomConfigHandler Delegate

Custom configuration about to be saved.

[Visual Basic]
Public Delegate Sub SaveCustomConfigHandler( _
ByVal xmlOut As XmlTextWriter _
)
[C#]
public delegate void SaveCustomConfigHandler(
XmlTextWriter xmlOut
);

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


SizeBar Class

Internal control.

For a list of all members of this type, see SizeBar Members.

System.Object
MarshalByRefObject
Component
Control
SizeBar

[Visual Basic]
Public Class SizeBar
Inherits Control
[C#]
public class SizeBar : Control

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

SizeBar Members | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


SizeBar Members

SizeBar overview

Public Instance Constructors

SizeBar Constructor Internal. Constructs a SizeBar.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
Direction | Gets or sets the direction of the bar.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Length | Gets or sets the length of the bar.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Renderer | Gets or sets the renderer used to draw the bar.
ResizeSource | Gets or sets the resize source of the bar.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
UpdateNameValue | Internal.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

SizeBar Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


SizeBar Constructor

Internal. Constructs a SizeBar.

[Visual Basic]
Public Sub New( _
ByVal direction As Direction, _
ByVal resizeSource As IResizeSource _
)
[C#]
public SizeBar(
Direction direction,
IResizeSource resizeSource
);

Parameters

direction
resizeSource

See Also

SizeBar Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


SizeBar Properties

The properties of the SizeBar class are listed below. For a complete list of SizeBar class members, see the SizeBar Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
Direction | Gets or sets the direction of the bar.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Length | Gets or sets the length of the bar.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Renderer | Gets or sets the renderer used to draw the bar.
ResizeSource | Gets or sets the resize source of the bar.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

See Also

SizeBar Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


SizeBar.Direction Property

Gets or sets the direction of the bar.

[Visual Basic]
Public Property Direction As Direction
[C#]
public NETXP.Library.Direction Direction {get; set;}

See Also

SizeBar Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


SizeBar.Length Property

Gets or sets the length of the bar.

[Visual Basic]
Public Property Length As Integer
[C#]
public int Length {get; set;}

See Also

SizeBar Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


SizeBar.Renderer Property

Gets or sets the renderer used to draw the bar.

[Visual Basic]
Public Property Renderer As IDockingRenderer
[C#]
public IDockingRenderer Renderer {get; set;}

See Also

SizeBar Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


SizeBar.ResizeSource Property

Gets or sets the resize source of the bar.

[Visual Basic]
Public ReadOnly Property ResizeSource As IResizeSource
[C#]
public IResizeSource ResizeSource {get;}

See Also

SizeBar Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


SizeBar Methods

The methods of the SizeBar class are listed below. For a complete list of SizeBar class members, see the SizeBar Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
UpdateNameValue | Internal.

See Also

SizeBar Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


SizeBar.UpdateNameValue Method

Internal.

[Visual Basic]
Public Sub UpdateNameValue( _
ByVal name As UpdateName, _
ByVal value As Object _
)
[C#]
public void UpdateNameValue(
UpdateName name,
object value
);

Parameters

name
value

See Also

SizeBar Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


State Enumeration

The state of docked objects.

[Visual Basic]
Public Enum State
[C#]
public enum State

Members

Member Name | Description
Floating | Floating
DockTop | Docked Top
DockBottom | Docked Bottom
DockLeft | Docked Left
DockRight | Docked Right

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups Class

The TabbedGroups control offers automated support for tabbed MDI, similar to Visual Studio .NET.

For a list of all members of this type, see TabbedGroups Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
TabbedGroups

[Visual Basic]
NotInheritable Public Class TabbedGroups
Inherits UserControl
Implements System.ComponentModel.ISupportInitialize, System.Windows.Forms.IMessageFilter
[C#]
public sealed class TabbedGroups : UserControl, ISupportInitialize, IMessageFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

TabbedGroups Members | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups Members

TabbedGroups overview

Public Instance Constructors

TabbedGroups Overloaded. Initializes a new instance of the TabbedGroups class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveNode | Gets or sets the active node.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AtLeastOneNode | Always show at least one node?
AutoCalculateDirty | Auto-update the Dirty flag?
AutoCompact | Automatically compact nodes?
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CloseShortcut | Gets or sets a shortcut key.
CompactOptions | Gets or sets compact options.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultGroupMinimumHeight | Gets or sets the minimum height of the default group.
DefaultGroupMinimumWidth | Gets or sets the minimum width of the default group.
Dirty | Mark the layout as dirty? (Needs to be saved)
DisplayRectangle (inherited from ScrollableControl) |
DisplayTabMode | Gets or sets the tabbed group display mode.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
Initializing | Internal
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
LayoutLock | Should layout be locked?
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MoveNextShortcut | Gets or sets a shortcut key.
MovePreviousShortcut | Gets or sets a shortcut key.
Name (inherited from Control) | Gets or sets the name of the control.
PageCloseWhenEmpty | Close a page when empty?
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
ProportionalResizeShortcut | Gets or sets a shortcut key.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Renderer | Gets or sets the renderer for the tabbed groups.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RootSequence | Gets the main tab group sequence.
SaveControls | Save the names of contained controls?
SelectedNode | Gets or sets the selected node.
SelectedShortcut | Gets or sets a shortcut key.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeBarLock | Should all size bars be locked?
SizeBarWidth | Gets or sets the width of the size bar.
SplitHorizontalShortcut | Gets or sets a shortcut key.
SplitVerticalShortcut | Gets or sets a shortcut key.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInit | Internal
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Compact | Overloaded. Compacts nodes.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInit | Internal
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
FirstNode | Finds the first node.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
LastNode | Finds the last node.
LoadConfigFromArray | Loads layout from binary.
LoadConfigFromFile | Loads layout from file.
LoadConfigFromStream | Loads layout from stream.
NextNode | Finds the next node.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreFilterMessage | Internal
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
PreviousNode | Finds the previous node.
ProportionalResize | Overloaded. Resizes all nodes proportionally.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
SaveConfigToArray | Overloaded. Saves layout to binary format.
SaveConfigToFile | Overloaded. Saves layout to file.
SaveConfigToStream | Saves layout to stream.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

ActiveNodeChanged | Raised when the active tabbed node has changed.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
DirtyChanged | Raised when the Dirty property has changed.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
ExternalDrop | Raised when an external drag source has been dropped onto a node.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GlobalLoading | Raised when global layout is being loaded.
GlobalSaving | Raised when global layout is being saved.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PageCloseRequest | Raised when a page is about to be closed.
PageContextMenu | Raised when a page's context menu is shown.
PageLoading | Raised when page layout is being loaded.
PageSaving | Raised when page layout is being saved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SelectedNodeChanged | Raised when the selected tabbed node is changed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabControlCreated | Raised when the tab control is created.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups Constructor

Constructs a new TabbedGroups control.

Overload List

Constructs a new TabbedGroups control.

public TabbedGroups();

Constructs a new TabbedGroups control with the specified renderer.

public TabbedGroups(IDockingRenderer);

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups Constructor ()

Constructs a new TabbedGroups control.

[Visual Basic]
Overloads Public Sub New()
[C#]
public TabbedGroups();

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace | TabbedGroups Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups Constructor (IDockingRenderer)

Constructs a new TabbedGroups control with the specified renderer.

[Visual Basic]
Overloads Public Sub New( _
ByVal renderer As IDockingRenderer _
)
[C#]
public TabbedGroups(
IDockingRenderer renderer
);

Parameters

renderer
The renderer to use.

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace | TabbedGroups Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups Properties

The properties of the TabbedGroups class are listed below. For a complete list of TabbedGroups class members, see the TabbedGroups Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveNode | Gets or sets the active node.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AtLeastOneNode | Always show at least one node?
AutoCalculateDirty | Auto-update the Dirty flag?
AutoCompact | Automatically compact nodes?
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CloseShortcut | Gets or sets a shortcut key.
CompactOptions | Gets or sets compact options.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultGroupMinimumHeight | Gets or sets the minimum height of the default group.
DefaultGroupMinimumWidth | Gets or sets the minimum width of the default group.
Dirty | Mark the layout as dirty? (Needs to be saved)
DisplayRectangle (inherited from ScrollableControl) |
DisplayTabMode | Gets or sets the tabbed group display mode.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
Initializing | Internal
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
LayoutLock | Should layout be locked?
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MoveNextShortcut | Gets or sets a shortcut key.
MovePreviousShortcut | Gets or sets a shortcut key.
Name (inherited from Control) | Gets or sets the name of the control.
PageCloseWhenEmpty | Close a page when empty?
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
ProportionalResizeShortcut | Gets or sets a shortcut key.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Renderer | Gets or sets the renderer for the tabbed groups.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RootSequence | Gets the main tab group sequence.
SaveControls | Save the names of contained controls?
SelectedNode | Gets or sets the selected node.
SelectedShortcut | Gets or sets a shortcut key.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeBarLock | Should all size bars be locked?
SizeBarWidth | Gets or sets the width of the size bar.
SplitHorizontalShortcut | Gets or sets a shortcut key.
SplitVerticalShortcut | Gets or sets a shortcut key.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.ActiveNode Property

Gets or sets the active node.

[Visual Basic]
Public Property ActiveNode As TabGroupNode
[C#]
public TabGroupNode ActiveNode {get; set;}

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.AtLeastOneNode Property

Always show at least one node?

[Visual Basic]
Public Property AtLeastOneNode As Boolean
[C#]
public bool AtLeastOneNode {get; set;}

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.AutoCalculateDirty Property

Auto-update the Dirty flag?

[Visual Basic]
Public Property AutoCalculateDirty As Boolean
[C#]
public bool AutoCalculateDirty {get; set;}

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.AutoCompact Property

Automatically compact nodes?

[Visual Basic]
Public Property AutoCompact As Boolean
[C#]
public bool AutoCompact {get; set;}

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.CloseShortcut Property

Gets or sets a shortcut key.

[Visual Basic]
Public Property CloseShortcut As Shortcut
[C#]
public System.Windows.Forms.Shortcut CloseShortcut {get; set;}

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.CompactOptions Property

Gets or sets compact options.

[Visual Basic]
Public Property CompactOptions As CompactFlags
[C#]
public TabbedGroups.CompactFlags CompactOptions {get; set;}

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.DefaultGroupMinimumHeight Property

Gets or sets the minimum height of the default group.

[Visual Basic]
Public Property DefaultGroupMinimumHeight As Integer
[C#]
public int DefaultGroupMinimumHeight {get; set;}

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.DefaultGroupMinimumWidth Property

Gets or sets the minimum width of the default group.

[Visual Basic]
Public Property DefaultGroupMinimumWidth As Integer
[C#]
public int DefaultGroupMinimumWidth {get; set;}

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.Dirty Property

Mark the layout as dirty? (Needs to be saved)

[Visual Basic]
Public Property Dirty As Boolean
[C#]
public bool Dirty {get; set;}

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.DisplayTabMode Property

Gets or sets the tabbed group display mode.

[Visual Basic]
Public Property DisplayTabMode As DisplayTabModes
[C#]
public TabbedGroups.DisplayTabModes DisplayTabMode {get; set;}

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.Initializing Property

Internal

[Visual Basic]
Public ReadOnly Property Initializing As Boolean
[C#]
public bool Initializing {get;}

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.LayoutLock Property

Should layout be locked?

[Visual Basic]
Public Property LayoutLock As Boolean
[C#]
public bool LayoutLock {get; set;}

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.MoveNextShortcut Property

Gets or sets a shortcut key.

[Visual Basic]
Public Property MoveNextShortcut As Shortcut
[C#]
public System.Windows.Forms.Shortcut MoveNextShortcut {get; set;}

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.MovePreviousShortcut Property

Gets or sets a shortcut key.

[Visual Basic]
Public Property MovePreviousShortcut As Shortcut
[C#]
public System.Windows.Forms.Shortcut MovePreviousShortcut {get; set;}

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.PageCloseWhenEmpty Property

Close a page when empty?

[Visual Basic]
Public Property PageCloseWhenEmpty As Boolean
[C#]
public bool PageCloseWhenEmpty {get; set;}

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.ProportionalResizeShortcut Property

Gets or sets a shortcut key.

[Visual Basic]
Public Property ProportionalResizeShortcut As Shortcut
[C#]
public System.Windows.Forms.Shortcut ProportionalResizeShortcut {get; set;}

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.Renderer Property

Gets or sets the renderer for the tabbed groups.

[Visual Basic]
Public Property Renderer As IDockingRenderer
[C#]
public IDockingRenderer Renderer {get; set;}

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.RootSequence Property

Gets the main tab group sequence.

[Visual Basic]
Public ReadOnly Property RootSequence As TabGroupSequence
[C#]
public TabGroupSequence RootSequence {get;}

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.SaveControls Property

Save the names of contained controls?

[Visual Basic]
Public Property SaveControls As Boolean
[C#]
public bool SaveControls {get; set;}

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.SelectedNode Property

Gets or sets the selected node.

[Visual Basic]
Public Property SelectedNode As TabGroupNode
[C#]
public TabGroupNode SelectedNode {get; set;}

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.SelectedShortcut Property

Gets or sets a shortcut key.

[Visual Basic]
Public Property SelectedShortcut As Shortcut
[C#]
public System.Windows.Forms.Shortcut SelectedShortcut {get; set;}

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.SizeBarLock Property

Should all size bars be locked?

[Visual Basic]
Public Property SizeBarLock As Boolean
[C#]
public bool SizeBarLock {get; set;}

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.SizeBarWidth Property

Gets or sets the width of the size bar.

[Visual Basic]
Public Property SizeBarWidth As Integer
[C#]
public int SizeBarWidth {get; set;}

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.SplitHorizontalShortcut Property

Gets or sets a shortcut key.

[Visual Basic]
Public Property SplitHorizontalShortcut As Shortcut
[C#]
public System.Windows.Forms.Shortcut SplitHorizontalShortcut {get; set;}

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.SplitVerticalShortcut Property

Gets or sets a shortcut key.

[Visual Basic]
Public Property SplitVerticalShortcut As Shortcut
[C#]
public System.Windows.Forms.Shortcut SplitVerticalShortcut {get; set;}

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups Methods

The methods of the TabbedGroups class are listed below. For a complete list of TabbedGroups class members, see the TabbedGroups Members topic.

Public Instance Methods

BeginInit | Internal
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Compact | Overloaded. Compacts nodes.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInit | Internal
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
FirstNode | Finds the first node.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
LastNode | Finds the last node.
LoadConfigFromArray | Loads layout from binary.
LoadConfigFromFile | Loads layout from file.
LoadConfigFromStream | Loads layout from stream.
NextNode | Finds the next node.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreFilterMessage | Internal
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
PreviousNode | Finds the previous node.
ProportionalResize | Overloaded. Resizes all nodes proportionally.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
SaveConfigToArray | Overloaded. Saves layout to binary format.
SaveConfigToFile | Overloaded. Saves layout to file.
SaveConfigToStream | Saves layout to stream.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.BeginInit Method

Internal

[Visual Basic]
NotOverridable Public Sub BeginInit() Implements _
ISupportInitialize.BeginInit
[C#]
public void BeginInit();

Implements

ISupportInitialize.BeginInit

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Compact Method

NetXP 3.0 Reference

TabbedGroups.Compact Method

Compacts nodes.

Overload List

Compacts nodes.

public void Compact();

Compacts nodes given compact flags.

public void Compact(CompactFlags);

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.Compact Method ()

Compacts nodes.

[Visual Basic]
Overloads Public Sub Compact()
[C#]
public void Compact();

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace | TabbedGroups.Compact Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.Compact Method (CompactFlags)

Compacts nodes given compact flags.

[Visual Basic]
Overloads Public Sub Compact( _
ByVal flags As CompactFlags _
)
[C#]
public void Compact(
CompactFlags flags
);

Parameters

flags
Compact flags.

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace | TabbedGroups.Compact Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.EndInit Method

Internal

[Visual Basic]
NotOverridable Public Sub EndInit() Implements _
ISupportInitialize.EndInit
[C#]
public void EndInit();

Implements

ISupportInitialize.EndInit

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.FirstNode Method

Finds the first node.

[Visual Basic]
Public Function FirstNode() As TabGroupNode
[C#]
public TabGroupNode FirstNode();

Return Value

The first node.

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.LastNode Method

Finds the last node.

[Visual Basic]
Public Function LastNode() As TabGroupNode
[C#]
public TabGroupNode LastNode();

Return Value

The last node.

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.LoadConfigFromArray Method

Loads layout from binary.

[Visual Basic]
Public Sub LoadConfigFromArray( _
ByVal buffer As Byte() _
)
[C#]
public void LoadConfigFromArray(
byte[] buffer
);

Parameters

buffer
Buffer.

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.LoadConfigFromFile Method

Loads layout from file.

[Visual Basic]
Public Sub LoadConfigFromFile( _
ByVal filename As String _
)
[C#]
public void LoadConfigFromFile(
string filename
);

Parameters

filename
File name.

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.LoadConfigFromStream Method

Loads layout from stream.

[Visual Basic]
Public Sub LoadConfigFromStream( _
ByVal stream As Stream _
)
[C#]
public void LoadConfigFromStream(
Stream stream
);

Parameters

stream
Stream.

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.NextNode Method

Finds the next node.

[Visual Basic]
Public Function NextNode( _
ByVal current As TabGroupNode _
) As TabGroupNode
[C#]
public TabGroupNode NextNode(
TabGroupNode current
);

Parameters

current
Current node.

Return Value

The next node.

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.PreFilterMessage Method

Internal

[Visual Basic]
NotOverridable Public Function PreFilterMessage( _
ByRef msg As Message _
) As Boolean Implements _
IMessageFilter.PreFilterMessage
[C#]
public bool PreFilterMessage(
ref Message msg
);

Parameters

msg

Return Value

Implements

IMessageFilter.PreFilterMessage

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.PreviousNode Method

Finds the previous node.

[Visual Basic]
Public Function PreviousNode( _
ByVal current As TabGroupNode _
) As TabGroupNode
[C#]
public TabGroupNode PreviousNode(
TabGroupNode current
);

Parameters

current
Current node.

Return Value

The previous node.

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


ProportionalResize Method

NetXP 3.0 Reference

TabbedGroups.ProportionalResize Method

Resizes all nodes proportionally.

Overload List

Resizes all nodes proportionally.

public void ProportionalResize();

Resizes all nodes proportionally, optionally recursing.

public void ProportionalResize(bool);

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.ProportionalResize Method ()

Resizes all nodes proportionally.

[Visual Basic]
Overloads Public Sub ProportionalResize()
[C#]
public void ProportionalResize();

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace | TabbedGroups.ProportionalResize Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.ProportionalResize Method (Boolean)

Resizes all nodes proportionally, optionally recursing.

[Visual Basic]
Overloads Public Sub ProportionalResize( _
ByVal recurse As Boolean _
)
[C#]
public void ProportionalResize(
bool recurse
);

Parameters

recurse
Recurse?

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace | TabbedGroups.ProportionalResize Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


SaveConfigToArray Method

NetXP 3.0 Reference

TabbedGroups.SaveConfigToArray Method

Saves layout to binary format.

Overload List

Saves layout to binary format.

public byte[] SaveConfigToArray();

Saves layout to binary format.

public byte[] SaveConfigToArray(Encoding);

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.SaveConfigToArray Method ()

Saves layout to binary format.

[Visual Basic]
Overloads Public Function SaveConfigToArray() As Byte()
[C#]
public byte[] SaveConfigToArray();

Return Value

Layout as binary.

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace | TabbedGroups.SaveConfigToArray Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.SaveConfigToArray Method (Encoding)

Saves layout to binary format.

[Visual Basic]
Overloads Public Function SaveConfigToArray( _
ByVal encoding As Encoding _
) As Byte()
[C#]
public byte[] SaveConfigToArray(
Encoding encoding
);

Parameters

encoding
Encoding.

Return Value

Layout as binary.

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace | TabbedGroups.SaveConfigToArray Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


SaveConfigToFile Method

NetXP 3.0 Reference

TabbedGroups.SaveConfigToFile Method

Saves layout to file.

Overload List

Saves layout to file.

public void SaveConfigToFile(string);

Saves layout to file.

public void SaveConfigToFile(string,Encoding);

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.SaveConfigToFile Method (String)

Saves layout to file.

[Visual Basic]
Overloads Public Sub SaveConfigToFile( _
ByVal filename As String _
)
[C#]
public void SaveConfigToFile(
string filename
);

Parameters

filename
The file.

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace | TabbedGroups.SaveConfigToFile Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.SaveConfigToFile Method (String, Encoding)

Saves layout to file.

[Visual Basic]
Overloads Public Sub SaveConfigToFile( _
ByVal filename As String, _
ByVal encoding As Encoding _
)
[C#]
public void SaveConfigToFile(
string filename,
Encoding encoding
);

Parameters

filename
File.
encoding
Encoding.

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace | TabbedGroups.SaveConfigToFile Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.SaveConfigToStream Method

Saves layout to stream.

[Visual Basic]
Public Sub SaveConfigToStream( _
ByVal stream As Stream, _
ByVal encoding As Encoding _
)
[C#]
public void SaveConfigToStream(
Stream stream,
Encoding encoding
);

Parameters

stream
Stream.
encoding
Encoding.

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups Events

The events of the TabbedGroups class are listed below. For a complete list of TabbedGroups class members, see the TabbedGroups Members topic.

Public Instance Events

ActiveNodeChanged | Raised when the active tabbed node has changed.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
DirtyChanged | Raised when the Dirty property has changed.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
ExternalDrop | Raised when an external drag source has been dropped onto a node.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GlobalLoading | Raised when global layout is being loaded.
GlobalSaving | Raised when global layout is being saved.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PageCloseRequest | Raised when a page is about to be closed.
PageContextMenu | Raised when a page's context menu is shown.
PageLoading | Raised when page layout is being loaded.
PageSaving | Raised when page layout is being saved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SelectedNodeChanged | Raised when the selected tabbed node is changed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabControlCreated | Raised when the tab control is created.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.ActiveNodeChanged Event

Raised when the active tabbed node has changed.

[Visual Basic]
Public Event ActiveNodeChanged As EventHandler
[C#]
public event EventHandler ActiveNodeChanged;

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.DirtyChanged Event

Raised when the Dirty property has changed.

[Visual Basic]
Public Event DirtyChanged As EventHandler
[C#]
public event EventHandler DirtyChanged;

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.ExternalDrop Event

Raised when an external drag source has been dropped onto a node.

[Visual Basic]
Public Event ExternalDrop As ExternalDropHandler
[C#]
public event ExternalDropHandler ExternalDrop;

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.GlobalLoading Event

Raised when global layout is being loaded.

[Visual Basic]
Public Event GlobalLoading As GlobalLoadingHandler
[C#]
public event GlobalLoadingHandler GlobalLoading;

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.GlobalSaving Event

Raised when global layout is being saved.

[Visual Basic]
Public Event GlobalSaving As GlobalSavingHandler
[C#]
public event GlobalSavingHandler GlobalSaving;

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.PageCloseRequest Event

Raised when a page is about to be closed.

[Visual Basic]
Public Event PageCloseRequest As PageCloseRequestHandler
[C#]
public event PageCloseRequestHandler PageCloseRequest;

Event Data

The event handler receives an argument of type CloseRequestEventArgs containing data related to this event. The following CloseRequestEventArgs properties provide information specific to this event.

Property | Description
Cancel | Cancel this event?
Node | Retrieves the node.
TabControl | Retrieves the tab control.
TabPage | Retrieves the tab page.

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.PageContextMenu Event

Raised when a page's context menu is shown.

[Visual Basic]
Public Event PageContextMenu As PageContextMenuHandler
[C#]
public event PageContextMenuHandler PageContextMenu;

Event Data

The event handler receives an argument of type ContextMenuEventArgs containing data related to this event. The following ContextMenuEventArgs properties provide information specific to this event.

Property | Description
Cancel | Cancel this event?
ContextMenu | Gets the context menu.
Node | Retrieves the node.
TabControl | Retrieves the tab control.
TabPage | Retrieves the tab page.

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.PageLoading Event

Raised when page layout is being loaded.

[Visual Basic]
Public Event PageLoading As PageLoadingHandler
[C#]
public event PageLoadingHandler PageLoading;

Event Data

The event handler receives an argument of type PageLoadingEventArgs containing data related to this event. The following PageLoadingEventArgs properties provide information specific to this event.

Property | Description
Cancel | Cancel this event?
TabPage | Gets the tab page.
XmlIn | Gets the XML reader.

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.PageSaving Event

Raised when page layout is being saved.

[Visual Basic]
Public Event PageSaving As PageSavingHandler
[C#]
public event PageSavingHandler PageSaving;

Event Data

The event handler receives an argument of type PageSavingEventArgs containing data related to this event. The following PageSavingEventArgs properties provide information specific to this event.

Property | Description
TabPage | Gets the tab page.
XmlOut | Gets the XML writer.

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.SelectedNodeChanged Event

Raised when the selected tabbed node is changed.

[Visual Basic]
Public Event SelectedNodeChanged As EventHandler
[C#]
public event EventHandler SelectedNodeChanged;

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.TabControlCreated Event

Raised when the tab control is created.

[Visual Basic]
Public Event TabControlCreated As TabControlCreatedHandler
[C#]
public event TabControlCreatedHandler TabControlCreated;

See Also

TabbedGroups Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.CompactFlags Enumeration

Flags for compacting tabbed groups.

[Visual Basic]
Public Enum TabbedGroups.CompactFlags
[C#]
public enum TabbedGroups.CompactFlags

Members

Member Name | Description
RemoveEmptyTabNode | Removes empty tabbed groups.
RemoveEmptyTabSequence | Removes empty tabbed sequences.
ReduceSingleEntries | Reduces single entries.
ReduceSameDirection | Reduces entries in the same direction.
All | All flags.

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.DisplayTabModes Enumeration

Specifies modes for showing/hiding tabbed groups.

[Visual Basic]
Public Enum TabbedGroups.DisplayTabModes
[C#]
public enum TabbedGroups.DisplayTabModes

Members

Member Name | Description
HideAll | Hide all tabbed groups.
ShowAll | Show all tabbed groups.
ShowActiveNode | Show only the active tabbed group.
ShowMouseOver | Show only on mouse over.
ShowActiveAndMouseOver | Show only the active tabbed group or the mouse-over group.

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.DragProvider Class

Defines a drag provider.

For a list of all members of this type, see TabbedGroups.DragProvider Members.

System.Object
TabbedGroups.DragProvider

[Visual Basic]
Public Class TabbedGroups.DragProvider
[C#]
public class TabbedGroups.DragProvider

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

TabbedGroups.DragProvider Members | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.DragProvider Members

TabbedGroups.DragProvider overview

Public Instance Constructors

TabbedGroups.DragProvider Overloaded. Initializes a new instance of the TabbedGroups.DragProvider class.

Public Instance Properties

Tag Gets or sets the tag.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

TabbedGroups.DragProvider Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.DragProvider Constructor

Constructs a new DragProvider.

Overload List

Constructs a new DragProvider.

public TabbedGroups.DragProvider();

Constructs a new DragProvider with the given tag.

public TabbedGroups.DragProvider(object);

See Also

TabbedGroups.DragProvider Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.DragProvider Constructor ()

Constructs a new DragProvider.

[Visual Basic]
Overloads Public Sub New()
[C#]
public TabbedGroups.DragProvider();

See Also

TabbedGroups.DragProvider Class | NETXP.Controls.Docking Namespace | TabbedGroups.DragProvider Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.DragProvider Constructor (Object)

Constructs a new DragProvider with the given tag.

[Visual Basic]
Overloads Public Sub New( _
ByVal tag As Object _
)
[C#]
public TabbedGroups.DragProvider(
object tag
);

Parameters

tag
The tag.

See Also

TabbedGroups.DragProvider Class | NETXP.Controls.Docking Namespace | TabbedGroups.DragProvider Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.DragProvider Properties

The properties of the TabbedGroups.DragProvider class are listed below. For a complete list of TabbedGroups.DragProvider class members, see the TabbedGroups.DragProvider Members topic.

Public Instance Properties

Tag Gets or sets the tag.

See Also

TabbedGroups.DragProvider Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.DragProvider.Tag Property

Gets or sets the tag.

[Visual Basic]
Public Property Tag As Object
[C#]
public object Tag {get; set;}

See Also

TabbedGroups.DragProvider Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.ExternalDropHandler Delegate

Defines an event handler.

[Visual Basic]
Public Delegate Sub TabbedGroups.ExternalDropHandler( _
ByVal tg As TabbedGroups, _
ByVal tgl As TabGroupNode, _
ByVal tc As TabControl, _
ByVal dp As DragProvider _
)
[C#]
public delegate void TabbedGroups.ExternalDropHandler(
TabbedGroups tg,
TabGroupNode tgl,
TabControl tc,
DragProvider dp
);

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.GlobalLoadingHandler Delegate

Defines an event handler.

[Visual Basic]
Public Delegate Sub TabbedGroups.GlobalLoadingHandler( _
ByVal tg As TabbedGroups, _
ByVal xmlIn As XmlTextReader _
)
[C#]
public delegate void TabbedGroups.GlobalLoadingHandler(
TabbedGroups tg,
XmlTextReader xmlIn
);

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.GlobalSavingHandler Delegate

Defines an event handler.

[Visual Basic]
Public Delegate Sub TabbedGroups.GlobalSavingHandler( _
ByVal tg As TabbedGroups, _
ByVal xmlOut As XmlTextWriter _
)
[C#]
public delegate void TabbedGroups.GlobalSavingHandler(
TabbedGroups tg,
XmlTextWriter xmlOut
);

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.PageCloseRequestHandler Delegate

Defines an event handler.

[Visual Basic]
Public Delegate Sub TabbedGroups.PageCloseRequestHandler( _
ByVal tg As TabbedGroups, _
ByVal e As CloseRequestEventArgs _
)
[C#]
public delegate void TabbedGroups.PageCloseRequestHandler(
TabbedGroups tg,
CloseRequestEventArgs e
);

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.PageContextMenuHandler Delegate

Defines an event handler.

[Visual Basic]
Public Delegate Sub TabbedGroups.PageContextMenuHandler( _
ByVal tg As TabbedGroups, _
ByVal e As ContextMenuEventArgs _
)
[C#]
public delegate void TabbedGroups.PageContextMenuHandler(
TabbedGroups tg,
ContextMenuEventArgs e
);

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.PageLoadingHandler Delegate

Defines an event handler.

[Visual Basic]
Public Delegate Sub TabbedGroups.PageLoadingHandler( _
ByVal tg As TabbedGroups, _
ByVal e As PageLoadingEventArgs _
)
[C#]
public delegate void TabbedGroups.PageLoadingHandler(
TabbedGroups tg,
PageLoadingEventArgs e
);

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.PageSavingHandler Delegate

Defines an event handler.

[Visual Basic]
Public Delegate Sub TabbedGroups.PageSavingHandler( _
ByVal tg As TabbedGroups, _
ByVal e As PageSavingEventArgs _
)
[C#]
public delegate void TabbedGroups.PageSavingHandler(
TabbedGroups tg,
PageSavingEventArgs e
);

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabbedGroups.TabControlCreatedHandler Delegate

Defines an event handler.

[Visual Basic]
Public Delegate Sub TabbedGroups.TabControlCreatedHandler( _
ByVal tg As TabbedGroups, _
ByVal tc As TabControl _
)
[C#]
public delegate void TabbedGroups.TabControlCreatedHandler(
TabbedGroups tg,
TabControl tc
);

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl Class

A tab control with extended features.

For a list of all members of this type, see TabControl Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
Panel
TabControl

[Visual Basic]
NotInheritable Public Class TabControl
Inherits Panel
Implements System.ComponentModel.ISupportInitialize
[C#]
public sealed class TabControl : Panel, ISupportInitialize

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

TabControl Members | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl Members

TabControl overview

Public Instance Constructors

TabControl Constructor Constructs a new TabControl.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop | Should drag and drop be allowed?
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
Appearance | The position of the tabs in the tab control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BoldSelectedPage | Bold selected page?
BorderStyle (inherited from Panel) | Indicates the border style for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ControlBottomOffset | Offset (at the bottom) of the control.
ControlLeftOffset | Offset (to the left) of the control.
ControlRightOffset | Offset (to the right) of the control.
Controls | Controls contained by the tab control.
ControlTopOffset | Offset (at the top) of the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
DragDropReorder | Reorder pages using drag and drop?
DragFromControl | Drag from control?
DragOverSelect | Select page when mouse is dragged over it?
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HideTabsMode | The mode by which to hide tabs.
HotTrack | Hot-track tab pages?
HoverSelect | Select on hover?
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InsetBorderPagesOnly | Inset border for pages only?
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MouseLeaveTimeout | Mouse-leave timeout.
Multiline | Multi-line tab control?
MultilineFullWidth | Show full-width tab pages for multi-line tab control?
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PixelArea | Show a one-pixel border at the top or bottom of the tab area?
PixelBorder | Show a one-pixel border around the tab control?
PositionTop | Should tabs be positioned at top?
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecordFocus | Record focus?
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Renderer | Renderer used to draw the tab control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
SelectedIndex | Index of the selected tab page.
SelectedTab | Selected tab page.
SelectedTextOnly | Show text only for selected item?
ShowArrows | Show arrows?
ShowClose | Show the close button?
ShrinkPagesToFit | Shrink pages to fit?
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabPages | Collection of tab pages contained by the tab control.
TabsAreaRect | Internal.
TabStop (inherited from Panel) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Panel) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInit | Internal
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BeginUpdate | Begins a series of updates. Suspends all redrawing.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInit | Internal
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
EndUpdate | Ends a series of updates. Refreshes the control.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
FindIndex | Loops over all the TabPages to find the index of the given TabPage.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
MakePageVisible | Overloaded. Makes a specified tab page visible.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
TabPageFromPoint | Gets a tab page at a specified point.
ToString (inherited from Panel) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClosePressed | Close button was pressed.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DoubleClickTab | A tab has been double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Panel) |
KeyPress (inherited from Panel) |
KeyUp (inherited from Panel) |
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PageDragEnd | Page dragging has ended.
PageDragMove | Page dragging is going on.
PageDragQuit | Page dragging has quit.
PageDragStart | Page dragging has started.
PageGotFocus | Tab page got focus.
PageLostFocus | Tab page lost focus.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PopupMenuDisplay | Context menu is being displayed.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SelectionChanged | Selected tab page changed.
SelectionChanging | Selected tab page is changing.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Panel) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

TabControl Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl Constructor

Constructs a new TabControl.

[Visual Basic]
Public Sub New()
[C#]
public TabControl();

See Also

TabControl Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl Properties

The properties of the TabControl class are listed below. For a complete list of TabControl class members, see the TabControl Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop | Should drag and drop be allowed?
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
Appearance | The position of the tabs in the tab control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BoldSelectedPage | Bold selected page?
BorderStyle (inherited from Panel) | Indicates the border style for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ControlBottomOffset | Offset (at the bottom) of the control.
ControlLeftOffset | Offset (to the left) of the control.
ControlRightOffset | Offset (to the right) of the control.
Controls | Controls contained by the tab control.
ControlTopOffset | Offset (at the top) of the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
DragDropReorder | Reorder pages using drag and drop?
DragFromControl | Drag from control?
DragOverSelect | Select page when mouse is dragged over it?
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HideTabsMode | The mode by which to hide tabs.
HotTrack | Hot-track tab pages?
HoverSelect | Select on hover?
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InsetBorderPagesOnly | Inset border for pages only?
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MouseLeaveTimeout | Mouse-leave timeout.
Multiline | Multi-line tab control?
MultilineFullWidth | Show full-width tab pages for multi-line tab control?
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PixelArea | Show a one-pixel border at the top or bottom of the tab area?
PixelBorder | Show a one-pixel border around the tab control?
PositionTop | Should tabs be positioned at top?
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecordFocus | Record focus?
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Renderer | Renderer used to draw the tab control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
SelectedIndex | Index of the selected tab page.
SelectedTab | Selected tab page.
SelectedTextOnly | Show text only for selected item?
ShowArrows | Show arrows?
ShowClose | Show the close button?
ShrinkPagesToFit | Shrink pages to fit?
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabPages | Collection of tab pages contained by the tab control.
TabsAreaRect | Internal.
TabStop (inherited from Panel) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Panel) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

See Also

TabControl Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.AllowDrop Property

Should drag and drop be allowed?

[Visual Basic]
Overrides Public Property AllowDrop As Boolean
[C#]
public override bool AllowDrop {get; set;}

See Also

TabControl Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.Appearance Property

The position of the tabs in the tab control.

[Visual Basic]
Public Property Appearance As TabPosition
[C#]
public TabPosition Appearance {get; set;}

See Also

TabControl Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.BoldSelectedPage Property

Bold selected page?

[Visual Basic]
Public Property BoldSelectedPage As Boolean
[C#]
public bool BoldSelectedPage {get; set;}

See Also

TabControl Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.ControlBottomOffset Property

Offset (at the bottom) of the control.

[Visual Basic]
Public Property ControlBottomOffset As Integer
[C#]
public int ControlBottomOffset {get; set;}

See Also

TabControl Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.ControlLeftOffset Property

Offset (to the left) of the control.

[Visual Basic]
Public Property ControlLeftOffset As Integer
[C#]
public int ControlLeftOffset {get; set;}

See Also

TabControl Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.ControlRightOffset Property

Offset (to the right) of the control.

[Visual Basic]
Public Property ControlRightOffset As Integer
[C#]
public int ControlRightOffset {get; set;}

See Also

TabControl Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.Controls Property

Controls contained by the tab control.

[Visual Basic]
Public ReadOnly Property Controls As ControlCollection
[C#]
new public System.Windows.Forms.Control.ControlCollection Controls {get;}

See Also

TabControl Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.ControlTopOffset Property

Offset (at the top) of the control.

[Visual Basic]
Public Property ControlTopOffset As Integer
[C#]
public int ControlTopOffset {get; set;}

See Also

TabControl Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.DragDropReorder Property

Reorder pages using drag and drop?

[Visual Basic]
Public Property DragDropReorder As Boolean
[C#]
public bool DragDropReorder {get; set;}

See Also

TabControl Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.DragFromControl Property

Drag from control?

[Visual Basic]
Public Property DragFromControl As Boolean
[C#]
public bool DragFromControl {get; set;}

See Also

TabControl Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.DragOverSelect Property

Select page when mouse is dragged over it?

[Visual Basic]
Public Property DragOverSelect As Boolean
[C#]
public bool DragOverSelect {get; set;}

See Also

TabControl Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.HideTabsMode Property

The mode by which to hide tabs.

[Visual Basic]
Public Property HideTabsMode As HideTabsModes
[C#]
public HideTabsModes HideTabsMode {get; set;}

See Also

TabControl Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.HotTrack Property

Hot-track tab pages?

[Visual Basic]
Public Property HotTrack As Boolean
[C#]
public bool HotTrack {get; set;}

See Also

TabControl Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.HoverSelect Property

Select on hover?

[Visual Basic]
Public Property HoverSelect As Boolean
[C#]
public bool HoverSelect {get; set;}

See Also

TabControl Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.InsetBorderPagesOnly Property

Inset border for pages only?

[Visual Basic]
Public Property InsetBorderPagesOnly As Boolean
[C#]
public bool InsetBorderPagesOnly {get; set;}

See Also

TabControl Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.MouseLeaveTimeout Property

Mouse-leave timeout.

[Visual Basic]
Public Property MouseLeaveTimeout As Integer
[C#]
public int MouseLeaveTimeout {get; set;}

See Also

TabControl Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.Multiline Property

Multi-line tab control?

[Visual Basic]
Public Property Multiline As Boolean
[C#]
public bool Multiline {get; set;}

See Also

TabControl Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.MultilineFullWidth Property

Show full-width tab pages for multi-line tab control?

[Visual Basic]
Public Property MultilineFullWidth As Boolean
[C#]
public bool MultilineFullWidth {get; set;}

See Also

TabControl Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.PixelArea Property

Show a one-pixel border at the top or bottom of the tab area?

[Visual Basic]
Public Property PixelArea As Boolean
[C#]
public bool PixelArea {get; set;}

See Also

TabControl Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.PixelBorder Property

Show a one-pixel border around the tab control?

[Visual Basic]
Public Property PixelBorder As Boolean
[C#]
public bool PixelBorder {get; set;}

See Also

TabControl Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.PositionTop Property

Should tabs be positioned at top?

[Visual Basic]
Public Property PositionTop As Boolean
[C#]
public bool PositionTop {get; set;}

See Also

TabControl Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.RecordFocus Property

Record focus?

[Visual Basic]
Public Property RecordFocus As Boolean
[C#]
public bool RecordFocus {get; set;}

See Also

TabControl Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.Renderer Property

Renderer used to draw the tab control.

[Visual Basic]
Public Property Renderer As IDockingRenderer
[C#]
public IDockingRenderer Renderer {get; set;}

See Also

TabControl Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.SelectedIndex Property

Index of the selected tab page.

[Visual Basic]
Public Property SelectedIndex As Integer
[C#]
public int SelectedIndex {get; set;}

See Also

TabControl Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.SelectedTab Property

Selected tab page.

[Visual Basic]
Public Property SelectedTab As TabPage
[C#]
public TabPage SelectedTab {get; set;}

See Also

TabControl Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.SelectedTextOnly Property

Show text only for selected item?

[Visual Basic]
Public Property SelectedTextOnly As Boolean
[C#]
public bool SelectedTextOnly {get; set;}

See Also

TabControl Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.ShowArrows Property

Show arrows?

[Visual Basic]
Public Property ShowArrows As Boolean
[C#]
public bool ShowArrows {get; set;}

See Also

TabControl Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.ShowClose Property

Show the close button?

[Visual Basic]
Public Property ShowClose As Boolean
[C#]
public bool ShowClose {get; set;}

See Also

TabControl Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.ShrinkPagesToFit Property

Shrink pages to fit?

[Visual Basic]
Public Property ShrinkPagesToFit As Boolean
[C#]
public bool ShrinkPagesToFit {get; set;}

See Also

TabControl Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.TabPages Property

Collection of tab pages contained by the tab control.

[Visual Basic]
Public ReadOnly Property TabPages As TabPageCollection
[C#]
public TabPageCollection TabPages {get;}

See Also

TabControl Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.TabsAreaRect Property

Internal.

[Visual Basic]
Public ReadOnly Property TabsAreaRect As Rectangle
[C#]
public System.Drawing.Rectangle TabsAreaRect {get;}

See Also

TabControl Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl Methods

The methods of the TabControl class are listed below. For a complete list of TabControl class members, see the TabControl Members topic.

Public Instance Methods

BeginInit | Internal
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BeginUpdate | Begins a series of updates. Suspends all redrawing.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInit | Internal
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
EndUpdate | Ends a series of updates. Refreshes the control.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
FindIndex | Loops over all the TabPages to find the index of the given TabPage.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
MakePageVisible | Overloaded. Makes a specified tab page visible.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
TabPageFromPoint | Gets a tab page at a specified point.
ToString (inherited from Panel) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

See Also

TabControl Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.BeginInit Method

Internal

[Visual Basic]
NotOverridable Public Sub BeginInit() Implements _
ISupportInitialize.BeginInit
[C#]
public void BeginInit();

Implements

ISupportInitialize.BeginInit

See Also

TabControl Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.BeginUpdate Method

Begins a series of updates. Suspends all redrawing.

[Visual Basic]
Public Sub BeginUpdate()
[C#]
public void BeginUpdate();

See Also

TabControl Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.EndInit Method

Internal

[Visual Basic]
NotOverridable Public Sub EndInit() Implements _
ISupportInitialize.EndInit
[C#]
public void EndInit();

Implements

ISupportInitialize.EndInit

See Also

TabControl Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.EndUpdate Method

Ends a series of updates. Refreshes the control.

[Visual Basic]
Public Sub EndUpdate()
[C#]
public void EndUpdate();

See Also

TabControl Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.FindIndex Method

Loops over all the TabPages to find the index of the given TabPage.

[Visual Basic]
Public Function FindIndex( _
ByVal page As TabPage _
) As Integer
[C#]
public int FindIndex(
TabPage page
);

Parameters

page
The TabPage we want the index for.

Return Value

The index of the given TabPage(-1 if it isn't found.)

See Also

TabControl Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


MakePageVisible Method

NetXP 3.0 Reference

TabControl.MakePageVisible Method

Makes a specified tab page visible.

Overload List

Makes a specified tab page visible.

public void MakePageVisible(TabPage);

Makes a specified tab page visible.

public void MakePageVisible(int);

See Also

TabControl Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.MakePageVisible Method (TabPage)

Makes a specified tab page visible.

[Visual Basic]
Overloads Public Sub MakePageVisible( _
ByVal page As TabPage _
)
[C#]
public void MakePageVisible(
TabPage page
);

Parameters

page
Tab page to make visible.

See Also

TabControl Class | NETXP.Controls.Docking Namespace | TabControl.MakePageVisible Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.MakePageVisible Method (Int32)

Makes a specified tab page visible.

[Visual Basic]
Overloads Public Sub MakePageVisible( _
ByVal index As Integer _
)
[C#]
public void MakePageVisible(
int index
);

Parameters

index
Index of tab page to make visible.

See Also

TabControl Class | NETXP.Controls.Docking Namespace | TabControl.MakePageVisible Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.TabPageFromPoint Method

Gets a tab page at a specified point.

[Visual Basic]
Public Function TabPageFromPoint( _
ByVal mousePos As Point _
) As TabPage
[C#]
public TabPage TabPageFromPoint(
Point mousePos
);

Parameters

mousePos
Point.

Return Value

Tab page.

See Also

TabControl Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl Events

The events of the TabControl class are listed below. For a complete list of TabControl class members, see the TabControl Members topic.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClosePressed | Close button was pressed.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DoubleClickTab | A tab has been double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Panel) |
KeyPress (inherited from Panel) |
KeyUp (inherited from Panel) |
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PageDragEnd | Page dragging has ended.
PageDragMove | Page dragging is going on.
PageDragQuit | Page dragging has quit.
PageDragStart | Page dragging has started.
PageGotFocus | Tab page got focus.
PageLostFocus | Tab page lost focus.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PopupMenuDisplay | Context menu is being displayed.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SelectionChanged | Selected tab page changed.
SelectionChanging | Selected tab page is changing.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Panel) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

TabControl Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.ClosePressed Event

Close button was pressed.

[Visual Basic]
Public Event ClosePressed As EventHandler
[C#]
public event EventHandler ClosePressed;

See Also

TabControl Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.DoubleClickTab Event

A tab has been double-clicked.

[Visual Basic]
Public Event DoubleClickTab As DoubleClickTabHandler
[C#]
public event DoubleClickTabHandler DoubleClickTab;

See Also

TabControl Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.PageDragEnd Event

Page dragging has ended.

[Visual Basic]
Public Event PageDragEnd As MouseEventHandler
[C#]
public event MouseEventHandler PageDragEnd;

See Also

TabControl Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.PageDragMove Event

Page dragging is going on.

[Visual Basic]
Public Event PageDragMove As MouseEventHandler
[C#]
public event MouseEventHandler PageDragMove;

See Also

TabControl Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.PageDragQuit Event

Page dragging has quit.

[Visual Basic]
Public Event PageDragQuit As MouseEventHandler
[C#]
public event MouseEventHandler PageDragQuit;

See Also

TabControl Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.PageDragStart Event

Page dragging has started.

[Visual Basic]
Public Event PageDragStart As MouseEventHandler
[C#]
public event MouseEventHandler PageDragStart;

See Also

TabControl Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.PageGotFocus Event

Tab page got focus.

[Visual Basic]
Public Event PageGotFocus As EventHandler
[C#]
public event EventHandler PageGotFocus;

See Also

TabControl Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.PageLostFocus Event

Tab page lost focus.

[Visual Basic]
Public Event PageLostFocus As EventHandler
[C#]
public event EventHandler PageLostFocus;

See Also

TabControl Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.PopupMenuDisplay Event

Context menu is being displayed.

[Visual Basic]
Public Event PopupMenuDisplay As PopupMenuHandler
[C#]
public event PopupMenuHandler PopupMenuDisplay;

See Also

TabControl Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.SelectionChanged Event

Selected tab page changed.

[Visual Basic]
Public Event SelectionChanged As EventHandler
[C#]
public event EventHandler SelectionChanged;

See Also

TabControl Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.SelectionChanging Event

Selected tab page is changing.

[Visual Basic]
Public Event SelectionChanging As EventHandler
[C#]
public event EventHandler SelectionChanging;

See Also

TabControl Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.DoubleClickTabHandler Delegate

Event handler for when tab is double-clicked.

[Visual Basic]
Public Delegate Sub TabControl.DoubleClickTabHandler( _
ByVal sender As TabControl, _
ByVal page As TabPage _
)
[C#]
public delegate void TabControl.DoubleClickTabHandler(
TabControl sender,
TabPage page
);

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.MultiRect Class

Util class for handling multiline calculations.

For a list of all members of this type, see TabControl.MultiRect Members.

System.Object
TabControl.MultiRect

[Visual Basic]
Public Class TabControl.MultiRect
[C#]
public class TabControl.MultiRect

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

TabControl.MultiRect Members | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.MultiRect Members

TabControl.MultiRect overview

Public Instance Constructors

TabControl.MultiRect Constructor Constructs a new MultiRect.

Public Instance Properties

Height | The height of the rectangle.
Index | The index of this rectangle.
Rect | The rectangle encapsulated.
Width | The width of the rectangle.
X | The X coordinate.
Y | The Y coordinate.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

TabControl.MultiRect Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.MultiRect Constructor

Constructs a new MultiRect.

[Visual Basic]
Public Sub New( _
ByVal rect As Rectangle, _
ByVal index As Integer _
)
[C#]
public TabControl.MultiRect(
Rectangle rect,
int index
);

Parameters

rect
index

See Also

TabControl.MultiRect Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.MultiRect Properties

The properties of the TabControl.MultiRect class are listed below. For a complete list of TabControl.MultiRect class members, see the TabControl.MultiRect Members topic.

Public Instance Properties

Height | The height of the rectangle.
Index | The index of this rectangle.
Rect | The rectangle encapsulated.
Width | The width of the rectangle.
X | The X coordinate.
Y | The Y coordinate.

See Also

TabControl.MultiRect Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.MultiRect.Height Property

The height of the rectangle.

[Visual Basic]
Public Property Height As Integer
[C#]
public int Height {get; set;}

See Also

TabControl.MultiRect Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.MultiRect.Index Property

The index of this rectangle.

[Visual Basic]
Public ReadOnly Property Index As Integer
[C#]
public int Index {get;}

See Also

TabControl.MultiRect Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.MultiRect.Rect Property

The rectangle encapsulated.

[Visual Basic]
Public Property Rect As Rectangle
[C#]
public System.Drawing.Rectangle Rect {get; set;}

See Also

TabControl.MultiRect Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.MultiRect.Width Property

The width of the rectangle.

[Visual Basic]
Public Property Width As Integer
[C#]
public int Width {get; set;}

See Also

TabControl.MultiRect Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.MultiRect.X Property

The X coordinate.

[Visual Basic]
Public Property X As Integer
[C#]
public int X {get; set;}

See Also

TabControl.MultiRect Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.MultiRect.Y Property

The Y coordinate.

[Visual Basic]
Public Property Y As Integer
[C#]
public int Y {get; set;}

See Also

TabControl.MultiRect Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControl.PopupMenuHandler Delegate

Event handler for when a popup menu is about to be shown.

[Visual Basic]
Public Delegate Sub TabControl.PopupMenuHandler( _
ByVal sender As Object, _
ByVal ctl As TabControl, _
ByVal pt As Point _
)
[C#]
public delegate void TabControl.PopupMenuHandler(
object sender,
TabControl ctl,
Point pt
);

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabControlCreatedHandler Delegate

A tab control has been created.

[Visual Basic]
Public Delegate Sub TabControlCreatedHandler( _
ByVal tabControl As TabControl _
)
[C#]
public delegate void TabControlCreatedHandler(
TabControl tabControl
);

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupBase Class

The base class for tabbed groups.

For a list of all members of this type, see TabGroupBase Members.

System.Object
TabGroupBase

[Visual Basic]
MustInherit Public Class TabGroupBase
Implements System.IDisposable
[C#]
public abstract class TabGroupBase : IDisposable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

TabGroupBase Members | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupBase Members

TabGroupBase overview

Public Instance Constructors

TabGroupBase Overloaded. Initializes a new instance of the TabGroupBase class.

Public Instance Properties

Count | Abstract. Must be implemented by derived classes.
GroupControl | Abstract. Must be implemented by derived classes.
IsNode | Abstract. Must be implemented by derived classes.
IsSequence | Abstract. Must be implemented by derived classes.
MinimumSize | Gets or sets the minimum size for this tabbed group.
Parent | Gets this group's parent.
Space | Gets or sets the space used up by this tabbed group.
TabbedGroups | Gets this group's children.
Tag | Gets or sets an object associated with this group.
Unique | Gets or sets a unique ID for this group.

Public Instance Methods

ContainsSelected | Abstract. Must be implemented by derived classes.
Dispose | Abstract. Must be implemented by derived classes.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadFromXml | Abstract. Must be implemented by derived classes.
Notify | Abstract. Must be implemented by derived classes.
SaveToXml | Abstract. Must be implemented by derived classes.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

TabGroupBase Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupBase Constructor

Constructs a new tabbed group.

Overload List

Constructs a new tabbed group.

public TabGroupBase(TabbedGroups);

Constructs a new tabbed group.

public TabGroupBase(TabbedGroups,TabGroupBase);

See Also

TabGroupBase Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupBase Constructor (TabbedGroups)

Constructs a new tabbed group.

[Visual Basic]
Overloads Public Sub New( _
ByVal tabbedGroups As TabbedGroups _
)
[C#]
public TabGroupBase(
TabbedGroups tabbedGroups
);

Parameters

tabbedGroups
The parent control.

See Also

TabGroupBase Class | NETXP.Controls.Docking Namespace | TabGroupBase Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupBase Constructor (TabbedGroups, TabGroupBase)

Constructs a new tabbed group.

[Visual Basic]
Overloads Public Sub New( _
ByVal tabbedGroups As TabbedGroups, _
ByVal parent As TabGroupBase _
)
[C#]
public TabGroupBase(
TabbedGroups tabbedGroups,
TabGroupBase parent
);

Parameters

tabbedGroups
The parent control.
parent
Parent group.

See Also

TabGroupBase Class | NETXP.Controls.Docking Namespace | TabGroupBase Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupBase Properties

The properties of the TabGroupBase class are listed below. For a complete list of TabGroupBase class members, see the TabGroupBase Members topic.

Public Instance Properties

Count | Abstract. Must be implemented by derived classes.
GroupControl | Abstract. Must be implemented by derived classes.
IsNode | Abstract. Must be implemented by derived classes.
IsSequence | Abstract. Must be implemented by derived classes.
MinimumSize | Gets or sets the minimum size for this tabbed group.
Parent | Gets this group's parent.
Space | Gets or sets the space used up by this tabbed group.
TabbedGroups | Gets this group's children.
Tag | Gets or sets an object associated with this group.
Unique | Gets or sets a unique ID for this group.

See Also

TabGroupBase Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupBase.Count Property

Abstract. Must be implemented by derived classes.

[Visual Basic]
MustOverride Public ReadOnly Property Count As Integer
[C#]
public abstract int Count {get;}

See Also

TabGroupBase Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupBase.GroupControl Property

Abstract. Must be implemented by derived classes.

[Visual Basic]
MustOverride Public ReadOnly Property GroupControl As Control
[C#]
public abstract System.Windows.Forms.Control GroupControl {get;}

See Also

TabGroupBase Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupBase.IsNode Property

Abstract. Must be implemented by derived classes.

[Visual Basic]
MustOverride Public ReadOnly Property IsNode As Boolean
[C#]
public abstract bool IsNode {get;}

See Also

TabGroupBase Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupBase.IsSequence Property

Abstract. Must be implemented by derived classes.

[Visual Basic]
MustOverride Public ReadOnly Property IsSequence As Boolean
[C#]
public abstract bool IsSequence {get;}

See Also

TabGroupBase Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupBase.MinimumSize Property

Gets or sets the minimum size for this tabbed group.

[Visual Basic]
Public Property MinimumSize As Size
[C#]
public System.Drawing.Size MinimumSize {get; set;}

See Also

TabGroupBase Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupBase.Parent Property

Gets this group's parent.

[Visual Basic]
Public ReadOnly Property Parent As TabGroupBase
[C#]
public TabGroupBase Parent {get;}

See Also

TabGroupBase Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupBase.Space Property

Gets or sets the space used up by this tabbed group.

[Visual Basic]
Public Property Space As Decimal
[C#]
public decimal Space {get; set;}

See Also

TabGroupBase Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupBase.TabbedGroups Property

Gets this group's children.

[Visual Basic]
Public ReadOnly Property TabbedGroups As TabbedGroups
[C#]
public TabbedGroups TabbedGroups {get;}

See Also

TabGroupBase Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupBase.Tag Property

Gets or sets an object associated with this group.

[Visual Basic]
Public Property Tag As Object
[C#]
public object Tag {get; set;}

See Also

TabGroupBase Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupBase.Unique Property

Gets or sets a unique ID for this group.

[Visual Basic]
Public Property Unique As Integer
[C#]
public int Unique {get; set;}

See Also

TabGroupBase Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupBase Methods

The methods of the TabGroupBase class are listed below. For a complete list of TabGroupBase class members, see the TabGroupBase Members topic.

Public Instance Methods

ContainsSelected | Abstract. Must be implemented by derived classes.
Dispose | Abstract. Must be implemented by derived classes.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadFromXml | Abstract. Must be implemented by derived classes.
Notify | Abstract. Must be implemented by derived classes.
SaveToXml | Abstract. Must be implemented by derived classes.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

TabGroupBase Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupBase.ContainsSelected Method

Abstract. Must be implemented by derived classes.

[Visual Basic]
MustOverride Public Function ContainsSelected( _
ByVal recurse As Boolean _
) As Boolean
[C#]
public abstract bool ContainsSelected(
bool recurse
);

Parameters

recurse

Return Value

See Also

TabGroupBase Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupBase.Dispose Method

Abstract. Must be implemented by derived classes.

[Visual Basic]
MustOverride Public Sub Dispose() Implements _
IDisposable.Dispose
[C#]
public abstract void Dispose();

Implements

IDisposable.Dispose

See Also

TabGroupBase Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupBase.LoadFromXml Method

Abstract. Must be implemented by derived classes.

[Visual Basic]
MustOverride Public Sub LoadFromXml( _
ByVal xmlIn As XmlTextReader _
)
[C#]
public abstract void LoadFromXml(
XmlTextReader xmlIn
);

Parameters

xmlIn

See Also

TabGroupBase Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupBase.Notify Method

Abstract. Must be implemented by derived classes.

[Visual Basic]
MustOverride Public Sub Notify( _
ByVal code As NotifyCode _
)
[C#]
public abstract void Notify(
NotifyCode code
);

Parameters

code

See Also

TabGroupBase Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupBase.SaveToXml Method

Abstract. Must be implemented by derived classes.

[Visual Basic]
MustOverride Public Sub SaveToXml( _
ByVal xmlOut As XmlTextWriter _
)
[C#]
public abstract void SaveToXml(
XmlTextWriter xmlOut
);

Parameters

xmlOut

See Also

TabGroupBase Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupBase.NotifyCode Enumeration

Notification code.

[Visual Basic]
Public Enum TabGroupBase.NotifyCode
[C#]
public enum TabGroupBase.NotifyCode

Members

Member Name | Description
StyleChanged | Renderer has changed.
SelectedChanged | Selected item has changed.
MinimumSizeChanged | Minimum size has changed.
SizeBarWidthChanged | Size bar width has changed.
DisplayTabMode | Display tab mode has changed.

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupBaseCollection Class

Provides a collection of TabGroupBase objects.

For a list of all members of this type, see TabGroupBaseCollection Members.

System.Object
CollectionBase
CollectionEx
TabGroupBaseCollection

[Visual Basic]
NotInheritable Public Class TabGroupBaseCollection
Inherits CollectionEx
[C#]
public sealed class TabGroupBaseCollection : CollectionEx

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

TabGroupBaseCollection Members | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupBaseCollection Members

TabGroupBaseCollection overview

Public Instance Constructors

TabGroupBaseCollection Constructor Initializes a new instance of the TabGroupBaseCollection class.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
IsSuspended (inherited from CollectionEx) | Is event generation already suspended?
Item | Gets or sets the tab group base at the specified index.

Public Instance Methods

Add | Adds an object to the collection.
AddRange | Adds an array of objects to the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Contains | Overloaded. Does the collection contain the specified object?
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Gets the index of an object.
Insert | Inserts an object at the specified index.
RaiseChanged (inherited from CollectionEx) | Raises the Changed event.
Remove | Removes an object from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
ResumeEvents (inherited from CollectionEx) | Resume event generation.
SuspendEvents (inherited from CollectionEx) | Suspend event generation.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

Changed (inherited from CollectionEx) | Event raised when the collection has changed.
Cleared (inherited from CollectionEx) | Event raised when collection has been cleared.
Clearing (inherited from CollectionEx) | Event raised when collection is being cleared.
Inserted (inherited from CollectionEx) | Event raised when an item has been inserted.
Inserting (inherited from CollectionEx) | Event raised when an item is being inserted.
Removed (inherited from CollectionEx) | Event raised when an item has been removed.
Removing (inherited from CollectionEx) | Event raised when an item is being removed.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

TabGroupBaseCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupBaseCollection Constructor

Initializes a new instance of the TabGroupBaseCollection class.

[Visual Basic]
Public Sub New()
[C#]
public TabGroupBaseCollection();

See Also

TabGroupBaseCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupBaseCollection Properties

The properties of the TabGroupBaseCollection class are listed below. For a complete list of TabGroupBaseCollection class members, see the TabGroupBaseCollection Members topic.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
IsSuspended (inherited from CollectionEx) | Is event generation already suspended?
Item | Gets or sets the tab group base at the specified index.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

TabGroupBaseCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupBaseCollection.Item Property

Gets or sets the tab group base at the specified index.

[Visual Basic]
Public Default Property Item( _
ByVal index As Integer _
) As TabGroupBase
[C#]
public TabGroupBase this[
int index
] {get; set;}

See Also

TabGroupBaseCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupBaseCollection Methods

The methods of the TabGroupBaseCollection class are listed below. For a complete list of TabGroupBaseCollection class members, see the TabGroupBaseCollection Members topic.

Public Instance Methods

Add | Adds an object to the collection.
AddRange | Adds an array of objects to the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Contains | Overloaded. Does the collection contain the specified object?
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Gets the index of an object.
Insert | Inserts an object at the specified index.
RaiseChanged (inherited from CollectionEx) | Raises the Changed event.
Remove | Removes an object from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
ResumeEvents (inherited from CollectionEx) | Resume event generation.
SuspendEvents (inherited from CollectionEx) | Suspend event generation.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

TabGroupBaseCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupBaseCollection.Add Method

Adds an object to the collection.

[Visual Basic]
Public Function Add( _
ByVal value As TabGroupBase _
) As TabGroupBase
[C#]
public TabGroupBase Add(
TabGroupBase value
);

Parameters

value
The object.

Return Value

The object.

See Also

TabGroupBaseCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupBaseCollection.AddRange Method

Adds an array of objects to the collection.

[Visual Basic]
Public Sub AddRange( _
ByVal values As TabGroupBase() _
)
[C#]
public void AddRange(
TabGroupBase[] values
);

Parameters

values
The objects.

See Also

TabGroupBaseCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Contains Method

NetXP 3.0 Reference

TabGroupBaseCollection.Contains Method

Does the collection contain the specified object?

Overload List

Does the collection contain the specified object?

public bool Contains(TabGroupBase);

Does the collection contain any of the specified objects?

public bool Contains(TabGroupBaseCollection);

See Also

TabGroupBaseCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupBaseCollection.Contains Method (TabGroupBase)

Does the collection contain the specified object?

[Visual Basic]
Overloads Public Function Contains( _
ByVal value As TabGroupBase _
) As Boolean
[C#]
public bool Contains(
TabGroupBase value
);

Parameters

value
The object.

Return Value

True if contains, false if not.

See Also

TabGroupBaseCollection Class | NETXP.Controls.Docking Namespace | TabGroupBaseCollection.Contains Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupBaseCollection.Contains Method (TabGroupBaseCollection)

Does the collection contain any of the specified objects?

[Visual Basic]
Overloads Public Function Contains( _
ByVal values As TabGroupBaseCollection _
) As Boolean
[C#]
public bool Contains(
TabGroupBaseCollection values
);

Parameters

values
The objects.

Return Value

True if at least one is contained.

See Also

TabGroupBaseCollection Class | NETXP.Controls.Docking Namespace | TabGroupBaseCollection.Contains Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupBaseCollection.IndexOf Method

Gets the index of an object.

[Visual Basic]
Public Function IndexOf( _
ByVal value As TabGroupBase _
) As Integer
[C#]
public int IndexOf(
TabGroupBase value
);

Parameters

value
The object.

Return Value

The index. -1 if not found.

See Also

TabGroupBaseCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupBaseCollection.Insert Method

Inserts an object at the specified index.

[Visual Basic]
Public Sub Insert( _
ByVal index As Integer, _
ByVal value As TabGroupBase _
)
[C#]
public void Insert(
int index,
TabGroupBase value
);

Parameters

index
The index.
value
The object.

See Also

TabGroupBaseCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupBaseCollection.Remove Method

Removes an object from the collection.

[Visual Basic]
Public Sub Remove( _
ByVal value As TabGroupBase _
)
[C#]
public void Remove(
TabGroupBase value
);

Parameters

value
The object.

See Also

TabGroupBaseCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupNode Class

Defines a tab group node.

For a list of all members of this type, see TabGroupNode Members.

System.Object
TabGroupBase
TabGroupNode

[Visual Basic]
NotInheritable Public Class TabGroupNode
Inherits TabGroupBase
[C#]
public sealed class TabGroupNode : TabGroupBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

TabGroupNode Members | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupNode Members

TabGroupNode overview

Public Instance Constructors

TabGroupNode Constructor Constructs a new tab group node.

Public Instance Properties

Count | Gets the number of tab pages.
GroupControl | Gets the tab control.
IsNode | Returns True.
IsSequence | Returns False.
MinimumSize (inherited from TabGroupBase) | Gets or sets the minimum size for this tabbed group.
Parent (inherited from TabGroupBase) | Gets this group's parent.
Space (inherited from TabGroupBase) | Gets or sets the space used up by this tabbed group.
TabbedGroups (inherited from TabGroupBase) | Gets this group's children.
TabControl | Gets the tab control for this node.
TabPages | Gets the tab pages in this node.
Tag (inherited from TabGroupBase) | Gets or sets an object associated with this group.
Unique (inherited from TabGroupBase) | Gets or sets a unique ID for this group.

Public Instance Methods

Close | Closes this node.
ContainsSelected | Finds out if the selected node is the same as this node.
Dispose | Implements inherited member.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadFromXml | Loads layout from XML.
MoveNext | Moves to next node.
MovePrevious | Moves to previous node.
NewHorizontal | New horizontal group.
NewVertical | New vertical group.
Notify | Internal
ProportionalResize | Resizes this node proportionally.
SaveToXml | Saves layout to XML.
ToggleSelected | Makes this the selected node.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

ShowContextMenu Raised when the context menu is about to be shown.

See Also

TabGroupNode Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupNode Constructor

Constructs a new tab group node.

[Visual Basic]
Public Sub New( _
ByVal tabbedGroups As TabbedGroups, _
ByVal parent As TabGroupBase _
)
[C#]
public TabGroupNode(
TabbedGroups tabbedGroups,
TabGroupBase parent
);

Parameters

tabbedGroups
The parent control.
parent
The parent group.

See Also

TabGroupNode Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupNode Properties

The properties of the TabGroupNode class are listed below. For a complete list of TabGroupNode class members, see the TabGroupNode Members topic.

Public Instance Properties

Count | Gets the number of tab pages.
GroupControl | Gets the tab control.
IsNode | Returns True.
IsSequence | Returns False.
MinimumSize (inherited from TabGroupBase) | Gets or sets the minimum size for this tabbed group.
Parent (inherited from TabGroupBase) | Gets this group's parent.
Space (inherited from TabGroupBase) | Gets or sets the space used up by this tabbed group.
TabbedGroups (inherited from TabGroupBase) | Gets this group's children.
TabControl | Gets the tab control for this node.
TabPages | Gets the tab pages in this node.
Tag (inherited from TabGroupBase) | Gets or sets an object associated with this group.
Unique (inherited from TabGroupBase) | Gets or sets a unique ID for this group.

See Also

TabGroupNode Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupNode.Count Property

Gets the number of tab pages.

[Visual Basic]
Overrides Public ReadOnly Property Count As Integer
[C#]
public override int Count {get;}

See Also

TabGroupNode Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupNode.GroupControl Property

Gets the tab control.

[Visual Basic]
Overrides Public ReadOnly Property GroupControl As Control
[C#]
public override System.Windows.Forms.Control GroupControl {get;}

See Also

TabGroupNode Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupNode.IsNode Property

Returns True.

[Visual Basic]
Overrides Public ReadOnly Property IsNode As Boolean
[C#]
public override bool IsNode {get;}

See Also

TabGroupNode Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupNode.IsSequence Property

Returns False.

[Visual Basic]
Overrides Public ReadOnly Property IsSequence As Boolean
[C#]
public override bool IsSequence {get;}

See Also

TabGroupNode Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupNode.TabControl Property

Gets the tab control for this node.

[Visual Basic]
Public ReadOnly Property TabControl As TabControl
[C#]
public TabControl TabControl {get;}

See Also

TabGroupNode Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupNode.TabPages Property

Gets the tab pages in this node.

[Visual Basic]
Public ReadOnly Property TabPages As TabPageCollection
[C#]
public TabPageCollection TabPages {get;}

See Also

TabGroupNode Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupNode Methods

The methods of the TabGroupNode class are listed below. For a complete list of TabGroupNode class members, see the TabGroupNode Members topic.

Public Instance Methods

Close | Closes this node.
ContainsSelected | Finds out if the selected node is the same as this node.
Dispose | Implements inherited member.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadFromXml | Loads layout from XML.
MoveNext | Moves to next node.
MovePrevious | Moves to previous node.
NewHorizontal | New horizontal group.
NewVertical | New vertical group.
Notify | Internal
ProportionalResize | Resizes this node proportionally.
SaveToXml | Saves layout to XML.
ToggleSelected | Makes this the selected node.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

TabGroupNode Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupNode.Close Method

Closes this node.

[Visual Basic]
Public Sub Close()
[C#]
public void Close();

See Also

TabGroupNode Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupNode.ContainsSelected Method

Finds out if the selected node is the same as this node.

[Visual Basic]
Overrides Public Function ContainsSelected( _
ByVal recurse As Boolean _
) As Boolean
[C#]
public override bool ContainsSelected(
bool recurse
);

Parameters

recurse
Unused

Return Value

True if selected == this.

See Also

TabGroupNode Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupNode.Dispose Method

Implements inherited member.

[Visual Basic]
Overrides Public Sub Dispose() Implements _
IDisposable.Dispose
[C#]
public override void Dispose();

Implements

IDisposable.Dispose

See Also

TabGroupNode Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupNode.LoadFromXml Method

Loads layout from XML.

[Visual Basic]
Overrides Public Sub LoadFromXml( _
ByVal xmlIn As XmlTextReader _
)
[C#]
public override void LoadFromXml(
XmlTextReader xmlIn
);

Parameters

xmlIn
XML reader.

See Also

TabGroupNode Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupNode.MoveNext Method

Moves to next node.

[Visual Basic]
Public Sub MoveNext()
[C#]
public void MoveNext();

See Also

TabGroupNode Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupNode.MovePrevious Method

Moves to previous node.

[Visual Basic]
Public Sub MovePrevious()
[C#]
public void MovePrevious();

See Also

TabGroupNode Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupNode.NewHorizontal Method

New horizontal group.

[Visual Basic]
Public Sub NewHorizontal()
[C#]
public void NewHorizontal();

See Also

TabGroupNode Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupNode.NewVertical Method

New vertical group.

[Visual Basic]
Public Sub NewVertical()
[C#]
public void NewVertical();

See Also

TabGroupNode Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupNode.Notify Method

Internal

[Visual Basic]
Overrides Public Sub Notify( _
ByVal code As NotifyCode _
)
[C#]
public override void Notify(
NotifyCode code
);

Parameters

code

See Also

TabGroupNode Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupNode.ProportionalResize Method

Resizes this node proportionally.

[Visual Basic]
Public Sub ProportionalResize()
[C#]
public void ProportionalResize();

See Also

TabGroupNode Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupNode.SaveToXml Method

Saves layout to XML.

[Visual Basic]
Overrides Public Sub SaveToXml( _
ByVal xmlOut As XmlTextWriter _
)
[C#]
public override void SaveToXml(
XmlTextWriter xmlOut
);

Parameters

xmlOut
XML writer.

See Also

TabGroupNode Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupNode.ToggleSelected Method

Makes this the selected node.

[Visual Basic]
Public Sub ToggleSelected()
[C#]
public void ToggleSelected();

See Also

TabGroupNode Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupNode Events

The events of the TabGroupNode class are listed below. For a complete list of TabGroupNode class members, see the TabGroupNode Members topic.

Public Instance Events

ShowContextMenu Raised when the context menu is about to be shown.

See Also

TabGroupNode Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupNode.ShowContextMenu Event

Raised when the context menu is about to be shown.

[Visual Basic]
Public Event ShowContextMenu As PopupMenuHandler
[C#]
public event PopupMenuHandler ShowContextMenu;

See Also

TabGroupNode Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupSequence Class

A container for multiple tabbed group nodes.

For a list of all members of this type, see TabGroupSequence Members.

System.Object
TabGroupBase
TabGroupSequence

[Visual Basic]
NotInheritable Public Class TabGroupSequence
Inherits TabGroupBase
Implements NETXP.Controls.Docking.IResizeSource
[C#]
public sealed class TabGroupSequence : TabGroupBase, IResizeSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

TabGroupSequence Members | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupSequence Members

TabGroupSequence overview

Public Instance Constructors

TabGroupSequence Overloaded. Initializes a new instance of the TabGroupSequence class.

Public Instance Properties

BackgroundColor | Gets the background color.
Count | Gets the number of children.
Direction | Gets the direction.
GroupControl | Gets the control within this sequence.
IsNode | Returns false.
IsSequence | Returns true.
Item | Gets the node at the index.
MinimumSize (inherited from TabGroupBase) | Gets or sets the minimum size for this tabbed group.
Parent (inherited from TabGroupBase) | Gets this group's parent.
Renderer | Gets the renderer for the sequence.
SizeBarWidth | Gets the width of the size bar.
Space (inherited from TabGroupBase) | Gets or sets the space used up by this tabbed group.
TabbedGroups (inherited from TabGroupBase) | Gets this group's children.
Tag (inherited from TabGroupBase) | Gets or sets an object associated with this group.
Unique (inherited from TabGroupBase) | Gets or sets a unique ID for this group.

Public Instance Methods

AddNewNode | Adds a new empty node.
CanResize | Can we resize this sequence?
Clear | Removes all children.
Compact | Overloaded. Compacts all children.
ContainsSelected | Gets whether or not the selected node is contained in this sequence.
Dispose | Implements inherited member.
EndResizeOperation | Finishes resize operation.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Gets the index of the specified node.
InsertNewNode | Inserts a new empty node at index.
LoadFromXml | Loads layout from XML.
Notify | Internal.
ProportionalResize | Resizes all children proportionally.
Remove | Removes a node.
RemoveAt | Removes a node at the specified index.
Reposition | Updates child layout to reflect new proportional spacing values.
SaveToXml | Saves layout to XML.
StartResizeOperation | Begins resize operation.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

TabGroupSequence Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupSequence Constructor

Creates a new sequence.

Overload List

Creates a new sequence.

public TabGroupSequence(TabbedGroups);

Creates a new sequence.

public TabGroupSequence(TabbedGroups,TabGroupBase);

Creates a new sequence.

public TabGroupSequence(TabbedGroups,TabGroupBase,Direction);

See Also

TabGroupSequence Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupSequence Constructor (TabbedGroups)

Creates a new sequence.

[Visual Basic]
Overloads Public Sub New( _
ByVal tabbedGroups As TabbedGroups _
)
[C#]
public TabGroupSequence(
TabbedGroups tabbedGroups
);

Parameters

tabbedGroups
The parent control.

See Also

TabGroupSequence Class | NETXP.Controls.Docking Namespace | TabGroupSequence Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupSequence Constructor (TabbedGroups, TabGroupBase)

Creates a new sequence.

[Visual Basic]
Overloads Public Sub New( _
ByVal tabbedGroups As TabbedGroups, _
ByVal parent As TabGroupBase _
)
[C#]
public TabGroupSequence(
TabbedGroups tabbedGroups,
TabGroupBase parent
);

Parameters

tabbedGroups
The parent control.
parent
The parent group.

See Also

TabGroupSequence Class | NETXP.Controls.Docking Namespace | TabGroupSequence Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupSequence Constructor (TabbedGroups, TabGroupBase, Direction)

Creates a new sequence.

[Visual Basic]
Overloads Public Sub New( _
ByVal tabbedGroups As TabbedGroups, _
ByVal parent As TabGroupBase, _
ByVal direction As Direction _
)
[C#]
public TabGroupSequence(
TabbedGroups tabbedGroups,
TabGroupBase parent,
Direction direction
);

Parameters

tabbedGroups
The parent control.
parent
The parent group.
direction
The direction.

See Also

TabGroupSequence Class | NETXP.Controls.Docking Namespace | TabGroupSequence Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupSequence Properties

The properties of the TabGroupSequence class are listed below. For a complete list of TabGroupSequence class members, see the TabGroupSequence Members topic.

Public Instance Properties

BackgroundColor | Gets the background color.
Count | Gets the number of children.
Direction | Gets the direction.
GroupControl | Gets the control within this sequence.
IsNode | Returns false.
IsSequence | Returns true.
Item | Gets the node at the index.
MinimumSize (inherited from TabGroupBase) | Gets or sets the minimum size for this tabbed group.
Parent (inherited from TabGroupBase) | Gets this group's parent.
Renderer | Gets the renderer for the sequence.
SizeBarWidth | Gets the width of the size bar.
Space (inherited from TabGroupBase) | Gets or sets the space used up by this tabbed group.
TabbedGroups (inherited from TabGroupBase) | Gets this group's children.
Tag (inherited from TabGroupBase) | Gets or sets an object associated with this group.
Unique (inherited from TabGroupBase) | Gets or sets a unique ID for this group.

See Also

TabGroupSequence Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupSequence.BackgroundColor Property

Gets the background color.

[Visual Basic]
Public ReadOnly Property BackgroundColor As Color
[C#]
public System.Drawing.Color BackgroundColor {get;}

See Also

TabGroupSequence Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupSequence.Count Property

Gets the number of children.

[Visual Basic]
Overrides Public ReadOnly Property Count As Integer
[C#]
public override int Count {get;}

See Also

TabGroupSequence Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupSequence.Direction Property

Gets the direction.

[Visual Basic]
Public Property Direction As Direction
[C#]
public NETXP.Library.Direction Direction {get; set;}

See Also

TabGroupSequence Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupSequence.GroupControl Property

Gets the control within this sequence.

[Visual Basic]
Overrides Public ReadOnly Property GroupControl As Control
[C#]
public override System.Windows.Forms.Control GroupControl {get;}

See Also

TabGroupSequence Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupSequence.IsNode Property

Returns false.

[Visual Basic]
Overrides Public ReadOnly Property IsNode As Boolean
[C#]
public override bool IsNode {get;}

See Also

TabGroupSequence Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupSequence.IsSequence Property

Returns true.

[Visual Basic]
Overrides Public ReadOnly Property IsSequence As Boolean
[C#]
public override bool IsSequence {get;}

See Also

TabGroupSequence Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupSequence.Item Property

Gets the node at the index.

[Visual Basic]
Public Default ReadOnly Property Item( _
ByVal index As Integer _
) As TabGroupBase
[C#]
public TabGroupBase this[
int index
] {get;}

See Also

TabGroupSequence Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupSequence.Renderer Property

Gets the renderer for the sequence.

[Visual Basic]
NotOverridable Public ReadOnly Property Renderer As IDockingRenderer Implements _
IResizeSource.Renderer
[C#]
public IDockingRenderer Renderer {get;}

Implements

IResizeSource.Renderer

See Also

TabGroupSequence Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupSequence.SizeBarWidth Property

Gets the width of the size bar.

[Visual Basic]
NotOverridable Public ReadOnly Property SizeBarWidth As Integer Implements _
IResizeSource.SizeBarWidth
[C#]
public int SizeBarWidth {get;}

Implements

IResizeSource.SizeBarWidth

See Also

TabGroupSequence Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupSequence Methods

The methods of the TabGroupSequence class are listed below. For a complete list of TabGroupSequence class members, see the TabGroupSequence Members topic.

Public Instance Methods

AddNewNode | Adds a new empty node.
CanResize | Can we resize this sequence?
Clear | Removes all children.
Compact | Overloaded. Compacts all children.
ContainsSelected | Gets whether or not the selected node is contained in this sequence.
Dispose | Implements inherited member.
EndResizeOperation | Finishes resize operation.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Gets the index of the specified node.
InsertNewNode | Inserts a new empty node at index.
LoadFromXml | Loads layout from XML.
Notify | Internal.
ProportionalResize | Resizes all children proportionally.
Remove | Removes a node.
RemoveAt | Removes a node at the specified index.
Reposition | Updates child layout to reflect new proportional spacing values.
SaveToXml | Saves layout to XML.
StartResizeOperation | Begins resize operation.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

TabGroupSequence Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupSequence.AddNewNode Method

Adds a new empty node.

[Visual Basic]
Public Function AddNewNode() As TabGroupNode
[C#]
public TabGroupNode AddNewNode();

Return Value

The node.

See Also

TabGroupSequence Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupSequence.CanResize Method

Can we resize this sequence?

[Visual Basic]
NotOverridable Public Function CanResize( _
ByVal bar As SizeBar _
) As Boolean Implements _
IResizeSource.CanResize
[C#]
public bool CanResize(
SizeBar bar
);

Parameters

bar
The size bar.

Return Value

True if sizing is allowed.

Implements

IResizeSource.CanResize

See Also

TabGroupSequence Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupSequence.Clear Method

Removes all children.

[Visual Basic]
Public Sub Clear()
[C#]
public void Clear();

See Also

TabGroupSequence Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Compact Method

NetXP 3.0 Reference

TabGroupSequence.Compact Method

Compacts all children.

Overload List

Compacts all children.

public void Compact();

Compacts all children.

public void Compact(CompactFlags);

See Also

TabGroupSequence Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupSequence.Compact Method ()

Compacts all children.

[Visual Basic]
Overloads Public Sub Compact()
[C#]
public void Compact();

See Also

TabGroupSequence Class | NETXP.Controls.Docking Namespace | TabGroupSequence.Compact Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupSequence.Compact Method (CompactFlags)

Compacts all children.

[Visual Basic]
Overloads Public Sub Compact( _
ByVal flags As CompactFlags _
)
[C#]
public void Compact(
CompactFlags flags
);

Parameters

flags
Flags.

See Also

TabGroupSequence Class | NETXP.Controls.Docking Namespace | TabGroupSequence.Compact Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupSequence.ContainsSelected Method

Gets whether or not the selected node is contained in this sequence.

[Visual Basic]
Overrides Public Function ContainsSelected( _
ByVal recurse As Boolean _
) As Boolean
[C#]
public override bool ContainsSelected(
bool recurse
);

Parameters

recurse
Go through all subgroups?

Return Value

True if the selected node is contained in this sequence.

See Also

TabGroupSequence Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupSequence.Dispose Method

Implements inherited member.

[Visual Basic]
Overrides Public Sub Dispose() Implements _
IDisposable.Dispose
[C#]
public override void Dispose();

Implements

IDisposable.Dispose

See Also

TabGroupSequence Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupSequence.EndResizeOperation Method

Finishes resize operation.

[Visual Basic]
NotOverridable Public Sub EndResizeOperation( _
ByVal bar As SizeBar, _
ByVal delta As Integer _
) Implements _
IResizeSource.EndResizeOperation
[C#]
public void EndResizeOperation(
SizeBar bar,
int delta
);

Parameters

bar
The size bar.
delta
The change in size.

Implements

IResizeSource.EndResizeOperation

See Also

TabGroupSequence Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupSequence.IndexOf Method

Gets the index of the specified node.

[Visual Basic]
Public Function IndexOf( _
ByVal group As TabGroupBase _
) As Integer
[C#]
public int IndexOf(
TabGroupBase group
);

Parameters

group
The node.

Return Value

The index.

See Also

TabGroupSequence Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupSequence.InsertNewNode Method

Inserts a new empty node at index.

[Visual Basic]
Public Function InsertNewNode( _
ByVal index As Integer _
) As TabGroupNode
[C#]
public TabGroupNode InsertNewNode(
int index
);

Parameters

index
The index.

Return Value

The node.

See Also

TabGroupSequence Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupSequence.LoadFromXml Method

Loads layout from XML.

[Visual Basic]
Overrides Public Sub LoadFromXml( _
ByVal xmlIn As XmlTextReader _
)
[C#]
public override void LoadFromXml(
XmlTextReader xmlIn
);

Parameters

xmlIn
The XML reader.

See Also

TabGroupSequence Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupSequence.Notify Method

Internal.

[Visual Basic]
Overrides Public Sub Notify( _
ByVal code As NotifyCode _
)
[C#]
public override void Notify(
NotifyCode code
);

Parameters

code

See Also

TabGroupSequence Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupSequence.ProportionalResize Method

Resizes all children proportionally.

[Visual Basic]
Public Sub ProportionalResize( _
ByVal recurse As Boolean _
)
[C#]
public void ProportionalResize(
bool recurse
);

Parameters

recurse
Go through subgroups?

See Also

TabGroupSequence Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupSequence.Remove Method

Removes a node.

[Visual Basic]
Public Sub Remove( _
ByVal group As TabGroupBase _
)
[C#]
public void Remove(
TabGroupBase group
);

Parameters

group
The node.

See Also

TabGroupSequence Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupSequence.RemoveAt Method

Removes a node at the specified index.

[Visual Basic]
Public Sub RemoveAt( _
ByVal index As Integer _
)
[C#]
public void RemoveAt(
int index
);

Parameters

index
The index.

See Also

TabGroupSequence Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupSequence.Reposition Method

Updates child layout to reflect new proportional spacing values.

[Visual Basic]
Public Sub Reposition()
[C#]
public void Reposition();

See Also

TabGroupSequence Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupSequence.SaveToXml Method

Saves layout to XML.

[Visual Basic]
Overrides Public Sub SaveToXml( _
ByVal xmlOut As XmlTextWriter _
)
[C#]
public override void SaveToXml(
XmlTextWriter xmlOut
);

Parameters

xmlOut
The XML writer.

See Also

TabGroupSequence Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabGroupSequence.StartResizeOperation Method

Begins resize operation.

[Visual Basic]
NotOverridable Public Function StartResizeOperation( _
ByVal bar As SizeBar, _
ByRef screenBoundary As Rectangle _
) As Boolean Implements _
IResizeSource.StartResizeOperation
[C#]
public bool StartResizeOperation(
SizeBar bar,
ref Rectangle screenBoundary
);

Parameters

bar
The size bar.
screenBoundary
The bounds of the screen.

Return Value

Allow resize operation to occur?

Implements

IResizeSource.StartResizeOperation

See Also

TabGroupSequence Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabPage Class

A tab page for NETXP.Controls.Docking.TabControl

For a list of all members of this type, see TabPage Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
Panel
TabPage

[Visual Basic]
NotInheritable Public Class TabPage
Inherits Panel
[C#]
public sealed class TabPage : Panel

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

TabPage Members | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabPage Members

TabPage overview

Public Instance Constructors

TabPage Overloaded. Initializes a new instance of the TabPage class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BorderStyle (inherited from Panel) | Indicates the border style for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Control | The control contained by the page.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font | Internal
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
Icon | The image or icon of the page.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Selected | Is this page selected?
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
StartFocus | The control that starts focused.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Panel) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Panel) |
Title | The title of the page.
ToolTipText | The text shown by the tooltip of the page.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Panel) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Panel) |
KeyPress (inherited from Panel) |
KeyUp (inherited from Panel) |
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PropertyChanged | A property has changed.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Panel) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

TabPage Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabPage Constructor

Constructs a new tab page.

Overload List

Constructs a new tab page.

public TabPage();

Constructs a new tab page with the specified title.

public TabPage(string);

Constructs a new tab page with the specified title and containing the specified control.

public TabPage(string,Control);

Constructs a new tab page with the specified title, containing the specified control, and having the specified icon.

public TabPage(string,Control,Image);

See Also

TabPage Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabPage Constructor ()

Constructs a new tab page.

[Visual Basic]
Overloads Public Sub New()
[C#]
public TabPage();

See Also

TabPage Class | NETXP.Controls.Docking Namespace | TabPage Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabPage Constructor (String)

Constructs a new tab page with the specified title.

[Visual Basic]
Overloads Public Sub New( _
ByVal title As String _
)
[C#]
public TabPage(
string title
);

Parameters

title
The title of the page.

See Also

TabPage Class | NETXP.Controls.Docking Namespace | TabPage Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabPage Constructor (String, Control)

Constructs a new tab page with the specified title and containing the specified control.

[Visual Basic]
Overloads Public Sub New( _
ByVal title As String, _
ByVal control As Control _
)
[C#]
public TabPage(
string title,
Control control
);

Parameters

title
The title of the page.
control
The control to be contained.

See Also

TabPage Class | NETXP.Controls.Docking Namespace | TabPage Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabPage Constructor (String, Control, Image)

Constructs a new tab page with the specified title, containing the specified control, and having the specified icon.

[Visual Basic]
Overloads Public Sub New( _
ByVal title As String, _
ByVal control As Control, _
ByVal icon As Image _
)
[C#]
public TabPage(
string title,
Control control,
Image icon
);

Parameters

title
The title of the page.
control
The control the page contains.
icon
The icon of the page.

See Also

TabPage Class | NETXP.Controls.Docking Namespace | TabPage Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabPage Properties

The properties of the TabPage class are listed below. For a complete list of TabPage class members, see the TabPage Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BorderStyle (inherited from Panel) | Indicates the border style for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Control | The control contained by the page.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font | Internal
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
Icon | The image or icon of the page.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Selected | Is this page selected?
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
StartFocus | The control that starts focused.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Panel) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Panel) |
Title | The title of the page.
ToolTipText | The text shown by the tooltip of the page.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

See Also

TabPage Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabPage.Control Property

The control contained by the page.

[Visual Basic]
Public Property Control As Control
[C#]
public System.Windows.Forms.Control Control {get; set;}

See Also

TabPage Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabPage.Font Property

Internal

[Visual Basic]
Overrides Public Property Font As Font
[C#]
public override System.Drawing.Font Font {get; set;}

See Also

TabPage Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabPage.Icon Property

The image or icon of the page.

[Visual Basic]
Public Property Icon As Image
[C#]
public System.Drawing.Image Icon {get; set;}

See Also

TabPage Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabPage.Selected Property

Is this page selected?

[Visual Basic]
Public Property Selected As Boolean
[C#]
public bool Selected {get; set;}

See Also

TabPage Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabPage.StartFocus Property

The control that starts focused.

[Visual Basic]
Public Property StartFocus As Control
[C#]
public System.Windows.Forms.Control StartFocus {get; set;}

See Also

TabPage Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabPage.Title Property

The title of the page.

[Visual Basic]
Public Property Title As String
[C#]
public string Title {get; set;}

See Also

TabPage Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabPage.ToolTipText Property

The text shown by the tooltip of the page.

[Visual Basic]
Public Property ToolTipText As String
[C#]
public string ToolTipText {get; set;}

See Also

TabPage Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabPage Events

The events of the TabPage class are listed below. For a complete list of TabPage class members, see the TabPage Members topic.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Panel) |
KeyPress (inherited from Panel) |
KeyUp (inherited from Panel) |
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PropertyChanged | A property has changed.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Panel) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

TabPage Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabPage.PropertyChanged Event

A property has changed.

[Visual Basic]
Public Event PropertyChanged As PropChangeHandler
[C#]
public event PropChangeHandler PropertyChanged;

See Also

TabPage Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabPage.PropChangeHandler Delegate

The property change event signature.

[Visual Basic]
Public Delegate Sub TabPage.PropChangeHandler( _
ByVal page As TabPage, _
ByVal prop As Property, _
ByVal oldValue As Object _
)
[C#]
public delegate void TabPage.PropChangeHandler(
TabPage page,
Property prop,
object oldValue
);

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabPage.Property Enumeration

Enumeration of property change events.

[Visual Basic]
Public Enum TabPage.Property
[C#]
public enum TabPage.Property

Members

Member Name | Description
Title | Title of the page has changed.
Control | Control contained by the page has changed.
Icon | Icon of the page has changed.
Selected | Page has been selected or deselected.

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabPageCollection Class

A collection of tab pages.

For a list of all members of this type, see TabPageCollection Members.

System.Object
CollectionBase
CollectionEx
TabPageCollection

[Visual Basic]
NotInheritable Public Class TabPageCollection
Inherits CollectionEx
[C#]
public sealed class TabPageCollection : CollectionEx

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

TabPageCollection Members | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabPageCollection Members

TabPageCollection overview

Public Instance Constructors

TabPageCollection Constructor Initializes a new instance of the TabPageCollection class.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
IsSuspended (inherited from CollectionEx) | Is event generation already suspended?
Item | Overloaded. Gets a tab page at the specified index.

Public Instance Methods

Add | Adds a tab page to the collection.
AddRange | Adds a bunch of tab pages.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Contains | Does the collection contain the specified tab page?
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Gets the index of a tab page.
Insert | Inserts a tab page at the specified location.
RaiseChanged (inherited from CollectionEx) | Raises the Changed event.
Remove | Removes a tab page.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
ResumeEvents (inherited from CollectionEx) | Resume event generation.
SuspendEvents (inherited from CollectionEx) | Suspend event generation.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

Changed (inherited from CollectionEx) | Event raised when the collection has changed.
Cleared (inherited from CollectionEx) | Event raised when collection has been cleared.
Clearing (inherited from CollectionEx) | Event raised when collection is being cleared.
Inserted (inherited from CollectionEx) | Event raised when an item has been inserted.
Inserting (inherited from CollectionEx) | Event raised when an item is being inserted.
Removed (inherited from CollectionEx) | Event raised when an item has been removed.
Removing (inherited from CollectionEx) | Event raised when an item is being removed.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

TabPageCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabPageCollection Constructor

Initializes a new instance of the TabPageCollection class.

[Visual Basic]
Public Sub New()
[C#]
public TabPageCollection();

See Also

TabPageCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabPageCollection Properties

The properties of the TabPageCollection class are listed below. For a complete list of TabPageCollection class members, see the TabPageCollection Members topic.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
IsSuspended (inherited from CollectionEx) | Is event generation already suspended?
Item | Overloaded. Gets a tab page at the specified index.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

TabPageCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Item Property

NetXP 3.0 Reference

TabPageCollection.Item Property

Gets a tab page at the specified index.

Overload List

Gets a tab page at the specified index.

public TabPage this[int] {get;}

Gets a tab page with the specified title.

public TabPage this[string] {get;}

See Also

TabPageCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabPageCollection.Item Property

Gets a tab page at the specified index.

[Visual Basic]
Overloads Public Default ReadOnly Property Item( _
ByVal index As Integer _
) As TabPage
[C#]
public TabPage this[
int index
] {get;}

See Also

TabPageCollection Class | NETXP.Controls.Docking Namespace | TabPageCollection.Item Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabPageCollection.Item Property

Gets a tab page with the specified title.

[Visual Basic]
Overloads Public Default ReadOnly Property Item( _
ByVal title As String _
) As TabPage
[C#]
public TabPage this[
string title
] {get;}

See Also

TabPageCollection Class | NETXP.Controls.Docking Namespace | TabPageCollection.Item Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabPageCollection Methods

The methods of the TabPageCollection class are listed below. For a complete list of TabPageCollection class members, see the TabPageCollection Members topic.

Public Instance Methods

Add | Adds a tab page to the collection.
AddRange | Adds a bunch of tab pages.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Contains | Does the collection contain the specified tab page?
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Gets the index of a tab page.
Insert | Inserts a tab page at the specified location.
RaiseChanged (inherited from CollectionEx) | Raises the Changed event.
Remove | Removes a tab page.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
ResumeEvents (inherited from CollectionEx) | Resume event generation.
SuspendEvents (inherited from CollectionEx) | Suspend event generation.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

TabPageCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabPageCollection.Add Method

Adds a tab page to the collection.

[Visual Basic]
Public Function Add( _
ByVal value As TabPage _
) As Integer
[C#]
public int Add(
TabPage value
);

Parameters

value
The tab page to be added.

Return Value

The index of the tab page.

See Also

TabPageCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabPageCollection.AddRange Method

Adds a bunch of tab pages.

[Visual Basic]
Public Sub AddRange( _
ByVal values As TabPage() _
)
[C#]
public void AddRange(
TabPage[] values
);

Parameters

values
The tab pages.

See Also

TabPageCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabPageCollection.Contains Method

Does the collection contain the specified tab page?

[Visual Basic]
Public Function Contains( _
ByVal value As TabPage _
) As Boolean
[C#]
public bool Contains(
TabPage value
);

Parameters

value
The tab page.

Return Value

True if the collection contains the specified tab page.

See Also

TabPageCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabPageCollection.IndexOf Method

Gets the index of a tab page.

[Visual Basic]
Public Function IndexOf( _
ByVal value As TabPage _
) As Integer
[C#]
public int IndexOf(
TabPage value
);

Parameters

value
The tab page.

Return Value

The index of the tab page.

See Also

TabPageCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabPageCollection.Insert Method

Inserts a tab page at the specified location.

[Visual Basic]
Public Sub Insert( _
ByVal index As Integer, _
ByVal value As TabPage _
)
[C#]
public void Insert(
int index,
TabPage value
);

Parameters

index
Where to insert tab page.
value
Tab page to insert.

See Also

TabPageCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabPageCollection.Remove Method

Removes a tab page.

[Visual Basic]
Public Sub Remove( _
ByVal value As TabPage _
)
[C#]
public void Remove(
TabPage value
);

Parameters

value
The tab page.

See Also

TabPageCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


TabPosition Enumeration

Enumeration of tab positions.

[Visual Basic]
Public Enum TabPosition
[C#]
public enum TabPosition

Members

Member Name | Description
Top | Tabs at the top, as in tabbed MDI.
Bottom | Tabs at the bottom, as in tabbed docking windows.

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


UpdateName Enumeration

Properties to propagate.

[Visual Basic]
Public Enum UpdateName
[C#]
public enum UpdateName

Members

Member Name | Description
SizeBarWidth | The resize bar vector.
DockRegionMinMax | DockRegion min/max?
Renderer | The renderer.
CaptionFont | The font of the DockFrameCaption.

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


VerticalTab Class

Internal.

For a list of all members of this type, see VerticalTab Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
VerticalTab

[Visual Basic]
Public Class VerticalTab
Inherits UserControl
[C#]
public class VerticalTab : UserControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

VerticalTab Members | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


VerticalTab Members

VerticalTab overview

Public Static (Shared) Methods

VerticalTabVector Internal.

Public Instance Constructors

VerticalTab Constructor Internal.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor | Internal.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Edging | Internal.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font | Internal.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
SelectedIndex | Internal.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabPages | Internal.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

AdjustRectForEdge | Internal.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
UpdateNameValue | Internal.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PageClicked | Internal.
PageOver | Internal.
PagesLeave | Internal.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

VerticalTab Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


VerticalTab Constructor

Internal.

[Visual Basic]
Public Sub New( _
ByVal renderer As IDockingRenderer _
)
[C#]
public VerticalTab(
IDockingRenderer renderer
);

Parameters

renderer

See Also

VerticalTab Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


VerticalTab Properties

The properties of the VerticalTab class are listed below. For a complete list of VerticalTab class members, see the VerticalTab Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor | Internal.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Edging | Internal.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font | Internal.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
SelectedIndex | Internal.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabPages | Internal.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

VerticalTab Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


VerticalTab.BackColor Property

Internal.

[Visual Basic]
Overrides Public Property BackColor As Color
[C#]
public override System.Drawing.Color BackColor {get; set;}

See Also

VerticalTab Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


VerticalTab.Edging Property

Internal.

[Visual Basic]
Public Property Edging As Edge
[C#]
public NETXP.Library.Edge Edging {get; set;}

See Also

VerticalTab Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


VerticalTab.Font Property

Internal.

[Visual Basic]
Overrides Public Property Font As Font
[C#]
public override System.Drawing.Font Font {get; set;}

See Also

VerticalTab Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


VerticalTab.SelectedIndex Property

Internal.

[Visual Basic]
Public Property SelectedIndex As Integer
[C#]
public int SelectedIndex {get; set;}

See Also

VerticalTab Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


VerticalTab.TabPages Property

Internal.

[Visual Basic]
Public Property TabPages As TabPageCollection
[C#]
public TabPageCollection TabPages {get; set;}

See Also

VerticalTab Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


VerticalTab Methods

The methods of the VerticalTab class are listed below. For a complete list of VerticalTab class members, see the VerticalTab Members topic.

Public Static (Shared) Methods

VerticalTabVector Internal.

Public Instance Methods

AdjustRectForEdge | Internal.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
UpdateNameValue | Internal.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

VerticalTab Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


VerticalTab.AdjustRectForEdge Method

Internal.

[Visual Basic]
Public Sub AdjustRectForEdge( _
ByRef rect As Rectangle _
)
[C#]
public void AdjustRectForEdge(
ref Rectangle rect
);

Parameters

rect

See Also

VerticalTab Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


VerticalTab.UpdateNameValue Method

Internal.

[Visual Basic]
Public Sub UpdateNameValue( _
ByVal name As UpdateName, _
ByVal value As Object _
)
[C#]
public void UpdateNameValue(
UpdateName name,
object value
);

Parameters

name
value

See Also

VerticalTab Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


VerticalTab.VerticalTabVector Method

Internal.

[Visual Basic]
Public Shared Function VerticalTabVector( _
ByVal font As Font _
) As Integer
[C#]
public static int VerticalTabVector(
Font font
);

Parameters

font

Return Value

See Also

VerticalTab Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


VerticalTab Events

The events of the VerticalTab class are listed below. For a complete list of VerticalTab class members, see the VerticalTab Members topic.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PageClicked | Internal.
PageOver | Internal.
PagesLeave | Internal.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

VerticalTab Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


VerticalTab.PageClicked Event

Internal.

[Visual Basic]
Public Event PageClicked As VerticalTabIndexHandler
[C#]
public event VerticalTabIndexHandler PageClicked;

See Also

VerticalTab Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


VerticalTab.PageOver Event

Internal.

[Visual Basic]
Public Event PageOver As VerticalTabIndexHandler
[C#]
public event VerticalTabIndexHandler PageOver;

See Also

VerticalTab Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


VerticalTab.PagesLeave Event

Internal.

[Visual Basic]
Public Event PagesLeave As VerticalTabHandler
[C#]
public event VerticalTabHandler PagesLeave;

See Also

VerticalTab Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


VerticalTab.VerticalTabHandler Delegate

Internal.

[Visual Basic]
Public Delegate Sub VerticalTab.VerticalTabHandler( _
ByVal sender As VerticalTab _
)
[C#]
public delegate void VerticalTab.VerticalTabHandler(
VerticalTab sender
);

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


VerticalTab.VerticalTabIndexHandler Delegate

Internal.

[Visual Basic]
Public Delegate Sub VerticalTab.VerticalTabIndexHandler( _
ByVal sender As VerticalTab, _
ByVal pageIndex As Integer _
)
[C#]
public delegate void VerticalTab.VerticalTabIndexHandler(
VerticalTab sender,
int pageIndex
);

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Window Class

Internal.

For a list of all members of this type, see Window Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Window

[Visual Basic]
Public Class Window
Inherits ContainerControl
[C#]
public class Window : ContainerControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

Window Members | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Window Members

Window overview

Public Instance Constructors

Window Constructor Internal.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoDispose | Internal.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockFrames | Internal.
DockingManager | Internal.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
DockRegionArea | Internal.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FullTitle | Internal.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MinimalSize | Internal.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentDockRegion | Internal.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
RedockAllowed | Internal.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
State | Internal.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DockFrameGotFocus | Internal.
DockFrameLostFocus | Internal.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
HideDetails | Internal.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
NotifyAutoHideImage | Internal.
NotifyCloseButton | Internal.
NotifyDockObjectGotFocus | Internal.
NotifyDockObjectLostFocus | Internal.
NotifyFullTitleText | Internal.
NotifyHideButton | Internal.
NotifyShowCaptionBar | Internal.
OnFullTitleChanged | Internal.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RecordRestore | Internal.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
ShowDetails | Internal.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
UpdateNameValue | Internal.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FullTitleChanged | Internal.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

Window Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Window Constructor

Internal.

[Visual Basic]
Public Sub New( _
ByVal manager As DockingManager _
)
[C#]
public Window(
DockingManager manager
);

Parameters

manager

See Also

Window Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Window Properties

The properties of the Window class are listed below. For a complete list of Window class members, see the Window Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoDispose | Internal.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockFrames | Internal.
DockingManager | Internal.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
DockRegionArea | Internal.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FullTitle | Internal.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MinimalSize | Internal.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentDockRegion | Internal.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
RedockAllowed | Internal.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
State | Internal.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

Window Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Window.AutoDispose Property

Internal.

[Visual Basic]
Public Property AutoDispose As Boolean
[C#]
public bool AutoDispose {get; set;}

See Also

Window Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Window.DockFrames Property

Internal.

[Visual Basic]
Public Property DockFrames As DockFrameCollection
[C#]
public DockFrameCollection DockFrames {get; set;}

See Also

Window Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Window.DockingManager Property

Internal.

[Visual Basic]
Public ReadOnly Property DockingManager As DockingManager
[C#]
public DockingManager DockingManager {get;}

See Also

Window Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Window.DockRegionArea Property

Internal.

[Visual Basic]
Public Property DockRegionArea As Decimal
[C#]
public decimal DockRegionArea {get; set;}

See Also

Window Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Window.FullTitle Property

Internal.

[Visual Basic]
Public ReadOnly Property FullTitle As String
[C#]
public string FullTitle {get;}

See Also

Window Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Window.MinimalSize Property

Internal.

[Visual Basic]
Public Property MinimalSize As Size
[C#]
public System.Drawing.Size MinimalSize {get; set;}

See Also

Window Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Window.ParentDockRegion Property

Internal.

[Visual Basic]
Public Property ParentDockRegion As DockRegion
[C#]
public DockRegion ParentDockRegion {get; set;}

See Also

Window Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Window.RedockAllowed Property

Internal.

[Visual Basic]
Public Property RedockAllowed As Boolean
[C#]
public bool RedockAllowed {get; set;}

See Also

Window Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Window.State Property

Internal.

[Visual Basic]
Public Property State As State
[C#]
public State State {get; set;}

See Also

Window Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Window Methods

The methods of the Window class are listed below. For a complete list of Window class members, see the Window Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DockFrameGotFocus | Internal.
DockFrameLostFocus | Internal.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
HideDetails | Internal.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
NotifyAutoHideImage | Internal.
NotifyCloseButton | Internal.
NotifyDockObjectGotFocus | Internal.
NotifyDockObjectLostFocus | Internal.
NotifyFullTitleText | Internal.
NotifyHideButton | Internal.
NotifyShowCaptionBar | Internal.
OnFullTitleChanged | Internal.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RecordRestore | Internal.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
ShowDetails | Internal.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
UpdateNameValue | Internal.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

Window Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Window.DockFrameGotFocus Method

Internal.

[Visual Basic]
Overridable Public Sub DockFrameGotFocus( _
ByVal wd As DockFrame _
)
[C#]
public virtual void DockFrameGotFocus(
DockFrame wd
);

Parameters

wd

See Also

Window Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Window.DockFrameLostFocus Method

Internal.

[Visual Basic]
Overridable Public Sub DockFrameLostFocus( _
ByVal wd As DockFrame _
)
[C#]
public virtual void DockFrameLostFocus(
DockFrame wd
);

Parameters

wd

See Also

Window Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Window.HideDetails Method

Internal.

[Visual Basic]
Public Sub HideDetails()
[C#]
public void HideDetails();

See Also

Window Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Window.NotifyAutoHideImage Method

Internal.

[Visual Basic]
Overridable Public Sub NotifyAutoHideImage( _
ByVal autoHidden As Boolean _
)
[C#]
public virtual void NotifyAutoHideImage(
bool autoHidden
);

Parameters

autoHidden

See Also

Window Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Window.NotifyCloseButton Method

Internal.

[Visual Basic]
Overridable Public Sub NotifyCloseButton( _
ByVal show As Boolean _
)
[C#]
public virtual void NotifyCloseButton(
bool show
);

Parameters

show

See Also

Window Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Window.NotifyDockObjectGotFocus Method

Internal.

[Visual Basic]
Overridable Public Sub NotifyDockObjectGotFocus()
[C#]
public virtual void NotifyDockObjectGotFocus();

See Also

Window Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Window.NotifyDockObjectLostFocus Method

Internal.

[Visual Basic]
Overridable Public Sub NotifyDockObjectLostFocus()
[C#]
public virtual void NotifyDockObjectLostFocus();

See Also

Window Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Window.NotifyFullTitleText Method

Internal.

[Visual Basic]
Overridable Public Sub NotifyFullTitleText( _
ByVal title As String _
)
[C#]
public virtual void NotifyFullTitleText(
string title
);

Parameters

title

See Also

Window Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Window.NotifyHideButton Method

Internal.

[Visual Basic]
Overridable Public Sub NotifyHideButton( _
ByVal show As Boolean _
)
[C#]
public virtual void NotifyHideButton(
bool show
);

Parameters

show

See Also

Window Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Window.NotifyShowCaptionBar Method

Internal.

[Visual Basic]
Overridable Public Sub NotifyShowCaptionBar( _
ByVal show As Boolean _
)
[C#]
public virtual void NotifyShowCaptionBar(
bool show
);

Parameters

show

See Also

Window Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Window.OnFullTitleChanged Method

Internal.

[Visual Basic]
Overridable Public Sub OnFullTitleChanged( _
ByVal fullTitle As String _
)
[C#]
public virtual void OnFullTitleChanged(
string fullTitle
);

Parameters

fullTitle

See Also

Window Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Window.RecordRestore Method

Internal.

[Visual Basic]
Overridable Public Function RecordRestore( _
ByVal child As Object _
) As Restore
[C#]
public virtual Restore RecordRestore(
object child
);

Parameters

child

Return Value

See Also

Window Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Window.ShowDetails Method

Internal.

[Visual Basic]
Public Sub ShowDetails()
[C#]
public void ShowDetails();

See Also

Window Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Window.UpdateNameValue Method

Internal.

[Visual Basic]
Overridable Public Sub UpdateNameValue( _
ByVal name As UpdateName, _
ByVal value As Object _
)
[C#]
public virtual void UpdateNameValue(
UpdateName name,
object value
);

Parameters

name
value

See Also

Window Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Window Events

The events of the Window class are listed below. For a complete list of Window class members, see the Window Members topic.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FullTitleChanged | Internal.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

Window Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


Window.FullTitleChanged Event

Internal.

[Visual Basic]
Public Event FullTitleChanged As EventHandler
[C#]
public event EventHandler FullTitleChanged;

See Also

Window Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


WindowCollection Class

Internal.

For a list of all members of this type, see WindowCollection Members.

System.Object
CollectionBase
CollectionEx
WindowCollection

[Visual Basic]
NotInheritable Public Class WindowCollection
Inherits CollectionEx
[C#]
public sealed class WindowCollection : CollectionEx

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

WindowCollection Members | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


WindowCollection Members

WindowCollection overview

Public Instance Constructors

WindowCollection Constructor Initializes a new instance of the WindowCollection class.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
IsSuspended (inherited from CollectionEx) | Is event generation already suspended?
Item | Internal.

Public Instance Methods

Add | Internal.
AddRange | Internal.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Contains | Internal.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Internal.
Insert | Internal.
RaiseChanged (inherited from CollectionEx) | Raises the Changed event.
Remove | Internal.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
ResumeEvents (inherited from CollectionEx) | Resume event generation.
SuspendEvents (inherited from CollectionEx) | Suspend event generation.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

Changed (inherited from CollectionEx) | Event raised when the collection has changed.
Cleared (inherited from CollectionEx) | Event raised when collection has been cleared.
Clearing (inherited from CollectionEx) | Event raised when collection is being cleared.
Inserted (inherited from CollectionEx) | Event raised when an item has been inserted.
Inserting (inherited from CollectionEx) | Event raised when an item is being inserted.
Removed (inherited from CollectionEx) | Event raised when an item has been removed.
Removing (inherited from CollectionEx) | Event raised when an item is being removed.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

WindowCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


WindowCollection Constructor

Initializes a new instance of the WindowCollection class.

[Visual Basic]
Public Sub New()
[C#]
public WindowCollection();

See Also

WindowCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


WindowCollection Properties

The properties of the WindowCollection class are listed below. For a complete list of WindowCollection class members, see the WindowCollection Members topic.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
IsSuspended (inherited from CollectionEx) | Is event generation already suspended?
Item | Internal.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

WindowCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


WindowCollection.Item Property

Internal.

[Visual Basic]
Public Default ReadOnly Property Item( _
ByVal index As Integer _
) As Window
[C#]
public Window this[
int index
] {get;}

See Also

WindowCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


WindowCollection Methods

The methods of the WindowCollection class are listed below. For a complete list of WindowCollection class members, see the WindowCollection Members topic.

Public Instance Methods

Add | Internal.
AddRange | Internal.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Contains | Internal.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Internal.
Insert | Internal.
RaiseChanged (inherited from CollectionEx) | Raises the Changed event.
Remove | Internal.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
ResumeEvents (inherited from CollectionEx) | Resume event generation.
SuspendEvents (inherited from CollectionEx) | Suspend event generation.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

WindowCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


WindowCollection.Add Method

Internal.

[Visual Basic]
Public Function Add( _
ByVal value As Window _
) As Window
[C#]
public Window Add(
Window value
);

Parameters

value

Return Value

See Also

WindowCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


WindowCollection.AddRange Method

Internal.

[Visual Basic]
Public Sub AddRange( _
ByVal values As Window() _
)
[C#]
public void AddRange(
Window[] values
);

Parameters

values

See Also

WindowCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


WindowCollection.Contains Method

Internal.

[Visual Basic]
Public Function Contains( _
ByVal value As Window _
) As Boolean
[C#]
public bool Contains(
Window value
);

Parameters

value

Return Value

See Also

WindowCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


WindowCollection.IndexOf Method

Internal.

[Visual Basic]
Public Function IndexOf( _
ByVal value As Window _
) As Integer
[C#]
public int IndexOf(
Window value
);

Parameters

value

Return Value

See Also

WindowCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


WindowCollection.Insert Method

Internal.

[Visual Basic]
Public Sub Insert( _
ByVal index As Integer, _
ByVal value As Window _
)
[C#]
public void Insert(
int index,
Window value
);

Parameters

index
value

See Also

WindowCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


WindowCollection.Remove Method

Internal.

[Visual Basic]
Public Sub Remove( _
ByVal value As Window _
)
[C#]
public void Remove(
Window value
);

Parameters

value

See Also

WindowCollection Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


WindowObjects Class

Internal.

For a list of all members of this type, see WindowObjects Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Window
WindowObjects

[Visual Basic]
Public Class WindowObjects
Inherits Window
[C#]
public class WindowObjects : Window

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.Docking

Assembly: NETXP.Controls.Docking (in NETXP.Controls.Docking.dll)

See Also

WindowObjects Members | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


WindowObjects Members

WindowObjects overview

Public Instance Constructors

WindowObjects Constructor Internal.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoDispose (inherited from Window) | Internal.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockFrames (inherited from Window) | Internal.
DockingManager (inherited from Window) | Internal.
DockObjects | Internal.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
DockRegionArea (inherited from Window) | Internal.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FullTitle (inherited from Window) | Internal.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MinimalSize (inherited from Window) | Internal.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentDockRegion (inherited from Window) | Internal.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
RedockAllowed (inherited from Window) | Internal.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
State (inherited from Window) | Internal.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringDockObjectToFront | Internal.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DockFrameGotFocus (inherited from Window) | Internal.
DockFrameLostFocus (inherited from Window) | Internal.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
HideDetails (inherited from Window) | Internal.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
NotifyAutoHideImage (inherited from Window) | Internal.
NotifyCloseButton (inherited from Window) | Internal.
NotifyDockObjectGotFocus (inherited from Window) | Internal.
NotifyDockObjectLostFocus (inherited from Window) | Internal.
NotifyFullTitleText (inherited from Window) | Internal.
NotifyHideButton (inherited from Window) | Internal.
NotifyShowCaptionBar (inherited from Window) | Internal.
OnFullTitleChanged (inherited from Window) | Internal.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RecordRestore (inherited from Window) | Internal.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
ShowDetails (inherited from Window) | Internal.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
UpdateNameValue (inherited from Window) | Internal.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FullTitleChanged (inherited from Window) | Internal.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

WindowObjects Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


WindowObjects Constructor

Internal.

[Visual Basic]
Public Sub New( _
ByVal manager As DockingManager, _
ByVal renderer As IDockingRenderer _
)
[C#]
public WindowObjects(
DockingManager manager,
IDockingRenderer renderer
);

Parameters

manager
renderer

See Also

WindowObjects Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


WindowObjects Properties

The properties of the WindowObjects class are listed below. For a complete list of WindowObjects class members, see the WindowObjects Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoDispose (inherited from Window) | Internal.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockFrames (inherited from Window) | Internal.
DockingManager (inherited from Window) | Internal.
DockObjects | Internal.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
DockRegionArea (inherited from Window) | Internal.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FullTitle (inherited from Window) | Internal.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MinimalSize (inherited from Window) | Internal.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentDockRegion (inherited from Window) | Internal.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
RedockAllowed (inherited from Window) | Internal.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
State (inherited from Window) | Internal.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

WindowObjects Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


WindowObjects.DockObjects Property

Internal.

[Visual Basic]
Public Property DockObjects As DockObjectCollection
[C#]
public DockObjectCollection DockObjects {get; set;}

See Also

WindowObjects Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


WindowObjects Methods

The methods of the WindowObjects class are listed below. For a complete list of WindowObjects class members, see the WindowObjects Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringDockObjectToFront | Internal.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DockFrameGotFocus (inherited from Window) | Internal.
DockFrameLostFocus (inherited from Window) | Internal.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
HideDetails (inherited from Window) | Internal.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
NotifyAutoHideImage (inherited from Window) | Internal.
NotifyCloseButton (inherited from Window) | Internal.
NotifyDockObjectGotFocus (inherited from Window) | Internal.
NotifyDockObjectLostFocus (inherited from Window) | Internal.
NotifyFullTitleText (inherited from Window) | Internal.
NotifyHideButton (inherited from Window) | Internal.
NotifyShowCaptionBar (inherited from Window) | Internal.
OnFullTitleChanged (inherited from Window) | Internal.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RecordRestore (inherited from Window) | Internal.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
ShowDetails (inherited from Window) | Internal.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
UpdateNameValue (inherited from Window) | Internal.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

WindowObjects Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


WindowObjects.BringDockObjectToFront Method

Internal.

[Visual Basic]
Overridable Public Sub BringDockObjectToFront( _
ByVal c As DockObject _
)
[C#]
public virtual void BringDockObjectToFront(
DockObject c
);

Parameters

c

See Also

WindowObjects Class | NETXP.Controls.Docking Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.Docking [3.0.5600.2205]


NETXP.Controls.TaskPane

NetXP 3.0 Reference

NETXP.Controls.TaskPane Namespace

Classes

Class | Description
GroupEventArgs | Provides data for the GroupStateChanged event.
XPLink | XPLink is a link which behaves XP-style and has an icon.
XPTaskPane | XPTaskPane holds XPTaskPaneGroups.
XPTaskPaneGroup | An extended Panel that provides task pane groups like those provided in Windows XP.

Delegates

Delegate | Description
GroupStateChangedEventHandler | A delegate type for hooking up group state change notifications.

Enumerations

Enumeration | Description
GroupState | Defines the state of a XPTaskPaneGroup.


GroupEventArgs Class

Provides data for the GroupStateChanged event.

For a list of all members of this type, see GroupEventArgs Members.

System.Object
EventArgs
GroupEventArgs

[Visual Basic]
Public Class GroupEventArgs
Inherits EventArgs
[C#]
public class GroupEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.TaskPane

Assembly: NETXP.Controls.TaskPane (in NETXP.Controls.TaskPane.dll)

See Also

GroupEventArgs Members | NETXP.Controls.TaskPane Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.TaskPane [3.0.5600.2205]


GroupEventArgs Members

GroupEventArgs overview

Public Instance Constructors

GroupEventArgs Constructor Initialises a new GroupEventArgs.

Public Instance Properties

GroupState | Gets the GroupState of the XPTaskPaneGroup that triggered the event.
XPTaskPaneGroup | Gets the XPTaskPaneGroup that triggered the event.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

GroupEventArgs Class | NETXP.Controls.TaskPane Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.TaskPane [3.0.5600.2205]


GroupEventArgs Constructor

Initialises a new GroupEventArgs.

[Visual Basic]
Public Sub New( _
ByVal sender As XPTaskPaneGroup _
)
[C#]
public GroupEventArgs(
XPTaskPaneGroup sender
);

Parameters

sender
The originating XPTaskPaneGroup.

See Also

GroupEventArgs Class | NETXP.Controls.TaskPane Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.TaskPane [3.0.5600.2205]


GroupEventArgs Properties

The properties of the GroupEventArgs class are listed below. For a complete list of GroupEventArgs class members, see the GroupEventArgs Members topic.

Public Instance Properties

GroupState | Gets the GroupState of the XPTaskPaneGroup that triggered the event.
XPTaskPaneGroup | Gets the XPTaskPaneGroup that triggered the event.

See Also

GroupEventArgs Class | NETXP.Controls.TaskPane Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.TaskPane [3.0.5600.2205]


GroupEventArgs.GroupState Property

Gets the GroupState of the XPTaskPaneGroup that triggered the event.

[Visual Basic]
Public ReadOnly Property GroupState As GroupState
[C#]
public GroupState GroupState {get;}

See Also

GroupEventArgs Class | NETXP.Controls.TaskPane Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.TaskPane [3.0.5600.2205]


GroupEventArgs.XPTaskPaneGroup Property

Gets the XPTaskPaneGroup that triggered the event.

[Visual Basic]
Public ReadOnly Property XPTaskPaneGroup As XPTaskPaneGroup
[C#]
public XPTaskPaneGroup XPTaskPaneGroup {get;}

See Also

GroupEventArgs Class | NETXP.Controls.TaskPane Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.TaskPane [3.0.5600.2205]


GroupState Enumeration

Defines the state of a XPTaskPaneGroup.

[Visual Basic]
Public Enum GroupState
[C#]
public enum GroupState

Members

Member Name | Description
Expanded | The XPTaskPaneGroup is expanded.
Collapsed | The XPTaskPaneGroup is collapsed.

Requirements

Namespace: NETXP.Controls.TaskPane

Assembly: NETXP.Controls.TaskPane (in NETXP.Controls.TaskPane.dll)

See Also

NETXP.Controls.TaskPane Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.TaskPane [3.0.5600.2205]


GroupStateChangedEventHandler Delegate

A delegate type for hooking up group state change notifications.

[Visual Basic]
Public Delegate Sub GroupStateChangedEventHandler( _
ByVal sender As Object, _
ByVal e As GroupEventArgs _
)
[C#]
public delegate void GroupStateChangedEventHandler(
object sender,
GroupEventArgs e
);

Requirements

Namespace: NETXP.Controls.TaskPane

Assembly: NETXP.Controls.TaskPane (in NETXP.Controls.TaskPane.dll)

See Also

NETXP.Controls.TaskPane Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.TaskPane [3.0.5600.2205]


XPLink Class

XPLink is a link which behaves XP-style and has an icon.

For a list of all members of this type, see XPLink Members.

System.Object
MarshalByRefObject
Component
Control
Label
XPLink

[Visual Basic]
Public Class XPLink
Inherits Label
[C#]
public class XPLink : Label

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.TaskPane

Assembly: NETXP.Controls.TaskPane (in NETXP.Controls.TaskPane.dll)

See Also

XPLink Members | NETXP.Controls.TaskPane Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.TaskPane [3.0.5600.2205]


XPLink Members

XPLink overview

Public Instance Constructors

XPLink Constructor Creates a new XPLink.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoSize (inherited from Label) | Gets or sets a value indicating whether the control is automatically resized to display its entire contents.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Label) |
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BorderStyle (inherited from Label) | Gets or sets the border style for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
ColorTable | Gets or sets the color table used by the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
FlatStyle (inherited from Label) | Gets or sets the flat style appearance of the label control.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HotForeColor | Gets or sets the foreground color of the control when the mouse is over it.
Image (inherited from Label) | Gets or sets the image that is displayed on a Label.
ImageAlign (inherited from Label) | Gets or sets the alignment of an image that is displayed in the control.
ImageIndex (inherited from Label) | Gets or sets the index value of the image displayed on the Label.
ImageList (inherited from Label) | Gets or sets the ImageList that contains the images to display in the Label control.
ImeMode (inherited from Label) |
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PreferredHeight (inherited from Label) | Gets the preferred height of the control.
PreferredWidth (inherited from Label) | Gets the preferred width of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Label) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextAlign (inherited from Label) | Gets or sets the alignment of text in the label.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseColorTable | Use the default XP-style colors for the link? (Set this to True for a task pane link, or False for a standalone link)
UseMnemonic (inherited from Label) | Gets or sets a value indicating whether the control interprets an ampersand character (&) in the control's Text property to be an access key prefix character.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Label) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

AutoSizeChanged (inherited from Label) | Occurs when the value of the AutoSize property has changed.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Label) |
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Label) |
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Label) |
KeyPress (inherited from Label) |
KeyUp (inherited from Label) |
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Label) |
TextAlignChanged (inherited from Label) | Occurs when the value of the TextAlign property has changed.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

XPLink Class | NETXP.Controls.TaskPane Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.TaskPane [3.0.5600.2205]


XPLink Constructor

Creates a new XPLink.

[Visual Basic]
Public Sub New()
[C#]
public XPLink();

See Also

XPLink Class | NETXP.Controls.TaskPane Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.TaskPane [3.0.5600.2205]


XPLink Properties

The properties of the XPLink class are listed below. For a complete list of XPLink class members, see the XPLink Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoSize (inherited from Label) | Gets or sets a value indicating whether the control is automatically resized to display its entire contents.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Label) |
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BorderStyle (inherited from Label) | Gets or sets the border style for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
ColorTable | Gets or sets the color table used by the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
FlatStyle (inherited from Label) | Gets or sets the flat style appearance of the label control.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HotForeColor | Gets or sets the foreground color of the control when the mouse is over it.
Image (inherited from Label) | Gets or sets the image that is displayed on a Label.
ImageAlign (inherited from Label) | Gets or sets the alignment of an image that is displayed in the control.
ImageIndex (inherited from Label) | Gets or sets the index value of the image displayed on the Label.
ImageList (inherited from Label) | Gets or sets the ImageList that contains the images to display in the Label control.
ImeMode (inherited from Label) |
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PreferredHeight (inherited from Label) | Gets the preferred height of the control.
PreferredWidth (inherited from Label) | Gets the preferred width of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Label) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextAlign (inherited from Label) | Gets or sets the alignment of text in the label.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseColorTable | Use the default XP-style colors for the link? (Set this to True for a task pane link, or False for a standalone link)
UseMnemonic (inherited from Label) | Gets or sets a value indicating whether the control interprets an ampersand character (&) in the control's Text property to be an access key prefix character.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

See Also

XPLink Class | NETXP.Controls.TaskPane Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.TaskPane [3.0.5600.2205]


XPLink.ColorTable Property

Gets or sets the color table used by the control.

[Visual Basic]
Public Property ColorTable As IColorTable
[C#]
public NETXP.Library.IColorTable ColorTable {get; set;}

See Also

XPLink Class | NETXP.Controls.TaskPane Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.TaskPane [3.0.5600.2205]


XPLink.HotForeColor Property

Gets or sets the foreground color of the control when the mouse is over it.

[Visual Basic]
Public Property HotForeColor As Color
[C#]
public System.Drawing.Color HotForeColor {get; set;}

See Also

XPLink Class | NETXP.Controls.TaskPane Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.TaskPane [3.0.5600.2205]


XPLink.UseColorTable Property

Use the default XP-style colors for the link? (Set this to True for a task pane link, or False for a standalone link)

[Visual Basic]
Public Property UseColorTable As Boolean
[C#]
public bool UseColorTable {get; set;}

See Also

XPLink Class | NETXP.Controls.TaskPane Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.TaskPane [3.0.5600.2205]


XPTaskPane Class

XPTaskPane holds XPTaskPaneGroups.

For a list of all members of this type, see XPTaskPane Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
XPTaskPane

[Visual Basic]
NotInheritable Public Class XPTaskPane
Inherits ContainerControl
[C#]
public sealed class XPTaskPane : ContainerControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.TaskPane

Assembly: NETXP.Controls.TaskPane (in NETXP.Controls.TaskPane.dll)

See Also

XPTaskPane Members | NETXP.Controls.TaskPane Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.TaskPane [3.0.5600.2205]


XPTaskPane Members

XPTaskPane overview

Public Instance Constructors

XPTaskPane Constructor Creates a new task pane.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor | Hides this member.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
ColorTable | Gets or sets the color table used by the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
GroupMoved | Called when a group has moved in the taskpane, or been resized.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

XPTaskPane Class | NETXP.Controls.TaskPane Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.TaskPane [3.0.5600.2205]


XPTaskPane Constructor

Creates a new task pane.

[Visual Basic]
Public Sub New()
[C#]
public XPTaskPane();

See Also

XPTaskPane Class | NETXP.Controls.TaskPane Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.TaskPane [3.0.5600.2205]


XPTaskPane Properties

The properties of the XPTaskPane class are listed below. For a complete list of XPTaskPane class members, see the XPTaskPane Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor | Hides this member.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
ColorTable | Gets or sets the color table used by the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

XPTaskPane Class | NETXP.Controls.TaskPane Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.TaskPane [3.0.5600.2205]


XPTaskPane.BackColor Property

Hides this member.

[Visual Basic]
Overrides Public Property BackColor As Color
[C#]
public override System.Drawing.Color BackColor {get; set;}

See Also

XPTaskPane Class | NETXP.Controls.TaskPane Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.TaskPane [3.0.5600.2205]


XPTaskPane.ColorTable Property

Gets or sets the color table used by the control.

[Visual Basic]
Public Property ColorTable As IColorTable
[C#]
public NETXP.Library.IColorTable ColorTable {get; set;}

See Also

XPTaskPane Class | NETXP.Controls.TaskPane Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.TaskPane [3.0.5600.2205]


XPTaskPane Methods

The methods of the XPTaskPane class are listed below. For a complete list of XPTaskPane class members, see the XPTaskPane Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
GroupMoved | Called when a group has moved in the taskpane, or been resized.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

XPTaskPane Class | NETXP.Controls.TaskPane Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.TaskPane [3.0.5600.2205]


XPTaskPane.GroupMoved Method

Called when a group has moved in the taskpane, or been resized.

[Visual Basic]
Public Sub GroupMoved( _
ByVal name As String, _
ByVal delta As Integer, _
ByVal top As Integer _
)
[C#]
public void GroupMoved(
string name,
int delta,
int top
);

Parameters

name
The name of the control.
delta
The amount of pixels it moved vertically.
top
The top position of the control.

See Also

XPTaskPane Class | NETXP.Controls.TaskPane Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.TaskPane [3.0.5600.2205]


XPTaskPaneGroup Class

An extended Panel that provides task pane groups like those provided in Windows XP.

For a list of all members of this type, see XPTaskPaneGroup Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
XPTaskPaneGroup

[Visual Basic]
Public Class XPTaskPaneGroup
Inherits ContainerControl
[C#]
public class XPTaskPaneGroup : ContainerControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Controls.TaskPane

Assembly: NETXP.Controls.TaskPane (in NETXP.Controls.TaskPane.dll)

See Also

XPTaskPaneGroup Members | NETXP.Controls.TaskPane Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.TaskPane [3.0.5600.2205]


XPTaskPaneGroup Members

XPTaskPaneGroup overview

Public Instance Constructors

XPTaskPaneGroup Constructor Initialises a new instance of XPTaskPaneGroup.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowExpandCollapse | Gets or sets whether or not to allow the user to expand and collapse the group by clicking on the header.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor | Hides this member.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
ColorTable | Gets or sets the color table for this control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
GroupState | Gets or sets the GroupState.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
Image | Gets or sets the image displayed in the header of the title bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
SpecialTasks | Indicates whether or not the task pane group is a special group.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text | Gets or sets the text displayed as the group title.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
GroupStateChanged | A GroupState changed event.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

XPTaskPaneGroup Class | NETXP.Controls.TaskPane Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.TaskPane [3.0.5600.2205]


XPTaskPaneGroup Constructor

Initialises a new instance of XPTaskPaneGroup.

[Visual Basic]
Public Sub New()
[C#]
public XPTaskPaneGroup();

See Also

XPTaskPaneGroup Class | NETXP.Controls.TaskPane Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.TaskPane [3.0.5600.2205]


XPTaskPaneGroup Properties

The properties of the XPTaskPaneGroup class are listed below. For a complete list of XPTaskPaneGroup class members, see the XPTaskPaneGroup Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowExpandCollapse | Gets or sets whether or not to allow the user to expand and collapse the group by clicking on the header.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor | Hides this member.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
ColorTable | Gets or sets the color table for this control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
GroupState | Gets or sets the GroupState.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
Image | Gets or sets the image displayed in the header of the title bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
SpecialTasks | Indicates whether or not the task pane group is a special group.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text | Gets or sets the text displayed as the group title.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

XPTaskPaneGroup Class | NETXP.Controls.TaskPane Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.TaskPane [3.0.5600.2205]


XPTaskPaneGroup.AllowExpandCollapse Property

Gets or sets whether or not to allow the user to expand and collapse the group by clicking on the header.

[Visual Basic]
Public Property AllowExpandCollapse As Boolean
[C#]
public bool AllowExpandCollapse {get; set;}

See Also

XPTaskPaneGroup Class | NETXP.Controls.TaskPane Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.TaskPane [3.0.5600.2205]


XPTaskPaneGroup.BackColor Property

Hides this member.

[Visual Basic]
Overrides Public Property BackColor As Color
[C#]
public override System.Drawing.Color BackColor {get; set;}

See Also

XPTaskPaneGroup Class | NETXP.Controls.TaskPane Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.TaskPane [3.0.5600.2205]


XPTaskPaneGroup.ColorTable Property

Gets or sets the color table for this control.

[Visual Basic]
Public Property ColorTable As IColorTable
[C#]
public NETXP.Library.IColorTable ColorTable {get; set;}

See Also

XPTaskPaneGroup Class | NETXP.Controls.TaskPane Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.TaskPane [3.0.5600.2205]


XPTaskPaneGroup.GroupState Property

Gets or sets the GroupState.

[Visual Basic]
Public Property GroupState As GroupState
[C#]
public GroupState GroupState {get; set;}

See Also

XPTaskPaneGroup Class | NETXP.Controls.TaskPane Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.TaskPane [3.0.5600.2205]


XPTaskPaneGroup.Image Property

Gets or sets the image displayed in the header of the title bar.

[Visual Basic]
Public Property Image As Image
[C#]
public System.Drawing.Image Image {get; set;}

See Also

XPTaskPaneGroup Class | NETXP.Controls.TaskPane Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.TaskPane [3.0.5600.2205]


XPTaskPaneGroup.SpecialTasks Property

Indicates whether or not the task pane group is a special group.

[Visual Basic]
Public Property SpecialTasks As Boolean
[C#]
public bool SpecialTasks {get; set;}

See Also

XPTaskPaneGroup Class | NETXP.Controls.TaskPane Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.TaskPane [3.0.5600.2205]


XPTaskPaneGroup.Text Property

Gets or sets the text displayed as the group title.

[Visual Basic]
Overrides Public Property Text As String
[C#]
public override string Text {get; set;}

See Also

XPTaskPaneGroup Class | NETXP.Controls.TaskPane Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.TaskPane [3.0.5600.2205]


XPTaskPaneGroup Events

The events of the XPTaskPaneGroup class are listed below. For a complete list of XPTaskPaneGroup class members, see the XPTaskPaneGroup Members topic.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
GroupStateChanged | A GroupState changed event.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

XPTaskPaneGroup Class | NETXP.Controls.TaskPane Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.TaskPane [3.0.5600.2205]


XPTaskPaneGroup.GroupStateChanged Event

A GroupState changed event.

[Visual Basic]
Public Event GroupStateChanged As GroupStateChangedEventHandler
[C#]
public event GroupStateChangedEventHandler GroupStateChanged;

Event Data

The event handler receives an argument of type GroupEventArgs containing data related to this event. The following GroupEventArgs properties provide information specific to this event.

Property | Description
GroupState | Gets the GroupState of the XPTaskPaneGroup that triggered the event.
XPTaskPaneGroup | Gets the XPTaskPaneGroup that triggered the event.

See Also

XPTaskPaneGroup Class | NETXP.Controls.TaskPane Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Controls.TaskPane [3.0.5600.2205]


NETXP.Forms

NetXP 3.0 Reference

NETXP.Forms Namespace

Classes

Class | Description
About | An inheritable about box.
Dialog | A form providing the functionality of a typical Win32 dialog.
PopupForm | See PopupForm
Wizard | An inheritable wizard from.


About Class

An inheritable about box.

For a list of all members of this type, see About Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
About

[Visual Basic]
Public Class About
Inherits Form
[C#]
public class About : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Forms

Assembly: NETXP.Forms (in NETXP.Forms.dll)

See Also

About Members | NETXP.Forms Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Forms [3.0.5600.2205]


About Members

About overview

Public Instance Constructors

About Constructor Creates a new about box.

Public Instance Fields

AppDesc | An inheritable field.
AppName | An inheritable field.
AssembliesGrp | An inheritable field.
BigTitle | An inheritable field.
CloseButton | An inheritable field.
Company | An inheritable field.
CompanyLabel | An inheritable field.
CopyrightLabel | An inheritable field.
LicTo | An inheritable field.
LicToLabel | An inheritable field.
ListOfAssemblies | An inheritable field.
Logo | An inheritable field.
LookForUpdatesLink | An inheritable field.
MainPanel | An inheritable field.
OrderOnlineLink | An inheritable field.
ProdEdition | An inheritable field.
ProdInfoLink | An inheritable field.
ProdVer | An inheritable field.
ProdVerLabel | An inheritable field.
SerialNo | An inheritable field.
VerInfoGrp | An inheritable field.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) |
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScale (inherited from Form) | Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | [To be supplied.]
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsRestrictedWindow (inherited from Form) |
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) |
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as the top-most form of your application.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Control) | Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with no owner window.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is not the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) |
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

About Class | NETXP.Forms Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Forms [3.0.5600.2205]


About Constructor

Creates a new about box.

[Visual Basic]
Public Sub New()
[C#]
public About();

See Also

About Class | NETXP.Forms Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Forms [3.0.5600.2205]


About Fields

The fields of the About class are listed below. For a complete list of About class members, see the About Members topic.

Public Instance Fields

AppDesc | An inheritable field.
AppName | An inheritable field.
AssembliesGrp | An inheritable field.
BigTitle | An inheritable field.
CloseButton | An inheritable field.
Company | An inheritable field.
CompanyLabel | An inheritable field.
CopyrightLabel | An inheritable field.
LicTo | An inheritable field.
LicToLabel | An inheritable field.
ListOfAssemblies | An inheritable field.
Logo | An inheritable field.
LookForUpdatesLink | An inheritable field.
MainPanel | An inheritable field.
OrderOnlineLink | An inheritable field.
ProdEdition | An inheritable field.
ProdInfoLink | An inheritable field.
ProdVer | An inheritable field.
ProdVerLabel | An inheritable field.
SerialNo | An inheritable field.
VerInfoGrp | An inheritable field.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

About Class | NETXP.Forms Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Forms [3.0.5600.2205]


About.AppDesc Field

An inheritable field.

[Visual Basic]
Public AppDesc As Label
[C#]
public Label AppDesc;

See Also

About Class | NETXP.Forms Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Forms [3.0.5600.2205]


About.AppName Field

An inheritable field.

[Visual Basic]
Public AppName As Label
[C#]
public Label AppName;

See Also

About Class | NETXP.Forms Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Forms [3.0.5600.2205]


About.AssembliesGrp Field

An inheritable field.

[Visual Basic]
Public AssembliesGrp As GroupBox
[C#]
public GroupBox AssembliesGrp;

See Also

About Class | NETXP.Forms Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Forms [3.0.5600.2205]


About.BigTitle Field

An inheritable field.

[Visual Basic]
Public BigTitle As Label
[C#]
public Label BigTitle;

See Also

About Class | NETXP.Forms Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Forms [3.0.5600.2205]


About.CloseButton Field

An inheritable field.

[Visual Basic]
Public CloseButton As XPButton
[C#]
public XPButton CloseButton;

See Also

About Class | NETXP.Forms Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Forms [3.0.5600.2205]


About.Company Field

An inheritable field.

[Visual Basic]
Public Company As Label
[C#]
public Label Company;

See Also

About Class | NETXP.Forms Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Forms [3.0.5600.2205]


About.CompanyLabel Field

An inheritable field.

[Visual Basic]
Public CompanyLabel As Label
[C#]
public Label CompanyLabel;

See Also

About Class | NETXP.Forms Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Forms [3.0.5600.2205]


About.CopyrightLabel Field

An inheritable field.

[Visual Basic]
Public CopyrightLabel As Label
[C#]
public Label CopyrightLabel;

See Also

About Class | NETXP.Forms Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Forms [3.0.5600.2205]


About.LicTo Field

An inheritable field.

[Visual Basic]
Public LicTo As Label
[C#]
public Label LicTo;

See Also

About Class | NETXP.Forms Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Forms [3.0.5600.2205]


About.LicToLabel Field

An inheritable field.

[Visual Basic]
Public LicToLabel As Label
[C#]
public Label LicToLabel;

See Also

About Class | NETXP.Forms Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Forms [3.0.5600.2205]


About.ListOfAssemblies Field

An inheritable field.

[Visual Basic]
Public ListOfAssemblies As ListView
[C#]
public ListView ListOfAssemblies;

See Also

About Class | NETXP.Forms Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Forms [3.0.5600.2205]


About.Logo Field

An inheritable field.

[Visual Basic]
Public Logo As XPictureBox
[C#]
public XPictureBox Logo;

See Also

About Class | NETXP.Forms Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Forms [3.0.5600.2205]


About.LookForUpdatesLink Field

An inheritable field.

[Visual Basic]
Public LookForUpdatesLink As XPLink
[C#]
public XPLink LookForUpdatesLink;

See Also

About Class | NETXP.Forms Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Forms [3.0.5600.2205]


About.MainPanel Field

An inheritable field.

[Visual Basic]
Public MainPanel As Panel
[C#]
public Panel MainPanel;

See Also

About Class | NETXP.Forms Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Forms [3.0.5600.2205]


About.OrderOnlineLink Field

An inheritable field.

[Visual Basic]
Public OrderOnlineLink As XPLink
[C#]
public XPLink OrderOnlineLink;

See Also

About Class | NETXP.Forms Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Forms [3.0.5600.2205]


About.ProdEdition Field

An inheritable field.

[Visual Basic]
Public ProdEdition As Label
[C#]
public Label ProdEdition;

See Also

About Class | NETXP.Forms Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Forms [3.0.5600.2205]


About.ProdInfoLink Field

An inheritable field.

[Visual Basic]
Public ProdInfoLink As XPLink
[C#]
public XPLink ProdInfoLink;

See Also

About Class | NETXP.Forms Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Forms [3.0.5600.2205]


About.ProdVer Field

An inheritable field.

[Visual Basic]
Public ProdVer As Label
[C#]
public Label ProdVer;

See Also

About Class | NETXP.Forms Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Forms [3.0.5600.2205]


About.ProdVerLabel Field

An inheritable field.

[Visual Basic]
Public ProdVerLabel As Label
[C#]
public Label ProdVerLabel;

See Also

About Class | NETXP.Forms Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Forms [3.0.5600.2205]


About.SerialNo Field

An inheritable field.

[Visual Basic]
Public SerialNo As Label
[C#]
public Label SerialNo;

See Also

About Class | NETXP.Forms Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Forms [3.0.5600.2205]


About.VerInfoGrp Field

An inheritable field.

[Visual Basic]
Public VerInfoGrp As GroupBox
[C#]
public GroupBox VerInfoGrp;

See Also

About Class | NETXP.Forms Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Forms [3.0.5600.2205]


Dialog Class

A form providing the functionality of a typical Win32 dialog.

For a list of all members of this type, see Dialog Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
Dialog

[Visual Basic]
Public Class Dialog
Inherits Form
[C#]
public class Dialog : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Forms

Assembly: NETXP.Forms (in NETXP.Forms.dll)

See Also

Dialog Members | NETXP.Forms Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Forms [3.0.5600.2205]


Dialog Members

Dialog overview

Public Instance Constructors

Dialog Constructor Creates a new dialog box (no sizing border)

Public Instance Fields

CancelBtn | An inheritable member.
OKBtn | An inheritable member.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) |
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScale (inherited from Form) | Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | [To be supplied.]
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsRestrictedWindow (inherited from Form) |
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) |
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as the top-most form of your application.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Control) | Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with no owner window.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is not the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) |
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

Dialog Class | NETXP.Forms Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Forms [3.0.5600.2205]


Dialog Constructor

Creates a new dialog box (no sizing border)

[Visual Basic]
Public Sub New()
[C#]
public Dialog();

See Also

Dialog Class | NETXP.Forms Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Forms [3.0.5600.2205]


Dialog Fields

The fields of the Dialog class are listed below. For a complete list of Dialog class members, see the Dialog Members topic.

Public Instance Fields

CancelBtn | An inheritable member.
OKBtn | An inheritable member.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

Dialog Class | NETXP.Forms Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Forms [3.0.5600.2205]


Dialog.CancelBtn Field

An inheritable member.

[Visual Basic]
Public CancelBtn As XPButton
[C#]
public XPButton CancelBtn;

See Also

Dialog Class | NETXP.Forms Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Forms [3.0.5600.2205]


Dialog.OKBtn Field

An inheritable member.

[Visual Basic]
Public OKBtn As XPButton
[C#]
public XPButton OKBtn;

See Also

Dialog Class | NETXP.Forms Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Forms [3.0.5600.2205]


PopupForm Class

See PopupForm

For a list of all members of this type, see PopupForm Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
PopupForm
PopupForm

[Visual Basic]
Public Class PopupForm
Inherits PopupForm
[C#]
public class PopupForm : PopupForm

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Forms

Assembly: NETXP.Forms (in NETXP.Forms.dll)

See Also

PopupForm Members | NETXP.Forms Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Forms [3.0.5600.2205]


PopupForm Members

PopupForm overview

Public Instance Constructors

PopupForm Constructor Initializes a new instance of the PopupForm class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) |
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScale (inherited from Form) | Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
BottomShadow (inherited from PopupForm) | Gets the bottom shadow window.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Filter (inherited from PopupForm) | Gets the message filter.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | [To be supplied.]
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
HasShadow (inherited from PopupForm) | Does this form have a shadow?
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsRestrictedWindow (inherited from Form) |
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightShadow (inherited from PopupForm) | Gets the right-side shadow window.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShadowSize (inherited from PopupForm) | Gets or sets the shadow size.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) |
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as the top-most form of your application.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreFilterMessage (inherited from PopupForm) | Internal
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Control) | Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with no owner window.
ShowPopup (inherited from PopupForm) | Shows a popup form at the specified location.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is not the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
ShadowCreated (inherited from PopupForm) | Raised when the shadow of the form has been created.
Showing (inherited from PopupForm) | Raised when showing the form. Provides an opportunity to animate the form.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) |
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

PopupForm Class | NETXP.Forms Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Forms [3.0.5600.2205]


PopupForm Constructor

Initializes a new instance of the PopupForm class.

[Visual Basic]
Public Sub New()
[C#]
public PopupForm();

See Also

PopupForm Class | NETXP.Forms Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Forms [3.0.5600.2205]


Wizard Class

An inheritable wizard from.

For a list of all members of this type, see Wizard Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
Wizard

[Visual Basic]
Public Class Wizard
Inherits Form
[C#]
public class Wizard : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Forms

Assembly: NETXP.Forms (in NETXP.Forms.dll)

See Also

Wizard Members | NETXP.Forms Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Forms [3.0.5600.2205]


Wizard Members

Wizard overview

Public Instance Constructors

Wizard Constructor Creates a new wizard.

Public Instance Fields

BackButton | An inheritable field.
CancelBtn | An inheritable field.
EtchedLine | An inheritable field.
LowerPanel | An inheritable field.
NextButton | An inheritable field.
OKBtn | An inheritable field.
PageTitle | An inheritable field.
ProductLogo | An inheritable field.
Separator | An inheritable field.
TitlePanel | An inheritable field.
WizardLogo | An inheritable field.
WizardPages | An inheritable field.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) |
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScale (inherited from Form) | Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | [To be supplied.]
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsRestrictedWindow (inherited from Form) |
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) |
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as the top-most form of your application.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
SetWizardMode | Changes from wizard to property sheet and back.
Show (inherited from Control) | Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with no owner window.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is not the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) |
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

Wizard Class | NETXP.Forms Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Forms [3.0.5600.2205]


Wizard Constructor

Creates a new wizard.

[Visual Basic]
Public Sub New()
[C#]
public Wizard();

See Also

Wizard Class | NETXP.Forms Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Forms [3.0.5600.2205]


Wizard Fields

The fields of the Wizard class are listed below. For a complete list of Wizard class members, see the Wizard Members topic.

Public Instance Fields

BackButton | An inheritable field.
CancelBtn | An inheritable field.
EtchedLine | An inheritable field.
LowerPanel | An inheritable field.
NextButton | An inheritable field.
OKBtn | An inheritable field.
PageTitle | An inheritable field.
ProductLogo | An inheritable field.
Separator | An inheritable field.
TitlePanel | An inheritable field.
WizardLogo | An inheritable field.
WizardPages | An inheritable field.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

Wizard Class | NETXP.Forms Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Forms [3.0.5600.2205]


Wizard.BackButton Field

An inheritable field.

[Visual Basic]
Public BackButton As XPButton
[C#]
public XPButton BackButton;

See Also

Wizard Class | NETXP.Forms Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Forms [3.0.5600.2205]


Wizard.CancelBtn Field

An inheritable field.

[Visual Basic]
Public CancelBtn As XPButton
[C#]
public XPButton CancelBtn;

See Also

Wizard Class | NETXP.Forms Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Forms [3.0.5600.2205]


Wizard.EtchedLine Field

An inheritable field.

[Visual Basic]
Public EtchedLine As GroupBox
[C#]
public GroupBox EtchedLine;

See Also

Wizard Class | NETXP.Forms Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Forms [3.0.5600.2205]


Wizard.LowerPanel Field

An inheritable field.

[Visual Basic]
Public LowerPanel As Panel
[C#]
public Panel LowerPanel;

See Also

Wizard Class | NETXP.Forms Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Forms [3.0.5600.2205]


Wizard.NextButton Field

An inheritable field.

[Visual Basic]
Public NextButton As XPButton
[C#]
public XPButton NextButton;

See Also

Wizard Class | NETXP.Forms Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Forms [3.0.5600.2205]


Wizard.OKBtn Field

An inheritable field.

[Visual Basic]
Public OKBtn As XPButton
[C#]
public XPButton OKBtn;

See Also

Wizard Class | NETXP.Forms Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Forms [3.0.5600.2205]


Wizard.PageTitle Field

An inheritable field.

[Visual Basic]
Public PageTitle As Label
[C#]
public Label PageTitle;

See Also

Wizard Class | NETXP.Forms Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Forms [3.0.5600.2205]


Wizard.ProductLogo Field

An inheritable field.

[Visual Basic]
Public ProductLogo As XPictureBox
[C#]
public XPictureBox ProductLogo;

See Also

Wizard Class | NETXP.Forms Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Forms [3.0.5600.2205]


Wizard.Separator Field

An inheritable field.

[Visual Basic]
Public Separator As Label
[C#]
public Label Separator;

See Also

Wizard Class | NETXP.Forms Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Forms [3.0.5600.2205]


Wizard.TitlePanel Field

An inheritable field.

[Visual Basic]
Public TitlePanel As Panel
[C#]
public Panel TitlePanel;

See Also

Wizard Class | NETXP.Forms Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Forms [3.0.5600.2205]


Wizard.WizardLogo Field

An inheritable field.

[Visual Basic]
Public WizardLogo As XPictureBox
[C#]
public XPictureBox WizardLogo;

See Also

Wizard Class | NETXP.Forms Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Forms [3.0.5600.2205]


Wizard.WizardPages Field

An inheritable field.

[Visual Basic]
Public WizardPages As MultiPage
[C#]
public MultiPage WizardPages;

See Also

Wizard Class | NETXP.Forms Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Forms [3.0.5600.2205]


Wizard Methods

The methods of the Wizard class are listed below. For a complete list of Wizard class members, see the Wizard Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
SetWizardMode | Changes from wizard to property sheet and back.
Show (inherited from Control) | Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with no owner window.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

Wizard Class | NETXP.Forms Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Forms [3.0.5600.2205]


Wizard.SetWizardMode Method

Changes from wizard to property sheet and back.

[Visual Basic]
Public Sub SetWizardMode( _
ByVal wizard As Boolean _
)
[C#]
public void SetWizardMode(
bool wizard
);

Parameters

wizard
Use wizard mode?

See Also

Wizard Class | NETXP.Forms Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Forms [3.0.5600.2205]


NETXP.Library

NetXP 3.0 Reference

NETXP.Library Namespace

Classes

Class | Description
ClassicColorTable | Contains colors for any other color scheme. These colors are computed from system colors.
CollectionEx | Implements an overrideable collection with events.
ColorCollection | A collection of Color objects.
ColorTables | Contains colors for various GUI elements.
ColorUtil | Exposes methods to work with color.
ControlUtil | Provides utility functions for dealing with controls.
Convert | Provides conversion methods for some .NET types.
CustomColorTable | Implements a custom color table. You can instantiate this color table and replace the colors in the Colors collection with your own colors.
DoNotObfuscateAttribute | Internal
DrawUtil | Provides some utility functions for drawing.
DynamicColorTable | Provides colors based on the current visual style.
FTP | The FTP class provides simple functionality of an FTP client.
Mapi | Provides a simple MAPI wrapper.
Margins | Provides a way to set up margins or padding.
Msg | Contains utility functions for displaying different kinds of messages.
PopupForm | Provides an inheritable, reusable popup form that implements all the functionality of a typical popup window.
PopupMessageFilter | Provides a reusable message filter for popup controls.
QuickMail | Provides easy access to Simple MAPI functions.
Resources | Provides a better way to work with .NET resources.
Settings | A class that is used to save and restore data using the registry or by binary serialization in a file. It works in conjuction with another class (with the recommended name "Settings") that contains all the data to be stored.
ShadowWindow | A special type of window that can be used to show a shadow for another window.
StringCollection | Implements a string collection with events.
Utility | Utility functions.
UXTheme | Provides some utility functions from the UXTheme API.
WNet | Contains utility functions for enumerating network nodes.
WNetNode | Describes a network node.
WNetNodeCollection | A collection of WNetNode objects.
XPBlueColorTable | Contains colors for the Luna Blue color scheme.
XPOliveColorTable | Contains colors for the Luna Olive Green color scheme.
XPSilverColorTable | Contains colors for the Luna Silver color scheme.

Interfaces

Interface | Description
IColorTable | Defines what it means to be a color table.
IStatusMessageAcceptor | Provides an interface for a status message acceptor for the command bars. This is typically implemented by a status bar.
IStatusMessageProvider | Provides an interface for a status message provider for the command bars. This is typically implemented by a command bar item.

Delegates

Delegate | Description
CollectionChange | Collection changed event.
CollectionClear | Collection cleared event.
PopupMessageFilter.FilterMessageHandler | Handles the FilterMessage event.

Enumerations

Enumeration | Description
BrowseFlags | Flags that control display and behaviour of folder browse dialog
Direction | Direction of docking.
DrawUtil.CommandState | Internal.
Edge | Docked Edge
EndChoices | Which button was chosen when the dialog box quit.
Glyph | Specifies the NetXP common glyphs found in this assembly.
ShadowType | Specifies the shadow window type.
TableColor | Provides a collection of colors defined in each color table.
WNetNodeLevel | Identifies the tree depth of a network node.
WNetNodeType | Identifies the type of network node.
WNetUsage | Identifies the use of the node.
XPThemeColor | Enumerates the XP color schemes.


BrowseFlags Enumeration

Flags that control display and behaviour of folder browse dialog

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

[Visual Basic]
Public Enum BrowseFlags
[C#]
public enum BrowseFlags

Members

Member Name | Description | Value
None | Default | 0
ReturnOnlyFSDirs | Same as BIF_RETURNONLYFSDIRS | 1
DontGoBelowDomain | Same as BIF_DONTGOBELOWDOMAIN | 2
ShowStatusText | Same as BIF_STATUSTEXT | 4
ReturnFSancestors | Same as BIF_RETURNFSANCESTORS | 8
EditBox | Same as BIF_EDITBOX | 16
Validate | Same as BIF_VALIDATE | 32
NewDialogStyle | Same as BIF_NEWDIALOGSTYLE | 64
BrowseIncludeURLs | Same as BIF_BROWSEINCLUDEURLS | 128
AddUsageHint | Same as BIF_UAHINT | 256
NoNewFolderButton | Same as BIF_NONEWFOLDERBUTTON | 512
BrowseForComputer | Same as BIF_BROWSEFORCOMPUTER | 4096
BrowseForPrinter | Same as BIF_BROWSEFORPRINTER | 8192
IncludeFiles | Same as BIF_BROWSEINCLUDEFILES | 16384
ShowShareable | Same as BIF_SHAREABLE | 32768

Requirements

Namespace: NETXP.Library

Assembly: NETXP.Library (in NETXP.Library.dll)

See Also

NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ClassicColorTable Class

Contains colors for any other color scheme. These colors are computed from system colors.

For a list of all members of this type, see ClassicColorTable Members.

System.Object
ClassicColorTable

[Visual Basic]
Public Class ClassicColorTable
Implements NETXP.Library.IColorTable
[C#]
public class ClassicColorTable : IColorTable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Library

Assembly: NETXP.Library (in NETXP.Library.dll)

See Also

ClassicColorTable Members | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ClassicColorTable Members

ClassicColorTable overview

Public Instance Constructors

ClassicColorTable Constructor Initializes a new instance of the ClassicColorTable class.

Public Instance Properties

Colors Gets the collection of colors provided by this color table.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ClassicColorTable Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ClassicColorTable Constructor

Initializes a new instance of the ClassicColorTable class.

[Visual Basic]
Public Sub New()
[C#]
public ClassicColorTable();

See Also

ClassicColorTable Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ClassicColorTable Properties

The properties of the ClassicColorTable class are listed below. For a complete list of ClassicColorTable class members, see the ClassicColorTable Members topic.

Public Instance Properties

Colors Gets the collection of colors provided by this color table.

See Also

ClassicColorTable Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ClassicColorTable.Colors Property

Gets the collection of colors provided by this color table.

[Visual Basic]
NotOverridable Public ReadOnly Property Colors As ColorCollection Implements _
IColorTable.Colors
[C#]
public ColorCollection Colors {get;}

Implements

IColorTable.Colors

See Also

ClassicColorTable Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


CollectionChange Delegate

Collection changed event.

[Visual Basic]
Public Delegate Sub CollectionChange( _
ByVal index As Integer, _
ByVal value As Object _
)
[C#]
public delegate void CollectionChange(
int index,
object value
);

Requirements

Namespace: NETXP.Library

Assembly: NETXP.Library (in NETXP.Library.dll)

See Also

NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


CollectionClear Delegate

Collection cleared event.

[Visual Basic]
Public Delegate Sub CollectionClear()
[C#]
public delegate void CollectionClear();

Requirements

Namespace: NETXP.Library

Assembly: NETXP.Library (in NETXP.Library.dll)

See Also

NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


CollectionEx Class

Implements an overrideable collection with events.

For a list of all members of this type, see CollectionEx Members.

System.Object
CollectionBase
CollectionEx

[Visual Basic]
Public Class CollectionEx
Inherits CollectionBase
[C#]
public class CollectionEx : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Library

Assembly: NETXP.Library (in NETXP.Library.dll)

See Also

CollectionEx Members | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


CollectionEx Members

CollectionEx overview

Public Instance Constructors

CollectionEx Constructor Constructs a new CollectionEx.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
IsSuspended | Is event generation already suspended?

Public Instance Methods

Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RaiseChanged | Raises the Changed event.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
ResumeEvents | Resume event generation.
SuspendEvents | Suspend event generation.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

Changed | Event raised when the collection has changed.
Cleared | Event raised when collection has been cleared.
Clearing | Event raised when collection is being cleared.
Inserted | Event raised when an item has been inserted.
Inserting | Event raised when an item is being inserted.
Removed | Event raised when an item has been removed.
Removing | Event raised when an item is being removed.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

CollectionEx Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


CollectionEx Constructor

Constructs a new CollectionEx.

[Visual Basic]
Public Sub New()
[C#]
public CollectionEx();

See Also

CollectionEx Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


CollectionEx Properties

The properties of the CollectionEx class are listed below. For a complete list of CollectionEx class members, see the CollectionEx Members topic.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
IsSuspended | Is event generation already suspended?

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

CollectionEx Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


CollectionEx.IsSuspended Property

Is event generation already suspended?

[Visual Basic]
Public ReadOnly Property IsSuspended As Boolean
[C#]
public bool IsSuspended {get;}

See Also

CollectionEx Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


CollectionEx Methods

The methods of the CollectionEx class are listed below. For a complete list of CollectionEx class members, see the CollectionEx Members topic.

Public Instance Methods

Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RaiseChanged | Raises the Changed event.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
ResumeEvents | Resume event generation.
SuspendEvents | Suspend event generation.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

CollectionEx Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


CollectionEx.RaiseChanged Method

Raises the Changed event.

[Visual Basic]
Public Sub RaiseChanged()
[C#]
public void RaiseChanged();

See Also

CollectionEx Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


CollectionEx.ResumeEvents Method

Resume event generation.

[Visual Basic]
Public Sub ResumeEvents()
[C#]
public void ResumeEvents();

See Also

CollectionEx Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


CollectionEx.SuspendEvents Method

Suspend event generation.

[Visual Basic]
Public Sub SuspendEvents()
[C#]
public void SuspendEvents();

See Also

CollectionEx Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


CollectionEx Events

The events of the CollectionEx class are listed below. For a complete list of CollectionEx class members, see the CollectionEx Members topic.

Public Instance Events

Changed | Event raised when the collection has changed.
Cleared | Event raised when collection has been cleared.
Clearing | Event raised when collection is being cleared.
Inserted | Event raised when an item has been inserted.
Inserting | Event raised when an item is being inserted.
Removed | Event raised when an item has been removed.
Removing | Event raised when an item is being removed.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

CollectionEx Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


CollectionEx.Changed Event

Event raised when the collection has changed.

[Visual Basic]
Public Event Changed As EventHandler
[C#]
public event EventHandler Changed;

See Also

CollectionEx Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


CollectionEx.Cleared Event

Event raised when collection has been cleared.

[Visual Basic]
Public Event Cleared As CollectionClear
[C#]
public event CollectionClear Cleared;

See Also

CollectionEx Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


CollectionEx.Clearing Event

Event raised when collection is being cleared.

[Visual Basic]
Public Event Clearing As CollectionClear
[C#]
public event CollectionClear Clearing;

See Also

CollectionEx Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


CollectionEx.Inserted Event

Event raised when an item has been inserted.

[Visual Basic]
Public Event Inserted As CollectionChange
[C#]
public event CollectionChange Inserted;

See Also

CollectionEx Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


CollectionEx.Inserting Event

Event raised when an item is being inserted.

[Visual Basic]
Public Event Inserting As CollectionChange
[C#]
public event CollectionChange Inserting;

See Also

CollectionEx Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


CollectionEx.Removed Event

Event raised when an item has been removed.

[Visual Basic]
Public Event Removed As CollectionChange
[C#]
public event CollectionChange Removed;

See Also

CollectionEx Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


CollectionEx.Removing Event

Event raised when an item is being removed.

[Visual Basic]
Public Event Removing As CollectionChange
[C#]
public event CollectionChange Removing;

See Also

CollectionEx Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ColorCollection Class

A collection of Color objects.

For a list of all members of this type, see ColorCollection Members.

System.Object
CollectionBase
ColorCollection

[Visual Basic]
Public Class ColorCollection
Inherits CollectionBase
[C#]
public class ColorCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Library

Assembly: NETXP.Library (in NETXP.Library.dll)

See Also

ColorCollection Members | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ColorCollection Members

ColorCollection overview

Public Instance Constructors

ColorCollection Constructor Creates a new collection.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Item | Overloaded. Retrieves an item at an index.

Public Instance Methods

Add | Adds an item to the collection.
AddRange | Adds a set of items to the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Contains | Checks if the collection contains a certain item.
CopyTo | Copies this collection's items into an array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Gets the index of an item.
Insert | Inserts an item at a specified index.
RaiseChanged | Raises a Changed event.
Remove | Removes an item.
RemoveAt | Removes an item at a specified index.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

Changed Called when the collection has changed.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

ColorCollection Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ColorCollection Constructor

Creates a new collection.

[Visual Basic]
Public Sub New()
[C#]
public ColorCollection();

See Also

ColorCollection Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ColorCollection Properties

The properties of the ColorCollection class are listed below. For a complete list of ColorCollection class members, see the ColorCollection Members topic.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Item | Overloaded. Retrieves an item at an index.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

ColorCollection Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Item Property

NetXP 3.0 Reference

ColorCollection.Item Property

Retrieves an item at an index.

Overload List

Retrieves an item at an index.

public System.Drawing.Color this[NETXP.Library.TableColor] {get; set;}

Retrieves an item at an index.

public System.Drawing.Color this[int] {get; set;}

See Also

ColorCollection Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ColorCollection.Item Property

Retrieves an item at an index.

[Visual Basic]
Overloads Public Default Property Item( _
ByVal eColor As TableColor _
) As Color
[C#]
public System.Drawing.Color this[
NETXP.Library.TableColor eColor
] {get; set;}

See Also

ColorCollection Class | NETXP.Library Namespace | ColorCollection.Item Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ColorCollection.Item Property

Retrieves an item at an index.

[Visual Basic]
Overloads Public Default Property Item( _
ByVal index As Integer _
) As Color
[C#]
public System.Drawing.Color this[
int index
] {get; set;}

See Also

ColorCollection Class | NETXP.Library Namespace | ColorCollection.Item Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ColorCollection Methods

The methods of the ColorCollection class are listed below. For a complete list of ColorCollection class members, see the ColorCollection Members topic.

Public Instance Methods

Add | Adds an item to the collection.
AddRange | Adds a set of items to the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Contains | Checks if the collection contains a certain item.
CopyTo | Copies this collection's items into an array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Gets the index of an item.
Insert | Inserts an item at a specified index.
RaiseChanged | Raises a Changed event.
Remove | Removes an item.
RemoveAt | Removes an item at a specified index.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

ColorCollection Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ColorCollection.Add Method

Adds an item to the collection.

[Visual Basic]
Public Function Add( _
ByVal item As Color _
) As Integer
[C#]
public int Add(
Color item
);

Parameters

item
The item to add.

Return Value

The index where the item was added.

See Also

ColorCollection Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ColorCollection.AddRange Method

Adds a set of items to the collection.

[Visual Basic]
Public Sub AddRange( _
ByVal items As Color() _
)
[C#]
public void AddRange(
Color[] items
);

Parameters

items
The array of items to add.

See Also

ColorCollection Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ColorCollection.Contains Method

Checks if the collection contains a certain item.

[Visual Basic]
Public Function Contains( _
ByVal item As Color _
) As Boolean
[C#]
public bool Contains(
Color item
);

Parameters

item
The item

Return Value

True if the collection contains this item.

See Also

ColorCollection Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ColorCollection.CopyTo Method

Copies this collection's items into an array.

[Visual Basic]
Public Sub CopyTo( _
ByVal array As Array, _
ByVal index As Integer _
)
[C#]
public void CopyTo(
Array array,
int index
);

Parameters

array
The array.
index
The index at which to start copying.

See Also

ColorCollection Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ColorCollection.IndexOf Method

Gets the index of an item.

[Visual Basic]
Public Function IndexOf( _
ByVal item As Color _
) As Integer
[C#]
public int IndexOf(
Color item
);

Parameters

item
The item.

Return Value

The index of the item.

See Also

ColorCollection Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ColorCollection.Insert Method

Inserts an item at a specified index.

[Visual Basic]
Public Sub Insert( _
ByVal index As Integer, _
ByVal item As Color _
)
[C#]
public void Insert(
int index,
Color item
);

Parameters

index
The index.
item
The item.

See Also

ColorCollection Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ColorCollection.RaiseChanged Method

Raises a Changed event.

[Visual Basic]
Public Sub RaiseChanged()
[C#]
public void RaiseChanged();

See Also

ColorCollection Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ColorCollection.Remove Method

Removes an item.

[Visual Basic]
Public Sub Remove( _
ByVal item As Color _
)
[C#]
public void Remove(
Color item
);

Parameters

item
The item to remove.

See Also

ColorCollection Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ColorCollection.RemoveAt Method

Removes an item at a specified index.

[Visual Basic]
Public Sub RemoveAt( _
ByVal index As Integer _
) Implements _
IList.RemoveAt
[C#]
new public void RemoveAt(
int index
);

Parameters

index
The index to remove at.

Implements

IList.RemoveAt

See Also

ColorCollection Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ColorCollection Events

The events of the ColorCollection class are listed below. For a complete list of ColorCollection class members, see the ColorCollection Members topic.

Public Instance Events

Changed Called when the collection has changed.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

ColorCollection Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ColorCollection.Changed Event

Called when the collection has changed.

[Visual Basic]
Public Event Changed As EventHandler
[C#]
public event EventHandler Changed;

See Also

ColorCollection Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ColorTables Class

Contains colors for various GUI elements.

For a list of all members of this type, see ColorTables Members.

System.Object
ColorTables

[Visual Basic]
Public Class ColorTables
[C#]
public class ColorTables

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Library

Assembly: NETXP.Library (in NETXP.Library.dll)

See Also

ColorTables Members | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ColorTables Members

ColorTables overview

Public Static (Shared) Properties

Classic | Retrieves the Windows Classic color table. This can also be used for unrecognized visual styles.
Dynamic | Retrieves a color table based on the current visual style.
UXThemeColor | Gets the theme color for UXTheme, if used.
XPBlue | Retrieves the XP Blue color table.
XPOlive | Retrieves the XP Olive Green color table.
XPSilver | Retrieves the XP Silver color table.

Public Instance Constructors

ColorTables Constructor Initializes a new instance of the ColorTables class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ColorTables Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ColorTables Constructor

Initializes a new instance of the ColorTables class.

[Visual Basic]
Public Sub New()
[C#]
public ColorTables();

See Also

ColorTables Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ColorTables Properties

The properties of the ColorTables class are listed below. For a complete list of ColorTables class members, see the ColorTables Members topic.

Public Static (Shared) Properties

Classic | Retrieves the Windows Classic color table. This can also be used for unrecognized visual styles.
Dynamic | Retrieves a color table based on the current visual style.
UXThemeColor | Gets the theme color for UXTheme, if used.
XPBlue | Retrieves the XP Blue color table.
XPOlive | Retrieves the XP Olive Green color table.
XPSilver | Retrieves the XP Silver color table.

See Also

ColorTables Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ColorTables.Classic Property

Retrieves the Windows Classic color table. This can also be used for unrecognized visual styles.

[Visual Basic]
Public Shared ReadOnly Property Classic As IColorTable
[C#]
public static IColorTable Classic {get;}

See Also

ColorTables Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ColorTables.Dynamic Property

Retrieves a color table based on the current visual style.

[Visual Basic]
Public Shared ReadOnly Property Dynamic As IColorTable
[C#]
public static IColorTable Dynamic {get;}

See Also

ColorTables Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ColorTables.UXThemeColor Property

Gets the theme color for UXTheme, if used.

[Visual Basic]
Public Shared ReadOnly Property UXThemeColor As XPThemeColor
[C#]
public static XPThemeColor UXThemeColor {get;}

See Also

ColorTables Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ColorTables.XPBlue Property

Retrieves the XP Blue color table.

[Visual Basic]
Public Shared ReadOnly Property XPBlue As IColorTable
[C#]
public static IColorTable XPBlue {get;}

See Also

ColorTables Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ColorTables.XPOlive Property

Retrieves the XP Olive Green color table.

[Visual Basic]
Public Shared ReadOnly Property XPOlive As IColorTable
[C#]
public static IColorTable XPOlive {get;}

See Also

ColorTables Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ColorTables.XPSilver Property

Retrieves the XP Silver color table.

[Visual Basic]
Public Shared ReadOnly Property XPSilver As IColorTable
[C#]
public static IColorTable XPSilver {get;}

See Also

ColorTables Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ColorUtil Class

Exposes methods to work with color.

For a list of all members of this type, see ColorUtil Members.

System.Object
ColorUtil

[Visual Basic]
Public Class ColorUtil
[C#]
public class ColorUtil

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Library

Assembly: NETXP.Library (in NETXP.Library.dll)

See Also

ColorUtil Members | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ColorUtil Members

ColorUtil overview

Public Static (Shared) Methods

BlendColors | Calculates a new color by blending two colors.
GetTabBackground | Retrieves the background color for tab pages, from a given background color.

Public Instance Constructors

ColorUtil Constructor Initializes a new instance of the ColorUtil class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ColorUtil Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ColorUtil Constructor

Initializes a new instance of the ColorUtil class.

[Visual Basic]
Public Sub New()
[C#]
public ColorUtil();

See Also

ColorUtil Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ColorUtil Methods

The methods of the ColorUtil class are listed below. For a complete list of ColorUtil class members, see the ColorUtil Members topic.

Public Static (Shared) Methods

BlendColors | Calculates a new color by blending two colors.
GetTabBackground | Retrieves the background color for tab pages, from a given background color.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ColorUtil Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ColorUtil.BlendColors Method

Calculates a new color by blending two colors.

[Visual Basic]
Public Shared Function BlendColors( _
ByVal front As Color, _
ByVal back As Color, _
ByVal alpha As Integer _
) As Color
[C#]
public static Color BlendColors(
Color front,
Color back,
int alpha
);

Parameters

front
The foreground color.
back
The background color.
alpha
The simulated alpha value of the foreground color.

Return Value

A blend between the foreground and background colors.

See Also

ColorUtil Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ColorUtil.GetTabBackground Method

Retrieves the background color for tab pages, from a given background color.

[Visual Basic]
Public Shared Function GetTabBackground( _
ByVal backColor As Color _
) As Color
[C#]
public static Color GetTabBackground(
Color backColor
);

Parameters

backColor
A background color.

Return Value

The tab page background.

See Also

ColorUtil Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ControlUtil Class

Provides utility functions for dealing with controls.

For a list of all members of this type, see ControlUtil Members.

System.Object
ControlUtil

[Visual Basic]
Public Class ControlUtil
[C#]
public class ControlUtil

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Library

Assembly: NETXP.Library (in NETXP.Library.dll)

See Also

ControlUtil Members | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ControlUtil Members

ControlUtil overview

Public Static (Shared) Methods

Remove | Removes the given control from the specified control collection.
RemoveAll | Removes all instances of the given control from its parent form.
RemoveAt | Removes a control at the specified index from the given control collection.
RemoveForm | Removes a form from the given container.

Public Instance Constructors

ControlUtil Constructor Initializes a new instance of the ControlUtil class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ControlUtil Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ControlUtil Constructor

Initializes a new instance of the ControlUtil class.

[Visual Basic]
Public Sub New()
[C#]
public ControlUtil();

See Also

ControlUtil Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ControlUtil Methods

The methods of the ControlUtil class are listed below. For a complete list of ControlUtil class members, see the ControlUtil Members topic.

Public Static (Shared) Methods

Remove | Removes the given control from the specified control collection.
RemoveAll | Removes all instances of the given control from its parent form.
RemoveAt | Removes a control at the specified index from the given control collection.
RemoveForm | Removes a form from the given container.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ControlUtil Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ControlUtil.Remove Method

Removes the given control from the specified control collection.

[Visual Basic]
Public Shared Sub Remove( _
ByVal coll As ControlCollection, _
ByVal item As Control _
)
[C#]
public static void Remove(
ControlCollection coll,
Control item
);

Parameters

coll
The control collection from which to remove the control.
item
The control to remove.

See Also

ControlUtil Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ControlUtil.RemoveAll Method

Removes all instances of the given control from its parent form.

[Visual Basic]
Public Shared Sub RemoveAll( _
ByVal control As Control _
)
[C#]
public static void RemoveAll(
Control control
);

Parameters

control
The control to remove.

See Also

ControlUtil Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ControlUtil.RemoveAt Method

Removes a control at the specified index from the given control collection.

[Visual Basic]
Public Shared Sub RemoveAt( _
ByVal coll As ControlCollection, _
ByVal index As Integer _
)
[C#]
public static void RemoveAt(
ControlCollection coll,
int index
);

Parameters

coll
The control collection.
index
The index at which to remove.

See Also

ControlUtil Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ControlUtil.RemoveForm Method

Removes a form from the given container.

[Visual Basic]
Public Shared Sub RemoveForm( _
ByVal source As Control, _
ByVal form As Form _
)
[C#]
public static void RemoveForm(
Control source,
Form form
);

Parameters

source
The container of the form.
form
The form to remove.

See Also

ControlUtil Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Convert Class

Provides conversion methods for some .NET types.

For a list of all members of this type, see Convert Members.

System.Object
Convert

[Visual Basic]
Public Class Convert
[C#]
public class Convert

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Library

Assembly: NETXP.Library (in NETXP.Library.dll)

See Also

Convert Members | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Convert Members

Convert overview

Public Static (Shared) Methods

PointToString | Converts a given Point to a string.
SizeToString | Converts a given Size to a string.
StringToPoint | Converts a given string to a Point.
StringToSize | Converts a given string to a Size.

Public Instance Constructors

Convert Constructor Initializes a new instance of the Convert class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Convert Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Convert Constructor

Initializes a new instance of the Convert class.

[Visual Basic]
Public Sub New()
[C#]
public Convert();

See Also

Convert Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Convert Methods

The methods of the Convert class are listed below. For a complete list of Convert class members, see the Convert Members topic.

Public Static (Shared) Methods

PointToString | Converts a given Point to a string.
SizeToString | Converts a given Size to a string.
StringToPoint | Converts a given string to a Point.
StringToSize | Converts a given string to a Size.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Convert Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Convert.PointToString Method

Converts a given Point to a string.

[Visual Basic]
Public Shared Function PointToString( _
ByVal point As Point _
) As String
[C#]
public static string PointToString(
Point point
);

Parameters

point
The point to convert.

Return Value

A string representation of the point.

See Also

Convert Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Convert.SizeToString Method

Converts a given Size to a string.

[Visual Basic]
Public Shared Function SizeToString( _
ByVal size As Size _
) As String
[C#]
public static string SizeToString(
Size size
);

Parameters

size
The size to convert.

Return Value

A string representation of the size.

See Also

Convert Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Convert.StringToPoint Method

Converts a given string to a Point.

[Visual Basic]
Public Shared Function StringToPoint( _
ByVal str As String _
) As Point
[C#]
public static Point StringToPoint(
string str
);

Parameters

str
The string representation of the point.

Return Value

The point, parsed from the string.

See Also

Convert Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Convert.StringToSize Method

Converts a given string to a Size.

[Visual Basic]
Public Shared Function StringToSize( _
ByVal str As String _
) As Size
[C#]
public static Size StringToSize(
string str
);

Parameters

str
The string representation of the size.

Return Value

The size, parsed from the string.

See Also

Convert Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


CustomColorTable Class

Implements a custom color table. You can instantiate this color table and replace the colors in the Colors collection with your own colors.

For a list of all members of this type, see CustomColorTable Members.

System.Object
CustomColorTable

[Visual Basic]
Public Class CustomColorTable
Implements NETXP.Library.IColorTable
[C#]
public class CustomColorTable : IColorTable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Library

Assembly: NETXP.Library (in NETXP.Library.dll)

See Also

CustomColorTable Members | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


CustomColorTable Members

CustomColorTable overview

Public Instance Constructors

CustomColorTable Constructor Constructs a new custom color table.

Public Instance Properties

Colors Gets the collection of colors provided by this color table.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

CustomColorTable Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


CustomColorTable Constructor

Constructs a new custom color table.

[Visual Basic]
Public Sub New()
[C#]
public CustomColorTable();

See Also

CustomColorTable Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


CustomColorTable Properties

The properties of the CustomColorTable class are listed below. For a complete list of CustomColorTable class members, see the CustomColorTable Members topic.

Public Instance Properties

Colors Gets the collection of colors provided by this color table.

See Also

CustomColorTable Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


CustomColorTable.Colors Property

Gets the collection of colors provided by this color table.

[Visual Basic]
NotOverridable Public ReadOnly Property Colors As ColorCollection Implements _
IColorTable.Colors
[C#]
public ColorCollection Colors {get;}

Implements

IColorTable.Colors

See Also

CustomColorTable Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Direction Enumeration

Direction of docking.

[Visual Basic]
Public Enum Direction
[C#]
public enum Direction

Members

Member Name | Description
Vertical | Vertical
Horizontal | Horizontal

Requirements

Namespace: NETXP.Library

Assembly: NETXP.Library (in NETXP.Library.dll)

See Also

NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


DoNotObfuscateAttribute Class

Internal

For a list of all members of this type, see DoNotObfuscateAttribute Members.

System.Object
Attribute
DoNotObfuscateAttribute

[Visual Basic]
Public Class DoNotObfuscateAttribute
Inherits Attribute
[C#]
public class DoNotObfuscateAttribute : Attribute

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Library

Assembly: NETXP.Library (in NETXP.Library.dll)

See Also

DoNotObfuscateAttribute Members | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


DoNotObfuscateAttribute Members

DoNotObfuscateAttribute overview

Public Instance Constructors

DoNotObfuscateAttribute Constructor Internal

Public Instance Properties

TypeId (inherited from Attribute) When implemented in a derived class, gets a unique identifier for this Attribute.

Public Instance Methods

Equals (inherited from Attribute) |
GetHashCode (inherited from Attribute) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IsDefaultAttribute (inherited from Attribute) | When overridden in a derived class, returns an indication whether the value of this instance is the default value for the derived class.
Match (inherited from Attribute) | When overridden in a derived class, returns a value indicating whether this instance equals a specified object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

_Attribute.GetIDsOfNames (inherited from Attribute)
_Attribute.GetTypeInfo (inherited from Attribute)
_Attribute.GetTypeInfoCount (inherited from Attribute)
_Attribute.Invoke (inherited from Attribute)

See Also

DoNotObfuscateAttribute Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


DoNotObfuscateAttribute Constructor

Internal

[Visual Basic]
Public Sub New()
[C#]
public DoNotObfuscateAttribute();

See Also

DoNotObfuscateAttribute Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


DrawUtil Class

Provides some utility functions for drawing.

For a list of all members of this type, see DrawUtil Members.

System.Object
DrawUtil

[Visual Basic]
Public Class DrawUtil
[C#]
public class DrawUtil

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Library

Assembly: NETXP.Library (in NETXP.Library.dll)

See Also

DrawUtil Members | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


DrawUtil Members

DrawUtil overview

Public Static (Shared) Methods

DrawDragRectangle | Draws a drag rectangle with the given indent.
DrawDragRectangles | Draws drag rectangles with the specified indent.
DrawGlyph | Draws a NetXP common glyph using the given color, at the specified location.
DrawReverseString | Draws a string upside down.

Public Instance Constructors

DrawUtil Constructor Initializes a new instance of the DrawUtil class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

DrawUtil Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


DrawUtil Constructor

Initializes a new instance of the DrawUtil class.

[Visual Basic]
Public Sub New()
[C#]
public DrawUtil();

See Also

DrawUtil Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


DrawUtil Methods

The methods of the DrawUtil class are listed below. For a complete list of DrawUtil class members, see the DrawUtil Members topic.

Public Static (Shared) Methods

DrawDragRectangle | Draws a drag rectangle with the given indent.
DrawDragRectangles | Draws drag rectangles with the specified indent.
DrawGlyph | Draws a NetXP common glyph using the given color, at the specified location.
DrawReverseString | Draws a string upside down.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

DrawUtil Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


DrawUtil.DrawDragRectangle Method

Draws a drag rectangle with the given indent.

[Visual Basic]
Public Shared Sub DrawDragRectangle( _
ByVal newRect As Rectangle, _
ByVal indent As Integer _
)
[C#]
public static void DrawDragRectangle(
Rectangle newRect,
int indent
);

Parameters

newRect
The rectangle.
indent
The indent.

See Also

DrawUtil Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


DrawUtil.DrawDragRectangles Method

Draws drag rectangles with the specified indent.

[Visual Basic]
Public Shared Sub DrawDragRectangles( _
ByVal newRects As Rectangle(), _
ByVal indent As Integer _
)
[C#]
public static void DrawDragRectangles(
Rectangle[] newRects,
int indent
);

Parameters

newRects
The rectangles.
indent
The indent.

See Also

DrawUtil Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


DrawUtil.DrawGlyph Method

Draws a NetXP common glyph using the given color, at the specified location.

[Visual Basic]
Public Shared Sub DrawGlyph( _
ByVal glyph As Glyph, _
ByVal color As Color, _
ByVal g As Graphics, _
ByVal x As Integer, _
ByVal y As Integer _
)
[C#]
public static void DrawGlyph(
Glyph glyph,
Color color,
Graphics g,
int x,
int y
);

Parameters

glyph
The NetXP common glyph to draw.
color
The color with which to draw it.
g
The graphics object where this glyph is to be drawn.
x
The location (x).
y
The location (y).

See Also

DrawUtil Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


DrawUtil.DrawReverseString Method

Draws a string upside down.

[Visual Basic]
Public Shared Sub DrawReverseString( _
ByVal g As Graphics, _
ByVal drawText As String, _
ByVal drawFont As Font, _
ByVal drawRect As Rectangle, _
ByVal drawBrush As Brush, _
ByVal drawFormat As StringFormat _
)
[C#]
public static void DrawReverseString(
Graphics g,
string drawText,
Font drawFont,
Rectangle drawRect,
Brush drawBrush,
StringFormat drawFormat
);

Parameters

g
The graphics object.
drawText
The string to draw.
drawFont
The font to draw with.
drawRect
The rectangle to draw inside.
drawBrush
The brush to draw with.
drawFormat
The format of the string.

See Also

DrawUtil Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


DrawUtil.CommandState Enumeration

Internal.

[Visual Basic]
Public Enum DrawUtil.CommandState
[C#]
public enum DrawUtil.CommandState

Members

Member Name | Description
Normal | Internal.
HotTrack | Internal.
Pushed | Internal.

Requirements

Namespace: NETXP.Library

Assembly: NETXP.Library (in NETXP.Library.dll)

See Also

NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


DynamicColorTable Class

Provides colors based on the current visual style.

For a list of all members of this type, see DynamicColorTable Members.

System.Object
DynamicColorTable

[Visual Basic]
Public Class DynamicColorTable
Implements NETXP.Library.IColorTable
[C#]
public class DynamicColorTable : IColorTable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Library

Assembly: NETXP.Library (in NETXP.Library.dll)

See Also

DynamicColorTable Members | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


DynamicColorTable Members

DynamicColorTable overview

Public Instance Constructors

DynamicColorTable Constructor Initializes a new instance of the DynamicColorTable class.

Public Instance Properties

Colors Gets the collection of colors provided by this color table.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

DynamicColorTable Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


DynamicColorTable Constructor

Initializes a new instance of the DynamicColorTable class.

[Visual Basic]
Public Sub New()
[C#]
public DynamicColorTable();

See Also

DynamicColorTable Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


DynamicColorTable Properties

The properties of the DynamicColorTable class are listed below. For a complete list of DynamicColorTable class members, see the DynamicColorTable Members topic.

Public Instance Properties

Colors Gets the collection of colors provided by this color table.

See Also

DynamicColorTable Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


DynamicColorTable.Colors Property

Gets the collection of colors provided by this color table.

[Visual Basic]
NotOverridable Public ReadOnly Property Colors As ColorCollection Implements _
IColorTable.Colors
[C#]
public ColorCollection Colors {get;}

Implements

IColorTable.Colors

See Also

DynamicColorTable Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Edge Enumeration

Docked Edge

[Visual Basic]
Public Enum Edge
[C#]
public enum Edge

Members

Member Name | Description
Top | Top
Left | Left
Bottom | Bottom
Right | Right
None | No edge

Requirements

Namespace: NETXP.Library

Assembly: NETXP.Library (in NETXP.Library.dll)

See Also

NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


EndChoices Enumeration

Which button was chosen when the dialog box quit.

[Visual Basic]
Public Enum EndChoices
[C#]
public enum EndChoices

Members

Member Name | Description
Continue | Continue (ignore exception)
TechSupport | Request technical support
Exit | Exit application

Requirements

Namespace: NETXP.Library

Assembly: NETXP.Library (in NETXP.Library.dll)

See Also

NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


FTP Class

The FTP class provides simple functionality of an FTP client.

For a list of all members of this type, see FTP Members.

System.Object
FTP

[Visual Basic]
Public Class FTP
[C#]
public class FTP

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Library

Assembly: NETXP.Library (in NETXP.Library.dll)

See Also

FTP Members | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


FTP Members

FTP overview

Public Instance Constructors

FTP Constructor Constructs a new FTP connection.

Public Instance Properties

RemoteHost | Gets/sets the name of the FTP server to connect to.
RemotePass | Gets/sets the password to use for logging into the remote server.
RemotePath | Gets/sets the remote directory path.
RemotePort | Gets/sets the port number to use for FTP.
RemoteUser | Gets/sets the user name to use for logging into the remote server.

Public Instance Methods

ChangeDirectory | Change the current working directory on the remote FTP server.
Close | Close the FTP connection.
CreateDirectory | Create a directory on the remote FTP server.
DeleteRemoteFile | Delete a file from the remote FTP server.
Download | Overloaded. Download a file to the Assembly's local directory, keeping the same file name.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetFileList | Returns a string array containing the remote directory's file list.
GetFileSize | Gets the size of a file.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Login | Logs in to an FTP server.
RemoveDirectory | Delete a directory on the remote FTP server.
RenameRemoteFile | Rename a file on the remote FTP server. KNOWN PROBLEM: RNTO will not take care of existing file. i.e. It will overwrite if newFileName exist
SetBinaryMode | If the value of mode is true, set binary mode for downloads. Else, set Ascii mode.
SetDebug | Set debug mode.
ToString (inherited from Object) | Returns a String that represents the current Object.
Upload | Overloaded. Upload a file.

See Also

FTP Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


FTP Constructor

Constructs a new FTP connection.

[Visual Basic]
Public Sub New()
[C#]
public FTP();

See Also

FTP Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


FTP Properties

The properties of the FTP class are listed below. For a complete list of FTP class members, see the FTP Members topic.

Public Instance Properties

RemoteHost | Gets/sets the name of the FTP server to connect to.
RemotePass | Gets/sets the password to use for logging into the remote server.
RemotePath | Gets/sets the remote directory path.
RemotePort | Gets/sets the port number to use for FTP.
RemoteUser | Gets/sets the user name to use for logging into the remote server.

See Also

FTP Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


FTP.RemoteHost Property

Gets/sets the name of the FTP server to connect to.

[Visual Basic]
Public Property RemoteHost As String
[C#]
public string RemoteHost {get; set;}

See Also

FTP Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


FTP.RemotePass Property

Gets/sets the password to use for logging into the remote server.

[Visual Basic]
Public Property RemotePass As String
[C#]
public string RemotePass {get; set;}

See Also

FTP Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


FTP.RemotePath Property

Gets/sets the remote directory path.

[Visual Basic]
Public Property RemotePath As String
[C#]
public string RemotePath {get; set;}

See Also

FTP Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


FTP.RemotePort Property

Gets/sets the port number to use for FTP.

[Visual Basic]
Public Property RemotePort As Integer
[C#]
public int RemotePort {get; set;}

See Also

FTP Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


FTP.RemoteUser Property

Gets/sets the user name to use for logging into the remote server.

[Visual Basic]
Public Property RemoteUser As String
[C#]
public string RemoteUser {get; set;}

See Also

FTP Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


FTP Methods

The methods of the FTP class are listed below. For a complete list of FTP class members, see the FTP Members topic.

Public Instance Methods

ChangeDirectory | Change the current working directory on the remote FTP server.
Close | Close the FTP connection.
CreateDirectory | Create a directory on the remote FTP server.
DeleteRemoteFile | Delete a file from the remote FTP server.
Download | Overloaded. Download a file to the Assembly's local directory, keeping the same file name.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetFileList | Returns a string array containing the remote directory's file list.
GetFileSize | Gets the size of a file.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Login | Logs in to an FTP server.
RemoveDirectory | Delete a directory on the remote FTP server.
RenameRemoteFile | Rename a file on the remote FTP server. KNOWN PROBLEM: RNTO will not take care of existing file. i.e. It will overwrite if newFileName exist
SetBinaryMode | If the value of mode is true, set binary mode for downloads. Else, set Ascii mode.
SetDebug | Set debug mode.
ToString (inherited from Object) | Returns a String that represents the current Object.
Upload | Overloaded. Upload a file.

See Also

FTP Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


FTP.ChangeDirectory Method

Change the current working directory on the remote FTP server.

[Visual Basic]
Public Sub ChangeDirectory( _
ByVal dirName As String _
)
[C#]
public void ChangeDirectory(
string dirName
);

Parameters

dirName
New working directory.

See Also

FTP Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


FTP.Close Method

Close the FTP connection.

[Visual Basic]
Public Sub Close()
[C#]
public void Close();

See Also

FTP Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


FTP.CreateDirectory Method

Create a directory on the remote FTP server.

[Visual Basic]
Public Sub CreateDirectory( _
ByVal dirName As String _
)
[C#]
public void CreateDirectory(
string dirName
);

Parameters

dirName
Directory path.

See Also

FTP Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


FTP.DeleteRemoteFile Method

Delete a file from the remote FTP server.

[Visual Basic]
Public Sub DeleteRemoteFile( _
ByVal fileName As String _
)
[C#]
public void DeleteRemoteFile(
string fileName
);

Parameters

fileName
Remote file name.

See Also

FTP Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Download Method

NetXP 3.0 Reference

FTP.Download Method

Download a file to the Assembly's local directory, keeping the same file name.

Overload List

Download a file to the Assembly's local directory, keeping the same file name.

public void Download(string);

Download a remote file to the Assembly's local directory, keeping the same file name, and set the resume flag.

public void Download(string,bool);

Download a remote file to a local file name which can include a path. The local file name will be created or overwritten, but the path must exist.

public void Download(string,string);

Download a remote file to a local file name which can include a path, and set the resume flag. The local file name will be created or overwritten, but the path must exist.

public void Download(string,string,bool);

See Also

FTP Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


FTP.Download Method (String)

Download a file to the Assembly's local directory, keeping the same file name.

[Visual Basic]
Overloads Public Sub Download( _
ByVal remFileName As String _
)
[C#]
public void Download(
string remFileName
);

Parameters

remFileName
Remote file name.

See Also

FTP Class | NETXP.Library Namespace | FTP.Download Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


FTP.Download Method (String, Boolean)

Download a remote file to the Assembly's local directory, keeping the same file name, and set the resume flag.

[Visual Basic]
Overloads Public Sub Download( _
ByVal remFileName As String, _
ByVal resume As Boolean _
)
[C#]
public void Download(
string remFileName,
bool resume
);

Parameters

remFileName
Remote file name.
resume
Resume?

See Also

FTP Class | NETXP.Library Namespace | FTP.Download Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


FTP.Download Method (String, String)

Download a remote file to a local file name which can include a path. The local file name will be created or overwritten, but the path must exist.

[Visual Basic]
Overloads Public Sub Download( _
ByVal remFileName As String, _
ByVal locFileName As String _
)
[C#]
public void Download(
string remFileName,
string locFileName
);

Parameters

remFileName
Remote file name.
locFileName
Local file name.

See Also

FTP Class | NETXP.Library Namespace | FTP.Download Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


FTP.Download Method (String, String, Boolean)

Download a remote file to a local file name which can include a path, and set the resume flag. The local file name will be created or overwritten, but the path must exist.

[Visual Basic]
Overloads Public Sub Download( _
ByVal remFileName As String, _
ByVal locFileName As String, _
ByVal resume As Boolean _
)
[C#]
public void Download(
string remFileName,
string locFileName,
bool resume
);

Parameters

remFileName
Remote file name.
locFileName
Local file name.
resume
Resume?

See Also

FTP Class | NETXP.Library Namespace | FTP.Download Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


FTP.GetFileList Method

Returns a string array containing the remote directory's file list.

[Visual Basic]
Public Function GetFileList( _
ByVal mask As String _
) As String()
[C#]
public string[] GetFileList(
string mask
);

Parameters

mask
DOS-style file mask.

Return Value

String array of file names.

Exceptions

Exception Type | Condition
IOException | IOException

See Also

FTP Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


FTP.GetFileSize Method

Gets the size of a file.

[Visual Basic]
Public Function GetFileSize( _
ByVal fileName As String _
) As Long
[C#]
public long GetFileSize(
string fileName
);

Parameters

fileName
The file whose size to retrieve.

Return Value

The file's size.

Exceptions

Exception Type | Condition
IOException | IOException

See Also

FTP Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


FTP.Login Method

Logs in to an FTP server.

[Visual Basic]
Public Sub Login()
[C#]
public void Login();

Exceptions

Exception Type | Condition
IOException | IOException

See Also

FTP Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


FTP.RemoveDirectory Method

Delete a directory on the remote FTP server.

[Visual Basic]
Public Sub RemoveDirectory( _
ByVal dirName As String _
)
[C#]
public void RemoveDirectory(
string dirName
);

Parameters

dirName
Remote directory name.

See Also

FTP Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


FTP.RenameRemoteFile Method

Rename a file on the remote FTP server. KNOWN PROBLEM: RNTO will not take care of existing file. i.e. It will overwrite if newFileName exist

[Visual Basic]
Public Sub RenameRemoteFile( _
ByVal oldFileName As String, _
ByVal newFileName As String _
)
[C#]
public void RenameRemoteFile(
string oldFileName,
string newFileName
);

Parameters

oldFileName
Original file name.
newFileName
New file name.

See Also

FTP Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


FTP.SetBinaryMode Method

If the value of mode is true, set binary mode for downloads. Else, set Ascii mode.

[Visual Basic]
Public Sub SetBinaryMode( _
ByVal mode As Boolean _
)
[C#]
public void SetBinaryMode(
bool mode
);

Parameters

mode
See summary.

Exceptions

Exception Type | Condition
IOException | IOException

See Also

FTP Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


FTP.SetDebug Method

Set debug mode.

[Visual Basic]
Public Sub SetDebug( _
ByVal debug As Boolean _
)
[C#]
public void SetDebug(
bool debug
);

Parameters

debug

See Also

FTP Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Upload Method

NetXP 3.0 Reference

FTP.Upload Method

Upload a file.

Overload List

Upload a file.

public void Upload(string);

Upload a file and set the resume flag.

public void Upload(string,bool);

See Also

FTP Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


FTP.Upload Method (String)

Upload a file.

[Visual Basic]
Overloads Public Sub Upload( _
ByVal fileName As String _
)
[C#]
public void Upload(
string fileName
);

Parameters

fileName
File name.

See Also

FTP Class | NETXP.Library Namespace | FTP.Upload Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


FTP.Upload Method (String, Boolean)

Upload a file and set the resume flag.

[Visual Basic]
Overloads Public Sub Upload( _
ByVal fileName As String, _
ByVal resume As Boolean _
)
[C#]
public void Upload(
string fileName,
bool resume
);

Parameters

fileName
File name.
resume
Resume?

See Also

FTP Class | NETXP.Library Namespace | FTP.Upload Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Glyph Enumeration

Specifies the NetXP common glyphs found in this assembly.

[Visual Basic]
Public Enum Glyph
[C#]
public enum Glyph

Members

Member Name | Description
ChevronDown | A chevron pointing down.
DDArrow | A small arrow pointing down.
Expansion2003Chevron | The expansion item glyph for Office 2003 style, with a chevron.
Expansion2003NoChevron | The expansion item glyph for Office 2003 style, without a chevron.
Close | The MDI close button glyph.
Maximize | The MDI maximize button glyph.
Restore | The MDI restore button glyph.
AutoHide | Shows a pin pointing down.
Pin | Shows a pin pointing to the side.
LeftArrow | An arrow pointing left, such as the one used by the tab control.
RightArrow | An arrow pointing right, such as the one used by the tab control.
Minimize | The MDI minimize button glyph.
DownArrow | An arrow pointing down.
ExpansionXPChevron | The expansion item glyph for Office XP style, with a chevron.
ExpansionXPNoChevron | The expansion item glyph for Office XP style, without a chevron.
ChevronUp | A chevron pointing up.
UpArrow | An arrow pointing up.
TaskPaneChevronUp | The task pane group chevron, pointing up.
TaskPaneChevronDown | The task pane group chevron, pointing down.
TabbedGroupsHorizontal | Icon for "New Horizontal Tab Group".
TabbedGroupsVertical | Icon for "New Vertical Tab Group".

Requirements

Namespace: NETXP.Library

Assembly: NETXP.Library (in NETXP.Library.dll)

See Also

NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


IColorTable Interface

Defines what it means to be a color table.

For a list of all members of this type, see IColorTable Members.

[Visual Basic]
Public Interface IColorTable
[C#]
public interface IColorTable

Requirements

Namespace: NETXP.Library

Assembly: NETXP.Library (in NETXP.Library.dll)

See Also

IColorTable Members | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


IColorTable Members

IColorTable overview

Public Instance Properties

Colors A collection of colors.

See Also

IColorTable Interface | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


IColorTable Properties

The properties of the IColorTable interface are listed below. For a complete list of IColorTable interface members, see the IColorTable Members topic.

Public Instance Properties

Colors A collection of colors.

See Also

IColorTable Interface | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


IColorTable.Colors Property

A collection of colors.

[Visual Basic]
Property Colors As ColorCollection
[C#]
ColorCollection Colors {get;}

See Also

IColorTable Interface | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


IStatusMessageAcceptor Interface

Provides an interface for a status message acceptor for the command bars. This is typically implemented by a status bar.

For a list of all members of this type, see IStatusMessageAcceptor Members.

[Visual Basic]
Public Interface IStatusMessageAcceptor
[C#]
public interface IStatusMessageAcceptor

Requirements

Namespace: NETXP.Library

Assembly: NETXP.Library (in NETXP.Library.dll)

See Also

IStatusMessageAcceptor Members | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


IStatusMessageAcceptor Members

IStatusMessageAcceptor overview

Public Instance Methods

ClearStatusText | Clears the status text.
SetStatusText | Sets the status text.

See Also

IStatusMessageAcceptor Interface | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


IStatusMessageAcceptor Methods

The methods of the IStatusMessageAcceptor interface are listed below. For a complete list of IStatusMessageAcceptor interface members, see the IStatusMessageAcceptor Members topic.

Public Instance Methods

ClearStatusText | Clears the status text.
SetStatusText | Sets the status text.

See Also

IStatusMessageAcceptor Interface | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


IStatusMessageAcceptor.ClearStatusText Method

Clears the status text.

[Visual Basic]
Sub ClearStatusText()
[C#]
void ClearStatusText();

See Also

IStatusMessageAcceptor Interface | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


IStatusMessageAcceptor.SetStatusText Method

Sets the status text.

[Visual Basic]
Sub SetStatusText( _
ByVal text As String _
)
[C#]
void SetStatusText(
string text
);

Parameters

text
The status text.

See Also

IStatusMessageAcceptor Interface | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


IStatusMessageProvider Interface

Provides an interface for a status message provider for the command bars. This is typically implemented by a command bar item.

For a list of all members of this type, see IStatusMessageProvider Members.

[Visual Basic]
Public Interface IStatusMessageProvider
[C#]
public interface IStatusMessageProvider

Requirements

Namespace: NETXP.Library

Assembly: NETXP.Library (in NETXP.Library.dll)

See Also

IStatusMessageProvider Members | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


IStatusMessageProvider Members

IStatusMessageProvider overview

Public Instance Events

Enter | Called when the mouse has entered the item.
Leave | Called when the mouse has left the item.

See Also

IStatusMessageProvider Interface | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


IStatusMessageProvider Events

The events of the IStatusMessageProvider interface are listed below. For a complete list of IStatusMessageProvider interface members, see the IStatusMessageProvider Members topic.

Public Instance Events

Enter | Called when the mouse has entered the item.
Leave | Called when the mouse has left the item.

See Also

IStatusMessageProvider Interface | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


IStatusMessageProvider.Enter Event

Called when the mouse has entered the item.

[Visual Basic]
Event Enter As EventHandler
[C#]
event EventHandler Enter;

See Also

IStatusMessageProvider Interface | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


IStatusMessageProvider.Leave Event

Called when the mouse has left the item.

[Visual Basic]
Event Leave As EventHandler
[C#]
event EventHandler Leave;

See Also

IStatusMessageProvider Interface | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Mapi Class

Provides a simple MAPI wrapper.

For a list of all members of this type, see Mapi Members.

System.Object
Mapi

[Visual Basic]
NotInheritable Public Class Mapi
[C#]
public sealed class Mapi

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Library

Assembly: NETXP.Library (in NETXP.Library.dll)

See Also

Mapi Members | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Mapi Members

Mapi overview

Public Instance Constructors

Mapi Constructor Initializes a new instance of the Mapi class.

Public Instance Methods

AddRecip | Adds a recipient to a message.
Attach | Attaches a file.
Delete | Deletes a message.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Error | Retruns the string representation of a MAPI error.
GetAttachNames | Get's a message's attachment names.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Logoff | Ends the MAPI session.
Logon | Logs in to MAPI.
Next | Gets the next message in an envelope.
Read | Reads a message with the specified ID.
Reset | Resets MAPI handles.
SaveAttachByName | Saves attachment by name.
SaveAttachm | Saves a message's attachments.
Send | Sends a MAPI mail message.
SetSender | Sets the recipient.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Mapi Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Mapi Constructor

Initializes a new instance of the Mapi class.

[Visual Basic]
Public Sub New()
[C#]
public Mapi();

See Also

Mapi Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Mapi Methods

The methods of the Mapi class are listed below. For a complete list of Mapi class members, see the Mapi Members topic.

Public Instance Methods

AddRecip | Adds a recipient to a message.
Attach | Attaches a file.
Delete | Deletes a message.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Error | Retruns the string representation of a MAPI error.
GetAttachNames | Get's a message's attachment names.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Logoff | Ends the MAPI session.
Logon | Logs in to MAPI.
Next | Gets the next message in an envelope.
Read | Reads a message with the specified ID.
Reset | Resets MAPI handles.
SaveAttachByName | Saves attachment by name.
SaveAttachm | Saves a message's attachments.
Send | Sends a MAPI mail message.
SetSender | Sets the recipient.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Mapi Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Mapi.AddRecip Method

Adds a recipient to a message.

[Visual Basic]
Public Sub AddRecip( _
ByVal name As String, _
ByVal addr As String, _
ByVal cc As Boolean _
)
[C#]
public void AddRecip(
string name,
string addr,
bool cc
);

Parameters

name
addr
cc

See Also

Mapi Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Mapi.Attach Method

Attaches a file.

[Visual Basic]
Public Sub Attach( _
ByVal filepath As String _
)
[C#]
public void Attach(
string filepath
);

Parameters

filepath

See Also

Mapi Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Mapi.Delete Method

Deletes a message.

[Visual Basic]
Public Function Delete( _
ByVal id As String _
) As Boolean
[C#]
public bool Delete(
string id
);

Parameters

id

Return Value

See Also

Mapi Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Mapi.Error Method

Retruns the string representation of a MAPI error.

[Visual Basic]
Public Function Error() As String
[C#]
public string Error();

Return Value

See Also

Mapi Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Mapi.GetAttachNames Method

Get's a message's attachment names.

[Visual Basic]
Public Sub GetAttachNames( _
ByRef aat As MailAttach() _
)
[C#]
public void GetAttachNames(
out MailAttach[] aat
);

Parameters

aat

See Also

Mapi Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Mapi.Logoff Method

Ends the MAPI session.

[Visual Basic]
Public Sub Logoff()
[C#]
public void Logoff();

See Also

Mapi Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Mapi.Logon Method

Logs in to MAPI.

[Visual Basic]
Public Function Logon( _
ByVal hwnd As IntPtr _
) As Boolean
[C#]
public bool Logon(
IntPtr hwnd
);

Parameters

hwnd
Window to be parent of login dialog.

Return Value

True if succeeds.

See Also

Mapi Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Mapi.Next Method

Gets the next message in an envelope.

[Visual Basic]
Public Function Next( _
ByRef env As MailEnvelop _
) As Boolean
[C#]
public bool Next(
ref MailEnvelop env
);

Parameters

env

Return Value

See Also

Mapi Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Mapi.Read Method

Reads a message with the specified ID.

[Visual Basic]
Public Function Read( _
ByVal id As String, _
ByRef aat As MailAttach() _
) As String
[C#]
public string Read(
string id,
out MailAttach[] aat
);

Parameters

id
aat

Return Value

See Also

Mapi Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Mapi.Reset Method

Resets MAPI handles.

[Visual Basic]
Public Sub Reset()
[C#]
public void Reset();

See Also

Mapi Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Mapi.SaveAttachByName Method

Saves attachment by name.

[Visual Basic]
Public Function SaveAttachByName( _
ByVal name As String, _
ByVal savepath As String _
) As Boolean
[C#]
public bool SaveAttachByName(
string name,
string savepath
);

Parameters

name
Name of attachment.
savepath
Path to save.

Return Value

True if success, False if error.

See Also

Mapi Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Mapi.SaveAttachm Method

Saves a message's attachments.

[Visual Basic]
Public Function SaveAttachm( _
ByVal id As String, _
ByVal name As String, _
ByVal savepath As String _
) As Boolean
[C#]
public bool SaveAttachm(
string id,
string name,
string savepath
);

Parameters

id
name
savepath

Return Value

See Also

Mapi Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Mapi.Send Method

Sends a MAPI mail message.

[Visual Basic]
Public Function Send( _
ByVal sub As String, _
ByVal txt As String, _
ByVal flags As Integer _
) As Boolean
[C#]
public bool Send(
string sub,
string txt,
int flags
);

Parameters

sub
txt
flags

Return Value

See Also

Mapi Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Mapi.SetSender Method

Sets the recipient.

[Visual Basic]
Public Sub SetSender( _
ByVal sname As String, _
ByVal saddr As String _
)
[C#]
public void SetSender(
string sname,
string saddr
);

Parameters

sname
saddr

See Also

Mapi Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Margins Class

Provides a way to set up margins or padding.

For a list of all members of this type, see Margins Members.

System.Object
Margins

[Visual Basic]
Public Class Margins
[C#]
public class Margins

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Library

Assembly: NETXP.Library (in NETXP.Library.dll)

See Also

Margins Members | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Margins Members

Margins overview

Public Instance Constructors

Margins Overloaded. Initializes a new instance of the Margins class.

Public Instance Properties

Bottom | Gets or sets the value of the bottom margin.
Left | Gets or sets the value of the left margin.
Right | Gets or sets the value of the right margin.
Top | Gets or sets the value of the top margin.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Gets a string representation of this Margins object.

Public Instance Events

Changed Called when the Margins object has changed.

See Also

Margins Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Margins Constructor

Creates a new Margins object with default values.

Overload List

Creates a new Margins object with default values.

public Margins();

Creates a new Margins object with the given values.

public Margins(int,int,int,int);

See Also

Margins Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Margins Constructor ()

Creates a new Margins object with default values.

[Visual Basic]
Overloads Public Sub New()
[C#]
public Margins();

See Also

Margins Class | NETXP.Library Namespace | Margins Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Margins Constructor (Int32, Int32, Int32, Int32)

Creates a new Margins object with the given values.

[Visual Basic]
Overloads Public Sub New( _
ByVal left As Integer, _
ByVal top As Integer, _
ByVal right As Integer, _
ByVal bottom As Integer _
)
[C#]
public Margins(
int left,
int top,
int right,
int bottom
);

Parameters

left
The left margin.
top
The top margin.
right
The right margin.
bottom
The bottom margin.

See Also

Margins Class | NETXP.Library Namespace | Margins Constructor Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Margins Properties

The properties of the Margins class are listed below. For a complete list of Margins class members, see the Margins Members topic.

Public Instance Properties

Bottom | Gets or sets the value of the bottom margin.
Left | Gets or sets the value of the left margin.
Right | Gets or sets the value of the right margin.
Top | Gets or sets the value of the top margin.

See Also

Margins Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Margins.Bottom Property

Gets or sets the value of the bottom margin.

[Visual Basic]
Public Property Bottom As Integer
[C#]
public int Bottom {get; set;}

See Also

Margins Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Margins.Left Property

Gets or sets the value of the left margin.

[Visual Basic]
Public Property Left As Integer
[C#]
public int Left {get; set;}

See Also

Margins Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Margins.Right Property

Gets or sets the value of the right margin.

[Visual Basic]
Public Property Right As Integer
[C#]
public int Right {get; set;}

See Also

Margins Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Margins.Top Property

Gets or sets the value of the top margin.

[Visual Basic]
Public Property Top As Integer
[C#]
public int Top {get; set;}

See Also

Margins Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Margins Methods

The methods of the Margins class are listed below. For a complete list of Margins class members, see the Margins Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Gets a string representation of this Margins object.

See Also

Margins Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Margins.ToString Method

Gets a string representation of this Margins object.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

A string representation of this Margins object.

See Also

Margins Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Margins Events

The events of the Margins class are listed below. For a complete list of Margins class members, see the Margins Members topic.

Public Instance Events

Changed Called when the Margins object has changed.

See Also

Margins Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Margins.Changed Event

Called when the Margins object has changed.

[Visual Basic]
Public Event Changed As EventHandler
[C#]
public event EventHandler Changed;

See Also

Margins Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Msg Class

Contains utility functions for displaying different kinds of messages.

For a list of all members of this type, see Msg Members.

System.Object
Msg

[Visual Basic]
NotInheritable Public Class Msg
[C#]
public sealed class Msg

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Library

Assembly: NETXP.Library (in NETXP.Library.dll)

See Also

Msg Members | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Msg Members

Msg overview

Public Static (Shared) Methods

AskIsYes | Asks the user a question.
Except | Creates an exception dialog.
Notify | Notifies the user using a message box.

Public Instance Constructors

Msg Constructor Initializes a new instance of the Msg class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Msg Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Msg Constructor

Initializes a new instance of the Msg class.

[Visual Basic]
Public Sub New()
[C#]
public Msg();

See Also

Msg Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Msg Methods

The methods of the Msg class are listed below. For a complete list of Msg class members, see the Msg Members topic.

Public Static (Shared) Methods

AskIsYes | Asks the user a question.
Except | Creates an exception dialog.
Notify | Notifies the user using a message box.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Msg Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Msg.AskIsYes Method

Asks the user a question.

[Visual Basic]
Public Shared Function AskIsYes( _
ByVal parent As IWin32Window, _
ByVal appname As String, _
ByVal prompt As String _
) As Boolean
[C#]
public static bool AskIsYes(
IWin32Window parent,
string appname,
string prompt
);

Parameters

parent
The parent window of the message box. Can be null.
appname
The application asking the question.
prompt
The question.

Return Value

The user's answer to the question (True = Yes, False = No).

See Also

Msg Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Msg.Except Method

Creates an exception dialog.

[Visual Basic]
Public Shared Function Except( _
ByVal parent As IWin32Window, _
ByVal x As Exception, _
ByVal appname As String _
) As EndChoices
[C#]
public static EndChoices Except(
IWin32Window parent,
Exception x,
string appname
);

Parameters

parent
The parent window. Can be null.
x
The exception to describe.
appname
The application causing the exception.

Return Value

Which button was chosen when the dialog quit.

See Also

Msg Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Msg.Notify Method

Notifies the user using a message box.

[Visual Basic]
Public Shared Sub Notify( _
ByVal parent As IWin32Window, _
ByVal appname As String, _
ByVal message As String _
)
[C#]
public static void Notify(
IWin32Window parent,
string appname,
string message
);

Parameters

parent
The parent window. Can be null.
appname
The name of the application displaying the notification.
message
The notification.

See Also

Msg Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


PopupForm Class

Provides an inheritable, reusable popup form that implements all the functionality of a typical popup window.

For a list of all members of this type, see PopupForm Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
PopupForm

[Visual Basic]
Public Class PopupForm
Inherits Form
Implements System.Windows.Forms.IMessageFilter
[C#]
public class PopupForm : Form, IMessageFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Call the ShowPopup function instead of the Show function to display a popup form.

Example

// using a PopupForm in a control
PopupForm frm = new PopupForm();
frm.ShowPopup(this.FindForm(), new Point(0, 0), false);

Requirements

Namespace: NETXP.Library

Assembly: NETXP.Library (in NETXP.Library.dll)

See Also

PopupForm Members | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


PopupForm Members

PopupForm overview

Public Instance Constructors

PopupForm Constructor Constructs a new PopupForm.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) |
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScale (inherited from Form) | Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
BottomShadow | Gets the bottom shadow window.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Filter | Gets the message filter.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | [To be supplied.]
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
HasShadow | Does this form have a shadow?
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsRestrictedWindow (inherited from Form) |
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightShadow | Gets the right-side shadow window.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShadowSize | Gets or sets the shadow size.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) |
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as the top-most form of your application.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreFilterMessage | Internal
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Control) | Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with no owner window.
ShowPopup | Shows a popup form at the specified location.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is not the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
ShadowCreated | Raised when the shadow of the form has been created.
Showing | Raised when showing the form. Provides an opportunity to animate the form.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) |
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

PopupForm Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


PopupForm Constructor

Constructs a new PopupForm.

[Visual Basic]
Public Sub New()
[C#]
public PopupForm();

See Also

PopupForm Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


PopupForm Properties

The properties of the PopupForm class are listed below. For a complete list of PopupForm class members, see the PopupForm Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) |
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScale (inherited from Form) | Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
BottomShadow | Gets the bottom shadow window.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Filter | Gets the message filter.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | [To be supplied.]
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
HasShadow | Does this form have a shadow?
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsRestrictedWindow (inherited from Form) |
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightShadow | Gets the right-side shadow window.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShadowSize | Gets or sets the shadow size.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) |
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as the top-most form of your application.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

PopupForm Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


PopupForm.BottomShadow Property

Gets the bottom shadow window.

[Visual Basic]
Overridable Public ReadOnly Property BottomShadow As ShadowWindow
[C#]
public virtual ShadowWindow BottomShadow {get;}

See Also

PopupForm Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


PopupForm.Filter Property

Gets the message filter.

[Visual Basic]
Overridable Public ReadOnly Property Filter As PopupMessageFilter
[C#]
public virtual PopupMessageFilter Filter {get;}

See Also

PopupForm Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


PopupForm.HasShadow Property

Does this form have a shadow?

[Visual Basic]
Overridable Public Property HasShadow As Boolean
[C#]
public virtual bool HasShadow {get; set;}

See Also

PopupForm Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


PopupForm.RightShadow Property

Gets the right-side shadow window.

[Visual Basic]
Overridable Public ReadOnly Property RightShadow As ShadowWindow
[C#]
public virtual ShadowWindow RightShadow {get;}

See Also

PopupForm Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


PopupForm.ShadowSize Property

Gets or sets the shadow size.

[Visual Basic]
Overridable Public Property ShadowSize As Integer
[C#]
public virtual int ShadowSize {get; set;}

See Also

PopupForm Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


PopupForm Methods

The methods of the PopupForm class are listed below. For a complete list of PopupForm class members, see the PopupForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreFilterMessage | Internal
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Control) | Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with no owner window.
ShowPopup | Shows a popup form at the specified location.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

PopupForm Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


PopupForm.PreFilterMessage Method

Internal

[Visual Basic]
NotOverridable Public Function PreFilterMessage( _
ByRef m As Message _
) As Boolean Implements _
IMessageFilter.PreFilterMessage
[C#]
public bool PreFilterMessage(
ref Message m
);

Parameters

m

Return Value

Implements

IMessageFilter.PreFilterMessage

See Also

PopupForm Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


PopupForm.ShowPopup Method

Shows a popup form at the specified location.

[Visual Basic]
Overridable Public Sub ShowPopup( _
ByVal owner As Form, _
ByVal location As Point, _
ByVal modal As Boolean _
)
[C#]
public virtual void ShowPopup(
Form owner,
Point location,
bool modal
);

Parameters

owner
The owner form for the popup form.
location
The location, in screen coordinates, where the popup is shown.
modal
Is this a modal popup?

Remarks

You may specify a null owner form, but it will mean that the popup control will deactivate all other forms when it is shown.

See Also

PopupForm Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


PopupForm Events

The events of the PopupForm class are listed below. For a complete list of PopupForm class members, see the PopupForm Members topic.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is not the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
ShadowCreated | Raised when the shadow of the form has been created.
Showing | Raised when showing the form. Provides an opportunity to animate the form.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) |
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

PopupForm Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


PopupForm.ShadowCreated Event

Raised when the shadow of the form has been created.

[Visual Basic]
Public Event ShadowCreated As EventHandler
[C#]
public event EventHandler ShadowCreated;

See Also

PopupForm Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


PopupForm.Showing Event

Raised when showing the form. Provides an opportunity to animate the form.

[Visual Basic]
Public Event Showing As EventHandler
[C#]
public event EventHandler Showing;

See Also

PopupForm Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


PopupMessageFilter Class

Provides a reusable message filter for popup controls.

For a list of all members of this type, see PopupMessageFilter Members.

System.Object
PopupMessageFilter

[Visual Basic]
Public Class PopupMessageFilter
Implements System.Windows.Forms.IMessageFilter
[C#]
public class PopupMessageFilter : IMessageFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Library

Assembly: NETXP.Library (in NETXP.Library.dll)

See Also

PopupMessageFilter Members | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


PopupMessageFilter Members

PopupMessageFilter overview

Public Instance Constructors

PopupMessageFilter Constructor Constructs a new message filter for the given popup form.

Public Instance Properties

Modal | Gets/sets whether or not the popup is running in modal mode.
Popup | Gets/sets the popup form which is being displayed.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
PreFilterMessage | Filters messages.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

FilterMessage Raised when filtering a message.

See Also

PopupMessageFilter Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


PopupMessageFilter Constructor

Constructs a new message filter for the given popup form.

[Visual Basic]
Public Sub New( _
ByVal popup As Form _
)
[C#]
public PopupMessageFilter(
Form popup
);

Parameters

popup
The popup form.

See Also

PopupMessageFilter Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


PopupMessageFilter Properties

The properties of the PopupMessageFilter class are listed below. For a complete list of PopupMessageFilter class members, see the PopupMessageFilter Members topic.

Public Instance Properties

Modal | Gets/sets whether or not the popup is running in modal mode.
Popup | Gets/sets the popup form which is being displayed.

See Also

PopupMessageFilter Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


PopupMessageFilter.Modal Property

Gets/sets whether or not the popup is running in modal mode.

[Visual Basic]
Public Property Modal As Boolean
[C#]
public bool Modal {get; set;}

See Also

PopupMessageFilter Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


PopupMessageFilter.Popup Property

Gets/sets the popup form which is being displayed.

[Visual Basic]
Public Property Popup As Form
[C#]
public System.Windows.Forms.Form Popup {get; set;}

See Also

PopupMessageFilter Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


PopupMessageFilter Methods

The methods of the PopupMessageFilter class are listed below. For a complete list of PopupMessageFilter class members, see the PopupMessageFilter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
PreFilterMessage | Filters messages.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

PopupMessageFilter Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


PopupMessageFilter.PreFilterMessage Method

Filters messages.

[Visual Basic]
NotOverridable Public Function PreFilterMessage( _
ByRef m As Message _
) As Boolean Implements _
IMessageFilter.PreFilterMessage
[C#]
public bool PreFilterMessage(
ref Message m
);

Parameters

m
The message.

Return Value

True if message should be devoured.

Implements

IMessageFilter.PreFilterMessage

See Also

PopupMessageFilter Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


PopupMessageFilter Events

The events of the PopupMessageFilter class are listed below. For a complete list of PopupMessageFilter class members, see the PopupMessageFilter Members topic.

Public Instance Events

FilterMessage Raised when filtering a message.

See Also

PopupMessageFilter Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


PopupMessageFilter.FilterMessage Event

Raised when filtering a message.

[Visual Basic]
Public Event FilterMessage As FilterMessageHandler
[C#]
public event FilterMessageHandler FilterMessage;

See Also

PopupMessageFilter Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


PopupMessageFilter.FilterMessageHandler Delegate

Handles the FilterMessage event.

[Visual Basic]
Public Delegate Function PopupMessageFilter.FilterMessageHandler( _
ByVal sender As Object, _
ByRef m As Message _
) As Boolean
[C#]
public delegate bool PopupMessageFilter.FilterMessageHandler(
object sender,
ref Message m
);

Requirements

Namespace: NETXP.Library

Assembly: NETXP.Library (in NETXP.Library.dll)

See Also

NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


QuickMail Class

Provides easy access to Simple MAPI functions.

For a list of all members of this type, see QuickMail Members.

System.Object
QuickMail

[Visual Basic]
NotInheritable Public Class QuickMail
[C#]
public sealed class QuickMail

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Library

Assembly: NETXP.Library (in NETXP.Library.dll)

See Also

QuickMail Members | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


QuickMail Members

QuickMail overview

Public Static (Shared) Methods

InitMapi | Initializes MAPI.
SendMessage | Sends a mail message.

Public Instance Constructors

QuickMail Constructor Initializes a new instance of the QuickMail class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

QuickMail Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


QuickMail Constructor

Initializes a new instance of the QuickMail class.

[Visual Basic]
Public Sub New()
[C#]
public QuickMail();

See Also

QuickMail Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


QuickMail Methods

The methods of the QuickMail class are listed below. For a complete list of QuickMail class members, see the QuickMail Members topic.

Public Static (Shared) Methods

InitMapi | Initializes MAPI.
SendMessage | Sends a mail message.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

QuickMail Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


QuickMail.InitMapi Method

Initializes MAPI.

[Visual Basic]
Public Shared Function InitMapi( _
ByVal hWnd As IntPtr _
) As Mapi
[C#]
public static Mapi InitMapi(
IntPtr hWnd
);

Parameters

hWnd
The window to use as parent for login UI.

Return Value

A Mapi object.

See Also

QuickMail Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


QuickMail.SendMessage Method

Sends a mail message.

[Visual Basic]
Public Shared Sub SendMessage( _
ByVal from As String, _
ByVal to As String, _
ByVal subj As String, _
ByVal body As String, _
ByVal flags As Integer, _
ByVal fileattach As String() _
)
[C#]
public static void SendMessage(
string from,
string to,
string subj,
string body,
int flags,
string[] fileattach
);

Parameters

from
From who?
to
To whom?
subj
Subject
body
Body or note
flags
Flags
fileattach
File attachments (string array)

See Also

QuickMail Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Resources Class

Provides a better way to work with .NET resources.

For a list of all members of this type, see Resources Members.

System.Object
Resources

[Visual Basic]
Public Class Resources
[C#]
public class Resources

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Library

Assembly: NETXP.Library (in NETXP.Library.dll)

See Also

Resources Members | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Resources Members

Resources overview

Public Static (Shared) Methods

LoadBitmap | Overloaded. Loads a bitmap from the specified assembly and bitmap file name.
LoadBitmapStrip | Overloaded. Loads a strip of images as an image list.
LoadCursor | Loads a cursor from a given assembly and cursor file name.
LoadGlyphs | Gets the .NET common glyphs as an image list.
LoadIcon | Overloaded. Loads an icon from a given assembly and icon file name.

Public Instance Constructors

Resources Constructor Initializes a new instance of the Resources class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Resources Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Resources Constructor

Initializes a new instance of the Resources class.

[Visual Basic]
Public Sub New()
[C#]
public Resources();

See Also

Resources Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Resources Methods

The methods of the Resources class are listed below. For a complete list of Resources class members, see the Resources Members topic.

Public Static (Shared) Methods

LoadBitmap | Overloaded. Loads a bitmap from the specified assembly and bitmap file name.
LoadBitmapStrip | Overloaded. Loads a strip of images as an image list.
LoadCursor | Loads a cursor from a given assembly and cursor file name.
LoadGlyphs | Gets the .NET common glyphs as an image list.
LoadIcon | Overloaded. Loads an icon from a given assembly and icon file name.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Resources Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


LoadBitmap Method

NetXP 3.0 Reference

Resources.LoadBitmap Method

Loads a bitmap from the specified assembly and bitmap file name.

Overload List

Loads a bitmap from the specified assembly and bitmap file name.

public static Bitmap LoadBitmap(Type,string);

Loads a bitmap from the specified assembly and bitmap file name, setting transparency.

public static Bitmap LoadBitmap(Type,string,Point);

See Also

Resources Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Resources.LoadBitmap Method (Type, String)

Loads a bitmap from the specified assembly and bitmap file name.

[Visual Basic]
Overloads Public Shared Function LoadBitmap( _
ByVal assemblyType As Type, _
ByVal imageName As String _
) As Bitmap
[C#]
public static Bitmap LoadBitmap(
Type assemblyType,
string imageName
);

Parameters

assemblyType
The assembly.
imageName
The file name.

Return Value

The bitmap.

See Also

Resources Class | NETXP.Library Namespace | Resources.LoadBitmap Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Resources.LoadBitmap Method (Type, String, Point)

Loads a bitmap from the specified assembly and bitmap file name, setting transparency.

[Visual Basic]
Overloads Public Shared Function LoadBitmap( _
ByVal assemblyType As Type, _
ByVal imageName As String, _
ByVal transparentPixel As Point _
) As Bitmap
[C#]
public static Bitmap LoadBitmap(
Type assemblyType,
string imageName,
Point transparentPixel
);

Parameters

assemblyType
The assembly.
imageName
The file name.
transparentPixel
The pixel location at which the transparent color is found.

Return Value

The bitmap.

See Also

Resources Class | NETXP.Library Namespace | Resources.LoadBitmap Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


LoadBitmapStrip Method

NetXP 3.0 Reference

Resources.LoadBitmapStrip Method

Loads a strip of images as an image list.

Overload List

Loads a strip of images as an image list.

public static ImageList LoadBitmapStrip(Type,string,Size);

Loads a strip of images as an image list, with transparency.

public static ImageList LoadBitmapStrip(Type,string,Size,Point);

See Also

Resources Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Resources.LoadBitmapStrip Method (Type, String, Size)

Loads a strip of images as an image list.

[Visual Basic]
Overloads Public Shared Function LoadBitmapStrip( _
ByVal assemblyType As Type, _
ByVal imageName As String, _
ByVal imageSize As Size _
) As ImageList
[C#]
public static ImageList LoadBitmapStrip(
Type assemblyType,
string imageName,
Size imageSize
);

Parameters

assemblyType
The assembly.
imageName
The bitmap file name.
imageSize
The image size.

Return Value

A bitmap strip as an image list.

See Also

Resources Class | NETXP.Library Namespace | Resources.LoadBitmapStrip Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Resources.LoadBitmapStrip Method (Type, String, Size, Point)

Loads a strip of images as an image list, with transparency.

[Visual Basic]
Overloads Public Shared Function LoadBitmapStrip( _
ByVal assemblyType As Type, _
ByVal imageName As String, _
ByVal imageSize As Size, _
ByVal transparentPixel As Point _
) As ImageList
[C#]
public static ImageList LoadBitmapStrip(
Type assemblyType,
string imageName,
Size imageSize,
Point transparentPixel
);

Parameters

assemblyType
The assembly.
imageName
The bitmap file name.
imageSize
The image size.
transparentPixel
The pixel location at which the transparent color is found.

Return Value

A bitmap strip as an image list.

See Also

Resources Class | NETXP.Library Namespace | Resources.LoadBitmapStrip Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Resources.LoadCursor Method

Loads a cursor from a given assembly and cursor file name.

[Visual Basic]
Public Shared Function LoadCursor( _
ByVal assemblyType As Type, _
ByVal cursorName As String _
) As Cursor
[C#]
public static Cursor LoadCursor(
Type assemblyType,
string cursorName
);

Parameters

assemblyType
The assembly.
cursorName
The cursor file name.

Return Value

The cursor.

See Also

Resources Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Resources.LoadGlyphs Method

Gets the .NET common glyphs as an image list.

[Visual Basic]
Public Shared Function LoadGlyphs() As ImageList
[C#]
public static ImageList LoadGlyphs();

Return Value

The glyphs.

See Also

Resources Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


LoadIcon Method

NetXP 3.0 Reference

Resources.LoadIcon Method

Loads an icon from a given assembly and icon file name.

Overload List

Loads an icon from a given assembly and icon file name.

public static Icon LoadIcon(Type,string);

Loads an icon from a given assembly and icon file name, with the specified size.

public static Icon LoadIcon(Type,string,Size);

See Also

Resources Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Resources.LoadIcon Method (Type, String)

Loads an icon from a given assembly and icon file name.

[Visual Basic]
Overloads Public Shared Function LoadIcon( _
ByVal assemblyType As Type, _
ByVal iconName As String _
) As Icon
[C#]
public static Icon LoadIcon(
Type assemblyType,
string iconName
);

Parameters

assemblyType
The assembly.
iconName
The icon file name.

Return Value

The icon.

See Also

Resources Class | NETXP.Library Namespace | Resources.LoadIcon Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Resources.LoadIcon Method (Type, String, Size)

Loads an icon from a given assembly and icon file name, with the specified size.

[Visual Basic]
Overloads Public Shared Function LoadIcon( _
ByVal assemblyType As Type, _
ByVal iconName As String, _
ByVal iconSize As Size _
) As Icon
[C#]
public static Icon LoadIcon(
Type assemblyType,
string iconName,
Size iconSize
);

Parameters

assemblyType
The assembly.
iconName
The icon file name.
iconSize
The size of the icon image to load.

Return Value

The icon.

See Also

Resources Class | NETXP.Library Namespace | Resources.LoadIcon Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Settings Class

A class that is used to save and restore data using the registry or by binary serialization in a file. It works in conjuction with another class (with the recommended name "Settings") that contains all the data to be stored.

For a list of all members of this type, see Settings Members.

System.Object
Settings

[Visual Basic]
Public Class Settings
[C#]
public class Settings

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Library

Assembly: NETXP.Library (in NETXP.Library.dll)

See Also

Settings Members | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Settings Members

Settings overview

Public Static (Shared) Methods

IsHexadecimal | This returns true if the input is a string of valid hexadecimal digits 0-9, A-F, or a-f
Read | Overloaded. Read all the information in a class to the registry. This method iterates through all members of the specified class and reads them to the registry.
ReadFromFile | Read from a file using binary serialization. Normally a call to this method would cast the return value to the correct type as in this example: settings = (Settings)Savior.ReadFromFile(FileName);
Save | Overloaded. Save all the information in a class to the registry. This method iterates through all members of the specified class and saves them to the registry.
SaveToFile | Save settings to a file using binary serialization
ToString | Overloaded. Returns a list of all the fields and field types for the specified class Useful for debugging.

Public Instance Constructors

Settings Constructor Initializes a new instance of the Settings class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Overloaded. Returns a String that represents the current Object.

See Also

Settings Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Settings Constructor

Initializes a new instance of the Settings class.

[Visual Basic]
Public Sub New()
[C#]
public Settings();

See Also

Settings Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Settings Methods

The methods of the Settings class are listed below. For a complete list of Settings class members, see the Settings Members topic.

Public Static (Shared) Methods

IsHexadecimal | This returns true if the input is a string of valid hexadecimal digits 0-9, A-F, or a-f
Read | Overloaded. Read all the information in a class to the registry. This method iterates through all members of the specified class and reads them to the registry.
ReadFromFile | Read from a file using binary serialization. Normally a call to this method would cast the return value to the correct type as in this example: settings = (Settings)Savior.ReadFromFile(FileName);
Save | Overloaded. Save all the information in a class to the registry. This method iterates through all members of the specified class and saves them to the registry.
SaveToFile | Save settings to a file using binary serialization
ToString | Overloaded. Returns a list of all the fields and field types for the specified class Useful for debugging.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Overloaded. Returns a String that represents the current Object.

See Also

Settings Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Settings.IsHexadecimal Method

This returns true if the input is a string of valid hexadecimal digits 0-9, A-F, or a-f

[Visual Basic]
Public Shared Function IsHexadecimal( _
ByVal input As String _
) As Boolean
[C#]
public static bool IsHexadecimal(
string input
);

Parameters

input
The input string

Return Value

true if the input is a valid hex number

See Also

Settings Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Read Method

NetXP 3.0 Reference

Settings.Read Method

Read from the registry using the default key, the standard user application data registry key. To use this effectively, be sure to specify the appropriate information in the AssemblyInfo file.

Overload List

Read from the registry using the default key, the standard user application data registry key. To use this effectively, be sure to specify the appropriate information in the AssemblyInfo file.

public static void Read(object);

Read all the information in a class to the registry. This method iterates through all members of the specified class and reads them to the registry.

public static void Read(object,RegistryKey);

Read from the registry using the specified key

public static void Read(object,string);

See Also

Settings Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Settings.Read Method (Object)

Read from the registry using the default key, the standard user application data registry key. To use this effectively, be sure to specify the appropriate information in the AssemblyInfo file.

[Visual Basic]
Overloads Public Shared Sub Read( _
ByVal settings As Object _
)
[C#]
public static void Read(
object settings
);

See Also

Settings Class | NETXP.Library Namespace | Settings.Read Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Settings.Read Method (Object, RegistryKey)

Read all the information in a class to the registry. This method iterates through all members of the specified class and reads them to the registry.

[Visual Basic]
Overloads Public Shared Sub Read( _
ByVal settings As Object, _
ByVal Key As RegistryKey _
)
[C#]
public static void Read(
object settings,
RegistryKey Key
);

Parameters

settings
An object that holds all the desired settings
Key
The registry key in which to save data

See Also

Settings Class | NETXP.Library Namespace | Settings.Read Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Settings.Read Method (Object, String)

Read from the registry using the specified key

[Visual Basic]
Overloads Public Shared Sub Read( _
ByVal settings As Object, _
ByVal key As String _
)
[C#]
public static void Read(
object settings,
string key
);

Parameters

settings
Settings to read.
key
A string giving the registry key path relative to HKCU

See Also

Settings Class | NETXP.Library Namespace | Settings.Read Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Settings.ReadFromFile Method

Read from a file using binary serialization. Normally a call to this method would cast the return value to the correct type as in this example: settings = (Settings)Savior.ReadFromFile(FileName);

[Visual Basic]
Public Shared Function ReadFromFile( _
ByVal FileName As String _
) As Object
[C#]
public static object ReadFromFile(
string FileName
);

Parameters

FileName
The name of the file from which to read settings

Return Value

An object is returned containing the settings

See Also

Settings Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Save Method

NetXP 3.0 Reference

Settings.Save Method

Save to the registry using the default key, the standard user application data registry key. To use this effectively, be sure to specify the appropriate information in the AssemblyInfo file.

Overload List

Save to the registry using the default key, the standard user application data registry key. To use this effectively, be sure to specify the appropriate information in the AssemblyInfo file.

public static void Save(object);

Save all the information in a class to the registry. This method iterates through all members of the specified class and saves them to the registry.

public static void Save(object,RegistryKey);

Save to the registry using the specified key

public static void Save(object,string);

See Also

Settings Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Settings.Save Method (Object)

Save to the registry using the default key, the standard user application data registry key. To use this effectively, be sure to specify the appropriate information in the AssemblyInfo file.

[Visual Basic]
Overloads Public Shared Sub Save( _
ByVal settings As Object _
)
[C#]
public static void Save(
object settings
);

Parameters

settings
Settings to save.

See Also

Settings Class | NETXP.Library Namespace | Settings.Save Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Settings.Save Method (Object, RegistryKey)

Save all the information in a class to the registry. This method iterates through all members of the specified class and saves them to the registry.

[Visual Basic]
Overloads Public Shared Sub Save( _
ByVal settings As Object, _
ByVal Key As RegistryKey _
)
[C#]
public static void Save(
object settings,
RegistryKey Key
);

Parameters

settings
An object that holds all the desired settings
Key
The registry key in which to save data

See Also

Settings Class | NETXP.Library Namespace | Settings.Save Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Settings.Save Method (Object, String)

Save to the registry using the specified key

[Visual Basic]
Overloads Public Shared Sub Save( _
ByVal settings As Object, _
ByVal key As String _
)
[C#]
public static void Save(
object settings,
string key
);

Parameters

settings
Settings to save.
key
A string giving the registry key path relative to HKCU

See Also

Settings Class | NETXP.Library Namespace | Settings.Save Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Settings.SaveToFile Method

Save settings to a file using binary serialization

[Visual Basic]
Public Shared Function SaveToFile( _
ByVal settings As Object, _
ByVal FileName As String _
) As Boolean
[C#]
public static bool SaveToFile(
object settings,
string FileName
);

Parameters

settings
This is the object that we want to serialize
FileName
The name of the file in which to store settings

See Also

Settings Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ToString Method

NetXP 3.0 Reference

Settings.ToString Method

Returns a list of all the fields and field types for the specified class Useful for debugging.

Overload List

Inherited from Object.

public virtual string ToString();

Returns a list of all the fields and field types for the specified class Useful for debugging.

public static string ToString(object);

See Also

Settings Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Settings.ToString Method (Object)

Returns a list of all the fields and field types for the specified class Useful for debugging.

[Visual Basic]
Overloads Public Shared Function ToString( _
ByVal settings As Object _
) As String
[C#]
public static string ToString(
object settings
);

See Also

Settings Class | NETXP.Library Namespace | Settings.ToString Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ShadowType Enumeration

Specifies the shadow window type.

[Visual Basic]
Public Enum ShadowType
[C#]
public enum ShadowType

Members

Member Name | Description
Bottom | Represents a horizontal shadow.
Right | Represents a vertical shadow.

Requirements

Namespace: NETXP.Library

Assembly: NETXP.Library (in NETXP.Library.dll)

See Also

NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ShadowWindow Class

A special type of window that can be used to show a shadow for another window.

For a list of all members of this type, see ShadowWindow Members.

System.Object
MarshalByRefObject
NativeWindow
ShadowWindow

[Visual Basic]
Public Class ShadowWindow
Inherits NativeWindow
[C#]
public class ShadowWindow : NativeWindow

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Library

Assembly: NETXP.Library (in NETXP.Library.dll)

See Also

ShadowWindow Members | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ShadowWindow Members

ShadowWindow overview

Public Instance Constructors

ShadowWindow Constructor Creates a new shadow window from the given handle.

Public Instance Properties

Handle (inherited from NativeWindow) | Gets the handle for this window.
HwndShadow | The actual handle to the shadow window.
ShadowSize | The size of the shadow.
ShadowType | The shadow type.

Public Instance Methods

AssignHandle (inherited from NativeWindow) | Assigns a handle to this window.
Close | Closes the shadow window, destroying the handle.
CreateHandle (inherited from NativeWindow) | Creates a window and its handle with the specified creation parameters.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DefWndProc (inherited from NativeWindow) | Invokes the default window procedure associated with this window. It is an error to call this method when the Handle property is 0.
DestroyHandle (inherited from NativeWindow) | Destroys the window and its handle.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
ReleaseHandle (inherited from NativeWindow) | Releases the handle associated with this window.
RenderShadow | Renders the shadow. Can also be called to force a redraw.
Show | Shows the shadow window.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

PaintShadow Raised when the shadow must be redrawn. You MUST handle this event.

See Also

ShadowWindow Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ShadowWindow Constructor

Creates a new shadow window from the given handle.

[Visual Basic]
Public Sub New( _
ByVal handle As IntPtr _
)
[C#]
public ShadowWindow(
IntPtr handle
);

Parameters

handle
The handle to which to attach.

See Also

ShadowWindow Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ShadowWindow Properties

The properties of the ShadowWindow class are listed below. For a complete list of ShadowWindow class members, see the ShadowWindow Members topic.

Public Instance Properties

Handle (inherited from NativeWindow) | Gets the handle for this window.
HwndShadow | The actual handle to the shadow window.
ShadowSize | The size of the shadow.
ShadowType | The shadow type.

See Also

ShadowWindow Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ShadowWindow.HwndShadow Property

The actual handle to the shadow window.

[Visual Basic]
Public Property HwndShadow As IntPtr
[C#]
public System.IntPtr HwndShadow {get; set;}

See Also

ShadowWindow Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ShadowWindow.ShadowSize Property

The size of the shadow.

[Visual Basic]
Public Property ShadowSize As Integer
[C#]
public int ShadowSize {get; set;}

See Also

ShadowWindow Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ShadowWindow.ShadowType Property

The shadow type.

[Visual Basic]
Public Property ShadowType As ShadowType
[C#]
public ShadowType ShadowType {get; set;}

See Also

ShadowWindow Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ShadowWindow Methods

The methods of the ShadowWindow class are listed below. For a complete list of ShadowWindow class members, see the ShadowWindow Members topic.

Public Instance Methods

AssignHandle (inherited from NativeWindow) | Assigns a handle to this window.
Close | Closes the shadow window, destroying the handle.
CreateHandle (inherited from NativeWindow) | Creates a window and its handle with the specified creation parameters.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DefWndProc (inherited from NativeWindow) | Invokes the default window procedure associated with this window. It is an error to call this method when the Handle property is 0.
DestroyHandle (inherited from NativeWindow) | Destroys the window and its handle.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
ReleaseHandle (inherited from NativeWindow) | Releases the handle associated with this window.
RenderShadow | Renders the shadow. Can also be called to force a redraw.
Show | Shows the shadow window.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ShadowWindow Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ShadowWindow.Close Method

Closes the shadow window, destroying the handle.

[Visual Basic]
Public Sub Close()
[C#]
public void Close();

See Also

ShadowWindow Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ShadowWindow.RenderShadow Method

Renders the shadow. Can also be called to force a redraw.

[Visual Basic]
Public Sub RenderShadow( _
ByVal rc As Rectangle, _
ByVal change As Boolean _
)
[C#]
public void RenderShadow(
Rectangle rc,
bool change
);

Parameters

rc
The shadow rectangle.
change
Has the shadow actually changed?

See Also

ShadowWindow Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ShadowWindow.Show Method

Shows the shadow window.

[Visual Basic]
Public Sub Show()
[C#]
public void Show();

See Also

ShadowWindow Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ShadowWindow Events

The events of the ShadowWindow class are listed below. For a complete list of ShadowWindow class members, see the ShadowWindow Members topic.

Public Instance Events

PaintShadow Raised when the shadow must be redrawn. You MUST handle this event.

See Also

ShadowWindow Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


ShadowWindow.PaintShadow Event

Raised when the shadow must be redrawn. You MUST handle this event.

[Visual Basic]
Public Event PaintShadow As PaintEventHandler
[C#]
public event PaintEventHandler PaintShadow;

See Also

ShadowWindow Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


StringCollection Class

Implements a string collection with events.

For a list of all members of this type, see StringCollection Members.

System.Object
CollectionBase
CollectionEx
StringCollection

[Visual Basic]
Public Class StringCollection
Inherits CollectionEx
[C#]
public class StringCollection : CollectionEx

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Library

Assembly: NETXP.Library (in NETXP.Library.dll)

See Also

StringCollection Members | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


StringCollection Members

StringCollection overview

Public Instance Constructors

StringCollection Constructor Initializes a new instance of the StringCollection class.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
IsSuspended (inherited from CollectionEx) | Is event generation already suspended?
Item | Internal.

Public Instance Methods

Add | Internal.
AddRange | Internal.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Contains | Overloaded. Internal.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Internal.
Insert | Internal.
LoadFromXml | Internal.
RaiseChanged (inherited from CollectionEx) | Raises the Changed event.
Remove | Internal.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
ResumeEvents (inherited from CollectionEx) | Resume event generation.
SaveToXml | Internal.
SuspendEvents (inherited from CollectionEx) | Suspend event generation.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

Changed (inherited from CollectionEx) | Event raised when the collection has changed.
Cleared (inherited from CollectionEx) | Event raised when collection has been cleared.
Clearing (inherited from CollectionEx) | Event raised when collection is being cleared.
Inserted (inherited from CollectionEx) | Event raised when an item has been inserted.
Inserting (inherited from CollectionEx) | Event raised when an item is being inserted.
Removed (inherited from CollectionEx) | Event raised when an item has been removed.
Removing (inherited from CollectionEx) | Event raised when an item is being removed.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

StringCollection Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


StringCollection Constructor

Initializes a new instance of the StringCollection class.

[Visual Basic]
Public Sub New()
[C#]
public StringCollection();

See Also

StringCollection Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


StringCollection Properties

The properties of the StringCollection class are listed below. For a complete list of StringCollection class members, see the StringCollection Members topic.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
IsSuspended (inherited from CollectionEx) | Is event generation already suspended?
Item | Internal.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

StringCollection Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


StringCollection.Item Property

Internal.

[Visual Basic]
Public Default ReadOnly Property Item( _
ByVal index As Integer _
) As String
[C#]
public string this[
int index
] {get;}

See Also

StringCollection Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


StringCollection Methods

The methods of the StringCollection class are listed below. For a complete list of StringCollection class members, see the StringCollection Members topic.

Public Instance Methods

Add | Internal.
AddRange | Internal.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Contains | Overloaded. Internal.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Internal.
Insert | Internal.
LoadFromXml | Internal.
RaiseChanged (inherited from CollectionEx) | Raises the Changed event.
Remove | Internal.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
ResumeEvents (inherited from CollectionEx) | Resume event generation.
SaveToXml | Internal.
SuspendEvents (inherited from CollectionEx) | Suspend event generation.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

StringCollection Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


StringCollection.Add Method

Internal.

[Visual Basic]
Public Function Add( _
ByVal value As String _
) As Integer
[C#]
public int Add(
string value
);

Parameters

value

Return Value

See Also

StringCollection Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


StringCollection.AddRange Method

Internal.

[Visual Basic]
Public Sub AddRange( _
ByVal values As String() _
)
[C#]
public void AddRange(
string[] values
);

Parameters

values

See Also

StringCollection Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Contains Method

NetXP 3.0 Reference

StringCollection.Contains Method

Internal.

Overload List

Internal.

public bool Contains(StringCollection);

Internal.

public bool Contains(string);

See Also

StringCollection Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


StringCollection.Contains Method (StringCollection)

Internal.

[Visual Basic]
Overloads Public Function Contains( _
ByVal values As StringCollection _
) As Boolean
[C#]
public bool Contains(
StringCollection values
);

Parameters

values

Return Value

See Also

StringCollection Class | NETXP.Library Namespace | StringCollection.Contains Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


StringCollection.Contains Method (String)

Internal.

[Visual Basic]
Overloads Public Function Contains( _
ByVal value As String _
) As Boolean
[C#]
public bool Contains(
string value
);

Parameters

value

Return Value

See Also

StringCollection Class | NETXP.Library Namespace | StringCollection.Contains Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


StringCollection.IndexOf Method

Internal.

[Visual Basic]
Public Function IndexOf( _
ByVal value As String _
) As Integer
[C#]
public int IndexOf(
string value
);

Parameters

value

Return Value

See Also

StringCollection Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


StringCollection.Insert Method

Internal.

[Visual Basic]
Public Sub Insert( _
ByVal index As Integer, _
ByVal value As String _
)
[C#]
public void Insert(
int index,
string value
);

Parameters

index
value

See Also

StringCollection Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


StringCollection.LoadFromXml Method

Internal.

[Visual Basic]
Public Sub LoadFromXml( _
ByVal name As String, _
ByVal xmlIn As XmlTextReader _
)
[C#]
public void LoadFromXml(
string name,
XmlTextReader xmlIn
);

Parameters

name
xmlIn

See Also

StringCollection Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


StringCollection.Remove Method

Internal.

[Visual Basic]
Public Sub Remove( _
ByVal value As String _
)
[C#]
public void Remove(
string value
);

Parameters

value

See Also

StringCollection Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


StringCollection.SaveToXml Method

Internal.

[Visual Basic]
Public Sub SaveToXml( _
ByVal name As String, _
ByVal xmlOut As XmlTextWriter _
)
[C#]
public void SaveToXml(
string name,
XmlTextWriter xmlOut
);

Parameters

name
xmlOut

See Also

StringCollection Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


TableColor Enumeration

Provides a collection of colors defined in each color table.

[Visual Basic]
Public Enum TableColor
[C#]
public enum TableColor

Members

Member Name | Description
TaskPaneStart | The first gradient color for the task pane background.
TaskPaneEnd | The last gradient color for the task pane background.
SystemTaskHeaderStart | The first gradient color for the special task pane group header background.
SystemTaskHeaderEnd | The last gradient color for the special task pane group header background.
SystemTaskHeaderTextNormal | The color for the special task pane group header text (normal state).
SystemTaskHeaderTextHover | The color for the special task pane group header text (hover state).
SystemTaskBoxFill | The background fill color for the special task pane group's body.
SystemTaskBoxBorder | The color of the border of special task pane groups.
SystemTaskButtonColor | A general-purpose color used for the chevron button of a special task pane group.
NormalTaskHeaderStart | The first gradient color for the normal task pane group header background.
NormalTaskHeaderEnd | The last gradient color for the normal task pane group header background.
NormalTaskHeaderTextNormal | The color for the normal task pane group header text (normal state).
NormalTaskHeaderTextHover | The color for the normal task pane group header text (hover state).
NormalTaskBoxFill | The background fill color for the normal task pane group's body.
NormalTaskBoxBorder | The color of the border of normal task pane groups.
NormalTaskButtonColor | A general-purpose color used for the chevron button of a normal task pane group.
LinkColorNormal | The color used for task pane links (normal state).
LinkColorHover | The color used for task pane links (hover state).
RebarGradientStart | The background color on the left side of a command bar dock.
RebarGradientEnd | The background color on the right side of a command bar dock.
ToolbarGradientStart | The toolbar gradient background color (top).
ToolbarGradientEnd | The toolbar gradient background color (bottom).
ToolbarBottom | The color of the bottom line of a toolbar.
GripperDark | The dark color of 3D grippers.
GripperLight | The light color of 3D grippers.
ToolbarButtonBorder | The color of a toolbar button's border.
ToolbarButtonToggledGradientStart | The background gradient for a checked toolbar button (top color).
ToolbarButtonToggledGradientEnd | The background gradient for a checked toolbar button (bottom color).
ToolbarButtonPressedGradientStart | The background gradient for a pressed toolbar button (top color).
ToolbarButtonPressedGradientEnd | The background gradient for a pressed toolbar button (bottom color).
ToolbarButtonHoverGradientStart | The background gradient for a hot toolbar button (top color).
ToolbarButtonHoverGradientEnd | The background gradient for a hot toolbar button (bottom color).
PopupMenuBackground | The background color of a context menu window.
PopupMenuBorder | The border color of a context menu window.
MenuBarItemGradientStart | The background gradient for a dropped-down toolbar button or top-level menu item (top color).
MenuBarItemGradientEnd | The background gradient for a dropped-down toolbar button or top-level menu item (bottom color).
PopupMenuItemUncommonGradientStart | The gradient background color shown to the left of an infrequent popup menu item (left).
PopupMenuItemUncommonGradientEnd | The gradient background color shown to the left of an infrequent popup menu item (right).
PopupMenuItemCommonGradientStart | The gradient background color shown to the left of a normal popup menu item (left).
PopupMenuItemCommonGradientEnd | The gradient background color shown to the left of a normal popup menu item (right).
PopupMenuItemSelected | The background color of a selected popup menu item.
PopupMenuItemChecked | The background color of a checked popup menu item.
PopupMenuItemCheckedHover | The background color of a selected checked popup menu item.
Separator | General color for separators.

Requirements

Namespace: NETXP.Library

Assembly: NETXP.Library (in NETXP.Library.dll)

See Also

NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Utility Class

Utility functions.

For a list of all members of this type, see Utility Members.

System.Object
Utility

[Visual Basic]
NotInheritable Public Class Utility
[C#]
public sealed class Utility

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Library

Assembly: NETXP.Library (in NETXP.Library.dll)

See Also

Utility Members | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Utility Members

Utility overview

Public Static (Shared) Properties

CommonControlsVersion Gets the version of COMCTL32.DLL.

Public Static (Shared) Methods

AddPNGToImageList | Adds a transparent image to an image list, with alpha channel transparency.
BrowseForFolder | Opens a Browse-For-Folder dialog.
Deserialize | Deserializes a generic XML-serializable object from an XML file.
DeserializeIsolated | Deserializes a generic XML-serializable object from an XML file in isolated storage.
FixPropertyGridsAndTreeViews | Fixes property grids to persist the visible properties, and makes tree views' scrollbars skinable.
IsNull | Overloaded. Verifies if a string is null or empty.
Serialize | Serializes a generic XML-serializable object to an XML file.
SerializeIsolated | Serializes a generic XML-serializable object to an XML file in isolated storage.
SetXPPasswordChar | Sets the XP-style password character for text boxes, used instead of the standard asterisk character on Windows XP.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Utility Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Utility Properties

The properties of the Utility class are listed below. For a complete list of Utility class members, see the Utility Members topic.

Public Static (Shared) Properties

CommonControlsVersion Gets the version of COMCTL32.DLL.

See Also

Utility Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Utility.CommonControlsVersion Property

Gets the version of COMCTL32.DLL.

[Visual Basic]
Public Shared ReadOnly Property CommonControlsVersion As Version
[C#]
public static System.Version CommonControlsVersion {get;}

See Also

Utility Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Utility Methods

The methods of the Utility class are listed below. For a complete list of Utility class members, see the Utility Members topic.

Public Static (Shared) Methods

AddPNGToImageList | Adds a transparent image to an image list, with alpha channel transparency.
BrowseForFolder | Opens a Browse-For-Folder dialog.
Deserialize | Deserializes a generic XML-serializable object from an XML file.
DeserializeIsolated | Deserializes a generic XML-serializable object from an XML file in isolated storage.
FixPropertyGridsAndTreeViews | Fixes property grids to persist the visible properties, and makes tree views' scrollbars skinable.
IsNull | Overloaded. Verifies if a string is null or empty.
Serialize | Serializes a generic XML-serializable object to an XML file.
SerializeIsolated | Serializes a generic XML-serializable object to an XML file in isolated storage.
SetXPPasswordChar | Sets the XP-style password character for text boxes, used instead of the standard asterisk character on Windows XP.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Utility Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Utility.AddPNGToImageList Method

Adds a transparent image to an image list, with alpha channel transparency.

[Visual Basic]
Public Shared Sub AddPNGToImageList( _
ByVal il As ImageList, _
ByVal bmp As Bitmap _
)
[C#]
public static void AddPNGToImageList(
ImageList il,
Bitmap bmp
);

Parameters

il
bmp

See Also

Utility Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Utility.BrowseForFolder Method

Opens a Browse-For-Folder dialog.

[Visual Basic]
Public Shared Function BrowseForFolder( _
ByVal owner As IWin32Window, _
ByRef folder As String, _
ByVal title As String, _
ByVal flags As BrowseFlags _
) As Boolean
[C#]
public static bool BrowseForFolder(
IWin32Window owner,
out string folder,
string title,
BrowseFlags flags
);

Parameters

owner
The owner of the dialog.
folder
The folder selected.
title
The title of the dialog.
flags
BrowseFlags.

Return Value

True if OK, False if Cancel.

See Also

Utility Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Utility.Deserialize Method

Deserializes a generic XML-serializable object from an XML file.

[Visual Basic]
Public Shared Function Deserialize( _
ByVal file As String, _
ByVal type As Type _
) As Object
[C#]
public static object Deserialize(
string file,
Type type
);

Parameters

file
XML File
type
Type of object

Return Value

The new deserialized object

See Also

Utility Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Utility.DeserializeIsolated Method

Deserializes a generic XML-serializable object from an XML file in isolated storage.

[Visual Basic]
Public Shared Function DeserializeIsolated( _
ByVal file As String, _
ByVal type As Type _
) As Object
[C#]
public static object DeserializeIsolated(
string file,
Type type
);

Parameters

file
XML File
type
Type of object

Return Value

The new deserialized object

See Also

Utility Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Utility.FixPropertyGridsAndTreeViews Method

Fixes property grids to persist the visible properties, and makes tree views' scrollbars skinable.

[Visual Basic]
Public Shared Sub FixPropertyGridsAndTreeViews( _
ByVal baseCtl As Control _
)
[C#]
public static void FixPropertyGridsAndTreeViews(
Control baseCtl
);

Parameters

baseCtl
The control or form containing the controls to be fixed.

See Also

Utility Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


IsNull Method

NetXP 3.0 Reference

Utility.IsNull Method

Verifies if a collection is null or empty.

Overload List

Verifies if a collection is null or empty.

public static bool IsNull(ICollection);

Verifies if a string is null or empty.

public static bool IsNull(string);

See Also

Utility Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Utility.IsNull Method (ICollection)

Verifies if a collection is null or empty.

[Visual Basic]
Overloads Public Shared Function IsNull( _
ByVal col As ICollection _
) As Boolean
[C#]
public static bool IsNull(
ICollection col
);

Parameters

col
Collection

Return Value

True if null, False if not.

See Also

Utility Class | NETXP.Library Namespace | Utility.IsNull Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Utility.IsNull Method (String)

Verifies if a string is null or empty.

[Visual Basic]
Overloads Public Shared Function IsNull( _
ByVal s As String _
) As Boolean
[C#]
public static bool IsNull(
string s
);

Parameters

s
String

Return Value

True if null, False if not.

See Also

Utility Class | NETXP.Library Namespace | Utility.IsNull Overload List

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Utility.Serialize Method

Serializes a generic XML-serializable object to an XML file.

[Visual Basic]
Public Shared Sub Serialize( _
ByVal o As Object, _
ByVal file As String, _
ByVal append As Boolean _
)
[C#]
public static void Serialize(
object o,
string file,
bool append
);

Parameters

o
Object
file
XML File
append
Should append to XML file?

See Also

Utility Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Utility.SerializeIsolated Method

Serializes a generic XML-serializable object to an XML file in isolated storage.

[Visual Basic]
Public Shared Sub SerializeIsolated( _
ByVal o As Object, _
ByVal file As String, _
ByVal append As Boolean _
)
[C#]
public static void SerializeIsolated(
object o,
string file,
bool append
);

Parameters

o
Object
file
XML File
append
Should append to XML file?

See Also

Utility Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


Utility.SetXPPasswordChar Method

Sets the XP-style password character for text boxes, used instead of the standard asterisk character on Windows XP.

[Visual Basic]
Public Shared Sub SetXPPasswordChar( _
ByVal textBox As TextBox _
)
[C#]
public static void SetXPPasswordChar(
TextBox textBox
);

Parameters

textBox
Textbox for which to set the XP-style password char.

See Also

Utility Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


UXTheme Class

Provides some utility functions from the UXTheme API.

For a list of all members of this type, see UXTheme Members.

System.Object
UXTheme

[Visual Basic]
Public Class UXTheme
[C#]
public class UXTheme

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Library

Assembly: NETXP.Library (in NETXP.Library.dll)

See Also

UXTheme Members | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


UXTheme Members

UXTheme overview

Public Static (Shared) Properties

IsFlatMenu | Are flat menus enabled on the system?
IsThemed | Determines if visual styles are enabled on this system.
LayeredSupport | Does the operating system support layered windows?
MenuShadows | Are menu drop shadows enabled and supported?

Public Static (Shared) Methods

DrawBackground | Draws the themed background for a themed part.
DrawThemeParentBackground | Draws the themed parent background for a window.
GetTextColor | Gets the text color for a specified themed part.
IsAppThemed | Is the current application themed?

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

UXTheme Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


UXTheme Properties

The properties of the UXTheme class are listed below. For a complete list of UXTheme class members, see the UXTheme Members topic.

Public Static (Shared) Properties

IsFlatMenu | Are flat menus enabled on the system?
IsThemed | Determines if visual styles are enabled on this system.
LayeredSupport | Does the operating system support layered windows?
MenuShadows | Are menu drop shadows enabled and supported?

See Also

UXTheme Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


UXTheme.IsFlatMenu Property

Are flat menus enabled on the system?

[Visual Basic]
Public Shared ReadOnly Property IsFlatMenu As Boolean
[C#]
public static bool IsFlatMenu {get;}

See Also

UXTheme Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


UXTheme.IsThemed Property

Determines if visual styles are enabled on this system.

[Visual Basic]
Public Shared ReadOnly Property IsThemed As Boolean
[C#]
public static bool IsThemed {get;}

See Also

UXTheme Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


UXTheme.LayeredSupport Property

Does the operating system support layered windows?

[Visual Basic]
Public Shared ReadOnly Property LayeredSupport As Boolean
[C#]
public static bool LayeredSupport {get;}

See Also

UXTheme Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


UXTheme.MenuShadows Property

Are menu drop shadows enabled and supported?

[Visual Basic]
Public Shared ReadOnly Property MenuShadows As Boolean
[C#]
public static bool MenuShadows {get;}

See Also

UXTheme Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


UXTheme Methods

The methods of the UXTheme class are listed below. For a complete list of UXTheme class members, see the UXTheme Members topic.

Public Static (Shared) Methods

DrawBackground | Draws the themed background for a themed part.
DrawThemeParentBackground | Draws the themed parent background for a window.
GetTextColor | Gets the text color for a specified themed part.
IsAppThemed | Is the current application themed?

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

UXTheme Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


UXTheme.DrawBackground Method

Draws the themed background for a themed part.

[Visual Basic]
Public Shared Function DrawBackground( _
ByVal name As String, _
ByVal part As Integer, _
ByVal state As Integer, _
ByVal hdc As IntPtr, _
ByVal ox As Integer, _
ByVal oy As Integer, _
ByVal dx As Integer, _
ByVal dy As Integer, _
ByVal clip_ox As Integer, _
ByVal clip_oy As Integer, _
ByVal clip_dx As Integer, _
ByVal clip_dy As Integer _
) As Boolean
[C#]
public static bool DrawBackground(
string name,
int part,
int state,
IntPtr hdc,
int ox,
int oy,
int dx,
int dy,
int clip_ox,
int clip_oy,
int clip_dx,
int clip_dy
);

Parameters

name
The name of the class to open.
part
The part.
state
The state ID of the part.
hdc
The device context.
ox
The destination location (x).
oy
The destination location (y).
dx
The destination size (x).
dy
The destination size (y).
clip_ox
The clip rectangle location (x).
clip_oy
The clip rectangle location (y).
clip_dx
The clip rectangle size (x).
clip_dy
The clip rectangle size (y).

Return Value

True if successful. False if failed.

See Also

UXTheme Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


UXTheme.DrawThemeParentBackground Method

Draws the themed parent background for a window.

[Visual Basic]
Public Shared Function DrawThemeParentBackground( _
ByVal hwnd As IntPtr, _
ByVal hdc As IntPtr, _
ByVal ox As Integer, _
ByVal oy As Integer, _
ByVal dx As Integer, _
ByVal dy As Integer _
) As Boolean
[C#]
public static bool DrawThemeParentBackground(
IntPtr hwnd,
IntPtr hdc,
int ox,
int oy,
int dx,
int dy
);

Parameters

hwnd
Window.
hdc
Device Context.
ox
The destination location (x).
oy
The destination location (y).
dx
The destination size (x).
dy
The destination size (y).

Return Value

True if successful. False if failed.

See Also

UXTheme Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


UXTheme.GetTextColor Method

Gets the text color for a specified themed part.

[Visual Basic]
Public Shared Function GetTextColor( _
ByVal name As String, _
ByVal part As Integer, _
ByVal state As Integer, _
ByRef r As Integer, _
ByRef g As Integer, _
ByRef b As Integer _
) As Boolean
[C#]
public static bool GetTextColor(
string name,
int part,
int state,
ref int r,
ref int g,
ref int b
);

Parameters

name
The name of the class to open.
part
The part.
state
The state ID of the part.
r
The red component.
g
The green component.
b
The blue component.

Return Value

True if successful. False if failed.

See Also

UXTheme Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


UXTheme.IsAppThemed Method

Is the current application themed?

[Visual Basic]
Public Shared Function IsAppThemed() As Boolean
[C#]
public static bool IsAppThemed();

Return Value

True if the current application is themed.

See Also

UXTheme Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


WNet Class

Contains utility functions for enumerating network nodes.

For a list of all members of this type, see WNet Members.

System.Object
WNet

[Visual Basic]
Public Class WNet
[C#]
public class WNet

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Library

Assembly: NETXP.Library (in NETXP.Library.dll)

See Also

WNet Members | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


WNet Members

WNet overview

Public Static (Shared) Methods

EnumerateNetwork Enumerates all the nodes in a network.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

WNet Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


WNet Methods

The methods of the WNet class are listed below. For a complete list of WNet class members, see the WNet Members topic.

Public Static (Shared) Methods

EnumerateNetwork Enumerates all the nodes in a network.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

WNet Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


WNet.EnumerateNetwork Method

Enumerates all the nodes in a network.

[Visual Basic]
Public Shared Function EnumerateNetwork() As WNetNodeCollection
[C#]
public static WNetNodeCollection EnumerateNetwork();

Return Value

A nested collection of network nodes.

See Also

WNet Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


WNetNode Class

Describes a network node.

For a list of all members of this type, see WNetNode Members.

System.Object
WNetNode

[Visual Basic]
Public Class WNetNode
[C#]
public class WNetNode

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Library

Assembly: NETXP.Library (in NETXP.Library.dll)

See Also

WNetNode Members | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


WNetNode Members

WNetNode overview

Public Instance Constructors

WNetNode Constructor Initializes a new instance of the WNetNode class.

Public Instance Fields

Comment | A user-defined comment for the node.
Level | The level of the node in the hierarchy.
LocalName | The name of the node as it is visible locally.
Nodes | A collection of subnodes.
Provider | The provider for the node.
RemoteName | The name of the node as it is visible remotely.
Type | The type of node.
Usage | Any special uses or flags for the node.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

WNetNode Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


WNetNode Constructor

Initializes a new instance of the WNetNode class.

[Visual Basic]
Public Sub New()
[C#]
public WNetNode();

See Also

WNetNode Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


WNetNode Fields

The fields of the WNetNode class are listed below. For a complete list of WNetNode class members, see the WNetNode Members topic.

Public Instance Fields

Comment | A user-defined comment for the node.
Level | The level of the node in the hierarchy.
LocalName | The name of the node as it is visible locally.
Nodes | A collection of subnodes.
Provider | The provider for the node.
RemoteName | The name of the node as it is visible remotely.
Type | The type of node.
Usage | Any special uses or flags for the node.

See Also

WNetNode Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


WNetNode.Comment Field

A user-defined comment for the node.

[Visual Basic]
Public Comment As String
[C#]
public string Comment;

See Also

WNetNode Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


WNetNode.Level Field

The level of the node in the hierarchy.

[Visual Basic]
Public Level As WNetNodeLevel
[C#]
public WNetNodeLevel Level;

See Also

WNetNode Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


WNetNode.LocalName Field

The name of the node as it is visible locally.

[Visual Basic]
Public LocalName As String
[C#]
public string LocalName;

See Also

WNetNode Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


WNetNode.Nodes Field

A collection of subnodes.

[Visual Basic]
Public Nodes As WNetNodeCollection
[C#]
public WNetNodeCollection Nodes;

See Also

WNetNode Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


WNetNode.Provider Field

The provider for the node.

[Visual Basic]
Public Provider As String
[C#]
public string Provider;

See Also

WNetNode Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


WNetNode.RemoteName Field

The name of the node as it is visible remotely.

[Visual Basic]
Public RemoteName As String
[C#]
public string RemoteName;

See Also

WNetNode Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


WNetNode.Type Field

The type of node.

[Visual Basic]
Public Type As WNetNodeType
[C#]
public WNetNodeType Type;

See Also

WNetNode Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


WNetNode.Usage Field

Any special uses or flags for the node.

[Visual Basic]
Public Usage As WNetUsage
[C#]
public WNetUsage Usage;

See Also

WNetNode Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


WNetNodeCollection Class

A collection of WNetNode objects.

For a list of all members of this type, see WNetNodeCollection Members.

System.Object
CollectionBase
WNetNodeCollection

[Visual Basic]
Public Class WNetNodeCollection
Inherits CollectionBase
[C#]
public class WNetNodeCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Library

Assembly: NETXP.Library (in NETXP.Library.dll)

See Also

WNetNodeCollection Members | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


WNetNodeCollection Members

WNetNodeCollection overview

Public Instance Constructors

WNetNodeCollection Constructor Creates a new collection.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Item | Retrieves an item at an index.

Public Instance Methods

Add | Adds an item to the collection.
AddRange | Adds a set of items to the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Contains | Checks if the collection contains a certain item.
CopyTo | Copies this collection's items into an array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Gets the index of an item.
Insert | Inserts an item at a specified index.
RaiseChanged | Raises a Changed event.
Remove | Removes an item.
RemoveAt | Removes an item at a specified index.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

Changed Called when the collection has changed.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

WNetNodeCollection Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


WNetNodeCollection Constructor

Creates a new collection.

[Visual Basic]
Public Sub New()
[C#]
public WNetNodeCollection();

See Also

WNetNodeCollection Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


WNetNodeCollection Properties

The properties of the WNetNodeCollection class are listed below. For a complete list of WNetNodeCollection class members, see the WNetNodeCollection Members topic.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Item | Retrieves an item at an index.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

WNetNodeCollection Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


WNetNodeCollection.Item Property

Retrieves an item at an index.

[Visual Basic]
Public Default Property Item( _
ByVal index As Integer _
) As WNetNode
[C#]
public WNetNode this[
int index
] {get; set;}

See Also

WNetNodeCollection Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


WNetNodeCollection Methods

The methods of the WNetNodeCollection class are listed below. For a complete list of WNetNodeCollection class members, see the WNetNodeCollection Members topic.

Public Instance Methods

Add | Adds an item to the collection.
AddRange | Adds a set of items to the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Contains | Checks if the collection contains a certain item.
CopyTo | Copies this collection's items into an array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Gets the index of an item.
Insert | Inserts an item at a specified index.
RaiseChanged | Raises a Changed event.
Remove | Removes an item.
RemoveAt | Removes an item at a specified index.
ToString (inherited from Object) | Returns a String that represents the current Object.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

WNetNodeCollection Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


WNetNodeCollection.Add Method

Adds an item to the collection.

[Visual Basic]
Public Function Add( _
ByVal item As WNetNode _
) As Integer
[C#]
public int Add(
WNetNode item
);

Parameters

item
The item to add.

Return Value

The index where the item was added.

See Also

WNetNodeCollection Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


WNetNodeCollection.AddRange Method

Adds a set of items to the collection.

[Visual Basic]
Public Sub AddRange( _
ByVal items As WNetNode() _
)
[C#]
public void AddRange(
WNetNode[] items
);

Parameters

items
The array of items to add.

See Also

WNetNodeCollection Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


WNetNodeCollection.Contains Method

Checks if the collection contains a certain item.

[Visual Basic]
Public Function Contains( _
ByVal item As WNetNode _
) As Boolean
[C#]
public bool Contains(
WNetNode item
);

Parameters

item
The item

Return Value

True if the collection contains this item.

See Also

WNetNodeCollection Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


WNetNodeCollection.CopyTo Method

Copies this collection's items into an array.

[Visual Basic]
Public Sub CopyTo( _
ByVal array As Array, _
ByVal index As Integer _
)
[C#]
public void CopyTo(
Array array,
int index
);

Parameters

array
The array.
index
The index at which to start copying.

See Also

WNetNodeCollection Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


WNetNodeCollection.IndexOf Method

Gets the index of an item.

[Visual Basic]
Public Function IndexOf( _
ByVal item As WNetNode _
) As Integer
[C#]
public int IndexOf(
WNetNode item
);

Parameters

item
The item.

Return Value

The index of the item.

See Also

WNetNodeCollection Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


WNetNodeCollection.Insert Method

Inserts an item at a specified index.

[Visual Basic]
Public Sub Insert( _
ByVal index As Integer, _
ByVal item As WNetNode _
)
[C#]
public void Insert(
int index,
WNetNode item
);

Parameters

index
The index.
item
The item.

See Also

WNetNodeCollection Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


WNetNodeCollection.RaiseChanged Method

Raises a Changed event.

[Visual Basic]
Public Sub RaiseChanged()
[C#]
public void RaiseChanged();

See Also

WNetNodeCollection Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


WNetNodeCollection.Remove Method

Removes an item.

[Visual Basic]
Public Sub Remove( _
ByVal item As WNetNode _
)
[C#]
public void Remove(
WNetNode item
);

Parameters

item
The item to remove.

See Also

WNetNodeCollection Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


WNetNodeCollection.RemoveAt Method

Removes an item at a specified index.

[Visual Basic]
Public Sub RemoveAt( _
ByVal index As Integer _
) Implements _
IList.RemoveAt
[C#]
new public void RemoveAt(
int index
);

Parameters

index
The index to remove at.

Implements

IList.RemoveAt

See Also

WNetNodeCollection Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


WNetNodeCollection Events

The events of the WNetNodeCollection class are listed below. For a complete list of WNetNodeCollection class members, see the WNetNodeCollection Members topic.

Public Instance Events

Changed Called when the collection has changed.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

WNetNodeCollection Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


WNetNodeCollection.Changed Event

Called when the collection has changed.

[Visual Basic]
Public Event Changed As EventHandler
[C#]
public event EventHandler Changed;

See Also

WNetNodeCollection Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


WNetNodeLevel Enumeration

Identifies the tree depth of a network node.

[Visual Basic]
Public Enum WNetNodeLevel
[C#]
public enum WNetNodeLevel

Members

Member Name | Description
None | No depth information available.
Network | The networks level.
Domain | The domains level.
Server | The servers level.
Share | The shares level.
Directory | The directories level.
File | The files level.

Requirements

Namespace: NETXP.Library

Assembly: NETXP.Library (in NETXP.Library.dll)

See Also

NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


WNetNodeType Enumeration

Identifies the type of network node.

[Visual Basic]
Public Enum WNetNodeType
[C#]
public enum WNetNodeType

Members

Member Name | Description
Generic | Node information is unavailable.
Domain | Domain node.
Server | Server node.
Share | Share node.
File | File node.
Group | Group node.
Network | Network node.
Root | Root node.
AdminShare | Administrative share.
Directory | Directory node.

Requirements

Namespace: NETXP.Library

Assembly: NETXP.Library (in NETXP.Library.dll)

See Also

NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


WNetUsage Enumeration

Identifies the use of the node.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

[Visual Basic]
Public Enum WNetUsage
[C#]
public enum WNetUsage

Members

Member Name | Description | Value
None | No special use. | 0
Connectable | Can connect to node. | 1
Container | Node contains subnodes. | 2

Requirements

Namespace: NETXP.Library

Assembly: NETXP.Library (in NETXP.Library.dll)

See Also

NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


XPBlueColorTable Class

Contains colors for the Luna Blue color scheme.

For a list of all members of this type, see XPBlueColorTable Members.

System.Object
XPBlueColorTable

[Visual Basic]
Public Class XPBlueColorTable
Implements NETXP.Library.IColorTable
[C#]
public class XPBlueColorTable : IColorTable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Library

Assembly: NETXP.Library (in NETXP.Library.dll)

See Also

XPBlueColorTable Members | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


XPBlueColorTable Members

XPBlueColorTable overview

Public Instance Constructors

XPBlueColorTable Constructor Initializes a new instance of the XPBlueColorTable class.

Public Instance Properties

Colors Gets the collection of colors provided by this color table.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

XPBlueColorTable Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


XPBlueColorTable Constructor

Initializes a new instance of the XPBlueColorTable class.

[Visual Basic]
Public Sub New()
[C#]
public XPBlueColorTable();

See Also

XPBlueColorTable Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


XPBlueColorTable Properties

The properties of the XPBlueColorTable class are listed below. For a complete list of XPBlueColorTable class members, see the XPBlueColorTable Members topic.

Public Instance Properties

Colors Gets the collection of colors provided by this color table.

See Also

XPBlueColorTable Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


XPBlueColorTable.Colors Property

Gets the collection of colors provided by this color table.

[Visual Basic]
NotOverridable Public ReadOnly Property Colors As ColorCollection Implements _
IColorTable.Colors
[C#]
public ColorCollection Colors {get;}

Implements

IColorTable.Colors

See Also

XPBlueColorTable Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


XPOliveColorTable Class

Contains colors for the Luna Olive Green color scheme.

For a list of all members of this type, see XPOliveColorTable Members.

System.Object
XPOliveColorTable

[Visual Basic]
Public Class XPOliveColorTable
Implements NETXP.Library.IColorTable
[C#]
public class XPOliveColorTable : IColorTable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Library

Assembly: NETXP.Library (in NETXP.Library.dll)

See Also

XPOliveColorTable Members | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


XPOliveColorTable Members

XPOliveColorTable overview

Public Instance Constructors

XPOliveColorTable Constructor Initializes a new instance of the XPOliveColorTable class.

Public Instance Properties

Colors Gets the collection of colors provided by this color table.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

XPOliveColorTable Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


XPOliveColorTable Constructor

Initializes a new instance of the XPOliveColorTable class.

[Visual Basic]
Public Sub New()
[C#]
public XPOliveColorTable();

See Also

XPOliveColorTable Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


XPOliveColorTable Properties

The properties of the XPOliveColorTable class are listed below. For a complete list of XPOliveColorTable class members, see the XPOliveColorTable Members topic.

Public Instance Properties

Colors Gets the collection of colors provided by this color table.

See Also

XPOliveColorTable Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


XPOliveColorTable.Colors Property

Gets the collection of colors provided by this color table.

[Visual Basic]
NotOverridable Public ReadOnly Property Colors As ColorCollection Implements _
IColorTable.Colors
[C#]
public ColorCollection Colors {get;}

Implements

IColorTable.Colors

See Also

XPOliveColorTable Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


XPSilverColorTable Class

Contains colors for the Luna Silver color scheme.

For a list of all members of this type, see XPSilverColorTable Members.

System.Object
XPSilverColorTable

[Visual Basic]
Public Class XPSilverColorTable
Implements NETXP.Library.IColorTable
[C#]
public class XPSilverColorTable : IColorTable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NETXP.Library

Assembly: NETXP.Library (in NETXP.Library.dll)

See Also

XPSilverColorTable Members | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


XPSilverColorTable Members

XPSilverColorTable overview

Public Instance Constructors

XPSilverColorTable Constructor Initializes a new instance of the XPSilverColorTable class.

Public Instance Properties

Colors Gets the collection of colors provided by this color table.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

XPSilverColorTable Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


XPSilverColorTable Constructor

Initializes a new instance of the XPSilverColorTable class.

[Visual Basic]
Public Sub New()
[C#]
public XPSilverColorTable();

See Also

XPSilverColorTable Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


XPSilverColorTable Properties

The properties of the XPSilverColorTable class are listed below. For a complete list of XPSilverColorTable class members, see the XPSilverColorTable Members topic.

Public Instance Properties

Colors Gets the collection of colors provided by this color table.

See Also

XPSilverColorTable Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


XPSilverColorTable.Colors Property

Gets the collection of colors provided by this color table.

[Visual Basic]
NotOverridable Public ReadOnly Property Colors As ColorCollection Implements _
IColorTable.Colors
[C#]
public ColorCollection Colors {get;}

Implements

IColorTable.Colors

See Also

XPSilverColorTable Class | NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]


XPThemeColor Enumeration

Enumerates the XP color schemes.

[Visual Basic]
Public Enum XPThemeColor
[C#]
public enum XPThemeColor

Members

Member Name | Description
Blue | The Luna Blue color scheme.
Silver | The Luna Silver color scheme.
Olive | The Luna Olive Green color scheme.
Classic | The Windows classic color scheme.

Requirements

Namespace: NETXP.Library

Assembly: NETXP.Library (in NETXP.Library.dll)

See Also

NETXP.Library Namespace

Copyright © 2004 Dacris Software Inc. All Rights Reserved.

Generated from assembly NETXP.Library [3.0.5600.2205]