ICSharpCode.SharpUnit

ICSharpCode.SharpUnit an Unit Testing Framework for .NET

ICSharpCode.SharpUnit Namespace

Namespace hierarchy

Classes

Class | Description
Assertion | A set of JUnit/NUnit compatible assertion methods
AssertionFailedException | Is thrown if an assertion failed.
ExceptExceptionAttribute | Indicates that a test method may throw an exception
TestAssemblyAttribute | Can be used to specify a description for an assembly that contains tests
TestMethodAttribute | Indicates that a method should be run in a test as a test method.
TestSuiteAttribute | Indicates that a class contains test methods.

Enumerations

Enumeration | Description
TestCallingMode | This enumeration is used to specify the calling mode for a test


Assertion Class

A set of JUnit/NUnit compatible assertion methods

For a list of all members of this type, see Assertion Members.

System.Object
MarshalByRefObject
Assertion

public sealed class Assertion : MarshalByRefObject

Requirements

Namespace: ICSharpCode.SharpUnit Namespace

Assembly: ICSharpCode.SharpUnit.dll

See Also

Assertion Members | ICSharpCode.SharpUnit Namespace


Assertion Members

Public Static Methods

Assert | Overloaded. Asserts that a condition is true.
AssertEquals | Overloaded. Asserts that two doubles are equal concerning a delta. If the expected value is infinity then the delta value is ignored.
AssertNotNull | Overloaded. Asserts that an object isn't null.
AssertNull | Overloaded. Asserts that an object is null.
AssertSame | Overloaded. Asserts that two objects refer to the same object.
Fail | Overloaded. Throw an AssertionFailedException.

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Assertion Class | ICSharpCode.SharpUnit Namespace


Assertion Methods

The methods of the Assertion class are listed below. For a complete list of Assertion class members, see the Assertion Members topic.

Public Static Methods

Assert | Overloaded. Asserts that a condition is true.
AssertEquals | Overloaded. Asserts that two doubles are equal concerning a delta. If the expected value is infinity then the delta value is ignored.
AssertNotNull | Overloaded. Asserts that an object isn't null.
AssertNull | Overloaded. Asserts that an object is null.
AssertSame | Overloaded. Asserts that two objects refer to the same object.
Fail | Overloaded. Throw an AssertionFailedException.

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Assertion Class | ICSharpCode.SharpUnit Namespace


Assert Method

ICSharpCode.SharpUnit an Unit Testing Framework for .NET

Assertion.Assert Method

Asserts that a condition is true.

Overload List

Asserts that a condition is true.

public static void Assert(string,bool);

Asserts that a condition is true.

public static void Assert(bool);

See Also

Assertion Class | Assertion Members | ICSharpCode.SharpUnit Namespace


Assertion.Assert Method (Boolean)

Asserts that a condition is true.

public static void Assert(
bool condition
);

Parameters

condition
The evaluated condition

Exceptions

Exception Type | Condition
AssertionFailedException | thrown if condition == false

See Also

Assertion Class | Assertion Members | ICSharpCode.SharpUnit Namespace | Assertion.Assert Overload List


Assertion.Assert Method (String, Boolean)

Asserts that a condition is true.

public static void Assert(
string message,
bool condition
);

Parameters

message
The message to display if the condition is false
condition
The evaluated condition

Exceptions

Exception Type | Condition
AssertionFailedException | thrown if condition == false

See Also

Assertion Class | Assertion Members | ICSharpCode.SharpUnit Namespace | Assertion.Assert Overload List


AssertEquals Method

ICSharpCode.SharpUnit an Unit Testing Framework for .NET

Assertion.AssertEquals Method

Asserts that two doubles are equal concerning a delta. If the expected value is infinity then the delta value is ignored.

Overload List

Asserts that two doubles are equal concerning a delta. If the expected value is infinity then the delta value is ignored.

public static void AssertEquals(double,double,double);

Asserts that two doubles are equal concerning a delta. If the expected value is infinity then the delta value is ignored.

public static void AssertEquals(string,double,double,double);

Asserts that two singles are equal concerning a delta. If the expected value is infinity then the delta value is ignored.

public static void AssertEquals(float,float,float);

Asserts that two floats are equal concerning a delta. If the expected value is infinity then the delta value is ignored.

public static void AssertEquals(string,float,float,float);

Asserts that two objects are equal.

public static void AssertEquals(object,object);

Asserts that two objects are equal.

public static void AssertEquals(string,object,object);

See Also

Assertion Class | Assertion Members | ICSharpCode.SharpUnit Namespace


Assertion.AssertEquals Method (Double, Double, Double)

Asserts that two doubles are equal concerning a delta. If the expected value is infinity then the delta value is ignored.

public static void AssertEquals(
double expected,
double current,
double delta
);

Parameters

expected
The expected value
current
The current value
delta
The maximum acceptable difference between the the expected and the current

Exceptions

Exception Type | Condition
AssertionFailedException | thrown if |excepted - current| > delta

See Also

Assertion Class | Assertion Members | ICSharpCode.SharpUnit Namespace | Assertion.AssertEquals Overload List


Assertion.AssertEquals Method (Object, Object)

Asserts that two objects are equal.

public static void AssertEquals(
object expected,
object current
);

Parameters

expected
The expected value
current
The current value

Exceptions

Exception Type | Condition
AssertionFailedException | if !excepted.Equals(current).

See Also

Assertion Class | Assertion Members | ICSharpCode.SharpUnit Namespace | Assertion.AssertEquals Overload List


Assertion.AssertEquals Method (Single, Single, Single)

Asserts that two singles are equal concerning a delta. If the expected value is infinity then the delta value is ignored.

public static void AssertEquals(
float expected,
float current,
float delta
);

Parameters

expected
The expected value
current
The current value
delta
The maximum acceptable difference between the the expected and the current

Exceptions

Exception Type | Condition
AssertionFailedException | thrown if |excepted - current| > delta

See Also

Assertion Class | Assertion Members | ICSharpCode.SharpUnit Namespace | Assertion.AssertEquals Overload List


Assertion.AssertEquals Method (String, Double, Double, Double)

Asserts that two doubles are equal concerning a delta. If the expected value is infinity then the delta value is ignored.

public static void AssertEquals(
string message,
double expected,
double current,
double delta
);

Parameters

message
The message to display if the two objects aren't equal.
expected
The expected value
current
The current value
delta
The maximum acceptable difference between the the expected and the current

Exceptions

Exception Type | Condition
AssertionFailedException | thrown if |excepted - current| > delta

See Also

Assertion Class | Assertion Members | ICSharpCode.SharpUnit Namespace | Assertion.AssertEquals Overload List


Assertion.AssertEquals Method (String, Object, Object)

Asserts that two objects are equal.

public static void AssertEquals(
string message,
object expected,
object current
);

Parameters

message
The message to display if the two objects aren't equal.
expected
The expected value
current
The current value

Exceptions

Exception Type | Condition
AssertionFailedException | thrown if !excepted.Equals(current)

See Also

Assertion Class | Assertion Members | ICSharpCode.SharpUnit Namespace | Assertion.AssertEquals Overload List


Assertion.AssertEquals Method (String, Single, Single, Single)

Asserts that two floats are equal concerning a delta. If the expected value is infinity then the delta value is ignored.

public static void AssertEquals(
string message,
float expected,
float current,
float delta
);

Parameters

message
The message to display if the two objects aren't equal.
expected
The expected value
current
The current value
delta
The maximum acceptable difference between the the expected and the current

Exceptions

Exception Type | Condition
AssertionFailedException | thrown if |excepted - current| > delta

See Also

Assertion Class | Assertion Members | ICSharpCode.SharpUnit Namespace | Assertion.AssertEquals Overload List


AssertNotNull Method

ICSharpCode.SharpUnit an Unit Testing Framework for .NET

Assertion.AssertNotNull Method

Asserts that an object isn't null.

Overload List

Asserts that an object isn't null.

public static void AssertNotNull(object);

Asserts that an object isn't null.

public static void AssertNotNull(string,object);

See Also

Assertion Class | Assertion Members | ICSharpCode.SharpUnit Namespace


Assertion.AssertNotNull Method (Object)

Asserts that an object isn't null.

public static void AssertNotNull(
object o
);

Exceptions

Exception Type | Condition
AssertionFailedException | thrown if o == null

See Also

Assertion Class | Assertion Members | ICSharpCode.SharpUnit Namespace | Assertion.AssertNotNull Overload List


Assertion.AssertNotNull Method (String, Object)

Asserts that an object isn't null.

public static void AssertNotNull(
string message,
object o
);

Parameters

message
The message to display if o == null
o

Exceptions

Exception Type | Condition
AssertionFailedException | thrown if o == null

See Also

Assertion Class | Assertion Members | ICSharpCode.SharpUnit Namespace | Assertion.AssertNotNull Overload List


AssertNull Method

ICSharpCode.SharpUnit an Unit Testing Framework for .NET

Assertion.AssertNull Method

Asserts that an object is null.

Overload List

Asserts that an object is null.

public static void AssertNull(object);

Asserts that an object is null.

public static void AssertNull(string,object);

See Also

Assertion Class | Assertion Members | ICSharpCode.SharpUnit Namespace


Assertion.AssertNull Method (Object)

Asserts that an object is null.

public static void AssertNull(
object o
);

Exceptions

Exception Type | Condition
AssertionFailedException | thrown if o != null

See Also

Assertion Class | Assertion Members | ICSharpCode.SharpUnit Namespace | Assertion.AssertNull Overload List


Assertion.AssertNull Method (String, Object)

Asserts that an object is null.

public static void AssertNull(
string message,
object o
);

Parameters

message
The message to display if o != null
o

Exceptions

Exception Type | Condition
AssertionFailedException | thrown if o != null

See Also

Assertion Class | Assertion Members | ICSharpCode.SharpUnit Namespace | Assertion.AssertNull Overload List


AssertSame Method

ICSharpCode.SharpUnit an Unit Testing Framework for .NET

Assertion.AssertSame Method

Asserts that two objects refer to the same object.

Overload List

Asserts that two objects refer to the same object.

public static void AssertSame(object,object);

Asserts that two objects refer to the same object.

public static void AssertSame(string,object,object);

See Also

Assertion Class | Assertion Members | ICSharpCode.SharpUnit Namespace


Assertion.AssertSame Method (Object, Object)

Asserts that two objects refer to the same object.

public static void AssertSame(
object expected,
object current
);

Parameters

expected
The expected value
current
The current value

Exceptions

Exception Type | Condition
AssertionFailedException | thrown if excepted and current don't refer to the same object.

See Also

Assertion Class | Assertion Members | ICSharpCode.SharpUnit Namespace | Assertion.AssertSame Overload List


Assertion.AssertSame Method (String, Object, Object)

Asserts that two objects refer to the same object.

public static void AssertSame(
string message,
object expected,
object current
);

Parameters

message
The message to display if the two objects don't refer to the same object
expected
The expected value
current
The current value

Exceptions

Exception Type | Condition
AssertionFailedException | thrown if excepted and current don't refer to the same object.

See Also

Assertion Class | Assertion Members | ICSharpCode.SharpUnit Namespace | Assertion.AssertSame Overload List


Fail Method

ICSharpCode.SharpUnit an Unit Testing Framework for .NET

Assertion.Fail Method

Throw an AssertionFailedException.

Overload List

Throw an AssertionFailedException.

public static void Fail();

Throw an AssertionFailedException.

public static void Fail(string);

See Also

Assertion Class | Assertion Members | ICSharpCode.SharpUnit Namespace


Assertion.Fail Method ()

Throw an AssertionFailedException.

public static void Fail();

See Also

Assertion Class | Assertion Members | ICSharpCode.SharpUnit Namespace | Assertion.Fail Overload List


Assertion.Fail Method (String)

Throw an AssertionFailedException.

public static void Fail(
string message
);

Parameters

message
The message to display.

See Also

Assertion Class | Assertion Members | ICSharpCode.SharpUnit Namespace | Assertion.Fail Overload List


AssertionFailedException Class

Is thrown if an assertion failed.

For a list of all members of this type, see AssertionFailedException Members.

System.Object
Exception
AssertionFailedException

public class AssertionFailedException : Exception

Requirements

Namespace: ICSharpCode.SharpUnit Namespace

Assembly: ICSharpCode.SharpUnit.dll

See Also

AssertionFailedException Members | ICSharpCode.SharpUnit Namespace


AssertionFailedException Members

Public Instance Constructors

AssertionFailedException Constructor

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AssertionFailedException Class | ICSharpCode.SharpUnit Namespace


AssertionFailedException Constructor

public AssertionFailedException(
string message
);

See Also

AssertionFailedException Class | AssertionFailedException Members | ICSharpCode.SharpUnit Namespace


ExceptExceptionAttribute Class

Indicates that a test method may throw an exception

For a list of all members of this type, see ExceptExceptionAttribute Members.

System.Object
Attribute
ExceptExceptionAttribute

public class ExceptExceptionAttribute : Attribute

Requirements

Namespace: ICSharpCode.SharpUnit Namespace

Assembly: ICSharpCode.SharpUnit.dll

See Also

ExceptExceptionAttribute Members | ICSharpCode.SharpUnit Namespace


ExceptExceptionAttribute Members

Public Instance Constructors

ExceptExceptionAttribute Constructor Creates a new instance

Public Instance Properties

ExceptionType | The type of the exception the method will throw
TypeId (inherited from Attribute) | When implemented in a derived class, gets a unique identifier for this Attribute.

Public Instance Methods

Equals (inherited from Attribute) |
GetHashCode (inherited from Attribute) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IsDefaultAttribute (inherited from Attribute) | When overridden in a derived class, returns an indication whether the value of this instance is the default value for the derived class.
Match (inherited from Attribute) | When overridden in a derived class, returns a value indicating whether this instance equals a specified object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExceptExceptionAttribute Class | ICSharpCode.SharpUnit Namespace


ExceptExceptionAttribute Constructor

Creates a new instance

public ExceptExceptionAttribute(
Type exceptionType
);

Parameters

exceptionType
The type of the exception the method will throw

See Also

ExceptExceptionAttribute Class | ExceptExceptionAttribute Members | ICSharpCode.SharpUnit Namespace


ExceptExceptionAttribute Properties

The properties of the ExceptExceptionAttribute class are listed below. For a complete list of ExceptExceptionAttribute class members, see the ExceptExceptionAttribute Members topic.

Public Instance Properties

ExceptionType | The type of the exception the method will throw
TypeId (inherited from Attribute) | When implemented in a derived class, gets a unique identifier for this Attribute.

See Also

ExceptExceptionAttribute Class | ICSharpCode.SharpUnit Namespace


ExceptExceptionAttribute.ExceptionType Property

The type of the exception the method will throw

public System.Type ExceptionType {get;}

See Also

ExceptExceptionAttribute Class | ExceptExceptionAttribute Members | ICSharpCode.SharpUnit Namespace


TestAssemblyAttribute Class

Can be used to specify a description for an assembly that contains tests

For a list of all members of this type, see TestAssemblyAttribute Members.

System.Object
Attribute
TestAssemblyAttribute

public class TestAssemblyAttribute : Attribute

Requirements

Namespace: ICSharpCode.SharpUnit Namespace

Assembly: ICSharpCode.SharpUnit.dll

See Also

TestAssemblyAttribute Members | ICSharpCode.SharpUnit Namespace


TestAssemblyAttribute Members

Public Instance Constructors

TestAssemblyAttribute Overloaded. Initialize a new instance of the TestAssemblyAttribute class.

Public Instance Properties

Description | The description of this testsuite
TypeId (inherited from Attribute) | When implemented in a derived class, gets a unique identifier for this Attribute.

Public Instance Methods

Equals (inherited from Attribute) |
GetHashCode (inherited from Attribute) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IsDefaultAttribute (inherited from Attribute) | When overridden in a derived class, returns an indication whether the value of this instance is the default value for the derived class.
Match (inherited from Attribute) | When overridden in a derived class, returns a value indicating whether this instance equals a specified object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TestAssemblyAttribute Class | ICSharpCode.SharpUnit Namespace


TestAssemblyAttribute Constructor

Creates a new instance

Overload List

Creates a new instance

public TestAssemblyAttribute();

Creates a new instance

public TestAssemblyAttribute(string);

See Also

TestAssemblyAttribute Class | TestAssemblyAttribute Members | ICSharpCode.SharpUnit Namespace


TestAssemblyAttribute Constructor ()

Creates a new instance

public TestAssemblyAttribute();

See Also

TestAssemblyAttribute Class | TestAssemblyAttribute Members | ICSharpCode.SharpUnit Namespace | TestAssemblyAttribute Constructor Overload List


TestAssemblyAttribute Constructor (String)

Creates a new instance

public TestAssemblyAttribute(
string description
);

See Also

TestAssemblyAttribute Class | TestAssemblyAttribute Members | ICSharpCode.SharpUnit Namespace | TestAssemblyAttribute Constructor Overload List


TestAssemblyAttribute Properties

The properties of the TestAssemblyAttribute class are listed below. For a complete list of TestAssemblyAttribute class members, see the TestAssemblyAttribute Members topic.

Public Instance Properties

Description | The description of this testsuite
TypeId (inherited from Attribute) | When implemented in a derived class, gets a unique identifier for this Attribute.

See Also

TestAssemblyAttribute Class | ICSharpCode.SharpUnit Namespace


TestAssemblyAttribute.Description Property

The description of this testsuite

public string Description {get; set;}

See Also

TestAssemblyAttribute Class | TestAssemblyAttribute Members | ICSharpCode.SharpUnit Namespace


TestCallingMode Enumeration

This enumeration is used to specify the calling mode for a test

public enum TestCallingMode

Members

Member Name | Description
SingleCall | If a test is running in SingleCall mode a new instance of the test suite class is generated before each execution of the test (only this test will run in the instance)
SharedCall | This is the default mode. It indicates that the test shares its test suite with the other tests all shared tests will use the same instance of the test suite class

Requirements

Namespace: ICSharpCode.SharpUnit Namespace

Assembly: ICSharpCode.SharpUnit.dll

See Also

ICSharpCode.SharpUnit Namespace


TestMethodAttribute Class

Indicates that a method should be run in a test as a test method.

For a list of all members of this type, see TestMethodAttribute Members.

System.Object
Attribute
TestMethodAttribute

public class TestMethodAttribute : Attribute

Requirements

Namespace: ICSharpCode.SharpUnit Namespace

Assembly: ICSharpCode.SharpUnit.dll

See Also

TestMethodAttribute Members | ICSharpCode.SharpUnit Namespace


TestMethodAttribute Members

Public Instance Constructors

TestMethodAttribute Overloaded. Initialize a new instance of the TestMethodAttribute class.

Public Instance Properties

CallingMode |
Description | The description of this test method
TypeId (inherited from Attribute) | When implemented in a derived class, gets a unique identifier for this Attribute.

Public Instance Methods

Equals (inherited from Attribute) |
GetHashCode (inherited from Attribute) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IsDefaultAttribute (inherited from Attribute) | When overridden in a derived class, returns an indication whether the value of this instance is the default value for the derived class.
Match (inherited from Attribute) | When overridden in a derived class, returns a value indicating whether this instance equals a specified object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TestMethodAttribute Class | ICSharpCode.SharpUnit Namespace


TestMethodAttribute Constructor

Creates a new instance

Overload List

Creates a new instance

public TestMethodAttribute();

Creates a new instance

public TestMethodAttribute(string);

See Also

TestMethodAttribute Class | TestMethodAttribute Members | ICSharpCode.SharpUnit Namespace


TestMethodAttribute Constructor ()

Creates a new instance

public TestMethodAttribute();

See Also

TestMethodAttribute Class | TestMethodAttribute Members | ICSharpCode.SharpUnit Namespace | TestMethodAttribute Constructor Overload List


TestMethodAttribute Constructor (String)

Creates a new instance

public TestMethodAttribute(
string description
);

See Also

TestMethodAttribute Class | TestMethodAttribute Members | ICSharpCode.SharpUnit Namespace | TestMethodAttribute Constructor Overload List


TestMethodAttribute Properties

The properties of the TestMethodAttribute class are listed below. For a complete list of TestMethodAttribute class members, see the TestMethodAttribute Members topic.

Public Instance Properties

CallingMode |
Description | The description of this test method
TypeId (inherited from Attribute) | When implemented in a derived class, gets a unique identifier for this Attribute.

See Also

TestMethodAttribute Class | ICSharpCode.SharpUnit Namespace


TestMethodAttribute.CallingMode Property

public TestCallingMode CallingMode {get; set;}

See Also

TestMethodAttribute Class | TestMethodAttribute Members | ICSharpCode.SharpUnit Namespace


TestMethodAttribute.Description Property

The description of this test method

public string Description {get; set;}

See Also

TestMethodAttribute Class | TestMethodAttribute Members | ICSharpCode.SharpUnit Namespace


TestSuiteAttribute Class

Indicates that a class contains test methods.

For a list of all members of this type, see TestSuiteAttribute Members.

System.Object
Attribute
TestSuiteAttribute

public class TestSuiteAttribute : Attribute

Requirements

Namespace: ICSharpCode.SharpUnit Namespace

Assembly: ICSharpCode.SharpUnit.dll

See Also

TestSuiteAttribute Members | ICSharpCode.SharpUnit Namespace


TestSuiteAttribute Members

Public Instance Constructors

TestSuiteAttribute Overloaded. Initialize a new instance of the TestSuiteAttribute class.

Public Instance Properties

Description | The description of this testsuite
TypeId (inherited from Attribute) | When implemented in a derived class, gets a unique identifier for this Attribute.

Public Instance Methods

Equals (inherited from Attribute) |
GetHashCode (inherited from Attribute) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IsDefaultAttribute (inherited from Attribute) | When overridden in a derived class, returns an indication whether the value of this instance is the default value for the derived class.
Match (inherited from Attribute) | When overridden in a derived class, returns a value indicating whether this instance equals a specified object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TestSuiteAttribute Class | ICSharpCode.SharpUnit Namespace


TestSuiteAttribute Constructor

Creates a new instance

Overload List

Creates a new instance

public TestSuiteAttribute();

Creates a new instance

public TestSuiteAttribute(string);

See Also

TestSuiteAttribute Class | TestSuiteAttribute Members | ICSharpCode.SharpUnit Namespace


TestSuiteAttribute Constructor ()

Creates a new instance

public TestSuiteAttribute();

See Also

TestSuiteAttribute Class | TestSuiteAttribute Members | ICSharpCode.SharpUnit Namespace | TestSuiteAttribute Constructor Overload List


TestSuiteAttribute Constructor (String)

Creates a new instance

public TestSuiteAttribute(
string description
);

See Also

TestSuiteAttribute Class | TestSuiteAttribute Members | ICSharpCode.SharpUnit Namespace | TestSuiteAttribute Constructor Overload List


TestSuiteAttribute Properties

The properties of the TestSuiteAttribute class are listed below. For a complete list of TestSuiteAttribute class members, see the TestSuiteAttribute Members topic.

Public Instance Properties

Description | The description of this testsuite
TypeId (inherited from Attribute) | When implemented in a derived class, gets a unique identifier for this Attribute.

See Also

TestSuiteAttribute Class | ICSharpCode.SharpUnit Namespace


TestSuiteAttribute.Description Property

The description of this testsuite

public string Description {get; set;}

See Also

TestSuiteAttribute Class | TestSuiteAttribute Members | ICSharpCode.SharpUnit Namespace


ICSharpCode.SharpUnit.Environment

ICSharpCode.SharpUnit an Unit Testing Framework for .NET

ICSharpCode.SharpUnit.Environment Namespace

Namespace hierarchy

Classes

Class | Description
AssemblyLister |
AssemblyLoader |
AssemblyLoaderDomain |
DefaultTest | Default implementation of the ITest interface.
DefaultTestRunner |
DefaultTestSuite |
TestAssemblyEventArgs |
TestEventArgs |
TestFailedEventArgs |
TestSuiteEventArgs |
TestSuiteFailedEventArgs |
UnloadTestSuitException |
XmlTestListener |
XmlTestListener.TestInformationBase |

Interfaces

Interface | Description
ITest | This interface describes the basic test.
ITestRunner | The basic interface for the test runner. The test runner is a container for all assembly loaders and it does run the tests.
ITestSuite | This is the basic collection of tests. (e.g. a testclass)

Delegates

Delegate | Description
TestAssemblyEventHandler |
TestEventHandler |
TestFailedEventHandler |
TestSuiteEventHandler |
TestSuiteFailedEventHandler |


AssemblyLister Class

For a list of all members of this type, see AssemblyLister Members.

System.Object
MarshalByRefObject
AssemblyLister

public class AssemblyLister : MarshalByRefObject

Requirements

Namespace: ICSharpCode.SharpUnit.Environment Namespace

Assembly: ICSharpCode.SharpUnit.dll

See Also

AssemblyLister Members | ICSharpCode.SharpUnit.Environment Namespace


AssemblyLister Members

Public Instance Constructors

AssemblyLister Constructor Initializes a new instance of the AssemblyLister class.

Public Instance Properties

Assembly

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize |
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
LoadAssemblyConfiguration |
MyResolveEventHandler |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AssemblyLister Class | ICSharpCode.SharpUnit.Environment Namespace


AssemblyLister Constructor

Initializes a new instance of the AssemblyLister class.

public AssemblyLister();

See Also

AssemblyLister Class | AssemblyLister Members | ICSharpCode.SharpUnit.Environment Namespace


AssemblyLister Properties

The properties of the AssemblyLister class are listed below. For a complete list of AssemblyLister class members, see the AssemblyLister Members topic.

Public Instance Properties

Assembly

See Also

AssemblyLister Class | ICSharpCode.SharpUnit.Environment Namespace


AssemblyLister.Assembly Property

public System.Reflection.Assembly Assembly {get;}

See Also

AssemblyLister Class | AssemblyLister Members | ICSharpCode.SharpUnit.Environment Namespace


AssemblyLister Methods

The methods of the AssemblyLister class are listed below. For a complete list of AssemblyLister class members, see the AssemblyLister Members topic.

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize |
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
LoadAssemblyConfiguration |
MyResolveEventHandler |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AssemblyLister Class | ICSharpCode.SharpUnit.Environment Namespace


AssemblyLister.Initialize Method

public void Initialize(
string assemblyName
);

See Also

AssemblyLister Class | AssemblyLister Members | ICSharpCode.SharpUnit.Environment Namespace


AssemblyLister.LoadAssemblyConfiguration Method

public void LoadAssemblyConfiguration(
string assemblyLocation
);

See Also

AssemblyLister Class | AssemblyLister Members | ICSharpCode.SharpUnit.Environment Namespace


AssemblyLister.MyResolveEventHandler Method

public Assembly MyResolveEventHandler(
object sender,
ResolveEventArgs e
);

See Also

AssemblyLister Class | AssemblyLister Members | ICSharpCode.SharpUnit.Environment Namespace


AssemblyLoader Class

For a list of all members of this type, see AssemblyLoader Members.

System.Object
MarshalByRefObject
AssemblyLoader

public class AssemblyLoader : MarshalByRefObject

Requirements

Namespace: ICSharpCode.SharpUnit.Environment Namespace

Assembly: ICSharpCode.SharpUnit.dll

See Also

AssemblyLoader Members | ICSharpCode.SharpUnit.Environment Namespace


AssemblyLoader Members

Public Instance Constructors

AssemblyLoader Constructor

Public Instance Properties

Assembly |
AssemblyDescription | Returns the description of the assembly which was specified wit hthe TestAssemblyAttribute
AssemblyLocation |
AssemblyName |
TestSuites |

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
ReloadAssembly |
ToString (inherited from Object) | Returns a String that represents the current Object.
UnloadAssembly |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AssemblyLoader Class | ICSharpCode.SharpUnit.Environment Namespace


AssemblyLoader Constructor

public AssemblyLoader(
string assemblyLocation,
bool newAppDomain
);

See Also

AssemblyLoader Class | AssemblyLoader Members | ICSharpCode.SharpUnit.Environment Namespace


AssemblyLoader Properties

The properties of the AssemblyLoader class are listed below. For a complete list of AssemblyLoader class members, see the AssemblyLoader Members topic.

Public Instance Properties

Assembly |
AssemblyDescription | Returns the description of the assembly which was specified wit hthe TestAssemblyAttribute
AssemblyLocation |
AssemblyName |
TestSuites |

See Also

AssemblyLoader Class | ICSharpCode.SharpUnit.Environment Namespace


AssemblyLoader.Assembly Property

public System.Reflection.Assembly Assembly {get;}

See Also

AssemblyLoader Class | AssemblyLoader Members | ICSharpCode.SharpUnit.Environment Namespace


AssemblyLoader.AssemblyDescription Property

Returns the description of the assembly which was specified wit hthe TestAssemblyAttribute

public string AssemblyDescription {get;}

See Also

AssemblyLoader Class | AssemblyLoader Members | ICSharpCode.SharpUnit.Environment Namespace


AssemblyLoader.AssemblyLocation Property

public string AssemblyLocation {get;}

See Also

AssemblyLoader Class | AssemblyLoader Members | ICSharpCode.SharpUnit.Environment Namespace


AssemblyLoader.AssemblyName Property

public System.Reflection.AssemblyName AssemblyName {get;}

See Also

AssemblyLoader Class | AssemblyLoader Members | ICSharpCode.SharpUnit.Environment Namespace


AssemblyLoader.TestSuites Property

public System.Collections.ArrayList TestSuites {get;}

See Also

AssemblyLoader Class | AssemblyLoader Members | ICSharpCode.SharpUnit.Environment Namespace


AssemblyLoader Methods

The methods of the AssemblyLoader class are listed below. For a complete list of AssemblyLoader class members, see the AssemblyLoader Members topic.

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
ReloadAssembly |
ToString (inherited from Object) | Returns a String that represents the current Object.
UnloadAssembly |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AssemblyLoader Class | ICSharpCode.SharpUnit.Environment Namespace


AssemblyLoader.ReloadAssembly Method

public void ReloadAssembly();

See Also

AssemblyLoader Class | AssemblyLoader Members | ICSharpCode.SharpUnit.Environment Namespace


AssemblyLoader.UnloadAssembly Method

public void UnloadAssembly();

See Also

AssemblyLoader Class | AssemblyLoader Members | ICSharpCode.SharpUnit.Environment Namespace


AssemblyLoaderDomain Class

For a list of all members of this type, see AssemblyLoaderDomain Members.

System.Object
MarshalByRefObject
AssemblyLoaderDomain

public class AssemblyLoaderDomain : MarshalByRefObject

Requirements

Namespace: ICSharpCode.SharpUnit.Environment Namespace

Assembly: ICSharpCode.SharpUnit.dll

See Also

AssemblyLoaderDomain Members | ICSharpCode.SharpUnit.Environment Namespace


AssemblyLoaderDomain Members

Public Instance Constructors

AssemblyLoaderDomain Constructor Initializes a new instance of the AssemblyLoaderDomain class.

Public Instance Properties

Domain

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Load |
ToString (inherited from Object) | Returns a String that represents the current Object.
Unload |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AssemblyLoaderDomain Class | ICSharpCode.SharpUnit.Environment Namespace


AssemblyLoaderDomain Constructor

Initializes a new instance of the AssemblyLoaderDomain class.

public AssemblyLoaderDomain();

See Also

AssemblyLoaderDomain Class | AssemblyLoaderDomain Members | ICSharpCode.SharpUnit.Environment Namespace


AssemblyLoaderDomain Properties

The properties of the AssemblyLoaderDomain class are listed below. For a complete list of AssemblyLoaderDomain class members, see the AssemblyLoaderDomain Members topic.

Public Instance Properties

Domain

See Also

AssemblyLoaderDomain Class | ICSharpCode.SharpUnit.Environment Namespace


AssemblyLoaderDomain.Domain Property

public System.AppDomain Domain {get;}

See Also

AssemblyLoaderDomain Class | AssemblyLoaderDomain Members | ICSharpCode.SharpUnit.Environment Namespace


AssemblyLoaderDomain Methods

The methods of the AssemblyLoaderDomain class are listed below. For a complete list of AssemblyLoaderDomain class members, see the AssemblyLoaderDomain Members topic.

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Load |
ToString (inherited from Object) | Returns a String that represents the current Object.
Unload |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AssemblyLoaderDomain Class | ICSharpCode.SharpUnit.Environment Namespace


AssemblyLoaderDomain.Load Method

public AssemblyLister Load(
string assemblyFileName,
bool createNewAppDomain
);

See Also

AssemblyLoaderDomain Class | AssemblyLoaderDomain Members | ICSharpCode.SharpUnit.Environment Namespace


AssemblyLoaderDomain.Unload Method

public void Unload();

See Also

AssemblyLoaderDomain Class | AssemblyLoaderDomain Members | ICSharpCode.SharpUnit.Environment Namespace


DefaultTest Class

Default implementation of the ITest interface.

For a list of all members of this type, see DefaultTest Members.

System.Object
MarshalByRefObject
DefaultTest

public class DefaultTest : MarshalByRefObject, ITest

Requirements

Namespace: ICSharpCode.SharpUnit.Environment Namespace

Assembly: ICSharpCode.SharpUnit.dll

See Also

DefaultTest Members | ICSharpCode.SharpUnit.Environment Namespace


DefaultTest Members

Public Instance Constructors

DefaultTest Constructor

Public Instance Properties

CallingMode
Description
Name

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DefaultTest Class | ICSharpCode.SharpUnit.Environment Namespace


DefaultTest Constructor

public DefaultTest(
ITestSuite suite,
MethodInfo methodInfo
);

See Also

DefaultTest Class | DefaultTest Members | ICSharpCode.SharpUnit.Environment Namespace


DefaultTest Properties

The properties of the DefaultTest class are listed below. For a complete list of DefaultTest class members, see the DefaultTest Members topic.

Public Instance Properties

CallingMode
Description
Name

See Also

DefaultTest Class | ICSharpCode.SharpUnit.Environment Namespace


DefaultTest.CallingMode Property

public ICSharpCode.SharpUnit.TestCallingMode CallingMode {get;}

Implements

ITest.CallingMode

See Also

DefaultTest Class | DefaultTest Members | ICSharpCode.SharpUnit.Environment Namespace


DefaultTest.Description Property

public string Description {get;}

Implements

ITest.Description

See Also

DefaultTest Class | DefaultTest Members | ICSharpCode.SharpUnit.Environment Namespace


DefaultTest.Name Property

public string Name {get;}

Implements

ITest.Name

See Also

DefaultTest Class | DefaultTest Members | ICSharpCode.SharpUnit.Environment Namespace


DefaultTest Methods

The methods of the DefaultTest class are listed below. For a complete list of DefaultTest class members, see the DefaultTest Members topic.

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DefaultTest Class | ICSharpCode.SharpUnit.Environment Namespace


DefaultTest.Run Method

public void Run();

Implements

ITest.Run

See Also

DefaultTest Class | DefaultTest Members | ICSharpCode.SharpUnit.Environment Namespace


DefaultTestRunner Class

For a list of all members of this type, see DefaultTestRunner Members.

System.Object
MarshalByRefObject
DefaultTestRunner

public class DefaultTestRunner : MarshalByRefObject, ITestRunner

Requirements

Namespace: ICSharpCode.SharpUnit.Environment Namespace

Assembly: ICSharpCode.SharpUnit.dll

See Also

DefaultTestRunner Members | ICSharpCode.SharpUnit.Environment Namespace


DefaultTestRunner Members

Public Instance Constructors

DefaultTestRunner Constructor Initializes a new instance of the DefaultTestRunner class.

Public Instance Properties

AssemblyLoader

Public Instance Methods

AddAssembly |
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
ReloadTestSuites |
RunAllTests |
RunTest |
ToString (inherited from Object) | Returns a String that represents the current Object.
UnloadTestSuites |

Public Instance Events

FailedTestSuiteCreation
TestAssemblyEnded
TestAssemblyStarted
TestEnded
TestFailed
TestRunEnded
TestRunStarted
TestStarted
TestSucceeded
TestSuiteEnded
TestSuiteStarted

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnFailedTestSuiteCreation |
OnTestAssemblyEnded |
OnTestAssemblyStarted |
OnTestEnded |
OnTestFailed |
OnTestRunEnded |
OnTestRunStarted |
OnTestStarted |
OnTestSucceeded |
OnTestSuiteEnded |
OnTestSuiteStarted |

See Also

DefaultTestRunner Class | ICSharpCode.SharpUnit.Environment Namespace


DefaultTestRunner Constructor

Initializes a new instance of the DefaultTestRunner class.

public DefaultTestRunner();

See Also

DefaultTestRunner Class | DefaultTestRunner Members | ICSharpCode.SharpUnit.Environment Namespace


DefaultTestRunner Properties

The properties of the DefaultTestRunner class are listed below. For a complete list of DefaultTestRunner class members, see the DefaultTestRunner Members topic.

Public Instance Properties

AssemblyLoader

See Also

DefaultTestRunner Class | ICSharpCode.SharpUnit.Environment Namespace


DefaultTestRunner.AssemblyLoader Property

public System.Collections.ArrayList AssemblyLoader {get;}

Implements

ITestRunner.AssemblyLoader

See Also

DefaultTestRunner Class | DefaultTestRunner Members | ICSharpCode.SharpUnit.Environment Namespace


DefaultTestRunner Methods

The methods of the DefaultTestRunner class are listed below. For a complete list of DefaultTestRunner class members, see the DefaultTestRunner Members topic.

Public Instance Methods

AddAssembly |
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
ReloadTestSuites |
RunAllTests |
RunTest |
ToString (inherited from Object) | Returns a String that represents the current Object.
UnloadTestSuites |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnFailedTestSuiteCreation |
OnTestAssemblyEnded |
OnTestAssemblyStarted |
OnTestEnded |
OnTestFailed |
OnTestRunEnded |
OnTestRunStarted |
OnTestStarted |
OnTestSucceeded |
OnTestSuiteEnded |
OnTestSuiteStarted |

See Also

DefaultTestRunner Class | ICSharpCode.SharpUnit.Environment Namespace


DefaultTestRunner.AddAssembly Method

public void AddAssembly(
string name,
bool newAppDomain
);

Implements

ITestRunner.AddAssembly

See Also

DefaultTestRunner Class | DefaultTestRunner Members | ICSharpCode.SharpUnit.Environment Namespace


DefaultTestRunner.OnFailedTestSuiteCreation Method

protected virtual void OnFailedTestSuiteCreation(
TestSuiteEventArgs e
);

See Also

DefaultTestRunner Class | DefaultTestRunner Members | ICSharpCode.SharpUnit.Environment Namespace


DefaultTestRunner.OnTestAssemblyEnded Method

protected virtual void OnTestAssemblyEnded(
TestAssemblyEventArgs e
);

See Also

DefaultTestRunner Class | DefaultTestRunner Members | ICSharpCode.SharpUnit.Environment Namespace


DefaultTestRunner.OnTestAssemblyStarted Method

protected virtual void OnTestAssemblyStarted(
TestAssemblyEventArgs e
);

See Also

DefaultTestRunner Class | DefaultTestRunner Members | ICSharpCode.SharpUnit.Environment Namespace


DefaultTestRunner.OnTestEnded Method

protected virtual void OnTestEnded(
TestEventArgs e
);

See Also

DefaultTestRunner Class | DefaultTestRunner Members | ICSharpCode.SharpUnit.Environment Namespace


DefaultTestRunner.OnTestFailed Method

protected virtual void OnTestFailed(
TestFailedEventArgs e
);

See Also

DefaultTestRunner Class | DefaultTestRunner Members | ICSharpCode.SharpUnit.Environment Namespace


DefaultTestRunner.OnTestRunEnded Method

protected virtual void OnTestRunEnded(
EventArgs e
);

See Also

DefaultTestRunner Class | DefaultTestRunner Members | ICSharpCode.SharpUnit.Environment Namespace


DefaultTestRunner.OnTestRunStarted Method

protected virtual void OnTestRunStarted(
EventArgs e
);

See Also

DefaultTestRunner Class | DefaultTestRunner Members | ICSharpCode.SharpUnit.Environment Namespace


DefaultTestRunner.OnTestStarted Method

protected virtual void OnTestStarted(
TestEventArgs e
);

See Also

DefaultTestRunner Class | DefaultTestRunner Members | ICSharpCode.SharpUnit.Environment Namespace


DefaultTestRunner.OnTestSucceeded Method

protected virtual void OnTestSucceeded(
TestEventArgs e
);

See Also

DefaultTestRunner Class | DefaultTestRunner Members | ICSharpCode.SharpUnit.Environment Namespace


DefaultTestRunner.OnTestSuiteEnded Method

protected virtual void OnTestSuiteEnded(
TestSuiteEventArgs e
);

See Also

DefaultTestRunner Class | DefaultTestRunner Members | ICSharpCode.SharpUnit.Environment Namespace


DefaultTestRunner.OnTestSuiteStarted Method

protected virtual void OnTestSuiteStarted(
TestSuiteEventArgs e
);

See Also

DefaultTestRunner Class | DefaultTestRunner Members | ICSharpCode.SharpUnit.Environment Namespace


DefaultTestRunner.ReloadTestSuites Method

public void ReloadTestSuites();

Implements

ITestRunner.ReloadTestSuites

See Also

DefaultTestRunner Class | DefaultTestRunner Members | ICSharpCode.SharpUnit.Environment Namespace


DefaultTestRunner.RunAllTests Method

public void RunAllTests();

Implements

ITestRunner.RunAllTests

See Also

DefaultTestRunner Class | DefaultTestRunner Members | ICSharpCode.SharpUnit.Environment Namespace


DefaultTestRunner.RunTest Method

public bool RunTest(
ITest test
);

Implements

ITestRunner.RunTest

See Also

DefaultTestRunner Class | DefaultTestRunner Members | ICSharpCode.SharpUnit.Environment Namespace


DefaultTestRunner.UnloadTestSuites Method

public void UnloadTestSuites();

Implements

ITestRunner.UnloadTestSuites

See Also

DefaultTestRunner Class | DefaultTestRunner Members | ICSharpCode.SharpUnit.Environment Namespace


DefaultTestRunner Events

The events of the DefaultTestRunner class are listed below. For a complete list of DefaultTestRunner class members, see the DefaultTestRunner Members topic.

Public Instance Events

FailedTestSuiteCreation
TestAssemblyEnded
TestAssemblyStarted
TestEnded
TestFailed
TestRunEnded
TestRunStarted
TestStarted
TestSucceeded
TestSuiteEnded
TestSuiteStarted

See Also

DefaultTestRunner Class | ICSharpCode.SharpUnit.Environment Namespace


DefaultTestRunner.FailedTestSuiteCreation Event

public event TestSuiteEventHandler FailedTestSuiteCreation;

Event Data

The event handler receives an argument of type TestSuiteEventArgs containing data related to this event. The following TestSuiteEventArgs property provides information specific to this event.

Property | Description
TestSuite |

See Also

DefaultTestRunner Class | DefaultTestRunner Members | ICSharpCode.SharpUnit.Environment Namespace


DefaultTestRunner.TestAssemblyEnded Event

public event TestAssemblyEventHandler TestAssemblyEnded;

Event Data

The event handler receives an argument of type TestAssemblyEventArgs containing data related to this event. The following TestAssemblyEventArgs property provides information specific to this event.

Property | Description
AssemblyLoader |

Implements

ITestRunner.TestAssemblyEnded

See Also

DefaultTestRunner Class | DefaultTestRunner Members | ICSharpCode.SharpUnit.Environment Namespace


DefaultTestRunner.TestAssemblyStarted Event

public event TestAssemblyEventHandler TestAssemblyStarted;

Event Data

The event handler receives an argument of type TestAssemblyEventArgs containing data related to this event. The following TestAssemblyEventArgs property provides information specific to this event.

Property | Description
AssemblyLoader |

Implements

ITestRunner.TestAssemblyStarted

See Also

DefaultTestRunner Class | DefaultTestRunner Members | ICSharpCode.SharpUnit.Environment Namespace


DefaultTestRunner.TestEnded Event

public event TestEventHandler TestEnded;

Event Data

The event handler receives an argument of type TestEventArgs containing data related to this event. The following TestEventArgs property provides information specific to this event.

Property | Description
Test |

Implements

ITestRunner.TestEnded

See Also

DefaultTestRunner Class | DefaultTestRunner Members | ICSharpCode.SharpUnit.Environment Namespace


DefaultTestRunner.TestFailed Event

public event TestFailedEventHandler TestFailed;

Event Data

The event handler receives an argument of type TestFailedEventArgs containing data related to this event. The following TestFailedEventArgs properties provide information specific to this event.

Property | Description
ExceptionThrown |
Test |

Implements

ITestRunner.TestFailed

See Also

DefaultTestRunner Class | DefaultTestRunner Members | ICSharpCode.SharpUnit.Environment Namespace


DefaultTestRunner.TestRunEnded Event

public event EventHandler TestRunEnded;

Implements

ITestRunner.TestRunEnded

See Also

DefaultTestRunner Class | DefaultTestRunner Members | ICSharpCode.SharpUnit.Environment Namespace


DefaultTestRunner.TestRunStarted Event

public event EventHandler TestRunStarted;

Implements

ITestRunner.TestRunStarted

See Also

DefaultTestRunner Class | DefaultTestRunner Members | ICSharpCode.SharpUnit.Environment Namespace


DefaultTestRunner.TestStarted Event

public event TestEventHandler TestStarted;

Event Data

The event handler receives an argument of type TestEventArgs containing data related to this event. The following TestEventArgs property provides information specific to this event.

Property | Description
Test |

Implements

ITestRunner.TestStarted

See Also

DefaultTestRunner Class | DefaultTestRunner Members | ICSharpCode.SharpUnit.Environment Namespace


DefaultTestRunner.TestSucceeded Event

public event TestEventHandler TestSucceeded;

Event Data

The event handler receives an argument of type TestEventArgs containing data related to this event. The following TestEventArgs property provides information specific to this event.

Property | Description
Test |

Implements

ITestRunner.TestSucceeded

See Also

DefaultTestRunner Class | DefaultTestRunner Members | ICSharpCode.SharpUnit.Environment Namespace


DefaultTestRunner.TestSuiteEnded Event

public event TestSuiteEventHandler TestSuiteEnded;

Event Data

The event handler receives an argument of type TestSuiteEventArgs containing data related to this event. The following TestSuiteEventArgs property provides information specific to this event.

Property | Description
TestSuite |

Implements

ITestRunner.TestSuiteEnded

See Also

DefaultTestRunner Class | DefaultTestRunner Members | ICSharpCode.SharpUnit.Environment Namespace


DefaultTestRunner.TestSuiteStarted Event

public event TestSuiteEventHandler TestSuiteStarted;

Event Data

The event handler receives an argument of type TestSuiteEventArgs containing data related to this event. The following TestSuiteEventArgs property provides information specific to this event.

Property | Description
TestSuite |

Implements

ITestRunner.TestSuiteStarted

See Also

DefaultTestRunner Class | DefaultTestRunner Members | ICSharpCode.SharpUnit.Environment Namespace


DefaultTestSuite Class

For a list of all members of this type, see DefaultTestSuite Members.

System.Object
MarshalByRefObject
DefaultTestSuite

public sealed class DefaultTestSuite : MarshalByRefObject, ITestSuite

Requirements

Namespace: ICSharpCode.SharpUnit.Environment Namespace

Assembly: ICSharpCode.SharpUnit.dll

See Also

DefaultTestSuite Members | ICSharpCode.SharpUnit.Environment Namespace


DefaultTestSuite Members

Public Instance Constructors

DefaultTestSuite Constructor

Public Instance Properties

CreateNewTestClass
Description
FullTypeName
TestClass
Tests
Type

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
LoadTestClass |
ToString (inherited from Object) | Returns a String that represents the current Object.
UnloadTestClass |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DefaultTestSuite Class | ICSharpCode.SharpUnit.Environment Namespace


DefaultTestSuite Constructor

public DefaultTestSuite(
AssemblyLoaderDomain domain,
AssemblyLoader assemblyLoader,
string fullTypeName
);

See Also

DefaultTestSuite Class | DefaultTestSuite Members | ICSharpCode.SharpUnit.Environment Namespace


DefaultTestSuite Properties

The properties of the DefaultTestSuite class are listed below. For a complete list of DefaultTestSuite class members, see the DefaultTestSuite Members topic.

Public Instance Properties

CreateNewTestClass
Description
FullTypeName
TestClass
Tests
Type

See Also

DefaultTestSuite Class | ICSharpCode.SharpUnit.Environment Namespace


DefaultTestSuite.CreateNewTestClass Property

public object CreateNewTestClass {get;}

Implements

ITestSuite.CreateNewTestClass

See Also

DefaultTestSuite Class | DefaultTestSuite Members | ICSharpCode.SharpUnit.Environment Namespace


DefaultTestSuite.Description Property

public string Description {get;}

Implements

ITestSuite.Description

See Also

DefaultTestSuite Class | DefaultTestSuite Members | ICSharpCode.SharpUnit.Environment Namespace


DefaultTestSuite.FullTypeName Property

public string FullTypeName {get;}

Implements

ITestSuite.FullTypeName

See Also

DefaultTestSuite Class | DefaultTestSuite Members | ICSharpCode.SharpUnit.Environment Namespace


DefaultTestSuite.TestClass Property

public object TestClass {get;}

Implements

ITestSuite.TestClass

See Also

DefaultTestSuite Class | DefaultTestSuite Members | ICSharpCode.SharpUnit.Environment Namespace


DefaultTestSuite.Tests Property

public System.Collections.ArrayList Tests {get;}

Implements

ITestSuite.Tests

See Also

DefaultTestSuite Class | DefaultTestSuite Members | ICSharpCode.SharpUnit.Environment Namespace


DefaultTestSuite.Type Property

public System.Type Type {get;}

Implements

ITestSuite.Type

See Also

DefaultTestSuite Class | DefaultTestSuite Members | ICSharpCode.SharpUnit.Environment Namespace


DefaultTestSuite Methods

The methods of the DefaultTestSuite class are listed below. For a complete list of DefaultTestSuite class members, see the DefaultTestSuite Members topic.

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
LoadTestClass |
ToString (inherited from Object) | Returns a String that represents the current Object.
UnloadTestClass |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DefaultTestSuite Class | ICSharpCode.SharpUnit.Environment Namespace


DefaultTestSuite.LoadTestClass Method

public void LoadTestClass();

Implements

ITestSuite.LoadTestClass

See Also

DefaultTestSuite Class | DefaultTestSuite Members | ICSharpCode.SharpUnit.Environment Namespace


DefaultTestSuite.UnloadTestClass Method

public void UnloadTestClass();

Implements

ITestSuite.UnloadTestClass

See Also

DefaultTestSuite Class | DefaultTestSuite Members | ICSharpCode.SharpUnit.Environment Namespace


ITest Interface

This interface describes the basic test.

For a list of all members of this type, see ITest Members.

public interface ITest

Requirements

Namespace: ICSharpCode.SharpUnit.Environment Namespace

Assembly: ICSharpCode.SharpUnit.dll

See Also

ITest Members | ICSharpCode.SharpUnit.Environment Namespace


ITest Members

Public Instance Properties

CallingMode | The calling mode of this test
Description The description of this test, may be
null
when no description is given.
Name | The name of the test (e.g. the name of the testmethod)

Public Instance Methods

Run Runs this test, if a exception is thrown the test is failed.

See Also

ITest Interface | ICSharpCode.SharpUnit.Environment Namespace


ITest Properties

The properties of the ITest interface are listed below. For a complete list of ITest interface members, see the ITest Members topic.

Public Instance Properties

CallingMode | The calling mode of this test
Description The description of this test, may be
null
when no description is given.
Name | The name of the test (e.g. the name of the testmethod)

See Also

ITest Interface | ICSharpCode.SharpUnit.Environment Namespace


ITest.CallingMode Property

The calling mode of this test

ICSharpCode.SharpUnit.TestCallingMode CallingMode {get;}

See Also

ITest Interface | ITest Members | ICSharpCode.SharpUnit.Environment Namespace | TestCallingMode


ITest.Description Property

The description of this test, may be

null
when no description is given.

string Description {get;}

See Also

ITest Interface | ITest Members | ICSharpCode.SharpUnit.Environment Namespace


ITest.Name Property

The name of the test (e.g. the name of the testmethod)

string Name {get;}

See Also

ITest Interface | ITest Members | ICSharpCode.SharpUnit.Environment Namespace


ITest Methods

The methods of the ITest interface are listed below. For a complete list of ITest interface members, see the ITest Members topic.

Public Instance Methods

Run Runs this test, if a exception is thrown the test is failed.

See Also

ITest Interface | ICSharpCode.SharpUnit.Environment Namespace


ITest.Run Method

Runs this test, if a exception is thrown the test is failed.

void Run();

See Also

ITest Interface | ITest Members | ICSharpCode.SharpUnit.Environment Namespace


ITestRunner Interface

The basic interface for the test runner. The test runner is a container for all assembly loaders and it does run the tests.

For a list of all members of this type, see ITestRunner Members.

public interface ITestRunner

Requirements

Namespace: ICSharpCode.SharpUnit.Environment Namespace

Assembly: ICSharpCode.SharpUnit.dll

See Also

ITestRunner Members | ICSharpCode.SharpUnit.Environment Namespace


ITestRunner Members

Public Instance Properties

AssemblyLoader An ArrayList which contains all assembly loaders.

Public Instance Methods

AddAssembly | Adds an Assembly to the runner, creates an AssemblyLoader which is put in the AssemblyLoader ArrayList.
ReloadTestSuites | Reloads all test suites.
RunAllTests | This method runs a all tests in all AssemblyLoaders
RunTest | This method runs a single test.
UnloadTestSuites | Unloads all test suites.

Public Instance Events

TestAssemblyEnded
TestAssemblyStarted
TestEnded
TestFailed
TestRunEnded
TestRunStarted
TestStarted
TestSucceeded
TestSuiteEnded
TestSuiteStarted

See Also

ITestRunner Interface | ICSharpCode.SharpUnit.Environment Namespace


ITestRunner Properties

The properties of the ITestRunner interface are listed below. For a complete list of ITestRunner interface members, see the ITestRunner Members topic.

Public Instance Properties

AssemblyLoader An ArrayList which contains all assembly loaders.

See Also

ITestRunner Interface | ICSharpCode.SharpUnit.Environment Namespace


ITestRunner.AssemblyLoader Property

An ArrayList which contains all assembly loaders.

System.Collections.ArrayList AssemblyLoader {get;}

See Also

ITestRunner Interface | ITestRunner Members | ICSharpCode.SharpUnit.Environment Namespace


ITestRunner Methods

The methods of the ITestRunner interface are listed below. For a complete list of ITestRunner interface members, see the ITestRunner Members topic.

Public Instance Methods

AddAssembly | Adds an Assembly to the runner, creates an AssemblyLoader which is put in the AssemblyLoader ArrayList.
ReloadTestSuites | Reloads all test suites.
RunAllTests | This method runs a all tests in all AssemblyLoaders
RunTest | This method runs a single test.
UnloadTestSuites | Unloads all test suites.

See Also

ITestRunner Interface | ICSharpCode.SharpUnit.Environment Namespace


ITestRunner.AddAssembly Method

Adds an Assembly to the runner, creates an AssemblyLoader which is put in the AssemblyLoader ArrayList.

void AddAssembly(
string name,
bool newAppDomain
);

See Also

ITestRunner Interface | ITestRunner Members | ICSharpCode.SharpUnit.Environment Namespace


ITestRunner.ReloadTestSuites Method

Reloads all test suites.

void ReloadTestSuites();

See Also

ITestRunner Interface | ITestRunner Members | ICSharpCode.SharpUnit.Environment Namespace


ITestRunner.RunAllTests Method

This method runs a all tests in all AssemblyLoaders

void RunAllTests();

See Also

ITestRunner Interface | ITestRunner Members | ICSharpCode.SharpUnit.Environment Namespace


ITestRunner.RunTest Method

This method runs a single test.

bool RunTest(
ITest test
);

Return Value

True, if the test succeeded

See Also

ITestRunner Interface | ITestRunner Members | ICSharpCode.SharpUnit.Environment Namespace


ITestRunner.UnloadTestSuites Method

Unloads all test suites.

void UnloadTestSuites();

See Also

ITestRunner Interface | ITestRunner Members | ICSharpCode.SharpUnit.Environment Namespace


ITestRunner Events

The events of the ITestRunner interface are listed below. For a complete list of ITestRunner interface members, see the ITestRunner Members topic.

Public Instance Events

TestAssemblyEnded
TestAssemblyStarted
TestEnded
TestFailed
TestRunEnded
TestRunStarted
TestStarted
TestSucceeded
TestSuiteEnded
TestSuiteStarted

See Also

ITestRunner Interface | ICSharpCode.SharpUnit.Environment Namespace


ITestRunner.TestAssemblyEnded Event

event TestAssemblyEventHandler TestAssemblyEnded;

Event Data

The event handler receives an argument of type TestAssemblyEventArgs containing data related to this event. The following TestAssemblyEventArgs property provides information specific to this event.

Property | Description
AssemblyLoader |

See Also

ITestRunner Interface | ITestRunner Members | ICSharpCode.SharpUnit.Environment Namespace


ITestRunner.TestAssemblyStarted Event

event TestAssemblyEventHandler TestAssemblyStarted;

Event Data

The event handler receives an argument of type TestAssemblyEventArgs containing data related to this event. The following TestAssemblyEventArgs property provides information specific to this event.

Property | Description
AssemblyLoader |

See Also

ITestRunner Interface | ITestRunner Members | ICSharpCode.SharpUnit.Environment Namespace


ITestRunner.TestEnded Event

event TestEventHandler TestEnded;

Event Data

The event handler receives an argument of type TestEventArgs containing data related to this event. The following TestEventArgs property provides information specific to this event.

Property | Description
Test |

See Also

ITestRunner Interface | ITestRunner Members | ICSharpCode.SharpUnit.Environment Namespace


ITestRunner.TestFailed Event

event TestFailedEventHandler TestFailed;

Event Data

The event handler receives an argument of type TestFailedEventArgs containing data related to this event. The following TestFailedEventArgs properties provide information specific to this event.

Property | Description
ExceptionThrown |
Test |

See Also

ITestRunner Interface | ITestRunner Members | ICSharpCode.SharpUnit.Environment Namespace


ITestRunner.TestRunEnded Event

event EventHandler TestRunEnded;

See Also

ITestRunner Interface | ITestRunner Members | ICSharpCode.SharpUnit.Environment Namespace


ITestRunner.TestRunStarted Event

event EventHandler TestRunStarted;

See Also

ITestRunner Interface | ITestRunner Members | ICSharpCode.SharpUnit.Environment Namespace


ITestRunner.TestStarted Event

event TestEventHandler TestStarted;

Event Data

The event handler receives an argument of type TestEventArgs containing data related to this event. The following TestEventArgs property provides information specific to this event.

Property | Description
Test |

See Also

ITestRunner Interface | ITestRunner Members | ICSharpCode.SharpUnit.Environment Namespace


ITestRunner.TestSucceeded Event

event TestEventHandler TestSucceeded;

Event Data

The event handler receives an argument of type TestEventArgs containing data related to this event. The following TestEventArgs property provides information specific to this event.

Property | Description
Test |

See Also

ITestRunner Interface | ITestRunner Members | ICSharpCode.SharpUnit.Environment Namespace


ITestRunner.TestSuiteEnded Event

event TestSuiteEventHandler TestSuiteEnded;

Event Data

The event handler receives an argument of type TestSuiteEventArgs containing data related to this event. The following TestSuiteEventArgs property provides information specific to this event.

Property | Description
TestSuite |

See Also

ITestRunner Interface | ITestRunner Members | ICSharpCode.SharpUnit.Environment Namespace


ITestRunner.TestSuiteStarted Event

event TestSuiteEventHandler TestSuiteStarted;

Event Data

The event handler receives an argument of type TestSuiteEventArgs containing data related to this event. The following TestSuiteEventArgs property provides information specific to this event.

Property | Description
TestSuite |

See Also

ITestRunner Interface | ITestRunner Members | ICSharpCode.SharpUnit.Environment Namespace


ITestSuite Interface

This is the basic collection of tests. (e.g. a testclass)

For a list of all members of this type, see ITestSuite Members.

public interface ITestSuite

Requirements

Namespace: ICSharpCode.SharpUnit.Environment Namespace

Assembly: ICSharpCode.SharpUnit.dll

See Also

ITestSuite Members | ICSharpCode.SharpUnit.Environment Namespace


ITestSuite Members

Public Instance Properties

CreateNewTestClass Creates a new object of the type
Type
Description Description of this testsuite, may be
null
if no description is given.
FullTypeName | The full type name of the type.
TestClass An object of type
Type
Tests | An ArrayList containing all Tests in this suite.
Type | The type in which the testmethods are.

Public Instance Methods

LoadTestClass | Loads the testclass. Initializes type, creates the TestClass object.
UnloadTestClass | Unloads the testclass, after this call TestClass == null and Type == null only the FullTypeName is valid.

See Also

ITestSuite Interface | ICSharpCode.SharpUnit.Environment Namespace


ITestSuite Properties

The properties of the ITestSuite interface are listed below. For a complete list of ITestSuite interface members, see the ITestSuite Members topic.

Public Instance Properties

CreateNewTestClass Creates a new object of the type
Type
Description Description of this testsuite, may be
null
if no description is given.
FullTypeName | The full type name of the type.
TestClass An object of type
Type
Tests | An ArrayList containing all Tests in this suite.
Type | The type in which the testmethods are.

See Also

ITestSuite Interface | ICSharpCode.SharpUnit.Environment Namespace


ITestSuite.CreateNewTestClass Property

Creates a new object of the type

Type

object CreateNewTestClass {get;}

See Also

ITestSuite Interface | ITestSuite Members | ICSharpCode.SharpUnit.Environment Namespace


ITestSuite.Description Property

Description of this testsuite, may be

null
if no description is given.

string Description {get;}

See Also

ITestSuite Interface | ITestSuite Members | ICSharpCode.SharpUnit.Environment Namespace


ITestSuite.FullTypeName Property

The full type name of the type.

string FullTypeName {get;}

See Also

ITestSuite Interface | ITestSuite Members | ICSharpCode.SharpUnit.Environment Namespace


ITestSuite.TestClass Property

An object of type

Type

object TestClass {get;}

See Also

ITestSuite Interface | ITestSuite Members | ICSharpCode.SharpUnit.Environment Namespace


ITestSuite.Tests Property

An ArrayList containing all Tests in this suite.

System.Collections.ArrayList Tests {get;}

See Also

ITestSuite Interface | ITestSuite Members | ICSharpCode.SharpUnit.Environment Namespace


ITestSuite.Type Property

The type in which the testmethods are.

System.Type Type {get;}

See Also

ITestSuite Interface | ITestSuite Members | ICSharpCode.SharpUnit.Environment Namespace


ITestSuite Methods

The methods of the ITestSuite interface are listed below. For a complete list of ITestSuite interface members, see the ITestSuite Members topic.

Public Instance Methods

LoadTestClass | Loads the testclass. Initializes type, creates the TestClass object.
UnloadTestClass | Unloads the testclass, after this call TestClass == null and Type == null only the FullTypeName is valid.

See Also

ITestSuite Interface | ICSharpCode.SharpUnit.Environment Namespace


ITestSuite.LoadTestClass Method

Loads the testclass. Initializes type, creates the TestClass object.

void LoadTestClass();

See Also

ITestSuite Interface | ITestSuite Members | ICSharpCode.SharpUnit.Environment Namespace


ITestSuite.UnloadTestClass Method

Unloads the testclass, after this call TestClass == null and Type == null only the FullTypeName is valid.

void UnloadTestClass();

See Also

ITestSuite Interface | ITestSuite Members | ICSharpCode.SharpUnit.Environment Namespace


TestAssemblyEventArgs Class

For a list of all members of this type, see TestAssemblyEventArgs Members.

System.Object
EventArgs
TestAssemblyEventArgs

public class TestAssemblyEventArgs : EventArgs

Requirements

Namespace: ICSharpCode.SharpUnit.Environment Namespace

Assembly: ICSharpCode.SharpUnit.dll

See Also

TestAssemblyEventArgs Members | ICSharpCode.SharpUnit.Environment Namespace


TestAssemblyEventArgs Members

Public Instance Constructors

TestAssemblyEventArgs Constructor

Public Instance Properties

AssemblyLoader

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TestAssemblyEventArgs Class | ICSharpCode.SharpUnit.Environment Namespace


TestAssemblyEventArgs Constructor

public TestAssemblyEventArgs(
AssemblyLoader assemblyLoader
);

See Also

TestAssemblyEventArgs Class | TestAssemblyEventArgs Members | ICSharpCode.SharpUnit.Environment Namespace


TestAssemblyEventArgs Properties

The properties of the TestAssemblyEventArgs class are listed below. For a complete list of TestAssemblyEventArgs class members, see the TestAssemblyEventArgs Members topic.

Public Instance Properties

AssemblyLoader

See Also

TestAssemblyEventArgs Class | ICSharpCode.SharpUnit.Environment Namespace


TestAssemblyEventArgs.AssemblyLoader Property

public AssemblyLoader AssemblyLoader {get;}

See Also

TestAssemblyEventArgs Class | TestAssemblyEventArgs Members | ICSharpCode.SharpUnit.Environment Namespace


TestAssemblyEventHandler Delegate

public delegate void TestAssemblyEventHandler(
object sender,
TestAssemblyEventArgs e
);

Requirements

Namespace: ICSharpCode.SharpUnit.Environment Namespace

Assembly: ICSharpCode.SharpUnit.dll

See Also

ICSharpCode.SharpUnit.Environment Namespace


TestEventArgs Class

For a list of all members of this type, see TestEventArgs Members.

System.Object
EventArgs
TestEventArgs

public class TestEventArgs : EventArgs

Requirements

Namespace: ICSharpCode.SharpUnit.Environment Namespace

Assembly: ICSharpCode.SharpUnit.dll

See Also

TestEventArgs Members | ICSharpCode.SharpUnit.Environment Namespace


TestEventArgs Members

Public Instance Constructors

TestEventArgs Constructor

Public Instance Properties

Test

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TestEventArgs Class | ICSharpCode.SharpUnit.Environment Namespace


TestEventArgs Constructor

public TestEventArgs(
ITest test
);

See Also

TestEventArgs Class | TestEventArgs Members | ICSharpCode.SharpUnit.Environment Namespace


TestEventArgs Properties

The properties of the TestEventArgs class are listed below. For a complete list of TestEventArgs class members, see the TestEventArgs Members topic.

Public Instance Properties

Test

See Also

TestEventArgs Class | ICSharpCode.SharpUnit.Environment Namespace


TestEventArgs.Test Property

public ITest Test {get;}

See Also

TestEventArgs Class | TestEventArgs Members | ICSharpCode.SharpUnit.Environment Namespace


TestEventHandler Delegate

public delegate void TestEventHandler(
object sender,
TestEventArgs e
);

Requirements

Namespace: ICSharpCode.SharpUnit.Environment Namespace

Assembly: ICSharpCode.SharpUnit.dll

See Also

ICSharpCode.SharpUnit.Environment Namespace


TestFailedEventArgs Class

For a list of all members of this type, see TestFailedEventArgs Members.

System.Object
EventArgs
TestEventArgs
TestFailedEventArgs

public class TestFailedEventArgs : TestEventArgs

Requirements

Namespace: ICSharpCode.SharpUnit.Environment Namespace

Assembly: ICSharpCode.SharpUnit.dll

See Also

TestFailedEventArgs Members | ICSharpCode.SharpUnit.Environment Namespace


TestFailedEventArgs Members

Public Instance Constructors

TestFailedEventArgs Constructor

Public Instance Properties

ExceptionThrown
Test (inherited from TestEventArgs)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TestFailedEventArgs Class | ICSharpCode.SharpUnit.Environment Namespace


TestFailedEventArgs Constructor

public TestFailedEventArgs(
ITest test,
Exception exceptionThrown
);

See Also

TestFailedEventArgs Class | TestFailedEventArgs Members | ICSharpCode.SharpUnit.Environment Namespace


TestFailedEventArgs Properties

The properties of the TestFailedEventArgs class are listed below. For a complete list of TestFailedEventArgs class members, see the TestFailedEventArgs Members topic.

Public Instance Properties

ExceptionThrown
Test (inherited from TestEventArgs)

See Also

TestFailedEventArgs Class | ICSharpCode.SharpUnit.Environment Namespace


TestFailedEventArgs.ExceptionThrown Property

public System.Exception ExceptionThrown {get;}

See Also

TestFailedEventArgs Class | TestFailedEventArgs Members | ICSharpCode.SharpUnit.Environment Namespace


TestFailedEventHandler Delegate

public delegate void TestFailedEventHandler(
object sender,
TestFailedEventArgs e
);

Requirements

Namespace: ICSharpCode.SharpUnit.Environment Namespace

Assembly: ICSharpCode.SharpUnit.dll

See Also

ICSharpCode.SharpUnit.Environment Namespace


TestSuiteEventArgs Class

For a list of all members of this type, see TestSuiteEventArgs Members.

System.Object
EventArgs
TestSuiteEventArgs

public class TestSuiteEventArgs : EventArgs

Requirements

Namespace: ICSharpCode.SharpUnit.Environment Namespace

Assembly: ICSharpCode.SharpUnit.dll

See Also

TestSuiteEventArgs Members | ICSharpCode.SharpUnit.Environment Namespace


TestSuiteEventArgs Members

Public Instance Constructors

TestSuiteEventArgs Constructor

Public Instance Properties

TestSuite

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TestSuiteEventArgs Class | ICSharpCode.SharpUnit.Environment Namespace


TestSuiteEventArgs Constructor

public TestSuiteEventArgs(
ITestSuite testSuite
);

See Also

TestSuiteEventArgs Class | TestSuiteEventArgs Members | ICSharpCode.SharpUnit.Environment Namespace


TestSuiteEventArgs Properties

The properties of the TestSuiteEventArgs class are listed below. For a complete list of TestSuiteEventArgs class members, see the TestSuiteEventArgs Members topic.

Public Instance Properties

TestSuite

See Also

TestSuiteEventArgs Class | ICSharpCode.SharpUnit.Environment Namespace


TestSuiteEventArgs.TestSuite Property

public ITestSuite TestSuite {get;}

See Also

TestSuiteEventArgs Class | TestSuiteEventArgs Members | ICSharpCode.SharpUnit.Environment Namespace


TestSuiteEventHandler Delegate

public delegate void TestSuiteEventHandler(
object sender,
TestSuiteEventArgs e
);

Requirements

Namespace: ICSharpCode.SharpUnit.Environment Namespace

Assembly: ICSharpCode.SharpUnit.dll

See Also

ICSharpCode.SharpUnit.Environment Namespace


TestSuiteFailedEventArgs Class

For a list of all members of this type, see TestSuiteFailedEventArgs Members.

System.Object
EventArgs
TestSuiteEventArgs
TestSuiteFailedEventArgs

public class TestSuiteFailedEventArgs : TestSuiteEventArgs

Requirements

Namespace: ICSharpCode.SharpUnit.Environment Namespace

Assembly: ICSharpCode.SharpUnit.dll

See Also

TestSuiteFailedEventArgs Members | ICSharpCode.SharpUnit.Environment Namespace


TestSuiteFailedEventArgs Members

Public Instance Constructors

TestSuiteFailedEventArgs Constructor

Public Instance Properties

ExceptionThrown
TestSuite (inherited from TestSuiteEventArgs)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TestSuiteFailedEventArgs Class | ICSharpCode.SharpUnit.Environment Namespace


TestSuiteFailedEventArgs Constructor

public TestSuiteFailedEventArgs(
ITestSuite testSuite,
Exception exceptionThrown
);

See Also

TestSuiteFailedEventArgs Class | TestSuiteFailedEventArgs Members | ICSharpCode.SharpUnit.Environment Namespace


TestSuiteFailedEventArgs Properties

The properties of the TestSuiteFailedEventArgs class are listed below. For a complete list of TestSuiteFailedEventArgs class members, see the TestSuiteFailedEventArgs Members topic.

Public Instance Properties

ExceptionThrown
TestSuite (inherited from TestSuiteEventArgs)

See Also

TestSuiteFailedEventArgs Class | ICSharpCode.SharpUnit.Environment Namespace


TestSuiteFailedEventArgs.ExceptionThrown Property

public System.Exception ExceptionThrown {get;}

See Also

TestSuiteFailedEventArgs Class | TestSuiteFailedEventArgs Members | ICSharpCode.SharpUnit.Environment Namespace


TestSuiteFailedEventHandler Delegate

public delegate void TestSuiteFailedEventHandler(
object sender,
TestSuiteFailedEventArgs e
);

Requirements

Namespace: ICSharpCode.SharpUnit.Environment Namespace

Assembly: ICSharpCode.SharpUnit.dll

See Also

ICSharpCode.SharpUnit.Environment Namespace


UnloadTestSuitException Class

For a list of all members of this type, see UnloadTestSuitException Members.

System.Object
Exception
UnloadTestSuitException

public class UnloadTestSuitException : Exception

Requirements

Namespace: ICSharpCode.SharpUnit.Environment Namespace

Assembly: ICSharpCode.SharpUnit.dll

See Also

UnloadTestSuitException Members | ICSharpCode.SharpUnit.Environment Namespace


UnloadTestSuitException Members

Public Instance Constructors

UnloadTestSuitException Constructor

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UnloadTestSuitException Class | ICSharpCode.SharpUnit.Environment Namespace


UnloadTestSuitException Constructor

public UnloadTestSuitException(
ITestSuite suite,
Exception e
);

See Also

UnloadTestSuitException Class | UnloadTestSuitException Members | ICSharpCode.SharpUnit.Environment Namespace


XmlTestListener Class

For a list of all members of this type, see XmlTestListener Members.

System.Object
XmlTestListener

public class XmlTestListener

Requirements

Namespace: ICSharpCode.SharpUnit.Environment Namespace

Assembly: ICSharpCode.SharpUnit.dll

See Also

XmlTestListener Members | ICSharpCode.SharpUnit.Environment Namespace


XmlTestListener Members

Public Instance Constructors

XmlTestListener Constructor

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GenerateXmlDocument |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlTestListener Class | ICSharpCode.SharpUnit.Environment Namespace


XmlTestListener Constructor

public XmlTestListener(
ITestRunner testRunner
);

See Also

XmlTestListener Class | XmlTestListener Members | ICSharpCode.SharpUnit.Environment Namespace


XmlTestListener Methods

The methods of the XmlTestListener class are listed below. For a complete list of XmlTestListener class members, see the XmlTestListener Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GenerateXmlDocument |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlTestListener Class | ICSharpCode.SharpUnit.Environment Namespace


XmlTestListener.GenerateXmlDocument Method

public XmlDocument GenerateXmlDocument();

See Also

XmlTestListener Class | XmlTestListener Members | ICSharpCode.SharpUnit.Environment Namespace


XmlTestListener.TestInformationBase Class

For a list of all members of this type, see XmlTestListener.TestInformationBase Members.

System.Object
XmlTestListener.TestInformationBase

public class XmlTestListener.TestInformationBase

Requirements

Namespace: ICSharpCode.SharpUnit.Environment Namespace

Assembly: ICSharpCode.SharpUnit.dll

See Also

XmlTestListener.TestInformationBase Members | ICSharpCode.SharpUnit.Environment Namespace


XmlTestListener.TestInformationBase Members

Public Instance Constructors

XmlTestListener.TestInformationBase Constructor Initializes a new instance of the TestInformationBase class.

Public Instance Properties

Description
Milliseconds
Name
StartTime
Succeeded
TestsFailed
TestsRun
TestsSucceeded

Public Instance Methods

AssignAttributes |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
StopTime |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

description
dontGiveTestNumbers
milliseconds
name
startTime
testsFailed
testsSucceeded

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlTestListener.TestInformationBase Class | ICSharpCode.SharpUnit.Environment Namespace


XmlTestListener.TestInformationBase Constructor

Initializes a new instance of the TestInformationBase class.

public XmlTestListener.TestInformationBase();

See Also

XmlTestListener.TestInformationBase Class | XmlTestListener.TestInformationBase Members | ICSharpCode.SharpUnit.Environment Namespace


XmlTestListener.TestInformationBase Fields

The fields of the XmlTestListener.TestInformationBase class are listed below. For a complete list of XmlTestListener.TestInformationBase class members, see the XmlTestListener.TestInformationBase Members topic.

Protected Instance Fields

description
dontGiveTestNumbers
milliseconds
name
startTime
testsFailed
testsSucceeded

See Also

XmlTestListener.TestInformationBase Class | ICSharpCode.SharpUnit.Environment Namespace


XmlTestListener.TestInformationBase.Description Property

public string Description {get; set;}

See Also

XmlTestListener.TestInformationBase Class | XmlTestListener.TestInformationBase Members | ICSharpCode.SharpUnit.Environment Namespace


XmlTestListener.TestInformationBase.dontGiveTestNumbers Field

protected bool dontGiveTestNumbers;

See Also

XmlTestListener.TestInformationBase Class | XmlTestListener.TestInformationBase Members | ICSharpCode.SharpUnit.Environment Namespace


XmlTestListener.TestInformationBase.Milliseconds Property

public double Milliseconds {get;}

See Also

XmlTestListener.TestInformationBase Class | XmlTestListener.TestInformationBase Members | ICSharpCode.SharpUnit.Environment Namespace


XmlTestListener.TestInformationBase.Name Property

public string Name {get; set;}

See Also

XmlTestListener.TestInformationBase Class | XmlTestListener.TestInformationBase Members | ICSharpCode.SharpUnit.Environment Namespace


XmlTestListener.TestInformationBase.StartTime Property

public System.DateTime StartTime {get; set;}

See Also

XmlTestListener.TestInformationBase Class | XmlTestListener.TestInformationBase Members | ICSharpCode.SharpUnit.Environment Namespace


XmlTestListener.TestInformationBase.TestsFailed Property

public int TestsFailed {get; set;}

See Also

XmlTestListener.TestInformationBase Class | XmlTestListener.TestInformationBase Members | ICSharpCode.SharpUnit.Environment Namespace


XmlTestListener.TestInformationBase.TestsSucceeded Property

public int TestsSucceeded {get; set;}

See Also

XmlTestListener.TestInformationBase Class | XmlTestListener.TestInformationBase Members | ICSharpCode.SharpUnit.Environment Namespace


XmlTestListener.TestInformationBase Properties

The properties of the XmlTestListener.TestInformationBase class are listed below. For a complete list of XmlTestListener.TestInformationBase class members, see the XmlTestListener.TestInformationBase Members topic.

Public Instance Properties

Description
Milliseconds
Name
StartTime
Succeeded
TestsFailed
TestsRun
TestsSucceeded

See Also

XmlTestListener.TestInformationBase Class | ICSharpCode.SharpUnit.Environment Namespace


XmlTestListener.TestInformationBase.Succeeded Property

public bool Succeeded {get;}

See Also

XmlTestListener.TestInformationBase Class | XmlTestListener.TestInformationBase Members | ICSharpCode.SharpUnit.Environment Namespace


XmlTestListener.TestInformationBase.TestsRun Property

public int TestsRun {get;}

See Also

XmlTestListener.TestInformationBase Class | XmlTestListener.TestInformationBase Members | ICSharpCode.SharpUnit.Environment Namespace


XmlTestListener.TestInformationBase Methods

The methods of the XmlTestListener.TestInformationBase class are listed below. For a complete list of XmlTestListener.TestInformationBase class members, see the XmlTestListener.TestInformationBase Members topic.

Public Instance Methods

AssignAttributes |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
StopTime |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlTestListener.TestInformationBase Class | ICSharpCode.SharpUnit.Environment Namespace


XmlTestListener.TestInformationBase.AssignAttributes Method

public virtual void AssignAttributes(
XmlDocument doc,
XmlElement el
);

See Also

XmlTestListener.TestInformationBase Class | XmlTestListener.TestInformationBase Members | ICSharpCode.SharpUnit.Environment Namespace


XmlTestListener.TestInformationBase.StopTime Method

public void StopTime();

See Also

XmlTestListener.TestInformationBase Class | XmlTestListener.TestInformationBase Members | ICSharpCode.SharpUnit.Environment Namespace


ICSharpCode.SharpUnit.EnvironmentHierarchy

ICSharpCode.SharpUnit an Unit Testing Framework for .NET

ICSharpCode.SharpUnit.Environment Hierarchy

System.Object
-EventArgs
-TestAssemblyEventArgs
-TestEventArgs
-TestFailedEventArgs
-TestSuiteEventArgs
-TestSuiteFailedEventArgs
-Exception
-AssertionFailedException
-UnloadTestSuitException
-MarshalByRefObject
-AssemblyLister
-AssemblyLoader
-AssemblyLoaderDomain
-Assertion
-DefaultTest
-DefaultTestRunner
-DefaultTestSuite
-XmlTestListener
-TestInformationBase

Interfaces

ITest
ITestRunner
ITestSuite


ICSharpCode.SharpUnitHierarchy

ICSharpCode.SharpUnit an Unit Testing Framework for .NET

ICSharpCode.SharpUnit Hierarchy

System.Object
-Attribute
-ExceptExceptionAttribute
-TestAssemblyAttribute
-TestMethodAttribute
-TestSuiteAttribute
-Exception
-AssertionFailedException
-UnloadTestSuitException
-MarshalByRefObject
-AssemblyLister
-AssemblyLoader
-AssemblyLoaderDomain
-Assertion
-DefaultTest
-DefaultTestRunner
-DefaultTestSuite