Введение

Runpad Сервер предназначен для удаленного управления клиентскими машинами в компьютерных клубах и других организациях. Управляемые компьютеры должны работать под управлением операционных систем семейства Windows с установленной на них системой Runpad Shell.
Простой интерфейс, множество функций контроля и управления значительно облегчают работу администратора.
Сервер является опциональной пассивной утилитой. Это значит, что его наличие или отсутствие ни коим образом не влияет на работу Runpad Shell, за исключением функций, описанных в справке и доступных администратору.

Для установки или же обновления сервера следует загрузить файл установки с официального сайта Runpad Shell, запустить его и выбрать конфигурацию установки "Серверная часть".


Начало работы

При первом запуске программа попросит Вас ввести пароль администратора сервера. Этот пароль будет использоваться в дальнейшем для настройки и полного доступа ко всему функционалу сервера.

Внимание! При утере пароля восстановить его будет невозможно.

После ввода пароля Runpad Cервер запустится в режиме администратора.
Выберите пункт меню "Настройки"->"Доступ к функциям" и установите те функции, которые должны быть доступны при входе без пароля (режим оператора компьютерного клуба).
После того, как все настройки сделаны, выберите пункт меню "Настройки"->"Режим администратора" чтобы выйти из режима администратора в режим оператора.

В следующий раз программа запустится в режиме оператора. Чтобы вновь войти в режим администратора, следует выбрать пункт меню "Настройки"->"Режим администратора" и ввести пароль.


Главное окно

Окно программы снабжено элементами управления машинами клуба и настройками сервера. К ним относятся:

1. Основное меню программы.
2. Выпадающий список клубов/залов. Здесь можно выбрать текущий клуб/зал, машины из которого будут отображены в списке машин.
3. Список машин. Отображает список доступных машин в клубе. Здесь можно выбрать одну или несколько (с зажатыми клавишами Shift или Crtl) машин, с которыми будут производиться операции.
4. Панель закладок с функциями. Для того, чтобы выбрать какую-либо закладку (группу функций), щелкните по кнопке с ее именем. На самой закладке представлены функции, которые можно произвести над выбранными в списке машинами.


Настройки

Настройка клубов/залов

Выберите пункт меню "Настройки"->"Клубы/залы..."
Появится окно со списком всех клубов/залов. Используйте контекстное меню для того, чтобы добавить, удалить, или же переименовать имеющийся клуб/зал. По окончании работы с клубами/залами закройте окно. Все имеющиеся клубы/залы будут доступны через выпадающий список на главном окне программы.

Данная функция может быть запрещена администратором сервера.

Настройка IP-адресов

Используйте контекстное меню в списке машин для установки IP-адресов машин. При выборе пунктов меню "Добавить машину" или "Изменить машину" будет отображено окно свойств машины, где необходимо указать IP-адрес машины. Также здесь можно установить комментарий к машине, который будет отображаться рядом с машиной в списке машин.

Функции манипулирования IP-адресами могут быть запрещены администратором сервера.

Импорт/экспорт настроек

Все настройки сервера можно сохранить для последующего их восстановления или же переноса на другую машину.
Выберите соответсвующий пункт в меню "Настройки". После этого Вам будет предложено указать путь к файлу с настройками.
Внимание: после импорта настроек сервер потребуется перезапустить.

Функции импорта/экспорта настроек могут быть запрещены администратором сервера.


Функции

Перезагрузить/Выключить машину/Завершить сеанс/Отключить шелл

Производят соответствующие действия на выбранных машинах. Для выполнения некоторых из этих функций потребуется ввести пароль администратора шелла выбранных машин.

Данные функции могут быть запрещены администратором сервера.
Снять все задачи

Снимает задачи на выбранных машинах (только те задачи, которые были запущены пользователем).

Данная функция может быть запрещена администратором сервера.
Выполнить

Запускает на выбранных клиентских машинах указанную программу. Введите имя программы с указанием пути, если необходимо, и нажмите Enter. Для выполнения этой функции также потребуется ввести пароль администратора шелла выбранных машин.

Данная функция может быть запрещена администратором сервера.
Администратор/Пользователь

Переводит шелл на выбранных машинах в режим администратора либо пользователя. Для перехода в режим администратора необходимо ввести пароль администратора шелла выбранных машин.

Данная функция может быть запрещена администратором сервера.
Включить/Выключить монитор

Включает/выключает монитор на выбранных машинах.

Данная функция может быть запрещена администратором сервера.
Послать сообщение

Позволяет отправить пользователям выбранных машин произвольное сообщение. Введите текст сообщения и нажмите Enter.

Данная функция может быть запрещена администратором сервера.
Статистика запуска

Позволяет посмотреть, какие программы и сколько раз были запущены на выбранной машине.
Эта функция может быть применена только к одной машине.

Данная функция может быть запрещена администратором сервера.
Общие сведения

Позволяет посмотреть различную информацию о выбранных машинах, такую как: версия шелла, версия установленной операционной системы, свободное пространство на жестких дисках и др., а также некоторые сведения об оборудовании выбранных машин - название видео адаптера, название сетевого адаптера, тип процессора.

Данная функция может быть запрещена администратором сервера.
Контроль оборудования

Позволяет посмотреть информацию об изменениях в составе оборудования выбранных машин за последние 7 дней.

Данная функция может быть запрещена администратором сервера.
Свободное место

Позволяет узнать, сколько свободного пространства осталось на жестком диске выбранной машины.
Эта функция может быть применена только к одной машине.

Данная функция может быть запрещена администратором сервера.
Экран пользователя

Позволяет посмотреть на рабочий стол выбранной машины в данный момент времени.
Эта функция может быть применена только к одной машине.

Данная функция может быть запрещена администратором сервера.
Синхронизация времени

Устанавливает системное время всех выбранных машин как на машине, на которой запущен сервер.

Данная функция может быть запрещена администратором сервера.
Смена пароля шелла

Позволяет сменить пароль администратора шелла выбранных машин. Вам будет предложено ввести старый пароль администратора шелла, после чего Вы сможете установить новый пароль. Внимание: правильность пароля сервером не проверяется!

Данная функция может быть запрещена администратором сервера.
Обновить шелл

Скачайте файл обновления шелла с официального сайта Runpad Shell и разместите его на сетевом ресурсе. После этого выберите данную функцию и укажите путь к файлу обновления шелла.

Сетевой ресурс должен быть доступен выбранным машинам по чтению. При успешном обновлении клиентская машина должна перезагрузиться 2 раза (рекомендуется использовать AutoLogon).
Данная функция может быть запрещена администратором сервера.
Импорт настроек шелла

Экспортируйте файл настроек шелла при помощи функции экспорта настроек на одной из клиентских машин и разместите его на сетевом ресурсе. После этого выберите данную функцию и укажите путь к файлу.

Сетевой ресурс должен быть доступен выбранным машинам по чтению. При успешном обновлении произойдет перезагрузка клиенской машины.
Данная функция может быть запрещена администратором сервера.
Копировать файлы клиентам

Перепешите на сетевой ресурс файлы, которые необходимо скопировать. После этого выберите данную функцию. Введите путь, куда следует скопировать файлы (путь задается для клиентской машины). На тех машинах, где этого пути не окажется, будет предпринята попытка его создать. Затем укажите путь к сетевому ресурсу, где Вы расположили файлы.
Для того, чтобы предотвратить блокировку замещаемых файлов процессами, эта функция может быть совмещена с функцией "Снять все задачи".

Сетевой ресурс должен быть доступен выбранным машинам по чтению.
Данная функция может быть запрещена администратором сервера.
Удалить файлы

Удаляет предварительно выбранные файлы на клиентских машинах. Указать, какие файлы подлежат удалению, необходимо заблаговременно в настройках шелла на каждой клиентской машине (см. вкалдку "удаление").
Для того, чтобы предотвратить блокировку удаляемых файлов процессами, эта функция может быть совмещена с функцией "Снять все задачи".

Данная функция может быть запрещена администратором сервера.


Вопросы и ответы (FAQ)

Вопрос: имеет ли сервер ограничения в демо-версии?
Ответ: не имеет, ограничения имеет лишь шелл

Вопрос: есть ли в сервере авто-обновление?
Ответ: нет, автоматическое обновление есть только в шелле, сервер нужно обновлять вручную

Вопрос: могут ли клиентские машины работать без сервера?
Ответ: могут, сервер является пассивным

Вопрос: что означает голубой цвет иконок машин? значит - машина в сети?
Ответ: нет, сервер не контролирует подключение машин к сети, цвет является постоянным

Вопрос: что означает красный цвет логотипа Runpad?
Ответ: логотип имеет голубой цвет в режиме оператора и становится красным в режиме администратора

Вопрос: пароль администратора сервера должен отличаться от пароля шелла?
Ответ: это два совершенно разных пароля, которые в частном случае могут быть одинаковы

Вопрос: почему команды от сервера иногда не срабатывают с первого раза?
Ответ: это может происходить из-за чрезмерной загрузки сети

Вопрос: можно ли в настройках сервера указать динамические IP-адреса, если клиентские машины имеют постоянные адреса?
Ответ: можно, но делать так не рекомендуется

Вопрос: в сервере можно указывать постоянные IP-адреса машин или же сделать их динамическими - какой подход лучше?
Ответ: лучше указывать постоянные IP-адреса: надежность обмена данными с клиентскими машинами в этом случае выше

Вопрос: можно ли совместно использовать шелл и сервер на одной машине?
Ответ: да, можно


Лицензионное соглашение

ЛИЦЕНЗИОННОЕ СОГЛАШЕНИЕ
Настоящее лицензионное соглашение заключается между вами (пользователь) и NodaSoft (NS) относительно Runpad Shell (c) NodaSoft, представляющего собой программу для PC и предназначенную для использования в семействе операционных систем Windows как аналога Explorer Microsoft, адаптированного для использования в компьютерных клубах. Программа Runpad Shell поставляется по принципу "AS IS", т.е. "как есть", следовательно никаких гарантий не прилагается и не предусматривается. Вы используете это программное обеспечение на свой риск. Авторы не будут отвечать ни за какие потери или искажения данных, любую упущенную выгоду в процессе использования или неправильного использования этого программного обеспечения.
Программа Runpad Shell является собственностью NodaSoft. Несмотря на то, что NS сохраняет права собственности на программу Runpad Shell, Вы, приняв лицензионное соглашение, будете иметь определенные права на его использование. Программа Runpad Shell защищена законами и международными соглашениями об авторских правах, а также другими законами и договорами, регулирующими отношения в области авторских прав.
По данному соглашению NS обязуется передать право пользование программой Runpad Shell. Для получения такого права требуется следующее:
- согласие с условиями лицензионного соглашения;
- перечисление установленной платы за право пользования по указанным реквизитам.
Более подробно о способе оплаты можно узнать из документации к программе.

Настоящее лицензионное соглашение предоставляет вам следующие права:
- разрешается установить и использовать несколько копий Runpad Shell на нескольких компьютерах (в зависимости от приобретенной лицензии);
- право бесплатной технической поддержки;
- право бесплатного обновления Runpad Shell;
- сделать одну копию программы для архивного хранения.

Вы не имеете права:
- сублицензировать, сдавать в аренду или временное пользование программу Runpad Shell без разрешения NS;
- изменять алгоритм, декомпилировать, деассемблировать, модифицировать, переводить или предпринимать какие-либо попытки выявить исходный код программы, либо закладывать ее в основу своих разработок, целью которых является извлечение прибыли;
- требовать оплату за распространение программы Runpad Shell;
- включать Runpad Shell в состав любых других программных продуктов.

Вне зависимости от того, достигнуты ли изложенными здесь средствами поставленные цели, NS не несет ответственности за прямой, косвенный или другие виды ущерба, в т.ч. упущенную выгоду или потерю данных вследствие использования или невозможности использования программы Runpad Shell, даже в том случае, если NS и был поставлен в известность относительно возможности нанесения такого ущерба.
Ни в коем случае ответственность NS не может превышать стоимости программы Runpad Shell.

NodaSoft НЕ ГАРАНТИРУЕТ БЕЗУПРЕЧНОЙ РАБОТЫ ПРОГРАММЫ RUNPAD SHELL. ПРОГРАММА RUNPAD SHELL НЕ РАЗРАБАТЫВАЛАСЬ, НЕ ПРОИЗВОДИЛАСЬ И НЕ ПРЕДНАЗНАЧЕНА ДЛЯ ИСПОЛЬЗОВАНИЯ В РЕЖИМЕ РЕАЛЬНОГО ВРЕМЕНИ ДЛЯ УПРАВЛЕНИЯ ОПАСНЫМ ОБОРУДОВАНИЕМ, НАПРИМЕР, СИСТЕМАМИ УПРАВЛЕНИЯ ЯДЕРНЫМИ УСТАНОВКАМИ, РАДИОНАВИГАЦИОННЫМ ОБОРУДОВАНИЕМ ИЛИ СИСТЕМАМИ СВЯЗИ, АВИАДИСПЕТЧЕРСКИМ ОБОРУДОВАНИЕМ, МЕДИЦИНСКИМИ СИСТЕМАМИ ЖИЗНЕОБЕСПЕЧЕНИЯ ИЛИ ВОЕННЫМ ОБОРУДОВАНИЕМ, А ТАКЖЕ ДРУГИМ ОБОРУДОВАНИЕМ ИЛИ СИСТЕМАМИ, ДЛЯ КОТОРЫХ ОТКАЗ В РАБОТЕ ПРОГРАММЫ RUNPAD SHELL МОЖЕТ ПРИВЕСТИ К ГИБЕЛИ ЛЮДЕЙ, ТРАВМАМ, АВАРИЯМ ИЛИ НАНЕСТИ ВРЕД ОКРУЖАЮЩЕЙ СРЕДЕ.

Приведенные выше отказ от ответственности и ее ограничения действительны вне зависимости от того, принята ли Вами программа Runpad Shell.
Владельцам сайтов и составителям сборников условно-бесплатного программного обеспечения разрешается размещение на своих носителях немодифицированного инсталяционного архива программы Runpad Shell, с предварительного согласия его разработчиков.
В любом случае NS передает Вам программу Runpad Shell, только если Вы принимаете все условия настоящего лицензионного соглашения.

Runpad Shell © 2002-2005 NodaSoft.
www.runpad-shell.com


Форум

Форум Runpad Shell доступен с ограниченными возможностями всем желающим, а с полными - только официальным покупателям.

Для входа в форум перейдите по ссылке:
Войти

Для перехода в группу "официальные пользователи Runpad Shell" пользователь, легально купивший ПО, должен зарегистрироваться в форуме обычным способом и прислать в службу поддержки следующие данные:
1) Свой созданный ник в форуме
2) Регистрационные данные, которые были использованы при приобретении Runpad Shell (ФИО/Город/Клуб/e-mail)
3) Свой реальный e-mail, на который будет дан ответ
4) Лицензионный ключ Runpad Shell, выданный при регистрации
После чего в течении одного рабочего дня, пользователь будет внесен в список официальных пользователей, о чем будет уведомлен по e-mail.

Также по желанию, пользователь может получить пароль для входа в "Директорскую" форума.


Поддержка

Служба технической поддержки:
support@runpad-shell.com

Вопросы, связанные с оплатой:
billing@runpad-shell.com

Общие вопросы:
info@runpad-shell.com

Контактные телефоны:
+48 (50)3639919 (Польша)
+38 (097)9988634 (Украина)
+7 (095)5107685 (Россия) - только по вопросам оплаты

Информационная и техническая поддержка осуществляется с понедельника по пятницу
с 9:00 до 17:00 по среднеевропейскому времени (GMT+01)

Сайт Runpad Shell:
www.runpad-shell.com

Сайт NodaSoft:
www.nodasoft.com

Форум Runpad Shell:
Узнать больше