Untitled Document

Описание

Спасибо за использование Magic HTML Editor 1.0

Magic HTML Studio 1.0 - профессиональная среда разработки HTML страниц. Программа имеет интуитивно понятный графический многодокументный интерфейс, удобные панели навигации сделают работы очень быстрой и увлекательной. В состав программы входит Java конструктор, который позволит создать различные эффекты на базе Java скриптов, причём для создания скрипта необходимо лишь ввести его параметры, и программа создаст скрипт сама. Также в состав программы входит генератор CGI скриптов, при помощи которого можно создать конференцию, гостевую книгу или чат всего за один щелчок мыши, предварительно установив параметры скрипта. Magic HTML Studio 1.0 позволяет быстро отредактировать HTML страницу, вставить скрипт загрузки Flash, который необходим для корректной загрузки страниц, созданных с использованием технологии Flash, а также многое другое.

AG FreeSoft.


Установка программы

Для установки программы запустите файл MagicHTMLStudio.exe и следуйте инструкциям программы установки.


Запуск программы

Для запуска программы необходимо выбрать соотвествующий пункт меню

Пуск --> Программы --> AG FreeSoft Programs --> Magic HTML Studio --> Magic HTML Studio v.1.0

После заставки появиться главное окно программы


Меню File

1.0 Меню File

1.1 New - команда создания нового документа.

1.2 Open - команда открытия документа.

1.3 Save - команда сохранения документа.

1.4 Save As - команда сохранения документа под другим названием.

1.5 Close - команда закрытия активного документа.

1.6 Close All - команда закрытия всех открытых документов.

1.7 Preview - команда просмотра документа в окне браузера программы.

1.8 Print - команда печати документа.

1.9 Exit - команда выхода из программы.


Меню Edit

2.0 Меню Edit

2.1 Undo - команда отмены действия (позволяет отменить все действия)

2.2 Redo - команда повтора действия (позволяет повторить все действия)

2.3 Cut - команда удаляет текст в буфер обмена.

2.4 Copy - команда копирует текст в буфер обмена.

2.5 Paste - команда вставляет содержимое буфера обмена в активный документ.

2.6 Select All - команда выделяет всё содержимое документа.

2.7 Select Case - команда изменения регистра.

2.8 Find - команда поиска.

2.9 Replace - команда замены.


Меню Tools

3.0 Меню Tools

3.1 Insert Image - команда добавления изображения в документ.

3.2 Page Setup- команда загрузки параметров.

3.3 Java Constructor - команда вызова Java Constructor-а.

3.4 CGI QuickBuilder - команда вызова CGI QuickBuilder.


Меню Options

4.0 Меню Options

4.1 Java Script for Load Flash - команда добавления скрипта, загружающего специальный компонент для корректного отображения страниц, изготовленных с использованием технологии Flash.

4.2 Elements Editor - команда вызова Elements Editor (редактора элементов).

4.3 Change font - команда смены шрифта.

4.4 Insert form - команда добавления формы.


Меню View

5.0 Меню View

5.1 Center Panel - команда отключения центральной панели нструментов.

5.2 Left Navigation Panel - команда отключения левой навигационной панели.

5.3 Right Navigation Panel - команда отключения правой навигационной панели.

5.4 Information Panel - команда отключения строки состояния.


Меню Font Size

6.0 Меню Font Size

6.1 H1 - команда добавления тега <h1></h1>

6.2 H2 - команда добавления тега <h2></h2>

6.3 H3 - команда добавления тега <h3></h3>

6.4 H4 - команда добавления тега <h4></h4>

6.5 H5 - команда добавления тега <h5></h5>

6.6 H6 - команда добавления тега <h6></h6>

6.7 H7 - команда добавления тега <h7></h7>

6.8 Other Size - команда вызова окна Other Size


Меню Font Color

7.0 Меню Font Color

7.1 Black - команда добавления тега <font color="black"></font>.

7.2 Red - команда добавления тега <font color="red"></font>.

7.3 Green - команда добавления тега <font color="green"></font>.

7.4 Yellow - команда добавления тега <font color="yellow"></font>.

7.5 Blue - команда добавления тега <font color="blue"></font>.

7.6 Magenta - команда добавления тега <font color="magenta"></font>.

7.7 Brown - команда добавления тега <font color="brown"></font>.

7.8 Cyan - команда добавления тега <font color="cyan"></font>.

7.9 White - команда добавления тега <font color="white"></font>.

7.10 Blue Violet - команда добавления тега <font color=#9F5F9F></font>.

7.11 Dark Brown - команда добавления тега <font color=#5C4033></font>.

7.12 Darl Green - команда добавления тега <font color=#2F4F2F></font>.

7.13 Dark Purple - команда добавления тега <font color=#871F78></font>.

7.18 Tan - команда добавления тега <font color="tan"></font>.

7.19 Orange - команда добавления тега <font color="orange"></font>.

7.20 Gold - команда добавления тега <font color="gold"></font>.

7.21 Other Color - команда вызова окна выбора цвета.


Меню Font Style And Position

8.0 Меню Font Style And Position

8.1 Left - команда добавления тега <left></left>.

8.2 Center - команда добавления тега <center></center>.

8.3 Right - команда добавления тега <right></right>.

8.4 Bold - команда добавления тега <b></b>.

8.5 Underline - команда добавления тега <u></u>.

8.6 Italic - команда добавления тега <i></i>.

8.7 Strong - команда добавления тега <strong></strong>.

8.8 Blinking - команда добавления тега <blink></blink>.

8.9 Citation - команда добавления тега <cite></cite>.

8.10 Typewriter - команда добавления тега <pre></pre>.

8.11 Strikethrough - команда добавления тега <strike></strike>.


Меню Other Tags

9.0 Меню Other Tags

9.1 BR - команда добавления тега <BR>.

9.2 P - команда добавления тега <P>.

9.3 HR - команда добавления тега <HR>.

9.4 <!--> - команда добавления тега <!-->.

9.5 End - команда добавления тега </BODY></HTML>.

9.6 Add Link- команда добавления ссылки.

9.7 Add E-mail - команда добавления ссылки электронной почты.


Меню Window

10.0 Меню Window

10.1 Tile Horizontally - команда расположения окон по горизонтали.

10.2 Tile Vertically - команда расположения окон по вертикали.

10.3 Cascade - команда расположения окон каскадом.

10.4 Arrange Icons - команда выстраивания значков.

10.5 Minimaze All - команда минимизации всех окон.


Меню Help

11.0 Меню Help

11.1 User's Guide - руководство пользователя.

11.2 Web-site - команда посещения сайта AG FreeSoft.

11.3 Send Mail - команда отправки электронного письма разработчику.

11.4 About - команда показывает сведения о разработчике.


Описание центральной панели инструментов

Все нижеперечисленные команды аналогичны соответствующим командам основного меню программы.

Кнопки панели инструментов перечисляются слева направо.

1. New.

2. Open.

3. Close.

4. Close All.

5. Save.

6. Save As.

7. Preview.

8. Print.

10. Undo .

11. Redo.

12. Cut.

13. Copy.

14. Paste.

15. Select All.

16. Select Case.

17. Insert Image.

18. Page Setup.

19. Java Constructor.

20. CGI QuickBuilder.

21. Java Script for Flash Load.

22. Elements Editor.

23. Change Font.

24. User's Guide.

25. Web-site.

26. Send Mail.

27. About .


Описание навигационных панелей.

Все нижеперечисленные кнопки навигационных панелей аналогичны соответствующим командам основного меню программы и выполняют такие же функции.


Использование программы.

Операции с меню File.

С помощью меню File можно производить операции открытия, создания, сохранения, закрытия документов, а также операции печати и предварительного просмотра.

Открытие документа.

Для открытия документа необходимо выбрать команду меню

File-->Open, в появившемся окне выбрать открываемый документ,

либо нажать кнопку Open на панели инструментов.

Создание нового документа.

Для создания нового документа необходимо выбрать команду меню

File-->New

либо нажать кнопку New на панели инструментов.

Закрытие активного документа.

Для закрытия активного документа необходимо выбрать команду меню

File-->Close

либо нажать кнопку Close на панели инструментов.

Закрытие всех документов.

Для закрытия всех документов необходимо выбрать команду меню

File-->Close All

либо нажать кнопку Close All на панели инструментов.

Сохранение документа.

Для сохранения документа необходимо выбрать команду меню

File-->Save (либо нажать кнопку Save на панели инструментов),

в появившемся окне ввести название сохраняемого документа.

Сохранение документа под другим именем.

Для сохранения документа под другим именем необходимо выбрать команду меню

File-->Save As (либо нажать кнопку Save As на панели инструментов),

в появившемся окне ввести название сохраняемого документа.

Предварительный просмотр дкумента.

Для преварительного просмотра документа необходимо выбрать команду меню

File-->Preview

либо нажать кнопку Preview на панели инструментов.

Печать документа.

Для печати документа необходимо выбрать команду меню

File-->Print

либо нажать кнопку Print на панели инструментов.

Выход из программы.

Для выхода из программы необходимо выбрать команду меню

File-->Exit

либо нажать кнопку Exit на панели инструментов.


Использование программы.

Операции с меню Edit.

С помощью меню Edit можно производить операции отмены действия, повтора действия, копирования, вырезания и добавления фрагментов документа, изменения регистра, а также операции поиска и замены.

Отмена действия.

Для отмены действия необходимо выбрать команду меню

Edit-->Undo

либо нажать кнопку Undo на панели инструментов.

Повтор действия .

Для повтора действия необходимо выбрать команду меню

Edit-->Redo

либо нажать кнопку Redo на панели инструментов.

Копирование.

Для копирования фрагмента документа необходимо выделить фрагмент при помощи мыши и выбрать команду меню

Edit-->Copy

либо нажать кнопку Copy на панели инструментов.

Вырезание.

Для вырезания фрагмента документа необходимо выделить фрагмент и выбрать команду меню

Edit-->Cut

либо нажать кнопку Cut на панели инструментов.

Вставить.

Для добавления фрагмента документа необходимо выбрать команду меню

Edit-->Paste

либо нажать кнопку Paste на панели инструментов.

Выделить всё.

Для выделения всего документа необходимо выбрать команду меню

Edit-->Select All

либо нажать кнопку Select All на панели инструментов.

Изменить регистр.

Для изменения регистра документа необходимо выбрать пункт меню

Edit-->Select Case (либо нажать кнопку Select Case на панели инструментов),

в появившемся окне выберите регистр (Upper Case - верхний регистр, Lower Case - нижний регистр).

Найти.

Для поиска нужного фрагмента необходимо выбрать команду меню

Edit-->Find (либо нажать кнопку Find на панели инструментов),

в появившемся окне Find&Replace ввести в поле Find искомый текст, и нажать кнопку Find. Если требуется произвести поиск с учётом регистра, то установите флажок Match Case. Если требуется произвести точный поиск слова, то необходимо установить флажок Find Whole Word Only.

Заменить.

Для замены нужного фрагмента необходимо выбрать команду меню

Edit-->Replace (либо нажать кнопку Replace на панели инструментов),

в появившемся окне Find&Replace ввести в поле Find текст, который требуется заменить, в поле Replace - новый текст (т.е на который будет заменён фрагмент, введённый в поле Find). Если требуется произвести поиск с учётом регистра, то установите флажок Match Case. Если требуется произвести точный поиск слова, то необходимо установить флажок Find Whole Word Only.


Использование программы.

Операции с меню Tools.

С помощью меню Tools можно производить операции добавления изображения, загрузки параметров документа,а также операции вызова конструктора Java скриптов и CGI QuickBuilder'а.

Добавление изображения.

Для добавления изображения необходимо выбрать команду меню

Tools-->Insert Image (либо нажать кнопку Insert Image на панели инструментов),

в появившемся окне в поле Image при помощи кнопки выбора (или вручную) введите имя и путь к изображению, затем нажмите кнопку OK.

Установка параметров документа.

Для загрузки параметров необходимо выбрать команду меню

Tools-->Page Setup (либо нажать кнопку Page Setup на панели инструментов),

в появившемся окне в поле Text Color введите цвет текста, в поле Link Color введите цвет ссылок, в поле Visited Link Color введите цвет посещённых ссылок, в поле Active Link Color введите цвет активных ссылок, в поле Background Color введите цвет фона, в поле Background Picture введите путь к изображению (вручную или при помощи кнопки выбора), в поле Title введите заголовок документа, и нажмите кнопку OK.

Работа с конструктором Java скриптов и конструктором CGI скриптов рассмотрена в отдельной главе Создание скриптов.


Использование программы.

Операции с меню Options.

С помощью меню Options можно производить операции добавления скрипта загрузки Flash, вызова редактора элементов, а также операции смены шрифта и добавления формы.

Добавление скрипта загрузки Flash.

Для добавления скрипта загрузки Flash необходимо выбрать команду меню

Options--> Java Script for Load Flash (либо нажать кнопку Java Script for Load Flash на панели инструментов).

Работа с редактором элементов.

Для вызова редактора элементов необходимо выбрать команду меню

Options--> Elements Editor (либо нажать кнопку Elements Editor на панели инструментов),

после этого появиться окно редактора:

1. Создание текстового поля.

Для создания текстового поля необходимо открыть вкладку Text Filed редактора элементов Elements Editor, в поле Name ввести имя текстового поля, в поле Size ввести размер поля, в поле Max Chars ввести максимальное количество символов в текстовом поле, в поле Value ввести текст, отображаемый в поле, и выбрать тип поля в списке Type - text - текстовый, или password - поле со звёздочками вместо символов. Затем нажмите кнопку Add.

2. Создание кнопки.

Для создания кнопки откройте вкладку Button редактора элементов Elements Editor,

в поле Name введите имя кнопки, в поле Label - надпись на кнопке, в поле Action задайте тип кнопки. Затем нажмите кнопку Add.

3. Создание кнопки-флажка.

Для создания кнопки откройте вкладку Check Box редактора элементов Elements Editor,

в поле Name введите имя кнопки, в поле Value - значение, в поле Initial State задайте состояние флажка - checked - флажок установлен, или же пропуск - флажок отсутствует. Затем нажмите кнопку Add.

4. Создание радиокнопки.

Для создания радиокнопки откройте вкладку Radio Button редактора элементов Elements Editor,

в поле Name введите имя кнопки, в поле Value - значение, в поле Initial State задайте состояние кнопку - checked - включено, или же пропуск - выключено. Затем нажмите кнопку Add.

5. Создание меню.

Для создания меню откройте вкладку Меню редактора элементов Elements Editor,

в поле Name введите имя меню, в поле Value - значение, в поле Item Label введите строку меню, после чего нажмите кнопку Add srings, добавляющую пункт меню. Затем нажмите кнопку Add.

6. Создание поля выбора файлов.

Для создания поля выбора файлов откройте вкладку File Field редактора элементов Elements Editor,

в поле Name введите имя поля, в поле Size - размер, в поле Max Chars введите максимально допустимое количество символов, после чего нажмите кнопку Add.

7. Создание скрытого поля.

Для создания скрытого поляоткройте вкладку Hidden Files редактора Elements Editor,

в поле Name введите имя поля, в поле Value - значение. Затем нажмите кнопку Add.

Смена шрифта.

Для изменения шрифта необходимо выбрать команду меню

Options--> Change Font (либо нажать кнопку Change Font на панели инструментов),

после чего в открывшемся окне выберте параметры шрифта.

Добавление формы.

Для добавления формы необходимо выбрать команду меню

Options--> Insert Form (либо нажать кнопку Insert Form на панели инструментов),

после чего в активный документ будет добавлен соотвествующий тег.


Использование программы.

Операции с меню View.

С помощью меню View можно управлять навигационными панели и панелью инструментов.

Центральная панель инструментов.

Для отключения панели инструментов установите флажок View--> Central Panel, для включения уберите флажок.

Левая навигационная панель.

Для отключения левой навигационной панели установите флажок View--> Left Navigation Panel, для включения уберите флажок.

Правая навигационная панель.

Для отключения левой навигационной панели установите флажок View--> Right Navigation Panel, для включения уберите флажок.

Строка состояния.

Для отключения строки состояния установите флажок View--> Information Panel, для включения уберите флажок.


Использование программы.

Операции с меню Font Size.

С помощью меню Font Size можно управлять размером шрифта.

Выбор команды меню (c H1 по H7) обеспечивает добавление соответствующего тега (см. Описание меню Font Size).

Выбор команды Other Size вызывает окно установки других размеров шрифта:

В поле Font Size введите размер шрифта и нажмите OK.


Использование программы.

Операции с меню Font Color.

С помощью меню Font Size можно управлять цветом шрифта.

Выбор команды меню (c Red по Gold) обеспечивает добавление соответствующего тега (см. Описание меню Font Color).

Выбор команды Other Color вызывает окно установки других цветов шрифта:

Можно установить цвет движками R,G,B , можно ввести Hex значение в поле Color Code (вводите только те значения, которые применяются в HTML). Также цвет можно выбрать кнопкой Choose, открывающей стандартное окно выбора цвета.После этого нажмите кнопку OK.


Использование программы.

Операции с меню Font Style And Position.

С помощью меню Font Style And Position можно управлять позицией и стилем шрифта.

Выбор команды меню Font Style And Position добавляет в документ соответствующий тег (см. Описание меню Font Style And Position)


Использование программы.

Операции с меню Window.

С помощью меню Window можно организовывать положение окон.

Расположение окон по горизонтали.

Для расположения окон по горизонтали необходимо выбрать команду меню

Window--> Tile Horizontally.

Расположение окон по вертикали.

Для расположения окон по вертикали необходимо выбрать команду меню

Window--> Tile Vertically.

Расположение окон каскадом.

Для расположения окон каскадом необходимо выбрать команду меню

Window--> Cascade.

Только значки.

Для включения режима необходимо выбрать команду меню

Window--> Arrange Icons.

Минимизация всех окон.

Для минимизации всех окон по горизонтали необходимо выбрать команду меню

Window--> Tile Horizontally.


Использование программы.

Операции с меню Help.

С помощью меню Help можно вызвать руководство пользователя, посетить сайт AG FreeSoft, написать нам письмо, и посмотреть сведения о разработчике.

Просмотр руководства пользователя.

Для просмотра руководства пользователя необходимо выбрать команду меню

Help--> User's Guide.

Посетить сайт .

Для посещения сайта необходимо выбрать команду меню

Help--> Web-site .

Написать письмо .

Для написания и отправки письма необходимо выбрать команду меню

Help--> Send E-mail.

Посмотреть сведения о разработчике.

Для просмотра сведений о разработчике необходимо выбрать команду меню

Help--> About.

Минимизация всех окон.

Для минимизации всех окон по горизонтали необходимо выбрать команду меню

Window--> Tile Horizontally.


Использование программы.

Создание Java скриптов.

Дата и время

Создание Java скриптов с использованием Magic HTML Studio превращается в увлекательное и интересное занятие.

Создание цифровых часов.

Для создания скрипта необходимо выбрать команду меню

Tools--> Java Constructor (или нажмите кнопку Java Constructor на панели инструментов),

после чего появиться окно конструктора

Выберите вкладку Date&Time, затем вкладку Digital Clock, выберите цвет часов, нажав одну из кнопок выбора цвета (Choose clock color), затем в поле Table Border введите размер бордюра, в поле Width ширину, в поле Height - высоту, в поле Background color - цвет фона, в списке Align выберите позицию часов, и нажмите кнопку Create Script. Выберите директорию, в которой вы хотите сохранить файл и ресурсы для хранения скрипта, и нажмите OK. Скрипт будет создан. Для предпросмотра нажмите Preview. Внимание: изменяя поля с данными в кавычках, кавычки не убирайте!

Создание текстовых часов и даты.

Для создания скрипта необходимо выбрать команду меню

Tools--> Java Constructor (или нажмите кнопку Java Constructor на панели инструментов),

после чего появиться окно конструктора

Выберите вкладку Date&Time, затем вкладку Text Date&Clock, в поле Font size введите размер шрифта, в поле Font face введите название шрифта, в поле Font Color введите цвет шрифта, в поле Clock position введите позицию шрифта, и нажмите кнопку Create script. Выберите директорию, в которой вы хотите сохранить файл и ресурсы для хранения скрипта, и нажмите OK. Скрипт будет создан. Для предпросмотра нажмите Preview. Внимание: изменяя поля с данными в кавычках, кавычки не убирайте!

Создание календаря.

Для создания скрипта необходимо выбрать команду меню

Tools--> Java Constructor (или нажмите кнопку Java Constructor на панели инструментов),

после чего появиться окно конструктора

Выберите вкладку Date&Time, затем вкладку Calendar, в поле Header Height введите высоту заголовка, в поле Border - размер бордюра, в поле Header Color введите цвет заголовка, в поле Header Size введите размер шрифта заголовка, в поле Col Width введите размер колонки, в поле Day CellHeight - высоту колонок для отображения дней, в поле Day Color - цвет дней, в поле Сell Height - высоту колонок, в поле Today Color - цвет сегодняшнего числа, в поле Time Color - цвет времени, и нажмите кнопку Create script. Выберите директорию, в которой вы хотите сохранить файл и ресурсы для хранения скрипта, и нажмите OK. Скрипт будет создан. Для предпросмотра нажмите Preview. Внимание: изменяя поля с данными в кавычках, кавычки не убирайте!

Создание цифровой даты.

Для создания скрипта необходимо выбрать команду меню

Tools--> Java Constructor (или нажмите кнопку Java Constructor на панели инструментов),

после чего появиться окно конструктора

Выберите вкладку Date&Time, затем вкладку Digital Date, выберите цвет даты с помощью кнопок выбора цвета, в списке Date position выберите позицию даты и нажмите кнопку Create script. Выберите директорию, в которой вы хотите сохранить файл и ресурсы для хранения скрипта, и нажмите OK. Скрипт будет создан. Для предпросмотра нажмите Preview.


Использование программы.

Создание Java скриптов.

Эффекты с изображением и строками.

Создание слайд-шоу.

Для создания скрипта необходимо выбрать команду меню

Tools--> Java Constructor (или нажмите кнопку Java Constructor на панели инструментов),

после чего появиться окно конструктора

Выберите вкладку Image&String Effects, затем вкладку Slide-show, выберите первую картинку в поле First image, затем создайте набор картинок, поочерёдно выбирая картинку в поле Image и добавляя их при помощи кнопки Add image, и затем нажмите кнопку Create Script. Выберите директорию, в которой вы хотите сохранить файл и ресурсы для хранения скрипта, и нажмите OK. Скрипт будет создан. Для предпросмотра нажмите Preview.

Создание поочерёдной смены картинок при выборе ссылки.

Для создания скрипта необходимо выбрать команду меню

Tools--> Java Constructor (или нажмите кнопку Java Constructor на панели инструментов),

после чего появиться окно конструктора

Выберите вкладку Image&String Effects, затем вкладку Change image, выберите первую картинку в поле First image, в поле с надписью center введите положение картинки, затем создайте набор картинок, поочерёдно выбирая картинку в поле Image и ссылку в поле Link, добавляя их при помощи кнопки Add image, и затем нажмите кнопку Create Script. Выберите директорию, в которой вы хотите сохранить файл и ресурсы для хранения скрипта, и нажмите OK. Скрипт будет создан. Для предпросмотра нажмите Preview.

Эффект выезжающих полос.

Для создания скрипта необходимо выбрать команду меню

Tools--> Java Constructor (или нажмите кнопку Java Constructor на панели инструментов),

после чего появиться окно конструктора

Выберите вкладку Image&String Effects, затем вкладку Leaving Strip, введите в поле Color цвет полос, в поле Speed - скорость движения полос, и затем нажмите кнопку Create Script. Выберите директорию, в которой вы хотите сохранить файл и ресурсы для хранения скрипта, и нажмите OK. Скрипт будет создан. Для предпросмотра нажмите Preview.

Создание эффекта бегущей строки.

Для создания скрипта необходимо выбрать команду меню

Tools--> Java Constructor (или нажмите кнопку Java Constructor на панели инструментов),

после чего появиться окно конструктора

Выберите вкладку Image&String Effects, затем вкладку Streaming string, в поле Width введите ширину строки, в поле Speed - скорость движения строки, в поле Height - высоту строки, в поле String text, и затем нажмите кнопку Create Script. Выберите директорию, в которой вы хотите сохранить файл и ресурсы для хранения скрипта, и нажмите OK. Скрипт будет создан. Для предпросмотра нажмите Preview.


Использование программы.

Создание Java скриптов.

Меню.

Создание динамического меню, выезжающего из-за края окна при наведении курсора мыши.

Для создания скрипта необходимо выбрать команду меню

Tools--> Java Constructor (или нажмите кнопку Java Constructor на панели инструментов),

после чего появиться окно конструктора

Выберите вкладку Menu, затем вкладку Dynamic menu , в поле Top введите положение меню относительно верхнего края окна, в поле Border - размер бордюра, в поле Backgrount color и Layer-background-color введите цвета фона, в поле Line height введите высоту меню, затем в поле Text введите текст строки меню, и ссылку, соответствующую этой строке, и добавьте пункт с помощью кнопки Add menu, и затем нажмите кнопку Create Script. Выберите директорию, в которой вы хотите сохранить файл и ресурсы для хранения скрипта, и нажмите OK. Скрипт будет создан. Для предпросмотра нажмите Preview.

Создание выпадающего меню.

Для создания скрипта необходимо выбрать команду меню

Tools--> Java Constructor (или нажмите кнопку Java Constructor на панели инструментов),

после чего появиться окно конструктора

Выберите вкладку Menu, затем вкладку Dropdown menu, в поле Position введите позицию меню, в поле First string введите первую строку меню, в поле Menu text введите текст меню и соответствующую ей ссылку в поле Menu link и нажмите кнопку Add menu для формирования меню, и затем нажмите кнопку Create Script. Выберите директорию, в которой вы хотите сохранить файл и ресурсы для хранения скрипта, и нажмите OK. Скрипт будет создан. Для предпросмотра нажмите Preview.


Использование программы.

Создание Java скриптов.

Манипуляция с окнами.

Внимание. Использовать для просмотра браузер, иначе вы ничего не увидите!

Создание бегущей строки в строке состояния браузера.

Для создания скрипта необходимо выбрать команду меню

Tools--> Java Constructor (или нажмите кнопку Java Constructor на панели инструментов),

после чего появиться окно конструктора

Выберите вкладку Window Manipulation, затем вкладку Streaming string in statusbar, в поле Speed введите скорость строки, в Text - текст строки, затем нажмите кнопку Add string (можно добавить несколько строк), и затем нажмите кнопку Create Script. Выберите директорию, в которой вы хотите сохранить файл и ресурсы для хранения скрипта, и нажмите OK. Скрипт будет создан.

Создание бегущей строки с паузой в строке состояния браузера.

Для создания скрипта необходимо выбрать команду меню

Tools--> Java Constructor (или нажмите кнопку Java Constructor на панели инструментов),

после чего появиться окно конструктора

Выберите вкладку Window Manipulation, затем вкладку Streaming string with pause, в поле Speed введите скорость строки, в Text - текст строки, затем нажмите кнопку Add string (можно добавить несколько строк), установите паузу в поле Pause, и затем нажмите кнопку Create Script. Выберите директорию, в которой вы хотите сохранить файл и ресурсы для хранения скрипта, и нажмите OK. Скрипт будет создан.


Использование программы.

Создание CGI скриптов.

Создание текстового счётчика.

Для создания скрипта необходимо выбрать команду меню

Tools--> CGI QuickBuilder (или нажмите кнопку CGI QuickBuilder на панели инструментов),

после чего появиться окно конструктора

Выберите вкладку Text Counter, в поле Path to Perl введите путь к Perl на компьютере, где будет использоваться скрипт, затем нажмите кнопку Create script. Выберите директорию для копирования файлов скрипта, и нажмите OK. Для использования скрипта все скопированные файлы поместите на компьютер ((в директорию, где разрешён запуск CGI), где они будут использоваться и установите для них права доступа - для counter.cgi и textcounter.cgi - 755, для log.txt, count.txt -777. Передачу CGI-файлов на сервер осущесвлять только в ASCII режиме.

Создание чата.

Для создания скрипта необходимо выбрать команду меню

Tools--> CGI QuickBuilder (или нажмите кнопку CGI QuickBuilder на панели инструментов),

после чего появиться окно конструктора

Выберите вкладку Chat, в поле Path to Perl введите путь к Perl на компьютере, где будет использоваться скрипт, в поле Chat name введите название чата, в поле Refresh - время обновления чата, в поле Background page и Background page(2) введите цвета фона, в поле Messages - количество сообщений на странице, затем нажмите кнопку Create script. Выберите директорию для копирования файлов скрипта, и нажмите OK. Для использования скрипта все скопированные файлы поместите на компьютер, где они будут использоваться (в директорию, где разрешён запуск CGI) и установите для них права доступа - для chat.cgi - 755, для log.txt, chat.txt -777. Передачу CGI-файлов на сервер осущесвлять только в ASCII режиме.

Создание эффекта появления нового текста.

Для создания скрипта необходимо выбрать команду меню

Tools--> CGI QuickBuilder (или нажмите кнопку CGI QuickBuilder на панели инструментов),

после чего появиться окно конструктора

Выберите вкладку New Banner, в поле Path to Perl введите путь к Perl на компьютере, где будет использоваться скрипт, в поле Add text in banner введите текст, нажимая кнопку Add string для добавления новой строки, затем нажмите кнопку Create script. Выберите директорию для копирования файлов скрипта, и нажмите OK. Для использования скрипта все скопированные файлы поместите на компьютер, где они будут использоваться (в директорию, где разрешён запуск CGI) и установите для них права доступа - для rhtml.cgi- 755, для list -755. Передачу CGI-файлов на сервер осущесвлять только в ASCII режиме.

Создание конференции.

Для создания скрипта необходимо выбрать команду меню

Tools--> CGI QuickBuilder (или нажмите кнопку CGI QuickBuilder на панели инструментов),

после чего появиться окно конструктора

Выберите вкладку Conference, в поле Path to Perl введите путь к Perl на компьютере, где будет использоваться скрипт, в поле Conference name введите название конференции, нажимая кнопку Add section вводите название разделов конференции (до 9!), затем введите пароль в поле Password,затем нажмите кнопку Create script. Выберите директорию для копирования файлов скрипта, и нажмите OK. Для использования скрипта все скопированные файлы поместите на компьютер, где они будут использоваться (в директорию, где разрешён запуск CGI) и установите для всех файлов права доступа - 755. Передачу CGI-файлов на сервер осущесвлять только в ASCII режиме. Перед использованием конференции инсталлируйте её с помощью команды вида http://имя вашего сайта/cgi-bin директория/ board.cgi?action=install&password=пароль, введённый вами в поле Password.

Создание гостевой книги.

Для создания скрипта необходимо выбрать команду меню

Tools--> CGI QuickBuilder (или нажмите кнопку CGI QuickBuilder на панели инструментов),

после чего появиться окно конструктора

Выберите вкладку GuestBook, в поле Path to Perl введите путь к Perl на компьютере, где будет использоваться скрипт, в поле Login введите ваше имя пользователя администратора, в поле Password введите ваш пароль администратора, установите в поле Messages - количество отображаемых сообщений, затем нажмите кнопку Create script. Выберите директорию для копирования файлов скрипта, и нажмите OK. Для использования скрипта все скопированные файлы поместите на компьютер, где они будут использоваться (в директорию, где разрешён запуск CGI) и установите для всех файлов права доступа - 755. Передачу CGI-файлов на сервер осущесвлять только в ASCII режиме. Для администрирования запутите файл admin.pl, для запуска гостевой - gb.pl.


Обратная связь

Уважаемые пользователи! AG FreeSoft непрерывно совершенствует и улучшает свои программные продукты, поэтому, если у Вас возникли какие-либо предложения по улучшению программных продуктов, идеи по созданию новых продуктов и модернизации существующих, пожалуйста, сообщайте нам об этом. Каждое пожелание или предложение будет нами обязательно рассмотрено. Нам очень важно знать мнение каждого пользователя о наших продуктах!

Адреса для обратной связи:

* Любые вопросы по программным продуктам AG FreeSoft - agfreesoft@privathost.ru, ag_support@fromru.com

* Предложения по сотрудничеству с AG FreeSoft - alan83@mail.ru

* Как стать бета-тестером наших продуктов - agfreesoft@fromru.com

AG FreeSoft