Планирование запуска заданий в определенное время

Программа планировщика заданий является средством назначения программ (таких как дефрагментация диска) и других служебных программ для выполнения в наиболее удобное время. Планировщик заданий запускается при каждом запуске Windows и выполняется в фоновом режиме.

Для запуска планировщика заданий нажмите кнопку Пуск, выберите команды Программы, Стандартные и Служебные, а затем выберите Назначенные задания.

Открытие планировщика заданий позволяет:

  • назначить задание для выполнения ежедневно, еженедельно, ежемесячно или в указанное время, например при запуске или во время простоя компьютера;
  • отключить или изменить график выполнения существующего задания;
  • назначить параметры выполнения задания в указанное время.


Назначение нового задания

  1. Нажмите кнопку Пуск и выберите команды Программы, Стандартные, Служебные и Назначенные задания.
  2. Дважды щелкните значок Добавить задание.
  3. Следуйте инструкциям мастера планирования заданий.

    4. Если требуется установить дополнительные параметры задания (такие как повторный запуск при каждом выполнения задания), установите флажок Установить дополнительные параметры в последнем окне мастера.

Примечания

  • Если программе требуется передать параметры, установите флажок Установить дополнительные параметры в последнем окне мастера, нажмите кнопку Готово, затем выберите вкладку Задание и введите параметры в поле Запуск вслед за путем к программе.
  • Выполнение назначенного задания начинается при включении компьютера, независимо от загрузки Windows. Если не требуется выполнять задание при незагруженной системе, перед завершением сеанса откройте папку «Назначенные задания» и в меню Дополнительно выберите команду Остановить планировщик. Для запуска планировщика заданий при возобновлении сеанса откройте папку «Назначенные задания» и в меню Дополнительно выберите команду Возобновить работу планировщика.
  • Проверьте правильность системной даты и времени на компьютере. Планировщик заданий использует системную дату и время при выполнении назначенных заданий. Для изменения даты и времени дважды щелкните значение времени на панели задач.

См. также


Изменение назначенного задания

  1. Нажмите кнопку Пуск и выберите команды Программы, Стандартные, Служебные и Назначенные задания.
  2. Щелкните правой кнопкой задание, которое требуется изменить, и выберите команду Свойства.
  3. Выполните одно или несколько из следующих действий.
    • Чтобы сменить запускаемую программу, введите путь и имя программы в поле Запуск или нажмите кнопку Обзор.
    • Чтобы изменить расписание задания, выберите вкладку Расписание.
    • Чтобы изменить настройку задания, выберите вкладку Настройка.

Примечания

  • Если программе требуется передать параметры, введите их после пути в поле Запуск.
  • Если полный путь к программе включает пробелы, заключите его в символы двойных кавычек (“).

См. также


Удаление назначенного задания

  1. Нажмите кнопку Пуск и выберите команды Программы, Стандартные, Служебные и Назначенные задания.
  2. Щелкните правой кнопкой задание, которое требуется удалить, и выберите команду Удалить.

Примечание

  • При удалении назначенного задания оно удаляется только из папки назначенных заданий. Связанная с заданием программа не удаляется с компьютера.


Прекращение выполнения текущего задания

  1. Нажмите кнопку Пуск и выберите команды Программы, Стандартные, Служебные и Назначенные задания.
  2. Щелкните правой кнопкой задание, которое требуется остановить, и выберите команду Завершить.

Примечания

  • Если в назначенном задании запускается другая программа, то данная команда приведет к остановке только исходного назначенного задания. Второе задание будет выполняться.
  • Чтобы снова запустить задание, щелкните правой кнопкой значок задания и выберите команду Запустить.
  • Выполнение назначенного задания начинается при включении компьютера, независимо от загрузки Windows. Если при незагруженной системе выполнять задание не требуется, перед завершением сеанса откройте папку «Назначенные задания» и в меню Дополнительно выберите команду Остановить планировщик. Для запуска планировщика заданий при возобновлении сеанса откройте папку «Назначенные задания» и в меню Дополнительно выберите команду Возобновить работу планировщика.

См. также


Принудительное выполнение задания

  1. Нажмите кнопку Пуск и выберите команды Программы, Стандартные, Служебные и Назначенные задания.
  2. Щелкните правой кнопкой задание, которое требуется выполнить, и выберите команду Запустить.

Примечания

  • Чтобы прекратить выполнение задания, выберите в меню Файл команду Завершить задачу.
  • Если задание не запускается, проверьте причину по журналу. В меню Дополнительно выберите команду Просмотр журнала.

См. также


Просмотр журнала выполнения назначенных заданий

  1. Нажмите кнопку Пуск и выберите команды Программы, Стандартные, Служебные и Назначенные задания.
  2. В меню Дополнительно выберите команду Просмотр журнала.


Просмотр назначенных заданий на удаленном компьютере

  1. Дважды щелкните значок Мое сетевое окружение.
  2. Дважды щелкните значок компьютера, на котором требуется просмотреть назначенные задания.
  3. Дважды щелкните значок папки «Назначенные задания».

Примечание

  • Изменять задания на удаленном компьютере можно только в том случае, если на удаленном компьютере установлено программное обеспечение общего доступа к файлам и назначен общий ресурс x$, где x представляет жесткий диск, на котором находится папка «Назначенные задания». Кроме того, ваша учетная запись на данном компьютере должна иметь разрешения удаленного управления. Чтобы указать пользователей, имеющих право на удаленное управление компьютером, дважды щелкните значок Пароли в окне Панель управления.


Временное отключение всех назначенных заданий

  1. Нажмите кнопку Пуск и выберите команды Программы, Стандартные, Служебные и Назначенные задания.
  2. В меню Дополнительно выберите команду Приостановить планировщик.

    Это полезно при выполнении другой программы (например игровой) или при установке программного обеспечения, когда назначенное задание может оказаться помехой.

Примечания

  • Задания, которые не были выполнены во время приостановки планировщика заданий, будут запущены в следующее время выполнения по графику после запуска планировщика.
  • Чтобы возобновить выполнение заданий, выберите в меню Дополнительно команду Возобновить работу планировщика.

См. также


Выключение планировщика заданий

  1. Нажмите кнопку Пуск и выберите команды Программы, Стандартные, Служебные и Назначенные задания.
  2. В меню Дополнительно выберите команду Остановить планировщик.

Примечание

  • После выключения планировщика заданий назначенные задания не будут выполняться и планировщик заданий не будет запускаться автоматически при следующем запуске Windows.

См. также


Устранение неполадок планировщика заданий

Если запланированное задание не выполняется в назначенное время, щелкните правой кнопкой значок задания в списке заданий и выберите команду Свойства. На вкладке Задание проверьте, что установлен флажок Включено. На вкладке Расписание проверьте, правильно ли задано расписание.

Если неверно выполняется программа задания, проверьте, указаны ли все необходимые аргументы команды. Чтобы больше узнать о программе и ее аргументах, выполните одно из следующих действий.

  • Если у программы имеется встроенная справка, просмотрите справку.
  • Попробуйте ввести с командной строки приведенную ниже команду, где программа представляет имя программы:
    программа /?


Открытие папки "Назначенные задания"

Открытие папки «Назначенные задания»

  • Нажмите кнопку Пуск и выберите команды Программы, Стандартные, Служебные и Назначенные задания.

См. также