
Contents

The following Help Topics are available:

General Concepts
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Menus and Toolbar

Toolbar for Polls and Questionnaires 
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Icons and Their Meanings

Poll
Questionnaire

New, not yet taken by you
Done, already completed by you
Incomplete, partially taken by you but not completed
Under Maintenance, being edited by the Poll Operator
Unavailable



What are Polls and Questionnaires?

Worldgroups are among the most powerful consensus-finding tools ever invented.    They 
permit individuals scattered across the planet to come to an electronic "town meeting" and 
let their concerns be heard.    While Teleconference and Forums offer a dynamic exchange of 
commentary, they are not well suited to measurement.    Polls and Questionnaires offer users
the chance to vote, and offer sysops the chance to get hard facts on voter sentiment.    

Businesses use Ps & Qs to find out how customers feel and what they want.    Social groups 
use Ps & Qs to find out the same information from members.    

Some Worldgroups even pay you to vote.    In return for filling out a poll or a questionnaire, 
you could receive extra file download privileges, extra time online, or other forms of 
persuasion.    

Polls are made up entirely of Yes/No, True/False, and Multiple Choice questions.    This means
that responses to a poll can be tabulated, totalled, and averaged to show how The People 
feel about any topic.    

Questionnaires can ask these sorts of questions, but can also ask "essay"-type questions 
which cannot be averaged.    As a result, questionnaires gather only individual responses.    
Sysops often use questionnaires to screen callers who apply for membership.    

You'll need to be online to perform most tasks in Polls and Questionnaires.    

See also Contents.    



Toolbar for Polls and Questionnaires

Take the currently highlighted poll 
or questionnaire.    Same as the 
File menu's Open, or pressing 
Enter, or double-clicking on the 
highlighted poll.    
View the totalled/averaged results
of the currently hightlighted poll.   
Same as the View menu's Results 
for Poll.    
Look up by User-ID the answers 
given by one person to the 
highlighted poll or questionnaire.   
Same as the View menu's Results 
for Individual.    

File Menu

Open
Take the currently highlighted poll, the same as pressing Enter or double-clicking on 
the highlighted poll.    

Exit
Close the Polls and Questionnaires module.    



Take a Poll

This is where you answer the questions asked by a poll or a questionnaire.    

To reach this window, either double-click on the poll or questionnaire you wish to take or 
highlight it and from the File menu select Open.    The leftmost toolbar button also opens the 
currently highlighted poll or questionnaire.    Just answer each question in turn.    

On occasion, you may notice that the next question changes as you answer the current 
question.    For example, suppose you were asked the question, "Do you own your own 
business?"    If you answer "No", there's not much point asking you half a dozen more 
detailed questions about the business that you don't have.    The poll can use your answer to 
branch to the next meaningful question.    



View Menu

Results for Poll
Displays the tallied results for the currently highlighted poll, supplying vote counts, 
percentages, and charts of the results.    

Results for Individual
Displays the specific responses of a single voter to the currently highlighted poll, 
looking up the individual by User-ID.    

Toolbar
Activates or deactivates the button toolbar.    



Results for Poll

This displays the totalled, averaged results of a poll.    

To reach this window, highlight the poll you wish to examine.    Then, from the View menu 
select Results for Poll.    Alternatively, click the middle toolbar button.    

Results are displayed in the order in which the poll's questions were asked.    You can use the
scroll bar to browse through the results.    

 
This button in the lower lefthand corner of each subwindow displays each question's 
results in a graph.    

Results in Text form    
The text of each question appears in the upper lefthand corner of each subwindow, in
bold type.    Possible answers are listed in the column directly beneath the question.  

The column under the title Matches displays the number of votes received for each 
possible answer.    The bottom line in this column shows the total number of votes 
received on this question.    Notice that this total may vary from question to question. 
If one of the questions asks, "Do you own your own business?" and branches 
depending on the answer, not everyone will answer the following, business-related 
questions.    

The far righthand column displays the votes in percentage terms.    



Question Results Graph

This graphically displays the results of a single question asked by a poll.    

To reach this window, from the View menu select Results for Poll.    Then, from any question 
listed, click .    

Graph Type
Select between Bar and Pie chart views of the question's results.    

Save
You can save the currently visible graph to a Windows bitmap file (.bmp) or Windows 
metafile (.wmf).    

Print
You can print the currently visible graph to whichever printer is attached to your PC.    
You can also save the printer output to a file if your printer's driver supports it.    



Save Graph

You can save the graph currently displayed in Question Results Graph to a Windows bitmap 
file (.bmp) or Windows metafile (.wmf) on your PC.    

To reach this window, from the View menu select Results for Poll.    Then, from any question 
listed, click .    Finally, from the Question Results Graph window click Save.    

File Name
The text box lets you manually enter the drive:\directory\...\filename.bmp or .wmf 
into which you wish to save the graph.    Set the appropriate file type in Save File as 
Type.    

The standard list box below the text box displays all files in the current drive:\
directory which are of the type selected either by a text box filter or by List Files of 
Type.    

If you wish to save the graph over top of an existing file which is visible in the list 
box, you can double-click on it, or highlight it then click on OK.    

Save File as Type
The dropdown list box lets you save the graph as either a Windows bitmap file 
(.bmp) or Windows metafile (.wmf).    

By default, List Files of Type inserts the *.bmp (bitmaps) filter in File Name's text box. 
Even if you hand-type .wmf in the File Name, the file will be saved as a bitmap 
unless you change Save File as Type to Windows Metafile.    

Directories
The list box displays the directory tree of the drive:\ selected below in Drives.    The 
current directory is the one whose folder icon is open and darkened within.    Any 
folders listed below it are children subdirectories of the current directory.    Any folders
listed above it are parent directories.    Between the list box and the title line 
Directories: you will see displayed in text the current directory's drive:\path, 
possibly abbreviated.    

Double-click on a directory to switch to it.    If the directory you seek is not visible, 
double-click on the directory which you know to be its parent.    This list box does not 
display the entire tree at once, but limits itself instead to the parentage and children 
of the current directory.    

Drives
This dropdown list box selects the drive letter you wish displayed.    Depending on 
your PC's setup, it may display volume names in [brackets] to the right of each drive 
letter.    

A single click selects a drive letter.    The Directories and File Name list boxes will 
change to display the new drive's current directory and files.    



Look Up Specific User-ID

This is where you can locate the answers a specific individual gave to a particular poll or 
questionnaire.    

To reach this window, from the View menu select Results for Individual.    Alternatively, click 
on the rightmost toolbar button.    

User-ID to Look Up Results For
If you know the exact User-ID of the person you seek, type the User-ID in here.    

If you're not sure, click Find...

(Dropdown list)
The dropdown list shows all polls and questionnaires from which you can call up an 
individual's answers.    

Once you've selected a valid User-ID and a poll, click OK.    



Results for Individual

This displays the answers given by one individual to a particular poll or questionnaire.    

To reach this window, from the View menu select Results for Individual.    

The status bar at the top center of the window displays User-ID: poll name

Use the scroll bar to browse through the list of questions.    Click on Close to exit.    
 



Glossary

The following definitions are available:

Bitmap File
C/S (Client/Server) Mode
Client Side
Dumb Terminal
File Transfer Protocol
Metafile
Online, Offline, On Deck
Password
Worldgroup server
Server Side
Sysop
Terminal Mode
User Account
User-ID



Bitmap File
A bitmap is a way to store a graphical image as a rectangular grid of dots (pixels).    

For example, this is a bitmap graphic:    

Here it is again 4 times as 
large.    Bitmaps don't enlarge 
very well because the 
information that is stored 
within them is only accurate 
down to the size of a single 
pixel (dot).    Enlarge a bitmap 
and you get big dots.      

On the other hand, bitmaps work very well when they store information which is not meant 
to be enlarged, reshaped or otherwise manipulated.    Windows icons are bitmaps (stored as
.ico files or embedded in .exe files).    Windows wallpaper designs are bitmaps (.bmp).    

The Windows program Paintbrush can manipulate .bmp files.    

See also Metafile.    



C/S (Client/Server) Mode

Two-sided computing: your PC and the Worldgroup server PC both work to satisfy your 
requests.    Your PC's processing power is not ignored (as with a terminal mode BBS).    In fact,
your PC ends up doing most of the work.    C/S mode minimizes wasted time online by letting
you do many tasks on deck.    

Client/server means that one program (the client) can ask another program (the server) for 
assistance.    The two programs often run on separate computers connected by a 
communications link (a network, the telephone system, etc.).    

WGM is a client program running on your PC.    

The Worldgroup server is a server program running on a remote PC.    



Client side
Your PC running WGM is the client side of a client/server relationship.    The remote PC 
running Worldgroup server software is the server side of the relationship.    The term client 
side includes:

1) any programs which run on your PC
2) any data, documents, or other files which are stored on your PC

The client side can do many tasks itself, and calls on the server side for tasks it cannot do 
(exchanging messages with other clients, looking up centralized information, etc.).    



Dumb Terminal
A device which has a keyboard, a monitor, possibly a mouse, but has no ability to process 
data by itself.    A dumb terminal has to be connected to a computer in order to do anything.  

Old-style user-side modem programs are known as terminal programs because they make 
your PC mimic a dumb terminal (thereby wasting your PC's processing power).    



File Transfer Protocol
A language for exchanging files between two computers and confirming that what arrives is 
the same as what was sent.    Common protocols for terminal-mode transfers include 
ZMODEM, XMODEM, YMODEM-Batch, and Kermit.    

WGM in C/S mode uses its own information transfer protocol, GCSP, which uses Dynapaks to 
exchange all forms of data including files.    



Metafile
A metafile is a way to store a graphical image as a collection of shapes, angles, and relative 
distances.    

For example, this drawing is a metafile:    

Here it is again 8 times 
as large.    Note that its 
curved edges are far 
smoother than would 
be a bitmap of the 
same size.    Stretched 
large or small, a 
metafile is recalculated
to provide the most 
accurate image 
possible.    

Because PC monitors in use today may be set to any of a dozen different resolutions (so 
many pixels tall, so many pixels wide), we have used metafiles within WGM's help files 
wherever possible.    This makes it more likely that graphics will appear properly on your 
display.    

The Windows program Paintbrush cannot manipulate .wmf files.    

See also Bitmap File.    



Online
Connected.    
Your PC is online whenever it is connected to a Worldgroup server.    

Offline
Disconnected.    
Your PC is offline whenever it is not connected to a Worldgroup server.    

On Deck
Disconnected but able to perform tasks.    
Your PC is on deck whenever WGM is running the client-side program for a 
Worldgroup service but your PC is not yet connected to the online service.    



Password
The private half of your identification, seen only by the Worldgroup server software and the 
Sysop.    

A password is the confirmation that you are who your User-ID says you are.    Without 
passwords, someone else could log on using your User-ID and do things that you would be 
blamed for.    Keep your password secret.    

Avoid obvious, easily guessed, passwords.    Make up something that is not your mother's 
maiden name, not your job title, in fact not anything related to your work.    

Don't use a completely random string of characters, though.    "NE1410S" will be hard to 
remember.    Instead, an effective middle choice is to run two words together which are 
easily remembered by you but not easily guessed by others.    "Twosun" for example.    



Worldgroup Server
Any online service running Worldgroup server software by Galacticomm, Inc.    

Online services running other software are not servers in the client/server sense.    WGM 
drops back to terminal mode in order to communicate with them.    



Server side
The remote PC running Worldgroup is the server side of a client/server relationship.    Your PC
is the client side of the relationship.    The term server side includes:

1) any programs which run on the Worldgroup server PC
2) any data, documents, or other files which are stored on the Worldgroup server PC

The server side exists solely to do tasks which the client side cannot do itself (exchanging 
messages with other clients, looking up centralized information, etc.).    



Sysop
A System Operator, or Sysop, is the manager of a Worldgroup system.    



Terminal Mode
One-sided computing: the software running on the remote computer insists on doing all of 
the work, so the user's PC might as well be a dumb terminal.    This mindset made sense 
when computing power was prohibitively expensive.    Today, though, your PC may well be 
more powerful than the PC running the online service you call.    Even if it isn't, your PC is 
closer to you than the service's PC.    It can do things without delay, if the software at both 
ends permits.    Client/server mode permits this.    Terminal mode does not.    

WGM falls back from C/S mode to terminal mode in order to communicate with non-
Worldgroup online services.    



User Account
A list of information including your full name, your mailing address, your telephone number, 
etc.    In a for-profit online service, the user account may include your credit card number or 
other method of payment.    

User account information is private, seen only by you and by the Sysop.    

Your user account is identified by your User-ID and password.    



User-ID
The public half of your identification, seen by the software and by other users.    

A User-ID is a string of 3 to 29 characters.    On business systems, it is often your full name.    
On social systems, it is often a nickname or "handle."    In some situations, a User-ID may be 
assigned to you, but in most cases you have creative control.    

Your User-ID is verified by the password you associate with it.    



I never metafile I didn't like
            (Stryker said I could do it! --Marc)
 



Save / Save As
This function lets you record information to a disk file on your PC.    

File Name
The text box lets you manually enter the drive:\directory\...\filename.ext into which 
you wish to save the information.    Set the appropriate file type in Save File as Type.    

The standard list box below the text box displays all files in the current drive:\
directory which are of the type selected by Save File as Type.    

If you wish to save over top of an existing file which is visible in the list box, you can 
double-click on it, or highlight it then click on OK.    

Save File as Type
The dropdown list box lets you choose the way you wish the information to be 
recorded in the file.    

For example:

° Text is usually saved as .txt (ASCII text).    
° DOS Batch files are usually saved as .bat. 

Text and Batch files can be safely viewed.   
The following file types are machine 
readable only and so should not be viewed
as text:

° Programs are usually saved as .com 
(command) or .exe (executable).    

° Graphics are often stored as .bmp 
(bitmap) or .wmf (metafile).    

° Files are often compressed and packaged 
into a single file for quicker and simpler 
delivery.    Such compressed packages are 
most commonly stored as .zip (PKware 
format).    In order to extract a zipped file's
contents, you need the program 
PKunzip.exe.    

° The results of searches in File Libraries 
should be saved as .gfl (Galacticomm's 
file library format) if you wish to use the 
list to tag files to be downloaded.    

Other forms of data will come with choices appropriate to them.    

Directories
The list box displays the directory tree of the drive:\ selected below in Drives.    The 
current directory is the one whose folder icon is open and darkened within.    Any 
folders listed below it are children subdirectories of the current directory.    Any folders
listed above it are parent directories.    Between the list box and the title line 



Directories: you will see displayed in text the current directory's drive:\path, 
possibly abbreviated.    

Double-click on a directory to switch to it.    If the directory you seek is not visible, 
double-click on the directory which you know to be its parent.    This list box does not 
display the entire tree at once, but limits itself instead to the parentage and children 
of the current directory.    

Drives
This dropdown list box selects the drive letter you wish displayed.    Depending on 
your PC's setup, it may display volume names in [brackets] to the right of each drive 
letter.    

A single click selects a drive letter.    The Directories and File Name list boxes will 
change to display the new drive's current directory and files.    
 



Find...
This function helps you find the correct spelling of a person's User-ID.    

Although people commonly use their full names as User-IDs, you need to remember that a 
User-ID is a single string.    That is, the User-ID "Carolyn G." will appear before the User-ID 
"Kelly B." because the letter C comes before the letter K.      

Type your best guess in the User: field    
As with almost everything in Worldgroup, UPPER/lower case doesn't matter:    "Tyler" 
equals "TYLER" equals "tyler".    

Click on the Search button    
If the function finds any matches, the window will enlarge to display a list of possible 
matches.    Select the one you wish either by double-clicking it, or by single-clicking it 
then clicking the OK button.    The selected User-ID will be returned to the window 
from which you called Find...    

If the function does not find a match, try a shorter string in the User: field.    Although 
you can type in a full name, it's generally better not to.    If you ask for "reginald" but 
he signed up as "Reggie", the search won't find him.    You're better off searching for 
"reg".    

Notice that you can search for a person by last name, or even partial last name.    It 
will not find "Ann Owen" if you type in "we", however.    The search string in User: 
must be the beginning of a word if not a whole word.    



Print
This function sends data to your printer.    It suggests Number of copies: 1 but will accept as 
many as 999.    From this point on, Windows takes over.    

If you simply click on OK (or press Enter), Windows will print the data on whatever default 
printer you've set in Control Panel's Printers area.    

If you click on Setup..., Windows will first bring up the printer setup window which will let you
choose which printer (or file) will receive this data.    

 



Edit Toolbar

This window lets you choose which buttons are displayed on the toolbar and which are not.    
Notice that not all of the buttons you add will necessarily appear immediately after you save
your edits.    It may be inappropriate to display a particular button at this moment but, when 
it becomes appropriate, the button will be displayed.    

Add/Remove a Button
A single mouse click on any of the buttons listed here, or on the description beside it, 
will toggle between displaying the button on the toolbar and not displaying it.    
Highlighted means the button has been included/added to the current toolbar.    Not 
highlighted means the button has been excluded/removed from the current toolbar.    

Add All
This button highlights every button in the list, including/adding all of them.    

Remove All
This button unhighlights every button in the list, excluding/removing all of them.    

Save
Once you've edited this toolbar to your satisfaction, click this button to save your 
changes.    Not all of the buttons you add will necessarily appear immediately.    It may
be inappropriate to display a particular button at this moment but, when it becomes 
appropriate, the button will be displayed.    

 




