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File menu commands

The File menu offers the following commands:

New
Open
Close
Save
Save As
Save All
Delete
Page 
Setup...
Print
Print 
Preview
Print Setup
Send...
File History
Exit



Edit menu commands

The Edit menu offers the following commands:

Undo
Cut
Copy
Paste
Select All



View menu commands

The View menu offers the following commands:

Properties...
Center 
Graphic
(Image Window 
only)
Full Screen
(Image Window 
only)
Zoom
(Image Window 
only)

Image menu commands
The Image menu offers the following commands. This menu is only available when an Image
Window is open.

Resize Image
Color 
Reduction
Rotate
Flip



Album menu commands
The Album menu offers the following commands. This menu is only available when an Album
Window is open.

Add Slides...
Delete Slides
Edit Slide...
Edit Graphic
View Graphic
View Graphic 
Full Screen
Create 
Common 
Palette
Generate 
Thumbnails
Image 
Processing...
Slide Show 
Abort 
Processing
Processing 
Options



Palette menu commands
Create Identity 
Palette...
Apply Palette 
File...
(Image Window 
only)

Apply Palette 
File & Dither...
(Image Window 
only)



Capture menu commands
Desktop
Window...
Client Area...
Rectangle...
Fixed 
Rectangle...
Hide ImageLab



Options menu commands
The Options menu offers the following commands:

Toolbars...
Status Bar

Settings...



Window menu commands

The Window menu offers the following commands, which enable you to arrange multiple 
views of multiple documents in the application window:

New Window
Cascade
Tile
Arrange Icons
Window 1, 
2, ...



Help menu commands

The Help menu offers the following commands, which provide you assistance with this 
application: 

Help 
Topics
About 
ImageLa
b...



New command (File menu)

Use this command to create a new document in ImageLab. Select the type of new file you 
want to create in the File New dialog box.

You can open an existing document with the Open command.

Shortcuts

Toolbar:
Keys: CTRL+N



File New dialog box

Specify the type of document you wish to create:
Album
Graphic
Palette



Open command (File menu)

Use this command to open an existing document in a new window.
You can create new documents with the New command.

Shortcuts

Toolbar:
Keys: CTRL+O



File Open dialog box

The following options allow you to specify which file to open:
File Name

Type or select the filename you want to open. This box lists files with the extension you 
select in the List Files of Type box. 

List Files of Type
Select the type of file you want to open:

Drives
Select the drive in which ImageLab stores the file that you want to open. 

Directories
Select the directory in which ImageLab stores the file that you want to open.



Close command (File menu)

Use this command to close all windows containing the active document. ImageLab suggests 
that you save changes to your document before you close it. If you close a document 
without saving, you lose all changes made since the last time you saved it. Before closing an
untitled document, ImageLab displays the Save As dialog box and suggests that you name 
and save the document.

You can also close a document by using the Close icon on the document's window, as shown 
below:



Save command (File menu)

Use this command to save the active document to its current name and directory. When you 
save a document for the first time, ImageLab displays the Save As dialog box so you can 
name your document. If you want to change the name and directory of an existing 
document before you save it, choose the Save As command.

Shortcuts

Toolbar:
Keys: CTRL+S



Save As command (File menu)

Use this command to save and name the active document. ImageLab displays the Save As 
dialog box so you can name your document. 

To save a document with its existing name and directory, use the Save command.



Send command (File menu)

Use this command to send the active document through electronic mail. This command 
presents a mail window with the active document attached to it. You may then fill out the To:
field, Subject: field, etc., and add text to the body of the message if you wish. When you are 
finished you may click the "Send" button to send the message.



File Save As dialog box

The following options allow you to specify the name and location of the file you're about to 
save:
File Name

Type a new filename to save a document with a different name. A filename can contain 
up to eight characters and an extension of up to three characters. ImageLab adds the 
extension you specify in the Save File As Type box.

Drives
Select the drive in which you want to store the document.

Directories
Select the directory in which you want to store the document.



1, 2, 3, 4 command (File menu)

Use the numbers and filenames listed at the bottom of the File menu to open the last four 
documents you closed. Choose the number that corresponds with the document you want to
open.



Exit command (File menu)

Use this command to end your ImageLab session. You can also use the Close command on 
the application Control menu. ImageLab prompts you to save documents with unsaved 
changes.

Shortcuts
Mouse: Double-click the application's Control menu button.

Keys: ALT+F4



Undo/Can't Undo command (Edit menu)

Use this command to reverse the last editing action, if possible. The name of the command 
changes, depending on what the last action was. The Undo command changes to Can't Undo
on the menu if you cannot reverse your last action.

Shortcuts
Keys: CTRL+Z or

ALT-BACKSPACE



Cut command (Edit menu)

Use this command to remove the currently selected data from the document and put it on 
the clipboard. This command is unavailable if there is no data currently selected.

Cutting data to the clipboard replaces the contents previously stored there.

Shortcuts

Toolbar:
Keys: CTRL+X



Copy command (Edit menu)

Use this command to copy selected data onto the clipboard. This command is unavailable if 
there is no data currently selected.

Copying data to the clipboard replaces the contents previously stored there.

Shortcuts

Toolbar:
Keys: CTRL+C



Paste command (Edit menu)

Use this command to insert a copy of the clipboard contents at the insertion point. This 
command is unavailable if the clipboard is empty.

Shortcuts

Toolbar:
Keys: CTRL+V



Toolbars... command (Options menu)

Use this command to display and hide the Main and Capture toolbars, which includes 
buttons for some of the most common commands in ImageLab, such as File Open. A check 
mark appears next to the name of the Toolbar when it is displayed.

See Toolbar for help on using the toolbar.



Toolbar

The toolbar is displayed across the top of the application window, below the menu bar. The 
toolbar provides quick mouse access to many tools used in ImageLab.

To hide or display the Toolbar, choose Toolbars... from the Options menu and select either 
Main or Capture for the appropriate toolbar.



Status Bar command (Options menu)

Use this command to display and hide the Status Bar, which describes the action to be 
executed by the selected menu item or depressed toolbar button, and keyboard latch state. 
A check mark appears next to the menu item when the Status Bar is displayed.

See Status Bar for help on using the status bar.



Status Bar

The status bar is displayed at the bottom of the ImageLab window. To display or hide the 
status bar, use the Status Bar command in the View menu.

The left area of the status bar describes actions of menu items as you use the arrow keys to 
navigate through menus. This area similarly shows messages that describe the actions of 
toolbar buttons as you depress them, before releasing them. If after viewing the description 
of the toolbar button command you wish not to execute the command, then release the 
mouse button while the pointer is off the toolbar button.

The second area from the left displays the x,y location of the mouse. The third area from the
left displays the size of the selected area. The fourth area displays the RGB value of the cell 
over which the cursor is positioned.



RGB area (Status bar)
This area displays the index and RGB value of the cell over which the cursor is positioned.



Mouse position area (Status bar)
This area displays the x,y location of the mouse.



Selection size area (Status bar)
This area displays the size of the selected area



New Window command (Window menu)

Use this command to open a new window with the same contents as the active window. You 
can open multiple document windows to display different parts or views of a document at 
the same time. If you change the contents in one window, all other windows containing the 
same document reflect those changes. When you open a new window, it becomes the active
window and is displayed on top of all other open windows.



Cascade command (Window menu)

Use this command to arrange multiple opened windows in an overlapped fashion. 



Tile command (Window menu)

Use this command to arrange multiple opened windows in a non-overlapped fashion.



Window Arrange Icons Command

Use this command to arrange the icons for minimized windows at the bottom of the main 
window. If there is an open document window at the bottom of the main window, then some 
or all of the icons may not be visible because they will be underneath this document window.



1, 2, ... command (Window menu)

ImageLab displays a list of currently open document windows at the bottom of the Window 
menu. A check mark appears in front of the document name of the active window. Choose a 
document from this list to make its window active. 



Index command (Help menu)

Use this command to display the opening screen of Help. From the opening screen, you can 
jump to step-by-step instructions for using ImageLab and various types of reference 
information. 

Once you open Help, you can click the Contents button whenever you want to return to the 
opening screen.



Using Help command (Help menu)

Use this command for instructions about using Help.



About command (Help menu)

Use this command to display the copyright notice and version number of your copy of 
ImageLab.



Context Help command 

Use the Context Help command to obtain help on some portion of ImageLab. When you 
choose the Toolbar's Context Help button, the mouse pointer will change to an arrow and 
question mark. Then click somewhere in the ImageLab window, such as another Toolbar 
button. The Help topic will be shown for the item you clicked.

Shortcut
Keys: SHIFT+F1



Title Bar

The title bar is located along the top of a window. It contains the name of the application and
document.

To move the window, drag the title bar. Note: You can also move dialog boxes by dragging 
their title bars.

A title bar may contain the following elements:
Application Control-menu button
Document Control-menu button
Maximize button
Minimize button
Name of the application
Name of the document
Restore button



Scroll bars

Displayed at the right and bottom edges of the document window. The scroll boxes inside 
the scroll bars indicate your vertical and horizontal location in the document. You can use 
the mouse to scroll to other parts of the document.



Size command (Control menu)

Use this command to display a four-headed arrow so you can size the active window with the
arrow keys.

After the pointer changes to the four-headed arrow:
1. Press one of the DIRECTION keys (left, right, up, or down arrow key) to move the pointer 

to the border you want to move. 
2. Press a DIRECTION key to move the border.
3. Press ENTER when the window is the size you want.

Note:    This command is unavailable if you maximize the window.

Shortcut
Mouse: Drag the size bars at the corners or edges of the window.



Move command (Control menu)

Use this command to display a four-headed arrow so you can move the active window or 
dialog box with the arrow keys.

Note:    This command is unavailable if you maximize the window.

Shortcut
Keys: CTRL+F7



Minimize command (application Control menu)

Use this command to reduce the ImageLab window to an icon.

Shortcut

Mouse: Click the minimize icon  on the title bar.
Keys: ALT+F9



Maximize command (System menu)

Use this command to enlarge the active window to fill the available space.

Shortcut

Mouse: Click the maximize icon  on the title bar; or double-click the title bar.
Keys: CTRL+F10 enlarges a document window.



Next Window command (document Control menu)

Use this command to switch to the next open document window. ImageLab determines 
which window is next according to the order in which you opened the windows.

Shortcut
Keys: CTRL+F6



Previous Window command (document Control menu)

Use this command to switch to the previous open document window. ImageLab determines 
which window is previous according to the order in which you opened the windows.

Shortcut
Keys: SHIFT+CTRL+F6



Close command (Control menus)

Use this command to close the active window or dialog box.

Double-clicking a Control-menu box is the same as choosing the Close command.

Note:    If you have multiple windows open for a single document, the Close command on the
document Control menu closes only one window at a time. You can close all windows at once
with the Close command on the File menu.

Shortcuts
Keys: CTRL+F4 closes a document window

ALT+F4 closes the active window or dialog box



Restore command (Control menu)

Use this command to return the active window to its size and position before you chose the 
Maximize or Minimize command.



Switch to command (application Control menu)

Use this command to display a list of all open applications. Use this "Task List" to switch to or
close an application on the list.

Shortcut
Keys: CTRL+ESC

Dialog Box Options
When you choose the Switch To command, you will be presented with a dialog box with the 
following options:
Task List

Select the application you want to switch to or close.
Switch To

Makes the selected application active.
End Task

Closes the selected application.
Cancel

Closes the Task List box.
Cascade

Arranges open applications so they overlap and you can see each title bar. This option 
does not affect applications reduced to icons.

Tile
Arranges open applications into windows that do not overlap. This option does not affect 
applications reduced to icons.

Arrange Icons
Arranges the icons of all minimized applications across the bottom of the screen.



No Help Available

No help is available for this area of the window.



No Help Available

No help is available for this message box.



Print command (File menu)

Use this command to print a document.    This command presents a Print dialog box, where 
you may specify the range of pages to be printed, the number of copies, the destination 
printer, and other printer setup options.

Shortcuts

Toolbar:
Keys: CTRL+P



Print dialog box

The following options allow you to specify how the document should be printed:
Printer

This is the active printer and printer connection. Choose the Setup option to change the 
printer and printer connection.

Setup
Displays a Print Setup dialog box, so    you can select a printer and printer connection.

Print Range
Specify the pages you want to print:
All Prints the entire document.
Selectio
n

Prints the currently selected text.

Pages Prints the range of pages you specify in the From and To boxes.
Copies

Specify the number of copies you want to print for the above page range.
Collate Copies

Prints copies in page number order, instead of separated multiple copies of each page.
Print Quality

Select the quality of the printing. Generally, lower quality printing takes less time to 
produce.



Print Progress Dialog

The Printing dialog box is shown during the time that ImageLab is sending output to the 
printer. The page number indicates the progress of the printing.

To abort printing, choose Cancel.



Print Preview command (File menu)

Use this command to display the active document as it would appear when printed. When 
you choose this command, the main window will be replaced with a print preview window in 
which one or two pages will be displayed in their printed format. The print preview toolbar 
offers you options to view either one or two pages at a time; move back and forth through 
the document; zoom in and out of pages; and initiate a print job.



Print Preview toolbar

The print preview toolbar offers you the following options:
Print

Bring up the print dialog box, to start a print job.
Next Page

Preview the next printed page.
Prev Page

Preview the previous printed page.
One Page / Two Page

Preview one or two printed pages at a time.
Zoom In

Take a closer look at the printed page.
Zoom Out

Take a larger look at the printed page.
Close

Return from print preview to the editing window.



Print Setup command (File menu)

Use this command to select a printer and a printer connection. This command presents a 
Print Setup dialog box, where you specify the printer and its connection.



Print Setup dialog box

The following options allow you to select the destination printer and its connection.
Printer

Select the printer you want to use. Choose the Default Printer; or choose the Specific 
Printer option and select one of the current installed printers shown in the box. You install
printers and configure ports using the Windows Control Panel. 

Orientation
Choose Portrait or Landscape.

Paper Size
Select the size of paper that the document is to be printed on.

Paper Source
Some printers offer multiple trays for different paper sources. Specify the tray here.

Options
Displays a dialog box where you can make additional choices about printing, specific to 
the type of printer you have selected.

Network...
Choose this button to connect to a network location, assigning it a new drive letter.



Delete command (File menu)
Use this command to delete files in the active window.



Save All command (File menu)
Use this command to save all named files with the same name.



Page Setup... command (File menu)
Use this command to setup the top, bottom, left and right margins and to specify the 
information to be included in the header and footer of a printed page.



Select All command (Edit menu)
Use this command to select all album items.



Properties... command (View menu)
Use this command to display the Properties dialog box which lets you set the properties for 
the active window.



Center Graphic command (View menu)
Use this command to center the graphic in the Image Window.



Full Screen command (View menu)
Use this command to display the graphic in the Image Window fullscreen. Click the mouse or
press a key to return to the ImageLab window.



Zoom command (View menu)
Use this command to zoom the graphic in the Image Window.



Resize Image command (Image menu)
Use this command to display the Resize Image dialog box which lets you resize the width 
and height of the image.



Crop command (Image menu)
Use this command to crop the image by selecting just the portion of the image you want to 
use.



Auto Crop command (Image menu)
Use this command to crop the image by identifying a color or range of colors you want to 
strip from the borders of the image.



Color Reduction command (Image menu)
Use this command to reduce the image to monochrome, 16 color or 256 color.



Color Reduction Mono Pattern command (Image menu)
Use this command to use black and white pattern dithering.



Color Reduction Halftone Mono command (Image menu)
Use this command to use small circles of varying size to simulate gray levels.



Color Reduction Mono Diffusion command (Image menu)
Use this command to use black and white diffusion dithering.



Color Reduction 256 Color Popularity command (Image menu)
Use this command to use the most frequently occurring colors in the image as the palette 
colors. Every other color is mapped to the popular colors.



Color Reduction 256 Color Median Cut command (Image menu)
Use this command to select color sets that are represented by approximately the same 
number of pixels in the image.



Color Reduction 256 Color Gray Scale command (Image menu)
Use this command to use a 256-color palette of grays.



Color Reduction 256 Color Octree command (Image menu)
Use this command to use an algorithm to create a palette of the best 256 colors in the 
image and apply them using diffusion dithering.



Color Reduction 256 Color Promotion command (Image menu)
Use this command to convert a monochrome or 16-color image to 256-colors.



Color Reduction 16 Color Octree command (Image menu)
Use this command to use the Octree alogorithm to create 16-color images that use the 16 
colors that best represent the image.



Color Reduction True Color Promotion command (Image menu)
Use this command to convert a monochrom, 16-color, or 256-color image to true color.



Color Reduction 16 Color Promotion command (Image menu)
Use this command to convert a monchrome image to 16-colors.



Color Reduction 16 Color Octree VGA command (Image menu)
Use this command to use the Octree algorithm to create 16-color images that use the 16 
colors that best represent the image.



Color Reduction 16 Color Pattern command (Image menu)
Use this command to use a hatch pattern of standard VGA colors to replace unsupported 
colors.



Color Reduction 16 Color Diffusion command (Image menu)
Use this command to use standard VGA colors to blend areas, creating less severe color 
transitions.



Rotate command (Image menu)
Use this command to rotate the image 90, 180 or 270 degrees.



Rotate 90 command (Image menu)
Use this command to rotate the image 90 degrees.



Rotate 180 command (Image menu)
Use this command to rotate the image 180 degrees.



Rotate 270 command (Image menu)
Use this command to rotate the image 270 degrees.



Flip command (Image menu)
Use this command to flip the image vertically or horizontally.



Flip Horizontal command (Image menu)
Use this command to flip the image horizontally.



Flip Vertical command (Image menu)
Use this command to flip the image vertically.



Add Slides... command (Album menu)
Use this command to display a dialog box which lets you add images to the active album.



Delete Slides command (Album menu)
Use this command to delete the selected images.



Edit Slide... command (Album menu)
Use this command to displays a dialog box that lets you change the name of the image, add 
comments or choose a new image.



Edit Graphic command (Album menu)
Use this command to launch the graphics editor associated with the selected image.



View Graphic command (Album menu)
Use this command to display the selected image in a separate window.



View Graphic Full Screen command (Album menu)
Use this command to display the selected image full screen. Press any key to return to ImageLab.



Create Common Palette command (Album menu)
Use this command to create a common palette for the images in the active album.



Generate Thumbnails command (Album menu)
Use this command to generate thumbnails of each image in the active album.



Image Processing... command (Album menu)
Use this command to display a wizard that lets you flip, rotate, change the size, create an identity 
palette, and/or change the colors of the selected images.



Slide Show command (Album menu)
Use this command to displays the images one at a time in a slide show fashion. Use the Settings 
command in the Options menu to control how the slide show displays.



Abort Processing command (Album menu)
Use this command to stop all processing.



Processing Options command (Album menu)
Use this command to choose to process all images in the album or only selected images.The 
following options are available:

Process All Items
Process Selected Items



Process All Items command (Album menu)
Use this command to process all images in the album.



Process Selected Items command (Album menu)
Use this command to process selected images in the album.



Create Identity Palette... command (Palette menu)
Use this command to display a dialog box which lets you create an identity palette for the selected 
image or palette.



Apply Palette File... command (Palette menu)
Use this command to apply a palette from a file to the selected image.



Apply Palette File & Dither... command (Palette menu)
Use this command to apply a palette from a file to the selected image and dithers it.



Desktop command (Capture menu)
Use this command to capture the entire desktop.



Window... command (Capture menu)
Use this command to capture the active window.



Client Area... command (Capture menu)
Use this command to capture the client area of the active window.



Rectangle... command (Capture menu)
Use this command to capture a rectangular area.



Fixed Rectangle... command (Capture menu)
Use this command to define a fixed size rectangle to capture.



Settings... command (Options menu)
Use this command to set various ImageLab options.



Hide ImageLab command (Capture menu)
Use this command to remove or hide the ImageLab window from the screen while the capture is in 
process.



Zoom 10% command (View menu)
Use this command to zoom in on the selected image at a ratio of 10%.



Zoom 25% command (View menu)
Use this command to zoom in on the selected image at a ratio of 25%.



Zoom 50% command (View menu)
Use this command to zoom in on the selected image at a ratio of 50%.



Zoom 100% command (View menu)
Use this command to zoom in on the selected image at a ratio of 100%.



Zoom 150% command (View menu)
Use this command to zoom in on the selected image at a ratio of 150%.



Zoom 200% command (View menu)
Use this command to zoom in on the selected image at a ratio of 200%.



Zoom 500% command (View menu)
Use this command to zoom in on the selected image at a ratio of 500%.



Zoom 1000% command (View menu)
Use this command to zoom in on the selected image at a ratio of 1000%.



Zoom Fit To View command (View menu)
Use this command to fit the graphic in the Image Window.



Change Format dialog box 
This dialog box appears if you are attempting to save an image to an incompatible file 
format. You can choose to change the number of colors of the image and the color reduction 
method to make the image compatible with the chosen file format.

 



Starting ImageLab
ImageLab lets you manipulate graphics so that they meet your precise needs. You can 
capture, view, and save images, as well as convert them so that they use the proper 
proportions and/or the appropriate number of colors for a particular system. ImageLab lets 
you manipulate individual graphic or palette files, and also lets you work with groups of 
graphics (called albums).
ImageLab is not a graphic editor. That is, it does not create graphic images, nor does it 
merge multiple graphic images.
You can start ImageLab from within IconAuthor or as a standalone application.    
To start ImageLab from within IconAuthor:
1.Choose Editors from the Run menu.

2.Choose ImageLab...

or

1.Press the Editors button on the ribbon bar.

2.Drag and select ImageLab... from the pull-down menu.
To start ImageLab as a stand alone-application:
1.Run Microsoft Windows.

2.Double-click on the ImageLab icon in the IconAuthor program group.

ImageLab is displayed.
Related Topic:Quitting ImageLab  



Initial ImageLab Display
The following figure shows the major components of the ImageLab window.

Title Bar
The title bar shows the name of the application, ImageLab. It also shows the name of a file 
(a graphic, palette or album) that is open, active, and maximized in the work area.
Menu Bar
The ImageLab menus allow you to manipulate graphics, palettes, and albums. The selection 
of menus changes depending on the type of window that is active in the work area.
Ribbon Bar
The ribbon bar lets you click on buttons to quickly perform some of the more frequently used
ImageLab tasks. All of the functions in the ribbon bar are also available through commands 
in the menu bar. 

The ribbon bar buttons are organized into logical groupings that are actually separate tool 
bars that you can move. For example, all of the buttons that let you capture images make up
one discrete part of the bar. To move a toolbar, position the cursor over a non-button portion
of it and drag it to a new location. You can leave the toolbar floating or you can dock it 
elsewhere in the ImageLab window. For example, if you drag the capture toolbar to the right 



side of the work area you can dock it as a vertical bar on the right side of the window.
Work Area
The work area is where you open and manipulate graphic, palette, and album files. Each file 
that you open appears in its own window within the work area.
Status Bar
The left end of the status bar displays hints about the current ribbon bar button or command
on which the cursor is positioned. When a palette file is open in the work area, the right end 
of the status bar displays the RGB value of the cell over which the cursor is positioned.



Supported Graphic Formats in ImageLab
ImageLab supports the following file formats.

Format Read Write
ASCII Yes No
Bitmap Yes Yes
CALS Yes Yes
Clipboard Yes Yes
DCX Yes No
EPS Yes No
GEM Yes No
GIF Yes Yes
HALO Yes No
ICOA Yes No
Icon Yes No
IFF Yes No
JPEG Yes Yes
KOFAX Yes No
LaserData Yes No
MAC Paint Yes No
Microsoft Paint Yes No
PCX Yes Yes
Photo CD Yes No
Photoshop Yes No
PICT Yes Yes
Pixmap Yes Yes
Postscript Yes Yes
Sun Raster Yes Yes
Storyboard Yes Yes
TIFF Yes Yes
Targa Yes Yes
Windows MetaFile Yes Yes
WordPerfect Meta Yes Yes
X Bitmap Yes Yes
X DumpUnix Yes Yes

Manipulating Graphic Files
The first step toward manipulating a graphic file in ImageLab is to bring the file into view. For
example, before you can resize a graphic or change its palette, you need to open the file you
want to use. ImageLab lets you open existing files and create new ones. 
Specifically you can:
Open an existing graphic file.
Start a graphic file by pasting from the Clipboard.
Start a graphic file by capturing an image.



Working with Graphic Files
The first step toward manipulating a graphic file in ImageLab is to bring the file into view. For
example, before you can resize a graphic or change its palette, you need to open the file you
want to use. ImageLab lets you open existing files and create new ones. 
Specifically you can:
Open an existing graphic file.
Start a graphic file by pasting from the Clipboard.
Start a graphic file by capturing an image.



Opening Existing Graphic Files
There are two ways to open existing graphic files. You can use the File Open... command to 
open files. Or, you can open an album file and open a graphic within the album.
Opening an Existing File
To open an existing file:
1. Choose Open... from the File menu or click on the Open Window button in the ribbon bar.

The Open dialog box appears.

2. Use the List Files of Type dialog box to specify that you want to open a graphic file.
3. Find the file you want to open and click on OK.
The file you selected appears in a window in the work area.
Opening a Graphic from within an Album
To open a graphic from within an album you must first open the album.
To open an existing file from within an album:
1. Choose Open... from the File menu.
The Open dialog box appears.
2. Use the List Files of Type dialog box to specify that you want to open an album file.
3. Find the album file you want to open and click on OK.
The file you selected appears in an Album window in the work area. 
4. Select the thumbnail of the graphic you want to view and choose View Graphic from the 
Album menu.
The selected graphic appears in its own window in the work area.

Note: By default, double-clicking on a thumbnail also displays the corresponding graphic in its own 
graphic window. However, you can change the action that results from double-clicking using the 
Settings dialog box.

Related Topic:
Working with Album Files



Pasting an Image from the Clipboard
To paste an image from the Clipboard:
1. Make sure the image you want to paste is on the Clipboard.
You can use one of ImageLabs Capture features to place an image on the Clipboard.
2. Choose New... from the File menu.
The New dialog box appears.

3. Click on Graphic and choose OK.
4. An empty graphic window appears in the work area.

5. Choose Paste from the Edit menu.
The image is pasted into the graphic window. The window is automatically resized to fit the 
image. Each window has a default title such as Graphic1, Graphic2 and so on. However, you 
must explicitly use the File Save command to save the information in the window to a file. 
When you save and name the file, the name of the file appears in the title bar.
Related Topic:
Capturing Images



Capturing Images
Use ImageLabs Capture menu to capture various areas on your screen. Captured images are
automatically placed in new graphic windows in the work area.
Capturing to the Clipboard
If you also want to place the captured image on the Clipboard, use ImageLabs Capture to 
Clipboard option.
To turn on the Capture to Clipboard option:
1. Choose Settings... from the Options menu.
The Settings dialog box appears.
2. Click on the Clipboard tab.

3. Make sure the Capture to Clipboard option is selected.
Note: The BITMAP, DIB and Palette options in this tab of the dialog box also determine what 
information is placed on the Clipboard when you capture an image.    
4. Click on OK.
To hide the ImageLab window while you do a capture operation, make sure that Hide 
ImageLab is selected in the Capture menu. When this option is selected and you choose a 
Capture command, ImageLab temporarily disappears from view. As soon as the capture 
operation is complete, ImageLab appears again. 
You can also turn the Hide ImageLab on and off by clicking on the Hide ImageLab button in 
the ribbon bar.

Related Topics:
Capturing the Desktop
Capturing a Window or Client Area
Capturing a Rectangle or Fixed Rectangle



Capturing an Image
Use ImageLabs Capture menu to capture various areas on your screen. Captured images are
automatically placed in new graphic windows in the work area.
Capturing to the Clipboard
If you also want to place the captured image on the Clipboard, use ImageLabs Capture to 
Clipboard option.
To turn on the Capture to Clipboard option:
1. Choose Settings... from the Options menu.
The Settings dialog box appears.
2. Click on the Clipboard tab.

3. Make sure the Capture to Clipboard option is selected.
Note: The BITMAP, DIB and Palette options in this tab of the dialog box also determine what 
information is placed on the Clipboard when you capture an image.    
4. Click on OK.
To hide the ImageLab window while you do a capture operation, make sure that Hide 
ImageLab is selected in the Capture menu. When this option is selected and you choose a 
Capture command, ImageLab temporarily disappears from view. As soon as the capture 
operation is complete, ImageLab appears again. 
You can also turn the Hide ImageLab on and off by clicking on the Hide ImageLab button in 
the ribbon bar.

Related Topics:
Capturing the Desktop
Capturing a Window or Client Area
Capturing a Rectangle or Fixed Rectangle



Capturing the Desktop
The desktop consists of all information that is visible on the screen.
To capture the entire desktop:
Choose Desktop from the Capture menu or click on the Capture Desktop button in the ribbon
bar.

A picture of the desktop is automatically placed in a new graphic window in the work area. 
The window has scrollbars.



Capturing a Window or Client Area
Although many users consider a window to be a large component on the desktop where an 
application runs, there are actually many other areas that are discrete windows that can be 
captured. For example, a dialog box, and even some areas within a dialog box (such as 
group boxes or text) are windows. ImageLab lets you capture these areas and place them in 
graphic windows. 
The client area is the entire area of a window minus any title bar, scrollbars, and borders 
the window may have. This means that if a window (such as a group box) does not have a 
title bar or scrollbars, the Capture Window and Capture Client Area operations will produce 
the same result.
Menu Bar Technique
Ribbon Bar Shortcut



Menu Bar Technique
To capture a window or client area:
1. Bring up the window you want to capture.
2. Choose Capture Window... or Capture Client Area... from the Capture menu.
Although the following figure shows how the Capture Window dialog box appears, the 
Capture Client Area dialog box is identical.

3. Follow the instructions in the Capture Window dialog box.
Hint: When Step 1 in the dialog box says to Drag the Capture Cursor it means that you should 
actually drag the picture of the capture cursor that is in the lower right corner of the dialog box.

The main ImageLab window will be hidden during the capture operation if the Hide 
ImageLab option is selected in the Capture menu. When you finish the operation, the image 
appears in a new graphic window. Each window has a default title such as Graphic1, 
Graphic2 and so on. However, you must explicitly use the File Save command to save the 
information in the window to a file. When you save and name the file, the name of the file 
appears in the title bar.

Note: Z-Order refers to the layering of windows. As an example, all of the windows that comprise a 
dialog box (e.g. the empty dialog box, the group boxes and text within the dialog, etc.) are layered 
according to Z-Order when they are first created by an engineer. By default, when you use the 
Capture Window feature, the windows that you can capture are at the bottom of the Z-Order. If you 
are unable to capture a window, turn on the Reverse Z-Order Search option before doing the capture. 
In most cases this will allow you to capture windows that were previously obscured by other windows 
that have a lower Z-Order.



Ribbon Bar Shortcut
Experienced users may prefer to simply use the ribbon bar to capture a window or client 
area.
To capture a window or client area:
1. Bring up the window or client area you want to capture.
2. Drag the appropriate Capture Cursor from the ribbon bar.

3. Position the cursor over the desired area and release the left mouse button.



Capturing a Rectangle or a Fixed Rectangle
ImageLab lets you use two commands to capture a rectangular area of the screen. When 
you use the Capture Rectangle feature, you grab the selection cursor and draw a box around
the information you want to capture. When you use the Capture Fixed Rectangle feature, 
first you use the dialog box to specify the size of the area you want to capture, then you use 
the selection tool to identify the area on the screen. The Capture Fixed Rectangle feature is 
particularly useful if you want to do several captures of images that you want to be identical 
in size.
Menu Bar Technique
To capture a rectangle:
1. Bring up the information you want to capture.
2. Choose Capture Rectangle... or Capture Fixed Rectangle... from the Capture menu.
The following figure shows how the Capture Rectangle dialog box appears.

The following figure shows how the Capture Fixed Rectangle appears.

3. Follow the instructions in the dialog box.
The main ImageLab window will be hidden during the capture operation if the Hide 
ImageLab option is selected in the Capture menu. When you finish the operation, the image 
appears in a new graphic window. 
Ribbon Bar Shortcuts



Ribbon Bar Shortcuts
Experienced users may prefer to simply use the ribbon bar to capture a rectangle or fixed 
rectangle.
To capture a rectangle:
1. Bring up the information you want to capture.
2. Drag the Capture Rectangle cursor from the ribbon bar to the rectangle starting position.

3. While the left button is down, press the right mouse button to start the selection.
4. Draw a rectangle around the area you want to capture.
5. Release the left mouse button to capture the rectangle.
To capture a fixed rectangle:
1. Bring up the information you want to capture.
2. Drag the Capture Fixed Rectangle cursor from the ribbon bar to the rectangle starting 
position. 

3. Position the rectangle over the image you want to capture.
4. Release the left mouse button to capture the rectangle.
Note: The Capture Fixed Rectangle tool uses the current dimension settings. If you need to 
change the dimensions, open the Capture Fixed Rectangle dialog box via the Capture menu.



Graphic File Views
Once a graphic window is open, you can view its properties, resize the window, and you can 
split the window to show up to three views of the image.
Related Topics:
Graphic File Properties
Showing Side-by-Side Views of the Graphic
Changing the Different Views of the Graphic
Showing a Graphics Palette
True-Color Graphics on 256-Color Systems



Graphic File Properties
Each type of file has properties (characteristics) that you can view. For example, when you 
view the properties of a graphic file ImageLab tells you the format and size of the file.
To view a graphic files properties:
1. Make sure it is the active window.
2. Choose Properties from the view menu or click on the Properties button in the ribbon bar.

The Properties dialog box appears. The following figure shows an example of how the 
Properties for a graphic might appear.

Note: If you have not yet saved the image to a file, the File Name, File Size and Last Modified
Date fields are empty.



Showing Side-by-Side Views of the Graphic
Two side-by-side views of the graphic can be extremely useful. For example, you can leave 
one view in its original state and use the other view to zoom in and examine the use of 
colors more closely. (When you zoom in on an image the close-up view automatically has 
scrollbars.) 
To split the window into two graphic views:
1. Position the cursor near the right side of the graphic window.
The cursor appears as a vertical splitter. 

2. Drag the splitter to the left.
This divides the view of the graphic window to show another copy of the image.
3. As necessary, you can resize the window to increase the amount of space available to 
each view. 



Changing the Different Views of the Graphic
When a graphic window is active, ImageLab lets you use the View menu commands to 
manipulate the different views of the graphic. For example, you can center one view and 
zoom the other. The following commands are available in the View menu:

Command: Purpose:
Center 
Graphic

Centers the graphic in the view area.

Full Screen The view takes up the full screen and shows the graphic in its 
true dimensions.

Zoom Allows you to zoom the graphic from 10-1000%. Also allows you
to select the FitToView command which scales the image to 
always fit in the view area (regardless of how you might resize 
the window).

Showing a Graphics Palette
In addition to showing side-by-side views of a graphic, a third view of the graphic window 
lets you look at the palette being used. 
To show the graphics palette view:
1. Position the cursor near the bottom of the graphic window.
The cursor appears as a horizontal splitter. 

2. Drag the splitter upward.
3. This horizontally splits the view so that the palette view appears in the bottom portion of 
the graphic window. 
The following figure shows one example of how the palette may appear.

16-color graphic
As necessary, you can resize the window to increase the amount of space available to each 
view. When you position the cursor over a cell in the palette, the Index number and RGB 
value of the current color appears in the ImageLab status bar. To edit the color, double-click 
on the cell. The Edit Palette Entry dialog box appears similar to the following.





True-Color Graphics on 256-Color Systems
When you use ImageLab to view a true-color graphic in 256-colors, ImageLab applies a 256-
color rainbow palette to the image. It is up to you to specify how you want ImageLab to 
compensate for unsupported colors.
Choose Settings... from the Options menu to display the Settings dialog box and make sure 
the General tab is in view. The dialog box appears similar to the following.

The options on this tab represent the different algorithms that you can automatically apply 
to true color images that are displayed on a 256-color system. Specifically, each of the 
options uses quantization and/or dithering algorithms. Quantization is the method used 
for selecting appropriate colors to include in the palette during the reduction process. Given 
the selected colors, dithering is the method used to position the available colors among the 
pixels that make up the resulting image.
Without dithering, the reduction process simply replaces every pixel of an unsupported color
with a supported color. The resulting effect is likely to use very jagged edged areas of color 
that do not blend gradually into adjacent areas. If you opt to use dithering however, the two 
general methods are pattern and diffusion. Pattern dithering replaces a block of pixels 
with pixels that use two alternating colors that the human eye perceives as a third color. For 
example, an patterned area of blue and red pixels can be perceived as purple. Diffusion 
dithering takes each pixel and comes as close as possible to matching the original color. It 
then calculates the difference between the old and new colors and spreads the difference 
among the colors of neighboring pixels. 
Related Topic:
Available Reduction Methods



Available Reduction Methods
The following table describe the different reduction methods that are available:

Method: Description:
None Uses the Windows default mapping, replacing each 

unsupported color with the closest available color. 
Pattern This is the fastest dithering method, using a hatch 

pattern of available colors to replace unsupported 
colors.

Diffusion This dithering method distributes the color error to 
adjacent pixels, using the colors that are available in 
the rainbow palette that comes with ImageLab.

Median Cut Creates a palette of optimal colors and applies them 
using diffusion dithering.

Octree Optimized 
Palette

Uses an alternative method to create a palette of the 
best 256 colors in the image and applies them using 
diffusion dithering.

Octree Common 
Palette

Uses the default palette that ImageLab uses for Album
displays and applies it using diffusion dithering.

Changing Graphic Files
ImageLab lets you make the following kinds of changes to graphic files:
resizeResizing_Graphics
cropCropping_Graphics
reduce colorsColor_Reduction
rotate and flipImage_Rotation_and_Flipping
create identity paletteCreating_an_Identity_Palette
apply different paletteApplying_an_Alternative_Palette
change colors in the paletteChanging_or_Adding_a_Palette_Color
change file formatChanging_File_Format
You can manipulate individual graphics or you can change multiple graphics simultaneously 
using album files.
Important: When you change a single graphic within a graphic window, the changes are not 
saved to the file until you explicitly choose Save or Save As... from the File menu. This 
means that if you change an image and have not yet saved it, you can reopen the original 
unchanged file.



Resizing Graphics
To change image dimensions, choose Resize Image... from the Image menu. The Resize 
Image dialog box appears similar to the following.

If you specify new values and change your mind while the dialog box is still open, click on 
the Defaults button. This returns the values that were displayed when you opened the dialog
box. If you click OK to close the dialog box and then change your mind, choose Undo from 
the Edit menu (or press CTRL + Z).
Related Topics:
Setting Specific Dimensions
Scaling the Image



Setting Specific Dimensions
Use the fields in the Dimensions area to set a specific width and height (in pixels) for the 
currently selected graphic. You can set both fields or you can set one field and the other is 
automatically updated to maintain the original proportions of the image if the Maintain 
Aspect Ration option is selected. 
To set the Width and Height fields to values that do not retain the original proportions of the 
graphic, turn off the Maintain Aspect Ratio option. Be aware that stretching or compressing 
may distort the image. For example, the following figures show an image before and after it 
was resized by changing only the width value:

Original graphic Width value increased from 50 to 100 pixels
The figure appears horizontally stretched because it is no longer proportionate.



Scaling the Image
Use the Scale field to change the images width and height proportionately. For example, the 
following figures show an image before and after it was scaled by 50%.

Original graphic

Image decreased by 50% scaling

Cropping Graphics
ImageLab lets you use two methods to crop graphics. You can crop by selecting just the 
portion of the image you want to use or you can identify a color or range of colors you want 
to strip from the borders of the image.
Related Topics:
Selecting an Area to Crop
Identifying Border Colors to Crop



Selecting an Area to Crop
To select an area to crop:
Make sure the graphic you want to alter is open and active.
1. Draw a rectangle around the part of the image you want to use.
2. Move or resize the selection rectangle as necessary.
You can position the cursor on one of the eight sizer blocks and drag to resize the rectangle. 
Or, position the cursor inside the rectangle and drag it to a new location. The coordinates of 
the current mouse position appear in the POS field of the status bar. The status bars SEL 
field identifies the coordinates of the upper left corner and the height and width of the 
selected area.
3. Choose Crop from the Image menu.
The graphic window contains only the selected area. To undo the crop operation, choose 
Undo from the Edit menu before performing any other operation.



Identifying Border Colors to Crop
Cropping an image by removing colors from its borders is called autocropping. When you use
the AutoCrop command ImageLab starts with the top left pixel and scans all four sides of the
image. If all the pixels in a line are the same color, the line is removed from the image. 
By default, the sensitivity of this feature is set to 10. This means that when ImageLab scans 
a pixel it looks to see if the values that make up its RGB value are within 10 (plus or minus) 
of the top left pixel in the image. For example, if the top left pixel is 20,20,20 and the other 
pixels in the top row are between 11,11,11 and 29,29,29 the line is removed.    
To set the AutoCrop sensitivity:
1. Choose Settings... from the Options menu.

2. Reset the AutoCrop Sensitivity field as desired and click OK.
To AutoCrop:
1. Make sure the graphic you want to alter is open and active.
2. Choose AutoCrop from the Image menu.
ImageLab strips lines from all sides of the image based on the color of the top left pixel and 
the AutoCrop Sensitivity setting.



Color Reduction
ImageLab lets you reduce 
graphics to monochrome, 16-
color or 256-color. It also lets you
promote graphics to 256-color or 
true color. To change image 
colors, select the graphic you 
want to change and choose Color
Reduction from the Image menu. 
The figure to the right shows the 
cascading menu of options that 
displays.
The available commands depend
on the type of graphic that is 
currently selected. Most of the 
options reflect different 
algorithms that are available for 
reducing the colors in the 
currently displayed image. (The 
last two promotion options

let you promote a graphic to 256-color or true color.) Specifically, each of the options uses 
quantization and/or dithering algorithms. Quantization is the method used for selecting 
appropriate colors during the reduction process. Given the selected colors, dithering is the 
method used to position the available colors.
Without dithering, the reduction process simply replaces every pixel of an unsupported color
with a supported color. The resulting effect is likely to use very jagged edged areas of color 
that do not blend gradually into adjacent areas. If you opt to use dithering however, the two 
general methods are pattern and diffusion. Pattern dithering replaces a block of pixels 
with pixels that use two alternating colors that the human eye perceives as a third color. For 
example, an area of blue and red pixels can be perceived as purple. Diffusion dithering 
takes each pixel and comes as close as possible to matching the original color. It then 
calculates the difference between the old and new colors and spreads the difference among 
the colors of neighboring pixels. 
If you are a computer graphic designer, it is likely that you will recognize most of the options
in this menu. In contrast, users who are more novice should experiment with the available 
commands to find the results that they find most suit their needs. There is often a 
substantial difference in the results that you achieve, depending on the way colors are used 
in the original graphic and the menu option you choose. 
Note: Dithering and quantization algorithms are typically complex. If you are interested in 
learning more about specific algorithms, it is recommended that you obtain to more 
advanced reference materials on palettes. 
Related Topic:
Color Reduction Commands



Color Reduction Commands
The following table provides descriptions of the various commands.

Command: Purpose:
Mono Pattern Uses black and white pattern dithering.
Mono Halftone Uses small circles of varying sizes to simulate gray 

levels.
Mono Diffusion Uses black and white diffusion dithering.
16 Color Pattern Uses a hatch pattern of standard VGA colors to replace 

unsupported colors.
16 Color Diffusion Uses standard VGA colors to blend areas, creating less 

severe color transitions.
16 Color Octree VGA Uses the Octree algorithm to create 16-color images 

that use the standard VGA static system colors.
16 Color Octree Uses the Octree algorithm to create 16-color images 

that use the 16 colors that best represent the image.
256 Color Gray Scale Uses a 256-color palette of grays.
256 Color Popularity Uses the most frequently occurring colors in the image 

as the palette colors. Every other color is mapped to 
the popular colors.

256 Color Median 
Cut

Selects color sets that are represented by 
approximately the same number of pixels in the image.

256 Color Octree Uses an algorithm to create a palette of the best 256 
colors in the image and applies them using diffusion 
dithering. 

256 Color Promotion Converts a monochrome or 16-color image to 256-
colors.

True Color Promotion Converts a monochrome, 16-color, or 256-color image 
to true color.

If you choose a command and are not satisfied with the color reduction, before doing any 
other action, choose Undo from the Edit menu (or press CTRL + Z).



Image Rotation and Flipping
To rotate an image, choose Rotate from the Image menu and choose to rotate the image 90, 
180, or 270 degrees. To flip an image, choose Flip from the Image menu and choose to flip 
the image horizontally or vertically.
If you choose a command and are not satisfied with the new image, before doing any other 
action, choose Undo from the Edit menu (or press CTRL + Z).



Creating an Identity Palette
ImageLab lets you create an identity palette  for a 256-color graphic.
To create an identity palette:
1. Make sure the graphic you want to alter is open and active.
2. Choose Create Identity Palette... from the Palette menu.

Table Lookup option - This option is available when your system is running in any color 
depth. It causes ImageLab to detect whether the graphic uses an identity palette. If the 
graphic already has an identity palette, ImageLab replaces the system colors in the first and 
last ten palette positions, using VGA system colors. If the graphic does not have an identity 
palette, ImageLab shifts the colors in the palette to make room for the first ten system 
colors and fills the last ten positions with the appropriate system colors. Note that this 
means that some colors may be lost (if the image used more than 236 colors) when the 
system colors are added to the palette.
Palette Manager option - This option is only available (and is the default) when your system 
is running in 256 colors. ImageLab realizes the graphics palette into the system palette. If 
any positions in the graphics palette previously contained any system colors, those positions
are stripped from the palette. 
3. Click on OK.



Identity Palette 
An identity palette is a variation of the conventional palette that is part of a 256-color 
bitmap. When you make a palette into an identity palette, you pre-assign the 20 system 
colors to the first ten and last ten reserved positions in the palette. When the bitmaps 
identity palette is realized into the system palette, the first color in the bitmaps palette is 
mapped to position 1. The second color is mapped to position 2 and so on.
The easiest way to create an identity palette for a bitmap is to use the Create Identity Palette... command.
This command lets you automatically create an identity palette.



Applying an Alternative Palette
ImageLab lets you assign a palette to 256-color graphic.
To assign a palette file:
1. Choose Apply Palette File... from the Palette menu.
The Open dialog box appears.

2. Select the palette file you want to use and click on OK.
You can also use the Apply Palette File & Dither... command to dither an image at the same 
time as you apply an alternative palette file. This method uses a standard diffusion dithering
algorithm.



Changing or Adding a Palette Color
You change one or more colors in an images palette.
To change or add a palette entry:
1. Make sure the graphic is in the active window. 
2. Position the cursor near the bottom of the graphic window.
The cursor appears as a horizontal splitter. 

3. Drag the splitter upward.
4. This horizontally splits the view so that the palette view appears in the bottom portion of 
the graphic window. 
As you move the cursor over the palette, the Index number and RGB value of the current cell
appear in the right side of the ImageLab status bar.
5. Double-click on a cell that you want to edit or if the palette contains less than the full 
complement of entries, double-click in the gray area where there is room to add an entry.
The Edit Palette Entry dialog box appears similar to the following.

6. Change components of the RGB value as necessary.
Drag the slider bars to adjust the Red, Green, and Blue intensities. The changes you make 
are reflected in the sample color area at the bottom of the dialog box. You can also remove a
color from the palette by clicking on the Delete button. 
7. When you are satisfied with the changes, click on OK to close the dialog box. 
If you double-clicked on an existing position, the color changes are in effect. If you added a 
new color to the palette, the new entry is added.
Note: You can also double-click to add a palette entry to a palette file that is open in its own 
window.



Changing File Format
ImageLab lets you change the file format of a graphic.
To change file format:
1. Make sure the graphic you want to alter is open and active.
2. Choose Save As... from the File menu.

3. Use the Save File as Type field to specify the file format you want to use and click on OK.
Note: In some situations, an error message appears informing you that the conversion you 
have chosen is not supported.
Related Topic:
Saving JPEG Files



Saving JPEG Files
ImageLab has a feature that lets you set how compression works when you save a file in the 
JPEG format. The more compressed a file is, the lower the quality. The less a file is 
compressed, the higher the quality.
To set the JPEG compression option:
1. Choose Settings... from the Options menu.
2. Make sure the General tab is selected.

3. Set the JPEG Quality % field as desired.
As an example, 100% is the highest quality you can set, however it also produces the largest
file size. 50% would produce a reduced quality image in a much smaller file size.



Album Files in ImageLab
Albums are groups of items that represent bitmap graphics. Initially an album is empty and 
you identify which graphics you want it to contain. Once graphics are placed in an album, 
you can do the following kinds of operations:
View thumbnails of album graphics.
Display a slide show of graphics in the album.
Change (colors, size, format, etc.) for individual or selected graphics.

Related Topics:
Creating Albums
Adding Slides to Albums
Editing Slides
Viewing Album Properties



Manipulating Album Files
Albums are groups of items that represent bitmap graphics. Initially an album is empty and 
you identify which graphics you want it to contain. Once graphics are placed in an album, 
you can do the following kinds of operations:
View thumbnails of album graphics.
Display a slide show of graphics in the album.
Change (colors, size, format, etc.) for individual or selected graphics.

Related Topics:
Creating Albums
Adding Slides to Albums
Editing Slides
Viewing Album Properties



Creating Albums
Before you can add graphics to an album, you need to create the album.
Starting New Albums
To begin a new album:
1. Choose New... from the File menu, press CTRL +N, or click on the New File button in the 
ribbon bar.

The New dialog box appears.

2. Click on OK.
The new album appears.

You can now add new graphics to the album.



Adding Slides to Albums
To add files to an album:
1. Make sure the album file is open and active.
2. Choose Add Slides... from the Album menu.
The Open dialog box appears.

3. In the File Name list box, select files that you want to add.
4. Click on the OK button.
The following figure shows an example of how an album might appear after two files have 
been added to it.

Note: You can also add a graphic slide to an album by dragging the name of the file from the
File Manager and dropping it within an Album window.



Editing Slides
The Edit Slide command provides three ways in which you can edit the slides that appear 
within an album. You can:
+    Change the label that appears below the slide. By default it is the filename, however, 
you can specify an alternative word or phrase. 
+    Record and store comments about the slide.
+    Change the file that appears in the slide.
To edit a slide:
1. Click on the slide to select it.
2. Choose Edit Slide... from the Album menu.
3. Use the Title field to change the title that appears beneath the slide.
4. Use the Comment field to enter notes about the slide.
5. Use the Browse... button to search for an alternative graphic to display in the slide.
6. If you change the file, the new path and filename appear in the Filename field.
7. When you are finished editing the slide click OK.



Viewing Album Properties
ImageLab lets you view the properties of the active album file.
To view an album files properties:
1. Make sure it is the active window.
2. Choose Properties... from the view menu.
The Album Properties dialog box appears. The following figure shows an example of how the 
album properties might appear.

Clicking on the Slide tab shows you information about the currently selected slide.



Viewing Album Thumbnails
If an album contains more images than can be seen at one time, it has scrollbars. By default,
the images that you add appear as thumbnails (small representations of the larger graphic). 
As you add graphics, the thumbnails are updated. 
To turn off the automatic updating of thumbnails:
1. Make sure an album is open and active.
2. Choose Settings... from the Options menu.
3. Click on the Album tab.
4. Deselect the Automatic Thumbnail Generation option and click on OK.

The following figure shows an example of how two thumbnails appear when you add slides 
to an album and Automatic Thumbnail Generation is off.

To generate the thumbnails, either turn on the Automatic Thumbnail Generation option, 
choose Generate Thumbnails from the Album menu, or click on the Generate Thumbnails 
button in the ribbon bar.

Related Topic:
Opening Graphics from an Album Thumbnail



Opening Graphics within an Album
There are several ways to open a graphic from an album thumbnail. You can view the image 
in its own window, view the image full screen, or bring the image up in a graphics editor.
Note: If you try to open an image that has been deleted from the directory (but is still in the 
album file), a message appears notifying you that the file cannot be found.
Related Topics:
Opening an Album Item in a Graphic Window
Viewing an Album Item Full Screen
Viewing an Album Item in a Graphics Editor



Opening an Album Item in a Graphic Window
To open an album item in a graphic window:
+ Choose View Graphic from the Album menu.
You can also double-click on the graphic thumbnail to open it in a graphic window. Note that 
this action occurs only if you have not changed the default double-click action. The double-
click action is set in the Album tab of the Settings dialog box (available through the Options) 
menu.



Viewing an Album Item Full Screen
To view an album item full screen:
+    Choose View Graphic Full Screen from the Album menu.
You can also change the default so that the item appears full screen when you double-click.
To view album an item full screen on double-click:
1. Choose Settings... from the Options menu.
The Settings dialog box appears.
2. Click on the Album tab.
In the DoubleClick Action area, select View Full Screen.

3. Click on OK.
The next time you double-click on an album item, the graphic will appear full screen. To 
return to ImageLab, click on the screen.



Viewing an Album Item in a Graphics Editor
In order to launch a graphics editor from within ImageLab, you must first associate the 
desired file extension with the appropriate editor.
After you have associated a graphics editor with each file extension you plan to use, you are 
ready to launch the editor from the album slide.
To open an album item in a graphics editor:
+    Choose Edit Graphic from the Album menu.
To open an album item in a graphic editor on double-click:
1. Choose Settings... from the Options menu.
2. Click on the Album tab in the Settings dialog box.
3. In the DoubleClick Action area, select Edit Image.

4. Click on OK to close the Settings dialog box.
The next time you double-click on an album item, the graphic will appear in the 
corresponding editor.
Related Topic:
Associating a Graphics Editor with a Graphic File Extension



Associating a Graphics Editor with a Graphic File Extension
To associate a graphics editor with a graphic file extension:
1. Choose Settings... from the Options menu.
2. Click on the Editors tab.

As shown in the previous figure, by default, .BMP files are set up to launch Paintbrush.
3. Click on the Add... button.
The Add Extension dialog box appears.

4. Enter the file extension you want to associate with an editor and click on OK.
The extension is returned to File Type list in the Editors tab.
5. Click in the Editor field.
6. Click on the Browse... button. 
An Open dialog appears.
7. Use the Open dialog to search for the name of the executable you want to launch. 
8. When you select the appropriate filename, click on OK.
The filename is automatically returned to the Editor field in the Editors tab.
9. Use the Command Line field to specify any additional command line parameters you want
to use when the editor is launched. 
For example, a program might may have a parameter that causes it to appear fullscreen 
when it is launched. For information on available parameters, refer the documentation that 
accompanies the editor you want to run. 
Do not remove the %f parameter. It marks the placeholder for the filename you want to 
open.
10. Optionally, click on the Display Maximized option if you want the editor to appear 



maximized when it runs.
11. Repeat steps 3 through 10 as necessary to add more extensions and editors.



Displaying Album Slide Shows
ImageLab also lets you display all of the items in an album in slide show fashion.
To run a slide show:
+    Choose Slide Show from the Album menu.
The screen clears to black and the album items appear centered on the screen one after another.

To change the slide show options:
1. Choose Settings... from the Options menu.
2. Click on the Slide Show tab.

3. Use the Layout area to specify how each image should appear.
Size to Graphic - Shows each graphic centered in its proper dimensions.
Fit To View - Shows each graphic as large as possible, while maintaining its proper 
dimensions.
Stretch To Fit - Shows each graphic full screen, possibly distorting it horizontally or vertically 
to make it fit.
4. Use the Slide Control option to specify how one slide is displayed after another.
Delay Time - This is the number of seconds until the next image appears.
Manual Control - This lets the user click to proceed to the next slide.
5. Use the Background Color option to change from black to another color of your choice.
6. Use the Effect list to select the special display effect used when a graphic appears.
7. Use the Hide Cursor option to remove the cursor from view when the slide show runs.
8. Use the Loop option to cause the slide show to continue repeatedly until the user presses 
Esc.
9. When you are satisfied with the settings, click on OK to close the dialog box.



Changing Album Graphics
This section describes how to alter one or more images from within an album file. This is a 
particularly powerful feature because you can make the same changes to many files all at 
once. For example, you can convert all the graphics for your application from 256-colors to 
16-colors, or you can apply the same palette to all the graphics in a directory.
ImageLab lets you make the same kinds of changes to graphics within albums that you can 
make to individual graphics. You can:
resize
reduce or promote colors
rotate and flip
create an identity palette
apply a different palette
change file format
When you make these kinds of changes to one or more images from within an album, you 
have the option of changing the original graphic files or creating new graphic files in an 
alternative directory. 
Caution: If you choose to change the original graphic files, the changes you make are 
permanent and cannot be undone.
Related Topic:
Selecting Album Graphics to Change



Selecting Album Graphics to Change
By default, ImageLab applies changes to selected graphics in an album. The alternative to 
this default is to automatically process all items in an album.
The following paragraphs describe how to select the images you want to alter.
To select a single graphic:
+ Click on the graphic.
The name of the graphic you select is highlighted. 

To select multiple contiguous graphics:
1. Click on the first graphic you want to select.
2. While pressing and holding the Ctrl key, click on any other graphics you want to select.
To select a range of graphics:
1. Click on the first graphic in the range.
2. While pressing and holding the Shift key, click on the last graphic in the range.
To select all graphics in the album:
+ Choose Select All from the Edit menu.
The name of the graphic you select is highlighted. Once you have selected the appropriate 
thumbnails, you are ready to change them as necessary.
To automatically process all graphics in the album:
If you prefer to process all the images in an album without selecting them, choose 
Processing Options from the Album menu and then choose Process All Items. To return to 
processing selected items only, choose Processing Options from the Album menu and then 
choose Process Selected Items.



Resizing Album Graphics
To change image dimensions:
1. Within the album, select the thumbnails you want to change.
2. Choose Image Processing... from the Album menu.
The Image Processing Wizard appears.

3.    Select Resize Image from the drop-down list and click on the Next button.
4.    Enter the Width and Height that you want to apply to all the selected graphics in the 
album and click on the Next button.
5.    Specify whether you want to overwrite the existing images or create new images.
6.    If you choose to overwrite the existing images, click on the Finish button to complete the
resize operation. 
Remember, if you overwrite existing images, the changes are permanent.
7.    If you choose to create new images, click on the Next button. The last screen will ask 
you to indicate the directory where you want to create the new images. 
When you click on the Finish button, the selected images are resized. 
To halt processing:
· Choose Abort Processing from the Album menu or click on the Abort Processing 
button in the ribbon bar.



Color Reduction or Promotion of Album Graphics
ImageLab lets you reduce graphics to monochrome, 16-color or 256-color. It also lets you 
promote graphics to 256-color or true color. 
To change image colors:
1. Within the album, select the thumbnails you want to change.
2. Choose Image Processing... from the Album menu.
The Image Processing Wizard appears.
3. Make sure that Color Reduce/Promote is selected in the drop-down list and click on the 
Next button.
4. Use the Number of Colors area to indicate the reduction or promotion you want to 
perform.
For example, if you have selected a group of 256-color images and want to make them 16-
color, click on the 16 Colors (4-bit) option.
5. Use the Dither/Quantization drop-down list to select the reduction or promotion algorithm 
you want to use to alter the images. 
Most of the options reflect different algorithms that are available for reducing the colors in 
the currently displayed image. (The 256 Color Promotion, actually lets you promote a 256 
color graphic to true color.) Specifically, these of the options uses quantization and/or 
dithering algorithms. Quantization is the method used for selecting appropriate colors 
during the reduction process. Given the selected colors, dithering is the method used to 
position the available colors. 
Without dithering, the reduction process simply replaces every pixel of an unsupported color
with a supported color. The resulting effect is likely to use very jagged edged areas of color 
that do not blend gradually into adjacent areas. If you opt to use dithering however, the two 
general methods are pattern and diffusion. Pattern dithering replaces a block of pixels with 
pixels that use two alternating colors that the human eye perceives as a third color. For 
example, an area of blue and red pixels can be perceived as purple. Diffusion dithering takes
each pixel and comes as close as possible to matching the original color. It then calculates 
the difference between the old and new colors and spreads the difference among the colors 
of neighboring pixels. 
If you are a computer graphic designer, it is likely that you will recognize most of the options
in this menu. In contrast, users who are more novice should experiment with the available 
commands to find the results that they find most suit their needs. There is often a 
substantial difference in the results that you achieve, depending on the way colors are used 
in the original graphic and the menu option you choose. 
Note: Dithering and quantization algorithms are typically complex. If you are interested in 
learning more about specific algorithms, it is recommended that you obtain to more 
advanced reference materials on palettes. 
Related Topics:
Dither/Quantization Choices for Monochrome 
ImagesDither_Quantization_Choices_for_Monochrome_Images
Dither/Quantization Choices for 256-Color 
ImagesDither_Quantization_Choices_for_256_Color_Images
Dither/Quantization Choices for True Color 
ImagesDither_Quantization_Choices_for_True_Color_Images



Dither/Quantization Choices for Monochrome Images
For Monochrome images the Dither/Quantization choices are:
Pattern - Uses black and white pattern dithering.
Halftone - Uses small circles of varying sizes to simulate gray levels.
Error Diffusion - Uses black and white diffusion dithering.
For 16-Color images the Dither/Quantization choices are:
Pattern - Uses a hatch pattern of standard VGA colors to replace unsupported colors.
Error Diffusion - Uses standard VGA colors to blend areas, creating less severe color 
transitions.
Octree VGA - Uses the Octree algorithm to create 16-color images that use the standard VGA
static system colors.
Octree - Uses the Octree algorithm to create 16-color images that use the 16 colors that are 
most used in the image.



Dither/Quantization Choices for 256-Color Images
For 256-Color images the Dither/Quantization choices are:
Gray Scale - Uses a 256-color palette of grays.
Popularity - Uses the most frequently occurring colors in the image as the palette colors. 
Every other color is mapped to the popular colors.
Median Cut - Selects color sets that are represented by approximately the same number of 
pixels in the image.
Octree - Uses an algorithm to create a palette of the best 256 colors in the image and 
applies them using diffusion dithering.



Dither/Quantization Choices for True Color Images
For True Color images the Dither/Quantization choices are:
True Color Promotion - Converts a monochrome, 16-color, or 256-color image to true color.
1. Click on the Next button.
2. Specify the file format you want to use for the files and click on the Next button.
3. Specify whether you want to overwrite the existing images or create new images.
4. If you choose to overwrite the existing images, click on the Finish button to complete 
the reduction/promotion operation. 
5. Remember, if you overwrite existing images, the changes are permanent.
6. If you choose to create new images, click on the Next button. The last screen will ask 
you to indicate the directory where you want to create the new images. 
When you click on the Finish button, the selected images are color reduced or promoted. 

To halt processing:
+    Choose Abort Processing from the Album menu or click on the Abort Processing button in 
the ribbon bar.



Image Rotation and Flipping in Albums
To change rotate or flip images:
1. Within the album, select the thumbnails you want to change.
2. Choose Image Processing... from the Album menu.
The Image Processing Wizard appears.
3. Select Flip Image or Rotate Image from the drop-down list and click on the Next button.
4. Specify how you want to change the orientation of the images. 
If you chose Flip Image, indicate whether you want to flip horizontally or vertically. If you 
chose Rotate, indicate whether you want to rotate 90, 180, or 270 degrees.
5. Click on the Next button.
6. Specify whether you want to overwrite the existing images or create new images.
7. If you choose to overwrite the existing images, click on the Finish button to complete the 
flip or rotate operation. 
Remember, if you overwrite existing images, the changes are permanent.
8. If you choose to create new images, click on the Next button. The last screen will ask you 
to indicate the directory where you want to create the new images. 
When you click on the Finish button, the selected images are re-oriented. 
To halt processing:
+    Choose Abort Processing from the Album menu or click on the Abort Processing button in 
the ribbon bar.



Creating an Identity Palette for Album Graphics
ImageLab lets you create an identity palette for 256-color graphics.
To make an identity palette for album graphics:
1. Within the album, select the thumbnails you want to change.
2. Choose Image Processing... from the Album menu.

The Image Processing Wizard appears.

3. Select Palette-Create Identity from the drop-down list and click on the Next button.
4. Specify the kind of information you want to be used in the identity palette and click on the
Next button.
Table Lookup option - This option is available when your system is running in any color 
depth. It causes ImageLab to detect whether the graphic uses an identity palette. If the 
graphic already has an identity palette, ImageLab replaces the system colors in the first an 
dlast ent palette postiions, using VGA system colors. If the graphic coes not have an identity 
palette, ImageLab shifts the colors in the aplette to make room for the first ten system 
colors and fills the last ten positions with the appropriate system colors. Note that this 
means that some colors may be lost (if the image used more than 236 colors) when the 
system colors are added to the palette.
Palette Manager option - This option is only available (and is the default) when your system 
is running in 256 colors. ImageLab realizes the graphics palette into the system palette. If 
any positions in the graphics palette previously contained any system colors, those positions
are stripped from the palette.
5. Specify whether you want to overwrite the existing images or create new images.
6. If you choose to overwrite the existing images, click on the Finish button to complete the 
operation. 
Remember, if you overwrite existing images, the changes are permanent.
7. If you choose to create new images, click on the Next button. The last screen will ask you 
to indicate the directory where you want to create the new images. 
When you click on the Finish button, an identity palette is assigned to the selected images. 
To halt processing:
+    Choose Abort Processing from the Album menu or click on the Abort Processing button in 
the ribbon bar.



Applying an Alternative Palette File to Album Graphics
ImageLab lets you assign a palette to 256-color graphic.
To apply a palette to album graphics:
1. Within the album, select the thumbnails you want to change.
2. Choose Image Processing... from the Album menu.
The Image Processing Wizard appears.
3. Select Palette-Apply from File from the drop-down list and click on the Next button.
4. Specify the name of the palette file you want to use and whether or not you want to use 

dithering.
5. Click on the Next button.
6. Specify whether you want to overwrite the existing images or create new images.
7. If you choose to overwrite the existing images, click on the Finish button to complete the 

operation. 
Remember, if you overwrite existing images, the changes are permanent.
8. If you choose to create new images, click on the Next button. The last screen will ask you 

to indicate the directory where you want to create the new images. 
When you click on the Finish button, the same palette file is assigned to the selected 

images. 
To halt processing:
+    Choose Abort Processing from the Album menu or click on the Abort Processing button in 
the ribbon bar.



Creating a Common Palette from Album Graphics
ImageLab lets you create a common palette for 256-color graphics in a palette.
To create a common palette from album graphics:
1. Within the album, select the thumbnails you want to change.
2. Choose Create Common Palette from the Album menu.
ImageLab automatically creates, applies and opens a common palette for the selected 

graphics.
To halt processing:
1. Choose Abort Processing from the Album menu or click on the Abort Processing button in 

the ribbon bar.



Changing File Format of Album Graphics
ImageLab lets you change the file format of a graphic.
To change the file format of album graphics:
1. Within the album, select the thumbnails you want to change.
2. Choose Image Processing... from the Album menu.
The Image Processing Wizard appears.
3. Select File Format from File from the drop-down list and click on the Next button.
4. Specify the file format you want to use for the selected graphics and click on the Next 

button.
5. Specify whether you want to overwrite the existing images or create new images.
6. If you choose to overwrite the existing images, click on the Finish button to complete the 

operation. 
Remember, if you overwrite existing images, the changes are permanent.
7. If you choose to create new images, click on the Next button. The last screen will ask you 

to indicate the directory where you want to create the new images. 
When you click on the Finish button, the files are converted to the new format. 
To halt processing:
+    Choose Abort Processing from the Album menu or click on the Abort Processing button in 
the ribbon bar.

Related Topic:
Saving JPEG Files



Removing Graphics from Albums
ImageLab lets you remove a graphic from an album. Note that this operation does not delete

the file from disk. It simply removes the thumbnail.
To remove a graphic from an album:
1. Within the album, select the thumbnails you want to remove.
2. Choose Delete Slides from the Album menu.
The thumbnails are removed from the album.



Palette Files in ImageLab
ImageLab lets you manipulate palette files in the following ways:
Opening Palette Files
Viewing the Palette of an Open Graphic
Creating a New Palette
Creating an Identity Palette
Creating a Common Palette from Album Graphics
Applying a Palette to a Graphic
Changing a Palette Color
Viewing the Palette of an Open Graphic



Working with Palette Files
ImageLab lets you manipulate palette files in the following ways:
Opening Palette Files
Viewing the Palette of an Open Graphic
Creating a New Palette
Creating an Identity Palette
Creating a Common Palette from Album Graphics
Applying a Palette to a Graphic
Changing a Palette Color
Viewing the Palette of an Open Graphic



Opening Palette Files
You can start a new palette file or open an existing one. 
Related Topics:
Beginning New Files
Opening Existing Files



Changing a Palette Color
You change one or more colors in a palette file.
To change a palette color:
1. Open the palette file. 
As you move the cursor over the palette, the Index number and RGB value of the current cell

appear in the ImageLab status bar.
2. Double-click on a cell that you want to edit.
The Edit Palette Entry dialog box appears similar to the following.

3. Change components of the RGB value as necessary.
Drag the slider bars to adjust the Red, Green, and Blue intensities. The changes you make 
are reflected in the sample color area at the bottom of the dialog box. You can also remove a
color from the palette by clicking on the Delete button. 
4. When you are satisfied with the changes, click on OK to close the dialog box.



Viewing the Palette of an Open Graphic
When a graphic is displayed in its own graphic window, you can change the view to show the
graphics palette in the bottom portion of the window.



Adding an Entry to a Palette
You can add a color entry to a palette. This can be a palette file that you open or a palette 
that you are viewing while a graphic is displayed in its own window. 
Related Topic:
Changing or Adding a Palette Color



Creating a New Palette
ImageLab lets you create a new palette file by pasting palette information that was 
previously copied to the Clipboard.
Related Topic:
Beginning a New File



Applying a Palette to a Graphic
You can apply an alternative palette to a graphic within an individual graphic window or for 
one or more graphics in an album.



Managing Files
There are several ways to manage files in ImageLab. 
Begin new files
Open existing files
Save files
Deleting files
Print files



Beginning New Files
To start a new file: 
1. Choose New... from the File menu.
The New dialog box appears.

2. Select the type of file you want to start and choose OK.
A new window appears in the work area with a different title depending on the type of file 
you chose to start. The following figure shows an example of how a new graphic appears.

Graphic Files
To place an image in the new graphic window, use the Paste command in the Edit menu to 
paste an image from the Clipboard.
Album Files
To place items in a new album, use the Add Files... command in the Album menu.
Palette Files
To place colors in a new palette file, paste into the window from the Clipboard. Note that to 
place a palette on the Clipboard, you must have the Palette option selected on the Clipboard
tab of the Settings dialog box. To open the Settings dialog box choose Settings... from the 
Options menu.





Opening Existing Files
ImageLab lets you open existing album, graphic or palette files. 
To open a file: 
1. Choose Open.. from the File menu.
The Open dialog box appears.

2. Select the type of file you want to open from the List Files of Type drop-down list.
3. Find the file you want to open and double-click on it in the File Name list.
The selected file appears in a window in the work area.
Graphic File Hint
You can also double-click to open a graphic file from within an album. By default, this action 
opens the graphic in its own window. However, you can change the action that results from 
double-clicking using the Settings dialog box.



Saving Files
The following subsections describe how to save files in ImageLab.
Saving New Files

Warning: Once you save a file, you cannot undo changes that you have applied.
To save new files:
1. Start a new file.
2. Choose Save As... from the File menu.
The Save As dialog box is displayed.
3. Name the file and choose OK.
The new name of the file appears in the window title bar.

Saving Changes to Existing Files

Warning: Once you save a file, you cannot undo changes that you have applied.
Whenever you change an existing file, you must decide whether to save the image to the 
same file (Save command), or save the image to a new file (Save As command).    When an 
existing image is saved to a new file, the contents of the original file remain the same as 
before any changes were made.
To save changed files to the same filename:
1. Make sure the window is active.
2. Choose Save from the File menu.
The file is updated and saved to the existing filename specified in the window title bar.

Hint: To preserve the original file, make a working copy and edit the working copy.    This 
procedure insures that you can always return back to the original file if the changed results 
are not what you expected.
To save and rename changed files:
1. Make sure the window is active.
2. Choose Save As... from the File menu.
The Save As dialog box is displayed.
3. Name the file and choose OK.
The new name of the file appears in the window title bar.



Deleting Graphic Files
ImageLab lets you delete graphic files.    
Caution: The deleted file is not just removed from ImageLab, it is deleted from your disk. 
To delete a graphic file:
1. Make sure the file you want to delete is open and in the active window.
2. Choose Delete... from the File menu.    
A message box appears with the directory path of the selected file, asking you to confirm 
that you want to delete the file. 
3. Click on OK if you want to delete the selected file or Cancel to halt the operation.



Printing Graphic Files
ImageLab lets you print a graphic file if your printer is properly installed and selected.    The 
appearance of the printed page varies depending on the current page setup.    You can use 
the default settings for page setup, or you can use the Page Setup... command from the File 
menu to change the defaults.change the layout of the printed page
To print a graphic file:
1. Make sure the file you want to print is open and in the active window.
2. Choose Print... from the File menu.
A dialog box appears letting you confirm or reset information about the selected printer and 
number of copies you want to produce. 
3. Click on OK to print.
Related Topics:

Changing the Page Setup
Using Print Preview



Changing the Page Setup
When you print a file, you can use the default margin and header/footer settings or you can 
use the Page Setup dialog box to customize the layout of the page.
To open the Page Setup dialog box:
+    Choose Page Setup... from the File menu.
The Page Setup dialog box appears.

To reset margins:
1.Click in the appropriate box in the Margins area and enter a new value.
2.Choose OK.
To setup headers and footers:
+    Use the Header and Footer text boxes to enter text and/or any codes you want to appear 
at the top and bottom of each page.
For example, you can type the word "Date" followed by a space and &d in the Header text 
box.    This generates text such as "Date 12/15/91" at the top of the printed page. 
Use the following codes to generate and format information in the Header and Footer text 
boxes:

&d Generates the current date. 
&p Generates page numbers.
&f Generates the current filename.
&l Justifies the text that follows at the left margin.
&r Justifies the text that follows at the right margin.
&c Centers the text that follows.
&t Generates the current time.

Using Print Preview
To preview the positioning and general appearance of the image when it is printed, choose 
Print Preview from the File menu. Print preview mode provides the following options:

Button: Purpose:
Print... Goes to the Print dialog box. 
Zoom In Zooms in on the image.
Zoom Out Zooms away from the image.
Close Returns to the ImageLab window.



Quitting ImageLab
To exit from ImageLab, choose Exit from the File menu.    
If there are any unsaved changes to files, you are prompted to save the changes. The dialog 
box gives you the option to save the changes, not save the changes, or cancel back to your 
last working position within ImageLab.



File History command (File menu)
This command displays a list of the last four recently opened files. Select from the list to 
automatically open a file.

 



Page Setup dialog box
This dialog box lets you set the top, bottom, left and right margins and specify the 
information to be included in the header and footer of a printed page. Use the following 
codes to generate and format information in the Header and Footer fields:

&d Generates the current date. 
&p Generates page numbers.
&f Generates the current filename.
&l Justifies the text that follows at the left margin.
&r Justifies the text that follows at the right margin.
&c Centers the text that follows.
&t Generates the current time.



Clipboard tab (Settings dialog box)
This tab lets you determine if captured images are placed on the Clipboard. Check the 
Capture to Clipboard option to automatically place captured images on the Clipboard. You 
cal also use the BITMAP, DIB and Palette options to determine what information is placed on 
the Clipboard when an image is captured.
Related Topic:
Capturing Images  



Capture Window dialog box
This dialog box lets you capture the currently selected window. This may be a dialog box or 
even some areas within a dialog box. 
Hint: When Step 1 in the dialog box says to Drag the Capture Cursor it means that you should actually 
drag the picture of the capture cursor that is in the lower right corner of the dialog box.

The main ImageLab window will be hidden during the capture operation if the Hide ImageLab option is 
selected in the Capture menu. When you finish the operation, the image appears in a new graphic 
window. Each window has a default title such as Graphic1, Graphic2 and so on. However, you must 
explicitly use the File Save command to save the information in the window to a file. When you save and 
name the file, the name of the file appears in the title bar.

Note: Z-Order refers to the layering of windows. As an example, all of the windows that comprise a dialog
box (e.g. the empty dialog box, the group boxes and text within the dialog, etc.) are layered according to 
Z-Order when they are first created by an engineer. By default, when you use the Capture Window 
feature, the windows that you can capture are at the bottom of the Z-Order. If you are unable to capture a
window, turn on the Reverse Z-Order Search option before doing the capture. In most cases this will 
allow you to capture windows that were previously obscured by other windows that have a lower Z-Order.



Capture Client Area dialog box
This dialog box lets you capture the entire area of a window minus any title bar, scrollbars 
and borders the window may have.
Hint: When Step 1 in the dialog box says to Drag the Capture Cursor it means that you should actually 
drag the picture of the capture cursor that is in the lower right corner of the dialog box.

The main ImageLab window will be hidden during the capture operation if the Hide ImageLab option is 
selected in the Capture menu. When you finish the operation, the image appears in a new graphic 
window. Each window has a default title such as Graphic1, Graphic2 and so on. However, you must 
explicitly use the File Save command to save the information in the window to a file. When you save and 
name the file, the name of the file appears in the title bar.

Note: Z-Order refers to the layering of windows. As an example, all of the windows that comprise a dialog
box (e.g. the empty dialog box, the group boxes and text within the dialog, etc.) are layered according to 
Z-Order when they are first created by an engineer. By default, when you use the Capture Window 
feature, the windows that you can capture are at the bottom of the Z-Order. If you are unable to capture a
window, turn on the Reverse Z-Order Search option before doing the capture. In most cases this will 
allow you to capture windows that were previously obscured by other windows that have a lower Z-Order.



Capture Rectangle dialog box
This dialog box lets you capture a rectangular area of the screen. 
Hint: When Step 1 in the dialog box says to Drag the Capture Cursor it means that you should actually 
drag the picture of the capture cursor that is in the lower right corner of the dialog box.

The main ImageLab window will be hidden during the capture operation if the Hide ImageLab option is 
selected in the Capture menu. When you finish the operation, the image appears in a new graphic 
window. Each window has a default title such as Graphic1, Graphic2 and so on. However, you must 
explicitly use the File Save command to save the information in the window to a file. When you save and 
name the file, the name of the file appears in the title bar.



Capture Fixed Rectangle dialog box
This dialog box lets you specify the size of the area you want to capture.
Hint: When Step 1 in the dialog box says to Drag the Capture Cursor it means that you should actually 
drag the picture of the capture cursor that is in the lower right corner of the dialog box.

The main ImageLab window will be hidden during the capture operation if the Hide ImageLab option is 
selected in the Capture menu. When you finish the operation, the image appears in a new graphic 
window. Each window has a default title such as Graphic1, Graphic2 and so on. However, you must 
explicitly use the File Save command to save the information in the window to a file. When you save and 
name the file, the name of the file appears in the title bar.



Image Properties dialog box
This dialog box is used to view the properties of a graphic. You can view the filename, file 
size, last modified date, type of file, number of colors, size, and color depth. If you have not 
yet saved the image to a file, the FileName, File Size and Last Modified Date fields are empty.



Edit Palette Entry dialog box
This dialog box lets you change (or add) one or more colors in an images palette. Drag the 
slider bars to adjust the Red, Green, and Blue intensities. The changes you make are 
reflected in the sample color area at the bottom of the dialog box. You can also remove a 
color from the palette by clicking on the Delete button. If you double-clicked on an existing 
position, the color changes are in effect. If you added a new color to the palette, the new 
entry is added.



General tab (Settings dialog box)
The options on this tab represent the different algorithms that you can automatically apply 
to true color images that are displayed on a 256-color system. Specifically, each of the 
options uses quantization and/or dithering algorithms. Quantization is the method used 
for selecting appropriate colors to include in the palette during the reduction process. Given 
the selected colors, dithering is the method used to position the available colors among the 
pixels that make up the resulting image. 
Without dithering, the reduction process simply replaces every pixel of an unsupported color
with a supported color. The resulting effect is likely to use very jagged edged areas of color 
that do not blend gradually into adjacent areas. If you opt to use dithering however, the two 
general methods are pattern and diffusion. Pattern dithering replaces a block of pixels 
with pixels that use two alternating colors that the human eye perceives as a third color. For 
example, an patterned area of blue and red pixels can be perceived as purple. Diffusion 
dithering takes each pixel and comes as close as possible to matching the original color. It 
then calculates the difference between the old and new colors and spreads the difference 
among the colors of neighboring pixels. 
Related Topic:
Available Reduction Methods



Resize Image dialog box
This dialog box lets you change the dimensions of the selected image.
Use the fields in the Dimensions area to set a specific width and height (in pixels) for the 
currently selected graphic. You can set both fields or you can set one field and the other is 
automatically updated to maintain the original proportions of the image if the Maintain 
Aspect Ration option is selected. 
To set the Width and Height fields to values that do not retain the original proportions of the 
graphic, turn off the Maintain Aspect Ratio option. Be aware that stretching or compressing 
may distort the image.
Use the Scale field to change the images width and height proportionately.



Create Identity Palette dialog box
This dialog box lets you create an identity palette for a 256-color graphic using one of two 

options.
Table Lookup option - This option is available when your system is running in any color depth. It causes 
ImageLab to detect whether the graphic uses an identity palette. If the graphic already has an identity 
palette, ImageLab replaces the system colors in the first and last ten palette positions, using VGA system 
colors. If the graphic does not have an identity palette, ImageLab shifts the colors in the palette to make 
room for the first ten system colors and fills the last ten positions with the appropriate system colors. Note 
that this means that some colors may be lost (if the image used more than 236 colors) when the system 
colors are added to the palette.

Palette Manager option - This option is only available (and is the default) when your system is running in 
256 colors. ImageLab realizes the graphics palette into the system palette. If any positions in the graphics
palette previously contained any system colors, those positions are stripped from the palette. 



Edit Slide dialog box
This dialog box lets you change the label below a slide, record and store comments about 
the slide, and change the file that appears in the slide.
Use the Title field to change the title that appears beneath the slide.

Use the Comment field to enter notes about the slide.

Use the Browse... button to search for an alternative graphic to display in the slide.



Album tab (Settings dialog box)
This tab lets you determine what happens when you double-click on a slide. You can also 
choose whether or not thumbnails are automatically generated for graphics as they are 
added to the album.



Full Screen tab (Settings dialog box)
This tab lets you determine how an image is displayed fullscreen.
Use the Layout area to specify how each image should appear.

Size to Graphic - Shows each graphic centered in its proper dimensions.

Fit To View - Shows each graphic as large as possible, while maintaining its proper dimensions.

Stretch To Fit - Shows each graphic full screen, possibly distorting it horizontally or vertically to make it fit.

Use the Background Color option to change from black to another color of your choice.

Use the Effect list to select the special display effect used when a graphic appears.



Editors tab (Settings dialog box)
This tab lets you determine the graphics editor associated with each file type. You can add 
an extension type by clicking on the Add... button then click on the Browse... button to 
choose the name of the executable you want to launch.
Use the Command Line field to specify any additional command line parameters you want to use when 
the editor is launched. 

For example, a program might may have a parameter that causes it to appear fullscreen when it is 
launched. For information on available parameters, refer the documentation that accompanies the editor 
you want to run. 

Do not remove the %f parameter. It marks the placeholder for the filename you want to open.



Slide Show tab (Settings dialog box)
This tab lets you determine how the items in an album are displayed in a slide show fashion.
Use the Layout area to specify how each image should appear.

Size to Graphic - Shows each graphic centered in its proper dimensions.

Fit To View - Shows each graphic as large as possible, while maintaining its proper dimensions.

Stretch To Fit - Shows each graphic full screen, possibly distorting it horizontally or vertically to make it fit.

Use the Slide Control option to specify how one slide is displayed after another.

Delay Time - This is the number of seconds until the next image appears.

Manual Control - This lets the user click to proceed to the next slide.

Use the Background Color option to change from black to another color of your choice.

Use the Effect list to select the special display effect used when a graphic appears.

Use the Hide Cursor option to remove the cursor from view when the slide show runs.

Use the Loop option to cause the slide show to continue repeatedly until the user presses 
Esc.



About Box dialog box
Use this command to display the copyright notice and version number of your copy of 
ImageLab.



Toolbars dialog box
This dialog box lets you choose to display and hide the Main and Capture toolbars, which 
includes buttons for some of the most common commands in ImageLab, such as File Open. A
check mark appears next to the name of the Toolbar when it is displayed.

 




