タスク スケジューラ

タスク スケジューラを使うと、コマンド、プログラム、またはスクリプトを指定した時間に実行するように設定できます。

  • タスク スケジューラを使う前に、チェックリストを参照してください。
  • 特定のタスクのヘルプを表示するには、使い方を参照してください。
  • 基本的な情報については、概要を参照してください。
  • 問題解決の手順については、トラブルシューティングを参照してください。


タスク スケジューラ チェックリスト

チェックリスト

次の表は、タスク スケジューラで最も頻繁に行う操作の一覧です。タスク スケジューラの操作方法の詳細については、使い方を参照してください。

手順 | 参照先
タスクが実行されるようにスケジュールを設定する前に、タスクを追加する必要があります。 | 新しいタスクを設定する
タスクを作成したら、そのプログラム、スケジュール、または特定のタスクの詳細を修正できます。 | タスクのスケジュールを修正する
予定されているタスクが必要なくなった場合は、スケジュールを完全に削除できます。 | タスクのスケジュールを削除する
コンピュータの使用中に、予定されているタスクが開始された場合は、そのタスクを中止し、後でもう一度起動できます。 | 実行中のタスクを中止する
予定されているすべてのタスクを一時的に中止または一時停止し、後で続行できます。 | 予定されているすべてのタスクを一時的に中止する


使い方

  • タスクのスケジュール
  • タスク スケジューラの管理


タスクのスケジュール
  • タスク スケジューラを起動する
  • 新しいタスクを設定する
  • タスクのスケジュールを修正する
  • タスクのスケジュールを削除する
  • 実行中のタスクを中止する
  • タスクをすぐに実行する


タスク スケジューラを起動する

タスク スケジューラを起動するには

  • タスク スケジューラを起動するには、[マイ コンピュータ] をダブルクリックし、[タスク] フォルダをクリックします。
  • [タスク] フォルダをダブルクリックし、[タスクの追加] をダブルクリックすると、タスク ウィザードが開き、タスクのスケジューリングが簡単にできます。


新しいタスクを設定する

新しいタスクを設定するには
  1. タスク スケジューラを起動します。
  2. [予定されたタスクの追加] をダブルクリックします。
  3. タスク ウィザードの指示に従って操作します。

注

  • タスクの詳細な設定を行うには、ウィザードの最後の画面で [[完了] をクリックしたときにプロパティの詳細を開く] チェック ボックスをオンにします。
  • 新しく設定したタスクを毎回繰り返し実行するようにするには、ウィザードの最後の画面で [[完了] をクリックしたときにプロパティの詳細を開く] チェック ボックスをオンにし、表示されるダイアログ ボックスで [スケジュール] タブをクリックして [詳細設定] をクリックします。
  • 実行するタスク プログラムのパラメータを指定する必要がある場合は、ウィザードの最後の画面で [[完了] をクリックしたときにプロパティの詳細を開く] チェック ボックスをオンにし、表示されるダイアログ ボックスで [タスク] タブをクリックして [実行するファイル名] ボックスに、ファイルのパスに続けてパラメータを入力します。
  • 使用しているコンピュータの日付および時刻は、正しく設定してください。タスク スケジューラでは、この情報に基づいて設定したプログラムが実行されます。日付および時刻を設定するには、タスク バーの時計をダブルクリックします。


タスクのスケジュールを修正する

タスクのスケジュールを修正するには
  1. タスク スケジューラを起動します。
  2. 修正するタスクをマウスの右ボタンでクリックし、[プロパティ] をクリックします。
  3. 次のいずれかを実行してください (複数選択可)。
    • 実行されるプログラムを変更するには、[実行するファイル名] ボックスに新しいプログラムへのパスおよびファイル名を入力します。
    • タスクのスケジュールを変更するには、[スケジュール] タブをクリックします。
    • タスクの実行の設定を変更するには、[設定] タブをクリックします。

注

  • ユーザー アカウント、または実行するプログラムを変更する場合は、ユーザー アカウントに対応するパスワードを入力しなければなりません。
  • 実行するタスク プログラムのコマンド ライン オプションを指定する必要がある場合は、[実行するファイル名] ボックスに、ファイルのパスに続けて入力します。
  • ファイルのパスにスペースが含まれる場合は、パスの文字列を二重引用符 ("") で囲む必要があります。
  • タスク スケジューラでは、使用しているコンピュータの日付および時刻に基づいてプログラムが実行されるので、日付および時刻は、正しく設定してください。日付および時刻を確認または変更するには、タスク バーの時計をダブルクリックします。


タスクのスケジュールを削除する

タスクのスケジュールを削除するには
  1. タスク スケジューラを起動します。
  2. 削除するタスクをマウスの右ボタンでクリックし、[削除] をクリックします。

注

  • この操作により、[タスク] ウィンドウで選択したタスクのスケジュールだけが削除されます。ハード ディスクからプログラムが削除されるわけではありません。
  • 選択したタスクのスケジュールは、Del キーを押して削除することもできます。


実行中のタスクを中止する

実行中のタスクを中止するには
  1. タスク スケジューラを起動します。
  2. 中止するプログラムをマウスの右ボタンでクリックし、[タスクの終了] をクリックします。

注

  • 予定されていたタスクからほかのプログラムが起動された場合、この操作で中止できるタスクは最初に実行されたタスクだけです。タスクから起動されたプログラムはそのまま実行されます。
  • 中止したタスクをもう一度起動するには、目的のタスクをマウスの右ボタンでクリックし、[タスクの実行] をクリックします。


タスクをすぐに実行する

タスクをすぐに実行するには
  1. タスク スケジューラを起動します。
  2. 実行するタスクをマウスの右ボタンでクリックし、[タスクの実行] をクリックします。

注

  • [ファイル] メニューの [タスクの終了] をクリックすると、実行しようとしたタスクを中止することができます。
  • 設定したタスクが実行されない場合は、[詳細設定] メニューの [ログの表示] をクリックし、タスクのログを表示して原因を調べてください。


タスク スケジューラの管理
  • 実行されたタスクのログを表示する
  • リモート コンピュータのタスクを表示する
  • 予定されているすべてのタスクを一時的に中止する
  • タスク スケジューラを一時停止する
  • AT サービス アカウントを設定する


実行されたタスクのログを表示する

実行されたタスクのログを表示するには
  1. タスク スケジューラを起動します。
  2. [詳細設定] メニューの [ログの表示] をクリックします。


リモート コンピュータのタスクを表示する

リモート コンピュータのタスクを表示するには
  1. デスクトップの [ネットワーク コンピュータ] アイコンをダブルクリックします。
  2. タスクを表示するコンピュータをダブルクリックします。
  3. [タスク] フォルダをダブルクリックします。

注

  • Windows を実行しているリモート コンピュータのタスクをほかのコンピュータで表示するには、リモート コンピュータの管理者権限を持っている必要があります。
  • Windows を実行しているリモート コンピュータのタスクの設定を変更するには、リモート コンピュータにリモート レジストリ ソフトウェアがインストールされていて、[タスク] フォルダがあるディスク ドライブが共有されている必要があります。また、Windows を実行しているリモート コンピュータには、操作しているコンピュータのユーザー アカウントが登録されている必要があります。どのユーザーが Windows を実行しているコンピュータのレジストリにアクセスできるかを指定するには、コントロール パネルの [パスワード] アイコンをクリックします。


予定されているすべてのタスクを一時的に中止する

予定されているすべてのタスクを一時的に中止するには
  1. タスク スケジューラを起動します。
  2. [詳細設定] メニューの [タスク スケジューラの一時停止] をクリックします。

注

  • このコマンドは、ゲームなどのほかのプログラムを実行したり、ソフトウェアをインストールしたりするときに、タスクを同時に実行したくない場合に便利です。
  • タスクが実行される予定の時間に、タスク スケジューラが停止していた場合は、次に設定されている時間までタスクは実行されません。
  • もう一度すべてのタスクがスケジュールに従って実行されるようにするには、[詳細設定] メニューの [タスク スケジューラの続行] をクリックします。


タスク スケジューラを停止する

タスク スケジューラを停止するには
  1. タスク スケジューラを起動します。
  2. [詳細設定] メニューの [タスク スケジューラの使用停止] をクリックします。

注

  • タスク スケジューラを停止すると、設定したタスクは実行されません。次に Windows を起動したときにもタスク スケジューラは起動されなくなります。


AT サービス アカウントを設定する

AT サービス アカウントを設定するには

  1. タスク スケジューラを起動します。
  2. [詳細設定] メニューの [AT サービス アカウント] をクリックします。
  3. [このアカウント] をクリックします。次に、AT コマンドで設定したタスクを実行するときに使われるユーザー アカウントを入力します。
  4. [パスワード] ボックスおよび [パスワードの確認入力] ボックスにアカウントのパスワードを正しく入力します。

注

  • AT サービスを使えるのは Windows NT だけです。
  • 必要に応じて [システム アカウント] をクリックすることができます。[システム アカウント] をクリックすると、タスク スケジューラは管理者権限が必要になる LocalSystem アカウントを使って、AT コマンドで設定したタスクを実行します。

  • 指定したユーザー アカウントには、AT コマンドで設定したすべてのタスクを実行するために適切な権限が必要です。たとえば、管理者だけが実行することができるプログラムのスケジュールを設定するには、管理者アカウントを指定する必要があります。


タスク スケジューラの概要

概要

ここでは、タスク スケジューラの基本的な情報について説明します。

  • タスク スケジューラ入門
  • タスク スケジューラを使う
  • タスク スケジューラと AT コマンド
  • タスク スケジューラとセキュリティ
  • トラブルシューティング


タスク スケジューラ入門

タスク スケジューラを使うと、デフラグなどの作業 (タスク) をスケジュールに従って都合のよいときに実行することができます。タスク スケジューラは、Windows を起動するたびに起動され、バックグラウンドで動作します。

タスク スケジューラを使うと、次のようなことが行えます。

  • 日単位、週単位、月単位、またはコンピュータの起動時など一定のスケジュールでタスクを実行するように設定できます。
  • タスクのスケジュールを変更することができます。
  • タスクの実行を中止することができます。
  • 設定された時刻にどのようにタスクが実行されるかを独自に設定できます。


タスク スケジューラを使う

Windows オペレーティング システムでは、タスク スケジューラは自動的にインストールされます。このスケジュール サービスを使うには、マイ コンピュータの [タスク] フォルダをダブルクリックします。

タスクを追加するには、[予定されたタスクの追加] をダブルクリックし、タスク ウィザードを起動します。タスクを追加するには、スクリプト、プログラム、またはドキュメントをエクスプローラやデスクトップから [タスク] ウィンドウへドラッグします。

タスク スケジューラを使って、スケジュールを設定したタスクを修正、削除、一時停止、または中止したり、実行されたタスクのログやリモート コンピュータのタスクを表示したりすることもできます。

タスク スケジューラの使い方の詳細については、使い方を参照してください。

タスク スケジューラの効果的な使い方

Windows オペレーティング システムでは、タスク スケジューラを使って、任意のアプリケーションが実行されるようにスケジュールを設定できます。タスク スケジューラを効果的に使用するには、タスクを追加する前に、使用しているコンピュータの日付および時刻を正しく設定してください。


タスク スケジューラと AT コマンド

タスク スケジューラの使用に加えて、AT コマンドを使ってタスクを自動的に実行することができます。

タスク スケジューラと AT コマンドは同じものではありませんが、同時に使用できます。AT コマンドを使ってタスクのスケジュールを設定すると、[タスク] ウィンドウに AT コマンドが表示されます。

タスク スケジューラを使い、AT コマンドでスケジュールを設定したタスクのプロパティを修正することもできます。 ただし、この方法でプロパティを修正した場合、そのタスクをアクセスするにはタスク スケジューラを使う必要があります。タスク スケジューラを使ってタスクのプロパティを修正すると、AT コマンドを使ってタスクにアクセスすることはできません。

AT コマンドでスケジュールを設定したタスクを実行するユーザー アカウントを指定するには、[マイ コンピュータ] で [タスク] フォルダをクリックし、[詳細設定] メニューの [AT サービス アカウント] をクリックします。

注

  • AT サービスを使えるのは Windows NT だけです。


タスク スケジューラとセキュリティ

タスク スケジューラでは、特定のタスクにユーザー名とパスワードを割り当てることによってセキュリティを設定できます。タスクにユーザー名とパスワードを設定すると、ほかのユーザーはそのタスクを取り消したり削除したりできなくなります。

注

  • このセキュリティ機能は Windows NT だけで使えます。
  • タスクのスケジュールの設定を続けるには、タスク ウィザードでユーザー名を入力する必要があります。パスワードは必要ありません。
  • パスワードの変更および新しいパスワードの設定を行うには、ウィザードの最後の画面で [[完了] をクリックしたときにプロパティの詳細を開く] チェック ボックスをオンにします。


タスク スケジューラに関するトラブルシューティング

タスクが設定どおりに実行されない場合は、目的のタスクをマウスの右ボタンでクリックし、[プロパティ] をクリックします。次に、[タスク] タブの [実行する (予定されたタスクは指定の時間に実行されます)] チェック ボックスがオンになっていることを確かめます。また、[スケジュール] タブをクリックし、スケジュールが正しく設定されていることを確かめます。

上の操作でタスクが正しく実行されない場合は、コマンドライン オプションを追加してください。プログラムのパラメータの詳細については、次のいずれかの方法で調べてください。

  • プログラムにオンライン ヘルプが用意されている場合は、オンライン ヘルプを参照してください。

  • コマンド プロンプトで、次のように入力します。ただし、"program" の部分にはプログラムの名前を入力します。

    • program /?


Windows NT コンポーネントがインストールされていません

プログラムを起動できませんでした。

次のような原因が考えられます。

    • プログラムが、システム管理者によって削除されました。
    • システム管理者が、ファイルに関連付けられているポリシーを変更しました。
    • プログラムがコンピュータにインストールされていません。
    • プログラムが誤って削除されました。
    • ファイルが破損しています。

システム管理者が、使用しているコンピュータを制御している場合は、プログラムを起動できない原因についてシステム管理者に問い合わせてください。