Microsoft Internet Explorer 管理者キット ヘルプ

Microsoft Internet Explorer 管理者キット
Internet Explorer のアイコン

管理者キット

バナー バナー

Web を思い通りの方法で提供することができます。 詳細については、ヘルプ を参照してください。

行頭文字 | キーワードを使った索引
行頭文字 | 全文検索の実行
行頭文字 | トピックの印刷

©1999-2001 Microsoft Corporation. All rights reserved.


Internet Explorer 管理者キットの新しい機能

Internet Explorer 管理者キット (IEAK) では、Internet Explorer 6 カスタマイズ ウィザードと IEAK プロファイル マネージャを使って、Internet Explorer をカスタマイズ、展開、および保守できます。IEAK の内容の詳細については、「IEAKの機能」を参照してください。

IEAK 6 の新機能

  • 統合された使用許諾契約を使用することで、今まで以上に早く IEAK を開始できます。これにより、IEAK を実行するためのライセンス キーコードを取得する必要がなくなりました。
  • IEAK の以前のバージョンよりも操作性が向上したわかりやすいウィザード ページを使って、Internet Explorer のカスタムパッケージを作成できます。
  • ツール バーの カスタマイズ機能を使って、Internet Explorer パッケージの概観を独自に設定することができます。ツール バーの背景およびボタンのアイコン用に独自のビットマップ画像を作成して、使用することができます。また、独自に設定したボタンへのリンクが設定されたスクリプトまたは実行可能ファイルを制御することができます。
  • IEAK を使うと、ブラウザのポリシーを設計してから、新しいポリシーの結果セット機能を使って Internet Explorer カスタム パッケージを展開することができます。

関連項目


IEAK の機能

IEAK には、Internet Explorer のカスタマイズと管理に役立つプログラムやツールが用意されています。

次のような機能があります。

  • ブラウザやその他のインターネット コンポーネントを、組織またはユーザーのニーズに応じてカスタマイズできます。たとえば、会社のプロモーションに結びつくリンクやユーザーに有益な情報を提供するリンクをリンク バーおよび [お気に入り] の一覧に追加したりすることができます。
  • インストールを開始する前に設定を構成できるので、対象となるコンピュータごとにオプションを設定する必要がありません。
  • ユーザーの入力をあまり必要としないようにセットアップをカスタマイズして、カスタム プログラムをインストールすることができます。
  • 企業内管理者の場合は、社員に対してどの設定の変更を許可するかを指定できるため、セキュリティや接続などの重要な設定を社内標準に従って統一することができます。

IEAK を使用する前に、どの設定をカスタマイズするかを決定し、パッケージに必要なグラフィックスやカスタム ファイルを用意すると共に、配布方法を選定してください。また、IEAK のプログラムやツールの機能と使用方法についても事前に十分理解しておきましょう。

このバージョンの IEAK の新機能の詳細については、「Internet Explorer 管理者キットの新しい機能」を参照してください。

IEAK のツール

Internet Explorer 6 カスタマイズ ウィザード

カスタマイズ ウィザードでは、5 つの段階に分けられた各種設定画面を通じて、Internet Explorer のカスタム パッケージが作成できるようになっています。

IEAK プロファイル マネージャ

プロファイル マネージャを使うと、Internet Explorer のインストール後にユーザーの設定および制限を自動的に変更できます。詳細については、「IEAK プロファイル マネージャとは」を参照してください。

IEAK ツールキット

IEAK ツールキットには、IExpress ウィザード、サインアップとアドオンのサンプル ファイル、およびグラフィックスなど、パッケージの作成に役立つツール、プログラム、およびサンプル ファイルが用意されています。これらのアイテムは、IEAK をインストールしたフォルダの [Toolkit] フォルダに格納されています。

IEAK ヘルプ

キーワード、目次、および全文検索を使って、知りたい情報が含まれているトピックを検索できます。目次を使うと、関連するトピックのグループを "ブック" 単位で印刷できます。


ハードウェアとシステムの必要条件

特定バージョンの Internet Explorer に関するハードウェアおよびソフトウェアの必要条件については、各バージョンの Readme ファイルを参照してください。

カスタム パッケージの作成に関するハードウェアのその他の必要条件

Internet Explorer 6 カスタマイズ ウィザードを起動する前に、カスタム パッケージのコピー先となるドライブのディスク容量を確認してください。コピー先のドライブは、カスタマイズ ウィザードの実行元と同じコンピュータにも、別のコンピュータにも指定できます。

IEAK パッケージを作成するには、Internet Explorer のシステム条件に加えて、以下の条件も満たしている必要があります。

  • ダウンロードしてインストール パッケージに含めるコンポーネントの数に応じて、最大 100 MB のディスク容量が必要になります。
  • 作成するカスタム パッケージごとに、最大 100 MB のディスク容量が必要になります。同じパッケージを CD-ROM などの別のメディア用に作成する場合は、別のパッケージとして扱います。

IEAK の必要条件

IEAK パッケージを作成する場合は、32 ビット Windows オペレーティング システム (Windows NT 3.51 を除く) が動作しており、Internet Explorer 6 がインストールされているコンピュータを使用する必要があります。

Windows NT 4.0 コンピュータでは、Service Pack 3 (またはそれ以降のバージョン) を実行している必要があります。

このバージョンの IEAK では、32 ビット Windows プラットフォーム用のカスタム ブラウザ パッケージのみ作成できます。16 ビット Windows または UNIX プラットフォーム用のカスタム パッケージを作成する場合は、IEAK 5.0x を使用します。Macintosh 用のカスタム パッケージを作成する場合は、Macintosh 版の IEAK を使用します。

IEAK 5.5 と IEAK 6 をそれぞれ別のディレクトリにインストールすると、両方を同じコンピュータで実行できます。

ユーザーの必要条件

ユーザーが Windows NT、Windows 2000、または Windows XP を実行している場合は、IEAK パッケージで Internet Explorer をインストールまたはアンインストールした後、ユーザーが初めて各自のコンピュータを起動する前に、そのコンピュータでの管理者権限を持っている必要があります。


Internet Explorer の再配布

IEAKを使用して、Internet Explorer を別のプログラムのセットアップ処理の一部として再配布できます。 たとえば、独立ソフトウェア ベンダ (ISV) は、Internet Explorerのインストールをカスタマイズし、Internet Explorer と共に再配布して、ユーザーが Internet Explorer の代りにこの ISV のカスタム プログラムを選択できるようにできます。

Internet Explorer を再配布するには、Internet Explorer 6 カスタマイズ ウィザードを使用して IEAK パッケージを作成します。Internet Explorer 6 カスタマイズ ウィザードの段階 1 で [コンテンツ プロバイダ/開発者] オプションを選択します。

ブラウザおよび Windows Update セットアップの外観と機能は、使用許諾契約で許可されている場合にのみカスタマイズすることができます。また、次の機能を使用して、Windows Update セットアップの機能や動作を制御することもできます。

  • バッチ モードでのセットアップの実行
  • Internet Explorer のバッチ モード セットアップ スイッチ
  • IExpress のバッチ モード セットアップ スイッチ
  • セットアップ情報ファイル (.inf) の使用


展開ガイドの概要

展開ガイドには、IEAK 6 を使用して Internet Explorer のカスタム パッケージを展開する方法がわかりやすく解説されています。IEAK 6 は、Internet Explorer の利点を最大限にユーザーに提供する、最も簡単で強力な方法の 1 つです。このガイドは、次の場合に役立ちます。

  • パイロットの導入とその他のタスクの実行により、展開の準備を行います。
  • 展開後、Internet Explorer 6 のインストールを中央で管理します。
  • IEAK 6 で提供されている最適な方法および指針を使用して、カスタム パッケージを作成します。

社内イントラネットおよびエクストラネットの重要性が増し、管理者による Web テクノロジの管理は非常に重要になりました。大部分の IT 部門では、オペレーティング システム、生産性、および主要な業務用アプリケーション (ほとんどが Web ベース) と同じ使用方針レベルで、ブラウザを扱っています。大部分の企業では、ユーザーの標準のデスクトップにブラウザを含めています。

カスタム ブラウザ パッケージを展開すると、ユーザーには次のような利点があります。

  • 生産性の向上 ブラウザのプロキシの設定、[お気に入り] の一覧、セキュリティの設定、およびデジタル証明書を作成します。カスタム ブラウザを展開することで、ユーザーが主なイントラネットおよびインターネット アプリケーションへアクセスできるようにし、すべてのブラウザに同じ機能を持たせ、ユーザー サポートをより簡単にします。
  • 管理の簡易化および信頼性の向上 カスタム パッケージを作成することで、主要な業務用アプリケーションでコンポーネントのテストを行い、信頼性を向上させ、展開、サポート、およびアップグレードにかかるコストを削減することができます。ユーザーのデスクトップ ブラウザ コンポーネントを中央で動的に管理できます。他のコンポーネントをアップグレードせずに、電子メール クライアントを効率的にアップグレードすることもできます。


自動展開オプション

カスタム ブラウザの展開を自動化するには、次のいずれかのオプションを使用します。

  • ディスク イメージのコピー

    • ディスク イメージのコピーは、複製とも呼ばれ、新しいデスクトップを最もすばやくセットアップできる方法の 1 つです。標準のデスクトップのイメージを作成し、新しいコンピュータおよび既存のコンピュータの両方にそのイメージをコピーします。カスタム ブラウザの設定は、標準のデスクトップのイメージの一部として構成されます。

    ディスク イメージのコピーでは、通常、ユーザーの操作がなくてもセットアップを完了できるので、最も時間とコストを節約できます。オペレーティング システム、アプリケーション、およびデスクトップのカスタマイズを含む、ほぼすべてのコンポーネントを構成できます。

    状況および環境によっては、ディスク イメージのコピーが適さない場合があります。イメージは、同じ構成のハードウェアまたは非常によく似た設定のハードウェアでのみ機能します。既存のコンピュータをアップグレードする場合、ディスク イメージによってコンピュータ上の既存のファイルが上書きされるので、ユーザーの設定およびデータをサーバーなどの別の場所に一時的に格納する必要があります。

  • 電子ソフトウェア配布

    電子ソフトウェア配布 (ESD) では、ネットワーク経由でデスクトップにソフトウェアをインストールするには、特別なアプリケーションを使用します。他の展開方法とは異なり、ESD は通常、Hewlett Packard、Intel、Microsoft、Tivoli などから提供されている包括的エンタープライズ管理スイートのコンポーネントです。

    ESD は通常、オペレーティング システムのインストールに使用されるのと同じインストール スクリプトに依存しますが、一部の ESD ソリューションでは、これらのスクリプトを作成するために、よりグラフィカルな環境およびアプリケーションのセットアップ言語との統合が提供されています。ESD ソリューションを使用して、展開の進捗状況および結果に関するレポートを作成することができます。

  • IEAK

    ネットワークの帯域幅をより効率的に使用するように、リモートからのインストールをスケジュールする必要がある場合などは、エンタープライズ管理スイートを使用して展開処理を管理することができます。ただし、結局はディスク イメージのコピーよりも ESD の方が複雑です。たとえば、ESD の構造を作成するには、イメージを作成してコピーするよりも時間がかかります。また、一部の ESD ソリューションは既存のハードウェア テクノロジを前提としています。


IEAK の主な機能

IEAK 6 では、以前のバージョンに比べて多くの機能が拡張および追加されています。これらの機能に慣れるには、IEAK のデモンストレーション モードでウィザードの各ページを見てみるのが一番です。デモンストレーション モードの IEAK の特徴と主な機能を以下に示します。

  • 配布メディア オプション

    いくつかの配布メディア オプションの中から、Internet Explorer の配布方法を指定することができます。Web からのダウンロード、CD-ROM、単一のディスク ブランド、および LAN での展開から選択できます。単一のディスク ブランドを使用すると、クライアント コンピュータにコードをインストールせずに、Internet Explorer の設定の構成を有効にすることができます。単一のディスク ブランドは、Internet Explorer 4.01 SP1 以降を実行しているコンピュータでのみ使用できます。

  • カスタム コンポーネントおよびアドオン アプリケーション

    Internet Explorer 6 と共に、自己展開型の実行可能 (.exe) ファイルおよびキャビネット (.cab) ファイルを 10 個まで含めることができます。カスタム コンポーネントには、配布する社内用アプリケーション、シェアウェア、およびその他のプログラムを含めます。

  • インストールするタイミング

    インストールするタイミングの 1 つに、Internet Explorer 6 の前にコンポーネントをインストールするというタイミングがあります。これは、ブラウザをインストールするためにコンピュータの用意をするユーティリティなどの場合に特に便利です。たとえば、レジストリ キーの影響を受けないように、Internet Explorer をインストールする前に、レジストリを消去するユーティリティを実行することができます。

  • ユーザーによるインストール

    インストール実行中にユーザーが行う操作のレベルを設定します。インタラクティブ インストール、ハンド フリー インストール、または完全サイレント インストールのいずれかを選択できます。インタラクティブ インストールの実行中には、ユーザーはコンポーネントをカスタマイズできます。ハンド フリー インストールでは、エラー メッセージや進捗状況は表示されますが、ユーザーに情報の入力を求めるプロンプトは表示されません。完全サイレント インストールはユーザー側では表示されないので、コンポーネントをカスタマイズしたり、進捗状況のメッセージを表示したりする手間をかけずにインストールできます。

  • インストール オプション

    インストール オプションは 10 個まで指定して、それぞれにコンポーネントのセットを含めることができます。IEAK 6 には、最小、標準、完全の 3 種類のインストール オプションが用意されており、維持、削除、またはカスタマイズすることができます。インストール オプションを使用して、ユーザーのグループごとにカスタマイズするパッケージを作成および配布します。

  • インストール ディレクトリ

    Internet Explorer 6 のインストール ディレクトリをカスタマイズして、ユーザーが場所を変更できないようにすることができます。Internet Explorer 6 の標準の場所を強制的に使用させることによって、管理およびトラブルシューティングをより簡単にし、バージョン番号、メータリング、およびソフトウェア インベントリの精度を向上させることができます。

  • Web での展開

    Web からのインストールは、10 個までのダウンロード サイトを使用して構成できます。接続上の問題が発生した場合は、インストール プログラムによって別のサイトに切り替えられます。Internet Explorer 6 のセットアップでは、中断されたダウンロードを再開することもできます。 これにより、ユーザー側でのインストール処理がよりスムーズになります。

  • バージョン番号

    IEAK 6 ではすべてのパッケージに自動的にバージョン番号が付けられ、以前のバージョンのパッケージを保存するか、または上書きするかを構成することができます。また、Internet Explorer 6 の個別のコンポーネントにバージョン番号を付けると、すべてのコンポーネントを再インストールせずに更新することができます。バージョン番号を使用してパッケージを更新し、組織内での標準化を確実にすることができます。

  • Web からのダウンロード

    Web からのダウンロードによるインストールを最適化します。Internet Explorer 6 のセットアップを実行すると、ユーザーのコンピュータに既にインストールされている Microsoft コンポーネントが検出されます。既存のコンポーネントは再ダウンロードされません。たとえば、カスタム パッケージにダイナミック HTML のデータ バインドが含まれている場合、この機能は再インストールされません。Web からのダウンロードを最適化すると、帯域幅の使用状況および使用時間を抑えることができるので、接続速度の遅いユーザーにとっては特に便利です。Web からのダウンロードを無効にして、すべてのコンピュータに同じバージョンのコンポーネントをインストールすると、一貫した環境を作成できます。

  • 自動インストール

    自動インストールを使用して、ユーザーが必要としたときにだけコンポーネントを配布します。たとえば、Internet Explorer 6 でユーザーのコンピュータに Microsoft Virtual Machine が必要であるということが検出されると、自動的に配布ポイント (LAN シェアなど) を検索し、必要なコンポーネントがインストールされます。これにより、ユーザーに必要なコンポーネントだけをインストールして、時間やディスク領域を節約できます。

  • 自動デジタル署名

    • Internet Explorer 6 のパッケージには、配布用にデジタル署名を施すことができます。デジタル署名を含めることにより、パッケージが改ざんされていないこと、発行元が信頼できることを保証します。


ブラウザのカスタマイズ オプション

Internet Explorer カスタマイズ ウィザードを使用すると、ブラウザの次の部分をカスタマイズできます。

  • ブラウザ名
  • ツール バー
  • カスタム ロゴおよび動画ビットマップ
  • 重要な URL
  • お気に入りとリンク
  • ウェルカム ページ
  • ユーザー エージェント文字列
  • 接続の設定
  • セキュリティ (証明機関および Authenticode セキュリティを含む)
  • セキュリティの設定 (セキュリティ ゾーンとプライバシーおよびコンテンツの規制を含む)


その他の主な機能

IEAK を使用すると、ブラウザそのものをカスタマイズできるだけでなく、次の設定もカスタマイズすることができます。

  • 管理者が許可した ActiveX コントロール

    実行を許可するコントロール、禁止するコントロールを指定します。これにより、社内で同じバージョンの Internet Explorer を維持し、オーバーヘッドやトラブルシューティングを軽減できます。許可した ActiveX コントロールのセットは、IEAK プロファイル マネージャのシステム ポリシーおよび制限を使用して、有効にしたり動的に管理することができます。

  • IEAK 6 の機能

    カスタム パッケージに必要な機能だけを表示します。たとえば、[お気に入り] だけをカスタマイズする場合は、ウィザードのその他のページをすべて非表示にして、処理にかかる時間や手間を省きます。

  • 単一のディスク ブランド

    Internet Explorer 4.01 SP1 以降を実行しているコンピュータ用に、カスタマイズ ウィザードを使用して、独自の文字列およびブランド情報を含む単一のフロッピー ディスクを作成することができます。

  • 自動構成

    ブラウザやコンポーネントの設定、およびシステム ポリシーや制限は、定期的に自動更新したり、ブラウザを起動するたびに自動更新することができます。この機能を使用すると、Internet Explorer 6 の設定と Windows のプロファイルの設定を簡単に構成し、社内全体のユーザーに配布することができます。

  • Outlook Express

    Outlook Express を Internet Explorer 6 と共に使用して、メールおよびニュース サーバーの設定の作成に使用できます。また、ウェルカム電子メール メッセージを作成したり、情報パネルをカスタマイズしたりできます。Outlook Express にはこのほかに、ニュースグループの作成、メッセージのルール、表示オプションなどのカスタマイズ可能なオプションがあります。これらの機能を使用すると、新しいコンピュータやユーザーにメールの設定を行ったり、社内全体で標準化されたメール クライアントを使用することができます。

  • Office Custom Installation Wizard (OCIW) モード

    Internet Explorer 6 を Microsoft Office XP と共に簡単に展開できるように、IEAK には Office Toolkit としての機能が備わっており、OCIW からすぐにアクセスできます。


カスタマイズの概要

Internet Explorer のカスタム パッケージを作成および展開するには、デスクトップ コンポーネントをアップグレードまたは変更するときと同じ処理を行います。展開を適切に計画するには、次の手順に従って操作することをお勧めします。

  1. 情報の収集と意思決定

    カスタム パッケージ作成のチェックリストを使用して、必要な情報およびファイルを収集します。チェックリストを使用すると、配布の種類やパッケージに入れるコンポーネントなど、展開に関する意思決定を行うのに便利です。

  2. IEAK の使い方の学習

    IEAK を使用して、パイロット展開パッケージを作成します。カスタマイズ ウィザードの指示に従って操作し、テスト パッケージを作成します。こうすると、使用できるすべてのオプションを表示することができ、カスタム パッケージの作成処理を理解することができます。

  3. 最初のテスト展開の実行

    まず、ラボのテスト用コンピュータでパイロット展開パッケージをテストします。テスト ラボの管理の説明およびガイドラインは、「パイロット プログラムの作成」に含まれています。すべてのプラットフォームおよびインストール メディアの種類について、インストールの処理とブラウザの構成をテストします。

  4. 2 回目のテスト展開の実行

    1 回目のテスト展開の後、テスト結果に応じて展開パッケージを更新し、ブラウザ パッケージにバージョン番号を割り当てます。ラボのテスト用コンピュータで、展開パッケージの最終テストを行います。展開パッケージに加えた変更がどんなに小さなもので、その変更が展開パッケージにそれほど大きな影響を与えることはないと考えるのは危険です。

  5. 展開

    最終バージョンのパッケージのテストと承認が終わったら、社内に展開します。

計画、開発、およびテストを繰り返すこの処理では、パッケージの展開準備が整うまでに、単一または複数のサイクルを必要とする場合があります。


カスタム パッケージのチェックリスト

次のチェックリストを使用すると、Internet Explorer のカスタム パッケージを作成するために必要な情報を収集することができます。

  • ファイルの場所と配布
  • カスタム コンポーネント
  • CD-ROM 自動実行のカスタマイズ
  • タイトル バーおよびビットマップのカスタマイズ
  • ユーザー側の手順
  • インストール オプション
  • Web での配布
  • コンポーネント ダウンロード
  • インストール先ディレクトリ
  • 接続マネージャのカスタマイズ
  • デジタル署名
  • ブラウザのカスタマイズ
  • 証明書のカスタマイズ
  • URL の収集
  • ユーザー エージェント文字列
  • 自動接続
  • Outlook Express のカスタマイズ
  • LDAP アドレス サーバー

チェックリストに使用する情報を入力し、個別に印刷できます。すべてのチェックリストを一度に印刷するには、目次で [展開ガイド] をクリックし、[カスタム パッケージのチェックリスト] をマウスの右ボタンでクリックし、[印刷] をクリックし、[選択された見出しおよびすべてのサブトピックを印刷] を選択します。


ファイルの場所と配布のチェックリスト

IEAK を使用してカスタム パッケージを作成および展開する前に、このチェックで挙げられている情報を入手しておく必要があります。

このワークシートを印刷して、空欄に自分の情報を記入できます。IEAK で作業するときに、ワークシートを使用して自分のデータを入力できます。

ファイルの場所

カスタム要素 | 場所
作成先フォルダ |

配布方法

使用 | 配布メディア
 | ダウンロード
 | CD-ROM
 | フラット (すべてのファイルが 1 つのディレクトリに存在する)
 | 単一のディスク ブランド


カスタム コンポーネントのチェックリスト

IEAK を使用してカスタム パッケージを作成および展開する前に、次の情報を入手しておく必要があります。

このワークシートを印刷して、空欄に自分の情報を記入できます。IEAK で作業するときに、ワークシートを使用して自分のデータを入力できます。

コンポーネント

カスタム要素 | 使用する情報
名前 |
場所 |
コマンド (.exe ファイルの名前。.cab ファイルの場合のみ) |
グローバル一意識別子 (GUID) |
説明 |
パラメータ |
アンインストール キー |
バージョン |

注

  • コンポーネントが .cab ファイルの場合は、カスタマイズ中にウィザードの [Custom Components] ページの [Command] ボックスに、.exe ファイルの名前を入力する必要があります。

カスタム コンポーネントは 10 個まで追加できます。

インストールのタイミング

チェック | インストール (いずれかを選択)
 | Internet Explorer の前
 | Internet Explorer の後
 | システムの再起動の後

インストールの条件

チェック | 条件
 | Internet Explorer が正しくインストールされたときにのみ、インストールします。

IEAK で、Internet Explorer が正しくインストールされたときにのみ、カスタム コンポーネントをインストールするように指定します。


CD-ROM 自動実行のカスタマイズのチェックリスト

IEAK を使用してカスタム パッケージを作成および展開する前に、次の情報を入手しておく必要があります。

このワークシートを印刷して、空欄に自分の情報を記入できます。IEAK で作業するときに、ワークシートを使用して自分のデータを入力できます。

CD-ROM 自動実行オプション

カスタム要素 | 使用する情報
タイトル バーの文字列 |
カスタム背景ビットマップの場所 |
標準の文字列の色 (いずれかを選択) |
強調表示した文字列の色 (いずれかを選択) |

ボタンのスタイル

インストール中に表示されるボタンのスタイルとして、いずれかを選択できます。

チェック | ボタンのスタイル (いずれかを選択)
 | 標準のボタン
 | 3D ビットマップ ボタン
 | カスタム ボタン ビットマップ

注

  • カスタム ボタン ビットマップを使用する場合は、ビットマップ ファイルの場所を指定する必要があります。

CD-ROM の詳細設定

カスタム要素 | 使用する情報
テキスト ファイルの詳細情報 |
キオスク モードのスタート ページ |

ブラウザをキオスク モードで起動しない場合、キオスク モードのスタート ページは使用されません。


タイトル バーおよびビットマップのカスタマイズのチェックリスト

IEAK を使用してカスタム パッケージを作成および展開する前に、次の情報を入手しておく必要があります。

このワークシートを印刷して、空欄に自分の情報を記入できます。IEAK で作業するときに、ワークシートを使用して自分のデータを入力できます。

セットアップ ウィザードのタイトルおよびビットマップ

次のタイトルおよびビットマップは、ユーザーが Windows Update セットアップ ウィザードを実行してカスタム パッケージをインストールするときに表示されます。

カスタム要素 | 使用する情報
セットアップ ウィザードのタイトル バーの文字列 |
画面の左側に表示するビットマップのパス (先頭ページ) |
画面の上部に表示するビットマップのパス (先頭ページを除くすべてのページ) |
カスタム コンポーネントのインストールのタイトル |


ユーザー側の手順のチェックリスト

IEAK を使用してカスタム パッケージを作成および展開する前に、次の情報を入手しておく必要があります。

このワークシートを印刷して、空欄に自分の情報を記入できます。IEAK で作業するときに、ワークシートを使用して自分のデータを入力できます。

以下の情報は、ブラウザのインストール中に必要となるユーザー側の操作のレベルに影響します。インストール中に、ユーザーにどの程度の操作を行わせるか (完全、一部、または操作させない) を指定します。

チェック | インストールの種類 (いずれかを選択)
 | インタラクティブ
 | ハンド フリー
 | 完全サイレント


インストール オプションのチェックリスト

IEAK を使用してカスタム パッケージを作成および展開する前に、次の情報を入手しておく必要があります。

カスタマイズするオプションごとにこのワークシートを印刷して、空欄に自分の情報を記入できます。IEAK で作業するときに、ワークシートを使用して自分のデータを入力できます。

最小インストール

最小インストールには Web ブラウザが含まれます。その他のコンポーネントは必要に応じてインストールします。

標準インストール

標準インストールには、Web ブラウザ、Outlook Express、Windows Media Player、およびその他のマルチメディア拡張機能が含まれます。

完全インストール

完全インストールには、Web ブラウザ、Outlook Express、Windows Media Player、Microsoft Virtual Machine、追加用 Web フォント、およびその他のマルチメディア拡張機能が含まれます。

カスタム インストール

カスタム インストール オプションは 10 個まで作成できます。ユーザーは、インストール時にこの 10 個の中から選択します。

チェック | インストール オプション (いずれかを選択)
 | 最小構成
 | 標準構成
 | 完全構成
 | カスタム


Web での配布のチェックリスト

IEAK を使用してカスタム パッケージを作成および展開する前に、次の情報を入手しておく必要があります。

このワークシートを印刷して、空欄に自分の情報を記入できます。IEAK で作業するときに、ワークシートを使用して自分のデータを入力できます。

ダウンロード サイト

ユーザーは、カスタム パッケージを Web サイトからダウンロードできます。

カスタム要素 | 使用する情報
サイト名 |
サイトの URL |
サイトの地域 |

サンプル タウンロード サイト

次に、Web での配布に使用する情報の例を示します。

カスタム要素 | 使用する情報
サイト名 | Microsoft
サイトの URL | http://www.microsoft.com/
サイトの地域 | 北米


コンポーネント ダウンロードのチェックリスト

IEAK を使用してカスタム パッケージを作成および展開する前に、次の情報を入手しておく必要があります。

このワークシートを印刷して、空欄に自分の情報を記入できます。IEAK で作業するときに、ワークシートを使用して自分のデータを入力できます。

Windows Update オプション

チェック | Windows Update オプション (いずれかを選択)
 | [ツール] メニューから [Windows Update] コマンドを削除します。
 | Windows Update の既定の URL を使用します。
 | カスタム アドオンの URL およびメニュー テキストを使用します。

注

  • カスタム アドオンの URL およびメニュー テキストを使用する場合は、カスタム URL およびメニュー項目の情報が必要です。

カスタム URL およびメニュー項目

Windows Update セットアップ ウィザードへのアクセスにカスタム アドオンの URL およびメニュー テキストを使用する場合は、この情報を指定する必要があります。

カスタム要素 | 使用する情報
アドオン コンポーネントのメニュー テキスト |
アドオン コンポーネント ページの URL |


インストール先ディレクトリのチェックリスト

IEAK を使用してカスタム パッケージを作成および展開する前に、次の情報を入手しておく必要があります。

このワークシートを印刷して、空欄に自分の情報を記入できます。IEAK で作業するときに、ワークシートを使用して自分のデータを入力できます。

チェック | カスタム要素
 | ユーザーがインストール先ディレクトリを選択できるようにします。
 | [Program Files] フォルダ内の指定したフォルダにインストールします。
 | カスタム フォルダの完全なパスを指定します。

注

  • ユーザーのコンピュータに Internet Explorer が既にインストールされている場合、既存のものは新しいバージョンによって上書きされます。カスタム ブラウザは、指定した場所にはインストールされません。
カスタム要素 | 使用する情報
カスタム パッケージへのパス |


接続マネージャのカスタマイズのチェックリスト

IEAK を使用してカスタム パッケージを作成および展開する前に、次の情報を入手しておく必要があります。

このワークシートを印刷して、空欄に自分の情報を記入できます。IEAK で作業するときに、ワークシートを使用して自分のデータを入力できます。

カスタム要素 | 使用する情報
指定したカスタム プロファイルの使用 |
カスタム プロファイルへのパス |

注

  • カスタム プロファイルへのパスは、カスタム プロファイルを使用するように指定した場合にのみ必要です。


デジタル署名のチェックリスト

IEAK を使用してカスタム パッケージを作成および展開する前に、次の情報を入手しておく必要があります。

このワークシートを印刷して、空欄に自分の情報を記入できます。IEAK で作業するときに、ワークシートを使用して自分のデータを入力できます。

カスタム要素 | 使用する情報
証明書上の会社名 |
ソフトウェア発行元証明書 (.spc) のパス |
秘密キー (.pvk) のパス |
説明 |
詳細情報の URL |
タイム スタンプの URL |


ブラウザのカスタマイズのチェックリスト

IEAK を使用してカスタム パッケージを作成および展開する前に、次の情報を入手しておく必要があります。

このワークシートを印刷して、空欄に自分の情報を記入できます。IEAK で作業するときに、ワークシートを使用して自分のデータを入力できます。

カスタム ビットマップは不要です。既定の Internet Explorer のロゴおよび画像を使用できます。

カスタム要素 | 使用する情報
タイトル バーの文字列 |
ツール バーの背景のビットマップの場所 |
ツール バーのボタンのビットマップの場所 |
静止ロゴのビットマップ (小さなビットマップ) の場所 |
静止ロゴのビットマップ (大きなビットマップ) の場所 |
動画ロゴのビットマップ (小さなビットマップ) の場所 |
動画ロゴのビットマップ (大きなビットマップ) の場所 |


証明書のカスタマイズのチェックリスト

IEAK を使用してカスタム パッケージを作成および展開する前に、次の情報を入手しておく必要があります。

このワークシートを印刷して、空欄に自分の情報を記入できます。IEAK で作業するときに、ワークシートを使用して自分のデータを入力できます。

ルート証明書によって、階層構造の中の下位の証明書に継承させることができる信頼レベルが提供されます。それぞれの証明書は、ルート証明書に到達するまで、親の証明書が検証されます。

カスタム要素 | 使用する情報
新しいルート証明書のパス |


URL の収集のチェックリスト

IEAK を使用してカスタム パッケージを作成および展開する前に、次の情報を入手しておく必要があります。

このワークシートを印刷して、空欄に自分の情報を記入できます。IEAK で作業するときに、ワークシートを使用して自分のデータを入力できます。

カスタム要素 | 使用する情報
ホーム ページの URL |
検索バーの URL |
オンライン サポート ページの URL |
お気に入りの URL 1 (200 個まで) |
お気に入りの URL 2 (200 個まで) |
お気に入りの URL 3 (200 個まで) |
製品の更新情報のページの URL |
カスタムのウェルカム ページの URL |


ユーザー エージェント文字列のチェックリスト

IEAK を使用してカスタム パッケージを作成および展開する前に、次の情報を入手しておく必要があります。

このワークシートを印刷して、空欄に自分の情報を記入できます。IEAK で作業するときに、ワークシートを使用して自分のデータを入力できます。

カスタム要素 | 使用する情報
ユーザー エージェント文字列に追加する文字列 |

注

  • ユーザー エージェント文字列の例に Mozilla/4.0(compatible;MSIE 6;Windows NT;Your custom text) があります。


自動接続のチェックリスト

IEAK を使用してカスタム パッケージを作成および展開する前に、次の情報を入手しておく必要があります。

このワークシートを印刷して、空欄に自分の情報を記入できます。IEAK で作業するときに、ワークシートを使用して自分のデータを入力できます。

必要なサインアップ ファイルは、サインアップ方法によって異なります。作業ディレクトリに、次のうち必要なファイルをコピーする必要があります。

  • Icwsign.htm
  • Signup.htm
  • インターネット サインアップ (.isp) ファイル
  • インターネット設定 (.ins) ファイル

サインアップ ファイル

カスタム要素 | 使用する情報
サインアップ ファイルへのパス |

サインアップ サーバー情報

カスタム要素 | 使用する情報
接続名 |
ファイル名 |
市外局番/電話番号 |
国番号/ID |
ユーザー名 |
パスワード |
最初のオンライン サインアップ ページの URL |

次の詳細なサインアップ サーバー オプションもカスタマイズできます。

カスタム要素 | 使用する情報
静的 DNS アドレス (プライマリ) |
静的 DNS アドレス (セカンダリ) |

インターネット設定ファイル

カスタム要素 | 使用する情報
接続名 |
ファイル名 |
市外局番/電話番号 |
国番号/ID |
ユーザー名 |
パスワード |

ユーザーがサーバーにサインアップする場合、または管理者がサーバーなしのサインアップを使用している場合は、ブランド情報をインターネット設定 (.ins) ファイルに適用できます。こうすると、サインアップ中にブランドが表示されます。ブランド情報を表示するには、次の情報が必要です。

カスタム要素 | 使用する情報
キャビネット ファイル (.cab) の名前 |
.cab ファイルへの URL |


Outlook Express のカスタマイズのチェックリスト

IEAK を使用してカスタム パッケージを作成および展開する前に、次の情報を入手しておく必要があります。

このワークシートを印刷して、空欄に自分の情報を記入できます。IEAK で作業するときに、ワークシートを使用して自分のデータを入力できます。

Outlook Express のアカウント

カスタム要素 | 使用する情報
受信メール サーバー |
送信メール (SMTP) サーバー |
インターネット ニュース (NNTP) サーバー |

Outlook Express のコンテンツの設定

カスタム要素 | 使用する情報
情報パネルの URL |
情報パネルのローカル HTML ファイル |
ウェルカム メッセージの HTML ファイルのパス |
ウェルカム メッセージの送信者 |
ウェルカム メッセージの返信先の名前 |

Outlook Express のカスタム設定

カスタム要素 | 使用する情報
ニュースグループ 1 |
ニュースグループ 2 |
ニュースグループ 3 |
その他のメール アカウントのサービス名 |
その他のメール アカウントのサービスの URL |


LDAP アドレス サーバーのチェックリスト

IEAK を使用してカスタム パッケージを作成および展開する前に、次の情報を入手しておく必要があります。

このワークシートを印刷して、空欄に自分の情報を記入できます。IEAK で作業するときに、ワークシートを使用して自分のデータを入力できます。

アドレス帳のディレクトリ サービス

カスタム要素 | 使用する情報
サービス名 (わかりやすいもの) |
サービス名 (LDAP) |
サービス Web サイト |
検索ベース |
サービス ビットマップ ファイルのパス |


IEAK プロファイル マネージャとは

Internet Explorer をインストールする前に、Internet Explorer 6 カスタマイズ ウィザードを使ってカスタム パッケージに自動構成および自動検出を組み込むことができます。これらの機能を使うと、自動構成 .ins ファイル (サーバー上で管理されている) でユーザーのコンピュータを自動的に更新できます。管理者は、ブラウザの構成の設定を更新する間隔を指定できます。

Internet Explorer をインストールした後に、IEAK プロファイル マネージャを使って、ユーザーのコンピュータにあるブラウザ構成の設定を管理することができます。IEAK プロファイル マネージャを使うと、自動構成 .ins ファイルを開いたり、デジタル署名やセキュリティ ゾーン オプションなどの設定を変更することができます。

また、インストールの前にこの機能を設定しなかった場合は、IEAK プロファイル マネージャを使って自動構成を有効にすることができます。自動検出機能が使用可能であれば、更新された自動構成 .ins ファイルが検索されます。または、クライアント コンピュータで、ブラウザの自動構成を手作業で設定することができます。

企業内管理者の方の場合は、IEAK プロファイル マネージャを使用すると、中央からシステムの設定にすばやく簡単にアクセスでき、Internet Explorer のバージョン管理が楽になります。自動構成を使用するには、プロファイル マネージャによって生成される .ins ファイルおよび キャビネット (.cab) ファイルからなるプロファイルを作成する必要があります。プロファイルには、ブラウザの構成に使用される情報が含まれます。プロファイルを作成したら、それをサーバーに置きます。

Internet Explorer 6 カスタマイズ ウィザードを実行するときに、.ins ファイルへのサーバー パスを入力します。後で設定を変更する必要がある場合は、.ins ファイルを変更するだけです。次にユーザーがブラウザを起動したとき、または指定したスケジュールに従って、ユーザーのコンピュータに変更が反映されます。

IEAK プロファイル マネージャを実行するには

  1. [スタート] ボタンをクリックし、[プログラム] をポイントし、[Microsoft IEAK 6] をポイントして、[IEAK プロファイル マネージャ] をクリックします。
  2. [ファイル] メニューの [開く] をクリックして編集する .ins ファイルを開くか、[ファイル] メニューの [新規作成] をクリックして新しい .ins ファイルを作成します。
  3. [ウィザードの設定] または [ポリシーおよび制限] で目的の分類をクリックします。
  4. 変更する設定を編集します。
  5. [ファイル] メニューの [名前を付けて保存] をクリックし、名前を入力します。
  6. .ins ファイルのパス、.cab ファイルの URL、および .cab ファイルのファイル名が既定のファイル名ではない場合は .cab ファイルのファイル名を、それぞれ入力します。

注

  • プロファイル マネージャを起動する前に、少なくとも 1 度は Internet Explorer 6 カスタマイズ ウィザードを実行する必要があります。
  • 自動構成 .ins ファイルを保存する既定のフォルダは \build directory\Ins\operating system\language\ です。たとえば、Windows 32 ビット プラットフォームで作成された英語版の .ins ファイルは、\Build1\Ins\Win32\En フォルダに保存されます。
  • ユーザーのコンピュータの構成の設定を更新する前に、IEAK プロファイル マネージャによって生成された自動構成 .ins ファイルと関連する .cab ファイルを、作業ディレクトリにコピーし、設定をテストしてください。変更を確認した後、新しい自動構成 .ins ファイルを製品サーバーにコピーします。こうすると、自動構成によってユーザーのコンピュータの設定が更新されます。
  • .ins ファイルのバージョン番号が変更されていない場合は、新しい .cab ファイルがダウンロードされません。バージョン番号は、.ins ファイルの変更日時と変更回数で構成されます。
  • .adm ファイルに詳しい場合は、[ポリシー] メニューの [インポート] をクリックし、自分の .adm ファイルに格納されているポリシーおよび制限を使用することができます。
  • 自動構成を使用しており、同じ自動構成ファイルを使用して Internet Explorer 5 以降と Internet Explorer 4.0 の両方をサポートしている場合は、両方の間で設定が異なっていると、Internet Explorer 4.0 にはその設定が適用されません。


ブラウザ構成の設定の更新

Internet Explorer カスタマイズ ウィザードは、作成したカスタム パッケージごとに自動構成 .ins ファイルを作成します。既定では、このファイルには Install.ins という名前が付けられますが、各カスタム パッケージに対するファイルの名前を変更することができます。

ブラウザをインストールした後に、IEAK プロファイル マネージャを使って自動構成 .ins ファイルを開き、設定を変更し、保存することにより、構成の設定を更新することができます。また IEAK プロファイル マネージャは、自動構成 .ins ファイルを保存するたびに、最新の関連ファイルも保持します。

ウィザードの設定だけでなく、ポリシーおよび制限も変更できます。

ウィザードの設定

ウィザードの設定は、Internet Explorer カスタマイズ ウィザードの段階 2 から 5 で最初に構成したブラウザおよびコンポーネントのオプションに対応しています。次の設定を変更できます。

  • ブラウザ名
  • デジタル署名
  • お気に入り
  • ユーザー エージェント文字列
  • 接続の設定
  • 重要な URL
  • Outlook Express のアカウント

ポリシーおよび制限

ポリシーおよび制限の設定は、Internet Explorer カスタマイズ ウィザードの段階 5 の[ポリシーおよび制限] 画面で最初に構成したオプションに対応しています。次の設定を変更できます。

  • Microsoft NetMeeting
  • インターネット設定
  • 個人情報管理
  • 企業の制限
  • Microsoft chat
  • Web のデスクトップ
  • 企業の設定

IEAK プロファイル マネージャを使用してウィザードの設定を変更するには

  1. [スタート] ボタンをクリックし、[プログラム] をポイントし、[Microsoft IEAK 6] をポイントして、[IEAK プロファイル マネージャ] をクリックします。
  2. [ファイル] メニューから、次のいずれかの操作を行います。
    • [開く] をクリックし、変更する .ins ファイルを開きます。
    • [新規作成] をクリックして .ins ファイルを新規作成します。
  3. [ウィザードの設定] で変更する設定をクリックし、情報を編集します。
  4. [ファイル] メニューの [名前を付けて保存] をクリックし、[.INS ファイルのフル パスとファイル名] ボックスで .ins ファイルの完全なパスを指定します。

IEAK プロファイル マネージャを使用してシステム ポリシーおよび制限を変更するには

  1. [スタート] ボタンをクリックし、[プログラム] をポイントし、[Microsoft IEAK 6] をポイントして、[IEAK プロファイル マネージャ] をクリックします。
  2. [ファイル] メニューから、次のいずれかの操作を行います。
    • [開く] をクリックし、変更する .ins ファイルを開きます。
    • [新規作成] をクリックして .ins ファイルを新規作成します。
  3. フォルダをダブルクリックし、ポリシーまたは制限をクリックします。
  4. 変更する情報を編集します。
  5. [ファイル] メニューの [名前を付けて保存] をクリックし、[.INS ファイルのフル パスとファイル名] ボックスで .ins ファイルの完全なパスを指定します。
  6. [キャビネット (.CAB) ファイルへの URL パス] ボックスで、.cab ファイルへの完全なパスを指定します。

注

  • 変更内容を保存すると、指定した .ins ファイルを使用して、[構成情報のキャビネット (.CAB) の名前] ボックスで指定した .cab ファイルが作成されます。このファイル名は、必要に応じて編集できます。


自動構成の管理

自動構成 URL を使用すると、自動的にユーザーのブラウザに IEAK プロファイルを参照させることができます。この場合、.ins ファイルを指定するか、または、.ins ファイルを自動生成するアクティブ サーバー ページ (.asp) ファイルを作成して指定することができます。

詳細なプロキシ設定の構成および保守を可能とする .js 形式、.jvs 形式、または .pac 形式のスクリプト ファイルを指定することもできます。自動構成および自動プロキシの両方に対して URL を指定すると、.ins ファイルには自動プロキシの URL が格納されます。その URL の正しい書式は、http://share/test.ins です。

自動構成を有効にするには

  1. [スタート] ボタンをクリックし、[プログラム] をポイントし、[Microsoft IEAK 6] をポイントして、[IEAK プロファイル マネージャ] をクリックします。
  2. [ファイル] メニューから、次のいずれかの操作を行います。
    • [開く] をクリックし、変更する .ins ファイルを開きます。
    • [新規作成] をクリックして .ins ファイルを新規作成します。
  3. [ウィザードの設定] で [自動構成] をクリックします。
  4. [自動構成を使用する] チェック ボックスをオンにします。
  5. [自動構成 URL ( .INS ファイル)] ボックスに、.ins ファイルの URL を入力します。
  6. [自動プロキシ URL (.JS、.JVS、または .PAC ファイル)] ボックスに、自動プロキシ スクリプトの URL を入力します。

注

  • [自動構成を実行する間隔] ボックスで、更新の間隔を設定できます。ここで、次の更新までの間隔を分単位で指定します。更新の間隔を指定しないと、ユーザーがブラウザを起動したり、Web ページを参照したりするたびに、ブラウザが更新されます。


自動構成 .ins ファイルの保存場所の変更

自動構成 .ins ファイルを別の製品サーバーに移動する必要がある場合は、IEAK プロファイル マネージャを使って、ブラウザの自動構成 URL を更新することができます。自動構成 .ins ファイルを指定した間隔で更新されるように設定している場合は、ブラウザの自動構成 URL を更新した後に、変更を反映するために間隔を 2 回考慮する必要があります。

ブラウザの自動構成 URL を更新するには

  1. [スタート] ボタンをクリックし、[プログラム] をポイントし、[Microsoft IEAK 6] をポイントして、[IEAK プロファイル マネージャ] をクリックします。
  2. [ファイル] メニューの [開く] をクリックし、カスタム パッケージの自動構成 .ins ファイルをクリックします。
  3. [ウィザードの設定] で [自動構成] をクリックします。
  4. [自動構成を使用する] チェック ボックスをオンにします。
  5. [自動構成 URL (.INS ファイル)] ボックスで、新しいサーバーへのパスを入力します。
  6. [ファイル] メニューの [名前を付けて保存] をクリックし、[.INS ファイルのフル パスとファイル名] ボックスに拡張子 .ins を付けてファイル名を入力します。

重要

  • 保存先のフォルダに作成された .cab ファイルは、.ins ファイルと同じフォルダにコピーする必要があります。

注

  • ユーザーの構成の設定がすべて更新されたことが確認できるまで、古い .ins ファイルはサーバーに残しておきます。 ユーザーがブラウザを起動し、ブラウザの構成の設定が更新されるようにスケジュールされると、ユーザーのコンピュータ上で、ブラウザの自動構成 URL を参照するポインタが更新されます。この時点では、ブラウザはまだ元の自動構成 .ins ファイル (例えば、http://既存のパス/Default.ins)の設定を使用しています。

    ユーザーが次にブラウザを起動し、ブラウザの構成の設定が更新されるように再度スケジュールされると、ブラウザが新しい自動構成 .ins ファイル (例えば、http://新しいパス/Default.ins) を読み込みます。ユーザーのすべてのコンピュータの設定が更新されたことを確認したら、自動構成 .ins ファイルのコピーを、元の場所から削除することができます。


IEAK プロファイル マネージャを使用したファイルの生成

構成の設定を更新して保存すると、IEAK プロファイル マネージャが次のファイルを生成します。

ファイルの種類 | 目的
自動構成 .ins ファイル | Internet Explorer がユーザーのコンピュータ上にあるブラウザの構成の更新に使用する、ブラウザおよびコンポーネントの設定が含まれます。これらの設定は、IEAK プロファイル マネージャの [Wizard Settings] セクションで指定できます。
キャビネット (.cab) ファイル | ユーザーのコンピュータにダウンロードされるインストール ファイルが含まれます。IEAK プロファイル マネージャによって作成される .cab ファイルには、デジタル署名を施してください。.cab ファイルの署名については、「プログラムへの署名」を参照してください。 自動構成 .cab ファイルには、情報 (.inf) ファイルも含まれます。
情報 (.inf) ファイル | オペレーティング システムがユーザーのコンピュータ上にあるシステム構成の更新に使用するシステム ポリシーと制限が含まれます。これらの設定は、IEAK プロファイル マネージャの [ポリシーおよび制限] セクションで指定できます。 各 .inf ファイルには、バージョン情報も含まれます。構成の設定を変更すると、IEAK プロファイル マネージャが影響を受けた .inf ファイルとそのバージョン情報を更新し、関連する .cab ファイルに再度まとめます。

Internet Explorer は自動構成 .ins ファイルのコンテンツをダウンロードして処理し、ユーザーのコンピュータで必要な設定を変更します。また、オペレーティング システムの関連する .cab ファイルをダウンロードし、内容を取り出して処理します。自動構成 .ins ファイルのバージョン番号が変更されていない場合は、新しい .cab ファイルがダウンロードされません。バージョン番号は、.ins ファイルが変更された日付とファイルが改訂された回数からなります。


ユーザー グループごとに異なる構成の作成

ユーザーごとに要求が異なる場合や、一部のユーザーの構成の設定だけを変更したい場合は、複数の自動構成 .ins ファイルを作成することができます。IEAK プロファイル マネージャを使って、各グループごとに異なる構成の設定を指定し、個別の usergroup .ins ファイルとして保存できます。 usergroup には、各ユーザー グループに固有の名前を付けます。IEAK プロファイル マネージャは、関連する .cab ファイルを自動的に生成します。たとえば、経理部に固有の構成を指定する場合は、Finance.ins という名前で保存します。そうすると、IEAK プロファイル マネージャが関連する必要な .cab ファイルを生成します。

注

  • 複数の自動構成 .ins ファイルを作成する場合は、カスタム パッケージが正しいファイルを使用するように構成されていることを確認してください。また、自動化されたサーバー ソリューションを使用することもできます。これにより、カスタム パッケージを作り直さずに、複数の .ins ファイルを使用できるようになります。


カスタム ポリシー テンプレートの使用

IEAK プロファイル マネージャは、既定の Windows ポリシー テンプレート ファイルか管理ファイル (.adm) のセット を使って、システム ポリシーと制限の規則を定義できます。.adm ファイルおよびポリシーと制限は、Windows 32 ビットおよび Windows 16 ビット プラットフォームに標準の機能です。.adm ファイルを詳しく理解している場合は、独自のテンプレートを作成して、追加の制限を定義することができます。詳細については、Windows のマニュアルを参照してください。

IEAK プロファイル マネージャを使って、独自の .adm ファイルをインポートし、更新した構成の設定に含めることができます。IEAK プロファイル マネージャは、インポートしたカスタム .adm ファイルのサフィックスを使って、関連する .inf ファイルを生成します。たとえば、Custom.adm という名前のファイルをインポートした場合は、Custom.inf というファイルが生成され、.cab ファイルに追加されます。カスタム .adm ファイルの使い方については、「設定と制限について」を参照してください。


プロファイル マネージャによる Windows 2000 システムの管理

Windows 2000 上で Internet Explorer の展開に無人セットアップを使用している場合は、IEAK プロファイル マネージャを使って Internet Explorer のカスタム設定を指定できます。これらの設定は無人セットアップが実行されたときに構成されます。プロファイル マネージャを使うと、.ins ファイルやキャビネット ファイル(.cab) を作成することができます。.ins ファイルは、Unattend.txt ファイルの [Branding] セクションで指定します。詳細については、Windows 2000 のセットアップに関するヘルプおよびマニュアルを参照してください。

Windows 2000 をプラットフォームに指定するには、[プラットフォーム] メニューの [Windows 2000] をクリックします。ウィザードで設定する場合は、カスタマイズする項目をクリックします。

制限の機能は、ユーザーが変更できる設定を指定するものですが、IEAK プロファイル マネージャで Windows 2000 がプラットフォームの場合は使用できません。Windows 2000 プラットフォームに制限を設定するには、グループ ポリシーを使ってください。詳細については、Windows 2000 のヘルプで「グループ ポリシー」を検索してください。

Windows 2000 は高度な証明書管理機能を持っているため、デジタル証明書のオプションは、IEAK プロファイル マネージャの Windows 2000 には使用できません。詳細については、Windows 2000 のヘルプで「デジタル証明」を検索してください。


パイロット プログラムの作成

テスト バージョンのカスタム パッケージを作成して、ラボの数台のコンピュータにインストールし、パフォーマンスのテストおよび評価を行い、必要な変更を加えてパッケージを更新する必要があります。ラボでのテスト用にテスト プランおよびチェックリストを用意して、テストのチェックリストを使用して正しく完了したタスクを記録したり、処理中に発生したすべての問題をメモします。また、展開および配布の方針をそれぞれテストするチェックリストも用意します。

パイロット グループを特定および選択し、パイロット プログラム用に準備します。組織の規模が大きい場合や、コンピューティング環境がグループによって大きく異なる場合は、環境やグループごとにパイロット プログラムを実行する必要があります。組織内のユーザーとして代表的なグループを探します。成功へ導くために、参加者にはスケジュールの時間を大きく割いてパイロット プログラムに完全に参加してもらいます。

次に、パイロット プログラムの実行に使用できる手順を示します。環境が同じことはないので、これらの手順は指針として使用してください。

展開用のパイロット プログラムを用意するには

パイロット プログラムの管理に必要なタスクおよびソースを特定します。Internet Explorer 6 を組織内に展開する前に、ラボのクライアントを使用して展開方針および構成のテストと練り直しを行います。パイロット プログラムのプランを立てるには、次の手順を実行します。

  1. 適切なパイロット グループを選択します。
  2. パイロット プログラムに必要なリソースおよびタスクを文書化します。
  3. ユーザー トレーニング プランを開発します。
  4. ユーザー サポート プランを開発します。

パイロット プログラム用のテスト パッケージを作成するには

パイロット プログラム用にテスト パッケージを作成する必要があります。

  1. テスト コンピュータに Internet Explorer 6 をインストールします。
  2. IEAK 6 をインストールし、Internet Explorer カスタマイズ ウィザードを実行します。
  3. テスト用のカスタム パッケージを作成します。
  4. 自動構成ファイル (.ins、.js、.pac) を設定します。
  5. ダウンロード サイトを構成し、配布ファイルをインストールします。
  6. 配布ファイルを CD-ROM およびフロッピー ディスクにコピーします。

パイロット プログラムをラボのクライアントに展開するには

適切な配布方法を使用して、Internet Explorer のカスタム パッケージをラボのコンピュータに展開します。たとえば、カスタム パッケージのダウンロード方法を指示した電子メール メッセージをユーザーに送信します。

または、電子メール メッセージにバッチ ファイルを添付し、そのバッチ ファイルをダブルクリックしてカスタム パッケージをインストールするようユーザーに指示します。カスタム パッケージを CD-ROM またはフロッピー ディスクで配布する場合は、それらをユーザーに配布し、インストール方法を指示します。

  1. さまざまな配布方法を使用して、テスト用のカスタム パッケージを配布します。
  2. Internet Explorer セットアップを使用して、テスト用のカスタム パッケージを各クライアントにインストールします。
  3. 各クライアントで Internet Explorer を起動して、正しくインストールされたことを確認します。

パイロット プログラムをラボのクライアントでテストするには

各ラボを設ける物理的な場所を用意し、組織内のハードウェアおよびソフトウェアの環境を反映した各種コンピュータを入手します。リモートからダイヤルするポータブル コンピュータを使用する場合や、業務用データのために別のサーバーまたはメインフレーム コンピュータが必要な場合は、ラボのコンピュータにアナログの電話回線およびネットワークへの適切なアクセス権を用意します。

ラボのクライアントおよびサーバーを、一般的な業務およびユーザーの構成を表すように構成します。すべてのオペレーティング システムおよび業務用アプリケーションの構成のほか、インターネットおよびブラウザの構成を必ず含めます。また、ラボのセットアップを文書化し、セットアップに加えられた変更の記録を管理します。

発生したすべての問題の記録を管理します。これらの記録は、問題解決のためのソリューションを設計するのに役立ちます。

  1. Internet Explorer 6 を実行して、すべてのアドインおよび機能をテストします。
  2. 業務用アプリケーションを実行して、操作に支障がないかチェックします。
  3. テスト プランのチェックリストを使用して、すべての展開タスクを実行します。
  4. 展開処理および移行に関する問題を特定します。
  5. テストのフィードバックに基づき、展開プランを練り直します。

パイロット プログラムをラボのクライアントからアンインストールするには

  1. Internet Explorer 6 およびアドインをアンインストールします。
  2. Internet Explorer 6 のコンポーネントが削除されたことを確認します。
  3. デスクトップ アプリケーションおよび業務用アプリケーションをテストします。

注意

  • 一部の設定のために、Internet Explorer 6 およびカスタム コンポーネントをアンインストールできない場合があります。ラボのクライアントからのアンインストールを能率化するのに便利なカスタム要素については、次の「関連項目」を参照してください。

関連項目

ユーザー トレーニング プランを開発するには

ユーザーの必要に応じて、サポート プランを開発します。カスタム パッケージの最終展開の基礎として、トレーニング プランを使用します。パイロット プログラムからのフィードバックに基づいてプランを練り直し、それを使用して最終展開用にユーザーのトレーニングを行います。

  1. トレーニング スタッフおよびリソースを特定します。
  2. 新規ユーザー用には Internet Explorer 6 の説明を含めます。
  3. 管理者用とエンドユーザー用のトレーニングを分けます。
  4. 管理者に対して IEAK およびプロファイル マネージャのトレーニングを施します。
  5. エンド ユーザーに対して、ヘルプへのアクセスと使い方のトレーニングを施します。

ユーザー サポート プランを開発するには

ユーザーの必要に応じて、サポート プランを開発します。

  1. サポート スタッフおよびリソースを特定します。
  2. カスタム Web ページを使用して、イントラネットに展開のためのオンライン サポートを含めます。
  3. ヘルプ デスクを設けて、エンド ユーザーに管理上のサポートを提供します。

パイロット プログラムのベータ テストを行うには

ラボでのパイロット プログラムが成功したら、カスタム パッケージのベータ テストを行う必要があります。これにより、多くのベータ ユーザーが、パッケージの設定およびカスタマイズ内容で作業できることを確認できます。方針を変更して、ユーザーに影響を与えずに一部の設定を変更することもできます。

  1. 展開するカスタム パッケージを用意します。
  2. カスタム パッケージをパイロット ユーザーに展開します。
  3. ユーザーによる Internet Explorer 6 のインストールおよび使用を監視およびサポートします。

カスタム パッケージを作成するには

カスタム パッケージを作成する準備ができたら、Internet Explorer 6 および IEAK 6 をインストールします。カスタム パッケージには作業用コンピュータの現在の構成がインポートされるので、作業用コンピュータで行ったカスタマイズを元に戻します。

  1. 作業用コンピュータに Internet Explorer 6 をインストールします。
  2. 作業用コンピュータに IEAK 6 をインストールします。
  3. 管理者としてサインインし、IEAK カスタマイズ ウィザードを実行します。
  4. 必要なカスタム パッケージを作成します。
  5. ダウンロード サイトを構成し、配布ファイルをインストールします。
  6. 配布ファイルを CD-ROM およびフロッピー ディスクにコピーします。


CMAK を使用した接続

接続マネージャ管理キット (CMAK) を使用すると、Microsoft 接続マネージャのプロファイルを作成および管理することができます。接続マネージャは、Internet Connection Point Services for RAS の一部で、Windows NT Option Pack に含まれています。

接続マネージャは、ダイヤルアップ ネットワーク接続に似たクライアント アプリケーションです。接続マネージャのプロファイル 1 つにつき、複数の電話番号をサポートしています。接続前、接続中、および接続後に自動的にアプリケーションを実行できます。仮想プライベート ネットワークをセットアップすることもできます。

Phone Book Administrator および電話帳サービスから成る Connection Point Services for Windows NT を接続マネージャに組み込むと、クライアントの接続マネージャのプロファイルに対して、構成、管理、および接続数の動的な更新を自動的に行うことができます。

CMAK で自動接続を作成すると、4 つの利点があります。以下に示します。

  • 接続マネージャのプロファイル 1 つにつき、複数の電話番号を使用できます。
  • 接続前、接続中、および接続後にアプリケーションを自動的に実行できます。
  • アクセス数が変わったときに、接続マネージャの電話帳を自動的に動的に更新できます。
  • 接続マネージャのプロファイルをビットマップ、特定の使用許諾契約、ヘルプ ファイル、およびコマンド ライン パラメータでカスタマイズできます。

注

  • 接続マネージャ管理キット (CMAK) は、IEAK 6 には含まれていません。CMAK は、Windows 2000 Server またはそれ以降、および Windows 2000 Administration Kit で使用できます。以前のバージョンの CMAK は IEAK 5.0 で使用できます。


接続のインポート

接続をインポートするには、ダイヤルアップ ネットワーク (DUN) の設定を IEAK ワークステーションからコピーし、接続の設定をカスタム パッケージに保存します。この方法で接続をインポートすると、すべてのユーザーのワークステーションに共通の DUN エントリが作成されます。各接続のダイヤルアップ、プロトコル、およびプロキシの設定もインポートされます。

複数の DUN エントリをインポートする場合は、IEAK ワークステーションの既定の接続が、ユーザーのワークステーションの既定の接続になります。この方法の最大の利点は、簡単であるという点です。DUN エントリをインポートして、ユーザーの既存の DUN エントリ (個人 ISP) と一緒に使用することができます。

IEAK を使用した DUN 設定の作成は、Dial-Up Point of Presence (RAS サーバーなど) が単一のダイヤルアップ番号を持っており、その番号は今後変更される可能性がないという状況では適切に動作します。既存の接続のインポートの欠点の 1 つに、DUN エントリの静的な特性が挙げられます。ユーザーがたくさんのダイヤルアップ番号を必要とする場合や、RAS 番号が頻繁に変更される場合は、DUN エントリを個別にインポートするのに膨大な時間がかかります。

次のような状況では、DUN 設定の作成に CMAK を使用する必要があります。

  • リモート ユーザーが複数の番号に接続する場合
  • パッケージを複数のユーザー グループに配布し、そのユーザー グループが接続する電話番号がそれぞれ異なる場合


カスタマイズ (インターネット コンテンツ プロバイダ対象)

インターネット コンテンツ プロバイダ (ICP) やソフトウェア ベンダの方は、IEAK を使用することにより、インターネットのアカウントを既に所持しているユーザーを対象としたカスタム ブラウザを作成できます。

また、ICP の方の場合は、カスタム パッケージの一部として弊社の参照サーバーを使用するようなカスタム ブラウザを作成することもできます。この参照サーバーは、ご使用になる地域のインターネット サービス プロバイダに関する情報を提供するものであり、弊社が運営しています。この参照サーバーを使用すれば、サインアップ サーバーにリンクすることができます。

セットアップ プログラムのカスタマイズ

  • Windows Update セットアップ プログラムの外観をカスタマイズして、インストール モード (標準インストールや最小インストールなど) を構成できます。
  • 製品の最新バージョンにアクセスするために、ユーザーにインターネット サーバーを参照させます。
  • Internet Explorer のインストール パッケージに格納する言語を指定できます。Internet Explorer 6 カスタマイズ ウィザードは、作成する言語ごとに実行しなければなりません。

ブラウザのカスタマイズ

  • ホーム ページ、検索ページ、およびサポート ページを指定できます。
  • [お気に入り] の一覧に、リンクやフォルダを読み込むことができます。
  • ブラウザおよび Outlook Express のタイトル バーやロゴを変更できます。Outlook Express をパッケージの一部として配布する場合や、Outlook Express が既にユーザーのコンピュータにインストールされている場合は、Outlook Express のタイトル バーが更新されます。

Internet Explorer のロゴの使用

使用許諾契約書の条項に従い、パッケージ、販促用の物品、および Web サイトには、Internet Explorer のロゴを表示しなければなりません。IEAK Web サイトには、ロゴ情報、Web にそのまま使用できるロゴ、および使用例が用意されています。

カスタム ブラウザへのブランドの方法の図解については、「カスタマイズの仕組み」を参照してください。

重要

  • 使用許諾契約によっては、一部の機能を使用できないことがあります。詳細については、使用許諾契約書を参照してください。


インターネット コンテンツ プロバイダ － ウィザードを実行するための準備

バナー

ウィザードを実行するための準備

Internet Explorer 6 カスタマイズ ウィザードを実行する前に、必要な情報を収集し、カスタム ビットマップを作成する必要があります。

プラットフォームの条件の決定

  • パッケージの作成に使用するコンピュータおよびパッケージをインストールするコンピュータがハードウェアとシステムの必要条件を満たしていることを確認してください。
  • ブラウザ パッケージの暗号化レベルを指定します。Internet Explorer の暗号化については、「IEAK に関する Web サイト」を参照してください。

配布方法の決定

カスタム パッケージの配布方法を決定します。Internet Explorer 6 カスタマイズ ウィザードでパッケージを作成した後で、選択したメディアにファイルを移動する必要があります。ダウンロード可能なパッケージを作成したら、そのパッケージをサーバー上の適切な場所に移動する必要があります。

カスタム パッケージをインターネット サーバーに発行するときは、サーバーへのパスとファイルのダウンロード元の URL を知っている必要があります。そして、カスタム パッケージに関連するすべてのファイルとフォルダを発行するには、[CIE] のようなフォルダを Web サーバー上に作成します。たとえば、サーバーへのパスは、C:\Inetpub\Wwwroot\Cie のように指定します。この Web サーバーの仮想ルートがコンピュータ名の場合、該当する URL は http://コンピュータ名/Cie/ のように指定します。

デジタル証明書の取得

インターネットまたは特別な構成を行っていないイントラネットを経由してファイルを配布する場合は、Internet Explorer 6 カスタマイズ ウィザードで作成したカスタム ファイルやカスタム コンポーネントなどの特定のファイルに署名を施すための準備が必要です。ブラウザのセキュリティ機能を使用すれば、署名が施されていないファイルをダウンロードする際、ユーザーに警告を表示したり、ダウンロード処理を禁止したりできます。デジタル署名は、プログラムの発行元を明らかにし、該当するコードが署名時点以降に変更されていないことを保証するものです。

証明機関から発行元証明書を既に取得している場合は、Internet Explorer 6 カスタマイズ ウィザードでファイルに署名を施すことができます。IEAK で使用する証明書を準備するために、証明書のインポート ウィザードを使用してコンピュータに証明書をインポートできます。拡張子 .spc のファイルを受け取ったら、Windows のエクスプローラまたはマイ コンピュータで .spc ファイルをダブルクリックして、証明書のインポート ウィザードを起動することができます。

Internet Explorer から証明書のインポート ウィザードを起動することもできます。それには、[ツール] メニューの [インターネット オプション] をクリックし、[コンテンツ] タブをクリックして、[証明書] をクリックしてください。[インポート] をクリックすると、証明書のインポート ウィザードが起動します。この後は、ウィザードの指示に従ってください。

ディレクトリ構造の作成

フォルダ名 | 説明
\CIE | IEAK によって作成された、またはカスタム パッケージで参照されるすべてのファイルの親フォルダ
\CIE\Bitmaps | カスタム ビットマップ ファイル (カスタム ブラウザに必要なグラフィック ファイル)

適切なグラフィックスの作成

次のビットマップは、ブラウザでカスタマイズすることもできます。Internet Explorer 6 カスタマイズ ウィザードを実行する前に、ビットマップを \CIE\Bitmaps フォルダに格納してください。

独自に作成した背景とボタンのビットマップは、256 色 (8 ビット) 以上の表示能力を持つコンピュータでだけ表示されます。16 色 (4 ビット) の表示能力を持つコンピュータでは、低解像度用の標準の背景ビットマップとボタン セットが表示されます。

  • CD-ROM 自動実行画面の背景のビットマップ 1 個 (CD-ROM パッケージを作成する場合)。

    カスタム ブラウザを CD-ROM で配布する場合は、ユーザーが CD-ROM を挿入したときに自動実行画面の一部に表示されるビットマップを作成する必要があります。

  • CD-ROM ボタンのカスタム イメージ (CD-ROM パッケージを作成する場合)。
  • Windows Update セットアップ ウィザード用の 2 つのカスタム ビットマップ (外観をカスタマイズする場合)。ウィザードの最初の画面の左側に表示する 162 × 312 ピクセルのビットマップ、およびウィザードの 2 番目以降の画面の上側に表示する 496 × 56 ピクセルのビットマップ。
  • カスタム ツール バー用のビットマップ 1 個 (ボタンとメニューの背景として表示されます)。
  • 256 色の静止ビットマップ イメージ 2 個 (38 x 38 ピクセル 1 個、22 x 22 ピクセル 1 個)。これらを使用すれば、Internet Explorer ブラウザに自社のブランドをロゴとして表示できます。
  • 256 色の動画ビットマップ イメージ 2 個 (38 x 38 ピクセル 1 個、22 x 22 ピクセル 1 個)。これらを使用すれば、Internet Explorer ブラウザに自社のブランドを動画ロゴとして表示できます。

    IEAK には、ブラウザに合ったカスタム版の動画ビットマップを簡単に作成およびプレビューできるようなツールが 2 つ入っています。

ホーム ページ、検索ページ、およびサポート ページ用の URL の指定

ユーザー サイトでブラウザのインストール時に問題が起きたときに備えて、サポート ページを作成しておくと便利です。Internet Explorer 6 カスタマイズ ウィザードを実行中に、サポート ページの URL を指定するように指示するメッセージが表示されます。

注

  • カスタム ブラウザへのブランドの方法の図解については、「カスタマイズの仕組み」を参照してください。


インターネット コンテンツ プロバイダ － 段階 1 : 情報の収集

バナー

段階 1 : 情報の収集

コンテンツ プロバイダおよび開発者の場合、Internet Explorer 6 カスタマイズ ウィザードの段階 1 では、次の情報を指定します。

  • ファイルの場所 － カスタム ブラウザ パッケージの作成先フォルダを指定します。
  • 対象言語 － 作成対象のブラウザ パッケージの言語を指定します。Internet Explorer 6 カスタマイズ ウィザードは、作成対象の言語ごとに起動する必要があります。
  • 配布メディア － CD-ROM やダウンロードなど、配布に使用するメディアを指定します。
  • 機能 － カスタマイズする機能を指定します。たとえば、ブラウザの機能のごく一部だけをカスタマイズする場合には、それらの機能に関する IEAK ウィザード画面だけを表示できます。

注

  • Internet Explorer 6 カスタマイズ ウィザードは、Internet Explorer 6 がインストールされていないと、正しく動作しません。詳細については、「ハードウェアとシステムの必要条件」を参照してください。


インターネット コンテンツ プロバイダ － 段階 2 : セットアップ パラメータのカスタマイズ

バナー

段階 2 : セットアップ パラメータのカスタマイズ

コンテンツ プロバイダの場合、Internet Explorer 6 カスタマイズ ウィザードのこの段階では、次の情報を指定します。

  • 自動バージョン同期 (AVS) による Microsoft コンポーネントのダウンロードまたは更新 － Internet Explorer のダウンロードは必須ですが、Internet Explorer に関連するその他のコンポーネントはダウンロードするかどうかを選択することができます。
  • カスタム コンポーネントの選択 － 必要なコンポーネントを選択します。

    また、追加するコンポーネントは、16 個まで指定できます。それらのコンポーネントは、自己展開型の実行可能ファイル (.exe) であっても、圧縮されたキャビネット (.cab) ファイルであってもかまいません。


インターネット コンテンツ プロバイダ － 段階 3 : セットアップのカスタマイズ

バナー

段階 3 : セットアップのカスタマイズ

コンテンツ プロバイダの場合、Internet Explorer 6 カスタマイズ ウィザードのこの段階では、Windows Update セットアップの外観と動作を次のようにカスタマイズできます。

  • CD-ROM パッケージを作成する場合は、CD-ROM 自動実行画面をカスタマイズできます。
  • CD-ROM パッケージを作成する場合は、CD-ROM に関する詳細なオプションをカスタマイズできます。
  • Internet Explorer およびその他のインターネット ツール用の Windows Update セットアップ ウィザードをカスタマイズできます。これらの設定は、ユーザー側に表示するセットアップの外観に影響します。
  • 独自のインストール オプションを 10 個まで指定できます。また、各オプションを選択したときにインストールすべきコンポーネントも指定できます。
  • パッケージのダウンロード サイトを 10 件まで指定できます。
  • コンポーネントの更新をユーザーに通知する方法を指定できます。
  • セットアップで既存のコンポーネントを検出するかどうか、また、どのコンポーネントがユーザーによるカスタマイズが可能かを詳細に指定できます。
  • ダウンロードしたコンポーネントのうちパッケージに追加していないコンポーネントを、Internet Explorer のオンデマンドのインストール機能でユーザーのコンピュータにインストールするかどうかを指定できます。
  • デジタル証明書を既に取得している場合は、IEAK パッケージの作成中にプログラムに署名できるように、証明機関情報を指定できます。

注

  • カスタム ブラウザへのブランドの方法の図解については、「カスタマイズの仕組み」を参照してください。
  • Internet Explorer 6 カスタマイズ ウィザードでカスタム パッケージを作成するときの流れについては、「IEAK でのカスタム パッケージの生成」を参照してください。


インターネット コンテンツ プロバイダ － 段階 4 : ブラウザのカスタマイズ

バナー

段階 4 : ブラウザのカスタマイズ

コンテンツ プロバイダの場合、Internet Explorer 6 カスタマイズ ウィザードのこの段階では、次の項目をカスタマイズできます。

  • ブラウザのタイトル バー － Internet Explorer および Outlook Express をパッケージに入れて配布した場合や、ユーザーのコンピュータに既に Internet Explorer および Outlook Express がインストールされている場合、カスタム ブラウザのタイトルは、Internet Explorer と Outlook Express の両方に表示されます。
  • ブラウザのツール バーの背景およびボタン － ツール バーには、スクリプトやプログラムを実行するカスタム ボタンを追加できます。
  • ブラウザの右上に表示される Internet Explorer のロゴ
  • ブラウザのホーム ページ、検索ページ、およびオンライン サポート ページ
  • [お気に入り]、[お気に入り] フォルダ、およびリンク バーのリンク
  • ウェルカム ページ － ユーザーがブラウザを最初に起動したときに表示されます。
  • ユーザー エージェント文字列 － ユーザー エージェントを使用すれば、カスタム ブラウザの使用状況を監視することができます。

注

  • カスタム ブラウザへのブランドの方法の図解については、「カスタマイズの仕組み」を参照してください。


インターネット コンテンツ プロバイダ － 段階 5 : コンポーネントのカスタマイズ

バナー

段階 5 : コンポーネントのカスタマイズ

コンテンツ プロバイダの場合、Internet Explorer 6 カスタマイズ ウィザードのこの段階では、次の項目をカスタマイズできます。

  • 既定のプログラムの設定 － 電子メールや HTML の編集に使用される特定のプログラムなど。
  • システム ポリシーおよび設定 － インターネット オプションをあらかじめ設定できます。


インターネット コンテンツ プロバイダ － ブラウザ パッケージの配布方法

バナー

インターネット コンテンツ プロバイダ

ブラウザ パッケージの配布方法

既定では、Internet Explorer 6 カスタマイズ ウィザードは、ユーザーがインターネットを経由してダウンロードすることのできるファイルを作成します。カスタム パッケージは、CD-ROM に格納して配布することもできます。

ダウンロード可能なファイル

カスタム パッケージをインターネット サーバーまたはイントラネット サーバーに作成した場合は、一連のファイルをユーザーがダウンロードできるように、Web サイトをセットアップする必要があります。たとえば、ダウンロード情報やインストール エンジン IE6setup.exe へのリンクを記載したページを作成します。

ブラウザ パッケージをハード ディスクやネットワーク ドライブに作成した場合は、次の項目をインターネット サーバーまたはイントラネット サーバーに移動する必要があります。

  • 配布するブラウザの言語バージョンに対応するフォルダおよびそのフォルダの内容。たとえば、英語版のフォルダ名が En である場合は、[En] フォルダをそれに格納されているファイルと共に移動する必要があります。 このフォルダは、メディアの種類 (ダウンロードなど) およびプラットフォーム (Win32 など) に対応するフォルダの中に作成されます。Internet Explorer 管理者キット 6 が使用できるプラットフォームは、"Win32" のみです。UNIX および 16 ビット Windows クライアントの場合は、Internet Explorer 管理者キット 5.x を使用します。
  • Ie6sites.dat という名前のファイル。このファイルは、Internet Explorer 6 カスタマイズ ウィザードを実行したときに指定したダウンロード サイト (1 つまたは複数個) を示します。

注

  • 図解については、「配布用ファイルの設定方法」を参照してください。
  • Internet Explorer 6 カスタマイズ ウィザードでのファイルの作成の流れについては、「IEAK でのカスタム パッケージの生成」を参照してください。

カスタム パッケージへの署名

Web ブラウザには、ユーザーが有害なプログラムをダウンロードできないようにするセキュリティ機能があります。 セキュリティ レベルおよびプラットフォームによっては、デジタル署名が施されていないプログラムをユーザーがダウンロードしようとすると、ダウンロードできないことを示すメッセージ、または警告メッセージが表示されることがあります。

Internet Explorer 6 カスタマイズ ウィザードで作成されたカスタム .cab ファイルには、ローカル イントラネット ゾーンのセキュリティ レベルを低に設定している場合を除いて、デジタル署名を施してください。また、32 ビット版のブラウザ パッケージと共にカスタム コンポーネントを配布する場合は、それらのコンポーネントにもデジタル署名を施してください。デジタル証明書を既に取得している場合は、Internet Explorer 6 カスタマイズ ウィザードでこれらのファイルに自動的に署名することができます。

注

  • キャビネット ファイルおよびカスタム プログラムに署名を施すには、デジタル証明書の取得、および Internet Explorer 6 カスタマイズ ウィザードでの証明書情報の指定という 2 つの手順を実行する必要があります。詳細については、「プログラムへの署名」を参照してください。
  • UNIX FTP サーバーの場合は、ファイル名の大文字/小文字の変更が必要になることがあります。特定の UNIX オペレーティング システムを使用する場合は、次のような決まりがあります。
    • Solaris UNIX

      大文字と小文字を区別する UNIX FTP サーバーを使用する場合は、.cab ファイルのフォルダを小文字で表記する必要がありますが、BRANDING.CAB、CUSTOM.CIF、DESKTOP.CAB、IE.CIF、IECIF.CAB、および IE6SITES.DAT の各ファイル名は、大文字で表記する必要があります。

    • AT&T UNIX

      AT&T UNIX FTP サーバーでは、すべてのファイル名を大文字で表記する必要があります。

    • IRIX UNIX (Silicon Graphics)

      大文字で表記する必要があるファイルには、BRANDING.CAB、CUSTOM.CIF、DESKTOP.CAB、IE.CIF、IECIF.CAB、および IE6SITES.DAT があります。IE.CIF に含まれる一覧のファイル名についても、テキスト エディタを使用して大文字に変更してください。

CD-ROM

Windows 95 および Windows 98 のユーザーにカスタム パッケージを配布する場合、ユーザーが CD-ROM を挿入すると、自動実行プログラムの画面が表示されます。このプログラムでは、カスタム ブラウザのインストールや詳細情報の表示をユーザーが選択できます。最新バージョンの Internet Explorer が既にインストールされていると、自動実行プログラムがそれを検出します。ブラウザは、Start.htm ファイルが読み込まれると、キオスク モードで表示されます。


カスタマイズ (インターネット サービス プロバイダ対象)

IEAK を使用すると、インターネット サービス プロバイダ (ISP) はユーザー向けにカスタム ブラウザやインターネット サービス サインアップ パッケージを作成することができます。

セットアップ プログラムのカスタマイズ

  • Windows Update セットアップ プログラムの外観をカスタマイズして、インストール モード (標準インストールや最小インストールなど) を構成できます。
  • 製品の最新バージョンにアクセスするために、ユーザーにインターネット サーバーを参照させます。
  • Internet Explorer と一緒に、その他のプログラム、カスタム スクリプト、または管理スクリプトを展開することができます。
  • Internet Explorer のインストール パッケージに格納する言語を指定できます。 Internet Explorer 6 カスタマイズ ウィザードは、作成する言語バージョンごとに実行しなければなりません。

ブラウザのカスタマイズ

  • ホーム ページ、検索ページ、およびサポート ページを指定できます。
  • [お気に入り] の一覧に、リンクやフォルダを読み込むことができます。
  • ブラウザおよび Outlook Express のタイトル バーやロゴを変更できます。 Outlook Express をパッケージの一部として配布する場合や、Outlook Express がユーザーのコンピュータに既にインストールされている場合は、Outlook Express のタイトル バーが更新されます。

注

  • カスタム ブラウザへのブランドの方法の図解については、「カスタマイズの仕組み」を参照してください。

サービスへのユーザーのサインアップ方法の制御

  • サーバーベースのサインアップ パッケージの実装 － ユーザーが貴社のサービスにまだサインアップしていない場合は、簡単に実装できる HTML ベースのサインアップ サーバーを使用することにより、正式なアカウントをユーザーに提供できます。
  • サーバーなしのサインアップ パッケージの実装 － ユーザーが貴社のサービスまたはほかのサービスに関してアカウントを既に持っている場合は、サーバーを使用しない簡単な処理を使用して、カスタム ブラウザでユーザーのサイトを更新することができます。この種類のパッケージを使用する場合は、インストール時にユーザーが最終的な設定をいくつか行う必要があります。

注

  • サインアップ処理の図解については、「ISP サインアップ処理」を参照してください。

Internet Explorer のロゴの使用

使用許諾契約書の条項に従い、パッケージ、販促用の物品、および Web サイトには、Internet Explorer のロゴを表示しなければなりません。Web サイト用のロゴ、パッケージ用のロゴ、および販促用物品のロゴは \<IEAK プログラム フォルダ>\Toolkit\Graphics\Samples フォルダに用意されています。

重要

  • 使用許諾契約によっては、一部の機能を使用できないことがあります。詳細については、使用許諾契約書を参照してください。


インターネット サービス プロバイダ : ウィザードを実行するための準備

バナー

ウィザードを実行するための準備

Internet Explorer 6 カスタマイズ ウィザードを実行する前に、必要な情報を収集し、カスタム ビットマップを作成する必要があります。

プラットフォームの条件の決定

  • パッケージの作成に使用するコンピュータおよびパッケージをインストールするコンピュータがハードウェアとシステムの必要条件を満たしていることを確認してください。
  • ブラウザ パッケージの暗号化レベルを指定します。Internet Explorer の暗号化については、「IEAK に関する Web サイト」を参照してください。

配布方法の決定

カスタム パッケージの配布方法 (フロッピー ディスク、CD-ROM、またはダウンロード) を決めます。Internet Explorer 6 カスタマイズ ウィザードでパッケージを作成した後で、選択したメディアにファイルを移動する必要があります。ダウンロード可能なパッケージを作成したら、そのパッケージをサーバー上の適切な場所に移動する必要があります。

ブラウザ パッケージをインターネット サーバーに発行するときは、サーバーへのパスとファイルのダウンロード元の URL を知っている必要があります。カスタム ブラウザに関連するすべてのファイルとフォルダを発行するには、[CIE] のようなフォルダを Web サーバー上に作成します。たとえば、サーバーへのパスは、C:\Inetpub\Wwwroot\Cie のように指定します。この Web サーバーの仮想ルートがコンピュータ名の場合、該当する URL は http://コンピュータ名/Cie/ のように指定します。

デジタル証明書の取得

インターネットまたは特別な構成を行っていないイントラネットを経由してファイルを配布する場合は、Internet Explorer 6 カスタマイズ ウィザードで作成したカスタム ファイルやカスタム コンポーネントなどの特定のファイルに署名を施すための準備が必要です。ブラウザのセキュリティ機能を使用すれば、署名が施されていないファイルをダウンロードする際、ユーザーに警告を表示したり、ダウンロード処理を禁止したりできます。デジタル署名は、プログラムの発行元を明らかにし、該当するコードが署名時点以降に変更されていないことを保証するものです。

証明機関から発行元証明書を既に取得している場合は、Internet Explorer 6 カスタマイズ ウィザードでファイルに署名を施すことができます。IEAK で使用する証明書を用意するには、証明書のインポート ウィザードを使用して現在のコンピュータに証明書をインポートします。拡張子 .spc の付いたファイルを受け取ったら、Windows エクスプローラまたはマイ コンピュータで .spc ファイルをダブルクリックして、証明書のインポート ウィザードを起動することができます。

Internet Explorer から証明書のインポート ウィザードを起動することもできます。それには、[ツール] メニューの [インターネット オプション] をクリックし、[コンテンツ] タブをクリックして、[証明書] をクリックしてください。[インポート] をクリックすると証明書のインポート ウィザードが起動するので、ウィザードの指示に従ってください。

ディレクトリ構造の作成

次のフォルダ構造を作成します。

フォルダ名 | 説明
\CIE | IEAK によって作成された、またはカスタム パッケージで参照されるすべてのファイルの親フォルダ
\CIE\Custom | Signup.isp、Signup.htm、Icwsign.htm、Install.ins、Cancel.ins などのサーバーベース サインアップ用カスタム ファイル (サインアップの方法によって異なる)
\CIE\Dist | ファイルの格納先ディレクトリ (このフォルダは、ハード ディスクまたはネットワーク ドライブ上にブラウザ パッケージを作成する場合にだけ必要)
\CIE\Bitmaps | カスタム ビットマップ ファイル (カスタム ブラウザに必要なグラフィック ファイル)

必要なサインアップ ファイルをこの構造にコピーするには

  1. IEAK がインストールされているサブフォルダ (サーバーなしのインターネット サインアップの場合は\<IEAK プログラム フォルダ>\Toolkit\Isp\Servless、サーバーベースのインターネット サインアップの場合は \<IEAK プログラム フォルダ>\Toolkit\Isp\Server) に格納されているファイルをすべて選択します。
  2. これらのファイルを、CIE\Custom にコピーします。

サインアップ方法の選択とサインアップ ファイルのカスタマイズ

カスタム パッケージで、新しいユーザーがサービスにサインアップし、インターネットに接続する方法を指定することができます。サーバーベースまたはサーバーなしのサインアップ処理を選択するか、サインアップ機能 (既存のユーザーへのソフトウェア更新の配布) をすべて無効にすることができます。IEAK ツールキットには、各サインアップ方法をサポートするために必要な HTML ページのサンプル ファイルが用意されています。

注

  • サインアップ処理の図解については、「ISP サインアップ処理」を参照してください。

適切なグラフィックスの作成

次のビットマップは、ブラウザでカスタマイズすることもできます。Internet Explorer 6 カスタマイズ ウィザードを実行する前に、ビットマップを \CIE\Bitmaps フォルダに格納してください。

独自に作成した背景とボタンのビットマップは、256 色 (8 ビット) 以上の表示能力を持つコンピュータでだけ表示されます。16 色 (4 ビット) の表示能力を持つコンピュータでは、低解像度用の標準の背景ビットマップとボタン セットが表示されます。

  • CD-ROM 自動実行画面の背景のビットマップ 1 個 (CD-ROM パッケージを作成する場合)。

    カスタム ブラウザを CD-ROM で配布する場合は、ユーザーが CD-ROM を挿入したときに自動実行画面の一部に表示されるビットマップを作成する必要があります。このビットマップの作成方法については、「自動実行画面のビットマップの作成」を参照してください。

  • CD-ROM ボタンのカスタム イメージ (CD-ROM パッケージを作成する場合)。
  • Windows Update セットアップ ウィザード用の 2 つのカスタム ビットマップ (外観をカスタマイズする場合)。ウィザードの最初の画面の左側に表示する 162 × 312 ピクセルのビットマップ、およびウィザードの 2 番目以降の画面の上側に表示する 496 × 56 ピクセルのビットマップ。
  • カスタム ツール バー用のビットマップ 1 個 (ボタンとメニューの背景として表示されます)。
  • 256 色の静止ビットマップ イメージ 2 個 (38 x 38 ピクセル 1 個、22 x 22 ピクセル 1 個)。これらを使用すれば、Internet Explorer ブラウザに自社のブランドをロゴとして表示できます。
  • 256 色の動画ビットマップ イメージ 2 個 (38 x 38 ピクセル 1 個、22 x 22 ピクセル 1 個)。これらを使用すれば、Internet Explorer ブラウザに自社のブランドを動画ロゴとして表示できます。

    IEAK には、ブラウザに合ったカスタム版の動画ビットマップを簡単に作成およびプレビューできるようなツールが 2 つ入っています。

ホーム ページ、検索ページ、およびサポート ページ用の URL の指定

ユーザー サイトでブラウザのインストール時に問題が起きたときに備えて、サポート ページを作成しておくと便利です。Internet Explorer 6 カスタマイズ ウィザードを実行中に、サポート ページの URL を指定するように指示するメッセージが表示されます。

注

  • カスタム ブラウザへのブランドの方法の図解については、「カスタマイズの仕組み」を参照してください。


ISP : インターネット サインアップ オプション

バナー

インターネット サインアップ オプション

インターネット サインアップ サーバー (ISS) は、ISP の顧客データベースに新規ユーザーを自動的に追加します。インターネット サインアップ サーバーでは、まず新規ユーザーから情報を収集し、その情報を ISP の顧客データベースに追加した後、構成パケットを新規ユーザーのデスクトップ コンピュータに返送します。構成パケットには、ISP のサービスへの以降の接続をユーザーのインターネット ブラウザで設定するために使用する情報が含まれています。

インターネット サインアップ サーバーでは、次の手順で新規ユーザーを ISP のデータベースに追加します。

  • クライアント コンピュータとサインアップ サーバーとの HTTP 接続を確立します。
  • ユーザーからサインアップ情報を収集します。
  • ユーザーによる ISP サービスの受け入れまたは拒否を処理します。

IEAK を使用する場合は、次の 3 つのオプションを使用してインターネット サインアップを行うことができます。

  • インターネット接続ウィザードによるインターネット サインアップ
  • 全画面表示のキオスク モードを使用するサインアップ サーバーのセットアップ
  • サーバーなしのサインアップ パッケージの実装

設定の変更はクライアント上よりもサーバー上で行う方が簡単なので、サインアップ サーバーを提供できない場合以外は、サーバーベースのサインアップを推奨します。サーバーベースの 2 つのオプションのうち、ICW を使った方法をお勧めします。ICW では標準のウィザード インターフェイスを使用しており、必要に応じてカスタマイズすることができるからです。ISP の方の場合は、ICW を、ユーザーがインターネット サービスにサインアップし、各自のコンピュータを構成するためのツールとして指定することができます。

重要

  • 単一のディスク ブランドをお使いの場合、一部のユーザーが Internet Explorer 4.01 SP1 (またはそれ以前) を使用している可能性があるときは、ICW のサインアップを使用しないでください。そのようなコンピュータに対しては、代わりにキオスク モードのサインアップを使用して別のパッケージを作成します。

IEAK ツールキットのサンプル コード

IEAK ツールキットには、インターネット サインアップ用のカスタマイズ可能なソリューションが含まれています。コードは、Active Server Pages (ASP) と Perl の両形式で用意されているので、異なるプラットフォームの Web サーバーに対応する ICW サインアップ処理を効率的に作成できます。サンプル コードを使用する場合は、サインアップ サーバーを登録用および課金用のシステムと統合化する必要がありますが、それ以外の作業は不要です。Windows の参照サーバー プログラムに参加している場合は、IEAK サインアップと参照サーバーの登録に、よく似たサインアップ サーバー コードが使われます。

注

  • IEAK のソリューションには、ユーザーのさまざまなニーズに合わせて複数のインターネット サインアップ (.isp) ファイルが用意されているので、カスタム パッケージにはダイナミック HTML データ バインド コンポーネントも含める必要があります。

似たような複数のカスタム ブラウザの作成

Internet Explorer のカスタム ブラウザを複数個作成したり、複数またはすべてのバージョンに渡って同じ設定を使用する場合は、手順を簡素化できます。詳細については、「似たようなブラウザを複数個作成する」を参照してください。


インターネット サービス プロバイダ : サーバーベースのサインアップ パッケージの実装

バナー

サーバーベースのサインアップ パッケージの実装

サーバーベースのサインアップ処理を使用すると、新規ユーザーおよび既存のユーザーの登録と設定を自動化することができます。この処理では、インターネット サインアップ サーバー (ISS) を使用して各ユーザーから情報を収集します。サインアップ サーバーは、データを顧客データベースに追加し、ユーザーのコンピュータに構成パケットを返送します。このパケットは、インターネット サービスへの以降の接続をブラウザで構成します。

ISP は、次のサーバーベースのサインアップ処理を行うことができます。

  • インターネット接続ウィザード (ICW) : Internet Explorer 6 カスタマイズ ウィザードを使用すると、ユーザーがインターネット サービスにサインアップしてコンピュータを構成するために使用するツールとして、ICW を指定することができます。インターネット接続ウィザードは、標準のウィザード インターフェイスを使用しており、企業と社員のニーズに合わせてカスタマイズすることができるため、この方法を使用することをお勧めします。また、ICW の自動構成機能を使用して、既にインターネット アカウントを取得しているユーザーの設定を構成することができます。
  • 全画面表示のキオスク モード : Internet Explorer 6 カスタマイズ ウィザードを使用すると、作成するサインアップ処理画面を全画面表示のキオスク モードで表示するかどうかを指定できます。

注

  • サインアップ処理の図解については、「ISP サインアップ処理」を参照してください。

サーバーベースのサインアップによるカスタム パッケージの作成

サーバーベースのサインアップ方法を含むカスタム ブラウザ パッケージを作成するには、Internet Explorer 6 カスタマイズ ウィザードの段階 4 で次のように指定します。

  • サインアップ方法として、[インターネット接続ウィザードを使用するサーバー ベースのサインアップ (推奨)] または [全画面表示のキオスク モードを使用するサーバー ベースのサインアップ] を選択します。
  • カスタム サインアップ ファイルがある作業用フォルダのパスを指定します。これらのファイルを使用すると、ユーザーはサインアップ サーバーに接続できるように自分のコンピュータを構成することができます。
  • ユーザーがサインアップ サーバーとの接続を確立するためのダイヤルアップ ネットワーク パラメータと、最初のオンライン サインアップ ページの URL を含む、サインアップ サーバー情報。
  • ICW のカスタマイズ情報。タイトル バーおよびカスタム画像を含む ([インターネット接続ウィザードを使用するサーバー ベースのサインアップ (推奨)] を選択した場合)。

パッケージが正しくインストールされるようにするには、カスタム サインアップ ファイルが格納されているのと同じフォルダに、次のファイルが含まれている必要があります。

  • Signup.htm － この HTML ページは、インターネット サービスに関する情報を提供します。このファイルには、サインアップ サーバー上の該当する HTML ページへのリンクを含める必要があります。IEAK をインストールしたディレクトリの \Reskit\ISP\Server\Client フォルダにある、サンプルの Signup.htm ファイルをカスタマイズすることもできます。たとえば、インターネット サインアップ (.isp) ファイルにテクニカル サポート情報を追加したり、リンクを挿入することができます。
  • Signup.htm － このインターネット サインアップ ファイルは、サインアップ サーバーへのダイヤルに使用され、Signup.htm で参照されます。また、このファイルには、インターネット設定 (.ins) ファイルを生成するサーバー スクリプトの URL へのリンクを含める必要があります。Internet Explorer 6 カスタマイズ ウィザードを使用して、このサインアップ ファイルに含まれているパラメータを編集することができます。Internet Explorer 6 カスタマイズ ウィザードでは、サインアップ処理に使用する他の .isp ファイルも生成できます。
  • その他のすべてのサインアップ ファイル － .gif や .jpg などのグラフィック ファイルを含む、すべての関連ファイル。カスタム サインアップ ファイルと同じフォルダ内に保存する必要があります。たとえば、カスタマイズした Install.gif ファイルを含めることができます。

サーバーベースのサインアップによるカスタム パッケージの配布

サーバーベースのサインアップ方法を使用する場合、カスタム ブラウザ パッケージのサインアップ処理では次の 3 つの操作を行います。

  1. ユーザーのコンピュータが、サインアップ サーバーとの接続を確立します。
  2. HTML/HTTP ベースのダイアログ ボックスを使ってユーザーから収集した情報が、顧客データベースに追加されます。
  3. サインアップ サーバーが、構成パケットをユーザーのコンピュータに返送します。このパケットには、構成とブランドに関する情報が入っています。また、ユーザーがインターネット サービス プロバイダにアクセスするための電話番号も入っています。

    4. なお、ユーザーのセキュリティ オプションが高に設定されている場合は、必要なファイルがダウンロードされないため、サインアップ サーバーは正しく動作しません。

サインアップ サーバーとの接続の確立

ユーザーは、Internet Explorer を起動するサインアップ プログラムを実行した後、サインアップ サーバーにダイヤルし、最初の接続要求を送信します。それに対して、サインアップ サーバーは次の処理を実行します。

  • ユーザーのコンピュータ (HTTP クライアント) から要求を受け取り、HTTP 接続を確立します。
  • ユーザーの入力情報を蓄積しておくためのローカル データ ストアを作成します。
  • 一意なセッション ハンドルを割り当てます。このハンドルは、以降ユーザーとやり取りするすべての HTTP トランザクションに埋め込まれます。

HTTP はセッションレスのプロトコルです。ただし、サインアップ サーバーはセッション指向のモードで動作し、セッション ハンドルを使用して特定のユーザーのサインアップ処理に関連するすべてのトランザクションを識別します。たとえば、データベースからこのトランザクションに自動的に割り当てられる連続する番号などが、セッション ハンドルになります。

ユーザーのサインアップ情報の収集

サインアップ サーバーは、一連の HTML ページで Windows ベースのプログラムのウィザードのようにユーザーに操作を実行させ、そこからユーザー情報を収集します。サインアップ サーバーは、ユーザーのコンピュータにオンデマンドでページをアップロードします。ユーザーが最後の HTML ページにある適切なボタンをクリックして、サインアップの使用許諾契約に同意するかどうかを選択すると、サインアップ処理は終了します。

各ページのコンテンツやフォーマットは自由です。HTML ページは一般に次の要素で構成されます。

  • ユーザーが情報を入力するためのフォーム。
  • ユーザーが次のページに進んだり、前のページに戻ったりするためのナビゲーション ボタン。
  • ユーザーがサインアップ セッションを中止するためのボタン。

各 HTML フォームには、入力された文字列を収集したり、ページ間を移動したり、セッションを識別したりするためのコントロールが含まれています。フォームはユーザーから情報を収集し、ユーザーがナビゲーション ボタンをクリックすると、その情報をサインアップ サーバーに渡します。また、サインアップ サーバーはデータを検証し、受け付けられないデータである場合は、ユーザーのコンピュータに編集用のページを送信します。

注

  • HTML ファイルは、サインアップ サーバーの適切なフォルダに保存してください。Signup.isp ファイルには Windows 32 ビット バージョンのサーバー ファイルへのリンクを、Signup.htm ファイルには Windows 16 ビット バージョンのサーバー ファイルへのリンクを含めます。

ユーザーのコンピュータへの構成パケットの返送

ユーザーがサインアップ使用許諾契約に同意すると、サインアップ サーバーは .ins ファイルと共に、構成パケットを作成します。.ins ファイルは、Internet Explorer 6 カスタマイズ ウィザードによって生成され、ユーザーとインターネット サービスに関する情報が含まれています。.ins ファイルには、接続の設定だけを含めることも、グラフィックスを含む接続、ブラウザ、およびメールの設定を含めることもできます。

サインアップ サーバーは、.ins ファイルを使用して、構成パケットをユーザーのコンピュータに返送します。.ins ファイルは、その場ですぐに生成されるか、単にクライアント コンピュータにリダイレクトされます。これにより、ユーザーのコンピュータでは、カスタム ブラウザ パッケージのインストールを続けて処理することができます。ユーザーがサインアップ使用許諾契約を拒否すると、サインアップ サーバーは、サインアップ処理を中止するためのファイルをユーザーのコンピュータにリダイレクトします。

構成パケットには、次の情報が含まれます。

  • インターネット接続の構成に必要な情報
  • 電子メールやニュースリーダーなど、ユーザー アカウントで利用できる機能に関する情報
  • サインアップ ページの外観を企業向けにカスタマイズするブランド情報
  • ユーザーがインターネット サービスにアクセスするために必要な電話番号

最初の 2 種類のデータは、サインアップ サーバーの一部として作成されます。ブランド用の .ins ファイルのデータは、Internet Explorer 6 カスタマイズ ウィザードによって作成されます。Entry、User、Phone、Device、Server、TCP/IP などの一部の値は、ウィザードで指定することができません。これらの設定は、.ins ファイルで手作業で行う必要があります。

ユーザー グループ別に独自の "プライベート ブランド" が設定された Internet Explorer を提供するには、サインアップ サーバーが .ins ファイルにダウンロードできるように、各種のブランド情報を格納しておきます。たとえば、ロゴ、タイトル バー、お気に入り、検索ページ、ホーム ページ、リンク、オンライン ヘルプの場所などを、バージョンごとにカスタマイズしておきます。この方法では、すべてのユーザーに同じ内容の CD-ROM を配布することができ、個々のブランドはサインアップ時に設定させることができるので、CD-ROM の管理が楽になります。

サインアップ サーバーとして Internet Information Services を使用するときの注意点

サインアップ サーバーとして Internet Information Services (IIS) を使用する場合は、クライアントがサーバーに接続するときに、DHCP の IP アドレスをクライアントに提供するように、インターネット サインアップ サーバーを構成する必要があります。サインアップ処理は比較的短いため、IP アドレスのリース期限はわずかで、通常は数秒です。

サインアップ処理はポイント ツー ポイントのダイヤルアップ接続で使用されるので、DHCP サーバーに割り当てられた IP アドレスに、実際に IP アドレスを割り当てる必要はありません。DHCP の IP アドレスを有効なインターネット アドレスにするか、任意のアドレスにするかは自由です。

.ins ファイルの MIME タイプの登録

クライアントで .ins ファイルを自動的に処理するには、サインアップ サーバーで .ins ファイルの MIME タイプを登録する必要があります。この MIME タイプは、"application/x-Internet-signup" と指定されます。クライアントが .ins ファイルを要求すると、サインアップ サーバーはこの MIME タイプで応答します。これにより、関連付けられているインストール アプリケーションがクライアント側で起動します。

MIME タイプはレジストリで手動で編集する必要があります。.ins ファイルに MIME タイプを追加するには、regedit.exe を使用して次の情報を追加します。

編集するキー :
HKEY_LOCAL_MACHINE\system32\CurrentControlSet\Services\InetInfo\Parameters\MimeMap

追加する値 :
application/x-internet-signup,ins,,5

この値には、文字列は関連付けられていません。MIME タイプの詳細については、IIS のオンライン ヘルプを参照してください。

注

  • これらのレジストリの設定を有効にするには、新しい MIME タイプを追加した後で、すべての IIS サービスをシャット ダウンする必要があります。Web 発行サービスを停止し、再開するだけでは不十分です(実際は、FTP および Gopher サービスは、サインアップ サーバーの構成を実行できそうにありません)。


ISP : 全画面表示のキオスク モードを使用するサインアップ サーバーのセットアップ

バナー

全画面表示のキオスク モードを使用するサインアップ サーバーのセットアップ

インターネット サインアップ サーバー (ISS) は、HTTP (ハイパーテキスト転送プロトコル) サーバーであり、インターネット サービス プロバイダ (ISP) の顧客データベースに新規ユーザーを自動的に追加します。ISS では、まず新規ユーザーから情報を収集し、その情報を ISP の顧客データベースに追加した後、データを新規ユーザーのコンピュータに返送します。この情報のパケットは、ISP のサービスを使用できるように、ユーザーのインターネット ブラウザを構成します。

注

  • サインアップ処理の図解については、「ISP サインアップ処理」を参照してください。

新規ユーザーを ISP データベースに追加するには

ISS では、次の手順で新規ユーザーを ISP のデータベースに追加します。

  1. ユーザー コンピュータとの HTTP 接続を確立します。
  2. ユーザーからサインアップ情報を収集します。
  3. ユーザーによる ISP サービスの受け入れまたは拒否を処理します。

これらの作業を処理するために、インターネット接続ウィザードを使用して、インターネット サインアップ用のサンプル コードを適用することができます。このコードは\<IEAK プログラム フォルダ>\Toolkit\ISP\Server\ICW フォルダとそのサブフォルダにある IEAK ツールキットに用意されています。

下に示すトピックでは、インターネット接続ウィザードのサインアップ処理の開発方法を説明します。これらのトピックでは、ほとんどの場合に適用できる、テスト済みで包括的なサインアップ ソリューションを示していますが、実際の用途に応じてカスタマイズしてもかまいません。

  • インターネット接続ウィザードによるインターネット サインアップ
  • インターネット接続ウィザードの画面のコーディングに関する必要条件
  • インターネット接続ウィザードのサンプル サインアップ ファイルの使用
  • ICW サインアップ用の Icwsign.htm、エラー ページ、および完了ページの作成
  • インターネット接続ウィザードのサインアップ用の支払いオプション ページの作成


インターネット接続ウィザードによるインターネット サインアップ

インターネット サービス プロバイダの場合は、ユーザーがサインアップして、インターネット サービスを使用できるように自分のコンピュータを構成するためのツールとして、インターネット接続ウィザード (ICW) を指定できます。ICW の画面との間で情報を交換するには、サーバーベースのソリューションを作成します。この機能は、サーバーなしのサインアップ方法の場合には利用できません。

<IEAK プログラム フォルダ>\Toolkit\ISP\Server\ICW フォルダとそのサブフォルダにある IEAK ツールキットには、インターネット サインアップ用のカスタマイズ可能なソリューションが含まれています。コードは、アクティブ サーバー ページ (ASP) と Perl の両形式で用意されているので、異なるプラットフォームの Web サーバーに対応する ICW サインアップ サーバーを効率的に作成できます。サンプル コードを使用する場合は、サインアップ サーバーを登録用および課金用のシステムと統合化する必要がありますが、それ以外の作業は不要です。

注

  • Windows の参照サーバー プログラムに参加している場合は、IEAK サインアップと参照サーバーの登録に、よく似たサインアップ サーバー コードが使われます。
  • サインアップ処理の図解については、「ISP サインアップ処理」を参照してください。

次のトピックでは、インターネット接続ウィザードのサインアップ処理の開発方法を説明します。これらのトピックでは、ほとんどの場合に適用できる、テスト済みで包括的なサインアップ ソリューションを示していますが、実際の用途に応じてカスタマイズしてもかまいません。

  • インターネット接続ウィザードの画面のコーディングに関する必要条件
  • インターネット接続ウィザードのサンプル サインアップ ファイルの使用
  • ICW サインアップ用の Icwsign.htm、エラー ページ、および完了ページの作成
  • インターネット接続ウィザードのサインアップ用の支払いオプション ページの作成
  • インターネット接続ウィザードの自動構成を使用した ISP サインアップ

重要

  • 単一のディスク ブランドをお使いの場合、一部のユーザーが Internet Explorer 4.01 SP1 (またはそれ以前) を使用している可能性があるときは、インターネット接続ウィザード モードのサインアップを使用しないでください。 そのようなコンピュータに対しては、代わりにキオスク モードのサインアップを使用して別のパッケージを作成します。


インターネット接続ウィザードのサンプル サインアップ ファイルの使用

独自のファイルを作成する前にサインアップ処理をシミュレートしたい場合は、\<IEAK プログラム フォルダ>\Toolkit\ISP\Server\ICW フォルダにある IEAK ツールキットに用意されているサンプル ファイルを使用できます。 このサンプル ファイルは、サインアップ処理の概要を理解し、指定する必要のある情報の種類を把握するのに役立ちます。

サンプル ファイルを使用してサインアップ処理をシミュレートするには

  1. サーバー上の wwwroot ディレクトリの下層に Signup という名前のディレクトリを作成します。
  2. サンプル ファイルを IEAK ツールキットから Signup ディレクトリにコピーします。
  3. ファイル内でサインアップ サーバーを参照している箇所をすべて実際の URL に修正します。
  4. サインアップ サーバー ページの HTML コード内に記述されているプロバイダ名を Acme ISP から実際のプロバイダ名に変更します。
  5. 実際の .ins ファイルの設定が反映されるように、最後のサインアップ サーバー ページを修正します。


インターネット接続ウィザード サインアップのコーディングとユーザー補助に関する必要条件

バナー

インターネット接続ウィザードの画面のコーディングに関する必要条件

IEAK に含まれているインターネット接続ウィザード (ICW) のサインアップ機構のインターネット サインアップ サーバーの外観および操作性は、Windows の標準的なウィザードを基にしています。ICW では、Hypertext Markup Language (HTML) の機能と柔軟性を利用していますが、HTML とは異なる書式設定方法を採用しています。

ICW の HTML ページでは Windows のシステム カラーを使用すること、およびユーザー補助の必要条件を満たすことが必要です。ウィザードの HTML ページには、特に明記されている場合を除いて、罫線付きのテーブル、画像、アンカーなどの特殊な HTML 書式要素を配置することはできません。使用できるのは、書式なしのテキストと必要なフォーム要素だけです。罫線のないテーブルであれば、レイアウト用に使用できます。

ユーザーのシステム カラーと一致させるには、Icwsign.htm ページ以外の HTML ページには、特に明記されている場合を除いて色やフォントの属性を設定しないでください。フォントのスタイルと色は、インターネット接続ウィザードによってユーザーのシステムに一致する属性に設定されます。

HTML ページ内でのフォームの実装に関する必要条件は、仕様で定義されている <FORM> 要素に NAME パラメータを使用するという 1 点のみです。HTML ページ内のその他の要素については、どのトークン名でも指定できます。これらの要素は、サインアップ サーバーに送信されます。

[戻る] ボタンと [次へ] ボタンの機能

ICW モードによるサインアップでは、インターネット接続ウィザードの [戻る] ボタンおよび [次へ] ボタンが正しく動作するように、次に示す条件を満たす必要があります。

なお、IEAK に用意されているサインアップ サーバーのサンプル コードでは、既に上の条件が満たされています。

[戻る] ボタン

[戻る] ボタンを正しく動作させるには、[戻る] ボタンの URL を指定する FORM 要素をサインアップ サーバー ページに追加する必要があります。サインアップ処理で取得したデータを維持するには、[戻る] ボタンに使用する URL の末尾に、維持する必要のあるデータを追加します。

サインアップ処理中にユーザーが前のページに戻ることができるように、[戻る] ボタンに次のような FORM 要素を追加する必要があります。指定したデータは、名前と値の対として URL の末尾に追加されます。

<FORM NAME="BACK"
ACTION="http://myserver/page2.asp"?firstname=bob&lastname=smith&address=...">
</FORM>

注

  • インターネット接続ウィザードでは大文字と小文字が区別されるため、NAME 要素とその値は、すべて大文字で記述する必要があります。

[次へ] ボタン

[次へ] ボタンを正しく動作させるには、[次へ] ボタンの URL を指定する FORM 要素をサインアップ サーバー ページに追加する必要があります。さらに、サインアップ処理で既に収集したデータを次のページに渡すことができるように、各サインアップ サーバー ページには、現在のページとそれ以前のすべてのページで収集したデータ要素を格納するための非表示のフォーム フィールドを追加する必要があります。参照先の URL には、サインアップ処理中に前のページからデータを収集して、次のページを表示するコードを格納しておく必要があります。

サインアップ処理中にユーザーが次のページに進むことができるように、[次へ] ボタンに次のような FORM 要素を追加する必要があります。

<FORM NAME="NEXT"
ACTION="http://myserver/page2.asp">
</FORM>

ユーザー補助に関する必要条件

キーボードだけを使用してもフォーム上の要素を操作できるように、各フォーム要素は次のような条件を満たしている必要があります。

  • フォーム要素にアクセス キー (ホットキー) が関連付けられていること。INPUT タグに Internet Explorer の <ACCESSKEY=> パラメータを指定します。アクセス キーとして使う文字には、<U> タグで下線を引きます。ただし、b、f、g、n、o の各文字は ICW 用に予約されているので、アクセス キーには指定できません。ACCESSKEY パラメータの詳細については、「MSDN Online Web Workshop」を参照してください。
  • ページ上に配置する各要素を ICW の Tab キー順序に含めること。ICW の Tab キー順序に含めるには、要素の <INPUT> タグに一意の ID を指定する必要があります。
  • 各要素にラベルが関連付けられていること。異なる HTML フォーム入力タイプに対してラベルを関連付けるには、Internet Explorer の LABEL= パラメータを使用します。

例

ICW のユーザー補助の必要条件を満たすオプション ボタン フォーム要素を次に示します。

<INPUT ID="option2"
TYPE="radio"
NAME="billing"
VALUE="hour"
ACCESSKEY="h"
CHECKED
>
<LABEL for="option2">
5 <U>H</U>ours per month for $10.
</LABEL>

HTML と設計の必要条件

インターネット接続ウィザードの各ページに次の設計要素を使用し、次の設計上の規則に従う必要があります。

重要

  • 文字列および HTML フォーム要素のみ使用できます。画像、ハイパーリンク、スクロール バーは使用できません。

スタイル シート

フォント スタイルや色などの属性は指定しないでください。これらの属性はインターネット接続ウィザードによって設定されます。エラー ページで <TABLE> タグを使用する場合は、次のスタイルでタグを使用する必要があります。

<TABLE style="font:8pt 'ms sans serif' buttontext"> </TABLE>

必要なフォーム要素

このページには、異なるページ プロパティを指定する 4つの HTML <FORM> 要素が必要です。

要素 | 必要条件
ページの一意の PAGEID | フォームの NAME は "PAGEID" です (大文字/小文字を区別)。フォームの ACTION 属性には、ウィザードの ISP セクションの他のページの PAGEID と一致しない、一意の ID を指定します (例 : <FORM NAME="PAGEID" ACTION="page4"></FORM>)。
[戻る] ボタンの機能 | フォームの NAME は "BACK" です (大文字/小文字を区別)。このフォームの ACTION 属性には、前のページの絶対 URL を指定します (例 : ACTION="HTTP://signup/bin/page1.cgi")。
ページの特性 | フォームは NAME "PAGETYPE" で識別されます (大文字/小文字を区別)。これは ISP がスペース全体を定義する標準のフレームなので、フォームの ACTION 属性には空の文字列を指定します (例 : ACTION="")。
[次へ] ボタンの機能 | フォームの NAME は "NEXT" です (大文字/小文字を区別)。これは、ISP のサインアップ サーバーに返信される実際のフォーム要素を含むフォームです。フォーム内の <INPUT> 要素には、トークン名の制限はありません。フォームの ACTION 属性には、フォーム情報の送信先の絶対 URL を指定します。サーバー上の送信先の URL には、データを受信し、ウィザードの次の HTML ページを表示するためのスクリプトを含める必要があります。


インターネット接続ウィザードの自動構成を使用した ISP サインアップ

ICW 自動構成を使用すると、ユーザーが新しいコンピュータを購入した場合に、前のコンピュータで使用していたインターネット サービス アカウントや仕事で使用しているインターネット サービス アカウントを新しいコンピュータで構成するときに役立ちます。また、インターネットの設定が破損してしまった場合にも役立ちます。ユーザー ID、パスワード、および POP サーバーさえわかっていれば、自動構成機能によってユーザーの設定を復元できます。

Internet Explorer のカスタム パッケージでは、ユーザーは Internet Explorer CD-ROM から Icwsign.htm ページ上のリンクをクリックして自動構成サーバーにアクセスします。このリンクによって、ユーザーのコンピュータが自動構成登録サーバーに接続されます。サインアップ サーバーに接続したユーザーに対して、ユーザー名、パスワード、および POP サーバーを指定するように求めるプロンプトを表示できます。これらの情報に従って、ユーザーのコンピュータに .ins ファイルを送信し、ユーザーのアカウントを再構成することができます。

ICW 自動構成をサポートするための 2 つの方法

自動構成でユーザーのアカウントを復元するには、次の 2 つの方法があります。

  • ユーザー名、パスワード、および POP サーバーを指定するように求めます。通常はこれらの情報があれば、.ins ファイルを再生成し、再生成した .ins ファイルをユーザーのコンピュータに送信し、アカウントを再構成できます。ユーザーのクレジット カード番号を再収集して、登録データベースと照合すれば、この機能が悪用されるのを防ぐことができます。
  • .ins ファイルをユーザーのその他のアカウント情報と共に保存します。自動構成サーバーに接続したユーザーは、ユーザー名とパスワードを指定するだけで .ins ファイルを取得できます。自動構成サーバーでは、ユーザーのアカウントを検索し、そのユーザーのオリジナルの .ins ファイルをコピーして送信します。前の方法と同様に、ユーザーのクレジット カード番号を再収集して、登録データベースと照合すれば、この機能が悪用されるのを防ぐことができます。

ICW 自動構成をセットアップするには

  • 「インターネット接続ウィザードの画面のコーディングに関する必要条件」の指示に従い、ISP のアカウント ログインおよび電子メール ページ、POP 選択ページ、および完了ページを作成してください。


インターネット サービス プロバイダ : サーバーなしのサインアップ パッケージの実装

バナー

サーバーなしのサインアップ パッケージの実装

サーバーなしのサインアップ処理により、ユーザーは、CD-ROM、フロッピー ディスク、またはダウンロードしたファイルから、Internet Explorer のカスタム ブラウザをインストールできます。このインストール処理では、ユーザーはユーザー名、パスワード、および接続情報を入力するだけで、アカウントをセットアップし、カスタム ブラウザでインターネットに接続することができます。ISP は、サインアップ サーバーを使用せずにユーザーの設定をカスタマイズできます。構成情報は、IEAK パッケージと共に配布され、ユーザーのコンピュータにローカルな構成として適用されるため、この処理は、サーバーベースのサインアップほど動的ではありません。

サーバーなしのサインアップ処理を使って、インターネット接続ウィザードをカスタマイズすることはできません。

サーバーなしのサインアップ処理を使ったカスタム パッケージの作成

サーバーなしのサインアップ処理を含むカスタム ブラウザ パッケージを作成するには、Internet Explorer 6 カスタマイズ ウィザードの段階 4 で次のように指定します。

  • サインアップ方法として [サーバーなしのサインアップ] を指定します。
  • カスタム サインアップ ファイルがあるフォルダへのパスを指定します。これらのファイルを使用すると、ユーザーはインターネット サービスを使用できるように自分のコンピュータを構成することができます。
  • ユーザーがインターネット サービスに接続するためのダイヤルアップ ネットワーク パラメータを指定します。

パッケージが正しくインストールされるようにするには、カスタム サインアップ ファイルが格納されているのと同じフォルダに、次のファイルが含まれている必要があります。

  • Signup.htm － この HTML ページは、インターネット サービスに関する情報を提供します。このファイルには、カスタム ブラウザ パッケージの構成の設定が含まれている .ins ファイルへのリンクを含める必要があります。
  • その他のすべてのサインアップ ファイル － .gif や .jpg などのグラフィック ファイルを含む、すべての関連ファイル。カスタム サインアップ ファイルと同じフォルダ内に保存する必要があります。たとえば、カスタマイズした Install.gif および Logohere.gif ファイルを含めることができます。

サーバーなしのサインアップ処理によるカスタム パッケージの配布

カスタム パッケージには、カスタム ブラウザ向けに指定した設定を含む、Install.ins という名前の構成ファイルが含まれます。インターネット サインアップ サーバーの方法とは違い、この .ins ファイルには、ユーザー固有の構成情報は含まれません。ユーザーがサインアップ プログラムを起動すると、ローカルの HTML ページ内のリンクから .ins ファイルが開きます。ユーザーは、ユーザー名、パスワード、および接続情報を指定します。こうすると、.ins ファイルはユーザーのアカウントを構成し、カスタム ブラウザを使用してインターネットに接続します。

サーバーなしのサインアップ処理の欠点

構成ファイルは IEAK パッケージと共に配布されるため、サインアップ サーバー上のユーザーの設定を動的に変更することはできません。

サインアップ サーバーを使う方法では通常、サインアップ サーバーがユーザーに関する情報を収集してカスタム構成ファイルを作成し、ユーザーのデスクトップ コンピュータにダウンロードします。Internet Explorer インストール パッケージに入っているソフトウェアは、この構成ファイルを使ってデスクトップ コンピュータを構成します。

サーバーなしのサインアップ処理では、構成ファイルはあらかじめ作成され、インストール パッケージに組み込まれて出荷されます。そのため、構成ファイルには、ユーザー固有の構成情報が入っていません。ローカルの HTML ページのリンクから Install.ins という構成ファイルを呼び出し、Internet Explorerのほとんどすべての項目をここで構成します。この構成ファイルはインストール パッケージに含まれているため、各ユーザーのコンピュータのローカルな設定となります。

この欠点を補うために、サーバーなしのサインアップ処理の詳細オプションは、ユーザー情報を格納する .ins ファイルを、ActiveX コントロール (installx.exe) を使用してすばやく生成します。Internet Explorer は ActiveX コントロールによって生成されたファイルを使用して、ユーザーの設定を構成します。


インターネット サービス プロバイダ : 段階 1 : 情報の収集

バナー

段階 1 : 情報の収集

インターネット サービス プロバイダ (ISP) の場合、Internet Explorer 6 カスタマイズ ウィザードの段階 1 では、次の情報を指定します。

  • ファイルの場所 － カスタム ブラウザ パッケージの作成先フォルダを指定します。
  • 対象言語 － 作成対象のブラウザ パッケージの言語を指定します。Internet Explorer 6 カスタマイズ ウィザードは、作成対象の言語ごとに起動する必要があります。
  • 配布メディア － CD-ROM やダウンロードなど、配布に使用するメディアを指定します。
  • 機能 － カスタマイズする機能を指定します。たとえば、ブラウザの機能のごく一部だけをカスタマイズする場合には、それらの機能に関する IEAK ウィザード画面だけを表示できます。

注

  • Internet Explorer 6 カスタマイズ ウィザードは、Internet Explorer 6 がインストールされていないと、正しく動作しません。詳細については、「ハードウェアとシステムの必要条件」を参照してください。


インターネット サービス プロバイダ : 段階 2 : セットアップ パラメータのカスタマイズ

バナー

段階 2 : セットアップ パラメータのカスタマイズ

インターネット サービス プロバイダの場合、Internet Explorer 6 カスタマイズ ウィザードのこの段階では、次の情報を指定します。

  • 自動バージョン同期 (AVS) による Microsoft コンポーネントのダウンロードまたは更新 － Internet Explorer のダウンロードは必須ですが、Internet Explorer に関連するその他のコンポーネントはダウンロードするかどうかを選択することができます。
  • カスタム コンポーネントの選択 － 必要なコンポーネントを選択します。

    また、追加するコンポーネントは、16 個まで指定できます。それらのコンポーネントは、自己展開型の実行可能ファイル (.exe) であっても、圧縮されたキャビネット (.cab) ファイルであってもかまいません。


インターネット サービス プロバイダ : 段階 3 : セットアップのカスタマイズ

バナー

段階 3 : セットアップのカスタマイズ

インターネット サービス プロバイダの場合、Internet Explorer 6 カスタマイズ ウィザードのこの段階では、Windows Update セットアップの外観と動作を次のようにカスタマイズできます。

  • CD-ROM パッケージを作成する場合は、CD-ROM 自動実行画面をカスタマイズできます。
  • CD-ROM パッケージを作成する場合は、CD-ROM に関する詳細なオプションをカスタマイズできます。
  • Internet Explorer およびその他のインターネット ツール用の Windows Update セットアップ ウィザードをカスタマイズできます。これらの設定は、ユーザー側に表示するセットアップの外観に影響します。
  • 独自のインストール オプションを 10 個まで指定できます。また、各オプションを選択したときにインストールすべきコンポーネントも指定できます。
  • パッケージのダウンロード サイトを 10 件まで指定できます。
  • コンポーネントの更新をユーザーに通知する方法を指定できます。
  • セットアップで既存のコンポーネントを検出するかどうか、また、どのコンポーネントがユーザーによるカスタマイズが可能かを詳細に指定できます。
  • ダウンロードしたコンポーネントのうちパッケージに追加していないコンポーネントを、Internet Explorer のオンデマンドのインストール機能でユーザーのコンピュータにインストールするかどうかを指定できます。
  • 接続マネージャ管理キット (CMAK) を使用してカスタム プロファイルをインポートできます。
  • デジタル証明書を既に取得している場合は、IEAK パッケージの作成中にプログラムに署名できるように、証明機関情報を指定できます。

注

  • カスタム ブラウザへのブランドの方法の図解については、「カスタマイズの仕組み」を参照してください。
  • Internet Explorer 6 カスタマイズ ウィザードでカスタム パッケージを作成するときの流れについては、「IEAK でのカスタム パッケージの生成」を参照してください。


インターネット サービス プロバイダ : 段階 4 : ブラウザのカスタマイズ

バナー

段階 4 : ブラウザのカスタマイズ

インターネット サービス プロバイダの場合、Internet Explorer 6 カスタマイズ ウィザードのこの段階では、次の項目をカスタマイズできます。

  • ブラウザのタイトル バー － Internet Explorer および Outlook Express をパッケージに入れて配布した場合や、ユーザーのコンピュータに既に Internet Explorer および Outlook Express がインストールされている場合、カスタム ブラウザのタイトルは、Internet Explorer と Outlook Express の両方に表示されます。
  • ブラウザのツール バーの背景およびボタン － ツール バーには、スクリプトやプログラムを実行するカスタム ボタンを追加できます。
  • ブラウザの右上に表示される Internet Explorer のロゴ
  • ブラウザのホーム ページ、検索ページ、およびオンライン サポート ページ
  • [お気に入り]、[お気に入り] フォルダ、およびリンク バーのリンク
  • ウェルカム ページ － ユーザーがブラウザを最初に起動したときに表示されます。
  • ユーザー エージェント文字列 － ユーザー エージェントを使用すれば、カスタム ブラウザの使用状況を監視することができます。
  • ユーザーの接続の設定 － 設定をカスタマイズしたり、現在のコンピュータの設定をインポートしたり、またユーザーの既存の設定を削除することができます。
  • プロキシの設定
  • ルート証明書
  • ユーザーのサインアップ方法
  • サインアップ ファイル － サインアップ ファイルが格納されているフォルダのパスを指定して、これらのファイルに変更を加えるかどうかを指定できます。
  • ダイヤルアップ ネットワーク接続およびインターネット設定ファイルのパラメータ － ユーザーは、このパラメータを使用して、インターネット サインアップ サーバーに接続することになります。
  • インターネット接続ウィザードの設定 － サービスへの設定にインターネット接続ウィザードを使用する場合。

注

  • カスタム ブラウザへのブランドの方法の図解については、「カスタマイズの仕組み」を参照してください。


インターネット サービス プロバイダ : 段階 5 : コンポーネントのカスタマイズ

バナー

段階 5 : コンポーネントのカスタマイズ

インターネット サービス プロバイダの場合、Internet Explorer 6 カスタマイズ ウィザードのこの段階では、次の項目をカスタマイズできます。

  • 既定のプログラムの設定 － 電子メールや HTML の編集に使用される特定のプログラムなど。
  • ユーザーのニュース サーバーとメール サーバー － カスタム パッケージに Outlook Express を含める場合。
  • ユーザーの IMAP 電子メール サーバーの設定 － IMAP サーバーを使用して、Outlook Express を展開する場合。
  • Outlook Express のカスタム コンテンツ － 電子メールでユーザーに送信するウェルカム メッセージを追加したり、該当するプログラムをユーザーが起動したときに表示される情報パネルをカスタマイズしたりすることができます。
  • Outlook Express のカスタム設定 － メールおよびニュースの既定のクライアントを設定したり、ユーザーが追加の電子メール アカウントを取得するときに必要となる情報を用意したり、ユーザーに既定で適用するメッセージ規則ファイルを作成したりすることができます。
  • Outlook Express のユーザー インターフェイスの設定 － フォルダ バー、フォルダ一覧、ステータス バー、または Outlook バーを表示するかどうかを指定できます。
  • Outlook Express のメッセージ作成時の設定 － インターネットのニュースグループや電子メールのメッセージで使用する企業文書や署名を提供する場合。
  • Windows アドレス帳のディレクトリ サービス － ユーザーにインターネット ディレクトリ サービスを提供し、LDAP (Lightweight Directory Access Protocol) サーバーをカスタマイズする場合。
  • システム ポリシーおよび設定 － インターネット オプションをあらかじめ設定できます。


インターネット サービス プロバイダ : ブラウザ パッケージの配布方法

バナー

インターネット サービス プロバイダ

ブラウザ パッケージの配布方法

既定では、Internet Explorer 6 カスタマイズ ウィザードは、ユーザーがインターネットを経由してダウンロードすることのできるファイルを作成します。カスタム ブラウザ パッケージは、CD-ROM に格納して配布することもできます。配布メディアの一覧については、「メディアの選択」を参照してください。

ダウンロード可能なファイル

インターネット サービス プロバイダ (ISP) は、インストール エンジンが格納された単一のファイルをユーザーに配布して、インターネット サーバーからアプリケーションのコンポーネントをダウンロードさせることができます。

インターネット サーバー上にブラウザ パッケージを作成した場合は、ユーザーがファイルをダウンロードできるように Web サイトをセットアップする必要があります。たとえば、ダウンロード情報やインストール エンジン IE6setup.exe へのリンクを記載したページを作成します。

ハード ディスクやネットワーク ドライブにブラウザ パッケージを作成した場合は、次の項目をインターネット サーバーに移動する必要があります。

  • 配布するブラウザの言語バージョンに対応するフォルダおよびそのフォルダの内容。たとえば、英語版のフォルダ名が En である場合は、[En] フォルダをそれに格納されているファイルと共に移動する必要があります。このフォルダは、メディアの種類 (ダウンロードなど) およびプラットフォーム (Win32 など) に対応するフォルダの中に作成されます。Internet Explorer 管理者キット 6 が使用できるプラットフォームは、"Win32" のみです。UNIX および 16 ビット Windows クライアントの場合は、Internet Explorer 管理者キット 5.x を使用します。
  • Ie6sites.dat という名前のファイル。このファイルは、Internet Explorer 6 カスタマイズ ウィザードを実行したときに指定したダウンロード サイト (1 つまたは複数個) を示します。

    図解については、「配布用ファイルのセットアップ方法」を参照してください。

    Internet Explorer 6 カスタマイズ ウィザードでのファイルの作成の流れについては、「IEAK でのカスタム パッケージの生成」を参照してください。

カスタム パッケージへの署名

Web ブラウザには、有害なプログラムをダウンロードできないようにユーザーを保護するセキュリティ機能があります。セキュリティ レベルおよびプラットフォームによっては、デジタル署名が施されていないプログラムをユーザーがダウンロードしようとすると、ダウンロードできないことを示すメッセージ、または警告メッセージが表示されることがあります。

Internet Explorer 6 カスタマイズ ウィザードで作成されたカスタム .cab ファイルには、ローカル イントラネット ゾーンのセキュリティ レベルを低に設定している場合を除いて、デジタル署名を施してください。これらのプラットフォーム用のブラウザ パッケージと共にカスタム コンポーネントを配布する場合は、それらのコンポーネントにもデジタル署名を施してください。デジタル証明書を既に取得している場合は、Internet Explorer 6 カスタマイズ ウィザードでこれらのファイルに自動的に署名することができます。

注

  • キャビネット ファイルおよびカスタム プログラムに署名を施すには、デジタル証明書の取得、および Internet Explorer 6 カスタマイズ ウィザードでの証明情報の指定という 2 つの手順を実行する必要があります。詳細については、「プログラムへの署名」を参照してください。
  • UNIX FTP サーバーの場合は、ファイル名の大文字/小文字の変更が必要になることがあります。特定の UNIX オペレーティング システムを使用する場合は、次のような決まりがあります。
    • Solaris UNIX 大文字と小文字を区別する UNIX FTP サーバーを使用する場合は、.cab ファイルのフォルダを小文字で表記する必要がありますが、BRANDING.CAB、CUSTOM.CIF、DESKTOP.CAB、IE.CIF、IECIF.CAB、および IE6SITES.DAT の各ファイル名は、大文字で表記する必要があります。
    • AT&T UNIX AT&T UNIX FTP サーバーでは、すべてのファイル名を大文字で表記する必要があります。
    • IRIX UNIX (Silicon Graphics) 一部のファイルは大文字で表記する必要があります。BRANDING.CAB、CUSTOM.CIF、DESKTOP.CAB、IE.CIF、IECIF.CAB、および IE6SITES.DAT の各ファイル名は、大文字で表記する必要があります。IE.CIF に含まれる一覧のファイル名についても、テキスト エディタを使用して大文字に変更してください。

CD-ROM

Windows 95 のユーザーにカスタム ブラウザを配布する場合、ユーザーが CD-ROM を挿入すると、自動実行プログラムの画面が表示されます。このプログラムでは、カスタム ブラウザのインストールや詳細情報の表示をユーザーが選択できます。最新バージョンの Internet Explorer が既にインストールされていると、自動実行プログラムがそれを検出します。ブラウザは、Start.htm ファイルが読み込まれると、キオスク モードで表示されます。

注

  • ダウンロード処理の図解については、「Windows Update セットアップ ウィザードによる Internet Explorer およびその他のインターネット ツールのセットアップ」を参照してください。

    • 関連項目


カスタマイズ (企業内管理者対象)

IEAK を使用すると、自社のニーズに合わせてカスタマイズした Microsoft Internet Explorer のハンド フリー インストールを作成することができます。

セットアップ プログラムのカスタマイズ

  • Windows Update セットアップ プログラムの外観をカスタマイズして、インストール モード (標準インストールや最小インストールなど) を構成できます。
  • 製品の最新バージョンにアクセスするためのインターネット サーバーまたはイントラネット サーバーをユーザーに示すことができます。
  • ユーザーが Internet Explorer をインストールするときに、内部プログラム、カスタム スクリプト、または管理スクリプトを展開することができます。
  • Internet Explorer のインストール パッケージに格納する言語を指定できます。Internet Explorer 6 カスタマイズ ウィザードは、作成する言語ごとに実行しなければなりません。

ブラウザと Windows デスクトップのアップデートのカスタマイズ

  • 使用するホーム ページ、検索ページ、およびサポート ページを指定できます。
  • [お気に入り] の一覧に、リンクやフォルダをロードできます。
  • ブラウザおよび Outlook Express のタイトル バーやロゴを変更できます。 Outlook Express をパッケージの一部として配布する場合や、Outlook Express がユーザーのコンピュータに既にインストールされている場合は、Outlook Express のタイトル バーが更新されます。
  • 自社の既定のデスクトップを作成し、ユーザーに変更を許可する設定を指定できます。

カスタム ブラウザへのブランドの方法の図解については、「カスタマイズの仕組み」を参照してください。

セキュリティと規制の管理

  • ユーザーのコンピュータに証明書をインストールして、別の証明書のダウンロードをユーザーに禁止することができます。
  • ユーザーの規制構成を設定して、会社のポリシーを遵守させることができます。
  • 組織内のユーザーがニュースグループに投稿するときの標準の企業文書を設定できます。
  • セキュリティ ゾーンを使用すれば、セキュリティのレベルや信頼できるゾーンを設定できます。
  • プロキシのアドレスやポートを設定できます。

重要

  • 使用許諾契約によっては、一部の機能を使用できないことがあります。詳細については、使用許諾契約書を参照してください。


企業内管理者 － ウィザードを実行するための準備

バナー

ウィザードを実行するための準備

Internet Explorer 6 カスタマイズ ウィザードを実行する前に、必要な情報を収集し、カスタム ビットマップを作成する必要があります。

プラットフォームの条件の決定

  • パッケージの作成に使用するコンピュータおよびパッケージをインストールするコンピュータがハードウェアとシステムの必要条件を満たしていることを確認してください。
  • ブラウザ パッケージの暗号化レベルを指定します。Internet Explorer の暗号化については、「IEAK に関する Web サイト」を参照してください。

配布方法の決定

カスタム パッケージの配布方法 (フロッピー ディスク、CD-ROM、またはダウンロード) を決めます。Internet Explorer 6 カスタマイズ ウィザードでパッケージを作成した後で、選択したメディアにファイルを移動する必要があります。ダウンロード可能なパッケージを作成したら、そのパッケージをサーバー上の適切な場所に移動する必要があります。

カスタム パッケージをインターネット サーバーに発行するときは、サーバーへのパスとファイルのダウンロード元の URL を知っている必要があります。そして、カスタム ブラウザに関連するすべてのファイルとフォルダを発行するには、[CIE] のようなフォルダを Web サーバー上に作成します。たとえば、サーバーへのパスは、C:\Inetpub\Wwwroot\Cie のように指定します。この Web サーバーの仮想ルートがコンピュータ名の場合、該当する URL は http://コンピュータ名/Cie/ のように指定します。

デジタル証明書の取得

インターネットまたは特別な構成を行っていないイントラネットを経由してファイルを配布する場合は、Internet Explorer 6 カスタマイズ ウィザードで作成したカスタム ファイルやカスタム コンポーネントなどの特定のファイルに署名を施すための準備が必要です。ブラウザのセキュリティ機能を使用すれば、署名が施されていないファイルをダウンロードする際、ユーザーに警告を表示したり、ダウンロード処理を禁止したりできます。デジタル署名は、プログラムの発行元を明らかにし、該当するコードが署名時点以降に変更されていないことを保証するものです。

証明機関から発行元証明書を既に取得している場合は、Internet Explorer 6 カスタマイズ ウィザードでファイルに署名を施すことができます。IEAK で使用する証明書を用意するには、証明書のインポート ウィザードを使用して現在のコンピュータに証明書をインポートします。拡張子 .spc の付いたファイルを受け取ったら、Windows エクスプローラまたはマイ コンピュータで .spc ファイルをダブルクリックして、証明書のインポート ウィザードを起動することができます。

Internet Explorer から証明書のインポート ウィザードを起動することもできます。それには、[ツール] メニューの [インターネット オプション] をクリックし、[コンテンツ] タブをクリックして、[証明書] をクリックしてください。[インポート] をクリックして証明書のインポート ウィザードを起動し、画面に表示される指示に従って操作してください。

Windows デスクトップのアップデートを組織で使用できるように構成するかどうかを決定しておきます。

ディレクトリ構造の作成

フォルダ名 | [説明]
\CIE | IEAK によって作成された、またはカスタム パッケージで参照されるすべてのファイルの親フォルダ
\CIE\Bitmaps | カスタム ビットマップ ファイル (カスタム ブラウザに必要なグラフィック ファイル)

適切なグラフィックスの作成

次のビットマップは、ブラウザでカスタマイズすることもできます。 Internet Explorer 6 カスタマイズ ウィザードを実行する前に、ビットマップを \CIE\Bitmaps フォルダに格納してください。

独自に作成した背景とボタンのビットマップは、256 色 (8 ビット) 以上の表示能力を持つコンピュータでだけ表示されます。16 色 (4 ビット) の表示能力を持つコンピュータでは、低解像度用の標準の背景ビットマップとボタン セットが表示されます。

  • CD-ROM 自動実行画面の背景のビットマップ 1 個 (CD-ROM パッケージを作成する場合)。

    カスタム ブラウザを CD-ROM で配布する場合は、ユーザーが CD-ROM を挿入したときに自動実行画面の一部に表示されるビットマップを作成する必要があります。

  • CD-ROM ボタンのカスタム イメージ (CD-ROM パッケージを作成する場合)。
  • Windows Update セットアップ ウィザード用の 2 つのカスタム ビットマップ (外観をカスタマイズする場合)。ウィザードの最初の画面の左側に表示する 162 × 312 ピクセルのビットマップ、およびウィザードの 2 番目以降の画面の上側に表示する 496 × 56 ピクセルのビットマップ。
  • カスタム ツール バー用のビットマップ 1 個 (ボタンとメニューの背景として表示されます)。
  • 256 色の静止ビットマップ イメージ 2 個 (38 x 38 ピクセル 1 個、22 x 22 ピクセル 1 個)。これらを使用すれば、Internet Explorer ブラウザに自社のブランドをロゴとして表示できます。
  • 256 色の動画ビットマップ イメージ 2 個 (38 x 38 ピクセル 1 個、22 x 22 ピクセル 1 個)。これらを使用すれば、Internet Explorer ブラウザに自社のブランドを動画ロゴとして表示できます。

    Internet Explorer 管理者キットには、ブラウザに合ったカスタム版の動画ビットマップを簡単に作成およびプレビューできるようなツールが 2 つ入っています。

ホーム ページ、検索ページ、およびサポート ページ用の URL の指定

ユーザー サイトでブラウザのインストール時に問題が起きたときに備えて、サポート ページを作成しておくと便利です。Internet Explorer 6 カスタマイズ ウィザードを実行中に、サポート ページの URL を指定するように指示するメッセージが表示されます。

セキュリティおよび Windows デスクトップのアップデートの使用方針の決定

セキュリティや Windows デスクトップのアップデートのように、カスタマイズして管理することのできるユーザー オプションはたくさんあります。そのようなオプションの使用方針は、Internet Explorer カスタマイズ ウィザードを実行する前に検討しておく必要があります。

注

  • カスタム ブラウザへのブランドの方法の図解については、「カスタマイズの仕組み」を参照してください。


企業内管理者 － 段階 1 : 情報の収集

バナー

段階 1 : 情報の収集

企業内管理者の場合、Internet Explorer 6 カスタマイズ ウィザードのこの段階では、次の情報を指定します。

  • ファイルの場所 － カスタム ブラウザ パッケージの作成先フォルダを指定します。
  • 対象言語 － 作成対象のブラウザ パッケージの言語を指定します。カスタマイズ ウィザードは、作成対象の言語ごとに起動する必要があります。
  • 配布メディア － CD-ROM またはイントラネットやインターネットからのダウンロードなど、配布に使用するメディアを指定します。
  • 機能 － カスタマイズする機能を指定します。たとえば、ブラウザの機能のごく一部だけをカスタマイズする場合には、それらの機能に関する IEAK ウィザード画面だけを表示できます。

注

  • カスタマイズ ウィザードは、Internet Explorer 6 がインストールされていないと、正しく動作しません。詳細については、「ハードウェアとシステムの必要条件」を参照してください。


企業内管理者 － 段階 2 : セットアップ パラメータのカスタマイズ

バナー

段階 2 : セットアップ パラメータのカスタマイズ

企業内管理者の場合、Internet Explorer 6 カスタマイズ ウィザードのこの段階では、次の情報を指定します。

  • 自動バージョン同期 (AVS) による Microsoft コンポーネントのダウンロードまたは更新 － Internet Explorer のダウンロードは必須ですが、Internet Explorer に関連するその他のコンポーネントはダウンロードするかどうかを選択することができます。
  • カスタム コンポーネントの選択 － 必要なコンポーネントを選択します。

    また、追加するコンポーネントは、16 個まで指定できます。それらのコンポーネントは、自己展開型の実行可能ファイル (.exe) であっても、圧縮されたキャビネット (.cab) ファイルであってもかまいません。


企業内管理者 － 段階 3 : セットアップのカスタマイズ

バナー

段階 3 : セットアップのカスタマイズ

企業内管理者の場合、Internet Explorer 6 カスタマイズ ウィザードのこの段階では、Windows Update セットアップの外観と動作を次のようにカスタマイズできます。

  • CD-ROM パッケージを作成する場合は、CD-ROM 自動実行画面をカスタマイズできます。
  • CD-ROM パッケージを作成する場合は、CD-ROM に関する詳細なオプションをカスタマイズできます。
  • Internet Explorer およびその他のインターネット ツール用の Windows Update セットアップ ウィザードをカスタマイズできます。これらの設定は、ユーザー側に表示するセットアップの外観に影響します。
  • パッケージをサイレント モードでインストールするかどうかを指定できます。ごく一部のプロンプトだけを表示するか、またはプロンプトを一切表示しないように設定できます。
  • 独自のインストール オプションを 10 個まで指定できます。また、各オプションを選択したときにインストールすべきコンポーネントも指定できます。
  • パッケージのダウンロード サイトを 10 件まで指定できます。 ただし、サイレント インストールを実行する企業内管理者の方は、対象外です。
  • コンポーネントの更新をユーザーに通知する方法を指定できます。
  • Internet Explorer をユーザーのコンピュータのどのフォルダにインストールするか、また、ユーザーがそのフォルダを変更できるようにするかどうかを指定できます。
  • ユーザーがセットアップをカスタマイズできるようにするかどうか、アンインストール情報を保存するかどうか、Internet Explorer を旧バージョンと共にインストールできるようにするかどうか、さらに、Internet Explorer を既定のブラウザにするかどうかを指定できます。
  • Windows Update セットアップで既存のコンポーネントを検出するかどうか、また、どのコンポーネントがユーザーによるカスタマイズが可能かを詳細に指定できます。
  • ダウンロードしたコンポーネントのうちパッケージに追加していないコンポーネントを、Internet Explorer のオンデマンドのインストール機能でユーザーのコンピュータにインストールするかどうかを指定できます。
  • Web ブラウザの機能をデスクトップおよびフォルダに統合するかどうかを指定できます。 この機能は、Windows 98 には標準で組み込まれています。
  • 接続マネージャ管理キット (CMAK) を使用して接続マネージャ ダイヤラをカスタマイズしたかどうかを指定できます。
  • デジタル証明書を既に取得している場合は、IEAK パッケージの作成中にプログラムに署名できるように、証明機関情報を指定できます。

注

  • カスタム ブラウザへのブランドの方法の図解については、「カスタマイズの仕組み」を参照してください。
  • Internet Explorer 6 カスタマイズ ウィザードでカスタム パッケージを作成するときの流れについては、「IEAK でのカスタム パッケージの生成」を参照してください。


企業内管理者 － 段階 4 : ブラウザのカスタマイズ

バナー

段階 4 : ブラウザのカスタマイズ

企業内管理者の場合、Internet Explorer 6 カスタマイズ ウィザードのこの段階では、次の項目をカスタマイズできます。

  • ブラウザのタイトル バー － Internet Explorer および Outlook Express をパッケージに入れて配布した場合や、ユーザーのコンピュータに既に Internet Explorer および Outlook Express がインストールされている場合、カスタム ブラウザのタイトルは、Internet Explorer と Outlook Express の両方に表示されます。
  • ブラウザのツール バーの背景およびボタン － ツール バーには、スクリプトやプログラムを実行するカスタム ボタンを追加できます。
  • ブラウザの右上に表示される Internet Explorer のロゴ
  • ブラウザのホーム ページ、検索ページ、およびオンライン サポート ページ
  • [お気に入り]、[お気に入り] フォルダ、およびリンク バーのリンク
  • ウェルカム ページ － ユーザーがブラウザを最初に起動したときに表示されます。
  • ユーザー エージェント文字列 － ユーザー エージェントを使用すれば、カスタム ブラウザの使用状況を監視することができます。
  • ユーザーの接続の設定 － 設定をカスタマイズしたり、現在のコンピュータの設定をインポートしたり、またユーザーの既存の設定を削除することができます。
  • 自動構成 － ブラウザの自動構成に使用するファイルのパスを指定できます。
  • プロキシの設定
  • セキュリティ証明書および Authenticode に関する設定
  • セキュリティ ゾーンおよび規制に関する設定

注

  • カスタム ブラウザへのブランドの方法の図解については、「カスタマイズの仕組み」を参照してください。


バナー

企業内管理者

段階 5 : コンポーネントのカスタマイズ

企業内管理者の場合、Internet Explorer 6 カスタマイズ ウィザードのこの段階では、次の項目をカスタマイズできます。

  • 既定のプログラムの設定 － 電子メールや HTML の編集に使用される特定のプログラムなど。
  • ユーザーのニュース サーバーとメール サーバー － カスタム パッケージに Outlook Express を含める場合。
  • ユーザーの IMAP 電子メール サーバーの設定 － IMAP サーバーを使用して、Outlook Express を展開する場合。
  • Outlook Express のカスタム コンテンツ － 電子メールでユーザーに送信するウェルカム メッセージを追加したり、該当するプログラムをユーザーが起動したときに表示される情報パネルをカスタマイズしたりすることができます。
  • Outlook Express のカスタム設定 － メールおよびニュースの既定のクライアントを設定したり、ユーザーが追加の電子メール アカウントを取得するときに必要となる情報を用意したり、ユーザーに既定で適用するメッセージ規則ファイルを作成したりすることができます。
  • Outlook Express のユーザー インターフェイスの設定 － フォルダ バー、フォルダ一覧、ステータス バー、または Outlook バーを表示するかどうかを指定できます。
  • Outlook Express のメッセージ作成時の設定 － インターネットのニュースグループや電子メールのメッセージで使用する企業文書や署名を提供する場合。
  • Windows アドレス帳のディレクトリ サービス － ユーザーにインターネット ディレクトリ サービスを提供し、LDAP (Lightweight Directory Access Protocol) サーバーをカスタマイズする場合。
  • 特定のシステムのポリシーおよび制限 － ユーザーが実行しているオペレーティング システムによって異なります。 ユーザーが Windows NT、Windows 2000、または Windows XP を使用している場合、ポリシーおよび制限によっては、IEAK カスタマイズ ウィザードまたは IEAK プロファイル マネージャ ではなく、Windows NT ポリシー エディタ、Windows 2000、または Windows XP グループ ポリシーを通して管理する必要があります。
  • システム ポリシーおよび設定 － ブラウザ、電子メール、セキュリティ、およびデスクトップに関するオプションを含む各種制御オプションをあらかじめ設定できます。


バナー

企業内管理者

ブラウザ パッケージの配布方法

既定では、Internet Explorer 6 カスタマイズ ウィザードは、ユーザーがインターネットを経由してダウンロードすることのできるファイルを作成します。必要に応じて、パッケージの配布に使用するメディアを変更することができます。

ダウンロード可能なファイル

ブラウザ パッケージをインターネット サーバーまたはイントラネット サーバーに作成した場合は、一連のファイルをユーザーがダウンロードできるように、Web サイトをセットアップする必要があります。たとえば、ダウンロード情報やインストール エンジン IE6setup.exe へのリンクを記載したページを作成します。

ブラウザ パッケージをハード ディスクやネットワーク ドライブに作成した場合は、次の項目をインターネット サーバーまたはイントラネット サーバーに移動する必要があります。

  • 配布するブラウザの言語に対応するフォルダおよびそのフォルダの内容。たとえば、英語版のフォルダ名が En である場合は、[En] フォルダをそれに格納されているファイルと共に移動する必要があります。このフォルダは、メディアの種類 (ダウンロードなど) およびプラットフォーム (Win32 など) に対応するフォルダの中に作成されます。Internet Explorer 管理者キット 6 が使用できるプラットフォームは、"Win32" のみです。UNIX および 16 ビット Windows クライアントの場合は、Internet Explorer 管理者キット 5.0.x を使用します。
  • Ie6sites.dat という名前のファイル。このファイルは、Internet Explorer 6 カスタマイズ ウィザードを実行したときに指定したダウンロード サイト (1 つまたは複数個) を示します。

ユーザーは、IE6setup.exe をダブルクリックして、ブラウザをインストールします。このファイルは、\Download フォルダ内のサブフォルダのうち、ブラウザの言語およびプラットフォームに対応するサブフォルダ (\Download\Win32\En) に格納されています。

カスタム パッケージへの署名

Web ブラウザには、ユーザーが有害なプログラムをダウンロードできないようにするセキュリティ機能があります。セキュリティ レベルおよびオペレーティング システムによっては、デジタル署名が施されていないプログラムをユーザーがダウンロードしようとすると、ダウンロードできないことを示すメッセージ、または警告メッセージが表示されることがあります。

Internet Explorer 6 カスタマイズ ウィザードで作成されたカスタム .cab ファイルには、ローカル イントラネット ゾーンのセキュリティ レベルを低に設定している場合を除いて、デジタル署名を施してください。これらのオペレーティング システム用のブラウザ パッケージと共にカスタム コンポーネントを配布する場合は、それらのコンポーネントにも署名を施してください。デジタル証明書を既に取得している場合は、Internet Explorer 6 カスタマイズ ウィザードでこれらのファイルに自動的に署名することができます。

注

  • キャビネット ファイルおよびカスタム プログラムに署名を施すには、2 つの操作が必要です。デジタル証明書の取得と、カスタマイズ ウィザードでの証明書情報の指定です。
  • UNIX FTP サーバーの場合は、ファイル名の大文字/小文字の変更が必要になることがあります。特定の UNIX オペレーティング システムを使用する場合は、次のような決まりがあります。
    • Solaris UNIX
      大文字と小文字を区別する UNIX FTP サーバーを使用する場合は、.cab ファイルのフォルダを小文字で表記する必要がありますが、BRANDING.CAB、CUSTOM.CIF、DESKTOP.CAB、IE.CIF、IECIF.CAB、および IE6SITES.DAT の各ファイル名は、大文字で表記する必要があります。
    • AT&T UNIX
      AT&T UNIX FTP サーバーでは、すべてのファイル名を大文字で表記する必要があります。
    • IRIX UNIX (Silicon Graphics)
      BRANDING.CAB、CUSTOM.CIF、DESKTOP.CAB、IE.CIF、IECIF.CAB、および IE6SITES.DAT の各ファイル名は、大文字で表記する必要があります。IE.CIF に含まれる一覧のファイル名についても、テキスト エディタを使用して大文字に変更してください。

[CD-ROM]

Windows 95 または Windows 98 のユーザーにカスタム ブラウザを配布する場合、ユーザーが CD-ROM を挿入すると、自動実行プログラムの画面が表示されます。このプログラムでは、カスタム ブラウザのインストールや詳細情報の表示をユーザーが選択できます。最新バージョンの Internet Explorer が既にインストールされていると、自動実行プログラムがそれを検出します。ブラウザは、Start.htm ファイルが読み込まれると、キオスク モードで表示されます。

Windows Update セットアップ ウィザードを使用すると、すべてのファイルをイントラネット サーバーまたはインターネット サーバーに送信できます。また、インターネットに最初からアクセスできないようなユーザーのために、CD-ROM で作成することもできます。

注

  • ダウンロード処理の図解については、「Windows Update セットアップ ウィザードによる Internet Explorer およびその他のインターネット ツールのセットアップ」を参照してください。
  • 図解については、「配布用ファイルのセットアップ方法」を参照してください。
  • Internet Explorer 6 カスタマイズ ウィザードでのファイルの作成の流れについては、「IEAK でのカスタム パッケージの生成」を参照してください。


ユーザーの設定の管理

ユーザーのオプションを設定し、ブラウザを配布した後も、管理者はそれらの設定を管理することができます。マスターの .ins ファイルをサーバーに保存し、ユーザーがネットワークにログオンのたびにそれをダウンロードするようにすれば、管理者はユーザーのオプション値の設定を絶えず調整できます。既存のログオン スクリプトに組み込むと、管理者は中央のサーバーからユーザーの設定を管理し、定期的に更新することができます。

Internet Explorer 管理者キット プロファイル マネージャを使用すると、構成ファイルを簡単に管理できます。プロファイル マネージャでは、任意の .ins ファイルを開いて、プロキシ、ホーム ページ、検索バー、LDAP (Lightweight Directory Access Protocol) などの設定を変更できます。

Windows 2000 および Windows XP を実行しているシステムの場合は、グループ ポリシーを使用して一部のユーザーの設定を管理できます。

インストール後、管理者は、証明書リストへの証明書の追加または削除を実行することにより、認証済み発行者 (およびサイト) をすべてリモートに管理することができます。


ポリシーの結果セットのスナップインの使用

ポリシーの結果セット (RSoP) のスナップインを使用して、コンピュータおよびユーザー用にセットアップされているポリシー情報を参照することができます。RSoP ウィザードを使用すると、ログ モードまたは計画モードを選択できます。ログ モードでは既存のコンピュータおよびユーザーのポリシー情報にアクセスし、計画モードでは Active Directory に基づいてポリシー情報を生成します。いずれの場合も、ソフトウェアの設定、ウィンドウの設定、および管理者のテンプレートなどの情報を参照できます。

ポリシーの結果セット ウィザードを使用する場合は、コンピュータ情報とユーザー情報のどちらを扱うのか、または両方を扱うのかどうかを決定します。ウィザードを実行すると、表示できる設定が含まれたフォルダの一覧が構成されます。情報を参照すると、ポリシーの計画に役立ちます。計画が完了したら、Internet Explorer 6 カスタマイズ ウィザードまたは Internet Explorer プロファイル マネージャを使用して、ポリシーを設定します。いったんポリシーを展開したら、RSoP のスナップインを使用してポリシーを調べることができます。

注

  • ポリシーの参照に、Windows 2000 および Windows XP のユーザーはグループ ポリシーのスナップインを使用できます。Windows NT のユーザーはポリシー エディタを使用できます。また、Internet Explorer 6 カスタマイズ ウィザードまたは Internet Explorer プロファイル マネージャを使用して、カスタマイズするポリシーを設定することもできます。
  • Internet Explorer 6 カスタマイズ ウィザードを使用して、Internet Explorer のカスタム パッケージのポリシーを設定し、展開します。
  • Internet Explorer プロファイル マネージャを使用して、特定のコンピュータまたはユーザー用にポリシーを設定します。

計画モードでは、コンピュータまたはユーザーで設定されていない新しいポリシーを作成します。そのため、RSoP のスナップインでグループ ポリシーに関する情報を生成する必要があります。ただし、ログ モードでは、グループ ポリシーが適用されているコンピュータに既存の情報があります。

RSoP のスナップインの使用には、2 つの処理があります。まず、ウィザードを実行して、表示したい情報を指定します。次に、コンソール ウィンドウで、表示したい設定が含まれているフォルダを開きます。

ポリシーの結果セット ウィザードを実行するには

  1. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。
  2. [名前] ボックスに「mmc」と入力し、[OK] をクリックします。
  3. [ファイル] メニューの [スナップインの追加と削除] をクリックします。
  4. [スタンドアロン] タブの [追加] をクリックします。

ポリシーの結果セットを使用して Internet Explorer の設定を調べるには

  1. ポリシーの結果セットで、[ユーザーの構成] をクリックします。
  2. [Windows の設定] をクリックして [Internet Explorer のメンテナンス] をクリックします。
  3. 調べる機能のアイコンをクリックします。
  4. 調べる機能のタイトルをダブルクリックします。


IEAK のセキュリティ オプション

IEAK のセキュリティ オプションに関する情報のほとんどは、Internet Explorer 6 カスタマイズ ウィザードの [ヘルプ] をクリックすれば参照できます。以下のトピックを参照して、その情報の概要を知ることもできます。

  • セキュリティ
  • セキュリティおよびプライバシーの設定
  • ポリシーおよび制限
  • ユーザーによるインストール
  • Outlook Express のアカウント

注

  • これらのウィザードのページを表示しているときに特定のページを参照するには、[次へ] をクリックして目的のページを見つけます。


ファイル形式

ファイル形式 | 説明
.adm | 管理 (.adm) ファイルは、デスクトップ、シェル、およびセキュリティのシステム ポリシーと制限を定義します。IEAK または Windows のシステム ポリシー エディタを使って、.adm ファイルの設定をカスタマイズおよび制限することができます。標準の .adm ファイルから設定できるシステム ポリシーと制限の一覧については、「IEAK プロファイル マネージャとは」を参照してください。
.asp | Internet Explorer を Web サーバーから配布する場合は、カスタム ブラウザ パッケージに Active Server Page (.asp) ファイルを含めることができます。.asp ファイルを使うと、HTML ページにスクリプトを埋め込んで、動的でインタラクティブな Web コンテンツを作成できます。たとえば、ユーザーがブラウザをダウンロードし、インターネット サービスに登録できるようなサインアップ ページを作成できます。Internet Explorer 6 カスタマイズ ウィザードまたは IEAK プロファイル マネージャの中で、.asp ファイルを示すことができます。リソース キットの CD-ROM に、サンプルの .asp ファイルが入っています。
.bat | オペレーション システムの一連のコマンドが記述された ASCII テキスト ファイルです。バッチ コマンド言語でサポートされているパラメータおよび演算子を含みます。ユーザーがコマンド プロンプトにバッチ ファイルの名前を入力すると、コンピュータがコマンドを連続的に処理します。
.bmp、.gif、.jpeg、.jpg | Internet Explorer には、.bmp、.gif、.jpeg、または jpg ファイル形式を使用した静止グラフィックスおよび動画グラフィックスを含めることができます。IEAK と共に供給されるグラフィック ファイルを使うだけでなく、独自のグラフィックスを作成して、カスタム ブラウザ パッケージに含めることができます。たとえば、Internet Explorer のロゴまたは自動実行画面を、独自の静止グラフィックスまたは動画グラフィックスのファイルに置き換えることができます。IEAK には、カスタム動画グラフィックスの作成に役立つ 2 つのツールが含まれています。カスタマイズするグラフィックスの必要条件については、「カスタム グラフィックスの作成」を参照してください。
.cab | キャビネット (.cab) ファイルは、ユーザーのコンピュータにコピーされる圧縮したインストール ファイルを作成し、格納します。Windows Update セットアップ (IE6Setup.exe) は、Internet Explorer のインストールに必要な .cab ファイルを、ユーザーのコンピュータにダウンロードします。これらの .cab ファイルには、ブラウザおよびカスタム コンポーネントの両方を含めることができます。ファイルが問題なくダウンロードされると、Windows Update セットアップが終了します。IEAK には、カスタム コンポーネントの .cab ファイルの作成に役立つツールが含まれています。
.cif | IESetup.cif という名前のコンポーネント情報 (.cif) ファイルは、新しいコンポーネントや更新されたコンポーネントを含む、Internet Explorer と共にインストールできるコンポーネントを識別します。.cif ファイルでは、各コンポーネントが関連した ComponentID を持っています。Windows Update セットアップは .cif ファイルを読み込んで、指定された ComponentID を持つコンポーネントが既にインストール済みであるかどうか、または最新バージョンのコンポーネントがインストールに利用可能かどうかを決定します。
.cmp | 接続プロファイル (.cmp) ファイルは CMAK によって生成され、ユーザーによって指定された情報を含みます。.cmp ファイルは編集しないでください。変更した内容は、ユーザーによって上書きされてしまいます。
.cms | サービス プロバイダ (.cms) ファイルは CMAK によって生成され、電話帳の構成とサービス プロファイルの他の機能のほとんどを指定します。サービス プロファイルの最も高度なカスタマイズは、そのサービス プロファイルの .cms ファイルを編集して行います。
.exe | IE6Setup.exe という名前の実行可能 (.exe) ファイルは、セットアップ処理を制御するインストール プログラムです。この .exe ファイルは、ユーザーのコンピュータ上にカスタム ブラウザ パッケージをインストールする .cab ファイルをダウンロードします。これらの .cab ファイルには、ブラウザおよびカスタム コンポーネント用の追加の自己展開型実行可能ファイル (*.exe) が交互に含まれます。
.htt | HTML テンプレート (.htt) ファイルは、マイ コンピュータ (Mycomp.htt)、コントロール パネル (Controlp.htt)、プリンタ (Printers.htt)、およびフォルダ用の既定の Web ビュー (Folder.htt) 用のカスタマイズ可能なテンプレートを提供します。テキスト エディタまたは HTML エディタを使って、これらのファイルの特別な指示や、ロゴ、Web サイトへのリンクなどをカスタマイズできます。カスタム ブラウザ パッケージに Mycomp.htt および Controlp.htt を含めることができます。Printers.htt および Folder.htt テンプレートは、ユーザーのコンピュータ上で直接カスタマイズする必要があります。
.inf | 一般に、Internet Explorer の各 .cab ファイルには、関連する情報 (.inf) ファイルが含まれます。.inf ファイルは、詳細なインストール情報を提供します。.inf ファイルは、.cab ファイル内のファイルのほか、他の URL にあるファイルを参照することができます。
.ins | Windows Update セットアップには、ブラウザとそのコンポーネントを構成するインターネット設定 (.ins) ファイルが含まれます。この .ins ファイルのコピーをカスタマイズすることにより、複数のバージョンのブラウザ パッケージを作成できます。また、IEAK プロファイル マネージャを使って、Internet Explorer の構成の設定の更新に使用する .ins ファイルの作成、保存、および読み込みを行うこともできます。
.isp | カスタム ブラウザ パッケージを使ってサインアップ処理を実行している場合は、Signup.isp という名前のインターネット サインアップ (.isp) ファイルが、インターネット サービス用のダイヤルアップ情報を提供します。Internet Explorer 6 カスタマイズ ウィザードを使って、インターネット サインアップ ファイルに含まれるパラメータを編集できます。サーバーベースのサインアップ方法では、このサインアップ ファイルに、.ins 構成ファイルを生成するサーバー スクリプトの URL へのリンクも含まれます。
.pac、.js、.jvs | テキスト エディタを使って、カスタム ブラウザ パッケージの自動プロキシ スクリプト ファイルを作成できます。自動プロキシ スクリプト ファイルは、JScript (.js)、JavaScript (.jvs)、または自動プロキシ構成 (.pac) ファイルです。自動プロキシ スクリプト ファイルが指定されると、Internet Explorer がそのスクリプトを使って、ホストに直接接続するかどうか、またはプロキシ サーバーを使用するかどうかを動的に決定します。Internet Explorer 6 カスタマイズ ウィザードの段階 4 で、詳細なプロキシの設定を構成および維持するための自動プロキシ URL を指定できます。
.pdf | Microsoft Systems Management Server を使って Internet Explorer を配布している場合は、カスタム ブラウザ パッケージがインストール ファイルおよびパッケージ定義ファイル (.pdf) のフォルダで構成されます。この IE6.pdf という名前のファイルには、セットアップ プログラム、インストール オプション、および自分のサーバーまたはユーザーのコンピュータ上に Internet Explorer を自動でセットアップするためのコマンド ラインの構文が含まれています。この .pdf ファイルを使うと、管理者またはユーザーからの入力を必要とせずにインストールを実行することができます。
.pvk | 秘密キー ファイル。デジタル署名に関連付けられている秘密キーが含まれています。
.pwl | このコンピュータのユーザーの Windows パスワードが含まれているファイルです。
.sed | 接続プロファイル (.sed) ファイルは CMAK によって生成され、サービス プロファイル用の自己展開型実行可能 (.exe) ファイルを作成するための指示を含んでいます。いずれの .sed ファイルも編集しないでください。
.spc | ソフトウェア発行元証明書ファイルです。証明書には、証明書の所有者を識別する名前およびその他の情報、証明書に関連付けられている公開キー、シリアル番号、証明書の有効期間、および証明書を発行した証明機関のデジタル署名が含まれます。


Internet Explorer のセキュリティ

Internet Explorer を使用すれば、いくつかの方法でセキュリティを制御できます。 サイト証明書、Authenticode の発行元、セキュリティ ゾーンなどの方法があります。ユーザーのコンピュータに証明書をあらかじめインストールしておき、ほかの証明書のダウンロードをユーザーに禁止することもできます。また、ユーザーが表示できるコンテンツに規制を設定することもできます。

企業内管理者は、Internet Explorer 6 カスタマイズ ウィザードの段階 4 および段階 5 で、セキュリティに関する設定と規制を指定できます。

セキュリティ ゾーン

Internet Explorer のセキュリティ オプションを使用すれば、各 Web サイトをそのコンテンツの信頼度に基づき、さまざまなゾーンに割り当てることができます。

Internet Explorer をインストールすると、次のセキュリティ ゾーンがセットアップされます。

  • インターネット ゾーン － 既定では、すべてのインターネット サイトがこのゾーンに含まれます。
  • イントラネット ゾーン － ローカル ネットワークに接続されているコンピュータ用のゾーンです。
  • 信頼済みサイト ゾーン － 信頼しているサイトをこのゾーンに割り当てることができます。
  • 制限付きサイト ゾーン － 信頼できないサイトをこれに割り当てることができます。
  • マイ コンピュータ ゾーン － ローカル コンピュータ上のファイルは、このゾーンに含まれます。

これらのゾーンには、4 つの既定のセキュリティ レベルのいずれかを適用できます。高、中、中低、および低の 4 つです。また、各ゾーンにカスタム セキュリティ レベルを設定することもできます。

コントロール パネルの [インターネット] アイコンをダブルクリックした後、[セキュリティ] タブをクリックすれば、セキュリティに関する設定をすべて表示することができます。これらのオプションに関する詳細な情報と操作方法については、「Internet Explorer のセキュリティ オプション」を参照してください。

ただし、インターネット上のセキュリティは、それらの設定に応じて良否が決まります。Internet Explorer を使用すれば、セキュリティをうまく設定するのに必要な情報が得られるだけでなく、それらの設定を柔軟に運用することができます。

セキュリティ オプションは、Internet Explorer 6 カスタマイズ ウィザードの実行時に設定できるばかりでなく、このとき設定したセキュリティ オプションをユーザーが後で変更できるようにするかどうかの指定もできます。セキュリティ オプションを事前に設定しない場合は、組織のニーズとユーザーの習熟度に応じて、最適なセキュリティ レベルをユーザーに推奨することを検討してください。

注

  • 作成中の Internet Explorer ブラウザ パッケージで使用している言語がコンピュータ上のブラウザの言語と異なる場合、セキュリティ ゾーンをインポートすると、パッケージのセキュリティ ゾーンに判読不能の文字が表示される可能性があります。
  • マイ コンピュータ ゾーンに関する設定はブラウザ インターフェイスには表示されないため、IEAK からしか構成できません。組織に特別な必要性のある場合以外は、このゾーンを既定の設定のままにしておくことをお勧めします。セキュリティ レベルを下げるとセキュリティ上のリスクが生じることがありますが、一方、セキュリティ レベルを上げると機能に関して問題が生じる可能性があります。

インターネット ゾーンのセットアップ

インターネット ゾーンは、ほかのどのゾーンにも含まれないようなサイトから構成されます。既定では、インターネット ゾーンは、中 (安全) というセキュリティ レベルに設定されます。インターネットを参照する際にセキュリティ上の問題が懸念される場合は、設定を高 (最も安全) に変更してもかまいません。セキュリティのこの設定を上げると、一部の Web ページに潜在している危険な動作の実行を防ぐことができます。ただし、そうした場合は、一部の便利な機能が動作しなくなったり、一部のページが正常に動作しなくなったりする可能性があります。

カスタム設定を使うと、ゾーンのセキュリティ項目を個別に制御できます。それには、コントロール パネルの [インターネット] アイコンをダブルクリックし、[セキュリティ] タブをクリックし、[レベルのカスタマイズ] をクリックします。

信頼済みサイト ゾーンおよび制限付きサイト ゾーンへのサイトの追加

インターネットおよびローカル イントラネットのゾーンに比べて信頼度の高い Web サイトや低い Web サイトは、これから説明する 2 つのゾーンに追加することができます。これらのゾーンにサイトを追加するには、該当するゾーンを選択し、次に [サイト] をクリックします。

信頼済みサイト ゾーンには、既定では「低」というセキュリティ設定が割り当てられます。このゾーンは、取り引きの多い会社のサイトのように、信頼性が非常に高いサイト ("エクストラネット") を割り当てるゾーンとして用意されています。信頼サイト ゾーンに割り当てたサイトは、より強力な動作を実行できるようになります。このようなゾーンに入れるサイトは、できるだけ少なくするよう、Internet Explorer から警告されます。このゾーンにサイトを追加するのは、そのサイトのコンテンツがコンピュータに被害をもたらす可能性がないと確信できる場合だけにしてください。信頼サイト ゾーンの場合は、HTTPS プロトコルを使用するか、あるいは該当サイトへの接続が安全であることを確認してください。

制限付きサイト ゾーンには、既定では「高 (最も安全)」というセキュリティ設定が割り当てられます。制限付きサイト ゾーンに割り当てたサイトは、最小限のきわめて安全な動作しか実行できなくなります。このゾーンは、信頼できないまれなケースのサイト用に用意されているものです。信頼性の低いコンテンツに対して高いセキュリティ レベルを設定すると、このゾーン内の多くのページは正しく動作しなくなります。

ローカル イントラネット ゾーンのセットアップ (ネットワーク管理者向け)

安全のためには、プロキシ サーバーおよびファイヤウォールと一緒に、ローカル イントラネット ゾーンをセットアップする必要があります。ゾーン内のサイトはすべて、"ファイヤウォールの内部" にある必要があります。また、プロキシ サーバーは、このゾーンに対する外部の DNS 名を解決しないように構成する必要があります。クライアントのゾーンのセキュリティを構成するには、既存のネットワークの構成、プロキシ サーバー、およびセキュリティ用のファイヤウォールに関して詳しい知識が必要です。そのような事柄に詳しくない方は、ネットワーク管理者に相談してください。

既定では、ローカル イントラネット ゾーンは、一連のローカルなドメイン名から構成され、[接続] タブ内の値は、プロキシ内の該当する値で上書きされます。これらの設定は、Internet Explorer 6 カスタマイズ ウィザードの [接続の設定] 画面で構成できます。なお、各ユーザーに複数の接続設定を構成できるようになりました。ネットワーク管理者は、これらの設定をインストールしても本当に安全であることを確認するか、または安全になるように調整してください。

ゾーンを設定する際は、検討の対象とする URL のカテゴリを指定することができます。また、ゾーンに特定のサイトを追加することもできます。

ゾーンに追加する URL のカテゴリをブラウザから指定するには

  1. Internet Explorerで、[ツール] メニューの [インターネット オプション] をクリックし、[セキュリティ] タブをクリックします。
  2. [イントラネット] ゾーンをクリックし、[サイト] をクリックします。
  3. 次のチェック ボックスのうち、適切なチェック ボックスをオンにします。

    [ほかのゾーンにないローカル (イントラネット) のサイトをすべて含める]
    [プロキシ サーバーを使用しないサイトをすべて含める]
    [すべてのネットワーク パス (UNC) を含める]

注

  • このゾーンに特定のサイトを追加するには、[詳細] をクリックして URL を入力し、[追加] をクリックします。サーバー認証を必ず使用するように指定するには、[このゾーンのサイトにはすべてサーバーの確認 (https:) を必要とする] チェック ボックスをオンにします。
  • IEAK パッケージで使用する URL のカテゴリを指定するには、Internet Explorer 6 カスタマイズ ウィザードの [セキュリティの設定] 画面で [現行のセキュリティ ゾーンとプライバシーの設定をインポートする] をクリックし、[設定の変更] をクリックします。

ローカル イントラネット ゾーンのオプションには、次の規則が適用されます。ただし、どのゾーンにサイトを追加する場合でも、次の規則は優先順位が一番下です。

  • ほかのゾーンにないローカル (イントラネット) のサイトをすべて含める － イントラネットのサイト名には、http://local のように、ドットが含まれません。http://www.microsoft.com のようなサイト名は、ドットが含まれているため、ローカルではないと判断できます。このサイトは、インターネット ゾーンに割り当てます。イントラネット サイトの名前の規則は、http: の URL だけでなく、ファイルにも適用されます。
  • プロキシ サーバーを使用しないサイトをすべて含める － イントラネットの通常の構成では、プロキシ サーバーを使用することにより、イントラネット サーバーに直接接続してインターネットにアクセスします。この設定では、このような種類の構成情報を使用して、ゾーンのイントラネット コンテンツとインターネット コンテンツを区別します。プロキシ サーバーがこのように構成されていない場合は、このオプションをクリアし、ほかのオプションを使って、ローカル イントラネット ゾーンに割り当てるファイルを指定してください。プロキシ サーバーが存在しないシステムでは、このオプションの設定は無視されます。
  • すべてのネットワーク パス (UNC) を含める － ネットワーク パス (\\local\file.txt など) は通常、イントラネット ゾーンに入れるべきローカル ネットワークのコンテンツを指すのに使用します。イントラネット ゾーンに含めるべきではないネットワーク パスがある場合は、このオプションをクリアし、ほかのオプションを使って、イントラネット ゾーンに割り当てるファイルを指定してください。たとえば、一部の共通インターネット ファイル システム (CIFS) の構成では、ネットワーク パスを使ってインターネットのコンテンツを参照することができます。

イントラネット ゾーンの安全性が確認されたら、より広範で強力な動作を実行できるように、ゾーンのセキュリティ レベルを中低または低に変更することを検討します。[セキュリティの設定] ダイアログ ボックスで、セキュリティの設定を個々に調整することもできます。

安全性が低かったり、信頼できなかったりする部分がイントラネットの中にある場合は、その部分をこのゾーンから除外して、制限付きサイト ゾーンに割り当てることもできます。

ローカル イントラネット ゾーンは、IEAK を使って構成するようになっていますが、[インターネット オプション] ダイアログ ボックスの [セキュリティ] タブにある一連のオプションを使って構成することもできます。

ドメイン名サフィックスの扱い

ドメイン名サフィックスを使うと、ドメインを含まない短縮アドレスで Web サーバーを参照できます。たとえば、sample.microsoft.com という名前の Web サーバーを sample という短縮アドレスで参照することができます。この場合、http://sample.microsoft.com と http://sample のどちらを入力しても同じコンテンツにアクセスできます。

このようにセットアップするには、次の手順に従って、TCP/IP プロパティの [ドメイン サフィックスの検索順序] にドメイン サフィックスの検索順序を追加します。

  1. [ネットワーク コンピュータ] アイコンを右クリックし、[プロパティ] をクリックします。
  2. [TCP/IP] をクリックし、[プロパティ] をクリックします。
  3. [DNS 設定] タブをクリックし、[ドメイン サフィックスの検索順] で必要な情報を追加します。

この構成では、セキュリティ ゾーンを正確にセットアップすることが重要です。既定では、http://sample のようにドットが含まれない URL はローカル イントラネット ゾーン内の URL と見なされ、http://sample.microsoft.com のようにドットが含まれている URL はインターネット ゾーン内の URL と見なされます。したがって、ドメイン名サフィックスを使う場合、コンテンツを適切なゾーンに明示的に割り当てるプロキシ サーバー バイパスが存在しなければ、ゾーンの設定を変更する必要があります。

ドメイン サフィックスでアクセスするコンテンツがイントラネットとインターネットのいずれのコンテンツとして扱われるかによって、どちらにも取れるサイト URL を適切なゾーンに割り当てなければなりません。http://sample のような URL をインターネット ゾーンに割り当てるには、イントラネット ゾーンに対して [ほかのゾーンにないローカル (イントラネット) のサイトをすべて含める] チェック ボックスをオフにし、そのサイトをゾーンのサイトの一覧に追加します。

すべてのゾーンに適用されるセキュリティについて必要な知識

Web コンテンツのアドレスは、ドメイン ネーム システム (DNS) の名前か、インターネット プロトコル (IP) のアドレスで指定できます。これらの両方を使用するサイトでは、同一のゾーンを両方の方法で参照するように構成しなければなりません。ローカル イントラネット サイトは一般に、プロキシ サーバーのバイパス リストの中にあるローカル名か IP アドレスによって識別が可能です。その他の名前と IP アドレスはすべて、インターネット ゾーンにマッピングされます。ただし、サイト名は信頼済みサイト ゾーンまたは制限付きサイト ゾーンのサイトの一覧に入っているが、該当する IP アドレスの範囲が一覧に入っていない場合、IP アドレスによってアクセスされたとき、このサイトは、インターネット ゾーンの一部として処理される可能性があります。

ユーザーが 2 つのゾーンの間でコンテンツをコピーすると、コンテンツのセキュリティ レベルが本来のレベルより高くなったり、低くなったりする可能性があることに注意してください。

自動構成を使用しており、同じ自動構成ファイルを使用して Internet Explorer 5 (またはそれ以降) と Internet Explorer 4 の両方をサポートしている場合は、両方の間でセキュリティ設定が異なっていると、Internet Explorer 4 にはその設定が構成されません。


Internet Explorer のセキュリティ オプション

Internet Explorer のセキュリティ ゾーンを使用すると、Web コンテンツに対してセキュリティ オプションを指定できます。ゾーンとは、同じレベルの信頼を割り当てる Web サイトの集合です。各 Web サイトを特定のゾーンに追加し、そのゾーンに適したセキュリティ オプションを設定します。

Internet Explorer の既定の設定は、システムのセキュリティ機能に合わせて、最も適切な設定に変更できます。たとえば、安全性の高いイントラネットの場合、ローカル イントラネット ゾーンがファイヤウォールに適合するように構成した後で、セキュリティ レベルを低または適切なカスタム設定に変更できます。

セキュリティ オプションはすべて、Internet Explorer ブラウザに適用されるものであって、システム全体に適用されるものではありません。ほかのインターネット プログラムには、これらのオプションを反映するものと、反映しないものがあります。

社内のセキュリティ オプションを設定するには、IEAK を使用して設定を変更しなければなりません。ユーザーがブラウザでセキュリティ オプションを表示するには、[ツール] メニューの [インターネット オプション] をクリックし、[セキュリティ] タブをクリックします。カスタム設定を表示するには、セキュリティ ゾーンを選択して、[レベルのカスタマイズ] をクリックします。

ActiveX コントロールとプラグイン

ここで説明するオプションでは、ActiveX コントロールとプラグインの管理者による認可、ダウンロード、実行、およびスクリプト実行の方法を制御します。ActiveX コントロールの管理と認可の詳細については、「ActiveX コントロールの管理」を参照してください。

ActiveX コントロールのダウンロード元のサイトがそのコントロールを使用しているサイトと異なる場合は、2 つのサイトのゾーン設定のうち、制限が厳しい方の設定が適用されます。たとえば、ダウンロード可能 ([有効にする]) と設定されているゾーン内の Web ページを表示しているが、実際にコードをダウンロードするのは、ユーザーにプロンプトを表示するように設定されている別のゾーンである場合は、後者の設定が使用されます。

[スクリプトを実行しても安全だとマークされている ActiveX コントロールのスクリプトの実行]
このオプションは、スクリプトを実行しても安全だとマークされている ActiveX コントロールをスクリプトで操作するかどうかを指定します。PARAM タグで読み込む初期化安全コントロールは、このオプションの影響を受けないことに注意してください。[スクリプトを実行しても安全だとマークされていない ActiveX コントロールの初期化とスクリプトの実行] が [有効にする] に設定されていると、その設定によってすべてのオブジェクトの安全性が無視されるため、このオプションは無視されます。安全なコントロールに対するスクリプト制御を禁止している間、安全でないコントロールに対するスクリプトは実行できません。
[スクリプトを実行しても安全だとマークされていない ActiveX コントロールの初期化とスクリプトの実行]
ActiveX コントロールは、安全と危険のいずれかに分類されます。このオプションでは、安全でないコントロールをスクリプトで操作できるようにするかどうかを指定します。安全でないコントロールは、原則としてインターネット上の Web ページでの使用には適しませんが、ページの信頼性が非常に高く、コントロールが悪用される危険性のない場合には、安全でないコントロールをインターネット上の Web ページに使用してもかまいません。オブジェクトの安全性は、該当ゾーン内の一連のページを操作する ActiveX コントロールとスクリプトがすべて信頼できる場合を除き、強制的に適用する必要があります。次のような設定があります。
[ActiveX コントロールとプラグインの実行]
このオプションでは、指定したゾーンから ActiveX コントロールとプラグインをページ上で実行することを許可するかどうかを指定します。このオプションを無効にすると、ActiveX コントロールやプラグインを実行できなくなり、ほかの ActiveX の設定が無視されます。ActiveX コントロールの使用に関しては、ダウンロード、実行、およびスクリプト制御の 3 つのステップがあり、各ステップに適用するオプションが用意されています。ダウンロード オプションでは、署名済みのコントロールと未署名のコントロールが区別されます。スクリプト オプションは、安全なコントロールと安全でないコントロールのそれぞれについて設定できます。コントロールがスクリプトで安全に制御 (または初期化) できるかどうかは、コントロールの作成者によって決定されますが、署名の有無には依存しません。署名と安全性は切り離して考える必要があります。詳細については、「MSDN Online Web Workshop」を参照してください。
[署名済み ActiveX コントロールのダウンロード]
このオプションでは、ユーザーが署名済みの ActiveX コントロールをこのゾーンのページからダウンロードできるようにするかどうかを指定します。次のような設定があります。
  • [有効にする] を選択すると、ユーザーは任意の署名済みコントロールをプロンプトなしでダウンロードできます。
  • [ダイアログを表示する] を選択すると、信頼できない発行元によって署名されたコントロールをダウンロードする場合は、その前に警告が表示されます。このオプションを設定しても、信頼できる発行元によって署名されたコードについては、プロンプトなしでダウンロードできます。
  • [無効にする] を選択すると、ユーザーはどの署名済みコントロールもダウンロードできなくなります。
[未署名の ActiveX コントロールのダウンロード]
このオプションを有効にすると、ユーザーは未署名の ActiveX コントロールをこのゾーンのページからダウンロードできます。この種のコードは有害である可能性が強く、信頼できないゾーンから発行されている場合は特に危険です。
  • [有効にする] を選択すると、オブジェクトの安全性が無視されます。信頼できないデータやスクリプトに対するオブジェクトの安全性の保証なしに、ActiveX コントロールの起動、パラメータ付きの読み込み、およびスクリプトによる制御が実行されます。この設定は、管理された安全なゾーン以外にはお勧めできません。この設定では、[スクリプトを実行しても安全だとマークされている ActiveX コントロールのスクリプトの実行] オプションを無視して、安全なコントロールに対しても、安全でないコントロールに対しても、初期化とスクリプトによる制御が実行されてしまいます。
  • [ダイアログを表示] を選択すると、オブジェクトの安全性が強制的に適用されます。ただし、信頼できないデータやスクリプトに対して ActiveX コントロールの安全性を保証できない場合でも、ユーザーはコントロールをパラメータ付きで読み込んだり、スクリプトで制御したりすることができます。
  • [無効にする] を選択すると、信頼できないデータやスクリプトに対してオブジェクトの安全性が強制的に適用されます。安全性を保証できない ActiveX コントロールは、パラメータ付きで読み込むことも、スクリプトで制御することもできません。

Java とは

Java のアクセス権

Java に関するオプションは、Microsoft Virtual Machine (Microsoft VM) をインストールした場合にのみ使用できます。

これらのオプションでは、ゾーン内での Java のダウンロードと実行を制御します。Java コントロールのダウンロード元のサイトがそのコントロールを使用しているサイトとは異なる場合は、2 つのサイトのゾーン設定のうち、制限が厳しい方の設定が適用されます。たとえば、ダウンロード可能と設定されているゾーン内の Web ページにアクセスしているが、実際にコードをダウンロードするのは、ユーザーにプロンプトを表示するように設定されている別のゾーンである場合は、後者の設定が使用されます。

各オプションでは、次の設定を行います。

  • ゾーンからダウンロードする署名済みのアプレットに対してプロンプト表示なしで許可する最高レベルのアクセス権
  • ゾーンからダウンロードする未署名のアプレットに対して許可するアクセス権
  • ゾーン内のページ上にあってアプレットを呼び出すスクリプトに許可するアクセス権

次の 5 つのオプションがあります。

  • [カスタム] では、アクセス権の設定を個別に制御します。[カスタム アクセス権] ダイアログ ボックスの [未署名] タブでは、未署名のアプレットおよび Java を呼び出すスクリプトの両方に対するアクセス権を指定します。[警告なしで許可済み] タブでは、プロンプト表示なしでアプレットに許可するアクセス権の最大値を、しきい値として指定します。
  • [安全性 - 低] を選択すると、アプレットはすべての機能を実行できます。
  • [安全性 - 中] を選択すると、アプレットはメモリ内のサンドボックスと呼ばれる領域の中で実行できますが、領域の外側ではプログラムからの呼び出しはできません。また、スクラッチ領域 (クライアント コンピュータ上の保護された安全な記憶領域) やユーザー制御のファイル入出力などの機能も有効になります。
  • [安全性 - 高] を選択すると、アプレットはそのサンドボックス内で実行できます。
  • [Java を無効にする] を選択すると、アプレットは一切実行できません。

スクリプトとは

[アクティブ スクリプト]
このオプションでは、ゾーン内のページにあるスクリプト コードを実行するかどうかを指定します。
[Java アプレットのスクリプト]
このオプションでは、ゾーン内のスクリプトで Java アプレット内のオブジェクトを操作して、ページ上のスクリプトから Java アプレットを制御できるようにするかどうかを指定します。

ダウンロードとは

[ファイルのダウンロード]
このオプションでは、このゾーンからのファイルのダウンロードを許可するかどうかを指定します。このオプションは、ファイルの実際の配布元のゾーンではなく、ダウンロード リンクが記載されているページのゾーンに対して指定します。
[フォントのダウンロード]
このオプションでは、このゾーン内のページからユーザーが HTML フォントをダウンロードできるようにするかどうかを指定します。

ユーザー認証とは

[ログオン]
HTTP の認証では、ログオン時の認証情報として、次の 4 つの設定からゾーンのセキュリティ ポリシーを指定できます。
  • [イントラネット ゾーンでのみ自動的にログオンする] － ほかのゾーンの場合は、ユーザー ID とパスワードを入力するように指示されます。ユーザーが情報を入力した後、その情報は自動的に該当セッション内で使用されます。
  • [匿名でログオンする] － HTTP 認証を無効にします。guest アカウントは、共通インターネット ファイル システム (CIFS) に対してのみ使用されます。
  • [ユーザー名とパスワードを入力してログオンする] － ユーザー ID とパスワードを入力するよう求めます。ユーザーが情報を入力した後、その情報は自動的に該当セッション内で使用されます。
  • [現在のユーザー名とパスワードで自動的にログオンする] － 入力を求めるプロンプトが表示される前に、エンド ユーザー クライアントとアプリケーション サーバー間の認証プロトコルである NTLM (Windows NT Challenge response) によって、ログオン時の認証情報が自動的に確認されます。

その他の情報

[ドメイン間でのデータ ソースのアクセス]
このオプションでは、データ ソースに接続するコンポーネントで別のサーバーに接続してデータを取得できるようにするかどうかを指定します。このオプションは、アクティブ データ オブジェクトなどのデータ バインドにのみ適用されます。次のような設定があります。
  • [有効にする] では、(ほかのドメインを含む) ほかのソースへのデータベース アクセスを許可します。
  • [ダイアログを表示する] では、ほかのドメインのソースへのデータベース アクセスを許可する前に、プロンプトが表示されます。
  • [無効にする] では、同じドメインへのページとしてのデータベース アクセスだけを許可します。
[暗号化されていないフォーム データの送信]
このオプションでは、ゾーン内の HTML ページとゾーン内のサーバーの間でフォームを双方向に送信できるようにするかどうかを指定します。Secure Sockets Layer (SSL) による暗号化で送信されたフォームは、常に許可されます。この設定は、SSL 以外のフォーム データを送信する場合にだけ影響を与えます。
[IFRAME のプログラムとファイルの起動]
このオプションでは、このゾーン内の Web ページに埋め込まれた IFRAME タグ (フォルダのディレクトリを含むタグ) からユーザーがアプリケーションやファイルを起動できるようにするかどうかを指定します。
[デスクトップ項目のインストール]
このオプションでは、このゾーン内の Web ページからユーザーがデスクトップ項目をインストールできるようにするかどうかを指定します。
[ファイルのドラッグ/ドロップ、またはコピー/貼り付け]
このオプションでは、このゾーン内の Web ページからユーザーがファイルをドラッグまたはコピーできるようにするかどうかを指定します。
[ソフトウェア チャンネルのアクセス許可]
次のような設定があります。
  • [安全性 - 低] を選択すると、次の操作を実行できます。
  • 電子メールによる通知
  • 自動ダウンロード
  • 自動インストール
  • [安全性 - 中] を選択すると、次の操作を実行できます。
  • 電子メールによる通知
  • 自動ダウンロード
  • [安全性 - 高] を選択すると、
  • ソフトウェアの配布機能はすべて実行できなくなります。

Cookie とは

[セッションごとの Cookie の使用許可 (保存なし)]
ユーザーがサイトにアクセスしたときに Web サイトで使用される Cookie (ユーザーの情報が格納されたテキスト ファイル) の設定を指定します。たとえば、この設定により、ユーザーがオンライン ショッピングをしている間、"仮想ショッピング カート" を作成できるかどうかが決定されます。セッションごとの Cookie は、セッションが終了するとハード ディスクから削除されます。

次のような設定があります。

  • [有効にする] を選択すると、セッションごとに Cookie が自動的に作成されます。
  • [ダイアログを表示する] を選択すると、セッションごとの Cookie を作成する前にプロンプトが表示されます。
  • [無効にする] を選択すると、セッションごとの Cookie の作成が禁止されます。セッションごとの Cookie を無効にすると、正しく動作しなくなる Web サイトがあります。
[コンピュータに保存されている Cookie の使用許可]
ユーザーのハード ディスク上に保存した Cookie の設定を、今後のセッションに使えるようにするかどうかを指定します。たとえば、この設定により、ユーザーの名前やこれまでに選択した項目が保存され、ユーザーが次にそのサイトにアクセスしたときに、保存された情報が反映されます。

次のような設定があります。

  • [有効にする] を選択すると、永続的な Cookie が自動的に作成されます。
  • [ダイアログを表示する] を選択すると、永続的な Cookie を作成する前にプロンプトが表示されます。
  • [無効にする] を選択すると、永続的な Cookie の作成が禁止されます。永続的な Cookie を無効にすると、ユーザーが同じサイトにもう一度アクセスしたときにも、それまでの設定を反映しないWeb サイトがあります。

構成できないセキュリティ オプション

次のオプションは固定であり、ユーザーが設定することはできません。これらのオプションは、ゾーンのセキュリティ レベル (高、中、中低、低) に影響されません。

[Web 表示フォルダからの起動]
このオプションでは、Web ページとして表示されるフォルダからユーザーがプログラムやファイルを起動できるようにするかどうかを指定します。この設定は、Windows 98 ユーザー、および Internet Explorer 4 からアップグレードして Windows デスクトップのアップデートを使用しているユーザーに適用されます。この設定は、フォルダ自体のゾーンではなく、カスタム Web コンテンツによって決定されます。
マイ コンピュータ | ローカル イントラネット | 信頼済みサイト | インターネット | 制限付きサイト
使用 | 使用 | 使用 | プロンプト | プロンプト


ActiveX コントロールの管理

IEAK 5 では、特定のゾーンでどの ActiveX コントロールを実行可能にするかを管理者が指定できるようになりました。この機能により、ActiveX コントロールの使用を効果的に制御して高いセキュリティを確保するには、次の 2 つの方法があります。

方法 1 : インターネット上の ActiveX コントロールの使用を制限する

多くの組織では、ローカル イントラネット上では ActiveX コントロールを多用していても、ファイヤウォールの外側 (インターネット ゾーン内) での ActiveX コントロールの使用に対しては制限を設けています。これは、ローカル イントラネット上では、コントロールは悪用されないという前提でコンテンツを作成できますが、インターネット上の Web ページではこの前提は成立しないからです。管理者は、インターネット上での使用を認可する一般的なコントロールを指定することにより、コントロールを使用するサイトをサポートしながら、そのゾーン内でその他のコントロールが不適切に使用されるのを防ぐことができます。

たとえば、管理者としては、ActiveX コントロールの使用を制限しながら、ビジネス パートナーやサービス プロバイダのサイトなど、重要なインターネット サイトについては ActiveX コントロールの使用を許可することができます。この場合、まず最初に目的のサイトにアクセスし、[Windows] フォルダ内の [Downloaded Program Files] フォルダに新たに追加されたエントリを調べることにより、そのサイトで使用している ActiveX コントロールを特定します。次に、このトピックの最後に示す手順に従って、それらのコントロールを管理者認可コントロールとして指定します。

このように構成すると、サイト上では管理者認可コントロールだけが実行できるようになります。イントラネット用のコントロールなど、管理者認可コントロール以外のコントロールをインターネット上で使用することはできなくなります。

方法 2 : 特定の ActiveX コントロールだけを使用できるように制限する

認可する ActiveX コントロールを列挙し、それらのコントロールだけをブラウザから実行できるように設定すると、ActiveX コントロールの使用をさらに厳密に制御できます。ただし、この方法では、使用を許可するコントロールをすべて具体的に列挙する必要があるため、比較的少数のコントロールに対して使用を許可する場合に適しています。

どのコントロールを任意のサイトで使用できるようにするかを決定します。これらのコントロールの使用を許可するサイトが含まれているゾーンについては、このトピックの最後に示す手順に従って、それらのコントロールを管理者認可コントロールに指定します。これらのコントロールの使用を禁止するサイトが含まれているゾーンについては、[ActiveX コントロールとプラグインの実行] の [無効にする] を選択します。これにより、指定したコントロールだけが、指定したゾーンの Web ページ上でのみ実行できるようになります。

ActiveX コントロールの選択

IEAK に付属している Axaa.adm ファイル (ActiveX コントロール管理者認可ファイル) には、代表的な ActiveX コントロールのリストが示されています。これは、推薦コントロールのリストではなく、あくまで Web 上でよく使われている ActiveX コントロールのリストです。これらのコントロールのうち、どのコントロールを実際に組織内で使用するかは、管理者が決定します。このファイルは、必要に応じて編集したり、新しいコントロールを追加したりできます。既定では、どのコントロールも認可コントロールとして指定されていません。ユーザーが Internet Explorerをインストールした後で、新しいコントロールを追加する場合は、自動構成を使用します。

管理者レベルのコントロールを指定するには

使用されている ActiveX コントロールを管理者認可コントロールに指定する場合、またはどのコントロールを認可するかを指定する場合には、次の操作を行います。

  1. [IEAK] フォルダの\Policies\<言語> サブフォルダにある Axaa.adm ファイルを開き、ActiveX コントロールの設定を調べます。このリストに、組織で作成したコントロールなどの新しいコントロールを追加するには、テキスト エディタを使って Axaa.adm ファイルを編集します。

    元の設定に戻す必要が生じる可能性もあるため、このファイルはバックアップしておくことをお勧めします。

  2. Internet Explorer 6 カスタマイズ ウィザードの [セキュリティとプライバシーの設定] ページで、[現行のセキュリティ ゾーンとプライバシーの設定をインポートする] をクリックし、[設定の変更] をクリックします。
  3. ActiveX コントロールの管理対象となるコンテンツ ゾーンを選択し、[レベルのカスタマイズ] をクリックします。
  4. [ActiveX コントロールとプラグインの実行] で [管理者の許可済み] をクリックします。
  5. 管理対象のゾーンをすべてセットアップし終えるまで、最後の 2 つの手順を繰り返します。
  6. Internet Explorer 6 カスタマイズ ウィザードの段階 5 の [ポリシーおよび制限] ページでカテゴリをクリックして展開し、認可するコントロールのチェック ボックスをオンにします。


プログラムへの署名

IEAK を使って、カスタム パッケージにデジタル署名を施すことができます。 デジタル署名は、プログラムの発行元を明らかにし、プログラムが改ざんされていないことを確認するものです。 カスタム ブラウザ パッケージやカスタム プログラムにはデジタル署名を施し、ユーザーがカスタム ブラウザをインストールするときに警告を受けないようにする必要があります。

ただし、最初に、ファイルにデジタル署名を施すためのデジタル証明書を取得する必要があります。Internet Explorer 6 カスタマイズ ウィザードの実行中に証明書の保存場所を指定すると、パッケージの作成時にファイルが自動的に署名されます。デジタル証明書の取得については、次のセクション「デジタル証明書の取得方法」を参照してください。

インターネット経由でカスタム パッケージを配布する場合は、IEAK を使用して、作成されるカスタム キャビネット (.cab) ファイルにデジタル署名を施してください。イントラネット経由でカスタム パッケージを配布する場合は、カスタム パッケージにデジタル署名を施すか、またはローカル イントラネット ゾーンのセキュリティ レベルを低に設定してください。既定のセキュリティ設定をイントラネットに適用している場合は、署名なしのプログラムやコードをユーザーがダウンロードすることはできません。セキュリティ ゾーンの詳細については、「Internet Explorer のセキュリティ」を参照してください。

デジタル署名が施されるファイルは、次に示すとおりです。

ファイル名 | 機能
Branding.cab | Windows Update セットアップのブランド情報
Desktop.cab | Windows デスクトップのアップデート
Iecif.cab | どの Microsoft Internet コンポーネントが Windows Update セットアップの一部としてインストールされたかを識別する
IE6setup.exe | Windows Update セットアップ
Custom<n>.cab | システムの再起動後にインストールされたカスタム コンポーネント。各コンポーネントは、独立した番号付きの .cab ファイルにまとめられる。

Internet Explorer 6 カスタマイズ ウィザードがこれらのファイルを作成する方法を示す図解については、「IEAK でのカスタム パッケージの生成」を参照してください。

注

  • 署名されていない ActiveX コントロールおよび Java のパッケージは、ユーザーがインストールできないことがあります。
  • また、ブラウザ パッケージに入れるカスタム プログラム (.exe または .cab フォーマット) にも、すべて署名しなければなりません。
  • オンデマンドのインストール機能を使用してインターネット上のユーザーにパッケージを配布する場合は、.cab ファイルに署名を施し、.cab ファイルを格納しているサーバーが信頼できるサーバーと見なされるようにセキュリティ設定を指定する必要があります。ただし、イントラネット サイトの場合に限り、セキュリティ レベルを低に設定することもできます。この機能の詳細については、「オンデマンドのインストールの管理」を参照してください。

ネットワーク サーバーを信頼できるサーバーとして指定するには

イントラネットのセキュリティ レベルが中以上に設定されている場合は、ネットワーク サーバーを信頼できるサーバーとして指定する必要があります。それには、次の操作を行います。

  1. ウィザードの [セキュリティとプライバシーの設定] ページで、[現行のセキュリティ ゾーンの設定をインポートする] をクリックし、[設定の変更] をクリックします。
  2. [イントラネット] ゾーンを選択し、[サイト] をクリックします。
  3. [すべてのネットワーク パス (UNC) を含める] チェック ボックスをオフにし、[OK] をクリックします。
  4. [信頼済みサイト] ゾーンを選択し、[サイト] をクリックし、ダウンロード サーバーのパスを入力し、[追加] をクリックします。
  5. 信頼できるサーバーとして指定するダウンロード サーバーごとに、以上の手順を繰り返します。

デジタル証明書の取得方法

デジタル証明書は、Authenticode 技術の一部であり、プログラムの発行元を識別し、プログラムが改ざんされていないことを確認するものです。証明書は、証明機関または個別管理の認証サーバーから取得できます。証明書には、"商業用" または "個人用" があります。

Authenticode およびセキュリティの詳細については、「Microsoft Security Advisor Web サイト (http://www.microsoft.com/security/)」を参照してください。

キャビネット ファイルまたはカスタム プログラムに署名を施す方法

証明書を取得したら、コードに署名する必要があります。コードの署名用のツールは、「MSDN Online Web Workshop」に用意されています。

Microsoft Internet Client SDK には、そのほかの追加リソースがあります。ソフトウェアの発行元が作成し、暗号化と解読にペアで使用される公開キーと秘密キーを知っておくことも必要です。これらのキーは、証明機関 (CA) が証明書を要求した時点で生成されます。これらは使用するコンピュータ上に生成され、秘密キーが CA やその他の団体に送られることはありません。

証明書の期限が切れた場合の処理

証明書の期限が切れた場合は、別のセキュリティ基準が必要になります。たとえば、大学がすべての学生をデジタル ID で認証する場合、学生の卒業時に ID の期限が切れるように設定することもできます。コードに施した署名の証明書の期限が切れていると、そのコードは無効です。証明書の期限が切れた場合、ソフトウェアの発行元はコードに新しい署名を施して、そのコードの新しいバージョンを発行する必要があります。

ソフトウェアの発行元は、コードに署名を施した時点での証明書が有効であることを示すために、タイム スタンプを使用してコードに署名することもできます。この方法で署名したコードは、証明書の期限が切れた後でも有効なものとして扱われます。

Authenticode を使用してユーザーに対する表示内容を制御する方法

企業内管理者の方は、セキュリティ ゾーンや規制を事前に構成したり、証明機関をカスタマイズしたりできます。また、システム ポリシーと制限を設定して、セキュリティ設定の変更をユーザーに許可するかどうかを制御することもできます。個々の設定については、「Internet Explorer のセキュリティ オプション」を参照してください。

危険性のあるコンテンツをユーザーが表示しようとした場合は、警告をエンド ユーザーに表示することができます。また、署名のない ActiveX コントロールや Java パッケージのダウンロードをエンド ユーザーに禁止することもできます。

コードに署名を施す方法

コードに対する署名は、簡単であり、短時間で行えます。 コードに署名を施すのに、コードへの署名の技術的な詳細を知っておく必要はありません。

コードを作成してテストしたら、ソフトウェアの発行元はコード ファイルに署名を施します。発行元では、Signcode.exe などの署名プログラムを使用してコードをハッシュし、ファイルの "要約" を作成します。このプログラムは、オペレーティング システム レイヤを通じて、秘密キーで要約を暗号化し、ハッシュ アルゴリズムおよび CA による証明書の名前 (ソフトウェア発行元の名前、公開キーなどを含む) と要約を組み合わせて、署名ブロックと呼ばれる構造に格納します。次にこのプログラムは、署名ブロックをコード ファイルに埋め込み、これにより、ファイルをインターネット経由で配布する準備が整います。.cab ファイルに署名した場合は、そのキャビネット ファイルにも署名ブロックが含まれることに注意してください。

ユーザーがインターネットからファイルをダウンロードするときには、ダウンロード処理を行うアプリケーションが認証関数を呼び出します。この関数が呼び出されると、オペレーティング システムが署名ブロックを取り出して、証明書を検証した CA を特定し、公開キーを使用して要約を解読します。次に、オペレーティング システムは、署名ブロックに示されているハッシュ アルゴリズムを使用して、もう 1 つの要約を作成します。署名以後にコードが改変されていなければ、新しい要約と以前の要約が一致するはずです。2 つの要約が一致しない場合は、コードが改変されたか、公開キーと秘密キーが対応していないことになります。どちらの場合も、コードが疑わしいものと見なされ、ユーザーに警告が表示されます。


Windows 2000 および Windows XP 上での Internet Explorer の管理

グループ ポリシーを使用して、Windows 2000 および Windows XP 上の Internet Explorer を展開後にカスタマイズすることができます。たとえば、ユーザーのブラウザのホーム ページを設定したり、お気に入りのリンクをカスタマイズできます。Windows 2000 および Windows XP の管理者は、複数のサイト/ドメイン/組織にわたってユーザーの設定やコンピュータの管理ができます。

グループ ポリシーの起動方法は、管理するグループの種類によって異なります。グループ ポリシーの起動については、Windows 2000 および Windows XP のグループ ポリシー ヘルプ ファイルを参照してください。

グループ ポリシーを使って Internet Explorer をメンテナンスおよびカスタマイズするには

  1. グループ ポリシーの [ユーザーの構成] をクリックします。
  2. [Windows の設定] をクリックして [Internet Explorer のメンテナンス] をクリックします。
  3. 変更する機能のアイコンをクリックします。
  4. 管理する機能のタイトルをダブルクリックします。
  5. 設定を変更します。

注

  • IEAK プロファイル マネージャにより、ほかのプラットフォーム上で自動構成を使って Internet Explorer を管理している場合は、グループ ポリシーの設定を .ins ファイルまたはキャビネット (.cab) ファイルにエクスポートすることができます。このようにすると、Windows 2000 または Windows XP で設定を構成すれば、改めてほかのプラットフォーム用の設定を構成する必要がありません。
  • OEM Preinstallation Kit を使用している場合は、Internet Explorer 6 カスタマイズ ウィザードを使って展開前に Windows 2000 または Windows XP をカスタマイズできます。
  • Windows 2000 または Windows XP の無人セットアップを使用している場合は、IEAK プロファイル マネージャ を使ってブラウザのブランドに必要なファイルを生成できます。詳細については、Windows 2000 または Windows XP のヘルプまたはマニュアルを参照してください。

Internet Explorer のグループ ポリシーをエクスポートするには

Windows 2000 または Windows XP のグループ ポリシーを使用して、Internet Explorer のすべての設定を .ins ファイルのエクスポートすることができます。 必要に応じて、キャビネット ファイル (.cab) にもエクスポートできます。これらの設定は、他のオペレーティング システムを実行しているコンピュータの自動構成に使用できます。

Windows 2000 または Windows XP の Internet Explorer の設定をエクスポートするには

  1. グループ ポリシーの [ユーザーの構成] をクリックします。
  2. [Windows の設定] をクリックし、エクスポートする設定が含まれている Internet Explorer の画面をマウスの右ボタンでクリックします。
  3. [ブラウザの設定のエクスポート] をクリックします。
  4. 設定のエクスポート先となる .ins ファイルの名前を入力します。必要に応じて、.cab ファイルの名前も入力します。
  5. Web サーバー上のファイルの URL を入力します。

グループ ポリシーで構成できる機能

グループ ポリシーを使用して、以下をカスタマイズおよび管理できます。

  • ユーザー インターフェイスとブラウザの外観
  • ダイヤルアップやローカル エリア ネットワーク (LAN) などの接続の設定、およびユーザー エージェント文字列
  • お気に入りや検索バー、ホーム ページなどの、カスタマイズした URL
  • セキュリティ ゾーンやコンテンツの規制などの、セキュリティ設定
  • 電子メールやニュースグループの表示などに使う、インターネット関連のタスクに使用する既定のインターネット プログラム

重要

  • パッケージに構成したインストール オプションにかかわらず、Windows Update セットアップは、Windows 2000 または Windows XP オペレーティング システムを実行しているユーザーには、インストール オプションを 1 つだけ表示します。このインストール オプションには、パッケージに入れたすべてのカスタム コンポーネントと、Microsoft Internet コンポーネントのフル セットが含まれます。


オンデマンドのインストールの管理

ユーザーが Internet Explorer をインストールするときには、ハード ディスクの容量を節約したり、ダウンロードやインストールに時間がかからないように、必要なコンポーネントだけを選択できます。ただし、ユーザーが実際に Web をブラウズしていると、インストールしなかったコンポーネントが必要になることがあります。

ある Web ページを見るのに必要なコンポーネントがまだユーザーのコンピュータにインストールされていなければ、オンデマンドのインストール機能によって、それらのコンポーネントをインストールするかどうかを確認するプロンプトが表示されます。

企業内管理者やインターネット サービス プロバイダの場合は、IEAKを使ってこの機能を制御することができます。

注

  • オンデマンドのインストール機能を使用してインターネット上のユーザーにパッケージを配布する場合は、.cab ファイルに署名を施し、.cab ファイルを格納しているサーバーが信頼できるサーバーと見なされるようにセキュリティ設定を指定する必要があります。ただし、イントラネット サイトの場合に限り、セキュリティ レベルを低に設定します。詳細については、「プログラムへの署名」を参照してください。

ネットワーク サーバーを信頼できるサーバーとして指定するには

イントラネットのセキュリティ レベルを中以上に設定して、ネットワーク サーバーを信頼できるサーバーとして指定する場合は、次の操作を行ってください。

  1. ウィザードの [セキュリティとプライバシーの設定] ページで、[現行のセキュリティ ゾーンとプライバシーの設定をインポートする] をクリックし、[設定の変更] をクリックします。
  2. [イントラネット] ゾーンを選択し、[サイト] をクリックします。
  3. [すべてのネットワーク パス (UNC) を含める] チェック ボックスをオフにし、[OK] をクリックします。
  4. [信頼済みサイト] ゾーンを選択し、[サイト] をクリックし、ダウンロード サーバーのパスを入力し、[追加] をクリックします。
  5. 信頼できるサーバーとして指定するダウンロード サーバーごとに、以上の操作を繰り返します。


IEAK リファレンス

IEAK の基本的な情報については、次のトピックを参照してください。

  • Windows 2000 および Windows XP 上での Internet Explorer の管理
  • カスタム グラフィックスの作成
  • Internet Explorer のセキュリティ
  • Internet Explorer の再配布
  • バッチ モードでのセットアップの実行
  • ユーザーの定期的更新
  • Windows Update セットアップ ウィザードによる Internet Explorer およびその他のインターネット ツールのセットアップ
  • セットアップ情報ファイル (.inf) の使用
  • ファイル形式
  • 自動検索の構成
  • 検索バーと検索アシスタントのカスタマイズ

その他のリソース

最新のリソースおよび技術の更新に関しては、次の Web サイトにアクセスしてください。

  • IEAK Web サイト
  • Microsoft Security Advisor Web サイト
  • MSDN Online Web Workshop
  • Windows Update Web サイト


自動検索の構成

自動検索をカスタマイズして、ユーザーが一般的な語句を [アドレス] ボックスに入力するだけで、その語句に関連する Web サイトが表示されるようにすることができます。指定するページの URL を覚えている必要がないため、重要な情報を簡単に見つけることができます。

たとえば、ユーザーが [アドレス] ボックスに "請求書" と入力すると、そのページの URL にこの語句が含まれていない場合でも、請求書に関連する Web ページが表示されるようにすることができます。企業内管理者の場合は、以下に示す自動検索のカスタマイズ方法を参照してください。インターネット コンテンツ プロバイダまたはインターネット サービス プロバイダの場合は、電子メールで autosrch@microsoft.com まで詳細をお問い合わせください。

この機能は既にインターネットで利用できます。たとえば一般的な語句をアドレス バーに入力すると、その語句に関連する Web サイトが表示されます。語句に関連する Web サイトが複数見つかったときのように、検索結果を特定の 1 つの Web サイトに絞り込めない場合は、検索結果の先頭の Web ページが表示されます。

表示する Web サイトの URL に、検索する文字列が含まれている必要はありません。Web サイトのドメインが検索文字列と一致していても、検索結果として最適でない場合は (URL から "www." と ".com" を除いたものが検索文字列と一致する場合など)、検索結果として最も適したサイトへ自動的にリダイレクトされます。既定では、リダイレクトされるときにユーザーにメッセージが表示されます。

自動検索をセットアップするには

  1. 検索語句を条件に従ってチェックするスクリプト (.ASP) ファイルを作成し、イントラネット サーバーの次の場所へ送信します。

    http://ieautosearch/response.asp?MT=%1&srch=%2

    パラメータ %1 および %2 の説明については、下の「自動検索の URL を設定するパラメータ」を参照してください。

    Internet Information Services (IIS) を使用していない場合は、この URL をスクリプトが位置するアドレスにマップする必要があります。

  2. このオプションを Internet Explorer 6 カスタマイズ ウィザードで設定するには、段階 5 の [ポリシーおよび制限] 画面で、[インターネットの設定] をクリックし、[詳細設定] をクリックします。

    または

    このオプションをプロファイル マネージャで設定する場合は、[ポリシーおよび制限] をクリックして、[インターネットの設定] をクリックします。

  3. [詳細設定] をクリックし、[検索] の [検索プロバイダのキーワード] ボックスに「intranet」と入力します。

注

  • ポリシーと制限を使用すると、検索結果を表示せずに、ユーザーを別のサイトへ移動することができます。それには、[詳細設定] をクリックします。[検索] の [アドレス バーから検索するとき] ボックスで [最も可能性の高いサイトに移動する] を選択します。
  • 企業内管理者の場合、社内ネットワークがインターネットに接続されていない場合で、さらに検索機能をカスタマイズしていなければ、ポリシーと制限を使用して自動検索を無効にすることができます。それには、[詳細設定] をクリックします。[検索] の [アドレス バーから検索するとき] ボックスで [アドレス バーから検索しない] を選択します。

自動検索の URL を構成するパラメータ

自動検索の URL を構成するには、http://ieautosearch/response.asp?MT=%1&srch=%2 の中の、先頭にパーセント記号 (%) が付いている 2 つのパラメータを置換します。これらの 2 つの値は、URL そのものの一部である必要があります。

パラメータ | 値
%1 | ユーザーによって [アドレス] ボックスに入力された文字列。
%2 | ユーザーによって選択された検索の種類。
 | 3 | 検索結果を表示し、最も可能性の高いサイトに移動する。
 | 2 | 最も可能性の高いサイトに移動する。
 | 1 | 検索結果をメイン ウィンドウに表示する。
 | 0 | [アドレス] ボックスから検索を実行しない。

.asp AutoSearch スクリプトの例

<%@ Language=VBScript %>

<%
' search には、ユーザーがアドレス バーに入力した語句が入ります。
' "go" や
' "find" や、スペースを表す
' "+" などの区切り文字は入りません。
' ユーザーが
' 「Apple pie」 と入力した場合、search = "Apple pie" です。
' ユーザーが
' 「find Apple pie」 と入力した場合、search = "Apple pie" です。
search = Request.QueryString("MT")
search = UCase(search)
searchOption = Request.QueryString("srch")

' このシンプルな if/then/else は、
' ユーザーが入力した語句に基づき、
' ブラウザをサイトに
' リダイレクトします。
' たとえば、expense report は、
' expense report (支出報告書) を記入するためのページに移動します。
if (search = "NEW HIRE") then
Response.Redirect("http://admin/hr/newhireforms.htm")
elseif (search = "LIBRARY CATALOG") then
Response.Redirect("http://library/catalog")
elseif (search = "EXPENSE REPORT") then
Response.Redirect("http://expense")
elseif (search = "LUNCH MENU") then
Response.Redirect("http://cafe/menu/")
else
' 一致するものがない場合は、
' 既定の IE 自動検索サーバーを使用します。
Response.Redirect("http://auto.search.msn.com/response.asp?MT="
+ search + "&srch=" + searchOption +
"&prov=&utf8")
end if

%>


検索バーと検索アシスタントのカスタマイズ

検索バーを使用すると、ユーザーは検索を実行し、検索結果を表示することができます。検索バーは、ユーザーが [検索] ボタンをクリックすると、ブラウザの左側に表示されます。

Microsoft Windows の検索アシスタントは検索バーで開き、統合化された単一の検索インターフェイスを使って、さまざまな種類の情報を検索できます。検索アシスタントにはラジオ ボタンが用意されており、使用する検索エンジンを指定しなくても、検索したい情報を指定するだけで検索を開始できます。

ユーザーは、検索バーで 1 つの検索エンジンだけを使用するように、Internet Explorer をカスタマイズすることができます。ISP または企業内管理者は、JScript (ECMA 262 言語仕様互換)、Visual Basic Scripting Edition (VBScript)、ActiveX コントロール、ダイナミック HTML、フレームセット、カスケード スタイル シート (CSS)、および Internet Explorer ブラウザと互換性のあるその他のテクノロジを使用して、ユーザーの代わりに社内の要求に応じて検索バーをカスタマイズすることができます。Internet Explorer 6 カスタマイズ ウィザードの段階 4 の [重要な URL] 画面で、検索バーの URL を指定します。

通常、検索結果は検索バーに表示されます。どのような検索サービスでも、ユーザーにとって利用しやすい状態で検索結果を提供することが不可欠です。検索バーには、要約、URL、ファイル サイズなどの詳細情報を保存する機能があります。この情報は、検索結果にマウス ポインタを合わせたときに表示される、ツールのヒントとして表示されます。ツールのヒントにより、シンプルな検索結果ページを維持しながら、ユーザーに対して詳細情報を表示できるようになります。

検索バーのユーザー インターフェイスをカスタマイズするためのガイドライン

検索バーを独自に設計する場合は、次のガイドラインに従ってください。

  • 検索結果が表示されるページでは常に、別の検索を実行できなければなりません。検索条件を変更したり、検索を実行したりするためのボタンは、コンテンツ領域の上 20% の領域内に表示します。
  • ページは、幅 200 ピクセルの検索バーに収まるようにします。テーブルなどのレイアウト用の HTML 要素を使う場合は、この幅に収まるように注意してください。そうしないと、水平スクロール バーが表示されてコンテンツの表示領域が狭くなり、ユーザーの手間が増えます。ツールのヒントを使えば、要約やメタ情報を表示でき、余分な領域が不要です。
  • ダイナミック HTML、ActiveX テクノロジ、Java、およびカスケード スタイル シートを使えば、動的な視覚効果が得られ、マルチメディア性が向上します。検索バー領域の広さには制限がある点に注意してください。
  • 検索バーの既定のサイズは、幅が 200 ピクセル、高さがブラウザ ウィンドウの高さ (430 ピクセル) です。この領域には、必要に応じて、検索情報のほかに、広告やブランドを含めることができます。ユーザーは、この領域のサイズを変更することができます。
  • 検索バーはコンパクトなサイズで表示されるので、ユーザー インターフェイスを優先して設計してください。基本的な指針は、ユーザーを視覚的に混乱させないように必要な情報をわかりやすく表示することです。通常、インターフェイスはページの上から下に、次の順序で構成します。
    • ブランド
    • 検索条件の絞り込みが可能な検索条件フィールド
    • 検索結果
    • 広告やその他のサービス

    ユーザーがスクロールしなくても検索結果を表示できるように、広告はページの下の方に配置することをお勧めします。

  • スクロールが必要になる場合でも、実際の検索結果 (カテゴリ結果ではない) の多くはスクロールなしで表示されるようにしてください。
  • 通常、検索バーには、検索結果 ("ヒット") へのリンクを表示します。ユーザーがこれらのリンクをクリックしたときに、対応する Web ページがブラウザのメイン ウィンドウに表示されるようにしてください。検索バーには、[戻る] ボタンも [進む] ボタンも表示されないため、検索バー内に Web ページを直接表示することは避けてください。

検索アシスタントのカスタマイズ方法

検索アシスタントは、特定の検索ニーズに応じてカスタマイズできます。たとえば、検索結果に関する補足情報をツールのヒントとして保存したり、検索結果を特定の Web ページで強調表示することができます。

検索結果の強調表示

NavigateAndFind 機能を使用すると、特定の Web ページから語句を簡単に検索できます。この機能は、特定の Web ページを読み込み、ドキュメントをスキャンして検索文字列と一致する文字列を探します。一致する文字列が見つかると、ドキュメント内のその文字列が強調表示されます。

例

次の例では、Microsoft Web サイトを開いて、"Microsoft Corporation" という語句を検索します。

window.external.NavigateAndFind("http://www.microsoft.com","Microsoft Corporation");

ツールのヒントと要約

Internet Explorer では、ブラウザ ウィンドウ内での表示サイズをできるだけ小さく抑えながら検索結果をわかりやすく表示できるように、ツールのヒントに表示するリンクに関する特定の情報を指定することができます。この機能を使用するには、HTML アンカー タグの TITLE= 属性を定義します。

例

リンクについての情報をツールのヒントとして表示する例を次に示します。

<A HREF="http://www.adventure-works.com/" TITLE="毎時更新される
スポーツと得点の最新情報勝利選手インタビュー。">スポーツ最新情報。</A>

次のリンクをポイントして、どのように表示されるかを確認してください。スポーツ最新情報

ツールのヒント内での改行

ツールのヒントではテキストが 3 インチごとに自動改行され、ヒントには少なくとも 1 段落分のテキストを含めることができます。ただし、ヒントの文字列の長さは1024 文字 (1 バイト文字の場合) 以内に制限されます。予約文字の &#10; (改行文字) と &#13 (復帰文字) を使用して、ヒントとして表示する要約の文字列を強制改行して行を送ったり、&#09 でタブ スペースを挿入することもできます。

例

ツールのヒントに強制改行や行送りを挿入する例を次に示します。

<A HREF="http://www.microsoft.com"
TITLE="1 行目の文字列&#10;&#13;
2 行目の文字列&#10;
&#09;3 行目の文字列&#10;
&#09;4 行目の文字列">
複数行のヒントの使用例</A>

次のリンクをポイントして、どのように表示されるかを確認してください。 複数行のヒントの使用例

スクリプトおよびダイナミック HTML の詳細については、「MSDN Online Web Workshop」を参照してください。


カスタム グラフィックスの作成

ロゴ用のグラフィックスは、使用許諾契約で許可されている場合にのみカスタマイズできます。ロゴ用のグラフィックスを準備する前に、使用許諾契約の内容をご確認ください。

Windows Update セットアップ

グラフィックス | サイズと種類 | その他
左側の縦長のグラフィックス | 162 × 312 ピクセル、256 色の .bmp ファイル | Windows Update セットアップ ウィザードの先頭のページに表示される縦長のアイコン。
上部の横長のグラフィックス | 496 × 56 ピクセル、256 色の .bmp ファイル | ウィザードの 2 番目以降のすべてのページに表示される横長のアイコン。ページの上側に表示される横長のバナー グラフィックスは、ユーザー インターフェイスの文字列が読めるように、"ウォーターマーク" のような明るい色にする必要があります。

Internet Explorer ブラウザ

カスタマイズしたブラウザにさまざまなグラフィックスがどのように表示されるかについては、「カスタマイズの仕組み」を参照してください。

グラフィックス | サイズと種類 | その他
静止ロゴ 38 × 38 ピクセルおよび
22 × 22 ピクセルの .bmp ファイル 		256 色のビットマップを 2 つ (38 × 38 ピクセルが 1 個、22 × 22 ピクセルが 1 個) 作成します。ファイルはカスタム ビットマップ フォルダ (CIE\Bitmaps) に保存します。動画ロゴの先頭フレームは、ブラウザがアクティブでないとき、静止ロゴとして表示されます。
動画ロゴ 38 × 38 ピクセルおよび
22 × 22 ピクセルの .bmp ファイル (動画フレームごと) 		動画フレームごとに、256 色のビットマップを 2 つ (38 × 38 ピクセルが 1 個、22 × 22 ピクセルが 1 個) 作成します。ファイルはカスタム ビットマップ フォルダ (CIE\Bitmaps) に保存します。動画ロゴの先頭フレームは、ブラウザがアクティブでないとき、静止ロゴとして表示されます。

IEAK の動画ビットマップ用のツールを使用すると、正しい形式の一連のビットマップから、動画のロゴを作成することができます。動画のロゴには、Internet Explorer の動画に関する規則に従った、動画セル イメージを格納する必要があります。

Intenet Explorer のロゴの動画規則

  • 1 ～ 4 のセルは、リードインのセルであり、Internet Explorer が Web の閲覧を開始するときに表示されます。
  • 5 ～ X (X はセルの総数) のセルは、閲覧の処理が完了するまでループして表示されます。
ツール バーの背景 | サイズの規定はありません。 | 背景は、サイズをツール バーのサイズに一致させ、黒色の文字列を十分に表示できるような明るさでなければなりません。
ブラウザ ツール バー ボタン | アクティブな状態を表すカラー画像と既定の状態を表すグレースケール画像の 2 つのアイコン ファイル | 詳細については、「Internet Explorer のツール バー アイコンの設計」を参照してください。
[お気に入り] の一覧用のアイコン | カスタマイズする各項目ごとの 16 × 16 ピクセルの .bmp ファイル
自動実行画面 (カスタム パッケージを CD-ROM で配布する場合) | ユーザーが CD-ROM を挿入したときに 540 × 357 ピクセルのビットマップを表示します。 | 自動実行画面を作成する前に、24 ビット画像を 256 色パレットに変換する必要があります。詳細については、「自動実行画面のビットマップの作成」を参照してください。

インターネット接続ウィザード、インターネット サインアップ

グラフィックス | サイズと種類
インターネット接続ウィザードの右上隅に表示される、先頭の画像 | 49 × 49 ピクセルの .bmp ファイル
インターネット接続ウィザードの画面の左側に表示される、縦長の画像 | 164 × 458 ピクセルの .bmp ファイル

注

  • インターネット接続ウィザードではサーバーなしのサインアップを利用できません。

Windows アドレス帳のディレクトリ サービス (Outlook Express で使用)

サイズと種類 | その他
134 × 38 ピクセルの .bmp ファイル | Windows の 16 色のパレットを使用します。


動画ビットマップ用のツール

ロゴ用のグラフィックスは、使用許諾契約で許可されている場合にのみ合法的にカスタマイズできます。ロゴ用のグラフィックスを準備する前に、使用許諾契約の内容をご確認ください。

Internet Explorer 管理者キットには、ブラウザで使用するカスタム動画ビットマップを簡単に作成するための次の 2 つのツールが入っています。

  • Animated Bitmap Creator を使用すると、通し番号の付いた一連のビットマップから、適切なフォーマットの動画用の単一のビットマップを作成できます。
  • Animated Bitmap Previewer を使用すると、ビットマップの動画をプレビューできます。フォーマットが正しいビットマップなら、どれでもこのツールで表示できます。

ビットマップのサイズとフォーマットは、正しくなければなりません。詳細については、「カスタム グラフィックスの作成」を参照してください。

注

  • これら 2 つのツールは、管理者の便宜を図るために提供しているものであって、サポートの対象となる Microsoft の製品として配布するものではありません。これら 2 つのツールは、\<IEAK プログラム フォルダ>\Toolkit\Graphics\Tools フォルダにあります。

Animated Bitmap Creator (Makebmp.exe)

このツールを実行するには、MS-DOS のコマンド プロンプトで次のように入力します。

makebmp basename numfiles outputname

構文の要素 | 意味
makebmp | ツールの名前
basename | すべてのファイルに共通のルート ファイル名 (通し番号または拡張子 .bmp を除く)
numfiles | 動画ファイルに付けられるビットマップの通し番号
outputname | 出力ファイル名 (拡張子 .bmp を含める)

例

Bitmap0.bmp ～ Bitmap19.bmp を使用して動画ビットマップを作成するには、次のように入力します。

makebmp bitmap 20 final.bmp

注

  • ビットマップ ファイルの名前には、0 から始まる通し番号を付けます。たとえば、Iebmp0.bmp、Iebmp1.bmp、Iebmp2.bmp、...Iebmp24.bmp のようなファイル名にします。これら 25 個のファイルのベース名は、Iebmp になります。

Animated Bitmap Previewer (Animbmp.exe)

このプレビュー用のプログラムは、MS-DOS のコマンド プロンプトか Windows のエクスプローラから起動します。Animbmp.exe の起動後、動画ビットマップをプレビューするには 2 つの方法があります。ウィンドウにファイルをドラッグ アンド ドロップするか、[ファイル] メニューの [開く] をクリックしてファイルを選択します。プレビューの開始時にのみリードイン フレームが表示され、それ以降はビットマップが連続してプレビュー表示されます。


自動実行画面のビットマップの作成

次に示す手順は、24 ビットの RGB ビットマップ ファイルの場合です。それ以外の場合は、まず 24 ビットの RGB ビットマップに変換する必要があります。

  1. 256 色のビットマップ イメージ (540 x 357 ピクセル) を作成します。

    このビットマップは、製品を紹介するためのものであり、2 つのボタンのラベルを指定する必要があります。1 つは Internet Explorer をインストールするためのボタン、もう 1 つは詳細情報を表示するためのボタンです。

  2. 好みのグラフィック プログラムを使用して、パレット用の作業ファイルを作成します。それには、背景とボタンのファイルを 1 つのファイルに貼り付けます。2 つのファイルを重ねず、横に並べるようにしてください。
  3. このファイルを Palette.bmp という名前で保存します。

注

  • ダイアログ ボックスのサイズは、ビットマップのサイズに合わせて自動的に調整されるので、ビットマップのサイズは重要です。ビットマップの幅が狭すぎると、ダイアログ ボックス内のテキストの一部が表示されなくなることがあります。


Internet Explorer のツール バー アイコンの設計

ツール バー アイコンを作成するには、ツール バーの 2 つの状態 (既定の状態のグレースケール画像およびユーザーがマウスでポイントしたときのアクティブ状態のカラー画像) に合わせて、2 つのサイズおよび 2 つの色深度の画像を用意する必要があります。

画像を作成するには

  1. グラフィック ソフトウェアで 16 色または 256 色の画像を 2 つ作成し、それらを別々のファイルに保存します。
  2. 各ファイルに適切なパレット (Windows 標準の 16 色パレットまたはハーフトーン パレット) を適用します。透明色を示すために、特定の色を予約します。
  3. 各ファイルを .bmp 形式で保存します。

次に、必要な画像の概要を示します。

アイコンの状態 サイズ (ピクセル単位) 色深度/パレット 枠線 外観 例
アクティブ 20 × 20 ピクセル Windows 標準 256 色ハーフトーン パレット アイコン スタイルの枠線 : 上部と左側はカラー、下部と右側は黒。
  • カラー画像
  • 影付けを強めにし、16 色の画像より視覚的に奥行きをもたせる。
  • 左上からの光源で、適宜、影を付ける。
 アクティブな状態 : 256 色、20 × 20 ピクセル
20 × 20 ピクセル Windows 標準 16 色パレット 黒 (枠線によってアイコンが見にくくなる場合は除く)。
  • カラー画像
  • 軽い影付け。平坦な外観。
 アクティブな状態 : 16 色、20 × 20 ピクセル
16 × 16 ピクセル Windows 標準 16 色パレット 黒 (枠線によってアイコンが見にくくなる場合は除く)。
  • カラー画像
  • 軽い影付け。平坦な外観。
 アクティブな状態 : 16 色、16 × 16 ピクセル
既定 20 × 20 ピクセル Windows 標準 256 色ハーフトーン パレット アイコン スタイルの枠線 : 上部と左側にグレー トーン、下部と右側に黒。
  • グレースケール画像
  • 影付けを強めにし、16 色の画像より視覚的に奥行きをもたせる。
  • 左上からの光源で、適宜、影を付ける。
 既定の状態 : 256 色、20 × 20 ピクセル
20 × 20 ピクセル Windows 標準 16 色パレット 黒 (枠線によってアイコンが見にくくなる場合は除く)。
  • グレースケール画像
  • 軽い影付け。平坦な外観。
 既定の状態 : 16 色、20 × 20 ピクセル
16 × 16 ピクセル Windows 標準 16 色パレット 黒 (枠線によってアイコンが見にくくなる場合は除く)。
  • グレースケール画像
  • 軽い影付け。平坦な外観。
 既定の状態 : 16 色、16 × 16 ピクセル

既定の画像とアクティブの状態の画像が交互に切り替わったときに自然に見えることを確認します。フォト レタッチ ソフトウェアなどで既定の画像とアクティブな状態の画像を別のレイヤーに置き、各レイヤーを交互に表示すると、これを簡単にテストできます。

ビットマップ画像をアイコンに変更するには

アイコンごとに、.ico ファイルを 2 つずつ作成する必要があります。

  • 一方の .ico ファイルには、特定のサイズおよび色深度のアクティブな状態の画像 (カラー画像) を格納します。
  • もう一方の .ico ファイルには、特定のサイズおよび色深度の既定の状態の画像 (グレースケール画像) を格納します。

アイコンの描画にはグラフィック ソフトウェアを使用し、.ico ファイルの作成には Microsoft Visual C++ Development Studio などの開発環境を使用することをお勧めします。

例

[ホーム] ボタンの 2 つのアイコン ファイルには、次の画像が格納されています。

アクティブな状態 | 既定の状態
アクティブな状態のアイコン | 既定の状態のアイコン

Visual C++ でアイコン ファイルを作成するには

  1. 各 .bmp ファイルを開きます。
  2. [ファイル] メニューの [新規作成] をクリックし、[アイコン] をクリックします。 既定では、標準の 32 × 32 ピクセルのデバイス画像がアイコン ウィンドウに表示されます。
  3. アイコン ウィンドウで [新規デバイス イメージ (ins)] をクリックします。[カスタム] をクリックして、次のデバイス画像を作成します。
    • 22 × 20 ピクセルの 16 色画像
    • 22 × 20 ピクセルの 256 色画像
    • 18 × 16 ピクセルの 16 色画像

    注

    • デバイス画像は、元の画像よりも 2 ピクセル分、幅が広くなっています。デバイス画像の領域内で画像を中央に揃えてください。
  4. 既定の 32 × 32 ピクセルのデバイス画像を削除します。
  5. .bmp ファイルからカラー画像をコピーして、適切なサイズおよび色深度のデバイス画像に貼り付けます。
  6. 背景を透明にするには、カラー パレットから透明色を選択して、各画像の背景の透明にする部分を塗りつぶします。
  7. 画像を .ico ファイルとして保存します。

同様に、既定の状態 (グレースケール画像) の .ico ファイルを作成します。


ユーザー エージェント文字列の挿入

コンテンツに対するアクセス回数および Web ブラウザのタイプといったサイトの統計情報を監視している会社もあります。ユーザー エージェント文字列を使用すれば、ブラウザの種類が簡単にわかります。

ブラウザの統計情報を収集する場合、ユーザー エージェント文字列を挿入しておけば、カスタム ブラウザの使用状況を監視することができます。Internet Explorer 6 カスタマイズ ウィザードでは、ユーザー エージェント文字列の末尾に文字列を追加して、ユーザー エージェント文字列をカスタマイズできます。

カスタマイズした文字列は、ユーザー エージェント文字列が含まれるすべての統計情報の中で検出できます。ただし、そのカスタマイズした文字列は、統計情報を監視しているほかの会社からも見ることができます。そのため、他人に見せたくないような文字列は使用しないでください。

例

ユーザー エージェント文字列の例を、次に示します。

Mozilla/4.0(compatible; MSIE 6; WindowsNT; YourCustomString)

注

  • ユーザー エージェント文字列の推奨サイズは、最大 200 文字です。


バッチ モードでのセットアップの実行

Windows Update セットアップの機能と操作性は、Internet Explorer 6 カスタマイズ ウィザードを使用して制御できます。バッチ ファイル、コマンド ライン スイッチ、またはこれらの組み合わせを使用することで、セットアップ処理をさらに詳細に制御できます。これらの方法は、Internet Explorer を単体でインストールする場合と、Microsoft Office と共にインストールする場合のどちらでも使用できます。

ほとんどの場合は、バッチ ファイルを使用した方が、個々のコンポーネントのインストールを詳細に制御でき、また、作業も簡単で済みます。コマンド ライン スイッチは、下位互換性の確保とカスタム ソリューションのサポートのために用意されています。

バッチ ファイルの作成

バッチ ファイルを作成するには、Windows のメモ帳などのテキスト エディタを使用して Iebatch.txt という名前のファイルを作成します。コマンド ラインでバッチ ファイルを呼び出すようにする場合は、コマンド ラインの構文で正しいファイル名を参照するなら、バッチ ファイルに違う名前を付けることができます。詳細については、「バッチ ファイルの構文」を参照してください。使用例については、「セットアップ バッチ ファイルのサンプル」を参照してください。

バッチ ファイルを使ったInternet Explorer の配布

インターネットまたはイントラネットを経由して Internet Explorer を配布する場合は、Internet Explorer のダウンロード用のサイトにバッチ ファイルを置くことができます。Internet Explorer を CD-ROM やフロッピー ディスクなどのほかのメディアで配布する場合は、バッチ ファイルをディスクに追加できます。バッチ ファイルは Ie6setup.exe ファイルと同じフォルダに置いてください。

IEAK パッケージを作成した時点でバッチ ファイルが用意できていない場合、または、カスタム IEAK パッケージで指定したセットアップ オプションを一時的または恒久的に変更する場合は、バッチ ファイルを別の場所に置くことができます。

コマンド ライン スイッチを使ったセットアップの実行

製品に Internet Explorer および関連するコンポーネントをバンドルしている場合は、一般的にコマンド ライン スイッチを使って、IEAK パッケージをセットアップ プログラムの一部としてインストールします。コマンド ライン スイッチを使ってセットアップの設定を変更する場合は、IEAK に付属する IExpress ウィザードを使うか、または独自のプログラムを使って、セットアップ ファイルをパッケージにまとめることができます。

詳細については、「Internet Explorer のバッチ モード セットアップ スイッチ」および「IExpress のバッチ モード セットアップ スイッチ」を参照してください。

コマンド ラインまたはバッチ ファイルからセットアップを実行する理由

次のような場合は、Windows Update セットアップに追加のコントロールを配置することができます。

ハンド フリー インストールを実装する場合

企業内管理者の方の場合は、就業時間後にユーザーに Internet Explorer を配布したいこともあります。IEAK では、ユーザーの操作をほとんど必要としない "サイレント" インストールを設定できますが、この処理をより詳細に制御することもできます。ユーザーに対してどのメッセージを表示するか、およびセットアップの終了時にコンピュータを再起動させるかどうかは、バッチ テキスト ファイルまたはコマンド ライン スイッチで指定できます。

Internet Explorer を再配布する場合

独立したソフトウェア ベンダの場合は、アプリケーション内で Internet Explorer をホストとして動作させたり、アイコンやブラウザ インターフェイスなしで Internet Explorer をインストールすることがあります。このような場合は、Redist オプションまたは /X スイッチを指定したバッチ ファイルを使用します。詳細については、「Internet Explorer のバッチ モード セットアップ スイッチ」を参照してください。

特定のコンポーネントのインストールをより詳細に制御する場合

バッチ ファイルを使用すると、IEAK パッケージにコンポーネントが含まれているかどうかにかかわらず、コンポーネントをインストールして制御できます。また、ユーザーが選択できるセットアップのタイプ ([標準] や [最小] など) を制限することもできます。特定のコンポーネントを指定するには、NetMeeting などの ComponentID 文字列を使用します。ComponentID 文字列に関する情報については、Iesetup.cif ファイルを参照してください。

IEAK パッケージを作成し直さずにセットアップ オプションを変更する場合

IEAK パッケージを作成し直さずに Internet Explorer を特定の方法で設定する必要がある場合があります。バッチ ファイルまたはスイッチを使用すると、パッケージを作成したときに Internet Explorer 6 カスタマイズ ウィザードで指定した設定を変更できます。


バッチ ファイルの構文

バッチ ファイルを使用すると、セットアップ処理と Internet Explorer およびインターネット ツール用の Windows Update セットアップ ウィザードをより詳細に制御できます。このバッチ ファイルのセクションとエントリは、次の表に示すとおりです。バッチ ファイルの使用法の詳細については、「バッチ モードでのセットアップの実行」を参照してください。完全なサンプル ファイルについては、「セットアップ バッチ ファイルのサンプル」を参照してください。

バッチ ファイルのセクション

[Options]

[Welcome]

[SetupChoice]

[Custom]

[Download]

[DownloadSite]

[PrepareSetup]

[Diskspace]

[Progress]

[RebootPartial]

[Finish]

[Reboot]

[Upgrade]

[Options]
SaveUninstallInfo=[0,1]
ExtraSection=
Quiet=[A,C,U]
ShowErrors=[0,1]
Display=[0,1]

このセクションのエントリ | [説明]
SaveUninstallInfo=[0,1] コンポーネントのアンインストールに関する情報を保存するかどうかを指定します。
  • 0 = アンインストール用の情報を保存しません。このスイッチを使用すると、コントロール パネルから Internet Explorer をアンインストールできなくなります。
  • 1 (既定値) = アンインストール用の情報を保存します。
ExtraSection=section1[,section2,...] | Iesetup.inf ファイル内のセクションを実行します。複数のセクションを指定する場合は、「section1,section2,section3」のようにカンマで区切ってください。
Quiet=[A,C,U] サイレント モードを示します。このモードでは、インストールの実行中に一部のプロンプトだけを表示するか、プロンプトを一切表示しません。
  • A = 完全サイレント モードを指定します。このモードでは、セットアップ画面は表示されず、また、エラー チェックも行われません。
  • C = 進捗状況ページの [キャンセル] ボタンを無効にします。
  • U = 特定の情報 (ダウンロード場所など) をユーザーに指定させるときにのみセットアップ画面を表示します。
ShowErrors=[0,1] セットアップのエラー メッセージをユーザーのコンピュータに表示するかどうかを指定します。
  • 0 = セットアップのエラー メッセージを表示しません。各メッセージに対して既定の処理が自動的に実行されます。
  • 1 (既定値) = セットアップのエラー メッセージを表示します。
先頭へ戻る

[Welcome]
Display=[0,1]

このセクションのエントリ [説明]
Display=[0,1] セットアップの最初の画面をユーザーの コンピュータに表示するかどうかを指定します。
  • 0 = セットアップの最初の画面を表示しません。
  • 1 (既定値) = セットアップの最初の画面を表示します。
先頭へ戻る

[SetupChoice]
Display=[0,1]
SetupChoice=[0,1]

このセクションのエントリ [説明]
Display=[0,1] カスタマイズ ウィザードでその後ページを表示するかどうかを決定する、セットアップ オプションを選択する画面をユーザーのコンピュータに表示するかどうかを指定します。
  • 0 = セットアップ タイプの選択画面をユーザーのコンピュータに表示しません。
  • 1 (既定値) = セットアップ タイプの選択画面をユーザーのコンピュータに表示します。
SetupChoice=[0,1] どのセットアップ オプションを選択するかを指定します。
  • 0 (既定値) = [今すぐインストール - 標準のコンポーネントのセットアップ] を選択します。
  • 1 = [カスタム セットアップ] を選択します。
先頭へ戻る

[Custom]
Display=[0,1]
InstallDir=foldername
InstallDirRO=[0,1]
UseInfInstallDir=[0,1]
SetupMode=[0,1,2]
SetupModeRO=[0,1]
Component=[ComponentID_1, ComponentID_2, ...]
ComponentListRO=[0,1]
DownloadOnly=[0,1]
DownloadOnlyRO=[0,1]
IECompat=[0,1]
IECompatRO=[0,1]
IECompatShow=[0,1]
ShowAdvanced=[0,1]
IEDefault=[0,1]
IEDefaultRO=[0,1]

このセクションのエントリ | [説明]
Display=[0,1] [コンポーネントのオプション] 画面をユーザーのコンピュータに表示するかどうかを指定します。この画面では、ユーザーがコンポーネントを選択でき、[詳細] をクリックして詳細なオプションを指定することもできます。
  • 0 = [コンポーネントのオプション] 画面をユーザーのコンピュータに表示しません。
  • 1 (既定値) = [コンポーネントのオプション] 画面をユーザーのコンピュータに表示します。
InstallDir=foldername | ファイルのインストール先となるフォルダを指定します。この設定を省略すると、Iesetup.inf ファイル内の現在の設定が適用されます。旧バージョンの Internet Explorer がインストールされているコンピュータでは、そのバージョンと同じフォルダに新しいバージョンがインストールされます。
InstallDirRO=[0,1] インストール先フォルダをユーザーが変更できるようにするかどうかを指定します。
  • 0 (既定値) = ユーザーがインストール先フォルダを変更できるようにします。
  • 1 = ユーザーがインストール先フォルダを変更できないようにします。
UseInfInstallDir=[0,1] Internet Explorer がインストールされたフォルダを指定します。
  • 0 (既定値) = 既定のインストール先フォルダ、または旧バージョンの Internet Explorer がインストールされているのと同じフォルダを使用します。
  • 1 = Iesetup.inf ファイルで指定されているフォルダをインストール先フォルダに使用します。
SetupMode=[0,1,2] 実行するセットアップの種類を指定します。
  • 0 = 最小インストールを選択します。
  • 1 (既定値) = 標準インストールを選択します。
  • 2 = 完全インストールを選択します。
SetupModeRO=[0,1] セットアップ タイプをユーザーが変更できるようにするかどうかを指定します。
  • 0 = ユーザーがセットアップ タイプを変更できるようにします。
  • 1 (既定値) = ユーザーがセットアップ タイプを変更できないようにします。
Component=[ComponentID1[,ComponentID2,...]] | Component= 設定に指定したコンポーネントだけをインストールするように指定します。ComponentID は、コンポーネントを特定する文字列です。対応する文字列は、Iesetup.cif ファイルのコンポーネント セクションで確認できます。 ComponentID 文字列に関する情報は、「IEAK に関する Web サイト」にも用意されています。
ComponentListRO=[0,1] セットアップ タイプで選択されるコンポーネントのほかにインストールするコンポーネントをユーザーが選択できるようにするかどうかを指定します。
  • 0 (既定値) = インストールするコンポーネントをユーザーが選択できるようにします。
  • 1 = インストールするコンポーネントをユーザーが選択できないようにします。
DownloadOnly=[0,1] Internet Explorer をダウンロードするだけか、またはダウンロード後にインストールするかどうかを指定します。
  • 0 (既定値) = ファイルをダウンロード後にインストールします。
  • 1 = ファイルのダウンロードだけを行い、インストールは行いません。
DownloadOnlyRO=[0,1] ファイルをダウンロード後にインストールする設定をユーザーが変更できるようにするかどうかを指定します。
  • 0 (既定値) = ユーザーがこの設定を変更できるようにします。
  • 1 = ユーザーがこの設定を変更できないようにします。
IECompat=[0,1] Internet Explorer 4 と同じコンピュータに Internet Explorer 5 以降をインストールして両方のバージョンを併用できるようにするかどうかを指定します。
  • 0 = Internet Explorer 5 以降を Internet Explorer 4 と同じコンピュータにインストールできないようにします。
  • 1 (既定値) = Internet Explorer 5 以降を Internet Explorer 4 と同じコンピュータにインストールして両方のバージョンを併用できるようにします。
IECompatRO=[0,1] Internet Explorer 4 の機能を Internet Explorer 5 以降と併用する設定をユーザーが変更できるようにするかどうかを指定します。
  • 0 (既定値) = ユーザーがこの設定を変更できるようにします。
  • 1 = ユーザーがこの設定を変更できないようにします。
IECompatShow=[0,1] [共存する] チェック ボックスを表示するかどうかを指定します。このチェック ボックスで、ユーザーは、Internet Explorer 5 以降を Internet Explorer 4 と共に実行できるようにするかどうかを選択できます。
  • 0 = このチェック ボックスをウィザードに表示しません。
  • 1 (既定値) = このチェック ボックスをウィザードに表示します。
ShowAdvanced=[0,1] Windows Update セットアップ ウィザードの [コンポーネント オプション] 画面に [詳細] ボタンを表示させるかどうかを指定します。[詳細] ボタンをクリックすると、[ダウンロードのみ]、[共存する]、および [ファイルの種類を関連付けない] オプションが表示されます。
  • 0 = ウィザードに [詳細] ボタンを表示しません。
  • 1 (既定値) = ウィザードに [詳細] ボタンを表示します。
IEDefault=[0,1] Internet Explorer を既定のブラウザにするかどうかを指定します。
  • 0 = Internet Explorer を既定のブラウザにしません。
  • 1 (既定値) = Internet Explorer を既定のブラウザにします。
IEDefaultRO=[0,1] Internet Explorer を既定のブラウザにする設定をユーザーが変更できるようにするかどうかを指定します。
  • 0 = Internet Explorer を既定のブラウザにするかどうかをユーザーが変更できるようにします。
  • 1 (既定値) = Internet Explorer を既定のブラウザにするかどうかをユーザーが変更できないようにします。
先頭へ戻る

[Download]
Display=[0,1]
DownloadDir=foldername
DownloadDirRO=[0,1]
DownloadOS=[0,1]
DownloadOSRO=[0,1]

このセクションのエントリ | [説明]
Display=[0,1] ファイルをダウンロード後にインストールするオプションをユーザーのコンピュータに表示するかどうかを指定します。
  • 0 = ファイルをダウンロード後にインストールするかどうかを指定するオプションをユーザーのコンピュータに表示しません。
  • 1 (既定値) = ファイルをダウンロード後にインストールするかどうかを指定するオプションをユーザーのコンピュータに表示します。
DownloadDir=foldername | ファイルをダウンロードするフォルダを指定します。この設定を省略すると、ディスク容量が最も大きいドライブに Windows Update Setup Files という名前のフォルダが作成されます。 < /td>
DownloadDirRO=[0,1] ファイルをダウンロードするフォルダをユーザーが変更できるようにするかどうかを指定します。
  • 0 (既定値) = ユーザーがダウンロード フォルダを変更できるようにします。
  • 1 = ユーザーがダウンロード フォルダを変更できないようにします。
DownloadOS=[0,1,2,3] 特定のオペレーティング システム用のファイルをダウンロードするように指定します。この設定は、ファイルをダウンロードした後でインストールしない場合 (DownloadOnly=1) にのみ有効です。
  • 0 (既定値) = 現在のオペレーティング システム用のファイルをダウンロードします。
  • 1 = Windows 95、Windows 98、Windows Millennium Edition、Windows NT、Windows 2000、および Windows XP を指定します。
DownloadOSRO=[0,1] ダウンロードするファイルのオペレーティング システムをユーザーが選択できるようにするかどうかを指定します。
  • 0 (既定値) = ユーザーがこの設定を変更できるようにします。
  • 1 = ユーザーがこの設定を変更できないようにします。
先頭へ戻る

[DownloadSite]
Display=[0,1]
DownloadLocation=URL
DownloadSiteList=URL

このセクションのエントリ | [説明]
Display=[0,1] ダウンロード サイトをユーザーに表示するかどうかを指定します。
  • 0 = ダウンロード サイトをユーザーのコンピュータに表示しません。
  • 1 (既定値) = ダウンロード サイトをユーザーのコンピュータに表示します。
DownloadLocation=URL | パッケージを Web から配布する場合に、.cab ファイルのダウンロード元の Web サイトのアドレスを指定します。このセクションに Display=0 と指定するか、またはこのページを表示しないスイッチを指定した場合は、ダウンロード サイトを入力する必要があります。
DownloadSiteList=URL | ダウンロード サイトのリストの URL を指定します。既定では、Ie6sites.dat ファイルがこのリストとして使用されます。この設定を省略すると、Iesetup.inf ファイル内の現在の設定が適用されます。
先頭へ戻る

[PrepareSetup]
Display=[0,1]

このセクションのエントリ [説明]
Display=[0,1] [セットアップの準備] 画面をユーザーのコンピュータに表示するかどうかを指定します。
  • 0 = [セットアップの準備] 画面をユーザーのコンピュータに表示しません。
  • 1 (既定値) = [セットアップの準備] 画面をユーザーのコンピュータに表示します。
先頭へ戻る

[Diskspace]
Display=[0,1]

このセクションのエントリ [説明]
Display=[0,1] 必要なディスク容量をユーザーのコンピュータに表示するかどうかを指定します。
  • 0 = 必要なディスク容量をユーザーのコンピュータに表示しません。ユーザーのコンピュータのディスク容量が不足している場合は、セットアップは中止されます。
  • 1 (既定値) = 必要なディスク容量をユーザーのコンピュータに表示します。
先頭へ戻る

[Progress]
Display=[0,1]

このセクションのエントリ [説明]
Display=[0,1] インストールの進捗状況をユーザーのコンピュータに表示するかどうかを指定します。
  • 0 = インストールの進捗状況をユーザーのコンピュータに表示しません。
  • 1 (既定値) = インストールの進捗状況をユーザーのコンピュータに表示します。
先頭へ戻る

[RebootPartial]
Display=[0,1]

このセクションのエントリ [説明]
Display=[0,1] コンポーネントのインストールに失敗した場合に [インストールの失敗] 画面を表示するかどうかを指定します。
  • 0 = コンポーネントのインストールに失敗した場合に [インストールの失敗] 画面を表示しません。
  • 1 (既定値) = コンポーネントのインストールに失敗した場合に [インストールの失敗] 画面を表示します。
先頭へ戻る

[Finish]
Display=[0,1]

このセクションのエントリ [説明]
Display=[0,1] セットアップの終了後にコンピュータを再起動するメッセージを表示するかどうかを指定します。
  • 0 = セットアップの終了後にコンピュータを再起動するメッセージを表示しません。インストール後の再起動をオフにする場合は、0 に設定してください。
  • 1 (既定値) = セットアップの終了後にコンピュータを再起動するメッセージを表示します。
先頭へ戻る

[Reboot]
Reboot=[0,1]

このセクションのエントリ [説明]
Reboot=[0,1] セットアップの終了後にコンピュータを再起動するかどうかを指定します。
  • 0 = セットアップの終了後にコンピュータを再起動しません。再起動をオフにした場合は、プログラム側でコンピュータの再起動を制御する必要があります。Internet Explorer は、コンピュータが再起動されるまで、正しく設定されません。
  • 1 (既定値) = セットアップの終了後にコンピュータを再起動します。
先頭へ戻る

[Upgrade]
ReinstallAll=[0,1]

このセクションのエントリ [説明]
ReinstallAll=[0,1] セットアップを 2 回目以降に実行する場合にすべてのコンポーネントを再インストールするかどうかを指定します。
  • 0 (既定値) = すべてのコンポーネントが既にインストールされている場合はセットアップを再実行しません。
  • 1 = すべてのコンポーネントを再インストールします。
先頭へ戻る


IExpress のバッチ モード セットアップ スイッチ

IExpress ウィザードを実行すると、アプリケーション間でセットアップ スイッチを使用することができます。IExpress で Internet Explorer のスイッチを使用する場合は、それらのスイッチは次のように IExpress の式に代入されます。

Ie6setup <IExpress のスイッチ> /c:"ie6wzd <Internet Explorer のスイッチ>"

IExpress のスイッチ

次に示すように、IExpress には、セットアップ中の展開処理を制御するスイッチが豊富に用意されています。これらのスイッチは、Internet Explorer 専用ではありません。

スイッチ | 動作
/Q | ファイルをサイレント モードで展開します。展開中にプロンプトは表示されません。 このスイッチは、Windows Update セットアップの実行中のプロンプトは非表示にできません。
/Q:U | ユーザー サイレント モードを指定します。ユーザーのコンピュータには、一部のダイアログ ボックスだけが表示されます。
/Q:A | 管理者サイレント モードを指定します。ユーザーのコンピュータには、ダイアログ ボックスは一切表示されません。
/C:<UNC location> | セットアップ用の .inf または .exe ファイルのパスと名前を指定します。
/R:N | インストール後にコンピュータを再起動しません。
/R:A | インストール後に必ずコンピュータを再起動します。
/R:S | インストール後にプロンプトを表示せずにコンピュータを再起動します。
/T:<directory path> | ファイルの展開先のフォルダを指定します。

IExpress の詳細については、「IExpress のテクノロジと IExpress ウィザード」を参照してください。


IExpress のテクノロジと IExpress ウィザード

IExpress は、セットアップ プログラムの作成を簡単にするために設計されたテクノロジです。IExpress ウィザードに従って処理を 1 ステップずつ実行すれば、内部のセットアップ プログラムを自動的に実行するような自己展開型のファイルを作成することができます。セットアップ プログラムは、.inf ファイルと実行可能プログラムのどちらでもかまいません。IExpress のテクノロジは、インストールが終了するとセットアップ ファイルを自動的に削除するため、時間と労力を節約することができます。

IExpress ウィザードでは、インストール後にコンピュータを再起動するかどうかなどの指定を通じて、カスタム ブラウザ パッケージのインストール方法を詳細に設定できます。IExpress ウィザード (IExpress.exe) は、\<IEAK プログラム フォルダ>\Tools フォルダに入っています。このウィザードで指定する選択肢は、バッチ モードでのセットアップ スイッチに対応しています。

IExpress は、パッケージに関する情報を格納するための自己展開型ディレクティブ (.sed) ファイルを使用します。IExpress ウィザードを実行する際は、既存の .sed ファイルを使用してもかまいませんし、ウィザードで新しい SED ファイルを作成してもかまいません。.sed ファイルには、セットアップ パッケージに関する情報および指示が格納されます。

IExpress で自己展開型ファイルを作成するとき、この自己展開型ファイルの言語が Internet Explorer 6 カスタマイズ ウィザードの言語と異なる場合は、\<IEAK プログラム フォルダ>\Iebin\<言語>\Optional フォルダの Wextract.exe および Advpack.dll ファイルを \<IEAK プログラム フォルダ>\Tools フォルダにコピーします。 なお、\<IEAK プログラム フォルダ>\Tools フォルダには、Iexpress.exe、Makecab.exe、W95inf32.dll、および W95inf16.dll ファイルが格納されています。advpack.dll をパッケージに含めます。

IExpress テクノロジの機能

  • Internet Explorer の自動サイレント インストール。
  • 以前にインストールしたものを削除しなくても、アップグレードすることができます。
  • 同じ作成方法を使用した更新または再インストール。

IExpress で使用される .inf ファイルで指定できる設定

  • 自動インストール パッケージを管理者向けと一般ユーザー向けのいずれにするか決定する。
  • 埋め込みインストール コマンドの実行に関しては、標準やサイレントなどの複数のモードを設定する。
  • ユーザーのコンピュータ上にある IExpress ダイナミックリンク ライブラリ (.dll ファイル) が現行のものより古くなった場合に、それを更新するかどうか決定する。
  • オペレーティング システム、ブラウザ、およびアプリケーションに関して、該当パッケージを使用できるバージョン (対象バージョン) の範囲 (1 つまたは複数のバージョン) を指定する。
  • バッチ モードの場合、該当パッケージの別のコピーが実行中のときは警告を出して 2 つのパッケージを同時に実行しないようにするか、または何もしないかを決定する。
  • 該当パッケージを作成し直すことなく、UPDFILE ツールを使って IExpress パッケージを更新しファイルを追加する。
  • ジョブの実行順序とステータスの表示に関して、発行者に制御を任せ、Runonce を RunOnceEx で置き換える (iernonce.dll の新しいバージョンがある場合)。
  • ローミング ユーザーをサポートするのに必要な機構を、企業内管理者に提供する。
  • カスタム コンテンツをユーザーに提供するような構成済みデスクトップの入ったパッケージの生成方法を、ICP および ISP に提供する。
  • 複数のダウンロード サイトをサポートする。
  • その他の内部および外部の開発、カスタマイズ、機能拡張、デバッグ機能の強化をサポートする。
  • セットアップ、アンインストール、およびメンテナンスの各モード時に、ハードディスク内のごみ箱、occache、wininet キャッシュ、[Temp] フォルダなどをクリーンアップすることにより、ディスク領域を節約する。
  • 非 SBCS の拡張文字セットをサポートする。
  • インターネット コンポーネントのダウンロードにおける .inf ファイルの使用をサポートする。

詳細については、「セットアップ情報ファイル (.inf) の使用」を参照してください。


Internet Explorer のバッチ モード セットアップ スイッチ

ユーザー側での Windows Update セットアップの実行方法を制御できると便利な場合があります。そのような場合は、コマンド ライン スイッチを使用すると、インストール モードを選択したり、サイレント モード (全部または一部のプロンプトが、ユーザーに表示されなくなる) を指定したり、インストール後にコンピュータを再起動するかどうかを制御することもできます。

コマンド ライン スイッチは、Windows Update セットアップの実行時にユーザーに指定させることもできますが、通常は、バッチ インストール用の別のプログラム (IExpress など) を使用して Internet Explorer に添付します。

Internet Explorer のスイッチ

次のスイッチを使用すると、Internet Explorer セットアップの動作を制御できます。

スイッチ | 動作
/Q | "操作が少なくて済む" サイレント モードを指定します。未指定の情報があると、ユーザーに入力が求められます。
/Q:A | ユーザー プロンプトを表示しない サイレント モードを指定します。
/Q:C | サイレント モードを指定し、なおかつ、ユーザーがセットアップを取り消せないように [キャンセル] ボタンを非表示にします。 企業内管理者の場合、Internet Explorer 6 カスタマイズ ウィザードで [完全サイレント インストール] オプションを選択すると、このスイッチが適用されます。
/B:filename | 使用するバッチ スクリプト ファイルを指定します。
/M[:{0|1|2|3...10}] インストール モードを指定します。IEAK のカスタム パッケージの場合、0 は先頭のインストール モード、1 は 2 番目のインストール モード、... というようになります (例 : 0 = 最小インストール、1 = 標準インストール (既定値)、2 = 完全インストール)。IEAK ではインストール モードを 10 個まで指定できます。

数字を指定せずに /M スイッチを使用すると、セットアップはモードを使用せず、指定されたコンポーネントだけをインストールします。このスイッチを使用しなければ、セットアップは .inf ファイルで指定された既定のモードを使用します。
/E:ComponentID[, ...] | インストール モードに関係なくインストールする追加のコンポーネントを指定します。このスイッチを使用すると、カスタマイズ ウィザードで指定したインストール タイプに含まれないコンポーネントを指定することができます。バッチ テキスト ファイルを使用している場合は、このスイッチがバッチ ファイルの設定に優先して適用されます。ComponentID は、コンポーネントを特定する文字列です。対応する文字列は、Iesetup.cif ファイルのコンポーネント セクションで確認できます。
/S:""#e"" Ie6setup.exe のソース パスを指定します。""#e"" には、.exe ファイルの完全パスと名前を指定します。

注

  • パスは、2 組の二重引用符で囲まなければならないことに注意してください。
/R:N | インストール後にコンピュータを再起動しません。このスイッチを指定した場合は、カスタム コンポーネント側でコンピュータを再起動する必要があります。Internet Explorer は、コンピュータが再起動されるまで、正しく構成されません。
/D | 現在のオペレーティング システムのファイルだけをダウンロードするよう指定します。
/D:1 | Windows および Windows NT のファイルをダウンロードするよう指定します。
/G:section[, ...] | Iesetup.inf ファイル内の指定したセクションを実行します。複数のセクションを指定する場合は、カンマで区切ってください。
/X | シェル、アイコン、およびリンクなしで、Internet Explorer をインストールします。このオプションは、ブラウザを独自のアプリケーションで制御する場合に便利です。
/X:1 | Internet Explorer をシェル、アイコン、またはリンクと共にインストールしますが、既定のブラウザや http プロトコルの関連付けの設定は変更せずに維持されます。
/P | インストールに必要なコンポーネントおよびディスク容量を報告します。このスイッチを使用すると、選択したインストール オプションに応じて必要なディスク容量を確認できます。詳細については、このトピックの「Internet Explorer のインストール サイズの評価」を参照してください。

IExpress で使用される Internet Explorer のコマンド ライン スイッチ

IExpress ウィザードを使用すると、プログラム間でセットアップ スイッチを簡単に渡すことができます。IExpress を Internet Explorer のスイッチと共に使用する場合、Internet Explorer のスイッチは IExpress の式の中に次のように配置されます。

Ie6setup <IExpress のスイッチ> /c:"ie6wzd <Internet Explorer のスイッチ>"

IExpress セットアップ スイッチの一覧については、「IExpress のバッチ モード セットアップ スイッチ」を参照してください。

例

次に、Internet Explorer のインストールに使用するコマンドの例を示します。

  • 次の式は、サイレント インストールを実行します。ユーザーにメッセージを表示せず、インストール後の再起動も行われません。

    ie6setup.exe /C:"ie6wzd /S:""#e"" /Q /R:N"

  • 次の式は、Ie6sites.dat のサイト一覧を無効にして、指定した場所から Internet Explorer をインストールします。これは 1 つの式ですが、読みやすいように複数の行で表示しています。

    ie6setup.exe
    /C:"ie6wzd
    /S:""\\yourserver.com\directory\ie6setup.exe"""

    この式を使用すると、IEAK パッケージを作成しなくても、ユーザーに他のダウンロード場所 (他の国や地域など) を参照させることができます。

Internet Explorer のインストール サイズの評価

Internet Explorer のバッチ モード スイッチを使用して、Internet Explorer のインストールに関する情報を IEAK のカスタム パッケージに渡すことができます。これには、2 つの大きな理由があります。1 つは Internet Explorer のインストールに必要なディスク容量を表示すること (ユーザーが選択したオプションを基にして動的に)、もう 1 つはインストール中に進捗情報を提供することです。

/P スイッチを使用すると、インストール中に、この情報はレジストリに格納されます。この情報に基づき、Windows Update セットアップは HKEY_LOCAL_MACHINE\Software\Microsoft\Active Setup\InstallInfo レジストリに次の情報を返します。

サブキー | データ型 | 値
InstallSize | 文字列型 | KB (実際のインストール サイズ)
AdminRights | バイナリ | 1 または 0
EstimatedCopy | 文字列型 | KB インストール処理にはより多くの領域が必要となるので、この値は通常、InstallSize より大きくなります。この値は、進捗状況の情報を "燃料計" スタイルで表示するときの見積もりとして使用します。

Windows Update セットアップのリターン コードとステータス

アプリケーションのインストールが成功または失敗したら、セットアップは実行の結果を報告する必要があります。IE6wzd.exe は Ie6setup.exe の内部にパッケージ化されているので、リターン コードを直接返すことはできません。代わりに、インストールが終了すると、セットアップはこの情報をレジストリ キー HKEY_LOCAL_MACHINE\Software\Microsoft\Active Setup\InstallInfo に返します。Failed HResult は、何らかの失敗を示します。

サブキー | データ型 | 値
Complete | 文字列型 | セットアップから返された HRESULT を反映する DWORD 値
 |  | 0 | インストール成功。
 |  | 0x80100003 | インストールに必要なファイルが見つからない。
 |  | 0x80100001 | セットアップは部分的に成功。ダウンロードまたはインストールに失敗したコンポーネントが 1 つ以上あります。これらのコンポーネントの一覧は、FailedComponents で確認します。
 |  | 0x80100002 | セットアップは部分的に成功しましたが、ユーザーによってセットアップはキャンセルされました。ダウンロードまたはインストールに失敗したコンポーネントが 1 つ以上あります。

インストールに失敗した項目については、さらに次の情報がセットアップから返されます。

サブキー | データ型 | 値
FailedComponents | MultiSZ | <CIFID からのコンポーネント名>null<コンポーネント名...>
InstallStatus | バイナリ | 0 | インストール成功。
 |  | 1 | インストールを中断します。ユーザーがセットアップの [キャンセル] ボタンをクリックし、実際に取り消すかどうかを確認するメッセージが表示されている状態のときに返される値です。
 |  | 2 | セットアップを終了せず、再開します。
 |  | 3 | セットアップを即座に終了します。ファイルのコピーや展開などの処理が現在実行されている場合は、その処理が完了した後で終了します。


ユーザーの定期的更新

Internet Explorer の新しいバージョンがリリースされているかどうかを自動的にチェックして、ユーザーに通知することができます。Internet Explorer にこのアップデート情報をチェックさせるかどうかを切り替えることができ、チェックさせる場合はその頻度を指定できます。

この機能は次のように動作します。

  • Internet Explorer の新しいバージョンが検出されると、ユーザーのホーム ページ (スタート ページ) が一時的に更新通知用のページに置き換えられます。ユーザーはこのページからブラウザを更新したり、このページを [お気に入り] の一覧に追加したり、更新を取り消すことができます。
  • 既定では、Microsoft Windows Update 用の Microsoft Internet Explorer ページが更新通知用のページとして使用されます。標準のページの代りに、製品情報や会社の最新情報などを示すカスタム Web ページを使用することもできます。たとえば、Internet Explorer の新しいバージョンに関する情報のほか、新しいサーバーのパスや会社の最新情報などをユーザーに通知する Web ページを作成することができます。

    更新通知用のページを使用すると、.htm 形式の情報を定期的にユーザーに配布できます。

  • 次回、ユーザーががブラウザを再起動すると、ユーザーの既定のホーム ページが表示されます。

更新通知用のページの設定を指定するには、次の操作を行います。

  1. この設定を Internet Explorer 6 カスタマイズ ウィザードで変更するには、段階 5 の [ポリシーおよび制限] 画面で、[インターネットの設定] をクリックし、[詳細設定] をクリックします。

    または

    この設定をプロファイル マネージャで変更するには、[ポリシーおよび制限] をクリックして、[インターネットの設定] をクリックし、[詳細設定] をクリックします。

  2. 画面の右側にある [[Internet Explorer の更新] を自動的にチェックする] チェック ボックスをオンにします。
  3. 画面の左側にある [コンポーネントの更新] をクリックします。
  4. 既定の Windows Update ページを使用する場合は、既定の URL をそのまま使用します。

    カスタム ページを使用する場合は、そのページのアドレスを [更新に表示される URL] ボックスに入力します。

  5. [更新チェック間隔 (日)] で、更新された情報の有無をチェックする間隔を日数単位で指定します。

組織のカスタム ページを作成する場合は、\<IEAK プログラム フォルダ>\Toolkit フォルダにあるサンプル ファイル ieupdate.htm を参照してください。

注

  • プロファイル マネージャまたはウィザードの [ポリシーおよび制限] ページの [インターネットの設定] では、[コンポーネントの更新] 画面の Internet Explorer およびインターネット ツールに更新があったかどうか、定期的にチェックするかどうかを選択できます。


ブラウザの設定の自動検出および自動構成

Internet Explorer を初めて起動したときに自動的にカスタマイズされるように、ネットワークを構成することができます。これにより、管理上のオーバーヘッドが軽減され、ブラウザの設定に関する問い合わせがサポート窓口に寄せられることも少なくなります。

Web Proxy AutoDiscovery (WPAD) に基づいたブラウザの設定の自動検出は、動的ホスト構成プロトコル (DHCP) および DNS (ドメイン ネーム システム) によってサポートされています。適切な設定を使って、DHCP と DNS サーバーがブラウザの設定の自動検出および自動構成を行います。この機能は、従来の自動構成テクノロジを基板としており、自動構成 URL (.ins ファイル) または Javascript プロキシ構成ファイル (.js、.jvs、.pac のいずれか) を使用して、集中管理を行う場所からブラウザを構成できます。

自動検出機能によって、管理者があらかじめカスタマイズを行わなくても、ブラウザの起動時に自動的に構成できます。 たとえばユーザーが、カスタム ブラウザを社内のサーバーからインストールする代わりに、カスタマイズされていないブラウザをインターネットからダウンロードすると、自動検出によってユーザーのブラウザが自動構成およびカスタマイズされます。

IEAK でブラウザの設定の自動検出をセットアップするように指定するには、Internet Explorer 6 カスタマイズ ウィザードの [自動構成] 画面で、[構成ファイルを自動検出する] を選択します。自動構成の図解については、「自動構成の仕組み」を参照してください。

DHCP および DNS によるブラウザの設定の自動検出

DHCP サーバーを使用すると、管理者は TCP/IP に関するグローバルなパラメータとサブネット固有のパラメータを指定し、予約済みのアドレスを使ってクライアント用のパラメータを定義して、これらを集中的に管理できます。クライアント コンピュータがサブネット間を移動した場合、コンピュータを再起動すると、そのコンピュータの TCP/IP が自動的に再構成されます。

重要

  • DHCP サーバーは、Windows 2000 および Windows XP の DHCP サーバーのように、DHCPINFORM メッセージをサポートしている必要があります。

DNS は、数字とドットだけで表される IP アドレスの代わりに、階層化されたわかりやすい名前 (ホスト名) を使用して、TCP/IP ネットワーク上のほかのコンピュータを検索するための一連のプロトコルおよびサービスです。

DHCP による自動検出は、LAN ベースのユーザーの場合に最も適しています。一方、DNS による自動検出では、LAN ベースのユーザーとダイヤルアップ ユーザーのどちらの場合も設定を検出できます。DNS ではネットワーク ユーザーとダイヤルアップ ユーザーの両方に対応できますが、LAN ユーザーにとっては、DHCP を使用した方が迅速なアクセスが可能になり、構成ファイルをより柔軟に構成できます。

ブラウザの設定の自動検出機能を有効にするには、対応する設定を DNS サーバーと DHCP サーバーの一方または両方で構成する必要があります。

詳細については、次の項目を参照してください。

DHCP によるブラウザの設定の自動検出機能を有効にする

DHCP サーバーでブラウザの設定の自動検出機能をセットアップするには、コード番号 252 による新しいオプション タイプを作成する必要があります。コードに関連付ける値として、構成ファイルの場所の URL を入力します。このファイルは、.pac、.jvs、.js、.inc、のいずれかです。

DHCP サーバーの構成の詳細については、サーバーのマニュアルを参照してください。

例

http://www.microsoft.com/webproxy.pac
http://marketing/config.ins
http://###.#.###.#/account.pac

DNS による自動検出機能を有効にする

DNS によるブラウザの設定の自動検出機能を有効にするには、DNS データベース ファイル内のホスト レコードと CNAME "エイリアス" レコードのいずれかを構成する必要があります。

ホスト レコード

ホスト レコードは、ゾーン内の IP アドレスにホスト名 (コンピュータ名) を静的に関連付けるためのレコードです。ホスト レコードには、ワークステーション、ネーム サーバー、メール サービスなど、静的マッピングが必要なすべてのホストに対応するエントリが格納されます。

このレコードの各エントリは、<ホスト名> IN A <ホストの IP アドレス> の構文で定義されます。

例を次に示します。

corserv | IN | A | 192.55.200.143
nameserver2 | IN | A | 192.55.200.2
mailserver1 | IN | A | 192.55.200.51

CNAME レコード

これらのレコード は "エイリアス" と呼ぶことがありますが、厳密には "Canonical Name" の略語です。これらのレコードでは、単一のホストに複数の名前を関連付けることができます。CNAME レコードを使用すると、1 台のコンピュータを FTP サーバーと Web サーバーの両方として兼用する場合などに役立ちます。

DNS データベース ファイルをブラウザの設定の自動検出機能に対応させるには

  • DNS データベース ファイルに、wpad という名前のホスト レコードを追加することによって、.pac、.jvs、.js、.ins 自動構成ファイルのいずれかが置かれている Web サーバーの IP アドレスを指定します。

    または、wpad という名前の CNAME エイリアスを入力し、.pac、.jvs、.js、.ins 自動構成ファイルのいずれかが置かれている Web サーバーの名前 (IP アドレスではなくホスト名) を指定します。

注

  • レコードを追加したデータベース ファイルをサーバーに転送すると、DNS 名 wpad.domain.com が自動構成ファイルの置かれているサーバーと同じコンピュータの名前として解決されます。
  • DNS を使用すると、Internet Explorer では、ホスト名 wpad に基づいて既定の URL テンプレートが作成されます。

    例を次に示します。

    http://wpad.domain.com/wpad.dat

    したがって、Web サーバー wpad 上では、自動構成ファイルの内容が参照可能になるように、wpad.dat という名前のファイルまたはリダイレクション ポイントをセットアップする必要があります。


設定と制限について

Internet Explorer のシステム ポリシーおよび制限は、コンピュータを制御し、管理する上で非常に強力な機構です。ポリシー ファイルで定義されるシステム ポリシーおよび制限は、ユーザーのログオン時に既定のレジストリ値を無効にすることで、ユーザーおよびコンピュータのアクセス権限を制御します。

Internet Explorer 6 カスタマイズ ウィザードを使用すると、システム ポリシーおよび制限を定義し、カスタム ブラウザ パッケージの一部として標準の Internet Explorer の構成を作成することができます。Internet Explorer のインストール後に、IEAK プロファイル マネージャを使用して、ユーザーのデスクトップに対して、システム ポリシーおよび制限を中央で管理し、更新することができます。また、グループごとにニーズが異なる場合は、IEAK プロファイル マネージャを使用して、グループごとに別の ポリシー (.ins) ファイルを作成できます。

たとえば、次のような場合にシステム ポリシーおよび制限を実装します。

  • Internet Explorer のツール バーなど、ユーザーが変更できる機能を指定します。
  • 帯域幅を管理し、Internet Explorer の外観と動作をカスタマイズします。
  • Microsoft NetMeeting などのコンポーネントのサーバー リストを指定したり、ユーザーを定期的に更新するためのページをセットアップします。
  • 電子メールおよびインターネット通話に使用するプログラムを指定します。
  • ユーザーの接続の設定をあらかじめ決めておきます。複数の接続の設定を管理する必要がある場合は、接続マネージャ管理キット (CMAK) を使って作成したカスタム プロファイルのインポートを検討してください。

この機能の図解については、「システム ポリシーおよび設定」を参照してください。

注

  • Internet Explorer 6 のイメージ ツール バーという新機能には、イメージ ツール バーの移動を有効にする、画面サイズに合わせて画像を縮小する、メディア バーで自動的にメディア ファイルを再生するなどの設定があります。これらのオプションは、[ポリシーおよび制限] の [インターネットの設定] で設定できます。

システム ポリシーおよび制限を使用する利点

企業内では、システム ポリシーおよび制限を実装することにより、次のようなメリットがあります。

  • システム ポリシーおよび制限を使用すると、標準の Internet Explorer の構成を実装できます。ユーザー向けに、ブラウザの機能や動作の一般的な設定を含むカスタム ブラウザ パッケージを作成できます。
  • システム ポリシーおよび制限を使用すると、ユーザーが Internet Explorer でアクセスできる機能を制限することができます。たとえば、NetMeeting のオプションをあらかじめ設定しておいて、オーディオおよびビデオへのアクセスを制御することができます。また、オプションの値を固定して、その機能や動作をユーザーのデスクトップでは非表示または淡色表示にすることができます。
  • システム ポリシーおよび制限を設定すると、既定のレジストリの設定を変更することができます。ポリシー ファイルの設定を使用すると、複数のコンピュータのレジストリ値を変更することができ、ユーザーのコンピュータで個別に設定を指定する手間が省けます。

システム ポリシーと制限の設定前に考慮すべき問題

システム ポリシーおよび制限を実装する前に、次の問題を考慮する必要があります。

  • 中央で定義および管理するシステム ポリシーと制限の種類。たとえば、NetMeeting の機能へのアクセスを制限するかどうか。
  • すべてのユーザーおよびコンピュータに対して 1 セットの標準のシステム ポリシーおよび制限を使用するか、またはユーザー グループ用に複数のポリシー ファイルを作成するか。ユーザー グループごとにニーズが異なる場合があります。
  • 実装するセキュリティ設定の種類。すべての設定を固定したり、設定を制御しながらローミング ユーザーに対してその設定のダウンロードを許可したり、設定をカスタマイズしながらユーザーに対してその設定の変更を許可することができます。

    これらの設定の影響を考慮する必要があります。ほかのユーザーとコンピュータを共有するようなローミング ユーザーが存在している場合は、特に注意します。たとえば、デスクトップからアイコンを削除したり、ユーザーに対してセキュリティ設定の変更を禁止した場合の影響を考えます。アクセスできる機能をユーザーに周知させる必要があります。

  • ポリシー ファイルを中央に格納するか、またはユーザーのコンピュータに格納するか。ローミング ユーザーがコンピュータ間で設定にアクセスできるように、ファイルをサーバー上に格納することもできます。この機能は、低レベルのセキュリティ設定を必要とするユーザーが、高レベルのセキュリティ設定を必要とする別のユーザーによって操作されているコンピュータを使用する場合などに便利です。

Windows NT、Windows 2000、および Windows XP におけるポリシーと制限の管理方法

Internet Explorer 6 カスタマイズ ウィザードで設定し、IEAK プロファイル マネージャで後から管理することのできるシステム ポリシーと制限はすべて、Windows 95、Windows 98、および Windows Millennium Edition オペレーティング システムを実行しているユーザー向けに構成できます。

ただし、Windows NT、Windows 2000、または Windows XP プラットフォーム上で管理者権限を持たないユーザーに対して構成できるのは、これらのシステム ポリシーと制限の一部だけです。その代わりに、Windows NT ポリシー エディタ、Windows 2000 グループ ポリシー、または Windows XP グループ ポリシーを使って、これらのユーザーの残りのポリシーと制限を構成することをお勧めします。詳細については、「Windows 2000 および Windows XP 上での Internet Explorer の管理」を参照してください。

ポリシーと制限の設定と管理

ポリシーと制限は、次の 2 通りの方法で設定できます。

  • Internet Explorer 6 カスタマイズ ウィザードの段階 5 で設定する。
  • プロファイル マネージャで自動構成を使う。

プロファイル マネージャを使うには、新しいユーザー プロファイルを作成するか、または既存のプロファイルを開きます。次に、変更する設定または制限が表示されるまでフォルダ階層を展開します。ポリシーと制限のカテゴリのフォルダをクリックすると、そのカテゴリの詳細な情報が表示されます。

自動構成では、Internet Explorer 6 カスタマイズ ウィザードまたは [インターネット オプション] ダイアログ ボックスで指定したパスにブラウザの設定と制限が保存されます。

ユーザーのコンピュータの自動構成の設定を調べるには

  1. ブラウザの [ツール] メニューをクリックします。
  2. [インターネット オプション] をクリックします。
  3. [接続] タブをクリックし、[LAN の設定] をクリックします。
  4. [自動構成スクリプトを使用する] チェック ボックスがオンになっていることを確認し、[アドレス] ボックス内のパスをチェックします。

カスタム プログラムのポリシーの作成と管理

Internet Explorer 6 カスタマイズ ウィザードを使用する場合は、[ポリシーおよび制限] 画面で [インポート] をクリックし、自分の .adm ファイルに格納されているポリシーおよび制限を使用することができます。.adm ファイルは、各言語でカスタマイズ可能で、[IEAK Policies] フォルダに格納しておきます。


プロキシの選択とプロキシ バイパス リストの使用方法

プロキシ サーバーを使用すると、管理者はインターネットへのアクセスを制限することができます。 プロキシ サーバーは、Internet Explorer 6 カスタマイズ ウィザード、IEAK プロファイル マネージャ、およびブラウザで指定できます。Internet Explorer 6 カスタマイズ ウィザードおよびプロファイル マネージャの [ポリシーおよび制限] ページで、ユーザーがプロキシの設定を変更できないように制限することもできます。

IEAK を使用したプロキシの選択とプロキシ バイパスの設定の構成の詳細については、Internet Explorer 6 カスタマイズ ウィザードの 段階 4 の画面の「自動構成」および「プロキシの設定」を参照してください。

注

  • プロキシ バイパス機能を使用すると、JavaScript や JScript を使用しなくてもプロキシを選択できる場合があります。

Internet Explorer でプロキシの選択とプロキシ バイパスを構成するには

  1. Internet Explorer で、[ツール] メニューの [インターネット オプション] をクリックします。
  2. [接続] タブをクリックし、[LAN の設定] をクリックします。
  3. [プロキシ サーバー] の [LAN にプロキシ サーバーを使用する (これらの設定はダイヤルアップまたは VPN 接続には適用されません)] チェック ボックスをオンにします。
  4. [詳細] をクリックして、サポートされているインターネット プロトコルごとにプロキシのアドレスとポート番号を入力します。

    注

    • ほとんどの場合、どのプロトコルでも、使用できるプロキシは 1 つだけです。そのような場合は、[HTTP] の設定でプロキシのアドレスとポート番号を入力して、[すべてのプロトコルに同じプロキシ サーバーを使用する] チェック ボックスをオンにします。
    • プロトコル ("http://" や "ftp://") が先頭に付いていないプロキシ アドレスは、CERN タイプの HTTP プロキシと見なされます。たとえば、"proxy" は、"http://proxy." と同じものとして処理されます。FTP ゲートウェイの場合は、TIS FTP ゲートウェイおよび WinGate Win95 Modem FTP プロキシの場合と同様に、プロキシ名の前にプロトコル "ftp://" を付ける必要があります。たとえば、"ftpproxy" という名前の FTP ゲートウェイを指定するには、"ftp://ftpproxy" と入力します。
  5. さらに複雑なアドレスをバイパスするには、[次で始まるアドレスにはプロキシを使用しない] ボックスにアドレスを入力します。

    バイパスするプロキシのアドレスの先頭には、http://、https://、ftp://、gopher:// などのプロトコルのタイプを指定することもできます。プロトコルのタイプを指定すると、そのプロトコルに対する要求だけが除外されます。プロトコルの値は、大文字/小文字が区別されないことに注意してください。エントリを複数個指定する際は、セミコロン (;) で区切ります。

    次に、インターネット アドレス、IP アドレス、またはドメイン名を入力します。プロトコルを指定しないと、該当アドレスを使用している要求がすべてバイパスされます。プロトコルを指定すると、該当アドレスが指定された要求は、指定したプロトコル タイプの場合だけバイパスされます。プロトコル タイプの場合と同様に、アドレスの大文字/小文字も区別されません。

    最後に、ポート番号を追加できます。使用すると、ここまでに指定した条件がすべて満たされ、かつ指定したポート番号が要求で使用されているときだけ、その要求が処理されます。

    [例外] の [次で始まるアドレスにはプロキシを使用しない] ボックスでは、ワイルドカード文字 ( * ) により、0 個以上の文字を表現することができます。

ワイルドカード文字の例

ワイルドカードは次のような場合に使用できます。

  • インターネット アドレス、IP アドレス、またはドメイン名の最後の部分だけを特定するには、先頭の部分をワイルドカードで指定します。たとえば、"*.example.com" と指定すると、最後の部分が ".example.com" になっているエントリ ("some.example.com" や "www.example.com" など) がすべて処理の対象になります。
  • インターネット アドレス、IP アドレス、またはドメイン名の先頭と最後の部分だけを特定するには、中間の部分をワイルドカードで指定します。 たとえば、"www.*.com" と指定すると、先頭部分が "www"、最後の部分が "com" になっているエントリ ("www.example.com," "www.department.example.com" など) がすべて処理の対象になります。
  • インターネット アドレス、IP アドレス、またはドメイン名の先頭の部分だけを特定するには、最後の部分をワイルドカードで指定します。たとえば、"www.example.*" と指定すると、先頭部分が "www.example." になっているエントリ ("www.example.com,"、"www.example.org,"、"www.example.microsoft.com" など) がすべて処理の対象になります。
  • パターンが似ているアドレスを表すには、ワイルドカードを複数個使います。 たとえば、"123.1*.66.*" と指定すると、"123.144.66.12"、"123.133.66.15"、"123.187.66.13" などのアドレスがすべて処理の対象になります。

注

  • ワイルドカードは便利ですが、注意して使用する必要があります。たとえば、"www.*.com," と指定すると、大部分の Web サイトでは Internet Explorer によってプロキシがバイパスされてしまいます。


Internet Explorer を Office と共にインストールする方法

Office Custom Installation Wizard (CIW) を使って、Office プログラムの展開方法をカスタマイズできます。インストール処理を簡単にするために、IEAK は CIW と連携して動作するように設計されています。

Internet Explorer を Office のカスタム パッケージと共に配布するには、次の 2 つの方法があります。

  • Internet Explorer をカスタマイズしない場合は、CIW を使用して Internet Explorer コンポーネントをインストールでき、IEAK を使う必要はありません。
  • Internet Explorer をカスタマイズして Office の展開の一部として配布する場合は、Office インストール ウィザードの [IE インストール オプションのカスタマイズ] 画面で [カスタマイズ] ボタンをクリックしてください。Custom Installation Wizard によって IEAK が起動します。

IEAK を Office Custom Installation Wizard から実行

Internet Explorer 6 カスタマイズ ウィザードは企業内管理者モードで実行され、次の設定が適用されます。

  • 配布メディアは単層です (すべてのファイルが 1 つのフォルダ内に)。
  • 2 つのインストール オプションが表示されます。これらのオプションの名前を変更することはできませんが、各インストール オプションでインストールされるコンポーネントは指定できます。
  • IEAK で作成した .cab ファイルおよびカスタム コンポーネントは、すべて同じフォルダに格納されます。このフォルダの既定の名前は、IE6_CUST です。

カスタム パッケージの作成が終わると、Windows Update セットアップ プログラム (IE6Setup.exe) のファイル名とパスが、[IE インストール オプションのカスタマイズ] 画面に表示されます。

CIW の実行中に IEAK を呼び出すには、インストール パッケージのカスタマイズに使用するコンピュータに、必要なバージョンの Internet Explorer および IEAK をインストールしておく必要があります。

注

  • Office Custom Installation Wizard を使って作成した IEAK パッケージでは、Internet Explorer 用の Windows Update セットアップのオプションはセットアップ中に表示されません。Windows Update セットアップのユーザー インターフェイスは、Office Custom Installation Wizard によって決定されます。


旧バージョンまたはほかの製品からの移行

ユーザーが Internet Explorer をインストールする前に、問題がないかどうかを確認し、問題がある場合は適切に対処しておく必要があります。

Internet Explorer 5.x からのアップグレード

Internet Explorer のセットアップを実行すると、現在インストールされている Internet Explorer 5.x が新しいバージョンで上書きされ、プロキシ設定、[お気に入り]、および Cookie は旧バージョンからインポートされます。

Internet Explorer 4 からのアップグレード

Internet Explorer のセットアップを実行すると、現在インストールされている Internet Explorer 4 が新しいバージョンで上書きされ、プロキシ設定、[お気に入り]、および Cookie は旧バージョンからインポートされます。ただし、旧バージョンのプラグインを引き続き使用する場合は、再インストールが必要です。

Internet Explorer 4 と Internet Explorer 5.x は、同じコンピュータで同時に実行できます。

Internet Explorer 3 からのアップグレード

Internet Explorer のセットアップを実行すると、現在インストールされている Internet Explorer 3 が新しいバージョンで上書きされ、プロキシ設定、[お気に入り]、および Cookie は旧バージョンからインポートされます。ただし、旧バージョンのプラグインを引き続き使用する場合は、再インストールが必要です。

Netscape Navigator 3 または 4 からの移行

Internet Explorer をインストールすると、Netscape からプロキシ設定、[ブックマーク]、および Cookie をインポートできます。ただし、旧バージョンのプラグインを引き続き使用する場合は、再インストールが必要です。Internet Explorer のインストール完了後には、Internet Explorer を既定のブラウザにするかどうかを指定できます。

Internet Explorer を Office と共にインストールする方法

この機能の詳細については、「Internet Explorer を Office と共にインストールする方法」を参照してください。


Windows Update セットアップ ウィザードによる Internet Explorer およびその他のインターネット ツールのセットアップ

管理者の方は、Windows Update セットアップ ウィザード (IE6Setup.exe) を使用すれば、Internet Explorer を効率よく配布できます。また、ユーザーがこのウィザードを使用すれば、Internet Explorer を簡単にインストールでき、インストールが失敗したときにも容易に修復できます。

このセットアップ ウィザードは、小さくてコンパクトです。クライアントがインターネットにアクセスして基本的なファイルのダウンロードを実現するために必要な最小限のコードで構成されています。

IEAK を使うと、ユーザーの要求に合わせて Windows Update セットアップをカスタマイズすることができます。

Windows Update セットアップ ウィザードの利点

このパッケージを使用することにより、Windows Update セットアップはダウンロードを開始する前に、ホスト コンピュータに関する情報を収集できます。セットアップはこの情報を使用して、Internet Explorer の .cab ファイルのダウンロードとインストールを、できる限り効率よく問題なく実行できるようにします。この小さなセットアップ パッケージを最初にダウンロードしておけば、次のように多くの利点があります。

  • 速度 : 28KBpsの回線の場合、IE6Setup.exe のダウンロードが約 2 分で済みます。
  • ディスク領域が足りない場合は、セットアップ処理の早い段階でその旨がユーザーに通知されます。長時間のダウンロード処理の末にディスクの領域不足で失敗する、ということがありません。
  • ユーザー オプションは最初にすべて収集されるので、ファイルのダウンロードとインストールが終わるまでユーザーがそばにいる必要はありません。
  • 配布サーバーとのリンクの信頼性が低く、再接続しなければならない場合には、ダウンロードは失敗したところから再開します。この処理により、ユーザーはセットアップを実行するたびに、最初からやり直すのではなく、毎回少しずつ完了に近づくことになります。
  • 配布サーバーとのリンクを再確立できない場合には、セットアップは別の配布サーバーに自動的に接続します。
  • ダウンロードの進捗状況がわかりやすく表示されます。1 秒当たりの受信バイト数だけでなく、インストール完了までの残り時間 (分) も表示されます。
  • 最新バージョンのコンポーネントがインストール済みの場合、不要な再インストールは実行されません。
  • セットアップを書き換えることなく、カスタム ダウンロード パッケージを作成して実行できます。
  • ハード ディスクから不要な一時ファイルを削除して、インストールに必要なディスク領域を解放できます。

図解については、「Windows Update セットアップ ウィザードによる Internet Explorer およびその他のインターネット ツールのセットアップ」の図を参照してください。

Intenet Explorer と共に他のコンポーネントをインストールする

Internet Explorer ブラウザに加えて、Microsoft および他の企業から提供される多くのインターネット コンポーネントを Windows Update セットアップのカスタマイズしたバージョンに含めることができます。 Internet Explorer 6 カスタマイズ ウィザードと使うと、ダウンロード可能な最新のソフトウェアを簡単に確認することができます。ユーザーは、ブラウザのインストール時に、カスタム パッケージを使って、管理者が選択したカスタム プログラムと共にこれらのコンポーネントを簡単にインストールできます。

Microsoft コンポーネントは、Web 作成ツールから多言語サポートまでの範囲にわたっています。使用可能なコンポーネントのセットは、頻繁に更新されています。インターネットに接続可能であれば、Internet Explorer 6 カスタマイズ ウィザードで最新のリストを見ることができます。

製品の更新に関する最新情報については、「Windows Update に関する Web サイト」(英語) を参照してください。

Windows Update セットアップの仕組み

IE6Setup.exe は、ユーザーとコンピュータから必要な情報をすべて収集すると、インターネット上にある Microsoft の正規の配布サーバーの 1 つから必要な .cab ファイルをダウンロードします。セットアップはコンピュータにインストール済みの Internet Explorer コンポーネントの一覧情報を持っているだけでなく、ユーザーがどのコンポーネントを必要としているかの情報も収集してあるため、不要な .cab ファイルをダウンロードしません。

セットアップ ウィザードの次の段階では、ほとんどの Microsoft 製品で従来から使用されているセットアップ プログラム (ACME) を使用します。セットアップ ウィザードと従来のセットアップとの違いは、現時点では、.cab ファイルがリムーバブル ディスクやネットワーク ドライブではなく、ローカルのハード ディスクのフォルダに格納されているという点だけです。

イントラネット管理者の方の場合、Windows Update セットアップを書き換えることなく、カスタム セットアップ パッケージ (IExpress パッケージとも言います) を作成できます。そのためには、IExpress テクノロジを使用して、カスタム バージョンの IE6Setup.exe を作成します。

追加のコマンド ライン スイッチを使って、インストール処理を細かく調整することができます。詳細については、「Internet Explorer のバッチ モード セットアップ スイッチ」を参照してください。

Windows Update セットアップのカスタマイズ

Windows Update セットアップをカスタマイズするには、いくつかの方法があります。Internet Explorer のコンポーネントを追加するか、別のセットアップ オプションを 10 個まで作成することができます。これにより、Internet Explorer の既定のセットアップに用意されている [最小構成]、[標準構成]、および [完全構成] オプションが拡張されます。追加のセットアップ オプションを用意しておくと、作業者によって使用する機能やディスクの空き容量が異なる場合に役立ちます。

重要

  • パッケージに構成したインストール オプションにかかわらず、Windows Update セットアップは、Windows 2000 および Windows XP オペレーティング システムを実行しているユーザーには、インストール オプションを 1 つだけ表示します。このインストール オプションには、パッケージに入れたすべてのカスタム コンポーネントと、Microsoft Internet コンポーネントのフル セットが含まれます。

ユーザーがセットアップ時に、オプションを迷わず選択できるようにして、混乱を避けたいとお考えの方もいるでしょう。ユーザーがほとんど、あるいはまったくオプションを指定せずにインストールできるように、Internet Explorer を構成することができます。このタイプのセットアップは、"サイレント インストール" と呼ばれることもあります。

オプションの指定が制限されたインストールは、作業者が帰宅した、就業時間後に行われる Internet Explorer のセットアップによく使用されます。これらのタイプのインストールは、コマンド ライン スイッチまたはバッチ ファイルを使うことにより、さらに適合させることができます。ユーザーに選択させるために、"サイレント インストール" のセットアップ オプションを 1 つだけ作成することもできます。

エラー メッセージやステータス情報などを含めて、すべてのユーザーからのフィードバックを受けない場合は、セットアップ プランにエラー処理が含まれていることを確認してください。インストール後に再起動させない場合は、Internet Explorer が正しくセットアップされるように、カスタム プログラムまたはスクリプトで再起動を処理する必要があります。これらのオプションの詳細については、「ユーザーによるインストール」を参照してください。

Internet Explorer のインストール時に、独自のカスタム コンポーネント (ウィルス チェックのプログラムやスクリプトなど) をインストールできると便利なことがあります。カスタム パッケージには、10 個までのカスタム コンポーネントを含めることができます。

自分の異なるセットアップ オプションに独自のビットマップを追加したり、説明を含めたりして、セットアップ プログラムの外観を変更することもできます。

カスタム ブラウザへのブランドの方法の図解については、「カスタマイズの仕組み」を参照してください。Internet Explorer 6 カスタマイズ ウィザードでカスタム パッケージを作成するときの流れについては、「IEAK でのカスタム パッケージの生成」を参照してください。

セットアップの問題点を記録するログ ファイル

ログ作成機能が拡張されたので、ユーザー、管理者、および弊社にとって、セットアップ時のトラブルシューティングが容易になりました。セットアップ ウィザードが作成する次の 2 つのログ ファイルは、問題点を突き止めて解決するのに役立ちます。この 2 つのログ ファイルは、[Windows] フォルダまたは [WinNT] フォルダのいずれかに作成されます。

  • Active Setup Log.txt セットアップ ウィザードまたはコンポーネントのインストール中に実行された処理が、すべて記録されます。Internet Explorer のコンポーネントが正しくインストールされない場合は、このログを調べてください。詳細については、「Active Setup Log.txt のエラー ログ情報」を参照してください。
  • RunOnceEx Log.txt 動的リンク ライブラリの登録中に実行された処理が、すべて記録されます。特定の .dll ファイルが正しく登録されなかったというメッセージを受け取った場合や、セットアップ処理の最終フェーズで予期しないダイアログ ボックスが表示されたりした場合は、このログを調べてください。


パッケージにアドオン コンポーネントを含める

カスタム ブラウザのパッケージを作成し終えたら、ユーザーがダウンロードできるサイトにそのパッケージを送信します。これらのサイトは、Internet Explorer 6 カスタマイズ ウィザードの段階 3 で指定します。また、新しいコンポーネントや更新済みのコンポーネントをユーザーに取得させるための場所も指定できます。これらは、アドオン コンポーネントと言います。

ユーザーが [ツール] をクリックして、[Windows Update] をクリックすると、ここで指定したアドオン コンポーネントの URL にあるページが表示されます。 このページは、コントロール パネルの [プログラムの追加と削除] で、[Internet Explorer とインターネット ツール] をクリックして [追加と削除] ボタンをクリックし、[コンポーネントを追加する] を選択したときにも表示されます。

注

  • 指定するアドオン コンポーネントの URL は、Addon.htm の完全なパスである必要があります。たとえば、http://myserver/addons/addon.htm のように指定します。

アドオン コンポーネントの Web ページのサンプル

IEAK ツールキットには、カスタマイズ可能なアドオン コンポーネントの Web ページのサンプルである Addon.htm が用意されています。このページは、\<IEAK プログラム フォルダ>\Toolkit\Addons\HTML フォルダにインストールされます。また、この Web ページは、Head.htm、Main.htm、および Info.htm ファイルにもリンクしています。

<IEAK プログラム フォルダ>\Toolkit\Addons\HTML フォルダには、次の 4 つのサンプル ファイルがあります。

  • Addon.htm : 次の 2 つのファイルを参照するフレームセットです。
    • Head.htm : タイトル用のヘッダー フレームです。
    • Main.htm : インストール スクリプトを備え、Info.htm にリンクしているメインのフレームです。
  • Info.htm : 使用可能なすべてのコンポーネントに関する情報が記載されています。

主な変更は Main.htm ファイルで行います。このファイルは、次の 3 つの部分で構成されます。

  • インストール スクリプト
  • 一連のチェック ボックス、コンポーネント名、およびサイズが記述されているテーブル
  • セットアップ用の ActiveX コントロール

サンプル ファイルの使用

上記の 4 つのファイルをすべてダウンロード場所または任意の場所にコピーして、テキスト エディタか HTML エディタで編集します。

スクリプトを正しく実行させるには、ファイルを次のようにセットアップする必要があります。

  • IEcif.cab ファイルを Web サーバー上に置きます。
  • Main.htm ファイルの <SCRIPT> セクションにある L_cab_Address= エントリに、IEcif.cab がある場所へのパスを指定します。
  • Main.htm 内のテーブルには、Microsoft の Web サイトからダウンロードしたコンポーネントで、提供の対象となるものだけを格納します。

新しいコンポーネントを追加するには

  1. 自動バージョン同期 (AVS) の実行中に、既にコンポーネントがダウンロードされていることを確認します。
  2. IESetup.cif を参照してコンポーネントの正確な名前を確認します。
  3. その名前のチェック ボックスを Addon.htm に追加します。

注

  • コンポーネントの名前は、コンシューマ Windows と Windows NT で異なっている場合もあります。詳細については、IESetup.cif を参照してください。
  • IESetup.cif には、自動バージョン同期の更新でダウンロードした新しいコンポーネントまたは更新されたコンポーネントが、自動的に含まれます。

Web ページの制作に習熟している方は、IEAK に付属しているテンプレートを使用しなくてもかまいません。

Web ページの制作に習熟している方へ

Main.htm では 2 つのスクリプト言語を使用しています。Microsoft JScript と Microsoft Visual Basic Scripting Edition (VBScript) です。JScript のコードの中には、Install() という関数が記述されています。この関数は、ページの一番下にある [インストール] ボタンをユーザーがクリックしたときに呼び出され、インストール処理の流れを制御します。Install() 関数は、いくつかの VBScript のサブルーチンを呼び出します。

これらのスクリプトは、該当するチェック ボックスの name プロパティ (input タグの一部) を使用して、IESetup.cif ファイルを読み込みます。このファイルは、IEcif.cab ファイルに格納されており、Window_onLoad() サブルーチンによって開かれます。

コンポーネントがインストール済みかどうかを調べるには、VBScript の IsComponentInstalled() サブルーチンを使用します。

IsComponentInstalled(ComponentID)

ComponentID は、IESetup.cif の該当するチェック ボックスの名前および値と同じです。

戻り値のコード | 意味
0 | コンポーネントはインストールされていません。
1 | コンポーネントは、インストール済みです。
2 | コンポーネントはインストール済みですが、新しいバージョンを入手できます。
3 | ユーザー セキュリティ ロックアウト。ステータスが不明です。

このメソッドを使用してコンポーネントを初めてチェックすると、ActiveX エンジンはセキュリティ ダイアログ ボックスを表示し、ユーザーのコンピュータにインストールされているコンポーネントのステータスをチェックするためのアクセス権を要求します。ユーザーが "いいえ" を選択すると、どのコンポーネントでも戻り値のコードが 3 になります。


Microsoft のアップデート情報をカスタム コンポーネントにパッケージ化する

自動バージョン同期 (AVS) を使用すると、利用可能な Microsoft コンポーネントとは別のバージョンのものをインストールすることができます。たとえば、Windows Update でユーザーに使用させたい修正プログラム (QFE) があるが、その修正プログラムは AVS で使用できないとします。あるいは、Internet Explorer に含まれる Microsoft NetMeeting などの Microsoft コンポーネントのさまざまなバージョンを社内で 1 つに標準化しているため、IEAK ウィザードによってパッケージに含まれたバージョンではなく、特定のバージョンをユーザーに使用させたいとします。

このような場合は、これらのファイルをカスタム コンポーネントにパッケージ化して、カスタム パッケージに含めることができます。

重要

  • Windows Update で最新のコンポーネントを検索する前に、Internet Explorer カスタマイズ ウィザードの AVS を使って利用可能なすべての更新されたまたは新しいコンポーネントを確認してください。Windows Update セットアップは、パッケージ化したすべてのコンポーネントを AVS を使ってダウンロードし、自動的にインストールします。この場合、Windows Update にあるものと同じファイルをカスタム コンポーネントに含める必要はありません。この新しい機能の詳細については、「自動バージョン同期 (AVS) の更新」を参照してください。

ユーザーがコンピュータを再起動する回数を最小限に抑えるために、このコンポーネントをインストールするタイミングを、インストール操作の他の手順と照らし合わせて選択することができます。コンポーネントは、Internet Explorer のインストール前やインストール後にインストールすることも、システムの再起動後にインストールすることもできます。


カスタム コンポーネントのアンインストール

カスタム コンポーネントのインストール中に、そのコンポーネントのアンインストール プログラムを登録しておけば、ユーザーはコントロール パネルの [プログラムの追加と削除] アイコンをクリックすることによって、プログラムを削除することができます。アンインストール ファイルのサンプルについては、IEAK ツールキットの \<IEAK プログラム フォルダ>\Toolkit\Inf フォルダにある Uncheck.inf ファイルを参照してください。

アンインストール プログラムを登録してコントロール パネルの [プログラムの追加と削除] に表示するには、アプリケーションはセットアップ中に下記のエントリをレジストリ キーに追加する必要があります。

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\ApplicationName

このレジストリ キーは、コンポーネントが正常にインストールされたかどうかを確認するため、Windows Update セットアップによっても使用されます。

サブキー | データ型 | 値
DisplayName | 文字列型 | アプリケーションのわかりやすい名前。
UninstallString | 文字列型 | アプリケーションをアンインストールする完全なコマンド ライン (パスを含む)。 バッチ ファイルやサブプロセスは使用しないでください。

ApplicationNameにも、Internet Explorer 6 カスタマイズ ウィザードの [カスタム コンポーネントの追加] 画面の [アンインストール キー] の値と同じ値を指定する必要があります。


Windows セットアップ機能の拡張

Windows セットアップは、次の 3 とおりの方法で拡張できます。

  • コマンド ラインから Rundll.exe を使って Windows .inf ファイルを実行します。
  • ユーザーがコントロール パネルの [プログラムの追加と削除] を使わなくてもよいように、32 ビットのプログラム コードからオプションの Windows コンポーネントをインストールします。
  • .inf ファイルを実行するためのアイコンを Windows デスクトップ上に作成します。この方法を使うと、インストール プログラムを開発する必要がなくなります。

コマンド ラインからの .inf ファイルの実行

.inf ファイル内のインストール セクションを実行するには、Windows システム コマンドの Rundll.exe または Rundll32.exe を使用します。コマンド ラインの構文は、次のとおりです。

RunDll setupx.dll,InstallHinfSection <section> <reboot-mode> <inf-name>

<section> パラメータには、.inf ファイル内のインストール セクションの名前を指定します。コマンド ラインからゲーム オプション コンポーネントをインストールする例を次に示します。この例では、コンピュータの再起動が必要であれば、インストール完了後すぐにコンピュータを起動するかどうかをユーザーに確認させるメッセージが表示されます。<reboot-mode> パラメータの意味については、このトピックの「再起動モード パラメータの使用」を参照してください。

RunDll setupx.dll,InstallHinfSection games 4 applets.inf

注

  • このコマンドは、インストール対象のファイルをすべて格納できる空き容量がディスク上に存在するものと見なして動作します。ディスク容量はチェックされません。
  • RUNDLL または RUNDLL32 から Setupx.dll に制御が渡されると、コンピュータが再起動される可能性があるため、インストール プログラムを独自に開発する場合は、RUNDLL または RUNDLL32 の呼び出し後にコードを実行しないようにしてください。インストール処理中に RUNDLL または RUNDLL32 を呼び出した後でほかのコードを実行する必要がある場合は、.inf ファイル内の RunOnce リストにそのコードを指定します。
  • インストール対象のオプション コンポーネントを RunOnce リストで実行することはできません。

再起動モード パラメータの使用

次の 5 つの再起動モードがサポートされています。

define HOW_NEVER_REBOOT 0
define HOW_ALWAYS_SILENT_REBOOT 1
define HOW_ALWAYS_PROMPT_REBOOT 2
define HOW_SILENT_REBOOT 3
define HOW_PROMPT_REBOOT 4

<inf-name>で Windows の .inf ファイルではなく独自の .inf ファイルを指定する場合は、上に示した値に 128 を加算した値を指定してください。上に示したゲーム オプション コンポーネントをインストールする例では、Windows の Applets.inf ファイルを指定しているため、<reboot-mode> が 4 に設定されています。独自の .inf ファイルが関連付けられているオプション コンポーネントをインストールする場合は、<reboot-mode> を 132 に設定します。<reboot-mode> パラメータに 128 を加算した値を指定する場合は、インストールするすべてのファイルをインストール ディスク上の .inf ファイルと同じフォルダに格納しておく必要があります。

注

  • Windows 95 の .inf ファイルを使用する場合は <reboot-mode> パラメータを 4 に設定し、独自の .inf ファイルを使用する場合は 132 に設定することをお勧めします。上に示した値のうち、4 と 132 以外の値を指定すると、再起動の必要がないときにコンピュータが再起動されたり、必要なときに再起動されなくなる可能性があります。

各再起動モードの意味を次に示します。

NeverReboot
<reboot-mode> を 0 または 128 に設定してください。このモードでは、どのような場合もコンピュータは再起動されません。コンピュータを再起動する必要があるかどうかは、クライアント側で判断する必要があります。セットアップでは、0 バイトより大きいサイズの C:\Windows\Wininit.ini ファイルが生成されることを意味します。

AlwaysSilentReboot
<reboot-mode> を 1 または 129 に設定してください。このモードでは、常にユーザーに対して確認を求めずにコンピュータを再起動します。

AlwaysPromptReboot
<reboot-mode> を 2 または 130 に設定してください。このモードでは、コンピュータを再起動するかどうかを確認するようにユーザーに求めます。コンピュータの再起動が必要かどうかは、セットアップ プログラム側では判断されません。

SilentReboot
<reboot-mode> を 3 または 131 に設定してください。このモードでは、セットアップ プログラム側でコンピュータの再起動が必要と判断した場合は、ユーザーに確認を求めずにコンピュータを再起動します。

PromptReboot
<reboot-mode> を 4 または 132 に設定してください。このモードでは、セットアップ プログラム側でコンピュータの再起動が必要と判断した場合は、ユーザーに確認を求めた上でコンピュータを再起動します。

ファイルの先頭に戻る

32 ビット アプリケーションからのオプション コンポーネントのインストール

Windows のセットアップ時にインストールしなかったオプション コンポーネント (ゲームなど) を後から追加する必要が生じることがあります。Windows の一回目のインストールの後に行うこのようなインストールのことを、メンテナンス モード セットアップと呼びます。通常、Windows ユーザーがメンテナンス モード セットアップを行う場合は、コントロール パネルの [プログラムの追加と削除] をクリックすることから始めます。これに対し、オプション コンポーネントを提供するベンダやサプライヤの場合は、32 ビット アプリケーションから CreateProcess を呼び出すことによって、オプション コンポーネントをインストールできます。

注

  • ここでは、CreateProcess を使ってオプション コンポーネントをインストールする方法を使用できるのは、32 ビット アプリケーションからインストールする場合に限られます。

32 ビット アプリケーションからオプション コンポーネントをインストールするには、次に示す方法を適切に組み合わせてください。

レジストリのチェック

まず最初にレジストリをチェックして、目的のオプション コンポーネントが既にインストールされているかどうか (コンポーネントのファイルが存在するかどうか) を確認します。インストール済みのオプション コンポーネントに関する情報は、次のレジストリ キーに格納されています。

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SETUP\OptionalComponents]

このキーの下層には複数のサブキーを示す値があり、各サブキーにはインストール済みのオプション コンポーネントに関する情報と、新しいオプション コンポーネントをインストールするために必要な情報が格納されています。ここでは、ゲーム オプション コンポーネントをインストールする場合を想定します。ゲームがインストールされているかどうかを確認するには、OptionalComponents キーの下層にある次のサブキーの値を調べます。

"Games"="Games"

OptionalComponents キーの下層にある "Games" キーを開いて、次のような設定を表示します。

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SETUP\OptionalComponents\Games]
"INF"="applets.inf"
"Section"="games"
"Installed"="0"

上の例では、"Installed" フラグが 0 に設定されています。これは、ゲーム オプション コンポーネントがこの Windows コンピュータにまだインストールされていないことを示しています。

CreateProcess 関数の呼び出しのコーディング

ゲームなどのオプション コンポーネントをインストールするには、上に示したキーに "INF" および "Section" の値を使用して CreateProcess 関数を呼び出し、RUNDLL 経由で Setupx.dll を実行します。これにより、コントロール パネルの [プログラムの追加と削除] を使った場合と同じ結果が得られます。CreateProcess 関数の呼び出しには、lpCommandLine パラメータを次の構文で指定します。

RunDll setupx.dll,InstallHinfSection <section> <reboot-mode> <inf-name>

<section> パラメータおよび <inf-name> パラメータには、上に示したレジストリ キーの値をそれぞれ指定します。CreateProcess 関数を呼び出してゲーム オプション コンポーネントをインストールする例を次に示します。この例では、コンピュータの再起動が必要であれば、インストール完了後すぐににコンピュータを起動するかどうかをユーザーに確認させるプロンプトが表示されます。<reboot-mode> パラメータの意味については、このトピックの「再起動モード パラメータの使用」を参照してください。

RunDll setupx.dll,InstallHinfSection games 4 applets.inf

注

  • コンポーネントをインストールする前に、ディスクの空き容量をチェックすることをお勧めします。ディスクの空き容量をチェックする場合は、システム スワップ ファイル用のディスク領域が必要になることを考慮してください。

CreateProcess 関数から Setupx.dll に制御が渡されると、コンピュータが再起動される可能性があるため、インストール プログラムを独自に開発する場合は、CreateProcess 関数の呼び出し後にコードを実行しないようにしてください。インストール処理中に CreateProcess 関数を呼び出した後でほかのコードを実行する必要がある場合は、.inf ファイル内の RunOnce リストにそのコードを指定します。

注

  • インストール対象のオプション コンポーネントを RunOnce リストで実行することはできません。

右クリックによる .inf ファイルの実行

セットアップでは、.inf ファイルに DefaultInstall という名前のセクションが含まれている場合には、そのセクションからオプション コンポーネントがインストールされます。独自の .inf ファイルに [DefaultInstall] セクションを記述し、.inf ファイルのファイル アイコンを 32 ビット Windows のデスクトップに配置しておくと、ユーザーはそのアイコンを右クリックして [DefaultInstall] セクションを実行できます。ユーザーが .inf ファイルのアイコンを右クリックすると、ポップアップ メニューが表示されます。実際に [DefaultInstall] セクションを実行するには、このメニューから [インストール] オプションを選択する必要があります。

独自の .inf ファイルの [DefaultInstall] という名前のインストール セクションを記述すると、オプション コンポーネントを簡単にインストールすることができます。この方法は、特にアプリケーションの開発中に役立ちます。最終的にはインストール用のアプリケーションを作成する予定の場合も、コードが完成するまでの間は、この方法でオプション コンポーネントをインストールできます。

一般的なエントリを含む [DefaultInstall] セクションの例を次に示します。

[DefaultInstall]
CopyFiles=QCD.copy.prog, QCD.copy.hlp, QCD.copy.win, QCD.copy.sys, QCD.copy.inf
UpdateInis=QCD.Links
AddReg=QCD.reg, QCD.run
Uninstall=FlexiCD_remove


セットアップ情報ファイル (.inf) によるフォルダとファイルの操作

.inf ファイルを使用すると、いくつかの方法でファイルとフォルダを操作できます。主に、次のような操作が可能です。

  • フォルダ内のサブフォルダおよびショートカットの作成
  • 長いファイル名の作成と削除
  • ファイル属性とフォルダ属性の設定
  • [Program Files] フォルダへのファイルのコピー

フォルダ内のサブフォルダおよびショートカットの作成

コンポーネントのインストール後には、シェルを介して、[Program Files] フォルダにサブフォルダを作成したり、任意のフォルダ内にショートカットを作成することができます。セットアップ プログラムは、Setup.ini ファイルの [progman.groups] セクションを参照し、指定されているフォルダにサブフォルダやショートカットを作成します。

コンポーネントのインストール時に [Program Files] フォルダ内にサブフォルダやショートカットを作成する必要がある場合は、Setup.ini ファイル内に適切なエントリが生成されるように、.inf ファイルに UpdateInis セクションを定義します。Setup.ini ファイルでは、次の構文でフォルダやショートカットが作成されます。これらのフォルダは、[スタート] メニューに対応しています。

[progman.groups]
folder_1=Folder_1_Name
folder_2=Folder_2_Name
:
folder_n=Folder_n_Name

[folder_1]
Link-Name, .exe-name, Icon-file-name, Icon-index, profile

profile フィールドの値を省略 (Null に設定) すると、ショートカットが常にフォルダに追加されます。

注

  • .exe-name を省略 (Null に設定) すると、対応するショートカットはグループから削除されます。
  • フォルダやショートカットの名前にスペースを含める場合は、二重引用符で囲む必要があります。これにより、Setup.ini ファイル内で二重引用符で名前が囲まれるようになります。次の例を参照してください。

例 : Games

[Optional Components]
games
[games]
OptionDesc= %GAMES_DESC%
CopyFiles= wingames.files
UpdateInis= wingames.links
[wingames.files]
cards.dll
freecell.exe
freecell.hlp
mshearts.exe
mshearts.hlp
sol.exe
sol.hlp
winmine.exe
winmine.hlp
[wingames.links]
setup.ini, progman.groups,, "gamesfolder=%GAMES_DESC%" ;creates folder
setup.ini, gamesfolder,, """Solitaire Game"",SOL.EXE,,," ;creates link
setup.ini, gamesfolder,, "Minesweeper,WINMINE.EXE,,," ;creates link
setup.ini, gamesfolder,, ""Hearts Card Game"",MSHEARTS.EXE,,,";creates link
setup.ini, gamesfolder,, "FreeCell,FREECELL.EXE,,," ;creates link

上の例の実行結果 : セットアップの [オプション コンポーネント] ダイアログ ボックスに "ゲーム" が表示されます。ユーザーが "ゲーム" を選択すると、[Program Files] フォルダ内に [Games] サブフォルダが作成され、このサブフォルダ内に ソリティア、マインスイーパ、ハーツ、およびフリーセルへのショートカットが作成されます。

長いファイル名の作成と削除

名前の変更操作は、レジストリ内で次のレベルの下層に定義します。

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\RenameFiles

削除操作は、レジストリ内で次のレベルの下層に定義します。

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\DeleteFiles

この 2 つのレベルの下層に、名前変更操作と削除操作を 1 つずつ個別のサブキーとして追加します。この各操作は、同じフォルダ内のファイルに対してのみ適用されます。各サブキーには、操作の対象となるフォルダ パスを指定するエントリと、実際の操作を指定するエントリの少なくとも 2 つのエントリを定義する必要があります。

それぞれの操作グループの最初のキーは、フォルダ エントリです。関連するフォルダに対する名前変更操作のエントリは、"old_short_name"="new_long_name,[attrib_flag]" の形式のエントリです。

名前変更操作中にファイル属性を設定する必要がある場合は、attrib_flag を指定します。このフラグに指定できる値は、次のとおりです。

1 | READONLY
2 | HIDDEN
3 | SYSTEM

ファイルまたはフォルダに複数の属性を設定するには、それらの属性に対応する値を加算した値をこのフラグに指定します。たとえば、READONLY 属性および HIDDEN 属性を設定するには、attrib_flag の値を 3 に設定します。

次に示す AddReg セクションの例では、\Windows\system32\Sample フォルダに SYSTEM 属性および HIDDEN 属性を設定します。

HKLM,Software\Microsoft\Windows\CurrentVersion\RenameFiles\Sys,,,%11%
HKLM,Software\Microsoft\Windows\CurrentVersion\RenameFiles\Sys,SAMPLE,,"SAMPLE,6"

注

  • ファイル名を短いファイル名のまま維持するには、ファイル名をすべて大文字で記述する必要があります。

関連するフォルダに対する削除操作の各エントリは、"arbitrary_key_name"="long_name_to_delete" の形式のエントリです。

長いファイル名を削除する AddReg セクションの例を次に示します。

  • C:\Samples フォルダ内の Oldname.txt ファイルの名前を New Long Name.txt に変更します。
  • [Windows] フォルダ内の Myreadme.txt ファイルの名前を My Application Readme.txt に変更します。
[MyAppShort2Long]
HKLM,Software\Microsoft\Windows\CurrentVersion\RenameFiles\Samples,,,C:\Samples
HKLM,Software\Microsoft\Windows\CurrentVersion\RenameFiles\Samples,oldname.txt,,"New
Long Name.txt"
HKLM,Software\Microsoft\Windows\CurrentVersion\RenameFiles\Win,,,%25%
HKLM,Software\Microsoft\Windows\CurrentVersion\RenameFiles\Win,myreadme.txt,,"My App Readme.txt"

長いファイル名を削除する AddReg セクションの例を次に示します。

  • C:\Samples フォルダから New Long Name.txt を削除します。
  • [Windows] フォルダから My Application Readme.txt を削除します。
[MyAppDelLong]
HKLM,Software\Microsoft\Windows\CurrentVersion\DeleteFiles\Samples,,,C:\Samples
HKLM,Software\Microsoft\Windows\CurrentVersion\DeleteFiles\Samples,oldname.txt,,"New
Long Name.txt"
HKLM,Software\Microsoft\Windows\CurrentVersion\DeleteFiles\Win,,,%25%
HKLM,Software\Microsoft\Windows\CurrentVersion\DeleteFiles\Win,myreadme.txt,,"My App Readme.txt"

これらのエントリの名前変更操作または削除操作が完了すると、レジストリからエントリが削除されます。

注

  • 名前変更操作では、新しい名前に一致するファイルが既に存在している場合は、そのファイルを削除してからファイル名が変更されます。つまり、同じ名前変更操作を 2 回繰り返すと、ファイルが失われる可能性があります。たとえば、あるビットマップ ファイルの名前を "Picture.bmp" から "Really Cool 3D Picture.bmp" に変更した後で、同じ名前変更操作をもう一度実行すると、既に存在している "Really Cool 3D Picture.bmp" を削除してから、名前変更操作が行われます。ただし、新しいファイル名に一致するのがフォルダ名の場合には、この規則は適用されません。

ファイル属性とフォルダ属性の設定

ファイルまたはフォルダの属性を設定するには、長いファイル名を作成する場合と同様に、オプションのフラグを使用します。

詳細については、このトピックの「長いファイル名の作成と削除」を参照してください。

[Program Files] フォルダへのファイルのコピー

次の例では、Program Files\Accessories フォルダに 3 つのファイルをコピーし、そのうち 1 つのファイルに対してショートカットを作成します。

[WordPadInstall
CopyFiles = WordPadCopyFiles
UpdateInis = WordPadInis
[DestinationDirs]
WordPadCopyFiles = 24,%PROGRAMF%\%ACCESSOR%
[WordPadCopyFiles]
mswd6_32.wpc
wordpad.exe
write32.wpc
[WordPadInis]
setup.ini, progman.groups,, "group4=%APPS_DESC%" ;creates Accessories folder (if not already there)
setup.ini, group4,, """%WORDPAD_LINK%"",
""%24%\%PROGRAMF%\%ACCESSOR%\WORDPAD.EXE""" ;creates link in Accessories folder
[Strings]
APPS_DESC = "Accessories"
WORDPAD_LINK = "WordPad"
; Folder names - note that the short versions must match the truncated
; 8-character names for the long versions, or else there are problems.
PROGRAMF = "Progra~1" ; first 6 chars of Program_Files, + "~1"
    ACCESSOR = "Access~1" ; first 6 chars of Accessories, + "~1"

.inf ファイルの制限事項

  • ディレクトリを削除することはできません。
  • RenFiles の使用時にファイルをほかの場所に移動することはできません。 RenFiles コマンドでは、同じフォルダにあるファイルの名前のみを変更できます。
  • ファイルをコピーすることはできません。 CopyFiles コマンドで実行できるのは、コピー元のディスクから特定のディレクトリへのコピー操作だけです。


.inf スクリプトによるアンインストール

独自の .inf ファイルでアンインストール機能を使用するには、ファイル、レジストリ エントリ、およびショートカットを削除するインストール セクションを作成し、次に、コントロール パネルの [プログラムの追加と削除] ダイアログ ボックスからアンインストールできるプログラムのリストにコンポーネントを追加します。IEAK ツールキットの \<IEAK プログラム フォルダ>\Toolkit\inf フォルダにサンプルが用意されています。

コンポーネントを [プログラムの追加と削除] ダイアログ ボックスに追加するには、次のレジストリ キーの下層に新しいキーと値を作成します。

HKLM,SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\app-name,"DisplayName",,"description"
HKLM,SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\app-name,"UninstallString",,"command-line"

description
[プログラムの追加と削除] ダイアログ ボックスのリスト ボックスに表示する文字列を指定します。

command-line
[プログラムの追加と削除] ダイアログ ボックスのリスト ボックスからコンポーネントが選択されたときに実行するコマンド ラインを指定します。.inf ファイル内のセクションを実行するには、Setupx.dll の InstallHinfSection エントリ ポイント (下記参照) を使用します。

次に示す AddReg セクション エントリの例では、[プログラムの追加と削除] ダイアログ ボックスのリスト ボックスに "My Test Application" を追加し、Test.inf の Remove_TestApp インストール セクションを実行します。

HKLM,SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Test,"DisplayName",,"My
Test Application"
HKLM,SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Test,"UninstallString",,"RunDll
setupx.dll,InstallHinfSection Remove_TestApp 4 test.inf"

注

  • コンポーネントのインストール時には、インストール スクリプトで .inf ファイルを Windows\Inf フォルダにコピーする必要があります。これは、Setupx.dll の InstallHinfSection エントリ ポイントの呼び出し時に検索される既定のディレクトリです。
  • Uninstall レジストリ キーの下層に作成したキーは、プログラムのアンインストール時にアンインストール スクリプトで削除し、そのプログラムが [プログラムの追加と削除] ダイアログ ボックスのリスト ボックスに表示されないようにする必要があります。


コンポーネント ダウンロード サービスに使用するサンプル .inf ファイル

;以下のサンプル .inf ファイルは、次のことを行います。
; - [Windows]、[System]、[Inf]、および [Help] フォルダにファイルをコピーします。
; - 多数のレジストリ エントリを作成します。
; (コピーしたファイルの名前を長いファイル名に変更するなど)
; - [ヘルプ] メニューにリンクを作成します。
; - コントロール パネルの [プログラムの追加と削除] ダイアログ ボックスに
; アンインストール アクションを登録するアンインストール セクションを追加します。
; - 他言語版を簡単に作成できるように、置換可能な文字列を使用します。
[Version]
Signature=$CHICAGO$
[DestinationDirs]
SampleCopy = 24,%PROGRAMF%\Sample
SampleDel = 24,%PROGRAMF%\Sample
SampleWinCopy = 25
SampleSysCopy = 11
SampleINFCopy = 17
SampleHLPCopy = 18
[DefaultInstall]
CopyFiles = SampleCopy, SampleWinCopy, SampleSysCopy, SampleINFCopy,
SampleHLPCopy AddReg = SampleRegisterApp, SampleRegUninstall,
SampleRenameFiles UpdateInis = SampleAddLinks
[RemoveSample]
DelFiles = SampleWinCopy, SampleSysCopy, SampleINFCopy, SampleHLPCopy
DelReg = SampleUnRegisterApp, SampleRegUninstall
AddReg = SampleRemoveLFNs
UpdateInis = SampleRemoveLinks
[SampleCopy]
sample.bmp
[SampleWinCopy]
sample.exe
[SampleSysCopy]
sample.dll
[SampleINFCopy]
sample.inf
[SampleHLPCopy]
sample.hlp
[SampleRegisterApp]
;任意のレジストリ エントリを作成します (Sample.exe の使用)。
HKLM,Software\Sample,Installed,,"1"
[SampleUnRegisterApp]
;レジストリ エントリを削除します (キー全体が削除されます)。
HKLM,Software\Sample
[SampleRegUninstall]
;プログラムをアンインストールするために、コントロール パネルの [プログラムの追加と削除] ダイアログ ボックスにエントリを追加します。
HKLM,SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Sample,"DisplayName",,"Sample
Application"
HKLM,SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Sample,"UninstallString",,"RunDll
setupx.dll,InstallHinfSection RemoveSample 4 sample.inf"
[SampleRenameFiles]
;8.3 形式のファイル名を長いファイル名に変更します。
HKLM,Software\Microsoft\Windows\CurrentVersion\RenameFiles\Sample,,,"%24%\%PROGRAMF%\Sample"
HKLM,Software\Microsoft\Windows\CurrentVersion\RenameFiles\Sample,sample.bmp,,"Sample
Bitmap.bmp"
[SampleRemoveLFNs]
;インストール中に、長いファイル名のファイルを削除します。
HKLM,Software\Microsoft\Windows\CurrentVersion\DeleteFiles\Sample,,,"%24%\%PROGRAMF%\Sample"
HKLM,Software\Microsoft\Windows\CurrentVersion\DeleteFiles\Sample,sample.bmp,,"Sample
Bitmap.bmp"
[SampleAddLinks]
;[スタート] メニューに Sample.exe へのショートカットを追加します。
setup.ini, progman.groups,, "Sample=%SampleFolder%" ;creates folder
setup.ini, Sample,, """%SampleDesc%"", %25%\SAMPLE.EXE" ;creates link
[SampleRemoveLinks]
;インストール中に、[スタート] メニューから Sample.exe へのショートカットを削除します。
setup.ini, progman.groups,, "Sample=%SampleFolder%" ;creates folder
setup.ini, Sample,, """%SampleDesc%""" ;deletes link
[SourceDisksNames]
99 = %DiskName%,Sample,0
[SourceDisksFiles]
sample.exe = 1,,13456
sample.dll = 1,,20987
sample.bmp = 1,,64098
sample.hlp = 1,,55441
sample.inf = 1,,5687
[Strings]
PROGRAMF = "PROGRA~1"
SampleFolder = "Samples"
SampleDesc = "Sample Application"
DiskName = "Sample Application Installation Disk"


セットアップ情報ファイル (.inf) の定義

基本的な .inf ファイルのセクションには、次のものがあります。複雑な .inf ファイルの場合は、このほかにもセクションを追加できます。下の説明で太字になっているのは予約語のセクション名です。斜体になっているのは任意に指定できるセクション名です。

  • Version セクション
  • インストール セクション
    • ファイルのコピー セクション (CopyFiles)
    • ファイルの名前変更セクション (RenFiles)
    • ファイルの削除セクション (DelFiles)
    • .ini ファイルの更新セクション (UpdateInis)
    • .ini フィールドの更新セクション (UpdateIniFields)
    • レジストリへの追加セクション (AddReg)
    • レジストリからの削除セクション (DelReg)
    • レジストリへの .ini ファイル追加セクション (Ini2Reg)
    • Config.sys の更新セクション (UpdateCfgSys)
    • Autoexec.bat の更新セクション (UpdateAutoBat)
  • DestinationDirs セクション
  • SourceDisksNames セクション
  • SourceDisksFiles セクション
  • Strings セクション
  • Optional Components セクション
Version | .inf ファイルの有効性をチェックするための基本的なバージョン情報。
[DefaultInstall] | 既定で実行されるインストール セクション。このセクションでは、コピーまたは削除の対象となるファイルを指定するセクションや、レジストリまたは .ini ファイルの更新を指定するセクションなど、ほかのセクションへの参照を定義します。
[OtherInstall] | [DefaultInstall] セクションと同じ形式で指定します。ただし、明示的に呼び出した場合にのみ実行されます。コンポーネントのアンインストール方法の定義などに使用します。
[DestinationDirs] | ファイルのコピー、削除、または名前変更を行うハード ディスク上のディレクトリ (\Windows や \Windows\System など) を指定します。
[FileCopy/Delete/RenameSection(s)] | コピー、削除、または名前変更の対象となるファイルを指定します。
[RegistryUpdateSection(s)] | レジストリ キーの追加または削除を指定します。
[IniFileUpdateSection(s)] | .ini ファイルの更新を指定します。このセクションには、リンクを作成します。
[SourceDisksNames] | ファイルが格納されているディスクを指定します。
[SourceDisksFiles] | 各ファイルが格納されているディスクのリストを指定します。
[Strings] | 使用するローカライズ文字列のリストを指定します。
ファイルの先頭に戻る

Version セクション

[Version]
Signature="$Chicago$"
LayoutFile=filename.inf
すべての Windows .inf ファイルに適用する標準ヘッダーを定義します。Windows で認識されるどのクラスのデバイスについても、署名 (Signature) には $Chicago$ を指定する必要があります。これ以外の値を指定した .inf ファイルは、.inf ファイルとして処理されません。

署名文字列では、大文字と小文字は区別されません。つまり、$Chicago$ の代わりに $CHICAGO$ と指定することもできます。

file name .inf
コンポーネントのインストールに必要なレイアウト情報 (コピー元のディスクとファイルに関する情報) を格納する .inf ファイルの名前を指定します。この行は省略可能です。省略する場合は、SourceDisksNames セクションおよび SourceDisksFiles セクションをこの .inf ファイル内に定義する必要があります。

一般的な Version セクションの例を次に示します。

Version
Signature="$CHICAGO$"
ファイルの先頭に戻る

インストール セクション

[install-section-name]

Copyfiles = file-list-section[,<file-list-section>]...
Renfiles = file-list-section[,file-list-section]...
Delfiles = file-list-section[,file-list-section]...
UpdateInis = update-ini-section[,update-ini-section]...
UpdateIniFields = update-inifields-section[,update-inifields-section]...
AddReg = add-registry-section[,add-registry-section]...
DelReg = del-registry-section[,del-registry-section]...
Ini2Reg = ini-to-registry-section[,ini-to-registry-section]...
UpdateCfgSys = update-config-section
UpdateAutoBat =update-autoexec-section

.inf ファイル内でコンポーネントのインストール情報が定義されているほかのセクションを示します。

インストール セクションでは、上の構文に示した項目タイプのうち、必要なものだけを使用できます。使用する項目タイプには、.inf ファイル内のセクション名を指定する必要があります。例外として、CopyFiles 項目の場合は、セクション名を指定する代りに @ 記号を付けてファイル名を指定し、個別のファイルをコピーすることもできます。セクション名は、印刷可能文字で記述する必要があります。

各インストール セクションに使用できる項目タイプ は 1 つだけです。1 つの項目に複数のセクション名を指定する場合は、セクション名をカンマで区切る必要があります。

install-section-name
インストール セクションに [DefaultInstall] という名前を付けると、.inf ファイルを右クリックし、[インストール] をクリックしたときに、そのインストール セクションが実行されます。また、Cabpack ウィザードで .inf ファイルをセットアップ オプションとして選択したときにも、このセクションが実行されます。

一般的なインストール セクションの例を次に示します。この例では、CopyFiles 項目と AddReg 項目を使用して、インストール対象のファイルに関する情報が定義されているセクションを指定します。

[MyApplication]
Copyfiles=MyAppWinFiles, MyAppSysFiles, @SRSutil.exe
AddReg=MyAppRegEntries

上の例では、[MyApplication] セクションの名前を [DefaultInstall] に変更して、inf ファイルを右クリックして [インストール] をクリックしたときに、このセクションが実行されるようにしています。

CopyFiles 項目では、特殊な表記法を使用して、コピー対象の各ファイルを直接指定することができます。個々のファイルを直接指定するには、ファイル名の直前に @ 記号を付けます。この方法で指定したファイルは、DestinationDirs セクションで定義した DefaultDestDir にコピーされます。個別のファイルを直接指定してコピーする例を次に示します。

CopyFiles=FileSection1,@myfile.txt,@anotherfile.txt,LastSectionName

ファイルの先頭に戻る

ファイルのコピー セクション (CopyFiles)

[CopyFiles-section-name]
destination-file-name[, source-file-name][,temporary-file-name][,flag]
[destination-file-name[,source-file-name][, temporary-file-name]][,flag]

コピー元ディスクからコピー先ディレクトリにコピーするファイル名のリストを指定します。各ファイルのコピー元ディスクとコピー先ディスクは、.inf ファイル内のほかのセクションで指定します。file-list-section name に指定するセクション名は、インストール セクションの CopyFiles 項目で定義する必要があります。

インストール セクション内で CopyFiles 項目を使う場合は、CopyFiles セクションを作成せずに個々のファイルを直接指定することもできます。個々のファイルを直接指定してコピーするには、ファイル名の先頭に @ 記号を付けます。CopyFiles タイプ項目で @ 記号を使用する例については、インストール セクションの説明を参照してください。ただし、この方法で個々のファイルをコピーする場合は、コピー元とコピー先のファイル名が同一である必要があり、一時ファイルを使用することはできません。

destination-file-name
コピー先ファイルの名前。コピー元ファイル名を省略すると、コピー先ファイル名はコピー元ファイル名としても使用されます。

source-file-name
コピー元ファイルの名前。コピー元ファイル名とコピー先ファイル名が同じ場合は、コピー元ファイル名を省略できます。

temporary-file-name
ファイルのコピー操作に使用する一時ファイルの名前。一時ファイル名を指定すると、インストーラでは、コピー元ファイルをその名前のファイルにコピーします。一時ファイル名は、この次にオペレーティング システムが起動したときにコピー先ファイル名に変更されます。この機能は、コピー先ファイルが現在開かれているか、または Windows で使用されている場合に使用できます。

flag
インストール処理中に特殊な操作を実行するための省略可能なパラメータ。複数の操作を実行する場合は、各操作に対応する値を加算して、一連の操作用のフラグを作成します。使用できる有効なフラグは、次のとおりです。

1 | CopyFiles の場合、ユーザーがファイルをスキップしようとしたときに警告を表示します。
1 | DelFiles の場合、 ファイルが使用中であれば、実行できない削除操作を Wininit.ini に入れます。このようにしないと、使用中のファイルは削除されません。
2 | セットアップに必要なファイル操作。 ユーザーがこのファイルをスキップできないようにします。
4 | バージョン チェックを無視し、常にファイルをコピーします。コピー先のファイルの方が新しくても、上書きされます。
8 | 強制的にファイル名を変更します。セットアップでは、このファイルを使用中のファイルと同様に扱います。これは、ユーザーのコンピュータに同じファイルが存在する場合にのみ該当します。
16 | ファイルがコピー先に既に存在する場合は、コピーを行いません。
32 | バージョンの不一致を示すダイアログ ボックスを表示せず、コピー先のファイルの方が新しい場合は上書きしません。

3 つのファイルをコピーする例を次に示します。

[CopyTheseFilesSec]
file11 ; copies file11
file21, file22, file23 ; copies file22, temporarily naming it file23
file31, file32 ; copies file32 to file31

この例では、すべてのコピー元ファイル名が SourceDisksFiles セクションで定義されており、SourceDisksFiles セクションで指定されている論理ディスク番号が SourceDisksNames セクションで定義されていることを前提としています。これらの情報は、Layout.inf ファイルで定義することもできます。

ファイルの先頭に戻る

ファイルの名前変更セクション (RenFiles)

[rename-files-section-name]
new-file-name, old-file-name
.
.
名前を変更するファイルのリストを指定します。セクション名は、.inf ファイルのインストール セクションの Renfiles 項目で定義する必要があります。

new-file-name
変更後のファイル名。

old-file-name
変更前のファイル名。

次の例では、file42 を file41 に、file52 を file51 に、file62 を file61 にそれぞれ変更します。

[RenameOldFilesSec]
file41, file42
file51, file52
file61, file62

この例では、変更前のファイル名 (file42、file52、および file62) がすべて SourceDisksFiles セクションで定義されており、SourceDisksFiles セクションで指定されている論理ディスク番号が SourceDisksNames セクションで定義されていることを前提としています。

ファイルの先頭に戻る

ファイルの削除セクション (DelFiles)

[ file-list-section]
file-name[,,,flag]
.
.
DelFiles セクションには、削除するファイルの名前のリストを指定します。file-list-section に指定するセクション名は、インストール セクションの Delfiles 項目で定義する必要があります。

file-name
削除するファイルを指定します。

flag
インストール時にファイルが使用中の場合に、ファイルを強制的に削除するように指定するための省略可能なパラメータ。コンピュータが再起動されるまでファイルの削除操作を待ち行列に入れるように Windows に指示するには、flag パラメータを 1 に設定します。flag パラメータを 1 に設定したファイルが使用中のため削除できない場合は、デバイスのインストールが完了してからコンピュータが再起動されます。

file-name パラメータで指定したファイルに対して flag パラメータを 1 に設定していない場合は、DelFiles セクションの実行時にそのファイルが使用中の場合には、そのファイルはコンピュータから削除されません。

3 つのファイルを削除する例を次に示します。

[DeleteOldFilesSec]
file1
file2
file3

ファイルの先頭に戻る

.ini ファイルの更新セクション (UpdateInis)

[ update-ini-section-name]
ini-file, ini-section, [old-ini-entry], [new-ini-entry], [flags]
.
.
指定された .ini ファイルで、個々のエントリ全体の置換、削除、または追加を行います。update-ini-section-name に指定するセクション名は、.inf ファイルのインストール セクションの UpdateInis 項目で定義する必要があります。

ini-file
変更するエントリが含まれている .ini ファイルの名前。.ini ファイルの名前の指定方法については、下の説明を参照してください。

ini-section
変更するエントリが含まれている セクションの名前。

old-ini-entry
省略可能。通常は、Key=Value の形式で指定します。

new-ini-entry
省略可能。通常は、Key=Value の形式で指定します。キーと値のどちらかに、置換可能な文字列を指定できます。たとえば、.inf ファイルの Strings セクションで %String1% を置換する値を定義し、new-ini-entry パラメータでキーと値のどちらかに %String1% を指定することができます。

flags
省略可能な操作フラグ。次の値のいずれかを指定できます。

0 | 既定値。.ini ファイルのエントリのうち、old-ini-entry と同じキーが含まれているエントリがあれば new-ini-entry に置換します。この設定では、.inf ファイルのエントリと old-ini-entry パラメータの間でキーが一致しているだけでよく、各エントリの値は無視されます。 .ini ファイルに new-ini-entry を無条件で追加するには、old-ini-entry を Null に設定します。.ini ファイルから old-ini-entry を無条件で削除するには、new-ini-entry を Null に設定します。
1 | .ini ファイルのエントリのうち、キーと値の両方が old-ini-entry に一致するエントリがあれば new-ini-entry に置換します。この設定では、old-ini-entry パラメータと .ini ファイルのエントリの間でキーと値の両方が一致していなければなりません。フラグを 0 に設定した場合にはキーが一致するかどうかだけがチェックされましたが、この場合はキーと値の両方がチェックされることに注意してください。
2 | old-ini-entry パラメータと同じキーのエントリが .ini ファイルに含まれていなければ、置換操作を行いません。 old-ini-entry パラメータと同じキーのエントリが .ini ファイル内に存在し、また、new-ini-entry パラメータと同じキーのエントリが .ini ファイル内に存在する場合は、後者のエントリが削除され、前者のエントリのキーが new-ini-entry パラメータのキーに置換されます。old-ini-entry パラメータと同じキーのエントリが .ini ファイル内に存在し、new-ini-entry パラメータと同じキーのエントリが .ini ファイル内に存在しない場合は、新しいエントリが .ini ファイルに追加されます。 この新しいエントリは、old-ini-entry パラメータと同じキーのエントリの値と new-ini-entry パラメータのキーを組み合わせたものとなります。 old-ini-entry パラメータと .ini ファイル エントリの間では、値はチェックされず、キーが一致するかどうかだけがチェックされます。
3 | old-ini-entry パラメータと .ini ファイル エントリの間でキーと値の両方が一致するかどうかをチェックします。それ以外は、2 に設定した場合と同じ処理を行います。

キーおよび値を指定するときは、アスタリスク (*) をワイルドカード文字として使用できます。ワイルドカードは正しく解釈されます。

ini-file 名には、文字列または文字列キーを指定できます。.inf ファイル内の Strings セクションで定義した値を strkey とすると、文字列キーは %strkey% の形式をとります。いずれの場合も、有効なファイル名を指定する必要があります。

名前にはファイルが格納されているフォルダの名前を含める必要がありますが、フォルダ名は、実際の名前ではなく論理ディレクトリ識別子 (LDID) として指定する必要があります。LDID は、インストール時にインストーラによって実際の名前に置換されます。

定義済みの識別子のいずれか、または DestinationDirs セクションで定義した識別子を ldid とすると、LDID は %ldid% の形式をとります。定数 LDID_BOOT および LDID_BOOTHOST の置換時には、パスに円記号 (\) が付加されます。たとえば、LDID_BOOT は C:\ などに置換されます。ただし、.inf ファイル内で円記号 (\) を使用するかどうかは任意です。たとえば、起動ドライブ上の BOOT.ini を参照する場合は、"%30%boot.ini" と指定することも、"%30%\boot.ini" と指定することもできます。

.ini ファイルの更新セクションに指定した個々の項目の例を次に示します。

%11%\sample.ini, Section1,, Value1=2 ; adds new entry
%11%\sample.ini, Section2, Value3=*, ; deletes old entry
%11%\sample.ini, Section4, Value5=1, Value5=4 ; replaces old entry

.inf ファイル内の .ini ファイルを更新するタイプのセクションで、SYSTEM.ini の Boot セクションを操作する項目の一覧を下に示します。"comm.drv=comm.drv" エントリを Boot セクションに追加するときには、.inf ファイル項目の flags パラメータによる条件指定が適用されます。ただし、"comm.drv=*vcoscomm.drv" エントリまたは "comm.drv=*r0dmdcom.drv" エントリが Boot セクション内に既に存在する場合は、既存のエントリが維持され、"comm.drv=comm.drv" エントリは .ini ファイルに追加されません。つまり、下に示す 4 つの .inf ファイル エントリを実行すると、.ini ファイル内の Boot セクションの "comm.drv=" エントリは、"comm.drv=*vcoscomm.drv"、"comm.drv=*r0dmdcom.drv"、"comm.drv=comm.drv" のいずれかになります。

system.ini, boot, "comm.drv=*vcoscomm.drv","~CommDrvTemp~=*", 3
system.ini, boot, "comm.drv=*r0dmdcom.drv","~CommDrvTemp~=*", 3
system.ini, boot,,"comm.drv=comm.drv"
system.ini, boot, "~CommDrvTemp~=*","comm.drv=*", 3

ファイルの先頭に戻る

.ini フィールドの更新セクション (UpdateIniFields)

[ update-inifields-section-name ]
ini-file, ini-section, profile-name, [old-field], [new-field],[flags]
.
.
指定された .ini エントリに対して、値のフィールドの置換、削除、または追加を行います。.ini ファイルを更新するタイプのセクションとは異なり、このタイプのセクションでは、.ini ファイル内の個々のエントリの全体ではなく、一部に対して、置換、追加、または削除を実行します。セクション名 update-inifields-section-name は、.inf ファイル内のインストール セクションの UpdateIniFields 項目で定義する必要があります。

ini-file
変更対象のエントリが含まれている .ini ファイルの名前。.ini ファイル名の指定方法については、.ini ファイルを更新するタイプのセクションの説明を参照してください。

ini-section
変更対象のエントリが含まれている .ini ファイル セクションの名前。

profile-name
変更対象のエントリ名。

old-field
削除するフィールド値。

new-field
既存のフィールド値がない場合に追加するフィールド値。

flags
old-field パラメータおよび new-field パラメータでアスタリスク (*) をワイルドカード文字として扱うかどうかを指定したり、.ini ファイル エントリの末尾に新しいフィールドを追加するときに使う区切り文字を指定します。次の値のいずれかを指定できます。

値 | 意味
0 | (既定値)。フィールドを比較するときに、アスタリスク (*) をワイルドカード文字ではなくリテラル文字として扱います。エントリに新しいフィールドを追加するときに、スペース ( ) を区切り文字として使います。
1 | フィールドを比較するときに、アスタリスク (*) をワイルドカード文字として扱います。エントリに新しいフィールドを追加するときに、スペース ( ) を区切り文字として使います。
2 | フィールドを比較するときに、アスタリスク (*) をワイルドカード文字ではなくリテラル文字として扱います。エントリに新しいフィールドを追加するときに、カンマ (,) を区切り文字として使います。
3 | フィールドを比較するときに、アスタリスク (*) をワイルドカード文字として扱います。エントリに新しいフィールドを追加するときに、カンマ (,) を区切り文字として使います。

変更後には .ini ファイル内の既存のコメントが実際の設定に対応しなくなる可能性があるため、対象となる行に付加されているコメントは削除されます。この .ini ファイル行に含まれるフィールドを処理するときは、スペース、タブ、およびカンマがフィールド区切り文字として使用されます。ただし、行の末尾に新しいフィールドを追加するときには、スペースが区切り文字として使われます。

ファイルの先頭に戻る

レジストリへの追加セクション (AddReg)

[ add-registry-section]
reg-root-string, [subkey], [value-name], [flag], [value]
[reg-root-string, [subkey], [value-name], [flag], [value]]
.
.
レジストリにサブキーまたは値の名前を追加します。必要に応じて値を設定できます。add-registry-section に指定するセクション名は、インストール セクションの AddReg タイプ項目で定義する必要があります。

reg-root-string
ルートとなるレジストリ キーの名前。次の値のいずれかを指定できます。

HKCR: ルート キーとして HKEY_CLASSES_ROOT を指定します。
HKCU: ルート キーとして HKEY_CURRENT_USER を指定します。
HKLM: ルート キーとして HKEY_LOCAL_MACHINE を指定します。
ルート キーとして HKEY_USERS を指定します。
HKR: GenInstallEx に渡したキーをルート キーとして指定します。

subkey
省略可能。設定するサブキーを指定します。key1\key2\key3.... の形式をとります。このパラメータは、置換可能な文字列として表すことができます。たとえば、このパラメータに %Subkey1% という置換可能文字列を指定し、%Subkey1% に置き換わる実際の文字列を .inf ファイルの Strings セクションに定義することができます。

value-name
省略可能。subkey の値の名前を指定します。文字列型の値の場合、the value-name パラメータを省略すると、subkey パラメータで指定したサブキーの値は Null に設定されます。なお、value-name パラメータは、置換可能な文字列として表すことができます。たとえば、このパラメータに %Valname1% という置換可能文字列を指定し、%Valname1% に置き換わる実際の文字列を .inf ファイルの Strings セクションに定義することができます。

flag
省略可能。値の型を指定すると共に、既存のレジストリ キーを置き換えるかどうかを指定します。

値 | 意味
0 | (既定値)。ANSI 文字列の値を指定します。既存のキーを置き換えます。
1 | 16 進値を指定します。既存のキーを置き換えます。
2 | ANSI 文字列の値を指定します。既存のキーを置き換えません。
3 | 16 進値を指定します。既存のキーを置き換えません。

value
省略可能。設定する値を指定します。ANSI 文字列か、または Intel フォーマットの 16 進値を指定できます。バイナリ値を含む項目の長さが 1 行あたり 128 バイトの制限を超える場合は、円記号 (\) で改行できます。strkey% の形式の文字列キーも指定できます。 strkey は、.inf ファイルの Strings セクションで定義する必要があります。行の中で % をリテラル文字として使うには、「%%」と入力します。

少なくとも 2 つのフィールドが必要ですが、いずれかを Null にすることができます。したがって、この形式を使うときは、少なくとも 1 つのカンマが必要です。

次に示す AddReg タイプのセクションの例では、2 つの項目を指定して、2 つの値の名前をレジストリに追加します。%25% は、コンピュータ上の Windows フォルダに展開されます。

[MyAppRegEntries]
HKLM,Software\MyApp,ProgramName,,"My Application"
HKLM,Software\MyApp,"Program Location",,"%25%\MyApp.exe"

ファイルの先頭に戻る

レジストリからの削除セクション (DelReg)

[ del-registry-section]
reg-root-string, subkey, [value-name]
[reg-root-string, subkey, [value-name]]
.
.
レジストリからサブキーまたは値の名前を削除します。del-registry-section に指定するセクション名は、インストール セクションの DelReg 項目で定義する必要があります。

reg-root-string
ルートとなるレジストリ キーの名前。次の値のいずれかを指定できます。

HKCR: ルート キーとして HKEY_CLASSES_ROOT を指定します。
HKCU: ルート キーとして HKEY_CURRENT_USER を指定します。
HKLM: ルート キーとして HKEY_LOCAL_MACHINE を指定します。
ルート キーとして HKEY_USERS を指定します。
HKR: GenInstallEx に渡したキーをルート キーとして指定します。

subkey
削除するサブキーを指定します。key1\key2\key3... の形式をとります。このパラメータは、置換可能な文字列として表すことができます。たとえば、このパラメータに %Subkey1% という置換可能文字列を指定し、%Subkey1% に置き換わる実際の文字列を .inf ファイルの Strings セクションに定義することができます。

value-name
省略可能。subkey の値の名前を指定します。なお、value-name パラメータは、置換可能な文字列として表すことができます。たとえば、このパラメータに %Valname1% という置換可能文字列を指定し、%Valname1% に置き換わる実際の文字列を .inf ファイルの Strings セクションに定義することができます。

このタイプのセクションには、任意の数の項目を指定できます。それぞれの項目では、サブキーまたは値の名前を 1 つずつレジストリから削除します。

レジストリへの .ini ファイル追加セクション (Ini2Reg)

[ ini-to-registry-section]
ini-file, ini-section, [ini-key], reg-root-string, subkey[,flags]
.
.
.ini ファイル内の行やセクションをレジストリに移動し、指定されたレジストリ キーの下層でレジストリ エントリの作成または置換を行います。ini-to-registry-section に指定するセクション名は、.inf ファイルのインストール セクションの Ini2Reg 項目で定義する必要があります。

ini-file
コピーするキーが含まれている .ini ファイルの名前。.ini ファイル名の指定方法については、.ini ファイルの更新セクションの説明を参照してください。

ini-section
コピーするキーが含まれている .ini ファイル セクションの名前。

ini-key
レジストリにコピーする .ini ファイル キーの名前。ini-key を省略すると、セクション全体がレジストリ キーに転送されます。

reg-root-string
ルートとなるレジストリ キーの名前。次の値のいずれかを指定できます。

HKCR: ルート キーとして HKEY_CLASSES_ROOT を指定します。
HKCU: ルート キーとして HKEY_CURRENT_USER を指定します。
HKLM: ルート キーとして HKEY_LOCAL_MACHINE を指定します。
ルート キーとして HKEY_USERS を指定します。
HKR: GenInstallEx に渡したキーをルート キーとして指定します。

subkey
値の転送先のサブキーを指定します。key1\key2\key3... の形式をとります。

flags
レジストリに転送した .ini キーを .ini ファイルから削除するかどうかを指定すると共に、レジストリ内の既存の値を上書きするかどうかを指定します。次の値のいずれかを指定できます。

値 | 意味
0 | (既定値)。レジストリに .ini エントリの情報を移動した後、.ini エントリを .ini ファイルから削除しません。対応するレジストリ サブキーが既に存在する場合は、現在の値を上書きしません。
1 | レジストリに .ini エントリの情報を移動した後、.ini エントリを .ini ファイルから削除します。対応するレジストリ サブキーが既に存在する場合は、現在の値を上書きしません。
2 | レジストリに .ini エントリの情報を移動した後、.ini エントリを .ini ファイルから削除しません。対応するレジストリ サブキーが既に存在する場合は、現在の値を .ini ファイル エントリの値で上書きします。
3 | レジストリに .ini エントリの情報を移動した後、.ini エントリを .ini ファイルから削除します。対応するレジストリ サブキーが既に存在する場合は、現在の値を .ini ファイル エントリの値で上書きします。
たとえば、Win.ini ファイルに次のようなエントリがあると想定します。
[Windows]
CursorBlinkRate=15

Control Panel\Desktop キーの下層に CursorBlinkRate サブキーが存在しない場合は、Ini File to Registry セクションの次の項目をレジストリへの .ini ファイル追加セクション内に指定すると、Control CursorBlinkRate サブキーが作成され、その値が 15 に設定されます。WIN.ini ファイル内の .ini エントリはそのまま維持されます。

win.ini,Windows,CursorBlinkRate,HKCU,"Control Panel\Desktop"

CursorBlinkRate サブキーが既に存在している場合は、このサブキーの値が 15 に設定され、WIN.ini ファイル内の .ini エントリはそのまま維持されます。

Config.sys の更新セクション (UpdateCfgSys)

[ update-config-section]
Buffers=legal-dos-buffer-value
DelKey=key
DevAddDev=driver-name,configkeyword[,flag][,param-string]
DevDelete=device-driver-name
DevRename=current-dev-name,new-dev-name
Files=legal-dos-files-value
PrefixPath=ldid[,ldid]
RemKey=key
Stacks=dos-stacks-values

Config.sys ファイルに対して、コマンドの追加、削除、または名前変更を行います。update-config-section-name に指定するセクション名は、.inf ファイルのインストール セクションの UpdateConfigSys 項目で定義する必要があります。

上の構文に示した項目のうち、必要なものだけを使用できます。Config.sys の更新セクションでは、DevRename、DevDelete、DevAddDev、DelKey、および RemKey の各項目は必要に応じて繰り返し指定できますが、Buffers、Files、および Stacks の各項目は 1 回しか指定できません。Config.sys の更新セクションを処理するとき、インストーラでは、まず最初に DevRenames 項目が処理され、次に DevDelete 項目、最後に DevAddDev 項目が処理されます。Config.sys の更新セクションに指定できる各項目タイプの構文と意味については、このトピックで後述します。

Buffers 項目

Buffers=legal-dos-buffer-value
ファイル バッファ数を設定します。Stacks 項目の場合と同様に、インストーラでは、既存の値を指定値と比較し、2 つの値のうち大きい方の値をファイル バッファ数として適用します。

legal-dos-buffers-value
MS-DOS でサポートされている有効範囲内の Buffers 値。

DelKey 項目

DelKey=key
指定したキーに一致する Config.sys コマンドを Config.sys ファイル内でコメント アウトします。たとえば、

DelKey=Break

と指定すると、Break=on コマンドが Config.sys ファイル内にコメント アウトされます。

DelKey 項目は、RemKey 項目と同じ結果を生成します。DelKey 項目と RemKey 項目は、.inf ファイルのセクション内で必要に応じて繰り返し指定できます。

key
コメント アウトする Config.sys コマンドのキー。

DevAddDev 項目

DevAddDev=driver-name,configkeyword[,flag][,param-string]
device コマンドまたは install コマンドを CONFIG.SYS ファイルに追加します。

driver-name
追加するドライバまたは実行可能ファイルの名前。インストーラでは、拡張子が .sys または .exe のファイル名を有効なファイル名として受け付けます。

configkeyword
コマンド名。device または install のいずれかです。

flag
コマンドの位置を示す省略可能なフラグ。0 に設定すると、コマンドはファイルの末尾に配置されます。1 に設定すると、コマンドはファイルの先頭に配置されます。フラグを省略すると、既定値の 0 が適用されます。

param-string
省略可能なコマンド パラメータ。デバイス ドライバまたは実行可能ファイルでサポートされているパラメータを指定する必要があります。

DevDelete 項目

DevDelete=device-driver-name
指定したファイル名が含まれている行を Config.sys ファイルから削除します。

device-driver-name
ファイルまたはデバイス ドライバの名前。インストーラでは、この名前が含まれる行を Config.sys ファイル内で検索し、見つかった行を削除します。MS-DOS の Config.sys では暗黙的なファイル名拡張子はサポートされていないため、device-driver-name に指定する各ファイル名には拡張子を明示的に付加する必要があります。

Config.sys の更新セクションの DevDelete 項目の例を次に示します。この例では、サンプル Config.sys ファイルから行 1 と行 3 を削除し、行 2 は削除しません。

DevDelete=filename.sys
;; lines in Config.sys
Device=Filename.sys ;; line #1
Install=Filename.exe ;; line #2
Device=Filename.sys /d:b800 /I:3 ;; line #3

DevRename 項目

DevRename=current-dev-name,new-dev-name
Config.sys ファイル内のデバイス ドライバの名前を変更します。

current-dev-name
名前変更の対象となるデバイス ドライバまたは実行可能ファイルの名前。インストーラでは、Config.sys ファイル内の行のうち、右側にこの名前が指定されている device コマンドまたは install コマンドを検索します。

new-dev-name
ドライバまたは実行可能ファイルの新しい名前。

Files 項目

Files=legal-dos-files-value
Config.sys ファイル内の Files (同時に開くことができるファイル数) の値を設定します。Stacks 項目の場合と同様に、インストーラでは、既存の値を指定値と比較し、2 つの値のうち大きい方の値を、同時に開くことのできるファイル数の上限として適用します。

legal-dos-files-value
MS-DOS でサポートされている有効範囲内の Files 値。

PrefixPath 項目

PrefixPath=ldid[,ldid]...
指定した LDID に関連付けられているパスを path コマンドに追加します。

ldid
定義済みの LDID のいずれかか、.inf ファイル内で定義した新しい値を指定します。定義済みの LDID の値の一覧については、DestinationDirs セクションの説明を参照してください。

RemKey 項目

RemKey=key
指定したキーに一致する Config.sys コマンドを Config.sys ファイル内でコメント アウトします。たとえば、

RemKey=Break

と指定すると、Break=on コマンドが Config.sys ファイル内にコメント アウトされます。

RemKey 項目は、DelKey 項目と同じ結果を生成します。RemKey 項目と DelKey 項目は、.inf ファイルのセクション内で必要に応じて繰り返し指定できます。

key
コメント アウトする Config.sys コマンドのキー。

Stacks 項目

Stacks=dos-stacks-values
Config.sys ファイル内の Stacks (スタックの数とサイズ) の値を設定します。インストーラでは、既存の値を指定値と比較し、2 つの値のうち大きい方の値を Stacks の値として適用します。たとえば、Config.sys ファイル内の設定が stacks=9,218 で、.inf ファイル内の設定が stacks=5,256 の場合は、stacks=9,218 が適用されます。

legal-dos-stacks-value
MS-DOS でサポートされている有効範囲内の Stacks 値。

ファイルの先頭に戻る

Autoexec.bat の更新セクション (UpdateAutoBat)

[ update-autoexec-section]
CmdAdd=command-name[,command-parameters]
CmdDelete=command-name
PrefixPath=ldid[,ldid]
RemOldPath=ldid[,ldid]
TmpDir=ldid[,subdir]
UnSet=env-var-name

Autoexec.bat ファイル内の行を操作します。update-autoexec-section-name に指定するセクション名は、.inf ファイルのインストール セクションの UpdateAutoBat 項目で定義する必要があります。

Autoexec.bat の更新セクションでは、上の構文に示した項目のうち、必要なものだけを使用できます。CmdAdd、CmdDelete、および UnSet の各項目はセクション内で必要に応じて繰り返し指定できますが、PrefixPath、RemOldPath、および TmpDir の各項目は .inf ファイル内で 1 回しか指定できません。Autoexec.bat の更新セクションに指定できる各項目タイプの構文と意味については、このトピックで後述します。

インストーラでは、CmdDelete 項目を処理してから、CmdAdd 項目を処理します。

CmdAdd 項目

CmdAdd =command-name[,"command-parameters"]
指定したコマンドを Autoexec.bat ファイルの末尾に追加します。必要に応じて、コマンド パラメータを指定することもできます。

command-name
実行可能ファイルの名前。拡張子を付けるかどうかは任意です。指定したファイル名が .inf ファイルの SourceDisksFiles セクションおよび DestinationDirs セクションでも定義されている場合には、適切なパスを付加したファイル名が Autoexec.bat ファイルに書き込まれます。

command-parameters
文字列を二重引用符で囲んで指定するか、%String1% や %Myparam% などの置換可能な文字列を指定します。これらの置換可能な文字列を置き換える実際の文字列は、.inf ファイルの Strings セクションで定義します。インストーラでは、この文字列を command-name の末尾に付加した上で、Autoexec.bat ファイルの最後の行にコマンドを追加します。この行の形式は、指定した実行可能ファイルのコマンド ライン構文に依存します。

CmdDelete 項目

CmdDelete=command-name
Autoexec.bat ファイル内の行のうち、指定したコマンド名が含まれている行を削除します。インストーラでは、指定したファイル名のうち .exe、.com、.bat のいずれかの拡張子が付いたファイル名が含まれる行を検索し、見つかった行を削除します。

command-name
実行可能ファイルの名前を拡張子なしで指定します。

PrefixPath 項目

PrefixPath=ldid[,ldid]...
指定した LDID に関連付けられているパスを path コマンドに追加します。

ldid
定義済みの LDID のいずれかか、.inf ファイル内で定義した新しい値を指定します。定義済みの LDID の値の一覧については、DestinationDirs セクションの説明を参照してください。

RemOldPath 項目

RemOldPath=ldid[,ldid]
指定した LDID に関連付けられているパスを path コマンドから削除します。たとえば、古いバージョンの Windows が C:\Windows にインストールされているコンピュータで、新しいバージョンの Windows を C:\Newwin にインストールする場合は、次の .inf ファイル項目を指定すると、path 環境変数から C:\Windows が削除されます。

RemOldPath=10
ldid
定義済みの LDID のいずれかか、.inf ファイル内で定義した新しい値を指定します。定義済みの LDID の値の一覧については、DestinationDirs セクションの説明を参照してください。

TmpDir 項目

TmpDir=ldid[,subdir]
指定した LDID に対応するフォルダ内に一時フォルダを作成します (まだ作成されていない場合)。

ldid
定義済みの LDID のいずれかか、.inf ファイル内で定義した新しい値を指定します。定義済みの LDID の値の一覧については、DestinationDirs セクションの説明を参照してください。

subdir
パス名。ldid\subdir が存在しない場合は、作成されます。

UnSet 項目

UnSet=env-var-name
Autoexec.bat ファイル内の set コマンドのうち、指定した環境変数名が含まれているものを削除します。

env-var-name
環境変数の名前。

ファイルの先頭に戻る

DestinationDirs セクション

[DestinationDirs]
file-list-section =ldid[, subdir ]
.
.
[DefaultDestDir=ldid[, subdir ]]

DestinationDirs セクションでは、file-list sections に指定したセクション (CopyFiles、RenFiles、または DelFiles) による操作の対象となるディレクトリを定義します。また、DestinationDirs では、.inf ファイルの CopyFiles、RenFiles、DelFiles の各セクションの名前を明示的に指定せずに、これらのセクションによる操作に使用する既定のフォルダを指定することもできます。

file-list-section
Name of a CopyFiles, RenFiles, or DelFiles section. この名前は、インストール セクション内の CopyFiles、RenFiles、DelFiles の各項目から参照する必要があります。

ldid
論理ディスク識別子 (LDID)。次の値のいずれかを指定できます。

00 | Null LDID － 新しい LDID の作成用
01 | コピー元ドライブ : \pathname
10 | マシン フォルダ (サーバーベースのセットアップ時に Windows フォルダにマッピングされます)
11 | System フォルダ
12 | IOSubsys フォルダ
13 | Command フォルダ
17 | Inf フォルダ
18 | Help フォルダ
20 | Fonts フォルダ
21 | Viewers フォルダ
22 | VMM32
23 | Color フォルダ
24 | Windows フォルダが格納されているドライブのルート
25 | Windows フォルダ
26 | Windows 用の保証起動デバイス (Winboot)
28 | ホストの Winboot
30 | 起動ドライブのルート フォルダ
31 | ホストの仮想起動ドライブのルート フォルダ

subdir
指定した LDID に対応するフォルダ内でコピー先となるサブフォルダ。

DestinationDirs セクションでは、必要に応じて DefaultDestDir 項目を使用できます。この項目を使うと、CopyFiles 項目で @ を付加したファイル名を直接指定してコピーする場合や、名前を明示的に指定していない CopyFiles セクション、RenFiles セクション、または DelFiles セクションの場合に適用する既定のコピー先ディレクトリを定義できます。DestinationDirs セクションで DefaultDestDir 項目を定義していない場合は、LDID_WIN が既定のディレクトリとして使用されます。

次の例では、MoveMiniPort セクションのコピー先のフォルダを Windows\Iosybsys に設定し、その他のセクションの既定のフォルダを起動ドライブ上の Bin フォルダに設定します。

[DestinationDirs]
MoveMiniPort=12 ; Destination for MoveMiniPort section is
; windows\iosubsys
DefaultDestDirs=30,bin ; Direct copies go to boot:\bin

ファイルの先頭に戻る

SourceDisksNames セクション

[SourceDisksNames]
disk-ordinal="disk-description",disk-label,disk-serial-number
.
.
ファイルのコピーまたは名前変更操作用のコピー元ファイルが格納されているディスクを指定します。

disk-ordinal
コピー元ディスクを一意に識別する番号。複数のコピー元ディスクがある場合は、各ディスクに一意な連番を割り当てる必要があります。

disk-description
ディスクの内容や目的を説明する文字列または文字列キー。インストーラでは、この文字列をユーザーに表示して各ディスクを識別します。説明文字列は、二重引用符で囲みます。

disk-label
コピー元ディスクのフォーマット時に設定されたボリューム ラベル。

disk-serial-number
現在のリリースでは使用されていません。0 に設定する必要があります。

1 つのコピー元ディスクを指定する例を次に示します。この例では、ディスクの説明として文字列キーを使用します。

[SourceDisksNames]
55 = %ID1%, Instd1, 0
[Strings]
ID1="My Application Installation Disk 1"

ファイルの先頭に戻る

SourceDisksFiles セクション

[SourceDisksFiles]
file name=disk-number[,subdir] [,file-size]
.
.
インストール中に使用するコピー元ファイルの名前を指定し、ファイルが格納されているコピー元ディスクを識別します。

color=#000000file name
コピー元ディスクに格納されているファイルの名前。

disk-number
ファイルが格納されているコピー元ディスクの連番。この連番は、SourceDisksNames セクションで定義します。各ディスクには、1 以上の連番を割り当てる必要があります。0 を指定することはできません。

subdir
コピー元ディスク上でファイルが格納されているサブフォルダを指定します (省略可能)。このパラメータを省略すると、コピー元ディスクのルート フォルダが既定のフォルダとして使用されます。

file-sizeファイルのサイズをバイト単位で指定します (省略可能)。

SourceDisksFiles セクションの例を次に示します。この例では、連番 1 のディスクに格納されている単一のコピー元ファイル (SRS01.386) を指定します。

[SourceDisksFiles]
SRS01.386 = 1

ファイルの先頭に戻る

Strings セクション

[Strings]
strings-key=value
.
.
1 つまたは複数の文字列キーを定義します。文字列キーは、印刷可能文字で構成される文字列を表す名前です。Strings セクションは一般に .inf ファイルの末尾に記述しますが、このセクションで定義した文字列キーは、同じ .inf ファイル内のどのセクションでも使用できます。インストーラでは、文字列キーを指定された文字列に展開し、それ以降の処理に使用します。文字列キーは、パーセント記号 (%) で囲む必要があります。

strings-key
文字列の一意の名前を英数字で記述します。

value
文字列を英数字やその他の印刷可能文字で記述します。二重引用符が必要なセクションで使用する文字列キーの場合は、ここに指定する文字列を二重引用符で囲む必要があります。

.inf ファイルの単一のセクションで .inf ファイルが使用されるとき、ユーザー側に表示できるすべての文字列を置換することにより、Strings セクションを使うと、ユーザー インターフェイスに表示される文字列をローカライズしやすくなります。文字列は、なるべくリテラルではなく文字列キーとして指定してください。

Strings セクションの例を次に示します。

[Strings]
String0="My Application"
String1="My Application Readme File"
String2="CX2590 SCSI Adapter"

ファイルの先頭に戻る

Optional Components セクション

[Optional Components]
install-section-name
[install-section-name]
.
.
インストール セクションのリストを指定します。これらのインストール セクションは、ユーザーがコントロール パネルの [プログラムの追加と削除] をクリックし、[Windows ファイル] タブの [ディスク使用] をクリックしたときに表示されます。インストール セクションの一覧には、それぞれのインストール セクションに対応するチェック ボックスが表示されます。

Optional Components セクションは、.inf ファイルを右クリックし、[インストール] を選択して .inf ファイルを実行した場合には無視されます。この方法で .inf ファイルを実行すると、[DefaultInstall] セクションが実行されます。また、Setupx.dll の InstallHinfSection エントリ ポイントを経由して .inf ファイルを実行した場合にも、Optional Components セクションは無視されます。SETUPX エントリ ポイントを経由して .inf ファイルを実行すると、エントリ ポイントへのパラメータに指定した インストール セクションが実行されます。

インストール セクションは、前述した形式で定義してください。また、次のキーを インストール セクションに追加すると、[ディスク使用] ダイアログ ボックスのインターフェイスを制御することができます。

OptionDesc=option-description
Tip=tip-description
InstallDefault=0 | 1 ; Whether to install this component by default.1=Yes, 0=No.
IconIndex=icon-index
Parent= install-section-name
Needs=install-section-name, [install-section-name]
Include=inf-file, [inf-file]

option-description
リスト ボックスにコンポーネント名として表示する文字列。option-description パラメータには、%String1% などの置換可能な文字列を指定できます。%String1% を置き換える実際の文字列は、.inf ファイルの Strings セクションで定義します。

tip-description
コンポーネントがリスト ボックス内で選択されたときに [説明] ボックスに表示する文字列。tip-description パラメータに指定する文字列の長さは、255 文字以内に制限されます。このパラメータには、%String1% などの置換可能な文字列を指定できます。 %String1% に置き換わる実際の文字列は、.inf ファイルの Strings セクションで定義します。

icon-index
コンポーネント名の横に表示するミニアイコンを示す数値。有効な値は、次のとおりです。
0 － マシン (本体とディスプレイ) のアイコン
1 － 集積回路チップのアイコン
2 － ディスプレイのアイコン
3 － ネットワーク回線のアイコン
4 － Windows の旗のアイコン
5 － マウスのアイコン
6 － キーボード (3 つのキー) のアイコン
7 － 電話のアイコン
8 － スピーカーのアイコン
9 － ハード ディスクのアイコン
10 － 通信ポート コネクタのアイコン
11 － ひし形のアイコン (既定値)
12 － オン状態のチェック ボックスのアイコン
13 － オフ状態のチェック ボックスのアイコン
14 － プリンタのアイコン
15 － ネットワーク カードのアイコン
16 － 0 と同じ
17 － 0 と同じ絵の下に握手する手を示すアイコン
18 － 疑問符のアイコン
19 － ロゴのアイコン
20 － 淡色表示のチェック ボックス
21 － ダイヤルアップ ネットワークのアイコン
22 － ケーブル接続のアイコン
23 － ブリーフケースのアイコン
24 － Exchange のアイコン
25 － パーシャル チェックのアイコン
26 － アクセサリ グループのアイコン
27 － マルチメディア グループのアイコン
28 － クイック ビューアのアイコン
29 － MSN のアイコン
30 － 電卓のアイコン
31 － Defrag のアイコン
32 － 一般的な文書のアイコン
33 － ドライブスペースのアイコン
34 － ソリティアのアイコン
35 － ハイパー ターミナルのアイコン
36 － オブジェクト パッケージャのアイコン
37 － ペイントのアイコン
38 － スクリーン セーバーのアイコン
39 － ワードパッドのアイコン
40 － クリップボード ビューアのアイコン
41 － ユーザー補助のアイコン
42 － バックアップのアイコン
43 － ビットマップ ドキュメントのアイコン
44 － 文字マップのアイコン
45 － マウス ポインタのアイコン
46 － ネット ウォッチャー のアイコン
47 － ダイヤラのアイコン
48 － システム モニタのアイコン
49 － ヘルプ ブックのアイコン
50 － 地球 (コントロール パネルの [地域]) のアイコン
51 － オーディオ圧縮のアイコン
52 － CD プレーヤーのアイコン
53 － Windows Media Player のアイコン
54 － サウンド設定のアイコン
55 － ビデオ クリップのアイコン
56 － ビデオ圧縮のアイコン
57 － ボリューム コントロールのアイコン
58 － ミュージカ サウンドのアイコン
59 － ジャングル サウンドのアイコン
60 － ロボッツ サウンドのアイコン
61 － ユートピア サウンドのアイコン

Parent
オプション コンポーネントの選択用のリスト ボックスには、子レベルの項目を含めることができます。子レベルのオプション コンポーネントの場合は、親レベルとなるインストール セクションを Parent= キーワードで定義します。

Needs
ほかのコンポーネントに依存するコンポーネントの場合は、必要なコンポーネントに対応するインストール セクションをこのキーワードに指定します。ユーザーがコンポーネントを選択すると、Needs= 行に指定したインストール セクションで記述されているコンポーネントが必要であることを示す警告メッセージがユーザーに対して表示されます。

Needs= 行には、同じ .inf ファイル内のインストール セクションを指定する必要があります。ただし、ほかの .inf ファイルを Include= 行に指定すると、それらのファイルで記述されているコンポーネントを Needs= 行に指定する必要があります。

Include
ほかの .inf ファイルに含まれているセクションが必要になる場合は、Include 項目を使うと、セットアップにそれらの .inf ファイルを現在の .inf ファイルと共に読み込ませることができます。この項目に指定した .inf ファイルのどのセクションを実行するかは、Needs 項目で指定します。

2 つのオプション コンポーネント インストール セクションを定義する例を次に示します。この例では、各インストール セクションにエントリを追加して、インターフェイスの要素とコンポーネントの依存関係を指定しています。

[Optional Components]
InstallMyToys
InstallGames
[InstallMyToys]
OptionDesc=%Toys_DESC%
Tip=%Tomytoysys_TIP%
IconIndex=35 ;Phone mini-icon for dialogs
Parent=MailApps
Needs=MSMAIL, MAPI, MicrosoftNetwork
Include=mos.inf, msmail.inf
CopyFiles=MyToysFiles
UpdateInis=MyToysLinks
AddReg=MyToysRegItems
[InstallOtherApps]
OptionDesc=%Other_DESC%
Tip=%Other_TIP%
IconIndex=4 ;windows mini icon for dialogs
CopyFiles=OtherFiles
UpdateInis=OtherLinks
AddReg=OtherRegItems
[Strings]
Toys_DESC="Mail Utilities"
Toys_TIP="Additional utilities for sending and organizing mail"
Other_DESC="Other Helpful Utilities"
Other_TIP="Calculator, disk checker and performance monitor"

ファイルの先頭に戻る


RunOnce 技術の使用

RunOnce レジストリ キーにエントリを追加すると、.inf ファイルの実行後に任意のプログラムを実行できます。RunOnce エントリは、コンピュータの再起動後、ユーザーがシステムにログオンした後 (システム ログオンが有効な場合) に実行されます。

RunOnce レジストリ キーでは、Windows で特定のプログラムを 1 回だけ実行するように指定できます。また、それらのプログラムをユーザーに対するプロンプトなしでサイレントに実行するか、プログラムまたはアクションの一覧を表示し、ユーザーに確認を求めた上で実行するかを指定できます。いったん実行したプログラムへの参照は削除されるため、指定したプログラムが 1 回だけ実行されます。

プログラムをサイレントに実行するには、次のレジストリ キーの下層に description-string=command-line エントリを追加します。

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\RunOnce

Windows Runonce マネージャで互いに同期させてプログラムを実行するには、次のレジストリ キーの下層に description-string=command-line エントリを追加します。

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\RunOnce\Setup

AddReg セクションで RunOnce レジストリ キーを定義してプログラムを実行する例を次に示します。

  • [Windows] フォルダ内の Myapp.exe をユーザーに対するプロンプトなしで起動する場合 :
    HKLM,Software\Microsoft\Windows\CurrentVersion\RunOnce,"SilentApp",,"%25%\myapp.exe"
  • "次の項目を設定します" というメッセージを表示してから、[System] フォルダ内の Test.exe を起動する場合 :
    HKLM,Software\Microsoft\Windows\CurrentVersion\RunOnce\Setup,"Test Utility",,"%11%\test.exe"

注

  • ユーザー インターフェイスには、Setup レジストリ キーの下層の説明文字列が表示されます。


インターネット設定ファイル

インターネット設定ファイル (.ins ファイル) は、Windows Welcome で、広帯域インターネット アクセスまたはダイヤルアップ インターネット アクセスをコンピュータで構成するのに使用する機構です。インターネット サインアップの最後に、ISP サインアップ サーバーによって指定したインターネット設定を含む .ins ファイルが作成され、そのファイルがコンピュータに返されます。次に、Windows Welcome は .ins ファイルを処理し、設定をコンピュータに適用します。

.ins ファイルは、ダイヤルアップ ネットワーク接続、接続 マネージャ、Internet Explorer、および Outlook Express の構成に使用されます。広帯域インターネット接続の場合は、.ins ファイルに TCP/IP およびその他の接続関連の設定を含めることもできます。

詳細については、「広帯域接続のインターネット接続ファイルのエントリ」を参照してください。

.ins ファイルには、次のセクションが含まれています。

セクション | 説明
[Animation] | セットアップ ウィザードに表示するカスタム動画ビットマップ ファイルの場所を指定します。
[ActiveSetup] | Internet Explorer 6 カスタマイズ ウィザードに表示するカスタム ビットマップ ファイルの場所を指定します。
[ActiveSetupSites] | ユーザーにダウンロードさせるカスタム パッケージの名前および場所を指定します。
[Batch] | カスタム パッケージのインストール メディアの種類を指定します。
[Big_Logo] | ブラウザの右上隅に表示される 38 × 38 ピクセルのビットマップ ファイルのファイル名およびパスを指定します。
[Branding] | ブラウザ パッケージに含める独自のブランドおよびセットアップ情報などの情報を指定します。
[BrowserToolbars] | Internet Explorer のツール バーの外観をカスタマイズします。
[CabSigning] | プログラムへの署名に使用する情報を指定します。
[ConnectionSettings] | Internet Explorer のカスタム パッケージのインストールに使用する、ダイヤルアップ ネットワーク (DUN) 接続の設定に関する情報を指定します。これにより、共通の DUN がすべてのユーザーのワークステーションに作成されます。
[CustomBranding] | ブランドされたキャビネット ファイルの URL を指定します。
[CustomWallpaper] | 独自の壁紙の HTML ファイルおよびサポート ファイルを指定します。
[Device] | セットアップに使用する接続の種類を指定します。
[Entry] | この .ins ファイルの情報を無効にして、カスタム パッケージに含まれているダイヤルアップ ネットワーク接続の名前を使用するかどうかを指定します。
[ExtRegInf] | 情報ファイル (.inf ファイル) の名前およびコンポーネントのインストール モードを指定します。
[FavoritesEx] | お気に入りのアイコン ファイルへのパスを指定し、お気に入りをオフラインで利用できるようにするかどうかを指定します。各お気に入りのサイトへの URL も指定できます。
[HideCustom] | グローバル一意識別子 (GUID) を非表示にするかどうかを指定します。各カスタム コンポーネントには、システム情報およびその他のパラメータ (作成日時など) に基づく GUID が含まれます。
[ICW_IEAK] | インターネット接続ウィザードに表示するカスタム ビットマップへのパスを指定します。
[Internet_Mail] | Outlook Express のカスタム情報を指定します。
[Internet_News] | ニュースに関するカスタム情報を指定し、Outlook Express を既定のニュース クライアントにするかどうかを指定します。
[ISP_Security] | カスタム パッケージに追加するルート証明書を指定します。
[LDAP] | Lightweight Directory Access Protocol (LDAP) サーバーに関する情報を指定します。Outlook Express で LDAP サーバーに対して常に名前および電子メール アドレスをチェックするかどうかも指定します。
[Mail_Signature] | ニュースに使用する電子メールの署名を指定し、署名を使用するかどうかを指定します。
[Media] | インストール パッケージに使用するメディアの種類 (CD-ROM、ダウンロード、フロッピー ディスクなど) を指定します。
[Outlook_Express_Global] | Outlook Express サービスのブランドを指定します。
[Outlook_Express] | Outlook Express のどの部分に、パッケージでブランドしたりカスタマイズしたりするかを指定します。
[Phone] | ダイヤルアップ接続に使用する電話情報を指定します。
[Proxy] | プロキシ サーバーおよびプロキシ サーバーのホスト名を使用するかどうかを指定します。
[Scripting] | ダイヤルアップ ネットワーク スクリプト ファイルの名前およびパスを指定します。
[Script_File] | ダイヤルアップ ネットワークに関連付けるスクリプト ファイルの文字列を指定します。
[Security Imports] | 作業用コンピュータのセキュリティ情報をカスタム パッケージにインポートするかどうかを指定します。
[Server] | ネットワーク サーバーに関する情報を指定します。
[Signature] | Outlook Express で署名を使用するかどうかを指定し、その署名に使用する文字列を指定します。
[SignupFiles] | サインアップ中に表示するファイルの名前 (sign-up.htm など) を指定します。
[Small_Logo] | ブラウザの右上隅に表示される 22 × 22 ピクセルのビットマップ ファイルのファイル名およびパスを指定します。
[TCP/IP] | 使用する DNS サーバーの IP 番号を指定します。リモート ゲートウェイ、IP アドレス、およびサーバー アドレスを使用するかどうかも指定できます。
[URL] | 自動構成プロキシ サーバーを使用するかどうかを指定し、ユーザーがそのサーバーに接続したときに表示するページの URL を指定します。
[User] | ユーザーに必要なログオン情報を指定します。


広帯域接続のインターネット設定ファイルのエントリ

Windows Millennium Edition では、新しい広帯域インターネット アカウントを構成できるように [Windows Welcome] が拡張されています。次の設定は、この広帯域を構成するために、既存の .ini ファイル形式を拡張するものです。ダイヤルアップ接続の .ins エントリの設定を、該当する設置に置換してください。

[Device]
Type = {modem, isdn, atm, ethernet, ethernet_1483, cable(?)}
Modem, ISDN and ATM will bind entries to RAS
Modem, ISDN and Ethernet (& cable) look only for [TCP/IP] header
ATM looks for [TCP/IP] and [ATM] headers
Ethernet_1483 looks for [TCP/IP] and [Ethernet_1483] headers
PPPOE looks for [TCP/IP] and [PPPOE] headers
Name = {friendly name of the device}
Pnpid = {Plug and Play ID of the device, or for multi-function
adapters, only the configured-network device Plug and Play required}

注

  • OEM は、広帯域デバイスを組み込む前に、そのデバイス名および Plug and Play ID をコンピュータ上に用意します。この情報は、ユーザーのサインアップ中にインターネット サービス プロバイダ (ISP) に送られます。ISP では、これらの情報を .ins ファイルに追加するため、サインアップ時に適切なデバイスが構成されます。
[TCP/IP]
Specify_IP_Address = {yes for static, no for DHCP}
IP_Address = {static IP address if used}
Subnet_Mask = {ip address}
Specify_DNS_Address = {yes if use, else no}
DNS List = {ip address},{ip address},
IP_Header_Compress = {yes if used, else no}
Gateway_On_Remote = {yes if used, else no}
Default_Gateway_List = {ip address},{ip address},
Domain_Name = {string},{string},

Host_Name = {string if used}
Domain_Suffix_Search_List = {ip address},{ip address},

Specify_WINS_Address = {yes,no}
WINS_List = {ip address},{ip address},
[PPPoverATM] or [Ethernet_1483]
Circuit_Speed = {flag}
0 = Line Rate
1 = User Specified
Or actual value of rate in kilobytes (512, 1536, 25000, 155000)
Circuit_QOS = {flag}
0 = UBR
1 = VBR
2 = CBR
3 = ABR
Circuit_Type = {0 if SVC, 1 if PVC}
Speed_Adjust = {yes or no}
QOS_Adjust = {yes or no}
Encapsulation = {flag}
0 – PPP over ATM (null encapsulation)
1 – PPP over ATM (LLC)
2 – Bridged Ethernet/802.3 (LLC/SNAP) Not defined for PPPOA
3 – Routed IPv4 (LLC/SNAP) Not defined for PPPOA
4 – Bridged Ethernet/802.3 (null encapsulation) Not defined for
PPPOA
5 – Routed IPv4 (null encapsulation) Not defined for PPPOA
VPI = {numeric value} Only for PVC
VCI = {numeric value}
Vendor_Config = {yes or no}
Show_Status = {yes or no}
Enable_Log = {yes or no}
[Phone]
PhoneNumber = NSAP address if ATM, else phone number

注

  • これらは、既存の .ins ファイル形式を拡張するもので、Windows Me の [Windows Welcome] でのみ動作します。


IEAK の使用例

ここには、自動プロキシ構成スクリプト、セットアップ バッチ ファイル、および .inf ファイルのサンプルが収録されています。Internet Explorer および IEAK のコンセプトを理解するのに役立つ図も収録されています。

  • JavaScript または JScript を使った自動プロキシ ファイルの例
  • コンポーネント ダウンロード サービスに使用するサンプル .inf ファイル
  • セットアップ バッチ ファイルのサンプル
  • IEAK のコンセプトの図解

また、IEAK ツールキットにも、サーバーベースのサインアップ パッケージを作成するためのサンプル ファイルや、アドオン コンポーネントをダウンロードおよびインストールするためのサンプル ページなどのサンプルが収録されています。


IEAK ツールキットの内容

IEAK リソース キットには、役に立つツール、プログラム、およびサンプル ファイルが入っています。IEAK ツールキットは、\<IEAK プログラム フォルダ>\Toolkit フォルダおよびそのサブフォルダに格納されています。

[Toolkit] フォルダには、.isp ファイルおよび .ins ファイルのリストを含む Insref.xls というファイルが入っています。

[Addons] フォルダ

このフォルダには、ダウンロードするアドオン コンポーネントのサンプル ページが収録されています。

[Corp] フォルダ

このフォルダには、自動構成 .ins ファイルのサンプルと、カスタマイズ可能な Active Server Pages (.asp) スクリプトが収録されています。.asp ファイルは、Internet Information Services 3.0 (またはそれ以降のバージョン) が動作する Web サーバーで実行できるように設計されていますが、どの Web ブラウザででも表示できます。

[Graphics] フォルダ

このフォルダには、サンプル グラフィックスとツールが収録されています。

[Inf] フォルダ

このフォルダには、アンインストール プログラム作成用の .inf ファイルのサンプルが収録されています。

[ISP] フォルダ

このフォルダには、インターネット サービス プロバイダ (ISP) のための、さまざまなツールとサンプルが収録されています。

  • ダイヤラ情報を構成するツール (ISP ファイル ウィザード)。
  • ユーザーのパスワードをキャッシュに保存し、ユーザーがその都度パスワードを入力しなくてもログオンできるようにするためのツール (Inetlogn.exe)。
  • サーバーベースのサインアップ パッケージ、インターネット接続ウィザード、およびサーバーなしのサインアップ パッケージのそれぞれについての、サンプル スクリプト、ツール、およびカスタマイズ可能なソリューション。


IEAK のコンセプトの図解

主要な機能とコンセプトの図解については、次の項目を参照してください。

IEAK で生成したパッケージから Internet Explorer をインストールするときの動作

Windows Update セットアップ ウィザードによる Internet Explorer およびその他のインターネット ツールのセットアップ

カスタマイズの仕組み

自動構成の仕組み

IEAK を使用したパッケージの作成

IEAK でのカスタム パッケージの生成

自動バージョン同期

配布用ファイルの設定方法

インターネット サインアップ

ISP サインアップ処理

企業内管理者

システム ポリシーおよび設定


JavaScript または JScript を使った自動プロキシ ファイルの例

ここでは、.pac ファイルを使用して自動プロキシ URL を指定するスクリプトの例を示します。これらの関数を使用するには、プロキシ サーバーの名前、ポート番号、および IP アドレスを変更する必要があります。

注

  • isInNet 関数、isResolvable 関数、および dnsResolve 関数は、DNS サーバーに対して問い合わせを実行します。
  • オブジェクト モデルのオブジェクト、プロパティ、またはメソッドを参照すると、プロキシ自動構成ファイルが異常終了し、メッセージが表示されません。たとえば、window.open(...)、alert(...)、password(...) などのいずれを参照しても、プロキシ自動構成ファイルは Internet Explorer 上で異常終了します。

例 1 - ローカル ホストは直接接続し、それ以外はプロキシ サーバーを経由して接続する

次の関数は、ホスト名がローカル ホストかどうかをまず調べます。ローカル ホストの場合は、次に直接接続であるかどうかをチェックします。ホスト名がローカル ホストでない場合は、プロキシ サーバー (proxy) を経由して接続します。

function FindProxyForURL(url, host)
 {
if (isPlainHostName(host))
return "DIRECT";
else
return "PROXY proxy:80";
 }

isPlainHostName 関数は、ホスト名の中にピリオドが含まれているかどうかを調べます。含まれている場合は偽 (False)、含まれていない場合は真 (True) を返します。

例 2 - ファイヤウォールの内側にあるホストは直接接続し、外側にあるローカル サーバーはプロキシを経由して接続する

次の関数は、ホストが "plain" (ホスト名にドメイン名が含まれていない) かどうか、またホスト名が "www" および "home" 以外で特定のドメイン (.company.com) の一部になっているかどうかを調べます。

function FindProxyForURL(url, host)
 {
if ((isPlainHostName(host) ||
 dnsDomainIs(host, ".company.com")) &&
 !localHostOrDomainIs(host, "www.company.com") &&
 !localHostOrDoaminIs(host, "home.company.com"))
return "DIRECT";
else
return "PROXY proxy:80";
 }

注

  • localHostOrDomainIs 関数は、ローカル ドメインの URL に対してだけ実行されます。
  • dnsDomainIs 関数は、指定されたドメインがホスト名のドメインと一致すると、真 (True) を返します。

例 3 - ホスト名の名前解決が可能な場合は直接接続し、それ以外の場合はプロキシ サーバーを経由して接続する

次の関数は、DNS サーバーにホスト名を渡し、名前の解決を要求します。名前を解決できる場合は、直接接続を確立します。解決できない場合は、プロキシ サーバーを経由して接続します。この方法は、内部の DNS サーバーを使用して内部のすべてのホスト名を解決する場合に便利です。

function FindProxyForURL(url, host)
 {
if (isResolvable(host))
return "DIRECT";
else
return "PROXY proxy:80";
 }

このページの先頭にある isResolvable 関数の注を参照してください。

例 4 - 指定したサブネットの中にホストがある場合は直接接続し、それ以外の場合はプロキシ サーバーを経由して接続する

次の関数は、指定された IP アドレスを、パターンおよびマスクを使用して、ホスト名と比較します。この方法を使用すると、サブネット内の特定のホストは直接接続し、それ以外のホストはプロキシ サーバーを使用して接続する場合に便利です。

function FindProxyForURL(url, host)
 {
if (isInNet(host, "999.99.9.9", "255.0.255.0"))
return "DIRECT";
else
return "PROXY proxy:80";
 }

このページの先頭にある isInNet 関数の注を参照してください。

指定されたパターンとホストの IP アドレスが一致すると、isInNet(host, pattern, mask) 関数は真 (True) を返します。この mask では、IP アドレスの中のどの部分を照合するのかを指定します (255 : すべて照合する、0 : すべて無視する)。

例 5 - ホストのドメインに基づいて接続のタイプを決定する

次の関数は、ホストがローカルな場合、直接接続します。ホストがローカルでない場合、この関数はホストのドメインに応じて使用するプロキシ サーバーを選択します。この方法は、ホストのドメイン名によってプロキシ サーバーを選択する場合に便利です。

function FindProxyForURL(url, host)
 {
if (isPlainHostName(host))
return "DIRECT";
else if (shExpMatch(host, "*.com"))
return "PROXY comproxy:80";
else if (shExpMatch(host, "*.edu"))
return "PROXY eduproxy:80";
else
return "PROXY proxy";
 }

shExpMatch(str, shexp) 関数は、str が shexp の条件に一致すると真 (True) を返します。shexp では、シェルのコマンドのようなパターンを使用できます。

例 6 - 使用するプロトコルに基づいて接続のタイプを選択する

次の関数は、使用しているプロトコルのタイプを取得し、それに従ってプロキシ サーバーを選択します。一致するプロトコルがない場合は、直接接続します。この方法は、使用しているプロトコルに応じてプロキシ サーバーを選択する場合に便利です。

function FindProxyForURL(url, host)
 {
if (url.substring(0, 5) == "http:") {
return "PROXY proxy:80";
 }
else if (url.substring(0, 4) == "ftp:") {
return "PROXY fproxy:80";
 }
else if (url.substring(0, 7) == "gopher:") {
return "PROXY gproxy";
 }
else if (url.substring(0, 6) == "https:") {
return "PROXY secproxy:8080";
 }
else {
return "DIRECT";
 }
 }

substring 関数は、指定された数の文字を文字列から取り出します。

例 7 - ホスト名が IP アドレスと一致するかどうかを調べ、プロキシの設定を決定する

次の関数は、ホスト名を IP アドレスに変換した後、指定された文字列と比較して、プロキシ サーバーを選択します。

function FindProxyForURL(url, host)
 {
if (dnsResolve(host) == "999.99.99.999") { // = http://secproxy
return "PROXY secproxy:8080";
 }
else {
return "PROXY proxy:80";
 }
 }

このページの先頭にある dnsResolve 関数の注を参照してください。

例 8 - 指定した IP アドレスとホストの IP アドレスが一致する場合はプロキシ サーバーを経由して接続し、一致しない場合は直接接続する

次の関数でも、IP アドレスに応じてプロキシ サーバーを選択できます。この例は例 7 とは異なり、関数呼び出しにより IP アドレスを数値として明示的に取得します。例 7 では、dnsResolve 関数を使用して、ホスト名を IP アドレス (数値) に変換しています。

function FindProxyForURL(url, host)
 {
if (myIpAddress() == "999.99.999.99") {
return "PROXY proxy:80";
 }
else {
return "DIRECT";
 }
 }

myIpAddress 関数は、ブラウザが動作しているホストの IP アドレスを、ピリオドで区切った整数の形式で返します。

例 9 - ホスト名にピリオドが含まれている場合はプロキシ サーバーを経由して接続し、含まれていない場合は直接接続する

次の関数は、ホスト名に含まれているピリオドの数を調べます。ホスト名にピリオドが含まれている場合は、プロキシ サーバーを経由して接続します。ピリオドが含まれていない場合は、直接接続します。この方法も、ホスト名の特性に応じて接続のタイプを選択するような方法です。

function FindProxyForURL(url, host)
 {
if (dnsDomainLevels(host) > 0) { // if the number of dots in host > 0
return "PROXY proxy:80";
 }
return "DIRECT";
 }

dnsDomainLevels 関数は、ホスト名に含まれるピリオドの個数を整数で返します。

例 10 - 指定した曜日にはプロキシ サーバーを経由して接続し、それ以外の曜日は直接接続する

次の関数では、プロキシ サーバーの使用に適した曜日を指定して接続のタイプを選択します。指定した範囲に含まれない曜日には、直接接続します。この関数は、通信の負荷が高いときにプロキシ サーバーを使用し、負荷が低いときに直接接続するような場合に便利です。

function FindProxyForURL(url, host)
 {
if(weekdayRange("WED", "SAT", "GMT"))
return "PROXY proxy:80";
else
return "DIRECT";
 }

weekdayRange(day1 [,day2] [,GMT] ) 関数は、パラメータの指定範囲 (day1、day2、および GMT) に現在のシステム時刻が含まれているかどうかを示す値を返します。必須のパラメータは、先頭のパラメータだけです。GMT では、ローカルな時刻ではなく、グリニッジ標準時が時刻として使用されます。


セットアップ バッチ ファイルのサンプル

;インストール先フォルダを選択する簡単な Iebatch.txt ファイルの例です。
;最初に指定したオプションを実行し、コンピュータを自動的に再起動します。

[Welcome]
Display=0

[SetupChoice]
Display=0

[Custom]
Display=0
Mode=0
InstallDir=c:\Int_exp\en

[Download]
Display=0
DownloadDir=c:\Int_exp\download\

[Finish]
Display=0

[Reboot]
Reboot=1


カスタム パッケージに関する問題のトラブルシューティング

カスタム パッケージがユーザーのコンピュータで思ったとおりに動作しない場合は、次のシナリオを調べてください。

Windows Update セットアップがユーザーのコンピュータで失敗した

Windows Update セットアップが失敗した場合は、Active Setup Log.txt ファイルをチェックすると、発生したエラーを調べることができます。Active Setup Log.txt ファイルには、IE6Setup.exe が起動されてから最後の .cab ファイルのダウンロードが完了するまでのセットアップ全体のログ情報が記録されます。

IE6Setup.exe を実行すると、Windows がインストールされているフォルダ (通常は、C:\Windows フォルダ) に Active Setup Log.txt ファイルが作成されます。前の Internet Explorer セットアップ実行時に作成された Active Setup Log.txt ファイルがある場合は、そのファイルの名前が Active Setup Log.bak に変更されます。

Active Setup Log.txt ファイルのログは、セットアップを起動した日時に開始し、最後の .cab ファイルのダウンロードが正常に完了した日時に終了します。セットアップ ウィザードの実行中は、ログ エントリが継続的にこのファイルに書き込まれます。ダウンロードが失敗した日時とその原因を調べるには、このログ ファイルが最も適しています。このファイルに書き込まれるエントリの大半は、レジストリにも書き込まれます。これらのデータは、システムを障害から安全に回復するために作成されます。

エラー コードにより、セットアップがどの時点で失敗し、その原因は何かを特定することができます。エラー コードの詳細については、「Active Setup Log.txt のエラー ログ情報」を参照してください。

Windows Update セットアップ中にファイルをダウンロードできなかった

Windows Update セットアップには、インストール中にサーバーを切り替える機能があるため、最大のスループットを維持しながらコンポーネントをインストールでき、さらに、配布サーバーが応答しなくなった場合に、ほかのサーバーに切り替えることができます。サーバーの切り替えは、スループットが 0 になったか、1 バイト未満の状態が 2 分間続いたことを Windows Update セットアップが検出した場合に行われます。

接続タイム アウトになると、セットアップは、リスト内の次のダウンロード サイトに接続し、ダウンロード途中の .cab ファイルの先頭に戻って処理を続行します。接続がタイム アウトになったときにサーバーを切り替えられない場合は、同じダウンロード サイトに再接続し、ダウンロードを中断した部分から処理を再開します。ダウンロード サイトへの接続を確立できない場合は、インストール処理を中止するか、再試行するかを確認するプロンプトが表示されます。

サーバーに問題が発生したことなどが原因で先頭のサイトがダウンしていると、既定では、セットアップは、残りのサイトを見つけることができません。次のコマンドで先頭サイトを上書きすると、それを解決できます。

<path>\ie6setup.exe /C:"ie6wzd.exe /S:""<path>\ie6setup.exe"" /L:""http://my Web server/my Web site/ie6sites.dat"""

<path> は、IE6setup.exe があるフォルダです。

例

次に、先頭のサイトがダウンしているときに、ユーザーに与える構文の例を示します。例では、読みやすいように 3 行の文字列にしていますが、実際には 1 行のコマンド ラインとなります。

C:\ie6setup.exe /C:"ie6wzd.exe
/S:""D:\Build\1700\package\download\win95_nt\en\ie6setup.exe""
/L:""http://<NewServerAddress>/<YourDownloadDir>/ie6sites.dat """

Windows 2000 または Windows XP のユーザーが使用できないインストール モードである

パッケージに構成したインストール オプションにかかわらず、Windows Update セットアップは、Windows 2000 または Windows XP オペレーティング システムを実行しているユーザーには、インストール オプションを 1 つだけ表示します。このインストール オプションには、パッケージに入れたすべてのカスタム コンポーネントと、Microsoft Internet コンポーネントのフル セットが含まれます。

自動構成で変更したブランドが、Windows 2000 または Windows XP を実行しているコンピュータには適用されない

ユーザーに配布するブランドを自動構成で変更しても、Windows 2000 または Windows XP のグループ ポリシーでブランドを使わないように設定されている場合、その変更は適用されません。このポリシーが設定されていると、インターネット サービス プロバイダやインターネット コンテンツ プロバイダは、Internet Explorer や Outlook Express のロゴとタイトル バーのカスタマイズなど、インターネット プログラムのブランドの変更を行うことができません。詳細については、「Windows 2000 および Windows XP 上での Internet Explorer の管理」を参照してください。

コンポーネントをアンインストールできない

アンインストール処理が失敗した場合のトラブルシューティングには、[Windows] フォルダに保存される IE6 Uninstall Log.txt というアンインストール ログ ファイルが最も役立ちます。このログには、ファイルの追加または削除、レジストリ値の追加、変更、または削除、さらにユーザーに表示されたダイアログ ボックスのそれぞれに対応するエントリを含む、アンインストール処理全体に関する情報が記録されます。

このログは、アンインストール処理の各段階に対応する複数のパスで構成されます。また、ログ内のエントリには、Setup.stf 内の行エントリに対応するオブジェクト番号が与えられています。オブジェクト番号のない行は、Internet Explorer に固有のカスタム アクションにより生成され、IE6.inf ファイルか、外部コンポーネントのアンインストールにより作成された .inf ファイルのエントリに対応しています。

コントロール パネルの [プログラムの追加と削除] を使って Internet Explorer をアンインストールできない場合は、アンインストール情報がコンピュータから削除されている可能性があります。アンインストールには、次のファイルが必要です。

  • IE6bak.dat
  • IE6bak.ini
  • Integrated Browser.dat
  • Integrated Browser.ini.

Internet Explorer の [Internet Explorer とインターネット ツール] の [詳細] をクリックして表示されるダイアログ ボックスには、このバックアップ情報をアンインストールするオプションが用意されていますが、このオプションを使うと Internet Explorer をアンインストールできなくなります。

カスタム コンポーネントのアンインストールについては、「.inf スクリプトによるアンインストール」および「カスタム コンポーネントのアンインストール」を参照してください。

単一のディスク ブランドを使用した ICW のインターネット サインアップが動作しない

単一のディスク ブランドをお使いの場合、一部のユーザーが Internet Explorer 4.01 SP1 (またはそれ以前) を使用している可能性があるときは、インターネット接続ウィザード モードのサインアップを使用する代わりにキオスク モードのサインアップを使用して別のパッケージを作成します。


Internet Explorer 6 カスタマイズ ウィザードの使用に関する問題のトラブルシューティング

Internet Explorer 6 カスタマイズ ウィザードの特定の画面を表示できない場合は、次の項目を確認してください。

  • 正しい職種 (インターネット コンテンツ プロバイダ(ICP)、独立ソフトウェア ベンダ (ISV)、インターネット サービス プロバイダ (ISP)、企業内管理者のいずれか) を選択していることを確認します。
  • 正しいオペレーティング システムを選択していることを確認します。
  • [機能の選択] 画面で、カスタマイズ対象の機能をすべて選択していることを確認します。この画面でチェック ボックスをオンにしていない機能については、対応する画面は表示されません。
  • Outlook Express をカスタマイズする場合は、Outlook Express のファイルを既にダウンロードしており、1 つ以上のインストール モードに Outlook Express を追加していることを確認します。

注

  • サイレント インストールをセットアップするか、Office Installation Wizard から Internet Explorer 6 カスタマイズ ウィザードを実行すると、一部のカスタマイズ オプションが利用できなくなります。


Active Setup Log.txt のエラー ログ情報

Active Setup Log.txt ファイルを調べると、Windows Update セットアップのエラーや、エラーが発生したときのセットアップのステータスがわかります。このログには、次のようなエントリがあります。

ログ エントリ | 意味
0 | 初期化中。一時フォルダを作成し、ディスクの空き領域をチェックしています。
1 | すべての依存性をチェックしています。
2 | サーバーからファイルをダウンロードしています。
3 | ダウンロード サイトから一時インストール フォルダにファイルをコピーしています。
4 | ダウンロード中にタイムアウト エラーやその他のダウンロード エラーが発生したため、ダウンロードを再開し、再インストールを試みています。
5 | 信頼性とアクセス権をチェックしています。
6 | ファイルを展開しています。
7 | セットアップ プログラム (.inf または .exe ファイル) を実行しています。
8 | インストールが完了しました。
9 | ダウンロードが完了しました。すべてのファイルがダウンロードされました。

共通エラー コードには、次のようなものがあります。

エラー コード | 意味
80100003 | インストール中にダウンロード フォルダに必要なファイルが見つかりませんでした。
800bxxxx | 800b で始まるエラー コードは、信頼性に関する障害を示します。
800Cxxxx | 800C で始まるエラー コードは、urlmon に関する障害を示します。

例

共通エラー コードの例を、いくつか示します。

800C005:ファイルまたはサーバーが見つかりません。

800C00B:接続のタイムアウトが発生しました。

8004004 : ユーザーによってセットアップが取り消されました。


用語集

記号/数字 A B C D EFG H I JK L M NO P Q R S T U V W XYZ ア カ サ タ ナ ハ マ ヤ ラ ワ

記号/数字

.adm ファイル

デスクトップ、シェル、およびシステム セキュリティに設定できる、システム ポリシーと制限を定義するシステム ポリシー テンプレート ファイルです。

関連項目: システム ポリシー

.bat ファイル

バッチ ファイル。オペレーション システムの一連のコマンドが記述された ASCII テキスト ファイルです。バッチ コマンド言語でサポートされているパラメータおよび演算子を含みます。ユーザーがコマンド プロンプトにバッチ ファイルの名前を入力すると、コンピュータがコマンドを連続的に処理します。

.cab ファイル

キャビネット ファイル。圧縮した複数のファイルを格納する 1 つのキャビネット ファイルです。これらのファイルは一般的に、ファイル サイズを小さくし、Web コンテンツのダウンロードにかかる時間を短くするために、ソフトウェアのインストールに使用されます。

.inf ファイル

情報ファイル。デバイスの有効な論理構成のリスト、デバイスに関連付けされているドライバ ファイルの名前などの、デバイスを設定するために必要な情報をオペレーティング システムに提供する特定のアダプタ用に作成されたファイルです。.inf ファイルは通常、デバイスの製造元からフロッピー ディスクで提供されるか、オペレーティング システムに含まれています。

.ins ファイル

インターネット設定ファイル。Windows Update セットアップに対して、ブラウザおよび関連コンポーネントを構成するインターネット設定を提供するファイルです。使用する .ins ファイルをパッケージごとに変更することにより、複数のバージョンのブラウザ パッケージを作成できます。.ins ファイルを作成および保存し、読み込むには、IEAK プロファイル マネージャを使用します。

A

Authenticode

ソフトウェアの発行元の企業または個人を識別し、発行後にそのソフトウェアが改ざんされていないことを確認するテクノロジ。企業内管理者は、セキュリティ ゾーンを構成したり、規制を事前に設定したり、証明機関をカスタマイズして、ユーザーが署名なしのソフトウェアをダウンロードできないようにすることができます。管理者は、システム ポリシーと制限を設定して、セキュリティの設定の変更をユーザーに許可するかどうかを制御することもできます。

B

この文字で始まる用語は収録されていません。

C

CD-ROM 自動実行画面

ユーザーが CD-ROM バージョンの Internet Explorer のカスタム パッケージをインストールするときに表示される最初の画面です。この画面に表示されるタイトル バー、背景、および文字列の色をカスタマイズすることができます。

D

DNS サーバー

IP アドレスとホスト名を一致させるコンピュータで、ISP によって管理されます。特定の DNS アドレスを提供している ISP もあります。

E

この文字で始まる用語は収録されていません。

F

この文字で始まる用語は収録されていません。

G

この文字で始まる用語は収録されていません。

H

HTML

Web ページの作成および設計に使用される言語。HTML は、Web 作成者がページのレイアウト、文字列の書式設定、グラフィックスやマルチメディアの挿入などに使用する、一連のタグです。

HTTP

定義を表示: ハイパーテキスト転送プロトコル (HTTP)

Hypertext Markup Language (HTML)

プラットフォーム間で移植できるハイパーテキスト ドキュメントの作成に使用する、シンプルなマークアップ言語です。HTML ファイルは、書式やハイパーテキスト リンクを表すコード (マークアップ タグで示す) が埋め込まれた、シンプルな ASCII テキスト ファイルです。

I

IEAK

定義を表示: Internet Explorer 管理者キット (IEAK)

IMAP

Internet Message Access Protocol。電子メール メッセージの受信に使用する一般的なプロトコル。このプロトコルを使用すると、電子メールをローカル コンピュータにダウンロードせずに、電子メール クライアントから電子メール ファイルにアクセスし、操作することができます。主に、自宅以外で電子メールを読む企業内ユーザーによって使用されます。

関連項目: POP3 (Post Office Protocol 3)

IMAP サーバー

IMAP を使用して、サーバー側の複数のフォルダへのアクセスを提供するサーバー。

関連項目: IMAP; POP3 サーバー

Internet Explorer カスタマイズ ウィザード

Internet Explorer 管理者キット (IEAK) のメインのコンポーネントです。特定の組織内でインストールするために、カスタマイズした Internet Explorer を生成するのに使用します。

Internet Explorer 管理者キット (IEAK)

企業内管理者、ISP、および ICPが、カスタマイズした Internet Explorer パッケージを作成、配布し、組織内で管理できるようにする一連のツールです。IEAK には、Internet Explorer カスタマイズ ウィザード、IEAK プロファイル マネージャ、および IEAK ツールキットが含まれています。

ISDN

定義を表示: 総合デジタル サービス通信網 (ISDN)

ISV

定義を表示: ソフトウェア ベンダ (ISV)

J

この文字で始まる用語は収録されていません。

K

この文字で始まる用語は収録されていません。

L

LDAP

定義を表示: ライトウェイト ディレクトリ アクセス プロトコル (LDAP)

M

MIME

定義を表示: Multipurpose Internet Mail Extensions (MIME)

Multipurpose Internet Mail Extensions (MIME)

ビデオ、サウンド、バイナリ ファイルを ASCII 形式のデータに変換せずに、インターネット上で送信できるようにする SMTP を拡張する標準です。

関連項目: SMTP

N

この文字で始まる用語は収録されていません。

O

この文字で始まる用語は収録されていません。

P

Parental Internet Content Selection (PICS)

Web コンテンツ プロバイダが、合意を得ている PICS 条件に従って、メタ タグを使用して自主的にコンテンツを規制するための規則。ブラウザは、タグの値を基に、Web サイトへのユーザー アクセスを禁止することができます。

関連項目: コンテンツの規制

Passport

1 つの名前およびパスワードを、参加している複数の Web サイトで使用する、単一のサインイン サービスです。

PICS

定義を表示: Parental Internet Content Selection (PICS)

POP3 (Post Office Protocol 3)

電子メール メッセージの受信に使用される一般的なプロトコル。このプロトコルは、ISP の POP3 サーバーでよく使用されます。複数のサーバー側のフォルダへのアクセスを提供する IMAP サーバーとは対照的に、POP3 サーバーは単一の受信トレイにアクセスします。

関連項目: SMTP; IMAP

POP3 サーバー

単一の受信トレイへのアクセスを提供するサーバーです。

関連項目: IMAP サーバー

Q

この文字で始まる用語は収録されていません。

R

RAS

定義を表示: リモート アクセス サービス (RAS)

S

Secure Password Authentication (SPA)

サーバーが、暗号化されたパスワードを使用してユーザーの身元を確認するためのプロトコルです。

Secure Sockets Layer (SSL)

データの暗号化と解読を使用して、セキュリティで保護されたデータ通信を提供するプロトコル。このプロトコルを使用すると、公開キーの暗号化とバルク データの暗号化を組み合わせて使用することにより、ネットワーク上での通信のプライバシーを保守することができます。

SMTP

定義を表示: 簡易メール転送プロトコル (SMTP)

T

この文字で始まる用語は収録されていません。

U

URL (Uniform Resource Locator)

"http://www.microsoft.com" のような Web アドレス。

Usenet

Usenet グループはニュースグループとも呼ばれます。テキスト ベースのニュースグループで、任意のユーザーが投稿できる掲示板として機能します。

V

この文字で始まる用語は収録されていません。

W

Web Proxy AutoDiscovery (WPAD)

インターネット クライアント ソフトウェアがネットワークのキャッシュ サービスを自動的に検出し、対話するのを支援する、標準のネットワーク プロトコルです。

Web パス

Internet Explorer 管理者キット (IEAK) では、ブラウザから Internet Explorer インストール ファイルに接続するのに使用するパスを Web パスと呼びます (例 : www.mycompany.com/ie6)。

Web 表示フォルダ

管理者は、社内のコンピュータでマイ コンピュータおよびコントロール パネルをとのように表示するかをカスタマイズすることができます。それには、表示スタイルのテンプレートとして使用されている HTML ファイルをカスタマイズします。Web 表示フォルダを使用するには、Windows デスクトップのアップデートがインストールされている必要があります。

Windows Update セットアップ

Internet Explorer およびその他のインターネット コンポーネントをインストールするセットアップ プログラムです。IEAK を使用すると、Windows Update セットアップをカスタマイズして、ユーザーの操作性を向上させることができます。

Windows インターネット ネーム サービス (WINS)

IP アドレスにコンピュータ名 (NetBIOS 名) を動的に割り当てるソフトウェア サービスです。これによりユーザーは、名前でリソースにアクセスできるので、覚えにくい IP アドレスを使用する必要がありません。WINS サーバーは、Windows NT 4.0 以前のバージョンの Microsoft のオペレーティング システムを実行しているクライアントに対応しています。

Windows デスクトップのアップデート

Windows デスクトップのアップデートは 2 つのコンポーネントから成ります。Active Desktop とシェルの統合です。Windows デスクトップのアップデートは、Windows 98、Windows 98 Second Edition、Windows Millennium Edition、Windows 2000、および Windows XP に含まれています。これらのオペレーティング システムを使用しているコンピュータには、このコンポーネントは再インストールされません。

WINS

定義を表示: Windows インターネット ネーム サービス (WINS)

X

この文字で始まる用語は収録されていません。

Y

この文字で始まる用語は収録されていません。

Z

この文字で始まる用語は収録されていません。

ア

アドオン コンポーネント

パッケージには含めていませんが、Windows Update セットアップの終了後にユーザーがインストールできるコンポーネントです。

暗号化

メッセージまたはデータを偽装して、その内容を隠すプロセス。

インターネット コンテンツ プロバイダ (ICP)

Web へ投稿するコンテンツを用意する組織です。

インターネット コンポーネント ダウンロード サービス

インターネットおよびイントラネット上の Web サイトからソフトウェアをダウンロードし、インストールするシステム サービスです。このサービスを使用して、証明書をチェックすることもできます。インターネット コンポーネント ダウンロードは、Internet Explorer 3.0 以降でサポートされています。

インターネット サインアップ サーバー (ISS)

ISP の顧客データベースへの新規ユーザーの追加処理を自動化する HTTP サーバーです。インターネット サインアップ サーバーは、各ユーザーから情報を収集し、その情報を ISP の顧客データベースに追加し、ユーザーのデスクトップ コンピュータに構成パケットを返送します。構成パケットには、ISP のサービスへの以降の接続をユーザーのインターネット ブラウザで設定するために使用する情報が含まれています。

ウェルカム ページ

ユーザーが Internet Explorer を初めて実行したときに表示されるページ。次回からは、ユーザーがブラウザを起動すると、Internet Explorer にはユーザーのホーム ページが表示されます。

ウォーターマーク

Internet Explorer のツール バーの背面に表示されるビットマップ。ツール バーのボタンの文字列やグラフィックスが見にくくならないような色にします。

お気に入り

Web サイトへの、あらかじめ定義されているリンク。お気に入りは "ブックマーク" とも呼ばれます。Internet Explorer のお気に入りは、コンテンツが変更されたときにユーザーに自動的に通知するように構成することができます。

オンデマンドのインストール

ユーザーのコンピュータに特定のコンポーネントがまだインストールされていない場合、そのコンポーネントを必要とする Web ページをユーザーが表示したときに、コンポーネントのインストールを指示するプロンプトを表示する機能です。IEAK では、ユーザーにこの機能の使用を許可するかどうかを制限できます。

カ

カスタマイズ ウィザード

定義を表示: Internet Explorer カスタマイズ ウィザード

カスタム コード

Internet Explorer 管理者キット (IEAK) をダウンロードするときに、組織に発行されるライセンス コードです。カスタム コードは、IEAK のインストール時には不要ですが、IEAK パッケージの生成時には必要です。

カスタム コンポーネント

パッケージに含めるコンポーネント。自動バージョン同期 (AVS) を使用して Microsoft からダウンロードしたインターネット コンポーネントも含めることができます。

カスタム パッケージ

カスタマイズしたすべてのインストール用のツール、ブラウザ コード、および Internet Explorer を社内にすばやく簡単に展開するために必要なその他のコンポーネントがすべて含まれています。

仮想マシン

別のオペレーティング システム内に独立したオペレーティング システム環境を提供するプログラムです。仮想マシンを使用することにより、ユーザーはほかのオペレーティング システムのプログラムを実行することができます。

簡易メール転送プロトコル (SMTP)

TCP/IP プロトコルの 1 つ。メッセージ送信エージェントとの電子メールのやり取りを管理します。

キオスク モードのスタート ページ

キオスク (全画面) モードのページ。ブラウザのツール バーやメニュー バーは、この画面には表示されません。ユーザーが Internet Explorer をインストールし終わると表示されます。

企業内管理者

社内のコンピュータおよびアプリケーションの設定と保守を行う責任者。管理者は、ユーザーとグループのアカウントの管理、パスワードと権限の割り当て、ネットワーク上の問題に関するユーザーのサポートも行います。

キャッシュ

画像、文字列、およびユーザーが直前にインターネットで表示したその他のファイルを格納するために予約されている、ハード ディスクの領域。

クイック起動バー

[スタート] ボタンの隣にある特別なツール バー領域。Web、電子メール、デスクトップ、およびその他の基本的なシステム サービスや、頻繁に使用するプログラムやアイコンへの簡単なアクセスをユーザーに提供します。このツール バーは一般的に、ユーザーがカスタマイズするために用意されています。

ゲートウェイ

IP パケットを相互に送信または配信できる、複数の物理 TCP/IP ネットワークに接続したデバイス。ゲートウェイは異なる転送プロトコルやデータ形式 (IPX および IP) を変換するので、通常は主にその変換機能のためにネットワークに追加されます。

Novell NetWare ネットワークと共に使用する場合、ゲートウェイは Windows ネットワークで使用されるサーバー メッセージ ブロック (SMB) と NetWare ネットワークで使用される NetWare コア プロトコル (NCP) の間のブリッジとして機能します。ゲートウェイは IP ルーターとも呼ばれます。

コード署名

完成した Internet Explorer パッケージにデジタル証明書で署名を行う処理です。パッケージに署名するには、2 つの操作が必要です。デジタル証明書の取得とコードの署名です。

関連項目: デジタル証明書

コンテンツの規制

Microsoft Internet Explorer には、インターネット上でコンピュータからアクセスできるコンテンツの種類を制御する方法が管理者のために用意されています。管理者は、適切なコンテンツだけを表示できるように、セックス、ヌード、言葉、暴力の設定をそれぞれ調整することができます。

関連項目: Parental Internet Content Selection (PICS)

コンポーネント

管理者は、Microsoft 社および他社の多数のインターネット コンポーネントを Internet Explorer ブラウザに含めることができます。管理者は、Microsoft 社および他社の多数のインターネット コンポーネントを Internet Explorer ブラウザに含めることができます。コンポーネントの例として、Outlook Express および Microsoft NetMeeting が挙げられます。

サ

サーバーベースのサインアップ

定義を表示: サインアップ パッケージ

サイレント インストール

ユーザーに決定を求める入力要求を行わず、インストールの進捗状況やエラーを表示するように、Windows Update セットアップを構成します。このオプションは、企業内管理者のみ使用できます。

関連項目: ハンド フリー インストール

サインアップ パッケージ

顧客からサインアップ情報を収集し、要求に応じてその情報を ISP のサインアップ サーバーに送信する HTML ページの集合です。顧客は、Windows ベースのプログラムのウィザードのように、一連のページでサインアップ処理を行うことができます。

関連項目: Hypertext Markup Language (HTML)

シェルの統合

Windows デスクトップのアップデートでインストールされる 2 つのコンポーネントのうちの 1 つ。シェルの統合により、ユーザーは Web を参照するのと同じようにコンピュータを参照できます。ユーザー側には、いたる所に [移動] や [お気に入り] メニューが表示されます。

システム ポリシー

Windows NT 4.0 スタイルのポリシー。Poledit.exe (システム ポリシー エディタ) を使用して設定したレジストリ設定に基づきます。

関連項目: レジストリ

システム ポリシー エディタ

Poledit.exe という名前のユーティリティ。Windows NT 4.0 ベースおよび Windows 95 ベースのコンピュータでシステム ポリシーを設定するときに管理者が使用します。

自動インストール

定義を表示: オンデマンドのインストール

自動検索

ユーザーがアドレス バーに一般的な言葉を入力すると、頻繁に使用するページを検索することができる、Internet Explorer の機能です。ユーザーは、これらのページの正確な URL を記憶する必要はありません。

自動構成

企業内管理者が、Internet Explorer のユーザーの設定、システム ポリシー、および制限を、中央で管理および更新するための処理です。自動設定ファイルへの参照は、ブラウザ内で手動で設定することも、IEAK を使ったブラウザのインストール時に設定することもできます。

自動構成 URL

このパッケージでブラウザを構成するのに使用する、インターネット設定 (.ins) ファイルの場所。.ins ファイルを使用すると、複数のユーザーの設定を中央で管理することができます。

自動バージョン同期 (AVS)

Internet Explorer 管理者キット (IEAK) を実行するたびに、Internet Explorer の各コンポーネントの更新されたバージョンがないかどうかを自動的にチェックするテクノロジです。更新されたコンポーネントは、Microsoft からダウンロードして、今後の IEAK パッケージに含めることができます。

自動プロキシ

ホストに直接接続するか、またはプロキシ サーバーを使用するかをブラウザが動的に決定するように Internet Explorer を構成するための、管理者向けの機能です。

自動プロキシ URL

自動プロキシ スクリプト ファイルの場所。このファイルを変更すると、複数のユーザーのプロキシ設定を中央で管理することができます。

自動プロキシ スクリプト

JScript (.js)、JavaScript (.jvs)、またはプロキシ自動構成 (.pac) 形式のファイルです。IEAK では、これらのファイルを使用して、プロキシの詳細設定を構成し、維持することができます。自動プロキシ スクリプト ファイルが指定されている場合、Internet Explorer は、ホストに直接接続するか、またはプロキシ サーバーを使用するかを、スクリプトを使用して動的に決定します。

証明書

定義を表示: デジタル証明書

セキュリティ

ネットワークで、コンピュータ システムおよびそのデータを損害または損失から保護すること。特に、許可されたユーザーだけが共有ファイルにアクセスできるようにするときに実装します。

セキュリティ ゾーン

Internet Explorer では、インターネットまたはイントラネットのセグメントに割り当てられる、特定のセキュリティ レベルを指します。これは、管理者が Web サイトのコンテンツの信頼性をどの程度まで認めているかに応じて割り当てられます。セキュリティ ゾーンを使用すると、管理者は、特定の Web サイトへのユーザー アクセスを制限することができます。

接続の設定

Internet Explorer がインターネット接続に使用する設定。通常、接続の設定とは、プロキシ設定、アカウント、パスワード、モデム設定などの、ダイヤルアップ ネットワークのエントリの設定の集合を指します。

接続マネージャ

インターネットにアクセスするためのクライアントのダイヤラです。

接続マネージャ管理キット (CMAK)

接続マネージャのプロファイルを作成、編集、および管理するためのツールです。接続マネージャはクライアントのダイヤラです。CMAK は、Windows 2000 サーバーおよび Windows 2000 の管理キットで使用できます。

関連項目: 接続マネージャ; 接続マネージャのプロファイル

接続マネージャのプロファイル

ダイヤルアップ接続を自動化する方法の 1 つ。ダイヤルアップ ネットワークのエントリに似ています。

総合デジタル サービス通信網 (ISDN)

世界規模のデジタル通信ネットワーク システムです。大部分の電話会社から使用できます。ISDN は、インターネット、オンライン ビジネス、および企業内ネットワークでの高速通信に使用されます。

ソフトウェア ベンダ (ISV)

サード パーティのソフトウェア ベンダです。独立してコンピュータ ソフトウェアを作成している個人または組織を指します。

タ

帯域幅

アナログ通信では、一定範囲における最高周波数と最低周波数の差を指します。たとえば、アナログの電話回線の帯域幅は 3,000 ヘルツ (Hz) ですが、これは、最低周波数 (300 Hz) と最高周波数 (3,300 Hz) の差を示します。デジタル通信では、帯域幅は bps (bits per second) という単位で表されます。

タイトル バーの文字列

プログラム ウィンドウ上部の文字列です。タイトル バーの文字列は、ブラウザ本体、CD-ROM 自動実行画面、および Outlook Express などを含む、Internet Explorer パッケージのさまざまな部分に付けることができます。

Internet Explorer でタイトル バーの文字列をカスタマイズすると、その文字列が Outlook Express にも追加されます。Outlook Express をパッケージの一部として配布する場合や、Outlook Express が既にユーザーのコンピュータにインストールされている場合は、Outlook Express のタイトル バーが更新されます。

ダイナミック HTML

従来の HTML の機能を拡張する機能の集合。Web 作成者に、Web ページの外観と動作を柔軟に設計および作成する機能を提供します。

関連項目: HTML

ダイヤルアップ ネットワーク (DUN)

専用回線やその他の企業内ネットワークではなく、公共の通信ネットワークを使用して、データ通信ネットワークに接続すること。

ダウンロード サイト

ユーザーがパッケージをダウンロードできる HTTP サーバーまたは FTP サーバー。接続のタイム アウトが発生した場合、Windows Update セットアップは、IE6Sites.dat で指定されている次のダウンロード サイトに接続し、セットアップ処理を .cab ファイルの先頭から再開しようとします。

関連項目: .cab ファイル

単一のディスク ブランド

Internet Explorer を再インストールせずに、ISP のインターネット サインアップを含め、既にインストールされている Internet Explorer をカスタマイズすること。このオプションを使用しても、カスタム コンポーネント パッケージを作成してインストールすることはできません。

チャンネル

チャンネルは、情報受信プログラムに対応した Web サイトです。この機能を可能にする機構が、チャンネル定義形式 (.cdf) ファイルです。チャンネルはカテゴリに分類して、ユーザーのデスクトップに配置できます。

デジタル証明書

証明機関によって発行された電子証明。プログラムの作成元を明らかにし、インストール パッケージが改ざんされていないことを確認します。Internet Explorer パッケージをインターネット上で配布する場合、管理者はデジタル証明書でそれらのコードに署名する必要があります。

デジタル署名

暗号化と機密の認証コードに基づく、個人の認証方法です。電子ドキュメントへの "署名" に使用されます。

展開

社内にソフトウェア プログラムを配布し、インストールする処理。展開は "パイロット" とは違います。"パイロット" とは、ソフトウェア アプリケーションを小規模グループのユーザーに提供し、実際の展開時に発生する可能性がある問題を特定および評価することです。

電子ソフトウェア配布 (ESD)

ユーザーがソフトウェアのダウンロードおよび支払いに使用する、安全な通信システム。インターネット上で操作することも、直接モデムによる接続で操作することもできます。ESD システムを使用すると、ユーザーは購入する前に試用期間としてソフトウェアを使用できます。

ドメイン ネーム システム (DNS)

インターネット コミュニティによって開発された、一連のガイドラインおよび規則。ドメイン名アドレス (例 : bluestem.prairienet.org) と IP アドレス (例 : 192.12.3.4) の両方を使用して、インターネットを閲覧できるようにします。ドメイン名アドレスは人間が使用するもので、自動的に数字から成る IP アドレスに変換されます。変換されたものは、パケット送信ソフトウェアが使用します。

ドメイン名

組織の所有者を階層化された形式で定義した、DNS によって使用されるネットワーク接続の名前 (例 : server.organization.type)。たとえば、www.whitehouse.gov は、アメリカ政府の一部であるホワイト ハウスの Web サーバーを示します。電子メール アドレスでは、ドメイン名は "@" 記号の後に付けられます。

ナ

名前解決

コンピュータのアドレスをコンピュータ名として解決するために、ネットワーク上で使用される処理。名前解決を使用すると、ネットワーク上のほかのコンピュータを検索し、接続することができます。

ハ

バージョン番号

Internet Explorer のバージョン番号には 2 つの種類があります。各 Internet Explorer パッケージにはバージョン番号が割り当てられます。このバージョン番号により、同じパッケージの新しいバージョンが古いバージョンで上書きされないようにすることができます。Internet Explorer 内の個別のコンポーネントにもバージョン番号が付けられているので、クライアント コンピュータにコンポーネントの互換バージョンが既にインストールされている場合は、そのコンポーネントをダウンロードおよびインストールしません。バージョン番号には、IEAK パッケージの作成に使用したモードを表す 2 文字のコードが含まれます。インターネット コンテンツ プロバイダは IC、インターネット サービス プロバイダは IS、企業内管理者は CO です。

ハイパーテキスト転送プロトコル (HTTP)

ブラウザが適切なサーバーに接続しているときに、Web ページなどのハイパーテキスト情報をインターネット上で使用できるようにするためのプロトコルです。

パイロット グループ

Internet Explorer パッケージを組織全体に展開する前に行うテストに使用する、作業用コンピュータの例として代表的なもの。テスト ラボとは異なり、パイロット グループでは作業用のコンピュータおよびユーザーを使用します。

関連項目: 展開

バッチ モード セットアップ

バッチ ファイルのコマンドから、または直接コマンド プロンプトからセットアップ プログラムを実行します。

関連項目: .bat ファイル

ハンド フリー インストール

ユーザーに決定を求める入力要求を行わず、インストールの進捗状況やエラーを表示するように、Windows Update セットアップを構成します。このオプションは、企業内管理者のみ使用できます。

関連項目: サイレント インストール

ビットマップ

Internet Explorer 管理者キット (IEAK) パッケージでグラフィックスのカスタマイズに使用する、画像のファイル形式です。

ファイル パス

配布ファイルの Web サーバー上の物理的な場所 (例 : C:\inetpub\wwwroot\ie6\download)。

プラットフォーム

Windows 2000、Windows NT 4.0、Windows Millennium Edition、Windows 98、Windows 3.x、Macintosh、UNIX などのクライアントの種類。

プロキシ

ファイヤウォールおよびコンテンツのキャッシュ サーバー。インターネット セキュリティを提供し、ネットワーク パフォーマンスを向上させます。

プロファイル マネージャ

Internet Explorer 管理者キット (IEAK) のツール。企業内管理者が、ブラウザおよびデスクトップの自動構成の設定を作成し、動的に管理するために使用します。

ホーム ページ

Internet Explorer では、ブラウザを起動したときに最初にユーザーが目にするページをホーム ページと呼びます。"ホーム ページ" には、Web サイトのメイン ページを指すより一般的な意味もあり、通常はサイト内のほかのページへのリンクを含むメイン メニューや目次が用意されています。

マ

メディア

コンピュータ ベースの情報の保存に使用される物理的な媒体。IEAK のパッケージを配布するためのメディアとしては、CD-ROM、Web ダウンロード、またはフロッピー ディスクが一般的です。

ヤ

ユーザー エージェント文字列

ブラウザのバージョンおよび作成元を識別する文字列です。

ラ

ライトウェイト ディレクトリ アクセス プロトコル (LDAP)

ユーザーの名前、電子メール アドレス、電話番号、およびその他の情報を格納および取得するための業界標準。Windows アドレス帳では、ディレクトリ サービスへのアクセスに LDAP をサポートしており、いくつかの一般的なディレクトリ サービスへのアクセスが組み込まれています。管理者は、ユーザー向けにその他のサービスを指定できます。

ラボ

Internet Explorer パッケージのテストに使用される、作業用ではないコンピュータの集合。ラボはパイロット グループとは異なります。

リモート アクセス サービス (RAS)

在宅および外勤で勤務する社員や、複数のオフィスでサーバーを監視および管理するシステム管理者に対して、ネットワークへのリモート アクセスを提供する Windows NT 4.0 のサービス。

領域

接続マネージャ管理キット (CMAK) の機能の 1 つ。接続マネージャ サービスへの接続時に、ユーザー名に接頭辞 (company など) や接尾辞 (@company.com など) を付けます。

関連項目: 接続マネージャ管理キット (CMAK); 接続マネージャ

レガシ

古いテクノロジに基づき、ほかのシステム コンポーネントとの互換性を維持しているコンピュータ システムの機能。

レジストリ

コンピュータの構成に関する情報が格納されたデータベース リポジトリです。レジストリには、操作中に Windows が繰り返し参照する、次のような情報が格納されます。

  • 各ユーザーのプロファイル。
  • コンピュータにインストールされているプログラム、および各プログラムで作成できるドキュメントの種類。
  • フォルダおよびプログラムのアイコンのプロパティ設定。
  • システムのハードウェア構成。
  • 使用中のポート。

レジストリ キー

レジストリにある単一または複数のレコードの識別子です。

ワ

ワイルドカード文字

検索を実行するときに、1 つまたは複数の文字を表すことのできる、キーボード上の文字です。疑問符 (?) は 1 つの文字を、アスタリスク (*) は複数の文字を表します。


カスタム ブラウザのパッケージをダウンロードまたは配布する

ウィザードの [完了] をクリックすると、カスタム ブラウザのパッケージが作成されます。 通常は、次に、Web からのダウンロード用にファイルを用意して、配布用にその他のメディア (CD-ROM など) を用意します。メディアの形式については、「メディアの選択」を参照してください。

インターネットまたは特別な構成を行っていないイントラネットを経由してプログラムおよびキャビネット ファイルを配布する場合は、それらのファイルにデジタル署名を施す必要があります。デジタル署名は、プログラムの発行元を明らかにし、プログラムが改変されていないことを確認するものです。詳細については、「プログラムへの署名」を参照してください。Internet Explorer 6 カスタマイズ ウィザードでプログラムおよびカスタム ファイルに署名を施すように指定した場合は、パッケージの作成時にウィザードによって自動的に署名されます。Internet Explorer カスタマイズ ウィザードでプログラムおよびファイルに署名するように指定しなかった場合は、ユーザーがダウンロードする前に、それらのファイルに手動で署名を施す必要があります。

カスタム ブラウザを配布するための手順は、処理を実行する人の職種およびパッケージの配布に使用するメディアによって異なります。詳細については、次に示すリンクのうち、該当するものをクリックしてください。

  • インターネット コンテンツ プロバイダ (ICP) または開発者
  • インターネット サービス プロバイダ (ISP)
  • 企業内管理者


キャビネット ファイルとは?

キャビネット (.cab) ファイルは、圧縮した複数のファイルを 1 つのファイルとして格納するライブラリです。キャビネット ファイルは、ユーザーのシステムにコピーすべきインストール ファイルを格納するのに使用します。1 つの圧縮ファイルのサイズが非常に大きい場合は、複数の .cab ファイルに分割して格納することもできます。

弊社では長年、ソフトウェアを圧縮してディスクで配布するために .cab ファイルを使用してきました。最初は、製品と一緒に出荷されるフロッピー ディスクの枚数を減らすのが目的でした。しかし現在では、インターネット サーバーや企業イントラネット サーバーに格納されている Web コンテンツのファイル サイズを小さくして、そのダウンロードにかかる時間を短くするために .cab ファイルを使用しています。

キャビネットに格納される代表的なファイルの 1 つに、情報ファイル (.inf ファイル) があります。このファイルには、詳しいインストール情報が格納されます。.inf ファイルでは、.cab ファイル内のほかのファイルを参照しても、別の URL にあるほかのファイルを参照してもかまいません。

Internet Explorer 管理者キットには、キャビネット ファイルの構築と IExpress テクノロジの活用のためのツール セットが入っています。

.cab 形式

.cab ファイル内の圧縮ファイルは、それぞれが単一のフォルダに格納されています。1 つの .cab ファイルには、フォルダを 1 つまたは複数個格納したり、1 つのフォルダの中の一部分を格納したりできます。 したがって、圧縮ファイルが 1 つの .cab ファイルに入りきらない場合、その圧縮ファイルは 1 つのフォルダにして、複数の .cab ファイルに格納することができます。そのときの一連の .cab ファイルを、セットといいます。それぞれの .cab ファイルには、論理的に隣接する .cab ファイルの名前情報が入っています。

インターネット コンポーネント ダウンロードで使用される .cab 形式は、非商用の Lempel-Ziv 圧縮形式に基づいています。

デジタル署名

.cab ファイルには、ActiveX コントロールの場合と同様に、デジタル署名を施すことができます。デジタル署名は、ソフトウェア開発者の責務を表明するものです。署名により、ソフトウェア ベンダの名前とファイルが関連付けられます。.cab ファイルにデジタル署名を施すには、Authenticode 技術を使用します。

複数のファイルを 1 つの .cab ファイルに格納すると、1 つの証明書で複数のファイルをダウンロードできるので、セットアップの操作性を向上できます。この技術の詳細については、「MSDN Online Web Workshop」を参照してください。

コントロールに "スクリプトの安全性" というマークを付けると、HTML ページ上のスクリプトがそのコントロールを使用してユーザーのコンピュータに損害を与えたり、ユーザーに隠れて情報を引き出したりできないことをユーザーに知らせることができます。

コントロールに "初期化時の安全性" というマークを付けると、HTML の作成者が HTML ページの初期化時にそのコントロールに無効なデータを与えてもユーザーのコンピュータに損害を与えることがないことをユーザーに知らせることができます。

注

  • コード署名用のツールを使用すると、.cab ファイル全体にデジタル証明書で署名を施すことができます。


著作権情報

URL やその他のインターネッ ト Web サイトを含み、このドキュメントに記載されている事柄は、将来予告なしに変更することがあります。 別途記載されていない場合、このソフトウェアおよび関連するドキュメントで使用している会社、組織、製品、ドメイン名、電子メール アドレス、ロゴ、人物、キャラクタ、場所、データなどの名称は架空のものです。実在する名称とは一切関係ありません。このソフトウェアおよびマニュアルは、本製品の使用許諾契約書のもとでのみ使用することができます。適用されるすべての著作権およびその他の法律によって保護されており、このドキュメントのいかなる部分も、米国 Microsoft Corporation の書面による許諾を受けることなく、その目的を問わず、どのような形態であっても、複製または譲渡することは禁じられています。ここでいう形態とは、複写や記録など、電子的な、または物理的なすべての手段を含みます。

マイクロソフトは、このドキュメントに記載されている内容に関し、特許、特許申請、商標、著作権、またはその他の無体財産権を有する場合があります。このドキュメントはこれらの特許、商標、著作権、またはその他の無体財産権に関する権利をお客様に許諾するものではありません。

©1999-2001 Microsoft Corporation.All rights reserved.

Active Directory、ActiveX、Authenticode、Developer Studio、DirectAnimation、DriveSpace、Hotmail、JScript、Microsoft、Microsoft Internet Explorer のロゴ、MS-DOS、MSDN、MSN、NetMeeting、Outlook、Visual Basic、Visual C++、Windows、Windows のロゴ、Windows Media、Windows NT、および Windows Start のロゴは、米国 Microsoft Corporation の米国およびその他の国における登録商標または商標です。

Macintosh は Apple Computer, Inc の登録商標です。Intel は Intel Corporation の登録商標です。

記載されている会社名、製品名には、各社の商標のものもあります。


Windows Update セットアップの図解

 Internet Explorer のセットアップ


IEAK でのカスタム パッケージの生成の図解

 IEAK でのカスタム パッケージの生成


インターネット接続ウィザードのサインアップ用の支払いオプション ページの作成

インターネット接続ウィザード (ICW) の各画面は、「インターネット接続ウィザードの画面のコーディングに関する必要条件」で説明する標準に準拠する必要があります。

ICW サインアップ用の名前とアドレス ページの作成

名前とアドレス ページは、ユーザーがサインアップ サーバーに接続したときに最初に表示されるページです。

名前とアドレス HTML ページは、ウィザードのフレーム内に表示されます。フレームのサイズは、幅 444 ピクセル、高さ 273 ピクセルです。HTML ページのサイズがフレームのサイズより大きい場合、スクロール バーは表示されません。

ICW サインアップ用の支払いオプション ページの作成

支払いオプション ページは、サービス課金オプションをユーザーに提供するページです。これらのオプションは、ICW ウィンドウのフレームに表示されます。

各オプションは、ユーザーがHTML ラジオ ボタンで選択できるようにし、ラジオ ボタン オプションのいずれかを既定値として選択しておく必要があります。ユーザーが複数のオプションを選択できるようにしたい場合は、フレーム内に HTML チェック ボックスを定義できます。

ユーザーに提供する支払いオプション HTML ページは、インターネット接続ウィザード内のフローティング フレームに表示されます。フレームのサイズは、幅 444 ピクセル、高さ 273 ピクセルです。HTML ページのサイズがフレームのサイズより大きい場合、スクロール バーは表示されません。

ICW サインアップ用の支払い方法ページの作成

支払い方法ページは、ユーザーがインターネット サービスの支払方法を指定するページです。支払方法の一覧には、それぞれのインターネット サービス プロバイダで実際に採用している支払方法を含めます。一覧から選択されたオプションに対応するフォームがオプションの下のフレームに表示され、ここに情報が入力されます。

次に示す支払方法は、いずれも支払方法の一覧に含めることができます。

  • クレジット カード (Visa や American Express などカードの種類を指定できます)
  • デビット カード
  • 銀行振込
  • 電話料金への加算

ICW サインアップ用のアカウント ログインおよび電子メール ページの作成

サインアップ サーバーで 4 番目に表示されるアカウント ログインおよび電子メール ページは、ユーザーがアカウント ログインと電子メールのいずれかまたは両方についての ID とパスワードを指定するページです。

サインアップ サーバーから送信されたアカウント ログインおよび電子メール ページは、インターネット接続ウィザード内のフローティング フレームに表示されます。フレームのサイズは、幅 444 ピクセル、高さ 273 ピクセルです。HTML ページのサイズがフレームのサイズより大きい場合、スクロール バーは表示されません。

ICW サインアップ用の POP 選択ページの作成

POP 選択ページは、ユーザーがインターネット アクセス ポイントの電話番号を選択するページです。

ISP のサインアップ サーバーから送信された POP 選択ページは、インターネット接続ウィザード内のフローティング フレームに表示されます。フレームのサイズは、幅 444 ピクセル、高さ 273 ピクセルです。HTML ページのサイズがフレームのサイズより大きい場合、スクロール バーは表示されません。

ユーザーが市外局番や電話番号を繰り返し入力しなくてもいいように、名前とアドレス ページからサインアップ サーバーに既に送信された情報を使用して、該当する番号がフレーム内の市外局番フィールドや電話番号フィールドに自動的に表示されるようにしてください。

ICW サインアップ用の約款ページの作成

約款ページには、ユーザーがサービスに加入する前に同意する必要のある、法的拘束力を持つ契約事項を表示します。インターネット接続ウィザードでは契約内容への同意を確認するために、ユーザーは [同意する] ボタンをクリックしない限り [次へ] ボタンを選択できないようになっています。

ユーザーは [コピーの保存] ボタンをクリックして契約内容を HTML ファイルに保存し、後で参照することができます。ユーザーがこのボタンをクリックすると、保存するファイルのパスと名前を入力するように求めるプロンプトが表示されます。

サインアップ サーバーから送信した約款ページは、インターネット接続ウィザード内のフローティング フレームに表示されます。このフレームは、2 ピクセルの境界線で囲まれています。2 ピクセルの境界線と垂直スクロールバーを除くと、このフレームの幅は 426 ピクセルです。HTML ページの幅がフレームの幅より大きい場合、水平スクロール バーは表示されません。

約款ページは、ユーザーが後でもう一度参照したり印刷することができるように、約款のタイトルと Web サイト上の約款にアクセスする方法から始まるようにしてください。

注

  • このページでは、HTML フォーム要素を使用できないので、ユーザー補助に関する必要条件はありません。


ICW サインアップ用の Icwsign.htm、エラー ページ、および完了ページの作成

ICW サインアップを行うには、ユーザーに対して最初に表示されるページ (Icwsign.htm)、エラー ページ、および完了ページを設計する必要があります。

最初のページ:Icwsign.htm

ユーザーが Internet Explorer のインストール後にコンピュータを再起動したときに最初に表示されるページは、Icwsign.htm というブランド ページです。Icwsign.htm ページでは、まずウェルカム メッセージが表示されます。サインアップに必要な ISP ファイルが 1 つだけの場合は、ユーザーは [次へ] をクリックして今すぐサインアップを開始するように求められます。複数のサインアップ サーバー ISP ファイルがある場合は、インターネット接続ウィザードで適切なファイルを選択できるように、ダイヤル元の都道府県と市町村名を指定するように求められます。

[次へ] をクリックすると、インターネット接続ウィザードによって電話番号がダイヤルされ、ユーザーのコンピュータが ISP サインアップ サーバーに接続されます。このページを IEAK で指定して、Internet Explorer のカスタム パッケージに組み込みます。サインアップ サーバー上には置きません。

ICW サインアップ用のエラー ページ

サインアップ処理中にサインアップ サーバーに無効なデータが送信された場合は、エラーをわかりやすく説明する HTMP ページをサーバーから表示できます。たとえば、既に使用されている電子メール名をユーザーが指定した場合は、代わりに使用できる電子メール名の候補を表示したり、別の電子メール アドレスを使用するよう指示するエラー ページを表示できます。

サインアップ サーバーから送信したエラー HTML ページは、インターネット接続ウィザード内のフローティング フレームに表示されます。フレームのサイズは、幅 444 ピクセル、高さ 273 ピクセルです。HTML ページのサイズがフレームのサイズより大きい場合、スクロール バーは表示されません。

フレームには、入力したデータが無効であることをユーザーに知らせる文字列を表示すると共に、ユーザーがデータを入力し直すためのフォーム要素を配置する必要があります。

HTML の設計および必要なフォーム要素の詳細については、「インターネット接続ウィザードの画面のコーディングに関する必要条件」を参照してください。

ICW サインアップ用の完了ページ

ユーザーが完了ページの [次へ] ボタンをクリックすると、.ins ファイルが処理され、ユーザーのコンピュータに新しいインターネット アカウントが構成されます。この後、インターネット接続ウィザードの最後のページが表示され、インターネットに接続する準備が整ったことを知らせると共に、インターネットのブラウズを開始する方法が示されます。このページには、インターネット サービス プロバイダ側で構成できるインターフェイスはありません。

完了ページには、[今すぐインターネットに接続するにはここを選び [完了] をクリックしてください] チェック ボックスも用意されています。ユーザーは、このチェック ボックスをオンにして、インターネットのブラウズをすぐに開始できます。

.ins ファイルの [URL] の値を使用すると、ブラウザが最初に起動されたときに特定のページを表示することができます。

.ins ファイルによるユーザーのコンピュータの構成

ユーザーがサインアップ処理を完了した時点で、サインアップ サーバーからユーザーに、ユーザーのコンピュータでインターネット アクセスを構成する方法についての情報を送信する必要があります。この情報は、サインアップ処理の最後にダウンロードされる .ins ファイルに含まれています。


インターネットでの詳細情報の参照

インターネット上で追加情報を検索したり、IEAK アカウントを管理することができます。

詳細については、「IEAK に関する Web サイト」を参照してください。この Web サイトは頻繁に更新されています。最新情報を絶えず確認してください。


セットアップ情報ファイル (.inf) の使用

コンポーネントを 32 ビット Windows 上で実行するためにインストールまたはダウンロードする必要があるファイルを指定するには、情報ファイル (.inf ファイル) と呼ばれるテキスト ファイルを使います。インターネット コンポーネント ダウンロード サービスでは、これらの情報に従って、インターネットからダウンロードしたソフトウェア コンポーネントやそれらのコンポーネントに必要なファイルをインストールし、登録します。インターネット コンポーネント ダウンロード サービスは、Internet Explorer Version 3.0 以降に搭載されています。

インターネット上でソフトウェアを配布する場合は、単一のキャビネット ファイル (.cab) からなる "パッケージ" 単位で配布されます。キャビネット ファイルには、.inf ファイルが含まれます。配布パッケージには、ActiveX コントロール (.ocx)、.dll ファイル、.exe ファイル、Java クラス ファイル、小さなプログラムなどのソフトウェア コンポーネントを格納することもできます。Internet Explorer Version 3.0 以降では、Web ページの OBJECT 要素の CODEBASE 属性から参照されているキャビネット ファイルに .inf ファイルが格納されている場合には、そのキャビネット ファイルが自動的にソフトウェア配布パッケージとして処理されます。

.inf ファイルを使用すると、レジストリ エントリやインストール先ディレクトリなど、ソフトウェアのインストールに関する項目を詳細に指定できます。.inf ファイルでは、プラットフォームの独立性およびソフトウェアへの依存性を制限できます。

.inf ファイルの使い方の詳細については、次のトピックを参照してください。

  • セットアップ情報ファイル (.inf) の定義
  • セットアップ情報ファイル (.inf) によるフォルダとファイルの操作
  • Windows セットアップ機能の拡張
  • .inf スクリプトによるアンインストール
  • RunOnce 技術の使用
  • コンポーネント ダウンロード サービスに使用するサンプル .inf ファイル

注

  • インターネット コンポーネント ダウンロード サービスの詳細については、「MSDN Online Web Workshop」を参照してください。


[ActiveSetup]

WizardBitmap

値 : ファイル パス

セットアップ ウィザードの左側に表示するビットマップ ファイルへの完全なパス。

WizardBitmap Top

値 : ファイル パス

セットアップ ウィザードの上部に表示するビットマップ ファイルへの完全なパス。

WizardTitle

値 : 文字列

セットアップ ウィザードのタイトル バーに表示する文字列。


[ActiveSetupSites]

SiteName0

値 : 文字列

ユーザーがファイルをダウンロードするサイトのわかりやすい名前。

SiteRegion0

値 : 文字列

1 つ目のダウンロード サイトのある地域。

SiteURL0

値 : URL

1 つ目のダウンロード サイトの URL。

SiteName1

値 : 文字列

ユーザーがファイルをダウンロードする 2 つ目のサイトのわかりやすい名前。

SiteRegion1

値 : 文字列

2 つ目のダウンロード サイトのある地域。

SiteURL1

値 : URL

2 つ目のダウンロード サイトの URL。

SiteNameX

値 : 文字列

ユーザーがファイルをダウンロードする 3 つ目以降のサイトのわかりやすい名前。

SiteRegionX

値 : 文字列

3 つ目以降のダウンロード サイトのある地域。

SiteURLX

値 : URL

3 つ目以降のダウンロード サイトの URL。

TestCertsOK

値 : 0 | 1

test certs を使用するかどうかを指定します。test certs を使用するには、1 に設定します。


[Animation]

Big_Name

値 : ファイル名

38 × 38 ピクセルの動画用のフレームを含むビットマップ ファイルの名前。

Big_Path

値 : ファイル パス

38 × 38 ピクセルの動画ビットマップ ファイルへの完全なパス。

DoAnimation

値 : 0 | 1

動画をカスタマイズするかどうかを指定。動画をカスタマイズ作成するには、1 に設定します。

Small_Name

値 : ファイル名

22 × 22 ピクセルの動画用のフレームを含むビットマップ ファイルの名前。

Small_Path

値 : ファイル パス

22 × 22 ピクセルの動画ビットマップ ファイルへの完全なパス。


[Batch]

Build_CD

値 : 0 | 1

CD-ROM での配布用にカスタム パッケージを作成するかどうかを指定。 CD-ROM での配布用にパッケージを作成するには、1 に設定します。

Build_Floppy

値 : 0 | 1

フロッピー ディスク 1 枚での配布用にカスタム パッケージを作成するかどうかを指定。フロッピー ディスク 1 枚での配布用にパッケージを作成するには、1 に設定します。

Build_MultiFloppy

値 : 0 | 1

複数のフロッピー ディスクでの配布用にカスタム パッケージを作成するかどうかを指定。複数のフロッピー ディスクでの配布用にパッケージを作成するには、1 に設定します。

Build_W31

値 : 0 | 1

Windows 3.1 ユーザー用に配布するパッケージを作成するかどうかを指定。Windows 3.1 ユーザー用に配布するパッケージを作成するには、1 に設定します。


[Big_Logo]

Name

値 : ファイル名

ブラウザの右上隅に表示される 38 × 38 ピクセルのビットマップ ファイルの名前。

Path

値 : ファイル パス

ブラウザの右上隅に表示される 38 × 38 ピクセルのビットマップ ファイルのパス。


[Branding]

Add on URL

値 : http://server/addons/addon.htm

ブラウザ内の製品の更新コマンドのためのアドオン URL。

BrowserDefault

値 : 0 | 1 | 2

企業内管理者モードの場合、Internet Explorer を既定のブラウザにするには 0、既存の既定のブラウザをそのまま残すには 1、ユーザーが選択できるようにするには 2 に設定します。

CMBitmapName

値 : file_name

接続マネージャのカスタム ビットマップのファイル名。

CMBitmapPath

値 : パス

接続マネージャのカスタム ビットマップ ファイルへの完全なパス。

CMProfileName

値 : file_name

接続マネージャのプロファイルの名前。

CMProfilePath

値 : パス

接続マネージャのプロファイルへの完全なパス。

CMUseCustom

値 : 0 | 1

接続マネージャのカスタム プロファイルを使用するかどうかを指定します。カスタム プロファイルを使用するには、1 に設定します。

CompanyName

値 : 名前

.ins ファイルを作成する、有効な IEAK ライセンスを持っている企業の名前。

EncodeFavs

値 : 0 | 1

Internet Explorer 5.0 以前のバージョン用に、IEAK で生成される [Favorites] セクションを正しくエンコードするには、1 に設定します。

FavoritesDelete

値 : 16 進値

[お気に入り] およびクイック起動バーの既存のリンクをすべて削除するには、0x89 に設定します。この機能は、企業内管理者のみ使用できます。

FavoritesOnTop

値 : 0 | 1

新しいお気に入り項目を [お気に入り] メニューの先頭に挿入するには、1 に設定します。

IE4 Welcome Msg

値 : 0 | 1

ブラウザを最初に起動したときにウェルカム ページを表示するには、1 に設定します。

Language ID

値 : 数値

使用する言語のコード ページ。

Language Locale

値 : ロケール

カスタマイズする Internet Explorer のバージョンのロケール。2 文字で表されます (英語の場合は EN)。

NoDial

値 : 0 | 1

ISP の場合 : IEAK ベースのサインアップ処理をまったく使用しない場合は、1 に設定します。

NoIELite

値 : 0 | 1

Active Setup ウィザードで、既存のファイルがあればそれを使用して、ダウンロードを最適化するには、1 に設定します。

Silent Install

値 : 0 | 1

企業内管理者の場合 : Windows Update のセットアップをユーザーが入力できないようにして実行し、進捗状況やエラー メッセージを表示するには、1 に設定します。

StealthInstall

値 : 0 | 1

企業内管理者の場合 : フィードバックを表示せずに Windows Update のセットアップを実行するには、1 に設定します。

Toolbar Bitmap

値 : path_and_file_name

ブラウザのツール バーに表示するビットマップへの完全なパス。

Type

値 : 0 | 1 | 2

使用するカスタマイズの種類を指定します。企業内管理者は 2、インターネット サービス プロバイダは 1、インターネット コンテンツ プロバイダは 0 に設定します。

User Agent

値 : 文字列

既定のユーザー エージェント文字列に追加する文字列。

Version

値 : 文字列

ブラウザのバージョン (6, 0, 0, 1 など)。

WebIntegrated

値 : 0 | 1

Internet Explorer 4.x が統合されたシェルをこのパッケージに含めるかどうかを指定します。含める場合は、1 に設定します。

Win32DownloadSite

値 : url

Windows Update セットアップ ファイル (IEsetup.exe) をダウンロードする URL。

Window_Title

値 : 文字列

Internet Explorer のウィンドウのカスタマイズしたタイトル。

Window_Title_CN

値 : 文字列

ウィンドウのタイトルに追加する社名。

WizardVersion

値 : 文字列

.ins ファイルを作成した IEAK ウィザードのバージョン (6.00.0707.2800 など)。


[BrowserToolbars]

Action0

値 : path_and_file_name

カスタム ツール バー ボタンに関連付けられている実行可能ファイルのパスおよびファイル名。

Caption0

値 : キャプション

カスタム ツール バー ボタンのキャプション。

DeleteButtons

値 : 0 | 1

インストール時に、既存のカスタム ツール バー ボタンを削除するかどうかを指定します。ボタンを削除するには、1 に設定します。

HotIcon0

値 : path_and_file_name

マウス ポインタをボタン上に移動したときに、ボタンに強調表示のアイコン (.ico ファイル) を表示します。

Icon0

値 : path_and_file_name

マウス ポインタがボタン上から移動したときに、ボタンに淡色表示のアイコン (.ico ファイル) を表示します。

Show0

値 : 0 | 1

既定でツール バーに新しいボタンを表示するかどうかを指定します。ボタンを表示するには、1 に設定します。

ToolTipText0

値 : 文字列

カスタム ボタンのツールのヒントの文字列。


[CabSigning]

InfoURL

値 : URL

証明書のダイアログ ボックスに表示する URL。

Name

値 : 文字列

証明書に関連付けられている社名。

pvkFile

値 : ファイル パス

秘密キー ファイルへのパス。

spcFile

値 : ファイル パス

証明書ファイルへのパス。


[CDCustomFiles]

DisableStart

値 : 0 | 1

CD-ROM 自動実行プログラムを使用するかどうかを指定します。CD-ROM 自動実行プログラムを使用するには、0 に設定します。

MoreInfo

値 : ファイル パス

ユーザーが CD-ROM 自動実行画面の [詳細情報] をクリックしたときに表示するファイル。

StartHtm

値 : ファイル パス

CD-ROM 自動実行画面からアクセスする HTML ページ。


[ConnectionSettings]

ConnectName0

値 : 文字列

接続の名前。

ConnectName1

値 : 文字列

DeleteConnectionSettings

値 : 0 | 1

インストール時に、既存の接続の設定を削除するかどうかを指定します。企業内管理者モードでのみ使用できます。設定を削除するには、1 に設定します。

Option

値 : 0 | 1

ユーザーが IEAK ウィザードの接続の設定のインポートを選択した場合は、1 に設定します。


[CustomBranding]

Branding

値 : url

ブランドされた .cab ファイルの URL (http://www.yourserver.net/cabs/branding.cab など)。


[CustomWallpaper]

File0

値 : file_name

独自の壁紙に使用する HTML ファイル。

File1

値 : file_name

独自の壁紙のサポート ファイル。

NumFiles

値 : 2

独自の壁紙のファイルの合計数。


[Device]

Type

値 : 文字列

Windows Update セットアップで使用する接続の種類 (モデムなど)。


[Entry]

Cancel

値 : Yes | No

サインアップ処理を取り消すかどうかを指定します。インターネット接続ウィザードで使用します。サインアップ処理を取り消すには、Yes に設定します。

Entry_Name

値 : 文字列

ダイヤルアップ ネットワーク接続の名前。


[ExtRegInf]

Chat

値 : 文字列

情報ファイル (.inf) およびコンポーネントのインストール モードの例 : *,chat.inf,DefaultInstall.

Conf

値 : 文字列

情報ファイル (.inf) およびコンポーネントのインストール モードの例 : *,conf.inf,DefaultInstall.

Inetres

値 : 文字列

情報ファイル (.inf) およびコンポーネントのインストール モードの例 : *,inetres.inf,DefaultInstall.

Inetset

値 : 文字列

情報ファイル (.inf) およびコンポーネントのインストール モードの例 : *,inetset.inf,DefaultInstall.

Oe

値 : 文字列

情報ファイル (.inf) およびコンポーネントのインストール モードの例 : *,oe.inf,DefaultInstall.

Shell

値 : 文字列

情報ファイル (.inf) およびコンポーネントのインストール モードの例 : *,shell.inf,DefaultInstall.

Sp1shell

値 : 文字列

情報ファイル (.inf) およびコンポーネントのインストール モードの例 : *,sp1shell.inf,DefaultInstall.

Subs

値 : 文字列

情報ファイル (.inf) およびコンポーネントのインストール モードの例 : *,subs.inf,DefaultInstall.

ConnectionSettings

値 : 文字列

情報ファイル (.inf) およびコンポーネントのインストール モードの例 : *,connect.inf,DefaultInstall.


[FavoritesEx]

IconFile1

値 : path_and_file_name

追加するお気に入りの項目のアイコン。

Offline1

値 : 0 | 1

お気に入りの項目をオフラインで表示できるようにするかどうかを指定します。表示できるようにするには、1 に設定します。

Title1

値 : 文字列

お気に入りのタイトル。

Url1

値 : url

お気に入りの項目の URL。


[HideCustom]

GUID

値 : 0 | 1

これが非表示のコンポーネントかどうかを指定します。これが非表示のコンポーネントである場合は、1 に設定します。


[ICW_IEAK]

Header_Bitmap

値 : ファイル パス

インターネット接続ウィザード (ICW) に表示するヘッダーのカスタム ビットマップへのパスを指定します。

Watermark_Bitmap

値 : ファイル パス

インターネット接続ウィザード (ICW) に表示するウォーターマークのカスタム ビットマップへのパスを指定します。


[Internet_Mail]

Default_Client

値 : Yes | No

Internet Mail を既定のクライアントにするかどうかを指定します (Internet Explorer 4.x Custom の場合)。

Infopane

値 : path_and_file_name

カスタマイズした Outlook Express のブランドされた InfoPane 用の HTML ファイル。

Infopane_Bitmap

値 : path_and_file_name

カスタマイズした Outlook Express 用のブランドされた .gif ファイル。

Junk_Mail_Filtering

値 : 0 | 1

迷惑メール機能を既定で有効にするかどうかを指定します。この機能を有効にするには、1 に設定します。

Logon_Using_SPA

値 : Yes | No

セキュリティで保護されたパスワード認証を使用してログオンするかどうかを指定します。

POP_Server

値 : 文字列

既定で設定する POP3 サーバーのホスト名 (pop.yourserver.net など)。

SMTP_Logon_Required

値 : 0 | 1

SMTP サーバーへのログオンを既定で必須にするかどうかを指定します。ログオンを必須にするには、1 に設定します。

SMTP_Logon_Using_SPA

値 : Yes | No

SMTP サーバーへのログオンに、セキュリティで保護されたパスワード認証を使用するかどうかを指定します。

SMTP_Server

値 : 文字列

既定で設定する SMTP サーバーのホスト名 (smtp.yourserver.net など)。

Use_IMAP

値 : Yes | No

電子メールに IMAP プロトコルを使用するかどうかを指定します。

Welcome_Address

値 : 文字列

Outlook Express のウェルカム メッセージの "送信者のアドレス" (welcome@yourserver.net など)。

Welcome_Message

値 : path_and_file_name

ウェルカム メッセージが含まれている HTML ファイルの場所。

Welcome_Name

値 : 文字列

ウェルカム メッセージの "送信者のアドレス" のわかりやすい名前 (Welcome To Custom Internet Mail! など)。

Window_Title

値 : 文字列

Outlook Express のカスタム ウィンドウ タイトル。


[Internet_News]

Default_Client

値 : Yes | No

Outlook Express を既定のニュース クライアントとして使用するかどうかを指定します。

Logon_Required

値 : 0 | 1

NNTP サーバーへのユーザーのログオンを必須にするかどうかを指定します。 ログオンを必須にする場合は、1 に設定します。

Logon_Using_SPA

値 : Yes | No

NNTP サーバーで、セキュリティで保護されたパスワード認証を使用するかどうかを指定します。

NNTP_Server

値 : 文字列

NNTP サーバーのホスト名 (news.yourserver.net など)。


[ISP_Security]

RootCertPath

値 : path_and_file_name

システムに追加するルート証明書。


[LDAP]

AuthType

値 : 0 | 2

Windows アドレス帳からディレクトリ サービスへのアクセス方法を指定します。一般的なディレクトリへの組み込みのサービスを使用して認証するには、0 に設定します。 SPA を使用して認証するには、2 に設定します。詳細については、「アドレス帳のディレクトリ サービス」を参照してください。

Bitmap

値 : path_and_file_name

C:\My Documents\Branding\LDAP.bmp

Checknames

値 : 0 | 1

Outlook Express で LDAP サーバーに対して常に名前および電子メール アドレスをチェックするかどうかを指定します。 Outlook Express で常にチェックするには、1 に設定します。

FriendlyName

値 : 文字列

LDAP サーバー アカウントのわかりやすい名前。

HomePage

値 : url

ブラウザのホーム ページの場所。

SearchBase

値 : url

ブラウザの検索 ページの場所。

Server

値 : 文字列

LDAP サーバーのホスト名 (LDAP-SRV-1 など)。


[Mail_Signature]

Signature_Text

値 : 文字列

電子メール メッセージやニュースグループへの投稿に自動的に追加される定型的な文字列。 末尾に "\n" が付きます。

Use_Mail_For_News

値 : 0 | 1

ニュースグループへの投稿の末尾に Signature_Text の値を追加するかどうかを指定します。署名を含めるには、1 に設定します。

Use_Signature

値 : 0 | 1

電子メール メッセージの末尾に Signature_Text の値を追加するかどうかを指定します。署名を含めるには、1 に設定します。


[Media]

Build_CD

値 : 0 | 1

CD-ROM のインストール パッケージを作成するかどうかを指定します。パッケージを作成するには、1 に設定します。

Build_Download

値 : 0 | 1

ユーザーがダウンロードできるインストール パッケージを作成するかどうかを指定します。パッケージを作成するには、1 に設定します。

Build_Floppy

値 : 0 | 1

フロッピー ディスク 1 枚に収まるブランドのみのインストール パッケージを作成するかどうかを指定します。パッケージを作成するには、1 に設定します。

Build_LAN

値 : 0 | 1

LAN ベースのインストール パッケージを作成するかどうかを指定します。パッケージを作成するには、1 に設定します。

Build_MultiFloppy

値 : 0 | 1

複数のフロッピー ディスクに納まるインストール パッケージを作成するかどうかを指定します。パッケージを作成するには、1 に設定します。


[Outlook_Express]

Contacts

値 : 0 | 1

既定で連絡先を表示するかどうかを指定します。

Folder_Bar

値 : 0 | 1

既定でフォルダ バーを表示するかどうかを指定します。

Folder_List

値 : 0 | 1

既定でフォルダ一覧を表示するかどうかを指定します。

Outlook_Bar

値 : 0 | 1

既定で Outlook バーを表示するかどうかを指定します。

Preview_Pane

値 : 0 | 1

既定でプレビュー ウィンドウを表示するかどうかを指定します。

Safe_Attachments

値 : 0 | 1

添付ファイルにウィルスが含まれている可能性がある場合、その添付ファイルを保存したり、開いたりできるようにするかどうかを指定します。添付ファイルを保存したり開いたりできるようにするには、0 に設定します。

Show_Preview_Beside_Msgs

値 : 0 | 1

既定でメッセージのプレビューを表示するかどうかを指定します。メッセージのプレビューを表示するには、1 に設定します。

Show_Preview_Header

値 : 0 | 1

既定でプレビュー ウィンドウ ヘッダーを表示するかどうかを指定します。

Show_Toolbar_Text

値 : 0 | 1

既定でツール バーの文字列を表示するかどうかを指定します。

Status_Bar

値 : 0 | 1

既定でステータス バーを表示するかどうかを指定します。

Tip_Day

値 : 0 | 1

既定でヒントを表示するかどうかを指定します。

Toolbar

値 : 0 | 1

既定でツール バーを表示するかどうかを指定します。

Warn_on_Mapi_Send

値 : 0 | 1

他のアプリケーションから管理者としてメッセージが送信されたときに警告のメッセージを受けるどうかを指定します。警告のメッセージを受けるには、1 に設定します。


[Outlook_Express_Global]

Read_Only

値 : 0 | 1

Outlook Express の設定でサーバー名を読み取り専用にするかどうかを指定します。サーバー名を読み取り専用にするには、1 に設定します。

Service_Name

値 : 名前

社名。

Service_URL

値 : url

メール サービスの場所。


[Phone]

Area_Code

値 : 数値

ダイヤルアップ接続の市外局番。

Country_Code

値 : 数値

ダイヤルアップ接続の国/地域コード。

Country_ID

値 : 数値

ダイヤルアップ接続の国/地域 ID。

Dial_As_Is

値 : Yes | No

市外局番やその他の番号を追加せずに、電話番号をそのままダイヤルします。

Phone_Number

値 : 数値

ダイヤルする電話番号。


[Proxy]

FTP_Proxy_Server

値 : プロキシ

プロキシ サーバーのホスト名。

Gopher_Proxy_Server

値 : プロキシ

プロキシ サーバーのホスト名。

HTTP_Proxy_Server

値 : プロキシ

プロキシ サーバーのホスト名。

Proxy_Enable

値 : 0 | 1

プロキシ サーバーを使用するかどうかを指定します。プロキシ サーバーを使用するには、1 に設定します。

Proxy_Override

値 : 文字列

プロキシ サーバーのホスト名 (<LOCAL> など)。

Secure_Proxy_Server

値 : プロキシ

プロキシ サーバーのホスト名。

Socks_Proxy_Server

値 : プロキシ

プロキシ サーバーのホスト名。

Use_Same_Proxy

値 : 0 | 1

すべてのサーバーにプロキシ サーバーを使用するかどうかを指定します。同じプロキシ サーバーを使用するには、1 に設定します。


[Script_File]

1

値 : 文字列

スクリプト ファイルの 1 行目。

2

値 : 文字列

スクリプト ファイルの 2 行目。

3

値 : 文字列

スクリプト ファイルの 3 行目。

n

値 : 文字列

スクリプト ファイルの n 行目の文字列。


[Scripting]

Name

値 : file_name

ダイヤルアップ ネットワーク スクリプトのファイル名 (dialup.scp など) 。

Name16

値 : file_name

ダイヤルアップ ネットワーク スクリプト (16 ビット) のファイル名。

Name32

値 : file_name

ダイヤルアップ ネットワーク スクリプト (32 ビット) のファイル名。

Path16

値 : path_and_file_name

16 ビットのスクリプトへの完全なパス。

Path32

値 : path_and_file_name

32 ビットのスクリプトへの完全なパス。


[Security Imports]

ImportAuthCode

値 : 0 | 1

既存の Authenticode の設定をインポートするかどうかを指定します。

ImportRatings

値 : 0 | 1

既存のコンテンツの規制の設定をインポートするかどうかを指定します。

ImportSecZones

値 : 0 | 1

既存のセキュリティ ゾーンの設定をインポートするかどうかを指定します。

ImportSiteCert

値 : 0 | 1

既存の証明機関をインポートするかどうかを指定します。

Win16SiteCerts

値 : 0 | 1

16 ビット Windows コンピュータのサイト証明書を使用するかどうかを指定します。


[Server]

Disable_LCP

値 : Yes | No

ユーザーのコンピュータで行ったインターネット アクセスの構成方法に関する情報を使用するかどうかを指定します。この情報は、インターネット接続ウィザードのサインアップ処理の最後に使用されます。

Negotiate_IPX/SPX

値 : Yes | No

IPX プロトコルを使用するかどうかを指定します。

Negotiate_NetBEUI

値 : Yes | No

NetBEUI プロトコルを使用するかどうかを指定します。

Negotiate_TCP/IP

値 : Yes | No

TCP/IP アドレスを使用するかどうかを指定します。

Network_Logon

値 : Yes | No

ネットワークにログオンするかどうかを指定します。

PW_Encrypt

値 : Yes | No

暗号化されたパスワードを使用するかどうかを指定します。

SW_Compress

値 : Yes | No

ソフトウェアの圧縮を使用するかどうかを指定します。

SW_Encrypt

値 : Yes | No

データの暗号化を必須にするかどうかを指定します。

Type

値 : 文字列

サーバーの種類 (ppp など)。


[Signature]

Signature_Text

値 : 文字列

電子メールの署名の文字列。末尾に "\n" が付きます。

Use_Signature

値 : 0 | 1

署名を使用するかどうかを指定します。


[SignupFiles]

File0

値 : ファイル名

サインアップ処理で使用される 1 つ目のファイルの名前 (cancel.ins など)。

File1

値 : ファイル名

サインアップ処理で使用される 2 つ目のファイルの名前 (sign-up.htm など)。

File2

値 : ファイル名

サインアップ処理で使用される 3 つ目のファイルの名前 (sign-up.isp など)。

File3

値 : ファイル名

サインアップ処理で使用される 4 つ目のファイルの名前。


[Small_Logo]

Name

値 : ファイル名

ブラウザの右上隅に表示される 22 × 22 ピクセルのビットマップ ファイルの名前。

Path

値 : ファイル パス

ブラウザの右上隅に表示される 22 × 22 ピクセルのビットマップ ファイルのパス。


[TCP/IP]

DNS_Address

値 : 文字列

使用する DNS サーバーの IP 番号 (127.0.0.1 など)。

DNS_Alt_Address

値 : 文字列

使用する別の DNS サーバーの IP 番号 (127.0.0.1 など)。

Gateway_On_Remote

値 : Yes | No

リモート ゲートウェイを使用するかどうかを指定します。

IP_Header_Compress

値 : Yes | No

IP ヘッダー圧縮を使用するかどうかを指定します。

Specify_IP_Address

値 : Yes | No

IP アドレスを使用するかどうかを指定します。

Specify_Server_Address

値 : Yes | No

サーバー アドレスを使用するかどうかを指定します。


[URL]

AutoConfig

値 : 0 | 1

カスタム ブラウザを自動的に構成するかどうかを指定。ブラウザを自動的に構成するには、1 に設定します。

AutoConfigJSURL

値 : url

自動プロキシ ファイルの URL。JavaScript または Microsoft JScript で記述されます。

AutoConfigTime

値 : 整数

ここで指定した分数だけ実行した後、ブラウザを自動的に構成します。

AutoConfigURL

値 : url

自動プロキシ ファイルの URL。

FirstHomePage

値 : url

カスタム ブラウザを最初に実行したときに表示するページ。

Help_Page

値 : url

テクニカル サポートを提供する Web ページの URL。

Home_Page

値 : url

既定のホーム ページの URL。

NoWelcome

値 : 0 | 1

ブラウザを最初に起動したときにウェルカム ページを表示しないかどうかを指定します。ウェルカム ページを表示しない場合は、1 に設定します。

Quick_Link_1

値 : url

クイック起動バーのリンクの URL。

Quick_Link_1_Name

値 : 文字列

Quick_Link_1 に関連付けられている名前。

Quick_Link_2

値 : url

クイック起動バーの 2 つ目のリンクの URL。

Quick_Link_2_Name

値 : 文字列

Quick_Link_2 に関連付けられている名前。

Quick_Link_X

値 : url

クイック起動バーのリンクの URL。

Quick_Link_X_Icon

値 : path_and_file_name

クイック起動バーのリンクのアイコン。

Quick_Link_X_Name

値 : 文字列

Quick_Link_X に関連付けられている名前。

Quick_Link_X_Offline

値 : 0 | 1

クイック起動バーのリンクをオフラインで表示できるようにするかどうかを指定します。

Search_Page

値 : url

既定の検索ページ。

Signup

値 : path_and_file_name

サインアップ サーバーの .ins ファイルへのリンクを含むページへのパス。

UseLocalIns

値 : 0 | 1

ローカルの .ins ファイルを使用するかどうかを指定します。


[User]

Display_Password

値 : Yes | No

パスワードを表示するかどうかを指定。

Name

値 : 文字列

ユーザー名。

Password

値 : 文字列

パスワード。

Requires_Logon

値 : Yes | No

ユーザーのログオンを必須にするかどうかを指定します。


インターネット設定ファイルのエントリ

インターネット設定ファイル (.ins) には、次のセクションが含まれています。

  • [Animation]
  • [ActiveSetup]
  • [ActiveSetupSites]
  • [Batch]
  • [Big_Logo]
  • [Branding]
  • [BrowserToolbars]
  • [CabSigning]
  • [CDCustomFiles]
  • [ConnectionSettings]
  • [Custom Branding]
  • [Custom Wallpaper]
  • [Device]
  • [Entry]
  • [ExtRegInf]
  • [FavoritesEx]
  • [HideCustom]
  • [ICW_IEAK]
  • [Internet_Mail]
  • [Internet_News]
  • [ISP_Security]
  • [LDAP]
  • [Mail_Signature]
  • [Media]
  • [Outlook_Express_Global]
  • [Outlook_Express]
  • [Phone]
  • [Proxy]
  • [Scripting]
  • [Script_File]
  • [Security Imports]
  • [Server]
  • [Signature]
  • [SignupFiles]
  • [Small_Logo]
  • [TCP/IP]
  • [URL]
  • [User]


似たようなブラウザを複数個作成する

ここでは、多くの設定は共通で、特定の設定だけが異なるバージョンのブラウザ (たとえば、メール サーバーが異なるバージョン) を作成します。

Internet Explorer 6 カスタマイズ ウィザードでは、基になるバージョンのカスタム ブラウザで指定した設定が表示されます。これらの設定は、Install.ins ファイルに格納されています。この .ins ファイルの名前を変更すれば、別バージョンのカスタム ブラウザを簡単に作成することができます。

  1. ウィザードを使用して、カスタム ブラウザを 1 つ作成します。
  2. CIE\Custom フォルダに入っている Install.ins ファイルの名前を変更します。たとえば、名古屋に住んでいるユーザー向けのバージョンを作る場合は、Nagoya.ins という名前に変更します。
  3. CIE\Custom フォルダの中にある Signup.htm ファイルを開きます。このファイルの中に Nagoya.ins ファイルへのリンクを作成します。
  4. ウィザードをもう一度実行して、同じカスタム フォルダをファイルの出力先として指定します。

    5. ウィザードの設定はすべてのバージョンで同じにしてください。ただし、次の設定はバージョンごとにカスタマイズできます。

    • ロゴ
    • タイトル バーの文字列
    • お気に入り
    • リンク バー
    • ホーム ページと検索バー
    • メール サーバーとドメイン
  5. 手順 2 ～ 4 を繰り返して、カスタム ブラウザのバージョンを必要なだけ作成します。

カスタム ブラウザへのブランドの方法の図解については、「カスタマイズの仕組み」を参照してください。


.isp ファイルの作成

カスタム ブラウザ パッケージでサインアップ処理を実装する場合は、Signup.isp という名前のインターネット サインアップ (.isp) ファイルが、インターネット サービスのダイヤラ情報を提供します。サーバーベースのサインアップ方法の場合、このサインアップ ファイルには、.ins 構成ファイルを生成するサーバー スクリプトの URL へのリンクも含まれます。IEAK ツールキットには、.isp ファイルの自動生成に使用できるツールや ISP ファイル ウィザードが含まれています。

ISP ファイル ウィザードをインストールするには、\<IEAK プログラム フォルダ>\Toolkit\ISP\Wizard フォルダにある Filewiz.exe をダブルクリックします。

ISP ファイル ウィザードを起動するには
  • [スタート] メニューをクリックし、[プログラム] をポイントして、[ISP File Wizard] をクリックします。
  • ウィザードの指示に従って、設定をカスタマイズし、.isp ファイルを作成します。

注

  • 既定の市外局番を設定しないようにするには、.isp ファイルのフラグを設定する方法があります。このフラグの構文は、次のとおりです。
    Dial_As_Is=Yes

    たとえば、ユーザーが既定の設定以外の市外局番から通話する可能性がある場合には、この設定をオンにした方がよいでしょう。ユーザーが現在の市外局番と既定の市外局番の違いに気付かないと、思わぬ長距離通話料を請求されることにもなりかねません。


テクニカル サポート

IEAK は、アドバンスト システム製品として位置付けられています。アドバンスト システム製品のテクニカル サポートは、マイクロソフトならびにマイクロソフト認定サポートセンター (ASC) 各社より有償で提供されます。詳細につきましては、マイクロソフト株式会社 Web サイト http://www.microsoft.com/japan/ をご参照ください。

また、Internet Explorer 管理者キットのご利用方法などについては、http://www.microsoft.com/japan/ie/ieak/ をご参照ください。


会社名とカスタム コード

IEAK をインストールして使用できるようにするプロセスを簡略化するために、氏名と 10 桁のカスタム コードを入力する必要がなくなりました。 IEAK 6 を開始するには、インストールの間に使用許諾契約に同意し、自分の職種を選択するだけです。

職種
目的に合致する職種を選択してください。
  • [コンテンツ プロバイダ/開発者] － カスタムなコンテンツ、リンク、および機能をユーザーに提供する方の場合。
  • [サービス プロバイダ] － インターネット サービスをユーザーに提供する方の場合。
  • [企業内管理者] － 会社または組織で使用するインターネット用のソフトウェアやサービスの管理を担当する方の場合。

重要

  • この職種は、使用許諾契約で規定した職種に合致するものを選択しなければなりません。


言語の選択

[対象言語] ボックスの一覧から、目的の言語を選択します。目的の言語が一覧に掲載されていない場合は、Internet Explorer 6 カスタマイズ ウィザードをいったん終了した後、目的の言語が含まれる IEAK の CD-ROM を挿入し、Internet Explorer 6 カスタマイズ ウィザードを再起動してください。

Internet Explorer 6 カスタマイズ ウィザードは、作成する Internet Explorer カスタム パッケージごとに実行しなければなりません。複数の言語の設定を保持したい場合は、どの言語でも同じコピー先フォルダを指定してください。そうすれば、設定が言語ごとに、コピー先のフォルダ内にある別々のサブフォルダに格納されます。

例

たとえば、EN が英語、DE が独語の省略名です。

コピー先フォルダとして C:\Cie\Build1\ を指定すると、ダウンロード可能な英語版の Internet Explorer を含むカスタム パッケージは、C:\Cie\Build1\Download\Win32\EN\ フォルダに作成されます。

ダウンロード可能な独語版の Internet Explorer を含むカスタム パッケージは、C:\Cie\Build1\Download\Win32\DE\ フォルダに作成されます。

注

  • ユーザーは、オペレーティング システムとは異なる言語を使用するバージョンの Internet Explorer をインストールすることができます。
  • IEAK 6 は "Win32" のプラットフォームでのみ使用できます。UNIX および 16 ビット Windows クライアントの場合は、IEAK 5.x をお使いください。


メディアの選択

ここで、パッケージの配布に使用するメディアの種類を指定します。

[ダウンロード]
イントラネットやインターネットを経由してダウンロードできるパッケージを作成する場合は、このチェック ボックスをオンにしてください。カスタム パッケージは、ハード ディスクに作成した後、インターネット サーバーやイントラネット サーバー (企業内管理者の場合) に移動することができます。また、サーバーのパスをダウンロード先のフォルダとして指定すると、パッケージをサーバー上に直接作成できます。詳細については、「ファイルの場所」を参照してください。
[CD-ROM]
CD-ROM 版を作成する場合は、自動実行情報も指定できます。このチェック ボックスをオンにすると、カスタム パッケージが一組のフォルダにグループ化され、自動実行画面がサポートされます。自動実行画面は、ユーザーが CD-ROM をコンピュータの CD-ROM ドライブに挿入したときに表示される画面です。
[フラット (すべてのファイルが 1 つのディレクトリに存在する)]
パッケージを LAN 上で作成する場合や、作成したパッケージを後で LAN に移動する場合は、このチェック ボックスをオンにすると、コピー先のフォルダのサブフォルダ (C:\Cie\Lan\ など) に必要なファイルがすべて格納されます。
[単一のディスク ブランド]
既存の Internet Explorer Version 4.01 Service Pack 1 (Windows 98 に付属) 以降のインストールをカスタマイズする場合は、このチェック ボックスをオンにします。これにより、作成したパッケージの保存場所にある [BrndOnly] フォルダに Setup.exe ファイルが作成されます。作成された Setup.exe ファイルは、あらゆるメディアまたはサーバーに配布できます。このファイルを実行すると、インターネット サービス プロバイダ (ISP) へのサインアップ方法など、Internet Explorer の各機能がカスタマイズされます。Internet Explorer を再インストールする必要はありません。単一のディスク ブランドのパッケージに、カスタム コンポーネントまたは接続マネージャのプロファイルを含めることはできません。これは、パッケージのサイズが、フロッピー ディスクの容量を超えてしまうからです。

重要

  • 単一のディスク ブランドを使用している場合や、Internet Explorer 4.01 Service Pack 1 またはそれ以前のバージョンを使用しているユーザーがいる場合は、[サインアップの方法] ページでインターネット接続ウィザードのサーバーベースのサインアップ モードを使用しないでください。 その代わりに、これらのユーザーに対しては、キオスク モードでサーバーベースのサインアップを使用した個別のパッケージを作成します。


ファイルの場所

ここで、作成した IEAK パッケージを格納するコピー先フォルダと、コンポーネントのダウンロード用のフォルダを変更できます。

[作成先フォルダ]
Internet Explorer カスタマイズ ウィザードが終了すると、このフォルダには、カスタム パッケージがコピーされています。このパッケージは、ハード ディスクに作成してからインターネット サーバーやイントラネット サーバーに移動することも、Web サーバー上に作成することもできます。

各種オペレーティング システムおよびメディアに対して指定したコピー先フォルダには、各言語版用のサブフォルダが作成されます。

パッケージをハード ディスクやネットワーク ドライブ上に作成する場合は、コピー先を C:\Cie\Dist\ にすることをお勧めします。使用しているハード ディスクで稼動する Web サーバー上にパッケージを作成する場合は、コピー先として Web サーバーのパスを使用します。

注

  • 図解については、「配布用ファイルの設定方法」を参照してください。

例 : コピー先フォルダの場所

たとえば、コピー先フォルダとして C:\Inetpub\Wwwroot\Cie\Dist と指定すると、Windows プラットフォーム用の英語版のパッケージは、C:\Inetpub\Wwwroot\Cie\Dist\Download\Win32\En\ というフォルダにコピーされます。

[詳細設定]
[詳細設定] をクリックすると、ファイルのダウンロード用のフォルダやダウンロード処理をカスタマイズしたり、既存の .ins ファイルから設定をインポートしたりすることができます。
[AVS を実行して、Internet Explorer のコンポーネントの最新バージョンを確認する]
Internet Explorer パッケージを作成するときに、Internet Explorer 6 カスタマイズ ウィザードを使って Microsoft のサーバーに接続し、新しいコンポーネントやセキュリティ問題の修正プログラム、または既存のコンポーネントで前回 Internet Explorer 6 カスタマイズ ウィザードを実行した後でリリースされた新しいバージョンを検出できます。

インターネットからダウンロードした IEAK を使用する場合は、コンポーネントの最新バージョンがないかどうかを調べるために、少なくとも 1 回は自動バージョン同期 (AVS) を使って Internet Explorer 6 カスタマイズ ウィザードを実行する必要があります。

注

  • このチェック ボックスをオフにしてウィザードを続行し、後でここに戻ってこの AVS 機能を選択しようとすると、チェック ボックスが淡色表示になって選択できないことに注意してください。このチェック ボックスを使用できるようにするには、Internet Explorer 6 カスタマイズ ウィザードを終了し、再度起動する必要があります。
[インポートの設定のための .INS ファイルのパス]
既存の .ins ファイルから設定をインポートして新しい IEAK パッケージを作成するには、完全なパスを入力します。既存のパッケージに近い設定のパッケージを新規に作成する場合は、設定をインポートすると効率的です。設定をインポートする場合でも、各設定は必要に応じて変更できます。
[コンポーネント ダウンロード フォルダ]
ダウンロードしたコンポーネントおよびセットアップ ファイルは、ここで指定したフォルダに格納されます。このフォルダは AVS によってチェックされ、最新のコンポーネントを利用できるかどうか自動的に判定されます。AVS では、前回のダウンロード以降に更新されたコンポーネントだけがダウンロードされます。通常は、このフォルダを変更しないでください。変更すると、コンポーネントを自動的に同期させることができなくなることがあります。

前回ウィザードを実行したときにダウンロードしたファイルをそのまま残しておきたい場合や、最新のコンポーネントを別の場所にダウンロードしたい場合にのみ、このフォルダを変更するようにしてください。


機能の選択

カスタマイズする機能を選択します。これにより、ウィザードでこれから表示する画面を限定することができます。たとえば、リンクおよび URL だけをカスタマイズする予定である場合は、そのほかのチェック ボックスをオフにすれば、リンクおよび URL のカスタマイズだけに集中することができます。項目を選択することにより、Internet Explorer 6 カスタマイズ ウィザードには必要な画面だけが表示されるので、効率よくカスタム パッケージを作成することができます。

注

  • すべての機能をカスタマイズする場合は、[すべて選択する] をクリックします。一覧表示されたいずれの機能もカスタマイズしない場合は、[すべてクリア] をクリックします。

以前に作成した IEAK パッケージの構成を、このパッケージの基礎として使用するには、[ファイルの場所] 画面に戻って、[詳細設定] をクリックし、.ins ファイルをインポートします。新しいパッケージを作成すると、インポートした設定を変更することができます。


段階 1 : 情報の収集

バナー

段階 1: 情報の収集

Internet Explorer 6 カスタマイズ ウィザードのこの段階では、作成するパッケージの言語や、そのパッケージ内でどの機能をカスタマイズするかなどの基本的な情報を入力するよう指示されます。

利用できるオプションは、次のうちどの職種を選択しているかによって異なります。

  • インターネット コンテンツ プロバイダ
  • インターネット サービス プロバイダ
  • 企業内管理者

注

  • Internet Explorer 6 カスタマイズ ウィザードは、Internet Explorer 6 がインストールされていないと、正しく動作しません。詳細については、「ハードウェアとシステムの必要条件」を参照してください。


自動バージョン同期 (AVS)

Internet Explorer 6 カスタマイズ ウィザードのこの段階では、Internet Explorer とほかのコンポーネントのセットアップ ファイルを、指定したダウンロードの場所からダウンロードします。

コンピュータにインストールされているコンポーネントのバージョンと、Internet Explorer 製品リリースのバージョンが同じ場合、既にインストールされているバージョンをそのまま使うように指示されます。コンポーネントをダウンロードするためにウィルス チェック プログラムを一時的に無効にする必要がある場合は、そのことを知らせるメッセージが表示されます。

パッケージを後で簡単に作成し直せるように、ファイルをハードディスクにコピーしておくことをお勧めします。パッケージを再作成する際は [更新] をクリックして、より新しいバージョンのプログラムがあるかどうかを確認してください。

Microsoft コンポーネント
ボックスに表示されている Microsoft のコンポーネントを 1 つまたは複数ダウンロードします。各コンポーネントの状況は、次のように表示されます。
記号 | 意味
赤色の点 | このコンポーネントは、お使いのコンピュータのダウンロード フォルダにありません。
黄色の感嘆符 | お使いのコンピュータのダウンロード フォルダにあるこのコンポーネントのバージョンが Internet Explorer 製品リリースのバージョンよりも古いか、またはウィザードの段階 1 で AVS を無効にしました。
緑色のチェック マーク | このコンポーネントのバージョンは、Internet Explorer 製品リリースのバージョンと同じです。
青色の矢印 | Microsoft は Internet Explorer 製品リリースの後に、このコンポーネントをアップデートしました。アップデートされたバージョンがお使いのコンピュータのダウンロード フォルダにあります。
紫色の星 | これは Internet Explorer 製品リリースには含まれていない、新しいコンポーネントです。
[更新]
この [更新] をクリックして、Internet Explorer がリリースされた後に更新されたインターネット コンポーネントや利用可能な新しいインターネット コンポーネントがないかどうかを調べます。

たとえば、リリースされているすべての Internet Explorer セキュリティ問題の修正プログラムを 1 つに集めたコンポーネントが [更新] ダイアログ ボックスから利用できます。

[更新] ダイアログ ボックスで選択したコンポーネントがダウンロードされ、ウィザードのこのページの一覧に含まれます。

AVS を無効にしてあると、このボタンは使用できません。

詳細については、「自動バージョン同期 (AVS) の更新」を参照してください。

重要

  • コンポーネントを最新バージョンに更新すると、古いバージョンに簡単に戻すことができなくなります。
[同期]
1 つまたは複数のコンポーネントをダウンロードするには、目的のコンポーネントを選択するたびに [同期] をクリックします。

注

  • 連続して並んでいる項目を選択するには、Shift キーを押しながら最後の項目をクリックします。
  • 隣接していない複数の項目を選択するには、Ctrl キーを押しながら各項目をクリックします。
[すべて同期]
すべての利用可能なコンポーネントをダウンロードするには、[すべて同期] をクリックします。

[同期] または [すべて同期] をクリックすると、最新の Internet Explorer 製品リリースがダウンロードされます。この同期処理が以前に [更新] ダイアログ ボックスからダウンロードした新しいまたは更新されたコンポーネントに影響を与えることはありません。

[ディスク領域]
選択したコンポーネントに必要なディスク領域を指定します。コンポーネントを 1 つも選択しなかった場合、一覧のすべてのコンポーネントが必要とする必要なディスク領域を指定します。

製品リリースに含まれるコンポーネントのバージョンに戻すには

  1. [キャンセル] をクリックして、Internet Explorer 6 カスタマイズ ウィザードを終了します。
  2. ウィザードを再起動します。
  3. ウィザードの [ファイルの場所] ページで、[詳細設定] をクリックします。
  4. [詳細設定] ダイアログ ボックスで [コンポーネント ダウンロード フォルダ] を別の場所に変更します。
  5. ウィザードに従い、処理を続行します。

Windows Update からのファイルの入手

より新しいバージョンのコンポーネントや修正プログラムを Windows Update Web サイトから利用できることがあります。ただし、パッケージに Windows Update のコンポーネントを含める場合は、関連するファイルをカスタム コンポーネントにバンドルする必要があります。それに対して、AVS を使ってダウンロードしたコンポーネントとパッケージに含まれたコンポーネントは、自動的に Windows Update セットアップからインストールされます。詳細については、「Microsoft のアップデート情報をカスタム コンポーネントにパッケージ化する」を参照してください。

製品の更新に関する最新情報については、「Windows Update に関する Web サイト」(英語) を参照してください。

注

  • このウィザードの段階 1 で、[詳細設定] ダイアログ ボックスの [AVS を実行して、Internet Explorer のコンポーネントの最新バージョンを確認する] チェック ボックスをオフにした場合 (「ファイルの場所」を参照)、Internet Explorer 6 カスタマイズ ウィザードは最新バージョンのコンポーネントが揃っているかどうかを検証することができません。その場合は、最新バージョンが揃っていても、アイコンが緑色で表示されません。ダウンロード済みのコンポーネントのアイコンは、黄色で表示されます。まだダウンロードしていないコンポーネントのアイコンは、赤色で表示されます。また、バージョンの同期機能を無効にしてあると、ウィザードのこの段階で個々のコンポーネントをダウンロードすることができません。
  • IESetup.cif には、自動バージョン同期の更新でダウンロードした新しいまたは更新されたコンポーネントが、自動的に含まれます。
  • コンポーネントとそれらに関連する ComponentID 文字列については、「IEAK に関する Web サイト」を参照してください。
  • AVS の図解については、「自動バージョン同期」を参照してください。


Microsoft ダウンロード サイト

最新の Microsoft プログラムとツールをダウンロードする場所を指定する必要があります。

Microsoft ダウンロード サイト
最新の Internet Explorer とインターネット ツールをダウンロードするサイトを選択し、[次へ] をクリックして Internet Explorer 6 カスタマイズ ウィザードの [自動バージョン同期] ページを表示します。


自動バージョン同期 (AVS) の更新

Internet Explorer がリリースされた後に更新されたインターネット コンポーネントや利用可能な新しいインターネット コンポーネントがないかどうがを調べることができます。たとえば、リリースされているすべての Internet Explorer セキュリティ問題の修正プログラムを 1 つに集めたコンポーネントが、ここから利用できます。

このダイアログ ボックスを表示するには、ウィザードの [自動バージョン同期 (AVS)] ページで [更新] をクリックします。ダウンロードする新しいまたは更新されたコンポーネントがない場合、このダイアログ ボックスは表示されません。

Microsoft コンポーネント
ボックスに表示されている Microsoft のコンポーネントの最新版をダウンロードします。各コンポーネントの状況は、次のように表示されます。
記号 | 意味
青色の矢印 | Microsoft は Internet Explorer 製品リリースの後に、このコンポーネントを更新しました。
紫色の星 | これは Internet Explorer 製品リリースには含まれていない、新しいコンポーネントです。
[すべて選択]
一覧のすべての項目を選択するには、[すべて選択] をクリックします。マウスを使って 1 つのコンポーネントを選択できます。

注

  • 連続して並んでいる項目を選択するには、Shift キーを押しながら最後の項目をクリックします。
  • 隣接していない複数の項目を選択するには、Ctrl キーを押しながら各項目をクリックします。
[ディスク領域]
この一覧のすべてのコンポーネントに必要なディスク領域を指定します。
[同期]
コンピュータにダウンロードするコンポーネントを選択し、[同期] をクリックします。クリックするとダイアログ ボックスを閉じて、選択したコンポーネントをコンピュータにダウンロードし、ウィザードの [自動バージョン同期] ページの一覧にコンポーネントを追加します。

一覧からコンポーネントを選択しなかった場合、このボタンは表示されません。

Windows Update からのファイルの入手

より新しいバージョンのコンポーネントや修正プログラムを Windows Update Web サイトから利用できることがあります。しかし、パッケージに Windows Update のコンポーネントを含める場合は、関連するファイルをカスタム コンポーネントにバンドルする必要があります。それに対して、AVS を使ってダウンロードしたコンポーネントとパッケージに含まれたコンポーネントは、自動的に Windows Update セットアップからインストールされます。詳細については、「Microsoft のアップデート情報をカスタム コンポーネントにパッケージ化する」を参照してください。

製品の更新に関する最新情報については、「Windows Update に関する Web サイト」(英語) を参照してください。

注

  • IESetup.cif には、自動バージョン同期の更新でダウンロードした新しいまたは更新されたコンポーネントが、自動的に含まれます。
  • コンポーネントとそれらに関連する ComponentID 文字列については、「IEAK に関する Web サイト」を参照してください。
  • AVS の図解については、「自動バージョン同期」を参照してください。


カスタム コンポーネントの追加

ブラウザをインストールする際にユーザーにインストールを許可するカスタム コンポーネントは、16 個まで指定できます。圧縮されたキャビネット (.cab) ファイルまたは自己展開型の実行可能 (.exe) ファイルをコンポーネントとして指定できます。ユーザーがインストールする Microsoft コンポーネントのバージョンを指定することができます。また、自動バージョン同期 (AVS) を使って最新のバージョンをインストールできます。

インターネット経由でダウンロードされるカスタム コードには署名を施すことをお勧めします。カスタム コードを何か署名しておけば、ユーザーはコードの身元を確認してから、自分のコンピュータにダウンロードすることができます。 Internet Explorer の既定の設定では、カスタム コードが署名されていないものは拒否されます。

次に示すオプションには、特定のオペレーション システムでしか使用できないものがあります。

詳細の確認

[コンポーネント]
このボックスには、コンポーネントの名前を入力します。この名前は、ユーザーがソフトウェアをインストールするときにセットアップ画面に表示されます。
[場所]
プログラムのパスを入力するか、[参照] をクリックしてそのパスを検索します。
[コマンド]
.cab ファイルを指定する場合は、キャビネット ファイルを解凍するためのコマンドも指定しなければなりません。
[GUID]
グローバル一意識別子 (GUID) を使用すれば、プログラムやオブジェクトなどの項目を一意に識別することができます。 GUID をプログラムで取得済みの場合は、それをこのボックスに入力します。プログラムがまだ GUID を取得していない場合は、GUID は自動的に生成されます。
[説明]
コンポーネントの説明を 511 文字以内で入力します。この文字列は、セットアップ画面でユーザーがコンポーネントをポイントしたときに表示されます。
[パラメータ]
実行時にカスタム プログラムに渡すスイッチを指定できます。たとえば、プロンプトがほとんどあるいはまったく表示されない、プログラムの "サイレント" インストールを行うと、プログラムと Internet Explorer のプロンプトはユーザーの目に触れることはありません。セットアップ プロンプトを非表示にするには、/Q:A スイッチを使います。
[アンインストール キー]
Windows Update セットアップは、この値とHKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\ApplicationName を比較し、現在インストールされているコンポーネントを再確認します。

詳細については、「カスタム コンポーネントのアンインストール」を参照してください。

[バージョン]
作成する Internet Explorer のカスタム パッケージに割り当てるシリアル番号を入力します。このバージョン番号の正しい書式は、xxxx,xxxx,xxxx,xxxx です。バージョン番号には数字を使用し、アルファベット文字は含めないでください。
[追加]
[追加] をクリックして、フィールドを空白にし、新しいカスタム コンポーネントを追加します。
[削除]
[削除] をクリックして、カスタム パッケージから現在のコンポーネントを削除します。
[参照]
[参照] をクリックして、カスタム コンポーネントの保存場所を検索します。
[確認]
インターネット経由でインストールするプログラムには、通常デジタル署名が必要です。プログラムの身元の確認と、署名の時点以降にコードが変更されていないことの保証は、この署名によって行われます。ブラウザのセキュリティの設定に従って、ユーザーはプログラムをダウンロードする前に警告を受け取ることもできます。コードの署名に必要な公開キーおよび秘密キーは、証明機関から取得できます。デジタル署名がプログラムに実施されているかどうかを調べるには、[確認] をクリックします。Internet Explorer 6 カスタマイズ ウィザードの実行時に、残りのファイルへの署名を施す場合は、その証明書による署名もこのコンポーネントに付加されます。

コード署名の詳細については、「Microsoft Security Advisor に関する Web サイト」を参照してください。

[インストールするタイミング]

[Internet Explorer のインストール前]
たとえば、バッチ ファイルを実行してユーザーの設定を構成するなど、Internet Explorer をインストールする前にカスタム コンポーネントをインストールする必要がある場合は、このオプションを使います。
[Internet Explorer のインストール後]
1 つまたは複数の Internet Explorer ソフトウェアの修正プログラムをインストールする場合、あるいは、自動バージョン同期を使ってダウンロードした基礎となる Internet Explorer に、異なるバージョンのコンポーネントが含まれていた場合には、このオプションを使います。

注

  • DirectAnimation や NetMeeting など、基礎となる Internet Explorer コンポーネントの異なるバージョンを取得して、これらのファイルをカスタム コンポーネントのパッケージに追加する場合、それらは同じファイルのサブセットを 2 度ダウンロードするため、ユーザーのダウンロード時間が増加してしまいます。
[システムの再起動後]
カスタム コンポーネントにシステム サービス パックまたは Microsoft Java Virtual Machine (VM) のアップデートが含まれている場合は、このオプションを使います。
[Internet Explorer が正しくインストールされたときのみ]
Internet Explorer がユーザーのマシンにインストールされていない限り、このコンポーネントはインストールしないでください。

注

  • IEAK には、IExpress スクリプト作成用のツールが用意されています。その他のツールは、「MSDN Online Web Workshop」に用意されています。
  • ブランドおよびカスタム コンポーネントのインストールがカスタム ブラウザに適用される仕組みを説明する図解については、「カスタマイズの仕組み」を参照してください。


段階 2 : セットアップ パラメータの指定

Internet Explorer 6 カスタマイズ ウィザードのこの段階では、どのコンポーネントをカスタム パッケージに含めるかを指定します。

利用できるオプションは、次のうちどの職種を選択しているかによって異なります。

  • インターネット コンテンツ プロバイダ
  • インターネット サービス プロバイダ
  • 企業内管理者


セットアップのカスタマイズ

セットアップ ウィザードの外観をカスタマイズすることができます。Windows Update セットアップ ウィザードをユーザーが実行するときに表示されるタイトル バーとグラフィックスをカスタマイズできます。一連のカスタム コンポーネントをグループにまとめれば、そのグループに名前を付けることができます。

[セットアップ ウィザードのタイトル バーの文字列]
この文字列は、ユーザーが実行するセットアップ ウィザードのタイトル バーに表示されます。このテキストは、カスタム ブラウザのタイトル バーに表示されるものではありません。ブラウザのタイトル バーは、Internet Explorer 6 カスタマイズ ウィザードの後の方でカスタマイズできます。
[左側に位置するセットアップ ウィザードのビットマップ パス (最初のページ)]
これは、セットアップ ウィザードの先頭ページ用に作成された 162 × 312 ピクセルのグラフィックスです。このグラフィックスによって、カスタム パッケージのセットアップ ウィザードの外観がカスタマイズされます。複雑な線やパターンがあるグラフィックスは使用しないでください。
[上側に位置するバーナー セットアップ ウィザードのビットマップ パス (最初以外のすべてのページ)]
これは、セットアップの指示情報の背景に表示される 496 × 56 ピクセルのグラフィックスです。前面の文字が読みにくくならないビットマップを使用してください。
[カスタム コンポーネントのインストール名]
カスタム ブラウザをインストールする際は、カスタム コンポーネントをインストールすることができます。複数のカスタム コンポーネントを指定する場合は、それらのコンポーネントを 1 つのグループとして、たとえば「Volcano Coffee Company Inventory Programs」などの名前を付けることができます。このグループ名は、ユーザーがカスタム パッケージをインストールするときに、Windows Update セットアップ ウィザードに表示されます。表示したい名前を、ここで指定してください。

注

  • ブラウザおよびカスタム コンポーネントのインストールがカスタム ブラウザに適用される仕組みを説明する図解については、「カスタマイズの仕組み」を参照してください。


接続マネージャのカスタマイズ

接続マネージャ管理キット (CMAK) は、ユーザーがインターネットまたは企業内ネットワークに接続する方法を構成および管理するために使用するツールです。CMAK では、独自のカスタム アイコン、ヘルプ ファイル、および動画グラフィックスを使って、Microsoft 接続マネージャ ダイヤラの外観および設定を変更できます。

CMAK は、IEAK 6 には含まれていません。CMAK は、Windows 2000 Server 、あるいは Windows 2000 および Windows XP 管理キットで使用できます。以前のバージョンの CMAK は、IEAK のバージョン 5.0 で使用できます。

既に CMAK を使ってカスタム プロファイルを作成してある場合は、Internet Explorer 6 カスタマイズ ウィザードを使って、インストール パッケージにインポートすることができます。

[指定されたカスタムのプロファイルを使用する]
既にカスタムの CMAK プロファイルを作成してある場合は、このブラウザ パッケージで使用する作成したプロファイルのパスを入力します。このプロファイルで、カスタム コンテンツと接続方法を指定します。CMAK ファイルには、.cmp および .cms ファイルが含まれます。サービス プロバイダのカスタマイズ内容は、.cms ファイルに含まれています。

注

  • CMAK は、ユーザーのコンピュータにインストールされる自己展開型の実行可能ファイル (*.exe) を作成します。ユーザーがカスタム アイコンをクリックしてインターネットに接続すると、作成したカスタム ダイヤラのダイアログ ボックスが表示されます。
  • CMAK によって作成される自己展開型の実行可能ファイルには、IEAK パッケージに含める前にデジタル署名を施す必要はありません。IEAK のファイルに電子署名を施すと、CMAK のファイルにも電子署名が自動的に付加されます。

詳細については、接続マネージャ管理キットのオンライン ヘルプを参照してください。


ユーザーによるインストール

Windows Update セットアップの実行中に、ユーザー側の手順を微調整することができます。

[インタラクティブ インストール]
ユーザーは、Internet Explorer のカスタム パッケージをインストールするときに、インストールの種類、ダウンロード サイト、およびインストール先のフォルダを選択することができます。インストールの実行中は、進捗状況を示すダイアログ ボックスやエラー メッセージのすべてが表示されます。
[ハンド フリー インストール]
インストールの進捗状況とエラー メッセージだけを表示し、インストールの設定はすべて自動で行われるようにするには、[ハンド フリー インストール] をクリックします。
[完全サイレント インストール]
ダイアログ ボックスや進捗状況のメッセージを表示しないでユーザーにカスタム ブラウザをインストールさせるには、[完全サイレント インストール] をクリックします。このオプションは、/Q:A スイッチを使って Internet Explorer をインストールした場合と同じになります。

注

  • サイレント インストール時は、ユーザー用のインストール オプションとダウンロード サイトを 1 つずつしか指定できません。
  • インストールをさらに微調整する場合は、追加の Internet Explorer の バッチ セットアップおよび IExpress のバッチ セットアップ用スイッチを使用できます。

完全サイレント インストールまたはハンド フリー インストールで行われる処理

サイレント インストール (ハンド フリーまたは完全サイレント) では、次の処理が行われます。

  • セットアップ処理を実行するのに必要なプロンプトに対して応答する。
  • 使用許諾契約を承認する。
  • Internet Explorer をダウンロードすると共にインストールするように指定する。
  • このインストール パッケージに指定した種類のインストール (標準やカスタムなど) を実行します。
  • 既にインストールされている場合を除いて、指定された場所に Internet Explorer をインストールする。ただし、Internet Explorer がインストール済みの場合は、それと同じ場所に新しいバージョンのブラウザがインストールされます。
  • このパッケージに指定した先頭のダウンロード サイトに接続します。

これらのモードはいずれもインタラクティブではなく、ユーザーは Windows Update セットアップの進捗を制御することができません。完全サイレント インストールでは、インストールが正常に完了しなかった場合でも、エラー メッセージは表示されません。このモードは、ユーザーがコンピュータの前にいないときにインストールを展開する場合などに役立ちます。

ユーザー権限

Windows NT、Windows 2000、および Windows XP のセキュリティ モデルにより、ユーザーがシステムにソフトウェアをインストールするのを防ぐことができます。重要なシステム ファイルを登録するには、ソフトウェアのインストール時はもちろんコンピュータの再起動後にも、管理者権限が必要です。パッケージのインストール後、管理者権限を持たないユーザーがログオンするようなシステム環境では、このことがシステムに対する新しいバージョンの Internet Explorer の展開を複雑にしています。

[再起動後のユーザー レベルのアクセスでのログオンを有効にする]
コンピュータの再起動後にも管理者権限が保持されるようにパッケージをカスタマイズするには、このチェック ボックスをオンにします。コンピュータの再起動後、ユーザーがログインすると、Windows インストーラ コンポーネントは Internet Explorer のシステム ファイルの登録を完了します。このパッケージは手動で、あるいは Systems Management Server (SMS) などの自動展開方法の一部としてユーザーに配布できます。どちらの場合も、次回からはユーザーがシステムにログオンするときに、管理者権限を求められることはありません。

Windows 95、Windows 98、または Windows Millennium Edition を実行しているコンピュータに IEAK パッケージをインストールするのに、管理者権限は必要ありません。これらのオペレーティング システムは、これらのシステムでのファイル登録を管理しないからです。

このパッケージが SMS クライアントにインストールされると、コンポーネントは .mif ステータス ファイルを生成します。SMS はこのファイルを使用して、パッケージが正常にインストールされたかどうかを検出します。

重要

  • このオプションを選択する場合は、パッケージのメディアの形式がフラットである (すべてのファイルが 1 つのフォルダ内にある) ことを確認してください。
  • このオプションを使用する前に、ユーザーがパッケージをインストールするときに他の Windows インストーラが実行されていないことを確認してください。
  • Internet Explorer が、Microsoft Office などの別の Windows インストーラのコンポーネントである場合は、この方法を使用しないでください。
  • このオプションを選択する場合は、その影響を全体的にチェックしてから、このパッケージをユーザーに配布してください。
  • ウィザードの段階 1 のメディアの選択で、配布方法として [フラット] を選択した場合にのみ、ユーザー権限が表示されます。


インストール オプション

インストール オプション (標準やカスタムなど) は 10 個まで指定でき、それぞれのモードについてインストールするブラウザとカスタム コンポーネントを指定できます。企業内管理者であり、このパッケージにサイレント インストールを指定した場合、指定できるインストール オプション (モード) は 1 つだけです。

重要

  • パッケージに構成したインストール オプションにかかわらず、Windows Update セットアップは、Windows 2000 および Windows XP オペレーティング システムを実行しているユーザーには、インストール オプションを 1 つだけ表示します。 このインストール オプションには、パッケージに入れたすべてのカスタム コンポーネントと、Internet Explorer コンポーネントのフル セットが含まれます。
[オプション]
既定のインストール オプションを選択します。または、[新規] をクリックして、新しいセットアップ オプションを作成します。オプションの説明を入力した後、矢印をクリックしてコンポーネントの追加や削除を行ってください。

ISP の方の場合は、個々のユーザー グループに合わせてセットアップ オプションを作成してください。企業内管理者の方の場合は、社内の各種部署に合わせてセットアップ オプションを指定してください。

[説明]
インストール オプションの説明 (インストールの対象となるコンポーネントやプログラムの一覧など) を入力します。ここで入力した文字列は、Windows Update セットアップ ウィザードに表示されます。

注

  • 説明の文字列にアンダースコアを使用するには、アンパサンド (&) を入力します。アンパサンドの文字を使用するには、アンパサンドを 2 つ (&&) 入力します。
[利用できるコンポーネント]
利用できるコンポーネントの一覧では、ダウンロードした Internet Explorer のコンポーネントや定義したカスタム コンポーネントを指定します。この一覧にコンポーネントを追加するには、Internet Explorer 6 カスタマイズ ウィザードの段階 2 に戻って行ってください。
[インストールするコンポーネント]
この一覧には、[オプション] ボックスの中のオプションを選択したときにインストールされる一連のコンポーネントが表示されます。一重の矢印をクリックすれば、各コンポーネントを対象として追加や削除が行えます。 また、二重の矢印をクリックすれば、利用できるすべてのコンポーネントを対象として追加や削除が行えます。

注

  • ブランドおよびカスタム コンポーネントのインストールがカスタム ブラウザに適用される仕組みを説明する図解については、「カスタマイズの仕組み」を参照してください。


コンポーネント ダウンロード サイト

ダウンロード サイト は 10 個以下で、少なくとも 1 つ指定する必要があります。各サイトには、HTTP または FTP サーバーを使用する必要があります。 また、Microsoft のコンポーネントやカスタム コンポーネントは、各サイトにすべて格納しておく必要があります。

[サイト名]
サイトの名前を入力します。サイト名は、わかりやすい名前で指定できます。サイト名には、カンマを使用しないでください。
[サイト URL]
サイトの URL を入力します。Ie6sites.dat ファイルが追加または更新され、パッケージの言語に対応するサブフォルダ (英語の場合の ENなど) が URL に付加されます。
[サイトの地域]
該当サイトが存在している地域の情報 (国、地方、県や州、市など) を入力します。
カスタム ダウンロード サイト
Internet Explorer 6 カスタマイズ ウィザードのこのページに追加するサイトは、この列に一覧表示されます。

注

  • 企業内管理者であり、このパッケージにサイレント インストールを指定した場合、指定できるダウンロード サイトは 1 つだけです。
  • 図解については、「配布用ファイルの設定方法」および「Windows Update セットアップ ウィザードによる Internet Explorer およびその他のインターネット ツールのセットアップ」を参照してください。

先頭のサイトの URL を処理できない場合

サーバーに問題が発生したことなどが原因で先頭のサイトがダウンしていると、既定では、セットアップは、残りのサイトを見つけることができません。次のコマンドで先頭サイトを上書きすると、それを解決できます。

<path>\IE6Setup.exe /C:"ie6wzd.exe /S:""<path>\IE6Setup.exe"" /L:""http://my Web server/my Web site/IE6sites.dat"""

<path> は、IE6setup.exe があるフォルダです。

例

次に、先頭のサイトがダウンしているときに、ユーザーに与える構文の例を示します。これは 1 行のコマンド ラインですが、読みやすいように複数の行で表示しています。

C:\IE6Setup.exe /C:"IE6wzd.exe
/S:""D:\Build\1700\package\download\win95_nt\en\IE6Setup.exe""
/L:""http://<NewServerAddress>/<YourDownloadDir>/IE6sites.dat """


コンポーネントのダウンロード

新しいバージョンの Internet Explorer がリリースされると、ユーザーは [ツール] メニューの [Windows Update] をクリックして、Internet Explorer を更新することができます。 このページは、コントロール パネルの [プログラムの追加と削除] をクリックし、[Internet Explorer とインターネット ツール] をクリックして [追加と削除] ボタンをクリックしたときにも表示されます。

[[ツール] メニューから [Windows Update] コマンドを削除する]
このオプションをクリックした場合、ユーザーがカスタム パッケージをインストールすると、[ツール] メニューに [Windows Update] オプションが表示されなくなります。 Internet Explorer を更新するには、新しいカスタム パッケージを作成して、ユーザーに展開する必要があります。
[Windows Update の既定の URL を使用する]
このオプションをクリックした場合、ユーザーが [ツール] メニューの [Windows Update] をクリックして、新しいバージョンの Internet Explorer をインストールします。

更新された製品をダウンロードする既定のサイトは、カスタム ブラウザをダウンロードしたサイトに設定されていますが、カスタムのアドオン コンポーネントの場所を指定することもできます。

[カスタム アドオン URL およびメニューの文字を使用する]
Internet Explorer の新しいバージョンをダウンロードする [ツール] メニューのオプションの名前をカスタマイズできます。 オプションの名前をカスタマイズする場合は、[アドオン コンポーネント ページの URL] を指定することもできます。
[アドオン コンポーネント URL のメニューの文字]
[ツール] メニューの [Windows Update] の位置に表示される文字列を入力します。 ユーザーはこのメニュー オプションをクリックして、カスタム パッケージの新しいバージョンをインストールします。
[アドオン コンポーネント ページの URL]
更新されたソフトウェア (アドオン コンポーネント) をほかの URL からダウンロードさせるには、このボックスに URL を指定します。 これは、ユーザーが [ツール] メニューのカスタム メニュー オプションをクリックしてダウンロードするカスタム コンポーネントの保存場所です。
[インストールした後で、Microsoft からコンポーネントをダウンロードする]
このチェック ボックスをオンにすると、ブラウザのインストール後にすべてのコンポーネントが Microsoft のサイトからダウンロードされます。ここでは、ユーザーが追加のアドオン コンポーネントをダウンロードすることができます。

注

  • 以前のバージョンの IEAK でこの画面に表示されていた構成 ID およびバージョン番号は、必要なくなりました。 これらの値は自動的に生成されます。 IEAK を使用して作成するカスタム設定またはブランドは、バージョン番号や構成 ID に関係なく常にインストールされます。


インストール ディレクトリ

企業内管理者の方の場合は、ユーザーが Internet Explorer およびその他のインターネット コンポーネントをインストールする場所を指定することができます。また、ユーザーが別のインストール フォルダを選択できるようにするかどうかを指定することができます。

ユーザーが保存場所を変更できるようにするには、[Internet Explorer のインストール先をユーザーが選択できる] をクリックします。このオプションを選択した場合は、指定したフォルダまたはパスが既定の場所として表示されます。

[[Windows] フォルダの指定されたフォルダにインストールする] または [[Program Files] フォルダの指定されたフォルダにインストールする] をクリックすると、Internet Explorer はボックスに表示されたサブフォルダにインストールされます。

[カスタム フォルダへの完全なパスを指定する] をクリックすると、目的のパスを入力することができます。パスがユーザーのハード ディスク上に存在していない場合は、作成されます。

注

  • ユーザーのコンピュータに Internet Explorer が既にインストールされている場合、既存のものは新しいバージョンによって上書きされます。ただし、カスタム ブラウザは、指定した場所にはインストールされません。


企業用インストール機能

ここで、ユーザーに対してWindows Update セットアップをどの程度までカスタマイズ可能にするかを指定できます。

[カスタム インストール オプションを無効にする]
Internet Explorer ユーザーは、カスタム パッケージをそのままインストールします。ユーザーは、カスタム インストールを使ってコンポーネントを個々にインストールすることはできません。
[アンインストール情報の保存を無効にする]
Windows Update セットアップは、アンインストール情報を自動的に保存します。ディスク領域を節約するには、このチェック ボックスをオンにして、アンインストール情報を保存しないようにできます。 ただし、アンインストール情報を保存しないと、ユーザーはコントロール パネルの [プログラムの追加と削除] をクリックして Internet Explorer を削除することができなくなります。
[Internet Explorer 互換モードのインストールを無効にする]
Internet Explorer の互換性オプションを使用すると Internet Explorer 5 以降がインストールされたコンピュータで Internet Explorer 4 の Web ページ機能をテストすることができます。この機能を無効にするには、このチェック ボックスをオンにします。
[既定のブラウザ]
次のいずれかのオプションを選択します。
  • [Internet Explorer を既定のブラウザとして設定する]
  • [Internet Explorer を既定のブラウザとして設定しない]
  • [ユーザーが選択する]

注

  • また、[既定のブラウザ] オプションで、Windows Media Player をマルチメディア ファイル再生用の既定のプログラムにするかどうかを指定します。
  • サイレント インストール モードを使用する場合、または Office Custom Installation Wizard を使用して Microsoft Office の展開用に Internet Explorer をカスタマイズする場合は、セットアップ中、Internet Explorer のユーザー オプションは表示されません。


Windows デスクトップのアップデート

Windows デスクトップのアップデートを使用すれば、デスクトップおよびフォルダの外観を Web に近づけることができます。Windows デスクトップのアップデートは Internet Explorer 5 以降には付属していませんが、必要に応じて IEAK パッケージに追加できます。Windows 98 またはそれ以降を使用している場合、このデスクトップ機能はあらかじめインストールされています。

Windows デスクトップのアップデートのインストールを選択した場合は、パッケージの作成に使用するコンピュータが次のいずれかの条件を満たしていれば、Internet Explorer 6 カスタマイズ ウィザードの後の方で Windows デスクトップのアップデートの設定をカスタマイズできます。

  • Windows 98
  • Windows 98 Second Edition
  • Windows Millennium Edition
  • Windows 2000
  • Windows の別のバージョンでは、Windows デスクトップのアップデートがインストールされた Internet Explorer 6 を使用している必要があります。

Windows デスクトップのアップデートは、社内標準のデスクトップを設定する場合に役立ちます。

[カスタム パッケージに Windows デスクトップのアップデートを統合しますか?]
Windows デスクトップのアップデートをインストールする場合は、[はい] をクリックします。 インストールしない場合は、[いいえ] をクリックします。


高度なインストール オプション

ここで、Windows Update セットアップを詳細にカスタマイズできます。特定のコンポーネントが既にインストールされているかどうかを検出するようにセットアップを設定したり、ユーザーがセットアップをカスタマイズするときに追加できるコンポーネントを詳細に設定することができます。

[Web ダウンロードを最適化する (互換性のあるバージョンが存在した場合は、ダウンロードしない)]
同じバージョンのコンポーネントがユーザーのコンピュータに既にインストールされているかどうかをセットアップの実行時に検出できます。そのバージョンのコンポーネントが既にインストールされており、Internet Explorer と一緒に動作している場合、セットアップはそのコンポーネントをダウンロードしません。これにより、ユーザーはダウンロードに要する時間を短縮できます。

注

  • 自動バージョン同期を使って以前にダウンロードした Internet Explorer の .cab ファイルに含まれるものではなく、特定のバージョンのコンポーネントをインストールする場合は、Web ダウンロードを最適化しないでください。
[特定のコンポーネントをカスタマイズしない]
ユーザーがセットアップをカスタマイズできるように設定している場合で、特定のコンポーネントについてはカスタマイズできないようにするには、そのコンポーネントに対応するチェック ボックスをオフにします。 Windows Update セットアップで、ブラウザと共に自動的にインストールされるコンポーネントの右側の列には、[強制インストール] と表示されます。


メディアのコンポーネント

この一覧には、現在使用しているコンピュータにダウンロードされているコンポーネントのうち、Windows Update セットアップで指定したモードのいずれかに含まれていないコンポーネントが表示されます。それらのコンポーネントを必要とする機能をユーザーが使用しようとすると、それらのコンポーネントがオンデマンドのインストールによって自動的にインストールされるように設定されます。


デジタル署名

証明機関または Microsoft 証明書サービスから既に発行元証明書を取得している場合は、ウィザードのこの段階でカスタム パッケージに電子署名を施すことができます。

IEAK で使用する証明書を用意するには、証明書のインポート ウィザードを使用して現在のコンピュータに証明書をインポートします。拡張子 .spc のファイルを受け取ったら、Windows のエクスプローラまたはマイ コンピュータで .spc ファイルをダブルクリックして、このウィザードを起動することができます。

Internet Explorer から証明書のインポート ウィザードを開くこともできます。 [ツール] メニューの [インターネット オプション] をクリックし、[コンテンツ] タブをクリックして、[証明書] をクリックしてください。[インポート] をクリックすると証明書のインポート ウィザードが起動するので、ウィザードの指示に従ってください。

[証明書での会社名]
発行元証明書が既にコンピュータにインポートされている場合は、証明書の会社名がこの一覧に表示されます。
[ソフトウェア発行元証明書 (.spc) のファイル]
証明書に関連付けられた .spc ファイルの名前を入力するか、[参照] をクリックしてパスを検索します。
[秘密 キー (.pvk) のファイル]
証明書に関連付けられた .pvk ファイルの名前を入するか、[参照] をクリックしてパスを検索します。
[説明]
説明テキストを入力します。このテキストは、この証明書で署名したプログラムをユーザーがダウンロードするときに表示されるダイアログ ボックスで表示されます。
[詳細情報 URL]
ユーザーがクリックして証明書と会社名に関する詳細情報を取得するための URL を入力します。
[タイム スタンプの URL]
ユーザーがクリックして、証明書が発行された日付と時刻を使って証明書の有効性を確認できる URL を入力します。


CD 自動実行のカスタマイズ

CD-ROM 版のカスタム パッケージを作成する場合は、CD-ROMの自動実行画面を作成し、ユーザーが CD-ROM を CD-ROM ドライブに挿入したときにその画面を表示することができます。イメージは、256 色のビットマップで、540 × 357 ピクセルの大きさにしてください。

CD-ROMの自動実行画面を作成する場合は、1 つの背景ビットマップと 2 つのボタンのラベルを指定することができます。1 つは Internet Explorer をインストールするためのボタン、もう 1 つは詳細情報を表示するためのボタンです。また、タイトル バーや文字列の色もカスタマイズすることができます。

[タイトル バーの文字列]
ここで指定した文字列は、自動実行画面のタイトル バーに表示されます。
[カスタム背景ビットマップの場所]
文字列の背景に表示するビットマップを指定することができます。ただし、背景の色は、文字列の色と重ならないようにしてください。
[標準テキストの色]
リンク部分以外の文字列の色を指定します。
[強調表示テキストの色]
ページ上のリンク部分の色を指定します。
[ボタンのスタイル]
Internet Explorer のインストールおよび詳細情報を表示するときにユーザーがクリックするボタンの外観を指定します。
  • [標準] を選択すると、Microsoft の標準的なソフトウェア プログラムで表示されるのと同様のボタンが表示されます。それらはグレースケールで四角形のボタンです。
  • [3D ビットマップ] を選択すると、ボタンは立体的に表示されます。
  • [カスタム ビットマップ (場所を指定してください)] を選択すると、ボタンは指定したビットマップに基づいて作成されます。イメージへのパスを検索するには、[参照] をクリックします。


CD の詳細設定

ここで、CD-ROM からのインストールを詳細にカスタマイズできます。 readme ファイルに代表される情報ファイル (.inf) を追加したり、インストール後に表示される特別な Web ページを指定することができます。

[テキスト ファイルの詳細情報]
インストール後にユーザーに参照させるファイルのパスおよび名前を指定します。既定では、CD-ROM 自動実行画面には、このファイルへのリンクが用意されています。このファイルの名前を変更した場合は、自動実行画面に定義されているパスを更新する必要があります。
[キオスク モードのスタート ページを使用する]
キオスク モードで Internet Explorer ウィンドウを使用するには、このチェック ボックスをオンにします。
[キオスク モードのスタート ページ HTML ファイル]
Internet Explorer のインストールが完了したときに表示される .htm ファイルのパスおよびファイル名を指定します。このページは、キオスク モードで表示されます。このページに関連するグラフィック ファイルは、.htm ファイルと同じフォルダに格納する必要があります。


段階 3 : セットアップのカスタマイズ

Internet Explorer 6 カスタマイズ ウィザードのこの段階では、Windows Update セットアップをどのようにカスタマイズするかを指定します。

利用できるオプションは、次のうちどの職種を選択しているかによって異なります。

  • インターネット コンテンツ プロバイダ
  • インターネット サービス プロバイダ
  • 企業内管理者


ブラウザ名

Internet Explorer および Outlook Express のタイトル バーに表示される文字列をカスタマイズすることができます。Outlook Express をパッケージに含めるかどうか、あるいは Outlook Express がユーザーのコンピュータに既にインストールされているかどうかにかかわらず、Outlook Express のタイトル バーは更新されます。表示したい文字列を入力してください。入力した文字列は、"Microsoft Internet Explorer の提供元 :" または "Outlook Express の提供元 :" という文字列の後に追加されます。

注

  • ビットマップを選択する際は、文字列と色とのコントラストに注意してください。ユーザーが見やすいように調整する必要があります。
  • カスタム ブラウザへのブランドの方法の図解については、「カスタマイズの仕組み」を参照してください。

タイトル バーをカスタマイズするには

  1. [タイトル バーをカスタマイズする] チェック ボックスをオンにします。
  2. [タイトル バーの文字列] ボックスにタイトルの文字列を入力します。


ツール バーのカスタマイズ

ユーザーのブラウザに表示するツール バーを独自に設定して、柔軟に設計を施すことができます。操作できる要素には、ツール バーの背景、[検索] および [履歴] といった標準のツール バー ボタンのアイコンの外観などがあります。

ツール バーをさらにカスタマイズするには、その他のボタンの外観および数を変更することができます。ボタンから起動するスクリプトまたはプログラムを指定することができるので、カスタム パッケージに含めるツール バーをより詳細に制御できます。カスタム プログラムの設計の詳細については、「MSDN Online Web Workshop」を参照してください。

[背景]
背景をカスタマイズしない場合は、[Windows 既定のツール バーの背景ビットマップを使う] をクリックします。背景をカスタマイズするには、[ツール バーの背景ビットマップをカスタム設定する] をクリックし、ビットマップ ファイルのファイル名および場所を指定します。
[ボタン]
カスタム ツール バーのボタンを操作するときは、独自に作成したボタンのアイコン、各ボタンに関連付けられたスクリプト ファイルまたは実行可能ファイル、およびツール バー アイコン ファイルの場所を追加できます。ボタンを追加した後で、ウィザードの [ツール バーのカスタマイズ] ページに戻り、必要に応じてそれらのボタンを編集または削除することができます。
[既存のツール バーのボタンを削除する]
ユーザーのブラウザにあるツール バー ボタンのうち、Internet Explorer と共に標準でインストールされるボタンを除くすべてのボタンを削除するには、このチェック ボックスをオンにします。このオプションは、企業内管理者のみ使用できます。

注

  • ツール バーの背景は、大きさをツール バーに合わせ、黒色の文字列が十分見える程度の明るさにしてください。
  • Windows でテーマを有効にすると、カスタム ツール バーの背景は無視されます。カスタム ツール バーの背景を使用するには、Windows クラシック テーマに切り替えます。
  • [既存のツール バーのボタンを削除する] チェック ボックスをオンにすると、手動で追加したボタンだけが削除されます。Internet Explorer と共にインストールされた標準のボタンは残ります。

カスタム ツール バーのボタンを追加するには

  1. [追加] をクリックします。
  2. [ツール バーのタイトル (必須)] ボックスに、ユーザーがツール バー ボタンの上にマウス ポインタを移動したときに表示される文字列を入力します。ボタンのキャプション (ラベル) を指定する必要があります。キャプションの長さは 10 文字以内にしてください。
  3. [ツール バーの処理、スクリプト形式または実行ファイル形式 (必須)] ボックスにスクリプト ファイルまたは実行可能ファイルのファイル名を入力するか、[参照] をクリックしてそのファイルを検索します。ユーザーがツール バー ボタンをクリックしたときに実行されるスクリプトまたは実行可能ファイルを指定する必要があります。
  4. [ツール バーのカラー アイコン (必須)] ボックスに選択状態のボタンを表すファイルのファイル名を入力するか、[参照] をクリックしてそのファイルを検索します。ツール バー ボタンに表示するカラーのアイコンを指定する必要があります。アイコンは、20 × 20 ピクセルのサイズの選択状態と非選択状態の 2 つの画像から成ります。詳細については、「MSDN オンライン Web ワークショップ」(英語) を参照してください。
  5. [ツール バーのグレースケール アイコン (必須)] ボックスにモノクロ モニタで表示するツール バーのグレースケール アイコンのファイル名および場所を入力するか、[参照] をクリックしてそのファイルを検索します。ツール バー ボタンに表示するグレースケールのアイコンを指定する必要があります。
  6. [既定で、このボタンをツール バーに表示する] チェック ボックスをオンにすると、ユーザーのブラウザに既定でツール バーのボタンが表示されます。

注

  • ビットマップ、スクリプト、およびアプリケーションの場所を指定するときは、ファイル名だけでなくアドレスも指定します。
  • カスタム ブラウザへのブランドの方法の図解については、「カスタマイズの仕組み」を参照してください。

カスタム ツール バーのボタンを編集するには

  1. カスタム ツール バーのボタンの一覧で、操作するボタンをクリックします。次に、[編集] をクリックします。
  2. 変更する情報を編集します。

カスタム ツール バーのボタンを削除するには

  1. カスタム ツール バーのボタンの一覧で、削除するボタンをクリックします。
  2. [削除] をクリックします。ツール バーのボタンが一覧からすぐに削除されます。Internet Explorer のカスタム パッケージをインストールしたユーザーは、ボタンを使用できません。


カスタム ロゴおよび動画ビットマップ

ブラウザ画面の右上隅にある Internet Explorer のロゴには、2 つの表示状態があります。静止画 (ブラウザの休止中を示す) および動画 (ブラウザの動作中を示す) です。ロゴのビットマップは、独自の動画および静止画のビットマップで置き換えることができます。

静止ロゴのカスタマイズ

静止画のビットマップを使用する場合、それはブラウザの休止中に静止画として表示されます。

独自の静止ロゴを使用するには、まずビットマップを 2 つ作成します。1 つ目は 22 × 22 ピクセル、2 つ目は 38 × 38 ピクセルの大きさにします。次に、[小さいビットマップ (22x22)] および [大きいビットマップ (38x38)] ボックスでロゴへのパスを指定します。

動画ロゴのカスタマイズ

動画のビットマップを使用する場合、先頭のフレームは、ブラウザの休止中に静止画として表示されます。残りのフレームは、ブラウザの動作中に動画として表示されます。

独自の動画ロゴを使用するには、まず動画ビットマップを 2 つ作成します。1 つ目は 22 × 22 ピクセル、2 つ目は 38 × 38 ピクセルの大きさにします。次に、[小さいビットマップ (22x22)] および [大きいビットマップ (38x38)] ボックスでロゴへのパスを指定します。

動画ビットマップのサンプルは、\<IEAK プログラム フォルダ>\Toolkit フォルダにインストールされる Internet Explorer 管理者キット ツールキットの中に入っています。

注

  • IEAK には、ブラウザに合ったカスタム版の動画ビットマップを簡単に作成できるようなツールが 2 つ入っています。片方のツールは上記のフォーマットで一連のビットマップを作成する際に使用し、もう一方のツールは動画をプレビューする際に使用します。
  • カスタム ブラウザへのブランドの方法の図解については、「カスタマイズの仕組み」を参照してください。


重要な URL

ホーム ページ、検索ページ、およびオンライン サポート ページの URL を指定できます。

[ホーム ページの URL]
ホーム ページ (スタート ページとも呼ばれる) は、ユーザーが [ホーム] ボタンをクリックすると表示されます。Internet Explorer では、既定のホーム ページを表示することも、独自のページの URL を指定することもできます。

ホーム ページをカスタマイズする場合は、[ホーム ページの URL をカスタマイズする] チェック ボックスをオンにします。ホーム ページとして使用するページの URL を [ホーム ページの URL] ボックスに入力します。

[検索バーの URL]
検索バーは画面の左側に表示されます。検索バーを使用すると、ユーザーは検索条件と検索結果を同時に表示できます。検索エンジンを選択することができます。検索バーの URL をカスタマイズする場合は、[検索バーの URL をカスタマイズする] チェック ボックスをオンにします。次に、[検索バーの URL] ボックスに URL を入力します。
[オンライン サポート ページの URL]
ユーザーが Internet Explorer でサポート情報を利用するには、[ヘルプ] メニューの [オンライン サポート] をクリックします。サポート ページを作成し、ユーザーが利用できるようにしてください。

サポート ページをカスタマイズする場合は、[オンライン サポート ページの URL をカスタマイズする] チェック ボックスをオンにします。次に、[オンライン サポート ページの URL] ボックスにカスタム サポート ページの URL を入力します。


お気に入りとリンク

[お気に入り] フォルダおよびリンク バーは、会社やサービスに関連したサイトへのリンクを追加することによってカスタマイズすることができます。たとえば、エンターテインメントを専門とする ICP の方の場合は、エンターテインメントに関連したサイトへのリンクを追加できます。

既定では、リンク バーは、ユーザー画面の上部に表示され、その中には一連の既定のリンク先が表示されます。この既定のフォルダにリンクを追加することも、新しいフォルダを追加することもできます。ユーザーが [お気に入り] をクリックすると、[お気に入り] の一覧がウィンドウの左側に表示されます。

[お気に入りとリンクを一覧の先頭に指定した順序で配置する]
このチェック ボックスをオンにすると、選択したお気に入りおよびリンクがユーザーの [お気に入り] の一覧の最初に移動されるので、ユーザーはそのお気に入りやリンクを見つけやすくなります。このチェック ボックスをオンにすると、[上へ] および [下へ] ボタンが使用できるようになります。
[既存のお気に入りとリンクを削除する]
企業内管理者の場合は、このチェック ボックスをオンにすると、ユーザーの [お気に入り] 一覧および [リンク] 一覧に既に含まれている項目が削除されます。ユーザーがこれまでにセットアップしたリンクおよびお気に入りが削除されることになるので、この設定は慎重に使用してください。
[管理者が作成したお気に入りに限り、削除する]
企業内管理者の場合は、このチェック ボックスをオンにすると、ユーザーの [お気に入り] 一覧および [リンク] 一覧に設定しておいた項目だけが削除されます。
[既存のチャンネルを削除する]
企業内管理者の場合は、このチェック ボックスをオンにすると、ユーザーのコンピュータ上の既存のチャンネルを削除できます。

注

  • リンクのテストを実施するには、一覧の中の URL をクリックして、[URL のテスト] をクリックします。
  • [お気に入り] フォルダには、リンクを 200 個まで追加できます。
  • [お気に入り] の一覧またはリンク バーから項目を削除するには、その項目をマウスの右ボタンでクリックして、[削除] をクリックします。
  • ブランドおよびカスタマイズしたリンクがカスタム ブラウザに適用される仕組みを説明する図解については、「カスタマイズの仕組み]を参照してください。

[お気に入り] の一覧またはリンク バーにフォルダを追加するには

  1. [お気に入り]、[リンク]、または [お気に入り] か [リンク] の中にあるフォルダをクリックして、[フォルダの追加] をクリックします。
  2. [名前] ボックスに、フォルダの名前を入力します。フォルダ内のリンクの種類をユーザーが理解できるように、ここではわかりやすい名前を指定します。

リンクのフォルダを自分のコンピュータから [お気に入り] の一覧またはリンク バーにインポートするには

  1. [お気に入り] または [リンク] をクリックし、[インポート] をクリックします。
  2. [フォルダの参照] ダイアログ ボックスで、自分のコンピュータ上にある目的のリンクのフォルダを検索し、クリックします。これらのリンクは、ほとんどの場合、\Windows\Favorites フォルダに保存されています。

[お気に入り] の一覧またはリンク バーに Web ページを追加するには

  1. [お気に入り]、[リンク]、または [お気に入り] か [リンク] の中にあるフォルダをクリックして、[URL の追加] をクリックします。
  2. [詳細設定] ダイアログ ボックスで、この Web ページの名前を [名前] ボックスに入力します。リンクの参照先をユーザーが理解できるように、ここではわかりやすい名前を指定します。
  3. [URL] ボックスには、リンクのジャンプ先を入力します。
  4. このリンクに 16 × 16 ピクセルのカスタム アイコンを指定するには、[アイコン] ボックスにビットマップ ファイルの名前を入力するか、[参照] をクリックしてそのファイルを検索します。
  5. 企業内管理者の場合は、[オフラインで使用する] チェック ボックスをオンにすると、インターネットに接続していないユーザーがこのページを表示できるように設定できます。このオプションは、ユーザーがラップトップ コンピュータを使用している場合に便利です。
  6. [OK] をクリックして、[詳細設定] ダイアログ ボックスを閉じます。


ウェルカム ページ

Internet Explorer は、ユーザーがブラウザを初めて起動したときに、ウェルカム ページを表示します。その際は、Internet Explorer 6 の既定のウェルカム ページを表示させることも、カスタムのウェルカム ページを指定することもできます。

[既定の Microsoft Internet Explorer 6 ウェルカム ページを表示する]
Internet Explorer の既定のウェルカム ページを表示する場合は、このオプションを選択してください。
[ウェルカム ページを表示しない]
ウェルカム ページを表示しない場合は、このオプションを選択してください。 最初の起動時には、ユーザーの指定したホーム ページが表示されます。
[カスタムのウェルカム ページを表示する (次のテキスト ボックスに URL を指定してください)]
カスタムのウェルカム ページを使用する場合は、このオプションを選択し、下のボックスに URL を入力してください。

注

  • ユーザーは、インターネットまたはイントラネットに接続しないと、ウェルカム ページを表示できません。


ユーザー エージェント文字列

コンテンツに対するアクセス回数や Web ブラウザの種類といったサイトの統計情報を監視している会社もあります。ユーザー エージェント文字列を使用すると、ブラウザの種類を識別するのに役立ちます。

[ユーザー エージェント文字列に追加する文字列をカスタマイズする]
ユーザー エージェント文字列をカスタマイズするには、このチェック ボックスをオンにします。
[ユーザー エージェント文字列に追加するカスタム文字列]
このボックスに入力した文字列は、カスタム ブラウザのユーザー エージェント文字列の末尾に付加されます。ただし、自分のカスタム ブラウザの使用状況を監視したり、ほかのインターネット サイトから統計情報を収集する必要がない場合は、ユーザー エージェント文字列のカスタマイズは不要です。カスタマイズした文字列は、サイトの統計情報を監視しているほかの会社からも見ることができるので注意してください。


自動構成

カスタム ブラウザを自動的に構成するファイルに URL を割り当てることができます。この機能は、複数のユーザーの設定を集中管理する場合に便利です。

また、オプションの構成は、.ins ファイル (IEAK プロファイルとも呼ばれます) を使用して行うこともできます。.ins ファイルを使用して、標準のプロキシ設定を行うこともできます。また、.js、.jvs、あるいは .pac フォーマットのスクリプト ファイルを指定すれば、詳細なプロキシ設定の構成や保守を実行することもできます。

ドメイン ネーム システム (DNS) および 動的ホスト構成プロトコル (DHCP) をサポートするネットワーク サービスでは、ユーザーがネットワーク上で最初にブラウザを起動したとき、ブラウザの設定を自動的に検出して構成することができます。詳細については、「ブラウザの設定の自動検出および自動構成」を参照してください。

自動構成および自動プロキシの両方に対して URL を指定すると、.ins ファイルには自動プロキシの URL が格納されます。その URL の正しい書式は、http://share/test.ins です。

自動構成を有効にするには、[自動構成を使用する] チェック ボックスをオンにします。[自動構成 URL ( .INS ファイル)] ボックスに、必要な .ins ファイルの URL を入力します。また、[自動プロキシ URL ( .JS、.JVS、または .PAC ファイル)] ボックスに、自動プロキシ スクリプトの URL を入力します。

ブラウザの設定を自動的に検出するには、[自動構成を使用する] チェック ボックスをオンにします。

[自動構成を実行する間隔]
自動構成の間隔は、分単位で指定できます。 0 (ゼロ) を入力するか、または値を省略すると、自動構成はユーザーのコンピュータが再起動されたときにのみ実行されます。


接続の設定

ここで、現在使用しているコンピュータから接続の設定をインポートして、ユーザーの接続を事前に設定することができます。

どの設定をインポートするかを確認するには、ブラウザで [ツール] メニューの [インターネット オプション] をクリックし、[接続] タブをクリックします。[設定] をクリックするとダイヤルアップの設定が表示され、[LAN の設定] をクリックするとネットワークの設定が表示されます。ただし、自動構成用のアドレスはインポートされません。

[接続の設定をカスタマイズしない]
ユーザーのカスタマイズ接続を事前に設定しない場合は、このオプションをクリックします。
[このコンピュータから現行の接続の設定をインポートする]
ユーザーのカスタマイズ設定を事前に設定して、お使いのコンピュータからインポートした値が使用されるように指定するには、このオプションをクリックします。お使いのコンピュータの設定が目的の設定と異なる場合は、[設定の変更] をクリックして変更します。
[既存のダイヤルアップ接続の設定を削除する]
企業内管理者の場合は、このチェック ボックスをオンにすると、ユーザーのコンピュータ上の既存の設定を削除するように指定できます。

注

  • 企業内管理者の場合は、システム ポリシーと制限を使って、ユーザーが接続の設定を変更できるようにするかどうかを決定することができます。 Internet Explorer 6 カスタマイズ ウィザードの段階 5 または自動構成を通じて、ポリシーと制限を設定できます。


プロキシの設定

ユーザーが接続するプロキシ サーバーを指定することができます。 プロキシ サーバーは、ワークステーション ユーザーとインターネットの間の仲介者の役割を果たし、管理コントロールとキャッシュ サービスの保持に役立ちます。

一覧に示されているサービスのいずれかにプロキシ サーバーを使用する場合は、[プロキシの設定を使用する] チェック ボックスをオンにしてください。

一覧に示されているサービスの右側に、プロキシ サーバーのアドレスを入力します。[ポート] の下にある適切なボックスに、ポート番号 (通常は「80」) を入力します。

どのサービスでも同じ設定を使用する場合は、[すべてのアドレスに同じプロキシ サーバーを使用する] チェック ボックスをオンにします。

企業内イントラネット上のアドレスなど、プロキシ サーバーを使用したくないアドレスもあります。 [例外] の [次で始まるアドレスにはプロキシを使用しない] ボックスに使用しないアドレスを入力してください。 エントリ同士は、セミコロンで区切ります。また、イントラネット上のすべてのアドレスに対してプロキシ サーバーを経由しないようにするには、[ローカル (イントラネット) のアドレスにはプロキシ サーバーを使用しない] チェック ボックスをオンにします。


新しいルート証明書の追加

[新しいルート証明書のパス] ボックスに URL を入力することによって、IEAK のカスタム パッケージにルート証明書を追加することができます。これで、階層構造の中の下位の証明書に継承させることができる信頼レベルが提供されます。それぞれの証明書は、ルート証明書が見つかるまで、親の証明書が検証されます。


サインアップの方法

ISP の方の場合は、ユーザーによるサービスのサインアップ方法およびインターネットへの接続方法を指定することができます。

[インターネット接続ウィザードを使用するサーバーベースのサインアップ (推奨)]
柔軟性があり、動的な機能を提供するインターネット サインアップ サーバーを使用すると、さまざまなサインアップ オプションに適応できます。インターネット接続ウィザード (ICW) の画面で情報をやり取りするサーバー ソリューションを作成します。詳細については、「インターネット接続ウィザードによるインターネット サインアップ」を参照してください。
[全画面表示のキオスク モードを使用するサーバー ベースのサインアップ]
柔軟性があり、動的な機能を提供するインターネット サインアップ サーバーを使用すると、さまざまなサインアップ オプションに適応できます。ツール バー ボタンが非表示のキオスク (全画面) モードのブラウザで情報をやり取りするサーバー ソリューションを作成します。詳細については、「全画面表示のキオスク モードを使用するサインアップ サーバーのセットアップ」を参照してください。
[サーバーなしのサインアップ]
[サーバーなしのサインアップ] を使用する場合、サインアップ サーバーは不要です。サーバーなしの方法を選択する場合、Internet Explorer 6 カスタマイズ ウィザードによって、サインアップ処理を制御するために必要な情報の指定を求めるプロンプトが表示されます。このオプションを選択した場合、ダイヤル、ゲートウェイ、およびパスワードに関する情報の入力が求められます。Internet Explorer 6 カスタマイズ ウィザードでは、サインアップ ページのテストを実行することもできます。サーバーなしのサインアップ処理を使って、ICW をカスタマイズすることはできません。
[サインアップしない]
ユーザーがサインアップなしでカスタム ブラウザをインストールできるようにするには、この方法を指定します。このオプションは、ケーブル モデムを使用している場合に効果的です。

サインアップ処理の図解については、「ISP サインアップ処理」を参照してください。


サインアップのファイル

ユーザーがコンピュータを構成してサーバーに接続できるようにするには、カスタム サインアップ ファイルを作成する必要があります。詳細については、「全画面表示のキオスク モードを使用するサインアップ サーバーのセットアップ」および「インターネット接続ウィザードによるインターネット サインアップ」を参照してください。

最初のファイルは、サービスに関する情報を格納している HTML ページでなければなりません。キオスク モードでインターネット サインアップを行うには、このファイルには Signup.htm という名前を付け、サインアップ サーバーの適切な HTML ファイルへのリンクを含める必要があります。インターネット接続ウィザードでインターネット サインアップを行うには、このファイルには Icwsign.htm という名前を付ける必要があります。

サインアップ ファイルの画面には、サインアップ ファイルの作業ディレクトリが表示されます。既にサインアップ ファイルに変更を加えている場合は、[ファイルのコピー] をクリックして変更したファイルを作業ディレクトリにコピーします。.isp ファイルまたは .ins ファイルの設定をカスタマイズ ウィザードの段階 4 で確認したり指定するには、それぞれ [.ISP ファイルのエントリを確認または変更する] または [.INS ファイルのエントリを確認または変更する] チェックボックスをオンにします。

サインアップに関連するファイルは、グラフィック ファイルも含め、すべて同じフォルダに格納しなければなりません。ウィザードはすべてのファイルの属性を "読み書き" に変更する必要があるので、このフォルダは、読み書き可能なフル アクセスにしてください。

カスタム サインアップ ファイルの指定
サインアップに関連するファイルを含むフォルダへのパスを入力するか、[参照] をクリックしてそのフォルダを検索します。

注

  • .isp ファイルの詳細については、「isp ファイルの作成」を参照してください。


サインアップ サーバーの情報

[サインアップ サーバーの情報] 画面では、ユーザーのダイヤルアップ接続を構成して、ユーザーがインターネット サーバーに接続できるようにします。

[接続名]
サインアップ サーバーの名前を入力します。わかりやすい名前を指定することができます。
[ファイル名]
ファイルの名前を入力します。サインアップ パラメータを格納するファイルには、拡張子 .isp を付ける必要があります。インターネット設定を格納するファイルには、拡張子 .ins を付ける必要があります。
[市外局番/電話番号]
この接続で使用する市外局番および電話番号を入力します。
[国番号/ID]
この接続で使用する国コードまたは地域コード、および国 ID を入力します。
[ユーザー名]
この接続で使用する既定のユーザー名を入力します。
[パスワード]
この接続で使用する既定のパスワードを入力します。
[サポート電話番号]
ユーザーがサポートにダイヤルできる電話番号を入力します。
[最初のオンライン サインアップ ページの URL]
サインアップ プロセスの最初のページの URL を入力します。
[詳細オプション]
次に示すダイヤルおよびゲートウェイに関する設定をするには、[詳細オプション] をクリックします。
[静的 DNS アドレスを使用する]
ドメイン ネーム システム (DNS) は、TCP/IP (Transmission Control Protocol/Internet Protocol) ネットワークのプロトコルおよびサービスです。DNS を使用すると、数値によるアドレスではなく、www.microsoft.com のようにわかりやすい名前を使用することができます。名前と IP アドレスの対応付けを調べるときに、すべての DNS サーバーで検索されるようにするには、このチェック ボックスをオンにして、手作業でプライマリ DNS アドレスとセカンダリ DNS アドレスを入力してください。
[ログオンを要求する]
クライアント コンピュータが Windows ログオン認証をオンにしているか確認するには、このチェック ボックスをオンにします。Windows パスワードを入れると ISP パスワードが格納されている Windows パスワードのキャッシュにアクセスします。長くてわかりにくい文字列をパスワードに割り当てる場合、このオプションは特に有効です。このオプションは Windows 95 および Windows 98 クライアントにのみ有効です。
[TCP/IP を取り決める]
ユーザーがインターネット接続を確立するときに、TCP/IP の取り決めを有効にするには、このチェック ボックスをオンにします。
[LCP を利用しない]
ポイント ツー ポイント プロトコル リンクの確立で LCP (Link Control Protocol) 拡張の使用を無効にするには、このチェック ボックスをオンにします。サインアップ サーバーが LCP 拡張を扱えない場合は、サーバーに接続するクライアント コンピュータ上で LCP を使用しない設定にしてください。この値は Windows NT 4.0 クライアントにのみ有効です。
[電話番号を表示する]
既定の市外局番を設定しないようにするには、このチェック ボックスをオンにします。たとえば、ユーザーが既定の設定以外の市外局番から通話する可能性がある場合は、このチェック ボックスをオンにした方がよいでしょう。ユーザーが現在の市外局番と既定の市外局番の違いに気付かないと、思わぬ長距離通話料を請求されることにもなりかねません。
[パスワードを暗号化する]
暗号化されたパスワードの送信および受信だけをコンピュータに実行させるように指定するには、このチェック ボックスをオンにします。この機能は、該当する接続のセキュリティを強化する場合に便利です。接続するコンピュータで、暗号化されたパスワードがサポートされている必要があります。
[ソフトウェア圧縮を使用する]
送受信する情報を送信前に圧縮して、情報の転送速度を上げるには、このチェック ボックスをオンにします。両方のコンピュータが互換性のある圧縮方法をサポートしている場合にのみ、この圧縮機能は動作します。
[IP ヘッダー圧縮を使用する]
TCP/IP ヘッダーを圧縮して、低速のシリアル回線の転送効率を上げるには、このチェック ボックスをオンにします。これを使用すると、通常はコンピュータ間のデータ転送が最適化されます。

接続 ID と変更フィールドを示す小さなヘッダーを構築し直すときは、転送するバイト数を減らす必要があります。ただし、圧縮を機能させるためには、パケットは順番に到着しなければなりません。

ただし、圧縮がいつでも望ましいわけではありません。たとえば、古い機器を使用している場合は、圧縮を利用できないかもしれません。相互運用性のために、Serial Line Internet プロトコル (SLIP) のドライバ (ヘッダーの圧縮をサポート) には、ユーザーが圧縮を無効にできるような何らかのフラグを備えておくべきです。

[既定のリモート ゲートウェイを使用する]
既定で、IP (Internet Protocol) のトラフィックを WAN (ワイド エリア ネットワーク) にルーティングするには、このチェック ボックスをオンにします。ゲートウェイとは、2 つの異なるネットワークを接続する接続ポイントまたは交換ポイントです。

注

  • .isp ファイルのフラグを設定すると、既定の市外局番を設定しないようにすることができます。このフラグの構文は、次のとおりです。
    Dial_As_Is=Yes


インターネット接続ウィザード

インターネット接続ウィザード (ICW) は、ユーザーがインターネット サービスにサインアップするためのツールとして指定できます。ICW の画面との間で情報を交換するには、サーバーベースのソリューションを作成します。ただし、この機能は、サーバーなしのサインアップ方法の場合には利用できません。

[タイトル バーをカスタマイズする]
このチェック ボックスをオンにすると、ユーザーがインターネット接続ウィザードでサービスにサインアップできるようになります。
[タイトル バーの文字列]
カスタマイズしたインターネット接続ウィザードのタイトル バーに表示される文字列を入力します。
[上側のイメージ]
インターネット接続ウィザードの画面の右上に表示する 49 × 49 ピクセルの .bmp ファイルのパスを入力します。
[左側のイメージ]
インターネット接続ウィザードの画面の左側に表示する 164 × 458 ピクセルの .bmp ファイルのパスを入力します。

注

  • インターネット接続ウィザードとサーバーの間の情報交換を可能にするには、ブラウザ パッケージにダイナミック HTML データ バインド コンポーネントを追加する必要があります。このコンポーネントにより、Signup.txt 内のリストに指定されている ISP ファイルをウィザードのページに表示できるようになります。このコンポーネントが選択可能なオプションとして表示されていると、ユーザーがインストール対象から除外する可能性があるため、選択可能なオプションの一覧に表示しないでおくことができます。 Internet Explorer カスタマイズ ウィザードの [高度なインストール オプション] ページで [ダイナミック HTML データ バインド] チェック ボックスをオフにすると、このコンポーネントは選択可能なコンポーネントの一覧に表示されなくなります。次に、Windows Update セットアップで、このコンポーネントの適切な列に [強制インストール] と表示されていることを確認します。
  • サインアップ処理の図解については、「ISP サインアップ処理」を参照してください。


インターネット設定ファイル

[インターネット設定ファイル] 画面では、Internet Explorer 6 カスタマイズ ウィザードを使って .ins ファイルを生成するための設定を指定します。.ins ファイルは、サーバー上に置くことも、また、サーバーなしのサインアップ用のカスタム パッケージに組み込むこともできます。

[接続名]
サインアップ サーバーの名前を入力します。わかりやすい名前を指定することができます。
[ファイル名]
ファイルの名前を入力します。サインアップ パラメータを格納するファイルには、拡張子 .isp を付ける必要があります。インターネット設定を格納するファイルには、拡張子 .ins を付ける必要があります。
[市外局番/電話番号]
この接続で使用する市外局番および電話番号を入力します。
[国番号/ID]
この接続で使用する国コードまたは地域コード、および国 ID を入力します。
[ユーザー名]
この接続で使用する既定のユーザー名を入力します。
[パスワード]
この接続で使用する既定のパスワードを入力します。
[詳細オプション]
次に示すダイヤルおよびゲートウェイに関する設定をするには、[詳細オプション] をクリックします。
[静的 DNS アドレスを使用する]
ドメイン ネーム システム (DNS) は、TCP/IP (Transmission Control Protocol/Internet Protocol) ネットワークのプロトコルおよびサービスです。DNS を使用すると、数値によるアドレスではなく、www.microsoft.com のようにわかりやすい名前を使用することができます。名前と IP アドレスの対応付けを調べるときに、すべての DNS サーバーで検索されるようにするには、このチェック ボックスをオンにして、手作業でプライマリ DNS アドレスとセカンダリ DNS アドレスを入力してください。
[ログオンを要求する]
クライアント コンピュータが Windows ログオン認証をオンにしているか確認するには、このチェック ボックスをオンにします。Windows パスワードを入れると ISP パスワードが格納されている Windows パスワードのキャッシュにアクセスします。長くてわかりにくい文字列をパスワードに割り当てる場合、このオプションは特に有効です。このオプションは Windows 95 および Windows 98 クライアントにのみ有効です。
[TCP/IP を取り決める]
ユーザーがインターネット接続を確立するときに、TCP/IP の取り決めを有効にするには、このチェック ボックスをオンにします。
[LCP を利用しない]
ポイント ツー ポイント プロトコル リンクの確立で LCP (Link Control Protocol) 拡張の使用を無効にするには、このチェック ボックスをオンにします。サインアップ サーバーが LCP 拡張を扱えない場合は、サーバーに接続するクライアント コンピュータ上で LCP を使用しない設定にしてください。この値は Windows NT 4.0 クライアントにのみ有効です。
[電話番号を表示する]
既定の市外局番を設定しないようにするには、このチェック ボックスをオンにします。たとえば、ユーザーが既定の設定以外の市外局番から通話する可能性がある場合は、このチェック ボックスをオンにした方がよいでしょう。ユーザーが現在の市外局番と既定の市外局番の違いに気付かないと、思わぬ長距離通話料を請求されることにもなりかねません。
[パスワードを暗号化する]
暗号化されたパスワードの送信および受信だけをコンピュータに実行させるように指定するには、このチェック ボックスをオンにします。この機能は、該当する接続のセキュリティを強化する場合に便利です。接続するコンピュータで、暗号化されたパスワードがサポートされている必要があります。
[ソフトウェア圧縮を使用する]
送受信する情報を送信前に圧縮して、情報の転送速度を上げるには、このチェック ボックスをオンにします。両方のコンピュータが互換性のある圧縮方法をサポートしている場合にのみ、この圧縮機能は動作します。
[IP ヘッダー圧縮を使用する]
TCP/IP ヘッダーを圧縮して、低速のシリアル回線の転送効率を上げるには、このチェック ボックスをオンにします。これを使用すると、通常はコンピュータ間のデータ転送が最適化されます。

接続 ID と変更フィールドを示す小さなヘッダーを構築し直すときは、転送するバイト数を減らす必要があります。ただし、圧縮を機能させるためには、パケットは順番に到着しなければなりません。

ただし、圧縮がいつでも望ましいわけではありません。たとえば、古い機器を使用している場合は、圧縮を利用できないかもしれません。相互運用性のために、Serial Line Internet プロトコル (SLIP) のドライバ (ヘッダーの圧縮をサポート) には、ユーザーが圧縮を無効にできるような何らかのフラグを備えておくべきです。

[既定のリモート ゲートウェイを使用する]
既定で、IP (Internet Protocol) のトラフィックを WAN (Wide Area Network、広域網) にルーティングするには、このチェック ボックスをオンにします。ゲートウェイとは、2 つの異なるネットワークを接続する接続ポイントまたは交換ポイントです。
[このファイルには、いかなるブランド情報も適用しない]
.ins ファイルにブランド情報を追加しないように指定します。
[このファイルのブランド情報を更新しない]
.ins ファイルのブランド情報を更新しないように指定します。
[このファイルには、現行のブランド情報を適用する]
.ins ファイルにブランド情報を含めるように指定します。
[キャビネット ファイル (.CAB) の名前]
ブランド情報を含むファイルの名前を指定します。この情報は、.ins ファイルに追加されます。サーバーなしのサインアップを使用する場合、またはユーザーがサインアップのためにサーバーに接続する場合は、サインアップ画面にブランドが表示されます。
[キャビネット ファイル (CAB) への URL]
ブランド情報を含むファイルへの URL を指定します。この情報は、.ins ファイルに追加されます。サーバーなしのサインアップを使用する場合、またはユーザーがサインアップのためにサーバーに接続する場合は、サインアップ画面にブランドが表示されます。

注

  • .isp ファイルのフラグを設定すると、既定の市外局番を設定しないようにすることができます。このフラグの構文は、次のとおりです。
    Dial_As_Is=Yes


セキュリティ

証明機関および Authenticode を利用すると、セキュリティの管理が容易になります。

証明機関を利用すると、ActiveX コントロールや Java アプレットなどの特定のコンテンツをダウンロードできるサイトを制御できます。サイトの認証は、インターネット サイト用のデジタル証明書の形式をとります。Authenticode 技術を基にすると、プログラムの発行元を特定でき、プログラムが変更されていないかどうかを確認できます。

[証明機関をカスタマイズしない]
証明機関をカスタマイズしない場合は、このオプションをクリックします。Authenticode セキュリティ情報はカスタマイズできます。

証明機関は、現在使用しているコンピュータからインポートできます。ユーザーのコンピュータに適用する設定を変更するには、[現行の証明機関をインポートする] をクリックして、[設定の変更] をクリックします。

これで、証明書のインポートウィザードを使用して、証明機関情報を表示または管理することができます。証明書は、ネットワーク サーバーの認証、ネットワーク クライアントの認証、セキュリティで保護された電子メールの認証、およびソフトウェアの発行元に適用できます。

[Authenticode セキュリティをカスタマイズしない]
Authenticode セキュリティ情報をカスタマイズしない場合は、このオプションをクリックします。

Authenticode を利用すると、ソフトウェア発行者および認証機関を信頼できるものとして指定できます。これらの設定も、現在使用しているコンピュータからインポートできます。ユーザーのコンピュータに適用する設定を変更するには、[現行の Authenticode セキュリティ情報をインポートする] をクリックして、[設定の変更] をクリックします。


セキュリティとプライバシーの設定

企業内管理者の場合は、ここで会社のセキュリティ ゾーン、プライバシーの設定、およびコンテンツの規制を管理することができます。各セキュリティ ゾーンの設定は、カスタマイズできます。カスタム ブラウザのユーザーすべてに対して、Cookie を規制するプライバシーのレベルを設定できます。コンテンツの規制を使用すれば、不快と思われるようなコンテンツや、社内の不適切な設定をユーザーに見せないようにすることができます。

[セキュリティ ゾーンとプライバシー]
ユーザーのコンピュータに適用する設定を変更するには、[現行のセキュリティ ゾーンとプライバシーの設定をインポートする] をクリックして、[設定の変更] をクリックします。セキュリティおよびプライバシー関連の設定の変更をユーザーに許可するかどうかは、段階 5 で指定することもできます。

注

  • セキュリティの設定には、インターネット、ローカル イントラネット、信頼済みサイト、および制限付きサイトが含まれます。
  • プライバシーには、高、中、低の 3 つのレベルがあります。プライバシー レベルに「高」を設定すると、インターネット サイトがユーザーのコンピュータに Cookie を設定できなくなります。プライバシーレベルに「中」を設定すると、インターネット サイトにプライバシー ポリシーがあるかどうかが確認され、そのポリシーとユーザーのコンピュータが比較され、インターネット サイトに既存の Cookie の使用を許可し、サード パーティの不十分な Cookie を使用できないようにします。プライバシー レベルに「低」を設定すると、インターネット サイトがユーザーのコンピュータに Cookie を設定できるようになります。
[セキュリティ ゾーンとプライバシーをカスタマイズしない]
セキュリティ ゾーンおよびプライバシーの設定を変更しない場合は、このオプションをクリックします。
[コンテンツの規制]
Microsoft Internet Explorer を使用すると、コンピュータからアクセスするインターネット上のコンテンツの種類を簡単に制御することができます。種類は、コンテンツに合わせ、言語、ヌード、セックス、および暴力の 4 つの分野に分類できます。

ユーザーのコンピュータに適用している規制を変更する場合は、[現行のコンテンツの規制の設定をインポートする] をクリックして、[設定の変更] をクリックしてください。これで、コンテンツ アドバイザを使用して設定を変更できます。

[コンテンツの規制をカスタマイズしない]
コンテンツの規制情報を変更しない場合は、このオプションをクリックします。

注

  • 初期設定では、コンテンツ アドバイザは、厳しい規制が標準となっています。それらの設定は、好みに合わせて調整することができます。
  • インターネット上のすべてのコンテンツが規制の対象になるわけではありません。規制を課していないサイトの中にも、不適切なコンテンツが入っている場合があります。


段階 4 : ブラウザのカスタマイズ

Internet Explorer 6 カスタマイズ ウィザードのこの段階では、Internet Explorer の外観と動作をカスタマイズできます。

利用できるオプションは、次のうちどの職種を選択しているかによって異なります。

  • インターネット コンテンツ プロバイダ
  • インターネット サービス プロバイダ
  • 企業内管理者

注

  • ロゴのカスタマイズなど、使用許諾契約によって使用できるオプションが異なるものもあります。詳細については、使用許諾契約書を参照してください。


ポリシーおよび制限の目的

システム ポリシーと制限を集中管理しておけば、組織全体で統一のとれたデスクトップ環境が維持でき、その後のサポートにかかるコストを削減することができます。

Internet Explorer 6 カスタマイズ ウィザードで設定し、IEAK プロファイル マネージャで後から管理することのできるシステム ポリシーおよび制限はすべて、Windows 95、Windows 98、および Windows Millennium Edition オペレーティング システムを実行しているユーザー向けに構成できます。

ただし、Windows NT、Windows 2000、または Windows XP プラットフォーム上で管理者権限を持たないユーザーに対して構成できるのは、これらのシステム ポリシーおよび制限の一部だけです。その代わりに、Windows NT ポリシー エディタ、Windows 2000 グループ ポリシー、または Windows XP グループ ポリシーを使って、これらのユーザーの残りのポリシーおよび制限を構成することをお勧めします。詳細については、「Windows 2000 および Windows XP 上での Internet Explorer の管理」を参照してください。

[すべての IEAK ポリシーを表示する]
Windows 95、Windows 98、および Windows Millennium Edition オペレーティング システムを実行しているすべてのユーザーと、Windows NT、Windows 2000、および Windows XP 上で管理者権限をもつユーザーに対して、システム ポリシーおよび制限のすべてを構成できます。
[管理者以外のユーザーには IEAK ポリシーのサブセットを表示する]
Windows NT、Windows 2000、および Windows XP オペレーティング システム上で管理者権限をもたないユーザーに適用するポリシーおよび制限の一部を表示して構成するには、このオプションを選択します。


プログラム

これらの設定を使って、既定の電子メール クライアントや既定の HTML エディタなど、ユーザーのプログラムを構成します。
[プログラムの設定をカスタマイズしない]
ユーザーのプログラムの設定を構成しない場合は、このオプションをクリックします。
[現行のプログラムの設定をインポートする]
電子メールの送受信や HTML の編集などに使う特定のプログラムの設定を自分のコンピュータからインポートする場合は、このオプションをクリックします。 これらの設定は、[インターネット オプション] ダイアログ ボックスの [プログラム] タブに表示されます。

設定を変更してからインポートするには、[現行のプログラムの設定をインポートする] をクリックして、[設定の変更] をクリックします。


Outlook Express のアカウント

サーバー

Outlook Express のメール サーバーおよびニュース サーバーを指定し、ユーザーがサーバーにアクセスするときに、セキュリティで保護されたパスワード認証 (SPA) を使用してログオンするように要求できます。

[受信メール]
メール サーバーで使用しているプロトコルを選択します。大半のインターネット加入者が電子メールに使用する POP3 と、主に企業内ユーザーが遠隔地から電子メール メッセージを読むときに使用する IMAP のどちらかを選択できます。POP3 サーバーでは各ユーザーが 1 つのメールボックスにのみアクセスできますが、IMAP サーバーでは複数のサーバー側フォルダにアクセスできます。
[サーバー]
「pop01.microsoft.com」などの完全な受信メール サーバー アドレスをテキスト ボックスに入力します。POP3 サーバーまたは IMAP サーバーで、NTLM などの SSPI プロバイダからの認証が要求される場合は、[SPA を使用してログオンする] (セキュリティで保護されたパスワード認証) をクリックします。
[送信メール (SMTP) サーバー]
SMTP サーバーは、メールを送信する際に使用するサーバーです。SMTP サーバーの名前は、POP3 サーバーと同じ場合もあります (smtp.microsoft.com など)。SMTP サーバーの完全なアドレスをテキスト ボックスに入力します。SMTP サーバーで、NTLM などの SSPI プロバイダからの認証が要求される場合は、[SPA を使用してログオンする] (セキュリティで保護されたパスワード認証) をクリックします。
[インターネット ニュース (NNTP) サーバー]
NNTP (Network News Transfer Protocol) は、インターネット上の NNTP サーバーおよび NNTP クライアント (ニュース リーダー) にネットワーク ニュースを配信する際に使用するプロトコルです。「nntp.microsoft.com」などの NNTP アドレスをテキスト ボックスに入力します。NNTP サーバーで、NTLM などの SSPI プロバイダからの認証が要求される場合は、[SPA を使用してログオンする] (セキュリティで保護されたパスワード認証) をクリックします。
[サーバー名を読み取り専用にする]
サーバー アカウントの設定を固定するには、このチェック ボックスをオンにします。これにより、ユーザーが設定を変更できなくなります。
[アカウントにアクセスできないようにする (アカウントを追加、削除、または修正できなくします)]
アカウントの設定を固定するには、このチェック ボックスをオンにします。これにより、構成したアカウントをユーザーが削除または変更できなくなり、また追加のアカウントを作成できなくなります。このオプションは、企業内管理者にのみお勧めします。

注

  • ここで指定した制限に従って、メールやニュースなどのユーザー アカウントが構成されます。
  • サーバー およびアカウントの設定を固定すると、設定は表示されますが、ユーザーが変更できなくなります。


Outlook Express の IMAP 設定

ここで、既定の IMAP 設定を作成できます。これらの設定は、ユーザーが IMAP アカウントを作成するときの既定値となります。

[ルート フォルダのパス]
このパスは、IMAP サーバー上のすべてのユーザーのフォルダを格納するメールボックスになります。Cyrus サーバーの場合は、すべてのユーザーのフォルダは Inbox フォルダに格納する必要があります。UNIX ベースの IMAP サーバーの場合は、通常、ユーザーのホーム フォルダの中の専用のフォルダ (~username/Mail など) にメールが保存されます。ルート フォルダ パスの末尾には、階層文字を付加しないでください。たとえば、「~username/Mail」はルート フォルダ パスとして有効ですが、「~username/Mail/」は無効です。Microsoft Exchange Server など、IMAP サーバーの中には、ルート フォルダ パスが不要なものもあります。
[特別なフォルダを IMAP サーバーに保存する]
IMAP サーバー上に作成する、ユーザーの送信済みメッセージおよび未送信メッセージを保存するフォルダを指定するには、[特別なフォルダを IMAP サーバーに保存する] を選択します。
[送信済みアイテムのパス]
送信済みアイテム フォルダのパス名を入力します。 このパスは、IMAP アカウントを作成するすべてのユーザーが使用します。
[下書きフォルダのパス]
下書きフォルダのパス名を入力します。 このパスは、IMAP アカウントを管理者によって構成されたすべてのユーザーが使用します。
[すべてのフォルダで新着メッセージを確認する]
ユーザーが Outlook Express を起動したときに、また、新着メールを定期的にチェックする設定のときに、IMAP ユーザーのお気に入りフォルダを調べて、メッセージの数の変化を自動的に調査させるには、[すべてのフォルダで新着メッセージを確認する] を選択します。このオプションが選択されていない場合は、Outlook Express は、受信トレイに対してのみ新着メッセージの有無をチェックします。


Outlook Express のコンテンツの設定

Outlook Express の外観をカスタマイズしたり、新しいユーザーを電子メール メッセージで歓迎したりできます。

情報パネル

Outlook Express の情報パネルは、コンテンツ プロバイダが有用な情報やリンクを表示するための領域です。情報パネルは、サポート番号、よく寄せられる質問 (FAQ)、自社についての情報などを表示して、カスタマイズすることができます。

情報パネルは、Outlook Express のメイン ウィンドウの下側に 50 ピクセルの高さで表示されます。この情報パネルは、ローカル コンピュータ上の HTML ファイルと、インターネット上の HTML ファイル (URL) のどちらを使用してもカスタマイズできます。ローカル ファイルを指定した場合は、そのファイルが IEAK 配布パッケージにコピーされ、次に、インストール中にユーザーのコンピュータにコピーされます。

注

  • IEAK で URL またはファイルが指定されていない場合、情報パネルは Outlook Express のユーザー インターフェイスの一部として表示されません。
[URL]
情報パネルに使用する HTML ファイルの URL を入力します。
[ローカル ファイル]
情報パネルにローカル HTML ファイルを使用する場合は、[URL] テキスト ボックスに URL を入力せずに、このテキスト ボックスにローカル ファイルへのパスを入力します。 または、[参照] をクリックして、ファイルを検索します。 ローカル ファイルを指定する場合は、[イメージのパス] ボックスにコピーの対象となるイメージも指定できます。

ウェルカム メッセージ

各ユーザーの受信トレイに、最初のアイテムとしてウェルカム メッセージを用意することもできます。ウェルカム メッセージは、HTML ファイルです。また、差出人にわかりやすい名前 (会社や組織の名前など) を設定し、受信者の電子メール アドレスを指定する必要があります。

注

  • IEAK には、ウェルカム メッセージに画像を追加する機能は用意されていません。ただし、IEAK を使用せずにウェルカム メッセージを編集すれば、Web 上の画像へのリンクを追加することができます。
[HTML パス]
送信する HTML ファイルのパスを入力するか、[参照] をクリックしてファイルを検索します。
[送信者]
ウェルカム メッセージの送信元となる会社または個人の名前 (Volcano 管理者など) を入力します。この名前は、ウェルカム メッセージの [送信者] の行に表示されます。
[返信先]
ウェルカム メッセージの送信元となる会社または個人の電子メール アドレスを入力します。ユーザーは、質問または確認することがあれば、このアドレスにメールを送信することができます。


Outlook Express のカスタム設定

ここで、すべてのユーザーに適用する設定を作成できます。たとえば、既定のメール クライアントやニュース クライアントを設定できます。また、ユーザーが追加の電子メール アカウントを取得するときに必要となる情報を用意しておくこともできます。さらに、ユーザーに既定で適用するメッセージ規則ファイルを指定することもできます。

既定の電子メール プログラム

[Outlook Express を通常使用するプログラムとして選択する]
ユーザーが Internet Explorer で電子メールのリンクをクリックしたときに常に Outlook Express を起動させるには、[メール] チェック ボックスをオンにします。また、既定のメール クライアント設定は、ユーザーが電子メールを使用して文書を送信するときに、多くのプログラムで利用されます。ここでの設定は、ユーザーが指定した既定のメール クライアント設定より優先されます。

ユーザーが Internet Explorer でニュースのリンクをクリックしたときに常に Outlook Express を起動させるには、[ニュース] チェック ボックスをオンにします。

ニュースグループ

ユーザーがニュースグループを簡単に購読できるように指定できます。 ユーザーに自動で購読させたいニュースグループがある場合は、その名前を空白のテキスト ボックスに入力します。複数のニュースグループを同時に指定することもできます。たとえば、運営する ISP または組織でユーザー サポートおよび情報を提供するニュースグループをいくつか開設していることがあります。

[サービス名]
運営する ISP からユーザーが追加のメール アカウントを取得するときに使用するメニュー項目を追加できます。指定したエントリは、Outlook Express の [ツール] メニューの [新しいアカウントのサインアップ] に追加されます。[サービス名] ボックスに ISP の名前 (Acme ISP など) を入力します。
[サービス URL]
ユーザーがセットアップできる追加のメール アカウントに関連する URL を [サービス URL] ボックスに入力します。ユーザーがこのサービス名をメニューから選択すると、Web ページが表示されます。このとき、アカウント番号およびユーザーの一意な識別子が ISP に送信されます。アカウント番号は .ins ファイルで指定できます。
[すべての Outlook Express のリンクを削除する]
このチェック ボックスをオンにすると、Outlook Express プログラムへのリンクがユーザーのデスクトップまたは [スタート] メニューに表示されません。


Outlook Express の表示設定

ここで、Outlook Express の特定の要素を表示するかどうか、およびどのような方法で表示するかを決定する、ビューをカスタマイズできます。

[基本]
これらの設定値を使って、Outlook Express のインターフェイスのうち、どの要素を新しいユーザーが使用する既定のビューに含めるかを指定できます。
  • ユーザーの既定としてフォルダ バーをビューに含めるには、[フォルダ バー] チェック ボックスをオンにします。
  • Outlook バーを表示するには、[Outlook バー] チェック ボックスをオンにします。Outlook バーは、受信トレイなどの特定のフォルダを表示する水平のバーです。
  • 電子メール フォルダおよびニュース フォルダの一覧を左側の列に含めるには、[フォルダ一覧] チェック ボックスをオンにします。
  • Outlook Express ウィンドウの下側にステータス バーを表示するには、[ステータス バー] チェック ボックスをオンにします。
  • MSN Messenger がインストールされて構成されている場合に、電子メールの連絡先に加えて、ユーザーの MSN Messenger の連絡先を一覧表示するには、[連絡先] チェック ボックスをオンにします。
  • Outlook Express を起動するたびにヒントを表示するには、[ヒント] チェック ボックスをオンにします。
[ツール バー]
これらの設定を使って、ツール バーを表示するかどうか、およびツール バーを表示する場合は、そこにテキストを表示するかどうかを指定できます。
  • ツール バーを表示するには、[ツール バーを表示する] チェック ボックスをオンにします。ツール バーは、Outlook Express ウィンドウの上端に表示されます。ツール バーには、よく使用するコマンドに対応するボタンが含まれています。ユーザーは、ツール バーを構成することができます。
  • ツール バーのボタンにテキストを表示するには、[ボタンに文字列を表示する] チェック ボックスをオンにします。
[プレビュー ウィンドウ]
これらの設定を使って、プレビュー ウィンドウのオプションを設定します。
  • ユーザーの電子メールおよびニュース メッセージの既定のビューにメッセージ プレビュー ウィンドウを含めるには、[プレビュー ウィンドウを表示する] チェック ボックスをオンにします。
  • プレビュー ウィンドウをメッセージ一覧の下に配置される水平のウィンドウとして表示する場合は、[メッセージの下] をクリックします。
  • プレビュー ウィンドウをメッセージ一覧の右側に配置される垂直のウィンドウとして表示する場合は、[メッセージの横] をクリックします。
  • メッセージのヘッダー情報 ([送信者]、[宛先]、[CC]、および [件名] の各行) を表示する プレビュー ウィンドウ ヘッダー領域を含めるには、[プレビュー ウィンドウ ヘッダーを表示する] チェック ボックスをオンにします。


Outlook Express の作成時の設定

Outlook Express のニュースグループや電子メール メッセージに記載される既定の署名 (企業文書など) を指定できます。この企業文書は、従業員によってインターネット経由で発信されたメッセージが会社の公式な方針に従っていないことを示す際によく使用します。署名の標準サイズは、1 KB です。

[メッセージに署名を追加する]
この署名は、電子メールのみ、または電子メールとニュースのメッセージの両方に付加することができます。 電子メール メッセージの署名にテキストを追加するには、[メッセージに署名を追加する] チェック ボックスをオンにします。
[ニュース メッセージに署名を追加する]
ニュース メッセージの署名にテキストを追加したり、修正したりするには、このチェック ボックスをオンにします。電子メール メッセージに使用したのと同じテキストを使用するか、ニュース メッセージ用に異なるテキストを入力します。
[メール メッセージとして、HTML メッセージの形式で作成することを既定とする]
既定では、電子メール メッセージは HTML 形式で作成され、ニュース メッセージはテキスト形式で作成されます。これらの設定は、無効にすることができます。たとえば、帯域幅に制限がある環境や、HTML を表示できないメール プログラムを使用しているユーザーが多い環境では、既定の設定をテキスト形式に変更した方が適切です。一方、また、社内のすべてのユーザーが HTML 対応のニュースリーダーを使用する環境では、ニュース メッセージの既定の設定は HTML 形式であるのが望ましいといえます。
[ニュース メッセージとして、HTML メッセージの形式で作成することを既定とする]
ニュース メッセージの既定の設定として HTML 形式を使用するには、このチェック ボックスをオンにします。


アドレス帳のディレクトリ サービス

ディレクトリ サービスは、人間やビジネスに関する情報を世界中から簡単に収集することができる、強力な検索ツールです。Windows のアドレス帳では、このディレクトリ サービスにアクセスするための LDAP (Lightweight Directory Access Protocol) がサポートされており、いくつかのポピュラーなディレクトリ サービスへのアクセス機能が標準で用意されています。ユーザーが使用するほかのサービスを指定することもできます。

[サービス名]
LDAP サービスのわかりやすい名前を入力します。この名前がサービス名として表示されます。
[サーバー名]
追加するディレクトリ サービスの名前 (ldap.contoso.com や ldap.lucernepublishing.comなど) を入力します。これらのサービスにアクセスするユーザーに、NTLM などの SSPI パッケージを介した認証を要求する場合は、[SPA を使用してログオンする] チェック ボックスをオンにします。ユーザー名とパスワードを使用した基本的な認証は、.ins ファイルを通じて構成できます。
[サービス Web サイト]
ディレクトリ サービスのホーム ページの URL を入力します。

Windows 95、Windows 98、または Windows NT でユーザーがディレクトリ サービスのホームページを表示する方法

  1. Windows で、[スタート] ボタンをクリックし、[検索] をポイントして、[人] をクリックします。
  2. [人の検索] ダイアログ ボックスで、[探す場所] ボックスの一覧からディレクトリ サービスのホーム ページを選択し、[Web サイト] をクリックします。

Windows 2000、Windows XP、または Windows Millennium Edition でユーザーがディレクトリ サービスのホームページを表示する方法

  1. Windows で、[スタート] ボタンをクリックし、[検索] をポイントして、[人] をクリックします。
  2. [人の検索] ダイアログ ボックスで、[探す場所] ボックスの一覧からディレクトリ サービスのホーム ページを選択し、[Web サイト] をクリックします。
[検索ベース]
[検索ベース] は、LDAP サーバーを検索する起点となる階層レベルで、ルートまたはスコープと呼ばれることもあります。国や組織などのグループを検索ベースとして指定できます。Outlook Express では、検索ベースを指定していない場合、検索ベースの既定値は "c=us" になります。検索ベースを指定しないようにするには、「NULL」と入力します。
[サービス ビットマップ]
134 × 38 ピクセル、16 色のカスタム ビットマップ ファイルを指定できます。カラー マッピングの一貫性を保つために、ビットマップの作成時には Windows の 16 ビット カラー パレットだけを使用してください。使用するコンピュータ上の .bmp ファイルを検索するには、[参照] をクリックします。
[検索のタイムアウト]
検索要求をタイム アウトするまでの時間を指定できます。スライダを使用して、時間値を 30 秒 ～ 5 分の範囲内で設定します。
[検索結果の最大表示数]
検索結果を何件まで表示させるかを指定できます。表示させる件数の最大値をこのボックスに入力します。
[メールを送信するときに、名前をサーバーで確認する]
ユーザーがメッセージを送信するときに、サーバーの代わりに Outlook Express に名前解決させるには、このチェック ボックスをオンにします。このオプションを選択すると、Outlook Express はメール メッセージの [宛先]、[CC]、[BCC] の各行に入力された名前に対応する電子メール アドレスを調べます。


ポリシーおよび制限

選択している職種に従って、デスクトップ、インターネット コンポーネント、オペレーティング システム、およびセキュリティを含む、ユーザーのマシンのさまざまな設定を、組織全体に渡って指定することができます。

インターネット コンテンツ プロバイダ、インターネット サービス プロバイダ、および企業内管理者は、ユーザーに適用する既定の設定を指定できます。 さらに、企業内管理者の場合は、プリンタの削除からデスクトップへの項目の追加まで、さまざまな設定をカスタマイズおよび制限することができます。

Internet Explorer 6 カスタマイズ ウィザードで設定し、IEAK プロファイル マネージャで後から管理することのできるシステム ポリシーと制限はすべて、Windows 95、Windows 98、および Windows Millennium Edition オペレーティング システムを実行しているユーザー向けに構成できます。

ただし、Windows NT、Windows 2000、または Windows XP プラットフォーム上で管理者権限を持たないユーザーに対して構成できるのは、これらのシステム ポリシーと制限の一部だけです。その代わりに、Windows NT ポリシー エディタ、Windows 2000 グループ ポリシー、または Windows XP グループ ポリシーを使って、これらのユーザーの残りのポリシーと制限を構成することをお勧めします。

セキュリティに関するこれらの設定がユーザーに与える影響をよく理解しておく必要があります。ほかのユーザーとコンピュータを共有するようなローミング ユーザーが存在している場合は、特に注意します。

注

  • Internet Explorer 6 のイメージ ツール バーという新機能には、イメージ ツール バーの移動を有効にする、画面サイズに合わせて画像を縮小する、メディア バーで自動的にメディア ファイルを再生するなどの設定があります。これらのオプションは、[ポリシーおよび制限] の [インターネットの設定] で設定できます。
  • ウィザードで表示される一連の設定項目は、IEAK に入っている管理者用の .adm ファイルに格納されています。.adm ファイルに詳しい方の場合は、[インポート] をクリックして、自分の .adm ファイルに格納されているポリシーおよび制限を Internet Explorer 6 カスタマイズ ウィザードで設定することができます。

    選択した設定と制限は、.ins ファイルとして格納されます。.ins ファイルは、カスタム パッケージ用の .inf ファイルの作成に使われます。 .adm ファイルと .inf ファイルの関係を説明する図解については、「システム ポリシーおよび設定」を参照してください。

  • [インターネットの設定] の [セキュリティ] での設定が確実に適用されるようにするためには、セキュリティ ゾーンおよびポリシーが正しくセットアップされていることを確認してください。

ユーザーの設定を集中管理しておけば、ユーザーはどのマシンからログオンしても、自分の設定を使用することができます。通常時のセキュリティの設定が非常に厳しいようなコンピュータ上で、緩いセキュリティ値を必要とするようなユーザーには、この機能が便利な場合もあります。

セキュリティに関する設定のカスタマイズ

ユーザーに許可できるカスタマイズのレベルには、通常次の 3 つがあります。

  • すべての設定を制御 ("固定") する
  • ユーザーによる設定項目は制御するが、ローミング ユーザーのためのプロファイルのダウンロードは許可する

    一連の設定の変更をユーザーに許可しないよう指定することができます。ただし、使用するプロファイルが異なるローミング ユーザーもサポートします。Windows のローミング ユーザー機能を使用すれば、ユーザーは各自の設定をサーバーからダウンロードすることができます。

  • 初期設定はカスタマイズするが、その設定の変更はユーザーに許可する

    ウィザードのこの段階では、セキュリティのレベルや規制など、多くのユーザー設定をカスタマイズできます。ただし、この段階での設定のカスタマイズは、ユーザーにその設定の制御を許可するかどうかを決定するものではありません。

システムのポリシーおよび制限を設定するには

  1. 各カテゴリをダブルクリックして、一連のオプションを表示します。
  2. 設定するポリシーまたは制限をクリックします。
  3. 該当するチェック ボックスのオン/オフを切り替えて、設定を実行します。

すべての設定を固定にするには

  1. [企業の制限] をクリックし、[[セキュリティ] ページ] をクリックします。
  2. [セキュリティ ゾーンにコンピュータの設定のみ使用する] チェック ボックスをオンにします。

ユーザーがゾーンのポリシーを変更できないように制限するには

  1. [企業の制限] をクリックし、[[セキュリティ] ページ] をクリックします。
  2. [セキュリティ ゾーンのポリシーの変更を許可しない] チェック ボックスをオンにします。

ユーザーがサイトを追加または削除できないように制限するには

  1. [企業の制限] をクリックし、[[セキュリティ] ページ] をクリックします。
  2. [セキュリティ ゾーンからサイトの追加/削除を許可しない] チェック ボックスをオンにします。


段階 5 : コンポーネントのカスタマイズ

Internet Explorer カスタマイズ ウィザードのこの段階では、カスタム パッケージのコンポーネントの設定、ポリシー、および制限を指定することができます。

利用できるオプションは、次のうちどの職種を選択しているかによって異なります。

  • インターネット コンテンツ プロバイダ
  • インターネット サービス プロバイダ
  • 企業内管理者