Culiet オンラインヘルプ

Culiet ™
~ Online Help ~

Designed for 更新風鐸™
Version 1.03 (Build 180)

Culiet へようこそ！

Culiet をダウンロードしていただき，どうもありがとうございました。このソフトウエアを十分活用していただくためにも，このヘルプを熟読していただけるよう，お願いいたします。

このカテゴリでは，最初にお読み戴くべき事を記しています。このカテゴリを把握することで，ソフトウエアを利用にするに当たっての注意点や，どのカテゴリを自分が読めばいいのかが分かるようになっています。以下のコンテンツをご確認願います。

コンテンツ

  • はじめに
  • 動作環境・開発環境
  • インストール・アンインストール
  • 更新風鐸対応
  • ヘルプの見方


はじめに

はじめに

この Culiet とは，クラッシュという悲劇の連続を経験し，更にそれらを乗り越えた(自称)作者が，満を持して世に送り出したバックアップソフトウエアです。悲劇を繰り返さないように，各種の工夫を凝らした，今までにない高機能でかつ効率的なバックアップソフトウエアとなっています。このソフトウエアをお使いになることで，今までにないほどバックアップ作業が簡単になり，更に意識せずに作業を行えるようになるので，「クラッシュとはバックアップより先に来る」というコンピュータ世界の常識を覆せるものと自負しております。

しかしながら，それなりに高機能で効率的にしたため，概念が普通のバックアップソフトに比べてわかりにくくなっている面があります。わかりにくいことに起因する問題を防ぐためにも，ヘルプファイルは欠かさずお読み下さい。

ところで，このソフトウエアは，1998年4月に最初のバージョンを作った拙作 Copio [image] の思想をベースに新たに再作成しています。この Copio 自体，Vector の週間ソフトニュースで取り上げられたこともあるほど，既にバックアップシステムに定評がありました。そしてそれを継承した Culiet では，当然より良くなり，更に強固になっています。ぜひ末永くお使いになり，Culiet の神髄を感じて下さい。

なお，このソフトウエアはシェアウエアとなっております。これは，制作に莫大な時間がかかった上，資金もかなりかかっているからです(資材・参考書とか)。御利用になることで削れる時間と手間と安心感の代償として，是非ご登録願います。しかしながら，拙作 Copio 相当の機能だけをお使いになる場合は，そのまま登録せず御利用いただくことも可能です。途中でより高い機能を利用されたくなったときに，ご登録下さい。未登録時の制限・登録方法等の詳細は，シェアウエア登録をご覧下さい。

謝辞

このソフトウエアは，次の方のご協力で開発されました。

動作確認協力

  • やまも氏 (Web: Windin' Cannan [image] )
  • その他，α・β版テスターの方々

アイコン

  • むねゴン氏 (Web: ねむの里 [image] )

利用ライブラリ

このソフトウエアでは，以下の各種コンポーネントを利用させていただきました。諸氏には大変感謝しております。

  • 統合アーカイバコンポーネント (米田 昌司 氏作)
  • FolderTreeViewEx (HISHIAMAZON 氏作)
  • トレイアイコンコンポーネント (Yukio Tsujihara 氏作)
  • DirectoryWatcher (うより 氏作)
  • HTML Help コンポーネント (中野 和彦 氏作; Delphi マガジン編集部)

当ソフトウエア公開場所について

当ソフトウエアは，私の Web サイト，Tenacious Nexus [image] で公開されています。その他，Vector [image] 等でも公開されています。

著作権情報

このソフトウエアは，G.ib(竹内 亨)により開発されました。このソフトウエアの著作権は開発者が保持しており，日本国著作権法並びに国際条約により保護されております。Copyright (C) 1999 by G.ib. All Rights Reserved.

第一版制作期間 1999年7月～9月


動作環境・開発環境

このソフトウエアを御利用になるに当たって，必要な環境についてご説明しています。御利用を始める前に，必ずご確認願います。

動作環境・開発環境

動作環境

以下の環境での動作が確認されているか，もしくは動作することが期待されます。以下のリストにない環境での動作は，残念ながら保証しません。

  • Microsoft Windows 95 + Internet Explorer 4.01 以降 (未確認)
  • Microsoft Windows 98 or w/ Service Pack 1
  • Microsoft Windows 98 Second Edition
  • Microsoft Windows NT 4.0 + Internet Explorer 4.01 以降
  • Microsoft Windows 2000 Professional

ご注意 Windows 95 や Windows NT 4.0 では，Internet Explorer 4.01 以上が必須です(要統合)。そうでないと，この HTML Help がご覧になれないばかりか，動作に支障が生じます。また，Internet Explorer 4.01 では，このヘルプが利用できないと言う旨が表示されることがあります。Microsoft から HTML Help コンポーネントのアップデートパッケージ [image] をダウンロードして下さい。(x86 用 Japanese 版を落として下さい)

開発環境

このソフトウエアは，次の環境で制作されています。

CPU | AMD K6-III/450MHz
HDD | 5.1GB + 10GB
RAM | 256MB SDRAM
OS | Microsoft Windows 2000 Professonal Beta 3
Language | INPRISE Borland Delphi 5 Professional Edition

動作確認

動作確認機種

PC/AT 互換機 (自作機)　-　開発マシン

CPU | AMD K6-III/450MHz
HDD | 5.1GB + 10GB
RAM | 256MB SDRAM
OS | Microsoft Windows 2000 Professional Beta 3

VAIO PCG-505V/CBX　-　副開発マシン

CPU | Intel MMX Pentium 300MHz
HDD | 4GB
RAM | 128MB SDRAM
OS | Microsoft Windows 98 Second Edition

Fujitsu FMV-5120 NA2/W　-　スペック寿命マシン

CPU | Intel Pentium 120MHz
HDD | 800MB
RAM | 64MB EDO
OS | Microsoft Windows 98


インストール・アンインストール

インストール
アンインストール

このソフトウエアのインストール・アンインストール・アップグレード等についての詳細を説明しています。

インストール

ダウンロードした書庫を展開の上，新たにこのソフトウエア専用のフォルダを作り，そこへコピーして下さい。なお，実行すべきファイルは，Culiet.exe です。この後，スタートアップへショートカットを作りたい方は，起動後に表示されるメッセージに [はい] と答えることで可能です。

インストール後の移動

移動した後，ログファイルのパスだけ書き直して下さい(Culiet と同じフォルダに指定しているとき)。スタートアップにショートカットを登録しているときは，移動後に再度登録して下さい。

アンインストール

付属のアンインストーラ，Uninstcl.exe を実行して下さい。画面の詳細は，専用アンインストーラについてをご覧下さい。また，実行する前に Culiet 本体を終了するようにしてください。

アップグレード

Culiet β版からのアップグレードは，そのまま上書きされることで実現できます。ただし，必ず Culiet を終了してから実行して下さい。

旧 Copio からの移行は，残念ながら全く出来ません。新たに設定して御利用下さい。

専用アンインストーラについて

専用アンインストーラは，マルチランゲージ対応になっています。Uninstcl.jpn が日本語対応リソースとなっていますので，消去してしまうと英語になってしまいます。

起動すると，4つの設定が並びます。

プログラムファイル

名前の通りですが，Culiet 本体やミラーリングエンジン，このヘルプファイル・ドキュメント等のこちらで用意したりソース全てを削除します。

設定保存ファイル

プロジェクトリストや登録認証キーなどの設定を保存したファイルを削除します。

レジストリエントリ

Culiet の設定をレジストリに保存していますが，これを削除します。

プロジェクト及び関連ファイル全て

これは削除しない方がいいですが，設定されたプロジェクトファイルや，その関連ファイル全てを削除します。

以上の設定を行った後，[Uninstall] を押すと，自動でアンインストールするようになっています。

このプログラムを使うことで，初期設定に戻すことも可能です。初期設定に戻すには，「プログラムファイル」以外のチェックを全てONにすることで行えます。


更新風鐸対応

拙作のオンラインソフトウエアアップデートチェックユーティリティ，更新風鐸 [image] に対応しております。このソフトウエアの最新版の確認がより便利になるこのソフトウエアも，併せて御利用下さい(フリーソフトウエア)。

更新風鐸とは？

更新風鐸とは，拙作のオンラインソフト全般に利用できるアップデートチェックユーティリティです。対応しているソフトウエアについては確実に，対応していないソフトウエアでも，Web に公開されているソフトウエアならほぼアップデートを検知することが出来るソフトウエアです。フリーソフトですので，どうぞ試しにお使いになってみて下さい。

ちなみに，更新風鐸は，1998年窓の杜大賞特別賞を頂いたソフトウエアです。


ヘルプの見方

各種マークについて

マーク [image] があるリンクは，インターネットへのリンクです。インターネットに接続できる環境の場合のみ御利用になれます。このリンクのほとんどは，新しいウインドウを開くようになっています。

目次欄で同様のマークがあるページは，インターネットのページです。私の Web サイトにつなぐようになっています。インターネットに接続できない環境では，選択しないで下さい。

マークに星印がついているリンクは，更新されたものを示しています。このマークは，一月以上経過した時点で消されますので，バージョンアップ時などに，どこを読めばいいのかという目安にして下さい。

カテゴリの説明

このソフトウエアのヘルプでは，次のカテゴリにわけて解説をしています。

最初にお読み下さい

このカテゴリです(^^ゞ。主にソフトウエアを利用するに当たって，最初に必ず把握しておく必要がある項目です。

スターティングガイド

この Culiet について，いち早く全貌を把握できるカテゴリです。ここを全て読むことで，後はポップアップヘルプを見るだけで使えるようになれると思います(そういうつもりで書いています…が，文章力が弱いと伝わっていないこともあるかも知れません…)。この Culiet を使い始める前に，ぜひご覧下さい。

各部の説明

それぞれのウインドウやメニュー毎に解説しているカテゴリです。この機能は何をするのか，このボタンはなんなのか，等の部品毎に説明をしています。使用中に分からなくなったときに，F1 を押したり，タイトルバーの ? ボタンを押してご覧になることが出来ます。

シェアウエア登録

シェアウエア登録される場合に，その手順等についてご説明しているカテゴリです。登録されるつもりがない方でも，未登録時の制限がどういうものかなどは把握しておかないと，バグと勘違いしたりする危険があります。念のため，確認を願います。

利用規程

このソフトウエアの利用規程を示しています。このソフトウエアを起動した時点で，このカテゴリの全ての規定に同意したと見なされます。また，シェアウエア登録をされた方を対象に，ライセンス規定についても記しています。

サポート

このソフトウエアのサポートをご希望になる場合は，このカテゴリを参照して下さい。HTML Help 内部から作者へメールを送ることなども出来るようになっています。

Culiet の情報

このソフトウエアの更新履歴や，CARK (Culiet Administrator Resource Kit) が掲載されています。CARK では，管理者向けの Culiet の情報が掲載されています。Culiet の情報とは，具体的には特性やミラーリングエンジンの再利用などについて解説しています。


スターティングガイド

このカテゴリでは，このソフトウエアを御利用になるに当たって，最低限必要な項目を把握していただくための情報を提供しております。このカテゴリにおいては，必ず最後まで確認の上，実際の御利用をお願いいたします。

なお，このソフトウエアのベースとなった Copio を御利用であった方も，必ずここの項目はご確認願います。

コンテンツ

  • ご利用になる前に
  • 全体の概要
  • バックアップの準備


ご利用になる前に

御利用になる前に，把握していただきたい項目です。

  • 不正利用防止策
  • 未登録時の制限
  • 分からないことがあったら？


不正利用防止策

現状

このソフトウエアはシェアウエアのため，正式なライセンスを取得するには送金していただく必要があります。しかし最近では，オンラインソフトウエアの世界にて，シリアルナンバーが闇で流通してしまうといった利用者のモラル低下が見受けられ，大きな問題となっています。この様なことでは，せっかく送金していただいたユーザの方にとっても，何か損をしたかのような気分なってしまうことがあるやもしれません。特に同じ開発者として，私などはあまつさえ作者がちゃんとそういったことを防止するぐらいの努力をしても良いのではないか，と思ってしまいます(しすぎてもいけませんが…)。

当ソフトウエアでの対策

そこで，このソフトウエアでは，こういった現状を是正するため，数々のクラッキング防止策をはぐらしています。玄人なクラッカーにとっては無いも同然かも知れませんが，大部分の素人には無理なレベルに達しているでしょう。

一番わかりやすいところでは，マシン毎に異なる登録認証キーを採用しています。これは正式登録ユーザの方々にもご迷惑をおかけすることは百も承知ですが(作者も大変です)，しかしこれで大部分の問題を回避できるはずです。ユーザ間の不公平感を無くすための処置ですので，ご理解とご協力をお願いします。


未登録時の制限

制限の詳細

このソフトウエアはシェアウエアですが，いくらかは余裕を持って御利用いただけるようになっています。詳細は，未登録時の制限についてをご覧下さい。

また，これら未登録時の制限は，警告無しに制限されます。そのため，一見不具合に見えるかも知れませんので，その点だけは十分に注意して下さい。


分からないことがあったら？

このソフトウエアを御利用になっていて，この設定はナニを示しているのだろう？ とか，この用語は何だろう？ と思われたら，直ぐにこのヘルプをご覧下さい。もしも理解が中途半端なまま御利用になった場合，バックアップソフトウエアという性質上，データの損失等の損害を招いてしまうことも十分にあり得ます。直ぐにヘルプを参照し，疑問を解いて下さい。これを読んでも疑問が解けない場合は，私の文章力の無さが原因ですから，どんどん作者まで質問して下さい。

設定が意味不明

分からない部品がありましたら，そのウインドウに表示されているヘルプボタン，もしくはタイトルバーにある [?] を押して該当部品の上でクリックするかをすると，ヘルプが表示されます。フォーカスを当ててから，F1 キーを押しても表示されます。

用語が意味不明

用語の大部分は，用語集に示されています。用語集を参照して下さい。


全体の概要

このソフトウエア Culiet について，どういう考えを元に作られたのかをご説明します。これを把握することで，使い方の方向性が分かるようになっています。

コンテンツ

  • Culiet の設計思想
  • Culiet の構造
  • バックアップモードと履歴
  • タスクトレイのアイコン
  • 機能一覧


Culiet の設計思想

このソフトウエアは，バックアックを忘れた頃にクラッシュ等の問題が発生することに注目(？)し，システムに常駐して，出来るだけ勝手にバックアップを行うことを目指して作られました。そのために，次のような機能を実現しました。以下で順にご紹介します。

  • 自動実行
  • 完全なミラーリング
  • 複数プロジェクトでの実行
  • アイドル時に実行

自動実行

自動実行オプションを ON にすることで，稼働状態の(アクティブな)バックアップすべきファイルが，オプションに従って実行されるようになります。これにより，全く意識せずともバックアップが行われるようになります。

完全なミラーリング

バックアップ元からファイルをバックアップ先にコピーするだけでなく，設定によってはバックアップ元のファイル・フォルダが削除されると，バックアップ先でも削除することも出来ます。これにより，完全なミラーリングが再現されています。設定を変えることで，バックアップ元で消されても残しておくこともできますので，間違えて消してしまうといったトラブルにも対処可能となっています。

複数プロジェクトでの実行

この Culiet 独自の機能といっても過言ではない代物で，バックアップするべきファイルを集めたプロジェクトを，いくつも用意して並行利用できるシステムのことです。通常のバックアップソフトウエアでは，いくつもの設定リストを保存することは出来ますが，その切り替えが大変面倒になっています。しかしこのソフトウエアでは，ただリストから操作したいプロジェクトを選ぶだけで設定や実行が可能で，大変楽になっています。何と言っても保存・読込の手間が無く，ユーザの手を煩わせません。なお，この機能の詳細は，同じスターティングガイドのCuliet の構造にて紹介しています。

アイドル時に実行

システムがあまり使われていないときに，バックアップを実行させることが出来ます。これにより，コンピュータから離れたときに実行させたりすることが出来，普段の作業に支障無くバックアップを行うことが出来ます。この機能は，前述の自動実行の一部として含まれます。


Culiet の構造

Culiet の全体がどういう構造をしているのかを把握していただくことで，どうバックアップするファイルを指定して良いのかが分かると思います。ここでは，大きな視点から Culiet の構造を紹介します。

CMPS

まず，Culiet の根底的概念である CMPS (Culiet Mirroring Project System) を把握していただく必要があります。この CMPS とは，複数のプロジェクトによりミラーリング(バックアップ)作業が行われるということを表しています。このシステムを理解していただくには，次の図をご覧になるのがもっとも早いでしょう。

プロジェクトリスト

図の通り，Culiet の一番大きなまとまりがプロジェクトリストと呼ばれる部分です。ここは複数のプロジェクトを一括して管理し，図では示されていませんが，Culiet の全体的動作もここが管理します。これらは全てCuliet のプロパティで設定が出来ます。このリストについては，_culiet.prj というファイルに保存されます。

また，図では「レ」として示されていますが，プロジェクトリストにはプロジェクト毎にアクティブかどうかの設定が付属します。これは，前述の自動実行が ON になっているとき，そのプロジェクトのオプションに従って自動的に実行されるのかどうかを指定しています。アクティブなプロジェクトは，自動実行の対象プロジェクトとなるわけです。

なお，アクティブかどうかの設定は，「Culiet のプロパティ」「プロジェクト編集の右ペイン『プロジェクトリスト』」「プロジェクトのプロパティ」のいずれでも行うことが出来，最初の二つではプロジェクトの名前のチェックボックスをチェックすることで，アクティブに出来ます。

プロジェクト

プロジェクトリストに管理される最小単位が，プロジェクトとなります。このプロジェクトは，同時にバックアップ設定の最小単位となります。ここには，複数のアイテムとプロジェクトをどう実行するかが記録されています。プロジェクトはファイル単位で扱われ，拡張子は CPJ となっていて，エディタで編集も可能です(別途 CARK を参照してください)。

プロジェクトの設定は，プロジェクトのプロパティで変更でき，プロジェクト編集で該当のプロジェクトタブをアクティブにした後，[プロジェクト]-[プロパティ] を選ぶと表示されます。

アイテム

アイテムとは，個々のバックアップすべきファイル・フォルダ・レジストリ(図では F/D/R)を記したもので，一つのアイテムが一つのアドレス(バックアップすべきファイル名やフォルダ名など)を示します。通常のバックアップするファイルは，アイテムとして指定します。

アイテムの追加は，[プロジェクト] メニューから行えるようになっていて，アイテムに対する操作は，[アイテム] メニューから行えるようになっています。ここからコピーして他のプロジェクトにペーストすることもできますので，バックアップ先だけを変えたクローンプロジェクトを作ることも簡単に出来るようになっています。

アイテムの設定は，アイテムのプロパティで行います。


バックアップモードと履歴

このソフトウエアに特殊な概念が，バックアップモードと履歴です。履歴機能は，他の類似ソフトウエアにも搭載されていますが，このソフトウエアでの履歴の扱いが特殊なのです。これについては，十分にご理解いただく必要があります。また，併せてテーブル機能と圧縮機能についても紹介しています。

バックアップモード

このソフトウエアでは，個々のプロジェクト毎に二つのバックアップモードで実行します。二つの実行モードは，それぞれ「標準」「完全」と呼ばれ(同種の扱いにリアルタイムがありますが，厳密には同じものではありません)，完全は標準を包括します。図を参照して下さい。

この2モードは，通常次のように使われます。

普段は標準モードで実行します。そして，個々のプロジェクト毎に指定された回数実行された後，完全モードで実行されます。たとえば，完全実行の間隔を3としていると「標準」「標準」「標準」「完全」「標準」…と実行されます。0にすると毎回完全実行され，-1にすると完全実行は行われません。

また，個々のアイテムについて，標準・完全のどちらでもバックアップをする「常時」アイテムにしたり，完全時のみにバックアップする「完全のみ」といった指定をすることが出来るようになっています。あまり更新されないファイルは，「完全のみ」にすると，普段の作業に与える影響を減らすことが出来るでしょう。

「リアルタイム」に指定されたアイテムは，変更があったファイルまたはフォルダを直ぐにバックアップする作業を行います。「しない」は，当然何もしません。

まとめると，次のようになります。

モード | 内容
標準 | 常時アイテムのみを処理
完全 | リアルタイム以外の全てのアイテムを処理 履歴を一つ増加 テーブルを更新
リアルタイム | リアルタイムアイテムのみ処理 標準実行としては数えない
しない | 何も行わない(リストに保持されるだけ)

履歴

バックアップを自動的に進めることから，誤って変更してしまったファイルをバックアップすることがあります。これを防止することは出来ませんが，誤って変更したファイルを過去にさかのぼって参照して正しいファイルを復元できれば，少なくとも損失を減らすことが出来ます。ただ，履歴というものをナニも考えずに追加すると，異様に場所をとるだけで動作が重くなってしまいます。古くなりすぎた履歴など不要でしょう。しかも，もしフォルダ毎復元するとなったとき，同じフォルダに履歴ファイルがあっては，それらをいちいち削除するのは大変です。そこで，このソフトウエアでは次のようなシステムをとっています。

バックアップモードが2種類有りますが，このうち完全モードの時だけ履歴を増やす処理をします。履歴は，通常バックアップするフォルダとは別の場所に待避されます。これにより，普段は必要なファイルだけバックアップされ，軽くなります。また，復元も容易な状態のままとなります。更にこの履歴に残すべきファイルは，前回の完全実行から，一度でも変更されたファイルが対象になります。これによって，履歴に残されるファイルは最低限必要なファイルだけとなり，よりディスクが有効に使えるようになります。

ただ，この方法には若干問題があり，あまりに古いファイルが参照できなくなってしまいます。これを防止するには，履歴の数を深くすることで対処できます。

履歴の階層は，履歴ディスティネーションの下に階層の番号がついたフォルダが作成され，更にその下にディスティネーションサブフォルダの指定に基づいて保存されるようになっています。

テーブル機能

このソフトウエアでバックアップをしている際に，フォルダのアイテムでは特に「ファイルをチェックしています...」が長期間表示されることがあると思います。通常ファイルのチェックには非常に時間がかかります。これはしょうがないことですが，これを出来るだけ高速化させるための機能が，このテーブル機能です。

この機能は，「標準」「リアルタイム」で実行中にテーブルファイルを参照することで，実際のファイル検索を省略します。これにより，深い階層のフォルダではかなりの高速化が図れます(400％位になることもあります)。ただ，実際にファイルを検索しないことから，新たに増えたファイル・減ったファイルへの対処が出来なくなってしまいます。このままでは意味がありませんので，「完全」で実行中にテーブルを更新するようになっています。そのため，完全モードで実行することが多いと，トータルパフォーマンスは悪くなるかも知れません。

テーブルは，プロジェクト毎に作成されます。拡張子 TBL と TAT がそのテーブルの内容です。

圧縮

このソフトウエアでは，バックアップ時にファイルを圧縮することをサポートしています。これにより，バックアップするファイルのサイズを減らすことが出来るようになります。詳細は，圧縮を行うためには？をご覧下さい。


タスクトレイのアイコン

タスクトレイのアイコン

このソフトウエアは，タスクトレイに常駐するように設計されています。このアイコンからは，Culiet に対する全ての操作が可能となっています。アイコンの操作やその詳細については，各部の説明のタスクトレイのアイコンを参照して下さい。

特に Culiet のプロパティは，右クリックした時に表示されるメニューから，[Culiet のプロパティ] を選択することで設定できるようになります。これは最低覚えておいて下さい。

管理者モードの利用

コーポレイトライセンスで提供される管理者制限機能により，このアイコンから表示されるメニューを制御したり，更にトレイのアイコン自体を非表示にすることが出来ます。


機能一覧

Culiet 1 に搭載されている全ての機能一覧です。「制限」に×がついた機能は，未登録時に御利用になれません。※がついているものは，未登録時・パーソナルライセンス契約時には御利用になれません。詳細は，未登録時の制限についてを参照して下さい。

機能名 | 機能詳細 | 制限
複数プロジェクトでの運用 | 複数のプロジェクトを運用することで，いくつものバックアップ先やバックアップタイミングを設けることが出来ます。 | ×
プロジェクト編集 | 個々のプロジェクトを編集したり，プロジェクトリストを追加・削除・プロジェクト自体の設定をしたり出来るウインドウです。 |
標準/完全実行 | バックアップに標準・完全の2モードを用意することで，一つのプロジェクト内部でもより柔軟にバックアップするファイルを指定することが出来ます。 |
リアルタイム実行 | ファイルが変更されると直ぐにバックアップを実行させることが出来ます。 | ×
圧縮バックアップ | LHA や ZIP 等で圧縮してバックアップさせることが出来ます。 | ×
同期/保持 | フォルダのバックアップ時，ミラーリング動作をさせる「同期」モードと，バックアップ元で消されても残しておく「保持」の二つのモードを用意しています。これはアイテムごとに指定可能です。 |
テーブル | 深い階層を持つフォルダの場合，検索に時間がかかりますが，あらかじめ検索してリストを蓄えておくことで処理速度を向上させる機能です。 |
検索/除外マスク | フォルダのバックアップ時，検索マスクで指定したファイルが取り出され，更に除外マスクに該当するファイルをリストから削除することが出来，より必要なファイルだけをバックアップできる機能です。 |
ログ | バックアップ処理の過程をファイルに保存する機能です。 |
レジストリバックアップ | レジストリの特定のキー以下をファイルに書き出す機能です。レジストリ自体をバックアップするより復元できる範囲が広がります。 |
間隔指定実行 | 指定した間隔でプロジェクトを実行させることが出来ます。 |
指定時間実行 | 指定した時間にプロジェクトを実行させることが出来ます。 | ×
アイドル時実行 | 指定した時間アイドル状態が続いた場合に，プロジェクトを実行させることが出来ます。アイドル判定には，CII か CPU 使用率を用います。 | ×
ボリューム確認 | ディスティネーションのボリュームを確認してから，コピーを開始する機能です。これを用いることで，RMS 等で間違えたメディアにコピーすることが無くなります。 | ×
実行確認 | プロジェクト実行前や，ディスティネーションにあるファイルを削除する前に確認する機能です。間違えを防止できます。 | ×
詳細な進行状況表示 | 進行状況を細かく表示するダイアログです。表示位置等，細かくカスタマイズできます。 |
管理者モード | 管理者によって Culiet の操作を制御できる機能です。 | ※


バックアップの準備

ここでは，実際に一つのプロジェクトを設定する例を通して，全体の概要をつかんでいただきます。これにより，大体のコツは分かるはずです。以下の手順でご紹介します。ここでは全てを解説していませんので，適宜分からないことがあったら？に示された方法で，不明な点を解消して下さい。

  • 新規プロジェクトの追加
  • アイテムの追加・設定
  • プロジェクトの設定
  • Culiet のプロパティの設定
  • 圧縮を行うためには？

※未登録時には，未登録時の制限についてに示されている機能について設定してもなんら効果を持たないものがあります。しかし，ここでは特に差別化して書いていません。その点をご注意下さい。


新規プロジェクトの追加

初回起動時

初回起動時には，自動的に新規プロジェクトの作成が行われます。この際，名前とパスを指定するだけでかまいません(他の設定は，後で行えます)。

プロジェクトを編集する

プロジェクトを編集するには，タスクトレイのアイコンを左ダブルクリック，もしくは右クリックのメニューから「プロジェクト編集」を選択します。ここで表示されたプロジェクト編集画面で，全てのプロジェクトの編集が行えます。

新たに新規プロジェクトを追加するには，ここで [ファイル]-[新規プロジェクト] を選択すると，新規プロジェクト作成ダイアログが表示されます。設定後に [OK] を押すと，プロジェクト編集画面に新規プロジェクトが追加され，反映されます。

設定するプロジェクトの切り替え

二つ以上のプロジェクトを利用する際には，現在どのプロジェクトを編集しているのかを勘違いすると，大変なことになります。

プロジェクト編集画面の左ペインでは，タブとしてリストに含まれるプロジェクトが並び，アクティブなタブに含まれるアイテムがその下のリストビューに表示されるようになっています。必ず設定したいプロジェクトのタブがアクティブになっていることを確認してから，各種設定を行って下さい。もし，今タブがアクティブでないプロジェクトを編集したいときは，該当するプロジェクトのタブをクリックして，そのプロジェクトをアクティブにして下さい。

※ここでいうアクティブとは，プロジェクトリストで言うアクティブプロジェクトではなく，タブがアクティブなプロジェクトを表します。わかりにくいですね…。

なお，いくつかの操作をすると，選択しているタブが元に戻ることがありますので，ご注意下さい。


アイテムの追加・設定

新規追加したプロジェクト，または既存のプロジェクトにアイテムを追加することで，バックアップするファイルを指定できます。ここでは，アイテムの追加方法や設定方法について解説します。

アイテムの追加

※ここでいうアクティブとは，プロジェクトリストで言うアクティブプロジェクトではなく，タブがアクティブなプロジェクトを表します。わかりにくいですね…。

ファイル・フォルダの追加

アイテムの追加をする前に，まず追加したいプロジェクトのタブをアクティブにします。アクティブにしたプロジェクトに対して，次の3通りの方法でアイテムを追加することが出来ます。

  • エクスプローラからプロジェクト編集画面にファイル・フォルダをドロップする
  • 右ペインに用意されたアドレス指定からファイル・フォルダをドロップする
  • [プロジェクト]-[ファイル/フォルダ アイテムの追加] を選択する

いずれにしても，ドロップ後に三つ目と同じ画面が表示されます。この画面は，ソースアイテム追加ウィザードと表示され，最初のページで追加したいアイテムのアドレスを指定します。いずれの方法でも，ここで更にエクスプローラからファイル・フォルダをドロップして追加したり，不要なものを削除したり出来るようになっています。

完了後，次のページに進めると，それらアイテムに共通の設定を選択できます。追加したいアイテムに共通の設定を施した後，次へ進めるとアイテムがプロジェクトに追加されます。

レジストリの追加

レジストリのアイテムを追加する方法を紹介します。これは，[プロジェクト]-[レジストリアイテムの追加] からしか実行できません。このコマンドを実行すると，同様にソースアイテム追加ウィザードが表示され，二つの項目を設定するように迫られます。

キーの名前と書き出すファイル名の二つですが，前者はレジストリエディタで該当するキーの名前をそのまま記述し，書き出すファイル名では，書き出すべきファイル名を指定します。書き出すべきファイル名は，プロジェクトのディスティネーションの下のフォルダを指定することもできますので，たとえば RegBak\HKLM_Software.reg といった指定をすることもできます。

※レジストリのバックアップは，レジストリエディタを利用できる権限のあるユーザに限られます。詳細は管理者にお聞き下さい。Windows 9x では，無条件に行えます。

アイテムの設定

ファイル・フォルダ・レジストリいずれのアイテムについても，次の4通りの方法のいずれかで，アイテムのプロパティを呼び出せます。

  • [アイテム]-[プロパティ] を選択する
  • アイテムを直接ダブルクリックする
  • メインツールバーから該当のアイコンをクリックする
  • アイテムを右クリックして，[プロパティ] を選択する

アイテムのプロパティでは，個々のアイテム毎に設定を行うことが出来ます(いくつかの設定は，ツールバーから直接行うこともできます)。この設定については，詳細は F1 を押したり [ヘルプ] ボタンを押して，ヘルプを参照して下さい。


プロジェクトの設定

ここでは，既にアイテムが追加され，バックアップすべきファイルの指定が完了した時点を想定し，プロジェクトを設定する方法を紹介します。

プロジェクトを設定することで，バックアップに関する詳細を指定することが出来ます。

プロジェクトの設定を呼び出す

プロジェクトの設定は，プロジェクト編集画面から呼び出します。呼び出す方法は，次の3通りがあります。

  • [プロジェクト]-[プロパティ] を選択する
  • メインツールバーから該当のアイコンをクリックする
  • 現在開いているプロジェクトのタブをダブルクリックする

プロジェクトのプロパティでは，プロジェクトファイル名以外の大部分を変更することが出来ます。ここで変更した内容は，[OK] を押すと反映されます。ここでバックアップするに当たっての重要な項目についてご紹介します。

全般シートでの設定

プロジェクトの全般的な設定を行います。

ディスティネーション

ディスティネーションとは，バックアップ先のことです。このソフトウエアでは，判別のしやすさから，英語を用いています(バックアップ元・バックアップ先 だと1文字しか変わりません)。履歴ディスティネーションは，履歴を保存するバックアップ先のことです。バックアップ先は，リムーバブルメディア・固定ディスク・ネットワークドライブのいずれでも動作可能です。

完全実行の間隔・履歴の最大数

バックアップモードと履歴で紹介した，完全モードで実行する間隔や，履歴の最大数を指定します。

トリガシートでの設定

自動実行するプロジェクトに設定しているとき(ここのシートにある「アクティブ」が ON になっていて，更に自動実行モードになっているとき)，どういうタイミングで実行するかを設定します。

基本トリガ

アクティブを ON にすると，自動実行対象となります。実際に自動実行するかどうかは，自動実行モードかどうかに依存します。

自動実行トリガ

間隔指定は指定した時間毎に，時間指定は指定した時間に，アイドル時指定は，アイドル判定で指定時間が経過した際に実行します。

これらの設定はコンバイン出来，たとえば間隔10分・アイドル3分とすると，12:00 に実行した後 PC を放置しても，12:10 まで実行されません。12:03 に実行したければ，間隔設定を OFF にします。更に，作業を続けている場合は，12:10 を過ぎても実行されません。アイドル状態が3分続いてから，実行されます。

高度シートでの設定

ボリュームラベルを調べてから実行する

ボリュームラベルが異なると，コピー動作に移らないようにします。これにより，ありもしないコピー先に転送したりする問題を回避できます。特にリムーバブルメディアでは，メディアが違うのに動作してしまう問題を回避できるでしょう。この設定を ON にするだけだと，特に確認せず，違えばキャンセルされますが，全般シートの「プロジェクトを実行する前に確認する」が ON ならば，確認するようになります。


Culiet のプロパティの設定

プロジェクトの設定が完了した時点を想定し，自動実行に移行するための設定を紹介します。

Culiet のプロパティを呼び出す

Culiet のプロパティは，タスクトレイのアイコンから呼び出すこともできますし，プロジェクト編集から [ツール]-[Culiet のプロパティ] を選択して呼び出すこともできます。

Culit のプロパティで設定した項目は，全てのプロジェクトに影響しますので，ご注意下さい。なお，これらの情報はプロジェクトには記述されません(プロジェクトファイルをコピーして他で利用する際には，他の Culiet における設定が優先されます)。

全般シートでの設定

ここでは，Culiet 全体の設定の内，頻繁に変更したり利用したりするオプションを載せています。

自動実行モードにする

類似の設定は，タスクトレイのアイコンにもCuliet プロジェクト編集の [ツール] メニューにもありますが，これを ON にすることでアクティブプロジェクトが自動実行されるようになります。逆に，OFF にすることで，全てのプロジェクトの自動実行を切断することが出来ます。

ログ

デフォルトでは OFF になっていますが，出来るだけログは残すようにして下さい。これは，ユーザにとってどのファイルがバックアップされたり，またはされなかったかが分かるだけでなく，バグの発見にもつながることがあるからです。ディスクに余裕がある場合は，追記オプションも ON にするといいかもしれませんが，時々Culiet プロジェクト編集の [ツール] メニューにある [ログをクリアする] を実行してファイルを削除し，肥大化を防いで下さい。

プロジェクトリストシートでの設定

ここでは，プロジェクト編集の右ペイン「プロジェクトリスト」よりも詳細にプロジェクトリストを操作することが出来ます。新規プロジェクトの追加はもちろん，既存のプロジェクトを追加したり，いらなくなったプロジェクトを削除(リストからだけで，実際のファイルは消えない)したりできます。プロジェクトリスト欄でのチェックは，アクティブプロジェクトかどうかを示しています。

ここの設定は瞬時に反映されますので，[キャンセル] を押しても元に戻りません。

高度シートでの設定

アイドル判定基準

プロジェクトにあった自動実行トリガの内，アイドル時実行に使われるアイドル判定基準を設定します。通常はデフォルトのままで良いでしょう。


圧縮を行うためには？

必要なもの

DLL の入手

本ソフトウエアでサポートされる，圧縮してバックアップを行うためには，外部の DLL が必要となります。この DLL を入手していただかないと，圧縮機能は御利用になれません。DLL は，統合アーカイバプロジェクト [image] や各種 PC 専門雑誌等に付属しています。必要な DLL は，利用したい圧縮フォーマットによって異なりますが，現在同プロジェクトで提供されている DLL は次の通りです。

利用したいフォーマット | 必要な DLL | サポート
LHA 形式 | UNLHA32.DLL | ◎
ZIP 形式 | ZIP32J.DLL | ○
ARJ 形式 | UNARJ32J.DLL | ×
CAB 形式 | CAB32.DLL | ×
TAR 形式 | TAR32.DLL | ×
RAR 形式 | UNRAR32.DLL | ×

※サポート欄は，◎=動作確認・保証 ○=動作可能 ×=動作しない です。

DLL の導入

該当の DLL を入手されたら，Windows のシステムフォルダにコピーします。Windows 9x では C:\Windows\System になります。Windows NT/2000 では，D:\Winnt\System32 となります。おのおの，ドライブ名はインストールしているドライブ・フォルダに書き直して確認して下さい。

フォーマットの切り替え

フォーマットを変更するには，圧縮するアイテムの履歴ディスティネーションをファイル名付きで記述します。更に，ファイル名に書庫の拡張子を含めます。何も書かない場合は，自動的に Culiet.lzh という LHA 形式で圧縮された書庫が，アイテム毎に作成されます。


各部の説明

このカテゴリでは，このソフトウエアの各部の説明を記しています。場所は分かっているけれども，その項目が何を意味しているのかが分からない場合にご確認下さい。また，直接ソフトウエアから呼び出すと，ここの項目が呼ばれます。

コンテンツ

  • タスクトレイのアイコン
  • Culiet プロジェクト編集
  • アイテムのプロパティ
  • プロジェクトのプロパティ
  • Culiet のプロパティ
  • 新規プロジェクト
  • ソースアイテム追加ウィザード
  • 進行状況表示ダイアログ
  • プロジェクトを選択して実行
  • 時刻設定ダイアログ
  • 管理者モード


タスクトレイのアイコン

アイコンの操作

このソフトウエアは，常時タスクトレイに常駐しています。アイコンは自動実行モードによって切り替わり，進入禁止のようなマークが記されているときは，自動実行モードが OFF になっています。また，アイコンに対する操作は，次のようになっています。

操作 | 実行される機能
左クリック | プロジェクト実行中は，進行状況表示ダイアログのメニューと同じメニューが表示されます。それ以外の時は，何も表示されません
左ダブルクリック | プロジェクト編集が呼び出されます
右クリック | 各種設定を操作できるメニューが表示されます(以下に詳細)
チップヘルプ | 現在の動作状況が表示されます

このうち，右クリック時のメニューについて解説します。左クリックしたときのメニューは，実行中に進行状況表示ダイアログのメニューと同じものが表示されますので，こちらを参照して下さい。

トレイアイコンからのメニュー

メニューに表示されるコマンドについて解説します。クリックすると，展開されます。

プロジェクト編集

Culiet プロジェクト編集を開きます。

自動実行モード

Culiet 全体で自動実行モードにします。アクティブなプロジェクトは，自動的に実行されるようになります。Culiet のプロパティでも設定できます。

プロジェクトを選択して実行

プロジェクトを選択して実行します。自動実行と違って，手動で実行するプロジェクトを選択できます。非アクティブプロジェクトも実行可能です。ダイアログを開くと，デフォルトではアクティブなプロジェクトが選択された状態で表示されます。

管理者モード

管理者によって制限をかける機能です。これを利用することで，他のユーザによって Culiet の存在が知られたりせずにすむようになります。ただ，管理者モードは全て英語で用意されています。

Culiet のプロパティ

Culiet 全体の設定をする，Culiet のプロパティを開きます。

ログ表示

既に記録されたログを，TXT に関連付けられたエディタ(メモ帳など)で開かれます。ログファイルの拡張子を変えているときは，それに追随します。


Culiet プロジェクト編集

Culiet における全ての設定が可能なウインドウです。ここからあらゆる設定を行います。以下の図に従ってご紹介します。

メニュー＆ツールバー

上部に並んだ三つのバーが，メニューとツールバーです。詳細は，次をご覧下さい。

  • メニュー
  • ツールバー

左ペイン

左ペインとは，ツールバーが終わってから下のブロックの内，左側を指します。ここでは，常時HDバックアップという文字が見える部分(プロジェクタタブ)と，その下の Folder という文字が見える部分(アイテムリスト)です。

プロジェクトタブ

プロジェクトタブでは，おのおののプロジェクトがタブとして表されています。ここを切り替えると，編集対象のプロジェクト変更することが出来ます。また，プロジェクトタブをダブルクリックすると，プロジェクトのプロパティを開くことが出来ます。

アイテムリスト

一つ一つのアイテムが，一行で示されています。ここではカラムをクリックすることでソートしたり，ドラッグアンドドロップで順番を変えたりすることが出来るようになっています。また，アイテムの上でダブルクリックすると，アイテムのプロパティを開きます。

右ペイン

右ペインとは，アドレス指定・プロジェクトリストタブが表示される部分です。ここでは，プロジェクトに対する補助的な機能を提供しています。

アドレス指定

ファイルやフォルダを一つだけ追加するときには，エクスプローラを開かずに追加できるツリーです。ここからドラッグアンドドロップでアイテムリストへドロップすることで，ソースアイテム追加ウィザードが起動するようになっています。

プロジェクトリスト

現在 Culiet に登録されているプロジェクトと共に，アクティブかどうかが示されています。また，ここではドラッグアンドドロップでアイテムを移動し，並び替えることが出来るようになっています。プロジェクトを追加したり削除したりするには，Culiet のプロパティを開いて下さい。なお，プロジェクトを新規追加するには，メニューから [ファイル]-[新規プロジェクト] を選択して下さい。新規/追加/削除 するには，[ツール]-[Culiet のプロパティ] を選択します。


メニュー

ここでは，Culiet プロジェクト編集にある全てのメニュー項目について説明しています。調べたい項目をクリックすると，その内容が展開されます。

ファイル

新規プロジェクト

新規プロジェクト作成ダイアログを表示し，新規プロジェクトを作成して追加します。

プロジェクトの保存

変更したカレントプロジェクトを保存します。ただし，Culiet のプロパティにて [プロジェクトの保存を確認しない] を設定しているときは，このコマンドを選択せずとも自動で保存します。

プロジェクトを別名で保存

カレントプロジェクトを別名をつけて保存します。他のマシンで使うときや，ファイル名を変更するときにお使い下さい。追加するには，Culiet のプロパティにて行って下さい。

閉じる

Culiet プロジェクト編集画面を閉じます。Culiet は常駐し続けます。

Culiet の終了

Culiet 自身を終了させます。常駐も解除されます。

アイテム

コピー・切り取り・貼り付け・削除・全て選択

選択しているアイテム(複数可)をそれぞれコピーしたり切り取ったり貼り付けたり，また削除したり出来ます。なお，二重登録は出来ないことから，同じプロジェクトでコピーして貼り付けても何もおきません。

アクセス

選択したアイテムにアクセスします。ファイルの際は関連付いていれば開き，フォルダの際はフォルダを開きます。レジストリには使えません。なお，ソースを選ぶとオリジナル(バックアップ元)のファイルを開き，ディスティネーションを選ぶとバックアップ先を開きます。

プロパティ

アイテムの設定を変更するためのアイテムのプロパティを開きます。複数選択しているときは，フォーカスがあるアイテムの設定を変更します。

プロジェクト

ファイル/フォルダ アイテムの追加

ファイルやフォルダのソースアイテムを追加します。エクスプローラや Culiet プロジェクト編集の右ペイン「アドレス指定」からドロップしたときも，このコマンドを選択した後に表示されるソースアイテム追加ウィザードが表示されます。

レジストリアイテムの追加

レジストリアイテムを追加します。ソースアイテム追加ウィザードが表示されます。

読込時の状態に戻す

プロジェクトを変更した際，間違えて消してしまったときなど，プロジェクトを読み込んだときの状態に戻します。このコマンド自体のやり直しはききません。

無効なソースを削除

カレントプロジェクトにおいて，ソースアドレスが存在しないアイテムを全て消去します。レジストリアイテムはチェックされません。

アクティブ

プロジェクトがアクティブかどうかを示します。Culiet プロジェクト編集の右ペイン「プロジェクトリスト」のチェックと同じです。クリックすることで，切り替えることが出来ます。

プロパティ

プロジェクトの設定を変更するためのプロパティを開きます。プロジェクトのプロパティでは，プロジェクトの動作についてを変更することが出来ます。

ツール

自動実行モード

アクティブなプロジェクトを自動実行するかどうかを設定します。Culiet のプロパティでも，タスクトレイのアイコンからでも設定できます。

プロジェクトを選択して実行

プロジェクトを選択して実行します。自動実行と違って，手動で実行するプロジェクトを選択できます。非アクティブプロジェクトも実行可能です。ダイアログを開くと，デフォルトではアクティブなプロジェクトが選択された状態で表示されます。

ログファイルのクリア

ログファイルを追記指定にしている場合，バックアップを繰り返すたびにログファイルが肥大化します。時々このコマンドで消去するようにして下さい。

関連づけの再登録

CPJ ファイルを関連付けます。通常，Culiet を初めて起動したときに登録されますが，登録されていないとき/登録が上書きされたときに実行して下さい。なお，現在のバージョンでは，関連付けを用いてそのまま実行することは出来ません。

Culiet のプロパティ

Culiet 全体の設定を行うためのCuliet のプロパティを開きます。


ツールバー

ここでは，Culiet プロジェクト編集にある全てのツールバー項目について説明しています。調べたい項目をクリックすると，その内容が展開されます。これらは，左から順に紹介しています。

メインバー

新規プロジェクト

新規プロジェクト作成ダイアログを表示し，新規プロジェクトを作成して追加します。。

プロジェクトの保存

変更したカレントプロジェクトを保存します。ただし，Culiet のプロパティにて [プロジェクトの保存を確認しない] を設定しているときは，このコマンドを選択せずとも自動で保存します。

コピー・切り取り・貼り付け・削除

選択しているアイテム(複数可)をそれぞれコピーしたり切り取ったり貼り付けたり，また削除したり出来ます。なお，二重登録は出来ないことから，同じプロジェクトでコピーして貼り付けても何もおきません。

アイテムのプロパティ

アイテムの設定を変更するためのアイテムのプロパティを開きます。複数選択しているときは，フォーカスがあるアイテムの設定を変更します。

ファイル/フォルダ アイテムの追加

ファイルやフォルダのソースアイテムを追加します。エクスプローラや Culiet プロジェクト編集の右ペイン「アドレス指定」からドロップしたときも，このコマンドを選択した後に表示されるソースアイテム追加ウィザードが表示されます。

レジストリアイテムの追加

レジストリアイテムを追加します。ソースアイテム追加ウィザードが表示されます。

プロジェクトのプロパティ

プロジェクトの設定を変更するためのプロパティを開きます。プロジェクトのプロパティでは，プロジェクトの動作についてを変更することが出来ます。

Culiet のプロパティ

Culiet 全体の設定を行うためのCuliet のプロパティを開きます。

編集バー

常時・完全のみ・リアルタイム・しない

選択しているアイテム(複数可)の実行属性を切り替えます。[常時] は「標準」「完全」のいずれのモードで実行されてもバックアップ対象となり，[完全のみ] は「完全」モードで実行されたときだけバックアップ対象となります。[リアルタイム] はリアルタイムアイテムになり，変更が有れば直ちにバックアップされるようになります。また，完全モード時にはバックアップ対象になります。[しない] は，いずれのモードにおいても，実行されないようになります。

サブフォルダ検索(フォルダ専用)

選択しているアイテム(複数可)において，サブフォルダも検索してバックアップの対象にするかどうかを指定します。この機能を利用すると極端に遅くなることがあります。[テーブルを使用] を ON にすると，若干緩和されることがあります。

同期(フォルダ専用)

選択しているアイテム(複数可)において，ソース側で消されたファイルが，ディスティネーション側で消されるかどうかを指定します。ON にすると(同期モード)消され，OFF にすると(保持モード)残されます。

テーブル使用(フォルダ専用)

選択しているアイテム(複数可)において，テーブルを使用するかどうかを指定します。テーブルとは，特定のフォルダを検索する際に，既に検索済みのリストを使って代用する機能のことで，深い階層のフォルダなどでは処理が格段に向上することがあります。サブフォルダが少ない場合は，ほぼ速度に変化が無くなります。また，テーブルを利用すると，次回の完全モード実行まで内容が更新されませんので，その間に追加されたファイルには対応できません。

圧縮(レジストリ以外)

チェックを ON にすると，圧縮して保存されるようになります。専用の DLL が必要です。圧縮については，圧縮を行うためには？を参照して下さい。


アイテムのプロパティ

アイテムの基本設定ファイル

実行タイミング

カレントアイテムの実行属性を切り替えます。[常時] は「標準」「完全」のいずれのモードで実行されてもバックアップ対象となり，[完全のみ] は「完全」モードで実行されたときだけバックアップ対象となります。[リアルタイム] はリアルタイムアイテムになり，変更が有れば直ちにバックアップされるようになります。また，完全モード時にはバックアップ対象になります。[しない] は，いずれのモードにおいても，実行されないようになります。

対象アドレス

対象のファイル・フォルダ・レジストリのアドレスを指定します。ファイル・フォルダの際には，右の [...] ボタンからアドレスを変更することが出来るようになってはいますが，変更については二重登録防止が動作しませんので，出来れば利用しないようにして下さい。レジストリアイテムの場合は，レジストリエディタが起動します。

ディスティネーションサブフォルダ

プロジェクトのプロパティで設定されたディスティネーションの下の，どこへバックアップするかを指定します。通常自動で設定されますが，変更するときは任意のパスを書いて下さい。書式は，Sub1\Sub2\...\Subn という形にして下さい。最初と最後に \ はいりません。
また，ファイルフォルダの圧縮・レジストリ機能を使用しているときは，ここへファイル名を付け足してバックアップ後のファイル名を指定できます。たとえば，Sub1\Culiet.zip と書くと ZIP 形式になります。Sub1 とかかれているだけだと，Sub1\Culiet.lzh と同じ意味になります。拡張子は必ず指定して下さい。また，その拡張子にあう DLL を別途入手して下さい。レジストリの際も同じで，Sub1\HKLM_Software.reg の様な形で記す必要があります。レジストリの場合は，省略すると Sub1 というファイル名のファイルが作られてしまいます。

圧縮して保存する

アイテムを圧縮して保存します。遅いマシンだとクリティカルなほど遅くなりますが，バックアップにあまり場所をとらないようになります。履歴だけを圧縮するには，プロジェクトのプロパティで [履歴を全て圧縮] にチェックしておくと，ここの設定には影響されずに圧縮することが出来ます。なお，圧縮については圧縮を行うためには？を参照して下さい。

フォルダアイテムの設定

サブフォルダを検索する

チェックされたアイテムは，アドレスに示されたフォルダの下にあるフォルダを検索します。ただし，サブフォルダが多いときは，検索に非常に時間がかかるようになります。検索については，テーブル機能を併用することで，早くすることが出来ます。

同期

ソース側で消されたファイルが，ディスティネーション側で消されるかどうかを指定します。ON にすると(同期モード)消され，OFF にすると(保持モード)残されます。

テーブルを使用

テーブルを使用するかどうかを指定します。テーブルとは，特定のフォルダを検索する際に，既に検索済みのリストを使って代用する機能のことで，深い階層のフォルダなどでは処理が格段に向上することがあります。サブフォルダが少ない場合は，ほぼ速度に変化が無くなります。また，テーブルを利用すると，次回の完全モード実行まで内容が更新されませんので，その間に追加されたファイルには対応できません。

検索マスク

検索マスクを指定します。通常 *.* で全てのファイルを示しています。ここの設定は DOS のワイルドカードと同じ設定が出来，* で複数文字の代用，? で一文字の代用が出来ます。複数指定時は，スペースで区切ります。たとえば，*.doc で Word ドキュメント全て，?in.ini で Win.ini や Kin.ini などを検索対象と出来ます。複数指定時は，*.doc *.xls とすると，Word/Excel ドキュメントが対象になります。

除外マスク

除外マスクを指定します。除外マスクを指定すると，検索マスクに該当したファイルリストから，このマスクに該当するファイルを除くことができます。設定法は検索マスクのヘルプを参照して下さい。


プロジェクトのプロパティ

全般

プロジェクト全般の設定

名前

プロジェクトの名前を設定します。プロジェクトの名前は，他のプロジェクトかぶらないようにした方が，管理の面でわかりやすくなります。ユニークな名前を付けて下さい。(ユニークは面白いじゃなくて，唯一の…って意味です)

ディスティネーション

ディスティネーション(バックアップ先)を設定します。横にドライブの種類が表示されるようになっていますので，ここでドライブが存在しないといわれたりするような指定は，しないようにして下さい。ディスティネーションの設定はフォルダ単位で行いますが，現在は存在しないフォルダでもかまいません。[...] をクリックすると，ディスティネーションのフォルダを参照して設定できます。

履歴ディスティネーション

履歴ディスティネーション(履歴バックアップ先)を設定します。ディスティネーションのヘルプも参照して下さい。

完全実行の間隔

完全実行の間隔を指定します。0とすると毎回完全実行され，-1とすると完全実行されなくなります。完全実行等が不明な場合は，スターティングガイドをご覧下さい。

履歴の最大数

履歴の最大数を設定します。履歴ディスティネーションの下に，この数字のフォルダを最大とする履歴が保存されるようになります。たとえば，Z:\History と設定してある場合，Z:\History\1 というフォルダが作られ，その下に保存されていきます。

履歴は全て圧縮

履歴を全て圧縮するようにします。履歴は通常あまり使われることはないですが，場所はやはりとってしまいます。このオプションを使うことで，履歴を全て圧縮して場所を有効活用することが出来るようになります。

確認

プロジェクトを実行する前に確認する

プロジェクトを実行開始する前に，実行を継続するかどうかを確認します。また，[ボリュームを確認してから実行する] を指定している場合は，ラベルが異なれば再試行するかどうか，確認します。

ディスティネーションのファイル削除時に確認する

ディスティネーションのファイルを削除する際に，いちいち確認するようにします。クリティカルなプロジェクトにおいては，チェックしておくと安全性が高まります。

トリガ

基本トリガ

アクティブ

プロジェクトをアクティブにするかどうかを設定します。アクティブでないプロジェクトは，自動的に実行されることはありません。アクティブなプロジェクトは，自動実行モードになっているときに自動実行されます。

起動直後にも実行する

Culiet を起動した直後に，必ず実行するようにします。自動実行モードでかつアクティブプロジェクトでないと，動作しません。

自動実行トリガ

間隔指定

間隔指定による自動実行を行います。Culiet が起動してから指定した時間が経過すると，自動的に実行します。他の設定と併用しているときは，全ての設定に合致する場合に実行されます。
たとえば，12:00 に実行指定にして，10分おきにしている場合で，11:55 に手動実行していると，12:00 には実行されなくなります。次の日まで実行されません。11:45 に手動実行していると，動作します。

時間指定

時間指定による自動実行を行います。指定した時間・曜日になると，実行を開始します。指定した時間を1分でも過ぎた後に Culiet を起動すると，実行されません。また，他の設定と併用しているときは，全ての設定に合致する場合に実行されます。
ここに示されているリストビューには，設定した時間・曜日が表示されます。日にちが0は無視を表します。ここで選択した後 [変更] をクリックすると，選択したアイテムを変更でき，[追加] を押すと新しいアイテムを追加できます。同様に [削除] を選択すると，アイテムを削除できます。なお，ドラッグアンドドロップで場所を移動することができます。

アイドル時指定

アイドル判定により一定時間が経過した後実行されるようにします。また，他の設定と併用しているときは，全ての設定に合致する場合に実行されるようになります。

高度

ディスティネーションのチェック

ボリュームラベルを調べてから実行する

ディスティネーションのボリュームラベルを調べてから，実行するようにします。ディスティネーションがリムーバブルメディア・ネットワークドライブ等の場合は，このオプションを利用することで，有りもしないディスティネーションにファイルがコピーされることが無くなります。
ディスティネーションが存在しないときに確認して欲しい場合は，全般シートの [プロジェクトを実行する前に確認する] オプションを ON にして下さい。OFF のままの場合は，確認せずエラーとして終了します。

(履歴)ディスティネーションのラベル

ディスティネーションのラベルを設定します。[...] を選択すると，全般シートで設定されたディスティネーションパスに従って，ラベルが取得されます。

タイムスタンプ許容誤差

ファイルを比較する際に，ここで指定された時間の誤差までなら同一日時として扱います。特に，FAT-NTFS 間では2秒ずれることがあり，このままの設定にすることをお勧めします。


Culiet のプロパティ

全般

一般的な設定

自動実行モードにする

自動実行モードにします。このモードにすると，アクティブプロジェクトを全て自動的に実行するようになります。個々のプロジェクトがどう実行されるかは，個々のプロジェクトのプロパティを編集して下さい。

確認せずにプロジェクトを保存する

プロジェクトを変更すると，保存コマンド以外でも所々で保存するかどうかを聞かれます。そういった場所では，保存したことを前提に処理するようになっているからです。この確認を省略するには，ここにチェックを入れて下さい。ただ，チェックを入れてしまうと，確認無しで保存されるので，注意が必要です。

実行中に進行状況を表示する

実行中に進行状況を表示させます。表示した方が心穏やかになりますが，管理者的に動いていることを知られたくないときなどは OFF にしてください。表示位置を設定する事もでき，プライマリディスプレイの四つ角，及び任意の位置を指定できます。任意の位置では，実際にプロジェクトが実行中に移動した場所を記録し，次回からそこを利用するようになります。詳細を表示するモードにすると，処理中のアイテム名・ファイル名・現在のアイテム数などが表示され，よりわかりやすくなります。

カーネルのプライオリティ

カーネルのプライオリティを設定します。通常，アイドル(右端)のままで使うことをお勧めしますが，他に仕事をしない PC (ファイルサーバで夜中に Culiet でバックアップなど)の場合は，標準レベルまで持っていってもいいでしょう。優先モードは，あまり使わない方がいいと思います。

ログ

処理のログを記録する

処理の結果をログに記録するかどうかを指定します。ログには，圧縮の結果・レジストリバックアップの結果が成功かどうかは記録されませんが，これ以外は全て記録されます。パス欄には，ログファイルのパスを設定します。

追記

追記にすると，既存のログを残すようになります。肥大化してきた場合は，適宜削除して下さい。

スタートアップへの登録/削除

登録する

スタートアップに Culiet のショートカットを作成します。これにより，Windows 起動と同時に Culiet の常駐が行えるようになります。

登録を削除する

スタートアップに既に登録済みの Culiet のショートカットを削除します。アンインストール前には，必ず実行して下さい。

プロジェクトリスト

プロジェクトリストの設定

プロジェクトリスト

プロジェクトリストを設定します。チェックを ON/OFF することで，アクティブかどうかを切り替えられます。ドラッグアンドドロップで順番を変更することもできます。

上へ/下へ

選択したプロジェクトを上/下へ移動します。ドラッグアンドドロップでも移動できます。

新規・追加・削除

新規ボタンは，新規プロジェクトを追加します。詳細は，続いて表示されたダイアログのヘルプを参照して下さい。追加ボタンは，既存のプロジェクトをリストに追加します。削除ボタンは，選択しているプロジェクトを削除します。実際のファイルは削除されません。

全てアクティブ/全て非アクティブ

全てのプロジェクトをアクティブ/非アクティブにします。

高度

アイドル判定基準

CII (Culiet Idle Indicator) を用いる

アイドル判定基準に CII を用います。システム的忙しさが一定時間同じの場合にアイドルと見なす数値です。通常はこのままでいいでしょう。また，誤差許容レベルでは，CII の値のぶれをどこまで誤差と見なすかを設定します。変更すると，値の実測グループの「現在の CII 値」にて，(+- 0) のところに反映されます。通常は，特に変更する必要もないでしょう。

CPU 使用率を用いる

アイドル判定基準に CPU 使用率を用います。特定の CPU 使用率以下の状態が継続して続いた場合に，アイドルと見なします。更にアイドルと見なす数値で指定した CPU 使用率以下の状態が続いた場合に，アイドルと見なします。

値の実測

このグループでは，設定に従ってアイドル状態が続いているか，また CII/CPU の実際の値が表示されます。どちらを使うべきかの目安にして下さい。

リアルタイム

リアルタイムの遅延

リアルタイムアイテムにおいて，変更が有ってからここで指定した時間が経過後，バックアップ作業が行われます。頻繁に更新される場合は短く，たまに更新する場合は長くしておくと，無駄な作業が行われずにすむでしょう。


新規プロジェクト

プロジェクト基本設定

名前

プロジェクトの名前を設定します。プロジェクトの名前は，他のプロジェクトかぶらないようにした方が，管理の面でわかりやすくなります。ユニークな名前を付けて下さい。(ユニークは面白いじゃなくて，唯一の…って意味です)

保存場所

プロジェクトの保存場所を設定します。この設定は，今後変更できないので注意して下さい(変更するためには，一旦プロジェクトリストから削除し，再度追加する必要があります)。デフォルトは，Culiet と同じフォルダの ProjectX.cpj となります(X には重ならない数字)。

アクティブとして追加

プロジェクトを最初からアクティブとして追加するかどうかを指定します。アイテムを追加してからアクティブにするときは，この時点ではオフにして下さい。

詳細設定

プロジェクトの詳細な設定(プロジェクトのプロパティ)を初めから設定するには，ここから行います。後でプロジェクトのプロパティで設定することもできます。


ソースアイテム追加ウィザード

ファイル/フォルダ時

新規アイテムの指定

(テキストボックス)

追加するアイテムのパスを指定します。レジストリはここでは指定できません。追加するには，[...] から参照するか，エクスプローラからドロップ，または直接記述して下さい。

追加アイテムのデフォルトプロパティ

実行タイミング

カレントアイテムの実行属性を切り替えます。[常時] は「標準」「完全」のいずれのモードで実行されてもバックアップ対象となり，[完全のみ] は「完全」モードで実行されたときだけバックアップ対象となります。[リアルタイム] はリアルタイムアイテムになり，変更が有れば直ちにバックアップされるようになります。また，完全モード時にはバックアップ対象になります。[しない] は，いずれのモードにおいても，実行されないようになります。

圧縮して保存する

アイテムを圧縮して保存します。遅いマシンだとクリティカルなほど遅くなりますが，バックアップにあまり場所をとらないようになります。履歴だけを圧縮するには，プロジェクトのプロパティで [履歴を全て圧縮] にチェックしておくと，ここの設定には影響されずに圧縮することが出来ます。なお，圧縮についてはディスティネーションサブフォルダのヘルプを参照して下さい。

サブフォルダを検索する

チェックされたアイテムは，アドレスに示されたフォルダの下にあるフォルダを検索します。ただし，サブフォルダが多いときは，検索と差分生成に非常に時間がかかるようになります。検索については，テーブル機能を併用することで，気持ち早くすることが出来ます。

同期

ソース側で消されたファイルが，ディスティネーション側で消されるかどうかを指定します。ON にすると(同期モード)消され，OFF にすると(保持モード)残されます。

テーブルを使用

テーブルを使用するかどうかを指定します。テーブルとは，特定のフォルダを検索する際に，既に検索済みのリストを使って代用する機能のことで，深い階層のフォルダなどでは処理が格段に向上することがあります。サブフォルダが少ない場合は，ほぼ速度に変化が無くなります。また，テーブルを利用すると，次回の完全モード実行まで内容が更新されませんので，その間に追加されたファイルには対応できません。

検索マスク

検索マスクを指定します。通常 *.* で全てのファイルを示しています。ここの設定は DOS のワイルドカードと同じ設定が出来，* で複数文字の代用，? で一文字の代用が出来ます。複数指定時は，スペースで区切ります。たとえば，*.doc で Word ドキュメント全て，?in.ini で Win.ini や Kin.ini などを検索対象と出来ます。複数指定時は，*.doc *.xls とすると，Word/Excel ドキュメントが対象になります。

除外マスク

除外マスクを指定します。除外マスクを指定すると，検索マスクに該当したファイルリストから，このマスクに該当するファイルを除くことができます。設定法は検索マスクのヘルプを参照して下さい。

レジストリ時

キーの名前

バックアップするレジストリキーの名前を記します。ここのキーで指定された下全てのキーが，書き出すファイル名で指定したファイルに書き出されます。キーの名前は，レジストリエディタを用いて，キーの名前をコピーコマンドでコピーするのが確実です。

書き出すファイル名

ディスティネーションの下のどこに保存するかを指定します。ですので，ここにサブフォルダを追加することが出来ます。RegBack の下に保存したい場合は，RegBack\HKCU_Software.reg の用に記述すると，Destination\RegBack\HKCU_Software.reg に書き出されます。ここの設定は，ディスティネーションサブフォルダに書き込まれます。

レジストリエディタ

レジストリエディタを起動します。インストールをしていなかったり，または権限がない場合は，この機能が利用できません。同時に，このレジストリアイテムが利用できないことも表します。


進行状況表示ダイアログ

進行状況ダイアログでは，下向きの矢印がついたボタン以外は全て状況を表示しているだけです。

タイトルバーでは，標準/完全/リアルタイム のいずれのモードで，どのプロジェクトが実行されているかが表示されます。詳細モード時には，どのアイテムを処理しているかやファイル名も含めて，現在の状況が表示されます。プログレスバーは，現在実行しているステージの処理を表していますので，プロジェクト全体の処理工程を表しているわけではありません。

下向きの矢印がついたボタンを押すと，プログレスメニューを表示します。これは，実行中に限って，タスクトレイのアイコンを左クリックすることでも表示できます。

プログレスメニュー

キャンセル

現在処理中のプロジェクト，もしくはキューにたまった全てのプロジェクトをキャンセルします。このキャンセルでは，エンジンを強制的に終了させるため，いかなる処理の途中であっても中断します。コピー中などは不完全なまま終わってしまいますので，キャンセルした後は必ず再度実行するように心がけて下さい。

詳細ダイアログ

Culiet のプロパティでの [詳細を表示をする] と同じ効果を持ちます。ただし，ここでの変更は保存されません。

表示位置変更

Culiet のプロパティでの [表示位置] と同じ効果を持ちます。ただし，ここでの変更は保存されません。

表示

Culiet のプロパティでの [実行中に進行状況を表示する] と同じ効果を持ちます。ただし，ここでの変更は保存されません。


プロジェクトを選択して実行

実行するプロジェクトの選択

実行するプロジェクトにチェックをつけて，OK を押します。ただ，[すべて] にする場合は，全てのプロジェクトを選択する必要はありません。デフォルトでは，アクティブプロジェクトがチェックされています。

すべて

全てのプロジェクトを実行します。


時刻設定ダイアログ

時刻条件の設定

日にち

自動実行する日にちを指定します。0 を指定すると毎日実行されます。これ以外では，その日だけ実行されます。

時間

自動実行する時間を指定します。秒設定は意味をなしません。また，毎時何分という実行は出来ません。これは，間隔指定を御利用になるか，1時間おきのアイテムを作って下さい。

曜日

自動実行させる曜日を指定します。最低一つは選択して下さい。

全選択/全解除

全ての曜日を選択/選択解除します。。


管理者モード

初めて開くときは，パスワードの入力を求められますので，指示に従ってパスワードを二つ入力します。次回からは，確認のためにパスワードを入力するだけで大丈夫です。

Administrator Mode (管理者モード)

管理者モードにします。全ての制限の ON/OFF は，ここで行えます。

Change Password (パスワードの変更)

パスワード変更時に選択します。

Administrator Mode Setting (管理者モード設定)

Disabled to change all Settings (設定変更を禁止)

設定の変更を禁止します。設定変更を禁止するとは，プロジェクト編集・Culiet のプロパティ等を選択できないようにすることです。完全に禁止するには，レジストリエディタを禁止し，更に Culiet.ini のファイルパーミッション等も設定変更する必要があります。

Disabled to Execute manually & Exit (手動実行と終了の禁止)

手動実行オプションを禁止し，更に管理者モードを解除しないと終了できないようにします。完全にするには，Ctrl+Alt+Delete も禁止しなくてはなりませんが，このソフトウエアではサポートしていません。また，Windows 終了時には終了するようにしています。

Disabled to stay in Task tray (タスクトレイ常駐の禁止)

Culiet が動作していることを分からないようにします。上の二つのオプションは，これを有効にすると効果が無くなります。

Admin Config Hotkey (管理者モード呼び出しホットキー)

ここに指定したキーを押すと，管理者モード画面を呼び出します。タスクトレイのアイコンを消去しているときには，必ずこの設定を覚えておかなければ，一生解除できません(^_^;)。忘れたときは，レジストリエディタで Culiet の設定を消す必要があります。

※この画面が英語になっているのは，国際版の制作を考慮してのことと，管理者専用の画面なので，ローカルユーザが敬遠するように(^^ゞ…。


用語集

このカテゴリでは，このソフトウエアで使われる専門的用語について説明しています。これらの用語について分からないことがありましたら，必ずここをご覧下さい。用語がよく分からないまま御利用いただくと，思わぬ失敗に遭遇してしまうことがあります。

ここの用語集では，PC 世界の一般用語，及び日本語については説明しません。辞書等を御利用下さい。

コンテンツ

  • 英数字(数字・A～L)
  • 英数字(M～Z)
  • あ～な
  • は～ん

※そこらでアホな記述があります。しゃれのつもりですので，見逃して下さい。


英数字(数字・A～L)

数字

2000年問題
2000年になると PC が誤作動するというホットな問題だが，このソフトウエアは日付を二桁で扱っていないため，基本的に2000年問題はない。
95 (きゅうじゅうご)
Windows 95 のこと。
98 (きゅうじゅうはち)
Windows 98 のこと。
98SE (きゅうはち えすいー)
Windows 98 Second Edition のこと。

A

Administrator Mode (あどみにすとれーた もーど)
管理者モードのこと。

C

CARK (かーく)
Culiet Administrator Resource Kit 参照。
CCC (とりぷるしー)
Culiet Control Center for Administrators のこと。登録者用の管理者向けツールで，作者のサイトで公開されている。
CII (しーだぶるあい)
Culiet Idle Indicator のこと。全ての対応 OS 上でサポートされる，Culiet におけるアイドル判定に使われる数値で，この値が落ち着いているとき(大小は関係ない)，アイドルであると思われる。ちなみに，本来はこのような目的でなく，システムがビジーなら少なくなるだろうと予想して作ってみたのであるが，なぜか挙動がそうはならずに，このような用途に向いていることが判明した。つまりは，けがの功名的存在。
CMPS (しーえむぴーえす)
Culiet Mirroring Project System のこと。ミラーリングするファイルをプロジェクト単位で管理できるシステムの総称で，このソフトウエアの中核をなす機能を示す用語。
CPU 使用率 (しーぴーゆーしようりつ)
Windows 95/98/98SE でサポートされる，Culiet におけるアイドル判定に使われる数値。パーセントで表され，CPU がどの程度仕事をしているかを表す。
Culiet (きゅりえっと)
このソフトウエアの名称。前作 Copio が「ロミオとジュリエット」のロミオを元に作った造語だったので，今回はジュリエットを元に作った造語。全く深い意味は無く，元々友人の進言から「Copio&Creatto」として復元ツール込みで Copio を制作予定であったのだが，復元機能は Copio 自身に取り込まれ，Creatto は行くところが無くなった。そこで今回採用することになった。読み方は「きゅりえっと」がお好みだが，別に「くりえっと」でもかまわない。
Culiet Administrator Resource Kit (きゅりえっと あどみにすとれーた りそーす きっと)
管理者用の技術資料集。Culiet の動作について，このヘルプでは触れられない詳細を述べてある。略して CARK と呼ばれ，作者のサイトで公開されている。

D

DLL (でぃーえるえる)
Dynamic Linking Library のこと。Windows における特殊な実行形式ファイル。このソフトウエアでは，統合アーカイバプロジェクト提供の DLL を用いて，圧縮を行うようにしている。

F

File (ふぁいる)
登録区分が「ファイル」の時にプロジェクト編集でアイテムのトップに表示される。この区分のアイテムは，単独ファイルについて更新チェックが行われる。追加したり削除したりしたファイルに対応できない。
Folder (ふぉるだ)
登録区分が「フォルダ」の時にプロジェクト編集でアイテムのトップに表示される。この区分のアイテムは，単独フォルダについて更新チェックが行われる。そのフォルダにおいて，ファイルが追加されたり削除されたりすると，それに追随させることが出来る。


英数字(H～Z)

英数字(M～Z)

K

Kernel (かーねる)
ミラーリングエンジンのこと。Culiet においては，カーネルと本体とを分離し，別プロセスで動作するようになっている。これにより，より安定性を高めることが出来るなどの利点があると，作者は思っている。clmiren.exe として提供されている。ちなみに，カーネルサンダースや kernel32.dll とは無関係。

R

Registry (れじすとり)
登録区分が「レジストリ」の時にプロジェクト編集でアイテムのトップに表示される。この区分のアイテムは，レジストリエディタを使って指定したキー以下をファイルに書き出す。これにより，より汎用的な復元が可能となる。ただし，レジストリを使用できる権限がなければならない。
RMS (あーるえむえす)
Removable Media Storage (リムーバブルメディア)のこと。FD/MO/CD-R/DVD-RAM 等の抜き差し可能なメディアのことで，このソフトウエアではこれらのために動作前にボリュームラベルをチェックさせることが出来るようになっている。

W

Win9x (ういん きゅうえっくす)
Windows 9x ともかかれている。Windows 95，Windows 98，Windows 98 Second Edition を指す総称。対して，WinNT とかかれている場合は，Windows NT 4.0 や Windows 2000 を指す。
Windows 95 (ういんどうず きゅうじゅうご)
某 Microsoft 社が開発した OS。作者は Preview Program を入手した覚えがある。3.1 からは良くなっていたが，今ではといとい。NT お勧め。ちなみに，この OS での動作は確認できないため，保証されない。
Windows 98 (ういんどうず きゅうじゅうはち)
某 Microsoft 社が開発した OS。95より良くはなっているが，リソースが足りないと言う弱点は残ったまま。やっぱし NT を進める(笑)。動作は確認されているが，今後は SE での確認のみとなる。
Windows 98 Second Edition (ういんどうず きゅうじゅうはち せかんどえでぃしょん)
某 Microsoft 社が開発した OS。名前そのまま，第2版の Windows 98。中身は良くなっているようだが，逆に互換性に問題がある様子。しかし，それはハードウエア的問題であり，このソフトウエアには問題にならないはずである。98SE とも書いている。
Windows NT 4.0 (ういんどうず えぬてぃー)
某 Microsoft 社が開発した OS。作者はメインマシンで愛用している。安定性も高く，開発にはもってこいだが，いかんせんゲームができん(笑)。動くソフトも多いが，動かないものは全く動かない。W2K でなんとかなるだろう。
Windows 2000 (ういんどうず にせん)
某 Microsoft 社が開発中の OS。作者は Beta 3 を入手し，Beta 3 上で開発を続けた。ゲームも動作し，快適である。Win2K と略していることがある。
Win2K (だぶるつーけー)
Windows 2000 のこと。

Y

Y2K (わいつーけー)
Year 2000 Problem のこと。いわゆる2000年問題。このソフトウエアは，日付を二桁で扱っていないため，基本的に2000年問題はない。


用語集(あ～な)

あ～な

あ

アイテム
最小のバックアップ単位。ファイル・フォルダ・レジストリの内から1種類をとり，アドレスを一つだけ持つ。アイテムを複数まとめたのがプロジェクトである。
アイドル
暇な状態のこと。この Culiet では，CII と呼ばれる数値が落ち着いているときにアイドル状態と見なす。また，カーネルのプライオリティでは，アイドル時に実行属性をつけてプロセスを実行させる。
アクティブ
活動している状態。
アクティブプロジェクト
活動しているプロジェクト=自動実行対象になっているプロジェクトを表す。本ソフトウエアでは，アクティブプロジェクトだけが自動実行の対象となり，どう設定していてもアクティブでないプロジェクトは，手動で実行しなければならない。
圧縮
ファイルのサイズを小さくすること。理論的には本当に重石を載せて小さくするわけではなく，同じデータが重なってでてくる場合にそれを有効に利用することで小さくしたように見せかける。本ソフトウエアでは，統合アーカイバプロジェクト [image] にて提供されている DLL (外部のライブラリ)を用い，バックアップするファイルを圧縮しておくことが出来る。
アドレス
場所。ファイルまたはフォルダの場合はフルパスを，レジストリの場合はキーの名前を表す。これらを総括して，本ソフトウエアではアドレスと読んでいる。

か

カーネル
ミラーリングエンジンのこと。Culiet においては，カーネルと本体とを分離し，別プロセスで動作するようになっている。これにより，より安定性を高めることが出来るなどの利点があると，作者は思っている。clmiren.exe として提供されている。ちなみに，カーネルサンダースや kernel32.dll とは無関係。
カレント
現在の～という意味。カレントアイテムで現在選択したり編集しているアイテムという意味。
完全
ちゃんとしていること。このソフトウエアでは，バックアップモードが3種類有り，その内の一つ。完全では，他の二つのモードを包括している上に，テーブルの更新，履歴の増加といった処理も行われる。
キュー
全能の生命体(マニアック…)。並んで待つ列を表し，入れていった順番にでてくる処理機構(FIFO=First In First Out)のこと。本ソフトウエアでは，複数のプロジェクトに同時に実行指令が来た場合は一旦キューに蓄えられて，前のプロジェクトが完了後に実行される。

さ

サブフォルダ
特定のフォルダより下にあるフォルダのこと。たとえば，Windows フォルダのサブフォルダの一つに，System フォルダがある。
シェアウエア
所定のライセンスフィーを支払って初めてソフトウエアの使用権を得るソフトウエアのこと。当ソフトウエアは，シェアウエアである。
実行タイミング
特定のアイテムが，いつ実行されるかを示しているものである。プロジェクトの動作モードは3種類有り，それに併せて4種類のタイミングが用意されている(「しない」が増えるから4)。
ソース
英語で源を表し，このソフトウエアではバックアップ元のことを言っている。なぜわかりにくい英語にしたかというと，バックアップ元とバックアップ先と呼ぶと，一文字しか変わらないので混同しやすいからである。

た

タイムスタンプ
ファイルが最後に保存された時刻のことで，これを元に本ソフトウエアではバックアップをすべきファイルを決定している。
ディスティネーション
英語で目的地を表し，このソフトウエアではバックアップ先のことを言っている。なぜわかりにくい英語にしたかというと，バックアップ元とバックアップ先と呼ぶと，一文字しか変わらないので混同しやすいからである。
ディスティネーションサブフォルダ
ディスティネーションの下のどこに保存するかを示したもの。相対パスを記せばよい。
テーブル
本ソフトウエアでは表を表し，時間のかかる検索を少しでも早めるための機能。あらかじめ検索しておいた表を参照し，ファイルの検索処理を省略することが出来るが，ファイルが追加されても対応できない。このために更新が必要で，これは完全モード時に行われる。
同期
ソースとディスティネーションを完全に一致させること。こういうのを本当のミラーリングというのであろう。同期とは言うが，リアルタイムと組み合わせない限り，常に一致しているわけではない。
トリガ
引き金。といっても，弾はでてこない。自動実行に至る引き金のことを表す。


用語集(は～ん)

は～ん

は

ボリュームラベル
ドライブ毎につけられた任意の識別可能な文字列。エクスプローラなら，ドライブの名前として表示されているはずである。変更も可能で，ドライブの上で右クリックして [プロパティ] を選択すればいい。
標準
バックアップモード3種類の内の一つで，通常はこのモードで実行される。このモードでは，常時実行するアイテムだけがバックアップされ，テーブル機能使用時はテーブルを参照する。
プライオリティ
優先度。作者は非常にこの単語の音感が好きである。Windows においては，CPU を分配するときにどう分配されるのかを決定する。本ソフトウエアでは，カーネルのプライオリティだけをいじることが出来る。通常はアイドルでの利用をお勧めする。
プロジェクト
バックアップするために必要な全ての条件を備えた単位で，プロジェクトには複数のアイテムが含まれている。また，プロジェクトが多数集まってプロジェクトリストとなる。
プロジェクトリスト
プロジェクトを集めて管理する場所。実際にはこれは，Culiet のプロパティとして実装されている。
プロパティ
属性。アイテムやプロジェクト，Culiet 全体においての設定を表す。ラテン語の「自分自身のもの」から来ている英語らしい。これまた非常に音が良い。
ペイン
痛みではない。部分のことで，エクスプローラの左ペインはツリービュー，左ペインはリストビューという感じ(逆にわかりにくいか…)。
保持
ソース側で消されても，ディスティネーション側で残しておくこと。完全にソースが消えたとき入らないファイルを復元してしまうが，昔のファイルも残しておきたいときは有用。

ま

マスク
仮面。つけると人が変わる(「誰にも止められないぜ」)。特定のフォルダに対して，条件に合うファイルを探し出すためのもの。ワイルドカード(?及び*)を用いることが出来る。? は一文字の代用，* は複数文字の代用を表す。
ミラーリング
鏡のように同一にすること。前作 Copio では「常駐型ミラーリングバックアップソフトウエア」と名乗っていましたが，どうも意味があまり正しくないので，今回は特にこの言葉を強調していません。

ら

ライセンス
許可・免許と言った意味で，本ソフトウエアを使用する正式な権利のことを表す。使用権であって，所有権ではない。本ソフトウエアはシェアウエアであり，ライセンスを取得するには，その対価であるライセンスフィーを支払う必要がある。
リアルタイム
電算機世界の専門用語で，入力されたデータの処理がほぼ瞬時に行なわれること。本ソフトウエアでは，ファイルまたはフォルダが変更後直ぐにバックアップ作業を行うことを表している。
履歴
変更される前のファイルを保存すること。本ソフトウエアでは履歴を完全モード実行時に残すようになっている。


シェアウエア登録

このカテゴリでは，シェアウエアの制限・登録・登録に当たっての注意などをご紹介しています。シェアウエアに登録される方も，またそうでない方も，ここのカテゴリのご確認をお願いします。

冒頭にもありますが，この Culiet は，ゾーンAのシェアウエアとなっています。まだ未登録の方は，是非ご登録願います。詳細は，以下のコンテンツをご覧下さい。

コンテンツ

  • 未登録時の制限
  • 送金前の注意
  • 実際の送金について
  • 登録認証キーの再発行


未登録時の制限について

制限範囲内での利用について

このソフトウエアの元となった Copio が完全とはいえなかった点を考慮して，Copio 相当の機能は，未登録時でも制限無く御利用いただけます。これにより，特に試用期間はありません。より高い機能を利用されたくなったときに，ご登録下さい。

制限される機能

以下の機能は，未登録時に制限されます。もちろん，登録後には全て利用できるようになります。

  • 複数プロジェクトでの運用
    - 初回起動時に作成したプロジェクトのみ，実行動作に移ります
  • リアルタイムバックアップ
    - 実行を開始しますが，何もしません
  • 圧縮機能の利用
    - 動いているように見えますが，コピーされません
  • 指定時間・アイドル時に実行機能
    - トリガとして動作しません
  • 実行前のボリュームの確認/削除時の確認
    - 設定して確認されません
  • 管理者モード (*1)
    - 設定しても，動作しません
  • 今後追加される全ての新機能

(*1) この機能は，パーソナルライセンス契約においても使えません。

なお，以上の制限は，全て特に制限があるという旨が表示されません(ログに記録されるものはあります)。これらはいずれも設定可能ですが，変な動作をしたり動作しないために，一見不具合に見えるかもしれません。これはもちろん仕様ですので，サポートでお答えできません。また，ミッションクリティカルな場面でお使いの場合は，この制限を十分に注意する必要があります。


送金前の注意

送金前にご確認戴きたい項目について，説明しています。

信頼性の確保

このヘルプにある通りの手順にそっていただければ，登録することが出来ます。しかし，その前に添付の PGP による署名ファイルをご確認願います。万が一，このオンラインヘルプが改竄されている場合，この署名ファイルが不整合を示します。もし不整合である場合，もしくは署名ファイル自身が付属しない場合は，信頼できるところから再度ファイルを入手して下さい。万が一，これら情報の信頼性を確認せずに振り込まれた場合などの全てのトラブルについて，作者は一切の責任を負いません。

なお，PGP 公開鍵は，作者の Web サイトからダウンロードできます。PGP による身元証明 [image] からダウンロードして下さい。

PGP をお持ちでない方は，本体のバージョン情報をご覧下さい。銀行口座番号・シェアレジ番号等のみ記しております。

一般的な注意点

  • シェアウエアへの送金とは， 開発資金の一部をシェアする目的で，作者に対して指定された金額を支払い，その対価としてソフトウエアの正式な使用権(所有権・独占権ではない)を取得するシステムを表します。
  • 送金されたお金は，いかなる事情があっても返却致しません
  • 送金されたからといって，特別な差別化をして優遇したりは致しません。ただし，サポートについては少しだけ優遇処置があります。詳細は，サポートをご覧下さい
  • 先に寄付いただいた場合でも，それを持ってシェアウエア登録料扱いをすることは，手続きの問題上出来ません(ですが，直接お問い合わせ下されば，適宜応じることもあります)
  • 所定の方法や手続きを守られなかった場合は，寄付金扱いになります。また，そうなってしまった場合でも，特にその旨は連絡しません
  • ライセンス契約条項(ゾーンA)を必ずご一読下さい


実際の送金について

ここでは，実際の送金をどうすればいいのかを示します。ここの項目に従う前に，必ず送金前の注意をご確認願います。

送金する金額

作者へライセンス取得のための最低限の金額を以下に示しています。しかし，更に追加していただいてもかまいません(寄付として認識させていただきます)。

パーソナルライセンス契約

個人で御利用の方向けのライセンス契約です。家庭利用(非商用利用)が前提です。この契約では，「管理者モード機能」は御利用になれません。

1ライセンス当たり：
\1,500- (手数料込み)

この契約では，1ライセンス当たり同一ユーザが同時に最大2台まで御利用になれます。詳細は，ライセンス契約条項(ゾーンA)で記しています。

手数料とは，消費税を除く振り込み・支払いにかかる費用のことです。銀行振り込みの場合は，同一銀行時には手数料300円(税別)とられますので，この場合は 1,200円 を振り込みます。シェアレジでは，最初から引いてあります。

詳細な手続きは，銀行振り込みの手順 または シェアレジ送金の手順 を参照して下さい。

コーポレイトライセンス契約

仕事での利用(SOHO 以上で一般の会社での利用も含む)や，企業等で大量導入される方向けのライセンス契約です。この契約では，団体・法人・個人毎に一つの契約とします。

1ライセンス当たり：
\2,500- (手数料別)
5ライセンスパック：
\10,000- (手数料別)

<例>
3ライセンス=7,500円 (1ライセンスx3)
15ライセンス=30,000円 (5ライセンスx3)
23ライセンス=47,500円 (5ライセンスx4+1ライセンスx3)

このライセンスでは，1ライセンス当たり同時に最大1台のみで御利用になれます。ただし，異なるユーザが使ってもOKです(パーソナルライセンスでは禁止)。詳細は，ライセンス契約条項(ゾーンA)で記しています。

詳細な手続きは，銀行振り込みの手順 または シェアレジ送金の手順 を参照して下さい。

※企業などで，「領収書」を発行して欲しい場合は，別途手数料150円でお受けします(希望の宛先までの郵送料を含む)。必要な場合は銀行振り込みのみで対応します(シェアレジではこの料金を送金できないため，発行できませんが，別途銀行に150円振り込んでくださってもかまいません)。銀行振り込み時に料金を追加の上，こちらにマシンキーを通知する際に必要だということを明記して下さい。なお，これらの書類は，パーソナルライセンスでは提供しません。


銀行振り込みの手順

送金の流れ

銀行振り込みでの送金の流れは，次のようになっています。

  1. 銀行に指定された金額を振り込む
  2. 電子メールか往復はがきで「マシンキー」を作者に知らせる
  3. 入金確認後，作者から「登録認証キー」が返信される
  4. バージョン情報でその内容を入力する

以上で完了します。この手順にそって，以下で説明します。

1.振り込み

以下の口座に，実際の送金についてで示された金額を振り込んで下さい。その前に，念のため送金前の注意をご確認下さい。

また，パーソナルライセンス契約では，手数料(消費税は含めない)を引いてからお支払い下さい。手数料については，各銀行の窓口でご確認下さい。たとえば，同一銀行なら 300円 のはずなので，1500-300 で 1200円 を振り込んで下さい。実際には 300円 に消費税がかかるので，1200+300+15=1515円 かかります。面倒な方は，適当に端数を上乗せしてくださって構いません。

コーポレイトライセンス契約で，書類を発行して欲しい場合は，300円を追加してください。詳細は実際の送金についての最後に示しています。

三和銀行 豊中支店
店番 221
口座番号 (普) 5062610

名義 竹内 亨(たけうち すすむ)

2.作者に送金の通知

このソフトウエアでは，シェアウエア登録制限を外すための「登録認証キー」が，マシンによって異なるシステムを採用しています。このため，個別に「登録認証キー」を送らせていただく必要があるため，必ず「マシンキー」をこちらに送っていただく必要があります。以下のいずれかの手順でお願いします。

電子メールでの手順

Web からメールが送信できる環境の方は，送金完了の通知 [image] から送信して下さい。もし御利用になれない場合でも，以下のフォームに従って送信していただければ，同じように素早く対応することが出来ます。

件名(サブジェクト)は，「Notice of Remittance」
本文は，次の通りでお願いします。なお，データは私の例です。なお，()で囲まれた部分は消してください。

::NAME::
竹内 亨
::ADDRESS::
sutak@osaka.dddd.ne.jp
::ZONE::
ZONE A
::LICENCE::
Personal (またはCorporateと書く)
(通常空行; コーポレイトライセンス時で追加する場合は，Addition と書く)
::MOUNT::
1 (ライセンス数を書く。コーポレイトのパック1つでは，5と書く)
::MONEY::
1500 (実際に送金した金額)
::MACHINE::
9100-7890-0DFF (バージョン情報で表示されるマシンキー; 複数指定時は，改行して追加していく)
::SENDTIME::
1999/09/01 13:00 (このままの形式で，送金した日時を記す)

このフォームに従わなくてもかまいませんが，対応が遅れることがあります。ご了承願います。

往復はがきでの手順

往復はがき(必ず返信宛名を記入済みのこと)にて，以下の項目をお知らせ下さい。ただし，コーポレイトライセンス契約の時は，出来るだけメールでお願いします(数が多いと大変です…お互い)。

  • 貴方のお名前(本名でお願いします)
  • 電子メールのアドレス または 住所
  • 送金するソフトウエアのゾーン
  • 送金いただいた日と時間
  • マシンキー(バージョン情報で確認できます)

〒564-0062
吹田市垂水町2丁目12-17

竹内 亨 (送金完了の通知) 宛

3.作者からの返答

いずれかの方法でご連絡いただいた後，こちらで送金いただいたお名前と日付等を元に入金確認を行い，確認後に登録認証キーを送ります。確認には，最低でも数日，こちらに余裕がないときは最大3週間ぐらいかかることもあります。なお，以上の項目に記入漏れがあるときは，「寄付扱い」になってしまいます。ご注意下さい。


シェアレジ送金の手順

送金の流れ

シェアレジ送金での送金の流れは，次のようになっています。

  1. Vector のシェアレジサイトへ行く
  2. 送金者情報を記入し，申し込む (ここでマシンキーを記入する必要があります)
  3. しばらく待つ (通常，一両日以内です)
  4. クレジットカードで自動的に引き落とし
  5. 引き落とし完了後，直ぐに登録認証キーが Vector から送られてくる

以上で完了します。この手順は，最初だけ分かれば，後は指示どおり行えばOKなので，最初だけ記します。

手順について

送金するライセンスをご確認下さい。三つありますので，間違わないようにしてください。

パーソナルライセンス契約

以下のリンクを開き，[ヘルプ]-[バージョン情報] で表示されるマシンキーや，その他貴方の情報を入力します。パーソナルライセンスでは，手数料込みのため，1400円となっています(シェアレジ利用料が100円+税金が別途請求されます)。

パーソナルライセンス契約の申し込み

コーポレイトライセンス契約

ライセンス数に応じて，次のいずれか，または組み合わせてお支払い下さい。(大量にあるときは，シェアレジでは支払いにくいので，銀行振り込みをお勧めします。) この際には，[ヘルプ]-[バージョン情報] で表示されるマシンキーや，その他貴方の情報を入力します。

コーポレイトライセンス契約「1ライセンス分」の申し込み

コーポレイトライセンス契約「5ライセンスパック」の申し込み


登録認証キーの再発行

登録認証キーの再発行の手順について説明しています。その前に，ライセンス契約条項(ゾーンA)をご覧の上，直ぐに再発行してもらえる状態か，確認をして下さい。

電子メールまたは往復はがきで受け付けております。

シェアレジで送金された方へ

シェアレジで送金された場合は，マシンキーが変わっていない間は Vector からお取り寄せ下さい。マシンキーが変わってからは，こちらの手順に従ってください。

電子メールでの手順

Web からメールが送信できる環境の方は，登録認証キー再発行フォーム [image] から送信して下さい。

もし御利用になれない場合は，以下のフォームに従って送信していただければ，同じように素早く対応することが出来ます。

件名(サブジェクト)は，「Reissue Certification Key」
本文は，次の通りでお願いします。括弧部分は消去して下さい。

::LICENCENO::
(ライセンス番号)
::ADDRESS::
(電子メールアドレス)
::ZONE::
ZONE A (Culiet etc)
::MACHINE::
(新規マシンキー)
::DESTRUCTION::
(破棄する登録認証キー。紛失時には紛失したという旨を記してください)

このフォームに従わなくてもかまいませんが，対応が遅れることがあります。ご了承願います。

往復はがきでの手順

往復はがきに返信宛名を記入の上，以下の項目をお書き添えの上，次の住所までお送り下さい。

  • ライセンス許諾番号
  • 登録された 貴方のお名前
  • 破棄する登録認証キー(紛失時はその旨を記してください)
  • 登録された 電子メールアドレス または 住所

〒564-0062
吹田市垂水町2丁目12-17

竹内 亨 (登録認証キーの再発行) 宛


利用規程

このカテゴリでは，利用規程について記しています。このソフトウエアを利用した時点で，全ての項目に同意されたものと見なされます。同意できない場合は，即刻消去して下さい(それまでに頒布したファイルも，全て消去して下さい)。

コンテンツ

  • 著作権
  • 転載・再配布
  • 免責
  • ライセンス契約条項(ゾーンA)


著作権

著作権について

このソフトウエア，並びに付属する全てのファイルは，以下のものを除き，全て G.ib (竹内 亨) が著作権を保持しています。

  • Culiet のアイコン - むねゴン氏＆G.ib 作

不正行為の禁止

このソフトウエアは日本国著作権法並びに国際条約に保護されています。この著作権の元，このソフトウエアに対するいかなる不正行為も許されません。たとえば，逆コンパイルやデバッガツールによるシリアルナンバーのクラッキングなど，これらに限られず，このソフトウエアをマニュアルにそって利用する行為から逸脱した行為全てを含みます。

また，転載・再配布時に書庫を改竄して公開することは，禁止します。必ず信頼できるサイトから入手したファイルそのままで公開して下さい。


転載・再配布

警告

このソフトウエアを転載・再配布をされるときは，絶対に書庫の内容に手を加えてはいけません。付属するファイルを減らしたり，このヘルプファイルを改竄したりすることは，全て禁止されます。もしも不備がありましたら，作者までご連絡下さい。

非商用利用時の転載

非商用利用の場合は，転載・再配布共に，原則的に許可は不要です。ただし，作者としてはその現状を把握したいので，事前事後のいずれでもかまいませんので，転載の事実をお知らせいただければ助かります。お知らせいただける場合は，メールでお願いします。

商用利用時の転載・再配布

商用利用の場合は，転載・再配布共に事前許可が必要です。また，雑誌・書籍掲載などでは，ソフトウエア自体を記憶媒体に付属する如何に関わらず，当該雑誌か同等の対価を作者までに支払うことを要求いたします。万が一，事前許可をお忘れになった事が発覚した場合は，当該雑誌とそれの2倍の対価を作者に支払っていただきます。許可については，メールでお願いします。


免責

利用時の免責

このソフトウエアに関しての不具合や誤動作によって，利用者・提供者・及び周辺の人，もしくはそれらから間接的な人やものに損害が加わったとしても，作者は一切の責任を負いません。

欠陥の免責

このソフトウエアになんらかの欠陥があり，なおかつそれを作者が認識していたとしても，改善する義務は作者にはありません。このソフトウエアは，開発された現状のまま公開されるものであり，その全ての動作に何らかの保証があるあけではありません。これは，シェアウエア登録の如何に関わりません。


ライセンス契約条項(ゾーンA)

ライセンス契約条項
(ゾーンA)

ここでは，ゾーンAのライセンスの中身について詳しく記します。以下のことにご同意いただけない場合は，送金をおやめ下さい。この条項は，シェアウエア登録された方全てに適用されます。

条項施行日: 1999/11/01
※条項は，予告無く変更されることがあります

共通の条項

送金していただく目的

送金していただく目的は，このソフトウエアに対する正式なライセンスの取得にあります。正式なライセンスを取得すると，制限されているほぼ全ての機能が御利用になれます(御利用にはなれますが，その動作については，免責にある通り保証されません)。また，送金いただいたお金は，開発資材・資料等への資金として廻されます。

送金時の問題

送金時・送金後に，このヘルプに記載されている全ての項目を守られていても，予想外のトラブルに遭遇することが考えられます。これら全てのトラブルに関して，作者は一切の責任を負いません。所定の手続きに従わなかったときは，その支払いは無効化されます。また，このヘルプファイルの信頼性などの確認には，所定の方法をお使い下さい。

同一ゾーンの使用権

このソフトウエアは，ゾーンAのシェアウエアです。同一のゾーンAに属する拙作ソフトウエアは，同じ登録認証キーで御利用になれます。つまり，ゾーンAのシェアウエアは全て，ライセンスを取得することが出来ます。当ソフトウエアの将来のバージョンにおいても，同一ゾーンである限り，新たにライセンスを取得することなく御利用になれます。

ゾーン移行に対する継承権

このソフトウエアに送金していただくと，このソフトウエアが今後ゾーンを移動することがあっても(ライセンス料の値上げ等)，そのまま移った先のゾーンの使用権を保持することが出来ます(アップグレード料金が必要な場合もあります)。これにより移行した新ゾーン，及び移行前のゾーン全てのソフトウエアの使用権も取得することが出来ます。(ただし，コーポレイトライセンス契約時は，追加ライセンスの金額は新ゾーンの規定に従うことになります。)

契約毎の条項

このほかの項目は，契約方法により条項が変わります。以下の項目を参照して下さい。

  • パーソナルライセンス契約
  • コーポレイトライセンス契約


パーソナルライセンス契約

ここでは，ゾーンAのパーソナルライセンスについて詳しく記します。まず，共通のライセンス事項をライセンス契約条項(ゾーンA)でご確認の上，以下をご一読下さい。また，これらにご同意いただけない場合は，送金をおやめ下さい。

パーソナルの規定

パーソナルライセンス契約は，非商用利用つまり家庭での利用の場合のみ，利用することが出来ます。SOHO でお使いの場合，会社で御利用の場合など，その利用している PC 自体が収入を得るような作業を行っている場合は，家庭利用とは見なされません。コーポレイトライセンス契約を御利用下さい。

ライセンスの条項

ライセンス取得後の制限

ライセンスを許諾されたユーザは，1ライセンス当たり最大2台までのPCで同時に使うことが出来ます。また，単一ユーザの方のみが御利用になれます。同一PCであっても，複数の方が利用される場合は，コーポレイトライセンス契約を御利用下さい。

Culiet におけるほぼ全ての機能が御利用いただけるようになりますが，「管理者制限機能」のみ御利用になれません。この機能を必要とされない方向けの契約ですので，ご了承願います。

登録認証キーの再発行

このソフトウエアでは，マシン毎に違うマシンキーを示し，登録認証キーもまたマシン毎に違うシステムとなっています。このため，いくらかのユーザの方は登録認証キーの再発行が必要になります。この際の手続きには，若干制限がありますのでご注意下さい。制限を設けているのは，ホイホイと再発行をしてしまうと，認証キーの意味が無くなってしまうからです。

まず，ライセンス許諾開始時に限り，同時に最大2つまでのマシンキーから登録認証キーを発行します。これ以後再発行をして欲しい場合は，古い登録認証キーを送付して戴くことになります。この際，古い登録認証キーが発行後1ヶ月経っていない場合は，経過するまで発行はストップします(つまり，一度発行した登録認証キーは，1ヶ月の間再発行しません)。

このシステムでは仕事にならない方(たとえば某スタパさんみたいに頻繁にマシンを買い換える方)は，別途お申し出ていただければこの範囲を逸脱することも可能です。ただし，ちゃんとした身分証明と理由説明を行っていただきます。

# よく考えると，某スタパさんは仕事ですので，こちらのライセンス契約は出来ません。

再発行の手順は，登録認証キーの再発行をご確認下さい。


コマーシャルライセンス契約

コーポレイトライセンス契約

ここでは，ゾーンAのコーポレイトライセンスの中身について詳しく記します。以下のことにご同意いただけない場合は，送金をおやめ下さい。

コーポレイトの規定

コーポレイトライセンス契約は，基本的に組織的利用の場合に利用することが出来ます。ただし，家庭で利用するにあたっても，SOHO など業務で利用される場合は，コーポレイト契約のみと致します。

コーポレイトライセンス契約

ライセンス取得後の制限

ライセンスを許諾されたユーザは，1ライセンス当たり最大1台までのPCで同時に使うことが出来ます。同一PCであれば，複数の方が利用されてもかまいません。

Culiet における全ての機能が御利用いただけるようになります。「管理者制限機能」も御利用いただけます。

ライセンスの追加

コーポレイトライセンス契約では，後々ライセンスを追加することが出来ます。その際には，元のライセンス許諾番号をお知らせの上，所定の金額(既に取得済みのライセンスも数に入れますので，たとえば既に50ライセンス取得していて1ライセンス追加するときは，1,500円となります)をお振り込み下さい。手順は同じですが，必ずライセンスの追加である旨を記して下さい。

登録認証キーの再発行

このソフトウエアでは，マシン毎に違うマシンキーを示し，登録認証キーもまたマシン毎に違うシステムとなっています。このため，いくらかのユーザの方は登録認証キーの再発行が必要になります。この際の手続きには，若干制限がありますのでご注意下さい。制限があるのは，ホイホイと再発行をしてしまうと，認証キーの意味が無くなってしまうからです。

まず，ライセンス許諾開始時に限り，同時に最大2つまでのマシンキーから登録認証キーを発行します。これ以後再発行をして欲しい場合は，古い登録認証キーを送付して戴くことになります。この際，古い登録認証キーが発行後1ヶ月経っていない場合は，経過するまで発行はストップします(つまり，一度発行した登録認証キーは，1ヶ月の間再発行しません)。

企業ではそう頻繁にマシンが入れ替わることはないという理由から，パーソナルライセンスのようにそのような環境を考慮しません。

再発行の手順は，登録認証キーの再発行をご確認下さい。


サポート

このカテゴリでは，このソフトウエアのサポートについて記しています。私へ直接サポートをご依頼される場合は，必ずこのカテゴリをご確認願います。ここの項目を確認せずにご依頼になったサポートは，予告無く標準的対応をとることがあります(標準的対応とは，以下のコンテンツで説明しています)。

コンテンツ

  • サポートシステムについて(必読)
  • Frequently Asked Questions


サポートシステムについて(必読)

サポートシステムについて

当方のサポートシステムは，他と少々異なります。必ず把握してからご依頼下さい。

まず，手順は次のようになっています。

  1. サポート依頼メールを作者へ送る
  2. 返答をメールマガジン(NMI)でまとめて送信する

このシステムになった理由は，同じ質問が多いこと，同じ疑問を持ったユーザの方にも返答を得るチャンスが増えるということによります。

ただ，これにより返答が最大15日程度送れてしまいます(メールマガジンは通常半月に1回送信するため)。これについては，緊急性の高い話題は速急に発行することにより対応します。緊急性が低い場合は，お待ちいただくようお願いします。

サポート依頼方法

サポートへの依頼は，Culiet サポート依頼 [image] でのみ受け付けています。メールでしか送信できない環境の方は，このサイトを確認して下さい。手順を最初に記しています。

サポートへの返答

サポートへの返答は，原則的には直接行いませんが，シェアウエア登録者＆寄付提供者に限り，ご希望なら直接返事します。前記フォームで「直ぐに直接返事して欲しい」にチェックされている場合に限られます。

それ以外，またその場合も含めて，ご質問への返答は以下のメールマガジンにて送信させていただきます。

メールマガジンについて

サポートメールマガジンは，NMI (Nexus Mail Information) と呼ばれ，最低半月に一回程度，登録された方に対してメールで配信されます。このメールマガジンでは，サポートに対しての返事を含め，バージョンアップや新製品公開等の情報をお知らせしています。登録や登録解除は，USERS' SITE [image] にて行えるようになっています。

このメールマガジンに登録されていない方には，このシステムではサポートの返事が受け取れないことになります。万が一何らかの理由で NMI に登録することが出来ない方は，同様の返答を Web にて FAQ として掲載しておりますので，そちらを参照して下さい。ただし，通常かなり遅れて更新されますので，ご了承下さい(最低でも半月，長いと数ヶ月…)。


Frequently Asked Questions

この Culiet に対する FAQ です。最新版は，Culiet の FAQ [image] にて公開しています。併せて確認して下さい。

Questions & Answers

履歴1のフォルダに入るファイルは，1世代前のファイルではないのか？

履歴1には，最新のものが最新の世代として残されます。このため，1世代前ではなく1世代目ということになります。なぜこうなっているかというと，履歴をディスティネーションと異なるところへバックアップしているからです。同じ場所なら簡単に名前を変えるだけで古い世代にすることが出来ますが，異なる場所に保存するときはそうはいきません。(両方が同じ場所だと復元するのが大変になりますので，別の場所になるようにしています。)よって仕様です。

Outlook の PST ファイルがバックアップされない

Microsoft Outlook は PST ファイルを占有して開きます。このため，Outlook 起動中は Culiet に関わらず，エクスプローラを通してもコピーできなくなっています。これは Outlook が一種の DBMS となっているからで，当然のことです(他からデータの書き換えがあったら，データベースとしてデータを保護できなくなります)。Outlook を終了してから実行してください。

バージョンをアップすると，マシンキーが変わってしまったが，同じ登録認証キーで使えるのか？

マシンキーの最初の4文字は，ゾーンやバージョンごとに変化するソフト ID となっています。これは登録時にはもちろん必要ですが，以後この部分が変わっても，登録認証キーを再発行する必要はありません。ただ，後ろの8桁はマシン固有であり，これが変更された場合には(具体的にはマシンを交換したとか)，登録認証キーを再発行する必要があります。詳細はオンラインヘルプをご覧下さい。

動作がおかしかったり，動作しない機能がある

シェアウエア登録されていない段階で，未登録時の制限についてに示されている機能をお使いの場合は，このような変な現象が起こります。これらの機能を御利用になる場合は，シェアウエア登録をしてください。また，払うのはイヤだという方は，これらの機能を使わないようにすれば，問題なく御利用になれます。

圧縮フォーマットを変更するには？

圧縮フォーマットは，現在 LHA/ZIP のみサポートされています。これは，書庫に対するファイルの追加・削除が行える DLL がこの二つだけだからです。詳細は，オンラインヘルプの [スターティングガイド]-[バックアップの準備]-[圧縮を行うためには？] を参照して下さい。

更にフォーマットを変更するには，ディスティネーションサブフォルダに書庫ファイル名を指定します。その際に拡張子を希望のフォーマットにすることで，そのフォーマットで圧縮されるようになります。たとえば，Windows とディスティネーションサブフォルダに指定していると，Culiet.lzh に保存されます。Windows\Other.zip と指定すると，Other.zip に ZIP 形式で保存されるようになります。詳細は，ディスティネーションサブフォルダのヘルプを参照して下さい。

エンジンが死んだようで，初期化状態から反応が全くない

エンジンが死んでしまった場合は，キャンセルしてください。その上で，再度実行して下さい。これでもまだ動作しない場合は，作者のサイトから最新版を入手して再度試してみて下さい。これでもダメな場合は，動作しないプロジェクトファイルと共に，作者までご連絡下さい。


Culiet の情報

このカテゴリでは，このソフトウエアの更新履歴や，CARK (Culiet Administrator Resource Kit) を掲載します。CARK では，管理者向けの Culiet の情報が掲載されています。作者のサイトの Culiet ダウンロードページまでお越し下さい。

コンテンツ

  • 更新履歴
  • 開発秘話
  • CARK (*1)

(*1) 同じフォルダにおくと，自動的に目次欄に表示されます。入手後は，目次欄の方からアクセスして下さい。


更新履歴

第1世代

第1世代の履歴を表示/非表示

Ver.1.03 (1999/11/03)

  • 大量のファイルが含まれるフォルダを圧縮するとエラーが出る不具合を修正しました
  • プロジェクト編集のプロジェクトリストにて，一番最初のアイテムのチェックを切り替えると，まれに領域外を参照する不具合を修正しました

Ver.1.02 (1999/11/01)

  • 圧縮指定のアイテムで，更新されたファイルが反映されない不具合を修正しました
  • 異なるフォルダアイテムで同じディスティネーションサブフォルダに設定した場合，自動的に連番を振っていましたが，ユーザに設定のし直しを要求するようにしました
  • 進行状況ダイアログで，パスの圧縮に Internet 用 API を使うようにしました
  • シェアレジ対応・利用規程の修正等，ヘルプを編集しました

Ver.1.01 (1999/10/20)

  • 上書き禁止属性のついたファイルが更新されない(アクセスが拒否される)不具合を修正しました
  • プロジェクト編集でアイテムを選択していなくても「アクセス」が見えていた不具合を修正しました
  • プロジェクト編集でアイテムのコピーをすると，デバッグ用のメッセージが表示される不具合を修正しました
  • プロジェクト編集から，[プロジェクトを選択して実行] が呼び出せるようになりました
  • 自動実行の設定に応じて，タスクトレイのアイコンを切り替えるようにしました
  • エンジン再利用時の問題を修正しました
  • ヘルプの誤字脱字を修正しました
  • 管理者向けのツール，CARK/CCC を用意しました

Ver.1.00 (1999/10/14)

初めての正式版。

  • 管理者モードで終了を制限していると，Windows 終了が出来ない問題を修正しました
  • エラー発生時には詳細なエラーを表示するようにしました
  • 未登録時の制限に関する動作を改善しました
  • 一部の信頼性をアップしました
  • その他，数点改善しました

第0世代(テスト)

第0世代の履歴を表示/非表示

Ver.0.97 Restricted RC (1999/10/07)

機能制限の付いた，リリース候補版です。β版の期日制限も削除され，正式版と大差なくなりました。

  • プロジェクト編集で，コピー動作が最初の2つにしか働いていない不具合を修正しました
  • 完全実行の間隔が1になっているときに，履歴が更新されない不具合を修正しました
  • 完全実行の間隔が0で毎回実行，-1で完全を実行しないというように，一つシフトしました
  • 進行状況ダイアログの四つ角位置指定で，がタスクバー等に隠れないようになりました
  • 各種機能が登録されていないと制限がかかるようになりました
  • タスクトレイのアニメーションアイコンが改善され，動作中か判別しやすくなりました
  • オンラインヘルプ全体を見直しました

Ver.0.96 Release Candidate (1999/09/29)

リリース候補版です。ほぼ完成版ですが，シェアウエア制限はまだありません。

  • [ログファイルのクリア] コマンドをプロジェクト編集のツールメニューに新設しました
  • 環境によっては，ネットワークドライブのルートファイルをバックアップしない不具合を修正しました
  • まれに実行中にアクセス違反が起こる不具合を修正しました
  • ログファイルが空の時に追記指定にしていると，エラーが発生する不具合を修正しました
  • プロジェクト終了時の時刻がファイルに書き込まれていても，プロジェクトのオプションには反映されていなかった不具合を修正しました
  • 完全実行の間隔を0としているときも1としているときも同じ扱いで毎回完全実行されていましたが，0とすると完全実行をしないようにしました(1とすると毎回完全実行となります)
  • ディスティネーションサブフォルダの指定を強制し，同じアドレスが指定できないようにしました
  • フォルダの参照でネットワークドライブが見えていなかった問題を修正しました
  • 進行状況のプログレスバーが標準/リアルタイム時にキレイにならない問題を修正しました
  • [ログファイルのクリア] コマンドをプロジェクト編集のツールメニューに新設しました
  • ラベルチェック時に RMS 未挿入エラーが表示されないようにしました
  • アイドル時指定で，実行後1分経たないと次を実行しないようにしました
  • その他，GUI 周りを数点修正しました
  • ヘルプの整備が完了しました

Ver.0.95 β4 (1999/09/18)

β3で発見された不具合を全て修正し，処理効率をアップしました。

  • 差分生成のアルゴリズムを見直し，処理速度を劇的に高速化しました(オーダーが n^n から nlogn に…って専門用語ですが)
  • Culiet のプロパティをキャンセル後直ぐに実行するとアクセス違反が起こっていた不具合を修正しました
  • 属性がついたファイルがあると，履歴が美味くシフトしていなかった不具合を修正しました
  • 履歴を0にしても履歴が作られ，古い履歴が消されなかった不具合を修正しました
  • 履歴処理中に更新リストに存在するが実際には消えているファイルもカウントしてしまう問題を修正しました
  • プロジェクト編集の右クリックメニューにあるアクセスが動作していない不具合を修正しました
  • 起動時実行が，自動実行が OFF でも動作していた不具合を修正しました
  • プロセス間＆ログファイル処理の排他制御を強化しました
  • 初回起動時にスタートアップに登録するか尋ねるようにしました
  • 既に存在しなくなったソースファイルも履歴の数に含めていた点を修正しました
  • 空のフォルダでも存在すればディスティネーション側に反映するようにしました
  • 進行状況を最前面で表示し始めないようにしました
  • 進行状況のプログレスバーを一つのプロジェクト単位に戻しました
  • タスクトレイのアイコンを自動復活するようにしました
  • ヘルプがほぼ完成し，更にチップヘルプを整備しました

Ver.0.94 β3 (1999/09/11)

全ての機能をインプリメントしました。

  • サブフォルダ検索にて特殊な属性のついたフォルダが含まれない不具合を修正しました
  • リアルタイムの遅延設定が動作していない不具合を修正しました
  • 「履歴を全て圧縮」にしていると毎回全てのファイルがコピーされてしまう不具合を修正しました
  • 実行途中にプロジェクト編集から Culiet の終了を選ぶと，アクセス違反が起こっていた不具合を修正しました
  • ごくまれに Culiet.ini で例外が発生する不具合を修正しました
  • 履歴処理の数が正しく表示されない不具合を修正しました
  • 自動実行がオフの時でもリアルタイムが動作してしまう不具合を修正しました
  • 間隔指定のプロジェクトをで編集して保存すると，たまに実行されてしまう不具合を修正しました
  • アクティブでなくても起動時実行プロジェクトを実行していた不具合を修正しました
  • ファイルアイテムに同期オプションが表示されていたミスを修正しました
  • プロジェクト編集画面にアイテム編集バーを追加しました
  • プロジェクトの前回実行日時が本当に実行された日時を示すようにしました
  • プロジェクト手動実行系を一つにまとめました
  • 処理中にも定期的にログを保存するようにしました
  • このバージョンから更新風鐸に対応しました
  • その他，ヘルプを整備・アンインストーラ添付・UI 関連修正等

Ver.0.93 β2 (1999/09/06)

β1から数多くの不具合を撤去し，いくつかの新機能を加えました。

  • サブフォルダ探索時に Win9x でリアルタイムが動作しない問題が解決しました
  • 履歴の処理システムがいい加減だった点を修正しました
  • 前のプロジェクトが途中でキャンセルされていると，次のプロジェクトが実行されない不具合を修正しました
  • リアルタイムが動作してもコピーが行われない不具合を修正しました
  • プロジェクトリスト関連の動作が数カ所いかがわしかった不具合を修正しました
  • Culiet のプロパティを開いた後新規プロジェクトを追加すると，画面に反映されない不具合を修正しました
  • 進行状況ダイアログの任意設定が美味く動いていない不具合を修正しました
  • 実行途中で終了すると，アクセス違反が起こっていた不具合を修正しました
  • 履歴のシフトが動作していない不具合を修正しました
  • プロジェクト全体圧縮は「履歴を全て圧縮」に変わりました
  • 実行中のプロジェクトに再度実行指令を出しても無視するようにしました
  • レジストリアイテムを書き出す間待つようにしました
  • レジストリアイテム処理の結果をログに残すようにしました
  • ラベルが異なる時の問い合わせを実行前に確認オプションで制御できるようにしました
  • リアルタイムの遅延が Culiet のプロパティで指定可能になりました
  • プロジェクト編集のアイテムリストでカラム幅を保存するようにしました
  • その他，UI 関連等を数点修正しています

Ver.0.92 β1 (1999/09/05)

フィールドテスト版で発見された問題を修正した，初β版。

  • ミラーリングエンジン全般で複数の不具合を修正しました
  • 実行キャンセル時の確認中に実行が終わると，アクセス違反が起こる不具合を修正しました
  • リアルタイム属性アイテムが正しく動作しない不具合を修正しました
  • 完全実行の際に実行しない属性のアイテムも実行していた不具合を修正しました
  • UNC ネームのドライブのタイプを示す際に，フォルダまで指定してあると誤作動していた不具合を修正しました

Ver.0.91 Field Test (1999/09/01) 非公開

カーネル(ミラーリングエンジン)を初めて同梱した，手元確認のため数名で行われたフィールドテスト版。本体については，α版から次の点が修正されています。

  • 起動時実行が動作していない不具合を修正しました
  • 自動実行オプションを全て消しているときに，毎回実行されてしまう不具合を修正しました
  • アイテムの二重登録を禁止したり，登録方式を統一しました
  • プロジェクトを保存時アイテム一覧が最初のプロジェクトになってしまう不具合を修正しました
  • その他，カーネルと同期をとれるように改善しました

Ver.0.90 α1 (1999/08/26)

初めての公開バージョン。本体側のプロセスのみで，ミラーリングエンジンはまだ手つかず。

開発開始

1999 7 の月にはぢまる(笑)


開発秘話

このページの存在価値

存在価値自体が怪しい。だいたい，誰が読むんだろね，こんなページ…。そんな労力有るんだったら，他に努力しなさいってツッコミ飛んできそうなぐらいである。まぁ確かにそうなんだが，この使っていれば何とも思わない Culiet だって，それなりに…いやかなり苦労して作ってるんですな。その苦労を少しは知っていただこうという意味で書こうかと思ったけれど，そんなの対岸の火事。ならば，ねじれの位置ぐらいまでひねって開発の苦労を書けば，少しは秘話となって面白くなるだろうと思ったりして書いてみたりしたわけで…

開発の経緯

時代背景

Culiet なるソフトウエアがまだ姿形も無き古き日々(*1)，Copio なるソフトウエアありけり。Copio は Vector 週間ソフトニュース等に取り上げられ，着眼点よろしと評価を得る。されど，スレッドといふ機構を用ひて処理を行ふにあたり，環境によっては動作が不安定である面が多し。たへかねた作者は，構造自体を作り直そうと決意す(*2)。

(*1) 何と今から200日も昔，平成11年3月までの話である
(*2) 時は平成11年4月

懐妊

いかんとせんと考え，某大学にて某友人達と某食堂で食しながら談話。その際に某心の友＆くどい顔のP氏曰く

「スレッド止めて，プロセスでわければいいじゃん？」

この一言により，我が輩は Culiet を身ごもったのである。もっとも，この頃は名前はまだなく，Copio 3 となる予定であった。んがしかし，世の中は甘くない。ゆにばーしてぃーは忙しく，Copio 3 なるものは完成するのに時間がかかりすぎることが分かったのである。

古きを知って…

そこで Copio 3 なるものを新ソフトウエアとして先送りし(このころは Creatto というコードネームで呼ばれていた)，旧来の Copio 2 にあった問題を改善した新バージョンを先に出すことにしたのである。これは無事に成功し，Copio 3 のリリースに至る。それでもまだ安定しているとは言い難いが，これは構造のせいである。私のせいではない(構造を考えたのは誰か，というのはほっときましょう)。

命名

時は少し戻って6月頃，とある再履修の授業にて Creatto の命名式が行われようとしていた。某心の友＆出っ歯のQ氏(当然彼も再履)と案を出し合うこと数十分，彼の意見はことごとく無視され，私が編み出した Culiet に決定。候補としては，「Copio Super」「CopioEx」「Copio II」等，アホなものが並んでいた。

新しきを作る！

ようやく Culiet がどんなものになるか決まり，更に名前も決まったのであるが，開発はそう簡単には行かなかったのである。「案ずるより生むがやすし」と古人いうが，これは嘘である。

一つの機能を良く練ってからクラス化し，これを組み合わせるときに不整合がでないように良く確認してインプリメントしていく。こういった作業を延々と繰り返すこと1ヶ月，ようやく本体側が出来るのである。が，しかし，本当に休みが残りわずかになってきているにも関わらず，エンジンは全く姿形がない。これでは，ワープドライブのないエンタープライズである。ピカード艦長も真っ青である。

休みが終わりに近づいていたため，エンジンは1週間程度で仕上げなければならなかった。この際，クラス化している暇はない。ならばいい加減なソースを書くべきか…。そこでふと気がついた。5月頃に Copio 3 (とその頃呼んでいた) で使えるように，既にクラスを書いていたのである。使えないいい加減なものもあったが，使えるものもあったのである。これ幸いと実用レベルにあったいくつかのクラスを引っ張ってきて，さらに少し拡張して採用したところ，美味く動作したのである(*3)。

しかし，他にも問題はあった。圧縮機能である。これは過去に実験も勉強もしてない。コンポーネントはあるが，そういう問題ではない。…そう，結局は Unlha32.dll の使い方が分からないことには，利用できないのである。Unlha32.dll はデフォルトでパスが / であるが，ファイルシステムでは当然 \ である。この辺を一緒くたに扱うところが少々面倒ではあった。

(*3) 後日，問題が山のように見つかったが，それはご愛敬。もち修正済みっす。

誕生

こうして苦労した末，1999・9の月に完成した。予想通り構造のうまさのおかげか(密かな自慢を挟む高等技)，細かな問題は多数見られたものの，構造的問題はみられなかった。これは偉大な進歩である。早速 HDD 用と MO 用のプロジェクトを用意し，MO は一日おきに曜日指定して実行するようにした。今まではバッチファイルを使ったり，Copio でバックアップ先を変更したりしてバックアップをしていたが，これで Culiet 一本化が図れるようになった。最高な気分である。

ここだけの話，削った機能

言い訳

この Culiet では，搭載しようと思っていたにもかかわらず，先送りした機能もないわけではない。ただ，今回の Culiet については，今までの全ての拙作ソフトウエアの中では，最もそういった削られた機能が少ない部類で，優秀である(と，俺は思う)。つまり，そう悲観することもないのである。

言い訳はこれくらいにして，見送った機能というのは，次の二つである。

削った機能1

一つ目は RMS の完全なるサポートである。これは，たとえば RMS におさまらないファイルを分割したりして記録することである。搭載しなかった主な理由は，分割が大変なのと，せっかくの自動実行があまり意味がないからである(メディアの入れ替えしなけりゃいけない)。そうはいっても必要な環境もあるだろう。次期バージョン以降で考慮すべき点である。

削った機能2

二つ目はバックアップ先の容量チェックである。これは，しないとまずい場合もある。たとえば HDD に容量が足りない場合，即座にバックアップ動作を止めてユーザに知らせなければならない。しかし，この Culiet では同じファイルに上書きする場合もあり，ファイルサイズだけで簡単に容量オーバーが判定できるわけではない。この処理のオーバーヘッドは無視できないほど時間を要するだろう。そこで見送ったのであるが，他の方法を考えて処理効率を下げずに出来るようにすべきであろう。今後検討を要する点である。


.1-100 は Property.dfm に割り当て
.50 まで アイテムとプロジェクトのプロパティ
.topic 1
実行するタイミングを設定します。[常時] は「標準」「完全」のいずれのモードで実行されてもバックアップ対象となり，[完全のみ] は「完全」モードで実行されたときだけバックアップ対象となります。[リアルタイム] はリアルタイムアイテムになり，変更が有れば直ちにバックアップされるようになります。また，完全モード時にはバックアップ対象になります。[しない] は，いずれのモードにおいても，実行されないようになります。

.topic 2
対象のファイル・フォルダ・レジストリのアドレスを指定します。ファイル・フォルダの際には，右の [...] ボタンからアドレスを変更することが出来るようになってはいますが，変更については二重登録防止が動作しませんので，出来れば利用しないようにして下さい。レジストリアイテムの場合は，レジストリエディタが起動します。

.topic 3
プロジェクトのプロパティで設定されたディスティネーションの下の，どこへバックアップするかを指定します。通常自動で設定されますが，変更するときは任意のパスを書いて下さい。書式は，Sub1\Sub2\...\Subn という形にして下さい。最初と最後に \ はいりません。

また，ファイルフォルダの圧縮・レジストリ機能を使用しているときは，ここへファイル名を付け足してバックアップ後のファイル名を指定できます。たとえば，Sub1\Culiet.zip と書くと ZIP 形式になります。Sub1 とかかれているだけだと，Sub1\Culiet.lzh と同じ意味になります。拡張子は必ず指定して下さい。また，その拡張子にあう DLL を別途入手して下さい。レジストリの際も同じで，Sub1\HKLM_Software.reg の様な形で書く必要があります。レジストリの場合は，省略すると Sub1 というファイル名のファイルが作られてしまいます。

.topic 4
アイテムを圧縮して保存します。遅いマシンだとクリティカルなほど遅くなりますが，バックアップにあまり場所をとらないようになります。履歴だけを圧縮するには，プロジェクトのプロパティで [履歴を全て圧縮] にチェックしておくと，ここの設定には影響されずに圧縮することが出来ます。なお，圧縮についてはディスティネーションサブフォルダのヘルプを参照して下さい。

.topic 5
チェックされたアイテムは，アドレスに示されたフォルダの下にあるフォルダを検索します。ただし，サブフォルダが多いときは，検索に非常に時間がかかるようになります。検索については，テーブル機能を併用することで，早くすることが出来ます。

.topic 6
ソース側で消されたファイルが，ディスティネーション側で消されるかどうかを指定します。ON にすると(同期モード)消され，OFF にすると(保持モード)残されます。

.topic 7
テーブルを使用するかどうかを指定します。テーブルとは，特定のフォルダを検索する際に，既に検索済みのリストを使って代用する機能のことで，深い階層のフォルダなどでは処理が格段に向上することがあります。サブフォルダが少ない場合は，ほぼ速度に変化が無くなります。また，テーブルを利用すると，次回の完全モード実行まで内容が更新されませんので，その間に追加されたファイルには対応できません。

.topic 8
検索マスクを指定します。通常 *.* で全てのファイルを示しています。ここの設定は DOS のワイルドカードと同じ設定が出来，* で複数文字の代用，? で一文字の代用が出来ます。複数指定時は，スペースで区切ります。たとえば，*.doc で Word ドキュメント全て，?in.ini で Win.ini や Kin.ini などを検索対象と出来ます。複数指定時は，*.doc *.xls とすると，Word/Excel ドキュメントが対象になります。

.topic 9
除外マスクを指定します。除外マスクを指定すると，検索マスクに該当したファイルリストから，このマスクに該当するファイルを除くことができます。設定法は検索マスクのヘルプを参照して下さい。

.topic 10
プロジェクトの名前を設定します。プロジェクトの名前は，他のプロジェクトかぶらないようにした方が，管理の面でわかりやすくなります。ユニークな名前を付けて下さい。(ユニークは面白いじゃなくて，唯一の…って意味です)

.topic 11
ディスティネーション(バックアップ先)を設定します。横にドライブの種類が表示されるようになっていますので，ここでドライブが存在しないといわれたりするような指定は，しないようにして下さい。ディスティネーションの設定はフォルダ単位で行いますが，現在は存在しないフォルダでもかまいません。[...] をクリックすると，ディスティネーションのフォルダを参照して設定できます。

.topic 12
履歴ディスティネーション(履歴バックアップ先)を設定します。ディスティネーションのヘルプも参照して下さい。

.topic 13
完全実行の間隔を指定します。0とすると毎回完全実行され，-1とすると完全実行されなくなります。完全実行等が不明な場合は，ヘルプのスターティングガイドをご覧下さい。

.topic 14
履歴の最大数を設定します。履歴ディスティネーションの下に，この数字のフォルダを最大とする履歴が保存されるようになります。

.topic 15
履歴を全て圧縮するようにします。履歴は通常あまり使われることはないですが，場所はやはりとってしまいます。このオプションを使うことで，履歴を全て圧縮して場所を有効活用することが出来るようになります。

.topic 16
プロジェクトを実行開始する前に，実行を継続するかどうかを確認します。また，[ボリュームを確認してから実行する] を指定している場合は，ラベルが異なれば再試行するかどうか，確認します。

.topic 17
ディスティネーションのファイルを削除する際に，いちいち確認するようにします。クリティカルなプロジェクトにおいては，チェックしておくと安全性が高まります。

.topic 18
プロジェクトをアクティブにするかどうかを設定します。アクティブでないプロジェクトは，自動的に実行されることはありません。アクティブなプロジェクトは，自動実行モードになっているときに自動実行されます。

.topic 19
Culiet を起動した直後に，必ず実行するようにします。アクティブでないプロジェクトでは動作しません。

.topic 20
間隔指定による自動実行を行います。Culiet が起動してから指定した時間が経過すると，自動的に実行します。他の設定と併用しているときは，全ての設定に合致する場合に実行されます。

たとえば，12:00 に実行指定にして，10分おきにしている場合で，11:55 に手動実行していると，12:00 には実行されなくなります。次の日まで実行されません。11:45 に手動実行していると，動作します。

.topic 21
自動実行する間隔を指定します。間隔指定のヘルプも参照して下さい。

.topic 22
時間指定による自動実行を行います。指定した時間・曜日になると，実行を開始します。指定した時間を1分でも過ぎた後に Culiet を起動すると，実行されません。また，他の設定と併用しているときは，全ての設定に合致する場合に実行されます。

ここに示されているリストビューには，設定した時間・曜日が表示されます。日にちが0は無視を表します。ここで選択した後 [変更] をクリックすると，選択したアイテムを変更でき，[追加] を押すと新しいアイテムを追加できます。同様に [削除] を選択すると，アイテムを削除できます。なお，ドラッグアンドドロップで場所を移動することができます。

.topic 23
設定した時間・曜日が表示されます。日にちが0は無視を表します。ここで選択した後 [変更] をクリックすると，選択したアイテムを変更でき，[追加] を押すと新しいアイテムを追加できます。同様に [削除] を選択すると，アイテムを削除できます。なお，ドラッグアンドドロップで場所を移動することができます。

.topic 24
新しい時刻指定を追加します。

.topic 25
左のリストで選択したアイテムを，変更することが出来ます。

.topic 26
左のリストで選択したアイテムを，削除することが出来ます。

.topic 27
アイドル判定により一定時間が経過した後実行されるようにします。また，間隔指定とコンバインしているときは間隔指定が優先され，時間指定とコンバインしているときは，並列扱いになります。

.topic 28
アイドル判定がここで指定した時間経過すると，自動実行されます。

.topic 29
ディスティネーションのボリュームラベルを調べてから，実行するようにします。ディスティネーションがリムーバブルメディア・ネットワークドライブ等の場合は，このオプションを利用することで，有りもしないディスティネーションにファイルがコピーされることが無くなります。

ディスティネーションが存在しないときに確認して欲しい場合は，全般シートの [プロジェクトを実行する前に確認する] オプションを ON にして下さい。OFF のままの場合は，確認せずエラーとして終了します。

.topic 30
ディスティネーションのラベルを設定します。[...] を選択すると，全般シートで設定されたディスティネーションパスに従って，ラベルが取得されます。

.topic 31
履歴ディスティネーションのラベルを設定します。[...] を選択すると，全般シートで設定された履歴ディスティネーションパスに従って，ラベルが取得されます。

.topic 32
ファイルを比較する際に，ここで指定された時間の誤差までなら同一日時として扱います。特に，FAT-NTFS 間では2秒ずれることがあり，このままの設定にすることをお勧めします。

.Culiet のプロパティは 51 から
.topic 51
自動実行モードにします。このモードにすると，アクティブプロジェクトを全て自動的に実行するようになります。個々のプロジェクトがどう実行されるかは，個々のプロジェクトのプロパティを編集して下さい。

.topic 52
プロジェクトを変更すると，保存コマンド以外でも所々で保存するかどうかを聞かれます。そういった場所では，保存したことを前提に処理するようになっているからです。この確認を省略するには，ここにチェックを入れて下さい。ただ，チェックを入れてしまうと，確認無しで保存されるので，注意が必要です。

.topic 53
実行中に進行状況を表示させます。表示した方が心穏やかになりますが，管理者的に動いていることを知られたくないときなどは OFF にしてください。

.topic 54
表示位置を設定します。プライマリディスプレイの四つ角，及び任意の位置を指定できます。任意の位置では，実際にプロジェクトが実行中に移動した場所を記録し，次回からそこを利用するようになります。

.topic 55
詳細を表示するモードにします。詳細表示モードでは，処理中のアイテム名・ファイル名・現在のアイテム数などが表示され，よりわかりやすくなります。

.topic 56
カーネルのプライオリティを設定します。通常，アイドル(右端)のままで使うことをお勧めしますが，他に仕事をしない PC (ファイルサーバで夜中に Culiet でバックアップなど)の場合は，標準レベルまで持っていってもいいでしょう。優先モードは，あまり使わない方がいいと思います。

.topic 57
処理の結果をログに記録するかどうかを指定します。ログには，圧縮の結果・レジストリバックアップの結果が成功かどうかは記録されませんが，これ以外は全て記録されます。

.topic 58
追記にすると，既存のログを残すようになります。肥大化してきた場合は，適宜削除して下さい。

.topic 59
ログを記録するファイル名を指定します。

.topic 60
スタートアップに Culiet のショートカットを作成します。これにより，Windows 起動と同時に Culiet の常駐が行えるようになります。

.topic 61
スタートアップに既に登録済みの Culiet のショートカットを削除します。アンインストール前には，必ず実行して下さい。

.topic 62
プロジェクトリストを設定します。チェックを ON/OFF することで，アクティブかどうかを切り替えられます。ドラッグアンドドロップで順番を変更することもできます。

.topic 63
選択したプロジェクトを上へ移動します。ドラッグアンドドロップでも移動できます。

.topic 64
選択したプロジェクトを下へ移動します。ドラッグアンドドロップでも移動できます。

.topic 65
新規プロジェクトを追加します。詳細は，続いて表示されたダイアログのヘルプを参照して下さい。

.topic 66
既存のプロジェクトをリストに追加します。

.topic 67
選択しているプロジェクトを削除します。実際のファイルは削除されません。

.topic 68
全てのプロジェクトをアクティブにします。

.topic 69
全てのプロジェクトを非アクティブにします。

.topic 70
アイドル判定基準に CII を用います。システム的忙しさが一定時間同じの場合にアイドルと見なす数値です。通常はこのままでいいでしょう。

.topic 71
CII の値のぶれをどこまで誤差と見なすかを設定します。変更すると，値の実測グループの「現在の CII 値」にて，(+- 0) のところに反映されます。特に変更する必要もないでしょう。

.topic 72
アイドル判定基準に CPU 使用率を用います。特定の CPU 使用率以下の状態が継続して続いた場合に，アイドルと見なします。

.topic 73
ここで指定した CPU 使用率以下の状態が続いた場合に，アイドルと見なします。

.topic 74
リアルタイムアイテムにおいて，変更が有ってからここで指定した時間が経過後，バックアップ作業が行われます。頻繁に更新される場合は短く，たまに更新する場合は長くしておくと，無駄な作業が行われずにすむでしょう。

.101-150 までは，新規プロジェクト
.topic 101
プロジェクトの名前を設定します。プロジェクトの名前は，他のプロジェクトかぶらないようにした方が，管理の面でわかりやすくなります。ユニークな名前を付けて下さい。(ユニークは面白いじゃなくて，唯一の…って意味です)

.topic 102
プロジェクトの保存場所を設定します。この設定は，今後変更できないので注意して下さい(変更するためには，一旦プロジェクトリストから削除し，再度追加する必要があります)。デフォルトは，Culiet と同じフォルダの ProjectX.cpj となります(X には重ならない数字)。

.topic 103
プロジェクトの保存場所を設定します。

.topic 104
プロジェクトを最初からアクティブとして追加するかどうかを指定します。アイテムを追加してからアクティブにするときは，この時点ではオフにして下さい。

.topic 105
プロジェクトの詳細な設定(プロジェクトのプロパティ)を初めから設定するには，ここから行います。後でプロジェクトのプロパティで設定することもできます。

.151-200 は，ソースアイテム追加ウィザード
.151-160 は新規アイテムシート
.topic 151
追加するアイテムのパスを指定します。レジストリはここでは指定できません。追加するには，[...] から参照するか，エクスプローラからドロップ，または直接記述して下さい。

.topic 152
追加するファイルを選択します。

.161-170 はデフォルトプロパティ
.topic 161
追加するアイテムに共通の，実行タイミングを設定します。[常時] は「標準」「完全」のいずれのモードで実行されてもバックアップ対象となり，[完全のみ] は「完全」モードで実行されたときだけバックアップ対象となります。[リアルタイム] はリアルタイムアイテムになり，変更が有れば直ちにバックアップされるようになります。また，完全モード時にはバックアップ対象になります。[しない] は，いずれのモードにおいても，実行されないようになります。

.topic 162
アイテムを圧縮して保存します。遅いマシンだとクリティカルなほど遅くなりますが，バックアップにあまり場所をとらないようになります。履歴だけを圧縮するには，プロジェクトのプロパティで [履歴を全て圧縮] にチェックしておくと，ここの設定には影響されずに圧縮することが出来ます。なお，圧縮についてはディスティネーションサブフォルダのヘルプを参照して下さい。

.topic 163
追加するアイテムの内フォルダアイテムに共通で，アドレスに示されたフォルダの下にあるフォルダを検索します。ただし，サブフォルダが多いときは，検索と差分生成に非常に時間がかかるようになります。検索については，テーブル機能を併用することで，気持ち早くすることが出来ます。

.topic 164
追加するアイテムの内フォルダアイテムに共通で，ソース側で消されたファイルが，ディスティネーション側で消されるかどうかを指定します。ON にすると(同期モード)消され，OFF にすると(保持モード)残されます。

.topic 165
追加するアイテムの内フォルダアイテムに共通で，テーブルを使用するかどうかを指定します。テーブルとは，特定のフォルダを検索する際に，既に検索済みのリストを使って代用する機能のことで，深い階層のフォルダなどでは処理が格段に向上することがあります。サブフォルダが少ない場合は，ほぼ速度に変化が無くなります。また，テーブルを利用すると，次回の完全モード実行まで内容が更新されませんので，その間に追加されたファイルには対応できません。

.topic 166
追加するアイテムの内フォルダアイテムに共通で，検索マスクを指定します。通常 *.* で全てのファイルを示しています。ここの設定は DOS のワイルドカードと同じ設定が出来，* で複数文字の代用，? で一文字の代用が出来ます。複数指定時は，スペースで区切ります。たとえば，*.doc で Word ドキュメント全て，?in.ini で Win.ini や Kin.ini などを検索対象と出来ます。複数指定時は，*.doc *.xls とすると，Word/Excel ドキュメントが対象になります。

.topic 167
追加するアイテムの内フォルダアイテムに共通で，除外マスクを指定します。除外マスクを指定すると，検索マスクに該当したファイルリストから，このマスクに該当するファイルを除くことができます。設定法は検索マスクのヘルプを参照して下さい。

.171-180 はレジストリアイテム
.topic 171
バックアップするレジストリキーの名前を記します。ここのキーで指定された下全てのキーが，書き出すファイル名で指定したファイルに書き出されます。キーの名前は，レジストリエディタを用いて，キーの名前をコピーコマンドでコピーするのが確実です。

.topic 172
ディスティネーションの下のどこに保存するかを指定します。ですので，ここにサブフォルダを追加することが出来ます。RegBack の下に保存したい場合は，RegBack\HKCU_Software.reg の用に記述すると，Destination\RegBack\HKCU_Software.reg に書き出されます。ここの設定は，ディスティネーションサブフォルダに書き込まれます。

.topic 173
レジストリエディタを起動します。インストールをしていなかったり，または権限がない場合は，この機能が利用できません。同時に，このレジストリアイテムが利用できないことも表します。

.201-250 は，frmSelect
.201-210 は時刻設定
.topic 201
自動実行する日にちを指定します。0 を指定すると毎日実行されます。これ以外では，その日だけ実行されます。

.topic 202
自動実行する時間を指定します。秒設定は意味をなしません。また，毎時何分という実行は出来ません。これは，間隔指定を御利用になるか，1時間おきのアイテムを作って下さい。

.topic 203
自動実行させる曜日を指定します。最低一つは選択して下さい。

.topic 204
全ての曜日を選択します。

.topic 205
全ての曜日を選択解除します。

.211-220 は選択実行
.topic 211
実行するプロジェクトにチェックをつけて，OK を押します。ただ，[すべて] にする場合は，全てのプロジェクトを選択する必要はありません。デフォルトでは，アクティブプロジェクトがチェックされています。

.300 台は CAMC
.topic 301
管理者モードにします。全ての制限の ON/OFF は，ここで行えます。

.topic 302
パスワード変更時に選択します。

.topic 303
設定の変更を禁止します。設定変更を禁止するとは，プロジェクト編集・Culiet のプロパティ等を選択できないようにすることです。完全に禁止するには，レジストリエディタを禁止し，更に Culiet.ini のファイルパーミッション等も設定変更する必要があります。

.topic 304
手動実行オプションを禁止し，更に管理者モードを解除しないと終了できないようにします。完全にするには，Ctrl+Alt+Delete も禁止しなくてはなりません。

.topic 305
Culiet が動作していることを分からないようにします。上の二つのオプションは，これを有効にすると効果が無くなります。

.topic 306
ここに指定したキーを押すと，管理者モード画面を呼び出します。タスクトレイのアイコンを消去しているときには，必ずこの設定を覚えておかなければ，一生解除できません(^_^;)。忘れたときは，レジストリエディタで Culiet の設定を消す必要があります。

.1001-1010 はアバウト
.topic 1001
ライセンス番号です。ライセンス許諾を受けた人だけに発行される，唯一無二の番号です。(Unregistered) と表示される場合は，未登録か，または入力した番号・キーが無効です。

.topic 1002
マシンキーです。ライセンスフィーを支払った後，ライセンスの許諾を受けるには，マシンキーが必要です。これにより，ユニークな登録認証キーが発行されます。マシンキーが変わったときには，速やかにヘルプにある登録認証キーの再発行を参照し，再発行を受けて下さい。