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Welcome to the Help file for Wallaby for Windows '95.    This Help file is designed as a fast and easy 
way for you to get answers to questions about Wallaby.

If you find that this Help file doesn't contain the answer to one of your problems, then you can always e-
mail us with your question at support@wallaby95.com (or, if our server is down for some reason, 
wallaby@theoffice.net). 

This help file is split up into various sections, as set out below.    Just click on the topic that best matches 
your problem and the answer to your question should be there!. 
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Contacting GMA Soft-Tech
If you need to contact GMA Soft-Tech there are 3 main methods - these are e-mail, telephone or snail 
mail.

E-Mail
If you wish to contact us by electronic mail, send a message to support@wallaby.com

This is our help desk.    All questions, Techical or otherwise may be directed here, you should usually have
an answer to your question within 48 hours

Contacting by Telephone.
To contact us by telephone (voice only), call 

1-210-691-8438

Please note that if you dial this number internationally, you will need to add your countries International 
dialling codes to the number.    This phone number is in America.

When requesting help, please quote all the details from File -> Options -> Version Details EXCEPT for the
e-mail address and http:// address.    This will aid us in helping you!

Contacting us by Snail Mail
You can contact GlobalScape by snail mail by sending mail to...

GlobalSCAPE
12500 network Blvd. Suite 407

San Antonio, Texas 78249
U.S.A.

Please note: International mail takes around a week and a half to get here or longer during holidays. And 
it takes around another week and a half to get back to you.    If you would like a reply to your mail (unless 
you want an e-mail reply) please include a stamped, self-addressed envelope.



About Wallaby '95
Wallaby '95 was first started late in April, 1996.    Since then it has grown and grown into a shareware 
authors dream.    

We have had registrations from all around the world and have managed to get Wallaby onto the 
prestegious windows95.com and tucows.com (plus all of its global mirror sites).

Wallaby '95 was written by Geoffrey Steffens (16yrs) and a bit by Alan Patterson (40-something).

If you are wondering why we wrote Wallaby '95, it was because the other unzipping and zipping programs
around were either to complex to use, or too underpowered.    So we wrote Wallaby '95 - keeping in mind 
that people like easy, yet powerfull attactive software.

Please keep in mind that Wallaby '95 is shareware.    You can use it 30 times without any obligation to 
register it - however if you want to use it more than this you must register.    

You can register via Credit Card either by Telephone (FREE CALL IN US), or through the our Secure 
Server on the Internet [all details given over the Internet are encrypted before sending - once encrypted, 
they are virtually impossible to read without the correct decryption keys], you can also register via sending
a cheque or cash to GlobalScape.

GlobalScape now provide all technical support and take care of all the orders for Wallaby '95.    
GlobalScape is a sub-company of American Tele-Source International.



Overview
Welcome to Wallaby '95. The fastest, easiest and best way to Zip and Unzip files in Microsoft Windows 
'95.    

Wallaby '95 offers many advanced features, and although they are not difficult to use they are explained 
in this help file, along with the basics of using Wallaby '95.    If you have belive that there is something that
we have not covered in this help file, just e-mail us at support@wallaby95.com and we will try to help 
you out.

NOTE : We will answer all of your queries quickly and will try to help you out - but please check the help 
file first..    Click here for information regarding contacting us.    Another source for answers to questions is 
the FAQ at our Web Site.

We have tried to keep Wallaby for Windows '95 very simply to use and visually apealing while making it 
powerfull enough for just about any user.    Wallaby '95 is also tightly integrated to the Windows '95 Shell 
(just right click any folder or drive and find out!).



Registering Wallaby '95
BE SURE THAT YOUR E-MAIL ADDRESS IS CORRECT OR YOU WILL HAVE TO WAIT FOR YOUR 
REGISTRATION NUMBER VIA POST - UP TO 2 WEEKS!!!

Registering Wallaby is simple.    There are many methods availible to you to register Wallaby, they are 
listed below...

Current Registration pricing is US$20.00, however this may change in future, please check the web site 
before purchasing Wallaby '95 if you are unsure of the price.

Global registration method (Prefered)
Register throught our Secure Server.    All credit card registrations are encrypted so they are safe during 
transfer across the Internet.    Visit our web site, listed below, and follow the link at the bottom of the page.

        Web Site Address: 
                                      http://www.wallaby95.com/
        You will need a credit card to register over the Internet.

Telephone Registration (US Only)
You can order with MasterCard, Visa, Amex, or Discoverer from GlobalScape by calling 1-800-290-
5054.

Please note that this phone number is in the United States of America. Also please note that 
this phone line IS NOT for Technical Support.

The phone number for TECHNICAL SUPPORT 
is 1-210-691-8438.

Any questions about the status of the shipment of the order, refunds, registration options, product details, 
technical support, volume discounts, dealer pricings, site licenses, non-credit card orders, etc, may be 
directed to support@wallaby95.com

When we recieve your order, you will be e-mailed your Registration Code, usually the day of your order.

Postal Registration
Print out the registration form found on the "nag" screen in Wallaby by clicking Registration Form.

Send the printed form and a cheque, cash or Money Order to ...

GlobalSCAPE
12500 network Blvd. Suite 407

San Antonio, Texas 78249
U.S.A.

Please make all cheques payable to GlobalScape

Please ensure that your e-mail address is correct!



The Basics



About the Menus
The menus are reasonably straight foward. They are layed out as follows...

The File Menu
The file menu contains the things that are associated with Files and the General thins such as opening 
files, repairing files, exiting the program and setting up the options for the program

The Actions Menu
The actions menu has most of the things that you will be using in your Zip file.    You can add/remove files,
Unzip the contents of the zip file, turn the Zip file into a Self-Extractor.    You can also Install the program 
from the Zip file if there is an install program in it.

The Send To... Menu
The send to menu allows you to move or copy the open zip file to another location.    You can also delete 
the zip file from this menu

The Plugins Menu
The Plugins menu contains some assorted "plugins" that GMA Soft-Tech have developed that don't quite 
fit on any other menu.    From this menu you can split a zip file up onto many disks or re-join a zip file that 
has already been split.    You can also back up a drive (for example, your Hard Drive) to floppy disks. We 
have also included an option to run Windows Explorer from this menu.

The Help Menu
Here you will find access to this Help file and also be able to view the programs about box.



Using the Keyboard
After being asked by a few people we decided to put full keyboard functionality into Wallaby '95.

Now, Enter in a dialog or question box, such as Add or Remove files is the equivalent of clicking the OK or
Go button.

Finally, you can also hold down the ALT key and press the underlined letter on a button.    This is the same
as clicking the button.

Below is a list of keys that are functional from the Main Wallaby screen (excluding the ALT-??? keys).

Key List Associated Function
Control-O Open a new zip file
Control-N Create New zip file
Control-X Exit Wallaby '95
Control-P Split a Zip file
Control-R Rejoin a zip file
Control-F12 Launch Windows Explorer
Control-E Extract files from the zip
Control-S Create Self-Extracting File
Control-DELETE Send zip file to Recycling Bin
F1 Run this Help file
F5 Refresh the screen and Zip file
Ins Adds a new file to the zip



The Buttons
Each of the buttons on the main screen are shown below along with a brief description of what each one 
does.

They are broken up into the following sections...
Always Enabled
Enabled After opening/creating a file

Always Enabled
These commands are always availible

Open This button allows you to open Zip files.    If you want to unzip a file (or do anything to 
the zip file for that matter) you must open it up first.    The first time you click it, the 
Favourites folder will appear.    Click here for help with Favourites

New If you want to create a New Zip file, click this button.    You will be asked a few 
questions about where you want to put the zip file and what you want to call it.    Then
you will be able to add/remove etc files from it.

Repair If you have a corrupt or "broken" zip file, click this button.    Wallaby will attempt to 
rebuild the zip file so that it can be used.    Usually there is nothing that Wallaby can 
do but in some cases where you are missing just a bit of data Wallaby may be able to
fix the zip file.

Find If you want to search your computer for a zip file, click here.    When you click this 
button a dialog like the Windows '95 Find command will appear. Click here for more 
Help on Find

Enabled after opening/creating a file
The following commands are only availible after you have opened or created new zip file.

Unzip To unzip all the files in the open zip file, just click here.    A dialog will appear asking 
you how you want the zip file decompressed to (such as where to etc)

Add If you want to add a file (or files) to the zip file this button will do it for you.    Once 
clicked the Add dialog will appear.    Click here for more information on Adding files to 
your Zip

Remove This does the reverse of the add button (above). When you have added files to a zip 
file that you don't want there anymore, simply select them by clicking them and click 
here. Once a file has been removed from the zip file, you can't get back 
without adding it again.



View If there is something in the zip file that you want to run or look at, simply select it (click 
it) and then click this button.    You will have the option of running the Associated 
program, viewing it with Wallaby's text editor, or with Windows's text editor Notepad.

Properties The properties button will show you details about the zip file, like how many files it has
in it, what operating system in was created under (eg DOS, Windows '95, etc), the 
compresser version that created it (not the program version, the engine version).    
You will also be able to read/write/change the comment of the zip file.

Make SFX Behold a very powerfull button! This button allows you to turn the zip file into an exe.    
Once a zip file is an exe you can give it to anybody you want and they don't even 
need to have Wallaby (or any other unzipper) to unzip it, they just have to run 
it.

Unzip Wizard This button will activate the unzip wizard.    The unzip wizard is a simplified version of 
the Unzip button which is easier to understand but has less options.    You may prefer 
the wizard because of it's easy to understand questions.

Install Program Unlike the rest of the buttons, this button WILL NOT light up unless there is an Install 
program in the zip file.    If this button is clickable, just click it once to install the 
program. It will unzip all the files to a temporary folder, run the Install program, and 
then delete the temporary folder when it has finished.

Space Maker This button runs the Space Maker. The Space Maker will search your Hard Drives for 
wasted space such as temporary files, backup files, and files left over from when your
computer has crashed.    Space Maker will show you what it has found and you will 
have the option to delete them all (or just the ones that you select).

Exit (not shown) Use this button to exit Wallaby '95.    You can also press Control-X or click the Close 
button in the top right hand corner.



Quick Tutorials



Unzipping your first file
To Unzip a file in Wallaby '95 just follow these simple steps...

Step 1
The simplest way of opening a Zip file is to double-click on it's icon from within Explorer, but you can also 
load Wallaby '95, then click the "Open" button (click here to see a picture).    If this is the first time you 
have opened a zip file then CLICK HERE.

You can also use "Find" if you don't know where the Zip file is, but you know it's name. 

Just locate the file you want and double-click it.    The file will then Open up for you in Wallaby.

Step 2
If this is the Zip file you were looking for, then you can use the Unzip Wizard or you can use the button 
marked "Unzip".    The Unzip Wizard makes unzipping the files easier, but does not have all the options 
that the "Unzip" button does.

Hint : If there is a Setup or Install program availible in the zip file, a button marked "Install Program" (click 
to see a picture) will light up on the main screen, You can click this button instead to install the program

If you want to use the Wizard
If you use the Wizard to unzip, simply follow the easy to understand question and then wait while the files 
are unzipped.

If you use the Unzip button
Either leave the directory that Wallaby '95 has determined for you which is unique for this zip file (defaults 
to the Windows Desktop\Unzips and then the Zip file name).    Or you can type in another folder (it will be 
automaticly created if it doesn't exist.

Advanced Options
If you want the directory structure inside the zip to be recreated (which, you usually should) select Yes to 
the question "Rebuild Zip file directory structure".



The Favourites
Since this is the first time that you have used Wallaby's Favourites, a message will appear when you click 
Open and tell you Wallaby "Can't open <WALLABY FOLDER>\Autofolders.lst"

Don't worry about it, just click the OK button and continue.    BEFORE you do anything click the 
"Favourites" button in the top-left hand side of the Favourites dialog. 

When you click the "Manage your Favourites" item, the screen will change.

Now click the Add button to Add a new Folder to your favourites.    Click the OK button when you have 
found the folder you want from the box that appears.(NB: You can repeat this procedure if you have zip 
files in more than 1 folder)

When you have finished adding and removing Folders, click the OK button in the bottom right corner of 
the box.    Wallaby will save this list of Favourites for future use (You can change these at any time by 
simply following this procedure again!).

Wallaby will search all of the folders selected and list the Zip files that it finds.    Simply find the one that 
you are after and double click it to open it.

You can also select a folder as a once off, say, a folder on your CD drive by clicking the Browse button 
and selecting it.

IF YOU WOULD PREFER TO USE THE NORMAL WINDOWS '95 OPEN DIALOGS, un-check the box 
that says "Always use Favourites".

If you disable favourites, they can be turned back on at anytime by going to the File -> Options.



Making your first Zip file
Once you have loaded Wallaby '95 click the button marked "New Zip" (click here to see a picture)

When the dialog box appears, enter a Name for your New Zip file (eg "My Cool Zip file") - but do not put 
an extension on it, and then select where you want to put it (Click the Select button to browse).    If you do 
not select a location, Wallaby will auto-maticly use the current folder.

When you are ready to Create this zip file, click "Create >".

You have now made your first zip file!

The next thing to do is add some files to it.    To do this, you click the Add button, or Alternatively you can 
Drag and Drop from Explorer.

The files will be added to the zip file.



Other Information



Glossary
-A-

Associated
Program An associated program is something that is run when a file is double clicked, for 

example, if you double-click a text file (.TXT) the program called Notepad (which is 
associated with .TXT files) will be run. Wallaby is associated with .Zip files.

-B-

Broken Zip A Broken Zip file is a zip file which has been corrupted or is missing a part of data.    
This can sometimes be repaired by using the Wallaby '95 

-C-

-D-

Decompressed Another way of saying unzipped.

Dialog A Dialog is just a fancy way of saying "another window of the program".    Dialogs 
are not usually resizable.

Dialog Box A Dialog Box is a box which you must answer a question to, such as "Do you want to 
save this file".    They usually have Ok, Cancel, Yes or No butons in them.

-E-

-F-

-G-

-H-

-I-

-J-

-K-

-L-

-M-

-N-

-O-

-P-

-Q-

-R-

-S-



Self-Extractor SEE SFX

SFX A SFX (Short for Self-Extractor) is a zip file which has been converted into an 
EXE.    Self-Extractors can be unzipped on any computer WITHOUT the need for 
Wallaby '95 or any other unzipping program.

Sub-Folders Sub-Folders are folders 

-T-

-U-

Unzip SEE UNZIPPING

Unzipping This is the reverse of Zipping.    When you unzip a file you decompress it so that it 
is usable.

-V-

-W-

Wizard A Wizard is something that makes a certain part of a program very easy by 
asking simple and easy to understand questions.    They usually have next, back and 
cancel buttons on them. An example of this is the Wallaby '95 Unzip Wizard.

-X-

-Y-

-Z-

Zip file A zip file is a compressed file which can contain many other files.    Zip files are 
especially useful for distributing files because they are usually small in size.

Zipping Zipping is the process of creating a Zip file.    When you "zip" files they are 
compressed and placed inside the open file.    They can be unzipped with Wallaby and 
any other PKZIP compatable program. SEE ALSO unzipping

.zip The extension of a Zip file.    Any file with this extension is a Zip file and can be 
unzipped with Wallaby.



Getting Updates
There are a few places you can get the latest version of Wallaby '95 from...

Our Home Page (Newest version always here first!)
http://www.wallaby95.com/

Tucows
http://www.tucows.com/

Windows95.com
http://www.windows95.com/

We recommend checking every 3 to 5 months for a newer version.    Newer versions usually have more 
features and have had bug fixes put into them. 

You will always find the most up to date version at our Home Page.



Frequently Asked Questions
The following is a list of Frequently Asked questions.    Some of them are already in this help 
file under different names, but these are questions that are asked regularly so they are 
duplicated here too.

Q) How do I unzip a file?
A) Step 1. Open the zip file that you want to unzip (Clicking the Open button will do this). 

If it is the first time they have opened a zip file, the Favorites must be configured. See 
Configuring Favorites for details.

Step 2. Now, click the Unzip button or alternatively, the 'Unzip Wizard' button. They both accomplish the 
same, but the Wizard has fewer options and is easier to use.

If using the Wizard, just click the Next button and answer the questions (like where to unzip to and also 
whether to show the files when they have been unzipped). A location is automatically guessed from the 
Zip file name and the Windows\Desktop folder. For example, if the zip file is MYZIP.ZIP, by default, it 
unzips to C:\WINDOWS\DESKTOP\UNZIPS\MYZIP    the user can change this if they want to or they can 
leave it. Folders that don't exist are created.

If not using the Wizard then you have a slightly more complicated screen. Obviously, there is the location 
where you want to unzip the file to at the top. Again, as above, a location is automatically guessed from 
the filename, but can be changed if desired.

There is the option to restore the paths in the zip file. This means when it was zipped, it had paths stored, 
you can unzip it and the paths will be recreated. An option to select what to do if a file exists, and also a 
space to enter a password to decrypt the zip with. If there is no password entered, but the zip is 
encrypted, you will be prompted.

NOTE:If there is a setup program in the Zip file (i.e. Setup.exe or Install.exe) then you can just click the 
"Install" button in the first place and the program will be automatically unzipped, installed and then the 
temporary files deleted.

Q) What are the Favorites and how do they work?
A) The Favorites are a system devised by GMA Soft-Tech. The favorites allow you to tell Wallaby to 
search a folder, or a group of Folders for Zip files whenever you click Open. 

The first time that you click "Open" (and therefore use the Favorites) you will be asked whether you would
like to create the Favorites folder. It is recommended that you select YES.

Now, you can add and remove folders that contain zip files that you wish to automatically search for zip 
files when you click "Open". For example, if you download files to C:\Downloads and you would like to see
the zip files that are there each time you select "Open" then you would click "Add" and select C:\
Downloads. Wallaby '95 can handle around 32,000 folders in this file, it is unlikely that you would require 
more than this.

When you are finished adding and removing folders, click the OK button to accept your changes. Wallaby 
will begin to scan the selected folders for Zip files.

You can open a file by double clicking on it, or selecting it and clicking OK. As you will see, there are 
various other options on the screen. Here is a list of what each of them do

· The text-box where (Favorites) appears
You can use this to quickly select a folder to check for Zip files. Just type in the folder, say, C:\



ZIPS and press Enter. This will process the entered folder and it's subfolders (it is very 
fast, around 20 seconds to scan through 500mb of files in various folders).

· The Favorites button.
This allows you to change the Favorites folder or to activate your favorites again. Why? You 

may want to do this if for example if you have just searched another folder and now want 
to see your favorites again.

· Type of Files to show
You can select whether to only show Zip files or to show all files

· Special Options
From here you can opt to show files downloaded today (with today's time stamp or later) all to

show all files. A handy feature.

· "Always use Favorites" checkbox
If you don't want to use the favorites, that is, you would prefer to use the standard Windows 

'95 Open dialog boxes, then un-check this. To turn Favorites back on, view the options 
(File à Options)

Q) How do I zip files? 
A) Firstly, you have to have a zip file to add files to. You can create a new zip file, or open an existing file. 
To find out how to create a zip file, see "How do I Create a Zip file".

As Wallaby '95 supports Drag and Drop, you can simply Drag and Drop files from within Explorer or any 
dialog box into the zip file and they will be compressed. Alternatively, you click the Add button (If you click 
the Add button, you have many more options when zipping your files, such as encryption).

When you click the Add button, a box will appear with the following options....

· Settings >>

Use this button to access the advanced zipping functions, such as Passwords, 
Compression levels, Recursing folders etc. You can also set defaults for Wallaby to use 
when compressing files by clicking the Save as Defaults button that will appear when the 
screen expands.

· Add Folder

This is a quick alternative to adding files. If you want to Add an entire folder, say, C:\
GAMES\DOOM to a zip file then you could use this option*. You can still accomplish this 
by using Add files, but Add folder is faster.

* = You can also use this option to recurse subfolders under the folder you select, say, C:\
GAMES. To do this, click Settings >> and make Recurse Folders TRUE.



· Add Files

Use Add files to add files to your zip file. If you are adding an entire folder, it is faster to use Add folder.

· Cancel
Fairly obvious, Cancels and does not add anything to the zip file

Q) How do I password protect / Encrypt files?
A) Just add a file to the zip file and specify a password for it when you are compressing it. See the above 
for how to do this. Adding an encrypted file will AUTOMATICALLY encrypt the rest of the zip file.Please 
note: Passwords are case sensitive, i.e. THE is different to the which is different to tHe

Q) How do I run files other than EXE's and COM's and BAT's from a Self-extractor? 
A) At the moment, the only way to do this is create a BAT file that contains 'Start <FILETO RUN>'. We will
be fixing this soon, it is a matter of changing a few things in the Autoloaders. This only works with the 
32bit Self-Extractors.

Q) When I create a self-extractor, it gives me a CDE-XXX code? What's wrong? 

A) It depends on the code, here is a list of the codes...

CDE-1 English.elf was not found in Windows\System. Reinstall Wallaby '95

CDE-2 Autoload.16 / .32 not found in Windows\System. Reinstall Wallaby '95

CDE-3 Corrupted Autoload.16 / .32 in Windows\System. Reinstall Wallaby '95

CDE-4 Source file missing. Occurs when the source file couldn't be found    occurs
sometimes when the file exists anyway, still looking for a solution to this.

Contact us if you ever get this one, or find a solution before we do.

CDE-5 Source file is locked or in use. Wallaby '95 can't open a locked file, close all
other copies of Wallaby and check the file is not read-only (usually shouldn't

matter but a couple of people had this happen to them).

CDE-6 The Self-Extractor is locked, i.e. there is already a Self-Extractor, with the
same name as the Zip file (but has a .exe extension), and it is currently locked
by the system, or is loaded. Solution, exit all other running copies of the Self-

Extractor.

CDE-7 Drive not ready. Windows can't read from the selected drive

CDE-8 The drive is read-only, i.e. it is a CD-Drive

CDE-9 The drive is write protected, Remove the write protection tab.

CDE-10 Disk full. There is no more space on C: drive or the temporary drive Wallaby is 
using. Free up more space and try again.



CDE-11 System out of memory. Free up some more memory and try again.

Q) How do I make multi-disk zip files? 
A)The only way to make multi-disk files is to compress files to your hard drive first and then select Split 
Zip file from the Plugins menu.

 

Q) When I try to rejoin a split file, I get told that I have to restart in MS-DOS mode and then when it 
does the rejoined file isn't there! 
A)This is very strange    we have only had 2 people tell us about this problem (whether is just there 
computers or not is another question). We do not at this stage know why it happens but there is a way 
around it (although it is hardly what you would call a workaround).

It goes as follows...

Don't run GO.EXE    (that's the Rebuilder)

Drop to Dos (Don't Restart unless you have to)    use Start->Programs->MS Dos Prompt

Make a temporary folder

Copy all files on all disks into a temporary folder on the hard drive

View the contents of DATA.EXT    it contains the extension of the original file, write this down.

Do a directory listing of all files ending in .0 (Dir *.0)    take note of the FILE NAME    not the 
extension.

Type...

Copy /b <FILE NAME from DIR *.0>.000 + <FILE NAME from DIR *.0>.001 + <FILE NAME from 
DIR *.0>.002 + <FILE NAME from DIR *.0>.n-1 <FILENAME from DIR *.0>.<Name from 
DATA.EXT>

What does all that mean? Well, it binary copies all files, in order, to the original file. 

<FILE NAME from DIR *.0>.n    1 means just keep repeating the numbers until you are 1 disk less
then the total disks. That is, if there are 9 disks, then the last disk will be <FILE NAME from DIR 
*.0>.008 (9    1 = 8 (plus the 0's in front of it!)) 

Q) Does GlobalScape or GMA Soft-Tech provide support for Ez-Unzipper 
A) GMA Soft-Tech have nothing to do with Ez-Unzipper, Alan Patterson owns Ez-Unzipper. His e-mail 
address is apatterson@peg.apc.org

Q) Does GlobalScape provide support for other products by GMA Soft-Tech?
A) No, Geoffrey Steffens provides support for GMA Soft-Tech products other then Wallaby '95, his e-mail 
address is wallaby@theoffice.net

 
END OF FAQ    - Check for new versions at the Web Site.






