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MacroModel 1.5 Facts

Product Name:
• MACROMODEL™

Version: 1.5
• AVAILABLE FOR THE FIRST TIME ON WINDOWS

Product Summary:
• PROFESSIONAL SPLINE-BASED, CAD-ACCURATE 3D MODELING SOFTWARE

Product Categories:
• VISUALIZATION & DESIGN, 3D GRAPHICS, 3D DESIGN, 3D MODELING, MULTIMEDIA

Technical Breakthroughs:
• BINARY COMPATIBILITY* BETWEEN MACINTOSH AND WINDOWS
• POWERFUL USER INTERFACE PARADIGM TO ALLOW EDITING IN 3D SPACE
• SUPPORT FOR CURVED SURFACES AS WELL AS POLYGONAL MODELS
• CAD ACCURAC

* MacroModel 1.5 for Macintosh and MacroModel 1.5 for Windows are binary compatible. Files are completely 
interchangeable between the two platforms.

Technical Support:
• REGISTERED OWNERS RECEIVE 90 DAYS OF FREE, UNLIMITED TECHNICAL SUPPORT. AFTER THE INITIAL 

90-DAY PERIOD, MACROSERVICE GOLD PRIORITY TECHNICAL SUPPORT CONTRACTS ARE AVAILABLE 
FROM MACROMEDIA.

Product Training:
• MACROMEDIA OFFERS BEGINNING, INTERMEDIATE, AND ADVANCED PRODUCT TRAINING CLASSES 

THROUGHOUT THE UNITED STATES AND IN CERTAIN INTERNATIONAL MARKETS. TRAINING VIDEOTAPES 
ARE ALSO AVAILABLE.

Distribution:
• DISTRIBUTION PARTNERS WORLDWIDE, INCLUDING INGRAM MICRO, MERISEL, AND TECHDATA IN THE 

UNITED STATES AND CANADA, DISTRIBUTE MACROMEDIA’S PRODUCTS TO AN INTERNATIONAL NETWORK 
OF VALUE-ADDED RESELLERS, DEALERS, AND MAIL ORDER COMPANIES.



Company Information:

MACROMEDIA™, INC.
600 TOWNSEND STREET, SUITE 310 WEST
SAN FRANCISCO, CA 94103
TEL: 415-252-2000
FAX: 415-626-0554

MACROMEDIA EUROPE
4 WELLINGTON BUSINESS PARK
DUKE'S RIDE
CROWTHORNE, BERKSHIRE
RG11 6LS ENGLAND
TEL: 44.344.76.11.11
FAX: 44.344.76.11.49

MACROMEDIA PACIFIC
LEVEL ONE 
270 PACIFIC HIGHWAY
CROW'S NEST
2065 NEW SOUTH WALES, AUSTRALIA
TEL: 61.2.906.3265
FAX: 61.2.906.6324



Setup

Macintosh System Configuration
Recommended: Macintosh IIci or better, System v.7.0 or later,  12 MB RAM or 

more, 24-bit graphics card, 6 MB free hard disk space
Minimum: Macintosh II family or better*, System v.6.07 w/32-bit QuickDraw or 

later, 8 MB RAM, 8-bit graphics card, 6 MB free hard disk space
NOTES:
• MacroModel is System 7 compatible and 32-bit clean.
• Macintosh II, IIx, LC & IIsi require a math co-processor.
• Set application memory to 10 Mb (if your system will allow it)

Windows PC System Configuration
Recommended: 486/33 PC or better, 8-bit video (16-, 24-bit also supported), 16 

MB RAM, Windows 3.1 and 6 MB free hard disk space
Minimum: 386/25 PC w/FPU, 8-bit video, 8 MB RAM, Windows 3.1 enhanced and 

6 MB free hard disk space

Applications You Need
• MacroModel v.1.5 and Scripts folder

Files You Need
• Demo file

Goal
• To built a realistic product prototype based on the Direction 2000 product 

concept

Process Steps
1.....Introduction to MacroModel
2.....Setting up the Body Outline
3.....Building the Screen
4.....Building the Control Panel
5.....Building the Trackball
6.....Building the Product Body
7.....Building the Antenna
8.....Viewing the Model





Do This Explanation

1. Introduction to MacroModel
Starting MacroModel
•  Double-click on the MacroModel Demo application icon to 
launch MacroModel.  From the File Menu, open the 
"Demo.mdl" file.

• Look at the Tool Palette.

• Look at the Workspace .

• Look at the Tool Palette again.

• Toggle on Show Working Plane from the
Object menu.

• Toggle off Show Working Plane from the
Object menu.

MacroModel is a spline-based, CAD-accurate 
modeling tool that allows users to create a wide variety
of three-dimensional models useful to multimedia 
developers, graphic artists, product designers, 
engineers and any other professional needing powerful 
3D modeling.

MacroModel is designed to allow users who are 
comfortable with a wide variety of 2D illustration and 
CAD tools to move their ideas into the third 
dimension.

When you design in MacroModel, you design in one 
window.  This window looks into a 3D world that has 
x, y & z axes.

All of MacroModel's objects are built from simple or 
complex 2D shapes.  2D shapes are built by using a 
wide variety of common tools that you are probably 
already familiar with.

To draw these objects, we need to have a surface, 
called the Working Plane which is like a piece of 
paper.  MacroModel draws and manipulates all 2D and
3D objects on, across and relative to the Working 
Plane.

The Working Plane is in itself an object that can be 
numerically or interactively manipulated and moved 
within the MacroModel world.



Do This Explanation

2. Build the Body Outline



Do This Explanation

Create some Construction Geometry
• Show Construction Object tool group 

from the Tool Palette.

      Construction Grid
• Select the Construction Grid from the 

Construction tool group.
• Set the draw center/corner-toggle to 

corner.
      Corner Toggle
• Draw a Construction Grid filling the 

Workspace.
 

Before we start to draw the body outline of the 
Direction 2000 prototype, let’s lay out some 
Construction Geometry that we can use to measure and
snap geometry to.  Construction objects can come in a 
variety of types including Lines, Grids, Axes, and 
Points.

For our purposes we will use the Construction Grid…

…and we will draw this object from the corner.

Now we will lay out a grid across the Workspace 
drawn on the current Working Plane.  This grid has a 
1/4” grid, which is MacroModel's default 
measurement.  The grid is changeable, which is a 
feature we will use later.

*Remember Construction Grids are NOT substitutes 
for the Working Plane, although you still can snap 
points to Construction Grids and draw along grids that 
are not aligned with the Working Plane.

Build the body outline.

      Rectangle
• Select the Rectangle tool and, starting a

.5 in and down from the top left corner of
the Construction Grid, draw a rectangle 
measuring W: 3” x H: 2”

 
*Watch the scrolling numbers to measure.

To build the body outline of the product we will start 
by using simple rectangle s to mass-out the shape.

The first rectangle will represent the major portion of 
the product that houses the Screen and Control Panel.
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     Rectangle
• Select the Rectangle tool and, 

starting .25” below the right top corner of
the first rectangle, draw another 
measuring W: 1” x H: 1.5”.

 

The second rectangle represents the minor portion of 
the product that houses the Trackball.

• Select Geometry Modifier tool group and
select the Cut tool and cut the lines that 
the two objects share out. (This needs 
to be done twice: once for each object.) 
Cut

To do this click on each end of the line 
segment and then click the segment 
itself.  Repeat this operation to remove 
the second piece of geometry.

 

To make this one continuous 2D object we must cut 
portions of these two separate rectangles out so that 
they can be subsequently joined together.  



Do This Explanation

• Marquis select the two rectangles and 
select Join from the Object menu.

• Click on the line with the cursor.

To cut parts of a 2D object apart simply designate the 
segment by clicking on each side of the line segment 
that you want to remove.  Notice that the arrow turns 
into a crosshair when the cursor passes over a line or 
point.  That means that MacroModel is snapping to a 
piece of geometry.  After selecting the extent of the 
piece to be removed, click on the segment itself and it 
will be cut out.  Now do this again because there are 
two pieces of geometry on top of each other.

To join these two shapes, much like you would in 
Illustrator™, select the lines and use the Join 
command.  

Now the two separate objects are one.

• Select Geometry Modifier tool group and
select the Fillet tool.

      Fillet
• Hold down the Option key for Mac/F3 for

Windows and click on the Fillet tool 
again.

• Click on each line segment on either 
side of the top left corner.

 

• Continue this operation all the way 
around.  Remember that the third and 
eighth corners go “in” so the third corner
in skipped and the fourth corner is 
filleted inward.  Do likewise for the 
corner on the opposite side of the 
outline.

Now to add rounded corners to this shape we will fillet
the corners with the Fillet tool.  To make our work go 
faster, we can make the Fillet tool the default tool.  
Now the tool will not change back to the Arrow tool 
after each operation.  Notice how the tool defaults 
to .25”, which we will not alter.  This value can, of 
course, be edited to any value that will work within the
constraints of the geometry that you want to modify.

Start at the top left corner and click on each side of the
corner.  MacroModel is smart enough to fillet the 
corner inbetween the two line segments you click.
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• Hold down the Option key for Mac/F3 for

Windows and click on the Arrow tool
when finished to make that tool the

default tool.

Continue this operation for every corner on this 
outline, skipping the third corner so that we can create 
an inward curve at this point.

• Marquis select the outline and select 
Join from the Object menu.

Look at the  outline from another angle.

      Pan/Rotate/Zoom View
• Select the Hand tool and, while holding 

down either the Option for Mac/F3 for 
Windows or Command for Mac/F4 for 
Windows, interactively move the view 
around.

• Select Home from the View menu to 
return to the default view.

Again we will need to join the geometry, so simply 
repeat the same procedure.

To look at the work from another angle we can 
interactively move our view around the MacroModel 
world.  By holding down special command keys we 
can move wherever we want to interactively.

To continue our work simply return to the Home view.
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3. Building the Screen



Do This Explanation

Create the basic Screen shape

      Square
• Get the Square tool and draw a square 

starting 1/4” down and in from the top 
left corner of the outline. Draw a 1.5” 
square.  The tool bar will read  W: 1.5”.

 
 .....Fillet

• Select Geometry Modifier tool group and
select the Fillet tool.

• Hold down the Option key for Mac/F3 for
Windows and click on the Fillet tool 
again.

• Click on each line segment on either 
side of the top left corner.

• Continue this operation all the way 
around, so that all of the corners are 
rounded.

 

Now we will build the Direction 2000's view Screen.  
It will consist of the Screen itself surrounded by a 
Screen trim.

Select the Square tool from the Rectangle tool group 
and, starting 1/4” down and in from the top left corner 
of the outline, draw a 1 1/2” x 1 1/2” square.

To create rounded corners to match the rest of the 
object, select the Fillet tool and make it the default 
tool like before.

Now fillet all of the corners of this square and join 
them together.
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This will be the outline for the Screen. 
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• Hold the Option key for Mac/F3 for 
Windows and click on the Arrow tool 
when finished to make that tool the 
default tool.

• Marquis select the Screen outline and 
select Join from the Object menu.

Create the Screen.

• Select the Screen outline and choose 
Duplicate from the Edit menu.  The new 
object will be placed to the right of the 
original.

• Hold down the H key and, while holding 
the mouse down, grab the right side of 
the object and move it horizontally to the
left until it snaps into position on top of 
the original outline.

 .....Extrude
• Select the Extrude tool and press tab so

that the default extrude value of 1.5” is 
highlighted.  Type in .025 and press 
Return to lock in the value, then either 
double click or press Enter to create the 
3D shape.

 
• Double click on the middle of the Screen

object to open it.
• Double click on the middle of the Screen

object again to close it.
• Open the Materials browser…

We will be able to use this geometry for two separate 
objects: the Screen and the trim, so let’s duplicate this 
object.

To place it EXACTLY on top of the original, we can 
constrain motion in certain directions using modifier 
keys.  Here we will use the H key to move the new 
outline horizontally to the left until it snaps exactly on 
top of the original geometry.

Now we will turn this outline into a 3D object, which 
will be the Screen.  To do this, select the Extrude tool 
and type in the exact value that we want to extrude to 
which is .025.  Double clicking or pressing Enter will 
initiate the action and create our first 3D shape.

To access the object’s geometry for editing we simply 
double click on the object.  To close the access to the 
points, double click again.

To Change the color of the objects we can open the 
Materials browser and apply a new color.  Since the 
object is already selected all we have to do is pick a 
new color.  In this case we have set up a list of colors 
corresponding to this demo, so pick the material called
Screen.  Materials can have color, reflectance, 
specularity, roughness and even Three-D or 
RenderMan shaders attached.  The squiggle at the top 
will update as you change the values in the Materials 
browser to give you visual feedback about what type of
material you are editing.
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…and select Screen from the material list.

Close the browser when finished.

 

Create the Screen trim.

      Oval
• Select the Oval tool from the Circle tool 

group and, above the Construction Grid,
draw a horizontally oriented oval whose 
length does not exceed approximately 
1/4”.

      Sweep
• Select the Sweep tool and click on the 

oval, then click on the black outline of 
the Screen.  The cursor will turn into a 
crosshair when the arrow passes over 
the geometry.  Double-click or press 
Enter to create the 3D shape.

• Open the Materials browser and select 
Trim from the material list.  Close the 
browser when finished.

Linking Objects

      Lock Link
• Select the Lock Link tool from the Link 

tool group.

To create the Screen trim object we will use the Sweep
tool, which will extrude a shape along a path.  The 
path, in this case, is the Screen outline, so we will need
a shape to extrude along this path.  Let’s create a small
oval and draw it at the top of the Screen.

To sweep this shape we will pick the Sweep tool and 
click on the oval, which will be the cross-section, and 
the original Screen geometry, which will be the path.  
When these are selected double click or type Enter to 
create the 3D shape.

Once again the object took on the default color, so 
open the Materials browser and select the Trim 
material from the material list.

To create a real-world relationship between two or 
more objects, we need to Link them together.  Linking 
is a very powerful feature that allows us to create 
dynamic working models that simulate many of the 
ways objects work together in the real world.  With 
linking we can produce ball joints, hinges, locked links
and a number of physical relationships.  In this case, 
we will use a simple Lock Link to bolt or glue these 
objects together.
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• With the Lock Link tool selected place 
the mouse in the center of the Screen, 
hold down the mouse button and drag 
the line out to the Screen trim object. 
Then release the mouse button.  Both 
objects will be highlighted meaning that 
they are linked together.

 

It is logical that if you created this object for real, the 
Screen would be set into the trim, so create a link that 
links the Screen TO the trim.  Notice now that BOTH 
objects are selected, meaning that they are linked 
together.  

We will see more sophisticated examples of this 
feature later in this demo.
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4. Building the Control Panel

      Rectangle
• Get the Rectangle tool and, starting .25”

to the right of the top right corner of the 
Screen object,  draw a rectangle that 
measures W: .75” x H: 1.5”.

 
      Extrude

• Select the Extrude tool and double-click 
or press Enter to create the 3D shape

• Open the Materials browser and select 
Control Panel from the material list.  
Close the browser when finished.

To create the Control Panel, where the prototype's 
input devices will reside, we will use the Extrude tool 
again.  We will not place any objects on this panel to 
represent these input devices, but instead render them 
onto this object later in Macromedia's Three-D, which 
is a professional-quality animation and rendering 
application.  If you do not have access to Three-D or 
any number of other renderers on the market, then you 
may wish to create 3D objects that show where and 
how the buttons will be placed

Start by drawing a rectangle that measures 3/4” x 1 
1/2”.  Notice how the numbers scroll as you draw the 
object.  You could type in these values just as easily.

To create a 3D object from this rectangle, choose the 
Extrude tool and double click or press Enter.  This 
creates an extruded rectangle that is .025” in height, 
which is the height that we set for the Screen object.  
We could have interactively created the object height 
or typed in a new value if we wanted it to be any 
different.

Once again the object took on the default color, so 
open the Materials browser and select the Control 
Panel material from the material list.
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5. Building the Trackball
Create the base 2D geometry.

Changing the Grid dimensions
• Select Rulers from the Object menu and

change Divisions from 4 to 8 and close 
the dialog.

Using the Center Arc tool
     Center Toggle
• Set the draw center/corner-toggle to 

center.
 .....Circle
• Select the Circle tool from the Circle tool

group.
• Draw a circle, where the radius 

equals .375” on the toolbar, placed in 
the horizontal center and 5/8” to the left 
of the right side of the body outline.

 

In this section we will build a working track ball 
device for the Direction 2000.  The track ball will 
consist of a ball and a trim ring to hold it in the 
Direction 2000.  Let’s start by creating the base 2D 
geometry for both of these objects.  This methodology 
should be getting familiar by now, for it will be a lot 
like how we created the Screen, except we will be 
using some different tools.

With the Construction Grid at its current dimensions, 
we will not be able to place and create the properly 
sized objects, so let’s change the grid dimensions.  
Currently the grid is set at 1/4” divisions, so we will 
simply change the grid so that it is set at 1/8” 
divisions.  At this scale we will be able to create the 
exact geometry we need and position it properly.

The first thing we will do is draw a piece of geometry 
that will be the basis for the Trackball's trim.  Use the 
Circle tool to draw a 3/8” circle in the middle of the 
lower portion of the body outline.
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      Center Arc
• Select the Center Arc tool from the Arc 

tool group.
• Draw a 180_ arc by clicking first on the 

circle's center, then click vertically to the
top of the circle so that the radius equals
.375” on the toolbar, and finally click 
vertically to the bottom so that the Angle
equals 180_ on the toolbar.

 

Create the base 3D Trackball.

• The arc should still be selected.
      Lathe
• Select the Lathe tool and click, first, on 

the top end of the arc and, second, on 
the bottom end of the arc.  The Lathe 
tool will automatically initiate the 
creation of the object.

 

• Open the Materials browser and select 
Trackball from the material list.  Close 
the browser when finished.

Next we will draw a piece of geometry that will 
become the Trackball itself.  Using the Center Arc 
tool, we will draw a half circle in the same place as the
ring.  Notice how the numbers on the toolbar are 
giving us accurate numeric feedback about the 
dimensions of this arc.

To create the actual 3D Trackball, we will use a new 
3D tool called the Lathe tool.  The Lathe tool will 
rotate a piece of geometry, to any specified angle, 
around a user-specified axis.  For example, to make a 
sphere from this arc, all we have to do is specify an 
axis that is defined by the two open ends of this arc.  
The Lathe tool will then rotate this arc 360_, the 
default value, around this axis to create a sphere.

Once again the object took on the default color, so 
open the Materials browser and select the Trackball 
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material from the material list. 
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Create the base 3D Trackball trim

      Oval
• Select the Oval tool from the Circle tool 

group and, above the Construction Grid,
draw a vertically oriented oval whose 
height does not exceed approximately 
1/4”.

 

      Sweep
• Select the Sweep tool and click on the 

oval, then click on the black outline of 
the Screen.  The cursor will turn into a 
crosshair when the arrow passes over 
the geometry.  Double-click or press 
Enter to create the 3D shape

• Open the Materials browser and select 
Trim from the material list.  Close the 
browser when finished.

Linking Objects

      Ball Link
• Select the Ball Link tool from the Link 

tool group.

To make the ring that holds the Trackball, we will use 
the same process we used to create the trim for the 
Screen.

To create the Trackball trim object, we will use the 
Sweep tool again.  The path, in this case, is the one we
drew at the beginning of this part of the demo.  The 
object that we sweep along this path will be another 
oval.  

Let’s create a small oval, much like we did for the 
Screen trim, and draw it at the top of the Screen.

To sweep this shape we will pick the Sweep tool and 
click on the oval, which will be the cross-section, and 
the circle that surrounds the new 3D Trackball object, 
which will be the path.  When these are selected, 
double click or press Enter to create the 3D shape.

Once again the object took on the default color, so 
open the Materials browser and select the Trim 
material from the material list.

Just as we did for the Screen object, we will need to 
create a real-world relationship between the Trackball 
and the Trackball trim objects.  There fore we will 
need to Link them together.  In the first example we 
used a Lock Link to lock both the attitude and the 
position of the objects relative to each other, but in this
example we will use a Ball Link instead.  A Ball Link 
will lock the position, but not the attitude.  This means 
that the Trackball can rotate freely in the trim, just like
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it would if it were a real assembly.
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• With the Ball Link tool selected, place 
the mouse in the center of the Trackball 
object, hold down the mouse button and
drag the line out to the Trackball trim 
object. Then release the mouse button.  
Both objects will be highlighted meaning
that they are linked together.

 

Look at the  work -in-progress from another angle

      Pan/Rotate/Zoom View
• Select the Hand tool and, while holding 

down the Command for Mac/F4 for 
Windows key, interactively move the 
view by pushing and depressing the 
mouse from the bottom of the Screen to 
the top so a 45_ view is created.

 

It is logical that if you created this object for real the 
Trackball would be set into the trim, so create a link 
that links the Trackball TO the trim.  Notice now that 
BOTH objects are selected, meaning they are linked 
together.  

To look at the work from another angle we can 
interactively move our view around the MacroModel 
world.  By holding down the Command for Mac/F4 for
Windows key we can move interactively to another 
view looking down on the work we have done thus far.

Interactively manipulate linked objects

      Arrow To see how the Trackball will actually work all we 
have to do is click and hold on the Trackball object 
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• The Arrow tool will be automatically 
selected because it is the default tool.  
Place the Arrow over the center of the 
Trackball object and click and hold down
the mouse button, while, at the same 
time, holding down the Option for 
Mac/F3 for Windows key.  While BOTH 
buttons are being held down, slowly 
move the mouse around the Workspace
to see the Trackball object rotate.

 

and, while holding down either the Option for Mac/F3 
for Windows or Command for Mac/F4 for Windows 
keys like for the views, move the mouse around the 
Screen.  Notice how the Trackball moves only its 
orientation, just like a functioning Trackball would 
actually work!
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6. Building the Product Body
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Managing the model

• Click on the Screen Trim object and 
shift-select the Control Panel and 
Trackball Trim objects so that all  
objects in the model are selected.  Since
the Screen Trim and Trackball Trim 
objects are the parent objectss of the 
objects that they contain, the entire 
assemblies will be chosen.

Creating the body object

      Bevel Extrude
• Choose the Bevel Extrude tool from the 

Extrude tool group and select the 
product body's 2D outline.

• Select the Bevel Extrude tool and press 
tab so that the default extrude value of 0
is highlighted.  Type in -.5 and press 
Return to lock in the value, then either 
double click or press Enter to create the 
3D shape.  Leave the default bevel 
of .05 as it is.

To build the body of the product we will use the body 
outline that we constructed at the beginning of this 
demo.  First, though, let’s manage our model.  This 
means that we will hide objects that we are finished 
working on so that we can work more efficiently and 
faster.

We will, therefore, hide the objects that we have 
created thus far: the Screen Assembly, the Control 
Panel and the Trackball Assembly.  To hide these 
objects, shift-select all of the objects and choose the 
Hide Selected command from the Object menu.  The 
objects haven't been deleted—only hidden from view.  
This means that the redraw time will be significantly 
faster because we don't have to redraw those objects 
every time we change something in the model.

To create the Direction 2000's main body we will use 
the Bevel Extrude tool in the Extrude tool group.  We 
will specify that the extrusion will be -1/2” and have a 
bevel radius of .05”.  We are extruding in a negative 
direction so that we do not have to move the product's 
Screen, Trackball, and control panel which are already 
placed on the Construction Grid.  

The Bevel Extrude tool, while very useful for complex
extrusions for prototypes, is also very useful for 
creating advanced text objects.
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• The product body will extrude in the 
negative direction and look like the 
illustration below.

 
• Double click on the middle of the body 

object to open it.

Interactively Editing the Body  Object

      Zoom
• Choose the Zoom tool and drag a 

window over the lower right area of the 
product body.

 

      Arrow
• The Arrow tool will be automatically 

selected because it is the default tool.  
Place the Arrow over the illustrated 
point, hold the mouse down, drag the 
point and let go.

 

One of MacroModel's most powerful features is its 
ability to edit an object with the same spline-based 
geometry that created it.  What we will do here is 
interactively zoom into a small part of the product 
body and change the profile of the 2D geometry that 
created it.

To edit the profile of the product body all we must do 
is place the mouse over one of the profile's tangent 
points and click and drag the tangent point so it 
changes the tension and direction of the curve.  This is 
the same operation on would use to change a curve in 
Adobe Illustrator or Aldus Freehand.  Let go of the 
mouse when you are satisfied with the new curve.  The
object will then be recalculated to conform to the new 
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shape and it will also place the .05 bevel on it too!
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• Choose Undo from the Edit menu to 
return the shape to its original form

Moving the Construction Grid 
Numerically

• Click on the Construction Grid to select 
it.

• Open the Object browser in the Objects 
menu.

• Type -.25 in the Z field of the Position 
dialog section of the Object browser and
press Return to lock in the value.

 
• Close the Object browser when finished.

After you have changed the shape of the object, choose
Undo from the Edit menu to return the object to its 
original state.

To allow us to build the next object in this tutorial we 
must first move the Construction Grid to a different 
location.  We will move the Construction Grid exactly 
1/4” below where it exists now so we can mirror the 
duplicated geometry over it.  To do this, select the grid
by clicking on it and then open the Object browser.  To
numerically change the Grid's position, simply type in 
-.25 in the Z field of the Position dialog section of the 
browser and press Return.  See how the Grid has 
changed position?  It is now 1/4” below its original 
location.
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7. Building the Antenna
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Setting up the Work View

• Select Home from the View menu.
      Pan/Rotate/Zoom View
• Select the Hand tool and click and drag 

the Hand tool from the center to the right
side of the Workspace so that the body 
is positioned half off the Screen.

 

Change the Working Plane.

      Working Plane 
• Select the Working Plane tool.  Click on three points in 

a counter-clockwise fashion on the Construction Grid.

 

The last element of the model we will build is the 
Direction 2000's extendible Antenna.  

To create this we will set up our Workspace by first 
going back to the Home view and using the hand tool 
to pan the view so that the body of the Direction 2000 
is on the right side of the  Screen.  

The second procedure will be to place the Working 
Plane, currently placed on top of the Product Body, so 
that it is aligned with the Construction Grid.  The 
Working Plane tool will allow me to place the 
Working Plane on a variety of points, lines or surfaces.
In this demonstration, we will just use points.  Like the
3D Mirror tool needs three points to define a plane, so 
does the Working Plane.  By designating three points 
on the Construction Grid, we can align the Working 
Plane to that object.

We moved the Working Plane in order to draw the 
Antenna so that it lies in the center of the body.  
Remember that all objects are drawn and moved across
the Working Plane.



Do This Explanation



Do This Explanation

Build the 2D Geometry.

      Line 
• Select the Line tool and, while holding 

the V key down, draw a line starting at 
the top/left of the body and going 
horizontally left.  The tool bar will start 
scrolling. Stop drawing the line when the
value in the toolbar is approximately 
three.

 

      Center Toggle
• Make sure that the draw center/corner-

toggle is set to center.
 .....Circle
• Select the Circle tool from the Circle tool

group and draw a circle in the lower left 
hand part of the Workspace that 
measures approximately .1”.

 

To build the 2D geometry that makes up the Antenna, 
draw a horizontally constrained line that extends from 
the top left-hand corner of the Direction 2000's body.  
Since we will be using the Sweep tool to create this 
shape, we will need to create an object to sweep along 
this new line.  

With the Circle tool draw a circle that has an 
approximate radius of .1”.  The toolbar will give you 
feedback as to the exact size of the circle.



Do This Explanation



Do This Explanation

Build the 3D Geometry.

      Sweep
• Select the Sweep tool and click on the 

circle, then click on the line.  The cursor 
will turn into a crosshair when the arrow 
passes over the geometry.  Double-click
or press Enter to create the 3D shape.

Linking Objects

      Lock Link
• Select the Lock Link tool from the Link 

tool group.

• With the Lock Link tool selected, place 
the mouse in the center of the Antenna 
object, hold down the mouse button, 
drag the line out to the product body, 
and release the mouse button.  Both 
objects will be highlighted meaning that 
they are linked together.

 

To create  the Antenna we will use the Sweep tool to 
simply sweep the circle along the line which is the 
path.

Just as we did for the Screen and the Trackball objects,
we will need to create a real-world relationship 
between the Antenna and the product body.  There 
fore, we will need to Link them together.  In the first 
example we used a Lock Link to lock both the attitude 
and the position of the objects relative to each other.  
In this example we will use the Lock Link again, but 
this time we will modify the link.

As for the Screen assembly, lock linking will lock both
the position and attitude of these two objects relative 
to each other.  In order for the Antenna to travel in and
out of the product body, we will have to modify the 
link.  But first we have to modify the view.



Do This Explanation

Look at the  work -in-progress from another angle.

• Select the Axonometric view found in 
the Orient list in the View menu.

      Pan/Rotate/Zoom View
• Select the Hand tool, place it in the 

center of the Workspace, depress and 
drag the mouse until the objects are 
centered in the Workspace.

 

Changing the link

• Click on the Antenna to select it.
• Open the Object browser in the Objects 

menu.
 

Using the pre-scripted Axonometric view, we can shift 
to a view that allows us to see the top of the product 
body and Antenna.  

We can then center the view with the Hand tool by 
panning the Antenna to the center of the Screen.

To change the link of the Antenna, select the object 
and open the Object browser box.  You will notice that
the position and attitude boxes are all checked.  To 
create a link that allows the Antenna to move in only 
one direction, up and down relative to the product 
body, we need to unlock one of the position boxes.  

MacroModel has a feature called a Virtual Trackball 
that gives us a visual representation of the orientation 
of selected objects.  Notice that, for the selected 
Antenna, the X face of the Trackball lines up with the 
top of the Antenna.  



Do This Explanation

• Deselect the X position lock by clicking 
on the checked box to the right of the X 
field in the Position field of the browser.

 
• Close the Object browser when finished.
• To move the object, click the arrow on 

the Antenna and drag to the right and 
left.

 

Finishing the model

• Toggle off Hide Objects from the 
Objects menu.

      Lock Link
• Select the Lock Link tool from the Link 

tool group.
• Option-select the Lock Link tool so it will

be the default tool and link the:
1. Screen Trim to the Product Body
2. Control Panel to the Product Body
1. Trackball Trim to the Product Body

If we unlock the X position, we unlink that part of the 
lock link which allows the Antenna now to move 
freely in that one direction.

To finish the model we need to link the hidden 
elements of our model to the product body.  
Deselecting Hide Objects brings all of the objects back
into view.

Now let’s finish the model by lock linking all of the 
elements to the product body.



Do This Explanation

      Arrow 
• Hold down the Option key for Mac/F3 for

Windows and click on the Arrow tool 
when finished to make that tool the 
default tool.

• Click in the Workspace to deselect the 
objects.

 

The model is now finished and ready for 
presentation viewing!



Do This Explanation

8. Viewing the Model

Final viewing of the model

• Open the Views browser in the View 
menu.

• From the list of saved views, click on 
Final View.

• Close the View browser when finished.

Clearing the construction geometry

• Choose Clear Construction Objects from
the Objects menu.

 

The last element of developing the Direction 2000 
prototype is viewing the model.  MacroModel has the 
ability to save any number of views.  In this demo file, 
there is a saved view named Final View.

Notice the View browser is very similar to the Object 
browser.  The Virtual Trackball now tracks the 
orientation of the view, not the objects here.  Notice 
also that when we select the Final View from the list of
saved views that the view has a colored background 
attached.

To finally present the prototype we will clear the 
construction geometry.

This is the final presentation view of the Direction 
2000 prototype in MacroModel!   For photorealistic
still images, change the materials in the Materials 
browser from plastic to any number of other 
material presets and export as a RIB file for 
PIXAR's RenderMan for both Macintosh or 
Windows.  For photorealistic animations, natively 
import into Macromedia's Three-D for the 
Macintosh or export  DXF for import into 
Autodesk’s 3D Studio™ or Crystal Graphics’ 
Topas™ for the PC.

CONCLUSION

You have seen how MacroModel can take an idea and turn it into reality.  MacroModel has allowed us to create a CAD-
accurate, curved-surface model of the Direction 2000 long before we would have to create a physical prototype of the 
product.  Furthermore, this model can be used by project engineers to actually create that physical prototype, used in 
conjunction with a CAD program like Autodesk’s AutoCAD™ or Ashlar's Vellum (both PC and Mac).  Graphic artists can 
use the same model to create photorealistic images and animations to sell the idea, used in conjunction with an animation 
and rendering program like Macromedia's Three-D (Mac) or Autodesk’s 3D Studio™ or Crystal Graphics’ Topas™ (PC).



Do This Explanation

MacroModel's flexibility means that you can even go back and change a model 
very easily.

Without a doubt, MacroModel is the tool of choice for a wide variety of design 
professionals.
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	• Double-click on the MacroModel Demo application icon to launch MacroModel. From the File Menu, open the "Demo.mdl" file.
	• Look at the Tool Palette.
	• Look at the Workspace .
	• Look at the Tool Palette again.
	• Toggle on Show Working Plane from the Object menu.
	• Toggle off Show Working Plane from the Object menu.

	MacroModel is a spline-based, CAD-accurate modeling tool that allows users to create a wide variety of three-dimensional models useful to multimedia developers, graphic artists, product designers, engineers and any other professional needing powerful 3D modeling.
	MacroModel is designed to allow users who are comfortable with a wide variety of 2D illustration and CAD tools to move their ideas into the third dimension.
	When you design in MacroModel, you design in one window. This window looks into a 3D world that has x, y & z axes.
	All of MacroModel's objects are built from simple or complex 2D shapes.  2D shapes are built by using a wide variety of common tools that you are probably already familiar with.
	To draw these objects, we need to have a surface, called the Working Plane which is like a piece of paper. MacroModel draws and manipulates all 2D and 3D objects on, across and relative to the Working Plane.
	The Working Plane is in itself an object that can be numerically or interactively manipulated and moved within the MacroModel world.
	2. Build the Body Outline
	Create some Construction Geometry
	• Show Construction Object tool group from the Tool Palette.
	Construction Grid
	• Select the Construction Grid from the Construction tool group.
	• Set the draw center/corner-toggle to corner.
	Corner Toggle
	• Draw a Construction Grid filling the Workspace.
	


	Before we start to draw the body outline of the Direction 2000 prototype, let’s lay out some Construction Geometry that we can use to measure and snap geometry to. Construction objects can come in a variety of types including Lines, Grids, Axes, and Points.
	For our purposes we will use the Construction Grid…
	…and we will draw this object from the corner.
	Now we will lay out a grid across the Workspace drawn on the current Working Plane. This grid has a 1/4” grid, which is MacroModel's default measurement.  The grid is changeable, which is a feature we will use later.
	*Remember Construction Grids are NOT substitutes for the Working Plane, although you still can snap points to Construction Grids and draw along grids that are not aligned with the Working Plane.
	Build the body outline.
	Rectangle
	• Select the Rectangle tool and, starting a .5 in and down from the top left corner of the Construction Grid, draw a rectangle measuring W: 3” x H: 2”
	
	*Watch the scrolling numbers to measure.
	Rectangle
	• Select the Rectangle tool and, starting .25” below the right top corner of the first rectangle, draw another measuring W: 1” x H: 1.5”.
	

	To build the body outline of the product we will start by using simple rectangle s to mass-out the shape.
	The first rectangle will represent the major portion of the product that houses the Screen and Control Panel.
	The second rectangle represents the minor portion of the product that houses the Trackball.
	• Select Geometry Modifier tool group and select the Cut tool and cut the lines that the two objects share out. (This needs to be done twice: once for each object.) Cut
	To do this click on each end of the line segment and then click the segment itself. Repeat this operation to remove the second piece of geometry.
	
	• Marquis select the two rectangles and select Join from the Object menu.
	• Click on the line with the cursor.

	To make this one continuous 2D object we must cut portions of these two separate rectangles out so that they can be subsequently joined together.
	To cut parts of a 2D object apart simply designate the segment by clicking on each side of the line segment that you want to remove. Notice that the arrow turns into a crosshair when the cursor passes over a line or point. That means that MacroModel is snapping to a piece of geometry. After selecting the extent of the piece to be removed, click on the segment itself and it will be cut out. Now do this again because there are two pieces of geometry on top of each other.
	To join these two shapes, much like you would in Illustrator™, select the lines and use the Join command.
	Now the two separate objects are one.
	• Select Geometry Modifier tool group and select the Fillet tool.
	Fillet
	• Hold down the Option key for Mac/F3 for Windows and click on the Fillet tool again.
	• Click on each line segment on either side of the top left corner.
	
	• Continue this operation all the way around. Remember that the third and eighth corners go “in” so the third corner in skipped and the fourth corner is filleted inward. Do likewise for the corner on the opposite side of the outline.
	
	• Hold down the Option key for Mac/F3 for Windows and click on the Arrow tool when finished to make that tool the default tool.

	Now to add rounded corners to this shape we will fillet the corners with the Fillet tool. To make our work go faster, we can make the Fillet tool the default tool. Now the tool will not change back to the Arrow tool after each operation. Notice how the tool defaults to .25”, which we will not alter. This value can, of course, be edited to any value that will work within the constraints of the geometry that you want to modify.
	Start at the top left corner and click on each side of the corner. MacroModel is smart enough to fillet the corner inbetween the two line segments you click.
	Continue this operation for every corner on this outline, skipping the third corner so that we can create an inward curve at this point.
	• Marquis select the outline and select Join from the Object menu.
	Pan/Rotate/Zoom View
	• Select the Hand tool and, while holding down either the Option for Mac/F3 for Windows or Command for Mac/F4 for Windows, interactively move the view around.
	• Select Home from the View menu to return to the default view.

	Again we will need to join the geometry, so simply repeat the same procedure.
	To look at the work from another angle we can interactively move our view around the MacroModel world. By holding down special command keys we can move wherever we want to interactively.
	To continue our work simply return to the Home view.
	3. Building the Screen
	Create the basic Screen shape
	Square
	• Get the Square tool and draw a square starting 1/4” down and in from the top left corner of the outline. Draw a 1.5” square. The tool bar will read W: 1.5”.
	
	.....Fillet
	• Select Geometry Modifier tool group and select the Fillet tool.
	• Hold down the Option key for Mac/F3 for Windows and click on the Fillet tool again.
	• Click on each line segment on either side of the top left corner.
	• Continue this operation all the way around, so that all of the corners are rounded.
	



	Now we will build the Direction 2000's view Screen.  It will consist of the Screen itself surrounded by a Screen trim.
	Select the Square tool from the Rectangle tool group and, starting 1/4” down and in from the top left corner of the outline, draw a 1 1/2” x 1 1/2” square.
	To create rounded corners to match the rest of the object, select the Fillet tool and make it the default tool like before.
	Now fillet all of the corners of this square and join them together.
	This will be the outline for the Screen.
	• Hold the Option key for Mac/F3 for Windows and click on the Arrow tool when finished to make that tool the default tool.
	• Marquis select the Screen outline and select Join from the Object menu.
	Create the Screen.
	• Select the Screen outline and choose Duplicate from the Edit menu. The new object will be placed to the right of the original.
	• Hold down the H key and, while holding the mouse down, grab the right side of the object and move it horizontally to the left until it snaps into position on top of the original outline.
	.....Extrude
	• Select the Extrude tool and press tab so that the default extrude value of 1.5” is highlighted. Type in .025 and press Return to lock in the value, then either double click or press Enter to create the 3D shape.
	
	• Double click on the middle of the Screen object to open it.
	• Double click on the middle of the Screen object again to close it.
	• Open the Materials browser…
	
	…and select Screen from the material list. Close the browser when finished.


	We will be able to use this geometry for two separate objects: the Screen and the trim, so let’s duplicate this object.
	To place it EXACTLY on top of the original, we can constrain motion in certain directions using modifier keys. Here we will use the H key to move the new outline horizontally to the left until it snaps exactly on top of the original geometry.
	Now we will turn this outline into a 3D object, which will be the Screen. To do this, select the Extrude tool and type in the exact value that we want to extrude to which is .025. Double clicking or pressing Enter will initiate the action and create our first 3D shape.
	To access the object’s geometry for editing we simply double click on the object. To close the access to the points, double click again.
	To Change the color of the objects we can open the Materials browser and apply a new color. Since the object is already selected all we have to do is pick a new color. In this case we have set up a list of colors corresponding to this demo, so pick the material called Screen. Materials can have color, reflectance, specularity, roughness and even Three-D or RenderMan shaders attached. The squiggle at the top will update as you change the values in the Materials browser to give you visual feedback about what type of material you are editing.
	
	Create the Screen trim.
	Oval
	• Select the Oval tool from the Circle tool group and, above the Construction Grid, draw a horizontally oriented oval whose length does not exceed approximately 1/4”.
	Sweep
	• Select the Sweep tool and click on the oval, then click on the black outline of the Screen. The cursor will turn into a crosshair when the arrow passes over the geometry. Double-click or press Enter to create the 3D shape.
	• Open the Materials browser and select Trim from the material list. Close the browser when finished.
	Linking Objects
	Lock Link
	• Select the Lock Link tool from the Link tool group.
	• With the Lock Link tool selected place the mouse in the center of the Screen, hold down the mouse button and drag the line out to the Screen trim object. Then release the mouse button. Both objects will be highlighted meaning that they are linked together.
	


	To create the Screen trim object we will use the Sweep tool, which will extrude a shape along a path. The path, in this case, is the Screen outline, so we will need a shape to extrude along this path. Let’s create a small oval and draw it at the top of the Screen.
	To sweep this shape we will pick the Sweep tool and click on the oval, which will be the cross-section, and the original Screen geometry, which will be the path. When these are selected double click or type Enter to create the 3D shape.
	Once again the object took on the default color, so open the Materials browser and select the Trim material from the material list.
	To create a real-world relationship between two or more objects, we need to Link them together. Linking is a very powerful feature that allows us to create dynamic working models that simulate many of the ways objects work together in the real world. With linking we can produce ball joints, hinges, locked links and a number of physical relationships. In this case, we will use a simple Lock Link to bolt or glue these objects together.
	It is logical that if you created this object for real, the Screen would be set into the trim, so create a link that links the Screen TO the trim. Notice now that BOTH objects are selected, meaning that they are linked together.
	We will see more sophisticated examples of this feature later in this demo.
	4. Building the Control Panel
	Rectangle
	• Get the Rectangle tool and, starting .25” to the right of the top right corner of the Screen object, draw a rectangle that measures W: .75” x H: 1.5”.
	
	Extrude
	• Select the Extrude tool and double-click or press Enter to create the 3D shape
	• Open the Materials browser and select Control Panel from the material list. Close the browser when finished.


	To create the Control Panel, where the prototype's input devices will reside, we will use the Extrude tool again.  We will not place any objects on this panel to represent these input devices, but instead render them onto this object later in Macromedia's Three-D, which is a professional-quality animation and rendering application. If you do not have access to Three-D or any number of other renderers on the market, then you may wish to create 3D objects that show where and how the buttons will be placed
	Start by drawing a rectangle that measures 3/4” x 1 1/2”. Notice how the numbers scroll as you draw the object. You could type in these values just as easily.
	To create a 3D object from this rectangle, choose the Extrude tool and double click or press Enter. This creates an extruded rectangle that is .025” in height, which is the height that we set for the Screen object. We could have interactively created the object height or typed in a new value if we wanted it to be any different.
	Once again the object took on the default color, so open the Materials browser and select the Control Panel material from the material list.
	5. Building the Trackball
	Create the base 2D geometry.
	Changing the Grid dimensions
	• Select Rulers from the Object menu and change Divisions from 4 to 8 and close the dialog.
	Using the Center Arc tool
	Center Toggle
	• Set the draw center/corner-toggle to center.
	.....Circle
	• Select the Circle tool from the Circle tool group.
	• Draw a circle, where the radius equals .375” on the toolbar, placed in the horizontal center and 5/8” to the left of the right side of the body outline.
	
	Center Arc
	• Select the Center Arc tool from the Arc tool group.
	• Draw a 180_ arc by clicking first on the circle's center, then click vertically to the top of the circle so that the radius equals .375” on the toolbar, and finally click vertically to the bottom so that the Angle equals 180_ on the toolbar.
	
	Create the base 3D Trackball.
	• The arc should still be selected.
	Lathe
	• Select the Lathe tool and click, first, on the top end of the arc and, second, on the bottom end of the arc. The Lathe tool will automatically initiate the creation of the object.
	
	• Open the Materials browser and select Trackball from the material list. Close the browser when finished.
	Create the base 3D Trackball trim
	Oval
	• Select the Oval tool from the Circle tool group and, above the Construction Grid, draw a vertically oriented oval whose height does not exceed approximately 1/4”.
	
	Sweep
	• Select the Sweep tool and click on the oval, then click on the black outline of the Screen. The cursor will turn into a crosshair when the arrow passes over the geometry. Double-click or press Enter to create the 3D shape
	• Open the Materials browser and select Trim from the material list. Close the browser when finished.
	Linking Objects
	Ball Link
	• Select the Ball Link tool from the Link tool group.


	To sweep this shape we will pick the Sweep tool and click on the oval, which will be the cross-section, and the circle that surrounds the new 3D Trackball object, which will be the path. When these are selected, double click or press Enter to create the 3D shape.
	Once again the object took on the default color, so open the Materials browser and select the Trim material from the material list.
	Just as we did for the Screen object, we will need to create a real-world relationship between the Trackball and the Trackball trim objects. There fore we will need to Link them together. In the first example we used a Lock Link to lock both the attitude and the position of the objects relative to each other, but in this example we will use a Ball Link instead. A Ball Link will lock the position, but not the attitude. This means that the Trackball can rotate freely in the trim, just like it would if it were a real assembly.
	• With the Ball Link tool selected, place the mouse in the center of the Trackball object, hold down the mouse button and drag the line out to the Trackball trim object. Then release the mouse button. Both objects will be highlighted meaning that they are linked together.
	
	Pan/Rotate/Zoom View
	• Select the Hand tool and, while holding down the Command for Mac/F4 for Windows key, interactively move the view by pushing and depressing the mouse from the bottom of the Screen to the top so a 45_ view is created.
	

	It is logical that if you created this object for real the Trackball would be set into the trim, so create a link that links the Trackball TO the trim. Notice now that BOTH objects are selected, meaning they are linked together.
	Arrow
	• The Arrow tool will be automatically selected because it is the default tool. Place the Arrow over the center of the Trackball object and click and hold down the mouse button, while, at the same time, holding down the Option for Mac/F3 for Windows key. While BOTH buttons are being held down, slowly move the mouse around the Workspace to see the Trackball object rotate.
	
	6. Building the Product Body
	Managing the model
	• Click on the Screen Trim object and shift-select the Control Panel and Trackball Trim objects so that all objects in the model are selected. Since the Screen Trim and Trackball Trim objects are the parent objectss of the objects that they contain, the entire assemblies will be chosen.
	Creating the body object
	Bevel Extrude
	• Choose the Bevel Extrude tool from the Extrude tool group and select the product body's 2D outline.
	• Select the Bevel Extrude tool and press tab so that the default extrude value of 0 is highlighted. Type in -.5 and press Return to lock in the value, then either double click or press Enter to create the 3D shape. Leave the default bevel of .05 as it is.
	
	• The product body will extrude in the negative direction and look like the illustration below.
	
	• Double click on the middle of the body object to open it.



	To build the body of the product we will use the body outline that we constructed at the beginning of this demo. First, though, let’s manage our model. This means that we will hide objects that we are finished working on so that we can work more efficiently and faster.
	We will, therefore, hide the objects that we have created thus far: the Screen Assembly, the Control Panel and the Trackball Assembly. To hide these objects, shift-select all of the objects and choose the Hide Selected command from the Object menu. The objects haven't been deleted—only hidden from view.  This means that the redraw time will be significantly faster because we don't have to redraw those objects every time we change something in the model.
	To create the Direction 2000's main body we will use the Bevel Extrude tool in the Extrude tool group.  We will specify that the extrusion will be -1/2” and have a bevel radius of .05”.  We are extruding in a negative direction so that we do not have to move the product's Screen, Trackball, and control panel which are already placed on the Construction Grid.
	The Bevel Extrude tool, while very useful for complex extrusions for prototypes, is also very useful for creating advanced text objects.
	Interactively Editing the Body Object
	Zoom
	• Choose the Zoom tool and drag a window over the lower right area of the product body.
	
	Arrow
	• The Arrow tool will be automatically selected because it is the default tool. Place the Arrow over the illustrated point, hold the mouse down, drag the point and let go.
	


	One of MacroModel's most powerful features is its ability to edit an object with the same spline-based geometry that created it.  What we will do here is interactively zoom into a small part of the product body and change the profile of the 2D geometry that created it.
	To edit the profile of the product body all we must do is place the mouse over one of the profile's tangent points and click and drag the tangent point so it changes the tension and direction of the curve.  This is the same operation on would use to change a curve in Adobe Illustrator or Aldus Freehand.  Let go of the mouse when you are satisfied with the new curve.  The object will then be recalculated to conform to the new shape and it will also place the .05 bevel on it too!
	
	• Choose Undo from the Edit menu to return the shape to its original form
	Moving the Construction Grid Numerically
	• Click on the Construction Grid to select it.
	• Open the Object browser in the Objects menu.
	• Type -.25 in the Z field of the Position dialog section of the Object browser and press Return to lock in the value.
	

	After you have changed the shape of the object, choose Undo from the Edit menu to return the object to its original state.
	To allow us to build the next object in this tutorial we must first move the Construction Grid to a different location. We will move the Construction Grid exactly 1/4” below where it exists now so we can mirror the duplicated geometry over it. To do this, select the grid by clicking on it and then open the Object browser. To numerically change the Grid's position, simply type in -.25 in the Z field of the Position dialog section of the browser and press Return.  See how the Grid has changed position?  It is now 1/4” below its original location.
	7. Building the Antenna
	Setting up the Work View
	• Select Home from the View menu.
	Pan/Rotate/Zoom View
	• Select the Hand tool and click and drag the Hand tool from the center to the right side of the Workspace so that the body is positioned half off the Screen.
	

	Change the Working Plane.
	Working Plane
	• Select the Working Plane tool. Click on three points in a counter-clockwise fashion on the Construction Grid.
	

	Build the 2D Geometry.
	Line
	• Select the Line tool and, while holding the V key down, draw a line starting at the top/left of the body and going horizontally left. The tool bar will start scrolling. Stop drawing the line when the value in the toolbar is approximately three.
	
	Center Toggle
	• Make sure that the draw center/corner-toggle is set to center.
	.....Circle
	• Select the Circle tool from the Circle tool group and draw a circle in the lower left hand part of the Workspace that measures approximately .1”.
	

	Build the 3D Geometry.
	Sweep
	• Select the Sweep tool and click on the circle, then click on the line. The cursor will turn into a crosshair when the arrow passes over the geometry. Double-click or press Enter to create the 3D shape.
	Linking Objects
	Lock Link
	• Select the Lock Link tool from the Link tool group.
	• With the Lock Link tool selected, place the mouse in the center of the Antenna object, hold down the mouse button, drag the line out to the product body, and release the mouse button. Both objects will be highlighted meaning that they are linked together.
	
	• Select the Axonometric view found in the Orient list in the View menu.
	Pan/Rotate/Zoom View
	• Select the Hand tool, place it in the center of the Workspace, depress and drag the mouse until the objects are centered in the Workspace.
	
	• Click on the Antenna to select it.
	• Open the Object browser in the Objects menu.
	



	Using the pre-scripted Axonometric view, we can shift to a view that allows us to see the top of the product body and Antenna.
	We can then center the view with the Hand tool by panning the Antenna to the center of the Screen.
	• Deselect the X position lock by clicking on the checked box to the right of the X field in the Position field of the browser.
	
	• Close the Object browser when finished.
	• To move the object, click the arrow on the Antenna and drag to the right and left.
	
	• Toggle off Hide Objects from the Objects menu.
	Lock Link
	• Select the Lock Link tool from the Link tool group.
	• Option-select the Lock Link tool so it will be the default tool and link the:
	1. Screen Trim to the Product Body
	2. Control Panel to the Product Body
	1. Trackball Trim to the Product Body
	Arrow
	• Hold down the Option key for Mac/F3 for Windows and click on the Arrow tool when finished to make that tool the default tool.
	• Click in the Workspace to deselect the objects.
	
	8. Viewing the Model
	• Open the Views browser in the View menu.
	• From the list of saved views, click on Final View.
	• Close the View browser when finished.
	• Choose Clear Construction Objects from the Objects menu.
	


	The last element of developing the Direction 2000 prototype is viewing the model. MacroModel has the ability to save any number of views. In this demo file, there is a saved view named Final View.
	Notice the View browser is very similar to the Object browser. The Virtual Trackball now tracks the orientation of the view, not the objects here. Notice also that when we select the Final View from the list of saved views that the view has a colored background attached.
	To finally present the prototype we will clear the construction geometry.
	This is the final presentation view of the Direction 2000 prototype in MacroModel! For photorealistic still images, change the materials in the Materials browser from plastic to any number of other material presets and export as a RIB file for PIXAR's RenderMan for both Macintosh or Windows.  For photorealistic animations, natively import into Macromedia's Three-D for the Macintosh or export DXF for import into Autodesk’s 3D Studio™ or Crystal Graphics’ Topas™ for the PC.
	MacroModel's flexibility means that you can even go back and change a model very easily.
	Without a doubt, MacroModel is the tool of choice for a wide variety of design professionals.


