
The smagic.cnt file is missing. Please restore it from the original.



Getting Started

Step 1 - Select Import Wizard from the File Menu.

Step 2 - Select All items from the Startup Group by clicking on each and pressing the Space Bar.

Step 3 - Click the Finish Button

Step 4 - Select Save As from the File Menu

Step 5 - Go to your Windows directory and enter the filename Common and press return

Step 6 - Select Compile Script from the File menu

That’s it……

{button ,AL(`Import Wizard;Save',0,`',`')}    See Also 



How to Create a New Script

To create a blank script, select New from the File Menu.

{button ,AL(`Open;Quickly Re-open a Script;Save',0,`',`')}    See Also 



How to Save a Script

To save a Script select Save As from the File Menu. If you have already Saved. Select Save from the file menu.

Files Names are Important
Files names that are important. If you save you script with the filename common.sms in the windows directory or in
the same location as Startup Magic Interpreter then this is the first script that will run. If you save another script as 
your computername.sms (computername) is the name of your computer in the network settings this will be run 
next after this if you save a script as your username.sms (username) is what you logged into windows 95 or NT 
with. This is run last.    All these must be saved in either the windows directory or in the Startup Magic Interpreters 
directory.

e.g. 
c:\windows\common.sms
c:\windows\skynet.sms
c:\windows\danny.sms

{button ,AL(`New Script;Open;Quickly Re-open a Script',0,`',`')}    See Also 



How to Open a saved Script

To open a saved Script select Open from the file Menu.

{button ,AL(`New Script;Quickly Re-open a Script;Save',0,`',`')}    See Also 



How to Quickly Re-open a Script

A Script that has been opened or saved in the past will be in the Re-open list found in the File Menu. To use this 
feature, select one of the nine possible items in the Re-open menu.

{button ,AL(`New Script;Open;Save',0,`',`')}    See Also 



How to use Import Wizard

What is Import Wizard?

Import wizard looks at your Startup Group and your Run in your Registry and compiles a list of files currently set to
run when you start Windows 95.    You have the option to select items from this list, which will be used in your 
current script. 

To select a item from the Wizard click with the left mouse button on any item that has this [      ] on the start. Then 
press the space bar or double click on the Item. Too un-select an item double click it or press the space bar.

When you have finished selecting. Click on the Finish button. This will transfer the links in to a Startup directory in 
the same location as this program. It will also create backup script so that it can be used to restore the links to 
their previous location.    If you have selected any items from the Run part in the Registry there will be a backup 
Registry file to restore these to.    The backups can be found in the Backup directory where Startup Magic was 
installed. It will then build a script back in the main part of the program.

{button ,AL(`Getting Started',0,`',`')}    See Also 



How to Compile a Script

Creating a script is not enough Startup Magic Interpreter can not use it until it has been compiled to do this you 
select Compile Script from the File Menu.

{button ,AL(`Run',0,`',`')}    See Also 



How to Run a Script

To run a script you must compile it first if you have not Startup Magic Developer will do it automatically for you. To 
run, select Run from the File Menu or press the Ctrl & R keys.

{button ,AL(`Compiling',0,`',`')}    See Also 



How to Cut

To cut a line or multiple select the lines by holding down the shift key and use the cursor keys up or down. To 
select individual lines hold the Ctrl key down and click on the lines with the left mouse button. To cut, select Cut 
from the Edit Menu or press the Ctrl & X keys.

{button ,AL(`Copy;Delete;Paste',0,`',`')}    See Also 



How to Copy

To Copy a line or multiple select the lines by holding down the shift key and use the cursor keys up or down. To 
select individual lines hold the Ctrl key down and click on the lines with the left mouse button. To Copy, select 
Copy from the Edit Menu or press the Ctrl & C keys

{button ,AL(`Cut;Delete;Paste',0,`',`')}    See Also 



How to Paste

To paste the line or lines Click on the line you wish to insert and select Paste from the Edit menu or press the Ctrl 
& V keys.

{button ,AL(`Copy;Cut;Delete',0,`',`')}    See Also 



How to Delete

To delete a line or multiple lines select the lines by holding down the shift key and use the cursor keys up or down. 
To select individual lines hold the Ctrl key down and click on the lines with the left mouse button. To Delete, select 
Delete from the Edit Menu or Press the Delete Key.

{button ,AL(`Copy;Cut;Paste',0,`',`')}    See Also 



Control Palette Summary

Load a 
Program

This button is used to load a 
application.
Settings are : Load Minimized, 
Maximized or Hidden.

Menu
Developer

This button is used to create a Menu or 
Individual Startup Magic Scripts.

Wait

This button creates a pause the number
of seconds of which are defined by you.

Wait for Load

This button creates a pause at the 
beginning of your script. The numbers 
of seconds of which are defined by you.

Locate Script 
Window

This button is used to change the 
location of the script window, choose 
from 9 different locations or choose 
minimize, hidden or show.

Run Script

This button is used to call another script
and when it completed it will return to 
the original to finish.

Prompt

This button is used to request a Yes & 
No response for each command in your
script.

It can be turned on and off at any 
position.

Change 
Desktop

This button is used to change the 
background image on your desktop. 
You can pick a single bitmap or random 
from 
a directory or random from the windows
directory.

No

This button is used to switch off the F8 
prompt on or the F5, Quit button on the 
startup interpreter window.

File Copy

This button is used to copy a single file 
or a directory and its subdirectories to a
destination.

File Delete

This button is used to delete a file.

This button is used to rename a file or a
directory.



File Rename

Change Date

This button is used to change the 
system time.

Show Errors

This button is used to hide any errors 
reported by Startup Magic interpreter.

It can be turned on or off anywhere in 
the script.



Filename
Enter the Application you wish to run e.g notepad.exe. You can run associated files e.g. readme.wri or you can 
browse a directory by entering the directory path e.g c:\windows\. You can even launch a www page if you are 
using Internet Explorer e.g. www.genesoft.demon.co.uk.



Command Line
The command line is used for any files or switches you wish to launch with your application e.g c:\my documents\
readme.doc /P.



Window Style
This is used to set the window style of the application you are launching. It works for associated files or exploring a
directory, but is ignored if you launch a Short cut link.



Browse
Use this to browse for the file you wish to launch.



Menu Titles
Use this to set the titles of the menu.
E.g.
O    Standard Startup
O    Virus Kill Startup
O    Backup Startup



Menu Scripts
Beside the Menu titles enter the name of the script that you wish to run.
E.g.
O    Standard Startup c:\my documents\standard.smc
O    Virus Kill Startup c:\my documents\virus.smc
O    Backup Startup c:\my documents\backup.smc



Auto Launch 1st Item
If you click the check box next to the Auto Launch and enter a number of second the first item in your menu will be 
automatically launched after count down.



Run Script
Use this button to browse for your script you have already compiled for the opposite Menu Item.



Wait
Enter a period of second or you can use the cursor keys up or down.



Vertical Placement
Use this to set the vertical location to Top, Center, Bottom



Horizontal Placement
Use this set the horizontal location to Left, Center, Right.



Visible
Use this to hide, show or minimize the Script Window.



Run Script
Use this to call another script and when it has completed it will return to the original to finish.



Prompt

Select yes or no to turn on or off a request Yes & No response for each command in your script.



Browse
Select a bitmap to change your desktop background.



Try
Use this to see the image on your desktop.



Other Options
Use this to turn on the Random Option.



Random in this Directory
Choose this option to select any bitmap in this directory.



Random in the Windows Directory
Choose this option to select any bitmap in the windows directory.



No F5 - Quit Script
Check this to disable the Quit button and the F5 key.



No F8 - Prompt
Check this to disable the manual Prompt when you press the F8 key.



Source
The source is where the file of files will be copied from. You can select a file or a directory. If you select a directory 
and do not include a back slash ‘\’ at the end then the source directory including the last directory name from the 
source name will be copied. For example: c:\windows\system to the destination c:\temp, a directory called 
system will be created in the temp directory.    If you do include a back slash ‘\’, all the files in source directory are 
copied to the destination. For example: c:\windows\system\ to the destination c:\temp will copy all the files in the
system directory to the c:\temp.



Destination
The destination is where the file or files will be copied to. If you are copying a single file then you do not have to 
include the filename of the destination, for example c:\windows\readme.txt to the destination c:\temp\ the file 
name will be taken from the source. If you do not include a back slash ‘\’ at the end, and the directory does not 
exist the file will be copied to the destination name as a file. For example c:\windows\readme.txt to c:\readme, a 
file will be created in the c:\ root called readme. If you include a backslash ‘\’ at end then it will try to create that 
directory. If you are copying a directory and you do not include a backslash at the end, a directory will always be 
created. You can not copy a directory to a single filename.



Advance
Click on the advance button this will reveal the advanced options. Overwrite All, Overwrite if Newer, Do not 
Overwrite, Confirm if exists, Do not Copy Sub directories, Overwrite Read only files.



Advance - Overwrite All
Check this option to overwrite all files that exist in the destination.



Advance - Overwrite if newer
Check this option to overwrite only if the destination file is older than the source.



Advance - Do Not Overwrite
Check this option to not write over any file in the destination.



Advance - Confirm if they Exist
Check this option to have a request window display before the file is over written.



Advance - Do not Copy the Subdirectories.
Check this option to not copy the subdirectories when you select a directory to copy as the source.



Advance - Overwrite Read Only Files
Check this option to overwrite Read Only Files.



File Requester
Use this button to select a file using the File Requester. If you wish to copy a directory select a file within the 
directory you wish to copy and when you click Open just delete the file name from text box.



What to Delete
Enter the name of the file you wish to delete.



File Requester
Use this to select a file using the File Requester.



Source
Enter the name of the file or directory to rename.



Destination
Enter the name of the file or directory to be renamed to.
E.g. from c:\window\readme.txt to c:\windows\readit.txt



File Requester
Use this button to select a file using the File Requester. If you wish to rename a directory select a file within the 
directory you wish to rename and when you click Open just delete the file name from text box.



Previous Year
Use this to go to the previous year.



Next Year
Use this to go to the next year.



Previous Month
Use this to go to the previous month.



Next Month
Use this to go to the next month.



Select a Day
Use this to select a day from the month.



Show Errors

Select yes or no to turn on or off the error log.



Goto Today
If you changed the date earlier in the script you can change it back to days date by checking the Goto Today 
button.



Latest Information

Just as we are about to release this version a problem arrived. It is to do with the Date command it seem that 
when you change the date the hour sometimes goes on one hour. But instead of holding back the release we fort 
better just notify you of the problem.

If you find any bugs in the Interpreter or even in the Developer please let us know by emailing us on 
BugsUK@genesoft.demon.co.uk and we will display your problem on http://www.genesoft.demon.co.uk/bugs.htm. 
Please check this page before sending in your bug it will help us immeasurably.

Limitations of this Version.
It is a single user version of the developer the scripts will not function if they are run from a network drive. Network
Version to be released later.

You have 30 days to evaluate this program after that the scripts that you have created with the unregistered 
version will time out.

That’s it.

The all Important Wish List.
If there is a feature that is not in Startup Magic. We want to hear from you. We can only make this program better 
with your help.

Please email your Ideas to Ideas@genesoft.demon.co.uk we will also display these on 
http://www.genesoft.demon.co.uk/Ideas.htm. We would like to display your name along with the idea but if do not 
wish it. Please comment in your email.



Registration

Registering Startup Magic

To register Startup Magic, you need to send £20 Sterling in the form of a check or postal order made payable to 
Genesoft Developments. 

You can register Online by Credit Card by going to www.genesoft.demon.co.uk 

If you are unable to send in Sterling then you can register using $35 American Dollars Cash. $40 American 
Dollars for a check.

You must send the following information

Name ................................................

Email (If Known)

...........................................................
Address

...........................................................

...........................................................

...........................................................

...........................................................

To :
Genesoft Developments
Langley House
Derby Road
Langley Mill
Nottingham
NG16 4AN
ENGLAND

When you receive the Name and Password enter it into the appropriate boxes, then Click on OK.

If you have typed it correctly then Startup Magic will report that you are now registered user.

Otherwise re-check and try again.



Limited Warranty & Copyright

© Copyright 1997 - Genesoft Developments. All rights reserved. 

Genesoft Developments
Langley House
Derby Road
Langley Mill
Nottinghamshire
NG16 4AN
England

LIMITED WARRANTY AND DISCLAIMER OF WARRANTY 
 
THIS SOFTWARE AND ACCOMPANYING WRITTEN MATERIALS (INCLUDING 
INSTRUCTIONS FOR USE) ARE PROVIDED "AS IS" WITHOUT WARRANTY OF ANY 
KIND. FURTHER, GENESOFT DEVELOPMENTS DOES NOT WARRANT, GUARANTEE, OR 
MAKE ANY REPRESENTATIONS REGARDING THE USE, OR THE RESULTS OF USE, OF 
THE SOFTWARE OR WRITTEN MATERIALS IN TERMS OF CORRECTNESS, ACCURACY, 
RELIABILITY, CURRENTNESS, OR OTHERWISE. THE ENTIRE RISK AS TO THE 
RESULTS AND PERFORMANCE OF THE SOFTWARE IS ASSUMED BY YOU. IF THE 
SOFTWARE OR WRITTEN MATERIALS ARE DEFECTIVE, YOU, AND NOT 
GENESOFT DEVELOPMENTS OR ITS DEALERS, DISTRIBUTORS, AGENTS, OR 
EMPLOYEES, ASSUME THE ENTIRE COST OF ALL NECESSARY SERVICING, REPAIR, 
OR CORRECTION.
 
THE ABOVE IS THE ONLY WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED,
INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY 
AND FITNESS FOR A PARTICULAR PURPOSE, THAT IS MADE BY 
GENESOFT DEVELOPMENTS, ON THIS GENESOFT DEVELOPMENTS PRODUCT. 
NO ORAL OR WRITTEN INFORMATION OR ADVICE GIVEN BY 
GENESOFT DEVELOPMENTS, ITS DEALERS, DISTRIBUTORS, AGENTS OR EMPLOYEES 
SHALL CREATE A WARRANTY OR IN ANY WAY INCREASE THE SCOPE OF THIS 
WARRANTY AND YOU MAY NOT RELY ON ANY SUCH INFORMATION OR ADVICE. YOU 
MAY HAVE OTHER RIGHTS WHICH VARY FROM STATE TO STATE AND COUNTRY TO 
COUNTRY.
 
NEITHER GENESOFT DEVELOPMENTS NOR ANYONE ELSE WHO HAS BEEN INVOLVED IN 
THE CREATION,    PRODUCTION OR DELIVERY OF THIS PRODUCT SHALL BE LIABLE 
FOR ANY DIRECT, INDIRECT, CONSEQUENTIAL OR INCIDENTAL DAMAGES 
(INCLUDING DAMAGES FOR LOSS OF BUSINESS PROFITS, BUSINESS INTERRUPTION,
LOSS OF BUSINESS INFORMATION, AND THE LIKE) ARISING OUT OF THE USE OR 
INABILITY TO USE SUCH PRODUCT EVEN IF GENESOFT DEVELOPMENTS HAS BEEN 
ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

ACKNOWLEDGMENT
 
BY USING THIS VERSION OF STARTUP MAGIC YOU ACKNOWLEDGE THAT YOU HAVE 
READ THIS LIMITED WARRANTY, UNDERSTAND IT, AND AGREE TO BE BOUND BY 
ITS' TERMS AND CONDITIONS. YOU ALSO AGREE THAT THE LIMITED WARRANTY 
IS THE COMPLETE AND EXCLUSIVE STATEMENT OF AGREEMENT BETWEEN THE 
PARTIES AND SUPERSEDE ALL PROPOSALS OR PRIOR AGREEMENTS, ORAL OR 
WRITTEN, AND ANY OTHER COMMUNICATIONS BETWEEN THE PARTIES RELATING 
TO THE SUBJECT MATTER OF THE LIMITED WARRANTY.




