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Introducing TextPad
TextPad™ 1.31 is a fast and powerful text editor for 16 and 32-bit versions of MS Windows™.    It 
includes the following features:

Huge files can be edited (up to the limits of virtual memory for the 32-bit edition).    See 
Specifications for the actual limits.

Supports Universal Naming Convention (UNC) style names, and long file names with spaces.
CUA compliant keyboard commands.
Multiple files can be simultaneously edited, with up to 2 views per file.
Warm Start feature lets you restart exactly where you left off.
In addition to the usual cut, copy and paste capabilities, selected text can be case shifted and 

block indented, and characters, words and lines can be transposed.    Cut and copied text can be 
appended to the clipboard, as well as replacing its contents.

Text can be automatically word-wrapped at the margin, or at a specified column, if it does not fit 
on a line.    In this mode, text can be split into separate lines where wrapping occurs, or lines can be 
intelligently joined, preserving paragraphs.

OLE2 drag and drop editing for copying and moving text between documents.
Unlimited undo/redo capability.
Block (column) selection mode, and visible display of tabs and spaces.
Text can be automatically aligned and indented, relative to the previous line, to aid block 

indentation.
The right mouse button pops up an in-context menu.
The caret can be constrained to the text, or can be positioned freely in the document view.
Toolbar with fly-by usage hints, and an active status bar.
A powerful search/replace engine using UNIX-style regular expressions, with the power of editor 

macros.    Sets of files in a directory tree can be searched, and text can be replaced in all open documents
at once.

Visible bookmarks can be placed on individual lines, and on all occurrences of a search pattern.    
Bookmarked lines can be cut, copied or deleted.

A built in file manager for fast file copying, renaming, deleting etc.
Print previewing, and printing with customizable headers/footers and page breaks.
Browser for binary files using a hexadecimal display format.
Built in file comparison utility, and up to 16 user-defined tools with argument macros.
Hypertext links from file search and user tool output to the relevant source line.
DDE interface to other tools, such as VC++.    The editor detects when an open file has been 

modified by another tool, and prompts you to reopen it.

Copyright © 1992-1995 Helios Software Solutions
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Specifications
Conforms to MS Windows User Interface Design Guide 4 recommendations.
The editor can handle files with up to 32,500 lines in 16-bit or word-wrapped modes, and up to 

the limits of virtual memory in 32-bit mode.
The maximum line length is 4095 characters.
The number of concurrent edits is limited by available memory.    In the 16-bit edition, the 64KB 

local heap restricts this to a maximum of 28.
Supports Universal Naming Convention (UNC) style, and long file names with spaces.
8-bit text files with DOS, UNIX and Macintosh end of line characters are supported.
Text can be in either the ANSI (Windows) or OEM (DOS) character sets.
Each document has a single MDI window with up to 2 views.
Fonts and tab stops are user selectable (fixed width font for editing).
Up to 16 (user settable)    most    recently used files are listed on the File menu.
Up to 16 user-defined commands can be added to the Tools menu.

Limitations:
The 16-bit edition cannot paste more than 64KB at a time.
Non-OLE drag and drop does not support scrolling.
The 16-bit edition, and the 32-bit edition under Win32s, can only display the output of a user tool 

command in a window after the command has completed.
The 32-bit edition cannot mail files under 16-bit Windows.



What's New
In Previous Releases

The following changes and enhancements have been made for TextPad 1.31:
User settable default for the ANSI or DOS character set.
"Options" on the Configure menu has been renamed "Preferences".
Changes to configuration settings are saved immediately.
Associating file extensions with TextPad must now be done from the Associations tab of the 

Preferences dialog box.    The setup program no longer has that as an option.
Dates and times are displayed according to the Windows regional setting (32-bit only).
Uninstallation now follows the Windows 95 guidelines.
Paths can be omitted from the file names displayed in the Window Selector.    This is set from the 

General tab of the Preferences dialog box.
The startup "splash" message can be disabled using the command line argument "-q".
A different caret is used in overtype mode.
When auto-indent mode is enabled, a "}" is always unindented on an empty line, regardless of 

whether or not the caret is constrained to the text.
The Find Next button on the Replace dialog box stops searching at the end of file, rather than 

wrapping around to the beginning, as happens with the Find dialog box.
When run on NT with the 2nd new shell preview, TextPad now uses the new File Open dialog 

box.
The environment variable COMSPEC is now used to determine which command interpreter to run

for user tools.
Bug Fixes:

On Windows 95, file extensions are now always displayed, regardless of the setting in Explorer.
Scroll bars now operate correctly on NT 3.5.
When switching from word-wrap mode, horizontal scroll bars are now displayed if set on in View 

Preferences.
Double clicking in the margin in word-wrap mode now selects the line as displayed, instead of the

paragraph.
Splitting lines longer than 4095 characters sometimes inserted garbage into a file.
The 32-bit edition could not open some files with particular accented characters in their names.
Starting with argument "-s" cleared the "Save Workspace" flag on exit.
Command line arguments are no longer case sensitive.
CreateProcess error -1 in Run command on NT with the new shell preview.



Changes Made in Previous Releases
The following enhancements were made for TextPad 1.30:

The state of the workspace can be saved between editing sessions, including open documents, 
window positions, bookmarks & fonts.

The Command and Search windows can now be edited, by turning off the read-only property.    
(Double-click Read on the status bar.)

Lines with bookmarks can be cut, copied or deleted.    The Edit menu has been slightly 
rearranged to accomodate the new commands.

A selected block can be filled with a character or string.
The left margin of word-wrapped paragraphs is now aligned with the first line of the paragraph, 

when the Maintain Indentation property is set on the Document tab of the Properties dialog box.
Paragraphs can be line-lengthened when not in word-wrap mode.
The Close All command has been moved from the Window to the File menu.
The Stay on Top command has been added to the System menu.
A word-wrap button has been added to the toolbar.
A file can be printed without bringing up the Print dialog box, by clicking the print button on the 

toolbar.    The Print command on the File menu still displays the dialog box.
Dragging and dropping files on to a printer icon is now supported on Windows 95.
Text can be converted between the ANSI and DOS (OEM) character sets when opening and 

saving files.
The caret can be set to a flashing block, or a vertical bar from the View tab of the Preferences 

dialog box.
If a document is opened read-only because its file has the read-only attribute set, it is 

automatically made editable when the state of the file changes. (Useful for source control systems.)
To avoid problems with file names containing spaces, TextPad now only allows a single file name 

as a command line argument.
The pre-release version of the new shell for NT is supported.

The following enhancements were made for release 1.29:
On Windows 95 and NT, the 32-bit edition uses the Windows Registry, instead of TEXTPAD.INI to

save its settings.
New commands to insert the current date and time were added to the Edit menu.
The installation program automatically registers TextPad's DDE commands.



Getting Assistance While You Work
You can use the on-line help system in various ways to help you as you work:

Press F1 in any context to display help information.    For example, highlight a menu command 
and press F1 to find out what it does.

Click 

 on the toolbar, then click 
 where you want help.

Hold the cursor over a toolbar button to find out what it does.
Use the Contents command on the Help menu to display all help topics.



Technical Support
Important: Please read How to Report Problems before submitting any problem reports.
Technical support is available at no charge by sending electronic mail to:

CompuServe: 100041,235
Internet: textpad@heliosof.demon.co.uk
MSN: HelioSoft

You can also fax queries to +44-(0)1772-324353, or post them to:
Helios Software Solutions
Carr Brook House
Chorley Old Road
Brindle
CHORLEY    PR6 7QZ
England



How to Report Problems
Have you checked the known problems list first?
Please provide at least the following information with any problem report:
1. The version number and edition (16/32-bit) of TextPad.
2. The version of Windows (and Win32s if appropriate) that you're using.
3. Driver manufacturer and version numbers for printer problems.
4. How to reproduce the problem.



Tips
Here are some tips you may find useful:

Remember to make use of the right mouse button.
Double left click in the left margin selects the line.
Ctrl+left click in the left margin selects the whole file.
When you right click a "#include" line in a C/C++ source file, a command to open the included file 

is added to the pop up menu.
To force TextPad to create a new document each time you start it up, specify an empty file name 

in quotes as the command line argument. eg.    TXTPAD32.EXE ""
When using the Save As dialog box, Windows 95 will not let you specify a name without an 

extension, or an arbitrary extension that it does not recognize, unless you select "No Extension" as the 
Save as type.

When the File Open dialog box is enabled for multiple file opening, it does not show long file 
names (except on Windows 95).    This setting can be changed on the General tab of the Preferences 
dialog box.

On Windows 95, you can create directories, and rename and delete files using the File Open 
dialog box, just like in Explorer.

Ctrl+Shift+O brings up a simple dialog box for file opening.
In the Replace dialog box, '\t' is interpreted as a tab in the replacement string, regardless of the 

Regular Expression check box setting.    To replace with the literal characters '\' and 't', you must specify '\\
t' as the replacement string.

After you have saved the Search or Command output results as an ordinary file, it loses its 
hypertext jump property, but you can always load an ordinary file into the Command output window by 
capturing the output from the DOS TYPE command.



Known Problems
The following problems have been identified with this release:
1. Various printer drivers do not work with Win32s (eg. HP DeskJet and Citizen Swift).    The symptoms 

are that TextPad 32 goes through the motions of printing a file, but it never gets printed.    Try using a 
compatible driver from the standard list of Windows printer drivers, instead of the one that comes 
with the printer, or contact your supplier for an updated driver.    You can get PCL driver 6.1d, to fix 
the problem with HP DeskJets, from CompuServe forum HPPERIPHERALS.

2. If you use TextPad 16 and you have an HP LaserJet 4M with the Adobe printer driver, you must use 
version 3.01 or later.    This can also be downloaded from CompuServe forum HPPERIPHERALS.

3. WinFax Pro 4 does not work with 32-bit applications that use Win32s to run on 16-bit Windows.    
Therefore you must use the 16-bit edition of TextPad if you want to use it to send faxes on Windows 
3.1x.



Obtaining Updates
New releases of TextPad will be made available for downloading from various sites, including:
CompuServe forums WINUTIL and WINPROD, as:

TPAD16.ZIP (16-bit edition)
TPAD32.ZIP (32-bit edition)

The SimTel WWW server at http://www.coast.net/SimTel/, and their FTP server at 
ftp://ftp.coast.net/SimTel/ as:
/simtel/win3/editor/txp16???.zip (16-bit edition)
/simtel/win95/editor/txp32???.zip (32-bit edition)

Note: To maintain full access rights, registered users must keep their original license file from the 
installation disk with each new release.



How to Uninstall TextPad
From Windows 95:
1. Click the Start menu and select Settings/Control Panel.
2. Double click Add/Remove Programs.
3. Select TextPad from the list and click Add/Remove.
4. Confirm that you want to uninstall TextPad.
5. When Uninstall has finished, use Explorer to manually delete the installation directory, and the 

uninstall program.

From Other Versions of Windows:
1. Run UNINSTAL.EXE (or UNINST16.EXE) from your installation directory.
2. Confirm that you want to uninstall TextPad.
3. When Uninstall has finished, use File Manager to manually delete the installation directory, and the 

uninstall program.
4. Manually delete any Program Manager icons and groups for TextPad.

A Note About File Associations:
Any file associations that you have made with TextPad 1.31 or later will revert back to their defaults 
when you uninstall TextPad.    If you have previously associated any file extensions with TextPad, and 
you want to set them back to their default associations at any time:
1. Run File Manager (WINFILE.EXE)
2. Select any file with the given extension.
3. From the File menu, choose the Associate command.
4. Make the corresponding association from the following table:

.BAT MS-DOS Batch File

.INF Setup Information

.INI Configuration Settings

.REG Registration Extries

.TXT Text Document



How to Create a New File
To create a new unnamed document:
From the File menu, choose New.

Toolbar: 

The new document may be given a name using the Save As command on the File menu.

To create a new named file:
1. From the File menu, choose Open (Ctrl+O).    The File Open dialog appears.

Toolbar: 

2. In the Directories box, double-click a directory where you want to store the source file (or move up or
down a path to the appropriate directory).

3. Type the file name in the File Name box, and click OK. The default extension given to a file is .TXT, 
unless you specify something else.

4. Click Yes on the message box that appears, asking if you want to create the file.
5. Use the editor to type the contents of the file.



How to Open an Existing File
1. From the File menu, choose Open (Ctrl+O).    The File Open dialog appears.

Toolbar: 

2. Select the drive and directory where the file is stored.    The default is the current drive and directory.
3. Set the types of files to display in the List Files of Type box.    Files with the chosen extension are 

displayed in the File Name box.    This box serves as a filter to display all files with a given extension. 
For example, Source (*.cpp,*.c,*.h) displays all files with the given extensions. The drop-down box 
initially lists commonly-used file extensions.    Alternatively, you can specify wildcard patterns in the 
File Name box to display file types.    The new wildcard pattern is retained until the dialog box is 
closed.    You can also use any combination of wildcard patterns, delimited by semicolons.    For 
example, entering "*.TXT; *.INI" displays all files with those extensions.

4. If you want to override the automatically determined file format, choose from the drop-down list as 
follows:

File 
Type:

Definition:

Auto A file with an extension matching the internal list 
of binary extensions will be viewed in 
hexadecimal, otherwise it will be opened as a 
text file.

Text The file is read as text in the selected character 
set.

Binary The file is binary and will be viewed in 
hexadecimal.

5. If you want to disable edits to the file, check the Read Only box.
6. In the File Name box, click a filename, then click OK. 
Shortcut: Double-click a filename.

Tips:
You can select multiple files to open at once, by using Ctrl+Left button to select each in turn, or 

Shift+Left button to select a range of files.
The use of spaces for multiple file opening conflicts with long file names (except on Windows 95),

so to see long file names in the File Open Dialog, uncheck Use Multiple File Open Dialog Box on the 
General tab of the Preferences dialog box.



How to Open a Hex View of a File
1. From the File menu, choose Open (Ctrl+O).    The File Open dialog appears.

Toolbar: 

2. Select the file to open.
3. Click the down arrow next to the File Format box.
4. Choose "Binary" from the drop-down list.
5. Click OK.

Tips:
You can select multiple files to open at once, by using Ctrl+Left button to select each in turn, or 

Shift+Left button to select a range of files.
The use of spaces for multiple file opening conflicts with long file names (except on Windows 95),

so to see long file names in the File Open Dialog, uncheck Use Multiple File Open Dialog Box on the 
General tab of the Preferences dialog box.



Binary File Extensions
The following file extensions are assumed to be associated with files containing binary, or non-textual 
data:
.COM .EXE .DLL .SYS .DRV .386 .DOS .VBX
.LIB .OBJ .PIF .RES .SYM .BIN .ZIP
.FON .FOT .TTF .MID .WAV .GRP
.WMF .TIF .PCX .BMP .CUR .ICO
.HLP .PPT .DOT .WRI .MDB .DBF .FRX
.XLS .IMP .WK1 .WK2 .WK3 .WK4 .TWS



How to Save a File
1. Switch to the source window.
2. From the File menu, choose Save (Ctrl+S).

Toolbar: 

3. If your file is unnamed, the environment displays the Save As dialog box . In the File Name box, type 
the filename.

4. In the Drives and Directories boxes, select a drive and directory.
5. Click OK.



How to Save a File with a Different Name
1. From the File menu, choose Save As.    The File Save As dialog appears.
2. Select the drive and directory where the file is to be stored.    The default is the current drive and 

directory.
3. Choose the File Format if you want to convert from the original.
4. Check the DOS character set box if you want the file saved with the DOS OEM character set, 

otherwise uncheck it for the Windows ANSI character set.
5. In the File Name box, type the filename.
6. Click OK. 



How to Save the Workspace
You can arrange for TextPad to "warm start" - that is, start up exactly where you left off when you last 
shut it down.    To enable this feature:
1. Choose Preferences from the Configure menu.    This brings up the Preferences dialog box.
2. On the General tab, check "Save the Workspace".
3. Click OK.

Notes:
The workspace is preserved in a file called TEXTPAD0.TWS in your Windows directory.
If more than one instance of TextPad is running, only the workspace of the first one to be started 

will be preserved.
If TextPad is started up with the command line argument "-s" (which is how DDE starts it), the 

workspace is not restored, nor saved when you exit.
On Windows 95, if this option is enabled and you shut down Windows whilst TextPad is still 

running, it will be automatically restarted when Windows starts up again.



How to Convert a File for DOS, Unix or Mac
1. From the File menu, choose Save As.    The File Save As dialog appears.
2. Select the drive and directory where the file is to be stored.    The default is the current drive and 

directory.
3. In the File Name box, type the filename.
4. Choose the file format from the drop-down list as follows:

Charact
er Set:

Definition:

PC The file is saved in DOS PC format with a 
carriage return/line feed at the end of each 
line.

Unix The file is saved in the Unix format with a 
line feed at the end of each line.

Mac The file is saved in the Apple MAC format 
with a carriage return at the end of each line.

5. Check the DOS character set box if you want the file saved with the DOS OEM character set, 
otherwise uncheck it for the Windows ANSI character set.

6. Click OK. 



How to Close a File
1. Switch to the file's window.
2. From the File menu, choose Close. This action closes the active window and any additional views of 

the window.

Tip:
When the Window Selector has the input focus, pressing the Delete key closes the highlighted file.



How to Set the Default File Folder
You can change the default file folder (or working directory) for TextPad, by changing the way TextPad is 
started.    See under the appropriate heading below for how to do this with the version of Windows that 
you have.

From a Program Manager Icon:
1. Click the Program Manager icon for TextPad.
2. Type Alt+Enter to get its properties dialog box.
3. Fill in the Default Directory field with the required directory, and click OK.

From a Desktop Icon:
1. Right click the desktop icon for TextPad.
2. Choose Properties to get the properties dialog box.
3. Fill in the Start In field on the Shortcut tab with the required folder name, and click OK.

From the Taskbar Start Menu:
1. Right click the Taskbar.
2. Choose Properties to get the Taskbar Properties dialog box.
3. Click the Advanced button on the Start Menu Programs tab.
4. Select "Programs" on the Explorer view.
5. Right click TextPad on the right hand pane, and choose Properties.
6. Select the Shortcut tab, and fill in the "Start In" field with the required folder name.
7. Click OK to close all the dialog boxes.

Tip:
To keep TextPad's current working directory in the chosen folder, uncheck "Directory follows Active 
Document" on the General tab of its Preferences dialog box.



How to Switch to a File's Window
Do one of the following:
Click anywhere in the window.
Choose the window name from the Window menu.
Double click the window name in the Window Selector.
Press Ctrl+F6 or Ctrl+TAB to cycle through the active source windows one at a time.



How to Create a Second View
Using the Keyboard:
1. From the Window menu, choose Split.
2. Use the up and down arrows to move the horizontal bar to where you want to split the window.
3. Press Enter to create the second view, or Escape to cancel.

Using the Mouse:
Drag  from the top of the scroll bar to where you want to split the window.



How to Use the Window Selector
The Window Selector is a list box showing the each of the files you are editing.    You can display it by 
choosing Use Selector (F11) from the Window menu.
The Window Selector displays the files in alphabetical order, and it can be resized to fit the file names it 
lists.    Its size and position are remembered between sessions.
You can use the following keys when the Window Selector is active:

Use this Key: To Do This:
Esc Close the Window Selector.
Left Click Select the file window.
Left Double Click Select and activate the file window.
Enter Activate the file window.
Delete Close the selected file window.
Up Arrow Select the previous window in the list.
Down Arrow Select the next window in the list.
Home Select the first window in the list.
End Select the last window in the list.



How to Print a File
1. Switch to the files window.
2. From the File Menu, choose Print.    The Print dialog box appears.
3. Click "All" for the print range.
4. Click OK.

Shortcuts:
Toolbar: (Prints to the default printer.)

Keys: Ctrl+P



How to Display a Page Before Printing
1. From the File Menu, choose Print Preview.
2. Click OK.    The print preview mode will be set, starting at the page containing the caret.
3. Click Next Page or Prev Page to see each page in turn.
4. Click Close to return to normal viewing mode.

Shortcuts:
Toolbar:

Keys: Ctrl+Shift+P



How to Copy a File
1. From the File Menu, choose Manage Files (F3).    The Manage Files dialog appears.

Toolbar: 

2. Type the name of the file that you want to copy.    This may include a path if it is not in the current 
working directory.    The filename may be a wildcard pattern if you want to copy multiple files.

3. Click Copy.    The Copy dialog appears.
4. Type the name that you want to give the copy.    If this is just a pathname, the file is copied to that 

directory, keeping its original file name.
5. Click OK.



How to Rename a File
1. From the File Menu, choose Manage Files (F3).    The Manage Files dialog appears.

Toolbar: 

2. Type the name of the file that you want to rename.    This may include a path if it is not in the current 
working directory.    The filename may be a wildcard pattern if you want to rename multiple files.

3. Click Rename.    The Rename dialog appears.
4. Type the new name that you want to give the file.    If this is just a pathname, the file is moved to that 

directory, keeping its original file name.
5. Click OK.



How to Delete a File
1. From the File Menu, choose Manage Files (F3).    The Manage Files dialog appears.

Toolbar: 

2. Type the name of the file that you want to delete.    This may include a path if it is not in the current 
working directory.    The filename may be a wildcard pattern if you want to delete multiple files.

3. Click Delete.    The Delete dialog appears.
4. Click OK to confirm that you really want to delete the file.



How to Update a File's Time Stamp
1. From the File Menu, choose Manage Files (F3).    The Manage Files dialog appears.

Toolbar: 

2. Type the name of the file that you want to update its last modified date to the current time.    This may
include a path if it is not in the current working directory.    The filename may be a wildcard pattern if 
you want to update multiple files.

3. Click Touch.    The Touch dialog appears.
4. Click OK to confirm that you really want to update the file.



How to Compare Text Files
1. From the Tools menu, choose the Compare Files command.    The Compare Files dialog appears.
2. In the First File box, type the name of the first file to be compared.    This is initialised with the 

filename of the active document, if appropriate.
3. In the Second File box, type the name of the second file to be compared.    If it has the same name in

another directory, just type the path name.
4. Click OK to start the comparison.

The differences are written to the Command Output window using the following conventions:
Symbol: Meaning:
< Precedes each different line from the first file.
> Precedes each different line from the second file.
a Means that the lines following were added.
d Means that the lines following were deleted.
c Means that the lines following were changed.
--- Separates changed lines in the first file from the 

second.



How to Move Around in Text
To Move the Caret: Press This Key:
To a specified line number Ctrl+G and type the line 

number
To the mouse cursor position Left button
To the beginning of the file Ctrl+Home
To the End of the file Ctrl+End
To first non-space on a line Home
To the start of a line Home
To the end of a line End
Forward one character Right arrow
Back one character Left arrow
Down one line Down arrow
Up one line Up arrow
Forward one word Ctrl+F or Ctrl+Right arrow
Back one word Ctrl+B or Ctrl+Left arrow
Forward to end of current word Ctrl+E
Back to end of previous word Ctrl+D
Scroll down one line Ctrl+Down arrow
Scroll up one line Ctrl+Up arrow

Caret Mode:
The caret can be constrained to positions within the existing text only, or can be free to be placed 
anywhere in the document window.    This setting is changed with the Constrain Caret command on the 
Configure menu.
When the caret is constrained, the left and right arrows wrap around to the previous or next line at the 
beginning and end of a line respectively.
In block selection mode, the Constrain Caret command is disabled.



How to Select Text
Text can be selected in block (column) or normal mode.    Use the Block Select Mode command on the 
configure menu to switch between modes.

To select any text with the mouse:
1. Press and hold the left button down at the start of the text you want to select.
2. Drag the cursor to the end of the selection, and release the button.

or
1. Click the left button at the start of the selection.
2. Hold the Shift key down and click the left button at the end of the selection.

To select any text using the keyboard:
1. Use any of the caret motion keys to move the caret to the start of the text you want to select.
2. Press and hold the shift key down whilst using the motion keys to move the caret to the end of the 

selection.

To select a word:
Move the cursor over the word and double click the left button.

To select a whole line:
Double click the left button in the left margin, next to the line.

To select a block of text:
1. Choose Block Select Mode from the Configure menu.

Shortcut: Alt+Left click toggles block select mode on and off.
2. Use the keyboard or mouse to mark the selection as normal.

To select the whole file:
Choose Select All from the Edit menu.
or
Click Ctrl+Left button anywhere in the left margin.

To cancel a selection:
Press ESC.



How to Use the Clipboard
To insert text from the clipboard:

Position the caret and choose the Paste (Ctrl+V) command from the Edit menu.

Toolbar: 

To copy selected text to the clipboard:
Choose the Copy (Ctrl+C) command from the Edit menu.

Toolbar: 

To move selected text to the clipboard:
Choose the Cut (Ctrl+X) command from the Edit menu.

Toolbar: 

To move the line containing the caret to the clipboard:
Cancel any selection (ESC) and choose the Cut Line (Ctrl+Y) command from the Edit menu.

To move the word containing the caret to the clipboard:
Cancel any selection (ESC) and choose the Cut Word (Ctrl+Q) command from the Edit menu.

To copy all bookmarked lines to the clipboard:
Choose the Copy Bookmarked Lines command from the Edit menu.

To move all bookmarked lines to the clipboard:
Choose the Cut Bookmarked Lines command from the Edit menu.

To append text to the existing contents of the clipboard:
Choose one of the Cut Append or Copy Append commands from the Edit menu.



How to Drag and Drop
You can use the mouse to move or copy text within a document, or to another document, as follows:

To move selected text:
1. Hold the left button down in the selection.
2. Drag the caret to the new location.
3. Release the left button.

To copy selected text:
1. Hold Ctrl+Left button down in the selection.
2. Drag the caret to the new location.
3. Release the left button.

To cancel a drag-drop:
Press ESC, or
Click the right button, or
Release the left button in the selection.

Notes:
1. The Ctrl key can be pressed or released at any time before releasing the left button, to make the 

drag a copy or a move.
2. If the new location is not visible, hold the cursor at the edge of the window nearest to the destination,

and it will scroll through the file until the cursor is moved away.



How to Delete Text
You can delete by character, word, selection or the whole document as follows:

To Delete This: Do This:
Selected text Delete or Backspace
The next character Delete
The previous character Backspace
To the start of the next word Ctrl+Delete
Back to the last start of word Ctrl+Backspace
Lines with bookmarks Choose the Delete Bookmarked 

Lines command from the Edit 
menu.

The whole document Alt+Delete

See Also:
How to Use the Clipboard for commands to save deleted text on the clipboard.



How to Change Case
Select the text to be changed, and then:

To Do This: Use this Edit Menu Command:
Change all to lower case Lower Case (Ctrl+L)
Change all to upper case Upper Case (Ctrl+U)
Invert the case of each character Invert Case (Ctrl+K)
Make the first character of each word 
upper case and the rest lower case

Capitalize (Ctrl+Shift+U)

How to Indent Lines
To increase the indentation of multiple lines:

1. Select the lines to be indented.
2. Choose Indent (Tab) from the Edit menu.

Toolbar: 

To reduce the indentation of multiple lines:
1. Select the lines to be unindented.
2. Choose Unindent (Shift+Tab) from the Edit menu.

Toolbar: 

To change the indentation level of a single line:
Either use the toolbar commands, or delete or insert tabs at the beginning of the line.

Note:
The indentation level of lines changes by increments of the indent size, which can be changed on the 
Tab Settings property sheet.



How to Join Lines
You can join single or multiple lines, such that each line in turn is appended to the first, separated by a 
single space.

To join a single line to the current line:
1. Cancel any selection (ESC).
2. Choose Join Lines (Ctrl+J) from the Edit menu.

To join multiple lines to the current line:
1. Select all the lines to be joined.
2. Choose Join Lines (Ctrl+J) from the Edit menu.

Word-Wrap Joins
When multiple lines are joined in word-wrapping mode, empty lines are treated as paragraph marks.    
So a new sequence of joined lines is started after each blank line, preserving the original paragraphs.



How to Split Long Lines
In word-wrapping mode, you can split long lines into separate lines where they are wrapped, as follows:
1. Select the lines to split.    (Note: Ctrl+Left button in the margin selects all.)
2. Choose Split Wrapped Lines (Ctrl+Shift+J) from the Edit menu.



How to Insert New Lines
To Create a New Line: Press This Key:
After the current line Ctrl+I or End Enter
Before the current line Ctrl+Shift+I or Home Enter
By splitting the current line Enter

How to Insert the Date or Time
You can insert the current date and time, using the formats defined with Control Panel's International 
applet, as follows:

To Insert this: Choose this Edit Command:
The current time Insert Time
Today's date in short format Insert Short Date
Today's date in long format Insert Long Date

How to Insert a Page Break 
1. Move the caret to the first line to be printed on a new page.
2. Choose Insert Page Break (Ctrl+Shift+L) from the Edit menu.

More Information:
This actually inserts the ASCII 0x0C (Ctrl+L) character in the text, but displays it on the screen as «, and 
draws a line at the point where the page break would occur on a printer.
The Page Break character is only recognised when it is the first character of a line.



How to Insert a File
1. Move the caret to the insertion point.
2. Choose Paste File from the Edit menu.    The File Open dialog appears.
3. Select the file you want to insert.
4. Click OK.



How to Transpose Text
To transpose adjacent characters:
1. Move the caret between the two characters to be transposed.
2. Choose Transpose Characters (Ctrl+T) from the Edit menu.    The characters will be swapped 

around.

To transpose adjacent lines:
1. Move the caret to the end of the first line, or start of the second line.
2. Choose Transpose Lines (Ctrl+T) from the Edit menu.    The lines will be swapped around.

To transpose adjacent words:
1. Move the caret between the two words to be transposed.    This may be on a space, or intervening 

punctuation, or the beginning or end of a line.
2. Choose Transpose Words (Ctrl+Shift+T) from the Edit menu.    The words will be swapped around.



How to Fill Blocks
You can fill a selected block of text with a repeating sequence of characters as follows:
1. Set Block Select Mode from the Configure menu.
2. Select the block of text that you want to fill.
3. Choose the Fill Block command from the Edit menu.
4. In the Fill Selected Block dialog box, enter the characters you want to fill with.
5. Click OK.

Notes:
If the block to be filled is wider than the number of characters to fill with, they are repeated to the 

full width, but each line starts with the first fill character.
To fill with a tab, enter "\t" (without the quotes).    If you actually want to fill with the characters "\t", 

enter it as "\\t".



How to Cancel the Last Action
To cancel the last edit:

Choose Undo (Ctrl+Z) from the Edit Menu

Toolbar: 

To cancel the last undo:
Choose Redo (Ctrl+A) from the Edit Menu.

Toolbar: 

To cancel all edits:
Type Ctrl+Shift+Z.

To redo all edits:
Type Ctrl+Shift+A.

Note:
The Undo command can be repeated until all changes made since the file was opened, or last saved, 
have been undone.



The Status Bar

The status bar is displayed at the bottom of the main window.    To display or hide the status bar, use the 
Preferences command in the Configure menu.
The left pane of the status bar describes the actions of menu items as you use the arrow keys to 
navigate through menus.    This area similarly shows messages that describe the actions of toolbar 
buttons as you depress them, before releasing them.    (If after viewing the description of the toolbar 
button command you wish not to execute the command, then release the mouse button while the pointer
is off the toolbar button.)
The right hand panes of the status bar indicate the following information:
Indicator Description
1 The line number of the caret.
2 The column number of the caret.
Read The file is read-only, otherwise Edit is shown.
Ovr The Insert key is latched down, otherwise Ins is shown.
Block Block or Normal selection mode, or Wrap for word wrap mode.
Caps The Caps Lock key is latched down.
Scrl The Scroll Lock key is latched down.
3.50pm The current time.

The status bar is active.    This means that you can double left click any of its panes (except for Time) to 
change the indicated state.



The Toolbar

The toolbar is displayed across the top of the main window, below the menu bar.    The toolbar provides 
quick mouse access to many commands.
To display or hide the toolbar, use the Preferences command in the Configure menu.

Click To
Open a new document.
Open an existing document.    This displays the Open 
dialog box, in which you can locate and open the 
desired file.
Save the active document with its current name.    If 
you have not named the document, the Save As 
dialog box is displayed.
Display the Manage Files dialog.    This allows you to 
copy, rename, delete and update files.
Print the active document.
Preview the printed layout of the active document.
Remove selected data from the document and stores 
it on the clipboard.
Copy the selection to the clipboard.
Insert the contents of the clipboard at the insertion 
point.
Cancel (undo) the last edit command.
Cancel the last Undo command
Reduce indentation of selected text.
Increase indentation of selected text.
Enable word wrapping (this button is latched down).

Display the Find dialog.    This allows you to specify 
text to search for in the active document.
Display the Replace dialog.    This allows you to find 
and replace text.
Display the Find in Files dialog.    This allows you you 
search for text in multiple files.
Jump to the previous item in the search or command 
window.
Jump to the next item in the search or command 
window.
Display a cursor to click on an item you require help 
on.



The Keyboard
Key Modifier Command
A Ctrl Redo last Undo
A Ctrl+Shift Redo All Undos
B Ctrl Move caret back to start of word
B Ctrl+Shift Select back to start of word
C Ctrl Copy selection to clipboard
C Ctrl+Shift Append selection to clipboard
D Ctrl Move caret back to end of word
D Ctrl+Shift Select back to end of word
E Ctrl Move caret forward to end of word
E Ctrl+Shift Select forward to end of word
F Ctrl Find next instance of search pattern
F Ctrl+Shift Find previous instance of search pattern
G Ctrl Go to line
I Ctrl Insert new line after current line
I Ctrl+Shift Insert new line before current line
J Ctrl Join selected lines
J Ctrl+Shift Split word-wrapped lines
K Ctrl Invert case of selection
L Ctrl Convert selection to lower case
L Ctrl+Shift Insert a page break
M Ctrl Find matching { [ ( or ) ] }
M Ctrl+Shift Select to matching { [ ( or ) ] }
N Ctrl Create a new document
O Ctrl Open a document using common File Open dialog box
O Ctrl+Shift Open a document by typing its name
P Ctrl Print active document
P Ctrl+Shift Preview the active document as it will print.
Q Ctrl Cut the word containing the caret to the clipboard
Q Ctrl+Shift Cut and append the word containing the caret to the 

clipboard
S Ctrl Save the active document
S Ctrl+Shift Save all documents
T Ctrl Transpose the lines or characters either side of the caret
T Ctrl+Shift Transpose the words either side of the caret
U Ctrl Convert selection to upper case
U Ctrl+Shift Convert first character of selection to uppercase and the 

rest lower case
V Ctrl Paste text from the clipboard
V Ctrl+Shift Paste the contents of a file at the caret position.
W Ctrl Move caret forward to start of word
W Ctrl+Shift Select forward to start of word
X Ctrl Cut the selection to the clipboard
X Ctrl+Shift Cut and append the selection to the clipboard
Y Ctrl Cut the line containing the caret to the clipboard
Y Ctrl+Shift Cut and append the line containing the caret to the 

clipboard



Z Ctrl Undo last edit
Z Ctrl+Shift Undo all edits
0-9 Alt Run user tool 0,1,...,9
0-5 Alt+Shift Run user tool 10,11,...,15
Break Ctrl Stop the tool running in the command window (only under

32-bit versions of Windows)
Backspace Delete selection, or character before the caret.
Backspace Ctrl Delete back to the last start of word.
Delete Delete selection, or character after the caret.
Delete Ctrl Delete forward to the next start of word.
Delete Alt Delete all lines in the document
Enter Start a new line in an edit document, or do a hypertext 

jump in a log document.
Enter Alt Display in-context properties dialog box
Escape Cancel any existing selection
Scroll Lock Locks caret position when scrolling with page up/down 

keys.
Tab  Indent selected lines, or move caret to next tab stop
Tab Ctrl Next window (same as Ctrl+F6)
Tab Shift Un-indent selected lines, or move caret to previous tab 

stop
F1  In-context help
F1 Ctrl Display document statistics on status bar
F1 Shift Invoke in-context help cursor
F2  Go to next bookmark
F2 Ctrl Set or clear a bookmark on the current line
F2 Shift Go to previous bookmark
F2 Ctrl+Shift Clear all bookmarks
F3  Invoke the Manage Files dialog box
F3 Alt Invoke Windows File Manager or Explorer
F4  Hypertext jump to next item in Search or Command 

Output window
F4 Shift Hypertext jump to previous item in Search or Command 

Output window
F5  Invoke the Find dialog box
F5 Ctrl Invoke Find in Files dialog box
F6  Activate next view
F6 Ctrl Activate previous view
F8  Invoke Replace dialog
F8 Ctrl Replace next instance of search pattern
F9  Find matching { [ ( or ) ] }
F9 Shift Select to matching { [ ( or ) ] }
F10 Invoke the main menu
F10 Shift Invoke document in-context popup menu
F11 Invoke Window Selector
F11 Ctrl Activate the Command Output window
F11 Shift Activate the Search Output window
F12 Shift Switch in and out of word-wrap mode





The Mouse
Cursor Positioning:
To set the insertion position with the mouse, click the left mouse button when the mouse cursor is at the 
required character position.    You can set it to the start of a line by clicking in the left margin next to the 
line.

Text Selection:
To: Do this with the left mouse button:
Select any text Click on the first character and drag to 

the last.
Select a single word Double click on the word.
Select an entire line Double click in the left margin next to 

the line.
Select the entire file Press Ctrl and click in the left margin.
Extend the current selection Press Shift and click or drag to the new

last character position.



How to Find Text
You can find each occurrence of a combination of any characters, including uppercase and lowercase 
characters, whole words, or parts of words, or regular expression.

To find text:
1. From the Search menu, choose Find (F5).    This starts a modeless dialog box which remains on the 

screen until you close it.

Toolbar: 

2. In the Find What box, type in the search string, or choose a previous string from the drop-down list.
3. Set the options you want to control the search.

Select: To:
Text Specify a text search 

string.
Hex Specify a search string 

in hexadecimal.
Match Whole
Word

Find occurrences of the 
text as a whole word.

Match Case Find text having the 
given pattern of 
uppercase and 
lowercase letters.

Regular 
Expression

Specify that the search 
string is a regular 
expression.

Backwards Search the document 
above the insertion 
point.

Forwards Search the document 
below the insertion 
point.

4. Choose Find Next. If the search string is found, the screen scrolls so you can see the text in context.
 or
Choose Mark All to place a bookmark on each line containing the search string.

5. Either close the dialog by pressing the Cancel button, or continue editing as normal.

Tips
1. The Find What box will be initialised with the current selection, if any (as long as it is on a single 

line), or the last search pattern entered.
2. The Find Next command (Ctrl+F) will copy the current selection to the Find What box.
3. To do a forward search after closing the dialog box, press Ctrl+F.
4. To do a backwards search after closing the dialog box, press Ctrl+Shift+F.
5. Match Whole Word is equivalent to the regular expression \<RE\>.
 Examples



How to Replace Text
You can find and replace each or every occurrence of a text pattern, in the current file, or all loaded files.

To Replace Text:
1. From the Search menu, choose Replace (F8).    This starts a modeless dialog box which remains on 

the screen until you close it.

Toolbar: 

2. Specify the text to replace as described in Finding Text.
3. Type the Replacement Expression in the Replace With box, or choose a previous string from the 

drop-down list.
4. Set the scope of the search:

Select: To:
Active 
Document

Search in current 
document only.

Selected 
Text

Search in currently 
selected text in current 
document.

All 
Documents

Search in all text in all 
open documents.

5. Choose one of the following actions:
a) Press Find Next to select the next occurrence.
b) Press Replace to replace the current selection.
c) Press Replace All to replace all occurrences of the search text.

6. Either close the dialog by pressing Cancel, or continue editing as normal.

Tips:
The Replace button will replace the current selection, so make sure you press Find Next first.
Because edit controls do not allow tabs to be input, '\t' is used (without the quotes) to represent a 

tab.    If you want to replace text with literal '\' and 't' characters, specify '\\t' in the Replace With box.
 Examples



How to Find in Multiple Files
You can search for strings in either text (excluding Unicode) or binary files, as follows:
1. From the Search menu, choose the Find in Files command (Ctrl+F5).    This starts a modeless dialog

box which remains on the screen until you close it.

Toolbar: 

2. In the Find What box, either type the search string, or choose a previous string from the drop-down 
list.    (Check that Text or Hex is correctly set for the type of string in the Conditions box.)

3. In the In Files box, either type a list of files using wild cards, or choose a previous list from the drop-
down list.

4. In the In Directory box, either type the pathname to the directory containing the files, or select a 
previous directory from the drop-down list, or click Defaults to set it to the current working directory.

5. In the Conditions box, specify the search criteria as follows:
Select: To:
Text Specify a text search 

string.
Hex Specify a search string 

in hexadecimal.
Match Whole
Word

Find occurrences of the 
text as a whole word.

Match Case Find text having the 
given pattern of 
uppercase and 
lowercase letters.

Regular 
Expression

Specify that the search 
string is a regular 
expression.

6. In the File Type box, choose Text if the files contain text, or Binary if they contain any NULL 
characters.

7. In the Report Detail box, choose All Matching Lines if you want each matching line printed out, or File
Counts Only if you simply want to know how many occurrences there are in each file.

8. Click Search Subdirectories if you want to search through all files in the subdirectories of the 
directory specified in step (4) as well.

9. Click Find.

Hypertext Jumps:
Matching strings are listed in the Search Output window.    You can use this to jump to a line in its file by 
double clicking the line.
To jump to the next occurrence, choose the Jump Next (F4) command from the Search menu.

Toolbar: 

To jump to the previous occurrence, choose the Jump Previous (Ctrl+F4) command from the Search 
menu.

Toolbar: 



How to Find a Matching Bracket
To Find a Matching Bracket:
1. Place the caret to the left of the bracket to be matched:    ([{ or }])
2. From the Search menu, choose the Match Brace command (Ctrl+M).    If there is a matching brace, it

will be selected.

To Select Text Between Brackets:
1. Place the caret to the left of the bracket to be matched.
2. Type Ctrl+Shift+M.    If there is a matching brace, all intervening text will be selected.    When 

matching forwards, both brackets are selected as well.    When matching backwards, neither bracket 
is selected.



How to Use Bookmarks
To Set a Bookmark:
Lines can have bookmarks placed on them either by choosing the Toggle Bookmark command (Ctrl+F2)
from the Search menu, or by clicking Mark All on the Find dialog.

To Go to the Next Bookmark:
From the Search menu, choose the Next Bookmark command (F2).

To Go to the Previous Bookmark:
From the Search menu, choose the Previous Bookmark command (Shift+F2).

To Clear a Single Bookmark:
From the Search menu, choose the Toggle Bookmark command (Ctrl +F2).

To Clear all Bookmarks:
From the Search menu, choose the Clear All Bookmarks command (Ctrl+Shift+F2).

To Delete all Bookmarked Lines:
From the Edit menu, choose the Delete Bookmarked Lines command.

To Copy all Bookmarked Lines to the Clipboard:
From the Edit menu, choose the Copy Bookmarked Lines command.

To Cut all Bookmarked Lines to the Clipboard:
From the Edit menu, choose the Cut Bookmarked Lines command.



Examples - Finding Text
See Also: Regular Expressions
1.    Find all trailing spaces:

[ \t]+$
finds one or more spaces or tabs followed by the end of line.

2.    Find an empty line:

^$
finds the beginning of a line immediately followed by its end.

3.    Find everything on a line:

^.*
finds the beginning of a line, followed by zero or more of any characters, up to the end of the line.

4.    Find "$12.34":

\$12\.34
Note that '.' and '$' have been escaped using the backslash to hide their regular expression 
meanings.

5.    Find any valid C language variable name:

\<[ a-zA-Z][ a-zA-Z0-9]*
finds a word starting with an underscore or alphabetic character, followed by zero or more 
underscores or alphanumeric characters.

6.    Find an inner-most bracketed expression:

([^()]*)
finds a left bracket, followed by zero or more characters excluding left and right brackets, followed by
a right bracket.

7.    Find a repeated expression:

\([0-9]+\)-\1
This uses a tagged expression "\(...\)" to find one or more digits, followed by a hyphen, followed by 
the string matched by the tagged expression.    So this regular expression will find 12-12, but not 12-
34.



Examples:    Replacing Text
See Also: Replacement Expressions
1.    Find any alphabetic word starting with an upper case letter:

[A-Z][a-z]+
and replace with the same word all in upper case:

\U&
2.    Find a C language variable name starting with a lower case letter:

\<[a-z][ a-zA-Z0-9]*
and make the first letter upper case:

\u&
3.    Find two numeric strings separated by one or more spaces:

\([0-9]+\) +\([0-9]+\)
and swap them around, using a tab to separate them:

\2\t\1
4.    Find "paste":

paste
and replace with the contents of the clipboard:

\p



Regular Expressions
Examples
A regular expression (RE) is a mechanism for describing patterns in text when executing the Find, the 
Replace, and the Find in Files commands.    An RE is made up of ordinary characters from the ANSI 
character set, some of which take on the special meanings described below.

Ordinary Characters
An ordinary character is an RE that matches itself.    It can be any character in the ANSI character set 
except <newline> and the special characters listed below.    An ordinary character preceded by a 
backslash is treated as the ordinary character itself, except when the character is (, ), <, >, or the letter t,
or the digits 1 through 9.    In all contexts, a tab is represented by the pair \t.

Special Characters
These special characters, can be rendered ordinary by preceding them with a backslash (\), if they are 
single special characters, or removing the preceding backslash if they are compound special characters.

Character Context
. [ \ The period, left square bracket, and backslash are special 

except when used in a Class Expression.
* + Asterisk and plus are special except when used in a class 

expression, as the first character of an RE, or as the first 
character of a Tagged Expression.

- The hyphen is special in a Class Expression, except as the 
first or last character of that expression.

^ The circumflex is special when used as the first character of an
entire RE (see Expression Anchoring), or as the first character 
of a Class Expression.

$ The dollar sign is special when used as the last character of an
entire RE (see Expression Anchoring).

Wildcard Character
The period (.), when used outside of a class expression, matches any character except newline.

Repetition Expressions
The asterisk (*) matches zero or more occurrences of the preceding regular expression, whilst the plus 
sign (+) matches at least one occurrence.    For example, A*b+ matches zero or more A's followed by 
one or more b's.

Class Expressions
A class expression is an RE, enclosed in square brackets ([ ]), that matches any one of the elements 
contained in the brackets.    The permitted elements of a class expression are:

Simple Characters
These are single characters that match themselves.    To match a right square bracket (]), it must be 
the first character of the class expression, after any initial circumflex (see Negated Class 
Expressions).    To match a hyphen, it must be either the first or the last character of the class 
expression.    For example [AaBb] matches upper or lower case A or B.

Negated Class Expressions
If the first character of a class expression is the circumflex (^), the expression matches any character
not in the class.    For example [^AB^] matches any character except A, B and the circumflex itself.

Range Expressions
A range expression is two characters separated by a hyphen (-).    It matches any of the characters in
the ANSI collating sequence, between the two characters.    For example, [A-Za-z0-9-] matches any
upper or lower case letter or digit, or the hyphen itself.

Expression Anchoring
An RE can be restricted to matching strings that begin or end a line or word, as follows:

^ A circumflex as the first character of an RE anchors



the expression to the beginning of the line.
$ A dollar sign as the last character of an RE anchors

the expression to the end of the line.
\< The character pair \< anchors the next RE to the 

start of a word.
\> The character pair \> anchors the previous RE to 

the end of a word.

Tagged Expressions
A tagged expression is an RE that starts with the pair \( and ends with the pair \).    There can be up to 
nine such expressions in a complete RE.    Such an expression matches the same as the expression 
without the surrounding \( and \).    The first expression defined in this way can be referenced as \1 later 
in the RE, and so on up to \9 for the ninth tagged expression.    Each such reference matches the same 
string as its original tagged expression.    For example \(tu\) \1 matches the string "tu tu".
References to tagged expressions can also be used in Replacement Expressions.



Replacement Expressions
Replacement expressions are used to substitute text in conjunction with Tagged Regular Expressions, 
when using the Replace command.

Expression Definition
& Substitute the text matching the entire 

search pattern.
\0 to \9 Substitute the text matching tagged 

expression 0 through 9.    \0 is equivalent to
&.

\n Substitute a newline.
\t Substitute a tab.
\u Force the next substituted character to be 

in upper case.
\l Force the next substituted character to be 

in lower case.
\U Force all subsequent substituted 

characters to be in upper case.
\L Force all subsequent substituted 

characters to be in lower case.
\E or \e Turns off previous \U or \L.
\p Paste in the contents of the clipboard.

To substitute a literal \ or &, use \\ and \&.



The Command Output Window
The Command Output Window is used to capture the output from the Run command, or from tools 
added to the Tools menu.    If the output is from a compiler, or Grep type program, it can be used to 
hypertext jump directly to the corresponding source line using left double-click.    Built-in support is 
provided for output from Microsoft and Symantec compilers, in the form:

filename(line): message
If this default is not suitable, it will be necessary to specify an alternative hypertext jump regular 
expression,.    This is set from the Hypertext Expression command on the Configure menu for the 
Commmand Output window.

Loading a File into the Command Output Window:
If the command output to be used for hypertext jumps is written to a file, rather than stdout, it cannot be 
automatically captured.    However, any file can subsequently be loaded into the Command Output 
window by adding the following command to the Tools menu:

Command: TYPE
Menu Text: Load Command Output
Arguments:
Initial Directory: (something suitable)
Prompt for Arguments X
Run Minimised: X
Capture Output: X
DOS Command: X

If the file needs post-processing in any way, use your own filter program, instead of the DOS TYPE 
command, to write the processed data to stdout.



Tool Argument Macros
Programs that you add to the Tools Menu can be started with context dependent information using 
argument macros.    These can be specified in the "Arguments" and "Initial Directory" fields of the Tools 
dialog box, and in the Run and Tool Arguments dialog boxes.    The following macros are defined:

Macro Name Expanded String
$File The fully qualified filename of the current

document.
$FileName The simple filename of the current 

document.
$BaseName $FileName, stripped of any extension.
$FileDir The drive and directory of the current 

document.
$Line The caret line within the current 

document
$Col The caret column within the current 

document
$Dir The current working drive and directory.

Notes:
Any macro that is inappropriate in the current context is replaced by an empty string.
Macros can be in any case (eg. $File = = $file = = $FILE).
Fully qualified is defined to mean drive + path from the root of that drive (eg. C:\WINDOWS\

WIN.INI).
In any expression using macros, each macro must be terminated by a non-alphabetic character, 

or the end of line.



Command Line Arguments
The command line arguments listed below can be used to start TextPad.    They are not case sensitive 
(except for P), but must appear before any file name.    Surround any arguments containing spaces with 
quotation marks (").    Because some of the arguments are mutually exclusive, conflicts are resolved by 
using the last option specified.    Any other arguments are silently ignored.    The switch character can be 
'/' or '-' as shown:

Argument Description
-av Arrange windows vertically tiled.
-ah Arrange windows horizontally tiled.
-ac Arrange windows cascaded.
-am Arrange windows maximized.
-p Print the specified file using default printer.
-q Dont display startup "splash" message.
-s Started by a DDE shell command.
-t "title" Append "title" to the main window title bar.

These arguments can be followed by the name of a file to edit (or print if the -p option was specified).    
An empty, quoted filename (ie. "") causes a new document to be created.
If the filename to be edited (not printed) is followed by "(<line>[,<col>])", with no intervening spaces, the 
file will be opened with the cursor at that position.    If <line> is a hex number (eg. 0x1a22), a hex view of 
the file will be created, with the cursor at that address.

eg.    TXTPAD32.EXE -ac main.cpp(51,20)
In this example TextPad will start up and open main.cpp at line 51, column 20 and display it in a 
cascaded window.



How Run Other Programs
1. From the Tools menu, choose the Run command.    The Run dialog box appears.
2. In the Command box, either type the name of the program or command, or choose a previous entry 

from the drop-down list.    If the program cannot be found in your search path, you will need to supply
its full path name.

3. In the Arguments box, type any arguments required by the program.    You can use any tool macros 
such as $File here, to specify the active file.

4. In the Initial Directory box, type the initial working directory for the program.    If this box is blank, it 
defaults to the installation directory of the particular program.    You can use directory tool macros 
here.

5. If the command is a DOS internal, such as DIR or TYPE, check the DOS Command box.
6. If you want the program to run in a minimized window, check the Run Minimized box.
7. If you want to redirect the output from the program to the Command window, check the Capture 

Output box.    This has no effect for Windows applications.
8. Click OK.

Note:
If you capture the output of another program in 32-bit versions of Windows, the output is displayed in the
Command window immediately.    In 16-bit versions of Windows, the output is displayed when the 
program finishes.



How to Use as the Editor for Other Applications
TextPad can easily be used as the editor for other applications.    By using its dynamic data exchange 
(DDE) capabilities, each file to be edited can be opened in a new window, rather than starting another 
copy of TextPad.
The installation directory contains a programs called DDEOPN16.EXE and DDEOPN32.EXE.    These 
translate command line requests to open files into the appropriate DDE commands for the 16 and 32-bit 
editions of TextPad respectively.    The first argument must be the registered server name TextPad, and 
the second argument is the file to open, with an optional line and column position immediately following 
in brackets.
Example 1:
To use TextPad as the editor for WinCIM, add the following line to the [General Preferences] section of 
WINCIM.INI:
Text-Editor=C:\TEXTPAD\DDEOPN16.EXE TextPad

Example 2:
To use TextPad with Visual C++, so that it edits the same active file as MSVC, customize the Tools 
menu of MSVC.EXE with the following command:
Command Line: C:\TEXTPAD\DDEOPN16.EXE
Menu Text: &TextPad
Arguments: TextPad $File($Line,$Col)

Notes:
For best performance, you should use DDEOPN32.EXE with 32-bit versions of Windows, and 

DDEOPN16.EXE with 16-bit versions.
Whenever TextPad is reactivated, it checks the last modified date of each file that you are editing,

and asks if it should reload any that have been changed by another application.



How to Customize: Overview
You can customize various settings to your own preferences, and these settings are preserved between 
sessions (except as explained below).    All user-configurable settings are accessible from the Configure 
menu, except for the Print Setup command, which is on the File menu. You can also configure properties
for the active document by choosing the Properties command from the popup menu that is displayed 
when you right click in its window.
Some of the configuration dialogs (eg. Font) give you the option to have the settings apply to the active 
document only, or to all documents.    Only settings that are applied to all documents are preserved 
between sessions.
Click the Contents button to see the various options that can be customized, or the next item button (>>)
to step through them one at a time.



How to Customize General Preferences
You can customize these general settings by choosing Preferences from the Configure menu:

Set this Option: To Do This:
Save Settings on Exit Save all settings between sessions.
Save the Workspace Save the state of open documents between 

sessions, so that you can continue from 
where you left off.

Allow Multiple Instances 
to Run

Allow more than one instance of the program
to run at a time.    This is not possible for the 
16-bit edition.

Use Multiple File Open 
Dialog Box

Allow multiple files to be selected in the File 
Open dialog.    Disable this option if your file 
names contain spaces.

Directory Follows Active 
Document

Automatically change working directory, to 
match that of the active document.

Backup Files Before 
Saving Changes

Before a document is saved, make a backup
copy of the original.    On Windows 95 & NT, 
FILE.EXT is backed up as FILE.BAK.EXT, 
otherwise it is backed up as FILE.BAK

Display Full Path Names
on Window Selector.

Display as much of the path as can be fitted 
in the Window Selector, otherwise omit the 
path and just display the file name.

Use OLE Drag and Drop Enable the full drag and drop capabilities.    
This setting can only be changed when no 
document windows are open, and OLE2 has
been installed.



How to Customize File Preferences
You can customize these file settings by choosing Preferences from the Configure menu:

Set this Option: To Do This:
Number of Recent Files 
on File Menu

Set the number of most recently used files 
on the File menu to between 1 and 16.

Default File Extension If you open or save a file using the File Open
or Save As dialog boxes, and do not specify 
a file extension, this string will be used.    It 
must not include spaces or dots.

Default Character Set Set the default character set used.    Click 
DOS if you want to use most of your text 
files with DOS applications, otherwise click 
ANSI.    This setting is used for dropped files,
and files opened by double clicking, but can 
be overridden for individual files on the File 
Open dialog box.

No Breaks in Lines Save word-wrapped documents without 
actually breaking the lines as wrapped.

Hard Breaks at Column 
#

Insert new line characters at the specified 
column position, when saving word-wrapped
documents.



How to Customize View Preferences
You can customize these view settings by choosing Preferences from the Configure menu:

Set this Option: To Do This:
Tool Bar Display the tool bar at the top of the main 

window.
Status Bar Display the status bar at the bottom of the main

window.
Clock Display the digital clock on the status bar.
Tool Bar Popup Tips Display tool bar help by holding the cursor over 

a button.
Visible Alerts Flash the window whenever the beeper is 

sounded.
Stay on Top of Other 
Windows

Keep the main window on top of all others, 
even when another application is active.

Horizontal Scroll Bar Display a horizontal scroll bar in each view.
Block Caret Display the caret as a block, instead of a 

vertical bar.    The caret is temporarily changed 
to the alternate form in overtype mode.



How to Customize Document Preferences
You can customize these document settings by choosing Preferences from the Configure menu to 
change all documents, or by choosing Document Properties to change them for the active document:

Set this Option: To Do This:
Word Wrap Long Lines Word-wrap lines that are wider than the view,

or than the column specified in File 
Preferences.

Constrain the Caret to 
the Text

Restrict the position of the caret to the 
existing text.    Otherwise it can be placed 
anywhere in the document window.    In word-
wrap mode, the caret is always constrained.

Maintain Indentation Automatically indent each new line by the 
same amount as the preceding line.

Auto-indent Blocks Indent a new line following a line ending with 
{, and unindent a } on a line on its own.    
Maintain Indentation must also be set.

Read Only Prevent the document from being edited.    
This cannot be set if the document has 
already been modified.



How to Customize Tab Stops
Tab stops and indentation can be set at regular intervals as follows:
1. To change the default settings for all documents, choose Preferences from the Configure menu, and 

the Preferences dialog box will be displayed.    To make changes for the active document only, 
choose Document Properties from the Configure menu, and the Properties For ... dialog box will be 
displayed.

2. Select the Tabs tab.
3. In the Tab Size box, type the character spacing between tab stops.
4. In the Indent Size box, type the character spacing for each line indentation.    This is best set to the 

same value as tab stops, otherwise indentation will be made up of a mixture of spaces and tabs.
5. Check Convert to Spaces, if you want tabs converted to the equivalent number of spaces.    This 

does not affect existing tabs, until a document is saved.
6. Click OK.



How to Customize File Filters
File filters are the list of wild cards in the List Files of Type box on the File Open dialog box.    You can 
add to the default list as follows:
1. From the Configure menu, choose Preferences.    The Preferences dialog box is displayed.
2. Select the Filters tab and Click New.    The word New is displayed in the Filters and Descriptions 

boxes.
3. Replace this word in the Description box with the text that you would like to describe the filter.    eg. 

Assembler Files (*.asm, *.inc).
4. In the Wild Cards box, type the corresponding list of wild cards, separated by semicolons.    eg. 

*.asm;*.inc.
5. Click Move Up or Move Down to change the position of this filter in the list.    The first entry in the list 

will normally be used as the default each time TextPad starts up.    However, if TextPad loaded a 
workspace when it started, the initial filter will be set to the last one used.

6. Click OK.



How to Customize File Associations
By associating TextPad with file extensions, Explorer or File Manager will know to start TextPad when 
you want to edit such a file.    Change the associations as follows:
1. From the Configure menu, choose Preferences.    The Preferences dialog box is displayed.
2. Choose the Associations tab.
3. Type an extension in the New Extension box, or choose one from the drop-down list.
4. Type the description of such files in the Description box.
5. Click the Add button.
6. Repeat steps 3-5 for each new extension.
7. Click OK or Apply.

To revert an association back to its default:
1. Select the extension from the list box.
2. Click Delete.
3. Repeat steps 1-2 for each extension to delete.
4. Click OK or Apply.

Notes:
Clicking Cancel will leave your current associations intact.
If you have associated extensions with releases of TextPad earlier than 1.31, they will not show 

up in the list initially.    You must remake the associations to get them in the list.    The uninstall program 
uses this list to reinstate the default associations.



How to Customize Hypertext Expressions
You can change the regular expression used in hypertext jumps from the Command Output window as 
follows:
1. From the Configure menu, choose Preferences.    The Preferences dialog box is displayed.
2. Choose the Jumps tab.
3. Clear the Use Defaults check box.
4. In the Regular Expression box, type the regular expression that matches the text in the Command 

Output window.    This must include at least two tagged expressions for the filename and line number,
and optionally a third for the column number.    Up to 10 such expressions are saved in the drop-
down list.

5. In the Register boxes, set the indexes corresponding to the tagged expressions defined in the last 
step.

6. Check Use Defaults, if you want to revert to the default expression.
7. Click OK.

More Information:
The Command Output window is used to capture the output from the Run command, or from tools 
added to the Tools menu.    If the output is from a compiler, or Grep type of program, it can be used to 
jump directly to the corresponding source line using left double-click.    Built-in support is provided for 
output from Microsoft and Symantec (Zortech) compilers, in the form:

filename(line): message
If this default is not suitable, it will be necessary to specify an alternative hypertext jump regular 
expression.    For example:
1. Microsoft and Symantec (Zortech) C/C++

Expression = ^\([^(]+\)(\([0-9]+\))
File Register = 1
Line Register = 2

2. Borland C/C++
Expression = ^[WE][a-z]+ \([^ ]+\) \([0-9]+\):
File Register = 1
Line Register = 2

3. Keil C51
Expression = ^.+ IN LINE \([0-9]+\) OF \([^:]+\):
File Register = 2
Line Register = 1

4. Generic filename(line,column)
Expression = ^\([^(]+\)(\([0-9]+\),\([0-9]+\))
File Register = 1
Line Register = 2
Column Register = 3



How to Customize the Screen Font
Only fixed width fonts are allowed on the screen, so the screen font is set independently of the printer 
font.
1. From the Configure menu, choose Screen Font.    The Font dialog is displayed.
2. In the Font box, choose from the list of fixed width fonts.
3. In the Font Style box, choose from the list of styles.
4. In the Size box, choose from the list of font point sizes.
5. In the Scope box, select Make Default, if you want these settings to be applied to all documents, 

otherwise select Active Document to make a temporary change to the active document only.
6. Check that the text displayed in the Sample box is satisfactory.
7. Click OK.



How to Customize the Tools Menu
You can add up to 10 of your own commands to the tools menu as follows:
1. From the Configure menu, choose Tools.    The Tools dialog is displayed.
2. Click New, and choose Command.    The Select File dialog is displayed.
3. Either use the Select File dialog to select an executable file and click OK, or click Cancel if you want 

to add a DOS internal command, such as DIR.
4. Make any necessary changes to the command in the Command box.    If you clicked Cancel in the 

previous step, this will have been initialized to User Tool, which must be changed.    Note that the 
command must include its full path name, unless it is on your search path.

5. Make any necessary changes to the text that will appear on the Tools menu in the Menu Text box.    
This box is initialized from the text in the Command box.

6. In the Arguments box, type any arguments required to run this tool.    You can include any tool 
macros here.

7. In the Initial Directory box, type the startup directory for the command.    This defaults to the directory 
containing the tool. You can include directory tool macros here.

8. Check Prompt for Arguments, if you want to supply different arguments each time you choose this 
tool.    The arguments you type in the Tool Arguments dialog at run time will be appended to those in 
the Arguments box.

9. Check Run Minimized, if you want the tool to run displayed as an icon.
10. Check Capture Output, if you want to see the output from the tool in the Command window.    This 

only applies to DOS or console commands.
11. Check DOS Command, if the tool is an internal DOS command, such as DIR or TYPE.
12. Click Move Up or Move Down to set the order of this tool on the Tools menu.
13. Click OK.



How to Configure Document Properties
To configure properties for the active document, choose Document Properties from the Configure menu, 
then choose one of the following tabs from the dialog box:

Document for word-wrap and indentation settings.
View for scroll bars and visible spaces.
Tabs for tab settings.
Statistics for information about the document, such as its word count.



How to Configure View Properties
You can change these settings for the active view by choosing Document Properties from the Configure 
menu, and selecting the View tab:

Set this Option: To Do This:
Horizontal Scroll Bar Display a horizontal scroll bar.
Visible Spaces and 
Tabs

In visible mode, spaces are shown as ( ) and 
tabs as (»).



How to View Document Statistics
You can view these properties of the active document by choosing Document Properties from the 
Configure menu, and selecting the Statistics tab:

Property: Notes:
Full Name Shows the fully qualified file name.    You may 

need to scroll to the end if the name is longer 
than the available display space.

Last Saved At Shows the date and time that the document 
was last written to its disk file.

Character Count Shows the number of characters in the 
document.

Line Count Shows the number of lines in the document.    
Note that a word-wrapped line is counted as a 
single line.

Word Count Shows the number of words in the document.    
A word is composed of letters, numbers, 
hyphens, underscores and apostrophes.



How to Customize the Printer
To choose a particular printer, or to set up the printed page layout and font:
1. From the File menu, choose Print Setup.    The Configure Printing dialog appears.
2. To change the printer, click the Printer button and the standard Print Setup dialog is displayed.    Click

its OK button when you have made your selection.
3. To change the font, click the Font button and the standard Font dialog is displayed.    Click its OK 

button when you have made your selection.    Note that this selection only applies to the printer, not 
the screen font.

4. To add a header and/or footer to each printed page, type the required text in the Header and Footer 
boxes.    You can also use page macros to get the file name, date and time:

5. If you want the times in the header and footer to correspond to the creation time of the file being 
printed, click File Time, else click Print Time.

6. To set the page margins, fill in the Left, Right, Top and Bottom boxes.    Note that if you set these to 
less than the minimum that the printer allows, the settings are ignored.

7. If you want lines that are too long for the page width to be wrapped on to the next line, click the Word
Wrap Long Lines box.    Otherwise lines that are too long will be truncated.

8. Click OK when you have completed your changes.

Tip:
To save on paper, use the Print Preview command on the File menu to check that your printer settings 
are satisfactory.



Page Header/Footer Macros
The following macros can be used in the Header and Footer boxes in the Configure Printing 
dialog:

Use To Get
&d The current date in Windows short form.
&D The current date in Windows long form.
&t The current time in Windows format.
&f The filename, excluding its path.
&F The full filename, including its path.
&p The page number.
&l Text that follows this code is to be left justified.
&c Text that follows this code is to be centred (this is the

default).
&r Text that follows this code is to be right justified.

For example: to get a page header that looks like:

Left Center Right
readme.txt Page 1 10/10/95

Set the header to "&l&f&cPage &p&r&d



How to Customize Colors
The foreground and background colors used by TextPad can be modified, but there is no user interface 
yet.

Defining Colors on Windows 3.1:
To make changes, you must edit the values in the [Colors] section in TEXTPAD.INI, which is stored in 
your Windows directory.    Note that if you use TextPad to edit this file, your changes will be overwritten 
when you exit, so use NotePad!

Defining Colors on Windows 95 and NT:
Use the registry editor (regedit32.exe on NT, or regedit.exe on Windows 95) to edit the values for the 
key:

HKEY_CURRENT_USER\Software\Helios\TextPad\Colors.

Color Values:
Each color is specified by 6 hex digits in the form BBGGRR, so black is 000000, white is FFFFFF, pure 
blue is FF0000, pure green is 00FF00, pure red is 0000FF, and light gray is C0C0C0.    The defaults are 
as specified using the Control Panel Color applet.

Change this: To set this color:
NormalFg The normal foreground color of text
NormalBk The normal background color of text
HighliteFg The foreground color of selected text
HighliteBk The background color of selected text
Bookmark The color of bookmarks
InactiveView The color used in the left margin to indicate

inactive views

Note:
If you change your Windows color scheme whilst TextPad is running, it will update the first four entries in
the above table to match the new color scheme.    If TextPad is not running, it will preserve your previous
settings for these colors.



New command (File menu)
Use this command to create a new, unnamed document.
You can open a new document, and give it a name at the same time, with the Open command.

Shortcuts:
Toolbar:

Keys: Ctrl+N
More information



Open command (File menu)
Use this command to open an existing document.
Select the file (or multiple files) from the File Open dialog box which appears.

Shortcuts:
Toolbar:

Keys: Ctrl+O
More information



Close command (File menu)
Use this command to close all views containing the active document.
You get prompted to save changes to your document before you close it.    If you close a document 
without saving, you lose all changes made since the last time you saved it.    Before closing an untitled 
document, the Save As dialog box appears to suggest that you name and save the document.
More information



Close All command (File menu)
Use this command to close all your documents.    If any document has been modified, you will be 
prompted to save it before its window is closed.



Save command (File menu)
Use this command to save an open document.
When you save an unnamed document for the first time, the Save As dialog box appears, so that you 
can give it a name.

Shortcuts:
Toolbar:

Keys: Ctrl+S
More information



Save As command (File menu)
Use this command to save the active document with another name.
The Save As dialog box appears, so that you can supply the new name.
More information



Save All command (File menu)
Use this command to save all modified documents.
When you save an unnamed document for the first time, the Save As dialog box appears, so that you 
can give it a name.

Shortcuts:
Keys: Ctrl+Shift+S



Manage Files command (File menu)
Use this command to open copy, rename, delete or update the timestamps of files.

Shortcuts:
Toolbar:

Keys: F3
More information



Print command (File menu)
Use this command to print the active document.
This command presents a Print dialog box, where you may specify the range of pages to be printed, the 
number of copies, the destination printer, and other printer setup options.

Shortcuts:
Toolbar:

Keys: Ctrl+P
More information



Print Preview command (File menu)
Use this command to display the active document as it would appear when printed.
When you choose this command, the main window will be replaced with a print preview window in which
one or two pages will be displayed in their printed format.    The print preview toolbar offers you options 
to view either one or two pages at a time; move back and forth through the document; zoom in and out 
of pages; and initiate a print job.

Shortcuts:
Toolbar:

Keys: Ctrl+Shift+P
More information



Print Setup command (File menu)
Use this command to select the printer and setup the appearance of the printed page.
You can set margins and headers and footers on the Configure Printing dialog box which appears.
More information



Send command (File menu)
Use this command to send the active document to another person via electronic mail.    You must have a
MAPI compatible e-mail system installed to enable this command.



1, 2, 3, 4 ... command (File menu)
Use the numbers and filenames listed at the bottom of the File menu to open the last several documents
you closed.    Choose the number that corresponds with the document you want to open.



Exit command (File menu)
Use this command to end your session.    You can also use the Close command on the application 
Control menu.    You are prompted to save any documents with unsaved changes.

Shortcuts:
Mouse: Double-click the application's Control menu button.
Keys: Alt+F4



Undo command (Edit menu)
Use this command to undo the last edit command, including Redo.    It is unavailable when there is 
nothing to undo.
You can undo each edit you made since the file was last saved by repeated use of this command, or you
can undo all edits at once using Ctrl+Shift+Z.

Shortcuts:
Toolbar:

Keys: Ctrl+Z    or    Alt+Backspace
More information



Redo command (Edit menu)
Use this command to cancel the last Undo command.    It is unavailable when there is nothing to redo.
You can redo each undo you cancelled by repeated use of this command, or you can redo all undos at 
once using Ctrl+Shift+A.

Shortcuts:
Toolbar:

Keys: Ctrl+A
More information



Select All command (Edit menu)
Use this command to select the whole document.

Shortcuts:
Mouse: Crl+Left click in the left margin.

More information



Cut command (Edit menu)
Use this command to remove the currently selected text from the document and put it on the clipboard.   
It is unavailable if no text is currently selected.
Cutting text to the clipboard replaces the contents previously stored there.

Shortcuts:
Toolbar:

Keys: Ctrl+X    or    Shift+Delete
More information



Cut Selection Append command (Edit menu)
Use this command to remove the currently selected text from the document and append it to any text 
already on the clipboard.    It is unavailable if no text is currently selected.

Shortcuts:
Keys: Ctrl+Shift+X

More information



Copy command (Edit menu)
Use this command to copy the selected text from the document to the clipboard.    It is unavailable if no 
text is currently selected.
Copying text to the clipboard replaces the contents previously stored there.

Shortcuts:
Toolbar:

Keys: Ctrl+C    or    Ctrl+Insert
More information



Copy Append command (Edit menu)
Use this command to copy the currently selected text from the document and append it to any text 
already on the clipboard.    It is unavailable if no text is currently selected.

Shortcuts:
Keys: Ctrl+Shift+C

More information



Paste command (Edit menu)
Use this command to insert the contents of the clipboard at the caret position, or to replace the current 
selection.    It is unavailable if there is no text on the clipboard.

Shortcuts:
Toolbar:

Keys: Ctrl+V    or    Shift+Insert
More information



Invert Case command (Edit menu)
Use this command to change selected characters from upper to lower case, and vice versa.
If no text is currently selected, the case of the character after the caret is changed, and the caret is 
moved one position to the right.

Shortcuts:
Keys: Ctrl+K

More information



Upper Case command (Edit menu)
Use this command to change selected characters from lower to upper case.
If no text is currently selected, the case of the character after the caret is changed, and the caret is 
moved one position to the right.

Shortcuts:
Keys: Ctrl+U

More information



Lower Case command (Edit menu)
Use this command to change selected characters from upper to lower case.
If no text is currently selected, the case of the character after the caret is changed, and the caret is 
moved one position to the right.

Shortcuts:
Keys: Ctrl+L

More information



Capitalize command (Edit menu)
Use this command to make the first character of each word in the current selection upper case, and the 
rest lower case.
This command is unavailable if no text is currently selected.

Shortcuts:
Keys: Ctrl+Shift+U

More information



Transpose command (Edit menu)
Use this command to transpose lines or characters.    If the caret is at the beginning or end of a line, the 
adjacent lines are swapped, otherwise the adjacent characters are swapped.
This command is unavailable if any text is selected.

Shortcuts:
Keys: Ctrl+T



Transpose Words command (Edit menu)
Use this command to transpose the words either side of the caret. Any punctuation between the words is
left in place.    If the caret is in the middle of a word, its two halves are transposed.
This command is unavailable if any text is selected.

Shortcuts:
Keys: Ctrl+Shift+T



Unindent command (Edit menu)
Use this command to reduce the indentation of currently selected lines.

Shortcuts:
Toolbar:

Keys: Shift+Tab
More information



Indent command (Edit menu)
Use this command to increase the indentation of currently selected lines.

Shortcuts:
Toolbar:

Keys: Tab
More information



Insert File command (Edit menu)
Use this command to insert the contents of a file at the caret position, or to replace the current selection. 
The File Open dialog box appears to allow you to select the file to insert.

Shortcuts:
Keys: Ctrl+Shift+V

More information



Join Lines command (Edit menu)
Use this command to join currently selected lines.    Each line in turn is appended to the first, separated 
by a single space.    Paragraphs are preserved in word-wrapping mode.

Shortcuts:
Keys: Ctrl+J

More information



Line Lengthen/Split Lines command (Edit menu)
Line Lengthen:
Use this command when not in word-wrapping mode to adjust the lengths of currently selected lines to 
the word-wrap margin.    Words are moved between the lines as necessary, and blank lines are 
preserved as paragraph separators.

Split Lines:
Use this command when in word-wrapping mode to split currently selected lines at the point where they 
are wrapped, by inserting new line characters.

Shortcuts:
Keys: Ctrl+Shift+J



Insert Line After command (Edit menu)
Use this command to open up a new line after the line containing the caret.    It is unavailable if the 
current selection extends over a line boundary.

Shortcuts:
Keys: Ctrl+I

More information



Insert Line Before command (Edit menu)
Use this command to open up a new line before the line containing the caret.    It is unavailable if the 
current selection extends over a line boundary.

Shortcuts:
Keys: Ctrl+Shift+I

More information



Insert Page Break command (Edit menu)
Use this command to insert a page break at the start of the line containing the caret.    It is unavailable if 
any text is currently selected.

Shortcuts:
Keys: Ctrl+Shift+L

More information



Insert Time command (Edit menu)
Use this command to insert the current time at the caret position.    The format used is as specified with 
Control Panel's International applet.



Insert Short Date command (Edit menu)
Use this command to insert the current date at the caret position.    The format used is as specified for 
short dates with Control Panel's International applet.



Insert Long Date command (Edit menu)
Use this command to insert the current date at the caret position.    The format used is as specified for 
long dates with Control Panel's International applet.



Cut Line command (Edit menu)
Use this command to remove the line containing the caret from the document and put it on the clipboard.
It is unavailable if the current selection extends over a line boundary.

Shortcuts:
Keys: Ctrl+Y

More information



Cut Line Append command (Edit menu)
Use this command to remove the line containing the caret from the document and append it to any text 
already on the clipboard.    It is unavailable if the current selection extends over a line boundary.

Shortcuts:
Keys: Ctrl+Shift+Y

More information



Cut Word command (Edit menu)
Use this command to remove the word containing the caret from the document and put it on the 
clipboard.    It is unavailable if any text is selected.

Shortcuts:
Keys: Ctrl+Q

More information



Cut Word Append command (Edit menu)
Use this command to remove the word containing the caret from the document and append it to any text
already on the clipboard.    It is unavailable if any text is selected.

Shortcuts:
Keys: Ctrl+Shift+Q

More information



Mark Clean command (Edit menu)
Use this command to cancel, without undoing, any changes that have been made to the active 
document.    The changes remain, but you will not be prompted to save the document when you close it.
This option is disabled until the document has been modified.



Delete command (Edit menu)
Use this command to delete the currently selected text, or the character after the caret if nothing is 
selected.



Delete Bookmarked Lines command (Edit menu)
Use this command to delete all lines that have bookmarks on them.



Cut Bookmarked Lines command (Edit menu)
Use this command to delete all lines that have bookmarks on them, and place them on the clipboard.



Copy Bookmarked Lines command (Edit menu)
Use this command to copy all lines that have bookmarks on them to the clipboard.



Fill Block command (Edit menu)
Use this command to fill the selected block of text with a specified character or characters.    A dialog box
is displayed for you to enter the characters to fill with.    These are repeated if the block to be filled is 
wider than the fill characters.
You can fill with tabs by entering \t as the fill character.    If you actually want to fill with \t, enter it as \\t.
This option is disabled until a selection has been made in block mode.



Clear All command (Edit menu)
Use this command to delete the whole contents of the Command Output window.

Shortcuts:
Keys: Ctrl+Del



Find command (Search menu)
Use this command to specify a search string and the search criteria, such as whether or not to match 
case.    It brings up the Find dialog box, which can remain permanently on screen.

Shortcuts:
Toolbar:

Keys: F5
More information



Find Next command (Search menu)
Use this command to find the next occurrence of the selected text.    If nothing is selected, or the 
selection extends over one line, the last search string, if any, is used.
If one of the Find, Replace, or Find in Files dialog boxes is on the screen, the new search string is 
copied to its Find What box.

Shortcuts:
Keys: Ctrl+F

More information



Find Previous command (Search menu)
Use this command to find the previous occurrence of the selected text.    If nothing is selected, or the 
selection extends over one line, the last search string, if any, is used.
If one of the Find, Replace, or Find in Files dialog boxes is on the screen, the new search string is 
copied to its Find What box.

Shortcuts:
Keys: Ctrl+Shift+F

More information



Find in Files command (Search menu)
Use this command to specify a search string, the search criteria, such as whether or not to match case, 
and the list of files to search.    It brings up the Find in Files dialog box, which can remain permanently on
screen.

Shortcuts:
Toolbar:

Keys: Ctrl+F5
More information



Replace command (Search menu)
Use this command to specify search and replace strings and the search criteria, such as whether or not 
to match case.    It brings up the Replace dialog box, which can remain permanently on screen.

Shortcuts:
Toolbar:

Keys: Ctrl+F8
More information



Replace Next command (Search menu)
Use this command to replace the current selection with the last defined replacement string.

Shortcuts:
Keys: Ctrl+F8

More information



Go To command (Search menu)
For text files, this command moves the caret to the beginning of a specified line.    It brings up the Go To 
Line dialog box, in which you type the line number.
For binary files, this command moves the caret to a specified offset in the file.    It    brings up the Go To 
Address dialog box, in which you type the address in hexadecimal.

Shortcuts:
Keys: Ctrl+G



Jump Next command (Search menu)
Use this command to do a hypertext jump to the next item in the Search or Command output windows.
Which of the Search or Command output windows is used by this command is set according to the last 
one accessed.    This is shown with a bullet ( ) against it on the Window menu.

Shortcuts:
Toolbar:

Keys: F4



Jump Previous command (Search menu)
Use this command to do a hypertext jump to the previous item in the Search or Command output 
windows.
Which of the Search or Command output windows is used by this command is set according to the last 
one accessed.    This is shown with a bullet ( ) against it on the Window menu.

Shortcuts:
Toolbar:

Keys: Shift+F4



Toggle Bookmark command (Search menu)
Use this command to set or clear a bookmark on the current line.

Shortcuts:
Keys: Ctrl+F2

More information



Next Bookmark command (Search menu)
Use this command to go to the next line containing a bookmark.

Shortcuts:
Keys: F2

More information



Previous Bookmark command (Search menu)
Use this command to go to the previous line containing a bookmark.

Shortcuts:
Keys: Shift+F2

More information



Clear All Bookmarks command (Search menu)
Use this command to remove all the bookmarks from the active document.

Shortcuts:
Keys: Ctrl+Shift+F2

More information



Match Bracket command (Search menu)
Use this command to go to the closing bracket matching the opening bracket after the caret (or vice 
versa).

Shortcuts:
Keys: Ctrl+M

More information



Compare Files command (Tools menu)
Use this command to look for differences between two text files.    It brings up the Compare Text Files 
dialog box, in which you can specify the file names.
More information



File Manager command (Tools menu)
Use this command start Windows own File Manager.

Shortcuts:
Keys: Alt+F3



Stop command (Tools menu)
Use this command to terminate the user tool whose output is being redirected to the Command Output 
window.

Shortcuts:
Keys: Ctrl+Break

More information



Run command (Tools menu)
Use this command to start another application, and optionally redirect its output to the Command Output
window.    It brings up the Run dialog box for you to fill in the details.
More information



User Tool command (Tools menu)
Use this command to start the application that has been added to the Tools menu.
More information



Block Select Mode command (Configure menu)
Use this command to alternate between block (column) and normal selection modes.    A check mark is 
shown against this menu item when block selection mode is enabled.    The current state is also 
displayed on the status bar.
This command is not available in word-wrapping mode.

Shortcuts:
Mouse: Alt+Left button

More information



Preferences command (Configure menu)
Use this command to bring up the Preferences dialog box.    This lets you configure various settings.
More information



Screen Font command (Configure menu)
Use this command to bring up the standard Font dialog box.    This lets you select the font to be used on 
the screen.
More information



Tools command (Configure menu)
Use this command to bring up the Tools dialog box.    This lets you add or modify your own entries on the
Tools menu.
More information



Document Properties command (Configure menu)
Use this command to bring up the Document Properties dialog box.    This lets you change various 
document properties, and view its statistics.
More information



Split Window command (Window menu)
Use this command to split the active window into 2 panes.    You may then use the mouse or the 
keyboard arrows to move the splitter bar.    When you are finished, press the left button, or Enter to leave
the splitter bar in its new location.
Pressing escape cancels this command.
More information



Tile Across command (Window menu)
Use this command to arrange your windows side by side across the screen.



Tile Down command (Window menu)
Use this command to arrange your windows one above another, in a non-overlapped fashion, down the 
screen.



Cascade command (Window menu)
Use this command to arrange your windows in an overlapped fashion, from top left to bottom right of the 
screen.



Arrange Icons command (Window menu)
Use this command to arrange neatly the icons for minimized windows at the bottom of the main window. 
If there is an open document window at the bottom of the main window, then some or all of the icons 
may not be visible because they will be underneath this document window.



Use Selector command (Window menu)
Use this command to bring up the Window Selector.    This is a list of your open documents that remains 
permanently on the screen.    You can move and resize this to your requirements, and use it to switch 
between document windows.

Shortcuts:
Keys: F11

More information



Search Output command (Window menu)
Use this command to switch to the window showing the results of the last Find in Files command.    This 
command is unavailable if you close the window, until you do another Find in Files.
After you have used this command, a bullet mark ( ) is shown against it on the Window menu, to show 
that the Jump Next/Previous commands on the Search menu apply to this window.

Shortcuts:
Keys: Shift+F11

More information



Command Output command (Window menu)
Use this command to switch to the window showing the output of the last tool from the tools menu.    This
command is unavailable if you close the window, until you run another tool.
After you have used this command, a bullet mark ( ) is shown against it on the Window menu, to show 
that the Jump Next/Previous commands on the Search menu apply to this window.

Shortcuts:
Keys: Ctrl+F11

More information



0,1,... command (Window menu)
A list of currently open document windows is displayed at the bottom of the Window menu.    A check 
mark appears in front of the document name of the active window.    Choose a document from this list to 
make its window active.



Contents command (Help menu)
Use this command to display the opening screen of Help.    From the opening screen, you can jump to 
step-by-step instructions, and various types of reference information.
Once you open Help, you can click its Contents button whenever you want to return to the opening 
screen.



Search for Help command (Help menu)
Use this command to display the Search dialog box.    This displays the index of help topics for you to 
select from.    It is equivalent to clicking the Search button when you are already running the help 
system.



File Statistics command (Help menu)
Use this command to display the size and number of lines in the active document, on the status bar.

Shortcuts:
Keys: Ctrl+F1



About TextPad command (Help menu)
Use this command to display the About dialog box.    This displays various license details, and system 
resource information.



Context Help command

Use the Context Help command to obtain help on some portion of the graphical interface.    When you 
choose the Toolbar's Context Help button, the mouse pointer will change to an arrow and question mark.
Then click somewhere in the application window, such as another Toolbar button.    The Help topic will be
shown for the item you clicked.
Pressing escape cancels this command.

Shortcuts:
Keys: Shift+F1



Open Include File
Clicking with the right button on a line beginning #include ..., adds a command to open the included
file to the popup menu.    If you choose that command, the file will be opened in a new window.



Quick Open File Dialog Box
This dialog box allows you to open a file, when you do not need the browsing capabilities of the standard
Open File dialog box, and you are willing to type the file name.
Use Ctrl+Shift+O to bring up this dialog box.    There is no menu or toolbar equivalent command.
Click the Browse button to get the standard Open File dialog box.



Fill Selected Block Dialog Box
This dialog box appears when you choose the Fill Block command from the Edit menu.
Type in the character or characters that you want to fill the current block selection with.    You can fill with
tabs by entering \t as the fill character.    If you actually want to fill with \t, enter it as \\t.



Manage Files Dialog Box
Use the manage Files dialog to:

 Copy Files
 Delete Files
 Rename Files
 Update Timestamps of Files

The Browse button brings up the standard Open File dialog box, so that you can select the file or files 
you want to manage.



Copy/Rename/Move Dialog Box
This dialog box appears when you click Copy or Rename on the Manage Files dialog box.
Confirm that the files in the From box are what you want, and edit them if necessary, then type the 
destination file name, wild card or directory name in the To box.
The Browse button brings up the standard Open File dialog box, so that you can select the destination 
file name.



Delete/Touch Dialog Box
This dialog box appears when you click Delete or Touch on the Manage Files dialog box.
Confirm that the files in the edit box are what you want, and edit them if necessary.    Then click OK.



Tool Arguments Dialog Box
This dialog appears when you choose a user tool from the Tools menu and you checked the Prompt for 
Arguments box when you configured this tool.
Type any arguments that the program requires in the Arguments box, and click OK.



Go To Line dialog box
This dialog box is displayed when you choose the Go To Line command from the Search menu (Ctrl+G).
Type the required line number in the Go To Line box, and click Go To.
If you want to select everything between the current position and the start of the given line, check the 
Extend Selection box.



Go To Address dialog box
This dialog box is displayed when you choose the Go To Address command from the Search menu 
(Ctrl+G) in Hex views.
Type the required hexadecimal offset in the file in the Go To Address box, and click Go To.
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Helios Software Solutions
Mail Address:

Carr Brook House
Chorley Old Road
Brindle
CHORLEY    PR6 7QZ
England
Tel/Fax: +44-(0)1772-324353

E-Mail Addresses:
CompuServe: 100041,235
MSN: HelioSoft
Internet: textpad@heliosof.demon.co.uk



How to Order
Registration Benefits:

This product makes use of the most advanced software technology available today.    As the technology 
improves, so does our software.    Your registration fee enables us to keep it at the forefront of 
technology, so that you continue to benefit from the productivity gains it gives you.
As a registered user, you will receive:

A copy of the latest release of both 16 and 32-bit editions on 3.5" diskette, which include support 
for OLE2 drag and drop editing, plus the Win32s installation disks.

A license to use all future maintenance releases (which will be made available for downloading 
using FTP, and from CompuServe).    This license file will be e-mailed to you, if you quote your address 
with your order.

The display of your name, company and registration number on the About dialog box.
Technical support via e-mail, by FAX, or through the mail, at no charge.

Registration Instructions:
The registration fee can be paid direct to Helios Software Solutions in UK Pounds, or to PsL using a 
credit card, or it can be debited from your CompuServe account using the shareware registration 
service.    Which ever way you choose to order, we send you an invoice.
Note that discounted site licenses can be supplied on request.

Ordering by Cheque (Check)
Ordering by Credit Card
CompuServe Registration
Purchase Orders



Ordering by Cheque (Check)
Payment must be by UK pound denominated drafts drawn on a UK bank, or by EuroCheque, or by 
Pound Sterling International Money Order.    Sorry, but banking fees for payments in other denominations
are prohibitively expensive.
Please enclose a cheque (check) or money order with your order form, payable to:

"Helios Software Solutions".
See the Order Form for current pricing.



CompuServe Shareware Registration Service
If you have a CompuServe account you can have the registration fee debited from your account.    
Simply GO SWREG and follow the online instructions, quoting registration ID number 3938.
To insure that you get the latest version, CompuServe will notify us on the day of your order and we will 
ship the product directly to you.
The registration fee for orders made using this service is $30 plus $5.00 shipping and handling.



Credit Card Orders
MasterCard, Visa, American Express, and Discover orders must be placed through PsL, a credit card 
order taking service.    You can reach PsL 24 hours a day 7 days a week by fax at 1-713-524-6398 or by 
CompuServe mail to 71355,470 or Internet mail to 71355.470@compuserve.com.    You can also call 
PsL at 1-800-242-4PsL(4775) or 1-713-524-6394 between the hours of 7:00 am and 6:00 pm CST 
Monday-Thursday and 7:00 am and 12:30 pm CST on Fridays, except holidays.
Credit card orders can be mailed to PsL at P.O. Box 35705, Houston, TX 77235, USA.

THESE NUMBERS ARE FOR ORDERING ONLY.    Any other queries, including the the status of the
shipment of the order, must be addressed to Helios Software Solutions.

PsL requires the following information:
Credit Card [    ] MasterCard [    ] VISA [    ] AMEX [    ] Discover

Credit Card Number: _____________________________________
Expiry Date: _____________________________________
Name On Card: _____________________________________
Billing Address: _____________________________________

_____________________________________
_____________________________________

To insure that you get the latest version, PsL will notify us on the day of your order and we will ship the 
product directly to you.
The registration fee for orders through PsL is $30 plus $5.00 shipping and handling.



Purchase Orders
Purchase orders (net 30 days) are accepted only from government and accredited educational 
institutions and major corporations, provided that they are submitted on purchase order forms with a 
purchase order number.    Please be sure to include the standard TextPad order form with a purchase 
order.
See the Order Form for current pricing.



User License Agreement
LIMITED WARRANTY AND REMEDIES

THE PROGRAM IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS
OR IMPLIED, INCLUDING, BUT NOT LIMITED TO WARRANTIES OF MERCHANTABILITY OR 
FITNESS FOR A PARTICULAR PURPOSE.    IN NO EVENT WILL THE AUTHOR BE LIABLE TO 
YOU FOR ANY DAMAGES, INCLUDING INCIDENTAL OR CONSEQUENTIAL DAMAGES, 
ARISING OUT OF THE USE OF THE PROGRAM, EVEN IF ADVISED OF THE POSSIBILITY OF 
SUCH DAMAGES.
YOU ACKNOWLEDGE THAT YOU HAVE READ THIS LICENSE, UNDERSTAND IT AND AGREE 
TO BE BOUND BY ITS TERMS AS THE COMPLETE AND EXCLUSIVE STATEMENT OF THE 
AGREEMENT BETWEEN US, SUPERSEDING ANY PROPOSAL OR PRIOR AGREEMENT, ORAL 
OR WRITTEN, AND ANY OTHER COMMUNICATIONS BETWEEN US RELATING TO THE 
SUBJECT MATTER OF THIS LICENSE.

Windev and TextPad are shareware programs and are provided at no charge to the user for evaluation.   
Feel free to share them with your friends, but please do not give them away altered or as part of another
system.    The essence of shareware software is to provide personal computer users with quality 
software without high prices, and yet to provide incentive for programmers to continue to develop new 
products.
If you find this program useful and find that you continue to use it after a reasonable trial period, you 
must make a registration payment (see the registration instructions for details).    This registration fee will
license one copy for use on any one computer at any one time.    All users will receive a copy of the 
latest release when they register, and free technical support for a limited period.
Commercial users must register and pay for their copies within 30 days of first use or their license is 
withdrawn.    Site License arrangements may be made by contacting Helios Software Solutions.
Anyone distributing this product for any kind of remuneration must first contact Helios Software Solutions
for authorization.
You must treat this software just like a book.    For example, this software may be used by any number of
people and may be freely moved from one computer location to another, as long as there is no 
possibility of it being used at more than one location at a time.    Just as a book cannot be read by two 
people at the same time.
You are encouraged to pass a copy of this software along to your friends for evaluation, but you must 
include all files in the original distribution.    Please encourage them to register their copy if they find that 
they make use of it.



Distributor License Agreement
Anyone wishing to charge people a fee for giving them a copy of this software must have the written 
authorization of the author, without which, the distributor is guilty of copyright violation.    To receive such 
authorization, send this completed application, along with a copy of your software library's order form to 
Helios Software Solutions.    Include £5.00 to cover the cost of processing the application and of sending 
you the latest version of the software.    For distributors already recognized by the Association of 
Shareware Professionals, this application is not necessary.

Name of Organization: ____________________________________
Your Name: _______________________________________________
Address:   _______________________________________________

_______________________________________________
_______________________________________________

Terms of Distribution of Windev and TextPad:
1.    The fee charged may not exceed $10, including postage, mailer and any other charges.
2.    Your library's catalog or listing must state that this program is not free, but is copyrighted software 
that is provided to allow the user to evaluate it before paying.
3.    The offering and sale of the software will be stopped at any time the author so requests.
4.    Copies must be made from the copy of the software sent to you with this agreement. This is required
for control purposes.
5.    Problems or complaints about the program will be reported to the author for investigation.    In return 
for a license to charge a fee for the distribution of the programs Windev and TextPad, I agree to comply 
with the above terms of distribution.

Signed, ____________________________________  ______________
your signature                        date

__________________________   _________   ______________
Keith MacDonald         control #         date



Definition of Shareware
Shareware distribution gives users a chance to try software before buying it.    If you try a shareware 
program and continue using it, you are expected to register.    Individual programs differ on details -- 
some request registration while others require it, some specify a maximum trial period.    With 
registration, you get anything from the simple right to continue using the software to an updated program
with printed manual.
Copyright laws apply to both shareware and commercial software, and the copyright holder retains all 
rights, with a few specific exceptions as stated below.    Shareware authors are accomplished 
programmers, just like commercial authors, and the programs are of comparable quality.    (In both 
cases, there are good programs and bad ones!)    The main difference is in the method of distribution.    
The author specifically grants the right to copy and distribute the software, either to all and sundry or to a
specific group.    For example, some authors require written permission before a commercial disk vendor
may copy their shareware.
Shareware is a distribution method, not a type of software.    You should find software that suits your 
needs and pocketbook, whether it's commercial or shareware.    The shareware system makes fitting 
your needs easier, because you can try before you buy.    And because the overhead is low, prices are 
low also.    Shareware has the ultimate money-back guarantee -- if you don't use the product, you don't 
pay for it.



Association of Shareware Professionals

Helios Software Solutions is an approved vendor and associate member of the Association of 
Shareware Professionals (ASP).
The primary goals of the ASP include:

o    To inform users about shareware programs and about shareware as a method of distributing and 
marketing software.
o    To foster a high degree of professionalism among shareware authors by setting programming, 
marketing, and support standards for ASP members to follow.
o    To encourage broader distribution of shareware through user groups and disk dealers who agree 
to identify and explain the nature of shareware.
o    To assist members in marketing their software.
o    To provide a forum through which ASP members may communicate, share ideas, and learn from 
each other.

The Association of Shareware Professionals have drafted a code of ethics for all present and future 
members.    This code of ethics includes the following requirements:

o    A member's program (evaluation version) must not be limited (crippled) in any way.    In the true 
spirit of Try-Before-You-Buy, users must be able to evaluate all the features in a program before 
paying the registration fee.
o    Members must respond to every registration.    At the very least they must send a receipt for the 
payment. 
o    Members must provide technical support for their products for at least 90 days from the date of 
registration.

The ASP has put in place a system to help ensure that users are treated fairly and professionally.    If a 
user is unable to resolve a problem with a member author then the user can contact the ASP 
Ombudsman with their complaint.    The Ombudsman will then try to help resolve the dispute.

ASP Ombudsman Statement:
Helios Software Solutions is a member of the Association of Shareware Professionals (ASP).    ASP 
wants to make sure that the shareware principle works for you.    If you are unable to resolve a 
shareware-related problem with an ASP member by contacting the member directly, ASP may be able to
help.    The ASP Ombudsman can help you resolve a dispute or problem with an ASP member, but does 
not provide technical support for members' products.
Please write to the ASP Ombudsman at:

ASP Ombudsman
545 Grover Road
Muskegon, MI    49442-9427
U.S.A.

or send a CompuServe message via CompuServe MAIL to ASP Ombudsman 70007,3536.



TextPad Order Form
Please register me as a licensed TextPad user, and send me a copy of the latest release.

Name:___________________________________________
Company:________________________________________
Address:________________________________________
________________________________________________
________________________________________________
Phone:_______________________________
Fax:_________________________________
E-mail:______________________________

Payment Due (valid from 1-September-1995):
Registration Fee: £19.00
Shipping & Handling*: £_____
Total paid: £_____
(*UK: £1.00, Europe £2.00, Worldwide: £3.00)

Cheque/Draft No._____________

Signed:______________________
Date:________________________

How did you discover TextPad?____________________________
_________________________________________________________

Any Comments:____________________________________________
_________________________________________________________
_________________________________________________________
_________________________________________________________

When you have filled in the above details, mail this to:
Helios Software Solutions
Carr Brook House
Chorley Old Road
Brindle
CHORLEY    PR6 7QZ
England

Thank you for your interest in this product.



File Open dialog box

The following options allow you to specify which file to open:
File Name

Type or select the filename you want to open.    This box lists files with the extension you select in the 
List Files of Type box. 

List Files of Type
Select the type of file you want to open:

Drives
Select the drive containing the file that you want to open.

Directories
Select the directory containing the file that you want to open.

Network...
Choose this button to connect to a network location, assigning it a new drive letter.



File Save As dialog box

The following options allow you to specify the name and location of the file you're about to save:
File Name

Type a new filename to save a document with a different name.    A filename can contain up to eight 
characters and an extension of up to three characters.

Drives
Select the drive in which you want to store the document.

Directories
Select the directory in which you want to store the document.

Network...
Choose this button to connect to a network location, assigning it a new drive letter. 



Title Bar

The title bar is located along the top of a window.    It contains the name of the application and 
document.

To move the window, drag the title bar.    Note: You can also move dialog boxes by dragging their title 
bars.

A title bar may contain the following elements:

Application Control-menu button
Document Control-menu button
Maximize button
Minimize button
Name of the application
Name of the document
Restore button



Scroll bars

Displayed at the right and bottom edges of the document window.    The scroll boxes inside the scroll 
bars indicate your vertical and horizontal location in the document.    You can use the mouse to scroll to 
other parts of the document.



Size command (System menu)

Use this command to display a four-headed arrow so you can size the active window with the arrow 
keys.

After the pointer changes to the four-headed arrow:
1. Press one of the DIRECTION keys (left, right, up, or down arrow key) to move the pointer to the 

border you want to move.    
2. Press a DIRECTION key to move the border.
3. Press ENTER when the window is the size you want.

Note:    This command is unavailable if you maximize the window.

Shortcut
Mouse: Drag the size bars at the corners or edges of the window.



Move command (Control menu)

Use this command to display a four-headed arrow so you can move the active window or dialog box with
the arrow keys.

Note:    This command is unavailable if you maximize the window.

Shortcut
Keys: Ctrl+F7



Minimize command (application Control menu)

Use this command to reduce the window to an icon.

Shortcut
Mouse: Click the minimize icon  on the title bar.

Keys: ALT+F9



Maximize command (System menu)

Use this command to enlarge the active window to fill the available space.

Shortcut
Mouse: Click the maximize icon  on the title bar; or double-click the title bar.

Keys: Ctrl+F10 enlarges a document window.



Next Window command (document Control menu)

Use this command to switch to the next open document window.    This corresponds to the order in which
you opened the windows.

Shortcut
Keys: Ctrl+F6



Previous Window command (document Control menu)

Use this command to switch to the previous open document window. This corresponds to the order in 
which you opened the windows.

Shortcut
Keys: SHIFT+Ctrl+F6



Close command (Control menus)

Use this command to close the active window or dialog box.
Double-clicking a Control-menu box is the same as choosing the Close command.

Shortcuts
Keys: Ctrl+F4 closes a document window

ALT+F4 closes the main window or a dialog box



Restore command (Control menu)

Use this command to return the active window to its size and position before you chose the Maximize or 
Minimize command.



Switch to command (application Control menu)

Use this command to display a list of all open applications.    Use this "Task List" to switch to or close an 
application on the list.

Shortcut
Keys: Ctrl+ESC

Dialog Box Options
When you choose the Switch To command, you will be presented with a dialog box with the following 
options:
Task List

Select the application you want to switch to or close.
Switch To

Makes the selected application active.
End Task

Closes the selected application.
Cancel

Closes the Task List box.
Cascade

Arranges open applications so they overlap and you can see each title bar.    This option does not 
affect applications reduced to icons.

Tile
Arranges open applications into windows that do not overlap.    This option does not affect 
applications reduced to icons.

Arrange Icons
Arranges the icons of all minimized applications across the bottom of the screen.



No Help Available

No help is available for this area of the window.



No Help Available

No help is available for this message box.



Print dialog box

The following options allow you to specify how the document should be printed:
Printer

This is the active printer and printer connection.    Choose the Setup option to change the printer and 
printer connection.

Setup
Displays a Print Setup dialog box, so    you can select a printer and printer connection.

Print Range
Specify the pages you want to print:
All Prints the entire document.
Selection Prints the currently selected text.
Pages Prints the range of pages you specify in the From and To boxes.

Copies
Specify the number of copies you want to print for the above page range.

Collate Copies
Prints copies in page number order, instead of separated multiple copies of each page.

Print Quality
Select the quality of the printing.    Generally, lower quality printing takes less time to produce.



Print Progress Dialog

The Printing dialog box is shown during the time that <<YourApp>> is sending output to the printer.    The 
page number indicates the progress of the printing.

To abort printing, choose Cancel.



Print Preview toolbar

The print preview toolbar offers you the following options:
Print

Bring up the print dialog box, to start a print job.
Next Page

Preview the next printed page.
Prev Page

Preview the previous printed page.
One Page / Two Page

Preview one or two printed pages at a time.
Zoom In

Take a closer look at the printed page.
Zoom Out

Take a larger look at the printed page.
Close

Return from print preview to the editing window.



Print Setup dialog box

The following options allow you to select the destination printer and its connection.
Printer

Select the printer you want to use.    Choose the Default Printer; or choose the Specific Printer option 
and select one of the current installed printers shown in the box.    You install printers and configure 
ports using the Windows Control Panel. 

Orientation
Choose Portrait or Landscape.

Paper Size
Select the size of paper that the document is to be printed on.

Paper Source
Some printers offer multiple trays for different paper sources.    Specify the tray here.

Options
Displays a dialog box where you can make additional choices about printing, specific to the type of 
printer you have selected.

Network...
Choose this button to connect to a network location, assigning it a new drive letter.




