
Opening Icon Resource Files

1    Click the Icons Tab.
2    Browse to the folder which contains the icon file.
3    Double click on file.
4    Studio will open the image, and place it in the grid area, ready to be edited.



Opening Icon Libraries

1    Click the Libraries Tab.
2    Browse to the folder which contains the file.
3    Double click to open in the Librarian.
Tip:
· Once the Icon Library is open, you may double click on any icon to start editing the image with the

Studio component.
· When working with an icon image in a Application file or an Application Extension, the Librarian is 

unable to delete images from the file. These file types can include program code and/or other 
types of resources.    Making any changes to these types of files other than editing the existing 
images could result in the loss of important information. 



Opening Application Files 

1    Click the Libraries Tab.
2    Browse to the folder which contains the file.
3    Double click on the file to open.
Tip:
· When working with an icon image in an Application file or Application Extension, the Librarian is 

unable to delete images from the file. These file types can include program code and/or other 
types of resources.    Making any changes to these types of files other than editing the existing 
images could result in the loss of important information. 

· Click with thr right mouse button, and select Save As ICO, this will provide you the ability to edit 
the image, and use it elsewhere on your desktop.



Creating a New Icon

1    Click the New Tab.
2    Double click New Icon.
3    Microangelo Studio will open with a blank grid area to start creating a new icon.
4    Once drawing has been completed, click Save As from the File menu.
Tip:
· When you click Save As from the File menu, it    will update the image in the file, but leave the 

Studio open, so that you may edit the image with different color schemes, or shapes, etc.



Creating a ‘Custom’ Size Icon Resource

1    Click the New Tab.
2    Double click on New Icon.
3    Microangelo Studio will open with a blank grid area to start creating a new icon.
4    Click the New Image Format button (far right of toolbar), and choose the size, and number of 

colors from the different options; or scroll to the Custom... selection and define your own.
5    Once editing has been completed, click Save As from the File menu.



Editing an Existing Icon Resource

1    Click the Icons Tab.
2    Browse to the folder, that contains the image to be edited.
3    Select the file, and double click to open.
4    This will invoke an edit session with the Studio.
5    Make any desired changes to the image.
6    Click Save from the File menu.
Tip:
· When you click Save from the File menu, it    will update the image in the file, but leave the Studio 

open, so that you may edit the image with different color schemes, or shapes, etc.    



Creating an Icon Resource From a Bitmap

1    Click the New Tab.
2    Double click New Icon, this will start the Studio component.
3    Click the New Image Format button (far right of toolbar), and choose the size, and number of 

colors from the different options; or scroll to the Custom... selection and define your own.
4    Click Open Bitmap File from the Edit menu.
5    Browse to the folder which contains the bitmap file.
6    Select the file, and click Open, the bitmap will be pasted into the grid area.
7    Click Save As from the File menu to save image as an icon.
Tip:
· You may also convert a BMP file into an icon, by pasting it to the Clipboard, and using the Paste 

Special option on the Edit menu.    However, if your bitmap uses colors that are not available in the
currently active palette, the Studio will substitute the closest color available from the currently 
active palette.    To ensure color integrity, always use the Open Bitmap File, on the Edit menu.



Copying/Moving an Icon From Library to New Library

1    Click the Libraries Tab.
2    Browse to the folder where the file of the image is saved.
3    Double click on file to open it in the Librarian.
4    Click New Window from the File menu.
5    Click on image with the right mouse button, then drag and drop it into the new library.    A pop 

up menu will appear with available options.
6    Click Save As from the File menu.
Note:
· While the icon is being dragged, the cursor will display an image of the icon whenever it is 

positioned over a legal drop area. 
· You may select multiple icons from the saved file, and move them to a new file.



Copying/Moving an Icon From Library to Library

1    Click the Libraries Tab.
2    Browse to the folder where the library is saved.
3    Double click on the file to open, the file will be opened in the Librarian.
4    Click New Window from the File menu.
5    Click Open from the File menu, in the new window.
6    Browse to the folder where the icon library is located.
7    Select the file, and click Open.
8    Click on image with the right mouse button, then drag and drop it into the new library.    A pop 

up menu will appear with available options.
9    Click Save from the File menu.
Note:
· While the icon is being dragged, the cursor will display an image of the icon whenever it is 

positioned over a legal drop area. 
· You may select multiple icons from the saved file, and move them to a new file.



Copying/Moving Multiple Icons Into a New Library

1    Click the Libraries Tab.
2    Browse to the folder where the library is saved.
3    Double click on file to open, it will open in the Librarian.
4    Click New Window from the File menu.
5    Select the icons, by holding the CTRL key down, and clicking once on each image.
6    Drag and drop one image into the new window, all the images will be pasted in to the new 

window (using left button=Move, using right button=Copy).
7    Click Save As from the File menu.
Note:
· While dragging the icons, the cursor will display an image of a paper clip attached to a sheet of 

icons, whenever it is positioned on top of a legal drop area.    
· A circle with a slash is displayed when the cursor is over any area that the icons cannot be 

dropped on.    Any open window inside the Microangelo Librarian is a valid drop area.    



Copying/Moving Icon Images Into Libraries

1    Click the Libraries Tab.
2    Browse to the folder where the library is saved.
3    Double click on file to open, it will open in the Librarian.
4    Click New Window from the File menu.
5    Click Open from the File menu, of the new window.
6    Browse to the folder where the library is saved.
7    Select file, and click open.
8    Select the icons, by holding down the CTRL key, and clicking once on each image to be moved.
9    Drag and drop one image into the exisitng file window, all the images will be pasted into that 

window (using left button=Move, using right button=Copy).
10    Click Save from the File menu.
Note:
· While dragging the icon, the cursor will display an image of a paper clip attached to a sheet of 

icons, whenever it is positioned on top of a legal drop area.    
· A circle with a slash is displayed when the cursor is over any area that the icon cannot be dropped

on.    Any open window inside the Microangelo Librarian is a valid drop area.    



Creating a New Animated Cursor

1    Click the New Tab.
2    Double click New Cursor.
3    Microangelo Animator will open with a blank grid area to start creating a new cursor.
4    Once drawing has been completed, click Save As from the File menu.
Note:
· If you would like to create a 256 color animated cursor, click the New button on the toolbar, and 

select 256, from the Color Depth dialog.



Opening Animated Cursor Files 

1    Click the ANI Cursors Tab.
2    Browse to the folder which contains the file.
3    Double click on the file to open.



Pencil Tool

1    Click the Pencil tool button in the tool box; or on the Tools menu, click Choose Tool.Pencil.
2    Move the Pencil to the place on the grid where you want to start drawing.
3    Click the left mouse button (for Color ‘A’) or the right button (for Color ‘B), and hold it down as 

you draw.
4    Release the mouse button.
Tip:
· Pressing either SHIFT key will restrict the Pencil tool to the current row or column.    You can press 

and release the SHIFT key more than once during a single draw to restrict and free the drawing 
motion.



Brush Tool

1    Click the Brush tool in the tool box; or on the Tools menu, click Choose Tool.Brush.
2    Select a shape representing the brush you want to draw with from the tool pan directly below 

the tool box.    A highlight appears around the shape you have selected.
3    Move the cursor to the place on the grid where you want to start drawing.
4    Click the left mouse button (for Color ‘A’) or the right button (for Color ‘B’), and hold it down as 

you draw.
5    Release the mouse button.



Flood Tool

1    Click the Flood tool in the tool box; or on the Tools menu, click Choose Tool.Flood.
2    Move the cursor to the area you want to fill.
3    Click the left or right mouse button to flood with Color ‘A’ or Color ‘B’, respectively.



Color Eraser

1    Click the Color eraser in the tool box; or on the Tools menu, click Choose Tool.Color Eraser.
2    Select a shape representing the Eraser you want to use, from the area below the tool box.    A 

rectangle appears around the option you have selected.
3    Move the Eraser to the place on the image where you want to start editing.
4    Click the left mouse button to replace Color ‘A’ with Color ‘B’.    Click the right mouse button to 

replace Color B with Color A.



Straight Line Tool

1    Click the Straight line tool in the tool box; or on the Tools menu, click Choose Tool.Straight Line.
2    Place the cursor at the starting point for the line.
3    Drag the cursor to where the line will end.    The origin and the X and Y components of the line 

will be displayed in the status bar.
4    Release the mouse button to complete the drawing operation. 
Tip:
· Press either SHIFT keys to restrict the line to increments of 45 degrees.



Rectangle Tool

1    Click the Rectangle tool in the tool box; or on the Tools menu, click Choose Tool.Rectangle.
2    Move the cursor to one corner of the of the rectangle.
3    Drag diagonally to the opposite corner.    The origin and size of the rectangle will be displayed at 

the far right of the status bar.
4    Release the mouse button to complete the drawing operation.
Tip:
· Press either SHIFT keys to restrict the drawing to perfect squares.



Rectangle Tool (Filled)

1    Click the Rectangle tool (filled) in the tool box; or on the Tools menu, click Choose 
Tool.Rectangle (Filled).

2    Move the cursor to one corner of the rectangle.
3    Drag the cursor diagonally to the opposite corner.    The size of the rectangle will be displayed at 

the far right of the status bar.    (When the left mouse button is used to drag, the rectangle will be 
framed with Color A and filled with Color B.    Using the right mouse button reverses this operation
- the rectangle will be framed with Color B and filled with Color A).

4    Release the mouse button to complete the drawing operation.
Tip:
· Press either SHIFT keys to restrict the drawing to perfect squares.



Rectangle Tool (Solid)

1    Click the Rectangle tool (solid) in the tool box; or on the Tools menu, click Choose 
Tool.Rectangle (Solid).

2    Move the cursor to one corner of the rectangle.
3    Drag the cursor diagonally to the opposite corner. The size of the rectangle will be displayed at 

the far right of the status bar.    (When the left mouse button is used to drag, the rectangle will be 
drawn with Color A.    Using the right mouse button draws the rectangle using Color B).

4    Release the mouse button.
Tip:
· Press either SHIFT keys to restrict the drawing to perfect squares.



Color Pipette

1    Click the Color pipette tool in the tool box; or on the Tools menu, click Choose Tool.Color 
Pipette 

2    Move the cursor over the pixel which contains the desired Color   ‘  A  ’   or Color   ‘  B  ’  .
3    Click the left mouse button to replace color ‘A’ or the right mouse button to replace color ‘B’.    

The color is updated and the cursor returns to the prior drawing tool.
Note:
· The Color pipette can only be accessed from the tool box or Tools menu when you are working 

with a 256 color icon image.



Selection Frame

1    Click the Selection tool in the tool box; or on the Tools menu, click Choose Tool.Selection 
Frame.

2    Move the cursor to one corner of the area that you want to select.
3    Drag the cursor to the opposite corner of the area you want to select. A rectangle shows which 

pixels will be selected. All pixels within the rectangle, including those "under the rectangle," are 
included in the selection.    The size of the area selected will be displayed at the far right of the 
status bar.

4    Release the mouse button to complete the select operation. A highlighted border will enclose the
selected area. The area may now be dragged to any other location in the work area, or operated 
on using the Cut or Copy editing commands.



Ellipse Tool

1    Click the Ellipse tool in the tool box; or on the Tools menu, click Choose Tool.Ellipse.
2    Move the cursor to one corner of the of the bounding rectangular area that will contain the 

ellipse.
3    Drag diagonally to the opposite corner.
4    Release the mouse button to complete the drawing operation.
Tip:
· Press either SHIFT keys to restrict the drawing to perfect circles.



Ellipse Tool (Filled)

1    Click the Ellipse tool (filled) in the tool box; or on the Tools menu, click Choose Tool.Ellipse 
(Filled).

2    Move the cursor to one corner of the of the bounding rectangular area that will contain the 
ellipse.

3    Drag diagonally to the opposite corner.    (When the left mouse button is used to drag, the ellipse
will be framed with Color A and filled with Color B.    When the right mouse button is used this 
operation is reversed - the ellipse will be framed with Color B, and filled with Color A).

4    Release the mouse button to complete the drawing operation.
Tip:
· Press either SHIFT keys to restrict the drawing to perfect circles.



Ellipse Tool (Solid)

1    Click the Ellipse tool (solid) in the tool box; or on the Tools menu, click Choose Tool.Ellipse 
(Solid).

2    Move the cursor to one corner of the of the bounding rectangular area that will contain the 
ellipse.

3    Drag the cursor diagonally to the opposite corner.    (When the left mouse button is used to drag, 
the ellipse will be drawn using Color A.    When the right mouse button is used, it will be drawn 
with Color B).

4    Release the mouse button to complete the drawing operation.
Tip:
· Press either SHIFT keys to restrict the drawing to perfect circles.



Color Locator

1    Click the Color locator tool in the tool box; or on the Tools menu, click Choose Tool.Color 
Locator.

2    Click a cell in the grid area or the color well in the color box that contains the color to be located.
The color well will blink in the color box and in all cells in the grid area that contain the color.

Note:
The Color locator can only be accessed from the tool box or Tools menu when you are working with 

a 256 color icon image.



The New Image Format option, is located to the far right of the tool bar, and gives you the ability to 
determine the size, and number of colors to be used in creating a new image for an icon.



The grid area is a zoomed view of the image being edited, and the area where all drawing takes 
place.



Open an existing image format by selecting it using the Image Format drop down combo control, 
above the grid area.    A new image format can be added to the current icon by pressing the New 
Image Format button located at the far right of the tool bar.



Multiple icons can be selected by clicking in an area outside of an icon and then dragging the 
mouse cursor to surround the desired icons, or by holding down the CTRL key and clicking once on 
each icon to be selected.



The Blend Color dialog is activated by double clicking on any color inside the 256 color Palette 
window.    



An Application file, in Windows 95, is the equivalent to an (*.EXE) file, under the old DOS based 
naming convention.



An Application Extension, in Windows 95, is the equivalent to a (*.DLL) file, under the old DOS 
naming convention.



An Icon Library, in Windows 95, is the equivalent to an (*.ICL) file, under the old DOS naming 
convention.



An Icon Resource, in Windows 95, is the equivalent to an (*.ICO) file, under the old DOS naming 
convention 



The view menu contains options that determine what features are displayed.    You can toggle the 
display of the tool bar, the status bar, the color box, the tool box, and the editing grid.



The status panel is located to the left of the grid area.    It displays an actual size view of the image 
being edited and the current ‘A’ and ‘B’ drawing colors.



The color box is used to select drawing colors when creating or editing an image. The color box is a 
pop up window that can be moved anywhere on your desktop.    The color box offers a full range of 
colors for the image being edited, as well as transparent and inverse screen selections.



The tool box provides access to the tools used to edit an image. The tool box is a pop up window 
that can be moved anywhere on your desktop.



Color A is assigned to your left mouse button.    Choose a new Color ‘A’ by positioning the cursor 
over a color well in the color box and clicking the left mouse button.



Color B is assigned to your right mouse button.    Choose a new Color ‘B’ by positioning the cursor 
over a color well in the color box and clicking the right mouse button.



The status bar at the bottom of the program window displays information and messages that 
provide feedback as you work.    It displays information about tool buttons and menu selections, and
also provides information on the cursor location and movement during drawing operations.



The transparent ink well is available on all palettes.    It is the well that has a computer screen filled 
with a dark blue color.    When this ink is used, all pixels will display as transparent, for the image.



The inverse screen ink well is available on all palettes.    It is the well that has a computer screen 
filled with a pink color.    When this ink is used, the complement color of the background is used.    
For example it will display as white on a black background, or as red when displayed on a blue 
background.



This will scale a bitmap image either from the Clipboard (if an image is present), or directly from a 
bitmap file.    You will also have the option of pasting into the grid as a New Selection, or paste into 
the grid in the current selection.



The New Selection will paste the bitmap image into the grid area, without altering the size of the 
bitmap image.



The current selection is only available, if pixels has been defined in the grid area, by the selection 
frame tool.    Microangelo will scale the size of the current image, into the area defined by the 
selection frame.



The Open Bitmap As Image, found on the Edit menu, is the most efficient way to convert a bitmap 
image into an icon.    With this selection, color integrity of the bitmap is preserved.    Studio will alter
the color box, to accommodate any colors that are not found in the palette, but used in the image.   
If the Paste Special selection is used, color integrity is NOT preserved.    The Studio will use a color 
close to the one used in the original bitmap image. 



The selection frame defines an area of the bitmap that you can cut, copy, clear, or move.



If you click the display button, the status panel will display the cursor in action.    To cease the action
click the stop button, then the status panel will display the currently selected frame.    While the 
cursor is in action, frames cannot be added or deleted.



The speed of the animation will increase if the global speed adjustment is moved to the right, and 
decrease if moved to the left.    All frames are affected by the global speed adjustment setting.    It is
located directly below the Display and Stop Animation buttons, in the status panel.



The Browser can always be accessed from the File menu of any Microangelo component.



The nudge and flip buttons will manipulate all graphics inside of the selection frame, or the entire 
grid, if the selection frame is not used.



The dither buttons can determine which pixels are affected, during a specific drawing action.



The screen capture button provides you a dialog to choose the size image you would like to 
capture, or create your own from the drag custom area option.    Upon selecting the 16x16, 32x32, 
or 48x48 size capture, your cursor will switch to a viewport, equivalent to the size of the image you 
selected.



One jif is approximately equal to 1/60th of a second.



Located at the right of the Engineer’s window. This displays which tabs will be updated when you 
click the Apply button.    It also displays changes on tabs that will be included, when creating or 
editing a Microangelo motif file.



The Engineer can operate in two modes: Local System Update and Motif File Maintenance.    These 
modes can be switched from the Config menu.    

· Local System will be the mode that the Engineer should be set to when making updates to icons 
and cursors on your system.    

· Motif File Maintenance will be the mode that the Engineer should be set to only when creating or 
editing a Microangelo Motif file.    



If you click the Clear Update button, the Engineer will undo any pending updates to the selected 
icon or cursor.



The Reset All button, will clear any pending updates to all tabs.



When you click the New button, the Engineer will clear any pending updates to all tabs.



If you click the Save button while editing a motif file, any pending changes will be updated to the 
active file.    If you want to create a new motif file, click the Save As button.



 A Micorangelo Motif file can enhance the look of your entire desktop.    A motif file can include 
cursors and icons.    You can save a motif, and you can modify it by changing one or more of its 
elements.



When an icon or cursor is selected, the status bar will display the pathway currently used to support
the image.



 To show or hide the toolbar, on the View menu, click Toolbar.    When the command has a check 
mark next to it, the toolbar is on.



Opening Icon Libraries 

There can be different procedures to follow, to help you accomplish a task the most efficient way 
possible.

What do you want to do?

{button ,JI(`Muangelo.hlp>Proceed1',`mua_opening_icl_and_dll_files_browse')}      Open an icon 
library from the Browser?
{button ,JI(`Mumgr.hlp>Proceed',`lib_opening_icl_and_dll_files_librarian')}      Open an icon library 
from the Librarian?



Opening Icon Resource Files

There can be different procedures to follow, to help you accomplish a task the most efficient way 
possible.

What do you want to do?

{button ,JI(`Muangelo.hlp>Proceed1',`mua_opening_ico_files_browse')}      Open an icon resource 
from the Browser?
{button ,JI(`Mumgr.hlp>Proceed',`lib_opening_ico_files_librarian')}      Open an icon resource from 
the Librarian?
{button ,JI(`Muedit.hlp>Proceed',`stu_opening_ico_files_studio')}      Open an icon resource from the 
Studio?



Opening Application Files

There can be different procedures to follow, to help you accomplish a task the most efficient way 
possible.

What do you want to do?

{button ,JI(`Muangelo.hlp>Proceed1',`mua_opening_exe_files_browse')}      Open an application file 
from the Browser?
{button ,JI(`Mumgr.hlp>Proceed',`lib_opening_exe_files_librarian')}      Open an application file from 
the Librarian?



Create Icon Image

There can be different procedures to follow, to help you accomplish a task the most efficient way 
possible.

What do you want to do?

{button ,JI(`Muangelo.hlp>Proceed1',`mua_create_new_icon_browse')}      Create a new icon from 
the Browser?
{button ,JI(`Mumgr.hlp>Proceed',`lib_create_new_icon_librarian')}      Create a new icon from the 
Librarian?
{button ,JI(`Muedit.hlp>Proceed',`stu_create_new_icon_studio')}      Create a new icon from the 
Studio?



Creating a ‘Custom” Size Icon Image

There can be different procedures to follow, to help you accomplish a task the most efficient way 
possible.

What do you want to do?

{button ,JI(`Muangelo.hlp>Proceed1',`mua_create_custom_icon_browse')}      Create a ‘custom’ size 
and color icon from the Browser?
{button ,JI(`Mumgr.hlp>Proceed',`lib_creating_custom_size_librarian')}      Create a ‘custom’ size 
and color icon from the Librarian?
{button ,JI(`Muedit.hlp>Proceed',`stu_creating_custom_size_studio')}      Create a ‘custom’ size and 
color icon from the Studio?



Edit Icon Resource Image

There can be different procedures to follow, to help you accomplish a task the most efficient way 
possible.

What do you want to do?

{button ,JI(`Muangelo.hlp>Proceed1',`mua_edit_an_icon_browse')}      Edit an existing icon resource 
from the Browser?
{button ,JI(`Mumgr.hlp>Proceed',`lib_edit_an_icon_librarian')}      Edit an existing icon resource from 
the Librarian?
{button ,JI(`Muedit.hlp>Proceed',`stu_edit_an_icon_studio')}      Edit an existing icon resource from 
the Studio?



Create an Icon Image From a Bitmap

There can be different procedures to follow, to help you accomplish a task the most efficient way 
possible.

What do you want to do?

{button ,JI(`Muangelo.hlp>Proceed1',`mua_converting_bmp_file_browse')}      Creating an icon 
resource from a bitmap from the Browser?
{button ,JI(`Mumgr.hlp>Proceed',`lib_converting_bmp_file_librarian')}      Creating an icon resource 
from a bitmap from the Librarian?
{button ,JI(`Muedit.hlp>Proceed',`stu_converting_bmp_file')}      Creating an icon resource from a 
bitmap from the Studio?



Copying/Moving an Icon Image to a New Library

There can be different procedures to follow, to help you accomplish a task the most efficient way 
possible.

What do you want to do?

{button ,JI(`Muangelo.hlp>Proceed1',`mua_ moving_from_saved_to_new_browse')}      
Copying/Moving an icon from a library, and create a new library from the Browser?
{button ,JI(`Mumgr.hlp>Proceed',`lib_multiple_saved_to_new')}      Copying/Moving an icon from a 
library, and create a library from the Librarian?



Copying/Moving an Icon Image to a Library

There can be different procedures to follow, to help you accomplish a task the most efficient way 
possible.

What do you want to do?

{button ,JI(`Muangelo.hlp>Proceed1',`mua_ moving_into_existing_browse')}      Copying/Moving 
from a library, to a library from Browser?
{button ,JI(`Mumgr.hlp>Proceed',`lib_multiple_into_existing_file')}      Copying/Moving from a library,
to a library from Librarian?



Copying/Moving Multiple Icons Into a New Library

There can be different procedures to follow, to help you accomplish a task the most efficient way 
possible.

What do you want to do?

{button ,JI(`Muangelo.hlp>Proceed1',`mua_ multiple_saved_to_new_browse')}      Copying/Moving 
multiple icons and create a new library from the Browser?
{button ,JI(`Mumgr.hlp>Proceed',`lib_multiple_saved_to_new')}      Copying/Moving multiple icons 
and create a new library from the Librarian?



Copying/Moving Multiple Icons Into a Library

There can be different procedures to follow, to help you accomplish a task the most efficient way 
possible.

What do you want to do?

{button ,JI(`Muangelo.hlp>Proceed1',`mua_ multiple_into_existing_file_browse')}      Copying/Moving
multiple icons into a library from the Browser?
{button ,JI(`Mumgr.hlp>Proceed',`lib_multiple_into_existing_file')}      Copying/Moving multiple icons 
into a library from the Librarian?



Create an Animated Cursor File

There can be different procedures to follow, to help you accomplish a task the most efficient way 
possible.

What do you want to do?

{button ,JI(`Muangelo.hlp>Proceed1',`mua_create_new_cursor_browse')}      Create an animated 
cursor from the Browser?
{button ,JI(`Muani.hlp>Proceed',`ani_new_cursor')}      Create an animated cursor from the 
Animator?



Open an Animated Cursor File

There can be different procedures to follow, to help you accomplish a task the most efficient way 
possible.

What do you want to do?

{button ,JI(`Muangelo.hlp>Proceed1',`mua_opening_ani_files_browse')}      Open an existing 
animated cursor from the Browser?
{button ,JI(`Muani.hlp>Proceed',`ani_open_file')}      Open an existing animated cursor from the 
Animator?



Introduction to Microangelo

Microangelo consists of five major components: the Browser, Animator, Engineer, Librarian, and 
Studio. 
The Browser will help you locate the files on your system that contain icons.    It provides you a 
place to start whenever you want to open a file, and can easily be accessed from the File menus of 
the Animator, Librarian, and Studio.    
The Animator will create and edit 16 and 256 color Animated Cursor files (*.ANI).    
The Engineer will install ICO files to replace over thirty standard WIN 95 icons, and install ANI and 
CUR files to replace fourteen standard cursors.    
The Librarian has been developed to facilitate managing and editing icons that are contained inside
Icon Resource, Icon Library, Application, and Application Extension files.    These file types are the 
Windows 95 equivalents of the ICO, ICL, EXE, and DLL file extensions used in the old DOS file 
naming convention.
The Studio will create and edit icon images contained in Icon Resource files.    It also acts as a 
server application for the Librarian to allow editing of icons contained inside other file types.    The 
Studio can also create and edit cursor (CUR) files in monochrome, 16, or 256 colors.

Microangelo Browser

    Icons
When you click on these Tabs and navigate through different folders on your machine, the Browser 
will only display the files that contain icons. If you double click on a file in the Icons tab, the file will
be opened in a Studio edit session.    Selecting a file in the Libraries tab will open the file in the 
Librarian.
Once a Librarian window has been opened, the Browser can be used to drag and drop files onto the 
Librarian.    Using the right mouse button to drag and drop, will provide a choice of either opening 
the file or adding the icons in the file(s) to the current Librarian workspace.
The Browser can also work directly with the Engineer component.    To replace icons and cursors on 
your system, simply drag and drop files from their respective tabs in the Browser, onto the images 
in the Engineer tabs.

    Animated Cursors (ANI)
When you click on the Animated Cur. tab, the Browser will display all animated cursor files located 
in the selected drive and folder.    If you double click on a file in this tab, the file will be opened in 
the Animator component, ready for editing.

    Cursors (CUR)
When you click on the Cursors tab, the Browser will display all cursor files located in the selected 
drive and folder.    If you double click on a file in this tab, the file will be opened in the Studio 
component, ready for editing.

Microangelo Animator
Microangelo Animator supports the editing and creating of animated cursors (*.ANI).    To create a 
new file, click the New tab from the Browser, and select New Animated Cursor.    The Animator can 
create or edit cursor files that are 32x32 pixels, in 16 and 256 colors.

Microangelo Engineer
The Engineer will give you the ability to replace standard WIN 95 icons, animated cursors (ANI), and
standard cursors (CUR) even if you do not have the Microsoft Plus! package installed on your 
machine.    The Engineer also allows you to change the size and color depths of the icons you 
display on your system.
The different tabs displayed upon initializing the Engineer, organize the icons and cursors that it 
can replace.    You can drag and drop icons and cursors from their respective tabs in the Browser, 
directly onto the file that you would like to replace; or you can use the Change button, and browse 
for a replacement file.



When you switch to Motif File Maintenance (Config menu), you can create and save Microangelo 
Motif files, to be used to give WIN 95 the look you prefer.    The Engineer can also open and update 
your system with Microsoft Plus! Theme files.

 Microangelo Librarian
The Microangelo Librarian provides you with the capability to extract, edit, organize, and store icons
on your system.    You can open a file in Librarian from the Libraries tab in the Browser or from 
Windows Explorer.    Double click on the file or simply drag and drop it onto an open Librarian 
window.
Individual icons can be moved or copied by dragging and dropping between Librarian windows to 
create customized icon libraries.    Icons contained in icon libraries and application files, can be 
modified in the Studio by double clicking on the icon in the Librarian window.

Microangelo Studio
Microangelo Studio supports the editing of various sizes and formats of icon images contained in 
icons.    It will create, open, and save icon resource files (*.ICO format) or support the Librarian 
directly.    Select a file from the Icons tab in the Browser to open the file in an edit session with the 
Studio.    Double click on any icon in the Librarian to establish an edit session with the Studio.    
Microangelo Studio will create or edit any size icon image from 8x8 to 64x64 pixels in monochrome,
16, or 256 color formats.
_________________________________________________
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Using the Windows Explorer

Animator
Double click on any Animated Cursor file to open in the Animator ready for editing.    When your 
updates have been completed, select Save from the File menu; and then exit.

Engineer
Double click on any Microangelo Motif file to open in the Engineer, in Local System mode, ready to 
be applied to your system.

Librarian
Windows Explorer can be a useful tool to navigate through the drives and folders on your machine.   
Double click on any Icon Library file to open it in a new Librarian window.    Drag and drop any file 
that contains icons into any open Librarian window to open the file.    Using the right mouse button 
to drag and drop provides access to a pop up menu where you can select to add the icons to the 
current Librarian workspace.

Studio
Double click on any Icon Resource file to start an edit session with the Studio where you can edit 
the icon.    When your updates have been completed, select Save from the File menu; and then exit.
_________________________________________________
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Microangelo Colors

To choose a color, position the cursor over any color well in the color box, then click the left mouse 
button to set Color A, or click the right mouse button to set Color B.    The color box is a free floating
pop up window.    It can be turned on or off from the View menu.

The tools in the tool box use the A and B colors for all drawing operations.    The currently selected A
and B colors are displayed in the status panel to the left of the grid area.

Animator
Color Box
Microangelo Animator initializes with a color box, that contains the 16 primary colors.    In addition 
to providing 16 primary colors, the color box also includes color wells that contain transparent and 
inverse screen ink.    From the tool bar click the New button, to create an animated cursor file using 
256 colors. 
Creating Custom Colors
When editing a cursor containing 256 colors, you can edit any color in the color box by double 
clicking directly on its color well.    If you create a 256 color cursor and customize colors in the color 
box, you can save the color palette by clicking Save Palette from the Edit menu.

Studio
Color Box
Microangelo Studio initializes the color box with the complete range of colors used by the current 
image being edited.    In addition to providing monochrome, 16, and 256 regular painting colors, the
color box also includes color wells that contain transparent and inverse screen ink.    To create or 
edit icon images in different color formats, select an existing image format from the Image Format 
combo box on the tool bar, or add a new image by clicking the New Image Format button on the far 
right of the tool bar.
Palette Files
The Studio initializes the color box for a new 256 color image using a default palette file included 
with Microangelo (default.pal).    You can save different palette files on your system by opening the 
Edit menu and clicking Save Palette, and use them again later by clicking the Open Palette option.    
The palette files used by Studio are not binary PAL files used by some Windows applications.    They 
are ASCII text files in a format used by Paint Shop Pro from JASC, Inc.    So in addition to being able 
to edit colors graphically in the Studio, you can also edit your palette files in a plain text editor such
as Notepad.    (Do not attempt to edit a palette file using Wordpad or any other word processing 
application).    The header records are followed by color definitions, one color per record.    Colors 
are defined by their relative red, green, and blue components in intensities from 0 to 255.
Creating Custom Colors
When editing an image containing 256 colors, you can edit any color in the color box by double 
clicking directly on its color well.    If you create a 256 color icon and customize colors in the color 
box, you can save the color palette by clicking Save Palette from the Edit menu.
___________________________________________________
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How Colors are Used by the Drawing Tools

Drawing
The left mouse button is used with most of the drawing tools to paint using the primary 'A' color, 
and the right mouse button is used to paint using the secondary 'B' color.    The Pencil, Line, Brush, 
Flood, Rectangle, and Ellipse functions operate in this manner.

Color Eraser
The 'A' and 'B' colors are used to specify the foreground and background colors for the color eraser. 
The tool will change the 'A' (foreground) color to the 'B' (background) color.    Using the right mouse 
button instead of the left will reverse this operation, changing any 'B' color under the Eraser to the 
'A' color.

Selection frame
The 'B' (background) color is also used when the selection frame is used to cut or drag a selection 
to a new location.    The desired 'B' color must be chosen before making the selection.
When a cut operation is performed, or the selection is dragged to a new location, the area the 
image previously occupied is filled with the 'B' color.
You can also use the Tools menu and click Paste and Drag to select either the Transparent or 
Opaque color ‘B’ option.    When a selection is dragged and the Transparent Color B option is in 
effect, any area in the selection that matches the 'B' color will be treated as a transparent area 
during the drag.
_________________________________________________
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Introduction to Microangelo Animator/Studio

Animator
Microangelo Animator can create, open, and save Animated Cursor files.    The Animator will create 
or edit images 32x32 pixels in 16 and 256 colors.
Studio
Microangelo Studio can create, open, and save Icon Resource files.    The Studio will create or edit 
any size image from 8x8 to 64x64 pixels in monochrome, 16, or 256 color formats.

Workspace
At the center of the main window is the    grid area.    It displays the zoomed view of the image and 
is where all drawing actions take place.    Above the grid area is where the most commonly used 
menu commands can be accessed from the tool bar. A screen capture button is also contained on 
the tool bar.    You can capture a portion of your screen, paste it into the grid area, to create a 
custom image.

To the left of the grid area, is the status panel that displays, from top to bottom, an actual size 
image being edited, and the current Color   ‘  A  ’   and Color   ‘  B  ’   settings.
The color box and the tool box are separate pop up windows.    Click the left or right mouse button 
over the desired color well in the color box to select a new ‘A’ or ‘B’ color.    A set of dither buttons 
are located directly above the tool buttons, in the tool box. The drawing tools will only color the 
pixels as directed by the dither selection.
At the bottom of the program window is the status bar.    When a tool tip is activated or when one of
the tool’s from the tool box is selected, a short description of the action or tool will be displayed on 
the left side of the bar.    The current X and Y coordinates of the cursor are displayed to the right 
when it is moved over the grid area.    Directly underneath the editing grid, are a set of nudge 
buttons, these buttons can manipulate the graphic in the grid area.    If the selection frame is used, 
the nudge buttons only affect the selected graphic.

Animator
When using the Animator on cursor files, the status panel will also contain Display and Stop 
Animation buttons, and a Global speed adjustment directly below the view of the actual size of the 
image.    To the right of the grid area is the frame layout area.    This area will display all frames for a
cursor file.    Each frame has a duration of play time, measured in jifs.    Each frame can have a 
different duration of play.

Studio
Microangelo Studio initializes the new image size and color format to 32 x 32 pixels and 16 colors.    
You can select the size and color format of a new image in an icon by clicking on the New Image 
Format button on the tool bar.    
_________________________________________________
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General Rules for Operating the Tools

Microangelo Studio and Animator will initialize to a minimum window size.    The main window size 
may be increased, but it cannot be reduced below the minimum size.    The color box and tool box 
are separate pop up windows that can be moved anywhere on your screen.    Click the View menu to
control the display of features including the tool and status bars and the color box and tool box.

    Freehand tools
Drawing with freehand tools (Pencil, Brush, and Color Eraser) is performed by pressing the left or 
right button in the edit area.    Drawing continues as the mouse is moved until the mouse button is 
released.

    Precision tools
Drawing with precision tools (Line, Rectangle, and Ellipse tools) is performed by pressing the left or 
right mouse button and dragging the mouse with the button depressed.    A line image of the 
potential figure is displayed in the grid area and in the actual size image in the status panel as the 
drawing action is performed.    Releasing the mouse button completes the paint operation and 
updates the icon image.

    Flood tool
To paint using the flood tool, press the left or right mouse button over a color cell in the grid area.    
The pixels, and all adjacent pixels of the same color will be filled.    The operation continues until the
flood is completely bounded by different color pixels.

    Selection frame
The selection frame works very much like the rectangle tool.    Press the left mouse button and drag 
to select areas of the edit image.    A selected area can be cut, copied or moved to a different 
location.    You can also    paste into the selected area using the Paste Special selection on the Edit 
menu.
_______________________________________________________________
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Edit menu

Undo
Reverses changes you make on an icon, such as colors, or shapes. The Undo command changes to 
Can't Undo when there are no more commands to be undone.    This will undo previous drawing 
action performed on an image.    The specific Undo action displayed (for example, Undo rectangle or
Undo Flood) identifies the command that is available to be undone if you cannot reverse the action.

Redo
Restores drawing actions that were undone using the Undo command.    The Redo command is only 
available after using Undo and before continuing with any new drawing actions.    The specific Redo 
action displayed (for example, Redo Ellipse or Redo Flood) identifies the command that is available 
to be redone.

Cut
Removes selected graphics and puts it on the Clipboard. This command is available only when you 
select graphics.    Graphics that you place on the Clipboard remains there until you replace it with a 
new item.    

Copy
Copies selected graphics to the Clipboard.    Graphics that you copy to the Clipboard, replaces the 
previous contents.    

Paste
Inserts a copy of the Clipboard contents into the work area, replacing the selection (if any) with the 
graphics on the Clipboard. The graphics are pasted into a selection frame, where they can be 
dragged to the desired location.    Once pasted into the selection frame, dragging the image will 
insert Color ‘B’ as the background color.    This command is not available if the Clipboard is empty or
if the selected graphics cannot be replaced.    

Paste Special
This will scale a bitmap image either from the Clipboard (if an image is present), or directly from a 
bitmap file.    You will also have the option of pasting into the grid as a New Selection, or paste into 
the current selection.    

Open Bitmap as Frame (Animator)/Image (Studio)
The Open Bitmap As Frame/Image, found on the Edit menu, is the most efficient way to convert a 
bitmap image into a cursor frame or icon image.    With this selection, color integrity of the bitmap 
is preserved.    Animator/Studio will alter the color box, to accommodate any colors that are not 
found in the palette, but used in the image.    If the Paste Special selection is used, color integrity is 
NOT preserved.    The Animator/Studio will use a color close to the one used in the original bitmap 
image.

Open Color Palette
Opens an existing color palette, to be used in the active image format, or open cursor file (only 
available when using 256 colors).

Save Color Palette
This will save the active 256 color palette.

Animator

    New Frame
Inserts a new frame to add to the cursor file.    

    Remove Frame



Removes the selected frame from the cursor file.
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File Menu
New

Prepares the work area to begin editing a new file.    The new file is initialized to the screen color.    If
you are currently working on a file, Microangelo will prompt you to Save it.

Open    (Ctrl+O)
Opens an existing icon resource file, (*.ICO) file, or animated cursor (*.ANI).

Save    (Ctrl+S)
Saves the work area to the current file on disk. When you save a file for the first time, Microangelo 
displays the Save As dialog box.

Note: (Studio component only)
· The Studio can open and save images with a *.GIF file format.    A *.GIF file can have only one 

image assigned to it.
· If operating the Studio through a Server mode from the Librarian, the Save function will display as 

Update.    The image will be pasted in the current window.    When editing an exisiting icon, the 
image will be updated automatically from the file from which it was opened.    

· The Update and Exit will perform the same as Update, except that the Server mode of the Studio
will close.

Save As    
Displays the Save As dialog box, where you specify the location of the icon resource file (*.ICO), or 
animated cursor (*.ANI) on disk.    

New Window
This will start another session of the component you are working with.

Exit    (Alt+F4)
Closes the active Microangelo component.

Animator Only

Properties
This will allow the addition of title and author credits for the file.
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{button ,AL(`relate_file',0,"",)} Related Topics



Tools menu

Drawing Tools

Selection frame
The selection frame defines an area of the bitmap that you can cut, copy, clear, or move.
Pencil
Draws in a constant width of one pixel. Drawing continues as the mouse is moved until the mouse 
button is released.
Straight line
Draws a line, filled with Color ‘A’ or Color ‘B’. A line image of the potential figure is displayed for 
your inspection as the cursor is dragged.    Releasing the mouse button completes the paint 
operation and updates the icon image.
Brush
Colors multiple pixels using the current brush size and shape. Drawing continues as the mouse is 
moved until the mouse button is released.
Flood
Replaces an area of one color with another color. The pixels, and all adjacent pixels of the same 
color will be filled.    The operation continues until the flood is completely bounded by different color
pixels.
Color eraser
Used to selectively replace one color with another color. Editing continues as the mouse is moved 
until the mouse button is released.
Rectangle
Draws a rectangle framed with Color ‘A’ or Color ‘B’. A line image of the potential figure is displayed
for your inspection as the cursor is dragged.    Releasing the mouse button completes the paint 
operation and updates the icon image.
Rectangle (filled)
Draws a rectangle filled with Color ‘A’ or Color ‘B’.
Rectangle (solid)
Draws a rectangle framed with Color ‘A’ and is filled with Color ‘B’.
Ellipse
Draws an ellipse framed with Color ‘A’ or Color ‘B’. A line image of the potential figure is displayed 
for your inspection as the cursor is dragged.    Releasing the mouse button completes the paint 
operation and updates the icon image.
Ellipse (filled)
Draws an ellipse filled with Color ‘A’ or Color ‘B’.
Ellipse (solid)
Draws an ellipse framed with Color ‘A’ and is filled with Color ‘B’.
Color pipette
Picks up Color ‘A’ or Color ‘B’ from the editing area. This option will become available in the Tools 
menu, and the tool box, when creating or editing an image with more than 16 colors.
Color locator
Locates the color in the grid area, and the color box.    All instances where the color was located in 
the grid area, will blink. This option will become available in the Tools menu, and the tool box, when 
creating or editing an image with more than 16 colors.
_________________________________________________
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Tools menu

Nudge/Flip Tools

Nudge Left
This selection will nudge all graphics contained inside of the selection frame, one pixel to the left.    
If the selection frame is not used, then all graphics in the editing grid will be affected.
Nudge Right
This selection will nudge all graphics contained inside of the selection frame, one pixel to the right.   
If the selection frame is not used, then all graphics in the editing grid will be affected.
Nudge Up
This selection will nudge all graphics contained inside of the selection frame, one pixel up.    If the 
selection frame is not used, then all graphics in the editing grid will be affected.
Nudge Down
This selection will nudge all graphics contained inside of the selection frame, one pixel down.    If the
selection frame is not used, then all graphics in the editing grid will be affected.
Flip Horizontal
This selection will flip all graphics contained inside of the selection frame, horizontally.    If the 
selection frame is not used, then all graphics in the editing grid will be affected.
Flip Vertical
This selection will flip all graphics contained inside of the selection frame, vertically.    If the 
selection frame is not used, then all graphics in the editing grid will be affected.
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Tools menu

Dithering Tools

Paint All Pixels
This selection will paint all pixels, when using the drawing tools.
Paint Every Other Pixel
This selection will paint every other pixel, based on the first pixel chosen to start.
Paint Even Pixels
This selection will paint every other pixel.    The pixels that can be painted will include the pixel 
located at position (1,0) and every other pixel thereafter.    Using this option will synchronize the 
pixels that can be painted without regard to the pixel underneath the location where the mouse 
button is first pressed.
Paint Odd Pixels
This selection will paint every other pixel.    The pixels that can be painted will include the pixel 
located at position (0,0) and every other pixel thereafter.    Using this option will synchronize the 
pixels that can be painted without regard to the pixel underneath the location where the mouse 
button is first pressed.
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View menu

Tool bar
This option shows or hides the tool bar from display.    The tool bar provides quick and easy 
selection of commonly used options.

Status bar
This option shows or hides the status bar from display.    The status bar is located at the bottom of 
the application window.    It displays descriptive information when a menu item is highlighted, or 
one of the tool tips is activated.

Color box
This option shows or hides the color box from display.    The color box is an independent window, 
and can be moved anywhere on your desktop.    The palette will offer more colors when the image 
format is changed (depends on the capability of your individual system).

Tool box
This option shows or hides the tool box from display.    The tool box is an independent window, and 
can be moved anywhere on your desktop.    It contains all tools available to create or edit icon, or 
cursor images.

Editing grid
This option shows or hides the grid from display.

Studio Only

Properties
This displays the number of images and color depths, used for a particular icon.
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Updating Icon in Windows 95

The original release of Windows 95 (including the first Service Pack update) contains flaws which 
prevent icon images from being updated properly.    Requests to update icons are ignored under 
certain conditions.    In a few of these cases the icon may be updated if you reboot your system.    
You can always select the Rebuild Icon Cache option from the Engineer’s File menu if you do not 
want to reboot your computer.    This option has been made available to be used only as you require
it so that the Engineer will work best on all versions of Windows 95, including any future versions 
that may correct these problems.

More About Icon Caching and Updating

Windows 95 caches icon images as you work.    What this means is that the icon is examined and an
appropriate image size and format is prepared for use on your computer’s display the first time that
the icon is used.    This prepared format is placed in a cache file for quick access whenever the icon 
must be displayed in the future.

It appears that Windows 95 does not examine the complete path of an icon’s location when the 
desktop is asked to update an icon.    It only looks at the filename portion.    So for example, if you 
have more than one icon on your system named “My Computer”, Windows 95 will think that they 
are all the same icon.    If you attempt to change an icon on your desktop from one of these to 
another, Windows will think that it already has the My Computer icon and will ignore the update 
request.

There are a few other instances when an update requested is not properly processed.    If you have 
the Briefcase option configured on your computer, it will not properly update a new desktop icon 
unless you rebuild the icon cache OR reboot your computer.

Also, Windows will display a default icon if you accidentally delete a file that contains an icon that is
currently being used to represent an object on your system.    In this case, Windows also appears to 
have trouble accepting an update request once a new icon has been selected.




