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EzWAP: Let’s go W@P! 

 

Welcome to EzWAP 

 
EZOS provides EzWAP, the first platform-independent WAP browser enabling all kinds of computing 
systems to access the mobile Internet: mobile devices (Pocket PC, PC companions), embedded 
systems and PCs running Microsoft Windows 95, 98, NT, 2000, Windows CE. Simply install EzWAP 
on your system, connect to your Service Provider and experience surfing on WAP sites as you would 
surf on HTML sites using a standard Web browser. 
 
This document describes how to quickly get started with EzWAP. 
 
Enjoy WAP surfing anywhere! 

Configuring EzWAP 

Before using EzWAP for the first time you have to configure your Pocket-PC, Windows CE device, 
Windows 95/98 or Windows NT/2000 connection settings to enable communication with your provider. 

To configure EzWAP 

1. In the EzWAP Tools menu, select Options…. 
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2. Select the General tab to edit the general settings. 

 

- Use the Connection selection box (1) to select the dial-up connection to be used.  

- Check the Connect automatically box (2) if you want EzWAP to automatically activate the 
selected connection when needed. 

- To change the default WML document that will load automatically as home page, enter a valid 
URL in the Home page box (3). 
Or, 
Click on the Use default button (4) to select the default EzWAP page as standard home page. 

- Check the Break line after images, anchors and edit fields box (5) if you want a line feed to 
be automatically inserted after input fields, anchors and images. 

- Check the Force images to fit screen width box (6) if you want images to be automatically 
adjusted to the size of your screen. 

3. Select the Connection tab to provide technical details about your WAP connection. Under 
Connection type, select one of the following options: 

Proxy  
Select this option if your mobile phone network operator does not operate a WAP gateway today 
(please consult the operator for details) and you want to use your regular Internet Service 
Provider to access WML-based sites.  
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- Complete the Address box (1) with the IP Address of your service provider, for example: 
63.254.8.6.  

- Complete the Port box (2) with the port number of the proxy, for example: 80. 
If applicable, complete the Authentication user box (3) with your personal account number 
and the Password box (4) with the corresponding secret code.  

Gateway  
Select this option if your mobile phone network operates a WAP gateway and you want to benefit 
from the additional services provided by your operator. Please consult the operator for details.  

 

- Complete the Address box (1) with the IP Address for the WAP gateway. This is a sequence 
of digits comprised of four integers separated by decimal points, for example: 193.96.141.24. 
This information can be found in the notice included in your operator's welcome pack.  

- Complete the Port box (2) with the port number used by the WAP gateway, for example: 
9200. 

- Select the Connectionless gateway check box (3) if the gateway works in connectionless 
mode. 
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- Select the WTLS secured connection check box (4) if the gateway uses the WTLS 
technology for enhanced security over the wireless network. 

None  
Select this option if you do not connect through a proxy or a gateway. 

4. Under Timeouts, specify the Connection timeout in milliseconds and the number and timeout of 
connection Retries. 

5. Select the Push tab to edit the push options.  

 

- Select the Enable push check box (1) if you want to enable push services, whereby on-the-fly 
messages such as latest traffic reports, stock quote updates, etc. are automatically delivered 
to your device. If you do not want to use push services, go directly to step 6. 

- Complete the Address box (2) with the IP Address for the push gateway. This is a sequence 
of digits comprised of four integers separated by decimal points, for example: 193.96.141.24. 
This information can be found in the notice included in the push operator's welcome pack.  

- Complete the Port box with the port number used by the push gateway i.e., 2948 
(connectionless push gateway), 2949 (connectionless push gateway with WTLS), 9120 
(WTLS) or 9209 (no connectionless push gateway + no WTLS). 

- Select the Connectionless push gateway check box (4) if the push gateway works in 
connectionless mode. 

- Select the WTLS secured connection check box (5) if the push gateway uses the WTLS 
technology for enhanced security over the wireless network. 

6. Select the History/Cache tab to edit the history settings. 
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- Use the first spin box (1) to specify the number of navigation steps that must be available for 
the Forward and Backward options of your EzWAP microbrowser.  
If you want to reset the history content and start with an empty one, click the Clear history 
button (2). 

- Use the second spin box (3) to adjust the cache size (in kilobytes). (In the example above, 
EzWAP uses 100Kb to avoid systematically reloading data from the network).  
If you want to reset the cache content and start with an empty one, click the Clear cache 
button (4). 

- Complete the Document cache path box (5) with the full path of the cache on your WAP 
device. 

- Complete the Cookies cache path box (6) with the full path for cookies on your WAP device. 

7. Click OK (7) to save the new settings. 

4

1 2 

3 

5 

7

6



EZOS EzWAP v2.0  Readme 

 
 
 

Belgium 
Rue de l'Hôpital, 5 
B-1420 Braine-l'Alleud 
Phone: +32 2 387 20 00 
Fax: +32 2 387 20 10 

France 
Boulevard de Valmy, 1 
F-59650 Villeneuve d'Ascq 
Phone : + 33 3 20 19 00 60 
Fax : + 33 3 20 19 00 69 

 
E-mail: info@ezos.com 

Web site: http://www.ezos.com 
 

WAP Surfing with EzWAP  

To surf with EzWAP 

1. In the location box (1), enter the URL of the WAP site that you want to access. 
Or, 
To access a local file, replace http: by file:   
For example: 
- file:c:\program files\ezos\ezwap\ezos.wmlc 
- http://wap.ezos.com 
Or, 
Click on the location selection box to select a recently visited site. 

Note:  
If you click on (3), the address in the upper box (1) will be replaced by the corresponding title 
information. 

2. Press Enter. 
Or, 
Click on the go button (2) to launch the request. 

 

3. When the WML document is loaded, select the appropriate hyperlinks (4) to browse through the 
available pages. 

 

To define bookmarks 

1. In the location box, enter the URL of the WAP site for which you want to define a bookmark. 

2. In the Tools menu, select Bookmarks. 

3. In the Bookmarks menu, select Add… to open the bookmark definition dialog box. 
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4. Type a name for the site in the Bookmark name box (1). 

5. Click OK (2) to save the new bookmark. 

 
(To access the site afterwards, choose the Tools > Bookmarks > View… menu sequence, then 
select the site in the bookmark list and click OK.) 
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Navigating Through EzWAP 

Navigation Buttons 

 
BUTTON NAME MEANING 

 stop abort loading 

 reload reload the current document from network rather than from 
cache 

 home load the home page specified in the Preferences 

 back go backward into the history 

 forward go forward into the history 

 card display the card contextual popup menu. This menu may be 
empty or contain site specific actions 

Note:  
The Home, Backward, Forward, Stop and Reload buttons are also available from the 
View >Go menu (see below). 

 

View Menu Options 

The View menu contains options to view the source of a WML deck and to refresh the view. 
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MENU OPTION MEANING 

Go Display the currently selected page, load the home page specified 
in the Preferences (Home), the previously accessed page 
(Backward), the next page in the browse history (Forward), stop 
loading (Stop) or reload the current document from network rather 
than from cache (Reload) 

History… Display the recent browse history 

Source… Display the WML source code of the current deck 

Address Bar Show or hide the address bar 

About Display information about the current version of EzWAP 

Exit Close EzWAP 
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Glossary 

Authentication  

The verification (check) of the identity of a user. Authentication can be carried out user-
oriented (user authentication) or computer-oriented (by the computer address). 

Cache 

A small fast memory holding recently-accessed information, designed to speed up 
subsequent access to the same data.  

Card 

An organisation metaphor used to refer to a block of WML code. A card usually defines a 
single action or operation that will be available on a small screen. Depending on the 
application, a number of action cards can be bundled into a deck to offer a more complex 
resource. 

Cookie 

A piece of information, such as login or registration information, online “shopping cart” 
information, user preferences, etc., which is sent by a (WAP) server to a browser. This 
information may be saved locally on the device for quicker, customised access to visited 
pages. 

Deck 

A sequence of WML cards available organised as a single unit for transmission to a WAP 
device.  A deck is similar to an HTML page when thinking in terms of Web pages, in that it is 
identified by a Web address and is the basic unit of content transmission. 

IP address  

The unique number that identifies a machine on the Internet. Usually, this address is 
represented by four numbers joined by periods, like 129.133.10.10. The first two or three 
pieces represent the network that the system is on, called its subnet. For example, all the 
computers for Wesleyan University in the U.S.A. are in the subnet 129.133, while the 
number in the previous paragraph represents a full address to one of the university's 
computers. 

Proxy  

A server configured to act as a security barrier between an internal network and the Internet, 
keeping other people on the Internet from gaining access to confidential information on the 
internal network or on individual PCs connected to the network. 
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Push  

A new technology responsible for the proactive delivery of information from a gateway to a 
WAP device.  

Skin 

A custom appearance that determines the general layout of a WAP browser. 

WAP Gateway 

A dedicated two-way device that translates  WAP contents and user requests using a 
common WAP protocol. Similar to a "door" through which data would transit between the 
Internet and the wireless network.  

WML (Wireless Markup Language) 

The markup language used to create decks. WML fulfils the same purpose as HTML does 
on World Wide Web. 

WTLS (Wireless Transport Layer Security) 

The protocol used to ensure security (data integrity, confidentiality, authentication and non-
repudiation) between the wireless device and the WAP gateway/proxy.  

http://wap.2pl.com/
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Cool WAP Site Collection 

The following collection contains a selection of interesting WAP sites to begin your exploration. 
 
 
URL http://wap.2pl.com/ 
Language Language selection 
Description Travel guide (hotel, tourism companies, tourist offices, etc.) 

 
URL http://www.palmreach.com/index.wml 
Language English 
Description Chat room (registration needed) 

 
URL http://wap.djuice.com/ 
Language English 
Description Portal site (Good site !) 

 
URL http://wapaw.com/index.phtml?format=wml 
Language English 
Description Search engine (Good site!!!) 

 
URL http://www.waptastic.com/application/wml.asp 
Language English 
Description Very complete portal site (FAQ, Articles, WML guide, etc.) 

 
URL http://wap.the451.com 
Language English 
Description News site 

 
URL http://wapmap.com/ 
Language English 
Description Search engine (Very good site!) 

 
URL http://mobile.worldof.net 
Language English 
Description Flight information 

 
URL http://showmewap.com 
Language English/French 
Description Search engine 

http://wap.2pl.com/
http://www.palmreach.com/index.wml
http://wap.djuice.com/
http://wapaw.com/index.phtml?format=wml
http://www.waptastic.com/application/wml.asp
http://wap.the451.com/
http://wapmap.com/
http://mobile.worldof.net/
http://showmewap.com/
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Bug Report 

 
Please fill the following form and send it to software@ezos.com. 
 
Thank you for your help! 
 
The EzWAP Development Team. 
 
 

EzWAP version / build : ……………………….. 
 
OS/Platform : ………………………….……….. 
 
Problem area :  [ ] Com 
  [ ] Navigation 
  [ ] User Interface 
  [ ] Other…  Please specify : ………………………..……………………… 
 
Problem type : [ ] Crash 
  [ ] Unable to access a WAP site 
  [ ] Bad data display 
  [ ] Other…  Please specify : ………………………..……………………… 
 
Is the problem reproducible? [ ] Yes 
    [ ] No 
    [ ] Don’t know 
 
Please provide a detailed description of the specific problem you experienced. 
Tell us what you expected to happen and what actually happened. 

………………………..………………………………………………..…………………………. 

………………………..………………………………………………..…………………………. 

………………………..………………………………………………..…………………………. 

………………………..………………………………………………..…………………………. 

………………………..………………………………………………..…………………………. 

………………………..………………………………………………..…………………………. 

………………………..………………………………………………..…………………………. 

………………………..………………………………………………..…………………………. 
 
Other remarks or suggestions: 
………………………..………………………………………………..…………………………. 
………………………..………………………………………………..…………………………. 

mailto:software@ezos.com
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