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Chapter 1.  Introduction

The PROFINET CbA User Guide discusses the following topics:
• Chapter 2. Programming Interface on Page 11
• Chapter 3. Embedded Configuration Pages on Page 25
• Chapter 4. Embedded Diagnostic and Statistics Pages on Page 43
For information about connecting the hardware, programming the DeviceMaster UP IP address, or uploading  
firmware, see the DeviceMaster UP Hardware Installation and Configuration Guide.
See the  Quick Start for embedded web page configuration procedures if you have Read-only or read/write 
devices, which provides procedures for your devices. 
See 1.3. Locating Updated Software and Documents on Page 6 to locate the latest firmware, documentation, 
and tools.

1.1. Audience

The primary audience of this document is the person responsible for installing and commissioning the 
DeviceMaster UP. This guide assumes you are familiar with the following topics:
• Windows operating system
• PROFINET CbA
• Siemens S7 PLC (optional)
• SIMATIC iMap configuration program

1.2. Product Overview

The DeviceMaster UP is a PROFINET CbA (Component Based Automation) device server after you upload 
the firmware over the default application. After uploading the firmware, the DeviceMaster UP provides an 
PROFINET CbA interface to serial device or devices, so you can simply add serial devices to your facilities’ 
PLC® platform.
The DeviceMaster UP provides a PROFINET CbA interface for 1 and 4-port models, which may or may not 
have the PROFINET CbA firmware loaded (depending on the model you purchased).
Note: Models that have PROFINET CbA loaded on the DeviceMaster UP are identified in PortVision Plus 

and the DeviceMaster UP is labeled accordingly.
This document describes how to configure the DeviceMaster UP for the PROFINET CbA protocol after basic 
DeviceMaster UP installation and configuration procedures. 
You can easily configure and manage devices through the SIMATIC iMap configuration program.
The DeviceMaster UP supports a Soft Real-Time (SRT) of 10 ms.
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Locating Updated Software and Documents
1.3. Locating Updated Software and Documents

You can access the firmware software assembly, PortVision Plus, and the DeviceMaster UP documentation 
from the CD shipped with the DeviceMaster UP or you can download the latest files using these internet 
links. 

Optionally, you can check for any updated files using this URL: http://support.comtrol.com/
download.asp?product=DMUP.

1.4. PROFINET CbA Application Setup

Before you can configure PROFINET CbA protocol on the DeviceMaster UP, you must have previously 
performed the following steps:
• Install the hardware
• Install PortVision Plus
• If necessary, upload the PROFINET CbA firmware using PortVision Plus

Note: Models that have PROFINET CbA loaded on the DeviceMaster UP are identified in PortVision Plus 
and the DeviceMaster UP is labeled accordingly.

• Configure the DeviceMaster UP IP address using PortVision Plus
Note: If necessary, refer to the DeviceMaster UP Hardware Installation and Configuration Guide for the 

above procedures.

DeviceMaster UP

Hardware Installation and Configuration Guide contains hardware 
installation, PortVision Plus installation, and if necessary, firmware 
updating procedures.

PortVision Plus

PortVision Plus is the application that you use to configure network 
settings and if necessary, upload the firmware.

PROFINET CbA Firmware

PROFINET CbA (.msi) contains the firmware and supporting files. 
The firmware provides embedded configuration web pages.

PROFINET CbA Documentation  

PROFINET CbA Quick Start is an outline of the installation and 
configuration procedures with links to the appropriate documents.

PROFINET CbA User Guide contains protocol specific information 
about configuring the DeviceMaster UP.
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PROFINET CbA Application Setup
Use the following steps to complete the DeviceMaster UP configuration for PROFINET CbA.
1. Change the DeviceMaster UP serial port settings using Chapter 3. Embedded Configuration Pages on 

Page 25.
2. Commission the device. For more information, see the instructions in Chapter 4. Commissioning the 

DeviceMaster UP on Page 31.
3. Connect your serial device or devices and make sure all Ethernet devices are attached to the same 

Ethernet subnet. If necessary, refer to the DeviceMaster UP Hardware Installation and Configuration 
Guide.
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PROFINET CbA Application Setup
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Chapter 2.  Programming Interface

2.1. Overview

The DeviceMaster UP provides a PROFINET CbA interface for 1 to 4 serial ports. This section is intended for 
the application programmer responsible for installing this product. 
This section covers the following topics:
• 2.2. PROFINET CbA Communication Properties
• 2.3. Packet Identification
• 2.4. Setting Baud Rate and Other Serial Parameters
• 2.5. PROFINET CbA Component
• 2.6. How the DeviceMaster UP Transmits Data
• 2.7. Handshaking (Optional)

2.2. PROFINET CbA Communication Properties

When you install the PROFINET CbA firmware on the DeviceMaster UP, the DeviceMaster UP uses the 
PROFINET CbA properties. You can set these communication property values through SIMATIC iMap. The 
following subsections describe:
• 2.2.1. What is PROFINET CbA?
• 2.2.2. Transfer Modes
• 2.2.3. Quality of Service (QOS)
For additional information, see 4.6. Setting a Project’s Transfer Properties on Page 37.

2.2.1. What is PROFINET CbA?

PROFINET CbA is the Ethernet-based automation standard issued by the PROFIBUS Nutzerorganisation 
e.V. (PNO). The PROFINET CbA standard defines a cross-vendor communication, automation and 
engineering model.
It has three objectives:
• Open, distributed automation
• Standardized communication through field bus and Ethernet
• Use of open IT standards.
PROFINET CbA specifies the functions for implementing an integrated automation package, from 
installation of the network right through to web-based diagnostics. The modular structure means you can 
easily upgrade PROFINET CbA with additional functions in the future.
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Transfer Modes
2.2.2. Transfer Modes

DeviceMaster UP supports the following transfer modes over Industrial Ethernet:
• Cyclical - Use this transfer mode for time-critical data.
• Acyclical - Use this transfer mode for engineering data and non time-critical data.
The transfer modes are selectable properties for the DeviceMaster UP. You can change these properties 
through SIMATIC iMap. The following table displays the supported transfer properties for DeviceMaster UP.

For additional information, see 2.5.6. Maximum Length for a Serial Packet on Page 15.

2.2.3. Quality of Service (QOS)

Each transfer mode has a quality of service:
• Transfer frequency (cyclical) - The time after a data item is transferred again in cyclical transfer 

mode (for example, every 10 ms). Use this transfer mode for Soft Real-Time (SRT).
• Scanning frequency (acyclical) - Determines how frequently the data is polled (for example, every 100 

ms) in acyclical transfer mode. The scanning frequency is the maximum time that elapses before a change 
in value is transferred.

You can set a transfer or scanning frequency to fast, medium, or low frequency. You can also change the 
transfer value within the following ranges:
• Cyclical range - 10 ms to 1000 ms.
• Acyclical range - 100 to 1000 ms
For additional information, see 2.5.6. Maximum Length for a Serial Packet on Page 15 and 4.6. Setting a 
Project’s Transfer Properties on Page 37.

Transfer Mode Frequency Value

Cyclical
Fast 10 ms
Medium 50 ms
Slow 100 ms

Acyclical
Fast 100 ms†
Medium 500 ms
Slow 1000 ms

† The DeviceMaster UP has a minimum value of 100 ms for 
acyclical transfer mode. To change this value to 100 ms, 
see the instructions in 4.6. Setting a Project’s Transfer 
Properties on Page 37
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Packet Identification
2.3. Packet Identification 

DeviceMaster UP polls the serial ports and gathers serial data into packets. The PROFINET CbA protocol 
moves these serial packets to the Programmable Logic Controller (PLC). Note that this device does not act as 
a gateway for serial streams of data. DeviceMaster UP gathers all serial data into packets.
Serial packets are identified by STX and ETX characters or the timeout feature.
• Start of Text (STX) - A delimiter that marks the beginning of a packet.
• End of Text (ETX) - A delimiter that marks the end of a packet.
• Timeout - Packets are identified by an absence of characters for a specified period of time.
The following tables show the available options.

As seen from the table, you must configure either an ETX or Timeout (or both).
When you enable STX, the DeviceMaster UP scans for STX and behaves accordingly:
• When the first byte is STX, the DeviceMaster UP collects the data. When the DeviceMaster UP finds an 

ETX or Timeout, the DeviceMaster UP declares the data to be a packet and moves the packet into the 
bstring output variable.

• If the first byte is not STX, the DeviceMaster UP discards the byte. The DeviceMaster UP continues to 
discard bytes until it finds an STX. 

When you enable ETX and/or timeout, DeviceMaster UP scans for ETX and/or waits for a Timeout and 
behaves accordingly:
• When you enable ETX, the DeviceMaster UP scans the serial data for the ETX. When the DeviceMaster 

UP finds an ETX, it stores the data as a packet.
• When you enable Timeout, and the time between characters exceeds the Timeout value, the DeviceMaster 

UP stores the data as a packet.
Note: You can enable ETX and Timeout together.
The DeviceMaster UP polls the serial port for serial data. The collection of a packet may span multiple polling 
periods. If a packet exceeds 128 bytes, DeviceMaster UP discards the packet. 
When you enable Strip STX/ETX Characters, DeviceMaster UP strips the STX and ETX characters in packets 
received from the serial port. 
Note: Serial Packets sent from the PLC to the DeviceMaster UP (over Ethernet), and then sent out the serial 

port, are not checked for STX/ETX. No STX/ETX character stripping occurs in these serial packets, 
and framing/parity/overrun error checking does not apply.

You can modify the STX, ETX, and Timeout values through the web page for the DeviceMaster UP. For more 
information, see the instructions in 3.1. Accessing the Server Configuration Page on Page 21. Additional 
information on the web page is provided in Chapter 3. Configuring the DeviceMaster UP on Page 21.

STX ETX Timeout Result
No No No Invalid, no packet ID method
No No Yes Timeout used to detect end of packet
No Yes No ETX used to detect end of packet
No Yes Yes ETX or timeout used to detect end of packet
Yes No No Invalid, no packet ID method
Yes No Yes STX starts packet, timeout used to detect end
Yes Yes No STX-ETX used to detect start and end
Yes Yes Yes STX starts packet, ETX or timeout used to detect end
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Setting Baud Rate and Other Serial Parameters
2.4. Setting Baud Rate and Other Serial Parameters

You can modify the baud rate value and other serial port settings through the web page for the DeviceMaster 
UP. See the following topics for instructions:
• See the DeviceMaster UP Hardware Installation Guide for information about using PortVision Plus to 

configure network settings on the DeviceMaster UP
• 3.1. Accessing the Server Configuration Page on Page 21
• 4.8. Using PortVision Plus to Change the PROFINET CbA Number on Page 40

2.5. PROFINET CbA Component

The PROFINET CbA component is written in XML (Extended Markup Language) and is intended for use 
with SIMATIC iMap. There are two XML files shipped on the CD for the DeviceMaster UP in the .MSI file. 
They are also available for downloading from the Internet. These XML files are included in the .MSI file:
• deviceMaster_1Port.xml - for a DeviceMaster UP 1-port.
• deviceMaster_4Port.xml - for a DeviceMaster UP 4-port.
See 1.3. Locating Updated Software and Documents on Page 6 for information on locating these files.

2.5.1. What is SIMATIC iMap?

SIMATIC iMap is a device-independent engineering tool designed by Siemens for Component based 
Automation (CBA). Use it to configure, commission and monitor modular, distributed automation systems 
based on the PROFINET CbA standard. For more information, see Chapter 4. Commissioning the 
DeviceMaster UP on Page 31.

2.5.2. Component Interface

The component interface defines the connectors (that is, the inputs and outputs) of the PROFINET CbA 
component. The connectors represent the external communication interface that is accessed through 
Ethernet and is visibly represented through SIMATIC iMap. Each connector has a direction (either input or 
output). You can interconnect inputs and outputs that are visibly represented through SIMATIC iMap. For 
more information on input and output variables, see 2.5.4. SIMATIC iMap Variables on Page 13.

2.5.3. Interconnections

In SIMATIC iMap. the interconnection is the connection between an output and an input. You can connect an 
output to one or more inputs. When you download the interconnections to the device, the corresponding 
communication links are automatically established between senders and receivers. For more information, see 
4.5. Interconnecting Technological Functions on Page 35.
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SIMATIC iMap Variables
2.5.4. SIMATIC iMap Variables

The SIMATIC iMap variables for the DeviceMaster UP are contained in a PROFINET CbA component. When 
you insert the PROFINET CbA component into a project (see 4.3. Inserting the PROFINET CbA Component 
into a SIMATIC iMap Project on Page 33), you can view the SIMATIC iMap variables associated with the 
device through the Plant view in SIMATIC iMap. The DeviceMaster UP presents the SIMATIC iMap 
variables provided in the following SIMATIC iMap variable tables. These variables use the following 
semantics:
• SEND – refers to sending serial data
• RECV – refers to receiving serial data
For more information on SIMATIC iMap, see the on-line help in SIMATIC iMap.

2.5.4.1.   SIMATIC iMap Variables for the 1-Port

The following table displays SIMATIC iMap variables for a DeviceMaster UP 1-port. The input and output 
variables in this table are described in 2.5.4.3. Input Variables on Page 14 and 2.5.4.4. Output Variables on 
Page 14.

2.5.4.2.   SIMATIC iMap Variables for the 4-Port

The following table displays SIMATIC iMap variables for a DeviceMaster UP 4-port. The input and output 
variables in this table are described in 2.5.4.3. Input Variables on Page 14 and 2.5.4.4. Output Variables on 
Page 14.

Input Data Type Output Data Type
P1_SEND_DATA BSTR[128] P1_RECV_DATA BSTR[128]
P1_SEND_HSK_ID     unsigned short P1_RECV_HSK_ID unsigned short
P1_RECV_HSK_ACK unsigned short P1_SEND_HSK_ACK unsigned short
P1_ENABLE                 bool P1_ENABLED bool
P1_RESET bool P1_STATUS unsigned long

Input Data Type Output Data Type

P1_SEND_DATA BSTR[128] P1_RECV_DATA BSTR[128]
P1_SEND_HSK_ID     unsigned short P1_RECV_HSK_ID unsigned short
P1_RECV_HSK_ACK unsigned short P1_SEND_HSK_ACK unsigned short
P1_ENABLE      bool P1_ENABLED bool
P1_RESET bool P1_STATUS unsigned long

P2_SEND_DATA BSTR[64] P2_RECV_DATA BSTR[64]
P2_SEND_HSK_ID unsigned short P2_RECV_HSK_ID unsigned short
P2_RECV_HSK_ACK unsigned short P2_SEND_HSK_ACK unsigned short
P2_ENABLE bool P2_ENABLED bool
P2_RESET bool P2_STATUS unsigned long

P3_SEND_DATA BSTR[128] P3_RECV_DATA BSTR[128]
P3_SEND_HSK_ID unsigned short P3_RECV_HSK_ID unsigned short
P3_RECV_HSK_ACK unsigned short P3_SEND_HSK_ACK unsigned short
P3_ENABLE bool P3_ENABLED bool
P3_RESET bool P3_STATUS unsigned long

P4_SEND_DATA BSTR[64] P4_RECV_DATA BSTR[64]
P4_SEND_HSK_ID     unsigned short P4_RECV_HSK_ID unsigned short
P4_RECV_HSK_ACK unsigned short P4_SEND_HSK_ACK unsigned short
P4_ENABLE     bool P4_ENABLED   bool
P4_RESET bool P4_STATUS    unsigned long
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Input Variables
2.5.4.3.   Input Variables

The following table describes the input variables.

2.5.4.4.   Output Variables

The following table describes output variables.

2.5.5. Programming Suggestions

When you configure the PLC program, consider the following:
• You must enable the serial port (Px_ENABLE) in the PLC program before data can flow. Alternately, you 

can tie this pin to True in SIMATIC iMap. See 4.4. Enabling the Serial Port in SIMATIC iMap on Page 35 
for instructions.

• You must initialize the DeviceMaster UP inputs for the handshake variables to zero.
• You can use reset (Px_RESET) in the PLC program to break out of hang or error conditions. Toggling the 

enable False-True will have the same effect.

Name Usage

Px_SEND_DATA This variable contains serial data that is sent out the serial port. The PLC 
writes this variable.

Px_SEND_HSK_ID 
This variable sends the handshake ID. The handshake ID acts as a sequence 
number. When incremented, it indicates to the DeviceMaster UP that the 
Px_SEND_DATA contains a new packet of serial data.

Px_RECV_HSK_ACK

This variable sends the receive handshake acknowledgement. When you enable 
handshaking, DeviceMaster UP acknowledges that the packet in 
Px_RECV_DATA has been consumed. When you disable handshaking, this value 
is zero.

Px_ENABLE
This variable opens the serial port and allows serial data to flow. When you 
enable the port, it also performs a port reset (flushes FIFOs, clears counters, 
etc.).

Px_RESET This variable initializes the serial port, flushes FIFOs, clears counters, and 
resets handshaking variables.

Name Usage

Px_RECV_DATA This variable contains a packet of serial data that was received by the 
DeviceMaster UP. 

Px_RECV_HSK_ID 
This variable receives the handshake ID. The handshake ID acts as a sequence 
number. When incremented, it indicates to the DeviceMaster UP that the 
Px_RECV_DATA contains a new packet of serial data.

Px_SEND_HSK_ACK

This variable sends the handshake acknowledgement. When you enable 
handshaking, DeviceMaster UP acknowledges that the packet in 
Px_SEND_DATA has been consumed. When you disable handshaking, this value 
is zero.

Px_ENABLE This variable indicates that the serial port is enabled (opened).

Px_STATUS This variable indicates device status and includes the results of the last send 
and receive operations.
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Maximum Length for a Serial Packet
2.5.6. Maximum Length for a Serial Packet

When you make SIMATIC iMap connections, you need to consider maximum length and QOS for serial 
packets. For more information on creating connections, see 4.6. Setting a Project’s Transfer Properties on Page 
37.

2.5.6.1.   DeviceMaster UP (1-Port)

If you have a DeviceMaster UP 1-port, you can configure the connections to a port for one of the following 
QOS options:
• Cyclical

- Fast
- Medium
- Slow 

• Acyclical
- Fast
- Medium
- Slow 

The port allows a serial packet length of 128 bytes.
The following example shows the serial packet length and optimal QOS setting for a DeviceMaster UP 1-port. 
Due to PROFINET CbA restrictions, the packet lengths are fixed as shown in the following table.

2.5.6.2.   DeviceMaster UP (4-Port)

If you have a DeviceMaster UP 4-port, you can configure the connections for two ports to use one QOS setting 
(for example, cyclical fast). The connections to the other two ports must be configured to another QOS setting 
(for example, cyclical medium).
Note: You cannot configure the connections to all ports to the same QOS setting.
The following example shows the serial packet length and optimal QOS setting for each port on a 
DeviceMaster UP 4-port. Due to PROFINET CbA restrictions, the serial packet lengths are fixed as shown in 
the following table.

For more information, see 2.2. PROFINET CbA Communication Properties on Page 9.

Port Number Serial Packet Length Recommended QOS
0 128 Cyclical Fast

Port Number Serial Packet Length Recommended QOS
0 128 Cyclical Fast
1 64 Cyclical Fast
2 128 Cyclical Medium
3 64 Cyclical Medium
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How the DeviceMaster UP Transmits Data
2.6. How the DeviceMaster UP Transmits Data

The following information describes how the DeviceMaster UP sends and receives data.

2.6.1. Receive Serial Packet Example

The following diagram shows how data flows when using DeviceMaster UP to receive serial data.

The following example shows a SIMATIC iMap connection.

 Serial
Device

DeviceMaster PLC

Serial Packet

Receive Serial Packet

Px_RECV_DATA

Px_RECV_HSK_ID

PX_RECV_HSK_ACK

Receive Serial Packet - iMap Connections

RECV_SERIAL_DATA

RECV_HSK_ID

RECV_HSK_ACK

Px_RECV_DATA

Px_RECV_HSK_ID

Px_ENABLE

Px_RECV_HSK_ACK

HIGH 
(True)

PLC Component DeviceMaster
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Send Serial Packet Example
2.6.2. Send Serial Packet Example

The following diagram shows how data flows when using DeviceMaster UP to send serial data.

The following example shows a SIMATIC iMap connection.

2.6.3. Send/Receive Serial Packet Example

You can configure full-duplex serial traffic by using both the Send and Receive connections.
The following example shows a SIMATIC iMap connection.

 Serial
Device

DeviceMaster PLC

Serial Packet

Send Serial Packet

Px_SEND_DATA

Px_SEND_HSK_ID

PX_SEND_HSK_ACK

Send Serial Packet - SIMATIC iMap Connections

SEND_SERIAL_DATA

SEND_HSK_ID

SEND_HSK_ACK

Px_SEND_DATA

Px_SEND_HSK_ID

Px_ENABLE

Px_SEND_HSK_ACK

HIGH 
(True)

PLC Component DeviceMaster UP

Send/Receive Serial Packet - SIMATIC iMap Connections

RECV_SERIAL_DATA SEND_SERIAL_DATA

RECV_HSK_ID SEND_HSK_ID

SEND_HSK_ACK

RECV_HSK_ACK

Px_SEND_DATA Px_RECV_DATA

Px_SEND_HSK_ID Px_RECV_HSK_ID

Px_ENABLE

PX_RECV_HSK_ACK Px_SEND_HSK_ACK

HIGH 
(True)

PLC Component DeviceMaster
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Handshaking (Optional)
2.7. Handshaking (Optional)

Handshaking between the DeviceMaster UP and the PLC assures the producer (for example, the PLC 
component) that the consumer (for example, DeviceMaster UP) received the serial packet. The producer must 
know this before it sends another packet. This avoids possible data loss that might occur due to dissimilar 
polling periods or system busy conditions.
Handshaking is optional. When you disable handshaking, serial data transfer is simplified. You must ensure 
that the duty cycle of the serial packets is low enough to prevent data loss.

2.7.1. General Serial Transfer Procedure: Handshaking Enabled

When you enable handshaking, the handshake variables HSK_ID and HSK_ACK act as flags to the serial 
data producer and consumer. In the initial state, producer and consumer set the handshake variables 
HSK_ID and HSK_ACK to zero and behave according to the following state machine:

Consumer Producer

1. Consumer loops reading HSK_ID. 

2. Producer writes packet of 
serial data to DATA variable.

3. Producer increments HSK_ID.

4. Producer loops reading 
HSK_ACK.

5. Consumer observes incremented 
HSK_ID, consumes DATA.

6. Consumer writes HSK_ACK to 
equal HSK_ID.

7. Producer observes HSK_ACK 
equals HSK_ID. Serial packet 
has been consumed.

Repeat
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General Serial Transfer Procedure: Handshaking Disabled
2.7.2. General Serial Transfer Procedure: Handshaking Disabled

When you disable handshaking, only HSK_ID is used as a transfer flag between producer and consumer, and 
producer and consumer behave according to the following state machine:

Consumer Producer

1. Consumer loops reading HSK_ID. 

2. Producer writes packet of 
serial data to DATA variable.

3. Producer increments HSK_ID.

4. Consumer observes incremented 
HSK_ID, consumes DATA.

Repeat
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General Serial Transfer Procedure: Handshaking Disabled
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Chapter 3.  Configuring the DeviceMaster UP

This section covers the following topics:
• 3.1. Accessing the Server Configuration Page
• 3.2. Server Configuration Page on Page 22
• 3.3. Edit Network Configuration Page on Page 26
• 3.4. Edit Port Configuration on Page 27
The latest PROFINET CbA firmware must be installed before you can configure network or serial port 
characteristics. For installation and setup information, see the DeviceMaster UP Hardware Installation and 
Configuration Guide.

3.1. Accessing the Server Configuration Page

The following is an overview of how to use PortVision Plus to access the DeviceMaster UP Server 
Configuration page and configure the serial port characteristics.

Note: Optionally, enter the IP address of the device in the Address box of your web browser, and press Enter to 
access the Server Configuration page.

1. From PortVision Plus, select the DeviceMaster UP that 
you want to configure and select Web Manager in the 
Device menu. The DeviceMaster UP Server Configuration 
page appears.

2. Select a port (for example, Port 1) to access the Edit Port 
Configuration page.

3. Change the port configuration properties as required for 
your site.
Information on packet identification properties are 
provided in 2.3. Packet Identification on Page 11. The 
port configuration properties are described in 3.4. Edit 
Port Configuration on Page 27.

4. Set DTR to WhenEnabled. 
The serial port is enabled through iMap. See 4.4. 
Enabling the Serial Port in SIMATIC iMap on Page 35 
for additional information.

5. Click Save to commit your changes.
6. Repeat Steps 2 through 5 for each additional port.
7. Read Chapter 2. Programming Interface on Page 9 and 

go to Chapter 4. Commissioning the DeviceMaster UP on Page 31 for instructions on how to commission 
the DeviceMaster UP.
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Server Configuration Page
3.2. Server Configuration Page

The DeviceMaster UP Server Configuration page 
displays the current network and serial port or 
ports configuration for the DeviceMaster UP. In 
addition, it provides access to Configure Network 
and Edit Port Configuration pages.
If you have not configured the network 
information into the DeviceMaster UP during 
initial setup, you must use PortVision Plus to 
initially configure the network information into 
the DeviceMaster UP before configuring serial 
port characteristics.
Note: See the instructions in the DeviceMaster 

UP Hardware Installation Guide or the 
PortVision Plus on-line help system if you 
need help configuring the network 
settings.

Port configuration settings must be configured 
through the web page, see 3.4. Edit Port 
Configuration on Page 27 and 4.8. Using 
PortVision Plus to Change the PROFINET CbA 
Number on Page 40.

Edit Network 
Configuration 
Page on Page 26

Edit Serial 
Configuration on 
Page 28

Serial 
Counters on 
Page 24

Status Area on 
Page 25

Packet ID 
Settings on 
Page 29
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Main Page Fields and Areas
3.2.1. Main Page Fields and Areas

The Server Configuration area displays the following information and provides links to the Configure Network 
and Edit Port Configuration pages.

Server Configuration Description of Fields and Areas

Software Displays the PROFINET CbA version currently running on the DeviceMaster 
UP.

Serial No Displays the DeviceMaster UP serial number.

IP Config Displays the type of IP configuration currently in use (static or DHCP).

IP Address Displays the IP address configured in the DeviceMaster UP.

IP Netmask Displays the IP netmask configured in the DeviceMaster UP.

IP Gateway Displays the IP gateway configured in the DeviceMaster UP.

PROFINet No Displays the PROFINET CbA number configured in the DeviceMaster UP.

Configure Network
Opens the Configure Network page that you can use to change the network 
information after initial installation. See 3.3. Edit Network Configuration Page 
on Page 26 for information about using this page.

Port # Select the appropriate port to access the Edit Port Configuration page for that 
port. See 3.4. Edit Port Configuration on Page 27 for information.

Serial Port Settings area
You can change the serial port settings if you select the link to the appropriate 
port. See 3.4.1. Edit Serial Configuration on Page 28 for information about 
serial port settings.

Serial Counters area See 3.2.2. Serial Counters on Page 24 for information.

Status See 3.2.3. Status Area on Page 25 for information.

Packet ID Settings area

• STX displays the STX character, configurable as 0 or 1-byte.
• ETX displays the ETX character, configurable as 0 or 1-byte or CR-LF.
• Timeout (ms) displays the timeout value in microseconds (ms) for Packet 

Timeout Detect.
See 3.4.2. Packet ID Settings on Page 29 for a description of the remaining 
fields.

Reboot

Selecting the Reboot button opens a Reboot DeviceMaster page. 
Select Yes - Reboot to reboot the DeviceMaster UP. You may need to refresh the 
view within the browser.
Reset port(s) to factory settings (network setting left unchanged). - When selected, 
changes all factory settings except network settings to original default values.
Erase persistent connections. - When selected, removes the PROFINET CbA 
connections on the DeviceMaster UP.
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Serial Counters
3.2.2. Serial Counters

The following counters are located on the Server Configuration page. You can reset the serial statistics 
counters by setting the Reset iMap flag or by selecting Reset Counters. 

Serial Counters Field Description

Reset Counters Clears the serial port counters, which sets the value to 0 for all ports.

TX Byte Count Displays the number of bytes sent out of the serial port.

TX Pkt Count Displays the number of serial packets sent out of the serial port.

RX Byte Count Displays the number of bytes received over the serial port.

RX Pkt Count Displays the number of packets received over the serial port.

Parity Errors Displays the number of received serial packets dropped due to parity errors.

Framing Errors Displays the number of received serial packets dropped due to framing errors.

Overrun Errors Displays the number of received serial packets dropped due to overrun error 
incidents.

Dropped Packets

Displays the number of received serial packets dropped due to:
• No STX byte(s) found
• No ETX byte(s) found
• UART errors
• Handshaking errors
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Status Area
3.2.3. Status Area

The Status area displays the current device and serial read information.

Field Description

Device Status

Displays the state of the unit.
• OK - Device is ready.
• Initializing - Device is not ready. This appears during initial power-up or reboot.

Last Read Pkt Status

Displays the status of the last packet read.
• OK - Indicates no error.
• Framing error - The UART detected a framing error and the packet was dropped. 

Check the serial word length (7-bit, 8-bit, etc.).
• Parity error - The UART detected a parity error and the packet was dropped. 

Check the UART parity setting.
• Overrun error - The UART detected an overrun condition and data was lost. Use 

flow control, if necessary.
• No STX - STX was enabled in the Packet ID configuration, but serial bytes were 

received that did not match that character and those bytes were dropped.
• Too long - The serial packet length exceeded the maximum length and the packet 

was dropped.
• Queue full - The serial packet queue is full and the packet was dropped.

Last Read Pkt Displays the last read packet corresponding to the Last Read Pkt Status.
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Edit Network Configuration Page
3.3. Edit Network Configuration Page

You can use the Edit Network Configuration page to change the DeviceMaster UP network configuration after 
using PortVision Plus for initial network configuration.
Use the following procedure to change the network configuration.
1. Select the IP configuration type (DHCP or Static). 
2. If you select Static, enter a valid IP address, subnet mask, and IP gateway for your network. The network 

information is programmed into the DeviceMaster after applying the changes and rebooting the device. If 
necessary, see your network administrator for a valid IP address.
Note: The DeviceMaster family default IP address is 192.168.250.250, default subnet mask is 

255.255.0.0, and the default IP gateway is 192.168.250.1.
3. Enter the PROFINET CbA number for the device in the provided box. For more information, see 4.3.2. 

What is a PROFINET CbA Number? on Page 33.
4. Select Save or Undo Changes to close the page.
5. If you selected Save, select Reboot to program the network 

information into the DeviceMaster UP or Continue if you 
want to reboot later. 

Note: Changed network settings will not take affect until the 
DeviceMaster UP is rebooted.
26 - DeviceMaster UP PROFINET CbA User Guide: 2000409 Rev. D Chapter 3. Configuring the DeviceMaster UP



Edit Port Configuration
3.4. Edit Port Configuration

Use the Edit Port Configuration page to change a 
serial port parameters (for example, baud, parity, 
etc.) and serial port protocol settings. See the 
following subsections for screen details.
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Edit Serial Configuration
3.4.1. Edit Serial Configuration

Use the Serial Configuration area of the Edit Port Configuration page to configure serial port characteristics 
for the device that you plan on connecting to the port. 

Serial 
Configuration Field Descriptions

Mode Select the communications mode for the serial device that you are connecting to the port. 
The available modes are RS-232, RS-422, and RS-485.

Baud Select a baud rate from the list. The baud rate that you select determines how fast 
information is transferred through a port.

Parity

Select a method for error checking.
• None - When the parity is set to none, there is no parity bit, and DeviceMaster UP 

does not perform parity checking.
• Odd - Indicates that the sum of all the 1-bits in the byte plus the parity bit must be 

odd. When the total is odd, the parity bit is set to zero, when it is even, the parity bit 
is set to one.

• Even - When the sum of all the 1-bits is even, the parity bit must be set to zero; when 
it is odd, the parity bit must be set to one.

Data Bits Select the number of bits that make up the data. Choose from 5, 6, 7 or 8-bits.

Stop Bits Select the number of bits to mark the end of data transmission.

Flow

Specifies the ability to start and stop the flow of data without the loss of bytes. Select a 
method for controlling the flow of data from the following list: 
• None - Indicates flow control is not in affect.
• RTS/CTS - Request To Send (RTS) tells the receiving device that the sending device 

has data that is ready to send and Clear To Send (CTS) indicates the device is ready 
to accept data.

• XON/XOFF - When selected, applies the standard method of controlling data flow 
between two modems.

• Half Duplex - Transmits data in half-duplex mode.

DTR

Select the state of Data Terminal Ready (DTR).
• on - Enables DTR.
• off - Disables DTR.
• WhenEnabled - Select this option when enabling the serial port through.
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Packet ID Settings
3.4.2. Packet ID Settings

Use the Packet ID Settings area of the Edit Serial Configuration page to configure the serial packet 
identification (ID) settings for a serial port.  

Packet Identification 
Settings Field Descriptions

STX Detect

When enabled, the DeviceMaster UP looks for the STX character, which is 
configurable as byte 0 or 1. The default is 1 byte (0x02 hex).
• enabled - When enabled, the DeviceMaster UP scans serial data for STX in 

the first byte. If STX is found, the data is collected. When ETX or Timeout 
is found in the first byte, the data is declared to be a packet and moved 
into the bstring output variable. If the first byte is not STX, the byte is 
discarded and bytes continue to be discarded until an STX is found.

• none - When disabled, the DeviceMaster UP does not scan the data for 
STX.

ETX Detect

When enabled, the DeviceMaster UP looks for the ETX character, which is 
configurable as byte 0 or 1, or CR-LF. The default is CR-LF.
• enabled - When enabled, the DeviceMaster UP scans the serial data for 

ETX. If ETX is found, the data is stored as a packet.
• none - When disabled, the serial data is not scanned for ETX.
• CR-LF - When CR-LF (Control line feed) is enabled, the DeviceMaster UP 

scans for CR-LF.

Packet Timeout Detect

When enabled it specifies the interpacket timeout in microseconds (ms). The 
default is disabled.
• enabled - When enabled and the time between characters exceeds the 

Timeout (ms) value, that data is stored as a packet.
• disabled - When disable, the data is not scanned for Timeout.

Use Handshake When checked, it enables handshaking. The default is enabled.

Strip STX/ETX

This check box is clear by default. When you select this check box, the 
DeviceMaster UP strips STX/ETX characters from received serial packets. 
Clear the check box when you do not want the DeviceMaster UP to strip STX/
ETX characters from received serial packets.
Note: Serial Packets sent from the PLC to the DeviceMaster UP (over 

Ethernet®), and then sent out the serial port, are not checked for STX/
ETX. No STX/ETX character stripping occurs in these serial packets, 
and framing/parity/overrun error checking does not apply.

Display Last Read Packet When checked this enables the Display Last Read Packet. The default is 
disabled.
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Saving Port Options
3.4.3. Saving Port Options

After configuring the serial and protocol characteristics for this port, scroll to the bottom of the Edit Port 
Configuration page to save the configuration.

3.5. Configuration Updated

This page appears when there are changes to the IP address or PROFINET CbA and indicates a reboot is 
required for changes to take affect.
• Continue - Returns to the Server Configuration page without rebooting the DeviceMaster UP.
• Reboot - Restarts the DeviceMaster UP with the latest changes.

Option Description

Undo Changes Restores modified port settings to current values.

Save Saves changes to port settings.
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Chapter 4.  Commissioning the DeviceMaster UP

4.1. Overview

This section describes how to commission a DeviceMaster UP and covers the following topics:
• 4.2. Importing the PROFINET CbA Component into a SIMATIC iMap Library on Page 32
• 4.3. Inserting the PROFINET CbA Component into a SIMATIC iMap Project on Page 33
• 4.4. Enabling the Serial Port in SIMATIC iMap on Page 35
• 4.5. Interconnecting Technological Functions on Page 35
• 4.6. Setting a Project’s Transfer Properties on Page 37
• 4.7. Assigning Addresses on Page 39
• 4.8. Using PortVision Plus to Change the PROFINET CbA Number on Page 40
• 4.9. Downloading Interconnections from SIMATIC iMap on Page 41
• 4.10. Documenting and Printing a Project on Page 41
• 4.11. Changing the IP Address on Page 42
You may want to read Chapter 2. Programming Interface on Page 11 before performing any of the procedures 
in this section.
You must meet the following requirements:
• SIMATIC iMap must be installed on your computer.

Note: If your computer is running Windows 2000 Professional or Windows XP Professional, go to the 
Siemens web site and review the notes on the operation of SIMATIC iMap under Windows 2000 and 
Windows XP. If you have Microsoft Security Update 828741 installed on Windows 2000 
Professional or Service Pack 2 installed on Windows XP Professional, you will need to make 
additional changes to your operating system to download the PROFINET CbA component on the 
DeviceMaster UP through SIMATIC iMap.

• The DeviceMaster UP must be connected to the same network segment as the PLC.
• A PROFINET CbA component (.xml) file and the icon (.ico) file provided in the self-installing (.MSI) file. 

These files are copied to the Comtrol/PROFINET_CbA folder on your computer when you open the .MSI 
file and follow the prompts. 
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Importing the PROFINET CbA Component into a SIMATIC iMap Library
4.2. Importing the PROFINET CbA Component into a SIMATIC iMap 
Library

This procedure describes how to import a PROFINET CbA component (.xml file) for the DeviceMaster UP 
into the SIMATIC iMap library. See the on-line help system in the SIMATIC iMap for additional information.
1. Start SIMATIC iMap. Select Start > Programs > Component based Automation > SIMATIC iMap or double-

click the iMap icon on the desktop.
2. Select the appropriate step:

• If necessary, select Project > New to create a new project. The new project opens when you create a new 
project.

• If a project already exists, select Project > Open and click the library in which you want to import the 
PROFINET CbA component. The filename must have a .cpb extension. When the library name appears 
in the File name box click Open.

Note: The file name drop-down list contains the most recently opened SIMATIC iMap projects.
3. Select the Project Library window and select Library > Import components from the menu and browse to 

location of your .xml files. For information on locating the .xml files for the DeviceMaster UP, see 4.1. 
Overview on Page 31.

4. Under Search in, select the path to the PROFINET CbA components.
5. Select the appropriate XML file (deviceMaster_1Port.xml or deviceMaster_4Port.xml) and click Open to 

import the selected PROFINET CbA component. The following example shows a deviceMaster_1Port.xml 
file. 

When finished, the selected PROFINET CbA component appears in the Project Library window as an icon 
and can now be used in the project.
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Inserting the PROFINET CbA Component into a SIMATIC iMap Project
4.3. Inserting the PROFINET CbA Component into a SIMATIC iMap 
Project

This procedure describes how to insert a PROFINET CbA component into a project. SIMATIC iMap may 
provide alternate ways to perform the task described here, see the on-line help system in the SIMATIC iMap 
for additional information. 
The PROFINET CbA components that you want to insert into your project must be contained in a library in 
SIMATIC iMap. See 4.2. Importing the PROFINET CbA Component into a SIMATIC iMap Library, earlier in 
this chapter, for complete instructions.
The following subsections provide this information:
• 4.3.1. What is a Technological Function?
• 4.3.2. What is a PROFINET CbA Number? on Page 33
• 4.3.3. Procedure on Page 34

4.3.1. What is a Technological Function?

In Component based Automation, the technological function of a PROFINET CbA component comprises the 
application-specific functionality of a programmable controller or field device and the component interface for 
communication with other PROFINET CbA components.
SIMATIC iMap displays the technological function as a 
block with inputs and outputs in the SIMATIC iMap 
plant view. The following example shows the 
technological function for a DeviceMaster UP 1-port.

4.3.2. What is a PROFINET CbA 
Number?

SIMATIC iMap assigns a PROFINET CbA number 
(PROFINET No) technological function when you insert 
a PROFINET CbA component into a project. The 
technological function in the example above has a 
PROFINET No of 0 because it was the first PROFINET 
CbA component for a DeviceMaster UP inserted into 
the project. When you insert additional instances of a 
PROFINET CbA component for DeviceMaster UP into 
a project, the name of the technological function is 
increment by one. (For example, SIMATIC iMap 
assigns the DeviceMaster to PROFINET CbA number 0, DeviceMaster_1 to PROFINET CbA number 1, etc.) 
The DeviceMaster in the following example is assigned to PROFINET CbA number 2.
Record the PROFINET CbA number, its associated IP address and subnet mask for each PROFINET CbA 
component you insert into a project. You will need the PROFINET CbA number when you change the network 
settings through the web page for each DeviceMaster UP. For more information, see 4.8. Using PortVision 
Plus to Change the PROFINET CbA Number on Page 40.

PROFINET CbA Number
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Procedure
4.3.3. Procedure

1. In the library window, select the 
PROFINET CbA component and 
use drag-and-drop to move it to the 
project net view.
Note: You can insert multiple 

copies of a PROFINET CbA 
component into a project. 
Each time you drag-and-
drop the PROFINET CbA 
component into a project 
SIMATIC iMap creates an 
instance of the PROFINET 
CbA component in the 
project. iMAP assigns 
additional properties to 
each instance (for example, 
a name and address). 
 
The association between all 
the instances and the 
original PROFINET CbA 
component is indicated by 
their identical identification 
(ID) and version number.

2. Record the PROFINET CbA number for each PROFINET CbA component that you insert into a project. 
(See 4.3.2. What is a PROFINET CbA Number? on Page 33, for a description of the PROFINET CbA 
number.)
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Enabling the Serial Port in SIMATIC iMap
4.4. Enabling the Serial Port in SIMATIC iMap

The PLC program must enable the serial port (Px_ENABLE) before data will flow. To enable the serial port 
the pin must be tied to True. You can enable the serial port in SIMATIC iMap.
Note: You must set the DTR (Data Terminal Ready) option in the web page for the DeviceMaster UP to 

WhenEnabled.
1. Select Px_ENABLE so that the mouse pointer with the interconnection icon appears. 
2. Right-click and select Interconnect Constants from the context menu.
3. Select True from the Constant value drop down box.
4. Click OK or Apply to save your changes. The input is identified by a constant icon, and the value of the 

constant is displayed at the input.
In this procedure, True appears by an enabled serial port.

4.5. Interconnecting Technological Functions

The following subsections describe:
• 4.5.1. What are Interconnections?
• 4.5.2. Rules for Interconnection on Page 36
• 4.5.3. Requirements on Page 36
• 4.5.4. Procedure on Page 36
Make sure that you have read 2.6. How the DeviceMaster UP Transmits Data on Page 16 before reading the 
following subsections.

4.5.1. What are Interconnections?

An interconnection is represented by a line that connects the input of a technological function to the output of 
a second technological function.
When you delete a technological function, all the associated interconnections are deleted.
When you move a technological function, the course of the associated interconnections is also changed.
If the course of a line cannot be calculated due to lack of space, then only the two ends of the interconnection 
are displayed. These are known as continuation connectors.
The color of the line changes when you select an interconnection. You can delete a selected interconnection or 
view and modify its properties.
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Rules for Interconnection
4.5.2. Rules for Interconnection

The following provides the rules for interconnection:
• An interconnection can only be set up between an output and an input. You can interconnect an output 

with several inputs, but you can only interconnect an input with one output.
• The two connectors of an interconnection must be of the same data type (for example, both of type UI2 or 

type BOOL)
• Connectors with composite data types must be of the same type (that is, arrays and structures must have 

the same structure).

4.5.3. Requirements

The PROFINET CbA components containing the technological functions must already be inserted into the 
project. For more information, see 4.3. Inserting the PROFINET CbA Component into a SIMATIC iMap 
Project on Page 33.

4.5.4. Procedure

If you change the settings of objects (for example, interconnections) in SIMATIC iMap, they do not take 
immediate effect on the plant. These changes will not become active until you download the interconnections 
to the DeviceMaster UP. For more information, see 4.9. Downloading Interconnections from SIMATIC iMap 
on Page 41.
The following task describes how to create an interconnections between technological functions.
1. Open the Plant View.
2. If desired, select View > Plant view > Display Interconnection Lines to show or hide the interconnection lines.
3. Click a connector. The connector changes color, and the shape of the cursor also changes.

Note: If you want to connect several inputs to one output, hold down the CTRL key and select the required 
inputs.

4. Select one of the following options:
• Hold down the left mouse button and drag to the second connector.
• Click the second connector of the interconnection.

If you selected several inputs using the CTRL key, release the CTRL key and select the required 
output.

In this procedure, compatible connectors are always highlighted in color.
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Setting a Project’s Transfer Properties
4.6. Setting a Project’s Transfer Properties

The following subsections describe how to set a project’s transfer properties. For more information, see 2.2. 
PROFINET CbA Communication Properties on Page 9.

4.6.1. Defining Transfer Properties for the Interconnections of an Entire 
Project

This procedure defines the default settings that will be applied to all new interconnections. 
1. Select Project > Properties.
2. Click the Interconnections tab.
3. Select the appropriate settings in the Default setting for the new interconnections box.

Note: These settings will apply to all subsequently created interconnections.
4. Select the appropriate settings in the Transfer frequencies (cyclical) box.
5. Select the appropriate settings in the Scanning frequencies (acyclical) box.

Note: You must set the fast value for Scanning frequencies (acyclical) to 100 ms.
6. Click OK or Accept to confirm and save your changes.
The settings in Steps 4 through 5 apply to all the interconnections in the project with the corresponding 
transfer mode and frequency level. These values are retained in SIMATIC iMap until they are changed again.
You can change the transfer properties of individual interconnections through the interconnection properties.
Note: The transfer properties of a highlighted interconnection are also displayed as a tooltip.
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Changing the Transfer Properties of an Interconnection
4.6.2. Changing the Transfer Properties of an Interconnection

This procedure defines the transfer properties for an individual interconnection. 
You may want to review 2.5.6. Maximum Length for a Serial Packet on Page 15 before selecting the transfer 
mode (QOS) for an interconnection.
1. Select the interconnection in the Plant View and select Edit > Properties.
2. In the Properties of Interconnection dialog box select the appropriate values for Transfer mode.
3. Repeat Steps 1 through 2 for each additional interconnection that you want to change.
4. Click OK or Accept to confirm and save your changes.
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4.7. Assigning Addresses

The following procedure describes how to assign the IP address to the device.
These are the requirements for assigning addresses:
• The PROFINET CbA components have been inserted into the project. See 4.3. Inserting the PROFINET 

CbA Component into a SIMATIC iMap Project.
• The IP address and subnet mask for the devices are known and assigned. See the DeviceMaster UP 

Hardware Installation Guide for procedures.

4.7.1. Procedure

1. If necessary, select the device in the Net View screen.
2. Select Edit > Properties....

3. Click the Addresses tab and enter the IP address and subnet mask for the device.
Note: This IP address must 

match the IP address and 
subnet mask for the target 
device. For more 
information on assigning 
the IP address to a device, 
see the DeviceMaster UP 
Hardware Installation 
Guide.

4. Click OK to save your changes.
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4.8. Using PortVision Plus to Change the PROFINET CbA Number

The following procedure requires the PROFINET CbA number. For more information, see 4.3.2. What is a 
PROFINET CbA Number? on Page 33.

4.8.1. Procedure

Use the following procedure to change the PROFINET CbA number assigned to the DeviceMaster UP on the 
web page.
1. Double-click the PortVision Plus icon or select Start > Programs > Comtrol > PortVision Plus to start 

PortVision Plus. 
2. Select the DeviceMaster UP for which 

you want to program network 
information and click Web Manager. The 
Server Configuration page for the 
selected device appears. 
Alternatively, you can enter the IP 
address for the device in the Address box 
of your web browser and press ENTER to 
access the web page for the device.

3. Click Configure Network. The Edit 
Network Configuration page appears.

4. Enter the PROFINET CbA number 
assigned to the device in SIMATIC iMap 
in the PROFINET No box. (For more 
information, see 4.3.2. What is a 
PROFINET CbA Number? on Page 33.)

5. Click Save. The Configuration Updated 
message appears.

6. Click Reboot. When the reboot completes, 
the Server Configuration page appears.

7. Repeat Steps 2 through 6 for each device 
on which you want to change the 
PROFINET CbA number.
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4.9. Downloading Interconnections from SIMATIC iMap

This procedure describes how to download interconnections to DeviceMaster UP units in your project.
Note: If you created an interconnection to a device that represents a PLC program, you may need to generate 

the PLC component and that requires Step 7 installed on your computer. See the SIMATIC iMap 
documentation for additional information before you download the interconnections.

1. From SIMATIC iMap, select Online > Download all instances > Interconnections only. A caution 
dialog box appears.

2. Click Yes to continue.

4.10. Documenting and Printing a Project

Comtrol recommends keeping a written record of your project for future reference to record project changes. 
The following subsections describe what you can include in the project documentation and how to create the 
project documentation.

4.10.1. Contents of Project Documentation

You can create documentation containing the following information for a SIMATIC iMap project:
• General project data such as name, path and creation date
• All the technological functions and subordinate charts of the plant chart and their interconnections
• All the PROFINET CbA devices of the network chart
• The PROFINET CbA components used as library elements and their instances (devices and functions) in 

the project
• Optional - descriptions of the interconnectable and non-interconnectable connectors of the component 

interfaces
• Optional - graphical representations of all charts (Network chart, plant chart and optional subordinate 

charts)

4.10.2. Procedure

Use this procedure to document and print a project.
1. Select Project > Documentation.
2. In the Create project documentation dialog box, select the information options for the information that you 

want to transfer to the documentation.
3. If necessary, click Modify and change the path under which the project documentation is stored.
4. Click OK to save your changes and create the project documentation. For more options on setting up and 

viewing the documentation, see the on-line help system in SIMATIC iMap.
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4.11. Changing the IP Address

If you have one installed DeviceMaster UP, with no connections to other devices, you can change the IP 
address at any time. If you have a DeviceMaster UP installed with bi-directional connections to another 
device and you want to change the IP address for one of these devices, you have to delete persistence 
connections stored in the DeviceMaster UP. 
The following subsections walk you through all the steps for changing an IP address on one or more 
DeviceMaster UP units. 
• 4.11.1. Erasing Persistent Connections
• 4.11.2. Changing the IP Address
• 4.11.3. Changing the IP Address in SIMATIC iMap
• 4.11.4. Downloading Interconnections

4.11.1. Erasing Persistent Connections

This procedure describes how to erase the persistent PROFINET CbA connections.
1. From PortVision Plus, select the 

DeviceMaster UP for which you want to 
reset the ports and click Web Manager. 
The Server Configuration page for the 
selected device appears.
Alternatively, you can enter the IP 
address for the device in the Address box 
of your web browser and press ENTER to 
access the web page for the device.

2. Scroll down to the bottom of the page 
and click Reboot. The Reboot 
DeviceMaster page appears.

3. Select Erase persistent connections.
Note: Only select Reset port(s) to factory 

settings if you also intend to 
restore the original factory 
settings for the ports. If you select 
this option, you also need to note 
the PROFINET CbA number for 
this device. You will need it in 
4.11.2. Changing the IP Address 
on Page 43.

4. Click Yes: Reboot. When the reboot 
completes, the Server Configuration 
page appears.

5. Verify that the network connection for 
the DeviceMaster UP is functioning 
properly.
• When lit, the amber Status LED on 

the device indicates the device is fully powered and has completed the boot cycle.
Note: The Status LED flashes for approximately 15 seconds while booting. When the bootloader 

completes the cycle, the LED has a solid, steady light. 
• When lit, the red Link/Act LED indicates a working Ethernet connection.
• When lit, the red Duplex LED indicates full-duplex activity.
• When lit, the red 100 LED indicates a working 100 MB Ethernet connection (100 MB network, only).
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• The Status column in PortVision Plus displays ON-LINE.
6. Repeat Steps 1 through 4 for each device that you intend to change the IP address for and all devices that 

are interconnected the changed devices.

4.11.2. Changing the IP Address

This procedure describes how to change or initially configure the IP address for a DeviceMaster UP.
1. From the Server Configuration page, click Configure Network. The Edit Network Configuration page 

appears.
2. Change the IP address information as required for your site.

Note: You also have to restore the original PROFINET CbA number in the PROFInet No box if you selected 
Reset port(s) to factory setting in the previous procedure.

3. Click Save. The Configuration Updated message appears.
4. Click Reboot.
5. Verify that the network connection for the DeviceMaster UP is functioning properly.

• When lit, the amber Status LED on the device indicates the device is fully powered and has completed 
the boot cycle.
Note: The Status LED flashes for approximately 15 seconds while booting. When the bootloader 

completes the cycle, the LED has a solid, steady light. 
• When lit, the red Link/Act LED indicates a working Ethernet connection.
• When lit, the red Duplex LED indicates full-duplex activity.
• When lit, the red 100 LED indicates a working 100 MB Ethernet connection (100 MB network, only).

6. Verify that the change is successful by one of the following methods:
• Type the new IP address for the device in your browser’s Address box.
• Open PortVision Plus and click Scan Network. Verify that the new IP address for the device appears in 

the list.
7. Repeat Steps 1 through 6 for each device for which you want to change the IP address and/or PROFINET 

CbA number.

4.11.3. Changing the IP Address in SIMATIC iMap

You can change the IP address for a DeviceMaster UP in SIMATIC iMap after initial configuration. Use 
PortVision Plus to initially configure the IP address (above).
1. Start SIMATIC iMap. Select Start > Programs > Component based Automation > SIMATIC iMap or double-

click the iMap icon on the desktop.
2. Select Project > Open and click the library in which you want to import the PROFINET CbA component. 

The filename must have a .cpb extension. When the library name appears in the File name box click Open.
Note: The file name drop-down list contains the most recently opened SIMATIC iMap projects.

3. If necessary, select the device in the Net View screen.
4. Select Edit > Properties....
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5. Click the Addresses tab and enter the IP address and subnet mask for the device.

Note: This IP address must match the IP address and subnet mask for the target device. For more 
information on changing the IP address for a device, see 4.11.2. Changing the IP Address on Page 
43.

6. Click OK to save your changes.

4.11.4. Downloading Interconnections

This procedure describes how do download interconnections to DeviceMaster UP devices in your project.
Note: If you created an interconnection to a device that represents a PLC program, you may need to generate 

the PLC component and that requires Step 7 installed on your computer. See the SIMATIC iMap 
documentation for additional information before you download the interconnections. 

1. Select Online > Download all instances > Interconnections only. A caution dialog box appears.
2. Click Yes to continue.
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