Table of Contents
SocketServer Overview
Server Status Page
Edit Port Configuration Page
Network Configuration Page
Security (Security Configuration/Key and Certificate Management Page)
EMail (Email Message Configuration Page)
RFC1006 [RFC1006 (ISO Over TCP) Configuration Page]
SocketServer Configuration Methods


SocketServer Overview

SocketServer Definition

SocketServer is integrated in the firmware that comes installed on your DeviceMaster LT, DeviceMaster PRO, DeviceMaster RTS, DeviceMaster Serial Hub, and some DeviceMaster UP models.

[Note]
Note

For the remainder of this help system, the DeviceMaster LT, DeviceMaster PRO, DeviceMaster RTS, DeviceMaster Serial Hub, and DeviceMaster UP are referred to simply as the DeviceMaster, unless there is a difference between models.

To use a DeviceMaster UP for a specific industrial protocol, use PortVision DX to load the appropriate firmware, which replaces SocketServer.

DeviceMaster ports can be configured for TCP/IP socket access from other hosts or for serial tunneling using SocketServer. The default operation of the DeviceMaster SocketServer is to buffer network-bound data and transmit the buffered data to the network once every 50ms. This is intended to provide a reasonable trade-off between latency and network utilization. If more control is desired when the serial port receive data is transmitted to the network, there are two user configurable features that can be used: EOL Detect and Serial Rx Timeout (Input Timeout field) on the Edit Port Configuration page.

When you open SocketServer, you can review information about the DeviceMaster on the Server Status page and then you can access these configuration pages:

  • Port

  • Network

  • Security

  • EMail

  • RFC1006


COM or tty Ports

If you want to use any of the ports as COM or tty ports, you should install the NS-Link (DeviceMaster) driver and then follow the procedures in this help system to configure the ports that you want to use as TCP/IP sockets.

[Note]
Note

Although the above link points to the DeviceMaster RTS path, the NS-Link driver is the same on all DeviceMasters.

If you install and enable an NS-Link (DeviceMaster) device driver on your PC, an NS-Link version of SocketServer loads on the DeviceMaster. The versions can be distinguished by what is displayed in the Software field on the Server Status page (NS-Link or SocketServer).


Configuration Modes

SocketServer provides three configuration modes:

  • TCP/IP socket mode operation is used to connect serial devices with an application that supports TCP/IP socket communications addressing.

  • Serial tunneling mode is used to establish a socket connection between two DeviceMasters through an ethernet network.

  • UDP mode is designed for applications that need faster data transmission, or that make use of UDP’s broadcast capabilities. UDP differs from TCP in that a UDP transmission does not first require a connection to be opened before sending data and the receiving device does not issue acknowledgements to the sender.


Telnet/SSH Command Line Interface

SocketServer provides a telnet command line interface that provides the following commands:

Telnet/SSH Command | Description
auth | Sets the authentication method used by web server.
help | help [cmd] - Displays the help information.
ip | Sets the IP configuration.
mac | Shows the MAC address.
model | Views the Model ID.
monitor | Monitors the serial port data. See the Serial Port Monitoring subsection for detailed information about this option.
nshosts | Shows the connected NS-Link (DeviceMaster device driver) hosts.
password | Sets the password.
reset | Resets the device.
secureconf | Enables/disables encryption for configuration.
securedata | Enables/disables encryption for data.
securemon | Enables/disables monitoring of the secure data via telnet.
setbaud | Sets the baud on any or all ports.
showtables | Show config tables.
snmp | Enables/disables SNMP.
telnet | Enables/disables telnet.
teltimeout | Sets the telnet timeout period (seconds).
timeout | Sets the time (seconds) until default application loads automatically.
ver | Displays the firmware revision.
quit | Exits the session.


Server Status Page

Server Status Page Overview

The following table provides information about the fields on the Server Status page. There is also an example of what the TCP Connection Status, Serial Status, and TCP Connection Configuration area in the lower portion of the page means.

Field or Area | Description
Software

This displays the version of the software, which can be the default firmware, SocketServer or the NS-Link DeviceMaster driver version.

The functionality of SocketServer is the same as the NS-Link DeviceMaster device driver version. If the NS-Link DeviceMaster driver is running on the DeviceMaster, NS-Link displays when you open a web browser session. If the NS-Link DeviceMaster driver is not running (not installed or not enabled), SocketServer displays when you open a web browser session.

Download and install the NS-Link DeviceMaster device driver for your operating system, if you want to use any of the ports as COM or tty ports before any configuration.

You can download the latest version of SocketServer for your platform:

  • DeviceMaster PRO, DeviceMaster RTS, and DeviceMaster Serial Hub

    [Note]
    Note

    Although the above link points to the DeviceMaster RTS path, SocketServer is the same on the specified DeviceMasters.

  • DeviceMaster LT
Host Name

You can enter a 16 character Host Name to identify this DeviceMaster using the Network Configuration page .

IPv4 Config

This field displays one of the following IP configuration types.

  • Use DHCP

  • Disable IPv4 networking

  • Use Static configuration below
IPv4 Address

The IPv4 address programmed into the DeviceMaster after applying the changes and rebooting the device.

See your network administrator for a valid IP address.

The default IP address programmed from the factory is 192.168.250.250.
IPv4 Netmask

The IP netmask is a 32-bit value (255.x.x.x) that enables IP packets to distinguish the network ID and host ID portions of the IP address.

The default Netmask programmed from the factory is 255.255.0.0.
IPv4 Gateway | The IPv4 Gateway is a TCP/IP configuration item that is the IP address of a directly reachable IP router. The default IP Gateway programmed from the factory is 192.168.250.1.
IPv6 Config

This field displays one of the following IP configuration types.

  • Use DHCP

  • Disable IPv6 networking

  • Use Static configuration below
IPv6 Address

The IPv6 address programmed into the DeviceMaster after applying the changes and rebooting the device.

See your network administrator for a valid IPv6 address.

The default IP address programmed from the factory is ::/0.

IPv6 Gateway | The IPv6 Gateway is a TCP/IP configuration item that is the IPv6 address of a directly reachable IP router. The default IP Gateway programmed from the factory is ::.
Network Tab | Click the Network tab to open the Network Configuration page. You can use Network Configuration page to change network settings after the initial DeviceMaster network configuration has been programmed.
Security Tab | Click the Security tab to open the Security Configuration page, which you can use to enable or disable DeviceMaster security for Telnet and SNMP.
EMail Tab | Click the EMail tab to open the Email Message Configuration page, which you can use to configure event notification through email from the DeviceMaster.
RFC1006 Tab

Click the RFC1006 tab to open the RFC1006 (ISO over TCP) Configuration page.

The RFC1006 protocol provides an additional transport layer on top of TCP/IP. RFC1006 connections to the DeviceMaster are made to a single TCP/IP port (default is 102). If the port number configured is negative, no incoming RFC1006 connections are allowed.

Port Name:

Port 1 (and Port x if there is more than one port; where x is the number of the port that corresponds to a physical port on the DeviceMaster)

Selecting the hyperlink for a port opens the corresponding Edit Port Configuration page for that port.

Use the Edit Port Configuration page to configure the following values for the port.

  • Serial configuration

  • TCP connection configuration

  • UDP configuration
TCP Connection Status Area | These values are configured in the Edit Port Configuration pages.
Serial Status Area | These values are configured in the Edit Port Configuration pages.
TCP Connection Configuration Area | These values are configured in the Edit Port Configuration pages.
Reboot | Click this button to reboot the DeviceMaster. Additionally, you can reset the serial port settings to the factory default values by clicking Reboot, Set configuration for all ports to factory default settings, and then Yes, Reboot.


Connection Status Example

You can verify operation of your connection by reviewing the Connection Status report on the Server Status page. The following table explains the sample connection status shown below.

Port | Configuration Settings | Notes
1 | Enabled = No | No This port has had no configuration changes applied. All values shown are default values. This port is not available for socket mode or serial tunneling at this time.
2
Enabled = Yes
Remote = 192.168.2.11:1363
Connect To = 0.0.0.0
Connect On = Always

This port is configured for Serial Tunneling mode and has a remotely connected PC as indicated by the address of 192.168.2.11:1363.

The Remote IP address is displayed indicating that there is a current connection from the IP address of 192.168.2.11. The value shown of 1055 is from the Ethernet layer and is a variable value and is not user controllable.

The Remote DeviceMaster is initiating the connection since the Connect To value is 0.0.0.0. In this case, the Connect On = Always would be incorrect. The initiating DeviceMaster would have the Connect On function. If the remote DeviceMaster does have the Connect On value set, then this Always option is ignored.

3 Incomplete

This port has been partially configured for Serial Tunneling. It is not connected to another DeviceMaster. The Port Enabled is set to No, so this port is unable to initiate or receive a socket connection.

A Remote IP address and port value has been entered into Connect To: configuration showing 192.168.2.11 to the default physical Port 1 as indicated by the value of 8000. It will not connect or be available until the Enabled is set to Yes and a Connect On option is selected.

4 Enabled = Yes

Socket Mode has been enabled. It confirms the local port of 8003 for the physical Port 4 on the DeviceMaster.

A Remote IP address is displayed indicating that there is a current connect from the IP address of 192.168.2.41. The value shown of 1990 is from the Ethernet layer and is a variable value and is not user controllable.

Since the Connection Configuration values are at the default, the remote system has initiated this connection.


Edit Port Configuration Page

To access the Edit Port Configuration page, click the Port that you want to configure on the Server Status page.

See the SocketServer Configuration Methods discussion for configuration procedures on how to configure the Edit Port Configuration page.

[Note]
Note

To reset the serial port settings to the factory default values, return to the Server Status page, click Reboot, Set configuration for all ports to factory default settings, and then Yes, Reboot.

Serial Configuration Fields

The following table explains the Serial Configuration portion of the Edit Port Configuration page. You can also refer to procedures on configuring the DeviceMaster for socket mode, serial tunneling, or UDP mode.

Serial Configuration | Description (Default in Bold)
Port Name

You can enter a 16-character Port Name to identify the port.
Mode

Mode of the device: RS-232 (default), RS-422, or RS-485 (2-port selections, see below) that you plan on connecting to the port.

DeviceMaster RTS 2-Port Models and DeviceMaster LT, only: RS-485 Mode provides these choices:

  • RS-485_2-wire (half-duplex) supports transmit and receive data. When data is transmitted, the Transmit Enable signal is activated, and the Transmit Receive device switches from receive to transmit automatically.

  • RS-485_4_wire_Master (full-duplex master) supports transmit and receive data, which means both signals are always active. The DeviceMaster is enabled by the Transmit Enable signal. This mode is the same as RS-422.

  • RS-485_4_wire_Slave (full-duplex slave) supports transmit and receive data. When data is transmitted, the Transmit Enable signal is activated, the Transmit device goes active and starts sending data. When the data is not being sent, the Transmit device is inactive. The Receive device is always active.

[Note]
Note

Modem control lines are not supported when using RS-485 mode.
Baud | Available device baud rates are: 300, 600, 1200, 2400, 4800, 9600 (default), 19200, 28800, 38400, 57600, 76800, 115200, and 230400.
Parity | Available choices are None (default), Even, or Odd.
Data Bits | Available choices are 5, 6, 7, and 8 (default).
Stop Bits | Available choices are 1 (default) or 2.
Flow | Available flow control choices are None (default), RTS/CTS, XON/XOFF, and (if supported by this DeviceMaster model) half-duplex.
DTR | Available choices are: ON all the time, OFF all the time, or on when a connection is established on this port (Socketon). Use Socketon if you want DTR turned on when a connection is established on this port.
RTS Available choices are: RTS ON all the time, OFF all the time, on when a connection is established on this port (Socketon), or on when data is being transmitted (Toggle). Use Socketon if you want RTS turned on when a connection is established on this port. Use Toggle if you want RTS turned on when data is being transmitted and turned off upon completion of data transmission.
[Note]
Note

RTS Toggle feature only works when Flow Control is set to None.

Check Tx Complete After Close if you want RTS to remain turned on for the Post RTS Hold Time after the TCP connection is closed. Otherwise, any buffered data will be discarded and RTS will be turned off immediately after the TCP connection is closed.

Pre/Post RTS Hold Time | If the RTS Toggle feature is enabled, SocketServer will turn RTS on and wait for the Pre RTS Hold Time before starting data transmission. RTS will remain turned on for the Post RTS Hold Time after data transmission completes. The Pre/Post RTS Hold Time can be configured to values from 0 ms to 4,294,967,295 ms (approximately 49 days). The default is 0 ms.
EOL† | If EOL detect is enabled (1-byte or 2-bytes), the DeviceMaster buffers receive serial data until the configured 1- or 2-byte EOL sequence is received. When that sequence has been received, the buffered data (including the EOL sequence) is written to the network. The default is Disabled.
Input Timeout†

If the Serial Rx Timeout feature is enabled (Input Timeout), the DeviceMaster buffers receive serial data until a gap in the serial receive data stream has been detected.

This gap can be configured to values from 1 ms to 4,294,967,295 ms (approximately 49 days). The default is 0ms.

Reset UART After Timeout

If a receive timeout is enabled, selecting this option causes the UART's internal state to be cleared whenever a receive timeout occurs.

Rx FIFO Disable (DeviceMaster RTS 1-Port only) | This option allows a parity conflict on a DeviceMaster RTS 1-port. It may be necessary to use this option after you have determined that the cabling is correct and you are able to transmit data but not receive proper data.
Tx Complete After Close

When unchecked, any buffered data will be discarded when the TCP connection is closed.

When checked SocketServer will finish sending any buffered data after the TCP connection is closed.

Resistor Termination (DeviceMaster LT, Only)

To ensure the best signal integrity on a long distance high-speed RS-422 or RS-485 network, sometimes it is required to place a 120Ω termination resistor between each of the transmit differential pair or receive differential pair. Signal reflection is reduced and a reliable communication is ensured by placing the 120Ω termination resistor. The DeviceMaster LT provides a software (SocketServer and NS-Link) controllable 120Ω termination resistor for each differential pair on every port in RS-422 and RS-485 mode. Using the software, you can place 120Ω termination resistors between the signals shown below:

  • RS-422 Mode

    • Between TxD+ and TxD- (Pin 5 and 7)

    • Between RxD+ and RxD- (Pin 4 and 2)

  • RS-485 - Between TxD/RxD+ and TxD/RxD- (Pin 5 and 7)

† If desired, the EOL and Input Timeout fields can be enabled at the same time: receive data is buffered until either an EOL or a timeout is detected. In any case, the maximum amount of receive data that is buffered is 8KB. If the 8KB receive buffer is filled, the buffered data is written to the network even though an EOL or timeout has not been detected.


TCP Connection Configuration Fields

The following table explains the TCP Connection Configuration portion of the Edit Port Configuration page. You can also refer to procedures on configuring the DeviceMaster for socket mode, serial tunneling, or UDP mode.

TCP Connection Configuration | Description
Enable | Not checked by default. Enable must be checked if you want to use this port as a socket or to enable security for the secure COM port redirector.

Listen

Port

Select the Listen check box (default) so that the DeviceMaster listens for incoming TCP/IP socket connections on the port number specified in the Port box.

You can change the default TCP port number on which the DeviceMaster listens for connections in the Port box. This is the actual socket value used for this physical serial port. This number must not be duplicated under this IP address.

Connect To/To Port/From Port

Connect To/

To Port

From Port

The IP address 0.0.0.0 is the default with Port 0 for the To Port and From Port fields.

This option is generally used in serial tunneling. Enter an IP address and port number to which the DeviceMaster should initiate a TCP connection in the Connect To and Port fields.

Connect On You must select the Connect On conditions under which the DeviceMaster should initiate a TCP connection (it only initiates a connection when a connection is not already established):
Always: Initiates a connection always and maintain a persistent connection.
Data: Initiates a connection when data is received.
DSR: Initiates a connection when DSR is active.
CD: Initiates a connection when CD is active.
Disconnect On Select the Disconnect On conditions under which the DeviceMaster should close the TCP connection:
Idle: Closes the connection if no data has been transmitted or received for the number of seconds specified by Idle Timer.
No DSR: Closes the connection when DSR goes inactive.
No CD: Closes the connection when CD goes inactive.
[Note]
Note

If you selected Always as the Connect On value, Disconnect On is not required.

Idle Timer | The default value is 300. The Idle Timer is the number of seconds in the Idle Timer box before a disconnect occurs if you selected a Disconnect On value.
Telnet Com Port Control Option (RFC 2217)

Select this option to enable RFC 2217 extensions to Telnet for full serial communication over a TCP connection.

The ports are configured in the client by specifying the IP address of the DeviceMaster and the port number (for example, 8000-80xx).


UDP Connection Configuration Fields

The following table explains the UDP Connection Configuration portion of the Edit Port Configuration page. You can refer to the procedures in configuring the DeviceMaster in UDP mode.

UDP Connection Configuration Description
Enable Serial to Ethernet

This enables data, from a serial port, to be sent to the list of IP addresses and/or port numbers.

When Enable Serial to Ethernet is selected, it allows data from the serial side to be forwarded on to the Ethernet side of the DeviceMaster.

When Enable Serial to Ethernet is NOT selected, this option prevents the data from the serial side being forwarded on to the Ethernet side of the DeviceMaster.

Enable Ethernet to Serial

This options allows data from the IP addresses, specified in the list, or any IP address.

When Enable Ethernet to Serial is selected, it allows data from the Ethernet side to be forwarded to the serial side of the DeviceMaster.

When Enable Ethernet to Serial is NOT selected, it prevents data from the Ethernet side being forwarded on to the serial side of the DeviceMaster.

Enable Ethernet Receive From Any IP Address

This options permits data reception from any IP address rather than limiting it to the list of IP addresses.

This option is used in conjunction with the Target IP Address Port (serial- >eth) fields.

When Enable Ethernet Receive from Any IP Address is selected, it requires you to enter the IP address of the sending unit, the IP address of the DeviceMaster that the data is expected from, in the following examples. The IP address is now serving double-duty. It is indicating that both the device the data is to be set to and received from when both Enable Serial to Ethernet and Enable Ethernet to Serial are enabled.

The only time the IP address needs to be entered in this case is if the data needs to be responded to so that the DeviceMaster knows where to send the replies back to. If the receive from any is checked, it accepts it form any address. If just can't reply to that address automatically. So the first line should not say it requires an IP address of the sending unit.

In the event that some incoming data from specific units may not need an acknowledgement (while other sending units do need acknowledgement) where the IP address of that sending unit is not included in the list, but the incoming data is needed, then this would be the time to enable this option. Remember that to send data back to the originating unit, that the Port number must also be used in addition to the IP address.

Target IP Address Port

Target Port (serial -> eth)

Source Port (serial ->eth)

Enter the Target IP Address Port (serial -> eth) for each port, which is a list of destination IP addresses and port numbers to which you are going to send the serial data received as UDP packets.

When there has been no IP address indicated, there is no data sent. This address can also indicate that data is allowed to be received from the network when it has originated at the IP address specified in this list.

UDP Listen Port

Enter the value of the UDP Listen Port, which is the specified port number to be used to listen for UDP data coming in on the Ethernet line.

This is the port number assigned to this particular port. This is used in the same manner as the TCP Port number assignments.


Edit Port Configuration Page (Management Fields)

The following table explains the fields at the bottom of the Edit Port Configuration page.

Edit Port Configuration Management | Description
Clone | Click Clone to propagate the serial configuration parameters for this port to all of the ports on a multi-port DeviceMaster.
Undo Changes | Allows you to undo the changes that you have made in this screen during this session.
Save | Saves the changes that you have made on this page and the DeviceMaster is updated.
Help | Opens the help file.


Network Configuration Page

You can use the Network Configuration page to configure the DeviceMaster network configuration after you have initially changed the default network information from the default values to appropriate values for your IPv4 or IPv6 network.

In addition, you can change the TCP Keepalive Timeout, Rx Polling Period, or Bootloader Timeout values to fit your environment.

Click the Network tab to access the Network Configuration page.

Network Configuration Fields

Field or Area | Description
Host Name

You can enter a 16-character Host Name to identify this DeviceMaster.

IPv4 Configuration

The following IPv4 configuration types are available.

  • Use DHCP

    Configures the DeviceMaster to use DHCPv4 mode.

    If you select Use DHCP, the IPv4 Address field below is disabled and set to 0.0.0.0.

    See your System Administrator to acquire a unique reserved IPv4 address if you are using DHCP. They will need the MAC address of the unit to provide you with an IPv4 address.

  • Disable IPv4 networking

    Configures the DeviceMaster to run in MAC mode with an NS-Link (DeviceMaster) driver. The MAC addressing method has the following advantages:

    • Simplifies implementation and ongoing support by eliminating the address administration issues inherent in network protocols.

    • MAC addresses are predefined by Comtrol and there is no potential for an “address conflict” at setup. Isolated from foreign LAN segments minimizing potential security issues.

    If you select Disable IPv4 networking, the IPv4 Address field below is disabled and set to 255.255.255.255. The netmask and default gateway are also disabled with their existing values.

  • Use Static configuration below

    Configures the DeviceMaster with the static IPv4 address information that you provide in the IPv4 Address, IPv4 Netmask, and IPv4 Gateway fields below.

    The DeviceMaster is shipped from the factory with the following default IPv4 network settings:

    • IPv4 address = 192.168.250.250

    • IPv4 Netmask = 255.255.0.0

    • IPv4 Gateway address = 192.168.250.1
IPv6 Configuration

The following IPv6 configuration types are available.

  • Use DHCP

    Configures the DeviceMaster to use DHCPv6 mode.

    If you select Use DHCP, the IPv6 Address field below is disabled.

    See your System Administrator to acquire a unique reserved IPv6 address if you are using DHCPv6 They will need the MAC address of the unit to provide you with an IPv6 address.

  • Disable IPv6 networking (Default)

    If you select Disable IPv6 networking, the IPv6 Address field below is disabled. The IPv6 gateway is also disabled with its existing values.

  • Use Static configuration below

    Configures the DeviceMaster with the static IPv6 address information that you provide in the IPv6 Address, IPv6 Prefix Length, and IPv6 Gateway fields below.

    The IPv6 Prefix Length is the network prefix bits for the IPv6 address.

TCP Keepalive Timeout

Default = 60

This option allows you to set the amount of time in seconds that the DeviceMaster waits until it closes this connection and frees all the ports associated with it.

The TCP protocol has an optional keepalive feature where the two network stacks periodically ping each other to make sure the connection is still up. In the UNIX world, this feature is usually known as the SOKEEPALIVE socket option.

By default, this keepalive feature is not enabled, and the only time you know a connection is down is when you try to write something and the other end does not acknowledge you. The potential issue with the DeviceMaster occurs when data flow was mostly one-way, and the receiver of the data was configured to initiate the TCP connection. If the sender of the data was rebooted, it would wait for the initiation a connection, discarding data.

The receiver would wait forever for data and never realize that the other end wasn't connected any more and that the TCP connection needed to be re-established.

Enabling the TCP keepalive feature for a connection solves this problem: the TCP stack periodically pings the other end. If the connection has gone away, the DeviceMaster is notified, so that it can attempt to re-establish the TCP connection.

Rx Polling Period

Default = 50

 This option controls the frequency with which the DeviceMaster transmits serial port data across the TCP connection. The default value is 50ms.

Bootloader Timeout

Default = 15

Allows you to change the bootloader time-out value before the default application, typically, SocketServer loads.

You may need to increase this time-out value to 45 for compatibility with spanning tree devices (normally switches). If you change the time-out value to 0, this prevents SocketServer from loading.

Undo Changes | Allows you to undo the changes that you have made in this screen during this session.
Save | Saves the changes that you have made on this page and the DeviceMaster is updated with the network information and reboots during the process.
Help | Opens the help file.


Changing Network Configuration

Use the following steps to change network settings in the DeviceMaster after initially configuring the network values. For initial configuration, you must use PortVision DX, an NS-Link (DeviceMaster) device driver, or a RedBoot method discussed in the DeviceMaster Installation and Configuration Guide that supports the DeviceMaster PRO, DeviceMaster RTS, and DeviceMaster Serial Hub or DeviceMaster LT User Guide, which supports the DeviceMaster LT.

PortVision DX is the easiest and recommended configuration method. PortVision DX is available on the product CD or you can download PortVision DX.

You can use the following procedure to change an IP address using the Network tab after initial network configuration.

  1. Click the Network tab.

  2. If desired, enter a Host Name to identify this DeviceMaster.

  3. Enter values appropriate for your network environment. You can refer to IP Configuration Fields for information.

    If you selected Use static configuration, enter a valid IP Address and support values for the selected IP type or types.

  4. If necessary, change the TCP Keepalive Timeout value.

  5. If necessary, change the Rx Polling Period.

  6. If necessary, change the Bootloader Timeout value.

  7. After making any changes, click Save.

    [Note]
    Note

    After completing this step, the browser may no longer be able to open the web page depending on the addresses in the DeviceMaster and the network segment to which it is connected.


Security (Security Configuration/Key and Certificate Management Page)

You can use this page to change DeviceMaster security configuration, and key and certificate management.

Security Configuration Area

This table discusses Security Configuration options.

Option Description
Enable Secure Data Mode

If Secure Data mode is enabled TCP connections which carry data to/from the serial ports will be encrypted using SSL or TLS security protocols. This includes the following:

  • TCP connections to the per-serial-port TCP ports (default is 8000, 8001, 8002, ...) are encrypted using SSL/TLS.

  • TCP connections to TCP port 4606 on which the DeviceMaster implements the Comtrol proprietary serial driver protocol are encrypted using SSL/TLS.

  • Since SSL/TLS can not be used for either UDP data streams or for the Comtrol proprietary MAC mode Ethernet driver protocol, both UDP and MAC mode serial data transport features are disabled.

  • In order to minimize possible security problems e-mail and RFC1006 features are also disabled in Secure Data mode.

In addition to encrypting the data streams, it is possible to configure the DeviceMaster so that only authorized client applications can connect using SSL/TLS. See the Client Authentication section for details.

Enable Secure Config Mode

If Secure Config mode is enabled, unencrypted access to administrative and diagnostic functions is disabled. Secure Config mode changes DeviceMaster behavior as follows:

  • Telnet access to administrative and diagnostic functions is disabled. SSH access is still allowed.

  • Unencrypted access to the web server via port 80 (http:// URLs) is disabled. Encrypted access to the web server via port 443 (https:// URLs) is still allowed.

  • Administrative commands that change configuration or operating state which are received using the Comtrol proprietary TCP driver protocol on TCP port 4606 are ignored.

  • Administrative commands that change configuration or operating state that are received using the Comtrol MAC mode proprietary Ethernet protocol number 0x11FE are ignored.

Enable Telnet/ssh

This option enables or disables the telnet security feature after you click Save and the DeviceMaster has been rebooted. This option is enabled by default.

Enable Monitoring Secure Data via telnet

When checked, this allows the monitor command to be used while Secure Data Mode is enabled. When unchecked, the monitor command can only be used if Secure Data Mode is not enabled. You must click Save and reboot the DeviceMaster for the change to affect. This option is disabled by default.

See Serial Port Monitoring for a detailed explanation of this feature.

Enable SNMP

This option enables or disables the SNMP security feature after you click Save and the DeviceMaster has been rebooted. This option is enabled by default.

Serial Port Monitoring

The Enable Monitoring Secure Data via Telnet feature allows you to monitor serial data being sent/received on a serial port (either via NS-Link or SocketServer). The monitoring is done by telnetting to the DeviceMaster and using the following commands:

  • monitor [-ac] portnumber

    Display a live hex dump of Tx/Rx data for the specified serial port. You can only monitor one port at a time. The live dump will continue until the Enter key is pressed. See the following detailed description and examples. The data is logged when it is written/read to/from the serial port driver's Tx/Rx buffers -- as such, the relative timing between Rx/Tx bytes is not precise, but it should be sufficient to debug most problems (especially frame-oriented, command/response serial protocols).

    Monitoring serial data through a telnet connection does generate extra network traffic and may have small effects on the timing of DeviceMaster operations when large amounts of data are being logged at high baud rates.

  • securemon [enable|disable]

    By default, monitoring of Tx/Rx data when in Secure Data Mode is not allowed via telnet (an insecure protocol). This command allows you to override that default when securemon is enabled it will allow monitoring of secure data via an insecure protocol like telnet.

    This setting is also accessible on the Security Configuration page where it is labeled Enable Monitoring Secure Data via Telnet.

    Currently, because of issues with the DeviceMaster's ssh implementation, monitoring serial port data via the ssh command-line interface is not supported. It is expected that it will be supported in the future. Once it is supported, the securemon setting will not affect the ability to monitor secure data via ssh (which will always be allowed).

Detailed monitor Command Usage

The command usage is

monitor [-ac] portnumber

This command will display a hex dump of tx/rx data with each line preceded by a direction marker of > for tx and < for rx. Pressing [Enter] terminates monitor mode.

Here is the monitor output using a loopback plug and a program that repeatedly sends the string abcABC123 to Port 1:

dm> monitor 1
                        Serial monitoring started for port 1 -- press [Enter] to stop.

                        > 61 62 63 41 42 43 31 32 33
                        < 61 62 63 41 42 43 31 32 33
                        > 61 62 63 41 42 43 31 32 33
                        < 61 62 63 41 42 43 31 32 33
                        > 61 62 63 41 42 43 31 32 33
                        < 61 62 63 41 42 43 31 32 33
                        > 61 62 63 41 42 43 31 32 33
                        < 61 62 63 41 42 43 31 32 33

There are two available options, -a and -c:

  • -a

    Enable display of ASCII representation of data in a column to the right the hex representation:

                                    dm> monitor -a 1
                                Serial monitoring started for port 1 -- press [Enter] to stop.

                                > 61 62 63 41 42 43 31 32 33                       > abcABC123
                                < 61 62 63 41 42 43 31 32 33                       < abcABC123
                                > 61 62 63 41 42 43 31 32 33                       > abcABC123
                                < 61 62 63 41 42 43 31 32 33                       < abcABC123
                                > 61 62 63 41 42 43 31 32 33                       > abcABC123
                                < 61 62 63 41 42 43 31 32 33                       < abcABC123
                                > 61 62 63 41 42 43 31 32 33                       > abcABC123
                                < 61 62 63 41 42 43 31 32 33                       < abcABC123
                                > 61 62 63 41 42 43 31 32 33                       > abcABC123
                                < 61 62 63 41 42 43 31 32 33                       < abcABC123
                                > 61 62 63 41 42 43 31 32 33                       > abcABC123
                                < 61 62 63 41 42 43 31 32 33                       < abcABC123

  • -c

    Enable use of color instead of < and > to indicate the data flow direction. Tx is green and Rx is red.

    [Note]
    Note

    In the following illustration, red text (Rx) is represented in bold and green text (Tx) is not bold.

    dm> monitor -c 1
                                Serial monitoring started for port 1 -- press [Enter] to stop.

                                61 62 63 41 42 43 31 32 33 61 62 63 41 42 43 31
                                32 33 61 62 63 41 42 43 31 32 33 61 62 63 41 42
                                43 31 32 33 61 62 63 41 42 43 31 32 33 61 62 63
                                41 42 43 31 32 33 61 62 63 41 42 43 31 32 33 61
                                62 63 41 42 43 31 32 33 61 62 63 41 42 43 31 32
                                    33 61 62 63 41 42 43 31 32 33 61 62 63 41 42 43
                                        31 32 33 61 62 63 41 42 43 31 32 33 61 62 63 41
                                            42 43 31 32 33 61 62 63 41 42 43 31 32 33 61 62
                                                63 41 42 43 31 32 33 61 62 63 41 42 43 31 32 33

The -a and -c options can be used together:

                        dm> monitor -ac 1
                        Serial monitoring started for port 1 -- press [Enter] to stop.
                        61 62 63 41 42 43 31 32 33 61 62 63 41 42 43 31  | abcABC123abcABC1
                        32 33 61 62 63 41 42 43 31 32 33 61 62 63 41 42  | 23abcABC123abcAB
                        43 31 32 33 61 62 63 41 42 43 31 32 33 61 62 63  | C123abcABC123abc
                        41 42 43 31 32 33 61 62 63 41 42 43 31 32 33 61  | ABC123abcABC123a
                        62 63 41 42 43 31 32 33 61 62 63 41 42 43 31 32  | bcABC123abcABC12
                        33 61 62 63 41 42 43 31 32 33 61 62 63 41 42 43  | 3abcABC123abcABC
                        31 32 33 61 62 63 41 42 43 31 32 33 61 62 63 41  | 123abcABC123abcA
                        42 43 31 32 33 61 62 63 41 42 43 31 32 33 61 62  | BC123abcABC123ab
                        63 41 42 43 31 32 33 61 62 63 41 42 43 31 32 33  | cABC123abcABC123


Key and Certificate Management Area

For secure operation, the DeviceMaster uses a set of four keys and certificates. These keys and certificates may be configured by the user.

Option Description
RSA Key pair used by SSL and SSH servers

This is a private/public key pair that is used for two purposes:

  • It is used by some cipher suites to encrypt the SSL/TLS handshaking messages. Possession of the private portion of this key pair allows an eavesdropper to both decrypt traffic on SSL/TLS connections that use RSA encryption during handshaking.

  • It is used to sign the Server RSA Certificate in order to verify that the DeviceMaster is authorized to use the server RSA identity certificate.

[Note]
Note

Possession of the private portion of this key pair allows somebody to pose as the DeviceMaster.

If the Server RSA Key is to be replaced, a corresponding RSA identity certificate must also be generated and uploaded or clients are not able to verify the identity certificate.

RSA Server Certificate used by SSL servers

This is the RSA identity certificate that the DeviceMaster uses during SSL/TLS handshaking to identify itself. It is used most frequently by SSL server code in the DeviceMaster when clients open connections to the DeviceMaster's secure web server or other secure TCP ports. If a DeviceMaster serial port configuration is set up to open (as a client) a TCP connection to another server device, the DeviceMaster also uses this certificate to identify itself as an SSL client if requested by the server.

In order to function properly, this certificate must be signed using the Server RSA Key. This means that the server RSA certificate and server RSA key must be replaced as a pair.

DH Key pair used by SSL servers

This is a private/public key pair that is used by some cipher suites to encrypt the SSL/TLS handshaking messages.

[Note]
Note

Possession of the private portion of the key pair allows an eavesdropper to decrypt traffic on SSL/TLS connections that use DH encryption during handshaking.

Client Authentication Certificate used by SSL servers

If configured with a CA certificate, the DeviceMaster requires all SSL/TLS clients to present an RSA identity certificate that has been signed by the configured CA certificate. As shipped, the DeviceMaster is not configured with a CA certificate and all SSL/TLS clients are allowed.

See Client Authorization for more detailed information.

[Note]
Note

All DeviceMaster units are shipped from the factory with identical configurations. They all have the identical, self-signed, Comtrol Server RSA Certificates, Server RSA Keys, Server DH Keys, and no Client Authentication Certificates.

For maximum data and access security, you should configure all DeviceMaster units with custom certificates and keys.

Client Authentication

If desired, controlled access to SSL/TLS protected features can be configured by uploading a client authentication certificate to the DeviceMaster. By default, the DeviceMaster is shipped without a CA (Certificate Authority) and therefore allows connections from any SSL/TLS client.

If a CA certificate is uploaded, the DeviceMaster only allows SSL/TLS connections from client applications that provide to the DeviceMaster an identity certificate that has been signed by the CA certificate that was uploaded to the DeviceMaster.

This uploaded CA certificate that is used to validate a client's identity is sometimes referred to as a "trusted root certificate", a "trusted authority certificate", or a "trusted CA certificate". This CA certificate might be that of a trusted commercial certificate authority or it may be a privately generated certificate that an organization creates internally to provide a mechanism to control access to resources that are protected by the SSL/TLS protocols.

To control access to the DeviceMaster's SSL/TLS protected resources you should create your own custom CA certificate and then configure authorized client applications with identity certificates signed by the custom CA certificate.


Changing Security Configuration

Use the following steps to change security settings in the DeviceMaster.

  1. Click the Security tab.

  2. Click the appropriate check boxes in the Security Configuration area to enable or disable security accordingly. Refer to the Security Configuration Area subsection for detailed information.

  3. After making changes to the Security Configuration area, you must click Save and then OK.

    [Note]
    Note

    You must reboot the DeviceMaster for any security changes to go into effect.


Changing Keys and Certificates

Use the following steps to update security keys and certificates in the DeviceMaster.

  1. Click the Security tab.

  2. Click Set for the appropriate key or certificate option in the Keys and Certificate Management area to configure security keys and certificates. Refer to the Key and Certificate Management subsection for detailed information.

  3. Click Browse to locate the key or certificate file, highlight the file, and click Open.

  4. Click Upload when you return to the Key and Certificate Management area.

    The key or certificate notation changes from factory or none to User when the DeviceMaster is secure.

    You do not need to click Save, but changes will not take effect until the DeviceMaster is rebooted.


EMail (Email Message Configuration Page)

Email Message Configuration Page

Use the following tables for field definitions. The first table illustrates the Server Status fields and the second table provides information about the Message Configuration fields.

Server Status | Description
SMTP Server IP Address | The IP address of the SMTP server.
SMTP Sender Host Name | The host name of the SMTP sender. A common format for host names is mail.domainname.com. (For example, mail.Comtrol.com.)
Email Recipient | The address of the administrator of the network or DeviceMaster. The DeviceMaster will send notifications to this address. Multiple email recipients are not supported. Use the normal email address format, for example, Support@Comtrol.com.
Email Sender | A name that you can assign to the DeviceMaster. For example, DeviceMaster1@Comtrol.com. This is only what is displayed in the senders address and cannot be replied to.

This table provides information about the Message Configuration fields.

Message Configuration | Description
Enable DeviceMaster Boot Up Message | The unit boots up. This includes when the unit resets or when the power is cycled.
Enable TCP Connection Message | When someone makes a TCP connection to the unit, for example when the NS-Link (DeviceMaster) driver connects using IP mode.
Enable TCP Timeout Message | When the TCP Time-out activates during an idle time-out or when the unit disconnects.
Enable TCP Host Disconnect Message | When the server causes a disconnect, for example when the NS-Link (DeviceMaster) device driver stops.
Enable MAC Connection Message | When someone makes a MAC connection to the unit, for example when the NS-Link (DeviceMaster) device driver starts up.
Enable MAC Timeout Message | When the MAC Time-out activates during an idle time-out or when the unit disconnects.
Enable Port Opened (Driver) Message | When someone opens a serial port using an NS-Link device driver. The message states which port is being used. NS-Link is a port connection.
Enable Port Closed (Driver) Message | When the port is closed. The message states which port is being used. NS-Link is a port connection.
Enable Port Opened (Socket) Message | When someone opens a port through a TCP/IP connection to the DeviceMaster. The message states which port is being used.
Enable Port Closed (Socket) Message | When the port is closed. The message states which port is being used.
Enable Web Server Login Message | This triggers when the password access is successful.
Enable Web Server Login Error Message | When someone tries to enter the DeviceMaster Web server unsuccessfully.
Enable Telnet/ssh Login Message | Triggers when someone successfully logs into a DeviceMaster Telnet/ssh session. The password is the same as the Web server password.
Enable Telnet/ssh Login Error Message | When someone tries to enter a DeviceMaster Telnet/ssh session unsuccessfully.
Enable Telnet/ssh Connection Closed Message | When someone closes the port. This provides a time stamp if desired.
Undo Changes | Allows you to undo the changes that you have made in this screen during this session.
Save | Saves the changes that you have made on this page and the DeviceMaster is updated.
Help | Opens the help file for this page.


Configuring Email Notification from the DeviceMaster

Use the following procedure to setup the parameters for email message delivery.

  1. Click the EMail tab.

  2. Enter the IP address of the SMTP server.

  3. Enter the Host Name of the SMTP server. The common format for host names is mail.domainname.com. (For example, mail.Comtrol.com.)

  4. Enter a valid Email Recipient. This is the address of the administrator of the network or DeviceMaster. The DeviceMaster will send notifications to this address. Multiple email recipients are not supported.

    Use the normal email address format, for example, Example@Comtrol.com.

  5. Enter a valid Email sender. This is a name that you can assign to the DeviceMaster. For example, DM1@Comtrol.com.

    This is only what is displayed in the sender's address and cannot be replied to.

  6. Select the desired check boxes to have the DeviceMaster send a message when the appropriate events occur.


RFC1006 [RFC1006 (ISO Over TCP) Configuration Page]

RFC1006 (ISO Over TCP) Configuration Page

The RFC1006 protocol provides an additional transport layer on top of TCP/IP. RFC1006 connections to the DeviceMaster are made to a single TCP/IP port (default is 102). If the port number configured is negative, no incoming RFC1006 connections are allowed.

To determine the desired destination for incoming connections, the RFC1006 protocol contains an endpoint name (TSAP) field in the connection request frame. Each serial port on the DeviceMaster has a TSAP endpoint name (defaults are PORT01 through PORT32). If a port’s TSAP name is configured as blank, connections to that port are not allowed. Incoming connections are also refused for serial ports that are busy (in use by either SocketServer or NS-Link).

RFC1006 is a datagram service and to get useful results you may have to configure the DeviceMaster so that it can determine where the RxSerial data stream is to be divided into datagrams. The buffering description determines how to do this.

Connections initiated by the DeviceMaster are RFC1006 connections if the Connect To TSAP field on the RFC1006 Configuration page is not blank. If that field is blank, then outbound connections are raw TCP/IP connections.

Field | Description
Listen on TCP Port

RFC1006 connections to the DeviceMaster are made to a single TCP/IP port (default is 102).

If the port number configured is negative, no incoming RFC1006 connections are allowed.
Port # | The physical port on the device.
Local TSAP | Each serial port on the DeviceMaster has a local TSAP endpoint name (defaults are PORT01 through PORT32).
IP | The IP address to which connections are initiated when the Connect On conditions are true for the serial port in the Connect To IP field. This is the same as the Connect To address field on the Edit Port Configuration page.
Port | The TCP port number to which connections are initiated when the Connect On conditions are true for the serial port in the Port field. This is the same as the Connect To Port field on the Edit Port Configuration page.
TSAP

The local endpoint name for the serial port.

To determine the desired destination for incoming connections, the RFC1006 protocol contains an endpoint name (TSAP) field in the connection request frame.

If a port’s TSAP name is configured as blank, connections to that port are not allowed and then outbound connections are raw TCP/IP connections. Incoming connections are also refused for serial ports that are busy (in use by either SocketServer or NS-Link).

Undo Changes | Allows you to undo the changes that you have made in this screen during this session.
Save | Saves the changes that you have made on this page and the DeviceMaster is updated.


Configuring RFC1006 (ISO Over TCP)

To configure DeviceMaster ports for the RFC1006 protocol, use the following procedure.

  1. Make sure that you have configured the network information into the DeviceMaster and it is connected to the network.

  2. Click the RFC1006 tab.

  3. If necessary, change the Listen on TCP Port to the TCP/IP port number upon which the DeviceMaster accepts incoming RFC1006 connections. The default value is 102. Any negative value disables all incoming RFC1006 connections.

  4. Enter the local endpoint name for the serial port in the Local TSAP field. A blank value disables incoming RFC1006 connections for that port.

  5. Enter the IP address to which connections are initiated when the Connect On conditions are true for the serial port in the Connect To IP field. This is the same as the Connect To address field on the Edit Port Configuration page.

  6. Enter the TCP port number to which connections are initiated when the Connect On conditions are true for the serial port in the Connect To Port field. This is the same as the Connect To port field on the Edit Port Configuration page.

  7. Enter the RFC1006 endpoint name (at the above IP/port) to which connections are initiated when the Connect On conditions are true for the serial port in the Connect To TSAP field. If this field is blank, a raw TCP/IP connection are initiated. If the field contains a value the RFC1006 protocol is used to connect to the TSAP name given.

  8. Click Save when you have completed the RFC1006 (ISO over TCP) Configuration page.

  9. Click OK, when the Configuration Updated page appears.


SocketServer Configuration Methods

Socket Mode Configuration

Use the following procedure to set up DeviceMaster ports for use through TCP/IP socket connections.

  1. Make sure that you have configured the network information into the DeviceMaster and it is connected to the network.

    [Note]
    Note

    The default IP address is 192.168.250.250 for the DeviceMaster.

  2. Select the port number on the DeviceMaster that you want to configure. The Edit Port Configuration page appears.

  3. Configure the serial characteristics for this port.

    [Note]
    Note

    See Serial Configuration Fields if you need field descriptions.

  4. Configure the connection characteristics for this port.

    1. Click Enable so that SocketServer uses this port.

    2. Click the Listen check box so that the DeviceMaster listens for incoming TCP/IP socket connections on the port number specified in the Enable on Port box for this port.

    3. Optionally, change the default TCP port number on which the DeviceMaster listens for connections in the Enable on Port box. This is the actual socket value used for this physical serial port. This number must not be duplicated under this IP address.

    4. You must select the Connect On conditions under which the DeviceMaster should initiate a TCP connection (it only initiates a connection when a connection is not already established).

    5. Optionally, select the Disconnect On conditions under which the DeviceMaster should close the TCP connection.

    6. Optionally, enter the number of seconds in the Idle Timer box before a disconnect occurs if you selected a Disconnect On value.

  5. After verifying that the value for each item for the selected port is suitable, select Save. When the Configuration Updated page appears, select OK.

  6. Repeat Steps 3 through 6 for each port that you want to configure on the DeviceMaster or clone the port.

    If you select Clone, only the Serial Configuration parameters are cloned, not the Connection Configuration values.

  7. Click the Security tab if you want to set up DeviceMaster security.

  8. To configure any ports for RFC1006, go to Configuring RFC1006 (ISO Over TCP) to complete configuration.

  9. You can verify the operation of your application and connections by checking for a change in the receive and transmit bytes on the Connection Status report in the Server Status page.


Serial Tunneling Port Configuration

Use the following procedure to set up two DeviceMasters for serial tunneling.

  1. Make sure that you have configured the network information into the DeviceMaster and it is connected to the network.

    [Note]
    Note

    The default IP address is 192.168.250.250 for the DeviceMaster.

  2. Select the port number on DM#1 that you want to configure. The Edit Port Configuration page appears.

  3. Configure the serial characteristics for this port.

    1. Select the mode of the device (RS-232, RS-422, or RS-485) that you plan on connecting to this port.

      [Note]
      Note

      The DeviceMaster Serial Hub only supports RS-232.

    2. Select the baud rate of the device.

    3. Select the parity, number of data bits, flow control, and stop bits for this port.

    4. Select whether you want DTR ON all the time, OFF all the time, or on when a connection is established on this port (socketon). Use socketon if you want DTR turned on when a connection is established to this port.

    5. If EOL detect is enabled (1-byte or 2-bytes), the DeviceMaster buffers received serial data until the configured 1 or 2 byte EOL sequence is received. When that sequence has been received, the buffered data (including the EOL sequence) is written to the network.

    6. If the Serial Rx Timeout feature is enabled (Input Timeout field), the DeviceMaster buffers receive serial data until a gap in the serial receive data stream has been detected. This gap can be configured to values from 1 ms to 4,294,967,295 ms (approximately 49 days).

      [Note]
      Note

      If desired, the EOL and Input Timeout fields can be enabled at the same time: receive data are buffered until either an EOL or a timeout is detected. In any case, the maximum amount of receive data that is buffered is 8KB. If the 8KB receive buffer is filled, the buffered data is written to the network even though an EOL or timeout has not been detected.

  4. Configure the connection characteristics for this port.

    1. Select Enable for SocketServer to use this port.

    2. Select the Listen check box so that the DeviceMaster listens for incoming TCP/IP socket connections on the port number specified in the Enable on Port box for this port.

    3. Optionally, change the default TCP port number on which the DeviceMaster listens for connections in the Enable on Port box.

    4. Enter the IP address and port number to which the DeviceMaster should initiate a TCP connection in the Connect To and Port boxes.

    5. You must select the Connect On conditions under which the DeviceMaster should initiate a TCP connection (it only initiates a connection when a connection is not already established):

      Always: Initiate a connection always and maintain a persistent connection.
      Data: Initiate a connection when data is received.
      DSR: Initiate a connection when DSR is active.
      CD: Initiate a connection when CD is active

    6. Optionally, select the Disconnect On conditions under which the DeviceMaster should close the TCP connection:

      Idle: Close the connection if no data has been transmitted or received for the number of seconds specified by Idle Timer.
      No DSR: Close the connection when DSR goes inactive.
      No CD: Close the connection when CD goes inactive.
      [Note]
      Note

      If you selected Always as the Connect On value, a Disconnect On value is not required.

    7. Optionally, enter the number of seconds in the Idle Timer box before a disconnect occurs if you selected a Disconnect On value.

  5. After verifying that the value for each item for the selected port is suitable, select Save. The Configuration Updated page appears. Select OK.

  6. Repeat Steps 3 through 6 for each port you want to configure on DM#1 or clone the port. If you select Clone, only the Serial Configuration parameters are cloned, not the Connection Configuration values.

  7. Enter the IP address of DM#2 in the Address box of the web browser, and press the Enter key.

  8. Select the port that you want to configure.

  9. Configure the serial characteristics for this port on DM#2, if necessary, use Step 4.

  10. Configure the connection characteristics.

    1. Select Enable so that SocketServer uses this port.

    2. Select the Listen check box so that the DeviceMaster listens for incoming TCP/IP socket connections on the port number specified in the Enable on Port box for this port.

    3. Optionally, change the default TCP port number on which the DeviceMaster listens for connections in the Enable on Port box. This must match the value entered in Step 5d.

      It is not necessary to enter an IP address for this unit to connect to as the first unit programmed is initiating the connection.

  11. After verifying that the value for each item is correct, select Save. When the Configuration Updated page appears, select OK.

  12. Repeat Steps 9 through 12 for each port you want to configure on DM#2.

  13. Click the Security tab if you want to set up DeviceMaster security.

  14. To configure any ports for RFC1006, go to Configuring RFC1006 (ISO Over TCP) to complete configuration.

  15. Connect your serial devices to the DeviceMasters.

  16. You can verify operation of your connection by reviewing the Connection Status report on the Server Status page.


UDP Mode Configuration

UDP mode is designed for applications that need faster data transmission, or that make use of UDP’s broadcast capabilities. UDP differs from TCP in that a UDP transmission does not first require a connection to be opened before sending data and the receiving device does not issue acknowledgements to the sender.

This section provides procedures for the following UDP configuration procedures:

  • One to many, one way UDP data transfer configuration

  • One to many, bi-directional UDP data transfer configuration

  • Many to one, one way UDP data transfer configuration

  • Many to one, bi-directional UDP data transfer configuration

The following procedure is a general procedure that provides basic descriptions and definitions. See the UDP Configuration Overview for detailed examples about each type of UDP configuration.

  1. Make sure that you have configured the network information into the DeviceMaster and it is connected to the network.

    [Note]
    Note

    The default IP address is 192.168.250.250 for the DeviceMaster.

  2. Select the port number on the DeviceMaster that you want to configure. The Edit Port Configuration page appears.

  3. Configure the serial characteristics for this port.

    1. Select the mode of the device (RS-232, RS-422, or RS-485) that you plan on connecting to this port.

      [Note]
      Note

      The DeviceMaster Serial Hub only supports RS-232.

    2. Select the baud rate of the device.

    3. Select the parity, number of data bits, flow control, and stop bits for this port.

    4. Select whether you want DTR ON all the time, OFF all the time, or on when a connection is established on this port (socketon). Use socketon if you want DTR turned on when a connection is established to this port.

    5. If EOL detect is enabled (1-byte or 2-bytes), the DeviceMaster buffers received serial data until the configured 1 or 2 byte EOL sequence is received. When that sequence has been received, the buffered data (including the EOL sequence) is written to the network.

    6. If the Serial Rx Timeout feature is enabled (Input Timeout field), the DeviceMaster buffers receive serial data until a gap in the serial receive data stream has been detected. This gap can be configured to values from 1 ms to 4,294,967,295 ms (approximately 49 days).

      [Note]
      Note

      If desired, the EOL and Input Timeout fields can be enabled at the same time: receive data is buffered until either an EOL or a timeout is detected. In any case, the maximum amount of receive data that is buffered is 8KB. If the 8KB receive buffer is filled, the buffered data is written to the network even though an EOL or timeout has not been detected.

  4. Configure the UDP connection characteristics. See the UDP Configuration Examples section, if you are unsure how to configure UDP for your environment.

    1. Select Enable Serial to Ethernet to enable data, from a serial port, to be sent to the list of IP addresses and/or port numbers.

      • When Enable Serial to Ethernet is NOT selected, it allows data from the serial side to be forwarded on to the Ethernet side of the DeviceMaster.

      • When Enable Serial to Ethernet is NOT selected, this option prevents the data from the serial side being forwarded on to the Ethernet side of the DeviceMaster.

    2. Select Enable Ethernet to Serial to allow data from the IP addresses, specified in the list, or any IP address. See Step c if you want the data to be sent out as serial data.

      • When Enable Ethernet to Serial is selected, it allows data from the Ethernet side to be forwarded to the serial side of the DeviceMaster.

      • When Enable Ethernet to Serial is NOT selected, it prevents data from the Ethernet side being forwarded on to the serial side of the DeviceMaster.

    3. Select Enable Ethernet Receive from Any IP Address to permit data reception from any IP address rather than limiting it to the list of IP addresses.

      This option is used in conjunction with the Target IP Address Port (serial- >eth) fields.

      • When Enable Ethernet Receive from Any IP Address is selected, it accepts incoming data from a sending unit where the sending unit has entered the IP address of this unit. There still must be an IP address installed in the list for data to be returned to the originating point.

        For example, if using these ports in a One-Way mode, and this is the unit receiving the data, instead of entering in the IP addresses of all of the sending units, select this option.

      • When Enable Ethernet Receive from Any IP Address is selected, it requires us to enter the IP address of the sending unit, the IP of the DeviceMaster that the data is expected from, in the following examples. The IP address is now serving double duty. It is indicating both the device that data is to be set to and received from when both Enable Serial to Ethernet and Enable Ethernet to Serial are enabled.

        In the event that some incoming data from specific units may not need an acknowledgement (while other sending units do need acknowledgement) where the IP address of that sending unit is not included in the list, but the incoming data is needed, then this would be the time to enable this option. Remember that to send data back to the originating unit, that the Port number must also be used in addition to the IP address.

    4. Enter the Target IP Address (serial- >eth) for each port, which is a list of destination IP addresses and port numbers for sending the serial data received as UDP packets.

      When there has been no IP address indicated, there is no data sent. This address can also indicate that data is allowed to be received from the network when it has originated at the IP address specified in this list.

    5. Enter the value of the UDP Listen Port, which is the specified port number to be used to listen for UDP data coming in on the Ethernet line.

      This is the port number assigned to this particular port. This is used in the same manner as the TCP Port number assignments.

  5. After verifying that the value for each item for the selected port is suitable, select Save. When the Configuration Updated page appears, select OK.

  6. Repeat Steps 3 through 6 for each port that you want to configure on the DeviceMaster.

  7. Click the Security tab if you want to set up DeviceMaster security.

  8. To configure any ports for RFC1006, go to Configuring RFC1006 (ISO Over TCP) to complete configuration.

  9. You can verify the operation of your application and connections by checking for a change in the receive and transmit bytes on the Connection Status report in the Server Status page.

  10. The UDP Configuration Overview section provides you with detailed information about how to use the different types of UDP configuration methods.

Example Overview

The following examples use a DeviceMaster 1-port (DM1) and a DeviceMaster 4-port. The following information is static in all of the examples.

  • DM1 is configured to these network settings:

    IP Address = 192.168.11.11
    Mask = 255.255.255.0
    Gateway = 192.168.11.1

  • DM4 is configured to these network settings:

    IP Address = 192.168.11.41
    Mask = 255.255.255.0
    Gateway = 192.168.11.1.

In the examples, you can use this procedure to configure the serial portion of the DM1 and DM4.

  1. Make sure that you have configured the network information into the DeviceMaster unit and it is connected to the network.

    [Note]
    Note

    The default IP address is 192.168.250.250 for the DeviceMaster.

  2. Enter the IP address of the DeviceMaster in the Address field of your web browser and press the Enter key.

  3. Select the appropriate port and configure it accordingly.

    Serial Configuration:

    • Mode: RS-232

    • Baud Rate: 115200

    • Parity: None

    • Data bits: 8

    • Stop bits: 1

    • Flow Control: None

    • DTR: off

    • EOL: Disabled

    • Timeout: 0

  4. TCP Connection Configuration:

    Make sure that Enable is NOT checked and all other options at default.


One-to-Many, One-Way UDP Data Transfer Configuration

In this example an DeviceMaster 1-port (DM1) forwards its incoming serial data out Ethernet to an DeviceMaster 4-port (DM4) to all four serial ports. Those four serial ports may connect to four different PCs, etc.

There are several steps in the procedure:

  • Configuring the DM1

  • Configuring the DM4

  • Testing the one-to-many, one-Way UDP data transfer configuration

Example Application: A scale connected to an DM1 that sends its data to multiple monitoring PCs. Each PC receives the data at the same time and has no need to acknowledge the receipt of the data from the scale.

Configuring the DM1

Use this procedure to configure one-to-many, one-way UDP data transfer. This example represents one serial port out to four serial ports.

  1. Configure the DM1 serial characteristics as shown in the Overview in Step 3.

  2. Configure the UDP Connection Configuration as follows:

    1. Select Enable Serial to Ethernet. This allows data from the serial side, to be forwarded on to the Ethernet side, of the DM.

    2. Do not Enable Ethernet to Serial. This prevents data from the Ethernet side to be forwarded on to the serial side of the DM.

    3. Do not Enable Ethernet Receive From Any IP Address. This prevents any data from being accepted from any undesired UDP origination point.

      Enter in Target IP Addresses and Port numbers of the DM4 destination ports.

      • 192.168.11.41 7000

      • 192.168.11.41 7001

      • 192.168.11.41 7002

      • 192.168.11.41 7003

    4. Select Save and then Ok to save the configuration and return to the Server Status page.


Configuring the DM4

  1. Configure Port 1 of the DM4 serial characteristics as shown in Step 3

  2. Configure the UDP Connection Configuration as follows:

    1. Do not Enable Serial to Ethernet. This prevents data from the serial side, to be forwarded on to the Ethernet side, of the DM.

    2. Select Enable Ethernet to Serial. This allows data from the Ethernet side to be forwarded on to the serial side of the DM.

    3. Do not Enable Ethernet Receive From Any IP Address. Leaving this disabled requires us to enter the IP address of the Sending unit, in this case, the IP of the DM1 in the Target IP Address field.

    4. Enter the DM1 IP address of 192.168.11.11 in the Target IP Address field.

      [Note]
      Note

      It is not necessary to enter the port value, but it may be a handy reminder of the sending port when a multiport units are used for troubleshooting and tracking purposes.

    5. Select Save and then Ok to save the configuration and return to the Server Status page.

  3. Configure Port 2 of the DM4 serial characteristics as shown in Step 3.

  4. Configure the UDP Connection Configuration as follows:

    1. Do not Enable Serial to Ethernet. This prevents data from the serial side, to be forwarded on to the Ethernet side, of the DM.

    2. Select Enable Ethernet to Serial. This allows data from the Ethernet side to be forwarded on to the serial side of the DM.

    3. Select Enable Ethernet Receive From Any IP Address. With this enabled, it prevents the requirement for us to enter the IP address of the sending unit, in this case the IP of the DM1 in the Target IP Address field. If this option is enabled, any UDP packets are accepted regardless of the origination point, as long as the origination point includes this address as a destination. This does create possible security issues and is not recommend as a general course. Since the previous option is selected, it is NOT necessary to enter the IP of the DM in the Target IP field.

      [Note]
      Note

      Keep in mind the security issues associated with this option.

    4. Select Save and then Ok to save the configuration and return to the Server Status page.

  5. Repeat the options from either Port 1 or Port 2 as desired for remaining ports


Testing this Configuration

Use this procedure to test this configuration. This procedure uses Test Terminal, which is included in PortVision DX.

[Note]
Note

In a Linux environment, you can use Minicom.

  1. Attach a null-modem cable from COM2 on PC#1 to DM1 RS-232 port.

  2. Use one of the methods below.

    • Install a multiport serial adapter into PC and connect each port of the DM4 to a port on the multiport serial adapter. This test has used a DeviceMaster 8-port (DM8) to create additional ports in the same PC that COM2 is being used in.

    • Attach a null-modem cable from COM2 on each PC to each DM4 RS-232 serial port.

      • Attach a null-modem cable from COM2 on PC#2 to DM4 Port#1

      • Attach a null-modem cable from COM2 on PC#3 to DM4 Port#2.

      • Attach a null-modem cable from COM2 on PC#4 to DM4 Port#3.

      • Attach a null-modem cable from COM2 on PC#5 to DM4 Port#4.

  3. Open Test Terminal and Open COM2, setting the port parameters to match the DM1.

  4. Open a second copy of Test Terminal and open four ports (in this example COMs3, 4, 5, and 6) set the port parameters to match the DM4.

    • Attach a null-modem cable from Port 1 of the DM4 to Port 1 of the DM8 (COM3).

    • Attach a null-modem cable from Port 2 of the DM4 to Port 2 of the DM8 (COM4).

    • Attach a null-modem cable from Port 3 of the DM4 to Port 3 of the DM8 (COM4).

    • Attach a null-modem cable from Port 4 of the DM4 to Port 4 of the DM8 (COM5).

  5. In the COM2 window, type any character. This character should appear in COMs3, 4, 5, and 6 in the second copy of Test Terminal.

    [Note]
    Note

    There is NO DATA RETURN to COM2 in this example.


One-to-Many: Bi-Directional UDP Data Transfer Configuration

In this example a DM 1-port (DM1) forwards its incoming serial data out Ethernet to an all four serial ports of a DM 4-port (DM4). The DM4 serial ports may connect to four different PCs, etc. Data is returned from the four ports to the DM1.

There are several steps in the procedure:

  • Configuring the DM1

  • Configuring the DM4

  • Testing the one-to-many, bi-directional UDP data transfer configuration

Example Application: A milling machine connected to an DM1 sends its data to multiple monitoring PCs. Each PC receives the data at the same time. One PC needs to acknowledge the receipt of the data and all PCs need the capability to send new instruction sets to the milling machine. In the situation of all PCs responding at the same time, all of the data is intermingled. There is NO means to differentiate the data to indicate the sending party. It is imperative that only one PC at a time send data.

Configuring the DM1

Use this procedure to configure one-to-many, bi-directional UDP data transfer. This example represents one serial port out to four serial ports with a data reply.

  1. Configure the DM1 serial characteristics as shown in Step 3.

  2. Configure the UDP Connection Configuration as follows:

    1. Select Enable Serial to Ethernet. This allows data from the serial side, to be forwarded on to the Ethernet side, of the DM.

    2. Select Enable Ethernet to Serial. This allows data from the Ethernet side to be forwarded on to the serial side of the DM.

    3. Do NOT Enable Ethernet Receive From Any IP Address. Leaving this disabled requires us to enter the IP address of the sending unit, in this case the IP of the DM4 that the reply is expected from. The IP address is now serving double duty. It is indicating both the device that data is to be set to and received from.

    4. Enter the Target IP Addresses and port numbers of the DM4 destination ports.

      • 192.168.11.41 7000

      • 192.168.11.41 7001

      • 192.168.11.41 7002

      • 192.168.11.41 7003

      Here we are setting the IP addresses and individual port addresses to enable the data to be sent to all four ports. The port value is required only for outbound data. Since this is two-way data transferring, the port value is required. Inbound data only would require that the IP address be added once.

    5. Select Save and then Ok to save the configuration and return to the Server Status page.


Configuring the DM4

  1. Configure Port 1 of the DM4 serial characteristics as shown in Step 3.

  2. Configure the UDP Connection Configuration as follows:

    1. Select Enable Serial to Ethernet. This allows data from the serial side, to be forwarded on to the Ethernet side, of the DM.

    2. Select Enable Ethernet to Serial. This allows data from the Ethernet side to be forwarded on to the serial side of the DM.

    3. Do NOT Enable Ethernet Receive From Any IP Address. Leaving this disabled requires us to enter the IP address of the Sending unit, in this case the IP of the DM1 in the Target IP Address field.

    4. Enter the IP address of 192.168.11.11 and Port 7000 for the DM1 in the Target IP Address field.

      [Note]
      Note

      For bi-directional communications, it IS required to enter the port value of the DM1. In this case, 7000.

    5. Select Save and then Ok to save the configuration and return to the Server Status page.

  3. Configure Port 2 of the DM4 serial characteristics as shown in Step 3.

  4. Configure the UDP Connection Configuration as follows:

    1. Select Enable Serial to Ethernet. This allows data from the serial side, to be forwarded on to the Ethernet side, of the DM.

    2. Select Enable Ethernet to Serial. This allows data from the Ethernet side to be forwarded on to the serial side of the DM.

    3. Select Enable Ethernet Receive From Any IP Address. When enabled, this prevents the requirement for us to enter the IP address of the sending unit, in this case the IP of the DM1 in the Target IP Address field. If this option is enabled any UDP packets are accepted, regardless of the origination point. This does create possible security issues and is not recommend as a general course.

      Since the previous option is selected, it is NOT necessary to enter the IP of the DM in the Target IP field.

      [Note]
      Note

      Now that bi-directional communication is desired, it is required that the IP address and port value of the DM1 be entered in the Target IP Address options so that the returning data know its destination.

    4. Select Save and then Ok to save the configuration and return to the Server Status page.

  5. Repeat the options from either Port 1 or Port 2 as desired for remaining ports.


Testing this Configuration

This test procedure is slightly different from the test procedure illustrated in the previous subsection.

  1. Follow Steps 1 through 5 in the Testing this Configuration discussion to start the test procedure.

  2. In the COM3 (or COM4, 5, 6) type any character. This character should appear in COM2 in the first copy of Test Terminal.

  3. To test that the data is not differentiated, place loopback plugs on the DM4.

  4. Open COM2 and enter a character. This character should be repeated four times (once for each port) with no indication of which port sent which character.

    [Note]
    Note

    There is DATA RETURN to COM2 in this example.


Many-to-One: One-Way UDP Data Transfer Configuration

In this example an DM 4-port (DM4), using all four serial ports, forwards its incoming serial data from all four ports out through Ethernet to an DM1 connected to the PC COM2 by means of a null-modem cable. The four serial ports may connect to four different PCs, scales, etc.

There are several steps in the procedure:

  • Configuring the DM1

  • Configuring the DM4

  • Testing the many-to-one, one-way UDP data transfer configuration

Example Application: A scale is connected to each of the DM4 ports and sends its data to a single monitoring PC (COM2). Each scale sends its data in sequence and no two scales send data at the same time. This is critical as there is no means by which data can be identified as to the sending port, and the data is intermingled. For example: Port 1 sends ABCD and Port 2 sends 1234, both at the same time. The data seen in COM2 may be A1B2CD34.

Configuring the DM1

Use this procedure to configure many-to-one, one-way UDP data transfer. This example represents four serial ports out to one serial port.

  1. Configure the DM1 serial characteristics as shown in Step 3.

  2. Configure the UDP Connection Configuration as follows:

    1. Do NOT Enable Serial to Ethernet. This prevents data from the serial side, to be forwarded on to the Ethernet side, of the DM.

    2. Select Enable Ethernet to Serial. This allows data from the Ethernet side to be forwarded on to the serial side of the DM.

    3. Do NOT Enable Ethernet Receive From Any IP Address. Leaving this disabled requires us to enter the IP address of the sending unit, in this case the IP of the DM4 in the Target IP Address field.

    4. Enter the IP address of 192.168.11.41 as the DM4 in the Target IP Address field. Since all four ports are in the same DM, all on the same IP address, it is not necessary to enter the IP address more than once. The receiving side does not know the sending port nor does it need to know the sending port value (7000, 7001, etc.).

      [Note]
      Note

      It is not necessary to enter the port value, but it may be a handy reminder of the sending port when several multiport units are used, for trouble shooting and tracking purposes.

    5. Select Save and then Ok to save the configuration and return to the Server Status page.


Configuring the DM4

  1. Configure Port 1 of the DM4 serial characteristics as shown in Step 3.

  2. Configure the UDP Connection Configuration as follows:

    1. Select Enable Serial to Ethernet. This allows data from the serial side, to be forwarded on to the Ethernet side, of the DM.

    2. Do NOT Enable Ethernet to Serial. This prevents data from the Ethernet side to be forwarded on to the serial side of the DM.

    3. Do not Enable Ethernet Receive From Any IP Address. This prevents any data from being accepted from any UDP origination point. We are not setting this unit up to accept any data.

    4. Enter the IP address of 192.168.11.11 and Port 7000 for the DM1 in the Target IP Address field.

      [Note]
      Note

      This is the destination of the data.

    5. Select Save and then Ok to save the configuration and return to the Server Status page.

  3. Repeat the port configuration options for the remaining ports.


Testing this Configuration

This test procedure is slightly different from the test procedure illustrated in the previous subsection.

  1. Follow Steps 1 through 5 in the Testing this Configuration discussion (One-to-Many, One-Way UDP Data Transfer Configuration) to start the test procedure.

  2. In the COM3, 4, 5, and 6 windows, type any character. This character should appear in COM2 in Test Terminal. If two or more, of COMs3, 4, 5, or 6 sends data at the same time, the data is merged in COM2 with no way to tell which device sent which information. COMs3, 4, 5, and 6 must use a round-robin approach so that the data may be properly evaluated.

    [Note]
    Note

    There is NO DATA RETURN to COMs3, 4, 5, or 6 in this example. Entering of any data into COM2 is not transmitted back to COM3, 4, 5, or 6.


Many-to-One: Bi-Directional UDP Data Transfer Configuration

In this example an DM 4-port (DM4), using all four serial ports, forwards its incoming serial data from all four ports out through Ethernet to an DM1 connected to the PC COM2 by means of a null-modem cable. The four serial ports may connect to four different PCs, scales, etc. Data is returned from the DM1 to the four ports.

There are several steps in the procedure:

  • Configuring the DM1

  • Configuring the DM4

  • Testing the many-to-one, bi-directional UDP data transfer configuration

Example Application: A scale is connected to each of the DM4 ports and it sends data to a single monitoring PC (COM2). Each scale sends its data in sequence and no two scales send data at the same time. This is critical as there is no means by which data can be identified as to the sending port, and the data is intermingled. For example: Port 1 sends ABCD and Port 2 sends 1234, both at the same time. The data seen in COM2 may be A1B2CD34. Once data has been received from all four ports, the application needs to send an acknowledgment so that the scale can reset in preparation for the next measurement.

Configuring the DM1

Use this procedure to configure many-to-one, one-way UDP data transfer. This example represents four serial ports out to out serial port with data reply.

  1. Configure the DM1 serial characteristics as shown in Step 3.

  2. Configure the UDP Connection Configuration as follows:

    1. Select Enable Serial to Ethernet. This allows data from the serial side, to be forwarded on to the Ethernet side, of the DM.

    2. Select Enable Ethernet to Serial. This allows data from the Ethernet side to be forwarded on to the serial side of the DM.

    3. Do NOT Enable Ethernet Receive From Any IP Address. Leaving this disabled requires us to enter the IP address of the sending unit, in this case the IP of the DM4 in the Target IP Address field.

    4. Enter the IP address of 192.168.11.41 as the DM4 in the Target IP Address field. Since we want replies to be sent to each of the four ports on the DM4 unit, we must enter the IP addresses and port values of each port.

      • 192.168.11.41 7000

      • 192.168.11.41 7001

      • 192.168.11.41 7002

      • 192.168.11.41 7003


Configuring the DM4

  1. Configure Port 1 of the DM4 serial characteristics as shown in Step 3.

  2. Configure the UDP Connection Configuration as follows:

    • Select Enable Serial to Ethernet. This allows data from the serial side, to be forwarded on to the Ethernet side, of the DM.

    • Select Enable Ethernet to Serial. This allows data from the Ethernet side to be forwarded on to the serial side of the DM.

    • Do NOT Enable Ethernet Receive From Any IP Address. This prevents any data from being accepted from any UDP origination point.

    • Enter the IP address of 192.168.11.11 and Port 7000 for the DM1 in the Target IP Address field.

      [Note]
      Note

      This is the destination of the data and with it entered in the field and both Enable Serial to Ethernet and Enable Ethernet to Serial, data flows both directions.

  3. Repeat the Port Configuration options for the remaining ports.


Testing this Configuration

  1. Follow Steps 1 through 5 in the Testing this Configuration discussion (One-to-Many, One-Way UDP Data Transfer Configuration) to start the test procedure.

  2. In the COM3, 4, 5, and 6 windows, type any character. This character should appear in COM2 in Test Terminal. If two or more of COM3, 4, 5, or 6 sends data at the same time, the data is merged in COM2 with no way to tell which device sent which information. COMs3, 4, 5, and 6 must use a round-robin approach so that the data may be properly evaluated.

    [Note]
    Note

    There is DATA RETURN to COM3,4,5 or 6 in this example. Entering of any data into COM2 is transmitted back to COM3,4,5 or 6 simultaneously.