Subject: multi-valued attributes

From: "Rick Snodgrass" <rts>
Date: Wed, 31 Mar 1993 14:22:22 MST

The proposed schema is much improved over previous ones, but now isn't
even in 3NF, which is somewhat embarrassing!  I suggest that we split
off the Skills attribute to a new relation:

        Skills (Name, Skill)

for which Skill would be a multi-valued attribute, in the
conventional, snapshot sense.  This change would, I think, result in
BNCF for all relations.

-- Rick

---

From: "Patrick P Kalua" <[email-masked]>
Date: Wed, 31 Mar 1993 16:37:46 -0500 (EST)

> conventional, snapshot sense.  This change would, I think, result in

    It makes more sense. At least let us start with good design principles.

Patrick