Subject: TSQL2 book now available

From: Rick Snodgrass <rts>
Date: Tue, 31 Oct 1995 16:00:13 -0700

The TSQL2 language design and commentaries have been updated and published
as a book.

Snodgrass, R.T., editor, {\it The TSQL2 Temporal Query Language}, Kluwer
Academic Publishers, 1995, 674+xxiv pages.\\

Attached is a table of contents and an order form.

Please note that I had nothing to do with setting the pricing of the book,
which is exceedingly high. If you are interested in this book, perhaps your
research grant or library can purchase a copy.

Cheers,

Rick


1. Rationale for a Temporal Extension to SQL
Richard T. Snodgrass and Henry Kucera
3-18

2. Introduction to TSQL2
Richard T. Snodgrass
19-31

3. Tutorial
Richard T. Snodgrass
33-47

4. A Second Example
Richard T. Snodgrass, Christian S. Jensen, Curtis
E. Dyreson, Wolfgang Kaefer, Nick Kline and John F. Roddick
49-73

5. The Baseline Clock
Curtis E. Dyreson and Richard T. Snodgrass
77-96

6. The Data Model for Time
Curtis E. Dyreson, Michael D. Soo and Richard T. Snodgrass
97-101

7. Supporting Multiple Calendars
Richard T. Snodgrass and Michael D. Soo
103-121

8. Temporal Data Types
Michael D. Soo and Richard T. Snodgrass
123-152

9. The Surrogate Data Type
Christian S. Jensen and Richard T. Snodgrass
153-156

10. The TSQL2 Data Model
Christian S. Jensen, Richard T. Snodgrass and Michael D. Soo
157-240

11. Schema Specification
Richard T. Snodgrass, Christian S. Jensen and Fabio Grandi
241-243

12. The From Clause
Richard T. Snodgrass, Christian S. Jensen and Fabio Grandi
245-249

13. Valid-Time Selection and Projection
Suchen Hsu, Christian S. Jensen and Richard T. Snodgrass
251--298

14. Update
T. Y. Cliff Leung, Christian S. Jensen and Richard T. Snodgrass
299--304

15. Cursors
Christian S. Jensen, Richard T. Snodgrass and T. Y. Cliff Leung
305--310

16. Event Tables
Richard T. Snodgrass
311-318

17. Transaction Time Support
John F. Roddick and Richard T. Snodgrass
319-325

18. Temporal Indeterminacy
Curtis E. Dyreson and Richard T. Snodgrass
327-346

19. Temporal Granularity
Curtis E. Dyreson and Richard T. Snodgrass
347-383

20. ``Now''
James Clifford, Curtis E. Dyreson, Richard T. Snodgrass,
Tomas Isakowitz and Christian S. Jensen
385-394

21. Aggregates
Nick Kline, Richard T. Snodgrass and T.Y. Cliff Leung
395-425

22.Schema Versioning Support
John F. Roddick and Richard T. Snodgrass
427-449

23. Vacuuming
Christian S. Jensen
451-462

24. An Architectural Framework
Michael D. Soo, Christian S. Jensen and Richard T. Snodgrass
465-473

25. A Timestamp Representation
Curtis E. Dyreson and Richard T. Snodgrass
474-499

26. SQL-92 Compatibility Issues
Michael D. Soo, Nick Kline and Richard T. Snodgrass
501-504

27. An Algebra for TSQL2
Michael D. Soo, Christian S. Jensen and Richard T. Snodgrass
505-546

28. Language Syntax
549

29. Section 5 Lexical Elements
551-561

30. Section 6 Scalar Expressions
563-590

31. Section 7 Query expressions
591-598

32. Section 8 Predicates
599-605

33. Section 10 Additional Common Elements
605-606

34. Section 11 Schema definition and manipulation
607-616

35. Section 12 Module
617-619

36. Section 13 Data manipulation
621-627

37. Section 21 Information Schema and Definition Schema
629-630

38. Section 22 Status Codes
631

Chapters 28-38 were authored by the TSQL2 Language Design Committee

=============================================================================
                            ORDER FORM    
   
Author: Richard T. Snodgrass  (Editor)
Title: The TSQL2 Temporal Query Language 
( ) Hardbound / ISBN: 0-7923-9614-6 
    NLG: 350.00 USD: 205.00 GBP: 139.50 

Ref: KAPIS

( ) Payment enclosed to the amount of ___________________________
( ) Please send invoice
( ) Please charge my credit card account:

    Card no.: |_|_|_|_|_|_|_|_|_|_|_|_|_|_|_|_|  Expiry date: ______________

    () Access       () American Express     () Mastercard
    () Diners Club  () Eurocard             () Visa

    Name of Card holder: ___________________________________________________

Delivery address:

Title       : ___________________________ Initials: _______________M/F______

First name  : ______________________ Surname: ______________________________

Organization: ______________________________________________________________

Department  : ______________________________________________________________

Address     : ______________________________________________________________

Postal Code : ___________________ City: ____________________________________

Country     : _____________________________Telephone: ______________________

Email       : ______________________________________________________________

Date        : _____________________ Signature: _____________________________

Our European VAT registration number is: |_|_|_|_|_|_|_|_|_|_|_|_|_|_|

To be sent to:
For customers in Mexico, USA, Canada        Rest of the world:
and Latin America:

Kluwer Academic Publishers                  Kluwer Academic Publishers Group
Order Department                            Order Department
P.O. Box 358                                P.O. Box 322
Accord Station                              3300 AH Dordrecht
Hingham, MA 02018-0358                      The Netherlands
U.S.A.

Tel    : 617 871 6600                       Tel   : +31 78 392392
Fax    : 617 871 6528                       Fax   : +31 78 546474
Email  : [email-masked]                    Email : [email-masked]
                                               After October 10, 1995
                                               Tel  : +31 78 6392392
                                               Fax  : +31 78 6546474

Payment will be accepted in any convertible currency. Please check the rate
of exchange with your bank. Prices are subject to change without notice. All 
prices are exclusive of Value Added Tax (VAT). Customers in the Netherlands
please add 6% VAT. Customers from other countries in the European Community:
* please fill in the VAT number of your institute/company in the appropriate
  space on the orderform: or
* please add 6% VAT to the total order amount (customers from the U.K. are
  not charged VAT).

---

From: Rakesh Chandra <[email-masked]>
Date: Sun, 5 Nov 1995 12:58:33 -0800

Hi Prof. Snodgrass,

Just wanted to tell you that I 
have moved from Salomon Brothers to ING Capital.
If you need any papers to be reviewed please
contact me at either [email-masked]
or [email-masked] .

/rakesh
.