Subject: Re: Ahn/Temporal element

From: Shashi K. Gadia <[email-masked]>
Date: Wed, 15 Sep 93 14:36:27 CDT

Hi Ilsoo:
	
> 	A temporal element in one dimension is 
> 	a union but NOT a set of intervals.  
> 
> Greetings.
> If a union is a set operator, doesn't a union of intervals
> result in a set (of intervals) ?

No.

> I don't see the significance of the distinction here.
> 
This distinction is similar to: "a relation is not a sequence 
of tuples rather a set of tuples.  This distinction is 
extremely important.

A union of intervals is already a reduced object having 
a unique representation, where as a set is not.  

> 	The terms "Multi-intervals" or "Interval sets" 
> 	or simply "Intervals" lean towards a set and 
> 	not union.  
> 
> I don't see how "temporal element" denotes a union better,
> if a distinction between a set and a union is important.
> 	
I agree that there is nothing inherent in the term 
"temporal element" that says it is a union and not 
a set of intervals.  One could use a term such as 
intervalunion which is self explaining.  But in science 
when a new and seemingly useful object is born, it is customary to 
give it a new name.  This allows the concept of that 
object to twist, turn, toss and change, and most 
importantly evolve through generalization.  

> 	The term temporal element is more generic.  
> 	In the bitemporal model, it is union of rectangles.  
> 	Moreover if your bitemporal space does not contain 
> 	notion of future the bitemporal space reduces 
> 	to triangle below the diagonal.  And a temporal 
> 	element becomes union of triangles and rectangles.  
> 	(See Section 6.2 on page P-26 of workshop 
> 	proceedings.)
> 
> Term "interval" is used in a general sense too.
> For example, Section 3.15 mentions bitemporal intervals.
> 	
What when it becomes a union of triangles?

> 	The term temporal element generalizes to spatial 
> 	or spatio-temporal element.  A spatio temporal 
> 	element can be very complex. 
> 	
> A temporal element reminds me of a picture element, which is a pixel.
> This unintended similarity may become more significant
> in a spatio-temporal DB which may deal with images.

I never thought of the interesting similarity with pixels.  
Even though in the discrete case any region (hence 
a spatial element) becomes a union of pixels this is not 
my intention.  But that is not what is of essenes here.  
A spatial elemen is defined as a union of implementor chosen 
primitive regions (e.g. half places, circles, polygons).

In summary the distance between the word "interval" 
and "temporal element" is intentional.  I think of temporal 
element as a starting point where temporal databases start.  
Intervals are a cosmic diversion, and have little 
significance to me.  Even though a temporal elemrnt is 
defined as a union of intervals, I use it only to 
convery what I have in mind.  If I could do it by magic 
without using intervals I would to it.  To me temporal 
element (the concept) is the most primitive notion in 
temporal databases.

> Regards
> Ilsoo Ahn

---

From: [email-masked]
Date: Thu, 16 Sep 1993 07:35:21 MST

From: Shashi K. Gadia <[email-masked]>
	Subject: Re: Ahn/Temporal element
	To: [email-masked]
	Date: Wed, 15 Sep 93 14:36:27 CDT
	Cc: [email-masked]
	
Gadia,
This discussion is more interesting and complex than I initially thought.
I still have some questions.

	No.
	
Is the union not a set operator then ?

You may call a sequence a set, though the reverse is not true.
If the union is a set operator, then the result of a union may be
called a set, though the reverse is not true.

Well, you may consider a triangle as a degenerate case of a rectangle.
(It may actually be a rectangle with two vertices 0.01 anstrom apart :)
Again, the reverse is not true.
	
	...  To me temporal 

I agree that it is an important concept.
The current proposal for TSQL2 is based on the concept.
That is why we need a good name that can withstand scrutinies of
people outside the temporal DB field.

    Rick wrote,
	> 	This discussion raises two questions in my mind. If I have
	> three temporal elements, each containing one interval:
	> 	A = [1..10]
	> 	B = [11..20]
	> 	C = [21..30]
	> 
	> Then D= A union C is a temporal element containing two intervals.
	> 
	> My question is, how many intervals are in E = D union B?

Is the answer 1 or 3 ?
E = [1..10] U [21..30] U [11..30].
This looks like 3.
Can it be simplified (coalesced) to E = [1..30] ?
Then the answer is 1, which seems to me correct.

	Example: 
	   E = 1..10 U 5..23 U 21..30 U 6..24
	Where as the above union is unique, the intervals chosen 
	to express that union is not.

You mean that E cannot be coalesced to 1..30 ?
Then what is the union operator for ?

Actually, it may be clearer to represent E in this case as a set,
without the union operator:
	   E = { 1..10, 5..23, 21..30, 6..24}
which is certainly different from
	   E = { 1..11, 5..23, 21..30, 6..24} or E = { 1..30 }

Regards,
Ilsoo