
 

Aligning Objects 
To align objects in columns or rows:

1. Select the objects you want to align.

2. Choose Row Align from the Arrange menu or click the Row Align button on the Ribbon Bar to 
horizontally align the objects.

3. Choose Column Align from the Arrange menu or click the Column Align button on the Ribbon Bar 
to vertically align the objects.

See also

Distributing Objects

General Alignment Options



 

Aligning Objects to the Grid

To align object centers to the grid as you draw them, choose Snap to Grid from the View menu (Ctrl+Y) or
click the Snap to Grid button on the Ribbon Bar.

To align the centers of objects to the grid:

1. Select the object(s) you want to align.

2. Choose Align from the Arrange menu.

3. Check the Align to Grid box.

4. Choose OK.

To align the edges of an object to the grid:

1. Select the object(s) you want to align. 

2. Enable Snap to Grid in the View menu.

3. Point to an edit handle surrounding the selected object(s).

4. Press and hold down the left mouse button to resize the object. The edges of the object lock to 
the grid.

5. Release the left mouse button.

See also

General Alignment Options

Grid Setup

Resizing Objects

Snap to Grid



General Alignment Options

The Align command in the Arrange menu opens the Align dialog box. It displays the portion of the current 
diagram containing the selected objects. Align the selected objects as follows:

· Left/Center/Right:    Aligns the selected objects in a column along either the left, center, or right side of
the objects' bounding box.

· Top/Center/Bottom:    Aligns the selected objects in a row either on the top, center, or bottom of the 
objects' bounding box.

See also

Aligning Objects to the Grid

Centering Objects on a Page

Distributing Objects

Aligning Objects



 

Centering Objects on a Page

To center objects on a page:

1. Select the objects you want to center.

2. Choose Grouped from the Arrange menu or click the Group button on the Ribbon Bar.

3. Choose Align from the Arrange menu.

4. Check the Align to Center of Page box. All selected objects are moved to the page center in the 
preview box.

5. If you do not want the objects to move vertically, deselect the Center box on the right side of the 
preview box. If you do not want the objects to move horizontally, deselect the Center box on the 
top of the preview window.

6. Choose OK.

Note: The Align to Center of Page option is only available for single-page diagrams. If your diagram has 
several tiled pages, this option is grayed.

See also

Aligning Objects to the Grid

General Alignment Options



 

Distributing Objects

To distribute a set of objects:

1. Select the objects to distribute.

2. Choose Align from the Arrange menu.

3. Choose a column align option (Left, Center, or Right), or a row align option (Top, Center, or 
Bottom).

4. Choose Distribute. The centers of the selected objects are distributed at equal intervals within the
bounding rectangle.

5. Adjust the object spacing by choosing a distribution value.

6. Choose Center or Edges. Center aligns each object to the center of the bounding box, spaced 
apart according to the distribution value. Edges aligns the objects to the edge (top/bottom, 
left/right, center) of the bounding box, depending on the distribution value. 

7. Choose OK.

See also

General Alignment Options

Aligning Objects



 

Moving Objects To Front

To move an object to the front of a layer:

1. Select the object.

2. Choose To Front from the Arrange menu, or click the To Front button on the Ribbon Bar. The 
selected object is moved to the front of the layer.

If the selected objects are located on different layers, arranging them using To Front or To Back does not 
alter the appearance of the image.

Note:  The redraw and printing order for objects is determined by which layer they reside on. Layer 10, 
the bottom-most layer, is redrawn and printed first. Layer 1, the top-most layer, is redrawn and printed 
last.

See also

Setting up Layers

Moving Objects Between Layers

Moving objects To Back



 

Moving Objects To Back

To move an object to the back of a layer:

1. Select the object.

2. Choose To Back on the Arrange menu or click the To Back button on the Ribbon Bar. The 
selected object is moved to the back of the layer.

If the selected objects are located on different layers, arranging them using To Front or To Back does not 
alter the appearance of the image. 

Note:  The redraw and printing order for objects is determined by which layer they reside on. Layer 10, 
the bottom-most layer, is redrawn and printed first. Layer 1, the top-most layer, is redrawn and printed 
last.

See also

Setting up Layers

Moving Objects Between Layers

Moving Objects To Front



 

Setting up Layers 

You can define up to 10 layers in a diagram, each with its own image content. Layer 1 is the top layer; 
layer 10 is the bottom one.

To set up the layers in a diagram:

1. Choose Layer Setup from the Arrange menu.

2. Define the current layer by typing a value in the Current Layer box. Objects added to the diagram are 
added to the layer you defined.

3. Designate each layer as either active, hidden or protected by clicking on the associated radio button.

See also

Moving objects To Back

Moving objects To Front

Moving Objects Between Layers



 

Moving Objects Between Layers

To move an object to another layer:

1. Select one or more objects.

2. Choose Change Layers from the Arrange menu.

3. Choose the new layer for the selected objects.

4. Choose OK.

See also

Setting up Layers

Moving objects To Back

Moving objects To Front



Rotating Objects

To rotate an objects(s):

1. Select the object(s) to be rotated.

2. Choose Rotate from the Arrange menu or click the Rotate button on the Ribbon Bar. 

3. Move the pointer over one of the edit handles.

4. Press the left mouse button and hold it down.

5. Drag the mouse to rotate the objects.

6. Release the left mouse button to end the rotate.

All shapes may be rotated except for imported bitmaps and metafiles.

To constrain the rotation:

Hold down the CTRL key while rotating an object to constrain the rotation to 15-degree increments.

See also

Selecting a Single Object



Scaling Objects

To scale objects:

1. Select an object(s).

2. Choose Scale & Mirror from the Arrange menu. 

3. Change the horizontal and/or vertical scaling factors to adjust the size of the selected objects.

4. Choose OK.

See also

Mirroring Objects

Resizing Objects



Mirroring Objects

To mirror objects:

1. Select an object(s).

2. Choose Scale & Mirror from the Arrange menu. 

3. Horizontally and/or vertically mirror the selected objects by clicking on the appropriate check box.

4. Choose OK. 

See also

Resizing Objects

Rotating Objects



    

Grouping Objects

A group of objects behaves as a single object. Grouping is useful for editing more than one object at a 
time.

To group objects:

1. Select the objects you want to group.

2. Choose Grouped from the Arrange menu or click the Group button on the Ribbon Bar.

Grouped objects behave like symbols. You can only perform operations such as selecting, moving, etc., 
to the group. To edit a single object in the group, you must ungroup the objects.

To ungroup objects:

1. Select the group.

2. Choose Ungroup from the Arrange menu or disable the Group button on the Ribbon Bar.

See also

Designing a Symbol



 

Breaking Apart Lines

To break apart a line(s):

1. Select the desired line(s).

2 Choose Break Apart from the Arrange menu. The line breaks at each point and disconnects from 
any connected shapes.

To break a line at a point:

1. Select any point of a line other than an end point.

2. Choose Break Apart from the Arrange menu. 

See also

Breaking Apart Symbols

Drawing Lines

Joining Lines



 

Breaking Apart Symbols

Symbols often consist of several grouped objects. 

To break the connections between the components of a symbol:

1. Select the symbol(s) to fragment.

2. Choose Break Apart from the Arrange menu

3. Deselect the selected objects. Now you can select and edit the individual components of the 
symbol.

Note: Break Apart ungroups grouped objects.

See also

Designing a Symbol

Drawing Symbols from a Library

Grouping Objects



 

Joining Lines

To join two separate lines:

1. Select two line ends.

2. Choose Join Lines from the Arrange menu.

Note: The point at which two lines are joined is marked by a hollow rectangle. This is to remind you that, 
although the lines are joined, they are still distinct. A curve cannot span a point marked by a hollow 
rectangle.

Note: Only the endpoint of one line can be joined to the endpoint of another line.

See also

Breaking Apart Lines

Drawing Lines



Creating New Arrows

When designing new arrows:

· Arrows may be created with any combination of symbols, shapes or lines.

· When you draw an arrow, note that the last pixel of a line is not drawn, which can cause arrows to 
appear asymmetrical. See instructions in the CorelFLOWs User's Guide on how to avoid this 
problem.

· Some arrows need to be filled with white so that lines do not show through from underneath the 
arrow. See the CorelFLOWs User's Guide for further information.

· The black parts of an arrow are assigned the color of the attached line. 

To create a new arrow:

1. Draw the new arrow in the drawing window and orient it so that it may be attached to the right end of 
a horizontal line. An arrow may consist of any combination of symbols, shapes or lines.

2. Select the objects to include in the new arrow.

3. Choose Arrows, Save As from the File menu.

4. Name the new arrow in the File Name box. 

To save the new arrow file in a directory other than the current directory, select the desired drive in 
the Drives box and directory from the Directory box.

5. Choose OK. If the arrow palette is full, a message box appears stating that the maximum number of 
arrows has been reached, and the save operation is terminated.

6. A message box appears, stating that you must click the left mouse button on the hot spot of the 
arrow. Click OK.

7. Center the cursor on the desired hot spot and click the left mouse button. 

A file containing the new arrow information is created in the specified arrow directory. The new arrow is 
automatically added to the arrow palette. 

See also

Adding Arrows to the Arrow Palette

Updating Arrows



 

Updating Arrows

To update an arrow:

1. Draw the arrow in the drawing window and orient it so that it may be attached to the right end of a 
horizontal line. An arrow may consist of any combination of shapes and lines.

2. Select the objects to include in the arrow.

3. Choose Arrows, Save As from the File menu.

4. Choose the arrow to update in the File Name list box.

If the arrow to update is not found in the current directory, select the desired drive and directory in the
Drives and Directories boxes.

5. Choose OK.

6. Confirm the save operation by choosing OK.

7. A message box appears, stating that you must click the left mouse button on the hot spot of the 
arrow. Click OK.

8. Move the center of the cursor over the hot spot and click the left mouse button. 

Note: Updating an arrow does not affect existing diagrams which contain the arrow. 

See also

Adding Arrows to the Arrow Palette

Changing Arrows on an Existing Line

Creating New Arrows



 

Adding Arrows to the Arrow Palette

To add an arrow to the arrow palette:

1. Choose Arrows, Open from the File menu.

2. Choose an arrow in the File Name list.

If the desired arrow is not located in the current directory, select the drive in the Drives box and 
directory in the Directories box.

3. Choose OK.

See also

Creating New Arrows

Updating Arrows

Setting Preferences



Basics

Drawing Objects

· Drawing Rectangles

· Drawing Ellipses

· Drawing Polygons

· Drawing Lines

· Drawing Curves

· Entering Text

· Drawing Symbols

Editing Objects

· Selecting Objects

· Moving Objects

· Resizing Objects

· Quick Formatting



Basics Overview

CorelFLOW is an ideal drawing tool for technical and business diagrams. Designed as a flow-charter, 
CorelFLOW is also an illustrator, design tool, organizer, problem solver, and communicator. 

You can use CorelFLOW to create an array of diagrams, charts, and training aids, including the following:

· Flow Charts
· Software Diagrams
· System Diagrams
· Technical Illustrations
· Organizational Charts
· Process Documentation
· Tutorials
· Training materials
CorelFLOW's hierarchical tools let you to build multi-page drawings joined by hypertext parent and child 
links, and open other programs and their files. Using Smart Libraries, you can quickly insert a range of 
symbols with a click of the mouse button. 

Connecting text, lines and objects is a breeze--type text inside a shape or drop text onto a line. 
CorelFLOW also makes moving connected objects easy, automatically redrawing connecting lines when 
you move objects. 

Other useful features include right-mouse-button access to attributes dialog boxes, many standard word-
processing features, and libraries of predefined objects you can add to your diagrams by dragging and 
dropping.



Basics: Drawing Rectangles

To draw a rectangle:
1. Choose the Rectangle tool on the Toolbox.

2. Click and hold down the left mouse button to place the upper left point of the rectangle.

3. Drag the mouse to create the rectangle.

4. Release the left mouse button to complete the operation.

Tip: Draw a square with a left mouse button click and drag the mouse while holding down the CTRL 
key. Draw a rectangle relative to its center by holding down the SHIFT key.



Basics: Drawing Ellipses

To draw an ellipse:
1. Choose the Ellipse tool on the Toolbox.

2. Click and hold down the left mouse button to place the upper left point of the ellipse.

3. Drag the mouse to create the ellipse.

4. Release the left mouse button to complete the operation.

Tip: Draw a circle with a left mouse button click and drag the mouse while holding down the CTRL 
key. Draw an ellipse relative to its center by holding down the SHIFT key.



Basics: Drawing Polygons

To draw a polygon:
1. Choose the Polygon tool on the Toolbox.

2. Click the left mouse button to place the first point of the polygon.

3. Draw the desired polygon by adding points with the left mouse button. You may also add points to
the polygon by pressing the Spacebar on the keyboard.

4. Add the last point using one of the following methods:

· double click the left mouse button.

· click the right mouse button.

A line connects the first and last points, completing the polygon. 



 

Basics: Drawing Lines

To draw a line:
1. Choose the Line tool on the Toolbox.

2. Click the left mouse button to add the first point of the line.

3. Add points by clicking the left mouse button or pressing the Spacebar on the keyboard.

4. End the line using one of the following methods:

· double click the left mouse button.

· click the right mouse button.

Tip: Constrain lines horizontally and vertically by holding down the SHIFT key while drawing the line.



Basics: Drawing Curves

To draw a curve:
1. Choose the Curve tool on the Toolbox.

2. Click the left mouse button to place the first point of the curve.

3. Add control points by clicking the left mouse button or pressing the Spacebar on the keyboard.

4. End the curve using either of the following methods:

· Double click the left mouse button.

· Click the right mouse button.

Tip: Constrain curves horizontally and vertically by holding down the SHIFT key while drawing the 
curve.



 

Basics: Entering Text

To enter text:
1. Click the Text tool on the Toolbox.

2. Click the left mouse button to place the text curosr. If a shape or line is highlighted when the left 
mouse button is clicked, text connects to the highlighted object.

3. Type the text. To enable the Pick tool while the Text tool is active, press the spacebar while 
holding down the Ctrl key.

Tip: You may also place the text cursor using the Pick tool. Double-click an empty space in your 
diagram and start typing. 



Basics: Drawing Symbols

To draw a symbol:
1. Move the cursor over a symbol from a smart library. 

Note:    If a symbol is not defined on the smart library, see Adding Symbols to a Smart Library.

2. Press and hold down the left mouse button on the desired symbol.

3. Drag the symbol to the desired location in the drawing window.

4. Release the left mouse button to complete the operation.



Basics: Selecting Objects

To select a single object:
1. Choose the Pick tool.

2. Point to an object. The object is highlighted.

3. Click the left mouse button.

To select multiple objects:
1. Choose the Pick tool.

2. Point to an object. The object is highlighted.

3. Click the left mouse button.

4. Hold down the SHIFT key. Repeat Steps 2 & 3. Previously selected objects remain selected.

Marquee Selection:
1. Choose the Pick tool.

2. Position the pointer so that it is not over any objects.

3. Press the left mouse button and hold it down.

4. Move the mouse to enclose the desired objects in the dotted rectangle (called a marquee box).

5. Release the left mouse button.

If the SHIFT key is held down while the marquee box is drawn, previously selected objects remain 
selected.



 

Basics: Moving Objects

To move a single object:
1. Choose the Pick tool.

2. Point to the object to move.

3. Press the left mouse button and hold it down.

4. Drag the object to the desired location.

5. Release the left mouse button to end the move.

To move more than one object:
1. Select the objects you want to move (see Basics: Selecting Objects).

2. Point to one of the objects.

3. Press the left mouse button and hold it down.

4. Drag the objects to the desired location.

5. Release the left mouse button to end the move.

To constrain the move:
· Use CTRL + ALT + any Arrow key to move selected objects one grid point. 

· Use the SHIFT key to constrain movements horizontally and vertically.



 

Basics: Resizing Objects

To resize one or more objects:
1. Select the objects to resize. Edit handles appear.

2. Point to the handle you want to move. The cursor changes to crosshairs.

If the handle selected is on the left or right of the object, the object scales horizontally. If the 
handle selected is on the top or bottom of the object, the object scales vertically. If the handle 
selected is on a corner of the object, the object scales both horizontally and vertically. In all cases,
the object retains its aspect ratio and resizes symmetrically.

3. Drag the edit handle with the left mouse button to scale the objects.

4. Release the left mouse button to end resizing.

Note: Lines selected via a left mouse button click have handles drawn at each point. These handles are
used to reshape a line, not to resize a line. To resize a line using the above approach, marquee select the
line.

Constrain the resize:
· To scale an object without maintaining its aspect ratio, hold down the CTRL key and drag a corner

handle. 

· To scale an object relative to one of its sides, hold down the SHIFT key and drag the handle 
opposite the side or corner you want to remain stationary.



 

Basics: Quick Formatting

To change the attributes of an object:

1. Select one or more objects (see Basics: Selecting Objects).

2. Click the right mouse button over a selected object. 

3. The appropriate format dialog box opens. Make the desired changes and choose OK.



CorelFLOW Help Contents
Help topics for CorelFLOW are divided into eight categories represented by the icons below.
To choose a category with the mouse, point to its icon, then click. With the keyboard, press Tab to highlight the category you want, 
then press ENTER. For more information on using Help, choose the Using Help icon or press F1 on the keyboard. To return to this 
screen, click the Contents button at the top of the Help window.

 

 

 

 

 

 







 

Drawing Rectangles 

Objects drawn with the Rectangle tool are given predefined outline and fill default attributes.

To draw a rectangle:

1. Click the Rectangle tool on the Toolbox.

2. Press and hold down the left mouse button to place the upper left point of the rectangle.

3. Drag the mouse to create the rectangle.

4. Release the left mouse button.

5. To enable the Pick tool, click the right mouse button.

By default, rectangles are drawn outwards from the point where you first clicked the rectangle tool. To 
draw them outwards from the center of the rectangle, press the SHIFT key before you click the mouse 
button to draw the rectangle. Hold the SHIFT key down until after you've released the mouse button.

Tip: Draw a square by pressing and dragging the left mouse button while holding down the CTRL key.

See also

Formatting Outline and Fill Defaults

Formatting Symbols



 

Drawing Ellipses

Shapes drawn with the Ellipse tool are given predefined outline and fill default attributes.

To draw an ellipse:

1. Click the Ellipse tool on the Toolbox.

2. Press and hold down the left mouse button to place the upper left point of the ellipse.

3. Drag the mouse to create the ellipse.

4. Release the left mouse button to complete the operation.

5. To enable the Pick tool, click the right mouse button.

Tip: Draw an ellipse relative to the center by pressing and dragging the left mouse button while 
holding down the SHIFT key.

Tip: Draw a circle by pressing and dragging left mouse button while holding down the CTRL key.

See also

Formatting Outline and Fill Defaults

Formatting Symbols



 

Drawing Polygons 

Polygons drawn with the Polygon tool are given predefined outline and fill default attributes.

To draw a polygon:

1. Click the Polygon tool on the Toolbox.

2. Click the left mouse button to place the first point of the polygon.

3. Draw the polygon by adding points with either the left mouse button or the Spacebar on the 
keyboard.

4. Add the last point using either of the following methods:

· Click the right mouse button.

· Double-click the left mouse button.

A line is drawn between the first and last points, completing the polygon.

5. To enable the Pick tool, click the right mouse button.

Each segment of a polygon can be given different attributes. For example, a polygon can contain both 
straight and curved segments, dotted and solid segments, and segments with different colors (refer to 
Formatting Lines).

Tip: Constrain lines horizontally and vertically by holding down the SHIFT key while drawing the 
polygon.

See also

Formatting Outline and Fill Defaults

Formatting Symbols



 

Drawing Lines

Lines drawn with the Line tool are given predefined outline and fill default attributes. The fill 
default is used if the line becomes a polygon.

To draw a line:

1. Choose the Line tool on the Toolbox.

2. Click the left mouse button to place the first point of the line.

3. Add points by either clicking the left mouse button or pressing the Spacebar on the keyboard.

4. End the line using either of the following methods:

· Click the right mouse button.

· Double click the left mouse button.

5. To enable the Pick tool, click the right mouse button.

When you draw a line with more than ten points, every tenth point is marked with a hollow 
rectangle. A curve cannot span a point marked with a hollow rectangle.

Tip: Constrain lines horizontally and vertically by holding down the SHIFT key while drawing the line.

Tip: When drawing a line, create a polygon by ending the line at the same point where it began.

See also

Formatting Lines

Formatting Outline and Fill Defaults

Joining Lines



    

Drawing Curves

Lines and shapes drawn with the Curve tool are given predefined outline and fill default 
attributes. The fill default is used if the curve becomes a polygon.

To draw a curve:

1. Choose the Curve tool on the Toolbox.

2. Click the left mouse button to place the first control points of the curve.

3. Add control points by clicking the left mouse button or by pressing the Spacebar on the keyboard.

4. End the curve using either of the following methods:

· Click the right mouse button.

· Double click the left mouse button.

5. To enable the Pick tool, click the right mouse button.

If you're drawing a curve with more than ten control points, note that every tenth control 
point is marked with a hollow rectangle. A curve cannot span a point marked with a hollow 
rectangle. Although CorelFLOW allows you to create curves with several control points, you 
should generally limit the number of points to five or fewer.

Tip: Constrain curves horizontally and vertically by holding down the SHIFT key while drawing the 
curve.

Tip: When drawing a curve, create a polygon by ending the curve at the same point where it began.

See also

Formatting Lines

Formatting Outline and Fill Defaults

Joining Lines



 

Entering Text

To enter text:

1. Choose the Text tool on the Toolbox.

2. Click the left mouse button to place the text cursor. If a shape or line is highlighted when the
text cursor is placed, text connects to the highlighted shape or line. 

3. Type the text.    

4. To enable the Pick tool, click the right mouse button or press Ctrl + Spacebar.

Tip: You may also enter text using the Pick tool. Double-click an empty space in your diagram to place
the text cursor and start typing. 

Note: Text entered with the Text tool is given predefined text default attributes.

Note: Background and text colors are not displayed while text is being edited.

See also

Editing Text Strings

Formatting Text

Formatting Text Defaults



 

Adding Symbols from a Smart Library

To add a symbol from a smart library:

1. Press and hold down the left mouse button on a symbol from a smart library. If there are no 
symbols in a smart library, see Adding Symbols to a Smart Library. 

2. Drag the symbol to the desired location in the drawing window.

3. Release the left mouse button to drop the symbol.

To continuously add a symbol from a smart library:

1. Click the left mouse button on a symbol from a smart library.    

2. Click the left mouse button in the drawing window to place the symbol.

3. Continue to place the symbol with left mouse button clicks until another tool is selected. To enable
the Pick tool, click the right mouse button.

See also

Formatting Symbols

Smart Library Overview



 

Drawing Lines from a Smart Library

To draw a line from a smart library:

1. Press and hold down the left mouse button on a line style from a smart library. If there are no line 
styles in a smart library, see Adding Line Styles to a Smart Library.

2. Place the first point of the line by dragging the mouse to the desired location in the drawing 
window and releasing the left mouse button.

3. Add points by clicking the left mouse button or by pressing the Spacebar on the keyboard.

4. End the line using either of the following methods:

· Click the right mouse button.

· Double-click the left mouse button.

The line is drawn with the attributes of the chosen line style.

When you draw a line with more than ten points, every tenth point is marked with a hollow 
rectangle. A curve cannot span a point marked by a hollow rectangle.

Tip: Constrain lines horizontally and vertically by holding down the SHIFT key while drawing the line.

Tip: When drawing a line, create a polygon by ending the line at the same point where it began.

Tip: You may continuously draw lines from a smart library by choosing a line style as you would the 
Line tool (instead of drag and drop). This enables you to draw multiple lines without changing the 
mouse mode.

Note: If drawing a line with more than ten points, note that every tenth point is marked with
a hollow rectangle. A curve cannot span a point marked by a hollow rectangle.

See also

Drawing Lines

Formatting Lines

Smart Library Overview



 

Entering Text from a Smart Library

To enter text from a smart library:

1. Press and hold down the left mouse button on a text style from a smart library. If there are no text 
styles located in a smart library, see Adding Text Styles to a Smart Library.

2. Place the text cursor by releasing the left mouse button. If a shape or line is highlighted when the 
left mouse button is released, text connects to the shape or line.

3. Type the text. To enable the Pick tool, press the spacebar while holding down the Ctrl key.

The text is entered with the attributes of the chosen text style.

Tip: You may also enter text using the Pick tool. Double-click an empty space in your diagram to place
the text cursor and start typing. 

Tip: You can enter text from a smart library by choosing a text style as you would the Text tool (instead
of dragging and dropping). This enables you to enter multiple text objects without changing the 
mouse mode.

Note: Background and text colors are not displayed while text is being edited.

See also

Formatting Text

Smart Library Overview



 

Connecting Symbols to Shapes

To connect symbols to shapes while drawing:

1. Click the left mouse button on a symbol from a smart library.

2. Point to a shape in your diagram. The shape is highlighted.

3. Click and drag the symbol toward the location where you want the symbol to be. A line with the 
attributes of the last line drawn connects the symbol to the shape.

4. Add points to the line by clicking the right mouse button or by pressing the Spacebar on the 
keyboard. 

5. Place the symbol in the desired location by releasing the left mouse button.

See also

Formatting Symbols

Setting Preferences



    

Connecting Lines to Shapes

To connect the end of a line to a shape:

1. Begin drawing a line (see Drawing Lines). Place all points except the last.

2. Move the pointer over a shape. The shape is highlighted.

3. Click the right mouse button to end the line. The line is connected to the shape relative to the 
shape center. The connected line is only drawn to the boundary of the shape.

Note: The Glue and Center Lines options must be enabled in the Preferences dialog box for the 
previous steps to perform accurately (see Setting Preferences).These options are enabled by 
default.

Connecting lines to off-center points:

Connect a line to an off-center point of a shape by holding down the CTRL key while you make the 
connection. If you want all lines connecting to off-center points, disable Center Lines in the Preferences 
dialog box.

To connect a line to a point outside of a shape:

1. Click the Line tool on the Toolbox or choose a line style from a smart library.

2. Point to a shape in your diagram.

3. Hold down the CTRL key. This freezes the highlighting when you move the mouse.

4. Point to where you want the line to begin and click the left mouse button.

5. Release the CTRL key and finish drawing the line. 

Line Connection Rules

· Lines may not be connected to other lines or text objects.

· Only the start and end points of a line may be connected to a shape.

· When attaching the end of a line to a symbol, the line is actually connected to the lower-most 
shape under the pointer. This rule is important when designing new symbols (see Designing a 
Symbol).

See also

Formatting Lines

Setting Preferences



    

Connecting Two Symbols on the Page

Using the Line Tool, you can connect two symbols that are already on the page in your 
diagram.

To connect two symbols on the page:

1. Click the Line Tool in the Toolbox.

2. Click the first symbol.

3. Move the mouse pointer over the second symbol so that the symbol becomes 
highlighted and the cursor changes to the connection cursor.

4. Double-click to end the line. The two symbols are connected.



 

Connecting Text to Shapes and Lines

To connect text to the center of a shape:

1. Choose the Text tool on the Toolbox or a text style from a smart library

2. Point to the shape in which to connect the text. It becomes highlighted.

3. Click the left mouse button. The text cursor displays in the center of the shape.

4. Type the text string. As you type, the text is centered within the shape. To enable the Pick tool 
while the Text tool is active, hold down the Ctrl key and press the spacebar.

Note: Glue and Center Text must be enabled in the Preferences dialog box for the previous steps to 
perform accurately (see Setting Preferences).

To connect text to a line:

1. Choose the Text tool on the Toolbox.

2. Click a line at the point where you want the text to connect. The text cursor displays 
where you clicked.

3. Type the text string. As you type, the text is centered at the cursor point.

Note: Glue and Center Text must be enabled in the Preferences dialog box for the previous steps to 
perform accurately.

To connect text to an off-center point of a shape or line:

Connect text to off-center points by pressing the CTRL key while making the connection. To 
have all text connecting to off-center points, disable Center Text in the Preferences dialog 
box (see Setting Preferences). 

To connect text outside of a shape or off a line:

1. Point to a line or shape so that it is highlighted.

2. Press and hold down the CTRL key. This freezes the highlight.

3. Click the left mouse button at the location where you want to enter connected text. The text cursor
displays.

4. Release the CTRL key.

5. Type the text string.

Notes for Connecting Text

· Text may be connected to shapes or lines, but not to other text objects.



· When attaching text to a symbol, text actually connects to a shape or line within the symbol. If 
more than one object is under the pointer when connecting, text connects to the top-most shape 
or line. This rule is important when designing new symbols (see Designing a Symbol).

See also

Formatting Text

Setting Preferences



    

Connection Feedback

Whenever it is possible to connect a new symbol, line, or text to an object in your diagram, CorelFLOW 
highlights the object by redrawing it with a gray pen. Generally, the highlighted object is the one under the
pointer. If    the pointer is over more than one object, the object with the highest priority is highlighted 
under the following scheme:

1. Lines have priority over shapes, and text has priority over lines.

2. Smaller shapes have priority over larger shapes.

3. An object, B, added after another object, A, has priority over A.

See also

Setting Preferences



    

Selecting a Single Object

To select a single object:

1. Choose the Pick tool.

2. Point to an object. The object is highlighted.

3. Click the left mouse button.

To marquee select a single object:

1. Choose the Pick tool.

2. Position the pointer so that it is not over any objects.

3. Press the left mouse button and hold it down.

4. Move the mouse to enclose the desired object in the dotted rectangle (called a "marquee box").

5. Release the left mouse button.

See also

Deselecting Objects
Selecting Multiple Objects
Selecting Objects by Type
Selecting Objects with Edge Selection



    

Selecting Multiple Objects

To select multiple objects:

1. Choose the Pick tool.

2. Point and click on an object. Eight sizing handles appear around the object.

3. While holding down the SHIFT key, click on the other objects that you want to select. Sizing 
handles will appear around each object as it is selected. 

Note: If you click on a previously-selected object, it will become deselected.

To marquee select multiple objects:

1. Choose the Pick tool.

2. Position the pointer above and to the left of the objects that you want to select.

3. Press and hold the left mouse button.

4. Drag the mouse diagonally towards the right until the desired objects are enclosed in a dotted 
rectangle (called a marquee box).

5. Release the left mouse button. Sizing handles appear around the objects.

To select all objects in a diagram:

Choose Select, All from the Edit menu.

See also

Deselecting Objects
Selecting a Single Object
Selecting Objects by Type
Selecting Objects with Edge Selection



    

Selecting Objects by Type

To select all the shapes and symbols in a diagram, choose Select, Symbols from the Edit menu. To select
all of the lines in a diagram, choose Select, Lines. To select all of the text in a diagram choose Select, 
Text.

See also

Deselecting Objects
Selecting a Single Object
Selecting Multiple Objects
Selecting Objects with Edge Selection



 

Selecting Objects with Edge Selection

Generally, shapes are highlighted whenever the pointer is over the inside of the shape.

When the Edge Selection option is enabled (see Setting Preferences), a shape will only be highlighted 
when the pointer is over the edge of the shape.

Edge Selection is useful when drawing complex diagrams or when drawing diagrams that contain shapes
within other shapes.

See also

Deselecting Objects
Selecting a Single Object
Selecting Objects by Type
Selecting Multiple Objects



    

Deselecting Objects

To deselect multiple objects or marquee-selected objects:

Using the Pick tool, click the left mouse button on any empty part of the drawing window.

To deselect a single object in a group of selected objects:

Using the Pick tool, click on the object while holding down the SHIFT key. 

See also

Selecting a Single Object
Selecting Multiple Objects
Selecting Objects by Type
Selecting Objects with Edge Selection



Moving Objects

To move a single object:

1. Choose the Pick tool.

2. Point to the object you want to move.

3. Press the left mouse button and hold it down.

4. Drag the object to the desired location.

5. Release the left mouse button to drop the object.

To move multiple objects:

1. Marquee select the objects to move.

2. Point to one of the objects.

3. Press the left mouse button and hold it down.

4. Drag the objects to the desired location.

5. Release the left mouse button to drop the objects.

To constrain the movement:

· Use CTRL + ALT + any Arrow key to move selected objects one grid point. 

· Use the SHIFT key to constrain movements horizontally and vertically.

See also

Selecting a Single Object
Selecting Multiple Objects



Resizing Objects

To resize one or more objects:

1. Select the object(s) to resize. Sizing handles appear.

2. Point to the handle you want to move.

If the handle selected is on the left or right of the object, the object scales horizontally. If the 
handle selected is on the top or bottom of the object, the object scales vertically. If the handle 
selected is on a corner of the object, the object scales horizontally and vertically. In all of these 
cases, the object scales symmetrically.

3. Drag the handle with the left mouse button to scale the objects.

4. Release the left mouse button.

Lines you select using a left mouse button click have handles drawn at each point. These handles are 
used to reshape a line; they cannot be used to scale a line. To scale a line using the above method, 
marquee select the line.

To Constrain the resizing of one or more objects:

· To scale an object without symmetrical constraints, hold down the CTRL key and drag a corner 
handle. 

· To scale an object relative to one of its sides, hold down the SHIFT key and drag the handle 
opposite the side or corner that you want to remain stationary.

See also

Scaling Objects
Selecting a Single Object
Selecting Multiple Objects



Undoing Operations

To undo the last operation:

Choose Undo from the Edit menu (Ctrl+Z). Redo the operation by choosing Undo again.



Cutting Objects

To cut objects to the clipboard:

1. Select one or more objects.

2. Click the Cut button on the Ribbon Bar, or choose Cut from the Edit menu (Ctrl+X). All selected 
objects are deleted and moved to the clipboard. Connected objects are also deleted.

See also

Copying Objects
Cutting, Copying, and Pasting
Deleting Objects
Pasting Objects



Copying Objects
To copy objects to the clipboard:

1. Select one or more objects.

2. Click the Copy button on the Ribbon Bar, or choose Copy from the Edit menu (Ctrl+C). All 
selected objects remain in the drawing window, but are copied to the clipboard.

See also

Cutting, Copying, and Pasting
Cutting Objects
Duplicating Objects
Pasting Objects



Pasting Objects

To paste objects from the clipboard into your diagram:

Click the Paste button on the Ribbon Bar, or choose Paste from the Edit menu (Ctrl+V). Objects from the 
clipboard will appear in the center of the current view.

To paste objects to a specific point in your diagram:

1. With the Pick tool, double click in an empty space in your diagram. This places the cursor.

2. Choose Paste from the Edit menu. Objects are pasted from the clipboard and centered on the 
point where you double clicked.

To paste objects using a different format:

1. Choose Paste Special from the Edit menu. The Paste Special dialog box opens.

2. Choose the desired format from the As list box.

3. If desired, choose Display as icon to display the clipboard objects as an icon in your diagram.

4. Choose Paste.

5. Choose OK. The objects on the clipboard are placed in the center of the current view.

See also

Cutting, Copying, and Pasting
Copying Objects
Cutting Objects
Lining Objects as a Client using the Clipboard



Duplicating Objects

To duplicate objects:

1. Select one or more objects.

2. Choose Duplicate from the Edit menu (Ctrl+D). A copy of the selected objects is created and 
positioned one grid point above and to the right of the original objects.

See also

Cut, Copy, and Paste to Exchange Data with other Applications
Copying Objects
Pasting Objects



    

Deleting Objects

To delete objects:

1. Select the objects you want deleted.

2. Choose Delete from the Edit menu or press the DELETE key.

See also

Cutting Objects



Moving Points of a Line

If a line is not part of a symbol or a group (see Grouping Objects), the individual points of the line can be 
moved. 

To move a single point of a line:

1. Choose the Pick tool.

2. Position the pointer over a point on a line.

3. Press and hold down the left mouse button. If the line is connected to a shape at the selected 
point, the line will disconnect.

4. Drag the point to the desired location.

5. Release the left mouse button. If a shape is highlighted when the move ends, the line will 
connect to the shape.

To move multiple points of a line:

1. Hold down the Shift key and click on the points you want to move.

2. Point to either one of the selected points or to a selected line segment.

3. Press the left mouse button and hold it down. 

4. Drag the points to the desired location. 

5. Release the left mouse button.

To constrain the movement:

· Move selected points one grid point by using the CTRL + Alt + Arrow keys.

· Hold down the SHIFT key to restrict movements horizontally and vertically.

Note: If you want to deselect all points on a line, hold down the shift key and click anywhere in the 
diagram.

See also

Adding and Deleting Points of a Line
Drawing Lines
Moving Objects



    

Adding and Deleting Points of a Line

To add a point to a line:

1. Choose the Pick tool.

2. Move the pointer over a point of a line.

3. Click the right mouse button. 

4. Choose Add Point from the pop-up menu. A new point is added before the existing point on the 
line.

To add a series of points to a line:

1. Click and hold the left mouse button on the desired point.

2. Move the pointer to where you want the next point to be (see Moving Points of a Line).

3. Click the right mouse button to add the point or press the Spacebar on the keyboard.

4. To add additional points, continue to move the pointer to different locations and click the right 
mouse button or press the Spacebar.

5. Release the left mouse button when you have finished adding points to the line. The last point is 
placed where you release the left mouse button.

To delete a point from a line:

1. Choose the Pick tool.

2. Move the cursor over a point on a line. The point is highlighted.

3. Choose one of the following methods to delete the point:

· Click the left mouse button to select the point and either press Delete on the keyboard or 
choose Delete from the Edit menu.

· Click the right mouse button on the point and choose Delete Point from the pop-up menu.

See also

Drawing Lines
Moving Points of a Line



    

Changing Line Connections

To change a line connection:

1. Choose the Pick tool.

2. Point to the desired end point of a line to change. The point is highlighted.

3. Press the left mouse button and hold it down. If the point is attached to a shape, it will 
disconnect.

4. Drag the end point to the desired location.

5. Release the left mouse button. If a shape is highlighted when the button is released, the line will 
connect to the shape.

See also

Connecting Lines to Shapes
Connecting Shapes to Shapes
Drawing Lines
Setting Preferences



Shaping Curves

The shape of a curve can be modified by manipulating its control polygon.

To shape a curve:

1. Choose the Pick tool.

2. Click the left mouse button on a curve (it is not possible to edit the control polygon of a curve 
which has been marquee selected). The control polygon appears in a blue dotted line.

3. Point to a control point.

4. Press the left mouse button and hold it down. 

5. Drag the control point to adjust the shape of the curve. 

6. Release the left mouse button to end the operation.

If the point being moved is an end point and a shape is highlighted when the move is ended, the curve 
end will connect to the highlighted shape.

See also

Drawing Curves
Adding and Deleting Points of a Line
Moving Points of a Line



Editing Text Strings

To edit a text string:

1. Choose the Text tool or Pick tool in the Toolbox.

2. Select the text object you want to edit. A text cursor is placed in the text where you clicked. If a 
shape is selected which has a text string connected to it, a text cursor will appear in the 
dependent text string.

3. Edit the text using keyboard and mouse commands (see Editing Text with keyboard and Mouse 
Commands). To enable the Pick tool when the Text tool is active, hold down the Ctrl key and 
press the spacebar.

4. Click the left mouse button outside of the text object to end the text edit. 

Note: If you chose the Pick tool to edit the text string, press any key on the keyboard to begin text 
editing (except the DELETE key, which will delete the text object).

See also

Check Spelling
Entering Text
Editing Text with keyboard and Mouse Commands



Editing Text with keyboard and Mouse Commands

Keyboard Commands
Cursor Movement
Right/Left Arrow Right or left one character.
Ctrl-Right/Left Arrow Right or left one word.
Up/Down Arrow Up or down one line.
Home Beginning of a line.
Ctrl+Home Beginning of text object.
End End of a line.
Ctrl+End End of text object.

Text Selection:
Shift+Right/Left Arrow Advance or reduce selected text by one character.
Shift+Ctrl+Left Arrow To the previous word.
Shift+Ctrl+Right Arrow To the next word.
Shift+Up/Down Arrow Up or down one line of text. 
Shift+Home To the beginning of a line.
Shift+Ctrl+Home To the beginning of the text object.
Shift+End To the end of a line.
Shift+Ctrl+End To the end of the text object.

Mouse Commands

To position the text cursor using the mouse, click the left mouse button on the point where you want the 
text cursor to be located.

To select a string of characters, you can use the SHIFT key or the mouse.

To select characters using the SHIFT key:
1. Place the text cursor at the start of the string you want to select.

2. Move the pointer so that it points to the end of the string you want to select.

3. While holding down the SHIFT key, click the left mouse button.

To select characters using the mouse:
1. Position the cursor at the start of the string you want to select.

2. Press the left mouse button and hold it down.

3. Move the cursor to the end of the string.

4. Release the left mouse button.

Use the above method to advance or reduce selected text one character at a time. If, however, you 
double click the left mouse button and hold it down, the selected text will advance or reduce one word at 
a time.

See also

Check Spelling
Editing Text Strings
Entering Text





Checking Spelling

To check the spelling of a text object:

1. Select a text object to check the spelling of selected text only. If nothing is selected, the entire 
diagram will be checked for spelling errors.

2. Choose Spell Check from the Edit menu or click the Spell Check button on the Ribbon Bar.

3. Choose Begin Check.

4. If a spelling error is found, choose a new word from the Change To list box or type the new word 
in the entry box.

5. Click the Change button. The word is changed and the spell check continues.

To check the spelling of a word:

1. Choose Check Spelling from the Edit menu or click the Spell Check button on the Ribbon Bar.

2. Type a word in the Unknown Word box.

3. Choose Begin Check.

4. If the word is misspelled, choose a new word from the Change To list box or type a new word in 
the entry box.

5. Click the Change button. The word is changed and the spell check is complete.

Using a personalized dictionary:

1. To create a personalized dictionary, type the name in the Dictionary entry box and choose 
Create.

2. To add the current word to a personal dictionary, choose Add Word. The word is added to the 
dictionary you created.

See also

Editing Text Strings
Editing Text with keyboard and Mouse Commands
Entering Text



Changing Text Connections

To connect an existing text object to a shape or line:

1. Move the text over the object. The object is highlighted.

2. To connect the text to an off-center point or to a point away from the object:

· Press the CTRL key.

· Move the text to any location in the diagram. The highlighted object remains highlighted. 

3. Release the left mouse button. The text is connected to the highlighted object.

To disconnect a text object from a shape or line:

1. Choose the Pick tool.

2. Point to a text object that is connected to a shape or line.

3. Press and hold down the left mouse button.

4. Drag the mouse. If the text is connected to an object, it will disconnect.

5. Release the left mouse button to end the move.

See also

Connecting Text to Shapes and Lines
Moving Objects
Setting Preferences



Creating a New Diagram

To create a new diagram:

1. Choose New from the File menu or click  on the Ribbon Bar.

You are prompted to save any existing work. The default name for a new diagram is "untitled.cfl".

See also

Creating a New Library

Creating a Project

Opening a Diagram

Saving a Diagram



Opening a Diagram

To open a diagram:

1. Choose Open from the File menu or click  on the Ribbon Bar.    

2. Choose a file from the File Name list.
If the file you want is not in the current directory, select a drive from the Drives box and directory 

from the Directories box.
3. Choose OK. When the file opens, it appears at the view used when it was last saved. See View 
Diagrams to list topics on viewing a diagram.

Tip: You can open a file by double-clicking the filename in the File Name list.

To use file recall:

Use file recall to quickly open recently-edited diagrams. Choose a file name from the list of four located at
the bottom of the File menu.

Note: When you first open the Open dialog box, CorelFLOW defaults to the Working Directory specified 
in the Program Item Properties dialog box in the Windows Program Manager.

See also

Importing Data

Opening a Project

Opening a Library

Saving a Diagram



Saving a Diagram

To save the current diagram, choose Save from the File menu or click  on the Ribbon Bar. 

To save the current diagram under a new name:
1. Choose Save As from the File menu.

2. Name the new file in the File Name box. This name must adhere to DOS file naming conventions.

To save the file in a location other than the current directory, choose the drive in the Drives box 
and directory in the Directories box.

3. Choose OK.

To save selected objects only:

1. Select the portion of the diagram that you want to save.

2. Choose Save As from the File menu. 

3. Check the Selected Only box.

4. Name the new file and directory in which to save the selected objects and choose OK.

See also

Exporting Data



Setting up the Page 

1. Choose Page Setup from the File menu to set the following options:

Page Size:
Choose a preset page size from the drop-down list box . For example, if you choose Letter, the paper 
width and height is automatically set to 8.5" and 11.0" inches. You can also enter your own values for the 
width and height in the numeric entry boxes.

Note: The maximum paper size is 47 by 47".

If you choose Business Card as your Page Size, see Creating Business Cards.

Page Margins:
Choose measurements for left, right, top, and bottom margins in the Margins box. The page boundary 
adjusts according to the current margins.

Page Orientation:
Check the Landscape box to give the diagram a landscape orientation (an 11 x 8.5" page boundary). 
Check Portrait for a portrait orientation (an 8.5 x 11" page boundary).

Units:
Set the unit of measurement for the Page Setup dialog box by choosing either inches or centimeters.

Number of Pages:
Choose the number of vertical and horizontal pages in the Vertical and Horizontal boxes. This tiles 
multiple pages in a diagram. The allowed number of pages varies depending on the current page size.

Note: All Page Setup options are saved in each diagram file.

See also

Printing Diagrams

Shifting and Scaling Printed Diagrams



Creating Business Cards 

To create business cards:

1. Choose Page Setup from the File Menu.

2. Choose either Business Card 1, 2, or 3 in the Page Size list box. The page width and height is 
set to the size of one individual card. 

3. If the predefined settings for width and height are not what you want, enter the measurements in 
the Width and Height boxes. (Use this method to create cards of any type, for example, greeting 
cards.)

4. Choose OK.

5. Draw symbols, lines, and text to design the business card.

6. To print the cards, choose Print from the File menu. Choose Clone in the Range box of the Print 
dialog box. A display of how many cards will fit on the printed page is displayed. CorelFLOW fits 
as many cards as possible given the printer paper size and margin settings of the printer. For 
example, if your page size is 3.5 by 2", paper size 8.5 by 14" and your printer can print to the very
edge of the paper, the card is placed twice horizontally and seven times vertically when printed.

Notes: Setting the Page Size smaller than the printer paper size sets all margins in the Page Setup 
dialog box to zero. All Page Setup options are saved in each diagram file.

See also

Page Setup

Printing Diagrams



Setting Preferences

Choosing Preferences from the File menu opens the Preferences dialog box, which allows you to specify 
some CorelFLOW operating options. You enable an option in the Preferences dialog box by clicking the 
box beside the option so that a check mark appears. You disable an option by clicking the box so that the 
check mark disappears 

Choose Preferences from the File menu to alter the following options:

Center Lines:
Generally, lines are connected to the center of shapes. Deselect the Center Lines box to have lines 
connect to points other than the center. 

Center Text:
Generally, text is connected to the center of shapes. Deselect the Center Text box to have text connect to
points other than the center. 

Glue:
When the Glue option is deselected, you cannot connect any lines, symbols, shapes, text, or objects to 
each other. You may want to deselect this option when you're drawing an object and you don't want to 
inadvertently connect anything. 

Edge Selection:
By default, shapes are highlighted whenever the cursor is over the inside of the shape. If you enable the 
Edge Selection option, shapes are highlighted whenever the pointer is over the edge of a shape.

Enabling Edge Selection is useful when you're drawing complex diagrams or objects inside of shapes.

Auto-Panning:
When Auto-Panning is enabled, the drawing window scrolls when you drag objects beyond its edges. 
When it's disabled, you can't drag an object beyond the edges of the drawing window. 

View Options:
Keep the Ribbon Bar , Text Ribbon, Color Palette, and/or Status Line hidden or in view by enabling or 
disabling the appropriate option. Show or hide the Pop-Up Help by enabling or disabling the Pop-Up Help
option.

Arrow Directory:
At program startup, all arrows in the directory selected here are copied into the Arrow Palette . To change
the arrow directory, enter a new directory in the Arrow Directory box or click the Browse button to find a 
new one.

Note: All preference options are stored in the CFLOW20.INI file and are read at program startup.

See also

Adding Arrows to the Arrow Palette

Connecting Shapes to Shapes



Connecting Lines to Shapes

Connecting Text to Shapes and Lines



Printing Diagrams 

To print a diagram:

1. Choose Print from the File menu.

2. Specify any print options in the Print dialog box.

3. Choose OK. 

Tip: Click  on the Ribbon Bar to bypass the Print dialog box and immediately begin printing.

See also

Fitting Diagrams to the Printed Page

Setting up the Printer

Printing Selected Pages and Multiple Copies

Printing Projects

Printing to an Encapsulated Postscript (EPS) File

Shifting and Scaling Printed Diagrams



Setting up the Printer 

To select a printer:

1. Choose Print from the File menu.

2. Choose Printers.

3. Highlight a printer in the Printers box and choose OK. 

To specify the printer settings:

1. Choose Print from the File menu.

2. Click the Setup button. The printer settings and controls vary from printer to printer, but typically 
you are able to set the printer page source, size and orientation.

Note: CorelFLOW does not automatically set the printer page size; you must set it. Any changes you 
make in the printer driver dialog boxes affect the printer environment for all Windows applications.

See also

Setting up the Page

Printing Diagrams

Printing to an Encapsulated Postscript (EPS) File



Shifting and Scaling Printed Diagrams
To shift a printed diagram:

1. Choose Print from the File menu.

2. Shift a diagram up, down, right or left on the printed page using the Horizontal and Vertical 
settings in the Offset box. The range is between -47.00 (inches) and 47.00 (inches). A positive 
horizontal value shifts the diagram to the right, and a positive vertical value shifts the diagram up.
Shift values may be specified to a maximum of .01" resolution.

To scale a printed diagram:

1. Choose Print from the File menu.

2. Scale output relative to the upper left corner of the page using the Width and Height values in the
Scale box. The valid range is .1 to 10.00 (inches). These values may be specified to a maximum 
of .01" resolution. 

3. Scale the Pen value up to 10 points in the Scale box. For example, if the Pen Scale value is 2, 
lines print at twice their thickness.

See also

Fitting Diagrams to the Printed Page

Printing Diagrams



Fitting Diagrams to the Printed Page

To scale a diagram to fit on a page:

1. Choose Print from the File menu.

2. Check the Fit to Page box. This expands or compresses a diagram to fit on a single printed page.
For example, if the page size is set to 8.5 x 11" but your diagram extends beyond the page 
boundary, choosing Fit to Page scales the printed output to fit on an 8.5 x 11" sheet of paper.

See also

Printing Diagrams

Shifting and Scaling Printed Diagrams



Printing Selected Pages and Multiple Copies

To print selected pages and multiple copies:

1. Choose Print from the File menu.

2. Increase the number of copies to print by typing a value in the Copies box (maximum of 100 
copies).

3. Use the Range box to determine which pages get printed. Choose File to print all pages in the 
diagram. Choose Pages to specify which pages get printed by clicking the left mouse button over
the pages you want to print. Pages drawn black are printed. Pages drawn white are not printed.

See also

Creating Business Cards

Printing Diagrams

Printing Projects



Printing Projects 

To print all diagrams in a project:

1. Choose Print from the File menu. 

2. In the Range box, choose Project.

3. Choose OK. All diagrams located within the current project are printed.

See also

Creating Business Cards

Printing Selected Pages and Multiple Copies

Printing Diagrams



Cloning Diagrams on the Printed Page 

To clone diagrams on the printed page:

1. Choose Print from the File menu. 

2. In the Range box, choose Clone. This places your diagram on the printed page as many times as
it will fit within the printer paper size and margins. The Range box displays the number of times 
the diagram will be printed . For example, if your page size is 3.5 by 2", paper size 8.5 by 14" and
the printer can print to the very edge of the page, the card is placed twice horizontally and seven 
times vertically when printed.

3. Choose OK. 

See also

Creating Business Cards

Printing Selected Pages and Multiple Copies

Printing Diagrams



Printing to an Encapsulated Postscript (EPS) File

The Windows postscript printer driver allows printing to an EPS file.

To print to an EPS file:

1. Choose Print from the File menu.

2. Click the Setup button.

3. In the Setup dialog box, click the Options button.

4. In the Print To section of the Options dialog box, click Encapsulated PostScript File and enter a 
name for the file.

5. Choose OK.

Note: When printing to an EPS file format, you are restricted to the page sizes supported by the printer 
driver. For example if your diagram is 8.5 x 5.5", and your printer driver only supports pages 8.5 x 11" and
larger, the page will have a 5.5" white space at the bottom when imported into a word processor.

See also 

Printing Diagrams



Format Overview

CorelFLOW's format commands let you change the attributes of shapes, symbols, lines, curves, and text 
in your diagram. You can also change the attributes of symbols, line styles, and text styles in a smart 
library. 

CorelFLOWs Quick Formatting option lets you quickly format objects. When you click the right mouse 
button on an object, the appropriate Attributes dialog box opens, where you can quickly make formatting 
changes.

You can also make formatting changes using the Outline and Fill Tools flyout menus. 

See also

Applying Styles to Objects in a Diagram

Formatting Lines

Formatting Shapes and Symbols

Formatting Text

Quick Formatting



Formatting Shapes and Symbols

To format shapes or symbols using the Toolbox:

1. Select the shapes or symbols to format.

2. Click the Outline tool to change the outline format:

· Click  for a hidden outline with a width of zero points.

· Click  for a hairline outline with a width of .2 points.
· Click  or 

 for dashed or dotted outlines.
· Choose from 5 other outline widths: width 1, 2, 3, 4 and 5 points.

3. Click the Fill tool to change the fill format:

· Click  for no fill.

· Click  for a solid fill.
· Choose from 6 patterns to fill the symbol: horizontal, vertical, forward diagonal, crosshatch, 
backward diagonal, and diagonal crosshatch fills.

To color shapes and symbols using the Color Palette:

1. Select the shapes or symbols to color.

2. Click the left mouse button on the Color Palette to choose a fill color.

3. Click the right mouse button on the Color Palette to choose an outline color.

4. Click  with the left mouse button to remove a fill.

To format shapes and symbols using the Symbol Attributes dialog box:

1. Click the right mouse button on a shape or symbol.

or

Select the shapes or symbols to change and choose Symbol from the Format menu.

2. Change the attributes of the selected objects:

Pen

Choose a solid, dashed, or dotted pen. Set the pen width in .1-point increments. Choose the Pen 
Color button and click the left mouse button to choose a color.

Fill

Choose no fill (marked with an 'X'), solid, or patterned fill type. Choose the Fill Color button and 
click the left mouse button to choose a color.

3. Choose OK.



When symbol attributes change, all applicable objects in the symbol are affected by the change. For 
example, if a symbol contains two shapes (one blue and one green), setting the fill color of one shape to 
black changes the fill color of both shapes to black.

See also

Applying Styles to Objects in a Diagram

Drawing Symbols from a Smart Library

Quick Formatting



Formatting Lines

To format lines using the Toolbox:

1. Select the lines to format.

2. Click the Outline tool to change the outline format:

· Click  for a hidden outline with a width of zero points.

· Click  for a hairline outline with a width of .2 points.

· Click  or 

 for dashed or dotted outlines.
· Choose from 5 other outline widths: width 1, 2, 3, 4 and 5 points.

To color lines using the Color Palette:

1. Select the lines to color.

2. Click the right mouse button on the Color Palette to choose an outline color.

To format lines using the Line Attributes dialog box:

1. Click the right mouse button on a line.

or

Select one or more lines and choose Line from the Format menu. 

2. Change the attributes of the line:

Pen

Choose a solid, dashed, or dotted pen. Set the pen width in .1-point increments. Choose the Pen 
Color button and click the left mouse button to choose a color.

Line Type

Choose a straight or curved line type.

Arrows

Choose the Start Arrow button and click the left mouse button to choose an arrow. Choose the 
End Arrow button to choose an arrow for the end of a line.

3. Choose OK. 

See also

Applying Styles to Objects in a Diagram

Changing Arrows

Drawing Lines

Quick Formatting





Changing Arrows

To change a line arrow:

1. Select the end points and/or start points of one or more lines.

2. Open the Arrow dialog box using one of the following methods:

· Click the right mouse button on a selected point and choose Arrow from the pop-up menu.

· Click the Arrow button on the Ribbon Bar.

· Choose Arrow from the Format menu.

3. Choose an arrow.

Note: The black parts of an arrow are assigned the color of the line to which they are attached. 

See also

Creating New Arrows

Drawing Lines

Formatting Lines



Formatting Text

To format text using the Text Ribbon Bar:

1. Select one or more text objects.

2. Change the format using the Text Ribbon Bar:

Font Name: Choose a font name from the list or type the font name in the font text field.

Font Size: Choose a font size from the list or type the size in the size text field.

Style: Click  to choose bold. Click 
 to choose italic. Click 
 to choose underline.

Justification: Click  for default justification. The default justification is center-justified for 
connected text and left-justified for unconnected text. Click 

 for left justification, 
 for center justification and 
 for right justification.

To color text using the Color Palette:

1. Select the text objects to color. Parts of text objects may not be given different text or background
colors.

2. Click the left mouse button on the Color Palette to choose a text color.

3. Click the right mouse button on the Color Palette to choose a text background color.

To format text using the Text Attributes dialog box:

1. Point to a text object and click the right mouse button.

or

Select one or more text objects and choose Text from the Format menu.

2. Change the attributes of the selected text as follows:

Background Mode

If you choose Default, unconnected text and text connected to shapes will have a transparent 
background. Text connected to a line will have an opaque background. 

If you choose Opaque, the background of the text string is filled with the text background color. 

If you choose Transparent, the background of the text string is transparent regardless of the text 
background color.

Symbol-Linked Text

If you choose Wordwrap, text is stays within the boundary of the shape in which it resides. If you 
choose Size to Text, shapes are resized to encompass connected text. Choosing Normal 
disables both of these options.



Font

Choose a font and font style from the list box: Regular, Bold, Italic, or Bold Italic. Choose a font 
size and underline and/or strikeout.

Justification

Click the side arrow to choose Left, Center, Right or Default Justification. With default 
justification, text connected to shapes and lines is center-justified; unconnected text is left-
justified.

Text Color

Click the Text Color button and click the left mouse button to choose a text color.

Background Color

Click the Background Color button and click the left mouse button to choose a background color.

3. Choose OK.

Note: You can have different font attributes within a text object (font name, style, size, underline, and 
strikeout). However, you cannot have different text justification, color, background color and mode, and 
symbol-linked text within a text object. 

See also

Applying Styles to Objects in a Diagram

Connecting Text to Shapes and Lines

Entering Text

Quick Formatting



Applying Styles to Objects in a Diagram

To apply a symbol, line style, or text style from a smart library to object(s) in a diagram:

1. Select one or more objects.

2. Choose a symbol, line style, or text style from a smart library. If a smart library is not open, see 
Opening a Smart Library.

3. Click  on the Ribbon Bar or choose Apply Style from the Format menu. If you chose in Step 
2, selected shapes are replaced with the symbol chosen from the smart library. If you chose a 
line in Step 2, selected lines are assigned the attributes of the line style chosen from the smart 
library. If you chose a text style in Step 3, selected text is assigned the attributes of the text style 
chosen from the smart library.
-or-

1. Press the right mouse button on a symbol, line style, or text style from a smart library and drag it 
onto an object in your diagram.

Note: A symbol is made up of shapes and other objects combined. When you apply a symbol from smart 
library to a selected shape in your diagram, the selected shape is replaced with the symbol.

See also

Formatting Shapes and Symbols

Formatting Lines

Formatting Text

Quick Formatting



Quick Formatting

To quickly format an object:

Point to an object in a diagram or in a smart library and click the right mouse button. The 
appropriate format dialog box opens, where you can quickly make format changes.

See also

Appying Styles to Objects in a Diagram

Formatting Shapes and Symbols

Formatting Lines

Formatting Text



Formatting Outline and Fill Defaults

To globally change the default Toolbox outline and fill attributes:

1. Deselect any objects that may be selected in your diagram.

2. Choose either the Line, Curve, Rectangle, Ellipse, or Polygon tool.

3. Choose a new outline color by clicking on the Color Palette with the right mouse button. Use the 
left mouse button to choose a new fill color.

4. Click the Outline tool to change various outline attributes from left to right: hidden outline, hairline 
outline, dashed outline, dotted outline, or an outline width from 1 to 5 points.

5. Click the Fill tool to change various fill attributes from left to right: no fill, solid fill, or one of the 6 
patterned fills.

Objects created with the Line, Curve, Rectangle, Ellipse and Polygon tools are drawn with the format 
previously specified.

To change the defaults using the Symbol and Line Attributes dialog boxes:

1. Deselect any objects that may be selected in your diagram.

2. Choose Symbol from the Format menu to change the following: fill color, fill pattern, outline width,
outline color, and solid, dashed or dotted outlines.

3. Choose OK.

4. Choose Line from the Format menu to change to following: outline type, outline width, outline 
color, start and end arrows, and solid, dashed or dotted outlines.

5. Choose OK. Objects created with the Line, Curve, Rectangle, Ellipse, and Polygon tools are 
drawn with the format specified.

See also

Drawing Curves

Drawing Ellipses

Drawing Lines

Drawing Polygons

Drawing Rectangles

Formatting Shapes and Symbols

Formatting Lines



Formatting Text Defaults

To globally change the text default attributes of the Text tool:

1. Deselect any objects that may be selected in your diagram.

2. Choose the Text tool on the Toolbox.

3. Choose a new text color by clicking on the Color Palette with the left mouse button. Use the right 
mouse button to choose a new background color.

4. Use the Text Ribbon Bar to change the following: font name, font size, bold, italic, underline, or 
justification.

5. Click the left mouse button in your diagram to place the text cursor.

6. Type the text. New text is drawn with the format specified.

To change the defaults using the Text Attributes dialog box:

1. Deselect any objects that may be selected in your diagram.

2. Choose Text from the Format menu to change the following: text background, symbol-linked text, 
font name, font size, font style, underline, strikeout, justification, text color and background color.

3. Choose OK. New text entered with the Text tool is drawn with the format specified.

See also

Entering Text

Formatting Text
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Apply Style Button
Arrow Button
Arrow File
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Child File
Client
Clipboard
Color Palette
Column Align Button
Connected Object
Control Point
Control Polygon
Convex Hull
Copy Button
Curve Tool
Cut Button
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Dependent Objects
Drawing Order
Drawing Window
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Edge Selection
Edit Handles
Ellipse Tool
Embed
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Fill Tool
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Grid Snap Button
Group
Group Button
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Hidden Layer
Hidden Lines
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Library
Library Object
Library Title Bar
Library Style
Line Tool
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New Diagram Button
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Object
OLE Link
Open Diagram Button
Open Library Button
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Parent File
Parent Object
Paste Button
Pen Tool
Pick Tool
Polygon
Polygon Tool
Print Button
Printable Page
PRJ File
Project
Project Directory 
Protected Layer 
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Rectangle Tool
Ribbon Bar
Root File
Rotate Button
Rotation Point
Row Align Button
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Save Button
Server
Shapes
Smart Library
Spell Check Button
Status Line
Symbol
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Text Object
Text Ribbon
Text Style
Text Tool
To Back Button
To Front Button
Toolbox
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Zoom Tool



Active Layer
Objects on layers designated "Active" can be selected, edited and printed. 



Apply Style Button
An icon located on the Ribbon Bar used to apply text, lines, or symbols from a library to selected objects 
in a diagram.



Arrow Button
An icon located on the Ribbon Bar used to change the arrow of one or more selected line ends.



Arrow File
An Arrow File contains all information needed by CorelFLOW to describe one line arrow. Arrow Files all 
have a '.ter' extension.



Arrow Palette
The Arrow Palette displays all open arrows. It is invoked by choosing Arrow from the Format menu.



Attributes
Characteristics of an object that govern its appearance.



Bounding Box
The invisible perimeter that surrounds an object.



Child File
A file or application that's pointed to by a parent object within a CorelFLOW project. In the hierarchical 
structure, it is below the parent file.



Client
A Client is a program that receives data from a Server program using the OLE data exchange protocol.



Clipboard
A temporary storage area where CorelFLOW places cut or copied objects. The Clipboard stores 
information until either it is pasted into a diagram or replaced by another object that has been cut or 
copied to the clipboard.



Color Palette
The strip of 256 colors located at the bottom of the CorelFLOW screen.



Column Align Button
An icon located on the Ribbon Bar used to vertically align selected objects.



Connected Object
Object A is connected to object B if A moves when B is moved. Line ends may be connected to shapes, 
and text may be connected to lines and shapes.



Control Point
A vertex used to manipulate the shape of a curve. Control points are part of the control polygon, drawn in 
a blue dotted pen.



Control Polygon
A set of vertices that control the shape of a curve. When drawing or editing a curve, the control polygon is
drawn in a blue dotted pen.



Convex Hull
The convex hull is the minimum convex polygon which includes all points of the control polygon.



Copy Button
An icon located on the Ribbon Bar used to copy selected objects to the clipboard.



 Curve Tool 
An icon located on the Toolbox used to draw curves.



Cut Button
An icon located on the Ribbon Bar used to remove selected objects and move them to the clipboard.



Dependent Objects
A Dependent object is any object (line or text) which is connected to another object.



Drawing Order
The sequence in which objects are drawn on the screen. If object A is on bottom of all other objects, it is 
drawn first and is first in the Drawing Order. If object B is on top of all other objects, it is drawn last and is 
last in the Drawing Order.



Drawing Window
The portion of the CorelFLOW window that is available for drawing. All objects in the drawing window 
may not be available for printing, only objects on the Printable Page may be printed.



Edge Selection
In this mode, symbols, lines, and text are highlighted when the cursor is over the edge of the object.



Edit Handles
Eight black squares surrounding one or more selected objects.



Embed
Store objects produced by one application in another application. Using this method, the embedded 
object can be edited from within the application it was embedded. For example, you can embed objects 
created in CorelFLOW into a Microsoft Word document. You can also embed text created in Microsoft 
Word into your CorelFLOW diagram.



 Ellipse Tool 
An icon located on the Toolbox used to draw ellipses.



 Fill Tool 
An icon located on the Toolbox used to give selected shapes a new fill color and pattern.



Grid Snap Button
An icon located on the Ribbon Bar used to constrain objects to the grid.



Group
Constrain objects to act as a single unit.



Group Button
An icon located on the Ribbon Bar used to constrain selected objects to act as a single unit.



Hidden Layer
Objects on layers designated "hidden" are not displayed in the Drawing Window and cannot be printed 
until the layer setting is changed to either Active or Protected.



Hidden Lines
A line with zero width.



Hot Spot
The point at which the end of a line rotates on an arrow. When you create a new arrow, typically the 
rotation point is located at the tip of the arrow. 



Library
A collection of predefined text, lines, and symbols. Each library is a unique file with a .set extension.



Library Object
A predefined object located in a library which includes text, lines, and symbols.



Library Title Bar 
The Library Title Bar is located at the top of every open library and displays the library name.



Line Style
Pre-drawn lines that are found in a Smart Library. When you apply a line style to a line in a diagram, the 
style of the line in the Smart Library is applied to the line in the diagram.



 Line Tool 
An icon located on the Toolbox used to draw lines.



Marquee Box
A dashed box used to select objects; a marquee box is created when using the Pick tool. 



Marquee Select
Drag a dotted rectangle around objects to marquee select.



New Diagram Button
An icon located on the Ribbon Bar used to close the existing diagram and clear the screen.



Object
A generic term used for shapes, symbols, lines, curves, text, etc.



OLE Link
Where information is created and stored in one application but is also referenced in another application. 
Changes made to the information are automatically reflected in the representation in the other 
application. For example, you can link objects from CorelFLOW to Microsoft Word, when the objects 
change in CorelFLOW they also change in Microsoft Word. You can also link text from Microsoft Word to 
CorelFLOW.



Open Diagram Button
An icon located on the Ribbon Bar used to invoke the Open Diagram dialog box.



Open Library Button
An icon located on the Ribbon Bar used to invoke the Open Library dialog box.



Parent File
A project file which contains one or more Parent Objects. In the hierarchical structure, it is said to be 
'above' the child file.



Parent Object
A text object in a project file which contains a link to another CorelFLOW Diagram file or contains a 
command string that launches another application.



Paste Button
An icon located on the Ribbon Bar used to copy objects from the clipboard to a specific point in the 
diagram.



 Pen Tool 
An icon located on the Toolbox used to give selected objects a new pen width and type.



 Pick Tool 
An icon located on the Toolbox used to select, resize, move, and edit objects.



Polygon
An object drawn with a line and closed to contain an interior is a polygon. Rectangles and octagons are 
examples of polygons.



 Polygon Tool 
An icon located on the Toolbox used to draw polygons.



Print Button
An icon located on the Ribbon Bar used to bypass the Print dialog box and immediately begin the print 
operation.



Printable Page
The area on the screen marked with a drop shadow is the Printable Page. You can draw anywhere in the 
drawing window, but only objects located on the printable page may be printed.



PRJ File
A PRJ File is the file which contains all the link information for a project. All PRJ files have a '.prj' 
extension.



 Project
A project is a set of CorelFLOW diagrams linked together in a hierarchical fashion. 



Project Directory 
The directory in which a project is stored. All CorelFLOW diagram files included in a project are located in
the same directory.



Protected Layer
Objects on layers designated "Protected" are displayed on the printable page, but cannot be selected or 
edited. This option is useful for locking objects which you do not want to accidentally edit or misalign.



 Rectangle Tool 
An icon located on the Toolbox used to draw rectangles.



Ribbon Bar
The Ribbon Bar is located just under the Menu Bar and above the Text Ribbon in the drawing window. It 
displays several buttons used to shortcut options located on CorelFLOWs menus.



Root File
The Root File is the first CorelFLOW diagram displayed when a project is opened. Typically, it is the top 
file in a project, meaning that there is no parent above it in the project hierarchy.



Rotate Button
An icon located on the Ribbon Bar used to rotate selected objects.



Rotation Point
The point at which the end of a line rotates on an arrow. When you're creating a new arrow, typically the 
rotation point is located at the tip of the arrow. 



Row Align Button
An icon located on the Ribbon Bar used to horizontally align selected objects.



Save Button
An icon located on the Ribbon Bar used to save the current diagram.



Server
A Server is a program that provides data to a Client program using the OLE data exchange protocol.



Shapes
A closed object you draw using a Toolbox tool, for example, rectangles, squares, ellipses, circles, and 
polygons.



Smart Library
A collection of predefined text, lines, and symbols. Each library is a unique file with a .set extension.



Spell Check Button
An icon located on the Ribbon Bar used to check the spelling of selected text.



Status Line
The Status Line is located at the very bottom of the screen. It displays status line hints, mouse positions, 
library object names, and insertion and number lock modes.



Symbol
All objects in the Smart Libraries except for Line Styles and Text Styles are symbols. Symbols include 
objects you've added to a Smart Library using the Add Object as Symbol option. 



Text Object
A text object is a string of characters.



Text Ribbon
The Text Ribbon is located just above the drawing window. It displays several buttons and edit fields used
to shortcut options located in the Format Text dialog box.



Text Style
Pre-drawn text that's found in a Smart Library (for example, in the Default1 library). When you apply the 
text to text in the diagram, the style of the text in the Smart Library is applied to the text in the diagram.



 Text Tool 
An icon located on the Toolbox used to enter and edit text.



To Back Button
An icon located on the Ribbon Bar used to move selected objects to the back of the current layer.



To Front Button
An icon located on the Ribbon Bar used to move selected object to the front of the current layer.



Toolbox
The Toolbox is positioned on the left side of the CorelFLOW screen. It is a collection of icons used to 
draw, view, and edit objects.



True Type Fonts 
True Type Fonts are text fonts that print as they appear on the screen and may be resized to any height.



 Zoom Tool 
An icon located on the Toolbox used to change the view of the current diagram.





How To...
· Draw Objects
· Edit Objects
· Format Objects
· View Diagrams
· Arrange Objects
· Manage Files
· Work with Projects
· Use Smart Libraries
· Manage and Create Arrows
· Exchange Data with Other Applications



Draw Objects

Drawing Shapes 
· Drawing Rectangles
· Drawing Ellipses
· Drawing Polygons

Drawing Lines and Text
· Drawing Lines
· Drawing Curves
· Entering Text

Drawing from Libraries
· Adding Symbols from a Library
· Drawing Lines from a Library
· Entering Text from a Library

Connecting Objects
· Connecting Symbols to Shapes
· Connecting Lines to Shapes
· Connecting Two Symbols on the Page
· Connecting Text to Shapes and Lines
· Connection Feedback



Edit Objects

Selecting Objects
· Selecting a Single Object
· Selecting Multiple Objects
· Selecting Objects by Type
· Selecting Objects with Edge Selection
· Deselecting Objects

General Edit Operations
· Moving Objects
· Resizing Objects
· Undoing Operations
· Cutting Objects
· Copying Objects
· Pasting Objects
· Duplicating Objects
· Deleting Objects

Editing Lines
· Moving Points of a Line
· Adding and Deleting Points of a Line
· Changing Line Connections
· Shaping Curves

Editing Text
· Editing Text Strings
· Editing Text with Keyboard and Mouse Commands
· Checking Spelling
· Changing Text Connections



Format Objects

Formatting Diagram Objects
· Formatting Shapes and Symbols
· Formatting Lines
· Changing Arrows
· Formatting Text
· Applying Styles to Objects in a Diagram
· Quick Formatting

Pen, Fill, and Text Defaults on the Toolbox
· Formatting Outline and Fill Defaults
· Formatting Text Defaults



View Diagrams

Viewing Tools
· Zooming In
· Zooming Out
· Actual Size
· Fit Selected
· Show All
· Show Page
· Quick View

Viewing Options
· Viewing the Toolbox
· Snap to Grid
· Grid Setup
· Hidden Lines
· Child Links
· Speed Move
· Refresh Window



Arrange Objects

Aligning Objects
· Aligning Rows and Columns
· Aligning Objects to the Grid
· General Alignment Options
· Centering Objects on a Page
· Distributing Objects

Layering Objects
· Moving objects To Front
· Moving objects To Back
· Setting up Layers
· Moving Objects Between Layers

Rotating, Scaling, and Mirroring
· Rotating Objects
· Scaling Objects
· Mirroring Objects

Grouping
· Grouping Objects

Breaking and Joining
· Breaking Apart Lines
· Breaking Apart Symbols
· Joining Lines



Manage Files

Managing Diagram Files
· Creating a New Diagram
· Opening a Diagram
· Saving a Diagram
· Setting up the Page
· Creating business cards
· Setting Preferences

Printing Files
· Printing Diagrams
· Setting up the Printer
· Shifting and Scaling Printed Diagrams
· Fitting Diagrams to the Printed Page
· Printing Selected Pages and Multiple Copies
· Printing Projects
· Cloning Diagrams on the Printed Page
· Printing to an Encapsulated Postscript (EPS) File



Work with Projects

· Creating a New Project
· Opening a Project
· Saving a Project
· Opening a Child File
· Opening a Parent File
· Adding a Child File
· Inserting a Parent File
· Changing a Project Link
· Deleting a Project Link
· Deleting a File From a Project
· Exiting a Project



Use Smart Libraries

Managing Library Files
· Creating a New Smart Library
· Opening a Smart Library
· Saving Changes to a Smart Library
· Closing a Smart Library

Repositioning Libraries on the Screen
· Moving a Smart Library
· Sizing a Smart Library
· Rolling a Smart Library Up or Down
· Arranging Smart Libraries

Managing Library Objects
· Exchanging Objects Between Smart Libraries
· Editing Smart Library Objects
· Deleting Objects from a Smart Library 
· Designing a Symbol
· Adding Symbols to a Smart Library
· Adding Line Styles to a Smart Library
· Adding Text Styles to a Smart Library



Manage and Create Line Arrows

· Creating New Arrows
· Updating Arrows
· Adding Arrows to the Arrow Palette



Exchange Data with Other Applications

Cutting, Copying, and Pasting
· Cutting, Copying, and Pasting

Importing and Exporting
· Importing Data
· Exporting Data

Embedding Objects from another Application
· Embedding as a Client
· Embedding as a Client via the Clipboard
· Updating Embedded Objects in a CorelFLOW diagram

Linking Objects from another Application
· Linking as a Client
· Linking as a Client via the Clipboard
· Updating Links as a Client
· Editing Links

Embedding and Linking Objects to other Applications
· Embedding as a Server via the Clipboard
· Updating Embedded Objects as a Server
· Linking as a Server via the Clipboard
· Updating Linked Objects as a Server





Shortcuts 

· Function Keys

· Menu Command Keys

· Toolbox Keys and Mouse

· Ribbon Bar Keys

· Dialog Box Keys

· Dialog Box Shortcuts



Function Keys
F1 Help Contents

Shift + F1 Screen/Menu Help

Ctrl + F1 Search For Help On

F2 Zoom In

F3 Zoom Out

F4 Zoom to all Objects

Shift+F4 Zoom to Page

F5 Line Tool

F6 Rectangle Tool

F7 Ellipse Tool

F8 Text Tool



Menu Command Keys
File Menu
Ctrl + N New

Ctrl + O Open

Ctrl + S Save 

Ctrl + P Print

Ctrl + J Preferences

Alt + F4 Exit

Edit Menu
Ctrl + Z Undo

Ctrl + X Cut

Ctrl + C Copy

Ctrl + V Paste

Del Delete

Ctrl + D Duplicate

View Menu
Ctrl + Y Snap to Grid

Ctrl + G Show Grid

Ctrl + W Refresh Window

Arrange Menu
Ctrl + A Align

To Front Shift + PgUp

To Back Shift + PgDn

Grouped Ctrl + G

Help Menu
F1 Contents

Shift + F1 Screen/Menu Help

Ctrl + F1 Search For Help On



Toolbox Keys and Mouse

 Pick Tool

 Zoom Tool

 Line Tool

 Curve Tool

 Rectangle Tool

 Ellipse Tool

 Polygon Tool

 Text Tool

 Pen Tool

 Fill Tool



 Pick Tool

Press To
Spacebar Enable the Pick tool when 

any tool except for the Text
tool is active

Ctrl + Spacebar Enable the Pick tool when 
the Text tool is active

Hold Down To
Shift Select more than one 

object. Deselect a single 
object. Resize objects 
relative to their sides. 
Constrain movements 
horizontally and vertically.

Ctrl Resize objects 
symmetrically. Freeze the 
highlight state. Connect 
text or lines to an off-
center point. Limit rotation 
to 15-degree increments.

Alt + Click Specify the view center 
point and zoom to actual 
size.

Ctrl + Alt + Any Arrow Move selected objects one
grid point.

Use Mouse To
left button click Select, resize, and move 

objects. Enter text.

double left button click When clicked on text or a 
symbol with connected 
text, pushes to specified 
child file. If no file is 
specified, opens the Set 
Child dialog box.

right mouse click When clicked on an object,
enables the appropriate 
format dialog box.

 Zoom Tool

Use Mouse To
left button click or drag Choose either Zoom In, 



Zoom Out, Actual Size, Fit 
Selected, Fit All,    Show 
Page, Show Diagram.

left button click and
drag with Zoom In

chosen

Define filling the viewing 
area with a drawn 
rectangle.

 Line Tool

Hold Down To
Shift Constrain movements 

horizontally and vertically.

Ctrl Freeze the highlight state 
when connecting lines. 
Connect a line to an off-
center point.

Spacebar Add line points.

Use Mouse To
left button click Begin line draw. Add line 

points.

double left button click End line draw.

right button click End line draw. Before or 
after drawing line, switch to
the Pick tool.

 Curve Tool

Hold Down To
Shift Constrain movements 

horizontally and vertically.

Ctrl Freeze the highlight state 
when connecting curves. 
Connect a curve to an off-
center point.

Spacebar Add line points.

Use Mouse To
left button click Begin curve draw. Add line 

points.

double left button click End curve draw.

right button click End curve draw. Before or 
after drawing curve, switch
to the Pick tool.



 Rectangle Tool

Hold Down To
Ctrl Draw a square.

Use Mouse To
left button click and

drag
Place upper left point of 
rectangle. Draw rectangle 
by dragging the mouse, 
release to end draw.

right button click Switch to the Pick tool.

 Ellipse Tool

Hold Down To
Ctrl Draw an ellipse.

Use Mouse To
left button click and

drag
Place upper left point of 
ellipse. Draw ellipse by 
dragging the mouse, 
release to end draw.

right button click Switch to the Pick tool.

 Polygon Tool

Hold Down To
Shift Constrain movements 

horizontally and vertically.

Spacebar Add line points.

Use Mouse To
left button click Begin polygon draw. Add 

line points.

double left button click End polygon draw.

right button click End polygon draw. Before 
or after drawing polygon, 
switch to the Pick tool.

 Text Tool



Hold Down To
Ctrl Freeze the highlight state 

when connecting text. 
Connect text to an off-
center point.

Spacebar Enables the Text tool when
the Pick tool is active

Ctrl + Spacebar Enable the Pick tool

Ctrl + Home Beginning of a text object.

Ctrl + End End of a text object.

Up/Down Arrow Up or down one line.

Left/Right Arrow Right or left one character.

Ctrl + Left Arrow Left one word.

Ctrl +    Right Arrow Right one word.

Home Beginning of a line.

End End of a line.

Shift + Left Arrow Reduce selected text by 
one character.

Shift +    Right Arrow Advance selected text by 
one character.

Shift + Up Arrow Select text up one line.

Shift + Down Arrow Select text down one line.

Shift + Home Select text to the beginning
of a line.

Shift + End Select text to the end of a 
line

Ctrl + Shift + Left Arrow Select text to the previous 
word.

Ctrl + Shift + Right
Arrow

Select text to the next 
word.

Ctrl + Shift + Home Select text to the beginning
of the text object.

Ctrl + Shift + End Select text to the end of 
the text object.

Use Mouse To
left button click Enter text. Begin text 

editing.

double left button click Push to a specified child 
file. If no file is specified, 
open the Set Child dialog 
box.



right button click Switch to the Pick tool.

 Pen Tool

Use Mouse To
left button click or drag Choose either Zero Width, 

Solid, Dashed, Dotted, 
Width2, Width4, Width6, 
Width8, or Width10.

 Fill Tool

Use Mouse To
left button click or drag Choose either 

Transparent, Solid, or one 
of the 6 Patterns.

Ribbon Bar Keys 

 New Diagram Button (Ctrl + N)

 Open Diagram Button (Ctrl + O)

 Save Button (Ctrl + S)

 Print Button (Ctrl + P)

 Cut Button (Ctrl + X)

 Copy Button (Ctrl + C)

 Paste Button (Ctrl + V)

 Arrow Button (Ctrl + K)

 Apply Style Button (Ctrl + M)

 Snap to Grid Button (Ctrl + G)



 Column Align Button (Ctrl + Alt + A)

 Row Align Button (Ctrl + Shift + A)

 Rotate Button (Ctrl + Alt + R)

 Group Button (Ctrl +G)

 To Front Button (Shift + PgUp)

 To Back Button (Shift + PgDn)

 Open Library Button

 Bold Button (Ctrl + B)

 Italics Button (Ctrl + I)

 Underline Button (Ctrl + U)

 Left Align Text Button (Ctrl + L)

 Center Text Button (Ctrl + E)

 Right Align Text Button (Ctrl + R)

 Default Align Text Button (Ctrl + T)

 Spell Check Button



Dialog Box Keys
Tab Moves to next list box, command button, text field, check box, or

group of option buttons.

Shift + Tab Moves to previous list box, command button, text field, check 
box, or group of option buttons.

Arrow Keys Moves and selects within an active group of option buttons.

Spacebar Turns on or off the active command button.

Letter Keys Moves to the next option beginning with the specified letter in an
active list box.

Alt + Underlined Moves to the option with that specified underlined

Letter letter.

Enter Chooses the active command button.

Esc Cancels commands and closes the dialog box.

Dialog Box Shortcuts

To open this dialog box Do This
Format Symbols With the Pick tool active, 

right mouse click on a 
symbol or object.

Format Lines With the Pick tool active, 
right mouse click on a line.

Format Text With the Pick tool active, 
right mouse click on a text 
object.

Format Arrows With the Pick tool active, 
right mouse click on a line 
end.



 Exchanging Data with Other Applications Overview

You can exchange CorelFLOW data directly from one file to another or using the Windows clipboard. 
CorelFLOW's import and export filters allow you to exchange CorelFLOW data among different 
applications.

You can also embed objects produced in one application into another application. You can embed objects
directly from the server or via the clipboard. For example, when you embed a CorelFLOW diagram in a 
Microsoft Word document, the file is stored and maintained within the Word document.

Linking lets you create and store objects in one application and reference them in one or more other 
applications. You can link objects directly from the server or via the clipboard. For example, you can link a
CorelFLOW diagram to several files in Microsoft Word. The file is stored in CorelFLOW. When you edit 
the diagram in CorelFLOW, every linked document in Word is updated.

See also
Cutting, Copying, and Pasting
Embedding as a Client
Embedding as a Server
Exporting Data
Importing Data
Linking as a Client
Linking as a Server



Cutting, Copying, and Pasting

Exchange data between applications using the Cut, Copy, and Paste options in the Edit menu of most 
applications. These options use the clipboard as a temporary storage area to transfer data between 
Windows applications. 

To cut objects to the clipboard:
1. Select the objects.

2. Choose Cut from the Edit menu (Ctrl + X). 

The objects are cut from the diagram and placed on the clipboard.

To paste the objects into another file, switch to the file and choose Paste from the Edit menu (Ctrl 
+ V). The cut objects are pasted into the destination file.

To copy objects to the clipboard:
1. Select the objects.

2. Choose Copy from the Edit menu (Ctrl + C).

To paste the objects into another file, switch to the file and choose Paste from the Edit menu (Ctrl 
+ V). The objects are copied into the destination file.

See also
Copying Objects
Cutting Objects
Embedding as a Client
Embedding as a Server
Linking as a Client
Linking as a Server
Pasting Objects



Importing Data

To import a file into a CorelFLOW diagram:
1. Choose Import from the File menu.

2. Choose a data format in the List Files of Type list box.

3. Choose the drive and directory in which the file you want to import resides.

4. Type the file name in the File Name list box.

5. If desired:

· Check the Preview box to view the diagram in the example box. Choose Full Image or 
Resample in the list box under the Preview section of the dialog box.

· Click the Filter Information button to view information about the selected filter.

· Click the Options button to view more information about the selected file, including, date, file 
size, file format, and image size. In the Sort By list box, you can choose the order in which the
file names are sorted in the File Name list box.

6. Choose OK to import the file.

See also
Cutting, Copying, and Pasting
Embedding as a Client
Exporting Data
Linking as a Client
Pasting Objects



Exporting Data

To export CorelFLOW data to another graphics format:
1. Choose Export from the File menu.

2. Choose a data format in the List Files of Type list box.

3. Choose a directory and drive to export the file to.

4. Enter a file name in the File Name box.

5. Click the Filter Information button to view information about the selected filter.

6. Choose OK to export the file.

See also
Copying Objects
Cutting, Copying, and Pasting
Cutting Objects
Embedding as a Server
Importing Data
Linking as a Server



Embedding as a Client

To embed objects into your CorelFLOW diagram:
1. Choose Insert Object from the Edit menu.

2. Choose Create New if you want to embed new objects that have not yet been created. Choose 
an object type in the Object Type list box. To embed from an existing file, choose Create from 
File. Name the file and path in the File box. If you don't know the file name, click the Browse 
button. Be sure that the Link check box is not enabled.

3. Click the Display as Icon box to if you want to represent the embedded objects as an icon in the 
CorelFLOW diagram. Change the icon by choosing the Change Icon button.

4. Choose OK. The objects are embedded into CorelFLOW and placed in the center of the current 
view.

See also
Embedding as a Client using the Clipboard
Embedding as a Server
Linking as a Client
Updating Embedded Object in a CorelFLOW diagram



Embedding as a Client via the Clipboard

To embed objects via the clipboard:
1. Switch to the Server application. This application must support embedding as a server.

2. Copy the objects to the clipboard (Ctrl + C). 

3. Switch to CorelFLOW. 

4. If desired, choose the Pick tool and double-click in an empty space in your diagram to mark 
where the embedded objects are to be placed. (If you don't mark the place, they will be centered 
in the diagram.)

5. Choose Paste from the Edit menu.

See also
Embedding as a Client
Embedding as a Server
Linking as a Client using the Clipboard
Updating Links as a Client



Updating Embedded Objects in a CorelFLOW diagram

To update embedded objects stored in a CorelFLOW diagram:
1. Select the embedded objects in your diagram.

2. Choose Object from the Edit menu.

3. The server application opens along with the associated file. The embedded objects are available 
to edit.

4. Update the objects in the server application and exit to CorelFLOW. The objects are updated in 
the CorelFLOW diagram.

Note:    You may want to refer to the other application's documentation on updating embedded objects as 
a server.

See also
Embedding as a Client
Embedding as a Client using the Clipboard
Updating Embedded Objects as a Server
Updating Links as a Client



Linking as a Client

To link objects from another application into CorelFLOW:
1. Choose Insert Object from the Edit Menu.

2. Choose Create from File.

3. Name the path and file to link from. This may be any file created from an application that supports
linking as a server. 

4. If you don't know the file name or path, click the Browse button. Double-click the directory and 
drive, then type the file name in the File list box.

5. Check the Link box.

6. Choose OK to create a link between the two documents. Now when the source file is edited, the 
changes are reflected in the linked data in the CorelFLOW file.

Note: Formatted text is not preserved when linking. For example, if you're linking a string of bold and 
italic text, the text is linked without the bold and italic formatting.

See also
Editing Links
Embedding as a Client
Linking as a Client using the Clipboard
Linking as a Server
Updating Links as a Client



Linking as a Client using the Clipboard
1. From the server application, select the objects to link. The server application must support linking 

as a server.

2. Copy the selected objects to the clipboard by choosing Copy from the Edit menu (Ctrl + C).

3. Open the file in CorelFLOW in which you want to insert the linked data.

4. If desired, place the cursor in the diagram with a double-click. This is where the linked data will be
inserted. If you don't mark the place, it will be inserted into the center of the diagram.

5. Choose Paste Special from the Edit menu.

6. In the Paste Special dialog box, choose the data type in the As list box. 

7. Choose Paste Link.

8. If desired, check the Display as Icon box to represent the linked objects as an icon in the 
CorelFLOW diagram. You may also change the icon by clicking the Change Icon button and 
choosing a new icon.

9. Choose OK to link the two documents.

Note: Formatted text is not preserved when linking. For example, if you're linking a string of bold and 
italic text, the text is linked without the bold and italic formatting.

See also
Editing Links
Embedding as a Client
Linking as a Client
Updating Links as a Client



Updating Linked Objects as a Client

Links default to automatic updating. When changes occur in the source file, the CorelFLOW diagram 
automatically updates.

To edit linked objects in the source document:
1. Choose Links from the Edit menu in CorelFLOW.

2. Select the link to edit in the Link list box.

3. Click the Open Source button. The server application is invoked and the source document 
opened.

4. Make the changes to the linked objects.

5. Exit the server application.

6. Switch to CorelFLOW. Choose Yes when prompted to update the link.

To change a link to manual updating:
1. Choose Links from the Edit menu in CorelFLOW.

2. Select the link(s) to be changed in the Link list box.

3. Choose Manual. Selected links must now be updated manually.

To manually update linked data:
1. Choose Links from the Edit menu in CorelFLOW.

2. Select the link(s) to be updated in the Link list box.

3. Click the Update Now button.

See also
Editing Links
Linking as a Client
Updating Embedded Objects in a CorelFLOW diagram
Updating Linked Objects as a Server



Editing Links

You may want to edit a link if it is broken (a link can be broken, for example, if the source has been 
moved or renamed). 

To edit a link:
1. Choose Links from the Edit menu.

1. Select the link with a left mouse button click.

2. Choose Change Source.

3. Change the necessary information (e.g.,. give a new source name) and choose OK.

To break or cancel a link: 
1. Choose Links from the Edit menu.

1. Select the link to be removed.

2. Choose Break Link. 

3. Confirm by choosing Yes.

If the linked data format was unformatted text, a copy of the linked data is retained and may be edited like
a normal text object (see Editing Text Strings). For all other formats, the object is deleted when the link is 
canceled (this is identical to selecting the object in the diagram and pressing the DELETE key).

See also
Linking as a Client
Updating Links as a Client



Embedding as a Server via the Clipboard

To embed objects created in CorelFLOW into another application via the clipboard:
1. Select the objects in CorelFLOW to embed.

2. Choose Copy from the Edit menu (Ctrl + C). The selected objects are copied to the clipboard.

3. Open the file in the client application. This application must support embedding as a client.

4. Choose Paste Special from the Edit menu while in the client application.    

5. Select CorelFLOW Diagram Object and choose Paste.

The procedure for pasting and embedding data in the client application may vary depending on that 
particular application. You may want to refer to the client application's documentation on OLE embedding.

Some OLE client applications allow you to insert a new embedded object directly into a document instead
of using the clipboard. The procedure is usually similar to Embedding as a Client in this application 
(choose Insert Object from an Edit menu or choose Object from an Insert menu).

See also
Embedding as a Client
Linking as a Server
Updating Embedded Objects as a Server



Updating Embedded Objects as a Server

Editing embedded objects varies according to the application which contains the embedded object. For 
example, to edit an embedded object in Microsoft Word, double-click on the object. CorelFLOW is 
invoked with the embedded object already loaded, ready to be edited. Notice the following differences in 
the CorelFLOW application:

· The title of the CorelFLOW Diagram is CorelFLOW Diagram in filename, filename being the name of 
the client document which contains the embedded object.

· The New and Open options on the File menu are disabled.    While running CorelFLOW as a server, 
you can only edit the embedded object. In addition, all project functionality is disabled while running 
as a server.

· The File menu option 'Save As' is changed to 'Save Copy As', a copy of the embedded object may be
saved to a CorelFLOW file.

· The File menu option 'Save' is changed to 'Update'. To save changes to the embedded object, 
choose Update from the File menu.

· To return to Word, choose Exit to [filename] from the File menu.

You must cancel embedding in the client application. For example, if the object is embedded in a Word 
document, select the object and press Unlink Field or Ctrl+Shift+F9.

Because each application is different, refer to the client application's documentation on embedding 
objects.

See also
Embedding as a Server
Updating Embedded Objects in a CorelFLOW diagram
Updating Linked Objects as a Server



Linking as a Server via the Clipboard

1. In CorelFLOW, select the objects to link.

2. From the Edit menu, choose Copy (Ctrl + C).

3. Open the file in the client application. This application must support linking as a client.

4. Choose Paste Special from the Edit menu.

5. Select CorelFLOW Diagram Object.

6. Choose Paste Link.

The procedure for pasting and linking data in the client application may vary depending on that particular 
application. Refer to the client application's documentation on creating OLE links.    

Some OLE client applications allow you to insert a linked object directly into a document instead of using 
the clipboard. The procedure is usually similar to Linking as a Client in this application (choose Insert 
Object from an Edit menu or choose Object from an Insert menu).

See also
Embedding as a Server
Linking as a Client
Updating Linked Objects as a Server



Updating Linked Objects as a Server

Links created with CorelFLOW as a server may be edited directly in CorelFLOW. To do this, save the 
changes to the file containing the linked data in CorelFLOW. When the client files are opened, you are 
prompted to update the changes.

You can also edit linked data from within the client application. However, editing the linked data varies 
depending on the client application. The procedure is usually similar to Updating Links as a Client in 
CorelFLOW. For many applications, you choose Links from the Edit menu to do this. Refer to the client 
application's documentation on updating links.

See also
Linking as a Server
Updating Embedded Objects as a Server
Updating Links Objects as a Client



Menus 
For help on a menu item, click the appropriate menu, then click the menu item.



 



Restore: Control menu

Returns the active window to its previous size and location before Minimize or Maximize were chosen 
from the Control menu. You can also restore the window by clicking the Restore button.

Note: The restore command does not affect a window moved or sized with the Move or Size 
commands from the Control menu.



Move: Control menu

Allows you to move the active window using the arrow keys on the keyboard. Press ENTER on the 
keyboard to end the move. You can also move the active window by clicking and dragging the left mouse 
button on the Title bar.

Note: You can not move a maximized window.



Size: Control menu

Allows you to resize the active window with the arrow keys on the keyboard. Press ENTER on the 
keyboard to end the resize. You can also size the active window by clicking and dragging the left mouse 
button on the edge or corner of the active window.

Note: You can not resize a maximized window.



Minimize: Control menu

Reduces the active window to an icon at the bottom of the screen. You can also minimize the window by 
clicking the Minimize button.

Note: Choose Restore from the Control menu to return the window to its previous size.



Maximize: Control menu

Expands the active window to fill the screen. You can also minimize the window by clicking the Maximize 
button. 

Note: Choose Restore from the Control menu to return the window to its previous size.



Close: Control menu

Closes the active window. CorelFLOW prompts you to save any changes if not previously saved. You can
also close the active window by double-clicking on the Control menu or choosing Exit from the File menu.



Switch To: Control menu

Opens the Task List dialog box which lists all currently open applications.

Dialog Box Options

Switch To
Displays the currently selected application.

End Task
Closes the selected application.

Cancel
Closes the Task List dialog box without performing an operation.

Cascade
Overlaps all open applications so that each Title bar is visible.

Tile
Sizes all open applications to fit on the screen.

Arrange Icons
Arranges all minimized application icons evenly across the bottom of the screen.





New: File menu

Displays an empty page. If a diagram was open you chose New, a dialog box opens, prompting you to 
save any changes. 

Shortcut: Click the New button on the Ribbon Bar.



Open: File menu

Opens a CorelFLOW diagram. If a diagram was open before you chose Open, a dialog box opens, 
prompting you to save any changes. 

Dialog Box Options
File Name
Enter a file name in the entry box or highlight a file name in the list box.

Directories
Select the directory in which the desired diagram is stored by double-clicking on a directory name.

List Files of Type
Highlight the diagram format you want to open.

Drives
Highlight the drive in which the diagram is stored.

Network
The Network button is only available if Windows for Workgroups is installed. Choose the Network button 
to open a diagram located on a network.

Shortcut:    Click the Open button on the Ribbon Bar.



Save: File menu

Saves the current diagram. CorelFLOW diagrams are saved with a .cfl extension (unless another format 
is specified). 

Shortcut:    Click the Save button on the Ribbon Bar.



Save As: File menu

Saves the current diagram under a new name or in a new directory.

Dialog Box Options

File Name
Either type the file name in the entry box or highlight a file name in the list box.

Directories
Select the desired directory in which the diagram is to be stored.

Network
The Network button is only available if Windows for Workgroups is installed. Choose the network button 
to save the diagram on a network.

Selected Only
Check the Selected Only box to save selected objects as a new diagram.

Save File as Type
Highlight the desired format in which to save the diagram.

Drives
Highlight the desired drive on which to save the diagram.



Import: File menu

Imports a CorelFLOW diagram into the current diagram.

Dialog Box Options

File Name
Only files of the chosen format in the List Files of Type box are listed. Either type the file name in the 
entry box or highlight a file name in the list box.

Directories
Choose the directory from which to import the diagram.

List Files of Type
Highlight the desired format of the imported diagram.

Drives
Highlight the desired drive from which to import the diagram.

Preview
Check the Preview box to view the selected diagram in the preview box. Choose Full Image or Resample
in the list box.

Filter Information
Click the Filter Information button to view facts on the filter used to import the data specified in the List 
Files of Type box.

Options
Click the Options button to view more information about the file chosen in the File Name list box, 
including date, file size, file format, and image size. You can also choose the method in which the file 
names are sorted in the File Name list box.



Export: File menu

Exports a CorelFLOW diagram in a specified graphics format.

Dialog Box Options

File Name
Only files of the chosen format in the List Files of Type box are listed. Either type the file name in the 
entry box or highlight a file name in the list box.

Directories
Select the desired directory in which to export the diagram.

Network
The Network button is only visible if Windows for Workgroups is installed. Choose the network button to 
export the diagram to a network.

List File of Type
Highlight the desired format of the exported diagram.

Drives
Highlight the desired drive to export the diagram.

Filter Information
Click the Filter Information button to view basic facts on the filter used to export the data specified in the 
List Files of Type box.



Smart Library, New: File menu

Creates a new library named "undefined.ssl".



Smart Library, Open: File menu

Opens an existing library.

Dialog Box Options

File Name
Type the file name in the entry box or highlight the file name in the list box.

Directories
Choose the directory in which the desired library is stored.

List File of Type
Choose Library to list only library in the File Name list box.

Drives
Highlight the drive on which the desired library is stored.



Arrows: File menu
The Arrows command has two options, Open and Save As, which let you load arrows onto the Arrow 
Palette and save arrows.

Arrows - Open:

Dialog Box Options

File Name
Type the file name of the arrow in the entry box or highlight the file name in the list box.

Directories
Choose the directory in which the desired arrow is stored.

List File of Type
Arrows (*.ter) is the only option that may be listed.

Drives
Highlight the drive on which the desired arrow is stored.

Arrows - Save As:

Dialog Box Options

File Name
Type a file name in the File Name entry box. Naming an existing arrow updates that arrow. 

Directories
Choose the desired directory in which the arrow is to be stored. 

Save File as Type
Highlight the desired format in which to save the diagram.

Drives
Highlight the desired drive on which to save the arrow.



Print: File menu

Prints the current diagram. 

Dialog Box Options

Offset
Shift the diagram up, down, left or right by changing the horizontal and vertical settings. A positive vertical
value shifts the diagram up. A positive horizontal value shifts the diagram to the right. The valid range for 
these variables is from -47.00 and 47.00 (inches).

Scale
Scale the diagram relative to the upper left corner of the page. The valid range for these variables is 
from .10 to 10.00. Scale the pen width from 1 to 10 pixels. 

Copies
Increase the number of copies printed using the arrows to the right of the Copies box.

Range
Choose File to print the entire file. Choose Project to print all files in the current project. Choose Pages to 
specify which pages of the current diagram to print. Pages drawn black will be printed, whereas pages 
drawn white will not be printed. Choose Clone to duplicate the diagram on the printed page (only if the 
page size defined in the Page Setup dialog box is smaller than the printed page).

Print to File
Print to a file by checking the Print to File box. If a different name is desired rather than the default, type it
in the box.

Fit to Page
Check the Fit to Page box to expand or compress your diagram to fit on a single printed page.

Shortcut: Click the Print button on the Ribbon Bar to bypass the Print dialog box and immediately begin 
printing.



Page Setup: File menu

Creates a page environment for the diagram according to specified options.

Dialog Box Options

Page Size
Choose the desired page size. For example, if Letter is chosen, the page width and height will 
automatically be set to 8.5 and 11.0 inches respectively. Manually set the page width and height by either
typing the measurements in the entry box or by using the arrows to specify a value. The maximum paper 
size is 48" by 48". 

Page Orientation
Choose either Portrait or Landscape orientation.

Page Margins
Set the top, bottom, left and right margins by either typing the measurements in the appropriate entry box
or by using the arrows to specify a value.

Number of Pages
Set the number of horizontal and vertical pages by either typing the number in the appropriate entry box 
or by using the arrows to specify a value. The allowed number of pages varies depending on the current 
page size.

Units
Set the unit of measurement for the entire Page Setup dialog box by choosing either inches or 
centimeters.



Preferences: File menu
Defines preferences for the CorelFLOW drawing environment.

Dialog Box Options

Center Lines
Enable to connect lines at the center of shapes. Disable to connect lines to an off-center point of a shape.

Center Text
Enable to connect text at the center of shapes. Disable to connect text to an off-center point of a shape. 

Edge Selection
Enabling this option lets you highlight shapes when the pointer is over the edge of a shape. Disabling it 
lets you highlight shapes when the pointer is over the interior of a shape.

Auto Panning
Enabling this option lets you scroll the diagram when an object is moved past the edge of the screen. 
Disabling it lets you keep the view constant when trying to move objects past the edge of the screen.

Glue
Enabling this option lets you connect CorelFLOW objects. When this option is disabled, you cannot 
connect objects. 

Display
View or hide the Ribbon Bar, Text Ribbon Bar, Color Palette, Status Line, or Pop-Up Help by checking or 
clearing the appropriate box.

Arrow Directory
Type the default Arrow Directory in the entry box. All arrows in the named directory are added to the 
Arrow Palette at program startup.



Exit: File menu

Closes CorelFLOW. If the current diagram has not been saved, you are prompted to save it.



1, 2, 3, 4: File menu

Displays the last four files saved or opened. Click on a file name to open it.





Undo: Edit menu

Reverses the last operation.



Cut: Edit menu

Removes selected objects from the diagram and places them on the clipboard.



Copy: Edit menu

Places a copy of selected objects on the clipboard.



Paste: Edit menu

Places objects on the clipboard in the center of the drawing window.



Paste Special: Edit menu

Allows you to choose the format in which to move objects from the clipboard to the drawing window. It is 
also possible to create a link from another application to CorelFLOW.

Dialog Box Options

As
Highlight the desired data type.

Paste
Click Paste to place objects stored on the clipboard in the center of the drawing window.

Paste Link
Click Paste Link to place objects stored on the clipboard in the center of the drawing window and create a
link between the object in CorelFLOW and the source document.

Note: The source document is named at the top of the dialog box.

Display as Icon
Click this option to represent the embedded objects as an icon in the CorelFLOW diagram. The icon 
associated with the currently-named application or file displays in the lower right corner of the dialog box. 
You can also change the icon by clicking the Change Icon button and choosing a new icon.

Result
Gives a text description of what will happen based on the options selected in the dialog box.



Delete: Edit menu

Deletes selected objects from the drawing window. You can also delete objects by clicking the Delete key 
on the keyboard.



Duplicate: Edit menu

Makes a copy of selected objects and places the copy one grid point above and to the right of the original
objects.



Spell Check: Edit menu
Checks the spelling of selected text.

Dialog Box Options

Unknown Word
Displays misspelled words or words not found in the current dictionary. You can also type the word you 
want to check and then choose the Begin Check button.

Change To
Choose the correct word from the list box.

Change
Click to change the spelling of the word in the text.

Change All
Click to change all instances of a misspelled word in the text. 

Skip
Leaves the word in the Word Unknown box unchanged and continues with the Spell Check.

Skip All
Leaves the word in the Word Unknown box unchanged for the remainder of the text object(s).

Dictionary
Lists previously-created personal dictionaries. 

Create
Add your own personal dictionary to the spell checker. Type a file name for the dictionary you want to 
create in the Dictionary box and then choose the Create button.

Add Word
Adds the word in the Unknown Word box to the dictionary named in the Dictionary box.

Context
Displays the text string in which the misspelled word was found.

Range
Click the Range button to view options in which to check text: check word, selected text, current object, 
all document text. The current range is listed at the top of the dialog box.

Begin Check
Click to begin spell checking. Choose one of the range options before starting the operation. 

Close
Closes the Spell Check dialog box.



Select, All: Edit menu

Selects all objects in the current diagram.



Select, Symbols: Edit menu

Selects all shapes and symbols in the current diagram.



Select, Lines: Edit menu

Selects all lines in the current diagram.



Select, Text: Edit menu

Selects all text in the current diagram.



Insert Object: Edit menu

Inserts an embedded or linked object into the current CorelFLOW diagram. 

Dialog Box Options

Create New
Creates new embedded objects. The chosen application opens, ready to create your new embedded 
objects.

Object Type: Choose the type of object desired to embed in the list box.

Create from File
Calls upon an existing file in which to embed or link data. If embedding, the appropriate application is 
invoked and the named file is opened. If linking, a representation of the chosen file is placed in 
CorelFLOW.

File: Type the name and the path of the desired file.

Browse: If you don't know the name or path of the desired file, click the Browse button. Choose a drive, 
directory and file name in the dialog box.

Link: Click the Link box to link the chosen file. A representation of the file is placed in CorelFLOW. If the 
Link box is not checked, the file is embedded.

Display as Icon
Check the Display as Icon box to represent the embedded object as an icon in the CorelFLOW diagram. 
The icon associated with the currently-named application or file displays in the lower-right corner of the 
dialog box. You can also change the icon by clicking the Change Icon button and choosing a new icon.

Result
Gives a text description of what will happen based on the options chosen in the dialog box.



Object: Edit menu

Opens the application associated with a linked or embedded object. When you exit the other application, 
edited objects are reflected in the CorelFLOW diagram. 



Links: Edit menu

Edits links located in CorelFLOW.

Dialog Box Options

Link
Lists all links located in your diagram. Also lists the type and update information of the link.

Source
Displays the file name and directory where the selected link in is stored.

Type
Displays the file type of the selected link.

Update
Specifies Automatic or Manual updating for the selected link. Choose Automatic to update the data in 
CorelFLOW whenever a change is made to the linked object in the other application. Choose Manual to 
update the data in CorelFLOW whenever you choose the Update Now button.

Update Now
Manually updates the selected link.

Open Source
Opens the application where the linked information originated.

Change Source
Displays the Change Link dialog box. Choose a new file in which to receive information.

Break Link
Breaks the selected link so that there is no longer a connection between the CorelFLOW diagram and the
original source.





Toolbox, Visible: View menu

Enable the Visible option to view the Toolbox. Disable it to hide the toolbox. 



Toolbox, Floating: View menu

Enable this option to release the Toolbox from its anchor point so you can reposition it in the drawing 
window. Disable this option to lock the Toolbox in its default position.



Hidden Outlines: View menu

Displays all hidden outlines in your diagram in a blue dotted pen.



Child Links: View menu

Marks all parent objects with a bounding box.



Speed Move: View menu

Enable this option to see only an object's outline while you move it. Disable this option to see the entire 
object during a move operation. Enabling Speed Move speeds up the move operation.



Snap to Grid: View menu

Constrains objects to the grid.



Show Grid: View menu

Enable this command to display the grid. Grid marks will appear in the drawing window. To change the 
frequency of the grid marks, choose Grid Setup from the View menu. 

Disable this command to hide the grid. 



Grid Setup: View menu

Sets the default grid settings. Grid settings are saved with each CorelFLOW file.

Dialog Box Options

Show Grid
Check the Show Grid box to draw the grid on the diagram.

Snap to Grid
Check the Snap to Grid box to constrain objects to the grid.

Grid Frequency
Set the Grid Frequency in points/inches by typing the units in the text field or by using the arrows to the 
right of the text field.



Refresh Window: View menu

Redraws the current diagram.





Symbol: Format menu

Formats any of the following:

· Symbols located in a smart library.

· Existing shapes and symbols in the workspace, including rectangles, ellipses, and polygons.

An example of the shape or symbol is displayed in the lower right corner of the dialog box.

Dialog Box Options

Pen
Choose a solid, dashed, or dotted outline. Set the width from zero to ten. Click the Color button and 
choose an outline color.

Fill
Choose a transparent, solid, or patterned fill type. Click the Color button and choose a fill color.



Line: Format menu

Formats any of the following:

· Line style located in a smart library.

· Existing lines in the workspace.

An example of the line will be displayed in the lower right corner of the dialog box.

Dialog Box Options

Pen
Choose a solid, dashed, or dotted pen. Set the line width from zero to ten. Click the Color button and 
choose a pen color. 

Line Type
Choose either a straight or curve line type.

Arrows
Click the Start or End button to choose start and end arrows. An 'X' is displayed if no arrow is chosen.



Text: Format menu

Formats any of the following:

· Text style located in a smart library.

· Existing text in the workspace.

An example of the text is displayed in the lower right corner of the dialog box.

Dialog Box Options

Background Mode
· Default: Unconnected text and text connected to shapes will have a transparent background. Text 

connected to a line will have an opaque background.

· Opaque: The background of the text string is filled with the text background color.

· Transparent: The background of the text string is transparent regardless of the text background 
color.

Symbol-Linked Text
· Normal: Text is neither wordwrapped or sized to text.

· Wordwrap: Text is restricted to stay within the boundary of a host shape.

· Size to Text: Shapes resize to encompass connected text.

Font
Choose a font, font style, and size from the list box. Choose underline and/or strikeout.

Justification
Choose Left, Center, Right or Default Justification. If you choose Default justification, text connected to 
shapes and lines is center-justified, and unconnected text is left-justified.

Text Color
Click the Color button to choose a text color.

Background Color
Click the Color button to choose a background color.



Arrow: Format menu

Adds a new arrow head to the end of a line. Click the left mouse button to choose a new arrow or None.



Apply Style: Format menu

Applies the attributes of the chosen symbol, line, or text in a smart library to selected objects in your 
diagram.



 



 



Align: Arrange menu

Opens the Align dialog box used for aligning objects.

Dialog Box Options

Left, Center, Right
Enable these options to align objects vertically to the left, center, or right of selected objects. Disable 
them to cancel alignment.

Top, Center, Bottom
Enable these options to align objects horizontally to the top, center, or bottom of selected objects. Disable
them to cancel alignment.

Center on Page
Enable this option box to center selected objects on the page. If you selected more than one object, you 
may want to group them before using this option.

Align to Grid
Enable this option to align all selected objects to the grid.

Distribute
Enable this option to equally space selected objects. The Distribute option is available only when left, 
center, right, top, center, or bottom have been enabled. Use the arrows to the right of the distribute box to
set the amount of spacing. Choose Center to equally space between object centers, or choose Edges to 
equally space between object edges.



Column Align: Arrange menu

Vertically aligns selected objects.



Row Align: Arrange menu

Horizontally aligns selected objects.



To Front: Arrange menu

Moves selected objects to the front of the current layer. Objects located in front will be drawn and printed 
last.



To Back: Arrange menu

Moves selected objects to the back of the current layer. Objects located in back will be drawn and printed 
first.



Rotate: Arrange menu

Rotates selected objects. Move the rotate cursor over an edit handle and press and drag the left mouse 
button to rotate.



Scale & Mirror: Arrange menu

Scales and/or mirrors objects horizontally and vertically.

Dialog Box Options

Mirror
Check the horizontal and/or vertical mirror boxes to flip selected objects relative to each object's center 
point.

Scale
Use the arrows to the right of the Horizontal and/or Vertical Scale boxes to set the scale factor for 
selected objects. Enter a value above 100% to increase the size, and a value below 100% to decrease 
the size.



Grouped: Arrange menu

Groups selected objects, allowing you to select and manipulate them as a single unit. A checkmark 
appears beside the command when a group of objects is selected. Selecting a group of objects and 
choosing the Grouped command again ungroups them. The checkmark beside the command disappears.



Join: Arrange menu

Joins two end points of a line to make one continuous line. Note that a curve may not span across a 
joined point.



Break Apart: Arrange menu

Breaks apart lines or symbols. When you break a line, the points of the line separate. You can also break 
a line at individually selected points. When you Break Apart a symbol, it separates into its original 
components.



Layer Setup: Arrange menu

Opens the Layers dialog box, where you specify layer attributes.

Dialog Box Options

Current Layer
Type the number of the layer (1-10) where new objects will be added.

Active
Objects may be added and edited on active layers. 

Hidden
Objects on hidden layers will not be displayed or printed.

Protected
Objects on protected layers can not be selected or edited.



Change Layers: Arrange menu

Changes selected objects to a new layer.

Dialog Box Options

Selected objects are on 
Displays the layers of selected objects. 

Move selected objects to layer 
Type the number of the layer (1-10) where all selected objects will be moved.



New: Project menu
Opens the New Project dialog box for opening a new CorelFLOW project.

Dialog Box Options
File Name
Type the new project file name in the File Name box. 

New Subdirectory
Choose the directory in which the project is stored. If desired, create a new directory by naming it in the 
New Subdirectory box.

List Files of Type
Choose a format for the file.

Drives
Choose the drive in which the new project is to be stored.



Open: Project menu
Opens the Open Project dialog box for opening a CorelFLOW project.

Dialog Box Options
File Name
Choose the project name from the File Name list. 

New Subdirectory
Choose the directory in which the project is stored. 

List Files of Type
Choose a format for the file.

Drives
Choose the drive in which the project is stored.



Save As: Project menu
Opens the Save As Project dialog box for saving a project under a new name and in a different directory.

Dialog Box Options
File Name
Type the name of the new project in the File Name box. 

New Subdirectory
Create a new directory by typing it in the New Subdirectory box. You must name a new directory.

List Files of Type
Highlight the desired format.

Drives
Highlight the drive in which to store the project.



Open Child: Project menu

Opens a defined child or application in a CorelFLOW project. If no child has been defined, CorelFLOW 
prompts for a file name or command string. This option is only available if a text object or shape with 
connected text is selected.



Open Parent: Project menu

Opens a parent in a CorelFLOW project. If more than one parent file exists, the Open Parent dialog box 
opens. Choose a file and click the Open button.



Define Child Link: Project menu

Creates a project link to another CorelFLOW diagram or launches an application. A text object or shape 
with connected text must be selected for this option to be enabled.

Dialog Box Options

File Name/Command
Name a child. If the desired child is a CorelFLOW diagram, type the name in the File Name/Command 
box. If the desired child is not a CorelFLOW diagram, type a command string in the File Name/Command 
box (you may launch another application or launch and open a file from another application). For 
example, open a file on the notepad by naming the executable and the file name: c:\notepad.exe c:\
notes\example.txt.

CorelFLOW Diagram
Create a project link to a CorelFLOW diagram. The CorelFLOW diagram is named in the File 
Name/Command box. 

Other Application/File
Create a project link to another application or file generated by another application. The executable 
and/or file name is named in the File Name/Command box.

Open
Saves the project link and opens the child.

OK
Saves the project link and returns to the current CorelFLOW file.

Cancel
Cancels any changes made in the Define Child Link dialog box and returns to the current CorelFLOW 
diagram.

Browse
Click to search directories and drives for the desired file.



Insert Parent: Project menu

Inserts a new parent above the current file. Type the name of the new file and click OK (only new 
CorelFLOW diagrams can be inserted in this manner). The Insert Parent option is available only if the 
current diagram is already located within a project.





Contents: Help menu

Opens the Contents screen of the CorelFLOW online help. Click one of the icons in the Help Contents 
screen.

Contents Options

Using Help
Opens a help file on how to use online Help.

Screen
Shows information on the CorelFLOW screen.

Menus
Shows information on menu items.

Basics
Gives instructions on basic CorelFLOW operations.

How To...
Gives procedures on CorelFLOW operations.

Shortcuts
Gives CorelFLOW keyboard shortcuts.

Glossary
Lists CorelFLOW definitions.

Support
Opens CorelFLOW Support help file.



Search For Help On: Help menu

Performs a topic search on keywords or phrases.

Dialog Box Options

Keyword List
Type or select a key word or phrase to search.

Show Topics
Click the Show Topics button to display all related topics in the Topic List.

Topic List
Displays all topics associated with the key word or phrase previously searched.

Go To
Clicking the Go To button moves to a more detailed description of the highlighted topic in the Topic List.



Tutorial: Help menu

Opens the CorelFLOW Tutorial. Double-click to choose Beginner, Intermediate, or Advanced levels.

Note: The tutorial is a project created with CorelFLOW.



About CorelFLOW: Help menu

Provides facts about CorelFLOW and the current diagram, including:

· Version number

· Copyright

· The name to which the copy is registered

· Serial number

· Amount of free disk space and memory

Dialog Box Options

System Info
Choose a category in the Choose a Category list box for information on that category.

Save
Saves the displayed information in a new file 'sysinfo.txt' located in the \CONFIG directory.



Library Menu
· Roll Down
· Roll Up
· Arrange
· Arrange All
· Close
· Close All
· Save Library
· Save Library As
· Add Object, Symbol
· Add Object, Line Style
· Add Object, Text Style
· Edit Object, Edit
· Edit Object, Name
· Edit Object, Delete



Roll Up: Library menu

Reduces the library to its Library Title Bar. You can also roll up the library by double-clicking the Library 
Title Bar.



Roll Down: Library menu

Opens the library so you can view all predefined symbols, line styles, and text styles. You can also roll 
down the library by double-clicking the Library Title Bar.



Arrange All: Library menu

Arranges all open libraries in a row starting from the left side of the screen.



Arrange: Library menu

Rolls up the open library and places it in the top right corner of the drawing window.



Save Library: Library menu

Saves the current library.



Save Library As: Library menu

Saves the current library under a new name or directory.

Dialog Box Options

File Name
Either type the file name in the entry box or highlight a file name in the list box.

Directories
Select the desired directory in which the library is to be stored.

Drives
Choose the desired drive on which to save the library.



Edit Object, Edit: Library menu

Changes the attributes of the currently selected symbol, line style, or text style from the library. When you
choose Edit Object and then choose Edit from the flyout menu, a dialog box opens for editing the type of 
object that's currently selected in the library. 

Dialog Box Options

If editing a text style:
Background Mode
Choose either Default, Opaque, and Transparent.

Symbol-Linked Text
Choose either Normal, Wordwrap, or Size to Text.

Font
Choose a font, font style, and size from the list box.

Justification
Choose Left, Center, Right or Default Justification.

Text Color
Click the Color button and choose a text color.

Background Color
Click the Color button and choose a background color.

If editing a line style:
Pen
Choose a solid, dashed, or dotted pen type. Set the pen width from zero to ten. Click the Color button
and choose a pen color. 

Line Type
Choose a straight or curved line type.

Arrows
Click the Start and End buttons and choose start and end arrows.

If editing a symbol:
Pen
Choose a solid, dashed, or dotted pen type. Set the pen width from zero to ten. Click the Color button
and choose a pen color.

Fill
Choose a transparent, solid, or patterned fill type. Click the Color button and choose a fill color.



Edit Object, Edit Name: Library menu

When you choose Edit Object and then choose Edit Name from the flyout menu, a dialog box opens 
where you edit the name of the currently selected symbol, line style, or text style from the library.



Edit Object, Delete: Library menu

When you choose Edit Object, Delete, the currently selected symbol, line style, or text style is deleted 
from the library.



Add Object, As Symbol: Library menu

Adds the selected object to the library as a symbol.

Dialog Box Options

Pen
Choose a solid, dashed, or dotted pen type. Set the pen width from zero to ten. Click the Color button to 
choose a pen color.

Fill
Choose a transparent, solid, or patterned fill type. Click the Color button to choose a fill color.



Add Object, As Line Style: Library menu
Adds a line style to the library.

Dialog Box Options

Pen
Choose a solid, dashed, or dotted pen type. Set the pen width from zero to ten. Click the Color button to 
choose a pen color. 

Line Type
Choose a straight or curve line type.

Arrows
Click the Start and End buttons and choose start and end arrows.



Add Object, As Text Style: Library menu

Adds a text style to the library.

Dialog Box Options

Background Mode
· Default: Unconnected text and text connected to shapes will have a transparent background. Text 

connected to a line has an opaque background.

· Opaque: The background of the text string is filled with the text background color.

· Transparent: The background of the text string is transparent regardless of the text background 
color.

Symbol-Linked Text
· Normal: Text is neither wordwrapped or sized to text.

· Wordwrap: Text is restricted to stay within the boundary of a host shape.

· Size to Text: Shapes resize to encompass connected text.

Font
Choose a font font style, and size from the list box. Choose underline and/or strikeout.

Justification
Choose Left, Center, Right or Default Justification. If you choose Default justification, text connected to 
shapes and lines is center-justified, and unconnected text is left-justified.

Text Color
Click the Color button to choose a text color.

Background Color
Click the Color button to choose a background color.



Close: Library menu

Closes the current library. CorelFLOW prompts you to save any changes you've made to the library. 
Double-click  to close the library.



Close All: Library menu

Closes all open libraries. 



Project Overview

You can develop interactive training programs, tutorials, or multi-level presentation material using 
CorelFLOW's project management features. 

You begin by creating a CorelFLOW project file which tracks the organization of the diagrams in your 
project. Then, you establish project links between text objects in CorelFLOW diagrams and other 
diagrams or applications. CorelFLOW gives you the flexibility to create as many project links as you need
to build a dynamic, interactive project. 

For instance, you could link the term "organizational chart" in one diagram to a flow chart depicting the 
different levels within a company. Then, when a user double-clicked on the text, an organizational chart 
would display. The text string in the example is called a Parent Object because it is linked to a lower-
level file. The organizational chart is called a Child File because it is linked to a higher-level parent file. 

You can also create links between text objects and other applications. For example, you could create a 
link that causes Microsoft Word to launch and display a particular file when a user double-clicks on a text 
string.

See also

Creating a Project

Exiting a Project

Opening a Project

Opening a Parent

Opening a Child



Creating a New Project

To create a new project: 

1. Choose New from the Project menu.

2. Name the project in the File Name box.

3. Select a directory for the new project by clicking on a drive letter and a directory name. You can 
also create a new directory by typing a name in the New Subdirectory box. 

4. Choose OK. You are prompted to save changes to any previously unsaved work. 

CorelFLOW displays a blank page on which you can create a diagram, choose parent objects and 
establish links to child files. Whenever you open the project again, this first file, called a Root File, will    
open.

Note: The CorelFLOW title bar displays the project and file names. 

To create a new project using an existing CorelFLOW diagram:

1. Open or create a CorelFLOW Diagram. This file must NOT be part of an existing project.

2. Select an object to be the parent object. This must be either a text object, a symbol with 
connected text or a shape with connected text.

3. Choose Define Child Link from the Project menu. 

4. Choose one of the following to create a child link: 

CorelFLOW Diagram: Click CorelFLOW Diagram and enter the name of the Child File you want 
to link in the File Name/Command box. You can also use the Browse button to search for an 
existing file. If the chosen CorelFLOW diagram is not in the current project directory, it will be 
moved to that directory.

Other Files/Applications: Click Other File/Application and type the executable and/or file name 
in the File Name/Command box.

5. Choose OK to save the link or Open to save the link and open the child. 

6. When the program prompts, type the name of the new project in the File Name box.

7. Choose the project directory by double-clicking on a name in the Directories list box. If desired, 
create a new directory for the project by naming it in the New Subdirectories box.

See also

Adding a Child

Inserting a Parent

Opening a Child

Opening a Parent





Opening a Project

To open a project with the Root File displayed:

1. Choose Open from the Project menu.

2. Choose the directory where the project is located by double-clicking on a Drive and Directory 
name.

3. Choose the project name in the File Name box.

4. Choose OK. The project opens with the root file displayed.

To open a project with an alternate file displayed:

1. Choose Open from the File menu.

2. Choose the directory where the project is located by double-clicking on a Drive and Directory 
name.

3. Choose the file from the project in the File Name box.

4. Choose OK. The named file is opened within the project.

See also

Exiting a Project

Opening a Child

Opening a Diagram

Opening a Parent



Saving a Project to a Different Location 

To save a project to a different location:

1. Open the project that you want to save to a different location.

1. Choose Save As from the Project menu.

2. Type the name of the project in the File Name box.

3. Type the name of the new directory in the New Subdirectories box.

4. Choose OK. A new project directory is created and all files in the project are copied to the new 
location.

See also

Exiting a Project

Opening a Project



Opening a Child

Open a child using any of the following methods:

· Double-click a parent object.

· Select the parent object and choose Open Child from the Project menu.

· Select the parent object and press PAGE DOWN on the keyboard.

If a child has already been defined in the Define Child Link dialog box, the child opens. If not, the Define 
Child Link dialog box opens (see Adding a Child).

See also

Adding a Child

Creating a Project

Opening a Parent



Opening a Parent

To open a parent:

1. While working in a child, choose Open Parent from the Project menu or press PAGE UP on the 
keyboard. If there is only one parent, CorelFLOW opens that file.

2. If there is more than one parent, select the parent in the Open Parent dialog box and click the 
Open button.

The Open Parent option on the Project menu is only enabled if the current child has at least one parent.

See also

Adding a Child

Inserting a Parent

Opening a Child



Adding a Child

To add a child to a project:

1. Select the text, symbol with connected text, or shape with connected text to be the parent object 
of the added file.

2. Choose Define Child Link from the Project menu.

3. Choose one of the following to create a child link: 

CorelFLOW Diagram: Click CorelFLOW Diagram and enter the name of the Child File you want 
to link in the File Name/Command box. You can also use the Browse button to search for an 
existing file. If the chosen CorelFLOW diagram is not in the current project directory, it will be 
moved to that directory.

Other Files/Applications: Click Other File/Application and type the executable and/or file name 
in the File Name/Command box.

4. Choose OK to save the link, or choose Open to save the link and open the child. 

See also

Creating a Project

Inserting a Parent Object

Opening a Child

Opening a Parent



Inserting a Parent

To insert a parent to a project:

1. While working in a child, choose Insert Parent from the Project menu.

2. Enter a name for the new file. The named file must be a new CorelFLOW diagram. Existing 
diagrams can not be added to a project in this manner.

3. Choose OK. The new diagram opens and is inserted into the project between the current diagram
and its parent. A text object is inserted into the diagram, this text object is the parent object which
links to the child.

If the current file already has one or more parents, Insert Parent changes these parents to link to the 
inserted diagram. The inserted diagram links to the current diagram.

Note: This procedure can still be done if the current file has no parents. This is how to create a new root 
file.

See also

Adding a Child

Opening a Parent

Opening a Child



Changing a Project Link

To change a project link:

1. Select the parent object containing the link.

2. Choose Define Child Link from the Project menu.

3. Name a new child using the CorelFLOW Diagram or Other File/Application options. 

4. Choose OK to save the project link or choose Open to save the link and open the new child.

See also

Deleting a Project Link

Opening a Child

Deleting a File From a Project



Deleting a Project Link

To delete a project link:

1. Select the parent object containing the link.

2. Choose Define Child Link from the Project menu.

3. Remove all text from the File Name/Command box to delete the link.

4. Choose OK to confirm the changes.

See also

Changing a Project Link

Opening a Child

Deleting a File From a Project



Deleting a File From a Project

Before deleting a file from its project directory, you should remove all links to and from other CorelFLOW 
diagrams 

To remove links to child files:

1. Open the file to be deleted (see Opening a Diagram).

2. Select each parent object in the diagram and perform steps 3 to 5.

3. Choose Define Child Link from the Project menu.

4. Delete all text from the File Name/Command box to remove the link to the child file.

5. Choose OK.

To remove links to parent files:

1. Choose Open Parent from the Project menu to view a list of all files linking to the current file. 
These links must be deleted while in the parent files.

2. Open each parent file referenced in the list (see Opening a Diagram) and perform steps 3 to 6.

3. Select the parent object that is linked to the file you want deleted.

4. Choose Define Child Link from the Project menu.

5. Delete all text from the File Name/Command box to remove the link to the child file.

6. Choose OK.

To delete the file from the File Manager:

1. Open or switch to the File Manager.

2. Select the drive and directory where the file is saved.

3. Select the file in the File Name list box.

4. Press Delete on the keyboard to remove the file from the project directory.

See also

Changing a Project Link

Deleting a Project Link



Exiting a Project

To exit a project:

· Open any diagram which is not part of the current project (see Opening a Diagram). 

-or-

· Choose New from the File menu or click  on the Ribbon Bar.

See also

Opening a Project



 Technical Support
The Technical Support Help file contains information pertaining to:

· Corel Support Services

· Common Error Messages

· Import and Export File Filters

· The Control Polygon

· The Registration Database

· other technical information

Click the highlighted text below to open the Technical Support Help file. 
Technical Support





 



Drawing Window

The large white area of the CorelFLOW window. You can draw anywhere in the drawing window, but only 
objects on the printable page are printed.



Printable Page

The rectangle with the drop shadow in the drawing window represents the Printable Page. You can draw 
beyond the borders of the Printable Page but normally only objects on the printable page are printed.



Control Menu box 

The Control Menu box is located in the uppermost left corner of the screen. When enabled, commands for
sizing and positioning the window are displayed:

· Restore

· Move

· Size

· Minimize

· Maximize

· Close

· Switch To



Maximize button 

Located in the upper right corner of the CorelFLOW window if not fully expanded. Click the Maximize 
button to expand the window to fill the entire screen.



Minimize button 

Located in the upper right corner of the CorelFLOW window. Click the Minimize button to shrink the 
window to an icon at the bottom of the screen.



Restore button 

Located in the upper right corner of the CorelFLOW window. Click the Restore button to return the 
window to the previous size and location.



Title Bar 

The Title Bar at the top of the CorelFLOW window displays the program title and the currently opened file 
name. Press and drag the left mouse button on the Title Bar to move the window. Double left mouse click 
on the Title Bar to maximize the window. The following buttons may also be on the Title Bar:

 Control Menu box

 Minimize button

 Maximize button

 Restore button



Menu Bar

The Menu Bar is located directly under the title bar and lists all menu titles:

· File Menu

· Edit Menu

· View Menu

· Format Menu

· Arrange Menu

· Project Menu

· Help Menu



Ribbon Bar

The Ribbon Bar is located just under the Menu Bar and above the Text Ribbon Bar. The Ribbon Bar 
displays the following 18 buttons:

New Diagram: Start a new diagram.

Open Diagram: Open an existing diagram via the Open Diagram dialog box.

Save Diagram: Save the current diagram. If the diagram has not been previously saved, save the current
diagram via the Save As dialog box.

Print Diagram: Print the current diagram using the current printer settings.

Cut: Remove selected objects and place them on the clipboard.

Copy: Place a copy of selected objects on the clipboard.

Paste: Place objects on the clipboard in the workspace at a specified point.

Arrows: Choose arrows for selected line ends.

Apply Style: Apply the current style in a library to selected objects.

Grid Snap: Enable to constrain objects to the grid. Disable to no longer constrain objects to the grid.

Column Align: Vertically align selected objects.

Row Align: Horizontally align selected objects.

Rotate: Rotate selected objects.

Group: Enable to constrain selected objects to act as a single unit. Disable to ungroup selected objects.



To Front: Move selected objects to the front of the current layer.

To Back: Move selected objects to the back of the current layer.

 Open Library: Open an existing library via the Open Library dialog box.



Text Ribbon Bar

The Text Ribbon Bar is located just under the Ribbon Bar and above the workspace. The Text Ribbon Bar 
displays nine text options:

Font: Change the font of selected text. Click the side arrow to view font options, or type the font name in 
the font edit field.

 Size: Change the size of selected text. Click the side arrow to view size options, or type any size in the 
size edit field.

 Bold: Turn bold format on or off selected text. 

 Italic: Turn italic format on or off selected text.

 Underline: Turn underline format on or off selected text.

 Left Justification: Change a selected text object to left justification.

 Center Justification: Change a selected text object to center justification.

 Right Justification: Change a selected text object to right justification.

 Default Justification: Change a selected text object to default justification. Connected text is center 
justified and unconnected text is left justified.

 Spell Check: Check the spelling of selected text.



Pick Tool 

Select, edit or format objects. Enter text. Push to a child file.

· Select an object by clicking the left mouse button on the object or marquee select it.

· Move an object by dragging the object with the left mouse button.

· Resize an object by dragging an edit handle after and object has been selected.

· Format an object with a right mouse button click.

· Enter text by placing the text caret with a left mouse button click and begin typing.

· Push to a child file with a double left mouse button click on text, or a symbol with connected text.



Zoom Tool  

Opens a menu with six viewing options:

 Zoom In: Click the left mouse button to zoom in on the clicked point by a factor of two. Drag the left 
mouse button to zoom in on a specific area drawn with a rectangle.

 Zoom Out: Zooms out by a factor of two.

 Actual Size: Sets the zoom magnification to 100%.

 Fit Selected: Fills the viewing area with previously selected objects.

 Show All: View all objects in the current diagram.

 Show Page: View the current page.



Line Tool 

Draws lines.

· Begin drawing a line with a left mouse button click.

· Add points to a line with left mouse button clicks.

· End a line with either a right mouse button click or a double left mouse button click.

· Lines drawn with the Line tool are automatically assigned the default format assigned to the tool.

· Constrain drawing horizontally and vertically by holding down the CTRL key while drawing lines.

· Switch to the Pick tool with a right mouse button click.



Curve Tool  

Draws curves.

· Begin drawing a curve with a left mouse button click.

· Add control points to a curve with left mouse button clicks.

· End a curve with either a right mouse button click or a double left mouse button click.

· Curves drawn with the Curve tool are automatically assigned the default format assigned to the tool.

· Constrain drawing horizontally and vertically by holding down the CTRL key while drawing curves.

· Switch to the Pick tool with a right mouse button click.



Rectangle Tool 

Draws rectangles and squares.

· Draw a rectangle with a left mouse button click and drag.

· Draw a rectangle in relation to the center while holding down the SHIFT key.

· Draw a square while holding down the CTRL key.

· Objects drawn with the Rectangle tool are automatically assigned the default format assigned to the 
tool.

· Switch to the Pick tool with a right mouse button click.



Ellipse Tool  

Draws ellipses and circles:

· Draw an ellipse with a left mouse button click and drag.

· Draw an ellipse relative to the center while holding down the SHIFT key.

· Draw a circle while holding down the CTRL key.

· Objects drawn with the Ellipse tool are automatically assigned the default format assigned to the tool.

· Switch to the Pick tool with a right mouse button click.



Polygon Tool  

Draws a polygon.

· Begin drawing a polygon with a left mouse button click.

· Add points to a polygon with left mouse button clicks.

· Add the last point of a polygon with either a right mouse button click or a double left mouse button 
click. A line is automatically drawn between the start and end points.

· Constrain drawing horizontally and vertically by holding down the CTRL key while drawing the 
polygon.

· Polygons drawn with the Polygon tool are automatically assigned the default format assigned to the 
tool.

· Switch to the Pick tool with a right mouse button click.



Text Tool  

Enters text.

· Click the left mouse button to place the text caret and begin typing.

· Text entered with the Text tool is automatically assigned the default format assigned to the tool.

· Click the left mouse button on an existing text object to begin editing text.

· Text edited with the Text tool is automatically assigned the default format of the selected text object.

· Switch to the Pick tool with a right mouse button click.



Pen Tool  

Opens a menu with nine pen options:

 Hidden Line: Change the selected pen width to zero points.

 Hairline: Change the selected pen width to .2 points.

 Dashed Line: Change selected pen type to dashed.

 Dotted Line: Change selected pen type to dotted.

 Width 1: Change selected pen width to 1 point.

 Width 2: Change selected pen width to 2 points.

 Width 3: Change selected pen width to 3 points.

 Width 4: Change selected pen width to 4 points.

 Width 5: Change selected pen width to 5 points.



Fill Tool  

Opens a menu with eight fill options:

 Transparent Fill: Change selected objects to a transparent fill.

 Uniform Fill: Change selected objects to a uniform fill.

 Fill Pattern1: Change selected objects to a pattern1 fill.

 Fill Pattern2: Change selected objects to a pattern2 fill.

 Fill Pattern3: Change selected objects to a pattern3 fill.

 Fill Pattern4: Change selected objects to a pattern4 fill.

 Fill Pattern5: Change selected objects to a pattern5 fill.

 Fill Pattern6: Change selected objects to a pattern6 fill.



Library Menu box 

The Library Menu box is located in the upper left corner of every open library. Click to view the following 
menu options:

· Roll Down
· Roll Up
· Arrange
· Arrange All
· Close
· Close All
· Save Library
· Save Library As
· Add Object, As Symbol
· Add Object, As Line Style
· Add Object, As Text Style
· Edit Object, Edit
· Edit Object, Name
· Edit Object, Delete



Library Title Bar 

The Library Title Bar at the top of a library displays the library name. 

· Click  to open the Library menu.
· Press and drag the left mouse button on the Library Title Bar to move the library.
· Double-click on the Library Title Bar to minimize or maximize the library.



Smart Library

Each Smart Library holds a collection of predefined text, lines, and symbols. Resize, move, maximize, 
and minimize libraries. Open more than one library at a time. Create new libraries.

· Draw library objects with a left mouse button click, drag, and drop in the current diagram. Add 
symbols, lines and text to your library by dragging objects from the diagram to the library with the left 
mouse button.

· Apply styles to existing objects in a diagram with a left mouse button click, drag, and drop on objects 
in a diagram. Replace symbols, lines and text in your library by dragging objects from your diagram to
a library with the right mouse button.

· Press and drag the left mouse button on the edge of a library to resize the library.



Color Palette 

The Color Palette is located at the bottom of the screen. It displays 256 colors and is used to change the 
color of selected objects. Click the left mouse button on a color to choose a fill or text color. Click the right 
mouse button to choose a pen or background text color.

 Scrolls the Color Palette to the left with a left mouse button click. Use the right mouse button to move 
up one row on the Color Palette. 

 Gives a transparent fill or returns a text color to black with a left mouse button click. Returns a pen 
color to black or gives text a transparent background with a right mouse button click.

 Displays all 256 colors.

 Scrolls the Color Palette to the right with a left mouse button click. Use the right mouse button to 
move down one row on the Color Palette.



Scroll Bars

The Horizontal Scroll Bar is located just below the drawing window. The Vertical Scroll Bar is located to 
the right of the drawing window. Both may be used in the following manner:

· Click on the scroll arrows to move 1/12 of the viewing area.

· Click on the scroll bar directly to move 5/6 of the viewing area.

· Drag the scroll button to continuously scroll the workspace.



Status Line 

The Status Line is an optional bar located at the very bottom of the screen. The Status Line displays the 
following information (from left to right):

Status Line Hints: Instructions and explanations that lead you through the basics so you can 
immediately start drawing diagrams. When the pointer is over a button on the Ribbon Bar or Text Ribbon 
Bar, an explanation of that option is displayed. While you are performing operations, instructions are 
displayed. These instructions often contain information on secondary features accessed via the right 
mouse button, the CTRL key, and the SHIFT key.

Mouse Position (in inches): The origin of the coordinate system is the upper left corner of the page.

If the cursor is over a library, the Mouse Position displays the name of the symbol, line, or text object.

Number Lock: NUM indicates that the keyboard number lock is on.

Text Insertion Mode: INS indicates that new text will be inserted in between existing characters; 
otherwise, typed text will overwrite existing characters.

To show or hide the Status Line:

1. Choose Preferences from the File menu.

2. Check the Status Line box to show the Status Line.

3. Uncheck the Status Line box to hide the Status Line.





Smart Library Overview

CorelFLOWs Smart Libraries make drawing easier than ever. Point and click to select symbols, line 
styles, or text styles. CorelFLOW comes with 90 different Smart Libraries containing over 2,000 symbols. 
You can add symbols, line styles and text styles to Smart Libraries, create new Smart Libraries, and swap
objects between Smart Libraries. You can open more than one Smart Library at a time, and roll up a 
Smart Library for easy access and more space to draw. Symbols, line styles, and text styles may be used
to create new objects or applied to existing objects.

Commands in the Smart Library System menu let you roll the library up and down, arrange all the Smart 
Libraries you have open on your screen, add and edit objects, and save libraries. You access the Smart 

Library System menu by clicking the  on the top left of the Smart Library's title bar. 

For help on a Smart Library System menu item, click the item on the Smart Library System menu shown 
below.

See also

Creating a New Smart Library

Drawing Lines from a Smart Library

Drawing Symbols from a Smart Library

Editing an Object from a Smart Library

Entering Text from a Smart Library

Opening a Smart Library



Roll Up
Choosing Roll Up rolls up the Smart Library.



Arrange

Choosing Arrange rolls up the Smart Library and positions it in either the top right or left corner of the 
drawing window.



Arrange All

Choosing Arrange All rolls up all open Smart Libraries and positions them in the top right and left corners 
of the drawing window.



Close

Choosing Close closes the Smart Library.



Close All

Choosing Close All closes all open Smart Libraries.



Save Library

Choosing Save Library saves any changes you've made to the Smart Library since you opened it.



Save Library As

Choosing Save Library As saves the Smart Library under a new name.



Add Object

Choosing Add Object adds a selected object to the Smart Library as a symbol, line style, or text style. 



Edit Object

Choosing Edit Object allows you to edit an object you've selected from the Smart Library. When you 
choose Edit Object, a flyout menu opens with the following options:

Name
Opens the Symbol Name dialog box, where you enter a new name for the object. 

Edit
Opens the Symbol Attributes dialog box, where you edit the object's attributes. 

Delete
Deletes the object from the Smart Library. Once you delete an object from a Smart Library, you cannot 
retrieve it using the Undo command in the Edit menu. If you delete an object by accident, close the Smart
Library without saving any changes 



Creating a New Smart Library 

To create a new Smart Library:

1. Choose Smart Library, New from the File menu. An empty Smart Library is created.

2. Add text styles, line styles, and symbols to the Smart Library (see Adding Symbols to a Smart 
Library, Adding Line Styles to a Smart Library and Adding Text Styles to a Smart Library).

3. Click  and choose Save Library.

4. Specify a name for the new Smart Library in the File Name box.
To save the Smart Library in a location other than the current directory, select the drive from the 

Drives box and directory from the Directories box.
5. Choose OK.

See also

Opening a Smart Library

Saving a Smart Library



Opening a Smart Library 

To open a Smart Library:

1. Choose Smart Library, Open from the File menu or click  on the Ribbon Bar.

2. Choose a Smart Library from the File Name list.
If the Smart Library you want is not in the current directory, choose the desired drive from the 

Directories box.

Note: All Smart Libraries that are open when you exit CorelFLOW are loaded at the same position the 
next time you open CorelFLOW.

See also

Creating a New Smart Library



Saving Changes to a Smart Library 

To save changes to a Smart Library, click  on the Smart Library and choose Save Library.

To save a Smart Library under a new name:

1. Click  on the Smart Library and choose Save Library As.

2. Name the Smart Library in the File Name box. 
To save the Smart Library in a location other than the directory shown, choose the desired 

directory from the Directories box.
3. Choose OK. If a Smart Library with the specified name already exists, you are prompted to 
overwrite the existing Smart Library. 

See also

Creating a New Smart Library

Opening a Smart Library



Closing a Smart Library 

To close a Smart Library:

1. Click  on the Smart Library.

2. Chose Close. You are prompted to save any changes you made to the Smart Library.

Tip: Close a Smart Library by double-clicking  on its title bar.

To close all open libraries:

1. Click  on any open Smart Library.

2. Choose Close All. You are prompted to save any changes you've made to the Smart Libraries.

See also

Opening a Smart Library

Rolling a Smart Library Up or Down



Moving a Smart Library 

To move a Smart Library:

1. Move the cursor over the title bar of the Smart Library.

2. Click the title bar and drag it to a new location.

3. Release the left mouse button.

See also

Arranging Smart Libraries

Rolling a Smart Library Up or Down

Sizing a Smart Library



Sizing a Smart Library 

To size a Smart Library:

1. Move the cursor over the edge or corner of the Smart Library.

2. Press the left mouse button drag the mouse to size the library.

3. Release the left mouse button.

See also

Arranging Smart Libraries

Moving a Smart Library

Rolling a Smart Library Up or Down



Rolling a Smart Library Up or Down 

To roll up/down a Smart Library:

1. Click  on the desired Smart Library.

2. If the Smart Library is minimized, choose Roll Down to roll it down. If the Smart Library is 
maximized, choose Roll Up. The Smart Library reduces to its title bar.

Tip: Click  on a Smart Library to roll it up or down. You may also double-click the title bar of a 
library to roll it up or down.

See also

Arranging Smart Libraries

Moving a Smart Library

Sizing a Smart Library



Arranging Smart Libraries 

To arrange a Smart Library:

1. Click  on the Smart Library.

2. Choose Arrange. The Smart Library is rolled up and placed in the upper right corner of the 
screen.

To arrange all open Smart Libraries:

1. Click  on any Smart Library.

2. Choose Arrange All. All open Smart Libraries are rolled up and placed in the upper right corner of 
the screen.

See also

Moving a Smart Library

Rolling a Smart Library Up or Down

Sizing a Smart Library



Exchanging Objects Between Smart Libraries

Symbols, line styles and text styles are interchangeable between Smart Libraries. 

To move a symbol, line style, or text style to another Smart Library:

1. Open the Smart Libraries in which in which you want to exchange objects (see Opening a Smart 
Library).

2. Press and hold down the left mouse button on the symbol, line style, or text style that you want to
move.

3. Drag the object to the new Smart Library. The object is added where the mouse is released on 
the Smart Library. 

See also

Adding Symbols to a Smart Library

Adding Line Styles to a Smart Library

Adding Text Styles to a Smart Library

Editing Objects from a Smart Library



Editing Smart Library Objects

To edit a symbol, line style, or text style from a Smart Library:

1. Choose a symbol, line style, or text style from a Smart Library using one of the following 
methods:

· Click the right mouse button on the desired object.

· Click the left mouse button on the desired object, click  and choose Edit Object, 
Edit. 

The format dialog box corresponding to the selected object type opens.

2. Change the format.

3. Choose OK. 

To edit an object from a Smart Library using objects in a diagram:

1. Press and hold down the right mouse button on one or more objects in your diagram.

2. Drag the object(s) to a Smart Library and drop them on the desired symbol, line style, or text 
style to edit. The chosen object from the Smart Library is updated.

To edit the name of an object from a library:

1. Choose a symbol, line style, or text style from a library.

2. Click  and choose Edit Object, Edit Name.

3. Type the new name and choose OK.

See also

Formatting Symbols

Formatting Lines

Formatting Text

Applying Styles to Objects

Quick Formatting



Deleting Objects from a Smart Library

To delete a symbol, line style, or text style from a Smart Library:

1. Choose a symbol, line style, or text style from a Smart Library.

2. Click  and choose Edit Object, Delete.

Warning: This operation permanently removes the chosen symbol, line style, or text style. If you delete 
an object accidentally, close the Smart Library without saving any changes (see Closing a Smart Library).

See also

Adding Line Styles to a Smart Library

Adding Symbols to a Smart Library

Adding Text Styles to a Smart Library



Designing a Symbol

The following types of objects may be included in a symbol:

· Symbols

· Lines

· Text

· Graphics (bitmaps & metafiles) generated by other applications

Generally, all you have to do in designing a new symbol is create the symbol image. However, the 
following rules may influence the symbol design.

· Lines connect to any shape contained within a symbol. 

· If more than one shape is directly underneath the pointer, lines connect to the shape that is 
lowest in the drawing order.

· When more than one shape is directly underneath the pointer, text connects to the smaller 
shape.

· Lines can only be connected to shapes. If the new symbol contains only lines and/or text, lines 
will not connect to the symbol. In some cases, you may want to include a rectangle with a hidden 
outline. 

Tip: You may want to disable the Glue option in the Preferences dialog box (see Setting Preferences) 
when designing a new symbol. This allows you to draw lines within shapes without inadvertently 
connecting lines to the shapes.

See also

Adding Symbols to a Smart Library

Editing Objects from a Smart Library

Formatting Symbols



Adding Symbols to a Smart Library 

To add a symbol to a Smart Library:

1. Specify the new symbol in one of the following ways:

· Create the symbol in the drawing window and then select it.

· Deselect all objects in the current diagram, and choose a symbol from a Smart Library.

2. Click  and choose Add Object, As Symbol. 

3. Name the new symbol in the Symbol Name dialog box.
4. Choose OK. The new symbol is added. If a symbol in the Smart Library was selected, 
CorelFLOW places the new symbol immediately before it. If no symbols were selected, the new symbol is
added to the end of the Smart Library.

Tip: Shortcut Steps 1 and 2 by pressing the left mouse button on one or more objects in your diagram 
and dragging them to the Smart Library. The new symbol is added where the mouse button is released.

See also

Adding Line Styles to a Smart Library

Adding Text Styles to a Smart Library

Designing a Symbol

Drawing Symbols from a Smart Library

Editing Objects from a Smart Library

Formatting Symbols



Adding Line Styles to a Smart Library 

To add a line style to a Smart Library:

1. Specify the new line style in one of the following ways:

· Create an example line in the current diagram and select it.

· Deselect all objects in the current diagram, and choose a line style from a Smart Library.

2. Click  and choose Add Object, As Line Style. 

3. Name the line style in the Line Style Name dialog box.
4. Choose OK. The new line style is added and placed before any selected line style from the Smart
Library. If no line styles are selected, the new line style is added as the last line style in the Smart Library.

Tip: Shortcut Steps 1 and 2 by pressing the left mouse button on a line in your diagram and dragging it to
a Smart Library. The new line style is added where the mouse button is released.

See also

Adding Symbols to a Smart Library

Adding Text Styles to a Smart Library

Drawing Lines from a Smart Library

Editing Objects from a Smart Library

Formatting Lines



Adding Text Styles to a Smart Library 

To add text styles to a Smart Library:

1. Specify the new text style in one of the following ways:

· Create example text in the current diagram and select it.

· Deselect all objects in the current diagram, and choose a text style from a Smart Library.

2. Click  and choose Add Object, As Text Style. 

3. Name the new text style in the Text Style Name dialog box.
4. Choose OK. The new text style is added before any selected text style from the Smart Library. If 
no text styles are selected, the new text style is added as the last text style in the Smart Library.

Tip: Shortcut Steps 1 and 2 by pressing the left mouse button on text in your diagram and dragging it to a
Smart Library. The new text style is added where the mouse button is released.

See also

Adding Symbols to a Smart Library

Adding Line Styles to a Smart Library

Editing Objects from a Smart Library

Entering Text from a Smart Library

Formatting Text



Zooming In

To zoom in by a factor of two:

1. Click the Zoom tool in the Toolbox.

2. Click  from the flyout menu.
3. Position the cursor on the area you want to zoom in on and click. The view centers on the point 
you clicked and is magnified by a factor of two.

To zoom in on a specific area:

1. Click the Zoom tool in the Toolbox.

2. Click  from the flyout menu.
3. Position the cursor at the top left corner of the area to be zoomed.
4. Press the left mouse button and drag the cursor until the area you want zoomed is enclosed by a 
rectangle.
5. Release the mouse button. The enclosed objects are magnified to fill the screen.

Note: The zoom magnification range is between 25% - 400%. 

See also

Actual Size

Fit Selected

Show All

Show Page

Zooming Out 



Zooming Out

To zoom out:

Click the Zoom tool from the Toolbox, then click  to zoom by a factor of two.

See also

Actual Size

Fit Selected

Show All

Show Page

Zoom In



Actual Size

To view the actual size of a diagram:

Click the Zoom tool in the Toolbox and then click  to set the zoom magnification to 100%. If any 
objects are selected before you choose 

, the zoom centers on those objects.

See also

Fit Selected

Show All

Show Page

Zooming In

Zooming Out 



Fit Selected

To zoom-in on selected objects:

Click the Zoom tool in the Toolbox and then click  to zoom in on a selected object or group of objects.

See also

Actual Size

Show All

Show Page

Zooming In

Zooming Out 



Show All

To show all the objects in a diagram:

Click the Zoom tool in the Toolbox and then click  to view all the objects in the diagram. 

Note: Sometimes your drawing may contain objects that extend beyond the boundaries of the workspace,
causing them to appear cut off. The Show All option adjusts the size of the drawing so that all the objects 
are displayed. 

See also

Actual Size

Fit Selected

Show Page

Zooming In

Zooming Out 



Show Page 

To show the entire printable page:

Click the Zoom tool in the Toolbox and then click  to view the current page. 

See also

Actual Size

Fit Selected

Show All

Zooming In

Zooming Out 



 

Quick View

To center and magnify an object in a diagram:

1. Point to the part of the diagram you want centered in the window.

2. Press ALT on the keyboard and hold it down.

3. Click the left mouse button. The point you click is moved to the center of the window, and the zoom 
magnification is set to actual size (100%).        

See also

Actual Size

Fit Selected

Show All

Show Page

Zooming In

Zooming Out 



Viewing the Toolbox

To make the Toolbox visible/invisible:

Choose Toolbox from the View menu. Enable Visible to keep the Toolbox in view. (A check mark 
appears beside the command when it's enabled.) Choose the command again to make the Toolbox 
invisible. (The check mark beside the command disappears.)

To make the Toolbox floating/stationary:
· Choose Toolbox from the View menu. Enable Floating to unlock the Toolbox from the stationary 

location at the left of the screen. (A check mark appears beside the command when it's enabled.) 
When the Toolbox is unlocked, you can click its title bar and drag it anywhere in the drawing window. 
Choose the command again to dock the Toolbox back to its position on the left side of the screen.

You can also unlock the Toolbox by holding down the SHIFT key while dragging the Toolbox with the 
left mouse button. 

With a floating Toolbox, click  on the Toolbox. Deselect Floating to return the Toolbox to the 
left side of the screen. 

To view all flyout menus in the Toolbox:
Click  on the Toolbox and disable the Grouped command to view all Toolbox flyout menus, 
including Zoom, Pen, and Fill options. To hide the flyout menus, choose the Grouped command again. 



Snap to Grid

To constrain the cursor to the grid:

Choose Snap to Grid from the View menu (Ctrl+Y) or click the Grid Snap button on the Ribbon Bar. 

Note: Once Snap to Grid has been enabled, objects will snap to the grid lines when you draw or move 
them.

See also

Grid Setup 



Grid Setup

To modify the grid settings:

1. Choose Grid Setup from the View menu to open the Grid Setup dialog box. 

2. Enter a Grid Frequency of up to 72 points per inch.

3. Check the Show Grid box to make the grid visible on the printable page. The grid is drawn in the 
following manner, depending on the zoom magnification:

· Zoom less than 35%: Inch markers are drawn only.

· Zoom greater than or equal to 35 but less than 100%: Every other grid point is drawn between 
inch markers.

· Zoom greater than or equal to 100%: Every grid point is drawn between inch markers. Every 
other grid point is drawn for the interior.

4. Check the Snap to Grid box to have objects you draw and move snap to the grid points.

See also

Snap to Grid 



Hidden Outlines

The Hidden Outlines command in the View menu allows you to show or hide outlines on objects in your 
diagram that are hidden.

To view hidden outlines:

Enable the Hidden Outlines command in the View menu. (A check mark appears beside the command 
when it's enabled. The Hidden Outlines command is enabled by default.) All hidden outlines are drawn 
with a dotted blue outline. 

To hide hidden outlines:

Choose the Hidden Outlines command again to disable it. (The check mark beside the command 
disappears when it's disabled.)

Note: Hidden outlines are not printed.

See also

Drawing Lines

Formatting Lines



 

Child Links

To show all parent objects:

Enable Child Links from the View menu. (A check mark appears beside the command when it's enabled.) 
All Parent objects are marked with a box surrounding the text. Choose Child Links again to disable this 
mode. (The check mark beside the command disappears when it's disabled.)

See also

Project Overview



Speed Move

When Speed Move is enabled, a bounding box representing objects that are moved is displayed rather 
than the objects themselves. This speeds up the move operation.

To enable the Speed Move option:

Choose Speed Move from the View menu to enable the command. (A check mark appears beside the 
command when it's enabled.)    Choose Speed Move again to disable this mode. (The check mark beside 
the command disappears when it's disabled.)

See also

Moving Objects



Refresh Window

To refresh the window:

Choose Refresh Window from the View menu to redraw objects in the Drawing Window. The screen is 
cleared of any remnants left over from earlier CorelFLOW manipulations.



Import File Filters - Technical Notes

Click  for technical information about CorelFLOW's import filters.

 All Files *.*
 Windows Bitmaps *.BMP
 Compuserve Bitmaps *.GIF
 PCX Bitmap *. PCX
 TIFF 5.0 Bitmaps *.TIF
 Adobe Illustrator 1.1, 88, 3.0 *.AI, *.EPS
 Macintosh PICT *.PCT
 Computer Graphics Metafile *.CGM
 Corel Binary Metafile *.BMF



Import - All Files (*.*)
This option automatically senses which file format you are importing and uses the appropriate filter to 
bring the object into CorelFLOW.    



Import - Windows Bitmaps (BMP, RLE, DIB)

Technical Notes

Imports bitmap graphics created in paint programs such as CorelPHOTO-PAINT and Windows Paintbrush
(BMP). CorelFLOW stores bitmaps as DIB's. 

You can import black & white, color and gray-scale bitmap graphics.

Full Image Imports the complete file.

Resample Allows you to change the size and level of resolution of the imported bitmap file. Use the 
Width and Height number boxes to control the size of the file. Adjust Resolution with the 
Horizontal and Vertical number boxes. If you choose Identical values, an adjustment to 
one axis will change the other. 

Windows & OS/2 BMP Bitmaps
CorelFLOW imports BMP files conforming to the Windows BMP specification. They may be either 
color, gray-scale or black & white and will print accordingly, depending on your printer. CorelFLOW 
imports OS/2 bitmaps and also handles RLE's (compressed bitmaps).



Import - Compuserve Bitmaps (GIF)

Technical Notes
CorelFLOW imports GIF files conforming to the 87A and 89A specifications. Preview of interlaced GIF 
images is not supported. CorelFLOW stores bitmap objects as DIB's.



Import - Adobe Illustrator (AI, EPS)

Technical Notes

Imports vector graphics created by Adobe Illustrator for Windows or Macintosh. CorelFLOW stores vector 
objects as native CorelFLOW objects.

CorelFLOW provides full support for all Adobe Illustrator formats up to and including 3.0, Illustrator 88 and
1.1.

Imported Illustrator graphics come into the program as a group of objects. Use the Ungroup command in 
the Arrange menu so you can manipulate objects in the imported graphic.

Note: Any EPS file format other than AI may not import correctly using this filter. Alos, importing AI files 
using the All Files option may not work correctly, so to import AI files successfully, choose the AI import 
filter.



Import Computer Graphics Metafile (CGM)
Technical Notes

Imports vector graphics from such programs as Harvard Graphics, Lotus Freelance and Arts & Letters. 
Also gives you access to graphics produced on mini and mainframe computers, as well as clipart from 
vendors such as MGI and New Vision. CorelFLOW stores vector objects as native CorelFLOW objects.

Bitmaps
Bitmaps are not supported.

Markers
CorelFLOW's CGM import filter only accepts markers supported by the CGM standard. Private-use 
markers are ignored.

Text in CGM Files
· Text will be editable, provided the file was exported by the originating program using the correct text

options (for example, in Harvard Graphics 3.0, you must select the CGM font).
· The typeface you see in CorelFLOW will probably not correspond to the one used in the originating 

program. However, you can easily change this in CorelFLOW.



Import - Macintosh PICT (PCT)
Technical Notes

Imports graphics created in Macintosh programs such as MacDraw. CorelFLOW can import vector and 
bitmap images contained in these files. CorelFLOW stores vector objects as native CorelFLOW objects. 

Objects
Objects that contain a fill and an outline will come into CorelFLOW as a group of two objects. One 
object will be the outline and the other the fill.

Colors
While not always obvious, PICT fills are often bitmap patterns. CorelFLOW will not support these fills. 
They will be replaced by a uniform fill. 

Pattern Outlines
Pattern outlines are converted to a solid color.

Arrowheads and Dashed Lines
These are not supported from MacDraw II into CorelFLOW.

Text
· Text in the PICT file will come into CorelFLOW as editable text.
· If a typeface in the imported file is not available on your system, it will default to the font it most 

closely resembles that is available on your system. 
· Unsupported Macintosh fonts come into CorelFLOW as the default font.
· Text alignment may not quite agree with the original file. This is due to the differences in font size, 

and inter-character and inter-word spacing between the two formats. Any misalignment is easily 
corrected in CorelFLOW.

· Unsupported characters appear as question marks in CorelFLOW.
· The following PICT text styles are supported: Bold, Italic, Outline, Shadow and any combination of 

these. Underlined text is not supported.



Import PCX Bitmap (.PCX)
Technical Notes

CorelFLOW imports PCX files conforming to the following specifications: 2.5, 2.8, and 3.0. These files 
can contain 1, 2 or 4 color planes. Files containing 3 color planes cannot be imported.



Import Corel Binary Metafile (BMF)
Technical Notes

CorelFLOW imports BMF files as native CorelFLOW objects.



Export File Filters - Technical Notes

Click  for technical information about CorelFLOW's export filters.

 Windows 3.0 Bitmaps, BMP
 TIFF Bitmaps, TIF
 Adobe Illustrator, AI
 Computer Graphics Meatfile, CGM
 PCX Bitmaps, PCX
 Windows Metafile (WMF)
 Macintosh PICT



Export - Bitmaps
Technical Notes

Saves drawings as bitmap graphics. CorelFLOW exports to three bitmap formats:    RLE, BMP and TIFF. 
You can use bitmaps of various formats in desktop publishing programs such as CorelVentura. You can 
also edit them in paint programs such as CorelPHOTO-PAINT and PC Paintbrush.

Scaling Bitmaps
Bitmaps are mapped pixel by pixel to the page, so if you enlarge a bitmap in another application the 
resolution will not increase. What you see will be an apparent loss of resolution, your bitmap will 
become "jagged". If you shrink a bitmap, the result should be acceptable, but you will be wasting disk 
space storing information which is not used. A common rule of thumb is to sample bitmaps to size, with
two pixels of information for every one line of screen. If your picture will print on a high resolution 
printer with a 150-line screen, you'd sample your photo to 300 dpi resolution.

File Size
To avoid unnecessarily large bitmap files (a full page at 300 dpi uncompressed can take several 
megabytes of disk space), scale the CorelFLOW graphic so that it's the same size as the space it will 
occupy in your word processing or page layout package or change the destination size in the dialog 
box.

Paintbrush RLE (PCX Version 3.0)
TIFF CorelFLOW exports to version 5.0 only.    

Note: All bitmaps are exported in 24-bit color.



Export Adobe Illustrator (AI)

Lets you choose the version of Adobe Illustrator you want to export to, and whether text is exported as 
text or curves.

Format
By default, exports to the AI 1.1 format.

Exporting Text as Text 
Exporting Text As Text will create smaller files, and the text will be editable in the destination 
application. Fonts and spacing may not be maintained.

· You may also Use Macintosh Characters. This is very useful when exporting text using an 
extended character set, such as foreign language or other special characters.



Export - Computer Graphics Metafile (CGM)
Saves drawings in a vector format for use in desktop publishing programs, such as Ventura Publisher or 
Aldus PageMaker.

Technical Notes
· Bitmaps are unsupported
· Text is exported as text



Export - Windows Metafile (.WMF)
Saves drawings in a vector format familiar to many Windows applications. Corel Ventura and
Microsoft Word are popular programs that can read WMF files.

Technical Notes

WMF File Complexity
WMF files can be very large if your graphic contains a lot of curves or text. This can cause problems in
programs such as Corel Ventura Publisher and PageMaker, which impose limits on the size of 
imported files.

Text
Text is exported as text by default.



Export Macintosh PICT
Saves drawings in PICT2 (color) format for use in many Macintosh graphics programs. Only vector 
objects can be exported in this format. Any bitmaps in the drawing will be ignored.

Exporting Text as Text 
By default, text is exported as text. Exporting Text As Text will create smaller files, and the text will be 
editable in the destination application. Fonts and spacing may not be maintained. 



Corel Technical Support

Corel Support Services
Common Error Messages
Troubleshooting Tips
Printing Information
Import/Export - File Transfer Information
The Control Polygon
Editing EPS Files
Registration Database



Corel support services

Corel recognizes that support needs vary from user to user, and we offer you a wide range of
choices when you need answers to your technical queries and problems in using the Corel 
applications.
If you have a question about CorelFLOW functions, first look in the CorelFLOW Manual or 
consult on-line Help. 
You can also find late-breaking updates and technical information by double-clicking the 
Readme Icon in the CorelFLOW program group.
If you cannot find the answer, you can speak to a Technical Support Representative located 
in North America or in Europe.
If you encounter problems after hours or on weekends or holidays, you can contact IVAN - 
our Interactive Voice Answering Network.
We also offer Electronic Support Services in the form of a Compuserve forum and a bulletin 
board.
How to reach Corel in North America
How to reach Corel worldwide
IVAN
Electronic support options
How to use Automated Fax System



Common error messages

General Protection Faults (GPF)
1000 series errors
2000 series errors
5000 series errors
Other memory errors
OLE problems



Troubleshooting tips

Enhancing system performance
Troubleshooting techniques
Tips & tricks for troubleshooting
Having memory problems?



Working with fonts & text

How to install TrueType fonts



Printing information

What to do if your print job doesn't print
Printing to non-PostScript printers
PostScript printing errors
Troubleshooting printing problems



Import/Export - File transfer information

Import filters 
Export filters



How to reach Corel in North America
Technical Support

Corel is committed to providing customers with high quality, timely technical support.    
Technical Support Representatives are available, on an 1-800 line, to answer your technical 
questions.    A fee will be charged for the technical support, but there will be no additional 
charge to your telephone bill.    Also, you may opt to call on a 1-900 line.    You will not be 
charged by Corel for this support option, but a charge will appear on your telephone bill.    
We also offer a number of Free Support options which you can access at any time.

Free Support Services
These services include IVAN, our Interactive Voice Answering Network and the Automated 
Fax System.
Calling 1-800-818-1848 (US and Canada)
CorelFLOW includes one free technical support credit in the box. This credit will be valid 
for one 15-minute technical support call. The technician answering the call will not use your
credit if the issue which you are calling about is a known or documented problem, with the 
software, which does not have a fix. 
After you have used your free credit, you will have the option of buying additional credits as 
follows:

One credit - $25.00US/$30.00CDN. 

A five-pack of credits - $100.00US/$120.00CDN 

A ten-pack    of credits -    $175.00US/$240.00CDN
If you do not have any remaining credits when you place your call, the technical support 
representative you reach will be able to sell one of the above options.

You can reach a representative Monday to Friday, excluding holidays.

Calling 1-900-896-8880 (US only)
If you do not wish to purchase these credits, you have the option of calling the 1-900 
number at a rate of $2.00 per minute. This option can benefit you if you have a question you
believe can be answered briefly, or if you are an occasional user of technical support. 

You can reach a representative Monday to Friday, excluding holidays.

Before You Call
Before calling Technical Support, please have the following information available.    It will 
assist the Technical Support Representative in helping you with your problem more quickly 
and efficiently:

· A brief description of the problem including the exact text of any error messages 
received, and the steps to recreate it.

· Type of computer, monitor and video card (display adapter) you are using.



· Type of pointing device in use (i.e. mouse, tablet).

· Type of printer that you are using to print your files.

· The version of DOS and Microsoft Windows you are running.

· A list of any programs loaded into RAM (i.e. TSR's).

· The contents of the AUTOEXEC.BAT and CONFIG.SYS files.

Corels Address

Corel Corporation
1600 Carling Avenue
Ottawa, Ontario, Canada
K1Z 8R7

Customer Service
Customer Service Representatives answer questions about specifications and pricing, and 
sell all of the Corel products.    They can also issue replacement disks.    There is no charge 
for calling Customer Service.    Please note that Customer Service Representatives cannot 
transfer you to a Technical Support Representative.

Telephone Numbers

800-77-COREL    (US and Canada)

800-836-3729    (US only)
613-728-3733 (outside US and Canada)



How to reach Corel worldwide
Corel European Technical Support
Corel is committed to providing customers with high quality, timely technical support.    Corel
customers residing outside North America can contact Corel Technical Support 
Representatives in Dublin, Ireland These representatives handle calls in the following 
languages: German, French, Spanish, Italian, Dutch and of course English. Calls are handled 
on toll lines.    A charge will appear on your telephone bill, but there is no additional charge 
by Corel for the technical support.

Telephone Number

353-1-4781900

Before You Call
Before calling Technical Support, please have the following information available.    It will 
assist the Technical Support Representative in helping you with your problem more quickly 
and efficiently:

· A brief description of the problem including the exact text of any error messages 
received, and the steps to recreate it.

· Type of computer, monitor and video card (display adapter) you are using.

· Type of pointing device in use (i.e. mouse, tablet).

· Type of printer that you are using to print your files.

· The version of DOS and Microsoft Windows you are running.

· A list of any programs loaded into RAM (i.e. TSR's).

· The contents of the AUTOEXEC.BAT and CONFIG.SYS files.

Corels Addresses

Canada Ireland
Corel Corporation Corel Corporation Limited
1600 Carling Avenue Europa House, 3rd Floor
Ottawa, Ontario, Canada Dublin 2, Ireland

K1Z 8R7

Third Party Worldwide Support
Corel has developed a working partnership with the following organizations who will also 
provide technical support to customers residing out of North America:

Country Company Phone & Fax
Australia Webster & Associates Pty Ltd., Phone:



Unit 2, 25 Frenchs Forest Road, 
Frenchs Forest, NSW 2086

011 612 975 3182
Fax: 
011 612 975 4273

Benelux Brightware Solutions B.V., 
Postbus, 3620 AD Breukelen

Phone:
011 31 3462 611 23
Fax:
011 31 3462 654 09

Denmark DTP Service, Bymestervej 2, DK-
2400 Copenhagen

Phone:
011 45 35 82 82 66
Fax:
011 45 35 82 82 23

Finland Subroutine OY, Harakanite 18, 
Sähkötalo, 02600 Espoo, Finland

Phone:
011 358 0 512 1491
Fax:
011 358 0 516 365

Germany EDCON Computer Gmbh, 
Ennsstr. 17, 47809 Krefeld

Phone:
011 49 2151 91 96 
30
Fax:
011 49 2151 91 96 
51

Germany DTP Partner Gmbh, 
Kredenburgstr.44, 22041 
Hamburg

Phone:
011 49 40 65 737 
456
Fax:
011 49 40 65 737 
441

UK Channel Market Makers, The Old
Bank, School Grounds, 
Southampton Road, Cadnam, 
Southampton SO4 2NF, UK

Phone:
011 44 703 812 755 
or
703 814 142
Fax:
011 44 703 813 830

Japan Sumitomo Metal Industries, LTD.
Mita Nittodai Building 11-36 
Mita, 3-Chome, Minato-ku, Tokyo
108, Japan

Phone:
011 81 354 769 816
Fax:
011 81 354 769 886

Austria Update EDV, Landstrasser 
Hauptstr. 146/8, A-1030 Wien

Phone:
011 43 1 718 02 76
Fax:
011 43 1715 41 41 
99

Customer Service
Customer Service Representatives answer questions about specifications and pricing, and 



sell all of the Corel products.    They can also issue replacement disks.    There is no charge 
for calling Customer Service.    Please note that Customer Service Representatives cannot 
transfer you to a Technical Support Representative.
Customer Service worldwide for the UK, France and Germany is handled by Alexander and 
Lord, Dublin, on behalf of Corel Corporation.    Customer Service for all other countries is 
handled by Corel in Canada.

Telephone Numbers
UK 0800-58-1028
France 0590-6512
Germany 0130-815074
Other Countries 613-728-3733 (Customer Service in Canada)

See also
IVAN
Electronic Support Options
How to use Automated Fax System



How to use the Automated Fax System

Technical Support maintains an automated fax system where up-to-date information about 
common issues and tips and tricks is stored in numbered documents.    If you have a fax 
machine, you have access to this service 24 hours a day, 365 days a year.    There is a 
catalogue of documents available.    You can fax this catalogue to yourself and then order 
any document at your convenience.

Calling the Automated Fax System
To access the automated fax system, dial 613-728-0826 and request extension 3080.    
You will then be prompted for a document number and your own fax number.    The 
document you request will be automatically sent to you.

To Obtain a Catalogue of Document Numbers:

Call the Automated Fax System number and request document 2000.



Electronic support options
BBS
Technical Support operates a BBS service, where customers are able to download any 
available program files that have been modified by our engineers, between releases.    Also, 
during the process of providing technical support, an agent may request that you upload 
troublesome files to the BBS.

Calling the BBS

(613) 728-4752 or

(613) 761-7798 

Both lines are set for 8 bit word, 1 stop bit, no parity.    The supported speeds on these
Hayes 288 modems are 2400-28,800 baud

COMPUSERVE
Technical Support operates a forum on Compuserve. Any available program files that have 
been modified between releases will be available via Compuserve.    As well, you will often 
find utilities and interesting information that have been made available by forum members. 
Corel sysops provide technical support to Compuserve users wishing to request support in 
this manner.

Compuserve Command

GO COREL- to access the Corel forums

Joining Compuserve
As a Corel customer, you are entitled to a free introductory Membership to CompuServe, 
including:

a FREE one month membership to access all of CompuServe's Basic Services,

a $15 introductory usage credit to explore the Corel Forum and CompuServe's other 
Extended and Premium Service Offerings,

a private user ID number and password,

a complimentary subscription to CompuServe Magazine, CompuServe's monthly 
computing publication.

Start connecting with Corel and other CompuServe members by calling:

US and Canada 1(800) 524-3388 and asking for representative #369
United Kingdom 0800-289-378
Germany 0130-37-32
Rest of Europe ask for representative #369





IVAN

IVAN is our Interactive Voice Answering Network.    This system contains answers to 
commonly-asked CorelFLOW questions, and allows customers to 'solve their own problems' 
24 hours a day, 7 days a week.    This system is regularly updated with the latest 
information, tips & tricks and also provides a feature whereby customers can request that 
IVANs solutions be faxed to them.

Calling IVAN
Dial (613) 728-1990.    There is no charge for the IVAN service beyond the cost of the 
telephone call.    IVAN will not transfer callers to a technical support representative.



Diagnosing GPF's, application errors and system lockups.

General Protection Faults, Application Errors and system lockups generally indicate memory 
problems. These problems can include memory shortages, memory conflicts, and sometimes
corrupted files. Unless an error or lockup becomes predictable, it is often difficult to pinpoint 
the exact cause of the problem.    The following lists a number of steps that should be 
followed when dealing with random and predictable system problems.    If the problem can 
be re-created, then follow the steps one at a time to determine which step solves the 
problem.

After any GPF, application error or lockup

1. Save files that are currently open, if possible.

2. Exit from all applications including Windows.

3. Ensure that the system meets Corel's minimum requirements i.e., 386DX with 8 MB 
of RAM.

4. Reboot the system.    In the case of repeatable problems, you should definitely reboot 
the system using a bootable floppy disk with a minimal system configuration.    Here 
are the steps for creating that disk:

Format a diskette for the A: drive, using the following DOS command:

FORMAT A: /S (Note:        /S copies system files)

Copy the AUTOEXEC.BAT and CONFIG.SYS files to the diskette
Edit them so they contain the following lines, only:

Autoexec.bat 

@ECHO OFF
PROMPT $P$G
PATH=C:\;C:\DOS;C:\WINDOWS

Config.sys 

DEVICE=C:\WINDOWS\HIMEM.SYS
FILES=40
BUFFERS=30

***Add any other drivers that are necessary for the system to operate

6. Run the SET command from a DOS prompt to determine the location of the TEMP 
directory.    Change to that directory and delete any *.TMP files.      Ensure that the TMP
files are being created on an UNCOMPRESSED drive.

If the GPF, Application Error or lockup becomes predictable, follow the above steps, then 
continue with steps 7-20



7. Run either Checkdisk with the fix parameter    ie. CHKDSK /F or SCANDISK /ALL (if 
using DOS 6.2) to locate any possible disk errors (e.g. lost clusters, lost allocation 
units, cross-linked files) Ensure that the bytes total memory    line reads    655,360.    
Any other number could indicate a virus.

8. Check for viruses using the DOS virus checker MSAV.EXE and run VSAFE.COM for 
constant monitoring of file writes/loading.

9. Before restarting Windows, open the WIN.INI file in a DOS editor and ensure that 
there is nothing after the Load= and Run= statements. If there are entries on those 
lines, insert a semi-colon (;) in front of the 'L' in Load and the 'R' in Run.    This will 
prevent the applications from loading.    Check to make sure that the WIN.INI does not
exceed 64KB in size.

10. Restart Windows.    Try adding the following parameters to the WIN command, 
if necessary, to determine where the problem lies:

Win /3    /D:FSVX      /B

/3 -> forces 386 enhanced mode

/D:F ->turns off 32-bit disk access.

/D:S ->specifies that windows should not use ROM address space between 
F000:0000 and 1 MB for a break point.

/D:V -> specifies that the ROM routine handles interrupts from the hard 
drive controller instead of using Windows internal code.

/D: X -> Excludes all of the adapter area from the range of memory 
Windows scans to find unused space.

/B -> Starts Windows bootlog, for diagnosing why Windows won't start. 
Creates a file called BOOTLOG.TXT in the Windows directory.

11. Disable or uninstall alternative window shells to the Program Manager (ie. 
Norton Desktop, DashBoard, Central Points PCTools for Windows...)

12. Turn off all TSR's (Screen savers, Disk cache displayers, Mouse watchers, etc.)

13. Change video to the standard Windows VGA driver (16 colors 640x480 
resolution).    Other graphic cards using comparable VGA resolutions may be 
accessing different memory addresses and may be causing a memory problem (Video
or GPF related).    To reload the Windows VGA driver, try the following:

From a DOS prompt (make sure Windows is shut down) change to the 
Windows directory.

Type SETUP and change the Video to VGA.    Restart windows.

If you are already running the Windows VGA driver and wish to reload it because you 
suspect that it may be corrupted:



From a DOS prompt (make sure Windows is shut down) change to the 
Windows directory.

Type SETUP and change the Video to something other than VGA.    Restart 
windows.      Repeat the setup procedure, but select VGA.    This will reload the 
original driver files from the Window 3.1 diskettes.

***If the video or GPF problem goes away, when running VGA, then contact 
the Video Manufacturer for updated drivers.***

Note: If you are running a video manufacturers driver and are trying the VGA 
test, please make sure you have the install diskette from the manufacturer. 
This may be required to set your video back to the original state after the test.

14. Recreate the windows SWAP file with the following procedure;

Control Panel -> 386 Enhanced -> Virtual Memory -> Change.

Set the SWAP file size to NONE, then restart Windows.

Repeat this procedure, then set the SWAP file size to 10 MB Permanent 
(preferred by Windows).

You may have to run an OPTIMIZER (e.g. Norton SpeedDisk, PCTools Optimize, 
etc.) to access a larger continuous section of disk space. Make sure that the 
swap file is located on an UNCOMPRESSED drive.

15. Reload any device or file causing the problem from diskettes or CDROM.    

***Please contact the manufacturer if you are unsure of the proper 
procedures***

A font file may have to be re-added or re-loaded from disk or CDROM.    To 
check and see if the font is the problem use this test;

Control Panel -> Fonts, highlight the font thought to be causing the problem. 
Check the preview window, if there is no display then the .FOT file is probably 
corrupted, also if the number of bytes displays 0 (zero) then it is also likely 
that the font file is corrupted.

16. Try reloading the printer driver.    Verify with Microsoft that you have the most 
up-to-date Postscript or Non-Postscript drivers.

17. Check the Properties of the designated program's icon.    Are the Command 
line and Working directory correct?    Try re-establishing the Command line and/or 
Working directory.

18. Try executing the program directly from File Manager.

19. Check BIOS date;

AMI BIOS:

1987 causes system reboot when a floppy is accessed through File Manager.
1989 causes intermittent system hangs.



1991 causes serial port problem; mouse or modem stops working.

PHOENIX:

Any BIOS dated 1988 or earlier should be upgraded.

AWARD:

Should be version 3.1 or higher.

20. If none of these steps resolve the problem, please contact Technical Support 
for further assistance.



1000 Series Errors

The error messages listed below are the result of memory shortages or memory conflicts on 
your system. Usually, you can bypass these messages and continue working.    However, you
should always:

1. Save your file immediately, if possible.

2. Exit Windows.

3. Reboot your system.
Since these memory problems are often intermittent, you should save your work at regular 
intervals during your CorelFLOW session.

The 1000 series of error messages:

1000 Allocate memory failed

1001 Lock memory failed

1002 Reallocate memory failed

1010 Memory block exceeded length limits

See the steps below on dealing with memory error messages.    The tips and information are 
quite generic because, though the errors have different numbers and different causes, the 
troubleshooting steps are identical.    These error messages are often intermittent, making 
troubleshooting difficult. If they become persistent and predictable, treat them like General 
Protection Faults.

Restoring files after a memory error or system lockup
If you work on a file for several hours, only to have the system produce an unrecoverable 
memory error or lock up completely, you will obviously look for all possible ways to recover 
that information.    In different situations, there are three possible sources of backup files.    
You will have a 50-100% chance of restore lost data by accessing these files.
TMP files - created by Windows as you work in CorelFLOW.    They are saved only if the 
system crashes or locks up.    If you cannot open a file or did not have a chance to save the 
file before the crash, you may be able to restore some the information by renaming the TMP 
file to CFL.    TMP files are stored in a subdirectory determined by a line in the AUTOEXEC.BAT
file.    The best way to determine where these files are is to run the SET command at the DOS
prompt and to look for a line stating TEMP=...    Check this subdirectory for any files with a 
TMP extension, a byte size other than zero (0), and a date and time that match when the 
crash occurred.    Rename the file(s) and attempt to open them in CorelFLOW.    Windows 
requires 5-10 MB of free disk space on the drive where TMP files will be created.

What to do after a memory error has appeared



1. Try to clear the error message.    If possible, exit from the CorelFLOW application and 
exit and re-start Windows.    If it isnt possible to clear the message, re-boot the 
system.

2. Try opening the CFL file, if you had saved the file.    If that is not possible, try 
importing it.      

3. Search for a TMP file and rename it.

4. At the DOS prompt, change to the directory where TMP files are stored and delete 
any remaining TMP files. 

After a lockup or crash
Reboot the system and follow steps 2-4 above.



2000 Series Errors

Errors numbered 2000 - 2013 are all Disk errors based on read, write, create, seek and open 
file problems. They usually occur because the drive, where Windows TMP files are stored is 
full.
TMP files - created by Windows as you work in CorelFLOW.    The TMP files will be stored in a
subdirectory determined by a line in the AUTOEXEC.BAT file.    The best way to determine 
where these files are is to run the SET command at the DOS prompt and to look for a line 
stating TEMP=.    Check this directory for TMP files and delete any that exist from the DOS 
prompt, rather than through Windows.    As a note, Windows requires 5-10 MB of free disk 
space on the drive where TMP files will be created.

Troubleshooting 2000 Series Errors

1. Exit Windows.

2. At the DOS prompt, change to the directory where TMP files are stored and delete 
any files with the .TMP extension.

3. Make sure you have 5-10 MB of free disk space to accommodate future TMP files.    If 
not, clear space on the hard disk or redirect the SET TEMP statement in 
AUTOEXEC.BAT to another drive.



5000 Series Errors

The 5000 series of error messages occur as a direct result of a memory conflict in your 
system. Usually such conflicts are object or file specific and can be easily isolated. When 
such an error occurs, and CorelFLOW will allow, save your work and exit from CorelFLOW and
Windows.
In all cases, another contributing factor to the generation of 5000 series errors is inadequate
space for Windows to create temporary files.  These files are created by Windows as you 
work in Corel applications.    The TMP files will be stored in a subdirectory dictated by a line 
in the AUTOEXEC.BAT file.    The best way to determine where these files are is to run the 
SET command at the DOS prompt and to look for a line stating TEMP=... Check this directory
for TMP files and delete any that exist from the DOS prompt, rather than through Windows.    
Windows requires 5-10 MB of free disk space on the drive where TMP files will be created.

5000
These errors occur as a direct result of a memory conflict on your system. Fault can be easily
isolated because the message is either file or object specific. If the error message returns, 
follow the instructions below to isolate the offending object and delete it. Check if you have 
adequate Temp space. If not, delete .TMP files. (TMP files are created on your system while 
you work in CorelFLOW.)

5001
These errors occur as a result of two conflicting pieces of data. Exit from CorelFLOW, delete 
CorelFLOW from your system, and re-install CorelFLOW.    

5002
These errors occur as a result of two conflicting pieces of data. Exit from CorelFLOW, delete 
CorelFLOW from your system, and re-install CorelFLOW. 

Dealing With Corrupted Objects or Files

· Marquee select half of the objects, then save them in a new file using the Selected 
Objects Only option. In the new file, if a problem occurs again, marquee select a 
smaller number of objects until you locate the corrupted object by process of 
elimination.    Once you've identified the corrupted object(s), delete it.

· For large files, often the error can be reproduced by selecting the offending object 
and copying it to the clipboard. To isolate the object,    marquee select half of the 
objects on your page and copy them to the clipboard. If no error occurs, marquee 
select another area and try the same. Once the error occurs, you will need to select 
fewer objects from that area and continue with the copying process until you have 
located the offending object. Once identified, delete and recreate it.



Dealing with memory-related errors

The common troubleshooting steps associated with handling memory errors are:

1. Save the file immediately.

2. Exit the application and Windows.

3. Reboot the system.

4. At the DOS prompt, type SET. The screen will display the directory where Windows 
temp files (*.TMP) are saved. (e.g., TEMP=C:\WINDOWS\TEMP.)

5. Change to that directory and delete any files with the .TMP extension.    Any TMP files 
created by Corel will automatically be deleted.    Any TMP files you find will be files 
created by other Windows applications and can be safely deleted.

6. Make sure you have 5-10 MB of free disk space to accommodate future TMP file 
creation.

If the messages become persistent and predictable, treat them like General Protection 
Faults.



OLE Problems
1. Sometimes the REG.DAT file becomes damaged, generating OLE Error Messages in 

the Corel applications.    If you encounter these error messages, close the Corel 
application and open the Windows File Manager.    Double click on REGEDIT.EXE.    If 
this file opens, you will see the Registration Information Editor.    Locate the Corel 
application which had the OLE problem and delete it from the list.    You can do this by
highlighting the item, then clicking on Edit and Delete File Type.    Then, exit from the 
Registration Information Editor and exit and restart Windows.    When you open and 
close the Corel application, it will re-register itself in REG.DAT.

2. If you cannot open the Registration Information Editor, rename REG.DAT to REG.OLD, 
then exit and restart Windows, and open and close the Corel Application.

3. Another requirement for OLE to function properly is having SHARE.EXE loaded in the 
AUTOEXEC.BAT file.    By default, the SHARE statement is placed at the end of the 
AUTOEXEC.BAT file.    This means that it may not execute properly if you have a batch
file that starts Windows listed before this reference.    If so, move the SHARE 
statement up under the PATH and PROMPT statements.



Enhancing system performance

Here are a number of considerations for improving the performance of CorelFLOW:

· the microprocessor and clock speed are important ie. a 486-50 will run CorelFLOW 
more quickly than a 386-33

· a math co-processor will enhance the performance of some functions

· ensure that you have at least 10 megabytes of free disk space on the drive where 
Window *.TMP files will be created ( you can determine the location of this directory 
by running the SET command at the DOS prompt)

· follow the suggestions in the chapter on 'Optimizing Windows' in your Window's 
User's Guide

· consider establishing a Swap file to provide Windows with extra memory.    See your 
Windows User's Guide for more details.

· you may want to consider an accelerated video card.    We cannot make 
recommendations on any hardware.



Troubleshooting techniques

While working in CorelFLOW, you may encounter problems printing, saving files, opening 
files, importing, exporting, etc.    Though each problem may have a different cause, there are
some general steps you can follow in attempting to troubleshoot your problem.    In many 
cases it will save you a call to Technical Support!

1. Can you duplicate the problem?

Try performing the same function again.    This is the first step in troubleshooting.    
Occasionally, a temporary memory problem will interrupt a function, and simply 
trying again will allow you to complete that task.

No

Problems that can't be reproduced are difficult to explain.    Continue working, but 
note details of the circumstances if the problem does occur again.    That will enable 
Technical Support to assist you more effectively if you decide to call.

Yes

If you can duplicate the problem, it may be file, program or system specific.    Proceed
to the next step.

2. Is the problem system-specific?

This step is sometimes appropriate at the beginning of a troubleshooting session and 
is sometimes left to the end.    Before spending a lot of time analyzing the causes of a
problem, it is often a good idea to    determine if the problems occur only on one 
system.    This is easy to do, if you have access to another computer and can try your 
function or file here.    Or, if the problems are printing related, try using a different 
printer.    If the problems persist on more than one system, zero in on file specific 
issues.    If not, concentrate on the system settings, installation and finally hardware 
issues.

If you do not have access to another system running CorelFLOW, proceed to the next 
step.

3. Is the problem file-specific?

If you can reproduce the problem, the culprit may be the file itself, the Corel program 
or something about this particular system. This step attempts to determine if the 
problem is unique to this file or if it may be caused by a program or system issue.

If you are having problems saving, printing or exporting, etc., try opening another file
of the same type and perform the same function.    If subsequent file works properly, 
you are most likely dealing with a file that contains a corrupted object(s) or may too 
complex for the particular function you are trying to perform.    If so, see the notes 
below on Dealing With Complexity Issues or Dealing With Corrupted Objects or Files.

If you are having problems opening or importing, try opening or importing other files 
into the same application.    Also, try taking the problem file in other applications. e.g.



if you have trouble importing a CGM file, try taking it into a different Windows 
application.    The goal is to determine whether problems are contained in the file or 
are caused by something else. 

4. Is the problem software-specific?

If a problem is reproducible but not limited to just one file, then problems are being 
caused by the Corel program, other software on the system ie. drivers, Windows, etc.,
or by hardware. If it is possible to try the same files and functions on another system 
running CorelFLOW, you can determine whether the root of the problem is based on 
one system as opposed to being software generated.    If this test is not possible, try 
to collect as much information as possible about whether the problem occurs only in 
Corel applications.    You can do this by trying to perform similar functions, ie. printing 
or importing, into other Windows applications.    If problems appear in other 
applications, then the cause is at a more basic level than Corel.    Sometimes video or 
printer drivers can cause problems.    Sometimes there are even problems with a 
particular Windows setup. 

If following the above steps do not allow you to resolve the problem you are encountering, 
you may wish to contact Technical Support.

Dealing With Corrupted Objects or Files

· Marquee select half of the objects, then save them in a new file using the Selected 
Objects Only option. In the new file, if a problem occurs again, marquee select a 
smaller number of objects until you locate the corrupted object by process of 
elimination.    Once you've identified the corrupted object(s), delete it.

· For large files, often the error can be reproduced by selecting the offending object 
and copying it to the clipboard. To isolate the object,    marquee select half of the 
objects on your page and copy them to the clipboard. If no error occurs, marquee 
select another area and try the same. Once the error occurs, you will need to select 
fewer objects from that area and continue with the copying process until you have 
located the offending object. Once identified, delete and recreate it.



Tips & tricks for troubleshooting

Problems Caused by Windows TMP files
Windows generates temporary files as you work in Corel applications.    Many functions such 
as printing, saving, importing and exporting can be affected by a shortage of temp space.    
It is recommended that you have at least 10 MB of free disk space on the drive where TMP 
files will be written.    You can identify that location by running the SET command at the DOS 
prompt.    Reference will be made to TEMP=...    Delete any TMP files from the DOS prompt 
that you find in this subdirectory.    In CorelFLOW, Corel will automatically delete its own TMP 
files when you restart the application after a crash.    
Damaged Program Files
If you suspect problems with program files including import and export filters, you may want
to consider running the SETUP program again, and re-installing the portions of the program 
that may be causing problems.

See also
What To Do If Your Print Job Doesn't Print



Having memory problems?

The common troubleshooting steps associated with handling memory errors are:

1. Save the file immediately.

2. Exit the application and Windows.

3. Reboot the system.

4. At the DOS prompt, type SET. The screen will display the directory where Windows 
temp files (*.TMP) are saved. (e.g., TEMP=C:\WINDOWS\TEMP.)

5. Change to that directory and delete any files with the .TMP extension.    Note:    any 
TMP files created by Corel will automatically be deleted.    Any TMP files you find will 
be files created by other Windows applications and can be safely deleted.

6. Make sure you have 5-10 MB of free disk space to accommodate future TMP file 
creation.

If the messages become persistent and predictable, treat them like General Protection 
Faults.



How to install True Type fonts

The True Type engine is internal to Windows, so you do not require a third-party font 
manager to use True Type fonts in Windows applications.      For an application use a True 
Type font, that font must be installed through Windows. 
There are two files associated with an installed font; the True Type font file (extension TTF) 
and the resource file (extension FOT).    During the CorelFLOW installation, both files for each
True Type font are copied into the WINDOWS\SYSTEM directory.    Windows requires that the 
FOT (resource) files reside in this directory.    The TTF file does not have to be in this 
directory, but the FOT file maintains a pointer to the TTF file.    It is important that the TTF file
is not moved or deleted from the directory into which it's installed.    If you think this may 
have happened, remove and the font and add again it through the Windows Control Panel.

Windows Control Panel Install
To add third-party or custom True Type fonts, follow the Windows True Type font installation 
procedure.    This involves accessing the Fonts dialog box through the Windows Control Panel.
Once a font has been installed into Windows, it will be available in CorelFLOW.    This 
installation option is a good choice when adding one or two fonts.



What to do if your print job doesn't print 

When you print a file through a Corel application:

1. Corel processes the information.

2. If the process is completed successfully, the print job will be passed to the Windows 
Print Manager. You can watch the job progress by clicking on the Print Manager icon.

3. If everything runs smoothly, the print job will then be passed to the printer.
At any one of these stages, the process may break down.    The first step in determining 
where the problem lies is to identify at which of the above three steps printing stopped.
If you encounter problems while printing a file, consider the following troubleshooting tips in 
an attempt to determine where the problem lies and how to resolve it

Printing Stops in the Corel Application 

· Exit and re-start the Corel application.

· Has the file printed before? Is this a repeatable problem?

· Is it one file or all files which are having print problems?

· Ensure that the default printer is correct.

· Check System Resources and Free Memory in the Help menu of the Windows Program
Manager.    If these values are low, exit and re-start Windows.      Also, make sure you 
do not have other Windows applications running.

· Is the Print Manager on?    Try disabling it.

Printing Stops in the Print Manager 

· Open the WIN.INI file. Find the reference to TransmissionRetryTimeout=45.    Set 
this value to 999 (this sets the time that Windows waits for the printer to report that 
it is ready to receive more data). A value of 999 is equal to an infinite amount of time.
Once changed, exit from Windows and then start it again.

· Check Load and Run statements in WIN.INI.    Programs and utilities can be set to run 
automatically when Windows is started by adding references to these lines.    Type a 
semi-colon (;) in front of either line if there is anything referenced.    Remember to 
save, exit and restart Windows after making changes to the WIN.INI.

· Move any icons found in the Windows Startup group to another icon group.

· While working in CorelFLOW, temporary files are created and placed on your system. 
Exit Windows completely delete any .TMP files found in the Windows temp directory. 
While here, ensure that you have at least 5-10 MB of free disk space. 

· Is fast printing direct to port on? Try disabling it.

· Make sure you are using an up-to-date printer driver. 



· Will other Windows applications print? If not, look at Windows setup or configuration 
issues as the problem will be occurring at a more basic level than CorelFLOW

Printing Stops in the Printer

· Maximize time-outs on the printer if possible.    Refer to your printer documentation 
for instructions.

· Check time-outs on the network, if applicable.

· Check to see how much RAM is resident in the printer. A minimum of 1.5 megabytes 
is required to print a full page of graphics to a 300dpi device. To print fairly complex 
files, we recommend a minimum of 4 megabytes of RAM in the printer. (Note: some 
files may require more than 4 megabytes).

· Do you print directly or through a switchbox or network.    If possible,    try connecting 
directly.

· Make sure you are using an up to date printer driver.

· What port is being used? If you're using LPT1, try LPT1.DOS. 

Postscript Specific Checklist:
Download the Postscript Error Handler under the Windows Control Panel; Printers icon; 
Setup; Options; Advanced.    If Postscript is having difficulty interpreting the file, an error 
code will be produced.

See also
PostScript Printing Errors
Troubleshooting Techniques



Printing to non-PostScript printers
Video Driver
With non-postscript devices, you should watch out for a non-Windows 3.1-supported video 
driver.    When an image on the CorelFLOW screen    is output, it is rasterized from 
information in the video driver.    Therefore, if a drawing is not printing correctly, or just not 
printing, go to the Windows Setup icon and check the video driver that Windows is currently 
using.    If Windows is set up for anything other that the standard VGA video driver, make a 
backup of the System.ini file and switch to the standard VGA driver.
Note: It is important to make a backup of the System.ini file before making any changes to 
the Windows Setup.    If you want to return to the original configuration, simply rename this 
backup file back to System.ini.



PostScript printing errors
The Windows Control Panel allows you to enable a Postscript Error Handler under the Printers
icon; Setup; Options; Advanced.    This error handler defines the errors that the Postscript 
language encounters when processing a file.    Listed below are some of the common 
Postscript error codes, their definitions, and solutions where applicable.
Error:    Limitcheck.    Offending Command=Nametype:    EOCLIP
This error may occur if you had imported a object(s) into CorelFLOW. This message indicates 
a path implementation error, usually where Postscript is unable to complete the clipping 
routine for filled objects. Try removing any extraneous outlines from objects in the 
application from which you imported them to fix this problem.
Error:    Limitcheck.    Offending Command=Nametype:    EOFILL
This message indicates a path implementation error when Postscript is completing a fill 
routine. 
Error:    Limitcheck.    Offending Command=Nametype:    LINETO or CURVETO
An implementation limit has been exceeded, usually indicating too many nodes on a straight
or curved path. This error may occur if you had imported an object(s) into CorelFLOW. Try to 
manually remove extraneous nodes from the objects in the application from which you 
imported the object(s).
Error:    Stack Overflow
The stack limit has been exceeded. Try the suggestions above for EOCLIP.
Offending Command:    Stack Underflow
The stack does not have enough objects for the requested operation.    Try the suggestions 
above for EOCLIP.
Error: Invalid restore
This message may appear after you cancel a print job.    Try clearing the Print Manager and 
repeating the printing process.
Error:    invalid font
This error message may appear if the file requires a font that has become corrupted.    Try re-
installing font.



Troubleshooting printing problems
Printer Drivers
Corel does not develop or distribute printer drivers.    We rely on the printer manufacturer or 
Microsoft to provide drivers that are supported in the Windows environment.    If you can 
print in Windows, you should be able to print from Corel applications. 

Printed Output Is Incorrect

If you print a file from CorelFLOW and the output is incorrect:

· Check cables and connections for potential communication problems.    A telltale sign 
of communication problems are ASCII characters appearing on your page where 
graphics should be appearing, i.e. happy faces, stars, etc.

· Make sure you are using the most up-to-date printer driver.

· Try changing your video driver to plain VGA.

Dealing With Corrupted Objects or Files

· Marquee select half of the objects, then save them in a new file using the Selected 
Objects Only option. In the new file, if a problem occurs again, marquee select a 
smaller number of objects until you locate the corrupted object by process of 
elimination.    Once you've identified the corrupted object(s), delete it.

· For large files, often the error can be reproduced by selecting the offending object 
and copying it to the clipboard. To isolate the object,    marquee select half of the 
objects on your page and copy them to the clipboard. If no error occurs, marquee 
select another area and try the same. Once the error occurs, you will need to select 
fewer objects from that area and continue with the copying process until you have 
located the offending object. Once identified, delete and recreate it.



The Control Polygon

When you draw a curve, both the curve and its control polygon are rendered. The control 
polygon is drawn as a dotted blue line, and is related to the shape of the curve in the 
following ways:
· The end points of the curve and the control polygon are the same.
· The slope of the curve at the start point is equal to the slope of the first segment of the control polygon.

Similarly, the slope of the curve at the end point is equal to the slope of the last segment of the control
polygon.

· While the curve does not generally pass through the interior points of the control polygon, it 
approaches them.

· The curve is contained entirely within the convex hull defined by the points of the control polygon. 



Editing EPS Files

When printing to an EPS file, you are restricted to the page sizes supported by the printer 
driver. For example, if your diagram has a page size of 8.5 x 5.5", and the smallest page size
supported by the printer driver is 8.5 x 11", when you import your EPS file into a word 
processor you will get an 8.5 x 11" diagram and the lower 5.5" is white space. 
If your word processor does not allow cropping of the diagram, you may crop the diagram by
editing the EPS file itself (before importing it into the word processor) as follows:
The 4th line of the EPS file contains the bounding box of the diagram as four numbers:
· lower left x coordinate.
· lower left y coordinate.
· upper right x coordinate.
· upper right y coordinate.
The lower left corner of the diagram is the origin and the coordinates are in units of 1/70". 
For example, an 8.5 x 11" diagram might have the numbers: 0, 0, 585, 770. To change such 
a diagram into an 8.5 x 5.5" diagram, 'raise' the lower left y coordinate by 5.5" by adding 
385 to it (5.5 x 70 = 385): 0, 385, 595, 770.



The Registration Database

Other applications can only invoke CorelFLOW as an OLE Server if the necessary information
is in the registration database. This information is automatically added to the database 
when CorelFLOW is installed.

If CorelFLOW is not registered in your database, register it as follows:
1. Open the Windows File Manager and locate the CORELFLW\CUSTOM directory. 
2. Double-click the CORELFLW.REG file that's found in the CORELFLW\CUSTOM directory.
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