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The Index contains a list of all first-level Help topics available for Image2 For information on 
how to use Help, press Shift-F10 or choose Using Help from the Help menu.



Edit Menu

The Edit menu includes commands that enable you to move images and clippings to and 
from the clipboard, to delete images, to annotate images, and to undo a previous operation.

For more information, select the Edit menu command name.

Undo
Paste DIB .
Paste DDB
Paste Palette
Paste Clipping
Copy
Cut .
Clear
Rich Text



File Menu

The File menu includes commands that enable you to open and save files, and to print.

For more information, select the File menu command name.

Open
Print
Save
Exit



Process Menu

The Process menu includes commands that enable you to change the way an image looks.

Grayscale: Lets you convert an image from color to gray using one of three algorithms. The 
average brightness algorithm makes the minimum change in the appearance of the image 
on the screen, but may not have enough range for effective printing. The maximum 
brightness algorithm often looks better; a carefully tuned weight-brightness conversion will, 
however, give you the best possible results. After a grayscale operation, you can revert to 
the original color image using undo. This gives you the opportunity to try various grayscaling
algorithms without reloading the image file.

Color: Let's you change the colors in an image. You can work with any of three possible color 
models: RGB, HSV, or HSL. Adjust the sliders and click OK to see the result. If you don't like 
the result, you can undo the color adjustment operation.



Help Menu

Index: Brings up the top-level index to Image2's help files

Keyboard: Brings up help about using the keyboard in Windows

Using Help: Tells you how to use the Windows help system

About: Displays the version and copyright for Image2, along with the current Windows 
environment, memory available, and resource utilization.



Exiting

Press Alt-F4, choose File Exit, or double-click on the close box to exit Image2. You may find 
that Image2 takes a moment to close if you have been working with large images: this is the
time required to put any deferred image renderings on the clipboard and release all 
allocated memory.



Selecting a Region

You can select a rectangular region of the current image with the mouse. Place the mouse 
cursor at the upper left-hand corner of the rectangle, press the left mouse button, drag the 
mouse down and right until the region is as you with, and release the left mouse button.

To remove a region, click once on the image without moving the mouse.

The selected region is used for cutting and pasting as an alternative to cutting and pasting 
the whole image. To copy a region, select the region and choose the edit copy operation. To 
cut a region, select it and use the edit cut operation. To paste an image into a region, get the
image onto the clipboard, select the region, and choose the paste clipping operation. To clip 
an image, select the clipping, copy it to the clipboard, and then choose Paste DIB.



Edit Paste DIB Command

Pastes a whole image from the clipboard in DIB (device-independent bitmap) format. The 
current image is saved for undoing.



Edit Paste DDB Command

Pastes a whole image from the clipboard in DDB (device-dependent bitmap) format. The 
current image is saved for undoing.



Edit Paste Palette Command

Pastes a color palette from the clipboard and applies it to the current image. The current 
image prior to application of the palette is saved for undoing.



Edit Paste Clipping Command

Pastes an image from the clipboard into the current image. The current image prior to 
application of the palette is saved for undoing.

The clipboard image will be pasted and stretched or compressed into a selection box if one 
exists. If no selection box exists, the clipboard image will be pasted onto the upper 
left hand corner of the current image at its normal size.

The pasted clipboard image can be dragged to any position in the window with the mouse. 
When you are satisfied with the position of the pasted image, press any key or 
double-click the left mouse button. If you want the clipping to be pasted at its initial 
position even though you've moved it, click the right mouse button.



Edit Rich Text Command

Allows you to add a text annotation to an image. This menu item brings up a dialog box in 
which you can enter a line of text. Use @-commands to specify text attributes:

Command Meaning
@+ Superscript
@- Subscript
{ Left Bracket
} Right Bracket
@b or @B Bold
@bc, @BC, @bC, or @Bc Background Color
@i or @I Italic
@u or @U Underline
@a or @A Angle
@tc, @TC, @tC, or @tC Text Color(R,G,B)
@f or @F Font @f{Courier}
@s or @S Size @s{12}

Curly brackets must be present to delimit the scope of each @-command. Unrecognized 
formatting commands will appear as text.



Edit Undo Command

Restores the previous image. The current image becomes the previous image, to allow for 
undoing your undo.



Edit Copy Command

Copies an image to the clipboard. If there is a selection box, only the selection is 
copied. If there is no selection box, the whole image is copied. 

Image2 always copies things to the clipboard in three formats: DIB, DDB, and Palette.
However, Image2 defers the step of rendering the formats on the clipboard. 

Because of delayed rendering, you may want to make sure that Image2 is still active 
and displaying the image you want to paste when you do your paste operation. 
Alternatively, you can paste the image back into Image2 to force real data to be placed on 
the clipboard.



Edit Cut Command

Copies an image to the clipboard and then deletes the image. If there is a selection box, only
the selection is copied and deleted. If there is no selection box, the whole image is copied 
and deleted.



Edit Clear Command

Deletes an image. If there is a selection box, only the selection is deleted. If there is no 
selection box, the whole image is deleted.



File Exit Command

Ends the current instance of Image2. Other instances of Image2 are not affected.



File Open Command

Opens an image file and reads the contents, converting the image to a Windows device-
independent bitmap. A palette and device-dependent bitmap are derived from the device-
independent bitmap.

Supported file formats are:

Any Windows or OS/2 DIB, BMP, or RLE file.
Any 1-bit, 4-bit, or 8-bit PCX file. 3-bit PCX files will display with some distortion. 24-

bit PCX files have not been tested.
Any 24-bit Targa file. 8-bit Targa files will display with the image tripled. 32-bit Targa 

files may crash the program.
Any Type P TIFF file. Other TIFF classes may cause error messages or possibly crash 

the program.
Any non-interlaced GIF file.
Any 8-bit VICAR file.
Any 24-bit pixel-interleaved or plane-interleaved raw image file. You will need to 

know the dimensions of the image in pixels and the type of interleaving to read the file 
successfully.

Once the image is read and converted successfully, it is displayed in a window sized to fit 
the picture.

The operation of display a 24-bit color image on an 8-bit palette-based display is rather 
time-consuming. The time is consumed by Windows internals, not by Image2. If you want to 
view deep-color images on an 8-bit display, you should first use another program to reduce 
the image to an optimal 256-color palette. This one-time color reduction will take less time 
than Windows would use to match the color palette each time it needed to display the deep-
color image.



File Print Command

Prints the current image on the currently selected printer. Attempts to scale the image to a 
full page. This operation works best with printers that can print color or convert color to gray
scales.



File Save Command

Saves the current image as a Windows device-independent bitmap. Using the options you 
can control the saved image color depth and compression.





Windows Keys

The keyboard topics below come from Help for Windows. You can create similar keyboard 
topics for your application's Help. Choose from the following list to review the keys used in 
Windows:
Cursor Movement Keys
Dialog Box Keys
Editing Keys
Help Keys
Menu Keys
System Keys
Text Selection Keys
Window Keys



Cursor Movement Keys

Key(s) Function

DIRECTION key Moves the cursor left, right, up, or down in a field.
End or Ctrl+Right Arrow Moves to the end of a field.
Home or CTRL+Left Arrow Moves to the beginning of a field.
PAGE UP or PAGE DOWN Moves up or down in a field, one screen at a time.



Dialog Box Keys

Key(s) Function

TAB Moves from field to field (left to right and top to bottom).
SHIFT+TAB Moves from field to field in reverse order.
ALT+letter Moves to the option or group whose underlined letter matches 

the one you type.
DIRECTION key Moves from option to option within a group of options.
ENTER Executes a command button.

Or, chooses the selected item in a list box and executes the 
command.

ESC Closes a dialog box without completing the command. (Same as
Cancel)

ALT+DOWN ARROW Opens a drop-down list box.
ALT+UP or DOWN ARROW Selects item in a drop-down list box.
SPACEBAR Cancels a selection in a list box.

Selects or clears a check box.
CTRL+SLASH Selects all the items in a list box.
CTRL+BACKSLASH Cancels all selections except the current selection.
SHIFT+ DIRECTION key Extends selection in a text box.
SHIFT+ HOME Extends selection to first character in a text box.
SHIFT+ END Extends selection to last character in a text box



Editing Keys

Key(s) Function

Backspace Deletes the character to the left of the cursor.
Or, deletes selected text.

Delete Deletes the character to the right of the cursor.
Or, deletes selected text.



Help Keys

Key(s) Function

F1 Gets Help and displays the Help Index for the application. If the 
Help window is already open, pressing F1 displays the "Using 
Windows Help" topics.
In some Windows applications, pressing F1 displays a Help topic
on the selected command, dialog box option, or system 
message.

SHIFT+F1 Changes the pointer to  so you can get Help on a specific 
command, screen region, or key. You can then choose a 
command, click the screen region, or press a key or key 
combination you want to know more about.
(This feature is not available in all Windows applications.)



Menu Keys

Key(s) Function

Alt Selects the first menu on the menu bar.
Letter key Chooses the menu, or menu item, whose underlined letter 

matches the one you type.
Alt+letter key Pulls down the menu whose underlined letter matches the one 

you type.
LEFT or RIGHT ARROW Moves among menus.
UP or DOWN ARROW Moves among menu items.
Enter Chooses the selected menu item.



System Keys

The following keys can be used from any window, regardless of the application you are 
using.

Key(s) Function

Ctrl+Esc Switches to the Task List.
Alt+Esc Switches to the next application window or minimized icon, 

including full-screen programs.
Alt+TAB Switches to the next application window, restoring applications 

that are running as icons.
Alt+PrtSc Copies the entire screen to Clipboard.
Ctrl+F4 Closes the active window.
F1 Gets Help and displays the Help Index for the application. (See 

Help Keys)



Text Selection Keys

Key(s) Function

SHIFT+LEFT or RIGHT ARROW Selects text one character at a time to the left 
or right.

SHIFT+DOWN or UP Selects one line of text up or down.
SHIFT+END Selects text to the end of the line.
SHIFT+HOME Selects text to the beginning of the line.
SHIFT+PAGE DOWN Selects text down one window.

Or, cancels the selection if the next window is 
already selected.

SHIFT+PAGE UP Selects text up one window.
Or, cancels the selection if the previous 
window is already selected.

CTRL+SHIFT+LEFT or RIGHT ARROW Selects text to the next or previous word.
CTRL+SHIFT+UP or DOWN ARROW Selects text to the beginning (UP ARROW) or 

end (DOWN ARROW) of the paragraph.
CTRL+SHIFT+END Selects text to the end of the document.
CTRL+SHIFT+HOME Selects text to the beginning of the document.



Window Keys

Key(s) Function

ALT+SPACEBAR Opens the Control menu for an application window.
ALT+Hyphen Opens the Control menu for a document window.
Alt+F4 Closes a window.
Alt+Esc Switches to the next application window or minimized icon, 

including full-screen programs.
Alt+TAB Switches to the next application window, restoring applications 

that are running as icons.
Alt+ENTER Switches a non-Windows application between running in a 

window and running full screen.
DIRECTION key Moves a window when you have chosen Move from the Control 

menu.
Or, changes the size of a window when you have chosen Size 
from the Control menu.




