
Shows the registry key tree (hierarchy) and lists INI files. When you click a registry key in this pane, its values are 
displayed in the Value pane to the right. When you open the folder for an INI file, the sections it contains are 
displayed; click on a section folder to display its values in the Value pane to the right.

You can add new INI files to the display by choosing Open INI File from the File menu.



Shows the values of the registry key or INI file section selected in the Key pane to the left.



This column lists the names of the values associated with the registry key or INI file section selected in the Key pane
to the left. Click this column heading to reverse the order in which value names are displayed.



This column lists the data stored in the values associated with the registry key or INI file section selected in the Key 
pane to the left.



Displays information about the key or INI file section selected in the Key pane.



Shows the keys you have bookmarked. To go directly to a bookmarked key, right-click it on this tab, then choose Go 
To Bookmark from the context menu.

Top-level registry keys, such as HKEY_LOCAL_MACHINE, cannot be bookmarked.



Shows the results of searches initiated using Find Keys, Values, And Data, or Find Orphans from the Edit menu.



If the registry key or INI file selected in the Key pane above has been monitored by Norton Registry Tracker, the 
Tracker Info tab lists the stored snapshots of that item. Each snapshot shows any changes that were made to the 
registry key or INI file since the previous snapshot was taken.
Pressing the F5 key refreshes the display to show any snapshots taken while this tab was open.

Use Norton Registry Tracker to specify registry keys and INI files to be tracked. Norton Registry Tracker 
automatically takes "snapshots" of registry keys and INI files you specify whenever the information they contain 
changes.

Click here  to start Norton Registry Tracker.



Lists any changes made to the registry, such as adding and deleting keys and values, during the current session. To 
reverse a change, right-click its Action and choose Undo This from the context menu.



This column lists the types of changes made during the current Norton Registry Editor session. To reverse a change,
right-click its Action and choose Undo This from the context menu.



This column describes actual changes made during the current Norton Registry Editor session. To reverse a change, 
right-click its Action and choose Undo This from the context menu.



Specify the text to search for by typing it in the box provided.



Specify the new text by typing it in the box provided.



Finds orphan registry value names and data.
"Orphan" registry entries are obsolete values that refer to nonexistent files and paths on your computer. Orphans 
are usually the result of incompletely removed programs. They take up space in the registry and serve no useful 
function. Once you have located them, it is usually safe to delete them from the registry.



Click this and choose from the list of places to search.



Limits search to finding only those keys, value names, or data that contain only the text you entered above. If this 
box is unchecked, the search finds instances where the text you entered is part of a larger string.



Click this to search the entire registry.



Click this and specify a registry key in the box below to limit the search to one branch of the registry.



Check this to include registry keys in the search.



Check this to include value names in the search.



Check this to include value data in the search.



Cancels the search currently in progress.



Enter the new value data in the text box provided.



Enter the new value data in the text box provided. Individual strings in the multi-string value should be separated 
by carriage returns.



Enter the new value data in the text box provided. Flag environment variables in the expanded string by enclosing 
them in a pair of percent (%) symbols.



Enter the new value data in the text box provided. You may enter the data in either binary, decimal, or hexadecimal
format by clicking the appropriate base from the group at the right.



Enter the new value data in the text box provided. Binary data must be entered in hexadecimal notation.
idh rege print from where



Click this and choose an item from the list to be printed.



Click this to print out the entire registry.
This can be a time-consuming and paper-consuming task.



Click this and enter a registry key to limit printing to one branch of the registry.



Select the print quality or resolution from the drop-down list. Higher-quality choices may take longer to print.
The resolutions or print qualities available depend on your printer's capabilities.



Enter the number of copies you want to print in the box to the right.



Organizes pages when you print multiple copies of a document so that complete copies of the document are printed
sequentially. If you do not check this option, your printer will print all necessary copies of page one before it begins 
printing all copies of page two, and so forth.



Shows your current printer settings and allows you to set printer options.



Presents a list of registries to which you have access and from which you can export REG files.



Click this to export the entire registry.



Click this and enter a registry key to limit the export to one branch of the registry.



To rename a registry key:
1 Right-click the key you want to rename.
2 Choose Rename from the context menu.
3 Type a new name for the key.

Warning: The registry is fundamental to the proper functioning of your system. You should only change registry 
entries if you know what you are doing, and are confident of the results. Improper use of Norton Registry Editor 
can cause problems with your system that may even result in your having to reinstall Windows. Always make a 
backup of your registry before you make any changes; from the File menu of Norton Registry Editor, choose 
Backup Entire Registry.

Click here 
{button ,AL("REGEDIT_T0020;REGEDIT_T0030;REGEDIT_T0040;REGEDIT_T0050;REGEDIT_T0060;REGEDIT_T0070;RE
GEDIT_T0360;REGEDIT_I0010;REGEDIT_I0040;REGEDIT_I0160")} for related information.



To rename a registry value:
1 Click the key that contains the value you want to rename.
2 In the Value pane, right-click the value you want to rename.
3 Choose Rename from the context menu.
4 Type the new name for the value.

Warning: The registry is fundamental to the proper functioning of your system. You should only change registry 
entries if you know what you are doing, and are confident of the results. Improper use of Norton Registry Editor 
can cause problems with your system that may even result in your having to reinstall Windows. Always make a 
backup of your registry before you make any changes; from the File menu of Norton Registry Editor, choose 
Backup Entire Registry.

Click here 
{button ,AL("REGEDIT_T0010;REGEDIT_T0030;REGEDIT_T0040;REGEDIT_T0050;REGEDIT_T0060;REGEDIT_T0070;RE
GEDIT_T0360;REGEDIT_I0010;REGEDIT_I0040;REGEDIT_I0160")} for related information.



To change a registry value:
1 Click the key whose value you want to change.
2 In the Value pane, double-click the name of the value you want to change.
3 Type the new data for the value in the Modify Value dialog box.

Warning: The registry is fundamental to the proper functioning of your system. You should only change registry 
entries if you know what you are doing, and are confident of the results. Improper use of Norton Registry Editor 
can cause problems with your system that may even result in your having to reinstall Windows. Always make a 
backup of your registry before you make any changes; from the File menu of Norton Registry Editor, choose 
Backup Entire Registry.

Click here 
{button ,AL("REGEDIT_T0010;REGEDIT_T0020;REGEDIT_T0040;REGEDIT_T0050;REGEDIT_T0060;REGEDIT_T0070;RE
GEDIT_T0360;REGEDIT_0010;REGEDIT_I0040;REGEDIT_I0160")} for related information.



To add a registry key:
1 Right-click a key to contain the new key.
2 Choose New from the context menu.
3 Choose Key from the cascading menu.
4 Type a name for the new key.
5 Press Enter.
Click here 
{button ,AL("REGEDIT_T0010;REGEDIT_T0020;REGEDIT_T0030;REGEDIT_T0050;REGEDIT_T0060;REGEDIT_T0070;RE
GEDIT_T0360;REGEDIT_I0010;REGEDIT_I0040;REGEDIT_I0160")} for related information.



To add a registry value:
1 Right-click a key to contain the new value.
2 Choose New from the context menu.
3 Choose the appropriate value type from the cascading menu.
4 Type a name for the value and press the Enter key.
5 Double-click the new value name or press Enter.
6 Type the data for the new value in the Modify Value dialog box.
Click here 
{button ,AL("REGEDIT_T0010;REGEDIT_T0020;REGEDIT_T0030;REGEDIT_T0040;REGEDIT_T0060;REGEDIT_T0070;RE
GEDIT_T0360;REGEDIT_I0010;REGEDIT_I0040;REGEDIT_I0160")} for related information.



To delete a registry key:
1 Right-click the key you want to delete.
2 Choose Delete from the context menu.

Deleting a registry key deletes any subkeys and values it contains.
Warning: The registry is fundamental to the proper functioning of your system. You should only change registry 
entries if you know what you are doing, and are confident of the results. Improper use of Norton Registry Editor 
can cause problems with your system that may even result in your having to reinstall Windows. Always make a 
backup of your registry before you make any changes; from the File menu of Norton Registry Editor, choose 
Backup Entire Registry.

Click here 
{button ,AL("REGEDIT_T0010;REGEDIT_T0020;REGEDIT_T0030;REGEDIT_T0040;REGEDIT_T0050;REGEDIT_T0070;RE
GEDIT_T0360;REGEDIT_I0010;REGEDIT_I0040;REGEDIT_I0160")} for related information.



To delete a registry value:
1 Click the key that contains the value you want to delete.
2 Right-click the value you want to delete in the Value pane.
3 Choose Delete from the context menu.

Warning: The registry is fundamental to the proper functioning of your system. You should only change registry 
entries if you know what you are doing, and are confident of the results. Improper use of Norton Registry Editor 
can cause problems with your system that may even result in your having to reinstall Windows. Always make a 
backup of your registry before you make any changes; from the File menu of Norton Registry Editor, choose 
Backup Entire Registry.

Click here 
{button ,AL("REGEDIT_T0010;REGEDIT_T0020;REGEDIT_T0030;REGEDIT_T0040;REGEDIT_T0050;REGEDIT_T0060;RE
GEDIT_T0360;REGEDIT_I0010;REGEDIT_I0040;REGEDIT_I0160")} for related information.



To refresh the registry display:
Press the F5 key or choose Refresh from the View menu.

Click here {button ,AL("REGEDIT_I0010;REGEDIT_I0040;REGEDIT_T0090")} for related information.



To expand or collapse registry tree branches:
Click the plus sign next to a key to expand it and show its contents.
Click the minus sign next to a key to collapse it and hide its contents.

Click here {button ,AL("REGEDIT_I0010;REGEDIT_I0040;REGEDIT_T0080;REGEDIT_I0160")} for related information.



To view information about a registry key or value:
1 Click the key or value.
2 Click the Advisor tab.
Click here {button ,AL("REGEDIT_T0090;REGEDIT_I0010;REGEDIT_I0160;REGEDIT_I0050")} for related information.



To view the snapshots list for tracked registry keys:
Click the Tracker History tab. This tab displays the Snapshot Log of items that are currently being tracked.
Use Norton Registry Tracker to specify items to be tracked.

Click here {button ,AL("REGEDIT_I0090;REGEDIT_I0010")} for related information.



To connect to another computer's registry:
1 From the Registry menu, choose Connect Network Registry.
2 Type in the name of a remote computer on your network, or click Browse.

To access registries on remote computers, you must have set up network administrator options when you 
installed Windows. For more information, see the Windows 95 Resource Kit.
Click here {button ,AL("REGEDIT_T0140;REGEDIT_I0010")} for related information.



To disconnect from another computer's registry:
From the Registry menu, choose Disconnect Network Registry.

Click here {button ,AL("REGEDIT_T0130;REGEDIT_I0010")} for related information.



To print the registry:
1 Open Norton Registry Editor.
2 From the File menu, choose Print.
By default, Norton Registry Editor will print only the branch of the registry currently selected in the Key pane. If you 
want to print the entire registry, click All in the Print Registry File dialog box.

Click here {button ,AL("REGEDIT_I0010")} for related information.



To import a registry file:
1 From the File menu, choose Import Registry File.
2 Specify the registry (REG) file you want to import.

Warning: The registry is fundamental to the proper functioning of your system. You should only change registry 
entries if you know what you are doing, and are confident of the results. Improper use of Norton Registry Editor 
can cause problems with your system that may even result in your having to reinstall Windows. Always make a 
backup of your registry before you make any changes; from the File menu of Norton Registry Editor, choose 
Backup Entire Registry.

Click here {button ,AL("REGEDIT_T0170;REGEDIT_T0180;REGEDIT_T0190;REGEDIT_I110")} for related information.



To export a registry file:
1 Click the key to be exported.
2 From the File menu, click Export Registry File.
3 Specify the name and location of the REG file that should be created.
Click here {button ,AL("REGEDIT_T0160;REGEDIT_T0180;REGEDIT_T0190;REGEDIT_I0110;REGEDIT_T0270")} for 
related information.



To save a Symantec Registry Archive:
1 Click the key to be archived.
2 From the File menu, choose Save Symantec Registry Archive.
3 Specify the name and location of the archive (SRG) file that should be created.
Click here {button ,AL("REGEDIT_T0190;REGEDIT_T0160;REGEDIT_T0170;REGEDIT_T0270;REGEDIT_I0110")} for 
related information.



To restore a Symantec Registry Archive:
1 Select the key under which you want the archived information to be restored.
2 From the File menu, choose Restore Symantec Registry Archive.
3 Specify the location and name of the SAR file that is to be restored.
4 Click Open.

The keys and values from the archive will be placed under the currently selected key, even if that key 
is not the original location from which the information was archived. If you wish to restore the information back to 
its original location, be sure the original key is selected, or use the export and import feature of REG files, rather 
than restoring from a Symantec Registry Archive.

Warning: The registry is fundamental to the proper functioning of your system. You should only change registry 
entries if you know what you are doing, and are confident of the results. Improper use of Norton Registry Editor 
can cause problems with your system that may even result in your having to reinstall Windows. Always make a 
backup of your registry before you make any changes; from the File menu of Norton Registry Editor, choose 
Backup Entire Registry.

Click here {button ,AL("REGEDIT_T0180;REGEDIT_T0160;REGEDIT_T0170;REGEDIT_T0270;REGEDIT_I0110")} for 
related information.



To load an INI file into Norton Registry Editor:
1 From the File menu, choose Load INI File.
2 Specify the name and location of the INI file you want to open.
3 Click Open.

The file is added to the INI Files branch in Norton Registry Editor.
Click here {button ,AL("REGEDIT_T0210;REGEDIT_T0220;REGEDIT_I0010")} for related information.



To create a new INI file:
1 From the File menu, choose Create New INI File.
2 Specify a name and location for the new INI file.
3 Click Save.

The new file is added to the INI Files branch in Norton Registry Editor.
Click here {button ,AL("REGEDIT_T0200;REGEDIT_T0220;REGEDIT_I0010")} for related information.



To unload an INI file from Norton Registry Editor:
1 From the File menu, click Unload INI File.
2 Click the name of the INI file to be unloaded in the Unload INI Files dialog box.

Not all INI files can be unloaded from Norton Registry Editor. Certain INI files, such as WIN.INI and 
SYSTEM.INI, are standard under Windows, and will always be displayed by Norton Registry Editor.
Click here {button ,AL("REGEDIT_T0200;REGEDIT_T0210;REGEDIT_I0010")} for related information.



To create a shortcut to a registry key:
1 Right-click the key.
2 Click Make Shortcut.

Shortcut icons look like folders with a small arrow at their lower left edge.
Click here {button ,AL("REGEDIT_T0240;REGEDIT_T0290;REGEDIT_I0060")} for related information.



To remove a shortcut to a registry key:
1 Right-click the shortcut.
2 Click Remove Shortcut.
Click here {button ,AL("REGEDIT_T0230;REGEDIT_T0340;REGEDIT_I0060")} for related information.



To find a registry key or value:
1 From the Edit menu, choose Find.
2 Click Text and type the text that you want to find, or

click Orphans to find orphan values.
3 Click the Find Where box to choose where to search.
4 Choose other search options from the Advanced tab of the Find dialog box.
5 Click Find Now to begin the search.

The results of the search appear on the Find Results tab. Right-click one of the listed search results and 
choose Go Here from the context menu to display that item above in the Key pane.
Click here {button ,AL("REGEDIT_T0260;REGEDIT_I0080;REGEDIT_T0255")} for related information.



To find and replace a registry key or value:
1 From the Edit menu, choose Replace.
2 Type the text to find in the Find What box.
3 Type the new text in the Replace With box.
4 Click the Find Where box to choose where to search.
5 Choose other search options from the Advanced tab of the Find dialog box.
6 Click Replace to begin the search.

The results of the search appear on the Find Results tab. As Norton Registry Editor finds entries that match 
your criteria, it highlights them in the Key pane (the left pane) and asks you to confirm the replacement. Click Yes to
replace the highlighted key or value with the text you have specified; click No if you do not want to replace the 
highlighted key or value.
Click here {button ,AL("REGEDIT_T0260;REGEDIT_I0080;REGEDIT_T0255")} for related information.



To find orphan registry values:
1 From the Edit menu, choose Find.
2 Click Orphans on the Find dialog box.
3 Click Find Now to begin the search.

The results of the search appear on the Find Results tab. Right-click one of the listed search results and 
choose Go Here from the context menu to display that item above in the Key pane. From the Key pane, you can 
delete obsolete registry values.
Click here {button ,AL("REGEDIT_T0250;REGEDIT_I0080;REGEDIT_T0260")} for related information.



To back up the registry:
1 From the File menu, choose Backup Entire Registry.
2 Specify the name and location for the backup registry (REG) file.
3 Click Save.

While the registry is being exported, you can continue to work on other things. You can even export 
individual branches of the registry to different REG files while the entire registry is being backed up.
Click here {button ,AL("REGEDIT_T0180;REGEDIT_I0110")} for related information.



To bookmark a registry key:
1 Right-click the key that you want to bookmark.
2 Choose Bookmark This from the context menu.

A red dot on a folder in the Key pane indicates that the corresponding registry key is bookmarked. Top-level
registry keys cannot be bookmarked.
Click here 
{button ,AL("REGEDIT_T0300;REGEDIT_T0310;REGEDIT_T0320;REGEDIT_T0330;REGEDIT_T0340;REGEDIT_I0060;RE
GEDIT_T0230")} for related information.



To save bookmarks to a file:
1 From the Bookmarks menu, click Save Bookmarks.
2 Specify a name and location for the bookmark file.
3 Click Save.
Click here 
{button ,AL("REGEDIT_T0290;REGEDIT_T0310;REGEDIT_T0320;REGEDIT_T0330;REGEDIT_T0340;REGEDIT_I0060")} 
for related information.



To load saved bookmarks:
1 From the Bookmarks menu, click Load Bookmarks.
2 Specify the name and location of the bookmark file to load.
3 Click Open.
Click here 
{button ,AL("REGEDIT_T0290;REGEDIT_T0300;REGEDIT_T0320;REGEDIT_T0330;REGEDIT_T0340;REGEDIT_I0060")} 
for related information.



To go to a bookmark
Double-click the bookmark on the Bookmarks tab.

Click here 
{button ,AL("REGEDIT_T0290;REGEDIT_T0300;REGEDIT_T0310;REGEDIT_T0330;REGEDIT_T0340;REGEDIT_I0060;RE
GEDIT_T0230")} for related information.



To view a list of bookmarks
1 Click the Bookmarks tab.
2 Click the plus sign next to a listed key to expand it and show the bookmarks defined for it.
Click here 
{button ,AL("REGEDIT_T0290;REGEDIT_T0300;REGEDIT_T0310;REGEDIT_T0320;REGEDIT_T0340;REGEDIT_I0060")} 
for related information.



To remove a bookmark
2 On the Bookmarks tab, right-click the bookmark you want to remove.
3 Choose Delete from the context menu.
Click here 
{button ,AL("REGEDIT_T0290;REGEDIT_T0300;REGEDIT_T0310;REGEDIT_T0320;REGEDIT_T0330;REGEDIT_I0060")} 
for related information.



To prevent Norton Registry Editor from changing the registry:
Check Read Only on the Registry menu.
Clicking Read Only toggles the check mark on and off. A check by the Read Only menu choice indicates 

that the registry is protected from changes. The status line will show "Read Only" at the lower right.
Click here {button ,AL("REGEDIT_I0010")} for related information.



To undo an action
From the Edit menu, choose Undo.
The edits you performed during the current session of Norton Registry Editor are listed on the Undo tab. 

When you click Undo, the bottom action on this list is undone.
Click here {button ,AL("REGEDIT_I0070;REGEDIT_I0010")} for related information.



To specify registry keys and INI files to track:
1 Click here  to start Norton Registry Tracker if it is not already running.
2 Choose Settings from the Norton Registry Tracker Options menu.
3 Click the tab for the type of item you want to track. INI files are Text Files, binary files are Data Files.
4 Click Add.
5 Select the specific item you want Norton Registry Tracker to start monitoring.
6 Click Open.

When you return to the Norton Registry Editor Tracker Info tab, press F5 to refresh the display.
Click here 
{button ,AL("REGTRK_I0010;REGTRK_I0020;REGTRK_I0030;REGTRK_I0040;REGTRK_I0070;REGTRK_T0190;REGTRK_T
0160;REGTRK_I0050,2")} for related information.



About Norton Registry Editor
Norton Registry Editor is a powerful tool for navigating and editing the Windows registry and the various 
initialization (INI) files that may be associated with some older Windows applications.
The registry is the centralized database used by Windows and newer Windows applications to store configuration 
information. It contains settings for system hardware, software, and network applications. Programs can freely 
modify and retrieve this information as necessary.
In earlier versions of Windows, configuration information was often stored in text files, such as INI files, 
AUTOEXEC.BAT, and CONFIG.SYS. These files are still supported by Windows for compatibility with older 
applications, but Windows and most new applications now make extensive use of the registry instead. Because it is 
centralized and so widely used, the registry contains much information that is vital to your computer's operation. 
For the same reasons, the registry can grow to be very large, complex, and difficult to navigate.
Norton Registry Editor helps you understand the structure of the registry and facilitates managing the registry. It 
helps you to examine, add, modify, or delete information stored in the registry. You can use Norton Registry Editor 
to troubleshoot application or device configuration settings, create a back up copies of your registry, and customize 
the Windows user interface.
In addition, Norton Registry Editor lets you easily view and manage the contents of any INI files.

Warning: The registry is fundamental to the proper functioning of your system. You should only change registry 
entries if you know what you are doing, and are confident of the results. Improper use of Norton Registry Editor 
can cause problems with your system that may even result in your having to reinstall Windows. Always make a 
backup of your registry before you make any changes; from the File menu of Norton Registry Editor, choose 
Backup Entire Registry.

Click here 
{button ,AL("REGEDIT_I0020;REGEDIT_I030;REGEDIT_I040;REGEDIT_I0110;REGEDIT_I0160;REGEDIT_T0040;REGEDI
T_T0050")} for related information.



Why you should use Norton Registry Editor
Every time you add software or hardware, the registry database is updated. Occasionally some changes to the 
registry may leave your computer behaving strangely and can even prevent Windows or certain programs or 
hardware components from operating properly. Using Norton Registry Editor in conjunction with Norton Registry 
Tracker lets you see exactly what has been changed, and helps you either make corrections in the registry or 
restore the registry to its state prior to the changes.
Many of the settings stored in the Windows registry are changed automatically when you make changes within 
application programs, such as changing settings in the Windows Control Panel or selecting program. In most cases, 
it's easier and safer to make configuration changes from the programs themselves and thereby avoid making 
changes directly to the registry.
However, some user interface customizations and performance-enhancing modifications can only be made directly 
in the registry. Certain hardware troubleshooting chores can also require direct registry access. Sometimes, you 
may want to have a look at the registry just to understand how your programs are configured.
Norton Registry Editor includes:

Information about many of the registry items that can help you understand how they're used by your 
system.

Built in navigational aids that quickly find or return you to registry areas of interest.
Features to facilitate making and restoring backups of the registry.
Editing tools to help you add, modify, and delete registry items.
A Read-Only setting to prevent you from making changes to the registry until you're ready.
Tracking features used in conjunction with Norton Registry Tracker that let you follow changes made to the 

registry and that can restore the registry to previous states.
Together these features provide a complete toolkit for managing and investigating the Windows registry.
Click here 
{button ,AL("REGEDIT_I0010;REGEDIT_I030;REGEDIT_I040;REGEDIT_I0110;REGEDIT_I0160;REGEDIT_T0040;REGEDI
T_T0050;REGEDIT_T0350;REGEDIT_T0270")} for related information.



When you should use Norton Registry Editor
Use Norton Registry Editor whenever you want information about the registry or your registry settings, or when you 
need to make changes to the registry or to INI files on your system. Norton Registry Editor can be used by system 
administrators to compare registries and INI files on remote networked PCs.
You should always back up the registry before making any modifications. Norton Registry Editor makes this a 
painless, one-step process. You can also save portions of the registry to special files, and later merge these files 
back into the registry to restore the settings.
Click here 
{button ,AL("REGEDIT_I0020;REGEDIT_I010;REGEDIT_I040;REGEDIT_I0110;REGEDIT_I0160;REGEDIT_T0100;REGEDI
T_T0270")} for related information.



About the Norton Registry Editor screen
The Norton Registry Editor screen has three viewing areas:

The Key pane, at the upper left, displays the registry keys and INI file sections. These are roughly 
analogous to categories of stored information.

The Value pane, at the upper right, displays the values stored in the registry key or INI file section selected 
in the Key pane. You can display the values in any of four views.

Below the Key and Value panes are the information tabs. The tabs provide a display area for some of the 
Norton Registry Editor features. There are five information tabs:

Advisor displays information about the items currently selected in the Key and Value panes.
Bookmarks lists any bookmarked registry keys and INI file sections, letting you quickly find and jump to 

specific areas of interest.
Undo records a history of edits made during the current Norton Registry Editor session. You can view the 

list of changes, and undo them.
Find Results lists results of the last Find operation you performed. You can instantly go to any of the items

found.
Tracker History shows the history of changes to the item maintained by Norton Registry Tracker. Unlike 

the changes recorded by the Undo tab, those recorded by Norton Registry Tracker persist from one session to the 
next.
You can change the relative sizes of the viewing areas by dragging the frame border that separates them.
Click here 
{button ,AL("REGEDIT_I0050;REGEDIT_I0060;REGEDIT_I0070;REGEDIT_I0080;REGEDIT_I0090;REGEDIT_I0100;REGE
DIT_I0210;REGEDIT_I0220")} for related information.



About the Advisor tab
The Advisor tab of Norton Registry Editor displays information about the item currently selected in the Key and 
Value panes. Information is available on many registry keys and values, as well as many common INI file sections 
and values.
The registry is an open and dynamic environment, with keys and values continually being added, changed, and 
removed by various programs running on your system. The specific items contained in the registry will depend on 
your system's current configuration and on the software you have installed. The exact structure of your system's 
registry is unpredictable simply because the possibilities for registry entries are unlimited.
Consequently, it would be virtually impossible to describe each and every item in the registry, and there will likely 
be many items for which no specific Advisor information is available. In these cases, the Advisor searches up the 
registry hierarchy to find the nearest related information available, and displays that. Because the registry is 
organized in a hierarchical fashion, the information at any level will apply to the items in that level and its sublevels 
as well.
Click here 
{button ,AL("REGEDIT_I0160;REGEDIT_I0060;REGEDIT_I0070;REGEDIT_I0080;REGEDIT_I0090;REGEDIT_T0100")} for
related information.



About the Bookmarks tab and registry shortcuts
The Bookmarks tab provides one-stop access to all the registry keys and INI file sections you have bookmarked. The
bookmarks appear in a hierarchical list that reflects the structure of the Key pane, but only includes those top 
branches of the hierarchy that contain bookmarked items.
To bookmark an item, right-click it in the Key pane, and choose Bookmark This from the context menu.
To instantly return to one of your bookmarked items, simply double-click it on the Bookmark tab.
You can save your bookmarks from one session to the next by choosing Save Bookmarks from the Bookmarks 
menu. To load your bookmarks during another Norton Registry Editor session, choose Load Bookmarks, and specify 
the bookmark file you want to load. You can save several sets of bookmarks for different types of Norton Registry 
Editor jobs, and load a different set whenever you want.
You can also create shortcuts to registry keys by right-clicking a key and choosing Make Shortcut from the context 
menu. Like bookmarks, shortcuts speed access to registry keys of interest, especially those keys buried deep in the 
registry hierarchy. Shortcuts differ from bookmarks in that they are placed directly at the top level of the hierarchy, 
rather than on the Bookmarks tab. When expanded, shortcuts display all the subkeys and values of the original key.
Click here 
{button ,AL(";REGEDIT_I0050;REGEDIT_I0070;REGEDIT_I0080;REGEDIT_I0090;REGEDIT_T0230;REGEDIT_T0240;REG
EDIT_T0290;REGEDIT_T0300;REGEDIT_T0310;REGEDIT_T0320;REGEDIT_T0330;REGEDIT_T0340")} for related 
information.



About the Undo tab
The Undo tab lists any changes made to the registry from Norton Registry Editor during the current session. 
Whenever you add, modify, or delete registry or INI file items, the transaction is logged on the Undo tab.
The Action column lists the action that was performed, such as Create, Delete, Rename, and Modify. The Description
column lists the items on which those actions were performed.
When you choose Undo from the Edit menu, the action at the bottom of the list is undone.

You can undo changes that occurred outside of the current Norton Registry Editor session if you use Norton
Registry Tracker. It lets you track any changes that occur to selected registry keys and INI files. You can see a 
history of changes, compare the different "snapshots", or selectively restore the tracked items to previous states.
Click here {button ,AL(";REGEDIT_I0060;REGEDIT_I0050;REGEDIT_I0080;REGEDIT_I0090;REGEDIT_T0360")} for 
related information.



About the Find Results tab and registry searches
The Find Results tab lists the results of the most recent search operation Norton Registry Editor performed. Each of 
the results listed functions as a bookmark; you can right-click on any of the items found and choose Go Here from 
the context menu to display that item in the Key or Value pane.
To search the registry and/or INI files, choose Find from the Edit menu. You can search the registry, INI files, or both. 
You can limit the search to a single branch of the registry. You can search registry keys, value names, value data, or 
some combination of the three. You can even search registries of remote computers, if you are a network 
administrator.
You can also check Find Orphans in the Find dialog box to search for any orphan registry entries. "Orphan" registry 
entries are obsolete values that refer to nonexistent files and paths on your computer. Orphans are usually the 
result of incompletely removed programs.
Most new 32-bit applications written for Windows can be completely removed by using Add/Remove Programs from 
the Windows Control Panel. This removes program files and folders, and any registry entries created by and for the 
program. If you remove a program by manually deleting the program's files and folders, any registry entries created
by the program are left in the registry, serving no useful purpose.
Any orphans that are found are listed on the Find tab. After inspecting the results, you can delete registry entries 
that are obsolete.
Click here 
{button ,AL(";REGEDIT_I0060;REGEDIT_I0070;REGEDIT_I0050;REGEDIT_I0090;REGEDIT_T0250;REGEDIT_T0254;REG
EDIT_T0260")} for related information.



About the Tracker History tab
The Tracker History tab works in conjunction with Norton Registry Tracker to display changes to tracked registry 
keys and INI file sections. Unlike the changes displayed on the Undo tab, the changes recorded on the Tracker 
History tab are not limited to changes made from Norton Registry Editor; any change made to a tracked item is 
listed on this tab as long as the item is being tracked. Furthermore, the log of changes to tracked items persists 
between Norton Registry Editor sessions.
Norton Registry Tracker lets you select which registry keys and INI file sections should be tracked. Whenever a 
change is made to a tracked item, the change is recorded in the Norton Registry Tracker Snapshot Log. If there are 
tracking snapshots available for the item currently selected in the Key pane, those snapshots appear in the Tracker 
History tab.
Changes to tracked items are indicated by the icons to the left of the items:

Indicates something that has been added.
Indicates something that has been removed.
Indicates a line in a text file that has been moved within a file.

The moved text is preceded by the line number from which the text was moved.
Indicates a line in a text file that has been moved within a file.

The moved text is preceded by the line number to which the text was moved.
Note that the Tracker History displayed for a particular item is only current if that item is being actively 

tracked from Norton Registry Tracker. If you disable an item's tracking from Norton Registry Tracker, or close Norton 
Registry Tracker, and subsequently make changes to the item, the snapshot information displayed on the Tracker 
History tab will be obsolete.
Click here 
{button ,AL(";REGEDIT_I0060;REGEDIT_I0070;REGEDIT_I0080;REGEDIT_I0050;REGEDIT_I0150;REGEDIT_I0110;REGE
DIT_T0120")} for related information.



About Value pane views
The View menu has four options for displaying the data in the Value pane:

List View presents the value names arranged in columns. The value names are preceded by small icons 
representing the value type, and the value data is not shown.

Report View presents the value names and value data in two columns. You can click the Name column 
heading to sort the list by name; each time you click the column heading the sort order is reversed. The names are 
preceded by small icons representing the value type.

Large Icon View presents the values as large labeled icons that represent the value types. The icons are 
arranged in rows.

Small Icon View presents the values as small labeled icons that represent the value types. The icons are 
arranged in rows.
For each of the views, you can use View menu options to sort the display by value names or value types.
Click here 
{button ,AL("REGEDIT_I0210;REGEDIT_I0220;REGEDIT_T0020;REGEDIT_T0030;REGEDIT_T0050;REGEDIT_T0070")} 
for related information.



About registry files and Symantec Registry Archives
You should make periodic backups of your registry, especially before making any changes to registry keys. A 
registry backup file can help you restore the registry to a known working state, in case you should inadvertently 
change registry items that make your system unstable.
With Norton Registry Editor, making backups is a simple process: simply choose Backup Entire Registry from the File
menu. The Save As dialog box lets you specify a name and location for the registry backup file. Registry backup files
are saved a text format, and given a REG file extension. Because backing up your entire registry can take some 
time, the registry backup runs as a separate process in the background, and can be minimized so you can continue 
working.
In addition to saving the whole registry, you can also save individual branches of it. For example, if you are making 
changes within a specific branch of the registry, you can save just that portion of the registry. This process is faster, 
and takes less disk space than saving the entire registry (though you should always have at least one copy of the 
entire registry available for emergencies).
Portions of the registry can be saved in either of two formats, each of which serves a different purpose:

Registry (REG) files are simple text files that can be exported from and imported to the registry, whether or
not you are running Norton Registry Editor.

Symantec Registry Archive (SRG) files are binary (non-viewable) format, and can only be used by Norton 
Registry Editor.
Click here 
{button ,AL("REGEDIT_I0120;REGEDIT_I0130;REGEDIT_I0140;REGEDIT_T0270;REGEDIT_T0160;REGEDIT_T0170;REG
EDIT_T0180;REGEDIT_T0190")} for related information.



About registry (REG) files
You can save individual branches of the registry by clicking a key and choosing Export Registry File from the File 
menu. This saves the selected key together with any values and subkeys it contains to a REG file. REG files are text 
files that describe keys and values stored in the registry. Because they are text files, you can view and edit REG files
with any text editor.

Exporting does not change the registry structure at all. The registry items that are exported remain 
physically stored in the registry; the REG file is just a text copy of those items.
Large branches of the registry can take some time to export, so exports run as separate processes, which can be 
minimized so you can continue working. You can even have more than one branch exporting simultaneously (to 
different REG files).
Just as they can be exported, REG files can be "imported" into the registry. The registry items described by the REG 
file are created in the registry, or, if the items already exist in the registry, they are overwritten with the new 
information. This process is also called "merging" a REG file into the registry.
Importing REG files provides a simple way to change large numbers of registry items at one time, since each REG 
file can contain any number of different key and value descriptions. Because the REG file contains the full registry 
paths of the items it describes, importing a REG file always places the keys and values it describes in the same 
precise location within the registry hierarchy. This is in contrast to restoring registry items stored in a Symantec 
Registry Archive, where the precise placement of the registry items in the registry will depend on the location to 
which you restore the items.
Normally, REG files are used to change existing registry entries or add new ones. The import feature of Norton 
Registry Editor also lets you use REG files to delete keys and values from the registry.
Click here 
{button ,AL("REGEDIT_I0110;REGEDIT_I0130;REGEDIT_I0140;REGEDIT_T0270;REGEDIT_T0160;REGEDIT_T0170;REG
EDIT_T0180;REGEDIT_T0190")} for related information.



Using REG files to delete registry items
Warning: The registry is fundamental to the proper functioning of your system. You should only change registry 
entries if you know what you are doing, and are confident of the results. Importing REG files you have edited or 
created will change the structure of your registry, just as in editing the registry directly will. Always make a 
backup of your registry before you make any changes; from the File menu of Norton Registry Editor, choose 
Backup Entire Registry.

Norton Registry Editor lets you use imported REG files to delete registry items, in addition to adding new items or 
changing the values of existing ones. By adding the following special notation to a REG file, you can have Norton 
Registry Editor automatically delete registry items when the REG file is imported:

To delete a registry key and its subkeys, add a tilde (~) character before the key.
To delete a registry value, specify a tilde as the value's data.
To delete all values under a key, without deleting the key itself or its subkeys, include a minus sign (-) 

before the key.
For example, say you import the following REG file that creates a key containing two values and one subkey:

[HKEY_CURRENT_USER\My_New_Key]
@="My default value"
"My String"="Some string data"
[HKEY_CURRENT_USER\My_New_Key\My_New_Subkey]

To delete the My_New_Key and all the values and subkeys it contains, you could create and import a REG file having
this line:

~[HKEY_CURRENT_USER\My_New_Key]
To delete either the default (signified by an @ symbol) or My String value, you could create and import a REG file 
having either of these lines:

@=~
or

"My String"=~
(Note that there are should be no quotation marks around the tilde.)
To delete both values, without affecting the subkey, My_New_Subkey, you could create and import a REG file having
this line:

-[HKEY_CURRENT_USER\My_New_Key]
Microsoft's built-in regedit program does not allow you to delete registry items using REG files. REG file 

entries that include the special notation listed above will be ignored if the file is imported using regedit. By default, 
double-clicking a REG file imports it to the registry using Microsoft's regedit. Norton Utilities Setup Wizard lets you 
change the REG file association to cause double-clicked REG files to be imported using Norton Registry Editor 
instead.
Click here 
{button ,AL("REGEDIT_I0120;REGEDIT_I0110;REGEDIT_I0140;REGEDIT_T0270;REGEDIT_T0160;REGEDIT_T0170;REG
EDIT_T0180;REGEDIT_T0190")} for related information.



About Symantec Registry Archives
You can save individual branches of the registry by clicking a key and choosing Save Symantec Registry Archive 
from the File menu. This saves the selected key together with any values and subkeys it contains to a Symantec 
Registry Archive file, which is given a file extension of SRG. Like REG files, SRG files describe keys and values stored
in the registry. Unlike REG files, however, SRG files have a binary rather than text format, they cannot be edited or 
viewed.

Saving a branch of the registry to a Symantec Registry Archive does not change the registry structure at 
all. The registry items that are archived remain physically stored in the registry; the SAR file is just a binary 
representation of those items.
SAR files also differ from REG files in the way that their stored items are replaced into the registry when you choose 
Restore Symantec Registry Archive (also on the File menu). You must have an existing registry key highlighted 
before you can restore from an archive. The items represented in the archive are recreated in the registry under 
the currently selected key. Because of this behavior, you should be careful when restoring from an archive, and 
be sure that you have the key selected under which you want all archived items to be created.
Archives provide a convenient way of grafting entire branches of the registry to new locations.

You cannot use Symantec Registry Archives to delete items from the registry, as you can with text-based 
REG files.
Click here 
{button ,AL("REGEDIT_I0120;REGEDIT_I0130;REGEDIT_I0110;REGEDIT_T0270;REGEDIT_T0160;REGEDIT_T0170;REG
EDIT_T0180;REGEDIT_T0190")} for related information.



About registry backups
Registry data is stored in two hidden files on your system. SYSTEM.DAT stores global hardware and software 
information. USER.DAT stores user-specific hardware and software settings. Every time you start your system 
successfully, these files are backed up to SYSTEM.DA0 and USER.DA0, respectively (the backup extensions end with 
the number zero, not the letter "O"). Because of this, if there is a problem with your registry, you can restart your 
computer in DOS mode and rename the backup files to return your computer to the state it was in the last time it 
was successfully started. This may not be enough, however, especially if you tend to leave your computer running 
for long periods of time; the last time the computer was successfully started may have been days or weeks ago.
Norton Registry Editor lets you make backups of your registry as often as you like. Simply choose Backup Entire 
Registry from the File menu. The file is stored as a text file with a REG extension. Should you ever need to restore 
the registry from your backup, you can simply double-click the backup REG file to merge it back into the registry. 
You should always make a backup of the registry before you make any changes using Norton Registry Editor.
Click here 
{button ,AL("REGEDIT_I0120;REGEDIT_I0110;REGEDIT_I0140;REGEDIT_T0270;REGEDIT_T0160;REGEDIT_T0170;REG
EDIT_T0180;REGEDIT_T0190")} for related information.



About the Windows registry
The Windows registry is a centralized database used by Windows and newer Windows applications to store 
configuration information. It contains settings for system hardware, software, and network applications. Programs 
can freely modify and retrieve this information as necessary.
In earlier versions of Windows, configuration information was often stored in text files, such as INI files, 
AUTOEXEC.BAT, and CONFIG.SYS. These files are still supported by Windows for compatibility with older 
applications, but Windows and most new applications now make extensive use of the registry instead.
The registry stores two basic types of information: global information, and user-specific information. The global 
information is necessary for the basic operation of the hardware and software on your computer. The user-specific 
information includes user customized settings, such as the layout of the Windows desktop and the options you have
selected for Windows and for your Windows applications.
The following topics provide more details about the registry:

How the registry is organized
How values are represented in the registry
What's wrong with INI files?



How the registry is organized
The registry is organized into six broad categories of information called "root keys." The root keys are like data 
containers, each storing information related to a specific aspect of your system. The root keys can contain data 
values and can also contain keys of their own, or "subkeys," which help to more finely organize the registry data.
The hierarchical registry structure that results is similar to that of the folder organization on your disk, where any 
folder can contain other folders as well as files. Consequently, the registry structure in Norton Registry Editor is 
represented much as your disk structure is represented in the Windows explorer. Keys are represented as folders, 
and those containing subkeys can be expanded (by clicking the plus signs to their left) to reveal the subkeys they 
contain.
The registry's root keys are:

HKEY_CLASSES_ROOT
HKEY_CURRENT_CONFIG
HKEY_CURRENT_USER
HKEY_DYN_DATA
HKEY_LOCAL_MACHINE
HKEY_USERS

The HKEY prefix identifies the key as a programming “handle” used by applications to gain access to the registry. 
Applications and operating system modules use the handles to retrieve stored configuration data, as well as to add, 
delete, or to change settings.
HKEY_USERS, HKEY_LOCAL_MACHINE, and HKEY_DYN_DATA are the most important root keys; the other root keys 
just point to subkeys of these.
Click here 
{button ,AL("REGEDIT_I0160;REGEDIT_I0170;REGEDIT_I0180;REGEDIT_I0190;REGEDIT_I0200;REGEDIT_I0210;REGE
DIT_I0230;REGEDIT_I0240")} for related information.



HKEY_LOCAL_MACHINE
HKEY_CLASSES_ROOT
HKEY_CURRENT_CONFIG
HKEY_LOCAL_MACHINE stores global (non-user-specific) settings that relate to the hardware, software, and network 
resources available to the machine. Two of the other root keys merely reflect subkeys of HKEY_LOCAL_MACHINE.
The HKEY_LOCAL_MACHINE\Config subkey shares a relationship with HKEY_CURRENT_CONFIG that is similar to the 
relationship shared by HKEY_USERS and HKEY_CURRENT_USER.
Just as the registry can store multiple sets of user preferences, it can also store multiple sets of hardware 
configuration profiles. This comes in handy, for example, if you use a notebook computer that can be docked. When
using the notebook as a standalone machine, you would want it configured with a minimal set of hardware drivers, 
to conserve system resources. When using the notebook in its docking station, however, you would need a different
hardware configuration, that includes appropriate drivers for the printer, monitor, and other peripherals to which 
the docking station is attached.
Windows can usually recognize the which hardware configuration to use on startup, and loads the appropriate 
profile automatically. If it can't, it prompts you to select a one from a list of all profiles that have been defined. 
Windows will load only those device drivers necessary for the hardware devices listed in the profile you select. (For 
more information about Windows hardware profiles, see the Windows Help.)
Each hardware profile defined for your system is assigned its own numbered subkey under HKEY_LOCAL_MACHINE\
Config. HKEY_CURRENT_CONFIG merely reflects the subkey under HKEY_LOCAL_MACHINE\Config that is currently in 
effect.
HKEY_CLASSES_ROOT reflects the subkeys under HKEY_LOCAL_MACHINE\SOFTWARE\Classes. This key stores the file
associations that allow you to simply double-click a file to have Windows automatically launch the appropriate 
application to view or edit the file. Each file extension that has a program association is listed under these keys. 
This area of the registry also contains support data for OLE applications and objects.
Click here 
{button ,AL("REGEDIT_I0160;REGEDIT_I0170;REGEDIT_I0180;REGEDIT_I0190;REGEDIT_I0200;REGEDIT_I0210;REGE
DIT_I0230;REGEDIT_I0240")} for related information.



HKEY_USERS
HKEY_CURRENT_USER
HKEY_USERS, as the name implies, stores user-specific settings—settings customized for the person logged on to 
the machine. These settings include things like the Windows desktop layout and options you have set in your 
application. Because these user preferences are stored in the registry, you won't need to reset them every time you
restart Windows or your Windows applications.
If Windows is configured to allow different users to customize their individual preferences and desktop settings, 
settings specific to each user are stored in corresponding keys under HKEY_USERS\username, where username is 
the name each user uses to log on to the system. This way, each individual user of a single computer can have 
personalized settings for network connections, desktop appearance, printer configuration, and much more. 
HKEY_CURRENT_USER merely reflects the information for the current user that is stored under the HKEY_USERS\
username subkey currently in effect.
Another benefit to keeping multiple user profiles under HKEY_USERS is that the user settings and data can be 
stored in the registry of a network server. Then when a user logs on to any computer on the network, the computer 
can use that user's personal settings.
If your machine is configured for multiple users, there are special considerations when accessing these keys in the 
registry.

To configure Windows to support multiple user profiles, click Passwords in the Windows Control Panel, and 
choose the User Profiles tab.
If Windows is set up for only a single user, HKEY_CURRENT_USER reflects the HKEY_USERS\.Default subkey.
Click here 
{button ,AL("REGEDIT_I0160;REGEDIT_I0170;REGEDIT_I0180;REGEDIT_I0190;REGEDIT_I0200;REGEDIT_I0210;REGE
DIT_I0230")} for related information.



HKEY_DYN_DATA
HKEY_DYN_DATA holds information that is dynamic in nature; it is continually being updated by the operating 
system. The uses for this data require that it always be as current as possible.
Plug-and-Play devices are smart components that communicate with the operating system and BIOS to simplify 
configuration. Much of the work of configuring these devices to avoid conflicts is coordinated through the registry. 
When you start Windows, the current system configuration, including the status of Plug-and-Play devices is stored in
RAM and tracked using the HKEY_DYN_DATA key.
Windows also stores virtual device driver data and system performance statistics under this key.

The information under HKEY_DYN_DATA is constantly being refreshed by Windows, and should not be 
changed manually.
Click here 
{button ,AL("REGEDIT_I0160;REGEDIT_I0170;REGEDIT_I0180;REGEDIT_I0190;REGEDIT_I0200;REGEDIT_I0210;REGE
DIT_I0230")} for related information.



How values are represented in the registry
The fundamental function of the registry is to store data. While the data is organized under the various registry 
keys, the data itself consists of stored values. It is usually these values that are accessed by Windows and by 
applications.
Many of the registry values are created during Windows installation by the setup program. Additional values are 
added when you make hardware changes or install applications. Registry values will vary significantly from one 
machine to another depending on the devices attached to the PC, whether the PC is attached to a network, and 
whether or not Windows 95 was installed on top of an earlier version of Windows.

Some registry keys store no values. These might be structural elements used to help organize the registry 
hierarchy, in which case the keys contain subkeys that likely store values. Other valueless keys are used as flags; 
some programs look for the mere presence or absence of these keys.
Each value consists of two parts: the value name and the value data. The value name identifies the value, the value
data is the stored information of interest. All values are stored in binary form in SYSTEM.DAT and USER.DAT, the files
that actually store the registry information. These values can be entered and displayed in a number of different 
formats:

String values hold alphanumeric text data such as the path to an application on disk.
Numeric ("DWORD") values are 32 bit values that can be entered in Norton Registry Editor as integers, 

hexadecimal digits, or binary.
Binary values can be any length, and are represented using hexadecimal digits.

Norton Registry Editor also lets advanced users view and enter binary values as expanded strings and multi-strings.
Use Norton Registry Editor to explore your registry and look at some of the values stored there. While some registry
values are comprehensible—a driver name, a program path, a software switch—many of the stored values are not 
user friendly. Such entries only make sense to the applications or devices that access them. The Advisor tab of 
Norton Registry Editor can help you understand the purpose of many of the keys and values stored in the registry.

To display the value data, Norton Registry Editor must be set to Report View. This is the default. If you 
cannot see the value data in the Value (right) pane of Norton Registry Editor, choose Report View from the View 
menu.
Click here 
{button ,AL("REGEDIT_I0160;REGEDIT_I0170;REGEDIT_I0180;REGEDIT_I0190;REGEDIT_I0200;REGEDIT_I0210;REGE
DIT_I0230")} for related information.



Expanded strings and multi-strings
It is frequently convenient for programmers to store special string data as binary registry values. Norton Registry 
Editor allows you view and edit these types of values as strings, rather than as the hexadecimal digits displayed by 
Microsoft's regedit program. Two string representations of this binary data are supported by Norton Registry Editor: 
"expanded strings" and "multi-strings."
The expanded string value type is used for string data that includes environment variables within the string. 
Expanded strings flag environment variables by enclosing them in a pair of percent (%) symbols. If a program is 
written to recognize expanded strings, the program can "expand" the environment variable to substitute the current
value of the environment variable. Thus, if an expanded string value looked like this:

"The path for temporary file storage is %TEMP%"
a program using this value would expand %TEMP% to the current value, resulting in:

"The path for temporary file storage is C:\WINDOWS\TEMP"
Multi-strings are binary values that comprise more than one string value. These can be used to store several string 
values, such as a list of file extensions, together in a single registry entry. Norton Registry Editor lets you view and 
enter these as regular text, rather than as hexadecimal digits. Individual strings in the multi-string value should be 
separated by carriage returns.
There are several reasons a programmer might want to use these special string types:

Efficiency—Multi-strings can store several text strings in a single binary registry value.
Organization—Expanded strings can be stored as distinct from regular strings, and programs can be 

written to recognize that only expanded string data requires expansion.
Security—Both multi-strings and expanded strings appear as hexadecimal notation when viewed with 

Microsoft's regedit that is included with Windows. This protects the data from casually prying eyes.
Click here {button ,AL("REGEDIT_I0210;REGEDIT_I0100;REGEDIT_T0020;REGEDIT_T0030;REGEDIT_T0050")} for 
related information.



What's wrong with INI files?
Under earlier versions of Windows, tracking settings or troubleshooting could involve quite a bit of detective work. 
Your hardware, operating system, network, and application settings were scattered—some settings were in 
application INI (initialization) files, some in the various Windows INI files, and still others in AUTOEXEC.BAT and 
CONFIG.SYS. By moving all these settings to the registry, Windows provides a global, centralized place to store 
configuration information for the operating system, hardware, and applications. The registry provides these 
advantages over INI files:

INI files are simple ASCII text files, but the registry is a binary file. Programs and system processes that use
information from the registry don't have the additional overhead of translating text data into machine-readable 
form.

INI files are limited in size to 64K, but the registry has no size limit. This unlimited registry size allows for 
future growth and greatly increases the potential for supported system resources.

INI files have a flat, two-tiered organization with sections and section entries, but the registry is a true 
hierarchical database. Although the registry can grow to be quite large, its multilevel branching arrangement 
enables Windows and other programs to access configuration data efficiently and quickly. The operating system 
uses the registry’s root keys to process only the portion of the database necessary to get the information it needs. 
To retrieve data from an INI file, the text must be processed from the top down, which is relatively slow.
Windows still supports the use of INI files in order to maintain compatibility with applications written for earlier 
versions of Windows. For unusual hardware and pre-Windows 95 software, the CONFIG.SYS, AUTOEXEC.BAT, and 
individual INI files still provide some configuration information.
Click here {button ,AL("REGEDIT_I0160")} for related information.



If your machine is configured for multiple users...
If Windows is configured to allow different users to customize their individual preferences and desktop settings, 
system administrators should bear in mind the special relationship between HKEY_USERS and 
HKEY_CURRENT_USER when inspecting or editing these branches of the registry.
In this case, the values under HKEY_USERS\.Default may not reflect the current system settings, as they may have 
been user-customized. To gain access to the settings for a specific user, system administrators should be certain 
they are in the appropriate user-specific subkey under HKEY_USERS.

To configure Windows to support multiple user profiles, click Passwords in the Windows Control Panel, and 
choose the User Profiles tab.
Click here {button ,AL("REGEDIT_I0190;REGEDIT_I0170")} for related information.




