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Welcome to Dr Solomon's Scheduler. 
This program is included as part of the award-winning Dr Solomon's Anti-Virus Toolkit.
Dr Solomon's Scheduler allows you to execute FindVirus on your computer, even while it is 
unattended. Using easy-to-follow dialogs, you simply choose which drives to scan, from a 
ready-made list box. You can even select your favorite FindVirus scan configuration simply 
by checking a list of options. 
You can ask FindVirus to execute just once, or at regular intervals. Either way, all you need to
do is to click on a calendar the date and time at which you want FindVirus to start. If you 
want FindVirus to run regularly, all you need to do is to specify the time interval, for example
every week. If you choose, you can even specify an "End Time" for FindVirus. This means 
that FindVirus will execute at regular intervals, but only between the start and end times.
But that's not all! Not only can you use Dr Solomon's Scheduler to set up FindVirus, you can 
in fact schedule any program to run. It doesn't have to be one of the utilities shipped with Dr
Solomon's Anti-Virus Toolkit, it can be any executable file, or batch file which you have 
access to. You can execute it remotely and at regular intervals.
Even better, under Windows NT you can use Dr Solomon's Scheduler to send messages to 
yourself, or to other people on your network. All you need to do is to type the message, and 
say who to send it to.



FindVirus is the award-winning Virus Detection program included in Dr Solomon's Anti-Virus 
Toolkit.
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Events
See also :
Adding and Changing Events
Copying Events
Removing Events
Disabling and Enabling Events
Saving Events
Event Data File Format
Events are the basic building blocks of your schedule. Each time you want to run a specific 
program, for example a virus scan, you can create an event to enable your chosen program 
to be executed. If you intend executing the program at regular intervals, you can build this 
into the event too. This means, for example, that if you want to check for viruses every day 
at 6:30pm you only need add one event, and Dr Solomon's Scheduler will know that you 
want the event to occur each day.
You can even tell Dr Solomon's Scheduler to ignore weekends, if you want.
But events don't have to be repeated. You can, if you choose, schedule an event so that it 
occurs only once. Additionally you can enable and disable events on an individual basis. This
means that you can "switch off" an event temporarily, without actually deleting it.
You can have as many events scheduled as you like. What's more, the event database is 
structured in a standard text format, just like a .INI file. So even though Dr Solomon's 
Scheduler lets you make changes quickly and easily, you can edit the file manually if you 
wish.



Adding and Changing Events
See also :
Event Overview
Copying Events
Removing Events
Disabling and Enabling Events
Saving Events
Event Data File Format
To add a new event, select "Add Event" from the "Edit" menu, or select the Toolbar item ( ).
To make changes to an existing event, either highlight the event in the event list, and select 
"Edit Event" from the "Edit" menu, or simply double-click on the event in the event list.
If you just want to change the name, or the start time, of the event, you can Cut ("Edit | 
Cut") and Paste ("Edit | Paste").
If you choose to Add or Change an event, an Event dialog is displayed. This dialog contains 
three main sections :
· Event Type
· Virus Scan Options
· Time Options
These sections provide a quick and easy way for you to build all the properties of your event.
Once you are satisfied with your event settings, simply select "OK".

NOTE : Dr Solomon's Scheduler stores each event by its Event Name. This means that, just 
as you can't have two files with exactly the same name, you need to give each event a 
unique name. But don't worry - Dr Solomon's Scheduler automatically checks for this.

NOTE : Once you have set up a new event you must make sure that the Scheduler is running
before the event can take place.



Event Type Dialog
The Event Type dialog stores the basic information about the event, including the event 
name and the event type. You can also store a full description of the event, and specify 
whether the event is to be enabled or not.
By default, Dr Solomon's Scheduler also writes to a "Log File" whenever an event is 
executed. The Log File records whether or not it was possible to start the event, and at what 
time the event was executed. For convenience, Dr Solomon's Scheduler allows you to 
suppress any writing to the Log File, or to ensure that the Log File is only written to following 
a failure.
In the current version of Dr Solomon's Scheduler, you may have any one of three types of 
events. The default event is to execute the FindVirus utility to check for viruses.

However, you can schedule two other types of event :

Running any Executable File

If you choose to run a program, the dialog allows you to specify exactly which program you 
wish to execute. The program has four properties :

the Program Description, for example "Text Editor"
the Command Line, for example "C:\WINDOWS\NOTEPAD.EXE"
the Working Directory - if your program requires it.
the Window Type. The application can be "Normal", "Maximized" or "Minimized".

HINT : you can pre-define a list of commonly-used programs. See the section on Setting 
Default Values for new Events for details.

Sending Messages (Windows NT only)
The third type of event is a Message event. If you choose an event of this type, the dialog 
allows you to type in a message. Again, you can create a list of default messages from which
to choose. Refer to Setting Default Values for new Events for details. If you choose to send a 
message, a list box also shows a list of recipients you have used in the past.

HINT : you can pre-define a list of commonly-sent messages. See the section on Setting 
Default Values for new Events for details.

Sending a message to yourself :
At the top of the "Recipients" list box is the "Screen" option. Instead of sending a message to
someone across your network, this option causes the message to be displayed to your 
screen. This may be useful, perhaps, as a reminder. For example, if you had a meeting at 
2:00pm each Tuesday, you could create an event which caused a warning message to pop 
up at 1:50pm.

Maximum length of Text Strings :



Any event names or descriptions may be up to 256 characters in length.

NOTE :
If you choose that the event is not a FindVirus execution, you will not be able to access the "Scan 
Options" tab. 
Conversely, if the program beeps when you try to access this tab, you should check that the "Event Type" 
has been set to perform a Virus Scan.



Scan Options Dialog
For most users of Dr Solomon's Anti-Virus Toolkit, the Scan Options Dialog will be very 
familiar ! The dialog is a point-and-click representation of all of the most common options 
which are used with the FindVirus program. 
From this dialog you can set :
· The drives to scan : 

A multi-select list box allows you simply to click on the drives you wish to scan. This is 
equivalent to the FindVirus "/D=......." command line parameter.

· Whether or not to scan Data Files : 
If you check this box, all files (not just executables) will be scanned. This is equivalent to 
the FindVirus "/DOALLFILES" option.

· Whether or not to scan inside ZIP and ARJ files : 
If you check this box, all compressed files in the formats PKZIP, ARJ and PKLite are 
scanned. This is equivalent to the FindVirus "/UNZIP" option.

· Whether or not to scan inside PKLite and LZExe files : 
If you leave this box unchecked, this is equivalent to the FindVirus "/NOPACK" option.

· Whether to scan Boot Sectors : 
If you leave this box unchecked, this is equivalent to the FindVirus "/NOBOOT" option.

· Whether to scan Partition Sectors :
If you leave this box unchecked, this is equivalent to the "/NOPART" option.

In addition, you can set the following options :

· Generate a Network Alert if a Virus is discovered : 
If the PC you are using is on a network and FindVirus discovers a virus, a message may be
sent to the Network Supervisor if this option is checked. If you wish to use this option, you
may also wish to investigate the "/MSG" and "/TELL" options, placing them in the 
"Additional Command Line Options" text box.

· Heuristic scanning : 
Enables FindVirus to use Advanced Heuristic Analysis to detect new and unknown viruses.
This is equivalent to the FindVirus "/ANALYZE" option.

· Beep upon each virus found : 
Generally, if a virus is detected, a beep is sounded at the end of the scan. However, 
checking this box causes a beep to be sounded with each occurrence of a virus. This is 
equivalent to the FindVirus "/BEEP" option.

· Automatically Repair Infected files : 
Although it is best to repair virus infections "hands-on", there may be circumstances when
you wish a remote execution of FindVirus to attempt to repair any infected files. Use of 
this option is equivalent to the FindVirus "/REPAIR" parameter.



You can force FindVirus to generate a Report on the results of a scan. From the Scan Options 
Dialog you can set the name of the file to write the report to. If you are executing an event 
several times, you may wish to add the "/APPEND" option to the "Additional Command Line 
Options" box. This will ensure that each execution of FindVirus generates a fresh report, 
which is appended to your report file.

NOTE : In addition to the checkbox options described above, it is possible to enter any of the
valid FindVirus command line parameters into the Additional Command Line Options field on 
the Scan Options dialog.



See Section 6, Advanced Virus Detection, in the Dr Solomon's Anti-Virus Toolkit User Manual.



Time Options Dialog
A vital feature of any scheduler is that the user can schedule events to run at any time of 
the day. In Dr Solomon's Scheduler, this is achieved by use of the Time Options Dialog.
Two types of event are currently supported. Firstly, you can specify an event to happen on 
one occasion only, and you can specify the date and time of that occurrence.
Secondly, and more commonly, you can specify a "Start Time" for the event. This is the time 
at which you want the first occurrence to take place. Dr Solomon's Scheduler then allows you
to qualify this by letting you specify that not only will the event be executed the first time,    
but it will also be executed at regular intervals after that, for example, every 3 days, every 
week, every 2 months, etc. 
If you adopt this approach, Dr Solomon's Scheduler also allows you to specify an end date for
the task (though, of course, you don't have to). Thus if you wanted to execute an event at 
6pm each evening, say, but only between 1 January 1997 and 1 February 1999, then this 
would be possible.

Time and Date Formats
Dr Solomon's Scheduler displays the date and time of an event in whatever format you have 
chosen. (You can change this format from the Windows Control Panel, "International" 
section.) 
Please note, however, that the Event Data File stores the times and dates in a fixed format. 
Refer to the section Event Data File Format for further details.

Time and Date Limits
The times you choose must be between 12:00am, 1 January 1970 and 11:59pm, 31 
December 2038. 
Any events where the start date is in the past will be assumed to start "now" (unless you 
have specified an end date which is also in the past).

Weekend Events
You may wish that your event occurs on weekdays only. If this is the case, you should check 
the "Disable at Weekends" option.

Performing an Event once per month, at the end of the month
If you wish to perform an event at the end of each month, simply select the last day of the 
month in which you want the event to start. When you save the event, Dr Solomon's 
Scheduler automatically detects that you have chosen the last day of the month, asks you to
choose between executing the event on the last day of each month, or on the specific day 
you have chosen.



Copying Events
See also :
Event Overview
Adding and Changing Events
Removing Events
Disabling and Enabling Events
Saving Events
Event Data File Format
You can copy the entire contents of one event into another using the "Copy" & "Paste" 
combination. Note, however, that since Dr Solomon's Scheduler requires that all event 
names are different, you will be asked to rename the event before you perform the copy. At 
this point you can also change the start time of the event.



Removing Events
See also :
Event Overview
Adding and Changing Events
Copying Events
Disabling and Enabling Events
Saving Events
Event Data File Format
There are two ways in which to remove events from your schedule.
To remove an event from your schedule, but store it in the Clipboard for later use, you can 
use the "Cut" command in the "Edit" menu. You can then re-introduce the event into your 
schedule using the "Paste" command.
To remove an event altogether, select "Delete Event" from the "Edit" menu. This makes 
immediate changes to your schedule. This command can also be achieved via the Toolbar (

).
Note that you can only store one event at a time in the clipboard. On the other hand, you 
can "Delete" as many events as you want in a single operation.



Disabling and Enabling Events
See also :
Event Overview
Adding and Changing Events
Copying Events
Removing Events
Saving Events
Event Data File Format
When you add a new event, by default it is enabled. You can change this status as you add 
the event, or by editing the event at a later time.
However, you can toggle between enabling and disabling events simply by choosing the 
events and selecting the appropriate option from the "Edit" menu.

HINT : If you wish, you can use the Toolbar instead to enable ( ) or disable (
) items .



Saving Events
See also :
Event Overview
Adding and Changing Events
Copying Events
Removing Events
Disabling and Enabling Events
Dr Solomon's Scheduler allows you to choose between two ways of saving the changes you 
make to your schedule.

Save Changes Immediately
This option means that you are effectively editing your schedule in "real time". Any changes 
you make will be invoked immediately by Dr Solomon's Scheduler. For example, if you set 
the event to trigger in 1 minute's time, it would trigger regardless of whether you'd finished 
editing the schedule or not.

Save Changes at the End of the Session
This option means that the changes you have made have been registered, but will not yet be
written to the Event Database.
If there are any unsaved events at the end of the session, you will be prompted to save 
these events. Alternatively, to save the changes manually, select the "Save Schedule To 
Disk" option from the "File" menu. If you wish to discard recent changes, you can select the 
"Reload Schedule From Disk" option, again in the "File" menu.

Changing your Save Option
By default, Dr Solomon's Scheduler will prompt you each time you modify your schedule. However, if in 
general you intend only to use one of the options, you can check the "Save this setting for future use" 
option, and this will save your choice and apply it to all further choices.
An alternative way to achieve this, and the way to change a previous setting, is to select the "Defaults" 
command from the "Options" menu. Select the section "Options" and you are then able to change the way
in which to save your data.



Event Data File Format
See also :
Event Overview
Adding and Changing Events
Copying Events
Removing Events
Disabling and Enabling Events
Checking the Format of your Data File
Saving Events
The Schedule Data File is written in a standard Windows INI file format, though the actual file
has the extension .SDF. The reason for saving the file in normal text format is so that users 
are not restricted to using the Scheduler in order to edit their Event Data file.
In general, the format of the file is as follows :

[SchedulerSetup]

LogFile=

FileStatus=

[Event:Title of first event]

...

[Event:Title of next event]

...

The section [SchedulerSetup] contains some general settings. The "LogFile" entry specifies 
the name of the Scheduler Log File. This is given a default value by Dr Solomon's Scheduler, 
but, if you want, you can subsequently change this file.
The "FileStatus" entry is an entry which is internal to Dr Solomon's Scheduler. If you edit this 
value, there is no effect on the Scheduler.
The events are actually stored in the [Event:Title of first event] sections. There can be an 
unlimited number of Event Sections. The format of each of these sections is as follows :
[Event:Event Title]

Description=

StartTime=

EndTime=

Enabled=

WeekendDisabled=

PeriodUnits=

PeriodValue=

SundayPattern=



MondayPattern=

TuesdayPattern

WednesdayPattern=

ThursdayPattern=

FridayPattern=

SaturdayPattern=

Dependency=

EventType=

StartDirectory=

CmdLine=

CmdParams=

WindowType=

TargetMachine=

TargetUser=

ResponseHandler=

ResponseTable=

UserToNotify=

LogAction=

Example



The title of the section contains the text "Event:", followed by the name of the event. The 
Event Name can contain spaces and be up to 250 characters in length.
You can have as many events as you like, but all Event Names must be unique.



You can use the description field to add a more verbose description of the event. This may 
be up to 256 characters in length.



The start and end times of the event must be in the format "dd-mm-yyyy hh:mm" 
(Example).
Although you must add a start time, the "End Time" entry is optional. If this field is left 
blank, the event will always repeat at your chosen interval.
The "End Time" field is only read when the event is defined to be cyclic (rather than a one-
off occurrence).
Times should be stated in 24-hour format.



10:15am, March 27th, 1995 is denoted by 27-03-1995 10:15.



Enabled may be set to TRUE or FALSE.
If you set Enabled=FALSE, the event will be ignored. This is designed so that events can be 
ignored temporarily.



You can set this value to TRUE or FALSE. If set to TRUE, the event will not execute on 
Saturdays or Sundays.



This setting, in conjunction with "PeriodValue", defines the repeat period of the event.
The following unit values are acceptable : MINUTE, HOUR, DAY, WEEK, MONTH, 
END_OF_MONTH.
END_OF_MONTH will run the event at the given time, on the last day of each month. If you 
use this option, "PeriodValue" is ignored.
To execute an event just once, the value of "PeriodUnits" must be ONCE. Again, in this case, 
"PeriodValue" is ignored.



PeriodValue is the number of "PeriodUnits" between events. The value must be between 1 
and 100.
PeriodValue is ignored if you choose PeriodUnits = ONCE or PeriodUnits = END_OF_MONTH.



The "...Pattern" entries are not supported in this version of Dr Solomon's Scheduler. Any 
entries will be ignored.



This version of Dr Solomon's Scheduler does not support anything other than a trigger at a 
specified time. The contents of this field are ignored in this version.



The Event Type may be one of three values. These are :
FINDVIRUS - to execute FindVirus
SPAWN - to execute any other program
MESSAGE - to send a message to somebody (Windows NT only).

The value of EventType must match one of these values exactly.



If you have set EventType to "SPAWN", this entry holds the working directory in which your 
program will be executed. Otherwise, this entry is ignored.



If you have set EventType to "SPAWN", this entry holds the command line of the program you
wish to execute. If you have set EventType to "FINDVIRUS", this entry points to the FindVirus 
executable.
Otherwise, this entry is ignored.



If you have set EventType to "FINDVIRUS", this entry contains all of    the command line 
parameters which you want to use to execute FindVirus. If you have set EventType to 
"MESSAGE", this entry holds the text of the message you wish to send.



If you have set EventType to "SPAWN", WindowType specifies the type of    window you want 
your application to have. Values may be "NORMAL", "MIN" or "MAX". Setting 
WindowType=MIN is equivalent to checking the "Run minimized" option under Windows.



TargetUser and TargetMachine are not supported in this version of Dr Solomon's Scheduler. 
Any values will be ignored.



ResponseHandler and ResponseTable are not supported in this version of Dr Solomon's 
Scheduler. Any values will be ignored.



If you have set EventType to MESSAGE, this entry holds the user(s) to whom you want to 
send the message. If you use the keywords "SCREEN", the message will be sent to your own 
screen rather than across the network.



This parameter tells Dr Solomon's Scheduler how much detail you wish to go into when 
logging the outcome (i.e. the successful launch) of events. Possible values are : NEVER 
(never write to the log file), FAIL_ONLY (only write to the log file if the event cannot be 
launched) and ALWAYS (write to the log file regardless of the result).



Example
Close
[SchedulerSetup]
LogFile=c:\winnt\avtk_sch.log
FileStatus=CHANGES_SEEN

[Event:Test Event #1]
Description=A test event that runs every 1 hour.
StartTime=04-04-1995 06:30
EndTime=
Enabled=TRUE
WeekendDisabled=FALSE ; You can add comments if you want
PeriodUnits=HOUR ;
PeriodValue=1 ; execute every hour
Dependency=
EventType=FINDVIRUS
StartDirectory=c:\winnt
CmdLine=c:\toolkit\ntfindvi
CmdParams=/this /that /theother
WindowType=NORMAL
TargetMachine=LOCAL
TargetUser=
ResponseHandler=
ResponseTable=
UserToNotify=
LogAction=ALWAYS

[Event:Test event number 2]
Description= A test event that runs every week until the end of April.
StartTime=07-04-1995 18:30
EndTime=30-04-1995 23:59
Enabled=TRUE
WeekendDisabled=FALSE
PeriodUnits=WEEK
PeriodValue=1
Dependency=
EventType=FINDVIRUS
StartDirectory=c:\winnt
CmdLine=c:\toolkit\ntviverif
CmdParams=/switch1 /switch2
WindowType=MIN
TargetMachine=
TargetUser=



ResponseHandler=
ResponseTable=
UserToNotify=SIMON
LogAction=NEVER



Checking the format of your Data File
See also :
Event Overview
Event Data File Format
Because the Schedule Data File is actually a text file, it is possible to write to the file using 
any text editor.
This may sometimes cause problems, if Dr Solomon's Scheduler cannot understand the text 
which has been written to the file. If an event cannot be understood, you will be informed 
when you try to open Dr Solomon's Scheduler editor. However, in order to allow you to edit 
the file yourself, all Dr Solomon's Scheduler does is to ignore the event completely. The 
event is still in the Data File, but just ignored.

If you wish Dr Solomon's Scheduler to remove any events which cannot be understood, 
select the "Validate Schedule" option from the "File" menu. This option cycles through each 
event, checking its syntax. If Dr Solomon's Scheduler encounters an event which it cannot 
interpret properly, you will be given the option to remove that particular event completely.



Viewing the Outcome of Scheduled Events
By default, Dr Solomon's Scheduler creates a Log File of the results of events. This records 
whether an event could be launched successfully.
The Log File is a standard text file, and can be viewed using Windows Notepad.

To View the Log File :
Select the "Scheduler Log File" option from the "File" menu. A popup menu is then displayed.
Select "View" from this menu.
Dr Solomon's Scheduler then executes Windows Notepad, loading the Scheduler Log File at 
the same time. You can also use Notepad to edit the file, for example, if you want to get rid 
of old messages contained in the file.
You can change the name of the Log File.

To Change the Name of the Log File : 
Rather than deleting information from the Scheduler Log File, you may wish to create 
periodically a completely new file. In this way, you could create archives of messages from 
Dr Solomon's Scheduler. 
From the "Scheduler Log File" popup menu select the "Change Name" option. A dialog is 
then displayed which allows you to change the name of the Scheduler Log File.

Example



Example
Close
10-May-1995 09:10:01 Event 'FindVirus Scan' launched successfully.
10-May-1995 09:10:00 Event 'ViVerify Scan' launched successfully.
10-May-1995 10:10:02 Event 'FindVirus Scan' launched successfully.
10-May-1995 11:10:00 Event 'FindVirus Scan' launched successfully.
10-May-1995 12:10:00 Event 'ViVerify Scan' launched successfully.
10-May-1995 12:10:03 Event 'FindVirus Scan' launched successfully.
10-May-1995 13:10:01 Event 'FindVirus Scan' launched successfully.



Customizing Dr Solomon's Scheduler
See also :
Setting the Default Values for new Events
Changing the way you view Events
Dr Solomon's Scheduler allows you to set default values for new events. You can use these 
defaults so that when you come to add new events to your schedule, it is quick and easy to 
do.
As well as a default set of FindVirus options, you can also build up a list of commonly-used 
programs and, under Windows NT, messages. When you add an event, these options are 
placed into a pull-down list box, so that you don't need to retype them.
You can also customize the way in which Dr Solomon's Scheduler appears on your screen. 
Depending on your screen resolution, you can change the font name and size to one which 
best suits your taste.
Options to change the way in which the Status Bar and the Toolbar are shown are also 
included.



Setting Default Values for new Events
See also :
Customizing Dr Solomon  '  s Scheduler  
If you select the "Defaults..." option from the "Options" menu, a dialog is shown which allows
you to customize many of the default properties of future events.
Select the "Find Viruses" section of the dialog in order to set up a set of default options for 
virus scans. This section is identical in nature to the Scan Options Dialog, except that instead
of specifying an actual report file, you just specify a default directory for the report file.
You can also customize some of the frequency settings, from the "Time" section. This allows 
you to specify whether the event is to be repeated cyclically and if so, the frequency. You 
can also set a default "Disable the event at weekends" flag from this section.
The "Programs" section allows you to build a list of commonly-used programs and, under 
Windows NT, messages. These are displayed in a list box when you come to add a new 
event. In this way you don't need to type all the details of the program into the event - 
simply click on the description and the fields are filled for you.
The "Options" section also allows you to specify the default way in which the Scheduler Log 
File is written to. You can choose to :
· Write to the file come what may, whether the event could be launched or not,
· Just write to the file if an event couldn't be launched, or
· Don't ever write to the file.
Similarly you can alter the way in which events are saved. See Saving Events for more details.

Of course, each of these defaults can be overridden on a per-event basis.



Changing the way you view Events

Changing the font in your Event List
The Toolbar
The Status Bar
Tool Tips



Changing the font in your Event List
You can change the font used in the Event List, by selecting the "Font" command from the 
"Options" menu.
You may use any currently-loaded font, regardless of the precise type of font. You can install 
fonts into Windows from the Control Panel.



The Toolbar
You can toggle whether or not the Toolbar is displayed from the Options menu.



The Status Bar
You can toggle whether or not the Status Bar is displayed from the Options menu.



Tool Tips
Tool tips are a neat way of making the Toolbar more intuitive. If you leave your mouse cursor
over a button for one second, the Tool tip pops up to give you more information about the 
command.

However, if you dont like Tool tips, you can toggle whether or not they're displayed from the 
Options menu.




