XADM: Deadlock in STORE Due to a Stack Overflow |
The information in this article applies to:
-
Microsoft Exchange Server, version 5.5
SYMPTOMS
The Microsoft Exchange information store may stop responding (hang) because
of a stack overflow when processing a corrupted message. After this
happens, the client cannot log on to the Exchange Server computer and cannot
send or receive a message.
CAUSE
This happens because the message contains a corrupted attachment, in this
case, there is no "END" section for the encoded attachment. When the
information store encounters an incomplete sequence at the end of the
encoded line, it keeps appending more data, but makes no progress with
decoding.
RESOLUTION
Exchange Server 5.5
To resolve this problem, obtain the latest service pack for Exchange Server
version 5.5. For more information, please see the following article in the
Microsoft Knowledge Base:
Q191014 XGEN: How to Obtain the Latest Exchange Server 5.5 Service Pack
The English version of this fix should have the following file attributes or later:
Component: Information Store
File Name |
Version |
Gapi32.dll |
5.5.2446.0 |
Mdbmsg.dll |
5.5.2446.0 |
Store.exe |
5.5.2446.0 |
Exchange Server 5.0
A supported fix that corrects this problem is now available from Microsoft, but
it has not been fully regression tested and should be applied only to systems
experiencing this specific problem. If you are not severely affected by this
specific problem, Microsoft recommends that you wait for the next version of Exchange Server 5.0
that contains this fix.
To resolve this problem immediately, contact Microsoft Product Support Services
to obtain the fix. For a complete list of Microsoft Product Support Services
phone numbers and information on support costs, please go to the following
address on the World Wide Web:
http://www.microsoft.com/support/supportnet/overview/overview.asp
The English version of this fix should have the following file attributes or later:
Component: Information Store
File Name |
Version |
Mdbmsg.dll |
5.0.1461.91 |
Store.exe |
5.0.1461.91 |
STATUS
Microsoft has confirmed this to be a problem in Microsoft Exchange Server
versions 5.0 and 5.5.
Additional query words:
QFE UUENCODE
Keywords : exc55sp2fix
Version : winnt:5.5
Platform : winnt
Issue type : kbbug