XFOR: Error Msg: The Domain or User Name You Have Specified... |
The information in this article applies to:
-
Microsoft Exchange Server, version 5.5 Service Pack 1
IMPORTANT: This article contains information about editing the registry.
Before you edit the registry, make sure you understand how to restore it if
a problem occurs. For information about how to do this, view the "Restoring
the Registry" Help topic in Regedit.exe or the "Restoring a Registry Key"
Help topic in Regedt32.exe.
SYMPTOMS
When you specify an exact domain match in the Message Filtering dialog box
of the Connections property page of the Internet Mail Service, the
following error message may appear:
The domain or user name you have specified is invalid.
CAUSE
The routine that handles domain name validation does not account for
"#@<domain>" being a valid entry for this field.
RESOLUTION
To resolve this problem, obtain the latest service pack for Exchange Server
version 5.5. For more information, please see the following article in the
Microsoft Knowledge Base:
Q191014
XGEN: How to Obtain the Latest Exchange Server 5.5 Service Pack
The English version of this fix should have the following file attributes
or later:
Component: Internet Mail Service
File Name Version
-------------------------
Imcadmin.dll 5.5.2395.0
WORKAROUND
To work around this problem, you can use the TurfTable registry value to
add exact domain match entries via the registry. To do so, use the
following steps.
WARNING: Using Registry Editor incorrectly can cause serious problems that
may require you to reinstall your operating system. Microsoft cannot
guarantee that problems resulting from the incorrect use of Registry Editor
can be solved. Use Registry Editor at your own risk.
For information about how to edit the registry, view the "Changing Keys And
Values" Help topic in Registry Editor (Regedit.exe) or the "Add and Delete
Information in the Registry" and "Edit Registry Data" Help topics in
Regedt32.exe. Note that you should back up the registry before you edit it.
If you are running Windows NT, you should also update your Emergency Repair
Disk (ERD).
- Start Registry Editor (Regedt32.exe).
- Locate the TurfTable value under the following key in the registry:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIMC
\Parameters
NOTE: The above registry key is one path; it has been wrapped for
readability.
- On the Edit menu, click Multi String, add the domain after the other
entries, and then click OK.
- Quit Registry Editor.
STATUS
Microsoft has confirmed this to be a problem in Microsoft Exchange Server
version 5.5 Service Pack 1. This problem was first corrected in Exchange
Server 5.5 Service Pack 2.
MORE INFORMATION
Exact domain match entries are valid per the Exchange Server version 5.5
Release Notes:
For example, a domain specified in the list using the following format
prevents all messages addressed from domain.com from being delivered.
#@domain.com
A domain specified in the list using the following format prevents all
messages addressed from domain.com and all of its subdomains from being
delivered.
@domain.com
The Message Filtering dialog box currently allows for the following
entries:
user@domain.com
@domain.com
#domain.com
user
In the following two formats, [xxx.xxx.xxx.xxx] represents a valid IP
address.
user@[xxx.xxx.xxx.xxx]
@[xxx.xxx.xxx.xxx]
Additional query words:
sub-domain biscuit ims
Keywords : exc55sp2fix XFOR
Version : WINDOWS:5.5
Platform : winnt
Issue type : kbbug