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Thread Deadlock When Windows NT Backup Is Stopped


The information in this article applies to:
  • Microsoft Exchange Server, versions 4.0, 5.0, 5.5


SYMPTOMS

When you are running a backup using the Windows NT Backup program against a Microsoft Exchange Server computer, if the backup is stopped before the backup completes, Windows NT Backup stops responding (hangs).


CAUSE

When a backup is stopped, the closing procedure blocks infinitely, waiting on a thread's handle to close. The thread handle is never closed, so Windows NT Backup stops responding.


RESOLUTION

Exchange Server 5.5

To resolve this problem, obtain the latest service pack for Microsoft Exchange Server version 5.5. For additional information, please see the following article in the Microsoft Knowledge Base:
Q191014 XGEN: How to Obtain the Latest Exchange Server 5.5 Service Pack

Exchange Server 5.0

A supported fix that corrects this problem is now available from Microsoft, but it has not been fully regression tested and should be applied only to systems experiencing this specific problem. If you are not severely affected by this specific problem, Microsoft recommends that you wait for the next Microsoft Exchange Server 5.0 service pack that contains this fix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information on support costs, please go to the following address on the World Wide Web:
http://www.microsoft.com/support/supportnet/overview/overview.asp
The English version of this fix should have the following file attributes or later:

Component: Exchange Database Engine

File name Version
Edbbcli.dll 5.0.1461.31


Exchange Server 4.0

A supported fix that corrects this problem is now available from Microsoft, but it has not been fully regression tested and should be applied only to systems experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information on support costs, please go to the following address on the World Wide Web:
http://www.microsoft.com/support/supportnet/overview/overview.asp
The English version of this fix should have the following file attributes or later:

Component: Exchange Database Engine

File name Version
Edbbcli.dll 4.0.997.1



STATUS

Exchange Server 5.5

Microsoft has confirmed this to be a problem in Microsoft Exchange Server version 5.5. This problem was first corrected in Microsoft Exchange Server Service Pack 1.

Exchange Server 5.0

Microsoft has confirmed this to be a problem in Microsoft Exchange Server version 5.0.

Exchange Server 4.0

Microsoft has confirmed this to be a problem in Microsoft Exchange Server version 4.0.

Additional query words: hang abort

Keywords          : XADM 
Version           : winnt:4.0,5.0,5.5
Platform          : winnt 
Issue type        : kbbug 


Last Reviewed: August 18, 1999
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