ACC: "Out Of Memory" Error After Printing Subform on Windows NT |
The information in this article applies to:
-
Microsoft Access versions 7.0, 97
SYMPTOMS
You may receive an "Out of Memory" error message in Microsoft Access 95 or
97 when you print a selection from a form. The error will continue to pop
up every minute or so until the program is re-run.
CAUSE
This error occurs when one Microsoft Access process releases a Windows
Graphics resource (GDI object) while a separate process still references
that same Windows resource. When the second Access process tries to
reference the Windows resource, the error described in the "Symptoms"
section occurs.
RESOLUTION
To resolve this problem for Microsoft Access 97, obtain Microsoft Office 97
Service Release 2 (SR-2).
For additional information about SR-2, please see the following article in
the Microsoft Knowledge Base:
Q151261 OFF97: How to Obtain and Install MS Office 97 SR-2
STATUS
Microsoft has confirmed this to be a problem in Microsoft Access versions
7.0 and 97. This problem was corrected in Microsoft Office 97 Service
Release 2 (SR-2).
MORE INFORMATION
Steps to Reproduce Behavior
- Open the sample database Northwind.mdb.
- Open the Orders form.
- Click the Print Invoice button or Select Print and choose Selection.
- Click on the Grid Object. The text may appear distorted.
- If it is not, repeat step 3 again.
After a period of time you will receive the error described in the SYMPTOMS
section.
Additional query words:
printing err
Keywords : kbprint FmsSubf FmrOthr
Version : WINDOWS: 7.0, 97
Platform : winnt
Issue type : kbbug