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Introducing VidEdit

VidEdit lets you create and edit audio-visual sequences consisting of a series of frames that
contain digital audio and video data. With VidEdit, you can edit one or more frames of a 
video sequence, adjusting the audio, video, or color components of the frames.
Using VidEdit, you can easily add, delete, or move multimedia data in your video 
sequences. You can synchronize a presentation by moving sound data to match the video 
image. When you finish fine-tuning a video sequence, you can generate a compressed, 
interleaved .AVI file. VidEdit lets you adjust compression parameters to allow for such 
factors as image quality and the data-transfer rate for your particular storage device.
You can run multiple copies of VidEdit simultaneously, which is useful if you need to edit 
and refine portions of a sequence.



See Also 
VidEdit Toolbar and Controls
Overview: Configuring VidEdit
Overview: Working with Video Files
Overview: Editing Video and Audio Tracks
Overview: Working with Color Information
Overview: Setting Options for the Video Sequence



Creating Video Using VidEdit

There are several ways to create video files:
Use VidCap to capture video from videotape, videodisc, or a camera
Use VidEdit to import animation or sequential image files
Use CapScrn to capture animation directly off the screen
Use VidEdit to arrange individual images and sounds in sequential order

For information about using VidCap and CapScrn to create video, see the Help files for 
those applications. Once you've captured video, you can load it into VidEdit, adjust the 
presentation, and save it as a compressed .AVI file.



See Also 
Overview: Working with Video Files
Importing Audio-Visual Sequences
Saving an AVI File



Editing Video Using VidEdit

VidEdit provides many functions for editing your video sequence. The content of a video 
sequence is stored in two tracks, the video track and the audio track. The tracks are 
divided into frames; a frame is a short segment of video or audio data. During the video 
presentation, video frames are displayed one after another, creating a moving picture. The 
audio frames are played in sequence, producing an unbroken sound track.
When editing a video sequence, you perform the following actions:

Add or remove data from the video and audio tracks
Synchronize the audio and video tracks
Adjust the audio, video, and compression characteristics of the sequence
Save the presentation as a compressed .AVI file

For example, you might want to replace the audio track with higher-quality sound captured 
in a separate session. You might remove some unnecessary material from the presentation.
Or, you might splice two video clips together into a longer clip. When you're finished 
adjusting the content of the presentation, you might experiment with different compression
settings to see which combination produces the best quality at the lowest storage cost. You
can perform all these editing actions using VidEdit.



See Also 
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Compressing Video

Compression is a critical component of a digital-video system. Uncompressed video 
sequences have immense storage requirements, so an immediate problem is storing the 
sequence on the distribution medium (for example, a CD-ROM disc). Another critical 
problem is the data-transfer bottleneck. For example, when playing video from CD-ROM, 
data is transferred from the CD drive and into the main processing unit of the computer. It 
is then decompressed and converted to images suitable for display. 
If the CD-ROM drive can't transfer data at sufficient speed, the animation might "fall 
behind" and become jerky or broken. An important goal of compression is reducing the 
amount of data required for each frame of video, thus reducing the amount of information 
to transfer from the storage device to the processing hardware.
In Video for Windows, compression is performed by software routines called codecs (short 
for compressor/decompressors). For additional performance, some codecs can interface 
with compression routines residing in hardware. 
Video for Windows provides a selection of codecs, each of which has specific advantages 
and liabilities. You'll need to consider the advantages and disadvantages to determine 
which method is appropriate. For information about the compression routines included with 
Video for Windows, see Compression Methods.
Compression Process
After you've captured a video sequence, you can load the sequence into VidEdit and apply 
compression. VidEdit has a Compression Options command (available from the Video 
menu) that lets you choose a compression method and set other options affecting the 
attributes of the compressed sequence. Compression isn't applied until the video file is 
saved.
Within the compression settings, you can choose the target playback platform for the video
sequence. The capabilities of the playback platform determine the target frame rate for the
video sequence. VidEdit lets you select from several representative playback platforms; you
can also choose custom combinations of compression settings.
After selecting a compression method and compression settings, you save the video 
sequence. Using the selected codec, VidEdit saves the video in compressed format. 
Depending on the compression method, compression might take a large amount of time. 



See Also 
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VidEdit Toolbar and Controls

Click the controls in the following illustration for an explanation of the VidEdit control:



See Also 
Overview: Configuring VidEdit
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File Menu Commands

The File menu contains the following commands:
Command Description
New Clears and resets the workspace in preparation of a 

new video sequence.
Open Opens a video file.
Save Saves the current file in the .AVI format.
Save As Lets you save the video sequence, specifying a different

filename and options, if necessary.
Revert Opens the last version of the video sequence saved on 

disk.
Insert Lets you insert a picture, audio sequence, or video 

sequence at the current position.
Extract Lets you extract one or more frames of video and/or 

audio information, saving the information in a variety of
file formats.

Capture 
Video

Starts VidCap, the video-capture application. You can 
load files created by VidCap into VidEdit, or insert them 
into the current video sequence.

Play Preview Displays a preview of the video sequence using the 
current video settings.

Exit Closes the video sequence and quits VidEdit.

See Also 
Importing Audio-Visual Sequences
Pasting and Inserting Frames
Playing Video
Extracting Audio and Video Tracks
Saving an AVI File



Edit Menu Commands

The Edit menu contains the following commands:
Command Description
Undo Undoes the last editing command or action. 
Cut Deletes frame data and places it on the Clipboard.
Copy Copies frame data to the Clipboard.
Paste Pastes audio and/or video data from the Clipboard.
Paste Palette Lets you paste color information to one or more frames 

in the video sequence.
Delete Deletes frame data. 
Set Selection Lets you select one or more frames of the video 

sequence.
Go To Lets you jump to a specific frame number within the 

video sequence.
Track Lets you select which tracks (video and/or audio) are 

available for editing. 
Preferences Lets you select configuration options for VidEdit.

See Also 
Overview: Editing Video and Audio Tracks
Copying Frames
Pasting and Inserting Frames
Cutting and Deleting Frames
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View Menu Commands

The View menu contains the following commands:
Command Description
Full Frame 
Update

Selects full-frame display. When VidEdit displays a 
frame in the editing window, it always displays the 
complete frame image. This option is slower than the 
Fast Frame Update option.

Fast Frame 
Update

Selects fast-frame display. When VidEdit displays a 
frame in the editing window, it overlays the video 
information for the current frame rather than rebuilding 
the complete image. This option can result in an 
incomplete frame display (but has no effect on the 
actual .AVI sequence).

Draw Full 
Frame

Displays the current frame as it will appear when 
playing the video sequence. This command is available 
only when the Fast Frame Update option is in effect.

Zoom Magnifies or reduces the image displayed in the edit 
area. Zoom choices include half-size, normal size, twice 
normal size, and four times normal size.

See Also 
Adjusting the Look of VidEdit
Adjusting the Video Frame Display
Setting Frame Update Options



Video Menu Commands

The Video menu contains the following commands:
Command Description
Compression Options Lets you select compression and formatting 

options for the video sequence.
Convert Frame Rate Lets you change the frame rate (number of 

frames per second) for the video sequence.
Synchronize Lets you synchronize audio playback with the 

video sequence by adjusting the frame rate 
and the starting position of the audio.

Audio Format Lets you set the audio characteristics for the 
video sequence.

Video Format Lets you change how color is stored in the 
video sequence.

Create Palette Creates an optimal palette for any range of 
frames in the video sequence, and lets you 
apply the palette to other ranges of frames.

Crop Lets you crop the video portion of the video 
sequence (thus changing the size of all the 
frames). 

Resize Lets you change the frame size of the video 
sequence.

Statistics Displays statistics about the video sequence, 
including number of frames, total time, and 
data size.

Load File into Memory Loads all the frames of a video sequence (or 
as many as will fit) into memory, which can 
speed up scrolling and editing operations.

See Also 
Displaying Video Statistics
Setting the Frame Rate
Setting the Audio Format
Setting Compression Options
Synchronizing Audio and Video Tracks
Creating Palettes
Pasting Palettes
Changing the Color Format



Help Menu Commands

The Help menu contains the following commands:
Command Description
Contents Displays the Contents topic of this Help file.
About Displays the version number and copyright statement 

for VidEdit.

See Also 
How to use Help



VidEdit Keys

Use the following keys to perform VidEdit functions:
To Press
Undo the last change CTRL+Z, ALT+BKSP
Delete the current frame or current selection DEL
Cut the current frame or current selection to 
the Clipboard

CTRL+X, SHIFT+DEL

Copy the current frame or current selection to 
the Clipboard

CTRL+C, CTRL+INS

Paste from the Clipboard CTRL+V, SHIFT+INS
Change the editing mode between insert and 
overwrite settings

INS

Open a file containing a video sequence CTRL+F12
Save the file to another name or format F12
Save the file to the same name and format SHIFT+F12
Redraw the current frame F5
Display the Help Index F1

See Also 
VidEdit Toolbar and Controls



Overview: Configuring VidEdit

VidEdit provides several features that let you customize the appearance of the window and 
increase the speed of certain editing operations. Many of these options are available from 
the Preferences dialog box, while others are available from the View menu.
For information about adjusting the look, frame display, and editing performance of VidEdit,
see the following topics in this sequence.



See Also 
VidEdit Preferences Dialog Box
View Menu Commands



Adjusting the Look of VidEdit

VidEdit provides several options for configuring the appearance of the editing window. The 
following procedures describe the different ways you can adjust the look of the application.
 To adjust the window size when a new file is loaded
VidEdit can expand or shrink its window to accommodate new video sequences as they are 
opened.
1 From the Edit menu, choose Preferences.
2 Select Resize Window To New Frame Size.
 To change the background color
You can specify the color for the area surrounding the video frame display in the VidEdit 
window.
1 From the Edit menu, choose Preferences.
2 In Background Color, select the color you want.
 To display the frame number in the title bar
You can display the number of the current frame in the VidEdit title bar.
1 From the Edit menu, choose Preferences.
2 Select Show Frame # In Title Bar.
 To change the time units
When specifying positions within the video sequence, you can use times (hh:mm:ss.hh) 
rather than frames. All position values throughout VidEdit are changed to the selected 
format.
1 From the Edit menu, choose Preferences.
2 Select Show Positions In Time Format.
 To hide or show the toolbar and status bar
1 From the Edit menu, choose Preferences.
2 Select or clear Tool Bar And/Or Status Bar.



See Also 
View Menu Commands
VidEdit Preferences Dialog Box
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Adjusting the Video Frame Display

VidEdit displays the current video frame in the editing window. The following procedures 
describe how to set options for the video frame display.
 To center the frame display
You can display the video frame in the center of the window, or you can display it at the top
left.
1 From the Edit menu, choose Preferences. 
2 To center the image, select Center Image In Window. 

Or, to display the image at the top, left corner of the window, clear Center Image In 
Window.

 To zoom the frame display
You can zoom or shrink the video frame within the editing window. Zooming the picture 
does not affect the actual size of the video sequence.
1 From the View menu, choose Zoom.
2 Choose the zoom proportion you want.

Or, choose the Zoom button  on the toolbar. Choose it repeatedly to toggle between the
different zoom sizes.



See Also 
View Menu Commands
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Setting Frame Update Options

Some compression methods don't store full video information with each frame; they 
overlay information from the current frame on the image present from the previous frame. 
When you scroll forward through such a sequence, the data stored for the current frame is 
overlaid on the data from previous frames, providing a complete image. However, when 
you jump to an arbitrary frame, the images from previous frames might not be available, so
the frame display might be incomplete.
In these situations, VidEdit can reconstruct the full-frame image by sequentially displaying 
the video data from all frames preceding the current frame. However, this reduces the 
display performance, so VidEdit lets you choose between speed and accurate display.
 To choose between fast display and full display

From the View menu, choose Fast Frame Update or Full Frame Update.
 To restore the full frame image (when using fast frame display mode)
If your frame image has become jumbled, you can tell VidEdit to reconstruct the current 
frame image by displaying all the preceding frames.

From the View menu, choose Draw Full Frame Image.

Or, choose the Redraw Frame button  on the toolbar.
Or, press F5.



See Also 
View Menu Commands
VidEdit Toolbar and Controls



Enhancing Editing Performance

VidEdit sets aside a segment of memory to store audio and video data in memory. You can 
change the size of this memory cache; by increasing the memory used, you can speed 
editing operations. The following procedures describe how to configure the cache.

 To change the size of the memory cache
1 From the Edit menu, choose Preferences.
2 In Memory For Caching Images, type a new cache size value. 

Keep the size of the cache smaller than the amount of physical memory on your 
computer; otherwise, portions of the cache might be swapped to disk, eliminating any 
speed improvements.

3 Choose OK.

 To load the entire video sequence into memory
To speed editing performance, you can load a small video sequence into memory.

From the View menu, choose Load File Into Memory.



See Also 
VidEdit Preferences Dialog Box
View Menu Commands



Overview: Creating Video

Video for Windows video sequences are stored in Audio-Video Interleaved (.AVI) files. You 
can capture video sequences using VidCap and CapScrn, or you can import Autodesk 
Animator animations, converted QuickTime movies, and bitmap (.DIB file) sequences 
directly into VidEdit.
VidEdit lets you perform the following tasks:

Add or remove frames, and synchronize audio with video

Set compression options

Play previews of an entire video sequence, or selected portions

Save the sequence as a compressed .AVI file
For more information about the basic functions provided by VidEdit, see the following topics
in this sequence.



See Also 
Capturing Video
Importing Audio-Visual Sequences
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Capturing Video

Video for Windows provides the following methods for capturing video sequences:

You can use the VidCap application to capture video and audio from an external 
device, such as a VCR, videodisc player, or video camera. To capture from an external 
source, you need a video-capture board.

You can use the CapScrn application to capture video directly off your computer 
display. For example, you can create a video sequence showing procedures performed in a 
word-processing or spreadsheet application.
You can start VidCap directly from VidEdit. Once you capture video using VidCap, you can 
load the capture file into VidEdit, perform any necessary editing, and then save the 
captured video as a compressed .AVI file. You can start CapScrn from the Video for Windows
group in Program Manager.

 To start the VidCap application to capture video

From the File menu, choose Capture Video.

Or, choose the Capture Video button  from the toolbar.



See Also 
Saving an AVI File
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Importing Audio-Visual Sequences

You can import Autodesk Animation files, converted QuickTime movies, and device-
independent bitmap (.DIB) sequences into VidEdit. After importing the sequence into 
VidEdit, you can insert additional video and audio sequences using the Insert command. 
You can then save the sequence in the .AVI format.
The following table lists more information about the conversions:

File Type Conversion Notes
Autodesk Animation
(.FLI, .FLC)

VidEdit converts video stored in Autodesk 
Animation files.

QuickTime movies Use the Video for Windows Converter on the 
Macintosh to convert the QuickTime file into .AVI
format. You can then transfer the .AVI file to the 
PC and load the .AVI file into VidEdit.
For information about using the Video for 
Windows Converter, see the Help file for the 
converter application.

Microsoft DIB 
Sequence (.DIB)

The .DIB files should be numbered to show 
sequence; for example, ANIM1.DIB, ANIM2.DIB, 
ANIM3.DIB. Specify the name of the first file, and
VidEdit searches the same directory for the rest 
of the files in the series.

Note Before playing a video sequence from an imported format, you should save the video 
sequence in the .AVI file format to improve its playback performance.

 To create a video sequence from an existing audio-visual sequence
1 From the File menu, choose Open.

Or, choose the Open button  on the toolbar.
2 Select the file you want to open.

To choose a file format other than .AVI, select a new file type from the List Files Of Type 
box.

3 Choose OK.
If the file is in a format other than .AVI, there will be a brief delay as VidEdit loads and 
converts the frames.



See Also 
Open Video File Dialog Box
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Playing Video

When using VidEdit, you can play your video sequence using Media Player or directly from 
VidEdit. Media Player lets you play .AVI files, while VidEdit lets you play .AVI files as well as 
video sequences stored in other file formats. Media Player provides better playback 
performance, but you can play video sequences from VidEdit to quickly preview them (or a 
selection of frames).
When playing edited video sequences and video sequences stored in other formats, the 
VidEdit Play Preview command plays more slowly and might skip frames, insert audio 
breaks, or cause the video and audio to be unsynchronized. To improve the playback of an 
edited or imported video sequence, save the video sequence first; you can then play it 
using Media Player or directly from VidEdit.

 To play a video sequence using VidEdit

From the File menu, choose Play Preview.

Or, select the following playback controls beneath the mark area:
Button Description

Plays a video sequence from the current frame to the 
end of the sequence. To play the currently selected 
frames, hold down the ALT key while choosing the 
button.
Stops the playback.
Moves the current position left to the nearest mark or 
the first frame of the video sequence.
Moves the current position backward through 10%.
Moves the current position forward 10%.
Moves the current position right to the nearest mark or 
the last frame of the video sequence.

 To play a video sequence using Media Player
1 Save the video sequence in the .AVI format.
2 Switch to Program Manager and start Media Player.
3 Open the .AVI file in Media Player.

4 Choose the Play button .



See Also 
Saving an AVI File



Saving an AVI File

When you save a video sequence, VidEdit saves the audio and video using the interleaving 
parameters you've chosen for the sequence. You can save a sequence with or without 
interleaving; with interleaving, you can choose from a variety of options.
There are three ways to save:

Saving to the current filename

Saving to a different filename

Saving to a different filename, retaining the previous video sequence in VidEdit
The third method is useful when you're experimenting with different variations of 
interleaving parameters. You can retain your uncompressed sequence in VidEdit and save 
different versions of the video sequence to different .AVI filenames.
Hints

While finalizing the content of a video sequence, save it in uncompressed format. 
After you've made all your editing changes, you can then save it in compressed format, 
experimenting as necessary with various compression parameters. 

When saving a video sequence that's already been compressed, you should avoid 
performing additional compression on the data. To save without additional compression, 
display the compression options and make sure "No Recompression" is selected as the 
video-compression method.

 To save the video file to the current filename

From the File menu, choose Save.

Or, choose the Save button  from the toolbar.

 To save the video file to a different filename
1 From the File menu, choose Save As.

The Save Video File dialog box appears.
2 Set the drive, directory, and filename for the .AVI file.
3 To retain the current video sequence in VidEdit after saving, select the Save Copy check 

box.
4 To change the compression options, choose the Compression Options button and set the 

compression options you want.
5 Choose OK.





See Also 
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Overview: Editing Video and Audio Tracks

VidEdit provides common video-editing capabilities, including the following:

Cutting unwanted portions of a sequence

Moving sequences to a different location

Making copies of sequences

Splicing sequences together
Most editing is performed using standard editing techniques in Windows: cutting and 
copying data to the Clipboard, pasting data from the Clipboard, and inserting the contents 
of files into the video sequence. The main difference in video editing is you're often dealing 
with a time-based segment of data that might include many frames of video and audio 
information. You can also work with individual frames (such as a single image). The 
following topics in this sequence describe the different editing operations.
Selecting Data for Editing
Editing operations such as insert, delete, cut, paste, and copy are performed on selections 
of video and audio data. The outcome of the editing operation depends on which data is 
selected. In VidEdit, the following factors determine the composition of a selection:

Which tracks are active. You can activate the audio track, the video track, or both 
tracks. Edits (such as cutting, pasting, or inserting data) only affect active tracks. For 
example, you can cut data from the video track but leave the audio track untouched.

Which frames are selected. By default, the current frame is selected. You can also 
select a range of frames using the Mark In 

 and Mark Out 
 buttons in the VidEdit window.

For example, you can select a single frame or a range of frames in the video data track, the
audio data track, or both data tracks.
The other factor that affects the outcome of editing operations is the editing mode (insert 
mode or overwrite mode).



See Also 
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Clipboard Formats Supported by VidEdit

VidEdit lets you transfer video and audio data to and from the Clipboard. When pasting 
data from the Clipboard to the video sequence, VidEdit supports the following formats:

Waveform audio

Bitmaps

Palettes

Video sequences copied from VidEdit

For example, you can copy a segment of audio from Sound Recorder, switch to VidEdit, and 
paste the sound into the video sequence.
Note When you cut or copy a selection of one or more frames, VidEdit copies the following 
items onto the Clipboard:

A bitmap and palette from the first selected frame. This information is provided in a 
universal format that most applications can use.

The selected frames. The frame selection is copied in a format used only by VidEdit; 
you will only be able to paste the frames to VidEdit (though you can paste the frames into a 
different VidEdit session running on your computer).

The audio sequence (waveform) corresponding to the selection. The audio is copied 
in standard waveform audio (.WAV) format, so any application that accepts waveform 
sounds can use the audio information.



See Also 
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Activating Multimedia Data Tracks

When you edit .AVI files, you work with the following multimedia data tracks:

Video track

Waveform audio track
VidEdit lets you activate one or both tracks for editing. Editing commands such as Insert, 
Cut, Paste, and Delete only affect active editing tracks. 

 To activate a data track for editing
1 From the Edit menu, choose Track.

Another menu appears from the Edit menu, showing the data tracks you can select.
2 Select Video Only, Audio Only, or Both Video and Audio.
Or, choose the appropriate Data Track buttons:

Video 

Audio 

Both video and audio 



See Also 
VidEdit Toolbar and Controls
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Selecting Frames

You can select one or more frames in a contiguous block within the video sequence. Editing
operations affect the frames in the selection, but only for those data tracks that are active. 
There are two ways to select frames:

Using a dialog box

Using the Mark In/Mark Out buttons in the VidEdit window
If you haven't selected a block of frames, the edit commands use the current frame.
Note VidEdit lets you refer to frame positions using frame units or time units. The position 
values used with the Set Selection dialog box and Mark In/Mark Out use the time 
measurement you've selected.

 To select frames using a dialog box
1 From the Edit menu, choose Set Selection.
2 In the From box, type the first frame number or time position to select.
3 In the To box, type the last frame number or time position to select.
4 Choose OK.

 To select frames using the Mark In/Mark Out buttons
1 Move to the first position you want to include in the selection. You can drag the slider in 

the VidEdit window, or you can use a dialog box, as described in the next procedure.
2 Choose the Mark In button .
3 Move to the last position you want to include in the selection.
4 Choose the Mark Out button .

 To jump to a specific position
1 From the Edit menu, choose Go To.

Or, double-click the frame-number display area of the status bar.
2 Type the frame number, or type the time position (depending on which measurement is 

active).
3 Choose OK.

 To change to a different time measurement
1 From the Edit menu, choose Preferences.
2 To use tracks, clear the Show Positions In Time Format check box.

To use time, select the Show Positions In Time Format check box.
3 Choose OK.
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Using the Editing Modes

VidEdit provides two editing modes that affect the outcome of editing operations. When 
inserting files into a video sequence or performing Clipboard operations such as cut and 
paste, you can use the following editing modes:

Editing Mode Description
Insert mode When adding data (by inserting a file or 

pasting from the Clipboard), VidEdit moves 
existing data forward to allow room for the 
new information.
When removing data (by cutting or deleting), 
VidEdit moves existing data back to cover the 
space vacated by the deleted information.

Overwrite mode When adding data (by inserting a file or 
pasting from the Clipboard), VidEdit writes 
over the data existing at the insertion 
position.
When removing data (by cutting or deleting), 
VidEdit removes the frame information but 
leaves the frames intact, so the video 
sequence remains the same length.

For more information about working with the editing modes to add and remove data, see 
the following topics in this sequence.

 To toggle between insert and overwrite modes

Press the INS key. The OVR/INS indicator in the status bar shows which mode is 
selected.

Or, double-click the OVR/INS indicator in the status bar.



See Also 
VidEdit Toolbar and Controls
Cutting and Deleting Frames
Pasting and Inserting Frames



Copying Frames

You can copy one or more frames of video or audio data to the Clipboard. After copying 
information to the Clipboard, you can paste it back into your video sequence. Also, some of 
the information that VidEdit transfers to the Clipboard is usable by other applications; for 
more information, see Clipboard Formats Supported by VidEdit.
The effects of copying depend on the following factors:

Factor Effect
Frame selection Determines which frames are copied. If no 

frames are selected, only the current frame is 
copied.

Active tracks Data is only copied from active tracks. If only 
one track is active, only that track is copied.

 To copy frame data to the Clipboard
1 Select the frames you want to copy.
2 Activate the tracks from which to copy data.
3 From the Edit menu, choose Copy.

Or, choose the Copy button  from the toolbar.



See Also 
Activating Multimedia Data Tracks
Clipboard Formats Supported by VidEdit



Cutting and Deleting Frames

You can remove one or more selected video or audio frames by using the Cut and Delete 
commands. The Cut command removes data and moves it to the Clipboard; the Delete 
command just removes the data.
The effects of cut or delete depend on the following factors:

Factor Effect
Frame selection Determines which frames are cut or deleted. If

no frames are selected, only the current frame
is removed.

Active tracks Data is only removed from active tracks. If 
only one track is active, only that track is 
affected.
Cutting data with both the video and audio 
data tracks active preserves synchronization 
between the two tracks. Cutting data on a 
single track affects synchronization between 
the two tracks. 

Editing mode 
(insert or 
overwrite)

In insert mode, the selected frames are 
removed, and the time of the video sequence 
is shortened by the number of frames 
removed.
In overwrite mode, data in the selected 
frames is removed, but the total time of the 
video sequence remains the same. For 
example, if video frames 100 through 105 are 
cut, the resulting video will show no changes 
between frames 99 and 105 (the action will 
appear to pause starting at frame 99).

 To cut frame data to the Clipboard
1 Select the frames you want to cut.
2 Activate the tracks from which to cut data.
3 From the Edit menu, choose Cut.

Or, choose the Cut button  from the toolbar.

 To delete frame data
1 Select the frames you want to cut.
2 Activate the tracks from which to cut data.
3 From the Edit menu, choose Delete.

 To toggle between overwrite mode and insert mode



Press the INS key.
Or, double-click the INS/OVR indicator in the status bar.

 To activate a data track for editing
1 From the Edit menu, choose Track.

Another menu appears from the Edit menu, showing the data tracks you can select.
2 Choose Video Only, Audio Only, or Both Video and Audio.
Or, choose the appropriate Data Track buttons:

Video 

Audio 

Both video and audio 

Effect of Cutting or Deleting Video
The following illustration shows part of a video sequence that contains five frames of video 
with a corresponding audio track. The current frame is selected. Data in the audio track is 
not selected because the audio track is inactive. 

Click here to see the effect of a Cut or Delete command in insert mode.
Click here to see the effect of a Cut or Delete command in overwrite mode.



See Also 
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Pasting and Inserting Frames

You can add data to the video and/or audio tracks by pasting from the Clipboard or by 
inserting the contents of a file. You can add video, audio, or both. 
When adding frames, make sure the inserted frames have the same size as the rest of the 
frames in the video sequence. If one or more images are smaller than the frame size, the 
unused portion of the frame might contain color information from earlier frames. 
The effects of a paste or insertion depend on the following factors:

Factor Effect
Frame selection In insert mode, VidEdit deletes the selected 

frames and then inserts the new data in their 
place. If no frames are selected, the new data 
is inserted before the current frame.
In overwrite mode, VidEdit starts overwriting 
data at the first frame of the selection. If the 
new data covers more frames than are 
selected, frames beyond the selection will be 
overwritten as well.

Active tracks Data is only added to active tracks. If only one
track is active, only that track is affected.
If both tracks are active, and you're only 
inserting one type of data (only video data, or 
only audio data), blank frames are inserted in 
the track for which new data is unavailable.

Editing mode 
(insert or 
overwrite)

In insert mode, the new data is inserted 
before the current frame. If there's a selection,
the selected frames are removed, and the new
frames are inserted in their place.
In overwrite mode, existing data is replaced 
by the new data. If there's a selection, the 
existing data is overwritten starting at the first
selected frame. If no frames are selected, data
is overwritten starting with the current frame. 
If the end of the video sequence is reached 
before the new data runs out, the video 
sequence is lengthened to accommodate the 
remaining frames of new data.

 To paste data from the Clipboard
1 Set the current frame or the current selection to the position where you want to paste 

data.
2 From the Edit menu, choose Paste.

Or, choose the Paste button  from the toolbar.

 To insert a file



1 Set the current frame or current selection to the position where you want to insert file 
data.

2 From the File menu, choose Insert.
3 Select a filename, and choose OK.

 To toggle between overwrite mode and insert mode

Press the INS key.
Or, double-click the INS/OVR indicator in the status bar.

 To activate a data track for editing
1 From the Edit menu, choose Track.

Another menu appears from the Edit menu, showing the data tracks you can select.
2 Select Video Only, Audio Only, or Both Video and Audio.
Or, choose the appropriate Data Track buttons:

Video 

Audio 

Both video and audio 

Effects of Pasting or Inserting
The following illustration shows part of a video sequence that contains four frames of video 
with a corresponding audio track. There's also a representation of the Clipboard, which 
contains one frame each of video and audio data. The current frame is indicated with the 
triangles. 

Click here to see the result of a paste in insert mode, and with only the video track 
activated.
The next illustration is similar to the preceding one. In this example, the Clipboard contains 
a single frame of video data but no audio data. 



Click here to see the result of a paste in insert mode, with both the video and audio tracks 
activated.
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Cropping the Frame

To reduce the size of the video frames, you can crop the video sequence. When you crop, 
you select a portion of the frame to keep, and VidEdit discards the rest. Cropping affects 
every frame in the video sequence.
 To crop the frames of a video sequence
1 From the Video menu, choose Crop.
2 Position the cropping borders to select the area you want to save. Data outside the 

cropping borders is discarded. Choose from the following actions:
To Do This
Set the border using 
the mouse

Click and drag inside the video frame to display the 
cropping rectangle.

Change the border 
using the mouse

Drag the handles to change the size of the border.
Or, drag the border to move the entire cropping 
rectangle.

Set coordinates using 
the keyboard

In the Crop Video dialog box, type values for X, Y, 
Width, and Height.

3 Choose OK.



See Also 
Crop Video Dialog Box



Resizing the Frame

To increase or reduce the size of the video frames, you can resize the video sequence. 
When you resize, you expand or shrink the frame image to the new size. Resizing affects 
every frame in the video sequence.
Note Because VidEdit stretches or shrinks the frame image to the new size, you might 
experience some loss in image quality as a result of resizing.
 To resize a video sequence
1 From the Video menu, choose Resize.

The Resize Video dialog box appears.
2 Type new values for the video frame size in the Width and Height boxes (dimensions are 

expressed in pixels).
3 To save the new dimensions as the default window size for new video sequences, choose 

Save As Default Size.
4 Choose OK.



See Also 
Resize Video Dialog Box



Synchronizing Audio and Video Tracks

The audio and video tracks of a video sequence might become unsynchronized. This can 
happen during video capture, due to a skew in timing, or during editing, when you add data
to one or both of the data tracks. There are two ways to adjust synchronization:

Adjust the starting point of the audio, shifting the entire sound track forward or 
backward to align it with the video track. This is useful when the entire audio track is off by a
specific number of frames.

Change the playback rate (frame rate) of the video track. This is useful when the 
video track is running faster or slower than the audio track.

Changing the playback rate affects the duration of the video sequence; for example, 
increasing the frame rate shortens the total time of the sequence. This is different from 
the Convert Frame Rate command, which maintains the duration of the video by adding 
or inserting frames to accommodate the changed rate.

You can perform both of these adjustments using the Synchronize command and then play 
segments of the video to determine whether you've succeeded.
Hint Choose a synchronization point (a point where an obvious sound coincides with an 
obvious action; for example, clapping hands). If you can synchronize this point, the rest of 
the sequence should be synchronized.
 To synchronize audio and video
1 From the Video menu, choose Synchronize.

The Synchronize dialog box appears.
2 To adjust the starting point of the audio track, type a value in the Audio Offset box. 

Positive values move the audio track later in the video sequence; negative values move 
the audio track earlier in the sequence.

3 To adjust the frame rate, type a value in the Video Speed box. Larger values compress 
the duration of the video track, shortening the display period for each frame. Smaller 
values increase the display period for each frame.

4 To close the dialog box, choose OK.
Or, to test your results, continue to the next procedure.

Note If you use the Synchronize routine repeatedly, you'll notice that the audio offset 
returns to zero each time you display the Synchronize dialog box. The offset always refers 
to a change in position from the current starting point of the waveform track, not an 
absolute position measured from the beginning of the video sequence.
 To test the synchronization
1 From the Synchronize dialog box, adjust values in the Sample Playback Of Video box:

In Play Start, specify where to begin sample playback.
In Play Duration, specify how many seconds of video and audio to play, starting at the 
specified point. 

2 Choose the Play button. Note any differences between the audio and video 
synchronization points. You can play the sequence several times, changing the Play Start
and Play Duration values to see the effects of different frame ranges. If necessary, adjust
your synchronization settings (as described in the first procedure). 

3 When you're finished synchronizing, choose OK.
Note Video sequences previewed from the Synchronize dialog box are played from 
memory. When playing larger sequences (for example, using a 320 by 240 frame size), you 
may run out of memory, causing a degradation in the preview quality.



See Also 
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Extracting Audio and Video Tracks

You can extract any range of frames within the video and/or audio tracks, and save the 
data in separate file. You can extract video data, audio data, or both; and you can extract 
to an .AVI file or to other formats such as waveform audio (.WAV) or bitmap (.DIB) 
sequence.
The specific data extracted depends on which type of file you choose to extract:

Extracted Data File Types
Video and audio Microsoft .AVI
Multiple bitmaps; one bitmap file 
created for each selected frame

.DIB sequence 

Audio only Microsoft Waveform
Single bitmap; only one bitmap file 
created using the image from the first 
selected frame

Microsoft Windows .DIB, 
Microsoft RIFF .DIB, other 
image-file formats

 To extract the current selection to a file
1 From the File menu, choose Extract.
2 Type the filename for the extracted file.
3 From the Save File As Type list, choose a file format you want.
4 To change the selection, choose Set Selection and specify a selection range.
5 Choose OK.



See Also 
Selecting Frames
Extract File Dialog Box
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Canceling Editing Changes

You can undo the last editing change made in VidEdit. You can also reload the last saved 
copy of the video sequence.
 To undo an editing change

From the Edit menu, choose Undo.

Or, choose the Undo button  on the toolbar.
 To reload the last saved version of a video sequence
1 From the File menu, choose Revert. This command is only available if changes have been

made to the current video sequence.
2 To discard the changed version and reload the previous version, choose OK.



See Also 
VidEdit Toolbar and Controls



Overview: Working with Color Information

Video for Windows records color in video sequences in one of three ways:
Color 
Format

Description

8 bits per 
pixel

Uses a color palette that stores up to
256 unique colors. Each pixel is 
represented by an 8-bit reference to 
an entry in the color palette. The 8-
bit format provides a maximum of 
256 unique colors within a video 
frame.

16 bits per 
pixel

Stores color information directly in 
the pixel. Each pixel is represented 
by a 16-bit color value, providing a 
maximum of 32,767 unique colors 
per pixel.

24 bits per 
pixel

Similar to the 16-bit format, but 
represents pixels using a 24-bit color
value. Provides a maximum of 16 
million unique colors per pixel.

On display adapters that provide 8-bit color capability, true-color video sequences (those 
with 16-bit or 24-bit video format) use dithering to display color information properly. 
Dithering requires more time and lowers the accuracy of the color information, so if you're 
creating video sequences for commonly available 8-bit SVGA systems, you should use the 
8-bit (palette) video format.
Video sequences that use color palettes require significantly less storage than the 16-bit 
and 24-bit formats. Using fewer colors can reduce the storage requirements per pixel, 
assuming you can trim the color palettes down to 8-bit (256-color) format. Using fewer 
unique colors can also reduce the number of changes from frame to frame, further 
decreasing the size of the video file. However, converting to 8-bit format can require 
additional editing of the video sequence.
Creating an 8-Bit Color Palette for a Video Sequence
You can use the following methods to convert your 16-bit or 24-bit video sequences to 8-bit 
format:

You can use the Video Format command to change the format. With this technique, 
VidEdit remaps all colors to a gray-scale palette. For information about the Video Format 
command, see Changing the Color Format.

Paste an 8-bit palette from the Clipboard to the video sequence. If the video 
sequence is in 16-bit or 24-bit format, VidEdit will change the color format to 8-bit.
VidEdit can create an 8-bit palette by combining the commonly used colors in one or more 
frames of the video sequence. You can also copy a palette (or any picture that has a 
palette) to the Clipboard. For example, you can open a bitmap in Paintbrush, select a 
portion of the bitmap, and copy the image to the Clipboard. Paintbrush puts the palette on 
the Clipboard along with the image, and you can then paste the palette into your video 
sequence.
For information about building a palette from the frames of a video sequence, see Creating 
Palettes. 
For information about pasting a palette to the video sequence, see Pasting Palettes.



Creating Common Palettes
Many SVGA adapters support a maximum of 256 simultaneous colors. If you want your 
multimedia applications to display colors accurately on these systems, you should develop 
common palettes for video sequences and still images that appear together on screen. 
For example, if you display two video sequences simultaneously, and each sequence uses 
256 unique colors, the system will be unable to display all 512 custom colors correctly. 
Priority will go to the video sequence in the active window, and colors in the other 
sequence will be mapped to similar colors available in the first video sequence.
To ensure correct color displays, you can create a common palette for the two video 
sequences. The common palette contains a composition of the most common colors from 
both video sequences. Both video sequences can use the common palette, so there won't 
be conflicts. Most importantly, creating a common palette gives you more control over 
which colors will be presented to the user. 
Using a common palette also helps reduce flicker and can also aid in compression, because 
it reduces color changes from frame to frame. 



See Also 
Overview: Setting Options for the Video Sequence
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Creating Palettes

VidEdit can build a palette using color information from one or more frames. After building 
the palette, VidEdit copies the palette to the Clipboard; you can then paste the palette to 
the video sequence. You can create a palette from a single frame, from a range of frames, 
or from the entire video sequence, and you can tell VidEdit how many colors to use in the 
new palette.
 To build a palette from a video sequence
1 From the Video menu, choose Create Palette.
2 Select the appropriate settings for building the palette. For information about the 

settings, see Create Palette Dialog Box.
3 If there are no frames in the current selection, you must set the current selection before 

choosing the Selection option. To display the Set Selection dialog box for the current 
selection, choose Set Selection.

4 Choose OK.
When VidEdit finishes building a palette, the Palette Created dialog box appears. You can 
choose OK to close the dialog box, or choose Paste Palette to apply the palette back to 
the video sequence. For information about pasting a palette, see Pasting Palettes.

Note Creating and applying a palette to a 16-bit or 24-bit true-color video sequence 
changes the entire video sequence to an 8-bit frame depth and remaps all colors to the 
new palette.



See Also 
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Pasting Palettes

You can copy palette data to the Clipboard and then paste it into your video sequence. To 
put a palette on the Clipboard, you can use VidEdit to build a palette from one or more 
frames in the video sequence; you can also copy an image (including the palette) using 
Paintbrush or other drawing programs. You can paste a palette to a single frame, to a range
of frames, or to the entire video sequence. 
You can remap the palette entries so colors in the new palette are substituted for similar 
colors in the original. For example, if you create a common palette from several video 
sequences, when pasting this new palette you'll want to preserve the original appearance 
of the video sequences by letting VidEdit match the colors. 
In some cases, however, you might want to avoid remapping the entries and instead 
perform a straight copy of the palette. For example, when modifying all the colors of a 
palette, such as adding tinting or changing the contrast or brightness in the entire palette, 
you should not remap colors. This maintains (in each frame) the pixel references to the 
palette, so the video frames will assume the desired color changes.
Note Applying a palette to a true-color video sequence changes the entire video sequence 
to an 8-bit frame depth and remaps all colors to the palette.
 To paste a palette from the Clipboard
1 From the Edit menu, choose Paste Palette.
2 In the Use Palette box, select where you want to paste the palette. To set a range of 

frames, choose the Set Selection button.
3 If you want VidEdit to remap the pixels to the new palette, select Remap Video To Best 

Palette Colors.
4 Choose OK.



See Also 
Paste Palette Dialog Box



Changing the Color Format

The color format of a video sequence determines the amount of storage space used to 
represent each pixel. You can change the color format for the video sequence; this changes
the size of the video sequence and can affect the accuracy of the colors used in the 
sequence. All frames in the video sequence use the same color format, so your change 
affects the entire sequence, not just a single frame. 
Video for Windows supports the following color formats:

Color Format Description
8 bits per pixel Provides a maximum of 256 unique colors for 

an entire video frame and uses a color palette.
16 bits per pixel Provides a selection of 32,767 unique colors 

per pixel and does not use a color palette. The
16-bit format uses twice the storage space as 
the 8-bit format.

24 bits per pixel Provides a selection of 16 million unique colors
per pixel and does not use a color palette. The
24-bit format uses three times the storage 
space as the 8-bit format.

Reducing the video format from 16-bit or 24-bit depth to the 8-bit depth changes the entire 
video sequence to an 8-bit depth and remaps all colors to a gray-scale palette. To retain 
accurate colors when converting to 8-bit format, you must create a color palette for the 
video sequence, then apply the palette to the entire sequence.
 To change the color format
1 From the Video menu, choose Video Format.
2 Select the color format for the entire video sequence.
3 Choose OK.



See Also 
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Overview: Setting Options for the Video Sequence

Video for Windows provides many options for configuring the attributes of video sequences.
These options let you configure a video sequence for optimal playback given the 
constraints of the capture and playback environments. When setting the attributes of the 
video sequence, you must take into account the following factors:

Quality requirements. Achieving better quality video and sound generally costs 
more in terms of storage space and processing power. For example, CD-quality audio (44 
kHz, 16-bit stereo) takes about 16 times more storage space than base-quality audio (11 
kHz, 8-bit mono).

Color capabilities of the playback environment. Are you playing on 8-bit video 
adapters that only support 256 colors? Or will playback occur on true-color devices (16- or 
24-bit adapters)? If you're playing on 8-bit devices, you'll want to use an 8-bit color palette 
so you can control the colors used at playback.

Data transfer rate of the storage device. Video demands fast transfer of data 
from the storage device, through the CPU, and to the video and sound hardware. You should 
configure your video sequence for optimal performance for the given transfer rate. Video for 
Windows lets you choose among several representative transfer rates (for CD-ROM drives 
and various hard disks); you can also choose a custom transfer rate.

Type of storage device. CD-ROM discs provide data sequentially, while hard disks 
provide more random access. Video for Windows lets you specify how video and audio data 
is interleaved in the video sequence, allowing you to create video sequences that play from 
CD-ROM devices without interruptions or skips.

Processor and hardware support. Different compressors have different hardware 
requirements; for example, at a certain frame size, an 80486 processor might be required 
for playback. Consult the documentation for the video compressor to determine whether it's 
appropriate for your playback environment.
The rest of the topics in this sequence provide information on the various options you can 
set for the video sequence.



See Also 
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Displaying Video Statistics

You can display a dialog box showing compression and size information for your video 
sequence. 
 To generate statistics for a video sequence

From the Video menu, choose Statistics.
For information about the statistics, see Statistics Dialog Box.

Note VidEdit might take a few seconds to generate the statistics. You can cancel the 
calculation by choosing OK or by pressing ESC.



See Also 
Statistics Dialog Box



Setting the Frame Rate

The frame rate determines how many frames of video are displayed per second. Faster 
frame rates provide smoother animation but require more storage space and demand 
faster data transfer. 
When changing the frame rate, VidEdit adds or removes frames to retain the original 
duration of the video sequence. For example, if you increase the frame rate from 12 to 15 
frames per second, VidEdit increases the total number of frames by 25%. VidEdit duplicates
every fourth frame and adds the duplicates to the video sequence. When decreasing the 
frame rate, VidEdit removes frames.
Note You can also use the Synchronize command to change the frame rate. With the 
Synchronize command, VidEdit does not insert or remove frames to retain the original 
duration of the video.
 To change the frame rate
1 From the Video menu, choose Convert Frame Rate.
2 In the Frame Rate box, adjust the frame rate to the speed you want.
3 Choose OK.



See Also 
Convert Frame Rate Dialog Box
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Setting the Audio Format

The audio format determines the playback quality of the sound track. The audio format also
affects the size of the audio data.
You can change the recording quality of the audio-data track in a video sequence. Audio 
ranges from the equivalent of a voice grade telephone line (8-bit samples, mono channel, 
and 11.025 kHz frequency) to CD audio quality (16-bit samples, stereo channels, and 44.1 
kHz frequency). 
 To set the audio format
1 From the Video menu, choose Audio Format.
2 Select the audio properties you want.

For information about the properties, see Change Audio Format Dialog Box.
3 Choose OK.



See Also 
Change Audio Format Dialog Box



Setting Compression Options

Video for Windows provides several compression methods that let you choose among 
tradeoffs of quality, size reduction, and compression time. Also, you can select compression
settings that affect the layout of the compressed video data within the video file. The 
compression options are used when you save the video sequence to disk.
Hint When experimenting with compression methods and options, always retain a copy of 
the original, uncompressed video file. Quality is lost each time you apply compression, so 
you don't want to compress the same video sequence using two different compression 
methods.
 To set compression options
1 From the Video menu, choose Compression Options.
2 Select the compression options you want.

To display more settings, choose Details.
For information about the compression options, see Compression Options Dialog Box.

3 To preview the sequence with the selected compression options, choose the Preview 
button (this button is only available when the detailed options are displayed).

4 Choose OK.



See Also 
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Compression Methods

Video sequences are compressed and decompressed by routines called codecs (short for 
compressor/decompressor). A codec is responsible for compressing raw video data into a 
format suitable for distribution. When users play the compressed video sequence, the 
codec performs a reverse role, converting the compressed data into images that can be 
displayed on the user's system.
Video for Windows includes several codecs, each of which has advantages and 
disadvantages. When evaluating a codec, you should consider the following factors:

Quality: how well does the codec preserve the original colors, motion, and image 
detail?

Data rate: does the codec reduce the data-transfer rate to an acceptable level?
Storage size: how much storage space is saved as a result of compressing?
Time: how much time is required for compression and playback?

You should experiment with several compression methods to see which works best with 
your video content and delivery platforms.
Note Don't apply multiple compression methods to your video sequence. Most methods 
result in some loss of quality, and the loss is compounded if multiple techniques are 
applied. When experimenting with compression settings, save the original uncompressed 
version of your video sequence as a baseline.
The following compression methods are available from the Compression Options Dialog 
Box:

Method Description
No Recompression Retains the current compression method, so the 

video is saved without a change in compression 
technique. No additional compression is applied.
When changing compression options (but 
retaining the same compression method), select 
No Recompression as the compression method. 
This option greatly reduces the time required to 
save the sequence, assuming you're only 
changing compression properties (for example, 
adding interleaving, or changing the data rate).
This option is not available if the sequence has 
been edited (for example, if you've added or 
removed frames).

Microsoft RLE Fast compression method useful for computer-
generated animation, screen captures, and 
other sequences with areas of uniform color. 
Quality and size reduction drop rapidly if there 
are many changes from frame to frame (for 
example, as would be the case in a sequence 
captured from videotape).
The RLE method is limited to 8-bit video 
sequences.

Full Frames Not a compression method; instead, Full Frames 
decompresses the video sequence and saves 
each frame as a device-independent bitmap. If 
the sequence was already compressed, the 
resulting bitmaps will show any distortions 



introduced during compression.
Cinepak Codec by 
SuperMatch

Excellent compression method for video 
sequences delivered on CD-ROM. Cinepak 
provides good image and motion quality at CD-
ROM data-transfer rates (15 frames per second 
with a 320-by-240 frame size produces an 150K 
per second data rate). 
The video sequence is stored using the 24-bit 
color format, which preserves much of the color 
information from the original video. When 
playing on 8-bit displays, Cinepak uses dithering
to transfer the 24-bit color values to an 8-bit 
palette format.
Cinepak uses an asymmetric compression 
technique, one that takes much longer during 
compression than during playback. On a fast 
capture system, allow approximately one hour of
compression time per minute of video at 320-by-
240 frame size, 15 frames per second.

Microsoft Video 1 Combines good playback quality with relatively 
quick compression times. If you're using the 
Cinepak codec as your final compression 
method, you might consider using Video 1 for 
draft versions of the video sequence. Just be 
sure to retain your original, uncompressed 
sequence as a master copy.
The video sequence is stored in either 8-bit or 
16-bit format. Using the 8-bit format, you can 
specify which palettes to use in the video 
sequence, so if your sequence is playing strictly 
on 8-bit machines, Video 1 provides better 
control over the palette colors than compression
methods that use an automatic dithering 
technique.

Intel Indeo(TM) 
Video R3.1

Provides high-quality video (320-by-240 frame 
size and 15 frames per second), using an 
asymmetric compression technique.
Indeo 3.1 uses a 24-bit color format. When 
played on 8-bit video displays, Indeo dithers the 
24-bit colors to 8-bit format. 
Indeo takes advantage of compression hardware
on the Intel Smart Video Recorder capture 
board, allowing real-time hardware compression 
during capture. Intel recommends a key-frame 
interval of 4.

Intel Indeo(TM) 
Video Raw

Uncompressed YUV format produced by the Intel
Smart Video Recorder capture board. Capture in 
this format if you want to use a different 
compressor than Indeo 3.1.

See Also 



Compression Options Dialog Box
Compressing Video
Saving an AVI File



Open Video File Dialog Box

Use this dialog box to open a Video for Windows (.AVI) sequence, as well as the following 
external video formats:

File Format Notes
Microsoft DIB 
Sequence (.DIB)

The DIB files should be numbered to show 
sequence; for example, ANIM1.DIB, ANIM2.DIB, 
ANIM3.DIB. Specify the name of the first file, and
VidEdit searches the same directory for the rest 
of the files in the series.

Autodesk Animation
(.FLI)

VidEdit converts video stored in Autodesk 
Animation files.

Converted 
QuickTime movies

Using the Video for Windows Converter, you can 
convert QuickTime files into the .AVI format and 
play converted movies on your multimedia PC.

After importing one of these video files, you can save it as a Video for Windows (.AVI) 
sequence.
The dialog box has the following options:

Option Description
File Name Identifies the currently selected file. To specify 

another file, select another filename from the 
list beneath the box, or type another filename.

Directories Specifies the directory path that contains the 
current file. To specify another directory, select 
another directory from the list beneath the box, 
or type another directory path in the File Name 
box.

List Files Of Type Specifies the type of file that you want to use. To
specify another type of file, select another entry 
from the list beneath the box.

Drives Specifies the device that contains the current 
file. To specify another device, select another 
device from the list beneath the box, or type 
another device name in the File Name box.

OK Opens the specified video sequence.
Cancel Closes the dialog box without opening a video 

sequence.

See Also 
Importing Audio-Visual Sequences



Save Video File Dialog Box

Use this dialog box to save the video sequence as a Video for Windows (AVI) file. The dialog
box has the following options:

Option Description
File Name Specifies the filename for the video sequence. 

Type the filename for a new file, or select an 
existing file.

Directories Specifies the current directory. To change the 
current directory, select a directory from the list 
below the box, or type another directory path in 
the File Name box.

Drives Specifies the current disk drive. To specify 
another drive, select one from the list, or type a 
new drive name in the File Name box.

Save Copy Select this option to retain the format of the 
video sequence loaded into VidEdit. With this 
option, the video sequence is saved using the 
specified compression options, but the original 
video sequence is retained in memory. This is 
useful if you're saving several versions of an 
same uncompressed video sequence. 
With the Save Copy option cleared, the video 
sequence loaded into VidEdit is replaced by the 
saved version.

Compression 
Options

Choose this button to change compression 
settings for the video sequence you're saving.

OK Saves the video sequence using the selected 
options.

Cancel Closes the dialog box without saving the video 
sequence.

See Also 
Saving an AVI File
Compression Options Dialog Box



Insert File Dialog Box

Use this dialog box to insert a video sequence, audio sequence, or picture at the current 
location. The following VidEdit settings affect the outcome of the insertion:

Setting Description
Insertion point or 
selection

Determines where the file data is placed.
If there's a selection, the selected frames are 
deleted from the active data tracks before the 
insertion occurs.
If no frames are selected, the file data is placed 
starting at the current frame (the one displayed 
in the editing window).

Editing Mode
(Insert or Overwrite)

Determines whether the file data overwrites 
data in the existing video sequence.

Active Data Tracks
(Video, Audio, or 
Both)

Determines what data is inserted (not used 
when inserting single-frame pictures or audio 
files).

The dialog box has the following options:
Option Description
File Name Specifies the file to insert. Type a filename, or 

select a filename from the list.
Directories Specifies the current directory path. To specify 

another directory, select another directory from 
the list beneath the box, or type another 
directory path in the File Name box.

List Files Of Type Specifies the type of file that you want to insert. 
To specify another type of file, select another 
entry from the list beneath the box.

Drives Specifies the current disk drive. To specify 
another drive, select one from the list, or type a 
new drive name in the File Name box.

OK Inserts the selected file.
Cancel Closes the dialog box without inserting a file.

See Also 
Pasting and Inserting Frames



Extract File Dialog Box

Use this dialog box to extract video and/or audio from the video sequence. You can extract 
the following types of information:

Video sequences, in .AVI format
Individual frames of video, in a variety of image formats
Audio sequences, in waveform audio format

The dialog box has the following options:
Option Description
File Name Specifies the filename for the extracted file. 

Type the filename for a new file, or select an 
existing file.

Directories Specifies the current directory. To change the 
current directory, select a directory from the list 
below the box, or type another directory path in 
the File Name box.

Drives Specifies the current disk drive. To specify 
another drive, select one from the list, or type a 
new drive name in the File Name box.

List Files Of Type Specifies the type of file to create.
Set Selection Choose this button to specify the portion of the 

video sequence to extract. 
OK Extracts data to the specified file.
Cancel Closes the dialog box without extracting data.

See Also 
Extracting Audio and Video Tracks
Selecting Frames
Set Selection Dialog Box



Paste Palette Dialog Box

Use this dialog box to paste color information from the Clipboard into a frame or range of 
frames within the video sequence. When pasting a palette, you can remap the new palette 
colors to the nearest colors in the previous palette. This option most closely preserves the 
current look of the video frames. For example, if you create a common palette from several 
video sequences, when pasting this new palette you'll want to preserve the original 
appearance of the video sequences by letting VidEdit match the colors. 
You can also copy the new palette colors without remapping. If the color entries in the new 
palette are not arranged exactly like those in the previous palette, there can be significant 
color changes in the video frames. When modifying all the colors of a palette, such as 
adding tinting or changing the contrast or brightness in the entire palette, you should not 
remap entries (in this case, you want the colors to change).
The Paste Palette dialog box has the following options:

Option Description
Use Palette (in 
current frame, in all
frames, or in 
selection)

You can apply a palette to a single frame, a 
range of frames, or the entire video sequence.
Note When pasting a palette to a 16- or 24-bit 
video sequence, the entire sequence is 
converted to the 8-bit format.

Remap Video To 
Best Palette Colors

Specifies whether to rearrange the palette 
entries so they approximate the colors used in 
the previous palette. With this option selected, 
you preserve more of the original appearance of 
the video frames. 
If you don't use this option, VidEdit simply 
copies the new palette entries over the old 
palette entries. If the new palette is not 
arranged exactly as the old palette, you might 
see significant color changes.

OK Pastes the palette using the selected options.
Cancel Closes the dialog box without pasting the 

palette.

See Also 
Creating Palettes
Pasting Palettes



Set Selection Dialog Box

Use this dialog box to change the selection range within the video sequence. You can also 
select frames using the Mark In  and Mark Out 

 buttons in the VidCap window. The dialog box has the following options:
Options Description
All Selects all frames in the video sequence.
None Removes any selection present.
Selected Range 
(From, To, and Size)

Specifies a range of frames to select. 
In From, specify the first frame in the selection.
In To, specify the last frame in the selection, or, 
in Size, specify how many frames to select 
(starting with the From frame).

OK Creates the selection using the options you 
chose.

Cancel Closes the dialog box without changing the 
selection.

See Also 
Selecting Frames
Activating Multimedia Data Tracks
VidEdit Toolbar and Controls



Go To Frame Dialog Box

Use this dialog box to jump to a specific frame number. You can also jump to a frame using 
the slider control in the VidEdit window. The dialog box has the following options:

Options Description
Go To Specifies the number of the frame to jump to.
OK Jumps to the specified frame.
Cancel Closes the dialog box without jumping to a 

different frame.

See Also 
Selecting Frames
VidEdit Toolbar and Controls



VidEdit Preferences Dialog Box

Use this dialog box to set options for editing video. These options don't affect your video 
clip; they just change options for VidEdit. The dialog box has the following options:

Options Description
Resize Window To 
New Frame Size

Select this option to resize the VidEdit window to
accommodate changes in the frame size of the 
video sequence (for example, when cropping the
frame or loading a new sequence). Clear this 
option to keep the VidEdit window the same 
size.

Center Image In 
Window

Select this option to center the video frame in 
the VidEdit window. Clear this option to display 
the video frame at the upper-left corner of the 
window.

Show Frame # In 
Title Bar

Select this option to display the current frame 
number in the VidEdit title bar.

Show Positions In 
Time Format

Select this option to display position 
measurements as times (hh:mm:ss.dd) rather 
than as frames.

Status Bar Select this option to display the status bar at the
bottom of the VidEdit window.

Tool Bar Select this option to display the toolbar at the 
top of the VidEdit window.

Overwrite Mode Select this option to use overwrite mode rather 
than insert mode when performing editing 
operations (insert, paste, cut, and delete). For 
more information about overwrite mode and 
insert mode, see Using the Editing Modes.

Memory For 
Caching Images

Specifies the amount of memory to reserve for 
storing video sequences while editing. Larger 
values can result in faster editing performance.

Background Color Specifies the background color for the VidEdit 
window. The background color fills the area 
outside the video-frame display.

OK Sets the specified editing options.
Cancel Closes the VidEdit Preferences dialog box 

without changing options.

See Also 
Adjusting the Look of VidEdit
Adjusting the Video Frame Display
Enhancing Editing Performance
Using the Editing Modes



Compression Options Dialog Box

Use this dialog box to set compression options for the video sequence. These options are 
used when the video sequence is saved to disk.
There are three parts to this dialog box. The simple version is displayed first; you can 
choose a Details button to display more options. After displaying the detailed options, you 
can expand again to display a preview using the specified compression options.
Basic Options

Option Description
Target Specifies the type of device on which the video 

sequence will be stored. The device type is 
important because it determines the speed at 
which data can be read and displayed. Each 
selection in the Target box has a matching set of
compression options displayed in the details are 
of the Compression Options dialog box. To view 
the detailed compression options for a target 
device, choose the Details button.

Video Compression 
Method

Specifies which compressor (codec) to use. For 
information about the various compressors, see 
Compression Methods.

Save As Default Saves the current compression options as 
default values to be displayed with new video 
sequences.

Use Default Resets the compression options to default 
values.

OK Saves the compression options. The options will 
be used when the video sequence is saved to 
disk.

Cancel Closes the Compression Options dialog box 
without saving the compression options.

Details/Preview With just the basic options displayed, the Details
button expands the dialog box to display 
detailed compression options.
With the detailed options displayed, the Details 
button changes into a Preview button. By 
choosing Preview, you can display a quality 
preview using the specified options. The quality 
preview lets you see how the selected 
compression options affect the quality of the 
video image.

Detailed Options

Options Description
Data Rate Specifies the expected data-transfer rate at 

playback. The video compressor uses this 
information to determine how much information 
to include on each frame; with higher data rates,



more information can be stored, and quality is 
better. 
If the video sequence is played from a device 
that has a slower transfer rate than specified for
compression, the playback quality might suffer.

Interleave Audio 
Every n Frames

Specifies that audio and video data will be 
stored in segments within the video sequence, 
with the segments placed at the indicated frame
intervals. Interleaving has benefits when playing
video sequences from storage devices that are 
more efficient in providing information 
sequentially (such as CD-ROM discs).
For CD-ROM, use the default value of 1 frame to 
interleave every frame of video with audio data. 
For sequences played from hard disk or network 
drives, you can use a larger value (but use a 
value different from the key-frame value).

Key Frame Every n 
Frames

Specifies how often a full frame should be stored
in the video sequence. Key frames provide a 
complete frame image and act as a reference 
point for successive frames that store only 
differences from the previous frame. Key frames 
provide convenient jump destinations for the 
video sequence; users can jump to the key 
frame, and the full-frame image will be 
displayed.

Pad Frames For CD-
ROM Playback

Specifies that the same amount of data should 
be stored for each frame, so frames with smaller
amounts of data are padded to keep a 
consistent size. This option is useful for CD-ROM 
playback because it lets the storage device 
maintain a constant data rate when retrieving 
the video sequence.

Compressor 
Settings

Lets you balance image quality with the 
specified data rate. Higher quality (moving the 
slider to the right) increases the importance of 
clear, accurate images at the expense of smooth
motion. Lower quality (moving the slider to the 
left) decreases the image quality but provides 
smoother motion.
Compressor Settings also contains a command 
button that provides compressor-specific 
settings or information.

See Also 
Setting Compression Options
Compression Methods
Saving an AVI File



Convert Frame Rate Dialog Box

Use this dialog box to change the frame rate for the video sequence. The change does not 
affect the duration of the video or the synchronization of the video and audio tracks; 
VidEdit just inserts or removes frames to accommodate the change.
The dialog box has the following options:

Options Description
Frame Rate Specifies the new frame rate for the video 

sequence.
Increasing the frame rate increases the number 
of frames in the sequence. For example, 
changing from 12 to 15 frames per second 
increases the number of frames by 25%. VidEdit 
duplicates every fourth frame to accommodate 
the new sequence.
Decreasing the frame rate decreases the 
number of frames in the sequence. For example,
changing from 12 to 9 frames per second 
reduces the number of frames by 25%. VidEdit 
removes every fourth frame to accommodate 
the reduced rate.

OK Saves the new frame rate. The new frame rate 
will be used when the video sequence is saved 
to disk.

Cancel Closes the dialog box without changing the 
frame rate.

See Also 
Setting the Frame Rate
Synchronizing Audio and Video Tracks



Synchronize Dialog Box

Use this dialog box to synchronize the video and audio tracks. You can adjust the starting 
point of the audio track, adjust the speed at which the video frames are displayed, and 
preview the results.
The dialog box has the following fields:

Options Description
Audio Offset Specifies the number of milliseconds to move 

the audio track. The entire audio track will be 
shifted the specified distance. You can type 
positive or negative values.

Video Speed Specifies a new frame rate for the video 
portion of the sequence. Unlike the frame-rate
adjustments made in the Convert Frame Rate 
dialog box, synchronization changes don't 
result in the addition or deletion of frames 
(the frame speed is the only change).

Sample Playback 
Of Video

Lets you play a sample of the video to preview
the effects of your synchronization efforts. You
can specify the starting position and duration 
of the playback. Choose Play to start 
playback; you can choose the same button 
(renamed Stop) to stop the playback.
Note Video sequences previewed from the 
Synchronize dialog box are played from 
memory. When playing larger sequences (for 
example, using a 320 by 240 frame size), you 
may run out of memory, causing a 
degradation in the preview quality.

OK Saves the synchronization changes.
Cancel Closes the Synchronize dialog box without 

saving the synchronization changes.

See Also 
Synchronizing Audio and Video Tracks



Change Audio Format Dialog Box

Use this dialog box to change the format of the audio information stored in the sequence. 
The dialog box has the following options:

Option Description
Sample Size Defines the amount of storage used for each 

digitized portion of the waveform. 8-bit samples 
use less memory to store waveform information;
16-bit samples provide greater dynamic range.

Channels Defines the waveform as mono or stereo. Mono 
waveforms store audio information in a single 
audio track. Stereo waveforms use two tracks to 
store waveform information and double the 
amount of audio information per frame.

Frequency Defines the rate at which audio samples are 
taken. The 11.025 kHz frequency (roughly 
equivalent to a voice-grade telephone line) 
samples over 11,000 samples per second. 
The 22.05 kHz frequency (equivalent in quality 
to AM radio) obtains samples twice as often as 
11.025 kHz frequency. 
The 44.1 kHz frequency is the sampling rate 
used for audio CDs.

OK Saves the audio settings.
Cancel Closes the Change Audio Format dialog box 

without saving the audio settings.

See Also 
Setting the Audio Format



Video Format Dialog Box

Use this dialog box to change the color format for the entire video sequence. The color 
format determines how much space is used to store each pixel of a video frame and, as a 
result, the number of unique colors that can appear in each frame. Changes to video format
apply to every frame in the sequence.
The dialog box has the following options:

Options Description
8-bit Provides a maximum of 256 unique colors per 

frame, using a color palette.
When converting a 16- or 24-bit sequence to 8-
bit format, VidEdit remaps all colors to a gray-
scale palette. To retain accurate colors, you 
should not use the Video Format dialog box to 
perform the conversion. Instead, build an 8-bit 
palette (for more information, see Creating 
Palettes), then apply the palette to the entire 
sequence (for more information, see Applying a 
Palette).

16-bit Provides an unlimited number of colors per 
frame, with each pixel having 32,767 color 
choices. Does not use a palette.

24-bit Provides an unlimited number of colors per 
frame, with each pixel having 16 million color 
choices. Does not use a palette.

OK Saves the video format changes.
Cancel Closes the Video Format dialog box without 

saving changes.

See Also 
Changing the Color Format
Creating Palettes
Pasting Palettes



Create Palette Dialog Box

Use this dialog box to create an 8-bit (256-color) palette using the colors of one or more 
frames in the video sequence. For example, to convert a true-color (24-bit) video sequence 
to 8-bit format, you might build an 8-bit palette from a representative range of frames in 
the sequence, then apply that palette to the entire sequence.
The dialog box has the following options:

Options Description
Current Frame Specifies to build a palette using colors from 

the currently displayed frame.
All Frames Specifies to build a palette using all frames in 

the sequence.
Selection Specifies to build a palette using a selected 

range of frames. This option is only available if
you've selected a range of frames; if it's 
disabled, you can choose the Set Selection 
button to create a selection.

Colors In Created 
Palette

Specifies how many colors will appear in the 
palette. 
If you specify 1 to 236 colors, VidEdit creates a
palette with the specified number of entries. 
The default size is 236; this allows space for 
the 20 system colors that are always used by 
Windows.
If you specify 256 colors, VidEdit creates an 
identity palette containing 236 colors drawn 
from the video sequence. The identity palette 
also contains the 20 system colors (arranged 
in a preset location expected by Windows) and
provides more efficient processing during 
playback.

OK Creates the palette and copies it to the 
Clipboard.

Cancel Closes the dialog box without creating a 
palette.

See Also 
Creating Palettes
Pasting Palettes
Paste Palette Dialog Box



Palette Created Dialog Box

This dialog box is displayed after VidEdit finishes building a palette from one or more video 
frames. VidEdit has copied the palette to the Clipboard. You can take one of the following 
actions:

To close the dialog box, choose OK.
To display the Paste Palette dialog box, which lets you apply the Clipboard palette to 

one or more frames in the video sequence, choose Paste Palette.



See Also 
Creating Palettes
Pasting Palettes
Paste Palette Dialog Box



Crop Video Dialog Box

Use this dialog box to reduce the size of the video frame. When cropping, you specify the 
area of the frame that you want to keep, and VidEdit discards the rest. Cropping affects all 
frames in the sequence.
To crop the frame, move the dialog box out of the way of the frame display. Then drag to 
draw a cropping rectangle around the frame area you want to keep. You can drag the 
handles to size the rectangle, or drag the rectangle border to move the rectangle. You can 
also type coordinate values in the dialog box; the rectangle is updated to show the new 
values.
Note You can also resize the video frame by shrinking or expanding the frame image 
(without cropping the frame image). For more information, see Resizing the Frame.



See Also 
Cropping the Frame
Resizing the Frame



Resize Video Dialog Box

Use this dialog box to change the size of the video frame. When resizing, you shrink or 
expand the frame image to the new size. Resizing affects all frames in the sequence.
The dialog box has the following options:

Options Description
Width Specifies the width of the frame (in pixels). 
Height Specifies the height of the frame (in pixels).
Save As Default 
Size

Saves the current size as the default for new 
sequences.

OK Resizes the frame to the specified size.
Cancel Closes the dialog box without resizing the frame.

See Also 
Resizing the Frame
Cropping the Frame



Statistics Dialog Box

Use this dialog box to view statistics about the video sequence. To close the dialog box, 
press ESC, or choose the OK button.
The dialog box has the following statistics:

Statistic Description
Est. File Size Approximate size of the file containing the video 

sequence.
File Length Number of frames making up the video 

sequence.
File Duration Running time of the video sequence, assuming 

the specified frame and data-transfer rates.
Frame Rate Number of video frames recorded for each 

second of playback of the video sequence.
Data Rate Predicted data-transfer rate of the playback 

environment.
Video Track Size Number of bytes of the file containing video-

frame data.
Video Format Color format of the video sequence (number of 

bits per pixel) and compression method.
Audio Track Size Total size of the audio data in the sequence.
Audio Format Characteristics of the audio data track, including

sample size, sampling frequency, and number of
channels (mono or stereo).

Interleaved every X 
frames

Video-chunk size (in frames) interspersed 
between chunks of audio data throughout the 
video file (expressed as the number of 
contiguous video frames regularly occurring 
throughout the video file).

See Also 
Displaying Video Statistics
Setting Compression Options





Title Bar
Displays "VidEdit" and the name of the video sequence.
You can also display the current frame number in the 
title bar; for more information, see Adjusting the Look 
of VidEdit,

Menu Bar
Contains a list of menus. You open menus and then 
choose commands from them to instruct VidEdit to 
perform actions.

Edit Area
Displays the current frame image.
Because many compression methods store only the 
changes from frame to frame, the edit area might not 
display a complete frame image. To generate a 
complete frame image for the current frame, press F5.

File Open Button
Opens an .AVI file or other video file (same as the Open 
command on the File menu).

File Save Button
Saves the current file in the .AVI format (same as the 
Save command on the File menu).

Cut Button
Deletes frame data and pastes it onto the Clipboard 
(same as the Cut command on the Edit menu).

Copy Button
Copies frame data onto the Clipboard (same as the 
Copy command on the Edit menu).

Paste Button
Pastes audio or video data from the Clipboard (same as 
the Paste command on the Edit menu).

Undo Button
Undoes the last operation (same as the Undo command
on the Edit menu).

Capture Video Button
Starts VidCap, the video-capturing application (same as
the Capture Video command on the File menu).



Redraw Full Frame Button
Redraws the complete frame image (same as the Draw 
Full Frame command on the View menu). This button is 
only active when Fast Frame Drawing is selected. 
For more information, see Setting Frame Update 
Options.

Zoom Button
Changes the magnification of the image displayed in 
the Edit area (same as the Zoom commands on the 
View menu).

Track Bar
Shows the current position within the video sequence. 
You can move the slider to move to different frames in 
the video sequence. Choose the arrow keys to move 
one frame at a time.

Mark In Button and Display
The Mark In button sets the beginning of a frame 
selection. The starting position of the selection is 
displayed to the right of the words "Mark In".

Mark Out Button and Display
The Mark Out button sets the end of a frame selection. 
The ending position of the selection is displayed to the 
right of the words "Mark Out".

Play Button
Previews a video sequence from the current frame to 
the end of the file. 
By holding down the ALT key and choosing this button, 
you can play only the selected frames.

Stop Button
Stops the video preview.

Previous Mark Button
Moves the current position left to the nearest mark or 
to the first frame of the video sequence.
By holding down the SHIFT key and choosing this button,
you can move to the first frame of the video sequence.

Page Left Button



Jumps to the previous 10% of the video sequence.

Page Right Button
Jumps to the next 10% of the video sequence.

Next Mark Button
Moves the current position right to the nearest mark or 
to the end of the video sequence.
By holding down the SHIFT key and choosing this button,
you can move to the last frame of the video sequence.

Video/Audio Tracks Button
Activates both the video and audio tracks for editing.

Video Track Button
Activates the video track for editing.

Audio Track Button
Activates the audio track for editing.

Current Position and Total Length
The first figure (before the slash) identifies the position 
of the current frame. The second figure specifies the 
total length of the video sequence.
You can use frame units or time units within VidEdit. For
information about changing units, see Adjusting the 
Look of VidEdit.

Edit Mode
Identifies the current edit mode. INS indicates insert mode; OVR 
indicates overwrite mode. You can double-click this region to toggle 
between modes.
In insert mode, deleting frames causes the following frames to move 
forward in the video sequence, and the total length of the sequence is
shortened by the number of frames deleted. Inserting frames 
increases the length of the video sequence.
In overwrite mode, deleting frames removes the frame information 
but leaves the time space intact, so the total length of the sequence 
remains the same. Inserting frames overwrites any information at the 
insertion location.

Palette Change Indicator
Specifies whether the palette changes with the current 
frame. 
If this box contains the letter P, the current frame 
redefines the palette. If no P is present, the current 



frame uses the same palette as the previous frame.

Key Frame Indicator
Specifies whether the current frame is a key frame. If 
this box contains the letter K, the current frame is a key
frame.
A key frame is a frame in which the full image is stored 
(as opposed to the differences from the last frame).

Data Tracks Indicator
Identifies data tracks selected for editing. You can 
activate the video track, audio track, or both. 
Editing operations only affect active data tracks.



Cut or Delete in Insert Mode

Because only video editing is active, only the video track is affected. Frames following the 
current frame move one position closer to the beginning of the video sequence. With the 
Cut command, the data in the current frame is moved from the video track to the 
Clipboard; with Delete, the data is discarded. 



Cut or Delete in Overwrite Mode

Because only video editing is active, only the video track is affected. Data in the current 
frame is removed, but the total number of video frames remains the same. During 
playback, the video frame will not be updated while the cut frame is active, so the action 
will appear to freeze.
With the Cut command, the data in the current frame is moved from the video track to the 
Clipboard; with Delete, the data is discarded. 



Paste in Insert Mode, with Video Track Active

Because only video editing was active, the Paste command only affected the video track. 
The video frame on the Clipboard is inserted before the current frame. Although the 
Clipboard also contains audio data, the audio-data track remains unchanged because audio
editing is not active.
If both the audio and video-data tracks were active, the same Paste command in insert 
mode would also add the frame of waveform data on the Clipboard to the video sequence. 



Paste in Insert Mode, with Video and Audio Tracks Active

The pasted video frame is inserted. Because no waveform data is on the Clipboard, VidEdit 
inserts the Clipboard image before the current frame and inserts empty space 
(representing silence) equivalent to the length of one frame in the waveform track. 



interleave
A method of storing video and audio data together in a
video file, such that a segment of video data is 
followed by a segment of audio data. By interleaving 
video and audio data, Video for Windows can maintain 
a smooth transfer of audio/video information while 
playing a video sequence from a hard disk or CD-ROM 
drive.

track
A linear depository of information within a video 
sequence. All video sequences have at least two 
tracks: a video track storing frames of video data, and 
an audio track storing segments of audio.

frame
A single unit of information within a video sequence. A 
video sequence consists of many frames of video and 
audio data; when the frames are played in sequence, 
you see an unbroken video sequence with 
accompanying audio playback.

palette
A collection of color information for a picture or video 
sequence. 
Video for Windows can use an 8-bit palette format. 
With this format, up to 256 color values can be stored 
in a table. Images within the video sequence reference
the entries in this table; each pixel has an 8-bit value 
identifying which palette color to draw. The 8-bit 
palette format uses less storage space than the 16-bit 
and 24-bit formats, which do not use a palette (rather 
than reference a value in a table, they store color 
information directly with the pixel).

bitmap
An image format commonly used for scanned 
photographs and artwork. A bitmap divides a picture 
into a grid of pixels, with each pixel assigned a specific
color. Bitmaps usually have .BMP or .DIB extensions.

waveform audio
A technique of recreating an audio waveform from 
digital samples of the waveform. The sound track for a 
video sequence is stored as waveform audio data.

insert mode
One of two VidEdit editing modes. In insert mode, 



space is provided for data added to the video 
sequence; existing data is retained and pushed later in
the sequence. When data is removed from a video 
sequence, data following the deletion is shifted back to
cover the empty area.

overwrite mode
One of two VidEdit editing modes. In overwrite mode, 
data added to the video sequence replaces any 
existing data at the insertion point. When data is 
removed from a video sequence, the frames storing 
the deleted data are retained (leaving an empty 
frame).

frame rate
The number of frames recorded for each second of 
video playback. Higher frame rates can provide 
smoother motion than lower frame rates.

dithering
A technique for simulating an unavailable color by 
combining two or more available colors.

sampling frequency
The rate at which digital-audio samples are taken. 
Higher sampling frequencies provide better fidelity but 
require more storage space.

sample size
The amount of storage space used for each digitized 
portion of the audio track. Larger sample sizes provide 
greater dynamic range and, therefore, better audio 
reproduction (but they also require more storage 
space).

stereo (audio)
Audio format in which two channels are used. Stereo 
audio can provide better sound reproduction, but it 
also requires twice the storage space as monaural 
(mono) audio.

mono (monaural audio)
Audio format in which a single channel is used. 
Monaural audio requires half the storage space as 
stereo audio, which uses two channels of audio 
information.



codec, or Compressor/Decompressor
A software component that provides compression 
services (while creating a video sequence) and 
decompression services (while playing a video 
sequence). The Video for Windows architecture 
provides for the use of multiple codecs, so you can 
choose the one that's most appropriate for your 
application.

data-transfer rate
The speed at which data is transferred from a storage 
device to the processing hardware of the computer. 
Devices with higher data-transfer rates can provide 
better playback quality.

key frame
A fully-drawn frame stored as a reference point for 
successive frames. Most video sequences store only 
the changes from frame to frame (they don't store a 
complete image for each frame). A key frame stores a 
complete frame image, so an application can jump to 
the key frame and obtain a fully drawn image for that 
point in the video sequence.

mark
A position marker defining the beginning or end of a 
selected range of frames.




