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Introduction
Welcome to SUDS, the brewers database and log program.    This program provides a single 
place to put all of your recipes, log entries and miscellaneous brewing comments. Provided 
is a full featured multi-windowing editor, a formatted log entry system, Hop IBU spreadsheet,
calendar, calculator, label printer and a host of other features.

SUDS was written in Turbo Pascal for Windows 1.5 along with the Topaz DBase engine for 
Windows.



File Menu
The SUDS file menu offers the following options:

New recipe
Get Recipe
Get Template
Open File
Save
Save to File
Delete
Open Log
Print
Exit



New recipe
Selecting the New Recipe option from the file menu opens a new untitled window for you to 
enter new recipe text into.    Often you may prefer to use one of SUDS provided templates or 
an external file to create a new recipe.



Get Recipe
Selecting the Get Recipe option from the file menu will display a selection list of all existing 
recipes in the SUDS database.    Selecting a recipe will display the text in an editing window 
where it may be changed.



Get Template
Selecting the Get Template option from the file menu will display a list of template recipes 
for most popular beer and ale styles.    Selecting one of these will load the template into an 
untitled edit window to provide a quick method of formulating new recipes.



Open File
Selecting the Open File option from the file menu will bring up an Open dialog box which 
allows you to edit a file external to SUDS.    This allows you to import recipes from external 
sources such as text files, messages, etc. into your SUDS database.

If the size of the external file exceeds 32K, SUDS will automatically execute Windows Write 
or whichever external editor you configured to display the file.    This is because the internal 
SUDS editor cannot directly handle files over 32K in size.

From the external editor, you can still copy text into the clipboard and paste it into your 
SUDS windows.



Open dialog boxes
An Open dialog box is where you open a file by typing the file name in the input box or using
the list boxes to find and open the file.

File Name input box

The File Name input box is where you enter the name of the file to open.

Files list box

The Files list box lists the names of files in the current directory that match the file-name 
mask in the File Name input box, plus the parent directory and all subdirectories.

Directories list box

You view the contents of different directories by selecting a directory name in the Directories
list box.

You can also use shortcut keys (those underlined on your screen) to get to the area of the 
dialog box you want. 

For example, pressing Alt+D outlines the first directory in the Directories list box.



External Editor
The internal editor in SUDS is more than adequate to edit recipes and small text files.    
However, the maximum file size that can be edited by a SUDS window is 32K.    To 
accomodate files larger than this, SUDS will execute an external editor program such as 
Windows Write.    You can optionally configure your own external editor if you choose not to 
use Windows Write.

This dialog box allows you to select an external editor to use for large files.    

File Name input box

The File Name input box is where you enter the name of the editor to specify.

Files list box

The Files list box lists the names of files in the current directory that match the file-name 
mask in the File Name input box, plus the parent directory and all subdirectories.

Directories list box

You view the contents of different directories by selecting a directory name in the Directories
list box.

You can also use shortcut keys (those underlined on your screen) to get to the area of the 
dialog box you want. 

For example, pressing Alt+D outlines the first directory in the Directories list box.



Save
Selecting the Save option from the file menu will save the current window in the SUDS 
database.    If the current window is a recipe, the Save Recipe dialog box will be displayed for
you to enter the recipe details.    If the current window is a log entry, it will be saved with its 
current values.



Save to File
Selecting the Save to File option from the file menu will bring up a file save dialog box which 
allows you to save the contents of the recipe window as an external text file.    This file can 
then be edited externally, exchanged or whatever.    This option works only for Recipe 
windows.



Delete
Selecting the Delete option from the file menu will bring up a confirmation screen to delete 
the current recipe or log entry (whichever happens to be on top).    If no recipe or log entry is
displayed, a recipe selection list will be shown.    Answering yes on the confirmation screen 
will delete the recipe or log entry.



Open Log
Selecting the Open Log option from the file menu will bring up a list of log entries for the 
current recipe if any exist.    If no entries exist, the add log entry screen will be displayed.    If 
no recipes are currently open, a list of all existing log entries is displayed.



Print
Selecting the Print option from the file menu will bring up a confirmation screen to print the 
current recipe or log entry.    For recipes, the confirmation screen allows you to optionally 
print
      Recipe text
      Statistics
      Log entries



Exit
Selecting the Exit option from the file menu will prompt you to save any unsaved recipes or 
log entries and will then exit the SUDSW program.



Edit Menu
The SUDS edit menu offers the following options:

Undo

Undoes your last editing or formatting action, including cut 
and paste actions. If an action cannot be undone, Undo appears dimmed on the Edit menu.

Cut

Deletes text from recipe or log entry and places it onto the Clipboard, replacing the previous 
Clipboard contents. 

Copy

Copies text from a recipe or log window onto the Clipboard, leaving the original intact and 
replacing the previous Clipboard contents. 

Paste

Pastes a copy of the Clipboard contents at the insertion point or replaces selected text in a 
recipe or log entry.

Delete

Deletes selected text from recipe or log entry, but does not place the text onto the 
Clipboard. 
Use Delete when you want to delete text from the current recipe or log window but you have
text on the Clipboard that you want to keep. 

Clear All

Deletes all text from recipe or log entry but does not place text onto the Clipboard.
Be careful with this option as Undo won't work with it!



Search Menu
The SUDS search menu offers the following options:

Find

Searches for characters or words in recipe text.
The search can optionally be case sensitive.

Find Next

Repeats the last search without opening the Find dialog box. 

Replace

Searches for characters or words in recipe text and replaces found occurrances with the 
specified replacement text.    
You may specify whether case sensitive search should be done, whether all occurrences 
should be changed and whether you want to be prompted before each replacement.



Options Menu
The SUDS options menu offers the following options:

Sort Order

The Sort order option will allow you to specify whether recipe selection lists will be presented
alphabetically by recipe name or alphabetically by recipe category.

Pack Database

The Pack database option will optimize the internal files used by SUDS.    One shortcoming of
the DBASE III/IV file structures (which SUDS uses internally) is that text files quickly grow 
larger leaving empty "spaces" in the files.    This option compresses the files used and 
consequently save space and improves performance.

Export to SXF

The Export to SXF option will export all of your recipes into a special "SXF" format allowing 
you to share files with other SUDS users.    Both DOS and Windows versions of SUDS are fully
compatible!    The advantage of using the SXF format over merely exporting to a file is that 
SXF files also carry the recipe statistics (gravities, volume, etc.).    Text files do not.

Import SXF file

The Import SXF option will import recipes from an SXF file into your SUDS database.    This 
allows you to load in recipes from other SUDS users.    The recipes provided free with SUDS 
are in SXF format and should be imported in this fashion.    This option will not overlay a 
recipe if the name already exists in your database.

Printer Setup

The Printer setup option will display your printer's setup dialog box.    This allows you to 
conveniently alter your print setup while working in SUDS.

Configure External Editor

The Configure External Editor option will display an open file dialog box allowing you to 
specify an external editor to use for large files opened from SUDS.    The default within SUDS 
is to use Windows Write.



Categories of recipes include Pale Ale, Stout, etc. or any category of beer that you choose to 
add to your SUDS database.



Tools Menu
The SUDS Tools menu offers the following options:

Calculator

The Calculator option initiates Microsoft's calculator utility from within the SUDS application. 
This allows you to make any calculations and optionally copy the results into the Clipboard 
from where they can be Pasted into your database.    See Windows documentation for details
on Calculator.

Calendar

The Calendar option takes you directly into Microsoft's calendar utility from within the SUDS 
application.    See Windows documentation for details on Calendar.

Hop IBU Calculator

The Hop IBU Calculator option is only valid from a log entry screen.    This option displays a 
Hop IBU spreadsheet for determining International Bittering Units for your recipe batch.    On 
the spreadsheet you specify hops used in your batch and the time in the boil.    SUDS 
automatically determines the Hop IBU value from this information and fills in the log window 
Hop IBU field.

Print Beer Labels

The Print Beer Labels option is only valid from a log entry screen.    This option displays a 
sample label dialog box which allows you to customize the information to be printed on your 
labels.    In this dialog box, you specify the label text and the number of labels to print.    
Note - When editing the label text, do not use the Enter key.    This will close the dialog box 
and begin printing labels.    Use the mouse or arrow keys to maneuver around when editing 
label text.



Hop IBUs (International Bittering Units) are a worldwide standard of bitterness measurement 
based on hop isomerization (how readily the alpha acids are converted to iso-alpha acids) 
and the percentage of alpha acids contained in the hops used.



Window Menu
The SUDS Window menu offers the following options:

Close All

Selecting the Close all option will close all open recipes and/or log entries prompting you to 
save if necessary.

Cascade

Selecting the Cascade option will organize all recipes and log entries within the SUDS 
"desktop" in a cascading fashion (Try it!).

Tile

Selecting the Tile option will organize all recipes and log entries so that all are visiblt on the 
SUDS "desktop".

Arrange Icons

Selecting the Arrange icons will neatly organize any recipes and log entries that are 
minimized at the bottom of the SUDS "desktop".

Window list

The Window menu option also lists all currently open recipes and log entries.    Selecting one 
of these will put the recipe or log entry on top of the SUDS "desktop".



Entering Recipes
Entering recipes into your SUDS database can be accomplished in many ways.    You can 
enter a recipe entirely from scratch, copy recipes in from other text files, create new recipes 
from one of the many templates provided with SUDS or import recipes from "SXF" files 
created by other SUDS users.

Entering Recipes from scratch
Copying text files into a recipe window
Entering recipe from a SUDS template
Importing recipes from "SXF files"
Saving the Recipe to SUDS database



Entering Recipes from Scratch
Selecting the New recipe option from the File menu will open up a clean window in which you
may enter recipe text.    This is the easiest and most laborious method of adding recipes to 
your database.    The SUDS editor is a bare-bones editor offering most of the functionality 
found in the Notepad editor including cut/paste, etc.

You can easily cut text from another SUDS window or another windows application and paste
it into your recipe window using Window's clipboard functions (see Windows documentation 
for information on clipboard).



Copying text files into a recipe window
Text may be copied into a recipe window in a number of ways with SUDS:

Open File method within SUDS
1.Select the Open File option from the File menu.    This will allow you to open any external 
text file into a new window.    
2.Make any edits you wish and press F2 to save the recipe into the SUDS database.

Cut and Paste Method
1.From a windows application, mark text to be copied into SUDS (usually by holding down 
left mouse button and dragging over desired text).
2.From application's Edit menu, select Copy function (This should copy selected text into 
Window's internal clipboard).
3.From SUDS, select New recipe option from File menu.
4.Select Paste option from SUDS Edit menu (Text should now be in new window).



Entering Recipes from a SUDS Template
SUDS comes equipped with several "template" recipes for most popular styles of beer.    To 
add a new recipe based on one of these templates, select the Get Template option from the 
file menu.

This will open a new window with a 'starter template' for the style of beer you selected.    
Simply edit the recipe to your liking and save under a new name.

You can also add your own templates to the SUDS database.    To do so, simply prefix the 
name of your recipe with the word "template".



Importing recipes from "SXF" files
Suds "SXF" contain recipes exported from other SUDS databases.    The starter set of recipes 
"RECIPES.SXF" is distributed in this format.    To add these recipes to your database, simply 
select the Import SXF file from the Options menu in SUDS.

If a recipe already exists in your database with the same name as a recipe in the SXF file, 
the SXF recipe will NOT overlay yours.



Saving the Recipe to SUDS database
Pressing F2 or selecting the Save option from the file menu from a recipe window will display
the Recipe Details screen where all pertinant information about the recipe is entered.

The screen includes the following fields:

Recipe Name
The name of the recipe.    All recipes must have a unique name.

Method
The method used for brewing (Extract, Full mash, Partial mash, etc.) Pressing the icon next 
to this field allows you to select an existing method rather than typing You can also add your
own methods to SUDS by keying in a new value for this field not already in the list.

Category
The category for the beer style (ie Pale Ale, Stout, etc.).    You can press the icon next to this 
field to select an existing category or type in your own to add to the list.

Starting Gravity
The typical hydrometer reading taken at the start of fermentation.    Individual batches may 
vary from this!

Finishing Gravity
The typical hydrometer reading taken at the end of fermentation. Individual batches may 
vary from this!

Quantity
The quantity of beer that the recipe makes in gallons.

Aging time
How long to age the beer in weeks.



Entering Log Entries
Each batch of beer you brew should be entered into a log entry tied to the appropriate 
recipe.    You must have the recipe in SUDS prior to entering the log entry.

Entering new log entries should proceed as follows:
1. Enter the recipe into SUDS if you haven't already done so.
2. Either select the Open Log option from the File Menu, or press the right mouse button 
while in the Recipe window.    If any log entries exist already, a pick list is displayed, 
otherwise you are taken directly into the log screen to enter a new log entry.
3. Fill in any pertinant information such as starting and finishing gravities and (lots of!) free-
form notes about your brewing procedures.    Selecting the OK button with the mouse or 
pressing Enter will save the log entry.    Selecting cancel will close the log entry.

The log entry screen contains the following fields:

Date Started
The date the batch of beer was started.    Pressing the + or - keys in this field will increase or 
decrease the date by one day.

Date Bottled
The date the beer was bottled (or kegged).    Pressing the + or - keys in this field will increase
or decrease the date by one day.

Starting Gravity
The initial hydrometer reading for this batch of the recipe.

Finishing Gravity
The final hydrometer reading for this batch of the recipe.

Hop IBUs
The Hop IBU value for this batch of the recipe.    Clicking on the right mouse button or 
selecting the Hop IBU Calculator option from the Options menu will display the Hop IBU 
Calculator which will calculate the IBU value for you.

Alcohol content
This field is a display only field that shows only if both the Starting and Finishing gravities 
have non-zero values.    If shown, this is the approximate alcohol content for your batch.

Log Notes
This is a free-form editor where all of your notes about your batch are typed.



Hop IBU Calculator
The hop calculator will calculate the IBU value for you automatically when you provide the 
hopping information about your batch of beer.    This screen allows you to enter up to four 
"hop addition" lines to determine the bitterness factor for your brew.
Each line represents one occurrence of hops being added to your wort:

Qty (oz)
The quantity in ounces of hops added to your brew at one time.

Hop Name
The type of hops used.    Selecting the icon next to this field will allow you to select a name 
from the current list of hop types or you may key in another hops type not on the list.

Hop AAU
The Alpha acid units for the hop used.    This information should be provided with the hops 
when you purchase them!

Minutes in boil
The number of minutes that the specified quantity of hops was boiled.    This affects how 
much of the bittering of the hops went into your beer.

Selecting the OK button from this screen will then calculate the IBU value and populate the 
Hop IBUs field in the log entry screen.



Exchanging recipes
SUDS provides a means to exchange your recipes with both SUDS users and non-SUDS 
users.

To provide recipes to non-SUDS users, open the desired recipe(s) windows and select the 
Save to File option from the File menu.    This will allow you to enter a filename into which the
recipe will be copied.    This file is a plain ASCII file and can be uploaded, printed or given to 
any brewer.

To provide recipes to other SUDS users, select the Export to SXF file option from the Options 
menu.    This will save all of your recipes into an SXF file that other SUDS users can Import 
into their database by using the Import from SXF option.    The advantage of this format is 
that it also carries all gravity and quantity information about your recipes as well as text.

Note - SUDS file structure and SXF files are exactly the same with both the MS-DOS and MS-
Windows releases.    Therefore you can easily run either version of the program against the 
same set of files and both DOS and Windows users can freely exchange recipes.


