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Using PrintIt!
If you develop software under Windows or perform other tasks that use text files you have 
probably been frustrated by the support for viewing and printing such files.    PrintIt! provides a 
multiple window file viewer and can print text files in a variety of formats.

Using PrintIt! as a file viewer, you can view several files at once or minimize a file window to an 
icon.    PrintIt! displays minimized file icons on a desktop.    You may select different display 
fonts for each open window using the Display Font option under the Format menu; see Format 
Menu Commands for more information.

You may also open files using the drag and drop paradigm;    see Using Drag and Drop with 
PrintIt! for more information.

You can use PrintIt! to print text files on any printer supported by Windows.    PrintIt! can print 
files in several different modes using the concept of logical pages.    A logical page contains the 
equivalent of a printed page of text.    By using different scaling factors, PrintIt! can print several 
logical pages on a physical page.    PrintIt! supports three different modes of printing:

1:1 - maps one logical page to a physical page
2:1 - maps two logical pages to a physical page
4:1 - maps four logical pages to a physical page

You can select different print modes using the Page Setup command under the Format menu; 
see Format Menu Commands for more information.

You can also use the Page Setup command to select PrintIt! print options.    PrintIt! has options 
to print page headers and line numbers.    Page headers include the name of the file being 
printed.      PrintIt! prints line numbers at the beginning of each logical line.



File Menu Commands
Use the File Menu to:

- Open a file
- Select printer setup
- Print a file
- View statistics
- Set preferences
- Exit from PrintIt!

You can open a file by selecting the Open command from the File Menu.    PrintIt! displays a 
dialog prompting you to select a file for display.    You can type the full path name of the file you 
wish to display or select a file using the mouse.    PrintIt! can display files of any size within the 
limits of available memory.

Selecting Print Setup displays a dialog that allows you to select which printer PrintIt! should use
when printing.    You can also use the dialog to set printer configuration options such as page 
orientation and paper tray selection.    PrintIt! remembers the last page orientation you selected 
for use the next time you use PrintIt!

Use the Print command to tell PrintIt! to print the current display window.    PrintIt! displays a 
dialog showing the destination printer selection.    You can also control the printer configuration 
by pressing the Setup button in the dialog.

PrintIt! displays a dialog box showing the progress of printing the current display window.    You 
can stop the printing operation by clicking on the cancel button.    PrintIt! will stop printing the 
current file and cancel any remaining print operations resulting from dropped files; see Using 
Drag and Drop with PrintIt! for information on aborting drag and drop initiated print operations.

Selecting Exit causes PrintIt! to terminate.

PrintIt! will always select the printer considered by Windows as the default printer.    Use the 
Windows Control Panel to change the default printer.    

PrintIt! remembers the printer configuration options you select until you Exit from the 
application.    PrintIt! saves the current page orientation when you Exit and will use this setting 
the next time you use PrintIt!

Use the Statistics command to determine information about how PrintIt! will print the current 
display window.    When you select the Statistics command, PrintIt! will display the number of 
physical pages needed to print the display window, the number of characters per print line, and 
the number of print lines per logical page.    PrintIt! updates this information when you change 



configuration options.

You can set certain characteristics that determine PrintIt! behavior by using the Preferences 
command.    Selecting this command causes PrintIt! to display a dialog box that allows you to 
select:

The order PrintIt! prints logical pages in four page mode.    Select the vertical radio button 
to command PrintIt! to print successive pages in column mode (down the page).    Select 
the horizontal radio button to have PrintIt! print successive pages in rows (across the 
page.)

Processing of form feed characters contained in the file.    Check the Process Form Feed 
check box if you want PrintIt! to honor form feed characters.    PrintIt! will skip to the top of
the next logical page if it finds a form feed and you have checked this option.    PrintIt! will 
skip one page regardless of the number of form feeds found in a single line.

Printing of boxed headers.    Check the Boxed Headers check box if you want PrintIt! to 
draw a gray filled box around page headers.



Format Menu Commands
Use the Format Menu to:

- Change the display font
- Select page printing options

You can change the font PrintIt! uses to display the current window by selecting the Font 
command.    PrintIt! remembers the font you select for each window.    When you use the Font 
command, PrintIt! changes it's display font for the top-most (current) window.

Use the Page Setup command to configure printing options:
- Setting page margins
- Selecting logical page mapping
- Setting the size of a tab
- Selecting page headers and line numbers

You may set independent margins for the left, right, top and bottom print margins.    Each margin
value represents the physical space in inches PrintIt! will leave between the edges of the page 
and the printed area.    PrintIt! will adjust the margin values if it finds a margin value smaller than
the printer supports.    If you specify margins of 0.0 inches, PrintIt! will set all margin values to 
the minimum possible when it prints a file.    Typical printers require a minimum margin of 0.25 
inches for all margins.

Select one of the three radio buttons in the Select Print Mode group to the logical page 
mapping.    PrintIt! provides buttons for printing one, two or four logical pages on a physical 
page.

Use the Tab Size edit box to set the size in character positions of a tab.    PrintIt! will use this 
value both for the display window and when it prints a file.

Select the Page Headers or Line Numbers check boxes to control whether PrintIt! prints headers
and line numbers.



Window Menu Command
Use the Window menu to:

- Control window display
- Arrange icons on the desktop
- Close all open windows

You can control the display of open windows.    Selecting Tile from the Window Menu causes 
PrintIt! to tile all open windows.    The cascade option causes PrintIt! to overlap each open 
window so that the title bar of each window is visible.

Use the Arrange Icons command to organize iconified windows.    PrintIt! will arrange all icons 
neatly on the desktop.

Selecting the Close All command causes PrintIt! to close all windows whether open or iconified.



Viewing Files with PrintIt!
You can use PrintIt! to view text files.    PrintIt! displays each text file you open using the File | 
Open... command (see File Menu Commands) in a new window.    The amount of available 
memory determines how many files you can have open at the same time.

You can scroll through a text display window using the window scroll bars or using the 
following keys:

HOME - View the start of the file
END - View the end of the file
PAGE UP - Scroll the display back
PAGE DOWN - Scroll the display forward

Clicking on the scroll bar arrows or using the PAGE keys causes PrintIt! to scroll through the 
file by the number of lines that fit within the current window size.



Printer Drivers and PrintIt!
PrintIt! uses Windows GDI commands and TrueType fonts to print files.    Some Printer drivers 
have obscure defects that show up in particular print modes.    For example, one printer driver 
incorrectly printed one physical page on two sheets of paper.    The driver printed part of the 
bottom header on the second sheet!

If you encounter one of these defects be sure to obtain the latest printer driver for your 
particular printer.    Printer drivers can be downloaded from CompuServe, several Internet 
archives or obtained directly from Microsoft.

PrintIt! uses the Courier New TrueType font since this is distributed by Microsoft as part of 
Windows and so is guaranteed to be on your system.    If you have chosen to delete Courier 
New, perhaps because you use Adobe Type Manager, Windows will map Courier New to the 
nearest available printer font.    Font mapping may result in pages appearing differently than 
desired.    For best results, insure the Courier New font is installed on your system.



Reporting Defects
If you encounter a defect when using PrintIt!, we want to hear about it!    Unlike other developers
of software, we don't call problems with our products 'bugs' or 'features'.    If the application fails
to perform as we document, there is a defect in the application and we want to remove it!

If you encounter problems using PrintIt! that you can't resolve by using the latest printer driver 
(see Printer Drivers and PrintIt!  )   please send us the following information:

- Version of Windows you are using
- The printer you are using
- Date, time and size of your printer driver (see below)
- A sample of the defective print-out
- Description of the circumstances under which the defect occurs (see below)

If you don't know the name of your printer driver, please send us a detailed directory listing of 
all the driver files (.DRV extension) in your WINDOWS and WINDOWS\SYSTEM directories, we'll 
do the rest.    We need the time stamp and file size of all the driver files to determine version 
information that may help us resolve the problem.

If you encounter a defect in a particular print mode (logical page mapping, page orientation, 
margin setting, etc.), try experimenting with other settings.    Is the output still defective ?    
Defects due to the printer drivers usually show with a particular set of configuration parameters.
Report these problems to Microsoft and your printer vendor since most likely the problem lies 
with the printer driver.    We still want to know about these problems so we can document the 
configuration or find a programmatic work around the problem. 

If you have access to CompuServe, USENET or system with similar e-mail, you can address 
queries regarding PrintIt! to printit-info@solaris.com.



Registering your copy of PrintIt!
PrintIt! is shareware.    You may freely copy PrintIt!, upload it to bulletin board, Internet file 
archives, etc., providing you include all the files listed in the MANIFEST file that accompanies the
application and other files.    You may evaluate PrintIt! for 30 days.    At the end of the evaluation 
period, you must either register your copy of PrintIt! (see below) or stop using the application. 

Remember that the future of shareware and a continued supply of quality software depends on 
you honoring the shareware principles!

You can register your copy of PrintIt! by completing the registration form provided in the file 
REGISTER contained in the archive file that comprises the PrintIt! distribution.    The registration
fee is $20 US.    The registered version of PrintIt! allows you to by-pass the initial display of the 
About... dialog.    

Registered users will receive the latest copy of PrintIt! and can obtain free technical support via 
electronic mail or letter for 1 year.

Please remit funds in US. dollars drawn on a US. bank.    If you are outside the US. and Canada, 
you may find it convenient to obtain an American Express US. money order.    You can usually 
obtain these money orders from American Express travel agencies or other accredited 
suppliers.    We regret that we cannot accept payment via credit cards.



Warranty Disclaimer and License

Warranty Disclaimer
SOLARIS TECHNOLOGIES DISCLAIMS ALL WARRANTIES RELATING TO THIS SOFTWARE, 
WHETHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO ANY IMPLIED 
WARRANTIES OF MECHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE, AND ANY 
AND ALL SUCH WARRANTIES ARE EXPRESSLY AND SPECIFICALLY DISCLAIMED.    NEITHER 
SOLARIS TECHNOLOGIES, NOR ANYONE ELSE WHO HAS BEEN INVOLVED IN THE 
PRODUCTION, OR DELIVERY OF THIS SOFTWARE SHALL BE LIABLE FOR ANY INDIRECT, 
CONSEQUENTIAL, OR INCIDENTAL DAMAGES ARISING OUT OF THE USE OF THIS SOFTWARE 
EVEN IF SOLARIS TECHNOLOGIES HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH 
DAMAGES OR CLAIMS.    IN NO EVENT SHALL SOLARIS TECHNOLGIES LIABILITY FOR ANY 
DAMAGES EVER EXCEED THE PRICE PAID FOR THE LICENSE TO USE THE SOFTWARE, 
REGARDLESS OF THE FORM OF THE CLAIM.    THE PERSON USING THE SOFTWARE BEARS 
ALL RISKS AS TO THE QUALITY AND PERFORMANCE OF THE SOFTWARE.

Some states do not allow the exclusion of the limit of liability for consequential or 
incidental damages, so the above limitation may not apply to you.

This agreement shall be governed by the laws of the State of California and shall inure to 
the benefit of Solaris Technologies and any successors administrators, heirs and assigns.    Any
action or proceeding brought by either party against the other arising out of or related to this 
agreement shall be brought only in a STATE or FEDERAL COURT of competent jurisdiction 
located in Santa Clara County, California.    The parties hereby consent in personam jurisdiction 
of said courts.

LICENSE
This software and disks on which it is contained is licensed to you, for your own use.    This is 
copyright software.    You are not obtaining title to the software or any copyright rights.    You 
may not sub-license, lease, convey, modify, or translate, convert to another programming 
language, decompile, disassemble or otherwise reverse engineer this software for any purpose.

You may make as many copies of this software as you need for back-up purposes.    You 
may use the software on more than one computer, provided there is no chance it will be used 
simultaneously on more than one computer.    If you need to use the software on more than one 
computer simultaneously, please contact us for information about site licenses.



Using Drag and Drop with PrintIt!
PrintIt! V2.1 and beyond supports the Windows Drag and Drop paradigm.    You may select files 
using the Microsoft File Manager or similar application and drag them onto PrintIt! either as an 
icon or as a window.

The result of dragging and dropping files on PrintIt! depends on whether PrintIt! is iconified or 
an open window.    

Dropping files on an iconified PrintIt! causes PrintIt! to open each dropped file and print it using 
the current defaults.    PrintIt! will print the dropped files with no interaction on your part.    While 
printing the files you dropped, PrintIt! will display the print status dialog showing printing 
progress.    You may abort the printing of the current file and stop printing of all other dropped 
files by pushing the cancel button displayed in the Print Status dialog box.

Dropping files on an open PrintIt! window causes PrintIt! to open each dropped file and display 
it in a window.    You may view or print the file using PrintIt! command menus.



Changes from PrintIt! V1.2
PrintIt! V2.1 represents a considerable functional and performance improvement over PrintIt! 
V1.2.    Brief summary of changes:

- Printing is approximately 3 times faster
- Page orientation is remembered as a default across runs of PrintIt!
- Enhanced headers display the timestamp of the file being printed
- Statistics command to determine printing parameters
- Support for the Windows Drag and Drop paradigm
- Support for command line arguments
- Form Feed processing
- Support for aborting printing
- Ability to control page placement in 4 page mode

We hope that you find these enhancements useful!    If you have any additional features you 
would like to see in future releases of PrintIt!, please let us know!!




