
Application Notes
_____________________________________________________________________________________________________________________

This file contains information devoted to helping you use HiJaak PRO with your software.  For information
on using Object Linking and Embedding (OLE), drag-drop, HiJaak import filters and TWAIN, see the 
HiJaak PRO User's Guide.  To print this file, pull down the File menu and select Print.  You will find 
information on the following topics:

Generating Output for Faxing
This section gives the procedure necessary to set up printers in your Windows environment to print to file.  
HiJaak PRO requires this set up in order to produce faxable documents from any of your applications.

PageMaker® 4.0 Application Note
This section provides instructions for using HiJaak PRO with PageMaker 4.0.  In addition to explaining 
how to place files in formats not supported by PageMaker 4.0 and explaining how to create faxable files 
from  PageMaker documents, it offers tips for achieving the best possible graphics output from PageMaker 
4.0. 

WordPerfect® 5.1 Application Note
This section provides instructions for using HiJaak PRO with WordPerfect 5.1 for DOS.  In addition to 
explaining how to place files in formats not supported by WordPerfect 5.1 and explaining how to create 
faxable files from WordPerfect documents, it offers tips for achieving the best possible graphics output 
from WordPerfect. 

WordPerfect® 5.1 and 5.2 for Windows Application Note
This section provides instructions for using HiJaak PRO with WordPerfect for Windows.  In addition to 
explaining how to place files in formats not supported by WordPerfect for Windows, how to use OLE in 
WordPerfect 5.2 for Windows, and explaining how to create faxable files from WordPerfect documents, it 
offers tips for achieving the best possible graphics output from WordPerfect. 

Word for Windows™ 2.0 Application Note
This section provides instructions on using HiJaak PRO with Word for Windows 2.0.  In addition to 
explaining how to place files in formats not supported by Word for Windows, how to use OLE, and how to 
produce faxable files from Word documents, it offers tips for achieving the best possible graphics output 
from Word for Windows.

 



Generating Output for Faxing
Using HiJaak PRO, you can generate faxable output from any of your applications in Windows 3.1 by 
using those application's print to disk capabilities.
Windows allows you to set up any printer for all the software applications that run under Windows.  To set 
up a print-to-file option in Windows where the output will be a HP LaserJet Series II Printer Control 
Language file, do the following:
 
To Set Up to Print to File

1.  Double-click on the Windows Control Panel icon.  The Control Panel pops up.
2.  Double-click on the Printers icon.  You will see the Printers dialog box.
3.  From the Printers dialog box, select <Add>>>.   You will see the Printers list box.  
4.  Scroll through the list and click on HP LaserJet Series II.  
5.  Click on <Install>.  You will see the Install Driver dialog box. Windows will prompt you to insert 

the proper Windows setup disk in Drive A.  Insert the disk with the HPPCL driver on it. Click on 
<OK>.

6.  Click on <Connect>.  You will see the Connect dialog box.  From the Ports list box, select File.   
Click on <OK>.

7.  You will return to the Printers dialog box.  Select <Setup>.
8.  You will see the Setup dialog box.  From the Graphics Resolution field, select 300 dots per inch.  

Accept all the other defaults and click on <OK>.
9.  Click on <Close> to exit the Printers dialog box.

10.  Close the Control Panel.  

11.  Run your application.

Any Windows application will now print to file in LaserJet language when you select the HP LaserJet 
printer on FILE from your application's Printer Setup Options.  HiJaak PRO needs the file in LaserJet 
II language in order to convert it to fax format.

To Create a Fax from Your Document:
1.  Start up the application that created the document you want to fax.  Select HP LaserJet Series II 

from the printer setup.  Open the document.
2.  Print the document to disk naming it with a PCL extension.  Be sure that HP LaserJet Series II on 

FILE is selected when you print to disk.  Exit the application.
3.  Run HiJaak PRO.
4.  Using the Convert command in the File menu, convert the PCL print file to your FAX format.  In 

order to select the correct extension for your fax device, select Fax Type from the List Files of Type 
box in the Convert To dialog box. If you have not yet configure HiJaak PRO for your fax card, you 
will see a dialog box allowing you to do so now.  Select your fax device and click on <OK>.

5.  In the Convert To dialog box, click on <OK>.  When the conversion completes, use your fax 
software to transmit the file or files that HiJaak PRO creates from your application's document.

If you need more information about how to fax your documents, see the section on your particular 
application, later in this file.  If you need more information on how to set up your printer to print to 
file, consult your Windows User's Manual.



PageMaker 4.0 Application Note
You can use HiJaak PRO with PageMaker 4.0 to do the following:

* convert files for placement in PageMaker; 
* place files that are produced by applications with limited export capabilities; 
* edit and process image files before placing them in PageMaker; 
* create screen captures to place in a PageMaker; 
* produce faxable files from your PageMaker documents.

Placing Files not Supported by PageMaker 4.0
PageMaker 4.0 supports a number of formats, such as TIF, PCX, BMP, CGM, WMF, PGL and PIC.  
However, if you want to place a file that is not in one of these formats, you can use HiJaak PRO to 
convert the file to a format that PageMaker 4.0 can read.  Follow the procedure below, or use HiJaak 
import filters to place the file.
You can also use HiJaak PRO to change the image quality of many files you would like to place into 
PageMaker 4.0.  Although each file is different, we recommend using HiJaak PRO to convert to the 
following formats before placing images into PageMaker 4.0: 

* If you are placing a color or gray raster image in PageMaker 4.0, convert to TIF .
* If you are placing a color or gray vector image, convert to WMF.
About TIFF:   To select the correct flavor of  TIFF, select TIF in the List Files of Type area of the 
Convert To or Save As dialog boxes, and then click on the Options button.  In the Flavors area, 
pull down and select PageMaker 3.0 TIF for gray files, and PageMaker 4.0 & 5.0 TIF (Windows) 
for color files. 

PCX Tip:  If, after placing into PageMaker 4.0 a PCX image converted by HiJaak PRO, you 
notice that the image is much larger than you expected or wanted, you can easily shrink the image 
in PageMaker using the following procedure:  
1.  Click on the Image.  Handles will appear on the corners and edges of the frame.
2.  Click on one of the handles and drag it in until the image is the size you want.
Note:  This process may change the aspect ratio of the image.  To keep the aspect ratio 
the same, hold down the shift key as you drag.

PageMaker 5.0 Tip:  PageMaker 5.0 supports only CMYK color TIF files.  If you need 
to import an RGB color TIFF into PageMaker 5.0, open the file in HiJaak PRO and 
convert it to TIF using the CMYK flavor of  TIF. You can then import the new CMYK 
TIF file into PageMaker 5.0.

To Place a File in a Format not Supported by PageMaker
PageMaker 4.0 does not recognize all file formats.  If you try to place an IFF file, PageMaker 4.0 gives
you the message "Do not know how to place file FILENAME.IFF!"  You can use HiJaak PRO to 
convert the file into one PageMaker 4.0 can read.  The following procedure explains how to place the 
IFF file GOLDN256.IFF into a PageMaker 4.0 document by using HiJaak PRO to convert it to PCX.

  

1.  Start up HiJaak PRO.  Open GOLDN256.IFF, located in the HJPRO directory.  This image is a 
color raster file, so, for the best results, convert it to a TIF format for placement in PageMaker.

2.  If you would like to perform any image processing options, do so now.
3.  Click on File; select Save As....  You will see the Save As... dialog box. 
4.  From the List Files of Type list box, select TIFF (*.TIF).  "GOLDN256.TIF" appears in the File 

Name field. Click on <OK>.  HiJaak PRO converts GOLDN256.IFF to GOLDN256.TIF.  To view 
the image before placing it into PageMaker 4.0, open the file GOLDN256.TIF. 



5.  Exit HiJaak PRO. 
6.  Run PageMaker 4.0.  Open the document in which you would like to place the image.
7.  From the File menu, select Place.  You will see the Place File dialog box.  Select GOLDN256.TIF 

from the Files/Directories list box.  Click on <OK>.
8.  The mouse pointer turns into an icon representing the graphics file.  Move to the place in the 

document where you want to place the file.  Click on the mouse button once.  GOLDN256.TIF 
appears in the document .

Note:  To skip the initial viewing step, select Convert from the File menu once you open 
HiJaak PRO.

Placing a File Created by an Application with Limited Export Capabilities
Suppose you want to import an image to PageMaker 4.0 from an application that does not support any 
of the formats that PageMaker 4.0 can import directly.  Chances are HiJaak PRO can help.  Your 
application can probably export to one of the formats that HiJaak PRO supports.  If this is the case, you
can use HiJaak PRO to convert the file to one of the recommended formats using the procedures 
above.
But suppose you want to place a file stored in a format not supported by HiJaak PRO or PageMaker.  
Even the most limited applications can usually print to disk in HP LaserJet II format.  If, for example, 
you are using PageMaker 4.0 to prepare a book on music theory, you may want to import files from 
Music Printer Plus.  Even though these two applications do not support a common format, you can 
perform the following procedure to place the file:
1.  Open Music Printer Plus and open or create the image you want to place in PageMaker 4.0.
2.  Use Music Printer Plus to print to disk in HP LaserJet Series II format.  When you print to disk in 

this PCL format, you will lose any color information in the file.
3.  Exit Music Printer Plus.
4.  Open HiJaak PRO.  Convert the PCL print file to the format best suited to PageMaker, in this case,  

PCX.
5.  Exit HiJaak PRO and place the converted file into your PageMaker 4.0 document.

Image Processing 
In addition to the above mentioned extra image support, HiJaak PRO provides PageMaker 4.0 users 
with control over image processing characteristics, such as brightness, grayscale, color changes, 
rotation, etc., that are not supported by PageMaker 4.0.
For more information on image processing options, see your HiJaak PRO User's Guide or the on-line 
help facility.

Screen Captures
We suggest that you convert HiJaak PRO captured objects, areas, windows, and screens to the 
recommended formats listed above unless you plan to print your PageMaker 4.0 document on a 
Postscript printer. In this case,  always convert screen captures to EPS format.  By selecting from the 
"Embedded View" options in the EPS Options dialog box, HiJaak PRO creates a viewable black and 
white or color TIFF header in the EPS file.

Tip:  For improved output on a black and white PostScript printer, set these Color options:
*Reduce Colors/Number of Colors: Same
*Force to Gray



Using HiJaak PRO to Produce Faxable PageMaker 4.0 
Documents

The following technique prints PageMaker 4.0 documents to disk in HP LaserJet II format and then 
converts the print file to your FAX format using HiJaak PRO.  Using this technique, your faxed 
PageMaker 4.0 documents will arrive looking remarkably like LaserJet printed documents. For more 
information on setting up your Windows 3.1 environment to do this, see the section Generating Output 
for Faxing above, or consult your Microsoft Windows User's Guide.

 

To Create a Fax from your PageMaker Document:
1.  Make sure that HP LaserJet Series II on file is your selected Windows default printer.  
2.  Start up PageMaker 4.0.
3.  From the File menu, select Target Printer.  You will see the Target printer dialog box.
4.  From the Printers list box, double-click on HP LaserJet Series II on File.  You will see a Set up 

dialog box.  Make sure resolution is set to 300 dots per inch.  Click on <OK>.
5.  In the Target Printer dialog box, click on <OK>.
6.  You will receive a message, "Recompose entire publication for HP LaserJet Series II on File:?"  

Click on <OK>
7.  Create the document you want to Fax.

Note:  You must create the document with the HP LaserJet Series II as the target printer.  
If the document is created with another printer as the target (Postscript, for example), you
will have to recompose the document for HP LaserJet Series II on File.  Answering "Yes" 
will reformat the document and may cause unexpected font and formatting changes.

8.  From the File menu, select Print.  You will see the Print dialog box.  Select HP LaserJet Series II 
on FILE from the Printer field.  Set your printer options and click on  <OK>.

9.  You will now see the Print To File dialog box.  In the Output File Name field, Type in   
your path to HiJaak PRO and your file name with a PCL extension.  For      
example, if your version of  HiJaak PRO is installed on the C: drive, type      C:\
HJPRO\Filename.PCL  Click on <OK>.

10.  Exit PageMaker.
11.  Run HiJaak PRO.
12.  From the File menu, select Convert.  You will see the Convert From... dialog box.
13.  In the File Name field, type Filename.PCL.  Click on <OK>.
14.  You will see the ...Convert To dialog box.  Your document's name will appear in the File Name field 

with a new extension.  In order to select the correct extension for your fax device, select Fax Type 
from the List Files of Type box. 

15.  When the conversion completes, you can use your fax software to transmit the file or files that 
HiJaak PRO creates from your PageMaker 4.0 document.



WordPerfect 5.1 for DOS Application Note
You can use HiJaak PRO with WordPerfect 5.1 to do the following:

* convert files for placement into  WordPerfect 5.1;
* place files that are produced by applications with limited export capabilities;  
* edit and process image files before placing them in WordPerfect; 
* create screen captures to place in WordPerfect;
* produce faxable files from your WordPerfect documents.

Placing Files Not Supported by WordPerfect 5.1
WordPerfect 5.1 supports a number of formats, such as HPGL, IMG, TIF, PCX, MSP, CGM, WPG, 
PIC, EPS, GEM, and DXF.  However, if you want to bring in a file that is not in one of these formats, 
you can use HiJaak PRO to convert the file into a format WordPerfect can read.  Follow the procedure 
below, to place the file.
You can also use HiJaak PRO to change the image quality of many files you would like to place in 
WordPerfect 5.1.  Although each file is different, we recommend using HiJaak PRO to convert to the 
following formats before placing images into WordPerfect 5.1:

* If you are bringing in a color raster image, convert to WPG.
* If you are bringing in a gray raster image, convert to TIF.
* If you are bringing in a color or gray vector image, convert to WPG.

Tip for TIF:  If you wish to create a 256 color TIF file to be brought into WordPerfect, choose the
WordPerfect Mac flavor of TIF from HiJaak PRO's Flavors menu in the Options dialog box when 
converting or saving the file.  Choosing the WordPerfect PC selection will result in a 16 color TIF. 
Choosing TIF as a destination for a HiJaak PRO conversion of a 256 color raster graphics file and 
using the halftone option gives the best printouts.

Tip for Multiple Graphics Files in One Document:  If you are using many graphics files in one 
WordPerfect document,  you may not want to save all the files with your WordPerfect document.  
To save each graphics file separately from the WordPerfect document:
1.  In WordPerfect 5.1, press <Alt>-F9 for the Graphics menu.
2.  Press 1 for the Figure menu.
3.  From the Figure menu, Press 2, to edit.
4.  Answer the question "Figure Number?" by typing in the number of the figure you would like to

save in a place other than the document file.  Press <Enter>.
5.  You will see the Definition: Figure menu.  Press 2 for Contents.
6.  Press 2 for Graphic on disk.  Type in the path and filename where you want to save the graphics

file.
7.  Press <Enter> to return to your document.

 
How to Place a File in a Format not Supported by WordPerfect
WordPerfect 5.1 does not recognize certain formats; IFF is one.  If you try to bring in a IFF file, 
WordPerfect 5.1 gives you the message "Error: Incorrect Format."  You can use HiJaak PRO to convert
the file into one WordPerfect 5.1 can read.  The following procedure explains how to place the IFF file 
GOLDN256.IFF into a WordPerfect 5.1 document by using HiJaak PRO to convert it to WPG format.
1.  Start up HiJaak PRO.  Open GOLDN256.IFF, located in the HJPRO directory.  This image is a 

color raster image, so for the best results, convert it to a WPG format before importing the file.
2.  If you would like to perform any image processing options, you may do so now.
3.  Click on File; select Save As....  You will see the Save As... dialog box.
4.  From the List Files of Type list box, select WordPerfect (*.WPG).  "GOLDN256.WPG" appears in 

the File Name field.  Click on <OK>.  HiJaak PRO converts the image GOLDN256.IFF to 



GOLDN256.WPG.  If you would like to view your WPG image before placing it into WordPerfect 
5.1, use HiJaak PRO to open GOLDN256.WPG. 

5.  Exit HiJaak PRO. 
6.  Run WordPerfect 5.1.  Open the document into which you would like to place GOLDN256.WPG, 

and place your cursor where you want the figure box to appear.
7.  Press <Alt>-F9.  You will see the Graphics menu.
8.  Press 1 for Figure.  You will see the Figure menu.
9.  From the Figure menu, Press 1 to Create.

10.  You will see the Definition:Figure menu.  Press 1 for Filename.  Type your HiJaak PRO path and 
GOLDN256.WPG.  Accept all other defaults.  Press <Enter>.

11.  GOLDN256.WPG appears in a figure box in the document.
Note:  To skip the initial viewing step, select Convert instead of Open from the File menu
once you open HiJaak PRO.

Tip: The WordPerfect editor can display graphics images with 256 colors and grayscaled images if
you have chosen a video driver with those capabilities.  If you have a driver available, choose 
it by following these steps:

1.  Press <Shift>-F1 to enter the Setup menu
2.  Press 2 for the Display option..  
3.  You will see the Setup:Display menu.  Press 2 to choose the Graphics Screen Type option and 

select the appropriate video driver.
4.  Press <Enter> to select.
5.  Press F7 to exit the menu.

Placing a File Created by an Application With Limited Export Capabilities
Suppose you want to import an image to WordPerfect 5.1 from an application that does not support any
of the formats that WordPerfect 5.1 can import directly.  Chances are HiJaak PRO can help.  Your 
application can probably export to one of the formats that HiJaak PRO supports.  If this is the case, you
can use HiJaak PRO to convert the file to one of the recommended formats using the procedure above.

But suppose you want to place a file stored in a format that neither HiJaak PRO or Word for Windows 
supports.  Even the most limited applications can usually print to disk in HP LaserJet II format.  You may, 
for example, have a relatively old DOS program which produces customized charts for your company. You 
can perform the following procedure to place the file:

1.  Open the application and read in or create the image you want to import to WordPerfect 5.1.
2.  Use your application to print to disk in HP LaserJet II format.  When you print to disk in this 
PCL format, you will lose any color information in your file.
3.  Exit the application.
4.  Open HiJaak PRO.  Convert the print file to the format best suited to WordPerfect 5.1.
5.  Exit HiJaak PRO and place the converted file into your WordPerfect 5.1 document.



Image Processing
In addition to the above mentioned extra image support, HiJaak PRO provides WordPerfect 5.1 users 
with control over image processing characteristics, such as  brightness, grayscale, color changes, etc., 
that are not supported by WordPerfect 5.1.

Tip:  For improved output on a black and white printer, use HiJaak PRO Colors menu, to select 
* Reduce Colors/Number of Colors:  2 
* Reduce Colors/Reduction Method: Halftone 

For more information on image processing options, see your HiJaak PRO User's Guide or the on-line 
help facility.

Screen Captures
We suggest that you convert HiJaak PRO captured objects, areas, windows and screens to the 
recommended formats listed above, unless you plan to print your WordPerfect 5.1 document on a 
Postscript printer. In this case,  always convert screen captures to EPS format.  By selecting the 
"Embedded View" option in the EPS Options dialog box, HiJaak PRO creates a viewable black and 
white, or color TIF header in the EPS file.

Tip:  For improved output on a black and white PostScript printer, set these Color options:
*Reduce Colors/Number of Colors: Same
*Grayscale

WPG Tip:  When converting a captured text screen to WPG and using the Colors to Black option,
the output will occasionally be white text on a black background.  For a black text on a white 
background, select Reverse Black and White while performing the conversion.

Producing Faxable Files from Your WordPerfect Documents
The following technique prints WordPerfect 5.1 documents to disk in HP LaserJet II format and then 
converts the print file to your FAX format using HiJaak PRO.  Using this technique, your faxed 
documents will arrive looking remarkably like LaserJet printed documents. 
To Create a Fax from your WordPerfect Document:
1.  Start up WordPerfect 5.1 and open the document you want to fax.
2.  Press <Shift>-F7 simultaneously to enter the Printer menu.
3.  Press S to select printer.
4.  From the Select Printer screen, use the arrow keys to highlight and select HP LaserJet Series II. 
5.  From the Select Printer menu, press 3 to Edit.
6.  From the Select Printer Edit menu, press 2  to select Port.  You will see a list of possible printer 

ports.
7.  From that list, press 8 to select Other.
8.  You will be prompted for a device or filename.  Type in your path to HiJaak PRO and your filename

with a PCL extension.  For example, if your version of HiJaak PRO is installed on the C: drive, type
C:\HJPRO\Filename.PCL.

9.  Press F7 to exit each of the menus until the Printer menu.  Press 1 to print the whole document to 
the filename you specified in step 8.

10.  Exit WordPerfect 5.1.
11.  Run HiJaak PRO.
12.  From the File menu, select Convert.  You will see the Convert From... dialog box.
13.  In the File Name field, type Filename.PCL.  Click on <OK>.



14.  You will see the ...Convert To dialog box.  Your document's name will appear in the File Name field 
with a new extension.  In order to select the correct extension for your fax device, select Fax Type 
from, the List Files of Type box.  If you have not yet configured HiJaak PRO for your fax card, you 
will see the Configure Fax dialog box.  Click on your fax device and click on <OK>.

15.  In the Convert To dialog box, click on <OK>.  When the conversion completes, you can use your 
fax software to transmit the file or files that HiJaak PRO created from your WordPerfect 5.1 
document.



WordPerfect 5.1 & 5.2 for Windows Application Note
You can use HiJaak PRO with WordPerfect 5.1 for Windows to do the following:

* convert file for placement in WordPerfect for Windows;
* place files that are produced by applications with limited export capabilities;  
* edit and process images before placing them in WordPerfect for Windows; 
* create screen captures to place in a WordPerfect for Windows document;
* produce faxable files from your WordPerfect for Windows documents.

You can use HiJaak PRO with WordPerfect 5.2 for Windows to perform all of the above operations and to 
* retrieve HiJaak Images using Object Linking and Embedding (OLE);

Retrieving Files Not Supported by WordPerfect for Windows
WordPerfect for Windows supports a number of formats, such as BMP, CGM, DXF, EPS, GEM, IMG, 
MSP, PCX, PIC, PNTG, PGL, TIF, WMF and WPG.  However, if you want to retrieve a file that is not 
in one of these formats, you can use HiJaak PRO to convert the file into a format WordPerfect for 
Windows can read.  Follow the procedure below, use HiJaak PRO as an OLE server, or use the HiJaak 
Retrieve Macro, explained in the User's Guide, to retrieve the file.
You can also use HiJaak PRO to change the image quality of many files you would like to place in 
WordPerfect for Windows.  Although each file is different, we recommend using HiJaak PRO to 
convert to the following formats before placing images into WordPerfect for Windows:

*If you will be retrieving a color or gray raster image, convert to TIF.
*If you will be retrieving a color or gray vector image, convert to WPG.
Note:  HiJaak PRO supports a special flavor of WordPerfect for Windows WPG format.
Tip for Placing Multiple Graphics Files in One Document:  If you are using many graphics 
files in one WordPerfect for Windows document,  you may not want to save all the graphics files 
with your document file.  To save each graphics file separately from the WordPerfect for Windows
document:
1.  In WordPerfect for Windows, click on the graphic you would like to save separately from the 

document.
2.  From the Graphics menu, select Figure.
3.  Select Edit.
4.  You will see the Edit Figure dialog box; type the figure number you would like to edit.
5.  Your graphic will appear in the WordPerfect Figure Editor.  Click on the File menu. Select 

Graphic on Disk.
6.  Type the path and filename of your figure.  Click on <Save>.
7.  Click on the File menu; select Close to return to your document.  WordPerfect for Windows 

will save the graphic in a separate file on disk rather than saving it with the document 
(changes you make in the Figure editor are saved with the document).

  
How to Retrieve a File in a Format not Supported by WordPerfect for Windows
WordPerfect for Windows does not recognize certain formats; IFF is one.  If you try to retrieve an IFF 
file, WordPerfect for Windows gives you the message "! Incompatible file format."  You can use 
HiJaak PRO to convert the file into one WordPerfect can read.  The following procedure explains how 
to place the IFF file GOLDN256.IFF into a WordPerfect for Windows document by using HiJaak PRO 
to convert it to a TIF format.
1.  Start up HiJaak PRO.  Open GOLDN256.IFF, located in your HJPRO directory.  This image is a 

color raster file, so, for the best results, convert it to a TIF format before bringing it into 
WordPerfect.

2.  If you would like to use any image processing options, do so now.



3.  Click on File; select Save As....  You will see the Save As... dialog box.
4.  From the List Files of Type list box, select TIFF (*.TIF).  "GOLDN256.TIF" will appear in the File 

Name field.  Click on <OK>.  HiJaak PRO converts the image GOLDN256.IFF to GOLDN256.TIF.
If you would like to view the image before placing it into WordPerfect for Windows, open the file 
GOLDN256.TIF. 

5.  Exit HiJaak PRO. 
6.  Start up WordPerfect for Windows and open the document into which you would like to bring 

GOLDN256.TIF.  Place the cursor at your desired insertion point.
7.  From the Main menu select Graphics; select Figure; select Retrieve.
8.  You will see the Retrieve Figure dialog box.  In the Filename field, type your path to HiJaak PRO 

and the filename  GOLDN256.TIF.
9.  Click on <Retrieve>.  GOLDN256.TIF will appear in your document at your specified insertion 

point.

Using OLE to Import a File
HiJaak PRO is an OLE server.  As an OLE server, it can help you integrate images with text in a 
WordPerfect 5.2 for Windows Document.    These images are either embedded or linked in the 
document.  If the image is embedded, then a copy of the image is saved with the document file.  If the 
image is linked, then a pointer to the image is saved with the document file.  After you establish an 
OLE connection, you can edit and update the linked or embedded images in the documents.
Note:  OLE is only available in WordPerfect 5.2 for Windows.

How to Link a HiJaak Image in WordPerfect 5.2 for Windows   
1.  Open HiJaak PRO.
2.  Open ISIJET.WMF.
3.  Pull down the Edit menu and select Copy As.  You will see the Select Clipboard Format dialog box. 
4.  Select the appropriate format for your image.  For ISIJET.WMF, select Windows.WMF.  Click on 

<OK>.  Exit HiJaak PRO.
Note:  When you are saving a file to the clipboard in order to link or embed it, save 
vector files to Windows WMF file format, and raster images to Windows DIB.  For 
information on raster and vector images, see your HiJaak PRO User Guide.

5.  Open WordPerfect 5.2 for Windows.  Open the document in which you want to create the link.
6.  Place the cursor where you want the upper-left corner of the HiJaak image to display.
7.  Pull down the Edit menu and select Paste Link.  
8.  ISIJET.WMF appears in your document at the point you specified.

Tip:  If the image you link appears in the document larger than you expected or wanted, you can 
scale the image:

1.  Click on the image.  A frame with handles appears around the image.  
2.  Scale the image by clicking on a corner handle and dragging it to the size you want the image.

If you grab and drag one of the side handles, the aspect ratio will become distorted.



How to Edit Linked HiJaak Images
1.  Open the WordPerfect 5.2 for Windows document containing the linked object you want to edit.
2.  Double-click the mouse when positioned over the linked image, or select the object and pull down 

the Edit menu and select Edit HiJaak Image Object.
3.  HiJaak PRO starts up with the image appearing on its Main screen.  Perform any of the editing 

functions offered by HiJaak PRO.
4.  From the File menu, select Save.  From the File Menu, select Exit.
5.  HiJaak PRO closes, and WordPerfect 5.2 for Windows displays the updated image in your 

document.

How to Cancel a Link
You can delete the link joining HiJaak PRO and WordPerfect 5.2 for Windows without deleting the 
linked object from the WordPerfect 5.2 for Windows document.
1. From the WordPerfect 5.2 for Windows Main menu, select Edit and click on Links.  You will see the

Links dialog box.
2. In the Link Types area, click on the Show OLE Links  radio button.
3. In the Links area, click on the link that you want to delete.
4. Click on the <Cancel Link> button.  Click on <OK>.

How to Embed HiJaak Images in WordPerfect 5.2 for Windows
1.  Open the WordPerfect document into which you want to embed an object.  
2.  Place your cursor where you want the upper-left corner of the embedded      image 

to be displayed.
3.  Pull down the Edit menu and select Insert Object. You will see the Object dialog box.
4.  In the Object Type list box, click on HiJaak Image. Click on <OK>.
5.  HiJaak PRO starts up with its Open dialog box.  Select the drive and directory where you installed 

HiJaak PRO.  From the File Name list box, select GOLDN256.IFF.  Click on <OK>.
6.  From the HiJaak PRO File menu, select Update WordPerfect.
7.  From the HiJaak PRO File menu, select Exit & Return to WordPerfect.  The image will appear in 

the document at your specified insertion point.

How to Edit HiJaak PRO Embedded Objects
1.  In WordPerfect 5.2 for Windows, double-click on the object you want to edit, or select the object 

and pull down the Edit menu and select Edit HiJaak Image Object.
2.  HiJaak PRO starts up with the object appearing in its Main screen.  Perform any of the editing 

functions available in HiJaak PRO.
3.  Pull down the File menu.  Select Update WordPerfect.
4.  Pull down the File menu.  Select Exit & Return to WordPerfect. The object appears in your 

WordPerfect 5.2 for Windows document with the changes you specified in HiJaak PRO.



Placing a File Created by an Application With Limited Export Capabilities
Suppose you want to import an image into WordPerfect for Windows from an application that does not 
support any of the formats that WordPerfect for Windows can import directly.  Chances are HiJaak 
PRO can help.  Your application can probably export to one of the formats that HiJaak PRO supports.  
If this is the case, you can use HiJaak PRO to convert the file to one of the recommended formats 
using the procedure above.
But suppose you want to place a file stored in a format not supported by WordPerfect for Windows or 
HiJaak PRO.  Even the most limited applications can usually print to disk in HP LaserJet II format.  
You may, for example, have a relatively old DOS program which produces customized charts for your 
company.  You can perform the following procedure to place the file:
1.  Open the application and read in or create the image you want to import to WordPerfect for 

Windows.
2.  Use your application to print to disk in HP LaserJet II format.  When you print to disk in this PCL 

format, you will lose any color information in your file.
3.  Exit the application.
4.  Open HiJaak PRO.  Convert the PCL print file to TIF for import into WordPerfect for Windows.
5.   Exit HiJaak PRO and place the converted file into your WordPerfect for Windows document sing 

the procedure above.
Note:  You can also use the HiJaak Retrieve Macro, or OLE to place the file once you have 

printed to disk in HP LaserJet II format. 

Image Processing
In addition to the above mentioned extra image support, HiJaak PRO provides WordPerfect for 
Windows users with control over image processing characteristics, such as  brightness, grayscale, color
changes, etc., that are not supported by WordPerfect for Windows.
For more information on image processing options, see your HiJaak PRO User's Guide or the on-line 
help facility.

Screen Captures
We suggest that you convert HiJaak PRO captured objects, areas, windows, and screens to the 
recommended formats listed above unless you plan to print your WordPerfect for Windows document 
on a Postscript printer. In this case,  always convert screen captures to EPS format.  By selecting from 
the "Embedded View" options in the EPS Options dialog box, HiJaak PRO creates a viewable black 
and white, or color TIFF header in the EPS file.

Tip:  For improved output on a black and white PostScript printer, set these Color options:
*Reduce Colors/Number of Colors: Same
*Grayscale

WPG Tip:  When converting a captured text screen to WPG and using the All Colors to Black 
option, the output will occasionally be white text on a black background.  For a black text on a 
white background, select the Reverse Black and White option while performing the conversion.



Producing Faxable Files from WordPerfect for Windows Documents
The following procedure prints WordPerfect for Windows documents to disk in HP LaserJet II format 
and then converts the print file to your FAX format using HiJaak PRO.  Using this technique, your 
faxed documents will arrive looking remarkably like LaserJet printed documents.
Before proceeding, make sure you have configured a Windows printer selection for the HP LaserJet 
Series II set to print to file.  For more information, see the section Generating Output for Faxing above.
To Create a Fax from your WordPerfect for Windows Document:
1.  Start up WordPerfect for Windows and open the document you want to fax.
2.  From the File menu, select Print.  You will see the Print dialog box.
3.  From the Current Printer field, click on <Select>.  You will see the Select Printer dialog box.  
4.  Select Windows from the Printer Drivers box.
5.  From the Available Printers list box, select HP LaserJet Series II on File.  Click on <Select>.
6.  You will return to the Print dialog box; click on <Print>.
7.  You will see the Print to File pop up box.  Type in the path and filename of your document with 

PCL as the file extension.  Click on <OK>
8.  When WordPerfect is through printing, exit the application and open HiJaak PRO.
9.  From the File menu, select Convert.  You will see the Convert From... dialog box.

10. In the File Name field, type the name of the print to disk file.  Click on <OK>.
11. You will see the ...Convert To dialog box.  Your document's name will appear in the File Name field 

with a new extension.  In order to select the correct extension for your fax device, select Fax Type 
from, the List Files of Type box.  

      If you have not yet configured HiJaak PRO for your fax device, you will see the Configure Fax 
dialog box.  Select your fax device and click on <OK>.

12.   In the Convert To dialog box, click on OK.  When the conversion completes, use your fax software 
to transmit the file or files that HiJaak PRO creates from your WordPerfect for Windows document.



Word for Windows™ 2.0 Application Note
You can use HiJaak PRO with Microsoft Word for Windows  to:

* convert  files for placement in Word for Windows; 
* link and embed HiJaak PRO objects in Word for Windows;
* place files that are produced by applications with limited export capabilities; 
* edit and process image files in Word for Windows; 
* produce faxable files from Word for Windows documents.

Placing Files not Supported by Microsoft Word for Windows 
Word for Windows supports a number of formats, such as WMF, EPS, TIF, CGM, HPGL, WPG, DRW,
PCX, BMP, DXF, PLT,  and Lotus PIC.  However, if you want to place a file that is not in one of these 
formats, you can use HiJaak PRO to convert the file to a format that Microsoft Word for Windows can 
read.  Follow the procedure below, use HiJaak PRO as an Object Linking and Embedding (OLE) 
server, or use HiJaak import filters to import the file into Microsoft Word.
You can use HiJaak PRO to improve the image quality of many files you would like to import into 
Microsoft Word for Windows .  Although each file is different, we recommend using HiJaak PRO to 
convert to the following formats before placing images into Microsoft Word for Windows: 

*  If you will be importing a color or gray raster image, convert to PCX.
*  If you will be importing a color or gray vector image, convert to WMF.

WMF, TIF and PGL TIP:  Although Word for Windows supports these formats, there are times 
that files in these formats will not import into Word.  If, for any reason this occurs, then open the 
file in HiJaak PRO.  From HiJaak PRO, save it in its original format, or the format of your choice. 
Word for Windows will now import the file.

Color Tip:  Word for Windows supports 16 color display and 256 color printouts.  If you are 
importing a 256 color graphic into Word, it might not display as you expected.  It will, however, 
print as you expect.  If your 256 color displayed image is more important than the printed image, 
then use HiJaak PRO to reduce the number of colors to 16.  From HiJaak PRO Colors menu, 
select Reduce Colors.  In the Number of Colors field, select 16.  Click on the Optimize Palette 
check box.  HiJaak PRO will match the closest 16 colors to those in your 256 color image.  You 
may also link or embed the image using OLE.  See Using OLE to Import a File, later in this 
section.



Converting a File and Importing it into Word for Windows
Microsoft Word for Windows does not recognize certain file formats;  IFF is one.  If you try to place an
IFF file, Microsoft Word for Windows gives you the message "The Graphics filter was unable to 
convert this file."  You can use HiJaak PRO to convert the file into one Microsoft Word for Windows 
can read.  The following procedure explains how to place the IFF file GOLDN256.IFF into a Word for 
Windows document by using HiJaak PRO to convert it to PCX and force the color to gray so you may 
print the image on your black and white printer.
1.  Start up HiJaak PRO. 
2.  Click on the File menu.  Select Open.  You will see the Open dialog box.  Select the drive and 

directory where you installed HiJaak PRO.  In the File Name list box, double-click on 
GOLDN256.IFF to view the image before conversion.  This is a color raster file, so for the best 
results, convert it to a PCX format to import into Microsoft Word for Windows .

3.  Click on File. Select Save As....  You will see the Save As... dialog box. 
4. Click on the Applications button.  You will see the Applications dialog box.  From the list box, select

Word for Windows 2.0, Microsoft.  Click on OK.  HiJaak PRO selects PCX as the best format for a 
file being imported into Word for Windows. 

5.  Click on the Options button.  You will see the Raster Processing Options dialog box.  Click on the 
Reduce Colors button.  You will see the Reduce/Expand Colors dialog box.  Click on the Grayscale 
check box.  Click on OK twice to return to the Save As dialog box.  

6.  In the Save As dialog box, select the drive and directory on which you want to save your converted 
file.  Click on OK.  HiJaak PRO converts the image GOLDN256.IFF to GOLDN256.PCX.  If you 
would like to view the image before placing it into Microsoft Word for Windows, open the file 
GOLDN256.PCX. 

7.  Exit HiJaak PRO. 
8.  Run Microsoft Word for Windows .  Open the document in which you would like to place the 

image.
9.  Place the cursor where you want the upper-left corner of GOLDN256.PCX  to appear.

10.  Pull down the Insert menu, select Picture.  You will see the picture dialog box.
11.  Select the drive and directory where you saved GOLDN256.PCX.  In the File Name box, select 

GOLDN256.PCX.
12. Click on <OK>.  GOLDN256.PCX will appear in your document at the point you specified.

Note: To skip the initial viewing step, select Convert from the File menu when you open 
HiJaak PRO.



Using OLE to Import a File
HiJaak PRO is an OLE server.  As an OLE server, it can help you integrate images with text in a Word 
for Windows Document.    These images are either embedded or linked in the document.  If the image 
is embedded, then a copy of the image is saved with the document file.  If the image is linked, then a 
pointer to the image is saved with the document file.  After you establish an OLE connection, you can 
edit and update the linked and embedded images in the documents.

How to Link a HiJaak Image in Word   
1.  Open HiJaak PRO.
2.  Open ISIJET.WMF.
3.  Pull down the Edit menu and select Copy As.  You will see the Select Clipboard Format dialog box. 
4.  Select the appropriate format for your image.  For ISIJET.WMF, select Windows.WMF.  Click on 

<OK>.  Exit HiJaak PRO.
Note:  When you are saving a file to the clipboard in order to link or embed it, save 
vector files to Windows WMF file format, and raster images to Windows DIB.  For 
information on raster and vector images, see your HiJaak PRO User Guide.

5.  Open Microsoft Word for Windows.  Open the document in which you want to create the link.
6.  Place the cursor where you want the upper-left hand corner of the HiJaak image to display.
7.  Pull down the Edit menu and select Paste Special.  You will see the Paste Special dialog box.
8.  From the Data Type box, select Picture.  Select <Paste Link>.  ISIJET.WMF will appear in your 

document at the point you specified.

Tip:  If the image you link appears in the document larger than you expected or wanted, you can 
scale the image.

1.  Click on the image.  A frame with handles appears around the image.  
2.  Scale the image by clicking on a corner handle and dragging it to the size you want the image.

If you grab and drag one of the side handles, the aspect ratio will become distorted.

How to Edit Linked HiJaak Images
1.  Open the Word for Windows document containing the linked object you want to edit.
2.  Double-click the mouse when positioned over the linked image.
3.  HiJaak PRO starts up with the image appearing on its Main screen.  Perform any of the editing 

functions offered by HiJaak PRO.
4.  From the File menu, select Save.  From the File Menu, select Exit.
5.  HiJaak PRO closes, and Word displays the updated image in your document.



How to Embed HiJaak Images in Word
1.  Open the Word document in which you want to embed an object.  
2.  Place your cursor where you want the upper-left hand corner of the embedded      

information to be displayed.
3.  From the Insert menu, select Object.  You will see the Object dialog box.
4.  In the Object Type list box, click on HiJaak Image. Click on <OK>.
5.  HiJaak PRO starts up with its Open dialog box.  Select the drive and directory where you installed 

HiJaak PRO.  From the File Name list box, select GOLDN256.IFF.  Click on <OK>
6.  From the HiJaak PRO File menu, select Update Microsoft Word.
7.  From the HiJaak PRO File menu, select Exit & Return to Microsoft Word.  The image will appear in

the document at your specified insertion point.

How to Edit Embedded HiJaak Images
1.  In Word, double-click on the object you want to edit.  
2.  HiJaak PRO starts up with the object appearing in its Main screen.  Perform any of the editing 

functions available in HiJaak PRO.
3.  Pull down the File menu.  Select Update Microsoft Word.
4.  Pull down the File menu.  Select Exit & Return to Microsoft Word. The object appears in your Word

document with the changes you specified in HiJaak PRO.

Placing a File Created by an Application with Limited Export Capabilities
Suppose you want to import an image to Word for Windows  from an application that does not support 
any of the formats that Word for Windows can import directly. Chances are HiJaak PRO can help.  
Your application can probably export to one of the formats that HiJaak PRO supports.  If this is the 
case, you can use HiJaak PRO to convert the file to one of the recommended formats using the 
procedures above.
But suppose you want to place a file that is in a format not supported by HiJaak PRO or Word for 
Windows.  Even the most limited applications can usually print to disk in the HP LaserJet II format.  
You may, for example, have a relatively old DOS program which produces customized charts for your 
company. You can perform the following procedure to place the file:
1.  Open your application and read in or create the image you want to import into Word for Windows.
2.   Use your application to print to disk in HP LaserJet Series II format.  When you print to disk in this

PCL format, you will lose any color information in your file.
3.   Exit the application.
4.  Open HiJaak PRO.  Convert the print file to the format best suited to Word for Windows.
5.  Exit HiJaak PRO and place the converted file into your Word for Windows document.

Image Processing 
In addition to the above mentioned extra image support, HiJaak PRO provides Microsoft Word for 
Windows users control over image characteristics, such as brightness, grayscale, color changes, etc., 
that are not supported by Microsoft Word for Windows.



Using HiJaak PRO to Produce Faxable Files from Microsoft Word for 
Windows Documents

The following technique prints Microsoft Word for Windows  documents to disk in HP LaserJet II 
format, and then converts the print file to your FAX format using HiJaak PRO.  Using this technique, 
your faxed Microsoft Word for Windows  documents will arrive looking remarkably like LaserJet 
printed documents.  For more information on setting up your Windows 3.1 environment to do this, see 
Generating Output for Faxing above, or consult your Microsoft Windows User's Guide.

   

To Create a Fax from Your Word for Windows Document:
1.  Make sure that HP LaserJet Series II is your selected Windows printer.  
2.  Start up Microsoft Word for Windows  and open the document you would like to fax.
3.  From the File menu, select Print Setup.  You will see the Print Setup dialog box.
4.  From the Printer list box, double-click on HP LaserJet Series II on FILE.  This selects the printer 

and closes out of the Print Setup dialog box.
5.  From the File menu, select Print.  You will see the Print dialog box.  Make sure HP LaserJet Series

II on FILE is the selected printer in the Printer field.  Set your printer options and click on <OK>.
6.  You will now see the Print To File dialog box.  In the Output File Name field, Type the path and 

desired filename with a PCL extension.  
7.  Exit Word.
8.  Run HiJaak PRO.
9.  From the File menu, select Convert.  You will see the Convert from... dialog box.

10.  In the File Name field, type Filename.PCL.  Click on <OK>.
11.  You will see the ...Convert  To dialog box.  Your document's name will appear in the                 

File Name field with a new extension.  In order to select the correct extension for your fax device, 
select Fax Type from the List Files of Type box. 

      If you have not yet configured HiJaak PRO for your fax device, you will see the Configure Fax 
dialog box.  Select your fax device and click on <OK>.

12.  When the conversion completes, you can use your fax software to transmit the file or files that 
HiJaak PRO creates from your Microsoft Word for Windows document.


