
Welcome to the WIRL VR Browser.

Welcome

WIRL Fundamentals

WIRL's Two Modes 

Mouse Controls

The Zoom Buttons 

The WIRL Control Panel 

Authoring Capabilities 

Advanced Features 

System Requirements 

Supported File Formats 

VRML Support 

Adding VREAM Extensions to VRML Worlds

Adding a Virtual World to a Web Page

Contacting VREAM



Welcome to WIRL

Welcome to WIRL!

WIRL Interactive VR Browser

A Plug-in for Netscape Navigator 2.0

from 
VREAM, Inc. 

Welcome to the WIRL Interactive VR Browser, the world's first true virtual reality browser for the Web.
WIRL brings you the future of virtual reality on the Web NOW!    Immerse yourself and enjoy!

What makes WIRL so special?

For starters, WIRL works as a plug-in for Netscape Navigator.    This means you can experience 
WIRL's interactive virtual reality seamlessly within your Netscape window.

That is great! What else is special about WIRL?

WIRL's most noteworthy feature is that it takes VR on the Web to a new level. It does this by enabling 
object behaviors and logical cause and effect relationships. WIRL allows standard VRML files to 
be enhanced with object dynamics, motion, sound, animations, interactivity and logic. As a result, 
WIRL brings static VRML files to life!

How does WIRL do this?

WIRL was developed using VREAM's virtual reality technology. Therefore, WIRL can read 
VREAMScript virtual reality world files (file extension .VRW), as well as standard 3D VRML files (file 
extension .WRL). In addition, the WIRL Browser allows standard 3D VRML Files to be given true virtual
reality capabilities by creating a Virtual Reality Extensions file (file extension .VRE) that contains 
VREAM's scripting language commands.

Fantastic! This is really cool stuff. Can I be expecting even more capabilities within WIRL in the future?

Yes. Keep watching to find out about the latest updates to WIRL, including support for Java, Multiple 
Users, and additional hardware platforms.

Wow. The applications of this technology seem limitless.

The VR technology available within WIRL, opens up endless possibilities for applications in a wide 
variety of areas-- including architecture, business, education, entertainment, finance, medicine, online 
commerce, network visualization, among others. At VREAM, we believe the applications are infinite, 
limited only by the imagination.



And the best news of all is that this is only the beginning.

The Web will truly never be the same again! Enjoy.



WIRL Fundamentals

Before you get started with WIRL, we strongly recommend that you read through the following help 
topics.

Viewer Navigation Mode and Object Manipulation Mode
Using the Mouse in Viewer Navigation Mode
Using the Mouse in Object Manipulation Mode
The Zoom Buttons
The Control Panel
Authoring Capabilities



Viewer Navigation Mode and Object Manipulation Mode

WIRL's Control Panel

As you look at WIRL and the WIRL Control Panel for the first time, the most important thing to understand
is that WIRL provides two modes in which you can experience virtual worlds: Viewer Navigation mode 
and Object Manipulation mode. At any given time, you are either in Viewer Navigation mode or in Object
Manipulation mode.

The Viewer Navigation mode may be selected by clicking the Left Mouse Button within 
the WIRL Control Panel on the Viewer Navigation Button (contains an image of a person 
running).

The Object Manipulation mode may be selected by clicking the Left Mouse Button within
the WIRL Control Panel on the Object Manipulation Button (contains an image of a hand).

Within each mode, the user may interact with the world by Using the Mouse Buttons directly within 
the virtual world area or by clicking the Left Mouse Button within the WIRL Control Panel on the Zoom 
Buttons (three buttons with arrows).

In either mode, you also can use some of the other features of WIRL that are enabled by the Buttons 
on the WIRL Control Panel. 

WIRL's Control Panel

And, last but by no means least, in either of the two modes if you want to enhance a virtual world "on-
the-fly", you can click the Right Mouse Button and take advantage of WIRL's Authoring Capabilities.   
With this facility, you can modify a virtual world that you encounter on the Web to suit your own needs.  
For example, you can modify a texture or change the behavior of an object within a virtual world.

WIRL's Authoring Menu



The various ways to interact with the virtual worlds, the WIRL control panel, and the authoring features 
of WIRL are discussed in more detail in this help file.



Using the Mouse Buttons in Viewer Navigation Mode

While in Viewer Navigation Mode, you can navigate through a virtual world by clicking and dragging the
Left Mouse Button within the virtual world screen area. You can also jump to a new URL associated 
with an object, or activate logic associated with an object by clicking your Left Mouse Button on the 
desired object.

A complete description of the available mouse controls within Viewer Navigation Mode is contained in 
the table below.

Mouse Left Click on an
Object with a URL

Jump to the URL Site

Mouse Left Click on an
Object with Logic

Execute Logic Associated with the Object

Ctrl + Mouse Left Click
on an Object

Automatically Move to the Object

Mouse Right Click Display the WIRL Authoring Menu

Mouse Left Drag Move Viewer forward/backward and Yaw Viewer
left/right

Ctrl + Mouse Left Drag Move Viewer up/down
and Move Viewer left/right

Shift + Mouse Left Drag Pitch Viewer up/down
and Roll Viewer left/right

Mouse Right Drag on an
Object

Move Object forward/backward
and Yaw Object left/right



Ctrl + Mouse Right Drag Move Object up/down
and Move Object left/right

Shift + Mouse Right
Drag

Pitch Object up/down
and Roll Object left/right



Using the Mouse Buttons in Object Manipulation Mode

While in Object Manipulation, you can move objects within a virtual world by clicking and dragging on 
the objects with the Left Mouse Button.

A complete description of the available mouse controls is contained in the table below.

Mouse Right Click Display the WIRL Authoring Menu

Mouse Left Drag on an
Object

Move Object forward/backward
and Yaw Object left/right

Ctrl + Mouse Left Drag Move Object up/down
and Move Object left/right

Shift + Mouse Left Drag Pitch Object up/down
and Roll Object left/right

Mouse Right Drag on an
Object

Move Object forward/backward
and Yaw Object left/right

Ctrl + Mouse Right Drag Move Object up/down
and Move Object left/right

Shift + Mouse Right
Drag

Pitch Object up/down
and Roll Object left/right



The Zoom Buttons

The Zoom Buttons (patent pending), located on the WIRL Control Panel, provide a simple and 
efficient way to both maneuver in 3D space and manipulate objects in 3D space using a standard 
mouse.

In Viewer Navigation mode, the zoom buttons are used to move the viewer through the virtual world.   
In Object Manipulation mode, the zoom buttons are used to move selected objects within the virtual 
world.

Each zoom button provides you with two ways to move (i.e. two degrees of freedom). A zoom button is 
active once you click and hold down the Left Mouse Button, which can be done whenever the cursor is 
above a zoom button.    For example, clicking and holding down the Left Mouse Button while the cursor
is above the leftmost zoom button results in that button expanding to look like this:

Once this button is expanded, the zoom button is active until you stop pressing the Left Mouse Button 
down.    While the button is active, you can drag the mouse up and down to experience one way to 
move, and drag the mouse left and right to experience another way to move. For example, in the case 
of the leftmost zoom button, dragging the mouse up and down will move the viewer or object forwards 
and backwards respectively.    Dragging the mouse left and right will yaw the viewer or object left and 
right respectively.    As you drag further away from where you first clicked, the speed of movement will 
increase.

We encourage you to experiment with the zoom buttons.    They are an intuitive way to experience 
virtual worlds.    In addition to using the zoom buttons, you can always use the direct mouse controls 
discussed above as an alternative.

Troubles with the zoom buttons?    Remember that in order for the zoom buttons to be active in Object 
Manipulation mode, you must have selected an object.    Also, be aware that the author of a virtual 
world can prevent the viewer from moving or can designate an object as not being moveable; in this 
case, you will not be able to use the zoom buttons.



The Control Panel

Control Panel Button Controls

VREAM WIRL Logo Display About WIRL Message

Moving Person Button Switch to Viewer Navigation 
Mode

Hand Button Switch to Object Manipulation 
Mode

First Button with Direction Arrows

If in Viewer Navigation Mode:
Move Viewer forward/backward

and Yaw Viewer left/right

If in Object Manipulation Mode:
Move Object forward/backward

and Yaw Object left/right

Second Button with Direction Arrows

If in Viewer Navigation Mode:
Move Viewer up/down

and Move Viewer left/right

If in Object Manipulation Mode:
Move Object up/down

and Move Object left/right

Third Button with Direction Arrows

If in Viewer Navigation Mode:
Pitch Viewer up/down

and Roll Viewer left/right

If in Object Manipulation Mode:
Pitch Object up/down

and Roll Object left/right

Reset Button Reset the Viewer to Original 
Position

Camera Button Set a new Viewer Position





Authoring Capabilities

WIRL provides the user with a variety of authoring capabilities that can be used to create new 3D 
virtual reality worlds and update existing virtual worlds. These authoring tools are on the popup menu 
which is displayed when the right mouse button is clicked.    Note that these authoring capabilities 
represent a small subset of those offered by VRCreator, VREAM's powerful virtual reality authoring 
software package.

File Menu

Edit Menu

World Attributes Menu

Object Attributes Menu

Viewer Position Menu

Devices Menu

Options Menu

Help Menu



File Menu

The File menu contains options that allow you to save the virtual worlds you create and virtual 
worlds you enhance, load in new objects into a virtual world from your local hard drive and/or 
from Web sites around the world, and otherwise manage virtual worlds. Worlds can be saved 
in a variety of file formats including .WRL (VRML), .VRW (VREAM), and .VRE (VREAM 
extensions to VRML).

The options on this menu are currently disabled in WIRL Lite and in freeware versions of WIRL 
or are not yet available.    To be sure you have the latest and most powerful version of WIRL, 
consider upgrading to the commercial version of WIRL ($29).    See the About Commercial 
WIRL option under the Help menu for more information regarding the commercial version of 
WIRL.

Save as

Load Object File

Load Object URL

Load Options



Save as

This option is currently disabled in WIRL Lite and in freeware versions of WIRL or is not yet 
available.    To be sure you have the latest and most powerful version of WIRL, consider 
upgrading to the commercial version of WIRL ($29).    See the About Commercial WIRL 
option under the Help menu for more information regarding the commercial version of WIRL.



Load Object File

This option is currently disabled in WIRL Lite and in freeware versions of WIRL or is not yet 
available.    To be sure you have the latest and most powerful version of WIRL, consider 
upgrading to the commercial version of WIRL ($29).    See the About Commercial WIRL 
option under the Help menu for more information regarding the commercial version of WIRL.



Load Object URL

This option is currently disabled in WIRL Lite and in freeware versions of WIRL or is not yet 
available.    To be sure you have the latest and most powerful version of WIRL, consider 
upgrading to the commercial version of WIRL ($29).    See the About Commercial WIRL 
option under the Help menu for more information regarding the commercial version of WIRL.



Load Options

This option is currently disabled in WIRL Lite and in freeware versions of WIRL or is not yet 
available.    To be sure you have the latest and most powerful version of WIRL, consider 
upgrading to the commercial version of WIRL ($29).    See the About Commercial WIRL 
option under the Help menu for more information regarding the commercial version of WIRL.



Edit Menu

The Edit menu contains options that allow you to undo your changes to a virtual world and cut,
copy, paste, and delete any object within a virtual world.

The WIRL Undo, Cut, Copy, Paste and Delete commands operate much the same as they do 
in other applications. You can undo, cut, copy, paste, and delete any object using the 
commands from the Edit menu or the standard shortcut keys. 

The options on this menu are currently disabled in WIRL Lite and in freeware versions of WIRL 
or is not yet available.    To be sure you have the latest and most powerful version of WIRL, 
consider upgrading to the commercial version of WIRL ($29).    See the About Commercial 
WIRL option under the Help menu for more information regarding the commercial version of 
WIRL.

Undo

Cut 

Copy

Paste

Delete



Undo

This option is currently disabled in WIRL Lite and in freeware versions of WIRL or is not yet 
available.    To be sure you have the latest and most powerful version of WIRL, consider 
upgrading to the commercial version of WIRL ($29).    See the About Commercial WIRL 
option under the Help menu for more information regarding the commercial version of WIRL.



Cut 

This option is currently disabled in WIRL Lite and in freeware versions of WIRL or is not yet 
available.    To be sure you have the latest and most powerful version of WIRL, consider 
upgrading to the commercial version of WIRL ($29).    See the About Commercial WIRL 
option under the Help menu for more information regarding the commercial version of WIRL.



Copy

This option is currently disabled in WIRL Lite and in freeware versions of WIRL or is not yet 
available.    To be sure you have the latest and most powerful version of WIRL, consider 
upgrading to the commercial version of WIRL ($29).    See the About Commercial WIRL 
option under the Help menu for more information regarding the commercial version of WIRL.



Paste

This option is currently disabled in WIRL Lite and in freeware versions of WIRL or is not yet 
available.    To be sure you have the latest and most powerful version of WIRL, consider 
upgrading to the commercial version of WIRL ($29).    See the About Commercial WIRL 
option under the Help menu for more information regarding the commercial version of WIRL.



Delete

This option is currently disabled in WIRL Lite and in freeware versions of WIRL or is not yet 
available.    To be sure you have the latest and most powerful version of WIRL, consider 
upgrading to the commercial version of WIRL ($29).    See the About Commercial WIRL 
option under the Help menu for more information regarding the commercial version of WIRL.



World Attributes Menu

The World Attributes menu contains options that allow you to modify world and viewer 
settings.

Shading

Background Color

Background Texture

Viewer Move Speed

Viewer Rotate Speed

Object Move Speed

Object Rotate Speed

Gravity

Collision Detection

Object Selection Type



World Shading

Shading under the World Attributes menu allows you to define the default shading method 
within a virtual world.

Select one of the five available radio buttons to define the default shading method for the 
world. You can define whether objects will be shaded with wireframe, unlit flat, flat, Gouraud or 
Phong shading.



Background Color

Background Color allows you to select the background color that will be displayed in the 
virtual world.

Specify a color by using the color field and color slider, or by entering numerical values for 
each color component. The new color is displayed in the color/solid box.

Note that the custom colors options are currently not enabled.

When you are satisfied with the color, choose OK. The background color in your virtual world 
changes to the color you selected.



Background Texture

Background Texture allows you to display a background image within a virtual world. 

The selected background image is a static texture that is displayed in the background of the 
virtual world window.    This feature is useful because it can add a photorealistic texture in the 
background of the virtual world, yet the user will experience no degradation in performance.

If you know the name of the background image you wish to use, you can type it into the 
Background Texture field. Supported file types for this version of WIRL include .JPG, .PNG, 
and .PPM.

To choose a texture on your hard drive, use the Browse option, select the texture and choose 
OK.

To leave the dialog without assigning a background texture, choose Cancel.



Viewer Move Speed

Viewer Move Speed allows you to set the viewer move speed and viewer rotation speed.

Enter the new viewer move speed multipliers in the appropriate edit controls.



Viewer Rotate Speed

Viewer Rotate Speed allows you to set the viewer rotation speed.

Enter the new viewer rotation speed multiplier in the appropriate edit controls.



Object Move Speed

Object Move Speed allows you to set the object move speed and object rotation speed.

Enter the new object move speed multipliers in the appropriate edit controls.



Object Rotate Speed

Object Rotate Speed allows you to set the object rotation speed.

Enter the new object rotation speed multiplier in the appropriate edit controls.



Gravity

Gravity allows you to define whether gravity will exist in the virtual world, and the force of that gravity.

Enter the new object rotation speed multiplier in the appropriate edit controls.



Collision Detection

This option is currently disabled in WIRL Lite and in freeware versions of WIRL or is not yet 
available.    To be sure you have the latest and most powerful version of WIRL, consider 
upgrading to the commercial version of WIRL ($29).    See the About Commercial WIRL 
option under the Help menu for more information regarding the commercial version of WIRL.



Object Selection Type

Object Selection Type defines the way in which objects are selected within WIRL.    You can choose to
select an entire group, potentially comprising multiple sub-groups, objects, and textures, or you can 
individually select primitives, which are typically individual objects.



Object Attributes Menu

The Object Attributes menu contains options that allow you to modify object settings.

Name

URL Hyperlink

Color

Texture

Shading

Position

Touchable

Moveable

Throwable

Rotateable

Respond to Gravity

Elasticity

Auto Translate

Auto Rotate



Name

Name allows you to set the name of a selected object. 

Enter a name for the selected object.

Names are an important attribute for organizing objects within a virtual world. The name you 
choose for an object is important for identification and use in defining the object behaviors and 
logic-based cause and effect relationships that WIRL brings to the world of VRML. You should 
name objects so that you can easily identify them.



URL Hyperlink

URL Hyperlink allows you to assign a link to a selected object such that it will jump to a URL 
when it is picked (clicked with the left mouse button).

Enter the URL address (e.g. http://www.vream.com) and a description of the URL (e.g. Virtual Reality 
Authoring and Internet 3D Browser Software).    After a URL has been assigned, whenever the cursor is
on the object then the cursor will change to indicate that there is an active link and the description will 
appear in the Netscape Navigator status bar.

Names are an important attribute for organizing objects within a virtual world. The name you 
choose for an object is important for identification and use in defining the object behaviors and 
logic-based cause and effect relationships that WIRL brings to the world of VRML. You should 
name objects so that you can easily identify them.



Color

Color allows you to set the color of a selected object.

An object must be selected before this command is executed.    Specify a color by using the color field 
and color slider, or by entering numerical values for each color component. The new color is displayed 
in the color/solid box.

Note that the custom colors options are currently not enabled.

When you are satisfied with the color, choose OK. The color of the selected object changes to 
the color you selected.



Texture

Texture allows you to select a texture which will be wrapped around a selected object using 
either flat,cylinder or sphere wrapping or using existing coordinates. An object must be 
selected before this command is executed. 

If you know the name of the background image you wish to use, you can type it into the Object
Texture field. Supported file types for this version of WIRL include .JPG, .PNG, and .PPM.

To choose a texture on your hard drive, use the Browse option, select the texture and choose 
OK.

To leave the dialog without assigning a background texture, choose Cancel.



Object Shading

Shading under the Object Attributes menu allows you to define the shading method for a 
selected object.

Select one of the five available radio buttons to define the shading method for the selected 
object. You can define whether objects will be shaded with wireframe, unlit flat, flat, Gouraud or
Phong shading.    The shading method for a particular object overrides the default shading 
method for the entire virtual world as long as the object's shading method is of a lesser quality 
than that of the world.



Position

The Position menu allows you to define the position and orientation of a selected object.

Enter the new position and orientation values in the appropriate edit controls.

It is recommended that only advanced users modify object orientation values. For those users who 
wish to modify object orientations, it is important to understand that WIRL uses two vectors, the 
directional vector and the up vector, to orient the object. The direction vector defines the yaw and pitch 
of the object. The up vector, which must be perpendicular to the direction vector, defines the roll of the 
object. In other words, the direction vector defines the direction the object is facing, and the up vector 
defines whether and how the object is tilted. Both vectors are defined from the origin. 



Touchable

This option is currently disabled in WIRL Lite and in freeware versions of WIRL or is not yet 
available.    To be sure you have the latest and most powerful version of WIRL, consider 
upgrading to the commercial version of WIRL ($29).    See the About Commercial WIRL 
option under the Help menu for more information regarding the commercial version of WIRL.



Moveable

The Moveable menu allows you to define whether an object may be moved by the viewer.

If you want an object to be moveable, check the Moveable check box.

Note that the VRML 1.0 specification currently treats the entire virtual world as a single object.    You 
can dynamically ungroup the objects in a VRML file by using the VRC_UNGROUP script command, 
which is one of VREAM's extensions to VRML.



Throwable

The Throwable menu allows you to define whether an object may be thrown by the viewer.

If you want an object to be throwable, check the Throwable check box.

Note that the VRML 1.0 specification currently treats the entire virtual world as a single object.    You 
can dynamically ungroup the objects in a VRML file by using the VRC_UNGROUP script command, 
which is one of VREAM's extensions to VRML.



Rotateable

The Rotateable menu allows you to define whether an object may be rotated by the viewer.

If you want an object to be rotateable, check the Rotateable check box.

Note that the VRML 1.0 specification currently treats the entire virtual world as a single object.    You 
can dynamically ungroup the objects in a VRML file by using the VRC_UNGROUP script command, 
which is one of VREAM's extensions to VRML.



Respond to Gravity

The Respond to Gravity menu allows you to define whether an object will be affected by gravity.

If you want an object to respond to gravity, check the Respond to Gravity check box.

Note that the VRML 1.0 specification currently treats the entire virtual world as a single object.    You 
can dynamically ungroup the objects in a VRML file by using the VRC_UNGROUP script command, 
which is one of VREAM's extensions to VRML.



Elasticity

The Elasticity menu allows you to define the elasticity of an object.

If you want an object to have elasticity, check the Elasticity check box and enter an elasticity value. 
The elasticity value is a percentage between 0% and 100%. A value of 0% indicates no elasticity (i.e. a 
brick). A value of 100% indicates perfect elasticity (i.e. a perfect rubber ball).

Note that the VRML 1.0 specification currently treats the entire virtual world as a single object.    You 
can dynamically ungroup the objects in a VRML file by using the VRC_UNGROUP script command, 
which is one of VREAM's extensions to VRML.



Auto Translate

The Auto Translate menu allows you to define an automatic translation, including limits on the 
translation, for an object.

The entered automatic translation values for an object allow an object to translate a number of units 
per frame. The automatic translation values defined by the user include translational elements along 
the X, Y and Z world coordinate axis, which will be applied to the object before every frame is drawn. 

The auto translate limit fields allows the user to define upper and lower limits on the translational 
motion of the object, restricting how far the object can move in any direction. Once the translating 
object reaches one of the defined limits, it will reverse direction and translate the opposite way until the 
other limit is reached. By defining limits, objects may be made to oscillate between two relative 
positions in space. 

The translational limits defined by this command are relative values, based on the initial position of the 
object. For example, an upper limit of 2 in the x direction will allow an object to move 2 units in the 
positive x direction before stopping it. The 2 limit refers to a relative number of units, not an absolute 
coordinate along an axis.



Auto Rotate

The Auto Rotate menu allows you to define an automatic rotation, including limits on the rotation, for 
an object.

The entered automatic rotation values for an object allow an object to rotate around a specified pivot 
point in the environment.    Be aware that rotations are relative to the object creator's initial midpoint 
specifications, and, as such, proper rotations are best defined by the creator of the object.

The automatic rotation values defined by the user, specified in degrees, include yaw, pitch and roll 
offset values which will be applied to the object before every frame is drawn.

The auto rotate limit fields allows the user to define upper and lower angular limits, restricting how far 
the object can rotate in any direction. Once the rotating object reaches one of the defined limits, it will 
reverse direction and rotate the opposite way until the other limit is reached. By defining limits, objects 
may be made to oscillate between two rotational angles. 



Viewer Position Menu

The Viewer Position menu allows you to move to any of the pre-defined viewpoints: Original, Front, 
Back, Top, Bottom, Left, and Right.    In addition, the user can select from custom views that have been 
defined within VRML files (.wrl).



Devices Menu

The options on this menu are currently disabled in WIRL Lite and in freeware versions of WIRL 
or are not yet available.    To be sure you have the latest and most powerful version of WIRL, 
consider upgrading to the commercial version of WIRL ($29).    See the About Commercial 
WIRL option under the Help menu for more information regarding the commercial version of 
WIRL.

Joystick

Virtual I/O I-Glasses! 

Forte VFX1 HMD



Joystick

This option is currently disabled in WIRL Lite and in freeware versions of WIRL or is not yet 
available.    To be sure you have the latest and most powerful version of WIRL, consider 
upgrading to the commercial version of WIRL ($29).    See the About Commercial WIRL 
option under the Help menu for more information regarding the commercial version of WIRL.



Virtual I/O I-Glasses!

This option is currently disabled in WIRL Lite and in freeware versions of WIRL or is not yet 
available.    To be sure you have the latest and most powerful version of WIRL, consider 
upgrading to the commercial version of WIRL ($29).    See the About Commercial WIRL 
option under the Help menu for more information regarding the commercial version of WIRL.



Forte VFX1 HMD

This option is currently disabled in WIRL Lite and in freeware versions of WIRL or is not yet 
available.    To be sure you have the latest and most powerful version of WIRL, consider 
upgrading to the commercial version of WIRL ($29).    See the About Commercial WIRL 
option under the Help menu for more information regarding the commercial version of WIRL.



Options Menu

The Options menu allows you to set various settings within WIRL.

Control Panel

Heads Up Display

Hyperlinks

WWWInlines

Load Textures

Tool Tips

Hint/URL Tips



Control Panel

The Control Panel option allows you to determine whether the WIRL control panel is displayed while 
you experience a virtual world.



Heads Up Display

This option is currently disabled in WIRL Lite and in freeware versions of WIRL or is not yet 
available.    To be sure you have the latest and most powerful version of WIRL, consider 
upgrading to the commercial version of WIRL ($29).    See the About Commercial WIRL 
option under the Help menu for more information regarding the commercial version of WIRL.



Hyperlinks

The Hyperlinks option allows you to determine whether hyperlinks to URLs on the Web are active 
while you experience a virtual world.



WWWInlines

The WWWInlines option allows you to determine whether WWWInline objects are active while you 
experience a virtual world.



Load Textures

The Load Textures option allows you to determine whether textures that are associated with objects 
are displayed while you experience a virtual world.



Tool Tips

The Tool Tips option allows you to determine whether tool tips that are associated with butttons on the
WIRL control panel are displayed when the cursor is above the button.



Hint/URL Tips

The Hint/URL option allows you to determine whether hints and/or URL descriptions that are 
associated with objects within a virtual world are displayed in the Netscape Navigator status bar when 
the cursor is above an object with a hint or URL hyperlink.



Help Menu

The Help menu allows you to access the WIRL Help System.

The WIRL Lite and freeware versions of WIRL have less extensive help than is available in the 
commercial version of WIRL.

To be sure you have the latest and most powerful version of WIRL, consider upgrading to the 
commercial version of WIRL ($29).    See the About Commercial WIRL option under the Help 
menu for more information regarding the commercial version of WIRL.

Help

Search for Help On

Index

About WIRL

About Commercial WIRL



Help

Help provides you with an introduction to the features of WIRL Lite and freeware versions of WIRL. 

The Help file available with the commercial version of WIRL provides you with more extensive help, 
including step-by-step instructions for using WIRL, reference information, examples and 
demonstrations of WIRL features, information about the VREAM scripting language, and technical 
support information.



Search for Help On

Search for Help On provides you with the ability to search this Help file for any word. 



Index

Index allows you to type in the first few letters of a keyword that may be associated with a topic in this 
help file. 



About WIRL

About WIRL displays information about this version of WIRL. 



About Commercial WIRL

About Commercial WIRL provides you with information on the commercial version of WIRL, which 
offers a number of advantages over WIRL Lite and freeware versions of WIRL. 



Advanced Features

WIRL contains many advanced features which allow true virtual reality to be experienced across the 
World Wide Web. Some of these advanced features include: 

Full Object Interactivity (Pick up objects, throw them 

around in 3D Space)

Object Dynamics (Objects can move, rotate, resize, 

etc.)

Object Physics (Gravity, Elasticity, Weight, 

Throwability)

Custom Object Behaviors and Logic definable as 

VREAMScript Extensions

Automatic Object and Viewer Paths

Full texturing

Texture Animation (For Playing Videos within the virtual

World)

Play sound files from within a virtual world

Launch External Applications from within a virtual world

Authoring Capabilities (Alter content of world while 

within the Browser)

Supports GZip compression

    . . .And there are many more awesome things to come!!



System Requirements

You will need at least the following system configuration to run the WIRL Interactive 3D Browser:

Hardware Requirements

IBM Compatible PC with at least a 486DX 33Mhz CPU (But a Pentium is much nicer)
    (Note: If you have a 486SX, you will need a math coprocessor)

 256 Color Display    (But worlds look even better if you use 64K colors)

 8 MB RAM

 Mouse

Software Requirements

Windows 95 and Windows NT (Windows NT, MacIntosh and UNIX versions are under development)

Netscape Navigator Version 2.0



Supported File Formats

WIRL supports standard 3D Files in the VRML 1.0 format (file extension .WRL), and also supports fully 
interactive virtual reality worlds in VREAM's Virtual Reality World format (file extension .VRW). 

In addition, the WIRL Browser allows standard 3D VRML Files to be given true virtual reality 
capabilities by creating a Virtual Reality Extensions file (file extension .VRE) that contains VREAM's 
scripting language commands. 



VRML Support

This Version of WIRL has support for most of the VRML 1.0 specification, but there are still a few items 
that are not yet supported. The following VRML nodes are not yet supported, but will be soon:

    Asciitext

    IndexedLineSet

    PointSet

    LOD

    OrthographicCamera

    Lights

    Texture2Transform



Adding VREAM Extensions to VRML Worlds

Fully supporting VRML, WIRL brings to VRML over 100 extensions in functionality, including many 
object behaviors and the ability to implement logic-based cause and effect relationships.    These 
extensions are currently implemented using VREAM's open scripting language, called VREAMScript.

To enhance a VRML-based virtual world with VREAM extensions, add the following line to the highest 
level “Separator” in your VRML file (.wrl).

DEF VRExtensions Info {string "filename.vre"}

The extension file should begin with the line:

// VREAM Extension File

To set an object attribute in the extension file, use the following command to state which vrml object’s 
attributes to change.

VRC_REFERENCE_OBJECT,S,Objectname;

Example:

// VREAM Extension File

//  SET OBJECT ATTRIBUTES
VRC_REFERENCE_OBJECT,S,car;
       VRC_AUTO_ROTATE_RELATIVE,S,0.1,0,0,  0,0,0;

This would cause the car to automatically spin around when the file is loaded.

Because of the extensive nature of the VREAM scripting language, the script command 
extensions are not documented in WIRL Lite or in freeware versions of WIRL. The extensions 
are documented in the commercial version of WIRL and on VREAM's Web site 
(http://www.vream.com).

To be sure you have the latest and most powerful version of WIRL, consider upgrading to the 
commercial version of WIRL ($29).    See the About Commercial WIRL option under the Help 
menu for more information regarding the commercial version of WIRL.



Adding a Virtual World to a Web Page

To add a virtual world to an HTML document you need to include the following line in the HTML file:

<embed src=filename.ext width=mmm height=nnn>
where filename.ext can be a .VRW (VREAM) or a .WRL (VRML) file and mmm and nnn are
the width and height in pixels of the virtual world.

You also can view a virtual world within the Netscape Navigator window without having it be embedded
within an HTML document.    Simply type the name of the .VRW (VREAM) or .WRL (VRML) file into the 
location field where you would normally type a URL.    The WIRL plug-in will then fill the entire Netscape
Navigator with the virtual world.

Note that in order to make a virtual world accessible from your server, you must add support for the 
following mime types:

x-world/x-vrml          wrl                  
x-world/x-vream         vrw



Contacting VREAM

Please feel free to contact us if you have any questions about WIRL or VRCreator or VREAM.

VREAM, Inc. 
2568 N. Clark St. #250
Chicago, IL 60610
Phone: (312) 477-0425
Fax: (312) 477-9702
Web: www.vream.com
Email: info@vream.com

If you have an active Internet connection, you can use the links below to contact us NOW!

Go to VREAM's Home Page on the Web NOW! 

Join VREAM's Mailing List NOW! 

Order WIRL or VRCreator NOW! 

Email VREAM Now! 



Visit VREAM's Web Page

You must have an active Internet connection for this option.

Go to VREAM's Home Page on the Web NOW! 



Join VREAM's Mailing List

You must have an active Internet connection for this option.

Join VREAM's Mailing List NOW! 



Order WIRL or VRCreator

You must have an active Internet connection for this option.

Order WIRL or VRCreator NOW! 



Send Email to VREAM

You must have an active Internet connection for this option.

Email VREAM Now! 




