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Getting Started
Note: If you are not familiar with Microsoft Windows we recommend that you work 
through the tutorial supplied with Windows before using this program.

Visual Trees is a genealogy program for Microsoft Windows 3.1. It enables the 
organisation of data on your ancestors / descendants (including documents) in a 
straight forward and easy manner. Features include:

- easy to use user interface including quick buttons
- instant on screen ancestor chart generation
- context sensitive help
- customizable fonts and background colour
- reports to printer or screen
- document database
- instant viewing of a persons related documents
- instant switching to Father/Mother/Spouse or Child records
- up to 32K of notes for each person
- customizable text search facility

When you run Visual Trees for the first time (or when no person records exist) you 
will be presented with a blank person record form ready for adding records. See 
Adding Person Records.

You can switch to the Document Record Window by selecting {Window->Document 
Record} from the menus (or by clicking the right mouse button inside the Person 
Record Window). If no document records exist this form will also be ready for 
entering records. See Adding Document Records.

Once person (or document) records exist you can work with them using the Quick 
Buttons or Menus. You can also browse through records using the arrow and Home-
End keys on your keyboard.

You can alter the font used to draw text (see Font Selection) and the background 
colour in windows (see Background Colour).

Note: You can search for a particular topic by clicking on the "Search" button at the 
top of this window.



Menu Items
File

Printer Setup
Exit

Record
Add
Save
Delete
Find
Jump 1st Jumps to the first record in the file
Next Moves to the next record in the file
Last Moves to the previous record in the file
Jump Last Jumps to the last record in the file

Reports
Reports

Options
Purge Files
Font
Background Colour

Window
Cascade
Tile



Quick Buttons

    Exit
    Table
    Ancestor Chart
    Reports
    Add Record
    Save Record
    Delete Record
    Finished Update
    Find Text
    Jump to first record
    Move to previous record
    Move to next record
    Jump to last record
    Activate Help System



Limits and Capacities
Person Records

The maximum number of person records is 32768.

Document Records

The maximum number of document records is 32768.

Document References

The maximum number of document references for a single person record is 800. 
The total number should not exceed 32768.

Notes

The maximum size of notes for a single person is 32768 characters.

Ancestor Chart Window

The number of generations which can be displayed in the ancestor chart is limited 
to the number that can fit within a windows total drawing surface. This depends on 
the width of the currently selected chart font - with the default chart font it is 
approximately 90 generations (you would need to scroll the window to view most of 
this).



Printer Setup
{File->Printer Setup}.

Use this option to set printer options. You can set:

- the current printer and port
- printer resolution
- paper size
- type of paper feed
- output orientation (portrait or landscape)

Printer

The current printer and output port is highlighted in the listbox. To change the 
selection click on the required entry in the listbox.

"OK" Button

Once you are satisfied with the printer settings click on the "OK" button to make the
changes permanent and close the dialog box.

"Cancel" Button

If you wish to close the dialog box without saving any changes, click the "Cancel" 
button.

"Setup" Button

To alter other printer settings, click on the "Setup" button and another dialog box 
will be opened. This is the Windows universal printer setup dialog box and has its 
own help. To receive help for this dialog box click its "Help" button.



Exit
    or {File->Exit}

This will close the program and return you to the last active application (usually 
Program Manager).



Add Record
    or {Record->Add}

This is a context sensitive function. If the Person Window is active then this 
command will invoke the Add Person Record function. If the Document Window is 
active then the Add Document Record function is invoked.

See:
Add Person Record
Add Document Record



Save Record
    or {Record->Save}

This function saves a document or person record depending on which window is 
active.

If you are adding a new record then the record is saved, the form is cleared, and the
focus is set on the first field in the form (either Surname or Document Reference).

If you are changing a record then the record is simply saved.



Delete Record
    or {Record->Delete}

This option deletes the current record whether it is a person record or a document 
record. A warning notice is displayed before a record is deleted.

Note:    Deleting records doesn't remove them from the file but removes all links to 
the record. To remove deleted records from the files use the Purge Files option from 
the Options menu (you only need do this once in a while or when short of disk 
space).



Find Record
    or {Record->Find} or <F3>

This function is context sensitive. If you run it with the Person Window active then 
you will be searching through the person records. If you run it with the Document 
Record Window active you will be searching through document records.

Note: Move between fields in the dialog box by pressing <TAB> to move to the next
or <Shift+TAB> to move to the last. You can also use the mouse by clicking on the 
required field with the left mouse button.

Choosing this function will bring up a dialog box for entering the search criteria as 
follows:

Find

Enter the text you wish to find. You can enter up to 30 characters which may include
spaces and punctuation.

Search field

Select a specific field to search in (or select "All fields" to search in all fields) by 
clicking on the button to the right and clicking on the required entry in the 
subsequent dropdown list.

Options - Whole word

Switch this option on to limit the search to the first n  characters of a field where n    
is the length of the text you wish to find (as entered in Find above). Toggle the 
option on or off by clicking over it or by hiliting it (Tabbing to it) and pressing the 
space bar.

Options - Case sensitive

Switch this option on for a case sensitive search. Toggle it on/off as above.

"OK" Button

Click on the "OK" button to begin the search. The search will begin from the first 
record (whether Person or Document). If a match is found the appropriate record will
be displayed with the search text hilited (if the text is found in the path or file fields 
when searching documents then the record will be displayed without any hiliting). 

"Cancel" Button

If you do not wish to proceed with a search then click the "Cancel" button to close 
the dialog box.



"Find Next" Button

If you have run a previously successful search and wish to continue that search then
click the "Find Next" button. Alternatively, you can press the <F4> key - which is 
quicker. This button is disabled if no previous and successful search has been 
carried out.



Repeat Last Search
<F4>

This function will continue a search from the record following the record where a 
match was last found. If no match was found during the last search operation then 
this function will do nothing.



Reports
    or {Reports}

Activates the Reports dialog box. Select a report, the destination (screen or printer),
and the font and click on the "OK" button to run the report.

The selection of reports is the same whether you run the reports function with the 
Document or Person Window active. There is only one document report - the 
document list.

Note: Move between fields in the dialog box by pressing <TAB> to move to the next
or <Shift+TAB> to move to the last. You can also use the mouse by clicking on the 
required field with the left mouse button.

Select a Report

Select a report from the combo-box by clicking the left mouse button on the button 
to the right and clicking over the required selection from the dropdown list. For 
more information on a particular report click on one of the following:

Ancestor Chart
Male Line
Descendants
Person List
Document List

Select a Destination

Select either printer or screen by clicking over the required option so that it is 
checked (or toggle between the two with the up/down arrow keys). Note that the 
Ancestor Chart, Person List and Document List all permanently exist in their own 
windows so running one of these reports with the destination set to screen will 
activate the appropriate window. A new report window is created for the other 
reports.

Select a Font

If you wish to change the font used to draw the report then click on the "Font" 
button to activate the Windows standard Font Selection Dialog.
The font set here is used to draw reports to both the screen and printer - with the 
exception of the Ancestor Chart which uses its own font and the Person and 
Document Lists which use the screen font for the screen and the report font for the 
printer.

Click on "OK"

Once you have selected the report, destination and font you require then click on 
the "OK" button to run the report.



"Cancel" Button

If you wish to exit the reports dialog without running a report then click on the 
"Cancel" button.

"Setup" Button

The current printer and port is displayed towards the top of the dialog box. If you 
wish to change this then click the "Setup" button to activate the Printer Setup 
dialog.



Purge Files
{Options->Purge Files}

This option will remove all deleted person and document records from the files so 
freeing up disk space.

When you delete records they are not removed from the file but unlinked (ie: all 
reference to them is removed) - This makes the Delete Record option work at an 
acceptable speed. Running the Purge Files option will remove any unlinked records 
from the files. You only need do this once in a while.

The progress of the operation is displayed in the status bar at the foot of the screen.



Font Selection
{Options->Font} for the screen or chart font.
Click the "Font" button in the Reports dialog to change the report font.

The screen font is used for the Person, Document, Person Table and Document Table
windows.

The chart font is used for the Ancestor Chart Window and the printed Ancestor 
Chart.

The report font is used for all printer output (except the Ancestor Chart) and for the 
Male Line and Descendants reports sent to the screen (in the Report Window).

Alter the face, style and size of the font as you see fit. A sample of how the settings 
look is shown in the bottom right quarter of the dialog box. For the screen font you 
may also change the color.

If you set the size of the screen font too high portions of the person form may not 
be visible.

Using italics    for the screen font is not recommended if you intend to do any editing
/ updating - the edit controls don't handle italics very well.

Note: The strikethrough and underline effects which can be set in the dialog are 
ignored by the program.

"OK" Button

Click on the "OK" button to save the settings and close the dialog box. The 
programs Windows will be cascaded so that they are all re-drawn to reflect the 
changes made to the font if you are changing the screen or chart font.

"Cancel" Button

Click on the "Cancel" button to close the dialog without saving or implementing any 
changes made. 



Background Colour
{Options->Background Colour}

Select this option to activate the Windows standard Colour Selection Dialog. Choose 
a    colour by clicking the left mouse button over the required color box. Click on 
"OK" to save and implement changes. Click on "Cancel" to leave the background 
colour unaltered.

Note: the custom colours option is ignored by the program.



Cascade Windows
{Window->Cascade}

Use this option to arrange the open windows in a cascade formation.

See also: Tile



Tile Windows
{Window->Tile}

Use this option to arrange the open windows in a tile formation.

See also: Cascade



Person Window
{Window->Person Record}

The Person window displays individual person records and is used to add new 
records or alter existing ones.

Adding new person records

See Adding Person Records.

Altering Records

To alter a person record just click the left mouse button over one of the fields 
(except the document and children list boxes) and make changes as required. You 
can still browse through records whilst altering them. See Altering Person Records.

Switching to a childs record

When browsing records you can switch to one of a person's children records by 
double clicking the left mouse button over the required childs entry in the Children 
list box.

Note: Children listed with an asterix (*) beside their name have a different 
father/mother to the one in the current persons Spouse field (ie: they are from a 
second marriage). You can switch to their record as for other children.

Viewing Related Documents

When browsing, you can view one of a person's related documents by double 
clicking the left mouse button over the required entry in the Documents list box. 
The Document Viewing Window is removed easily by clicking outside of it, or by 
choosing "Close" from its system menu.

"Print" Button

When browsing records you can print an individual record by clicking on the "Print" 
button. The record is printed using the current report font as set in the Reports 
dialog.

"Father" Button

When browsing through records you can jump to the current persons father's record
by clicking on the "Father" button. If the current person has no father selected then 
this button is grayed and disabled.

"Mother" Button

When browsing through records you can jump to the current persons mother's 



record by clicking on the "Mother" button. If the current person has no mother 
selected then this button is grayed and disabled.

"Spouse" Button

When browsing through records you can jump to the current persons spouse's 
record by clicking on the "Spouse" button. If the current person has no spouse then 
this button is grayed and disabled.

You can switch to the Document Window by clicking the right mouse button within 
the person windows client area.

The font used to draw text in the Person Window can be altered by selecting 
{Options->Font} from the menus with the Person Window active. This will also alter 
the font used in the Document and Table windows. See Font Selection.

See also: Document Window
Person Table Window
Document Table Window
Ancestor Chart Window
Report Window



Document Window
{Window->Document Record}

This window displays individual document records and is used to add new records or
alter existing ones.

Adding new document records

See Adding Document Records.

Altering Records

To alter a document record just click the left mouse button over one of the fields 
and make changes as required. You can still browse through records whilst altering 
them. See Altering Document Records.

"Print" Button

When browsing records you can print an individual record by clicking on the "Print" 
button. The record is printed using the current report font as set in the Reports 
dialog.

"Edit" Button

When browsing records you can opt to edit a document (using Paintbrush) by 
clicking the "Edit" button. This will run Paintbrush with the document loaded and 
ready for editing. See Paintbrush's own help system for information on how to use it.

You can switch to the Person Window by clicking the right mouse button within the 
document window.

The font used to draw text in the Document Window can be altered by selecting 
{Options->Font} from the menus with the Document Window active. This will also 
alter the font used in the Person and Table windows. See Font Selection.

See also: Person Window
Person Table Window
Document Table Window
Ancestor Chart Window
Report Window



Person Table Window
    or {Window->Person Table}

Displays a cut down version of all person records in table form. Records may be 
scrolled horizontally or vertically if necessary by using the scroll bars which appear 
if any part of the table cannot fit inside the window. You can use the <Page Up>, 
<Page Down>, <Home>, <End> and arrow keys to scroll. Press <Ctrl>+<Home> 
to move to the top of the table and <Ctrl>+<End> to move to the bottom.

You can select an individual record by clicking the left mouse button over it and 
switch to the Person Window with the selected record displayed in full by double 
clicking over it.

You can switch back to the Person Window by clicking the right mouse button within 
the window.

The font used to draw text in the Person Table Window can be altered by selecting 
{Options->Font} from the menus with the Person Table Window active. This will also
alter the font used in the Document and Person windows. See Font Selection.

See also: Person Window
Document Window
Document Table Window
Ancestor Chart Window
Report Window



Document Table Window
    or {Window->Document Table}

Displays all document records in table form. Records may be scrolled horizontally or 
vertically if necessary by using the scroll bars. You can use the <Page Up>, <Page 
Down>, <Home>, <End> and arrow keys to scroll. Press <Ctrl>+<Home> to move
to the top of the table and <Ctrl>+<End> to move to the bottom.

You can select a document record by clicking the left mouse button over it so that it 
is hilited and switch to the Document Window with the selected record displayed in 
full by double clicking over it.

You can switch back to the Document Window by clicking the right mouse button 
within the window.

The font used to draw text in the Document Table Window can be altered by 
selecting {Options->Font} from the menus with the Document Table Window active.
This will also alter the font used in the Document and Person windows. See Font 
Selection.

See also: Person Window
Document Window
Person Table Window
Ancestor Chart Window
Report Window



Ancestor Chart Window
    or {Window->Ancestor Chart}

Displays the ancestors of the current person (displayed in the Person Window) in 
chart form. The window may be scrolled if necessary by using the scroll bars. You 
can use the <Page Up>, <Page Down>, <Home>, <End> and arrow keys to scroll.

You can select a person displayed in the chart and switch to his/her person record in
the Person Window by double clicking over the persons box.

You can switch to the Person Window by clicking the right mouse button within the 
chart window.

The font used to draw text in the Ancestor Chart Window can be altered by selecting
{Options->Font} from the menus with the Ancestor Chart Window active. This will 
also alter the font used to print the Ancestor Chart. See Font Selection.

See also: Person Window
Document Window
Person Table Window
Report Window
Limits and Capacities



Document Viewing Window
The document viewing window allows the quick viewing of documents related to the
current person record.

Documents are related to a person when adding or updating a person record by 
selecting documents into the Documents field via the Document Selection Dialog 
Box.

Related documents are viewed by double clicking the required entry in the 
Documents field list box when browsing person records.

Close the window and return to browsing by:

- clicking outside the window or
- choosing {Close} from the windows system menu or
- pressing <Esc> or
- clicking or pressing one of the browse buttons



Report Window
The report window displays the last report run with the destination set to screen 
(except the ancestor chart and person/document lists which have their own 
permanent windows). Reports are run via the Reports Dialog.

You can scroll through the report using the scroll bars if neccessary.

You can switch to the Person Window by clicking the right mouse button within the 
report window.



Add Person
    or {Record->Add} with the Person Window active.

On selecting this option the person record form is cleared and the focus is set on the
first field - Surname.

Note: Move between fields in the form by pressing <TAB> to move to the next or 
<Shift+TAB> to move to the last. You can also use the mouse by clicking on the 
required field with the left mouse button.

Surname

The surname may be upto 30 characters in length. The surname field is always 
output as block capitals. You must enter a surname.

First names

First names may be upto 35 characters in length.

Address

The address may be upto 120 characters in length. You can start a new line by 
pressing <Enter> (<Return> on some keyboards).

Born

The date of birth of the person - upto 10 characters. Use the format dd/mm/yyyy or 
mm/dd/yyyy or yyyy/mm/dd.
Visual Trees assumes you are using the "Short Date" format as set through the 
"International" option of Windows Control Panel - so a birth date of 1st May 1994 
should be entered as 01/05/1994 if the short date format is set on "DMY", 
05/01/1994 for "MDY" and 1994/05/01 for "YMD".

The date of birth is used to sort records of people with the same surname.

Born where

Place of birth of the person - upto 30 characters.

Married

Date of marriage - upto 10 characters as Born above.

Married where

Place of marriage - upto 30 characters.

Died



Date of death - upto 10 characters as above.

Died where

Place of death - upto 30 characters.

Occupation

The persons occupation - upto 30 characters.

Sex

Sex of person. Select male or female by clicking over it or toggle between the two 
by using the up and down arrow keys.

Father

Select the persons father by clicking over the required entry in the dropdown list. 
Alternatively use the up and down arrow keys to change the selection. The 
dropdown list can be scrolled using the scroll bar or the Up/Down arrow keys and 
the <Page Up>, <Page Down> keys.

The default selection is <unknown>. If you haven't entered the persons father yet 
then leave it at this and change it later.

Mother

Select the persons mother as above.

Spouse

Select the persons spouse as above. If a person has been married more than once 
select that persons first spouse. Children from a subsequent partner will be listed 
with an asterix (*) beside their name (when browsing records).

 (children)

Children are filled in automatically when browsing. Leave this field empty.

Documents

You can associate document records with a person. If there are no document records
this field is jumped. Otherwise the Document Selection Dialog is displayed.

Notes

Notes can be entered for upto 32 thousand characters. Start a new line by pressing 
<Enter> (or <Return> on some keyboards). The edit control will automatically scroll
as you fill it. If you wish to insert a Tab use <Ctrl>+<Tab> (pressing just <Tab> will 



move you to the next field in the tabbing sequence (Surname)).

Save the record by clicking on the     quick button or select {Record->Save} from 
the menus.

When you have finished adding records and wish to return to browsing through 
them click on the  quick button or press the <F10> key on your keyboard.

See also: Limits and Capacities
Backing Up Your Data



Altering Person Records
Alter person records by clicking the left mouse button over a field on the person 
form (except the Children and Document list boxes) whilst browsing. The quick 
button bar will change to include the  (save)
and  (end update) buttons.

You can still browse through the records whilst in update mode. If you try to move to
another record having altered the current one without saving it, you are given the 
option of saving it first.

Return to browse mode by clicking on the afore mentioned End Update button.



Add Document
    or {Record->Add} with the Document Window active.

On selecting this option the document record form is cleared and the focus is set on 
the first field - Reference.

Note: Move between fields in the form by pressing <TAB> to move to the next or 
<Shift+TAB> to move to the last. You can also use the mouse by clicking on the 
required field with the left mouse button.

Reference

Document Reference - used for indexing document records. Can be upto 10 
characters in length.

Description

Description of the document - upto 30 characters.

Path/File

Note: Document files must be in Bit Map format (.BMP).

Select the required path and file from the list boxes. When a file is selected it is 
displayed in the lower half of the screen enabling you to check you have the correct 
one. You may change the selected file and path until satisfied.

Save the record by clicking on     or select {Record->Save} from the menus.

When you have finished adding records and wish to return to browsing through 
them click on the  quick button or press the <F10> key.

See also: Limits and Capacities
Backing Up Your Data



Altering Document Records
Alter document records by clicking the left mouse button over a field on the 
document form whilst browsing. The quick button bar will change to include the  
(save) and 

 (end update) buttons and the focus will be set on the field clicked on.

You can still browse through the records whilst in update mode. If you try to move to
another record having altered the current one and not saved it you are given the 
option of saving it first.

Return to browse mode by clicking on the afore mentioned End Update button.



Finish Update
    or <F10> on your keyboard.

Once you have finished updating or adding records, click on the above quick button 
to return to browsing.

If you choose this option having made changes and not yet saved them, you will be 
given the option of saving the changes.



Document Selection Dialog
The Document Selection Dialog Box will appear automatically when the focus is set 
on the documents field in the Person Form during an update.

Select documents to associate with a person record by double clicking the required 
documents in the list box on the left. Selected documents will be copied to the list 
box on the right. If you wish to de-select a document then double click on its entry 
in the list box on the right.

"OK" Button

To keep selections/alterations made once you have finished click on the "OK" 
button. The selections made will be copied to the Documents list box in the Person 
Form.

"Cancel" Button

To abandon document selection without keeping any alterations click on the 
"Cancel" button.

The Document Selction dialog box is automatically removed when you click on the 
"OK" or "Cancel" button and the focus moved to the Notes field in the Person Form.



Help Quick Button
    or <F1>

Gives context sensitive help. This help system is activated with the topic related to 
what you are doing displayed.

Switch back to Visual Trees by:
- clicking the left mouse button in one of its windows or
- closing the help system by choosing {File->Exit} from its menus or
- closing the help system by double clicking its system menu (in the top left 
corner of the help window) or
- pressing <Ctrl>+<Esc> and selecting Visual Trees from the subsequent 
task list.

Note: If the help system is open when you exit Visual Trees it will be closed unless 
you have another program running with its help system open.



Ancestor Chart Report
The ancestor chart displays or prints the current persons (the person displayed in 
the Person Window) ancestors in chart form.

If this report is run with the destination set to screen the Chart Window is activated 
and displayed.

Note that the font used for drawing the chart on screen or printer is set by choosing 
{Options->Font} from the menus with the chart window active. The ancestor chart 
is not printed with the report font.

See also: Reports



Male Line Report
The male line report displays or prints the current persons (the person displayed in 
the Person Window) male ancestors on the fathers side. The earliest recorded 
ancestor is displayed first with each subsequent one below it down to, and 
including, the current person.

See also: Reports



Descendants Report
The descendants report displays or prints the current persons (the person displayed 
in the Person Window) descendants by family group with each new generation 
indented.

See also: Reports



Person List Report
The person list report displays or prints all person records in list form.
Note that if this report is run with the destination set to screen the Person Table 
Window is activated and displayed (as this is what the report is).

See also: Reports



Document List Report
The document list report displays or prints document records in list form.
Note that if this report is run with the destination set to screen the Document Table 
Window is displayed (as this is what the report is).

See also: Reports



Problems?
If you are using version 3.0 of Windows and are having trouble running Visual Trees 
you may need to copy the files in the "redist" directory of your installation disk into 
the "windows" or "windows\system" directory on your hard disk. These are 
redistributable files from Windows 3.1 which Visual Trees needs in order to run 
correctly.

If you have any problems, queries or suggestions regarding Visual Trees then please
write to:

Richard Styles
PO Box 2113
Dorchester
Dorset DT1 2YT
United Kingdom



Backing Up Your Data
It is advisable to backup your data regularly.
The files which should be backed up are:

person.dat - main person record file
person.not - person notes
person.dr - person document references
document.dat - document file
vt.ini - program initialisation file

Refer to your DOS documentation on how to backup (and restore) files.



Registering Visual Trees
If you haven't registered the program a "nag" screen will appear at more and more 
regular intervals whilst you are using it. To disable the nag screen and become a 
licensed user register by contacting Springsoft on 0352 770049 (major credit cards 
accepted) or by writing to:

Springsoft
Springfield House
Llanfynydd
Wrexham
Clwyd LL11 5HW
UK

You will be given a password which you enter by selecting {Options->Register} from
the menus. Once the password and your name have been correctly entered the 
"Register" menu option and nag screen will be removed.




