
SuperMonitor Help Contents    
To learn how to use Help, press F1...

Menu Commands:
File     
View     
Options     
Actions     
Window      
Help      

Topics of interest:
Installation and removal instructions 
Windows 95 and Windows NT issues 
Monitoring your system resources 
Reported resource usage accuracy 
Resource colors and what it all means 
Choosing the optimal monitoring, updating, and logging rates 
What you want is exactly what you see -customizing your views 
How to use SuperMonitor's multiple document capabilities to determine exactly 

how much resources a specific program uses 
Evaluation program limitations 

File menu commands
The File menu offers the following commands:

New Open a new document.
Open Open an existing document.
Close Close an open document.
Save As Save a document with a new name (renames the document and its log file).
Print Print current document's view (window).
Print 
Preview 

Display current document's view (window) exactly as it would appear on your 
printer.

Print Setup Setup your printer.
MRU 1-4 Open most recently used document.
Exit Exit SuperMonitor.



View menu commands

The View menu offers the following commands:

Toolbar Shows or hides the toolbar.
Statusbar Shows or hides the status bar.



Options menu commands

The Options menu offers the following commands:

Log to Disk Log file options.
Stay on Top Stay on top or normal window behavior.
Position Remember last window position upon startup.
Rates Rates options.
Views View window options.



Actions menu commands

The Actions menu offers the following commands:

Start 
Stop 
Reset 
Restart 



Window menu commands

The Window menu offers the following commands:

New Instants Window  Create new Instants view (window) of current document.
New Averages Windows Create new Averages view (window) of current document.
New Minimums Window Create new Minimums view (window) of current document.
Cascade Cascade all views.
Tile Tile all views.
Arrange Icons Arrange all views.

Help menu commands

The Help menu offers the following commands:

Contents Offers you an index to topics on which you can get help.
Search for Help on Searches for a Help topic by typing or selecting a keyword.
Using Help Provides general instructions on using help.
Product Support Where to get technical and sales support.
About Displays the version number of this application.



New command (File menu & Toolbar)

Opens a new (non-existent) document and its associated views as defined in the Views 
command (Option menu)    dialog.

Remember, SuperMonitor is a multiple-document aware program. You may have an 
unlimited number of documents open and monitoring your system resources.

The document name is used as the name of the log file (if logging to disk). It is not used 
anywhere else in the program.

Shortcuts
Mouse: Click this button to open a new file (document)



Open command (File menu & Toolbar)

Opens an existing document and its associated views as defined in the Views command 
(Option menu)    dialog.

Remember, SuperMonitor is a multiple-document aware program. You may have an 
unlimited number of documents open and monitoring your system resources.

The document name is used as the name of the log file (if logging to disk). It is not used 
anywhere else in the program.

Shortcuts
Mouse: Click this button to open an existing file (document)



Close command (File menu)

Closes the active document and all of its views. If the document was monitoring your system
resources, you will first be prompted for permission to stop monitoring your system.



Save As command (File menu)

Renames (saves) the current document. 

The document name is used as the name of the log file (if logging to disk). It is not used 
anywhere else in the program.



Print command (File menu & Toolbar)

Prints the active document's active view to the printer. Only the active view of the document
is printed. If your document has all three views open, you must activate each view, print it, 
and repeat the process for the remaining views.

Shortcuts
Mouse: Click this button to print the active document's active view



Print Preview command (File menu & Toolbar)

Displays the active document's active view as it will appear on the printer. Only the active 
view of the document is displayed. If your document has all three views open, you must 
activate each view, print it, and repeat the process for each remaining view.

Shortcuts
Mouse: Click this button to preview the active document's active view



Print Setup command (File menu)

Displays the printer setup dialog box for your printer.



Exit command (File menu)

Use this command to end your session.    You can also use the Close command on the application Control
menu.

Shortcuts
Mouse: Double-click the application's Control menu button.

Keys: ALT+F4



MRU 1-4 command (File menu)

Displays the last four documents that were accessed. Click on one of these to quickly open 
the file (document).



Toolbar command (View menu)

Use this command to display and hide the Toolbar, which includes buttons for some of the most common 
commands in the program.    A check mark appears next to the menu item when the Toolbar is displayed.

See Toolbar for help on using the toolbar.



Toolbar

The toolbar is displayed across the top of the application window, below the menu bar.    The toolbar 
provides quick mouse access to many tools used in this program,

To hide or display the Toolbar, choose Toolbar from the View menu (ALT, V, T).



Status Bar command (View menu)

Use this command to display and hide the Status Bar, which describes the action to be executed by the 
selected menu item or depressed toolbar button. A check mark appears next to the menu item when the 
Status Bar is displayed.

See Status Bar for help on using the status bar.



Statusbar

The status bar is displayed at the bottom of the program window.    To display or hide the status bar, use 
the Status Bar command in the View menu.

The left area of the status bar describes actions of menu items as you use the arrow keys to navigate 
through menus.    This area similarly shows messages that describe the actions of toolbar buttons as you 
depress them, before releasing them.    If after viewing the description of the toolbar button command you 
wish not to execute the command, then release the mouse button while the pointer is off the toolbar 
button.



Log to Disk command (Options menu)

This command displays a dialog box that allows you to customize log files. Click on any of 
the dialog options for more help...



Stay on Top command (Options menu, System menu)

Forces SuperMonitor to always be on top of all other programs. When you want to monitor 
your system while a wide variety of programs are executing, we suggest that you minimize 
SuperMonitor and make it stay on top so that its information is always visible. You may 
also execute SuperMonitor full screen while it is on top.

Note that when SuperMonitor is minimized (as an icon) you can access its system menu 
and perform a variety of useful commands (Stay on Top, Start, Stop, etc.) without having to 
maximize SuperMonitor, issue the command, and then re-minimize it.



Position command (Options menu)

With Position disabled (not checked), SuperMonitor always starts executing almost full 
screen. If you want SuperMonitor to remember its last size and position right before it 
terminated, so that the next time you execute it, it will display in the same place as during 
its previous execution, enable this option (check it).



Rates command (Options menu)

This command displays a dialog box that allows you to customize the sampling rates of 
SuperMonitor... Click on any of the dialog options for more help...



Views command (Options menu)

This command displays a dialog box that allows you to customize the start up behavior of 
SuperMonitor... Click on any of the dialog options for more help...



Open a new document

If this option is checked, then at the start of the program, SuperMonitor will automatically 
open a new document. If not checked, then you will have to manually open a new or existing
document before monitoring may begin.



Start scanning system

If this option is checked, then at the start of the program, SuperMonitor will automatically 
instruct the new document to start monitoring your system's resources. If not checked, then 
you will have to manually start your document.



Open views: Instants

If this option is checked, each document will automatically display your system's 
instantaneous (Instants) resource usage. If not checked, then you will have to manually open
this view through the Window menu.



Open views: Averages

If this option is checked, each document will automatically display your system's average 
(Averages) resource usage. If not checked, then you will have to manually open this view 
through the Window menu.



Open views: Minimums

If this option is checked, each document will automatically display your system's minimum 
(Minimums) resource usage. If not checked, then you will have to manually open this view 
through the Window menu.



Active view: Instants

This group of choices determines which view will automatically be made active when 
SuperMonitor first executes. Only one view may be selected.

This choice makes the Instants view be active upon program startup.



Active view: Averages

This group of choices determines which view will automatically be made active when 
SuperMonitor first executes. Only one view may be selected.

This choice makes the Averages view be active upon program startup.



Active view: Minimums

This group of choices determines which view will automatically be made active when 
SuperMonitor first executes. Only one view may be selected.

This choice makes the Minimums view be active upon program startup.



Arrange views by: Tile

If this option is checked, SuperMonitor will tile (side by side) your views upon program 
startup.



Arrange views by: Cascade

If this option is checked, SuperMonitor will cascade your views upon program startup.



Resources in each view: User

If checked, causes the User resource vertical usage bar to appear in all future document's 
views. If not checked, then the resource won't appear.

Checked resources always appear left to right within a view in the following order:
User, GDI, Memory, RAM, Virtual



Resources in each view: GDI

If checked, causes the GDI resource vertical usage bar to appear in all future document's 
views. If not checked, then the resource won't appear.

Checked resources always appear left to right within a view in the following order:
User, GDI, Memory, RAM, Virtual



Resources in each view: Memory

If checked, causes the Memory resource vertical usage bar to appear in all future 
document's views. If not checked, then the resource won't appear.

Checked resources always appear left to right within a view in the following order:
User, GDI, Memory, RAM, Virtual



Resources in each view: RAM

If checked, causes the RAM resource vertical usage bar to appear in all future document's 
views. If not checked, then the resource won't appear.

Checked resources always appear left to right within a view in the following order:
User, GDI, Memory, RAM, Virtual



Resources in each view: Virtual

If checked, causes the Virtual resource vertical usage bar to appear in all future document's 
views. If not checked, then the resource won't appear.

Checked resources always appear left to right within a view in the following order:
User, GDI, Memory, RAM, Virtual



View: Restore defaults

Pressing this button restores the dialog box options to the state that the program was 
shipped in.



View: OK

Saves your changes (if any) to the program's INI file and immediately alters the operation of 
the program.



View: Cancel

Disregards any changes that you made in this dialog box.



Start command (Actions menu, System menu, & Toolbar)

Selecting this command tells the active document to start monitoring your system 
resources.

Note that when SuperMonitor is minimized (as an icon) you can access its system menu 
and perform a variety of useful commands (Stay on Top, Start, Stop, etc.) without having to 
maximize SuperMonitor, issue the command, and then re-minimize it.

Shortcuts
Mouse: Click this button to start the active document.



Stop command (Actions menu, System menu, & Toolbar)

Selecting this command tells the active document to stop monitoring your system resources.

If the document was logging data to disk, this command stops the logging, and closes the 
disk file.

Note that when SuperMonitor is minimized (as an icon) you can access its system menu 
and perform a variety of useful commands (Stay on Top, Start, Stop, etc.) without having to 
maximize SuperMonitor, issue the command, and then re-minimize it.

Shortcuts
Mouse: Click this button to stop the active document.



Reset command (Actions menu, System menu, & Toolbar)

Selecting this command tells the active document to stop monitoring your system resources 
and then resets the document's data.

Note that when SuperMonitor is minimized (as an icon) you can access its system menu 
and perform a variety of useful commands (Stay on Top, Start, Stop, etc.) without having to 
maximize SuperMonitor, issue the command, and then re-minimize it.

Shortcuts
Mouse: Click this button to reset the active document.



Restart command (Actions menu, System menu, & Toolbar)

Selecting this command tells the active document to stop monitoring your system resources,
resets the document's data, and then starts again.

Note that when SuperMonitor is minimized (as an icon) you can access its system menu 
and perform a variety of useful commands (Stay on Top, Start, Stop, etc.) without having to 
maximize SuperMonitor, issue the command, and then re-minimize it.

Shortcuts
Mouse: Click this button to restart the active document.



New Instants Window command (Window menu)

This command opens a new Instants view for the active document. Only one view of this 
type may be opened per document.



New Averages Window command (Window menu)

This command opens a new Averages view for the active document. Only one view of this 
type may be opened per document.



New Minimums Window command (Window menu)

This command opens a new Minimums view for the active document. Only one view of this 
type may be opened per document.



Cascade command (Window menu)

Cascades (overlaps) all views of all documents on your screen.



Tile command (Window menu)

Tiles (displays side-by-side) all views of all documents on your screen.



Arrange Icons command (Window menu)

Arranges all iconic views on your screen.



Contents command (Help menu)

Use this command to display the opening screen of Help.    From the opening screen, you can jump to 
step-by-step instructions for using this program and various types of reference information.

Once you open Help, you can click the Contents button whenever you want to return to the opening 
screen.



Search for Help on... command (Help menu)

Use this command to search for help on a topic or keyword of your choosing.



Using Help command (Help menu)

Use this command for instructions about using Help.



Product Support command (Help menu)

SuperMonitor is NOT free. Unregistered evaluation versions may be freely shared. Registered, 
purchased versions may NOT be shared. Unregistered versions are limited to 3 minutes of consecutive 
monitoring per document. Purchased versions are fully functional.

Site licenses and quantity discounts are available upon request. Feel free to contact us for a complete 
description of all of TNT's 35 programs in the collection.

Tessler's Nifty Tools (TNT)    Release 5.0
430 Canyon Woods Place Suite A

San Ramon, Ca. 94583
(510) 244-5449

CompuServe: 71044,542
Internet:      71044.542@compuserve.com

More information on using this program may be found in the SuperMon.Doc or SuperMon.Txt files...



About command (Help menu & System menu)

Use this command to display the copyright notice and version number of your copy of this program.



Installation and removal instructions

To install:

Copy the following files to any single area of your PC's disk:

· SuperMon.exe
· SuperMon.hlp
· Super32.dll

A typical destination might be:    C:\TNT\SUPERMON

To uninstall:

Delete the above files along with SuperMon.ini from your Windows directory (typically c:\
windows).



Monitoring your system resources

SuperMonitor can monitor your system's USER, GDI, Memory, RAM, and Virtual memory 
resources. You can customize your views to show precisely the resources that you are 
interested in. See Views command (Option menu)    for more information.

SuperMonitor can display the following resource information each within its own view 
window:

·Instantaneous resource usage (in percent free) of your system.
· Average resource usage (in percent free) of your system.
· Minimum resource usage (in percent free) of your system.

Each view displays the resources that you chose above.

USER resource 
GUI (Graphics Device Interface) resource 
Memory resource 
RAM resource 
Virtual resource 



USER resource:

This is a 64 KByte resource that includes handles to windows and menu objects, etc.

The System Resources number reported by Program Manager's Help About dialog box 
reports the lower of the USER and GUI resources currently available.



GUI (Graphics Device Interface) resource:

This is a 64 KByte resource that includes handles to brushes, pens, bitmaps, device 
contexts, and regions, etc.

The System Resources number reported by Program Manager's Help About dialog box 
reports the lower of the USER and GDI resources currently available.



Memory resource:

This is the summation of real physical memory and virtual memory which is your swap file 
located on your fixed disk.



RAM resource:

RAM (random access memory) is the physical memory chips installed in your PC. Real 
physical memory is significantly faster than virtual disk based memory. In systems that don't
have enough physical memory installed, Windows must swap programs in and out of real 
memory and into the virtual memory which slows down your applications.

SuperMonitor is ideal for users and PC administrators need to determine how much 
physical memory to purchase for the user's PC. Simply monitor the RAM and Virtual 
resources!



Virtual resource:

This is pseudo memory that Windows creates from your disk swap file in 386-enhanced 
mode. Programs don't actually execute in virtual memory. Programs only execute in real 
physical RAM memory. Programs are swapped to RAM physical memory when they need to 
execute, and are swapped to virtual memory when Windows is low on RAM physical memory 
and needs more free RAM physical memory.



Resource colors and what it all means

SuperMonitor's vertical resource status bars change color based upon their percentage 
free level. The colors and their meanings are as follows:

Color % free Resource condition
Gree
n

60 - 100 Excellent

Yello
w

30 - 59 Fair

Red 0 - 29 Critical

Resources that become red may cause instability in Windows...



Reported resource usage accuracy

SuperMonitor accurately reports USER, GDI and Memory utilization because Windows 
provides well-documented resource information to SuperMonitor.

In order to compute RAM and Virtual memory utilization, SuperMonitor must resort to using
poorly documented Windows functions that do not behave as well as they should. 

SuperMonitor usually reports 100% accurate resource utilization numbers, but occasionally
its RAM and Virtual answers are off by 1-5% by stating that you are using more memory than
you actually using. This small error should be insignificant in your assessment of your PC's 
resource usage.

If Microsoft improves their functions, we will immediately incorporate them into 
SuperMonitor and will notify you of the upgraded product. Thank you for understanding...



Evaluation program limitations

Evaluation versions of SuperMonitor are fully functional except that each document is 
limited to three consecutive minutes of system resource monitoring. After three minutes, 
SuperMonitor will automatically stop the document. The document can not be restarted. 
You may however, open a new document and monitor your system for another three 
minutes. You may freely share unregistered evaluation versions of SuperMonitor.

Remember! Purchased SuperMonitor programs are not limited in any way. You may not 
share purchased copies of SuperMonitor.



Scan system every N milliseconds

Determines how often SuperMonitor will attempt to monitor your system's resources. 

In order to "catch" resource allocation "spikes", we recommend that you monitor your 
system every 50 milliseconds. Slow PCs may not be able to monitor every 50 milliseconds, 
but will automatically monitor as fast as possible.



Update display after N consecutive scans

Determines how often SuperMonitor will update its display with current resource usage 
statistics. To reduce SuperMonitor processor overhead on your PC's CPU, we recommend 
that you update your display as infrequently as possible. If you only need to see updated 
statistics every one second, don't update more frequently. At 50 milliseconds, sample rate, 
the default display update after 18 scans is equal to approximately once every second (18 * 
50 = 900 msec).



Log to disk after N consecutive scans

Determines how often SuperMonitor will write a snapshot of your system's resource 
utilization to your disk log file. The less frequent you write to disk, the smaller your log file 
will be. At 50 milliseconds, sample rate, logging to disk after 18 scans is equal to 
approximately once every second (18 * 50 = 900 msec).

Remember: You must enable logging to disk through the Options    dialog box.



Rates: OK

Saves your changes (if any) to the program's INI file and immediately alters the operation of 
the program.



Rates: Cancel

Disregards any changes that you made in this dialog box.



Rates: Restore defaults

Pressing this button restores the dialog box options to the state that the program was 
shipped in.



Log (save) data to disk

Checking this box enables logging of system resource usage to a disk file. The name of the 
disk file is the name of the document. To change the name of the log file, rename your 
document via the Save As command.



Save to disk via: Fast writes

Select this option for fast disk writes. If your Windows session crashes while you happen to 
be logging to disk, your SuperMonitor log file will most likely be empty and your collected 
data will be lost. For safer but slower logging, see Save to disk via: Slow writes .



Save to disk via: Slow writes

Select this option for slow (safe) disk writes. If your Windows session crashes while you 
happen to be logging to disk, your SuperMonitor log file will most likely still contain your 
data.

Only use this option if you have Windows stability problems. Slow writes significantly slows
down your data logging rate. For faster but less safe logging, see Save to disk via: Fast 
writes .



Include log file name and time stamp

Check this box to include the name of the log time and the date and time of its creation at 
the top of your log file.



Include installed memory summary

Check this box to include a summary of the amount of memory in your system at the top of 
your log file.



Include field headers

Check this box to include descriptions of the data fields that will appear in your log file. 
These descriptions help you understand the columns of data that you are analyzing.



Data delimiter: Commas

Select this option for a comma delimited log file. When importing this file into your 
spreadsheet, tell your spreadsheet that the delimiter is a comma.



Data delimiters: Spaces

Select this option for a space delimited log file. When importing this file into your 
spreadsheet, tell your spreadsheet that the delimiter is a space.



Data delimiters: Tabs

Select this option for a tab delimited log file. When importing this file into your spreadsheet, 
tell your spreadsheet that the delimiter is a tab.



Save in units of: Bytes

Select this option when you need a high degree of accuracy in your data. This high degree of
accuracy significantly increases the size of your log file. Since most people don't need this 
precision, don't use it unless you need it. The data is reported in units of bytes -like 
16462643 rather than in megabytes which would be 15.7 .



Save in units of: MBytes

Select this option when you need a less accurate reporting of your data. This setting is best 
for most people. The data is reported in units of megabytes -like 15.7 rather than in bytes 
which would be 16462643.



What to save: Instants

Brings up the Instants resource data fields dialog box where you may choose which fields to 
actually log to disk.



What to save: Averages

Brings up the Averages resource data fields dialog box where you may choose which fields 
to actually log to disk.



What to save: Minimums

Brings up the Minimums resource data fields dialog box where you may choose which fields 
to actually log to disk.



Log data: OK

Saves your changes (if any) to the program's INI file and immediately alters the operation of 
the program.



Log data: Cancel

Disregards any changes that you made in this dialog box.



Choosing the optimal monitoring, updating, and logging rates

The following options in the Log to disk    dialog box discuss optimal rates:

Scan system every N milliseconds 
Update display after N consecutive scans 
Log to disk after N consecutive scans 



What you want is exactly what you see -customizing your views

The Views command (Option menu) dialog box discuss viewing exactly what and only what 
you want to monitor.



How to use SuperMonitor's multiple document capabilities to determine exactly 
how much resources a specific program uses

Since SuperMonitor monitors your overall system resources at any moment in time, you 
might think that its impossible to determine the exact resource requirements of a 
specific program. Well, you're wrong!

By opening multiple documents and starting multiple monitoring sessions, you can precisely 
determine any program's resource requirements by performing the following steps:

1. Open a new document and for the sake of this example, call it BaseDoc1.
2. Command BaseDoc1 to start monitoring.
3. Command BaseDoc1 to stop monitoring. This document's views now show

 baseline resource levels before running your program.
4. Open another new document and for the sake of this example, call it Doc2.
5. Command Doc2 to start monitoring.
6. Execute your program and use it for as long as you wish.
7. When you are ready to terminate your program, stop Doc2 from monitoring.
8. Exit your program.

The exact resources that your program required may be determined by subtracting Doc2 
values from BaseDoc1 (for example, if BaseDoc1 had 75% GDI free, and Doc2 had 70% GDI 
free, then your program required 75 - 70 = 5% GDI). Cool!



Windows 95 and Windows NT issues

Windows 95 resource usage more closely mirrors Windows NT than Windows 3.1 !

In Windows 3.1, your "Memory" resource was defined as an approximate summation of the 
available memory in RAM and in virtual memory (swap file). Per Microsoft, in Windows 95 
and NT, the "Memory" resource is now the amount of memory available in the global heap. 
Don't expect to see the same "Memory" free values in Windows 95 and NT as you often saw 
in Windows 3.1 .

In Windows 3.1, the virtual memory (swap file) was fixed in size. In Windows 95, you can 
either choose to have a fixed size swap file or let Windows 95/NT manage your swap file. In 
Windows NT, it is always variable. If you let Windows 95 manage your swap file, the size of 
your swap file is equal to the amount of free disk space on your hard disk. Windows 95/NT 
will shrink the swap file when another application needs more disk space. If you are using 
dynamic swap file sizing, and are logging your swap file usage percentages rather than the 
actual bytes used to disk, you might want to include the size of the swap file in your log file 
so that your percentages can reference the size of the swap file at the time of the data 
sampling.

 




