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Requirements
When opening a form saved in an InForms Designer version later than 1.0b, InForms 
Diagnostics requires that the APPINFO.DLL file which matches the version of InForms Designer
that saved the form, be in the same directory as INDIAG.EXE.    Otherwise the form won’t be 
opened and an error message will be displayed.

NOTE: This DLL is only provided with the InForms Designer program.

Startup Options
/WPC Points to the path where shared code is located.      InForms Diagnostics uses 

Shared Code version 2.x.    

Example /wpc-c:\office\shared\wpc20



Menu Options
File

Open
Save Info
View File
File Manager
Designer
Filler
Custom Reports
Print all Form Info
File Info
Preferences
          Environment
          Location of Files
Exit

Format
Form Layout

Define
Object Definition
Formulas
Data Links
Form Fill Options

Tools
Object Library
GroupWare Support Center



File, Open

Purpose:
Use Open to retrieve a form into InForms Diagnostic.    You will be able to open one form at a 
time.    The supported file formats are 1.0 through 4.1.

Steps:
1- Choose Open from the File menu or the Button Bar.
2- Select the drive and directory you want to list the files in.
3- Select the file you want or Type the full path and file name to the form you wish to open.
4- Choose Open.



File, Save Info

Purpose:
Use Save Info to save your form information to an ASCII text file.    All information about the form
will be saved.

Steps:
1- Choose Save Info from the File menu or the Button Bar.
2- Select the drive and directory where you want to save the file.
3- Choose Save Info.

See Also:
Custom Reports



File, View File

Purpose:
To show what the form you currently have open looks like.

Steps:
1- Choose View File from the File menu or View from the Button Bar.
2- Double click on the control icon on the top left to close the window.



File, File Manager

Purpose:
Launches the file manager selected in preferences.    You have the choice of launching any file 
manager or other program by selecting that program in preferences.

Steps:
1 - Choose File Manager from the File menu or the Button Bar.

See also:
Preferences, Environment



File, Designer

Purpose:
Launches Designer, loading the form that is currently open in InForms Diagnostics.    InForms 
Diagnostics will read the path in Preferences, Location of Files to find where the Designer is 
located. 

Steps:
1 - Choose Designer from the File menu or Button Bar.

See also:
Preferences, Location of Files



File, Filler

Purpose:
Launches Filler, loading the form that is currently open in InForms Diagnostics.    InForms 
Diagnostics will read the path in Preferences Location of Files to find where the Filler is located.

Steps:
1 - Choose Filler from the File menu or the Button Bar.

See also:
Preferences, Location of Files



File, Custom Reports

Purpose:
Use Custom Reports to build a specific report that will have only the information you want to 
print or save.

Steps:
1- Choose Custom Reports from the File menu or the Power Bar.    
2- Select the item(s) you would like printed or saved by clicking on that item. 
3- Choose Add to add the selected items.    Choose Add All to add all the items.

You may choose from any of the following items:
File Information--
Form Information--
Form Fill Options--
Printer Information--
Data Link Information--
Object Field Name Information--
Object Label Information--
Object Type Information--
Object Data Type Information--
Object Default Value Information--
Control Attributes Information--
Object Formula Status Information--
Object Formula Text Information--

4- Choose Print or Save to File.

If you wish to remove items from the custom report list, select the item you would like removed 
and choose Remove to remove the selected items or Remove All to remove all items from the 
custom report list.

See also:
Print all Form Info
Save Info



File, Print all Form Info

Purpose:
Prints all of the forms information in landscape or portrait.

Steps:
1- Choose Print all Form Info from the File menu or Button Bar.
2- Select the printer you wish to send the file to.
3- Choose Print.

Orientation--Allows you to print the document Portrait or Landscape.
Select--Allows you to select the desired printer.

See Also:
Custom Reports



File, File Info

Purpose:
Provides file information such as:
- Date and Time the file was created
- Size of the file
- Version the form was created in
- If the form contains DOS Filler information
- If the form contains any object libraries
- Version of OEM DLL file, if the form was created using the APPINFO.DLL

Steps:
Choose File Info from the File menu or the Power Bar. 



File, Preferences

Purpose:
Use Preferences to set options that are in effect each time you start InForms Diagnostics.

Steps:
1- Choose Preferences from the File menu.
2- Choose from the following options:

Environment
List
Location of Files



File, Preferences, Environment

Purpose:
Use Preferences Environment to choose which File Manager you wish to launch and to select 
the different help options.

Steps:
1- Choose Preferences under the File menu and double click on Environment.
2- Choose from the following options:

File Manager Program--Allows you to specify a path to the file manager you wish to open 
when the File Manager option is chosen from the File menu.    This path is not restricted to file
managers only.    If you wish to launch a different program, you may specify the path to that 
program.
Show top-line help prompts--When marked, displays long prompts when the mouse 
passes over that item (i.e. Button Bar, Power Bar, Editable screen boxes, etc.).
Show QuickTips--When marked, displays a pop-up long prompt when the mouse passes 
over that item (i.e. Button Bar, Power Bar, Editable screen boxes, etc.).

3- Choose OK



File, Preferences, List

Purpose:
Use Preferences List to choose which information you would like displayed and in what order 
you would like it listed.

Steps:
1- Choose Preferences from the File menu and double click on List.
2- Choose from the following options:

Information to Display
Show All form Information--List all objects in the form.
Show only objects with Formulas--Lists only those objects that contain Formulas, whether 
the Formula is invalid or valid.
Show only Main object types--Shows only those objects that you can interact with.    
Excluding all drawing objects.
Sort Order
Sort by Creation order for each page--Sorts the field objects by the order they were 
created in for each page.
Sort by Tab order for each page--Sorts the field objects by the Tab Order defined in 
Designer.    (See also: Tab Order in Designer on-line help)
Sort alphabetically by Field Name--Sorts the field objects alphabetically by field name, 
NOT label name, for each page.
Sort by Object type--Sorts the field objects alphabetically by field type.

3- Choose OK

You may also access the list preferences by clicking on the List Preferences button located in 
the lower left corner of the Main window.    However, changing the list preferences here only 
changes the listing for the current session.    It will not change the preferences permanently.



File, Preferences, Location of Files

Purpose:
Use Preferences Location of Files to designate where Designer, Filler, and the Forms are 

located.

Steps:
1- Choose Preferences from the File menu and double click on Location of Files.
2- Click on the File button to the right of the option you wish to set the path for.
3- Select the correct directory and .EXE file name for the program.    (Forms and Database Files

will not allow a file to be selected. You need only select the desired directory)
4- Click on Select.
5- If all paths are set correctly click on OK.



File, Exit

Purpose:
Exits the InForms Diagnostics program.

Steps:
1- Choose Exit from the File menu or the Button Bar.



Format, Form Layout
Purpose:
Display the layout features of the form that is opened.    Form Layout features include:

Sculpted Form
Print Orientation
Margins
Pages
Layout Name
Form Size

Steps:
1- Choose Form Layout from the Format menu.



Define, Object Definition

Purpose:
Displays the definition of the object.    Definitions include:

Name
Label
Default Value
Data Type
Control Attributes
Input Attributes

Steps:
1- Choose Object Definition from the Define menu.

You may also access Object Definition by clicking on the Object Definition button located in the 
bottom center of the Main window or by double clicking on the form object in the Form Object
list.



Define, Formulas
Purpose:
Displays the Formula(s) for the selected field.

Steps:
1- Highlight the desired field in the Form Objects List on the Main window.    If the field text is 

Red, then there is an invalid formula on that form object.    If the text is Blue, then all formulas
on that field are valid.    If the text is Black, there are no formulas defined on that form object.

2- Choose Formulas from the Define menu

You may View all Formulas or view each Formula individually.    The word Valid will appear to 
the right of each Formula that you may view.

To View All Formulas--Click on the View All Formulas button.    All Formulas will be 
displayed in the Formula display box.    If there is only one Formula on the selected object, 
the View All Formulas button will be greyed out and not selectable.
To view each Formula individually--Click on the corresponding Formula button (i.e. Entry, 
Exit, Action, Change, Close, or Open).    If there is only one Formula on the selected object, 
all buttons will be greyed out and not selectable.    If there is more that one Formula for the 
selected object, the word Valid will appear to the right of the button you may select.

You may also choose to print all of the Formulas for that object.

To Print the Formula--Click on the Print Formula button.    Only the Formula(s) that are 
displayed will print.

You may also view the Formulas by clicking on the View button located in the middle of the Main
window, in the Formulas box.



Define, Data Links
Purpose:
Displays all data link information.    Link information includes:

Number of Links
Link Names
Access Type

Database Type
Filename
Multi-Record Link

Total Linked Form Objects
Form Object Names

Field Link Types
Linked Form Objects
Database Field Data Type (only with 4.1 format)

Steps:
1- Choose Data Links from the Define menu, or the Power Bar.
2- Click on the link name you would like to view.
3- If the link is a Multi-Record link, the Multi-Record Link information button will appear.    

Click on this button or double-click on the link name in the Link list box to view the Multi- Record
Link information.

You may also access the Data Links by clicking on the Data Links button on the lower right corner 
of the Main window.

For further information on the Object/Data Type abbreviations, see Link 
Abbreviations. 

See also Databas Data Typesfor information on the corresponding database field 
formats that InForms links to.



Define, Form Fill Options
Purpose:
Display the options selected for this form when it is opened in Filler.    Form Fill Options include:

Hide Menus in Filler
Disable Database Menu in Filler
Allow Database Creation in Filler
Link to Files in Specified Locations Only
Auto-Incrementing Field Action
Form State After Add/Update
Record State after Add/Update
Action When Entering Multi-Record Tables
Delete Child Record When Parent Record is Deleted

Steps:
1- Choose Form Fill Options from the Define menu.



Tools, Object Library

Purpose:
Displays the form objects that each library object is linked to.

Steps:
1- Choose Object Library from the Tools menu or from the Power Bar. 

See also:
Object Library in the Designer documentation.



Tools, Support Information
Purpose:
Launches the GSC.EXE program.    This program displays important troubleshooting information
about the Novell’s GroupWare environment.    GSC.EXE must be in the same directory as 
InForms Diagnostics.

Steps:
1- Choose GroupWare Support Center from the Tools menu.



Main Window Controls
Form Object
Purpose:
Displays all form objects by page.    By clicking on an object in the Form Object list, you will 
display the following information for the highlighted object:

Label
Default Value
Object Type
Data Type
Format
Length
Formulas

Some objects do not have all of the above information.    Only information pertaining to that 
object will be displayed.

Steps
1- Click on the form object in the Form Object list.

Button Bar
Purpose:
Provides easier access to features.    The Button Bar contains the following features:

Exit
Save Info
Open
File Manager (FileMan)
Print
View
Designer
Filler

Steps:
1- Click on the desired button to activate that feature.

Power Bar
Purpose:
Provides easier access to features.    The Power Bar contains the following features:

Custom Reports 
File Information
Form Layout
Object Library
Form Fill Options

Steps:
1- Click on the desired button to activate that feature.

Main window Information



Objects--Displays the total number of objects in the form including drawing objects.
Data Objects--Total number of data objects in the form.    Excludes drawing objects such as: 

circle, square, text box, etc.
Total Formulas--Total number of Formulas in the form.
Indep. Formulas--Total number of Independent Formulas in the form.
Invalid Formulas--Total number of Formula that are invalid.
Links to Forms--Total number of Data Links that are Form to Form link types.
Data Links--Total number of all Data Links including Form to Form link types.
Printer--Displays the printer that is currently saved within the form.
Printer Driver File--Displays the name of the .DRV file for the printer that is currently saved 

with the form.



Database Data Types InForms Links To:

Database Format:

ASCII
Btrieve
Clipper
DataPerfect
dBase III+
dBase IV
dBase Windows
FoxPro
ODBC
Paradox 3.5
Paradox 4.0
Paradox 5.0
Secondary Merge



Paradox 3.5
* Indicates the data type is different than in InForms

Text Text
Memo Fixed *Text[255]
Memo (32000)
Small Integer Small
Large Integer Large
Small Decimal *Large
Large Decimal Large
Check Box (Logical) *Small
Date Date
Time *Text[11]
Date and Time *Text[22]
Custom Data Format *Text
Auto-Incrementing *Text
Signature *Text[254]



Paradox 4.0
* Indicates the data type is different than in InForms

Text Text
Memo Fixed Text[255]
Memo (32000)
Small Integer *Small
Large Integer Large
Small Decimal *Large
Large Decimal Large
Check Box (Logical) *Small
Date Date
Time *Text[11]
Date and Time *Text[22]
Custom Data Format *Text
Auto-Incrementing *Text
Signature *Text[254]



Paradox 5.0
* Indicates the data type is different than in InForms

Text Text
Memo Fixed Memo
Memo (32000) Memo
Small Integer *Large
Large Integer Large
Small Decimal *Large
Large Decimal Large
Check Box (Logical) Logical
Date Date
Time *Text[11]
Date and Time *Text[22]
Custom Data Format *Text
Auto-Incrementing *Text
Signature *Text[254]



dBase IV 2.0
* Indicates the data type is different than in InForms

Text Text
Memo Fixed Memo
Memo (32000) Memo
Small Integer *Large
Large Integer Large
Small Decimal *Large
Large Decimal Large
Check Box (Logical) Logical
Date Date
Time *Text[11]
Date and Time *Text[22]
Custom Data Format *Text
Auto-Incrementing *Text
Signature *Text[254]



dBase III+
* Indicates the data type is different than in InForms

Text Text
Memo Fixed Memo
Memo (32000) Memo
Small Integer *Large
Large Integer Large
Small Decimal *Large
Large Decimal Large
Check Box (Logical) Logical
Date Date
Time *Text[11]
Date and Time *Text[22]
Custom Data Format *Text
Auto-Incrementing *Text
Signature *Text[254]



dBase Windows
* Indicates the data type is different than in InForms

Text Text
Memo Fixed Memo
Memo (32000) Memo
Small Integer *Large
Large Integer Large
Small Decimal *Large
Large Decimal Large
Check Box (Logical) Logical
Date Date
Time *Text[11]
Date and Time *Text[22]
Custom Data Format *Text
Auto-Incrementing *Text
Signature *Text[254]



ODBC
* Indicates the data type is different than in InForms

Text Text
Memo Fixed Memo
Memo (32000) Memo
Small Integer Small
Large Integer Large
Small Decimal Small
Large Decimal Large
Check Box (Logical) Logical
Date *Text[16]
Time *Text[16]
Date and Time *Text[16]
Custom Data Format *Text
Auto-Incrementing *Text
Signature *Text[254]



Secondary Merge
* Indicates the data type is different than in InForms

Text Text variable length
Memo Fixed Text variable length
Memo (32000) Text variable length
Small Integer Text variable length
Large Integer Text variable length
Small Decimal Text variable length
Large Decimal Text variable length
Check Box (Logical) Text variable length
Date Text variable length
Time Text variable length
Date and Time Text variable length
Custom Data Format Text variable length
Auto-Incrementing Text variable length
Signature Text variable length



ASCII
* Indicates the data type is different than in InForms

Text Text variable length
Memo Fixed Text variable length
Memo (32000) Text variable length
Small Integer Text variable length
Large Integer Text variable length
Small Decimal Text variable length
Large Decimal Text variable length
Check Box (Logical) Text variable length
Date Text variable length
Time Text variable length
Date and Time Text variable length
Custom Data Format Text variable length
Auto-Incrementing Text variable length
Signature Text variable length



Btrieve
* Indicates the data type is different than in InForms

Text Text
Memo Fixed Memo
Memo (32000) Memo
Small Integer Small
Large Integer Large
Small Decimal Small
Large Decimal Large
Check Box (Logical) Logical
Date Date
Time *Text[4]
Date and Time *Text[22]
Custom Data Format *Text
Auto-Incrementing *Text
Signature ??S



Clipper
* Indicates the data type is different than in InForms

Text Text
Memo Fixed Memo
Memo (32000) Memo
Small Integer *Large
Large Integer Large
Small Decimal *Large
Large Decimal Large
Check Box (Logical) Logical
Date Date
Time *Text[11]
Date and Time *Text[22]
Custom Data Format *Text
Auto-Incrementing *Text
Signature *Text[254]



FoxPro
* Indicates the data type is different than in InForms

Text Text
Memo Fixed Memo
Memo (32000) Memo
Small Integer *Large
Large Integer Large
Small Decimal *Large
Large Decimal Large
Check Box (Logical) Logical
Date Date
Time *Text[11]
Date and Time *Text[22]
Custom Data Format *Text
Auto-Incrementing *Text
Signature *Text[254]



DataPerfect
* Indicates the data type is different than in InForms

Text Text
Memo Fixed Memo
Memo (32000) Memo
Small Integer *Large
Large Integer Large
Small Decimal *Large
Large Decimal Large
Check Box (Logical) *Text[1]
Date Date
Time *Text[8]
Date and Time *Text[22]
Custom Data Format *Text
Auto-Incrementing *Text
Signature *Memo



 
Text Text
Memo Fixed Memo
Memo (32000) Memo
Small Integer *Large
Large Integer Large
Small Decimal *Large
Large Decimal Large
Check Box (Logical) Logical
Date Date
Time *Text[11]
Date and Time *Text[22]
Custom Data Format *Text
Auto-Incrementing *Text
Signature *Text[254]



Form Object Abbreviations:

Form Object Type Abbreviation

Entry Field E
Drop-Down List Box D
Check Box C
Radio Button R
Table Cell T



Object Type Abbreviations

Data Type Abbreviation

Text T
Memo Fixed M
Memo (32000) M
Small Integer S
Large Integer L
Small Decimal S
Large Decimal L
Check Box (Logical) Y
Date D
Time t
Date and Time d
Custom Data Format C
Auto-Incrementing A
Signature s

NOTE: Text data types will have brackets to specify the length of the text data type.    

T[12] has a length of 12 characters
T[...] is a variable length field




