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 · Welcome to Image Editor

The Image Editor program is dedicated
towards enhancing and editing image files.
With a comprehensive range of image processing
commands and tools you can easily create,
compose, change and improve any type of
image – from Black & White to True Color.
Unique new features such as the object pool and
extensive drag-and-drop support make Image
Editor the most convenient and efficient image
editing program available today.
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How to get the most from Image Editor

Reading this guide is not the only way you can learn

about Image Editor: the introductory guide provides useful

background information that will help you work more efficiently

while the ReadMe file contains technical information and

anything that came to light after this manual was produced.

Lastly, the on-line help provides the most complete and

in-depth reference to Image Editor. You can access help from

the program by pressing the F1 key or clicking on the help

button provided in certain dialog boxes.

This guide introduces Image Editor’s functions and provides

examples to illustrate their use as follows:

1. Getting started, introduces the Image Editor program window
and provides a reference to the menu commands and tools.

2. Managing images, describes basic Image Editor functions such
as creating, opening, saving and viewing image files.

3. Image Editor basics, explains how to apply commands and
highlights drag-and-drop operations. There are also sections on
using the clipboard and setting the Image Editor Preferences.

4. Making selections, shows you how to select areas of an image,
save and load these areas as masks, and use the object pool.

5. Manipulating images, explains how to change an image’s
dimensions, resolution and data type and provides descriptions
of transformation commands such as rotate and flip.

6. Painting, takes a look at working with colors and how you can
apply those colors to images. There is also a section on editing
the color tables of Indexed-Color images.

7. Enhancing images, describes how you can “touch–up” images
by adjusting and correcting the color values of pixels. There is
also a section on creating and using a variety of special effects.

8. Image input & stitching, introduces the different sources from
which you can obtain images and explains how to stitch images.

• Index
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1 Getting started

This chapter explains how to run Image Editor
and introduces the Image Editor program
window. After the introductory section there is a
brief explanation of the menus, as well as tables
referencing where in this guide you will find
descriptions about menu commands and tools.
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1·1
Running Image Editor

To run Image Editor, you first need to locate the appropriate

program icon. If you followed the suggestions made by the

installation program, the Image Editor icon will appear in the

ImagePals program group.

The ImagePals
program group

Run Image Editor by double-clicking on the Image Editor icon.

The program window appears containing the product

information box. (Clicking anywhere within the program

window removes the product information box and enables

Image Editor.)

1.1.1 The Image Editor window

When you invoke Image Editor you may see:

• Images in individual windows within the workspace of the
Image Editor window (the central portion).

• The toolbar, on the left, containing the tools necessary to create
selection areas, paint and edit images.

• The color palette, on the right, displaying available colors as well
as access to the size and shape of paintbrushes and the object
pool.

• The status bar, at the bottom, where information about the
current image as well as menu command and tool messages
appear.
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The Image Editor program window
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1·2
The Image Editor menus

One of the most common methods of applying operations to an

image is to choose a command from the menu bar. In Image

Editor certain commands can also be accessed through the

menu button on the status bar or from a pop-up menu that

appears when you click the right mouse button when on an

image.

When you view menus, some commands appear in black while

others are grayed-out. (The actual colors depend on your

current Windows color scheme.) Commands in black are active

and available for selection while grayed-out commands are

inactive and unavailable for selection.

Note: A command may be inactive because it is not currently
applicable, e.g. when there are no images open the Close
command is inactive, or when your PC does not have the
necessary hardware to support that particular function.

In each drop-down menu, keyboard shortcuts appear to

the right of some of the menu commands. These allow

you to perform the corresponding command from the keyboard

– without the need to access the menu with your mouse.

After many commands you will see a right-pointing arrow or

three dots. The arrow signifies that a submenu exists for that

command while the dots indicate the command accesses a

dialog box. If a command has neither of these, then its effect is

immediate.

1.2.1 Command and tool reference tables

The following tables provide a list of all Image Editor’s

commands and tools. In each table, to the right of the command

or tool name, you will find any shortcut keys available and the

number of the page on which they are described.
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File menu Edit menu

Command shortcut p. Command shortcut p.

New... 18 Undo Ctrl + Z 34

Open... Ctrl + O 16 Cut Ctrl + X 35
Restore 34 Copy Ctrl + C 35
Close 24 Paste

As Selection

Into Selection

Ctrl + V 36

36

Save Ctrl + S 21

Save As... 22

Batch Manager... 32 Clear Del 93

Acquire... 130 Clipboard

Load...

Save...

Display...

37

37

37

Source

Select...

Auto Tone Adjustment

Brightness & Contrast..

Tone Adjustment...

Tone Mapper...

Scan to Printer...

130

131

131

131

131

131

Select

None

All

Invert

Border...

Similar...

Make Floating

Discard Floating

Merge Control...

Load Mask...

Save Mask...

Ctrl + N

Ctrl + L

F3

F4

49

18

55

58

57

49

49

59

65

63

Import 129

Export 129

Print... Ctrl + P 22

Printer Setup... 22

Preferences

Image Editor...

OLE & Clipboard...

Photo CD...

Display...

Memory...

File Formats...

F6 42

44

44

45

46

46

Crop Ctrl + R 69

Fill... Ctrl + F 91

Stitch... Ctrl + T 134

Tile Two Images... 132

Exit Ctrl + Q 24
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Image menu Effect menu

Command shortcut p. Command shortcut p.

Tone Mapper... 108 Blur

Slightly

More

Heavily

113

113

113

Tone Adjustment... Ctrl + J 106

Brightness & Contrast... Ctrl + B 109

Hue & Saturation... Ctrl + H 110

Invert F7 110 Sharpen

Slightly

More

Strongly

114

114

114

Level Adjustment... F8 111

Optimize F9 112

Convert

Black & White

Grayscale

Indexed 16-Color

Indexed 256-Color

RGB True Color

80

82

83

84

83

Despeckle 115

Emphasize Edges 115

Find Edges 116

Adjust for NTSC 116

Special Effects... Ctrl + E 119

Duplicate Ctrl + D 18 Warping... 117

Custom Filter... 118Resample... Ctrl + M 71

Free Resize 72Resolution... 70

Flip

Horizontal

Vertical

73

73

Rotate

Left 90°

Right 90°

180°

Freely

Degree...

by Horizontal Line

by Vertical Line

Ctrl + G

74

74

74

74

74

74

74

Slant 77

Distort 78

Set as Wallpaper 119
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View menu Stitch mode menus

Command shortcut p. Action menu

Add a View Ctrl + I 25 Command shortcut p.
Actual View Ctrl + A 28 Auto Stitch... 135
Zoom In + 26 Done 135
Zoom Out - 26 Quit Ctrl + X 135
Fit in Window 27

View menu
Full Screen Ctrl + W 28

Image Information... 30
Command shortcut p.System Information... 30

Actual View Ctrl + A 136Color Table... 89

Zoom In + 136Options

Hide Toolbar

Hide Color Palette

Hide Status Bar

Show Global Viewer

Show Object Pool

Show Rulers

30

30

30

28

61

30

Zoom Out - 136

Transparency... 136

Option menu

Command shortcut p.

Auto Fine Tune 136

Window menu

Command shortcut p.

Cascade Shift + F5 20

Tile Shift + F4 20

Arrange Icons 20
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Toolbar index

Tool p. double-click click on image with:
on icon left mouse button right mouse button

50 options select new area or
move existing one

pop-up menu

52 select none select new area or
move existing one

pop-up menu

53 options select new area or
move existing one

pop-up menu

53 options select new area or
move existing one

pop-up menu

54 select none move marquee

87 select color choose foreground
color

choose background
color

27 actual view zoom in/out actual view

95 options apply effect

97 options apply foreground
color

apply background
color

98 options apply effectapply
effect

99 options apply foreground
color

apply background
color

100 options apply foreground
color

apply background
color

101 options apply effect apply
effect

102 options options
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2 Managing images

This chapter and the next cover some of the more
common functions you will use when working
with images. They do not tell you how to perform
complicated image editing or enhancing, but do
provide basic information that will help you
establish a good and efficient working method.

In this chapter you will find two sections: the first
describes basic maintenance commands such as
Open and Close; the second deals with the ways
you can view images, information and elements
of the interface.
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2·1
The basics

All Windows programs provide some basic commands that have

a lot in common – and, if you are familiar with Windows, you

will already know how to use commands such as Open, Save

and Print. This section describes the Image Editor Open,

Duplicate, New, Save As, Print, Close and Exit commands

highlighting, where necessary, any ways they differ from other

programs.

2.1.1 Opening image files

After installation you will find a number of files in the SAMPLES

subdirectory under your installation directory. To open these

files, or other image and graphics files, choose the Open

command in the File menu. The Open dialog box appears

displaying files of the current type shown in the List Files of Type

combo box. To open a file simply click on its filename and press

OK. (Double-clicking on the filename also opens the file.) The

dialog box closes and the file is opened in the Image Editor

workspace.

When you select a file, its information and contents (where

possible) are displayed at the bottom of the dialog box. Some

files may not display automatically, in such cases click on the

Preview button to display the contents of the file.

Notes:

• When you open a graphics file, which does not contain bitmap
data, it is converted into an image and opens in an untitled
window. (The data type of this image is the same as your current
display mode). You can then edit it in the same way as other
images.

• You can also open the files you have most recently been
working on by choosing their names from the list at the bottom
of the File menu.
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An image window

Opening multiple files

One of the advantages of Image Editor is that it allows you to

open multiple images in one go. You can also open images from

the Album program of ImagePals or Windows File Manager. To

open multiple images:

• in the Image Editor Open dialog box, use the Shift key in
conjunction with your mouse to select a range of files or the Ctrl
key to select, or deselect, individual files. (You can also drag your
mouse over the filenames to select them.) Once selected click
OK. The images open in individual windows in the program
workspace.

• from ImagePals Album, select multiple thumbnails and drag
them to Image Editor’s icon in the Album toolbox, or to Image
Editor’s workspace or minimized program icon. This invokes
Image Editor and automatically opens the files in the Image
Editor workspace.

• from Windows File Manager,  drag-and-drop image files in the
same way as from ImagePals Album.
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2.1.2 Duplicating images

When working with images you often need to make a copy of the

active image. This allows you to continue editing without any

danger of losing a particular stage of your work. You can also

retain copies to compare images at different stages of your

editing, helping you see the effects of particular commands.

When you create a duplicate image it opens in a new untitled

window that becomes the active window.

You can create a duplicate image in a number of ways:

• choose the Duplicate command in the Image menu.

• use the Ctrl + D shortcut key.

• choose the All command in the Edit: Select submenu to select
the entire image and drag the selection into the open
workspace.

2.1.3 Creating a new image

In many cases your images will have been obtained with some

sort of image input device like a scanner or frame grabber, or

you will have opened them from a CD or hard drive. At other

times you will want to start with a “clean” image window for

compiling elements of other images together or for using the

painting tools of Image Editor.
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To create a new image:

1. Choose “New” from the File menu. The New dialog box appears.

2. In the Data Type combo box, choose the data type of the new
image. (For more information on data types see the introductory
guide.)

3. Select an image size.

To choose a pre-defined size click on one of the Standard
options. To define your own size, click on the User Defined
option and enter values for both the width and height. Clicking
the Active Image option creates an image the same size as the
active image in the workspace. (This is unavailable when there
are no open images.) The Current Clipboard option creates an
image the same size as the image on the clipboard. (This is
unavailable when there is no image on the clipboard.)

4. Enter a value for the image’s resolution.

Note: If the Unit of Measure option in the Image Editor dialog box
(see p.42) is in centimeters or inches, the resolution determines
how many pixels are used to create the image: the higher the
resolution, the greater the number of pixels and thus amount of
memory required to store the image. When the Unit of Measure
is pixels, the resolution determines how large your image will be
when printed. The higher the resolution, the smaller your image
will print (the memory required to store the image however,
remains the same).

5. Click OK. The dialog box closes and the new image, filled with
the background color, appears in an untitled window.
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2.1.4 Managing image windows

Image Editor allows you to work with many images open at the

same time. This convenience makes it easy to combine

elements from different images as well as being able to compare

the “before-and-after” of a performed effect.

While working with multiple files can be advantageous, it also

places a strain on your system’s resources – not to mention

making the workspace cluttered. Image Editor provides the

solution to these problems with the Cascade, Tile and Arrange

Icons commands found in the Window menu. Cascade “stacks”

open windows beneath and to the right of each other while Tile

resizes open windows to fill the workspace. If you have a large

number of minimized image windows, the Arrange Icons

command arranges their icons along the bottom of the

workspace.

Note: To save on system resources, minimize images you are not
currently working on. If you have a large number of open
images, use the batch manager’s Minimize command (see p.32).
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2.1.5 Saving files

When you want to save your work, Image Editor provides three

commands: Save, Save As and Save to Album. Use Save when

you wish to update the file you are currently working on and

Save As when saving new files, or to save a file to a new

destination and/or filename. The Save to Album command is

provided in the batch manager (see p.32) and allows you to save

files to an album in the ImagePals Album program.

Note: You can also save a file to a new album from the Save As dialog
box by clicking on the Album button. This opens the Insert
Thumbnails Into Album dialog box. To save to an existing album,
check the Save to Album option and select an album from the
combo box. (This is disabled if there are no existing album files.)

You should save whenever you make changes to a file that you

wish to retain. When you save, you can choose the file format

you save your image in and, if a compression option is available,

whether or not to compress the file. (For more information on

file formats and the availability of the compression options, see

the introductory guide.)
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To save an image for the first time:

1. Select the image you wish to save.

2. Choose “Save As” from the File menu. The Save As dialog box
opens.

3. In the Directories list box, select the drive and directory you
want to save the image to.

4. Select a format from the List Files of Type combo box. For
general purposes choose “TIF”.

5. In the File Name entry box type the name of your file (up to eight
characters). You do not need to enter the File extension.

Note: If you type in an extension, ensure that it is the same as the
extension shown in the List Files of Type combo box.

6. Click OK. The dialog box closes, returning you to the window
containing your saved image.

2.1.6 Printing files

When it comes to printing your work, Image Editor allows you to

output files to any Windows-compatible output device. Before

you print however, make sure that your output device is turned

on, connected and selected in the Printer Setup dialog box. If

you need to, you can access this dialog box through the Printer

Setup command in the File menu.

Note: The Printer Setup command allows you to change the current
printer options including the orientation of the page from
landscape to portrait, and the paper size.
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When ready to print, choose the Print command in the File

menu. The Print dialog box opens. In this dialog box you have a

number of options to control the printed output.

The Scale to Fit the Page option scales images to be as large as

possible on the page while maintaining their aspect ratio. With

this option unchecked, images print at the size determined by

their resolution.

The Center Image Horizontally, Center Image Vertically and

Start From Top Left Corner options allow you to choose where

images print on the page. If both the center options are selected,

images print centered on the page. (Choosing these options

disables the corresponding From Top or From Left option.)

Image Editor also allows you to accurately control the way your

printer simulates multiple shades in your images. The process

used to do this is called halftoning or sometimes dithering. (For

more information on halftoning, refer to the introductory

guide.) For everyday printing, select the Perform Halftone by

Printer option. This leaves the halftoning to the printer and

should produce the quickest and most acceptable results.

The Tone Map button provides access to the Tone Mapper

dialog box (see p.108). This function is intended to help you

calibrate your printer to reproduce images consistently.
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2.1.7 Closing files

When you have finished working on an image or wish to remove

it from the workspace you can close it. It is a good idea to close

unnecessary images as these occupy valuable system resources.

You can close an image in one of the following ways:

• choosing the Close command in the File menu.

• double-clicking on the image window’s Control menu box.

• choosing the Close command in the image window’s Control
menu.

• using the batch manager’s Close or Close Quickly commands.

When you close an image, it disappears from the workspace. If

you have not saved it, or you have made changes since you last

saved it, a message box appears asking if you want to save the

changes. Selecting No discards any changes; Yes saves them.

Note: Close Quickly is only available in the batch manager (see p.32)
and allows you to close selected images from the workspace
quickly. When you use this command no new images or changes
made to existing images are saved.

2.1.8 Exiting Image Editor

When you have finished working with Image Editor, you can exit

by closing the program window or by selecting the Exit

command in the File menu. When exiting Image Editor, you will

be asked if you want to save any new images or any changes

made to previously saved images. If you have many open

images, use the batch manager to save the images and then

close them with the Close Quickly command.
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2·2
Viewing

When you display an image, the image pixels are “mapped”

onto your screen pixels. Controlling the mapping of these pixels

determines the way you see images. This section takes a look at

the ways you can control the view of an image as well as how to

display file and system information and choose which features

of the interface to show or hide.

2.2.1 Adding a view

When you edit specific portions of an image it is often difficult to

appreciate how your editing affects the image as a whole. By

choosing the Add a View command in the View menu, you can

create a new window containing an additional view (at 1×) of the

image you are working on. This image differs from a duplicated

image in that any editing done in either of the windows is

reflected in the other.

Note: You can have up to eight views of an image displayed at any
one time.

Editing an image (at
8x view) with a view

added (at 1x view)
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2.2.2 Viewing images

Image Editor provides commands to adjust both the

magnification at which an image is displayed as well as to

determine what area of an image is displayed. This section deals

with the ways you can control the magnification and window

size while the next, the global viewer, describes how to control

what area of an image is displayed.

Zooming

When you edit an image, you may want to see part of it in

greater detail or more of the image at a smaller size. You can do

this in two ways: with the Zoom In and Zoom Out commands

from the View menu or using the zoom tool. Choosing the Zoom

In command enlarges the view of an image. This allows you to

zoom in up to 8× the actual view. To reduce the view, choose the

Zoom Out command. This command allows you to zoom out

down to ⅛× the size of the actual view.

         

Image at actual view (1x), enlarged to 3x view and reduced to a ¹/³x view
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The zoom tool provides an alternative to the Zoom In and Zoom

Out commands and allows you to accurately zoom in on

particular areas of an image. You can use the zoom tool in a

number of ways:

• clicking the left mouse button zooms in on the area under your
mouse pointer.

• holding down the Shift key and clicking the left mouse button
zooms out from the image.

• clicking the right mouse button or double-clicking on the zoom
tool icon in the toolbar returns the image to actual view (1×).

• dragging the left mouse button creates a rectangular viewing
marquee. When you release the mouse button the image
automatically zooms in on the area defined by the marquee.
(If the viewing marquee is too large or the image is already at
8× magnification the view will not be adjusted.)

Note: You can also press the “+” and “-” keys to zoom in and out on
images – irrespective of the current tool selected.

Fit in window

When you use the zoom commands, the image window does not

change to fit the new image size. So after zooming in, the entire

image will not display in its window and scroll bars appear along

the window border. If you wish to display the complete image

within its window choose an available zoom command from the

View: Fit in Window submenu. (The maximum zoom level

available is determined by the size of the image and the

resolution of your current display mode.)



28 IMAGE EDITOR USER GUIDE

Actual view

When you open an image for the first time, it is displayed at its

actual size, with each image pixel shown by one screen pixel.

This is the normal (1×) view of an image. If you change the view

of an image, for instance by zooming, you can return the image

to its actual size by choosing the Actual View command in the

View menu.

Note: If you have the zoom tool selected, clicking on the image with
the right mouse button performs the same effect.

Full screen

The Full Screen command in the View menu displays the active

image at the current zoom level occupying the entire screen; the

program window, toolbar, status bar and color palette are all

hidden. The current editing tool and the Undo command

(via the Ctrl + Z shortcut key) remain available and scroll bars

appear when the image is too large to be completely displayed.

To return to normal screen mode press the Esc key.

2.2.3 The global viewer

When the whole of an image cannot be displayed in its window,

you would normally have to use the scroll bars to locate hidden

areas. The global viewer of Image Editor is a better method that

allows you to locate these areas quickly and easily by providing

a thumbnail view of the entire active image. This thumbnail

image contains a floating frame that can be moved independ-

ently around the viewer. Moving the frame automatically

repositions the current view of the active image. To access the

global viewer, choose the Show Global Viewer command in the

View: Options submenu or the same command from the menu

button in the status bar.
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The global viewer can be moved around the program workspace

by dragging on its title bar. If you want to use the global viewer

for a quick adjustment, click on the box that appears at the

intersection of the scroll bars in an image window. This displays

the global viewer at the corner of the image window and allows

you to reposition the current view by dragging the floating

frame. When you release the mouse the global viewer

disappears, or returns to its last position in the workspace.

Note: Double-clicking on the title bar of the global viewer closes it.
Double-clicking anywhere else adjusts the view of the image to
fit within its window.

Using the global
viewer to reposition
the current view of

an image
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2.2.4 Displaying information

Image Editor provides information about the active image and

your system status with two commands in the View menu:

Image Information and System Information. The Image

Information command opens the Image Information dialog box.

Here you can find information about the attributes of an image,

such as its data type, dimensions, resolution, and working file

size as well as various file details. These details include the

filename, file format and space occupied on disk. There is also a

section on the current state of your memory, disk space and

whether your file has been modified since you opened it.

Note: For different file formats the information provided may vary.

The System Information command opens the System

Information dialog box. Here you can find information about

Windows including the version number, your current mode and

available system memory. There is also a section on disk

information displaying the current directory, size of your disk

and available disk space.

2.2.5 Displaying interface elements

The Options command in the View menu reveals a submenu of

show and hide commands. Choose the appropriate commands

to show or hide the status bar, toolbar, color palette, global

viewer, object pool and rulers. This submenu can also be

accessed from the workspace by clicking on the menu button on

the left of the status bar.
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3 Image Editor basics

So far this guide has introduced the Image Editor
program and provided a look at some of the more
common menu commands. This chapter takes
you towards your first step into the world of
image editing. Here you will learn how to
apply commands, use the clipboard, perform
“drag-and-drop” operations and customize
certain display and feature options.
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3·1
Applying commands

To perform an operation, you first need to select the image you

want the operation to be performed on, and then choose the

appropriate command from a menu. This is fine when you

are working with single files but proves inefficient when it

comes to working with a large number of files. To overcome this

“one-command, one-file” limitation, Image Editor provides an

extra feature, the batch manager, that allows you to apply one

menu command to multiple files. This section first describes the

batch manager and then goes on to explain the Restore and

Undo commands which can help you recover from any mistakes

made.

3.1.1 Using the batch manager

The batch manager can be accessed in two ways: double-

clicking on an empty part of the workspace or by choosing the

Batch Manager command in the File menu. Once invoked, the

batch manager opens and displays the filenames of all image

windows present in the workspace as well as a combo box of

operations that can be applied to them: Close, Close Quickly,

Minimize, Print, Resolution, Restore Window, Save and Save to

Album.

Note: The batch manager can only apply operations to files that are
open in the workspace. When there are no open files it is
unavailable.
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To perform a batch command, choose the operation you want to

perform, select the files you want the operation to be performed

to and click OK – batch manager does the rest for you.

The batch manager contains an additional two commands not

available in any of the Menus – Close Quickly and Save to

Album. Close Quickly clears the workspace of all the selected

images at one go, without asking to save changes. (Only use this

command if you do not want to retain changes made in an

image or to save new files.) Save to Album allows you to save

selected images to a new or existing album in the Album

program of ImagePals.

3.1.2 Recovering from mistakes

One of the advantages of working with images in a digital format

is that you can experiment with a variety of different effects and

filters. As a consequence you may perform a function and end

up with an unsatisfactory or unexpected result. If you make such

a mistake while working in Image Editor, you normally correct it

by selecting the Undo or Restore commands.
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Using the Undo command

If you change your mind about a command you have applied,

choose the Undo command in the Edit menu. The effect of the

command is reversed, and the image is restored to its state prior

to the application of the command. Undo will only undo the

most recent change. If you need to undo several changes, use

the Restore command to return the image to its last saved

version.

Instead of “Undo” at the top of the Edit menu, you may see:

• Redo... this appears after you have “undone” something,
effectively allowing you to undo the undo; in other words, redo
the change.

• Can’t Undo is displayed when it is not possible to undo the last
action, e.g. after you have saved an image file.

• Undo Disabled means that the undo facility has been disabled in
the Image Editor dialog box (see p.43).

Restoring an image

When experimenting with a variety of effects on an image, you

may not wish to undo each effect after you perform it. In such

cases you can restore the image to its original state by choosing

the Restore command in the File menu. (This essentially closes

the file and reopens it.) Before using this command, consider

carefully because it cannot be undone. If in doubt, create a

duplicate image before restoring so that you can compare the

current stage of your work with the original.

Note: Whenever you make a major change to an image that you want
to retain, you should save, or create a duplicate.



IMAGE EDITOR BASICS 35

3·2
Using the clipboard

Many commands in Image Editor make use of the clipboard.

The clipboard is a temporary storage area for any type of

information. This may be an image, text or even sound; but the

clipboard can only hold one piece of information at a time.

When you place something on the clipboard, existing clipboard

data is overwritten: irrespective of whether you placed new data

on the clipboard from another program or from Image Editor.

3.2.1 Performing a cut and copy operation

The most common methods of placing data onto the clipboard

are the Cut and Copy commands. Regardless of the active

image’s data type, the Cut and Copy commands are always

available. Copy places a duplicate of a selected area on the

clipboard whereas Cut deletes the selected area and places it

onto the clipboard. (The affected area of the image is filled with

the current background color.) When there is no selection area,

both Cut and Copy are applied to the entire image.

3.2.2 Pasting data into an image

After cutting or copying some image data, you can paste it from

the clipboard into an image by choosing the As Selection or Into

Selection commands in the Edit: Paste submenu.

The Paste commands are disabled when the clipboard is empty

or the contents of the clipboard is from another, incompatible

program and cannot be pasted into images. The Paste: Into

selection is disabled when there is no current selection.

Note: Image Editor allows you to paste image data into any image,
regardless of data type. When pasted into an image of a
different data type, the pasted data is converted. At times this
may cause an extreme change in color, e.g. if the clipboard data
is RGB True Color and the destination image is Indexed 16-Color.
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Pasting as selection

Using the As Selection command places the clipboard image at

the top left corner of the current view. (You can freely move the

image by dragging on it with one of the selection tools.) If you

want to position the clipboard image at a specific point in the

image prior to pasting, use a selection tool to draw a selection

area starting at the point you want the data to be pasted. (The

size of this selection area is not important.) This time when you

paste, the top left of the image from the clipboard is pasted at

the top left corner of the selection area.

Note: When you drag a selection between images, it is dropped pixel-
on-pixel. So, if your source and target images are at different
zoom levels, the selection may appear to be enlarged or reduced
when it is dropped.

Pasting into a selection

Use the Into Selection command when you want to paste the

clipboard image inside the selection area of an image. If the

clipboard image is larger than the selection area, only the

portion contained within the selection area is displayed. After

pasting, a selection marquee appears indicating the size of the

clipboard image. This marquee can be moved to change the

portion of the clipboard image displayed in the selection area.

Note: If the pasted image is smaller than the selection area, it is placed
at the top left corner of the selection. The remaining areas of
the image are left unaffected.
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Pasting image data As Selection (left) and Into Selection (right)

3.2.3 The Clipboard submenu

To help you work with the clipboard, Image Editor provides a

Clipboard submenu in the Edit menu. This submenu contains

commands to Load, Save and Display clipboard images:

Load – brings image files and previously saved clipboard images

onto the clipboard. This command is similar to the Open

command, but rather than opening a file and placing it in a new

image window, Load places the file onto the clipboard.

Save – saves an image from the clipboard to disk. After saving,

you can open this image as you do any other images, or bring it

back onto the clipboard with the Load command.

Display - shows the current clipboard image. The clipboard

window appears containing the image fitted in a window

(if possible). To close the clipboard window, press a key or click

the mouse.
Note: These commands can only be used when the clipboard contains

image data. The Windows Clipboard Viewer utility, accessed by
choosing the Clipboard Viewer command in the Pals menu,
provides similar functions for other types of clipboard data.
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3·3
Using drag-and-drop

An advantage of working in a Windows environment is that you

can use your mouse to easily move images around the program

workspace as well as place them into other images or programs.

Performing such tasks is referred to as “drag-and-drop”. Image

Editor supports standard drag-and-drop operations as well as

more advanced drag-and-drop operations such as moving

selection areas to other images, the open workspace or the

object pool. This section describes some of these more

advanced ways of using drag-and-drop.

3.3.1 Drag-and-drop between image windows

Once you create a selection area, you can move the selection

within the original window, or to any other image window, by

dragging it with one of the selection tools. If you drag-and-drop

between images of different data types, the dropped selection is

converted to the data type of the destination image.

When you drag-and-drop a selection into another image, you

have the choice of moving the selection into the image, filling

the image (holding down the F key as you drop), or moving the

selection marquee alone (holding down the M key as you drop).

Note: When you drag a selection between images, it is dropped pixel-
on-pixel. So, if your source and target images are at different
zoom levels, the selection may appear to be enlarged or reduced
when it is dropped.
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Dragging a selection from the image on the left (with the F key held down) to “fill” the
selected area of the image on the right
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3.3.2 Drag-and-drop to the workspace

During your imaging work you may want to retain or duplicate a

particular part of an image. Image Editor makes this easy by

allowing you to drag a selected part of an image into the open

workspace; a new image window is created containing the

image. (The background, where visible, is filled with the current

background color.) If you hold down the M key as you perform

the drag-and-drop operation, a Grayscale image is created

containing the selection mask (for more about masks see p.63).

Dragging a selection from the image on the left to the open workspace
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3.3.3 Drag-and-drop to the object pool

Image Editor provides a useful feature that allows you to

instantly save selections and masks while you work – the object

pool (see p.61). To save a selection area to the object pool,

drag-and-drop it onto the object pool icon at the bottom of the

color palette, or into the object pool window. By dragging

selections from the object pool, you can place them into image

windows or create new images by dropping them into the

workspace.

Dragging a selection to the object pool
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3·4
Customizing the way you work

All the ImagePals programs come equipped with extensive

commands to customize the way each program operates as well

as interacts with Windows. In Image Editor these commands

can be found in the File: Preferences submenu. The following

section discusses each of these commands and details how you

can use them to improve the way Image Editor works for you.

3.4.1 Image Editor

Choosing the  Image Editor command opens the Image Editor

dialog box. From this dialog box you can set various features

related to working with images while in the Image Editor

workspace:

The Unit of Measure combo box allows you to define the

measurement system used, centimeters, inches or pixels. When

you are moving selection areas and wish to leave the original

image unaffected by the move check the Preserve Image Under

Selection option. With this option unchecked moving selection

areas results in the original image under the selected area being

filled with the background color. (This option can be

conveniently “toggled” while you work with the F5 key.)

Note: You cannot toggle this option when the selection is floating.
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The Enable Undo option, when checked, causes Image Editor to

retain in memory the status of an image immediately prior to a

change made to it. After making a change you may recover to

the previous state by choosing the Undo command in the Edit

menu. Undo does, however, occupy memory, as Image Editor

has to “remember” what the active image was like before the last

change was made. Unchecking Enable Undo frees this memory

allowing you to work with larger images and to perform some

operations more quickly.

The Number of File Names Kept option allows you to specify

how many files are listed at the bottom of the File menu. This list

contains the filenames of your most recently saved images,

which can be opened by clicking on them.

The final option, Background Color in Thumbnail, allows you

to change the color used to fill the background of irregularly

shaped selections appearing in an effect dialog box. Change this

color when you find it hard to distinguish between the edges of

the image and the background color. (The color selected here is

also used to fill the background of irregularly shaped images

stored in the object pool.)

Note: The Image Editor dialog box can also be opened by pressing the
F6 key or double-clicking on the status bar.
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3.4.2 OLE & Clipboard

Running under Windows 3.1, Image Editor can make use of the

Windows OLE capabilities and act as a server program. The OLE

& Clipboard dialog box allows you to choose what is placed on

the clipboard when you use the Copy or Cut commands. This is

important because it puts you in control of the demand on your

system resources: you only want to copy the minimum amount

to the clipboard to complete your task.

These options are fully described in the introductory guide, but

if you want to use Image Editor as an OLE server, you must

check the Include OLE Related Formats option. If this is

unchecked you will find the OLE paste commands disabled in

your client program.

When moving large amounts of image data, check the Delay

Render option. This only places the data onto the clipboard

when you decide to perform a paste operation. For general

purposes leave this unchecked.

Note: After placing images onto the clipboard, do not change these
options before pasting. Doing so may produce unexpected
results.

3.4.3 Photo CD

The Photo CD dialog box gives you the option of determining

the resolution and data type of any image files imported from a

Kodak Photo CD. Any changes made here are also reflected in

the CD Browser program.
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3.4.4 Display

The Display dialog box allows you to adjust the way images are

displayed by Image Editor.

If you are using a HiColor display mode, checking the HiColor

Dithering option improves display of True Color images. When

working in a 256-color display mode, you can select the View

Images With a Common Palette option to display all images

with the system palette – this provides reasonable

representation of all images and makes your work quicker

because the palette stays the same: as such there is no need to

repaint any of the images.

A 256 Color display mode also enables the Don’t Care About

Background Quality option. If you have selected the common

palette option, this makes no difference, otherwise select this

option to prevent the background images repainting – giving

you the best representation of the active image and the fastest

working environment. (You cannot, however, compare images

with this option selected.)

The final option present in the Display Preferences is the

Monitor Gamma option. This tunes your monitor to the current

display. It is very important that you calibrate your display

before you start working with images for the first time. To learn

more about how to calibrate your display, please refer to the

introductory guide.
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3.4.5 Memory

The Memory command gives you the opportunity to specify

directories which can provide additional working space when

working with images. The first directory shown is the TEMP

directory defined by the SET TEMP statement in your

AUTOEXEC.BAT file. Image Editor provides a further three

choices that would normally be different drives. If you are

working on a network, you may have different space allocations

on the same drive; in such cases you can specify more than one

temporary directory from the same drive.

3.4.6 File Formats

The File Formats command allows you to specify which file

formats you want Image Editor to support. When you use Image

Editor for the first time all available file formats are placed on

the active list. This allows you to open a wide range of files but

does use up valuable system resources and extends the List Files

of Type combo box (in certain dialog boxes).

If you only work with a limited number of file formats, then use

this command to remove unnecessary formats from the active

list. This will save you a lot of time when you open and save files

as you do not have to scroll through so many formats every time.

Notes:

• If you have an image currently open in the workspace, the
image’s file format appears with an asterisk; indicating that the
format is in use. If you want to remove the format from the
active list first close the image.

• The object pool stores images in the TIF file format. If you want
to use the object pool, ensure that the TIF format is on the
active list.
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4 Making selections

An essential part of working with images is being
able to manipulate portions of an image. Image
Editor provides a comprehensive range of
selection tools and commands that allow you to
accurately isolate those areas you want to
perform an operation on and protect areas you
want left alone.

This chapter begins by introducing selection
areas and explains the tools and commands you
use to select and manipulate areas within an
image. Following this is a section on the object
pool – an indispensable tool that not only
increases your productivity, but adds a whole
new dimension to the way you work with
selections and images.
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4·1
Understanding selection areas

After opening an image, you can choose to edit the entire image

or selected parts of it. To edit specific areas within an image, you

must first select them. Unless a selection area has been created,

any editing you do may affect the entire image. Image Editor

allows you to select a single part of an image or multiple,

unconnected parts.

Note: When moving images an important consideration is the Preserve
Image Under Selection option in the Image Editor dialog box. If
this option is checked, any selected areas leave the original,
underlying image unaffected. When it is unchecked, the
underlying image of the selection is replaced by the background
color – you can see this when you move or transform the
selection. (This option can be toggled by pressing the F5 key.)

Moving a selection
area with the

Preserve Image
Under Selection
option disabled

(image on the left)
and enabled (image

on the right)
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4.1.1 The selection marquee

When you create a selection, an animated dotted line appears

around the edge of the selected area. This dotted line is called

the selection marquee. This marquee can be either floating,

containing some image data, or non-floating, selecting part of

the active image. A floating selection is created when you:

• move a selected area,

• perform a transformation on a selected area,

• paste or drag a selection into an image,

• choose Make Floating from the Edit: Select submenu.

Deselecting and discarding selections

After editing or moving a floating selection you can make it part

of the underlying image or remove it. To make it part of the

underlying image, you deselect it by:

• choosing None from the Edit: Select submenu,

• double-clicking on the freehand or move selection tools in the
toolbar.

To remove a floating selection, choose the Discard Floating

command in the Edit: Select submenu. (If the selection is not

floating, this command is disabled and you cannot “remove” the

selection area as such, but you can Undo your last applied

action or Restore the image, see p.34).



50 IMAGE EDITOR USER GUIDE

4·2
Making and manipulating
selections

You can create and manipulate selection areas with the

selection tools at the top of the toolbar and the select commands

in the Edit: Select submenu. This menu can also be accessed by

clicking the right mouse button on an image when a selection

tool is selected. (Choose a command by dragging down the

menu and releasing the mouse button or by clicking on the

appropriate command with the left mouse button.)

This section describes how to use the selection tools to select

anything from similar colors to irregular shapes.

4.2.1 Selecting an area containing similar colors

The magic wand tool selects an area in an image that contains

colors or grays falling within a defined color range. To define this

color range double-click on the magic wand icon in the toolbar.

The Magic Wand dialog box appears. In the Color Similarity

entry box, type in the value that you feel closest reflects the

range of colors you wish to select.

To select an area of the active image, click in the center of the

area you want to select (the color value of the pixel under the

magic wand is displayed in the left-hand portion of the status

bar). All the surrounding pixels that fall within the color range

will be selected.
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Below is a guideline on what to expect when choosing particular

color values.

• A value of 0 selects neighboring pixels of exactly the same gray
or color.

• A value of 255 selects pixels of all colors and grays – thereby
selecting the entire image.

• A value of 50 selects neighboring pixels that have values which
differ from the pixel you clicked on by ±50. For example, if you
click on a pixel with values R25, G60, B190, neighboring pixels
with values between R0, G10, B140, and R75, G110, B240 will be
selected.

Using the magic wand tool to select an area of similar colors

. Note: You can expand existing selection areas to include areas of
similar colors with the Similar command in the Edit: Select
submenu (see p.57).
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4.2.2 Selecting irregularly shaped areas

Using the freehand tool you can select an area of any shape you

desire. Do this by dragging the tool to outline an area or by

clicking on selected points to define the ends of straight line

segments. Once completed, double-click and Image Editor

automatically completes the selection by drawing a straight line

between the last and first point of the selection.

Note: If you make a mistake while drawing a selection area with the
freehand tool or wish to start again, press the Esc key.

Using the freehand tool to select an irregularly shaped area
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4.2.3 Selecting square and circular shapes

  
Image Editor provides two tools which select areas of preset

shapes, the rectangular and elliptical selection tools. Both tools

operate in a similar manner and provide two basic methods for

creating selection areas: freehand and fixed size. To define this

mode, double-click on the tool icon in the toolbar. The

appropriate tool dialog box opens.

In Fixed mode you can define the width and height (in pixels) of

your selection area. When you click on the image the selection

area appears at this size.

In Freehand mode, you drag the mouse over the area you want

to include in the selection. A further option, Draw From Center

allows you to determine if the selection area is defined from the

center out or top left corner.

Note: Depending on the tool selected, you can define the selection
area as a square or circle.

Using the rectangular tool to select a rectangular area
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4.2.4 Moving the selection marquee

When you click on a selection area with a selection tool and

drag, the selection marquee and the image data it contains both

move. If you wish to move the selection marquee alone without

its contents use the move tool. If the selection area was floating,

the contents of the area become part of the underlying image.

Note: To drag a selection area from one image to another you should
use one of the selection tools and hold down the M key as you
drag. After you drop the image the move tool becomes the
current tool.

Dragging a selection marquee from the image on the left (with the M key held down) to
the image on the right
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4.2.5 Inverting a selection

When you wish to protect a particular area while working on the

rest of an image, select it and then choose the Invert command

from the Edit: Select submenu. This “flips” the selection area so

that those areas originally selected are now deselected and the

unselected area is selected. This allows you to work on the rest of

the image with no danger of damaging the area you want to

protect.

Selecting the
woman (image on
the left) and then

inverting the
selection to select

the background
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4·3
Selecting more of an image

Image Editor allows you to use any combination of its selection

tools to add to or subtract from existing selection areas. To select

additional areas of an image, or to extend an existing area, make

your initial selection and then, with the “Shift” key held down

(the pointer changes to display an addition sign) use a selection

tool to select more of the image. If you wish to exclude an area

from an already selected area, hold the Ctrl key down (the

pointer changes to display a subtraction sign) and select the

unwanted area – the marquee redraws itself so that it no longer

contains that area.

        

1. Create a selection area  2. Add to the selection 3. Subtract from the selection
 (hold down the Shift key) (hold down the Ctrl key)
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4.3.1 Expanding a selection

As well as using the Shift key in conjunction with the selection

tools to select more of an image, you can expand selection areas

with the Similar command in the Edit: Select submenu. When

you select this command the Similar dialog box opens. This

dialog box allows you to define a color range and whether to

expand the selection to include neighboring areas of similar

pixels or similar pixels from the entire image. This is most useful

when you have a complex image on a simple background and,

after selecting part of the background, you wish to expand it to

include the whole.

Expanding the
selection on the left

with the Expand
From Current

Selection option
enabled
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      4.3.2 Selecting the border of an area

When you want to add a keyline to part of an image or draw a

box or circle use the Border command in the Edit: Select

submenu. This allows you to select a line of pixels around the

edge of the current selection marquee – the width of the line is

determined by the width specified in the Border dialog box that

appears when you choose this command. (You can define the

border width from 1 to 64 pixels.) The border is created centered

on the selection marquee, i.e. half the specified width is placed

on the inside of the marquee and half on the outside. After

defining a border you can then “fill” it with a color to create a

keyline, box or circle, or use a blurring or averaging effect to

“blend” the edges of the selection area into the surrounding

image.

1. Create a selection area  2. Apply the Border command
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4·4
Merging a selected area

When you deselect a floating selection, the contents of the

selection completely replace the portion of the underlying

image below it. In many cases this may be desirable, but you will

often require greater control over the process.

The Merge Control dialog box gives you that control.

Specifically, it provides options to set the transparency of the

floating area, how colors combine and the degree to which the

edges of the floating selection are blended with the underlying

image. Use these options as follows:

• HSB merges the floating selection as you see it.

• Hue and Saturation merges the colors in the floating selection
with the underlying image. If your underlying image is a
Grayscale image that has been converted to RGB True Color and
your floating selection is a colored square, this option will
combine the color of the floating selection with the underlying
gray image: thereby colorizing the gray image.

• Hue only merges only the hues from the floating selection with
the underlying image. Use this option to change the color of
areas in a colored image.
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Transparency defines the transparency of the floating selection.

Choosing 0% and the floating selection completely replaces the

underlying image; the closer the value is to 100%, the greater the

transparency. At 50% the floating selection and underlying

image are merged equally.

Edge Blending determines the number of pixels (depth) at the

edge of the floating selection that are blended with the

underlying image. This function is centered around one pixel,

hence the available options are odd numbers (3, 5, 7, 9 and 11).

Notes:

• The merge control is a “modal” command, that is, its effect is
only permanent when the floating selection is deselected.
Before that time you can reapply the merge settings and even
move the selection area.

• The Merge Control is only available when there is a floating
selection and you are working on a Grayscale or RGB True Color
image.

Merging a floating
selection (25%

transparency) with
the underlying

image
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4·5
The object pool

When you create a selection area you may want to save it and its

contents for later use. Doing this allows you to use the same

selection for multiple images or use it repeatedly with the

same image. To do this Image Editor provides a unique and

easy-to-use feature: the object pool.

To access the object pool, double-click on the object pool icon

at the bottom of the color palette. The object pool window

opens. In this window, stored selections are displayed as

thumbnails and a ribbon, at the top of the window, displays the

name of the current group and various function and selection

buttons.

Note: The object pool is always on top of the Image Editor program
window and any image windows. To close the object pool
double-click on its title bar or choose the Hide Object Pool
command in the View: Options submenu.

The object pool



62 IMAGE EDITOR USER GUIDE

4.5.1 Saving selections to the object pool

You save a selection in the object pool by dragging it from an

image to the object pool or its icon. The selection is then

automatically saved and a thumbnail of the selection appears in

the object pool window.

When you save a selection area, you have the option of saving it

as a mask or image “object”. (You choose which in the Object

menu, accessed by clicking on the blue menu button). A mask

object is a selection marquee, while an image object is a

selection marquee and the image data it contains. For Grayscale

images there is an additional option to save a selection area as

an “image as mask”. This converts the image into a selection

marquee and saves the marquee.

Notes:

• Holding down the M key as you drag a selection area into the
object pool automatically saves the selection as a mask object.

• Selections are saved in the TIF file format in the directory
specified at the time the group was created. (The files are
identified with an O prefix followed by the letter I [image],
K [image as mask], or M[mask], with a creation number at the
end.) You can choose to compress these files when they are
created by checking the Compress Objects option in the
Information dialog box, accessed by choosing the Information
command in the Disk menu.

• When saving a selection as an image or image as mask object,
Image Editor creates two files. One is the image portion of the
file, the other is the mask portion which used to define the
shape of the image.

• As the object pool uses the TIF file format, the TIF format must
be one of the available file formats (see p.46).
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Saving selections to file

Although the object pool allows you to easily export masks as

Grayscale images, reimport images as masks, and place masks

into images, you may want to export a mask to another machine,

or save it to a secondary storage device. Image Editor provides a

direct method of doing this: the Save Mask command in the

Edit: Select submenu. This opens the Save Mask dialog box and

allows you to save the current selection marquee as a Grayscale

image in a file format of your choice (the options in this dialog

box are the same as the Save As dialog box, see p.22).
Note: In general, do not save masks in a format that involves “lossey”

compression (like JPEG), these formats will change the mask.
For general purposes, use the TIF file format (with or without
compression).

4.5.2 In the object pool

The object pool is a very handy and useful place to store your

work. It can however, become quickly cluttered with large

numbers of masks and images. To better organize these masks

and images you can place them into user-defined groups. Once

created, a group can be selected by choosing its name from the

group combo box in the object pool ribbon. To view the objects

of a group, click on the mask and image buttons in the object

pool ribbon. If neither button is pressed the window will be

empty. (These buttons are disabled if the group does not contain

their respective objects.)
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To create a group:

1. Double-click on the object pool icon. The object pool window
opens.

2. Click on the disk button in the ribbon and choose “Create
Group”. The Create Group dialog box appears.

3. Type in a name for your group in the New Group Name entry
box. The name can be up to 10 characters long (do not type in an
extension). If you want to change the path and directory where
the group is saved, type in a new destination in the New Group
Directory. (Group files are saved with the OPG file extension.)

4. Click OK. The dialog box closes and the newly created group
appears as the active group in the group combo box.

You can import object groups from a network by choosing the

Import Group command from the disk menu. (When you import

a group, the group file and objects remain in their original

directories.) If you wish to share your own object groups but

want to make them read only, click the lock button. Other users

can still access your object groups but cannot make any changes

to your objects or groups. If a group from another user is locked,

the lock button in your object pool will be depressed (you will

not be able to unlock it).

Deleting groups and objects

Having created a group, you can easily delete it and its

associated files from disk by choosing the Delete Group

command in the Disk menu. To delete an object from a group,

click on the object to select it and choose the Delete Object

command in the Disk menu.
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4.5.3 Retrieving an object

Just as you create objects by dragging them into the object pool,

you can retrieve them by dragging them from the object pool

into an image window or the workspace. Dragging an object to

the workspace creates a new image window containing the

object as a floating selection. You can then edit the object just as

you would any other image.

If you drag an object back to the image it originally came from,

or another of equal size, the object is placed as a floating

selection in the same position it was originally taken from. If the

destination image is a different size, the selection is placed at

the position of your mouse.

When dragging mask objects into an image, the selection tool

automatically changes to the move tool. This enables you to

accurately identify the areas selected by the mask and to move it

freely without fear of affecting the underlying image.

Notes:

• When placing a mask object that has been created from a
Grayscale image into an Indexed-Color or Black & White image
the gray areas of the mask are converted to pure black or white.

• To load a previously saved mask (or any Grayscale image) into
the active image as a selection marquee, use the Load command
from the Edit: Select submenu.
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4.5.4 Editing masks

When you create a selection area, areas are either selected or

not. This means that when you apply commands to the selected

area you will often get a hard edge or too strong an effect. To

avoid this you can export the selection area as a mask and edit

the mask so that some areas are partially selected, i.e.

commands will only have a partial effect on these areas.

When you export a mask, by dragging a selection area from an

image into the workspace (with the M key held down) or by

dragging a mask from the object pool into the workspace, a

Grayscale image is created. You can edit this Grayscale image as

you would any normal image, but always remember:

• black areas are not selected,

• white areas are selected,

• gray areas are partially selected. When the mask is placed into
an image and editing functions are applied to the image, the
degree of effect is determined by the gray shade – the closer to
white the greater the effect; the closer to black the less the effect.

When you finish editing and wish to place the mask back into an

image as a selection marquee, you do so via the object pool:

1. Select the whole image with “All” from the Edit: Select menu.

2. With the “image as mask” option checked in the object pool
menu, drag the image back into the object pool. The image is
saved as a mask.

3. Drag the newly created mask object into an image.

Note: When a mask containing gray shades is dragged into an image,
the selection marquee may not appear to accurately represent
the mask. This is because the selection marquee only shows the
border of areas in the mask that go from a value less than 128
to a value greater than 128. If your mask is very dark, containing
only gray values below 128, no marquee will be shown: if it is
very light, containing only gray values greater than 128, the
whole image will appear to be selected.
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5 Manipulating images

Editing images involves many different stages
and operations. Rather than presenting all the
facilities provided by Image Editor in one place,
we have separated them out into three chapters:
Manipulating images, Painting and Enhancing
images.

This chapter deals with manipulating images,
and explains how you can change images by
converting their data type, changing their
resolution or size, or applying transformations
to them such as crop, flip, distort and rotate.
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5·1
Transforming images

Whatever your reasons for editing images, it is essential to be

able to manipulate them to suit your intended purpose.

Whether you are preparing images for a publication and need to

resize and crop them or preparing images for display and need

to convert them – Image Editor’s manipulation commands will

more than satisfy your needs.

This section deals with the commands that you use to crop,

resize, rotate and distort images.

Notes:

• If the Preserve Image Under Selection option is unchecked
(in the Image Editor dialog box) sections of an image may be
filled with the background color after applying transformation
commands. (You can toggle this option by pressing the F5 key).

• If, in transforming a selection, you click on or drag anything
other than a handle, the handles will disappear. By choosing
“Undo” you can undo your last action, but this does not make
the handles reappear.
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5.1.1 Cropping an image

Cropping is a way to trim the edges of an image and control the

position and size of the subject in an image. This is particularly

useful when you have images that are too large to be displayed

and contain information around the edges that you wish to

discard. It is important to remember that when you crop an

image the cropped portions cannot be retrieved again, unless

you immediately undo the Crop command or restore the image.

To crop an image:

1. Select the area of the image you wish to retain.

2. Choose “Crop” from the Edit menu. The areas outside the
selection marquee are discarded. Only the area you selected is
retained.

Note: If you select a non-rectangular area, the image is cropped to the
smallest rectangle that can contain the selected area. Areas outside
the selected area are filled with the current background color.

    

Image with area selected before cropping and, on the right, after cropping
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5.1.2 Resizing images

You can resize images in three ways: by changing their

resolution,  resampling them or resizing a selected portion of

them. Changing the resolution of images adjusts their size

without changing the actual image data and thereby retains

original quality. Resampling an image discards data when you

reduce an image and creates new data when you enlarge one.

Resizing a selection area stretches or shrinks the selection within

the image.

Changing an image’s resolution

Resolution determines the physical size of an image by defining

the size of its constituent pixels. As you change the resolution,

you change the number of pixels that can be placed in a given

measure making the image bigger or smaller: increasing the

resolution reduces the size of the image while decreasing it

makes the image larger.

In this way you resize an image without actually changing the

number of pixels the image contains, thus retaining the original

quality of the image. (The images in this guide have all been

resized by changing their resolution.)

To change the resolution of an image:

1. Select the image whose resolution you want to change.

2. Choose “Resolution” from the Image menu. The Resolution
dialog box appears.

3. Decide on the resolution to use: Display, Printer, or User
Defined. If you select User Defined, enter a new resolution in
the entry box.

4. Click OK. The dialog box closes and the resolution of the active
image is changed. There is no change to the appearance of the
image. Changes are only apparent when you print the image or
place it into another program that reads the resolution.
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Image before
resizing

Image after resizing

Left: increasing
resolution by 2×

Right: resampling
to 50%

    

Resampling an image

When you open images, their size on screen is determined by

your screen resolution and the number of pixels they contain.

The Resample command allows you to adjust the number of

these pixels in an image. You will want to do this when:

• you are preparing images for display on your computer, e.g. in a
slide show, and wish to make them all display at the same size.

• you are preparing images for a publication and you wish to
make their file size smaller so that they take less time to import
into, and print from, your DTP or word processing program.

• you wish to stretch or squash an image.
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To resample an image:

1. Select the image you want to resample.

2. Choose “Resample” from the Image menu. The Resample dialog
box appears containing information about the current width
and height of the image.

3. Check the Keep Aspect Ratio option to retain the proportions of
the image. Uncheck this option to independently change the
width and height of the image.

4. Enter the new width and height for the image. (If Keep Aspect
Ratio is checked, entering one value automatically adjusts the
other value.)

5. Click OK. A new image window is created with the new width
and height specified.

Notes:

• Resampling up generates new data, thereby increasing the size
of the image file. Conversely, resampling down discards data
and results in a smaller file, but may reduce image quality.

• If you enter a new width and height of 100%, the image is
duplicated. Entering 200% doubles the size of the image and
50% halves the size. This affects the output (physical) size of the
image as well because the resolution remains unchanged.
Therefore, if you wish to reduce the size of an image file and
retain its physical size you must reduce its resolution by a
corresponding amount.

Resizing selected areas of an image

With the Free Resize command, in the Effect menu, you can

make the contents of a selection area bigger or smaller. When

you choose this command, handles appear at each corner and

side of the selection marquee. Dragging a handle resizes the

selection area. Holding down the Shift key as you drag maintains

the original proportions of the selection.



MANIPULATING IMAGES 73

5.1.3 Flipping an image

The crop, resolution and resample commands all relate to the

manipulation of entire images. The Flip command is an

example of a command which can be applied to either an entire

image or to a selected part of an image. After “flipping” the

image or selected area is horizontally or vertically mirrored.

To flip an image or selection area:

1. Select the part of the image to flip. (To flip the entire image,
do not make a selection.)

2. Choose “Horizontal” or “Vertical” from the Effect: Flip
submenu. The image or selected area is then flipped in its
position.

Image before and
after flipping
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5.1.4 Rotating an image

The Rotate command allows you to rotate an entire image or

selected area in any direction and to any degree. Choosing the

Rotate command in the Effect menu displays a submenu of

commands, that when chosen, apply an immediate effect,

open a dialog box or place a line on the image:

• Left 90° (counter-clockwise) – immediate effect.

• Right 90° (clockwise) – immediate effect.

• 180° – immediate effect.

• Freely allows you to define the rotation of a selected area by
dragging the corners of the area. (If there is no selection area this
command is disabled.) – immediate effect.

• Degree allows you to specify the angle and direction of the
rotation – opens a dialog box.

• by Horizontal line allows you to horizontally rotate an image to
a defined line. Use this if the image has a strong horizontal
feature  – places a horizontal line with handles on the image.

• by Vertical line allows you to vertically rotate an image to
a defined line. Use this if the image has a strong vertical
feature – places a vertical line with handles on the image.

Note: If you rotate an image by anything other than 90°, 180° or 270°,
extra space is introduced around the image. This space is filled
with the background color.

To freely rotate a selection area:

1. Select the portion of the image to rotate.

2. Choose “Freely” from the Effect: Rotate submenu.
Handles appear at each corner of the selection marquee.
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3. Place your mouse pointer over a handle and drag it clockwise or
counterclockwise. The selection is rotated around its center.

4. When you are satisfied with the rotation, choose “None” from
the Edit: Select submenu to merge the area with the image.

1. Select area within image 2. Choose “Rotate: Freely” 3. Drag handle to rotate

Rotating by horizontal/vertical line

The rotate by Horizontal and Vertical Line commands are useful

when you have an image which is not quite straight. This is often

the case when you input an image with a hand-held scanner.

To vertically align an image:

1. Select the image you want to straighten.

2. Choose “by Vertical Line” from the Effect: Rotate submenu.
A line, with a handle at each end, appears on the image.

3. Identify a strong vertical feature in the image and drag the
closest handle to one end of this feature.

4. Drag the other handle to the other end of the feature so that the
joining line now aligns along the feature.

5. Double-click on one of the handles. The image is rotated until
the joining line becomes vertical.
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Rotating by Vertical Line

             

1. Choose “Rotate by Vertical Line” 2. Drag a handle onto one end of a vertical
feature

3. Drag other handle so line aligns along 4. Double-click on handle to rotate image
the vertical feature
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5.1.5 Slanting a selection area

Apart from being able to rotate and flip images or parts of

images, Image Editor allows you to skew or slant selected areas

of an image using the Slant command. When you perform a

slant operation you can choose to slant the selected area along

the horizontal or vertical plane.

To slant a selected area:

1. Select the portion of the image to slant.

2. Choose “Slant” from the Effect menu. Handles appear at each
corner of the selection marquee.

3. Drag one of the handles in the direction you want to slant.
(Clicking outside a handle removes the selection marquee. You
can undo the action but need to reapply the Slant command.)

4. When the selection is at the desired slant, choose “None” from
the Edit: Select submenu to merge the selection with the image.

Note: If you slant a selected area with the Shift key held down, you
can move a single handle of the area. To create a perspective
effect, slant two adjacent corners of an area in opposite
directions.

1. Select area within image 2. Choose “Slant” 3. Drag handle to slant
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5.1.6 Distorting a selection area

Distort produces a similar effect to Slant except that it allows

you to move each marquee handle independently and in any

direction. Once you drag and release the mouse, the contents of

the selected area are resized to fit the new shape. Although

Distort uses a rectangular selection area, you can curve the

selection area and create 3-D effects by repeatedly applying the

Distort command to the same selection area.

To distort a selected area:

1. Select the portion of the image to distort.

2. Choose “Distort” from the Effect menu. Handles appear at each
corner of the selection marquee.

3. Drag one of the handles in the direction you want to distort.
(Clicking outside a handle removes the selection marquee. You
can undo the action but need to reapply the Distort command.)

4. When you are happy with the distortion, choose “None” from
the Edit: Select submenu to merge the selection with the image.

Note: Holding down the Shift key as you drag each handle prevents
the selection area from resizing. When the handles are in the
correct position, release the Shift key and click on any handle to
resize the contents.

1. Select area within image 2. Choose “Distort” 3. Drag handles to distort



MANIPULATING IMAGES 79

5·2
Converting images

When working with images, it is often necessary or useful to

change the data type of an image, for example, from Grayscale

to RGB True Color. Your choice of data type directly relates to

the image’s file size and quality.

By converting to a data type that supports more colors, you can

take advantage of the extra colors, but the image’s file size will

increase. Conversely, if you don’t require the number of colors

supported by the current data type, convert to one that makes

your image file smaller. For example, for black-and-white

publications use Grayscale images, not RGB True Color.

You convert an image by choosing a target data type from the

Image: Convert menu. (Some data types may not be available:

these require an intermediate conversion to Grayscale or RGB

True Color). After choosing the target data type, the conversion

is immediate or an options dialog box appears (see table below).

Note: Conversions do not change the original image but open a new,
untitled image window containing a copy of the image in the
new data type.

Source format Can convert to: Options

Black & White Grayscale

Grayscale Black & White
Indexed 16-Color
Indexed 256-Color
RGB True Color

Indexed 16-Color Grayscale
RGB True Color

Indexed 256-Color Grayscale
RGB True Color

RGB True Color Grayscale
Indexed 16-Color
Indexed 256-Color

Conversion paths between data types
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5.2.1 Converting Black & White to Grayscale

You can only directly convert a Black & White image to

Grayscale. This conversion involves options that enable you to

choose if, and how, the black and white pixels are converted to

gray shades. If you wish to convert a Black & White image to

other color data types, first convert to Grayscale, and then to the

target data type.

When you choose the Convert to Grayscale command in the

Image: Convert submenu, the Convert to Grayscale dialog box

opens containing the following options:

Cell size defines the size of the cells used to convert the black

and white pixels of a Black & White image to shades of gray.

The higher the number, the greater the number of gray shades

introduced. For line-art images that you wish to keep as black

and white, use a cell size of one. For a photo scanned with a

black-and-white hand-held scanner choose a cell size from

three to eight (depending on the settings of the scanner). If the

resulting image shows visible grids, the cell size is incorrect.

Scale down defines how much the image is scaled down during

conversion. A scale-down of one results in no scaling.

A scale-down of two reduces the width and height (in pixels)

and resolution of the image by half. Scaling down prevents the

new gray image from displaying a mosaic like effect that may be

caused when you define a large cell size.
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Original Black &
White image

After conversion:
Cell Size 5 and

Scale Down of 5.

(Retention of
detail good, but

grid pattern
visible – caused by
incorrect cell size)

After conversion:
Cell Size 8 and

Scale Down of 5.

(Transitions in
tone are much
smoother but

detail is blurred)
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5.2.2 Converting Grayscale to Black & White

When you convert Grayscale images to Black & White, the

original gray shades cannot be retained. To simulate them,

Image Editor groups black and white pixels using a “dithering”

option. Image Editor’s dithering options are adequate for most

situations but are particularly suited for preparing images for

display on monochrome monitors.

Note: You can only convert Grayscale images directly to Black & White.
To convert images of other data types to Black & White, first
convert them to Grayscale.

When you choose the Black & White command in the Image:

Convert submenu, the Convert to Black & White dialog box

opens. This dialog box provides the following options:

Resolution allows you to choose the resolution of the new

image. You can choose the resolution to match that of your

Printer, Display or Active Image or define your own. (If you

select a high resolution, a very large file will be produced and

the conversion may take a long time.)

Dither allows you to choose a dither method. None simply maps

lighter grays to white and darker grays to black. Pattern arranges

pixels in square patterns to simulate gray shades. Diffusion uses

a more random method to dither gray shades. The Diffusion

option generally results in the best conversion.

Original Grayscale image No dither conversion Diffusion dither conversion
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5.2.3 Converting Grayscale to Indexed 16-Color

Converting from Grayscale to Indexed 16-Color involves the

same dither options as those used to convert Grayscale to Black

& White. But these options control how a possible 256 gray

shades are dithered with the 16 colors available in an Indexed

16-Color image. Whichever option you choose, Image Editor

selects a range of 16 grays that match the grays in the original.

These sixteen grays are then used to dither the original shades in

the same way as when Grayscale is converted to Black & White.

5.2.4 Converting RGB True Color to Indexed 16-Color

When you convert from RGB True Color to Indexed 16-Color,

you are converting a possible 16.7 million colors to only 16.

To get the most effective result you need to decide how the

16 colors are chosen and how they are arranged (dithered) to

simulate the millions of colors in the original. Image editor

provides the following options to control this choice:

Palette allows you to select the colors to be included in the new

image’s color table. Standard uses the system’s default 16-color

table, containing the 16 colors available on a standard VGA

display. This option is most useful when you transfer images to

other Windows programs or prepare them for use in a help file.

Choosing the Optimized option creates a color table that is the

closest adaptation of the colors used in the image. In most cases

this option gives the best conversion.

Reserve Entries allows you to reserve some entries in an

optimized palette. For example, if your image is largely green

and blue, you may not have any black in the image, but you may

need black to add text at a later time. Select the Reserve Entries

Black & White option and the color table will contain greens,

blues, black and white. Checking the 8 Prime Colors option

retains red, green, blue, cyan, magenta, yellow, black and white.
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5.2.5 Converting RGB True Color to Indexed 256-Color

Converting True Color to Indexed 256-Color, Image Editor is

faced with the same problem as converting to Indexed 16-Color.

That is, how to represent several million colors with only a few.

The options dialog box for this conversion contains the

following palette and dithering options:

Palette controls the selection of colors for the palette.

3-3-2 (bits) uses the system’s default 256-color (8-bit) table,

based on a combination of eight (3-bit) reds, eight (3-bit) greens,

and four (2-bit) blues. 6-7-6 (levels) uses a palette that offers six

levels (shades) of red, seven levels of green, and six levels of

blue. This is the standard palette used by ZSoft Paintbrush IV

Plus. 6-6-6 (levels) gives the most balanced use of palette color.

This palette offers six levels (shades) of red, six levels of green,

and six levels of blue. This is the standard palette used by the

Apple Macintosh computer. Optimized creates a palette that

matches the range of colors used in the image as closely as

possible and as such normally produces the best results.

Dither provides you with the choice to either not dither or dither

by Pattern or Diffusion. If you choose not to dither, Image Editor

uses the color in the table that is closest to the color in question.

(The other Dither options, Pattern and Diffusion, work in a

similar manner to those described earlier for converting

Grayscale images to Black & White)

Notes:

• To preview an RGB True Color image on a 256-color display,
select the Optimized Palette and Diffusion Dither options. This
provides the best possible results. (Make sure the View Images
With a Common Palette option in the Display dialog box is not
checked.)

• To transfer an Indexed 256-Color image to another program,
you should use the palette option supported by that program.
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6 Painting

Image Editor’s painting tools enable you to easily
“touch-up” and enhance any kind of image. The
painting tools themselves present a variety of
functions from the advanced magic lamp and
clone tool to more common tools like the
paintbrush, eraser and text tool. This chapter
introduces these painting tools, and begins by
describing how to select and work with colors in
Image Editor.
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6·1
Choosing colors

The most important part of painting is choosing the right color.

Image Editor provides a number of ways to help you get this

right and gives you maximum freedom in your choice of how to

display and select colors. The most obvious means of doing this

is with the color palette.

6.1.1 The color palette

The color palette contains colors you can apply to any given

image. The way colors are displayed varies according to the type

of image you are working on. For Grayscale images, the color

palette displays shades of gray. Changing to an Indexed-Color

image switches the color palette to display the 16 or 256 colors

from the image’s color table. For RGB True Color images, a

complete range of colors is displayed in discrete cells or as a

continuous spectrum.

Of the available colors in an image, two are active at any given

time. These two colors, referred to as the foreground and

background color, are displayed in the color squares just below

the color area in the color palette. The foreground color is in the

front, slightly lower and to the right of the background color.
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6.1.2 Selecting colors with the eyedropper tool

The eyedropper tool is used to select foreground or background

colors. This can be done by clicking on a color in an image or in

the color palette. (Whenever you move the mouse pointer over

the color palette, it changes to the eyedropper tool, irrespective

of your current tool selection.)

Clicking the left mouse button selects the color under the

pointer as foreground while clicking the right mouse button

selects the color as the background color. When passing the

eyedropper tool over an image, or the color palette, the color

values of the pixel the tool is on are displayed in the left corner

of the status line.

6.1.3 Selecting colors with the color dialog box

Another method of selecting color is to use the Foreground or

Background Color dialog boxes. These can be accessed by:

• double-clicking on the eyedropper tool icon (accesses the dialog
box for the highlighted color square).

• double-clicking on the foreground or background color squares;
the appropriate Color dialog box opens.
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When the dialog box appears, the current color is displayed on

the right side. To change it, first specify the color model to use:

RGB or HSB. (For more information on color models see the

introductory guide) Your choice determines the function of the

three slider bars in the center of the dialog box. Drag the slider

bars to change the value of each individual color component.

Adjustments you make are reflected in the new color area.

Note: When working with Indexed-Color or Grayscale images, the
selected color is replaced by the closest matching color or
converted to an equivalent gray value.

6.1.4 Selecting colors with the color sliders

Below the color squares in the color palette are the color sliders.

These display the color values of the highlighted square. Moving

the slider arrows changes these values, and thus the color, of the

color square currently highlighted. (You can change which color

square is highlighted by clicking on the non-highlighted one.)

The values are RGB or HSB depending on the model you have

chosen in the Select Color dialog box (see p.89).
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6·2
Editing an image’s color table

The colors in an Indexed-Color image are recorded in a color

table. To view the color table, choose the Color Table command

in the View menu (this command is disabled when the active

image is not Indexed-Color). From this dialog box you can

change the colors in the table, thereby changing the color

composition of the image.

To change the color contained in a cell, click on the cell. The

Select Color dialog box appears. Once you have chosen the new

color, click OK. The new color is inserted into the color table. To

return  to the image, click OK in the Select Color dialog box, the

new color table is stored and the image now reflects any

changes made.

Note: Use this command to globally change a single color in an image,
e.g. from white to black.

 

Color table of an Indexed 16-Color image Color table of an Indexed 256-Color image
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6.2.1 Loading and saving color tables

Image Editor allows you to load and save color tables, enabling

you to optimize a color table for one type of image, and then

apply the same color table to other images. When you load a

new color table, the old table is discarded and the pixels in the

image assume the values of the new table.

During  installation  of the program you had the opportunity to

install some pre-defined color tables. (Color tables appear with

a PAL extension.) These color tables are intended to be loaded

into Grayscale images that you have converted to Indexed 256-

Color. Experiment with them or create your own to achieve the

best possible results.

Note: You can only load color tables containing 16 colors into Indexed
16-Color images. Likewise, color tables containing 256 colors can
only be loaded into Indexed 256-Color images.



PAINTING 91

6·3
Filling an area with color

One of the ways to alter the contents of an image or selected

area is to “fill” it with a color or other image data. When you fill

an image you can control exactly how the fill takes place and

what is used to fill the area. To perform a fill, choose the Fill

command in the Edit menu. The Fill dialog box opens providing

the following options:

Clipboard Data fills the area with image data from the

clipboard. If the area is larger than the contents of the clipboard,

the data is tiled to fill the area. If the area is smaller, the

clipboard image is cropped. Checking the Start From Selection

option places the clipboard image’s top left corner at the top left

corner of the selected area (or top left corner of the bounding

box of a non-rectangular selection area). When unchecked, or

when there is no selection, the first copy of the clipboard image

is pasted in the top left corner of the active image; subsequent

copies are tiled to the right and below it, until the image or

selected area is filled. (If you are filling several areas in an image

and you want the clipboard images to align, do not check this

option.)

Note: To put a large clipboard image into a small area and be able to
choose which part appears in the image, use the Into Selection
command in the Paste: Edit submenu (see p.36).

Selecting the Foreground to Background or Background to

Foreground options enables the Gradient Fill Style options at

the bottom of the dialog box. The three options, Linear,

Rectangular and Elliptical, set the basic gradient pattern that

will be used in the operation. How this pattern is created

depends on how you define the area to fill.



92 IMAGE EDITOR USER GUIDE

To use a gradient fill:

1. Select the image, or area, you wish to fill. (Gradient fills can only
be used in Grayscale or RGB True Color images.)

2. Choose “Fill” from the Edit menu.

3. Select the Foreground to Background Color option. The
Gradient Fill Style box is enabled.

4. Click on the Linear option.

5. Click OK. The dialog box closes and the mouse pointer changes
to the fill pointer.

6. Click on the point at which you want the fill to start changing
from the foreground color and drag your mouse to the point
where you want it to reach the background color. Release the
mouse button to fill the selected area. Any area before the start
point and after the end point is filled with the foreground and
background colors respectively.(If you have created a selection
area, only the area within the selection is filled.)

Notes:

• The gradient fill option is modal, that is, you can repeat the fill
until you deselect the fill tool. This allows you to experiment
with different effects as well as being able to change the
foreground or background colors. (If you are filling a selection
area the selection area is not floating.) To end the fill, press the
Esc key, change tools or choose a new menu command.

• When using the rectangular or elliptical option, holding down
the Shift key as you draw produces a square or circle fill.
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Sample gradient fills, from left: Linear, Rectangular, Elliptical

6.3.1 Using Clear and drag-and-drop to fill

The quickest way to fill an image is to choose your fill color as

the background color and then use the Clear command in the

Edit menu or press the Delete key. This fills the image, or

selected area, without the need to access the Fill dialog box.

If you wish to use an existing image as the fill, you can copy it to

the clipboard and then paste it into another image.

Alternatively, simply drag an image selection from one image

(with the F key held down) and drop it onto another (see p.38).
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6·4
Using the painting tools

Image Editor comes equipped with a number of tools that allow

you to accurately paint and touch-up areas of an image. How

you use these tools depends on the tool selected and the

operation you wish to perform.

Select a tool by clicking on the appropriate icon in the tool bar.

(When you place your mouse on an image the mouse pointer

changes to reflect the tool you are currently using.) To apply the

tool, move the tool to the point on the image where you want to

start and press the left mouse button. The effect of the tool

continues for as long as you hold the mouse button down.

Most of the tools provide options that you can check or change

by double-clicking on their icons in the tool bar. Of the seven

painting tools three, the paintbrush, airbrush, and line tool,

provide the same options, while the magic lamp, clone, eraser

and text tool provide their own unique options. This section

describes the characteristics of each.

Note: If you have created a selection area, the tools are only applied to
the area within the selection. Use selection areas in this way to
restrict the parts of the image to which enhancements are applied,
protecting the rest of the image from inadvertent changes.
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6.4.1 Selecting brush type and size

Irrespective of which painting tool you wish to use, you should

first decide on the type and size of brush to use. Do this by

double-clicking on the brush button at the top of the color

palette. This opens the Select Shape dialog box in which you

can choose from six different brush shapes and twenty-four

sizes. Experiment with the various options to find the one most

suited to your particular painting operation.

Note: You can also increase or decrease the brush size by moving the
slider (next to the brush button) up or down.

6.4.2 Using the magic lamp

The magic lamp is not strictly a painting tool in the sense that it

does not “paint” over the existing image with a selected color. It

is used to enhance areas of an image by adjusting the existing

pixel values in the area. It provides five functions: blur, sharpen,

darken, lighten and smudge. You choose the function and the

strength of its effect in the Magic Lamp dialog box that appears

when you double-click on the magic lamp icon in the tool bar.

Notes:

• The magic lamp can only be applied to Grayscale and RGB True
Color images.

• Depending on the function selected, you can strengthen or
weaken the effect by dragging the Level slider to the left or right.
A higher value applies a stronger effect than a lower value.

• When you apply a selected function to an area, the tool uses the
shape and size of the current brush each time you press the left
mouse button. Drag your mouse to perform the effect over a
larger area. Click repeatedly to reapply and increase the effect on
a specific area. (Smudging requires you to drag the tool, as it
smudges color from one area into another.)
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Examples of magic lamp effects

Original image Blurring Sharpening

Darkening Lightening Smudging
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6.4.3 Applying color with the paintbrush

The paintbrush applies color to parts of an image. Click the left

mouse button to apply the foreground color or the right mouse

button to apply the background color. (The size and shape of the

applied color are determined by the current brush settings.) If

you drag the paintbrush around, you draw a freehand line.

Double-clicking on the paintbrush icon in the tool bar opens the

Paintbrush dialog box containing the following options:

The Factor combo box allows you to choose the color

components that are applied to the active image.

• HSB replaces any parts of an image, to which you apply the
painting tool, with the applied color.

• Hue and Saturation replaces the hue and saturation of pixels
with those of the applied color but retains their brightness. For
example, if you convert a Grayscale image to RGB True Color,
you can use this option to colorize areas of the image.

• Hue only changes the hue of pixels to the hue of the foreground
color. Use this to change the color of areas in color images.

The Soft edge option blends the edges of painted areas with the

original image by feathering them.

Note: This dialog box can only be accessed if the active image is
Grayscale or RGB True Color.

Painting with all a
color’s components
(image on the left)
and painting with

just the Hue and
Saturation of a

color (image on
the right)
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6.4.4 Cloning parts of an image

Cloning allows you to copy part of an image to another area in

the same image or to another image of the same data type.

To clone part of an image:

1. Click on the clone tool icon.

2. Hold down the Shift key and click with the left mouse button
over the area you wish to clone. (This area is then marked with a
cross-hair and the mouse pointer changes to the clone pointer.)

3. Drag your mouse across another part of the image to begin
painting. The cross-hair changes to a square indicating the area
you are cloning and as you paint you replace the area with
whatever the clone square passes over. (The size and shape of
the area painted are determined by the current brush settings.)

After painting, the cross-hair’s position is determined by the

Continue Drawing option in the Clone dialog box (accessed by

double-clicking on the tool icon). With this option unchecked,

the cross-hair returns to its original point; with it checked, the

cross-hair remains where you left it, allowing you to take a rest

while cloning a large area. The Clone dialog box also allows you

to control transparency and select a soft edge to blend the edges

of your cloned areas with the  image.

Note: Indexed-Color and Black & White images cannot be cloned.

Cloning an image
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6.4.5 Using the airbrush

The airbrush tool produces a sprayed area over the image.

Clicking the left mouse button on the image applies the

foreground color while clicking the right mouse button applies

the background color. (The size and shape of the airbrush are

determined by the current brush settings.) When you use the

airbrush, the color gradually builds up as you drag back and

forth over an area. Staying on one point and keeping the mouse

button depressed increases the density of the color on that

point.

Double-clicking on the airbrush icon opens the Airbrush dialog

box. This dialog box provides the same options as the

Paintbrush dialog box. If you use the Soft Edge option, color is

sprayed like a fine mist. If this option is not selected, color

appears more like grains of sand.

Note: This dialog box can only be accessed if the active image is
Grayscale or RGB True Color.

Painting without a
soft edge (image on
the left) and with a

soft edge (image on
the right)
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6.4.6 Painting straight lines

Use the line tool to paint straight lines in an image. Dragging

with the left mouse button applies the foreground color while

dragging with the right mouse button applies the background

color. (The width and ends of the line are determined by the

current brush settings.)

To draw a line, click on the point at which you want the line to

start and drag  to the point where you want it to end and release

the button. Pressing the Shift key while drawing a line constrains

it to an angle of 0°, 45°, or 90°. Double-clicking on the line icon

opens the Line dialog box which contains the same options as

the Paintbrush dialog box (see p.97).

Note: This dialog box can only be accessed if the active image is
Grayscale or RGB True Color.

Painting a straight
line

      



PAINTING 101

6.4.7 Erasing colors

The eraser tool replaces areas of an image with the current

background color. You can choose to replace all the colors that

the tool passes over with the background color or just replace

the foreground color only. (Use the left mouse button to erase, if

you use the right button there is no effect.)

To use the eraser tool:

1. Select the image or area you want to erase.

2. Choose the color you want to change as the foreground color
and the replacement color as the background color.

3. Double-click on the eraser icon in the tool bar. The Eraser dialog
box appears.

4. Select the Erase Foreground to Background Color option and
click OK to close the dialog box and return to your image.

5. Drag the eraser across an area in the image containing the
foreground color. The foreground color in the area changes to
the background color without affecting any of the other colors.

      

Original image with Erasing foreground color Erasing all colors to
foreground color (gray) to background (black) background (black)
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6.4.8 Adding text to an image

The text tool allows you to add text to an image. In addition to

entering text in a variety of fonts and styles, the text tool also

provides options  to create text with a 3-D shadow as well as use

anti-aliasing to makes the edges of text appear smoother.

To add text:

1. Click on the text tool icon in the tool bar.

2. Click on the area in the image where you want your text to start.
The Text dialog box appears.

3. Enter the text to insert in the Text entry box at the top of the
dialog box. The amount of text entered is limited by the size of
the entry box. To start a new line press Ctrl + M (or Ctrl + Enter).

4. Select the size and style for the text. Set shadow and color effects
as desired.

5. Click OK. The dialog box closes and the text appears on the
image as a floating selection filled with the selected color. The
mouse pointer also changes to the rectangular selection tool to
allow you to re-position the text.

6. To combine the text with the image choose “None” from the
Edit: Select menu.

Note: Anti-aliasing is only available for True Color and Grayscale images.

Adding text to an
image
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7 Enhancing images

Image editing would not be complete without
tools to enhance images. This chapter explains
the use of the Image Editor enhancement tools,
beginning with a look at the commands for
adjusting and correcting color. The final section
of this chapter describes the wide range of special
effects and filters that can be used in conjunction
with these tools to introduce new elements into
your imaging work.
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7·1
Adjusting and correcting color

Some of the more common commands you will use when

working with images are concerned with adjusting and

correcting the color values of an image. This is particularly

important when the colors recorded during a scanning process

are incorrect or you wish to highlight or darken particular parts

of an image. In Image Editor the commands that control this

type of operation, Tone Mapper, Tone Adjustment, Brightness &

Contrast, Hue & Saturation, Invert, Level Adjustment and

Optimize can all be found in the Image menu.

In most instances these commands can be applied to selected

areas or to entire images. However, some of the commands are

not applicable to some data types, or they cannot be applied to

selected areas in certain data types.

Note: If you are not familiar with the terminology used in this chapter
refer to the Glossary in the ImagePals introductory guide.

7.1.1 Understanding mapping curves

When you select the Tone Mapper or Tone Adjustment

commands, a dialog box appears with a graph representing the

color values of the pixels in the active image. The horizontal (x)

axis represents the “input” value, or original value from black at

the left (0) to white at the right (255). The vertical (y) axis

represents the “output”, or remapped value.

Note: For RGB True Color images the right side of the graph can also
represent a primary value, red, green, or blue, depending on the
channel selected in the channel combo box.

When you view the graph, a default mapping curve (line) bisects

the graph on the diagonal. This indicates that for each “input”

value the “output” value is the same (i.e. y=x). By altering this

curve you can change the color values of pixels as follows:
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Normal mapping
curve (y=x)
and image

 

New mapping curve
(y=2x) and image:

All gray values over
128 become white.

 

New mapping curve
(y=½x) and image:

All values are
mapped onto the

range from black to
mid-gray (128).
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7.1.2 Adjusting image tones

The Tone Adjustment command in the Image menu opens the

Tone Adjustment dialog box in which you can adjust the

highlight, midtone and shadow areas in an image. Highlight

areas are those areas that appear brighter or lighter than others.

Shadow areas are dark areas and the midtone areas are

somewhere in between.

Note: Adjusting these options affects the color values of all pixels in an
image or selected area.

In the Tone Adjustment dialog box you normally adjust the

overall tones in an image, but for RGB True Color images, you

can also adjust the three color channels, Red, Green and Blue

individually. How best to adjust the color values of an image is

totally dependent on the type of image you have. Try

experimenting by moving the respective slider controls and

clicking on the Preview button to see the effect on the image.

The following should give you a good idea of what to expect

when you use these controls:

Changing the Highlight enables you to increase or decrease the

brightness of the brighter pixels in an image. Dragging to the

right (a positive percentage) increases this brightness, whereas

dragging to the left (a negative percentage) decreases the

brightness.

Changing the Midtone allows you to adjust midtone pixels

without affecting the highlights and shadows too much. Drag to

the right to lighten the midtones; to the left to darken them.

Changing the Shadow lightens or darkens the darker pixels in an

image. Drag the slider to the right to lighten the shadows or to

the left to deepen them.
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The graph in the Tone Adjustment dialog box displays an added

feature: the histogram. This chart graphically represents the

distribution of color values within an image. The number of

pixels with a particular color is indicated by the vertical “y” axis.

As all colors in the image are shown within this graph, the

distribution of some may be less apparent than others, e.g., light

pixels in a dark image or vice versa. In such cases increase the

Histogram Scale Factor to magnify those color values with fewer

pixels. (This only affects the display of the histogram.)

Sometimes when you access the Tone Adjustment dialog box,

you will see the Auto button enabled. This indicates the image

has no black (x=0, y=0) and/or white (x=255, y=255) pixels. In

such cases clicking the Auto button redraws the mapping curve

to map the original values onto the complete range of colors

from black to white. This improves the contrast in an image and

is recommended (for most images) before you start adjusting

any color values.

Note: If you have selected an area of the image, only the area within
the selection is affected.

Sample histogram
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7.1.3 Using the tone mapper curve

The previous section discussed how to change the color values

of pixels within an image by using the Tone Adjustment dialog

box. At times this may be too general and not specific enough for

your needs. In such cases use the Tone Mapper to apply finer

adjustments to more specific ranges of color values.

Note: This command is primarily aimed at calibrating your input and
output devices. As such you will find it is provided as an
extension to both the input/scanning process as a post
processing option (see p.131) and the printing process. To aid in
this calibration you can also load and save curves for subsequent
use.

When you display the Tone Mapper dialog box you only see a

graph and mapping curve. You can adjust this curve directly by

dragging your mouse over the graph or by selecting a predefined

enhancement using the Enhance Button.

Note: Each time you select an enhancement option the enhancement
is applied to the default curve (i.e x=0 y=0).To apply different
enhancements sequentially check the Accumulatively option.
This applies each enhancement to the existing curve.

After adjusting the mapping curve you may feel the curve is not

“smooth” enough – simply click on the Smooth button and it

smoothes out automatically. You can also use the Smooth

button to reduce the effect of a new tone curve as it makes the

curve tend towards the default.
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You may have noticed that the color value graph includes a 5×5

grid pattern. Each square block within that grid represents a

possible 51 consecutive color values (on a scale from 0 to 255). If

you want to edit only those values within a block or you wish to

have more restrictions on your adjustments click on the Show

Control Points option. This places handles at each point where

the mapping curve intersects the grid. After adjusting the

control points you can apply other enhancements or smooth the

curve, but the control points will disappear.

Note: Points to remember: the left area represents darker pixels; the
right lighter. Raising the curve lightens color values; lowering
the curve darkens color values.

7.1.4 Changing brightness and contrast

The Brightness & Contrast command in the Image menu allows

you to adjust the lightness and darkness as well as the difference

between areas of light and dark colors in an image or selection

area. Use this when you want to perform a general adjustment

to the brightness and contrast of pixels in an image.

Note: For RGB True Color images you can also edit the individual color
channels, Red, Green or Blue.
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7.1.5 Changing hue and saturation

The commands mentioned so far deal primarily with the

lightness and darkness of pixels. Sometimes you may only want

to change the color (hue) or purity (saturation) of colors. To

change the hue and saturation of an image choose the Hue and

Saturation command in the Image menu, the Hue and

Saturation dialog box opens. For best results experiment by

moving the sliders and previewing your changes.

7.1.6 Inverting colors

The Invert command in the Image menu reverses the colors in

an image. If your image has shades of black, they are inverted to

reflect shades of white. For color images each pixel changes to

its complementary color (e.g. blue changes to yellow).

Image before and
after inverting
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7.1.7 Adjusting the number of displayable colors

The Level Adjustment command allows you to reduce the

number of gray or color shades in an image or selected area.

This is useful when you want to reduce the number of colors in

an image to enable a compression scheme to compress the

image more, or to create special effects.

Note: Unless you are using a well calibrated monitor with a True Color
display driver, you may not notice any change in images when
you select higher numbers of levels (up to 64). But when you
output the image the changes may be more apparent.

Image before and
after reducing the

number of
displayable colors
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7.1.8 Optimizing an image’s color

The Optimize command attempts to generate the best possible

color for an image or selected area by redistributing the pixels

across the full range of gray or color values. This effect will vary

from one image to another, depending on the original

distribution of the gray/color values. In general, optimizing pixel

values will make detail in the darker shadow areas more

apparent.

One good way to understand the process of optimization is to

view the histogram of an image (choose the Tone Adjustment

command) and then apply the optimize command. This time

when you view the histogram of the image the color values will

be distributed throughout the image.
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7·2
Applying special effects

Image Editor provides different commands that can be used to

enhance images and create special effects. You can apply these

commands to entire images or just to selected parts. However, it

is only possible to apply them to RGB True Color and Grayscale

images. If you wish to apply special effects to other image data

types, first convert them to Grayscale or RGB True Color.

Blurring images

The Blur command in the Effect menu allows you to reduce the

contrast of pixel values in an image to create a softer image.

Images can be blurred in three ways: Slightly, More, and

Heavily. To blur an image more selectively, use the magic lamp

blur option. This has the same effect as the Blur commands

except that you perform the operation on a small area rather

than the entire image or selected area.

Image before and
after blurring
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 Sharpening images

The Sharpen command in the Effect menu increases the

contrast between light and dark pixels in an image. This is

essentially the opposite of blurring an image. Images can be

sharpened in three ways: Slightly, More, and Strongly. To

sharpen an image more selectively, use the magic lamp sharpen

option. This has the same effect as the Sharpen commands

except that you perform the operation on a small area rather

than the entire image or selected area.

Image before and
after sharpening
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Removing “noise” from an image

”Noise” in an image refers to stray pixels that are significantly

different in color from surrounding pixels. For example, a black

pixel appearing in a predominantly white area. (This often

happens when scanning poor quality images.) Choosing the

Despeckle command in the Effect menu clears up these stray

pixels and blends them into the background color. Larger areas

of color, different from surrounding areas, have their edges

softened slightly.

Emphasizing the edges of an image

An edge in an image is defined as the parts of an image where

significant changes in color occurs. The Emphasize Edges

command in the Effect menu outlines such changes in color,

effectively increasing the contrast along edges by making them

harder and more sharply defined.

Image before and
after emphasizing

edges
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Marking the edges of an image

The Find Edges command in the Effect menu differs from the

Emphasize Edges command in that it inverts the edges of an

image and obscures the rest of the image with black. The color

of the lines varies depending on the image format you are

working on. Grayscale images produce lines of white and

varying shades of gray. RGB True Color images produce either

white or colored lines.

Image before and
after find edges

Note: Inverting an image you have applied “Find Edges” to creates a
“pencil-drawn” effect.

Adjusting an image for video

The Adjust for NTSC Preview command in the Effect menu

allows you to see an image as it would appear when viewed on

an NTSC device. This is particularly useful when you want to

know how an image will look when it appears in a video

sequence of a video editing program.

Note: Depending on the image and your current display mode, using
this command may not produce any visible effect.
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Warping an image

Warping is a method of distorting a Grayscale or RGB True Color

image using a grid (or mesh) based pattern. This grid is visible

on a sample image that appears in the Warping dialog box,

accessed by choosing the Warping command in the Effect

menu. In this dialog box you can define the size of the grid

squares, quality of the warp and whether or not to show the

control points that appear at grid intersections.

To warp an area, click on a control point (or at a grid

intersection if the control points are hidden) and drag it. (You

can only drag within squares bordering the control point

selected.) When you release the mouse, the grid redraws to

accommodate the new position. To see the effect on the sample

image, click the Testing button. (If you want to see how the

effect looks on the actual image, click on the Preview button.)

Note: In most cases checking the Good option for Quality Control will
produce more than adequate results. If you want even better
results, check the Better option. This does however require more
time to perform the effect.

Image before and
after warping
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Custom Filter

Many of the effects provided by Image Editor work by

regenerating a pixel value based on its original value and the

value of its surrounding pixels. The Custom Filter command

allows you to create your own effects in a similar way using a 5

by 5 pixel matrix.

To create your own filter:

1. Select the image you want to apply the filter to.

2. Choose “Custom Filter” from the Effect menu. The Custom
Filter dialog box opens.

3. In the Symmetry combo box, select one of the following:

• No – this provides no symmetry.

• Horizontal – selecting this option duplicates the value in the
horizontally opposite cell.

• Vertical – selecting this option duplicates the value in the
vertically opposite cell.

• 4-Way – this option duplicates values in the three cells that form
the other corners of a square around the center.

4. Enter values in the matrix cells. The cell in the middle of the
matrix represents the pixel whose value is going to be
regenerated. The surrounding cells represent the surrounding
pixels. (The Divided by value changes to show the total value of
all the cells.)

5. Change the Divided by value to affect the overall tone of the
image. The higher the value, the darker the image; the lower the
value, the lighter the image. This value automatically adjusts as
you change other options to retain the overall tone (optional).

6. Check the Invert option to invert the gray/color values of the
image.

7. Click OK. The filter is applied to the image.

Note: You can only create custom filters for use with RGB True Color
and Grayscale images. Once created you can then save them for
future use or editing.
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Changing your wallpaper

Although not strictly an effect, the Set as Wallpaper command in

the Effect menu is a useful feature that allows you to make any

BMP file the current Windows wallpaper. (This command is

disabled if the active image is not BMP.) When you choose this

command, you have the choice of either tiling the image or

centering it. Once chosen, the wallpaper is changed

immediately. If you the image appears too big or too small, use

the Resample command in the Image menu (see p.71) to resize

the image accordingly.

7.2.1 The Special Effects command

Apart from the above filters and effects, Image Editor also

provides a number of additional options in the Special Effects

dialog box (opened by choosing the Special Effects command in

the Effect menu). The kind of effect that can be applied depends

on the data type of the active image, e.g. for RGB True Color

images you can choose from a maximum of 15 effects. To

perform an effect, simply choose it from the Effect combo box.

The effect is immediately reflected in the sample images at the

bottom of the dialog box. (If you want to see how the effect looks

on the actual image, click on the Preview button.) The following

section describes each of the effects available in the Special

Effects dialog box:
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Average

The Average effect recalculates the value of a pixel in an image

by averaging its value with the values of the surrounding pixels.

By moving the slider in the Factor group box you can specify the

number of pixels with which each pixel is averaged. For

example, a square size of 4 pixels defines a 4×4 cell containing

16 pixels to be used for calculating the average pixel values. The

averaged value then replaces the original value of the pixel

resulting in a softer image with smoother transitions in color.

Blast

The Blast effect is only available for RGB True Color images and

simulates the effect of a strong cold wind. This causes the image

or selected area to develop icicles. Use the direction options to

show the wind blowing to the left or right, and the slider to

increase or decrease the intensity of the wind.

Cool/Warm

The Cool and Warm effects are only available for RGB True

Color images. They work by enhancing the hue of pixels

containing particular color values. Increasing the Level leads to

a corresponding increase in the particular hue values – making

the images appear “cooler” or “warmer”. The Cool effect

enhances the hue of pixels with a blue or cyan component while

the Warm effect enhances the hue pixels with a red or yellow

component.



ENHANCING IMAGES 121

Emboss

The Emboss filter makes an image appear to be “raised” or

“stamped” from paper of a particular color. In the Factor group

box you can select this color as either the current foreground or

background color. You can also define how deeply the image is

stamped by moving the slider to the right; to make the image

appear raised, move the slider to the left.

Image before and
after embossing

Facet

The Facet command breaks an image up into squares which are

then “shifted” in a random order. To control the size of the

squares, use the Square Size slider. The Shift Value slider

changes how the squares are moved around the image.
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Fat/Thin

Selecting the Fat option distorts an image out to the sides,

effectively making the center of an image appear fatter. The

higher the Level the greater the distortion. The Thin option

works in the opposite way by squeezing the image in from the

sides to make the center of an image appear thinner. Again, the

higher the Level the greater the distortion.

Note: For best results ensure that your subject is in the center of your
image or selected area.

Image made fatter
(on the left) and

thinner (on the
right)
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Fish Eye

The Fish Eye effect creates a convex circle in the center of an

image or selected area. This results in a distorted 3D effect

which is controlled by the slider bar.

Note: For best results ensure that your subject is in the center of your
image or selected area.

Image before and
after applying the

fish eye effect

Mosaic

This filter breaks an image into blocks containing pixels of the

same gray/color value. (Use the slider to specify the size of the

blocks.) The pixels within each block are averaged together to

produce the color value for all the pixels in the block. This is

similar to the technique some television companies use to

obscure the faces of people who wish to remain anonymous.
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Motion Blur

Using this effect creates the appearance that the image is

moving. This effect is commonly produced in photographs

showing people and objects moving at high speed. Changing the

Angle changes the direction of the movement while the Moving

Offset slider allows you to define how much the image moves by.

Puzzle

The puzzle effect divides an image into a grid. The sequences of

the grid are then randomly rearranged. The size of the squares in

this grid is determined by the slider. Each square is surrounded

by a border which takes its color from the current background

color.

Image before and
after applying the

puzzle effect
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Stagger

The Stagger effect is only available for RGB True Color images.

When you select this effect the image is distorted horizontally,

producing a severe zigzag effect along the image or selected

area. Using the direction options you can change the stagger to

the left or right.

Tile

The Tile effect is similar to the puzzle effect except that the

image is broken up into square blocks rather than a grid. To

control the size of the squares, use the Square Size slider. The

Shift Value slider determines how the squares are moved

around the image. (When the squares overlap each other, the

background is filled with the current background color.)

Image before and
after applying the

tile effect
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Watercolor

The Watercolor effect is only available for RGB True Color

images. Applying this effect gives the impression that the image

has been created using watercolors. By adjusting the Stroke Size

you can specify the size and length of each paint stroke. Moving

the slider to the right adds more water to the paint, making the

edges appear darker than the center.

Windy

Windy is similar to the Blast effect and can only be applied to

RGB True Color images. Use this to create “wisps” of wind over

the image. To control the direction of the wind use the direction

options, and the slider to determine how hard the wind is

blowing.
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8 Image input & stitching

All types of photographs, illustrations, and even
video frames can be brought into Image Editor
via a range of input devices. This chapter
introduces the commands that access image
input devices and then goes on to describe the
different options Image Editor provides for
combining images.
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8.0.1 Before you begin

The Acquire, Source, Import and Export commands in the File

menu provide ways to access external software drivers. The

commands in the Import and Export submenus change

according to installed drivers. Because of this flexibility, we

cannot describe all the possibilities here. For information about

the use of an installed driver, please refer to its documentation

and on-line help.

Note: All external image sources involve some sort of hardware and an
associated software driver. Different sources require different
installation procedures and provide different facilities. To find
out about these, please refer to the manufacturer’s
documentation.
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8·1
Importing and exporting

The Import and Export submenus in the File menu provide

access to external software modules expanding Image Editor’s

ability to access and output image files in special formats and for

special devices.

To install modules, run the Driver Setup program and select the

Import/Export module option. Click OK and in the subsequent

screen, choose the module you wish to install or select “Others”

to install an unlisted driver. Unlisted modules require a disk

containing the module’s driver file and an OEM.INF  file.

Because the Import and Export submenu commands access

specific functions and devices, you won’t be able to use any that

appear unless you have a suitable device. Devices supported by

modules available for Image Editor include Photo CD drives and

special printers like the Kodak XL 7700.

8.1.1 The TWAIN commands

TWAIN is an industry standard that allows applications to use

input devices without a complex installation procedure. It has

been described as “providing seamless connection between

applications and devices”.

If you have a TWAIN-compatible device you should follow its

installation procedure. Once correctly installed, you will be able

to use the device from Image Editor or any other application

that supports TWAIN without worrying about compatibility

problems.
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Acquire

Choosing the Acquire command in the File menu accesses the

software driver for the device selected in the Select Source

dialog box. When you choose the Acquire command, a dialog

box appears. This dialog box varies according to the image input

device you have installed.

Note: If you select the Acquire command and you do not have a
TWAIN device installed, you will see an error message. If you do
have a TWAIN device, but it is incorrectly installed, a dialog box
appears containing installation options.

The source options

The Source submenu in the File menu contains commands that

allow you to select your TWAIN source and define post

processing options. The Select command opens the Select

Source dialog box that lists all your available input sources. To

select a source, click on the source and then press OK. If you

have only one source, it is automatically selected. The other

commands define what happens to the image after scanning.
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Performing post processing

When you input an image, Image Editor allows you to perform a

variety of post processing commands: Auto Tone Adjustment,

Brightness and Contrast (see p.109), Tone Adjustment (see

p.106), Tone Mapper (see p.108) and Scan to Printer. The Auto

Tone Adjustment command is applied during the input process

whereas the others, except for Scan to Printer, invoke their

respective dialog boxes once the image has been created. The

Scan to Printer command opens the Print dialog box, allowing

you to specify how the image is printed before input.

Note: When you choose a command, a tick appears to the left of the
command. Choosing the command again deselects it.

Auto Tone Adjustment automatically adjusts the highlights and

shadows and remaps newly input images onto the full range of

available colors, improving contrast in the image. When you

select Auto Tone Adjustment you also have the option of

adjusting midtones. In the spin box at the bottom of the dialog

box, enter a value from -100% to 100%. Negative values darken

the midtones, positive values lighten them. Select a value of 0 if

you only want to remap the image to use the full range of colors

available.
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8·2
Joining image strips

If your scanner cannot scan the whole of a picture in one pass,

you can input the entire picture by scanning the picture in strips

and then joining the resulting images. In this situation, the

ability to join images accurately and efficiently is essential.

Image Editor provides two approaches to this function through

the Tile Two Images and Stitch commands in the Edit menu.

With both “Tile Two Images” and “Stitch” you choose an image

and the position to place it relative to the active image. The

major difference between the two commands is that “Tile Two

Images” joins images with a specific distance between them

while “Stitch” provides multiple options and controls for both

manual and automatic joining.

Use “Tile Two Images” to create special effects or to join two

images when the joint is not critical. Special effects can include

placing the same image against itself or by joining a flipped

version of an image to the original to create a mirrored effect.

“Stitch” is the command of choice where pixel-level control and

seamless joining is important.

Note: You can only join images that share the same data type and are
either Grayscale or RGB True Color. To join images of other data
types, first convert them to Grayscale or RGB True Color.
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To join two images using the Tile Two Images command:

1. Make one of the images you wish to join active by clicking on its
title bar.

2. Choose “Tile Two Images” from the Edit menu. The Tile Two
Images dialog box appears. In the preview window the active
image and floating image (with a gray shadow) appear.

3. In the Floating Image combo box, select the image you want to
join to the active image. The image selected here appears as the
floating image in the preview window.

4. Use the Direction arrows to place the floating image relative to
the active image.

5. In the Distance entry box, enter the distance you want between
the edges of the images. If you enter a positive value, the gap
between the active and floating images is filled with the current
background color. If you enter a negative value, the images
overlap with the combination in the overlap area being
controlled by the Transparency option.

6. Click OK. The dialog box closes and a new window appears
containing the joined images.
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8·3
The Stitch command

The Stitch command in the Edit menu opens the Stitch dialog

box. This dialog box is similar to the Tile Two Images dialog box

except that it does not have the Distance and Transparency

entry boxes; the OK button is also replaced by a Place button.

Clicking on the Place button puts Image Editor into “Stitch”

mode. In this mode, the Image Editor workspace is cleared

leaving only the two images to be stitched. The normal Image

Editor menus are replaced by special Stitch menus. In Stitch

mode you can use the following options:

• set auto-stitching parameters and make Image Editor
automatically match and align the floating image on the active
image.

• drag the floating image until it matches with the active image.

• define a reference point in each image, by holding shift down
and clicking first in one and then in the other, Image Editor then
aligns the images on these points.

• select “Auto Fine Tune” in the Option menu to aid in manual
stitching.

• set the transparency of the floating image to aid manual
stitching and to define how images are combined in the overlap
area.

8.3.1 Operating in Stitch mode

Stitch mode allows you to find the best alignment of two images

by combining the use of manual, automatic, and assisted joining

functions. In this mode there are three menus and one menu

bar command.
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Action menu

Auto Stitch... choosing this command opens the Auto Stitch

dialog box. At the same time a horizontal or vertical line appears

on the active image. This line represents the approximate

position to which the floating image should overlap. This line is

moved by dragging the Overlap Range slider.

Note: If the overlap is too small (less than thirty pixels), the chance of
a successful match is greatly reduced.

As well as adjusting this overlap range, a second control,

“Horizontal/Vertical Tolerance”, allows you to provide for

misalignment in the other direction. The tolerance should be

slightly greater than the distance the floating image needs to

move (horizontally or vertically) to align with the active image.

Clicking OK in this dialog box automatically repositions the

floating image to match the active image according to the

overlap and tolerance parameters you have defined.

Done stitches the two images together. The Image Editor

window reappears as it was before stitching with an additional

window containing the newly stitched image. (Double-clicking

on the non-active image has the same effect.)

Note: If you try to exit Stitch mode by selecting “Close” from the
control menu, a message, “Please complete the Image Editor
operation first”, appears. Click OK and, if you don’t want to
continue stitching, select “Quit” from the Action menu.
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View menu

Actual view returns the view of the images to the normal (1×)

view where each image pixel is shown by one screen pixel. If you

are already at actual view, this command has no effect.

Zoom In and Zoom Out change the view of the images one step

at a time. Use these commands if you want to view a magnified

or reduced portion of the images to enable you to stitch more

accurately.

Transparency... opens the Transparency dialog box. This dialog

box allows you to specify the transparency of the floating image.

Wile you are placing the floating image, use a transparency of

50% to enable you to see both images equally. Before stitching,

choose another transparency to define how the area of overlap

appears after stitching. Selecting 0% causes the floating image to

obscure the active image in the area of overlap. A 100% selection

causes the active image to obscure the floating image.

Option menu

Auto fine tune automatically fine-tunes the position of the

floating image immediately after you have moved it by dragging

or by defining matching points. To be successful the floating

image must be placed fairly close to its final destination (within

thirty pixels either way). This option usually achieves the best

result with the least amount of effort.

Note: When you choose the Auto Fine Tune command, a tick appears
to the left of the command, thus enabling it. Choosing the
command again deselects it.

Help! menu bar command provides you with direct access to

help on the stitching process.
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To stitch two images manually:

1. Make one of the images you wish to join the active image.

2. Choose “Stitch” from the Edit menu. The Stitch dialog box
appears.

3. In the Floating Image combo box, select the image you want to
join to the active image. The image selected here appears as the
floating image (with a gray shadow) in the preview window.

4. Use the Direction arrows to place the floating image relative to
the active image.

5. Click on the Place button. Image Editor enters Stitch mode.

6. Drag the floating image until you are satisfied with its position.

7. Double-click on the image or select “Done” from the Action
menu. You exit Stitch mode and a window appears containing
the stitched image.

Notes:

• An alternative to dragging is to define a matching point in each
image: hold Shift down and click on a point in one image and
then on a point in the other. Image Editor then moves the
images to match on these corresponding points. To improve
either method, choose “Auto fine tune” from the Options menu
before setting reference points or dragging.
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Stitching images by defining reference points

1. Original matching point, defined by holding down Shift and clicking on the floating
    image

2. Corresponding matching point, defined by holding down Shift and clicking on the active
    image
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A
Acquire command  130

Actual View command  28

Add a View command  25

Adding text to an image  102

Adjust for NTSC Preview command  116

Adjusting image values  104 –12

Airbrush tool  99

Arrange Icons command  20

Auto Stitch command, (stitch mode)  135

Auto Tone Adjustment command  131

Average effect  120

B
Background color  87

Batch manager  32

Blast effect  120

Blur command  113

Border command  58

Brightness & Contrast command  109

Brush shape and size button  95
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C E
Cascade command  20 Editing an image’s color table  89

Choosing colors  86 Elliptical selection tool  53

Clear command  93 Emboss effect  121

Clipboard viewer  37 Emphasize Edges command  115

Clone tool  98 Eraser tool  101

Close Command  24 Exiting Image Editor  24

Close Quickly command  33 Expand command  51

Color palette  86 Export command  129

Color tables, Indexed-Color images  89 Eyedropper tool  87

Command reference table  10 F
Converting images  79

Facet effect  121
Cool effect  120

Fat effect  122
Copy command  35

File Formats, Preferences  46
Create a new image  18

Fill command  91
Create a new group, (object pool)  64

Find Edges command  116
Crop command  69

Fish eye effect  123
Custom Filter command  118

Fit in Window command  27
Cut command  35

Flip command  73

D Freehand selection tool  52

Delete
groups  64
images  93
objects  64

Free Resize command  72

Full Screen command  28

G
Global viewer  28Despeckle command  115
Gradient fill  91Discard Floating command  49

HDisplay a clipboard image  37

Display command  45
Histogram  107

Distort command  78
Hue & Saturation command  110

Drag and drop
between Windows  38
to the Object Pool  41
to the workspace  40

Driver Setup program  129

Duplicate command  18
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I O
Image Information command  30 Object pool  61

ImagePals program group  8 OLE & Clipboard, Preferences  44

Import group command, (object pool)  64 Open command  16

Import command  129 Optimize command  112

Invert command  110 P
L Paintbrush tool  97

Level Adjustment command  111 Paste  36

Line tool  100 Post processing, (stitch mode)  131

Load files to the clipboard  37 Photo CD, Preferences command  44

Load color tables  90 Preferences
Display  45
File Formats  46
Image Editor  42
Memory  46
OLE & Clipboard  44
Photo CD  44

Load Mask command  65

M
Magic lamp tool  95

Magic wand tool  50

Make floating command  49
Print

files  22
Setup command  22

Managing images  20

Masks  62

Memory, Preferences command  46 Puzzle effect  124
Merge control command  59

R
Mosaic effect  123

Rectangular selection tool  53
Motion blur effect  124

Resample command  71
Move tool  54

Resolution command  70
N Restore command  34
New

image  18
group (object pool)  64

Rotate command  74

Running Image Editor  8



142 IMAGE EDITOR USER GUIDE

S Set as Wallpaper command  119

Save
files  21
to Album  21
to the clipboard  37
to the object pool  62

Sharpen command  114

Show/Hide commands  28

Similar command  57

Slant command  77

Source command  130Select
All command  49
areas of similar colors  50
brush type and size  95
irregularly shaped areas  52
None command  18
regularly shaped areas  53

Special effects
Average  120
Blast  120
Cool  120
Emboss  121
Facet  121
Fat  122
Fish Eye  123
Mosaic  123
Motion blur  124
Puzzle  124
Stagger  125
Thin  122
Tile  125
Warm  120
Watercolor  126
Windy  126

Selection areas
floating  49
non-floating  49
marquee  36
moving  54
paste as  36
paste into  36
resize  72
rotate  74
slant  77
tools  50 –4

Stitch command  134Selecting colors
with the color dialog box  87
with the color sliders  88
with the eyedropper tool  87

System Information command  30
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T
Text tool  102

Tile effect  125

Tile Two Images command  132

Tone Adjustment command  106

Tone Mapper command  108

Tone mapping curve  104

Tool reference table  10

Tools
Airbrush  99
Clone  98
Elliptical  53
Eraser  101
Eyedropper  87
Freehand  52
Line  100
Magic wand  50
Paintbrush  97
Rectangular  53
Text  102
Zoom  27

U
Undo command  34

V
Viewing an image  25 –9

W
Warping command  117

Z
Zoom In command  26

Zoom Out command  26


