Welcome to CIDview

CIDview overview

CIDview monitors the selected telephone line and reports the Caller ID whenever there is an incoming call. It is designed to work with all versions of Windows - 95/98/NT and is TAPI compliant.

CIDview is simple to use - just select the device you want to use to detect the Caller ID and press Start.

When a call arrives CIDview will display the Caller's details in the center of the screen.

Application Launcher

CIDview can be made to automatically launch other applications when an incoming call is detected. You can pass the caller's phone number and name as parameters.

Variable | Replaced with
$RV_CIDNAME | Caller's name (if supplied)
$RV_CIDNUMBER | Caller's number (if supplied)
$RV_DATETIME(format string) | Date and time according to the format string specified. C function's strftime() notation is used when specifying the date and time format.

Example : The command line below will launch Excel and attempt to load the spreadsheet which has the caller's name as its filename.

excel d:\customers\$RV_CIDNAME.xls

Example : The command line below will write the time, phone number and name of each caller into a file called callsMMDD.txt in directory c:\worklog.

command.com /c echo $RV_DATETIME(%H:%M:%S) $RV_CIDNUMBER $RV_CIDNAME >> c:\worklog\calls$RV_DATETIME(%m%d).txt

Registering CIDview

If you use CIDview in a commercial environment, you must register it. The registration costs are:

1-10 licenses : US$ 10 per copy
10-100 licenses : US$ 5 per copy

For information on Katalina Technologies' products, visit:

 http://www.katalina.com.au