Guide de l'utilisateur relatif aux outils de déploiement en entreprise de Microsoft Windows

bannière1 bannière2

Windows XP

Les outils de déploiement en entreprise vous aident à préinstaller, personnaliser et déployer les produits suivants :

puce | Windows XP Édition familiale, Service Pack 2 (SP2)
puce | Windows XP Professionnel, Service Pack 2 (SP2)

Famille Windows Server 2003

Vous pouvez également utiliser ces outils de déploiement en entreprise pour préinstaller, personnaliser et déployer les versions de Windows suivantes :

puce | Windows Server 2003, Standard Edition, Service Pack 1 (SP1)
puce | Windows Server 2003, Enterprise Edition, Service Pack 1 (SP1)
puce | Windows Server 2003, Datacenter Edition, Service Pack 1 (SP1)
puce | Windows Server 2003, Web Edition, Service Pack 1 (SP1)
puce | Windows XP Édition 64 bits version 2003 pour les systèmes étendus 64 bits
puce | Windows XP Édition 64 bits version 2003 pour les systèmes Itanium

Disponibilité limitée de versions linguistiques de Windows

Les versions ci-dessous de Windows sont uniquement disponibles en anglais et en japonais :

puce | Windows Server 2003, Standard Edition pour les systèmes étendus 64 bits
puce | Windows Server 2003, Enterprise Edition pour les systèmes étendus 64 bits
puce | Windows Server 2003, Datacenter Edition pour les systèmes étendus 64 bits
puce | Windows XP Édition 64 bits version 2003

© Copyright 1985-2004 Microsoft Corporation. Tous droits réservés.


Impression de la documentation

La commande Imprimer de la Visionneuse de l'aide HTML permet d'imprimer une seule rubrique ou toutes les sous-rubriques d'un titre.

Pour imprimer des rubriques de cette documentation

  1. Sélectionnez une rubrique ou un titre (livre) sous l'onglet Sommaire.
  2. Cliquez sur le bouton Imprimer de la barre d'outils, puis suivez les instructions qui s'affichent.

    — ou —

    3. Cliquez avec le bouton droit sur le livre sélectionné, cliquez sur Imprimer, puis suivez les instructions qui s'affichent.


Utilisation des outils de déploiement en entreprise

Le fichier Deploy.cab situé dans le dossier Support\Tools du CD-ROM du produit Windows contient plusieurs outils que les administrateurs d'entreprise et les informaticiens peuvent utiliser pour déployer Windows sur plusieurs ordinateurs au sein d'une organisation.

Outils de déploiement

Le fichier Deploy.cab contient les outils suivants :

  • Assistant Gestion d'installation : Assistant qui automatise la création et la modification de partages de distribution pour préinstaller des systèmes d'exploitation Microsoft et diverses applications.
  • Préparation du système (Sysprep) : prépare le disque dur d'un ordinateur pour la duplication de disque, l'audit et la livraison au client. Vous devez exécuter Sysprep pour resceller les ordinateurs avant de les distribuer. Sysprep contient les composants suivants : Sysprep.exe, Setupcl.exe, Factory.exe, Sysprep.inf et Winbom.ini. Les fichiers d'application (Sysprep.exe, Setupcl.exe et Factory.exe) sont obligatoires et dépendent les uns des autres.
  • Cvtarea : outil flexible permettant de créer des fichiers et d'analyser le placement de ces fichiers sur un système de fichiers FAT32 ou FAT. Avec l'outil Cvtarea, vous pouvez créer et placer un fichier contigu à un emplacement spécifique du disque.
  • Oformat : crée un volume FAT32 avec des clusters alignés d'une manière optimale en vue d'une conversion future au format du système de fichiers NTFS.

Prise en charge des outils de déploiement en entreprise pour les versions du système d'exploitation

L'ordinateur du technicien est l'emplacement où vous installez les outils de déploiement en entreprise, en extrayant ces outils à partir du fichier Deploy.cab. L'ordinateur de destination est l'ordinateur que vous livrez à l'utilisateur final.

L'ordinateur du technicien doit exécuter l'un des systèmes d'exploitation suivants :

  • Windows XP
  • Famille Windows Server 2003
  • Windows 2000

Il n'est possible d'installer qu'une seule version des outils de déploiement sur l'ordinateur du technicien. Chaque version des outils de déploiement fonctionne avec la version de Windows livrée avec ces derniers et les versions antérieures de Windows.

N'installez pas les outils de déploiement en entreprise sur Windows XP Édition 64 bits, la version 64 bits de Windows Server 2003, Enterprise Edition ou la version 64 bits de Windows Server 2003, Datacenter Edition.

Important

  • Utilisez toujours la version de Sysprep correspondant à la version du système d'exploitation Windows que vous déployez. Si vous déployez un Service Pack, utilisez la version de Sysprep correspondant à ce Service Pack spécifique.
Version des outils sur l'ordinateur du technicien | Système d'exploitation à déployer
 | Windows XP | Windows XP SP1 | Windows Server 2003 | Windows XP SP2 | Windows Server 2003 SP1
Windows XP | X |  |  |  |
Windows XP SP1 | X | X |  |  |
Windows Server 2003 | X | X | X |  |
Windows XP SP2 | X | X | X | X |
Windows Server 2003 SP1 | X | X | X | X | X

Lorsque vous procédez à une mise à niveau vers les outils de déploiement en entreprise de Windows XP SP2 ou Windows Server 2003 SP1, aucune modification n'est apportée aux fichiers du produit Windows disponibles situés dans les partages de distribution. Vous devez utiliser la page Produit de l'Assistant Gestion d'installation pour charger les fichiers du produit Windows correspondant aux nouvelles versions de Windows, par exemple Windows XP SP2 ou les membres de la famille Windows Server 2003.

La mise à niveau vers les outils de déploiement de Windows XP SP2 ou Windows Server 2003 SP1 met à jour les fichiers de modèles utilisés par l'Assistant Gestion d'installation lors de la création d'un fichier de réponses. Tous les fichiers de réponses créés avec l'Assistant Gestion d'installation de Windows XP SP2 ou Windows Server 2003 SP1 utiliseront les nouvelles valeurs par défaut.

Documentation contenue dans Deploy.cab

Le fichier Deploy.cab contient deux manuels en ligne.

  • Le Guide de l'utilisateur relatif aux outils de déploiement en entreprise de Microsoft Windows contient une vue d'ensemble du processus de préinstallation et des instructions pour utiliser les outils de déploiement en entreprise.
  • Le Guide de référence de préinstallation contient la syntaxe des divers fichiers de réponses qui automatisent le processus de préinstallation de Windows.

Pour obtenir des instructions sur l'impression d'une partie ou de la totalité de la documentation sur les outils de déploiement en entreprise, consultez la rubrique Impression de la documentation.


Types d'installation

L'Assistant Gestion d'installation aide les administrateurs à créer les fichiers de réponses, qui sont utilisés par le programme d'installation de Windows pour effectuer des installations ou des mises à niveau de Windows sans assistance. Les fichiers de réponses répondent aux questions que le programme d'installation pose à l'utilisateur. Par exemple, le programme d'installation demande généralement à l'utilisateur d'indiquer le nom de l'ordinateur. Mais si vous indiquez le nom de l'ordinateur dans le fichier de réponses, le programme d'installation ne posera pas la question à l'utilisateur final.

Lorsque vous utilisez l'Assistant Gestion d'installation pour créer un fichier de réponses, il vous demande les informations requises sur les pages qui apparaissent lors de l'exécution d'une installation sans assistance. Les fichiers de réponses n'éliminent pas automatiquement toute saisie par l'utilisateur au cours de l'exécution du programme d'installation. Vous devez configurer les entrées du fichier de réponses de sorte qu'elles requièrent le minimum, voire aucune interaction de l'utilisateur.

Installation de Windows sans assistance

Le programme d'installation de Windows s'exécute dans un des cinq modes sans assistance qui régit la quantité d'interactions avec l'utilisateur. Dans une installation sans aucune assistance, le programme d'installation ne sollicite pas du tout l'utilisateur et vous devez fournir toutes les informations requises dans le fichier de réponses. Dans ce cas, l'Assistant Gestion d'installation vous demande de spécifier les données de tous les paramètres nécessaires. Lorsque vous utilisez l'un des autres modes sans assistance, vous n'êtes pas obligé de spécifier toutes les données. Si vous ne souhaitez pas spécifier un paramètre particulier dans le fichier de réponses, laissez le champ correspondant vide ou, dans certains cas, sélectionnez Non spécifié.

Remarque

  • Lorsque vous effectuez une mise à niveau d'une installation de Windows XP existante, le programme d'installation utilise les paramètres de l'installation existante et ignore ceux qui sont spécifiés dans le fichier de réponses.

Installation Sysprep

Lorsque vous créez un fichier de réponses pour une installation Sysprep, un fichier .inf est généré. Pour utiliser ce fichier de réponses, il doit être placé sur votre lecteur système, dans le dossier « Sysprep » (exemple : C:\Sysprep).

Les fichiers Sysprep.exe, Setupcl.exe et Factory.exe doivent aussi se trouver dans le dossier %SYSTEMDRIVE%\Sysprep. L'exécution de Sysprep.exe ou du fichier .bat générée par l'Assistant Gestion d'installation prépare le disque dur à la duplication. Pour simplifier, utilisez l'Assistant Gestion d'installation pour créer le dossier %SYSTEMDRIVE%\Sysprep avec tous les fichiers nécessaires. Ne le faites que si vous exécutez l'Assistant Gestion d'installation sur l'ordinateur à dupliquer.

Remarque

  • Le dossier %SYSTEMDRIVE%\Sysprep est automatiquement supprimé après le démarrage du disque dur et la fin du programme d'installation.

Pour plus d'informations sur l'utilisation de l'outil Sysprep, consultez Préparation de l'installation en vue d'un déploiement.

Services d'installation à distance

Lorsque vous créez un fichier de réponses à utiliser avec un serveur d'installation à distance, l'Assistant Gestion d'installation crée un fichier .sif à la place du fichier .txt habituel.

Dans ce cas, un script de commandes échantillon n'est pas créé. Vous devez utiliser les outils d'administration livrés avec le Serveur d'installation à distance pour activer votre nouveau fichier .sif.


Définition du mot de passe Administrateur

Dans la section [GuiUnattended] du fichier Unattend.txt, vous pouvez définir le mot de passe Administrateur en utilisant l'entrée AdminPassword :

AdminPassword
Valeur : "mot_de_passe" | *

Le mot de passe peut contenir jusqu'à 127 caractères. Les mots de passe respectent la casse et doivent être spécifiés entre guillemets. Utilisez le Gestionnaire d'installation pour crypter le mot de passe. Si la valeur est *, le programme d'installation définit le mot de passe Administrateur comme étant vide (null). Il est recommandé de laisser un mot de passe Administrateur vide pour les ordinateurs qui sont distribués aux utilisateurs finals.

Important

  • L'utilisation d'un mot de passe Administrateur courant et non vide sur tous les ordinateurs vendus aux utilisateurs finals peut constituer une violation des règles de sécurité. Avant d'exécuter Sysprep, vous pouvez appliquer une procédure d'automatisation pour laisser le mot de passe Administrateur vide. Les utilisateurs finals peuvent ensuite spécifier leurs propres mots de passe Administrateur.
  • Dans une installation en mode sans assistance, le programme d'installation de Windows rendra nulle toute chaîne de mot de passe commençant par un astérisque.

Lors de la définition du mot de passe Administrateur, vous devez prendre en compte les éléments suivants :

  • Si vous spécifiez un mot de passe à l'aide de AdminPassword, ce mot de passe sera utilisé à chaque fois que vous ouvrirez une session de façon automatique. Au terme de l'installation, le mot de passe est supprimé dans la copie du fichier de réponses laissée sur l'ordinateur.
  • Si AdminPassword = * (est vide) et que AutoLogon = Yes, l'ordinateur n'ouvre qu'une seule session, quelle que soit la valeur fournie par AutoLogonCount. Si, toutefois, AdminPassword = mot_de_passe, l'ordinateur ouvre plusieurs sessions et le mot de passe non vide est enregistré dans le Registre.
  • L'ordinateur ouvre automatiquement le nombre de sessions spécifié pour AutoLogonCount uniquement lorsque AdminPassword = mot_de_passe.
  • Si vous utilisez le Gestionnaire d'installation pour crypter le mot de passe, AutoLogon ne fonctionne pas.
  • Tapez tous les mots de passe entre guillemets pour que les caractères spéciaux qu'ils contiennent éventuellement ne soient pas traités. Par exemple, le caractère # est traité comme un jeton de commentaire durant l'installation en mode texte.


Utilisation d'images pour la préinstallation

La manière la plus rapide de préinstaller Windows XP sur de nombreux ordinateurs consiste à utiliser la reproduction d'image de disque, méthode également connue sous le nom de clonage de disque. Pour ce faire, vous pouvez choisir d'utiliser un logiciel ou un matériel tiers de duplication de disque. Le logiciel de reproduction d'image effectue une duplication basée sur le secteur, qui est plus rapide que la copie de fichiers selon les méthodes standard. Aucun logiciel de reproduction d'image n'est inclus dans les outils de déploiement de Windows XP.

Les préinstallations à partir d'images conviennent parfaitement à la fabrication d'ordinateurs dont le matériel est semblable. En particulier, la couche d'abstraction matérielle (HAL, Hardware Abstraction Layer) de l'installation principale doit être identique à celle de l'ordinateur de destination.

Pour utiliser des images dans la préinstallation

  1. Utilisez les outils de déploiement pour créer une installation principale de Windows.
  2. Démarrez l'installation et exécutez Sysprep avec les options de ligne de commande appropriées.
  3. Utilisez le logiciel de reproduction d'image pour créer une image de l'installation principale.
  4. Transférez l'image aux ordinateurs de destination, soit manuellement à travers votre réseau, soit à l'aide d'un CD Windows PE (Windows Preinstallation Environment) personnalisé, soit en copiant l'image sur un disque dur qui est ensuite installé dans l'ordinateur de destination.


Optimisation de vos images

Les suggestions suivantes peuvent vous aider à réduire la taille de l'image de votre installation principale et le temps requis pour la reproduire sur les ordinateurs de destination.

  • Utilisez autant que possible des pilotes disponibles dans le système d'exploitation, afin de réduire le nombre de fichiers de pilote copiés vers chaque ordinateur de destination.
  • Si vous incluez des pilotes supplémentaires, employez un ensemble de pilotes communs que vous réutilisez à travers plusieurs lignes de produits. Avant de livrer l'ordinateur de destination au client, installez cet ensemble commun sur tous les ordinateurs lors de l'installation principale, ce qui réduit le temps requis pour rechercher et installer un pilote personnalisé spécifique.
  • Limitez le nombre de périphériques répertoriés dans la section [SysprepMassStorage] de Sysprep.inf.

    Si vous incluez une section [SysprepMassStorage] vide dans le fichier Sysprep.inf et définissez BuildMassStorageSection = Yes dans la section [Sysprep], Sysprep génère automatiquement les entrées de [SysprepMassStorage] à partir des ID matériels Plug-and-Play spécifiés dans les fichiers Machine.inf, Scsi.inf, Pnpscsi.inf et Mshdc.inf.

  • Réduisez le nombre d'applications supplémentaires que vous installez.
  • Si une application particulière est incluse sur la plupart de vos ordinateurs, pensez à incorporer une version temporisée de l'application dans l'installation principale. Temporiser une application signifie faire en sorte que tous les fichiers de cette application soient disponibles localement. Dans ce cas, l'installation de l'application se limite à effectuer les modifications nécessaires dans le Registre, ce qui évite la perte de temps occasionnée par la copie des fichiers. Si vous ne voulez pas installer cette application sur l'ordinateur de destination, il suffit d'en détacher (c.-à-d. supprimer) les fichiers.

    La méthode d'amorçage à partir du lecteur de CD-ROM ne prend pas en charge les applications temporisées.

    Pour plus d'informations, consultez Préinstallation d'applications.

  • Utilisez les outils de ligne de commande Diskpart et Format pour créer une partition NTFS unique au début du processus de préinstallation. L'utilisation de Diskpart permet d'éviter un redémarrage entre fdisk et format, qui est obligatoire sous MS-DOS.
  • Utilisez une petite image pour installer Windows sur une petite partition, puis utilisez ExtendOemPartition si vous effectuez une installation sur une partition du système de fichiers NTFS.
  • Supprimez Hiberfil.sys et Pagefile.sys de l'installation principale avant de créer l'image. Utilisez la commande del /a:sh hiberfil.sys pour supprimer Hiberfil.sys. Windows recrée automatiquement ces fichiers si nécessaire.

    Remarque

    • Le fichier Pagefile.sys a la même taille que la mémoire vive (RAM) disponible sur l'ordinateur. Vérifiez qu'il existe un espace disponible au moins égal à la taille de ce fichier sur la partition %SYSTEMDRIVE% de l'ordinateur de destination, afin que la mini-installation puisse correctement recréer le fichier.
  • Supprimez le contenu du dossier %WINDIR%\System32\Dllcache avant de créer une image de l'installation principale. Vous devez laisser le dossier vide Dllcache sur le système pour que la protection de fichiers Windows (WFP, Windows File Protection) fonctionne convenablement.

    Si vous supprimez le contenu du dossier %WINDIR%\System32\Dllcache, affectez à l'entrée SourcePath de la section [ComputerSettings] du fichier Winbom.ini une valeur correspondant à l'emplacement du dossier i386 sur l'ordinateur de destination. Le dossier i386 doit se trouver dans %WINDIR%.

  • Pour supprimer des fichiers d'une image, vous devez avoir des outils capables de modifier cette image ou d'accéder au disque. Vous ne pouvez pas supprimer des fichiers d'une installation Windows pendant son exécution.


Ajout de fichiers supplémentaires dans le partage de distribution

Le partage de distribution (également appelé dossier de distribution) vous permet de fournir vos propres fichiers que le programme d'installation de Windows copie automatiquement sur les ordinateurs de destination. L'Assistant Gestion d'installation vous guide à travers les étapes du processus de création d'un partage de distribution.

Les fichiers peuvent inclure des fichiers d'aide que vous voulez installer sur chaque ordinateur de votre organisation ou des pilotes de périphérique qui n'ont pas été livrés avec Windows XP. Il peut également s'agir de vos propres applications que vous voulez déployer sur les ordinateurs de destination.

Lorsque vous créez un partage de distribution en utilisant l'Assistant Gestion d'installation, vous avez besoin de suffisamment d'espace disque pour contenir le CD de produit Windows plus l'espace requis par les fichiers que vous déployez.


Configuration du disque dur

Vous pouvez automatiser la configuration des disques durs pendant la préinstallation.

Le système de fichiers NTFS est le format de disque recommandé pour les éditions 32 bits de Windows XP et de la famille Windows Server 2003. Le format NTFS contient toutes les fonctionnalités de base du système FAT et il offre des avantages essentiels par rapport aux systèmes de fichiers FAT et FAT32.

Extension des partitions NTFS

Vous pouvez utiliser l'un des fichiers de réponses suivants pour étendre automatiquement les partitions NTFS sur l'ordinateur de destination pendant le processus de préinstallation :

Fichier de réponses | Section | Entrée | Moment où la partition est étendue
Unattend.txt | [Unattended] | ExtendOEMPartition | Installation en mode silencieux
Winbom.ini | [ComputerSettings] | ExtendPartition | Démarrage suivant de l'ordinateur, après le mode Usine de Sysprep
Sysprep.inf | [Unattended] | ExtendOEMPartition | Mini-installation

Les partitions peuvent être étendues jusqu'à une taille spécifiée ou pour remplir l'espace disponible.

Conversion de partitions FAT/FAT32 en partitions NTFS

Si votre processus de déploiement requiert le système FAT32, utilisez l'outil de ligne de commande Oformat pour formater le disque dur afin d'optimiser sa configuration pour NTFS. Utilisez l'outil de ligne de commande Convert pour convertir le système de fichiers au format NTFS. Après cette conversion, vous ne pouvez plus revenir au système de fichiers FAT32. Pour plus d'informations, consultez la rubrique Conversion de partitions FAT32/FAT en partitions NTFS.

Lorsque le disque dur est formaté, utilisez l'outil DiskPart pour créer d'autres scripts de configuration du disque dur, par exemple pour le partitionnement et l'affectation de lettres de lecteur.

Scénarios de conversion FAT32

Si vous ne configurez pas le disque dur pour utiliser le système NTFS dans le cadre de l'installation en mode silencieux, la méthode privilégiée consiste à exécuter l'outil Convert avant la procédure Sysprep finale. Ajoutez la commande Convert /fs:ntfs à la section [OEMRunOnce] du fichier Winbom.ini, comme dans l'exemple suivant :

[OEMRunOnce]
Command0 = "Convert /fs:ntfs"

Cette commande permet de s'assurer que la conversion est effectuée en mode Usine et non au cours du premier démarrage par l'utilisateur final.

Une autre méthode de conversion du système FAT32 consiste à ajouter la commande Convert /fs:ntfs à la section [GUIRunOnce] du fichier Sysprep.inf, comme dans l'exemple suivant :

[GuiRunOnce]
Command0 = "Convert /fs:ntfs"

Après l'exécution de Sysprep -reseal, la conversion a lieu dès que l'utilisateur final met l'ordinateur sous tension, lors du premier démarrage.


Comparaison des systèmes de fichiers NTFS et FAT32/FAT

bannière

Comparaison des systèmes de fichiers NTFS et FAT/FAT32

Le système de fichiers NTFS est le format de disque recommandé pour les éditions 32 bits de Windows XP et de la famille Windows Server 2003. NTFS possède toutes les fonctionnalités de base de FAT et fournit les avantages suivants par rapport aux systèmes de fichiers FAT et FAT32 :

  • une récupération plus aisée lors des réinitialisations ou pannes de système ;
  • une prise en charge des disques durs de taille importante ;
  • un contrôle de l'accès aux fichiers privés plus strict ;
  • des utilitaires de disque améliorés, notamment pour le cryptage, la défragmentation et la compression de niveau fichiers et dossiers

Important

  • Sur les ordinateurs d'utilisateurs finaux, Microsoft ne teste ni ne prend en charge FAT32 sur les volumes supérieurs à 32 Go. Microsoft prend en charge les volumes FAT32 supérieurs à 32 Go utilisés par les OEM dans leur processus de fabrication, à condition que ces volumes soient convertis au format NTFS avant le départ de l'ordinateur de l'usine. Pour plus d'informations, consultez Conversion de partitions FAT32/FAT en NTFS.

Performances

Les performances du sous-système de disque constituent un facteur important dans les performances globales du système. Dans Windows XP et la famille Windows Server 2003, les systèmes de fichiers NTFS et FAT possèdent des caractéristiques système similaires ; toutefois, les performances de NTFS sont meilleures sur les volumes de grande taille.

De nombreuses personnes pensent que le système NTFS est plus lent que le FAT. Cependant, cela est généralement dû à une configuration du système de fichiers NTFS peu performante lors des tests. Un système NTFS correctement configuré fonctionne de manière similaire à un système de fichiers FAT. Les indices de performances du système de fichiers NTFS sont plus élevés pour Windows XP et la famille Windows Server 2003 que pour les précédentes versions de Windows.

Spécifications du système de fichiers

Description | NTFS | FAT32 | FAT
Taille de fichier maximale | 244 - 64 K octets | 232 - 1 octets | 232 - 1 octets
Taille de partition minimale | 10 Mo (le minimum recommandé est de 500 Mo) ; impossible d'utiliser sur des disquettes | 512 Mo | Taille d'une disquette
Taille de partition maximale | 2 To (téraoctets) | 2 To (téraoctets) Dans Windows XP, vous pouvez formater une partition FAT32 uniquement jusqu'à 32 Go Windows XP peut lire les partitions FAT32 de toutes tailles | 4 Go
Taille de volume minimale | 1 Mo | 65 535 clusters | 4 085 clusters
Taille de volume maximale | 232 clusters | Windows 2000 : possibilité de formater jusqu'à 32 Go au maximum, de monter et de convertir des volumes plus importants Windows Millenium Edition : 228 - 12 clusters au maximum Windows 98 et Windows 95 : 4.177.918 clusters | 2 Go Si durant l'installation de Windows XP, vous choisissez de formater le disque pour utiliser un système FAT et que votre partition est supérieure à 2 Go, le programme d'installation formate automatiquement le disque en FAT32.
Fichiers par volume | 232 - 1 | 228 | 2316
Taille de répertoire | Illimité | 216 - 2 entrées de répertoire physique | 216 - 2 entrées de répertoire physique ; limites spéciales sur le répertoire racine
Sécurité | Sécurité de niveau utilisateur Sécurité de niveau fichier Sécurité de niveau dossier Sécurité de niveau partage | Sécurité de niveau partage | Sécurité de niveau partage

Taille de cluster

La taille de cluster dépend du système d'exploitation, pas du système de fichiers.

Système(s) d'exploitation | Taille de cluster
Windows XP, famille Windows Server 2003, Windows 2000 et Windows NT | Une puissance de 2 entre 512 octets et 65 536 octets inclus
Windows Millenium Edition, Windows 98 et Windows 95 | Une puissance de 2 entre 512 octets et 32.768 octets inclus

Compatibilité du système de fichiers avec différents systèmes d'exploitation Microsoft

Windows XP, Windows 2000 et Windows NT 4.0 sont les seuls systèmes d'exploitation qui peuvent lire les données et y accéder à partir de volumes locaux formatés avec le système de fichiers NTFS. Si vous configurez un ordinateur pour un double démarrage avec Windows XP et un autre système d'exploitation, vérifiez que le système de fichiers que vous choisissez est utilisable par les deux systèmes d'exploitation.

Système d'exploitation | NTFS | FAT32 | FAT
Windows XP | X | X | X
Famille Windows Server 2003 | X | X | X
Windows 2000 | X | X | X
Windows Millenium Edition |  | X | X
Windows NT 4.0 avec Service Pack 4 (ou ultérieur) | X |  | X
Windows NT 3.5 Windows NT 4.0 avec Service Pack 1, Service Pack 2, ou Service Pack 3 |  |  | X
Windows 98 Windows 98 SE |  | X | X
OS/2 |  | X | X
Windows 95 |  | X | X
Windows 3.1 |  |  | X
MS-DOS |  |  | X


Conversion de partitions FAT/FAT32 en partitions NTFS

Le système de fichiers NTFS est recommandé pour Windows XP et la famille Windows Server 2003. Toutefois, il est possible que vos processus de fabrication reposent sur Windows 9.x ou MS-DOS, ce qui vous oblige à formater les disques durs en utilisant le système de fichiers FAT32 ou FAT.

Pour conserver ce processus tout en permettant à vos clients de bénéficier du système de fichiers NTFS, convertissez les volumes FAT32 ou FAT au format NTFS. Pour Windows XP et la famille Windows Server 2003, les performances du volume NTFS converti sont identiques à celles d'un volume ayant le format NTFS de manière native.

Remarque

  • Au cours d'une installation sur une partition NTFS, une liste de contrôle d'accès (ACL) est créée pour le système de fichiers à l'aide d'un jeu prédéfini de modèles de sécurité par défaut. Vous pouvez par ailleurs utiliser la section [.security] des fichiers d'installation (.inf) des composants qui utilisent l'API d'installation pour spécifier leur sécurité de fichier unique. Les autorisations des modèles de sécurité par défaut et celles définies par les fichiers .inf sont capturées dans un modèle setup security.inf.

    Si vous installez initialement Windows sur une partition FAT ou FAT32, puis que vous utilisez par la suite l'utilitaire Convert.exe pour convertir la partition au format NTFS, ces paramètres de sécurité par défaut ne sont pas appliqués. Windows ne prend pas en charge la définition de la sécurité sur des fichiers déjà installés pour qu'elle corresponde à la sécurité NTFS après une conversion à partir de FAT(32). Pour vous assurer que vous générez la liste de contrôle d'accès correcte, exécutez le programme d'installation directement à partir du CD-ROM ou effectuez une installation en mode silencieux avec le commutateur NTFS correspondant. Pour plus d'informations, consultez l'article (en anglais) suivant de la Base de connaissances : 237399 The Default NTFS Permissions Are Not Applied to a Converted Boot (http://kb/article.asp?id=Q237399).

Pour plus d'informations sur les différences entre les systèmes de fichiers NTFS, FAT32 et FAT, consultez la rubrique Comparaison des systèmes de fichiers NTFS et FAT/FAT32.

Méthode 1 : Conversion au format NTFS au cours d'une installation en mode silencieux

Dans la section [Unattended] du fichier Unattend.txt, affectez à l'entrée FileSystem la valeur ConvertNTFS. Cette valeur entraîne la conversion automatique du disque dur par le programme d'installation, juste avant le démarrage de l'installation en mode graphique.

[Unattended]
FileSystem = ConvertNTFS

Remarque

  • FileSystem n'est pas une entrée valide dans Sysprep.inf.

Méthode 2 : Conversion au format NTFS après l'installation

Une fois que vous avez installé Windows, démarrez l'ordinateur. À l'invite de commandes, tapez :

Convert Lecteur /FS:NTFS

Redémarrez l'ordinateur pour terminer la conversion au format NTFS. Pour plus d'informations, consultez :

  • Préinstallation de NTFS et Windows XP (http://www.microsoft.com/whdc/)
  • « Converting Volumes to NTFS » sur le site Microsoft TechNet


Extension d'une partition NTFS

Lors de l'installation de Windows, vous serez peut-être amené à augmenter la taille de la partition sur l'ordinateur de destination. Lorsqu'elle est utilisée dans un fichier de réponses, l'entrée ExtendOemPartition de la section [Unattended] du fichier Unattend.txt oblige le programme d'installation à étendre la partition de destination sur l'espace adjacent et non partitionné du disque.

Définissez ExtendOemPartition avec une valeur autre que 1 afin d'indiquer une taille de disque spécifique pour l'extension du disque dur en plus de l'espace occupé. Cela s'avère utile si vous voulez configurer plus d'une partition sur le disque dur.

Important

  • Vous pouvez utiliser ExtendOemPartition dans les deux fichiers de réponses Unattend.txt et Sysprep.inf. Lorsqu'elle est utilisée dans Sysprep.inf pour les ordinateurs mis en image, la taille du disque dur de l'ordinateur de destination doit être supérieure ou égale à celle du disque dur de l'ordinateur principal.
  • Vous ne pouvez étendre que les partitions de systèmes de fichiers NTFS. Si la partition de destination que vous pensez étendre est de type FAT ou FAT32, affectez la valeur ConvertNTFS à l'entrée FileSystem de la section [Unattended] du fichier Unattend.txt, afin de convertir la partition lors de la partie « texte » de l'installation.
  • Le programme d'installation ne développe pas les partitions FAT32 et FAT, et Sysprep ne peut convertir un volume FAT32 ou FAT en NTFS.

Développement d'une partition NTFS dans la fabrication planifiée

Par exemple, si vous souhaitez étendre la partition d'un ordinateur sur lequel l'outil Sysprep s'exécute automatiquement, plusieurs actions sont possibles :

  1. Conservez une taille d'image principale aussi petite que possible en créant une partition sur l'ordinateur principal qui soit suffisamment grande pour permettre l'installation de Windows et des autres outils principaux dans l'image principale.
  2. Ajoutez l'entrée suivante dans la section [Unattended] de votre fichier Sysprep.inf :
    ExtendOemPartition = 1
  3. Dans le fichier Unattend.txt utilisé pour générer l'image principale, ajoutez l'entrée suivante :
    [GuiRunOnce]
...<commandes utilisées pour la configuration ou l'installation des applications>
Commandn-1 = "Convert c:\ /fs:ntfs"
Commandn = "%SYSTEMDRIVE%\sysprep\sysprep -quiet"

    Une fois l'installation sans assistance terminée sur l'ordinateur principal, Sysprep exécute les commandes spécifiées dans [GuiRunOnce] pour installer des applications ou configurer le système. Lorsque la commande Convert est exécutée, une entrée est définie dans le Registre pour demander au système d'exploitation de convertir le lecteur C lors du réamorçage. Lorsque le programme d'installation convertit le lecteur, Sysprep s'exécute et éteint l'ordinateur.

  4. Générez l'image.

Lorsque vous placez l'image principale sur un ordinateur de destination, le lecteur C est converti lors du démarrage de l'ordinateur. L'ordinateur redémarre puis exécute l'accueil Windows ou la mini-installation. Pendant la première mise en route, Windows étend le lecteur C au reste de l'espace non partitionné sur le disque dur selon un processus presque instantané. L'ordinateur redémarre alors une dernière fois ; dès lors, l'utilisateur peut ouvrir une session et utiliser Windows.


Configuration de la famille Windows Server 2003

L'interface utilisateur de la famille Windows Server 2003 diffère de celle de Windows XP à plusieurs égards :

  • Différences du menu Démarrer sur les serveurs exécutant Windows Server 2003
  • Le programme d'installation définit la résolution de l'écran à 1024 x 768 pixels si la carte graphique et l'écran autorisent ce mode d'affichage. Sinon, le programme d'installation sélectionne une résolution en 800 x 600. Beaucoup plus rarement, le programme d'installation est contraint d'utiliser une résolution en 640 x 480.
  • L'arrière-plan de l'écran d'ouverture de session emploie un code de couleur pour représenter la version de Windows. La même couleur est utilisée pour toutes les versions de Windows Server 2003.
  • Le Nettoyage du bureau est désactivé par défaut.

La mini-installation constitue le premier démarrage de la famille Windows Server 2003. Pour plus d'informations, consultez Premier démarrage de l'utilisateur final et Préconfiguration et automatisation de la mini-installation.

Vous n'êtes pas obligé d'installer l'Autoformation interactive pour la famille Windows Server 2003.

Pour plus d'informations sur la configuration d'un serveur, consultez les rubriques suivantes :

  • Installation des services Internet (IIS) de Microsoft
  • Installation d'outils d'administration distante
  • Installation du service de cluster
  • Installation d'un contrôleur de domaine

Vous pouvez ajouter des composants de serveur additionnels et les personnaliser dans le fichier Unattend.txt. Pour plus d'informations, consultez :

  • [Components]
  • [InternetServer]
  • [NetOptionalComponents]
  • [NetServices]
  • [SNMP]
  • [TerminalServices]


Différences du menu Démarrer sur les serveurs exécutant Windows Server 2003

L'interface utilisateur des membres de la famille Windows Server 2003 diffère de celle de Windows XP Édition familiale et de Windows XP Professionnel à plusieurs égards :

  • Le menu Démarrer est plus large.
  • Si l'utilisateur actuel fait partie du groupe Administrateurs de serveur, un lien Outils d'administration apparaît dans le menu Démarrer. Ce lien n'apparaît pas si l'utilisateur n'a pas les prérogatives des administrateurs.
  • Le lien Catalogue Windows, qui apparaît lorsque vous cliquez sur Tous les programmes, pointe vers une page du catalogue qui est mieux adaptée aux besoins des utilisateurs d'un serveur.
  • Des liens à la Console de gestion Microsoft (MMC, Microsoft Management Console) et au Gestionnaire des tâches sont inclus dans le menu Outils d'administration initial.
  • La zone de sélection rapide du menu Démarrer contient des liens pour la Gestion de l'ordinateur (Compmgmt.msc), l'Invite de commandes (Cmd.exe) et l'Explorateur Windows (Explorer.exe).
  • La liste des programmes les plus fréquemment utilisés contient deux liens prédéfinis : Bloc-notes et Configurer votre serveur.
  • Le Panneau de configuration et les Outils d'administration sont situés dans le menu Démarrer, sous forme de « menus volants » ou d'extension.
  • Le Poste de travail apparaît sous forme de lien sur le menu Démarrer.
  • Les Connexions réseau se trouvent sur le menu Démarrer si une connexion existante est détectée.
  • Aide et support, Rechercher et Exécuter se trouvent sur le menu Démarrer.
  • Mes documents et Mes documents récents sont désactivés.
  • Les Favoris réseau sont désactivés.

Pour approfondir la liste des différences entre l'interface utilisateur de Windows XP et celle de Windows Server 2003, consultez Configuration de la famille Windows Server 2003.


Installation des services Internet (IIS) de Microsoft

Windows XP Professionnel contient les Services Internet (IIS) Microsoft 5.1. Windows XP Professionnel Édition 64 bits 2003 et tous les membres de la famille Windows Server 2003 contiennent IIS 6.0.

Windows XP Édition familiale ne contient pas de composants logiciels du serveur Web.

Pour préinstaller les services Internet (IIS), vous devez spécifier les :

  • valeurs des différents composants IIS de la section [Components] du fichier Unattend.txt, et vous devez définir l'entrée iis_www avec la valeur On.
  • entrées permettant de configurer les emplacements d'installation de la section [InternetServer] du fichier Unattend.txt.

Si la section [InternetServer] est vide, les services Internet (IIS) sont installés dans l'emplacement par défaut.

Remarque

  • Certains composants facultatifs de la famille Windows Server 2003 exigent l'installation de composants IIS supplémentaires. Si vous configurez ces composants facultatifs dans le cadre d'une unattended Setup de Windows Server 2003, Standard Edition, Windows Server 2003, Enterprise Edition, ou Windows 2000 Datacenter Server, vous pouvez définir des préférences pour les composants IIS associés. Pour obtenir une liste des interdépendances des services IIS ainsi qu'une liste des composants à installer, consultez [Components], [InternetServer] et [NetOptionalComponents].


Installation d'outils d'administration distante

L'installation contrôlée par défaut des composants relatifs aux outils d'administration distante (anciennement appelés Kit d'administration de serveur (SAK, Server Administration Kit)) a lieu lors de la première ouverture de session après l'installation. Cette opération peut être effectuée automatiquement via Unattend.txt en utilisant l'une des méthodes suivantes :

  • création d'une entrée dans la section [GuiUnattended], pour Windows Server 2003, Web Edition, uniquement ;
  • exécution du Gestionnaire de composants facultatifs ;
  • insertion d'une ligne de commande dans la section [GUIRunOnce].

Pour plus d'informations, consultez le manuel Internet Information Services 6.0 Administrator's Guide sur le CD de Windows.

Installation sans assistance en mode graphique pour Windows Server 2003, Web Edition

Le comportement contrôlé par défaut lors de la première ouverture de session sur Windows Server 2003, Web Edition, consiste à exécuter Sasetup.exe et à installer l'interface utilisateur Web d'administration distante. Pour contrôler ce comportement lié à la première ouverture de session, le programme d'installation traite l'entrée ServerWelcome dans la section [GuiUnattended] du fichier Unattend.txt. Par exemple :

[GuiUnattended]
ServerWelcome = Yes

La valeur affectée au comportement par défaut est Yes.

Important

  • L'entrée ServerWelcome n'est pas traité durant l'exécution de Sysprep.

Dans Windows Server 2003, Web Edition, si ce paramètre est défini en Yes, Sasetup.msi est exécuté depuis le lecteur de disque dur lors de la première ouverture de session utilisateur. L'interface utilisateur Web d'administration de serveur Web sera ajoutée au groupe de programmes de démarrage du compte Administrateur, et démarrée.

Installation sans assistance à l'aide du Gestionnaire de composants facultatifs

Le comportement contrôlé par défaut lors de la première ouverture de session sur Windows Server 2003, Standard Edition, Windows Server 2003, Enterprise Edition, Microsoft Small Business Server et Windows Server 2003, Datacenter Edition, consiste à ne pas installer les outils.

Il est possible d'exécuter le Gestionnaire de composants facultatifs pour effectuer une installation sans assistance de l'interface utilisateur Web des composants d'administration de serveur Web après l'installation et la première ouverture de session. Si le Gestionnaire de composants facultatifs est appelé avec Unattend.txt comme argument, il fera appel au fichier iisoc.dll qui analysera le fichier Unattend.txt à la recherche des paramètres qui définissent le chemin vers Sasetup.msi, et vérifiera si l'interface utilisateur Web est installée.

Voici un exemple de ligne de commande pour l'installation :

sysocmgr /i:sysoc.inf /u:unattend.txt

Si aucun support n'est spécifié, le fichier iisoc.dll utilise le lecteur de CD-ROM. Si SaInstall.dll ne peut pas trouver Sasetup.msi à l'emplacement indiqué, il renvoie une erreur au fichier iisoc.dll, qui consigne l'erreur dans un journal.

Paramètres d'exécution sans assistance pour le contrôle du Gestionnaire de composants facultatifs d'IIS

Ces paramètres d'exécution sans assistance fournissent les fonctionnalités nécessaires aux outils d'administration distante sur les produits de la famille Windows Server 2003 :

[Components]
Sakit_web = On | Off

La valeur affectée au comportement par défaut est Off. Définir ce paramètre sur On permet d'installer les outils d'administration distante, ainsi que les composants suivants : iis_common, iis_inetmgr, iis_www.

Remarque

  • Ce paramètre a remplacé le précédent paramètre iis_htmla pour le composant HTMLA d'IIS de Windows 2000. Le paramètre iis_htmla n'est plus valide pour la famille Windows Server 2003.

Si la valeur (par défaut) Off est affectée à ce paramètre et que l'interface utilisateur Web d'administration de serveur Web est déjà installée, le composant est désinstallé.

Installation par script des composants relatifs aux outils d'administration distante via Sasetup.msi

Une fois l'installation terminée, vous pouvez effectuer une installation sans assistance de l'interface utilisateur Web d'administration distante en exécutant Sasetup.msi avec les options de ligne de commande appropriées. Pour plus d'informations, consultez la documentation relative à Sasetup.

Il est possible d'exécuter Sasetup automatiquement après l'installation en plaçant Sasetup.msi dans la section [GUIRunOnce] du fichier Unattend.txt. Ceci peut être effectué conjointement avec la définition du paramètre AutoLogon = Yes, afin de permettre la connexion et l'installation sans assistance des composants relatifs aux outils d'administration distante une fois l'installation terminée.


Installation du service de cluster

Pour vous assurer que le service de cluster est installé, créez une entrée [GuiRunOnce] pour ce dernier.

Pour créer un cluster

  1. Dans la section [GuiRunOnce] du fichier Unattend.txt, ajoutez :
    Command0 = "%WINDIR%\cluster /cluster:SV-CLUSTER /CREATE /NODE:SV-NODE1 /USER:your_domain\user /PASS:****** /IPADDR:157.5.5.50"

Pour ajouter des noeuds à un cluster existant

  1. Dans la section [GuiRunOnce] du fichier Unattend.txt, ajoutez :
    Command0 = "%WINDIR%\ cluster /cluster:SV-CLUSTER /ADDNODES:SV-NODE2 /PASSWORD:*********"

Les entrées de la section [GuiRunOnce] sont exécutées une fois l'installation terminée, lors de la première ouverture de session de l'utilisateur. Toutes les entrées spécifiées dans la section [GuiRunOnce] sont enregistrées sur l'ordinateur et ne sont traitées qu'après le redémarrage et non au cours de l'installation en mode silencieux.

Important

  • Pour plus d'informations sur la configuration du service de cluster et les sections de son fichier de réponses associé, consultez le document (en anglais) Windows Cluster Technologies: Server Clusters: Remote Setup, Unattended Installations and Image-based Installations.


Installation d'un contrôleur de domaine

Dcpromo.exe est le composant de l'Assistant Installation de Active Directory qui permet de créer ou de rétrograder des contrôleurs de domaine sur des ordinateurs exécutant Windows Server 2003, Standard Edition, Windows Server 2003, Enterprise Edition, ou Windows 2000 Datacenter Server.

Remarque

  • Dcpromo.exe ne peut être exécuté qu'une fois que le mode graphique du programme d'installation est terminé et qu'un utilisateur a ouvert une session.

Pour exécuter Dcpromo.exe

  • Ouvrez une fenêtre de commande et tapez :

    dcpromo /answer:fichier_réponses

    — ou —

  • Créez un fichier Sysprep.inf comprenant :
    [GuiRunOnce]
"dcpromo /answer:fichier_réponses"

    Dans les deux cas, fichier_réponses indique le nom du fichier de réponses qui comporte les valeurs du contrôleur de domaine.

Spécifiez les valeurs utilisées par Dcpromo.exe dans la section [DCInstall] du fichier de réponses Unattend.txt lors de l'installation sans assistance ou dans un fichier de réponses séparé qui contient uniquement la section [DCInstall].

Remarques

  • Si vous ne fournissez pas de fichier de réponses, l'Assistant Installation de Active Directory vous réclame les informations nécessaires pour promouvoir l'ordinateur au rang de contrôleur de domaine.
  • Si vous ne spécifiez pas de valeur pour une option du fichier de réponses créé, la valeur par défaut est appliquée.

Personnalisation de [DCInstall]

[DCInstall] est une section facultative d'un fichier de réponses qui contient les paramètres d'installation d'un contrôleur de domaine à l'issue de l'installation de Windows Server 2003, Standard Edition, Windows Server 2003, Enterprise Edition, ou Windows 2000 Datacenter Server. Vous pouvez créer un fichier de réponses contenant seulement cette section qui s'exécute au terme de l'installation et une fois que l'utilisateur a ouvert une session sur l'ordinateur.

Les entrées utilisées avec [DCInstall] ne sont prises en charge que sur Windows Server 2003, Standard Edition, Windows Server 2003, Enterprise Edition, ou Windows 2000 Datacenter Server. Le tableau suivant répertorie les diverses entrées utilisées.

Entrée | S'applique aux opérations suivantes :
RebootOnSuccess | Toutes les opérations (installation et suppression)
DatabasePath LogPath SYSVOLPath NomUtilisateur Mot_de_passe UserDomain | Toutes les installations
ReplicaOrNewDomain = Replica ReplicaDomainDNSName | Mise à niveau du contrôleur secondaire de domaine et nouvelle installation de réplica
ReplicaOrNewDomain = Domain TreeOrChild = Child ParentDomainDNSName ChildName DomainNetbiosName AutoConfigDNS | Installation de domaines enfants
ReplicaOrNewDomain = Domain TreeOrChild = Tree CreateOrJoin = Join NewDomainDNSName DomainNetbiosName AutoConfigDNS | Installation d'une nouvelle arborescence dans une forêt existante
AdministratorPassword IsLastDCInDomain | Rétrogradation d'un contrôleur de domaine
ReplicaOrNewDomain = Domain TreeOrChild = Tree CreateOrJoin = Create NewDomainDNSName DNSOnNetwork DomainNetbiosName AutoInstallAndConfigDNS SiteName | Installation d'une nouvelle arborescence dans une nouvelle forêt

Remarques

  • Les mots de passe peuvent contenir jusqu'à 127 caractères.
  • Vous pouvez ajouter des composants de serveur additionnels et les personnaliser dans le fichier de réponses. Pour obtenir une liste de ces composants, consultez Unattend.txt.


Utilisation de l'Assistant Gestion d'installation

L'Assistant Gestion d'installation permet de créer ou modifier les fichiers qui contrôlent une installation sans assistance.

L'Assistant Gestion d'installation peut :

  • créer des fichiers de réponses permettant d'automatiser l'installation de Windows XP sur plusieurs ordinateurs ;
  • créer un point de partage de distribution pour les installations réseau ; outre les fichiers d'installation de Windows XP, ce partage d'installation réseau peut contenir des applications et pilotes supplémentaires, des commandes supplémentaires à exécuter à la fin de l'installation et d'autres composants personnalisés, spécifiés par l'administrateur du système.

L'Assistant Gestion d'installation n'affecte pas les fichiers système de l'ordinateur du technicien sur lequel l'outil s'exécute et qui n'exécute pas réellement le programme d'installation Windows.

Vous n'avez pas besoin de spécifier toutes les personnalisations que vous avez apportées à l'aide de l'Assistant Gestion d'installation. En revanche, vous pouvez créer un fichier Unattend.txt dans l'Assistant Gestion d'installation, puis le modifier manuellement. Lorsque vous ouvrirez ce fichier Unattend.txt ultérieurement dans l'Assistant Gestion d'installation, l'outil affichera les paramètres que vous avez modifiés.

Démarrage de l'Assistant Gestion d'installation

Pour exécuter l'Assistant Gestion d'installation, vous devez utiliser Windows 2000 ou Windows XP (la version 32 bits).

Pour installer et exécuter l'Assistant Gestion d'installation

  1. À partir du fichier Deploy.cab situé dans le dossier \Support\Tools sur le CD du produit Windows, copiez le fichier Setupmgr.exe sur votre disque dur.
  2. À l'invite de commandes, passez du répertoire actuel à celui dans lequel vous avez copié les fichiers. Tapez la commande :

    setupmgr

    puis appuyez sur ENTRÉE.

Important

  • Comme le nom d'utilisateur et le mot de passe que vous choisissez pour vous connecter au partage de distribution ne sont pas cryptés, il est recommandé de n'octroyer à ce compte que le minimum de droits indispensable pour établir la connexion.

Informations complémentaires

Pour plus d'informations sur les tâches spécifiques que vous pouvez accomplir à l'aide de l'Assistant Gestion d'installation, consultez :

  • Types d'installations
  • Ajout de fichiers supplémentaires dans le partage de distribution
  • Utilisation de scripts de commandes

Pour obtenir une liste détaillée des paramètres écrits par l'Assistant Gestion d'installation, consultez Paramètres de l'Assistant Gestion d'installation. Pour des informations détaillées sur le déploiement de Windows, consultez les pages Déploiement sur le site Web Microsoft Windows Server (http://www.microsoft.com/windows2000/techinfo/planning/).


Personnalisation du pare-feu Windows

Vous pouvez configurer le pare-feu Windows à l'aide des fichiers de réponses Unattend.txt et Winbom.ini.

Personnalisation du pare-feu Windows à l'aide des fichiers de réponses

Le pare-feu Windows est activé (On) par défaut. Utilisez les fichiers de réponses Unattend.txt ou Winbom.ini pour modifier la liste des exceptions du pare-feu Windows.

Pour configurer le pare-feu Windows à l'aide du fichier de réponses Unattend.txt

  1. Utilisez l'Assistant Gestion d'installation pour créer un fichier Unattend.txt ou modifiez un fichier Unattend.txt existant.
  2. Ajoutez les entrées et les sections relatives au pare-feu Windows définies par l'utilisateur pour ajouter des programmes, des services, des ports statiques et des messages ICMP à la liste des exceptions du pare-feu Windows. Pour plus de détails, consultez les rubriques [WindowsFirewall] du Guide de référence de préinstallation de Microsoft Windows. L'exemple suivant présente une façon d'ajouter des sections et des entrées au fichier Unattend.txt :
    [WindowsFirewall]
Profiles=WindowsFirewall.Standard
LogFile = %WINDIR%\pfirewall.log
LogSize = 4096
LogDroppedPackets = 1
LogConnections = 1

[WindowsFirewall.Standard]
Type = 3
Mode = 1
Exceptions = 1
Notifications = 1
MulticastBroadcastResponse = 1
AllowedPrograms = WindowsFirewall.RemoteAssistance
Services = WindowsFirewall.RemoteDesktop
PortOpenings = WindowsFirewall.WebService
IcmpSettings = WindowsFirewall.EchoRequest

[WindowsFirewall.RemoteAssistance]
Program = %WINDIR%\System32\Sessmgr.exe
Name = Remote Assistance
Mode = 1
Scope = 2
Addresses = 192.168.0.5,LocalSubnet

[WindowsFirewall.RemoteDesktop]
Type = 2
Mode = 1
Scope = 2
Addresses = 192.168.0.5,LocalSubnet

[WindowsFirewall.WebService]
Protocol= 6
Port = 80
Name = Web Server (TCP 80)
Mode = 1
Scope = 2
Addresses = 192.168.0.5,LocalSubnet

[WindowsFirewall.EchoRequest]
Type = 8
Mode = 1

    Remarque

    • Dans l'exemple précédent, il n'est pas nécessaire d'ajouter l'entrée Addresses aux sections. Si vous ajoutez l'entrée Addresses, assurez-vous qu'elle ne comporte pas d'espaces.
  3. Exécutez une installation sans assistance.
  4. Créez une image du système d'exploitation en utilisant les paramètres de pare-feu Windows définis par l'utilisateur.
  5. Copiez l'image sur l'ordinateur de destination.
  6. Exécutez Sysprep -reseal sur l'ordinateur de destination.

Pour désactiver le pare-feu Windows à l'aide du fichier de réponses Unattend.txt

  1. Utilisez l'Assistant Gestion d'installation pour créer un fichier Unattend.txt ou modifiez un fichier Unattend.txt existant.
  2. Ajoutez les sections et entrées suivantes dans votre fichier de réponses Unattend.txt :
    [WindowsFirewall]
Profiles = WindowsFirewall.TurnOffFirewall

[WindowsFirewall.TurnOffFirewall]
Mode = 0

    Remarque

    • Il n'est pas nécessaire d'inclure l'entrée Type dans la section [WindowsFirewall.TurnOffFirewall]. La valeur par défaut All est appliquée s'il n'existe aucune entrée Type.
  3. Exécutez une installation sans assistance.
  4. Créez une image du système d'exploitation en utilisant les paramètres de pare-feu Windows définis par l'utilisateur.
  5. Copiez l'image sur l'ordinateur de destination.
  6. Exécutez Sysprep -reseal sur l'ordinateur de destination.

Pour configurer le pare-feu Windows à l'aide du fichier de réponses Winbom.ini

  1. Créez un fichier de réponses Winbom.ini, ou modifiez un fichier de réponses Winbom.ini existant.
  2. Ajoutez les entrées et les sections relatives au pare-feu Windows définies par l'utilisateur pour ajouter des programmes, des services, des ports statiques et des messages ICMP à la liste des exceptions du pare-feu Windows. Pour plus de détails, consultez les rubriques [WindowsFirewall] du Guide de référence de préinstallation de Microsoft Windows. Les sections et entrées définies par l'utilisateur sont identiques pour Unattend.txt et pour Winbom.ini. Consultez l'exemple précédent qui utilise le fichier de réponses Unattend.txt.
  3. Exécutez Sysprep -factory.

Pour désactiver le pare-feu Windows à l'aide du fichier de réponses Winbom.ini

  1. Créez un fichier de réponses Winbom.ini, ou modifiez un fichier de réponses Winbom.ini existant.
  2. Ajoutez les sections et entrées suivantes dans votre fichier de réponses Winbom.ini :
    [WindowsFirewall]
Profiles = WindowsFirewall.TurnOffFirewall

[WindowsFirewall.TurnOffFirewall]
Mode = 0

    Remarque

    • Il n'est pas nécessaire d'inclure l'entrée Type dans la section [WindowsFirewall.TurnOffFirewall]. La valeur par défaut All est appliquée s'il n'existe aucune entrée Type.
  3. Exécutez Sysprep -factory.

Utilisation du fichier Netfw.inf du pare-feu Windows pour configurer les paramètres par défaut

Si l'utilisateur final apporte des modifications aux paramètres du pare-feu Windows, puis décide d'utiliser le bouton Par défaut sous l'onglet Avancé du pare-feu Windows dans le Panneau de configuration, les paramètres par défaut sont lus à partir du fichier Netfw.inf. Toutes les configurations apportées aux paramètres du pare-feu Windows par Unattend.txt ou Winbom.ini sont ignorées. Si vous souhaitez que le bouton Par défaut restaure les paramètres de la configuration d'origine, vous devez utiliser le fichier Netfw.inf pour personnaliser la liste des exceptions du pare-feu Windows.

Pour obtenir plus d'informations sur l'utilisation du fichier Netfw.inf pour configurer la liste des exceptions du pare-feu Windows et les paramètres par défaut du pare-feu, consultez le livre blanc du CD-ROM d'OPK intitulé, Utilisation du fichier .inf du pare-feu Windows dans Microsoft Windows XP Service Pack 2.


Paramètres de l'Assistant Gestion d'installation

L'Assistant Gestion d'installation se compose des pages décrites dans le tableau suivant. Pour connaître les emplacements dans lesquels sont enregistrés les paramètres de chaque page de l'Assistant Gestion d'installation, cliquez sur chaque page dans le tableau.

Important

  • Le nom d'utilisateur et le mot de passe que vous choisissez pour vous connecter au partage de distribution ne sont pas cryptés, ce qui peut constituer une faille dans la sécurité. Il est recommandé de n'accorder à cet utilisateur que le minimum de droits nécessaires pour établir la connexion.
Titre de la page | Description
Fichier de réponse nouveau ou existant | Vous permet de créer ou de modifier un fichier de réponses.
Type d'installation | Fournit trois options d'installation : sans assistance, via Sysprep ou les services d'installation à distance (RIS).
Produit | Vous invite à sélectionner le produit Windows à installer.
Interaction utilisateur | Vous invite à sélectionner le niveau d'interaction utilisateur que vous voulez.
Partage de distribution | Vous permet de créer ou de modifier un partage de distribution, ou d'installer Windows à partir d'un CD.
Emplacement des fichiers d'installation | Vous demande d'indiquer l'emplacement des fichiers d'installation à copier.
Emplacement du dossier partagé de distribution | Vous demande d'indiquer l'emplacement du partage de distribution à créer ou à modifier.
Nom et société | Vous permet d'indiquer un nom d'utilisateur et un nom de société par défaut.
Afficher les paramètres | Vous permet de modifier les paramètres des couleurs, de la zone d'écran et de la fréquence de rafraîchissement.
Fuseau horaire | Vous invite à sélectionner un fuseau horaire par défaut.
Clé du produit | Vous invite à fournir la clé du produit pour identifier votre copie de Windows.
Noms des ordinateurs | Vous invite à fournir les noms des ordinateurs de destination.
Mot de passe Administrateur | Vous permet de spécifier un mot de passe pour le compte Administrateur sur tous les ordinateurs de destination.
Configuration de mise en réseau | Vous permet de choisir des paramètres réseau standard ou personnalisés.
Groupe de travail ou domaine | Vous invite à spécifier la manière dont les ordinateurs de destination s'intègrent à un réseau.
Composants de Windows | Vous permet d'installer les composants Windows fréquemment utilisés.
Téléphonie | Vous permet de spécifier des informations téléphoniques pour l'utilisateur final.
Paramètres régionaux | Vous permet de personnaliser Windows pour des régions et des langues différentes.
Langues | Vous invite à sélectionner les groupes linguistiques à utiliser.
Paramètres de l'Explorateur et de l'interface | Vous permet de personnaliser les paramètres du navigateur et de l'interpréteur de commandes de Windows.
Dossier d'installation | Vous permet de spécifier le nom du dossier Windows.
Installer des imprimantes | Vous permet d'installer des imprimantes en réseau sur les ordinateurs de destination.
Exécuter une fois | Vous permet d'exécuter automatiquement une commande la première fois que l'utilisateur se connecte.
Commandes supplémentaires | Vous permet d'ajouter des commandes à exécuter à la fin d'une installation en mode sans assistance.

Page Nouveau fichier de réponses ou fichier existant

Aucun paramètre n'est écrit à partir de cette page.

Page Type d'installation

Aucun paramètre n'est écrit à partir de cette page.

Page Produit

Aucun paramètre n'est écrit à partir de cette page.

Page Interaction utilisateur

L'Assistant Gestion d'installation enregistre les paramètres de cette page à l'emplacement suivant :

Unattend.txt

[Unattended]

UnattendMode

Cette page n'est pas utilisée pour les installations effectuées via les services d'installation à distance ou Sysprep.

Page Partage de distribution

Aucun paramètre n'est écrit à partir de cette page.

Page Emplacement des fichiers d'installation

L'Assistant Gestion d'installation enregistre les paramètres de cette page à l'emplacement suivant :

Unattend.txt

Page Emplacement du dossier partagé de distribution

L'Assistant Gestion d'installation enregistre les paramètres de cette page à l'emplacement suivant :

Unattend.txt

[Setupmgr]

DistShare

DistFolder

Cette section n'est utilisée que par le Gestionnaire d'installation lors de la modification d'un partage de distribution existant. Elle n'est pas employée par le programme d'installation pendant une installation sans assistance.

Page Nom et société

L'Assistant Gestion d'installation enregistre les paramètres de cette page à l'emplacement suivant :

Unattend.txt

[UserData]

FullName

OrgName

Page Paramètres d'affichage

L'Assistant Gestion d'installation enregistre les paramètres de cette page à l'emplacement suivant :

Unattend.txt

[Display]

BitsPerPel

XResolution

YResolution

VRefresh

Page Fuseau horaire

L'Assistant Gestion d'installation enregistre les paramètres de cette page à l'emplacement suivant :

Unattend.txt

[GuiUnattended]

TimeZone

Page Clé du produit

L'Assistant Gestion d'installation enregistre les paramètres de cette page à l'emplacement suivant :

Unattend.txt

[UserData]

ProductKey

Page Noms d'ordinateur

L'Assistant Gestion d'installation enregistre les paramètres de cette page à l'emplacement suivant :

Unattend.txt

[UserData]

ComputerName

Page Mot de passe Administrateur

L'Assistant Gestion d'installation enregistre les paramètres de cette page à l'emplacement suivant :

Unattend.txt

[GuiUnattended]

AdminPassword

EncryptedAdminPassword

Page Configuration de mise en réseau

L'Assistant Gestion d'installation enregistre les paramètres de cette page à l'emplacement suivant :

Unattend.txt

[Networking]

Si des paramètres personnalisés sont utilisés, des entrées supplémentaires s'affichent sous les en-têtes suivants :

Unattend.txt

[NetAdapters]

[NetClients]

[NetProtocols]

Page Groupe de travail ou domaine

L'Assistant Gestion d'installation enregistre les paramètres de cette page à l'emplacement suivant :

Unattend.txt

[Identification]

Page Composants de Windows

L'Assistant Gestion d'installation enregistre les paramètres de cette page à l'emplacement suivant :

Unattend.txt

[Components]

Page Téléphonie

L'Assistant Gestion d'installation enregistre les paramètres de cette page à l'emplacement suivant :

Unattend.txt

[TapiLocation]

Page Paramètres régionaux

L'Assistant Gestion d'installation enregistre les paramètres de cette page à l'emplacement suivant :

Unattend.txt

[RegionalSettings]

Page Langues

L'Assistant Gestion d'installation enregistre les paramètres de cette page à l'emplacement suivant :

Unattend.txt

[RegionalSettings]

Language

Page Paramètres du navigateur et du shell

L'Assistant Gestion d'installation enregistre les paramètres de cette page à l'emplacement suivant :

Unattend.txt

[FavoritesEx]

Page Dossier d'installation

L'Assistant Gestion d'installation enregistre les paramètres de cette page à l'emplacement suivant :

Unattend.txt

[Unattended]

TargetPath

Page Installer les imprimantes

L'Assistant Gestion d'installation enregistre les paramètres de cette page à l'emplacement suivant :

Unattend.txt

[GuiRunOnce]

Page Exécuter une fois

L'Assistant Gestion d'installation enregistre les paramètres de cette page à l'emplacement suivant :

Unattend.txt

[GuiRunOnce]

Page Commandes supplémentaires

L'Assistant Gestion d'installation enregistre les paramètres de cette page à l'emplacement suivant :

Cmdlines.txt
[Commands]

Les paramètres de cette page ne sont enregistrés que si vous choisissez de créer ou de modifier un partage de distribution. Si vous choisissez d'effectuer l'installation à partir d'un CD, toute information entrée sur cette page est ignorée.


Utilisation de Winnt32.exe pour exécuter le programme d'installation

À partir d'une invite de commandes, vous pouvez exécuter Winnt32.exe pour démarrer le programme d'installation de Windows sur un ordinateur disposant de l'un des systèmes d'exploitation suivants :

  • Windows XP
  • Windows 2000
  • Windows NT
  • Windows Millenium Edition
  • Windows 98
  • Windows 95

Pour obtenir la liste complète des options de la ligne de commande Winnt32.exe, consultez Options de la ligne de commande Winnt32.exe.

Pour exécuter le programme d'installation avec Winnt32.exe

  1. Sur l'ordinateur du technicien, préparez un fichier Unattend.txt créé à l'aide de l'Assistant Gestion d'installation.
  2. Démarrez l'ordinateur de destination à partir de l'un des systèmes d'exploitation répertoriés précédemment.
  3. Cliquez sur Démarrer, sur Exécuter, puis tapez :

    chemin_vers_winn32\winnt32/unattend:nom_fichier

    chemin_vers_winnt32
    Indique le chemin d'accès de Winnt32.exe. Par exemple, \\server\share\I386.
    nom_fichier
    Spécifie le nom du fichier de réponses, lequel contient des réponses aux questions relatives à l'installation que vous souhaitez automatiser. La valeur de nom_fichier est généralement Unattend.txt.

Une fois l'installation terminée, vous pouvez préinstaller les applications, effectuer l'audit du système et exécuter Sysprep pour préparer l'ordinateur à la livraison. Pour plus d'informations, consultez Préinstallation d'applications, Utilisation de Sysprep pour l'audit des installations et Préparation de l'installation en vue d'un déploiement.

Remarques

  • Pour garantir une installation propre, n'installez pas Windows XP ou un produit de la famille Windows Server 2003 en tant que mise à niveau.
  • Le serveur d'installation à distance, qui est décrit dans le Kit de ressources techniques de Microsoft Windows Server 2003 est une autre méthode de préinstallation de Windows XP à partir d'un réseau.


Utilisation de Winnt.exe pour lancer l'installation

À partir d'une invite de commande, utilisez Winnt.exe pour démarrer le programme d'installation de Windows sur un ordinateur qui est installé avec l'un des anciens systèmes d'exploitation suivants :

  • MS-DOS
  • Windows 3.1
  • Windows pour Workgroups

Ces systèmes d'exploitation ne prennent pas en charge les noms de fichier longs, si bien que tous les fichiers et dossiers du partage de distribution doivent être au format 8.3 pour que le programme d'installation de Windows (Winnt.exe) copie les fichiers. Pour restaurer les noms de fichier au format 8.3 en noms de fichier longs au cours de l'installation de Windows, placez le fichier $$Rename.txt dans le partage de distribution. $$Rename.txt doit se trouver dans le dossier $OEM$\$1.

Pour plus d'informations, consultez Conversion des noms de fichiers courts en noms de fichiers longs.

Pour obtenir la liste complète des options de ligne de commande Winnt32.exe, consultez Options de la ligne de commande Winnt.exe.

Vous pouvez aussi utiliser la commande Winnt.exe pour installer Windows sur un réseau. Vous devez démarrer chaque ordinateur de destination en utilisant l'un des systèmes d'exploitation mentionnés ci-dessus, situé sur un support amovible quelconque. Vous pouvez par exemple utiliser une disquette d'amorçage MS-DOS qui contient également une prise en charge réseau.

Pour exécuter le programme d'installation à l'aide de Winnt.exe

  1. Assurez-vous que les pilotes nécessaires pour le lecteur de CD-ROM sont disponibles sur le disque ou le lecteur et qu'ils sont chargés correctement.
  2. Sur l'ordinateur du technicien, utilisez l'Assistant Gestion d'installation pour créer un fichier Unattend.txt.
  3. Démarrez l'ordinateur de destination avec l'un des systèmes d'exploitation mentionnés plus haut.
  4. Cliquez sur Démarrer, sur Exécuter, puis tapez :

    winnt /s:source_installation /u:NomFichier

    source_installation
    Spécifie l'emplacement des fichiers Windows.
    NomFichier
    Spécifie le nom du fichier de réponses, généralement Unattend.txt.

Après avoir terminé l'installation, vous êtes prêt à préinstaller les applications, à auditer le système et à exécuter Sysprep pour convertir le système de manière à ce qu'il soit prêt pour le client.

Pour plus d'informations, consultez Préinstallation d'applications, Utilisation de Sysprep pour l'audit des installations et Préparation de l'installation en vue d'un déploiement.

Remarque

  • Lors d'une installation sans assistance sur un ordinateur doté de plusieurs disques durs ou partitions, vous devez préciser l'emplacement de destination. Utilisez l'option de ligne de commande /t de Winnt ou /tempdrive de Winnt32 pour spécifier la destination.


Conversion des noms de fichier courts en noms de fichier longs

Si vous utilisez Winnt.exe pour préinstaller le système d'exploitation, tous les fichiers et dossiers du partage de distribution doivent être au format 8.3 pour que le programme d'installation de Windows copie les fichiers. Par ailleurs, vous devez toujours utiliser des noms de fichier au format 8.3 lorsque vous copiez un jeu de fichiers d'un ordinateur à un autre à l'aide de MS-DOS.

Utilisez le fichier $$Rename.txt pour restaurer ces noms au format 8.3 en noms de fichier longs au cours de l'installation de Windows. $$Rename.txt doit se trouver dans le dossier $OEM$\$1.

Syntaxe du fichier $$Rename.txt

Syntaxe de $$Rename.txt :

[Nom_section_1]
Nom_court_1 = "Nom_long_1[$$]"
Nom_court_2 = "Nom_long_2[$$]"
.
.
Nom_court_x = "Nom_long_x[$$]"

[Nom_section_2]
.
.

Paramètres

Nom_section_1, Nom_section_2, etc.
Chemin d'accès des dossiers contenant les fichiers. Une section peut ne pas avoir de nom ou son nom peut être une barre oblique inverse (\). Une barre oblique inverse indique que la section contient les noms des fichiers ou sous-dossiers qui se trouvent à la racine du lecteur.
Nom_court_1, Nom_court_2, etc.
Noms des fichiers ou sous-dossiers de ce dossier à renommer. Ne placez pas les noms entre guillemets.
Nom_long_1, Nom_long_2, etc.
Nouveaux noms des fichiers et sous-dossiers. Placez ces noms entre guillemets s'ils comprennent des espaces ou des virgules. Par exemple :
[\]
NomFichier.xxx = "Nom de fichier long.xxx"

Si Nom_long_x est le nom du répertoire Profils et se termine par « $$ », le programme d'installation fusionne ce répertoire avec le répertoire Profils en cours.

Par exemple, si le fichier $$Rename.txt contient les entrées suivantes :

[\]
D = "Documents et Paramètres$$"

dans ce cas, les fichiers répertoriés dans cette section sont placés dans le répertoire Profils de « Documents and Settings$$ ».


Utilisation de scripts de commandes

L'A ssistant Gestion d'installation crée un exemple de script de commandes pour illustrer l'utilisation du fichier de réponses que vous avez créé. Dans certains cas, il est nécessaire de modifier cet exemple de script pour qu'il fonctionne correctement.

Dans tous les cas, le fichier de réponses doit être transmis au programme d'installation de Windows à l'aide de l'option /unattend: de la commande Winnt32 (pour les systèmes Win32) ou de la commande Winnt (pour MS-DOS). Pour plus d'informations, consultez Options de la ligne de commande Winnt32.exe ou Options de la ligne de commande Winnt.exe. En cas de doute, consultez l'exemple de script de commandes.

Si vous effectuez un déploiement à partir d'un partage de distribution, modifiez l'exemple de script de commandes pour qu'il se réfère à ce partage de distribution.

Si vous avez copié le fichier de réponses à un autre emplacement, vous devez modifier le script de commandes pour qu'il fasse référence au nouvel emplacement.

Utilisation des fichiers .udf

Si vous avez spécifié plusieurs noms d'ordinateurs, l'Assistant Gestion d'installation crée un script de commandes qui suppose que le nom de l'ordinateur sera transmis à la ligne de commande. Dans ce cas, le fichier .udf doit aussi être présent.

Lorsque vous utilisez le fichier .udf pour gérer l'attribution de noms à plusieurs ordinateurs, vous devez utiliser l'option /udf avec Winnt32.exe ou Winnt.exe. À titre d'exemple, consultez le script de commandes échantillon créé par l'Assistant Gestion d'installation.


Préparation de l'installation en vue d'un déploiement

L'outil Sysprep s'adresse aux administrateurs de système d'entreprise, aux OEM et à tous ceux qui déploient Windows XP sur plusieurs ordinateurs. Après avoir terminé les premières étapes de l'installation sur un ordinateur unique, vous pouvez exécuter Sysprep pour préparer l'ordinateur à la duplication. Sysprep attribue un ID de sécurité (SID) unique à chaque ordinateur de destination au premier démarrage de celui-ci. Sysprep configure le système d'exploitation de sorte qu'il utilise l'accueil de Windows ou la mini-installation pour s'exécuter au premier redémarrage de l'ordinateur par l'utilisateur final. Cette forme raccourcie de l'installation en mode graphique prend cinq à six minutes au lieu des 45 à 60 minutes habituelles et sollicite l'utilisateur final uniquement concernant des informations spécifiques à l'utilisateur, telle que l'acceptation de l'accord de licence utilisateur final (CLUF) et la saisie de la clé de produit, du nom de l'utilisateur et du nom de la société.

Sysprep est un utilitaire pratique même quand vous n'effectuez pas de duplication de disque. Vous pouvez exécuter Sysprep avec l'option -nosidgen pour configurer l'accueil Windows ou la mini-installation sur un ordinateur unique. Dans ce cas, Sysprep active un audit supplémentaire et automatise la mini-installation pour que les utilisateurs puissent entrer les informations qui leur sont spécifiques, telles que les options régionales et les informations TAPI, mais il s'abstient de créer les identificateurs SID uniques car ces derniers seront uniques lorsque le programme d'installation s'exécutera réellement sur l'ordinateur.

Pour plus d'informations sur Sysprep, consultez :

  • Utilisation de Sysprep
  • Utilisation de Sysprep en mode Usine
  • Composants de Sysprep
  • Sysprep et activation de produit Windows
  • Préparation des images pour la duplication de disque
  • Utilisation de Sysprep pour l'audit des installations
  • Options de la ligne de commande Sysprep


Utilisation de Sysprep

Lorsque vous déployez Windows XP, vous procédez à l'installation complète du système d'exploitation et préconfigurez le shell et les applications au niveau requis. Vous pouvez ensuite utiliser Sysprep pour activer la personnalisation spécifique à l'utilisateur lorsque l'ordinateur est livré ou configuré pour celui-ci. Dans ce cas, la première fois que l'utilisateur final démarre l'ordinateur, l'écran d'accueil de Windows ou de la mini-installation demande à l'utilisateur d'indiquer un minimum d'informations. Une fois le premier démarrage effectué, le dossier Sysprep est supprimé automatiquement du disque dur.

Vous pouvez utiliser l'utilitaire Sysprep dans trois contextes différents :

  • Duplication de disque. L'utilisation de Sysprep pour préparer les images pour la duplication de disque vous permet de copier des systèmes entièrement installés sur du matériel similaire. Sysprep modifie l'identificateur de sécurité (SID) de l'ordinateur local pour le rendre unique sur chaque ordinateur.
  • Audit. Lorsque vous utilisez Sysprep après avoir audité l'ordinateur (à l'aide de l'option de ligne de commande -nosidgen), Sysprep est prêt pour que l'utilisateur final exécute Windows.
  • Sysprep crée une forme raccourcie de l'installation en mode graphique qui prend cinq ou six minutes au lieu des 45 à 60 minutes habituelles, et il invite l'utilisateur final à indiquer uniquement les informations qui lui sont spécifiques, telles que l'acceptation des termes du CLUF, la saisie de la clé de produit, de son nom et de celui de sa société. Pour utiliser Sysprep dans ce mode, préinstallez Windows XP sur l'ordinateur local, puis exécutez Sysprep avec l'option -nosidgen.

Pour plus d'informations, consultez les rubriques suivantes :

  • Utilisation de Sysprep en mode Usine
  • Options de la ligne de commande Sysprep
  • Composants de Sysprep

Pour restaurer manuellement l'ordinateur à l'état de fonctionnement pour l'utilisateur final avec Sysprep

  1. Cliquez sur Démarrer, sur Exécuter, puis tapez :

    cmd

  2. À l'invite de commandes, placez-vous à la racine du lecteur système (%SYSTEMDRIVE%), puis tapez :

    md sysprep

  3. À partir du fichier \Support\Tools\Deploy.cab situé sur le CD-ROM du produit Windows XP, copiez les fichiers Sysprep.exe et Setupcl.exe dans le dossier Sysprep que vous avez créé.
  4. Retirez le CD-ROM du produit Windows du lecteur.
  5. À l'invite de commandes, accédez au dossier Sysprep et tapez :

    sysprep -nosidgen

    avec toutes les options supplémentaires souhaitées. Consultez la rubrique Options de la ligne de commande Sysprep pour obtenir la liste des options de ligne de commande.

  6. L'ordinateur s'arrête automatiquement s'il est compatible ACPI. Si ce n'est pas le cas, un message vous invite à arrêter l'ordinateur une fois le processus terminé.

Pour automatiser le processus de restauration de l'ordinateur à l'état de fonctionnement pour l'utilisateur final

  1. Dans le dossier \$OEM$\$1 de votre partage de distribution, créez un sous-dossier nommé \Sysprep.
  2. Ajoutez les fichiers Sysprep.exe et Setupcl.exe au dossier \$OEM$\$1\Sysprep à partir du fichier \Support\Tools\Deploy.cab situé sur le CD-ROM du produit Windows. Vous pouvez également, si nécessaire, créer un fichier de réponses Sysprep.inf et le placer dans ce dossier.
  3. Dans le fichier de réponses, ajoutez la ligne suivante au bas de la section [GuiRunOnce] :
    %SYSTEMDRIVE%\sysprep\sysprep.exe -quiet options supplémentaires requises

    Pour obtenir la liste des options de ligne de commande, consultez la rubrique Options de la ligne de commande Sysprep.

  4. Une fois l'installation terminée, l'ordinateur s'arrête automatiquement s'il est compatible ACPI. Si ce n'est pas le cas, un message vous invite à arrêter l'ordinateur une fois le processus terminé.

Remarques

Dans Windows XP :

  • Le fichier Sysprep.inf doit résider au même emplacement que Sysprep.exe et Setupcl.exe. Ces fichiers Sysprep doivent se trouver dans le dossier %SYSTEMDRIVE%\Sysprep situé sur le disque dur de l'ordinateur de destination.
  • Lorsque vous exécutez Sysprep.exe, le fichier Sysprep.inf est copié dans %WINDIR%\System32\$winnt$.inf.
  • Vous pouvez spécifier des adresses IP statiques dans le fichier Sysprep.inf. Lorsque l'ordinateur de destination démarre, les informations relatives à la carte réseau sont supprimées, mais Plug-and-Play réinstalle la carte réseau. La mini-installation lit les informations d'adresse IP statique dans le fichier Sysprep.inf et définit l'adresse IP statique sur l'ordinateur de destination.
  • Sysprep s'exécute seulement si l'ordinateur est membre d'un groupe de travail, et non d'un domaine. Si l'ordinateur appartient à un domaine, Sysprep le retire de ce domaine.
  • Vous pouvez exécuter des programmes ou des commandes supplémentaires à la fin de la mini-installation en indiquant un fichier Cmdlines.txt dans le dossier \Sysprep.

    Pour plus d'informations sur Cmdlines.txt, consultez la rubrique Préinstallation d'applications à l'aide des techniques traditionnelles.

  • Vous ne pouvez pas exécuter Sysprep sur un ordinateur qui a été configuré comme serveur de services de cluster ou de services de certificats, ou comme contrôleur de domaine. Vous pouvez exécuter Sysprep sur un serveur autonome.
  • Si vous exécutez Sysprep sur une partition au format de système de fichiers NTFS contenant des fichiers ou dossiers cryptés, les données de ces dossiers deviennent complètement illisibles et irrécupérables.
  • Vous ne pouvez utiliser cette version de Sysprep que sur des installations de Windows XP. Vous ne pouvez pas l'utiliser sur une installation de Windows 2000.
  • Vous ne devez exécuter Sysprep que sur de nouvelles installations de Windows, en préparation pour un déploiement. N'exécutez pas Sysprep sur des installations qui sont en déploiement ou sur des mises à niveau.


Utilisation de Sysprep en mode Usine

Le mode Usine de Sysprep est une méthode de préconfiguration des options d'installation susceptible de réduire le nombre d'images que vous devez gérer.

Le mode Usine permet d'installer des pilotes et des applications supplémentaires après le redémarrage qui a lieu à la fin de l'exécution de Sysprep. En règle générale, l'exécution de Sysprep comme dernière étape du processus de préinstallation prépare l'ordinateur pour sa livraison. Après le redémarrage, l'ordinateur affiche l'accueil Windows ou la mini-installation. L'exécution de Sysprep avec l'option -factory redémarre l'ordinateur avec la prise en charge réseau sans lancer l'accueil de Windows ni la mini-installation. À ce stade, le fichier Factory.exe traite son fichier de réponses, Winbom.ini, et effectue les actions suivantes :

  • Copie les lecteurs d'une source réseau vers l'ordinateur
  • Démarre l'énumération Plug-and-Play
  • Prépare le déploiement des applications, les installe et les désinstalle sur l'ordinateur à partir des fichiers sources placés soit sur l'ordinateur, soit sur une source réseau
  • Ajoute les données du client

À ce stade, vous pouvez auditer l'ordinateur. Une fois terminé, exécutez Sysprep avec l'option -reseal afin de préparer l'ordinateur pour sa livraison au client.

Par exemple, vous pouvez créer une installation principale contenant un jeu minimal de lecteurs, exécuter sysprep -factory, créer une image de l'installation et copier cette image sur plusieurs ordinateurs de destination. Si un ordinateur de destination requiert des pilotes supplémentaires, exécutez sysprep -factory sur l'ordinateur de destination et chargez ces lecteurs à ce moment-là.

En mode Usine, vous pouvez fournir à l'avance des informations utilisateur dans le fichier de réponses Winbom.ini, par exemple le nom, le fuseau horaire et ainsi de suite. En mode Usine, vous pouvez également mettre à jour d'autres fichiers .ini ou d'autres fichiers de réponses, tels que les fichiers Sysprep.inf, Oobeinfo.ini, ou d'autres fichiers .isp et les .ins files.

Remarque

  • Après avoir scellé l'ordinateur avec Sysprep, vous pouvez le redémarrer sans passer par l'accueil Windows en ajoutant l'entrée OEMAuditBoot = 1 à la section [StartupOptions] du fichier Oobeinfo.ini.

Pour plus d'informations sur les autres options de Sysprep, consultez Options de la ligne de commande Sysprep.

Recherche d'un fichier Winbom.ini

Sysprep recherche un fichier Winbom.ini aux emplacements suivants :

  1. le chemin d'accès et le nom de fichier spécifiés par la clé de Registre HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Factory\Winbom ;
  2. la racine de tous les lecteurs de médias amovibles qui ne sont pas des lecteurs de CD-ROM, comme un lecteur de disquette ;
  3. la racine de tous les lecteurs de CD-ROM ;
  4. l'emplacement de Factory.exe, généralement le dossier %SYSTEMDRIVE%\Sysprep ;
  5. la racine de %SYSTEMDRIVE%.

Après avoir localisé un fichier Winbom.ini, Sysprep lit la valeur de l'entrée WinbomType dans la section [Factory].

Si la valeur de l'entrée WinbomType n'est pas appropriée dans ce contexte, le fichier Winbom.ini est ignoré et Sysprep cherche un autre fichier Winbom.ini. Si la valeur de l'entrée WinbomType est appropriée dans ce contexte, Sysprep lit la valeur de l'entrée NewWinbom dans la section [Factory]. Si une valeur est spécifiée pour NewWinbom et qu'un fichier Winbom.ini est placé à cet endroit, Sysprep recherche une entrée NewWinbom dans ce fichier Winbom.ini.

Ce cycle se répète jusqu'à ce que Sysprep trouve un fichier Winbom.ini du type approprié ne contenant pas d'entrée NewWinbom ou il s'arrête sur le dixième fichier Winbom.ini qu'il a trouvé, et choisit la solution qui se présente en premier. Sysprep continue ensuite à s'exécuter en mode Usine, en utilisant les paramètres du dernier fichier Winbom.ini identifié.

Lorsque vous exécutez Sysprep en mode Usine, l'entrée NewWinbom n'est traitée qu'une seule fois à chaque démarrage.


Composants de Sysprep

L'utilitaire Sysprep se compose des fichiers suivants :

  • Sysprep.exe
  • Setupcl.exe
  • Factory.exe
  • Sysprep.inf
  • Winbom.ini

Les fichiers d'application (Sysprep.exe, Setupcl.exe et Factory.exe) sont obligatoires et dépendants les uns des autres.

Sysprep.inf

Sysprep.inf est un fichier de réponses facultatif qui permet d'automatiser partiellement ou totalement la mini-installation. La mini-installation demande à l'utilisateur d'indiquer un certain nombre d'informations générales nécessaires pour configurer l'ordinateur, telles que le fuseau horaire et les paramètres de clavier. Cependant, si Sysprep.inf est présent et qu'il contient des valeurs pour les éléments requis, le programme de mini-installation utilise les informations de Sysprep au lieu d'interroger l'utilisateur.

La syntaxe de Sysprep.inf est similaire à celle du fichier de réponses de l'installation sans assistance, Unattend.txt. Sysprep.inf gère un sous-ensemble des sections et entrées prises en charge par Unattend.txt, plus quelques entrées spécifiques à Sysprep.

Winbom.ini

Le fichier Winbom.ini spécifie une « liste des composants » de l'outil Factory à utiliser pour mettre à jour une installation principale. Pour utiliser l'outil Factory, exécutez sysprep -factory.

Pour plus d'informations, consultez Utilisation de Sysprep en mode Usine et Options de la ligne de commande Sysprep.

Emplacement des fichiers Sysprep

Les fichiers Sysprep doivent se trouver dans le dossier %SYSTEMDRIVE%\Sysprep.

Si vous exécutez Sysprep.exe, Sysprep supprime le dossier %SYSTEMDRIVE%\Sysprep et son contenu au terme de son exécution. Si vous voulez que ce dossier reste sur le disque dur après l'exécution de Sysprep, dans la section [Unattended] du fichier Unattend.txt, affectez à l'entrée FactoryMode la valeur Yes.

Pour garantir que les options que vous spécifiez dans le fichier Sysprep.inf prennent effet, vous devez placer ce dernier au même endroit que Sysprep.exe. En revanche, le fichier Winbom.ini peut se trouver ailleurs.

Remarque

  • Lorsque vous ne spécifiez pas l'option de ligne de commande -nosidgen, Sysprep appelle Setupcl.exe. Vous ne pouvez pas utiliser cet outil directement. Setupcl.exe doit résider dans le même dossier que Sysprep.exe.

Si vous modifiez les autorisations de sécurité sur les fichiers ou dans le registre avant d'exécuter Sysprep, vous devez vous assurer que le compte « Système » a l'autorisation de lecture/écriture dans tous les contextes de sécurité. Dans le cas contraire, l'ordinateur risque d'échouer au prochain démarrage du système d'exploitation.


Sysprep et activation de produit Windows

L'activation de produit Microsoft Windows (WPA, Microsoft Product Activation) est une technologie anti-piratage destinée à vérifier que le produit est utilisé dans le cadre d'une licence acquise légalement.

Les licences de mise à niveau Windows XP acquises dans le cadre de l'un contrat de licence en volume Microsoft, par exemple Licence Microsoft Open, Accord Entreprise ou Licence Select, ne requièrent pas d'activation. Les installations de Windows XP réalisées avec un support de programme de licence en volume et des clés de produits pour licence en volume (VLK, volume license product keys) ne sont pas assujetties à l'activation, à la vérification du matériel ni à aucune limitation quant à l'installation ou la création d'image de disque.

Une clé de produit pour licence en volume est une clé de produit délivrée à un client spécifique dans le cadre d'un contrat de licence spécifique. Chaque clé VLK est associée à un client spécifique et au type de produit couvert par la licence de ce client. Dans le cadre des contrats Licence Select, Accord Entreprise, Accord School ou Accord Campus, le client reçoit une clé VLK par contrat de licence utilisateur final par famille de produits. Pour les licences Microsoft Open, la clé VLK est fournie au client sur la confirmation de commande de Licence Open. Ces clés VLK doivent être fournies durant l'installation du produit ou lors de la création d'une image personnalisée. Une clé VLK doit être utilisée avec le support du programme de licence en volume concerné. Les clés VLK ne peuvent s'utiliser ni avec le produit complet conditionné pour la vente au détail, ni avec le CD OEM.

Utilisez l'entrée ProductKey de Sysprep.inf pour automatiser la saisie de la clé du produit dans les images d'installation réseau ou CD personnalisé, afin d'éviter que la clé du produit ne soit demandée à l'utilisateur final durant l'installation du produit.

Activation pour le support OEM ou revendeur

La plupart des clients n'ont aucune difficulté à réaliser l'activation eux-mêmes après avoir reçu leur ordinateur. Toutefois, si vous le préférez, vous pouvez activer le logiciel au nom de vos clients, ce qui facilite leurs premiers pas avec leur nouvel ordinateur et ajoute à votre service une valeur non négligeable. Une fois l'activation effectuée, la plupart des utilisateurs n'ont plus jamais besoin d'activer à nouveau leur installation.

Vous ne pouvez pas faire une image d'une installation Windows activée, et dupliquer cette image sur un autre ordinateur. Si vous le faites, Windows ne reconnaît pas l'activation et oblige l'utilisateur final à réactiver manuellement l'installation.

Pour activer Windows pour un client, préparez l'entrée ProductKey à partir de la clé du produit figurant sur l'étiquette du certificat d'authenticité (CA) qui est placée sur l'ordinateur concerné, puis activez l'ordinateur à la place de l'utilisateur final. Ensuite, exécutez sysprep -reseal pour arrêter l'ordinateur.

Pour vous assurer d'une activation réussie de l'installation, vous devez exécuter Sysprep avec l'option de ligne de commande -activated. Par exemple :

sysprep -activated -reseal

Si vous n'exécutez pas Sysprep avec l'option -activated, Sysprep supprime ces paramètres d'activation et réinitialise l'horloge de l'activation WPA.

L'horloge de l'activation WPA commence son compte à rebours la première fois que Windows XP est lancé. Vous pouvez utiliser Sysprep au maximum trois fois pour réinitialiser l'horloge de l'activation WPA. Après trois exécutions de Sysprep, l'horloge ne peut plus être réinitialisée.

Limitation du nombre de rescellages Sysprep

  • Vous pouvez créer une installation principale, exécuter sysprep -reseal, créer une image de cette installation, puis stocker cette image en toute sécurité pendant plus de 30 jours. Le compte à rebours du délai de 30 jours pour l'activation de produit Windows ne commence pas avant le prochain démarrage du système d'exploitation.
  • Si vous ne voulez pas réinitialiser l'horloge ou si vous souhaitez conserver des paramètres lors de l'exécution de Sysprep sur une installation déjà activée, utilisez l'option de ligne de commande -activated. Par exemple, tapez :
    sysprep -activated -reseal
  • En utilisant la commande sysprep -activated, vous pouvez éviter de réinitialiser le délai de grâce pour l'activation. Cette méthode exige que le système soit préactivé en usine.
  • Vous pouvez éviter de réinitialiser le délai de grâce en utilisant la préinstallation SLP (System Locked Preinstallation) dans vos installations en usine.
  • En définissant le paramètre OEMAuditBoot = 1 dans la section [Startup] du fichier Oobeinfo.ini avant le rescellage, vous pouvez spécifier que l'ordinateur redémarre en mode Usine. Ceci équivaut à utiliser la commande sysprep -factory.
  • Si vous devez modifier la configuration de l'ordinateur avant de le livrer à l'utilisateur final, vous pouvez appuyer sur CTRL+MAJ+F3 lorsque l'écran de l'Accueil Windows apparaît, afin de repasser en mode audit.

Pour plus d'informations, consultez :

  • L'activation de produit Windows
  • Options de la ligne de commande Sysprep


Préparation des images pour la duplication de disque

Pour vous permettre d'utiliser Sysprep dans le cadre d'une procédure de duplication de disque, les conditions suivantes doivent être remplies :

  • L'installation principale ainsi que les ordinateurs de destination doivent disposer de couches d'abstraction matérielles (HAL) compatibles. Par exemple, HAL APIC et HAL MP (systèmes multiprocesseurs) sont compatibles, alors que HAL PIC (Programmable Interrupt Controller) n'est compatible ni avec HAL APIC ni avec MP HAL.
  • Les contrôleurs de mémoire de masse (IDE ou SCSI) doivent être identiques sur les ordinateurs de référence et de destination.

    Si vous souhaitez créer une image principale pour installer Windows sur des ordinateurs de destination pouvant utiliser des contrôleurs de mémoire de masse différents, vous souhaiterez alors que cette image comprenne tous les périphériques de mémoire de masse identifiés dans les fichiers Machine.inf, Scsi.inf, Pnpscsi.inf et Mshdc.inf. Pour ce faire, insérez le texte suivant dans le fichier Sysprep.inf :

    [Sysprep]
BuildMassStorageSection = Yes
[SysprepMassStorage]

    Pour plus d'informations, consultez Réduction du nombre d'images principales pour les ordinateurs dotés de contrôleurs de stockage de masse différents.

  • En revanche, il n'est pas nécessaire que les périphériques Plug-and-Play (modem, carte son, carte réseau, carte vidéo, etc.) soient les mêmes sur chaque ordinateur de destination. Si un pilote de périphérique ne figure pas dans le fichier Drivers.cab, vous devez l'ajouter à l'installation principale avant d'exécuter Sysprep. Vous pouvez également faire en sorte que les pilotes non installés soient disponibles sur l'ordinateur de destination lors de la première mise en route pour que la fonction Plug-and-Play puisse détecter et installer les pilotes.
  • Des logiciels ou des périphériques matériels de duplication de disque d'autres fournisseurs sont nécessaires. Ces produits créent une image binaire du disque dur d'un ordinateur, puis la dupliquent sur un autre disque dur ou la stockent dans un fichier sur un disque séparé.
  • La taille du disque dur de l'ordinateur de destination doit être au moins équivalente à celle du disque dur de l'ordinateur principal. Si la taille du disque dur de l'ordinateur de destination est plus grande, la différence n'est pas incluse dans la partition principale. Vous pouvez, cependant, utiliser l'entrée ExtendOemPartition dans le fichier Sysprep.inf pour étendre la partition principale si elle a été formatée pour utiliser le système de fichiers NTFS.

    Remarque

    • Si les ordinateurs principal et de destination ont des versions différentes du BIOS, vous devez d'abord tester la procédure.

Pour préparer une installation principale au clonage

  1. Installez Windows XP sur l'ordinateur principal. L'installation principale doit se trouver sur le lecteur C: ou sur un partage de distribution. Pour obtenir les meilleurs résultats, Microsoft recommande d'installer Windows XP à partir d'un partage de distribution avec un fichier de réponses permettant d'assurer la cohérence de la configuration de l'installation principale, de façon à pouvoir créer des versions successives, plus faciles à tester. Pour plus d'informations sur l'automatisation de l'installation de Windows à l'aide de fichiers de réponses, consultez Unattend.txt.
  2. Ouvrez une session sur l'ordinateur en tant qu'administrateur.
  3. (Facultatif) Installez et personnalisez les applications, telles que Microsoft Office, les éléments favoris d'Internet Explorer, etc.
  4. (Facultatif) Installez les pilotes de périphériques ne figurant pas dans le fichier Drivers.cab et non installés par le fichier de réponses.
  5. (Facultatif) exécutez les tests d'audit.
  6. (Facultatif) Créez un fichier Sysprep.inf manuellement ou à l'aide de l'Assistant Gestion d'installation. Ce fichier sert à personnaliser chaque ordinateur pour l'utilisateur et permet de définir les informations qui sont demandées à l'utilisateur au cours de la mini-installation.
  7. Exécutez Sysprep.exe. Vérifiez que les fichiers Sysprep.exe et Setupcl.exe sont tous les deux situés dans le dossier %SYSTEMDRIVE%\Sysprep sur le disque dur local. Pour l'utiliser, le fichier Sysprep.inf doit se trouver dans le même dossier.

    Important

    • Si Setupcl.exe ne se trouve pas dans le même répertoire que Sysprep.exe, Sysprep ne fonctionne pas.
  8. Si l'ordinateur est compatible ACPI, il s'arrête automatiquement. Sinon, une boîte de dialogue s'affiche pour inviter à fermer l'ordinateur
  9. Retirez le lecteur système et exécutez la procédure de duplication du système sur d'autres ordinateurs. Vous devez disposer d'un matériel ou d'un logiciel spécial pour la duplication de disques durs.

Lorsque l'utilisateur met en marche un ordinateur contenant un disque dur dupliqué :

  1. La détection Plug-and-Play a lieu. Cette opération prend environ trois minutes.
  2. La mini-installation invite l'utilisateur à :
    • accepter le Contrat de Licence Utilisateur Final (CLUF) ;
    • spécifier son nom et celui de son organisation ;
    • se joindre à un domaine ou un groupe de travail ;
    • spécifier les options régionales ;
    • spécifier les informations TAPI (Telephony API) ;
    • spécifier les protocoles et services réseau à installer.

    Remarque

    • Si un fichier Sysprep.inf a été utilisé pour exécuter Sysprep.exe, seules les boîtes de dialogue omises dans le fichier .inf s'affichent. Si les paramètres d'affichage ne sont pas définis, les paramètres par défaut sont utilisés à la place.
  3. Le dossier Sysprep local contenant Sysprep.exe et Sysprep.inf dans %SYSTEMDRIVE% est supprimé.
  4. L'ordinateur redémarre et l'écran d'ouverture de session apparaît.

Pour plus d'informations, consultez Utilisation de Sysprep en mode Usine.


Utilisation de Sysprep pour l'audit des installations

La procédure d'audit permet de vérifier qu'un ordinateur fonctionne correctement avant sa livraison à l'utilisateur. Au cours de cette procédure, vous pouvez, par exemple, vérifier que le système d'exploitation se charge et que les applications sont correctement lancées, exécuter un programme de défragmentation de disque, exécuter l'utilitaire Chkdsk afin d'examiner l'état du disque dur, vérifier que les contrats de licence sont respectés et vous assurer que tous les périphériques installés dans le Gestionnaire de périphériques sont correctement reconnus.

Vous pouvez utiliser vos propres outils d'audit pour examiner chaque ordinateur sur lequel Windows est déployé. Vous avez la possibilité de tester l'ordinateur, puis d'utiliser l'outil Sysprep pour le replacer dans l'état où l'utilisateur final peut en prendre livraison. Lorsque l'utilisateur le mettra en marche pour la première fois, l'ordinateur exécutera l'accueil Windows ou la mini-installation.

Pour auditer un ordinateur de destination

  1. Installez Windows en suivant la procédure décrite dans Utilisation de Sysprep. Une fois l'installation terminée, l'ordinateur redémarre et exécute alors la version complète de Windows.
  2. Créez le dossier \\Sysprep avant d'y copier Sysprep.exe et Setupcl.exe. Pour plus d'informations, consultez Utilisation de Sysprep.
  3. Auditez le système à l'aide d'un outil d'audit d'un fabricant tiers.

    Important

    • Lors d'un audit, ne remplacez pas de fichiers système et ne perturbez pas l'ordinateur préconfiguré, car Sysprep n'est pas en mesure de détecter ou de restaurer les fichiers système modifiés par vos outils d'audit.
    • Vous pouvez redémarrer autant de fois que nécessaire pendant l'audit de l'ordinateur.
  4. Une fois l'audit terminé, supprimez les fichiers ou dossiers placés sur le disque dur pendant la procédure d'audit. À l'invite de commandes, accédez au répertoire contenant Sysprep.exe, puis tapez la commande suivante avec les options de ligne de commande appropriées :

    sysprep -nosidgen

    Pour plus d'informations, consultez Options de la ligne de commande Sysprep.

  5. Une fois Sysprep terminé, fermez immédiatement Windows. L'ordinateur est désormais prêt pour la livraison à l'utilisateur final.


Sysprep et hyperthreading

L'hyperthreading permet aux applications logicielles multithread d'exécuter des threads parallèles au sein de chaque processeur. Sur un système optimisé hyperthreading, Windows XP et les membres de la famille Windows Server 2003 fonctionnent comme ils le feraient sur un système multiprocesseur, même s'il n'y a effectivement qu'un processeur physique installé. Pour plus d'informations, consultez Windows Support for Hyper-Threading Technology (http://www.microsoft.com/whdc/hwdev/platform/proc/HT-Windows.mspx).

Lorsqu'une image Sysprep est déployée sur un système optimisé hyperthreading, si la couche d'abstraction matérielle (HAL, Hardware Abstraction Layer) est incompatible, l'ordinateur risque de pas démarrer correctement. Si l'ordinateur ne démarre pas correctement, il peut ne pas être en mesure de tirer parti de la technologie hyperthreading.

Pour vérifier quelle HAL est utilisée par l'ordinateur :

  1. Dans la barre des tâches, cliquez sur Démarrer, puis sur Exécuter.
  2. Tapez DEVMGMT.MSC, puis cliquez sur OK.

    Le Gestionnaire de périphériques s'ouvre.

  3. Dans le Gestionnaire de périphériques, cliquez sur le signe plus (+) en regard de l'icône Ordinateur pour développer la branche Ordinateur et afficher le type de HAL.

Pour vous assurer que les images Sysprep seront compatibles avec les systèmes optimisés hyperthreading, vous devez créer l'image principale sur l'un des types de systèmes suivants :

  • ordinateur optimisé hyperthreading conforme à la norme ACPI ;
  • ordinateur APIC exécutant l'interface ACPI que le Gestionnaire de périphériques appelle « PC monoprocesseur ACPI » ;
  • ordinateur multiprocesseur conforme à la norme ACPI.

Si vous ne créez pas l'image Sysprep sur l'un de ces types de systèmes, Windows ne pourra pas mettre à jour le système pour qu'il utilise plusieurs processeurs. Une image Sysprep faite sur un ordinateur multiprocesseur conforme à la norme ACPI s'exécutera dans une configuration multiprocesseur même si la prise en charge de la technologie hyperthreading est désactivée dans le BIOS.

Windows utilise automatiquement les capacités hyperthreading du processeur si les conditions suivantes sont réunies :

  • Le matériel de l'ordinateur prend en charge la fonctionnalité hyperthreading et celle-ci est activée dans le BIOS de l'ordinateur.
  • La fonctionnalité hyperthreading est installée sur le processeur de l'ordinateur.
  • L'installation de Windows utilise la couche HAL PC monoprocesseur ACPI.
  • Windows détecte un ou plusieurs processeurs ou un ou plusieurs threads actifs.

Lorsque ces conditions sont réunies, Windows met automatiquement la HAL à jour en HAL « PC multiprocesseur ACPI » et installe un processeur supplémentaire, qui apparaîtra sous Processeurs dans le Gestionnaire de périphériques.

Pendant l'exécution, le type de HAL doit être « PC multiprocesseur ACPI », faute de quoi les capacités hyperthreading du processeur ne seront pas utilisées. Si le type de HAL est « PC multiprocesseur ACPI », cela signifie qu'une ou plusieurs des conditions précitées n'ont pas été satisfaites.


Personnalisation et test de l'ordinateur de destination

Plusieurs actions doivent se produire après la préinstallation du système d'exploitation afin de préparer l'ordinateur de destination à la distribution. Certaines d'entre elles peuvent être effectuées dans l'usine et d'autres peuvent être reportées jusqu'à ce que l'utilisateur final démarre l'ordinateur pour la première fois.

L'utilisation de commandes dans la section [GuiRunOnce] qui doit être effectuée pour terminer l'installation sur l'ordinateur de destination illustre cette dernière action, car elle peut être retardée jusqu'au premier démarrage de l'ordinateur par l'utilisateur.

L'horloge de l'activation de produit Windows commence son compte à rebours la première fois que Windows XP démarre. Vous pouvez utiliser Sysprep au maximum trois fois pour réinitialiser l'horloge de l'activation de produit Windows. Après trois exécutions de Sysprep, l'horloge ne peut plus être réinitialisée.

  • Préinstallation d'applications
  • Préinstallation d'applications à l'aide de techniques traditionnelles
  • Préremplissage de la clé du produit et préactivation de Windows
  • Premier démarrage de l'utilisateur final
  • Préconfiguration et automatisation de la mini-installation
  • Suppression de l'accès à des composants de Windows
  • Audit des ordinateurs de destination
  • Préinstallation de correctifs
  • Préinstallation de l'interface utilisateur multilingue (MUI, Multilingual User Interface)
  • Préinstallation du Pack linguistique LIP (Language Interface Pack)


Préinstallation d'applications

Lors de la sélection des logiciels à préinstaller, Microsoft vous recommande de choisir ceux qui satisfont aux critères du programme Certifié pour Windows (http://msdn.microsoft.com/certification/). Pour plus d'informations sur les avantages de cette certification, consultez Programmes de logo Microsoft Windows.

Le meilleur moment pour préinstaller des applications sur les ordinateurs Windows est celui de l'exécution en mode Usine de Sysprep, à l'aide de la section [OEMRunOnce] du fichier Winbom.ini. Cette technique est plus rapide et beaucoup plus souple dans l'environnement de fabrication.

Pour élaborer ces ordinateurs, l'une des méthodes consiste à commencer par une image de base du système d'exploitation uniquement personnalisée avec la marque de l'entreprise et configurée pour démarrer dans Sysprep en mode Usine au prochain redémarrage. Pour chaque commande, placez l'image de base sur l'ordinateur de destination, puis installez chaque application commandée par le client et scellez l'ordinateur afin de le préparer à la distribution. Ces applications peuvent être installées manuellement ou à l'aide de la section [OEMRunOnce] du fichier Winbom.ini.

Toutefois, si les applications représentent des logiciels d'installation Microsoft® Windows® Installer, le même niveau de personnalisation peut être obtenu de manière plus efficace en préparant le déploiement de toutes les applications sur l'installation principale. Lorsque vous préparez le déploiement d'une application, tous les fichiers sont placés sur l'ordinateur, mais aucune modification n'est apportée au Registre. Une fois que l'image de l'installation principale est placée sur l'ordinateur de destination, vous pouvez soit attacher (terminer l'installation), soit détacher (supprimer tous les fichiers) chaque application, de manière à configurer l'ordinateur selon les souhaits du client. L'installation de l'application attachée est plus rapide car le programme d'installation n'a pas besoin de copier les fichiers sur l'ordinateur. Par ailleurs, il est plus facile de supprimer des fichiers d'un ordinateur que d'installer une application via une connexion réseau, en particulier lorsque cette application est installée sur la plupart des ordinateurs de destination.

Si vous ajoutez des applications au profil Propriétaire (dans Windows XP Édition familiale) ou au profil Administrateur (dans les autres versions de Windows), l'Accueil de Windows ou la Mini-installation copie ces applications vers le profil de l'utilisateur par défaut afin qu'elles soient disponibles lorsque l'utilisateur final ouvre une session. Si vous souhaitez installer des applications sur des comptes d'utilisateurs isolés, vous devez installer ces applications après l'achèvement de l'Accueil Windows ou de la Mini-installation, ou encore les installer au moyen d'un compte d'utilisateur autre que Propriétaire ou Administrateur.

Exemple : Préinstallation d'applications très vendues

Fabrikam, Inc. est un fabricant d'ordinateurs OEM qui fabrique des ordinateurs sur commande. Fabrikam propose trois applications de productivité en options standard. D'après les ventes précédentes, Fabrikam sait que 80 % de ses clients commandent la première application, 70 % commandent la deuxième application et 50 % commandent la troisième.

Fabrikam construit un jeu de configuration pour l'image de base qu'il utilise avec ce type d'ordinateur. Dans la boîte de dialogue Ajouter une application de l'Assistant Gestion d'installation, les trois applications sont identifiées comme utilisant des scripts Microsoft Windows Installer (.msi).

L'Assistant Gestion d'installation génère un fichier Winbom.ini à partir duquel les fichiers des trois applications différentes sont copiés vers l'ordinateur principal, mais les applications elles-mêmes ne sont pas entièrement installées. Lors de son arrêt, l'ordinateur est configuré pour redémarrer dans le mode Usine de Sysprep.

[OEMRunOnce]
"Se connecter au partage réseau", "net use R: \\serveur\partage"
"Déployer première application", "Application1.Stage", MSI
"Déployer deuxième application", "Application2.Stage", MSI
"Déployer troisième application", "Application3.Stage", MSI

[Application1.Stage]
InstallType = Stage
StagePath = "C:\App1_Temp"
SetupFile = "Application_Une.msi"
SourcePath = "R:\ApplicationUne"

[Application2.Stage]
InstallType = Stage
StagePath = "C:\App2_Temp"
SetupFile = "Application_Deux.msi"
SourcePath = "R:\ApplicationDeux"

[Application3.Stage]
InstallType = Stage
StagePath = "C:\App3_Temp"
SetupFile = "Application_Trois.msi"
SourcePath = "R:\ApplicationTrois"

[Factory]
ResealMode = Factory
Reseal = Yes

Fabrikam crée une image de l'installation principale. Par ailleurs, l'équipe technique de Fabrikam a créé un outil personnalisé qui permet de générer un fichier Winbom.ini spécifique au client correspondant à chaque commande et de le placer sur une disquette.

À l'usine, l'assembleur reçoit une commande et la disquette correspondante, copie l'image principale sur l'ordinateur de destination et place la disquette dans le lecteur. L'ordinateur est redémarré dans l'atelier et entre dans le mode Usine de Sysprep qui traite le fichier Winbom.ini spécifique au client.

Pour cette commande, ce fichier Winbom.ini installe la première application et supprime les fichiers de la deuxième et de la troisième application. L'ordinateur, une fois éteint, est prêt à être livré au client.

[OEMRunOnce]
"Attacher la première application", "Application1.Attach", MSI
"Détacher la deuxième application", "Application2.Detach", MSI
"Détacher la troisième application", "Application3.Detach", MSI

[Application1.Attach]
InstallType = Attach
StagePath = "C:\App1_Temp"
SetupFile = "Application_Une.msi"

[Application2.Detach]
InstallType = Detach
StagePath = "C:\App2_Temp"

[Application3.Detach]
InstallType = Detach
StagePath = "C:\App3_Temp"

[Factory]
ResealMode = OOBE
Reseal = Shutdown

Utilisation de [GuiRunOnce] ou de Cmdlines.txt pour préinstaller des applications

Pour assurer la compatibilité descendante, vous pouvez toujours appliquer les techniques que vous avez utilisées pour préinstaller les applications sous Windows 2000. Néanmoins, avec ces techniques, le premier démarrage de l'ordinateur par l'utilisateur final sera plus long ; elles ne sont donc pas recommandées. Pour plus d'informations, consultez Préinstallation d'applications à l'aide des techniques traditionnelles.

Placement de raccourcis d'applications dans le menu Démarrer

Si vous voulez placer un raccourci vers l'application dans la liste des programmes les plus fréquemment utilisés (MFU, Most Frequently Used) du menu Démarrer, vérifiez qu'un chemin d'accès au fichier de raccourci (.lnk) figure dans la section [StartMenuMFUlist] du fichier Winbom.ini.

Reconditionnement des applications pour la préinstallation

Si l'application n'a pas de package d'installation Microsoft Windows Installer (.msi), vous pouvez utiliser un outil fourni par un fabricant tiers pour reconditionner les applications au format .msi. Le format .msi est préconisé car il offre les avantages suivants :

  • Il permet d'installer les applications pendant l'installation sans assistance de Windows.
  • Il contribue à réduire les problèmes de gestion des versions de fichiers .dll.

Pour plus d'informations sur Microsoft Windows Installer, consultez http://www.microsoft.com/windowsxp/home/using/productdoc/en/default.asp?url=/WINDOWSXP/home/using/productdoc/en/sag_WinInstall_Overview.asp.

Vous pouvez également utiliser le programme d'installation propre à l'application à condition qu'il dispose d'une option de ligne de commande /q (calme) ou /s (silencieuse).

Les options de la ligne de commande d'installation varient d'une application à l'autre. Par exemple, certaines applications utilisent l'option /l pour créer un fichier journal afin de surveiller l'installation. Il est important de consulter le fabricant de l'application pour obtenir les informations, instructions et outils nécessaires avant de procéder à la préinstallation.

Remarque

  • Si l'application utilise un programme d'installation InstallShield, vous devez ajouter un commutateur -SMS (sans guillemets) à la ligne de commande. Le nom du commutateur -SMS doit être écrit en majuscules. Grâce à cette option de la ligne de commande, le processus créé par le programme d'installation s'arrête avant le traitement de l'entrée suivante de la section [OEMRunOnce].

Important

  • Vous devez satisfaire aux critères requis en matière de licence pour toute application que vous installez sur l'ordinateur, quelle que soit la méthode utilisée pour la préinstaller.
  • Si le programme d'installation d'une application remplace un système de fichiers Windows en cours par l'ancien système de fichiers dans son package d'installation, la Protection de fichier Windows est activée et remplace l'ancien système de fichiers par le système de fichiers en cours installé avec Windows.


Préinstallation d'applications à l'aide des techniques traditionnelles

Le meilleur moment pour préinstaller des applications sur les systèmes Windows XP est celui de l'exécution en mode Usine de Sysprep, à l'aide de la section [OEMRunOnce] du fichier Winbom.ini. Cette technique est plus rapide et beaucoup plus souple dans l'environnement de fabrication. Pour plus d'informations, consultez Préinstallation d'applications.

Pour assurer la compatibilité descendante, vous pouvez toujours appliquer les techniques que vous avez utilisées pour préinstaller les applications sous Windows 2000. Néanmoins, avec ces techniques, le premier démarrage de l'ordinateur par l'utilisateur final sera plus long ; elles ne sont donc pas recommandées.

Préinstallation d'applications à l'aide Cmdlines.txt

Utilisez Cmdlines.txt dans les cas suivants :

  • Vous effectuez l'installation à partir du partage de distribution \$OEM$.
  • Vous installez des applications pendant la phase d'installation en mode graphique.
  • L'application que vous installez est conçue pour être installée par un seul utilisateur et vous devez dupliquer les informations propres à l'utilisateur vers tous les utilisateurs de l'ordinateur.

Les commandes énumérées dans Cmdlines.txt sont synchrones, ce qui signifie qu'aucune d'elles ne peut s'exécuter aussi longtemps que la commande précédente (éventuelle) n'est pas terminée.

Le fichier Cmdlines.txt contient les commandes que le programme d'installation en mode graphique exécute lors de l'installation de composants facultatifs telles que des applications. Par exemple, vous pouvez utiliser les commandes spécifiées dans ce fichier pour exécuter un fichier .inf en utilisant la commande Rundll32.exe ou pour effectuer une autre action. Si vous prévoyez d'utiliser Cmdlines.txt pour installer une application, placez l'application en question dans le sous-dossier \$OEM$ du partage de distribution.

Remarque

  • Pour plus d'informations sur l'utilisation de Rundll32.exe avec des fichiers .inf, consultez le Kit de développement de logiciel Microsoft Platform à l'adresse http://msdn.microsoft.com/library/.

Syntaxe de Cmdlines.txt :

[Commands]
"commande_1"
"commande_2"
     .
     .
"commande_x"
"commande_1", "commande_2" etc.
Spécifie les commandes à exécuter dans l'ordre lorsque l'installation en mode graphique appelle Cmdlines.txt. Placez toutes les commandes entre guillemets.

Limites et conseils d'utilisation de Cmdlines.txt

Cmdlines.txt présente les limitations suivantes :

  • Lorsque Cmdlines.txt s'exécute, aucun utilisateur n'a de session ouverte et la connexion réseau n'est pas établie. Les informations spécifiques à l'utilisateur sont toutes consignées dans le Registre de l'utilisateur par défaut et tous les utilisateurs créés par la suite héritent de ces paramètres de Registre.
  • Vous devez placer les fichiers nécessaires à l'exécution d'une application ou d'un utilitaire dans le partage de distribution.
  • Lorsque vous installez des applications en utilisant Cmdlines.txt, installez-les en mode sans assistance. Ainsi, l'utilisateur n'est pas obligé de répondre à des messages à propos de l'application.
  • Vous ne pouvez pas installer les applications Microsoft® Windows® Installer (.msi) à l'aide de Cmdlines.txt. Utilisez plutôt [GuiRunOnce].

Préinstallation d'applications à l'aide de [GuiRunOnce]

Utilisez [GuiRunOnce] dans les circonstances suivantes :

  • Vous effectuez une installation à partir d'une source quelconque : réseau, disque dur ou lecteur de CD-ROM.
  • Vous ne pouvez pas installer l'application pendant la phase d'installation en mode graphique.
  • Vous voulez ouvrir une session en tant qu'utilisateur et ne souhaitez pas que ces paramètres de Registre soient automatiquement dupliqués pour les utilisateurs futurs.
  • L'application que vous installez exige qu'un utilisateur ait ouvert une session sur l'ordinateur.

Remarque

  • [GuiRunOnce] nécessite que la fonction d'ouverture de session soit activée (utilisez l'entrée AutoLogon dans la section [GuiUnattended]). Pour plus d'informations, consultez Automatisation du processus d'ouverture de session.

Les commandes énumérées dans [GUIRunOnce] sont synchrones, ce qui signifie qu'aucune d'elles ne peut s'exécuter aussi longtemps que la commande précédente (éventuelle) n'est pas terminée.

La section [GuiRunOnce] du fichier Unattend.txt contient une liste de commandes qui s'exécutent lors de la première ouverture de session après l'installation en mode graphique. Chaque ligne entre guillemets spécifie une commande qui est enregistrée dans la clé GuiRunOnce du Registre Windows. Par exemple, entrez la ligne suivante dans [GuiRunOnce] pour exécuter Sysprep dans le cadre de l'installation sans assistance.

[GuiRunOnce]
"%SYSTEMDRIVE%\Sysprep\Sysprep -quiet"

Si une application nécessite l'installation de l'Explorateur Windows, vous pouvez utiliser [GuiRunOnce] pour créer une installation d'usine automatisée qui exécute le programme d'installation, ouvre automatiquement une session sur l'ordinateur, installe l'application, puis arrête l'ordinateur. [GuiRunOnce] peut également servir à contrôler l'ordre dans lequel les applications sont installées.

Important

  • [GuiRunOnce] ne peut pas servir à activer l'exécution de shells, d'autres programmes, etc., au cours du démarrage par l'utilisateur final.

Automatisation du processus d'ouverture de session

Vous pouvez configurer le processus d'ouverture de session automatique en ajoutant AutoLogon = Yes à la section [GuiUnattended] du fichier Unattend.txt (fichier de réponses). Windows ouvre alors une session automatiquement en utilisant le compte et le mot de passe Administrateur après le premier redémarrage, une fois l'installation terminée. Le mot de passe du compte d'administrateur peut être vide (NULL), mais vous avez la possibilité de spécifier un mot de passe dans le fichier de réponses. La valeur par défaut de AutoLogon est No.

Remarques

  • Si le mot de passe du compte Administrateur est vide, l'ordinateur ouvre une seule session. Si un mot de passe est attribué, l'ordinateur ouvre plusieurs sessions et Windows enregistre le mot de passe dans le Registre.
  • Si vous utilisez l'Assistant Gestion d'installation pour crypter le mot de passe, AutoLogon ne fonctionne pas. Une solution de ce problème consiste à créer un autre compte doté des privilèges administratifs durant l'installation en mode graphique et à utiliser ce compte à la place du compte Administrateur pour automatiser l'ouverture de session. Quand vous avez terminé, le compte est supprimé. Vous avez ainsi la possibilité d'ouvrir une session automatiquement, d'installer des applications et d'arrêter l'ordinateur sans compromettre l'intégrité du mot de passe du compte Administrateur.

Pour plus d'informations, consultez Définition du mot de passe Administrateur.

Contrôle de l'installation des applications

Si vous souhaitez contrôler l'installation de plusieurs applications, vous pouvez créer un fichier de commandes qui contient toutes les commandes individuelles d'installation et la commande Start avec l'option de ligne de commande /wait. Cette méthode garantit que vos applications s'installent dans l'ordre et que chaque procédure d'installation commence seulement quand l'application précédente est complètement installée. Le fichier de commandes est alors exécuté à partir de la section [GuiRunOnce] du fichier de réponses.

La procédure ci-dessous explique comment effectuer les actions suivantes :

  • créer le fichier de commandes ;
  • installer l'application ;
  • supprimer toutes les références au fichier de commandes une fois l'installation achevée.

Pour installer des applications à l'aide d'un fichier de commandes

  1. Créez un fichier de commandes contenant les lignes suivantes :

    Start /wait chemin\programme_installation [-x ...]
    ...
    Exit

    chemin
    Désigne le chemin d'accès du fichier exécutable qui démarre l'installation.
    programme_installation
    Désigne le nom du fichier exécutable qui démarre l'installation.
    x
    Désigne les options sans assistance disponibles, appropriées à l'application que vous voulez installer.
  2. Copiez le fichier de commandes vers le partage de distribution ou un autre dossier accessible pendant l'exécution du programme d'installation.

    Remarque

    • Vous pouvez également copier le fichier de commandes nomfichier.bat dans le dossier Sysprep du partage de distribution. Le fichier de commandes est alors un fichier local de l'ordinateur de destination. Après l'exécution de Sysprep, l'utilisateur réalise la première mise en route, l'ordinateur redémarre et le dossier Sysprep est supprimé avec tout ce qu'il contient. Il n'est pas nécessaire de supprimer le fichier de commandes avec un autre processus. Pour plus d'informations, consultez Utilisation de Sysprep.
  3. En utilisant nomfichier.bat comme nom du fichier de commandes, ajoutez dans la section [GuiRunOnce] du fichier de réponses l'entrée nécessaire pour exécuter ce fichier de commandes. Par exemple :
    [GuiRunOnce]
Command0() = "%SYSTEMDRIVE%\sysprep\nomfichier.bat"
Command1() = "chemin-1\Commande-1.exe"
Commandn() = "chemin-n\Commande-n.exe"
Commandn+1() = "%SYSTEMDRIVE%\sysprep\sysprep.exe –quiet"
    chemin\Commande-1.exe et chemin-n\Commande-n.exe
    Spécifie les chemins d'accès complets aux applications supplémentaires, installations d'utilitaires, outils de configuration ou autre fichier de commandes. Tous ces chemins doivent être accessibles pendant l'exécution du programme d'installation.

Cet exemple suppose que le fichier de commandes a été copié dans le dossier Sysprep du disque dur local, mais ce fichier peut se trouver à n'importe quel emplacement accessible au programme d'installation au cours de l'installation.


Préremplissage de la clé de produit et préactivation de Windows

En raison des conditions requises par l'activation de produit Windows dans Windows XP, vous ne pouvez pas préremplir une clé de produit générique pour tous les ordinateurs que vous fabriquez. Vous avez cependant d'autres possibilités :

  • Répercuter une clé de produit dans plusieurs installations, sans activer aucune de ces installations. Vous devrez exécuter Sysprep pour supprimer cette clé de produit avant de livrer l'ordinateur de destination à l'utilisateur final.
  • Préconfigurer une clé de produit unique sur un ordinateur de destination et activer l'installation Windows en usine. La clé de produit que vous utilisez pour activer l'installation Windows doit correspondre à la clé de produit indiquée sur l'étiquette autocollante du certificat d'authenticité placée sur cet ordinateur particulier.

Pour plus d'informations, consultez Sysprep et activation de produit Windows.

Utilisation d'une clé de produit unique dans votre usine

Dans votre processus de préinstallation, vous pouvez dupliquer vers plusieurs ordinateurs de destination une image de système d'exploitation contenant une clé de produit donnée, aux conditions suivantes :

  • N'essayez pas d'activer plusieurs installations Windows avec cette clé de produit.
  • Exécutez Sysprep sur chaque ordinateur de destination pour supprimer cette clé de produit avant de livrer l'ordinateur à l'utilisateur final.

Le système d'exploitation doit être configuré de telle sorte que, lorsque l'utilisateur final le démarre pour la première fois, l'accueil Windows ou la mini-installation demande à l'utilisateur d'entrer la clé de produit unique correspondant à l'étiquette autocollante du certificat d'authenticité placée sur cet ordinateur.

Pour plus d'informations, consultez Sysprep et activation de produit Windows.

Préactivation de Windows pour le compte de l'utilisateur

Vous pouvez livrer à l'utilisateur un ordinateur sur lequel vous avez préconfiguré l'installation de Windows, à l'aide de la clé de produit unique indiquée sur l'étiquette autocollante du certificat d'authenticité placée sur le châssis de cet ordinateur. Vous pouvez aussi recourir à Internet pour activer chaque installation de Windows dans votre usine.

Préconfiguration de la clé de produit

Si vous ne souhaitez pas entrer manuellement une clé de produit, vous pouvez la préconfigurer dans l'un de ces emplacements :

  • L'entrée ProductKey, située dans la section [UserData] du fichier Unattend.txt
  • L'entrée ProductKey, située dans la section [UserData] du fichier Sysprep.inf
  • L'entrée ProductKey, située dans la section [Version] du fichier Oobeinfo.ini

Vous pouvez modifier manuellement le fichier Unattend.txt à l'aide d'un éditeur de texte ou à partir de la page Clé du produit dans l'Assistant Gestion d'installation. Vous ne pouvez modifier l'entrée ProductKey du fichier Oobeinfo.ini que manuellement, à l'aide d'un éditeur de texte.

Utilisation d'Internet pour l'activation de Windows en usine

Dans un environnement de production, vous pouvez utiliser Internet pour activer une installation de Windows.

Important

  • Une clé de produit est toujours exigée.
  • La clé de produit que vous utilisez pour activer l'installation à l'aide de l'activation de produit Windows doit correspondre au numéro indiqué sur le certificat d'authenticité qui accompagne chaque produit vendu au détail et qui est collé physiquement sur le châssis de l'ordinateur par le constructeur OEM.
  • Les contrats de licence standard spécifient que vous pouvez utiliser une clé de produit donnée pour n'activer qu'une seule installation de Windows XP sur un ordinateur. L'activation de produit Windows se charge de faire respecter cette obligation.

Pour activer automatiquement l'installation de Windows durant l'installation

  1. Dans Unattend.txt, définissez l'entrée ProductKey de la section [UserData] comme égale à la clé de produit figurant sur l'étiquette autocollante du certificat d'authenticité placée sur cet ordinateur.
  2. Donnez à AutoActivate la valeur Oui.
  3. Installez Windows en mode sans assistance, conformément à la description fournie dans Utilisation de Winnt32.exe pour lancer l'installation.

L'ordinateur de destination doit avoir un accès physique à Internet. Si la connexion Internet passe par un pare-feu, vous devrez sans doute configurer manuellement les paramètres de proxy appropriés :

  • Spécifiez vos paramètres de proxy dans la section [Proxy] du fichier Unattend.txt.
  • Dans la section [Unattended], affectez à ActivateProxy la valeur Proxy.
  • Lorsque vous exécutez Sysprep sur cet ordinateur de destination, vous devrez inclure l'option de ligne de commande -activated.

Important

  • Définir AutoActivate = Yes ne garantit pas le succès de l'activation de cette installation de Windows XP. Par exemple, cette tentative d'activation échouera si l'ordinateur ne parvient pas à se connecter à Internet.

Pour vous assurer d'une activation réussie de l'installation, vous devez exécuter Sysprep avec l'option de ligne de commande -activated. Par exemple :

sysprep -activated -reseal

Important

  • Si vous n'exécutez pas Sysprep avec l'option -activated, Sysprep supprime ces paramètres d'activation et réinitialise l'horloge dans l'activation de produit Windows.

Pour plus d'informations, consultez Sysprep et activation de produit Windows et Options de la ligne de commande Sysprep.


Premier démarrage de l'utilisateur final

L'accueil de Windows constitue le premier démarrage par défaut pour Windows XP Édition familiale et Windows XP Professionnel ; la mini-installation constitue quant à elle le premier démarrage par défaut pour la famille Windows Server 2003, Service Pack 1 (SP1) et Windows XP Édition 64 bits version 2003. Chaque premier démarrage permet à l'utilisateur final de lire le Contrat de Licence Utilisateur Final (CLUF), d'entrer et d'activer la clé du produit pour cette installation de Windows XP et de configurer des paramètres utilisateur qui ne sont pas encore présents dans l'ordinateur de destination.

Vous pouvez configurer Windows XP Professionnel pour qu'il utilise la mini-installation au lieu de l'accueil de Windows par défaut à l'aide de la commande sysprep -mini, comme décrit dans Options de la ligne de commande Sysprep. Vous ne pouvez pas modifier le mode de premier démarrage de Windows XP Édition familiale ; ce produit présente toujours l'accueil de Windows lors de son premier démarrage.

Accueil de Windows

La séquence de pages exacte que l'utilisateur final voit dans l'accueil de Windows est contrôlée par Oobeinfo.ini.

Mini-installation

Toutes les pages de la mini-installation sont présentées à l'utilisateur final, sauf si vous préconfigurez les paramètres utilisateur.

Pour faciliter le test dans votre environnement de production, vous pouvez automatiser la mini-installation à l'aide de Sysprep.inf. Cependant, vous ne pouvez pas utiliser ce fichier pour automatiser l'accueil de Windows. Pour plus d'informations, consultez la rubrique Préconfiguration et automatisation de la mini-installation.

Il est possible de configurer Windows XP Professionnel pour qu'il utilise la mini-installation au lieu de l'accueil de Windows par défaut à l'aide de la commande sysprep -mini, comme décrit dans Options de la ligne de commande Sysprep. Vous pouvez configurer Windows XP Professionnel pour qu'il utilise la mini-installation sur des ordinateurs que vous distribuez à des clients.

Remarque

  • Étant donné que Windows XP Édition familiale utilise toujours un groupe de travail, la mini-installation sur Windows XP Édition familiale n'affiche pas la page Groupe de travail ou domaine d'ordinateurs.

Résolution d'écran et Windows XP

Si le matériel de l'ordinateur prend en charge une résolution d'écran minimale de 800 x 600 pixels et que la résolution d'écran par défaut est de 640 x 480 pixels, l'accueil de Windows reconfigure l'ordinateur pour utiliser une résolution d'écran de 800 x 600 pixels.

Si le matériel de l'ordinateur ne prend pas en charge une résolution d'écran minimale de 800 x 600 pixels, Windows XP Édition familiale et Windows XP Professionnel utilisent par défaut la mini-installation au lieu de l'accueil de Windows. Utilisez l'entrée ScreenResolutionCheck dans la section [StartupOptions] du fichier Oobeinfo.ini pour configurer Windows XP de manière à utiliser des barres de défilement dans l'accueil de Windows lorsque le matériel ne prend pas en charge la résolution minimale requise.


Préconfiguration et automatisation de la mini-installation

La mini-installation correspond au premier démarrage pour la famille de systèmes d'exploitation Windows Server 2003 avec Service Pack 1 (SP1) et Windows XP Édition 64 bits. Vous pouvez configurer Windows XP Professionnel pour utiliser la mini-installation plutôt que l'accueil Windows par défaut, conformément à la description fournie dans Options de la ligne de commande Sysprep.

Pour plus d'informations sur l'accueil Windows et la mini-installation, consultez Premier démarrage de l'utilisateur final.

Vous pouvez utiliser le fichier de réponses Sysprep.inf pour pré-remplir les informations de configuration utilisateur et automatiser la mini-installation. Si vous utilisez Sysprep.inf, la mini-installation peut demander un sous-ensemble des informations de configuration, ou vous pouvez créer une installation entièrement automatisée qui ne pose aucune question à l'utilisateur concernant la configuration.

Vous ne pouvez pas utiliser Sysprep.inf pour automatiser l'accueil Windows.

Remarque

  • Au lieu d'automatiser la mini-installation, vous pouvez améliorer l'efficacité de votre production en utilisant Sysprep pour démarrer l'ordinateur en mode Usine, ce qui vous permet de sauter complètement le premier démarrage de l'utilisateur final. En mode Usine, vous pouvez installer des applications supplémentaires, mettre à jour des pilotes ou auditer l'ordinateur préinstallé. Pour plus d'informations, consultez Utilisation de Sysprep en mode Usine.

La syntaxe de Sysprep.inf est similaire au fichier de réponses d'installation sans assistance, Unattend.txt. Sysprep.inf prend en charge un sous-ensemble des sections et entrées prises en charge par Unattend.txt ainsi que certaines entrées spécifiques à Sysprep. Vous pouvez utiliser l'Assistant Gestion d'installation pour créer le fichier Sysprep.inf.

Contenu de la mini-installation

Si Sysprep.inf n'est pas utilisé, la Mini-installation affiche les écrans suivants :

  • Bienvenue dans l'installation de Windows
  • Contrat de licence
  • Clé du produit
  • Options régionales et linguistiques
  • Personnalisez votre logiciel
  • Nom d'ordinateur et mot de passe Administrateur
  • Paramètres de date et d'heure
  • Paramètres de gestion de réseau
  • Groupe de travail ou domaine d'ordinateurs
  • Terminer l'installation de Windows

Important

  • L'utilisateur final doit accepter le Contrat de Licence Utilisateur Final Microsoft (CLUF) pour terminer l'installation de Windows.

Pour contourner ces pages et faire en sorte que Sysprep automatise complètement l'installation, vous pouvez spécifier au moins les entrées suivantes dans Sysprep.inf :

Pour sauter cette page | Ajoutez cette entrée à Sysprep.inf
Options régionales et linguistiques | [GuiUnattended] Définissez OemSkipRegional avec la valeur 1.
Personnalisez votre logiciel | [UserData] FullName OrgName
Nom d'ordinateur et mot de passe Administrateur | [UserData] ComputerName [GuiUnattended] AdminPassword
Paramètres de date et d'heure | [GuiUnattended] TimeZone
Paramètres réseau | [Networking] [Identification] JoinWorkgroup (se joindre à un groupe de travail) JoinDomain, DomainAdmin, DomainAdminPassword (se joindre à un domaine)
Paramètres réseau (ne concerne que la famille Windows Server 2003) | [LicenseFilePrintData] Définissez AutoMode avec la valeur PerServer. Définissez AutoUsers avec une valeur inférieure ou égale au nombre d'utilisateurs autorisés par votre contrat de licence.

Exécution de commandes supplémentaires lors de la mini-installation

Vous pouvez exécuter des programmes ou des commandes supplémentaires au terme de la mini-installation en plaçant un fichier Cmdlines.txt dans le dossier Sysprep. Les commandes qui effectuent des modifications dans les préférences utilisateur ne sont pas appliquées aux utilisateurs si elles sont exécutées à partir de Cmdlines.txt dans l'accueil Windows ou la mini-installation.

Pour exécuter Cmdlines.txt pendant la mini-installation

  1. Dans le dossier de distribution, créez :

    %SYSTEMDRIVE%\Sysprep\i386\$OEM$

  2. Ajoutez Cmdlines.txt au dossier %SYSTEMDRIVE%\Sysprep\i386\$OEM$.
  3. Dans Sysprep.inf, ajoutez :
    [Unattended]
InstallFilesPath = C:\Sysprep\i386
  4. Exécutez Sysprep.

Important

  • L'entrée InstallFilesPath ne prend pas en charge les variables d'environnement (par exemple %SYSTEMDRIVE%). Vous devez utiliser un chemin d'accès valide à la place avec une lettre de lecteur existante.

Pour plus d'informations sur Cmdlines.txt, consultez Préinstallation d'applications à l'aide des techniques traditionnelles.


Suppression de l'accès à des composants de Windows

Dans Windows XP, vous pouvez supprimer des points d'entrée visibles vers Internet Explorer, Outlook Express, le Lecteur Windows Media ou Windows Messenger. Ces points d'entrée visibles peuvent être supprimés dans le cadre d'une installation en mode silencieux ou en postinstallation à l'aide des outils Sysprep ou Factory.

Remarque

  • Les options permettant de supprimer les points d'entrée visibles de chacun de ces éléments sont également disponibles dans l'outil Ajout/Suppression de programmes, sous Ajouter ou supprimer des composants Windows et Configurer les programmes par défaut.

Pour supprimer des points d'entrée visibles lors d'une installation en mode silencieux

  1. Utilisez l'Assistant Gestion d'installation pour créer un fichier Unattend.txt ou modifiez un fichier Unattend.txt existant.
  2. Pour supprimer les points d'entrée visibles vers Internet Explorer, dans la section [Components] du fichier Unattend.txt, attribuez à IEAccess la valeur Off.
  3. Pour supprimer les points d'entrée visibles vers Outlook Express, dans la section [Components] du fichier Unattend.txt, attribuez à OEAccess la valeur Off.
  4. Pour supprimer les points d'entrée visibles vers le Lecteur Windows Media, dans la section [Components] du fichier Unattend.txt, attribuez à WMPOCM la valeur Off.
  5. Pour supprimer les points d'entrée visibles vers Windows Messenger, dans la section [Components] du fichier Unattend.txt, attribuez à WMAccess la valeur Off.
  6. Exécutez une installation en mode silencieux en suivant les instructions fournies dans Options de la ligne de commande Winnt32.exe.

Exemple

[Components]
IEAccess = Off
OEAccess = Off
WMAccess = Off
WMPOCM = Off

Pour supprimer les points d'entrée visibles vers Internet Explorer, Outlook Express, le Lecteur Windows Media ou Windows Messenger lorsque Windows est déjà installé, effectuez l'une des procédures suivantes :

Pour supprimer des points d'entrée visibles à l'aide de Sysprep

  1. Créez un fichier Unattend.txt avec une ou plusieurs des entrées suivantes dans la section [Components] :
    [Components]
IEAccess = Off
OEAccess = Off
WMAccess = Off
WMPOCM = Off

    Vous pouvez utiliser le même fichier Unattend.txt, comme décrit plus haut dans « Pour supprimer des points d'entrée visibles lors d'une installation en mode silencieux », ou vous pouvez utiliser un fichier distinct contenant uniquement la section [Components].

  2. Ajoutez la ligne de commande suivante à la section [GuiRunOnce] de Sysprep.inf :
    [GuiRunOnce]
sysocmgr /u:unattend.txt /q /r /c /x
  3. Exécutez Sysprep, en suivant les instructions fournies dans Utilisation de Sysprep.

Pour supprimer des points d'entrée visibles à l'aide du fichier Winbom.ini et de l'outil Factory

  1. Créez un fichier Winbom.ini avec une ou plusieurs des entrées suivantes dans la section [Components] :
    [Components]
IEAccess = Off
OEAccess = Off
WMAccess = Off
WMPOCM = Off
  2. Ajoutez la ligne de commande suivante à la section [GuiRunOnce] de Sysprep.inf :
    [GuiRunOnce]
sysocmgr /u:winbom.ini /q /r /c /x
  3. Exécutez Sysprep -factory, en suivant les instructions fournies dans Utilisation de Sysprep en mode Usine.

Changement des programmes par défaut

Dans Windows XP, vous pouvez installer des applications tierces qui se lancent à la place d'Internet Explorer, d'Outlook Express, du Lecteur Windows Media ou de Windows Messenger, telles qu'activées par les paramètres du Registre Windows et d'autres mécanismes documentés. Le programme d'installation de ces applications tierces peut enregistrer ces dernières en modifiant des éléments, tels que les associations de fichiers par défaut pour des extensions données, les gestionnaires de protocoles des URL, les gestionnaires MIME et les gestionnaires d'exécution automatique, de sorte que les applications tierces soient appelées (dans des circonstances équivalentes) à la place d'Internet Explorer, d'Outlook Express, du Lecteur Windows Media ou de Windows Messenger. Pour plus d'informations, consultez Registering Programs with Client Types (http://msdn.microsoft.com/library/en-us/shellcc/platform/shell/programmersguide/shell_adv/RegisteringApps.asp).

Pour configurer Windows de sorte qu'un utilisateur final puisse réactiver ultérieurement la configuration d'origine du fabricant d'ordinateurs OEM pour ces composants, ajoutez les entrées suivantes dans la section Shell du fichier Winbom.ini.

[Shell]
DefaultClientIM =
DefaultClientJavaVM =
DefaultClientMail =
DefaultClientMedia =
DefaultClientStartMenuInternet =

La valeur par défaut de chacune de ces entrées correspond à n'avoir aucun paramètre. Vous pouvez modifier ces paramètres par défaut en indiquant le nom canonique d'un programme de remplacement, comme décrit dans Registering Programs with Client Types (http://msdn.microsoft.com/library/en-us/shellcc/platform/shell/programmersguide/shell_adv/RegisteringApps.asp), à droite de chaque signe égal.

Tout programme spécifié pour l'une de ces entrées doit pouvoir changer les associations de fichiers par défaut, comme décrit dans Registering Programs with Client Types.

Si une entrée est manquante, le programme par défaut associé à cette entrée ne change pas lorsque l'utilisateur choisit de réactiver la configuration OEM d'origine. Par exemple, en l'absence d'entrée DefaultClientJavaVM, la machine virtuelle par défaut pour Java reste inchangée si l'utilisateur choisit de réactiver le paramètre OEM par défaut.


Modification des paramètres de la stratégie de groupe

Lors de la préinstallation, avec Windows XP, d'applications qui modifient les objets Stratégie de groupe utilisateur locaux ou lors de la création de nouveaux groupes d'utilisateurs locaux bénéficiant d'autorisations spécifiques, il est conseillé de procéder de la façon suivante :

  1. Attendez environ cinq minutes après la modification ou l'ajout des objets Stratégie de groupe locaux afin de vous assurer que les modifications été prise en compte.

    — ou —

    Redémarrez l'ordinateur.

  2. Exécutez Sysprep.

Effectuez ces étapes lorsque vous modifiez des stratégies de groupe pour des groupes locaux ou lorsque vous créez de nouveaux groupes et de nouvelles stratégies sur un ordinateur avant d'exécuter Sysprep. Par exemple, effectuez ces étapes lorsque vous :

  • préinstallez une version de Windows Server 2003 avec des autorisations de groupe spécifiques ;
  • préinstallez des ordinateurs d'entreprise avec des autorisations de groupe d'utilisateurs personnalisées.


Audit des ordinateurs de destination

L'audit est la vérification manuelle des nouveaux ordinateurs. Vous pouvez vérifier le chargement du système d'exploitation et le démarrage des applications, exécuter un programme de défragmentation du disque, exécuter Chkdsk pour détecter les fichiers endommagés du disque dur, vérifier que tous les périphériques installés dans le Gestionnaire de périphériques sont correctement reconnus et exécuter d'autres outils d'audit ou de vérification. Vous pouvez vérifier que le premier démarrage de l'utilisateur final se déroule normalement, que l'écran d'accueil et les ajouts d'aide OEM fonctionnent correctement et que les informations sur les options de support de votre entreprise sont présentes dans les Propriétés système. Vous pouvez tester l'ordinateur ou installer les applications sans détruire les pages affichées pour le premier démarrage par l'utilisateur final.

Vous êtes également chargé de corriger toutes les erreurs graves détectées pendant l'installation initiale. Si des erreurs graves sont détectées, l'installation en mode graphique vous invite à consulter le journal des erreurs d'installation. Si ces erreurs ne sont pas corrigées, l'utilisateur final est invité à son tour, lors de l'affichage de l'écran d'accueil de Windows ou de la mini-installation, à consulter le journal des erreurs d'installation qui répertorie les erreurs de l'installation initiale, ainsi que celles survenues lors du premier démarrage de l'utilisateur final.

Il vous appartient également de nettoyer le disque dur avant de livrer l'ordinateur à l'utilisateur final. N'oubliez pas de supprimer les fichiers ou les dossiers que vos outils d'audit ont pu créer.

Après l'audit ou les vérifications, vous devez exécuter Sysprep qui constitue la dernière étape du processus de déploiement. Sysprep supprime les modifications système effectuées par les outils d'audit et rétablit l'ordinateur à l'état de disponibilité pour le client, sans réinstaller Windows ou toute autre application précédemment installée. Lorsque l'utilisateur recevra l'ordinateur et le mettra en marche pour la première fois, ce dernier exécutera la procédure d'accueil de Windows ou une mini-installation.

Vous pouvez redémarrer l'ordinateur autant de fois que nécessaire pendant l'audit.

Important

  • Vous pouvez utiliser Sysprep au maximum trois fois pour réinitialiser l'horloge en vue de l'activation de produit Windows. Après trois exécutions de Sysprep, l'horloge ne peut plus être réinitialisée. Pour plus d'informations, consultez Sysprep et activation de produit Windows.

Pour plus d'informations et des instructions complètes sur l'utilisation de Sysprep, consultez Préparation de l'installation en vue d'un déploiement.

Pour auditer un ordinateur de destination

  1. Exécutez sysprep -audit.
  2. Préinstallez Windows en suivant les procédures décrites dans « Préparation de l'installation » et «Création de l'installation ». Lorsque l'installation est terminée et que l'ordinateur de destination est redémarré, ce dernier exécute une version complètement installée de Windows.
  3. Créez un dossier \Sysprep sur %SYSTEMDRIVE% de l'ordinateur de destination. Copiez Sysprep.exe, Setupcl.exe et Factory.exe dans ce répertoire. Placez également vos fichiers personnalisés Sysprep.inf et Winbom.ini dans ce même répertoire.
  4. Effectuez l'audit du système à l'aide de vos outils d'audit.
  5. Une fois l'audit terminé, supprimez les fichiers ou les dossiers placés sur le disque dur pendant la procédure d'audit.

    À l'invite de commandes, accédez au dossier contenant Sysprep.exe, puis tapez la commande suivante :

    sysprep -reseal

    L'option -reseal efface le journal de l'Observateur d'événements et prépare l'ordinateur pour sa livraison au client.

    Vous pouvez également inclure d'autres options de ligne de commande, telles que décrites dans les options de ligne de commande Sysprep.

  6. Une fois Sysprep terminé, fermez immédiatement Windows. L'ordinateur est maintenant prêt à être distribué à l'utilisateur final.

Pour effectuer l'audit d'un ordinateur de destination après avoir exécuté Sysprep -reseal

Après avoir exécuté sysprep -reseal afin de préparer l'ordinateur de destination pour l'utilisateur final, vous pouvez toujours accéder au Bureau Windows pour effectuer l'audit du système.

Si l'accueil de Windows est exécuté lors du premier démarrage :

  • Appuyez sur CTRL-MAJ-F3 au premier écran d'accueil de Windows et acceptez le Contrat de Licence Utilisateur Final (CLUF). L'ordinateur redémarre alors en mode Usine.

    — ou —

  • Modifiez le fichier Oobeinfo.ini dans l'installation et ajoutez l'entrée OEMAuditBoot = 1 à la section [StartupOptions]. L'ordinateur redémarre alors en mode Usine.

Si la mini-installation est exécutée lors du premier démarrage :

  • Ajoutez au fichier Sysprep.inf situé dans le dossier C:\Sysprep toutes les entrées nécessaires pour automatiser entièrement la mini-installation. Le système termine automatiquement la mini-installation, puis il redémarre. Après avoir terminé l'audit de l'ordinateur, vous devez recopier le dossier Sysprep sur le disque dur et réexécuter sysprep -reseal.

Important

  • Lorsque l'ordinateur redémarre, l'accueil de Windows ou la mini-installation supprime le dossier %SYSTEMDRIVE%\Sysprep et son contenu.
  • Ne jamais écraser les fichiers système ni perturber le système préinstallé. Sysprep n'est pas en mesure de détecter ni de restaurer les fichiers système modifiés par vos outils d'audit.

Remarque

  • Sysprep rétablit le délai d'attente du menu de démarrage à sa valeur par défaut, soit 2 secondes lorsqu'un seul système d'exploitation est installé, ou 0 seconde lorsque plusieurs systèmes d'exploitation sont installés, de façon que l'image à partir de laquelle vous avez exécuté Sysprep démarre par défaut. Après l'exécution de l'accueil de Windows ou de la mini-installation, la valeur du délai d'attente du menu de démarrage est fixée à 30 secondes.

Une fois l'ordinateur remis en état de disponibilité pour le client, il peut être distribué au client avec tous les composants de Windows éventuellement requis, conformément au contrat de licence Microsoft. Il s'agit généralement des éléments suivants :

  • CD-ROM de produit Windows
  • Certificat d'authenticité (COA)

La commande sysprep -audit redémarre l'ordinateur en mode Usine sans générer de nouveaux ID de sécurité (SID) ni traiter aucun élément de la section [OEMRunOnce] de Winbom.ini.

N'utilisez cette option de ligne de commande que si l'ordinateur est déjà configuré en mode Usine.

Pour plus d'informations, consultez Options de la ligne de commande Sysprep.

Important

  • S'il existe un compte d'utilisateur nommé « Propriétaire », l'accueil de Windows le supprime.
  • Si durant vos tests, vous créez des comptes d'utilisateurs supplémentaires dans le dossier Comptes d'utilisateurs du Panneau de configuration de Windows XP, Sysprep et l'accueil de Windows ne suppriment pas ces comptes lorsque vos tests sont terminés.
  • Lors de l'exécution de l'accueil de Windows, le compte Propriétaire (dans Windows XP Édition familiale) ou Administrateur (dans Windows XP Professionnel) est copié dans le profil d'utilisateur par défaut. Pour cette raison, si vous ajoutez des fichiers au profil utilisateur par défaut avant d'exécuter Sysprep -reseal, ceux-ci n'existeront plus après la fin de l'accueil de Windows.
  • Avant de resceller l'ordinateur, supprimez les comptes d'utilisateurs que vous avez créés pour le test dans le dossier Comptes d'utilisateurs du Panneau de configuration de Windows XP.
  • Pour ajouter ou supprimer des comptes, cliquez sur le bouton Démarrer, cliquez avec le bouton droit sur Poste de travail, cliquez sur Propriétés, sélectionnez l'onglet Avancé, puis cliquez sur Paramètres dans la section Profil des utilisateurs.


Programmes de logo Microsoft Windows

Microsoft Corporation a développé le programme de logo « Designed for Microsoft Windows » (Conçu pour Microsoft Windows) (http://www.microsoft.com/winlogo/default.mspx) et le programme « Certified for Windows » (Certifié pour Windows) (http://msdn.microsoft.com/certification/) afin d'aider les utilisateurs finaux à identifier facilement les matériels et les logiciels spécialement conçus pour les systèmes d'exploitation Windows. L'objectif de ce programme est de s'assurer que les utilisateurs finaux auront une expérience optimale en utilisant le matériel et les logiciels qui portent le logo « Designed for Microsoft Windows ».

Les utilisateurs peuvent combiner différents matériels et logiciels portant ces logos, et ont la garantie que ces produits bénéficient des nouvelles technologies disponibles dans Microsoft Windows XP et la famille Windows Server 2003.

Pour utiliser les logos « Designed for Microsoft Windows » et « Certified for Microsoft Windows », une licence spécifique est nécessaire. Le fait que ces logos soient sous licence permet aux concepteurs de les utiliser sur les sites Web, les conditionnements de produit, les accessoires, dans leur publicité ainsi que dans tous autres documents commerciaux ayant une relation avec des produits qui ont subi les tests et ont obtenu la licence leur permettant de porter ces logos. Utilisez le logo « Designed for Microsoft Windows » uniquement tel que spécifié dans la licence du logo.

Test du matériel

L'organisme chargé de tester le matériel pour le programme de logo est le Laboratoire du contrôle qualité pour Windows (WHQL) qui effectue les tests de compatibilité pour le matériel et les pilotes Windows 2000, Windows XP et Windows Server 2003. Le matériel comme les logiciels sont tous testés avant d'obtenir le droit de porter un logo.

Les fabricants de matériel dont les produits ont subi avec succès le programme des tests de WHQL reçoivent un rapport de test détaillé, l'intégration du matériel testé à la Liste du matériel compatible (HCL) de Microsoft Windows et la possibilité de distribuer gratuitement des pilotes dans la Bibliothèque de pilotes Windows (WDL).

Pour obtenir une liste actualisée du matériel pris en charge, consultez le Catalogue Windows (http://www.microsoft.com/whdc/hcl/default.mspx) (en anglais) (auparavant connu sous le nom « liste du matériel compatible »).

Nous vous encourageons à soumettre votre matériel à des tests pour obtenir le logo ainsi qu'à utiliser des composants portant le logo « Designed for Microsoft Windows ». Pour plus d'informations, contactez

WHQL
Microsoft Corporation
One Microsoft Way
Redmond, WA 98053-6399 États-Unis d'Amérique
Télécopie : (425) 703-3872

Pour plus d'informations sur le matériel, visitez le site Web central pour le matériel et les pilotes Windows (http://www.microsoft.com/whdc/).

Certification des logiciels

La certification des logiciels nécessite que les concepteurs de logiciels suivent les directives indiquées sur le site Web Application Specifications for Windows (spécifications des applications pour Windows) (http://msdn.microsoft.com/certification/appspec.asp). Ces applications :

  • permettent une installation solide et auto-corrective qui minimise les conflits entre les composants partagés ;
  • facilitent le déploiement des logiciels et la gestion pour les organisations ;
  • conservent correctement les préférences utilisateur et les paramètres de l'ordinateur pour garantir de bonnes conditions d'utilisation pour les « utilisateurs itinérants », assurer la prise en charge de plusieurs utilisateurs par ordinateur et la régénération des paramètres de l'application dans les scénarios de remplacement de l'ordinateur ;
  • s'exécutent dans un environnement réseau très contrôlé afin de permettre aux administrateurs réseau de sécuriser et de gérer les ordinateurs de bureau de leur entreprise ;
  • permettent à l'utilisateur d'avoir une expérience positive et de satisfaire aux normes d'accessibilité afin de réduire les coûts liés au support et à la formation ;
  • offrent une transition en douceur d'une application à l'autre aux utilisateurs qui procèdent à une mise à niveau à partir de Windows 95 ou de versions ultérieures ;
  • prennent en charge les fonctions de gestion OnNow pour avoir une meilleure expérience des ordinateurs portables.

Les applications conformes aux spécifications du serveur :

  • offrent un support pour une infrastructure globalement disponible afin de faciliter l'accès de l'utilisateur et la gestion de l'administrateur ;
  • facilitent un accès sécurisé aux ressources et apportent une sécurité aux interactions clients-serveurs ;
  • réduisent les temps morts de service dus aux pannes système ou aux mises à niveau et maintenances planifiées des serveurs, en exploitant les services de clusters (pour les applications répondant aux conditions pour Windows Server 2003, Enterprise Edition).

Pour obtenir une liste des derniers logiciels testés, consultez le programme « Certified for Windows » (Certifié pour Windows) (http://msdn.microsoft.com/certification/).


Préinstallation de correctifs

Cette rubrique décrit trois procédures permettant d'installer des correctifs sur l'ordinateur du technicien avant de préinstaller le système d'exploitation sur des ordinateurs de destination :

  • Intégration de correctifs dans un partage de distribution
  • Préinstallation de correctifs à l'aide de l'Assistant Gestion d'installation et des jeux de configuration (pour les fabricants d'ordinateurs OEM uniquement)
  • Préinstallation de correctifs à l'aide d'un partage de distribution et d'un serveur (pour les administrateurs informaticiens de l'entreprise)

Ces procédures sont destinées à Windows XP et à la famille Windows Server 2003.

Intégration de correctifs dans un partage de distribution

Cette procédure explique comment intégrer des correctifs (procédé également appelé slipstreaming) dans votre processus de préinstallation Windows. Vous pouvez intégrer la préinstallation de Windows XP ou de la famille Windows Server 2003 et les correctifs correspondants à partir d'un dossier de distribution partagé situé sur un réseau. Le processus intégré installe le correctif lors de l'installation de Windows.

Cette méthode ne fonctionne que pour les correctifs distribués à partir de Windows Sustained Engineering (correctifs liés au système d'exploitation Windows central et aux outils du Kit de préinstallation OEM). Remplacez « pro.sp2 » ci-dessous par le nom de la version de Windows que vous voulez mettre à jour. Par exemple, pour intégrer Windows XP Édition familiale SP2, remplacez « pro.sp2 » par « per.sp2 ». Vous pouvez déterminer le nom correct de la version de Windows en ouvrant le dossier c:\OPKTools\Lang\<LANG>\sku.

Vous pouvez utiliser cette procédure avec les outils du Kit de préinstallation OEM (pour les fabricants d'ordinateurs OEM uniquement) ou les partages de distribution (pour les administrateurs informaticiens de l'entreprise). Les chemins d'accès au dossier sont toutefois différents. Par exemple :

c:\OPKTools\Lang\Eng\Sku\Pro.sp2\x86\i386 (fabricants d'ordinateurs OEM)
c:\XPPRO2\i386 (clients qui ne sont pas fabricants d'ordinateurs OEM)

Pour intégrer des correctifs dans un partage de distribution

  1. Créez un dossier c:\OPKTools\lang\eng\sku\pro.sp2\x86\i386\svcpack. Par exemple, à l'invite de commandes, tapez ce qui suit :
    MD c:\OPKTools\lang\eng\sku\pro.sp2\x86\i386\svcpack
  2. Renommez le correctif en lui attribuant un nom de fichier adéquat au format 8.3 (le programme d'installation ne reconnaît pas les noms de fichiers longs). Par exemple, tapez ce qui suit :
    REN Q308387_WXP_SP2_X86_ENG.EXE Q308387.EXE
  3. Copiez le programme exécutable du correctif (dans cet exemple, Q308387.EXE) dans le dossier c:\OPKTools\lang\eng\sku\pro.sp2\x86\i386\svcpack.

    Remarque

    • Si vous déployez plusieurs correctifs, copiez et renommez tous les fichiers de correctif dans le même dossier.
  4. Développez le contenu du correctif dans un emplacement temporaire unique. Par exemple, pour développer les fichiers dans un dossier nommé c:\hold, à l'invite de commandes, tapez ce qui suit :
    c:\OPKTools\lang\eng\sku\pro.sp2\x86\i386\svcpack\Q308387.exe /X

    Lorsque vous êtes invité à le faire, tapez c:\hold.

  5. Copiez le fichier de catalogue et les fichiers de correctif associés à partir du dossier c:\hold. Par exemple, à l'invite de commandes, tapez ce qui suit :
    Copy c:\hold\sp3\update\KB823980.cat c:\OPKTools\lang\eng\sku\pro.sp2\x86\i386\svcpack

    Remarques

    • Si vous déployez plusieurs correctifs ensemble, vous devez copier tous les fichiers de catalogue de chacun des correctifs à déployer. Chaque correctif possède un fichier de catalogue unique que vous devez copier au format KBnnnnnn.cat.
    • Utilisez le contenu du dossier SP3 si vous utilisez la version SP2. Le correctif correspond toujours à n+1 de la version du système d'exploitation que vous utilisez.
  6. Supprimez les fichiers d'origine. Par exemple, à l'invite de commandes, tapez ce qui suit :
    del c:\OPKTools\lang\eng\sku\pro.sp2\x86\i386\rpcss.dl_
del c:\OPKTools\lang\eng\sku\pro.sp2\x86\i386\rpcrt4.dl_
del c:\OPKTools\lang\eng\sku\pro.sp2\x86\i386\ole32.dl_

    Important

    • Si vous ne supprimez pas les fichiers d'origine, les fichiers mis à jour ne peuvent pas remplacer les originaux.
  7. Copiez les fichiers exécutables du correctif à partir du répertoire c:\hold\sp3 dans le dossier c:\OPKTools\lang\eng\sku\pro.sp2\x86\i386 :
    copy c:\hold\sp3\rpcss.dll c:\OPKTools\lang\eng\sku\pro.sp2\x86\i386
copy c:\hold\sp3\rpcrt4.dll c:\OPKTools\lang\eng\sku\pro.sp2\x86\i386
copy c:\hold\sp3\ole32.dll c:\OPKTools\lang\eng\sku\pro.sp2\x86\i386

    Il n'est pas nécessaire de copier les fichiers Update.exe, Update.inf, SPmsg.dll, SPcustom.dll, SPuninst.exe, Update.ver ou les fichiers de symboles (.pdb).

  8. Supprimez le fichier c:\OPKTools\lang\eng\sku\pro.sp2\x86\i386\svcpack.in_.
  9. Créez un nouveau fichier Svcpack.inf dans c:\OPKTools\lang\eng\sku\pro.sp2\x86\i386. Ajoutez les sections et entrées suivantes avec les valeurs appropriées au correctif que vous appliquez.

    Pour Windows XP :

    [Version]
Signature = "$Windows NT$"
MajorVersion = 5
MinorVersion = 1
BuildNumber = 2600

[SetupData]
CatalogSubDir = "\i386\svcpack"

[ProductCatalogsToInstall]
KBArticleNumber.cat

[SetupHotfixesToRun]
KBArticleNumber.exe /options

    Pour Windows Server 2003 :

    [Version] Signature="$Windows NT$"
MajorVersion = 5
MinorVersion = 2
BuildNumber = 3790

[SetupData]
CatalogSubDir = "\i386\svcpack"

[ProductCatalogsToInstall]
KBArticleNumber.cat

[SetupHotfixesToRun]
KBArticleNumber.exe /options

    Pour Windows 2000 :

    [Version]
Signature = "$Windows NT$"
MajorVersion = 5
MinorVersion = 0
BuildNumber = 2195

[SetupData]
CatalogSubDir = "\i386\svcpack"

[ProductCatalogsToInstall]
KBArticleNumber.cat

[SetupHotfixesToRun]
KBArticleNumber.exe /options

    Remarque

    • Si vous envisagez de déployer plusieurs correctifs ensemble à l'aide de cette procédure, ajoutez une entrée pour chaque correctif dans les sections [ProductCatalogsToInstall] et [SetupHotfixesToRun]. Par exemple :
      [ProductCatalogsToInstall]
KB123456.cat
KB123478.cat
KB123490.cat

[SetupHotfixesToRun]
Q308387.exe -q -n -z
Q123478.exe -q -n -z
Q123490.exe -q -n -z
  10. Ajoutez la section et l'entrée suivantes au fichier c:\OPKTools\lang\eng\sku\pro.sp2\x86\i386\Dosnet.inf :
    [OptionalSrcDirs]
svcpack

    Utilisez le dossier i386 pour votre préinstallation de cette version de Windows.

Préinstallation de correctifs à l'aide de l'Assistant Gestion d'installation et des jeux de configuration

Cette procédure est uniquement destinée aux fabricants d'ordinateurs OEM. Il est facile d'ajouter des correctifs sous la forme d'applications préinstallées à l'aide de l'Assistant Gestion d'installation. Ces correctifs seront inclus dans votre jeu de configuration lors de la préinstallation du système d'exploitation Windows.

Pour préinstaller des correctifs à l'aide de l'Assistant Gestion d'installation et des jeux de configuration

  1. Créez un dossier sur l'ordinateur du technicien destiné à contenir tous les correctifs que vous voulez installer.
  2. Copiez les correctifs dans ce dossier.
  3. Renommez le correctif en lui attribuant un nom de fichier adéquat au format 8.3 (le programme d'installation ne reconnaît pas les noms de fichiers longs). Par exemple :
    REN Q308387_WXP_SP2_X86_ENG.EXE Q308387.EXE
  4. Ouvrez l'Assistant Gestion d'installation et créez un jeu de configuration ou modifiez-en un existant.
  5. Dans la boîte de dialogue Applications préinstallées, cliquez sur le bouton Ajouter de chaque correctif à installer. La boîte de dialogue Ajouter une application s'affiche.
  6. Entrez une valeur pour Nom complet.

    Il s'agit du nom qui s'affiche lorsque l'application commence l'installation.

  7. Cliquez sur Parcourir et accédez au dossier créé à la première étape.
  8. Sélectionnez un correctif à installer en double-cliquant sur son nom de fichier.

    Le champ Commande d'installation indique le chemin d'accès réseau de l'ordinateur du technicien où se trouve le correctif, ainsi que le nom du correctif en question.

  9. Cliquez sur Arguments de la ligne de commande, puis tapez -q-n-z. Vérifiez qu'un espace sépare chaque option, puis cliquez sur OK.

    Les entrées sont créées automatiquement dans la section [OEMRunOnce] du fichier Winbom.ini.

  10. Répétez les étapes 5 à 10 pour tous les autres correctifs que vous voulez préinstaller.
  11. Lorsque l'ajout des correctifs est terminé, cliquez sur Suivant, puis suivez les étapes pour terminer l'Assistant Gestion d'installation.

Préinstallation de correctifs à l'aide d'un partage de distribution et d'un serveur

Cette procédure est destinée aux administrateurs informaticiens de l'entreprise. Les correctifs seront installés automatiquement à l'aide d'un fichier Unattend.txt modifié à partir de votre partage de distribution.

Pour préinstaller des correctifs à l'aide d'un partage de distribution et d'un serveur

  1. Accédez au partage de distribution et ouvrez le dossier i386.
  2. S'il n'existe pas encore de dossier $OEM$, créez-en un.
  3. Ouvrez le dossier $OEM$.
  4. Créez un dossier nommé $1.

    Le contenu du dossier $1 est copié à la racine du lecteur système, sur l'ordinateur de destination.

  5. Ouvrez le dossier $1.
  6. Créez un dossier nommé %HOTFIXES%.
  7. Ouvrez le dossier %HOTFIXES% et copiez-y tous les correctifs que vous voulez installer.
  8. Renommez chaque correctif en lui attribuant un nom de fichier adéquat au format 8.3 (le programme d'installation ne reconnaît pas les noms de fichiers longs). Par exemple :
    REN Q308387_WXP_SP2_X86_ENG.EXE Q308387.EXE
  9. À l'aide d'un éditeur de texte, créez un fichier de commandes nommé Install.bat dans le dossier %HOTFIXES%. Par exemple :
    @echo off
    %SYSTEMDRIVE%\Hotfixes\Q308387.exe -q -n -z
    %SYSTEMDRIVE%\Hotfixes\Q123457.exe -q -n -z

    Ce fichier de commandes répertorie chaque correctif à exécuter.

  10. À l'aide d'un éditeur de texte, créez un fichier Unattend.txt ou modifiez-en un existant, puis ajoutez les sections et entrées suivantes :
    [Unattended]
OEMPreinstall = Yes

[GuiRunOnce]
"%SYSTEMDRIVE%\Hotfixes\install.bat"
  11. Lorsque vous préinstallez Windows XP ou la famille Windows Server 2003 à l'aide du fichier Unattend.txt modifié à partir du partage de distribution, les correctifs sont automatiquement installés. Vous pouvez supprimer le dossier de correctif de l'ordinateur de destination avant de livrer l'ordinateur à l'utilisateur final.


Préinstallation du pack multilangue

Le pack multilangue (à interface utilisateur multilingue) est un ensemble de fichiers de ressources linguistiques que vous pouvez ajouter à la version anglaise de Windows. L'interface utilisateur multilingue (MUI) permet de changer la langue de l'interface utilisateur du système d'exploitation en fonction des préférences d'utilisateurs individuels en adoptant l'une des 33 langues prises en charge. Ceci permet aux grandes entreprises de déployer la même image dans le monde entier avec une seule installation. La langue de l'interface utilisateur peut ensuite être sélectionnée par les utilisateurs locaux ou être définie par une stratégie de groupe pour des unités d'organisation.

L'interface MUI permet également à des utilisateurs de langues différentes de partager la même station de travail ou à des utilisateurs itinérants de porter leur interface utilisateur localisée d'une station de travail à l'autre. Par exemple, tel utilisateur peut choisir de voir les menus système, les boîtes de dialogue et les autres textes en japonais, alors que tel autre utilisateur ouvrant une session sur le même système préférera les afficher en français.

Il existe deux manières de préinstaller l'interface MUI de Windows XP/2000 en mode silencieux :

  • dans le cadre de l'installation de base de Windows en anglais ;
  • après l'installation de base de Windows en anglais.

Préinstallation de l'interface MUI dans le cadre de l'installation de base de Windows en anglais

Dans la mesure où l'interface MUI est distribuée sur plusieurs CD-ROM, l'installation en mode silencieux doit utiliser un partage de distribution. Tous les fichiers MUI doivent être préalablement copiés dans le partage de distribution. La section [GUIRunOnce] du fichier Unattend.txt doit spécifier l'exécution de Muisetup.exe, le programme qui installe les langues de l'interface utilisateur. Enfin, vous devez exécuter Winnt32.exe en spécifiant certaines options pour garantir l'installation correcte des fichiers.

L'installation de l'interface MUI implique la configuration de groupes de langues, de paramètres régionaux (utilisateur, système et d'entrée) et de langues d'interface utilisateur. Pour que des paramètres régionaux et des langues d'interface utilisateur donnés soient installés correctement, vous devez installer les groupes de langues appropriés. Les paramètres régionaux que vous installez doivent être compatibles entre eux et correspondre à la langue d'interface utilisateur par défaut. Les combinaisons de groupe de langues, de paramètres régionaux et de langue d'interface utilisateur valides sont répertoriées dans [RegionalSettings].

Remarque

  • Si vous n'installez pas les groupes de langues nécessaires aux paramètres régionaux/langues et aux langues d'interface utilisateur que vous spécifiez, le programme d'installation peut afficher des boîtes de dialogue vous invitant à indiquer le chemin d'accès des fichiers requis. L'installation réussira, mais elle risque d'exiger des interventions de l'utilisateur.

Création du partage de distribution

L'installation en mode silencieux de l'interface MUI nécessite la copie de tous les fichiers de ressources linguistiques à partir des CD-ROM MUI vers un partage de distribution. Ces fichiers doivent être placés dans un répertoire temporaire situé sous le répertoire racine. Dans l'exemple, les fichiers sont contenus dans un répertoire temporaire nommé MUITEMP.

\source de l'installation
     \MUITEMP
        ...tous les fichiers multilingues

Durant la phase de copie de fichiers de l'installation, le répertoire MUITEMP est copié dans %WINDIR% sur le lecteur de distribution. À la fin de l'installation, ce répertoire temporaire est supprimé.

Création du fichier de réponses

Pour l'interface MUI, deux sections du fichier Unattend.txt jouent un rôle important : [RegionalSettings] et [GUIRunOnce].

La section [RegionalSettings] spécifie des valeurs pour le groupe de langues et les paramètres régionaux (utilisateur, système et d'entrée) à installer sur le système. Pour spécifier ces valeurs, vous utilisez les numéros d'identification appropriés.

Pour les systèmes à un seul utilisateur, il est recommandé d'affecter aux paramètres régionaux la même valeur que la langue d'interface utilisateur par défaut (spécifiée lors de l'exécution de Muisetup.exe). Par exemple, si l'allemand est défini comme langue d'interface utilisateur par défaut, un des paramètres régionaux allemands doit être spécifié.

Pour les stations de travail partagées et dans les environnements Terminal Server, il est recommandé de choisir l'anglais (la langue administrative de la version multilingue) pour la langue d'interface utilisateur par défaut et les paramètres régionaux du système. Les paramètres régionaux utilisateur peuvent être définis en fonction de préférences/contraintes individuelles ou, si l'entrée Language le spécifie, rester identique aux paramètres régionaux du système.

Le groupe de langues nécessaire aux paramètres régionaux que vous spécifiez doit être installé. Par exemple, si les paramètres régionaux ont pour valeur l'arabe et que l'arabe doit être la langue par défaut des menus et des boîtes de dialogue, le groupe de langues arabe doit être spécifié dans la section [RegionalSettings] :

[RegionalSettings]
LanguageGroup = 13
Language = 0401

— ou —

[RegionalSettings]
LanguageGroup = 13
SystemLocale = 0401
UserLocale = 0401
InputLocale = 0409:00000409,0401:00000401

La section [GUIRunOnce] contient une liste de commandes à exécuter lorsqu'un utilisateur ouvre pour la première fois une session sur l'ordinateur après une installation en mode graphique. Chaque ligne entre guillemets spécifie une commande qui doit être exécutée par l'entrée de Registre GuiRunOnce.

Utilisez cette section pour exécuter le programme Muisetup avec les paramètres et les valeurs appropriés. Notez que le chemin d'accès à Muisetup.exe inclut le répertoire temporaire créé dans la source de l'installation. La deuxième ligne de l'exemple d'entrée supprime ce répertoire temporaire du lecteur à la fin de l'installation :

[GuiRunOnce]
"%WINDIR%\MUITEMP\MUISETUP.exe [-i LangID LangID...] [-d LangID] -r -s"
"%WINDIR%\SYSTEM32\CMD.EXE /c RMDIR %WINDIR%\MUITEMP /s /q"

\MUITEMP est le dossier d'installation temporaire créé au cours de l'installation.

Options de la ligne de commande Muisetup

Option | Description
-i | Spécifie les langues d'interface utilisateur à installer. Les langues doivent être entrées sous la forme de valeurs LangID à quatre chiffres en hexadécimal.
-d | Spécifie la langue d'interface utilisateur par défaut (appliquée à tous les nouveaux comptes d'utilisateurs et utilisée par exemple dans l'écran d'ouverture de session Windows).
-r | Spécifie que le message de redémarrage n'est pas affiché.
-s | Spécifie que le message d'installation achevée n'est pas affiché.
-l | (Lettre L. Windows XP uniquement) Fait correspondre la langue des programmes non-Unicode à la langue utilisateur par défaut ; ce paramètre est ignoré, sauf si l'option /d est utilisée.
-f | (Windows XP uniquement) Fait correspondre la police d'interface utilisateur du shell par défaut à la langue utilisateur par défaut ; ce paramètre est ignoré, sauf si les options /d et /l sont utilisées. Applicable uniquement à l'interface utilisateur en langue japonaise.

Exécution de Winnt32.exe

La phase finale de l'installation de l'interface MUI en mode silencieux consiste à exécuter Winnt32.exe avec les options correctes.

Spécifiez Unattend.txt avec l'option /unattend. Utilisez l'option /copydir pour garantir que le répertoire d'installation temporaire (MUITEMP) est copié dans le lecteur de destination. Si les paramètres régionaux et les langues d'interface utilisateur que vous comptez installer requièrent l'installation de groupes de langues, utilisez l'option /copysource pour copier les fichiers de groupe de langues nécessaires. Si vous n'avez qu'un seul groupe de langues à copier, spécifiez lang\[nom_répertoire_de_langue].

Par exemple :
winnt32.exe /unattend: chemin_fichier_réponses
    /copysource:lang /copydir:MUITEMP /s:chemin_source_installation

Préinstallation de l'interface MUI après l'installation de base de Windows en anglais

Création du partage d'installation

L'installation en mode silencieux de l'interface MUI de Windows XP nécessite la copie de tous les fichiers à partir des CD-ROM MUI vers un partage de distribution. Ces fichiers doivent être placés dans un répertoire temporaire situé sous le répertoire $OEM$. Dans cet exemple, un serveur \\muicore est utilisé. Les répertoires correspondant au contenu des CD-ROM MUI sont les suivants :

\\muicore
     \unattend
        \$OEM$
          \muiinst

Créez le fichier Cmdlines.txt dans \\unattend\$OEM$ avec le texte suivant :

[Commands]
"muiinst\muisetup.exe [/i LangID1 LangID2 ...] [/d LangID] /r /s"

Vous devez utiliser des guillemets dans le fichier Cmdlines.txt. Utilisez les identificateurs de langue appropriés (LANGID) et les options de ligne de commande MUISetup pour garantir une installation en mode silencieux. Pour avoir une description complète de toutes les options de ligne de commande de Muisetup.exe, consultez la section précédente ou le fichier Muisetup.hlp.

Création du fichier de réponses

Pour l'interface MUI, deux sections du fichier Unattend.txt jouent un rôle important : [RegionalSettings] et [GUIRunOnce].

L'en-tête de section [Unattended] identifie qu'une installation en mode silencieux est en cours d'exécution et est obligatoire dans le fichier Unattend.txt. En l'absence de cet en-tête, le fichier de réponses est ignoré.

[Unattended]
    OemPreinstall = Yes
    OemFilesPath = \\muicore\unattend
    OemSkipEula = YES

La section [RegionalSettings] spécifie des valeurs pour le groupe de langues et les paramètres régionaux (utilisateur, système et d'entrée) à installer sur le système. Les valeurs sont spécifiées avec des numéros d'identification, tels ceux répertoriés dans [RegionalSettings].

Le groupe de langues nécessaire aux paramètres régionaux que vous spécifiez doit être installé. Par exemple, si les paramètres régionaux ont pour valeur l'arabe et que l'arabe doit être la langue par défaut des menus et des boîtes de dialogue, le groupe de langues arabe doit être spécifié dans la section [RegionalSettings] :

[RegionalSettings]
LanguageGroup = "5","8","13"
Language = "0401"

Exécution de Winnt32.exe

La phase finale de l'installation de l'interface MUI en mode silencieux consiste à exécuter Winnt32.exe avec les options correctes, comme dans l'exemple suivant :

winnt32.exe /unattend:chemin_fichier_réponses /copysource:lang /s:chemin_source_installation

Si l'installation de la prise en charge d'une langue et de paramètres régionaux d'Extrême-Orient est requise, vous devez spécifier /copysource:lang ou /rx:lang pour copier les fichiers linguistiques nécessaires. Si vous ne le faites pas alors que la section [RegionalSettings] de votre fichier de réponses contient des valeurs pour l'Extrême-Orient, le programme d'installation ignore la section [RegionalSettings].


Préinstallation de kits de langue LIP (Language Interface Pack)

Les kits de langue LIP (Language Interface Pack) pour Windows XP proposent une interface utilisateur localisée pour les marchés linguistiques émergents ou minoritaires. Un kit de langue LIP, qui se base sur la technologie de l'interface utilisateur multilingue, permet aux utilisateurs d'ordinateurs de bureau d'accéder à une interface localisée à environ 80 pour cent grâce à la traduction d'un jeu réduit d'éléments d'interface utilisateur. Un kit de langue LIP est installé sur une copie sous licence de Windows, avec une langue de base fixe. Pour plus d'informations, consultez le Forum Aux Questions sur les kits de langue LIP pour Microsoft® Windows® XP (http://www.microsoft.com/globaldev/).

Un kit de langue LIP pour Windows XP n'installe la prise en charge que d'une seule langue. Vous ne pouvez pas installer plusieurs langues à la fois. Pour installer un autre kit de langue LIP, vous devez tout d'abord désinstaller toute installation de kit de langue LIP existante.

Les kits de langue LIP sont actuellement disponibles dans les langues suivantes :

  • Bulgare
  • Catalan (basé sur Windows XP en espagnol)
  • Croate
  • Estonien
  • Hindi
  • Letton
  • Lituanien
  • Roumain
  • Serbe (cyrillique)
  • Serbe (latin)
  • Slovaque
  • Slovène
  • Thaï
  • Ukrainien (basé sur Windows XP en russe)

Sauf indication contraire, la langue de base des kits de langue LIP mentionnés ci-dessus est l'anglais.

Les kits de langue LIP ne peuvent être installés que sur les versions 32 bits de Windows XP, mais ils ne peuvent pas être installés sur un ordinateur sur lequel le pack multilingue Windows XP est installé ou l'a été précédemment.

Méthodes de préinstallation

Vous pouvez préinstaller tous les kits de langue LIP, à l'exception de ceux pour le slovaque et le slovène, en employant la même méthode. Pour plus d'informations sur la préinstallation des kits de langue LIP pour le slovaque et le slovène, consultez Préinstallation des kits de langue LIP pour le slovaque ou le slovène.

Pour préinstaller les kits de langue LIP

  1. Copiez l'intégralité du contenu du CD-ROM du kit de langue LIP dans un sous-répertoire de l'ordinateur du technicien. Par exemple, créez un dossier Updates sous le répertoire OPKTools. Sous le répertoire Updates, créez un dossier appelé LIP.
  2. Utilisez l'Assistant Gestion d'installation pour créer un jeu de configuration Windows XP Édition familiale ou Windows XP Professionnel ou pour en modifier un existant.
  3. Ajoutez les informations de ligne de commande suivantes à l'écran Préinstallation d'application de l'Assistant Gestion d'installation :
    Executable:  msiexec /i
\\server_name\\OpkTools\Updates\LIP\MUISETUP.EXE
Parameters: /q
Executable:  %WINDIR%\mui\fallback\LCID\profupd.exe
Parameters:  /l  LCID_value

Lorsque vous installez Windows XP Édition familiale ou Windows XP Professionnel sur un ordinateur de destination en utilisant ce jeu de configuration, le kit de langue LIP sera installé automatiquement en mode audit et sera activé lors du redémarrage suivant de l'ordinateur (démarrage Audit, Rescellage ou Usine).

Pour que l'installation réussisse, vous devez utiliser l'identificateur de paramètres régionaux (LCID) correct correspondant à la langue que vous installez. Les identificateurs LCID disponibles sont répertoriés dans le tableau suivant :

Identificateur LCID | Langue
0402 | Bulgare
0403 | Catalan
041a | Croate
0425 | Estonien
0439 | Hindi
0426 | Letton
0427 | Lituanien
0418 | Roumain
0c1a | Serbe (cyrillique)
081a | Serbe (latin)
041e | Thaï
0422 | Ukrainien

Cette méthode crée la section suivante dans le fichier Winbom.ini :

[OemRunOnce]
"PackageName1","msiexec /i \\server\\OpkTools\Updates\LIP\MUISETUP.EXE\LIPSetup.msi /q"
"PackageName2","c:\windows\mui\fallback\LCID_value\profupd.exe /l LCID_value"

Préinstallation des kits de langue LIP pour le slovaque ou le slovène

Pour préinstaller les kits de langue LIP pour le slovaque ou le slovène

  1. Copiez l'intégralité du contenu du CD-ROM du kit de langue LIP dans un sous-répertoire de l'ordinateur du technicien. Par exemple, créez un dossier Updates sous le répertoire OPKTools. Sous le répertoire Updates, créez un dossier appelé LIP.
  2. Utilisez l'Assistant Gestion d'installation pour créer un jeu de configuration Windows XP Édition familiale ou Windows XP Professionnel ou pour en modifier un existant.
  3. Ajoutez les informations de ligne de commande suivantes dans l'écran Préinstallation d'application de l'Assistant Gestion d'installation :
    Executable:  msiexec /i
\\server_name\\OpkTools\Updates\LIP\MUISETUP.EXE
Parameters: /l  LCID_value /s /r

Lorsque vous installez Windows XP Édition familiale ou Windows XP Professionnel sur un ordinateur de destination en utilisant ce jeu de configuration, le kit de langue LIP sera installé automatiquement en mode audit et sera activé lors du redémarrage suivant de l'ordinateur (démarrage Audit, Rescellage ou Usine).

Pour que l'installation réussisse, vous devez utiliser l'identificateur LCID correct correspondant à la langue que vous installez. Les identificateurs LCID disponibles sont répertoriés dans le tableau suivant :

Identificateur LCID | Langue
0424 | Slovène
041b | Slovaque

Cette méthode crée la section suivante dans le fichier Winbom.ini :

[OemRunOnce]
"PackageName1","msiexec /i \\server_name\\OpkTools\Updates\LIP\MUISETUP.EXE /l  LCID_value /s /r "


Préinstallation des périphériques matériels

Vous pouvez préinstaller des périphériques matériels et notamment :

  • Périphériques de stockage de masse
  • Périphériques Plug-and-Play

Autres rubriques dans cette section :

  • Utilisation de pilotes signés
  • Mode de sélection d'un pilote de périphérique particulier par Windows
  • Détection du mode vidéo correct pour les écrans d'ordinateurs portables
  • Affichage des périphériques cachés
  • Réduction du nombre d'images principales pour les ordinateurs avec des contrôleurs de stockage de masse différents
  • Réduction du nombre d'images principales pour les ordinateurs avec plusieurs processeurs

Pour obtenir les dernières informations sur les développements nécessaires au fonctionnement des périphériques matériels sur les ordinateurs qui exécutent Microsoft® Windows®, consultez le site Web central pour le matériel et les pilotes Windows (http://www.microsoft.com/whdc/).


Utilisation de pilotes signés

Microsoft contribue à promouvoir la signature des pilotes pour des classes de périphériques conçues à la manière d'un mécanisme permettant d'améliorer la qualité des pilotes, de faciliter le travail des utilisateurs finals et de réduire aussi bien le coût du support technique pour les fournisseurs que le coût total de possession pour les clients.

Les pilotes signés sont des pilotes auxquels sont associées des signatures numériques. L'utilisation de signatures numériques pour les pilotes Windows permet au système d'exploitation de vérifier l'intégrité de tous les fichiers d'un pilote. Le pilote copie un fichier catalogue (.cat) signé numériquement, fourni par Microsoft, qui contient un enregistrement de chaque fichier composant le pilote. La signature de pilote (parfois appelée signature du code) inclut les composants suivants :

  • un fichier catalogue (.cat) qui fait partie du pilote et qui contient une signature numérique émise par le laboratoire de qualité du matériel Windows (WHQL, Windows Hardware Quality Labs) ;
  • un fichier .inf qui contient une référence au fichier catalogue ;
  • un pilote qui a passé les tests du programme de logo Windows ;
  • les paramètres de stratégie du système d'exploitation qui vérifient si un pilote non signé peut être installé.

Pour recevoir un fichier catalogue signé numériquement, tous les pilotes doivent répondre aux critères des tests définis par Microsoft pour le périphérique concerné et administrés par le laboratoire WHQL. Pour plus d'informations sur les pilotes signés, consultez le site Web central pour le matériel et les pilotes Windows (http://www.microsoft.com/whdc/).

Si vous avez l'intention d'utiliser des pilotes mis à jour, vous devez d'abord vérifier qu'ils portent une signature valide. Si ce n'est pas le cas, le choix du pilote à installer dépend de deux facteurs :

  • la stratégie de signature que vous indiquez dans votre fichier de réponses ;
  • la disponibilité d'un pilote signé compatible qui est livré avec le système d'exploitation.

Test des pilotes non signés

Si un fabricant vous a envoyé un pilote qui n'est pas encore signé et qui remplace un pilote Windows XP à des fins de test, le programme d'installation de Windows sélectionne le pilote qui a été livré avec Windows XP, et non le pilote non signé. Pour plus d'informations sur le programme d'installation de Windows et sur les pilotes, consultez Mode de sélection d'un pilote de périphérique particulier par Windows.

Important

  • Tous les pilotes installés sur le système livré au client doivent être signés. Les pilotes présentés aux tests du programme de logo Microsoft Windows en vue de l'obtention d'une signature doivent être conformes au cahier des charges défini dans le livre blanc Driver Signing for Windows (http://www.microsoft.com/windowsxp/home/using/productdoc/en/default.asp?url=/windowsxp/home/using/productdoc/en/code_signing.asp) disponible sur le site Web Windows Hardware and Driver Central (http://www.microsoft.com/whdc/).

Pour installer des pilotes non signés lors de l'exécution de Sysprep, insérez les lignes suivantes dans le fichier Sysprep.inf :

[Unattended]
UpdateInstalledDrivers = Yes

L'entrée DriverSigningPolicy dans la section [Unattended] spécifie la façon dont les pilotes non signés sont traités pendant l'installation sans assistance. Vous pouvez définir DriverSigningPolicy = Ignore, mais uniquement à des fins de test. Pour les ordinateurs que vous fabriquez, vous devez utiliser la valeur par défaut (DriverSigningPolicy = Warn) ou la stratégie de signature supérieure (DriverSigningPolicy = Block) pour garantir que les utilisateurs téléchargeant des pilotes non signés (nouveaux ou mis à jour) seront prévenus des problèmes potentiels qu'ils encourent.

Une fois l'exécution de Sysprep terminée, l'entrée DriverSigningPolicy prend automatiquement la valeur Warn, sauf si Sysprep.inf contient l'entrée DriverSigningPolicy = Block.

Remarque

  • Un fichier .cat permet d'authentifier la signature d'un pilote. Microsoft utilise des certificats pour signer des pilotes sur une durée limitée qui est généralement de six mois. Toutefois, pour autant que le pilote porte une signature numérique associée à un certificat valide, la date d'expiration du certificat n'a aucune influence sur l'état du pilote. La signature d'un pilote n'expire jamais, même lorsque la date du certificat utilisé pour signer le pilote a expiré.

Préinstallation de pilotes signés

Une fois le pilote signé, ses fichiers (y compris les fichiers .inf) ne peuvent plus être modifiés. Toute modification de fichiers d'un pilote annule la signature numérique de ce pilote.

Les conditions suivantes sont requises lors de la préinstallation de pilotes signés :

  • Tous les fichiers nécessaires doivent être placés dans le répertoire de préinstallation décrit dans Préinstallation de périphériques Plug-and-Play.
  • Le pilote doit être installé en utilisant un fichier .inf.
  • Le pilote doit avoir passé les tests du programme de logo Windows et reçu du laboratoire WHQL une signature numérique.
  • Le fichier .inf ne doit contenir aucune erreur en matière de signature numérique.
  • Le pilote ne doit pas inclure de fichiers provenant de Microsoft.

Vérification des signatures de fichiers

Pour rechercher les signatures, utilisez l'outil de vérification de signature Sigverif.exe inclus dans Windows. Par défaut, cet outil analyse un jeu prédéfini de fichiers système répertoriés dans Corelist.inf, tous les pilotes dont dispose le Gestionnaire de périphériques ainsi que tous les pilotes d'imprimante installés. Vous pouvez aussi utiliser cet outil pour analyser des fichiers signés individuellement. Testez avec Sigverif chaque image préinstallée en usine que vous produisez et identifiez les fichiers .sys ou .drv non signés.

Pour exécuter Sigverif, cliquez sur le bouton Démarrer, cliquez sur Exécuter, puis tapez sigverif.

Pour vérifier les propriétés d'un pilote après l'installation, affichez l'onglet Propriétés du pilote du Gestionnaire de périphériques sur un ordinateur de test.

Validation et débogage des signatures de pilotes de périphérique

Vous pouvez utiliser Setupapi.log, situé dans le répertoire %SYSTEMROOT%, pour déterminer les points d'échec lors de l'installation et de la vérification de la signature d'un pilote. Pour obtenir un enregistrement propre du code que Windows utilise pour installer un pilote et vérifier sa signature, supprimez le journal avant d'installer le pilote.

Activez l'enregistrement documenté dans le journal Setupapi en ajoutant la valeur LogLevel à la clé de Registre suivante :

HKEY_Local_Machine\Software\Microsoft\Windows\CurrentVersion\Setup

DWORD LogLevel
Data = FFFF

Redémarrez le système, installez le pilote que vous souhaitez tester et ouvrez le fichier Setupapi.log. L'état de chaque composant individuel du pilote, assorti d'une mention précisant s'il est signé correctement, est décrit en détail.

Pour plus d'informations, consultez le livre blanc Driver Signing for Windows (http://www.microsoft.com/windowsxp/home/using/productdoc/en/default.asp?url=/windowsxp/home/using/productdoc/en/code_signing.asp) disponible sur le site Web Windows Hardware and Driver Central (http://www.microsoft.com/whdc/).


Préinstallation de pilotes de stockage de masse

La technologie Plug-and-Play permet d'installer la plupart des pilotes de matériel que vous pouvez charger ultérieurement au cours du processus d'installation. Toutefois, les pilotes de stockage de masse, tels que les pilotes des contrôleurs de disque dur, doivent être installés convenablement pour permettre une prise en charge Plug-and-Play parfaite au cours de l'installation en mode graphique. C'est pourquoi leur installation est gérée différemment de celle des autres pilotes de matériel.

Lorsque la section [MassStorageDrivers] est utilisée dans Unattend.txt, les pilotes de stockage de masse disponibles ne sont pas installés pendant l'exécution du programme d'installation en mode texte, sauf si vous les spécifiez dans cette section. Si cette section est absente ou vide, le programme d'installation tente de détecter les périphériques sur l'ordinateur et d'installer les pilotes disponibles correspondants.

Pour préinstaller un pilote de stockage de masse au cours de l'installation en mode texte, avant qu'une prise en charge Plug-and-Play complète ne soit disponible, vous devez fournir un fichier Txtsetup.oem décrivant comment le programme d'installation doit installer le pilote en question.

Pour plus d'informations sur Txtsetup.oem, consultez le Kit de développement de pilotes Microsoft Windows (DDK, Driver Development Kit), que vous pouvez commander à partir du site Web Microsoft DDK (http://www.microsoft.com/ddk/). Vous pouvez également lire la documentation du Kit de développement de pilotes dans MSDN Library (http://msdn.microsoft.com/library/) : Sélectionnez Windows Development, puis Driver Development Kit.

Pour préinstaller un périphérique de stockage de masse

  1. Dans le sous-dossier \$OEM$ du jeu de configuration, créez le sous-dossier \Textmode.
  2. Copiez les fichiers des disquettes fournies par le fabricant du périphérique vers le dossier \Textmode. Il s'agit normalement des fichiers suivants :
    • Pilote.sys
    • Pilote.dll
    • Pilote.inf
    • Pilote.cat
    • Txtsetup.oem

    où Pilote désigne le nom du pilote.

    Remarques

    • Vous devez également copier les fichiers du pilote vers l'emplacement que vous avez spécifié dans l'entrée OemPnPDriversPath des fichiers de réponses. Par exemple :
      OemPnPDriversPath = drivers\storage
    • Certains pilotes ne comprennent pas de fichier .dll, notamment les pilotes de miniport SCSI.
    • Un fichier catalogue (Pilote.cat) doit accompagner les pilotes de périphérique de stockage de masse s'il est mentionné dans le fichier Txtsetup.oem.

      Pour plus d'informations sur les fichiers catalogue, consultez Utilisation de pilotes signés. Consultez également le Kit de développement de pilotes Microsoft Windows (DDK, Driver Development Kit), disponible dans MSDN Library (http://msdn.microsoft.com/library/) : Sélectionnez Windows Development, puis Driver Development Kit.

  3. Dans le fichier Unattend.txt, créez une section [MassStorageDrivers] et tapez dans cette section les entrées relatives aux pilotes. La section [MassStorageDrivers] peut par exemple contenir l'entrée :
    "Adaptec 2940..." = "OEM"

    Les informations à placer dans cette section sont disponibles dans la section [SCSI] du fichier Txtsetup.oem fourni par le fabricant du matériel.

    Remarque

    • Utilisez toujours des pilotes signés. Les pilotes non signés ne sont pas installés durant une installation sans assistance.
  4. Dans le fichier Unattend.txt, créez une section [OEMBootFiles] et tapez dans cette section la liste des fichiers du dossier \$OEM$\Textmode. Par exemple :
    [OEMBootFiles]
Pilote.sys
Pilote.dll
Pilote.inf
Pilote.cat
Txtsetup.oem

    où Pilote désigne le nom du pilote.

    Important

    • N'ajoutez des entrées de pilote que dans les sections [MassStorageDrivers] et [OEMBootFiles] relatives aux périphériques de stockage de masse démarrables. N'incluez pas de périphériques de stockage de masse secondaires. Au lieu de cela, ajoutez les pilotes des périphériques de stockage de masse secondaires dans le dossier spécifié par l'entrée OemPnPDriversPath de votre fichier de réponses d'installation sans assistance. La déclaration de pilotes pour des périphériques de stockage de masse non démarrables dans les sections [MassStorageDrivers] ou [OEMBootFiles] provoque une erreur lors de l'installation.
  5. Si votre périphérique de stockage de masse est un périphérique Plug-and-Play, vérifiez qu'une section Hardware Identification et que le nom du fichier catalogue du pilote (Pilote.cat) existent dans le fichier Txtsetup.oem. Pour plus d'informations, consultez le Kit de développement de pilotes Microsoft Windows (DDK, Driver Development Kit), disponible dans MSDN Library (http://msdn.microsoft.com/library/) : Sélectionnez Windows Development, puis Driver Development Kit.

Si la section Hardware Identification n'existe pas, vous devez ajouter la section [HardwareIds.scsi.yyyyy] dans le fichier Txtsetup.oem et vérifier que les informations suivantes y figurent :

id = "xxxxx" , "yyyyy"

où xxxxx représente l'ID du périphérique et yyyyy, le service associé à ce périphérique.

Par exemple, pour préinstaller le pilote Symc810, dont l'ID de périphérique est PCI\VEN_1000&DEV_0001, vérifiez que votre fichier Txtsetup.oem contient la section supplémentaire suivante :

[HardwareIds.scsi.symc810]
id = "PCI\VEN_1000&DEV_0001","symc810"

Vous devez supprimer du fichier Txtsetup.oem les références à des lecteurs et des chemins d'accès. Par exemple, au lieu du texte ci-dessous, utilisez les exemples qui suivent pour NTFS ou FAT32 :

[disks]
d1 = "Windows XP Driver Set v1.00", \w2kdsk1, \win2000\smy810\

Pour les installations NTFS, utilisez le texte suivant :

[disks]
d1 = "Windows XP Driver Set v1.00", \w2kdsk1, \

Notez la présence de la barre oblique à la fin de la ligne.

Pour les installations FAT32, utilisez le texte suivant :

[disks]
d1 = "Windows XP Driver Set v1.00", w2kdsk1, .

Notez l'absence de barre oblique inverse, mais la présence d'un point à la fin de la ligne.

Sélection et chargement du pilote de stockage de masse adéquat

Si vous incluez des pilotes mis à jour ou nouveaux pour des périphériques de stockage de masse, vous devez ajouter le nouveau pilote aux deux dossiers suivants :

  • \$OEM$\Textmode
  • L'emplacement spécifié dans l'entrée OemPnPDriversPath du fichier Unattend.txt.

    Par exemple : \$OEM$\$1\PilotPnP\stockage

Chargement des pilotes de stockage de masse au cours de l'installation en mode texte

Si le pilote du périphérique de stockage de masse est inclus dans Windows XP, le pilote de Windows XP est sélectionné avant tous les autres pilotes dans \$OEM$\Textmode.

Le pilote que vous placez dans \$OEM$\Textmode est le premier pilote sélectionné lors de l'installation en mode texte uniquement si :

  • Le pilote livré avec Windows XP ne démarre pas.
  • Le pilote n'est pas livré avec Windows XP.

Chargement des pilotes de stockage de masse au cours de l'installation en mode graphique

Windows XP charge un pilote nouveau ou mis à jour au cours de l'installation en mode graphique dans les cas suivants :

Vous chargez la mise à jour d'un pilote de périphérique de stockage de masse fourni avec Windows XP :

  • Le pilote de stockage de masse correct est fourni à l'emplacement spécifié par l'entrée OemPnPDriversPath.
  • Le pilote est signé et il provient d'une version plus récente que celle fournie avec Windows XP.

Vous chargez un nouveau pilote de périphérique de stockage de masse qui n'était pas fourni avec Windows XP :

  • Le pilote est nouveau (non fourni avec Windows XP), signé et s'installe correctement lors de l'installation en mode texte.

Pour plus d'informations sur la façon dont Windows sélectionne le pilote le plus approprié lors de la phase de détection Plug-and-Play, consultez Mode de sélection d'un pilote de périphérique particulier par Windows.

Pour plus d'informations sur la gestion des images des systèmes d'exploitation qui contiennent des pilotes de stockage de masse différents, consultez Réduction du nombre d'images principales pour les ordinateurs dotés de contrôleurs de stockage de masse différents.

Remarque

  • Lorsque vous exécutez Sysprep -reseal ou Sysprep -factory, Sysprep lit la section [SysprepMassStorage] du fichier Sysprep.inf et écrit les informations relatives au stockage de masse dans le Registre avant l'arrêt. Lorsque vous redémarrez l'ordinateur, tous les contrôleurs de stockage de masse sont disponibles.


Préinstallation de périphériques Plug-and-Play

Pour améliorer les conditions dans lesquelles l'utilisateur final travaille et réduire les délais de démarrage de l'ordinateur au premier démarrage, vous pouvez inclure des pilotes de périphérique Plug-and-Play supplémentaires dans votre installation principale. Si, à ce stade de votre cycle de production, vous ne souhaitez apporter aucune modification à votre installation principale, vous pouvez utiliser Sysprep pour installer des pilotes de périphérique Plug-and-Play supplémentaires avant de livrer l'ordinateur à votre client.

Préinstallation de périphériques Plug-and-Play pendant une installation sans assistance

Au cours d'une installation sans assistance, vous pouvez facilement préinstaller des périphériques Plug-and-Play qui ne sont pas des périphériques de stockage de masse et qui ne sont pas inclus dans le CD-ROM produit de Windows.

Pour préinstaller des périphériques Plug-and-Play

  1. Dans le sous-dossier \$OEM$ du jeu de configuration, créez un sous-dossier pour y placer les pilotes Plug-and-Play spéciaux ainsi que leurs fichiers .cat et .inf. Par exemple :
    $OEM$\$1\PilotPnP
  2. Dans le fichier Unattend.txt, ajoutez l'entrée OEMPnPDriversPath dans la section [Unattended]. Par exemple :
    OEMPnPDriversPath = "PnPDrvrs"

S'il y a des sous-dossiers dans le dossier qui contient les pilotes, vous devez spécifier le chemin d'accès de chaque sous-dossier. Séparez les chemins par un point-virgule. Par exemple, si le dossier \PilotPnP comporte les sous-dossiers \Net et \Audio, ajoutez la ligne suivante dans le fichier Unattend.txt :

OEMPnPDriversPath = "PnPDrvrs\Net;PnPDrvrs\Audio"

Remarques

  • Le programme d'installation crée le dossier spécifié à la racine du disque système et l'y laisse une fois l'installation terminée.
  • Au lieu de cela, pour éviter que les utilisateurs finals ne suppriment par inadvertance des dossiers de pilotes situés à la racine du disque, vous pouvez placer les pilotes dans un sous-dossier de \$OEM$\$$ (exemple : $OEM$\$$\PnP\Audio).

Pour plus d'informations, consultez Mode de sélection d'un pilote de périphérique particulier par Windows.

Préinstallation de périphériques Plug-and-Play avec Sysprep

Pour ajouter d'autres chemins d'accès en dehors de ceux qui existent pour l'image principale, vous pouvez inclure l'entrée OemPnPDriversPath dans le fichier Sysprep.inf pour spécifier un ou plusieurs autres chemins d'accès aux pilotes. Chaque chemin d'accès doit pointer vers un dossier qui contient tous les fichiers nécessaires à l'installation des périphériques spécifiques : fichiers catalogues, fichiers .inf et pilotes.

Lorsqu'un ordinateur dupliqué à l'aide de Sysprep démarre la première fois, il détecte tout le matériel. Si un périphérique matériel est trouvé alors qu'aucun pilote correspondant n'existe dans le fichier drivers.cab par défaut, l'ordinateur vérifie l'emplacement spécifié dans OemPnPDriversPath. Si les pilotes ne se trouvent pas à cet emplacement, l'utilisateur est alors invité à indiquer leur emplacement.

Vous pouvez aussi préinstaller des périphériques Plug-and-Play en utilisant Sysprep -factory et le fichier Winbom.ini. Pour plus d'informations, consultez Utilisation de Sysprep et [PnPDrivers] dans le fichier Winbom.ini.


Mode de sélection d'un pilote de périphérique particulier par Windows

Pour déterminer quel pilote convient le mieux pour un périphérique donné, Windows XP attribue des rangs aux pilotes et choisit le pilote dont le rang est le plus bas. Moins le rang est élevé, plus le pilote est adapté au périphérique. Si plusieurs pilotes ont le même rang, Windows choisit celui dont la date est la plus récente.

Pour déterminer le rang d'un pilote, Windows XP recherche une signature et compare les ID matériels ( ID) et les ID compatibles du périphérique aux ID répertoriés dans la section [Models] du fichier .inf. La meilleure solution, pour un périphérique donné, est un pilote signé auquel correspond un ID matériel figurant en premier choix dans le périphérique. Lorsque les pilotes sont signés, leur rang offre toujours une meilleure correspondance.

D'une façon générale, il n'est pas important de connaître le numéro de rang exact du périphérique car l'algorithme qui le détermine peut changer dans les versions ultérieures. En revanche, il est important de savoir que plus ce rang est bas, plus le pilote est adapté au périphérique. Un pilote de rang 0 constitue la solution idéale.

Les systèmes de classement des pilotes de Windows 2000 et Windows XP sont différents. Le système de classement des pilotes détermine quel pilote charger lorsque plusieurs pilotes sont disponibles pour un périphérique. Les pilotes sont classés en fonction de critères tels que le fait qu'ils soient signés ou non et le niveau de correspondance avec l'ID matériel du périphérique. Les listes suivantes récapitulent les systèmes de classement des pilotes pour Windows 2000 et Windows XP, dans l'ordre décroissant de classement :

Système de classement des pilotes de Windows 2000 :

  1. Pilote signé dont l'ID matériel présente une correspondance parfaite (les quatre parties sont identiques) avec celui du pilote
  2. Pilote non signé dont l'ID matériel présente une correspondance parfaite (les quatre parties sont identiques) avec celui du pilote
  3. Pilote signé dont l'ID matériel présente une correspondance partielle (deux parties sont identiques) avec celui du pilote
  4. Pilote non signé dont l'ID matériel présente une correspondance partielle (deux parties sont identiques) avec celui du pilote

Système de classement des pilotes de Windows XP :

  1. Pilote signé dont l'ID matériel présente une correspondance parfaite (les quatre parties sont identiques) avec celui du pilote
  2. Pilote signé dont l'ID matériel présente une correspondance partielle (deux parties sont identiques) avec celui du pilote
  3. Pilote non signé dont l'ID matériel présente une correspondance parfaite (les quatre parties sont identiques) avec celui du pilote (avec une section INF décorée de mentions NT)
  4. Pilote non signé dont l'ID matériel présente une correspondance partielle (les deux parties sont identiques) avec celui du pilote (avec une section INF décorée de mentions NT)
  5. Pilote non signé dont l'ID matériel présente une correspondance parfaite (les quatre parties sont identiques) avec celui du pilote (avec une section INF non décorée)
  6. Pilote non signé dont l'ID matériel présente une correspondance partielle (deux parties sont identiques) avec celui du pilote (avec une section INF non décorée)

Si plusieurs pilotes ont le même rang, Windows XP compare les dates qui figurent dans l'entrée DriverVer du fichier .inf.

Pour plus d'informations sur les méthodes employées par Windows XP pour classer les pilotes, consultez le site Web central pour le matériel et les pilotes Windows (http://www.microsoft.com/whdc/) ou le Kit de développement de pilotes Microsoft (DDK, Driver Development Kit). Vous pouvez commander le Kit de développement de pilotes (DDK) à partir du site Web Microsoft DDK (http://www.microsoft.com/ddk/). Vous pouvez également lire la documentation du Kit de développement de pilotes dans MSDN Library (http://msdn.microsoft.com/library/) : sélectionnez Windows Development, puis Driver Development Kit.

Utilisation de Setupapi.log pour résoudre les problèmes de sélection des pilotes

Si vous installez un pilote Windows XP mis à jour pour un périphérique et constatez que ce nouveau pilote n'est pas utilisé une fois l'installation de Windows terminée, vous devez effectuer les vérifications suivantes :

  • Vérifiez que le pilote porte une signature valide. Pour plus d'informations sur les signatures de pilotes, consultez Signatures de pilotes.
  • Vérifiez le rang du nouveau pilote.
  • Vérifiez dans le journal Setupapi.log les informations concernant la manière dont Windows traite le pilote. Pour afficher le fichier Setupapi.log, utilisez le chemin d'accès %WINDIR%\Setupapi.log.

Pour plus d'informations sur Setupapi.log, consultez le Kit de développement de pilotes de Microsoft ou le site Web central pour le matériel et les pilotes Windows à l'adresse suivante : http://www.microsoft.com/whdc/hwdev/driver/setup/SetupAPI.mspx.

Augmentation du niveau de détail du journal Setupapi.log

Si vous avez besoin d'informations plus détaillées que celles fournies par le journal Setupapi.log dans sa configuration par défaut pour faire le diagnostic des problèmes de sélection des pilotes, vous pouvez augmenter le niveau de détail de l'enregistrement dans le journal (c'est-à-dire augmenter la quantité d'informations fournie par le journal) à l'aide des procédures suivantes :

Pour augmenter le niveau de détail de Setupapi.log en modifiant le Registre

Pour définir le niveau de journalisation détaillée, ajoutez une valeur à la clé de Registre suivante :

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Setup

Nom de la valeur : LogLevel
Type de donnée : REG_DWORD
Valeur : 0xFFFF

Vous devez ajouter cette valeur avant que la phase d'installation en mode graphique ne commence (juste après la fin de l'installation en mode texte). Ou bien, vous pouvez faire ajouter cette valeur automatiquement par le programme d'installation en suivant la procédure ci-dessous.

Cette méthode exige que vous modifiiez les fichiers d'installation de Windows XP. Si vous n'avez pas encore de partage de distribution sur un serveur réseau, vous devez copier le dossier \I386 à partir du CD-ROM du produit Windows XP vers un disque dur local. Faites une copie de sauvegarde du fichier Hivesft.inf avant de continuer.

Pour augmenter le niveau de détail de Setupapi.log en modifiant Hivesft.inf

  1. Sur le partage de distribution ou le disque dur local contenant les fichiers de Windows XP, recherchez le fichier Hivesft.inf dans le dossier \I386.
  2. À l'aide d'un éditeur de texte (comme le Bloc-notes), recherchez la ligne suivante dans le fichier Hivesft.inf :
    HKLM,"SOFTWARE\Microsoft\Windows\CurrentVersion\Setup","DriverCachePath",0x00020002,"%SYSTEMROOT%\Driver Cache"
  3. Après la ligne reproduite ci-dessus, ajoutez la ligne suivante :
    HKLM,"SOFTWARE\Microsoft\Windows\CurrentVersion\Setup","LogLevel",0x00010003,0x0000FFFF

    Ces deux lignes peuvent s'afficher avec des retours à la ligne pour des raisons de lisibilité, mais chacune d'elles constitue une ligne distincte et une seule.

  4. Lorsque vous avez terminé, le fichier doit présenter l'aspect montré dans l'exemple suivant. Vérifiez-le avant d'enregistrer le fichier sur le disque :
    HKLM,"SOFTWARE\Microsoft\Windows\CurrentVersion\Setup","DriverCachePath",0x00020002,"%SYSTEMROOT%\Driver Cache"
    HKLM,"SOFTWARE\Microsoft\Windows\CurrentVersion\Setup","LogLevel",0x00010003,0x0000FFFF
    HKLM,"SOFTWARE\Microsoft\Windows\CurrentVersion\Setup\BaseWinOptions",,0x00000012

    Enregistrez le fichier et fermez l'éditeur de texte.

Toute installation initiée à partir de ce partage s'effectuera avec l'option de journalisation détaillée activée dans le fichier Setupapi.log. Vous pouvez vérifier que l'option est activée lors de l'exécution du programme d'installation en mode graphique : à cet effet, appuyez sur MAJ+F10 pour ouvrir une invite de commandes et utilisez Regedit.exe pour vérifier que la valeur du Registre a bien été créée.

Remarques

  • Pour afficher le journal Setupapi.log et voir comment Windows a détecté et installé les pilotes de périphériques, accédez à %WINDIR%\Setupapi.log.
  • Pour plus d'informations sur la préinstallation des périphériques Plug-and-Play, consultez Préinstallation de périphériques Plug-and-Play.


Détection du mode vidéo correct pour les écrans d'ordinateurs portables

Pour vous assurer que le programme d'installation détecte correctement le mode vidéo, vérifiez que :

  • Votre BIOS prend en charge l'ensemble des extensions ACPI vidéo.
  • Les pilotes des cartes vidéo et des écrans sont inclus dans le chemin \$1\PilotPnP.

Important

  • Ajoutez le chemin d'accès PilotPnP dans l'entrée OemPnPDriversPath du fichier Unattend.txt.

Si vous voulez que le programme d'installation détecte la résolution de l'écran de l'ordinateur portable automatiquement (une fois les éléments précédents correctement traités), spécifiez les paramètres optimaux dans la section [Display] du fichier Unattend.txt.

Pour permettre aux polices écran ClearType d'améliorer la lisibilité pour l'utilisateur final, dans la section [ComputerSettings] du fichier Winbom.ini, affectez à l'entrée FontSmoothing la valeur On.

Pour obtenir les dernières informations sur les périphériques matériels fonctionnant avec Windows XP, consultez le site Web central pour le matériel et les pilotes Windows (http://www.microsoft.com/whdc/).


Affichage des périphériques cachés

Au cours de la préinstallation, vous pouvez créer une installation principale qui inclut tous les périphériques Plug-and-Play que vous pouvez fournir à un utilisateur final. Dans Windows XP, le Gestionnaire de périphériques affiche seulement les périphériques qui sont présents sur un ordinateur livré, et non tous les périphériques qui figurent dans le fichier d'installation principale.

La procédure suivante permet à un représentant du service de support technique ou à un ingénieur de commander au Gestionnaire de périphériques d'afficher les périphériques qui se trouvaient sur l'ordinateur principal.

Pour afficher les périphériques cachés

  1. Cliquez sur Démarrer, puis sur Panneau de configuration.
  2. Double-cliquez sur Système.
  3. Sous l'onglet Avancé, cliquez sur Variables d'environnement.
  4. Sous Variables système, cliquez sur Nouveau.
  5. Dans le champ Nom de la variable, tapez
    DEVMGR_SHOW_NONPRESENT_DEVICES
  6. Dans le champ Valeur de la variable, tapez Vrai.

    Remarque

    • Vous pouvez entrer dans ce champ n'importe quelle valeur différente de zéro.
  7. Cliquez deux fois sur OK.
  8. Dans la fenêtre Propriétés système, cliquez sur l'onglet Matériel, puis sur Gestionnaire de périphériques.
  9. Dans le menu Affichage, sélectionnez Afficher les périphériques cachés.

Remarque

  • Chaque fois que vous accédez au Gestionnaire de périphériques, vous devez resélectionner l'option Afficher les périphériques cachés pour visualiser les périphériques cachés.

Pour plus d'informations, consultez Mode de sélection d'un pilote de périphérique particulier par Windows.

Suppression des périphériques fantômes

Pour supprimer les références à des périphériques qui étaient présents dans l'ordinateur principal, exécutez Sysprep -clean. Pour que la commande fonctionne, le fichier Sysprep.inf doit contenir une section [Cleanup] valide. Lorsque vous l'exécutez, cette commande efface les pilotes de stockage de masse inutilisés ajoutés par la section [SysprepMassStorage] du fichier Sysprep.inf et supprime les références aux périphériques fantômes créés par la fonctionnalité Plug-and-Play. Si elles ne sont pas effacées, ces entrées peuvent causer des problèmes lorsque vous tentez d'installer de nouveaux périphériques. Sysprep -clean supprime tous les périphériques fantômes, excepté :

  1. HTREE\ROOT\0 (la racine de l'arborescence Plug-and-Play)
  2. Les périphériques SWENUM (périphériques, énumérés par le logiciel, qui ne reposent sur aucun matériel).

    Comme ces périphériques ne sont pas installés en détectant la présence d'un matériel, il vaut mieux ne pas les supprimer.

  3. Les devnodes hérités (devnodes créés par la présence de services hérités).

Remarque

  • Si vous exécutez Sysprep -factory alors que la section [SysprepMassStorage] existe déjà dans votre fichier Sysprep.inf, Sysprep -reseal nettoie automatiquement le Gestionnaire de périphériques. (En d'autres termes, Sysprep supprime les références à des périphériques qui ne sont plus présents.) Vous économisez ainsi l'étape supplémentaire consistant à exécuter Sysprep -clean dans le fichier Cmdlines.txt.


Réduction du nombre d'images principales pour les ordinateurs dotés de contrôleurs de stockage de masse différents

bannière

Réduction du nombre d'images principales pour les ordinateurs avec des contrôleurs de stockage de masse différents

Sysprep exige que le contrôleur de stockage de masse de l'installation principale soit identique aux contrôleurs des ordinateurs de destination.

Si vous utilisez des images dans le cadre de votre processus de déploiement, vous pouvez réduire le nombre des images à gérer en créant une image principale pour l'installation de Windows sur les ordinateurs de destination qui peuvent utiliser des contrôleurs de stockage de masse différents, comme cela est décrit dans les scénarios suivants :

Contrôleur utilisé pour créer l'installation principale | Contrôleur sur l'ordinateur de destination | Scénario exemple
IDE | IDE | L'image principale a été créée sur un ordinateur qui utilise un contrôleur PCI IDE ; les ordinateurs de destination utilisent un contrôleur IDE Intel.
IDE | SCSI | L'image principale a été créée sur un ordinateur qui utilise un contrôleur PCI IDE ; certains ordinateurs de destination démarrent à partir d'un contrôleur SCSI, par exemple le contrôleur Adaptec 7800.
SCSI | SCSI | L'image principale a été créée sur un ordinateur qui utilise un contrôleur Adaptec 7800 ; les ordinateurs de destination utilisent un contrôleur Qlogic.
SCSI | IDE | L'image principale a été créée sur un ordinateur qui utilise un contrôleur Adaptec 7800 ; parmi les ordinateurs de destination, certains démarrent à partir d'un contrôleur IDE.

Avant d'exécuter Sysprep sur l'installation principale et de créer votre image, identifiez les différents contrôleurs de stockage de masse que vous pouvez installer sur chaque ordinateur de destination dans la section [SysprepMassStorage] du fichier Sysprep.inf. Vous pouvez le faire automatiquement en suivant la procédure décrite dans la section « Identification automatique des jeux de pilotes de stockage de masse ». Sysprep remplit préalablement les informations nécessaires relatives aux pilotes pour que Windows puisse charger les pilotes adéquats lorsque le système d'exploitation démarre sur un ordinateur qui utilise l'un des contrôleurs de stockage de masse prédéfinis.

Pour plus d'informations, consultez Préparation de l'installation en vue d'un déploiement et [SysprepMassStorage].

Identification automatique des jeux de pilotes de stockage de masse

Il n'est pas nécessaire de créer manuellement les entrées de la section [SysprepMassStorage]. Vous pouvez par contre ajouter la section [Sysprep] au fichier Sysprep.inf pour que Sysprep génère automatiquement les entrées de la section [SysprepMassStorage] à partir des ID matériels Plug-and-Play spécifiés dans les fichiers Machine.inf, Scsi.inf, Pnpscsi.inf et Mshdc.inf.

Remarque

  • Cette procédure ne fonctionne que pour les pilotes inclus dans Windows XP. De plus, la section [SysprepMassStorage] doit être vide, sans quoi la procédure échoue.

Dans la section [Sysprep] du fichier Sysprep.inf, affectez à l'entrée BuildMassStorageSection la valeur Yes. Par exemple :

[Sysprep]
BuildMassStorageSection = Yes

Cette technique peut entraîner l'installation de plus de pilotes de stockage de masse que vous n'en avez besoin et peut donc augmenter le délai de démarrage de l'ordinateur. Elle est toutefois beaucoup moins susceptible de générer des erreurs.

Identification manuelle des jeux de pilotes de stockage de masse

Si vous connaissez le jeu d'ID Plug-and-Play dont vous avez besoin, vous pouvez améliorer le délai de démarrage du système d'exploitation en créant manuellement la section [SysprepMassStorage] dans le fichier Sysprep.inf.

Pour identifier les contrôleurs de stockage de masse potentiels sur les ordinateurs de destination

  1. Générez la liste des ID matériels pour tous les contrôleurs de stockage de masse susceptibles de se trouver sur les ordinateurs de destination.
  2. Comparez la liste générée à l'étape 1 avec la liste d'ID matériels des fichiers .inf pour déterminer les références nécessaires.
  3. Pour les contrôleurs de stockage de masse fournis sur le CD-ROM du produit Windows, créez un fichier Sysprep.inf avec la section suivante :
    [SysprepMassStorage]
id_matériel = chemin_fichier_inf_périphérique

    Dans cet exemple :

    id_matériel
    ID Plug-and-Play du périphérique, tel qu'il est spécifié dans le fichier .inf du périphérique.
    chemin_fichier_inf_périphérique
    Chemin d'accès au fichier .inf qui contient l'ID Plug-and-Play du contrôleur à installer.

    Par exemple, pour la prise en charge des différents contrôleurs IDE (PCI et Intel) fournis avec Windows XP, cette section peut se présenter de la manière suivante :

    [SysprepMassStorage]
PCI\VEN_8086&DEV_1222 = "%WINDIR%\inf\mshdc.inf"
PCI\VEN_8086&DEV_1230 = "%WINDIR%\inf\mshdc.inf"
PCI\VEN_8086&DEV_7010 = "%WINDIR%\inf\mshdc.inf"
PCI\VEN_8086&DEV_7111 = "%WINDIR%\inf\mshdc.inf"
PCI\VEN_8086&DEV_2411 = "%WINDIR%\inf\mshdc.inf"
PCI\VEN_8086&DEV_2421 = "%WINDIR%\inf\mshdc.inf"
PCI\VEN_8086&DEV_7199 = "%WINDIR%\inf\mshdc.inf"

    Pour obtenir les meilleurs résultats, incluez uniquement dans cette liste le sous-ensemble des ID Plug-and-Play dont vous avez besoin pour votre environnement. Si vous identifiez des ID matériels qui ne sont pas nécessaires, les temps de démarrage risquent d'être plus longs qu'à la normale.

  4. Pour les contrôleurs de stockage de masse qui ne sont pas fournis sur le CD-ROM du produit Windows :
    • Copiez les fichiers de pilote correspondant aux contrôleurs de stockage de masse des ordinateurs de destination dans un dossier situé sur votre ordinateur, par exemple %SYSTEMDRIVE%\pilotes_pnp\stockage sur le disque dur de l'ordinateur principal.
  5. Ajoutez des lignes à la section [SysprepMassStorage] en utilisant le format suivant :
    id_matériel = "chemin_fichier_inf_périphérique", "répertoire_disquette", "description_disquette", libellé_disquette

    Dans cet exemple :

    id_matériel
    ID Plug-and-Play du périphérique, tel qu'il est spécifié dans le fichier .inf du périphérique.
    chemin_fichier_inf_périphérique
    Chemin d'accès au fichier .inf qui contient l'ID Plug-and-Play du contrôleur à installer.
    répertoire_disquette
    Nom du dossier qui, sur la disquette fournie par le fabricant tiers, contient la copie du pilote de stockage de masse.
    description_disquette
    La description de la disquette, telle qu'elle apparaît dans le fichier Txtsetup.oem fourni par le fabricant tiers.
    libellé_disquette
    La description de la disquette, telle qu'elle apparaît dans le fichier Txtsetup.oem fourni par le fabricant tiers.

    Les valeurs répertoire_disquette, description_disquette et libellé_disquette sont requises pour permettre au processus de réparation de différencier les pilotes inclus sur le CD-ROM du produit Windows des pilotes qui ne le sont pas. Si le pilote d'un fabricant tiers remplace un pilote fourni sur le CD-ROM du produit Windows, suivez les instructions de l'étape 2.

    Placez les fichiers des pilotes à l'emplacement spécifié dans la section [SysprepMassStorage] de Sysprep.inf. Par exemple, pour prendre en charge un nouveau pilote Qlogic, si vous copiez les fichiers dans le dossier C:\Drivers\Storage, ajoutez le texte suivant :

    [SysprepMassStorage]
PCI\VEN_1077&DEV_1080 = "C:\Drivers\Storage\qlogic\qlogic.inf", "C:\Drivers\Storage\qlogic", "Qlogic Software Disk", "C:\Drivers\Storage\qlogic\qlogic"

    Remarque

    • Placez toutes les valeurs de cette commande sur une seule ligne de texte.
  6. Créez un fichier Cmdlines.txt qui commence par les lignes suivantes :
    [Commands]
"C:\Sysprep\Sysprep -clean"

    Cette commande désactive tous les contrôleurs de stockage de masse qui ne sont pas installés parce qu'ils ne sont pas présents sur l'ordinateur de destination.

    Important

    • Si vous n'ajoutez pas cette ligne au fichier Cmdlines.txt, le processus de démarrage des ordinateurs de destination risque d'être plus lent, car le système d'exploitation tente de charger tous les pilotes de contrôleur à chaque redémarrage.

    Placez le fichier Cmdlines.txt dans un dossier $OEM$, à l'emplacement indiqué dans le fichier Sysprep.inf par l'entrée InstallFilesPath. Par exemple, si :

    InstallFilesPath = "C:\Sysprep\i386"

    Copiez le fichier Cmdlines.txt dans le dossier
    C:\Sysprep\i386\$OEM$.

    Pour plus d'informations sur Cmdlines.txt, consultez Préinstallation d'applications à l'aide des techniques traditionnelles.

  7. Exécutez Sysprep.

    Remarque

    • Si vous utilisez cette procédure pour préinstaller des contrôleurs de stockage de masse, ne fournissez pas un fichier Sysprep.inf mis à jour sur une disquette. Cette méthode ne fonctionnera pas et risque même de provoquer l'échec de votre installation.

Important

  • Pour les scénarios IDE vers SCSI et SCSI vers SCSI, les disques durs des ordinateurs de destination doivent être accessibles via les fonctions BIOS INT13 étendues pour que Sysprep puisse fonctionner correctement. Les ordinateurs doivent être en mesure de démarrer avec un fichier boot.ini qui utilise la syntaxe multi( ) au lieu de la syntaxe scsi( ) ou signature( ).

    Pour garantir l'utilisation de la syntaxe multi( ), ajoutez l'entrée UseBiosToBoot à votre fichier de réponses (Unattend.txt).

  • Cette possibilité existe uniquement pour les contrôleurs de stockage de masse Plug-and-Play (PnP) ou pour les contrôleurs qui utilisent des mini-ports PnP.
  • Les couches HAL de l'ordinateur principal et des ordinateurs de destination doivent toujours être compatibles.

Pour plus d'informations sur la préinstallation de ces périphériques, consultez Préinstallation de pilotes de stockage de masse.


Réduction du nombre d'images principales pour les ordinateurs avec plusieurs processeurs

Si vous utilisez des images dans le cadre du processus de fabrication, vous pouvez préinstaller la même image de Windows sur les ordinateurs multiprocesseurs et monoprocesseurs à condition que l'ordinateur principal et l'ordinateur de destination soient tous deux des ordinateurs à contrôleur d'interruptions programmable avancé (APIC) ou des ordinateurs APIC à interface de configuration et d'énergie avancée (ACPI).

Pour plus d'informations, consultez :

  • Spécification relative à l'interface de configuration et d'énergie avancée (ACPI) (http://www.acpi.info/index.html)
  • Avantages majeurs de l'APIC E/S (http://www.microsoft.com/whdc/hwdev/platform/proc/IO-APIC.mspx)

Le tableau suivant illustre le type des ordinateurs de destination sur lesquels vous pouvez installer une image principale donnée, selon le type de couche d'abstraction matérielle (HAL) de l'ordinateur utilisé pour créer l'installation principale.

Couche HAL de l'installation principale | Couche HAL de l'ordinateur de destination
 | Monoprocesseur APIC ACPI | Multiprocesseur APIC ACPI | Monoprocesseur APIC non-ACPI | Multiprocesseur APIC non-ACPI
Monoprocesseur APIC ACPI | X | X |  |
Multiprocesseur APIC ACPI | X | X |  |
Monoprocesseur APIC non-ACPI |  |  | X | X
Multiprocesseur APIC non-ACPI |  |  | X | X

Important

  • Le type de couche HAL ne change que si vous exécutez Sysprep en mode mini-installation. La couche HAL ne change pas si vous exécutez Sysprep en mode Usine ou Rescellage.
  • N'essayez en aucun cas de transformer une couche HAL ACPI en couche HAL standard ou inversement, sans quoi votre ordinateur ne démarrera pas correctement, voire ne démarrera pas du tout. Étant donné que les arborescences de périphérique des deux types de couche HAL sont littéralement différentes, le système n'aura pas connaissance des changements de matériel après le redémarrage de l'ordinateur, notamment concernant l'emplacement du périphérique de démarrage. Microsoft ne recommande pas d'effectuer cette procédure et ne la prend pas en charge, car elle entraîne une perte de données.

    Pour plus d'informations sur les options de la couche HAL, consultez l'article 309283 dans la Base de connaissances Microsoft.

Remarques

  • Windows XP Édition familiale ne prend pas en charge les multiprocesseurs.
  • Vous ne pouvez installer une installation principale qu'à partir d'un ordinateur PIC ACPI vers un ordinateur de destination PIC ACPI.
  • Vous ne pouvez installer une installation principale qu'à partir d'un ordinateur PIC monoprocesseur non-ACPI vers un ordinateur de destination PIC monoprocesseur non-ACPI.
  • Une image créée sur un ordinateur monoprocesseur (sans prise en charge multiprocesseur) ne peut pas s'utiliser sur un ordinateur multiprocesseur.
  • Les systèmes APIC offrent un plus grand nombre d'interruptions que les systèmes monoprocesseurs PIC (Processor Interrupt Controller). Par conséquent, un ordinateur doté d'une couche HAL APIC :
    • offre des temps de réponse plus courts ;
    • peut prendre en charge davantage de périphériques matériels.

Vous disposez de deux techniques pour créer des images utilisables aussi bien sur les systèmes multiprocesseurs que sur les systèmes monoprocesseurs. Choisissez la technique qui vous convient et qui s'adapte le mieux à votre environnement de fabrication.

Application d'une installation principale multiprocesseur sur un ordinateur de destination monoprocesseur

La première technique consiste à créer l'installation principale sur un ordinateur multiprocesseur. L'image créée peut ensuite être utilisée sur d'autres ordinateurs multiprocesseurs ou sur des ordinateurs monoprocesseurs.

Important

  • Le type de couche HAL de l'ordinateur sur lequel l'installation principale a été créée détermine le type d'ordinateur de destination sur lequel vous pouvez utiliser l'image :
    • Vous pouvez utiliser une installation principale créée sur un ordinateur multiprocesseur APIC ACPI sur d'autres ordinateurs APIC ACPI multiprocesseurs ou monoprocesseurs.
    • Vous pouvez utiliser une installation principale créée sur un ordinateur multiprocesseur APIC non-ACPI sur d'autres ordinateurs APIC non-ACPI multiprocesseurs ou monoprocesseurs.

Pour créer une image d'ordinateur multiprocesseur vers un ordinateur monoprocesseur

  1. Dans Sysprep.inf, ajoutez :
    [Unattended]
UpdateUPHAL = "idmat,%WINDIR%\Inf\Hal.inf"

    où idmat correspond à MPS_UP ou à ACPIAPIC_UP.

    Pour plus d'informations, consultez l'entrée UpdateUPHAL.

  2. Installez le jeu de configuration Windows sur un ordinateur multiprocesseur.
  3. Exécutez Sysprep en mode mini-installation avec le fichier Sysprep.inf.

    Par exemple, à partir du dossier Sysprep, exécutez :

    C:\sysprep\sysprep -mini -quiet -shutdown
  4. Créez une image de l'installation.
  5. Placez cette image sur des ordinateurs de destination multiprocesseurs comparables.

Application d'une installation principale monoprocesseur sur un ordinateur de destination multiprocesseur

La seconde technique consiste à créer l'installation principale sur un ordinateur monoprocesseur avec une couche HAL APIC. Vous pouvez ensuite utiliser cette image pour préinstaller Windows sur des ordinateurs de destination équipés d'un matériel compatible, que ces ordinateurs utilisent une couche HAL APIC monoprocesseur ou multiprocesseur.

Important

  • Toutes les versions de Windows XP et de la famille Windows Server 2003 utilisant une couche HAL APIC (ACPI ou non-ACPI) installent automatiquement la couche HAL multiprocesseur correspondante lors de la détection d'un deuxième processeur. Cela signifie que l'entrée UpdateHAL n'est nécessaire que pour les versions de Windows antérieures à Windows XP.

Important

Le type de couche HAL de l'ordinateur sur lequel l'installation principale a été créée détermine le type d'ordinateur de destination sur lequel vous pouvez utiliser l'image :

  • Vous pouvez utiliser une installation principale créée sur un ordinateur monoprocesseur APIC ACPI sur d'autres ordinateurs de destination APIC ACPI monoprocesseurs ou multiprocesseurs.
  • Vous pouvez utiliser une installation principale créée sur un ordinateur monoprocesseur APIC non-ACPI sur d'autres ordinateurs de destination APIC non-ACPI monoprocesseurs ou multiprocesseurs.

Pour créer une image d'un ordinateur monoprocesseur vers un ordinateur multiprocesseur

  1. Installez Windows sur un ordinateur monoprocesseur.
  2. Créez une image de l'installation.
  3. Dans Sysprep.inf, ajoutez :
    [Unattended]
UpdateHAL = "idmat,%WINDIR%\Inf\Hal.inf"

    où idmat correspond à MPS_MP ou à ACPIAPIC_MP.

    Pour plus d'informations, consultez l'entrée UpdateHAL.

  4. Exécutez Sysprep en mode mini-installation avec ce fichier Sysprep.inf.

    Important

    Par exemple, à partir du dossier Sysprep, exécutez :

    C:\sysprep\sysprep -mini -quiet -shutdown
  5. Créez une image de l'installation.
  6. Placez cette image sur des ordinateurs de destination multiprocesseurs comparables.

Important

  • N'utilisez pas de fichier Sysprep.inf contenant l'entrée UpdateHAL sur des ordinateurs de destination monoprocesseurs, car l'entrée UpdateHAL charge la couche HAL multiprocesseur sur l'ordinateur de destination, qu'il s'agisse d'un ordinateur monoprocesseur ou multiprocesseur. Un noyau multiprocesseur sur un ordinateur monoprocesseur réduit considérablement les performances de l'ordinateur.

Vous pouvez utiliser les outils que vous employez habituellement pour manipuler les fichiers sur le disque dur lorsque vous créez des ordinateurs à partir d'une image.


Outils et options de la ligne de commande

Les outils suivants de Deploy.cab peuvent être exécutés à partir de la ligne de commande :

  • Options de la ligne de commande Sysprep
  • Options de la ligne de commande Cvtarea
  • Options de la ligne de commande Oformat

Les outils suivants, intégrés au système d'exploitation Windows XP, s'avèrent utiles pour déployer Windows XP :

  • Options de la ligne de commande Convert
  • Commandes Diskpart
  • Script Diskpart
  • Options de la ligne de commande Winnt32.exe
  • Options de la ligne de commande Winnt.exe


Options de la ligne de commande Sysprep

L'outil de préparation de systèmes Windows (Sysprep) prépare le lecteur de disque dur d'un ordinateur pour la livraison à l'utilisateur final.

La syntaxe de l'outil Sysprep est la suivante :

sysprep [-bmsd] | { {[-factory] | [-reseal]} {[-clean] | [-activated] [-audit] [-forceshutdown] [-mini] [-noreboot] [-nosidgen] [-pnp] [-quiet] [-reboot]} }

Option | Action
-activated Ne réinitialise pas le délai de grâce pour l'activation de produit Windows. Utilisez cette option uniquement si vous avez activé l'installation Windows en usine.

Important

  • La clé de produit que vous utilisez pour activer l'installation Windows doit correspondre à la clé de produit indiquée sur l'étiquette autocollante du certificat d'authenticité placée sur cet ordinateur.
-audit Redémarre l'ordinateur en mode Usine sans générer de nouveaux ID de sécurité (identificateurs de sécurité) ni traiter aucun élément de la section [OEMRunOnce] de Winbom.ini.

Utilisez cette option de ligne de commande uniquement si l'ordinateur est en mode Usine.
-bmsd Si l'en-tête de section [SysprepMassStorage] existe dans Sysprep.inf et que vous exécutez la commande Sysprep -bmsd, Sysprep remplit la section [SysprepMassStorage] avec les entrées ID_Plug_and_Play = chemin_vers_fichier_inf_périphérique correspondant aux ID Plug-and-Play des périphériques de stockage de masse spécifiés dans Machine.inf, Scsi.inf, Pnpscsi.inf et Mshdc.inf. Sysprep crée uniquement la liste des périphériques de stockage de masse ; il n'installe pas ces derniers dans la base de données des périphériques critiques et n'effectue pas d'autres traitements.

Après avoir utilisé la commande sysprep -bmsd pour générer les entrées de la section [SysprepMassStorage], vous pouvez supprimer des éléments de cette section avant d'exécuter Sysprep -reseal ou Sysprep -factory sur cette installation. L'installation d'un petit nombre d'éléments dans la base de données des périphériques critiques réduit le temps nécessaire à l'image pour redémarrer sur le système d'exploitation.

N'utilisez pas l'option de ligne de commande -bmsd avec d'autres options de ligne de commande.
-clean | Efface les pilotes de stockage de masse ajoutés par la section [SysprepMassStorage] de Sysprep.inf et supprime les références aux périphériques fantômes créés par la fonctionnalité Plug-and-Play.
-factory Redémarre l'ordinateur avec la prise en charge réseau sans afficher l'Accueil de Windows ni la mini-installation. Cette option est utile pour mettre à jour des lecteurs, exécuter l'énumération Plug-and-Play, installer des applications, tester, configurer l'ordinateur avec les données du client ou apporter d'autres modifications à la configuration dans votre environnement d'usine. Pour les sociétés qui utilisent un logiciel de création d'image (ou clonage) de disque, le mode Usine peut réduire le nombre d'images requises.

Après avoir achevé les tâches en mode Usine, exécutez l'option sysprep -reseal afin de préparer l'ordinateur pour la livraison.
-forceshutdown Arrête l'ordinateur à l'issue de Sysprep.

Remarque

  • Utilisez cette option avec les ordinateurs dotés d'un BIOS ACPI qui ne s'arrêtent pas correctement avec les paramètres par défaut de Sysprep.
-mini | Configure Windows XP Professionnel pour utiliser la mini-installation à la place de l'Accueil de Windows. Cette option n'a aucun effet sur Windows XP Édition familiale, où la première mise en route se fait toujours dans l'Accueil de Windows.
-noreboot | Modifie les clés du Registre (SID, OemDuplicatorString, etc.) sans redémarrer le système ni le préparer à la duplication. Cette option est surtout utilisée dans les tests, notamment pour savoir si le Registre été modifié correctement. Cette option n'est pas recommandée dans la mesure où les modifications effectuées sur un ordinateur après l'exécution de Sysprep peuvent invalider la préparation effectuée par Sysprep. N'utilisez pas cette option dans un environnement de production.
-nosidgen | Exécute Sysprep sans générer de nouveaux numéros SID. Vous devez utiliser cette option si vous ne dupliquez pas l'ordinateur ou si l'ordinateur est un contrôleur de domaine.
-pnp Exécute l'énumération de tous les périphériques Plug-and-Play et les installe pendant la mini-installation. Cette option de ligne de commande n'a aucun effet si le premier démarrage se fait dans l'Accueil de Windows.

Utilisez -pnp uniquement pour détecter et installer des périphériques traditionnels, non Plug-and-Play. N'utilisez pas -pnp sur les ordinateurs dotés exclusivement de périphériques Plug-and-Play. Dans le cas contraire, vous ralentiriez le premier démarrage, sans avantages supplémentaires pour l'utilisateur.
-quiet | Exécute Sysprep sans afficher de messages de confirmation à l'écran. Cette option est très pratique si vous automatisez Sysprep. Par exemple, si vous prévoyez d'exécuter Sysprep immédiatement après une installation sans assistance, ajoutez sysprep -quiet à la section [GuiRunOnce] du fichier Unattend.txt.
-reboot | Force l'ordinateur à redémarrer automatiquement puis à démarrer l'accueil Windows, la mini-installation ou le mode Usine, selon l'option spécifiée. Cette option est pratique lorsque vous voulez auditer le système et vérifier que le premier démarrage fonctionne correctement.
-reseal | Efface le journal de l'Observateur d'événements et prépare l'ordinateur pour sa livraison au client. L'Accueil de Windows ou la mini-installation est défini pour démarrer au prochain rédémarrage. Si vous exécutez la commande sysprep -factory, vous devez sceller l'installation à la dernière étape du processus de préinstallation, en exécutant la commande sysprep -reseal ou en cliquant sur le bouton Resceller dans la boîte de dialogue Sysprep.


Options de la ligne de commande Cvtarea

Cvtarea est un outil souple de création de fichiers et d'analyse du placement de ces fichiers sur un système de fichiers FAT32 ou FAT. Avec l'outil Cvtarea, vous pouvez créer et placer un fichier contigu à un emplacement spécifique du disque.

Si vos processus de fabrication vous obligent à formater le disque dur avec le système de fichiers FAT ou FAT32 avant de convertir le lecteur de disque dur au système de fichiers NTFS, vous pouvez utiliser l'outil Cvtarea pour créer un fichier d'espaces réservés contigus pouvant être utilisé par les fichiers de métadonnées NTFS après la conversion. Le résultat se traduira par un système de fichiers moins fragmenté et plus performant.

Pour plus d'informations, consultez :

  • Conversion de partitions FAT/FAT32 en NTFS
  • Préinstallation de NTFS et Windows XP (http://www.microsoft.com/whdc/)
  • « Converting Volumes to NTFS » sur le site Microsoft TechNet

Détection de la quantité d'espace libre dans un volume FAT

La syntaxe de l'outil Cvtarea pour trouver les clusters d'espace libre d'un volume FAT est la suivante :

cvtarea nom_lecteur /freespace

Option | Action
NomLecteur | Spécifie la lettre de lecteur (suivie d'un signe deux-points). Par exemple, C :
/freespace | Affiche les blocs d'espace libre disponibles.

Création d'un fichier

La syntaxe de l'outil Cvtarea pour la création d'un fichier est la suivante :

cvtarea nom_fichier taille [unités] [/contig] [/firstcluster cluster [unités_cluster] [/strictlocation]]

Option | Action
nomfichier | Spécifie le nom du fichier à créer. Ce fichier doit se trouver dans le répertoire racine du lecteur à convertir.
taille | Entier de 32 bits spécifiant la taille de la zone à créer.
unités Unité de mesure de la taille ; les options valables sont Ko, Mo, Go, %disk et %free.
%disk
Indique que la taille du fichier est un certain pourcentage de la dimension totale du disque.
%free
Indique que la taille du fichier est un certain pourcentage de l'espace libre actuel du disque.
/contig | Spécifie que le fichier doit être créé sur le disque de façon contiguë.
/premier_cluster:cluster [unités_cluster] | Spécifie le premier cluster où vous voulez placer le fichier. Le cas échéant, vous pouvez indiquer la taille des unités de cluster (par exemple 4 ou 8 Ko).
/strictlocation | Ne crée pas le fichier si le cluster spécifié est déjà utilisé.

Affichage du nombre de clusters utilisés par un fichier

La syntaxe de l'outil Cvtarea pour l'affichage des clusters utilisés par un fichier est la suivante :

cvtarea nom_fichier /info

Option | Action
nomfichier | Spécifie le nom d'un fichier existant.
/info | Affiche le nombre de clusters alloués à un fichier donné.


Options de la ligne de commande Oformat

Oformat crée un volume FAT32 avec des clusters alignés d'une manière optimale en vue de sa conversion future au format du système de fichiers NTFS.

Important

  • Cet outil est basé sur l'outil Format de Windows Millenium Edition. Par conséquent, vous pouvez seulement :
    • exécuter Oformat sur les versions de MS–DOS disponibles dans Windows Millenium Edition et Windows XP ;
    • démarrer avec MS–DOS et installer Windows XP avec Winnt.exe.

De plus, Oformat présente d'importantes modifications spécifiquement conçues pour les constructeurs d'ordinateurs :

  • Oformat n'impose pas la vérification des secteurs lors du premier formatage du disque. Vous pouvez donc effectuer un formatage rapide immédiatement après la création d'une nouvelle partition, ce qui est beaucoup plus rapide que d'utiliser le programme Format conventionnel dans un environnement de fabrication.
  • Oformat ne demande pas de confirmation avant de formater un disque.
  • L'option de ligne de commande /a permet à Oformat d'aligner les clusters de données FAT au niveau d'un secteur spécifié, ce qui réduit la durée de la conversion au format NTFS.

La syntaxe de l'outil Oformat dans le cadre de la préinstallation de Windows est la suivante :

oformat LettreLecteur [/a:nombre] [/autotest|/v:NomDisque] [/q]

Option | Action
LettreLecteur | Indique le lecteur à formater.
/a:nombre | Aligne les secteurs système pour les FAT convertibles en NTFS. La valeur de nombre peut être 2, 4, 8, 16, 32, 64, 128.
/autotest | S'exécute en silence. Ne pas utiliser avec /v.
/q | Réalise un formatage rapide.
/v:NomDisque | Représente le nom du volume. Ne pas utiliser avec /autotest.

Important

  • Si vous n'utilisez pas l'option /q, l'exécution de Oformat dure aussi longtemps que celle de Format.
  • L'option de ligne de commande /a:8 formate le volume de telle sorte que les clusters de données FAT sont alignés à des frontières de 4 Ko. Cette configuration est recommandée car elle est la plus efficace pour la conversion en NTFS.

Exemple

La ligne de commande suivante formate le volume sur le lecteur E en remplaçant le secteur d'amorçage, la table FAT et le dossier racine par des structures propres sur un disque dur récemment partitionné. En outre, elle configure de manière optimale le disque pour la conversion NTFS.

oformat e: /q /autotest /a:8

Pour plus d'informations, consultez Options de la ligne de commande Convert.

Options supplémentaires de la ligne de commande Oformat

Oformat comprend des options de ligne de commande supplémentaires. La syntaxe complète de l'outil Oformat est la suivante :

oformat LettreLecteur [/a:nombre] [/autotest|/v:NomDisque] [/b | /s] [/c] [/f:taille] [/q] [/t:pistes /n:secteurs] [/u] [/1] [/4] [/8]

Option | Action
/b | Alloue de l'espace pour les fichiers système sur le disque formaté.
/c | Teste les clusters actuellement marqués comme étant incorrects.
/f:taille | Indique la taille de la disquette à formater. La valeur de taille peut être 160, 180, 320, 360, 720, 1,2, 1,44, 2,88.
/n:secteurs | Spécifie le nombre de secteurs par piste.
/s | Copie des fichiers système sur le disque formaté.
/t:pistes | Spécifie le nombre de pistes par face du disque.
/u | N'enregistre pas les informations de récupération pouvant être utilisées pour déformater le disque.
/l | Formate une seule face de la disquette.
/4 | Formate une disquette 5,25 pouces de 360 Ko dans un lecteur haute densité.
/8 | Formate huit secteurs par piste.

Différences entre Oformat et Format

Contrairement à l'outil Format, Oformat vous permet de ne pas vérifier l'intégrité du disque ou d'écraser les données existantes dans la zone des données. Afin de préserver la géométrie du disque, les valeurs présentes dans le BPB (BIOS Parameter Block) du secteur d'amorçage d'origine sont insérées dans le nouveau secteur d'amorçage. Dans le cas d'une partition non formatée, Oformat utilise les valeurs BPB calculées par le code d'initialisation de MS-DOS à la place des valeurs du secteur d'amorçage existant. Cette modification permet au formatage rapide de continuer lorsque le secteur d'amorçage n'est pas valide, ce qui est le cas juste après le partitionnement du disque. Oformat récupère les paramètres du disque directement à partir du BIOS MS-DOS, qui les calcule à l'aide des informations de la partition, de telle sorte que le secteur d'amorçage que Oformat place éventuellement sur le disque est correct. Ces modifications permettent le formatage d'un disque dur de n'importe quelle taille en cinq secondes environ, que le lecteur ait été formaté préalablement ou non.

Comme Oformat ne vérifie pas le disque, il se peut que vous ne détectiez pas les secteurs incorrects du disque. Évaluez ce risque en vous basant sur la présence d'une garantie de zéro défaut de la part du fabricant du disque.


Options de la ligne de commande Convert

Convert est un outil de ligne de commande présent dans Windows XP et la famille Windows Server 2003. Il convertit les volumes FAT et FAT32 au système de fichiers NTFS. Vous ne pouvez pas reconvertir un volume NTFS en un volume FAT ou FAT32.

La syntaxe de l'outil Convert est la suivante :

convert [volume] /fs:ntfs [/v] [/cvtarea:nomfichier] [/nosecurity] [/x]

Option | Action
volume: Spécifie la lettre de lecteur (suivie de deux points), le point de montage ou le nom du volume à convertir au format NTFS.
/fs:ntfs | Requis. Convertit le volume au format NTFS en laissant intacts les fichiers et les dossiers existants.
/v | Spécifie le mode Verbose. Dans ce mode, tous les messages sont affichés au cours de la conversion.
/cvtarea:nomfichier Spécifie que la table MFT (Master File Table) et les autres fichiers de métadonnées NTFS sont écrits dans un fichier d'espaces réservés d'un seul tenant existant préalablement. Ce fichier doit se trouver dans le répertoire racine du système de fichiers pour pouvoir être converti. Pour que celle-ci donne les meilleurs résultats, la taille du fichier doit être de 1 Ko multiplié par le nombre de fichiers et de répertoires contenus dans le système de fichiers. Toutefois, la commande Convert accepte toute taille de fichier jusqu'à un maximum de 4 Go, qui constitue la limite de taille de fichier FAT. L'utilisation du paramètre /cvtarea peut aboutir à un système de fichiers moins fragmenté au terme de la conversion.

Pour plus d'informations sur l'utilisation du paramètre /cvtarea, consultez :

  • Options de la ligne de commande Cvtarea
  • Préinstallation de NTFS et Windows XP (http://www.microsoft.com/whdc/)
  • « Converting Volumes to NTFS » sur le site Microsoft TechNet

Important

  • Vous devez créer le fichier d'espaces réservés à l'aide de la commande fsutil file createnew avant d'exécuter Convert. La commande Convert ne crée pas ce fichier automatiquement. Elle lui substitue les métadonnées NTFS. Après la conversion, tout espace inutilisé dans ce fichier est libéré. Pour plus d'informations sur fsutil file, consultez l'aide de Windows.
/nosecurity | Spécifie que toute personne peut accéder aux paramètres de sécurité des fichiers et des répertoires convertis.
/x | Le cas échéant, démonte le volume avant sa conversion. Tous les descripteurs ouverts du volume perdent leur validité.

Remarques

  • Pour recréer le comportement de convert dans Windows 2000, utilisez la commande convert /nosecurity.
  • Pour recréer le comportement par défaut dans Windows 2000 et démarrer automatiquement chkdsk après la conversion d'un volume système, utilisez convert sans argument.

Commentaires

  • Si Convert ne peut pas verrouiller le lecteur, elle propose de le convertir au prochain démarrage de l'ordinateur. Si vous ne pouvez pas redémarrer l'ordinateur immédiatement pour terminer la conversion, planifiez le redémarrage en tenant compte du fait qu'il prendra plus longtemps à cause du processus de conversion.
  • Pour les volumes sur lesquels le système de fichiers est converti de FAT ou FAT32 à NTFS, la table MFT ne se trouve pas au même endroit que pour les volumes formatés dès le début avec NTFS. Pour optimiser les performances, vous avez peut-être intérêt à recréer ces volumes NTFS.
  • Les volumes FAT convertis au format NTFS sont moins performants que les volumes auxquels le format NTFS est appliqué dès l'origine. Sur les volumes convertis, la table MFT peut se fragmenter. En outre, les autorisations NTFS ne s'appliquent plus sur un volume de démarrage converti.
  • Un volume converti peut être fragmenté et plus lent qu'un volume formaté dès le début avec NTFS. Il est toujours préférable d'utiliser NTFS, que le volume soit formaté avec NTFS dès le départ ou converti.

Exemple

Pour convertir le volume du lecteur E au format NTFS et afficher tous les messages, tapez :

convert e: /fs:ntfs /v


Commandes DiskPart

DiskPart est un interpréteur de commande en mode texte présent dans Windows XP et la famille Windows Server 2003. Cet outil vous permet de gérer des objets (disques, partitions ou volumes) à l'aide de scripts ou de commandes directes à partir d'une invite de commandes. Avant de pouvoir utiliser les commandes DiskPart sur un disque, une partition ou un volume, vous devez d'abord répertorier et sélectionner l'objet voulu pour lui donner le focus. Lorsqu'un objet a le focus, toutes les commandes DiskPart que vous tapez s'appliquent à cet objet.

Vous pouvez répertorier les objets disponibles et déterminer le numéro ou la lettre de lecteur d'un objet à l'aide des commandes list disk, list volume et list partition. Les commandes list disk et list volume affichent tous les disques et les volumes présents dans l'ordinateur. Toutefois, la commande list partition n'affiche que les partitions du disque qui ont le focus. Lorsque vous utilisez les commandes list, un astérisque (*) apparaît près de l'objet qui a le focus. Vous sélectionnez un objet à l'aide de son numéro ou de sa lettre de lecteur, comme disque 0, partition 1, volume 3 ou volume C.

Lorsque vous sélectionnez un objet, le focus reste sur cet objet jusqu'à ce que vous en sélectionniez un autre. Par exemple, si le disque 0 a le focus et que vous sélectionnez le volume 8 sur le disque 2, le focus passe du disque 0 au volume 8 du disque 2. Certaines commandes changent automatiquement le focus. Par exemple, lorsque vous créez une nouvelle partition, le focus passe automatiquement à la nouvelle partition.

Vous pouvez uniquement donner le focus à une partition du disque sélectionné. Lorsqu'une partition a le focus, le volume associé (le cas échéant) a également le focus. Lorsqu'un volume a le focus, le disque et la partition associés ont également le focus si le volume est mappé à une partition spécifique unique. Dans le cas contraire, le disque et la partition perdent le focus.

Important

  • Lorsque vous utilisez la commande DiskPart dans le cadre d'un script, il est recommandé d'effectuer toutes les opérations DiskPart ensemble au sein d'un script DiskPart unique. Vous pouvez exécuter des scripts DiskPart consécutifs, mais il est nécessaire de laisser s'écouler au moins 15 secondes entre chaque script pour laisser l'exécution précédente se terminer complètement avant d'exécuter à nouveau la commande DiskPart dans des scripts successifs. Sinon, les scripts successifs peuvent échouer. Vous pouvez ajouter une pause entre les scripts DiskPart consécutifs en ajoutant la commande de délai d'attente /t 15 à votre fichier de commandes avec vos scripts DiskPart.

Pour plus d'informations sur DiskPart, consultez la rubrique de gestion des disques sur le site Web des Kits de ressources techniques de Microsoft Windows.(http://www.microsoft.com/)

Commandes DiskPart

Le tableau suivant identifie la syntaxe et les paramètres des commandes DiskPart.

Commande | Syntaxe | Description
active active Sur les disques de base, marque la partition dotée du focus comme étant active. Cette indication informe le système d'entrée/sortie de base (BIOS) ou l'interface EFI (Extensible Firmware Interface) que la partition ou le volume est une partition système ou un volume système valide.

Seules les partitions peuvent être marquées comme étant actives.

Important

  • DiskPart vérifie uniquement que la partition est capable de contenir les fichiers de démarrage d'un système d'exploitation. DiskPart ne contrôle pas le contenu de la partition. Si vous marquez par erreur une partition comme étant active et qu'elle ne contient pas les fichiers de démarrage du système d'exploitation, votre ordinateur peut ne pas démarrer.
add disk add disk=n [noerr] Crée un miroir du volume simple qui a le focus sur le disque spécifié.
n
Spécifie le disque qui contiendra le miroir. Vous ne pouvez mettre en miroir que des volumes simples. Le disque spécifié doit disposer d'un espace non alloué au moins égal à la taille du volume simple que vous voulez mettre en miroir.
noerr
Pour les scripts uniquement. En cas d'erreur, spécifie que DiskPart continue à traiter les commandes comme si l'erreur ne s'était pas produite. Sans le paramètre noerr, la détection d'une erreur entraîne la fermeture de DiskPart et l'affichage d'un code d'erreur.
assign assign [{letter=d|mount=chemin_accès}] [noerr] Affecte une lettre de lecteur ou un point de montage au volume qui a le focus. Si aucune lettre de lecteur ou aucun point de montage n'est spécifié, la première lettre de lecteur disponible est affectée. Si la lettre de lecteur ou le point de montage affecté est déjà utilisé, une erreur est générée.

Vous pouvez changer la lettre de lecteur associée à un lecteur amovible à l'aide de la commande assign.

Vous ne pouvez pas affecter de lettres de lecteur aux volumes système, aux volumes de démarrage ou aux volumes qui contiennent le fichier d'échange. De plus, vous ne pouvez pas affecter de lettre de lecteur à une partition OEM (Original Equipment Manufacturer) ou à une partition GPT autre qu'une partition de données de base.

letter=d
Spécifie la lettre de lecteur que vous voulez affecter au volume.
mount=chemin_accès
Spécifie le chemin d'accès au point de montage que vous voulez affecter au volume.
noerr
Pour les scripts uniquement. En cas d'erreur, spécifie que DiskPart continue à traiter les commandes comme si l'erreur ne s'était pas produite. Sans le paramètre noerr, la détection d'une erreur entraîne la fermeture de DiskPart et l'affichage d'un code d'erreur.
automount automount [enable] [disable] [scrub] [noerr] Lorsque ce paramètre est activé (valeur par défaut), Windows monte automatiquement le système de fichiers d'un nouveau volume de base lorsque celui-ci est ajouté au système, puis il lui affecte une lettre de lecteur. Dans le cadre de configurations de réseau SAN (System Area Network), la désactivation du paramètre automount empêche Windows de monter automatiquement les nouveaux volumes de base qui sont ajoutés au système ou de leur affecter une lettre de lecteur.
enable
Permet à Windows de monter automatiquement les nouveaux volumes de base qui sont ajoutés au système et de leur affecter une lettre de lecteur.
disable
Empêche Windows de monter automatiquement les nouveaux volumes de base qui sont ajoutés au système.
scrub
Supprime les répertoires de point de montage de volume et les paramètres de Registre des volumes qui ne sont plus présents dans le système. Lorsque des volumes qui étaient auparavant présents dans le système sont rajoutés à ce dernier, ceci empêche leur montage automatique et l'attribution de leurs anciens points de montage de volume.
noerr
Pour les scripts uniquement. En cas d'erreur, spécifie que DiskPart continue à traiter les commandes comme si l'erreur ne s'était pas produite. Sans le paramètre noerr, la détection d'une erreur entraîne la fermeture de DiskPart et l'affichage d'un code d'erreur.
break disk break disk=n [nokeep] [noerr] S'applique aux disques dynamiques uniquement. Scinde le volume en miroir qui a le focus en deux volumes simples. Un des volumes simples conserve la lettre de lecteur et les points de montage du volume en miroir ; l'autre volume simple reçoit le focus pour que vous puissiez lui affecter une lettre de lecteur.

Le contenu des deux moitiés du miroir est conservé par défaut et chaque moitié devient un volume simple. Avec le paramètre nokeep, vous conservez une seule moitié du miroir en tant que volume simple, l'autre moitié étant supprimée et convertie en espace disponible. Aucun volume ne reçoit le focus.

n
Spécifie le disque qui contient le volume en miroir.
nokeep
Spécifie qu'un seul des volumes en miroir est conservé tandis que l'autre est supprimé et converti en espace disponible. Aucun volume ne reçoit le focus.
noerr
Pour les scripts uniquement. En cas d'erreur, spécifie que DiskPart continue à traiter les commandes comme si l'erreur ne s'était pas produite. Sans le paramètre noerr, la détection d'une erreur entraîne la fermeture de DiskPart et l'affichage d'un code d'erreur.
clean clean [all] Supprime tout formatage de partition ou de volume sur le disque qui a le focus. Sur les disques d'enregistrement de démarrage principal (MBR, Master Boot Record), seules les informations de partitionnement MBR et les informations de secteurs cachés sont effacées. Sur les disques GPT (GUID Partition Table), les informations de partitionnement GPT, y compris le MBR Protectif, sont effacées ; il n'y a pas d'informations sur les secteurs cachés.
all
Spécifie que tous les secteurs du disque sont effacés, ce qui signifie la suppression complète et définitive de toutes les données du disque.
convert basic convert basic [noerr] Convertit un disque dynamique vide en disque de base.

Important

  • Le disque doit être vide pour être converti en disque de base. Sauvegardez vos données, puis supprimez l'ensemble des partitions ou volumes avant de convertir le disque.
noerr
Pour les scripts uniquement. En cas d'erreur, spécifie que DiskPart continue à traiter les commandes comme si l'erreur ne s'était pas produite. Sans le paramètre noerr, la détection d'une erreur entraîne la fermeture de DiskPart et l'affichage d'un code d'erreur.
convert dynamic convert dynamic [noerr] Convertit un disque de base en disque dynamique. Toutes les partitions existantes du disque deviennent des volumes simples.
noerr
Pour les scripts uniquement. En cas d'erreur, spécifie que DiskPart continue à traiter les commandes comme si l'erreur ne s'était pas produite. Sans le paramètre noerr, la détection d'une erreur entraîne la fermeture de DiskPart et l'affichage d'un code d'erreur.
convert gpt convert gpt [noerr] Sur les ordinateurs Itanium, convertit un disque de base vide avec un style de partition MBR (Master Boot Record) en disque de base avec le style de partition GPT (GUID Partition Table).

Important

  • Le disque doit être vide pour être converti en disque GPT. Sauvegardez vos données, puis supprimez l'ensemble des partitions ou volumes avant de convertir le disque.
noerr
Pour les scripts uniquement. En cas d'erreur, spécifie que DiskPart continue à traiter les commandes comme si l'erreur ne s'était pas produite. Sans le paramètre noerr, la détection d'une erreur entraîne la fermeture de DiskPart et l'affichage d'un code d'erreur.
convert mbr convert mbr [noerr] Sur les ordinateurs Itanium, convertit un disque de base vide avec un style de partition GPT (GUID Partition Table) en disque de base avec le style de partition MBR (Master Boot Record).

Important

  • Le disque doit être vide pour être converti en disque MBR. Sauvegardez vos données, puis supprimez l'ensemble des partitions ou volumes avant de convertir le disque.
noerr
Pour les scripts uniquement. En cas d'erreur, spécifie que DiskPart continue à traiter les commandes comme si l'erreur ne s'était pas produite. Sans le paramètre noerr, la détection d'une erreur entraîne la fermeture de DiskPart et l'affichage d'un code d'erreur.
create partition efi create partition efi [size=n] [offset=n] [noerr] Sur les ordinateurs Itanium, crée une partition système EFI (Extensible Firmware Interface) sur un disque GPT (GUID Partition Table). Une fois la partition créée, le focus lui est donné.
size=n
Spécifie la taille de la partition en mégaoctets (Mo). Si aucune taille n'est donnée, la partition se poursuit jusqu'à ce que l'espace libre de la région en cours soit épuisé.
offset=n
Spécifie le décalage d'octet par rapport auquel créer la partition. Si aucun décalage n'est fourni, la partition est placée sur la première extension de disque suffisamment volumineuse pour l'accueillir.
noerr
Pour les scripts uniquement. En cas d'erreur, spécifie que DiskPart continue à traiter les commandes comme si l'erreur ne s'était pas produite. Sans le paramètre noerr, la détection d'une erreur entraîne la fermeture de DiskPart et l'affichage d'un code d'erreur.
create partition extended create partition extended [size=n] [offset=n] [noerr] Crée une partition étendue sur le lecteur actuel. Une fois la partition créée, le focus se déplace automatiquement sur elle. Une seule partition étendue peut être créée par disque. Cette commande échoue si vous essayez de créer une partition étendue au sein d'une autre partition étendue. Vous devez créer une partition étendue avant de pouvoir créer des lecteurs logiques.
size=n
Spécifie la taille de la partition étendue en mégaoctets (Mo). Si aucune taille n'est donnée, la partition se poursuit jusqu'à ce que l'espace libre de la région soit épuisé. La taille est ajustée aux cylindres : en d'autres termes, elle est arrondie à la limite de cylindre la plus proche. Si, par exemple, vous spécifiez une taille de 500 Mo, la taille de la partition est arrondie à 504 Mo.
offset=n
S'applique uniquement aux disques MBR (Master Boot Record). Spécifie le décalage d'octet par rapport auquel créer la partition étendue. Si aucun décalage n'est fourni, la partition commence au début du premier espace libre sur le disque. Le décalage est ajusté aux cylindres : en d'autres termes, il est arrondi à la limite de cylindre la plus proche. Par exemple, si vous spécifiez un décalage de 27 Mo et que la taille de cylindre est de 8 Mo, le décalage est arrondi à la limite de 24 Mo.
noerr
Pour les scripts uniquement. En cas d'erreur, spécifie que DiskPart continue à traiter les commandes comme si l'erreur ne s'était pas produite. Sans le paramètre noerr, la détection d'une erreur entraîne la fermeture de DiskPart et l'affichage d'un code d'erreur.
create partition logical create partition logical [size=n] [offset=n] [noerr] Crée un lecteur logique dans la partition étendue. Une fois la partition créée, le focus se déplace automatiquement sur le nouveau lecteur logique.
size=n
Taille du lecteur logique en mégaoctets (Mo). Si aucune taille n'est donnée, la partition se poursuit jusqu'à ce que l'espace libre de la région en cours soit épuisé.
offset=n
S'applique uniquement aux disques MBR (Master Boot Record). Spécifie le décalage d'octet par rapport auquel créer le lecteur logique. Le décalage est ajusté aux cylindres ; autrement dit, il est arrondi de manière à remplir entièrement la taille de cylindre utilisée. Si aucun décalage n'est fourni, la partition est placée sur la première extension de disque suffisamment volumineuse pour l'accueillir. La partition est au moins aussi longue en octets que le nombre spécifié par size=n. Si vous spécifiez une taille pour le lecteur logique, elle doit être plus petite que la partition étendue.
noerr
Pour les scripts uniquement. En cas d'erreur, spécifie que DiskPart continue à traiter les commandes comme si l'erreur ne s'était pas produite. Sans le paramètre noerr, la détection d'une erreur entraîne la fermeture de DiskPart et l'affichage d'un code d'erreur.
create partition msr create partition msr [size=n] [offset=n] [noerr] Sur les ordinateurs Itanium, crée une partition réservée Microsoft (MSR) sur un disque GPT (GUID Partition Table).

Attention

  • Utilisez la commande create partition msr avec précaution. Étant donné que les disques GPT nécessitent un format de partition spécifique, la création de partitions réservées Microsoft (MSR) peut rendre le disque illisible. Sur les disques GPT utilisés pour démarrer Windows XP Édition 64 bits ou les versions 64 bits de la famille Windows Server 2003, la partition système EFI est la première partition du disque, suivie de la partition MSR. Les disques GPT utilisés uniquement à des fins de stockage des données ne possèdent pas de partition système EFI et la partition MSR est la première partition.

    Windows XP et la famille Windows Server 2003 ne montent pas de partitions MSR. Vous ne pouvez pas stocker de données sur les partitions réservées Microsoft et vous ne pouvez pas les supprimer.

size=n
Spécifie la taille de la partition en mégaoctets (Mo). La partition est au moins aussi longue en octets que le nombre spécifié par size=n. Si aucune taille n'est donnée, la partition se poursuit jusqu'à ce que l'espace libre de la région en cours soit épuisé.
offset=n
Spécifie le décalage d'octet par rapport auquel créer la partition. La partition démarre au décalage d'octet spécifié par offset=n. Le décalage est ajusté aux secteurs : en d'autres termes, le décalage est arrondi de manière à remplir entièrement la taille de secteur utilisée. Si aucun décalage n'est fourni, la partition est placée sur la première extension de disque suffisamment volumineuse pour l'accueillir.
noerr
Pour les scripts uniquement. En cas d'erreur, spécifie que DiskPart continue à traiter les commandes comme si l'erreur ne s'était pas produite. Sans le paramètre noerr, la détection d'une erreur entraîne la fermeture de DiskPart et l'affichage d'un code d'erreur.
create partition primary create partition primary [size=n] [offset=n] [ID={octet|GUID}] [noerr] Crée une partition principale sur le disque de base actuel. Une fois la partition créée, le focus se déplace automatiquement sur elle. La partition ne reçoit pas de lettre de lecteur ; vous devez utiliser la commande assign pour affecter une lettre de lecteur à la partition.
size=n
Spécifie la taille de la partition en mégaoctets (Mo). Si aucune taille n'est donnée, la partition se poursuit jusqu'à ce que l'espace non alloué de la région en cours soit épuisé. La taille est ajustée aux cylindres : en d'autres termes, elle est arrondie à la limite de cylindre la plus proche. Si, par exemple, vous spécifiez une taille de 500 Mo, la taille de la partition est arrondie à 504 Mo.
offset=n
Spécifie le décalage d'octet par rapport auquel créer la partition. Si aucun décalage n'est fourni, la partition commence au début du premier espace libre sur le disque. Pour les disques MBR (Master Boot Record), le décalage est ajusté aux cylindres ; autrement dit, il est arrondi à la limite de cylindre la plus proche. Par exemple, si vous spécifiez un décalage de 27 Mo et que la taille de cylindre est de 8 Mo, le décalage est arrondi à la limite de 24 Mo.
ID={octet|GUID}
Destiné uniquement aux fabricants d'ordinateurs OEM.

Attention

  • La création de partitions avec ce paramètre peut entraîner une panne de votre ordinateur ou l'empêcher de démarrer. À moins d'être vous-même un fabricant d'ordinateurs OEM ou un informaticien professionnel expérimenté en disques GPT, ne créez pas de partitions sur des disques GPT avec le paramètre ID=octet | GUID. À la place, utilisez toujours la commande create partition efi pour créer des partitions système EFI, la commande create partition msr pour créer des partitions réservées Microsoft et la commande create partition primary (sans le paramètre ID=octet | GUID) pour créer des partitions principales sur des disques GPT.
noerr
Pour les scripts uniquement. En cas d'erreur, spécifie que DiskPart continue à traiter les commandes comme si l'erreur ne s'était pas produite. Sans le paramètre noerr, la détection d'une erreur entraîne la fermeture de DiskPart et l'affichage d'un code d'erreur.

Commentaires

Pour partitionner un disque GPT avec une partition OEM :

  1. Générez un GUID OEM.
  2. Utilisez la commande suivante pour créer une partition EFI :
    Create partition efi size=n
  3. Utilisez la commande suivante pour créer une partition principale :
    Create partition primary size=n ID={octet|GUID}
  4. Utilisez la commande suivante pour créer une partition MSR :
    Create partition MSR size=n

Important

  • Vous devez créer la partition OEM entre les partitions EFI et MSR.
  • Ne créez jamais explicitement les partitions de données ou de métadonnées LDM en tant que partitions. Au lieu de cela, convertissez le disque sélectionné en disque dynamique.

Pour les disques MBR, vous pouvez spécifier un octet de type de partition, sous forme hexadécimale, pour la partition. Si vous ne spécifiez aucun octet de type de partition sur un disque MBR, la commande create partition primary crée une partition de type 0x6. N'importe quel octet de type de partition peut être spécifié avec le paramètre ID=octet | GUID. DiskPart ne vérifie pas la validité de l'octet de type de partition, pas plus qu'il n'effectue de contrôle du paramètre ID.

Pour les disques GPT, vous pouvez spécifier un GUID de type de partition correspondant à la partition que vous voulez créer :

  • Partition système EFI : c12a7328-f81f-11d2-ba4b-00a0c93ec93b
  • Partition réservée Microsoft : e3c9e316-0b5c-4db8-817d-f92df00215ae
  • Partition de données de base : ebd0a0a2-b9e5-4433-87c0-68b6b72699c7
  • Partition de métadonnées LDM sur un disque dynamique : 5808c8aa-7e8f-42e0-85d2-e1e90434cfb3
  • Partition de données LDM sur un disque dynamique : af9b60a0-1431-4f62-bc68-3311714a69ad

Si vous ne spécifiez pas de GUID de type de partition, la commande create partition primary crée une partition de données de base. N'importe quel type de partition peut être spécifié avec le paramètre ID=octet | GUID. DiskPart ne vérifie pas la validité du GUID de partition, pas plus qu'il n'effectue de contrôle du paramètre ID.
create volume raid create volume raid [size=n] [disk=n,n,n[,n,…]] [noerr] Crée un volume RAID-5 sur les disques dynamiques spécifiés (vous devez en spécifier au moins trois). Une fois le volume créé, le focus se déplace automatiquement sur lui.
size=n
Spécifie l'espace disque en mégaoctets (Mo) occupé par le volume sur chaque disque. Si vous ne spécifiez aucune taille, le volume RAID-5 le plus vaste possible est créé. Le disque contenant la plus petite quantité d'espace libre disponible contigu détermine la taille du volume RAID-5 et la même quantité d'espace est allouée à partir de chaque disque. La quantité effective d'espace disque utilisable dans le volume RAID-5 est inférieure à la quantité combinée d'espace disque, car une partie de cet espace est utilisée pour la parité.
disk=n,n,n[,n,…]
Spécifie les disques dynamiques sur lesquels créer le volume. Vous devez disposer au minimum de trois disques dynamiques pour créer un volume RAID-5. Une quantité d'espace égale à size=n est allouée sur chaque disque.
noerr
Pour les scripts uniquement. En cas d'erreur, spécifie que DiskPart continue à traiter les commandes comme si l'erreur ne s'était pas produite. Sans le paramètre noerr, la détection d'une erreur entraîne la fermeture de DiskPart et l'affichage d'un code d'erreur.
create volume simple create volume simple [size=n] [disk=n] [noerr] Crée un volume simple. Une fois le volume créé, le focus se déplace automatiquement sur lui.
size=n
Spécifie la taille du volume en mégaoctets (Mo). Si aucune taille n'est spécifiée, le nouveau volume occupe l'espace disponible restant sur le disque.
disk=n
Spécifie le disque dynamique sur lequel créer le volume. Si aucun disque n'est spécifié, le disque actif est utilisé.
noerr
Pour les scripts uniquement. En cas d'erreur, spécifie que DiskPart continue à traiter les commandes comme si l'erreur ne s'était pas produite. Sans le paramètre noerr, la détection d'une erreur entraîne la fermeture de DiskPart et l'affichage d'un code d'erreur.
create volume stripe create volume stripe [size=n] [disk=n,n[,n,…]] [noerr] Crée un volume agrégé par bandes sur les disques spécifiés (vous devez en spécifier au moins deux). Une fois le volume créé, le focus se déplace automatiquement sur lui.
size=n
Spécifie l'espace disque en mégaoctets (Mo) occupé par le volume sur chaque disque. Si aucune taille n'est spécifiée, le nouveau volume occupe le reste de l'espace disponible sur le plus petit disque et une quantité d'espace égale sur les disques suivants.
disk=n,n[,n,…]
Spécifie les disques dynamiques sur lesquels créer le volume. Vous devez disposer au minimum de deux disques dynamiques pour créer un volume agrégé par bandes. Une quantité d'espace égale à size=n est allouée sur chaque disque.
noerr
Pour les scripts uniquement. En cas d'erreur, spécifie que DiskPart continue à traiter les commandes comme si l'erreur ne s'était pas produite. Sans le paramètre noerr, la détection d'une erreur entraîne la fermeture de DiskPart et l'affichage d'un code d'erreur.
delete disk delete disk [noerr] [override] Supprime un disque dynamique manquant dans la liste des disques.
noerr
Pour les scripts uniquement. En cas d'erreur, spécifie que DiskPart continue à traiter les commandes comme si l'erreur ne s'était pas produite. Sans le paramètre noerr, la détection d'une erreur entraîne la fermeture de DiskPart et l'affichage d'un code d'erreur.
override
Permet à DiskPart de supprimer tous les volumes simples sur le disque. Si le disque contient la moitié d'un volume en miroir, celle-ci est supprimée. La commande delete disk override échoue si le disque appartient à un volume RAID-5.
delete partition delete partition [noerr] [override] Sur un disque de base, supprime la partition qui a le focus. Vous ne pouvez pas supprimer la partition système, la partition de démarrage ou n'importe quelle partition qui contient le fichier d'échange ou le fichier de vidage sur incident (image mémoire) actif.

Attention

  • La suppression d'une partition sur un disque dynamique peut entraîner la suppression de tous les volumes dynamiques du disque ; toutes les données sont donc supprimées et le disque reste dans un état endommagé. Pour supprimer un volume dynamique, vous devez toujours plutôt utiliser la commande delete volume.

Sur des disques dynamiques, vous pouvez supprimer des partitions, mais vous ne devez pas en créer. Par exemple, vous pouvez supprimer une partition GPT (GUID Partition Table) non reconnue sur un disque GPT dynamique. Cependant, la suppression d'une partition de ce type ne transforme pas l'espace libéré obtenu en espace disponible. Cette commande est destinée à permettre de récupérer de l'espace sur un disque dynamique hors connexion et endommagé dans une situation d'urgence où la commande clean ne peut pas être utilisée.

noerr
Pour les scripts uniquement. En cas d'erreur, spécifie que DiskPart continue à traiter les commandes comme si l'erreur ne s'était pas produite. Sans le paramètre noerr, la détection d'une erreur entraîne la fermeture de DiskPart et l'affichage d'un code d'erreur.
override
Permet à DiskPart de supprimer n'importe quelle partition, quel qu'en soit le type. En règle générale, DiskPart vous permet uniquement de supprimer des partitions de données connues.
delete volume delete volume [noerr] Supprime le volume sélectionné. Vous ne pouvez pas supprimer le volume système, le volume de démarrage, ni aucun volume contenant le fichier d'échange ou le fichier de vidage sur incident (image mémoire) actif.
noerr
Pour les scripts uniquement. En cas d'erreur, spécifie que DiskPart continue à traiter les commandes comme si l'erreur ne s'était pas produite. Sans le paramètre noerr, la détection d'une erreur entraîne la fermeture de DiskPart et l'affichage d'un code d'erreur.
detail disk | detail disk | Affiche les propriétés du disque sélectionné et les volumes présents sur ce disque.
detail partition | detail partition | Affiche les propriétés de la partition sélectionnée.
detail volume | detail volume | Affiche les disques sur lesquels le volume actif réside.
exit | exit | Permet de quitter l'interpréteur de commande DiskPart.
extend extend [size=n] [disk=n] [noerr] Étend le volume qui a le focus à l'espace non alloué contigu suivant. Pour les volumes de base, l'espace non alloué doit se trouver sur le même disque et doit suivre la partition qui a le focus (autrement dit, son décalage de secteur doit être plus grand que celui de la partition). Un volume dynamique simple ou fractionné peut être étendu à n'importe quel espace vide sur n'importe quel disque dynamique. Cette commande vous permet d'étendre un volume existant à un espace nouvellement créé.

Si la partition avait précédemment le format du système de fichiers NTFS, le système de fichiers est automatiquement étendu pour occuper la partition de taille plus importante. Il ne se produit aucune perte de données. Si la partition avait précédemment le format d'un système de fichiers différent de NTFS, la commande échoue et aucune modification n'est apportée à la partition.

Vous ne pouvez pas étendre les partitions système ou de démarrage actuelles.

size=n
Spécifie la quantité d'espace, en mégaoctets (Mo), à ajouter à la partition actuelle. Si vous ne spécifiez pas de taille, le disque est étendu à l'ensemble de l'espace non alloué contigu suivant.
disk=n
Spécifie le disque dynamique sur lequel étendre le volume. Une quantité d'espace égale à size=n est allouée sur le disque. Si vous ne spécifiez aucun disque, le volume est étendu sur le disque actif.
noerr
Pour les scripts uniquement. En cas d'erreur, spécifie que DiskPart continue à traiter les commandes comme si l'erreur ne s'était pas produite. Sans le paramètre noerr, la détection d'une erreur entraîne la fermeture de DiskPart et l'affichage d'un code d'erreur.
gpt attributes gpt attributes= n Sur les disques GPT de base, affecte les attributs GPT à la partition qui a le focus. Les attributs de partition GPT fournissent des informations supplémentaires sur l'utilisation de la partition. Certains attributs sont spécifiques au GUID de type de partition.

Important

  • Si vous changez les attributs GPT, vos volumes de données de base risquent de ne pas pouvoir être montés ou l'affectation de lettres de lecteur à ceux-ci peut échouer. À moins d'être vous-même un fabricant d'ordinateurs OEM ou un informaticien professionnel expérimenté en disques GPT, ne changez pas les attributs GPT.
n
Valeur hexadécimale se rapportant à l'attribut que vous voulez appliquer à la partition avec le focus. Le champ d'attribut GPT est un champ 64 bits contenant deux sous-champs. Le champ de niveau supérieur est interprété uniquement dans le contexte de l'ID de partition, tandis que celui de niveau inférieur est commun à tous les ID de partition.

Toutes les partitions ont l'attribut suivant :

0x000000000000001 marque la partition comme étant requise. Il indique à tous les utilitaires de gestion de disques que la partition ne doit pas être supprimée. La partition système EFI ne contient que les binaires nécessaires au démarrage du système d'exploitation. Il est ainsi facile de placer sur d'autres partitions les binaires spécifiques au fabricant d'ordinateurs OEM ou au système d'exploitation.

Pour les partitions de données de base, l'attribut suivant est défini :

0x8000000000000000 empêche l'affectation automatique d'une lettre de lecteur à la partition. Par défaut, une nouvelle lettre de lecteur est affectée à chaque partition. En définissant cet attribut, une nouvelle lettre de lecteur n'est pas automatiquement générée lorsqu'un disque est déplacé vers un nouvel ordinateur. L'utilisateur peut à la place affecter manuellement des lettres de lecteur.

Remarque

  • D'autres attributs peuvent être ajoutés à n'importe quel moment.
help | help | Affiche la liste des commandes disponibles.
import import [noerr] Importe un groupe de disques étrangers dans le groupe de disques de l'ordinateur local. La commande import importe chaque disque qui est dans le même groupe que le disque qui a le focus.
noerr
Pour les scripts uniquement. En cas d'erreur, spécifie que DiskPart continue à traiter les commandes comme si l'erreur ne s'était pas produite. Sans le paramètre noerr, la détection d'une erreur entraîne la fermeture de DiskPart et l'affichage d'un code d'erreur.
inactive inactive Sur les disques MBR (Master Boot Record) de base, marque la partition système ou la partition de démarrage qui a le focus comme étant inactive. Lorsque vous redémarrez l'ordinateur, il démarre à partir de l'option suivante spécifiée dans le BIOS, par exemple le lecteur de CD-ROM ou un environnement de démarrage PXE (Pre-Boot eXecution Environment) comme celui des services d'installation à distance (RIS, Remote Installation Services).

Attention

  • L'ordinateur risque de ne pas pouvoir démarrer sans partition active. Par conséquent, abstenez-vous de marquer comme inactive une partition système ou une partition de démarrage, sauf si vous êtes un utilisateur expérimenté possédant une connaissance approfondie de la famille Windows Server 2003.

    Si vous ne parvenez pas à démarrer l'ordinateur une fois que vous avez marqué la partition système ou la partition de démarrage comme étant inactive, insérez le CD d'installation dans le lecteur de CD-ROM, redémarrez l'ordinateur, puis réparez la partition à l'aide des commandes Fixmbr et Fixboot de la console de récupération.
list disk | list disk | Affiche la liste des disques et des informations les concernant, telles que leur taille, leur quantité d'espace disque disponible, leur nature (de base ou dynamique) et si le disque utilise le style de partition MBR (Master Boot Record) ou GPT (GUID Partition Table). Le disque marqué d'un astérisque (*) a le focus.
list partition | list partition | Affiche les partitions répertoriées dans la table de partition du disque actif. Sur les disques dynamiques, ces partitions peuvent ne pas correspondre aux volumes dynamiques du disque. Cette incohérence s'explique par le fait que les disques dynamiques contiennent des entrées dans la table de partition pour le volume système ou le volume de démarrage (s'il existe sur le disque). Les disques dynamiques contiennent également une partition qui occupe le reste du disque pour réserver l'espace correspondant à l'usage des volumes dynamiques.
list volume | list volume | Affiche la liste des volumes de base et dynamiques sur tous les disques.
online online [noerr] Met en ligne un disque ou un volume hors connexion qui a le focus. Resynchronise le volume en miroir ou RAID-5 qui a le focus.
noerr
Pour les scripts uniquement. En cas d'erreur, spécifie que DiskPart continue à traiter les commandes comme si l'erreur ne s'était pas produite. Sans le paramètre noerr, la détection d'une erreur entraîne la fermeture de DiskPart et l'affichage d'un code d'erreur.
rem rem Permet d'ajouter des commentaires à un script. Exemple :
rem Ces commandes configurent 3 lecteurs.
create partition primary size=2048
assign d:
create partition extend
create partition logical size=2048
assign e:
create partition logical
assign f:
remove remove [{letter=d|mount=chemin_accès|[all]}] [dismount][noerr] Supprime une lettre de lecteur ou un point de montage du volume qui a le focus. Si le paramètre all est utilisé, toutes les lettres de lecteur et tous les points de montage actifs sont supprimés. Si vous ne spécifiez ni lettre de lecteur ni point de montage, DiskPart supprime la première lettre de lecteur ou le premier point de montage qu'il rencontre.

Vous pouvez utiliser la commande remove pour changer la lettre de lecteur associée à un lecteur amovible. Vous ne pouvez pas supprimer les lettres de lecteur des volumes système, de démarrage ou d'échange. De plus, vous ne pouvez pas supprimer la lettre de lecteur d'une partition OEM, d'une partition GPT dont le GUID n'est pas reconnu, ni de toute partition GPT spéciale (non-données) telle que la partition système EFI.

letter=d
Spécifie la lettre de lecteur à supprimer.
mount=chemin_accès
Spécifie le chemin de point de montage à supprimer.
all
Supprime toutes les lettres de lecteur et tous les points de montage actifs.
dismount
Démonte le volume de base lorsque toutes les lettres de lecteur et tous les points de montage ont été supprimés du volume, puis place le volume de base hors connexion, le rendant ainsi non montable. Si d'autres processus utilisent le volume, DiskPart ferme tous les descripteurs ouverts avant de démonter le volume. Pour rendre le volume montable, affectez-lui une lettre de lecteur ou créez un chemin d'accès de point de montage au volume. La commande dismount échoue si elle est utilisée sur un volume qui dispose encore de lettres de lecteur ou de points de montage. Pour les scripts, il est recommandé d'utiliser remove all dismount.
noerr
Pour les scripts uniquement. En cas d'erreur, spécifie que DiskPart continue à traiter les commandes comme si l'erreur ne s'était pas produite. Sans le paramètre noerr, la détection d'une erreur entraîne la fermeture de DiskPart et l'affichage d'un code d'erreur.
repair disk repair disk=n [noerr] Répare le volume RAID-5 qui a le focus en remplaçant le membre RAID-5 défaillant par le disque dynamique spécifié. Le disque dynamique spécifié doit offrir un espace disponible supérieur ou égal à la taille totale du membre RAID-5 défaillant.
n
Spécifie le disque dynamique qui remplace le membre RAID-5 défaillant. Le disque spécifié doit offrir un espace disponible supérieur ou égal à la taille totale du membre RAID-5 défaillant.
noerr
Pour les scripts uniquement. En cas d'erreur, DiskPart continue à traiter les commandes comme si l'erreur ne s'était pas produite. Sans le paramètre noerr, la détection d'une erreur entraîne la fermeture de DiskPart et l'affichage d'un code d'erreur.
rescan | rescan | Repère les nouveaux disques qui peuvent avoir été ajoutés à l'ordinateur.
retain retain Prépare un volume simple dynamique existant à être utilisé en tant que volume système ou de démarrage.

Sur un ordinateur x86, crée une entrée de partition dans l'enregistrement MBR (Master Boot Record) du volume simple dynamique qui a le focus. Pour créer une partition MBR, le volume simple dynamique doit démarrer à un décalage ajusté aux cylindres et avoir une taille égale à un nombre entier de cylindres.

Sur un ordinateur Itanium, crée une entrée de partition dans la table GPT (GUID Partition Table) du volume simple dynamique qui a le focus.

Remarque

  • La commande retain est destinée à être utilisée uniquement au cours d'une installation sans assistance ou par les fabricants d'ordinateurs OEM.
select disk select disk=[n] Sélectionne le disque spécifié et lui donne le focus.
n
Spécifie le numéro du disque qui recevra le focus. Si vous ne spécifiez aucun numéro de disque, la commande select répertorie le disque qui possède actuellement le focus. Vous pouvez afficher les numéros de tous les disques de l'ordinateur à l'aide de la commande list disk.
select partition select partition=[{n|d}] Sélectionne la partition spécifiée et lui donne le focus. Si vous ne spécifiez pas de partition, la commande select répertorie la partition qui possède actuellement le focus. Vous pouvez afficher les numéros de toutes les partitions du disque actif à l'aide de la commande list partition.
n
Spécifie le numéro de la partition qui recevra le focus.
d
Spécifie la lettre de lecteur ou le chemin de point de montage de la partition qui recevra le focus.
select volume select volume=[{n|d}] Sélectionne le volume spécifié et lui donne le focus. Si aucun volume n'est spécifié, la commande select prend en compte le volume qui possède actuellement le focus. Vous pouvez spécifier le volume par numéro, par lettre de lecteur ou par chemin de point de montage. Sur un disque de base, sélectionner un volume donne également le focus à la partition correspondante. Vous pouvez afficher les numéros de tous les volumes de l'ordinateur à l'aide de la commande list volume.
n
Spécifie le numéro du volume qui recevra le focus.
d
Spécifie la lettre de lecteur ou le chemin de point de montage du volume qui recevra le focus.

Pour plus d'informations, consultez Scripts DiskPart.


Scripts DiskPart

L'outil de ligne de commande DiskPart vous permet de créer des scripts pour automatiser des tâches en rapport avec les disques comme la création de volumes ou la conversion de disques en disques dynamiques. La création de scripts qui regroupent ces tâches est utile si vous déployez Windows à l'aide d'une installation sans assistance ou de Sysprep ; en effet, ces modes de déploiement ne prennent pas en charge la création de volumes autres que le volume de démarrage.

Pour plus d'informations sur les scripts DiskPart, consultez « Gestion des disques » dans le Kit de Ressources Techniques Microsoft Windows XP Professionnel.

Pour démarrer un script DiskPart, à l'invite de commandes, tapez :

DiskPart /S nom_script.txt

où nom_script.txt est le nom du fichier texte qui contient votre script.

Pour rediriger la sortie du script DiskPart dans un fichier, tapez :

DiskPart /S nom_script.txt > fichier_journal.txt

où fichier_journal.txt est le nom du fichier texte dans lequel DiskPart écrit la sortie.

Lorsque DiskPart démarre, la version de DiskPart et le nom de l'ordinateur s'affichent à l'invite de commandes. Par défaut, si DiskPart rencontre une erreur en essayant d'effectuer une tâche du script, DiskPart arrête le traitement du script et affiche un code d'erreur (sauf si vous avez spécifié le paramètre noerr). Toutefois, DiskPart renvoie toujours les erreurs de syntaxe rencontrées, que vous ayez ou non spécifié le paramètre noerr. Le paramètre noerr vous permet d'effectuer des tâches utiles comme utiliser un seul script pour supprimer l'ensemble des partitions de tous les disques, quel qu'en soit le nombre.

Le tableau suivant répertorie les codes d'erreur de DiskPart :

Erreur | Description
0 | Aucune erreur ne s'est produite. La totalité du script s'est exécutée sans erreur.
1 | Une exception fatale s'est produite. Il peut y avoir un problème grave.
2 | Les paramètres spécifiés pour une commande DiskPart ne sont pas corrects.
3 | DiskPart n'a pas pu ouvrir le script ou le fichier de sortie spécifié.
4 | Un des services utilisés par DiskPart a renvoyé une erreur.
5 | Une erreur de syntaxe de commande s'est produite. Le script a échoué, car un objet a été sélectionné de manière incorrecte ou ne pouvait pas être utilisé avec cette commande.


Options de la ligne de commande Winnt32.exe

À partir d'une invite de commandes, utilisez Winnt32.exe pour démarrer le programme d'installation de Windows depuis un ordinateur qui exécute un des systèmes d'exploitation suivants :

  • Windows Server 2003
  • Windows XP
  • Windows 2000
  • Windows NT, (Service Pack 5 ou ultérieur)
  • Windows Millennium Edition
  • Windows 98
  • Windows 95

Remarques

  • Si vous déployez Windows XP sur des ordinateurs clients, utilisez la version de Winnt32.exe qui accompagne Windows XP. Une autre manière de déployer Windows XP consiste à utiliser Winnt32.msi, qui fait appel à Microsoft® Windows® Installer, partie intégrante de l'ensemble de technologies IntelliMirror. Pour plus d'informations sur les déploiements de clients, consultez le Kit de déploiement Windows Server 2003.
  • Si vous exécutez winnt32 sur un ordinateur équipé d'un processeur Itanium, la commande peut être exécutée à p artir d'une Extensible Firmware Interface (EFI) ou de Windows XP (mais non à partir d'un système d'exploitation antérieur). D'autre part, sur un ordinateur doté d'un processeur Itanium, /cmdcons et /syspart ne sont pas disponibles, de même que les options de mise à niveau.

La syntaxe de la commande Winnt32 est la suivante :

winnt32 [/checkupgradeonly] [/cmd:ligne_commande] [/cmdcons] [/copydir:{i386|ia64}\nom_dossier] [/copysource:nom_dossier] [/debug[niveau ]:[nom_fichier]] [/dudisable] [/duprepare:chemin] [/dushare:chemin] [/emsport:{com1|com2|usebiossettings|off}] [/emsbaudrate:débit_en_bauds] [/m:nom_dossier] [/makelocalsource] [/noreboot] [/s:cheminsource] [/syspart:lettre_lecteur:] [/tempdrive:lettre_lecteur:] [/udf:id [,fichier_UDB ]] [/unattend[num]:[fichier_réponse]]

Dans cet exemple :

Option | Action
/checkupgradeonly Vérifie la compatibilité de mise à niveau de votre ordinateur avec cette version de Windows.

Si vous utilisez cette option avec /unattend, aucune entrée n'est requise de la part de l'utilisateur. Sinon, les résultats s'affichent, et vous pouvez les enregistrer dans un fichier dont vous spécifiez le nom. Le nom de fichier par défaut est Upgrade.txt dans le dossier %SYSTEMROOT%.
/cmd:ligne_commande | Demande au programme d'installation d'exécuter une commande spécifique avant la phase finale de l'installation. Cette exécution a lieu après le redémarrage de votre ordinateur et une fois que le programme d'installation a collecté les informations de configuration nécessaires, mais avant la fin de l'installation.
/cmdcons | Installe la console de récupération comme option de démarrage sur un ordinateur x86 qui fonctionne. La console de récupération est une interface de ligne de commande d'où vous pouvez effectuer des tâches, telles que le démarrage et l'arrêt des services, ou l'accès au disque local (y compris les disques formatés avec NTFS). L'option /cmdcons ne peut être utilisée qu'une fois l'installation terminée.
/copydir:{i386|ia64}\nom_dossier Crée un ou plusieurs dossiers supplémentaires à l'intérieur du dossier où les fichiers Windows sont installés.

Nom_dossier désigne un dossier que vous avez créé en vue d'y placer les modifications relatives à votre site uniquement. Par exemple, pour les ordinateurs x86, créez un dossier appelé Pilotes_privés dans le dossier source i386 de votre installation et placez-y les fichiers des pilotes. Tapez ensuite /copydir:i386\Pilotes_privés pour que le programme d'installation copie ce dossier sur l'ordinateur récemment installé ; l'emplacement du nouveau dossier est %SYSTEMROOT%\Pilotes_privés. Utilisez /copydir pour créer autant de dossiers supplémentaires que vous le souhaitez.
/copysource:nom_dossier Crée un ou plusieurs dossiers temporaires à l'intérieur du dossier où les fichiers Windows sont installés.

Nom_dossier désigne un dossier que vous avez créé en vue d'y placer les modifications relatives à votre site uniquement. Par exemple, créez un dossier appelé Pilotes_privés dans le dossier source de votre installation et placez-y les fichiers des pilotes. Tapez ensuite /copysource:Pilotes_privés pour que le programme d'installation copie ce dossier sur l'ordinateur récemment installé et utilise ses fichiers durant l'installation ; l'emplacement du dossier temporaire est %SYSTEMROOT%\Pilotes_privés. Contrairement aux dossiers créés par /copydir, les dossiers /copysource sont supprimés une fois l'installation terminée.
/debug[niveau]:[NomFichier] | Crée un journal de débogage au niveau spécifié, par exemple, /debug4:Débogage.log. Le fichier journal par défaut est C:\%SYSTEMROOT%\Winnt32.log, avec un niveau de débogage défini à 2 par défaut. Les niveaux du journal sont les suivants : 0 représente les erreurs graves, 1 les erreurs, 2 les avertissements, 3 les informations et 4 les informations détaillées pour le débogage. Chaque niveau englobe les niveaux inférieurs.
/dudisable | Empêche l'exécution de Windows Update. Sans Windows Update, le programme d'installation s'exécute uniquement avec les fichiers d'installation d'origine. Cette option désactive Windows Update même si vous définissez DUDisable comme étant égal à No dans la section [Unattended] du fichier Unattend.txt.
/duprepare:NomChemin | Prépare un partage de distribution afin qu'il puisse être utilisé avec les fichiers Windows Update téléchargés à partir du site Web Windows Update. Vous pouvez utiliser ce partage de distribution pour installer Windows sur plusieurs clients.
/dushare:NomChemin | Spécifie un partage de distribution sur lequel vous avez précédemment téléchargé des fichiers Windows Update (fichiers mis à jour à utiliser avec le programme d'installation) à partir du site Web Windows Update et sur lequel vous avez préalablement exécuté /duprepare:nomchemin. Lorsque cette option est exécutée sur un client, l'installation cliente utilise les fichiers mis à jour sur le partage de distribution spécifié dans la variable nomchemin.
/emsbaudrate:DébitEnBauds Pour les ordinateurs x86, spécifie le débit en bauds des services EMS. (Cette option n'est pas applicable aux ordinateurs dotés de processeurs Itanium.) Doit être utilisée avec /emsport:com1 ou /emsport:com2 (sinon, /emsbaudrate est ignoré).

DébitEnBauds peut prendre les valeurs 9600, 19200, 57600 ou 115200. 9600 est la valeur par défaut.
/emsport:{com1|com2|usebiossettings|off} Active ou désactive les services de gestion d'urgence (EMS, Emergency Management Services) pendant l'exécution du programme d'installation et après l'installation d'un système d'exploitation de la famille Windows Server 2003. Avec ces services, vous pouvez gérer à distance un serveur dans des situations d'urgence qui nécessitent normalement un clavier, une souris et un écran locaux, par exemple lorsque le réseau est indisponible ou que le serveur ne fonctionne pas correctement. Les services EMS exigent une configuration matérielle spécifique et ne sont disponibles que pour les produits de la famille Windows Server 2003.

La valeur par défaut usebiossettings utilise le paramètre spécifié dans la table SPCR (Serial Port Console Redirection) du BIOS ou, dans les systèmes Itanium, par le biais du chemin de périphérique de console EFI (Extensible Firmware Interface). Si vous spécifiez usebiossettings et qu'aucune table SPCR ni aucun chemin de périphérique de console EFI approprié n'est disponible, les services de gestion d'urgence ne sont pas activés.

Com1 et com2 s'appliquent uniquement aux ordinateurs x86 (pas aux ordinateurs dotés de processeurs Itanium).

Si vous désactivez les services EMS en spécifiant /emsport:off, vous pourrez les activer ultérieurement en modifiant les paramètres de démarrage. Pour obtenir des informations sur la modification des paramètres de démarrage, consultez le Kit de ressources techniques de Windows XP Professionnel.
/m:nom_dossier | Spécifie que le programme d'installation copie des fichiers de remplacement à partir d'un autre emplacement. Demande au programme d'installation de rechercher d'abord des fichiers dans l'autre emplacement et, si des fichiers sont présents, de les utiliser à la place des fichiers qui se trouvent dans l'emplacement par défaut.
/makelocalsource | Demande au programme d'installation de copier tous les fichiers source d'installation vers votre lecteur de disque dur local. Utilisez /makelocalsource lorsque vous effectuez l'installation à partir d'un CD-ROM pour rendre les fichiers d'installation accessibles au cas où le CD-ROM ne serait pas disponible à une phase ultérieure de l'installation.
/noreboot | Demande au programme d'installation de ne pas redémarrer l'ordinateur une fois que la phase de copie de fichiers du programme d'installation est terminée afin de vous permettre d'exécuter une autre commande.
/s:CheminSource Spécifie l'emplacement des fichiers Windows. Pour copier simultanément des fichiers provenant de plusieurs serveurs, tapez l'option /s:CheminSource plusieurs fois (huit fois maximum). Par exemple :
winnt32 /s:serveur1 /s:serveur2

Si vous tapez cette option plusieurs fois, le premier serveur spécifié doit être disponible car, si cela n'est pas le cas, l'installation échoue.
/syspart:lettre_lecteur: Sur un ordinateur x86, spécifie que vous pouvez copier les fichiers de démarrage du programme d'installation sur un lecteur de disque dur, marquer ce disque comme étant actif, puis l'installer dans un autre ordinateur. Lorsque vous démarrerez cet ordinateur, il commence automatiquement par la phase suivante de l'installation. Veillez à toujours associer le paramètre /tempdrive au paramètre /syspart.

Vous pouvez démarrer Winnt32 avec l'option /syspart sur un ordinateur x86 exécutant Windows NT 4.0, Windows 2000 ou Windows XP. L'ordinateur sur lequel vous exécutez cette commande ne doit pas fonctionner sous Windows 95, Windows 98 ou Windows Millenium Edition.
/tempdrive:lettre_lecteur: Indique au programme d'installation de placer les fichiers temporaires dans une partition spécifiée. Lors d'une nouvelle installation, Windows s'installe dans la partition spécifiée. S'il s'agit d'une mise à niveau, l'option /tempdrive affecte l'emplacement des fichiers temporaires uniquement ; le système d'exploitation est lui mis à niveau dans la partition à partir de laquelle vous avez exécuté la commande winnt32.
/udf:id[,ficher_UDB] Indique un identificateur (id) que le programme d'installation utilise pour spécifier la façon dont un fichier de base de données d'unicité (UDB, Uniqueness Database) modifie un fichier de réponses (consultez l'entrée /unattend).

Le fichier UDB remplace les valeurs du fichier de réponses, et l'identificateur détermine quelles valeurs du fichier UDB sont utilisées. Par exemple, /udf:RAS_user,Notre_société.udb remplace des paramètres spécifiés pour l'identificateur RAS_user dans le fichier Notre_société.udb. Si aucun fichier_UDB n'est spécifié, le programme d'installation invite l'utilisateur à insérer un disque contenant le fichier $Unique$.udb.

Si vous démarrez l'ordinateur à partir du CD-ROM du produit Windows pour exécuter une installation sans assistance, vous ne pouvez pas utiliser l'option de ligne de commande /udf pour Winnt32.exe.
/unattend | Sur un ordinateur à processeur x86, met à niveau l'ancienne version de Windows 98, Windows Millenium Edition, Windows NT 4.0 ou Windows 2000 en mode sans assistance. Le programme d'installation télécharge les fichiers Windows Update depuis Windows Update et inclut ces fichiers dans l'installation. Tous les paramètres utilisateur restent les mêmes que ceux de l'ancienne installation ; aucune intervention de l'utilisateur n'est donc requise pendant l'installation.
/unattend[nombre]:[fichier_réponses] Exécute une nouvelle installation de Windows en mode sans assistance. Le programme d'installation télécharge les fichiers Windows Update depuis le site Web Windows Update et inclut ces fichiers dans l'installation. Le fichier_réponses spécifié fournit au programme d'installation vos spécifications personnalisées.
nombre
Spécifie le nombre de secondes entre le moment où le programme d'installation finit de copier les fichiers et le moment où il redémarre. Vous pouvez utiliser nombre sur n'importe quel ordinateur exécutant Windows 98, Windows Me, Windows NT, Windows 2000 ou Windows XP.
fichier_réponses
Spécifie le nom du fichier de réponses.

En utilisant l'option de ligne de commande /unattend pour automatiser l'installation, vous confirmez que vous avez lu et accepté les termes du Contrat de Licence Utilisateur Final (CLUF) de Windows. Avant d'utiliser cette option de ligne de commande pour installer Windows pour le compte d'une autre société que la vôtre, vous devez confirmer que l'utilisateur final (particulier ou entité unique) a reçu, lu et accepté les termes du Contrat de Licence Utilisateur Final Microsoft pour Windows.

Pour plus d'informations sur Winnt32.exe, consultez Utilisation de Winnt32.exe pour lancer l'installation.


Options de la ligne de commande Winnt.exe

À partir d'une invite de commande, utilisez Winnt.exe pour démarrer le programme d'installation de Windows depuis un ordinateur qui exécute un des systèmes d'exploitation suivants :

  • MS-DOS
  • Windows 3.1
  • Windows pour Workgroups

La syntaxe de la commande Winnt est la suivante :

winnt [/s:[CheminSource]] [/t:[LecteurTemp]] [/u:[fichier_réponses]] [/udf:id [,fichier_UDB]] [/r:dossier] [/rx:dossier] [/e:commande] [/a]

Option | Action
/s:CheminSource | Spécifie l'emplacement source des fichiers Windows. Cet emplacement doit correspondre à un chemin d'accès complet de la forme x:\[chemin] ou \\serveur\partage[\chemin]. Le paramètre par défaut est le dossier en cours.
/t:LecteurTemp | Indique au programme d'installation de placer les fichiers temporaires sur le lecteur spécifié et d'installer Windows sur ce lecteur. Si vous ne spécifiez aucun emplacement, le programme d'installation essaie de rechercher un lecteur à votre place.
/u:fichier_réponses | Exécute une installation en mode sans assistance avec un fichier de réponses. Le fichier de réponses répond à une partie ou à la totalité des questions que des messages posent normalement à l'utilisateur final au cours de l'installation. Si vous utilisez /u, vous devez également obligatoirement utiliser /s.
/udf:id [,fichier_UDB] | Indique un identificateur (id) que le programme d’installation utilise pour spécifier la façon dont un fichier de base de données d'unicité (UDB, Uniqueness Database) modifie un fichier de réponses (voir /u). Le fichier UDB remplace les valeurs du fichier de réponses et l'identificateur détermine les valeurs du fichier UDB à utiliser. Si aucun fichier_UDB n'est spécifié, le programme d'installation invite l'utilisateur à insérer un disque contenant le fichier $Unique$.udb. Par exemple, /udf:RAS_user,Notre_société.udb remplace les paramètres spécifiés pour l'identificateur RAS_user dans le fichier Notre_société.udb.
/r:dossier | Spécifie un dossier facultatif à installer. Le dossier n'est pas supprimé en fin d'installation.
/rx:dossier | Spécifie un dossier facultatif à copier. Le dossier est supprimé en fin d'installation.
/e:commande | Spécifie une commande à exécuter après l'installation en mode graphique.
/a | Active les options d'accessibilité.

Pour plus d'informations sur Winnt.exe, consultez Utilisation de Winnt.exe pour lancer l'installation et Conversion des noms de fichiers courts en noms de fichiers longs.


Glossaire

Symboles A B C D E F G H I J K L M N O P Q R S T U V W X YZ

Symboles

$$Rename.txt

Un fichier qui établit la liste de tous les fichiers contenus dans un dossier particulier qui doit être renommé à partir d'un format de nom 8.3 vers un format long durant l'Installation. Tous les noms de fichiers doivent être au format 8.3 si vous lancez l'installation par Winnt.exe ou si vous copiez des fichiers d'un ordinateur à un autre en utilisant MS-DOS.

%windir%

Répertoire par défaut où Windows est installé, soit le plus souvent C:\winnt.

.adm

L'extension de nom de fichier pour les fichiers modèles d'administration.

100baseT

Standard Ethernet pour les réseaux locaux qui utilisent des câbles à paire torsadée transportant les données à 100 Mbits/s.

8.3

Format standard pour les noms de fichiers dans MS-DOS et Windows 3.1. Ce format se compose d'un nom de fichier de 8 caractères au maximum suivi d'un point et d'une extension de trois caractères.

A

accès à distance

Élément du Service de routage et d'accès distant qui fournit l'accès réseau distant aux télétravailleurs, aux employés itinérants et aux administrateurs système qui surveillent et gèrent des serveurs de plusieurs succursales. Les utilisateurs peuvent utiliser Connexions réseau pour composer un numéro permettant d'accéder à distance à leurs réseaux afin d'utiliser des services tels que le partage de fichiers et d'imprimantes, le courrier électronique, le planning et les bases de données SQL.

Voir aussi : serveur d'accès distant ; service

Accès réseau à distance

Connexion à un réseau distant ou à Internet via une connexion d'accès à distance, par exemple un modem.

Accueil de Windows

La première expérience de l'utilisateur final avec Microsoft Windows dans Windows XP Édition familiale et Windows XP Professionnel. Par le biais d'une série d'écrans et de pages au format HTML, l'Accueil de Windows accompagne l'utilisateur final durant les dernières étapes de l'installation de son ordinateur personnel. Les utilisateurs sont invités à fournir d'autres informations nécessaires à la personnalisation de leurs paramètres, entre autres les options régionales et celle concernant les langues, la configuration du réseau (le cas échéant) et les paramètres de connexion à Internet. L'Accueil de Windows est précédemment connu sous le nom de Première Expérience (OOBE)

ACPI

Voir la définition pour : interface de configuration et d'énergie avancée (ACPI, Advanced Configuration and Power Interface)

activation

Voir la définition pour : Activation de produit Windows

activation de produit

Voir la définition pour : Activation de produit Windows

Activation de produit Windows

Technologie qui réduit le piratage de logiciels en requérant que chaque installation d'un produit Windows soit activée par Microsoft, soit par téléphone, soit par Internet. Une clé unique de produit est requise pour chaque installation de Windows mais Microsoft ne requiert pas ou ne relève par d'autres informations que la clé du produit pour l'installation. L'utilisateur final peut réinstaller Windows en utilisant la même clé de produit sur le même ordinateur autant de fois que nécessaire mais il ne peut le faire sur un autre ordinateur. L'utilisateur final peut effectuer des mises à niveau incrémentielles de son matériel. Toutefois, si le matériel est modifié en profondeur, l'utilisateur final se verra demandé de réactiver l'installation de Windows.

Active Directory

Le service d'annuaire qui renferme des informations relatives aux objets d'un réseau et met celles-ci à la disposition des utilisateurs et des administrateurs réseau. Active Directory permet aux utilisateurs réseau d'accéder aux ressources autorisées partout sur le réseau à l'aide d'une simple procédure d'ouverture de session. Il fournit aux administrateurs réseau une vue hiérarchique intuitive du réseau et un point d'administration unique de l'ensemble des objets du réseau.

Voir aussi : domaine ; forêt

administrateur

Dans Windows XP Professionnel et Windows XP Édition familiale, personne chargée d'effectuer les modifications système sur l'ordinateur local. Par exemple, sur l'ordinateur local, un administrateur peut installer un logiciel, gérer des comptes d'utilisateurs et de groupes locaux, assigner des mots de passe et des autorisations et gérer les fichiers locaux.

Dans Windows XP Professionnel, les administrateurs sont membres du groupe Administrateurs local et possèdent un contrôle total de l'ordinateur local.

Voir aussi : autorisation ; compte de groupe ; compte d'utilisateur ; contrôleur de domaine ; mot de passe

adresse Internet

Adresse d'une ressource Internet qui est utilisée par les navigateurs Web pour rechercher des ressources Internet. Une adresse Internet commence habituellement par un nom de protocole, suivi par le nom de l'organisation qui gère le site ; le suffixe identifiant le type d'organisation. Par exemple, l'adresse http://www.yale.edu/ fournit les informations suivantes :

  • http : Ce serveur Web utilise le protocole HTTP (Hypertext Transfer Protocol).
  • www : Ce site se situe sur le Web.
  • edu : Il s'agit d'un établissement d'enseignement.
L'adresse Internet est également appelée URL (Uniform Resource Locator).

Voir aussi : protocole ; serveur Web

adresse IP

Adresse 32 bits utilisée pour identifier un nœud au sein d'un réseau d'interconnexion IP. Chaque nœud du réseau d'interconnexion IP doit posséder une adresse IP unique, composée de l'ID réseau et d'un ID hôte unique. En règle générale, la valeur décimale de chaque octet est séparée par un point (par exemple, 192.168.7.27). Vous pouvez configurer l'adresse IP de manière statique ou dynamique à l'aide du protocole DHCP.

Voir aussi : adresse IP ; nœud ; protocole DHCP (Dynamic Host Configuration Protocol)

adresse mémoire

Partie de la mémoire d'un ordinateur qui peut être allouée à un périphérique ou utilisée par un programme ou le système d'exploitation. Une plage d'adresses mémoire est généralement allouée au périphérique.

Voir aussi : périphérique

algorithme de hachage

Algorithme utilisé pour obtenir une valeur de hachage de certains éléments de données, notamment une clé de session ou de message. Un bon algorithme de hachage possède une qualité qui fait que toute modification des données d'entrée peut entraîner la modification de chaque bit de la valeur de hachage résultante. Pour cette raison, les hachages sont utiles dans la détection des modifications apportées à un grand objet de données, notamment un message. En outre, un bon algorithme de hachage rend impossible la construction, par calculs, de deux entrées indépendantes qui possèdent le même hachage. Les algorithmes de hachage habituels sont MD2, MD4, MD5 et SHA-1. Également appelé fonction de hachage.

ancrer

Connecter un ordinateur portable à une station d'accueil.

Voir aussi : station d'accueil

anti-crénelage

Technique logicielle de lissage de l'apparence en escalier des lignes courbes ou diagonales causée par la résolution faible sur un écran d'affichage. Les méthodes d'anti-crénelage mettent en jeu des pixels entourant avec des nuances intermédiaires et la manipulation de la taille et de l'alignement horizontal des pixels.

API

Voir la définition pour : interface de programmation d'applications (API)

API de téléphonie (TAPI)

Interface de programmation d'application (API, Application Programming Interface) utilisée par les programmes de communication pour exploiter les services réseau et de téléphonie. Les programmes de communication, notamment HyperTerminal et le Numéroteur téléphonique utilisent TAPI pour numéroter, répondre et acheminer les appels téléphoniques sur des équipements téléphoniques standard, notamment des centraux, des modems et des télécopieurs. TAPI 3.0 assure aussi la prise en charge de la téléphonie IP (Internet Protocol), qu'utilisent le Numéroteur téléphonique et d'autres programmes pour transmettre, acheminer et contrôler en temps réel les signaux audio et vidéo sur les réseaux IP, notamment sur Internet.

Voir aussi : interface de programmation d'applications (API) ; modem (modulateur/démodulateur) ; Protocole Internet (IP) ; service

APIC

Contrôleur avancé d'interruptions programmables. Jeu distribué de périphériques qui constituent un contrôleur d'interruptions.

APIPA (Automatic Private IP Addressing)

Fonctionnalité TCP/IP de Windows XP et des produits de la famille Windows Server 2003 qui configure automatiquement une adresse IP unique, située dans une plage allant de 169.254.0.1 à 169.254.255.254, et un masque de sous-réseau de 255.255.0.0 lorsqu'aucun serveur DHCP (Dynamic Host Configuration Protocol) n'est disponible alors que le protocole TCP/IP est configuré pour l'adressage dynamique. La plage d'adresses IP APIPA est réservée par l'IANA (Internet Assigned Numbers Authority), et les adresses IP qui en font partie ne sont pas utilisées sur Internet.

Voir aussi : adresse IP ; protocole DHCP (Dynamic Host Configuration Protocol) ; protocole TCP/IP (Transmission Control Protocol/Internet Protocol) ; serveur DHCP

apparence

Interface utilisateur personnalisée qui recouvre une interface utilisateur existante.

AppleTalk

Voir la définition pour : protocole AppleTalk

application RunOnce

Application configurée pour être exécutée la prochaine fois que l'ordinateur redémarre. L'application ne s'exécute plus après d'autres redémarrages.

apposition de marque OEM

Actions consistant à incorporer un nom de société, un logo, des informations de support technique et des fichiers d'aide dans le programme d'installation de Microsoft Windows.

arborescence de console

Volet gauche de la console MMC (Microsoft Management Console) qui affiche les éléments contenus dans la console. Les éléments de l'arborescence de la console ainsi que leur organisation hiérarchique déterminent les possibilités d'une console.

Voir aussi : MMC (Microsoft Management Console)

arborescence de domaine

Dans DNS, structure de l'arborescence hiérarchique inversée utilisée pour indexer les noms de domaines. Dans leur but et leur concept, les arborescences de domaines sont identiques aux arborescences de répertoires utilisées par les systèmes de fichiers des ordinateurs pour le stockage sur les disques. Par exemple, lorsque de nombreux fichiers sont stockés sur un disque, les répertoires peuvent être utilisés pour organiser les fichiers de façon logique. Lorsqu'une arborescence de domaine comprend plusieurs branches, chaque branche peut organiser en ensembles logiques des noms de domaines utilisés dans l'espace de noms.

Dans Active Directory, structure hiérarchique d'un ou plusieurs domaines liés par des relations d'approbations bidirectionnelles et transitives formant un espace de noms contigu. Les arborescences de domaines multiples peuvent appartenir à la même forêt.

Voir aussi : Active Directory ; domaine ; forêt ; nom de domaine

arborescence du matériel

Enregistrement dans la mémoire vive (RAM) de la configuration système actuelle basée sur les informations concernant tous les périphériques de la branche sur le matériel du registre. L'arborescence du matériel est créée à chaque démarrage du système, ou dès qu'une modification dynamique est apportée à la configuration du système.

Voir aussi : branche matérielle

ASCII (American Standard Code for Information Interchange)

Schéma de codage standard de caractères à un octet utilisé pour les données à base de texte. ASCII utilise des combinaisons de nombres 7 bits ou 8 bits désignés pour représenter 128 ou 256 caractères possibles. L'ASCII Standard utilise 7 bits pour représenter toutes les lettres majuscules et minuscules, les chiffres 0 à 9, les signes de ponctuation et les caractères de contrôle spéciaux utilisés en anglais (États-Unis). La plupart des ordinateurs actuels bâtis autour d'un processeur x86 prennent en charge l'utilisation des codes ASCII étendus (« supérieurs »). Les codes ASCII étendus permettent d'utiliser le huitième bit de chaque caractère pour identifier 128 caractères (symbole) spéciaux supplémentaires, des lettres de langues étrangères ainsi que des symboles graphiques.

Voir aussi : Unicode

Assistant Nouvelle connexion

Outil qui aide les utilisateurs à s'inscrire à un service Internet et prend automatiquement en charge les étapes de configuration logicielle nécessaire pour pouvoir accéder à Internet.

asynchrone

Non dépendant du temps. Chaque application ou commande est exécutée dans l'ordre spécifié, mais l'élément spécifié n'attend pas qu'un quelconque processus démarré préalablement se termine avant que l'application ou la commande ne soit exécutée.

attacher

Exécute le programme d'installation pour une application déjà présente sur l'ordinateur de destination.

Voir aussi : détacher ; ordinateur de destination ; stade

attribut

Pour les fichiers, informations qui indiquent si un fichier est en lecture seule, caché, prêt pour l'archivage (sauvegarde), compressé ou crypté, et si le contenu de ce fichier doit être indexé pour la recherche rapide des fichiers.

Dans Active Directory, un attribut est une propriété d'un objet. Pour chaque classe d'objet, le schéma définit les attributs que doit posséder une instance de la classe et ceux qu'elle pourrait avoir en plus.

Voir aussi : objet

authentification

Processus de vérification de la nature réelle ou prétendue d'une entité ou d'un objet. L'authentification consiste par exemple à confirmer la source et l'intégrité des informations, vérifier une signature numérique ou l'identité d'un utilisateur ou d'un ordinateur.

Voir aussi : carte à puce

autorisation

Règle associée à un objet en vue de déterminer les utilisateurs qui peuvent accéder à l'objet et la manière qu'ils doivent employer. Les autorisations sont accordées ou refusées par le propriétaire de l'objet.

Voir aussi : objet

Autorité de certification (CA, Certification Authority)

Entité chargée de garantir l'authenticité des clés publiques qu'elle émet pour des sujets (habituellement des utilisateurs ou des ordinateurs) ou d'autres Autorités de certification. Parmi les activités d'une Autorité de certification, citons la liaison des clés publiques aux noms uniques au moyen de certificats signés, la gestion des numéros de série des certificats et la révocation de ceux-ci.

Voir aussi : Autorité de certification racine ; certificat ; clé publique

Autorité de certification racine

Autorité de certification la plus digne de confiance, située au sommet de la hiérarchie de certification. L'Autorité de certification racine possède un certificat auto-signé. Également appelée autorité racine.

Voir aussi : Autorité de certification (CA, Certification Authority) ; racine

autotest de mise en route (POST, power-on self test)

Un ensemble de routines stockées en mémoire morte (ROM) qui teste différents composants système tels que la mémoire vive, les disques et le clavier pour vérifier qu'ils sont correctement connectés et qu'ils fonctionnent. Si des problèmes sont rencontrés, ces routines préviennent l'utilisateur par le biais de signaux sonores ou d'un message, qui sont souvent accompagnés d'une valeur numérique de diagnostique. Si la publication est réussie, il passe le contrôle au chargeur de démarrage.

Voir aussi : chargeur de démarrage

B

bail

Durée pendant laquelle un client DHCP peut utiliser une configuration d'adresse IP affectée dynamiquement. Avant l'expiration du bail, le client doit renouveler le bail ou en obtenir un nouveau avec DHCP.

Voir aussi : adresse IP ; protocole DHCP (Dynamic Host Configuration Protocol)

bande passante

Dans les communications analogiques, différence entre les fréquences les plus hautes et les plus basses au sein d'une plage spécifique. Une ligne téléphonique analogique, par exemple, prend en charge une bande passante de 3 000 Hertz (Hz), qui correspond à la différence entre la fréquence la plus basse (300 Hz) et la plus haute (3 300 Hz) qu'elle peut acheminer. Pour les communications numériques, la bande passante est exprimée en bits par seconde (b/s).

Voir aussi : bits par seconde (bits/s)

bibliothèque de liaison dynamique (DLL, Dynamic-link Library)

Fonctionnalité du système d'exploitation qui permet à des routines exécutables (qui assument généralement une fonction ou un ensemble de fonctions déterminé) d'être stockées séparément sur la forme de fichiers portant l'extension .dll. Ces routines ne sont chargées qu'au moment requis par le programme qui les appelle.

Bibliothèque de pilotes Windows (WDL, Windows Driver Library)

Un point de distribution sur www.microsoft.com pour les pilotes de tiers qui répondent aux normes du logo Windows.

bidi

Texte bidirectionnel. Association de caractères dont certains sont lus de gauche à droite, et d'autres de droite à gauche. Par exemple, la plupart des textes en arabe, en hébreu, en farsi ou en urdu sont lus de droite à gauche, mais les nombres ou les citations de langues occidentales au sein de ces textes sont lus de gauche à droite.

BIOS

Voir la définition pour : BIOS (basic input/output system)

BIOS (basic input/output system)

Sur les ordinateurs de type x86, ensemble des principales routines logicielles qui testent le matériel au démarrage, démarrent le système d'exploitation et prennent en charge le transfert des données entre les périphériques. Le BIOS est stocké dans une mémoire morte (MEM) afin de pouvoir être exécuté au moment de la mise sous tension de l'ordinateur. Bien qu'il revête une importance critique au niveau des performances, le BIOS est généralement invisible aux yeux des utilisateurs de l'ordinateur.

Voir aussi : interface EFI (Extensible Firmware Interface) ; mémoire morte (ROM) ; x86

BIOS Plug-and-Play

BIOS responsable lors du démarrage de la configuration des cartes et périphériques de carte mère répondant à la norme Plug-and-Play. Fournit des services de configuration à l'exécution pour les périphériques de carte mère après le démarrage.

Voir aussi : BIOS ; carte système ; interface de configuration et d'énergie avancée (ACPI, Advanced Configuration and Power Interface)

bit (chiffre binaire)

Plus petite unité d'information gérée par un ordinateur. Un bit exprime le nombre binaire 1 ou 0, ou encore la condition logique vrai ou faux. Un groupe de 8 bits constitue un octet, qui peut représenter de nombreux types d'informations, notamment une lettre de l'alphabet, un chiffre décimal ou un autre caractère. Autre nom : chiffre binaire.

bitmap

Format de fichier pour les images servant à personnaliser les graphiques dans un kit IEAK (Internet Explorer Administration Kit).

bits par seconde (bits/s)

Nombre de bits transmis par seconde. Mesure la vitesse à laquelle un périphérique, notamment un modem, peut transférer des données.

Voir aussi : modem (modulateur/démodulateur)

branche matérielle

Clé de la racine d'archive matérielle dans le Registre, qui est un sur-ensemble de l'arborescence matérielle résidente en mémoire. Bien que l'arborescence matérielle ne contienne d'informations que sur ceux des périphériques qui sont actuellement détectés et qui fonctionnent dans le système, le Registre contient une liste complète de tous les matériels qui ont jamais été installés sur l'ordinateur considéré. La clé de la racine matérielle est \\HKEY-LOCAL-MACHINE\Hardware.

Bureau

Zone de travail de l'écran dans laquelle apparaissent les fenêtres, les icônes, les menus et les boîtes de dialogue.

bus

Ligne de communication utilisée pour le transfert de données entre les composants d'un ordinateur. Fondamentalement, le bus permet le partage des données entre les différents éléments de l'ordinateur. Par exemple, un bus connecte un contrôleur de lecteur de disque, la mémoire et les ports d'entrée/sortie au microprocesseur.

Voir aussi : bus série universel (USB, Universal Serial Bus) ; connecteur d'extension

bus local

Fait généralement référence à un bus système directement connecté au microprocesseur sur une carte système. Le bus local fait référence, de manière simplifiée, à des bus de la carte système situés plus près du microprocesseur que les bus d'expansion ordinaires (ce qui requiert une mise en tampon moindre), ce qui leur permet un plus grand débit.

bus série universel (USB, Universal Serial Bus)

Bus externe qui prend en charge l'installation Plug-and-Play. Avec un bus USB, vous pouvez connecter et déconnecter des unités sans arrêter ou redémarrer votre ordinateur. Sur un même port USB, vous pouvez connecter jusqu'à 127 unités périphériques, dont des haut-parleurs, des téléphones, des lecteurs de CD-ROM, des manettes de jeu, des lecteurs de bandes, des claviers, des scanneurs et des appareils photo. En général, un port USB se trouve à l'arrière de l'ordinateur à proximité du port série ou du port parallèle.

Voir aussi : bus ; Plug-and-Play ; ports

C

cache

Sous-système de mémoire spécial dans lequel des valeurs de données utilisées fréquemment sont dupliquées pour permettre un accès plus rapide à ces valeurs.

Voir aussi : fichier cache

caractère

Élément le plus simple pour la représentation de langues écrites. L'apparence d'un caractère n'est pas constante ; elle dépend de la police utilisée, ainsi que du contexte du texte environnant.

caractère composite

Élément de texte qui consiste en un caractère de base et une diacritique ou une marque d'accentuation. Bien qu'ils soient très fréquents dans les langues latines, d'autres langues (tels que Grec, Devanagari et Tamil) ont aussi des caractères composites.

caractère de base

Caractère dont la signification est indépendante des autres caractères, ou tout caractère graphique qui n'est pas une marque diacritique.

caractère d'espacement

Caractère dont l'espacement est supérieur à zéro.

caractère précomposé

Caractère unique qui représente une séquence de caractères, généralement une combinaison de caractères de base et un ou plusieurs signes diacritiques.

caractère sans espacement

Caractère, tel qu'un diacritique, qui n'a pas de signification en soi, mais qui recouvre un caractère de base pour le modifier. Parfois appelé « caractère de combinaison ».

caractères à deux octets

Jeu de caractères dans lequel les caractères sont codés sur deux octets. Certaines langues comme le japonais, le chinois et le coréen nécessitent des jeux de caractères DBCS.

carte

Voir la définition pour : périphérique

carte à puce

Périphérique de la taille d'une carte de crédit utilisé avec un code confidentiel pour permettre l'authentification par certificats et la connexion individuelle à l'entreprise. Les cartes à puce stockent de manière sécurisée les certificats, les clés publiques et privées, les mots de passe et autres types d'informations personnelles. Un lecteur de carte à puce connecté à l'ordinateur lit les cartes à puces.

Voir aussi : authentification ; lecteur de carte à puce ; ouverture de session unique

carte d'interface réseau (NIC, network interface card)

Carte d'extension ou autre périphérique utilisé pour permettre l'accès au réseau à un ordinateur ou un autre périphérique, tel qu'une imprimante. Les cartes d'interface réseau jouent le rôle d'intermédiaire entre l'ordinateur et le média physique, tel que le câblage, sur lequel les transmissions s'effectuent. Également appelé carte réseau.

carte mère

Principale carte à circuits imprimés d'un micro-ordinateur. La carte mère contient les connecteurs qui permettent le raccordement des autres cartes.

carte réseau

Périphérique qui connecte votre ordinateur à un réseau. Parfois appelée adaptateur réseau ou carte d'interface réseau.

carte réseau

Voir la définition pour : carte d'interface réseau (NIC, network interface card)

carte système

Également appelée carte-mère. Carte de circuit principale dans un ordinateur et contenant les composants de base du système.

CD-ROM

CD-ROM. Forme de stockage caractérisée par une capacité élevée (environ 650 Mo) et l'utilisation d'un laser plutôt que d'une méthode magnétique pour la lecture des données.

Centre d'aide et de support

Emplacement unifié où un utilisateur peut accéder à l'ensemble du contenu et des services d'aide et de support de Microsoft et de l'OEM.

certificat

Document numérique utilisé communément pour l'authentification et la protection des informations sur les réseaux ouverts. Un certificat lie de manière sécurisée une clé publique à l'entité qui possède la clé privée correspondante. Les certificats sont signés numériquement par l'Autorité de certification émettrice et peuvent être émis pour un utilisateur, un ordinateur ou un service. Le format de certificat le plus largement accepté est défini par la norme internationale ITU-T X.509.

Voir aussi : Autorité de certification (CA, Certification Authority) ; clé privée ; clé publique ; service

Certificat d'authenticité (COA)

Étiquette munie de méthodes sophistiquées de protection contre la contrefaçon, qui aide l'utilisateur final à s'assurer que l'ordinateur utilise une copie dûment licenciée de Microsoft Windows. Le nom du produit et une clé de produit unique apparaissent au centre de l'étiquette. L'OEM doit attacher physiquement l'étiquette COA au châssis de l'ordinateur, et elle ne doit jamais être détachée de l'ordinateur.

Certificat d'authenticité (COA)

Voir la définition pour : Certificat d'authenticité (COA)

certificat racine

Certificat d'Autorité de certification auto-signé. Appelé certificat racine, car il s'agit du certificat de l'autorité racine. Celle-ci doit signer son propre certificat car, par définition, il n'existe pas d'Autorité de certification supérieure dans la hiérarchie de certification.

Voir aussi : Autorité de certification (CA, Certification Authority) ; Autorité de certification racine ; certificat

chargeur de démarrage

Programme exécuté automatiquement quand un ordinateur est allumé ou démarré. Après avoir complété quels tests matériels de base, le chargeur de démarrage se charge et passe le contrôle à un programme chargeur plus grand, qui en général charge alors le système d'exploitation. Le chargeur de démarrage réside généralement dans la mémoire morte (ROM) de l'ordinateur.

Voir aussi : mémoire morte (ROM)

classement

Windows XP propose une hiérarchie des pilotes en fonction de leur degré de bon fonctionnement. Moins le rang est élevé, plus le pilote est adapté au périphérique.

clé de Registre

Identificateur d'un enregistrement ou groupe d'enregistrements du Registre.

Clé du produit

Une chaîne alphanumérique de 25 caractères. Les clients doivent entrer cette chaîne pour activer l'installation de Windows. Cette clé est disponible sur le certificat d'authenticité qui se trouve sur le châssis de l'ordinateur.

clé prédéfinie

Clé qui représente l'une des principales divisions du Registre. Chaque clé prédéfinie s'affiche dans une fenêtre distincte de l'Éditeur du Registre et son nom apparaît dans la barre de titre de la fenêtre. Par exemple, HKEY_CLASSES_ROOT est une clé prédéfinie.

Voir aussi : registre ; ruche ; touche

clé privée

Moitié secrète d'une paire de clés cryptographiques utilisée avec un algorithme de clé publique. Les clés privées permettent généralement de décrypter une clé de session symétrique, de signer numériquement des données ou de décrypter des données qui ont été cryptées avec la clé publique correspondante.

Voir aussi : clé publique ; cryptage par clé publique

clé publique

Moitié non secrète d'une paire de clés cryptographiques utilisée avec un algorithme de clé publique. Les clés publiques sont généralement utilisées pour crypter une clé de session, vérifier une signature numérique ou crypter des données qui peuvent être décryptées avec la clé publique correspondante.

Voir aussi : clé privée ; cryptage par clé publique ; touche

ClearType

Technologie d'affichage des polices qui améliore très sensiblement la résolution d'affichage des polices, de sorte que les lettres sur l'écran de l'ordinateur apparaissent lisses, et non en escalier. ClearType augmente très sensiblement la lisibilité du texte sur les écrans couleur LCD avec interface numérique, tels que ceux trouvés sur les ordinateurs portables et les écrans plats de haute qualité pour ordinateur de bureau.

client

Ordinateur ou programme qui se connecte à un autre ordinateur ou programme, ou qui sollicite des services de celui-ci. Le client peut aussi être le logiciel qui permet à l'ordinateur ou au programme d'établir la connexion.

Dans un réseau local (LAN) ou sur Internet, ordinateur qui utilise les ressources réseau partagées fournies par un autre ordinateur (appelé serveur).

Voir aussi : serveur

CLUF

Voir la définition pour : Contrat de Licence Utilisateur Final (CLUF)

cluster

Dans le stockage de données, le plus petit espace disque qui peut être alloué pour la sauvegarde d'un fichier. Tous les systèmes de fichiers utilisés par Windows organisent les disques durs en clusters, qui sont composés d'un ou plusieurs secteurs contigus. Plus la taille des clusters est petite, plus le stockage des informations s'avère efficace. Si aucune taille de cluster n'est spécifiée lors du formatage, Windows choisit une valeur par défaut en fonction de la taille du volume. Ces valeurs par défaut sont sélectionnées en vue de réduire l'espace perdu et la fragmentation du volume. Également appelé unité d'allocation.

Dans le cadre d'un réseau d'ordinateur, groupe d'ordinateurs indépendants qui fonctionnent ensemble afin de fournir un ensemble commun de services et de présenter l'image d'un système unique aux clients. L'utilisation d'un cluster améliore la disponibilité des services et l'adaptabilité ainsi que la gérabilité du système d'exploitation qui fournit ces services.

Voir aussi : client ; système de fichiers

cluster de serveurs

Groupe d'ordinateurs indépendants désignés sous le nom de nœuds, qui fonctionnent comme s'ils constituaient un système unique afin que les ressources et les applications critiques demeurent à la disposition des clients. Un cluster de serveurs est le type de cluster mis en œuvre par le service de cluster.

Voir aussi : cluster ; nœud

Cmdlines.txt

Fichier texte que l'installation en mode graphique exécute lors de l'installation de composants facultatifs, tels que des applications.

codec

Matériel capable de convertir des signaux audio ou vidéo entre leurs formes analogique et numérique (codeur/décodeur) ; matériel ou logiciel capable de compresser et de décompresser des données audio ou vidéo (compression/décompression) ; ou combinaison de codeur/décodeur et de compression/décompression. Généralement, un codec compresse des données numériques non compressées pour économiser de la mémoire.

collatéral

Guide de l'utilisateur final et tous les autres éléments que l'OEM associe à un nouvel ordinateur.

Compagnon

Personnage interactif animé qui guide les utilisateurs dans l'Accueil de Windows. Le personnage interagit avec l'utilisateur par des méthodes similaires aux aspects naturels de la communication humaine. Les personnages peuvent répondre en utilisant la synthèse vocale, des messages audio enregistrés, ou du texte dans une bulle.

Voir aussi : Accueil de Windows

compagnon Qmark

Compagnon animé Microsoft dans l'Accueil de Windows

composant logiciel enfichable

Type d'outil que vous pouvez ajouter à une console prise en charge par la console MMC (Microsoft Management Console). Un composant logiciel enfichable autonome peut être ajouté de lui-même tandis qu'un composant logiciel enfichable d'extension ne peut être ajouté que pour étendre la fonction d'un autre composant logiciel enfichable.

Voir aussi : MMC (Microsoft Management Console)

compte de groupe

Ensemble de comptes d'utilisateurs. En prenant un compte d'utilisateur et en le faisant membre d'un groupe, vous accordez à l'utilisateur concerné l'ensemble des droits et des autorisations accordés au groupe.

Voir aussi : compte d'utilisateur

compte d'utilisateur

Dans Active Directory, objet composé de toutes les informations qui définissent un utilisateur d'un domaine, notamment le nom d'utilisateur, le mot de passe et les groupes dont fait partie l'utilisateur. Les comptes d'utilisateurs peuvent être stockés dans Active Directory ou sur votre ordinateur local.

Pour les ordinateurs exécutant Windows XP Professionnel et les serveurs membres exécutant Windows Server 2003, l'option Utilisateurs et groupes locaux permet de gérer les comptes d'utilisateurs locaux. Pour les contrôleurs de domaine exécutant Windows Server 2003, l'option Utilisateurs et ordinateurs Active Directory permet de gérer les comptes d'utilisateurs de domaine.

Voir aussi : Active Directory ; mot de passe ; nom d'utilisateur ; objet

concentrateur

Point de connexion commun aux périphériques d'un réseau. Généralement utilisé pour la connexion de segments d'un réseau local, un concentrateur comporte plusieurs ports. Lorsque les données arrivent à l'un des ports, elles sont copiées vers les autres ports de sorte que tous les segments du réseau local puissent voir les données.

Voir aussi : ports ; réseau local (LAN, Local Area Network)

configuration attribuée

Ressources contenues dans le nœud de périphérique, et qui sont attribuées au périphérique. Pour les cartes Plug-and-Play, les ressources attribuées pour un périphérique peuvent être modifiées dynamiquement ou d'un démarrage du système à l'autre.

configuration sur mesure

Construction d'un ordinateur conformément aux souhaits d'un client en personnalisant une image préexistante d'une installation principale.

connecteur d'extension

Prise d'un ordinateur destinée à recevoir des cartes d'extension et à les connecter au bus système.

Voir aussi : bus

connexion d'accès à distance

Connexion à votre réseau si vous utilisez un périphérique qui emploie le réseau téléphonique. Il s'agit notamment des modems avec ligne téléphonique standard, des cartes RNIS avec lignes RNIS à haut débit, et des réseaux X.25.

Si vous êtes un utilisateur ordinaire, vous disposez probablement d'une ou de deux connexions d'accès à distance, par exemple à Internet et à votre réseau d'entreprise. Dans une situation plus complexe, plusieurs connexions de modems réseau pourraient être utilisées pour mettre en oeuvre un routage avancé.

Voir aussi : modem (modulateur/démodulateur)

Connexion d'accès à distance (DUN, Dial-up connection)

Voir la définition pour : Accès réseau à distance

Console de récupération

Interface de ligne de commande qui propose un jeu restreint de commandes d'administration utiles pour réparer un ordinateur.

Voir aussi : système de fichiers NTFS

contexte système

Statut de Windows après qu'il a été démarré pour la première fois quand des services système sont chargés mais quand aucun utilisateur n'est connecté et les paramètres par utilisateurs ne sont pas disponibles.

Contrat de licence OEM

Contrat légal entre Microsoft Licensing, Inc., et les OEM précisant les termes de préinstallation, de personnalisation et de distribution de Microsoft Windows. Pour les fabricants de systèmes, le contrat correspondant est fixé sur le côté de chaque Pack de distribution OEM. En ouvrant l'emballage, vous acceptez tous les termes du contrat Microsoft OEM System Builder. Pour les OEM, le contrat de licence est un contrat signé. Les exigences spécifiques et les options de personnalisation qui s'appliquent à l'un des contrats de licence (ou aux deux) sont documentées dans le Guide de l'utilisateur OPK.

Voir aussi : Contrat Microsoft OEM System Builder; fabricant de systèmes ; OEM soumis à redevance

Contrat de Licence Utilisateur Final (CLUF)

Contrat passé entre un fabricant de matériel ou de logiciel et l'utilisateur final en vue de régir les conditions dans lesquelles le logiciel peut être utilisé et transféré.

Contrat Microsoft OEM System Builder

Contrat de licence entre un intégrateur de système et Microsoft Licensing, Inc., apposé sur le côté de tout Pack de distribution OEM. En ouvrant l'emballage, vous acceptez tous les termes du contrat Microsoft OEM System Builder. Si vous n'acceptez tous les termes du Contrat, contactez le distributeur autorisé OEM Microsoft auprès duquel vous avez effectué l'achat et prenez toutes dispositions nécessaires pour le renvoi du logiciel.

contrôleur de domaine

Dans une forêt Active Directory, serveur qui détient une copie modifiable de la base de données Active Directory, participe à la réplication Active Directory et contrôle l'accès aux ressources réseau. Les administrateurs peuvent gérer les comptes d'utilisateurs, l'accès au réseau, les ressources partagées, la topologie du site et d'autres objets d'annuaire à partir de n'importe quel contrôleur de domaine de la forêt.

Voir aussi : Active Directory ; authentification ; forêt

contrôleur de stockage de masse

Dispositif utilisé par des périphériques de stockage de masse pour accéder à un sous-système de l'ordinateur. Par exemple, une carte SCSI ou une fonctionnalité IDE sur la carte mère est un contrôleur de stockage de masse ; le disque dur physique est un périphérique de stockage de masse.

contrôleur incorporé

Classe générale des microcontrôleurs utilisés pour la prise en charge des implémentations spécifiques des OEM, essentiellement dans les environnements mobiles. Le contrôleur incorporé effectue de complexes fonctions de bas niveau par le biais d'une interface simple avec le ou les microprocesseurs hôtes.

convention d'affectation des noms (UNC, Universal Naming Convention)

Convention d'affectation aux fichiers et à d'autres ressources de noms commençant par deux barres obliques inverses (\), qui indiquent que la ressource se trouve sur un ordinateur en réseau. Les noms UNC respectent la syntaxe \\nom_serveur\nom_partage, où nom_serveur représente le nom du serveur et nom_partage le nom de la ressource partagée. Le nom UNC d'un répertoire ou d'un fichier peut également inclure le chemin du répertoire après le nom de partage, selon la syntaxe suivante : \\nom_serveur\nom_partage\répertoire\nom_fichier.

cookie

Bloc de données qu'un serveur Web stocke sur un système client. Lorsqu'un utilisateur retourne au site Web en question, son navigateur renvoie une copie du cookie au serveur. Les cookies identifient les utilisateurs, déclenchent l'envoi par le serveur d'une version personnalisée de la page Web demandée et soumettent des informations de compte pour l'utilisateur.

copie de fichiers

La première des trois étapes de l'installation, lorsque les fichiers de programme de Windows et tous les fichiers supplémentaires spécifiés sont copiés sur le disque dur de l'ordinateur.

correctif

Mise à jour destinée à résoudre un problème identifié après la distribution d'un produit logiciel. La distribution d'un correctif est limitée par les termes de sa licence.

couche d'abstraction matérielle (HAL, hardware abstraction layer)

Fine couche logicielle fournie par le fabricant du matériel qui dissimule les différences matérielles décelées dans les couches supérieures du système d'exploitation. Au moyen du filtre fourni par la HAL, différents types de matériels apparaissent semblables pour le reste du système d'exploitation. Ceci permet au système d'exploitation d'être portable d'une plate-forme matérielle à une autre. La HAL fournit aussi des routines qui permettent à un seul pilote de périphérique de prendre en charge le même périphérique sur toutes les plates-formes.

couche d'adaptation ATM (AAL, ATM adaptation layer)

Couche de la pile de protocole ATM qui analyse les données de la portion de la charge utile de la cellule ATM en vue d'un transport sur un réseau ATM.

cryptage

Déguisement d'un message de données en vue d'en masquer la substance.

Voir aussi : cryptage par clé publique

cryptage par clé publique

Méthode de cryptage qui fait appel à deux clés de cryptage entre lesquelles il existe une relation mathématique. Une clé est appelée clé privée et demeure confidentielle. L'autre est appelée clé publique et est librement distribuée à tous les correspondants potentiels. Dans un scénario normal, un expéditeur utilise la clé publique du destinataire pour crypter un message. Seul le destinataire possède la clé privée correspondante qui permet de décrypter le message. La complexité de la relation entre la clé publique et la clé privée signifie que, pour autant que les clés soient suffisamment longues, il n'est pas possible de déterminer par calcul une clé en se basant sur une autre. Également appelé cryptage asymétrique.

Voir aussi : clé privée ; clé publique ; cryptage

D

dateur

Certification par une tierce partie approuvée spécifiant qu'un message déterminé existait à une heure et une date données. Dans un contexte numérique, les tierces parties approuvées génèrent un datage approuvé pour un message particulier en employant un service de datage qui ajoute une valeur horaire à un message puis signe numériquement le résultat.

Voir aussi : service ; signature numérique

déboguer

Détecter, localiser et corriger les erreurs logiques ou syntaxiques dans un programme.

démarrage à partir d'un lecteur de CD-ROM

Démarrage d'un ordinateur à partir du CD-ROM du produit complet, puis installation de Windows sur le disque dur grâce au programme d'installation qui se trouve sur le CD-ROM. Cette méthode est plus lente que l'installation de Windows à partir d'un réseau, et n'est pas recommandée. Pour une installation sans assistance grâce au démarrage par le CD-ROM, le fichier Unattend.txt doit être nommé Winnt.sif. L'utilisateur peu sélectionner dans le fichier winnt.sif s'il souhaite sélectionner manuellement la partition ou s'il préfère qu'elle soit sélectionnée automatiquement.

détacher

Supprimer d'un ordinateur de destination les fichiers d'une application désinstallée.

Voir aussi : attacher ; ordinateur de destination ; stade

DHCP (Dynamic Host Configuration Protocol)

Voir la définition pour : protocole DHCP (Dynamic Host Configuration Protocol)

diacritique

Toute marque placée sur, sous ou en travers d'un caractère, généralement pour indiquer une modification de la valeur phonétique par rapport au caractère non marqué. Un caractère qui y est associé est appelé caractère de base. La plupart des diacritiques sont des caractères sans espacement qui n'augmentent pas la largeur du caractère de base.

diskpart.exe

Utilitaire de ligne de commande pour le formatage et la gestion des partitions de disques et des volumes.

disque

Périphérique de stockage associé à un ordinateur.

Voir aussi : disque de base ; disque dynamique

disque de base

Disque physique auquel peuvent accéder MS-DOS et tous les systèmes d'exploitation Windows. Les disques de base peuvent contenir jusqu'à quatre partitions principales, ou trois partitions principales et une partition étendue avec plusieurs lecteurs logiques. Si vous souhaitez créer des partitions fractionnées sur plusieurs disques, vous devez d'abord convertir le disque de base en disque dynamique en utilisant le composant Gestion des disques ou l'outil de ligne de commande Diskpart.exe.

Voir aussi : disque dynamique ; lecteur logique ; partition étendue ; partition principale

disque dynamique

Disque physique qui fournit des fonctionnalités que les disques de base n'offrent pas, telles que la prise en charge des volumes fractionnés sur plusieurs disques. Les disques dynamiques utilisent une base de données cachée pour conserver les informations relatives aux volumes dynamiques sur le disque et aux autres disques dynamiques de l'ordinateur. Vous pouvez convertir des disques de base en disques dynamiques grâce au composant logiciel enfichable Gestion des disques ou à l'outil de ligne de commande DiskPart. Lors de la conversion d'un disque de base en disque dynamique, tous les volumes de base existants deviennent des volumes dynamiques.

Voir aussi : disque de base ; partition ; volume actif ; volume de base ; volume dynamique

disque principal

Disque dur qui contient les partitions système et de démarrage utilisées pour démarrer Windows.

Voir aussi : partition de démarrage ; partition système

dissocier

Voir la définition pour : détacher

distributeur autorisé

Société indépendante ayant obtenu une licence de Microsoft Licensing, Inc. pour gérer la production et la distribution de multipacks de produits OEM Windows XP aux fabricants de systèmes. Si vous achetez des logiciels Microsoft d'un intermédiaire autre qu'un distributeur autorisé Microsoft, vous courez le risque d'acheter un logiciel contrefait, ce qui entraîne généralement les problèmes suivants pilotes manquants, documentation manquante, virus, bogues et autres défauts. L'installation de produits authentiques de Microsoft évite les problèmes pour le client et réduit le besoin de recours au support technique.

domaine

Dans Active Directory, collection d'objets de type ordinateur, utilisateur et groupe définis par l'administrateur. Ces objets partagent une base de données d'annuaire commune, des stratégies de sécurité et des relations de sécurité avec d'autres domaines.

Dans le système DNS (Domain Name System), un domaine est une arborescence ou une sous-arborescence de l'espace de noms DNS. Bien que les noms des domaines DNS correspondent souvent aux domaines Active Directory, les domaines DNS ne doivent pas être confondus avec les domaines Active Directory.

Voir aussi : Active Directory ; objet

Driver.cab

Fichier contenant tous les pilotes de périphériques fournis avec Windows XP.

droits de l'utilisateur

Tâches qu'un utilisateur est autorisé à effectuer sur un ordinateur ou un domaine. Il existe deux types de droits d'utilisateur : privilèges et droits d'ouverture de session. Le droit de fermer le système est un exemple de privilège. Le droit d'ouvrir une session sur un ordinateur localement est un exemple de droit d'ouverture de session. Les privilèges et les droits sont attribués par les administrateurs à des utilisateurs ou groupes particuliers dans le cadre de la configuration des paramètres de sécurité de l'ordinateur.

Voir aussi : domaine

duplication de disque

Utilisation de matériel ou de logiciel de tierce partie pour copier une installation principale complète de Windows XP sur les disques durs d'ordinateurs de destination multiples. L'ordinateur principal et les ordinateurs de destination doivent avoir des couches d'abstraction matérielles (HAL) compatibles. L'ordinateur de destination peut être délivré directement aux clients, ou il peut requérir des traitements supplémentaires sur la chaîne de production.

Voir aussi : couche d'abstraction matérielle (HAL, hardware abstraction layer)

DVD

Disque vidéo digital. Forme de stockage caractérisée par une capacité élevée (environ 650 Mo) et l'utilisation d'un laser plutôt que d'une méthode magnétique pour la lecture des données. Stockage sur disque optique généralement utilisé pour les données audio, vidéo et informatiques. La capacité des DVD s'échelonne de 4,7 Go à 17 Go ; ils peuvent donc stocker considérablement plus qu'un CD-ROM.

DWORD

Type de données composé de données hexadécimales et dont l'espace alloué maximal est de 4 octets.

E

E/S

Voir la définition pour : port d'entrée/sortie (E/S)

éditeur de méthode d'entrée (IME, Input Method Editor)

Programmes utilisés pour entrer des milliers de caractères différents dans des langues asiatiques écrites, à partir d'un clavier 101 touches standard. Un éditeur de méthode d'entrée est constitué à la fois d'un moteur qui convertit les frappes de touches en caractères phonétiques et idéographiques, et d'un dictionnaire des mots idéographiques les plus usités. Au fur et à mesure que l'utilisateur frappe sur les touches, le moteur de l'éditeur de méthode d'entrée tente de reconnaître le ou les caractères dans lesquels convertir les frappes de touches.

EFI

Voir la définition pour : interface EFI (Extensible Firmware Interface)

enregistrement ISP pré-configuré

Configuration du système d'exploitation pendant la phase de fabrication pour utiliser un compte spécifique pour accéder à Internet.

ensemble de caractères à un seul octet

Encodage de caractère dans lequel chaque caractère est représenté par 1 octet. Les ensembles de caractères à un seul octet sont limités à 256 caractères.

ensemble de propriété

Méthode destinée à définir et à obtenir des propriétés pour un pilote. Chaque propriété dispose d'un identificateur unique qui représente différents types d'informations liées et est utilisé pour accéder à l'ensemble de propriété.

ensemble de volumes

Volume constitué d'espace disque sur un ou plusieurs disques physiques. Un ensemble de volumes se crée à partir de disques de base et n'est pris en charge que dans Windows NT 4.0 ou version antérieure. Les ensembles de volumes ont été remplacés par les volumes fractionnés, qui utilisent des disques dynamiques.

Voir aussi : disque de base ; disque dynamique ; partition ; volume fractionné

énumérateur BIOS

Responsable dans un système Plug-and-Play non-ACPI de l'identification de tous les périphériques matériels sur la carte mère de l'ordinateur. Le BIOS prend en charge une API qui permet à tous les ordinateurs Plug-and-Play d'être interrogés de la même façon.

Environnement de préinstallation de Windows (WinPE)

Système d'exploitation Win32 minimal avec des services limités, basé sur le noyau de Windows XP Professionnel. WinPE n'est utilisé que dans la préinstallation et le déploiement de Windows.

environnement PXE (Pre-boot eXecution Environment)

Technologie de démarrage à distance basée sur le protocole DHCP et employée pour démarrer ou installer un système d'exploitation sur un ordinateur client à partir d'un serveur distant. Un serveur RIS constitue un exemple de serveur PXE.

espace libre

Espace disponible que vous utilisez pour créer des lecteurs logiques au sein d'une partition étendue.

Voir aussi : espace non alloué ; lecteur logique ; partition étendue

espace non alloué

Espace disque qui n'est alloué à aucun volume. Le type de volume que vous pouvez créer sur un espace disque non alloué varie en fonction du type de disque. Sur les disques de base, vous pouvez utiliser l'espace non alloué pour créer des partitions principales ou étendues. Sur les disques dynamiques, vous pouvez utiliser l'espace non alloué pour créer des volumes dynamiques.

Voir aussi : disque de base ; disque dynamique ; lecteur logique ; objet ; partition ; partition étendue ; partition principale

état de reliaison

État utilisé par les clients DHCP pour étendre et renouveler leur bail d'adresse lorsque le bail actuel va bientôt expirer. Dans cet état, le client transmet sur le réseau pour rechercher un serveur DHCP qui peut renouveler ou remplacer sa configuration de location actuelle. L'état de reliaison commence lorsque 87,5 pour cent de la durée du bail du client s'est écoulé.

Voir aussi : bail ; protocole DHCP (Dynamic Host Configuration Protocol)

étiquette

Chaque partie d'un nom de domaine DNS complet qui représente un nœud dans l'arborescence de l'espace de noms du domaine. Les noms de domaines se composent d'une série d'étiquettes, telles que les trois étiquettes (exemple, microsoft et com) qui composent le nom de domaine DNS exemple.microsoft.com. Chaque étiquette utilisée dans un nom de domaine DNS ne doit pas comporter plus de 63 octets.

Voir aussi : nœud ; nom de domaine

événement

Tout fait important se produisant dans le système ou dans une application et devant être signalé aux utilisateurs ou consigné dans un journal.

F

fabricant de systèmes

Toute personne acquérant un Pack de Distribution OEM de Windows (disponible via les distributeurs) et qui pré-installe Windows sur des nouveaux ordinateurs. Les intégrateurs de système doivent respecter les termes du contrat Microsoft OEM System Builder joint au Pack de distribution OEM.

Voir aussi : Contrat Microsoft OEM System Builder

FAT

Voir la définition pour : table d'allocation des fichiers (FAT, File Allocation Table)

FAT32

Variante du système de fichiers FAT (File Allocation Table). FAT32 prend en charge des tailles de cluster moins importantes et des volumes plus grands que FAT, assurant ainsi une allocation d'espace plus efficace.

Voir aussi : table d'allocation des fichiers (FAT, File Allocation Table)

fichier cache

Fichier utilisé par des serveurs et des clients DNS (Domain Name System) pour stocker les réponses aux requêtes DNS. Pour les serveurs DNS Windows, le fichier cache est appelé Cache.dns par défaut.

Voir aussi : cache

fichier de réponses

Fichier texte qui indique par script les réponses à apporter à une série de boîtes de dialogue de l'interface graphique. Le fichier de réponses pour l'installation est généralement appelé Unattend.txt, mais pour une préinstallation en réseau, vous pouvez nommer le fichier comme vous le souhaitez. Pour une installation à l'aide d'un CD-ROM, le fichier de réponses doit être nommé Winnt.sif. Les fichiers de réponses pour Sysprep sont Sysprep.inf et Winbom.ini. Vous pouvez créer ou modifier ces fichiers de réponses dans un éditeur de texte ou grâce au Gestionnaire d'installation.

Voir aussi : Unattend.txt

fichier d'échange

Fichiers cachés sur le disque dur dans lesquels Windows conserve des parties de programme et des fichiers de données qui ne trouvent pas place en mémoire. Le fichier d'échange et la mémoire physique (MEV) comprennent la mémoire virtuelle. Windows déplace les données du fichier d'échange vers la mémoire en fonction de ses besoins et déplace des données de la mémoire vers le fichier d'échange lorsqu'il doit libérer de la place pour de nouvelles données. Également appelé fichier de pagination.

fichiers .cab

fichier .cab. Un fichier CAB qui contient de nombreux fichiers compressés. Ces fichiers sont souvent utilisés dans l'installation de logiciels et sont destinés à réduire la taille du fichier de même que la durée de téléchargement lorsqu'il s'agit de contenu Web.

fichiers .dll

Voir la définition pour : bibliothèque de liaison dynamique (DLL, Dynamic-link Library)

fichiers .inf

Fichier d'information. Un fichier créé pour un adaptateur particulier qui fournit au système d'exploitation les informations requises pour installer un périphérique, telles qu'une liste de configurations logiques valides pour les périphériques, les noms des fichiers de pilote(s) associé(s) au périphérique, etc. Un fichier .inf est fournit sur disque par le fabricant du périphérique ou peut être inclus dans le système d'exploitation.

fichiers .ini

Fichier d'initialisation. Largement utilisés sous Windows 3.x et dans les versions antérieures, les fichiers .ini ont été utilisés par le système d'exploitation et par les applications pour stocker des paramètres persistants liés à une application, à un pilote ou à un matériel. Sous Windows 32 bits, les fichiers .ini sont supportés pour assurer une compatibilité sur les versions antérieures mais le registre est l'endroit de préférence pour la mise en mémoire de ce type de paramètres.

fichiers .ins

Fichier de paramètres Internet Un fichier qui fournit à l'installation de Windows Update des paramètres qui configurent le navigateur et les composants associés. Vous pouvez créer des versions multiples de votre navigateur en modifiant le fichier .ins de chaque package. Utilisez le Gestionnaire de profil pour créer, enregistrer et charger les fichiers .ins.

flasher le BIOS

Processus de mise à jour du logiciel BIOS de l'ordinateur avec une nouvelle version.

Voir aussi : BIOS (basic input/output system)

forêt

Nom désignant un ou plusieurs domaines Active Directory qui partagent les mêmes définitions de classes et d'attributs (schéma), les mêmes informations de site et de réplication (configuration) et des possibilités de recherche dans l'ensemble qu'ils forment (catalogue global). Les domaines d'une forêt sont liés par des relations d'approbation bidirectionnelles et transitives.

Voir aussi : Active Directory ; domaine

format UTF-8 (UCS Transformation Format 8)

Jeu de caractères destiné aux protocoles évoluant au-delà de l'utilisation de l'ASCII. Le protocole UTF-8 prend en charge les caractères ASCII étendus et la traduction du jeu de caractères Unicode 16 bits international UCS-2. Le format UTF-8 permet d'utiliser un éventail de noms beaucoup plus large que ne le permet le codage ASCII ou ASCII étendu des données caractères.

Voir aussi : ASCII (American Standard Code for Information Interchange) ; Unicode

formation interactive pas à pas (SBSI, Step-by-Step Interactive)

Didacticiel publié par Microsoft Press et intégré dans le Centre d'aide et de support de Windows XP.

fournisseur de logiciel indépendant (ISV, independent software vendor)

Développeur de logiciels de tierce-partie ; personne physique ou organisation qui crée de façon indépendante des logiciels pour ordinateurs.

fournisseur de matériel indépendant (IHV, independent hardware vendor)

Entreprise qui conçoit des pilotes de matériel ainsi que les pilotes de périphérique associés.

fournisseur de services Internet (ISP)

Société qui permet à des personnes ou des entreprises d'accéder à Internet et au World Wide Web. Un fournisseur de services Internet fournit un numéro de téléphone, un nom d'utilisateur, un mot de passe et d'autres informations de connexion permettant aux utilisateurs de connecter leur ordinateur aux ordinateurs du fournisseur de services. En règle générale, un fournisseur de services Internet applique un tarif de connexion mensuel ou horaire.

Voir aussi : serveur Web

FTP (File Transfer Protocol)

Membre de la suite de protocoles TCP/IP, utilisé pour copier des fichiers entre deux ordinateurs sur Internet. Les deux ordinateurs doivent prendre en charge leur rôle FTP respectif : l'un doit être un client FTP et l'autre un serveur FTP.

Voir aussi : protocole TCP/IP (Transmission Control Protocol/Internet Protocol)

G

gestion de l'alimentation

Mécanismes du logiciel et du matériel destinés à minimiser la consommation d'énergie du système, gérer les limites de température du système, et maximiser la durée de vie de la batterie du système. La gestion de l'alimentation met en jeu des compromis entre la vitesse du système, le bruit, la durée de vie de la batterie, la vitesse de traitement et la consommation d'énergie.

Gestionnaire de compte technique (TAM, Technical Account Manager)

Employé de Microsoft qui fournit une assistance technique à un ou plusieurs OEM soumis à redevance ; cette assistance technique est fournie dans la mesure où ils fabriquent des ordinateurs dans lesquels une version existante de Microsoft Windows est installée.

Gestionnaire de comptes

Employé de Microsoft qui est le contact principal pour les relations commerciales entre l'OEM et Microsoft.

Gestionnaire de configuration

Composant du système Plug-and-Play de Windows qui gère le processus consistant à rechercher les périphériques, à définir leur nœud dans l'arborescence de matériel et à exécuter le processus d'attribution de ressources. Chacune des trois phases de gestion de configuration --phase de démarrage, mode réel et mode protégé-- possède ses propres gestionnaires de configuration.

Gestionnaire de connexion

Numéroteur client utilisé pour accéder à Internet.

Gestionnaire de périphériques

Outil d'administration qui vous permet de gérer les périphériques de votre ordinateur. Grâce au Gestionnaire de périphériques, vous pouvez afficher et modifier les propriétés des périphériques, mettre à jour les pilotes de périphérique, configurer les paramètres des périphériques et désinstaller ces derniers.

Voir aussi : périphérique

Gestionnaire d'installation

Service pour créer et modifier des fichiers de réponse et des ensembles de configuration.

Voir aussi : fichier de réponses ; jeu de configurations

glyphe

Représentation graphique d'un caractère, d'une partie de caractère ou d'une séquence de caractères.

GPT

Voir la définition pour : GPT (GUID partition table)

GPT (GUID partition table)

Schéma de partitionnement utilisé par l'interface EFI (Extensible Firmware Interface) sur les ordinateurs à processeur Itanium. La table GPT offre plus d'avantages que le partitionnement d'enregistrement de démarrage principal (MBR, Master Boot Record) car elle autorise plus de 128 partitions par disque, prend en charge des volumes à hauteur de 18 exaoctets en taille, des tables de partition principales et de sauvegarde pour les redondances, et des identificateurs uniques globaux (GUID).

Voir aussi : interface EFI (Extensible Firmware Interface) ; Itanium ; Partition MBR (Master Boot Record)

groupe de travail

Regroupement simple d'ordinateurs, conçu uniquement pour aider les utilisateurs à trouver des imprimantes et des dossiers partagés à l'intérieur de ce groupe. Les groupes de travail dans Windows n'offrent pas les comptes d'utilisateurs centralisés et l'authentification proposés par les domaines.

Voir aussi : authentification ; compte d'utilisateur ; domaine

groupes de langues

Terme utilisé pour décrire les familles de scripts prises en charge dans Microsoft Windows.

groupes prédéfinis

Groupes de sécurité installés par défaut avec le système d'exploitation. Les groupes prédéfinis sont dotés d'une série de droits et de fonctions prédéfinis extrêmement utiles.

Dans la plupart des cas, les groupes prédéfinis confèrent à un utilisateur donné toutes les possibilités nécessaires. Par exemple, les membres du groupe prédéfini Opérateurs de sauvegarde sont autorisés à sauvegarder et à restaurer des fichiers. Pour attribuer à un compte d'utilisateur un ensemble de possibilités données, assignez-le au groupe prédéfini approprié.

H

hachage

Résultat de taille fixe qui est obtenu en appliquant une fonction mathématique unidirectionnelle (parfois appelée algorithme de hachage) à une quantité arbitraire de données. Toute modification aux données d'entrée est répercutée dans le hachage. Le hachage peut être utilisé dans de nombreuses situations, telles que les opérations d'authentification et de signature numérique. Également appelé message résumé.

Voir aussi : algorithme de hachage ; authentification

HAL

Voir la définition pour : couche d'abstraction matérielle (HAL, hardware abstraction layer)

HCL

Voir la définition pour : Liste du matériel compatible (HCL, Hardware Compatibility List)

héritée

Toute fonctionnalité du système basée sur une technologie antérieure pour laquelle la compatibilité est toujours assurée continue à être maintenue dans les autres composants du système.

HTML (Hypertext Markup Language)

Langage à balises simple utilisé pour la création de documents hypertextes portables d'une plate-forme à une autre. Les fichiers HTML sont de simples fichiers texte ASCII dans lesquels sont incorporés des codes (désignés par des balises) indiquant la mise en forme et les liens hypertextes.

Voir aussi : ASCII (American Standard Code for Information Interchange)

I

IA-PC

Intel Architecture Personal Computer. Terme descriptif général destiné aux ordinateurs conçus avec des processeurs en conformité avec l'architecture définie par la famille de processeurs Intel, basée sur l'ensemble d'instructions 486 et possédant une architecture PC standard.

icône caractère

Icône animée dans le Centre d'aide et de support qui guide les utilisateurs lors de la première mise en route, ou au cours de l'Accueil de Windows.

Voir aussi : Accueil de Windows

ID compatible

ID utilisé par le Gestionnaire Plug-and-Play. Si Plug-and-Play ne trouve aucune correspondance pour l'ID de matériel du périphérique, Plug-and-Play installe le fichier .inf du pilote associé à l'ID compatible.

ID de langue

Une valeur 16 bits constituée d'un ID de langue principal et secondaire. Les bits 0 à 9 constituent l'ID de langue principal et les bits de 10 à 15 composent l'ID de sous-langue.

ID de matériel

Chaîne définie par le fournisseur et utilisée par le Gestionnaire Plug-and-Play pour trouver le fichier .inf adéquat pour installer un périphérique particulier.

Voir aussi : fichiers .inf ; Plug-and-Play

ID de périphérique

Chaîne ASCII unique pour le périphérique, créée par des énumérateurs pour identifier un périphérique matériel et utilisée pour référencer les données concernant le périphérique et stockées dans le Registre. Distingue chaque périphérique logique et bus de tous les autres sur le système.

ID du paramètre régional

Valeur 32 bits constituée de l'ID de langue dans le mot bas (bits 0-15) et de l'ID de tri (bits 16-19) ainsi que d'une valeur réservée (bits 20-31) dans le mot haut.

IDE

Voir la définition pour : IDE (Integrated device electronics)

IDE (Integrated device electronics)

Type d'interface de lecteur de disque dans laquelle les circuits du contrôleur résident sur le lecteur proprement dit, ce qui évite de recourir à une carte séparée. L'IDE offre des avantages tels que la mise en antémémoire pour de meilleures performances globales.

identificateur de sécurité (SID, Security ID)

Structure de données de longueur variable qui identifie les comptes d'utilisateurs, de groupes et d'ordinateurs. Chaque compte du réseau reçoit un SID personnel au moment de sa création. Les processus internes de Windows se réfèrent au SID d'un compte plutôt qu'à son nom d'utilisateur ou de groupe.

Voir aussi : compte de groupe ; compte d'utilisateur ; nom d'utilisateur

IEEE

Institute of Electrical and Electronics Engineers, fondé en 1963. IEEE est une organisation composée d'ingénieurs, de scientifiques et d'étudiants, réputée pour avoir développé les standards de l'industrie informatique et électronique.

IEEE 1394

Norme relative aux périphériques série haute vitesse, notamment les appareils de copie audio numériques et vidéo numériques.

Voir aussi : périphérique

IHV

Voir la définition pour : fournisseur de matériel indépendant (IHV, independent hardware vendor)

IIS

Voir la définition pour : services Internet (IIS)

image

Collection de fichiers et de dossiers (parfois compressée en un seul fichier) qui duplique la structure de fichiers et de dossiers d'origine d'un système d'exploitation. Une image contient souvent d'autres fichiers ajoutés par l'entreprise ou le constructeur OEM qui fabrique l'ordinateur.

infrastructure de clés publiques (PKI)

Lois, stratégies, normes et logiciels qui régissent ou manipulent les certificats ainsi que les clés publiques et privées. Dans la pratique, il s'agit d'un système de certificats numériques, d'Autorités de certification et d'autres autorités d'enregistrement qui vérifient et authentifient la validité de chacune des parties impliquées dans une transaction électronique. Les normes relatives à l'infrastructure PKI évoluent sans cesse, même si elles sont largement mises en œuvre en tant qu'élément indispensable au commerce électronique.

Voir aussi : Autorité de certification (CA, Certification Authority) ; certificat ; clé publique

Infrastructure de gestion Windows (WMI, Windows Management Instrumentation)

Infrastructure de gestion qui, dans Windows, prend en charge la surveillance et le contrôle des ressources du système par l'intermédiaire d'un jeu commun d'interfaces, et qui fournit un modèle de fonctionnement, de configuration et d'état de Windows qui se caractérise par sa cohérence et son organisation logique.

Voir aussi : ressource

ingénieur système

Employé de Microsoft qui assiste un ou plusieurs OEM soumis à redevance fabriquant des ordinateurs qui utiliseront la version de Microsoft Windows actuellement en cours de développement.

inscription

Fournir le nom de l'utilisateur, son adresse et d'autres informations démographiques à Microsoft ou à Microsoft et à l'OEM. Les informations d'inscription sont souvent utilisées dans un but commercial. L'inscription est différente de l'activation du fait que l'utilisateur peut activer son installation de Windows sans fournir d'information d'identité ou démographique.

Voir aussi : Activation de produit Windows

inscription sur le Bureau

Opportunité donnée à l'utilisateur final de s'inscrire auprès de Microsoft et de l'OEM, s'il omet de le faire lors de l'accueil Windows.

installation

En matière de logiciel, ajouter des dossiers et des fichiers de programme à votre disque dur et des données connexes à votre Registre afin que votre logiciel s'exécute correctement. L'installation se distingue de la mise à jour dans laquelle les fichiers de programme, les dossiers et les entrées de Registre existants sont mis à jour et remplacés par une version plus récente.

En matière de matériel, connecter physiquement le périphérique à l'ordinateur, charger les pilotes de périphériques sur l'ordinateur, et configurer les paramètres ainsi que les propriétés du périphérique.

Voir aussi : pilote de périphérique ; registre

installation en mode graphique

Dernière des trois étapes de l'installation, au cours de laquelle les matériels de l'ordinateur et les paramètres réseau sont configurés, un mot de passe pour l'administrateur vous est demandé, et vous pouvez personnaliser l'installation.

installation en mode texte

La seconde des trois étapes d'installation, lorsque le matériel de base de l'ordinateur (processeur, carte-mère, contrôleurs de disques durs, systèmes de fichiers et mémoire) est défini, le système d'exploitation de base nécessaire à la poursuite de l'installation est installé et les dossiers spécifiés sont créés.

installation principale

Installation personnalisée de Windows qu'un OEM veut dupliquer sur un ou plusieurs ordinateurs de destination.

installation sans assistance

Méthode automatisée sans contact pour installer Windows. L'installation sans assistance fait appel à un fichier de réponses pour donner les informations nécessaires au programme d'installation au lieu d'exiger qu'un administrateur ou un utilisateur final fournisse les réponses de manière interactive.

interface de configuration et d'énergie avancée (ACPI, Advanced Configuration and Power Interface)

Norme industrielle ouverte qui définit la gestion de l'alimentation d'une large gamme d'ordinateurs et de périphériques de bureau et serveurs mobiles. L'interface ACPI constitue le fondement même de l'initiative industrielle OnNow qui permet aux fabricants de systèmes de livrer des ordinateurs qui démarrent par simple pression sur une touche du clavier. La conception ACPI est essentielle pour tirer pleinement parti des fonctionnalités de gestion de l'alimentation et de Plug-and-Play.

Voir aussi : Plug-and-Play

interface de contrôleur incorporé

ACPI définit une interface de communication standard pour le matériel et les logiciels entre un pilote de système d'exploitation et un contrôleur incorporé, tel que Smart Battery et le code AML. Ceci permet à tout système d'exploitation de fournir un pilote standard qui peut directement communiquer avec un contrôleur incorporé dans le système, permettant ainsi aux autres pilotes de communiquer et d'utiliser les ressources des contrôleurs incorporés du système.

Voir aussi : interface de configuration et d'énergie avancée (ACPI, Advanced Configuration and Power Interface) ; pilote

interface de programmation d'applications (API)

Ensemble de routines qu'une application utilise pour demander et traiter des services de bas niveau effectués par le système d'exploitation d'un ordinateur. En règle générale, ces routines exécutent les tâches de maintenance, telles que la gestion des fichiers et l'affichage des informations.

interface EFI (Extensible Firmware Interface)

Dans les ordinateurs à processeur Itanium d'Intel, interface entre le microprogramme, le matériel et le système d'exploitation de l'ordinateur. L'interface EFI définit un nouveau style de partition appelé GPT (table de partition GUID). L'interface EFI remplit la même fonction pour les ordinateurs de type Itanium que le BIOS dans les ordinateurs x86. Toutefois, elle possède des capacités étendues offrent un moyen cohérent de démarrer n'importe quel système d'exploitation compatible et d'ajouter facilement des pilotes EFI pour de nouveaux périphériques de démarrage sans nécessiter de mettre à jour le microprogramme de l'ordinateur.

Voir aussi : BIOS (basic input/output system) ; GPT (GUID partition table) ; Itanium ; x86

interface SCSI (small computer system interface)

Interface parallèle à haut débit définie par l'ANSI (American National Standards Institute). L'interface SCSI est utilisée pour connecter des micro-ordinateurs à des périphériques, notamment des disques durs et des imprimantes, à d'autres ordinateurs et à des réseaux locaux.

Voir aussi : périphérique ; réseau local (LAN, Local Area Network)

interface utilisateur graphique (GUI)

Format d'affichage, tel celui de Windows, qui représente les fonctions d'un programme à l'aide d'images graphiques tels que boutons et icônes. Les interfaces graphiques permettent à un utilisateur d'effectuer des actions et de faire des choix en pointant et en cliquant à l'aide d'une souris.

interface utilisateur multilingue (MUI, Multi-Language User Interface)

Version séparée et autonome de Windows qui inclut des ressources de l'interface utilisateur pour chacune des langues prises en charge. MUI permet aux utilisateurs de définir la langue de l'interface utilisateur en fonction de leurs préférences, à condition que les fichiers de la langue requise soient présents sur l'ordinateur. Ceci est conçu pour permettre aux grandes entreprises de déployer une seule version de Windows dans le monde entier, tout en donnant à leurs utilisateurs et groupes locaux la possibilité de choisir la langue de leur interface. Les éléments suivants ne sont pas localisés dans les versions MUI : tout le code 16 bits, les bitmaps, les clés et valeurs de Registre, les noms de fichiers et dossiers et les fichiers .inf.

Internet

Internet. Au moins deux segments de réseau connectés par des routeurs. Synonyme d'interconnexion.

Internet. Réseau mondial d'ordinateurs. Si vous avez accès à Internet, vous pouvez extraire des informations provenant de millions de sources différentes : écoles, administrations, entreprises et particuliers entre autres.

Voir aussi : World Wide Web

IPX (Internetwork Packet Exchange)

Protocole réseau d'origine NetWare qui contrôle l'adressage et le routage des paquets à l'intérieur des réseaux locaux et entre eux. IPX ne garantit pas qu'un message sera complet (qu'aucun paquet ne sera perdu).

Voir aussi : IPX/SPX (Internetwork Packet Exchange/Sequenced Packet Exchange) ; réseau local (LAN, Local Area Network)

IPX/SPX (Internetwork Packet Exchange/Sequenced Packet Exchange)

Protocoles de transport utilisés sur les réseaux Novell NetWare, qui correspondent globalement à la combinaison des protocoles TCP et IP dans la suite de protocoles TCP/IP. Windows implémente IPX par l'intermédiaire de NWLink.

Voir aussi : IPX (Internetwork Packet Exchange) ; protocole de transport compatible IPX/SPX/NetBIOS (NWLink) ; protocole TCP/IP (Transmission Control Protocol/Internet Protocol)

IRP

Voir la définition pour : Paquet de demande d'E/S (IRP)

IRQ

Voir la définition pour : requête d'interruption (IRQ)

isochrone

Dépendant du temps. Fait référence aux processus où les données doivent être délivrées selon certains contraintes de temps. Les flux multimédias requièrent un mécanisme de transport isochrone afin de garantir que les données sont délivrées aussi rapidement qu'elles sont affichées, et d'assurer que l'audio est synchronisé avec la vidéo.

isolation

Processus Plug-and-Play par lequel une distinction est effectuée entre les cartes d'un bus ISA après le démarrage du système.

ISP

Voir la définition pour : fournisseur de services Internet (ISP)

ISV

Voir la définition pour : fournisseur de logiciel indépendant (ISV, independent software vendor)

Itanium

Microprocesseur Intel qui utilise un mode de calcul à base de jeux d'instructions explicitement parallèles et l'adressage de mémoire 64 bits.

J

jeu de caractères multi-octets (MBCS, MultiByte Character Set)

Jeu de caractères à largeur variable, dans lequel certains caractères sont codés sur plus d'un octet. Le jeu de caractères à deux octets (DBCS, double byte character set), qui est un type spécifique de jeu de caractères multi-octets, comprend des caractères codés sur 1 octet, alors que certains autres caractères sont codés sur 2 octets.

jeu de configuration

Voir la définition pour : jeu de configurations

jeu de configurations

Structure de dossiers et de fichiers contenant les paramètres de configuration nécessaires au déroulement du processus de préinstallation et définissant les informations personnalisées des fabricants.

K

kernel

Noyau de l'architecture à couches qui gère les opérations les plus élémentaires du système d'exploitation et du processeur. Le noyau (kernel) planifie différents blocs de code d'exécution, appelés threads, pour maintenir le processeur aussi occupé que possible et coordonne plusieurs processeurs pour optimiser les performances. Le noyau synchronise également les activités entre les sous-composants de niveau Exécutif, tels que le Gestionnaire d'E/S et le Gestionnaire de processus, et gère les exceptions matérielles et autres fonctions liées au matériel. Le noyau collabore étroitement avec la couche d'abstraction matérielle.

Kit de préinstallation OEM (OPK, OEM Preinstallation Kit)

Jeu d'outils, documentation et exemples qui permettent aux OEM de préinstaller efficacement Windows sur de nouveaux ordinateurs en accord avec les termes du contrat de licence OEM.

L

Laboratoire de qualité du matériel Windows

Fournit des services de test de compatibilité pour le matériel et les pilotes pour les systèmes d'exploitation Windows.

LAN

Voir la définition pour : réseau local (LAN, Local Area Network)

langue d'entrée

Paramètre des Options régionales et linguistiques qui définit l'association entre, d'une part la langue utilisée pour les entrées et, d'autre part, l'agencement du clavier, l'éditeur IME (Input Method Editor), le convertisseur de dictée en texte ou tout autre périphérique d'entrée. Ancien nom : paramètres régionaux d'entrée.

Voir aussi : éditeur de méthode d'entrée (IME, Input Method Editor)

langue d'interface utilisateur

La langue dans laquelle le système d'exploitation affiche ses menus, fichiers d'aide et boîtes de dialogue.

langue pour les programmes non-Unicode

Paramètre des Options régionales et linguistiques qui spécifie les pages de codes par défaut et les fichiers de police bitmap associés pour tous les utilisateurs d'un ordinateur spécifique. Les pages de codes et les polices par défaut permettent à une application non-Unicode écrite pour une version linguistique d'un système d'exploitation de fonctionner correctement sur une autre version linguistique de ce système d'exploitation. Ancien nom : paramètres régionaux système.

large bande

Relatif à des systèmes de communication dans lesquels le média de transmission (tel qu'un câble ou une fibre optique) fait transiter plusieurs messages à la fois, chaque message étant modulé sur sa propre fréquence par un modem.

LBA

Adresse de bloc logique (Logical Block Addressing). Méthode utilisée avec des lecteurs de disque SCSI et IDE pour convertir les spécifications de cylindre, d'en-tête, et de secteur du lecteur en adresses pouvant être utilisées par un BIOS amélioré. LBA est utilisé avec des lecteurs supérieurs à 528 Mo.

lecteur de carte à puce

Périphérique installé dans les ordinateurs pour lire les cartes à puce qui permettent de bénéficier de fonctionnalités de sécurité avancées.

Voir aussi : carte à puce

lecteur logique

Volume que vous créez au sein d'une partition étendue sur un disque MBR (Master Boot Record) de base. Les lecteurs logiques sont identiques aux partitions principales, à ceci près que vous êtes limité à quatre partitions principales par disque, tandis que vous vous créez autant de lecteurs logiques que vous voulez par disque. Un lecteur logique peut être formaté et une lettre de lecteur peut lui être assignée.

Voir aussi : disque de base ; partition étendue ; Partition MBR (Master Boot Record) ; partition principale ; volume de base

lecteur système

Lettre de lecteur du périphérique de stockage de masse (le plus souvent un disque dur) sur lequel Windows est installé.

licence

Droit dont dispose une personne ou une entreprise d'utiliser le logiciel d'une manière particulière, comme décrit dans les termes de l'accord de licence. La loi du copyright limite également la manière dont une personne peut utiliser le logiciel. Une personne nécessite un accord de licence pour chaque programme logiciel qu'elle utilise.

licence CAL

Voir la définition pour : licence d'accès client (CAL)

licence d'accès client (CAL)

Licence qui spécifie le nombre d'utilisateurs ou de périphériques qui peuvent se connecter à un serveur et utiliser les logiciels qui s'y trouvent.

lien OEM

Lien dans le menu Démarrer où les OEM peuvent placer à loisir des liens et raccourcis.

lignes de requête d'interruption (IRQ)

Lignes sur lesquelles les périphériques peuvent envoyer des signaux pour attirer l'attention du processeur lorsque le périphérique est prêt à recevoir ou envoyer des informations. Chaque périphérique doit disposer d'une ligne IRQ unique.

Voir aussi : périphérique ; requête d'interruption (IRQ)

liste de certificats de confiance (CTL, Certificate Trust List)

Liste signée de certificats émis par des Autorités de certification racine qu'un administrateur estime dignes de confiance pour des rôles désignés, tels que l'authentification du client ou la messagerie électronique sécurisée.

Voir aussi : Autorité de certification (CA, Certification Authority) ; certificat ; certificat racine

liste de révocation de certificats (CRL, Certificate Revocation List)

Document géré et publié par une Autorité de certification qui énumère les certificats qui ont été révoqués.

Voir aussi : Autorité de certification (CA, Certification Authority) ; certificat

Liste du matériel compatible (HCL, Hardware Compatibility List)

Liste de matériels dressée par Microsoft pour un produit spécifique. La Liste du matériel compatible Windows, qui est publiée sur le Web, répertorie les périphériques matériels et les ordinateurs qui sont compatibles avec des versions spécifiques de Windows.

Voir aussi : périphérique

Liste MFU

Liste utilisée le plus fréquemment. Liste des applications que l'utilisateur final a récemment utilisées.

logiciel contrefait

Logiciel qu'un fabricant de systèmes n'obtient pas d'un distributeur autorisé, ou qu'un OEM soumis à redevance n'obtient pas d'un réplicateur autorisé. Les logiciels contrefaits entraînent généralement plusieurs des problèmes suivants : pilotes manquants, documentation manquante, virus, bogues et autres défauts. L'installation de produits Microsoft authentiques aide à assurer la qualité de vos produits, empêche les problèmes pour les clients, et réduit le recours au support technique.

M

maître d'attribution de noms de domaines

Contrôleur de domaine qui joue le rôle de maître des opérations d'attribution de noms de domaine dans Active Directory. Ce rôle consiste à contrôler l'ajout ou la suppression de domaines dans la forêt. Il peut être dévolu à un seul contrôleur de domaine de la forêt à un instant donné.

Voir aussi : Active Directory ; contrôleur de domaine

marque de service

Marque utilisée dans la vente ou la promotion de services pour les identifier et les distinguer des services fournis par une autre société.

MBR Protectif

Premier secteur d'un disque à table de partition GTP (GUID partition table) qui est structuré comme le premier secteur d'un disque MBR (Master Boot Record) pour empêcher les utilitaires de disque de type x86 de détruire les partitions GPT. Le MBR Protectif contient une partition qui réserve l'ensemble de l'espace utilisé sur le disque par les partitions GPT.

Voir aussi : GPT (GUID partition table) ; interface EFI (Extensible Firmware Interface) ; Partition MBR (Master Boot Record) ; x86

mémoire morte (ROM)

Circuit à semi-conducteurs qui contient des informations qu'il est impossible de modifier.

mémoire vive (RAM)

Mémoire dans laquelle un ordinateur ou d'autres périphériques peuvent exécuter des opérations de lecture et d'écriture. Les informations stockées dans la RAM disparaissent lorsque l'ordinateur est hors tension.

Message Queuing

Système de mise en file d'attente et de routage des messages pour Windows qui permet à des applications distribuées, exécutées à des moments différents, de communiquer sur des réseaux hétérogènes et avec des ordinateurs qui sont peut-être hors connexion. Message Queuing garantit la remise des messages, l'efficacité de leur routage, de leur sécurité et de leur traitement selon leur priorité. Ancien nom : MSMQ.

Voir aussi : MSMQ

microprogramme

Routines logicielles et instructions d'entrée/sortie de bas niveau stockées dans la mémoire morte (ROM). À l'inverse de la mémoire vive (RAM), la mémoire morte reste intacte même en l'absence de courant.

Voir aussi : mémoire morte (ROM) ; mémoire vive (RAM)

MIDI

MIDI (Musical Instrument Digital Interface). Connexion standard pour le contrôle d'instruments et de périphériques de musique sur un ordinateur. Norme de matériel et de données pour la communication entre matériels. De nombreuses références n'indiquent que la norme des données, qui est un flux d'octets utilisé pour le contrôle d'instruments de musique et le stockage de la sortie de tels instruments.

mini-installation

Sous-ensemble de la partie graphique de l'installation, la mini-installation est l'expérience de première expérience pour la famille de produits Windows Server. La mini-installation demande des informations relatives à l'utilisateur, détecte le nouveau matériel et régénère les ID du système.

MIPS

Millions d'instructions par seconde. Mesure usuelle de la vitesse du processeur.

mise en cache

Processus consistant à stocker temporairement les informations utilisées récemment dans un sous-système de mémoire spécial permettant des accès rapides.

Voir aussi : cache

MMC (Microsoft Management Console)

Cadre d'hébergement d'outils d'administration appelés composants logiciels enfichables. Une console peut contenir des outils, des dossiers ou d'autres conteneurs, des pages Web et d'autres éléments d'administration. Ces éléments sont affichés dans le volet gauche de la console, dans ce qu'il est convenu d'appeler l'arborescence de la console. Une console possède une ou plusieurs fenêtres qui affichent des représentations de l'arborescence de la console. La fenêtre MMC principale regroupe les commandes et les outils des consoles de création. Les fonctionnalités de création de la console MMC et de l'arborescence de la console proprement dite peuvent être masquées lorsqu'une console est en mode Utilisateur.

Voir aussi : arborescence de console ; composant logiciel enfichable

mode audit

Vérification, avant la livraison à l'utilisateur final, que l'ordinateur complet fonctionne comme prévu. Après l'audit, rescellez toujours le système d'exploitation pour réinitialiser l'expérience de première exécution pour l'utilisateur.

mode kernel

Mode extrêmement privilégié de fonctionnement, où un code programme dispose d'un accès direct à l'ensemble de la mémoire, y compris aux espaces d'adresses de tous les processus et applications en mode utilisateur et au matériel. Également connu sous le nom de mode superviseur, mode protégé ou Ring 0.

mode mixte

Dans un domaine Windows 2000, paramètre du mode de domaine par défaut. Le mode mixte permet aux contrôleurs secondaires de domaine Windows NT de coexister avec les contrôleurs de domaine exécutant Windows 2000. Le mode mixte ne prend en charge ni les groupes universels, ni l'imbrication de groupes. Vous pouvez modifier le paramètre du mode de domaine et lui donner la valeur de mode natif quand tous les contrôleurs de domaine Windows NT sont supprimés d'un domaine.

Dans les domaines Windows Server 2003, le mode mixte est appelé Windows 2000 mixte et constitue l'un des trois niveaux fonctionnels de domaine disponibles.

Voir aussi : Active Directory ; mode natif

mode natif

Dans les domaines Windows 2000, mode de domaine dans lequel tous les contrôleurs du domaine exécutent Windows 2000 et qui est établi à la place du mode mixte par un administrateur de domaine. Le mode natif prend en charge les groupes universels et l'imbrication de groupes. En mode natif, les contrôleurs de domaine exécutant Windows NT 4.0 ou version antérieure ne sont pas pris en charge.

Dans les domaines Windows Server 2003, le mode natif est appelé Windows 2000 natif et constitue l'un des trois niveaux fonctionnels de domaine disponibles.

Voir aussi : Active Directory ; mode mixte

mode silencieux

Lancer une application à partir de la ligne de commande afin qu'elle n'affiche pas de messages de confirmation ou tout autre message d'interface utilisateur qui apparaît normalement à l'écran. Le commutateur du mode silencieux est généralement /q.

mode usine

Mode de fonctionnement de Sysprep qui retarde l'expérience de première exécution et permet aux OEM d'installer des pilotes et applications supplémentaires, d'incorporer pour le client des informations sur la fabrication sur mesure, et de tester l'installation de Windows. Pour exécuter Sysprep en mode usine, utilisez la commande Sysprep -factory.

mode utilisateur

Mode de traitement dans lequel l'application est exécutée.

modèle de certificat

Structure Windows qui définit le format et le contenu de certificats en fonction de l'usage auquel ils sont destinés. Lorsqu'ils sollicitent un certificat auprès d'une Autorité de certification d'entreprise Windows, les demandeurs de certificat peuvent opérer un choix parmi un large éventail de types de certificats fondés sur des modèles de certificats.

Voir aussi : Autorité de certification (CA, Certification Authority) ; certificat

modem (modulateur/démodulateur)

Périphérique qui permet de transmettre des informations d'un ordinateur à l'autre via une ligne téléphonique. Le modem émetteur transforme les données informatiques numériques en signaux analogiques pouvant être acheminés par une ligne téléphonique. Le modem récepteur transforme les signaux analogiques en signaux numériques.

Voir aussi : API de téléphonie (TAPI) ; ports

modem câble

Modem qui envoie et reçoit les données à travers un câble coaxial de réseau de télévision au lieu d'une ligne téléphonique.

monochrome

Écran qui affiche les images en une seule couleur, ou n'affiche que différentes nuances d'une couleur, par exemple un écran à nuances de gris.

mot de passe

Mesure de sécurité utilisée pour limiter les noms d'ouverture de session sur les comptes d'utilisateurs ainsi que les accès aux systèmes et aux ressources. Un mot de passe est une chaîne de caractères qui doit être fournie pour qu'une ouverture de session ou un accès soit autorisé. Un mot de passe peut être composé de lettres, de chiffres ou de symboles et respecte la casse.

Voir aussi : compte d'utilisateur

mot de passe de l'utilisateur

Mot de passe stocké dans chaque compte d'utilisateur. Chaque utilisateur ne possède généralement qu'un seul mot de passe utilisateur, obligatoire pour ouvrir une session ou accéder à un serveur.

Voir aussi : compte d'utilisateur ; mot de passe

MP3

Acronyme de MPEG Audio Layer-3. Modèle de codage audionumérique employé pour distribuer de la musique enregistrée sur Internet. MP3 réduit la taille d'un fichier audio de 10 à 12 fois sans pour autant dégrader la qualité (niveau d'enregistrement CD-ROM) du son.

MPEG Audio Layer-3

Code audio numérique employé pour distribuer de la musique enregistrée sur Internet. MP3 réduit la taille d'un fichier audio de 10 à 12 fois sans pour autant dégrader la qualité (niveau d'enregistrement CD-ROM) du son.

MSDN

Microsoft Developer Network.

MSMQ

Système de mise en file d'attente et de routage de messages pour Windows NT 4.0, Windows 95 et Windows 98. Pour Windows 2000, Windows XP et la famille Windows Server 2003, cette fonctionnalité est appelée Message Queuing.

Voir aussi : Message Queuing

multimédia

Fait référence à la livraison d'informations qui combinent différents formats de contenu, tels que le format vidéo, audio, les photos fixes, les images et l'animation et le texte.

multiprocesseur

Deux processeurs (ou plus) connectés et à peu près équivalents, qui peuvent chacun supporter en tandem un ou plusieurs processus (programmes ou jeux d'instructions).

N

navigateur

Logiciel qui interprète les balises des fichiers HTML, les transforme en pages Web et les affiche à l'utilisateur. Certains navigateurs permettent également aux utilisateurs d'envoyer et de recevoir des courriers électroniques, de consulter des groupes de discussion et de lire des fichiers audio et vidéo intégrés à des documents Web.

Voir aussi : World Wide Web

NCW

Voir la définition pour : Assistant Nouvelle connexion

NetBEUI

Voir la définition pour : NetBEUI (NetBIOS Extended User Interface)

NetBEUI (NetBIOS Extended User Interface)

Protocole réseau natif des réseaux Microsoft. Il est généralement utilisé dans des petits réseaux locaux au sein d'un département regroupant entre 1 et 200 clients. Ce protocole peut utiliser le routage source Token Ring comme unique méthode de routage. Il s'agit de la version Microsoft de la norme NetBIOS.

Voir aussi : NetBIOS (network basic input/output system) ; protocole ; réseau local (LAN, Local Area Network)

NetBIOS (network basic input/output system)

Interface de programmation d'application (API) qui peut être utilisée par des programmes sur un réseau local. NetBIOS fournit aux programmes un jeu de commandes identique pour les demandes de services de bas niveau nécessaires à la gestion des noms, au déroulement des sessions, et à l'échange de datagrammes entre les nœuds d'un réseau.

Voir aussi : BIOS (basic input/output system) ; interface de programmation d'applications (API) ; nœud ; réseau local (LAN, Local Area Network) ; service

NIC

Voir la définition pour : carte d'interface réseau (NIC, network interface card)

nœud

Pour les arborescences, élément de l'arborescence qui peut être lié à un ou plusieurs éléments situés en aval.

Pour les réseaux locaux, périphérique qui est connecté au réseau et qui peut communiquer avec d'autres périphériques du réseau.

Pour les clusters de serveurs, ordinateur qui est membre actif ou inactif d'un cluster.

Voir aussi : cluster de serveurs ; réseau local (LAN, Local Area Network)

nom de domaine

Nom donné par un administrateur à un ensemble d'ordinateurs connectés en réseau partageant un annuaire commun. Appartenant à la structure de noms DNS (Domain Name System), les noms de domaine sont constitués d'une suite d'étiquettes de noms séparées par des points.

Voir aussi : domaine ; étiquette

nom de fichier long

Nom de dossier ou de fichier plus long que les noms de fichier habituels au format 8.3 (huit caractères maximum suivis d'un point et d'une extension de trois caractères maximum). La plupart des versions de Windows, notamment Windows XP, Windows 2000, Windows NT, Windows 95 et Windows 98, prennent en charge les noms de fichiers longs jusqu'à 255 caractères.

nom de l'utilisateur principal

Nom de compte d'utilisateur (parfois appelé nom d'ouverture de session de l'utilisateur) et nom de domaine identifiant le domaine dans lequel est situé le compte d'utilisateur. Il s'agit de la procédure standard de connexion à un domaine Windows. Le format est le suivant : personne@fabrika.com (comme pour une adresse de messagerie).

Voir aussi : compte d'utilisateur ; domaine ; nom de domaine

nom d'utilisateur

Nom unique identifiant un compte d'utilisateur pour Windows. Le nom d'utilisateur d'un compte doit être unique parmi les autres noms de groupe et noms d'utilisateur au sein de son propre domaine ou groupe de travail.

Voir aussi : compte d'utilisateur ; domaine ; groupe de travail

nom furigana

Petits caractères japonais kana écrits sous ou à côté des caractères kanji. Les caractères kana indiquent la prononciation correcte du mot écrit en kanjis.

normes et formats

Paramètre des Options régionales et linguistiques qui détermine l'ordre de tri du texte et les formats utilisés pour afficher les dates, les heures, les montants monétaires et les nombres. Anciennement connus sous le nom de paramètres régionaux utilisateur.

nouveau système

Installation de Windows n'ayant subi aucune modification et sur laquelle aucun logiciel supplémentaire n'a été installé.

NWLink

Voir la définition pour : protocole de transport compatible IPX/SPX/NetBIOS (NWLink)

O

objet

Entité, par exemple un fichier, un dossier, un dossier partagé, une imprimante ou un objet Active Directory, identifiée par un jeu nommé et distinct d'attributs. Les attributs d'un objet Fichier, par exemple, couvrent son nom, son emplacement et sa taille tandis que les attributs d'un objet Utilisateur Active Directory peuvent comporter le prénom, le nom et l'adresse de messagerie de l'utilisateur.

Pour OLE et ActiveX, un objet peut aussi être n'importe quel élément d'information qui peut être lié (incorporé) à un autre objet.

Voir aussi : attribut ; objet enfant ; objet parent

objet enfant

Objet qui réside dans un autre objet. Un objet enfant implique une relation. Un fichier, par exemple, est un objet enfant qui réside dans un dossier (objet parent).

Voir aussi : objet ; objet parent

objet parent

Objet dans lequel réside un autre objet. Un dossier, par exemple, est un objet parent dans lequel réside un fichier (objet enfant). Un objet peut être tout à la fois parent et enfant. Un sous-dossier, par exemple, qui contient des fichiers est à la fois l'enfant du dossier parent et le dossier parent des fichiers.

Voir aussi : objet ; objet enfant

Observateur d'événements

Composant qui permet d'afficher et de gérer les journaux des événements, de recueillir des informations sur les problèmes matériels et logiciels et de surveiller les événements de sécurité. L'Observateur d'événements tient à jour des journaux relatifs aux événements du programme, de la sécurité et du système.

Voir aussi : événement

octet journal

Valeur octet qui est la seconde moitié d'un caractère à double octet.

OEM

Voir la définition pour : OEM (Original Equipment Manufacturer)

OEM (Original Equipment Manufacturer)

Fabricant dont l'activité consiste à acheter des composants informatiques à d'autres constructeurs pour fabriquer des ordinateurs où il préinstalle Windows avant de les mettre sur le marché.

OEM direct

Voir la définition pour : OEM soumis à redevance

OEM soumis à redevance

Un fournisseur d'équipement informatique originel qui a signé un contrat de licence directement avec Microsoft Licensing, Inc. Les OEM soumis à redevance reçoivent de Microsoft une copie « golden master » de Windows. L'OEM soumis à redevance peut adapter Windows comme décrit dans les kits de préinstallation, dans le contrat de licence ou dans l'addenda signé.

Oem.chm

Fichier d'aide HTML que vous personnalisez pour fournir des informations de support spécifiques à votre société dans l'aide de Windows.

Oeminfo.ini

Fichier utilisé pour fournir les informations OEM requises, telles que le nom de la société, le modèle d'ordinateur, le numéro de téléphone de la société et les informations d'accès au support technique.

offre d'abonnement à un fournisseur de services Internet

Ensemble de pages HTML qui s'affichent à l'Accueil de Windows qui permettent aux utilisateurs finaux de s'abonner à un accès à Internet à partir d'un fournisseur de services Internet particulier.

offre d'abonnement à un fournisseur de services Internet OEM

Jeu de pages HTML créées par l'OEM ou une société tierce, qui permettent aux utilisateurs finaux de souscrire un accès à Internet auprès d'un fournisseur de services Internet (ISP) donné. Vous pouvez incorporer ces pages dans l'Accueil de Windows, ou inclure un raccourci vers la première page du lien OEM dans le menu Démarrer.

Voir aussi : Accueil de Windows ; lien OEM

offre d'abonnement à un fournisseur de services Internet sur le Bureau

Jeu de pages HTML qui permettent à l'utilisateur final de souscrire un accès à Internet. Pour afficher l'offre, l'utilisateur final clique sur un lien à partir du lien OEM du menu Démarrer.

offre d'enregistrement ISP précaché

Voir la définition pour : offre d'abonnement à un fournisseur de services Internet OEM

OnNow

Voir la définition pour : interface de configuration et d'énergie avancée (ACPI, Advanced Configuration and Power Interface)

OOBE

Voir la définition pour : Accueil de Windows

OOBE (Out-Of-Box Experience)

Voir la définition pour : Accueil de Windows

OPK

Voir la définition pour : Kit de préinstallation OEM (OPK, OEM Preinstallation Kit)

ordinateur à jeu d'instruction réduit

Type de microprocesseur essentiellement centré sur le traitement rapide et efficace d'un ensemble d'instructions relativement réduit. L'architecture RISC limite le nombre d'instructions intégrées dans le microprocesseur, mais optimise chacune d'entre elles de manière à ce qu'elles puissent être traitées très rapidement,{bmct emdash.bmp} généralement en un seul cycle d'horloge.

ordinateur cible

Voir la définition pour : ordinateur de destination

ordinateur de destination

Ordinateur sur lequel vous préinstallez Windows et qui est destiné à un client. Vous pouvez lancer le programme d'installation sur l'ordinateur de destination ou copier une installation principale sur cet ordinateur de destination.

ordinateur de référence

Voir la définition pour : ordinateur du technicien

ordinateur du technicien

Ordinateur où est installé l'Assistant Gestion d'installation. Généralement, les jeux de configurations et le partage de distribution se trouvent aussi sur cet ordinateur.

Voir aussi : Gestionnaire d'installation ; jeu de configurations ; partage de distribution

ordinateur fabriqué sur commande

Ordinateur construit en fonction des souhaits d'un client.

ordinateur fabriqué sur plan

Ordinateur construit en fonction d'un cahier des charges général.

ordinateur principal

Ordinateur complètement assemblé contenant une installation principale.

Voir aussi : installation principale

ouverture de session automatique

Ouverture automatique de session sur l'ordinateur avec le compte Administrateur quand l'ordinateur redémarre.

ouverture de session unique

Processus qui permet à un utilisateur qui possède un compte de domaine d'ouvrir (à une seule reprise) une session sur un réseau en utilisant un mot de passe ou une carte à puce, et d'accéder à n'importe quel ordinateur du domaine.

Voir aussi : carte à puce ; domaine

P

page de code

Moyen de prendre en charge des jeux de caractères et des dispositions de clavier de différents pays ou de différentes régions. Une page de codes est une table qui met en correspondance les codes de caractères binaires utilisés par un programme et les touches du clavier ou les caractères affichés.

Paquet de demande d'E/S (IRP)

Structures de données que les pilotes utilisent pour communiquer entre eux.

paramètre régional d'entrée

Voir la définition pour : langue d'entrée

paramètres régionaux

Groupe d'informations concernant les préférences de l'utilisateur, par exemple le format de la date et de l'heure, représentées sous la forme d'une liste de valeurs associées à la langue et à la sous-langue de l'utilisateur.

paramètres régionaux système

Voir la définition pour : langue pour les programmes non-Unicode

paramètres régionaux utilisateur

Voir la définition pour : normes et formats

partage de distribution

Dossier réseau qui contient les fichiers sources des produits Windows que vous préinstallez. Ce dossier peut aussi contenir les outils OPK et vos jeux de configuration. Il est créé soit manuellement, soit par l'Assistant Gestion d'installation.

partition

Partie d'un disque physique qui se comporte comme s'il s'agissait d'un disque physiquement distinct. Lorsque vous créez une partition, vous devez la formater et lui assigner une lettre de lecteur avant de pouvoir y stocker des données.

Sur les disques de base, les partitions sont appelées des volumes de base, qui peuvent être des partitions principales et des lecteurs logiques. Sur les disques dynamiques, les partitions sont appelées des volumes dynamiques qui peuvent être simples, fractionnés, agrégés par bande, en miroir ou RAID-5.

Voir aussi : disque de base ; partition étendue ; partition principale ; partition système ; volume de base ; volume dynamique

partition active

Partition à partir de laquelle démarre un ordinateur de type x86. La partition active doit être une partition principale d'un disque de base. Si vous utilisez exclusivement Windows, la partition active peut être la même que celle du volume système.

Voir aussi : disque de base ; partition principale ; partition système ; x86

partition cachée

Partition invisible pour l'utilisateur. Pour créer une partition cachée, attribuez-lui un type non reconnu par Windows.

partition de démarrage

Partition qui contient le système d'exploitation Windows et ses fichiers de prise en charge. La partition de démarrage peut être la même que la partition système, mais pas nécessairement.

Voir aussi : disque principal ; partition ; partition système

partition étendue

Type de partition que vous pouvez uniquement créer sur les disques d'enregistrement de démarrage principal (MBR, Master Boot Record) de base. Utilisez une partition étendue si vous souhaitez disposer de plus de quatre volumes sur votre disque MBR de base. Contrairement aux partitions principales, vous ne formatez pas une partition étendue avec un système de fichiers en lui attribuant ensuite une lettre de lecteur. Il faut à la place créer un ou plusieurs lecteurs logiques au sein de la partition étendue. Après avoir créé un lecteur logique, vous le formatez et lui assignez une lettre de lecteur. Un disque MBR peut contenir au maximum quatre partitions principales ou trois partitions principales, une partition étendue et plusieurs lecteurs logiques.

Voir aussi : disque de base ; espace non alloué ; lecteur logique ; partition ; Partition MBR (Master Boot Record) ; partition principale

Partition MBR (Master Boot Record)

Premier secteur du disque dur, qui commence le processus de démarrage de l'ordinateur. La partition MBR contient la table de partition du disque et un code succinct exécutable appelé code de démarrage principal.

Voir aussi : Console de récupération ; secteur de démarrage de partition

partition MSR (Microsoft Reserved)

Partition requise sur tout disque GPT (GUID partition table). Les composants système peuvent allouer des portions de la partition MSR en de nouvelles partitions réservées à leur usage. Par exemple, lorsque vous convertissez un disque GPT de base en disque dynamique, le système alloue une portion de la partition MSR afin de l'utiliser comme partition de métadonnées LDM (Logical Disk Manager). La taille de la partition MSR varie en fonction de la taille du disque GPT. Pour les disques de moins de 16 Go, la taille de la partition MSR est de 32 Mo. Pour les disques de plus de 16 Go, la taille de la partition MSR est de 128 Mo. La partition MSR n'est pas visible dans Gestion des disques, et vous ne pouvez pas stocker les données de la partition MSR ou les supprimer.

Voir aussi : GPT (GUID partition table) ; partition

partition principale

Type de partition que vous pouvez créer sur les disques de base. Une partition principale est une partie de l'espace disque physique qui fonctionne comme un disque physiquement indépendant. Sur les disques MBR (Master Boot Record) de base, vous pouvez créer jusqu'à quatre partitions principales ou trois partitions principales et une partition étendue avec plusieurs lecteurs logiques. Sur les disques GPT de base, vous pouvez créer jusqu'à 128 partitions principales. Également appelée volume.

Voir aussi : disque de base ; GPT (GUID partition table) ; lecteur logique ; partition ; partition étendue ; Partition MBR (Master Boot Record)

partition système

Partition qui contient des fichiers propres au matériel qui sont indispensables au chargement de Windows (par exemple Ntldr, Osloader, Boot.ini, Ntdetect.com). La partition système peut être la même que la partition de démarrage, mais pas nécessairement.

Voir aussi : partition ; partition de démarrage

partition système EFI

Sur les ordinateurs de type Itanium, partie du disque GPT (GUID partition table) formatée en système de fichiers FAT et qui contient les fichiers nécessaires au démarrage. Tout ordinateur de type Itanium doit posséder au moins un disque GPT avec une partition système EFI. La partition système EFI remplit la même fonction que le volume système des ordinateurs de type x86.

Voir aussi : GPT (GUID partition table) ; interface EFI (Extensible Firmware Interface) ; Itanium ; partition MSR (Microsoft Reserved) ; x86

Passport

Service unique d'inscription qui vous permet d'utiliser un seul nom et mot de passe pour accéder à de nombreux sites Web participants.

PC Card

Périphérique amovible d'une taille proche de celle d'une carte de crédit, que vous pouvez brancher dans un emplacement PCMCIA (Personal Computer Memory Card International Association) d'un ordinateur portable. Les périphériques PCMCIA peuvent être des modems, des cartes réseau et des disques durs.

Voir aussi : modem (modulateur/démodulateur)

PC Health

Ensemble de technologies et de fonctionnalités destinées à fournir aux utilisateurs un support technique amélioré par la mise en place de solutions de support basées sur le Web. PC Health fournit aussi une meilleure fiabilité du système d'exploitation, et une expérience améliorée pour l'utilisateur, en permettant un accès plus facile au contenu de l'aide et des services de support.

périphérique

Tout équipement qui peut être connecté à un réseau ou à un ordinateur ; par exemple, une imprimante, une manette de jeu, une carte modem ou tout autre équipement périphérique. Les périphériques requièrent normalement un pilote de périphérique pour fonctionner avec Windows.

Voir aussi : pilote de périphérique

périphérique de stockage de masse

Terme générique pour le disque, le disque optique ou tout autre périphérique qui fournit un stockage permanent pour les données d'ordinateur.

périphérique LPT

Voir la définition pour : périphérique parallèle

périphérique parallèle

Périphérique qui utilise une connexion parallèle.

périphérique PCMCIA

Périphérique amovible, ayant approximativement la taille d'une carte de crédit, et pouvant être inséré dans un emplacement PCMCIA d'un ordinateur portable. Les périphériques PCMCIA peuvent être des modems, des cartes réseau et des disques durs.

Certaines cartes PCMCIA peuvent être connectées et déconnectées sans qu'il ne soit nécessaire de redémarrer l'ordinateur. Cependant, avant de retirer la carte PCMCIA, il est recommandé d'utiliser l'Assistant Ajout de matériel pour prévenir Windows de l'opération. Windows vous notifie lorsque vous pouvez déconnecter le périphérique.

périphérique série (COM)

Chaîne jusqu'à 256 caractères avec cinq champs obligatoires et dix choix optionnels, tels que définis dans le chapitre 3 de la spécification concernant le périphérique Plug-and-Play COM, v. 10.

périphériques ajoutés

Périphériques généralement ajoutés à un PC de base pour augmenter ses fonctionnalités, tels que contrôleurs audio, réseau, graphiques ou SCSI. Les périphériques ajoutés se divisent en deux catégories : les périphériques intégrés à la carte mère, et les périphériques sur des cartes d'extension, ajoutées au système grâce à un connecteur de la carte mère, tel que PCI.

périphériques système

Périphériques sur une carte système, tels que les contrôleurs d'interruption, le contrôleur clavier, l'horloge en temps réel, les registres de page DMA, les contrôleurs DMA, les contrôleurs de mémoire, FDC, les ports IDE, les ports parallèle et série, les ponts PCI, et ainsi de suite. Dans les PC actuels, ces périphériques sont intégrés dans le jeu d'instructions de la puce principale.

personnalisation

Actions consistant à incorporer un nom de société, un logo, des informations de support technique et des fichiers d'aide dans le programme d'installation de Microsoft Windows.

peupler

Pour importer des données préparées à l'aide d'une procédure logicielle au lieu que ces informations ne soient entrées par l'utilisateur final.

PIC

Contrôleur d'interruptions programmables. Ce type de matériel ne peut pas être utilisé dans les ordinateurs à processeurs multiples, et la vitesse de traitement est inférieure à celle du matériel APIC similaire.

pilote

Code en mode kernel utilisé pour contrôler ou émuler un périphérique matériel.

pilote de carte réseau

Pilote de périphérique qui travaille directement avec la carte réseau en faisant office d'intermédiaire entre la carte et le pilote de protocole.

pilote de périphérique

Programme qui permet à un périphérique spécifique, comme un modem, un adaptateur réseau ou une imprimante de communiquer avec le système d'exploitation. Tout périphérique installé sur votre système ne peut être utilisé par Windows que lorsque le pilote approprié a été installé et configuré.

Si un périphérique est répertorié dans la liste de compatibilité matérielle (HCL), un pilote est généralement fourni avec Windows. Les pilotes de périphériques se chargent automatiquement (pour tous les périphériques activés) au démarrage de l'ordinateur, et s'exécutent ensuite de manière invisible.

Voir aussi : Liste du matériel compatible (HCL, Hardware Compatibility List)

pilote disponible dans le système d'exploitation

Pilote contenu dans le fichier Driver.cab, situé dans le dossier i386 du CD-ROM Windows. Les ID matériels Plug-and-Play des pilotes disponibles sont spécifiés dans Machine.inf, Scsi.inf, Pnpscsi.inf et Mshdc.inf.

pilote en couches

Un des ensembles de pilotes qui répondent aux mêmes IRP. Le pilote en couches décrit les pilotes du plus haut et du plus bas niveau dans une chaîne de pilotes en couches qui traitent les mêmes IRP, ainsi que tous les pilotes intermédiaires dans la chaîne.

pilote en mode kernel

Pilote d'un périphérique logique, virtuel ou physique.

pilote monolithique

Pilote qui contient plusieurs classes différentes de fonctionnalité.

pilote signé

Pilote qui satisfait aux critères du programme de logo Windows. Pour des raisons de performances et de stabilité, Microsoft recommande vivement de n'utiliser que des pilotes signés pour remplacer ou mettre à jour les pilotes existants.

pilotes fournis par un fabricant tiers

Pilotes de périphériques qui ne sont pas inclus dans les fichiers CAB.

Voir aussi : Driver.cab

piratage

Copie non autorisée, distribution et utilisation de logiciels, ou vol de logiciels.

pixels

Abréviation pour tout type d'images. Plus petit élément d'affichage par matrice, représenté par un point, avec une couleur et une luminosité spécifiées. Une méthode de mesure de la résolution d'une image est d'indiquer le nombre de pixels utilisés pour créer les images.

Plug-and-Play

Ensemble de spécifications, développé par Intel Corporation, qui permet à un ordinateur de détecter et de configurer automatiquement un périphérique, ainsi que d'installer les pilotes appropriés.

Voir aussi : bus série universel (USB, Universal Serial Bus)

point de contrôle

Identificateur pour une page spécifique ou un jeu de pages reliées de façon conceptuelle, qui assurent le suivi de la navigation de l'utilisateur dans l'accueil de Windows.

point de montage

Voir la définition pour : point de montage de volume

point de montage de volume

Point d'accès à un volume que les utilisateurs et les applications peuvent utiliser pour unifier des systèmes de fichiers disparates en un seul système logique.

police

Représentation graphique appliquée à un ensemble de chiffres, de symboles et de caractères. Une police décrit un dessin de caractère déterminé ainsi que d'autres qualités telles que la taille, l'espacement et le pas.

Voir aussi : polices OpenType

polices OpenType

Les polices de contour peuvent être rendues à partir de commandes de lignes et de courbes. Elles peuvent en outre subir une rotation et être mises à l'échelle. Les polices OpenType sont nettes et lisibles dans toutes les tailles et sur tous les périphériques de sortie pris en charge par Windows. OpenType est une extension de la technologie de police TrueType.

Voir aussi : police

port d'entrée/sortie (E/S)

Canal de transfert des données entre un périphérique et le microprocesseur. Le microprocesseur considère le port comme une ou plusieurs adresses mémoire qu'il peut utiliser pour envoyer ou recevoir des données.

Voir aussi : adresse mémoire ; périphérique ; ports

ports

Point de connexion de votre ordinateur auquel vous pouvez raccorder des périphériques qui passent des données de/vers un ordinateur. Une imprimante, par exemple, est généralement connectée à un port parallèle (également appelé port LPT) et un modem à un port série (également appelé port COM).

Voir aussi : bus série universel (USB, Universal Serial Bus)

POST

Voir la définition pour : autotest de mise en route (POST, power-on self test)

préinstallation

Action d'installer et de configurer Windows XP sur de nouveaux ordinateurs qui sont ensuite distribués aux utilisateurs finals.

préinstallation SLP (system-locked preinstallation)

Technologie liée à l'activation de produit Windows (WPA, Windows Product Activation) qui permet de limiter l'utilisation du logiciel de système d'exploitation acquis légalement au seul ordinateur sur lequel il a été distribué à l'origine par un OEM soumis à redevance, conformément aux droits d'utilisation accordés dans le Contrat de Licence Utilisateur Final (CLUF) applicable. Des détails sur la préinstallation SLP sont disponibles pour les OEM soumis à redevance dans un livre blanc séparé.

préinstaller

Pour installer et configurer Windows XP sur de nouveaux ordinateurs qui sont ensuite distribués aux utilisateurs finals.

première mise en route

Logiciel que l'utilisateur final voit la première fois qu'il démarre un nouvel ordinateur. L'expérience de première exécution est appelée Accueil de Windows dans Windows XP et mini-installation dans la famille de systèmes d'exploitation Windows Server.

Voir aussi : Accueil de Windows

programme de logo Windows

Programme de certification pour permettre aux clients d'identifier les systèmes, matériels et logiciels qui répondent à une définition essentielle des fonctions et des qualités définies par la plate-forme pour assurer une utilisation efficace de Windows.

programme de premier plan

Programme exécuté dans la fenêtre active (fenêtre la plus en avant, avec la barre de titre mise en évidence). Le programme de premier plan réagit aux commandes entrées par l'utilisateur.

programme d'installation de Windows

Le programme qui installe le système d'exploitation Windows.

Protection de fichiers Windows

Fonctionnalité exécutée en arrière-plan qui protège vos fichiers système contre l'écriture. Lorsqu'un fichier est modifié dans un dossier protégé, la protection de fichiers Windows détermine si le nouveau fichier est la version correcte de Microsoft ou si le fichier a été signé numériquement. Si non, le fichier modifié est remplacé par une version valable.

Protection des fichiers système

Voir la définition pour : Protection de fichiers Windows

protocole

Ensemble de règles et de conventions relatives à l'envoi d'informations sur un réseau. Ces règles régissent le contenu, le format, la synchronisation, la mise en séquence et le contrôle des erreurs des messages échangés entre les périphériques du réseau.

Voir aussi : Protocole Internet (IP) ; protocole TCP/IP (Transmission Control Protocol/Internet Protocol)

protocole AppleTalk

Ensemble de protocoles réseau sur lequel est basée l'architecture réseau AppleTalk. Le protocole AppleTalk est installé avec les Services pour Macintosh pour permettre aux utilisateurs d'accéder aux ressources d'un réseau.

Voir aussi : protocole ; ressource

protocole de transport compatible IPX/SPX/NetBIOS (NWLink)

Mise en œuvre des protocoles IPX (Internetwork Packet Exchange), SPX (Sequenced Packet Exchange) et NetBIOS utilisés dans les réseaux Novell. NWLink est un protocole réseau standard prenant en charge le routage et capable de prendre en charge les applications client-serveur NetWare, qui permet à des applications préparées pour NetWare et basées sur les sockets de communiquer avec des applications IPX/SPX basées elles aussi sur les sockets.

Voir aussi : IPX/SPX (Internetwork Packet Exchange/Sequenced Packet Exchange) ; NetBIOS (network basic input/output system)

protocole DHCP (Dynamic Host Configuration Protocol)

Protocole de service TCP/IP qui offre une configuration louée dynamique d'adresses IP hôte et qui distribue d'autres paramètres de configuration aux clients réseau admissibles. DHCP fournit une configuration de réseau TCP/IP sûre, fiable et simple, qui évite les conflits d'adresse et permet de continuer à utiliser sur le réseau les adresses IP des clients.

DHCP utilise un modèle client/serveur dans lequel le serveur DHCP assure la gestion centralisée des adresses IP utilisées sur le réseau. Les clients qui prennent en charge DHCP peuvent ensuite demander et obtenir la location d'une adresse IP auprès d'un serveur DHCP dans le cadre de leur procédure d'amorçage réseau.

Voir aussi : adresse IP ; bail ; protocole TCP/IP (Transmission Control Protocol/Internet Protocol) ; service

Protocole Internet (IP)

Protocole routable faisant partie de la suite de protocoles TCP/IP et prenant en charge l'adressage IP, le routage ainsi que la fragmentation et le réassemblage des paquets IP.

Voir aussi : protocole TCP/IP (Transmission Control Protocol/Internet Protocol)

protocole L2TP (Layer Two Tunneling Protocol)

Protocole de tunneling Internet standard qui assure l'encapsulation pour l'envoi de trames PPP (Point-to-Point Protocol) à travers un support orienté paquet. Pour les réseaux IP, les envois L2TP s'effectuent sous forme de messages UDP (User Datagram Protocol). Dans les systèmes d'exploitation Microsoft, L2TP est utilisé conjointement avec IPSec (Internet Protocol security) comme technologie de réseau privé virtuel (VPN, virtual private network) pour fournir des connexions d'accès distant ou des connexions VPN de routeur à routeur. L2TP est décrit dans la RFC 2661.

Voir aussi : protocole PPP (Point-to-Point Protocol)

protocole LDAP (Lightweight Directory Access Protocol)

Protocole d'accès principal pour Active Directory. LDAP est un protocole standard, établi par le groupe de travail IETF (Internet Engineering Task Force), qui permet aux utilisateurs d'interroger un service d'annuaire et d'y mettre à jour des informations. Active Directory prend en charge LDAP version 2 et LDAP version 3.

Voir aussi : Active Directory ; protocole

protocole NNTP (Network News Transfer Protocol)

Membre de la suite de protocoles TCP/IP utilisé pour distribuer les messages de News réseau aux serveurs et clients (lecteurs de News) NNTP sur Internet. Le protocole NNTP est conçu afin de stocker les articles de News sur un serveur dans une base de données centrale, ce qui permet à un utilisateur de sélectionner des éléments spécifiques à lire.

Voir aussi : protocole TCP/IP (Transmission Control Protocol/Internet Protocol)

protocole PPP (Point-to-Point Protocol)

Suite de protocoles standard de l'industrie régissant l'utilisation de liaisons point-par-point pour le transport de datagrammes multi-protocoles. PPP est documenté dans la RFC 1661.

Voir aussi : accès à distance ; protocole TCP/IP (Transmission Control Protocol/Internet Protocol)

protocole PPTP (Point-to-Point Tunneling Protocol)

Technologie de réseau qui prend en charge les réseaux privés virtuels (VPN, Virtual Private Network) multiprotocoles et permet aux utilisateurs distants d'accéder aux réseaux d'entreprise en toute sécurité par l'intermédiaire d'Internet, soit en appelant un fournisseur de services Internet, soit en se connectant directement à Internet. PPTP encapsule (fait passer par un tunnel) le trafic IP, IPX ou NetBEUI dans des paquets IP. Autrement dit, les utilisateurs peuvent exécuter à distance des applications qui sont tributaires d'un protocole réseau déterminé.

Voir aussi : IPX (Internetwork Packet Exchange) ; NetBEUI (NetBIOS Extended User Interface) ; Protocole Internet (IP)

protocole PXE (Pre-boot eXecution Environment)

Extension du protocole DHCP qui permet l'envoi d'informations à des systèmes démarrables à distance et permet à ces systèmes de rechercher les serveurs RIS.

protocole SMTP (Simple Mail Transfer Protocol)

Membre de la suite de protocoles TCP/IP qui régit l'échange de courrier électronique entre des agents de transfert de messages.

Voir aussi : protocole ; protocole TCP/IP (Transmission Control Protocol/Internet Protocol)

protocole TCP/IP (Transmission Control Protocol/Internet Protocol)

Ensemble de protocoles réseau largement utilisés sur Internet qui assurent les communications entre des réseaux interconnectés d'ordinateurs possédant des architectures matérielles et des systèmes d'exploitation différents. TCP/IP comprend des normes qui régissent la manière dont les ordinateurs communiquent ainsi que des conventions relatives à la connexion des réseaux et au routage du trafic.

Voir aussi : protocole ; Protocole Internet (IP)

proxy

Pare-feu et serveur de cache de contenu qui fournit la sécurité Internet et améliore les performances du réseau.

PXE

Voir la définition pour : environnement PXE (Pre-boot eXecution Environment)

Q

QFE

Correctif QFE. Généralement appelé correctif logiciel.

Voir aussi : correctif

R

racine

Niveau le plus haut ou le plus élevé dans un ensemble d'informations organisé hiérarchiquement. La racine est le point de départ de l'arborescence logique des sous-ensembles qui va d'une vision générale à une vision plus en détail au fur et à mesure de la descente dans la hiérarchie.

Voir aussi : Autorité de certification racine ; certificat racine

RAID (Redundant Array of Independent Disks)

Méthode utilisée pour normaliser et classer les systèmes de disques à tolérance de pannes. Les différents niveaux RAID offrent différentes combinaisons de performances, de fiabilité et de coûts. Certains serveurs proposent trois niveaux RAID : Niveau 0 (agrégat par bande), Niveau 1 (en miroir), et niveau 5 (RAID-5).

Voir aussi : tolérance de pannes ; volume RAID-5

RAM

Voir la définition pour : mémoire vive (RAM)

ratio d'aspect

Rapport entre la largeur et la hauteur d'une image. Quand une image est affichée sur des écrans différents, le ratio d'aspect doit être conservé pour éviter des déformations verticales ou horizontales.

récupération ordonnée

Interruption d'un processus qui permet au système d'exploitation ou au processus parent de reprendre le contrôle normal. Ne bloque pas la machine, et n'a pas pour conséquence une erreur de protection générale (GPF) ou un écran bleu. L'utilisateur n'a pas besoin de fermer l'application, et peut continuer à utiliser les autres fonctionnalités.

redémarrer

Opération consistant à redémarrer un ordinateur en rechargeant le système d'exploitation. Ceci peut être fait grâce à un redémarrage complet, par exemple en éteignant et en rallumant l'ordinateur, ou par un redémarrage à chaud, obtenu généralement en appuyant sur CTRL + ALT + SUPPR, en cliquant sur Arrêter le système puis sur Redémarrer.

registre

Emplacement de base de données destiné aux informations relatives à la configuration d'un ordinateur. Le Registre contient des informations auxquelles Windows se réfère en permanence, notamment :

  • les profils de chaque utilisateur ;
  • les programmes installés sur l'ordinateur et les types de documents qu'ils peuvent créer ;
  • les paramètres de propriété des dossiers et des icônes de programme ;
  • le matériel présent sur le système ;
  • les ports actuellement utilisés.

Le Registre est organisé de manière hiérarchique sous forme d'arborescence ; en outre, il est constitué de clés, de sous-clés, de ruches et d'entrées.

Voir aussi : ruche ; sous-clé ; touche

réplica

Dans la réplication Active Directory, instance d'une partition Active Directory logique qui est synchronisée grâce à la réplication entre les contrôleurs de domaine détenant des copies de la même partition d'annuaire. Un réplica peut également désigner une instance d'un objet ou d'un attribut dans un annuaire distribué.

Dans le service de réplication de fichiers (FRS, File Replication service), il s'agit de l'ordinateur qui a été inclus dans la configuration d'un jeu de réplicas spécifique.

réplicateur autorisé

Société indépendante ayant obtenu une licence de Microsoft Licensing, Inc. pour gérer la production et la distribution de produits OEM Microsoft aux fabricants OEM. Microsoft Licensing, Inc. fournit au réplicateur autorisé les composants maîtres, les spécifications de fabrication et d'assemblage, et toutes autres instructions utiles. Le réplicateur autorisé fabrique et assemble des produits Microsoft authentiques et conformes aux spécifications. Les avantages de l'utilisation de réplicateurs autorisés comprennent la protection contre le piratage, l'obtention de logiciels dont la haute qualité est constante, et les prix compétitifs.

requête d'interruption (IRQ)

Signal envoyé par un périphérique pour attirer l'attention du processeur lorsque le périphérique est prêt à recevoir ou envoyer des informations. Chaque périphérique envoie ses requêtes interrompues via une ligne de matériel spécifique. Un numéro IRQ unique doit être attribué à chaque périphérique.

reseal

Pour préparer le système d'exploitation à la livraison à l'utilisateur final, après avoir procédé à tout traitement complémentaire ou validation à l'usine. Exécuter Sysprep -reseal à la fin de votre processus de fabrication pour sceller l'ordinateur.

réseau étendu (WAN)

Réseau de communication permettant de relier des ordinateurs, imprimantes ou autres périphériques éloignés géographiquement. N'importe quel périphérique connecté peut communiquer avec tous les autres périphériques du réseau étendu.

Voir aussi : périphérique ; réseau local (LAN, Local Area Network)

réseau local (LAN, Local Area Network)

Réseau de communication permettant de connecter des ordinateurs, des imprimantes et d'autres périphériques situés dans une zone limitée (par exemple, dans un immeuble). N'importe quel périphérique connecté peut communiquer avec tous les autres périphériques du réseau local.

Voir aussi : groupe de travail ; NetBEUI (NetBIOS Extended User Interface) ; NetBIOS (network basic input/output system)

résolution de noms

Processus de traduction logicielle entre, d'une part les noms faciles à utiliser pour les utilisateurs et, d'autre part, les adresses IP numériques, peu évocatrices pour les utilisateurs mais nécessaires pour les communications TCP/IP. La résolution de noms peut être fournie par des composants logiciels tels que DNS ou WINS.

Voir aussi : protocole TCP/IP (Transmission Control Protocol/Internet Protocol) ; service WINS (Windows Internet Name Service)

résolution des images

Finesse et grain d'une image lors de sa numérisation, mesurés en points par pouce (PPP), et qui s'étendent en général entre 200 et 400 PPP.

ressource

En général, partie quelconque d'un ordinateur ou d'un réseau, notamment un lecteur de disque, une imprimante ou de la mémoire, qui peut être allouée à un processus ou un programme d'exécution.

Pour le Gestionnaire de périphériques, un des quatre composants système qui contrôle la manière dont fonctionnent les périphériques sur un ordinateur. Ces quatre ressources système comprennent les lignes de requête d'interruption (IRQ), les canaux d'accès direct à la mémoire (DMA), les ports d'entrée/sortie et les adresses mémoire.

Pour les clusters de serveurs, entité physique ou logique qui est susceptible d'être gérée par un cluster, d'être connectée et mise hors connexion, et d'être déplacée entre des nœuds. Une ressource peut être la propriété d'un seul nœud, à tout moment.

Voir aussi : adresse mémoire ; cluster de serveurs ; lignes de requête d'interruption (IRQ) ; nœud ; port d'entrée/sortie (E/S)

restauration du système

Outil qui recherche les modifications sur votre ordinateur et crée un point de restauration lorsqu'il détecte le début d'un changement. Vous pouvez utiliser l'Assistant Restauration du système pour sélectionner un point de restauration et restaurer votre ordinateur à un état antérieur, dans lequel il fonctionnait correctement.

revendeur à valeur ajoutée (VAR, Value Added Reseller)

Société qui revend du matériel et des logiciels à des développeurs et/ou à des utilisateurs finals.

RIS

Voir la définition pour : serveur d'installation à distance (RIS)

RISC

Voir la définition pour : ordinateur à jeu d'instruction réduit

routage

Processus de transfert d'un paquet d'un hôte source à un hôte de destination via une interconnexion.

ruche

Fichier dans lequel le système stocke une partie du Registre (ce nom a été choisi par analogie avec la structure alvéolée d'une ruche d'abeilles). Une ruche est sauvegardée par un fichier unique et un fichier .log qui se trouvent dans le dossier racine_système\System32\Config ou le dossier racine_système\Profiles\nom_utilisateur.

Par défaut, la plupart de ces fichiers (par défaut, SAM, sécurité et système) sont stockés dans le dossier racine_système\System32\Config. Le dossier racine_système\Profiles contient le profil d'utilisateur de tous les utilisateurs de l'ordinateur. Puisqu'une ruche est un fichier, elle peut être déplacée d'un système à un autre. Cependant, vous devez utiliser l'Éditeur de Registre, Regedit.exe, pour modifier le fichier.

Voir aussi : registre ; systemroot ; touche

S

SBSI

Voir la définition pour : formation interactive pas à pas (SBSI, Step-by-Step Interactive)

script

Type de programme constitué d'un jeu d'instructions pour une application ou un programme d'outil. Un script exprime généralement des instructions en employant les règles et la syntaxe de l'application ou de l'outil, avec des structures de commande simples telles que des boucles et des expressions if/then (si/alors). Dans l'environnement Windows, « batch » ou programme de traitement par lots est synonyme de « script ».

SCSI

Voir la définition pour : interface SCSI (small computer system interface)

seal

Voir la définition pour : reseal

secteur de démarrage de partition

Partie d'une partition de disque dur qui contient des informations relatives au système de fichiers du disque et un petit programme en langage machine qui charge le système d'exploitation Windows.

Voir aussi : partition

serveur

En général, ordinateur qui fournit des ressources partagées aux utilisateurs réseau.

Voir aussi : client

serveur autonome

Ordinateur qui exécute Windows 2000 Server sans faire partie d'un domaine. Un serveur autonome ne possède que sa base de données d'utilisateurs et traite lui-même les demandes d'ouverture de session. Il ne partage les informations de compte avec aucun autre ordinateur et ne peut pas permettre l'accès aux comptes de domaine.

Voir aussi : domaine

serveur d'abonnement à un fournisseur de services Internet

Serveur HTTP qui automatise la tâche d'ajout de nouveaux clients à une base de données client d'un fournisseur de services Internet. Le serveur d'abonnement à Internet regroupe des informations auprès de chaque client, les ajoute à la base de données client du fournisseur de services Internet, puis renvoie un paquet de configuration vers l'ordinateur personnel du client. Le paquet de configuration contient des informations utilisées pour configurer le navigateur Internet de l'utilisateur pour la connexion suivante aux services du fournisseur de services Internet.

serveur d'accès distant

Ordinateur Windows exécutant le service de routage et d'accès distant et configuré pour fournir un accès à distance.

Voir aussi : accès à distance

serveur DHCP

Ordinateur exécutant le service Microsoft DHCP qui offre une configuration dynamique des adresses IP et des informations associées aux clients DHCP.

Voir aussi : adresse IP ; protocole DHCP (Dynamic Host Configuration Protocol)

serveur d'installation à distance (RIS)

Composant en option qui installe Windows XP Professionnel à distance. RIS installe le système d'exploitation sur des ordinateurs clients à distance qui peuvent être initialisés, en connectant l'ordinateur au réseau en commençant par l'ordinateur client, en se connectant avec un compte d'utilisateur valide et en copiant une image du système d'exploitation sur l'ordinateur client.

serveur Web

Ordinateur géré par un administrateur système ou un fournisseur de services Internet et qui répond aux requêtes du navigateur d'un utilisateur.

Voir aussi : fournisseur de services Internet (ISP)

service

Programme, routine ou processus qui exécute une fonction système déterminée en vue de prendre en charge d'autres programmes, plus particulièrement à un bas niveau (proche du matériel). Lorsque des services sont fournis par l'intermédiaire d'un réseau, ils peuvent être publiés dans Active Directory, afin de faciliter l'utilisation et l'administration assujetties à un service. Parmi les services, citons le service Gestionnaire de comptes de sécurité, le service de réplication de fichiers et le service de routage et d'accès distant.

Service Pack

Mise à niveau d'un logiciel commercialisé, contenant des fichiers mis à niveau et des correctifs logiciels.

service WINS (Windows Internet Name Service)

Service logiciel qui mappe dynamiquement les adresses IP aux noms d'ordinateur (noms NetBIOS). Cela permet aux utilisateurs d'accéder aux ressources à l'aide d'un nom plutôt que d'utiliser des adresses IP qui sont difficiles à reconnaître et à mémoriser.

Voir aussi : adresse IP ; NetBIOS (network basic input/output system) ; ressource ; service

services Internet (IIS)

Services logiciels qui prennent en charge la création, la configuration et la gestion de site Web, ainsi que d'autres fonctions Internet. Les services Internet (IIS) comprennent le protocole NNTP (Network News Transfer Protocol), le protocole FTP (File Transfer Protocol) et le protocole SMTP (Simple Mail Transfer Protocol).

Voir aussi : FTP (File Transfer Protocol) ; protocole NNTP (Network News Transfer Protocol) ; protocole SMTP (Simple Mail Transfer Protocol)

services TCP/IP simples

Quatre services TCP/IP : Générateur de caractères, Heure du jour, Rejet, Écho et Citation du jour.

Voir aussi : protocole TCP/IP (Transmission Control Protocol/Internet Protocol) ; service

Setupapi.log

Un fichier journal fournit des informations utiles pour résoudre et déboguer l'installation, l'installation de périphériques et d'autres problèmes de ce type. Les informations stockées dans le fichier journal comprennent les erreurs, les avertissements et d'autres informations destinées à l'installation de Windows, y compris des données concernant l'heure.

Setupcl.exe

Exécutable invoqué par Sysprep.exe qui reconnaît les ID de sécurité (SIDs). Il doit se trouver dans le même dossier que Sysprep.exe.

Voir aussi : identificateur de sécurité (SID, Security ID) ; Sysprep.exe

signature

Voir la définition pour : signature numérique

signature numérique

Moyen dont dispose le créateur d'un message d'un fichier ou de toute autre information codée numériquement, de lier son identité à l'information. Le processus de signature numérique de l'information implique la transformation de celle-ci, ainsi que d'autres informations secrètes connues de l'expéditeur, dans une balise appelée signature. Les signatures numériques sont utilisées dans les environnements de clés publiques et fournissent des services d'intégrité et de non-répudiation.

Voir aussi : dateur ; service

SKU

unité Shelf keeping. Dans ce cas, produit particulier qui correspond à une édition spécifique de Windows XP.

sous-arborescence

Nœud d'une arborescence, ainsi que n'importe quelle sélection de nœuds descendants connectés.

Niveau le plus élevé dans le Registre (par exemple, HKEY_LOCAL_MACHINE).

Voir aussi : nœud ; registre ; sous-clé ; touche

sous-clé

Élément du Registre qui contient des entrées ou d'autres sous-clés. Niveau du Registre situé immédiatement au-dessous d'une clé ou d'une sous-arborescence (si la sous-arborescence ne contient pas de clés).

Voir aussi : registre ; sous-arborescence ; touche

spécifications de bits

Nombres de couleurs ou de niveaux de gris qui peuvent être affichés en même temps. Dépend de la quantité de mémoire sur la carte graphique de l'ordinateur. Un contrôleur 8 bits peut afficher 256 couleurs ou niveaux de gris ; un contrôleur 16 bits, 64 000 couleurs ; et un contrôleur 24 bits, 16,8 millions de couleurs.

stade

Faire une copie des répertoires et fichiers à installer dans un ordinateur sans configurer les réglages de registre.

Voir aussi : attacher ; détacher ; ordinateur de destination

station d'accueil

Unité d'accueil d'un ordinateur portable qui contient une connexion à une source d'alimentation, des connecteurs d'extension et des connexions à des périphériques, notamment un moniteur, une imprimante, un clavier complet et une souris. La station d'accueil transforme l'ordinateur portable en un ordinateur de bureau.

Voir aussi : ancrer

Stratégie de groupe

Infrastructure qui, dans le service d'annuaire Active Directory, permet de modifier les paramètres d'utilisateur et d'ordinateur dans l'annuaire et de gérer leur configuration, notamment en matière de sécurité et d'authentification. Vous utilisez la stratégie de groupe pour définir des configurations pour des groupes d'utilisateurs et d'ordinateurs. Dans le cadre de la stratégie de groupe, vous pouvez spécifier des paramètres pour les stratégies basées sur le Registre, la sécurité, l'installation de logiciel, les scripts, la redirection de dossier, les services d'installation à distance et la maintenance d'Internet Explorer. Les paramètres de stratégie de groupe que vous créez sont contenus dans un objet Stratégie de groupe (GPO, Group Policy object). En associant un GPO à des conteneurs système Active Directory sélectionnés (sites, domaines et unités d'organisation), vous pouvez appliquer les paramètres de stratégie du GPO aux utilisateurs et aux ordinateurs qui se trouvent dans ces conteneurs Active Directory. Pour créer un GPO individuel, utilisez l'Éditeur d'objets Stratégie de groupe.

Voir aussi : Active Directory

support de récupération

Supports fournis par les OEM au client qui permettent à ce dernier de récupérer ou de réinstaller leur installation de Windows.

SVGA

Super VGA. Norme vidéo établie par BESA afin de fournir un affichage couleurs haute résolution sur les ordinateurs compatibles IBM. La norme SVGA la plus communément utilisée est la résolution 1024 x 768 points-image.

synchrone

Chaque application ou commande s'effectue dans l'ordre établi et chaque élément doit se terminer avant que la commande suivante ne soit exécutée.

Syspart

Processus qui s'exécute par l'intermédiaire d'un paramètre optionnel de Winnt32.exe. Utilisé pour nettoyer des installations sur des ordinateurs ayant des matériels différents. Cette méthode d'installation automatisée réduit le temps de déploiement en éliminant la phase de copie de fichiers d'installation.

Sysprep

Outil qui prépare le disque dur d'un ordinateur source en vue d'une duplication vers des ordinateurs cibles, puis exécute un processus de création d'image de disque non-Microsoft. Cette méthode d'installation automatisée est employée lorsque le disque dur de l'ordinateur principal est identique à celui des ordinateurs cibles.

Voir aussi : identificateur de sécurité (SID, Security ID) ; ordinateur de destination ; première mise en route

Sysprep.exe

Utilitaire de Préparation Système qui utilise le fichier de réponse de Sysprep.inf pour préparer un disque système image pour duplication.

Sysprep.inf

Fichier de réponse optionnel utilisé par Sysprep qui automatise la mini-installation et adapte plus précisément le système d'exploitation installé.

Voir aussi : fichier de réponses

système de fichiers

Dans un système d'exploitation, structure d'ensemble au sein de laquelle les fichiers sont nommés, stockés et organisés. NTFS, FAT et FAT32 sont des types de systèmes de fichiers.

Voir aussi : FAT ; FAT32 ; système de fichiers NTFS

système de fichiers NTFS

Système de fichiers avancé qui offre des performances, une sécurité, une fiabilité et des fonctionnalités avancées qui ne se retrouvent dans aucune version de FAT. Par exemple, NTFS garantit la cohérence des volumes en utilisant des techniques standard d'ouverture de transaction et de restauration. Si un système présente une défaillance, NTFS utilise son fichier journal et ses informations de points de vérification pour restaurer la cohérence du système de fichiers. NTFS fournit également des fonctionnalités avancées telles que les autorisations sur fichiers et dossiers, le cryptage, les quotas de disque et la compression.

Voir aussi : FAT32 ; système de fichiers ; table d'allocation des fichiers (FAT, File Allocation Table)

systemroot

Chemin d'accès et nom du dossier dans lequel se situent les fichiers système Windows. Généralement, il s'agit de C:\Windows, bien que vous puissiez désigner un lecteur ou un dossier différent quand vous installez Windows. Vous pouvez utiliser la valeur %systemroot% pour substituer l'emplacement réel du dossier qui contient les fichiers système de Windows. Pour identifier votre dossier systemroot, cliquez sur Démarrer, sur Exécuter, tapez %systemroot%, puis cliquez sur OK.

T

table d'allocation des fichiers (FAT, File Allocation Table)

Système de fichiers utilisé par MS-DOS et certains systèmes d'exploitation Windows pour organiser et gérer les fichiers. La table d'allocation de fichiers (FAT) est une structure de données créée par Windows lors du formatage d'un volume en utilisant les systèmes de fichiers FAT ou FAT32. Windows stocke les informations relatives à chaque fichier dans la FAT de façon à pouvoir retrouver le fichier ensuite.

Voir aussi : FAT32 ; système de fichiers ; système de fichiers NTFS

table de fichiers principale (MFT, Master File Table)

Fichier système NTFS de volumes formatés pour NTFS, qui contient des informations relatives à chaque fichier et dossier du volume. La table de fichiers principale (MFT) est le premier fichier d'un volume NTFS.

Voir aussi : système de fichiers NTFS ; table d'allocation des fichiers (FAT, File Allocation Table)

TAM

Voir la définition pour : Gestionnaire de compte technique (TAM, Technical Account Manager)

TAPI

Voir la définition pour : API de téléphonie (TAPI)

taxonomie

Dans le Centre d'aide et de support de Windows XP, système de classification qui organise les rubriques d'aide en catégories distinctes.

TCM

Tests de compatibilité de matériel. Suite de tests effectués par le Laboratoire de qualité du matériel Windows (WHQL, Windows Hardware Quality Labs) pour vérifier les opérations de pilote de périphérique et de matériel sous un environnement de fonctionnement spécifique. Ces tests ont recours à un ensemble composé d'un périphérique, d'un pilote logiciel et d'un système d'exploitation sous certaines conditions, pour vérifier que tous les composants fonctionnent correctement.

Voir aussi : Laboratoire de qualité du matériel Windows

TCP/IP

Voir la définition pour : protocole TCP/IP (Transmission Control Protocol/Internet Protocol)

téléphonie

Technologie du téléphone ; transmission de communications vocales, de télécopies et de données basée soit sur la conversion du son en signaux électriques, soit sur la communication sans fil au moyen d'ondes radio.

tolérance de pannes

Capacité des composants matériels et logiciels d'un ordinateur à assurer l'intégrité des données en cas de défaillance matérielle. Les fonctionnalités de tolérance de pannes figurent dans de nombreux systèmes d'exploitation de serveur et comprennent les volumes en miroir, les volumes RAID-5 et les clusters de serveurs.

Voir aussi : cluster ; volume en miroir ; volume RAID-5

topologie

Sur Windows, relation entre un ensemble de composants réseau. Dans le contexte de la réplication Active Directory, la topologie fait référence à l'ensemble de connexions que les contrôleurs de domaine utilisent pour répliquer les informations entre eux.

Voir aussi : Active Directory ; contrôleur de domaine

touche

Dans l'Éditeur du Registre, dossier qui apparaît dans le panneau gauche de la fenêtre de l'Éditeur de Registre. Une clé peut contenir des sous-clés et des entrées. Environment, par exemple, est une clé de HKEY_CURRENT_USER.

Dans IPSec (IP Security), valeur utilisée conjointement avec un algorithme en vue de crypter ou de décrypter des données. Les paramètres de clé de IPSec peuvent être configurés afin d'offrir davantage de sécurité.

Voir aussi : registre ; sous-clé

Txtsetup.oem

Un fichier texte identifiant des composants matériels pris en charge, les fichiers à copier du disque pour le composant matériel et qui liste les touches de registre et les valeurs à créer pour le composant matériel. Ceci est utilisé uniquement durant l'installation en mode texte.

type de matériel

Classification de périphériques semblables. Par exemple, Périphérique d'images est un type de matériel qui s'applique aux appareils photo numériques et aux scanneurs.

Voir aussi : périphérique

U

Unattend.txt

Nom générique pour le fichier de réponse de l'Installation de Windows. Dans la méthode de préinstallation du démarrage à partir du CD-ROM, Unattend.txt doit être renommé par Winnt.sif.

Voir aussi : démarrage à partir d'un lecteur de CD-ROM ; fichier de réponses ; programme d'installation de Windows ; Winnt.exe

UNC

Voir la définition pour : convention d'affectation des noms (UNC, Universal Naming Convention)

Unicode

Standard de codage des caractères développé par le consortium Unicode couvrant pratiquement toutes les langues écrites existantes. Le répertoire des caractères Unicode inclut plusieurs formes de représentation, notamment les formes d'encodage UTF-8, UTF-16 et UTF-32. La plupart des interfaces Windows adoptent l'encodage UTF-16.

Voir aussi : ASCII (American Standard Code for Information Interchange) ; format UTF-8 (UCS Transformation Format 8)

uniprocesseur

Ordinateur avec un processeur unique.

Voir aussi : multiprocesseur

unité d'allocation

Plus petite quantité d'espace disque susceptible d'être allouée pour l'enregistrement d'un fichier. Tous les fichiers système utilisés par Windows organisent les disques durs en fonction des unités d'allocation. Plus la taille de l'unité d'allocation est petite, plus le stockage des informations s'avère efficace. Si vous ne spécifiez pas de taille d'unité d'allocation lorsque vous formatez le disque, Windows sélectionne des tailles par défaut en fonction de la taille du volume. Ces tailles par défaut sont sélectionnées en vue de réduire l'espace perdu et la fragmentation du volume. Également appelée cluster.

Voir aussi : système de fichiers

USB

Voir la définition pour : bus série universel (USB, Universal Serial Bus)

UTF-8

Voir la définition pour : format UTF-8 (UCS Transformation Format 8)

utilisateur

Personne qui achète un nouvel ordinateur.

utilisateur final

Personne se servant de l'ordinateur fabriqué par l'OEM.

Utilisateurs et ordinateurs Active Directory

Outil d'administration utilisé par un administrateur pour exécuter des tâches d'administration quotidiennes relatives à Active Directory. Ces tâches consistent notamment à créer, supprimer, modifier ou déplacer des objets stockés dans l'annuaire et à définir des autorisations pour ces objets. Les unités d'organisation, les utilisateurs, les contacts, les groupes, les ordinateurs, les imprimantes et les fichiers partagés constituent autant d'exemples d'objets de l'annuaire Active Directory.

Voir aussi : Active Directory ; autorisation ; objet

V

VAR (value added reseller)

Voir la définition pour : revendeur à valeur ajoutée (VAR, Value Added Reseller)

VGA

Moniteurs multiples. Adaptateur vidéo qui prend en charge une résolution couleur de 640x480 pixels. VGA est la norme d'affichage vidéo pour les périphériques de démarrage sous Windows et fournit une résolution moyenne pour le texte et l'image.

volume actif

Volume de démarrage de l'ordinateur. Le volume actif doit être un volume simple d'un disque dynamique. Vous ne pouvez pas activer un volume dynamique existant mais vous parvenez par compte à activer un disque de base contenant la partition active. Une fois le disque activé et devenu dynamique, la partition devient un volume simple actif.

Voir aussi : disque de base ; disque dynamique ; partition active ; volume dynamique ; volume simple

volume agrégé par bande

Volume qui stocke les données sous la forme d'agrégats par bande sur deux disques physiques ou davantage. Les données d'un volume agrégé par bande sont allouées de manière alternative et régulière (par bande) à ces disques. Les volumes agrégés par bande possèdent les meilleures performances de tous les volumes disponibles dans Windows 2000, mais n'offrent pas la tolérance de pannes. Si un disque d'un volume agrégé par bande connaît une défaillance, les données de la totalité du volume sont perdues. Vous pouvez créer des volumes agrégés par bande uniquement sur des disques dynamiques. Les volumes agrégés par bande ne peuvent pas être étendus ou mis en miroir.

Voir aussi : disque dynamique ; tolérance de pannes ; volume dynamique ; volume en miroir

volume de base

Partition principale ou lecteur logique résidant sur un disque de base.

Voir aussi : disque de base ; lecteur logique ; partition principale

volume dynamique

Volume qui réside sur un disque dynamique. Windows prend en charge cinq types de volumes dynamiques : simple, fractionné, agrégé par bandes, en miroir et RAID-5. Un volume dynamique est formaté en utilisant un système de fichiers, tel que FAT ou NTFS, et est identifié par une lettre de lecteur.

Voir aussi : disque de base ; disque dynamique ; volume agrégé par bande ; volume de base ; volume en miroir ; volume fractionné ; volume RAID-5 ; volume simple

volume en miroir

Volume à tolérance de pannes qui duplique les données sur deux disques physiques. Un volume en miroir assure la redondance des données en les dupliquant pour produire deux volumes identiques, appelés miroirs. Le miroir se trouve toujours sur un disque différent. En cas de défaillance d'un des disques physiques, les données qu'il contient ne sont plus disponibles, mais le système continue de fonctionner sur le miroir du disque restant. Vous ne pouvez créer des volumes en miroir que sur des disques dynamiques sur des ordinateurs exécutant un système d'exploitation de la famille Windows 2000 Server ou Windows Server 2003. Vous ne pouvez pas étendre les volumes en miroir.

Voir aussi : disque dynamique ; tolérance de pannes ; volume dynamique ; volume RAID-5

volume fractionné

Volume dynamique constitué d'espace disque réparti sur plusieurs disques physiques. Vous pouvez augmenter la taille d'un volume fractionné en l'étendant sur des disques dynamiques supplémentaires. Vous pouvez créer des volumes fractionnés uniquement sur des disques dynamiques. Les volumes fractionnés ne prennent pas en charge la tolérance de pannes et ne peuvent pas être mis en miroir.

Voir aussi : disque dynamique ; tolérance de pannes ; volume dynamique ; volume en miroir ; volume simple

volume RAID-5

Volume à tolérance de pannes dont les données et la parité sont agrégées par bande de façon intermittente sur trois disques physiques ou davantage. La parité est une valeur calculée qui permet de reconstituer des données après une défaillance. Si une partie d'un disque physique présente une défaillance, Windows restaure les données de la partie endommagée grâce aux données restantes et au contrôle de parité. Vous ne pouvez créer des volumes RAID-5 que sur des disques dynamiques sur des ordinateurs exécutant un système d'exploitation de la famille Windows 2000 Server ou Windows Server 2003. Vous ne pouvez pas mettre en miroir ni étendre de volumes RAID-5. Dans Windows NT 4.0, un volume RAID-5 était connu sous le nom d'agrégat par bandes avec parité.

Voir aussi : disque dynamique ; tolérance de pannes ; volume dynamique

volume simple

Volume dynamique constitué de l'espace disque d'un seul disque dynamique. Un volume simple peut être constitué d'une seule région d'un disque ou de plusieurs régions du même disque, liées entre elles. Si le volume simple n'est ni un volume système, ni un volume de démarrage, vous pouvez l'étendre sur le même disque ou sur des disques supplémentaires. Si vous étendez un volume simple sur plusieurs disques, il devient un volume fractionné. Vous pouvez créer des volumes simples uniquement sur des disques dynamiques. Les volumes simples ne prennent pas en charge la tolérance de pannes, mais vous pouvez les exploiter en miroir sur les ordinateurs exécutant un système d'exploitation de la famille Windows 2000 Server ou Windows Server 2003.

Voir aussi : disque dynamique ; tolérance de pannes ; volume dynamique ; volume en miroir ; volume fractionné

W

WDL

Voir la définition pour : Bibliothèque de pilotes Windows (WDL, Windows Driver Library)

WHQL (Windows Hardware Quality Labs)

Voir la définition pour : Laboratoire de qualité du matériel Windows

Windows Installer

Windows Installer est un service du système d'exploitation qui permet à ce dernier de gérer l'installation. Les technologies de Windows Installer s'articulent autour de deux axes, qui fonctionnent conjointement : un service d'installation du côté client (Msiexec.exe) et un fichier de lot (fichier .msi). Pour installer l'application, Windows Installer utilise les informations contenues dans un fichier de lot.

Winnt.exe

Utilitaire de ligne de commande utilisé pour démarrer une installation sans assistance de Windows XP à partir d'ordinateurs exécutant MS-DOS, Windows 3.1 ou Windows pour Workgroups.

Winnt.sif

Fichier de réponse contenant des informations utilisées par le programme d'installation lors de l'installation de Windows 2000 selon la méthode de démarrage à partir d'un CD-ROM.

Voir aussi : démarrage à partir d'un lecteur de CD-ROM ; fichier de réponses

Winnt32.exe

Utilitaire de ligne de commande utilisé pour démarrer une installation sans assistance de Windows XP à partir d'ordinateurs exécutant Windows 95, Windows 98, Windows NT, Windows 2000 ou Windows XP.

WinPE

Voir la définition pour : Environnement de préinstallation de Windows (WinPE)

WINS

Voir la définition pour : service WINS (Windows Internet Name Service)

Winsock

Windows Sockets. Norme API (Application Programming Interface) applicable aux logiciels qui fournissent une interface TCP/IP sous Windows.

Voir aussi : interface de programmation d'applications (API) ; protocole TCP/IP (Transmission Control Protocol/Internet Protocol)

WMI

Voir la définition pour : Infrastructure de gestion Windows (WMI, Windows Management Instrumentation)

World Wide Web

Système d'exploration d'Internet au moyen de liens hypertexte. Lorsque vous utilisez un navigateur Web, le Web se présente comme un ensemble de textes, d'images, de sons et de films numériques.

Voir aussi : Internet

X

x86

Fait référence aux microprocesseurs qui possèdent ou émulent l'architecture 32 bits d'Intel.

Y

Aucune entrée de glossaire ne commence par cette lettre.

Z

Aucune entrée de glossaire ne commence par cette lettre.


Informations légales

Les informations contenues dans ce document, y compris les URL et autres références à des sites Web Internet, pourront faire l’objet de modifications sans préavis. Sauf mention contraire, les sociétés, les organisations, les produits, les noms de domaine, les adresses électroniques, les logos, les personnes, les lieux et les événements utilisés dans les exemples sont fictifs et toute ressemblance avec des sociétés, organisations, produits, noms de domaine, adresses électroniques, logos, personnes, lieux et événements réels est purement fortuite et involontaire. L'utilisateur est tenu de respecter la réglementation relative aux droits d'auteur applicable dans son pays. Sans restriction des droits dérivés des droits d’auteur, aucune partie de ce document ne peut être reproduite, stockée ou introduite dans un système de restitution, ou transmise à quelque fin, par quelque moyen (électronique, mécanique, photocopie, enregistrement ou autre) ou dans quelque but que ce soit sans la permission expresse et écrite de Microsoft Corporation.

Microsoft peut détenir des brevets, avoir déposé des demandes d'enregistrement de brevets ou être titulaire de marques, droits d'auteur ou autres droits de propriété intellectuelle portant sur tout ou partie des éléments qui font l'objet du présent document. Sauf stipulation expresse contraire d'un contrat de licence écrit de Microsoft, la fourniture de ce document n'a pas pour effet de vous concéder une licence sur ces brevets, marques, droits d'auteur ou autres droits de propriété intellectuelle.

© 2004 Microsoft Corporation. Tous droits réservés.

Active Desktop, ActiveX, Authenticode, BackOffice, ClearType, DirectX, FrontPage, Hotmail, JScript, Microsoft, Microsoft Press, MS-DOS, MSDN, MSN, Visual Basic, Win32, Win64, Windows, le logo Windows, Windows Media, Windows NT et le logo Windows Start sont soit des marques de Microsoft Corporation, soit des marques déposées de Microsoft Corporation, aux États-Unis d'Amérique et/ou dans d’autres pays/régions.

Ce produit contient un logiciel de filtrage graphique qui est basé en partie sur le travail du groupe Independent JPEG Group.

TrueType est une marque déposée de Apple, Inc.

Les noms de sociétés et de produits mentionnés dans ce document sont des marques de leurs propriétaires respectifs.