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 What is the *.INI-Navigator?

The *.INI-Navigator was developed for the advanced Windows user to make his or her work
with Windows' INI-files faster and easier.    You can manage, edit, save, delete, backup, 
restore and print INI-files in the Windows directory or any other directory with the ease, 
simplicity and features not offered by any other Windows system file utility available.

When working with larger files such as WIN.INI, you'll be able to keep track of where you are 
and need to go, since all of the sections of the file are alphabetically sorted in a separate list
box.    This allows you to jump right to the section you want - fast - with a click of the mouse, 
thereby eliminating the tedious task of entering search patterns from the keyboard.

Once you've edited your INI-file, you can let the *.INI-Navigator create a backup copy of the 
file in its previous state when you save your changes to the hard drive.    If your changes 
don't quite achieve the results you expected, the *.INI-Navigator's built-in restore function 
can quickly restore the INI-file.    Unlike Windows' SysEdit, the backup option can be activated
or deactivated, allowing you to retain a "standard" backup copy of the INI-file and make 
numerous subsequent changes without the backup being overwritten.    In addition, all 
standard format INI-files anywhere on your computer can be edited and backed up, not just 
WIN.INI and SYSTEM.INI.    This backup/restore feature also allows the Windows newcomer to 
experiment and gain experience on how modifications to INI-files affect Windows and 
Windows applications.    If something should go awry, the restore function can undo any 
mistakes.

For the Windows user who prefers to make modifications to INI-files on his/her own, the *.INI-
Navigator is an extremely useful utility for custom tailoring and fine-tuning the performance 
of Windows and Windows applications.



 Menus and Commands

Click on a menu title below for information on the commands found in the menu.



 The Toolbar
Related Topics: The File Menu          The Edit Menu          The Options Menu

Click on any toolbar icon below for information about its function.

    Open File     Restore File     Undo

    Save File     Cut     Find

    Delete File     Copy     Sections Pop-up Menu

    Print File     Paste

Note: In the program window, clicking on any toolbar icon with the right mouse button will 
provide a description of the button's function in the adjacent status bar.



 Editing a File
Related Topics: The Edit Menu          The Options Menu

To edit an INI-file it must first be opened and loaded into the *.INI-Navigator's text editor. To 
do this, select the file you wish to edit from the list box entitled "INI-Files". Then choose the 
Open command from the File   Menu   or click the Open File icon from the toolbar (you can 
also open a file by double clicking the file name in the list box or by highlighting it with the 
cursor bar and pressing <ENTER>).

Once the INI-file is loaded, all sections contained in the file will appear in the list box entitled
Sections, and the entire contents of the file in the text editor below.

To jump to a particular section of the file in the text editor quickly, double click the desired 
section in the Sections list box, or highlight it with the cursor bar and press <ENTER>.

In the text editor, the contents of the file can be edited as with any other text editing 
program, and all of the usual Windows Clipboard functions are supported.

To save any changes you have made to the file, choose the Save command from the File 
menu, or click the Save File icon on the toolbar.

If you have activated an option for creating a backup file, it will either be automatically 
created or you will be asked if you wish to create a backup.
Please note: If you have not made any changes to the text after it has been loaded, no 
backup file will be created when you click the save file button, regardless of the backup 
option you have selected.    The logic behind this feature is to avoid unnecessary creation of 
files on the hard drive, since a backup for an unmodified file is not really required in this 
case.



 Restoring a File
Related Topics: The File Menu          The Options Menu

If you have modified an INI-file, and your changes have brought about unwanted or 
unexpected results, you can restore the file to its previous state by using the built-in restore 
function offered by the *.INI-Navigator (provided you have chosen to create a backup upon 
saving your changes).

To restore an INI-file, follow these steps:

Open the Restore INI-File window by choosing Restore... from the File   menu   or by 
clicking the "Restore" icon in the toolbar.

A list of all available backup files located in the current working directory will appear in a 
list box on the left side of the window.    If no backup files are present, a message will 
appear alerting you to the fact.    The backup files created by the *.INI-Navigator have the 
same file name as their corresponding INI-file, but have the extension .NAV.

If you wish to restore an INI-file located in a directory other than the current working 
directory, click the Browse... button.    Use the Directories dialog box to change to the 
directory containing the backup file you wish to use.    The list on the left will show all 
available backup files found in the directory chosen. Click OK to change directories.

In the Restore INI-File window, highlight the file name you wish to use to restore the INI-
file and click the Select button.    You can also select the file by pressing <ENTER> or by 
double clicking on the file name with the mouse.

In the adjacent status box, a description of the restore process will appear, with 
information as to the creation dates and times for each file involved.    If you want the 
backup file to be deleted from the hard drive after the restore process is complete, 
activate the check box option Delete backup file after restoring.    Otherwise, the 
backup file will remain in the directory.

To begin the restore process, click the Continue button.    To abort the process, choose 
Cancel.    If you continue, a dialog box will appear asking you to confirm the restore 
process.    Choose Yes to complete the restoration of the file.    Once the process is 
complete, the Restore INI-File window will close automatically.

Note: If you have restored an INI-file which was loaded in the text editor at the time you 
opened the Restore INI-File window, the contents of the text editor will be automatically 
updated to show the new contents of the file.

You can close the Restore INI-File window at any time by choosing the Close button.



 Printing a File
Related Topic: The File Menu

To print an INI-file, it must first be loaded into the text editor.    Then, choose the Print... 
command from the File   menu  .    A dialog box will appear with which you confirm your print 
job.    Here, you can also change your printer resolution, as well as access your printer setup.

If you have highlighted any text in the text editor, the option Selection will be available, 
which will allow you to print out only the highlighted text.    This is handy with large INI-files 
such as WIN.INI, where you may only want to print out a particular section, but not the whole
file.    If no text is highlighted in the text editor, the entire contents of the file will be printed 
(You can also print out the entire file even if you have highlighted some text.    Just choose 
the All option.).

Since INI-files do not contain formatted page breaks, the option Pages From... To... is not 
available.

Choose OK to send your print job to the Print Manager.



 Using the Menu Editor

The Menu Editor allows you to add up to four INI-files you work with most often to the 
menu.

Click on any item in the section of the dialog box shown here for an explanation of its 
function and use.



 Registration Information
Notes and info from the author

Dear Windows User,

Just a reminder that the *.INI-Navigator for Windows Version 3.1 is a shareware 
program.    It is not free software.    In keeping with the shareware concept, you are permitted
to use this program free of charge for an evaluation period of 21 days so that you can 
determine if the program suits your needs and is worth using over an extended period of 
time...the so called "try before you buy" principle.

If you find the program useful and wish to leave it installed on your computer after the 
evaluation period, you are required to register your copy.    Continued use of the software 
without registration is illegal.

The registration fee for the *.INI-Navigator 3.1 is US$15.00 (for those updating from the 
1.1, 2.0 or 2.01 versions, the update fee is $5.00; for those updating from the 3.0 version, 
the update is free).    Users who register will receive a registration number by mail (which will
eliminate the intro screen and enable all program functions), and will be entitled to updates 
of this program for only $5.00    They will immediately be notified by mail (or E-mail if the 
user prefers) as soon as the newest version becomes available.

Your registration fee and continued support are very important, as these enable me to 
continue to produce quality shareware from which everyone can benefit, at prices below 
those of conventionally marketed software.    I register all shareware I use on a regular basis, 
and I hope you will too.

Since it is shareware, this program may be freely copied and distributed without the author's
permission, provided the following conditions are fulfilled:

 All files contained on the distribution diskette (or if downloaded from a BBS, the file 
ININAV.ZIP) are distributed unaltered and in their entirety as a single unit.

 You may not distribute your *.INI-Navigator registration number or that portion of the 
WIN.INI file created by the *.INI-Navigator.

 The full machine-readable *.INI-Navigator documentation must be included with each copy.

How to register your copy

Your registration fee may be submitted in the following forms:
- personal check (US banks only)
- certified check
- Eurocheque
- money order
- postal money order
- international money order

You can also register using the CompuServe Shareware Registration Service - just type 
GO SWREG at any ! prompt and follow the menus.    The *.INI-Navigator's registration ID is 
911.



Send your registration fee with your name, address and version number you are registering 
to:

Daniel Di Bacco
Huttenstr. 12
8700 Würzburg
(after 30 June, 1993: 97072 Würzburg)
Germany

Please make your check or money order payable to the author.    You may also indicate if you
wish to be notified of other Windows shareware utilities and games available from the 
author.

To make registering less complicated, registration fees are also accepted in the following 
currencies: 

Country Registration Fee Update Fee
Canada $22.00 Canadian $9.00 Canadian
United Kingdom £10.00 £4.00
Germany DM 25.00 DM 10.00
Japan ¥2000 ¥800
Australia $25.00 Australian $10.00 Australian
All Others $15.00 US $5.00 US

Note: If you live in an EC country, the easiest method of payment is Eurocheque. Simply 
make the check payable in German Marks (DM 25.00).

I gladly welcome any questions, comments or suggestions regarding this program.    I also 
wish to thank those users who took the time to suggest improvements for this version.

You can contact me at the address above or via CompuServe (CIS ID: 100140,1156).

Thanks again for trying the *.INI-Navigator and keep on Windowing!

This program is also available in a German language version.    Write for information.

------------------------------------------------------

And now, the obilgatory legal stuff...

The *.INI-Navigator has been carefully programmed and thoroughly tested to ensure 
reliability and system stability when used.    However, the following applies:

Except as provided above, the author disclaims all warranties, either express or implied, 
including, but not    limited to, implied warranties of merchantability and fitness for a 
particular purpose with respect to the product.    Should the program prove defective, the 
user assumes the responsibility of paying all costs of any necessary servicing, repair, or 
correction as well as the risk of any incidental or consequential damages.    In no event will 
the author be liable for any damages whatsoever (including, without limitation, damages for 
loss of profits, business interruption, loss of data and the like) arising out of the use, misuse 
or the inability to use this product even if the author has been advised of the possibility of 
such damages.

Use of this product for any period of time constitutes your acceptance of this agreement and



subjects you to its contents.

Windows is a trademark of the Microsoft Corporation
CompuServe is a registered trademark of CompuServe Incorporated



 The File Menu

Related Topics: Restoring a File          Printing a File

Open
Loads the INI-file selected in the list box into the text editor.

Open External
Contains the following submenu:

Select...
Displays the Open External File dialog box which allows you to change the current
drive and/or directory to open an INI-file which is not located in the current working 
directory.    By default, the *.INI-Navigator starts in the Windows directory, since the 
most important files are located here.

If you have added any files to the menu using the Menu Editor, the files will 
appear in this submenu below the Select command and can be directly opened by 
choosing them from this menu.

Save
Saves any changes made to the file.    If you have set the option to create a backup in the 
Options   menu   or by using the option buttons in the program window, a copy of the file in
its previous state (i.e., before your modifications) will be created in the directory where 
the original INI-file is located.

Since a file can only be saved after its has been opened (logically), this menu command is
not available until a file has been loaded into the text editor.

Shortcut key: Ctrl+S

Delete
Deletes the INI-file from its directory.    If no file has been loaded into the text editor, the 
file highlighted in the INI-File list box is deleted.    Otherwise, the file loaded in the editor is
deleted.

Caution should be exercised when deleting INI-files, as Windows and many Windows 
applications rely on them to initialize and run properly.    Delete only those INI-files you are
certain are no longer needed (such as after deleting the parent application from your hard
drive). 

Important!: Under no circumstances should you delete the files WIN.INI or SYSTEM.INI.    
Strictly speaking, Windows can be started without the WIN.INI file, but the performance of
Windows is drastically reduced.    If you delete SYSTEM.INI, you can forget trying to start 
Windows at all.    Windows cannot be run without this file!    As a guard against 
unintentional deletion of necessary INI-files, the *.INI-Navigator will not allow you to 
delete WIN.INI or SYSTEM.INI.

Restore...
Opens the Restore INI-File window.    For a detailed description of the how to restore an 
INI-file, refer to the topic Restoring a File.

Print...



Opens the Print dialog box for printing out an INI-file.    Since an INI-file must first be 
loaded into the *.INI-Navigator before it can be printed, this menu command is not 
available until a file has been opened.    Refer to the topic Printing a File for more 
information.

Printer Setup...
Opens the Printer Setup dialog box.    Here, you can modify the various settings for any 
printers for which you have installed a Windows printer driver.

Windows Directory
Selecting this menu item automatically changes the current working directory back to the
Windows directory.    If you have not yet saved the changes to the file you have been 
editing, you will be asked if you wish to save them before switching directories.

If your current working directory is already the Windows directory, this menu item is not 
available.

Shortcut key: Ctrl+W

Exit
Closes the main program window and exits the *.INI-Navigator.    If you have not yet saved
your changes to file, you will be asked if you wish to do so before exiting.

Shortcut key: Alt+F4



 The Edit Menu
Related Topics: Editing a File          The Toolbar

Undo
Cancels the last keyboard input or Clipboard action.

Shortcut key: Ctrl+Z

Cut
Moves the highlighted text from the text editor window to the Clipboard.    The highlighted
text is deleted from the editor.

Shortcut key: Ctrl+X

Copy
Copies the highlighted text from the text editor to the Clipboard.

Shortcut key: Ctrl+C

Paste
Inserts the contents of the Clipboard into the text editor at the current cursor position.

Shortcut key: Ctrl+V

Delete
Deletes the highlighted text from the text editor.

Shortcut key: Del

Find...
Opens the Find window which allows the entry of search strings from the keyboard.    This
is handy if you know what entry or keyword you're looking for, but don't know in which 
particular section of the INI-file it is located.

Note: For convenience and ease of use, the Find window has been programmed to stay 
"on top" even when the window is inactive (much like the Windows Clock), so you can 
switch back and forth between it and the text editor without having to recall it repeatedly 
using the keyboard or menu.    This does not pose a problem within the *.INI-Navigator 
itself, but when switching tasks from the *.INI-Navigator to another application, the Find 
window could obstruct portions of the other application.    Therefore, it is recommended 
that you either minimize the *.INI-Navigator or close the Find window before switching to 
another application.

Shortcut key: F3

Sections
This menu item contains three submenu commands:

Refresh List
If you have manually deleted one or more sections from an INI-file using the text 
editor, it is possible that these sections still appear in the Sections list box.    
Choosing this command will rescan the file and refresh the list box.    Any sections
you have deleted in the text editor will be removed from the list.



Shortcut key: Ctrl+R

Select Section
If you want to copy the contents of an entire section to the Clipboard or if you 
only want to print out a particular section of an INI-file, this command makes it 
easy.    Just highlight the section you want in the Sections list box and then 
choose this command.    The entire section will be selected for you in the text 
editor.

This saves you the time of manually selecting the text by hand in the text editor 
using the mouse or the SHIFT and arrow keys (which can take some time if a 
section is particularly long).

Delete Section
This function is especially handy for cleaning up your WIN.INI.    As you've 
probably noticed by now, many Windows applications are notorious for adding 
entries to the WIN.INI, but when you delete or deinstall them from your drive, 
they don't take their WIN.INI sections with them.    This function allows you to 
delete an entire section at once from an INI-file.

Simply highlight the section you wish to delete in the Sections list box, and then 
choose this menu command.    After a confirmation, the whole section will be 
removed from the file.

Shortcut key: Ctrl+D



 The Options Menu
Related Topics: The Toolbar          Restoring a File          Using the Menu Editor

Toolbar
When this menu item is checked, the toolbar is displayed.    If you work primarily from the 
keyboard and don't use the mouse very often, you may wish to hide the toolbar by 
unchecking this menu item.    Hiding the toolbar will give you more workspace in the text 
editor window.

Backup
This menu item offers three options for backing up your INI-files after you've modified 
them:
Always

If this option is checked the *.INI-Navigator will automatically create a backup copy of 
the INI-file in its previous state (i.e. before your modifications) and place it in the same 
directory as its corresponding INI-file whenever you save your modifications to file.    A 
backup file has the same name as its INI-file counterpart, but carries the file extension
.NAV.    This backup can then be used to restore the file should your changes cause 
unwanted results.    It is recommended that you always backup the files WIN.INI and 
SYSTEM.INI if you modify them.

Prompt for Backup
This option allows you to decide if the INI-file you've modified should be backed up or 
not.

When you choose the Save command, a dialog box will appear and ask if you wish to 
save a backup copy of the file.    If you choose Yes, the backup will be saved to the 
directory where the INI-file is located.    If you choose No, no backup is created.    This 
way, backups of non-critical INI-files do not take up (in the Windows era, precious) disk 
space.    Of course, you may want to back up a non-critical INI-file for some reason - 
this option at least lets you decide. 

No Backup
This option does exactly what it says... it does not create a backup file at all.

It is not recommended that you use this setting unless you really need to conserve 
hard disk space or are 100% certain that your modifications will not negatively affect 
the performance of Windows or the corresponding application...Or...You may already 
have an existing backup file that you may not want to have overwritten (if this is the 
case, you're better off using the "Prompt for Backup" option).

Newcomers to Windows who are experimenting with INI-file modifications should not 
use this option. They are advised to use one of the two above options instead.

These options can also be selected using the option buttons found in the main program 
window.

Important: If you have modified your SYSTEM.INI and, as a result of these changes, you 
are unable to restart Windows, you can still manually restore the file from the DOS level 
by using the RENAME or COPY commands (provided a backup copy is available).

Examples:



To restore SYSTEM.INI while deleting the backup file, type at the DOS prompt
rename c:\windows\system.nav system.ini

To restore SYSTEM.INI while retaining the backup file, type
copy c:\windows\system.nav c:\windows\system.ini

Menu Editor...
Opens the Menu Editor dialog box which allows you to add the INI-files you work with 
most often to the File-Open External submenu.
For more information on adding files to the menu, refer to the topic Using the Menu 
Editor.



 The Help Menu

In addition to the Help commands, the following can be selected from the Help menu:

About...
Contains information about the application, such as the name of the program, its version 
number, author and copyright information.    Information as to the Windows version in use,
system configuration and free Windows resources are also displayed.



Open File
Loads the INI-file selected in the list box into the text editor.



Save File
Saves any changes made to the file.    If you have set the option to create a backup in the 
Options menu or by using the option buttons in the program window, a backup copy of 
the file in its previous state (i.e., before your modifications) will be created in the directory
where the original INI-file is located.



Delete File
Deletes the INI-file from the current directory.    If no file has been loaded into the text 
editor, the file highlighted in the INI-File list box is deleted.    Otherwise, the file currently 
loaded in the editor is deleted.

Caution should be exercised when deleting INI-files, as Windows and many Windows 
applications rely on them to initialize and run properly.    Delete only those INI-files you are
certain are no longer needed (such as after deleting the parent application from your hard
drive).    As a guard against unintentional deletion of necessary INI-Files, the *.INI-
Navigator will not allow you to delete WIN.INI or SYSTEM.INI.



Print File
Opens the Print dialog box for printing out an INI-file.    Refer to the topic Printing a File for 
more information.



Restore File
Opens the Restore INI-File window.    For a detailed description of the how to restore an 
INI-file, refer to the topic Restoring a File.



Cut
Moves the highlighted text from the text editor window to the Clipboard.    The highlighted
text is deleted from the editor.



Copy
Copies the highlighted text from the text editor to the Clipboard.



Paste
Inserts the contents of the Clipboard into the text editor at the current cursor position.



Undo
Cancels the last keyboard input or Clipboard action.



Find
Opens the Find window which allows the entry of search text from the keyboard.
See also: The Edit Menu



Sections Pop-Up Menu 
with the following commands:

Refresh List
If you have manually deleted one or more sections from an INI-file using the text 
editor, it is possible that these sections still appear in the Sections list box.    
Choosing this command will rescan the file and refresh the list box.    Any sections
you have deleted in the text editor will be removed from the list.

Select Section
If you want to copy the contents of an entire section to the Clipboard or if you 
only want to print out a particular section of an INI-file, this command makes it 
easy.    Just highlight the section you want in the Sections list box and then 
choose this command.    The entire section will be selected for you in the text 
editor.

Delete Section
This function allows you to delete an entire section at once from an INI-file.
Simply highlight the section you wish to delete in the Sections list box, and then 
choose this pop-up menu command.    After a confirmation, the whole section will 
be removed from the file.



INI-File
The Windows initialization files or "INI-files" are ANSI text files which contain important 
information used to initialize Windows and many Windows applications.    All INI-files carry 
the file name extension .INI and, in the majority of cases, are located in the Windows 
directory.

When Windows or a Windows application is started, the information contained in its INI-
file is read by the program (in some cases, several times) to configure itself before its 
loading is complete.

By modifying certain entries in INI-files, you can optimize the performance of Windows 
and Windows applications to best fit your hardware/software configuration or other 
requirements.



Section
All INI-files consist of one or more "sections" (technically referred to as "application 
names").    Every entry in an INI-file must be subordinate to a section.

The title of a section is always enclosed in square brackets "[    ]".



External INI-File
Any INI-file not located in the Windows directory.    Certain Windows applications create 
their INI-files in their own directory, instead of using the standard practice of saving them 
to the Windows directory.    The *.INI-Navigator also allows you to manage any external 
INI-files created by such applications.



INI-File(s)
Displays a list of the INI-files contained in the directory selected.
Use the Directories list in the upper portion of the Menu Editor (not shown here) to 
change to the directories where the files you wish to add to the menu are located.



Add to Menu
Adds the file selected in the INI-File(s) list on the left to the Files in Menu list on the 
right.    Up to four external INI-files can be added to the menu. 
(Of course, you are not limited to external INI-files, but since the *.INI-Navigator is 
designed for fast access to the Windows directory, you may want to reserve these menu 
positions for files outside the Windows directory).



Remove
Removes the selected file from the Files in Menu list.    Files removed from the list will no
longer appear in the menu.



Files in Menu
A list of the files you have selected to appear in the menu.    Adding files to the menu 
saves you the time of having to click your way through drives and directories to find and 
open them.



Cancel
Cancels any changes you have made in the Menu Editor and changes the dialog box 
back to the basic "Open External File" configuration.



Save Settings
Saves the menu configuration you have created using the Menu Editor.    These changes 
become effective immediately.    Selecting this button also changes the dialog box back to 
the basic "Open External File" configuration.    Clicking the Close button in the upper 
portion of the dialog box will return you to the main program window.



Help
Displays this help topic.






