
Wally Texture Editor for Quake II

Welcome to Wally v1.0, an editor for Quake II's .wal texture files.

The most up-to-date version of Wally and its FAQs can be found at
www.quake2.com/bdp/wally

Click the 'Contents' button at the top of this window to see the contents of this help file.
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Introduction

Wally is a program for the manipulation of Quake II .wal files.    It currently allows you to:-

- Load, view and save .wal files.
- Create new textures.
- Browse texture directories.
- Set content and surface flags in textures.
- Edit at a pixel level.
- Add various effects, such as bullet holes, scratches, and so on.
- Import and export PCX, BMP and Quake MIP files.
- Change the palette of a texture.
- Copy and paste to and from the Windows clipboard.
- Resample individual mips within a texture, using ReMip Deluxe.
- Drag-and-drop files into the Wally desktop.

Wally was conceived in order to allow Quake2 editors to bring custom textures into their levels with 
the maximum of ease, by avoiding the need to convert images between formats in image editing apps 
and eliminating awkward DOS-prompt programs for the creation of the actual .wal file. It also allows flags 
to be set in the .wal files defining light levels, transparency and other properties of the texture. Wally is, 
and always will be, freeware.



Version History
                0.7 (2/2/1998):
                          First public release of Wally

                0.8 (2/16/1998):
                          Added some cool stuff:
                                        - ClipBoard paste
                                        - PCX import
                                        - Support for JASC .pal files
                                        - Wally Options menu
                                        - Texture pop-up dialog
                                        - Persistent settings

                          And fixed others:
                          - Fixed texture flags
                                        - Fixed explorer-type launching

                0.81 (2/23/1998):
New/Improved:

                          - ReMipDeluxe has been implemented :)
                          - Added Paste As New Texture
                          - Added Drag-n-Drop support for Wally shortcut

                0.90 (3/14/1998):
 Bug Fixes:

- Draw Tiled
- Drawing coords bug when scrolled
- Drawing tools draw connected lines

New/Improved:
- Undo/Redo up to 50 items
- Paintbrush
- Eraser
- Darken
- Lighten
- Scratch
- Bullet Holes
- Brush width
- Brush shape
- Brush intensity
- Texture browsing
- 24bit BMP support
- 24bit clipboard pasting
- Quake1 MIP file support
- Changed File...Import to File...Convert
- View of all four sub-mips at once
- Improved drawing code
- Better drag-n-drop support to Wally icon/screen

                                
                1.00 (4/14/1998):

 Bug Fixes:
- Fixed always too dark scratch



- Fixed lighten/darken/tint tools after Edit...Paste

New/Improved:
- Flood fill
- Big cursor for drawing tools
- Constraining tool (vertical/horizontal)
- Pattern paint
- Added some tool widths (4, 6, and 8)
- Copy to clipboard, copy to clipboard tiled
- Mirror, flip, and rotate (left/right, 90-180-270 degrees)
- Three blend filters (light, medium, heavy)
- Spray paint tool
- Color palette tooblar
- Color replacer tool
- 24-bit PCX import
- Added export of BMP and PCX format
- Moved multiple options dialog boxes into one



Credits

Id Software... duh.

Team BDP for just being the best damn TC group on the planet.

To ADarcJedi, Ozric, and Talon:
"Thanks for putting up with my crap during our all-nighter ICQ meetings :)"

Thanks to Neal White III for coming aboard and straightening me out :)

Mosquito from Quake2.com, for painting the awesome splash screen and art.

Tom Cleghorn for doing up the Help file and tutorial stuff.

Q11 for beta testing and various bug reporting/enhancement suggestions.

Wally was written in Visual C++ by Ty Matthews <ty@wwa.com> and Neal White III
<nwhite@softblox.com>.

This help file was written by Tom Cleghorn <murgatroyd@geocities.com>
Remember: Caffeine is your Friend.

The beat goes on.



About ReMipDLX

ReMipDLX was written by Neal White III to resample .mip and .wad files for Quake 1. Since the 
texture data itself is the same in Q2, ReMipDLX was written into Wally to give maximum sub-mip quality - 
in most cases, textures resampled by ReMipDLX will turn out with better quality than id's textures; try 
ReMipping one of the textures from Q2 to see what we mean. If you prefer the look of id's textures, you 
can set ReMipDLX to create sub-mips of similar quality. If you don't, feel free to go through all the Q2 
textures and ReMip them all. Just bear in mind that there are over 2,000 of them :)

Using ReMipDLX

ReMipDLX Options



.WAL Files:
Quake II, unlike Quake, stores all its textures inside its .pak files in the form
of .wal files - a .wal file consists of four images, each half the size of the
previous, in order to be able to map textures at different resolutions depending
on the distance of the viewer.    See the topic Using .WAL Files for more information
on the use of .WALs.



ReMipDLX Options

This is the options dialogue for ReMipDLX, which you can access through the View menu.

The Dithering Method options control how ReMipDLX calculates the scaled-down mips. Error 
Diffusion is recommended. Experiment with    these settings if you are having problems with rogue pixels 
of the wrong colour.

The Sharpening options control the extent to which ReMipDLX sharpens the scaled-down mips. 
Again, experiment with the settings if your ReMipped textures look wrong.

The Use Recommended Settings button returns ReMipDLX settings to their defaults.

The Use Quake Lookalike Settings sets ReMipDLX to use settings which will give results similar to 
id's textures.

You can also set ReMipDLX to automatically operate when you save, when you paste or import, and 
when you have altered the main image with the check-boxes at the bottom. These are set to off by 
default.



Using ReMipDLX
There are three ways to ReMip a texture - you can simply press F11, you can choose ReMipDLX from

the Edit menu, or you can right-click with the pointer tool anywhere on the texture and choose ReMipDLX.
This will run ReMipDLX with your settings, and create or update the three sub-mips.



Using .WAL Files
This tutorial assumes that you have already created the .wal files you wish to use in your level; if not, 

you should read the tutorial on Creating a New Texture first. It would also be helpful to have some idea of 
how Quake2 reads the textures for its levels - the basics of this can be found in the Quake2 Technical 
Information section.

There are two ways to use a custom texture in your Quake2 levels; the easier way is to create a 
subdirectory of Quake2/baseq2 called textures, and place the appropriate .wal file in there, or in a 
subdirectory of it. If you are creating a large modification to Q2, or your mod uses a new game DLL, you 
will need to create a different subdirectory of baseq2/ and run Q2 with the command line "quake2 +set 
game <yourmodname>". All that is different here is that you create your textures directory within 
Quake2/yourmod/. If you use directories, your directory listing should look something like this:

In this example, ALL the custom .wal files would go into
the directory C:\Quake2\baseq2\textures\custom\

Alternatively, you can put your textures into a .pak file. To do this, you will need a .pak extracting 
program - there are plenty available for download on the Internet. This method would be more sensible if 
you intend to distribute several levels at once, as users can simply place the .pak file into their baseq2 
directory and play. Remember, however, that QRAD3 needs the textures OUTSIDE the .pak file in order 
to perform coloured lighting and radiosity when you compile your level.

Once the .wal files are in place, all you need to do is set up your editor to read the new texture 
directory and use it in your levels. Remember to distribute the .wal files with your level, or users will not 
see the new textures.



Wally Image Tools
Click on the icons below to read more about each tool. Most of them should be familiar

to you if you have used any standard paint programs. You can constrain the tools to either vertical
or horizontal movement by holding the Shift key as you draw; change between the two by pressing
the spacebar - the current constrain direction is displayed in the bottom right of the Wally window.

 Clicker tool.

 Tile image.

 Set flags.

 Zoom tool.

 Dropper tool.

 Pencil tool.

 Paintbrush tool.

 Eraser tool.

 Flood Fill.

 Spraycan Tool.

 Spraycan Recolour Tool.

 Replace Tool.

 Recolour Tool.

 Lighten tool.

 Darken tool.

 Tint tool.

 Pattern Paint.



 Scratch tool.

 Bullet Holes tool.

 ReMip.



Set Flags
This is the Texture Information dialogue:

Use this to set content and surface properties of a texture - this will
give the properties you set to any brush with the texture, unless you change

the settings in your level editor.

The options available are as follows:

Name - allows you to specify an internal name for the texture; it is best if the name matches the filename -
e.g, a custom texture in "\baseq2\textures\mymod\custom.wal" would be called "mymod/custom"

Width and Height - displays the dimensions of the texture.

Next Animation Texture - this allows you to specify a texture to follow the texture in an animation. Use 
the internal name of the texture, not the path to the file (i.e, "mymod/custom2" instead of "..\textures\
mymod\custom.wal").

Value (light) - when the 'light' flag is set, this number will be the intensity of the light given off by the 
texture.

Surface Property Flags:-

These flags affect only individual faces which have the texture.

      Light - Sets the texture to emit light, which is coloured to match the texture in GL mode.

Slick - Sets the texture to act like ice.



Sky - Sets the texture to plot the sky set for the level instead of the image in the .wal.

Warp - Sets the texture to shift and swirl like water, lava, and so on.

Trans33 and Trans66 - Sets the texture to be 33% or 66% translucent.

Flowing - Sets the texture to move. Used with rivers or conveyor belts.

NoDraw - The texture will not be drawn in the game.

Hint - The texture will be a hint brush. Do not use if you do not understand what these are :)

Skip - A face with this texture will be completely ignored by Q2.

Content Property Flags:-

These flags affect the entire brush to which the texture is applied.

Solid - Default for all brushes.

Window - Sets the brush to be a window.

Aux - Not used

Lava - The brush is lava.

Slime - The brush is slime.

Water - The brush is water.

Mist - The brush can be walked through.

AreaPortal - The brush will block VIS. Refer to your level editor manual.

PlayerClip - The player cannot walk through the brush, but other things can.

MonsterClip - Monsters cannot walk through the brush, but other things can.

Current 0/90/180/270/up/dn - Use with 'flowing' surface property to set the direction of flow.

Origin - Sets the brush to be an origin. Refer to your level editor manual.

Detail - The brush will not be included in the VIS process. Refer to your level editor manual.

Translucent - The brush allows light to pass through it.

Ladder - The brush is a ladder.

Most level editor manuals will go into far more detail about the surface attributes - this is intended as a 
basic guide, since it is more a level editing matter than a texture matter. You do not need to set these 
attributes in order to use them in your levels, as any settings in the map will override the flags in the .wal 
file - it is simply more convenient to have the flags already set when you build your level.



Tile Image
Click this to display the texture in a 3x3 array; this is useful for checking that a texture has no
visible 'seams' - that is, that the edges line up correctly when the texture is repeated.



Flood Fill
This replaces the colour of the area you click in with the
selected colour, up to any change in colour.



Zoom Tool
Sets the magnification factor of the texture - left-click zooms in, and right-click zooms out.



Clicker Tool
The clicker tool does not affect the image in any way - use it to turn off any editing tools, and 
right-click on the image with it to bring up the popup menu.



Dropper Tool
Click on any part of the texture with the Dropper to pick the colour of that part for use with
the drawing tools.



Pencil Tool
Use the Pencil to draw freehand onto the image.



Paintbrush Tool
Use the Paintbrush tool to paint onto the image in different shapes and thicknesses of
brush. You can change the thickness, shape and intensity of the brush from menus
accessed from these buttons on the colour palette:



Eraser Tool
Erases pixels to black.



Lighten
Use this tool to make the texture lighter.



Darken
Use this tool to make the texture darker.



Tint
This tool will tint the texture with the currently-selected colour. You can also set
the size, shape and intensity of the tint in the same way as the paintbrush.



Scratch
Draw freehand with this tool to simulate scratches on the surface of the texture.



Bullet Holes Tool
This tool simulates bullet holes on the surface of the texture. Left-click for a small hole,
and right-click for a larger one.



ReMip Button
Press this button to ReMip the texture on the basis of the largest mip.



Spraycan Tool
This applies paint to the texture in the selected colour to look
like a spraypaint or an airbrush has been used.



Pattern Paint
Use this tool to paint a hatched pattern using the two selected colours alternately,
similar to a safety hazard strip. Use the left button for narrow stripes and the right
for wide stripes. Hold 'F' to reverse the direction of the stripes.



Spraycan Recolour
Use this tool to spray paint in the same way as the spraycan tool, while
retaining the underlying features of the texture.



Replace Colour
Replaces the colour you click on with the selected colour.



Wally File Tools
Click on the icons below to read more about each tool.

 New

 Open

 Save

 Browse

 Convert Image

 Export Image

 Load Palette

 Wally Options

 Cut

 Copy

 Paste

 Undo

 Redo

 Show/Hide Colour Palette Toolbar

 About



New
Creates a new blank texture.



Open
Opens an existing .wal file.



Save
Saves the current texture.



Browse
Opens a dialogue to select a folder to browse for .wal files. The .wal files will be shown
in tiles in a separate window, from which you can open the files.



Convert Image
Loads an image in 8 or 24-bit BMP, 8-bit PCX or Quake 1 .mip format and converts
it to .wal format.



Load Palette
Loads a palette in Quake .lmp or JASC .pal format and converts the current texture to it.



Wally Options
Allows you to change Wally's settings. See the topic Wally Settings for more detail.



Export Image
Saves the current texture in Windows bitmap or
PCX format.



Show/Hide Colour Toolbar
Click this button to show or hide the Colour Palette Toolbar.



Cut, Copy, Paste
These are the standard Windows 95 clipboard operations, used to transfer information between
files.



Undo, Redo
Click undo to return an image to its previous state, from before you applied the last
change to it. You can undo an undo operation by clicking redo.



About
Displays a little window telling you all about Wally. Click it again, just to see our names - 
what fun!



Recolour Tool
Paints the texture with the selected colour, but retains the underlying
features of the texture, as though the paint was transparent.



Wally Settings
These are the settings which can be changed for Wally:

Wally Options

ReMipDLX Options



Wally Options
This is the Wally Options dialogue, accessed through the View menu or by clicking

the button on the toolbar:

You can change the following settings:

Default Zoom Value
This is the magnification which a texture will be opened at and at
which Wally will be set when you start.

Default New Texture Size
A new texture will be created at the dimensions you set here.
All textures must have dimensions which are multiples of 16.

Retain previous texture width/height
Check this box to tell Wally to retain old settings.

Palette Conversion
You can change the way Wally resamples the image when you load

a new palette. Experiment with the settings if you are getting
weird results.



Colour Palette Toolbar
This is Wally's colour selection toolbar:

Click with the left button to set the colour to be painted with the left button
and click with the right button to set the colour to be painted with the right mouse button.
The three menus at the bottom are used to set the thickness, shape and
intensity of the selected painting tool. The selected colours are previewed in the 
two boxes in the middle; the box in the background is the right-button colour and the
one in the foreground is the left-button colour.



File Menu

The commands available from the File menu are:

New (Ctrl+N)

Creates a new texture. You can specify the name of the texture and its dimensions, which must be 
multiples of 16.

Open (Ctrl+O)

Opens a .wal format texture.

Browse (Ctrl+B)

Allows you to bring up a window showing previews of all the .wal files in a directory. You can open 
files by double-clicking on the preview tile in the browse window.

Close
Closes the currently active texture.

Save (Ctrl+S)

Saves the currently active texture.

Save As

Saves the currently active texture to a specific filename.

Convert...

Imports an image in PCX, Windows bitmap or Quake 1 .mip format, converting it to .wal format.

Load Palette (Ctrl+P)

Loads a palette from disk in either Quake .lmp format or JASC .pal format (as exported from 
PaintShop Pro) and converts the image to it.

Exit

Quits Wally. Duh.

You can also open textures from the history list at the bottom of the File menu.



View Menu

The commands available in the View menu are:

Toolbar

Shows or hides the toolbar.

Tool Palette

Shows or hides the tool palette.

Status Bar

Shows or hides the status bar at the bottom.

Tiled (Ctrl+T)

Toggles the texture window between tiled and untiled - when the window is tiled, it displays nine 
copies of the texture arranged in a square, allowing you to see what the texture will look like when applied
to a large brush.

Options...
ReMipDLX Options...
Tool Options...

See the topic Wally Options.



Edit Menu

The commands available from the Edit menu are:

Undo (Ctrl+Z)

Reverts the image to its state before the last action you carried out on it.

Redo (Ctrl+Y)

Returns an image to its state after an action that has been undone.

Cut (Ctrl+X), Copy (Ctrl+C), Paste (Ctrl+V/E)

Standard Windows clipboard functionality - you can paste the contents of the clipboard either as a 
new texture or into the currently active texture.

Clear (Del)

Scrubs mip 1 of the texture (the largest panel) to black.

ReMip (F11)
See the topic on ReMip Deluxe.

Texture Properties... (F12)

Displays the Texture Properties dialogue, allowing you to change the surface properties of a texture.



Image Menu
The commands available from the Image menu are:

Blend

Softens the image, blurring it slightly. This is useful when the edges of a seamless texture
do not quite line up properly. You can choose between light, medium or heavy blending.

Mirror (Ctrl+M)

Flips the image in its X-axis (left-right).

Flip (Ctrl+L)

Flips the image in its Y-axis (top-bottom).

Rotate (Ctrl+R)

Displays the Rotate Image dialogue, from which you can rotate the image by 90, 180 or
270 degrees clockwise or anticlockwise.



Creating a New Texture with Wally
This is a relatively simple procedure, requiring very little technical expertise; if done correctly, you can 

produce great-looking results. There are two ways to do it: the quicker way is to draw everything within 
Wally, and the slower, but better, way is to import an image or photograph from another paint app and use
Wally to convert it to a Quake2 texture. For this tutorial, which will show you how to create a cliff texture 
from a photograph, we will take the longer route. It is assumed that you are capable of basic use of your 
paint app.

1. Find the photo you want to use (or take it, if you have a digital camera, you flashy show-off, you :) 
and load it into your paint app. Make sure that both dimensions are multiples of 16 (16, 32, 48, 64, 80 
etc...), or Wally will not load it - Quake2 requires that ALL textures are divisible by 16 in both dimensions. 
Save it as a 24-bit .bmp image.

2. Start Wally, and click on the Convert Image button - . Use the file selection dialogue to find and 
open your bmp file. Wally will load the image and convert it to the Quake2 palette, and create the three 
sub-mips. Click the ReMip button - 

 - to resample the image and create the sub-mip images.

3. Your texture should now look something like this:

4. Click on the Tile Image button -  - and you will probably notice that your texture does not mesh 
properly at the seams - you can see the edge of each tile, something like this:



5. Staying in Tiled mode, use a combination of the Blend filters (from the Image Menu) and straight 
painting to remove the seams from the texture.

6. Save the texture as a .wal file into your custom .wal directory below ..\baseq2\textures\ and make 
sure you have set the Flags for the texture name.




